SQL Server 安裝程式文件集的概觀

[image]

SQL Server 安裝程式文件集的概觀
傳送回函

您可以在安裝媒體上取得 SQL Server 安裝程式的文件集，也可以透過線上方式取得。

在安裝期間提供的文件集

在安裝 SQL Server 期間，按一下 [安裝精靈] 頁面上的 [說明] 按鈕或按下鍵盤上的 F1，即可取得完成作業所需的立即資訊。

SQL Server 安裝主題的概觀

不論您是使用 SQL Server 安裝精靈或命令提示字元來安裝 SQL Server，都可以閱讀下列章節來進行準備：

  • 規劃 SQL Server 安裝。

    描述如何準備進行 SQL Server 安裝。

  • 安裝 SQL Server 2012

    描述安裝 SQL Server 的選項。

  • 安裝 SQL Server 2012 BI 功能

    描述安裝屬於 Microsoft BI 平台之 SQL Server 功能 (包括 Analysis Services、Integration Services、Reporting Services 及數種用於建立及使用分析資料的用戶端應用程式) 的選項。

  • 升級為 SQL Server 2012

    描述升級至 SQL Server 的選項

如果您要安裝 SQL Server 容錯移轉叢集，請檢閱下列章節：

  • SQL Server 容錯移轉叢集使用者入門。

  • 安裝容錯移轉叢集之前。

將意見反應提供給 Microsoft

© 2012 Microsoft Corporation. 著作權所有，並保留一切權利。


關於 SQL Server 授權條款

[image]

關於 SQL Server 授權條款
請參閱 傳送回函

在安裝 SQL Server 時，Microsoft 軟體授權條款會複製到本機電腦。 如果在同一部電腦上安裝了相同 SQL Server 版本和語言的多個執行個體，一份授權條款便可適用於該版本和語言的所有執行個體。 這些檔案會寫入至：%ProgramFiles%\Microsoft SQL Server\110\License Terms\ or %ProgramFiles(x86)%\Microsoft SQL Server\110\License Terms\。

如果在同一部電腦上安裝了相同 SQL Server 版本和語言的多個執行個體，一份授權條款便可適用於該版本和語言的所有執行個體。

授權條款檔案名稱會指示 SQL Server 的版本以及 SQL Server 語言版本。 例如：

  • SQL Server Developer (英文版) 適用的 License_DEV_ENU.txt。

  • SQL Server Standard (義大利文版) 適用的 License_STD_ITA.txt。

  • SQL Server Upgrade Advisor (日文版) 適用的 License_UA_JPN.txt。

  • SQL Server Native Client (英文版) 適用的 License_SQLNCLI_ENU.txt。

  • SQLXML (韓文版) 適用的 License_SQLXML4_KOR.txt。

  • SQL Server Business Intelligence Edition 適用的 License_SQLBI.rtf。

  • SQL Server Enterprise 版: 核心授權適用的 License_ENTCORE.rtf。

  • SQL Server Enterprise 版 Server/CAL 授權適用的 License_ENT.rtf。

下列檔案名稱區段可用來識別 SQL Server 版本：

  • ENT - Enterprise 版: Server/Client Access License (CAL) 授權

  • ENTCORE - Enterprise 版: 核心授權

  • BI - Business Intelligence

  • DEV - Developer

  • STD - Standard

  • WEB - Web

  • EXPR - Express

下列檔案名稱區段可用來識別對應的 SQL Server 語言：

  • ENU - 英文

  • JPN - 日文

  • FRA - 法文

  • ITA - 義大利文

  • KOR - 韓文

  • DEU - 德文

  • ESN - 西班牙文

  • CHS - 簡體中文

  • CHT - 繁體中文

  • PTB - 巴西葡萄牙文

  • RUS - 俄文

SQL Server 授權選項

如需有關 SQL Server 計價和授權選項的詳細資訊，請參閱 Microsoft SQL Server (http://go.microsoft.com/fwlink/?LinkId=190955) 網站。

請參閱

概念

SQL Server 的授權考量
Microsoft SQL Server 隱私權聲明
文件集的法律注意事項


SQL Server 的授權考量

[image]

SQL Server 的授權考量
請參閱 傳送回函

如需有關 SQL Server 授權選項的詳細資訊，請參閱這個 Microsoft SQL Server 網站。

請參閱

參考

關於 SQL Server 授權條款

概念

Microsoft SQL Server 隱私權聲明
文件集的法律注意事項


文件集的法律注意事項

[image]

文件集的法律注意事項
傳送回函

本文件是以原本的形式提供， 本文件中所表達的資訊和觀點，包括 URL 及其他網際網路網站參考資料，如有變更恕不另行通知。 您應自行承擔使用本文件的風險。

此處描述的部分範例僅供說明使用，純屬虛構， 並無意圖亦不應將其影射為任何實際關聯或連接。

本文件不會為您提供任何 Microsoft 產品的任何智慧財產權的任何法律權限。 您可以在內部為了參考用途來複製及使用本文件。

© 2012 Microsoft. 著作權所有，並保留一切權利.

Microsoft, Active Directory, ActiveX, Bing Maps, Excel, IntelliSense, MSDN, MS-DOS, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual Studio, Windows, Windows NT, Windows Server 及 Windows Vista 是 Microsoft 集團的商標。 SAP NetWeaver 是 SAP AG 在德國和其他一些國家 (地區) 的註冊商標。 其他所有的商標為各擁有人所有之財產。

SQL Server 支援及升級的文件集原則

Microsoft SQL Server 2012 軟體文件集包括《Microsoft Microsoft SQL Server 2012 線上叢書》、安裝文件集、開發人員參考文件集、教學課程、讀我檔案、已知問題文件、範例程式碼、範例資料庫以及 Microsoft 所發行的知識庫文件，這些全都包含有關 SQL Server 特性與功能的內容。 此支援和升級原則適用於 Microsoft SQL Server 2012 文件集，包括 Microsoft SQL Server 2012 版本及 Service Pack 的讀我檔案；讀我檔案可視為《Microsoft SQL Server 2012 線上叢書》的延伸部分。

本文件內所含範例的主要目的在於闡釋某個概念，或說明特定陳述式或子句的合理使用。 多數範例並不包含通常可在完整生產系統中找到的所有程式碼，因為已將某些一般資料驗證及錯誤處理部分移除，以將焦點放在範例中的特定概念或陳述上。 這些範例或其中包含的任何原始程式碼並不包含於技術支援的服務範圍之內。

在某些情況下，Microsoft SQL Server 2012 中的特定功能未經過充分的測試或開發，所以不打算提供給您使用。 這類功能通常會當做預留位置； 因此，軟體中包含的某些功能不會記載於文件集中。 未記載的功能或是有註明僅供 Microsoft 內部使用的功能將不提供給您使用，也不會受到 Microsoft 客戶支援服務的支援。 除非 Microsoft SQL Server 2012 文件集另外註明，否則協力廠商內容 (包括搭配 Microsoft SQL Server 2012 使用這類協力廠商內容所產生的問題) 將不會受到 Microsoft 客戶支援服務的支援，而且也可能造成資料遺失。 Microsoft 客戶支援服務也不支援利用或使用未記載之進入點 (如未記載的 API) 的資料庫或應用程式，其中包括但不限於：預存程序、擴充預存程序、函數、檢視、資料表、資料行、屬性或中繼資料。

升級至 Microsoft SQL Server 2012 未來版本的伺服器或資料庫，對於利用及使用未記載之進入點的應用程式或資料庫可能不適用，而且也不受支援。 當您使用 Microsoft SQL Server 2012 文件集中未記載之 Microsoft SQL Server 包含的 SQL Server 特性與功能時，將不會受到支援，這樣的使用也可能造成資料遺失。


Microsoft SQL Server 隱私權聲明

[image]

Microsoft SQL Server 隱私權聲明
傳送回函

如需有關 Microsoft SQL Server 2012 中使用者資料收集元件的詳細資訊，請參閱 SQL Server 隱私權聲明。


SQL Server 的預設和具名執行個體的檔案位置

[image]

SQL Server 的預設和具名執行個體的檔案位置
請參閱 傳送回函

SQL Server 的安裝是由一個或多個不同的執行個體所組成。 不論是預設或具名，執行個體都有自己的一組程式和資料檔，以及在電腦上所有 SQL Server 執行個體之間共用的一組共同檔案。

如果 SQL Server 執行個體包括 Database Engine、Analysis Services 和 Reporting Services，則每一個元件都有一組完整的資料檔和可執行檔，以及所有元件共用的共同檔案。

為了隔離每一個元件的安裝位置，會針對給定的 SQL Server 執行個體內的每一個元件產生唯一的執行個體識別碼。

重要事項 重要事項

程式檔和資料檔不能安裝在抽取式磁碟機以及使用壓縮的檔案系統上、不能安裝在系統檔案所在的目錄中，也不能安裝在容錯移轉叢集執行個體上的共用磁碟機。

請勿刪除下列任何一個目錄或是其內容：Binn、Data、Ftdata、HTML 或 1033。 必要時，您可以刪除其他目錄。不過，如果您沒有解除安裝後再重新安裝 SQL Server 的話，可能會無法擷取任何遺失的功能或資料。 請勿刪除或修改 HTML 目錄中的任何 .htm 檔。 這些檔案是 SQL Server 工具得以正常運作所不可或缺的要素。

所有 SQL Server 執行個體的共用檔案

單一電腦上所有執行個體使用的共用檔案都會安裝在 <drive>:\Program Files\Microsoft SQL Server\110\ 資料夾中，其中 <drive> 是要安裝元件的磁碟機代號。 預設值通常是磁碟機 C。

檔案位置和登錄對應

在 SQL Server 安裝期間，系統會為每一個伺服器元件產生一個執行個體識別碼。 這個 SQL Server 版本中的伺服器元件是 Database Engine、Analysis Services 和 Reporting Services。

預設執行個體識別碼是使用以下格式建構的：

  • Database Engine 的 MSSQL，後面接著主要版本號碼、底線、次要版本 (如果適用的話) 和句點，再接著執行個體名稱。

  • Analysis Services 的 MSAS，後面接著主要版本號碼、底線、次要版本 (如果適用的話) 和句點，再接著執行個體名稱。

  • Reporting Services 的 MSRS，後面接著主要版本號碼、底線、次要版本 (如果適用的話) 和句點，再接著執行個體名稱。

此 Microsoft SQL Server 2012 版本中的預設執行個體識別碼範例如下：

  • MSSQL11.MSSQLSERVER 代表 Microsoft SQL Server 2012 預設執行個體。

  • MSAS11.MSSQLSERVER 代表 Analysis Services 預設執行個體。

  • MSSQL11.MyInstance 代表名為 "MyInstance" 的 Microsoft SQL Server 2012 具名執行個體。

包含 Database Engine 和 Analysis Services 而且已安裝到預設目錄之 Microsoft SQL Server 2012 具名執行個體 "MyInstance" 的目錄結構將會如下所示：

  • C:\Program Files\Microsoft SQL Server\MSSQL11.MyInstance\

  • C:\Program Files\Microsoft SQL Server\MSASSQL11.MyInstance\

您可以為執行個體識別碼指定任何值，但是請避免特殊字元和保留關鍵字。 如需詳細資訊，請參閱＜Reserved Keywords (Setup)＞。

您可以在 SQL Server 安裝期間指定非預設的執行個體識別碼。 如果使用者選擇變更預設安裝目錄，則可以不要使用 <Program Files>\Microsoft SQL Server，而改用 <自訂路徑>\Microsoft SQL Server。 請注意，不支援以底線 (_) 為開頭或是包含數字符號 (#) 或貨幣符號 ($) 的執行個體識別碼。

附註 附註

Integration Services 和用戶端元件都不會感知執行個體，因此，也不會被指派執行個體識別碼。 根據預設，不會感知執行個體的元件會安裝至單一目錄：<磁碟機>:\Program Files\Microsoft SQL Server\110\。 變更某個共用元件的安裝路徑也會變更其他共用元件的安裝路徑。 後續安裝會將非執行個體感知的元件安裝到與原始安裝相同的目錄。

SQL Server Analysis Services 是安裝之後支援執行個體重新命名的唯一 SQL Server 元件。 如果 Analysis Services 的執行個體已重新命名，執行個體識別碼將不會變更。 當執行個體重新命名完成之後，目錄和登錄機碼將會繼續使用安裝期間所建立的執行個體識別碼。

對於執行個體感知元件，會在 HKLM\Software\Microsoft\Microsoft SQL Server\<Instance_ID> 之下建立登錄區。 例如，

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL11.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSASSQL11.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.110

登錄也會維護執行個體識別碼到執行個體名稱的對應。 執行個體識別碼到執行個體名稱的對應維護如下：

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\SQL] "InstanceName"="MSSQL11"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\OLAP] "InstanceName"="MSASSQL11"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\RS] "InstanceName"="MSRSSQL11"

指定檔案路徑

在安裝期間，您可以變更下列功能的安裝路徑：

只有具有使用者可設定目的資料夾的功能，其安裝路徑才會顯示在安裝程式中：

元件 | 預設路徑1, 2 | 可設定 3 或固定路徑
Database Engine 伺服器元件 | \Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\ | 可設定
Database Engine 資料檔 | \Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\ | 可設定
Analysis Services 伺服器 | \Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\ | 可設定
Analysis Services 資料檔 | \Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\ | 可設定
Reporting Services 報表伺服器 | \Program Files\Microsoft SQL Server\MSRS11.<InstanceID>\Reporting Services\ReportServer\Bin\ | 可設定
Reporting Services 報表管理員 | \Program Files\Microsoft SQL Server\MSRS11.<InstanceID>\Reporting Services\ReportManager\ | 固定路徑
Integration Services | <安裝目錄>\110\DTS\ | 可設定4
Master Data Services | <安裝目錄>\110\Master Data Services | 可設定4
用戶端元件 | <安裝目錄>\110\Tools\ | 可設定4
複寫和伺服器端 COM 物件 | <磁碟機>:\Program Files\Microsoft SQL Server\110\COM\5 | 固定路徑
資料轉換執行階段引擎的 Integration Services 元件 DLL、資料轉換管線引擎和 dtexec 命令提示字元公用程式 | <磁碟機>:\Program Files\Microsoft SQL Server\110\DTS\Binn | 固定路徑
對 Integration Services 提供 Managed 連接支援的 DLL | <磁碟機>:\Program Files\Microsoft SQL Server\110\DTS\Connections | 固定路徑
Integration Services 支援的每一種類型之列舉值的 DLL | <磁碟機>:\Program Files\Microsoft SQL Server\110\DTS\ForEachEnumerators | 固定路徑
SQL Server Browser 服務，WMI 提供者 | <磁碟機>:\Program Files\Microsoft SQL Server\110\Shared\ | 固定路徑
SQL Server 的所有執行個體之間共用的元件 | <磁碟機>:\Program Files\Microsoft SQL Server\110\Shared\ | 固定路徑

1請確定 \Program Files\Microsoft SQL Server\ 資料夾受到有限權限的保護。

2這些位置的預設磁碟機是 systemdrive，通常是磁碟機 C。

3子功能的安裝路徑由父功能的安裝路徑來決定。

4在 Integration Services 和用戶端元件之間共用單一安裝路徑。 變更一個元件的安裝路徑也會變更其他元件的安裝路徑。 後續安裝會將元件安裝到與原始安裝相同的位置。

5這個目錄供電腦上 SQL Server 的所有執行個體使用。 如果您將更新項目套用至電腦的任何執行個體，則此資料夾之檔案若有任何變更，電腦上所有執行個體都會受到影響。 將功能加入現有的安裝時，您不能變更先前安裝之功能的位置，也不能指定新功能的位置。 您必須將其他功能安裝到安裝程式所建立的目錄中，或解除安裝後再重新安裝本產品。

附註 附註

如果是叢集組態，您必須選取該叢集的每一個節點上可用的本機磁碟機。

當您在安裝期間指定伺服器元件或資料檔的安裝路徑時，除了程式和資料檔的指定位置之外，安裝程式還會使用執行個體識別碼。 安裝程式不會使用工具和其他共用檔案的執行個體識別碼。 安裝程式也不會使用 Analysis Services 程式和資料檔的任何執行個體識別碼，但是它會使用 Analysis Services 儲存機制的執行個體識別碼。

如果您設定了 Database Engine 功能的安裝路徑，SQL Server 安裝程式會使用該路徑做為該安裝作業之所有執行個體特定資料夾的根目錄，包括 SQL 資料檔在內。 在這個情況下，如果您將根目錄設定為 "C:\Program Files\Microsoft SQL Server\MSSQL11\MSSQL\"，則執行個體特定目錄會加入該路徑的結尾。

選擇在 SQL Server 安裝精靈 (安裝程式 UI 模式) 中使用 USESYSDB 升級功能的客戶，很容易讓自己進入這樣的情況：產品會安裝到遞迴的資料夾結構。 例如 <SQLProgramFiles>\MSSQL11\MSSQL\MSSQL11\MSSQL\Data\。 若要改用 USESYSDB 功能，請設定 SQL 資料檔功能 (而非 Database Engine 功能) 的安裝路徑。

附註 附註

您應該可以在 Data 子目錄中找到資料檔。 例如，在升級期間，若在 C:\Program Files\Microsoft SQL Server\MSSQL11\MSSQL\Data 下找到資料檔，請指定 C:\Program Files\Microsoft SQL Server\MSSQL11\，將根路徑指定為系統資料庫的資料目錄。

請參閱

參考

Database Engine 組態 - 資料目錄
Analysis Services 組態 - 資料目錄


檢視與讀取 SQL Server 安裝程式記錄檔

[image]

檢視與讀取 SQL Server 安裝程式記錄檔
請參閱 傳送回函

每次執行安裝程式時，記錄檔都會與新時間戳記的記錄檔資料夾 (位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\) 一起建立。 時間戳記記錄檔資料夾的名稱格式為 YYYYMMDD_hhmmss。 在自動安裝模式下執行安裝程式時，會在 % temp%\sqlsetup*.log 建立記錄檔。 記錄檔資料夾中的所有檔案都會封存到個別記錄檔資料夾的 Log*.cab 檔中。

典型的安裝程式要求會經過三個執行階段：

  1. 全域規則文字

  2. 元件更新

  3. 使用者要求的動作

在每個階段，安裝程式都會產生詳細和摘要的記錄檔，並且會依需要建立其他的記錄檔。 每個使用者要求的安裝程式動作都會至少呼叫安裝程式三次。

資料存放區檔案包含安裝程序所追蹤的所有組態物件的狀態快照，對於疑難排解組態錯誤很有用。 XML 檔案傾印會針對每個執行階段為資料存放區物件而建立。 這些會儲存在本身的記錄子資料夾的時間戳記記錄檔資料夾下方，如下所示：

  • Datastore_GlobalRules

  • Datastore_ComponentUpdated

  • Datastore

下列各節描述 SQL Server 安裝程式記錄檔。

摘要文字

概觀

此檔案會顯示安裝期間偵測到的 SQL Server 元件、作業系統環境、命令列參數值 (如果有指定)，以及已執行之每個 MSI/MSP 的整體狀態。

記錄檔組織成下列各區段：

  • 執行的整體摘要

  • 執行 SQL Server 安裝程式所在電腦的屬性和組態

  • 先前安裝在電腦上的 SQL Server 產品功能

  • 安裝版本與安裝套件屬性的描述

  • 安裝期間提供的執行階段輸入設定

  • 組態檔的位置

  • 執行結果的詳細資料

  • 全域規則

  • 安裝狀況專屬的規則

  • 失敗的規則

  • 規則報表檔案的位置

位置

這個檔案位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\。

若要尋找摘要文字檔中的錯誤，使用 "error" 或 "failed" 等關鍵字搜尋檔案。

Summary_engine-base_YYYYMMDD_HHMMss.txt

概觀

summary_engine base 檔案與摘要檔案類似，而且是在主要工作流程期間產生的。

位置

這個檔案位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

Summary_engine-base_YYYYMMDD_HHMMss_ComponentUpdate.txt

概觀

元件更新摘要記錄檔與摘要檔案類似，而且是在元件更新工作流程期間產生的。

位置

這個檔案位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

Summary_engine-base_<VersionNumber>MMDD_HHMMss_GlobalRules.txt

概觀

全域規則摘要記錄檔與摘要檔案類似，而且是在全域規則工作流程期間產生的。

位置

這個檔案位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

Detail.txt

概觀

安裝或升級之類的主要工作流程會產生 Detail.txt，並提供執行的詳細資料。 針對安裝叫用每個動作時，檔案中的記錄會隨著時間而產生，並顯示執行動作的順序及其相依性。

位置

這個檔案位於 %programfiles%\Microsoft SQL Server\110\Setup

Bootstrap\Log\<YYYYMMDD_HHMM>\Detail.txt。

如果在安裝程序期間發生錯誤，就會在此檔案的結尾記錄異常狀況或錯誤。 若要尋找此檔案中的錯誤，請先檢查檔案的結尾，然後再搜尋檔案中的 "error" 或 "exception" 等關鍵字。

Detail_ComponentUpdate.txt

概觀

元件更新工作流程會產生 Detail_ComponentUpdate.txt 檔，而且與 Detail.txt 類似。

位置

這個檔案位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

Detail_GlobalRules.txt

概觀

全域規則執行會產生 Detail_GlobalRules.txt，而且與 Detail.txt 類似。

位置

這個檔案位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

MSI 記錄檔

概觀

MSI 記錄檔會提供安裝套件程序的詳細資料。 在指定之套件的安裝期間，MSIEXEC 會產生這些記錄檔。

MSI 記錄檔的類型：

  • <Feature>_<Architecture>_<Interation>.log

  • <Feature>_<Architecture>_<Language>_<Interation>.log

  • <Feature>_<Architecture>_<Interation>_<workflow>.log

位置

MSI 記錄檔位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\<Name>.log。

檔案的結尾是執行的摘要，其中包含成功或失敗狀態以及屬性。 若要尋找 MSI 檔中的錯誤，請搜尋 "value 3"，通常就可以在該字串的附近找到錯誤。

ConfigurationFile.ini

概觀

組態檔包含安裝期間提供的輸入設定。 該檔案可以用來重新啟動安裝，而不必手動輸入設定。 不過，帳號的密碼、PID 與某些參數不會儲存在組態檔中。 這些設定可以加入至檔案，或者使用命令列或安裝程式使用者介面提供。 如需詳細資訊，請參閱＜使用組態檔安裝 SQL Server 2012＞(http://go.microsoft.com/fwlink/?LinkId=231296)。

位置

這個檔案位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

SystemConfigurationCheck_Report.htm

概觀

系統組態檢查報告包含每個已執行規則以及執行狀態的簡短描述。

位置

這個檔案位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

請參閱

概念

SQL Server 安裝的疑難排解


SQL Server 安裝的疑難排解

[image]

SQL Server 安裝的疑難排解
請參閱 傳送回函

若要檢視有關安裝和升級問題的疑難排解資訊，請參閱 SQL Server 2012 讀我檔案 (http://go.microsoft.com/fwlink/?LinkId=196910)。

請參閱

概念

檢視與讀取 SQL Server 安裝程式記錄檔


SQL Server 安裝程式使用者介面參考

[image]

SQL Server 安裝程式使用者介面參考
傳送回函

本節描述 SQL Server 安裝精靈所顯示的安裝選項。


接受授權條款

[image]

接受授權條款
請參閱 傳送回函

請使用 SQL Server 安裝精靈的 [接受授權條款] 頁面來接受此版 SQL Server 的授權條款。

您可以列印授權合約，或將它複製到剪貼簿。 若要繼續，請接受授權條款，然後按一下 [下一步]。 若要結束安裝，請按一下 [取消]。

功能使用方式報表

如果您啟用功能使用方式報表，SQL Server 就會設定為定期傳送報表至 Microsoft。 報表包含硬體組態及您如何使用 SQL Server 和元件的相關資訊。 Microsoft 將會使用功能使用方式資料來改進 SQL Server。 這項功能所監視的 SQL Server 元件包括：

  • Database Engine

  • Analysis Services

  • Reporting Services

  • Integration Services

  • 複寫

  • SQL Server Data Tools (SSDT)

  • SQL Server 安裝程式

關於功能使用方式的資訊會傳送到 Microsoft (以限制存取的方式予以儲存)。

若要在安裝程式完成之後停用功能使用方式報表，請使用 SQL Server [組態工具] 功能表中的 [SQL Server 錯誤和使用方式報表] 工具。

對於安裝、升級、修復等等的安裝程式動作，僅會在執行安裝程式期間，收集並上傳資訊。

對於其他所有 SQL Server 元件，則會每天針對所有啟用的 SQL Server 執行個體，收集一次資訊。 根據預設，收集的時間為午夜，好讓伺服器的負載減至最小。 如果您想要變更收集的時間，可手動編輯控制收集時間的登錄機碼。 每個 SQL Server 執行個體都擁有自己的登錄機碼：

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL11.<INSTANCEID>\CPE\TimeofReporting

這個登錄機碼的值包含從 00:00 (午夜) 開始執行之收集時間的分鐘數。 例如，60 這個值會在 1:00 a.m. 執行收集，1200 這個值會在 8:00 p.m. 執行收集，以此類推。

請參閱

參考

關於 SQL Server 授權條款


加入 SQL Server 容錯移轉叢集節點

[image]

加入 SQL Server 容錯移轉叢集節點
請參閱 傳送回函

在 SQL Server 安裝程式的作業完成之前，此安裝程式會驗證您的電腦組態。 在 SQL Server 安裝期間，System Configuration Checker (SCC) 會掃描將安裝 SQL Server 的電腦。 SCC 會檢查是否有任何狀況阻止 SQL Server 安裝作業成功。 在安裝程式啟動 SQL Server 安裝精靈以前，SCC 會擷取每一個項目的狀態。 然後它會比較所需條件的結果，並提供解決封鎖問題的指引。

系統組態檢查會產生報告，其中包含每個已執行規則以及執行狀態的簡短描述。 系統組態檢查報告位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

執行安裝作業之前，請檢閱下列主題：

  1. 安裝 SQL Server 的硬體和軟體需求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各版本支援的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server 安裝的安全性考量(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的地區語言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他參考資料：

  1. 支援的版本與版本升級(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安裝容錯移轉叢集之前(http://go.microsoft.com/fwlink/?LinkId=235034)

請參閱

參考

安裝程式支援檔案


Analysis Services 組態 - 帳戶提供

[image]

Analysis Services 組態 - 帳戶提供
請參閱 傳送回函

此用此頁面可以設定伺服器模式，以及將管理權限授與需要無限制存取 Analysis Services 的使用者或服務。 安裝程式不會自動將本機 Windows 群組 BUILTIN\Administrators 加入至您所安裝之執行個體的 Analysis Services 伺服器管理員角色。 如果您想要將本機 Administrators 群組加入至伺服器管理員角色，就必須明確指定該群組。

如果您要安裝 PowerPivot for SharePoint，請務必將管理權限授與負責在 SharePoint Server 2010 伺服陣列中進行 PowerPivot 部署的 SharePoint 伺服陣列管理員或服務管理員。 如需有關 PowerPivot 服務 安裝與服務帳戶需求的詳細資訊，請參閱安裝 PowerPivot for SharePoint。

選項

伺服器模式 - 伺服器模式指定可以部署到伺服器的 Analysis Services 資料庫類型。 伺服器模式是在安裝期間決定，之後不能修改。 每個模式是互斥的，也就是說，您需要兩個 Analysis Services 執行個體，各設定為不同的模式，以便同時支援傳統 OLAP 和表格式模型方案。

指定管理員 - 您必須為 SQL Server 執行個體至少指定一個伺服器管理員。 您所指定的使用者或群組將成為所安裝之 Analysis Services 執行個體的伺服器管理員角色成員。 這些都必須是與安裝該軟體的電腦處於相同網域中的 Windows 網域使用者帳戶。

附註 附註

使用者帳戶控制 (UAC) 為 Windows 安全性功能，會要求系統管理員明確地核准系統管理動作或應用程式，之後才會允許這些項目執行。 由於 UAC 預設為開啟，系統將會提示您允許需要更高權限的特定作業。 您可以設定 UAC，以變更預設行為或針對特定程式自訂 UAC。 如需有關 UAC 和 UAC 組態的詳細資訊，請參閱＜使用者帳戶控制逐步指南＞和＜使用者帳戶控制 (Wikipedia)＞。

請參閱

其他資源

變更服務帳戶和密碼 (PowerPivot for SharePoint)
設定 Analysis Services 服務帳戶
設定 Windows 服務帳戶


Analysis Services 組態 - 資料目錄

[image]

Analysis Services 組態 - 資料目錄
請參閱 傳送回函

下表的預設目錄可在 SQL Server 安裝期間由使用者設定。 本機管理員和安裝期間建立及佈建的 SQLServerMSASUser$<instance> 安全性群組成員具有這些檔案的存取權限。

說明 | 預設目錄 | 建議
資料根目錄 | C:\Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Data\ | 請確定 \Program files\Microsoft SQL Server\ 資料夾受到有限權限的保護。 在許多組態中，Analysis Services 效能取決於資料目錄所在之儲存體的效能。 請將這個目錄放置於附加至系統的最高效能儲存體上。 若為容錯移轉叢集安裝，請確定資料目錄位於共用磁碟上。
記錄檔目錄 | C:\Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Log\ | 這是 Analysis Services 記錄檔的目錄，而且它包括了 FlightRecorder 記錄檔。 如果您增加了飛行記錄器持續時間，請確定記錄檔目錄具有足夠的空間。
暫存目錄 | C:\Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Temp\ | 請將暫存目錄放置於高效能的儲存體子系統上。
備份目錄 | C:\Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Backup\ | 這是 Analysis Services 預設備份檔案的目錄。 對於 PowerPivot for SharePoint 安裝來說，這也是 PowerPivot 系統服務快取 PowerPivot 資料檔案的位置。 請確定已設定適當的權限來防止資料遺失，並且確定 Analysis Services 服務的使用者群組具有足夠的權限，可寫入備份目錄。 不支援針對備份目錄使用對應的磁碟機。

附註

  • 部署在 SharePoint 伺服陣列上的 Analysis Services 執行個體會將應用程式檔案、資料檔案和屬性儲存在內容資料庫與服務應用程式資料庫中。

  • 將功能加入至現有的安裝時，您不能變更先前安裝之功能的位置，也不能指定新功能的位置。

  • 如果您要指定非預設的安裝目錄，請確定安裝資料夾對於此 SQL Server 執行個體是唯一的。 此對話方塊上的任何目錄都不應該與其他 SQL Server 執行個體中的目錄共用。 SQL Server 執行個體內的 Database Engine 和 Analysis Services 元件也應該安裝在不同的目錄中。

  • 程式檔和資料檔無法安裝在下列位置中：

    • 抽取式磁碟機

    • 使用壓縮的檔案系統

    • 系統檔案所在的目錄

    • 容錯移轉叢集執行個體上的共用磁碟機

請參閱

概念

SQL Server 的預設和具名執行個體的檔案位置


叢集磁碟選取

[image]

叢集磁碟選取
傳送回函

您可以使用 SQL Server 安裝精靈的 [叢集磁碟選取] 頁面來選取 SQL Server 容錯移轉叢集的共用叢集磁碟資源。 叢集磁碟就是即將放置 SQL Server 資料的位置。

共用叢集磁碟並非 SQL Server Database Engine 叢集安裝的需求。 SMB 檔案伺服器是 SQL Server Database Engine 容錯移轉叢集安裝的支援儲存體，而且您可以在完成安裝之前，使用 [Database Engine - 資料目錄] 頁面來指定儲存體。

警告注意事項 注意

如果您已經選取了要安裝 Analysis Services，就必須指定共用叢集磁碟。

如果您計畫在這個 SQL Server 容錯移轉叢集執行個體上啟用 FILESTREAM，就必須指定共用叢集磁碟。

選項

共用磁碟

從清單中選取單一磁碟。 叢集磁碟就是即將放置 SQL Server 資料的位置。

您只能指定一個磁碟。 如果您選取包含叢集仲裁資源的群組，則會出現警告。 我們建議您不要安裝到叢集仲裁資源。

可用共用磁碟

顯示可用磁碟的清單、每個磁碟是否具有成為共用磁碟的資格，以及每個磁碟資源的描述。


叢集網路組態

[image]

叢集網路組態
傳送回函

使用 [叢集網路選取] 頁面，即可指定容錯移轉叢集執行個體的網路資源。

選項

SQL Server 容錯移轉叢集網路名稱 - 這是用來在網路上識別容錯移轉叢集執行個體的名稱。

網路設定 - 指定容錯移轉叢集執行個體的 IP 類型和 IP 位址。

在加入節點和移除節點作業期間，SQL Server 會顯示 SQL Server 容錯移轉叢集之現有 IP 位址的唯讀清單。

  • 整合式安裝：

    • 如果您要加入支援一組完全相同網路子網路的節點，而且 SQL Server 容錯移轉叢集的現有節點支援這組子網路，就無法加入其他 IP 位址。 相依性設定會維持不變。

    • 如果您要加入支援子網路子集的節點，而且 SQL Server 容錯移轉叢集的現有節點支援這個子集，就無法加入其他 IP 位址資源。IP 位址資源相依性會設定為 OR，以便反映所有指定的 IP 位址在所有叢集節點上都無效。

    • 如果您要加入支援其他子網路 (除了 SQL Server 容錯移轉叢集之現有節點已經支援的子網路以外) 的節點，就可以選擇加入新的有效 IP 位址。 如果指定了新的 IP 位址，IP 位址資源相依性會設定為 OR，以便反映所有指定的 IP 位址在所有叢集節點上都無效。

    • 如果您要加入支援其他網路子網路的節點，但是這個節點不支援 SQL Server 容錯移轉叢集之現有節點所支援的任何子網路，就必須加入其他 IP 位址。 IP 位址資源相依性會設定為 OR，以便反映所有指定的 IP 位址在所有叢集節點上都無效。

  • 進階安裝：在安裝的完成步驟期間，請針對容錯移轉叢集執行個體的所有節點和子網路指定 IP 位址。 您可以針對多重子網路容錯移轉叢集指定多個 IP 位址，但是每個子網路只支援一個 IP 位址。 每個備妥的節點都至少應該是一個 IP 位址的擁有者。 如果您的 SQL Server 容錯移轉叢集具有多個子網路，系統就會提示您將 IP 位址資源相依性設定為 OR。移除節點：

    • 如果所有其餘節點都支援其餘 IP 位址，系統就會提示您將 IP 位址資源相依性設定為 AND。

    • 如果所有其餘節點不支援其餘 IP 位址，IP 位址資源相依性就會維持 OR。


叢集節點組態

[image]

叢集節點組態
傳送回函

您可以使用 [叢集節點組態] 頁面，在容錯移轉叢集執行個體中加入或移除節點。若要安裝或升級 SQL Server 容錯移轉叢集，您必須在容錯移轉叢集的每個節點上執行安裝程式。 若要將節點加入至現有的 SQL Server 容錯移轉叢集，您必須在要加入至 SQL Server 容錯移轉叢集執行個體的節點上執行 SQL Server 安裝程式。

選項

SQL Server 執行個體名稱 - 使用下拉式清單來選取要修改的 SQL Server 容錯移轉叢集執行個體。

此節點的名稱 - 這個欄位將會填入執行 SQL Server 安裝程式之電腦的名稱。 這是即將在 SQL Server 容錯移轉叢集執行個體中加入或移除的容錯移轉叢集節點。


叢集節點組態 (完成)

[image]

叢集節點組態 (完成)
傳送回函

您可以使用 [叢集節點組態 (完成)] 頁面來指定已經準備要建立叢集的現有 SQL Server 執行個體。若要安裝或升級 SQL Server 容錯移轉叢集，您必須在容錯移轉叢集的每個節點上執行安裝程式。 若要將節點加入至現有的 SQL Server 容錯移轉叢集，您必須在要加入至 SQL Server 容錯移轉叢集執行個體的節點上執行 SQL Server 安裝程式。

選項

在下拉式方塊中：

  • SQL Server 執行個體名稱 - 選取 SQL Server 容錯移轉叢集的執行個體名稱。

  • 此節點的名稱 - 這個欄位會預先填入執行 SQL Server 安裝程式的電腦名稱。

  • SQL Server 容錯移轉叢集網路名稱 - 這個欄位不會預先填入內容。 您可以針對新的 SQL Server 容錯移轉叢集執行個體指定網路名稱。 這是在網路上識別容錯移轉叢集執行個體的名稱。


叢集資源群組

[image]

叢集資源群組
請參閱 傳送回函

使用 [叢集資源群組] 頁面，即可指定即將放置 SQL Server 虛擬伺服器資源的磁碟。

選項

指定 SQL Server 叢集資源群組名稱。 您有兩個選項：

  • 使用下拉式方塊來指定要使用的現有群組。

  • 輸入要建立之新群組的名稱。 請注意，名稱 "Available storage" 不是有效的群組名稱。

請參閱

其他資源

如何：建立新的 SQL Server 容錯移轉叢集


叢集安全性原則

[image]

叢集安全性原則
傳送回函

使用 [叢集安全性原則] 頁面，即可針對容錯移轉叢集執行個體設定安全性原則。

選項

針對叢集服務指定全域或本機網域群組。 所有資源權限都是由包含 SQL Server 服務帳戶當做群組成員的網域層級群組所控制。 如需有關 Windows Server 2008 上服務安全性識別碼 (SID) 功能的詳細資訊，請參閱設定 Windows 服務帳戶。

如果您要在 Windows 2000 混合模式網域中安裝 Microsoft SQL Server 2012 容錯移轉叢集執行個體，就必須針對 SQL Server 叢集服務使用網域全域群組。

附註 附註

Windows 2000 網域控制站可以在混合模式和原生模式中運作。 混合模式允許在相同網域中存在下層網域控制站。


完成 - 完成映像

[image]

完成 - 完成映像
傳送回函

使用 [完成] 頁面，即可確認備妥執行個體的設定是否已完成。

選項

這個對話方塊包含此作業之安裝程式記錄檔的連結。 若要完成安裝，請按一下 [關閉]。


完成映像進度

[image]

完成映像進度
請參閱 傳送回函

請使用 SQL Server 安裝精靈的 [完成映像進度] 頁面來監視 SQL Server 映像完成安裝的狀態。 完成此步驟之後，這個頁面將會列出每個已設定和完成之 SQL Server 功能的狀態。

請參閱

概念

檢視與讀取 SQL Server 安裝程式記錄檔


完成影像規則

[image]

完成影像規則
傳送回函

在 SQL Server 安裝程式的作業完成之前，此安裝程式會驗證您的電腦組態。 在 SQL Server 安裝期間，System Configuration Checker (SCC) 會掃描將安裝 SQL Server 的電腦。 SCC 會檢查是否有任何狀況阻止 SQL Server 安裝作業成功。 在安裝程式啟動 SQL Server 安裝精靈以前，SCC 會擷取每一個項目的狀態。 然後它會比較所需條件的結果，並提供解決封鎖問題的指引。

系統組態檢查會產生報告，其中包含每個已執行規則以及執行狀態的簡短描述。 系統組態檢查報告位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

執行安裝作業之前，請檢閱下列主題：

  1. 安裝 SQL Server 的硬體和軟體需求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各版本支援的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server 安裝的安全性考量(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的地區語言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他參考資料：

  1. 支援的版本與版本升級(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安裝容錯移轉叢集之前(http://go.microsoft.com/fwlink/?LinkId=235034)


完成 - 準備映像

[image]

完成 - 準備映像
傳送回函

使用 [完成] 頁面，即可確認映像準備是否已完成。

選項

這個對話方塊包含此作業之安裝程式記錄檔的連結。 若要完成映像準備，請按一下 [關閉]。


完成 - 修復

[image]

完成 - 修復
傳送回函

使用 [完成 - 修復] 頁面，即可確認修復是否已完成。

選項

這個對話方塊包含此作業之安裝程式記錄檔的連結。 若要繼續，請按一下 [關閉]。


完成 - 升級

[image]

完成 - 升級
傳送回函

使用 [完成 (升級)] 頁面，即可確認升級是否已完成。

選項

這個對話方塊包含此作業之安裝程式記錄檔的連結。 若要繼續，請按一下 [關閉]。


Database Engine 組態 - 帳戶提供

[image]

Database Engine 組態 - 帳戶提供
請參閱 傳送回函

您可以使用此頁面來設定 SQL Server 安全性模式，以及加入 Windows 使用者或群組做為 SQL Server Database Engine 的管理員。

在 Windows Vista、Windows 7 和 Windows Server 2008 上執行 SQL Server 2012 的考量

在舊版 SQL Server 上，BUILTIN\Administrators 群組是提供成 Database Engine 的登入，而且本機 Administrators 群組的成員可以使用其管理員認證來登入。 使用較高的權限並非最佳做法。 在 Microsoft SQL Server 2012 中，BUILTIN\Administrators 群組並未提供成登入。 因此，您應該為每個管理使用者建立 SQL Server 登入，並在安裝新的 Microsoft SQL Server 2012 執行個體期間，將該登入加入至系統管理員 (sysadmin) 固定伺服器角色。 您也應該針對用來執行 SQL Server 代理程式作業的 Windows 帳戶進行上述作業。 這些作業包括複寫代理程式作業。

選項

安全性模式 - 為您的安裝選取 Windows 驗證或混合模式驗證。

Windows 主體提供 - 在舊版的 SQL Server 中，Windows Builtin\Administrator 本機群組置於 SQL Server 系統管理員 (sysadmin) 伺服器角色中，可有效授與 Windows 管理員對 SQL Server 執行個體的存取權。 在 Microsoft SQL Server 2012 中，Builtin\Administrator 群組不會提供在系統管理員 (sysadmin) 伺服器角色中。 您應該改在安裝期間針對新的安裝明確提供 SQL Server 管理員。

重要事項 重要事項

您必須在安裝期間針對新的安裝明確提供 SQL Server 管理員。 要等到您完成此步驟之後，安裝程式才允許您繼續。

指定 SQL Server 管理員 - 您在 SQL Server 執行個體上至少必須指定一個 Windows 主體。 若要加入 SQL Server 安裝程式執行所用的帳戶，請按一下 [目前使用者] 按鈕。 若要從系統管理員清單中加入或移除帳戶，請按一下 [加入] 或 [移除]，然後編輯在 SQL Server 執行個體中將會有管理員權限的使用者、群組或電腦清單。

當您完成清單的編輯之後，請按一下 [確定]，然後在組態對話方塊中確認管理員的清單。 當此清單完成時，請按 [下一步]。

如果您選取混合模式驗證，您必須為內建 SQL Server 系統管理員 (SA) 帳戶提供登入認證。

安全性注意事項 安全性注意事項

請勿使用空白密碼。請使用增強式密碼。

Windows 驗證模式

當使用者透過 Windows 使用者帳戶連接時，SQL Server 會使用作業系統中的 Windows 主體 Token 來驗證帳戶名稱和密碼。 這是預設驗證模式，比混合模式更加安全。 Windows 驗證利用 Kerberos 安全性通訊協定，在增強式密碼的複雜驗證方面提供密碼原則強化，並提供對帳戶鎖定的支援，同時支援密碼逾期。

安全性注意事項 安全性注意事項

盡可能使用 Windows 驗證。

重要事項 重要事項

請勿使用空白密碼。請使用增強式密碼。 絕對不可設定空白或弱式 sa 密碼。

混合模式 (Windows 驗證或 SQL Server 驗證)

允許使用者利用 Windows 驗證或 SQL Server 驗證來連接。 透過 Windows 使用者帳戶連接的使用者可以使用 Windows 已驗證的信任連接。

如果您必須選擇混合模式驗證，而且需要使用 SQL 登入來配合舊版應用程式，則您必須為所有 SQL Server 帳戶設定增強式密碼。

附註 附註

提供 SQL Server 驗證的目的，只是為了回溯相容性。 盡可能使用 Windows 驗證。

輸入密碼

輸入並確認系統管理員 (sa) 登入。 密碼是對抗入侵者的第一道防線，因此，設定增強式密碼對於系統的安全性很重要。 不得設定空白或弱式 sa 密碼。

附註 附註

SQL Server 密碼可包含 1 到 128 個字元，包括字母、符號和數字的任意組合。 如果您選擇混合模式驗證，則在您可以繼續到安裝精靈的下一頁之前，必須先輸入增強式 sa 密碼。

增強式密碼方針

增強式密碼不會很快被猜到，使用電腦程式也不容易破解。 增強式密碼不得使用禁止條件或詞彙，包括：

  • 空白或 NULL 條件

  • "Password"

  • "Admin"

  • "Administrator"

  • "sa"

  • "sysadmin"

增強式密碼不得為與安裝電腦相關的下列詞彙：

  • 目前登入機器的使用者名稱。

  • 電腦名稱。

增強式密碼的長度必須為 8 個字元以上，且至少滿足下列四項準則中的三項：

  • 必須包含大寫字母。

  • 必須包含小寫字母。

  • 必須包含數字。

  • 必須包含非英數字元；例如 #、% 或 ^。

此頁面中輸入的密碼必須符合增強式密碼原則的需求。 如果您有使用 SQL Server 驗證的任何自動化作業，請確定此密碼符合增強式密碼原則的需求。

相關內容

如需有關選擇 Windows 驗證和 SQL Server 驗證之比較的詳細資訊，請參閱《SQL Server 線上叢書》中的「選擇驗證模式」主題。

如需有關選擇帳戶以執行 SQL Server Database Engine 的詳細資訊，請參閱《SQL Server 線上叢書》中的「設定 Windows 服務帳戶與權限」主題。

請參閱

參考

設定 Windows 服務帳戶與權限


Database Engine 組態 - 資料目錄

[image]

Database Engine 組態 - 資料目錄
請參閱 傳送回函

使用此頁面可以指定 SQL Server Database Engine 程式和資料檔案的安裝位置。 根據安裝類型，支援的儲存體可能包括本機磁碟、共用儲存體或 SMB 檔案伺服器。

若要將 SMB 檔案共用指定為目錄，您必須手動輸入支援的 UNC 路徑。 不支援瀏覽 SMB 檔案共用。 以下是 SMB 檔案共用支援的 UNC 路徑格式："\\Servername\ShareName\..."

SQL Server 獨立執行個體

下表列出 SQL Server 獨立執行個體支援的儲存類型，以及使用者可以在 SQL Server 安裝期間設定的預設目錄。

說明 | 支援的儲存類型 | 預設目錄 | 建議
資料根目錄 | 本機磁碟、SMB 檔案伺服器、共用儲存體 1 | C:\Program Files\Microsoft SQL Server\ | 進行組態設定時，SQL Server 安裝程式將會設定 SQL Server 目錄的 ACL 並中斷繼承。
使用者資料庫目錄 | 本機磁碟、SMB 檔案伺服器、共用儲存體 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data | 使用者資料目錄的最佳作法取決於工作負載和效能需求。
使用者資料庫記錄檔目錄 | 本機磁碟、SMB 檔案伺服器、共用儲存體 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data | 請確定記錄檔目錄具有足夠的空間。
暫存資料庫目錄 | 本機磁碟、SMB 檔案伺服器、共用儲存體 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data | 暫存目錄的最佳作法取決於工作負載和效能需求。
暫存資料庫記錄檔目錄 | 本機磁碟、SMB 檔案伺服器、共用儲存體 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data | 請確定記錄檔目錄具有足夠的空間。
備份目錄 | 本機磁碟、SMB 檔案伺服器、共用儲存體 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Backup | 請設定適當的權限來防止資料遺失，並且確定 SQL Server 服務的使用者帳戶具有足夠的權限，可寫入備份目錄。 不支援針對備份目錄使用對應的磁碟機。

1 儘管支援共用磁碟，但不建議對 SQL Server 獨立執行個體採用這種做法。

SQL Server 容錯移轉叢集執行個體

下表列出 SQL Server 容錯移轉叢集執行個體支援的儲存類型，以及使用者可以在 SQL Server 安裝期間設定的預設目錄。

說明

支援的儲存類型

預設目錄

建議

資料根目錄

共用儲存體、SMB 檔案伺服器

<Drive:>\Program Files\Microsoft SQL Server\

提示 提示

如果在 [叢集磁碟選取] 頁面上選取共用磁碟，預設為第一個共用磁碟。 如果在 [叢集磁碟選取] 頁面上沒有進行任何選擇，此欄位預設為空白。

進行組態設定時，SQL Server 安裝程式將會設定 SQL Server 目錄的 ACL 並中斷繼承。

使用者資料庫目錄

共用儲存體、SMB 檔案伺服器

<Drive:>\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data

提示 提示

如果在 [叢集磁碟選取] 頁面上選取共用磁碟，預設為第一個共用磁碟。 如果在 [叢集磁碟選取] 頁面上沒有進行任何選擇，此欄位預設為空白。

使用者資料目錄的最佳作法取決於工作負載和效能需求。

使用者資料庫記錄檔目錄

共用儲存體、SMB 檔案伺服器

<Drive:>\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data

提示 提示

如果在 [叢集磁碟選取] 頁面上選取共用磁碟，預設為第一個共用磁碟。 如果在 [叢集磁碟選取] 頁面上沒有進行任何選擇，此欄位預設為空白。

請確定記錄檔目錄具有足夠的空間。

暫存資料庫目錄

本機磁碟、共用儲存體、SMB 檔案伺服器

<Drive:>\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data

提示 提示

如果在 [叢集磁碟選取] 頁面上選取共用磁碟，預設為第一個共用磁碟。 如果在 [叢集磁碟選取] 頁面上沒有進行任何選擇，此欄位預設為空白。

請確定指定的目錄對所有叢集節點都有效。 在容錯移轉期間，如果容錯移轉目標節點上的 tempdb 目錄無法使用，則 SQL Server 資源將無法上線。

暫存資料庫記錄檔目錄

本機磁碟、共用儲存體、SMB 檔案伺服器

<Drive:>\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data

提示 提示

如果在 [叢集磁碟選取] 頁面上選取共用磁碟，預設為第一個共用磁碟。 如果在 [叢集磁碟選取] 頁面上沒有進行任何選擇，此欄位預設為空白。

請確定指定的目錄對所有叢集節點都有效。 在容錯移轉期間，如果容錯移轉目標節點上的 tempdb 目錄無法使用，則 SQL Server 資源將無法上線。

備份目錄

本機磁碟、共用儲存體、SMB 檔案伺服器

<Drive:>\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Backup

提示 提示

如果在 [叢集磁碟選取] 頁面上選取共用磁碟，預設為第一個共用磁碟。 如果在 [叢集磁碟選取] 頁面上沒有進行任何選擇，此欄位預設為空白。

請設定適當的權限來防止資料遺失，並且確定 SQL Server 服務的使用者帳戶具有足夠的權限，可寫入備份目錄。 不支援針對備份目錄使用對應的磁碟機。

安全性考量

進行組態設定時，安裝程式將會設定 SQL Server 目錄的 ACL 並中斷繼承。

以下建議適用於 SMB 檔案伺服器：

  • 如果使用 SMB 檔案伺服器，SQL Server 服務帳戶必須是網域帳戶。

  • 用於安裝 SQL Server 的帳戶應該擁有當做資料目錄之 SMB 檔案共用資料夾的 FULL CONTROL NTFS 權限。

  • 用於安裝 SQL Server 的帳戶應該具有 SMB 檔案伺服器的 SeSecurityPrivilege 權限。 若要授與此權限，請使用檔案伺服器上的 [本機安全性原則] 主控台，將 SQL Server 安裝帳戶新增至 [管理稽核及安全性記錄] 原則中。 在 [本機安全性原則] 主控台中 [本機原則] 下的 [使用者權限指派] 區段可以找到此設定。

附註

  • 將功能加入現有的安裝時，您不能變更先前安裝之功能的位置，也不能指定新功能的位置。

  • 如果您要指定非預設的安裝目錄，請確定安裝資料夾對於此 SQL Server 執行個體是唯一的。 此對話方塊上的任何目錄都不應該與其他 SQL Server 執行個體中的目錄共用。 SQL Server 執行個體內的 Database Engine 和 Analysis Services 元件也應該安裝在不同的目錄中。

  • 程式檔和資料檔無法安裝在下列位置中：

    • 抽取式磁碟機

    • 使用壓縮的檔案系統

    • 系統檔案所在的目錄

    • 容錯移轉叢集執行個體上的對應網路磁碟機

請參閱

概念

SQL Server 的預設和具名執行個體的檔案位置

其他資源

檔案伺服器的共用及 NTSF 權限


Database Engine 組態 - Filestream

[image]

Database Engine 組態 - Filestream
請參閱 傳送回函

您可以使用這個頁面，針對這個 Microsoft SQL Server 2012 安裝啟用 FILESTREAM。FILESTREAM 會將 SQL Server Database Engine 與 NTFS 檔案系統整合，方法是將 varbinary(max) 二進位大型物件 (BLOB) 資料當做檔案儲存在檔案系統上。 Transact-SQL 陳述式可以插入、更新、查詢、搜尋和備份 FILESTREAM 資料。 Win32 檔案系統介面提供了資料的資料流方式存取。

對 Transact-SQL 存取啟用 FILESTREAM

選取此選項即可針對 Transact-SQL 存取啟用 FILESTREAM。 您必須先核取這個控制項，然後才能使用其他控制選項。

對檔案 I/O 資料流存取啟用 FILESTREAM

選取此選項即可針對 Win32 資料流存取啟用 FILESTREAM。

Windows 共用名稱

使用這個控制項即可輸入即將儲存 FILESTREAM 資料之 Windows 共用的名稱。

允許遠端用戶端具有 FILESTREAM 資料的資料流存取權

選取這個控制項即可允許遠端用戶端在此伺服器上存取這項 FILESTREAM 資料。

請參閱

參考

sp_configure (Transact-SQL)

概念

啟用及設定 FILESTREAM


資料庫引擎組態 - 使用者執行個體

[image]

資料庫引擎組態 - 使用者執行個體
傳送回函

使用 [使用者執行個體] 頁面，即可為不具管理員權限的使用者產生個別的 Database Engine 執行個體，並將使用者加入至管理員角色。

選項

啟用使用者執行個體

預設值為開啟。 若要停用啟用使用者執行個體的功能，請清除該核取方塊。

使用者執行個體 (也稱為子系或用戶端執行個體) 是父執行個體 (當做服務執行的主要執行個體，例如 SQLExpress) 代表使用者所產生的 SQL Server 執行個體。 使用者執行個體是在該使用者的安全性內容下，以使用者處理序的形式執行。 使用者執行個體與父執行個體和電腦上執行的其他使用者執行個體隔離。 使用者執行個體功能也稱為「以一般使用者的身分執行」(RANU)。

附註 附註

在安裝期間佈建為 sysadmin (系統管理員) 固定伺服器角色成員的登入，會佈建為範本資料庫中的管理員。 除非移除，否則這些登入會是使用者執行個體上 sysadmin (系統管理員) 固定伺服器角色的成員。

將使用者加入至 SQL Server 管理員角色

預設值不是開啟。 若要將目前的安裝程式使用者加入至 SQL Server 管理員角色，請選取該核取方塊。

身為 BUILTIN\Administrators 成員的 Windows Vista 使用者並不會在連接到 SQL Server Express 時，自動加入至系統管理員 (sysadmin) 固定伺服器角色。 只有已明確地加入至伺服器層級之管理員角色的 Windows Vista 使用者可以管理 SQL Server Express。 Built-In\Users 群組的任何成員都可以連接至 SQL Server Express 執行個體，但這些成員僅具有執行資料庫工作的有限權限。 因為這個原因，所以必須在 Windows Vista 上執行的 SQL Server Express 執行個體中，明確地為從舊版 Windows 的 BUILTIN\Administrators 和 Built-In\Users 繼承 SQL Server Express 權限的使用者授與管理員權限。

若要在此安裝程式結束後，對使用者角色進行任何變更，請使用 SQL Server 2005 介面區組態工具 (SQLSAC.exe)。 若要更新 SQL Server 系統管理員角色中的使用者清單，按一下 [新增管理員] 連結。

請確定 [要提供的使用者] 欄位有列出其權限應該更新之使用者的 DomainName\UserName。 從 [可用權限] 窗格的 SQL Server 執行個體清單中選取要更新的角色，然後按一下向右鍵。 若要將使用者加入至 SQL Server 執行個體的所有可用執行個體及可用角色的可用角色，按一下雙重向右鍵。

若要在完成選擇時實作變更，按一下 [確定]。 若要結束工具而不進行變更，按一下 [取消]。


磁碟空間需求

[image]

磁碟空間需求
請參閱 傳送回函

使用 [磁碟空間摘要] 頁面，即可檢查您選取要安裝之 SQL Server 功能的磁碟空間需求。

選項

如果所需的磁碟空間太高，請考慮下列選項：

  • 將安裝目錄變更為具有更多磁碟空間的磁碟機。

  • 變更要安裝的 SQL Server 功能。

  • 在指定的磁碟機上，移動其他檔案或應用程式，藉以創造更多可用空間。

請參閱

其他資源

安裝 SQL Server 2008 R2 的硬體和軟體需求


Distributed Replay Controller 組態

[image]

Distributed Replay Controller 組態
傳送回函

您可以使用 SQL Server 安裝精靈的 [Distributed Replay Controller 組態] 頁面來指定您想要授與 Distributed Replay Controller 服務之管理權限的使用者。

擁有管理權限的使用者將可不受限制地存取 Distributed Replay Controller 服務。

選項

加入目前使用者

按一下此按鈕即可加入您想要授與 Distributed Replay Controller 服務之存取權限的使用者。

加入

按一下此按鈕即可加入 Distributed Replay Controller 服務的存取權限。

移除

按一下此按鈕即可移除 Distributed Replay Controller 服務的存取權限。


Distributed Replay Client 組態

[image]

Distributed Replay Client 組態
傳送回函

您可以使用 SQL Server 安裝精靈的 [Distributed Replay Client 組態] 頁面來指定您想要授與 Distributed Replay Client 服務之管理權限的使用者。

擁有管理權限的使用者將可不受限制地存取 Distributed Replay Client 服務。

選項

控制器名稱

這是選擇性參數，預設值為 <blank>。

針對 Distributed Replay Client 服務，輸入將與用戶端電腦進行通訊之控制器的名稱。 請注意下列事項：

  • 名稱必須是完整網域名稱 (FQDN)。 例如，Microsoft 的產品階層中稱為 server1 的主機，其 FQDN 會是 server1.products.microsoft.com。

  • 如果您已經設定了控制器，請在設定每個用戶端時輸入該控制器的名稱。

  • 如果您尚未設定控制器，則可以將控制器名稱留空。 不過，您必須在 [用戶端組態] 檔中，手動輸入控制器名稱。

工作目錄

指定 Distributed Replay Client 服務的工作目錄。

預設工作目錄為 <drive letter>:\Program Files\Microsoft SQL Server\DReplayClient\WorkingDir\。

結果目錄

指定 Distributed Replay Client 服務的結果目錄。

預設結果目錄為 <drive letter>:\Program Files\Microsoft SQL Server\DReplayClient\ResultDir\。


版本升級規則

[image]

版本升級規則
請參閱 傳送回函

在 SQL Server 安裝程式的作業完成之前，此安裝程式會驗證您的電腦組態。 在 SQL Server 安裝期間，System Configuration Checker (SCC) 會掃描將安裝 SQL Server 的電腦。 SCC 會檢查是否有任何狀況阻止 SQL Server 安裝作業成功。 在安裝程式開始進行版本升級之前，SCC 會擷取每一個項目的狀態。 然後它會比較所需條件的結果，並提供解決封鎖問題的指引。

系統組態檢查會產生報告，其中包含每個已執行規則以及執行狀態的簡短描述。 系統組態檢查報告位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

執行安裝作業之前，請檢閱下列主題：

  1. 安裝 SQL Server 的硬體和軟體需求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各版本支援的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server 安裝的安全性考量(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的地區語言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他參考資料：

  1. 支援的版本與版本升級(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安裝容錯移轉叢集之前(http://go.microsoft.com/fwlink/?LinkId=235034)

請參閱

參考

安裝程式支援檔案


錯誤報告

[image]

錯誤報告
傳送回函

使用 SQL Server 安裝精靈的 [錯誤和使用方式報表設定] 頁面，可啟用 SQL Server 的功能錯誤和使用方式報告功能。

選項

根據預設，Microsoft SQL Server 2012 中的 SQL Server 及其元件會停用功能使用方式資料收集和錯誤報告功能。

錯誤報告

如果您啟用錯誤報告功能，萬一下列任何一個 SQL Server 元件發生嚴重錯誤時，SQL Server 就會設定為自動將報表傳送至 Microsoft。

  • Database Engine

  • SQL Server Agent

  • Analysis Services

  • Reporting Services

  • Integration Services

  • 複寫

Microsoft 使用錯誤報表來改進 SQL Server 功能，並將所有資訊視為機密資訊。

關於錯誤的資訊會透過安全 (https) 連接傳送到 Microsoft (以限制存取的方式予以儲存)。 另外，錯誤報表也可以傳送到您自己的 Corporate Error Reporting 伺服器。

錯誤報表包含下列資訊：

  • 發生問題時的 SQL Server 狀況。

  • 作業系統版本和電腦硬體資訊。

  • 數位產品識別碼，它不是用於識別授權。

  • 電腦或 Proxy 伺服器的網路 IP 位址。

  • 導致錯誤之處理序的記憶體或檔案中的資訊。

Microsoft 不刻意收集檔案、名稱、地址、電子郵件地址或任何形式的個人資訊。 不過，錯誤報表可包含導致錯誤之處理序的記憶體或檔案中的個人資訊。 雖然這項資訊可能用於判斷您的識別，但 Microsoft 不會將這項資訊用於此用途。

如需有關 SQL Server 隱私權和資料收集原則的詳細資訊，請參閱＜Microsoft SQL Server 隱私權聲明＞。

如果您啟用錯誤報告卻發生嚴重錯誤，您可能會在 Windows 事件記錄檔中看到 Microsoft 的回應，它會指向關於特定錯誤的 Microsoft 知識庫文件。

在安裝程式完成之後，若要對 SQL Server 的所有執行個體及其元件停用錯誤或功能使用方式報表，請到 [錯誤和使用方式報表設定] 對話方塊，清除 [功能使用方式] 的核取方塊。 如果已對 SQL Server 的多個元件 (SQL Server Database Engine、Analysis Services、Reporting Services 和共用元件) 啟用 [錯誤報告]，您可以停用個別元件及共用元件 (以 [其他] 列出) 之每一個執行個體的錯誤報告。


容錯移轉叢集報表

[image]

容錯移轉叢集報表
傳送回函

使用 [容錯移轉叢集報表] 頁面，即可檢視這項作業之安裝程式系統掃描的報表結果。

選項

若要檢視掃描的詳細報表，請按一下報表連結。


功能檢閱

[image]

功能檢閱
請參閱 傳送回函

[功能檢閱] 頁面是一份唯讀的功能清單，其中列出已經備妥而且將在完成映像步驟結束時設定並完成的功能。 此功能清單是在準備映像步驟期間選取，而且無法在完成映像步驟期間修改。 除了所顯示的功能以外，備妥的執行個體也會包含 SQL Server Browser、SQL Server Writer 和 SQL Server Native Client。

在您已經完成備妥 SQL Server 執行個體的設定之後，就可以新增備妥 SQL Server 執行個體中並未包含的其他功能。

元件群組

元件和功能

Database Engine 服務

SQL Server Database Engine 包含以下元件：

  • Database Engine 是用於儲存、處理和保護資料的核心服務。

    • 複寫：(選擇性) 複寫是一組技術，用於將資料和資料庫物件從某個資料庫複製和散發到另一個資料庫，然後在兩個資料庫之間進行同步處理以維護一致性。

    • 全文檢索搜尋：(選擇性) 全文檢索搜尋提供一種功能，可針對 SQL Server 資料表中一般以字元為主的資料發出全文檢索查詢。

    • Data Quality Services：(選擇性) Data Quality Services (DQS) 是一項資料清除方案，可讓您在資料來源中探索不一致和不正確的資料，而且提供了可清除資料的自動化和互動方式。

Reporting Services

Reporting Services 包括伺服器和用戶端元件，可用來建立、管理和部署表格式、矩陣、圖形化和自由形式報表。 Reporting Services 也是一個可延伸的平台，可讓您用來開發報表應用程式。

請參閱

其他資源

如何：使用 SysPrep 安裝 SQL Server


安裝規則

[image]

安裝規則
請參閱 傳送回函

在 SQL Server 安裝程式的作業完成之前，此安裝程式會驗證您的電腦組態。 在 SQL Server 安裝期間，System Configuration Checker (SCC) 會掃描將安裝 SQL Server 的電腦。 SCC 會檢查是否有任何狀況阻止 SQL Server 安裝作業成功。 在安裝程式啟動 SQL Server 安裝精靈以前，SCC 會擷取每一個項目的狀態。 然後它會比較所需條件的結果，並提供解決封鎖問題的指引。

系統組態檢查會產生報告，其中包含每個已執行規則以及執行狀態的簡短描述。 系統組態檢查報告位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

執行安裝作業之前，請檢閱下列主題：

  1. 安裝 SQL Server 的硬體和軟體需求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各版本支援的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server 安裝的安全性考量(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的地區語言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他參考資料：

  1. 支援的版本與版本升級(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安裝容錯移轉叢集之前(http://go.microsoft.com/fwlink/?LinkId=235034)

請參閱

參考

安裝程式支援檔案


功能規則

[image]

功能規則
傳送回函

在 SQL Server 安裝程式的作業完成之前，此安裝程式會驗證您的電腦組態。 在 SQL Server 安裝期間，System Configuration Checker (SCC) 會掃描將安裝 SQL Server 的電腦。 SCC 會檢查是否有任何狀況阻止 SQL Server 安裝作業成功。 在安裝程式啟動之前，SCC 會擷取每一個項目的狀態。 然後它會比較所需條件的結果，並提供解決封鎖問題的指引。

系統組態檢查會產生報告，其中包含每個已執行規則以及執行狀態的簡短描述。 系統組態檢查報告位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

執行安裝作業之前，請檢閱下列主題：

  1. 安裝 SQL Server 的硬體和軟體需求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各版本支援的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server 安裝的安全性考量(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的地區語言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他參考資料：

  1. 支援的版本與版本升級(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安裝容錯移轉叢集之前(http://go.microsoft.com/fwlink/?LinkId=235034)


特徵選取

[image]

特徵選取
請參閱 傳送回函

使用 SQL Server 安裝精靈之 [特徵選取] 頁面上的核取方塊可選取 SQL Server 安裝的元件。

安裝 SQL Server 功能

在 [特徵選取] 頁面上，SQL Server 功能分成兩個主要部分：執行個體功能與共用功能。

執行個體功能指的是針對每個執行個體安裝一次，讓您擁有多個複本 (每個執行個體一個) 的元件。 每個執行個體都可以擁有不同修補程式等級的單獨版本。 當您安裝修補程式時，不論它是 Service Pack、Hotfix，還是累計更新，都只會針對給定機器上的一個執行個體更新檔案，如果尚未更新共用功能，也會一併更新。

共用功能：指的是給定機器上所有執行個體都通用的功能。 這些每一個共用功能的設計，都與支援且可並存安裝的 SQL Server 版本 (Service Pack、累計更新以及 Hotfix) 回溯相容。

附註 附註

SQL Server SysPrep：Database Engine 和 Reporting Services 是唯一支援 SQL Server SysPrep 的 Microsoft SQL Server 2012 功能。 您可以在此程序的準備映像步驟期間選取這些功能和元件。 不過，您無法在完成備妥的 SQL Server 映像時進行選擇。 如需詳細資訊，請參閱＜如何：使用 SysPrep 安裝 SQL Server 2012＞(http://go.microsoft.com/fwlink/?LinkId=190965)。

SQL Server 容錯移轉叢集：Database Engine 和 Analysis Services 元件是支援容錯移轉叢集的唯一 Microsoft SQL Server 2012 功能。 雖然您可以在容錯移轉叢集節點上安裝其他元件 (例如 Reporting Services 或 Integration Services)，但是這些元件無法感知叢集，而且如果容錯移轉叢集節點離線，這些元件的服務就不會容錯移轉。 如需詳細資訊，請參閱 SQL Server 容錯移轉叢集入門 (http://go.microsoft.com/fwlink/?LinkId=190953)。

執行個體功能

當您選取元件時，每一個元件群組的描述會出現在 [描述] 窗格中。 您可以選取核取方塊的任何組合。 若要繼續，您必須做選擇。

功能

說明

Database Engine 服務

SQL Server Database Engine 包括 Database Engine，這是一種用以儲存、處理及保護資料安全的核心服務，並提供複寫、全文檢索搜尋功能、管理關聯式和 XML 資料的工具，以及 Data Quality Services (DQS) 伺服器。

  • Database Engine 是用於儲存、處理和保護資料安全的核心服務。

  • 複寫：(選擇性) 複寫是一組技術，用於將資料和資料庫物件從某個資料庫複製和散發到另一個資料庫，然後在兩個資料庫之間進行同步處理以維護一致性。

  • 全文檢索搜尋：(選擇性) 全文檢索搜尋提供一種功能，可針對 SQL Server 資料表中一般以字元為主的資料發出全文檢索查詢。

  • Data Quality Services：(選擇性) Data Quality Services (DQS) 是一項資料清理方案，可讓您在資料來源中探索不一致和不正確的資料，而且提供了可清理資料的電腦輔助和互動方式。 選取此核取方塊可安裝 DQS 伺服器。 在完成 SQL Server 安裝之後，您必須執行 DQSInstaller.exe 檔案才能完成 DQS 伺服器安裝。 如果您安裝了 SQL Server 的預設執行個體，這個檔案會位於：C:\Program Files\Microsoft SQL Server\MSSQL11.MSSQLSERVER\MSSQL\Binn。

SQL Server 容錯移轉叢集：當您選取 Database Engine Services 時，就需要複寫和全文檢索搜尋元件，而且 SQL Server 容錯移轉叢集安裝的安裝程式會在選取 Database Engine Services 時自動選取。

Analysis Services

Analysis Services 包括用來建立及管理線上分析處理 (OLAP) 和資料採礦應用程式的工具。

Reporting Services - 原生

Reporting Services 原生模式包括伺服器和用戶端元件，可用來建立、管理和部署表格式、矩陣、圖形化和自由形式報表。 Reporting Services 也是一個可延伸的平台，可讓您用來開發報表應用程式。

重要事項 重要事項

  1. 安裝程式不會為 Reporting Services 向外延展部署中的多個節點，設定負載平衡和單一 URL 定址。 若要完成向外延展部署，您必須使用 Windows Server、Microsoft Application Center 或協力廠商叢集管理軟體。 如需有關設定 Web 伺服陣列部署的詳細資訊，請參閱設定 Reporting Services 進行向外延展部署 (http://go.microsoft.com/fwlink/?LinkId=199448)。

  2. Microsoft Internet Explorer 7.0 SP 1 是 Reporting Services 報表設計師元件的必要項目。

  3. 同時在 64 位元平台以及在 64 位元伺服器的 32 位元子系統 (WOW64) 的並存組態中，不支援 Reporting Services。

共用功能

單一電腦上供所有 SQL Server 執行個體共用的功能會安裝到單一目錄， 其中包括：

功能

說明

Reporting Services -SharePoint

Reporting Services SharePoint 模式是伺服器應用程式，可用於報表建立、管理，以及將其傳遞至電子郵件、多個檔案格式和互動式 Web 格式。 SharePoint 模式會將報表檢視和報表管理經驗與 SharePoint 產品整合。

適用於 SharePoint 產品的 Reporting Services 增益集

適用於 SharePoint 產品的 Reporting Services 增益集包含管理和使用者介面元件，將 SharePoint 產品與 SharePoint 模式的 Reporting Services 報表伺服器整合在一起。

Data Quality Client

Data Quality Client 是連接到 DQS 伺服器的獨立應用程式，提供了直覺式的圖形化使用者介面，可執行資料清理作業、資料比對作業，以及執行 DQS 的管理工作。

SQL Server Data Tools1

SQL Server Data Tools (SSDT) 提供 IDE，可用於建立下列商業智慧元件的方案：Analysis Services、Reporting Services 和 Integration Services

(先前稱為 Business Intelligence Development Studio)。

SSDT 也包含「資料庫專案」，為資料庫開發人員提供整合環境，以實現 Visual Studio 內任何 SQL Server 平台 (內部和外部部署) 適用的所有資料庫設計工作。 資料庫開發人員可以使用 Visual Studio 中的增強伺服器總管，輕鬆建立或編輯資料庫物件和資料，或執行查詢。

用戶端工具連接性

用戶端工具包括用於用戶端和伺服器之間通訊的元件，包括 DB-Library、OLEDB for OLAP、ODBC、ADODB 和 ADOMD+ 的網路程式庫。

Integration Services

Integration Services 是一組圖形化工具和可程式化物件，用來移動、複製和轉換資料。

用戶端工具回溯相容性

[用戶端工具回溯相容性] 包含下列元件：

  • SQL Distributed Management Objects (SQL-DMO)。 如需詳細資訊，請參閱＜在 SQL Server 2012 中停止 SQL Server 的功能＞(http://go.microsoft.com/fwlink/?LinkId=190968)。

  • 決策支援物件 (DSO)。 如需詳細資訊，請參閱＜SQL Server 2012 中 Analysis Services 功能的突破性變更＞(http://go.microsoft.com/fwlink/?LinkId=190970)。

用戶端工具 SDK

包括內含供程式設計人員使用之資源的軟體開發套件。

文件集元件

文件集文件包括檢視並管理說明內容的元件。

管理工具 - 基本

管理工具 - 基本：這包括下列元件：

  • SQL Server Database Engine、SQL Server Express、sqlcmd 公用程式，以及 SQL Server PowerShell 提供者的 SQL Server Management Studio 支援

管理工具 - 完整：除了基本版的元件以外，還包括下列元件：

  • Reporting Services、Analysis Services 和 Integration Services 的SQL Server Management Studio 支援

  • SQL Server Profiler

  • Database Engine Tuning Advisor

  • SQL Server 公用程式管理

Distributed Replay Controller

Distributed Replay Controller 可協調 Distributed Replay Client 的動作。 每個 Distributed Replay 環境都只能有一個 Controller 執行個體。 如需詳細資訊，請參閱 SQL Server Distributed Replay (http://go.microsoft.com/fwlink/?LinkId=229847)。

Distributed Replay Client

Distributed Replay Client 會共同運作以模擬 SQL Server 執行個體的工作負載。 每個 Distributed Replay 環境中可以有一個或多個用戶端。 如需詳細資訊，請參閱 SQL Server Distributed Replay (http://go.microsoft.com/fwlink/?LinkId=229847)。

SQL 用戶端連接性 SDK

包括供資料庫應用程式開發使用的 SQL Server Native Client (ODBC/OLE DB) SDK。

Master Data Services

Master Data Services 是一套平台，可針對精確度和稽核目的，將組織中不同系統的資料整合成單一主要資料來源。 Master Data Services 選項會安裝 Master Data Services 組態管理員、組件、Windows PowerShell 嵌入式管理單元，以及 Web 應用程式與服務的資料夾和檔案。

LocalDB

LocalDB 是 SQL Server Express 的執行模式，專供程式開發人員使用。 由空間連接字串初始化之後，必要的 SQL Server 基礎結構就會自動建立及啟動，應用程式不需執行組態或管理工作即可使用資料庫。

1Internet Explorer 6.0 SP1 是 SQL Server Data Tools (SSDT) 安裝的必要項目。

根據預設，共用元件會安裝到 %Program Files%Microsoft SQL Server\。 若要變更安裝路徑，請按一下 [瀏覽] 按鈕。 如果您變更某個共用元件的安裝路徑，您也會變更其他共用元件的安裝路徑。 後續安裝會將共用元件安裝到與原始安裝相同的位置。

在 x64 型作業系統上，您可以指定將要安裝 64 位元元件的位置，以及 32 位元元件將要安裝在 WOW64 子系統上的哪一個位置。

安裝 AdventureWorks 範例資料庫

根據預設，SQL Server 安裝程序中不會安裝範例資料庫和範例程式碼。 如需有關安裝範例資料庫和範例程式碼的詳細資訊，請參閱＜Microsoft SQL Server 社群專案和範例＞(http://go.microsoft.com/fwlink/?LinkId=87843)。

在安裝 Microsoft SQL Server 2012 之後，可使用有關範例的其他資訊。 從 [開始] 功能表，依序按一下 [所有程式]、[Microsoft SQL Server 2012]、[文件集和教學課程]，然後按一下 [Microsoft SQL Server 範例概觀]。

請參閱

其他資源

SQL Server 2012 的版本和元件


特徵選取 (解除安裝)

[image]

特徵選取 (解除安裝)
傳送回函

使用 [特徵選取 - 解除安裝] 頁面，即可選取要從指定之 SQL Server 執行個體中移除的功能。

選項

您可以選取任何功能的組合。


要升級的功能

[image]

要升級的功能
請參閱 傳送回函

使用 Microsoft SQL Server 2012 安裝精靈的 [要升級的功能] 頁面可檢視要升級到 Microsoft SQL Server 2012 的功能。

選項

  • 在這一版中將無法變更要升級的功能。 若要將功能加入至這個 SQL Server 執行個體，請完成升級程序、重新啟動安裝程式，然後在安裝中心上按一下 [新的安裝或將功能加入到現有安裝]。

請參閱

其他資源

版本與版別的升級
使用 Upgrade Advisor 來準備升級
使用 SQL Server 的多個版本


全文檢索搜尋升級選項

[image]

全文檢索搜尋升級選項
傳送回函

您可以使用 SQL Server 安裝精靈的 [全文檢索搜尋升級選項] 頁面，針對此時升級的資料庫選取要使用的全文檢索搜尋升級選項。

在 SQL Server 2005 和舊版中，每個全文檢索索引都位於屬於檔案群組、具有實體路徑而且被視為資料庫檔案的全文檢索目錄中。 不過，從 SQL Server 2008 開始，全文檢索目錄是參考一組全文檢索索引的邏輯概念 (虛擬物件)。 因此，新的全文檢索目錄不會被視為具有實體路徑的資料庫檔案。 不過，在升級含有資料檔案的任何全文檢索目錄期間，系統會在相同的磁碟上建立新的檔案群組。 這會在升級之後保留舊磁碟 I/O 行為。 如果根路徑存在，則任何來自該目錄的全文檢索索引都會放置於新的檔案群組中。 如果舊的全文檢索目錄路徑無效，升級作業就會將全文檢索索引保留在與基底資料表相同的檔案群組中，或是保留在資料分割資料表的主要檔案群組中。

選項

當您從 SQL Server 2005 或 SQL Server 2008 升級為 Microsoft SQL Server 2012 時，請選擇下列其中一個全文檢索升級選項。

匯入

匯入全文檢索目錄。 一般而言，匯入的速度明顯比重建的速度更快。 例如，只有使用一個 CPU 時，匯入的執行速度大約比重建的速度快 10 倍。 不過，從 SQL Server 2005 匯入的全文檢索目錄並不會使用 SQL Server 2008 中導入的新增強化斷詞工具，所以您最後可能會想要重建全文檢索目錄。

附註 附註

重建可以在多執行緒模式中執行，而且如果有 10 個以上的 CPU 可用，當您允許重建使用所有 CPU 時，重建的執行速度可能會比匯入的速度更快。

如果無法使用全文檢索目錄，將會重建關聯的全文檢索索引。 只有針對 SQL Server 2005 資料庫才可以使用此選項。

如需有關匯入全文檢索索引之影響的詳細資訊，請參閱本主題後面的「選擇全文檢索升級選項的考量」。

重建

全文檢索目錄會使用 SQL Server 2008 中導入的新增強化斷詞工具重建。 重建索引可能要花一些時間，而且在升級之後可能需要相當多的 CPU 和記憶體。

重設

重設全文檢索目錄。 從 SQL Server 2005 進行升級時，全文檢索目錄檔案會遭到移除，但是全文檢索目錄和全文檢索索引的中繼資料則會保留。 在升級之後，所有的全文檢索索引都會停用變更追蹤，而且不會自動啟動搜耙。 當您在升級完成之後手動發出完整母體擴展之前，此目錄將會維持空白狀態。

這些所有升級選項都可確保升級的資料庫會完全從 SQL Server 2008 和更新版本的全文檢索效能增強功能中獲益。

重要事項 重要事項

如需有關在匯入 SQL Server 2005 全文檢索索引之後使用新斷詞工具以及將非搜尋字檔案升級為停用字詞表的詳細資訊，請參閱 Microsoft SQL Server 2012 安裝說明中的＜全文檢索搜尋升級＞主題。

選擇全文檢索升級選項的考量

當您為升級作業選擇升級選項時，請考慮下列事項：

  • 您如何使用斷詞工具？

    Microsoft SQL Server 2012 中的全文檢索搜尋服務包含 SQL Server 2008 中導入的斷詞工具和字幹分析器。 這些項目可能會針對特定文字模式或狀況，變更從 SQL Server 2005 全文檢索查詢的結果。 因此，在選擇適當的升級選項時，您如何使用斷詞工具便很重要：

    • 如果您所使用之全文檢索語言的斷詞工具並未在 SQL Server 2008 或更新版本中變更，或者重新叫用精確度對您不重要，則適合進行匯入。 之後，如果您遇到任何重新叫用的問題，只要透過重建全文檢索目錄，就可以升級為新的斷詞工具。 如需詳細資訊，請參閱 Microsoft SQL Server 2012 安裝說明中的＜全文檢索搜尋升級＞主題。

    • 如果您很重視重新叫用精確度，而且使用了已經在 SQL Server 2008 中改善的其中一個斷詞工具，則適合進行重建。

  • 是否有任何全文檢索索引建立在整數全文檢索索引鍵資料行上？

    重建會執行內部最佳化，以便在某些情況中改善已升級之全文檢索索引的查詢效能。 具體而言，如果您擁有包含全文檢索索引的全文檢索目錄，其中基底資料表的全文檢索索引鍵資料行是整數資料類型，則重建會在升級之後達到理想的全文檢索查詢效能。 在此情況中，我們強烈建議您使用 [重建] 選項。

    附註 附註

    若為 Microsoft SQL Server 2012 中的全文檢索索引，我們建議當做全文檢索索引鍵的資料行必須是整數資料類型。 如需詳細資訊，請參閱《Microsoft SQL Server 2012 線上叢書》中的＜效能微調與最佳化 (全文檢索搜尋)＞主題。

  • 將伺服器執行個體保持在線上狀態的優先權為何？

    在升級期間匯入或重建會耗用大量 CPU 資源，因而延遲將其餘伺服器執行個體升級並保持在線上狀態的時間。 如果盡可能將伺服器執行個體保持在線上狀態很重要，而且您願意在升級之後執行手動母體擴展，則適合使用 [重設]。


完成 - 安裝

[image]

完成 - 安裝
請參閱 傳送回函

按一下 [關閉] 完成安裝。

請參閱

概念

驗證 SQL Server 安裝


安裝的必要條件

[image]

安裝的必要條件
傳送回函

為了讓 SQL Server 能夠安裝成功，安裝電腦上必須有下列軟體元件。 SQL Server 安裝程式會安裝它們：

  • .NET Framework 4.0 版，適用於所有版本的Microsoft SQL Server 2012

  • SQL Server 安裝程式支援檔案

  • SQL Server Native Client

附註 附註

如果安裝程式失敗或取消，並不會移除這些元件。 若要移除它們，請使用 [控制台] 的 [新增或移除程式]。

選項

若要安裝必要條件檔案，請按一下 [安裝]。 若要結束安裝，請按一下 [取消]。


安裝進度

[image]

安裝進度
請參閱 傳送回函

請使用 SQL Server 安裝精靈的 [安裝進度] 頁面來監視 SQL Server 安裝程式的狀態。

請參閱

概念

檢視與讀取 SQL Server 安裝程式記錄檔


安裝類型

[image]

安裝類型
傳送回函

使用 SQL Server 安裝精靈的 [安裝類型] 頁面，即可指定要安裝新的 SQL Server 執行個體，或是將功能加入至現有的執行個體。

選項

選取指定您選擇的選項按鈕：

  • 執行 SQL Server 的新安裝

  • 將功能加入到現有的 SQL Server 執行個體

    如果您選取將功能加入至現有執行個體的選項，請使用下拉式清單來選取要更新的 SQL Server 執行個體。

您可以單獨將 SysPrep 支援的功能 (Database Engine 和 Reporting Services) 加入至備妥的 SQL Server 映像。 當備妥的執行個體完成之後，您就可以加入其他 SysPrep 不支援的功能。

注意：在容錯移轉叢集執行個體安裝完成之後，您就無法將功能加入至其中。 若要將 SQL Server 功能加入至現有的容錯移轉叢集，您必須執行新的安裝來安裝個別的 SQL Server 執行個體。


執行個體組態

[image]

執行個體組態
傳送回函

請使用 SQL Server 安裝精靈的 [執行個體組態] 頁面，指定要建立 SQL Server 的預設執行個體還是具名執行個體。 如果尚未安裝 SQL Server 的執行個體，則除非您指定具名執行個體，否則將會建立預設執行個體。

每個 SQL Server 執行個體都包含一組不同的服務，而這些服務對於定序和其他選項具有特定設定。 目錄結構、登錄結構和服務名稱都反映出在 SQL Server 安裝期間建立的執行個體名稱和特定的執行個體識別碼。

執行個體是預設執行個體或具名執行個體。 預設執行個體名稱是 MSSQLSERVER。 它不需要用戶端指定執行個體名稱來進行連接。 具名執行個體由使用者在安裝期間決定。 您可以將 SQL Server 安裝為具名執行個體，而不需要先安裝預設執行個體。 一次只有一個 SQL Server 安裝 (不論版本為何) 可以是預設執行個體。

附註 附註

透過 SQL Server SysPrep，當您完成備妥的執行個體時，就可以在 [執行個體組態] 頁面上指定執行個體名稱。 如果電腦上沒有任何現有的 SQL Server 預設執行個體，您就可以選擇將所完成的備妥執行個體設定為預設執行個體。

多個執行個體

SQL Server 支援單一伺服器或處理器上的多個 SQL Server 執行個體，但是只有一個執行個體可以是預設執行個體； 其他所有的執行個體都必須是具名執行個體。 電腦可同時執行 SQL Server 的多個執行個體，每一個執行個體的執行與其他執行個體無關。

如需詳細資訊，請參閱＜SQL Server 的最大容量規格＞。

選項

僅限容錯移轉叢集執行個體 - 指定 SQL Server 容錯移轉叢集網路名稱。 這個名稱會在網路上識別容錯移轉叢集執行個體。

預設或具名執行個體 - 在決定要安裝 SQL Server 的預設執行個體還是具名執行個體時，請考量以下資訊：

  • 如果您計劃在資料庫伺服器上安裝單一 SQL Server 執行個體，它應該是預設執行個體。

  • 當您打算在相同電腦上擁有多個執行個體時，請使用具名執行個體。 一個伺服器只能主控一個預設執行個體。

  • 安裝 SQL Server Express 的任何應用程式都應該將它安裝為具名執行個體。 這種作法可以減少將多個應用程式安裝在相同電腦時所造成的衝突。

預設執行個體

選取這個選項可安裝 SQL Server 的預設執行個體。 電腦只能主控一個預設執行個體；所有其他執行個體都必須加以命名。 不過，如果您已安裝 SQL Server 的預設執行個體，您可將 Analysis Services 的預設執行個體加入相同電腦中。

具名執行個體

選取這個選項可建立新的具名執行個體。 當您為 SQL Server 的執行個體命名時，請注意以下事項：

  • 執行個體名稱不區分大小寫。

  • 執行個體名稱不能以底線 (_) 開始或結束。

  • 執行個體名稱不得包含 "Default" 一詞或其他保留關鍵字。 如果在執行個體名稱中使用了保留關鍵字，會發生安裝程式錯誤。 如需詳細資訊，請參閱＜保留關鍵字＞。

  • 如果您為執行個體名稱指定 MSSQLServer，將會建立預設執行個體。 如果您在 SQL Server Express 中指定 SQLExpress 當做執行個體名稱，將會建立預設執行個體。

  • 安裝 Microsoft SQL Server 2012 PowerPivot for SharePoint 時，一律會安裝成 'PowerPivot' 的具名執行個體。 您無法針對這個功能角色指定不同的執行個體名稱。

  • 執行個體名稱限制為 16 個字元。

  • 執行個體名稱中的第一個字元必須是字母。 可接受的字母是由 Unicode Standard 2.0 所定義的字母。 這些包括拉丁字元 a-z、A-Z 及其他語言的字母字元。

  • 後續字元可以是 Unicode 標準 2.0 定義的字母、基本拉丁文或其他國家 (地區) 指令碼中的十進位數字、錢幣符號($) 或底線 (_)。

  • 執行個體名稱中不允許內嵌空格或其他特殊字元。 此外，也不允許反斜線 (\)、逗號 (,)、冒號 (:)、分號 (;)、單引號 (')、連字號 (&) 和 At 符號 (@)。

    附註 附註

    只有目前 Windows 字碼頁中有效的字元，才可以用於 SQL Server 執行個體名稱。 如果使用不受支援的 Unicode 字元，將會發生安裝程式錯誤。

偵測到的執行個體和功能

在執行 SQL Server 安裝程式的電腦上檢視已安裝的 SQL Server 執行個體和元件的清單。

執行個體識別碼 - 根據預設，此執行個體名稱會當做執行個體識別碼使用。 這是用來識別 SQL Server 執行個體的安裝目錄和登錄機碼。 這是預設執行個體和具名執行個體的狀況。 如果是預設執行個體，執行個體名稱和執行個體識別碼將會是 MSSQLSERVER。 若要使用非預設的執行個體識別碼，請在 [執行個體識別碼] 欄位中指定它。

重要事項 重要事項

透過 SQL Server SysPrep，顯示在這個頁面上的執行個體識別碼就是 SQL Server SysPrep 程序之準備映像步驟期間所指定的執行個體識別碼。 您無法在完成映像步驟期間指定不同的執行個體識別碼。

附註 附註

不支援以底線 (_) 為開頭或是包含數字符號 (#) 或貨幣符號 ($) 的執行個體識別碼。

如需有關目錄、檔案位置和執行個體識別碼命名的詳細資訊，請參閱＜SQL Server 的預設和具名執行個體的檔案位置＞。

執行個體根目錄 - 根據預設，執行個體根目錄為 C:\Program Files\Microsoft SQL Server\。 若要指定非預設的根目錄，請按一下 [瀏覽] 按鈕，或是提供路徑名稱。

給定 SQL Server 執行個體的所有元件都會當做一個單位來管理。 所有的 SQL Server Service Pack 和升級項目都會套用至 SQL Server 執行個體的每一個元件。

所有共用相同執行個體名稱之 SQL Server 的所有元件，都必須符合下列準則：

  • 相同版本

  • 相同修訂版

  • 相同語言設定

  • 相同叢集狀態

    附註 附註

    Reporting Services 無法識別叢集。

  • 相同作業系統


執行個體選取範圍 (解除安裝)

[image]

執行個體選取範圍 (解除安裝)
傳送回函

您可以在 [執行個體選取範圍 - 解除安裝] 頁面上，使用下拉式方塊來指定要解除安裝的 SQL Server 執行個體。

選項

您可以指定整個 SQL Server 執行個體，也可以指定只解除安裝共用功能和管理工具。


執行個體選取範圍 (升級)

[image]

執行個體選取範圍 (升級)
傳送回函

使用 [執行個體選取範圍 (升級)] 頁面，即可指定要升級的 SQL Server 執行個體。

選項

您必須同時升級執行個體的所有元件。 您無法在升級期間加入或移除功能。


要升級的執行個體

[image]

要升級的執行個體
請參閱 傳送回函

請使用 SQL Server 安裝精靈的 [要升級的執行個體] 頁面，指定您想要升級到 Microsoft SQL Server 2012 的 SQL Server 2005、SQL Server 2008 或 SQL Server 2008 R2 執行個體。

選項

使用選項按鈕指定您是要升級 SQL Server 執行個體和它的共用元件，還是只升級共用元件。 此 SQL Server 版本的共用元件為以下項目：

  • Integration Services

  • SQL Server Browser

  • SQL Server Active Directory Helper

  • SQL Writer

如需有關支援升級狀況和升級已知問題的詳細資訊，請參閱＜版本與版別的升級＞。

請參閱

其他資源

使用 Upgrade Advisor 來準備升級
使用 SQL Server 的多個版本


解除安裝之後

[image]

解除安裝之後
傳送回函

使用 [解除安裝之後] 頁面，即可確認此作業已順利完成。


準備映像進度

[image]

準備映像進度
請參閱 傳送回函

請使用 SQL Server 安裝精靈的 [準備映像進度] 頁面來監視 SQL Server 映像準備安裝的狀態。 完成此步驟之後，這個頁面將會列出在這個程序期間備妥之每個 SQL Server 功能的狀態。

請參閱

概念

檢視與讀取 SQL Server 安裝程式記錄檔


準備影像規則

[image]

準備影像規則
傳送回函

在 SQL Server 安裝程式的作業完成之前，此安裝程式會驗證您的電腦組態。 在 SQL Server 安裝期間，System Configuration Checker (SCC) 會掃描將安裝 SQL Server 的電腦。 SCC 會檢查是否有任何狀況阻止 SQL Server 安裝作業成功。 在安裝程式啟動精靈之前，SCC 會擷取每一個項目的狀態。 然後它會比較所需條件的結果，並提供解決封鎖問題的指引。

系統組態檢查會產生報告，其中包含每個已執行規則以及執行狀態的簡短描述。 系統組態檢查報告位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

執行安裝作業之前，請檢閱下列主題：

  1. 安裝 SQL Server 的硬體和軟體需求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各版本支援的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server 安裝的安全性考量(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的地區語言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他參考資料：

  1. 支援的版本與版本升級(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安裝容錯移轉叢集之前(http://go.microsoft.com/fwlink/?LinkId=235034)


準備映像類型

[image]

準備映像類型
傳送回函

使用 SQL Server 安裝精靈的 [準備映像類型] 頁面，即可指定要安裝新的 Microsoft SQL Server 2012 執行個體，或是將功能加入至現有的執行個體。

選項

選取指定您選擇的選項按鈕：

  • 準備新的 Microsoft SQL Server 2012 執行個體

  • 將功能加入到現有備妥的 Microsoft SQL Server 2012 執行個體

    如果您選取將功能加入至現有執行個體的選項，請使用下拉式清單來選取要更新的備妥 SQL Server 執行個體。

    附註 附註

    您可以將 SQL Server SysPrep 支援的功能 (Database Engine 和 Reporting Services) 加入至備妥的 SQL Server 映像。 只有當備妥的執行個體完成之後，您才能加入其他 SQL Server SysPrep 不支援的功能。


產品金鑰

[image]

產品金鑰
傳送回函

使用 [產品金鑰] 頁面，即可驗證 SQL Server 的執行個體，或是指定要安裝哪一個免費的 SQL Server 版本。

選項

若要指定免費的 SQL Server 版本，請選取免費安裝的選項按鈕，然後使用下拉式方塊來識別要安裝哪一個版本。

若要驗證付費的 SQL Server 版本，請選取產品金鑰的選項按鈕，然後在提供的空間內輸入您的金鑰。

若為容錯移轉叢集安裝，請針對每個容錯移轉叢集節點使用相同的產品金鑰。 如果產品金鑰來自不同的 SQL Server 版本，就會發生錯誤。


進度 (解除安裝)

[image]

進度 (解除安裝)
請參閱 傳送回函

使用 [進度 (解除安裝)] 頁面，即可監視安裝程式的進度。

請參閱

概念

檢視與讀取 SQL Server 安裝程式記錄檔


準備好要完成映像

[image]

準備好要完成映像
傳送回函

[準備開始完成映像] 頁面會提供套用至備妥執行個體之組態的組態設定摘要。

選項

這個頁面含有下列選項：

  • 若要繼續安裝，請按一下 [安裝]。

  • 若要變更安裝設定，請按 [上一步]。

  • 若要結束安裝程式，請按一下 [取消]。


安裝準備就緒

[image]

安裝準備就緒
請參閱 傳送回函

[準備安裝] 頁面會提供 SQL Server 安裝程式所要安裝或變更之功能的摘要。

選項

這個頁面含有下列選項：

  • 若要繼續安裝，請按一下 [安裝]。

  • 若要變更安裝設定，請按 [上一步]。

  • 若要結束安裝程式，請按一下 [取消]。

請參閱

概念

檢視與讀取 SQL Server 安裝程式記錄檔


準備好要預備映像

[image]

準備好要預備映像
傳送回函

[準備開始預備映像] 頁面會提供將由 SQL Server 安裝程式準備之功能的摘要。

選項

這個頁面含有下列選項：

  • 若要繼續安裝，請按一下 [安裝]。

  • 若要變更安裝設定，請按 [上一步]。

  • 若要結束安裝程式，請按一下 [取消]。


已完成修復準備工作

[image]

已完成修復準備工作
請參閱 傳送回函

[已完成修復準備工作] 頁面會提供 SQL Server 安裝程式之修復程序的摘要。

選項

這個頁面含有下列選項：

  • 若要繼續安裝，請按一下 [修復]。

  • 若要變更安裝設定，請按 [上一步]。

  • 若要結束安裝程式，請按一下 [取消]。

請參閱

概念

檢視與讀取 SQL Server 安裝程式記錄檔


移除 SQL Server 容錯移轉叢集節點

[image]

移除 SQL Server 容錯移轉叢集節點
傳送回函

使用 [移除容錯移轉叢集節點] 頁面，即可識別要當做 Microsoft SQL Server 2012 容錯移轉叢集節點移除的電腦。


修復進度

[image]

修復進度
請參閱 傳送回函

請使用 SQL Server 安裝精靈的 [修復進度] 頁面來監視 SQL Server 修復的狀態。

請參閱

概念

檢視與讀取 SQL Server 安裝程式記錄檔


Reporting Services 組態選項 (SSRS)

[image]

Reporting Services 組態選項 (SSRS)
請參閱 傳送回函

您可以使用 Microsoft SQL Server 安裝精靈的 [Reporting Services 組態] 頁面來指定報表伺服器的安裝和設定方式。 某個安裝選項的可用與否，取決於您先前在 [特徵選取] 頁面上選擇的選項，以及在安裝報表伺服器時是否也一併安裝 SQL Server Database Engine 的本機執行個體。

在某些情況下，如果安全通訊端層 (SSL) 憑證安裝在電腦上，並繫結至強式萬用字元，則安裝程式將會使用 HTTPS 前置詞建立 Reporting Services URL。 如需憑證如何對應到 Reporting Services URL 的詳細資訊，請參閱《SQL Server 線上叢書》中的設定安全通訊端層 (SSL) 連接的報表伺服器 (http://go.microsoft.com/fwlink/?LinkId=199089)。

如需有關 Reporting Services 以及這個版本之安裝和組態的最新資訊，請參閱其他安裝資訊 (http://go.microsoft.com/fwlink/?LinkId=207425)。

選項

Reporting Services 原生模式

如果安裝程式因一項或多項需求不符而無法執行預設報表伺服器組態，安裝精靈可讓您執行最小安裝選項。它會複製您需要的檔案，不過，安裝完成之後，您必須利用 Reporting Services 組態管理員來設定原生模式報表伺服器。

附註 附註

如果您選擇預設安裝選項的其中一個，現有的報表伺服器資料庫檔案會導致安裝失敗。 當您選擇預設安裝選項時，安裝程式會嘗試使用預設名稱來建立報表伺服器資料庫。 如果已有該名稱的資料庫存在，則安裝程式將會失敗，而且您必須回復安裝。 若要避免這個問題，則可在執行安裝程式之前重新命名現有的資料庫，或選擇 [只安裝] 選項，讓您可在安裝完成之後指定自訂資料庫設定。

安裝和設定

使用報表伺服器資料庫、服務帳戶和 URL 保留項目的預設值，以原生模式安裝報表伺服器執行個體。 當您選擇這個選項時，安裝完成之後，報表伺服器執行個體便已備妥，隨時可以使用。 安裝程式會利用本機 Database Engine 執行個體來建立報表伺服器資料庫，並會將報表伺服器設定成使用預設值。

報表伺服器安裝架構所用的預設值必須對您的系統有效，您才能使用這個選項。 這個選項適合想要在本機安裝所有元件的開發人員以及要試用本軟體的使用者。

若要檢視有關安裝程式所使用之預設值的資訊，或是要了解無法安裝預設組態的原因，請按一下 [詳細資料]。 如需有關原生模式報表伺服器之預設組態的詳細資訊，請參閱原生模式安裝的預設組態 (Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199091)。

只安裝

安裝報表伺服器程式檔、建立報表伺服器服務帳戶，以及註冊報表伺服器 Windows Management Instrumentation (WMI) 提供者。 這個安裝選項稱為「僅限檔案」的安裝。 如果您不想要使用預設組態，請選取這個選項。 如果無法安裝預設組態，或者您要安裝包含 Reporting Services 的 SQL Server 容錯移轉叢集，這就是唯一可用的選項。如需有關僅限檔案安裝的詳細資訊，請參閱僅限檔案安裝 (Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199093)。

安裝完成之後，您必須建立報表伺服器資料庫以及設定報表伺服器，之後，才能使用它。 若要設定報表伺服器和建立資料庫，請使用 Reporting Services 組態管理員。 如需詳細資訊，請參閱如何：建立報表伺服器資料庫 (Reporting Services 組態) (http://go.microsoft.com/fwlink/?LinkId=199094) 及設定報表伺服器資料庫連接 (http://go.microsoft.com/fwlink/?LinkId=199095)。

Reporting Services SharePoint 模式

只安裝

安裝報表伺服器程式檔案和 PowerShell 指令程式。 安裝完成之後，您必須啟動 Reporting Services SharePoint 服務並建立 Reporting Services 服務應用程式。 如需詳細資訊，請參閱針對 SharePoint 整合安裝和設定 Reporting Services 服務的概觀 (http://go.microsoft.com/fwlink/?LinkId=207543)、建立 SQL Server Reporting Services 服務應用程式 (SSRS) (http://go.microsoft.com/fwlink/?LinkId=207544)，以及Reporting Services 和 SharePoint 整合的概觀 (http://go.microsoft.com/fwlink/?LinkID=207244)。

安裝適用於 SharePoint 技術的 Reporting Services 增益集

從 Microsoft SQL Server 2012 版本開始，您可以在 SQL Server 安裝精靈的 [特徵選取] 頁面中，將增益集當做 SQL Server 安裝的一部分來安裝。

不過，您也可以使用下列其中一種方法來安裝適用於 SharePoint 2010 的 Reporting Services 增益集：

  • 執行 SharePoint 2010 產品準備工具 PreRequisiteInstaller.exe。

  • 從 SQL Server 安裝媒體安裝。 在 SQL Server 安裝完成之後，按一下 SQL Server 安裝媒體上 Setup 資料夾中的 rsSharePoint.msi 檔案。

  • 下載和安裝增益集。 如需詳細資訊，請參閱尋找適用於 SharePoint 產品之 Reporting Services 增益集的位置 (http://go.microsoft.com/fwlink/?LinkID=208634)。

請參閱

其他資源

如何：啟動 Reporting Services 組態管理員
如何：建立報表伺服器資料庫 (Reporting Services 組態)
安裝 Reporting Services 的考量
原生模式安裝的預設組態 (Reporting Services)
SharePoint 模式的預設組態 (Reporting Services)
從命令提示字元安裝 SQL Server


Reporting Services SharePoint 模式升級 (SSRS)

[image]

Reporting Services SharePoint 模式升級 (SSRS)
請參閱 傳送回函

請使用 [Reporting Services SharePoint 模式] 頁面，以確認所有共用功能的升級。 Reporting Services SharePoint 模式是 SQL Server 共用功能，會隨著所有其他 SQL Server 共用功能一起升級。 SQL Server 安裝精靈不支援只升級一個共用功能。 所有 SQL Server 共用功能都會同時升級。

選項

唯有在選取了 [繼續升級] 核取方塊之後，[下一步] 按鈕才可以使用。 如果未選取此核取方塊，則無法繼續升級。

如需詳細資訊，請參閱 SharePoint 整合模式的預設組態 (Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199092)。

請參閱

概念

檢視與讀取 SQL Server 安裝程式記錄檔

其他資源

從命令提示字元安裝 SQL Server


Reporting Services SharePoint 模式驗證

[image]

Reporting Services SharePoint 模式驗證
請參閱 傳送回函

您可以使用 Microsoft SQL Server 安裝精靈的 [Reporting Services SharePoint 模式驗證] 頁面，來指定目前 Reporting Services 安裝中所用服務帳戶的認證。 認證將會用於建立新的 SharePoint 應用程式集區。 此外，也會建立一個新的 Reporting Services SharePoint 服務應用程式 服務應用程式名稱會包含上一個 Reporting Services 執行個體的名稱。

選項

  • [SSRS 應用程式集區帳戶名稱] 選項是唯讀的。 此值是用您所升級的現有 Reporting Services 安裝中的目前值來自動填入。

  • 如果應用程式集區帳戶不需要密碼，[SSRS 應用程式集區帳戶密碼] 選項就會停用。 例如，"NT Authority\NetworkSerivce"。 如果應用程式集區帳戶需要密碼，您必須輸入正確密碼，才能繼續升級。

如需詳細資訊，請參閱 SharePoint 整合模式的預設組態 (Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199092)。

請參閱

其他資源

Reporting Services 升級


選取備妥的執行個體

[image]

選取備妥的執行個體
傳送回函

使用 [選取備妥的執行個體] 頁面，即可指定您想要完成的備妥執行個體。

選項

[選取執行個體識別碼] 方塊會列出您可以完成的備妥執行個體。 請選取您想要完成的備妥執行個體。

選取執行個體識別碼

此清單包含您可以在執行 SQL Server 安裝程式之電腦上完成的所有備妥執行個體。 請選取您想要完成的備妥執行個體。

安裝的執行個體

這包括已安裝、備妥以及完成的執行個體。


伺服器組態 - 定序

[image]

伺服器組態 - 定序
傳送回函

在 SQL Server 安裝精靈的 [伺服器組態 - 定序] 頁面上，您可以修改 Database Engine 和 Analysis Services 用於排序的定序設定。 選取選項來比對 SQL Server 或另一部電腦之不同安裝的定序設定。

選項

針對 SQL Server 和 Analysis Services 而自訂

SQL Server 提供了兩組定序：Windows 定序和 SQL Server 定序。 您可以對 Database Engine 和 Analysis Services 指定個別的定序設定，也可以對這兩者指定相同的定序。

根據預設，系統會針對 US-English 系統地區設定選取 SQL Server 定序。 當地語系化 SQL Server 版本的預設定序是由電腦的 Windows 系統地區設定所決定。 如需詳細資訊，請參閱＜Using SQL Collations＞。

只有當這個 SQL Server 安裝的定序設定必須符合 SQL Server 的另一個執行個體所使用的定序設定，或是定序設定必須符合另一部電腦的 Windows 系統地區設定時，您才應該變更預設設定。

附註 Analysis Services 只會使用 Windows 定序。 如果您打算安裝 Analysis Services，請在 SQL Server 安裝期間選取 Windows 定序，以便確保 SQL Server Database Engine 與 Analysis Services 之間產生一致的結果。

如需詳細資訊，請參閱＜安裝程式中的定序設定＞。

最佳做法

如需 Windows 系統地區設定和 SQL Server 安裝程式所使用之對應預設定序的表格，請參閱＜安裝程式中的定序設定＞。

如果可能的話，請針對組織使用單一定序。 這樣您就不需要針對每個資料庫、資料行、運算式或識別碼明確指定定序。 如果您必須使用多重定序和字碼頁設定，則在編寫查詢程式碼時，必須考量定序優先順序的規則。 如需詳細資訊，請參閱＜定序優先順序 (Transact-SQL)＞的線上叢書主題。

當您選取 SQL Server 的定序時，請考慮下列建議：

  • 如果可接受以二進位字碼指標為基礎的排序，請選取 BINARY2 定序。

  • 選取 Windows 定序以便跨資料類型進行一致的比較。

  • 為獲得更好的語言排序支援，請使用新的 100 層級定序。 如需詳細資訊，請參閱＜定序和 Unicode 支援＞。

  • 如果您計畫將資料庫移轉到升級的 SQL Server 執行個體，請選取符合您現有資料庫定序的定序。


伺服器組態 - 服務帳戶

[image]

伺服器組態 - 服務帳戶
請參閱 傳送回函

使用 SQL Server 安裝精靈的 [伺服器組態] 頁面，即可為 SQL Server 服務指派登入帳戶。 設定在這個頁面上的實際服務隨著您選取要安裝的功能而不同。

用來啟動並執行 SQL Server 的啟動帳戶可以是網域使用者帳戶、本機使用者帳戶、受管理的服務帳戶、虛擬帳戶或內建的系統帳戶。

選項

您可以將相同登入帳戶指派給所有 SQL Server 服務，或個別設定每一個服務帳戶。 此外，您也可以指定要自動啟動服務、手動啟動服務或停用服務。 大部分安裝都建議使用預設帳戶。

  • 在 Windows 7 和 Windows Server 2008 R2 上，大部分帳戶都預設為虛擬帳戶。

  • 在 Windows Vista 和 Windows Server 2008 上，大部分帳戶都預設為 NETWORK SERVICE 帳戶。

  • 在 Windows Server 2008 的叢集安裝上，您必須提供網域帳戶。

如果您將服務設定為使用網域帳戶，Microsoft 建議您個別設定服務帳戶，以便為每一個服務提供最低權限，其中 SQL Server 服務會被授與完成其工作所需的最低權限。 如需詳細資訊，包括帳戶類型的說明，請參閱＜設定 Windows 服務帳戶＞。

個別設定 SQL Server 服務帳戶 (建議選項)

使用此方格來為每一個 SQL Server 服務提供登入使用者名稱和密碼，並為該服務設定啟動類型。 您可以將內建系統帳戶、本機帳戶、本機群組、網域群組或是網域使用者帳戶用於 SQL Server 服務。

選取下列任何一項服務來自訂其設定。

選取這項服務

設定驗證設定

SQL Server Agent

執行作業、監視、SQL Server 及允許自動化管理工作的服務。

此服務沒有預設登入帳戶。

預設啟動類型為 [手動]。

SQL Server

SQL Server Database Engine。

預設啟動類型為 [自動]。

附註 附註

SQL Server Browser

SQL Server Browser 是提供 SQL Server 連接資訊給用戶端電腦的名稱解析服務。 這項服務會在多個 SQL Server 和 Integration Services 執行個體之間共用。

預設登入帳戶為 NT Authority\Local service，而且無法在 SQL Server 安裝期間加以變更。 您可以在安裝完成之後變更此帳戶。

如果沒有在安裝期間指定啟動類型，系統就會依照下列方式決定啟動類型：

  • SQL Server Browser 設定為 [自動] 並在下列所述的安裝狀況中執行：

    • SQL Server 容錯移轉叢集執行個體

    • 啟用 TCP 或 NP 的 SQL Server 具名執行個體

    • Analysis Server 的具名執行個體而且未建立叢集

  • 如果上述狀況都不適用，而且已經安裝 SQL Server Browser，就會維持 SQL Server Browser 的目前狀態。

  • 啟動類型設定為 [停用]，而且如果安裝之前現有的 SQL Server 2005、SQL Server 2008 或 SQL Server 2008 R2 執行個體不存在，就會停止。

Analysis Services

Analysis Services.

預設啟動類型為 [自動]。

若為 SharePoint 整合模式，您必須指定 Windows 網域使用者帳戶。 您所指定的帳戶會用於 Analysis Services 服務。 您針對目前執行個體所指定的帳戶也必須用於之後加入至相同伺服陣列的任何其他 Analysis Services 執行個體。

Reporting Services

Reporting Services. 服務帳戶是用來設定報表伺服器資料庫連接。 如果您想要使用預設驗證設定，請選擇內建的網路服務。 如果您指定網域使用者帳戶，並且正在報表伺服器上使用 Windows 驗證，請務必註冊此帳戶的服務主要名稱 (SPN)。 如需詳細資訊，請參閱＜如何：在 Reporting Services 中設定 Windows 驗證＞。

重要事項 重要事項

如果可以使用擁有較低權限的帳戶，Microsoft 建議您不要對 SQL Server 或 SQL Server Agent 服務使用網路服務帳戶，因為網路服務是可共用的帳戶。 只有當您可以確定電腦沒有安裝使用此帳戶的其他服務時，網路服務才適合當做 SQL Server 服務帳戶使用。 不是 Windows 管理員的本機使用者或網域使用者帳戶比較適合用於 SQL Server 服務。

預設啟動類型為 [自動]。

Integration Services

Integration Services 是一組圖形化工具和可程式化物件，用來移動、複製和轉換資料。

預設啟動類型為 [自動]。

SQL Server 全文檢索篩選背景程式啟動器

建立 fdhost.exe 處理序的服務。 這是主控處理全文檢索索引之文字資料的斷詞工具與篩選的必要項目。

如果您提供了用以執行 FDHOST 啟動器服務的網域帳戶，我們強烈建議您使用低權限帳戶。 這個帳戶應該與您用於 SQL Server 服務的帳戶不同。 在 Windows Vista 和 Windows Server 2008 上，FDHOST 啟動器服務帳戶預設為 LOCAL SERVICE。

SQL Server Distributed Replay Client

用於 Distributed Replay Client 服務的服務帳戶。

提供用以執行 Distributed Replay Client 服務的帳戶。 這個帳戶應該與您用於 SQL Server 服務的帳戶不同。

預設啟動類型為 [手動]。

SQL Server Distributed Replay Controller

用於 Distributed Replay Controller 服務的服務帳戶。

提供用以執行 Distributed Replay Controller 服務的帳戶。 這個帳戶應該與您用於 SQL Server 服務的帳戶不同。

預設啟動類型為 [手動]。

請參閱

其他資源

SQL Server 安裝的安全性考量


安裝程式角色

[image]

安裝程式角色
請參閱 傳送回函

您可以使用此頁面來指定要使用 [特徵選取] 頁面選取個別功能，還是使用安裝程式角色進行安裝。

setup role 是所有功能與共用元件實作預先定義之 SQL Server 組態所需的固定選項。

選項

SQL Server 功能安裝

選擇此選項來選取個別功能與共用元件。 執行個體功能包括 Database Engine Services、Analysis Services (原生模式) 和 Reporting Services。

SQL Server PowerPivot for SharePoint

選擇此選項將 Analysis Services 伺服器元件安裝在 SharePoint 2010 伺服陣列中。 此選項會在伺服陣列中部署 PowerPivot 系統服務與 Analysis Services 伺服器，讓您針對包含內嵌 PowerPivot 資料的已發行 Excel 活頁簿進行查詢與資料處理。

如果需要關聯式資料庫引擎執行個體以裝載 SharePoint 伺服器陣列的資料庫，可以選擇在安裝中新增關聯式資料庫引擎執行個體。 如果已設定伺服器陣列，您就可以略過此選項。

安裝完成後，必須使用下列其中一個方法設定軟體：PowerPivot 配置工具、PowerShell 指令程式或 SharePoint 2010 管理中心。 相對於舊版，安裝程式不再執行 PowerPivot 安裝的任何組態工作。

以角色為基礎的安裝不包含 SQL Server PowerPivot for Excel 用戶端應用程式。 用戶端應用程式要另外安裝。

具有預設值的所有功能

選擇此安裝程式角色來安裝可用於此版本的所有功能。 請注意，這個角色中會排除 PowerPivot for SharePoint。 您必須使用 PowerPivot for SharePoint 安裝程式角色來安裝該功能。

Database Engine 設定為使用 NT AUTHORITY\NETWORK SERVICE 帳戶啟動。 目前的使用者將會當做 SQL Server sysadmin 角色的成員提供。 此選項所設定的值可透過指定其他命令行參數來覆寫。

在 Windows Vista 或 Windows Server 2008 或更新版本上，以及當作業系統不是網域控制站時，Database Engine 和 Reporting Services 預設會使用 NTAUTHORITY\NETWORK SERVICE 帳戶、Integration Services 會使用 NTAUTHORITY\NETWORK SERVICE 帳戶，而 SQL 全文檢索篩選背景程式啟動器則會使用 NTAUTHORITY\LOCAL SERVICE 帳戶。

請參閱

參考

特徵選取

其他資源

安裝 PowerPivot for SharePoint
硬體和軟體需求 (PowerPivot for SharePoint)


SQL Server 容錯移轉叢集精靈 - 完成

[image]

SQL Server 容錯移轉叢集精靈 - 完成
請參閱 傳送回函

在 SQL Server 安裝程式的作業完成之前，此安裝程式會驗證您的電腦組態。 在 SQL Server 安裝期間，System Configuration Checker (SCC) 會掃描將安裝 SQL Server 的電腦。 SCC 會檢查是否有任何狀況阻止 SQL Server 安裝作業成功。 在安裝程式啟動 SQL Server 安裝精靈以前，SCC 會擷取每一個項目的狀態。 然後它會比較所需條件的結果，並提供解決封鎖問題的指引。

系統組態檢查會產生報告，其中包含每個已執行規則以及執行狀態的簡短描述。 系統組態檢查報告位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

執行安裝作業之前，請檢閱下列主題：

  1. 安裝 SQL Server 的硬體和軟體需求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各版本支援的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server 安裝的安全性考量(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的地區語言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他參考資料：

  1. 支援的版本與版本升級(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安裝容錯移轉叢集之前(http://go.microsoft.com/fwlink/?LinkId=235034)

請參閱

參考

安裝程式支援檔案


SQL Server 容錯移轉叢集精靈 - 安裝

[image]

SQL Server 容錯移轉叢集精靈 - 安裝
請參閱 傳送回函

在 SQL Server 安裝程式的作業完成之前，此安裝程式會驗證您的電腦組態。 在 SQL Server 安裝期間，System Configuration Checker (SCC) 會掃描將安裝 SQL Server 的電腦。 SCC 會檢查是否有任何狀況阻止 SQL Server 安裝作業成功。 在安裝程式啟動 SQL Server 安裝精靈以前，SCC 會擷取每一個項目的狀態。 然後它會比較所需條件的結果，並提供解決封鎖問題的指引。

系統組態檢查會產生報告，其中包含每個已執行規則以及執行狀態的簡短描述。 系統組態檢查報告位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

執行安裝作業之前，請檢閱下列主題：

  1. 安裝 SQL Server 的硬體和軟體需求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各版本支援的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server 安裝的安全性考量(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的地區語言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他參考資料：

  1. 支援的版本與版本升級(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安裝容錯移轉叢集之前(http://go.microsoft.com/fwlink/?LinkId=235034)

請參閱

參考

安裝程式支援檔案


SQL Server 容錯移轉叢集精靈 - 準備

[image]

SQL Server 容錯移轉叢集精靈 - 準備
請參閱 傳送回函

在 SQL Server 安裝程式的作業完成之前，此安裝程式會驗證您的電腦組態。 在 SQL Server 安裝期間，System Configuration Checker (SCC) 會掃描將安裝 SQL Server 的電腦。 SCC 會檢查是否有任何狀況阻止 SQL Server 安裝作業成功。 在安裝程式啟動 SQL Server 安裝精靈以前，SCC 會擷取每一個項目的狀態。 然後它會比較所需條件的結果，並提供解決封鎖問題的指引。

系統組態檢查會產生報告，其中包含每個已執行規則以及執行狀態的簡短描述。 系統組態檢查報告位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

執行安裝作業之前，請檢閱下列主題：

  1. 安裝 SQL Server 的硬體和軟體需求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各版本支援的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server 安裝的安全性考量(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的地區語言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他參考資料：

  1. 支援的版本與版本升級(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安裝容錯移轉叢集之前(http://go.microsoft.com/fwlink/?LinkId=235034)

請參閱

參考

安裝程式支援檔案


摘要 (升級)

[image]

摘要 (升級)
傳送回函

使用 [摘要] 頁面，即可檢視針對這個升級所指定的選項。


安裝程式支援檔案

[image]

安裝程式支援檔案
傳送回函

在 SQL Server 安裝程式的作業完成之前，此安裝程式會驗證您的電腦組態。 在 SQL Server 安裝期間，System Configuration Checker (SCC) 會掃描將安裝 SQL Server 的電腦。 SCC 會檢查是否有任何狀況阻止 SQL Server 安裝作業成功。 在安裝程式啟動 SQL Server 安裝精靈以前，SCC 會擷取每一個項目的狀態。 然後它會比較所需條件的結果，並提供解決封鎖問題的指引。

系統組態檢查會產生報告，其中包含每個已執行規則以及執行狀態的簡短描述。 系統組態檢查報告位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

執行安裝作業之前，請檢閱下列主題：

  1. 安裝 SQL Server 的硬體和軟體需求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各版本支援的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server 安裝的安全性考量(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的地區語言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他參考資料：

  1. 支援的版本與版本升級(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安裝容錯移轉叢集之前(http://go.microsoft.com/fwlink/?LinkId=235034)

其他規則主題

請參閱下列主題中有關特定狀況的安裝程式規則：

  • 安裝規則

  • 升級規則檢查

  • 版本升級規則

  • 解除安裝規則

  • 準備影像規則

  • 完成影像規則


解除安裝規則

[image]

解除安裝規則
請參閱 傳送回函

[解除安裝規則] 頁面將會執行一組規則來確保安裝程式作業可以順利完成。

在 SQL Server 安裝程式的作業完成之前，此安裝程式會驗證您的電腦組態。 在 SQL Server 安裝期間，System Configuration Checker (SCC) 會掃描將安裝 SQL Server 的電腦。 SCC 會檢查是否有任何狀況阻止 SQL Server 安裝作業成功。 在安裝程式啟動 SQL Server 解除安裝精靈以前，SCC 會擷取每一個項目的狀態。 然後它會比較所需條件的結果，並提供解決封鎖問題的指引。

系統組態檢查會產生報告，其中包含每個已執行規則以及執行狀態的簡短描述。 系統組態檢查報告位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

執行安裝作業之前，請檢閱下列主題：

  1. 安裝 SQL Server 的硬體和軟體需求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各版本支援的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server 安裝的安全性考量(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的地區語言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他參考資料：

  1. 支援的版本與版本升級(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安裝容錯移轉叢集之前(http://go.microsoft.com/fwlink/?LinkId=235034)

請參閱

參考

安裝程式支援檔案


升級進度

[image]

升級進度
請參閱 傳送回函

請使用 SQL Server 安裝精靈的 [升級進度] 頁面來監視 SQL Server 升級的狀態。

請參閱

概念

檢視與讀取 SQL Server 安裝程式記錄檔


升級規則檢查

[image]

升級規則檢查
請參閱 傳送回函

在 SQL Server 安裝程式的作業完成之前，此安裝程式會驗證您的電腦組態。 在 SQL Server 安裝期間，System Configuration Checker (SCC) 會掃描將安裝 SQL Server 的電腦。 SCC 會檢查是否有任何狀況阻止 SQL Server 安裝作業成功。 在安裝程式啟動升級精靈之前，SCC 會擷取每一個項目的狀態。 然後它會比較所需條件的結果，並提供解決封鎖問題的指引。

系統組態檢查會產生報告，其中包含每個已執行規則以及執行狀態的簡短描述。 系統組態檢查報告位於 %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

執行安裝作業之前，請檢閱下列主題：

  1. 安裝 SQL Server 的硬體和軟體需求 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server 各版本支援的功能(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server 安裝的安全性考量(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server 中的地區語言版本(http://go.microsoft.com/fwlink/?LinkId=235027)

其他參考資料：

  1. 支援的版本與版本升級(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. 安裝容錯移轉叢集之前(http://go.microsoft.com/fwlink/?LinkId=235034)

請參閱

參考

安裝程式支援檔案


確認解除安裝選項

[image]

確認解除安裝選項
傳送回函

確認您的選取，然後按 [下一步] 繼續進行。


您搜尋的主題無法使用

[image]

您搜尋的主題無法使用
傳送回函

安裝程式完成之後，您就可以檢視 SQL Server 的文件集，方法是按一下 [說明]、在對話方塊或介面元素中按下 F1 鍵，或是 (從 [開始] 功能表) 依序指向 [所有程式]、[Microsoft SQL Server]、[說明及社群]，然後按一下 [SQL Server 線上叢書]。 如需詳細資訊，請參閱＜加入和移除說明集合＞。