SQL Server 服務安裝概觀

[image]

SQL Server 服務安裝概觀
請參閱 傳送回函

您可以使用 SQL Server 2012 服務更新，將更新套用至任何已安裝的 SQL Server 2012 元件。如果現有 SQL Server 2012 元件的版本層級比更新版本層級還新，則安裝程式會將其排除在更新作業外。如需有關套用服務更新的詳細資訊，請參閱＜安裝 SQL Server 2012 服務更新＞(http://go.microsoft.com/fwlink/?LinkId=231297)。

當您安裝 SQL Server 2012 更新時，應該進行下列考量：

  • 您必須同時更新屬於 SQL Server 執行個體的所有功能。例如，更新 Database Engine 時，如果 Analysis Services 和 Reporting Services 元件與同一個 SQL Server 執行個體一起安裝，則您也必須更新這些元件。共用功能 (例如管理工具、SQL Server Data Tools (SSDT) 及 SQL Server Integration Services) 一律必須更新為最新的更新。如果未選取功能樹狀目錄中的元件或執行個體，便不會更新元件或執行個體。

  • 根據預設，SQL Server 2012 更新記錄檔會儲存到 %Program Files%\Microsoft SQL Server\110\Setup Bootstrap\LOG\。

  • SQL Server 安裝程式現在可以整合更新與原始媒體，以便同時執行原始媒體及更新。如需詳細資訊，請參閱 SQL Server 2012 安裝的產品更新 (英文) 和 SQL Server 安裝的新增功能 (http://go.microsoft.com/fwlink/?LinkID=219508)。

  • 套用 SQL Server 2012 服務更新之前，我們建議您考慮將資料備份。

  • 您可以透過 Microsoft Update 取得 SQL Server 更新。建議您定期掃描更新讓 SQL Server 的執行個體維持更新以及安全的狀態。SQL Server 2012SP1 會以完整 SQL Server 安裝的形式提供。這個版本並非以標準修補可執行檔封裝的形式提供要套用至 SQL Server 2012 RTM 執行個體的 Service Pack，而是提供安裝套件 (由 2 個檔案組成)。執行時，將會安裝已預先安裝 SP1 的新 SQL Server 2012 執行個體。如需詳細資訊，請參閱＜SQL Server 2012 SP1 完整安裝＞。

需求和已知問題

建議的磁碟空間需求大約是用於安裝、下載及擷取封裝之封裝大小的 2.5 倍。安裝 Service Pack 之後，您可以移除下載的封裝。任何暫存檔都會自動移除。

檢閱已知問題：如需有關目前版本已知問題的詳細資訊，請參閱這裡的對應版本資訊：SQL Server 版本資訊 (英文)。

安裝概觀

本節將討論累計更新和 Service Pack 的 SQL Server 2012 安裝，包括如何執行下列作業：

  • 準備安裝 SQL Server 2012 更新

  • 安裝 SQL Server 2012 更新

  • 重新啟動服務及應用程式

準備安裝 SQL Server 2012 更新

我們強烈建議您最好先執行以下作業再安裝 SQL Server 2012 更新：

  • 備份 SQL Server 系統資料庫：在安裝 SQL Server 2012 更新之前，請先備份 master、msdb 和 model 資料庫。安裝 SQL Server 2012 更新會變更這些資料庫，而使它們無法與舊版 SQL Server 2012 相容。如果您決定要重新安裝 SQL Server 2012 (不含這些更新)，則這些資料庫的備份就是必要項目。

    您也必須備份使用者資料庫。

    重要事項 重要事項

    將更新套用至參與複寫拓撲的 SQL Server 執行個體時，您必須先備份複寫資料庫以及系統資料庫，然後再套用更新。

  • 備份 Analysis Services 資料庫、組態檔和儲存機制：更新 Analysis Services 的執行個體之前，應該先備份下列項目：

    • Analysis Services 資料庫。根據預設，這些資料庫會安裝在 C:\Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Data\。如果是 WOW 安裝，預設路徑會是 C:\ProgramFiles (x86)\Microsft SQL Server\MSAS11.<InstanceID>\OLAP\Data\。

    • msmdsrv.ini 組態檔中的 Analysis Services 組態設定。根據預設，此檔案位於 C:\Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Config\ 目錄中。

    • (選擇性) 包含 Analysis Services 儲存機制的資料庫。只有在 Analysis Services 已設定成使用決策支援物件 (DSO) 程式庫時，才需要執行此步驟。

    附註 附註

    如果備份 Analysis Services 資料庫、組態檔和儲存機制時發生失敗，則無法將已更新的 Analysis Services 執行個體還原為舊版。

  • 確認系統資料庫擁有足夠的可用空間：如果未選取 master 和 msdb 系統資料庫的自動成長選項，則每個資料庫都至少必須擁有 500 KB 的可用空間。若要確認資料庫是否有足夠的空間，請在 master 和 msdb 資料庫上，執行 sp_spaceused 系統預存程序。如果其中一個資料庫的未配置空間少於 500 KB，請增加該資料庫的大小。

  • 停止服務和應用程式：若要避免系統可能重新啟動，請停止所有連接到正在升級之 SQL Server 執行個體的應用程式和服務，然後再安裝 SQL Server 2012 更新。這些包括 SQL Server Management Studio、SQL Server Data Tools (SSDT)。如需詳細資訊，請參閱啟動、停止、暫停、繼續、重新啟動 Database Engine、SQL Server Agent 或 SQL Server Browser 服務。

    附註 附註

    您無法停止容錯移轉叢集環境中的服務。如需詳細資訊，請參閱這個主題稍後的容錯移轉叢集安裝章節。

  • 為了排除在進行更新安裝之後重新啟動電腦的需求，安裝程式會顯示正在鎖定檔案之處理序的清單。如果更新安裝程式必須在安裝時結束某項服務，它會在安裝完成之後重新啟動該服務。

  • 如果安裝程式判斷在安裝時鎖定了檔案，則在安裝完成之後可能必須重新啟動電腦。如有必要，安裝程式會提示您重新啟動電腦。

安裝 SQL Server 2012 更新

本節將說明安裝程序。

重要事項 重要事項

您必須在即將安裝 SQL Server 2012 更新的電腦上，使用具有管理權限的帳戶來安裝更新。如果是本機安裝，您必須以系統管理員身分執行安裝程式。如果您是從遠端共用位置安裝 SQL Server，則必須使用對遠端共用位置具有讀取和執行權限的網域帳戶。

啟動 SQL Server 2012 更新

若要安裝 SQL Server 2012 更新，請執行自動解壓縮封裝檔案。

累計更新封裝 (CU)：<SQLServer2012>-KBxxxxxx-PPP.exe

Service Pack 封裝 (PCU)：<SQLServer2012><SPx> -KBxxxxxx-PPP-LLL.exe

  • x 表示 Service Pack 號碼

  • PPP 表示特定的平台

  • LLL 表示 SQL Server 語言的字元縮寫，例如：英文的 LLL 為 ENU。

若要將更新套用至屬於容錯移轉叢集一部分的 SQL Server 2012 元件，請參閱容錯移轉叢集安裝的章節。如需有關如何以自動模式來執行更新安裝的詳細資訊，請參閱從命令提示字元安裝更新。

SQL Server 2012 安裝的產品更新

產品更新是 SQL Server 2012 安裝程式的新功能。它可以整合最新產品更新與主要產品安裝，因此主要產品及其適用的更新可以同時安裝。產品更新可以搜尋 Microsoft Update、Windows Server Update Services (WSUS)、本機資料夾，或可用更新的網路共用。安裝程式找到最新版本的可用更新後，會使用目前的 SQL Server 安裝程序進行下載與整合。產品更新可以引入累計更新、Service Pack，或 Service Pack 加上累計更新。產品更新功能是 SQL Server 2008 PCU1 中可用之匯集功能的延伸模組。如需 SQL Server 2012 安裝程式中「產品更新」功能的詳細資訊，請參閱 SQL Server 2012 安裝的產品更新。

SQL Server 2012 SP1 完整安裝

SQL Server 2012 SP1 也會以完整 SQL Server 安裝套件的形式提供。SQL Server 2012 SP1 安裝套件將會安裝已預先安裝 SP1 的新 SQL Server 執行個體。

此套件具有採用壓縮格式的可執行檔和安裝檔案。套件包含的檔案格式如下：SQLServer2012SP1-<Architecture>-<Language>.exe 和 SQLServer2012SP1-<Architecture>-<Language>.box。

安裝 SQL Server 2012 SP1 時，請檢閱下列指示：

  • 將下列檔案從下載頁面下載至您裝置中的暫存目錄：

    • SQLServer2012SP1-architecture-language.box

    • SQLServer2012SP1-architecture-language.exe

  • 下載作業完成後，按兩下 SQLServer2012SP1-<architecture>-<language>.exe 開始安裝程序。

  • 在 [選擇供解壓縮檔案使用的目錄] 對話方塊中，會預先填入預設的目錄路徑：<目前磁碟機>\<目前工作目錄>\<封裝名稱>。例如，%temp%\SQLServer2012SP1-x64-ENU\。按一下 [瀏覽] 按鈕以變更解壓縮檔案的目錄路徑。

  • 此套件會解壓縮至指定的安裝路徑，並且在安裝完成之後，可能會遺留在選取的目錄路徑中。使用者必須能夠使用解壓縮資料夾中的二進位檔案，以便日後安裝。

  • 安裝精靈會執行 SQL Server 安裝中心。請依照從安裝精靈安裝 SQL Server 2012 (安裝程式) (http://msdn.microsoft.com/library/ms143219.aspx) 中的安裝指示執行。

下列表格包含一些可用來解壓縮 SQL Server 2012 SP1 套件的命令列參數。

如需可直接提供 SP1 套件使用之支援命令列參數的詳細清單，請參閱從命令提示字元安裝 SQL Server 2012 (http://msdn.microsoft.com/library/ms144259.aspx)

參數 | 描述
/x 或 -x | 將套件解壓縮至指定的路徑。開啟 [選擇供解壓縮檔案使用的目錄] 對話方塊，然後將套件解壓縮至指定的路徑。 此命令不會執行安裝程式。
/x:<path> 或 -x:<path> | 將套件解壓縮至指定的路徑，但不會啟動安裝程式。
/q 或 -q | 指定安裝程式會在不含任何使用者介面的無訊息模式中執行。這是自動安裝所使用的參數。
/l:<path> 或 -l:<path> | 記錄檔預設儲存在暫存目錄中，名稱為 SQLServer2012SPx-<Architecture>-<Language>_decompression_log.txt 使用此參數可將解壓縮記錄檔產生至指定的路徑。 例如： SQLServer2012SP1-x64-ENU /x /l:<path> 此選項只能與 /x 或 -x 或者 /x:<path> 或 -x:<path> 一起使用

更新 SQL Server 的備妥映像

您可以將更新套用到已備妥但是未設定的 SQL Server 執行個體，而不需完成已備妥之執行個體的組態。將更新套用至已備妥之 SQL Server 執行個體的其他方式將於底下說明：

  • 更新之前已備妥的 SQL Server 執行個體

    已備妥之執行個體的更新可以在組態設定之前套用。更新封裝會偵測到此執行個體位於備妥狀態，並將修補程式套用到備妥的執行個體，而不會完成組態設定。

  • 使用 Microsoft Update 更新備妥的執行個體：

    您可以透過 Microsoft Update 將更新套用至 SQL Server 的備妥執行個體。Microsoft Update 封裝會偵測到此執行個體位於備妥狀態，並將修補程式套用到備妥的執行個體，而不會完成組態設定。

如果您要更新備妥的 SQL Server 映像，您需要指定 InstanceID 參數。如需詳細資訊和範例語法，請參閱＜從命令提示字元安裝更新＞。

更新完成的 SQL Server 映像

更新已完成且設定好的 SQL Server 執行個體會依照與任何其他已安裝的 SQL Server 執行個體相同的程序。

重建 SQL Server 2012 容錯移轉叢集節點

套用更新之後，如果您必須重建容錯移轉叢集中的節點，請遵循下列步驟：

  1. 重建容錯移轉叢集中的節點。如需有關重建節點的詳細資訊，請參閱從容錯移轉叢集執行個體失敗的狀況復原。

  2. 執行原始的 SQL Server 2012 安裝程式以便將 SQL Server 2012 安裝到容錯移轉叢集節點。

  3. 在您已加入的節點上執行 SQL Server 2012 更新安裝程式。

重新啟動服務及應用程式

當安裝程式完成時，它可能會提示您重新啟動電腦。在系統重新啟動或在安裝程式完成 (但未要求重新啟動電腦) 之後，您可以使用 [控制台] 中的 [服務] 節點來重新啟動在套用 SQL Server 2012 更新之前所停止的服務。這包括分散式交易協調器及 Microsoft Search 等服務，或執行個體特定的對等服務。

重新啟動在執行 SQL Server 2012 更新安裝程式之前所關閉的應用程式。您可能還想在安裝成功完成之後，立即為已升級的 master、msdb 和 model 資料庫進行另一次備份。

解除安裝 SQL Server 2012 的更新

您可以從 [控制台] 中的 [程式和功能] 解除安裝 SQL Server 2012 累計更新或 Service Pack。若要檢視已安裝的更新清單，請依序按一下 [開始] 按鈕、[控制台]、[程式集]，然後按一下 [程式和功能] 下的 [檢視已安裝的更新]，開啟 [已安裝的更新]。系統會個別列出每個累計更新。然而，安裝了高於累計更新的 Service Pack 時，累計更新項目會隱藏而且在您解除安裝 Service Pack 時，才會變成可用。

若要解除安裝任何 Service Pack 及更新，您必須以套用於 SQL Server 之執行個體最新的更新或 Service Pack 開始並回溯執行。在下列每個範例中，SQL Server 會在解除安裝其他的 Service Pack 或更新完成後，以累計更新 1 結束。

  • 如果是已安裝具有累計更新 1 及 SP1 之 SQL Server 2012 的執行個體，請移除 SP1。

  • 如果是已安裝具有累計更新 1、SP1 及累計更新 2 之 SQL Server 2012 的執行個體，請先解除安裝累計更新 2，然後再解除安裝 SP1。

請參閱

其他資源

從命令提示字元安裝 SQL Server 2012
安裝 SQL Server 2012 服務更新
驗證 SQL Server 安裝
檢視與讀取 SQL Server 安裝程式記錄檔
將意見反應提供給 Microsoft

© 2012 Microsoft Corporation. 著作權所有，並保留一切權利。


文件集的法律注意事項

[image]

文件集的法律注意事項
傳送回函

本文件是以原本的形式提供， 本文件中所表達的資訊和觀點，包括 URL 及其他網際網路網站參考資料，如有變更恕不另行通知。 您應自行承擔使用本文件的風險。

此處描述的部分範例僅供說明使用，純屬虛構， 並無意圖亦不應將其影射為任何實際關聯或連接。

本文件不會為您提供任何 Microsoft 產品的任何智慧財產權的任何法律權限。 您可以在內部為了參考用途來複製及使用本文件。

© 2012 Microsoft. 著作權所有，並保留一切權利.

Microsoft, Active Directory, ActiveX, Bing Maps, Excel, IntelliSense, MSDN, MS-DOS, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual Studio, Windows, Windows NT, Windows Server 及 Windows Vista 是 Microsoft 集團的商標。 SAP NetWeaver 是 SAP AG 在德國和其他一些國家 (地區) 的註冊商標。 其他所有的商標為各擁有人所有之財產。

SQL Server 支援及升級的文件集原則

SQL Server 2012 軟體文件集包括《Microsoft SQL Server 2012 線上叢書》、安裝文件集、開發人員參考文件集、教學課程、讀我檔案、已知問題文件、範例程式碼、範例資料庫以及 Microsoft 所發行的知識庫文件，這些全都包含有關 SQL Server 特性與功能的內容。 此支援和升級原則適用於 SQL Server 2012 文件集，包括 SQL Server 2012 版本及 Service Pack 的讀我檔案；讀我檔案可視為《SQL Server 2012 線上叢書》的延伸部分。

本文件內所含範例的主要目的在於闡釋某個概念，或說明特定陳述式或子句的合理使用。 多數範例並不包含通常可在完整生產系統中找到的所有程式碼，因為已將某些一般資料驗證及錯誤處理部分移除，以將焦點放在範例中的特定概念或陳述上。 這些範例或其中包含的任何原始程式碼並不包含於技術支援的服務範圍之內。

在某些情況下，SQL Server 2012 中的特定功能未經過充分的測試或開發，所以不打算提供給您使用。 這類功能通常會當做預留位置； 因此，軟體中包含的某些功能不會記載於文件集中。 未記載的功能或是有註明僅供 Microsoft 內部使用的功能將不提供給您使用，也不會受到 Microsoft 客戶支援服務的支援。 除非 SQL Server 2012 文件集另外註明，否則協力廠商內容 (包括搭配 SQL Server 2012 使用這類協力廠商內容所產生的問題) 將不會受到 Microsoft 客戶支援服務的支援，而且也可能造成資料遺失。 Microsoft 客戶支援服務也不支援利用或使用未記載之進入點 (如未記載的 API) 的資料庫或應用程式，其中包括但不限於：預存程序、擴充預存程序、函數、檢視、資料表、資料行、屬性或中繼資料。

升級至 SQL Server 2012 未來版本的伺服器或資料庫，對於利用及使用未記載之進入點的應用程式或資料庫可能不適用，而且也不受支援。 當您使用 SQL Server 2012 文件集中未記載之 Microsoft SQL Server 包含的 SQL Server 特性與功能時，將不會受到支援，這樣的使用也可能造成資料遺失。


從命令提示字元安裝更新

[image]

從命令提示字元安裝更新
請參閱 傳送回函

測試並修改安裝指令碼，以便符合組織的需求。如需有關將更新安裝至 SQL Server 容錯移轉叢集的詳細資訊，請參閱 Microsoft 知識庫中的如何將 SQL Server 更新套用至容錯移轉叢集執行個體。

安裝的範例語法

更新封裝的名稱會有所不同而且可能包含語言、版本及處理器元件。在命令提示字元中套用更新，並以您的封裝更新名稱取代 <package_name>：

  • 更新單一 SQL Server 執行個體及所有共用元件，類似 Integration Services 和管理工具：您可以使用 InstanceName 參數或 InstanceID 參數來指定執行個體。若要更新備妥的 SQL Server 執行個體，您必須指定 InstanceID 參數<package_name>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /InstanceName=MyInstance 或 <package_name>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /InstanceID=<執行個體識別碼>

  • 安裝程式可以整合最新產品更新與主要產品安裝，因此主要產品及其適用的更新可以同時安裝。您可以準備資料庫引擎執行個體安裝，使其包含產品更新：setup.exe /q /IAcceptSQLServerLicenseTerms /ACTION=PrepareImage /UpdateEnabled=True /UpdateSource=<下載更新的路徑> /INSTANCEID=<執行個體識別碼> /FEATURES=SQLEngine

  • 僅更新 SQL Server 共用元件，例如 Integration Services 和管理工具：<package_name>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch

  • 更新電腦上的所有 SQL Server 執行個體和所有共用元件，例如 Integration Services 和管理工具：<package_name>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /AllInstances

從命令提示字元移除更新，並以您的更新封裝名稱取代 <package_name>：

  • 從 SQL Server 的單一執行個體和所有共用元件中移除更新，例如 Integration Services 和管理工具：<package_name>.exe /qs /Action=RemovePatch /InstanceName=MyInstance

  • 僅從 SQL Server 共用元件中移除更新，例如 Integration Services 和管理工具：<package_name>.exe /qs /Action=RemovePatch

    附註 附註

    更新安裝程式會確保共用元件一定處於執行個體版本的最高層級或最高層級以上。

支援的命令提示字元參數

重要事項 重要事項

可能的話，請在執行階段提供安全性認證。如果您將認證儲存在指令碼檔案中，必須保護該檔案免於未經授權的存取。

參數 | 說明
/? | 顯示自動安裝命令提示字元說明。
/action=Patch or /action=RemovePatch | 指定安裝動作：Patch 或 RemovePatch。
/allinstances | 將 SQL Server 更新套用至所有 SQL Server 執行個體以及所有 SQL Server 共用的非執行個體感知元件。
/instancename=InstanceName1 | 將 SQL Server 更新套用至名為 InstanceName 的 SQL Server 執行個體以及所有 SQL Server 共用的非執行個體感知元件。
/InstanceID=Inst1 | 將 SQL Server 更新套用至 SQL Server Inst1 執行個體以及所有 SQL Server 共用的非執行個體感知元件。
/quiet | 以自動安裝模式執行 SQL Server 更新安裝程式。
/qs | 只顯示進度 UI 對話方塊。
/UpdateEnabled | 指定 SQL Server 安裝程式是否應該探索及包含產品更新。有效值為 True 和 False 或 1 和 0。根據預設，SQL Server 安裝程式會包含找到的更新。
/UpdateSource | 指定 SQL Server 安裝程式將取得產品更新的位置。有效值為 "MU"，表示搜尋 Microsoft Update、有效資料夾路徑、相對路徑 (例如 .\MyUpdates) 或 UNC 共用。根據預設，SQL Server 安裝程式會搜尋 Microsoft Update 或透過 Windows Server Update Services 搜尋 Windows Update Service。
/IAcceptSQLServerLicenseTerms | 只有當您針對自動安裝指定了 /Q 或 /QS 參數時，才需要使用此參數。

1 您不能指定這個參數來將更新套用到備妥的 SQL Server 執行個體。您必須改為指定 /instanceID 參數。

請參閱

概念

SQL Server 服務安裝概觀


如何：驗證 SQL Server 更新的安裝是否成功

[image]

如何：驗證 SQL Server 更新的安裝是否成功
請參閱 傳送回函

若要驗證 SQL Server 更新的安裝是否成功：

  • 確認 SQL Server 服務已在線上。

  • 確認 @@version 查詢所傳回的版本資訊正確無誤。

請參閱

概念

SQL Server 服務安裝概觀


取得 SQL Server 協助

[image]

取得 SQL Server 協助
請參閱 傳送回函

Microsoft 提供三個有關 SQL Server 的主要資訊來源：

  • 文件會安裝為《SQL Server 線上叢書》的本機集合。

  • Microsoft Developer Network (MSDN) 和 TechNet 上的 SQL Server 網站。

  • 其他 Microsoft 網站上的 SQL Server 資訊。

如果您在這些來源中找不到想要尋找的資訊，可以在 SQL Server 社群論壇和新聞群組中提出問題，也可以向 Microsoft 提交支援案例。

SQL Server 線上叢書

《SQL Server 線上叢書》包含了使用 SQL Server 所需的概念和程序。 《線上叢書》也包含了許多語言和程式設計介面的參考資料，可供 SQL Server 用來儲存、擷取、報告和修改資料。

《線上叢書》可以透過下列方法存取：

  • 網際網路上的 MSDN Library 和 TechNet Library 都會發行《SQL Server 2012 線上叢書》副本。 這些《SQL Server 線上叢書》複本中的主題包含來自社群的意見，例如來自其他客戶的額外資訊和程式碼範例。 您可以在 SQL Server 2012 線上叢書上檢視此 MSDN Library 複本。

  • 您可以使用 [Help Library 管理員]，將《SQL Server 線上叢書》安裝在本機電腦上。 如需詳細資訊，請參閱＜加入或移除說明集合＞。

當 Microsoft 發行《SQL Server 線上叢書》的更新時，MSDN Library 中的《SQL Server 線上叢書》複本和透過 [Help Library 管理員] 取得的線上叢書檔案都會重新整理。

MSDN 和 TechNet 上的資訊

Microsoft Developer Network (MSDN) 提供線上和離線服務，協助開發人員使用 Microsoft 產品和技術撰寫應用程式。 Microsoft TechNet Program 會傳遞完整的技術資源，協助 IT 專業人員有效地評估、部署和支援 Microsoft 方案。

MSDN 和 TechNet 上的數個網站會針對特定使用者提供連結，以取得與其工作最相關的 SQL Server 資訊，包括 MSDN 或 TechNet 上《SQL Server 線上叢書》副本中的資訊。 這些網站還包含可用來擴充 SQL Server 線上叢書中可用資訊的資訊。

下表描述這些資源及其預期使用者。

資源 | 適用對象
SQL Server 程式開發人員中心 | 正在建立 SQL Server 資料庫、報表系統和商業智慧方案的開發人員，以及啟用其應用程式和網站以使用這些系統的開發人員。
資料存取和儲存體程式開發人員中心 | 正在啟用其應用程式和網站，以便使用透過類似 SQL Server 和 Access 等產品儲存之資料的開發人員。
XML 程式開發人員中心 | 使用 XML 執行資料儲存和操作之站台和應用程式的網站建立者和應用程式開發人員。
SQL Server TechNet 網站 | 針對使用 SQL Server 的系統進行規劃、部署、管理和支援的管理員和操作員。

其他線上資訊

可以從這些 Microsoft 網站取得其他 SQL Server 資訊。

資源 | 說明
Microsoft SQL Server | 提供有關將 SQL Server 評估為資料儲存和商業智慧工具的售前資訊。
Microsoft 知識庫 | 提供由 Microsoft 技術支援所撰寫之 SQL Server 文件的可搜尋儲存機制。
Microsoft Learning | 描述 SQL Server 的 Microsoft 培訓和認證。
Microsoft Press | 列出有關 SQL Server 的 Microsoft Press 叢書。

由他處取得協助

如果您沒有在產品文件集或網站上找到您所搜尋的資訊，可以在 SQL Server 社群論壇和新聞群組中提出問題， 也可以向產品支援部門要求說明。

附註 附註

請勿在 MSDN Library 或 TechNet Library 之《SQL Server 線上叢書》主題底部的「社群註解」區段中提出問題。 我們不會監控這些區段的問題，而且您通常不會收到解答。 請在社群論壇和新聞群組中提出問題，因為這些地方會由可回答您問題的其他客戶進行監控。

下表會連結到這些資源並提供說明。

資源 | 說明
SQL Server IT 專業人員社群 | 提供由 SQL Server 社群所監控之新聞群組和論壇的連結。 它還會列出社群資訊來源，例如網誌或網站。 雖然不保證一定有答案，不過 SQL Server 社群對於解答問題有很大的幫助。
SQL Server 程式開發人員中心社群 | 此網站著重在新聞群組、論壇及其他社群資源，這些資訊對 SQL Server 開發人員很有用。
Microsoft 說明及支援 | 您可以使用這個網站向 Microsoft 技術支援人員提交支援案例。

Microsoft 產品有支援週期，可定義每一個版本可用的支援時間長度。 Microsoft 支援會維護一個定義 Microsoft 支援週期的頁面。 此頁面包含其他頁面的連結，這些頁面會指定 Microsoft 產品支援的可用性。 如需詳細資訊，請參閱 Microsoft 支援週期。

請參閱

概念

使用 SQL Server 的產品文件集


歡迎使用

[image]

歡迎使用
傳送回函

安裝規則會掃描即將安裝更新的電腦。


授權條款

[image]

授權條款
傳送回函

使用 [授權條款] 頁面，即可接受這個版本的授權條款。

選項

若要繼續進行安裝，您必須接受 SQL Server 授權條款。

請使用 [列印] 按鈕來列印此版本的授權條款副本。 若要結束安裝，請按一下 [取消]。


選取功能

[image]

選取功能
傳送回函

使用 [特徵選取] 頁面，即可選取要更新的 SQL Server 元件和功能。

選項

按一下左窗格中的功能名稱，即可查看語言、作業系統、版本和狀態詳細資料。

若要更新元件或功能，請選取功能名稱旁的核取方塊。 若要從此次更新作業中排除元件或功能，請選取功能名稱旁的核取方塊。

單一電腦上的多個 SQL Server 執行個體可以在不同時間更新，但是 SQL Server 執行個體中的所有元件則必須同時更新。 工作站元件、MSXML 剖析器、SQLXML、回溯相容性元件和 VSS Writer 等所有共用元件都必須更新。

如果元件無法更新，則 [詳細資料] 窗格中會提供說明。


檢查使用中的檔案

[image]

檢查使用中的檔案
傳送回函

若要避免在安裝 SQL Server 更新之後重新啟動 Windows，請使用 [檢查使用中檔案] 頁面來識別正在鎖定 SQL Server 更新安裝程式所需之檔案的處理序。

停止所有連接到正在更新之 SQL Server 執行個體的應用程式和服務。 其中包括停止 SQL Server Management Studio 和 SQL Server Data Tools (SSDT)。

如果安裝程式判斷在安裝時鎖定了檔案，則在安裝完成之後可能必須重新啟動電腦。 如有必要，安裝程式會提示您重新啟動電腦。 如果安裝程式必須在安裝時結束某項服務，它會在安裝完成之後重新啟動該服務。

為了排除安裝之後重新啟動電腦的需求，安裝程式會顯示正在鎖定檔案之處理序的清單。 請停止或結束此清單中的處理序和應用程式， 然後按一下 [重新整理檢查] 重新執行檢查。 按一下 [停止檢查] 可結束正在執行的檢查作業。 如果找不到鎖定的檔案，表格會是空的。 當所有鎖定的處理序都已關閉或停止時，請按 [下一步] 繼續。

安裝程式會將資訊記錄到記錄檔中。 如需有關如何檢視記錄檔的詳細資訊，請參閱＜如何：檢視 SQL Server 安裝程式記錄檔＞和＜如何：讀取 SQL Server 安裝程式記錄檔＞。

記錄檔中將包含下列資訊：

  • 處理序的名稱

  • SQL Server 功能的名稱

  • 處理序類型

  • 執行處理序所使用的帳戶

  • 處理序識別碼

  • 鎖定的檔案名稱

名稱 | 說明
處理序 | 顯示正在使用要更新之檔案的處理序完整名稱。
型別 | 顯示處理序的類型。
帳戶 | 顯示執行處理序所使用的帳戶。
處理序識別碼 | 顯示處理序識別碼。


準備更新

[image]

準備更新
傳送回函

使用 [摘要] 頁面，即可確認即將套用至 SQL Server 執行個體的變更。 若要繼續進行安裝，請按一下 [安裝]。


更新進度

[image]

更新進度
傳送回函

使用 [安裝進度] 頁面，即可監視安裝程式將更新套用至 SQL Server 執行個體及其元件時的狀況。

選項

此表格提供 SQL Server 產品名稱、執行個體名稱和安裝狀態。


完成

[image]

完成
傳送回函

[完成] 頁面會確認安裝狀態。