Übersicht über die SQL Server-Setupdokumentation

[image]

Übersicht über die SQL Server-Setupdokumentation
Feedback senden

Die Dokumentation für das SQL Server-Setup ist auf den Installationsmedien und online verfügbar.

Während des Setups verfügbare Dokumentation

Klicken Sie während der Installation von SQL Server im Setup-Assistenten auf die Schaltfläche Hilfe, oder drücken Sie F1 auf der Tastatur, um die zum Ausführen des Vorgangs unmittelbar erforderlichen Informationen zu erhalten.

Übersicht über die SQL Server-Installationsthemen

Unabhängig davon, ob Sie für die Installation von SQL Server den SQL Server-Installations-Assistenten oder die Eingabeaufforderung verwenden, sollten Sie zur Vorbereitung die folgenden Abschnitte lesen:

  • Planen einer SQL Server-Installation.

    Beschreibt, wie der Computer für eine SQL Server-Installation vorbereitet wird.

  • Installieren von SQL Server 2012

    Beschreibt die Installationsoptionen für SQL Server.

  • Installieren von SQL Server 2012-BI-Funktionen

    Beschreibt die Installationsoptionen für SQL Server-Funktionen, die Teil der Microsoft BI-Plattform sind und Analysis Services, Integration Services, Reporting Services sowie mehrere Clientanwendungen beinhalten, die zum Erstellen von oder Arbeiten mit analytischen Daten verwendet werden.

  • Aktualisieren auf SQL Server 2012

    Beschreibt die Optionen zum Aktualisieren auf SQL Server.

Lesen Sie die folgenden Themen, wenn Sie einen SQL Server-Failovercluster installieren.

  • Erste Schritte mit dem SQL Server-Failoverclustering.

  • Vor dem Installieren des Failoverclusterings.

Senden Sie Feedback zu diesem Thema an Microsoft

© 2012 Microsoft Corporation. Alle Rechte vorbehalten.


Informationen zu den SQL Server-Lizenzbedingungen

[image]

Informationen zu den SQL Server-Lizenzbedingungen
Siehe auch Feedback senden

Die Microsoft-Softwarelizenzbedingungen werden während der Installation von SQL Server auf den lokalen Computer kopiert. Wenn mehrere Instanzen derselben Edition und Sprache von SQL Server auf demselben Computer installiert sind, gelten die Lizenzbedingungen für alle Instanzen dieser Edition und Sprache. Die Dateien werden in den folgenden Ordner geschrieben: %ProgramFiles%\Microsoft SQL Server\110\License Terms\ oder %ProgramFiles(x86)%\Microsoft SQL Server\110\License Terms\.

Wenn mehrere Instanzen derselben Edition und Sprache von SQL Server auf demselben Computer installiert sind, gelten die Lizenzbedingungen für alle Instanzen dieser Edition und Sprache.

Der Name der Datei mit den Lizenzbedingungen gibt die Edition von SQL Server und die Sprachversion von SQL Server an: Beispiel:

  • License_DEV_ENU.txt für SQL Server Developer in der Sprachversion Englisch.

  • License_STD_ITA.txt für SQL Server Standard in der Sprachversion Italienisch.

  • License_UA_JPN.txt für SQL Server Upgrade Advisor in der Sprachversion Japanisch.

  • License_SQLNCLI_ENU.txt für SQL Server Native Client in der Sprachversion Englisch.

  • License_SQLXML4_KOR.txt für SQLXML in der Sprachversion Koreanisch.

  • License_SQLBI.rtf für SQL Server Business Intelligence-Edition.

  • License_ENTCORE.rtf für SQL Server Enterprise Edition: Core-basierte Lizenzierung.

  • License_ENT.rtf für SQL Server Enterprise Edition: Server-/Clientzugriffslizenzen.

Die folgenden Dateinamensegmente werden zum Identifizieren der Editionen von SQL Server verwendet:

  • ENT – Enterprise Edition: Server-/Clientzugriffslizenzen

  • ENTCORE – Enterprise Edition: Core-basierte Lizenzierung

  • BI – Business Intelligence

  • DEV – Developer

  • STD – Standard

  • WEB – Web

  • EXPR – Express

Die folgenden Dateinamensegmente werden zum Identifizieren der entsprechenden Sprachen von SQL Server verwendet:

  • ENU - Englisch

  • JPN - Japanisch

  • FRA - Französisch

  • ITA - Italienisch

  • KOR - Koreanisch

  • DEU - Deutsch

  • ESN - Spanisch

  • CHS - Vereinfachtes Chinesisch

  • CHT - Traditionelles Chinesisch

  • PTB - Portugiesisch (Brasilien)

  • RUS – Russisch

SQL Server-Lizenzierungsoptionen

Weitere Informationen über Preis- und Lizenzierungsoptionen zu SQL Server finden Sie auf der Website zu Microsoft SQL Server (http://go.microsoft.com/fwlink/?LinkId=190955).

Siehe auch

Konzepte

Lizenzierungsüberlegungen für SQL Server
Datenschutzbestimmungen für Microsoft SQL Server
Rechtliche Hinweise für die Dokumentation


Lizenzierungsüberlegungen für SQL Server

[image]

Lizenzierungsüberlegungen für SQL Server
Siehe auch Feedback senden

Weitere Informationen zu Lizenzierungsoptionen für SQL Server finden Sie auf der Website von Microsoft SQL Server.

Siehe auch

Verweis

Informationen zu den SQL Server-Lizenzbedingungen

Konzepte

Datenschutzbestimmungen für Microsoft SQL Server
Rechtliche Hinweise für die Dokumentation


Rechtliche Hinweise für die Dokumentation

[image]

Rechtliche Hinweise für die Dokumentation
Feedback senden

Dieses Dokument wird "wie besehen" zur Verfügung gestellt. Die in diesen Unterlagen enthaltenen Angaben und Ansichten, einschließlich URLs und anderer Verweise auf Internetwebsites, können ohne vorherige Ankündigung geändert werden. Ihnen obliegt das Risiko der Verwendung.

Einige der in diesem Dokument dargestellten Beispiele werden nur zu Illustrationszwecken bereitgestellt und sind fiktiv. Es wird keine reale Verknüpfung beabsichtigt oder abgeleitet.

Dieses Dokument gibt Ihnen keine Rechte auf geistiges Eigentum in Microsoft-Produkten. Sie können dieses Dokument zu internen Zwecken und als Referenz kopieren und verwenden.

© 2012 Microsoft. Alle Rechte vorbehalten.

Microsoft, Active Directory, ActiveX, Bing Maps, Excel, IntelliSense, MSDN, MS-DOS, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual Studio, Windows, Windows NT, Windows Server und Windows Vista sind Marken der Microsoft-Unternehmensgruppe. SAP NetWeaver ist eine eingetragene Marke der SAP AG in Deutschland und/oder anderen Ländern. Alle anderen Marken sind Eigentum ihrer jeweiligen Inhaber.

Dokumentationsrichtlinie für den Support von und das Upgrade auf SQL Server

Die Dokumentation zur Microsoft SQL Server 2012-Software besteht aus der Microsoft-Onlinedokumentation für Microsoft SQL Server 2012, Installationsdokumentation, Referenzdokumentation für Programmierer, Lernprogrammen, Infodateien, Dokumenten zu bekannten Problemen, Beispielcode, Beispieldatenbanken und von Microsoft veröffentlichten Knowledge Base-Artikeln. Alle diese Elemente enthalten Inhalte zu Funktionen und zur Funktionalität von SQL Server. Diese Support- und Upgraderichtlinie gilt für die Microsoft SQL Server 2012-Dokumentation, einschließlich der Infodateien zu Versionen und Service Packs von Microsoft SQL Server 2012. Eine Infodatei wird als Erweiterung der Microsoft SQL Server 2012-Onlinedokumentation betrachtet.

Die in dieser Dokumentation enthaltenen Beispiele dienen in erster Linie der Veranschaulichung eines Konzepts oder der sinnvollen Verwendung einer bestimmten Anweisung oder Klausel. Die meisten Beispiele enthalten nicht den gesamten Code, der normalerweise in einem vollständigen Produktionssystem vorhanden wäre, da die Datenüberprüfung und Fehlerbehandlung teilweise entfernt wurde, um das Beispiel eines bestimmten Konzepts oder einer Anweisung hervorzuheben. Für diese Beispiele oder den enthaltenen Quellcode ist kein technischer Support verfügbar.

In einigen Fällen wurde eine bestimmte Funktion von Microsoft SQL Server 2012 nicht ausreichend getestet bzw. entwickelt und ist nicht für Ihre Verwendung gedacht. Derartige Funktionen dienen häufig als Platzhalter. Deshalb sind bestimmte Funktionen, die in der Software enthalten sind, nicht dokumentiert. Funktionen, die nicht dokumentiert wurden oder als Vermerk für die Microsoft-interne Verwendung aufgenommen wurden, sind nicht für eine Verwendung durch Benutzer gedacht, und der Microsoft-Kundendienst bietet keinen Support dafür an. Sofern in der Dokumentation zu Microsoft SQL Server 2012 nicht anders angegeben ist, werden Drittanbieterinhalte, einschließlich der Probleme, die aus der Verwendung derartiger Drittanbieterinhalte mit Microsoft SQL Server 2012 entstehen, nicht vom Microsoft-Kundendienst unterstützt und können zu Datenverlust führen. Der Microsoft-Kundendienst bietet auch keinen Support für Datenbanken oder Anwendungen, die nicht dokumentierte Einstiegspunkte, wie beispielsweise nicht dokumentierte APIS, nutzen oder verwenden. Gleiches gilt auch für die folgenden und weitere hier nicht genannten Elemente: gespeicherte Prozeduren, erweiterte gespeicherte Prozeduren, Funktionen, Sichten, Tabellen, Spalten, Eigenschaften und Metadaten.

Server- und Datenbankupgrades auf zukünftige Versionen von Microsoft SQL Server 2012 für Anwendungen und Datenbanken, die nicht dokumentierte Einstiegspunkte nutzen und verwenden, funktionieren möglicherweise ebenfalls nicht und werden nicht unterstützt. Die Verwendung der in Microsoft SQL Server enthaltenen SQL Server-Funktionen und -Funktionen, die in der Dokumentation von Microsoft SQL Server 2012 nicht für Ihre Verwendung dokumentiert sind, wird nicht unterstützt und kann zu Datenverlust führen.


Datenschutzbestimmungen für Microsoft SQL Server

[image]

Datenschutzbestimmungen für Microsoft SQL Server
Feedback senden

Informationen zu den Datensammlungsskomponenten für Benutzerdaten in Microsoft SQL Server 2012 finden Sie in den Datenschutzbestimmungen für SQL Server


Dateispeicherorte für Standard- und benannte Instanzen von SQL Server

[image]

Dateispeicherorte für Standard- und benannte Instanzen von SQL Server
Siehe auch Feedback senden

Eine Installation von SQL Server besteht aus einer oder mehreren separaten Instanzen. Eine Instanz (Standard- als auch benannte Instanz) besitzt eine Reihe eigener Programm- und Datendateien sowie mehrere freigegebene Dateien, die für alle Instanzen von SQL Server auf dem Computer freigegeben werden.

Für eine Instanz von SQL Server, die Database Engine (Datenbankmodul), Analysis Services und Reporting Services umfasst, verfügt jede Komponente über einen vollständigen Satz an Daten- und ausführbaren Dateien sowie die für alle Komponenten freigegebenen Dateien.

Zum Isolieren der Installationsspeicherorte für jede Komponente werden eindeutige Instanz-IDs für jede Komponente innerhalb einer bestimmten SQL Server-Instanz generiert.

Wichtiger Hinweis Wichtig

Programm- und Datendateien können weder auf einem Wechseldatenträger, auf einem Dateisystem mit Komprimierung, in einem Verzeichnis mit Systemdateien noch auf freigegebenen Laufwerken einer Failoverclusterinstanz installiert werden.

Löschen Sie keines der folgenden Verzeichnisse oder dessen Inhalt: Binn, Data, Ftdata, HTML oder 1033. Andere Verzeichnisse können ggf. gelöscht werden. Möglicherweise können Sie auf diese Weise verloren gegangene Funktionalität oder Daten dann aber nur abrufen, indem Sie SQL Server deinstallieren und anschließend erneut installieren. Löschen oder ändern Sie keine HTM-Dateien im Verzeichnis HTML. Sie sind für die ordnungsgemäße Funktion der SQL Server-Tools erforderlich.

Freigegebene Dateien für alle Instanzen von SQL Server

Gemeinsame, von allen Instanzen auf einem Computer verwendete Dateien werden im Ordner <drive>:\Programme\Microsoft SQL Server\110\ installiert, wobei <drive> für den Buchstaben des Laufwerks steht, auf dem die Komponenten installiert werden. Der Standardwert ist Laufwerk "C".

Dateispeicherorte und Registrierungszuordnung

Während des Setups von SQL Server wird für jede Serverkomponente eine Instanz-ID generiert. Die Serverkomponenten in dieser Version von SQL Server sind Database Engine (Datenbankmodul), Analysis Services und Reporting Services.

Die Standardinstanz-ID wird mit dem folgenden Format erstellt:

  • Auf MSSQL für Database Engine (Datenbankmodul) folgt die Hauptversionsnummer, ggf. gefolgt von einem Unterstrich und der Nebenversionsnummer, und ein Punkt, woraufhin wiederum der Instanzname folgt.

  • Auf MSSQL für Analysis Services folgt die Hauptversionsnummer, ggf. gefolgt von einem Unterstrich und der Nebenversionsnummer, und ein Punkt, woraufhin wiederum der Instanzname folgt.

  • Auf MSSQL für Reporting Services folgt die Hauptversionsnummer, ggf. gefolgt von einem Unterstrich und der Nebenversionsnummer, und ein Punkt, woraufhin wiederum der Instanzname folgt.

Beispiele für Standardinstanz-IDs in dieser Version von Microsoft SQL Server 2012 lauten wie folgt:

  • MSSQL11.MSSQLSERVER für eine Standardinstanz von Microsoft SQL Server 2012.

  • MSAS11.MSSQLSERVER für eine Standardinstanz von Analysis Services.

  • MSSQL11.MyInstance für eine benannte Instanz von Microsoft SQL Server 2012 mit dem Namen "MyInstance".

Die Verzeichnisstruktur für eine mit dem Namen "MyInstance" benannte Microsoft SQL Server 2012-Instanz, die Database Engine (Datenbankmodul) und Analysis Services umfasst und in den Standardverzeichnissen installiert ist, lautet wie folgt:

  • C:\Programme\Microsoft SQL Server\MSSQL11.MyInstance\

  • C:\Programme\Microsoft SQL Server\MSASSQL11.MyInstance\

Sie können jeden Wert für die Instanz-ID angeben, sollten aber Sonderzeichen und reservierte Schlüsselwörter vermeiden. Weitere Informationen finden Sie unter Reserved Keywords (Setup).

Sie können während des SQL Server-Setups eine nicht standardmäßige Instanz-ID angeben. Wenn der Benutzer das Standardinstallationsverzeichnis ändert, wird statt <Programme>\Microsoft SQL Server ein als <custom path>\Microsoft SQL Server festgelegter benutzerdefinierter Pfad verwendet. Beachten Sie, dass die Instanz-IDs, die mit einem Unterstrich (_) beginnen oder das Nummernzeichen (#) oder Dollarzeichen ($) enthalten, nicht unterstützt werden.

Hinweis Hinweis

Integration Services und Clientkomponenten sind nicht instanzabhängig und bekommen daher keine Instanz-ID zugewiesen. Standardmäßig werden nicht instanzabhängige Komponenten in einem einzelnen Verzeichnis installiert: <drive>:\Programme\Microsoft SQL Server\110\. Wenn der Installationspfad einer freigegebenen Komponente geändert wird, wirkt sich diese Änderung auch auf die anderen freigegebenen Komponenten aus. Bei allen zukünftigen Installationen werden die nicht instanzbezogenen Komponenten wieder im gleichen Verzeichnis installiert wie bei der ursprünglichen Installation.

SQL ServerAnalysis Services ist die einzige SQL Server-Komponente, die nach der Installation Instanzumbenennung unterstützt. Wenn eine Instanz von Analysis Services umbenannt wird, ändert sich die Instanz-ID nicht. Nach abgeschlossener Instanzumbenennung wird die während der Installation erstellte Instanz-ID von Verzeichnissen und Registrierungsschlüsseln weiterhin verwendet.

Die Registrierungsstruktur für instanzabhängige Komponenten wird unter HKLM\Software\Microsoft\Microsoft SQL Server\<Instance_ID> erstellt. Beispiel:

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL11.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSASSQL11.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.110

Die Registrierung verwaltet auch eine Zuordnung der Instanz-ID zum Instanznamen. Die Zuordnung der Instanz-ID zum Instanznamen wird folgendermaßen verwaltet:

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\SQL] "InstanceName"="MSSQL11"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\OLAP] "InstanceName"="MSASSQL11"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\RS] "InstanceName"="MSRSSQL11"

Angeben von Dateipfaden

Beim Setup können Sie den Installationspfad für die folgenden Funktionen ändern:

Der Installationspfad wird im Setup nur für die Funktionen angezeigt, die einen vom Benutzer konfigurierbaren Zielordner besitzen.

Komponente | Standardpfad1, 2 | Konfigurierbarer3 oder fester Pfad
Database Engine (Datenbankmodul)-Serverkomponenten | \Programme\Microsoft SQL Server\MSSQL11.<InstanceID>\ | Konfigurierbar
Datendateien für Database Engine (Datenbankmodul) | \Programme\Microsoft SQL Server\MSSQL11.<InstanceID>\ | Konfigurierbar
Analysis Services-Server | \Programme\Microsoft SQL Server\MSAS11.<InstanceID>\ | Konfigurierbar
Analysis Services-Datendateien | \Programme\Microsoft SQL Server\MSAS11.<InstanceID>\ | Konfigurierbar
Reporting Services-Berichtsserver | \Programme\Microsoft SQL Server\MSRS11.<InstanceID>\Reporting Services\ReportServer\Bin\ | Konfigurierbar
Reporting Services-Berichts-Manager | \Programme\Microsoft SQL Server\MSRS11.<InstanceID>\Reporting Services\ReportManager\ | Fester Pfad
Integration Services | <Installationsverzeichnis>\110\DTS\ | Konfigurierbar4
Master Data Services | <Installationsverzeichnis>\110\Master Data Services | Konfigurierbar4
Clientkomponenten | <Installationsverzeichnis>\110\Tools\ | Konfigurierbar4
Replikations- und serverbasierte COM-Objekte | <drive>:\Programme\Microsoft SQL Server\110\COM\5 | Fester Pfad
Von Integration Services bereitgestellte DLLs für das Data Transformation Runtime-Modul, das Data Transformation Pipeline-Modul und das dtexec-Eingabeaufforderungshilfsprogramm | <drive>:\Programme\Microsoft SQL Server\110\DTS\Binn | Fester Pfad
DLLs, die die Verbindungsunterstützung für Integration Services verwalten | <drive>:\Programme\Microsoft SQL Server\110\DTS\Connections | Fester Pfad
DLLs für alle Arten von Enumeratoren, die von Integration Services unterstützt werden | <drive>:\Programme\Microsoft SQL Server\110\DTS\ForEachEnumerators | Fester Pfad
SQL Server-Browser-Dienst, WMI-Anbieter | <drive>:\Programme\Microsoft SQL Server\110\Shared\ | Fester Pfad
Komponenten, die von allen Instanzen von SQL Server gemeinsam genutzt werden | <drive>:\Programme\Microsoft SQL Server\110\Shared\ | Fester Pfad

1Stellen Sie sicher, dass der Ordner \Programme\Microsoft SQL Server\ durch entsprechend eingeschränkte Berechtigungen geschützt wird.

2 Das Standardlaufwerk für diese Pfade ist systemdrive, normalerweise Laufwerk C.

3 Die Installationspfade für untergeordnete Funktionen werden durch die Installationspfade der übergeordneten Funktionen vorgegeben.

4Ein einzelner Installationspfad wird von Integration Services und Clientkomponenten gemeinsam genutzt. Wenn der Installationspfad einer Komponente geändert wird, wirkt sich diese Änderung auch auf die anderen Komponenten aus. Bei allen zukünftigen Installationen werden die Komponenten wieder am gleichen Speicherort installiert wie bei der ursprünglichen Installation.

5Das Verzeichnis wird von allen auf dem Computer installierten Instanzen von SQL Server verwendet. Wenn Sie ein Update auf eine der Instanzen auf dem Computer anwenden, wirken sich alle Änderungen an den Dateien dieses Ordners auch auf die übrigen auf dem Computer installierten Instanzen aus. Wenn Sie Funktionen zu einer vorhandenen Installation hinzufügen, können Sie den Speicherort einer vorher installierten Funktion nicht ändern und auch keinen Speicherort für eine neue Funktion angeben. Sie müssen zusätzliche Funktionen entweder in die durch das Setup bereits vorgegebenen Verzeichnisse installieren, oder Sie deinstallieren das Produkt und installieren es anschließend neu.

Hinweis Hinweis

Bei gruppierten Konfigurationen müssen Sie ein lokales Laufwerk auswählen, das für jeden Knoten des Clusters verfügbar ist.

Wenn Sie beim Setup einen Installationspfad für die Serverkomponenten oder Datendateien angeben, verwendet das Setup-Programm die Instanzkennung zusätzlich zum angegebenen Speicherort für Programm- und Datendateien. Die Instanz-ID wird vom Setup nicht für Tools und andere freigegebene Dateien verwendet. Darüber hinaus verwendet das Setup keine Instanz-ID für das Analysis Services-Programm und Datendateien. Für das Analysis Services-Repository wird jedoch eine Instanz-ID verwendet.

Wenn Sie einen Installationspfad für die Funktion Database Engine (Datenbankmodul) festlegen, wird dieser Pfad vom SQL Server-Setup als Stammverzeichnis für alle instanzspezifischen Ordner der Installation, einschließlich der SQL-Datendateien, verwendet. Wenn Sie in diesem Fall "C:\Programme\Microsoft SQL Server\MSSQL11\MSSQL\" als Stammverzeichnis festlegen, werden die instanzspezifischen Verzeichnisse am Ende dieses Pfads hinzugefügt.

Wenn die im Installations-Assistenten für SQL Server bereitgestellte Upgradefunktionalität USESYSDB verwendet wird, kann der Fall eintreten, dass das Produkt in einer rekursiven Ordnerstruktur installiert wird. Beispiel: <SQLProgramFiles>\MSSQL11\MSSQL\MSSQL11\MSSQL\Data\. Legen Sie stattdessen bei Verwendung der USESYSDB-Funktion nur einen Installationspfad für die Funktion "SQL-Datendateien" und nicht für die Funktion Database Engine (Datenbankmodul) fest.

Hinweis Hinweis

Datendateien werden erwartungsgemäß immer in einem untergeordneten Verzeichnis mit dem Namen Data gesucht. Geben Sie beispielsweise beim Upgrade "C:\Programme\Microsoft SQL Server\MSSQL11\" als Stammpfad zum Datenverzeichnis der Systemdatenbanken an, falls Datendateien unter "C:\Programme\Microsoft SQL Server\MSSQL11\MSSQL\Data" gefunden werden.

Siehe auch

Verweis

Konfiguration des Datenbankmodells &#8211; Datenverzeichnisse
Konfigurationseigenschaften von Analysis Services – Datenverzeichnisse


Lesen und Anzeigen der Setupprotokolldateien von SQL Server

[image]

Lesen und Anzeigen der Setupprotokolldateien von SQL Server
Siehe auch Feedback senden

Bei jeder Ausführung von Setup werden Protokolldateien in einem neuen Protokollordner erstellt, der einen Zeitstempel aufweist, und zwar unter %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\. Das Namensformat für mit einem Zeitstempel versehene Protokollordner ist JJJJMMTT_hhmmss. Wenn Setup in einem unbeaufsichtigten Modus ausgeführt wird, werden die Protokolle unter %temp%\sqlsetup*.log erstellt. Alle Dateien in den Protokollordnern werden in der Log*.cab-Datei im jeweiligen Protokollordner archiviert.

Eine typische Setupanforderung durchläuft drei Ausführungsphasen:

  1. Überprüfung der allgemeinen Regeln

  2. Komponentenupdate

  3. Vom Benutzer angeforderte Aktion

In jeder dieser Phasen werden Detail- und Zusammenfassungsprotokolle generiert, wobei je nach Bedarf auch noch zusätzliche Protokolldateien generiert werden. Das Setup wird mindestens dreimal pro vom Benutzer angeforderter Setupaktion aufgerufen.

Datenspeicherdateien enthalten eine Momentaufnahme vom Zustand aller Konfigurationsobjekte, die vom Setupprozess nachverfolgt werden, und sind bei der Behebung von Konfigurationsfehlern nützlich. Für jede Ausführungsphase werden XML-Dateidumps von Datenspeicherobjekten erstellt. Sie werden in einem eigenen Protokollunterordner unter dem mit einem Zeitstempel versehenen Protokollordner wie folgt gespeichert:

  • Datastore_GlobalRules

  • Datastore_ComponentUpdated

  • Datastore

In den folgenden Abschnitten werden die SQL Server-Setupprotokolldateien beschrieben.

Zusammenfassungstext

Übersicht

In dieser Datei werden die SQL Server-Komponenten, die beim Setup entdeckt wurden, die Betriebssystemumgebung, die Parameterwerte für die Befehlszeile, wenn diese angegeben wurden, und der allgemeine Status jeder MSI-/MSP-Datei, die ausgeführt wurde, angegeben.

Das Protokoll ist in folgende Abschnitte unterteilt:

  • Eine allgemeine Zusammenfassung der Ausführung

  • Eigenschaften und Konfiguration des Computers, auf dem das SQL Server-Setup ausgeführt wurde

  • Zuvor auf dem Computer installierte SQL Server-Produktfeatures

  • Die Beschreibung der Installationsversion und der Installationspaketeigenschaften

  • Laufzeiteingabeeinstellungen, die während der Installation angegeben werden

  • Speicherort der Konfigurationsdatei

  • Details zu den Ausführungsergebnissen

  • Globale Regeln

  • Für das Installationsszenario spezifische Regeln

  • Regeln, bei denen Fehler aufgetreten sind

  • Speicherort der Regelberichtdatei

Speicherort

Der Speicherort lautet %Programme%\Microsoft SQL Server\110\Setup Bootstrap\Log\.

Um Fehler in der Textdatei zu finden, die die Zusammenfassung enthält, durchsuchen Sie die Datei nach den Stichwörtern "error" oder "failed".

Summary_engine-base_YYYYMMDD_HHMMss.txt

Übersicht

Die summary_engine-Basisdatei ähnelt der Zusammenfassungsdatei und wird während des Hauptworkflows generiert.

Speicherort

Der Speicherort lautet %Programme%\Microsoft SQL Server\110\Setup Bootstrap\Log\<JJJJMMTT_HHMM>\.

Summary_engine-base_JJJJMMTT_HHMMss_ComponentUpdate.txt

Übersicht

Die Komponentenupdate-Zusammenfassungsprotokolldatei ähnelt der Zusammenfassungsdatei und wird während des Komponentenupdateworkflows generiert.

Speicherort

Der Speicherort lautet %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<JJJJMMTT_HHMM>\.

Summary_engine-base_<Versionsnummer>MMTT_HHMMss_GlobalRules.txt

Übersicht

Die Zusammenfassungsprotokolldatei für die globalen Regeln ähnelt der Zusammenfassungsdatei und wird während des Workflows für allgemeine Regeln generiert.

Speicherort

Der Speicherort lautet %Programme%\Microsoft SQL Server\110\Setup Bootstrap\Log\<JJJJMMTT_HHMM>\.

Detail.txt

Übersicht

Die Datei Detail.txt wird für den Hauptworkflow wie Installation oder Upgrade generiert und liefert Einzelheiten zur Ausführung. Die Protokolle in der Datei werden basierend auf dem Zeitpunkt generiert, zu dem die Installationsaktionen aufgerufen wurden. Sie zeigen die Reihenfolge, in der die Aktionen ausgeführt wurden, und ihre Abhängigkeiten.

Speicherort

Der Speicherort lautet %Programme%\Microsoft SQL Server\110\Setup.

Bootstrap\Log\<JJJJMMTT_HHMM>\Detail.txt.

Wenn während des Setupvorgangs ein Fehler auftritt, wird die Ausnahme oder der Fehler am Ende dieser Datei protokolliert. Um die Fehler zu finden, prüfen Sie daher zunächst das Ende der Datei, und suchen Sie dann nach den Stichwörtern "Fehler" oder "Ausnahme".

Detail_ComponentUpdate.txt

Übersicht

Die Datei Detail_ComponentUpdate.txt wird für den Komponentenupdateworkflow generiert und ähnelt der Datei Detail.txt.

Speicherort

Der Speicherort lautet %Programme%\Microsoft SQL Server\110\Setup Bootstrap\Log\<JJJJMMTT_HHMM>\.

Detail_GlobalRules.txt

Übersicht

Die Datei Detail_GlobalRules.txt wird für die Ausführung der globalen Regeln generiert und ähnelt der Datei Detail.txt.

Speicherort

Der Speicherort lautet %Programme%\Microsoft SQL Server\110\Setup Bootstrap\Log\<JJJJMMTT_HHMM>\.

MSI-Protokolldateien

Übersicht

Die MSI-Protokolldateien liefern Details zum Installationspaketprozess. Sie werden durch MSIEXEC während der Installation des angegebenen Pakets generiert.

Typen von MSI-Protokolldateien:

  • <Feature>_<Architektur>_<Interaktion>.log

  • <Feature>_<Architektur>_<Sprache>_<Interaktion>.log

  • <Feature>_<Architektur>_<Interaktion>_<Workflow>.log

Speicherort

Die MSI-Protokolldateien befinden sich unter %Programme%\Microsoft SQL Server\110\Setup Bootstrap\Log\<JJJJMMTT_HHMM>\<Name>.log.

Am Ende der Datei ist eine Zusammenfassung der Ausführung zu finden, die Aufschluss über eventuelle Fehler gibt. Um die Fehler in der MSI-Datei zu finden, suchen Sie nach "value 3". In der Regel sind die Fehler in der Nähe dieser Zeichenfolge zu finden.

ConfigurationFile.ini

Übersicht

Die Konfigurationsdatei enthält die Eingabeeinstellungen, die während der Installation angegeben werden. Sie kann verwendet werden, um eine Installation neu zu starten, ohne die Einstellungen manuell eingeben zu müssen. Kennwörter für die Konten, die PID und einige Parameter werden jedoch nicht in der Konfigurationsdatei gespeichert. Diese Einstellungen können der Datei entweder hinzugefügt oder über die Befehlszeile oder die Setupbenutzeroberfläche angegeben werden. Weitere Informationen finden Sie unter Installieren von SQL Server 2012 mithilfe einer Konfigurationsdatei (http://go.microsoft.com/fwlink/?LinkId=231296).

Speicherort

Der Speicherort lautet %Programme%\Microsoft SQL Server\110\Setup Bootstrap\Log\<JJJJMMTT_HHMM>\.

SystemConfigurationCheck_Report.htm

Übersicht

Im Bericht zur Systemkonfigurationsprüfung sind eine kurze Beschreibung für jede ausgeführte Regel sowie der Ausführungsstatus enthalten.

Speicherort

Der Speicherort lautet %Programme%\Microsoft SQL Server\110\Setup Bootstrap\Log\<JJJJMMTT_HHMM>\.

Siehe auch

Konzepte

Fehlerbehebung in einer Installation von SQL Server


Fehlerbehebung in einer Installation von SQL Server

[image]

Fehlerbehebung in einer Installation von SQL Server
Siehe auch Feedback senden

Informationen zu Problemen mit der Installation und dem Upgrade finden Sie in der Infodatei zu SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=196910).

Siehe auch

Konzepte

Lesen und Anzeigen der Setupprotokolldateien von SQL Server


Informationen zur Benutzeroberfläche des SQL Server-Setups

[image]

Informationen zur Benutzeroberfläche des SQL Server-Setups
Feedback senden

In diesem Abschnitt werden die Installationsoptionen des Installations-Assistenten für SQL Server beschrieben.


Akzeptieren von Lizenzbedingungen

[image]

Akzeptieren von Lizenzbedingungen
Siehe auch Feedback senden

Mithilfe der Seite Lizenzbedingungen akzeptieren des Installations-Assistenten für SQL Server können Sie die Lizenzbedingungen für diese Version von SQL Server akzeptieren.

Sie können den Lizenzvertrag drucken oder in die Zwischenablage kopieren. Akzeptieren Sie die Lizenzbedingungen, und klicken Sie dann auf Weiter, um den Vorgang fortzusetzen. Um die Installation zu beenden, klicken Sie auf Abbrechen.

Erstellen von Funktionsverwendungsberichten

Wenn Sie die Erstellung von Funktionsverwendungsberichten aktivieren, wird SQL Server so konfiguriert, dass in regelmäßigen Abständen ein Bericht an Microsoft gesendet wird. Die Berichte beinhalten Informationen zur Hardwarekonfiguration und zur Verwendung von SQL Server und zugehörigen Komponenten. Microsoft verwendet die Funktionsverwendungsdaten, um SQL Server weiter zu verbessern. Folgende SQL Server-Komponenten werden von dieser Funktion überwacht:

  • Database Engine (Datenbankmodul)

  • Analysis Services

  • Reporting Services

  • Integration Services

  • Replikation

  • SQL Server-Datentools (SSDT)

  • SQL Server-Setup

Informationen zur Funktionsverwendung werden an Microsoft gesendet und dort mit eingeschränktem Zugriff gespeichert.

Um nach Abschluss von Setup die Erstellung von Funktionsverwendungsberichten zu deaktivieren, verwenden Sie das Tool Fehler- und Verwendungsberichterstellung von SQL Server im SQL Server-Menü Konfigurationstools.

Informationen zu Setupaktionen wie Installations-, Upgrade- oder Reparaturvorgängen usw. werden ausschließlich während der Ausführung des Setupprogramms erfasst und hochgeladen.

Für alle anderen SQL Server-Komponenten werden einmal täglich Informationen zu allen aktivierten Instanzen von SQL Server erfasst. Der Zeitpunkt der Erfassung ist standardmäßig Mitternacht, um die Belastung des Servers zu minimieren. Wenn Sie diesen Zeitpunkt ändern möchten, können Sie manuell den Registrierungsschlüssel bearbeiten, durch den die Erfassungszeit gesteuert wird. Jede Instanz von SQL Server hat ihren eigenen Registrierungsschlüssel:

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL11.<INSTANZ-ID>\CPE\TimeofReporting

Der Wert dieses Registrierungsschlüssels enthält den Ausführungszeitpunkt der Sammlung als Anzahl von Minuten ab 00:00 Uhr (Mitternacht). Bei einem Wert von 60 würde die Erfassung also beispielsweise um 1:00 Uhr ausgeführt werden, bei einem Wert von 1200 um 8:00 Uhr usw.

Siehe auch

Verweis

Informationen zu den SQL Server-Lizenzbedingungen


Hinzufügen von SQL Server-Failoverclusterknoten

[image]

Hinzufügen von SQL Server-Failoverclusterknoten
Siehe auch Feedback senden

Das SQL Server-Setup überprüft die Computerkonfiguration, bevor der Setupvorgang abgeschlossen wird. Während des Setups von SQL Server durchsucht die Systemkonfigurationsprüfung (System Configuration Checker, SCC) den Computer, auf dem SQL Server installiert werden soll. SCC sucht nach Bedingungen, die ein erfolgreiches Setup von SQL Server verhindern. Bevor Setup den SQL Server-Installations-Assistenten startet, ruft SCC den Status jedes Elements ab. SCC vergleicht dann das Ergebnis mit den erforderlichen Bedingungen und gibt Anweisungen zum Entfernen der Blockierungsprobleme.

Die Systemkonfigurationsprüfung generiert einen Bericht, der eine kurze Beschreibung für jede ausgeführte Regel sowie den Ausführungsstatus enthält. Der Bericht der Systemkonfigurationsprüfung befindet sich unter %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Bevor Sie Setup ausführen, lesen Sie die folgenden Themen:

  1. Hardware- und Softwareanforderungen für die Installation von SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Von den SQL Server-Editionen unterstützte Funktionen(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Sicherheitsüberlegungen für eine SQL Server-Installation(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Lokale Sprachversionen in SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Weitere Referenzen:

  1. Unterstützte Versions- und Editionsupgrades(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Vor dem Installieren des Failoverclusterings(http://go.microsoft.com/fwlink/?LinkId=235034)

Siehe auch

Verweis

Unterstützungsregeln für Setup


Analysis Services-Konfiguration – Kontobereitstellung

[image]

Analysis Services-Konfiguration – Kontobereitstellung
Siehe auch Feedback senden

Verwenden Sie diese Seite zum Einrichten des Servermodus und zum Zuweisen von administrativen Berechtigungen an Benutzer oder Dienste, die uneingeschränkten Zugriff auf Analysis Services benötigen. Während des Setups wird die lokale Windows-Gruppe BUILTIN\Administrators der Analysis Services-Serveradministratorrolle der Instanz, die Sie installieren, nicht automatisch hinzugefügt. Wenn Sie der Serveradministratorrolle die lokale Gruppe "Administratoren" hinzufügen möchten, müssen Sie diese Gruppe explizit angeben.

Bei der Installation von PowerPivot für SharePoint sollten Sie Administratoren von SharePoint-Farmen oder -Diensten, die für eine PowerPivot-Serverbereitstellung in einer SharePoint Server 2010-Farm zuständig sind, Administratorrechte gewähren. Weitere Informationen zur PowerPivot-Dienst-Installation und den Anforderungen an Dienstkonten finden Sie unter Installing PowerPivot for SharePoint.

Optionen

Servermodus - Der Servermodus gibt den Typ von Analysis Services-Datenbanken an, die auf dem Server bereitgestellt werden können. Servermodi werden während des Setups bestimmt und können später nicht mehr geändert werden. Die einzelnen Modi schließen einander aus. Das bedeutet, dass Sie zwei Instanzen von Analysis Services benötigen, die jeweils für einen anderen Modus konfiguriert sind, um beide klassische Lösungen - das OLAP- und das tabellarische Modell - zu unterstützen.

Administratoren angeben - Sie müssen mindestens einen Serveradministrator für die Instanz von SQL Server angeben. Die Benutzer oder die Gruppen, die Sie angeben, werden Mitglieder der Serveradministratorrolle der Analysis Services-Instanz, die Sie installieren. Diese müssen Windows-Domänenbenutzerkonten in der gleichen Domäne wie der Computer sein, auf dem Sie die Software installieren.

Hinweis Hinweis

Die Benutzerkontensteuerung (User Account Control, UAC) ist eine Windows-Sicherheitsfunktion, bei der ein Administrator administrative Aktionen oder Anwendungen einzeln genehmigen muss, bevor diese ausgeführt werden können. Da die Benutzerkontensteuerung in den Standardeinstellungen aktiviert ist, werden Sie aufgefordert, einzelne Vorgänge, für die erhöhte Berechtigungen erforderlich sind, zu genehmigen. Sie können die Benutzerkontensteuerung konfigurieren, um das Standardverhalten zu ändern, oder sie für bestimmte Programme anpassen. Weitere Informationen über die Benutzerkontensteuerung und deren Konfiguration finden Sie unter Schrittweise Anleitung zur Benutzerkontensteuerung und Benutzerkontensteuerung (Wikipedia).

Siehe auch

Andere Ressourcen

Ändern von Dienstkonten und Kennwörtern (PowerPivot für SharePoint)
Konfigurieren des Analysis Services-Dienstkontos
Einrichten von Windows-Dienstkonten


Konfigurationseigenschaften von Analysis Services – Datenverzeichnisse

[image]

Konfigurationseigenschaften von Analysis Services – Datenverzeichnisse
Siehe auch Feedback senden

Die in der folgenden Tabelle angegebenen Standardverzeichnisse können beim Setup von SQL Server vom Benutzer konfiguriert werden: Die Berechtigung zum Zugriff auf diese Dateien wird den lokalen Administratoren und Mitgliedern der Sicherheitsgruppe SQLServerMSASUser $<Instanz> gewährt, die während des Setups erstellt und bereitgestellt wird.

Beschreibung

Standardverzeichnis

Empfehlungen

Datenstammverzeichnis

C:\Programme\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Data\

Stellen Sie sicher, dass der Ordner \Programme\Microsoft SQL Server\ durch entsprechend eingeschränkte Berechtigungen geschützt wird. Die Leistung von Analysis Services ist in vielen Konfigurationen von der Leistung des Speichers abhängig, in dem sich das Datenverzeichnis befindet. Platzieren Sie dieses Verzeichnis im Speicher mit der höchsten Leistung, der mit dem System verknüpft ist. Stellen Sie für Failoverclusterinstallationen sicher, dass Datenverzeichnisse auf dem freigegebenen Datenträger platziert werden.

Protokolldateiverzeichnis

C:\Programme\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Log\

Dies ist das Verzeichnis für Analysis Services-Protokolldateien, das auch das FlightRecorder-Protokoll enthält. Wenn Sie die Dauer von Flight Recorder erhöhen, stellen Sie sicher, dass für das Protokollverzeichnis genügend Speicherplatz zur Verfügung steht.

Temporäres Verzeichnis

C:\Programme\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Temp\

Platzieren Sie das temporäre Verzeichnis in einem leistungsstarken Speichersubsystem.

Sicherungsverzeichnis

C:\Programme\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Backup\

Dies ist das Verzeichnis für Standardsicherungsdateien von Analysis Services. Bei einer PowerPivot für SharePoint-Installation werden in diesem Verzeichnis zudem die PowerPivot-Datendateien des PowerPivot-Systemdiensts zwischengespeichert.

Stellen Sie sicher, dass zur Vermeidung von Datenverlusten entsprechende Berechtigungen festgelegt wurden und die Benutzergruppe für den Analysis Services-Dienst über die erforderlichen Berechtigungen zum Schreiben im Sicherungsverzeichnis verfügt. Die Verwendung eines zugeordneten Laufwerks für Sicherungsverzeichnisse wird nicht unterstützt.

Hinweise

  • Auf einer SharePoint-Farm bereitgestellte Analysis Services-Instanzen speichern Anwendungsdateien, Datendateien und Eigenschaften in Inhaltsdatenbanken und Dienstanwendungsdatenbanken.

  • Wenn Sie Funktionen zu einer vorhandenen Installation hinzufügen, können Sie den Speicherort einer vorher installierten Funktion nicht ändern und auch keinen Speicherort für eine neue Funktion angeben.

  • Wenn Sie keine Standardverzeichnisse angeben, sollten Sie sicherstellen, dass die Installationsordner nur für die Instanz SQL Server verwendet werden. Keines der Verzeichnisse in diesem Dialogfeld sollte gemeinsam mit Verzeichnissen von anderen SQL Server-Instanzen genutzt werden. Die Database Engine (Datenbankmodul)- und Analysis Services-Komponenten in einer Instanz von SQL Server sollten ebenfalls in separaten Verzeichnissen installiert werden.

  • Programmdateien und Datendateien können in den folgenden Situationen nicht installiert werden:

    • Auf einem Wechseldatenträger

    • In einem Dateisystem, in dem die Komprimierung verwendet wird

    • In einem Verzeichnis, in dem sich Systemdateien befinden

    • Auf freigegebenen Laufwerken einer Failoverclusterinstanz

Siehe auch

Konzepte

Dateispeicherorte für Standard- und benannte Instanzen von SQL Server


Datenträgerauswahl für Cluster

[image]

Datenträgerauswahl für Cluster
Feedback senden

Verwenden Sie die Seite Datenträgerauswahl für Cluster des Installations-Assistenten von SQL Server, um die freigegebene Cluster-Datenträgerressource für den SQL Server-Failovercluster auszuwählen. Auf dem Clusterdatenträger werden die SQL Server-Daten platziert.

Für SQL Server Database Engine (Datenbankmodul)-Clusterinstallationen ist ein freigegebener Clusterdatenträger keine Voraussetzung. Ein SMB-Dateiserver ist ein unterstützter Speicher für SQL Server Database Engine (Datenbankmodul)-Failoverclusterinstallationen, der auf der Seite Datenbankmodul – Datenverzeichnisse während der Installation angegeben werden kann.

Vorsichtshinweis Vorsicht

Wenn Sie Analysis Services installieren möchten, müssen Sie einen freigegebenen Clusterdatenträger angeben.

Wenn FILESTREAM in dieser SQL Server-Failoverclusterinstanz aktiviert werden soll, müssen Sie einen freigegebenen Clusterdatenträger angeben.

Optionen

Freigegebene Datenträger

Wählen Sie einen Datenträger aus der Liste aus. Auf dem Clusterdatenträger werden die SQL Server-Daten platziert.

Es kann nur ein Datenträger angegeben werden. Wenn Sie die Gruppe mit der Quorumressource des Clusters auswählen, wird eine Warnung angezeigt. Von einer Installation in der Quorumressource des Clusters wird abgeraten.

Verfügbare freigegebene Datenträger

Zeigt eine Liste der verfügbaren Datenträger, Informationen zur Qualifikation der Datenträger als freigegebene Datenträger und eine Beschreibung der einzelnen Datenträgerressourcen an.


Netzwerkkonfiguration für Cluster

[image]

Netzwerkkonfiguration für Cluster
Feedback senden

Verwenden Sie die Seite Netzwerkauswahl für Cluster, um die Netzwerkressourcen für die Failoverclusterinstanz anzugeben.

Optionen

Netzwerkname des SQL Server-Failoverclusters - Mit diesem Namen wird die Failoverclusterinstanz im Netzwerk identifiziert.

Netzwerkeinstellungen - Geben Sie den IP-Typ und die IP-Adresse für die Failoverclusterinstanz an.

SQL Server zeigt während der Vorgänge Knoten hinzufügen und Knoten entfernen eine schreibgeschützte Liste vorhandener IP-Adressen für den SQL Server-Failovercluster an.

  • Integrierte Installation:

    • Wenn Sie einen Knoten hinzufügen, der einen identischen Satz von Netzwerksubnetzen unterstützt, der von den vorhandenen Knoten des SQL Server-Failoverclusters unterstützt wird, können keine zusätzlichen IP-Adressen hinzugefügt werden. Die Abhängigkeitseinstellung bleibt unverändert.

    • Wenn Sie einen Knoten hinzufügen, der eine Teilmenge der Subnetze unterstützt, die von den vorhandenen Knoten im SQL Server-Failovercluster unterstützt werden, können keine zusätzlichen IP-Adressressourcen hinzugefügt werden. Die Abhängigkeit der IP-Adressressource ist auf OR festgelegt, da nicht alle angegebenen IP-Adressen für alle Clusterknoten gültig sind.

    • Wenn Sie einen Knoten hinzufügen, der zusätzlich zu den Subnetzen, die von den bereits im SQL Server-Failovercluster vorhandenen Knoten unterstützt werden, weitere Subnetze unterstützt, können Sie neue gültige IP-Adressen hinzufügen. Bei der Angabe neuer IP-Adressen wird die Abhängigkeit der IP-Adressressource auf OR festgelegt, da nicht alle angegebenen IP-Adressen für alle Clusterknoten gültig sind.

    • Wenn Sie einen Knoten hinzufügen, der zusätzliche Netzwerksubnetze unterstützt, jedoch keines der Subnetze, das von den im SQL Server-Failovercluster vorhandenen Knoten unterstützt wird, müssen Sie zusätzliche IP-Adressen hinzufügen. Die Abhängigkeit der IP-Adressressource ist auf OR festgelegt, da nicht alle angegebenen IP-Adressen für alle Clusterknoten gültig sind.

  • Erweiterte Installation: Geben Sie während des Schritts Abschließen der Installation die IP-Adresse sämtlicher Knoten und Subnetze für die Failoverclusterinstanz an. Sie können für einen Multisubnetz-Failovercluster mehrere IP-Adressen angeben, jedoch wird nur eine IP-Adresse pro Subnetz unterstützt. Jeder vorbereitete Knoten sollte Besitzer von mindestens einer IP-Adresse sein. Wenn im SQL Server-Failovercluster mehrere Subnetze vorhanden sind, werden Sie aufgefordert, die Abhängigkeit der IP-Adressressource auf OR festzulegen. Knoten entfernen:

    • Wenn die restlichen IP-Adressen in allen restlichen Knoten unterstützt werden, werden Sie aufgefordert, die Abhängigkeit der IP-Adressressource auf AND festzulegen.

    • Wenn die restlichen IP-Adressen nicht in allen restlichen Knoten unterstützt werden, bleibt die Abhängigkeit der IP-Adressressource auf OR festgelegt.


Clusterknotenkonfiguration

[image]

Clusterknotenkonfiguration
Feedback senden

Verwenden Sie die Seite Clusterknotenkonfiguration, um Knoten einer Failoverclusterinstanz hinzuzufügen oder daraus zu entfernen. Zum Installieren oder Aktualisieren eines SQL Server-Failoverclusters müssen Sie das Setupprogramm für jeden einzelnen Knoten des Failoverclusters ausführen. Zum Hinzufügen eines Knotens zu einem vorhandenen SQL Server-Failovercluster müssen Sie SQL Server-Setup für den Knoten ausführen, der der SQL Server-Failoverclusterinstanz hinzugefügt werden soll.

Optionen

Name der SQL Server-Instanz - Verwenden Sie die Dropdownliste, um die zu ändernde SQL Server-Failoverclusterinstanz auszuwählen.

Name dieses Knotens - Dieses Feld wird mit dem Namen des Computers aufgefüllt, der das SQL Server-Setup ausführt. Dies ist der Failoverclusterknoten, der der SQL Server-Failoverclusterinstanz hinzugefügt oder daraus entfernt wird.


Clusterknotenkonfiguration (Vollständig)

[image]

Clusterknotenkonfiguration (Vollständig)
Feedback senden

Auf der Seite Clusterknotenkonfiguration (Vollständig) können Sie eine vorhandene Instanz von SQL Server angeben, die für das Clustering vorbereitet wurde. Zum Installieren oder Aktualisieren eines SQL Server-Failoverclusters müssen Sie das Setupprogramm für jeden einzelnen Knoten des Failoverclusters ausführen. Zum Hinzufügen eines Knotens zu einem vorhandenen SQL Server-Failovercluster müssen Sie SQL Server-Setup für den Knoten ausführen, der der SQL Server-Failoverclusterinstanz hinzugefügt werden soll.

Optionen

Auswahl aus den Dropdownfeldern:

  • SQL Server-Instanzname – Wählen Sie den Namen der Instanz für den SQL Server-Failovercluster aus.

  • Name dieses Knotens – Dieses Feld wird mit dem Namen des Computers aufgefüllt, auf dem das SQL Server-Setup ausgeführt wird.

  • Netzwerkname des SQL Server-Failoverclusters – Dieses Feld ist nicht im Voraus ausgefüllt. Geben Sie den Netzwerknamen für die neue Instanz des SQL Server-Failoverclusters an. Anhand dieses Namens wird die Failoverclusterinstanz im Netzwerk identifiziert.


Clusterressourcengruppe

[image]

Clusterressourcengruppe
Siehe auch Feedback senden

Auf der Seite Clusterressourcengruppe können Sie den Datenträger angeben, auf dem sich die Ressourcen des virtuellen Servers für SQL Server befinden.

Optionen

Geben Sie den Namen der SQL Server-Clusterressourcengruppe an. Hierfür stehen zwei Möglichkeiten zur Verfügung:

  • Geben Sie die vorhandene Gruppe, die Sie verwenden möchten, mithilfe des Dropdownfelds an.

  • Geben Sie den Namen der neuen Gruppe ein, die Sie erstellen möchten. Beachten Sie, dass der Name "Verfügbarer Speicherplatz" kein gültiger Gruppenname ist.

Siehe auch

Andere Ressourcen

Vorgehensweise: Erstellen eines neuen SQL Server-Failoverclusters


Sicherheitsrichtlinie für Cluster

[image]

Sicherheitsrichtlinie für Cluster
Feedback senden

Verwenden Sie die Seite Sicherheitsrichtlinie für Cluster, um die Sicherheitsrichtlinie für die Failoverclusterinstanz zu konfigurieren.

Optionen

Geben Sie globale oder lokale Domänegruppen für Clusterdienste an. Alle Ressourcenberechtigungen werden durch Gruppen auf Domänenebene gesteuert, die SQL Server-Dienstkonten als Mitglieder enthalten. Weitere Informationen über die Dienstsicherheits-ID (SID)-Funktionen für Windows Server 2008 finden Sie unter Einrichten von Windows-Dienstkonten.

Wenn Sie eine Microsoft SQL Server 2012-Failoverclusterinstanz in einer Windows 2000-Domäne im gemischten Modus installieren, müssen Sie globale Domänengruppen für gruppierte SQL Server-Dienste verwenden.

Hinweis Hinweis

Windows 2000-Domänencontroller können im gemischten Modus und einheitlichen Modus verwendet werden. Im gemischten Modus sind Domänencontroller der unteren Ebene in der gleichen Domäne zulässig.


Abgeschlossen - Image abschließen

[image]

Abgeschlossen - Image abschließen
Feedback senden

Auf der Seite Abgeschlossen können Sie überprüfen, ob die Konfiguration der vorbereiteten Instanz abgeschlossen ist.

Optionen

Dieses Dialogfeld enthält einen Link zur Setupprotokolldatei für diesen Vorgang. Um die Installation abzuschließen, klicken Sie auf Schließen.


Status des Imageabschlusses

[image]

Status des Imageabschlusses
Siehe auch Feedback senden

Auf der Seite Status des Imageabschlusses des SQL Server-Installations-Assistenten können Sie den Status des SQL Server-Imageabschlusses überwachen. Nach dem Abschluss dieses Schritts wird auf dieser Seite der Status der konfigurierten und abgeschlossenen SQL Server-Funktionen angezeigt.

Siehe auch

Konzepte

Lesen und Anzeigen der Setupprotokolldateien von SQL Server


Regeln zum Abschließen des Images

[image]

Regeln zum Abschließen des Images
Feedback senden

Das SQL Server-Setup überprüft die Computerkonfiguration, bevor der Setupvorgang abgeschlossen wird. Während des Setups von SQL Server durchsucht die Systemkonfigurationsprüfung (System Configuration Checker, SCC) den Computer, auf dem SQL Server installiert werden soll. SCC sucht nach Bedingungen, die ein erfolgreiches Setup von SQL Server verhindern. Bevor Setup den SQL Server-Installations-Assistenten startet, ruft SCC den Status jedes Elements ab. SCC vergleicht dann das Ergebnis mit den erforderlichen Bedingungen und gibt Anweisungen zum Entfernen der Blockierungsprobleme.

Die Systemkonfigurationsprüfung generiert einen Bericht, der eine kurze Beschreibung für jede ausgeführte Regel sowie den Ausführungsstatus enthält. Der Bericht der Systemkonfigurationsprüfung befindet sich unter %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Bevor Sie Setup ausführen, lesen Sie die folgenden Themen:

  1. Hardware- und Softwareanforderungen für die Installation von SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Von den SQL Server-Editionen unterstützte Funktionen(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Sicherheitsüberlegungen für eine SQL Server-Installation(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Lokale Sprachversionen in SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Weitere Referenzen:

  1. Unterstützte Versions- und Editionsupgrades(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Vor dem Installieren des Failoverclusterings(http://go.microsoft.com/fwlink/?LinkId=235034)


Abgeschlossen - Image vorbereiten

[image]

Abgeschlossen - Image vorbereiten
Feedback senden

Auf der Seite Abgeschlossen können Sie überprüfen, ob die Imagevorbereitung abgeschlossen ist.

Optionen

Dieses Dialogfeld enthält einen Link zur Setupprotokolldatei für diesen Vorgang. Um die Imagevorbereitung abzuschließen, Klicken Sie auf Schließen.


Abgeschlossen - Reparieren

[image]

Abgeschlossen - Reparieren
Feedback senden

Auf der Seite Abgeschlossen - Reparieren können Sie überprüfen, ob die Reparatur abgeschlossen wurde.

Optionen

Dieses Dialogfeld enthält einen Link zur Setupprotokolldatei für diesen Vorgang. Klicken Sie auf Schließen, um den Vorgang fortzusetzen.


Abgeschlossen (Upgrade)

[image]

Abgeschlossen (Upgrade)
Feedback senden

Auf der Seite Abgeschlossen (Upgrade) können Sie überprüfen, ob das Upgrade abgeschlossen wurde.

Optionen

Dieses Dialogfeld enthält einen Link zur Setupprotokolldatei für diesen Vorgang. Klicken Sie auf Schließen, um den Vorgang fortzusetzen.


Konfiguration des Datenbankmoduls - Kontobereitstellung

[image]

Konfiguration des Datenbankmoduls - Kontobereitstellung
Siehe auch Feedback senden

Auf dieser Seite können Sie den SQL Server-Sicherheitsmodus festlegen und Windows-Benutzer oder -Gruppen als Administratoren von SQL Server Database Engine (Datenbankmodul) hinzufügen.

Überlegungen zum Ausführen von SQL Server 2012 unter Windows Vista, Windows 7 und Windows Server 2008

In früheren Versionen von SQL Server wurde die Gruppe BUILTIN\Administrators für die Anmeldung bei Database Engine (Datenbankmodul) bereitgestellt, und Mitglieder der lokalen Administratorgruppe konnten sich mit ihren Administratoranmeldeinformationen anmelden. Die Verwendung von erhöhten Berechtigungen ist keine bewährte Vorgehensweise. In Microsoft SQL Server 2012 wird die Gruppe BUILTIN\Administrators nicht für die Anmeldung bereitgestellt. Daher sollten Sie für jeden Administratorbenutzer eine SQL Server-Anmeldung erstellen und diese während der Installation einer neuen Instanz von Microsoft SQL Server 2012 der festen Serverrolle sysadmin hinzufügen. Gehen Sie genauso für Windows-Konten vor, die zum Ausführen von SQL Server-Agent-Aufträgen verwendet werden. Dies schließt auch Replikations-Agent-Aufträge ein.

Optionen

Sicherheitsmodus – Wählen Sie Windows-Authentifizierung oder die Authentifizierung im gemischten Modus für die Installation aus.

Windows-Prinzipal-Bereitstellung - In früheren Versionen von SQL Server befand sich die lokale Windows-Gruppe Vordefiniert\Administrator in der sysadmin-Serverrolle von SQL Server, wodurch die Windows-Administratoren effektiv Zugriff auf die SQL Server-Instanz erhielten. In Microsoft SQL Server 2012 wird die Gruppe Vordefiniert\Administrator nicht in der sysadmin-Serverrolle bereitgestellt. Stattdessen sollten Sie während des Setups explizit SQL Server-Administratoren für Neuinstallationen festlegen.

Wichtiger Hinweis Wichtig

Sie müssen SQL Server-Administratoren für Neuinstallationen während des Setups explizit festlegen. Sie können den Setup-Vorgang erst nach Ausführung dieses Schrittes fortsetzen.

SQL Server-Administratoren angeben - Sie müssen wenigstens einen Windows-Prinzipal für die Instanz von SQL Server angeben. Um das Konto hinzuzufügen, unter dem das SQL Server-Setup ausgeführt werden soll, klicken Sie auf die Schaltfläche Aktueller Benutzer. Um Konten zur Liste der Systemadministratoren hinzuzufügen bzw. daraus zu entfernen, klicken Sie auf Hinzufügen bzw. Entfernen, und bearbeiten Sie anschließend die Liste der Benutzer, Gruppen bzw. Computer, die Administratorrechte für die SQL Server-Instanz haben sollen.

Wenn Sie die Bearbeitung der Liste abgeschlossen haben, klicken Sie auf OK, und überprüfen Sie anschließend die Liste der Administratoren im Konfigurationsdialogfeld. Sobald die Liste vollständig ist, klicken Sie auf Weiter.

Bei Auswahl des gemischten Authentifizierungsmodus müssen Sie Anmeldeinformationen für das vordefinierte SQL Server-Systemadministrator-(SA-)Konto angeben.

Sicherheitshinweis Sicherheitshinweis

Verwenden Sie kein leeres Kennwort. Verwenden Sie ein sicheres Kennwort.

Windows-Authentifizierungsmodus

Wenn ein Benutzer eine Verbindung über ein Windows-Benutzerkonto herstellt, überprüft SQL Server Kontonamen und Kennwort mithilfe des Tokens für den Windows-Prinzipal im Betriebssystem. Dieser als Standardauthentifizierungsmodus verwendete Modus bietet eine höhere Sicherheit als der gemischte Modus. Die Windows-Authentifizierung verwendet das Kerberos-Sicherheitsprotokoll, stellt Maßnahmen zur Durchsetzung von Kennwortrichtlinien, z. B. zur Überprüfung der Komplexität sicherer Kennwörter, bereit und bietet Unterstützung für Kontosperrungen und Ablauf von Kennwörtern.

Sicherheitshinweis Sicherheitshinweis

Verwenden Sie nach Möglichkeit die Windows-Authentifizierung.

Wichtiger Hinweis Wichtig

Verwenden Sie kein leeres Kennwort. Verwenden Sie ein sicheres Kennwort. Legen Sie auf keinen Fall ein leeres oder unsicheres sa-Kennwort fest.

Gemischter Modus (Windows-Authentifizierung oder SQL Server-Authentifizierung)

Ermöglicht Benutzern das Herstellen einer Verbindung mithilfe der Windows-Authentifizierung bzw. der SQL Server-Authentifizierung. Benutzer, die mithilfe eines Windows-Benutzerkontos Verbindungen herstellen, können vertrauenswürdige Verbindungen verwenden, die von Windows überprüft werden.

Wenn Sie den gemischten Authentifizierungsmodus auswählen und beim Ausführen älterer Anwendungen ausschließlich SQL-Anmeldungen verwenden, müssen Sie für alle SQL Server-Konten sichere Kennwörter festlegen.

Hinweis Hinweis

Die SQL Server-Authentifizierung wird nur aus Gründen der Abwärtskompatibilität bereitgestellt. Verwenden Sie nach Möglichkeit die Windows-Authentifizierung.

Kennwort eingeben

Geben Sie die Systemadministratoranmeldung (sa) ein, und bestätigen Sie sie. Kennwörter dienen als erste Schutzmaßnahme gegen Eindringlinge, daher ist die Festlegung sicherer Kennwörter von entscheidender Bedeutung für die Systemsicherheit. Legen Sie auf keinen Fall ein leeres oder unsicheres sa-Kennwort fest.

Hinweis Hinweis

SQL Server-Kennwörter können zwischen 1 und 128 Zeichen (Kombinationen aus Buchstaben, Sonderzeichen und Ziffern) enthalten. Wenn Sie den gemischten Authentifizierungsmodus auswählen, müssen Sie ein sicheres sa-Kennwort eingeben, bevor Sie den Vorgang auf der nächsten Seite des Installations-Assistenten fortsetzen können.

Richtlinien für sichere Kennwörter

Sichere Kennwörter können von anderen nur schwer erraten und selbst von Computerprogrammen nicht ohne größeren Aufwand ausgespäht werden. Beim Festlegen von sicheren Kennwörtern dürfen keine verbotenen Richtlinien oder Bestimmungen verwendet werden, z. B.:

  • Leeres Kennwort oder NULL

  • "Password"

  • "Admin"

  • "Administrator"

  • "sa"

  • "sysadmin"

Beim Festlegen von sicheren Kennwörtern dürfen keine Angaben verwendet werden, die auf den Computer mit der Installation verweisen:

  • Der Name des Benutzers, der zurzeit auf dem Computer angemeldet ist.

  • Der Computername.

Ein sicheres Kennwort muss mehr als 8 Zeichen enthalten und wenigstens drei der folgenden vier Kriterien erfüllen:

  • Es muss Großbuchstaben enthalten.

  • Es muss Kleinbuchstaben enthalten.

  • Es muss Zahlen enthalten.

  • Es muss nicht alphanumerische Zeichen, z. B. #, % oder ^, enthalten.

Auf dieser Seite eingegebene Kennwörter müssen die Anforderungen der Richtlinien für sichere Kennwörter erfüllen. Bei Automatisierungen, die die SQL Server-Authentifizierung verwenden, sollten Sie sicherstellen, dass das Kennwort die Anforderungen der Richtlinien für sichere Kennwörter erfüllt.

Verwandte Inhalte

Weitere Informationen zum Auswählen von Windows-Authentifizierung im Vergleich zu Die SQL Server-Authentifizierung finden Sie im Thema Auswählen eines Authentifizierungsmodus in der SQL Server-Onlinedokumentation.

Weitere Informationen zur Auswahl eines Kontos für die Ausführung von SQL Server Database Engine (Datenbankmodul) finden Sie im Thema Konfigurieren von Windows-Dienstkonten und -Berechtigungen in der SQL Server-Onlinedokumentation.

Siehe auch

Verweis

Konfigurieren von Windows-Dienstkonten und -Berechtigungen


Konfiguration des Datenbankmodells – Datenverzeichnisse

[image]

Konfiguration des Datenbankmodells &#8211; Datenverzeichnisse
Siehe auch Feedback senden

Verwenden Sie diese Seite, um den Installationspfad für das SQL Server Database Engine (Datenbankmodul)-Programm und die Datendateien anzugeben. Auf Grundlage des Typs der Installation schließt der unterstützte Speicher möglicherweise einen lokalen Datenträger, freigegebenen Speicher oder SMB-Dateiserver ein.

Um eine SMB-Dateifreigabe als Verzeichnis anzugeben, müssen Sie den unterstützten UNC-Pfad manuell eingeben. Das Navigieren zu einer SMB-Dateifreigabe wird nicht unterstützt. Das folgende Format ist ein unterstütztes UNC-Pfadformat einer SMB-Dateifreigabe: "\\Servername\ShareName\..."

Eigenständige Instanz von SQL Server

In der folgenden Tabelle sind die unterstützten Speichertypen und die Standardverzeichnisse für eine eigenständige Instanz von SQL Server aufgeführt, die während des SQL Server-Setups vom Benutzer konfigurierbar sind.

Beschreibung | Unterstützter Speichertyp | Standardverzeichnis | Empfehlungen
Datenstammverzeichnis | Lokaler Datenträger, SMB-Dateiserver, freigegebener Speicher 1 | C:\Programme\Microsoft SQL Server\ | Das SQL Server-Setup konfiguriert Zugriffssteuerungslisten für SQL Server-Verzeichnisse und unterbricht während der Konfiguration die Vererbung.
Benutzerdatenbankverzeichnis | Lokaler Datenträger, SMB-Dateiserver, freigegebener Speicher 1 | C:\Programme\Microsoft SQL Server\MSSQL11.<Instanz-ID>\MSSQL\Data | Welche Vorgehensweise für Benutzerdatenverzeichnisse empfohlen wird, hängt von der Arbeitsauslastung und den Leistungsanforderungen ab.
Benutzerdatenbank-Protokollverzeichnis | Lokaler Datenträger, SMB-Dateiserver, freigegebener Speicher 1 | C:\Programme\Microsoft SQL Server\MSSQL11.<Instanz-ID>\MSSQL\Data | Stellen Sie sicher, dass ausreichend Speicherplatz für das Protokollverzeichnis verfügbar ist.
Temporäres DB-Verzeichnis | Lokaler Datenträger, SMB-Dateiserver, freigegebener Speicher 1 | C:\Programme\Microsoft SQL Server\MSSQL11.<Instanz-ID>\MSSQL\Data | Welche Vorgehensweise für das Verzeichnis Temp empfohlen wird, hängt von der Arbeitsauslastung und den Leistungsanforderungen ab.
Temporäres DB-Protokollverzeichnis | Lokaler Datenträger, SMB-Dateiserver, freigegebener Speicher 1 | C:\Programme\Microsoft SQL Server\MSSQL11.<Instanz-ID>\MSSQL\Data | Stellen Sie sicher, dass ausreichend Speicherplatz für das Protokollverzeichnis verfügbar ist.
Sicherungsverzeichnis | Lokaler Datenträger, SMB-Dateiserver, freigegebener Speicher 1 | C:\Programme\Microsoft SQL Server\MSSQL11.<Instanz-ID>\MSSQL\Backup | Legen Sie zur Vermeidung von Datenverlusten entsprechende Berechtigungen fest, und stellen Sie sicher, dass das Benutzerkonto für den SQL Server-Dienst über die erforderlichen Berechtigungen zum Schreiben im Sicherungsverzeichnis verfügt. Die Verwendung eines zugeordneten Laufwerks für Sicherungsverzeichnisse wird nicht unterstützt.

1 Obwohl freigegebene Datenträger unterstützt werden, wird diese Vorgehensweise für eine eigenständige Instanz von SQL Server nicht empfohlen.

SQL Server-Failoverclusterinstanz

In der folgenden Tabelle sind die unterstützten Speichertypen und die Standardverzeichnisse für eine Failoverclusterinstanz von SQL Server aufgeführt, die während des SQL Server-Setups vom Benutzer konfigurierbar sind.

Beschreibung

Unterstützter Speichertyp

Standardverzeichnis

Empfehlungen

Datenstammverzeichnis

Freigegebener Speicher, SMB-Dateiserver

<Laufwerk>\Programme\Microsoft SQL Server\

Tipp Tipp

Wenn "Freigegebener Datenträger" auf der Seite Datenträgerauswahl für Cluster ausgewählt wurde, ist der Standard der erste freigegebene Datenträger. Dieses Feld ist standardmäßig leer, wenn keine Auswahl auf der Seite Datenträgerauswahl für Cluster getroffen wurde.

Das SQL Server-Setup konfiguriert Zugriffssteuerungslisten für SQL Server-Verzeichnisse und unterbricht während der Konfiguration die Vererbung.

Benutzerdatenbankverzeichnis

Freigegebener Speicher, SMB-Dateiserver

<Laufwerk:>Programme\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data

Tipp Tipp

Wenn "Freigegebener Datenträger" auf der Seite Datenträgerauswahl für Cluster ausgewählt wurde, ist der Standard der erste freigegebene Datenträger. Dieses Feld ist standardmäßig leer, wenn keine Auswahl auf der Seite Datenträgerauswahl für Cluster getroffen wurde.

Welche Vorgehensweise für Benutzerdatenverzeichnisse empfohlen wird, hängt von der Arbeitsauslastung und den Leistungsanforderungen ab.

Benutzerdatenbank-Protokollverzeichnis

Freigegebener Speicher, SMB-Dateiserver

<Laufwerk:>\Programme\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data

Tipp Tipp

Wenn "Freigegebener Datenträger" auf der Seite Datenträgerauswahl für Cluster ausgewählt wurde, ist der Standard der erste freigegebene Datenträger. Dieses Feld ist standardmäßig leer, wenn keine Auswahl auf der Seite Datenträgerauswahl für Cluster getroffen wurde.

Stellen Sie sicher, dass ausreichend Speicherplatz für das Protokollverzeichnis verfügbar ist.

Temporäres DB-Verzeichnis

Lokaler Datenträger, freigegebener Speicher, SMB-Dateiserver

<Laufwerk:>\Programme\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data

Tipp Tipp

Wenn "Freigegebener Datenträger" auf der Seite Datenträgerauswahl für Cluster ausgewählt wurde, ist der Standard der erste freigegebene Datenträger. Dieses Feld ist standardmäßig leer, wenn keine Auswahl auf der Seite Datenträgerauswahl für Cluster getroffen wurde.

Stellen Sie sicher, dass das angegebene Verzeichnis für alle Clusterknoten gültig ist. Sind die tempdb-Verzeichnisse auf dem Failoverzielknoten während des Failovers nicht verfügbar, wird die SQL Server-Ressource nicht online geschaltet.

Temporäres DB-Protokollverzeichnis

Lokaler Datenträger, freigegebener Speicher, SMB-Dateiserver

<Laufwerk:>\Programme\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data

Tipp Tipp

Wenn "Freigegebener Datenträger" auf der Seite Datenträgerauswahl für Cluster ausgewählt wurde, ist der Standard der erste freigegebene Datenträger. Dieses Feld ist standardmäßig leer, wenn keine Auswahl auf der Seite Datenträgerauswahl für Cluster getroffen wurde.

Stellen Sie sicher, dass das angegebene Verzeichnis für alle Clusterknoten gültig ist. Sind die tempdb-Verzeichnisse auf dem Failoverzielknoten während des Failovers nicht verfügbar, wird die SQL Server-Ressource nicht online geschaltet.

Sicherungsverzeichnis

Lokaler Datenträger, freigegebener Speicher, SMB-Dateiserver

<Laufwerk:>\Programme\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Backup

Tipp Tipp

Wenn "Freigegebener Datenträger" auf der Seite Datenträgerauswahl für Cluster ausgewählt wurde, ist der Standard der erste freigegebene Datenträger. Dieses Feld ist standardmäßig leer, wenn keine Auswahl auf der Seite Datenträgerauswahl für Cluster getroffen wurde.

Legen Sie zur Vermeidung von Datenverlusten entsprechende Berechtigungen fest, und stellen Sie sicher, dass das Benutzerkonto für den SQL Server-Dienst über die erforderlichen Berechtigungen zum Schreiben im Sicherungsverzeichnis verfügt. Die Verwendung eines zugeordneten Laufwerks für Sicherungsverzeichnisse wird nicht unterstützt.

Überlegungen zur Sicherheit

Das Setup konfiguriert Zugriffssteuerungslisten für SQL Server-Verzeichnisse und unterbricht während der Konfiguration die Vererbung.

Die folgenden Empfehlungen gelten für den SMB-Dateiserver:

  • Das SQL Server-Dienstkonto muss ein Domänenkonto sein, wenn ein SMB-Dateiserver verwendet wird.

  • Das Konto, das verwendet wurde, um SQL Server zu installieren, muss über FULL CONTROL NTFS-Berechtigungen für den als Datenverzeichnis verwendeten SMB-Dateifreigabeordner verfügen.

  • Dem Konto, das für die Installation von SQL Server verwendet wird, müssen SeSecurityPrivilege-Berechtigungen auf dem SMB-Dateiserver zugewiesen werden. Diese Berechtigung weisen Sie zu, indem Sie die Konsole Lokale Sicherheitsrichtlinie auf dem Dateiserver verwenden, um das SQL Server-Setupkonto der Richtlinie Überwachungs- und Sicherheitsprotokolle verwalten hinzuzufügen. Diese Einstellung ist im Abschnitt Zuweisen von Benutzerrechten unter Lokale Richtlinien in der Konsole Lokale Sicherheitsrichtlinie verfügbar.

Hinweise

  • Wenn Sie Funktionen zu einer vorhandenen Installation hinzufügen, können Sie den Speicherort einer vorher installierten Funktion nicht ändern und auch keinen Speicherort für eine neue Funktion angeben.

  • Wenn Sie keine Standardverzeichnisse angeben, sollten Sie sicherstellen, dass die Installationsordner nur für die Instanz SQL Server verwendet werden. Keines der Verzeichnisse in diesem Dialogfeld sollte gemeinsam mit Verzeichnissen von anderen SQL Server-Instanzen genutzt werden. Die Database Engine (Datenbankmodul)- und Analysis Services-Komponenten in einer Instanz von SQL Server sollten ebenfalls in separaten Verzeichnissen installiert werden.

  • Programmdateien und Datendateien können in den folgenden Situationen nicht installiert werden:

    • Auf einem Wechseldatenträger

    • In einem Dateisystem, in dem die Komprimierung verwendet wird

    • In einem Verzeichnis, in dem sich Systemdateien befinden

    • Auf einem zugeordneten Netzlaufwerk auf einer Failoverclusterinstanz

Siehe auch

Konzepte

Dateispeicherorte für Standard- und benannte Instanzen von SQL Server

Andere Ressourcen

Share-Berechtigung und NTFS-Berechtigung für einen Dateiserver


Konfiguration des Datenbankmoduls - Filestream

[image]

Konfiguration des Datenbankmoduls - Filestream
Siehe auch Feedback senden

Verwenden Sie diese Seite, um FILESTREAM für diese Installation von Microsoft SQL Server 2012 zu aktivieren. FILESTREAM integriert SQL Server Database Engine (Datenbankmodul) in ein NTFS-Dateisystem, indem BLOB (Binary Large Object)-Daten vom Typ varbinary(max) im Dateisystem gespeichert werden. Mit Transact-SQL-Anweisungen können FILESTREAM-Daten eingefügt, aktualisiert, abgefragt, gesucht und gesichert werden. Die Win32-Dateisystemschnittstellen stellen Streamingzugriff auf die Daten bereit.

FILESTREAM für Transact-SQL-Zugriff aktivieren

Wählen Sie diese Option aus, um FILESTREAM für den Transact-SQL-Zugriff zu aktivieren. Dieses Steuerelement muss aktiviert werden, bevor die anderen Steuerelementoptionen verfügbar sind.

FILESTREAM für E/A-Streamingzugriff auf Datei aktivieren

Wählen Sie diese Option aus, um den Win32-Streamingzugriff für FILESTREAM zu aktivieren.

Windows-Freigabename

Verwenden Sie dieses Steuerelement, um den Namen der Windows-Freigabe einzugeben, in der die FILESTREAM-Daten gespeichert werden sollen.

Streamingzugriff von Remoteclients auf FILESTREAM-Daten zulassen

Aktivieren Sie dieses Steuerelement, damit Remoteclients auf diese FILESTREAM-Daten auf diesem Server zugreifen können.

Siehe auch

Verweis

sp_configure (Transact-SQL)

Konzepte

Aktivieren und Konfigurieren von FILESTREAM


Konfiguration des Datenbankmoduls - Benutzerinstanz

[image]

Konfiguration des Datenbankmoduls - Benutzerinstanz
Feedback senden

Mithilfe der Seite Benutzerinstanz können Sie eine separate Instanz von Database Engine (Datenbankmodul) für Benutzer ohne Administratorberechtigungen generieren. Zudem können Sie der Administratorrolle Benutzer hinzufügen.

Option

Benutzerinstanzen aktivieren

Standardmäßig aktiviert. Um die Funktionalität zum Aktivieren von Benutzerinstanzen zu deaktivieren, deaktivieren Sie das Kontrollkästchen.

Die Benutzerinstanz, auch bekannt als untergeordnete Instanz oder Clientinstanz, ist eine Instanz von SQL Server, die durch die übergeordnete Instanz für den Benutzer generiert wurde (die primäre Instanz wird als Dienst, wie SQLExpress, ausgeführt). Die Benutzerinstanz wird als Benutzerprozess in dem Sicherheitskontext des Benutzers ausgeführt. Die Benutzerinstanz ist von der übergeordneten Instanz und anderen Benutzerinstanzen, die auf dem Computer ausgeführt werden, isoliert. Im Zusammenhang mit der Benutzerinstanzfunktion wird auch der Ausdruck "Ausführen von Instanzen als normaler Benutzer" (RANU, Run As Normal User) verwendet.

Hinweis Hinweis

Während des Setups als Mitglieder der festen Serverrolle sysadmin bereitgestellte Anmeldungen werden in der Vorlagendatenbank als Administratoren bereitgestellt. Sie sind so lange Mitglieder der festen Serverrolle sysadmin auf der Benutzerinstanz, bis sie entfernt werden.

Benutzer zur SQL Server-Administratorrolle hinzufügen

Standardmäßig deaktiviert. Aktivieren Sie dieses Kontrollkästchen, um den aktuellen Setupbenutzer der SQL Server-Administratorrolle hinzuzufügen.

Windows Vista-Benutzer, die Mitglieder von VORDEFINIERT\Administratoren sind, werden nicht automatisch der festen Serverrolle sysadmin hinzugefügt, wenn sie eine Verbindung mit SQL Server Express herstellen. Nur Windows Vista-Benutzer, die explizit einer Administratorrolle auf Serverebene hinzugefügt wurden, können SQL Server Express verwalten. Mitglieder der Gruppe VORDEFINIERT\Administratoren können eine Verbindung mit der SQL Server Express-Instanz herstellen, verfügen jedoch nur über begrenzte Berechtigungen für Datenbankaufgaben. Daher müssen Benutzern, deren SQL Server Express-Berechtigungen in früheren Versionen von Windows von VORDEFINIERT\Administratoren und VORDEFINIERT\Benutzer vererbt wurden, unter Windows Vista explizit Administratorberechtigungen in Instanzen von SQL Server Express erteilt werden.

Wenn Sie nach Beendigung dieses Installationsprogramms Änderungen an Benutzerrollen vornehmen möchten, verwenden Sie das Oberflächen-Konfigurationstool von SQL Server 2005 (SQLSAC.exe). Klicken Sie zum Aktualisieren der Liste der Benutzer in der SQL Server-Systemadministratorrolle auf den Link Neuen Administrator hinzufügen.

Stellen Sie sicher, dass im Feld Bereitstellung für Benutzer die Angaben zu Domänenname\Benutzername des Benutzers aufgeführt sind, dessen Berechtigungen aktualisiert werden sollen. Wählen Sie aus der Liste der SQL Server-Instanzen im Bereich Verfügbare Privilegien die zu aktualisierende Rolle aus, und klicken Sie dann auf den Pfeil nach rechts. Wenn Sie den Benutzer allen verfügbaren Rollen für alle verfügbaren SQL Server-Instanzen und allen verfügbaren Rollen hinzufügen möchten, klicken Sie auf den doppelten Pfeil nach rechts.

Klicken Sie zum Implementieren der Änderungen nach Abschluss der Auswahl auf OK. Klicken Sie auf Abbrechen, wenn Sie das Tool beenden möchten, ohne Änderungen vorzunehmen.


Benötigter Speicherplatz

[image]

Benötigter Speicherplatz
Siehe auch Feedback senden

Untersuchen Sie auf der Seite Speicherplatzzusammenfassung die Speicherplatzanforderungen für die zur Installation ausgewählten SQL Server-Funktionen.

Optionen

Wenn die Speicherplatzanforderungen zu hoch sind, erwägen Sie die folgenden Optionen:

  • Erstellen Sie die Installationsverzeichnisse auf einem Laufwerk mit mehr Speicherplatz.

  • Ändern Sie die SQL Server-Funktionen für die Installation.

  • Vergrößern Sie den freien Speicherplatz auf dem angegebenen Laufwerk, indem Sie andere Dateien oder Anwendungen verschieben.

Siehe auch

Andere Ressourcen

Hardware- und Softwareanforderungen für die Installation von SQL Server 2008 R2


Distributed Replay Controller-Konfiguration

[image]

Distributed Replay Controller-Konfiguration
Feedback senden

Verwenden Sie die Seite für die Distributed Replay Controller-Konfiguration des SQL Server-Installations-Assistenten, um die Benutzer anzugeben, denen Sie Administratorberechtigungen für den Distributed Replay Controller-Dienst gewähren möchten.

Benutzer, die über Administratorberechtigungen verfügen, besitzen unbeschränkten Zugriff auf den Distributed Replay Controller-Dienst.

Optionen

Aktuellen Benutzer hinzufügen

Klicken Sie auf diese Schaltfläche, um die Benutzer hinzuzufügen, denen Sie Zugriffsberechtigungen für den Distributed Replay Controller-Dienst gewähren möchten.

Hinzufügen

Klicken Sie auf diese Schaltfläche, um Zugriffsberechtigungen für den Distributed Replay Controller-Dienst hinzuzufügen.

Entfernen

Klicken Sie auf diese Schaltfläche, um Zugriffsberechtigungen für den Distributed Replay Controller-Dienst zu entfernen.


Distributed Replay Client-Konfiguration

[image]

Distributed Replay Client-Konfiguration
Feedback senden

Verwenden Sie die Seite für die Distributed Replay Client-Konfiguration des SQL Server-Installations-Assistenten, um die Benutzer anzugeben, denen Sie Administratorberechtigungen für den Distributed Replay Client-Dienst gewähren möchten.

Benutzer, die über Administratorberechtigungen verfügen, besitzen unbeschränkten Zugriff auf den Distributed Replay Client-Dienst.

Optionen

Controllername

Dies ist ein optionaler Parameter, und der Standardwert ist <blank>.

Geben Sie den Namen des Controllers ein, mit dem der Clientcomputer für den Distributed Replay Client-Dienst kommuniziert. Beachten Sie Folgendes:

  • Der Name muss ein vollqualifizierter Domänenname sein. Ein Host mit dem Namen "server1" kann in der Produkthierarchie von Microsoft z. B. den vollqualifizierten Domänennamen "server1.products.microsoft.com" haben.

  • Wenn Sie bereits einen Controller eingerichtet haben, geben Sie den Namen des Controllers beim Konfigurieren jedes Clients ein.

  • Wenn Sie noch keinen Controller eingerichtet haben, können Sie das Feld für den Controllernamen leer lassen. Sie müssen den Controllernamen jedoch in der Clientkonfigurationsdatei manuell eingeben.

Arbeitsverzeichnis

Geben Sie das Arbeitsverzeichnis für den Distributed Replay Client-Dienst an.

Das Standardarbeitsverzeichnis ist "<drive letter>:\Programme\Microsoft SQL Server\DReplayClient\WorkingDir\".

Ergebnisverzeichnis

Geben Sie das Ergebnisverzeichnis für den Distributed Replay Client-Dienst an.

Das Standardergebnisverzeichnis ist "<drive letter>:\Programme\Microsoft SQL Server\DReplayClient\ResultDir\".


Upgraderegeln für Editionen

[image]

Upgraderegeln für Editionen
Siehe auch Feedback senden

Das SQL Server-Setup überprüft die Computerkonfiguration, bevor der Setupvorgang abgeschlossen wird. Während des Setups von SQL Server durchsucht die Systemkonfigurationsprüfung (System Configuration Checker, SCC) den Computer, auf dem SQL Server installiert werden soll. SCC sucht nach Bedingungen, die ein erfolgreiches Setup von SQL Server verhindern. Bevor Setup das Editionsupgrade startet, ruft SCC den Status jedes Elements ab. SCC vergleicht dann das Ergebnis mit den erforderlichen Bedingungen und gibt Anweisungen zum Entfernen der Blockierungsprobleme.

Die Systemkonfigurationsprüfung generiert einen Bericht, der eine kurze Beschreibung für jede ausgeführte Regel sowie den Ausführungsstatus enthält. Der Bericht der Systemkonfigurationsprüfung befindet sich unter %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Bevor Sie Setup ausführen, lesen Sie die folgenden Themen:

  1. Hardware- und Softwareanforderungen für die Installation von SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Von den SQL Server-Editionen unterstützte Funktionen(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Sicherheitsüberlegungen für eine SQL Server-Installation(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Lokale Sprachversionen in SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Weitere Referenzen:

  1. Unterstützte Versions- und Editionsupgrades(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Vor dem Installieren des Failoverclusterings(http://go.microsoft.com/fwlink/?LinkId=235034)

Siehe auch

Verweis

Unterstützungsregeln für Setup


Fehlerberichterstellung

[image]

Fehlerberichterstellung
Feedback senden

Verwenden Sie die Seite Einstellungen für Fehler- und Verwendungsberichte des Installations-Assistenten von SQL Server, um die Funktionalität für Fehler- oder Verwendungsberichte für SQL Server zu aktivieren.

Optionen

In Microsoft SQL Server 2012 sind die Features zur Auflistung von Featureverwendungsdaten und zur Fehlerberichterstellung für SQL Server sowie die entsprechenden Komponenten standardmäßig deaktiviert.

Fehlerberichterstellung

Wenn Sie die Funktion Fehlerberichterstellung aktivieren, wird SQL Server so konfiguriert, dass automatisch ein Bericht an Microsoft gesendet wird, sobald ein schwerwiegender Fehler in einer der folgenden SQL Server-Komponenten auftritt:

  • Das Database Engine (Datenbankmodul)

  • SQL Server-Agent

  • Analysis Services

  • Reporting Services

  • Integration Services

  • Replikation

Microsoft verwendet Fehlerberichte, um die SQL Server-Funktionalität zu verbessern, und behandelt alle Informationen vertraulich.

Informationen zu Fehlern werden über eine sichere Verbindung (https) an Microsoft gesendet, wo sie mit eingeschränkten Zugriffsrechten gespeichert werden. Alternativ dazu können Sie die Fehlerberichte auch an Ihren Firmen-Fehlerberichtsserver senden.

Fehlerberichte enthalten die folgenden Informationen:

  • Zustand von SQL Server beim Auftreten des Problems.

  • Version des Betriebssystems und Computerhardwareinformationen.

  • Ihre digitale Product ID, die nicht zum Identifizieren Ihrer Lizenz verwendet wird.

  • Die Netzwerk-IP-Adresse des Computers oder Proxyservers.

  • Informationen aus dem Arbeitsspeicher oder aus Dateien zum Prozess, der den Fehler verursacht hat.

Microsoft verfolgt nicht die Absicht, Dateien, Namen, Adresse, E-Mail-Adresse oder andere persönliche Daten von Ihnen zu erfassen. Der Fehlerbericht kann jedoch persönliche Informationen aus dem Arbeitsspeicher oder Dateien des Prozesses enthalten, der den Fehler verursacht hat. Mithilfe dieser Daten ist es möglich, Ihre Identität zu ermitteln. Microsoft verwendet diese Daten jedoch nicht zu diesem Zweck.

Weitere Informationen über die Datenschutz- und Datensammlungsrichtlinien für SQL Server finden Sie unter Datenschutzbestimmungen für Microsoft SQL Server.

Wenn Sie die Fehlerberichterstellung aktivieren und ein schwerwiegender Fehler auftritt, wird möglicherweise im Windows-Ereignisprotokoll eine Meldung von Microsoft mit einem Verweis auf einen Microsoft Knowledge Base-Artikel zu dem entsprechenden Fehler angezeigt.

Um nach Abschluss des Setups die Fehler- und Funktionsverwendungs-Berichterstellung für alle Instanzen von SQL Server und die dazugehörigen Komponenten zu deaktivieren, wechseln Sie in das Dialogfeld Einstellungen für Fehler- und Verwendungsberichte, und deaktivieren Sie die Kontrollkästchen für die Funktionsverwendung. Wenn die Fehlerberichterstellung für mehrere Komponenten von SQL Server (SQL Server Database Engine (Datenbankmodul), Analysis Services, Reporting Services sowie freigegebene Komponenten) aktiviert ist, können Sie die Fehlerberichterstellung für die einzelnen Instanzen der verschiedenen Komponenten sowie die unter Sonstige aufgelisteten freigegebenen Komponenten deaktivieren.


Failoverclusterbericht

[image]

Failoverclusterbericht
Feedback senden

Auf der Seite Failoverclusterbericht können Sie für diesen Vorgang Berichtsergebnisse aus dem Systemscanvorgang beim Setup anzeigen.

Optionen

Klicken Sie zum Anzeigen eines ausführlichen Berichts für den Scan auf den Berichtslink.


Überprüfung der Funktionen

[image]

Überprüfung der Funktionen
Siehe auch Feedback senden

Die Seite Überprüfung der Funktionen ist eine schreibgeschützte Liste von vorbereiteten Funktionen, die am Ende des Schritts "Image abschließen" konfiguriert und durchgeführt werden. Die Funktionsliste wird während des Schritts "Image vorbereiten" ausgewählt und kann während des Schritts "Image abschließen" nicht geändert werden. Zusätzlich zu den angezeigten Funktionen enthält eine vorbereitete Instanz auch SQL Server-Browser, SQL Server-Schreiber und SQL Server Native Client.

Sie können andere, in der vorbereiteten Instanz der SQL Server-Instanz nicht enthaltene Funktionen hinzufügen, nachdem Sie die Konfiguration der vorbereiteten Instanz von SQL Server abgeschlossen haben.

Komponentengruppe

Komponenten und Funktionen

Database Engine (Datenbankmodul)-Dienste

SQL Server Database Engine (Datenbankmodul) schließt die folgenden Komponenten ein:

  • Database Engine (Datenbankmodul) ist der Kerndienst zum Speichern, Verarbeiten und Sichern von Daten.

    • Replikation: (Optional) Bei der Replikation handelt es sich um eine Reihe von Technologien zum Kopieren und Verteilen von Daten und Datenbankobjekten aus einer Datenbank in eine andere und das anschließende Synchronisieren der Datenbanken, um die Konsistenz der Daten sicherzustellen.

    • Volltextsuche: (Optional) Die Volltextsuche enthält die Funktionalität zum Ausführen von Volltextabfragen für rein zeichenbasierte Daten in SQL Server-Tabellen.

    • Data Quality Services (optional): Data Quality Services (DQS) ist eine Datenbereinigungslösung, die es ermöglicht, inkonsistente und falsche Daten in der Datenquelle zu ermitteln und die Daten mit den bereitgestellten automatischen und interaktiven Methoden zu bereinigen.

Reporting Services

Reporting Services enthält Server- und Clientkomponenten, mit denen Berichte in Form einer Tabelle, Matrix, Grafik oder Freiform erstellt, verwaltet und bereitgestellt werden können. Reporting Services ist gleichzeitig eine erweiterbare Plattform, die Sie zum Entwickeln von Berichtsanwendungen verwenden können.

Siehe auch

Andere Ressourcen

Vorgehensweise: Installieren von SQL Server mit SysPrep


Installationsregeln

[image]

Installationsregeln
Siehe auch Feedback senden

Das SQL Server-Setup überprüft die Computerkonfiguration, bevor der Setupvorgang abgeschlossen wird. Während des Setups von SQL Server durchsucht die Systemkonfigurationsprüfung (System Configuration Checker, SCC) den Computer, auf dem SQL Server installiert werden soll. SCC sucht nach Bedingungen, die ein erfolgreiches Setup von SQL Server verhindern. Bevor Setup den SQL Server-Installations-Assistenten startet, ruft SCC den Status jedes Elements ab. SCC vergleicht dann das Ergebnis mit den erforderlichen Bedingungen und gibt Anweisungen zum Entfernen der Blockierungsprobleme.

Die Systemkonfigurationsprüfung generiert einen Bericht, der eine kurze Beschreibung für jede ausgeführte Regel sowie den Ausführungsstatus enthält. Der Bericht der Systemkonfigurationsprüfung befindet sich unter %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Bevor Sie Setup ausführen, lesen Sie die folgenden Themen:

  1. Hardware- und Softwareanforderungen für die Installation von SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Von den SQL Server-Editionen unterstützte Funktionen(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Sicherheitsüberlegungen für eine SQL Server-Installation(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Lokale Sprachversionen in SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Weitere Referenzen:

  1. Unterstützte Versions- und Editionsupgrades(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Vor dem Installieren des Failoverclusterings(http://go.microsoft.com/fwlink/?LinkId=235034)

Siehe auch

Verweis

Unterstützungsregeln für Setup


Funktionsregeln

[image]

Funktionsregeln
Feedback senden

Das SQL Server-Setup überprüft die Computerkonfiguration, bevor der Setupvorgang abgeschlossen wird. Während des Setups von SQL Server durchsucht die Systemkonfigurationsprüfung (System Configuration Checker, SCC) den Computer, auf dem SQL Server installiert werden soll. SCC sucht nach Bedingungen, die ein erfolgreiches Setup von SQL Server verhindern. Bevor Setup gestartet wird, ruft SCC den Status jedes Elements ab. SCC vergleicht dann das Ergebnis mit den erforderlichen Bedingungen und gibt Anweisungen zum Entfernen der Blockierungsprobleme.

Die Systemkonfigurationsprüfung generiert einen Bericht, der eine kurze Beschreibung für jede ausgeführte Regel sowie den Ausführungsstatus enthält. Der Bericht der Systemkonfigurationsprüfung befindet sich unter %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Bevor Sie Setup ausführen, lesen Sie die folgenden Themen:

  1. Hardware- und Softwareanforderungen für die Installation von SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Von den SQL Server-Editionen unterstützte Funktionen(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Sicherheitsüberlegungen für eine SQL Server-Installation(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Lokale Sprachversionen in SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Weitere Referenzen:

  1. Unterstützte Versions- und Editionsupgrades(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Vor dem Installieren des Failoverclusterings(http://go.microsoft.com/fwlink/?LinkId=235034)


Funktionsauswahl

[image]

Funktionsauswahl
Siehe auch Feedback senden

Mit den Kontrollkästchen auf der Seite Funktionsauswahl des Installations-Assistenten für SQL Server können Sie die Komponenten für Ihre SQL Server-Installation auswählen.

Installieren von SQL Server-Funktionen

Auf der Seite Funktionsauswahl werden die SQL Server-Funktionen in zwei Hauptabschnitte getrennt: Instanzfunktionen und Freigegebene Funktionen.

Instanzfunktionen verweist auf die Komponenten, die einmal für jede Instanz installiert sind, damit Sie über mehrere Kopien von ihnen (einer für jede Instanz) verfügen. Jede Instanz kann eine separate Version sein, die eine andere Patchebene aufweist. Bei der Installation eines Patches werden unabhängig davon, ob es sich um einen Service Pack, Hotfix oder ein kumulatives Update handelt, nur die Dateien für eine Instanz auf einem bestimmten Computer sowie die gemeinsam verwendeten Funktionen aktualisiert, falls diese nicht bereits aktualisiert wurden.

Freigegebene Funktionen verweist auf Funktionen, die von allen Instanzen auf einem bestimmten Computer gemeinsam verwendet werden. Diese freigegebenen Funktionen werden so entworfen, dass sie abwärtskompatibel mit unterstützten SQL Server-Versionen (Service Packs, kumulative Updates und Hotfixes) sind, die nebeneinander installiert werden können.

Hinweis Hinweis

SQL Server SysPrep: Die Database Engine (Datenbankmodul)-Komponente und die Reporting Services-Komponente sind die einzigen Microsoft SQL Server 2012-Funktionen mit SQL Server SysPrep-Unterstützung. Sie können diese Funktionen und Komponenten während des Schritts Image vorbereiten des Prozesses auswählen. Beim Abschließen eines vorbereiteten Images von SQL Server können Sie keine Auswahl treffen. Weitere Informationen finden Sie unter Vorgehensweise: Installieren von SQL Server 2012 mit SysPrep (http://go.microsoft.com/fwlink/?LinkId=190965).

SQL Server-Failovercluster: Die Database Engine (Datenbankmodul)-Komponente und die Analysis Services-Komponente sind die einzigen Microsoft SQL Server 2012-Funktionen mit Failoverclustering. Sie können weitere Komponenten, z. B. Reporting Services oder Integration Services, auf einem Failoverclusterknoten installieren, doch diese sind nicht clusterabhängig, und für ihre Dienste wird kein Failover ausgeführt, wenn der Failoverclusterknoten offline geschaltet wird. Weitere Informationen finden Sie unter Erste Schritte mit SQL Server-Failoverclustering (http://go.microsoft.com/fwlink/?LinkId=190953).

Instanzfunktionen

Im Bereich Beschreibung wird eine Beschreibung für jede Komponentengruppe angezeigt, wenn Sie sie ausgewählt haben. Sie können jede beliebige Kombination von Kontrollkästchen aktivieren. Um fortzufahren, müssen Sie eine Auswahl treffen.

Funktionen

Beschreibung

Database Engine (Datenbankmodul)-Dienste

SQL Server Database Engine (Datenbankmodul) enthält Database Engine (Datenbankmodul), den Basisdienst zum Speichern, Verarbeiten und Sichern von Daten, die Replikation, Volltextsuche, Tools zum Verwalten von relationalen Daten und XML-Daten und den Data Quality Services (DQS)-Server.

  • Database Engine (Datenbankmodul) ist der Kerndienst zum Speichern, Verarbeiten und Sichern von Daten.

  • Replikation: (Optional) Bei der Replikation handelt es sich um eine Reihe von Technologien zum Kopieren und Verteilen von Daten und Datenbankobjekten aus einer Datenbank in eine andere und das anschließende Synchronisieren der Datenbanken, um die Konsistenz der Daten sicherzustellen.

  • Volltextsuche: (Optional) Die Volltextsuche enthält die Funktionalität zum Ausführen von Volltextabfragen für rein zeichenbasierte Daten in SQL Server-Tabellen.

  • Data Quality Services (optional): Data Quality Services (DQS) ist eine Datenbereinigungslösung, die es ermöglicht, inkonsistente und falsche Daten in der Datenquelle zu ermitteln und die Daten mit den bereitgestellten computergestützten und interaktiven Verfahren zu bereinigen. Aktivieren Sie dieses Kontrollkästchen, um den DQS-Server zu installieren. Nachdem die Installation von SQL Server abgeschlossen ist, muss die Datei DQSInstaller.exe ausgeführt werden, um die DQS-Serverinstallation abzuschließen. Wenn Sie die Standardinstanz von SQL Server installiert haben, steht diese Datei unter C:\Programme\Microsoft SQL Server\MSSQL11.MSSQLSERVER\MSSQL\Binn zur Verfügung.

SQL Server-Failovercluster: Wenn Sie für SQL Server-Failoverclusterinstallationen Datenbankmoduldienste auswählen, sind die Komponenten Replikation und Volltextsuche erforderlich und werden vom Setup automatisch ausgewählt.

Analysis Services

Analysis Services enthält Tools zum Erstellen und Verwalten der analytischen Onlineverarbeitung (OLAP, Online Analytical Processing) sowie Data Mining-Anwendungen.

Reporting Services – Einheitlich

Reporting Services Einheitlicher Modus enthält Server- und Clientkomponenten, mit denen Berichte in Form einer Tabelle, Matrix, Grafik oder Freiform erstellt, verwaltet und bereitgestellt werden können. Reporting Services ist gleichzeitig eine erweiterbare Plattform, die Sie zum Entwickeln von Berichtsanwendungen verwenden können.

Wichtiger Hinweis Wichtig

  1. Der Lastenausgleich und die Adressierung mit einer einzelnen URL für mehrere Knoten werden vom Setupprogramm in einer Reporting Services-Bereitstellung für dezentrales Skalieren nicht konfiguriert. Zur Durchführung einer Bereitstellung für horizontales Skalieren müssen Sie Windows Server, Microsoft Application Center oder eine Clusterverwaltungssoftware eines Drittanbieters verwenden. Weitere Informationen zum Einrichten der Webfarmbereitstellung finden Sie unter Konfigurieren von Reporting Services zur Bereitstellung für horizontales Skalieren (http://go.microsoft.com/fwlink/?LinkId=199448).

  2. Microsoft Internet Explorer 7.0 SP 1 ist für die Berichts-Designer-Komponente von Reporting Services erforderlich.

  3. Bei einer gleichzeitigen Konfiguration auf der 64-Bit-Plattform und dem 32-Bit-Subsystem (WOW64) eines 64-Bit-Servers wird Reporting Services nicht unterstützt.

Freigegebene Funktionen

Funktionen, die von allen Instanzen von SQL Server auf einem einzelnen Computer gemeinsam verwendet werden, werden in einem einzelnen Verzeichnis installiert. Dabei handelt es sich um folgende Elemente:

Funktion

Beschreibung

Reporting Services –SharePoint

Reporting Services SharePoint-Modus ist eine serverbasierte Anwendung zum Erstellen, Verwalten und Bereitstellen von Berichten in E-Mail-Formaten, mehreren Dateiformaten sowie interaktiven webbasierten Formaten. Im SharePoint-Modus werden die Funktionen für die Berichtsanzeige und -verwaltung in SharePoint-Produkte integriert.

Reporting Services Add-In für SharePoint-Produkte

Das Reporting Services Add-In für SharePoint-Produkte enthält Verwaltungs- und Benutzeroberflächenkomponenten zur Integration eines SharePoint-Produkts in einen Reporting Services-Berichtsserver im integrierten SharePoint-Modus.

Data Quality Client

Data Quality Client ist eine eigenständige Anwendung, die eine Verbindung mit dem DQS-Server herstellt und eine intuitive grafische Benutzeroberfläche bereitstellt, um Datenbereinigungs- und Datenabgleichsvorgänge sowie Verwaltungsaufgaben in DQS auszuführen.

SQL Server-Datentools1

SQL Server-Datentools (SSDT) bietet eine IDE zum Erstellen von Lösungen für die Business Intelligence-Komponenten: Analysis Services, Reporting Services und Integration Services.

(Früher Business Intelligence Development Studio genannt).

SSDT schließt auch "Datenbankprojekte" ein, die eine integrierte Umgebung für Datenbankentwickler bereitstellen, die ihre ganze Datenbankentwurfsarbeit für eine beliebige SQL Server-Plattform (sowohl vor Ort als auch remote) in Visual Studio ausführen möchten. Datenbankentwickler können den verbesserten Server-Explorer in Visual Studio verwenden, um Datenbankobjekte und Daten einfach zu erstellen oder zu bearbeiten und Abfragen auszuführen.

Konnektivität der Clienttools

Die Clienttools beinhalten Komponenten für die Kommunikation zwischen Clients und Servern, einschließlich Netzwerkbibliotheken für DB-Library, OLEDB für OLAP, ODBC, ADODB und ADOMD+.

Integration Services

Integration Services stellt eine Gruppe grafischer Tools und programmierbarer Objekte zum Verschieben, Kopieren und Transformieren von Daten bereit.

Clienttools-Abwärtskompatibilität

In der Clienttools-Abwärtskompatibilität sind die folgenden Komponenten enthalten:

  • SQL Distributed Management Objects (SQL-DMO). Weitere Informationen finden Sie unter Nicht mehr unterstützte SQL Server-Funktionen in SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=190968).

  • Decision Support Objects (DSO). Weitere Informationen finden Sie unter Aktuelle Änderungen von Analysis Services-Funktionen in SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=190970).

Clienttools SDK

Enthält das Software Development Kit, das Ressourcen für Programmierer enthält.

Dokumentationskomponenten

Dokumentationskomponenten enthalten die Komponenten zum Anzeigen und Verwalten von Hilfeinhalten.

Verwaltungstools - Einfach

Verwaltungstools – Basic: Dazu gehören folgende Elemente:

  • SQL Server Management Studio-Unterstützung für SQL Server Database Engine (Datenbankmodul), SQL Server Express, das sqlcmd-Hilfsprogramm und den SQL Server PowerShell-Anbieter

Verwaltungstools – Vollständig: Dazu gehören neben den Komponenten der Standardversion die folgenden Komponenten:

  • SQL Server Management Studio-Unterstützung für Reporting Services, Analysis Services und Integration Services

  • SQL Server Profiler

  • Datenbankoptimierungsratgeber

  • Verwaltung mit dem SQL Server-Hilfsprogramm

Distributed Replay Controller

Der Distributed Replay Controller koordiniert die Aktionen der Distributed Replay Clients. Es kann in jeder Distributed Replay-Umgebung jeweils nur eine Controllerinstanz geben. Weitere Informationen finden Sie unter SQL Server Distributed Replay (http://go.microsoft.com/fwlink/?LinkId=229847).

Distributed Replay Client

Die Distributed Replay Clients simulieren gemeinsam Arbeitsauslastungen auf einer Instanz von SQL Server. In jeder Distributed Replay-Umgebung kann sich mindestens ein Client befinden. Weitere Informationen finden Sie unter SQL Server Distributed Replay (http://go.microsoft.com/fwlink/?LinkId=229847).

SQL Client Connectivity SDK

Enthält SQL Server Native Client (ODBC/OLE DB) SDK für die Entwicklung von Datenbankanwendungen.

Master Data Services

Master Data Services ist eine Plattform, mit der für Genauigkeits- und Überwachungszwecke Daten aus unterschiedlichen Systemen einer gesamten Organisation in einer einzelnen Quelle von Masterdaten integriert werden. Mit der Master Data Services-Option werden der Konfigurations-Manager für Master Data Services, Assemblys, das Windows PowerShell-Snap-In sowie Ordner und Dateien für Webanwendungen und Dienste installiert.

LocalDB

LocalDB ist ein Ausführungsmodus von SQL Server Express, der speziell für Programmentwickler konzipiert wurde. Nach der Initiierung durch eine bestimmte Verbindungszeichenfolge wird die erforderliche SQL Server-Infrastruktur automatisch erstellt und gestartet. Dies ermöglicht der Anwendung, die Datenbank ohne Ausführung von Konfigurations- oder Verwaltungstasks zu verwenden.

1Für die Installation von SQL Server-Datentools (SSDT) ist Internet Explorer 6.0 SP1 erforderlich.

Standardmäßig werden freigegebene Komponenten unter %Programme%Microsoft SQL Server\ installiert. Um den Installationspfad zu ändern, klicken Sie auf die Schaltfläche Durchsuchen. Wenn Sie den Installationspfad einer freigegebenen Komponente ändern, wirkt sich diese Änderung auch auf andere freigegebene Komponenten aus. Bei allen zukünftigen Installationen werden die freigegebenen Komponenten wieder am gleichen Speicherort installiert wie bei der ursprünglichen Installation.

Unter x64-basierten Betriebssystemen können Sie angeben, wo 64-Bit-Komponenten installiert werden sollen und wo im WOW64-Subsystem 32-Bit-Komponenten installiert werden sollen.

Installieren der AdventureWorks-Beispieldatenbanken

Standardmäßig werden Beispieldatenbanken und Beispielcode nicht als Teil des SQL Server-Setups installiert. Weitere Informationen zur Installation von Beispieldatenbanken und Beispielcode finden Sie unter Microsoft SQL Server Community Projects & Samples (http://go.microsoft.com/fwlink/?LinkId=87843).

Weitere Informationen zu Beispielen stehen nach der Installation von Microsoft SQL Server 2012 zur Verfügung. Klicken Sie im Menü Start auf Alle Programme, klicken Sie auf Microsoft SQL Server 2012, klicken Sie auf Dokumentation und Lernprogramme, und klicken Sie dann auf Übersicht über die Beispiele für Microsoft SQL Server.

Siehe auch

Andere Ressourcen

Editionen und Komponenten von SQL Server 2012


Funktionsauswahl (Deinstallieren)

[image]

Funktionsauswahl (Deinstallieren)
Feedback senden

Auf der Seite Funktionsauswahl – Deinstallieren können Sie Funktionen auswählen, die aus der ausgewählten Instanz von SQL Server entfernt werden sollen.

Optionen

Sie können jede beliebige Kombination von Funktionen auswählen.


Zu aktualisierende Funktionen

[image]

Zu aktualisierende Funktionen
Siehe auch Feedback senden

Auf der Seite Zu aktualisierende Funktionen des Installations-Assistenten für Microsoft SQL Server 2012 können Sie die Funktionen anzeigen, die auf Microsoft SQL Server 2012 aktualisiert werden sollen.

Optionen

  • Es ist nicht möglich, die Funktionen zu ändern, die in dieser Version aktualisiert werden sollen. Um dieser Instanz von SQL Server Funktionen hinzuzufügen, schließen Sie den Upgradevorgang ab, starten Sie Setup neu, und klicken Sie im Installationscenter auf Neuinstallation oder Hinzufügen von Funktionen zu einer vorhandenen Installation.

Siehe auch

Andere Ressourcen

Versions- und Editionsupgrades
Verwenden des Upgrade Advisors zur Vorbereitung auf Upgrades
Verwenden mehrerer Versionen von SQL Server


Upgradeoptionen für die Volltextsuche

[image]

Upgradeoptionen für die Volltextsuche
Feedback senden

Verwenden Sie im SQL Server-Installations-Assistenten die Seite mit den Upgradeoptionen für die Volltextsuche, um die Upgradeoption für die Volltextsuche auszuwählen, die Sie für die zu aktualisierenden Datenbanken verwenden möchten.

In SQL Server 2005 und älteren Versionen befindet sich jeder Volltextindex in einem Volltextkatalog, der einer Dateigruppe angehört, über einen physischen Pfad verfügt und als Datenbankdatei behandelt wird. Ab SQL Server 2008 ist ein Volltextkatalog ein logisches Konzept – ein virtuelles Objekt – bei dem eine Gruppe von Volltextindizes verwendet wird. Deshalb wird ein neuer Volltextkatalog nicht als Datenbankdatei mit einem physischen Pfad behandelt. Wenn jedoch ein Volltextkatalog aktualisiert wird, der Datendateien enthält, wird auf demselben Datenträger jeweils eine neue Dateigruppe erstellt. Auf diese Weise wird nach dem Upgrade das alte Datenträger-E/A-Verhalten beibehalten. Jeder Volltextindex aus diesem Katalog wird in die neue Dateigruppe eingefügt, wenn der Stammpfad vorhanden ist. Falls der alte Volltextkatalogpfad ungültig ist, wird beim Upgrade der Volltextindex in derselben Dateigruppe als Basistabelle – bzw. bei einer partitionierten Tabelle in der primären Dateigruppe – beibehalten.

Optionen

Wählen Sie eine der folgenden Volltextupgrade-Optionen aus, wenn Sie von SQL Server 2005 oder SQL Server 2008 auf Microsoft SQL Server 2012 aktualisieren.

Importieren

Volltextkataloge werden importiert. Normalerweise ist der Import bedeutend schneller als eine Neuerstellung. Wenn Sie zum Beispiel nur eine CPU verwenden, läuft ein Import etwa zehnmal schneller ab als eine Neuerstellung. Ein von SQL Server 2005 importierter Volltextkatalog verwendet jedoch nicht die neuen mit SQL Server 2008 eingeführten Wörtertrennungen. Aus diesem Grund sollten Sie zu einem späteren Zeitpunkt eine Neuerstellung der Volltextkataloge durchführen.

Hinweis Hinweis

Sie können die Neuerstellung im Multithreadmodus ausführen. Wenn mehr als 10 CPUs verfügbar sind, ist die Neuerstellung ggf. schneller als der Import, falls dabei alle CPUs genutzt werden können.

Wenn ein Volltextkatalog nicht verfügbar ist, werden die zugehörigen Volltextindizes neu erstellt. Diese Option ist nur für SQL Server 2005-Datenbanken verfügbar.

Informationen zu den Auswirkungen eines Imports von Volltextindizes finden Sie unter "Überlegungen beim Auswählen einer Volltext-Upgradeoption" weiter unten in diesem Thema.

Neu erstellen

Volltextkataloge werden mithilfe der neuen und verbesserten Wörtertrennungen neu erstellt, die mit SQL Server 2008 eingeführt wurden. Das Neuerstellen von Indizes kann einige Zeit dauern, und nach dem Upgrade ist ggf. eine beträchtliche Menge an CPU-Leistung und Arbeitsspeicherkapazität erforderlich.

Zurücksetzen

Volltextkataloge werden zurückgesetzt. Beim Aktualisieren von SQL Server 2005 werden Volltextkatalogdateien entfernt. Die Metadaten für die Volltextkataloge und die Volltextindizes bleiben jedoch erhalten. Nach der Upgrade wird die Änderungsnachverfolgung für alle Volltextindizes deaktiviert, und Durchforstungen werden nicht automatisch gestartet. Der Katalog bleibt leer, bis Sie ihn nach Beendigung des Upgrades manuell vollständig auffüllen.

Bei all diesen Upgradeoptionen ist sichergestellt, dass aktualisierte Datenbanken von der optimierten Volltextleistung von SQL Server 2008 und neueren Versionen profitieren.

Wichtiger Hinweis Wichtig

Informationen zur Verwendung der neuen Wörtertrennungen und zum Aktualisieren der Füllwortdateien in Stopplisten nach dem Importieren eines SQL Server 2005-Volltextindexes finden Sie im Thema "Upgrade der Volltextsuche" in der Setup-Hilfe für Microsoft SQL Server 2012.

Überlegungen beim Auswählen einer Volltextupgrade-Option

Beachten Sie beim Auswählen der Upgradeoption Folgendes:

  • Wie werden Wörtertrennungen verwendet?

    Ab Microsoft SQL Server 2012 enthält der Volltextsuchdienst Wörtertrennungen und Wortstammerkennungen, die in SQL Server 2008 eingeführt wurden. Aus diesem Grund können sich die Ergebnisse von Volltextabfragen für ein bestimmtes Textmuster oder Szenario im Vergleich zu SQL Server 2005 unterscheiden. Es ist also wichtig, beim Auswählen einer geeigneten Upgradeoption auf die verwendete Wörtertrennung zu achten:

    • Wenn die Wörtertrennung der verwendeten Volltextsprache sich in SQL Server 2008 oder neueren Versionen nicht geändert hat oder wenn die Rückrufgenauigkeit nicht entscheidend ist, ist das Importieren eine geeignete Maßnahme. Falls später Rückrufprobleme auftreten, können Sie ein Upgrade auf die neuen Wörtertrennungen durchführen, indem Sie die Volltextkataloge einfach neu erstellen. Weitere Informationen finden Sie im Thema "Aktualisieren der Volltextsuche" in der Setup-Hilfe für Microsoft SQL Server 2012.

    • Wenn die Rückrufgenauigkeit wichtig ist und Sie eines der Worttrennmodule verwenden, die in SQL Server 2008 optimiert wurden, sollten Sie eine Neuerstellung durchführen.

  • Wurden Volltextindizes basierend auf ganzzahligen Volltextschlüsselspalten erstellt?

    Bei der Neuerstellung werden interne Optimierungen durchgeführt, die die Abfrageleistung des aktualisierten Volltextindex in einigen Fällen verbessern. Mit der Neuerstellung erzielen Sie besonders dann eine optimale Leistung der Volltextabfragen, wenn Sie Volltextkataloge mit Volltextindizes verwenden, bei denen die Volltextschlüsselspalte der Basistabelle ein integer-Datentyp ist. In diesem Fall ist es sehr zu empfehlen, die Option Neu erstellen zu verwenden.

    Hinweis Hinweis

    Für die Volltextindizes in Microsoft SQL Server 2012 ist es ratsam, dass es sich bei der Spalte, die als Volltextschlüssel dient, um einen ganzzahligen Datentyp handelt. Weitere Informationen finden Sie im Thema "Leistungsoptimierung (Volltextsuche)" in der Microsoft SQL Server 2012-Onlinedokumentation.

  • Worauf liegt beim Herstellen der Onlineverfügbarkeit der Serverinstanz die Priorität?

    Das Importieren bzw. das Neuerstellen während eines Upgrades belegt viele CPU-Ressourcen. Dies führt zu Verzögerungen beim Aktualisieren und Herstellen der Onlineverfügbarkeit des Rests der Serverinstanz. Wenn die schnellstmögliche Onlineverfügbarkeit der Serverinstanz wichtig und das manuelle Auffüllen nach dem Upgrade akzeptabel ist, eignet sich die Option Zurücksetzen.


Installation abgeschlossen

[image]

Installation abgeschlossen
Siehe auch Feedback senden

Klicken Sie auf Schließen, um die Installation abzuschließen.

Siehe auch

Konzepte

Überprüfen einer SQL Server-Installation


Installationsvoraussetzungen

[image]

Installationsvoraussetzungen
Feedback senden

Damit SQL Server erfolgreich installiert werden kann, sind auf dem Installationscomputer folgende Softwarekomponenten erforderlich. Die Komponenten werden vom SQL Server-Setup installiert:

  • .NET Framework Version 4.0 für alle Editionen von Microsoft SQL Server 2012

  • Unterstützungsdateien für SQL Server-Setup

  • SQL Server Native Client

Hinweis Hinweis

Diese Komponenten werden bei einem Fehler oder Abbruch der Installation nicht entfernt. Mithilfe der Option Software in der Systemsteuerung können Sie die betreffenden Komponenten entfernen.

Optionen

Um die erforderlichen Dateien zu installieren, klicken Sie auf Installieren. Um die Installation abzubrechen, klicken Sie auf Abbrechen.


Installationsstatus

[image]

Installationsstatus
Siehe auch Feedback senden

Verwenden Sie die Seite Installationsstatus des Installations-Assistenten für SQL Server, um den Status des SQL Server-Setups zu überwachen.

Siehe auch

Konzepte

Lesen und Anzeigen der Setupprotokolldateien von SQL Server


Installationstyp

[image]

Installationstyp
Feedback senden

Auf der Seite Installationstyp des SQL Server-Installations-Assistenten können Sie angeben, ob Sie eine neue Instanz von SQL Server installieren oder einer vorhandenen Instanz Funktionen hinzufügen möchten.

Optionen

Aktivieren Sie das Optionsfeld für Ihre Auswahl:

  • Neuinstallation von SQL Server ausführen

  • funktionen zu einer vorhandenen SQL Server-Instanz hinzufügen

    Wenn Sie die Option zum Hinzufügen von Funktionen zu einer vorhandenen Instanz auswählen, können Sie in der Dropdownliste die Instanz von SQL Server auswählen, die Sie aktualisieren möchten.

Sie können einem vorbereiteten Image von SQL Server nur die die unterstützten SysPrep-Funktionen (Database Engine (Datenbankmodul) und Reporting Services) hinzufügen. Andere Funktionen, die nicht von SysPrep unterstützt werden, können hinzugefügt werden, nachdem die vorbereitete Instanz abgeschlossen wurde.

Hinweis Nach der Installation einer Failoverclusterinstanz können keine Funktionen mehr hinzugefügt werden. Wenn Sie einer vorhandenen Failoverclusterinstanz SQL Server-Funktionen hinzufügen möchten, müssen Sie eine Neuinstallation vornehmen, um eine separate Instanz von SQL Server zu installieren.


Instanzkonfiguration

[image]

Instanzkonfiguration
Feedback senden

Verwenden Sie die Seite Instanzkonfiguration des Installations-Assistenten für SQL Server, um anzugeben, ob eine Standardinstanz oder eine benannte Instanz von SQL Server erstellt werden soll. Wenn noch keine Instanz von SQL Server auf dem Server installiert wurde, wird eine Standardinstanz erstellt, es sei denn Sie geben eine benannte Instanz an.

Jede SQL Server-Instanz besteht aus einem Satz von Diensten mit bestimmten Einstellungen für Sortierungen und andere Optionen. Verzeichnisstruktur, Registrierungsstruktur und Dienstnamen spiegeln den Instanznamen und die von Ihnen bei der Installation von SQL Server angegebene Instanz-ID wider.

Bei der Instanz kann es sich um eine Standardinstanz oder um eine benannte Instanz handeln. Der Name der Standardinstanz lautet MSSQLSERVER. Es ist kein Client erforderlich, um den Instanznamen zur Herstellung einer Verbindung anzugeben. Eine benannte Instanz wird vom Benutzer während des Setups festgelegt. Sie können SQL Server als benannte Instanz installieren, ohne zuvor die Standardinstanz zu installieren. Es kann jeweils nur eine Installation von SQL Server, unabhängig von der Version, als Standardinstanz fungieren.

Hinweis Hinweis

Bei SQL Server SysPrep können Sie den Instanznamen angeben, wenn Sie auf der Seite Instanzkonfiguration eine vorbereitete Instanz abschließen. Sie können die vorbereitete Instanz, die Sie abschließen, als Standardinstanz konfigurieren, wenn sich auf dem Computer keine vorhandene Standardinstanz von SQL Server befindet.

Mehrere Instanzen

SQL Server unterstützt mehrere Instanzen von SQL Server auf einem einzelnen Server oder Prozessor, es kann jedoch nur eine einzige Instanz als Standardinstanz fungieren. Alle anderen müssen benannte Instanzen sein. Auf einem Computer können mehrere Instanzen von SQL Server gleichzeitig ausgeführt werden, und jede Instanz wird unabhängig von den anderen Instanzen ausgeführt.

Weitere Informationen finden Sie unter Spezifikationen der maximalen Kapazität für SQL Server.

Optionen

Nur Failoverclusterinstanzen: Geben Sie den Netzwerknamen des SQL Server-Failoverclusters an. Anhand dieses Namens wird die Failoverclusterinstanz im Netzwerk identifiziert.

Standardinstanz oder benannte Instanz: Bei der Entscheidung der Frage, ob eine Standardinstanz oder eine benannte Instanz von SQL Server installiert werden soll, müssen folgende Informationen beachtet werden:

  • Wenn Sie eine einzelne Instanz von SQL Server auf einem Datenbankserver installieren möchten, sollte dies eine Standardinstanz sein.

  • Verwenden Sie eine benannte Instanz , wenn Sie mehrere Instanzen auf dem gleichen Computer verwenden möchten. Ein Server kann nur als Host für eine einzelne Standardinstanz dienen.

  • Jede Anwendung, die SQL Server Express installiert, sollte die Installation als benannte Instanz vornehmen. Dadurch werden die Konflikte für den Fall minimiert, dass mehrere Anwendungen auf demselben Computer installiert werden.

Standardinstanz

Wählen Sie diese Option aus, um eine Standardinstanz von SQL Server zu installieren. Ein Computer kann nur als Host für eine Standardinstanz dienen, alle anderen Instanzen müssen benannt sein. Wenn eine Standardinstanz von SQL Server installiert ist, ist es jedoch möglich, demselben Computer eine Standardinstanz von Analysis Services hinzufügen.

Benannte Instanz

Wählen Sie diese Option aus, um eine neue benannte Instanz zu erstellen. Beachten Sie beim Benennen einer Instanz von SQL Server Folgendes:

  • Bei Instanznamen wird die Groß-/Kleinschreibung nicht berücksichtigt.

  • Instanznamen dürfen nicht mit einem Unterstrich (_) beginnen oder enden.

  • Instanznamen dürfen keine Begriffe wie "Standard" oder andere reservierte Schlüsselwörter enthalten. Wenn in einem Instanznamen ein reserviertes Schlüsselwort verwendet wird, tritt ein Setupfehler auf. Weitere Informationen finden Sie unter Reservierte Schlüsselwörter.

  • Wenn Sie MSSQLServer als Instanznamen angeben, wird eine Standardinstanz erstellt. Wenn Sie bei SQL Server Express SQLExpress als Instanznamen angeben, wird eine Standardinstanz erstellt.

  • Eine Installation von Microsoft SQL Server 2012 PowerPivot für SharePoint wird immer als benannte Instanz von 'PowerPivot' installiert. Sie können keinen anderen Instanznamen für diese Funktionsrolle angeben.

  • Instanznamen können maximal 16 Zeichen enthalten.

  • Das erste Zeichen eines Instanznamens muss ein Buchstabe sein. Akzeptable Buchstaben sind diejenigen, die durch Unicode Standard 2.0 definiert werden. Dazu gehören die lateinischen Zeichen a-z, A-Z sowie Buchstaben aus anderen Sprachen.

  • Bei den anderen Zeichen kann es sich um Buchstaben des Unicode-Standards 2.0, Dezimalzeichen aus dem lateinischen Grundalphabet oder anderen nationalen Schriften, das Dollarzeichen ($) oder einen Unterstrich (_) handeln.

  • Eingebettete Leerzeichen und sonstige Sonderzeichen sind in Instanznamen nicht zugelassen. Umgekehrte Schrägstriche (\), Kommas (,), Doppelpunkte (:), Strichpunkte (;), einfache Anführungszeichen ('), kaufmännische Und-Zeichen (&) und das At-Zeichen (@) sind ebenfalls nicht zulässig.

    Hinweis Hinweis

    In SQL Server-Instanznamen können nur gültige Zeichen der aktuellen Windows-Codepage verwendet werden. Wenn ein nicht unterstütztes Unicode-Zeichen verwendet wird, tritt ein Setupfehler auf.

Erkannte Instanzen und Funktionen

Zeigt eine Liste der SQL Server-Instanzen und Komponenten an, die auf dem Computer installiert sind, auf dem das SQL Server-Setup ausgeführt wird.

Instanz-ID – Standardmäßig wird der Instanzname als Instanz-ID verwendet. Das Ziel ist dabei, Installationsverzeichnisse und Registrierungsschlüssel für die Instanz von SQL Server zu identifizieren. Dies ist der Fall für Standardinstanzen und benannte Instanzen. Bei einer Standardinstanz lauten Instanzname und Instanz-ID MSSQLSERVER. Um eine nicht standardmäßige Instanz-ID zu verwenden, geben Sie sie im Feld Instanz-ID an.

Wichtiger Hinweis Wichtig

Bei SQL Server SysPrep handelt es sich bei der auf dieser Seite angezeigten Instanz-ID um die Instanz-ID, die Sie während des Schritts Image vorbereiten des SQL Server SysPrep-Prozesses angegeben haben. Sie sind nicht in der Lage, während des Schritts Image abschließen eine andere Instanz-ID anzugeben.

Hinweis Hinweis

Instanz-IDs, die mit einem Unterstrich (_) beginnen oder das Nummernzeichen (#) oder Dollarzeichen ($) enthalten, werden nicht unterstützt.

Weitere Informationen zu Verzeichnissen, Dateispeicherorten und Namen für Instanz-IDs finden Sie unter Dateispeicherorte für Standard- und benannte Instanzen von SQL Server.

Instanzstammverzeichnis – Standardmäßig lautet das Instanzstammverzeichnis C:\Programme\Microsoft SQL Server\. Um ein nicht standardmäßiges Stammverzeichnis anzugeben, klicken Sie auf die Schaltfläche Durchsuchen, oder geben Sie einen Pfadnamen an.

Alle Komponenten einer gegebenen Instanz von SQL Server werden als Einheit verwaltet. Alle SQL Server-Service Packs und Updates werden für jede Komponente einer Instanz von SQL Server übernommen.

Alle Komponenten von SQL Server, die denselben Instanznamen verwenden, müssen die folgenden Kriterien erfüllen:

  • Gleiche Version

  • Gleiche Edition

  • Gleiche Spracheinstellungen

  • Gleicher gruppierter Status

    Hinweis Hinweis

    Reporting Services ist nicht clusterabhängig.

  • Gleiches Betriebssystem


Instanzauswahl (Deinstallieren)

[image]

Instanzauswahl (Deinstallieren)
Feedback senden

Verwenden Sie auf der Seite Instanzauswahl – Deinstallieren das Dropdownfeld, um die zu deinstallierende Instanz von SQL Server anzugeben.

Optionen

Sie können eine vollständige Instanz von SQL Server angeben, Sie können aber auch angeben, dass nur die freigegebenen Funktionen und Verwaltungstools deinstalliert werden.


Instanzauswahl (Upgrade)

[image]

Instanzauswahl (Upgrade)
Feedback senden

Auf der Seite Instanzauswahl (Upgrade) können Sie die zu aktualisierende Instanz von SQL Server angeben.

Optionen

Alle Komponenten einer Instanz müssen gleichzeitig aktualisiert werden. Während des Upgrades können keine Funktionen hinzugefügt oder entfernt werden.


Zu aktualisierende Instanz

[image]

Zu aktualisierende Instanz
Siehe auch Feedback senden

Verwenden Sie die Seite Zu aktualisierende Instanz des Installations-Assistenten für SQL Server, um die Instanz von SQL Server 2005, SQL Server 2008 bzw. SQL Server 2008 R2 anzugeben, die auf Microsoft SQL Server 2012 aktualisiert werden soll.

Optionen

Geben Sie mithilfe der Optionsfelder an, ob die Instanz von SQL Server und die zugehörigen freigegebenen Komponenten oder nur die freigegebenen Komponenten aktualisiert werden sollen. Diese SQL Server-Version weist folgende freigegebene Komponenten auf:

  • Integration Services

  • SQL Server-Browser

  • Hilfsdienst von SQL Server für Active Directory

  • SQL Writer

Weitere Informationen zu unterstützten Upgradeszenarien und bekannten Problemen des Upgrades finden Sie unter Versions- und Editionsupgrades.

Siehe auch

Andere Ressourcen

Verwenden des Upgrade Advisors zur Vorbereitung auf Upgrades
Verwenden mehrerer Versionen von SQL Server


Nach der Deinstallation

[image]

Nach der Deinstallation
Feedback senden

Verwenden Sie die Seite Nach der Deinstallation, um sich zu überzeugen, dass der Vorgang erfolgreich abgeschlossen wurde.


Status der Imagevorbereitung

[image]

Status der Imagevorbereitung
Siehe auch Feedback senden

Auf der Seite Status der Imagevorbereitung des SQL Server-Installations-Assistenten können Sie den Status des SQL Server-Imagevorbereitungssetups überwachen. Nach dem Abschluss dieses Schritts wird auf dieser Seite der Status der während dieses Prozesses vorbereiteten SQL Server-Funktionen angezeigt.

Siehe auch

Konzepte

Lesen und Anzeigen der Setupprotokolldateien von SQL Server


Regeln zum Vorbereiten des Images

[image]

Regeln zum Vorbereiten des Images
Feedback senden

Das SQL Server-Setup überprüft die Computerkonfiguration, bevor der Setupvorgang abgeschlossen wird. Während des Setups von SQL Server durchsucht die Systemkonfigurationsprüfung (System Configuration Checker, SCC) den Computer, auf dem SQL Server installiert werden soll. SCC sucht nach Bedingungen, die ein erfolgreiches Setup von SQL Server verhindern. Bevor Setup den Assistenten startet, ruft SCC den Status jedes Elements ab. SCC vergleicht dann das Ergebnis mit den erforderlichen Bedingungen und gibt Anweisungen zum Entfernen der Blockierungsprobleme.

Die Systemkonfigurationsprüfung generiert einen Bericht, der eine kurze Beschreibung für jede ausgeführte Regel sowie den Ausführungsstatus enthält. Der Bericht der Systemkonfigurationsprüfung befindet sich unter %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Bevor Sie Setup ausführen, lesen Sie die folgenden Themen:

  1. Hardware- und Softwareanforderungen für die Installation von SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Von den SQL Server-Editionen unterstützte Funktionen(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Sicherheitsüberlegungen für eine SQL Server-Installation(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Lokale Sprachversionen in SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Weitere Referenzen:

  1. Unterstützte Versions- und Editionsupgrades(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Vor dem Installieren des Failoverclusterings(http://go.microsoft.com/fwlink/?LinkId=235034)


Typ der Imagevorbereitung

[image]

Typ der Imagevorbereitung
Feedback senden

Auf der Seite Typ der Imagevorbereitung des SQL Server-Installations-Assistenten können Sie angeben, ob Sie eine neue Instanz von Microsoft SQL Server 2012 installieren oder einer vorhandenen Instanz Funktionen hinzufügen möchten.

Optionen

Aktivieren Sie das Optionsfeld für Ihre Auswahl:

  • Eine neue Instanz von Microsoft SQL Server 2012 vorbereiten

  • Einer vorhandenen vorbereiteten Microsoft SQL Server 2012-Instanz Funktionen hinzufügen

    Wenn Sie die Option zum Hinzufügen von Funktionen zu einer vorhandenen Instanz auswählen, können Sie in der Dropdownliste die vorbereitete Instanz von SQL Server auswählen, die aktualisiert werden soll.

    Hinweis Hinweis

    Sie können die unterstützten SQL Server-SysPrep-Funktionen (Database Engine (Datenbankmodul) und Reporting Services) einem vorbereiteten Image von SQL Server hinzufügen. Andere Funktionen, die nicht von SQL Server-SysPrep unterstützt werden, können nur hinzugefügt werden, nachdem die vorbereitete Instanz abgeschlossen wurde.


Product Key

[image]

Product Key
Feedback senden

Auf der Seite Product Key können Sie Ihre Instanz von SQL Server validieren, oder Sie können angeben, welche kostenlose Edition von SQL Server Sie installieren möchten.

Optionen

Wenn Sie eine kostenlose Edition von SQL Server installieren möchten, aktivieren Sie die Optionsschaltfläche für kostenlose Installationen, und wählen Sie aus dem Dropdownfeld die gewünschte Edition aus.

Aktivieren Sie die Optionsschaltfläche für den Product Key, und geben Sie diesen in die dafür vorgesehenen Felder ein, um eine bezahlte Edition von SQL Server zu validieren.

Verwenden Sie bei der Installation von Failoverclustern den gleichen Product Key für jeden Failoverclusterknoten. Wenn Sie einen Product Key aus einer anderen SQL Server-Edition verwenden, tritt ein Fehler auf.


Status (Deinstallieren)

[image]

Status (Deinstallieren)
Siehe auch Feedback senden

Verwenden Sie die Seite Status (Deinstallieren), um den Setupstatus zu überwachen.

Siehe auch

Konzepte

Lesen und Anzeigen der Setupprotokolldateien von SQL Server


Das Image kann jetzt abgeschlossen werden

[image]

Das Image kann jetzt abgeschlossen werden
Feedback senden

Die Seite Das Image kann jetzt abgeschlossen werden stellt eine Zusammenfassung der Konfigurationseinstellungen bereit, die für die Konfiguration der vorbereiteten Instanz übernommen werden.

Optionen

Auf dieser Seite stehen Ihnen die folgenden Optionen zur Verfügung:

  • Um mit dem Setup fortzufahren, klicken Sie auf Installieren.

  • Um die Installationseinstellungen zu ändern, klicken Sie auf Zurück.

  • Klicken Sie auf Abbrechen, um Setup zu beenden.


Bereit zur Installation

[image]

Bereit zur Installation
Siehe auch Feedback senden

Die Seite Installationsbereit enthält eine Zusammenfassung der Funktionen, die beim SQL Server-Setup installiert oder geändert werden sollen.

Optionen

Auf dieser Seite stehen Ihnen die folgenden Optionen zur Verfügung:

  • Um mit dem Setup fortzufahren, klicken Sie auf Installieren.

  • Um die Installationseinstellungen zu ändern, klicken Sie auf Zurück.

  • Klicken Sie auf Abbrechen, um Setup zu beenden.

Siehe auch

Konzepte

Lesen und Anzeigen der Setupprotokolldateien von SQL Server


Das Image kann jetzt vorbereitet werden

[image]

Das Image kann jetzt vorbereitet werden
Feedback senden

Die Seite Das Image kann jetzt vorbereitet werden stellt eine Zusammenfassung der Funktionen bereit, die von SQL Server-Setup vorbereitet werden soll.

Optionen

Auf dieser Seite stehen Ihnen die folgenden Optionen zur Verfügung:

  • Um mit dem Setup fortzufahren, klicken Sie auf Installieren.

  • Um die Installationseinstellungen zu ändern, klicken Sie auf Zurück.

  • Klicken Sie auf Abbrechen, um Setup zu beenden.


Die Reparatur kann jetzt ausgeführt werden

[image]

Die Reparatur kann jetzt ausgeführt werden
Siehe auch Feedback senden

Die Seite Die Reparatur kann jetzt ausgeführt werden stellt eine Zusammenfassung des Reparaturprozesses durch SQL Server-Setup bereit.

Optionen

Auf dieser Seite stehen Ihnen die folgenden Optionen zur Verfügung:

  • Um mit dem Setup fortzufahren, klicken Sie auf Reparieren.

  • Um die Installationseinstellungen zu ändern, klicken Sie auf Zurück.

  • Um das Setup zu beenden, klicken Sie auf Abbrechen.

Siehe auch

Konzepte

Lesen und Anzeigen der Setupprotokolldateien von SQL Server


Entfernen eines SQL Server-Failoverclusterknotens

[image]

Entfernen eines SQL Server-Failoverclusterknotens
Feedback senden

Auf der Seite Failoverclusterknoten entfernen können Sie den Computer identifizieren, der als Microsoft SQL Server 2012-Failoverclusterknoten entfernt werden soll.


Reparaturstatus

[image]

Reparaturstatus
Siehe auch Feedback senden

Auf der Seite Reparaturstatus des SQL Server-Installations-Assistenten können Sie den Status der SQL Server-Reparatur überwachen.

Siehe auch

Konzepte

Lesen und Anzeigen der Setupprotokolldateien von SQL Server


Reporting Services-Konfigurationsoptionen (SSRS)

[image]

Reporting Services-Konfigurationsoptionen (SSRS)
Siehe auch Feedback senden

Auf der Seite Reporting Services-Konfiguration des Installations-Assistenten für Microsoft SQL Server können Sie die Optionen für das Installieren und Konfigurieren eines Berichtsservers angeben. Die Verfügbarkeit einer Installationsoption ist von den Optionen abhängig, die Sie auf der Seite Funktionsauswahl ausgewählt haben, und richtet sich danach, ob Sie gleichzeitig mit dem Berichtsserver auch eine lokale Instanz von SQL Server Database Engine (Datenbankmodul) installieren.

Wenn ein SSL-Zertifikat (Secure Sockets Layer) auf dem Computer installiert und an ein starkes Platzhalterzeichen gebunden ist, werden Reporting Services-URLs von Setup in einigen Fällen mit HTTPS-Präfix erstellt. Weitere Informationen über das Zuordnen von Zertifikaten zu Reporting Services-URLs finden Sie in der SQL Server-Onlinedokumentation unter Konfigurieren eines Berichtsservers für SSL-Verbindungen (Secure Sockets Layer) (http://go.microsoft.com/fwlink/?LinkId=199089).

Die neuesten Informationen über Reporting Services und die Installation und Konfiguration dieser Version finden Sie unter Zusätzliche Installationsinformationen (http://go.microsoft.com/fwlink/?LinkId=207425).

Optionen

Einheitlicher Modus von Reporting Services

Wenn Setup keine Standardkonfiguration des Berichtsservers ausführen kann, weil mindestens eine Anforderung nicht erfüllt wird, lässt der Installations-Assistent nur die Option für die minimale Installation zu. Dabei werden die erforderlichen Dateien kopiert, nach Abschluss der Installation muss jedoch ein Berichtsserver im einheitlichen Modus mithilfe des Konfigurations-Managers für Reporting Services konfiguriert werden.

Hinweis Hinweis

Eine vorhandene Berichtsserver-Datenbankdatei verursacht möglicherweise einen Fehler beim Setup, wenn Sie eine der Standardinstallationsoptionen auswählen. Wenn Sie eine Standardinstallationsoption auswählen, versucht Setup, eine Berichtsserver-Datenbank mit dem Standardnamen zu erstellen. Wenn bereits eine Datenbank mit diesem Namen vorhanden ist, tritt ein Fehler beim Setup auf, und Sie müssen ein Rollback für die Installation ausführen. Um dieses Problem zu vermeiden, können Sie die vorhandene Datenbank umbenennen, bevor Sie Setup ausführen, oder die Option Nur installieren auswählen, sodass Sie benutzerdefinierte Datenbankeinstellungen angeben können, wenn Setup beendet ist.

Installieren und konfigurieren

Installiert eine Berichtsserverinstanz im einheitlichen Modus mit den Standardwerten für die Berichtsserver-Datenbanken und das Dienstkonto sowie die URL-Reservierungen. Wenn Sie diese Option auswählen, kann die Berichtsserverinstanz verwendet werden, wenn das Setup fertig gestellt ist. Das Setup erstellt die Berichtsserver-Datenbank mithilfe einer lokalen Instanz von Database Engine (Datenbankmodul) und konfiguriert einen Berichtsserver so, dass Standardwerte verwendet werden.

Diese Option steht nur zur Verfügung, wenn die Standardwerte, die in einer Berichtsserverinstallation verwendet werden, für Ihr System gültig sind. Diese Option wird für Entwickler empfohlen, die alle Komponenten lokal installieren möchten, sowie für Benutzer, die die Software evaluieren.

Klicken Sie auf Details, um Informationen über die Standardeinstellungen anzuzeigen, die das Setup verwendet, oder um festzustellen, warum die Standardkonfiguration nicht installiert werden kann. Weitere Informationen über die Standardkonfiguration für einen Berichtsserver im einheitlichen Modus finden Sie unter Standardkonfiguration für die Installation im einheitlichen Modus (Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199091).

Nur installieren

Installiert die Berichtsserver-Programmdateien, erstellt das Berichtsserver-Dienstkonto und registriert den Windows-Verwaltungsinstrumentationsanbieter des Berichtsservers. Diese Installationsoption wird als "Nur Dateien"-Installation bezeichnet. Wählen Sie diese Option aus, wenn Sie die Standardkonfiguration nicht verwenden möchten. Wenn die Standardkonfiguration nicht installiert werden kann oder wenn Sie ein SQL Server-Failovercluster installieren, das Reporting Services enthält, ist dies die einzige verfügbare Option. Weitere Informationen zu einer ausschließlichen Datei-Installation finden Sie unter Ausschließliche Datei-Installation (Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199093).

Nach Abschluss des Setups müssen Sie die Berichtsserver-Datenbank erstellen und den Berichtsserver konfigurieren, bevor Sie ihn verwenden können. Verwenden Sie zum Konfigurieren eines Berichtsservers und Erstellen der Datenbank den Reporting Services-Konfigurations-Manager. Weitere Informationen finden Sie unter Vorgehensweise: Erstellen einer Berichtsserver-Datenbank (Reporting Services-Konfiguration) (http://go.microsoft.com/fwlink/?LinkId=199094) und Konfigurieren einer Berichtsserver-Datenbankverbindung (http://go.microsoft.com/fwlink/?LinkId=199095).

SharePoint-Modus von Reporting Services

Nur installieren

Installiert die Berichtsserver-Programmdateien und PowerShell-Cmdlets. Wenn die Installation abgeschlossen ist, müssen Sie die Reporting Services SharePoint Services starten und eine Reporting Services-Dienstanwendung erstellen. Weitere Informationen finden Sie unter Übersicht über das Installieren und Konfigurieren des Reporting Services-Diensts für die SharePoint-Integration (http://go.microsoft.com/fwlink/?LinkId=207543), Erstellen einer SQL Server Reporting Services-Dienstanwendung (SSRS) (http://go.microsoft.com/fwlink/?LinkId=207544) und Überblick über Reporting Services und die SharePoint-Integration (http://go.microsoft.com/fwlink/?LinkID=207244).

Installieren des Reporting Services-Add-Ins für SharePoint-Technologien

Das Add-In kann ab Version Microsoft SQL Server 2012 als Teil der SQL Server-Installation auf der Seite für die Funktionsauswahl des Installations-Assistenten für SQL Server installiert werden.

Das Reporting Services-Add-In für SharePoint 2010 kann jedoch mithilfe einer der folgenden Methoden installiert werden:

  • Führen Sie das Vorbereitungstool für SharePoint 2010-Produkte, PreRequisiteInstaller.exe, aus.

  • Führen Sie die Installation über das SQL Server-Installationsmedium durch. Klicken Sie im Setupordner auf den SQL Server-Installationsmedien auf die Datei rsSharePoint.msi, nachdem das Setup von SQL Server abgeschlossen ist.

  • Laden Sie das Add-In herunter, und installieren Sie es. Weitere Informationen finden Sie unter Verfügbarkeit des Reporting Services-Add-Ins für SharePoint-Produkte (http://go.microsoft.com/fwlink/?LinkID=208634).

Siehe auch

Andere Ressourcen

Vorgehensweise: Starten des Reporting Services-Konfigurations-Managers
Vorgehensweise: Erstellen einer Berichtsserver-Datenbank (Reporting Services-Konfiguration)
Überlegungen zum Installieren von Reporting Services
Standardkonfiguration für die Installation im einheitlichen Modus (Reporting Services)
Standardkonfiguration für den SharePoint-Modus (Reporting Services)
Installieren von SQL Server von der Eingabeaufforderung


Upgrade des SharePoint-Modus von Reporting Services (SSRS)

[image]

Upgrade des SharePoint-Modus von Reporting Services (SSRS)
Siehe auch Feedback senden

Verwenden Sie die Seite SharePoint-Modus von Reporting Services, um das Upgrade aller freigegebenen Funktionen zu bestätigen. Der SharePoint-Modus von Reporting Services ist eine freigegebene Funktion von SQL Server und wird mit allen anderen freigegebenen Funktionen von SQL Server aktualisiert. Das Upgrade nur einer freigegebenen Funktion wird vom Installations-Assistenten für SQL Server nicht unterstützt. Alle freigegebenen Funktionen von SQL Server werden gleichzeitig aktualisiert.

Optionen

Die Schaltfläche Weiter ist nur verfügbar, wenn das Kontrollkästchen Upgrade fortsetzen aktiviert ist. Wenn Sie das Kontrollkästchen nicht aktivieren, können Sie das Upgrade nicht fortsetzen.

Weitere Informationen finden Sie unter Reporting Services-Upgrade (http://go.microsoft.com/fwlink/?LinkId=199092).

Siehe auch

Konzepte

Lesen und Anzeigen der Setupprotokolldateien von SQL Server

Andere Ressourcen

Installieren von SQL Server von der Eingabeaufforderung


Authentifizierung im SharePoint-Modus von Reporting Services

[image]

Authentifizierung im SharePoint-Modus von Reporting Services
Siehe auch Feedback senden

Verwenden Sie die Seite für dieAuthentifizierung im SharePoint-Modus von Reporting Services des Installations-Assistenten für Microsoft SQL Server, um die Anmeldeinformationen des in der aktuellen Reporting Services-Installation verwendeten Dienstkontos anzugeben. Die Anmeldeinformationen werden zum Erstellen eines neuen SharePoint-Anwendungspools verwendet. Darüber hinaus wird eine neue Reporting Services-SharePoint-Dienstanwendung erstellt. Der Name der Dienstanwendung enthält den Namen der vorherigen Reporting Services-Instanz.

Optionen

  • Die Option Name des SSRS-Anwendungspoolkontos: ist schreibgeschützt. Der Wert wird automatisch durch den aktuellen Wert aus der vorhandenen Reporting Services-Installation ersetzt, die Sie aktualisieren.

  • Falls das Anwendungspoolkonto kein Kennwort erfordert, ist die Option Kennwort des SSRS-Anwendungspoolkontos: deaktiviert. Beispiel: "NT Authority\NetworkService". Falls für das Anwendungspoolkonto ein Kennwort erforderlich ist, kann das Upgrade erst nach Eingabe des richtigen Kennworts fortgesetzt werden.

Weitere Informationen finden Sie unter Reporting Services-Upgrade (http://go.microsoft.com/fwlink/?LinkId=199092).

Siehe auch

Andere Ressourcen

Reporting Services-Upgrade


Vorbereitete Instanz auswählen

[image]

Vorbereitete Instanz auswählen
Feedback senden

Auf der Seite Vorbereitete Instanz auswählen können Sie die vorbereitete Instanz auswählen, die Sie abschließen möchten.

Optionen

Im Feld Instanz-ID auswählen werden die vorbereiteten Instanzen angezeigt, die Sie abschließen können. Wählen Sie eine vorbereitete Instanz aus, die Sie abschließen möchten.

Instanz-ID auswählen

Die Liste enthält alle vorbereiteten Instanzen, die Sie auf dem Computer abschließen können, auf dem das SQL Server-Setup ausgeführt wird. Wählen Sie eine vorbereitete Instanz aus, die Sie abschließen möchten.

Installierte Instanzen

Dies schließt die installierten, vorbereiteten und abgeschlossenen Instanzen ein.


Serverkonfiguration – Sortierung

[image]

Serverkonfiguration – Sortierung
Feedback senden

Auf der Seite Serverkonfiguration - Sortierung des SQL Server-Installations-Assistenten können Sie die Sortierungseinstellungen von Database Engine (Datenbankmodul) und Analysis Services für die Sortierung ändern. Wählen Sie die entsprechende Option aus, um die Sortierungseinstellungen von verschiedenen SQL Server-Installationen oder verschiedenen Computern abzugleichen.

Optionen

Anpassen für SQL Server und Analysis Services.

SQL Server stellt zwei Gruppen von Sortierungen bereit: Windows-Sortierungen und SQL Server-Sortierungen. Sie können die Sortierungseinstellungen für Database Engine (Datenbankmodul) und Analysis Services entweder getrennt oder die gleiche Sortierung für beide Programme angeben.

Bei englischsprachigen (USA) Systemgebietsschemas wird die SQL Server-Sortierung standardmäßig automatisch ausgewählt. Die Standardsortierung für lokalisierte Versionen von SQL Server wird durch das Systemgebietsschema von Windows für den Computer bestimmt. Weitere Informationen finden Sie unter Using SQL Collations.

Sie sollten die Standardeinstellungen nur ändern, wenn die Sortierungseinstellungen der SQL Server-Installation mit den Sortierungseinstellungen einer anderen SQL Server-Instanz oder mit dem Windows-Systemgebietsschema eines anderen Computers übereinstimmen muss.

Hinweis Analysis Services verwendet ausschließlich Windows-Sortierungen. Wenn Sie Analysis Services installieren möchten, wählen Sie während des SQL Server-Setups eine Windows-Sortierung aus, um einheitliche Ergebnisse zwischen SQL Server Database Engine (Datenbankmodul) und Analysis Services sicherzustellen.

Weitere Informationen finden Sie unter Sortierungseinstellungen im Setup-Programm.

Bewährte Methoden

Weitere Informationen zu einer Tabelle von Windows-Systemgebietsschemas und den entsprechenden Standardsortierungen, die von SQL Server-Setup verwendet werden, finden Sie unter Sortierungseinstellungen im Setup-Programm.

Wenn möglich, sollte in Unternehmen eine Sortierung verwendet werden. Auf diese Weise müssen Sie die Sortierung nicht explizit für jede Datenbank, jede Spalte, jeden Ausdruck oder jeden Bezeichner angeben. Wenn Sie mit mehreren Sortierungen und Codepageeinstellungen arbeiten müssen, codieren Sie Ihre Abfragen so, dass diese den Regeln der Sortierungspriorität entsprechen. Weitere Informationen finden Sie im Thema Rangfolge von Sortierungen (Transact-SQL) in der Onlinedokumentation.

Berücksichtigen Sie folgende Empfehlungen beim Auswählen einer Sortierung für SQL Server:

  • Wählen Sie eine BINARY2-Sortierung aus, wenn auf Binärcodepunkten basierende Sortierungen zulässig sind.

  • Wählen Sie eine Windows-Sortierung für einen einheitlichen, datentypübergreifenden Vergleich aus.

  • Verwenden Sie die neue Sortierung (gekennzeichnet mit "* _100") für eine bessere sprachliche Sortierungsunterstützung. Weitere Informationen finden Sie unter Sortierung und Unicode-Unterstützung.

  • Wenn Sie planen, eine Datenbank zur aktualisierten Instanz von SQL Server zu migrieren, wählen Sie die Sortierung aus, die zur vorhandenen Sortierung der Datenbank passt.


Serverkonfiguration – Dienstkonten

[image]

Serverkonfiguration – Dienstkonten
Siehe auch Feedback senden

Auf der Seite Serverkonfiguration des Installations-Assistenten von SQL Server können Sie den SQL Server-Diensten Anmeldekonten zuweisen. Welche Dienste tatsächlich auf dieser Seite konfiguriert sind, ist von den Funktionen abhängig, die Sie für die Installation ausgewählt haben.

Startkonten, die zum Starten und Ausführen von SQL Server verwendet werden, können Domänenbenutzerkonten, lokale Benutzerkonten, verwaltete Dienstkonten, virtuelle Konten oder integrierte Systemkonten sein.

Optionen

Sie können allen SQL Server-Diensten dasselbe Anmeldekonto zuweisen, oder Sie können jedes Dienstkonto einzeln konfigurieren. Außerdem können Sie angeben, ob Dienste automatisch starten sollen, manuell gestartet werden oder deaktiviert sind. Das Standardkonto wird für die meisten Installationen empfohlen.

  • Unter Windows 7 und Windows Server 2008 R2 werden die meisten Konten standardmäßig als virtuelles Konto eingerichtet.

  • Unter Windows Vista und Windows Server 2008 werden die meisten Konten standardmäßig als NETWORK SERVICE-Konto eingerichtet.

  • In einer Clusterinstallation unter Windows Server 2008 müssen Sie ein Domänenkonto geben.

Wenn Sie Dienste für die Verwendung von Domänenkonten konfigurieren, empfiehlt Microsoft, die Dienstkonten einzeln zu konfigurieren, um möglichst geringe Rechte für jeden Dienst bereitzustellen. Dabei erhalten SQL Server-Dienste die Berechtigungen, die mindestens erforderlich ist, um ihre Tasks auszuführen. Weitere Informationen einschließlich Beschreibungen der Typen von Konten finden Sie unter Einrichten von Windows-Dienstkonten.

SQL Server-Dienstkonten einzeln konfigurieren (empfohlen)

Stellen Sie mithilfe des Rasters die einzelnen SQL Server-Dienste mit Benutzername und Kennwort bereit, und legen Sie den Starttyp für jeden Dienst fest. SQL Server-Dienste können mit integrierten Systemkonten, lokalen Konten, lokalen Gruppen, Domänengruppen oder Domänenbenutzerkonten verwendet werden.

Wählen Sie einen der folgenden Dienste aus, um die Einstellungen anzupassen.

Diesen Dienst auswählen

Zum Konfigurieren der Authentifizierungseinstellungen für

SQL Server-Agent

Dienst, der Aufträge ausführt, SQL Server überwacht und die Automatisierung administrativer Tasks ermöglicht.

Dieser Dienst verfügt nicht über ein Standardanmeldekonto.

Der Standardstarttyp ist Manuell.

SQL Server

SQL Server Database Engine (Datenbankmodul).

Der Standardstarttyp ist Automatisch.

Hinweis Hinweis

SQL Server Browser

SQL Server Browser ist der Namensauflösungsdienst, der SQL Server-Verbindungsinformationen für Clientcomputer bereitstellt. Dieser Dienst wird für mehrere Instanzen von SQL Server und Integration Services freigegeben.

Das Standardanmeldekonto ist NT-Autorität\Lokaler Dienst und kann während des SQL Server-Setups nicht geändert werden. Sie können das Konto ändern, nachdem Setup abgeschlossen wurde.

Wird der Starttyp beim Setup nicht angegeben, wird er wie folgt bestimmt:

  • Der SQL Server-Browser wird auf Automatisch festgelegt und in den unten beschriebenen Installationsszenarien ausgeführt:

    • SQL Server-Failoverclusterinstanz

    • Benannte Instanz von SQL Server, wobei TCP oder NP aktiviert ist

    • Benannte Instanz von Analysis-Server und keine Gruppierung

  • Wenn keines dieser Szenarien zutrifft und der SQL Server-Browser bereits installiert ist, wird der aktuelle Status des SQL Server-Browsers beibehalten.

  • Der Starttyp wird auf Deaktiviert festgelegt und beendet, wenn vor der Installation keine SQL Server 2005-, SQL Server 2008- oder SQL Server 2008 R2-Instanz vorhanden ist.

Analysis Services

Analysis Services.

Der Standardstarttyp ist Automatisch.

Für den integrierten SharePoint-Modus müssen Sie ein Windows-Domänenbenutzerkonto angeben. Das von Ihnen angegebene Konto wird für den Analysis Services-Dienst verwendet. Das Konto, das Sie für die aktuelle Instanz angeben, muss auch für alle zusätzlichen Analysis Services-Instanzen verwendet werden, die der gleichen Farm anschließend hinzugefügt werden.

Reporting Services

Reporting Services. Dienstkonten werden verwendet, um eine Verbindung mit der Berichtsserver-Datenbank zu konfigurieren. Wählen Sie den integrierten Netzwerkdienst aus, wenn Sie Standardauthentifizierungseinstellungen verwenden möchten. Wenn Sie ein Domänenbenutzerkonto angeben und auf dem Berichtsserver die Windows-Authentifizierung verwenden, müssen Sie dafür einen Dienstprinzipalnamen (Service Principal Name, SPN) registrieren. Weitere Informationen finden Sie unter Vorgehensweise: Konfigurieren der Windows-Authentifizierung in Reporting Services.

Wichtiger Hinweis Wichtig

Microsoft empfiehlt, dass Sie das Netzwerkdienstkonto nicht für SQL Server oder die Agent-Dienste von SQL Server verwenden, wenn ein Konto mit weniger Rechten zur Verfügung steht, denn das Netzwerkdienstkonto ist ein Konto, das freigegeben werden kann. Das Netzwerkdienstkonto eignet sich als SQL Server-Dienstkonto nur, wenn Sie sicherstellen können, dass auf dem Computer keine anderen Dienste installiert sind, die das Konto verwenden. Lokale Benutzerkonten oder Domänenbenutzerkonten, bei denen es sich nicht um einen Windows-Administrator handelt, sind für diese SQL Server-Dienste besser geeignet.

Der Standardstarttyp ist Automatisch.

Integration Services

Integration Services stellt eine Gruppe grafischer Tools und programmierbarer Objekte zum Verschieben, Kopieren und Transformieren von Daten bereit.

Der Standardstarttyp ist Automatisch.

SQL Server-Volltextfilterdaemon-Startprogramm

Der Dienst, der die fdhost.exe-Prozesse erstellt. Dieser wird zum Hosten der Wörtertrennungen und Filter benötigt, mit denen Textdaten für die Volltextindizierung verarbeitet werden.

Wenn Sie ein Domänenkonto angeben, unter dem der FDHOST-Startprogrammdienst ausgeführt wird, wird dringend empfohlen, ein Konto mit eingeschränkten Berechtigungen zu verwenden. Dieses Konto sollte nicht mit dem Konto identisch sein, das Sie für den SQL Server-Dienst verwenden. Unter Windows Vista und Windows Server 2008 wird das Standarddienstkonto des FDHOST-Startprogramms auf LOCAL SERVICE festgelegt.

SQL Server Distributed Replay Client

Dienstkonto für den Distributed Replay Client-Dienst.

Stellen Sie ein Konto bereit, unter dem der Distributed Replay Client-Dienst ausgeführt werden soll. Dieses Konto sollte nicht mit dem Konto identisch sein, das Sie für den SQL Server-Dienst verwenden.

Der Standardstarttyp ist Manuell.

SQL Server Distributed Replay Controller

Dienstkonto für den Distributed Replay Controller-Dienst.

Stellen Sie ein Konto bereit, unter dem der Distributed Replay Controller-Dienst ausgeführt werden soll. Dieses Konto sollte nicht mit dem Konto identisch sein, das Sie für den SQL Server-Dienst verwenden.

Der Standardstarttyp ist Manuell.

Siehe auch

Andere Ressourcen

Überlegungen zur Sicherheit bei SQL Server-Installationen


Setuprolle

[image]

Setuprolle
Siehe auch Feedback senden

Geben Sie auf dieser Seite an, ob einzelne Funktionen über die Seite Funktionsauswahl ausgewählt werden sollen oder ob die Installation unter Verwendung einer Setuprolle ausgeführt werden soll.

Eine setup role ist eine unveränderliche Auswahl aller Funktionen und freigegebenen Komponenten, die zur Implementierung einer vordefinierten SQL Server-Konfiguration erforderlich sind.

Optionen

SQL Server-Funktionsinstallation

Verwenden Sie diese Option, um einzelne Funktionen und freigegebene Komponenten auszuwählen. Die Instanzfunktionen beinhalten Datenbankmoduldienste, Analysis Services (einheitlicher Modus) und Reporting Services.

SQL Server PowerPivot für SharePoint

Verwenden Sie diese Option, um Analysis Services-Serverkomponenten in einer SharePoint 2010-Farm zu installieren. Durch diese Option werden der PowerPivot-Systemdienst und der Analysis Services-Server in einer Farm bereitgestellt, wodurch Abfrage- und Datenverarbeitungsvorgänge für veröffentlichte Excel-Arbeitsmappen ermöglicht werden, die eingebettete PowerPivot-Daten enthalten.

Optional können Sie der Installation eine relationale Datenbankmodulinstanz hinzufügen, wenn Sie diese benötigen, um Datenbanken in einer SharePoint-Farm zu hosten. Wenn die Farm bereits konfiguriert ist, können Sie diese Option überspringen.

Nach Beenden des Setups müssen Sie die Software mit einem der folgenden Ansätze konfigurieren: PowerPivot-Konfigurationstool, PowerShell-Cmdlets oder SharePoint 2010-Zentraladministration. Im Gegensatz zu vorherigen Versionen werden beim Setup keine Konfigurationsaufgaben für eine PowerPivot-Installation mehr ausgeführt.

Eine rollenbasierte Installation enthält keine SQL Server PowerPivot für Excel-Clientanwendung. Die Clientanwendung wird getrennt installiert.

Alle Funktionen mit Standardwerten

Wählen Sie diese Setuprolle aus, um alle für diese Version verfügbaren Funktionen zu installieren. Beachten Sie, dass PowerPivot für SharePoint von dieser Rolle ausgeschlossen wird. Sie müssen diese Funktion mithilfe der PowerPivot für SharePoint-Setuprolle installieren.

Das Database Engine (Datenbankmodul) wird für den Start unter Verwendung des Kontos NT-AUTORITÄT\NETZWERKDIENST konfiguriert. Der aktuelle Benutzer wird als Mitglied der SQL Server-Rolle sysadmin bereitgestellt. Durch diese Option festgelegte Werte können durch Angabe zusätzlicher Befehlszeilenparameter überschrieben werden.

Unter Windows Vista oder Windows Server 2008 oder höher und sofern das Betriebssystem kein Domänencontroller ist, verwenden das Datenbankmodul, Reporting Services und Integration Services standardmäßig das Konto NT-AUTORITÄT\NETZWERKDIENST, und das Startprogramm für den SQL-Volltextfilterdaemon verwendet das Konto NT-AUTORITÄT\LOKALER DIENST.

Siehe auch

Verweis

Funktionsauswahl

Andere Ressourcen

Installieren von PowerPivot für SharePoint
Hardware- und Softwareanforderungen (PowerPivot für SharePoint)


SQL Server-Failovercluster-Assistent – Abgeschlossen

[image]

SQL Server-Failovercluster-Assistent – Abgeschlossen
Siehe auch Feedback senden

Das SQL Server-Setup überprüft die Computerkonfiguration, bevor der Setupvorgang abgeschlossen wird. Während des Setups von SQL Server durchsucht die Systemkonfigurationsprüfung (System Configuration Checker, SCC) den Computer, auf dem SQL Server installiert werden soll. SCC sucht nach Bedingungen, die ein erfolgreiches Setup von SQL Server verhindern. Bevor Setup den SQL Server-Installations-Assistenten startet, ruft SCC den Status jedes Elements ab. SCC vergleicht dann das Ergebnis mit den erforderlichen Bedingungen und gibt Anweisungen zum Entfernen der Blockierungsprobleme.

Die Systemkonfigurationsprüfung generiert einen Bericht, der eine kurze Beschreibung für jede ausgeführte Regel sowie den Ausführungsstatus enthält. Der Bericht der Systemkonfigurationsprüfung befindet sich unter %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Bevor Sie Setup ausführen, lesen Sie die folgenden Themen:

  1. Hardware- und Softwareanforderungen für die Installation von SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Von den SQL Server-Editionen unterstützte Funktionen(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Sicherheitsüberlegungen für eine SQL Server-Installation(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Lokale Sprachversionen in SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Weitere Referenzen:

  1. Unterstützte Versions- und Editionsupgrades(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Vor dem Installieren des Failoverclusterings(http://go.microsoft.com/fwlink/?LinkId=235034)

Siehe auch

Verweis

Unterstützungsregeln für Setup


SQL Server-Failovercluster-Assistent – Installation

[image]

SQL Server-Failovercluster-Assistent – Installation
Siehe auch Feedback senden

Das SQL Server-Setup überprüft die Computerkonfiguration, bevor der Setupvorgang abgeschlossen wird. Während des Setups von SQL Server durchsucht die Systemkonfigurationsprüfung (System Configuration Checker, SCC) den Computer, auf dem SQL Server installiert werden soll. SCC sucht nach Bedingungen, die ein erfolgreiches Setup von SQL Server verhindern. Bevor Setup den SQL Server-Installations-Assistenten startet, ruft SCC den Status jedes Elements ab. SCC vergleicht dann das Ergebnis mit den erforderlichen Bedingungen und gibt Anweisungen zum Entfernen der Blockierungsprobleme.

Die Systemkonfigurationsprüfung generiert einen Bericht, der eine kurze Beschreibung für jede ausgeführte Regel sowie den Ausführungsstatus enthält. Der Bericht der Systemkonfigurationsprüfung befindet sich unter %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Bevor Sie Setup ausführen, lesen Sie die folgenden Themen:

  1. Hardware- und Softwareanforderungen für die Installation von SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Von den SQL Server-Editionen unterstützte Funktionen(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Sicherheitsüberlegungen für eine SQL Server-Installation(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Lokale Sprachversionen in SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Weitere Referenzen:

  1. Unterstützte Versions- und Editionsupgrades(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Vor dem Installieren des Failoverclusterings(http://go.microsoft.com/fwlink/?LinkId=235034)

Siehe auch

Verweis

Unterstützungsregeln für Setup


SQL Server-Failovercluster-Assistent – Vorbereitung

[image]

SQL Server-Failovercluster-Assistent – Vorbereitung
Siehe auch Feedback senden

Das SQL Server-Setup überprüft die Computerkonfiguration, bevor der Setupvorgang abgeschlossen wird. Während des Setups von SQL Server durchsucht die Systemkonfigurationsprüfung (System Configuration Checker, SCC) den Computer, auf dem SQL Server installiert werden soll. SCC sucht nach Bedingungen, die ein erfolgreiches Setup von SQL Server verhindern. Bevor Setup den SQL Server-Installations-Assistenten startet, ruft SCC den Status jedes Elements ab. SCC vergleicht dann das Ergebnis mit den erforderlichen Bedingungen und gibt Anweisungen zum Entfernen der Blockierungsprobleme.

Die Systemkonfigurationsprüfung generiert einen Bericht, der eine kurze Beschreibung für jede ausgeführte Regel sowie den Ausführungsstatus enthält. Der Bericht der Systemkonfigurationsprüfung befindet sich unter %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Bevor Sie Setup ausführen, lesen Sie die folgenden Themen:

  1. Hardware- und Softwareanforderungen für die Installation von SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Von den SQL Server-Editionen unterstützte Funktionen(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Sicherheitsüberlegungen für eine SQL Server-Installation(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Lokale Sprachversionen in SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Weitere Referenzen:

  1. Unterstützte Versions- und Editionsupgrades(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Vor dem Installieren des Failoverclusterings(http://go.microsoft.com/fwlink/?LinkId=235034)

Siehe auch

Verweis

Unterstützungsregeln für Setup


Zusammenfassung (Upgrade)

[image]

Zusammenfassung (Upgrade)
Feedback senden

Die Seite Zusammenfassung enthält eine Übersicht über die angegebenen Optionen für dieses Upgrade.


Unterstützungsregeln für Setup

[image]

Unterstützungsregeln für Setup
Feedback senden

Das SQL Server-Setup überprüft die Computerkonfiguration, bevor der Setupvorgang abgeschlossen wird. Während des Setups von SQL Server durchsucht die Systemkonfigurationsprüfung (System Configuration Checker, SCC) den Computer, auf dem SQL Server installiert werden soll. SCC sucht nach Bedingungen, die ein erfolgreiches Setup von SQL Server verhindern. Bevor Setup den SQL Server-Installations-Assistenten startet, ruft SCC den Status jedes Elements ab. SCC vergleicht dann das Ergebnis mit den erforderlichen Bedingungen und gibt Anweisungen zum Entfernen der Blockierungsprobleme.

Die Systemkonfigurationsprüfung generiert einen Bericht, der eine kurze Beschreibung für jede ausgeführte Regel sowie den Ausführungsstatus enthält. Der Bericht der Systemkonfigurationsprüfung befindet sich unter %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Bevor Sie Setup ausführen, lesen Sie die folgenden Themen:

  1. Hardware- und Softwareanforderungen für die Installation von SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Von den SQL Server-Editionen unterstützte Funktionen(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Sicherheitsüberlegungen für eine SQL Server-Installation(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Lokale Sprachversionen in SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Weitere Referenzen:

  1. Unterstützte Versions- und Editionsupgrades(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Vor dem Installieren des Failoverclusterings(http://go.microsoft.com/fwlink/?LinkId=235034)

Weitere Themen zu Regeln

Szenariospezifische Setupregeln finden Sie in den folgenden Themen:

  • Installationsregeln

  • Prüfung der Upgraderegeln

  • Upgraderegeln für Editionen

  • Deinstallationsregeln

  • Regeln zum Vorbereiten des Images

  • Regeln zum Abschließen des Images


Deinstallationsregeln

[image]

Deinstallationsregeln
Siehe auch Feedback senden

Auf der Seite Deinstallationsregeln wird eine Reihe von Regeln ausgeführt, um sicherzustellen, dass der Setupvorgang erfolgreich abgeschlossen werden kann.

Das SQL Server-Setup überprüft die Computerkonfiguration, bevor der Setupvorgang abgeschlossen wird. Während des Setups von SQL Server durchsucht die Systemkonfigurationsprüfung (System Configuration Checker, SCC) den Computer, auf dem SQL Server installiert werden soll. SCC sucht nach Bedingungen, die ein erfolgreiches Setup von SQL Server verhindern. Bevor Setup den SQL Server-Deinstallations-Assistenten startet, ruft SCC den Status jedes Elements ab. SCC vergleicht dann das Ergebnis mit den erforderlichen Bedingungen und gibt Anweisungen zum Entfernen der Blockierungsprobleme.

Die Systemkonfigurationsprüfung generiert einen Bericht, der eine kurze Beschreibung für jede ausgeführte Regel sowie den Ausführungsstatus enthält. Der Bericht der Systemkonfigurationsprüfung befindet sich unter %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Bevor Sie Setup ausführen, lesen Sie die folgenden Themen:

  1. Hardware- und Softwareanforderungen für die Installation von SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Von den SQL Server-Editionen unterstützte Funktionen(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Sicherheitsüberlegungen für eine SQL Server-Installation(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Lokale Sprachversionen in SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Weitere Referenzen:

  1. Unterstützte Versions- und Editionsupgrades(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Vor dem Installieren des Failoverclusterings(http://go.microsoft.com/fwlink/?LinkId=235034)

Siehe auch

Verweis

Unterstützungsregeln für Setup


Upgradestatus

[image]

Upgradestatus
Siehe auch Feedback senden

Auf der Seite Upgradestatus des SQL Server-Installations-Assistenten können Sie den Status des SQL Server-Upgrades überwachen.

Siehe auch

Konzepte

Lesen und Anzeigen der Setupprotokolldateien von SQL Server


Prüfung der Upgraderegeln

[image]

Prüfung der Upgraderegeln
Siehe auch Feedback senden

Das SQL Server-Setup überprüft die Computerkonfiguration, bevor der Setupvorgang abgeschlossen wird. Während des Setups von SQL Server durchsucht die Systemkonfigurationsprüfung (System Configuration Checker, SCC) den Computer, auf dem SQL Server installiert werden soll. SCC sucht nach Bedingungen, die ein erfolgreiches Setup von SQL Server verhindern. Bevor Setup den Upgrade-Assistenten startet, ruft SCC den Status jedes Elements ab. SCC vergleicht dann das Ergebnis mit den erforderlichen Bedingungen und gibt Anweisungen zum Entfernen der Blockierungsprobleme.

Die Systemkonfigurationsprüfung generiert einen Bericht, der eine kurze Beschreibung für jede ausgeführte Regel sowie den Ausführungsstatus enthält. Der Bericht der Systemkonfigurationsprüfung befindet sich unter %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Bevor Sie Setup ausführen, lesen Sie die folgenden Themen:

  1. Hardware- und Softwareanforderungen für die Installation von SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Von den SQL Server-Editionen unterstützte Funktionen(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Sicherheitsüberlegungen für eine SQL Server-Installation(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Lokale Sprachversionen in SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Weitere Referenzen:

  1. Unterstützte Versions- und Editionsupgrades(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Vor dem Installieren des Failoverclusterings(http://go.microsoft.com/fwlink/?LinkId=235034)

Siehe auch

Verweis

Unterstützungsregeln für Setup


Überprüfen der Deinstallationsoptionen

[image]

Überprüfen der Deinstallationsoptionen
Feedback senden

Überprüfen Sie Ihre Auswahl, und klicken Sie dann auf Weiter.


Das Thema, das Sie suchen, ist nicht verfügbar

[image]

Das Thema, das Sie suchen, ist nicht verfügbar
Feedback senden

Nach Abschluss der Installation können Sie die Dokumentation für SQL Server anzeigen, indem Sie auf Hilfe klicken, die Taste F1 in Dialogfeldern oder Elementen der Benutzeroberfläche drücken, oder im Menü Start auf Alle Programme, dann auf Microsoft SQL Server und dann auf Hilfe und Community zeigen und anschließend auf SQL Server-Onlinedokumentation klicken. Weitere Informationen finden Sie unter Hinzufügen und Entfernen von Hilfeauflistungen.