Übersicht über die SQL Server-Wartungsinstallation

[image]

Übersicht über die SQL Server-Wartungsinstallation
Siehe auch Feedback senden

Sie können ein Update auf eine beliebige vorhandene Microsoft SQL Server 2012-Komponente mit einem Microsoft SQL Server 2012-Wartungsupdate anwenden. Wenn die Versionsebene einer vorhandenen Komponente von Microsoft SQL Server 2012 neuer ist als die Versionsebene des Updates, schließt das Setupprogramm diese Komponente vom Update aus. Weitere Informationen zur Anwendung eines Wartungsupdates finden Sie unter Installieren von SQL Server 2012-Wartungsupdates (http://go.microsoft.com/fwlink/?LinkId=231297).

Beim Installieren von Microsoft SQL Server 2012-Updates gelten die folgenden Überlegungen:

  • Alle Funktionen, die zu einer Instanz von SQL Server gehören, müssen gleichzeitig aktualisiert werden. Wenn Sie beispielsweise Database Engine (Datenbankmodul) aktualisieren, müssen Sie auch die Analysis Services-Komponente und die Reporting Services-Komponente aktualisieren, sofern diese als Teil derselben Instanz von SQL Server installiert sind. Freigegebene Funktionen wie Verwaltungstools, SQL Server-Datentools (SSDT) und SQL Server Integration Services müssen stets mit dem aktuellen Update aktualisiert werden. Wenn eine Komponente oder Instanz in der Funktionsstruktur nicht ausgewählt ist, wird die Komponente oder Instanz nicht aktualisiert.

  • Standardmäßig werden die Microsoft SQL Server 2012-Updateprotokolldateien unter "%Programme%\Microsoft SQL Server\110\Setup Bootstrap\LOG\" gespeichert.

  • Das Setup von SQL Server kann nun in den Originalmedien ein Update einschließen, sodass die Originalmedien und das Update gleichzeitig ausgeführt werden. Weitere Informationen finden Sie unter Neues in der SQL Server-Installation(http://go.microsoft.com/fwlink/?LinkID=219508).

  • Es wird empfohlen, vor dem Ausführen eines Microsoft SQL Server 2012-Wartungsupdates eine Sicherung der Daten in Erwägung zu ziehen.

  • SQL Server-Updates stehen über Microsoft Update zur Verfügung. Es wird empfohlen, regelmäßig nach Updates zu suchen, damit Ihre Instanz von SQL Server stets aktuell und sicher ist.

Weitere Informationen finden Sie unter Anwenden eines SQL Server-Updates auf eine Failoverclusterinstanz in der Microsoft Knowledge Base.

Erforderlicher Speicherplatz

Der empfohlene erforderliche Speicherplatz beträgt etwa das 2,5-fache der Paketgröße, um das Paket installieren, herunterladen und extrahieren zu können.

Nach dem Installieren eines Service Packs können Sie das heruntergeladene Paket entfernen. Die temporären Dateien werden automatisch entfernt.

Übersicht über die Installation

In diesem Abschnitt wird die Microsoft SQL Server 2012-Installation für kumulierte Updates und Service Packs einschließlich der folgenden Themen beschrieben:

  • Vorbereiten einer Installation von Microsoft SQL Server 2012-Updates

  • Installieren von Microsoft SQL Server 2012-Updates

  • Neustarten von Diensten und Anwendungen

Vorbereiten einer Installation von Microsoft SQL Server 2012-Updates

Es wird dringend empfohlen, dass Sie wie folgt vorgehen, bevor Sie Microsoft SQL Server 2012-Updates installieren:

  • Sichern der SQL Server-Systemdatenbanken – Sichern Sie vor der Installation von Microsoft SQL Server 2012-Updates die Datenbanken master, msdb und model. Durch die Installation von Microsoft SQL Server 2012-Updates werden diese Datenbanken geändert. Sie werden damit inkompatibel mit früheren Versionen von Microsoft SQL Server 2012. Sicherungen dieser Datenbanken sind erforderlich, wenn Sie Microsoft SQL Server 2012 ohne diese Updates erneut installieren möchten.

    Das Sichern der Benutzerdatenbanken ist ebenfalls empfehlenswert.

Wichtiger Hinweis Wichtig

Wenn Sie Updates auf Instanzen von SQL Server anwenden, die Teil einer Replikationstopologie sind, müssen Sie vor dem Anwenden der Updates die replizierten Datenbanken zusammen mit den Systemdatenbanken sichern.

  • Sichern der Datenbanken, der Konfigurationsdatei und des Repositorys von Analysis Services – Vor dem Aktualisieren einer Instanz von Analysis Services sollten Sie Folgendes sichern:

    • Analysis Services-Datenbanken. Standardmäßig sind diese unter C:\Programme\Microsoft SQL Server\MSAS11.<Instanz-ID>\OLAP\Data\ installiert. Für die WOW-Installation ist der Standardpfad C:\ProgramFiles (x86) \Microsft SQL Server\MSAS11.<Instanz-ID>\OLAP\Data\.

    • Die Analysis Services-Konfigurationseinstellung in der Konfigurationsdatei msmdsrv.ini. Standardmäßig befindet sich diese im Verzeichnis C:\Programme\Microsoft SQL Server\MSAS11.<Instanz-ID>\OLAP\Config\.

    • (Optional) Die Datenbank, die das Analysis Services-Repository enthält. Dieser Schritt ist nur erforderlich, wenn Analysis Services für die Verwendung der Decision Support Objects (DSO)-Bibliothek konfiguriert wurde.

Hinweis Hinweis

Ohne eine Sicherung der Datenbanken, der Konfigurationsdatei und des Repositorys von Analysis Services ist es nicht möglich, eine aktualisierte Instanz von Analysis Services auf die vorherige Version zurückzusetzen.

  • Überprüfen des freien Speicherplatzes für die Systemdatenbanken – Falls die automatische Vergrößerungsoption für die Systemdatenbanken master und msdb nicht aktiviert ist, muss für jede dieser Datenbanken mindestens 500 KB Speicherplatz verfügbar sein. Führen Sie die gespeicherte Systemprozedur sp_spaceused für die Datenbanken master und msdb aus, um zu überprüfen, ob die Datenbanken über genügend Speicherplatz verfügen. Falls der nicht zugeordnete Speicherplatz in einer der Datenbanken weniger als 500 KB beträgt, sollten Sie die Datenbank vergrößern. Weitere Informationen finden Sie unter "Erweitern einer Datenbank" in der SQL Server-Onlinedokumentation.

  • Beenden von Diensten und Anwendungen – Um einen möglichen Neustart des Systems zu vermeiden, beenden Sie vor dem Installieren von Microsoft SQL Server 2012-Updates alle Anwendungen und Dienste, die Verbindungen mit zu aktualisierenden Instanzen von SQL Server herstellen. Dazu gehören SQL Server Management Studio und SQL Server-Datentools (SSDT).

Hinweis Hinweis

In einer Failoverclusterumgebung können Sie keine Dienste beenden. Weitere Informationen hierzu finden Sie weiter unten in diesem Thema im Abschnitt zur Failoverclusterinstallation.

  • Damit der Computer nach der Installation des Updates nicht neu gestartet werden muss, zeigt das Setup eine Liste der Prozesse an, die Dateien sperren. Wenn das Setupprogramm für das Update während der Installation einen Dienst beenden muss, wird der Dienst nach Abschluss der Installation neu gestartet.

  • Wenn vom Setup festgestellt wird, dass Dateien während der Installation blockiert werden, müssen Sie den Computer möglicherweise nach dem Fertigstellen der Installation erneut starten. Gegebenenfalls werden Sie aufgefordert, den Computer neu zu starten.

Installieren von Microsoft SQL Server 2012-Updates

In diesem Abschnitt wird der Installationsvorgang beschrieben.

Wichtiger Hinweis Wichtig

Microsoft SQL Server 2012-Updates müssen unter einem Konto installiert werden, das über Administratorrechte auf dem Computer verfügt, auf dem diese installiert werden.

Starten eines Microsoft SQL Server 2012-Updates

Um ein Microsoft SQL Server 2012-Update zu installieren, führen Sie die selbst extrahierende Paketdatei aus.

Kumuliertes Update-Paket (CU): <SQLServer2011>-KBxxxxxx-PPP.exe

Service Pack-Paket (PCU): <SQLServer2011><SPx> -KBxxxxxx-PPP-LLL.exe

  • x gibt die Nummer des Service Packs an.

  • PPP gibt die spezifische Plattform an.

  • LLL gibt die Sprach-LCID an (Beispiel: ENU für Englisch).

Informationen zum Anwenden von Updates auf Komponenten von Microsoft SQL Server 2012, die Teil eines Failoverclusters sind, finden Sie im Abschnitt zur Failoverclusterinstallation. Weitere Informationen über das Ausführen einer Updateinstallation im unbeaufsichtigten Modus finden Sie unter Installieren von SQL Server 2012 vom Installations-Assistenten aus (Setup).

Produktupdates in der Microsoft SQL Server 2012-Installation

Das Produktupdate ist eine neue Funktion im Microsoft SQL Server 2012-Setup. Mit ihr werden die neuesten Produktupdates in die Installation des Hauptprodukts integriert, sodass das Hauptprodukt und geeignete Updates gleichzeitig installiert werden. Product Update kann Microsoft Update, Windows Server Update Services (WSUS), einen lokalen Ordner oder eine Netzwerkfreigabe nach anwendbaren Updates durchsuchen. Nachdem Setup die neuesten Versionen der anwendbaren Updates gefunden hat, lädt es diese herunter und integriert sie in den aktuellen SQL Server-Installationsvorgang. Das Produktupdate kann ein kumulatives Update, Service Pack oder Service Pack plus kumulatives Update einziehen. Die Produktupdatefunktionalität ist eine Erweiterung der Slipstream-Funktionalität, die in SQL Server 2008 PCU1 verfügbar war.

Aktualisieren eines vorbereiteten Images von SQL Server

Sie können ein Update auf eine nicht konfigurierte vorbereitete Instanz von SQL Server anwenden, ohne die Konfiguration der vorbereiteten Instanz abzuschließen. Im Folgenden werden verschiedene Methoden für die Anwendung eines Updates auf eine vorbereitete Instanz von SQL Server erklärt:

  • Aktualisieren einer zuvor vorbereiteten Instanz von SQL Server

    Updates für eine vorbereitete Instanz können vor der Konfiguration angewendet werden. Das Updatepaket erkennt, dass die Instanz im vorbereiteten Status ist und wendet den Patch für die vorbereitete Instanz an, ohne die Konfiguration abzuschließen.

  • Updates für eine vorbereitete Instanz mittels Microsoft Update:

    Sie können Updates auf eine vorbereitete Instanz von SQL Server mittels Microsoft Updates anwenden. Das Microsoft Update-Paket erkennt, dass die Instanz im vorbereiteten Status ist, und wendet den Patch für die vorbereitete Instanz an, ohne die Konfiguration abzuschließen.

Wenn Sie ein vorbereitetes Image von SQL Server aktualisieren, müssen Sie den InstanceID-Parameter angeben. Weitere Informationen und eine Beispielsyntax finden Sie unter Installieren von Updates an der Eingabeaufforderung.

Aktualisieren eines abgeschlossenen Images von SQL Server

Bei dem Update einer abgeschlossenen und konfigurierten Instanz von SQL Server werden die gleichen Prozesse angewendet wie für jede andere installierte Instanz von SQL Server.

Anwenden eines Microsoft SQL Server 2012-Updates auf eine Failoverclusterinstanz

Weitere Informationen über das Installieren von Updates für einen Microsoft SQL Server 2012-Failovercluster finden Sie unter Anwenden eines SQL Server-Updates auf eine Failoverclusterinstanz in der Microsoft Knowledge Base.

Neuerstellen eines Microsoft SQL Server 2012-Failoverclusterknotens

Führen Sie die folgenden Schritte aus, wenn Sie einen Knoten im Failovercluster nach der Anwendung von Updates neu erstellen müssen:

  1. Erstellen Sie den Knoten im Failovercluster neu. Weitere Informationen zum Neuerstellen eines Knotens finden Sie unter "Vorgehensweise: Wiederherstellen bei einem Failoverclusterfehler in Szenario 1" in der SQL Server-Onlinedokumentation.

  2. Führen Sie das ursprüngliche Microsoft SQL Server 2012-Setupprogramm aus, um Microsoft SQL Server 2012 auf dem Failoverclusterknoten zu installieren.

  3. Führen Sie das Setup für Microsoft SQL Server 2012-Updates auf dem hinzugefügten Knoten aus.

Neustarten von Diensten und Anwendungen

Nach Abschluss des Setups werden Sie möglicherweise aufgefordert, den Computer neu zu starten. Nach dem Neustart des Systems oder nach Abschluss des Setups ohne erforderlichen Neustart können Sie den Knoten Dienste in der Systemsteuerung verwenden, um die Dienste neu zu starten, die Sie vor dem Anwenden der Microsoft SQL Server 2012-Updates beendet haben. Dazu gehören Dienste wie Distributed Transaction Coordinator und die Microsoft Search-Dienste oder entsprechende instanzenspezifische Dienste.

Starten Sie die Anwendungen erneut, die Sie vor dem Ausführen des Setups für das Microsoft SQL Server 2012-Update beendet haben. Es ist auch sinnvoll, sofort nach der erfolgreichen Installation eine weitere Sicherung der aktualisierten Datenbanken master, msdb und model zu erstellen.

Deinstallieren von Microsoft SQL Server 2012-Updates

Kumulative Updates für Microsoft SQL Server 2012 oder Service Packs können in der Systemsteuerung mithilfe der Option Programme und Funktionen deinstalliert werden. Die kumulativen Updates werden einzeln aufgelistet. Wenn jedoch ein Service Pack installiert wird, das höher als die kumulativen Updates ist, werden die Einträge der kumulativen Updates ausgeblendet und stehen nur zur Verfügung, wenn das Service Pack deinstalliert wird.

Um alle Service Packs und Updates zu deinstallieren, müssen Sie mit dem aktuellen Update oder Service Pack, das auf die Instanz von SQL Server angewendet wurde, beginnen und anschließend die niedrigeren Versionen deinstallieren. In den folgenden Beispielen verfügt SQL Server zum Schluss über das kumulative Update 1, nachdem die Deinstallation der anderen Service Packs und Updates abgeschlossen wurde:

  • Bei einer Instanz von Microsoft SQL Server 2012, auf der das kumulative Update 1 und SP1 installiert sind, müssen Sie SP1 deinstallieren.

  • Bei einer Instanz von Microsoft SQL Server 2012, auf der das kumulative Update 1, SP1 und das kumulative Update 2 installiert sind, deinstallieren Sie zunächst das kumulative Update 2 und anschließend SP1.

Siehe auch

Konzepte

Installieren von Updates an der Eingabeaufforderung
Senden Sie Feedback zu diesem Thema an Microsoft

© 2012 Microsoft Corporation. Alle Rechte vorbehalten.


Rechtliche Hinweise für die Dokumentation

[image]

Rechtliche Hinweise für die Dokumentation
Feedback senden

Dieses Dokument wird "wie besehen" zur Verfügung gestellt. Die in diesen Unterlagen enthaltenen Angaben und Ansichten, einschließlich URLs und anderer Verweise auf Internetwebsites, können ohne vorherige Ankündigung geändert werden. Ihnen obliegt das Risiko der Verwendung.

Einige der in diesem Dokument dargestellten Beispiele werden nur zu Illustrationszwecken bereitgestellt und sind fiktiv. Es wird keine reale Verknüpfung beabsichtigt oder abgeleitet.

Dieses Dokument gibt Ihnen keine Rechte auf geistiges Eigentum in Microsoft-Produkten. Sie können dieses Dokument zu internen Zwecken und als Referenz kopieren und verwenden.

© 2012 Microsoft. Alle Rechte vorbehalten.

Microsoft, Active Directory, ActiveX, Bing Maps, Excel, IntelliSense, MSDN, MS-DOS, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual Studio, Windows, Windows NT, Windows Server und Windows Vista sind Marken der Microsoft-Unternehmensgruppe. SAP NetWeaver ist eine eingetragene Marke der SAP AG in Deutschland und/oder anderen Ländern. Alle anderen Marken sind Eigentum ihrer jeweiligen Inhaber.

Dokumentationsrichtlinie für den Support von und das Upgrade auf SQL Server

Die Dokumentation zur Microsoft SQL Server 2012-Software besteht aus der Microsoft-Onlinedokumentation für Microsoft SQL Server 2012, Installationsdokumentation, Referenzdokumentation für Programmierer, Lernprogrammen, Infodateien, Dokumenten zu bekannten Problemen, Beispielcode, Beispieldatenbanken und von Microsoft veröffentlichten Knowledge Base-Artikeln. Alle diese Elemente enthalten Inhalte zu Funktionen und zur Funktionalität von SQL Server. Diese Support- und Upgraderichtlinie gilt für die Microsoft SQL Server 2012-Dokumentation, einschließlich der Infodateien zu Versionen und Service Packs von Microsoft SQL Server 2012. Eine Infodatei wird als Erweiterung der Microsoft SQL Server 2012-Onlinedokumentation betrachtet.

Die in dieser Dokumentation enthaltenen Beispiele dienen in erster Linie der Veranschaulichung eines Konzepts oder der sinnvollen Verwendung einer bestimmten Anweisung oder Klausel. Die meisten Beispiele enthalten nicht den gesamten Code, der normalerweise in einem vollständigen Produktionssystem vorhanden wäre, da die Datenüberprüfung und Fehlerbehandlung teilweise entfernt wurde, um das Beispiel eines bestimmten Konzepts oder einer Anweisung hervorzuheben. Für diese Beispiele oder den enthaltenen Quellcode ist kein technischer Support verfügbar.

In einigen Fällen wurde eine bestimmte Funktion von Microsoft SQL Server 2012 nicht ausreichend getestet bzw. entwickelt und ist nicht für Ihre Verwendung gedacht. Derartige Funktionen dienen häufig als Platzhalter. Deshalb sind bestimmte Funktionen, die in der Software enthalten sind, nicht dokumentiert. Funktionen, die nicht dokumentiert wurden oder als Vermerk für die Microsoft-interne Verwendung aufgenommen wurden, sind nicht für eine Verwendung durch Benutzer gedacht, und der Microsoft-Kundendienst bietet keinen Support dafür an. Sofern in der Dokumentation zu Microsoft SQL Server 2012 nicht anders angegeben ist, werden Drittanbieterinhalte, einschließlich der Probleme, die aus der Verwendung derartiger Drittanbieterinhalte mit Microsoft SQL Server 2012 entstehen, nicht vom Microsoft-Kundendienst unterstützt und können zu Datenverlust führen. Der Microsoft-Kundendienst bietet auch keinen Support für Datenbanken oder Anwendungen, die nicht dokumentierte Einstiegspunkte, wie beispielsweise nicht dokumentierte APIS, nutzen oder verwenden. Gleiches gilt auch für die folgenden und weitere hier nicht genannten Elemente: gespeicherte Prozeduren, erweiterte gespeicherte Prozeduren, Funktionen, Sichten, Tabellen, Spalten, Eigenschaften und Metadaten.

Server- und Datenbankupgrades auf zukünftige Versionen von Microsoft SQL Server 2012 für Anwendungen und Datenbanken, die nicht dokumentierte Einstiegspunkte nutzen und verwenden, funktionieren möglicherweise ebenfalls nicht und werden nicht unterstützt. Die Verwendung der in Microsoft SQL Server enthaltenen SQL Server-Funktionen und -Funktionen, die in der Dokumentation von Microsoft SQL Server 2012 nicht für Ihre Verwendung dokumentiert sind, wird nicht unterstützt und kann zu Datenverlust führen.


Installieren von Updates an der Eingabeaufforderung

[image]

Installieren von Updates an der Eingabeaufforderung
Siehe auch Feedback senden

Testen und ändern Sie die Installationsskripts, um die Anforderungen Ihrer Organisation zu erfüllen. Weitere Informationen über das Installieren von Updates auf einem SQL Server-Failovercluster finden Sie unter Anwenden eines SQL Server-Updates auf eine Failoverclusterinstanz in der Microsoft Knowledge Base.

Beispielsyntax zur Installation

Der Name des Updatepakets kann variieren und enthält möglicherweise Komponenten zu Sprache, Version und Prozessor. Anwenden eines Updates über eine Eingabeaufforderung. Dabei wird <package_name> mit dem Namen des Updatepakets ersetzt:

  • Aktualisieren Sie eine einzelne Instanz von SQL Server und aller freigegebenen Komponenten wie Integration Services und Verwaltungstools: Sie können entweder die Instanz mit dem InstanceName-Parameter oder dem InstanceID-Parameter angeben. Um eine vorbereitete Instanz von SQL Server zu aktualisieren, müssen Sie den InstanceID-Parameter "<package_name>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /InstanceName=MyInstance" oder "<package_name>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /InstanceID=<Instance ID>" angeben.

  • Setup ist in der Lage, die neuesten Produktupdates in die Installation des Hauptprodukts zu integrieren, sodass das Hauptprodukt und geeignete Updates gleichzeitig installiert werden. Sie können bei der Installation einer Datenbank-Modulinstanz vorsehen, dass das Produktupdate eingeschlossen wird: setup.exe /q /IAcceptSQLServerLicenseTerms /ACTION=PrepareImage /UpdateEnabled=True /UpdateSource=<Downloadpfad des Updates> /INSTANCEID=<Instance ID> /FEATURES=SQLEngine

  • Aktualisierung nur von freigegebenen SQL Server-Komponenten, wie z. B. Integration Services und Verwaltungstools: <package_name>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch

  • Aktualisieren aller Instanzen von SQL Server auf dem Computer und aller freigegebenen Komponenten, wie z. B. Integration Services und Verwaltungstools: <package_name>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /AllInstances

Entfernen eines Updates über eine Eingabeaufforderung. Dabei wird <package_name> mit dem Namen des Updatepakets ersetzt:

  • Entfernen eines Updates aus einer einzelnen Instanz von SQL Server und aus allen freigegebenen Komponenten, wie z. B. Integration Services und Verwaltungstools: <package_name>.exe /qs /IAcceptSQLServerLicenseTerms /Action=RemovePatch /InstanceName=MyInstance

  • Ausschließliches Entfernen eines Updates aus freigegebenen SQL Server-Komponenten, wie z. B. Integration Services und Verwaltungstools: <package_name>.exe /qs /Action=RemovePatch

    Hinweis Hinweis

    Mit dem Updateinstallationsprogramm wird sichergestellt, dass die freigegebenen Komponenten stets mindestens die Version der Instanz auf höchster Ebene aufweisen.

Unterstützte Befehlszeilenparameter

Wichtiger Hinweis Wichtig

Anmeldeinformationen sollten nach Möglichkeit zur Laufzeit angegeben werden. Wenn Sie Anmeldeinformationen in einer Skriptdatei speichern müssen, sollten Sie die Datei schützen, um nicht autorisierten Zugriff zu verhindern.

Option | Beschreibung
/? | Zeigt Hilfe zur unbeaufsichtigten Installation an der Eingabeaufforderung an.
/action=Patch or /action=RemovePatch | Gibt die Installationsaktion an: Patch oder RemovePatch.
/allinstances | Wendet das SQL Server-Update auf alle Instanzen von SQL Server und auf alle freigegebenen, nicht instanzabhängigen Komponenten von SQL Server an.
/instancename=InstanceName1 | Wendet das SQL Server-Update auf eine Instanz von SQL Server mit dem Namen InstanceName und auf alle freigegebenen, nicht instanzabhängigen Komponenten von SQL Server an.
/InstanceID=Inst1 | Wendet das SQL Server-Update auf eine Instanz von SQL Server Inst1 und auf alle freigegebenen, nicht instanzabhängigen Komponenten von SQL Server an.
/quiet | Führt Setup für das SQL Server-Update im unbeaufsichtigten Modus aus.
/qs | Zeigt nur das Statusdialogfeld in der Benutzeroberfläche an.
/UpdateEnabled | Gibt an, ob Produktupdates von SQL Server-Setup ermittelt und eingeschlossen werden sollen. Gültige Werte sind True und False oder 1 und 0. SQL Server-Setup schließt standardmäßig alle gefundenen Updates ein.
/UpdateSource | Gibt an, wo Produktupdates von SQL Server-Setup abgerufen werden sollen. Gültige Werte sind "MU" für die Suche in Microsoft Update, ein gültiger Ordnerpfad, ein relativer Pfad wie . \MyUpdates oder eine UNC-Freigabe. SQL Server-Setup durchsucht standardmäßig Microsoft Update oder einen Windows Update-Dienst über die Windows Server Update Services.
/IAcceptSQLServerLicenseTerms | Nur erforderlich, wenn der /Q-Parameter oder der /QS-Parameter für die unbeaufsichtigte Installation angegeben wird.

1 Sie können diesen Parameter nicht angeben, um ein Update auf eine vorbereitete Instanz von SQL Server anzuwenden. Sie müssen stattdessen den /instanceID-Parameter angeben.

Siehe auch

Konzepte

Übersicht über die SQL Server-Wartungsinstallation


Gewusst wie: Überprüfen der erfolgreichen Installation eines SQL Server-Updates

[image]

Gewusst wie: Überprüfen der erfolgreichen Installation eines SQL Server-Updates
Siehe auch Feedback senden

So überprüfen Sie die erfolgreiche Installation eines SQL Server-Updates

  • Überprüfen Sie, ob die SQL Server-Dienste online sind.

  • Überprüfen Sie die von der @@version-Abfrage zurückgegebenen Versionsinformationen.

Siehe auch

Konzepte

Übersicht über die SQL Server-Wartungsinstallation


Informationsquellen für SQL Server

[image]

Informationsquellen für SQL Server
Siehe auch Feedback senden

Es gibt drei Hauptquellen für Informationen von Microsoft zu SQL Server:

  • Die als lokale Sammlung der SQL Server-Onlinedokumentation installierte Dokumentation.

  • Die SQL Server-Sites im Microsoft Developer Network (MSDN) und TechNet.

  • Informationen zu SQL Server auf weiteren Microsoft-Websites.

Wenn Sie die gewünschten Informationen nicht in diesen Quellen finden, können Sie in den Foren und Newsgroups der SQL Server-Community Fragen stellen oder sich an den Microsoft-Support wenden.

SQL Server-Onlinedokumentation

Die SQL Server-Onlinedokumentation behandelt Konzepte und Prozeduren, die für die Verwendung von SQL Server erforderlich sind. Darüber hinaus enthält die Onlinedokumentation Referenzmaterial zu den Sprachen und Programmierschnittstellen für das Speichern, Abrufen, Erstellen von Berichten und Ändern von Daten mithilfe von SQL Server.

Es gibt folgende Möglichkeiten, um auf die Onlinedokumentation zuzugreifen:

  • Eine Kopie der Microsoft SQL Server 2012-Onlinedokumentation ist in der MSDN Library sowie in der TechNet Library im Internet veröffentlicht. Die Themen in diesen Kopien der SQL Server-Onlinedokumentation enthalten Kommentare aus der Community, z. B. Zusatzinformationen und Codebeispiele von anderen Kunden. Sie finden die MSDN Library-Version auf der Website der SQL Server 2008-Onlinedokumentation .

  • Sie können die SQL Server-Onlinedokumentation auf einem lokalen Computer mithilfe des Managers für die Hilfebibliothek installieren. Weitere Informationen finden Sie unter Hinzufügen oder Entfernen von Hilfeauflistungen.

Die Kopie der SQL Server-Onlinedokumentation in der MSDN Library und die Dateien der Onlinedokumentation, die mithilfe des Managers für die Hilfebibliothek aufgerufen werden können, werden aktualisiert, wenn von Microsoft ein Update für die SQL Server-Onlinedokumentation veröffentlicht wird.

Weitere Informationen zum Installieren und Zugreifen auf die Beispielanwendungen und Datenbanken finden Sie unter Samples and Sample Databases.

Informationen im MSDN und TechNet

MSDN (Microsoft Developer Network) stellt Online- und Offlinedienste bereit, durch die Entwickler beim Schreiben von Anwendungen mithilfe von Microsoft-Produkten und -Technologien unterstützt werden. Das Microsoft TechNet-Programm liefert umfassende technische Ressourcen, die IT-Experten dabei helfen, Microsoft-Lösungen effizient auszuwerten, bereitzustellen und zu unterstützen.

Auf mehreren MSDN- und TechNet-Websites werden für eine bestimmte Zielgruppe Links zu den SQL Server-Informationen angeboten, die für ihre Arbeit besonders relevant sind. Dazu gehören auch die Informationen in den MSDN- und TechNet-Kopien der SQL Server-Onlinedokumentation. Auf diesen Websites finden Sie auch Informationen, die über den Inhalt der SQL Server-Onlinedokumentation hinausgehen.

In der folgenden Tabelle werden diese Ressourcen und deren beabsichtigte Zielgruppen beschrieben.

Ressource | Zielgruppe
SQL Server Developer Center | Entwickler von Datenbank-, Berichtsystem- und Business Intelligence-Lösungen von SQL Server, die ihre Anwendungen und Websites für die Verwendung dieser Systeme entwerfen möchten.
Developer Center für Datenzugriff und -speicherung | Entwickler, deren Anwendungen und Websites Daten verwenden, die mit Produkten wie SQL Server und Access gespeichert wurden.
XML Developer Center | Entwickler von Websites und Anwendungen, deren Sites und Anwendungen XML für die Datenspeicherung und -bearbeitung verwenden.
SQL Server TechNet-Site | Administratoren und Operatoren, die Systeme planen, verwalten, und unterstützen, die SQL Server verwenden.

Zusätzliche Onlineinformationen

Auf diesen Microsoft-Websites sind zusätzliche SQL Server-Informationen verfügbar.

Ressource | Beschreibung
Microsoft SQL Server | Beinhaltet Produktinformationen, die eine Einschätzung von SQL Server als Datenspeicher- und Business Intelligence-Tool ermöglichen.
Microsoft Knowledge Base | Bietet ein durchsuchbares Repository mit Artikeln zu SQL Server, die vom Microsoft Support geschrieben wurden.
Microsoft Learning | Beschreibt Microsoft-Schulungen und -Zertifizierungen für SQL Server.
Microsoft Press | Enthält eine Liste von Büchern von Microsoft Press zu SQL Server.

Unterstützung durch Andere

Wenn Sie die gewünschten Informationen nicht in der Produktdokumentation oder im Web gefunden haben, können Sie in den Foren und Newsgroups der SQL Server-Community Fragen stellen. Sie können auch Hilfe vom Produktsupport anfordern.

Hinweis Hinweis

Stellen Sie bitte keine Fragen im Kommentarteil der Community am unteren Rand der SQL Server-Onlinedokumentationsthemen in der MSDN Library oder TechNet Library. Diese Abschnitte werden nicht nach Fragen durchsucht, und meist erhalten Sie dann keine Antwort. Stellen Sie Fragen in den Foren und Newsgroups der Community; dort werden sie von anderen Kunden gelesen, die Ihre Fragen beantworten können.

In der folgenden Tabelle finden Sie Links zu diesen Ressourcen und kurze Beschreibungen dazu.

Ressource | Beschreibung
SQL Server IT-Professional-Community | Bietet Links zu Newsgroups und Foren, die von der SQL Server-Community überwacht werden. Hier sind auch Community-Informationsquellen aufgeführt, z. B. Blogs und Websites. Die SQL Server-Community ist bei Problemen ausgesprochen hilfreich, obwohl die Beantwortung von Fragen nicht unbedingt sichergestellt ist.
SQL Server Developer Center-Community | Diese Site ist speziell auf Newsgroups, Foren und andere Communityressourcen ausgerichtet, die für Entwickler von SQL Server von Interesse sind.
Microsoft Hilfe und Support | Verwenden Sie diese Website, um sich mit einer Frage an einen Supportmitarbeiter von Microsoft zu wenden.

Jedes Microsoft-Produkt verfügt über einen Support-Lebenszyklus, der definiert, wie lange Sie für jede Version auf den Support zugreifen können. Der Microsoft-Support pflegt eine Website, die den Microsoft-Support-Lebenszyklus erklärt. Auf der Seite finden Sie Links zu anderen Seiten, die Informationen über die Verfügbarkeit von Support für Microsoft-Produkte geben. Weitere Informationen finden Sie unter Microsoft Support Lifecycle.

Siehe auch

Konzepte

Verwenden der Microsoft-Onlinedokumentation für SQL Server


Willkommen

[image]

Willkommen
Feedback senden

Anhand von Installationsregeln wird der Computer auf den Speicherort geprüft, an dem das Update installiert wird.


Lizenzbedingungen

[image]

Lizenzbedingungen
Feedback senden

Nehmen Sie auf der Seite mit den Lizenzbedingungen die Lizenzbedingungen für diese Version an.

Optionen

Um mit der Installation fortzufahren, müssen Sie die SQL Server-Lizenzbedingungen annehmen.

Mithilfe der Schaltfläche Drucken können Sie eine Kopie der Lizenzbedingungen für diese Version ausdrucken. Klicken Sie zum Beenden der Installation auf Abbrechen.


Funktionen auswählen

[image]

Funktionen auswählen
Feedback senden

Verwenden Sie die Seite Funktionsauswahl, um zu aktualisierende SQL Server-Komponenten und -Funktionen auszuwählen.

Optionen

Klicken Sie auf einen Funktionsnamen im linken Bereich, und zeigen Sie so die Sprache, das Betriebssystem, die Edition und die Statusdetails an.

Aktivieren Sie zum Aktualisieren einer Komponente oder einer Funktion das Kontrollkästchen neben dem Funktionsnamen. Deaktivieren Sie zum Ausschließen einer Komponente oder einer Funktion von diesem Update das Kontrollkästchen neben dem Funktionsnamen.

Es können mehrere Instanzen von SQL Server auf einem einzigen Computer zu unterschiedlichen Zeitpunkten aktualisiert werden, allerdings müssen alle Komponenten in einer Instanz von SQL Server gleichzeitig aktualisiert werden. Alle freigegebenen Komponenten, beispielsweise Arbeitsstationskomponenten, MSXML Parser, SQLXML, Abwärtskompatibilitätskomponenten und VSS Writer müssen aktualisiert werden.

Wenn eine Komponente nicht aktualisiert werden kann, wird eine Erläuterung im Bereich Details zur Verfügung gestellt.


Verwendete Dateien überprüfen

[image]

Verwendete Dateien überprüfen
Feedback senden

Verwenden Sie zum Vermeiden eines Neustarts von Windows nach dem Installieren von SQL Server-Updates die Seite Verwendete Dateien überprüfen zum Identifizieren von Vorgängen, die vom Setupprogramm für das SQL Server-Update benötigte Dateien blockieren.

Beenden Sie alle Anwendungen und Dienste, die Verbindungen mit den aktualisierten Instanzen von SQL Server herstellen. Dies schließt das Beenden von SQL Server Management Studio und SQL Server-Datentools (SSDT) ein.

Wenn vom Setup erkannt wird, dass Dateien während der Installation blockiert sind, müssen Sie den Computer möglicherweise nach dem Fertigstellen der Installation erneut starten. Gegebenenfalls werden Sie aufgefordert, den Computer neu zu starten. Wenn das Setupprogramm einen Dienst während der Installation beenden muss, wird der Dienst nach Abschluss der Installation neu gestartet.

Damit der Computer nach der Installation nicht neu gestartet werden muss, zeigt das Setup eine Liste der Prozesse an, die Dateien sperren. Beenden Sie die in der Liste aufgeführten Prozesse und Anwendungen. Klicken Sie dann auf Überprüfung aktualisieren, um die Überprüfung erneut auszuführen. Klicken Sie zum Beenden einer gerade ausgeführten Überprüfung auf Überprüfung beenden. Wenn keine blockierten Dateien gefunden wurden, ist die Tabelle leer. Klicken Sie auf Weiter, um den Vorgang fortzusetzen, wenn alle blockierten Vorgänge beendet wurden.

Die Informationen werden vom Setup in den Protokolldateien protokolliert. Weitere Informationen zum Anzeigen der Protokolldateien finden Sie unter Vorgehensweise: Anzeigen der Setup-Protokolldateien von SQL Server und Vorgehensweise: Lesen einer Setupprotokolldatei von SQL Server.

Die Protokolldatei enthält die folgenden Informationen:

  • Name des Prozesses

  • Name der SQL Server-Funktion

  • Prozesstyp

  • Konto, unter dem der Prozess ausgeführt wird

  • Prozess-ID

  • Name der gesperrten Datei

Name | Beschreibung
Prozess | Zeigt den vollständigen Namen des Prozesses an, von dem die zu aktualisierenden Dateien verwendet werden.
Typ | Zeigt den Typ des Prozesses an.
Konto | Zeigt das Konto an, unter dem der Prozess ausgeführt wird.
Prozess-ID | Zeigt die Prozess-ID an.


Das Update kann jetzt ausgeführt werden

[image]

Das Update kann jetzt ausgeführt werden
Feedback senden

Auf der Seite Zusammenfassung können Sie die Änderungen bestätigen, die auf die Instanz von SQL Server angewendet werden sollen. Klicken Sie auf Installieren, um mit der Installation fortzufahren.


Updatestatus

[image]

Updatestatus
Feedback senden

Auf der Seite Installationsstatus können Sie Setup beim Anwenden des Updates auf die Instanz von SQL Server und der zugehörigen Komponenten überwachen.

Optionen

In der Tabelle werden der Produktname von SQL Server, dessen Instanznamen und der Installationsstatus zur Verfügung gestellt.


Abgeschlossen

[image]

Abgeschlossen
Feedback senden

Auf der Seite Abgeschlossen wird der Installationsstatus bestätigt.