Vue d'ensemble de la documentation d'installation de SQL Server

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Vue d'ensemble de la documentation d'installation de SQL Server
Envoyer des commentaires

La documentation du programme d'installation de SQL Server est disponible sur le support d'installation et en ligne.

Documentation disponible pendant l'installation

Lors de l'installation de SQL Server, cliquez sur le bouton Aide dans la page Assistant Installation ou appuyez sur la touche F1 de votre clavier pour obtenir immédiatement les informations nécessaires pour terminer l'opération.

Vue d'ensemble des rubriques d'installation de SQL Server

Que vous utilisiez l'Assistant Installation de SQL Server ou l'invite de commandes pour installer SQL Server, vous pouvez vous préparer en lisant les sections suivantes :

  • Planification d'une installation SQL Server.

    Explique comment préparer une installation de SQL Server.

  • Installer SQL Server 2012

    Décrit les options d'installation de SQL Server.

  • Installer les fonctionnalités BI de SQL Server 2012

    Décrit les options d'installation de SQL Server qui font partie de la plateforme BI de Microsoft, notamment Analysis Services, Integration Services, Reporting Services, ainsi que plusieurs applications clientes servant à créer ou utiliser des données analytiques.

  • Mettre à niveau vers SQL Server 2012

    Décrit les options de mise à niveau vers SQL Server.

Si vous installez un cluster de basculement SQL Server, examinez les éléments suivants :

  • Mise en route avec le clustering de basculement SQL Server.

  • Avant l'installation du clustering de basculement.

Image du pied de page
Transmettre des commentaires sur cette rubrique à Microsoft

© 2012 Microsoft Corporation. Tous droits réservés.


À propos des termes du contrat de licence SQL Server

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

À propos des termes du contrat de licence SQL Server
Voir aussi Envoyer des commentaires

Les termes de la Licence d'utilisation du logiciel Microsoft sont copiés vers l'ordinateur local lorsque SQL Server est installé. Lorsque plusieurs instances des mêmes édition et langue de SQL Server sont installées sur le même ordinateur, une seule copie du contrat de licence s'applique à toutes les instances de cette édition et de cette langue. Les fichiers sont enregistrés dans : %ProgramFiles%\Microsoft SQL Server\110\License Terms\ ou %ProgramFiles(x86)%\Microsoft SQL Server\110\License Terms\.

Lorsque plusieurs instances des mêmes édition et langue de SQL Server sont installées sur le même ordinateur, une seule copie du contrat de licence s'applique à toutes les instances de cette édition et de cette langue.

Le nom de fichier des termes du contrat de licence indique l'édition de SQL Server ainsi que l'édition linguistique de SQL Server : Par exemple :

  • License_DEV_ENU.txt pour SQL Server Developer, édition en langue anglaise.

  • License_STD_ITA.txt pour SQL Server Standard, édition en langue italienne.

  • License_UA_JPN.txt pour le Conseiller de mise à niveau SQL Server, édition en langue japonaise.

  • License_SQLNCLI_ENU.txt pour SQL Server Native Client, édition en langue anglaise.

  • License_SQLXML4_KOR.txt pour SQLXML, édition en langue coréenne.

  • License_SQLBI.rtf pour SQL Server édition Business Intelligence.

  • License_ENTCORE.rtf pour SQL Server Enterprise : contrat de licence selon le nombre de cœurs.

  • License_ENT.rtf pour SQL Server Enterprise : contrat de licence Serveur/CAL.

Les segments de noms de fichiers suivants sont utilisés pour identifier les éditions de SQL Server :

  • ENT – Enterprise Edition : Licences Serveur/licence d'accès client (CAL)

  • ENTCORE – Enterprise Edition : contrat de licence selon le nombre de cœurs

  • BI – Business Intelligence

  • DEV – Developer

  • STD – Standard

  • WEB – Web

  • EXPR – Express

Les segments de noms de fichiers suivants sont utilisés pour identifier les langues correspondantes de SQL Server :

  • ENU - Anglais

  • JPN - Japonais

  • FRA - Français

  • ITA - Italien

  • KOR - Coréen

  • DEU - Allemand

  • ESN - Espagnol

  • CHS - Chinois simplifié

  • CHT - Chinois traditionnel

  • PTB - Portugais (Brésil)

  • RUS - Russe

Options de licences de SQL Server

Pour plus d'informations sur les prix et les options de licences de SQL Server, consultez le site Web Microsoft SQL Server (http://go.microsoft.com/fwlink/?LinkId=190955).

Voir aussi

Concepts

Considérations relatives aux licences de SQL Server
Déclaration de confidentialité de Microsoft SQL Server
Notice légale pour documentation


Considérations relatives aux licences de SQL Server

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Considérations relatives aux licences de SQL Server
Voir aussi Envoyer des commentaires

Pour plus d'informations sur les options de licences de SQL Server, consultez ce site Web de Microsoft SQL Server.

Voir aussi

Référence

À propos des termes du contrat de licence SQL Server

Concepts

Déclaration de confidentialité de Microsoft SQL Server
Notice légale pour documentation


Notice légale pour documentation

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Notice légale pour documentation
Envoyer des commentaires

Ce document est fourni « en l'état ». Les informations et les opinions exprimées dans ce document, y compris les adresses URL et les autres références à des sites Internet, peuvent faire l'objet de modifications sans préavis. Vous assumez tous les risques liés à son utilisation.

Certains exemples mentionnés dans ce document ne sont fournis qu'à titre indicatif et sont fictifs. Toute ressemblance ou similitude avec des éléments réels est purement fortuite et involontaire.

Ce document ne vous concède aucun droit de propriété intellectuelle portant sur les produits Microsoft. Vous pouvez copier et utiliser ce document à titre de référence pour un usage interne.

© 2012 Microsoft. Tous droits réservés.

Microsoft, Active Directory, ActiveX, Bing Maps, Excel, IntelliSense, MSDN, MS-DOS, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual Studio, Windows, Windows NT, Windows Server et Windows Vista sont des marques du groupe Microsoft. SAP NetWeaver est une marque déposée de SAP AG en Allemagne et dans plusieurs autres pays. Toutes les autres marques sont la propriété de leurs propriétaires respectifs.

Stratégie de documentation pour le support et la mise à niveau de SQL Server

La documentation de Microsoft SQL Server 2012 inclut la documentation en ligne Microsoft de Microsoft SQL Server 2012, la documentation d'installation, la documentation de référence du développeur, les didacticiels, les fichiers Lisez-moi, les documents relatifs aux problèmes connus, les exemples de code, les exemples de bases de données et les articles de la Base de connaissances publiés par Microsoft – l'ensemble de ces éléments recouvre le contenu relatif aux fonctions et fonctionnalités SQL Server. Cette stratégie de support et de mise à niveau s'applique à la totalité de la documentation Microsoft SQL Server 2012, y compris aux fichiers Lisez-moi des versions et Service Packs Microsoft SQL Server 2012 ; un fichier Lisez-moi est considéré comme une extension de la documentation en ligne de Microsoft SQL Server 2012.

Un exemple présenté dans cette documentation sert principalement à illustrer un concept ou l'utilisation raisonnable d'une instruction ou d'une clause particulière. La plupart des exemples ne reprennent pas la totalité du code normalement utilisé dans un système en production puisque certaines parties de la validation des données et de la gestion des erreurs sont retirées pour mettre l'accent sur un concept ou une instruction particulière. Aucun support technique n'est disponible pour ces exemples, ni pour le code source fourni.

Dans certains cas, une fonctionnalité particulière de Microsoft SQL Server 2012 n'a pas été suffisamment testée ou développée, et n'est pas destinée à votre utilisation. De telles fonctionnalités se retrouvent alors sous forme d'espaces réservés. Par conséquent, certaines fonctionnalités incluses dans le logiciel ne sont pas documentées. Les fonctionnalités qui ne sont pas documentées ou qui sont incluses comme notation pour une utilisation interne de Microsoft ne sont pas destinées à votre utilisation et ne sont pas prises en charge par le support technique de Microsoft. Sauf spécification contraire de la documentation de Microsoft SQL Server 2012, le contenu tiers, y compris les problèmes qui résultent de son utilisation avec Microsoft SQL Server 2012, n'est pas pris en charge par le support technique de Microsoft et peut également entraîner une perte des données. Le support technique de Microsoft n'assure pas la prise en charge des bases de données ou des applications qui exploitent ou utilisent les points d'entrée non documentés comme les API non documentées, notamment sans que la liste soit limitative, les éléments suivants : procédures stockées, procédures stockées étendues, fonctions, vues, tables, colonnes, propriétés ou métadonnées.

Les mises à niveau de serveur et de base de données vers les versions ultérieures de Microsoft SQL Server 2012 pour les applications et les bases de données qui exploitent et utilisent des points d'entrée non documentés (qui peuvent ne pas fonctionner) ne sont pas prises en charge. L'utilisation des fonctionnalités SQL Server et de celles incluses dans Microsoft SQL Server sans être documentées dans la documentation Microsoft SQL Server 2012 destinée à votre utilisation n'est pas prise en charge et peut provoquer une perte des données.


Déclaration de confidentialité de Microsoft SQL Server

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Déclaration de confidentialité de Microsoft SQL Server
Envoyer des commentaires

Pour plus d'informations sur les composants de la collecte de données utilisateur de Microsoft SQL Server 2012, consultez la Déclaration de confidentialité de SQL Server


Emplacements des fichiers pour les instances par défaut et les instances nommées de SQL Server

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Emplacements des fichiers pour les instances par défaut et les instances nommées de SQL Server
Voir aussi Envoyer des commentaires

Une installation de SQL Server se compose d'une ou de plusieurs instances distinctes. Une instance, qu'elle soit par défaut ou nommée, possède son propre jeu de fichiers programmes et de fichiers de données, ainsi qu'un ensemble de fichiers communs partagés entre toutes les instances de SQL Server présentes sur l'ordinateur.

Pour une instance SQL Server qui inclut Moteur de base de données, Analysis Services et Reporting Services, chaque composant a un jeu complet de fichiers de données et de fichiers exécutables, ainsi que des fichiers communs partagés par tous les composants.

Pour isoler l'emplacement d'installation de chaque composant, un ID d'instance unique est généré pour chaque composant d'une instance SQL Server donnée.

Important Important

Les fichiers programmes et les fichiers de données ne peuvent pas être installés sur un lecteur de disque amovible, dans un système de fichiers utilisant la compression, dans un répertoire où figurent des fichiers système ni sur des lecteurs partagés sur une instance de cluster de basculement.

Vous ne devez supprimer ni les répertoires suivants ni leur contenu : Binn, Data, Ftdata, HTML ou 1033. Si besoin est, vous pouvez supprimer d'autres répertoires mais il est possible que vous ne puissiez pas récupérer certaines fonctionnalités ou données sans désinstaller puis réinstaller SQL Server. Ne supprimez pas et ne modifiez pas les fichiers .htm se trouvant dans le répertoire HTML. Ils sont nécessaires pour que les outils de SQL Server fonctionnent correctement.

Fichiers partagés pour toutes les instances SQL Server

Les fichiers communs utilisés par toutes les instances d'un même ordinateur sont installés dans le dossier <lecteur>:\Program Files\Microsoft SQL Server\110\, où <drive> correspond à la lettre du lecteur sur lequel les composants sont installés. La valeur par défaut est généralement le lecteur C.

Emplacements des fichiers et mappage du Registre

Au cours de l'installation de SQL Server, un ID d'instance est généré pour chaque composant serveur. Les composants de cette version SQL Server sont Moteur de base de données, Analysis Services et Reporting Services.

L'ID d'instance par défaut est construit à l'aide du format suivant :

  • MSSQL pour le Moteur de base de données, suivi du numéro de version principale, puis d'un trait de soulignement et du numéro de version secondaire, le cas échéant, puis d'un point et du nom de l'instance.

  • MSAS pour Analysis Services, suivi du numéro de version principale, puis d'un trait de soulignement et du numéro de version secondaire, le cas échéant, puis d'un point et du nom de l'instance.

  • MSRS pour Reporting Services, suivi du numéro de version principale, puis d'un trait de soulignement et du numéro de version secondaire, le cas échéant, puis d'un point et du nom de l'instance.

Voici quelques exemples d'ID d'instance par défaut dans cette version de Microsoft SQL Server 2012 :

  • MSSQL11.MSSQLSERVER pour une instance par défaut de Microsoft SQL Server 2012.

  • MSAS11.MSSQLSERVER pour une instance par défaut Analysis Services.

  • MSSQL11.MyInstance pour une instance nommée de Microsoft SQL Server 2012 intitulée « MyInstance ».

La structure de répertoire pour une instance nommée de Microsoft SQL Server 2012 incluant le Moteur de base de données et Analysis Services, intitulée « MyInstance » et installée sur les répertoires par défaut, se présenterait de la façon suivante :

  • C:\Program Files\Microsoft SQL Server\MSSQL11.MyInstance\

  • C:\Program Files\Microsoft SQL Server\MSASSQL11.MyInstance\

Vous pouvez spécifier n'importe quelle valeur pour l'ID d'instance, mais évitez les caractères spéciaux et les mots clés réservés. Pour plus d'informations, consultez Reserved Keywords (Setup).

Vous pouvez spécifier un ID d'instance non défini par défaut pendant l'installation de SQL Server. Si l'utilisateur choisit de changer de répertoire d'installation par défaut, un <chemin personnalisé>\Microsoft SQL Server est utilisé à la place de <Program Files>\Microsoft SQL Server. Notez que les ID d'instance qui commencent avec un trait de soulignement (_) ou qui contiennent le signe dièse (#) ou le symbole dollar ($) ne sont pas pris en charge.

Remarque Remarque

Integration Services et les composants clients ne sont pas dépendants d'une instance et, par conséquent, ne se voient pas attribuer d'ID d'instance. Par défaut, les composants indépendants des instances sont installés sur un répertoire unique : <lecteur>:\Program Files\Microsoft SQL Server\110\. La modification du chemin d'installation d'un composant partagé affecte également les autres composants partagés. En effet, les installations ultérieures placent des composants ne prenant pas en charge les instances dans le même répertoire que celui prévu par l'installation d'origine.

SQL ServerAnalysis Services est le seul composant SQL Server qui prend en charge l'attribution d'un nouveau nom à une instance après l'installation. Si une instance de Analysis Services est renommée, l'ID d'instance ne change pas. Une fois l'attribution du nouveau nom de l'instance terminée, les répertoires et les clés de Registre continuent à utiliser l'ID d'instance créé pendant l'installation.

La ruche du Registre est créée sous HKLM\Software\Microsoft\Microsoft SQL Server\<Instance_ID> pour les composants qui prennent les instances en charge. Par exemple,

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL11.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSASSQL11.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.110

Le Registre maintient également le mappage d'un ID d'instance sur un nom d'instance. Le mappage de l'ID d'instance sur le nom d'instance se maintient comme suit :

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\SQL] "NomInstance"="MSSQL11"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\OLAP] "NomInstance"="MSASSQL11"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\RS] "NomInstance"="MSRSSQL11"

Spécification des chemins d'accès des fichiers

Pendant l'installation, vous pouvez modifier le chemin d'installation des fonctionnalités suivantes :

Ce chemin d'installation s'affiche uniquement dans le programme d'installation pour les fonctionnalités dotées d'un dossier de destination configurable par l'utilisateur.

Composant | Chemin d'accès par défaut1, 2 | Chemin configurable ou fixe3
Composants serveur du Moteur de base de données | \Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\ | Configurable
Fichiers de données du Moteur de base de données | \Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\ | Configurable
Serveur Analysis Services | \Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\ | Configurable
Fichiers de données Analysis Services | \Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\ | Configurable
Serveur de rapports Reporting Services | \Program Files\Microsoft SQL Server\MSRS11.<InstanceID>\Reporting Services\ReportServer\Bin\ | Configurable
Gestionnaire de rapports Reporting Services | \Program Files\Microsoft SQL Server\MSRS11.<ID d'instance>\Reporting Services\ReportManager\ | Chemin fixe
Integration Services | <Répertoire d'installation>\110\DTS\ | Configurable4
Master Data Services | <Répertoire d'installation>\110\Master Data Services | Configurable4
Composants clients | <Répertoire d'installation>\110\Tools\ | Configurable4
Objets COM côté serveur et de réplication | <lecteur>:\Program Files\Microsoft SQL Server\110\COM\5 | Chemin fixe
DLL des composants Integration Services pour le moteur d'exécution de transformation des données, le moteur pipeline de transformation des données et l'utilitaire d'invite de commandes dtexec | <lecteur>:\Program Files\Microsoft SQL Server\110\DTS\Binn | Chemin fixe
DLL qui assurent la prise en charge de connexions managées pour Integration Services | <lecteur>:\Program Files\Microsoft SQL Server\110\DTS\Connections | Chemin fixe
DLL pour chaque type d'énumérateur que Integration Services prend en charge | <lecteur>:\Program Files\Microsoft SQL Server\110\DTS\ForEachEnumerators | Chemin fixe
Service SQL Browser SQL Server, fournisseurs WMI | <lecteur>:\Program Files\Microsoft SQL Server\110\Shared\ | Chemin fixe
Composants qui sont partagés entre toutes les instances SQL Server | <lecteur>:\Program Files\Microsoft SQL Server\110\Shared\ | Chemin fixe

1Vérifiez que le dossier \Program Files\Microsoft SQL Server\ est protégé par des autorisations limitées.

2Le lecteur par défaut de ces emplacements est systemdrive, en général le lecteur C.

3Les chemins d'installation des composants enfants sont déterminés par le chemin d'installation de la fonctionnalité parente.

4Un chemin d'installation unique est partagé par Integration Services et les composants clients. La modification du chemin d'installation d'un composant affecte également les autres composants. En effet, les installations ultérieures placent les composants dans l'emplacement prévu par l'installation d'origine.

5Ce répertoire est utilisé par toutes les instances de SQL Server sur un ordinateur. Si vous effectuez une mise à jour sur l'une des instances situées sur l'ordinateur, toute modification apportée aux fichiers de ce dossier affecte toutes les instances de l'ordinateur. Lors de l'ajout de fonctionnalités à une installation existante, vous ne pouvez ni modifier l'emplacement d'une fonctionnalité précédemment installée, ni spécifier l'emplacement d'une nouvelle fonctionnalité. Vous devez soit installer les fonctionnalités supplémentaires dans les répertoires déjà établis par le programme d'installation, soit désinstaller et réinstaller le produit.

Remarque Remarque

Pour les configurations en cluster, vous devez sélectionner un lecteur local disponible sur chaque nœud du cluster.

Lorsque, pendant l'installation, vous indiquez un chemin d'installation pour les composants serveur ou les fichiers de données, le programme d'installation utilise l'ID de l'instance, en plus de l'emplacement spécifié pour les fichiers programmes et les fichiers de données. Le programme d'installation n'utilise pas l'ID d'instance pour les outils et les autres fichiers partagés. S'il ne l'utilise pas non plus pour les fichiers programmes et les fichiers de données de Analysis Services, il l'utilise en revanche pour le référentiel de Analysis Services.

Si vous définissez le chemin d'installation de la fonctionnalité du Moteur de base de données, le programme d'installation de SQL Server utilise ce chemin comme répertoire racine de tous les dossiers spécifiques à l'instance pour cette installation, y compris les fichiers de données SQL. Dans ce cas, si vous définissez comme racine « C:\Program Files\Microsoft SQL Server\MSSQL11\MSSQL\ », les répertoires spécifiques à l'instance sont ajoutés à la fin du chemin.

Les clients qui choisissent d'utiliser la fonctionnalité de mise à niveau USESYSDB dans l'Assistant Installation de SQL Server (mode d'interface utilisateur du programme d'installation) peuvent aisément se trouver dans une situation où le produit est installé dans une structure de dossiers récursive. Par exemple, <SQLProgramFiles>\MSSQL11\MSSQL\MSSQL11\MSSQL\Data\. Pour utiliser la fonctionnalité USESYSDB, il est donc conseillé de définir un chemin d'installation pour la fonctionnalité fichiers de données SQL au lieu de la fonctionnalité Moteur de base de données.

Remarque Remarque

Les fichiers de données se situent généralement dans un répertoire enfant nommé « Data ». Par exemple, spécifiez C:\Program Files\Microsoft SQL Server\MSSQL11\ comme chemin d'accès racine au répertoire de données des bases de données système durant la mise à niveau lorsque les fichiers de données se trouvent sous C:\Program Files\Microsoft SQL Server\MSSQL11\MSSQL\Data.

Voir aussi

Référence

Configuration du moteur de base de données – Répertoires de données
Configuration de Analysis Services – Répertoires de données


Afficher et lire les fichiers journaux d'installation de SQL Server

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Afficher et lire les fichiers journaux d'installation de SQL Server
Voir aussi Envoyer des commentaires

Chaque fois que le programme d'installation est exécuté, des fichiers journaux sont créés dans un nouveau dossier de journal horodaté à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\. Le format du nom du dossier de journal horodaté est AAAAMMJJ_hhmmss. Lorsque le programme d'installation est exécuté en mode sans assistance, les journaux sont créés à l'emplacement % temp%\sqlsetup*.log. Tous les fichiers du dossier de journal sont archivés dans le fichier Log*.cab dans leur dossier de journal respectif.

Une demande d'Installation typique passe par trois phases d'exécution :

  1. Texte de règles globales

  2. Mise à jour du composant

  3. Action demandée par l'utilisateur

Dans chaque phase, le programme d'installation génère des journaux résumés et détaillés, ainsi que des journaux supplémentaires si besoin est. Le programme d'installation est appelé au moins trois fois par action d'installation demandée par l'utilisateur.

Les fichiers de banque de données contiennent un instantané de l'état de tous les objets de configuration qui sont suivis par le processus d'installation et qui sont utiles pour réparer les erreurs de configuration. Des vidages de fichiers XML sont créés pour les objets de banque de données pour chaque phase d'exécution. Ils sont enregistrés dans leur propre sous-dossier de journal sous le dossier de journal horodaté, comme suit :

  • Datastore_GlobalRules

  • Datastore_ComponentUpdated

  • Datastore

Les sections suivantes décrivent les fichiers journaux d'installation de SQL Server.

Texte de résumé

Vue d'ensemble

Ce fichier montre les composants SQL Server détectés au cours de l'installation, l'environnement du système d'exploitation, les valeurs des paramètres de ligne de commande (si elles sont spécifiées) et l'état d'ensemble de chaque fichier MSI/MSP exécuté.

Le journal comprend les sections suivantes :

  • un résumé d'ensemble de l'exécution ;

  • les propriétés et la configuration de l'ordinateur sur lequel le programme d'installation de SQL Server a été exécuté ;

  • les fonctionnalités du produit SQL Server précédemment installées sur l'ordinateur ;

  • la description des propriétés de la version d'installation et du package d'installation ;

  • les paramètres d'entrée d'exécution fournis au cours de l'installation ;

  • l'emplacement du fichier de configuration ;

  • les détails des résultats d'exécution ;

  • les règles globales ;

  • les règles spécifiques au scénario d'installation ;

  • les règles ayant échoué ;

  • l'emplacement du fichier du rapport de règles.

Emplacement

Il se trouve à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\.

Pour trouver les erreurs dans le fichier texte résumé, recherchez les mots clés « error » ou « failed » dans le fichier.

Summary_engine-base_YYYYMMDD_HHMMss.txt

Vue d'ensemble

Le fichier de base summary_engine est semblable au fichier résumé et est généré au cours du flux de travail principal.

Emplacement

Il se trouve à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMJJ_HHMM>\.

Summary_engine-base_YYYYMMDD_HHMMss_ComponentUpdate.txt

Vue d'ensemble

Le fichier journal résumé de mise à jour des composants est semblable au fichier résumé et est généré au cours du flux de travail de mise à jour des composants.

Emplacement

Il se trouve à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMJJ_HHMM>\.

Summary_engine-base_<VersionNumber>MMDD_HHMMss_GlobalRules.txt

Vue d'ensemble

Le fichier journal résumé des règles globales est semblable au fichier résumé généré au cours du flux de travail des règles globales.

Emplacement

Il se trouve à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMJJ_HHMM>\.

Detail.txt

Vue d'ensemble

Detail.txt est généré pour le flux de travail principal, par exemple l'installation ou la mise à niveau, et fournit les détails de l'exécution. Les journaux dans le fichier sont générés en fonction de l'heure à laquelle chaque action pour l'installation a été appelée, et indiquent l'ordre dans lequel les actions ont été exécutées et leurs dépendances.

Emplacement

Il se trouve à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup.

Bootstrap\Log\<AAAAMMJJ_HHMM>\Detail.txt.

Si une erreur se produit au cours du processus d'installation, l'exception ou l'erreur est journalisée à la fin de ce fichier. Pour trouver les erreurs dans ce fichier, examinez d'abord la fin du fichier, puis lancez une recherche sur les mots clés « error » ou « exception » dans le fichier.

Detail_ComponentUpdate.txt

Vue d'ensemble

Le fichier Detail_ComponentUpdate.txt est généré pour le flux de travail de mise à jour des composants et est semblable au fichier Detail.txt.

Emplacement

Il se trouve à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMJJ_HHMM>\.

Detail_GlobalRules.txt

Vue d'ensemble

Le fichier Detail_GlobalRules.txt est généré pour l'exécution des règles globales et est semblable au fichier Detail.txt.

Emplacement

Il se trouve à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMJJ_HHMM>\.

Fichiers journaux MSI

Vue d'ensemble

Les fichiers journaux MSI fournissent des détails sur le processus du package d'installation. Ils sont générés par le programme MSIEXEC lors de l'installation du package spécifié.

Types de fichiers journaux MSI :

  • <Fonctionnalité>_<Architecture>_<Interation>.log

  • <Fonctionnalité>_<Architecture>_<Langue>_<Interation>.log

  • <Fonctionnalité>_<Architecture>_<Interation>_<Flux de travail>.log

Emplacement

Les fichiers journaux MSI se trouvent à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMJJ_HHMM>\<Nom>.log.

À la fin du fichier se trouve un résumé de l'exécution qui indique l'état de réussite ou d'échec et les propriétés. Pour trouver l'erreur dans le fichier MSI, recherchez « value 3 ». Les erreurs se trouvent généralement à proximité de cette chaîne.

ConfigurationFile.ini

Vue d'ensemble

Le fichier de configuration contient les paramètres d'entrée fournis au cours de l'installation. Vous pouvez l'utiliser pour redémarrer l'installation sans entrer les paramètres manuellement. Toutefois, les mots de passe pour les comptes, PID et certains paramètres ne sont pas enregistrés dans le fichier de configuration. Les paramètres peuvent être soit ajoutés au fichier, soit fournis à l'aide de la ligne de commande ou de l'interface utilisateur du programme d'installation. Pour plus d'informations, consultez Installer SQL Server 2012 à l'aide d'un fichier de configuration (http://go.microsoft.com/fwlink/?LinkId=231296).

Emplacement

Il se trouve à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMJJ_HHMM>\.

SystemConfigurationCheck_Report.htm

Vue d'ensemble

Le rapport de vérification de la configuration du système contient une brève description de chaque rôle exécuté et de l'état d'exécution.

Emplacement

Il se trouve à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMJJ_HHMM>\.

Voir aussi

Concepts

Dépannage d'une installation de SQL Server


Dépannage d'une installation de SQL Server

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Dépannage d'une installation de SQL Server
Voir aussi Envoyer des commentaires

Pour afficher des informations de dépannage pour les problèmes d'installation et de mise à niveau, consultez le Fichier Lisez-moi de SQL Server (http://go.microsoft.com/fwlink/?LinkId=196910).

Voir aussi

Concepts

Afficher et lire les fichiers journaux d'installation de SQL Server


Guide de référence de l'interface utilisateur du programme d'installation de SQL Server

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Guide de référence de l'interface utilisateur du programme d'installation de SQL Server
Envoyer des commentaires

Cette section décrit les options d'installation proposées par l'Assistant Installation de SQL Server.


Accepter les termes du contrat de licence

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Accepter les termes du contrat de licence
Voir aussi Envoyer des commentaires

Utilisez la page Accepter les termes du contrat de licence de l'Assistant Installation de SQL Server pour accepter les termes du contrat de licence de cette version de SQL Server.

Vous pouvez imprimer le contrat de licence ou le copier dans le Presse-papiers. Pour continuer, acceptez le contrat de licence, puis cliquez sur Suivant. Pour quitter l'installation, cliquez sur Annuler.

Création de rapports sur l'utilisation des fonctionnalités

Si vous activez la création de rapports sur l'utilisation des fonctionnalités, SQL Server est configuré pour envoyer régulièrement un rapport à Microsoft. Ces rapports incluent des informations sur votre configuration matérielle et sur la façon dont vous utilisez SQL Server et les composants. Microsoft utilise les données sur l'utilisation des fonctionnalités pour améliorer les composants SQL Server. Les composants suivants font partie des composants SQL Server analysés :

  • Moteur de base de données

  • Analysis Services

  • Reporting Services

  • Integration Services

  • Réplication

  • Outils de données SQL Server (SSDT)

  • Programme d'installation de SQL Server

Les informations sur l'utilisation des fonctionnalités sont envoyées à Microsoft, puis stockées avec un accès limité.

Pour désactiver la création de rapports sur l'utilisation des fonctionnalités une fois l'installation terminée, utilisez l'outil Rapports d'erreurs et d'utilisation SQL Server dans le menu Outils de configuration de SQL Server.

Pour les actions du programme d'installation, telles que l'installation, la mise à niveau, la réparation, entre autres, les informations sont recueillies et téléchargées uniquement pendant l'exécution du programme d'installation

Pour tous les autres composants SQL Server, les informations sont recueillies une fois par jour pour toutes les instances activées de SQL Server. Par défaut, la collecte est effectuée à minuit afin de réduire la charge sur le serveur. Si vous souhaitez changer l'heure de la collecte, vous pouvez modifier manuellement la clé du Registre concernée. Chaque instance de SQL Server possède sa propre clé de Registre :

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL11.<INSTANCEID>\CPE\TimeofReporting

La valeur de cette clé de Registre inclut l'heure de la collecte ainsi que le nombre de minutes qui s'écoulent à partir de 00:00 (minuit). Par exemple, la valeur 60 fixe l'exécution de la collecte à 1:00 a.m., la valeur 1200 fixe l'exécution de la collecte à 8:00 p.m., et ainsi de suite.

Voir aussi

Référence

À propos des termes du contrat de licence SQL Server


Ajouter un nœud de cluster de basculement SQL Server

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Ajouter un nœud de cluster de basculement SQL Server
Voir aussi Envoyer des commentaires

Le programme d'installation de SQL Server valide la configuration de votre ordinateur avant la fin de l'opération d'installation. Lors de l'exécution du programme d'installation de SQL Server, l'outil d'analyse de configuration système (SCC) analyse l'ordinateur sur lequel SQL Server sera installé. L'outil SCC recherche toute anomalie susceptible d'empêcher une installation correcte de SQL Server. Avant que le programme d'installation ne démarre l'Assistant Installation de SQL Server, le SCC extrait l'état de chaque élément. Puis, il compare le résultat avec les conditions requises et fournit une aide pour la suppression des problèmes importants.

La vérification de la configuration du système génère un rapport qui contient une brève description de chaque règle exécutée et de l'état d'exécution. Le rapport de contrôle de configuration du système se trouve à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Avant d'exécuter l'opération d'installation, examinez les rubriques suivantes :

  1. Configurations matérielle et logicielle requises pour l'installation de SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Fonctionnalités prises en charge par les éditions de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considérations sur la sécurité pour une installation de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versions linguistiques locales dans SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Autres références :

  1. Mises à niveau de la version et de l'édition prises en charge(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Avant l'installation du clustering de basculement(http://go.microsoft.com/fwlink/?LinkId=235034)

Voir aussi

Référence

Règles de support du programme d'installation


Configuration Analysis Services – Mise en service de compte

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Configuration Analysis Services – Mise en service de compte
Voir aussi Envoyer des commentaires

Utilisez cette page pour définir le mode serveur et pour accorder des autorisations administratives aux utilisateurs ou services qui requièrent un accès non restreint à Analysis Services. Le programme d'installation n'ajoute pas automatiquement le groupe Windows local BUILTIN\Administrateurs au rôle des administrateurs de serveur Analysis Services de l'instance que vous installez. Si vous souhaitez ajouter le groupe Administrateurs local au rôle des administrateurs de serveur, vous devez spécifier explicitement ce groupe.

Si vous installez PowerPivot pour SharePoint, vous devez accorder des autorisations administratives aux administrateurs de batterie de serveurs SharePoint ou aux administrateurs de service qui sont responsables d'un déploiement de PowerPivot dans une batterie de serveurs SharePoint Server 2010. Pour plus d'informations sur les conditions requises pour l'installation du Service PowerPivot et la configuration des comptes de service, consultez Installer PowerPivot pour SharePoint.

Options

Mode serveur - Le mode serveur spécifie le type des bases de données Analysis Services qui peuvent être déployées sur le serveur. Les modes serveur sont déterminés pendant l'installation et ne peuvent pas être modifiés par la suite. Tous les modes s'excluent mutuellement, ce qui signifie que vous aurez besoin de deux instances d'Analysis Services, chacune configurée pour un mode différent, pour prendre en charge à la fois les solutions de modèle tabulaire et OLAP classiques.

Spécifier les administrateurs - Vous devez spécifier au moins un administrateur de serveur pour l'instance de SQL Server. Les utilisateurs ou groupes que vous spécifiez deviendront membres du rôle des administrateurs de serveur de l'instance Analysis Services que vous installez. Ceux-ci doivent être des comptes d'utilisateur de domaine Windows dans le même domaine que l'ordinateur sur lequel vous installez le logiciel.

Remarque Remarque

Le contrôle de compte d'utilisateur est une fonctionnalité de sécurité Windows qui requiert qu'un administrateur approuve de façon spécifique les actions ou applications administratives avant qu'elles soient autorisées à s'exécuter. Dans la mesure où le contrôle de compte d'utilisateur est activé par défaut, vous serez invité à autoriser des opérations spécifiques qui requièrent des privilèges élevés. Vous pouvez configurer le contrôle de compte d'utilisateur de manière à modifier son comportement par défaut ou à le personnaliser pour des programmes spécifiques. Pour plus d'informations sur la configuration des contrôles de compte d'utilisateur, consultez Guide pas à pas du contrôle de compte d'utilisateur et User Account Control (Wikipédia).

Voir aussi

Autres ressources

Modifier des comptes de service et des mots de passe (PowerPivot pour SharePoint)
Configurer le compte de service d'Analysis Services
Configuration des comptes de service Windows


Configuration de Analysis Services – Répertoires de données

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Configuration de Analysis Services – Répertoires de données
Voir aussi Envoyer des commentaires

Les répertoires par défaut indiqués dans le tableau suivant sont configurables par l'utilisateur pendant l'installation de SQL Server. L'autorisation d'accéder à ces fichiers est accordée aux administrateurs locaux et aux membres du groupe de sécurité SQLServerMSASUser$<instance> qui est créé et mis en service pendant l'installation.

Description

Répertoire par défaut

Recommandations

Répertoire de données racine

C:\Program Files\Microsoft SQL Server\MSAS11.<ID_instance>\OLAP\Data\

Vérifiez que le dossier \Program files\Microsoft SQL Server\ est protégé par des autorisations limitées. Le fonctionnement de Analysis Services dépend, dans de nombreuses configurations, de la performance de l'emplacement de stockage sur lequel le répertoire de données se trouve. Placez ce répertoire sur l'emplacement de stockage le plus performant raccordé au système. Pour les installations de cluster de basculement, vérifiez que les répertoires de données sont placés sur le disque partagé.

Répertoire de fichiers journaux

C:\Program Files\Microsoft SQL Server\MSAS11.<ID_instance>\OLAP\Log\

Il s'agit du répertoire des fichiers journaux Analysis Services ; il inclut le journal FlightRecorder. Si vous augmentez la durée de la boîte noire, assurez-vous que le répertoire de journal dispose de l'espace adéquat.

Répertoire Temp

C:\Program Files\Microsoft SQL Server\MSAS11.<ID_instance>\OLAP\Temp\

Placez le répertoire Temp sur le sous-système de stockage le plus performant.

Répertoire de sauvegarde

C:\Program Files\Microsoft SQL Server\MSAS11.<ID_instance>\OLAP\Backup\

Il s'agit du répertoire pour les fichiers de sauvegarde par défaut Analysis Services. Pour les installations de PowerPivot pour SharePoint, il s'agit également de l'emplacement où les services système PowerPivot mettent en cache les fichiers de données PowerPivot.

Vérifiez que des autorisations appropriées sont définies pour empêcher la perte de données et vérifiez que le groupe d'utilisateurs pour le service Analysis Services a les autorisations adéquates pour écrire dans le répertoire de sauvegarde. L'utilisation d'un lecteur mappé pour les répertoires de sauvegarde n'est pas prise en charge.

Remarques

  • Les instances d'Analysis Services déployées sur une batterie de serveurs SharePoint stockent des fichiers d'application, des fichiers de données et des propriétés dans les bases de données de contenu et les bases de données d'application de service.

  • Lors de l'ajout de fonctionnalités à une installation existante, vous ne pouvez ni modifier l'emplacement d'une fonctionnalité précédemment installée, ni spécifier l'emplacement d'une nouvelle fonctionnalité.

  • Si vous spécifiez des répertoires d'installation autres que les répertoires par défaut, assurez-vous que les dossiers d'installation sont uniques à cette instance de SQL Server. Aucun des répertoires dans cette boîte de dialogue ne doit être partagé avec des répertoires d'autres instances de SQL Server. Les composants Moteur de base de données et Analysis Services d'une instance de SQL Server doivent également être installés dans des répertoires distincts.

  • Les fichiers programmes et les fichiers de données ne peuvent pas être installés aux emplacements suivants :

    • sur un lecteur de disque amovible ;

    • dans un système de fichiers utilisant la compression ;

    • dans un répertoire où figurent des fichiers système ;

    • sur des lecteurs partagés sur une instance de cluster de basculement.

Voir aussi

Concepts

Emplacements des fichiers pour les instances par défaut et les instances nommées de SQL Server


Sélection du disque du cluster

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Sélection du disque du cluster
Envoyer des commentaires

Utilisez la page Sélection du disque du cluster de l'Assistant Installation de SQL Server pour sélectionner la ressource disque de cluster partagée pour votre cluster de basculement SQL Server. Le disque de cluster est l'emplacement où les données SQL Server seront placées.

Un disque de cluster partagé n'est pas obligatoire pour les installations de cluster SQL ServerMoteur de base de données. Un serveur de fichiers SMB correspond à un stockage pris en charge pour les installations du cluster de basculement du moteur de base de données de SQL Server et peut être spécifié à l'aide de la page Moteur de base de données - Répertoires de données avant de terminer l'installation.

Attention Attention

Si vous avez sélectionné Analysis Services pour l'installer, vous devez spécifier un disque de cluster partagé.

Si vous envisagez d'activer FILESTREAM sur cette instance du cluster de basculement SQL Server, vous devez spécifier un disque de cluster partagé.

Options

Disques partagés

Sélectionnez un disque dans la liste. Le disque de cluster est l'emplacement où les données SQL Server seront placées.

Un seul disque peut être spécifié. Si vous sélectionnez le groupe contenant la ressource quorum du cluster, un avertissement s'affiche. Il est recommandé de ne pas procéder à l'installation dans cette ressource.

Disques partagés disponibles

Affiche une liste de disques disponibles, indique si chacun d'eux est qualifié en tant que disque partagé et fournit une description de chaque ressource de disque.


Configuration du réseau du cluster

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Configuration du réseau du cluster
Envoyer des commentaires

Utilisez la page Sélection du réseau du cluster pour spécifier les ressources réseau de votre instance de cluster de basculement.

Options

Nom réseau du cluster de basculement SQL Server - Il s'agit du nom identifiant votre instance de cluster de basculement sur le réseau.

Paramètres réseau - Spécifiez le type IP et l'adresse IP de votre instance de cluster de basculement.

Lors des opérations Ajouter un nœud et Supprimer un nœud, SQL Server affiche une liste en lecture seule des adresses IP existantes pour le cluster de basculement SQL Server.

  • Installation intégrée :

    • Si vous ajoutez un nœud qui prend en charge un ensemble identique des sous-réseaux de réseau pris en charge par les nœuds existants du cluster de basculement SQL Server, aucune adresse IP supplémentaire ne peut être ajoutée. Le paramètre de dépendance reste inchangé.

    • Si vous ajoutez un nœud qui prend en charge un sous-ensemble des sous-réseaux pris en charge par les nœuds existants du cluster de basculement SQL Server, aucune ressource d'adresse IP supplémentaire ne peut être ajoutée. La dépendance de ressource d'adresse IP est définie sur OR pour prendre en compte le fait que toutes les adresses IP spécifiées ne sont pas valides sur l'ensemble des nœuds de cluster.

    • Si vous ajoutez un nœud qui prend en charge des sous-réseaux en plus de ceux déjà pris en charge par les nœuds existants sur le cluster de basculement SQL Server, vous avez la possibilité d'ajouter de nouvelles adresses IP valides. Si de nouvelles adresses IP sont spécifiées, la dépendance de ressource d'adresse IP est définie sur OR pour prendre en compte le fait que toutes les adresses IP spécifiées ne sont pas valides sur l'ensemble des nœuds de cluster.

    • Si vous ajoutez un nœud qui prend en charge des sous-réseaux de réseau supplémentaires, mais aucun des sous-réseaux pris en charge par les nœuds existants sur le cluster de basculement SQL Server, vous devez ajouter des adresses IP supplémentaires. La dépendance de ressource d'adresse IP est définie sur OR pour prendre en compte le fait que toutes les adresses IP spécifiées ne sont pas valides sur l'ensemble des nœuds de cluster.

  • Installation avancée : lors de l'étape de fin de l'installation, spécifiez l'adresse IP de tous les nœuds et sous-réseaux pour votre instance de cluster de basculement. Vous pouvez spécifier plusieurs adresses IP pour un cluster de basculement de sous-réseaux multiples, mais une seule adresse IP par sous-réseau est prise en charge. Chaque nœud préparé doit être le propriétaire d'au moins une adresse IP. Si vous avez plusieurs sous-réseaux dans votre cluster de basculement SQL Server, vous êtes invité à définir la dépendance de ressource d'adresse IP sur OR. Supprimer un nœud :

    • Si les adresses IP restantes sont prises en charge sur tous les nœuds restants, vous êtes invité à définir la dépendance de ressource d'adresse IP sur AND.

    • Si les adresses IP restantes ne sont pas prises en charge sur tous les nœuds restants, la dépendance de ressource d'adresse IP reste sur OR.


Configuration du nœud de cluster

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Configuration du nœud de cluster
Envoyer des commentaires

Utilisez la page Configuration du nœud de clusters pour ajouter ou supprimer des nœuds d'une instance de cluster de basculement. Pour installer ou mettre à niveau un cluster de basculement SQL Server, vous devez exécuter le programme d'installation sur chaque nœud du cluster de basculement. Pour ajouter un nœud à un cluster de basculement SQL Server existant, vous devez exécuter le programme d'installation de SQL Server sur le nœud destiné à être ajouté à l'instance de cluster de basculement SQL Server.

Options

Nom de l'instance SQL Server - Utilisez la liste déroulante pour sélectionner l'instance de cluster de basculement SQL Server à modifier.

Nom de ce nœud - Ce champ contiendra le nom de l'ordinateur qui exécute le programme d'installation de SQL Server. Il s'agit du nœud de cluster de basculement qui sera ajouté ou supprimé de l'instance de cluster de basculement SQL Server.


Configuration du nœud de cluster (Complète)

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Configuration du nœud de cluster (Complète)
Envoyer des commentaires

Utilisez la page Configuration du nœud de clusters (Complète) pour spécifier une instance existante de SQL Server qui a été préparée pour le clustering. Pour installer ou mettre à niveau un cluster de basculement SQL Server, vous devez exécuter le programme d'installation sur chaque nœud du cluster de basculement. Pour ajouter un nœud à un cluster de basculement SQL Server existant, vous devez exécuter le programme d'installation de SQL Server sur le nœud destiné à être ajouté à l'instance de cluster de basculement SQL Server.

Options

Dans les zones de liste déroulante :

  • Nom de l'instance SQL Server — Sélectionnez le nom de l'instance pour le cluster de basculement SQL Server.

  • Nom de ce nœud — Ce champ est prérempli avec le nom de l'ordinateur où le programme d'installation de SQL Server s'exécute.

  • Nom réseau du cluster de basculement SQL Server— Ce champ n'est pas prérempli. Indiquez le nom réseau de la nouvelle instance de cluster de basculement SQL Server. Il s'agit du nom qui identifie l'instance de cluster de basculement sur le réseau.


Groupe de ressources de cluster

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Groupe de ressources de cluster
Voir aussi Envoyer des commentaires

Utilisez la page Groupe de ressources de cluster pour spécifier le disque où les ressources du serveur virtuel SQL Server seront hébergées.

Options

Spécifiez le nom du groupe de ressources de cluster SQL Server. vous avez le choix entre deux options :

  • Utilisez la zone de liste déroulante pour spécifier un groupe existant à utiliser.

  • Tapez le nom d'un groupe à créer. Notez que le nom « Stockage disponible » n'est pas un nom de groupe valide.

Voir aussi

Autres ressources

Procédure : créer un cluster de basculement SQL Server


Stratégie de sécurité du cluster

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Stratégie de sécurité du cluster
Envoyer des commentaires

Utilisez la page Stratégie de sécurité du cluster pour configurer la stratégie de sécurité pour votre instance de cluster de basculement.

Options

Spécifiez des groupes de domaines locaux ou globaux pour les services cluster. Toutes les autorisations de ressources sont gérées par des groupes au niveau du domaine qui incluent des comptes de service SQL Server en tant que membres de groupe. Pour plus d'informations sur les fonctionnalités des ID de sécurité (SID) d'un service sur Windows Server 2008, consultez Setting Up Windows Service Accounts (en anglais).

Si vous installez une instance de cluster de basculement Microsoft SQL Server 2012 dans un domaine Windows 2000 en mode mixte, vous devez utiliser les groupes globaux de domaine pour les services cluster SQL Server.

Remarque Remarque

Les contrôleurs de domaine Windows 2000 peuvent fonctionner en mode mixte et en mode natif. Le mode mixte autorise l'utilisation de contrôleurs de domaine de bas niveau dans le même domaine.


Finaliser - Finaliser l'image

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Finaliser - Finaliser l'image
Envoyer des commentaires

Utilisez la page Complète pour vérifier que la configuration de l'instance préparée est complète.

Options

Cette boîte de dialogue comprend un lien vers le fichier journal d'installation pour cette opération. Pour terminer l'installation, cliquez sur Fermer.


Progression de la finalisation d'image

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Progression de la finalisation d'image
Voir aussi Envoyer des commentaires

Utilisez la page Progression de la finalisation d'image de l'Assistant Installation de SQL Server pour contrôler l'état d'installation de la finalisation d'image SQL Server. À l'issue de cette étape, cette page répertorie l'état de chaque fonctionnalité SQL Server configurée et finalisée.

Voir aussi

Concepts

Afficher et lire les fichiers journaux d'installation de SQL Server


Règles de finalisation d'image

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Règles de finalisation d'image
Envoyer des commentaires

Le programme d'installation de SQL Server valide la configuration de votre ordinateur avant la fin de l'opération d'installation. Lors de l'exécution du programme d'installation de SQL Server, l'outil d'analyse de configuration système (SCC) analyse l'ordinateur sur lequel SQL Server sera installé. L'outil SCC recherche toute anomalie susceptible d'empêcher une installation correcte de SQL Server. Avant que le programme d'installation ne démarre l'Assistant Installation de SQL Server, le SCC extrait l'état de chaque élément. Puis, il compare le résultat avec les conditions requises et fournit une aide pour la suppression des problèmes importants.

La vérification de la configuration du système génère un rapport qui contient une brève description de chaque règle exécutée et de l'état d'exécution. Le rapport de contrôle de configuration du système se trouve à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Avant d'exécuter l'opération d'installation, examinez les rubriques suivantes :

  1. Configurations matérielle et logicielle requises pour l'installation de SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Fonctionnalités prises en charge par les éditions de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considérations sur la sécurité pour une installation de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versions linguistiques locales dans SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Autres références :

  1. Mises à niveau de la version et de l'édition prises en charge(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Avant l'installation du clustering de basculement(http://go.microsoft.com/fwlink/?LinkId=235034)


Finaliser - Préparer l'image

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Finaliser - Préparer l'image
Envoyer des commentaires

Utilisez la page Finaliser pour vérifier que la préparation d'image est terminée.

Options

Cette boîte de dialogue comprend un lien vers le fichier journal d'installation pour cette opération. Pour terminer la préparation d'image, cliquez sur Fermer.


Finaliser - Réparer

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Finaliser - Réparer
Envoyer des commentaires

Utilisez la page Finaliser - Réparer pour vérifier que la réparation est terminée.

Options

Cette boîte de dialogue comprend un lien vers le fichier journal d'installation pour cette opération. Pour continuer, cliquez sur Fermer.


Complète - Mise à niveau

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Complète - Mise à niveau
Envoyer des commentaires

Utilisez la page Complète (Mise à niveau) pour vérifier que la mise à niveau est terminée.

Options

Cette boîte de dialogue comprend un lien vers le fichier journal d'installation pour cette opération. Pour continuer, cliquez sur Fermer.


Configuration du moteur de base de données – Mise en service de compte

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Configuration du moteur de base de données – Mise en service de compte
Voir aussi Envoyer des commentaires

Utilisez cette page pour définir le mode de sécurité SQL Server et ajouter des utilisateurs Windows ou des groupes comme administrateurs du Moteur de base de données SQL Server.

Considérations relatives à l'exécution de SQL Server 2012 sous Windows Vista, Windows 7 et Windows Server 2008

Dans les versions précédentes de SQL Server, le groupe BUILTIN\Administrateurs était fourni en tant que compte de connexion du Moteur de base de données et les membres du groupe Administrateurs local pouvaient se connecter en utilisant leurs informations d'identification d'administrateur. L'utilisation d'autorisations élevées n'est pas recommandée. Dans Microsoft SQL Server 2012, le groupe BUILTIN\Administrateurs n'est pas fourni en tant que compte de connexion. Par conséquent, vous devez créer un compte de connexion SQL Server pour chaque utilisateur administrateur et ajouter ce compte de connexion au rôle serveur fixe sysadmin lors de l'installation d'une nouvelle instance de Microsoft SQL Server 2012. Vous devez procéder de même pour les comptes Windows utilisés pour exécuter les travaux de l'Agent SQL Server. Ceux-ci incluent les travaux de l'agent de réplication.

Options

Mode de sécurité - Sélectionnez l'authentification Windows ou l'authentification en mode mixte pour votre installation.

Configuration du principal Windows - Dans les versions antérieures de SQL Server, le groupe local de Windows Builtin\Administrator a été placé dans le rôle serveur sysadmin de SQL Server, en accordant aux administrateurs Windows l'accès à l'instance de SQL Server. Dans Microsoft SQL Server 2012, le groupe Builtin\Administrator n'est pas configuré dans le rôle serveur sysadmin. Au lieu de cela, vous devez configurer de manière explicite des administrateurs SQL Server pour les nouvelles installations lors de l'installation.

Important Important

Vous devez configurer de manière explicite des administrateurs SQL Server pour les nouvelles installations lors de l'installation. L'installation ne vous permet pas de continuer tant que cette étape n'a pas été effectuée.

Spécifier les administrateurs SQL Server - Vous devez spécifier au moins un principal Windows pour l'instance de SQL Server. Pour ajouter le compte sous lequel le programme d'installation de SQL Server s'exécute, cliquez sur le bouton Utilisateur actuel. Pour ajouter ou supprimer des comptes dans la liste des administrateurs système, cliquez sur Ajouter ou Supprimer, puis modifiez la liste des utilisateurs, groupes ou ordinateurs qui disposeront des privilèges d'administrateur pour l'instance de SQL Server.

Lorsque vous avez terminé de modifier la liste, cliquez sur OK, puis vérifiez la liste des administrateurs dans la boîte de dialogue de configuration. Une fois la liste complète, cliquez sur Suivant.

Si vous sélectionnez l'authentification de mode mixte, vous devez fournir les informations d'identification de session pour le compte de l'administrateur système (SA) SQL Server intégré.

Remarque relative à la sécurité Remarque relative à la sécurité

N'utilisez pas de mot de passe vide. Utilisez un mot de passe fort.

Mode d'authentification Windows

Quand un utilisateur se connecte par le biais d'un compte d'utilisateur Windows, SQL Server valide le nom et le mot de passe du compte à l'aide du jeton du principal Windows du système d'exploitation. Il s'agit du mode d'authentification par défaut et il est plus fiable que le mode mixte. L'authentification Windows utilise le protocole de sécurité Kerberos, met en œuvre les stratégies de mot de passe en termes de validation de la complexité des mots de passe forts et prend en charge le verrouillage des comptes et l'expiration des mots de passe.

Remarque relative à la sécurité Remarque relative à la sécurité

Lorsque c'est possible, utilisez l'authentification Windows.

Important Important

N'utilisez pas de mot de passe vide. Utilisez un mot de passe fort. Ne définissez jamais un mot de passe sa vide ou faible.

Mode mixte (authentification Windows ou authentification SQL Server)

Permet aux utilisateurs de se connecter en utilisant l'authentification Windows ou l'authentification SQL Server. Les utilisateurs qui se connectent via un compte d'utilisateur Windows peuvent utiliser des connexions approuvées qui sont validées par Windows.

Si vous devez choisir l'authentification en mode mixte et utiliser des connexions SQL pour vous adapter à des applications héritées, définissez des mots de passe forts pour tous les comptes SQL Server.

Remarque Remarque

L'authentification SQL Server est fournie uniquement dans un souci de compatibilité descendante. Lorsque c'est possible, utilisez l'authentification Windows.

Entrer le mot de passe

Entrez et confirmez la connexion d'administrateur système (sa). Les mots de passe constituant la première ligne de défense contre les intrus, le choix de mots de passe forts est essentiel à la sécurité de votre système. Ne définissez jamais un mot de passe sa vide ou faible.

Remarque Remarque

Les mots de passe SQL Server peuvent contenir de 1 à 128 caractères, notamment des lettres, des symboles et des chiffres. Si vous choisissez l'authentification en mode mixte, vous devez d'abord entrer un mot de passe sa fort avant de passer à la page suivante de l'Assistant Installation.

Instructions sur les mots de passe forts

Les mots de passe forts ne peuvent pas être aisément devinés par une personne et ils ne sont pas aisément piratés par un programme informatique. Les mots de passe forts ne peuvent pas utiliser des conditions ou des termes interdits, notamment :

  • Une condition vide ou NULL

  • "Password"

  • "Admin"

  • "Administrator"

  • "sa"

  • "sysadmin"

Un mot de passe fort ne peut pas se composer des termes suivants associés à l'ordinateur d'installation :

  • Le nom de l'utilisateur qui a ouvert la session sur l'ordinateur.

  • Nom de l'ordinateur.

Un mot de passe fort doit contenir plus de 8 caractères et satisfaire au moins trois des quatre critères suivants :

  • Il doit contenir des lettres majuscules.

  • Il doit contenir des lettres minuscules.

  • Il doit contenir des chiffres.

  • Il doit contenir des caractères non alphanumériques, comme #, % ou ^.

Les mots de passe entrés sur cette page doivent répondre aux exigences des stratégies de mots de passe forts. Si vous avez un processus automatisé qui utilise l'authentification SQL Server, assurez-vous que le mot de passe répond aux exigences des stratégies de mots de passe forts.

Contenu connexe

Pour plus d'informations sur le choix de l'authentification Windows ou de l'authentification SQL Server, consultez la rubrique Choisir un mode d'authentification dans la documentation en ligne de SQL Server.

Pour plus d'informations sur le choix d'un compte pour l'exécution de Moteur de base de données SQL Server, consultez la rubrique Configurer les comptes de service Windows et les autorisations dans la documentation en ligne de SQL Server.

Voir aussi

Référence

Configurer les comptes de service Windows et les autorisations


Configuration du moteur de base de données – Répertoires de données

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Configuration du moteur de base de données – Répertoires de données
Voir aussi Envoyer des commentaires

Cette page vous permet de spécifier l'emplacement d'installation pour les fichiers programme et les fichiers de données du moteur de base de données SQL Server. Selon le type d'installation, le stockage pris en charge peut inclure un disque local, un stockage partagé ou un serveur de fichiers SMB.

Pour spécifier un partage de fichiers SMB comme répertoire, vous devez taper manuellement le chemin d'accès UNC pris en charge. La navigation vers un partage de fichiers SMB n'est pas prise en charge. Vous trouverez ci-dessous un format de chemin d'accès UNC pris en charge d'un partage de fichiers SMB : \\Nom_serveur\Nom_partage\...

Instance autonome de SQL Server

Le tableau suivant répertorie les types de stockage pris en charge et les répertoires par défaut pour une instance autonome de SQL Server qui sont configurables par l'utilisateur pendant l'installation de SQL Server.

Description | Type de stockage pris en charge | Répertoire par défaut | Recommandations
Répertoire de données racine | Disque local, serveur de fichiers SMB, stockage partagé 1 | C:\Program Files\Microsoft SQL Server\ | Le programme d'installation de SQL Server configurera les listes de contrôle d'accès pour les répertoires SQL Server et rompra l'héritage dans le cadre de la configuration.
Répertoire de base de données utilisateur | Disque local, serveur de fichiers SMB, stockage partagé 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data | Les meilleures pratiques recommandées pour les répertoires de données utilisateur dépendent de la charge de travail et des exigences en matière de performances.
Répertoire du journal de la base de données utilisateur | Disque local, serveur de fichiers SMB, stockage partagé 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data | Assurez-vous que le répertoire du journal a un espace adéquat.
Répertoire Temp de base de données | Disque local, serveur de fichiers SMB, stockage partagé 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data | Les meilleures pratiques recommandées pour le répertoire Temp dépendent de la charge de travail et des exigences en matière de performances.
Répertoire Temp du journal de base de données | Disque local, serveur de fichiers SMB, stockage partagé 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data | Assurez-vous que le répertoire du journal a un espace adéquat.
Répertoire de sauvegarde | Disque local, serveur de fichiers SMB, stockage partagé 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Backup | Définissez les autorisations appropriées pour empêcher la perte de données et vérifiez que le compte d'utilisateur pour le service SQL Server a les autorisations adéquates pour écrire dans le répertoire de sauvegarde. L'utilisation d'un lecteur mappé pour les répertoires de sauvegarde n'est pas prise en charge.

1 Même si les disques partagés sont pris en charge, cette méthode n'est pas recommandée pour une instance autonome de SQL Server.

Instance de cluster de basculement de SQL Server

Le tableau suivant répertorie les types de stockage pris en charge et les répertoires par défaut pour une instance de cluster de basculement de SQL Server qui sont configurables par l'utilisateur pendant l'installation de SQL Server.

Description

Type de stockage pris en charge

Répertoire par défaut

Recommandations

Répertoire de données racine

Stockage partagé, serveur de fichiers SMB

<Lecteur:>\Program Files\Microsoft SQL Server\

Conseil Conseil

Si le disque partagé a été sélectionné à la page Sélection du disque du cluster, la valeur par défaut est le premier disque partagé. La valeur par défaut de ce champ est vide si aucune sélection n'a été effectuée à la page Sélection du disque du cluster.

Le programme d'installation de SQL Server configurera les listes de contrôle d'accès pour les répertoires SQL Server et rompra l'héritage dans le cadre de la configuration.

Répertoire de base de données utilisateur

Stockage partagé, serveur de fichiers SMB

<Lecteur:>Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data

Conseil Conseil

Si le disque partagé a été sélectionné à la page Sélection du disque du cluster, la valeur par défaut est le premier disque partagé. La valeur par défaut de ce champ est vide si aucune sélection n'a été effectuée à la page Sélection du disque du cluster.

Les meilleures pratiques recommandées pour les répertoires de données utilisateur dépendent de la charge de travail et des exigences en matière de performances.

Répertoire du journal de la base de données utilisateur

Stockage partagé, serveur de fichiers SMB

<Lecteur:>\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data

Conseil Conseil

Si le disque partagé a été sélectionné à la page Sélection du disque du cluster, la valeur par défaut est le premier disque partagé. La valeur par défaut de ce champ est vide si aucune sélection n'a été effectuée à la page Sélection du disque du cluster.

Assurez-vous que le répertoire du journal a un espace adéquat.

Répertoire Temp de base de données

Disque local, stockage partagé, serveur de fichiers SMB

<Lecteur:>\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data

Conseil Conseil

Si le disque partagé a été sélectionné à la page Sélection du disque du cluster, la valeur par défaut est le premier disque partagé. La valeur par défaut de ce champ est vide si aucune sélection n'a été effectuée à la page Sélection du disque du cluster.

Assurez-vous que le répertoire spécifié est valide pour tous les nœuds du cluster. Pendant le basculement, si les répertoires tempdb ne sont pas disponibles sur le nœud de basculement cible, la ressource SQL Server ne sera pas en ligne.

Répertoire Temp du journal de base de données

Disque local, stockage partagé, serveur de fichiers SMB

<Lecteur:>\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data

Conseil Conseil

Si le disque partagé a été sélectionné à la page Sélection du disque du cluster, la valeur par défaut est le premier disque partagé. La valeur par défaut de ce champ est vide si aucune sélection n'a été effectuée à la page Sélection du disque du cluster.

Assurez-vous que le répertoire spécifié est valide pour tous les nœuds du cluster. Pendant le basculement, si les répertoires tempdb ne sont pas disponibles sur le nœud de basculement cible, la ressource SQL Server ne sera pas en ligne.

Répertoire de sauvegarde

Disque local, stockage partagé, serveur de fichiers SMB

<Lecteur:>\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Backup

Conseil Conseil

Si le disque partagé a été sélectionné à la page Sélection du disque du cluster, la valeur par défaut est le premier disque partagé. La valeur par défaut de ce champ est vide si aucune sélection n'a été effectuée à la page Sélection du disque du cluster.

Définissez les autorisations appropriées pour empêcher la perte de données et vérifiez que le compte d'utilisateur pour le service SQL Server a les autorisations adéquates pour écrire dans le répertoire de sauvegarde. L'utilisation d'un lecteur mappé pour les répertoires de sauvegarde n'est pas prise en charge.

Considérations sur la sécurité

Le programme d'installation configurera les listes de contrôle d'accès pour les répertoires SQL Server et rompra l'héritage dans le cadre de la configuration.

Les recommandations suivantes s'appliquent au serveur de fichiers SMB :

  • Le compte de service SQL Server doit être un compte de domaine si un serveur de fichiers SMB est utilisé.

  • Le compte utilisé pour installer SQL Server doit avoir des autorisations FULL CONTROL NTFS sur le dossier de partage de fichiers SMB utilisé comme répertoire de données.

  • Des privilèges SeSecurityPrivilege sur le serveur de fichiers SMB doivent être accordés au compte utilisé pour installer SQL Server. Pour accorder ce privilège, utilisez la console de stratégie de sécurité locale sur le serveur de fichiers pour ajouter le compte utilisé pour l'installation de SQL Server à la stratégie Gérer le journal d'audit et de la sécurité. Ce paramètre est disponible dans la section Attribution des droits utilisateur sous Stratégies locales dans la console Stratégie de sécurité locale.

Remarques

  • Lors de l'ajout de fonctionnalités à une installation existante, vous ne pouvez ni modifier l'emplacement d'une fonctionnalité précédemment installée, ni spécifier l'emplacement d'une nouvelle fonctionnalité.

  • Si vous spécifiez des répertoires d'installation autres que les répertoires par défaut, assurez-vous que les dossiers d'installation sont uniques à cette instance de SQL Server. Aucun des répertoires dans cette boîte de dialogue ne doit être partagé avec des répertoires d'autres instances de SQL Server. Les composants Moteur de base de données et Analysis Services d'une instance de SQL Server doivent également être installés dans des répertoires distincts.

  • Les fichiers programmes et les fichiers de données ne peuvent pas être installés aux emplacements suivants :

    • sur un lecteur de disque amovible ;

    • dans un système de fichiers utilisant la compression ;

    • dans un répertoire où figurent des fichiers système ;

    • sur un lecteur réseau mappé sur une instance de cluster de basculement.

Voir aussi

Concepts

Emplacements des fichiers pour les instances par défaut et les instances nommées de SQL Server

Autres ressources

Autorisations de partage et NTFS sur un serveur de fichiers


Configuration du moteur de base de données - Filestream

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Configuration du moteur de base de données - Filestream
Voir aussi Envoyer des commentaires

Utilisez cette page pour activer FILESTREAM pour cette installation de Microsoft SQL Server 2012. FILESTREAM intègre le Moteur de base de données SQL Server avec un système de fichiers NTFS en stockant les données d'objet blob varbinary(max) en tant que fichiers dans le système de fichiers. Les instructions Transact-SQL peuvent insérer, mettre à jour, interroger, rechercher et sauvegarder des données FILESTREAM. Les interfaces de système de fichiers Win32 fournissent l'accès de diffusion en continu aux données.

Activer FILESTREAM pour l'accès Transact-SQL

Sélectionnez cette option pour activer FILESTREAM pour l'accès Transact-SQL. Ce contrôle doit être activé pour que les autres options de contrôle soient disponibles.

Activer FILESTREAM pour l'accès en continu des E/S de fichier

Sélectionnez cette option pour activer l'accès en continu Win32 pour FILESTREAM.

Nom du partage Windows

Utilisez ce contrôle pour entrer le nom du partage Windows dans lequel les données FILESTREAM doivent être stockées.

Permettre aux clients distants d'avoir un accès en continu aux données FILESTREAM

Sélectionnez ce contrôle pour permettre aux clients distants d'accéder à ces données FILESTREAM sur ce serveur.

Voir aussi

Référence

sp_configure (Transact-SQL)

Concepts

Activer et configurer FILESTREAM


Configuration du moteur de base de données – Instance utilisateur

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Configuration du moteur de base de données – Instance utilisateur
Envoyer des commentaires

La page Instance utilisateur permet de générer une instance distincte du moteur de base de données pour les utilisateurs sans autorisations d'administrateur et d'ajouter des utilisateurs dans le rôle d'administrateur.

Option

Activer les instances utilisateur

Par défaut, cette option est activée. Pour désactiver la fonction qui active les instances utilisateur, désactivez cette case à cocher.

L'instance utilisateur, également désignée comme instance enfant ou client, est une instance de SQL Server qui est générée par l'instance parent (l'instance principale exécutée en tant que service, telle que SQLExpress) pour le compte d'un utilisateur. L'instance utilisateur s'exécute en tant que processus utilisateur dans le contexte de sécurité de cet utilisateur. L'instance utilisateur est isolée de l'instance parent et de toutes les autres instances utilisateur exécutées sur l'ordinateur. La fonction d'instance utilisateur est également appelée RANU (« Run As Normal User », exécution en mode utilisateur normal).

Remarque Remarque

Les connexions configurées en tant que membres du rôle serveur fixe sysadmin lors de l'installation sont configurées en tant qu'administrateurs dans l'exemple de base de données. Si elles ne sont pas supprimées, elles sont membres du rôle serveur fixe sysadmin sur l'instance utilisateur.

Ajouter l'utilisateur au rôle Administrateur SQL Server

Par défaut, cette option est désactivée. Pour ajouter l'utilisateur du programme d'installation en cours au rôle Administrateur SQL Server, activez la case à cocher.

Les utilisateurs Windows Vista qui sont membres de BUILTIN\Administrateurs ne sont pas ajoutés automatiquement au rôle serveur fixe sysadmin lorsqu'ils se connectent à SQL Server Express. Seuls les utilisateurs Windows Vista qui ont été ajoutés explicitement à un rôle d'administrateur de niveau serveur peuvent administrer SQL Server Express. Tous les membres du groupe Built-In\Users peuvent se connecter à l'instance de SQL Server Express, mais ils auront des autorisations limitées pour effectuer les tâches de base de données. Pour cette raison, les utilisateurs dont les privilèges SQL Server Express sont hérités de BUILTIN\Administrateurs et de Built-In\Utilisateurs dans les versions précédentes de Windows doivent bénéficier explicitement des privilèges d'administrateur dans les instances de SQL Server Express qui s'exécutent sur Windows Vista.

Pour apporter des modifications quelconques aux rôles d'utilisateur une fois le programme d'installation terminé, utilisez l'outil Configuration de la surface d'exposition SQL Server 2005 (SQLSAC.exe). Pour mettre à jour la liste des utilisateurs dans le rôle SQL Server Administrateur système, cliquez sur le lien Ajouter un nouvel administrateur.

Assurez-vous que le champ Utilisateur à mettre en service contient les paramètres DomainName\UserName de l'utilisateur dont les autorisations doivent être mises à jour. Sélectionnez le rôle à mettre à jour dans la liste des instances de SQL Server dans le volet Privilèges disponibles, puis cliquez sur la flèche droite. Pour ajouter l'utilisateur à tous les rôles disponibles pour toutes les instances disponibles de SQL Server et tous les rôles disponibles, cliquez sur la double flèche vers la droite.

Pour implémenter les modifications une fois votre sélection terminée, cliquez sur OK. Pour quitter l'outil sans apporter de modification, cliquez sur Annuler.


Espace disque nécessaire

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Espace disque nécessaire
Voir aussi Envoyer des commentaires

Utilisez la page Résumé sur l'espace nécessaire pour examiner l'espace disque nécessaire pour les fonctionnalités SQL Server sélectionnées pour votre installation.

Options

Si la quantité d'espace disque requis est trop élevée, envisagez les options suivantes :

  • Remplacez les répertoires d'installation par un lecteur disposant de davantage d'espace disque.

  • Modifiez les fonctionnalités SQL Server pour votre installation.

  • Créez davantage d'espace libre sur le lecteur spécifié en déplaçant d'autres fichiers ou applications.

Voir aussi

Autres ressources

Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008 R2


Configuration de Distributed Replay Controller

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Configuration de Distributed Replay Controller
Envoyer des commentaires

Utilisez la page Configuration de Distributed Replay Controller de l'Assistant Installation de SQL Server pour spécifier les utilisateurs auxquels vous voulez accorder des autorisations administratives sur le service Distributed Replay Controller.

Les utilisateurs qui disposent d'autorisations administratives ont un accès illimité au service Distributed Replay Controller.

Options

Ajouter l'utilisateur actuel

Cliquez sur ce bouton pour ajouter les utilisateurs auxquels vous voulez accorder des autorisations d'accès au service Distributed Replay Controller.

Ajouter

Cliquez sur ce bouton pour ajouter des autorisations d'accès au service Distributed Replay Controller.

Supprimer

Cliquez sur ce bouton pour supprimer des autorisations d'accès du service Distributed Replay Controller.


Configuration de Distributed Replay Client

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Configuration de Distributed Replay Client
Envoyer des commentaires

Utilisez la page Configuration de Distributed Replay Client de l'Assistant Installation de SQL Server pour spécifier les utilisateurs auxquels vous voulez accorder des autorisations administratives sur le service Distributed Replay Client.

Les utilisateurs qui disposent d'autorisations administratives ont un accès illimité au service Distributed Replay Client.

Options

Nom du contrôleur

Il s'agit d'un paramètre optionnel ; la valeur par défaut est <blank>.

Entrez le nom du contrôleur avec lequel l'ordinateur client communiquera pour le service Distributed Replay Client. Notez les points suivants :

  • Le nom doit être un nom de domaine complet (FQDN). Par exemple, un hôte appelé server1 dans la hiérarchie de produits au sein de Microsoft peut avoir un nom de domaine complet server1.products.microsoft.com.

  • Si vous avez déjà configuré un contrôleur, entrez son nom lors de la configuration de chaque client.

  • Si vous n'avez pas encore configuré de contrôleur, vous n'êtes pas obligé de fournir le nom du contrôleur. Toutefois, vous devez entrer manuellement le nom du contrôleur dans le fichier de configuration du client.

Répertoire de travail

Spécifiez le répertoire de travail du service Distributed Replay Client.

Le répertoire de travail par défaut est <drive letter>:\Program Files\Microsoft SQL Server\DReplayClient\WorkingDir\.

Répertoire des résultats

Spécifiez le répertoire des résultats du service Distributed Replay Client.

Le répertoire des résultats par défaut est <drive letter>:\Program Files\Microsoft SQL Server\DReplayClient\ResultDir\.


Règles de mise à niveau de l'édition

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Règles de mise à niveau de l'édition
Voir aussi Envoyer des commentaires

Le programme d'installation de SQL Server valide la configuration de votre ordinateur avant la fin de l'opération d'installation. Lors de l'exécution du programme d'installation de SQL Server, l'outil d'analyse de configuration système (SCC) analyse l'ordinateur sur lequel SQL Server sera installé. L'outil SCC recherche toute anomalie susceptible d'empêcher une installation correcte de SQL Server. Avant que le programme d'installation ne démarre la mise à niveau de l'édition, le SCC extrait l'état de chaque élément. Puis, il compare le résultat avec les conditions requises et fournit une aide pour la suppression des problèmes importants.

La vérification de la configuration du système génère un rapport qui contient une brève description de chaque règle exécutée et de l'état d'exécution. Le rapport de contrôle de configuration du système se trouve à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Avant d'exécuter l'opération d'installation, examinez les rubriques suivantes :

  1. Configurations matérielle et logicielle requises pour l'installation de SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Fonctionnalités prises en charge par les éditions de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considérations sur la sécurité pour une installation de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versions linguistiques locales dans SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Autres références :

  1. Mises à niveau de la version et de l'édition prises en charge(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Avant l'installation du clustering de basculement(http://go.microsoft.com/fwlink/?LinkId=235034)

Voir aussi

Référence

Règles de support du programme d'installation


Création de rapports d'erreurs

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Création de rapports d'erreurs
Envoyer des commentaires

Utilisez la page Paramètres de rapports d'erreurs et d'utilisation de l'Assistant Installation de SQL Server pour activer la fonctionnalité de création de rapports d'erreurs et d'utilisation dans SQL Server.

Options

Par défaut, les fonctionnalités de rapport d'erreurs et de collecte des données d'utilisation des fonctionnalités sont désactivées pour SQL Server et ses composants dans Microsoft SQL Server 2012.

Rapport d'erreurs

Si vous activez la fonctionnalité Rapport d'erreurs, SQL Server est configuré pour envoyer automatiquement un rapport à Microsoft si une erreur irrécupérable se produit dans l'un des composants SQL Server suivants :

  • Le Moteur de base de données

  • Agent SQL Server

  • Analysis Services

  • Reporting Services

  • Integration Services

  • Réplication

Microsoft utilise les rapports d'erreurs pour améliorer le fonctionnement de SQL Server. Ces informations sont traitées en toute confidentialité.

Des informations sur les erreurs sont envoyées à Microsoft par le biais d'une connexion sécurisée (https) et elles sont stockées avec un accès limité. Des rapports d'erreurs peuvent également être envoyés sur votre propre serveur de rapports d'erreurs d'entreprise.

Les rapports d'erreurs comprennent les informations suivantes :

  • la condition de SQL Server lorsque le problème s'est produit ;

  • des informations sur la version du système d'exploitation et le matériel ;

  • votre ID de produit numérique, qui n'est pas utilisé pour identifier votre licence ;

  • l'adresse IP réseau de votre ordinateur ou de votre serveur proxy ;

  • des informations provenant de la mémoire ou des fichiers du processus à l'origine de l'erreur.

Microsoft ne regroupe pas de manière intentionnelle vos fichiers, nom, adresse, adresse électronique ou tout autre forme d'informations personnelles. Le rapport d'erreurs peut toutefois contenir des informations personnelles qui proviennent de la mémoire ou des fichiers du processus à l'origine de l'erreur. Bien que ces informations permettent à priori de déterminer votre identité, Microsoft ne les exploite pas à cette fin.

Pour plus d'informations sur la politique de confidentialité et la procédure de collecte de données de SQL Server, consultez la page Web Déclaration de confidentialité de Microsoft SQL Server.

Si vous activez les rapports d'erreurs et qu'une erreur irrécupérable se produit, vous pouvez voir une réponse de Microsoft dans le journal des événements Windows, qui pointe sur un article de la Base de connaissances Microsoft traitant cette erreur.

Pour désactiver la fonction de rapport d'erreurs et d'utilisation de fonctionnalités pour toutes les instances de SQL Server et leurs composants une fois l'installation terminée, accédez à la boîte de dialogue Paramètres de rapports d'erreurs et d'utilisation et désactivez les cases à cocher pour Utilisation de fonctionnalités. Si l'option Rapport d'erreurs est activée pour plusieurs composants SQL Server (le Moteur de base de données SQL Server, Analysis Services, Reporting Services et les composants partagés), vous pouvez la désactiver individuellement pour l'instance de chaque composant, ainsi que pour les composants partagés répertoriés comme Autres.


Rapport sur le cluster de basculement

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Rapport sur le cluster de basculement
Envoyer des commentaires

Utilisez la page Rapport sur le cluster de basculement pour afficher les résultats du rapport de l'analyse du système du programme d'installation pour cette opération.

Options

Pour afficher un rapport détaillé pour l'analyse, cliquez sur le lien de rapport.


Vérification des fonctionnalités

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Vérification des fonctionnalités
Voir aussi Envoyer des commentaires

La page Vérification des fonctionnalités est une liste en lecture seule des fonctionnalités qui ont été préparées et qui seront configurées et finalisées à la fin de l'étape de finalisation d'image. La liste de fonctionnalités est sélectionnée pendant l'étape de préparation d'image et ne peut pas être modifiée pendant l'étape de finalisation d'image. En plus des fonctionnalités affichées, une instance préparée inclut également SQL Server Browser, Enregistreur SQL Server et SQL Server Native Client.

Vous pouvez ajouter des autres fonctionnalités non incluses dans l'instance préparée de l'instance SQL Server après avoir finalisé la configuration de l'instance préparée de SQL Server.

Groupe de composants

Composants et fonctionnalités

Services du moteur de base de données

Le Moteur de base de données SQL Server inclut les composants suivants :

  • Le moteur de base de données est le service central qui permet de stocker, traiter et sécuriser les données.

    • Réplication : (Facultatif) La réplication est un ensemble de technologies qui permettent de copier et de distribuer des données et des objets de base de données d'une base de données vers une autre, puis de synchroniser les bases de données afin de préserver leur cohérence.

    • Recherche en texte intégral : (facultatif) La recherche en texte intégral fournit les fonctionnalités nécessaires à l'émission de requêtes de texte intégral sur les données caractères en texte brut des tables SQL Server.

    • Data Quality Services (facultatif) : Data Quality Services (DQS) est une solution de nettoyage de données qui vous permet de détecter des données incohérentes et incorrectes dans votre source de données. Par ailleurs, elle vous offre des moyens automatisés et interactifs pour nettoyer les données.

Reporting Services

Reporting Services inclut les composants serveur et clients permettant de créer, de gérer et de déployer des rapports tabulaires, de matrice, graphiques et de forme libre. Reporting Services est également une plateforme évolutive que vous pouvez utiliser pour développer des applications de création de rapports

Voir aussi

Autres ressources

Procédure : installer SQL Server à l'aide de SysPrep


Règles d'installation

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Règles d'installation
Voir aussi Envoyer des commentaires

Le programme d'installation de SQL Server valide la configuration de votre ordinateur avant la fin de l'opération d'installation. Lors de l'exécution du programme d'installation de SQL Server, l'outil d'analyse de configuration système (SCC) analyse l'ordinateur sur lequel SQL Server sera installé. L'outil SCC recherche toute anomalie susceptible d'empêcher une installation correcte de SQL Server. Avant que le programme d'installation ne démarre l'Assistant Installation de SQL Server, le SCC extrait l'état de chaque élément. Puis, il compare le résultat avec les conditions requises et fournit une aide pour la suppression des problèmes importants.

La vérification de la configuration du système génère un rapport qui contient une brève description de chaque règle exécutée et de l'état d'exécution. Le rapport de contrôle de configuration du système se trouve à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Avant d'exécuter l'opération d'installation, examinez les rubriques suivantes :

  1. Configurations matérielle et logicielle requises pour l'installation de SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Fonctionnalités prises en charge par les éditions de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considérations sur la sécurité pour une installation de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versions linguistiques locales dans SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Autres références :

  1. Mises à niveau de la version et de l'édition prises en charge(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Avant l'installation du clustering de basculement(http://go.microsoft.com/fwlink/?LinkId=235034)

Voir aussi

Référence

Règles de support du programme d'installation


Règles de fonctionnalité

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Règles de fonctionnalité
Envoyer des commentaires

Le programme d'installation de SQL Server valide la configuration de votre ordinateur avant la fin de l'opération d'installation. Lors de l'exécution du programme d'installation de SQL Server, l'outil d'analyse de configuration système (SCC) analyse l'ordinateur sur lequel SQL Server sera installé. L'outil SCC recherche toute anomalie susceptible d'empêcher une installation correcte de SQL Server. Avant que le programme d'installation ne démarre l'Assistant, le SCC extrait l'état de chaque élément. Puis, il compare le résultat avec les conditions requises et fournit une aide pour la suppression des problèmes importants.

La vérification de la configuration du système génère un rapport qui contient une brève description de chaque règle exécutée et de l'état d'exécution. Le rapport de contrôle de configuration du système se trouve à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Avant d'exécuter l'opération d'installation, examinez les rubriques suivantes :

  1. Configurations matérielle et logicielle requises pour l'installation de SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Fonctionnalités prises en charge par les éditions de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considérations sur la sécurité pour une installation de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versions linguistiques locales dans SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Autres références :

  1. Mises à niveau de la version et de l'édition prises en charge(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Avant l'installation du clustering de basculement(http://go.microsoft.com/fwlink/?LinkId=235034)


Sélection de fonctionnalités

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Sélection de fonctionnalités
Voir aussi Envoyer des commentaires

Utilisez les cases à cocher de la page Sélection de fonctionnalités de l'Assistant Installation de SQL Server pour sélectionner les composants de votre installation de SQL Server.

Installation des fonctionnalités SQL Server

Dans la page Sélection de fonctionnalités, les fonctionnalités SQL Server sont séparées en deux sections principales : Fonctionnalités de l'instance et Fonctionnalités partagées.

Les fonctionnalités de l'instance font référence aux composants installés une seule fois pour chaque instance pour pouvoir disposer de plusieurs copies de ces derniers (une pour chaque instance). Chaque instance peut être une version distincte qui a un niveau de correctif logiciel différent. Lorsque vous installez un correctif logiciel, s'il s'agit d'un Service Pack, d'un correctif logiciel ou d'une mise à jour cumulative, il met uniquement à jour les fichiers pour une instance sur un ordinateur donné, ainsi que les fonctionnalités partagées si elles n'ont pas déjà été mises à jour.

Les fonctionnalités partagées font référence aux fonctionnalités qui sont communes à toutes les instances sur un ordinateur donné. Chacune de ces fonctionnalités partagées est conçue pour assurer une compatibilité descendante avec les versions de SQL Server prises en charge (Service Packs, mises à jour cumulatives et correctifs logiciels) qui peuvent être installées côte à côte.

Remarque Remarque

SQL Server SysPrep : les composants du Moteur de base de données et Reporting Services sont les seules fonctionnalités Microsoft SQL Server 2012 qui prennent en charge SQL Server SysPrep. Vous pouvez sélectionner ces fonctionnalités et composants pendant l'étape de préparation d'image du processus. Vous ne pouvez pas effectuer la sélection lors de la finalisation d'une image préparée de SQL Server. Pour plus d'informations, consultez Procédure : installer SQL Server 2012 à l'aide de SysPrep (http://go.microsoft.com/fwlink/?LinkId=190965).

Clusters de basculement SQL Server : les composants du Moteur de base de données et d'Analysis Services sont les seules fonctionnalités de Microsoft SQL Server 2012 qui prennent en charge le clustering de basculement. Vous pouvez installer d'autres composants, tels que Reporting Services ou Integration Services, sur un nœud de cluster de basculement, mais ils ne prennent pas en charge les clusters et leurs services ne basculent pas si le nœud est placé hors connexion. Pour plus d'informations, consultez Mise en route avec le clustering de basculement SQL Server (http://go.microsoft.com/fwlink/?LinkId=190953).

Fonctionnalités de l'instance

Une description de chaque groupe de composants s'affiche dans le volet Description en cas de sélection. Vous pouvez choisir n'importe quelle combinaison de cases à cocher. Pour continuer, vous devez faire une sélection.

Fonctionnalités

Description

Services du Moteur de base de données

Le Moteur de base de données SQL Server inclut le Moteur de base de données, le service principal de stockage, de traitement et de protection des données, la réplication, la recherche en texte intégral et les outils d'administration des données relationnelles et XML et le serveur Data Quality Services (DQS).

  • Le Moteur de base de données est le service central qui permet de stocker, traiter et sécuriser les données.

  • Réplication : facultatif : la réplication est un ensemble de technologies qui permettent de copier et de distribuer des données et des objets de base de données d'une base de données vers une autre, puis de synchroniser les bases de données afin de préserver leur cohérence.

  • Recherche en texte intégral : facultatif : la recherche en texte intégral fournit les fonctionnalités nécessaires à l'émission de requêtes de texte intégral sur les données caractères en texte brut des tables SQL Server.

  • Data Quality Services : facultatif : Data Quality Services (DQS) est une solution de nettoyage de données qui vous permet de détecter des données incohérentes et incorrectes dans votre source de données. Par ailleurs, elle vous offre des moyens assistés par ordinateur et interactifs pour nettoyer vos données. Activez cette case à cocher pour installer le serveur DQS. Une fois l'installation de SQL Server terminée, vous devez exécuter le fichier DQSInstaller.exe pour terminer l'installation du serveur DQS. Si vous avez installé l'instance par défaut de SQL Server, ce fichier est disponible sous C:\Program Files\Microsoft SQL Server\MSSQL11.MSS QLSERVER\MSSQL\Binn.

Clusters de basculement SQL Server : les composants de réplication et de recherche en texte intégral sont requis et sélectionnés automatiquement par le programme d'installation pour les installations du clustering de basculement SQL Server lorsque vous sélectionnez Services Moteur de base de données.

Analysis Services

Analysis Services inclut les outils de création et de gestion d'applications de traitement analytique en ligne (OLAP, OnLine Analytical Processing) et d'exploration de données.

Reporting Services – Natif

Le mode natif Reporting Services inclut les composants serveur et clients permettant de créer, de gérer et de déployer des rapports tabulaires, de matrice, graphiques et de forme libre. Reporting Services est également une plateforme évolutive que vous pouvez utiliser pour développer des applications de création de rapports.

Important Important

  1. Le programme d'installation ne configure pas l'équilibrage de charge et l'adressage par URL unique pour les nœuds multiples d'un déploiement par montée en puissance parallèle de Reporting Services. Pour effectuer un déploiement avec montée en puissance parallèle, vous devez utiliser Windows Server, Microsoft Application Center ou un logiciel tiers de gestion de clusters. Pour plus d'informations sur l'installation du déploiement de batterie de serveurs Web, consultez Configuration de Reporting Services pour un déploiement par montée en puissance parallèle (http://go.microsoft.com/fwlink/?LinkId=199448).

  2. Microsoft Internet Explorer 7.0 SP 1 est requis pour le composant Concepteur de rapports de Reporting Services.

  3. Reporting Services n'est pas pris en charge simultanément dans les configurations côte à côte sur la plateforme 64 bits et sur le sous-système 32 bits (WOW64) d'un serveur 64 bits.

Fonctionnalités partagées

Les fonctionnalités partagées par toutes les instances de SQL Server sur un même ordinateur sont installées dans un répertoire unique. Cela comprend les éléments suivants :

Fonctionnalité

Description

Reporting Services- SharePoint

Le mode Reporting Services SharePoint est une application basée sur serveur permettant de créer, de gérer et de livrer des rapports sous forme de courrier électronique, selon plusieurs formats de fichiers et sous forme de formations Web interactives. Le mode SharePoint intègre la consultation et la gestion de rapports avec les produits SharePoint.

Complément Reporting Services pour les produits SharePoint

Le complément Reporting Services pour les produits SharePoint inclut des composants de gestion et d'interface utilisateur permettant d'intégrer un produit SharePoint avec un serveur de rapports Reporting Services en mode SharePoint.

Data Quality Client

Le client de qualité des données est une application autonome qui se connecte au serveur DQS et fournit une interface utilisateur graphique intuitive pour effectuer des opérations de nettoyage et de correspondance des données et effectuer des tâches administratives dans DQS.

Outils de données SQL Server1

Les outils de données SQL Server (SSDT) fournissent un environnement de développement intégré (IDE) permettant de générer des solutions pour les composants Business Intelligence : Analysis Services, Reporting Services et Integration Services.

(Anciennement, Business Intelligence Development Studio.)

SSDT inclut également des « projets de base de données », qui offrent un environnement intégré aux développeurs, afin qu'ils puissent mener à bien leurs travaux de création de bases de données quelle que soit la plateforme SQL Server (sur site et hors site) dans Visual Studio. Les développeurs de bases de données peuvent utiliser l'explorateur de serveurs amélioré de Visual Studio pour créer ou modifier facilement des objets de base de données et des données, ou exécuter des requêtes.

Connectivité des outils clients

Les outils clients incluent les composants permettant la communication entre les clients et les serveurs, notamment les bibliothèques réseau pour DB-Library, OLEDB pour OLAP, ODBC, ADODB et ADOMD+.

Integration Services

Integration Services propose un ensemble d'outils graphiques et d'objets programmables permettant de déplacer, de copier et de transformer les données.

Compatibilité descendante des outils clients

La compatibilité descendante des outils clients inclut les composants suivants :

  • Objets SQL-DMO (Distributed Management Objects). Pour plus d'informations, consultez Fonctionnalités SQL Server supprimées dans SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=190968).

  • DSO (Decision Support Objects). Pour plus d'informations, consultez Modifications avec rupture des fonctionnalités Analysis Services dans SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=190970).

Kit de développement logiciel (SDK) des outils clients

Inclut le Kit de développement logiciel (SDK) contenant des ressources pour les programmeurs.

Composants de documentation

Les composants de documentation incluent les composants permettant d'afficher et de gérer le contenu d'aide.

Outils de gestion - Base

Outils de gestion - De base : Notamment :

  • Prise en charge de SQL Server Management Studio pour le Moteur de base de données SQL Server, SQL Server Express, l'utilitaire sqlcmd et le fournisseur PowerShell SQL Server.

Outils de gestion – Complet : Cela comprend les composants suivants en plus de ceux de la version de base :

  • Prise en charge de SQL Server Management Studio pour Reporting Services, Analysis Services et Integration Services

  • SQL Server Profiler

  • Assistant Paramétrage du moteur de base de données

  • Gestion de l'utilitaire SQL Server

Distributed Replay Controller

Le contrôleur Distributed Replay orchestre les actions des clients de relecture distribuée. Chaque environnement Distributed Replay ne doit contenir qu'une seule instance de contrôleur. Pour plus d'informations, consultez SQL Server Distributed Replay (http://go.microsoft.com/fwlink/?LinkId=229847).

Distributed Replay Client

Les clients Distributed Replay fonctionnent ensemble pour simuler les charges de travail sur une instance de SQL Server. Chaque environnement Distributed Replay peut contenir un ou plusieurs clients. Pour plus d'informations, consultez SQL Server Distributed Replay (http://go.microsoft.com/fwlink/?LinkId=229847).

Kit de développement logiciel (SDK) de l'option Connectivité client de SQL

Inclut le Kit de développement logiciel (SDK) SQL Server Native Client (ODBC/OLE DB) pour le développement d'applications de base de données.

Master Data Services

Master Data Services est une plateforme pour intégrer des données issues de systèmes disparates de toute une organisation dans une source unique de données de référence à des fins de précision et d'audit. L'option Master Data Services installe Gestionnaire de configuration Master Data Services, des assemblys, un composant logiciel enfichable Windows PowerShell et des dossiers et des fichiers pour les applications et services Web.

LocalDB

LocalDB est un mode d'exécution de SQL Server Express destiné aux développeurs de programmes. Initialisé par une chaîne de connexion spéciale, l'infrastructure SQL Server nécessaire est automatiquement créée et démarrée, ce qui permet à l'application d'utiliser la base de données sans tâches de configuration ou de gestion.

1Internet Explorer 6.0 SP1 est requis pour les installations de Outils de données SQL Server (SSDT).

Par défaut, ces composants partagés sont installés dans %Program Files%Microsoft SQL Server\. Pour modifier le chemin d'installation, cliquez sur le bouton Parcourir. La modification du chemin d'installation d'un composant partagé affecte également les autres composants partagés. En effet, les installations ultérieures placeront les composants partagés dans le même emplacement que celui de l'installation d'origine.

Sur les systèmes d'exploitation x64, vous pouvez spécifier où les composants 64 bits doivent être installés et où les composants 32 bits doivent l'être sur le sous-système WOW64.

Installation des exemples de bases de données AdventureWorks

Par défaut, les exemples de bases de données et les exemples de code ne sont pas installés dans le cadre de l'installation de SQL Server. Pour plus d'informations sur l'installation des exemples de bases de données et de code, consultez Projets & exemples de la communauté Microsoft SQL Server (http://go.microsoft.com/fwlink/?LinkId=87843).

Les informations supplémentaires sur les exemples sont disponibles après que Microsoft SQL Server 2012 a été installé. Dans le menu Démarrer, cliquez sur Programmes, sur Microsoft SQL Server 2012, sur Documentation et didacticiels, puis sur Vue d'ensemble des exemples pour Microsoft SQL Server.

Voir aussi

Autres ressources

Éditions et composants de SQL Server 2012


Sélection de composant (Désinstaller)

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Sélection de composant (Désinstaller)
Envoyer des commentaires

Utilisez la page Sélection de composant — Désinstaller pour sélectionner les fonctionnalités à supprimer de l'instance spécifiée de SQL Server.

Options

Vous pouvez choisir n'importe quelle combinaison de fonctionnalités.


Fonctionnalités à mettre à niveau

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Fonctionnalités à mettre à niveau
Voir aussi Envoyer des commentaires

Utilisez la page Fonctionnalités à mettre à niveau de l'Assistant Installation de Microsoft SQL Server 2012 pour afficher les fonctionnalités à mettre à niveau vers Microsoft SQL Server 2012.

Options

  • Il n'est pas possible de modifier les fonctionnalités à mettre à niveau dans cette version. Pour ajouter des fonctionnalités à cette instance de SQL Server, terminez la mise à niveau, redémarrer le programme d'installation, puis cliquez sur Nouvelle installation ou ajout de fonctionnalités à une installation existante dans le centre d'installation.

Voir aussi

Autres ressources

Mises à niveau de la version et de l'édition
Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau
Utilisation de plusieurs versions de SQL Server


Options de mise à niveau de recherche en texte intégral

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Options de mise à niveau de recherche en texte intégral
Envoyer des commentaires

Utilisez la page des options de mise à niveau de recherche en texte intégral de l'Assistant Installation SQL Server pour sélectionner l'option de mise à niveau de recherche en texte intégral à utiliser pour les bases de données que vous mettez actuellement à niveau.

Dans SQL Server 2005 et les versions antérieures, chaque index de recherche en texte intégral réside dans un catalogue de texte intégral qui appartient à un groupe de fichiers, a un chemin d'accès physique et est traité en tant que fichier de base de données. Depuis SQL Server 2008, un catalogue de texte intégral est un concept logique – objet virtuel – qui renvoie à un groupe d'index de recherche en texte intégral. Par conséquent, un nouveau catalogue de texte intégral n'est pas traité en tant que fichier de base de données avec un chemin d'accès physique. Toutefois, un nouveau groupe de fichiers est créé sur le même disque pendant la mise à niveau de tout catalogue de texte intégral qui contient des fichiers de données. Cela maintient le comportement d'E/S de l'ancien disque après la mise à niveau. Tout index de recherche en texte intégral de ce catalogue est placé dans le nouveau groupe de fichiers si le chemin d'accès racine existe. Si l'ancien chemin de catalogue de texte intégral est non valide, la mise à niveau conserve l'index de recherche en texte intégral dans le même groupe de fichiers comme table de base ou, pour une table partitionnée, dans le groupe de fichiers principal.

Options

Lorsque vous effectuez une mise à niveau de SQL Server 2005 ou SQL Server 2008 vers Microsoft SQL Server 2012, choisissez l'une des options de mise à niveau de texte intégral ci-dessous.

Importer

Les catalogues de texte intégral sont importés. En général, l'importation est considérablement plus rapide que lors d'une reconstruction (rebuild). Par exemple, lorsque vous utilisez un seul processeur, l'importation s'exécute approximativement 10 fois plus vite que lors de la reconstruction. Toutefois, les catalogues de texte intégral importés depuis SQL Server 2005 n'utilisent pas les nouveaux analyseurs lexicaux améliorés inclus dans SQL Server 2008, ce qui peut finalement vous obliger à les reconstruire malgré tout.

Remarque Remarque

Le processus de reconstruction peut s'exécuter en mode multithread, et si plus de 10 processeurs sont disponibles, la reconstruction peut s'effectuer plus vite que l'importation si vous la laissez utiliser tous les processeurs.

Si aucun catalogue de texte intégral n'est disponible, les index de recherche en texte intégral associés sont reconstruits. Cette option est disponible uniquement pour les bases de données SQL Server 2005.

Pour plus d'informations sur l'impact de l'importation de l'index de recherche en texte intégral, consultez « Considérations relatives au choix d'une option de mise à niveau », plus loin dans cette rubrique.

Reconstruire

Les catalogues de texte intégral sont reconstruits à l'aide des analyseurs lexicaux nouveaux et améliorés introduits dans SQL Server 2008. La reconstruction des index peut prendre du temps, et une quantité importante de ressources en termes d'UC et de mémoire peut être requise après la mise à niveau.

Réinitialiser

Les catalogues de texte intégral sont réinitialisés. Lors de la mise à niveau à partir de SQL Server 2005, les catalogues de texte intégral sont supprimés, mais les métadonnées pour les catalogues de texte intégral et les index de recherche en texte intégral sont conservées. Après leur mise à niveau, tous les index de recherche en texte intégral ont le suivi des modifications désactivé et aucune analyse n'est démarrée automatiquement. Le catalogue reste vide tant que vous n'avez pas procédé manuellement à une alimentation complète, au terme de la mise à niveau.

Toutes ces options de mise à niveau garantissent que les bases de données mises à niveau bénéficient pleinement des améliorations en termes de performances du texte intégral de SQL Server 2008 et des versions ultérieures.

Important Important

Pour plus d'informations sur l'utilisation des nouveaux analyseurs lexicaux et la mise à niveau des fichiers de mots parasites vers les listes de mots vides après avoir importé un index de recherche en texte intégral SQL Server 2005, consultez la rubrique « Mise à niveau de la fonction de recherche en texte intégral » dans l'aide du programme d'installation de Microsoft SQL Server 2012.

Considérations relatives au choix d'une option de mise à niveau de texte intégral

Au moment de choisir l'option de mise à niveau pour votre mise à niveau, tenez compte des éléments suivants :

  • Comment utilisez-vous les analyseurs lexicaux ?

    Le service de recherche en texte intégral dans Microsoft SQL Server 2012 inclut des analyseurs lexicaux et des générateurs de formes dérivées introduits dans SQL Server 2008. Ceux-ci peuvent modifier les résultats de requêtes de texte intégral de SQL Server 2005 pour un modèle ou scénario de texte spécifique. Par conséquent, la manière dont vous utilisez les analyseurs lexicaux est importante lors du choix d'une option de mise à niveau appropriée :

    • Si les analyseurs lexicaux de la langue de texte intégral que vous utilisez n'ont pas changé dans SQL Server 2008 ou versions ultérieures, ou si l'exactitude de rappel n'est pas critique pour vous, l'importation est appropriée. Ultérieurement, si vous rencontrez des problèmes de rappel, vous pouvez effectuer une mise à niveau vers les nouveaux analyseurs lexicaux en reconstruisant vos catalogues de texte intégral. Pour plus d'informations, consultez la rubrique « Mise à niveau de la fonction de recherche en texte intégral » dans l'aide du programme d'installation de Microsoft SQL Server 2012.

    • Si vous tenez à l'exactitude de rappel et que vous utilisez l'un des analyseurs lexicaux qui ont été améliorés dans SQL Server 2008, la reconstruction est appropriée.

  • Certains index de recherche en texte intégral ont-ils été construits sur la base de colonnes de clés de texte intégral de type Integer ?

    La reconstruction effectue, dans quelques cas, des optimisations internes qui améliorent le performances des requêtes de l'index de recherche en texte intégral mis à niveau. Spécifiquement, si vous avez des catalogues de texte intégral qui contiennent des index de recherche en texte intégral dont la colonne clé de texte intégral de la table de base correspond à un type de données Integer, la reconstruction permet d'obtenir une performance idéale des requêtes de texte intégral après la mise à niveau. Nous recommandons vivement que vous utilisiez l'option Reconstruire dans ce cas.

    Remarque Remarque

    Pour les index de texte intégral dans Microsoft SQL Server 2012, nous recommandons que la colonne servant de clé de texte intégral corresponde à un type de données Integer. Pour plus d'informations, consultez la rubrique « Paramétrage et optimisation des performances (recherche en texte intégral) » dans la documentation en ligne de Microsoft SQL Server 2012.

  • Quelle est la priorité pour obtenir votre instance de serveur en ligne ?

    L'importation ou la reconstruction pendant la mise à niveau mobilise beaucoup de ressources processeur, ce qui retarde la mise à niveau et en ligne du reste de l'instance serveur. Si le fait d'avoir l'instance de serveur en ligne dès que possible est important et si vous êtes disposé à exécuter une alimentation manuelle après la mise à niveau, la réinitialisation est appropriée.


Complète - Installation

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Complète - Installation
Voir aussi Envoyer des commentaires

Cliquez sur Fermer pour terminer l'installation.

Voir aussi

Concepts

Valider une installation SQL Server


Conditions préalables d'installation

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Conditions préalables d'installation
Envoyer des commentaires

Pour que SQL Server soit correctement installé, les composants logiciels suivants sont requis sur l'ordinateur d'installation. Ils sont installés par le programme d'installation de SQL Server :

  • .NET Framework version 4.0 pour toutes les autres éditions de Microsoft SQL Server 2012

  • Fichiers de support d'installation de SQL Server

  • SQL Server Native Client

Remarque Remarque

En cas d'échec ou d'annulation de l'installation, ces composants ne sont pas supprimés. Pour les supprimer, utilisez Ajout/Suppression de programmes dans le Panneau de configuration.

Options

Pour installer les fichiers requis, cliquez sur Installer. Pour quitter l'installation, cliquez sur Annuler.


progression de l'installation

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

progression de l'installation
Voir aussi Envoyer des commentaires

Utilisez la page Progression de l'installation de l'Assistant Installation de SQL Server pour vérifier l'état du programme d'installation de SQL Server.

Voir aussi

Concepts

Afficher et lire les fichiers journaux d'installation de SQL Server


Type d'installation

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Type d'installation
Envoyer des commentaires

Utilisez la page Type d'installation de l'Assistant Installation de SQL Server pour spécifier s'il convient d'installer une nouvelle instance de SQL Server ou d'ajouter des fonctionnalités à une instance existante.

Options

Sélectionnez la case d'option qui correspond à votre choix :

  • Effectuer une nouvelle installation de SQL Server

  • Ajouter des fonctionnalités à une instance existante de SQL Server

    Si vous choisissez d'ajouter des fonctionnalités à une instance existante, utilisez la liste déroulante pour sélectionner l'instance de SQL Server à mettre à jour.

Vous pouvez uniquement ajouter les fonctionnalités prises en charge par SysPrep (moteur de base de données et Reporting Services) à une image préparée de SQL Server. Les autres fonctionnalités qui ne sont pas prises en charge par SysPrep peuvent être ajoutées après que l'instance préparée a été finalisée.

Remarque Vous ne pouvez pas ajouter des fonctionnalités à une instance de cluster de basculement après son installation. Pour ajouter des fonctionnalités SQL Server à un cluster de basculement existant, vous devez effectuer une nouvelle installation pour installer une instance séparée de SQL Server.


Configuration d'une instance

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Configuration d'une instance
Envoyer des commentaires

Utilisez la page Configuration d'une instance de l'Assistant Installation de SQL Server pour spécifier s'il faut créer une instance par défaut ou une instance nommée de SQL Server. Si une instance de SQL Server n'est pas déjà installée, une instance par défaut sera créée à moins que vous ne spécifiiez une instance nommée.

Chaque instance de SQL Server consiste en un ensemble distinct de services avec des paramètres spécifiques pour les classements et les autres options. La structure des répertoires, la structure du Registre et les noms de services reflètent tous le nom de l'instance et l'ID spécifique de l'instance créé durant l'installation de SQL Server.

Une instance est soit l'instance par défaut, soit une instance nommée. MSSQLSERVER est le nom de l'instance par défaut. Il n'est pas nécessaire qu'un client spécifie le nom de l'instance pour établir une connexion. Une instance nommée est déterminée par l'utilisateur au cours de l'installation. Vous pouvez installer SQL Server comme instance nommée sans installer d'abord l'instance par défaut. Une seule installation de SQL Server, indépendamment de la version, peut être à un instant donné l'instance par défaut.

Remarque Remarque

SQL Server SysPrep vous permet de spécifier le nom de l'instance lorsque vous finalisez une instance préparée dans la page Configuration de l'instance. Vous pouvez choisir de configurer l'instance préparée que vous finalisez comme instance par défaut s'il n'existe aucune instance par défaut de SQL Server sur l'ordinateur.

Instances multiples

SQL Server prend en charge plusieurs instances de SQL Server sur un seul serveur ou processeur, mais une seule instance peut être l'instance par défaut. Toutes les autres instances doivent être des instances nommées. Un ordinateur peut exécuter simultanément plusieurs instances SQL Server et chaque instance s'exécute indépendamment des autres.

Pour plus d'informations, consultez Spécifications des capacités maximales pour SQL Server.

Options

Instances de cluster de basculement uniquement — Indiquez le nom réseau du cluster de basculement SQL Server. Ce nom identifie l'instance de cluster de basculement sur le réseau.

Instance par défaut ou instance nommée — Prenez ces informations en compte lorsque vous décidez d'installer une instance par défaut ou une instance nommée de SQL Server :

  • Si vous envisagez d'installer une seule instance de SQL Server sur un serveur de bases de données, ce doit être une instance par défaut.

  • Utilisez une instance nommée lorsque vous envisagez plusieurs instances sur le même ordinateur. Un serveur ne peut héberger qu'une seule instance par défaut.

  • Toute application qui installe SQL Server Express doit l'installer en tant qu'instance nommée. Ce procédé réduit au minimum les conflits liés à l'installation de plusieurs applications sur le même ordinateur.

Instance par défaut

Choisissez cette option pour installer une instance par défaut de SQL Server. Un ordinateur ne peut héberger qu'une instance par défaut ; toutes les autres instances doivent être nommées. Toutefois, si vous avez une instance par défaut de SQL Server installée, vous pouvez ajouter une instance par défaut de Analysis Services sur le même ordinateur.

Instance nommée

Sélectionnez cette option pour créer une nouvelle instance nommée. Prenez en compte les points suivants lorsque vous nommez une instance de SQL Server :

  • Les noms d'instance ne respectent pas la casse.

  • Les noms d'instance ne peuvent pas commencer ni se terminer par un trait de soulignement (_).

  • Les noms d'instance ne peuvent pas contenir le terme « Default » ou autres mots clés réservés. Si un mot clé réservé est utilisé dans le nom d'une instance, une erreur d'installation se produit. Pour plus d'informations, consultez Reserved Keywords (en anglais).

  • Si vous spécifiez MSSQLServer comme nom d'instance, une instance par défaut est créée. Pour SQL Server Express, si vous spécifiez SQLExpress comme nom d'instance, une instance par défaut est créée.

  • Microsoft SQL Server 2012 PowerPivot pour SharePoint est toujours installé comme une instance nommée de « PowerPivot ». Vous ne pouvez pas spécifier de nom d'instance différent pour ce rôle de fonctionnalité.

  • Les noms d'instance sont limités à 16 caractères.

  • Le premier caractère d'un nom d'instance doit être une lettre. Les lettres acceptables sont celles définies par la norme Unicode 2.0. Elles incluent les caractères latins a-z, A-Z et les caractères littéraux des autres langues.

  • Les autres caractères d'un nom d'instance peuvent être des lettres définies par le standard Unicode 2.0, des nombres décimaux provenant de scripts de latin de base ou nationaux, le symbole dollar ($) ou le trait de soulignement (_).

  • Les espaces incorporés ou autres caractères spéciaux ne sont pas autorisés dans les noms d'instance. La barre oblique inverse (\), la virgule (), les deux-points (:), le point-virgule (;), le guillemet simple ('), l'esperluette (&) et l'arobase (@) ne sont pas autorisés non plus.

    Remarque Remarque

    Seuls les caractères valides dans la page de codes Windows en cours sont autorisés dans les noms d'instance SQL Server. En cas d'utilisation d'un caractère Unicode non pris en charge, une erreur d'installation se produit.

Instances et fonctionnalités détectées

Consultez la liste des instances et des composants de SQL Server installés sur l'ordinateur sur lequel le programme d'installation de SQL Server est en cours d'exécution.

ID d'instance - Par défaut, le nom de l'instance est utilisé comme ID d'instance. Il permet d'identifier les répertoires d'installation et les clés de Registre de votre instance SQL Server. Tel est le cas pour les instances par défaut et les instances nommées. Pour une instance par défaut, le nom de l'instance et l'ID d'instance sont MSSQLSERVER. Pour utiliser un ID d'instance non défini par défaut, spécifiez-le dans le champ ID d'instance.

Important Important

Avec SQL Server SysPrep, l'ID d'instance affiché dans cette page correspond à l'ID d'instance spécifié pendant l'étape de préparation d'image du processus SQL Server SysPrep. Vous ne serez pas en mesure de spécifier un ID d'instance différent pendant l'étape de finalisation d'image.

Remarque Remarque

Les ID d'instance qui commencent par un trait de soulignement (_) ou qui contiennent le signe dièse (#) ou le symbole dollar ($) ne sont pas pris en charge.

Pour plus d'informations sur les répertoires, les emplacements de fichiers et la dénomination d'ID d'instance, consultez Emplacements des fichiers pour les instances par défaut et les instances nommées de SQL Server.

Répertoire racine de l'instance - Par défaut, le répertoire racine de l'instance est C:\Program Files\Microsoft SQL Server\. Pour spécifier un répertoire racine non défini par défaut, cliquez sur le bouton Parcourir ou fournissez un nom de chemin d'accès.

Tous les composants d'une instance donnée de SQL Server sont gérés comme une unité. Tous les Service Packs et mises à niveau SQL Server s'appliqueront à chaque composant d'une instance de SQL Server.

Tous les composants de SQL Server qui partagent le même nom d'instance doivent remplir les critères suivants :

  • Même version

  • Même édition

  • Mêmes paramètres de langue

  • Même état cluster

    Remarque Remarque

    Reporting Services n'est pas sensible aux clusters.

  • Même système d'exploitation


Sélection de l'instance (Désinstaller)

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Sélection de l'instance (Désinstaller)
Envoyer des commentaires

Dans la page Sélection de l'instance — Désinstaller, utilisez la zone de liste déroulante pour spécifier l'instance de SQL Server à désinstaller.

Options

Vous pouvez spécifier une instance entière de SQL Server ou bien indiquer que seuls les fonctionnalités partagées et les outils d'administration doivent être désinstallés.


Sélection de l'instance (Mise à niveau)

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Sélection de l'instance (Mise à niveau)
Envoyer des commentaires

Utilisez la page Sélection de l'instance (Mise à niveau) pour spécifier l'instance de SQL Server à mettre à niveau.

Options

Tous les composants d'une instance doivent être mis à niveau simultanément. Vous ne pouvez ajouter ni supprimer des fonctionnalités au cours de la mise à niveau.


Instance à mettre à niveau

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Instance à mettre à niveau
Voir aussi Envoyer des commentaires

Utilisez la page Instance à mettre à niveau de l'Assistant Installation de SQL Server pour spécifier l'instance de SQL Server 2005, SQL Server 2008 ou SQL Server 2008 R2 que vous voulez mettre à niveau vers Microsoft SQL Server 2012.

Options

Utilisez les cases d'option pour spécifier s'il faut mettre à niveau l'instance de SQL Server et ses composants partagés, ou uniquement les composants partagés. Les composants partagés dans cette version de SQL Server sont les suivants :

  • Integration Services

  • SQL Server Browser

  • SQL Server Active Directory Helper

  • SQL Writer

Pour plus d'informations sur les scénarios de mise à niveau pris en charge et sur les problèmes de mise à niveau connus, consultez Mises à niveau de la version et de l'édition.

Voir aussi

Autres ressources

Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau
Utilisation de plusieurs versions de SQL Server


Post-désinstallation

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Post-désinstallation
Envoyer des commentaires

Utilisez la page Post-désinstallation pour vérifier que l'opération a été correctement effectuée.


Progression de la préparation de l'image

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Progression de la préparation de l'image
Voir aussi Envoyer des commentaires

Utilisez la page Progression de la préparation de l'image de l'Assistant Installation de SQL Server pour contrôler l'état d'installation de la préparation de l'image SQL Server. À l'issue de cette étape, cette page répertorie l'état de chaque fonctionnalité SQL Server préparée durant ce processus.

Voir aussi

Concepts

Afficher et lire les fichiers journaux d'installation de SQL Server


Règles de préparation d'image

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Règles de préparation d'image
Envoyer des commentaires

Le programme d'installation de SQL Server valide la configuration de votre ordinateur avant la fin de l'opération d'installation. Lors de l'exécution du programme d'installation de SQL Server, l'outil d'analyse de configuration système (SCC) analyse l'ordinateur sur lequel SQL Server sera installé. L'outil SCC recherche toute anomalie susceptible d'empêcher une installation correcte de SQL Server. Avant que le programme d'installation ne démarre l'Assistant, le SCC extrait l'état de chaque élément. Puis, il compare le résultat avec les conditions requises et fournit une aide pour la suppression des problèmes importants.

La vérification de la configuration du système génère un rapport qui contient une brève description de chaque règle exécutée et de l'état d'exécution. Le rapport de contrôle de configuration du système se trouve à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Avant d'exécuter l'opération d'installation, examinez les rubriques suivantes :

  1. Configurations matérielle et logicielle requises pour l'installation de SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Fonctionnalités prises en charge par les éditions de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considérations sur la sécurité pour une installation de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versions linguistiques locales dans SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Autres références :

  1. Mises à niveau de la version et de l'édition prises en charge(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Avant l'installation du clustering de basculement(http://go.microsoft.com/fwlink/?LinkId=235034)


Préparer le type d'image

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Préparer le type d'image
Envoyer des commentaires

Utilisez la page Préparer le type d'image de l'Assistant Installation de SQL Server pour spécifier s'il convient d'installer une nouvelle instance de Microsoft SQL Server 2012 ou d'ajouter des fonctionnalités à une instance existante.

Options

Sélectionnez la case d'option qui correspond à votre choix :

  • Préparer une nouvelle instance de Microsoft SQL Server 2012

  • Ajouter des fonctionnalités à une instance préparée existante de Microsoft SQL Server 2012

    Si vous choisissez d'ajouter des fonctionnalités à une instance existante, utilisez la liste déroulante pour sélectionner l'instance préparée de SQL Server à mettre à jour.

    Remarque Remarque

    Vous pouvez ajouter les fonctionnalités prises en charge SQL Server SysPrep (Moteur de base de données et Reporting Services) à une image préparée de SQL Server. Les autres fonctionnalités qui ne sont pas prises en charge par SQL Server SysPrep peuvent être ajoutées uniquement après que l'instance préparée a été finalisée.


Clé du produit

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Clé du produit
Envoyer des commentaires

Utilisez la page Clé du produit pour valider votre instance de SQL Server ou indiquer l'édition gratuite de SQL Server à installer.

Options

Pour indiquer une édition gratuite de SQL Server, sélectionnez la case d'option qui correspond aux installations gratuites, puis utilisez la zone de liste déroulante pour identifier l'édition à installer.

Pour valider une édition payante de SQL Server, sélectionnez la case d'option qui correspond à la clé du produit, puis indiquez votre clé dans l'espace fourni.

Pour les installations de cluster de basculement, utilisez la même clé de produit pour chaque nœud de cluster de basculement. Si la clé du produit provient d'une autre édition de SQL Server, une erreur se produit.


Progression (Désinstaller)

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Progression (Désinstaller)
Voir aussi Envoyer des commentaires

Utilisez la page Progression (Désinstaller) pour contrôler la progression du programme l'installation.

Voir aussi

Concepts

Afficher et lire les fichiers journaux d'installation de SQL Server


Prêt à finaliser l'image

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Prêt à finaliser l'image
Envoyer des commentaires

La page Prêt à finaliser l'image fournit un résumé des paramètres de configuration appliqués à la configuration de l'instance préparée.

Options

La page affiche les options suivantes :

  • Pour continuer l'installation, cliquez sur Installer.

  • Pour modifier vos paramètres d'installation, cliquez sur Précédent.

  • Pour quitter le programme d'installation, cliquez sur Annuler.


Prêt pour l'installation

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Prêt pour l'installation
Voir aussi Envoyer des commentaires

La page Prêt pour l'installation fournit un résumé des fonctionnalités qui doivent être installées ou modifiées par le programme d'installation de SQL Server.

Options

La page affiche les options suivantes :

  • Pour continuer l'installation, cliquez sur Installer.

  • Pour modifier vos paramètres d'installation, cliquez sur Précédent.

  • Pour quitter le programme d'installation, cliquez sur Annuler.

Voir aussi

Concepts

Afficher et lire les fichiers journaux d'installation de SQL Server


Prêt à préparer l'image

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Prêt à préparer l'image
Envoyer des commentaires

La page Prêt à préparer l'image fournit un résumé des fonctionnalités devant être préparées par le programme d'installation de SQL Server.

Options

La page affiche les options suivantes :

  • Pour continuer l'installation, cliquez sur Installer.

  • Pour modifier vos paramètres d'installation, cliquez sur Précédent.

  • Pour quitter le programme d'installation, cliquez sur Annuler.


Prêt à réparer

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Prêt à réparer
Voir aussi Envoyer des commentaires

La page Prêt à réparer fournit un résumé du processus de réparation par le programme d’installation de SQL Server.

Options

La page affiche les options suivantes :

  • Pour continuer l'installation, cliquez sur Réparer.

  • Pour modifier vos paramètres d'installation, cliquez sur Précédent.

  • Pour quitter le programme d'installation, cliquez sur Annuler.

Voir aussi

Concepts

Afficher et lire les fichiers journaux d'installation de SQL Server


Supprimer un nœud de cluster de basculement SQL Server

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Supprimer un nœud de cluster de basculement SQL Server
Envoyer des commentaires

Utilisez la page Supprimer un nœud de cluster de basculement pour identifier l'ordinateur à supprimer en tant que nœud de cluster de basculement Microsoft SQL Server 2012.


Progression de la réparation

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Progression de la réparation
Voir aussi Envoyer des commentaires

Utilisez la page Progression de la réparation de l'Assistant Installation de SQL Server pour vérifier l'état de la réparation de SQL Server.

Voir aussi

Concepts

Afficher et lire les fichiers journaux d'installation de SQL Server


Options de configuration Reporting Services (SSRS)

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Options de configuration Reporting Services (SSRS)
Voir aussi Envoyer des commentaires

Utilisez la page Configuration de Reporting Services de l'Assistant Installation de Microsoft SQL Server pour spécifier le mode d'installation et de configuration d'un serveur de rapports. La disponibilité d'une option d'installation dépend des options que vous avez choisies précédemment dans la page Sélection de fonctionnalités, ainsi que du fait que vous installez également ou non une instance locale du Moteur de base de données SQL Server lors de l'installation du serveur de rapports.

Dans certains cas, si un certificat SSL (Secure Sockets Layer) est installé sur l'ordinateur et lié à un caractère générique fort, le programme d'installation crée les URL Reporting Services à l'aide du préfixe HTTPS. Pour plus d'informations sur la façon dont les certificats sont mappés aux URL Reporting Services, consultez Configuration d'un serveur de rapports pour des connexions SSL (Secure Sockets Layer) (http://go.microsoft.com/fwlink/?LinkId=199089) dans la documentation en ligne de SQL Server.

Pour obtenir les dernières informations sur Reporting Services et sur l'installation et la configuration de cette version, consultez Informations supplémentaires sur l'installationhttp://go.microsoft.com/fwlink/?LinkId=207425 (http://go.microsoft.com/fwlink/?LinkId=207425).

Options

Mode natif de Reporting Services

Si le programme d'installation ne peut pas configurer le serveur de rapports par défaut, car une ou plusieurs conditions requises ne sont pas respectées, l'Assistant Installation n'autorise que l'option d'installation minimale ; les fichiers dont vous avez besoin sont copiés mais vous êtes obligé d'utiliser le Gestionnaire de configurations de Reporting Services pour configurer un serveur de rapports en mode natif à la fin de l'installation.

Remarque Remarque

Un fichier de base de données de serveur de rapports existant peut entraîner l'échec de l'installation si vous choisissez l'une des options d'installation par défaut. Lorsque vous choisissez une option d'installation par défaut, le programme d'installation tente de créer une base de données de serveur de rapports à l'aide du nom par défaut. Si une base de données existe déjà sous ce nom, le programme d'installation échoue et vous devez restaurer l'installation. Pour éviter ce problème, renommez la base de données existante avant d'exécuter le programme d'installation ou choisir l'option Installer uniquement afin de pouvoir spécifier des paramètres de base de données personnalisés une fois l'installation terminée.

Installation et configuration

Installe une instance du serveur de rapports en mode natif en utilisant les valeurs par défaut pour les bases de données, le compte de service et les réservations d'URL du serveur de rapports. Lorsque vous choisissez cette option, l'instance du serveur de rapports est prête à être utilisée à la fin de l'installation. Le programme d'installation crée la base de données du serveur de rapports à l'aide d'une instance locale du Moteur de base de données, puis configure un serveur de rapports pour l'utilisation des valeurs par défaut.

Cette option n'est disponible que si les valeurs par défaut utilisées dans l'installation d'un serveur de rapports sont valides pour votre système. Cette option est recommandée pour les développeurs qui souhaitent installer tous les composants localement, ainsi que pour les utilisateurs qui évaluent le logiciel.

Pour afficher les informations relatives aux paramètres par défaut utilisés par le programme d'installation ou pour déterminer la raison pour laquelle la configuration par défaut ne peut pas être installée, cliquez sur Détails. Pour plus d'informations sur la configuration par défaut pour un serveur de rapports en mode natif, consultez Configuration par défaut pour une installation en mode natif (Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199091).

Installer uniquement

Installe les fichiers programme du serveur de rapports, crée le compte de service Report Server et inscrit le fournisseur WMI (Windows Management Instrumentation) du serveur de rapports. Cette option d'installation porte également le nom d'installation de « fichiers uniquement ». Sélectionnez cette option si vous ne souhaitez pas utiliser la configuration par défaut. Si la configuration par défaut ne peut pas être installée, ou si vous installez un cluster de basculement SQL Server qui inclut Reporting Services, il s'agit de la seule option disponible. Pour plus d'informations sur une installation de fichiers uniquement, consultez Installation de fichiers uniquement (Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199093).

Une fois l'installation terminée, vous devez créer la base de données du serveur de rapports et configurer le serveur de rapports de sorte qu'il puisse être utilisé. Pour configurer un serveur de rapports et créer la base de données correspondante, utilisez le gestionnaire de configuration de Reporting Services. Pour plus d'informations, consultez Procédure : créer une base de données du serveur de rapports (configuration de Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199094) et Configuration d'une connexion à la base de données du serveur de rapports (http://go.microsoft.com/fwlink/?LinkId=199095).

Mode SharePoint de Reporting Services

Installer uniquement

Installe les fichiers programmes du serveur de rapports, ainsi que les applets de commande PowerShell. Une fois l'installation terminée, vous devez démarrer les services Reporting Services SharePoint et créer une application de service Reporting Services. Pour plus d'informations, consultez, Présentation de l'installation et de la configuration du service Reporting Services pour l'intégration SharePoint (http://go.microsoft.com/fwlink/?LinkId=207543), Créer une application de service SQL Server Reporting Services (http://go.microsoft.com/fwlink/?LinkId=207544), et Présentation de Reporting Services et de l'intégration SharePoint (http://go.microsoft.com/fwlink/?LinkID=207244).

Installation du complément Reporting Services pour les technologies SharePoint

À partir de la version Microsoft SQL Server 2012 le complément peut être installé avec l'installation de SQL Server, dans la page de sélection de fonctionnalités de l'Assistant Installation de SQL Server.

Toutefois, vous pouvez installer le complément Reporting Services pour SharePoint 2010 à l'aide d'une des méthodes suivantes :

  • Exécutez l'outil de préparation des produits SharePoint 2010, PreRequisiteInstaller.exe.

  • Effectuez l'installation depuis le support d'installation de SQL Server. Cliquez sur le fichier rsSharePoint.msi dans le dossier d'installation sur le support d'installation SQL Server une fois l'installation de SQL Server terminée.

  • Téléchargez et installez le complément. Pour plus d'informations, consultez Où trouver le complément Reporting Services pour les produits SharePoint (http://go.microsoft.com/fwlink/?LinkID=208634).

Voir aussi

Autres ressources

Procédure : lancer le Gestionnaire de configuration de Reporting Services
Procédure : créer une base de données du serveur de rapports (configuration de Reporting Services)
Considérations sur l'installation de Reporting Services
Configuration par défaut pour une installation en mode natif (Reporting Services)
Configuration par défaut pour le mode SharePoint (Reporting Services)
Installer SQL Server à partir de l'invite de commandes


Mise à niveau en mode SharePoint de Reporting Services (SSRS)

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Mise à niveau en mode SharePoint de Reporting Services (SSRS)
Voir aussi Envoyer des commentaires

Utilisez la page Mode SharePoint de Reporting Services pour confirmer la mise à niveau de toutes les fonctionnalités partagées. Le mode SharePoint de Reporting Services est une fonctionnalité partagée de SQL Server et sera mis à niveau avec toutes les autres fonctionnalités partagées de SQL Server. L'assistant Installation de SQL Server ne prend pas en charge la mise à jour d'une seule fonctionnalité partagée. Toutes les fonctionnalités partagées de SQL Server sont mises à niveau à la fois.

Options

Le bouton Suivant est disponible uniquement si vous avez coché la case Continuer la mise à niveau. Si vous n'activez pas la case à cocher, vous ne pouvez pas continuer la mise à niveau.

Pour plus d'informations, consultez Mise à niveau de Reporting Services (http://go.microsoft.com/fwlink/?LinkId=199092).

Voir aussi

Concepts

Afficher et lire les fichiers journaux d'installation de SQL Server

Autres ressources

Installer SQL Server à partir de l'invite de commandes


Authentification en mode SharePoint de Reporting Services

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Authentification en mode SharePoint de Reporting Services
Voir aussi Envoyer des commentaires

Utilisez la page Authentification en mode SharePoint de Reporting Services de l'Assistant Installation de Microsoft SQL Server pour spécifier les informations d'identification du compte de service utilisé dans l'installation actuelle de Reporting Services. Les informations d'identification seront utilisées pour créer un pool d'applications SharePoint. Une application de service SharePoint Reporting Services sera également créée. Le nom de l'application de service contiendra le nom de l'instance précédente de Reporting Services.

Options

  • L'option Nom de compte de pool d'applications SSRS : est en lecture seule. La valeur est automatiquement remplie avec la valeur actuelle de l'installation existante Reporting Services que vous mettez à niveau.

  • L'option Mot de passe du compte du pool d'applications SSRS : sera désactivée si le compte de pool d'applications ne nécessite pas de mot de passe. Par exemple, “NT Authority\NetworkSerivce”. Si le compte de pool d'applications nécessite un mot de passe, vous ne pouvez pas poursuivre la mise à niveau tant que vous ne tapez pas le mot de passe correct.

Pour plus d'informations, consultez Mise à niveau de Reporting Services (http://go.microsoft.com/fwlink/?LinkId=199092).

Voir aussi

Autres ressources

Mise à niveau de Reporting Services


Sélectionner une instance préparée

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Sélectionner une instance préparée
Envoyer des commentaires

Utilisez la page Sélectionner une instance préparée pour spécifier l'instance préparée que vous souhaitez finaliser.

Options

La zone Sélectionner un ID d'instance répertorie les instances préparées que vous pouvez finaliser. Sélectionnez une instance préparée que vous souhaitez finaliser.

Sélectionner un ID d'instance

La liste inclut toutes les instances préparées que vous pouvez finaliser sur l'ordinateur sur lequel le programme d'installation SQL Server s'exécute. Sélectionnez une instance préparée que vous souhaitez finaliser.

Instances installées

Cette liste inclut les instances installées, préparées et finalisées.


Configuration du serveur - Classement

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Configuration du serveur - Classement
Envoyer des commentaires

Dans la page Configuration du serveur - Classement de l'Assistant Installation de SQL Server, vous pouvez modifier les paramètres de classement utilisés par le moteur de base de données et Analysis Services pour le tri. Sélectionnez l'option pour correspondre aux paramètres de classement de différentes installations de SQL Server ou d'un autre ordinateur.

Options

Personnaliser pour SQL Server et Analysis Services

SQL Server fournit deux groupes de classements : les classements Windows et les classements SQL Server. Vous pouvez spécifier des paramètres de classement distincts pour le moteur de base de données et pour Analysis Services ou spécifier le même classement pour tous les deux.

Par défaut, un classement SQL Server est sélectionné pour les paramètres régionaux système de langue anglaise (US). Le classement par défaut pour les versions localisées de SQL Server est la valeur des paramètres régionaux système Windows pour votre ordinateur. Pour plus d'informations, consultez Using SQL Collations.

Les paramètres par défaut ne doivent être modifiés que si le paramètre de classement de cette installation de SQL Server doit se conformer aux paramètres de classement utilisés par une autre instance de SQL Server ou aux paramètres régionaux système Windows d'un autre ordinateur.

Remarque Analysis Services utilise uniquement les classements Windows. Si vous prévoyez d'installer Analysis Services, sélectionnez un classement Windows pendant l'exécution du programme d'installation de SQL Server afin de garantir des résultats cohérents entre le moteur de base de données SQL Server et Analysis Services.

Pour plus d'informations, consultez Paramètres de classement du programme d'installation.

Recommandations

Pour plus d'informations sur une table de paramètres régionaux système Windows et les classements par défaut correspondants utilisés par le programme d'installation de SQL Server, consultez Paramètres de classement du programme d'installation.

Dans la mesure du possible, choisissez un classement unique pour votre organisation. De cette manière, vous n'avez pas à spécifier explicitement le classement pour chaque base de données, colonne, expression ou identificateur. Si vous devez utiliser plusieurs classements et paramètres de page de codes, codez vos requêtes conformément aux règles de priorité des classements. Pour plus d'informations, consultez la rubrique Priorité de classement (Transact-SQL) dans la documentation en ligne.

Lorsque vous sélectionnez un classement pour SQL Server, considérez les recommandations suivantes :

  • Sélectionnez un classement BINARY2 si le classement basé sur les points de code binaires est acceptable.

  • Sélectionnez un classement Windows pour une comparaison cohérente entre les différents types de données.

  • Utilisez le nouveau classement de niveau 100 pour une meilleure prise en charge du tri linguistique. Pour plus d'informations, consultez Prise en charge d'Unicode et du classement.

  • Si vous prévoyez de migrer une base de données vers l'instance mise à niveau de SQL Server, sélectionnez le classement qui correspond au classement existant de la base de données.


Configuration du serveur - Comptes de service

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Configuration du serveur - Comptes de service
Voir aussi Envoyer des commentaires

Utilisez la page Configuration du serveur de l'Assistant Installation de SQL Server pour attribuer des comptes de connexion aux services SQL Server. Les services configurés dans cette page dépendent des fonctionnalités que vous avez sélectionnées.

Les comptes de démarrage utilisés pour démarrer et exécuter SQL Server peuvent être des comptes d'utilisateurs de domaine, des comptes d'utilisateurs locaux, des comptes de service administré, des comptes virtuels ou des comptes système intégrés.

Options

Vous pouvez attribuer le même compte de connexion à tous les services SQL Server ou configurer chaque compte de service individuellement. Vous pouvez également spécifier si les services démarrent automatiquement, sont démarrés manuellement ou sont désactivé. Le compte par défaut est recommandé pour la plupart des installations.

  • Sous Windows 7 et Windows Server 2008 R2, la plupart des comptes correspondent par défaut à un compte virtuel.

  • Sous Windows Vista et Windows Server 2008, la plupart des comptes correspondent par défaut au compte NETWORK SERVICE.

  • Sur une installation de cluster sous Windows Server 2008, vous devez fournir un compte de domaine.

Si vous configurez des services afin d'utiliser des comptes de domaine, Microsoft vous recommande de configurer les comptes de service individuellement afin de fournir des privilèges moindres pour chaque service, où les services SQL Server disposent des autorisations minimales requises pour effectuer leurs tâches. Pour plus d'informations, et notamment pour obtenir une description des types de comptes, consultez Configuration des comptes de service Windows

Configurer les comptes de service SQL Server individuellement (recommandé)

Utilisez la grille pour attribuer à chaque service SQL Server un nom d'utilisateur et un mot de passe d'ouverture de session et définir le type de démarrage pour le service. Vous pouvez utiliser des comptes système intégrés, un compte local, un groupe local, un groupe de domaine ou des comptes d'utilisateurs de domaine pour les services SQL Server.

Sélectionnez l'un des services suivants pour en personnaliser les paramètres.

Sélectionnez ce service

Pour configurer les paramètres d'authentification pour

SQL Server Agent

Service qui exécute les travaux, analyse SQL Server et autorise l'automatisation de certaines tâches administratives.

Il n'y a aucun compte d'ouverture de session par défaut pour ce service.

Le type de démarrage par défaut est Manuel.

SQL Server

Le moteur de base de données SQL Server.

Le type de démarrage par défaut est Automatique.

Remarque Remarque

SQL Server Browser

SQL Server Browser est le service de résolution des noms qui fournit des informations de connexion SQL Server aux ordinateurs clients. Ce service est partagé entre plusieurs instances SQL Server et Integration Services.

Le compte d'ouverture de session par défaut est AUTORITE NT\Service local ; il ne peut pas être modifié durant l'installation de SQL Server. Vous pouvez modifier le compte une fois l'installation terminée.

Si le type de démarrage n'est pas spécifié pendant l'installation, il est déterminé comme suit :

  • La valeur Automatique est affectée au démarrage de SQL Server Browser et ce dernier s'exécute dans les scénarios d'installation décrits ci-dessous :

    • Instance de cluster de basculement SQL Server

    • Instance nommée de SQL Server où est activé le protocole TCP ou celui des canaux nommés

    • Instance nommée du serveur d'analyse non cluster

  • Si aucun des scénarios ci-dessus ne s'applique et si SQL Server Browser est déjà installé, l'état actuel de SQL Server Browser est conservé.

  • La valeur Désactivé est affectée au type de démarrage et ce dernier est arrêté en l'absence d'une instance de SQL Server 2005 ou SQL Server 2008 ou SQL Server 2008 R2 avant l'installation.

Analysis Services

Analysis Services.

Le type de démarrage par défaut est Automatique.

Pour le mode intégré SharePoint, vous devez spécifier un compte d'utilisateur de domaine Windows. Le compte que vous spécifiez est utilisé pour le service Analysis Services. Le compte que vous spécifiez pour l'instance actuelle doit également être utilisé pour toutes les instances Analysis Services supplémentaires que vous ajoutez par la suite à la même batterie.

Reporting Services

Reporting Services. Les comptes de service sont utilisés pour configurer une connexion à la base de données du serveur de rapports. Choisissez le service réseau intégré si vous souhaitez utiliser les paramètres d'authentification par défaut. Si vous spécifiez un compte d'utilisateur de domaine, assurez-vous d'inscrire un nom principal de service (SPN) pour ce compte si vous utilisez l'authentification Windows sur le serveur de rapports. Pour plus d'informations, consultez Procédure : configurer l'authentification Windows dans Reporting Services.

Important Important

Microsoft vous recommande de ne pas utiliser le compte Service réseau pour les services SQL Server ou SQL Server Agent si un compte disposant de privilèges moindres est disponible, car Service réseau est un compte partageable. Service réseau convient uniquement à une utilisation comme compte de service SQL Server si vous pouvez garantir qu'aucun autre service qui utilise le compte n'est installé sur l'ordinateur. Les comptes Utilisateur local ou Utilisateur de domaine qui ne sont pas administrateur Windows sont plus appropriés pour les services SQL Server.

Le type de démarrage par défaut est Automatique.

Integration Services

Integration Services propose un ensemble d'outils graphiques et d'objets programmables permettant de déplacer, de copier et de transformer les données.

Le type de démarrage par défaut est Automatique.

Lanceur de démon de filtre de texte intégral SQL Server

Service qui crée les processus fdhost.exe. Ce service est obligatoire pour héberger les analyseurs lexicaux et filtres qui traitent les données textuelles pour l'indexation de texte intégral.

Si vous fournissez un compte de domaine dans lequel exécuter le service de lancement FDHOST, nous vous recommandons vivement d'utiliser un compte à faibles privilèges. Ce compte doit être différent de celui que vous utilisez pour le service SQL Server. Sur Windows Vista et Windows Server 2008, le compte du service du lanceur FDHOST prend pour valeur par défaut SERVICE LOCAL.

SQL Server Distributed Replay Client

Compte de service utilisé pour le service Distributed Replay Client.

Fournissez un compte dans lequel exécuter le service Distributed Replay Client. Ce compte doit être différent de celui que vous utilisez pour le service SQL Server.

Le type de démarrage par défaut est Manuel.

SQL Server Distributed Replay Controller

Compte de service utilisé pour le service Distributed Replay Controller.

Fournissez un compte dans lequel exécuter le service Distributed Replay Controller. Ce compte doit être différent de celui que vous utilisez pour le service SQL Server.

Le type de démarrage par défaut est Manuel.

Voir aussi

Autres ressources

Considérations sur la sécurité pour une installation SQL Server


Rôle d'installation

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Rôle d'installation
Voir aussi Envoyer des commentaires

Utilisez cette page pour spécifier s'il convient d'utiliser la page Sélection de fonctionnalités pour sélectionner des fonctionnalités individuelles, ou de procéder à l'installation à l'aide d'un rôle d'installation.

Un setup role est une sélection fixe de toutes les fonctionnalités et composants partagés qui sont requis pour implémenter une configuration SQL Server prédéfinie.

Options

Installation de fonctionnalités SQL Server

Choisissez cette option pour sélectionner des fonctionnalités individuelles et des composants partagés. Les fonctionnalités de l'instance incluent les services de moteur de base de données, Analysis Services (mode natif) et Reporting Services.

SQL Server PowerPivot pour SharePoint

Choisissez cette option pour installer les composants serveur Analysis Services dans une batterie de serveurs SharePoint 2010. Cette option déploie le service système PowerPivot et le serveur Analysis Services dans une batterie, ce qui active le traitement des requêtes et des données à grande échelle pour les classeurs Excel publiés qui contiennent des données PowerPivot incorporées.

Vous pouvez éventuellement ajouter une instance de moteur de base de données relationnelle à votre installation si vous voulez qu'elle héberge des bases de données dans une batterie SharePoint. Si la batterie est déjà configurée, vous pouvez ignorer cette option.

Une fois l'installation terminée, vous devez configurer le logiciel à l'aide de l'une des méthodes suivantes : outil de configuration PowerPivot, applets de commande PowerShell ou Administration centrale de SharePoint 2010. Contrairement aux versions antérieures, le programme d'installation n'effectue plus les tâches de configuration pour une installation PowerPivot.

Une installation basée sur les rôles n'inclut pas l'application cliente SQL Server PowerPivot pour Excel. L'application cliente est installée séparément.

Toutes les fonctionnalités avec les valeurs par défaut

Choisissez ce rôle d'installation pour installer toutes les fonctionnalités qui sont disponibles pour cette version. Notez que PowerPivot pour SharePoint est exclu de ce rôle. Vous devez utiliser le rôle d'installation PowerPivot pour SharePoint pour installer cette fonctionnalité.

Le moteur de base de données est configuré pour démarrer à l'aide du compte NT AUTHORITY\NETWORK SERVICE. L'utilisateur actuel sera configuré en tant que membre du rôle sysadmin SQL Server. Les valeurs définies par cette option peuvent être remplacées en spécifiant des paramètres de ligne de commande supplémentaires.

Sur Windows Vista ou Windows Server 2008 ou version ultérieure, lorsque le système d'exploitation n'est pas un contrôleur de domaine, par défaut, le moteur de base de données et Reporting Services utiliseront le compte NTAUTHORITY\NETWORK SERVICE, Integration Services utilisera le compte NTAUTHORITY\NETWORK SERVICE et le Lanceur de démon de filtre de texte intégral SQL utilisera le compte NTAUTHORITY\LOCAL SERVICE.

Voir aussi

Référence

Sélection de fonctionnalités

Autres ressources

Installation de PowerPivot pour SharePoint
Configuration matérielle et logicielle requise (PowerPivot pour SharePoint)


Assistant Cluster de basculement SQL Server - Terminé

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Assistant Cluster de basculement SQL Server - Terminé
Voir aussi Envoyer des commentaires

Le programme d'installation de SQL Server valide la configuration de votre ordinateur avant la fin de l'opération d'installation. Lors de l'exécution du programme d'installation de SQL Server, l'outil d'analyse de configuration système (SCC) analyse l'ordinateur sur lequel SQL Server sera installé. L'outil SCC recherche toute anomalie susceptible d'empêcher une installation correcte de SQL Server. Avant que le programme d'installation ne démarre l'Assistant Installation de SQL Server, le SCC extrait l'état de chaque élément. Puis, il compare le résultat avec les conditions requises et fournit une aide pour la suppression des problèmes importants.

La vérification de la configuration du système génère un rapport qui contient une brève description de chaque règle exécutée et de l'état d'exécution. Le rapport de contrôle de configuration du système se trouve à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Avant d'exécuter l'opération d'installation, examinez les rubriques suivantes :

  1. Configurations matérielle et logicielle requises pour l'installation de SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Fonctionnalités prises en charge par les éditions de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considérations sur la sécurité pour une installation de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versions linguistiques locales dans SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Autres références :

  1. Mises à niveau de la version et de l'édition prises en charge(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Avant l'installation du clustering de basculement(http://go.microsoft.com/fwlink/?LinkId=235034)

Voir aussi

Référence

Règles de support du programme d'installation


Assistant Cluster de basculement SQL Server - Installer

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Assistant Cluster de basculement SQL Server - Installer
Voir aussi Envoyer des commentaires

Le programme d'installation de SQL Server valide la configuration de votre ordinateur avant la fin de l'opération d'installation. Lors de l'exécution du programme d'installation de SQL Server, l'outil d'analyse de configuration système (SCC) analyse l'ordinateur sur lequel SQL Server sera installé. L'outil SCC recherche toute anomalie susceptible d'empêcher une installation correcte de SQL Server. Avant que le programme d'installation ne démarre l'Assistant Installation de SQL Server, le SCC extrait l'état de chaque élément. Puis, il compare le résultat avec les conditions requises et fournit une aide pour la suppression des problèmes importants.

La vérification de la configuration du système génère un rapport qui contient une brève description de chaque règle exécutée et de l'état d'exécution. Le rapport de contrôle de configuration du système se trouve à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Avant d'exécuter l'opération d'installation, examinez les rubriques suivantes :

  1. Configurations matérielle et logicielle requises pour l'installation de SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Fonctionnalités prises en charge par les éditions de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considérations sur la sécurité pour une installation de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versions linguistiques locales dans SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Autres références :

  1. Mises à niveau de la version et de l'édition prises en charge(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Avant l'installation du clustering de basculement(http://go.microsoft.com/fwlink/?LinkId=235034)

Voir aussi

Référence

Règles de support du programme d'installation


Assistant Cluster de basculement SQL Server - Préparer

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Assistant Cluster de basculement SQL Server - Préparer
Voir aussi Envoyer des commentaires

Le programme d'installation de SQL Server valide la configuration de votre ordinateur avant la fin de l'opération d'installation. Lors de l'exécution du programme d'installation de SQL Server, l'outil d'analyse de configuration système (SCC) analyse l'ordinateur sur lequel SQL Server sera installé. L'outil SCC recherche toute anomalie susceptible d'empêcher une installation correcte de SQL Server. Avant que le programme d'installation ne démarre l'Assistant Installation de SQL Server, le SCC extrait l'état de chaque élément. Puis, il compare le résultat avec les conditions requises et fournit une aide pour la suppression des problèmes importants.

La vérification de la configuration du système génère un rapport qui contient une brève description de chaque règle exécutée et de l'état d'exécution. Le rapport de contrôle de configuration du système se trouve à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Avant d'exécuter l'opération d'installation, examinez les rubriques suivantes :

  1. Configurations matérielle et logicielle requises pour l'installation de SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Fonctionnalités prises en charge par les éditions de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considérations sur la sécurité pour une installation de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versions linguistiques locales dans SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Autres références :

  1. Mises à niveau de la version et de l'édition prises en charge(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Avant l'installation du clustering de basculement(http://go.microsoft.com/fwlink/?LinkId=235034)

Voir aussi

Référence

Règles de support du programme d'installation


Résumé (Mise à niveau)

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Résumé (Mise à niveau)
Envoyer des commentaires

Utilisez la page Résumé pour afficher les options spécifiées pour cette mise à niveau.


Règles de support du programme d'installation

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Règles de support du programme d'installation
Envoyer des commentaires

Le programme d'installation de SQL Server valide la configuration de votre ordinateur avant la fin de l'opération d'installation. Lors de l'exécution du programme d'installation de SQL Server, l'outil d'analyse de configuration système (SCC) analyse l'ordinateur sur lequel SQL Server sera installé. L'outil SCC recherche toute anomalie susceptible d'empêcher une installation correcte de SQL Server. Avant que le programme d'installation ne démarre l'Assistant Installation de SQL Server, le SCC extrait l'état de chaque élément. Puis, il compare le résultat avec les conditions requises et fournit une aide pour la suppression des problèmes importants.

La vérification de la configuration du système génère un rapport qui contient une brève description de chaque règle exécutée et de l'état d'exécution. Le rapport de contrôle de configuration du système se trouve à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Avant d'exécuter l'opération d'installation, examinez les rubriques suivantes :

  1. Configurations matérielle et logicielle requises pour l'installation de SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Fonctionnalités prises en charge par les éditions de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considérations sur la sécurité pour une installation de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versions linguistiques locales dans SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Autres références :

  1. Mises à niveau de la version et de l'édition prises en charge(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Avant l'installation du clustering de basculement(http://go.microsoft.com/fwlink/?LinkId=235034)

Rubriques supplémentaires relatives aux règles

Consultez les rubriques suivantes pour des règles d'installation spécifiques au scénario :

  • Règles d'installation

  • Mettre à niveau le contrôle des règles

  • Règles de mise à niveau de l'édition

  • Règles de désinstallation

  • Règles de préparation d'image

  • Règles de finalisation d'image


Règles de désinstallation

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Règles de désinstallation
Voir aussi Envoyer des commentaires

La page Règles de désinstallation exécute un ensemble de règles pour garantir le succès de l'installation.

Le programme d'installation de SQL Server valide la configuration de votre ordinateur avant la fin de l'opération d'installation. Lors de l'exécution du programme d'installation de SQL Server, l'outil d'analyse de configuration système (SCC) analyse l'ordinateur sur lequel SQL Server sera installé. L'outil SCC recherche toute anomalie susceptible d'empêcher une installation correcte de SQL Server. Avant que le programme d'installation ne démarre l'Assistant Désinstallation de SQL Server, l'outil SCC extrait l'état de chaque élément. Puis, il compare le résultat avec les conditions requises et fournit une aide pour la suppression des problèmes importants.

La vérification de la configuration du système génère un rapport qui contient une brève description de chaque règle exécutée et de l'état d'exécution. Le rapport de contrôle de configuration du système se trouve à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Avant d'exécuter l'opération d'installation, examinez les rubriques suivantes :

  1. Configurations matérielle et logicielle requises pour l'installation de SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Fonctionnalités prises en charge par les éditions de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considérations sur la sécurité pour une installation de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versions linguistiques locales dans SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Autres références :

  1. Mises à niveau de la version et de l'édition prises en charge(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Avant l'installation du clustering de basculement(http://go.microsoft.com/fwlink/?LinkId=235034)

Voir aussi

Référence

Règles de support du programme d'installation


Progression de la mise à niveau

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Progression de la mise à niveau
Voir aussi Envoyer des commentaires

Utilisez la page Progression de la mise à niveau de l'Assistant Installation de SQL Server pour vérifier l'état de la mise à niveau de SQL Server.

Voir aussi

Concepts

Afficher et lire les fichiers journaux d'installation de SQL Server


Mettre à niveau le contrôle des règles

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Mettre à niveau le contrôle des règles
Voir aussi Envoyer des commentaires

Le programme d'installation de SQL Server valide la configuration de votre ordinateur avant la fin de l'opération d'installation. Lors de l'exécution du programme d'installation de SQL Server, l'outil d'analyse de configuration système (SCC) analyse l'ordinateur sur lequel SQL Server sera installé. L'outil SCC recherche toute anomalie susceptible d'empêcher une installation correcte de SQL Server. Avant que le programme d'installation ne démarre l'Assistant Mise à niveau, le SCC extrait l'état de chaque élément. Puis, il compare le résultat avec les conditions requises et fournit une aide pour la suppression des problèmes importants.

La vérification de la configuration du système génère un rapport qui contient une brève description de chaque règle exécutée et de l'état d'exécution. Le rapport de contrôle de configuration du système se trouve à l'emplacement %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Avant d'exécuter l'opération d'installation, examinez les rubriques suivantes :

  1. Configurations matérielle et logicielle requises pour l'installation de SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Fonctionnalités prises en charge par les éditions de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considérations sur la sécurité pour une installation de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versions linguistiques locales dans SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Autres références :

  1. Mises à niveau de la version et de l'édition prises en charge(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Avant l'installation du clustering de basculement(http://go.microsoft.com/fwlink/?LinkId=235034)

Voir aussi

Référence

Règles de support du programme d'installation


Vérifier les options de désinstallation

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Vérifier les options de désinstallation
Envoyer des commentaires

Vérifiez votre sélection, puis cliquez sur Suivant pour continuer.


La rubrique que vous recherchez n'est pas disponible

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

La rubrique que vous recherchez n'est pas disponible
Envoyer des commentaires

Une fois l'installation terminée, vous pouvez consulter la documentation de SQL Server en cliquant sur Aide, en appuyant sur la touche F1 dans les boîtes de dialogue ou les éléments d'interface, ou (à partir du menu Démarrer) en pointant sur Tous les programmes, sur Microsoft SQL Server, sur Aide&Communtauté, puis en cliquant sur Documentation en ligne de SQL Server. Pour plus d'informations, consultez Ajout et suppression de collections d'aide.