Vue d'ensemble de l'installation de maintenance de SQL Server

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Vue d'ensemble de l'installation de maintenance de SQL Server
Voir aussi Envoyer des commentaires

Vous pouvez appliquer une mise à jour à n'importe quel composant SQL Server 2012 installé sur votre ordinateur à une mise à jour de maintenance de SQL Server 2012. Si le niveau de version d'un composant SQL Server 2012 existant est ultérieur à celui de la mise à jour, le programme d'installation exclut ce composant de la mise à jour. Pour plus d'informations sur l'application d'une mise à jour de maintenance, consultez Installer les mises à jour de maintenance de SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=231297).

Vous devez tenir compte des points suivants lors de l'installation de mises à jour de SQL Server 2012 :

  • Toutes les fonctionnalités appartenant à une instance de SQL Server doivent être mises à jour en même temps. Par exemple, lorsque vous mettez à jour le Moteur de base de données, vous devez également mettre à jour les composants Analysis Services et Reporting Services s'ils sont installés sur la même instance de SQL Server. Les fonctionnalités partagées, telles que les outils d'administration, Outils de données SQL Server (SSDT) et SQL Server Integration Services, doivent toujours être mises à jour vers le correctif logiciel le plus récent. Si un composant ou une instance n'est pas sélectionné dans l'arborescence de fonctionnalités, le composant ou l'instance ne sera pas mis à jour.

  • Par défaut, les fichiers journaux de mise à jour de SQL Server 2012 sont enregistrés dans %Program Files%\Microsoft SQL Server\110\Setup Bootstrap\LOG\.

  • Le programme d'installation de SQL Server peut à présent intégrer une mise à jour avec le média d'origine pour exécuter simultanément le média d'origine et la mise à jour. Pour plus d'informations, consultez Mises à jour de produit dans l'installation de SQL Server 2012 et Nouveautés liées à l'installation de SQL Server(http://go.microsoft.com/fwlink/?LinkID=219508).

  • Avant d'appliquer une mise à jour de maintenance de SQL Server 2012, il est recommandé de sauvegarder vos données.

  • Les mises à jour de SQL Server sont disponibles via Microsoft Update. Il est recommandé de vérifier régulièrement l'existence de mises à jour pour garantir l'actualisation et la sécurisation de votre instance de SQL Server.SQL Server 2012 Le SP1 est fourni sous la forme d'une installation complète de SQL Server. Alors qu'habituellement, le Service Pack est disponible dans le package correctif exécutable standard devant être appliqué aux instances de SQL Server 2012 RTM, pour cette version, un package d'installation (composé de 2 fichiers) est fourni. Une fois exécuté, il installe une nouvelle instance de SQL Server 2012 dans laquelle le SP1 est pré-installé. Pour plus d'informations, consultez Installation complète de SQL Server 2012 SP1.

Configuration requise et problèmes connus

L'espace disque nécessaire représente environ 2,5 fois la taille du package pour permettre l'installation, le téléchargement et l'extraction de ce dernier. Après l'installation d'un Service Pack, vous pouvez supprimer le package téléchargé. Les fichiers temporaires sont supprimés automatiquement.

Passer en revue les problèmes connus : Pour plus d'informations sur les problèmes connus relatifs à la version actuelle, consultez ici la rubrique correspondante consacrée aux notes de publication : Notes de publication de SQL Server.

Vue d'ensemble de l'installation

Cette section traite de l'installation de SQL Server 2012 pour les mises à jour cumulatives et les Service Packs. Elle explique notamment comment effectuer les opérations suivantes :

  • Préparer l'installation des mises à jour de SQL Server 2012

  • Installer les mises à jour de SQL Server 2012

  • Redémarrer les services et les applications

Préparer l'installation des mises à jour de SQL Server 2012

Il est vivement conseillé d'effectuer les opérations suivantes avant d'installer les mises à jour de SQL Server 2012 :

  • Sauvegarder vos bases de données système SQL Server — Avant d'installer les mises à jour de SQL Server 2012, sauvegardez les bases de données master, msdb et model. L'installation d'une mise à jour de SQL Server 2012 modifie ces bases de données et les rend incompatibles avec les versions antérieures de SQL Server 2012. La sauvegarde de ces bases de données est nécessaire si vous décidez de réinstaller SQL Server 2012 sans ces mises à jour.

    Il est également prudent de sauvegarder vos bases de données utilisateur.

    Important Important

    Lorsque vous appliquez des mises à jour à des instances de SQL Server qui participent à une topologie de réplication, vous devez sauvegarder vos bases de données répliquées en même temps que vos bases de données système avant d'appliquer les mises à jour.

  • Sauvegarder vos bases de données, votre fichier de configuration et votre base de données de référentiel Analysis Services — Avant de mettre à jour une instance d'Analysis Services vous devez sauvegarder les éléments suivants :

    • Bases de données Analysis Services. Par défaut, ces bases de données sont installées dans C:\Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Data\. Pour l'installation WOW, le chemin d'accès par défaut est C:\ProgramFiles (x86)\Microsft SQL Server\MSAS11.<InstanceID>\OLAP\Data\.

    • Paramètre de configuration Analysis Services dans le fichier de configuration msmdsrv.ini. Par défaut, celui-ci se trouve dans le répertoire C:\Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Config\.

    • (Facultatif) Base de données qui contient le référentiel Analysis Services. Cette étape est requise uniquement si Analysis Services a été configuré pour fonctionner avec la bibliothèque DSO (Decision Support Objects).

    Remarque Remarque

    Si vous ne sauvegardez pas vos bases de données, votre fichier de configuration et votre base de données de référentiel Analysis Services, il ne vous sera pas possible de rétrograder une instance d'Analysis Services mise à jour vers la version antérieure.

  • Vérifier que les bases de données système disposent d'un espace libre suffisant — Si l'option de croissance automatique n'est pas sélectionnée pour les bases de données système master et msdb, ces dernières doivent disposer chacune d'un espace libre d'au moins 500 Ko. Pour vérifier que les bases de données disposent d'un espace suffisant, exécutez la procédure stockée système sp_spaceused sur les bases de données master et msdb. Si l'espace non alloué dans l'une ou l'autre base de données est inférieur à 500 Ko, augmentez la taille de la base de données.

  • Arrêter les services et applications — Pour éviter un éventuel redémarrage du système, avant d'installer des mises à jour de SQL Server 2012, arrêtez toutes les applications et tous les services qui établissent des connexions aux instances de SQL Server qui sont en cours de mise à niveau. Ceux-ci comprennent notamment SQL Server Management Studio et Outils de données SQL Server (SSDT). Pour plus d'informations, consultez Démarrer, arrêter, suspendre, reprendre, redémarrer le moteur de base de données, SQL Server Agent ou le service SQL Server Browser.

    Remarque Remarque

    Vous ne pouvez pas arrêter les services dans un environnement de cluster de basculement. Pour plus d'informations, consultez la section relative à l'installation sur un cluster de basculement plus loin dans cette rubrique.

  • Pour vous éviter d'avoir à redémarrer votre ordinateur après l'installation des mises à jour, le programme d'installation affichera la liste des processus qui verrouillent des fichiers. Si le programme d'installation des mises à jour doit arrêter un service au cours de l'installation, il redémarrera ce dernier une fois l'installation terminée.

  • Si le programme d'installation détermine que des fichiers sont verrouillés au cours de l'installation, vous devrez peut-être redémarrer votre ordinateur au terme de l'installation. Si c'est le cas, le programme d'installation vous invite à le faire.

Installer les mises à jour de SQL Server 2012

Cette section décrit le processus d'installation.

Important Important

Les mises à jour de SQL Server 2012 doivent être installées à l'aide d'un compte disposant de privilèges administratifs sur l'ordinateur sur lequel elles seront installées. Pour les installations locales, vous devez exécuter le programme d'installation en tant qu'administrateur. Si vous installez SQL Server à partir d'un partage distant, vous devez utiliser un compte de domaine qui dispose des autorisations de lecture et d'exécution sur le partage distant.

Démarrage d'une mise à jour de SQL Server 2012

Pour installer une mise à jour de SQL Server 2012, exécutez le fichier de package à extraction automatique.

Package de mise à jour cumulative (CU) : <SQLServer2012>-KBxxxxxx-PPP.exe

Package Service Pack (PCU) : <SQLServer2012><SPx> -KBxxxxxx-PPP-LLL.exe

  • x indique le numéro de Service Pack

  • PPP indique la plateforme spécifique.

  • LLL correspond à l'abréviation de la langue de SQL Server. Par exemple, pour l'anglais, LLL correspond à ENU.

Pour appliquer des mises à jour à des composants SQL Server 2012 qui font partie d'un cluster de basculement, consultez la section relative à l'installation d'un cluster de basculement. Pour plus d'informations sur l'exécution d'une installation de mise à jour en mode sans assistance, consultez Installer SQLServer 2012 à partir de l'invite de commandes.

Mises à jour du produit dans l'installation de SQL Server 2012

La Mise à jour de produit est une nouvelle fonctionnalité du programme d'installation de SQL Server 2012. Elle intègre les dernières mises à jour du produit avec l'installation principale du produit de sorte que le produit principal et ses mises à jour applicables sont installés en même temps. La fonctionnalité de mise à jour du produit peut rechercher les mises à jour applicables dans Microsoft Update, les services de mise à jour Windows Server (WSUS), un dossier local, ou un partage réseau. Une fois que le programme d'installation a détecté les versions les plus récentes des mises à jour applicables, il les télécharge et les intègre dans le processus d'installation de SQL Server actuel. La fonctionnalité de mise à jour du produit peut extraire une mise à jour, un Service Pack, ou un Service Pack et la mise à jour cumulative. La fonctionnalité de mise à jour de produit est une extension de la fonctionnalité Slipstream qui était disponible dans SQL Server 2008 PCU1. Pour plus d'informations sur la fonctionnalité de mise à jour de produit dans le programme d'installation de SQL Server 2012, consultez Mises à jour de produit dans l'installation de SQL Server 2012.

Installation complète de SQL Server 2012 SP1

SQL Server 2012 SP1 est également disponible sous la forme d'un package permettant l'installation complète de SQL Server. Le package d'installation de SQL Server 2012 SP1 installe une nouvelle instance de SQL Server dans laquelle le SP1 est pré-installé.

Le package comporte un exécutable et des fichiers d'installation au format compressé. Le package inclut des fichiers sous la forme suivante : SQLServer2012SP1-<Architecture>-<Langue>.exe et SQLServer2012SP1-<Architecture>-<Langue>.box.

Tenez compte des instructions suivantes lorsque vous installez SQL Server 2012 SP1 :

  • Télécharger les fichiers suivants à partir de la page de téléchargement dans un répertoire temporaire situé sur votre unité :

    • SQLServer2012SP1-architecture-langue.box

    • SQLServer2012SP1-architecture-langue.exe

  • Une fois que les téléchargements ont été effectuées, double-cliquez sur SQLServer2012SP1-<architecture>-<langue>.exe pour commencer le processus d'installation.

  • Dans la boîte de dialogue Choisir le répertoire pour les fichiers extraits, le chemin d'accès par défaut du répertoire est pré-renseigné : <Lecteur actuel>\<Dossier de travail actuel>\<Nom du package>. Par exemple, %temp%\SQLServer2012SP1-x64-ENU\. Cliquez sur Parcourir pour modifier le chemin d'accès du répertoire des fichiers extraits.

  • Le package est décompressé dans le chemin d'installation spécifié et est conservé dans le chemin d'accès de répertoire sélectionné une fois l'installation terminée. Ainsi, un utilisateur pourra utiliser les binaires contenues dans le dossier extrait pour de futures installations.

  • L'Assistant Installation exécute le Centre d'installation de SQL Server. Suivez les instructions d'installation de la section Installer SQL Server 2012 avec l'assistant d'installation (programme d'installation) (http://msdn.microsoft.com/library/ms143219.aspx).

Le tableau suivant répertorie une partie des paramètres de ligne de commande pouvant être utilisés pour extraire le package SQL Server 2012 SP1 :

Pour obtenir la liste détaillée des paramètres de ligne de commande pouvant être fournis directement au package SP1, consultez Installer SQLServer 2012 à partir de l'invite de commandes (http://msdn.microsoft.com/library/ms144259.aspx)

Paramètre | Description
/x ou -x | Extrait le package dans le chemin d'accès spécifié. Ouvre la boîte de dialogue Choisir le répertoire pour les fichiers extraits, puis extrait le package dans le chemin spécifié. Ne lance pas le programme d'installation.
/x:<chemin> ou -x:<chemin> | Extrait le package dans le chemin d'accès spécifié sans lancer le programme d'installation.
/q ou -q | Spécifie que le programme d'installation s'exécute en mode silencieux sans interface utilisateur. Il s'agit du mode utilisé pour les installations sans assistance.
/l:<chemin> ou -l:<chemin> | Par défaut, le fichier journal est stocké dans le répertoire temporaire et est nommé SQLServer2012SPx-<Architecture>-<Langue>_decompression_log.txt Utilisez ce paramètre pour générer le fichier journal d'extraction dans le chemin spécifié. Par exemple : SQLServer2012SP1-x64-ENU /x /l:<chemin> Utilisez cette option uniquement en association avec /x ou –x ou /x:<chemin> ou -x:<chemin>

Mise à jour d'une image préparée de SQL Server

Vous pouvez appliquer une mise à jour à une instance préparée non configurée de SQL Server sans terminer la configuration de l'instance préparée. Les différentes méthodes pour appliquer une mise à une instance préparée de SQL Server sont expliquées ci-dessous :

  • Mise à jour d'une instance de SQL Server préparée précédemment

    Il est possible d'appliquer des mises à jour à une instance préparée avant la configuration. Le package de mise à jour détecte que l'instance est en état préparé et applique le correctif logiciel à l'instance préparée, sans terminer la configuration.

  • Mise à jour d'une instance préparée à l'aide de Microsoft Update :

    Vous pouvez appliquer des mises à jour à une instance préparée de SQL Server via Microsoft Update. Le package Microsoft Update détecte que l'instance est en état préparé et applique le correctif logiciel à l'instance préparée, sans terminer la configuration.

Si vous mettez à jour une image préparée de SQL Server, vous devez spécifier le paramètre InstanceID. Pour obtenir plus d'informations et un exemple de syntaxe, consultez Installation de mises à jour à partir de l'invite de commandes.

Mise à jour d'une image finalisée de SQL Server

La mise à jour d'une instance finalisée et configurée de SQL Server suit les mêmes processus que toute autre instance installée de SQL Server.

Reconstruction d'un nœud de cluster de basculement SQL Server 2012

Si vous devez reconstruire un nœud dans le cluster de basculement après l'application de mises à jour, procédez comme suit :

  1. Reconstruisez le nœud dans le cluster de basculement. Pour plus d'informations sur la reconstruction d'un nœud, consultez Récupérer à partir d'une défaillance de cluster de basculement.

  2. Exécutez le programme d'installation d'origine de SQL Server 2012 pour installer SQL Server 2012 sur le nœud de cluster de basculement.

  3. Exécutez le programme d'installation des mises à jour de SQL Server 2012 sur le nœud que vous avez ajouté.

Redémarrage des services et des applications

Une fois l'exécution du programme d'installation terminée, vous devrez peut-être redémarrer l'ordinateur. Après le redémarrage du système ou après l'exécution du programme d'installation sans redémarrage, utilisez le nœud Services dans le Panneau de configuration pour redémarrer les services que vous avez arrêtés avant d'appliquer les mises à jour de SQL Server 2012. Cela inclut des services tels que Distributed Transaction Coordinator et les services Microsoft Search ou des services équivalents spécifiques à une instance.

Redémarrez les applications que vous avez fermées avant d'exécuter le programme d'installation des mises à jour de SQL Server 2012. Vous pouvez également effectuer une autre sauvegarde des bases de données master, msdb et model mises à niveau, immédiatement après l'installation réussie.

Désinstallation des mises à jour à partir de SQL Server 2012

Vous pouvez désinstaller les mises à jour cumulatives ou les Service Packs de SQL Server 2012 à partir de l'élément Programmes et fonctionnalités du Panneau de configuration. Pour consulter la liste des mises à jour installées, ouvrez Mises à jour installées en cliquant sur Démarrer, Panneau de configuration et Programmes. Ensuite, sous Programmes et fonctionnalités, cliquez sur Afficher les mises à jour installées. Chaque mise à jour cumulative est répertoriée séparément. Toutefois, lorsqu'un Service Pack est installé et que sa version est supérieure à celle des mises à jour cumulatives, les entrées des mises à jour cumulatives sont masquées et deviennent accessibles uniquement si vous désinstallez le Service Pack.

Pour désinstaller les Service Packs et les mises à jour, vous devez commencer par la mise à jour ou le Service Pack appliqué en dernier à l'instance de SQL Server et progresser à rebours. Dans chacun des exemples suivants, SQL Server ne dispose plus que de Cumulative Update 1 une fois que la désinstallation des autres Service Packs ou mises à jour a été effectuée :

  • Pour une instance de SQL Server 2012 où sont installés Cumulative Update 1 et le SP1, désinstallez le SP1.

  • Pour une instance de SQL Server 2012 où sont installés Cumulative Update 1, le SP1 et Cumulative Update 2, désinstallez Cumulative Update 2 en premier, puis désinstallez le SP1.

Voir aussi

Autres ressources

Installer SQL Server 2012 à partir de l'invite de commandes
Installer des mises à jour de maintenance de SQL Server 2012
Valider une installation SQL Server
Afficher et lire les fichiers journaux d'installation de SQL Server
Image du pied de page
Transmettre des commentaires sur cette rubrique à Microsoft

© 2012 Microsoft Corporation. Tous droits réservés.


Notice légale pour documentation

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Notice légale pour documentation
Envoyer des commentaires

Ce document est fourni « en l'état ». Les informations et les opinions exprimées dans ce document, y compris les adresses URL et les autres références à des sites Internet, peuvent faire l'objet de modifications sans préavis. Vous assumez tous les risques liés à son utilisation.

Certains exemples mentionnés dans ce document ne sont fournis qu'à titre indicatif et sont fictifs. Toute ressemblance ou similitude avec des éléments réels est purement fortuite et involontaire.

Ce document ne vous concède aucun droit de propriété intellectuelle portant sur les produits Microsoft. Vous pouvez copier et utiliser ce document à titre de référence pour un usage interne.

© 2012 Microsoft. Tous droits réservés.

Microsoft, Active Directory, ActiveX, Bing Maps, Excel, IntelliSense, MSDN, MS-DOS, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual Studio, Windows, Windows NT, Windows Server et Windows Vista sont des marques du groupe Microsoft. SAP NetWeaver est une marque déposée de SAP AG en Allemagne et dans plusieurs autres pays. Toutes les autres marques sont la propriété de leurs propriétaires respectifs.

Stratégie de documentation pour le support et la mise à niveau de SQL Server

La documentation de SQL Server 2012 inclut la documentation en ligne Microsoft de SQL Server 2012, la documentation d'installation, la documentation de référence du développeur, les didacticiels, les fichiers Lisez-moi, les documents relatifs aux problèmes connus, les exemples de code, les exemples de bases de données et les articles de la Base de connaissances publiés par Microsoft – l'ensemble de ces éléments recouvre le contenu relatif aux fonctions et fonctionnalités SQL Server. Cette stratégie de support et de mise à niveau s'applique à la totalité de la documentation SQL Server 2012, y compris aux fichiers Lisez-moi des versions et Service Packs SQL Server 2012 ; un fichier Lisez-moi est considéré comme une extension de la documentation en ligne de SQL Server 2012.

Un exemple présenté dans cette documentation sert principalement à illustrer un concept ou l'utilisation raisonnable d'une instruction ou d'une clause particulière. La plupart des exemples ne reprennent pas la totalité du code normalement utilisé dans un système en production puisque certaines parties de la validation des données et de la gestion des erreurs sont retirées pour mettre l'accent sur un concept ou une instruction particulière. Aucun support technique n'est disponible pour ces exemples, ni pour le code source fourni.

Dans certains cas, une fonctionnalité particulière de SQL Server 2012 n'a pas été suffisamment testée ou développée, et n'est pas destinée à votre utilisation. De telles fonctionnalités se retrouvent alors sous forme d'espaces réservés. Par conséquent, certaines fonctionnalités incluses dans le logiciel ne sont pas documentées. Les fonctionnalités qui ne sont pas documentées ou qui sont incluses comme notation pour une utilisation interne de Microsoft ne sont pas destinées à votre utilisation et ne sont pas prises en charge par le support technique de Microsoft. Sauf spécification contraire de la documentation de SQL Server 2012, le contenu tiers, y compris les problèmes qui résultent de son utilisation avec SQL Server 2012, n'est pas pris en charge par le support technique de Microsoft et peut également entraîner une perte des données. Le support technique de Microsoft n'assure pas la prise en charge des bases de données ou des applications qui exploitent ou utilisent les points d'entrée non documentés comme les API non documentées, notamment sans que la liste soit limitative, les éléments suivants : procédures stockées, procédures stockées étendues, fonctions, vues, tables, colonnes, propriétés ou métadonnées.

Les mises à niveau de serveur et de base de données vers les versions ultérieures de SQL Server 2012 pour les applications et les bases de données qui exploitent et utilisent des points d'entrée non documentés (qui peuvent ne pas fonctionner) ne sont pas prises en charge. L'utilisation des fonctionnalités SQL Server et de celles incluses dans Microsoft SQL Server sans être documentées dans la documentation SQL Server 2012 destinée à votre utilisation n'est pas prise en charge et peut provoquer une perte des données.


Installation de mises à jour à partir de l'invite de commandes

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Installation de mises à jour à partir de l'invite de commandes
Voir aussi Envoyer des commentaires

Testez et modifiez les scripts d'installation selon les besoins de votre organisation. Pour plus d'informations sur l'installation de mises à jour sur un cluster de basculement SQL Server, consultez Application d'une mise à jour de SQL Server à une instance de cluster de basculement dans la Base de connaissances Microsoft.

Exemple de syntaxe pour l'installation

Le nom du package de mise à jour peut varier et inclure une langue, une édition et un processeur. Appliquez une mise à jour à partir de l'invite de commandes en remplaçant <package_name> par le nom de votre package de mise à jour :

  • Mettez à jour une instance unique de SQL Server et tous les composants partagés, tels que Integration Services et Outils d'administration : vous pouvez spécifier l'instance à l'aide du paramètre InstanceName ou InstanceID. Pour mettre à jour une instance préparée de SQL Server, vous devez spécifier le paramètre InstanceID<nom_du_package>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /InstanceName=MyInstance ou <package_name>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /InstanceID=<ID d'instance>

  • Le programme d'installation peut intégrer les dernières mises à jour du produit avec l'installation principale du produit de sorte que le produit principal et ses mises à jour applicables sont installées en même temps. Vous pouvez préparer une installation d'une instance de moteur de base de données pour inclure la mise à jour du produit : setup.exe /q /IAcceptSQLServerLicenseTerms /ACTION=PrepareImage /UpdateEnabled=True /UpdateSource=<chemin dans lequel la mise à jour est téléchargée> /INSTANCEID=<ID d'instance> /FEATURES=SQLEngine

  • Mettre à jour uniquement les composants partagés de SQL Server, comme Integration Services et les outils d'administration : <nom_du_package>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch

  • Mettre à jour toutes les instances de SQL Server présentes sur l'ordinateur et tous les composants partagés, comme Integration Services et les outils d'administration : <NomPackage>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /AllInstances

Supprimez une mise à jour à partir de l'invite de commandes en remplaçant <NomPackage> par le nom de votre package de mise à jour :

  • Supprimer une mise à jour d'une seule instance de SQL Server et tous les composants partagés, comme Integration Services et les outils d'administration : <package_name>.exe /qs /Action=RemovePatch /InstanceName=MyInstance

  • Supprimer une mise à jour des composants partagés de SQL Server uniquement, comme Integration Services et les outils d'administration : <package_name>.exe /qs /Action=RemovePatch

    Remarque Remarque

    Le programme d'installation de mise à niveau permet que les composants partagés soient toujours de la même version ou une version ultérieure par rapport à l'instance de niveau le plus élevé.

Paramètres d'invite de commandes pris en charge

Important Important

Lorsque cela est possible, fournissez les informations d'identification de sécurité au moment de l'exécution. Si vous devez stocker des informations d'identification dans un fichier de script, sécurisez le fichier pour empêcher tout accès non autorisé.

Switch | Description
/? | Affiche de l'aide sur l'invite de commandes d'une installation sans assistance
/action=Patch or /action=RemovePatch | Spécifie l'action d'installation : Patch ou RemovePatch.
/allinstances | Applique la mise à jour de SQL Server à toutes les instances de SQL Server et à tous les composants SQL Server partagés ne dépendant pas des instances.
/instancename=InstanceName1 | Applique la mise à jour de SQL Server à une instance de SQL Server nommée InstanceName et à tous les composants SQL Server partagés ne dépendant pas des instances.
/InstanceID=Inst1 | Applique la mise à jour de SQL Server à une instance de SQL Server Inst1 et à tous les composants SQL Server partagés ne dépendant pas des instances.
/quiet | Exécute le programme d'installation de mise à jour de SQL Server en mode sans assistance.
/qs | Affiche uniquement la boîte de dialogue de progression.
/UpdateEnabled | Spécifie si le programme d'installation de SQL Server doit découvrir et inclure les mises à jour du produit. Les valeurs valides sont True et False ou 1 et 0. Par défaut, le programme d'installation de SQL Server inclut les mises à jour trouvées.
/UpdateSource | Spécifie l'emplacement où le programme d'installation de SQL Server obtiendra les mises à jour du produit. Les valeurs valides sont “MU” pour rechercher Microsoft Update, un chemin d'accès au dossier valide, un chemin d'accès relatif tel que .\MyUpdates ou un partage UNC. Par défaut, le programme d'installation de SQL Server recherche Microsoft Update ou un service Windows Update via Windows Server Update Services.
/IAcceptSQLServerLicenseTerms | Obligatoire uniquement lorsque le paramètre /Q ou /QS est spécifié pour les installations sans assistance.

1 Vous ne pouvez pas spécifier ce paramètre pour appliquer une mise à jour à une instance préparée de SQL Server. Vous devez spécifier à la place le paramètre /instanceID.

Voir aussi

Concepts

Vue d'ensemble de l'installation de maintenance de SQL Server


Procédure : valider l'installation réussie d'une mise à jour de SQL Server

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Procédure : valider l'installation réussie d'une mise à jour de SQL Server
Voir aussi Envoyer des commentaires

Pour valider l'installation réussie d'une mise à jour de SQL Server

  • Vérifiez que les services SQL Server sont en ligne.

  • Vérifiez les informations de version retournées par la requête @@version.

Voir aussi

Concepts

Vue d'ensemble de l'installation de maintenance de SQL Server


Assistance sur SQL Server

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Assistance sur SQL Server
Voir aussi Envoyer des commentaires

Microsoft propose trois principales sources d'informations sur SQL Server :

  • La documentation installée comme une collection locale de documentation en ligne SQL Server.

  • Les sites dédiés à SQL Server sur Microsoft MSDN (Microsoft Developer Network) et TechNet.

  • Les informations relatives à SQL Server sur les autres sites Web Microsoft.

Si vous ne trouvez pas les informations que vous recherchez dans ces sources, vous pouvez poser des questions sur les forums et groupes de discussion de la communauté SQL Server ou présenter un cas de support à Microsoft.

Documentation en ligne de SQL Server

La documentation en ligne de SQL Server aborde les concepts et les procédures requis pour l'utilisation de SQL Server. La documentation en ligne inclut également des documents de référence sur les langages et les interfaces de programmation pour le stockage et l'extraction de données, la création de rapports et la modification de données à l'aide de SQL Server.

Vous pouvez accéder à la documentation en ligne des façons suivantes :

  • Une copie de la documentation en ligne de SQL Server 2012 est publiée dans MSDN Library et TechNet Library sur Internet. Les rubriques de ces copies de la documentation en ligne de SQL Server sont étoffées de commentaires de la communauté, par exemple des informations supplémentaires et des exemples de code d'autres clients. Vous pouvez consulter la copie MSDN Library dans la documentation en ligne de SQL Server 2012.

  • Vous pouvez utiliser le Gestionnaire de bibliothèque d'aide pour installer la documentation en ligne de SQL Server sur un ordinateur local. Pour plus d'informations, consultez Ajouter ou supprimer des collections d'aide.

La documentation en ligne de SQL Server dans MSDN Library et les fichiers de documentation en ligne disponibles via le Gestionnaire de bibliothèque d'aide sont actualisés lorsque Microsoft publie une mise à jour de la documentation en ligne de SQL Server.

Informations disponibles sur MSDN et TechNet

Le site Microsoft Developer Network (MSDN) fournit des services en ligne et hors connexion destinés à aider les développeurs dans l'écriture d'applications faisant appel aux produits et aux technologies Microsoft. Le programme Microsoft TechNet fournit des ressources techniques complètes destinées à aider les informaticiens à évaluer, déployer et supporter efficacement des solutions Microsoft.

Plusieurs sites sur MSDN et TechNet fournissent à un public spécialisé des liens vers des informations relatives à SQL Server adaptées à leurs travaux, y compris vers des informations proposées dans les copies de la documentation en ligne de SQL Server sur MSDN et TechNet. Ces sites contiennent également des informations qui complètent celles fournies dans la documentation en ligne de SQL Server.

Le tableau suivant décrit ces sources d'information et les personnes à qui elles sont destinées.

Ressource | Public visé
Centre pour les développeurs SQL Server | Les développeurs qui créent des bases de données SQL Server, des systèmes de génération de rapports et des solutions de Business Intelligence, et qui font en sorte que leurs applications et leurs sites Web utilisent ces systèmes.
Centre Accès aux Données et Stockage | Les développeurs qui font en sorte que leurs applications et leurs sites Web utilisent des données stockées au moyen de produits tels que SQL Server et Access.
XML Developer Center (en anglais) | Les créateurs de sites Web et les développeurs d'applications dont les sites et applications utilisent XML pour le stockage et la manipulation des données.
Site TechNet SQL Server | Les administrateurs et opérateurs qui planifient, déploient, administrent et supportent des systèmes qui utilisent SQL Server.

Autres informations en ligne

Des informations supplémentaires sur SQL Server sont disponibles sur ces sites Web Microsoft.

Ressource | Description
Microsoft SQL Server | Fournit des informations d'avant-vente sur l'évaluation de SQL Server en tant qu'outil de stockage de données et de Business Intelligence.
Base de connaissances de Microsoft | Fournit un référentiel dans lequel il est possible de chercher des articles sur SQL Server rédigés par le support Microsoft.
Microsoft Learning (en anglais) | Décrit la formation et les certifications Microsoft pour SQL Server.
Microsoft Press (en anglais) | Répertorie les ouvrages de Microsoft sur SQL Server.

Autres sources d'assistance

Si vous ne trouvez pas les informations que vous recherchez dans la documentation du produit ou sur le Web, vous pouvez poser une question sur les forums et groupes de discussion de la communauté SQL Server. Vous pouvez également demander de l'aide au support technique.

Remarque Remarque

Ne posez pas vos questions dans la section Contenu de la communauté située au bas des rubriques de la documentation en ligne de SQL Server dans MSDN Library ou TechNet Library. Aucune surveillance n'est effectuée sur ces sections pour y consulter vos questions et vous ne recevrez généralement pas de réponse. Posez vos questions sur les forums et groupes de discussion de la communauté, lesquels sont surveillés par d'autres clients qui peuvent répondre à vos questions.

Le tableau ci-dessous répertorie les liens vers ces ressources et les décrit.

Ressource | Description
Communauté de professionnels de l'informatique SQL Server | Fournit des liens vers des groupes de discussion et des forums contrôlés par la communauté SQL Server. S'y trouvent également des sources d'information de la communauté, telles que les blogs et les sites Web. La communauté SQL Server représente une aide précieuse grâce aux réponses qu'elle fournit aux questions posées, mais il n'y a pas de garantie d'obtenir une réponse.
Centre SQL Server Communautés | Ce site est centré sur les groupes de discussion, les forums et d'autres ressources de communautés qui sont utiles aux développeurs SQL Server.
Aide et support Microsoft | Vous pouvez utiliser ce site Web pour présenter un cas de support à un professionnel du support Microsoft.

Les produits Microsoft ont un cycle de vie de support qui détermine la durée du support pour chaque version Le support Microsoft tient à jour une page qui définit le cycle de vie du support Microsoft. Cette page contient des liens vers d'autres pages qui indiquent la disponibilité du support pour les produits Microsoft. Pour plus d’informations, consultez Microsoft Support Lifecycle.

Voir aussi

Concepts

Utiliser la documentation du produit pour SQL Server


Bienvenue

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Bienvenue
Envoyer des commentaires

Les règles d'installation analysent l'ordinateur sur lequel la mise à jour sera installée.


Termes du contrat de licence

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Termes du contrat de licence
Envoyer des commentaires

Utilisez la page Termes du contrat de licence pour accepter les termes du contrat de licence de cette version.

Options

Pour pouvoir poursuivre l'installation, vous devez accepter les termes du contrat de licence de SQL Server.

Utilisez le bouton Imprimer pour imprimer un exemplaire des termes du contrat de licence de cette version. Pour mettre fin à l'installation, cliquez sur Annuler.


Sélectionner les composants

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Sélectionner les composants
Envoyer des commentaires

Utilisez la page Sélection de composant pour sélectionner les composants et fonctionnalités SQL Server à mettre à jour.

Options

Cliquez sur un nom de composant dans le volet de gauche pour voir les informations relatives à la langue, au système d'exploitation, à l'édition et à l'état du composant.

Pour mettre à jour un composant ou une fonctionnalité, activez la case à cocher qui se trouve en regard de son nom. Pour exclure un composant ou une fonctionnalité de cette mise à jour, désactivez la case à cocher qui se trouve en regard de son nom.

Plusieurs instances de SQL Server installées sur un même ordinateur peuvent être mises à jour séparément, mais tous les composants d'une même instance de SQL Server doivent être mis à jour en même temps. Tous les composants partagés, tels que les composants de station de travail, l'analyseur MSXML, SQLXML, les composants de compatibilité descendante et l'enregistreur VSS, doivent être mis à jour.

Si un composant ne peut pas être mis à jour, une explication sera fournie dans le volet Détails.


Vérifier les fichiers en cours d'utilisation

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Vérifier les fichiers en cours d'utilisation
Envoyer des commentaires

Pour éviter d'avoir à redémarrer Windows après avoir installé des mises à jour de SQL Server, utilisez la page Vérifier les fichiers en cours d'utilisation afin d'identifier les processus qui verrouillent des fichiers requis par le programme d'installation des mises à jour de SQL Server.

Arrêtez toutes les applications et tous les services qui établissent des connexions aux instances de SQL Server qui sont en cours de mise à jour. Cela implique l'arrêt de SQL Server Management Studio et Outils de données SQL Server (SSDT).

Si le programme d'installation détermine que des fichiers sont verrouillés au cours de l'installation, vous devrez peut-être redémarrer votre ordinateur au terme de l'installation. Si tel est le cas, le programme d'installation vous demandera de le faire. Si le programme d'installation doit arrêter un service au cours de l'installation, il redémarrera ce dernier une fois l'installation terminée.

Pour vous éviter d'avoir à redémarrer votre ordinateur après l'installation, le programme d'installation affiche la liste des processus qui verrouillent des fichiers. Arrêtez les processus et les applications de la liste. Cliquez sur Actualiser la vérification pour réexécuter la vérification. Cliquez sur Arrêter la vérification pour mettre fin à une vérification en cours d'exécution. Si aucun fichier verrouillé n'est détecté, le tableau est vide. Une fois que tous les processus bloquants ont été arrêtés, cliquez sur Suivant pour continuer.

Le programme d'installation enregistre les informations dans le fichier journal. Pour plus d'informations sur la consultation des fichiers journaux, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server et Procédure : lire un fichier journal d'installation de SQL Server.

Les informations suivantes sont contenues dans le fichier journal :

  • Nom du processus

  • Nom de la fonctionnalité SQL Server

  • Type de processus

  • Compte sous lequel le processus est en cours d'exécution

  • ID de processus

  • Nom du fichier verrouillé

Nom | Description
Processus | Affiche le nom complet du processus qui utilise les fichiers à mettre à jour.
Type | Affiche le type de processus.
Compte | Affiche le compte sous lequel le processus est en cours d'exécution.
ID de processus | Affiche l'ID de processus.


Prêt pour la mise à jour

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Prêt pour la mise à jour
Envoyer des commentaires

Utilisez la page Résumé pour valider les modifications qui seront appliquées à votre instance de SQL Server. Pour continuer l'installation, cliquez sur Installer.


Avancement de la mise à jour

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Avancement de la mise à jour
Envoyer des commentaires

Utilisez la page Progression de l'installation pour contrôler le programme d'installation à mesure qu'il applique la mise à jour à votre instance de SQL Server et à ses composants.

Options

Le tableau indique le nom du produit SQL Server, son nom d'instance et l'état de l'installation.


Terminé

 Image de Réduire Image de Développer Image de Copier Image du pointage pour copie
[image]

Terminé
Envoyer des commentaires

La page Terminé confirme l'état de votre installation.