Panoramica sulla documentazione del programma di installazione di SQL Server

[image]

Panoramica sulla documentazione del programma di installazione di SQL Server
Commenti e suggerimenti

La documentazione per il programma di installazione di SQL Server è disponibile sui supporti di installazione e online.

Documentazione disponibile durante l'installazione

Durante l'installazione di SQL Server, fare clic sul pulsante ? nella pagina Installazione guidata o premere F1 sulla tastiera per visualizzare le informazioni immediate necessarie per completare l'operazione.

Panoramica sugli argomenti per l'installazione di SQL Server

Sia che si utilizzi l'Installazione guidata di SQL Server o il prompt dei comandi per installare SQL Server, è possibile prepararsi consultando le seguenti sezioni:

  • Pianificazione di un'installazione di SQL Server.

    Viene descritto come prepararsi per l'installazione di SQL Server.

  • Installare SQL Server 2012

    Descrive le opzioni di installazione di SQL Server.

  • Installare le funzionalità di Business Intelligence di SQL Server 2012

    Descrive le opzioni di installazione delle funzionalità di SQL Server che fanno parte della piattaforma di Business Intelligence di Microsoft, che include Analysis Services, Integration Services, Reporting Services, e diverse applicazioni client utilizzate per la creazione o l'utilizzo di dati analitici.

  • Eseguire l'aggiornamento a SQL Server 2012

    Vengono descritte le opzioni per l'aggiornamento a SQL Server.

Se si sta installando un cluster di failover di SQL Server, vedere i seguenti argomenti:

  • Introduzione al clustering di failover di SQL Server.

  • Operazioni preliminari all'installazione del clustering di failover.

Inviare commenti e suggerimenti sull'argomento a Microsoft

© 2012 Microsoft Corporation. Tutti i diritti riservati.


Informazioni sulle condizioni di licenza di SQL Server

[image]

Informazioni sulle condizioni di licenza di SQL Server
Vedere anche Commenti e suggerimenti

Le condizioni di licenza software Microsoft vengono copiate nel computer locale durante l'installazione di SQL Server. Quando più istanze della stessa edizione e lingua di SQL Server vengono installate nello stesso computer, a tutte le istanze della stessa edizione e lingua verrà applicata una sola copia delle condizioni di licenza. I file vengono memorizzati nel percorso: %ProgramFiles%\Microsoft SQL Server\110\Condizioni di licenza\ o %ProgramFiles(x86)%\Microsoft SQL Server\110\Condizioni di licenza\.

Quando più istanze della stessa edizione e lingua di SQL Server vengono installate nello stesso computer, a tutte le istanze della stessa edizione e lingua verrà applicata una sola copia delle condizioni di licenza.

Nel nome di file delle condizioni di licenza sono indicate l'edizione e la lingua di SQL Server, come ad esempio:

  • License_DEV_ENU.txt per SQL Server Developer, edizione in lingua inglese.

  • License_STD_ITA.txt per SQL Server Standard, edizione in lingua italiana.

  • License_UA_JPN.txt per Preparazione aggiornamento a SQL Server, edizione in lingua giapponese.

  • License_SQLNCLI_ENU.txt per SQL Server Native Client, edizione in lingua inglese.

  • License_SQLXML4_KOR.txt per SQLXML, edizione in lingua coreana.

  • License_SQLBI.rtf per l'edizione SQL Server Business Intelligence.

  • License_ENTCORE.rtf per SQL Server Enterprise Edition: licenze basate su core.

  • License_ENT.rtf per licenze CAL/Server di SQL Server Enterprise Edition.

Di seguito vengono indicati i segmenti dei nomi di file utilizzati per identificare le edizioni di SQL Server:

  • ENT – Enterprise Edition: licenze Server/CAL (Client Access License)

  • ENTCORE – Enterprise Edition: licenze basate su core

  • BI – Business Intelligence

  • DEV - Developer

  • STD - Standard

  • WEB - Web

  • EXPR - Express

Di seguito vengono indicati i segmenti dei nomi di file utilizzati per identificare le lingue corrispondenti di SQL Server:

  • ENU - Inglese

  • JPN - Giapponese

  • FRA - Francese

  • ITA - Italiano

  • KOR - Coreano

  • DEU - Tedesco

  • ESN - Spagnolo

  • CHS - Cinese semplificato

  • CHT - Cinese tradizionale

  • PTB - Portoghese (Brasile)

  • RUS - Russo

Opzioni di gestione delle licenze per SQL Server

Per ulteriori informazioni sulle opzioni di determinazione dei prezzi e di gestione delle licenze di SQL Server, vedere il sito Web Microsoft SQL Server (http://go.microsoft.com/fwlink/?LinkId=190955).

Vedere anche

Concetti

Considerazioni sulla gestione delle licenze per SQL Server
Informativa sulla privacy di Microsoft SQL Server
Nota legale sulla documentazione


Considerazioni sulla gestione delle licenze per SQL Server

[image]

Considerazioni sulla gestione delle licenze per SQL Server
Vedere anche Commenti e suggerimenti

Per ulteriori informazioni sulle opzioni di gestione delle licenze di SQL Server, vedere il sito Web di Microsoft SQL Server.

Vedere anche

Riferimento

Informazioni sulle condizioni di licenza di SQL Server

Concetti

Informativa sulla privacy di Microsoft SQL Server
Nota legale sulla documentazione


Nota legale sulla documentazione

[image]

Nota legale sulla documentazione
Commenti e suggerimenti

Il documento viene fornito "com'è". Le informazioni e le opinioni espresse nel presente documento, inclusi gli URL e altri riferimenti a siti Web, possono essere soggette a modifiche senza preavviso. L'utente accetta di utilizzarlo a proprio rischio.

Alcuni esempi utilizzati in questo documento vengono forniti a scopo puramente illustrativo e sono fittizi. Nessuna associazione reale o connessione è intenzionale o può essere desunta.

Il presente documento non implica la concessione di alcun diritto di proprietà intellettuale relativo ai prodotti Microsoft. È possibile copiare e utilizzare questo documento per fini di riferimento interno.

© 2012 Microsoft. Tutti i diritti sono riservati.

Microsoft, Active Directory, ActiveX, Bing Maps, Excel, IntelliSense, MSDN, MS-DOS, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual Studio, Windows, Windows NT, Windows Server e Windows Vista sono marchi di società del gruppo Microsoft. SAP NetWeaver è un marchio registrato di SAP AG in Germania e in altri paesi. Altri nomi di prodotti e società citati nel presente documento sono marchi dei rispettivi proprietari.

Criteri relativi alla documentazione per il supporto e l'aggiornamento di SQL Server

La documentazione del software Microsoft SQL Server 2012 comprende la documentazione online di Microsoft per Microsoft SQL Server 2012, la documentazione di installazione, la documentazione di riferimento per gli sviluppatori, esercitazioni, file Leggimi, documenti su problemi noti, codice/applicazioni di esempio, database di esempio e articoli della Knowledge Base pubblicati da Microsoft, tutti con contenuto su caratteristiche e funzionalità di SQL Server. Tali criteri per il supporto e l'aggiornamento si applicano alla documentazione di Microsoft SQL Server 2012, inclusi i file Leggimi relativi a versioni e Service Pack di Microsoft SQL Server 2012. I file Leggimi sono considerati estensioni della documentazione online di Microsoft SQL Server 2012.

Obiettivo principale degli esempi inclusi nella documentazione è quello di illustrare un concetto o l'utilizzo comune di un'istruzione o di una clausola specifica. La maggior parte degli esempi non include il codice completo normalmente disponibile in un sistema completo e finale, in quanto una parte dei normali dati di convalida o la gestione degli errori vengono in genere rimossi dagli esempi per mettere in maggiore evidenza il concetto o l'istruzione specifici illustrati nell'esempio stesso. I servizi del Servizio Supporto Tecnico Clienti Microsoft non sono disponibili per gli esempi e il codice sorgente incluso.

In alcuni casi, una particolare caratteristica di Microsoft SQL Server 2012 non è stata sufficientemente testata o sviluppata e non è destinata all'utilizzo. Tali caratteristiche sono incluse come segnaposto. Alcune caratteristiche incluse nel software, pertanto, sono escluse dalla trattazione nella documentazione. Le caratteristiche non documentate o incluse come notazione per l'uso interno da parte di Microsoft non sono destinate all'utilizzo e non sono supportate dal Servizio Supporto Tecnico Clienti Microsoft. Se non diversamente indicato nella documentazione di Microsoft SQL Server 2012, il contenuto di terze parti, inclusi i problemi derivati dall'utilizzo di tale contenuto con Microsoft SQL Server 2012, non è supportato dal Servizio Supporto Tecnico Clienti Microsoft e può inoltre comportare la perdita di dati. Il Servizio Supporto Tecnico Clienti Microsoft non fornisce alcun supporto per i database o le applicazioni che utilizzano punti di ingresso non trattati nella documentazione, ad esempio le API non documentate, inclusi, a titolo esemplificativo, metadati, stored procedure, stored procedure estese, funzioni, viste, tabelle, colonne o proprietà.

Gli aggiornamenti di server e database alle versioni successive di Microsoft SQL Server 2012 per le applicazioni e i database che utilizzano punti di ingresso non trattati nella documentazione potrebbero non funzionare e non sono supportati. L'utilizzo di caratteristiche e funzionalità di SQL Server incluse in Microsoft SQL Server che esulano dalla trattazione nella documentazione di Microsoft SQL Server 2012 non è supportato e può provocare la perdita di dati.


Informativa sulla privacy di Microsoft SQL Server

[image]

Informativa sulla privacy di Microsoft SQL Server
Commenti e suggerimenti

Per informazioni sui componenti di raccolta dati utente in Microsoft SQL Server 2012, vedere l'Informativa sulla privacy di SQL Server.


Percorsi dei file per le istanze predefinite e denominate di SQL Server

[image]

Percorsi dei file per le istanze predefinite e denominate di SQL Server
Vedere anche Commenti e suggerimenti

Un'installazione di SQL Server è costituita da una o più istanze separate. Un'istanza, predefinita o denominata, contiene un proprio set di file di programma e di dati, oltre a un set di file comuni condivisi tra tutte le istanze di SQL Server presenti nel computer.

Per un'istanza di SQL Server che include Motore di database, Analysis Services e Reporting Services, ogni componente ha un set completo di file di dati, file eseguibili e file comuni condivisi da tutti i componenti.

Per isolare i percorsi di installazione di ogni componente, vengono generati ID istanza univoci per ogni componente all'interno di una determinata istanza di SQL Server.

Nota importante Importante

Non è possibile installare i file di programma e i file di dati in un'unità disco rimovibile, in un file system che utilizza la compressione, in una directory in cui sono presenti file di sistema o in unità condivise in un'istanza del cluster di failover.

Non eliminare alcuna delle directory seguenti o il relativo contenuto: Binn, Data, Ftdata, HTML o 1033. Se necessario, è possibile eliminare altre directory; potrebbe non essere tuttavia possibile recuperare funzionalità o dati non più disponibili se prima non si disinstalla e quindi si reinstalla SQL Server. Non eliminare o modificare nessuno dei file htm disponibile nella directory HTML. Questi file sono necessari per il corretto funzionamento degli strumenti di SQL Server.

File condivisi per tutte le istanze di SQL Server

I file comuni utilizzati da tutte le istanze presenti in un singolo computer vengono installati nella cartella <drive>:\Programmi\Microsoft SQL Server\110\, dove <drive> corrisponde alla lettera dell'unità in cui vengono installati i componenti. L'unità C è in genere quella predefinita.

Percorsi dei file e mapping del Registro di sistema

Durante l'installazione di SQL Server, viene generato un ID istanza per ogni componente. I componenti server di questa versione di SQL Server sono il Motore di database, Analysis Services e Reporting Services.

L'ID dell'istanza predefinita viene creato utilizzando il formato seguente:

  • MSSQL per Motore di database, seguito dal numero di versione principale, da un carattere di sottolineatura e, se possibile, dalla versione secondaria e quindi da un punto, seguiti dal nome di istanza.

  • MSAS per Analysis Services, seguito dal numero di versione principale, da un carattere di sottolineatura e, se possibile, dalla versione secondaria e quindi da un punto, seguiti dal nome di istanza.

  • MSRS per Reporting Services, seguito dal numero di versione principale, da un carattere di sottolineatura e, se possibile, dalla versione secondaria e quindi da un punto, seguiti dal nome di istanza.

Di seguito vengono indicati alcuni esempi di ID delle istanze predefinite utilizzati in questa versione di Microsoft SQL Server 2012:

  • MSSQL11.MSSQLSERVER per un'istanza predefinita di Microsoft SQL Server 2012.

  • MSAS11.MSSQLSERVER per un'istanza predefinita di Analysis Services.

  • MSSQL11.Istanza per un'istanza denominata di Microsoft SQL Server 2012 il cui nome è "Istanza".

Di seguito viene indicata la struttura di directory per un'istanza denominata di Microsoft SQL Server 2012 che include Motore di database e Analysis Services, denominata "Istanza" e installata nelle directory predefinite:

  • C:\Programmi\Microsoft SQL Server\MSSQL11.Istanza\

  • C:\Programmi\Microsoft SQL Server\MSASSQL11.Istanza\

È possibile specificare qualsiasi valore per l'ID istanza, evitando tuttavia caratteri speciali e parole chiave riservate. Per ulteriori informazioni, vedere Reserved Keywords (Setup).

È possibile specificare l'ID di un'istanza non predefinita durante l'installazione di SQL Server. Se l'utente sceglie di modificare la directory di installazione predefinita, anziché <Programmi>\Microsoft SQL Server verrà utilizzato <percorso personalizzato>\Microsoft SQL Server. Si noti che gli ID delle istanze che iniziano con un carattere di sottolineatura (_) o che contengono il simbolo cancelletto (#) o il segno di dollaro ($) non sono supportati.

Nota Nota

Integration Services e i componenti client non sono specifici dell'istanza e non dispongono pertanto di un ID istanza assegnato. Per impostazione predefinita, i componenti non specifici dell'istanza vengono installati in una singola directory: <unità>:\Programmi\Microsoft SQL Server\110\. Se si modifica il percorso di installazione di un componente condiviso, la modifica sarà valida anche per tutti gli altri componenti condivisi. Nelle successive installazioni i componenti non specifici dell'istanza verranno installati nella stessa directory dell'installazione originale.

SQL Server Analysis Services è l'unico componente di SQL Server che supporta la ridenominazione delle istanze in seguito all'installazione. Se un'istanza di Analysis Services viene rinominata, l'ID istanza non cambierà di conseguenza. Al termine della ridenominazione dell'istanza, le directory e le chiavi del Registro di sistema continueranno a utilizzare l'ID istanza creato durante l'installazione.

L'hive del Registro di sistema viene creato in HKLM\Software\Microsoft\Microsoft SQL Server\<Instance_ID> per i componenti specifici dell'istanza. Ad esempio,

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL11.Istanza

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSASSQL11.Istanza

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.110

Nel Registro di sistema viene inoltre gestito un mapping degli ID istanza ai nomi delle istanze. Il mapping degli ID istanza in base ai nomi delle istanze viene gestito nel modo seguente:

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\SQL] "InstanceName"="MSSQL11"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\OLAP] "InstanceName"=""MSASSQL11"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\RS] "InstanceName"="MSRSSQL11"

Specifica dei percorsi dei file

Durante l'installazione è possibile modificare il percorso di installazione delle caratteristiche seguenti:

Durante la procedura di installazione viene visualizzato il percorso di installazione delle caratteristiche con una cartella di destinazione configurabile dall'utente:

Componente | Percorso predefinito1, 2 | Percorso configurabile3 o fisso
Componenti server di Motore di database | \Programmi\Microsoft SQL Server\MSSQL11.<IDIstanza>\ | File di dati di
Motore di database configurabili | \Programmi\Microsoft SQL Server\MSSQL11.<IDIstanza>\ | Server di
Analysis Services configurabile | \Programmi\Microsoft SQL Server\MSAS11.<IDIstanza>\ | File di dati di
Analysis Services configurabili | \Programmi\Microsoft SQL Server\MSAS11.<IDIstanza>\ | Server di report di
Reporting Services configurabile | \Programmi\Microsoft SQL Server\MSRS11.<IDIstanza>\Reporting Services\ReportServer\Bin\ | Gestione report di
Reporting Services configurabile | \Programmi\Microsoft SQL Server\MSRS11.<IDIstanza>\Reporting Services\ReportManager\ | Percorso fisso
Integration Services | <Directory di installazione>\110\DTS\ | Configurabile4
Master Data Services | <Directory di installazione>\110\Master Data Services | Configurabile4
Componenti client | <Directory di installazione>\110\Tools\ | Oggetti di replica e oggetti COM sul lato server4
configurabili | <unità>:\Programmi\Microsoft SQL Server\110\COM\5 | Percorso fisso
DLL del componente Integration Services per il motore di runtime Data Transformation Services, il motore della pipeline di trasformazione dati e utilità da riga di comando dtexec | <unità>:\Programmi\Microsoft SQL Server\110\DTS\Binn | Percorso fisso
DLL che forniscono supporto per connessioni gestite di Integration Services | <unità>:\Programmi\Microsoft SQL Server\110\DTS\Connections | Percorso fisso
DLL per ogni tipo di enumeratore supportato da Integration Services | <unità>:\Programmi\Microsoft SQL Server\110\DTS\ForEachEnumerators | Percorso fisso
Servizio SQL Server Browser, provider WMI | <unità>:\Programmi\Microsoft SQL Server\110\Shared\ | Percorso fisso
Componenti condivisi tra tutte le istanze di SQL Server | <unità>:\Programmi\Microsoft SQL Server\110\Shared\ | Percorso fisso

1Verificare che la cartella \Programmi\Microsoft SQL Server\ sia protetta con autorizzazioni limitate.

2L'unità predefinita di questi percorsi è systemdrive, in genere l'unità C.

3I percorsi di installazione di caratteristiche figlio vengono determinati dal percorso di installazione della caratteristica padre.

4Un singolo percorso di installazione viene condiviso tra Integration Services e i componenti client. La modifica del percorso di installazione per un componente si applica quindi a tutti i componenti. Nel caso di installazioni successive i componenti vengono installati nello stesso percorso dell'installazione iniziale.

5Questa directory viene utilizzata da tutte le istanze di SQL Server presenti in un computer. Se si applica un aggiornamento a una delle istanze nel computer, le modifiche apportate ai file inclusi in questa cartella interesseranno tutte le istanze presenti nel computer. Quando si aggiungono caratteristiche a un'installazione esistente, non è possibile modificare il percorso di una caratteristica installata in precedenza né specificare il percorso di una nuova caratteristica. È necessario installare le caratteristiche aggiuntive nelle directory già stabilite durante l'installazione iniziale oppure disinstallare e reinstallare il prodotto.

Nota Nota

Per le configurazioni cluster, è necessario selezionare un'unità locale che sia disponibile per ogni nodo del cluster.

Se durante l'installazione si specifica un percorso di installazione per i componenti server o i file di dati, oltre al percorso specificato per i file di dati e di programma, verrà utilizzato l'ID istanza. L'ID istanza non viene utilizzato per gli strumenti e altri file condivisi, né per i file di dati e di programma di Analysis Services, ma solo per il repository di Analysis Services.

Se si imposta un percorso di installazione per la caratteristica Motore di database, nell'istallazione di SQL Server tale percorso verrà utilizzato come directory radice di tutte le cartelle specifiche dell'istanza per l'installazione, inclusi i file di dati SQL. In questo caso, se si imposta la radice su "C:\Programmi\Microsoft SQL Server\MSSQL11\MSSQL\", le directory specifiche dell'istanza verranno aggiunte alla fine del percorso.

Se si utilizza la funzionalità di aggiornamento USESYSDB nell'Installazione guidata di SQL Server (modalità interfaccia utente del programma di installazione), è probabile che si verifichino le condizioni per un'installazione del prodotto in una struttura di cartelle ricorsiva, ad esempio, <SQLProgramFiles>\MSSQL11\MSSQL\MSSQL11\MSSQL\Data\. Per utilizzare la caratteristica USESYSDB, impostare invece un percorso di installazione per la caratteristica dei file di dati SQL anziché per la caratteristica Motore di database.

Nota Nota

I file di dati si trovano in genere in una directory figlio denominata Data. Specificare, ad esempio, "C:\Programmi\Microsoft SQL Server\MSSQL11\" per indicare il percorso radice della directory dei dati dei database di sistema durante l'aggiornamento se i file di dati si trovano in C:\Programmi\Microsoft SQL Server\MSSQL11\MSSQL\Data.

Vedere anche

Riferimento

Configurazione Motore di database - Directory dati
Configurazione di Analysis Services - Directory dati


Visualizzare e leggere i file di log del programma di installazione di SQL Server

[image]

Visualizzare e leggere i file di log del programma di installazione di SQL Server
Vedere anche Commenti e suggerimenti

Ogni esecuzione del programma di installazione determina la creazione di file di log e di una nuova cartella dei log con indicazione di data e ora nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\. Il formato del nome della cartella dei log con indicazione di data e ora è AAAAMMGG_hhmmss. L'esecuzione del programma di installazione in modalità automatica determina la creazione dei file di log nel percorso % temp%\sqlsetup*.log. Tutti i file inclusi nella cartella dei log vengono archiviati nel file Log*.cab nella rispettiva cartella dei log.

Una richiesta di installazione tipica viene eseguita in tre fasi:

  1. Testo delle regole globali

  2. Aggiornamento del componente

  3. Azione richiesta dall'utente

In ogni fase il programma di installazione genererà log di riepilogo e dettagliati e creerà log aggiuntivi in base alle necessità. Il programma di installazione viene richiamato almeno tre volte per ogni azione di installazione richiesta dall'utente.

I file dell'archivio dati contengono uno snapshot dello stato di tutti gli oggetti di configurazione registrati dal processo di installazione e contribuiscono a risolvere i problemi relativi agli errori di configurazione. Vengono creati file di dump XML per gli oggetti dell'archivio dati per ogni fase dell'esecuzione. Questi file vengono salvati nella rispettiva sottocartella dei log sotto la cartella dei log con indicazione di data e ora, come indicato di seguito:

  • Datastore_GlobalRules

  • Datastore_ComponentUpdated

  • Datastore

Nelle sezioni seguenti vengono illustrati i file di log del programma di installazione di SQL Server.

Testo di riepilogo

Panoramica

Nel file sono indicati i componenti di SQL Server rilevati durante l'installazione, l'ambiente del sistema operativo, i valori dei parametri della riga di comando eventualmente specificati e lo stato globale di ogni MSI/MSP eseguito.

Il log è organizzato nelle sezioni seguenti:

  • Riepilogo globale dell'esecuzione.

  • Proprietà e configurazione del computer in cui è stato eseguito il programma di installazione di SQL Server.

  • Funzionalità di SQL Serverinstallate in precedenza nel computer.

  • Descrizione delle proprietà relative alla versione dell'installazione e al pacchetto di installazione.

  • Impostazioni di input al runtime fornite durante l'installazione.

  • Percorso del file di configurazione.

  • Dettagli dei risultati di esecuzione.

  • Regole globali.

  • Regole specifiche per lo scenario di installazione.

  • Regole non riuscite.

  • Percorso del file di report delle regole.

Percorso

Si trova nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\.

Per individuare gli errori nel file del testo di riepilogo, eseguire una ricerca nel file utilizzando le parole chiave "error" o "failed".

Summary_engine-base_AAAAMMGG_HHMMss.txt

Panoramica

Il file di base summary_engine è simile al file di riepilogo e viene generato durante il flusso di lavoro principale.

Percorso

Si trova nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMGG_HHMM>\.

Summary_engine-base_AAAAMMGG_HHMMss_ComponentUpdate.txt

Panoramica

Il file di log di riepilogo relativo all'aggiornamento del componente è simile al file di riepilogo e viene generato durante il flusso di lavoro di aggiornamento del componente.

Percorso

Si trova nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMGG_HHMM>\.

Summary_engine-base_<NumeroVersione>MMGG_HHMMss_GlobalRules.txt

Panoramica

Il file di log di riepilogo relativo alle regole globali è simile al file di riepilogo e viene generato durante il flusso di lavoro delle regole globali.

Percorso

Si trova nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMGG_HHMM>\.

Detail.txt

Panoramica

Il file Detail.txt viene generato per il flusso di lavoro principale, ad esempio installazione o aggiornamento, e fornisce i dettagli dell'esecuzione. Le registrazioni presenti nel file vengono generate in base al momento in cui viene richiamata ogni azione dell'installazione e indicano l'ordine in cui le azioni sono state eseguite, nonché le relative dipendenze.

Percorso

Si trova nel percorso %programfiles%\Microsoft SQL Server\110\Setup

Bootstrap\Log\<AAAAMMGG_HHMM>\Detail.txt.

Se si verifica un errore durante il processo di installazione, l'eccezione o l'errore verrà registrato alla fine di questo file. Per individuare gli errori in questo file, esaminare innanzitutto la parte finale del file, quindi eseguire una ricerca nel file delle parole chiave "error" o "exception".

Detail_ComponentUpdate.txt

Panoramica

Il file Detail_ComponentUpdate.txt viene generato per il flusso di lavoro di aggiornamento del componente ed è simile al file Detail.txt.

Percorso

Si trova nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMGG_HHMM>\.

Detail_GlobalRules.txt

Panoramica

Il file Detail_GlobalRules.txt viene generato per l'esecuzione delle regole globali ed è simile al file Detail.txt.

Percorso

Si trova nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMGG_HHMM>\.

File di log MSI

Panoramica

I file di log MSI forniscono dettagli sul processo del pacchetto di installazione. Vengono generati da MSIEXEC durante l'installazione del pacchetto specificato.

Tipi di file di log MSI:

  • <Funzionalità>_<Architettura>_<Interazione>.log

  • <Funzionalità>_<Architettura>_<Lingua>_<Interazione>.log

  • <Funzionalità>_<Architettura>_<Interazione>_<flusso di lavoro>.log

Percorso

I file di log MSI si trovano nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMGG_HHMM>\<Nome>.log.

Nella parte finale del file è incluso un riepilogo dell'esecuzione in cui sono indicati lo stato riuscito o non riuscito e le proprietà. Per individuare l'errore nel file MSI, eseguire la ricerca di "value 3", poiché gli errori si trovano in genere in prossimità di tale stringa.

ConfigurationFile.ini

Panoramica

Il file di configurazione contiene le impostazioni di input fornite durante l'installazione. Può essere utile riavviare l'installazione senza dover immettere manualmente le impostazioni. Nel file di configurazione non vengono tuttavia salvati le password degli account, i PID e alcuni parametri. Le impostazioni possono essere aggiunte al file o specificate tramite una riga di comando o l'interfaccia utente del programma di installazione. Per ulteriori informazioni, vedere Installare SQL Server 2012 tramite un file di configurazione (http://go.microsoft.com/fwlink/?LinkId=231296).

Percorso

Si trova nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMGG_HHMM>\.

SystemConfigurationCheck_Report.htm

Panoramica

Il report di controllo della configurazione di sistema contiene una breve descrizione di ogni regola eseguita, nonché lo stato di esecuzione.

Percorso

Si trova nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMGG_HHMM>\.

Vedere anche

Concetti

Risoluzione dei problemi relativi all'installazione di SQL Server


Risoluzione dei problemi relativi all'installazione di SQL Server

[image]

Risoluzione dei problemi relativi all'installazione di SQL Server
Vedere anche Commenti e suggerimenti

Per visualizzare le informazioni sulla risoluzione dei problemi relativi all'installazione e all'aggiornamento, vedere il File Leggimi relativo a SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=196910).

Vedere anche

Concetti

Visualizzare e leggere i file di log del programma di installazione di SQL Server


Guida di riferimento all'interfaccia utente del programma di installazione di SQL Server

[image]

Guida di riferimento all'interfaccia utente del programma di installazione di SQL Server
Commenti e suggerimenti

In questa sezione vengono descritte le opzioni di installazione disponibili nell'Installazione guidata di SQL Server.


Accettazione delle condizioni di licenza

[image]

Accettazione delle condizioni di licenza
Vedere anche Commenti e suggerimenti

Utilizzare la pagina Condizioni di licenza dell'Installazione guidata di SQL Server per accettare le condizioni di licenza per la versione di SQL Server in uso.

È possibile stampare il contratto di licenza o copiarlo negli Appunti. Per continuare, accettare le condizioni di licenza, quindi scegliere Avanti. Per chiudere l'installazione, fare clic su Annulla.

Segnalazione utilizzo caratteristiche

Se si abilita la segnalazione di utilizzo delle caratteristiche, SQL Server viene configurato per l'invio periodico di un report a Microsoft. Nei report verranno incluse informazioni sulla configurazione hardware in uso e sulle modalità di utilizzo dei componenti di SQL Server. I dati relativi all'utilizzo delle caratteristiche verranno utilizzati da Microsoft per migliorare SQL Server. Tra i componenti di SQL Server monitorati da questa caratteristica sono inclusi quelli indicati di seguito:

  • Motore di database

  • Analysis Services

  • Reporting Services

  • Integration Services

  • Replica

  • SQL Server Data Tools (SSDT)

  • Programma di installazione di SQL Server

Le informazioni relative all'utilizzo delle caratteristiche vengono inviate a Microsoft e archiviate con diritti di accesso limitati.

Per disabilitare la segnalazione di utilizzo delle caratteristiche al termine dell'installazione, utilizzare lo strumento Segnalazione errori e utilizzo caratteristiche di SQL Server, disponibile nel menu Strumenti di configurazione di SQL Server.

Per le azioni di installazione quali aggiornamento, ripristino, installazione e così via, le informazioni vengono raccolte e caricate solo durante l'esecuzione del programma di installazione

Per tutti gli altri componenti di SQL Server, le informazioni vengono raccolte una volta al giorno per tutte le istanze abilitate di SQL Server. Per impostazione predefinita, la raccolta viene eseguita a mezzanotte per ridurre il carico del server. Se si desidera cambiare l'ora di raccolta, è possibile modificare manualmente la chiave del Registro di sistema che la controlla. È disponibile una chiave del Registro di sistema specifica per ogni istanza di SQL Server:

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL11.<IDISTANZA>\CPE\TimeofReporting

Il valore della chiave del Registro di sistema include l'ora di esecuzione della raccolta espressa in numero di minuti a partire da 00.00 (mezzanotte). Ad esempio, se il valore immesso è 60 la raccolta verrà eseguita alla 1.00, mentre se il valore immesso è 1200 la raccolta verrà eseguita alle 20.00 e così via.

Vedere anche

Riferimento

Informazioni sulle condizioni di licenza di SQL Server


Aggiunta di un nodo del cluster di failover di SQL Server

[image]

Aggiunta di un nodo del cluster di failover di SQL Server
Vedere anche Commenti e suggerimenti

Prima che l'operazione di installazione di SQL Server venga completata, viene convalidata la configurazione del computer. Durante l'installazione di SQL Server viene eseguita l'analisi del computer in cui verrà installato SQL Server tramite Controllo configurazione sistema. Questo strumento consente di verificare le condizioni che impediscono la corretta operazione di installazione di SQL Server. Prima dell'avvio dell'installazione guidata di SQL Server, lo strumento recupera le informazioni sullo stato di ciascun elemento. Il risultato viene confrontato con i requisiti, quindi vengono fornite indicazioni per la rimozione di eventuali problemi che impediscono di proseguire.

Con il controllo della configurazione di sistema viene generato un report con una breve descrizione di ogni regola eseguita, nonché lo stato dell'esecuzione. Il report di controllo della configurazione si trova nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMGG_HHMM>\.

Prima di eseguire l'operazione di installazione, esaminare i seguenti argomenti:

  1. Requisiti hardware e software per l'installazione di SQL Server (http://go.microsoft.com/fwlink/? LinkId=235029)

  2. Funzionalità supportate dalle Edizioni di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerazioni sulla sicurezza per un'installazione di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versioni in lingua locale di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Altri riferimenti:

  1. Aggiornamenti di versione ed edizione supportati(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Operazioni preliminari all'installazione del clustering di failover(http://go.microsoft.com/fwlink/?LinkId=235034)

Vedere anche

Riferimento

Regole di supporto per l'installazione


Configurazione di Analysis Services - Provisioning account

[image]

Configurazione di Analysis Services - Provisioning account
Vedere anche Commenti e suggerimenti

Utilizzare questa pagina per impostare la modalità server e per concedere le autorizzazioni amministrative a utenti o servizi che richiedono l'accesso illimitato ad Analysis Services. Durante l'installazione non viene aggiunto automaticamente il gruppo locale BUILTIN\Administrators di Windows al ruolo di amministratore del server Analysis Services dell'istanza che viene installata. Se si desidera aggiungere il gruppo Administrators locale al ruolo di amministratore del server, è necessario specificare in modo esplicito tale gruppo.

Se si installa PowerPivot per SharePoint, accertarsi di concedere le autorizzazioni amministrative agli amministratori di farm SharePoint o agli amministratori di servizi responsabili di una distribuzione server di PowerPivot in una farm SharePoint Server 2010. Per ulteriori informazioni sui requisiti di installazione e di account di servizio di Servizio PowerPivot, vedere la pagina relativa all'installazione di PowerPivot per SharePoint.

Opzioni

Modalità server: specifica il tipo di database di Analysis Services che è possibile distribuire nel server. Le modalità del server vengono determinate durante l'installazione e non possono essere modificate successivamente. Le modalità si escludono a vicenda, ovvero saranno necessarie due istanze di Analysis Services, ciascuna configurata per una modalità diversa, in modo da supportare sia la soluzione OLAP classico che quella per il modello tabulare.

Specifica amministratori: è necessario specificare almeno un amministratore del server per l'istanza di SQL Server. Gli utenti o i gruppi specificati diventeranno membri del ruolo di amministratore del server dell'istanza di Analysis Services che viene installata e devono essere account utente di dominio Windows nello stesso dominio del computer in cui viene installato il software.

Nota Nota

Controllo account utente è una caratteristica di sicurezza di Windows che richiede a un amministratore di approvare in modo specifico azioni o applicazioni amministrative prima di poterle eseguire. Poiché Controllo account utente è attivato per impostazione predefinita, verrà richiesto di consentire operazioni specifiche che necessitano di privilegi elevati. È possibile configurare Controllo account utente per modificare il comportamento predefinito oppure è possibile personalizzarlo per programmi specifici. Per ulteriori informazioni su Controllo account utente e sulla relativa configurazione, vedere Guida dettagliata su Controllo account utente in Windows e Controllo account utente (Wikipedia).

Vedere anche

Altre risorse

Modificare gli account e le password di servizio (PowerPivot per SharePoint)
Configurare l'account di servizio di Analysis Services
Configurazione degli account di servizio Windows


Configurazione di Analysis Services - Directory dati

[image]

Configurazione di Analysis Services - Directory dati
Vedere anche Commenti e suggerimenti

Le directory predefinite della tabella seguente sono configurabili dall'utente durante l'installazione di SQL Server. L'autorizzazione per accedere a questi file viene concessa agli amministratori locali e ai membri del gruppo di sicurezza SQLServerMSASUser$<istanza> creato e di cui viene effettuato il provisioning durante l'installazione.

Descrizione

Directory predefinita

Indicazioni

Directory radice dati

C:\Programmi\Microsoft SQL Server\MSAS11.<IDIstanza>\OLAP\Data\

Assicurarsi che la cartella \Programmi\Microsoft SQL Server\ sia protetta con autorizzazioni limitate. Le prestazioni di Analysis Services dipendono, in molte configurazioni, dalle prestazioni del sottosistema di archiviazione in cui si trova la directory dei dati. Posizionare tale directory nel sottosistema di archiviazione collegato al sistema in grado di garantire le prestazioni più elevate. Per le installazioni del cluster di failover, assicurarsi che le directory dei dati vengano posizionate nel disco condiviso.

Directory file di log

C:\Programmi\Microsoft SQL Server\MSAS11.<IDIstanza>\OLAP\Log\

Si tratta della directory per i file di log di Analysis Services e include il log FlightRecorder. Se si aumenta la durata dell'Utilità Traccia eventi, assicurarsi che la directory dei log disponga di spazio sufficiente.

Directory temporanea

C:\Programmi\Microsoft SQL Server\MSAS11.<IDIstanza>\OLAP\Temp\

Posizionare la directory temporanea nel sottosistema di archiviazione a elevate prestazioni.

Directory di backup

C:\Programmi\Microsoft SQL Server\MSAS11.<IDIstanza>\OLAP\Backup\

Si tratta della directory dei file di backup predefiniti di Analysis Services. Per le installazioni di PowerPivot per SharePoint, si tratta inoltre della posizione in cui i servizi di sistema PowerPivot memorizzano nella cache i file di dati PowerPivot.

Verificare che vengano impostate le autorizzazioni appropriate in modo da impedire la perdita di dati e che il gruppo di utenti per il servizio Analysis Services disponga delle autorizzazioni adeguate per la scrittura nella directory di backup. Non è supportato l'utilizzo di un'unità di cui è stato eseguito il mapping per le directory di backup.

Note

  • Le istanze di Analysis Services distribuite in una farm di SharePoint archiviano i file dell'applicazione, i file di dati e le proprietà nei database del contenuto e delle applicazioni di servizio.

  • Quando si aggiungono caratteristiche a un'installazione esistente, non è possibile modificare il percorso di una caratteristica installata in precedenza, né specificare il percorso di una nuova caratteristica.

  • Se si specificano directory di installazione non predefinite, verificare che le cartelle di installazione siano univoche per l'istanza di SQL Server. Nessuna delle directory presenti in questa finestra di dialogo deve essere condivisa con le directory di altre istanze di SQL Server. Anche i componenti Motore di database e Analysis Services all'interno di un'istanza di SQL Server devono essere installati in directory separate.

  • Non è possibile installare file di programma e file di dati nelle situazioni seguenti:

    • In un'unità disco rimovibile

    • In un file system che utilizza la compressione

    • In una directory in cui si trovano i file di sistema

    • In unità condivise in un'istanza del cluster di failover

Vedere anche

Concetti

Percorsi dei file per le istanze predefinite e denominate di SQL Server


Selezione dischi cluster

[image]

Selezione dischi cluster
Commenti e suggerimenti

Utilizzare la pagina Selezione dischi cluster dell'Installazione guidata di SQL Server per selezionare la risorsa disco del cluster condivisa per il cluster di failover di SQL Server. Il disco del cluster è l'unità in cui verranno memorizzati i dati di SQL Server.

Un disco del cluster condiviso non è un requisito per le installazioni di cluster del Motore di database di SQL Server. Un file server SMB è un archivio supportato per le installazioni di cluster di failover del Motore di database di SQL Server e può essere specificato utilizzando la pagina Motore di database - Directory dati prima di completare l'installazione.

Nota di attenzione Attenzione

Se si è scelto di installare Analysis Services, è necessario specificare un disco del cluster condiviso.

Se si intende abilitare FILESTREAM in questa istanza del cluster di failover di SQL Server, è necessario specificare un disco del cluster condiviso.

Opzioni

Dischi condivisi

Selezionare un singolo disco dall'elenco. Il disco del cluster è l'unità in cui verranno memorizzati i dati di SQL Server.

È possibile specificare un solo disco. Se si seleziona il gruppo contenente la risorsa quorum del cluster, verrà visualizzato un messaggio di avviso. È consigliabile non installare la risorsa quorum del cluster.

Dischi condivisi disponibili

Visualizza un elenco dei dischi disponibili, una descrizione di ogni risorsa disco e l'indicazione se ciascun disco è qualificato come disco fisso.


Configurazione di rete cluster

[image]

Configurazione di rete cluster
Commenti e suggerimenti

Utilizzare la pagina Selezione rete cluster per specificare le risorse di rete per l'istanza del cluster di failover.

Opzioni

Nome di rete cluster di failover di SQL Server - Nome utilizzato per identificare l'istanza del cluster di failover nella rete.

Impostazioni di rete - Specificare il tipo e l'indirizzo IP per l'istanza del cluster di failover.

Durante le operazioni di aggiunta e rimozione dei noti, in SQL Server viene visualizzato un elenco di sola lettura degli indirizzi IP esistenti per il cluster di failover di SQL Server.

  • Installazione integrata:

    • Se si aggiunge un nodo che supporta un set identico di subnet di rete supportate dai nodi esistenti nel cluster di failover di SQL Server, non sarà possibile aggiungere ulteriori indirizzi IP. L'impostazione della dipendenza rimane invariata.

    • Se si aggiunge un nodo che supporta un subset di subnet supportate dai nodi esistenti nel cluster di failover di SQL Server, non sarà possibile aggiungere ulteriori risorse indirizzo IP. La dipendenza della risorsa indirizzo IP viene impostata su OR per riflettere il fatto che tutti gli indirizzi IP specificati non sono validi su tutti i nodi del cluster.

    • Se si aggiunge un nodo che supporta subnet oltre a quelle già supportate dai nodi esistenti nel cluster di failover di SQL Server, si avrà la possibilità di aggiungere nuovi indirizzi IP validi. Se vengono specificati nuovi indirizzi IP, la dipendenza della risorsa indirizzo IP viene impostata su OR per riflettere il fatto che tutti gli indirizzi IP specificati non sono validi su tutti i nodi del cluster.

    • Se si aggiunge un nodo che supporta subnet di rete aggiuntive, ma nessuna delle subnet supportate dai nodi esistenti nel cluster di failover di SQL Server, verrà richiesto di aggiungere ulteriori indirizzi IP. La dipendenza della risorsa indirizzo IP viene impostata su OR per riflettere il fatto che tutti gli indirizzi IP specificati non sono validi su tutti i nodi del cluster.

  • Installazione avanzata: durante il passaggio di completamento dell'installazione specificare l'indirizzo IP per tutti i nodi e le subnet dell'istanza del cluster di failover. È possibile specificare più indirizzi IP per un cluster di failover su più subnet, tuttavia è supportato un solo indirizzo IP per subnet. Ogni nodo preparato deve essere proprietario di almeno un indirizzo IP. Se si dispone di più subnet nel cluster di failover di SQL Server, viene richiesto di impostare la dipendenza della risorsa indirizzo IP su OR.Rimozione nodo:

    • Se gli indirizzi IP restanti sono supportati su tutti i nodi restanti, viene richiesto di impostare la dipendenza della risorsa indirizzo IP su AND.

    • Se gli indirizzi IP restanti non sono supportati su tutti i nodi restanti, la dipendenza della risorsa indirizzo IP rimane impostata su OR.


Configurazione nodi cluster

[image]

Configurazione nodi cluster
Commenti e suggerimenti

Utilizzare la pagina Configurazione nodi cluster per aggiungere o rimuovere nodi da un'istanza del cluster di failover. Per installare o aggiornare un cluster di failover di SQL Server, è necessario eseguire il programma di installazione su ogni nodo del cluster di failover. Per aggiungere un nodo a un cluster di failover di SQL Server esistente, è necessario eseguire il programma di installazione di SQL Server nel nodo che deve essere aggiunto all'istanza del cluster di failover di SQL Server.

Opzioni

Nome istanza di SQL Server - Utilizzare l'elenco a discesa per selezionare l'istanza del cluster di failover di SQL Server da modificare.

Nome del nodo - In questo campo verrà inserito il nome del computer in cui viene eseguito il programma di installazione di SQL Server. Si tratta del nodo del cluster di failover che verrà aggiunto o rimosso dall'istanza del cluster di failover di SQL Server.


Configurazione nodi cluster (completa)

[image]

Configurazione nodi cluster (completa)
Commenti e suggerimenti

Utilizzare la pagina Configurazione nodi cluster (completa) per specificare un'istanza esistente di SQL Server che è stato preparato per clustering. Per installare o aggiornare un cluster di failover di SQL Server, è necessario eseguire il programma di installazione su ogni nodo del cluster di failover. Per aggiungere un nodo a un cluster di failover di SQL Server esistente, è necessario eseguire il programma di installazione di SQL Server nel nodo che deve essere aggiunto all'istanza del cluster di failover di SQL Server.

Opzioni

Dalle caselle a discesa:

  • Nome istanza di SQL Server: selezionare il nome istanza del cluster di failover di SQL Server.

  • Nome del nodo: in questo campo viene inserito automaticamente il nome del computer su cui è in esecuzione il programma di installazione di SQL Server.

  • Nome di rete del Cluster di failover di SQL Server: in questo campo il valore non viene inserito automaticamente. Specificare il nome di rete della nuova istanza del cluster di failover di SQL Server. Si tratta del nome che identifica l'istanza del cluster di failover nella rete.


Gruppo risorse cluster

[image]

Gruppo risorse cluster
Vedere anche Commenti e suggerimenti

Utilizzare la pagina Gruppo risorse cluster per specificare il disco in cui verranno memorizzate le risorse del server virtuale di SQL Server.

Opzioni

Specificare il nome del gruppo di risorse del cluster di SQL Server. Sono disponibili due opzioni:

  • Utilizzare la casella di riepilogo a discesa per specificare un gruppo esistente.

  • Digitare il nome di un nuovo gruppo da creare. Il nome "Archiviazione disponibile" non è un nome di gruppo valido.

Vedere anche

Altre risorse

Procedura: Creazione di un nuovo cluster di failover di SQL Server


Criteri di sicurezza cluster

[image]

Criteri di sicurezza cluster
Commenti e suggerimenti

Utilizzare la pagina Criteri di sicurezza cluster per configurare i criteri di sicurezza per l'istanza del cluster di failover.

Opzioni

Specificare gruppi a livello di dominio globale o locale per i servizi di cluster. Tutte le autorizzazioni per le risorse sono controllate da gruppi a livello di dominio che includono gli account del servizio SQL Server come membri del gruppo. Per ulteriori informazioni sulla funzionalità degli ID di sicurezza (SID) del servizio in Windows Server 2008, vedere la pagina relativa alla configurazione di account di servizio Windows.

Se si installa un'istanza del cluster di failover di Microsoft SQL Server 2012 in un dominio Windows 2000 in modalità mista, è necessario utilizzare gruppi globali di dominio per i servizi cluster di SQL Server.

Nota Nota

I controller di dominio di Windows 2000 possono funzionare in modalità mista e in modalità nativa. La modalità mista consente di utilizzare controller di dominio legacy nello stesso dominio.


Operazione completata - Completamento immagine

[image]

Operazione completata - Completamento immagine
Commenti e suggerimenti

Utilizzare la pagina Operazione completata per verificare che la configurazione dell'istanza predisposta sia completata.

Opzioni

Questa finestra di dialogo include un collegamento al file di log del programma di installazione per questa operazione. Per completare l'installazione, fare clic su Chiudi.


Avanzamento completamento immagine

[image]

Avanzamento completamento immagine
Vedere anche Commenti e suggerimenti

Utilizzare la pagina Avanzamento completamento immagine dell'Installazione guidata di SQL Server per monitorare lo stato dell'installazione del completamento immagine di SQL Server. Al completamento di questo passaggio, questa pagina elenca lo stato per ogni caratteristica di SQL Server configurata e completata.

Vedere anche

Concetti

Visualizzare e leggere i file di log del programma di installazione di SQL Server


Regole di completamento immagine

[image]

Regole di completamento immagine
Commenti e suggerimenti

Prima che l'operazione di installazione di SQL Server venga completata, viene convalidata la configurazione del computer. Durante l'installazione di SQL Server viene eseguita l'analisi del computer in cui verrà installato SQL Server tramite Controllo configurazione sistema. Questo strumento consente di verificare le condizioni che impediscono la corretta operazione di installazione di SQL Server. Prima dell'avvio dell'installazione guidata di SQL Server, lo strumento recupera le informazioni sullo stato di ciascun elemento. Il risultato viene confrontato con i requisiti, quindi vengono fornite indicazioni per la rimozione di eventuali problemi che impediscono di proseguire.

Con il controllo della configurazione di sistema viene generato un report con una breve descrizione di ogni regola eseguita, nonché lo stato dell'esecuzione. Il report di controllo della configurazione si trova nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMGG_HHMM>\.

Prima di eseguire l'operazione di installazione, esaminare i seguenti argomenti:

  1. Requisiti hardware e software per l'installazione di SQL Server (http://go.microsoft.com/fwlink/? LinkId=235029)

  2. Funzionalità supportate dalle Edizioni di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerazioni sulla sicurezza per un'installazione di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versioni in lingua locale di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Altri riferimenti:

  1. Aggiornamenti di versione ed edizione supportati(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Operazioni preliminari all'installazione del clustering di failover(http://go.microsoft.com/fwlink/?LinkId=235034)


Operazione completata - Preparazione immagine

[image]

Operazione completata - Preparazione immagine
Commenti e suggerimenti

Utilizzare la pagina Operazione completata per verificare che la preparazione dell'immagine sia completata.

Opzioni

Questa finestra di dialogo include un collegamento al file di log del programma di installazione per questa operazione. Per completare la preparazione dell'immagine, fare clic su Chiudi.


Operazione completata - Ripristino

[image]

Operazione completata - Ripristino
Commenti e suggerimenti

Utilizzare la pagina Operazione completata - Ripristino per verificare il completamento del ripristino.

Opzioni

Questa finestra di dialogo include un collegamento al file di log del programma di installazione per questa operazione. Per continuare, fare clic su Chiudi.


Operazione completata (aggiornamento)

[image]

Operazione completata (aggiornamento)
Commenti e suggerimenti

Utilizzare la pagina Operazione completata (aggiornamento) per verificare il completamento dell'aggiornamento.

Opzioni

Questa finestra di dialogo include un collegamento al file di log del programma di installazione per questa operazione. Per continuare, fare clic su Chiudi.


Configurazione Motore di database - Provisioning account

[image]

Configurazione Motore di database - Provisioning account
Vedere anche Commenti e suggerimenti

Utilizzare questa pagina per impostare la modalità di sicurezza di SQL Server e aggiungere utenti o gruppi di Windows come amministratori del Motore di database di SQL Server.

Considerazioni sull'esecuzione di SQL Server 2012 in Windows Vista, Windows 7 e Windows Server 2008

Nelle versioni precedenti di SQL Server, viene eseguito il provisioning del gruppo BUILTIN\Administrators come account di accesso nel Motore di database e i membri del gruppo Administrators locale possono accedere utilizzando le credenziali di amministratore. L'utilizzo di autorizzazioni elevate non è una procedura consigliata. In Microsoft SQL Server 2012 non viene eseguito il provisioning del gruppo BUILTIN\Administrators come account di accesso. Di conseguenza, è consigliabile creare un account di accesso di SQL Server per ogni utente amministrativo e aggiungere tale account al ruolo predefinito del server sysadmin durante l'installazione di una nuova istanza di Microsoft SQL Server 2012. È consigliabile eseguire questa operazione anche per gli account di Windows utilizzati per eseguire i processi di SQL Server Agent, inclusi i processi dell'agente di replica.

Opzioni

Modalità di sicurezza: selezionare l'autenticazione di Windows o l'autenticazione mista per l'istallazione.

Provisioning entità Windows: nelle versioni precedenti di SQL Server, il gruppo locale Builtin\Administrator di Windows è incluso nel ruolo del server sysadmin di SQL Server e consente agli amministratori di Windows di accedere in modo efficace all'istanza di SQL Server. In Microsoft SQL Server 2012 il gruppo Builtin\Administrator non è disponibile nel ruolo del server sysadmin. Al contrario, è necessario eseguire in modo esplicito il provisioning degli amministratori di SQL Server per le nuove installazioni durante l'esecuzione del programma di installazione.

Nota importante Importante

È necessario eseguire il provisioning esplicito degli amministratori di SQL Server per le nuove installazioni durante l'esecuzione del programma di installazione. Se non si completa questo passaggio, non sarà possibile procedere con l'installazione.

Specifica amministratori di SQL Server: è necessario specificare almeno un'entità di Windows per l'istanza di SQL Server. Per aggiungere l'account utilizzato per l'esecuzione del programma di installazione di SQL Server, fare clic sul pulsante Aggiungi utente corrente. Per aggiungere o rimuovere account dall'elenco degli amministratori di sistema, fare clic su Aggiungi o Rimuovi, quindi modificare l'elenco di utenti, gruppi o computer che disporranno di privilegi di amministratore per l'istanza di SQL Server.

Dopo avere modificato l'elenco, scegliere OK, quindi verificare l'elenco di amministratori nella finestra di dialogo di configurazione. Quando l'elenco è completo, scegliere Avanti.

Se si seleziona l'autenticazione Modalità mista, è necessario fornire credenziali di accesso per l'account amministratore di sistema di SQL Server predefinito.

Nota sulla sicurezza Nota sulla sicurezza

Non utilizzare una password vuota. Utilizzare una password complessa.

Autenticazione di Windows

Quando un utente si connette utilizzando un account utente di Windows, in SQL Server il nome di account e la password vengono convalidati tramite il token dell'entità di Windows nel sistema operativo. Si tratta della modalità di autenticazione predefinita e garantisce maggiore protezione rispetto alla modalità mista. L'autenticazione di Windows, per la quale viene utilizzato il protocollo di sicurezza Kerberos, garantisce l'applicazione dei criteri password mediante convalida della complessità delle password, fornisce supporto per il blocco dell'account e supporta la scadenza delle password.

Nota sulla sicurezza Nota sulla sicurezza

Se possibile, utilizzare l'autenticazione di Windows.

Nota importante Importante

Non utilizzare una password vuota. Utilizzare una password complessa. Non impostare mai password sa vuote o vulnerabili.

Modalità mista (autenticazione di Windows o autenticazione di SQL Server)

Consente agli utenti di connettersi tramite l'autenticazione di Windows o l'autenticazione di SQL Server. Gli utenti che utilizzano un account utente di Windows per la connessione possono utilizzare connessioni trusted convalidate da Windows.

Se è necessario selezionare l'autenticazione Modalità mista e utilizzare account di accesso SQL per le applicazioni legacy, sarà necessario impostare password complesse per tutti gli account di SQL Server.

Nota Nota

L'autenticazione di SQL Server è disponibile solo per la compatibilità con le versioni precedenti. Se possibile, utilizzare l'autenticazione di Windows.

Password

Immettere e confermare l'account di accesso dell'amministratore di sistema (sa). Le password rappresentano la prima forma di difesa contro eventuali intrusi, pertanto l'impostazione di password complesse costituisce una misura di sicurezza fondamentale per la sicurezza del sistema. Non impostare mai password dell'account "sa" vuote o vulnerabili.

Nota Nota

Le password di SQL Server possono includere da 1 a 128 caratteri, compresi lettere, simboli e numeri. Se si seleziona l'autenticazione Modalità mista, sarà necessario immettere una password dell'account sa complessa prima di passare alla pagina successiva dell'Installazione guidata.

Linee guida per la creazione di password complesse

Le password complesse non vengono decifrate facilmente, né da parte degli utenti né mediante l'utilizzo di programmi specifici. Le password complesse non prevedono l'utilizzo di termini o condizioni non consentite, quali:

  • Condizione di spazio vuoto o NULL

  • 'Password'

  • "Admin"

  • "Administrator"

  • "sa"

  • 'sysadmin'

Una password complessa non può essere costituita dagli elementi seguenti associati al computer di installazione:

  • Nome dell'utente attualmente connesso al computer.

  • Nome del computer.

Una password complessa deve essere formata da più di otto caratteri e soddisfare almeno tre dei quattro criteri seguenti:

  • Deve contenere lettere maiuscole.

  • Deve contenere lettere minuscole.

  • Deve contenere numeri.

  • Deve contenere caratteri non alfanumerici, ad esempio #, % o ^.

Le password immesse in questa pagina devono soddisfare i requisiti relativi ai criteri password complessi. In presenza di qualsiasi componente di automazione in cui viene utilizzata l'autenticazione di SQL Server, assicurarsi che la password soddisfi i requisiti relativi ai criteri password complessi.

Contenuto correlato

Per ulteriori informazioni sulla scelta tra l'autenticazione di Windows e l'autenticazione di SQL Server, vedere l'argomento Scegliere una modalità di autenticazione nella documentazione online di SQL Server.

Per ulteriori informazioni sulla scelta di un account per l'esecuzione del Motore di database di SQL Server, vedere l'argomento Configurare account di servizio e autorizzazioni di Windows nella documentazione online di SQL Server.

Vedere anche

Riferimento

Configurare account di servizio e autorizzazioni di Windows


Configurazione Motore di database - Directory dati

[image]

Configurazione Motore di database - Directory dati
Vedere anche Commenti e suggerimenti

Utilizzare questa pagina per specificare il percorso di installazione per i file di dati e di programma del Motore di database di SQL Server. A seconda del tipo di installazione possono essere supportati i tipi di archivio seguenti: disco locale, spazio di archiviazione condiviso o file server SMB.

Per specificare una condivisione file SMB come directory, è necessario immettere manualmente il percorso UNC supportato. La selezione di una condivisione file SMB non è supportata. Il formato di un percorso UNC supportato di una condivisione file SMB è "\\NomeServer\NomeCondivisione\..."

Istanza autonoma di SQL Server

Nella tabella seguente vengono elencati i tipi di archivio supportati e le directory predefinite per un'istanza autonoma di SQL Server configurabili dall'utente durante l'installazione di SQL Server.

Descrizione | Tipo di archivio supportato | Directory predefinita | Indicazioni
Directory radice dati | Disco locale, file server SMB, spazio di archiviazione condiviso 1 | C:\Programmi\Microsoft SQL Server\ | Durante l'installazione di SQL Server vengono configurati gli elenchi ACL per le directory di SQL Server e viene disattivata l'ereditarietà come parte della configurazione.
Directory database utente | Disco locale, file server SMB, spazio di archiviazione condiviso 1 | C:\Programmi\Microsoft SQL Server\MSSQL11.<IDIstanza>\MSSQL\Data | Le procedure consigliate per le directory dei dati dell'utente dipendono dai requisiti del carico di lavoro e delle prestazioni.
Directory log database utente | Disco locale, file server SMB, spazio di archiviazione condiviso 1 | C:\Programmi\Microsoft SQL Server\MSSQL11.<IDIstanza>\MSSQL\Data | Assicurarsi che nella directory del log sia disponibile una quantità di spazio adeguata.
Directory database temporaneo | Disco locale, file server SMB, spazio di archiviazione condiviso 1 | C:\Programmi\Microsoft SQL Server\MSSQL11.<IDIstanza>\MSSQL\Data | Le procedure consigliate per la directory Temp dipendono dai requisiti del carico di lavoro e delle prestazioni.
Directory log database temporaneo | Disco locale, file server SMB, spazio di archiviazione condiviso 1 | C:\Programmi\Microsoft SQL Server\MSSQL11.<IDIstanza>\MSSQL\Data | Assicurarsi che nella directory del log sia disponibile una quantità di spazio adeguata.
Directory di backup | Disco locale, file server SMB, spazio di archiviazione condiviso 1 | C:\Programmi\Microsoft SQL Server\MSSQL11.<IDIstanza>\MSSQL\Backup | Impostare le autorizzazioni appropriate in modo da impedire la perdita di dati e assicurarsi che all'account utente per il servizio SQL Server vengano concesse autorizzazioni adeguate per la scrittura nella directory di backup. Non è supportato l'utilizzo di un'unità di cui è stato eseguito il mapping per le directory di backup.

1 Sebbene i dischi condivisi siano supportati, è consigliabile non utilizzarli per un'istanza autonoma di SQL Server.

Istanza del cluster di failover di SQL Server

Nella tabella seguente vengono elencati i tipi di archivio supportati e le directory predefinite per un'istanza del cluster di failover di SQL Server configurabili dall'utente durante l'installazione di SQL Server.

Descrizione

Tipo di archivio supportato

Directory predefinita

Indicazioni

Directory radice dati

Spazio di archiviazione condiviso, file server SMB

<Unità:>\Programmi\Microsoft SQL Server\

Suggerimento Suggerimento

Se nella pagina Selezione dischi cluster è stato selezionato un disco condiviso, per impostazione predefinita verrà utilizzato il primo disco condiviso. Se nella pagina Selezione dischi cluster non è stata effettuata alcuna selezione, questo campo sarà vuoto per impostazione predefinita.

Durante l'installazione di SQL Server vengono configurati gli elenchi ACL per le directory di SQL Server e viene disattivata l'ereditarietà come parte della configurazione.

Directory database utente

Spazio di archiviazione condiviso, file server SMB

<Unità>:\Programmi\Microsoft SQL Server\MSSQL11.<IDIstanza>\MSSQL\Data

Suggerimento Suggerimento

Se nella pagina Selezione dischi cluster è stato selezionato un disco condiviso, per impostazione predefinita verrà utilizzato il primo disco condiviso. Se nella pagina Selezione dischi cluster non è stata effettuata alcuna selezione, questo campo sarà vuoto per impostazione predefinita.

Le procedure consigliate per le directory dei dati dell'utente dipendono dai requisiti del carico di lavoro e delle prestazioni.

Directory log database utente

Spazio di archiviazione condiviso, file server SMB

<Unità:>\Programmi\Microsoft SQL Server\MSSQL11.<IDIstanza>\MSSQL\Data

Suggerimento Suggerimento

Se nella pagina Selezione dischi cluster è stato selezionato un disco condiviso, per impostazione predefinita verrà utilizzato il primo disco condiviso. Se nella pagina Selezione dischi cluster non è stata effettuata alcuna selezione, questo campo sarà vuoto per impostazione predefinita.

Assicurarsi che nella directory del log sia disponibile una quantità di spazio adeguata.

Directory database temporaneo

Disco locale, spazio di archiviazione condiviso, file server SMB

<Unità:>\Programmi\Microsoft SQL Server\MSSQL11.<IDIstanza>\MSSQL\Data

Suggerimento Suggerimento

Se nella pagina Selezione dischi cluster è stato selezionato un disco condiviso, per impostazione predefinita verrà utilizzato il primo disco condiviso. Se nella pagina Selezione dischi cluster non è stata effettuata alcuna selezione, questo campo sarà vuoto per impostazione predefinita.

Assicurarsi che la directory specificata sia valida per tutti i nodi del cluster. Durante il failover, se le directory tempdb non sono disponibili sul nodo di destinazione del failover, la risorsa di SQL Server non verrà riportata online.

Directory log database temporaneo

Disco locale, spazio di archiviazione condiviso, file server SMB

<Unità:>\Programmi\Microsoft SQL Server\MSSQL11.<IDIstanza>\MSSQL\Data

Suggerimento Suggerimento

Se nella pagina Selezione dischi cluster è stato selezionato un disco condiviso, per impostazione predefinita verrà utilizzato il primo disco condiviso. Se nella pagina Selezione dischi cluster non è stata effettuata alcuna selezione, questo campo sarà vuoto per impostazione predefinita.

Assicurarsi che la directory specificata sia valida per tutti i nodi del cluster. Durante il failover, se le directory tempdb non sono disponibili sul nodo di destinazione del failover, la risorsa di SQL Server non verrà riportata online.

Directory di backup

Disco locale, spazio di archiviazione condiviso, file server SMB

<Unità:>\Programmi\Microsoft SQL Server\MSSQL11.<IDIstanza>\MSSQL\Backup

Suggerimento Suggerimento

Se nella pagina Selezione dischi cluster è stato selezionato un disco condiviso, per impostazione predefinita verrà utilizzato il primo disco condiviso. Se nella pagina Selezione dischi cluster non è stata effettuata alcuna selezione, questo campo sarà vuoto per impostazione predefinita.

Impostare le autorizzazioni appropriate in modo da impedire la perdita di dati e assicurarsi che all'account utente per il servizio SQL Server vengano concesse autorizzazioni adeguate per la scrittura nella directory di backup. Non è supportato l'utilizzo di un'unità di cui è stato eseguito il mapping per le directory di backup.

Considerazioni sulla sicurezza

Durante l'installazione vengono configurati gli elenchi ACL per le directory di SQL Server e viene disattivata l'ereditarietà come parte della configurazione.

Al file server SMB si applicano le indicazioni seguenti:

  • L'account del servizio SQL Server deve essere un account di dominio se viene utilizzato un file server SMB.

  • L'account utilizzato per installare SQL Server deve disporre delle autorizzazioni FULL CONTROL NTFS nella cartella di condivisione file SMB utilizzata come directory dei dati.

  • È necessario che all'account utilizzato per installare SQL Server venga concesso il privilegio SeSecurityPrivilege nel file server SMB. Per concedere tale privilegio, utilizzare la console Criteri di sicurezza locali nel file server per aggiungere l'account di configurazione SQL Server ai criteri Gestione file registro di controllo e di sicurezza. Questa impostazione è disponibile nella sezione Assegnazione diritti utente in Criteri locali nella console Criteri di sicurezza locali.

Note

  • Quando si aggiungono caratteristiche a un'installazione esistente, non è possibile modificare il percorso di una caratteristica installata in precedenza, né specificare il percorso di una nuova caratteristica.

  • Se si specificano directory di installazione non predefinite, verificare che le cartelle di installazione siano univoche per l'istanza di SQL Server. Nessuna delle directory presenti in questa finestra di dialogo deve essere condivisa con le directory di altre istanze di SQL Server. Anche i componenti Motore di database e Analysis Services all'interno di un'istanza di SQL Server devono essere installati in directory separate.

  • Non è possibile installare file di programma e file di dati nelle situazioni seguenti:

    • In un'unità disco rimovibile

    • In un file system che utilizza la compressione

    • In una directory in cui si trovano i file di sistema

    • In un'unità di rete di cui è stato eseguito il mapping in un'istanza del cluster di failover

Vedere anche

Concetti

Percorsi dei file per le istanze predefinite e denominate di SQL Server

Altre risorse

Autorizzazioni NTFS e di condivisione in un file server


Configurazione del Motore di database - Filestream

[image]

Configurazione del Motore di database - Filestream
Vedere anche Commenti e suggerimenti

Utilizzare questa pagina per abilitare FILESTREAM per l'installazione corrente di Microsoft SQL Server 2012. FILESTREAM consente di integrare il Motore di database di SQL Server con un file system NTFS archiviando dati BLOB (Binary Large Object) varbinary(max) come file nel file system. Le istruzioni Transact-SQL possono inserire, aggiornare, eseguire query, ricerca e back up dei dati FILESTREAM. Le interfacce del file system Win32 forniscono accesso ai dati tramite flusso.

Abilita FILESTREAM per l'accesso Transact-SQL

Selezionare questa opzione per abilitare FILESTREAM per l'accesso Transact-SQL. È necessario che questo controllo sia selezionato affinché le altre opzioni di controllo siano disponibili.

Abilita FILESTREAM per l'accesso tramite il flusso di I/O dei file

Selezionare questa opzione per abilitare l'accesso tramite flusso Win32 per FILESTREAM.

Nome condivisione di Windows

Utilizzare questo controllo per immettere il nome della condivisione di Windows in cui verranno archiviati i dati FILESTREAM.

Consenti ai client remoti l'accesso tramite flusso ai dati FILESTREAM

Selezionare questo controllo per consentire ai client remoti di accedere ai dati FILESTREAM nel server corrente.

Vedere anche

Riferimento

sp_configure (Transact-SQL)

Concetti

Abilitazione e configurazione di FILESTREAM


Configurazione del Motore di database – Istanze utente

[image]

Configurazione del Motore di database – Istanze utente
Commenti e suggerimenti

Utilizzare la pagina Istanze utente per generare un'istanza distinta del Motore di database per gli utenti che non dispongono di autorizzazioni di amministratore, nonché per aggiungere utenti al ruolo di amministratore.

Opzione

Attiva istanze utente

Per impostazione predefinita questa opzione è abilitata. Per disabilitare la funzionalità di attivazione delle istanze utente, deselezionare la casella di controllo.

L'istanza utente, nota anche come istanza figlio o client, è un'istanza di SQL Server generata dall'istanza padre (l'istanza primaria eseguita come servizio, ad esempio SQLExpress) per conto di un utente. L'istanza utente viene eseguita come processo utente nel contesto di sicurezza di tale utente. L'istanza utente è isolata dall'istanza padre e da qualsiasi altra istanza che viene eseguita nel computer. Questa caratteristica è nota anche come RANU (Run As Normal User).

Nota Nota

Per gli account di accesso di cui è stato eseguito il provisioning come membri del ruolo predefinito del server sysadmin in fase di configurazione, viene effettuato il provisioning come amministratori nel database dei modelli. Gli account rimarranno membri del ruolo predefinito del server sysadmin nell'istanza utente, a meno che non vengano rimossi

Aggiungi utente al ruolo di amministratore di SQL Server

Per impostazione predefinita, questa opzione non è abilitata. Per aggiungere l'utente dell'installazione corrente al ruolo di amministratore di SQL Server, selezionare la casella di controllo.

Gli utenti di Windows Vista membri di BUILTIN\Administrators non vengono automaticamente aggiunti al ruolo predefinito del server sysadmin quando si connettono a SQL Server Express. Solo gli utenti di Windows Vista aggiunti esplicitamente a un ruolo di amministratore a livello di server possono amministrare SQL Server Express. Tutti i membri del gruppo Built-In\Users possono connettersi all'istanza di SQL Server Express, ma dispongono di autorizzazioni limitate per l'esecuzione delle operazioni relative al database. Agli utenti che ereditano i privilegi di SQL Server Express dai gruppi BUILTIN\Administrators e Built-In\Users delle versioni precedenti di Windows devono pertanto essere concessi esplicitamente privilegi amministrativi nelle istanze di SQL Server Express in esecuzione in Windows Vista.

Per apportare modifiche ai ruoli utente al termine del programma di installazione, utilizzare lo strumento Configurazione superficie di attacco (SQLSAC.exe) di SQL Server 2005. Per aggiornare l'elenco degli utenti nel ruolo di amministratore di sistema di SQL Server, fare clic sul collegamento Aggiungi nuovo amministratore.

Verificare che il campo Utente a cui concedere i privilegi contenga DomainName\UserName dell'utente le cui autorizzazioni devono essere aggiornate. Nell'elenco delle istanze di SQL Server incluso nel riquadro Privilegi disponibili selezionare il ruolo da aggiornare e quindi fare clic sulla freccia a destra. Per aggiungere l'utente a tutti i ruoli disponibili per tutte le istanze di SQL Server, fare clic sulla doppia freccia a destra.

Al termine delle selezioni, fare clic su OK per implementare le modifiche apportate. Per chiudere lo strumento senza apportare alcuna modifica, fare clic su Annulla.


Requisiti di spazio su disco

[image]

Requisiti di spazio su disco
Vedere anche Commenti e suggerimenti

Utilizzare la pagina Riepilogo spazio richiesto per esaminare i requisiti di spazio su disco relativi alle caratteristiche di SQL Server selezionate per l'installazione.

Opzioni

Se lo spazio su disco richiesto è troppo elevato, considerare le opzioni seguenti:

  • Impostare le directory di installazione su un'unità con una quantità maggiore di spazio su disco.

  • Modificare le caratteristiche di SQL Server per l'installazione.

  • Creare più spazio disponibile nell'unità specificata spostando gli altri file o le altre applicazioni.

Vedere anche

Altre risorse

Requisiti hardware e software per l'installazione di SQL Server 2008 R2


Configurazione Distributed Replay Controller

[image]

Configurazione Distributed Replay Controller
Commenti e suggerimenti

Utilizzare la pagina Configurazione Distributed Replay Controller dell'Installazione guidata di SQL Server per specificare gli utenti a cui si desidera concedere autorizzazioni amministrative per il servizio Distributed Replay Utility (DRU) Controller.

Gli utenti che dispongono di autorizzazioni amministrative disporranno di accesso illimitato al servizio Distributed Replay Controller.

Opzioni

Aggiungi utente corrente

Fare clic su questo pulsante per aggiungere gli utenti a cui si desidera concedere autorizzazioni di accesso per il servizio Distributed Replay Controller.

Aggiungi

Fare clic su questo pulsante per aggiungere autorizzazioni di accesso per il servizio Distributed Replay Controller.

Rimuovi

Fare clic su questo pulsante per rimuovere autorizzazioni di accesso dal servizio Distributed Replay Controller.


Configurazione Distributed Replay Client

[image]

Configurazione Distributed Replay Client
Commenti e suggerimenti

Utilizzare la pagina Configurazione Distributed Replay Client dell'Installazione guidata di SQL Server per specificare gli utenti a cui si desidera concedere autorizzazioni amministrative per il servizio Distributed Replay Client.

Gli utenti che dispongono di autorizzazioni amministrative disporranno di accesso illimitato al servizio Distributed Replay Client.

Opzioni

Nome controller

Si tratta di un parametro facoltativo e il valore predefinito è <blank>.

Immettere il nome del controller che il computer client comunicherà con per il servizio Distributed Replay Client. Si noti quanto segue:

  • Il nome deve essere un nome di dominio completo. Ad esempio, è possibile che un host denominato server1 nella gerarchia dei prodotti di Microsoft disponga di un nome di dominio completo server1.products.microsoft.com.

  • Se è già stato configurato un controller, immettere il nome del controller durante la configurazione di ciascuno client.

  • In caso contrario, è possibile lasciare vuoto il nome del controller. Tuttavia, è necessario immettere manualmente il nome del controller nel file configurazione client.

Directory di lavoro

Specificare la directory di lavoro per il servizio Distributed Replay Client.

La directory di lavoro predefinita è <drive letter>:\Programmi\Microsoft SQL Server\DReplayClient\WorkingDir\.

Directory dei risultati

Specificare la directory dei risultati per il servizio Distributed Replay Client.

La directory dei risultati predefinita è <drive letter>:\Programmi\Microsoft SQL Server\DReplayClient\ResultDir\.


Regole per l'aggiornamento delle edizioni

[image]

Regole per l'aggiornamento delle edizioni
Vedere anche Commenti e suggerimenti

Prima che l'operazione di installazione di SQL Server venga completata, viene convalidata la configurazione del computer. Durante l'installazione di SQL Server viene eseguita l'analisi del computer in cui verrà installato SQL Server tramite Controllo configurazione sistema. Questo strumento consente di verificare le condizioni che impediscono la corretta operazione di installazione di SQL Server. Prima dell'avvio dell'aggiornamento dell'edizione, lo strumento recupera le informazioni sullo stato di ciascun elemento. Il risultato viene confrontato con i requisiti, quindi vengono fornite indicazioni per la rimozione di eventuali problemi che impediscono di proseguire.

Con il controllo della configurazione di sistema viene generato un report con una breve descrizione di ogni regola eseguita, nonché lo stato dell'esecuzione. Il report di controllo della configurazione si trova nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMGG_HHMM>\.

Prima di eseguire l'operazione di installazione, esaminare i seguenti argomenti:

  1. Requisiti hardware e software per l'installazione di SQL Server (http://go.microsoft.com/fwlink/? LinkId=235029)

  2. Funzionalità supportate dalle Edizioni di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerazioni sulla sicurezza per un'installazione di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versioni in lingua locale di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Altri riferimenti:

  1. Aggiornamenti di versione ed edizione supportati(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Operazioni preliminari all'installazione del clustering di failover(http://go.microsoft.com/fwlink/?LinkId=235034)

Vedere anche

Riferimento

Regole di supporto per l'installazione


Segnalazione errori

[image]

Segnalazione errori
Commenti e suggerimenti

Utilizzare la pagina Impostazioni segnalazione errori e utilizzo funzionalità dell'Installazione guidata di SQL Server per abilitare la funzionalità di segnalazione degli errori e di utilizzo delle funzionalità di SQL Server.

Opzioni

La segnalazione degli errori e la raccolta dei dati di utilizzo delle funzionalità sono disabilitate per impostazione predefinita in SQL Server e nei relativi in Microsoft SQL Server 2012.

Segnalazione errori

Se si abilita la funzionalità Segnalazione errori, SQL Server viene configurato per l'invio automatico di un report a Microsoft in caso si verifichi un errore irreversibile in uno dei componenti di SQL Server seguenti:

  • Il Motore di database

  • SQL Server Agent

  • Analysis Services

  • Reporting Services

  • Integration Services

  • Replica

Le segnalazioni degli errori sono considerate riservate e vengono utilizzate da Microsoft per migliorare le funzionalità di SQL Server.

Le informazioni relative agli errori vengono inviate mediante una connessione protetta (https) a Microsoft e archiviate con diritti di accesso limitati. In alternativa, le segnalazioni possono essere inviate al server interno per la segnalazione degli errori (Corporate Error Reporting).

Nelle segnalazioni degli errori sono incluse le informazioni seguenti:

  • La condizione di SQL Server nel momento in cui si è verificato il problema.

  • La versione del sistema operativo e le informazioni sull'hardware del computer.

  • L'ID digitale del prodotto che non viene utilizzato per l'identificazione della licenza.

  • L'indirizzo IP di rete del computer o del server proxy.

  • Le informazioni ricavate dalla memoria o dai file del processo che ha generato l'errore.

Microsoft non raccoglie intenzionalmente file, nomi, indirizzi, indirizzi di posta elettronica o qualsiasi altra forma di informazioni personali. È tuttavia possibile che la segnalazione degli errori contenga informazioni personali ricavate dalla memoria o dai file del processo che ha generato l'errore. Le informazioni raccolte possono contenere dati personali. Tuttavia, tali informazioni non saranno utilizzate da Microsoft in alcun modo per identificare l'utente.

Per ulteriori informazioni sulla SQL Server privacy e sui criteri della raccolta dati, vedere Informativa sulla privacy di Microsoft SQL Server.

Se dopo avere abilitato la funzionalità Segnalazione errori si verifica un errore irreversibile, è possibile che venga visualizzata una risposta da Microsoft nel registro eventi di Windows con un collegamento a un articolo della Microsoft Knowledge Base relativo all'errore specifico.

Per disabilitare le funzionalità di segnalazione degli errori e di utilizzo delle funzionalità per tutte le istanze di SQL Server e nei relativi componenti al termine dell'installazione, aprire la finestra di dialogo Impostazioni segnalazione errori e utilizzo funzionalità e deselezionare le caselle di controllo relative a Utilizzo funzionalità. Se l'opzione Segnalazione errori è abilitata per più componenti di SQL Server, ovvero il Motore di database di SQL Server, Analysis Services, Reporting Services e i componenti condivisi, è possibile disabilitarla per ogni istanza di un singolo componente o di componenti condivisi, indicati come Altri.


Report cluster di failover

[image]

Report cluster di failover
Commenti e suggerimenti

Utilizzare la pagina Report cluster di failover per visualizzare i risultati del report generati dall'analisi del sistema di installazione per questa operazione.

Opzioni

Per visualizzare un report dettagliato per l'analisi, fare clic sul collegamento al report.


Esame caratteristiche

[image]

Esame caratteristiche
Vedere anche Commenti e suggerimenti

La pagina Esame caratteristiche è un elenco di sola lettura di caratteristiche che sono state preparate e saranno configurate e completate alla fine del passaggio di completamento dell'immagine. L'elenco delle caratteristiche viene selezionato durante il passaggio relativo alla preparazione dell'immagine e non può essere modificato durante il passaggio di completamento dell'immagine. Oltre alle caratteristiche visualizzate, un'istanza predisposta include anche SQL Server Browser, Writer di SQL Server e SQL Server Native Client.

È possibile aggiungere altre caratteristiche non incluse nell'istanza predisposta dell'istanza di SQL Server dopo aver completato la configurazione dell'istanza predisposta di SQL Server..

Gruppo di componenti

Componenti e caratteristiche

Servizi Motore di database

Nel Motore di database di SQL Server sono inclusi i seguenti componenti:

  • Motore di database è il servizio principale per l'archiviazione, l'elaborazione e la sicurezza dei dati.

    • Replica: (Facoltativo) La funzione di replica è un set di tecnologie per la copia e la distribuzione di dati e oggetti di database da un database a un altro e la successiva sincronizzazione dei database per garantirne la coerenza.

    • Ricerca full-text (facoltativa): la ricerca full-text fornisce le funzionalità necessarie per eseguire query full-text su semplici dati di tipo carattere in tabelle di SQL Server.

    • Data Quality Services (facoltativo): Data Quality Services (DQS) è una soluzione per la pulizia dei dati che consente di individuare dati incoerenti e non corretti nell'origine dati e che offre metodi automatici e interattivi per pulire i dati.

Reporting Services

In Reporting Services sono inclusi componenti client e server per la creazione, la gestione e la distribuzione di report tabulari, matrice, grafici e in formato libero. Reporting Services è inoltre una piattaforma estendibile che consente di sviluppare applicazioni di creazione di report.

Vedere anche

Altre risorse

Procedura: Installare SQL Server tramite SysPrep


Regole di installazione

[image]

Regole di installazione
Vedere anche Commenti e suggerimenti

Prima che l'operazione di installazione di SQL Server venga completata, viene convalidata la configurazione del computer. Durante l'installazione di SQL Server viene eseguita l'analisi del computer in cui verrà installato SQL Server tramite Controllo configurazione sistema. Questo strumento consente di verificare le condizioni che impediscono la corretta operazione di installazione di SQL Server. Prima dell'avvio dell'installazione guidata di SQL Server, lo strumento recupera le informazioni sullo stato di ciascun elemento. Il risultato viene confrontato con i requisiti, quindi vengono fornite indicazioni per la rimozione di eventuali problemi che impediscono di proseguire.

Con il controllo della configurazione di sistema viene generato un report con una breve descrizione di ogni regola eseguita, nonché lo stato dell'esecuzione. Il report di controllo della configurazione si trova nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMGG_HHMM>\.

Prima di eseguire l'operazione di installazione, esaminare i seguenti argomenti:

  1. Requisiti hardware e software per l'installazione di SQL Server (http://go.microsoft.com/fwlink/? LinkId=235029)

  2. Funzionalità supportate dalle Edizioni di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerazioni sulla sicurezza per un'installazione di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versioni in lingua locale di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Altri riferimenti:

  1. Aggiornamenti di versione ed edizione supportati(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Operazioni preliminari all'installazione del clustering di failover(http://go.microsoft.com/fwlink/?LinkId=235034)

Vedere anche

Riferimento

Regole di supporto per l'installazione


Regole delle funzionalità

[image]

Regole delle funzionalità
Commenti e suggerimenti

Prima che l'operazione di installazione di SQL Server venga completata, viene convalidata la configurazione del computer. Durante l'installazione di SQL Server viene eseguita l'analisi del computer in cui verrà installato SQL Server tramite Controllo configurazione sistema. Questo strumento consente di verificare le condizioni che impediscono la corretta operazione di installazione di SQL Server. Prima dell'avvio del programma di installazione, lo strumento recupera le informazioni sullo stato di ciascun elemento. Il risultato viene confrontato con i requisiti, quindi vengono fornite indicazioni per la rimozione di eventuali problemi che impediscono di proseguire.

Con il controllo della configurazione di sistema viene generato un report con una breve descrizione di ogni regola eseguita, nonché lo stato dell'esecuzione. Il report di controllo della configurazione si trova nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMGG_HHMM>\.

Prima di eseguire l'operazione di installazione, esaminare i seguenti argomenti:

  1. Requisiti hardware e software per l'installazione di SQL Server (http://go.microsoft.com/fwlink/? LinkId=235029)

  2. Funzionalità supportate dalle Edizioni di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerazioni sulla sicurezza per un'installazione di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versioni in lingua locale di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Altri riferimenti:

  1. Aggiornamenti di versione ed edizione supportati(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Operazioni preliminari all'installazione del clustering di failover(http://go.microsoft.com/fwlink/?LinkId=235034)


Selezione funzionalità

[image]

Selezione funzionalità
Vedere anche Commenti e suggerimenti

Utilizzare le caselle di controllo disponibili nella pagina Selezione funzionalità dell'Installazione guidata di SQL Server per selezionare i componenti desiderati per l'installazione di SQL Server.

Installazione delle funzionalità di SQL Server

Nella pagina Selezione funzionalità, le funzionalità di SQL Server sono separate in due sezioni principali: Funzionalità dell'istanza e Funzionalità condivise.

In Funzionalità dell'istanza sono presenti i componenti che vengono installati una volta per ogni istanza in modo da averne più copie, una per ogni istanza. Ogni istanza può essere una versione separata per cui è disponibile un livello di patch diverso. Quando si installa una patch, indipendentemente dal fatto che sia un Service Pack, un hotfix o un aggiornamento cumulativo, vengono aggiornati solo i file per un'istanza in un computer specifico e le funzionalità condivise, se non sono già state aggiornate.

In Funzionalità condivise sono presenti le funzionalità comuni a tutte le istanze di un computer specifico. Ognuna di queste funzionalità condivise viene progettata per essere compatibile con le versioni precedenti di SQL Server supportate (Service Pack, aggiornamenti cumulativi e hotfix) che possono essere installate side-by-side.

Nota Nota

SQL Server SysPrep: il Motore di database e Reporting Services sono le uniche funzionalità di Microsoft SQL Server 2012 che supportano SQL Server SysPrep. È possibile selezionare queste funzionalità e i componenti durante il passaggio relativo alla preparazione dell'immagine del processo. Non è possibile effettuare la selezione durante il completamento di un'immagine predisposta di SQL Server. Per ulteriori informazioni, vedere Procedura: Installazione di SQL Server 2012 tramite SysPrep (http://go.microsoft.com/fwlink/?LinkId=190965).

Cluster di failover di SQL Server: i componenti Motore di database e Analysis Services sono le uniche funzionalità di Microsoft SQL Server 2012 che supportano il clustering di failover. Sebbene sia possibile installare altri componenti, ad esempio Reporting Services o Integration Services, in un nodo del cluster di failover, questi non sono compatibili e non viene eseguito il failover dei rispettivi servizi se il nodo del cluster di failover passa alla modalità offline. Per ulteriori informazioni, vedere la pagina relativa all'introduzione al clustering di failover di SQL Server (http://go.microsoft.com/fwlink/?LinkId=190953).

Funzionalità dell'istanza

Quando si seleziona un gruppo di componenti, nel riquadro Descrizione verrà visualizzata la relativa descrizione. È possibile selezionare qualsiasi combinazione di caselle di controllo. Per continuare, è necessario effettuare una selezione.

Funzionalità

Descrizione

Servizi Motore di database

In Motore di database di SQL Server è incluso il Motore di database, cioè il servizio di base per l'archiviazione, l'elaborazione e la sicurezza dei dati, la replica, la ricerca full-text, gli strumenti per la gestione di dati XML e relazionali, nonché il server DQS (Data Quality Services).

  • Il Motore di database è il servizio di base per l'archiviazione, l'elaborazione e la sicurezza dei dati.

  • Replica (facoltativo): la funzione di replica è costituita da un set di tecnologie per la copia e la distribuzione di dati e oggetti di database da un database a un altro e la successiva sincronizzazione dei database per garantirne la coerenza.

  • Ricerca full-text (facoltativo): la ricerca full-text fornisce le funzionalità necessarie per effettuare query full-text su semplici dati di tipo carattere in tabelle di SQL Server.

  • Data Quality Services (facoltativo): Data Quality Services (DQS) è una soluzione per la pulizia dei dati che consente di individuare dati incoerenti e non corretti nell'origine dati e che offre metodi interattivi e assistiti da computer per pulire i dati. Selezionare questa casella di controllo per installare il server DQS. Una volta completata l'installazione di SQL Server, sarà necessario eseguire il file DQSInstaller.exe per completare l'installazione del server DQS. Se è stata installata l'istanza predefinita di SQL Server, il file sarà in genere disponibile in C:\Programmi\Microsoft SQL Server\MSSQL11.MSSQLSERVER\MSSQL\Binn.

Cluster di failover di SQL Server: i componenti di replica e di ricerca full-text sono necessari e vengono selezionati automaticamente dal programma di installazione per il clustering di failover di SQL Server quando si seleziona Servizi motore di database.

Analysis Services

In Analysis Services sono inclusi gli strumenti per la creazione e la gestione delle applicazioni di data mining e di elaborazione analitica online (OLAP).

Modalità nativa di Reporting Services

Nella modalità nativa di Reporting Services sono inclusi componenti client e server per la creazione, la gestione e la distribuzione di report tabulari, matrice, grafici e in formato libero. Reporting Services è inoltre una piattaforma estendibile che consente di sviluppare applicazioni di creazione di report.

Nota importante Importante

  1. Con il programma di installazione non è possibile configurare il bilanciamento del carico e l'indirizzamento a URL singolo per più nodi in una distribuzione con scalabilità orizzontale di Reporting Services. Per completare una distribuzione con scalabilità orizzontale, è necessario utilizzare Windows Server, Microsoft Application Center o un software di gestione cluster di terze parti. Per ulteriori informazioni sulla configurazione della distribuzione di Web farm, vedere la pagina relativa alla configurazione di Reporting Services per una distribuzione con scalabilità orizzontale (http://go.microsoft.com/fwlink/?LinkId=199448).

  2. Microsoft Internet Explorer 7.0 SP 1 è necessario per il componente Progettazione report di Reporting Services.

  3. Reporting Services non è supportato in configurazioni side-by-side presenti contemporaneamente nella piattaforma a 64 bit e nel sottosistema a 32 bit (WOW64) di un server a 64 bit.

Funzionalità condivise

Le funzionalità condivise da tutte le istanze di SQL Server in un singolo computer vengono installate in un'unica directory. Di seguito ne sono riportate alcune:

Funzionalità

Descrizione

Modalità SharePoint di Reporting Services

La modalità SharePoint di Reporting Services è un'applicazione basata su server per la creazione, la gestione e il recapito di report tramite posta elettronica, in diversi formati di file e in formati interattivi basati su Web. Nella modalità SharePoint la visualizzazione e la gestione dei report sono integrate nei prodotti SharePoint.

Componente aggiuntivo Reporting Services per prodotti SharePoint

Nel componente aggiuntivo Reporting Services per prodotti SharePoint sono disponibili componenti di gestione e dell'interfaccia utente che permettono di integrare un prodotto SharePoint con un server di report di Reporting Services in modalità SharePoint.

Client Data Quality

Il client Data Quality è un'applicazione autonoma che consente la connessione al server DQS e offre un'interfaccia utente grafica intuitiva per eseguire operazioni di pulizia o corrispondenza dei dati ed effettuare attività amministrative in DQS.

SQL Server Data Tools1

In SQL Server Data Tools (SSDT) è disponibile un IDE per la compilazione di soluzioni per i componenti di Business Intelligence: Analysis Services, Reporting Services e Integration Services

(in precedenza denominato Business Intelligence Development Studio).

In SSDT è inoltre incluso un ambiente integrato che consente agli sviluppatori di database di svolgere tutte le attività di progettazione di database per qualsiasi piattaforma SQL Server, locale e non, all'interno di Visual Studio. Gli sviluppatori di database possono utilizzare le funzionalità avanzate di Esplora server in Visual Studio per creare o modificare facilmente dati e oggetti di database oppure eseguire query.

Connettività strumenti client

Negli strumenti client sono inclusi i componenti per la comunicazione tra client e server, quali le librerie di rete per DB-Library, OLEDB per OLAP, ODBC, ADODB e ADOMD+.

Integration Services

Integration Services è un set di strumenti grafici e oggetti programmabili per lo spostamento, la copia e la trasformazione di dati.

Compatibilità con le versioni precedenti di strumenti client.

In Compatibilità con le versioni precedenti di strumenti client sono inclusi i componenti seguenti:

  • SQL-DMO (SQL Distributed Management Objects). Per ulteriori informazioni, vedere Funzionalità di SQL Server obsolete in SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=190968).

  • DSO (Decision Support Objects). Per ulteriori informazioni, vedere Modifiche di rilievo nelle funzionalità di Analysis Services in SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=190970).

SDK di strumenti client

È incluso il Software Development Kit (SDK) contenente le risorse per i programmatori.

Componenti della documentazione

Nei componenti della documentazione sono inclusi i componenti per visualizzare e gestire il contenuto della Guida.

Strumenti di gestione - Di base

Strumenti di gestione - Di base: sono inclusi i seguenti:

  • Il supporto di SQL Server Management Studio per il Motore di database di SQL Server, SQL Server Express, l'utilità sqlcmd e il provider PowerShell per SQL Server.

Strumenti di gestione - Completa: oltre ai componenti della versione di base sono inclusi i componenti seguenti:

  • Supporto di SQL Server Management Studio per Reporting Services, Analysis Services e Integration Services

  • SQL Server Profiler

  • Ottimizzazione guidata motore di database

  • Gestione delle utilità di SQL Server

Distributed Replay Controller

Con Distributed Replay Controller è possibile orchestrare le azioni dei client di riproduzione distribuita. In ogni ambiente di riproduzione distribuita può essere presente una sola istanza del controller. Per ulteriori informazioni, vedere la pagina relativa a SQL Server Distributed Replay (http://go.microsoft.com/fwlink/?LinkId=229847).

Distributed Replay Client

I client di riproduzione distribuita vengono utilizzati insieme per simulare carichi di lavoro in un'istanza di SQL Server. In ogni ambiente di riproduzione distribuita possono essere presenti uno o più client. Per ulteriori informazioni, vedere la pagina relativa a SQL Server Distributed Replay (http://go.microsoft.com/fwlink/?LinkId=229847).

SDK di Connettività SQL Client

È incluso l'SDK di SQL Server Native Client (ODBC/OLE DB) per lo sviluppo dell'applicazione di database.

Master Data Services

Master Data Services è una piattaforma per l'integrazione di dati da sistemi disparati di un'organizzazione in una sola origine di dati master per fini di accuratezza e controllo. L'opzione Master Data Services consente di installare Gestione configurazione Master Data Services, assembly, uno snap-in di Windows PowerShell, nonché cartelle e file per servizi e applicazioni Web.

LocalDB

LocalDB è una modalità di esecuzione di SQL Server Express destinata agli sviluppatori, Avviata da una stringa di connessione speciale, l'infrastruttura SQL Server necessaria viene creata automaticamente e avviata, consentendo all'applicazione di utilizzare il database senza attività di configurazione o di gestione.

1Per le installazioni di SQL Server Data Tools (SSDT) è necessario Internet Explorer 6.0 SP1.

Per impostazione predefinita, i componenti condivisi vengono installati in %Programmi%Microsoft SQL Server\. Per modificare il percorso di installazione, scegliere Sfoglia. Se si modifica il percorso di installazione di un componente condiviso, la modifica verrà applicata a tutti gli altri componenti condivisi. Nelle installazioni successive i componenti condivisi verranno installati nello stesso percorso dell'installazione originale.

Nei sistemi operativi basati su processore x64, è possibile specificare il percorso di installazione dei componenti 64 bit e quello dei componenti a 32 bit nel sottosistema WOW64.

Installazione dei database di esempio AdventureWorks

Per impostazione predefinita, i database di esempio e il codice di esempio non vengono installati come parte dell'installazione di SQL Server. Per ulteriori informazioni sull'installazione di database e codici di esempio, vedere Esempi e progetti della community di Microsoft SQL Server (http://go.microsoft.com/fwlink/?LinkId=87843).

Informazioni aggiuntive sugli esempi sono disponibili in seguito all'installazione di Microsoft SQL Server 2012. Fare clic sul menu Start, scegliere Tutti i programmi, Microsoft SQL Server 2012, Documentazione ed esercitazioni, quindi Panoramica esempi di Microsoft SQL Server.

Vedere anche

Altre risorse

Edizioni e componenti di SQL Server 2012


Selezione caratteristiche (disinstallazione)

[image]

Selezione caratteristiche (disinstallazione)
Commenti e suggerimenti

Utilizzare la pagina Selezione caratteristiche – Disinstallazione per selezionare le caratteristiche da rimuovere dall'istanza specificata di SQL Server.

Opzioni

È possibile selezionare qualsiasi combinazione di caratteristiche.


Caratteristiche da aggiornare

[image]

Caratteristiche da aggiornare
Vedere anche Commenti e suggerimenti

Utilizzare la pagina contenente le caratteristiche da aggiornare dell'Installazione guidata di Microsoft SQL Server 2012 per visualizzare le caratteristiche che si desidera aggiornare a Microsoft SQL Server 2012.

Opzioni

  • Non è possibile modificare le caratteristiche da aggiornare in questa versione. Per aggiungere caratteristiche a questa istanza di SQL Server, completare il processo di aggiornamento, riavviare l'installazione e fare clic su Nuova installazione o aggiunta di caratteristiche a un'installazione esistente nel Centro installazione.

Vedere anche

Altre risorse

Aggiornamenti di versione ed edizione
Utilizzo di Preparazione aggiornamento per preparare gli aggiornamenti
Utilizzo di più versioni di SQL Server


Opzioni di aggiornamento della ricerca full-text

[image]

Opzioni di aggiornamento della ricerca full-text
Commenti e suggerimenti

Utilizzare la pagina Opzioni di aggiornamento della ricerca full-text dell'Installazione guidata di SQL Server per selezionare l'opzione di aggiornamento della ricerca full-text da utilizzare per l'aggiornamento dei database.

In SQL Server 2005 e versioni precedenti, ogni indice full-text risiede in un catalogo full-text che appartiene a un filegroup, dispone di un percorso fisico e viene considerato un file di database. A partire da SQL Server 2008, un catalogo full-text è un concetto logico, ovvero un oggetto virtuale, che fa riferimento a un gruppo di indici full-text. Pertanto, un nuovo catalogo full-text non viene considerato un file di database con un percorso fisico. Tuttavia, durante l'aggiornamento di un catalogo full-text contenente file di dati viene creato un nuovo filegroup nello stesso disco mantenendo in questo modo il vecchio comportamento I/O su disco dopo l'aggiornamento. Tutti gli indici full-text di quel catalogo vengono posizionati nel nuovo filegroup se esiste il percorso radice. Se il percorso precedente del catalogo full-text non è valido, l'indice full-text rimane nello stesso filegroup della tabella di base o nel filegroup primario nel caso di una tabella partizionata.

Opzioni

Quando si esegue l'aggiornamento da SQL Server 2005 o SQL Server 2008 a Microsoft SQL Server 2012, scegliere una delle opzioni di aggiornamento full-text seguenti.

Importazione

I cataloghi full-text vengono importati. In genere, l'importazione è molto più veloce della ricompilazione. Se ad esempio si utilizza solo una CPU, l'importazione è di circa 10 volte più veloce della ricompilazione. Un catalogo full-text importato da SQL Server 2005 non utilizza tuttavia i nuovi word breaker ottimizzati introdotti in SQL Server 2008 e pertanto potrebbe essere necessario ricompilare i cataloghi full-text.

Nota Nota

La ricompilazione può essere eseguita in modalità a thread multipli e, nel caso in cui siano disponibili più di 10 CPU, può risultare più veloce dell'importazione se si consente alla ricompilazione di utilizzare tutte le CPU.

Se non è disponibile un catalogo full-text, vengono ricompilati gli indici full-text associati. Questa opzione è disponibile solo per i database di SQL Server 2005.

Per informazioni sull'impatto dell'importazione di un indice full-text, vedere "Considerazioni per la scelta di un'opzione di aggiornamento full-text" più avanti in questo argomento.

Ricompilazione

I cataloghi full-text vengono ricompilati utilizzando i nuovi word breaker ottimizzati introdotti in SQL Server 2008. La ricompilazione degli indici può richiedere tempo e dopo l'aggiornamento potrebbe essere necessaria una quantità significativa di CPU e di memoria.

Reimposta

I cataloghi full-text vengono ripristinati. Quando si esegue l'aggiornamento da SQL Server 2005, i file dei cataloghi full-text vengono rimossi, ma i metadati per i cataloghi full-text e gli indici full-text vengono mantenuti. Dopo l'aggiornamento, in tutti gli indici full-text il rilevamento delle modifiche viene disabilitato e le ricerche per indicizzazione non vengono avviate automaticamente. Il catalogo resterà vuoto fino a quando non si eseguirà manualmente un popolamento completo al termine dell'aggiornamento.

Tutte queste opzioni di aggiornamento consentono ai database aggiornati di sfruttare appieno i miglioramenti delle prestazioni full-text di SQL Server 2008 e versioni successive.

Nota importante Importante

Per informazioni sull'utilizzo dei nuovi word breaker e sull'aggiornamento dei file di parole non significative agli elenchi di parole non significative dopo l'importazione di un indice full-text di SQL Server 2005, vedere l'argomento relativo all'aggiornamento della ricerca full-text nella Guida del programma di installazione di Microsoft SQL Server 2012.

Considerazioni per la scelta di un'opzione di aggiornamento full-text

Quando si sceglie l'opzione di aggiornamento, tenere presente quanto segue:

  • Modalità di utilizzo dei word breaker

    Il servizio di ricerca full-text in Microsoft SQL Server 2012 include word breaker e stemmer introdotti in SQL Server 2008, che potrebbero modificare i risultati delle query full-text rispetto a SQL Server 2005 per un modello di testo o uno scenario specifico. Pertanto, la modalità di utilizzo dei word breaker è importante nella scelta di un'opzione di aggiornamento appropriata:

    • Se i word breaker della lingua full-text non sono stati modificati in SQL Server 2008 o versioni successive oppure se l'accuratezza delle chiamate non è essenziale, è consigliabile utilizzare l'importazione. Se successivamente si verificano problemi relativi alle chiamate, è possibile eseguire l'aggiornamento ai nuovi word breaker ricompilando semplicemente i cataloghi full-text. Per ulteriori informazioni, vedere l'argomento relativo all'aggiornamento della ricerca full-text nella Guida del programma di installazione di Microsoft SQL Server 2012.

    • Se invece l'accuratezza delle chiamate è importante e si utilizza uno dei word breaker ottimizzati in SQL Server 2008, è consigliabile eseguire la ricompilazione.

  • Eventuale presenza di indici full-text compilati in colonne chiave full-text di tipo integer

    Con la ricompilazione vengono eseguite ottimizzazioni interne che in alcuni casi migliorano le prestazioni di esecuzione delle query dell'indice full-text aggiornato. In particolare, se si dispone di cataloghi full-text che contengono indici full-text per i quali la colonna chiave full-text della tabella di base è un tipo di dati integer, la ricompilazione consente di ottenere prestazioni ideali delle query full-text dopo l'aggiornamento. In questo caso, è fortemente consigliabile utilizzare l'opzione Ricompila.

    Nota Nota

    Per gli indici full-text in Microsoft SQL Server 2012 è consigliabile che la colonna utilizzata come chiave full-text sia un tipo di dati integer. Per ulteriori informazioni, vedere l'argomento relativo all'ottimizzazione delle prestazioni (ricerca full-text) nella documentazione online di Microsoft SQL Server 2012.

  • Priorità della disponibilità online dell'istanza del server

    L'importazione o la ricompilazione durante l'aggiornamento richiede l'utilizzo di molte risorse della CPU ritardando in questo modo l'aggiornamento del resto dell'istanza del server e la disponibilità online dell'istanza stessa. Se la disponibilità online dell'istanza del server è essenziale e si desidera eseguire un popolamento manuale dopo l'aggiornamento, è consigliabile utilizzare l'opzione Reimposta.


Operazione completata - Installazione

[image]

Operazione completata - Installazione
Vedere anche Commenti e suggerimenti

Fare clic su Chiudi per terminare l'installazione.

Vedere anche

Concetti

Convalidare un'installazione di SQL Server


Prerequisiti di installazione

[image]

Prerequisiti di installazione
Commenti e suggerimenti

Per la corretta installazione di SQL Server, è necessario che nel computer di installazione siano disponibili i componenti software riportati di seguito. Tali componenti verranno installati dal programma di installazione di SQL Server:

  • .NET Framework versione 4.0 per tutte le altre edizioni di Microsoft SQL Server 2012

  • File di supporto per l'installazione di SQL Server

  • SQL Server Native Client

Nota Nota

Questi componenti non vengono rimossi se l'installazione viene annullata o non viene completata. Per rimuoverli, utilizzare Installazione applicazioni nel Pannello di controllo.

Opzioni

Per installare i file necessari, fare clic su Installa. Per uscire dall'installazione, scegliere Annulla.


Stato dell'installazione

[image]

Stato dell'installazione
Vedere anche Commenti e suggerimenti

Utilizzare la pagina Stato dell'installazione dell'Installazione guidata di SQL Server per monitorare lo stato dell'installazione di SQL Server.

Vedere anche

Concetti

Visualizzare e leggere i file di log del programma di installazione di SQL Server


Tipo di installazione

[image]

Tipo di installazione
Commenti e suggerimenti

Nella pagina Tipo di installazione dell'Installazione guidata di SQL Server è possibile specificare se installare una nuova istanza di SQL Server o aggiungere caratteristiche a un'istanza esistente.

Opzioni

Selezionare il pulsante di opzione corrispondente alla scelta:

  • Esegui una nuova installazione di SQL Server

  • Aggiungi caratteristiche a un'istanza esistente di SQL Server

    Se si seleziona l'opzione che consente di aggiungere caratteristiche a un'istanza esistente, utilizzare l'elenco a discesa per selezionare l'istanza di SQL Server da aggiornare.

È possibile soltanto aggiungere le caratteristiche supportate da SysPrep, ovvero Motore di database e Reporting Services, a un'immagine predisposta di SQL Server. Le altre caratteristiche non supportate da SysPrep possono essere aggiunte solo dopo aver completato l'istanza predisposta.

Nota Non è possibile aggiungere caratteristiche a un'istanza del cluster di failover dopo averlo installato. Per aggiungere caratteristiche di SQL Server a un cluster di failover esistente, è necessario eseguire una nuova installazione di un'istanza distinta di SQL Server.


Configurazione dell'istanza

[image]

Configurazione dell'istanza
Commenti e suggerimenti

Utilizzare la pagina Configurazione dell'istanza dell'Installazione guidata di SQL Server per specificare se creare un'istanza predefinita oppure un'istanza denominata di SQL Server. Se un'istanza di SQL Server non è già installata, verrà creata un'istanza predefinita a meno che non si specifichi un'istanza denominata.

Ogni istanza di SQL Server è costituita da un set distinto di servizi con impostazioni specifiche per le regole di confronto e le altre opzioni. La struttura della directory, la struttura del Registro di sistema e i nomi dei servizi riflettono il nome dell'istanza e un ID di istanza specifico creato durante l'installazione di SQL Server.

Un'istanza può essere l'istanza predefinita oppure un'istanza denominata. Il nome dell'istanza predefinita è MSSQLSERVER. Non è necessario che un client specifichi il nome dell'istanza per stabilire una connessione. Un'istanza denominata è determinata dall'utente durante l'installazione. È possibile installare SQL Server come istanza denominata senza prima installare l'istanza predefinita. Indipendentemente dalla versione, l'istanza predefinita può essere costituita solo da un'installazione di SQL Server per volta.

Nota Nota

Con SQL Server SysPrep è possibile specificare il nome dell'istanza quando si completa un'istanza predisposta nella pagina Configurazione dell'istanza. È possibile scegliere di configurare l'istanza predisposta che si sta completando come istanza predefinita se non è presente alcuna istanza predefinita di SQL Server sul computer.

Più istanze

SQL Server supporta più istanze di SQL Server in un singolo server o processore, ma solo un'istanza può costituire l'istanza predefinita, mentre tutte le altre istanze devono essere istanze denominate. Un computer può eseguire più istanze di SQL Server simultaneamente e ciascuna di esse viene eseguita in modo indipendente dalle altre.

Per ulteriori informazioni, vedere Specifiche di capacità massima per SQL Server.

Opzioni

Solo istanze del cluster di failover: specificare il nome di rete del cluster di failover di SQL Server. Questo nome identifica l'istanza del cluster di failover nella rete.

Istanza predefinita o denominata: nel determinare se installare un'istanza predefinita o denominata di SQL Server, tenere presenti le informazioni seguenti:

  • Se si intende installare una singola istanza di SQL Server in un server di database, l'istanza deve essere predefinita.

  • Utilizzare un'istanza denominata nei casi in cui si prevede di installare più istanze nello stesso computer. Un server può contenere una sola istanza predefinita.

  • In qualsiasi applicazione che prevede l'installazione di SQL Server Express, questo deve essere installato come istanza denominata. In questo modo è possibile ridurre al minimo i conflitti quando più applicazioni sono installate nello stesso computer.

Istanza predefinita

Selezionare questa opzione per installare un'istanza predefinita di SQL Server. Un computer può ospitare una sola istanza predefinita. Tutte le altre istanze devono essere denominate. Se, tuttavia, è installata un'istanza predefinita di SQL Server, è possibile aggiungere un'istanza predefinita di Analysis Services nello stesso computer.

Istanza denominata

Selezionare questa opzione per creare una nuova istanza denominata. Quando si assegna il nome a un'istanza di SQL Server, tenere presenti le considerazioni seguenti:

  • Per i nomi delle istanze non viene fatta distinzione tra maiuscole e minuscole.

  • I nomi delle istanze non possono iniziare né terminare con un carattere di sottolineatura (_).

  • I nomi delle istanze non possono contenere il termine "Default" o altre parole chiave riservate. Se nel nome di un'istanza viene utilizzata una parola chiave riservata, si verificherà un errore di installazione. Per ulteriori informazioni, vedere Parole chiave riservate.

  • Se si specifica MSSQLServer per il nome di istanza, verrà creata un'istanza predefinita. Per SQL Server Express se si specifica SQLExpress per il nome di istanza, verrà creata un'istanza predefinita.

  • Un'installazione di Microsoft SQL Server 2012 PowerPivot per SharePoint viene sempre eseguita come un'istanza denominata di "PowerPivot". Non è possibile specificare un nome di istanza diverso per questo ruolo caratteristica.

  • I nomi delle istanze devono essere costituiti al massimo da 16 caratteri.

  • Il primo carattere del nome dell'istanza deve essere una lettera. Le lettere consentite sono quelle definite dallo standard Unicode 2.0 e includono i caratteri latini a-z, A-Z e i caratteri corrispondenti a lettere di altre lingue.

  • I caratteri successivi possono essere costituiti dalle lettere definite dallo standard Unicode 2.0, dai numeri decimali inclusi negli script Latino di base o in altri script nazionali, il simbolo del dollaro ($) o un carattere di sottolineatura (_).

  • Nei nomi di istanza non sono consentiti spazi interni o altri caratteri speciali. La barra rovesciata (\), la virgola (,) i due punti (:), il punto e virgola (;), la virgoletta singola ('), la e commerciale (&) e la chiocciola (@) rappresentano altri caratteri non consentiti.

    Nota Nota

    Nei nomi di istanza di SQL Server è possibile utilizzare solo i caratteri indicati come validi nella tabella codici corrente di Windows. Se viene utilizzato un carattere Unicode non supportato, si verificherà un errore di installazione.

Istanze e caratteristiche rilevate

È possibile visualizzare un elenco dei componenti e delle istanze di SQL Server installati sul computer su cui viene eseguito il programma di installazione di SQL Server.

ID istanza: per impostazione predefinita, come ID istanza viene utilizzato il nome di istanza. Tale nome viene utilizzato per identificare le directory di installazione e le chiavi del Registro di sistema per l'istanza di SQL Server. Si tratta del caso delle istanze predefinite e delle istanze denominate. Per un'istanza predefinita, il nome di istanza e l'ID istanza sono MSSQLSERVER. Per utilizzare un ID istanza non predefinita, specificarlo nel campo ID istanza.

Nota importante Importante

Con SysPrep di SQL Server, l'ID istanza visualizzato in questa pagina è quello specificato durante il passaggio relativo alla preparazione dell'immagine del processo SQL Server SysPrep. Non sarà possibile specificare un ID istanza diverso durante il passaggio relativo al completamento dell'immagine.

Nota Nota

Gli ID delle istanze che iniziano con un carattere di sottolineatura (_) o che contengono il simbolo del cancelletto (#) o del dollaro ($) non sono supportati.

Per ulteriori informazioni sulle directory, i percorsi dei file e la denominazione degli ID delle istanze, vedere Percorsi dei file per le istanze predefinite e denominate di SQL Server.

Directory radice istanza: per impostazione predefinita, la directory radice dell'istanza è C:\Programmi\Microsoft SQL Server\. Per specificare una directory radice non predefinita, fare clic sul pulsante Sfoglia oppure specificare un percorso.

Tutti i componenti di un'istanza specifica di SQL Server vengono gestiti come unità. Tutti i Service Pack e gli aggiornamenti di SQL Server verranno applicati a ogni componente di un'istanza di SQL Server.

Tutti i componenti di SQL Server che condividono lo stesso nome di istanza devono soddisfare i criteri seguenti:

  • Stessa versione

  • Stessa edizione

  • Stesse impostazioni della lingua

  • Stesso stato del cluster

    Nota Nota

    Reporting Services non è in grado di interagire con i cluster.

  • Stesso sistema operativo


Selezione istanza (disinstallazione)

[image]

Selezione istanza (disinstallazione)
Commenti e suggerimenti

Nella pagina Selezione istanza - Disinstallazione utilizzare la casella a discesa per specificare l'istanza di SQL Server da disinstallare.

Opzioni

È possibile specificare un'intera istanza di SQL Server oppure è possibile specificare che la disinstallazione deve riguardare solo le caratteristiche e gli strumenti di gestione condivisi.


Selezione istanza (aggiornamento)

[image]

Selezione istanza (aggiornamento)
Commenti e suggerimenti

Nella pagina Selezione istanza (aggiornamento) è possibile specificare l'istanza di SQL Server da aggiornare.

Opzioni

Tutti i componenti di un'istanza devono essere aggiornati simultaneamente. Non è possibile aggiungere o rimuovere caratteristiche durante l'aggiornamento.


Istanza da aggiornare

[image]

Istanza da aggiornare
Vedere anche Commenti e suggerimenti

Utilizzare la pagina Istanza da aggiornare dell'Installazione guidata di SQL Server per specificare l'istanza di SQL Server 2005, SQL Server 2008 o SQL Server 2008 R2 che si desidera aggiornare a Microsoft SQL Server 2012.

Opzioni

Utilizzare i pulsanti di opzione per specificare se aggiornare l'istanza di SQL Server e i relativi componenti condivisi o solo i componenti condivisi. I componenti condivisi di questa versione di SQL Server sono i seguenti:

  • Integration Services

  • SQL Server Browser

  • SQL Server Active Directory Helper

  • Writer SQL

Per informazioni sugli scenari di aggiornamento supportati e sui problemi noti, vedere Aggiornamenti di versione ed edizione.

Vedere anche

Altre risorse

Utilizzo di Preparazione aggiornamento per preparare gli aggiornamenti
Utilizzo di più versioni di SQL Server


Post-disinstallazione

[image]

Post-disinstallazione
Commenti e suggerimenti

Utilizzare la pagina Post-disinstallazione per verificare il completamento dell'operazione.


Avanzamento preparazione immagine

[image]

Avanzamento preparazione immagine
Vedere anche Commenti e suggerimenti

Utilizzare la pagina Avanzamento preparazione immagine dell'Installazione guidata di SQL Server per monitorare lo stato dell'installazione della preparazione immagine di SQL Server. Al completamento di questo passaggio, questa pagina elenca lo stato per ogni caratteristica di SQL Server preparata durante questo processo.

Vedere anche

Concetti

Visualizzare e leggere i file di log del programma di installazione di SQL Server


Regole di preparazione immagine

[image]

Regole di preparazione immagine
Commenti e suggerimenti

Prima che l'operazione di installazione di SQL Server venga completata, viene convalidata la configurazione del computer. Durante l'installazione di SQL Server viene eseguita l'analisi del computer in cui verrà installato SQL Server tramite Controllo configurazione sistema. Questo strumento consente di verificare le condizioni che impediscono la corretta operazione di installazione di SQL Server. Prima dell'avvio dell'installazione guidata, lo strumento recupera le informazioni sullo stato di ciascun elemento. Il risultato viene confrontato con i requisiti, quindi vengono fornite indicazioni per la rimozione di eventuali problemi che impediscono di proseguire.

Con il controllo della configurazione di sistema viene generato un report con una breve descrizione di ogni regola eseguita, nonché lo stato dell'esecuzione. Il report di controllo della configurazione si trova nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMGG_HHMM>\.

Prima di eseguire l'operazione di installazione, esaminare i seguenti argomenti:

  1. Requisiti hardware e software per l'installazione di SQL Server (http://go.microsoft.com/fwlink/? LinkId=235029)

  2. Funzionalità supportate dalle Edizioni di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerazioni sulla sicurezza per un'installazione di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versioni in lingua locale di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Altri riferimenti:

  1. Aggiornamenti di versione ed edizione supportati(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Operazioni preliminari all'installazione del clustering di failover(http://go.microsoft.com/fwlink/?LinkId=235034)


Prepara tipo di immagine

[image]

Prepara tipo di immagine
Commenti e suggerimenti

Utilizzare la pagina Prepara tipo di immagine dell'Installazione guidata di SQL Server per specificare se installare una nuova istanza di Microsoft SQL Server 2012 o aggiungere caratteristiche a un'istanza esistente.

Opzioni

Selezionare il pulsante di opzione corrispondente alla scelta:

  • Preparare una nuova istanza di Microsoft SQL Server 2012.

  • Aggiungere caratteristiche a un'istanza predisposta esistente di Microsoft SQL Server 2012

    Se si seleziona l'opzione che consente di aggiungere caratteristiche a un'istanza esistente, utilizzare l'elenco a discesa per selezionare l'istanza predisposta di SQL Server da aggiornare.

    Nota Nota

    È possibile aggiungere le caratteristiche supportate da SysPrep SQL Server (Motore di database e Reporting Services) a un'immagine preparata di SQL Server. Le altre caratteristiche non supportate da SysPrep SQL Server possono essere aggiunte solo dopo aver completato l'istanza predisposta.


Codice Product Key

[image]

Codice Product Key
Commenti e suggerimenti

Utilizzare la pagina del codice Product Key per convalidare l'istanza di SQL Server o per specificare l'edizione gratuita di SQL Server da installare.

Opzioni

Per specificare un'edizione gratuita di SQL Server, selezionare il pulsante di opzione relativo alle installazioni gratuite, quindi utilizzare la casella a discesa per identificare l'edizione da installare.

Per convalidare un'edizione a pagamento di SQL Server, selezionare il pulsante di opzione relativo al codice Product Key, quindi specificare il codice nello spazio fornito.

Per le installazioni del cluster di failover, utilizzare lo stesso codice Product Key per ogni nodo del cluster di failover. Se il codice Product Key è di un'edizione di SQL Server diversa, si verificherà un errore.


Stato (disinstallazione)

[image]

Stato (disinstallazione)
Vedere anche Commenti e suggerimenti

Nella pagina Stato (disinstallazione) è possibile monitorare lo stato di avanzamento dell'installazione.

Vedere anche

Concetti

Visualizzare e leggere i file di log del programma di installazione di SQL Server


Inizio completamento immagine

[image]

Inizio completamento immagine
Commenti e suggerimenti

La pagina Inizio completamento immagine fornisce un riepilogo delle impostazioni di configurazione applicate alla configurazione dell'istanza predisposta.

Opzioni

Nella pagina sono disponibili le opzioni seguenti:

  • Per continuare l'installazione, fare clic su Installa.

  • Per modificare le impostazioni di installazione, fare clic su Indietro.

  • Per uscire dal programma di installazione, fare clic su Annulla.


Inizio installazione

[image]

Inizio installazione
Vedere anche Commenti e suggerimenti

Nella pagina Inizio installazione viene visualizzato un riepilogo delle caratteristiche da installare o modificare durante l'esecuzione del programma di installazione di SQL Server.

Opzioni

Nella pagina sono disponibili le opzioni seguenti:

  • Per continuare l'installazione, fare clic su Installa.

  • Per modificare le impostazioni di installazione, fare clic su Indietro.

  • Per uscire dal programma di installazione, fare clic su Annulla.

Vedere anche

Concetti

Visualizzare e leggere i file di log del programma di installazione di SQL Server


Inizio preparazione immagine

[image]

Inizio preparazione immagine
Commenti e suggerimenti

La pagina Inizio preparazione immagine fornisce un riepilogo delle caratteristiche da preparare durante l'esecuzione del Programma di installazione di SQL Server.

Opzioni

Nella pagina sono disponibili le opzioni seguenti:

  • Per continuare l'installazione, fare clic su Installa.

  • Per modificare le impostazioni di installazione, fare clic su Indietro.

  • Per uscire dal programma di installazione, fare clic su Annulla.


Inizio ripristino

[image]

Inizio ripristino
Vedere anche Commenti e suggerimenti

La pagina Inizio ripristino fornisce un riepilogo del processo di ripristino dal programma di installazione di SQL Server.

Opzioni

Nella pagina sono disponibili le opzioni seguenti:

  • Per continuare l'installazione, fare clic su Ripara.

  • Per modificare le impostazioni di installazione, fare clic su Indietro.

  • Per uscire dal programma di installazione, fare clic su Annulla

Vedere anche

Concetti

Visualizzare e leggere i file di log del programma di installazione di SQL Server


Rimozione di un nodo del cluster di failover di SQL Server

[image]

Rimozione di un nodo del cluster di failover di SQL Server
Commenti e suggerimenti

Utilizzare la pagina Rimuovi nodo cluster di failover per identificare il computer da rimuovere come nodo del cluster di failover di Microsoft SQL Server 2012.


Stato del ripristino

[image]

Stato del ripristino
Vedere anche Commenti e suggerimenti

Utilizzare la pagina Stato del ripristino dell'Installazione guidata di SQL Server per monitorare lo stato del ripristino di SQL Server.

Vedere anche

Concetti

Visualizzare e leggere i file di log del programma di installazione di SQL Server


Opzioni di configurazione di Reporting Services (SSRS)

[image]

Opzioni di configurazione di Reporting Services (SSRS)
Vedere anche Commenti e suggerimenti

Utilizzare la pagina Configurazione di Reporting Services dell'Installazione guidata di Microsoft SQL Server per specificare le modalità di installazione e di configurazione di un'istanza del server di report. La disponibilità di un'opzione di installazione dipende dalle opzione scelte in precedenza nella pagina Selezione funzionalità e dall'installazione o meno di un'istanza locale del Motore di database di SQL Server contemporaneamente all'installazione del server di report.

In alcuni casi, se nel computer è installato un certificato Secure Sockets Layer (SSL) associato a un carattere jolly complesso, il programma di installazione creerà gli URL di Reporting Services utilizzando il prefisso HTTPS. Per ulteriori informazioni su come eseguire il mapping dei certificati agli URL di Reporting Services, vedere Configurazione di un server di report per le connessioni SSL (Secure Sockets Layer) (http://go.microsoft.com/fwlink/?LinkId=199089) nella documentazione online di SQL Server.

Per le informazioni più recenti riguardo a Reporting Services e all'installazione e alla configurazione di questa versione, vedere la pagina relativa alle informazioni aggiuntive sull'installazione (http://go.microsoft.com/fwlink/?LinkId=207425).

Opzioni

Modalità nativa di Reporting Services

Se non è possibile eseguire la configurazione predefinita del server di report poiché uno o più requisiti non vengono soddisfatti, l'Installazione guidata consentirà solo l'opzione di installazione minima. Al termine dell'installazione, sarà possibile copiare i file necessari e utilizzare Gestione configurazione Reporting Services per configurare un server di report in modalità nativa.

Nota Nota

La presenza di un file di database del server di report può impedire l'installazione se si seleziona una delle opzioni di installazione predefinite. Quando si seleziona un'opzione di installazione predefinita, il programma di installazione tenta di creare un database del server di report utilizzando il nome predefinito. Se è già presente un database con lo stesso nome, l'installazione avrà esito negativo e sarà necessario eseguirne il rollback. Per evitare questo problema, è possibile rinominare il database esistente prima di eseguire l'installazione oppure selezionare l'opzione Solo installazione in modo da poter specificare impostazioni personalizzate per il database al termine dell'installazione.

Installazione e configurazione

Consente di installare un'istanza del server di report in modalità nativa utilizzando i valori predefiniti per i database del server di report, l'account del servizio e le prenotazioni di URL. Se si sceglie questa opzione, l'istanza del server di report è pronta per essere utilizzata al termine dell'installazione. Durante l'installazione viene creato un database del server di report utilizzando un'istanza locale di Motore di database e viene configurato un server di report per l'utilizzo dei valori predefiniti.

Questa opzione è disponibile solo se i valori predefiniti utilizzati nell'installazione di un server di report sono validi per il sistema. Questa opzione è consigliabile per gli sviluppatori che desiderano installare tutti i componenti localmente e per gli utenti che desiderano valutare il software.

Per visualizzare le informazioni relative alle impostazioni predefinite utilizzate durante l'installazione o per individuare i motivi per cui è impossibile installare la configurazione predefinita, fare clic su Dettagli. Per ulteriori informazioni sulla configurazione predefinita per un server di report in modalità nativa, vedere Configurazione predefinita per un'installazione in modalità nativa (Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199091).

Solo installazione

Consente di installare i file di programma del server di report, di creare l'account del servizio del server di report e di registrare il provider di Strumentazione gestione Windows (WMI) per il server di report. Questa opzione di installazione viene definita installazione di tipo "solo file". Selezionare questa opzione se non si desidera utilizzare la configurazione predefinita. Se non è possibile installare la configurazione predefinita o se si installa un cluster di failover di SQL Server in cui è incluso Reporting Services, questa è l'unica opzione disponibile. Per ulteriori informazioni su un'installazione in modalità solo file, vedere Installazione di tipo "solo file" (Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199093).

Al termine dell'installazione, è necessario creare il database del server di report e configurare quest'ultimo prima di utilizzarlo. Per configurare un server di report e creare il database, utilizzare Gestione configurazione Reporting Services. Per ulteriori informazioni, vedere Procedura: Creazione di un database del server di report (configurazione di Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199094) e Configurazione della connessione a un server di report (http://go.microsoft.com/fwlink/?LinkId=199095).

Modalità SharePoint di Reporting Services

Solo installazione

Consente di installare i file di programma del server di report e i cmdlet di PowerShell. Al termine dell'installazione, sarà necessario avviare SharePoint Services per Reporting Services e creare un'applicazione di servizio Reporting Services. Per ulteriori informazioni, vedere le pagine relative alla panoramica dell'installazione e della configurazione del servizio Reporting Services per l'integrazione SharePoint (http://go.microsoft.com/fwlink/?LinkId=207543), alla creazione di un'applicazione di servizio SQL Server Reporting Services (SSRS) (http://go.microsoft.com/fwlink/?LinkId=207544) e alla panoramica di Reporting Services e dell'integrazione SharePoint (http://go.microsoft.com/fwlink/?LinkID=207244).

Installazione del componente aggiuntivo Reporting Services per le tecnologie SharePoint

A partire dalla versione Microsoft SQL Server 2012, è possibile installare il componente aggiuntivo come parte dell'installazione di SQL Server, nella pagina Selezione funzionalità dell'Installazione guidata di SQL Server.

È tuttavia possibile installare il componente aggiuntivo di Reporting Services per SharePoint 2010 mediante uno dei metodi seguenti:

  • Eseguire lo strumento di preparazione dei prodotti SharePoint 2010 PreRequisiteInstaller.exe.

  • Eseguire l'installazione dal supporto di installazione di SQL Server. Fare clic sul file rsSharePoint.msi nella cartella Setup nel supporto di installazione di SQL Server al termine dell'installazione di SQL Server.

  • Scaricare e installare il componente aggiuntivo. Per ulteriori informazioni, vedere Posizione in cui trovare il componente aggiuntivo Reporting Services per prodotti SharePoint (http://go.microsoft.com/fwlink/?LinkID=208634).

Vedere anche

Altre risorse

Procedura: Avvio di Configurazione Reporting Services
Procedura: Creazione di un database del server di report (configurazione di Reporting Services)
Considerazioni sull'installazione di Reporting Services
Configurazione predefinita per un'installazione in modalità nativa (Reporting Services)
Configurazione predefinita per la modalità integrata SharePoint (Reporting Services)
Procedura: Installazione di SQL Server 2008 R2 dal prompt dei comandi


Aggiornamento in modalità SharePoint di Reporting Services (SSRS)

[image]

Aggiornamento in modalità SharePoint di Reporting Services (SSRS)
Vedere anche Commenti e suggerimenti

Utilizzare la pagina Modalità SharePoint di Reporting Services per confermare l'aggiornamento di tutte le funzionalità condivise. La modalità SharePoint di Reporting Services è una funzionalità SQL Server condivisa e verrà aggiornata con tutte le altre funzionalità SQL Server condivise. Nell'Installazione guidata di SQL Server non è supportato l'aggiornamento di una sola funzionalità condivisa. Tutte le funzionalità SQL Server condivise vengono aggiornate contemporaneamente.

Opzioni

Il pulsante Avanti è disponibile solo dopo aver selezionato la casella di controllo Procedi con l'aggiornamento. In caso contrario, non sarà possibile procedere.

Per ulteriori informazioni, vedere la pagina relativa all'aggiornamento di Reporting Services (http://go.microsoft.com/fwlink/?LinkId=199092).

Vedere anche

Concetti

Visualizzare e leggere i file di log del programma di installazione di SQL Server

Altre risorse

Installare SQL Server dal prompt dei comandi


Autenticazione in modalità SharePoint di Reporting Services

[image]

Autenticazione in modalità SharePoint di Reporting Services
Vedere anche Commenti e suggerimenti

Utilizzare la pagina Autenticazione in modalità SharePoint di Reporting Services dell'Installazione guidata di Microsoft SQL Server per specificare le credenziali dell'account del servizio utilizzato nell'installazione attuale di Reporting Services. Le credenziali verranno utilizzate per creare un nuovo pool di applicazioni SharePoint. Verrà inoltre creata una nuova applicazione di servizi Reporting Services SharePoint. Il nome dell'applicazione conterrà il nome dell'istanza di Reporting Services precedente.

Opzioni

  • L'opzione Nome account pool di applicazioni SSRS è di sola lettura. Il valore viene automaticamente popolato con il valore attuale dall'installazione di Reporting Services esistente in fase di aggiornamento.

  • L'opzione Password account pool di applicazioni SSRS verrà disabilitata se l'account del pool di applicazioni non richiede una password (ad esempio, "NT Authority\NetworkService". Se per l'account del pool di applicazioni è richiesta una password, digitare la password corretta per procedere con l'aggiornamento.

Per ulteriori informazioni, vedere la pagina relativa all'aggiornamento di Reporting Services (http://go.microsoft.com/fwlink/?LinkId=199092).

Vedere anche

Altre risorse

Pagina relativa all'aggiornamento di Reporting Services


Seleziona istanza predisposta

[image]

Seleziona istanza predisposta
Commenti e suggerimenti

Utilizzare la pagina Seleziona istanza predisposta per specificare l'istanza predisposta che si desidera completare.

Opzioni

La casella Seleziona ID istanza elenca le istanze predisposte che è possibile completare. Selezionare un'istanza predisposta che si desidera completare.

Seleziona ID istanza

L'elenco include tutte le istanze predisposte che è possibile completare sul computer sul quale il programma di installazione di SQL Server è in esecuzione. Selezionare un'istanza predisposta che si desidera completare.

Istanze installate

Sono incluse le istanze installate, predisposte e completate.


Configurazione del server - Regole di confronto

[image]

Configurazione del server - Regole di confronto
Commenti e suggerimenti

Nella pagina Configurazione del server - Regole di confronto dell'Istallazione guidata di SQL Server è possibile modificare le impostazioni per le regole di confronto utilizzate dal Motore di database e da Analysis Services per scopi di ordinamento. Scegliere l'opzione che corrisponde alle impostazioni per le regole di confronto di installazioni diverse di SQL Server o di un altro computer.

Opzioni

Personalizza per SQL Server e Analysis Services

In SQL Server sono disponibili due gruppi di regole di confronto, ovvero le regole di confronto di Windows e le regole di confronto di SQL Server. È possibile specificare impostazioni distinte per le regole di confronto per il Motore di database e Analysis Services oppure le stesse regole di confronto per entrambi i servizi.

Per impostazione predefinita, vengono selezionate regole di confronto di SQL Server per le impostazioni locali di sistema della lingua inglese. Le regole di confronto predefinite per le versioni localizzate di SQL Server sono determinate dalle impostazioni locali di sistema di Windows per il computer in uso. Per ulteriori informazioni, vedere Using SQL Collations.

Modificare le impostazioni predefinite solo se l'impostazione delle regole di confronto per questa installazione di SQL Server deve corrispondere alle impostazioni delle regole di confronto utilizzate da un'altra istanza di SQL Server oppure alle impostazioni locali di sistema di Windows di un altro computer.

Nota In Analysis Services vengono utilizzate solo le regole di confronto di Windows. Se si intende installare Analysis Services, selezionare una regola di confronto di Windows durante l'installazione di SQL Server per garantire risultati coerenti tra Motore di database di SQL Server e Analysis Services.

Per ulteriori informazioni, vedere Collation Settings in Setup.

Procedure consigliate

Per ulteriori informazioni su una tabella delle impostazioni locali di sistema Windows e sulle regole di confronto predefinite corrispondenti utilizzate dal programma di installazione di SQL Server, vedere Collation Settings in Setup.

Se possibile, utilizzare un'unica regola di confronto per l'organizzazione. In questo modo, non è necessario specificare esplicitamente la regola di confronto per ogni database, colonna, espressione o identificatore. In caso di utilizzo di più regole di confronto e impostazioni di tabelle codici, sarà necessario codificare le query in modo da considerare le regole di precedenza delle regole di confronto. Per ulteriori informazioni, vedere l'argomento Collation Precedence (Transact-SQL) nella documentazione online.

Quando si selezionano regole di confronto per SQL Server, tenere presenti le indicazioni seguenti:

  • Selezionare regole di confronto BINARY2 se l'ordinamento in base a punti di codice binario risulta accettabile.

  • Selezionare una regola di confronto di Windows per garantire un confronto coerente tra tipi di dati.

  • Per un supporto linguistico più efficace, utilizzare una nuova regola di confronto di livello 100. Per ulteriori informazioni, vedere Collation and Unicode Support.

  • Se si prevede di eseguire la migrazione di un database all'istanza aggiornata di SQL Server, selezionare regole di confronto corrispondenti alle regole di confronto esistenti per il database.


Configurazione Server - Account di servizio

[image]

Configurazione Server - Account di servizio
Vedere anche Commenti e suggerimenti

Utilizzare la pagina Configurazione del server dell'Installazione guidata di SQL Server per assegnare account di accesso ai servizi di SQL Server. I servizi effettivamente configurati in questa pagina dipendono dalle caratteristiche selezionate per l'installazione.

Gli account di avvio utilizzati per avviare ed eseguire SQL Server possono essere account utente di dominio, account utente locali, account di servizio gestiti, account virtuali o account di sistema predefiniti.

Opzioni

È possibile assegnare lo stesso account di accesso a tutti i servizi di SQL Server oppure configurare singolarmente l'account di ogni servizio. È inoltre possibile specificare se i servizi verranno avviati automaticamente, manualmente o se sono disabilitati. Per la maggior parte delle installazioni l'account consigliato è quello predefinito.

  • In Windows 7 e Windows Server 2008 R2 la maggior parte degli account viene impostata automaticamente su un account virtuale.

  • In Windows Vista e Windows Server 2008 la maggior parte degli account viene impostata automaticamente sull'account NETWORK SERVICE.

  • In un'installazione di un cluster in Windows Server 2008, è necessario specificare un account di dominio.

Se si configurano i servizi per l'utilizzo di account di dominio, Microsoft consiglia di configurare singolarmente gli account del servizio per fornire privilegi minimi per ogni servizio, in modo che i servizi di SQL Server dispongano delle autorizzazioni minime necessarie per completare le attività. Per ulteriori informazioni, incluse le descrizioni dei tipi di account, vedere la pagina relativa alla configurazione di account di servizio Windows.

Configura singolarmente gli account del servizio SQL Server (scelta consigliata)

Utilizzare la griglia per fornire a ogni servizio di SQL Server un nome utente di accesso e una password e per impostare il tipo di avvio per il servizio. Per i servizi di SQL Server è possibile utilizzare account di sistema predefiniti, un account locale, un gruppo locale, un gruppo di dominio o account utente di dominio.

Selezionare i servizi seguenti per personalizzarne le impostazioni.

Selezionare questo servizio

Per personalizzare le impostazioni di autenticazione per

SQL Server Agent

Il servizio che esegue processi e il monitoraggio di SQL Server e che consente l'automazione di attività di amministrazione.

Per questo servizio non è disponibile alcun account di accesso predefinito.

Il tipo di avvio predefinito è Manuale.

SQL Server

Motore di database di SQL Server.

Il tipo di avvio predefinito è Automatico.

Nota Nota

SQL Server Browser

SQL Server Browser è il servizio di risoluzione dei nomi che rende disponibili le informazioni di connessione di SQL Server per i computer client. Questo servizio viene condiviso da più istanze di SQL Server e di Integration Services.

L'account di accesso predefinito è NT Authority\Local service e non può essere modificato durante l'installazione di SQL Server. È possibile modificare l'account dopo che l'installazione è stata completata.

Se non specificato durante l'installazione, il tipo di avvio viene determinato nel modo seguente:

  • SQL Server Browser viene impostato su Automatico e viene eseguito negli scenari di installazione descritti di seguito.

    • Istanza del cluster di failover di SQL Server

    • Istanza denominata di SQL Server in cui è abilitato TCP o NP

    • Istanza denominata di Analysis Server senza cluster

  • Se lo scenario di installazione non è uno di quelli descritti in precedenza e SQL Server Browser è già installato, verrà mantenuto lo stato corrente di SQL Server Browser.

  • Il tipo di avvio viene impostato su Disabilitato e viene arrestato se non è presente alcuna istanza di SQL Server 2005, SQL Server 2008 o SQL Server 2008 R2 precedente all'installazione.

Analysis Services

Analysis Services.

Il tipo di avvio predefinito è Automatico.

Per la modalità integrata SharePoint è necessario specificare un account utente di dominio di Windows. L'account specificato viene utilizzato per il servizio di Analysis Services. L'account specificato per l'istanza corrente deve essere utilizzato anche per qualsiasi altra istanza di Analysis Services che si aggiunge successivamente alla stessa farm.

Reporting Services

Reporting Services. Gli account di servizio vengono utilizzati per configurare una connessione al database del server di report. Scegliere il servizio di rete predefinito se si desidera utilizzare impostazioni di autenticazione predefinite. Se si specifica un account utente di dominio, registrare un nome SPN (Service Principle Name) se si utilizza l'autenticazione di Windows nel server di report. Per ulteriori informazioni, vedere How to: Configure Windows Authentication in Reporting Services.

Nota importante Importante

Microsoft consiglia di non utilizzare l'account Servizio di rete per i servizi SQL Server o SQL Server Agent se è disponibile un account con privilegi inferiori, perché Servizio di rete è un account condivisibile. Servizio di rete è appropriato per l'utilizzo come account del servizio SQL Server solo se è possibile assicurarsi che nel computer non siano installati altri servizi che utilizzano l'account. Gli account Utente locale o Utente di dominio che non sono amministratori di Windows sono più appropriati per i servizi di SQL Server.

Il tipo di avvio predefinito è Automatico.

Integration Services

Integration Services è un set di strumenti grafici e oggetti programmabili per lo spostamento, la copia e la trasformazione di dati.

Il tipo di avvio predefinito è Automatico.

Utilità di avvio del daemon di filtri full-text di SQL Server

Servizio che crea i processi fdhost.exe. È necessario per ospitare i filtri e i word breaker che elaborano i dati testuali per l'indicizzazione full-text.

Se si specifica un account di dominio in cui eseguire il servizio per l'utilità di avvio di FDHOST, è consigliabile utilizzare un account con privilegi limitati. Questo account dovrebbe essere diverso dall'account utilizzato per il servizio SQL Server. In Windows Vista e Windows Server 2008 l'account del servizio dell'utilità di avvio di FDHOST viene automaticamente impostato su SERVIZIO LOCALE.

SQL Server Distributed Replay Client

Account di servizio utilizzato per il servizio Distributed Replay Client.

Specificare un account con cui eseguire il servizio Distributed Replay Client. Questo account dovrebbe essere diverso dall'account utilizzato per il servizio SQL Server.

Il tipo di avvio predefinito è Manuale.

SQL Server Distributed Replay Controller

Account di servizio utilizzato per il servizio Distributed Replay Controller.

Specificare un account con cui eseguire il servizio Distributed Replay Controller. Questo account dovrebbe essere diverso dall'account utilizzato per il servizio SQL Server.

Il tipo di avvio predefinito è Manuale.

Vedere anche

Altre risorse

Considerazioni sulla sicurezza per un'installazione di SQL Server


Impostazione ruolo

[image]

Impostazione ruolo
Vedere anche Commenti e suggerimenti

Utilizzare questa pagina per specificare se utilizzare la pagina Selezione caratteristiche per selezionare le caratteristiche singole oppure eseguire l'installazione tramite un ruolo di installazione.

Il setup role è una selezione predefinita di tutte le caratteristiche e di tutti i componenti condivisi necessari per implementare una configurazione predefinita di SQL Server.

Opzioni

Installazione caratteristiche SQL Server

Scegliere questa opzione per selezionare le caratteristiche singole e i componenti condivisi. Le caratteristiche dell'istanza includono Servizi Motore di database, Analysis Services (modalità nativa) e Reporting Services.

SQL Server PowerPivot per SharePoint

Scegliere questa opzione per installare i componenti del server Analysis Services in una farm SharePoint 2010. Questa opzione consente di distribuire il servizio di sistema PowerPivot e il server Analysis Services in una farm, abilitando l'elaborazione di dati e query per cartelle di lavoro di Excel pubblicate che contengono dati di PowerPivot incorporati.

Se necessario, è possibile aggiungere un'istanza del motore di database relazionale all'installazione per ospitare i database in una farm di SharePoint. Se la farm è già configurata, è possibile ignorare questa opzione.

Al termine dell'installazione, è necessario configurare il software utilizzando uno degli approcci seguenti: strumento di configurazione PowerPivot, cmdlet di PowerShell o Amministrazione centrale SharePoint 2010. A differenza delle versioni precedenti, durante l'installazione non viene più eseguita alcuna attività di configurazione per un'installazione di PowerPivot.

Un'installazione basata su ruoli non include SQL Server PowerPivot per l'applicazione client di Excel. L'applicazione client viene installata separatamente.

Tutte le caratteristiche con valori predefiniti

Scegliere questo ruolo per installare tutte le caratteristiche disponibili per questa versione. Si noti che PowerPivot per SharePoint è escluso da questo ruolo. È necessario utilizzare il ruolo di installazione PowerPivot per SharePoint per installare tale caratteristica.

Il Motore di database è configurato per eseguire l'avvio tramite l'account NT AUTHORITY\NETWORK SERVICE. Per l'utente corrente sarà effettuato il provisioning come membro del ruolo sysadmin di SQL Server. È possibile eseguire l'override dei valori impostati con questa opzione specificando i parametri della riga di comando aggiuntivi.

In Windows Vista o Windows Server 2008 o versioni successive e se il sistema operativo non è un controller di dominio, per impostazione predefinita il Motore di database e Reporting Services utilizzano l'account NTAUTHORITY\NETWORK SERVICE, Integration Services utilizza l'account NTAUTHORITY\NETWORK SERVICE e l'Utilità di avvio del daemon filtri full-text di SQL utilizza l'account NTAUTHORITY\LOCAL SERVICE.

Vedere anche

Riferimento

Selezione funzionalità

Altre risorse

Installazione di PowerPivot per SharePoint
Requisiti hardware e software (PowerPivot per SharePoint)


Creazione guidata cluster di failover di SQL Server (Completamento)

[image]

Creazione guidata cluster di failover di SQL Server (Completamento)
Vedere anche Commenti e suggerimenti

Prima che l'operazione di installazione di SQL Server venga completata, viene convalidata la configurazione del computer. Durante l'installazione di SQL Server viene eseguita l'analisi del computer in cui verrà installato SQL Server tramite Controllo configurazione sistema. Questo strumento consente di verificare le condizioni che impediscono la corretta operazione di installazione di SQL Server. Prima dell'avvio dell'installazione guidata di SQL Server, lo strumento recupera le informazioni sullo stato di ciascun elemento. Il risultato viene confrontato con i requisiti, quindi vengono fornite indicazioni per la rimozione di eventuali problemi che impediscono di proseguire.

Con il controllo della configurazione di sistema viene generato un report con una breve descrizione di ogni regola eseguita, nonché lo stato dell'esecuzione. Il report di controllo della configurazione si trova nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMGG_HHMM>\.

Prima di eseguire l'operazione di installazione, esaminare i seguenti argomenti:

  1. Requisiti hardware e software per l'installazione di SQL Server (http://go.microsoft.com/fwlink/? LinkId=235029)

  2. Funzionalità supportate dalle Edizioni di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerazioni sulla sicurezza per un'installazione di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versioni in lingua locale di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Altri riferimenti:

  1. Aggiornamenti di versione ed edizione supportati(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Operazioni preliminari all'installazione del clustering di failover(http://go.microsoft.com/fwlink/?LinkId=235034)

Vedere anche

Riferimento

Regole di supporto per l'installazione


Installazione della Creazione guidata cluster di failover di SQL Server

[image]

Installazione della Creazione guidata cluster di failover di SQL Server
Vedere anche Commenti e suggerimenti

Prima che l'operazione di installazione di SQL Server venga completata, viene convalidata la configurazione del computer. Durante l'installazione di SQL Server viene eseguita l'analisi del computer in cui verrà installato SQL Server tramite Controllo configurazione sistema. Questo strumento consente di verificare le condizioni che impediscono la corretta operazione di installazione di SQL Server. Prima dell'avvio dell'installazione guidata di SQL Server, lo strumento recupera le informazioni sullo stato di ciascun elemento. Il risultato viene confrontato con i requisiti, quindi vengono fornite indicazioni per la rimozione di eventuali problemi che impediscono di proseguire.

Con il controllo della configurazione di sistema viene generato un report con una breve descrizione di ogni regola eseguita, nonché lo stato dell'esecuzione. Il report di controllo della configurazione si trova nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMGG_HHMM>\.

Prima di eseguire l'operazione di installazione, esaminare i seguenti argomenti:

  1. Requisiti hardware e software per l'installazione di SQL Server (http://go.microsoft.com/fwlink/? LinkId=235029)

  2. Funzionalità supportate dalle Edizioni di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerazioni sulla sicurezza per un'installazione di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versioni in lingua locale di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Altri riferimenti:

  1. Aggiornamenti di versione ed edizione supportati(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Operazioni preliminari all'installazione del clustering di failover(http://go.microsoft.com/fwlink/?LinkId=235034)

Vedere anche

Riferimento

Regole di supporto per l'installazione


Creazione guidata cluster di failover di SQL Server (preparazione)

[image]

Creazione guidata cluster di failover di SQL Server (preparazione)
Vedere anche Commenti e suggerimenti

Prima che l'operazione di installazione di SQL Server venga completata, viene convalidata la configurazione del computer. Durante l'installazione di SQL Server viene eseguita l'analisi del computer in cui verrà installato SQL Server tramite Controllo configurazione sistema. Questo strumento consente di verificare le condizioni che impediscono la corretta operazione di installazione di SQL Server. Prima dell'avvio dell'installazione guidata di SQL Server, lo strumento recupera le informazioni sullo stato di ciascun elemento. Il risultato viene confrontato con i requisiti, quindi vengono fornite indicazioni per la rimozione di eventuali problemi che impediscono di proseguire.

Con il controllo della configurazione di sistema viene generato un report con una breve descrizione di ogni regola eseguita, nonché lo stato dell'esecuzione. Il report di controllo della configurazione si trova nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMGG_HHMM>\.

Prima di eseguire l'operazione di installazione, esaminare i seguenti argomenti:

  1. Requisiti hardware e software per l'installazione di SQL Server (http://go.microsoft.com/fwlink/? LinkId=235029)

  2. Funzionalità supportate dalle Edizioni di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerazioni sulla sicurezza per un'installazione di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versioni in lingua locale di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Altri riferimenti:

  1. Aggiornamenti di versione ed edizione supportati(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Operazioni preliminari all'installazione del clustering di failover(http://go.microsoft.com/fwlink/?LinkId=235034)

Vedere anche

Riferimento

Regole di supporto per l'installazione


Riepilogo (aggiornamento)

[image]

Riepilogo (aggiornamento)
Commenti e suggerimenti

Utilizzare la pagina Riepilogo per visualizzare le opzioni specificate per questo aggiornamento.


Regole di supporto per l'installazione

[image]

Regole di supporto per l'installazione
Commenti e suggerimenti

Prima che l'operazione di installazione di SQL Server venga completata, viene convalidata la configurazione del computer. Durante l'installazione di SQL Server viene eseguita l'analisi del computer in cui verrà installato SQL Server tramite Controllo configurazione sistema. Questo strumento consente di verificare le condizioni che impediscono la corretta operazione di installazione di SQL Server. Prima dell'avvio dell'installazione guidata di SQL Server, lo strumento recupera le informazioni sullo stato di ciascun elemento. Il risultato viene confrontato con i requisiti, quindi vengono fornite indicazioni per la rimozione di eventuali problemi che impediscono di proseguire.

Con il controllo della configurazione di sistema viene generato un report con una breve descrizione di ogni regola eseguita, nonché lo stato dell'esecuzione. Il report di controllo della configurazione si trova nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMGG_HHMM>\.

Prima di eseguire l'operazione di installazione, esaminare i seguenti argomenti:

  1. Requisiti hardware e software per l'installazione di SQL Server (http://go.microsoft.com/fwlink/? LinkId=235029)

  2. Funzionalità supportate dalle Edizioni di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerazioni sulla sicurezza per un'installazione di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versioni in lingua locale di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Altri riferimenti:

  1. Aggiornamenti di versione ed edizione supportati(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Operazioni preliminari all'installazione del clustering di failover(http://go.microsoft.com/fwlink/?LinkId=235034)

Argomenti aggiuntivi relativi alle regole

Vedere gli argomenti seguenti per le regole del programma di installazione specifiche di uno scenario:

  • Regole di installazione

  • Controllo regole di aggiornamento

  • Regole per l'aggiornamento delle edizioni

  • Regole di disinstallazione

  • Regole di preparazione immagine

  • Regole di completamento immagine


Regole di disinstallazione

[image]

Regole di disinstallazione
Vedere anche Commenti e suggerimenti

La pagina Regole di disinstallazione esegue un set di regole per garantire il completamento dell'operazione di installazione.

Prima che l'operazione di installazione di SQL Server venga completata, viene convalidata la configurazione del computer. Durante l'installazione di SQL Server viene eseguita l'analisi del computer in cui verrà installato SQL Server tramite Controllo configurazione sistema. Questo strumento consente di verificare le condizioni che impediscono la corretta operazione di installazione di SQL Server. Prima dell'avvio della disinstallazione guidata di SQL Server, lo strumento recupera le informazioni sullo stato di ciascun elemento. Il risultato viene confrontato con i requisiti, quindi vengono fornite indicazioni per la rimozione di eventuali problemi che impediscono di proseguire.

Con il controllo della configurazione di sistema viene generato un report con una breve descrizione di ogni regola eseguita, nonché lo stato dell'esecuzione. Il report di controllo della configurazione si trova nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMGG_HHMM>\.

Prima di eseguire l'operazione di installazione, esaminare i seguenti argomenti:

  1. Requisiti hardware e software per l'installazione di SQL Server (http://go.microsoft.com/fwlink/? LinkId=235029)

  2. Funzionalità supportate dalle Edizioni di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerazioni sulla sicurezza per un'installazione di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versioni in lingua locale di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Altri riferimenti:

  1. Aggiornamenti di versione ed edizione supportati(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Operazioni preliminari all'installazione del clustering di failover(http://go.microsoft.com/fwlink/?LinkId=235034)

Vedere anche

Riferimento

Regole di supporto per l'installazione


Stato aggiornamento

[image]

Stato aggiornamento
Vedere anche Commenti e suggerimenti

Utilizzare la pagina Stato aggiornamento dell'Installazione guidata di SQL Server per monitorare lo stato dell'aggiornamento di SQL Server.

Vedere anche

Concetti

Visualizzare e leggere i file di log del programma di installazione di SQL Server


Controllo regole di aggiornamento

[image]

Controllo regole di aggiornamento
Vedere anche Commenti e suggerimenti

Prima che l'operazione di installazione di SQL Server venga completata, viene convalidata la configurazione del computer. Durante l'installazione di SQL Server viene eseguita l'analisi del computer in cui verrà installato SQL Server tramite Controllo configurazione sistema. Questo strumento consente di verificare le condizioni che impediscono la corretta operazione di installazione di SQL Server. Prima dell'avvio dell'aggiornamento guidato, lo strumento recupera le informazioni sullo stato di ciascun elemento. Il risultato viene confrontato con i requisiti, quindi vengono fornite indicazioni per la rimozione di eventuali problemi che impediscono di proseguire.

Con il controllo della configurazione di sistema viene generato un report con una breve descrizione di ogni regola eseguita, nonché lo stato dell'esecuzione. Il report di controllo della configurazione si trova nel percorso %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMGG_HHMM>\.

Prima di eseguire l'operazione di installazione, esaminare i seguenti argomenti:

  1. Requisiti hardware e software per l'installazione di SQL Server (http://go.microsoft.com/fwlink/? LinkId=235029)

  2. Funzionalità supportate dalle Edizioni di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerazioni sulla sicurezza per un'installazione di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versioni in lingua locale di SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Altri riferimenti:

  1. Aggiornamenti di versione ed edizione supportati(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Operazioni preliminari all'installazione del clustering di failover(http://go.microsoft.com/fwlink/?LinkId=235034)

Vedere anche

Riferimento

Regole di supporto per l'installazione


Verifica delle opzioni di disinstallazione

[image]

Verifica delle opzioni di disinstallazione
Commenti e suggerimenti

Verificare la selezione, quindi scegliere Avanti per continuare.


L'argomento cercato non è disponibile

[image]

L'argomento cercato non è disponibile
Commenti e suggerimenti

Al termine dell'installazione, è possibile visualizzare la documentazione di SQL Server facendo clic su ?, premendo F1 in finestre di dialogo o elementi di interfaccia oppure dal menu Start scegliendo Tutti i programmi, Microsoft SQL Server, Guida e community e infine facendo clic su Documentazione online di SQL Server. Per ulteriori informazioni, vedere Aggiunta e rimozione di insiemi di file della Guida.