Panoramica sull'installazione dei servizi SQL Server

[image]

Panoramica sull'installazione dei servizi SQL Server
Vedere anche Commenti e suggerimenti

È possibile applicare un aggiornamento a qualsiasi componente installato di SQL Server 2012 tramite un aggiornamento dei servizi di SQL Server 2012. Se il livello di versione di un componente esistente di SQL Server 2012 è successivo rispetto a quello dell'aggiornamento, il programma di installazione lo escluderà dall'aggiornamento. Per ulteriori informazioni sull'applicazione di un aggiornamento dei servizi, vedere Installare gli aggiornamenti dei servizi di SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=231297).

Quando si installano aggiornamenti di SQL Server 2012 è necessario tenere conto delle considerazioni seguenti:

  • Tutte le funzionalità appartenenti a una determinata istanza di SQL Server devono essere aggiornate contemporaneamente. Se ad esempio si aggiorna il Motore di database e nella stessa istanza di SQL Server sono installati anche Analysis Services e Reporting Services, sarà necessario aggiornare anche tali componenti. È necessario aggiornare sempre le funzionalità condivise, quali gli strumenti di gestione, SQL Server Data Tools (SSDT) e SQL Server Integration Services, con l'aggiornamento più recente. Le istanze o i componenti non selezionati nell'albero delle funzionalità non verranno aggiornati.

  • Per impostazione predefinita, i file di log degli aggiornamenti di SQL Server 2012 vengono salvati in %Programmi%\Microsoft SQL Server\110\Setup Bootstrap\LOG\.

  • Tramite l'installazione di SQL Server è ora possibile integrare un aggiornamento con il supporto originale in modo da eseguire il supporto in questione e l'aggiornamento contemporaneamente. Per ulteriori informazioni, vedere Aggiornamenti del prodotto nell'installazione di SQL Server 2012 e Novità relative all'installazione di SQL Server(http://go.microsoft.com/fwlink/?LinkID=219508).

  • Prima di eseguire un aggiornamento dei servizi di SQL Server 2012, è consigliabile eseguire il backup dei dati.

  • Gli aggiornamenti di SQL Server sono disponibili tramite Microsoft Update. È consigliabile cercare regolarmente i nuovi aggiornamenti per mantenere l'istanza di SQL Server aggiornata e sicura. SQL Server 2012 SP1 viene fornito come installazione completa di SQL Server. Anziché fornire il Service Pack nel pacchetto eseguibile della patch standard da applicare alle istanze di SQL Server 2012 RTM, per questa versione viene fornito un pacchetto di installazione costituito da due file. Quando eseguito, tramite il pacchetto verrà installata una nuova istanza di SQL Server con SP1 preinstallato. Per ulteriori informazioni, vedere l'installazione completa di SQL Server 2012 SP1.

Requisiti e problemi noti

I requisiti di spazio su disco consigliati corrispondono a circa 2,5 volte la dimensione del pacchetto e vengono utilizzati per installare, scaricare ed estrarre il pacchetto. Al termine dell'installazione di un Service Pack, è possibile rimuovere il pacchetto scaricato. Qualsiasi file temporaneo viene rimosso automaticamente.

Esaminare i problemi noti: per ulteriori informazioni sui problemi noti della versione corrente, vedere l'argomento corrispondente riguardante le note sulla versione nella pagina relativa alle note sulla versione di SQL Server.

Panoramica sull'installazione

In questa sezione viene descritta l'installazione di SQL Server 2012 per gli aggiornamenti cumulativi e i Service Pack, con le istruzioni per eseguire le operazioni seguenti:

  • Preparazione per l'installazione degli aggiornamenti di SQL Server 2012

  • Installazione degli aggiornamenti di SQL Server 2012

  • Riavvio di servizi e applicazioni

Preparare l'installazione di un aggiornamento di SQL Server 2012

Prima di installare gli aggiornamenti di SQL Server 2012, è opportuno effettuare le operazioni indicate di seguito:

  • Eseguire il backup dei database di sistema di SQL Server: prima di installare gli aggiornamenti di SQL Server 2012, eseguire il backup dei database master, msdb e model. L'installazione di un aggiornamento di SQL Server 2012 implica la modifica di tali database, rendendoli incompatibili con le versioni precedenti di SQL Server 2012. Se si decide di reinstallare SQL Server 2012 senza questi aggiornamenti, saranno necessari i backup di tali database.

    È inoltre consigliabile eseguire il backup dei database utente esistenti.

    Nota importante Importante

    Prima di applicare gli aggiornamenti alle istanze di SQL Server che fanno parte di una topologia di replica, è necessario eseguire il backup dei database replicati e dei database di sistema.

  • Eseguire il backup dei database, dei file di configurazione e del repository di Analysis Services: prima di aggiornare un'istanza di Analysis Services, è consigliabile eseguire il backup degli elementi seguenti:

    • Database di Analysis Services. Per impostazione predefinita, i database sono installati in C:\Programmi\Microsoft SQL Server\MSAS11.<IDIstanza>\OLAP\Data\. Per un'installazione in ambiente WOW, il percorso predefinito è C:\Programmi (x86)\Microsft SQL Server\MSAS11.<IDIstanza>\OLAP\Data\.

    • Impostazione della configurazione di Analysis Services nel file di configurazione msmdsrv.ini. Per impostazione predefinita, questo file si trova nella directory C:\Programmi\Microsoft SQL Server\MSAS11.<IDIstanza>\OLAP\Config\.

    • Database contenente il repository di Analysis Services (facoltativo). Questo passaggio è necessario solo se Analysis Services è stato configurato per l'utilizzo con la libreria DSO (Decision Support Objects).

    Nota Nota

    Se non si esegue il backup dei database, del file di configurazione e del repository di Analysis Services, non sarà possibile ripristinare la versione precedente di Analysis Services dopo l'installazione di una versione aggiornata.

  • Verifica dello spazio disponibile per i database di sistema: se l'opzione di aumento automatico delle dimensioni non è selezionata per i database di sistema master e msdb, saranno necessari almeno 500 KB di spazio disponibile per ogni database. Per verificare che i database dispongano di spazio sufficiente, eseguire la stored procedure di sistema sp_spaceused nei database master e msdb. Se la quantità di spazio non allocato in uno dei due database è inferiore a 500 KB, aumentare la dimensione del database.

  • Arresto dei servizi e delle applicazioni: prima di installare gli aggiornamenti di SQL Server 2012, arrestare tutti i servizi e le applicazioni tramite cui si effettua la connessione alle istanze di SQL Server da aggiornare per evitare un eventuale riavvio del sistema. Questi sono SQL Server Management Studio, SQL Server Data Tools (SSDT). Per ulteriori informazioni, vedere Avviare, arrestare, sospendere, riprendere, riavviare il motore di database, SQL Server Agent o SQL Server Browser.

    Nota Nota

    Non è possibile arrestare i servizi in un ambiente con cluster di failover. Per ulteriori informazioni, vedere la sezione relativa all'installazione nei cluster di failover più avanti in questo argomento.

  • Per eliminare la necessità di riavviare il computer dopo l'installazione degli aggiornamenti, verrà visualizzato un elenco dei processi che bloccano i file necessari. Se durante l'installazione degli aggiornamenti è necessario arrestare un determinato servizio, al termine dell'installazione tale servizio verrà riavviato automaticamente.

  • Se vengono rilevati file bloccati durante l'installazione, potrebbe essere necessario riavviare il computer al termine dell'installazione. Se necessario, verrà richiesto di riavviare il computer.

Installare gli aggiornamenti di SQL Server 2012

In questa sezione viene descritto il processo di installazione.

Nota importante Importante

Gli aggiornamenti di SQL Server 2012 devono essere installati con un account che dispone di privilegi amministrativi nel computer in cui verranno installati. Per le installazioni locali, è necessario eseguire il programma di installazione come amministratore. Se si installa SQL Server da una condivisione remota, è necessario utilizzare un account di dominio con autorizzazioni di lettura ed esecuzione relative a tale condivisione.

Avvio di un aggiornamento di SQL Server 2012

Per installare un aggiornamento di SQL Server 2012, eseguire il file di pacchetto autoestraente.

Pacchetto di aggiornamenti cumulativi (CU): <SQLServer2012>-KBxxxxxx-PPP.exe

Pacchetto di Service Pack (PCU): <SQLServer2012><SPx> -KBxxxxxx-PPP-LLL.exe

  • x indica il numero di Service Pack.

  • PPP indica la piattaforma specifica.

  • LLL indica l'abbreviazione per la lingua di SQL Server, ad esempio LLL per la lingua inglese è ENU.

Per informazioni sull'applicazione di aggiornamenti ai componenti di SQL Server 2012 che fanno parte di un cluster di failover, vedere la sezione relativa all'installazione del cluster di failover. Per ulteriori informazioni sull'esecuzione dell'installazione di un aggiornamento in modalità automatica, vedere Installazione degli aggiornamenti dal prompt dei comandi.

Aggiornamenti del prodotto nell'installazione di SQL Server 2012

La funzionalità di aggiornamento del prodotto è una nuova funzionalità del programma di installazione di SQL Server 2012. Integra gli aggiornamenti più recenti del pacchetto con l'installazione del prodotto principale, in modo che il prodotto principale e i relativi aggiornamenti applicabili vengano installati contemporaneamente. L'Aggiornamento prodotto consente di cercare aggiornamenti applicabili in Microsoft Update, Windows Server Update Services (WSUS), una cartella locale o una condivisione di rete. Dopo che il programma di installazione trova le versioni più recenti degli aggiornamenti applicabili, li scarica e li integra con il processo di installazione di SQL Server corrente. L'Aggiornamento prodotto può effettuare il pull in un aggiornamento cumulativo, un Service Pack o Service Pack con aggiornamento cumulativo. La funzionalità di aggiornamento del prodotto è un'estensione dal punto di vista funzionale dell'installazione integrata che era disponibile in SQL Server 2008 PCU1. Per ulteriori informazioni sulla funzionalità di aggiornamenti del prodotto nel programma di installazione di SQL Server 2012, vedere Aggiornamenti del prodotto nell'installazione di SQL Server 2012.

Installazione completa di SQL Server 2012 SP1

SQL Server 2012 SP1 è disponibile anche come pacchetto di installazione completa di SQL Server. Tramite il pacchetto di installazione di SQL Server 2012 SP1 verrà installata una nuova istanza di SQL Server con SP1 preinstallato.

Nel pacchetto sono disponibili file eseguibili e di installazione in formato compresso. Il formato dei file del pacchetto è SQLServer2012SP1-<Architettura>-<Lingua>.exe e SQLServer2012SP1-<Architettura>-<Lingua>.box.

Esaminare le istruzioni seguenti durante l'installazione di SQL Server 2012 SP1:

  • Scaricare i seguenti file da una pagina di download in una directory temporanea nel dispositivo in uso:

    • SQLServer2012SP1-architettura-lingua.box

    • SQLServer2012SP1-architettura-lingua.exe

  • Al termine dei download, fare doppio clic sul file SQLServer2012SP1-<architettura>-<lingua>.exe per avviare il processo di installazione.

  • Nella finestra di dialogo Selezionare una directory per i file estratti il percorso di directory predefinito è prepopolato: <Unità attuale>\<Cartella di lavoro attuale>\<Nome pacchetto>. Ad esempio, %temp%\SQLServer2012SP1-x64-ENU\. Fare clic su Sfoglia per modificare il percorso di directory per i file estratti.

  • Il pacchetto viene decompresso nel percorso di installazione specificato e viene ignorato nel percorso di directory selezionato al termine dell'installazione. Un utente potrà utilizzare i file binari nella cartella estratta per le installazioni future.

  • Tramite l'Installazione guidata viene eseguito il Centro installazione SQL Server. Seguire le istruzioni di installazione da Installare SQL Server 2012 dall'Installazione guidata (programma di installazione) (http://msdn.microsoft.com/library/ms143219.aspx).

Nella tabella seguente sono elencati alcuni dei parametri della riga di comando utilizzabili per l'estrazione del pacchetto SQL Server 2012 SP1:

Per l'elenco dettagliato dei parametri della riga di comando supportati che possono essere forniti direttamente al pacchetto SP1, vedere Installare SQL Server 2012 dal prompt dei comandi (http://msdn.microsoft.com/library/ms144259.aspx)

Parametro | Descrizione
/x o -x | Estrae il pacchetto nel percorso specificato. Apre la finestra di dialogo Selezionare una directory per i file estratti, quindi estrae il pacchetto nel percorso specificato. Non esegue il programma di installazione.
/x:<percorso> O -x:<percorso> | Estrae il pacchetto nel percorso specificato e non avvia il programma di installazione.
/q o -q | Specifica che il programma di installazione viene eseguito in modalità non interattiva senza alcuna interfaccia utente. Questo parametro viene utilizzato per le installazioni automatiche.
/l:<percorso> O -l:<percorso> | Per impostazione predefinita il file di log viene archiviato nella directory temporanea con il nome SQLServer2012SPx-<Architettura>-<Lingua>_decompressione_log.txt Utilizzare questo parametro per generare il file di log di estrazione in un percorso specificato. Esempio: SQLServer2012SP1-x64-ENU /x /l:<percorso> Questa opzione deve essere utilizzata solo con /x o –x o /x:<percorso> o -x:<percorso>

Aggiornamento di un'immagine preparata di SQL Server

È possibile applicare un aggiornamento a un'istanza predisposta non configurata di SQL Server senza completare la configurazione dell'istanza predisposta. I diversi metodi per l'applicazione di un aggiornamento a un'istanza predisposta di SQL Server vengono spiegati di seguito:

  • Aggiornamento di un'istanza precedentemente predisposta di SQL Server

    Gli aggiornamenti a un'istanza predisposta possono essere applicati prima della configurazione. Il pacchetto di aggiornamento rileva che l'istanza è in stato predisposto e applica la patch all'istanza predisposta, senza completare la configurazione.

  • Aggiornamenti a un'istanza predisposta tramite Microsoft Update:

    È possibile applicare aggiornamenti a un'istanza predisposta di SQL Server tramite Microsoft Update. Il pacchetto di Microsoft Update rileva che l'istanza è in stato predisposto e applica la patch all'istanza predisposta, senza completare la configurazione.

Se si aggiorna un'immagine preparata di SQL Server, sarà necessario specificare il parametro InstanceID. Per ulteriori informazioni e la sintassi di esempio, vedere Installazione degli aggiornamenti dal prompt dei comandi.

Aggiornamento di un'immagine completata di SQL Server

L'aggiornamento di un'istanza completata e configurata di SQL Server segue gli stessi processi di qualsiasi altra istanza installata di SQL Server.

Ricompilazione di un nodo del cluster di failover di SQL Server 2012

Se è necessario ricompilare un nodo nel cluster di failover dopo l'applicazione degli aggiornamenti, effettuare le operazioni seguenti:

  1. Ricompilare il nodo nel cluster di failover. Per ulteriori informazioni sulla ricompilazione di un nodo, vedere Recuperare da un errore dell'istanza del cluster di failover.

  2. Eseguire il programma di installazione originale di SQL Server 2012 per installare SQL Server 2012 nel nodo del cluster di failover.

  3. Eseguire il programma di installazione degli aggiornamenti di SQL Server 2012 sul nodo appena aggiunto.

Riavvio di servizi e applicazioni

Al termine dell'installazione potrebbe essere necessario riavviare il computer. Dopo il riavvio del sistema, oppure al termine del programma di installazione se non viene richiesto di riavviare il sistema, utilizzare l'icona Servizi del Pannello di controllo per riavviare i servizi arrestati prima dell'applicazione degli aggiornamenti di SQL Server 2012. Sono inclusi servizi quali Distributed Transaction Coordinator e Microsoft Search o i servizi equivalenti specifici dell'istanza.

Riavviare le applicazioni chiuse prima di eseguire il programma di installazione degli aggiornamenti di SQL Server 2012. Subito dopo il completamento dell'installazione, è inoltre consigliabile eseguire un altro backup dei database master, msdb e model aggiornati.

Disinstallazione di aggiornamenti da SQL Server 2012

È possibile disinstallare gli aggiornamenti cumulativi o i Service Pack di SQL Server 2012 da Programmi e funzionalità nel Pannello di controllo. Per visualizzare l'elenco di aggiornamenti installati, aprire Aggiornamenti installati facendo clic sul pulsante Start, Pannello di controllo, Programmi, quindi facendo clic su Visualizza aggiornamenti installati in Programmi e funzionalità. Ogni aggiornamento cumulativo è elencato separatamente. Tuttavia, quando si installa un Service Pack più recente degli aggiornamenti cumulativi, le voci relative agli aggiornamenti cumulativi vengono nascoste e diventano disponibili solo se si disinstalla il Service Pack.

Per disinstallare Service Pack e aggiornamenti, è necessario iniziare dall'aggiornamento o dal Service Pack applicato più di recente all'istanza di SQL Server e procedere a ritroso. In ciascuno dei seguenti esempi, SQL Server termina con l'aggiornamento cumulativo 1 dopo aver completato la disinstallazione degli altri Service Pack o aggiornamenti.

  • Nelle istanze di SQL Server 2012 con aggiornamento cumulativo 1 e SP1 installati, disinstallare il SP1.

  • Nelle istanze di SQL Server 2012 con aggiornamento cumulativo 1, SP1 e aggiornamento cumulativo 2 installati, disinstallare prima l'aggiornamento cumulativo 2 e successivamente SP1.

Vedere anche

Altre risorse

Installare SQL Server 2012 dal prompt dei comandi
Installare gli aggiornamenti dei servizi di SQL Server 2012
Convalidare un'installazione di SQL Server
Visualizzare e leggere i file di log del programma di installazione di SQL Server
Inviare commenti e suggerimenti sull'argomento a Microsoft

© 2012 Microsoft Corporation. Tutti i diritti riservati.


Nota legale sulla documentazione

[image]

Nota legale sulla documentazione
Commenti e suggerimenti

Il documento viene fornito "com'è". Le informazioni e le opinioni espresse nel presente documento, inclusi gli URL e altri riferimenti a siti Web, possono essere soggette a modifiche senza preavviso. L'utente accetta di utilizzarlo a proprio rischio.

Alcuni esempi utilizzati in questo documento vengono forniti a scopo puramente illustrativo e sono fittizi. Nessuna associazione reale o connessione è intenzionale o può essere desunta.

Il presente documento non implica la concessione di alcun diritto di proprietà intellettuale relativo ai prodotti Microsoft. È possibile copiare e utilizzare questo documento per fini di riferimento interno.

© 2012 Microsoft. Tutti i diritti sono riservati.

Microsoft, Active Directory, ActiveX, Bing Maps, Excel, IntelliSense, MSDN, MS-DOS, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual Studio, Windows, Windows NT, Windows Server e Windows Vista sono marchi di società del gruppo Microsoft. SAP NetWeaver è un marchio registrato di SAP AG in Germania e in altri paesi. Altri nomi di prodotti e società citati nel presente documento sono marchi dei rispettivi proprietari.

Criteri relativi alla documentazione per il supporto e l'aggiornamento di SQL Server

La documentazione del software SQL Server 2012 comprende la documentazione online di Microsoft per SQL Server 2012, la documentazione di installazione, la documentazione di riferimento per gli sviluppatori, esercitazioni, file Leggimi, documenti su problemi noti, codice/applicazioni di esempio, database di esempio e articoli della Knowledge Base pubblicati da Microsoft, tutti con contenuto su caratteristiche e funzionalità di SQL Server. Tali criteri per il supporto e l'aggiornamento si applicano alla documentazione di SQL Server 2012, inclusi i file Leggimi relativi a versioni e Service Pack di SQL Server 2012. I file Leggimi sono considerati estensioni della documentazione online di SQL Server 2012.

Obiettivo principale degli esempi inclusi nella documentazione è quello di illustrare un concetto o l'utilizzo comune di un'istruzione o di una clausola specifica. La maggior parte degli esempi non include il codice completo normalmente disponibile in un sistema completo e finale, in quanto una parte dei normali dati di convalida o la gestione degli errori vengono in genere rimossi dagli esempi per mettere in maggiore evidenza il concetto o l'istruzione specifici illustrati nell'esempio stesso. I servizi del Servizio Supporto Tecnico Clienti Microsoft non sono disponibili per gli esempi e il codice sorgente incluso.

In alcuni casi, una particolare caratteristica di SQL Server 2012 non è stata sufficientemente testata o sviluppata e non è destinata all'utilizzo. Tali caratteristiche sono incluse come segnaposto. Alcune caratteristiche incluse nel software, pertanto, sono escluse dalla trattazione nella documentazione. Le caratteristiche non documentate o incluse come notazione per l'uso interno da parte di Microsoft non sono destinate all'utilizzo e non sono supportate dal Servizio Supporto Tecnico Clienti Microsoft. Se non diversamente indicato nella documentazione di SQL Server 2012, il contenuto di terze parti, inclusi i problemi derivati dall'utilizzo di tale contenuto con SQL Server 2012, non è supportato dal Servizio Supporto Tecnico Clienti Microsoft e può inoltre comportare la perdita di dati. Il Servizio Supporto Tecnico Clienti Microsoft non fornisce alcun supporto per i database o le applicazioni che utilizzano punti di ingresso non trattati nella documentazione, ad esempio le API non documentate, inclusi, a titolo esemplificativo, metadati, stored procedure, stored procedure estese, funzioni, viste, tabelle, colonne o proprietà.

Gli aggiornamenti di server e database alle versioni successive di SQL Server 2012 per le applicazioni e i database che utilizzano punti di ingresso non trattati nella documentazione potrebbero non funzionare e non sono supportati. L'utilizzo di caratteristiche e funzionalità di SQL Server incluse in Microsoft SQL Server che esulano dalla trattazione nella documentazione di SQL Server 2012 non è supportato e può provocare la perdita di dati.


Installazione degli aggiornamenti dal prompt dei comandi

[image]

Installazione degli aggiornamenti dal prompt dei comandi
Vedere anche Commenti e suggerimenti

Provare gli script di installazione e adattarli alle esigenze della propria azienda. Per ulteriori informazioni sull'installazione di aggiornamenti in un cluster di failover di SQL Server, vedere l'articolo relativo all' applicazione di un aggiornamento di SQL Server a un'istanza del cluster di failover nella Microsoft Knowledge Base.

Sintassi di esempio per l'installazione

Il nome del pacchetto di aggiornamento può variare e includere una lingua, un'edizione e un componente processore. Applicare un aggiornamento dal prompt dei comandi sostituendo <package_name> con il nome del pacchetto di aggiornamento.

  • Aggiornare una sola istanza di SQL Server e tutti i componenti condivisi, quali Integration Services e gli strumenti di gestione. È possibile specificare l'istanza tramite il parametro InstanceName o il parametro InstanceID. Per aggiornare un'istanza predisposta di SQL Server è necessario specificare il parametro InstanceID<nome_pacchetto>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /InstanceName=NomeIstanza o <nome_pacchetto>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /InstanceID=<ID istanza>

  • La configurazione consente di integrare gli aggiornamenti più recenti del pacchetto con l'installazione del prodotto principale, in modo che il prodotto principale e i relativi aggiornamenti applicabili vengano installati contemporaneamente. È possibile preparare un'installazione dell'istanza del motore di database affinché includa l'aggiornamento del prodotto: setup.exe /q /IAcceptSQLServerLicenseTerms /ACTION=PrepareImage /UpdateEnabled=True /UpdateSource=<pacchetto in cui viene scaricato l'aggiornamento> /INSTANCEID=<ID istanza> /FEATURES=SQLEngine

  • Aggiornare solo i componenti condivisi di SQL Server, quali Integration Services e gli strumenti di gestione: <nome_pacchetto>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch

  • Aggiornare tutte le istanze di SQL Server presenti nel computer e tutti i componenti condivisi, quali Integration Services e gli strumenti di gestione: <nome_pacchetto>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /AllInstances

Rimuovere un aggiornamento dal prompt dei comandi sostituendo <nome_pacchetto> con il nome del pacchetto di aggiornamento.

  • Rimuovere un aggiornamento da una singola istanza di SQL Server e da tutti i componenti condivisi, quali Integration Services e gli strumenti di gestione: <nome_pacchetto>.exe /qs /Action=RemovePatch /InstanceName=MyInstance

  • Rimuovere un aggiornamento solo dai componenti condivisi di SQL Server, quali Integration Services e gli strumenti di gestione: <nome_pacchetto>.exe /qs /Action=RemovePatch

    Nota Nota

    Il programma di installazione dell'aggiornamento verifica che la versione dei componenti condivisi sia sempre corrispondente o superiore alla versione dell'istanza di livello più alto.

Parametri del prompt dei comandi supportati

Nota importante Importante

Se possibile, specificare le credenziali di sicurezza in fase di esecuzione. Se è necessario archiviare le credenziali in un file di script, proteggere tale file per impedire l'accesso non autorizzato.

Switch | Descrizione
/? | Visualizza la Guida del prompt dei comandi per l'installazione automatica
/action=Patch or /action=RemovePatch | Specifica l'azione di installazione: Patch o RemovePatch.
/allinstances | Applica l'aggiornamento di SQL Server a tutte le istanze di SQL Server e a tutti i componenti condivisi di SQL Server che non supportano le istanze.
/instancename=InstanceName1 | Applica l'aggiornamento di SQL Server all'istanza di SQL Server denominata InstanceName e a tutti i componenti condivisi di SQL Server che non supportano le istanze.
/InstanceID=Inst1 | Applica l'aggiornamento di SQL Server all'istanza Inst1 di SQL Server e a tutti i componenti condivisi di SQL Server che non supportano le istanze.
/quiet | Esegue l'installazione dell'aggiornamento di SQL Server in modalità automatica.
/qs | Visualizza solo la finestra di dialogo dell'interfaccia utente relativa allo stato.
/UpdateEnabled | Specifica se durante la configurazione di SQL Server debbano essere individuati e inclusi aggiornamenti del prodotto. I valori validi sono True e False oppure 1 e 0. Per impostazione predefinita, nella configurazione di SQL Server verranno inclusi gli aggiornamenti individuati.
/UpdateSource | Specifica il percorso in cui la configurazione di SQL Server otterrà aggiornamenti del prodotto. I valori validi sono "MU" per cercare Microsoft Update, un percorso di cartella valido, un percorso relativo come .\MyUpdates o una condivisione UNC. Per impostazione predefinita, nella configurazione di SQL Server verrà individuato Microsoft Update o un servizio Windows Update tramite Windows Server Update Services.
/IAcceptSQLServerLicenseTerms | Obbligatorio solo quando il parametro /Q o /QS è specificato per le installazioni automatiche.

1 Non è possibile specificare questo parametro per applicare un aggiornamento a un'istanza predisposta di SQL Server. Specificare il parametro /instanceID.

Vedere anche

Concetti

Panoramica sull'installazione dei servizi SQL Server


Procedura: Convalida della corretta installazione di un aggiornamento di SQL Server

[image]

Procedura: Convalida della corretta installazione di un aggiornamento di SQL Server
Vedere anche Commenti e suggerimenti

Per convalidare la corretta installazione di un aggiornamento di SQL Server:

  • Verificare che i servizi SQL Server siano online.

  • Verificare le informazioni sulla versione restituite dalla query @@version.

Vedere anche

Concetti

Panoramica sull'installazione dei servizi SQL Server


Assistenza su SQL Server

[image]

Assistenza su SQL Server
Vedere anche Commenti e suggerimenti

In Microsoft sono disponibili tre fonti principali di informazioni su SQL Server:

  • La documentazione installata come una raccolta locale della documentazione online di SQL Server.

  • I siti di SQL Server in Microsoft Developer Network (MSDN) e TechNet.

  • Le informazioni su SQL Server in altri siti Web Microsoft.

Se non si trovano le informazioni desiderate, è possibile inserire domande nei forum e nei newsgroup della community di SQL Server oppure richiedere assistenza al supporto tecnico di Microsoft.

Documentazione online di SQL Server

Nella documentazione online di SQL Server sono inclusi i concetti e le procedure necessari per utilizzare SQL Server ed è disponibile del materiale di riferimento per i linguaggi e le interfacce di programmazione per l'archiviazione, il recupero, la creazione di report e la modifica dei dati mediante SQL Server.

È possibile accedere alla documentazione online nei modi seguenti:

  • Una copia della documentazione online di SQL Server 2012 è pubblicata sia in MSDN Library sia nella libreria TechNet disponibile su Internet. Negli argomenti di queste copie della documentazioni online di SQL Server sono inclusi commenti della community, quali esempi di codice e informazioni aggiuntive forniti da altri utenti. È possibile visualizzare la copia di MSDN Library nella Documentazione online di SQL Server 2012.

  • È possibile utilizzare Gestione librerie della Guida per installare la documentazione online di SQL Server in un computer locale. Per ulteriori informazioni, vedere Aggiungere o rimuovere raccolte della Guida..

Quando Microsoft pubblica un aggiornamento alla documentazione online di SQL Server vengono aggiornati sia la copia della documentazione online di SQL Server in MSDN Library sia i file della documentazione online disponibili tramite Gestione librerie della Guida.

Informazioni su MSDN e TechNet

In Microsoft Developer Network (MSDN) sono disponibili servizi online e offline destinati agli sviluppatori che scrivono applicazioni utilizzando prodotti e tecnologie Microsoft. Il programma Microsoft TechNet offre risorse tecniche complete che consentono ai professionisti IT di valutare, distribuire e fornire supporto per soluzioni Microsoft in modo efficace.

In numerosi siti MSDN e TechNet sono disponibili collegamenti alle informazioni su SQL Server più rilevanti per specifici ruoli professionali, incluse le informazioni contenute nelle copie della documentazione online di SQL Server in MSDN o TechNet. In questi siti sono inoltre contenute informazioni aggiuntive rispetto a quelle disponibili nella documentazione online di SQL Server.

Nella tabella seguente vengono descritte queste risorse con i relativi destinatari.

Risorsa | Destinatari
Centro per sviluppatori di SQL Server | Sviluppatori che compilano database, sistemi per la gestione di report e soluzioni di Business Intelligence per SQL Server e che progettano applicazioni e siti Web per l'utilizzo di questi sistemi.
Centro per sviluppatori di soluzioni di accesso ai dati e archiviazione | Sviluppatori che desiderano abilitare le proprie applicazioni e i propri siti Web per l'utilizzo di dati archiviati mediante prodotti diversi, ad esempio SQL Server e Access.
Centro per sviluppatori XML | Creatori di siti Web e sviluppatori di applicazioni i cui siti e le cui applicazioni utilizzano il linguaggio XML per l'archiviazione e la manipolazione dei dati.
Sito TechNet di SQL Server | Amministratori e operatori che pianificano, distribuiscono, amministrano e supportano sistemi che utilizzano SQL Server.

Ulteriori informazioni online

Informazioni aggiuntive su SQL Server sono disponibili nei siti Web Microsoft seguenti.

Risorsa | Descrizione
Sito Web di Microsoft SQL Server | Informazioni di prevendita per la valutazione di SQL Server come strumento per l'archiviazione dei dati e per soluzioni di Business Intelligence.
Microsoft Knowledge Base | Repository in cui è possibile eseguire la ricerca di articoli relativi a SQL Server scritti dai tecnici del Servizio Supporto Tecnico Clienti Microsoft.
Microsoft Learning | Descrive gli strumenti per la formazione e la certificazione offerti da Microsoft per SQL Server.
Microsoft Press | Elenco delle pubblicazioni di Microsoft Press relative a SQL Server.

Altre risorse di assistenza

Se non è stato possibile trovare le informazioni desiderate né nella documentazione del prodotto né sul Web, è possibile inoltrare una domanda ai forum e ai newsgroup della community di SQL Server. È anche possibile richiedere assistenza al supporto del prodotto.

Nota Nota

Non pubblicare domande nella sezione dei commenti della community posta nella parte inferiore degli argomenti della documentazione online di SQL Server in MSDN Library o nella libreria Technet. Tali sezioni non vengono infatti controllate per le domande e non forniscono pertanto risposte. Inserire le domande nei forum e nei newsgroup della community, che vengono controllati da altri clienti in grado di fornire risposte.

Nella tabella seguente sono riportati collegamenti e descrizioni per tali risorse.

Risorsa | Descrizione
Pagina relativa alla community di professionisti IT di SQL Server | Sono contenuti collegamenti ai newsgroup e ai forum monitorati dalla community di SQL Server. Elenca inoltre le fonti di informazione della community, quali Blog e siti Web. La community di SQL Server è molto solerte nel rispondere alle domande. Non è tuttavia garantita una risposta.
Community del centro per sviluppatori di SQL Server | Questo sito è incentrato sui newsgroup, i forum e le altre risorse della community utili per gli sviluppatori di SQL Server.
Supporto Tecnico Microsoft | È possibile utilizzare questo sito Web per richiedere assistenza al supporto tecnico di Microsoft.

I prodotti Microsoft dispongono di un ciclo di vita del supporto che ne definisce il periodo di disponibilità per ciascuna versione. Nel sito relativo al supporto tecnico Microsoft è disponibile una pagina in cui viene definito il ciclo di vita del supporto per i prodotti Microsoft. Nella pagina sono presenti collegamenti ad altre pagine che specificano la disponibilità del supporto per i prodotti Microsoft. Per ulteriori informazioni, vedere Microsoft Support Lifecycle.

Vedere anche

Concetti

Utilizzare la documentazione del prodotto per SQL Server


Procedura guidata

[image]

Procedura guidata
Commenti e suggerimenti

Le regole di installazione consentono di eseguire l'analisi del computer in cui verrà installato l'aggiornamento.


Condizioni di licenza

[image]

Condizioni di licenza
Commenti e suggerimenti

Utilizzare la pagina relativa alle condizioni di licenza per accettare le condizioni di licenza della versione in uso.

Opzioni

Per procedere con l'installazione, è necessario accettare le condizioni di licenza di SQL Server.

Per stampare una copia delle condizioni di licenza per la versione in uso, utilizzare il pulsante Stampa. Fare clic su Annulla per terminare l'installazione.


Seleziona caratteristiche

[image]

Seleziona caratteristiche
Commenti e suggerimenti

Utilizzare la pagina Selezione caratteristica per selezionare i componenti e le caratteristiche di SQL Server da aggiornare.

Opzioni

Fare clic sul nome di una caratteristica nel riquadro sinistro per visualizzare informazioni sulla lingua, il sistema operativo, l'edizione e lo stato.

Per aggiornare un componente o una caratteristica, selezionare la casella di controllo accanto al suo nome. Per escludere dall'aggiornamento un componente o una caratteristica, deselezionare la casella di controllo accanto al suo nome.

Se in uno stesso computer sono presenti più istanze di SQL Server, le singole istanze potranno essere aggiornate in momenti diversi, ma tutti i componenti di una stessa istanza di SQL Server dovranno essere aggiornati contemporaneamente. È necessario aggiornare tutti i componenti condivisi, quali i componenti workstation, il parser MSXML, SQLXML, i componenti per la compatibilità con le versioni precedenti e VSS Writer.

Se non è possibile aggiornare un determinato componente, il motivo verrà specificato nel riquadro dei dettagli.


Controllo file in uso

[image]

Controllo file in uso
Commenti e suggerimenti

Per evitare il riavvio di Windows dopo l'installazione degli aggiornamenti di SQL Server, utilizzare la pagina Controllo file in uso per identificare i processi che bloccano i file necessari per il programma di installazione degli aggiornamenti di SQL Server.

Arrestare tutti i servizi e le applicazioni che si connettono alle istanze di SQL Server da aggiornare, Arrestare anche SQL Server Management Studio e SQL Server Data Tools (SSDT).

Se vengono rilevati file bloccati durante l'installazione, potrebbe essere necessario riavviare il computer al termine dell'installazione. In questo caso, verrà richiesto di riavviare il computer. Se durante l'installazione degli aggiornamenti è necessario arrestare un determinato servizio, al termine dell'installazione tale servizio verrà riavviato automaticamente.

Per eliminare la necessità di riavviare il computer dopo l'installazione, verrà visualizzato un elenco dei processi che bloccano i file necessari. Arrestare o terminare i processi e le applicazioni elencati. Fare clic su Aggiorna controllo per ripetere il controllo. Per arrestare un controllo in esecuzione, fare clic su Arresta controllo. Se non vengono rilevati file bloccati, la tabella risulta vuota. Dopo la chiusura o l'arresto di tutti i processi bloccati, fare clic su Avanti per continuare.

Le informazioni verranno registrate nei file di log. Per ulteriori informazioni sulla visualizzazione dei file di log, vedere Procedura: Visualizzazione dei file di log del programma di installazione di SQL Server e Procedura: Lettura di un file di log del programma di installazione di SQL Server.

Nel file di log sono incluse le seguenti informazioni:

  • Nome del processo

  • Nome della caratteristica di SQL Server

  • Tipo di processo

  • Account con il quale viene eseguito il processo

  • ID processo

  • Nome del file bloccato

Nome | Descrizione
Processo | Indica il nome completo del processo che utilizza i file da aggiornare.
Tipo | Indica il tipo di processo.
Account | Indica l'account con il quale viene eseguito il processo.
ID processo | Indica l'ID del processo.


Inizio aggiornamento

[image]

Inizio aggiornamento
Commenti e suggerimenti

Utilizzare la pagina Riepilogo per confermare le modifiche applicate all'istanza di SQL Server. Per procedere con l'installazione, fare clic su Installa.


Stato dell'aggiornamento

[image]

Stato dell'aggiornamento
Commenti e suggerimenti

La pagina Stato dell'installazione consente di monitorare il programma di installazione durante l'applicazione dell'aggiornamento all'istanza di SQL Server e ai relativi componenti.

Opzioni

Nella tabella vengono specificati il nome del prodotto SQL Server, il nome della relativa istanza e lo stato dell'installazione.


Operazione completata

[image]

Operazione completata
Commenti e suggerimenti

La pagina Operazione completata conferma lo stato dell'installazione.