SQL Server セットアップのドキュメントの概要

[image]

SQL Server セットアップのドキュメントの概要
フィードバックの送信

SQL Server セットアップに関するドキュメントは、インストール メディアに収録されているほか、オンラインで参照することができます。

セットアップ時に利用できるドキュメント

SQL Server のインストール中に、セットアップ ウィザード ページの [ヘルプ] をクリックするか、キーボードの F1 キーを押すと、操作に必要な情報をすばやく確認できます。

SQL Server のインストール関連トピックの概要

SQL Server をインストールする際は、SQL Server インストール ウィザードを使用するかコマンド プロンプトを使用するかに関係なく、次のセクションを読んでインストールに備えてください。

  • SQL Server のインストール計画

    SQL Server インストールの準備について説明します。

  • SQL Server 2012 のインストール

    SQL Server をインストールするオプションについて説明します。

  • SQL Server 2012 の BI 機能のインストール

    Analysis Services、Integration Services、Reporting Services、および分析データの作成または操作に使用するいくつかのクライアント アプリケーションを含む、Microsoft BI プラットフォームの一部である SQL Server 機能のインストールのオプションについて説明します。

  • SQL Server 2012 へのアップグレード

    SQL Server にアップグレードするオプションについて説明します。

SQL Server フェールオーバー クラスターをインストールする場合は、次のドキュメントを確認してください。

  • SQL Server フェールオーバー クラスタリングの概要

  • フェールオーバー クラスタリングをインストールする前に

このトピックに関するフィードバックを Microsoft に送る

© 2012 Microsoft Corporation.All rights reserved.


SQL Server の使用許諾条件について

[image]

SQL Server の使用許諾条件について
関連項目 フィードバックの送信

Microsoft ソフトウェア使用許諾条件は、SQL Server のインストール時にローカル コンピューターにコピーされます。 同じエディションと言語の SQL Server インスタンスを、同じコンピューターに複数インストールする場合、それらのエディションと言語のすべてのインスタンスに対して単一の使用許諾条件が適用されます。 このファイルは、%ProgramFiles%\Microsoft SQL Server\110\License Terms\ または %ProgramFiles(x86)%\Microsoft SQL Server\110\License Terms\ に保存されます。

同じ SQL Server エディションと言語のインスタンスを、同じコンピューターに複数インストールする場合、それらのエディションと言語のすべてのインスタンスに対して単一の使用許諾条件が適用されます。

使用許諾条件ファイル名は、SQL Server のエディションと SQL Server の言語のエディションを示します。 次にその例を示します。

  • License_DEV_ENU.txt: SQL Server Developer (英語版)

  • License_STD_ITA.txt: SQL Server Standard (イタリア語版)

  • License_UA_JPN.txt: SQL Server アップグレード アドバイザー (日本語版)

  • License_SQLNCLI_ENU.txt: SQL Server Native Client (英語版)

  • License_SQLXML4_KOR.txt: SQLXML (韓国語版)

  • SQL Server Business Intelligence エディションの License_SQLBI.rtf。

  • SQL Server Enterprise エディションの License_ENTCORE.rtf: コアベース ライセンス。

  • SQL Server Enterprise エディション Server/CAL ライセンスの License_ENT.rtf。

次のファイル名の一部は、SQL Server のエディションを識別するために使用します。

  • ENT - Enterprise Edition: サーバー/クライアント アクセス ライセンス (CAL) ライセンス

  • ENTCORE - Enterprise Edition: コア ベース ライセンス

  • BI - Business Intelligence

  • DEV - Developer

  • STD - Standard

  • WEB - Web

  • EXPR - Express

次に示すファイル名の部分は、対応する SQL Server の言語を識別するために使用します。

  • ENU - 英語

  • JPN - 日本語

  • FRA - フランス語

  • ITA - イタリア語

  • KOR - 韓国語

  • DEU - ドイツ語

  • ESN - スペイン語

  • CHS - 簡体字中国語

  • CHT - 繁体字中国語

  • PTB - ポルトガル語 (ブラジル)

  • RUS - ロシア語

SQL Server ライセンス オプション

SQL Server の価格およびライセンス オプションの詳細については、Microsoft SQL Server (http://go.microsoft.com/fwlink/?LinkId=190955) の Web サイトを参照してください。

関連項目

概念

SQL Server のライセンスに関する注意点
Microsoft SQL Server のプライバシーに関する声明
ドキュメントの免責事項


SQL Server のライセンスに関する注意点

[image]

SQL Server のライセンスに関する注意点
関連項目 フィードバックの送信

SQL Server のライセンス オプションの詳細については、Microsoft SQL Server の Web サイトを参照してください。

関連項目

参照

SQL Server の使用許諾条件について

概念

Microsoft SQL Server のプライバシーに関する声明
ドキュメントの免責事項


ドキュメントの免責事項

[image]

ドキュメントの免責事項
フィードバックの送信

このドキュメントは現状有姿で提供され、 このドキュメントに記載されている情報や見解 (URL 等のインターネット Web サイトに関する情報を含む) は、将来予告なしに変更されることがあります。 お客様は、その使用に関するリスクを負うものとします。

ここで使用される例は架空のものであり、説明のためだけに使用されます。 実在するものとは一切関係ありません。

このドキュメントは、Microsoft 製品の無体財産権に関する法的な権利をお客さまに許諾するものではありません。 内部的な参照目的に限り、このドキュメントを複製して使用することができます。

© 2012 Microsoft. All rights reserved.

Microsoft、Active Directory、ActiveX、Bing Maps、Excel、IntelliSense、MSDN、MS-DOS、PivotChart、PivotTable、PowerPoint、SharePoint、SQL Server、Visual Basic、Visual C#、Visual C++、Visual Studio、Windows、Windows NT、Windows Server、および Windows Vista は、Microsoft Corporation およびその関連会社の商標です。 SAP NetWeaver は、ドイツ SAP AG のドイツおよびその他の国における登録商標または商標です。 記載されている会社名、製品名には、各社の商標のものもあります。

SQL Server のサポートおよびアップグレードに関するドキュメント ポリシー

Microsoft SQL Server 2012 ソフトウェア マニュアルには、マイクロソフトによって発行された Microsoft SQL Server 2012 の Microsoft オンライン ブック、インストール マニュアル、デベロッパー向けリファレンス マニュアル、チュートリアル、Readme ファイル、既知の問題、サンプル コード、サンプル データベース、サポート技術情報などがあり、それらすべてに SQL Server の特徴および機能に関する内容が含まれています。 このサポートおよびアップグレードに関するポリシーは、Microsoft SQL Server 2012 リリースおよびサービス パックの Readme ファイルを含む Microsoft SQL Server 2012 ドキュメントに適用されます。Readme は、Microsoft SQL Server 2012 オンライン ブックの追加ファイルとして扱われます。

このマニュアルに含まれているサンプルは、概念や特定のステートメントまたは句の利用方法の説明を主目的として提供されています。 多くのサンプルは、特定の概念やステートメントの説明のみを目的としているため、通常の実稼働システムで必要となるようなデータ評価やエラー処理のコードは含んでいません。 提供されているサンプルおよびソース コードに対するテクニカル サポートは行っていません。

Microsoft SQL Server 2012 の機能によっては、十分なテストまたは開発が行われていないものもあり、利用を想定していない場合があります。 多くの場合、このような機能はプレースホルダーとして含まれています。 したがって、ソフトウェアに含まれている機能の中にはドキュメントに記載されていないものもあります。 ドキュメントに記載されていない機能またはマイクロソフト内部で使用することが表記されている機能は、利用を想定していないので、マイクロソフト カスタマー サポート サービスではサポートされません。 Microsoft SQL Server 2012 ドキュメントに記載されていない限り、第三者が発行した内容 (Microsoft SQL Server 2012 で第三者が発行した内容を使用することによって生じた問題を含む) はマイクロソフト カスタマー サポート サービスではサポートされず、その内容を使用することでデータが失われる可能性もあります。 また、マイクロソフト カスタマー サポート サービスでは、公開されていないエントリ ポイントを使用または応用したデータベースやアプリケーションもサポートされません。このようなエントリ ポイントには、ストアド プロシージャ、拡張ストアド プロシージャ、関数、ビュー、テーブル、列、プロパティ、メタデータなどの公開されていない API が挙げられます。

また、このようなデータベースやアプリケーションについて、サーバーおよびデータベースを Microsoft SQL Server 2012 の将来のバージョンにアップグレードする場合も、動作は保証されずサポート対象外となります。 Microsoft SQL Server 2012 ドキュメントに記載されていない Microsoft SQL Server の機能の使用はサポートされず、そのような機能を使用することでデータが失われる可能性もあります。


Microsoft SQL Server のプライバシーに関する声明

[image]

Microsoft SQL Server のプライバシーに関する声明
フィードバックの送信

Microsoft SQL Server 2012 のプライバシーとデータ収集ポリシーについては、「SQL Server のプライバシーに関する声明」を参照してください。


SQL Server の既定のインスタンスおよび名前付きインスタンスのファイルの場所

[image]

SQL Server の既定のインスタンスおよび名前付きインスタンスのファイルの場所
関連項目 フィードバックの送信

SQL Server のインストールは、1 つ以上の別個のインスタンスで構成されます。 既定のインスタンスか名前付きインスタンスかにかかわらず、各インスタンスには、それぞれ専用のプログラム ファイルとデータ ファイルが用意されます。さらに、コンピューター上の SQL Server のすべてのインスタンスが使用する共有ファイル セットもあります。

SQL Server のインスタンスにデータベース エンジン、Analysis Services、Reporting Services が含まれている場合は、これらの各コンポーネントで使用するデータと実行ファイルのセット、およびすべてのコンポーネントが使用する共有ファイルが用意されます。

コンポーネントごとにインストール場所を分けるため、SQL Server インスタンス内の各コンポーネントについて一意のインスタンス ID が生成されます。

重要な注意事項 重要

リムーバブル ディスク ドライブ、圧縮を使用するファイル システム、システム ファイルが存在するディレクトリ、およびフェールオーバー クラスター インスタンス上の共有ドライブには、プログラム ファイルとデータ ファイルをインストールすることができません。

Binn、Data、Ftdata、HTML、1033 の各ディレクトリとその内容は削除しないでください。 他のディレクトリは必要に応じて削除できますが、削除した機能やデータを元に戻すには、SQL Server をいったんアンインストールしてからインストールし直す必要があります。 HTML ディレクトリ内のすべての .htm ファイルは、削除も修正もしないでください。 SQL Server のツールを正常に機能させるには、これらのファイルが必要です。

SQL Server のすべてのインスタンスで共有されるファイル

同じコンピューター上のすべてのインスタンスが使用する共通ファイルは、<ドライブ>:\Program Files\Microsoft SQL Server\110\ フォルダーにインストールされます (<ドライブ> は、コンポーネントがインストールされているドライブの名前です)。 既定値は、通常はドライブ C です。

ファイルの場所とレジストリのマッピング

SQL Server セットアップの実行時には、サーバー コンポーネントごとにインスタンス ID が生成されます。 この SQL Server リリースのサーバー コンポーネントは、データベース エンジン、Analysis Services、および Reporting Services です。

既定のインスタンス ID は、次の形式を使用して作成されます。

  • データベース エンジンを表す "MSSQL" に、メジャー バージョン番号、アンダースコアおよびマイナー番号 (該当する場合)、ピリオド、およびインスタンス名を連結した形式

  • Analysis Services を表す "MSAS" に、メジャー バージョン番号、アンダースコアおよびマイナー番号 (該当する場合)、ピリオド、およびインスタンス名を連結した形式

  • Reporting Services を表す "MSRS" に、メジャー バージョン番号、アンダースコアおよびマイナー番号 (該当する場合)、ピリオド、およびインスタンス名を連結した形式

このリリースの Microsoft SQL Server 2012 における既定のインスタンス ID の例を次に示します。

  • Microsoft SQL Server 2012 の既定のインスタンスの場合、MSSQL11.MSSQLSERVER

  • Analysis Services の既定のインスタンスの場合、MSAS11.MSSQLSERVER

  • "MyInstance" という名前の付いた Microsoft SQL Server 2012 インスタンスの場合、MSSQL11.MyInstance

データベース エンジンおよび Analysis Services を含み、名前が "MyInstance" で、インストール先が既定のディレクトリである Microsoft SQL Server 2012 の名前付きインスタンスの場合、ディレクトリ構造は次のようになります。

  • C:\Program Files\Microsoft SQL Server\MSSQL11.MyInstance\

  • C:\Program Files\Microsoft SQL Server\MSASSQL11.MyInstance\

インスタンス ID には任意の値を指定できますが、特殊文字や予約されたキーワードは使用しないでください。 詳細については、「Reserved Keywords (Setup)」を参照してください。

SQL Server のセットアップ時に、既定以外のインスタンス ID を指定できます。 ユーザーが既定のインストール ディレクトリを変更した場合は、<Program Files>\Microsoft SQL Server の代わりに <カスタム パス>\Microsoft SQL Server が使用されます。 アンダースコア (_) で始まるインスタンス ID、またはシャープ記号 (#) かドル記号 ($) を含むインスタンス ID はサポートされていないことに注意してください。

注意 注

Integration Services とクライアント コンポーネントはインスタンス対応でないため、インスタンス ID は割り当てられません。 既定では、インスタンス対応でないコンポーネントが単一のディレクトリ (<ドライブ>:\Program Files\Microsoft SQL Server\110\) にインストールされます。 1 つの共有コンポーネントのインストール パスを変更すると、他の共有コンポーネントのパスも変更されます。 後続のインストールでは、最初のインストールと同じディレクトリに、インスタンス対応でないコンポーネントがインストールされます。

SQL Server Analysis Services は、インストール後にインスタンスの名前を変更できる、唯一の SQL Server コンポーネントです。 Analysis Services のインスタンスの名前を変更しても、インスタンス ID は変更されません。 インスタンスの名前変更が完了した後も、ディレクトリとレジストリ キーは、インストール時に作成されたインスタンス ID を引き続き使用します。

インスタンス対応のコンポーネントの場合は、HKLM\Software\Microsoft\Microsoft SQL Server\<Instance_ID> の下にレジストリ ハイブが作成されます。 以下に例を示します。

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL11.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSASSQL11.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.110

このレジストリは、インスタンス ID とインスタンス名のマッピングも管理します。 インスタンス ID とインスタンス名のマッピングは次のようになります。

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\SQL] "InstanceName"="MSSQL11"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\OLAP] "InstanceName"="MSASSQL11"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\RS] "InstanceName"="MSRSSQL11"

ファイル パスの指定

セットアップ中、次の機能のインストール パスを変更できます。

セットアップでインストール パスが表示されるのは、ユーザーがインストール先フォルダーを構成できる機能のみです。

コンポーネント | 既定のパス1, 2 | 構成可能3/固定パス
データベース エンジン サーバー コンポーネント | \Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\ | 構成可能
データベース エンジン データ ファイル | \Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\ | 構成可能
Analysis Services サーバー | \Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\ | 構成可能
Analysis Services データ ファイル | \Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\ | 構成可能
Reporting Services レポート サーバー | \Program Files\Microsoft SQL Server\MSRS11.<InstanceID>\Reporting Services\ReportServer\Bin\ | 構成可能
Reporting Services レポート マネージャー | \Program Files\Microsoft SQL Server\MSRS11.<InstanceID>\Reporting Services\ReportManager\ | 固定パス
Integration Services | <インストール ディレクトリ>\110\DTS\ | 構成可能4
マスター データ サービス | <インストール ディレクトリ>\110\Master Data Services | 構成可能4
クライアント コンポーネント | <インストール ディレクトリ>\110\Tools\ | 構成可能4
レプリケーションおよびサーバー側 COM オブジェクト | <ドライブ>:\Program Files\Microsoft SQL Server\110\COM\5 | 固定パス
データ変換ランタイム エンジン、データ変換パイプライン エンジン、および dtexec コマンド プロンプト ユーティリティ用の Integration Services コンポーネント DLL | <ドライブ>:\Program Files\Microsoft SQL Server\110\DTS\Binn | 固定パス
Integration Services のマネージ接続をサポートする DLL | <ドライブ>:\Program Files\Microsoft SQL Server\110\DTS\Connections | 固定パス
Integration Services がサポートする列挙子の型ごとの DLL | <ドライブ>:\Program Files\Microsoft SQL Server\110\DTS\ForEachEnumerators | 固定パス
SQL Server Browser Service、WMI プロバイダー | <ドライブ>:\Program Files\Microsoft SQL Server\110\Shared\ | 固定パス
SQL Server のすべてのインスタンス間で共有されるコンポーネント | <ドライブ>:\Program Files\Microsoft SQL Server\110\Shared\ | 固定パス

1 \Program Files\Microsoft SQL Server\ フォルダーが権限の制限により保護されていることを確認してください。

2 これらの場所の既定のドライブは systemdrive で、通常はドライブ C です。

3 子機能のインストール パスは、親機能のインストール パスと同じになります。

4 1 つのインストール パスが Integration Services とクライアント コンポーネントの間で共有されます。 1 つのコンポーネントのインストール パスを変更すると、他のコンポーネントのパスも変更されます。 後続のインストールでは、最初のインストールと同じ場所にコンポーネントがインストールされます。

5 このディレクトリは、コンピューター上のすべての SQL Server インスタンスで使用されます。 コンピューター上のいずれかのインスタンスに更新を適用すると、このフォルダー内のファイルに対する変更内容が、コンピューター上のすべてのインスタンスに反映されます。 既存のインストールに機能を追加する場合、前にインストールした機能の場所は変更できません。また、新しい機能のインストール場所を指定することもできません。 セットアップで以前に設定したディレクトリに追加機能をインストールするか、製品をいったんアンインストールしてインストールし直す必要があります。

注意 注

クラスター化された構成では、クラスターのすべてのノードで使用できるローカル ドライブを選択する必要があります。

セットアップ時にサーバー コンポーネントまたはデータ ファイルのインストール パスを指定する場合、プログラム ファイルとデータ ファイルについては、指定した場所に加えてインスタンス ID も使用されます。 ツールおよびその他の共有ファイルについては、インスタンス ID は使用されません。 また、Analysis Services プログラム ファイルとデータ ファイルについてもインスタンス ID は使用されませんが、Analysis Services リポジトリについてはインスタンス ID が使用されます。

データベース エンジン機能のインストール パスを設定すると、SQL Server セットアップではそのパスがルート ディレクトリとして使用されます。このルート ディレクトリは、SQL データ ファイルを含め、そのインストールで使用するすべてのインスタンス固有フォルダーに適用されます。 この場合、ルートを "C:\Program Files\Microsoft SQL Server\MSSQL11\MSSQL\" に設定すると、このパスの後にインスタンス固有のディレクトリが付加されます。

SQL Server インストール ウィザード (セットアップ UI モード) で USESYSDB アップグレード機能の使用を選択すると、製品が再帰的フォルダー階層にインストールされることがよくあります。 たとえば、<SQLProgramFiles>\MSSQL11\MSSQL\MSSQL11\MSSQL\Data\ などです。 USESYSDB 機能を使用する場合は、データベース エンジン機能ではなく、SQL データ ファイル機能のインストール パスを設定してください。

注意 注

データ ファイルは、常に、Data という名前の子ディレクトリに格納されているものと見なされます。 たとえば、アップグレード時に、システム データベースのデータ ディレクトリのルート パスとして C:\Program Files\Microsoft SQL Server\MSSQL11\ を指定すると、C:\Program Files\Microsoft SQL Server\MSSQL11\MSSQL\Data からデータ ファイルが検出されます。

関連項目

参照

データベース エンジンの構成 - データ ディレクトリ
Analysis Services の構成 - データ ディレクトリ


SQL Server セットアップ ログ ファイルの表示と読み取り

[image]

SQL Server セットアップ ログ ファイルの表示と読み取り
関連項目 フィードバックの送信

セットアップを実行するたびにログ ファイルが、新しいタイムスタンプを持つログ フォルダーと共に %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\ に作成されます。 タイムスタンプ付きのログ フォルダーの名前形式は YYYYMMDD_hhmmss です。 セットアップを自動モードで実行した場合は、% temp%\sqlsetup*.log にログが作成されます。 ログ フォルダー内のログ ファイルはすべて、それぞれのログ フォルダー内で Log*.cab ファイルにアーカイブされます。

一般的なセットアップの要求では、次の 3 つの実行フェーズを経由します。

  1. グローバル ルールのテキスト

  2. コンポーネントの更新

  3. ユーザーが要求した操作

各フェーズでは、セットアップが詳細ログと概要ログを生成するほか、必要に応じて追加のログ ファイルも生成されます。 セットアップは、ユーザーが要求したセットアップ操作ごとに最低 3 回呼び出されます。

データストア ファイルにはセットアップ処理で記録されるすべての構成オブジェクトの状態を示すスナップショットが含まれており、構成エラーのトラブルシューティングに便利です。 実行フェーズごとに、データストア オブジェクトに対して XML ファイル ダンプが作成されます。 これらの XML ファイル ダンプは、次に示すタイムスタンプ付きのログ フォルダー内にある独自のログ サブフォルダーに保存されます。

  • Datastore_GlobalRules

  • Datastore_ComponentUpdated

  • Datastore

次のセクションでは SQL Server セットアップのログ ファイルを説明します。

概要テキスト

概要

このファイルは、セットアップ時に検出された SQL Server コンポーネント、オペレーティング システム環境、指定されているコマンド ライン パラメーター値、および実行された各 MSI/MSP の全体的な状態を示します。

ログは次の各セクションに整理されています。

  • 実行全体の要約

  • SQL Server セットアップが実行されたコンピューターのプロパティと構成

  • そのコンピューターに以前にインストールされていた SQL Server 製品の機能

  • インストールされたバージョンとインストール パッケージのプロパティ

  • インストール時に提供されたランタイム入力設定

  • 構成ファイルの場所

  • 実行結果の詳細

  • グローバル ルール

  • そのインストール シナリオ独自のルール

  • 失敗したルール

  • ルール レポート ファイルの場所

場所

場所は %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\ です。

概要テキスト ファイル内でエラーを見つけるには、"エラー" や "失敗" をキーワードにして検索できます。

Summary_engine-base_YYYYMMDD_HHMMss.txt

概要

summary_engine の基本的なファイルは概要ファイルに似ていますが、メイン ワークフロー内で生成されます。

場所

場所は %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\ です。

Summary_engine-base_YYYYMMDD_HHMMss_ComponentUpdate.txt

概要

コンポーネントの更新概要ファイルは概要ファイルに似ていますが、コンポーネント更新ワークフロー内で生成されます。

場所

場所は %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\ です。

Summary_engine-base_<VersionNumber>MMDD_HHMMss_GlobalRules.txt

概要

グローバル ルール概要ファイルは概要ファイルに似ていますが、グローバル ルール ワークフロー内で生成されます。

場所

場所は %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\ です。

Detail.txt

概要

Detail.txt はインストールやアップグレードなど、メイン ワークフロー内で生成され、実行の詳細を示します。 このファイル内のログは、インストールで各アクションが呼び出された時刻に基づいて生成され、アクションが実行された順序とその依存関係を示します。

場所

場所は %programfiles%\Microsoft SQL Server\110\Setup です。

Bootstrap\Log\<YYYYMMDD_HHMM>\Detail.txt です。

セットアップ過程でエラーが発生すると、実行やエラーはこのファイルの終わりに記録されます。 このファイル内でエラーを見つけるには、まずファイルの終わりを調べてから、「エラー」や「例外」をキーワードにして検索します。

Detail_ComponentUpdate.txt

概要

Detail_ComponentUpdate.txt ファイルはコンポーネント更新ワークフローに対して生成され、Detail.txt に似ています。

場所

場所は %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\ です。

Detail_GlobalRules.txt

概要

Detail_GlobalRules.txt ファイルはグローバル ルール実行のために生成され、Detail.txt ファイルに似ています。

場所

場所は %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\ です。

MSI ログ ファイル

概要

MSI ログ ファイルはパッケージ インストール過程の詳細を提供します。 各パッケージのインストール時に、MSIEXEC によって生成されるログ ファイルです。

MSI ログ ファイルの種類

  • <Feature>_<Architecture>_<Interation>.log

  • <Feature>_<Architecture>_<Language>_<Interation>.log

  • <Feature>_<Architecture>_<Interation>_<workflow>.log

場所

MSI ログ ファイルの場所は %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\<Name>.log です。

ファイルの終わりに実行の概要があり、成功したかどうかとプロパティを示します。 MSI ファイル内でエラーを見つけるには、"value 3" を検索します。通常エラーはその文字列の近くで見つかります。

ConfigurationFile.ini

概要

構成ファイルにはインストール時に使用される入力の設定が含まれています。 手動で設定を入力しなくてもインストールを再起動できるようにするときに使用できます。 ただし、パスワード、PID、およびパラメーターの一部は構成ファイルには保存されません。 設定はファイルに追加できますが、コマンドラインまたはセットアップのインターフェイスを使って供給することもできます。 詳細については、「構成ファイルを使用した SQL Server 2012 のインストール」(http://go.microsoft.com/fwlink/?LinkId=231296) を参照してください。

場所

場所は %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\ です。

SystemConfigurationCheck_Report.htm

概要

システム構成チェッカーのレポートには、実行された各ルールの簡単な記述と、実行ステータスが含まれています。

場所

場所は %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\ です。

関連項目

概念

SQL Server のインストールに関するトラブルシューティング


SQL Server のインストールに関するトラブルシューティング

[image]

SQL Server のインストールに関するトラブルシューティング
関連項目 フィードバックの送信

インストールおよびアップグレードの問題に関するトラブルシューティング情報を表示するには、SQL Server 2012 Readme (http://go.microsoft.com/fwlink/?LinkId=196910) を参照してください。

関連項目

概念

SQL Server セットアップ ログ ファイルの表示と読み取り


SQL Server セットアップのユーザー インターフェイス リファレンス

[image]

SQL Server セットアップのユーザー インターフェイス リファレンス
フィードバックの送信

ここでは、SQL Server インストール ウィザードのインストール オプションについて説明します。


使用許諾条件への同意

[image]

使用許諾条件への同意
関連項目 フィードバックの送信

SQL Server インストール ウィザードの [使用許諾条件への同意] ページを使用して、このリリースの SQL Server の使用許諾条件に同意します。

使用許諾契約書を印刷することも、クリップボードにコピーすることもできます。 処理を続行するには、使用許諾条件に同意し、[次へ] をクリックします。 インストールしない場合は、[キャンセル] をクリックします。

機能の使用状況レポート

機能の使用状況レポートを有効にすると、SQL Server は Microsoft に定期的にレポートを送信するように構成されます。 レポートには、ハードウェア構成に関する情報と、SQL Server およびコンポーネントがどのように使用されているかを示す情報が含められます。 Microsoft では、機能の使用状況データを SQL Server の機能強化のために使用します。 この機能によって関しされる SQL Server コンポーネントは次のとおりです。

  • データベース エンジン

  • Analysis Services

  • Reporting Services

  • Integration Services

  • レプリケーション

  • SQL Server データ ツール (SSDT)

  • SQL Server セットアップ

機能の使用に関する情報は Microsoft に送信され、アクセスが制限された場所に格納されます。

セットアップの完了後、機能の使用状況レポートを無効にするには、SQL Server の [構成ツール] メニューにある [SQL Server エラーと使用状況レポート] ツールを使用します。

インストール、アップグレード、修復などのセットアップ操作では、セットアップ プログラムの実行時にのみ情報が収集されアップロードされます。

他のすべての SQL Server コンポーネントでは、情報はすべての有効な SQL Server インスタンスで 1 日 1 回収集されます。 既定の収集時刻は、サーバーにかかる負荷を最小限に抑えるため、午前 0 時に設定されています。 収集時刻を変更する場合は、収集時刻を制御するレジストリ キーを手動で編集します。 各 SQL Server インスタンスには、次のような専用のレジストリ キーがあります。

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL11.<INSTANCEID>\CPE\TimeofReporting

このレジストリ キーの値には、収集を実行する時刻が 00:00 (午前 0 時) から何分後であるかが示されています。 たとえば、値が 60 の場合は収集が午前 1 時に実行され、1200 の場合は午後 8 時に実行されます。

関連項目

参照

SQL Server の使用許諾条件について


SQL Server フェールオーバー クラスター ノードの追加

[image]

SQL Server フェールオーバー クラスター ノードの追加
関連項目 フィードバックの送信

SQL Server セットアップによって、セットアップ操作が完了する前にコンピューターの構成が検証されます。 SQL Server セットアップの実行中、システム構成チェッカー (SCC) は SQL Server のインストール先コンピューターをスキャンします。 SCC は、SQL Server セットアップ操作の成功を妨げる条件がないかどうかを調べます。 セットアップで SQL Server インストール ウィザードが起動する前に、SCC は各項目の状態を取得します。 次に、必要な条件と取得した結果を比較し、ブロックの問題解決に関するガイダンスを提供します。

システム構成チェッカーは、実行された各ルールの簡単な記述と、実行ステータスを含むレポートを生成します。 システム構成チェッカーのレポートは %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\ に配置されます。

セットアップ操作を実行する前に、次のトピックを確認してください。

  1. SQL Server のインストールに必要なハードウェアおよびソフトウェア (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server の各エディションがサポートする機能 (http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server インストールのセキュリティに関する注意点 (http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server のローカル言語版 (http://go.microsoft.com/fwlink/?LinkId=235027)

その他の参考資料:

  1. サポートされているバージョンとエディションのアップグレード (http://go.microsoft.com/fwlink/?LinkId=235031)

  2. フェールオーバー クラスタリングをインストールする前に (http://go.microsoft.com/fwlink/?LinkId=235034)

関連項目

参照

セットアップ サポート ルール


Analysis Services の構成 - アカウントの準備

[image]

Analysis Services の構成 - アカウントの準備
関連項目 フィードバックの送信

このページを使用すると、サーバー モードを設定し、Analysis Services への無制限アクセスを必要とするユーザーまたはサービスに管理権限を付与することができます。 セットアップでは、ローカル Windows グループ BUILTIN\Administrators が、インストールするインスタンスの Analysis Services サーバー管理者ロールに自動的に追加されません。 サーバー管理者ロールにローカルの Administrators グループを追加する場合は、そのグループを明示的に指定する必要があります。

PowerPivot for SharePoint をインストールする場合は、SharePoint Server 2010 ファームでの PowerPivot サーバーの配置に責任を負う SharePoint ファーム管理者またはサービス管理者に管理権限を付与してください。 PowerPivot サービスのインストールおよびサービス アカウントの要件の詳細については、「PowerPivot for SharePoint のインストール」を参照してください。

オプション

[サーバー モード] - サーバー モードでは、サーバーに配置できる Analysis Services データベースの種類を指定します。 セットアップ中に指定したサーバー モードを後で変更することはできません。 各モードは互いに排他的です。そのため、従来の OLAP ソリューションとテーブル モデル ソリューションの両方をサポートする場合は、それぞれ異なるモードで構成した 2 つの Analysis Services のインスタンスが必要になります。

[管理者の指定] - SQL Server のインスタンスのサーバー管理者を少なくとも 1 人指定する必要があります。 指定したユーザーまたはグループは、インストールする Analysis Services インスタンスのサーバー管理者ロールのメンバーになります。 これらは、ソフトウェアをインストールするコンピューターと同じドメインの Windows ドメイン ユーザー アカウントである必要があります。

注意 注

ユーザー アカウント制御 (UAC) は Windows セキュリティ機能であり、管理操作または管理アプリケーションの承認を管理者が実行前に明示的に行う必要があります。 UAC は既定でオンになっているため、高度な特権を必要とする特定の操作について許可するよう求めるメッセージが表示されます。 UAC を構成して既定の動作を変更することも、特定のプログラム用に UAC をカスタマイズすることもできます。 UAC および UAC 構成の詳細については、「Windows ユーザー アカウント制御手順ガイド」および「ユーザー アカウント制御 (Wikipedia)」を参照してください。

関連項目

その他の技術情報

サービス アカウントとパスワードを変更する方法 (PowerPivot for SharePoint)
Analysis Services サービス アカウントの構成
Windows サービス アカウントの設定


Analysis Services の構成 - データ ディレクトリ

[image]

Analysis Services の構成 - データ ディレクトリ
関連項目 フィードバックの送信

次の表にある既定のディレクトリは、SQL Server のセットアップ中にユーザーが構成できます。 これらのファイルにアクセスする権限は、ローカル管理者と、セットアップ中に作成されて準備される SQLServerMSASUser$<instance> セキュリティ グループのメンバーに付与されます。

説明

既定のディレクトリ

推奨事項

データ ルート ディレクトリ

C:\Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Data\

\Program files\Microsoft SQL Server\ フォルダーが権限の制限により保護されていることを確認してください。 Analysis Services のパフォーマンスは、多くの構成で、データ ディレクトリが配置されているストレージのパフォーマンスに依存します。 このディレクトリは、システムに割り当てられている中でパフォーマンスが最も高いストレージに配置してください。 フェールオーバー クラスターのインストールの場合は、データ ディレクトリが共有ディスク上に配置されるようにしてください。

ログ ファイル ディレクトリ

C:\Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Log\

このディレクトリは Analysis Services ログ ファイルのディレクトリであり、FlightRecorder ログを含んでいます。 フライト レコーダーの時間を増加する場合、ログ ディレクトリに十分な容量があることを確認してください。

Temp ディレクトリ

C:\Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Temp\

Temp ディレクトリは、高パフォーマンスのストレージ サブシステムに配置してください。

バックアップ ディレクトリ

C:\Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Backup\

このディレクトリは、Analysis Services の既定のバックアップ ファイルのディレクトリです。 PowerPivot for SharePoint のインストールでは、ここは PowerPivot System サービスが PowerPivot データ ファイルをキャッシュする場所でもあります。

データの損失を防ぐために適切な権限を設定し、バックアップ ディレクトリに書き込むための適切な権限が Analysis Services サービスのユーザー グループに付与されるようにしてください。 マップされたドライブをバックアップ ディレクトリに使用することはサポートされていません。

注

  • SharePoint ファームに配置された Analysis Services インスタンスは、アプリケーション ファイル、データ ファイル、およびコンテンツ データベースのプロパティとサービス アプリケーション データベースのプロパティを格納します。

  • 既存のインストールに機能を追加する場合、前にインストールした機能の場所は変更できません。また、新しい機能のインストール場所を指定することもできません。

  • 既定以外のインストール ディレクトリを指定する場合は、インストール フォルダーがこの SQL Server インスタンスに対して一意であることを確認します。 このダイアログ ボックスのディレクトリは、SQL Server の他のインスタンスのディレクトリと共有できません。 SQL Server のインスタンス内の データベース エンジン コンポーネントと Analysis Services コンポーネントは、別のディレクトリにインストールする必要もあります。

  • 次の状況では、プログラム ファイルとデータ ファイルをインストールすることができません。

    • リムーバブル ディスク ドライブ

    • 圧縮を使用したファイル システム

    • システム ファイルが配置されているディレクトリ

    • フェールオーバー クラスター インスタンスの共有ドライブ

関連項目

概念

SQL Server の既定のインスタンスおよび名前付きインスタンスのファイルの場所


クラスター ディスクの選択

[image]

クラスター ディスクの選択
フィードバックの送信

SQL Server フェールオーバー クラスターの共有クラスター ディスク リソースを選択するには、SQL Server インストール ウィザードの [クラスター ディスクの選択] ページを使用します。 クラスター ディスクは、SQL Server データが配置される場所です。

共有クラスター ディスクは、SQL Server データベース エンジンのクラスター インストールには必須ではありません。 SMB ファイル サーバーは、SQL Server データベース エンジンのフェールオーバー クラスター インストールでサポートされているストレージであり、インストールを完了する前に [データベース エンジン - データ ディレクトリ] を使用して指定できます。

注記 注意

Analysis Services のインストールを選択した場合は、共有クラスター ディスクを指定する必要があります。

SQL Server のフェールオーバー クラスター インスタンスで FILESTREAM を有効にする場合は、共有クラスター ディスクを指定する必要があります。

オプション

[共有ディスク]

単一のディスクを一覧から選択します。 クラスター ディスクは、SQL Server データが配置される場所です。

1 つのディスクのみを指定できます。 クラスター クォーラム リソースを含んでいるグループを選択すると、警告が表示されます。 クラスター クォーラム リソースにインストールすることはお勧めしません。

[使用可能な共有ディスク]

使用可能なディスクの一覧、各ディスクが共有ディスクに適しているかどうか、および各ディスク リソースの説明が表示されます。


クラスター ネットワークの構成

[image]

クラスター ネットワークの構成
フィードバックの送信

フェールオーバー クラスター インスタンスのネットワーク リソースを指定するには、[クラスター ネットワークの選択] ページを使用します。

オプション

[SQL Server フェールオーバー クラスターのネットワーク名] - ネットワーク上でフェールオーバー クラスター インスタンスを識別するために使用される名前です。

[ネットワーク設定] - フェールオーバー クラスター インスタンスの IP の種類と IP アドレスを指定します。

ノードの追加またはノードの削除を実行すると、その操作が進行している間、SQL Server フェールオーバー クラスターの既存の IP アドレスを示した読み取り専用の一覧が SQL Server によって表示されます。

  • 統合インストール:

    • 追加しようとしているノードが、SQL Server フェールオーバー クラスターの既存のノードとまったく同じ一連のネットワーク サブネットをサポートする場合、他の IP アドレスは追加できません。 依存関係の設定は変更されません。

    • 追加しようとしているノードが、SQL Server フェールオーバー クラスターの既存のノードがサポートしているサブネットの一部のみをサポートする場合、他の IP アドレス リソースは追加できません。指定された IP アドレスが一部のクラスター ノードでは無効であるという事実を反映するために、IP アドレス リソースの依存関係は [OR] に設定されます。

    • 追加しようとしているノードが、SQL Server フェールオーバー クラスターの既存のノードによって既にサポートされている以外のサブネットもサポートする場合、新しい有効な IP アドレスを追加することを選択できます。 新しい IP アドレスが指定された場合、指定された IP アドレスが一部のクラスター ノードでは無効であるという事実を反映するために、IP アドレス リソースの依存関係は [OR] に設定されます。

    • 追加しようとしているノードが、他のネットワーク サブネットをサポートしている場合で、なおかつ、SQL Server フェールオーバー クラスターの既存のノードによってサポートされたサブネットは一切サポートしないという場合、別途 IP アドレスを追加する必要があります。 指定された IP アドレスが一部のクラスター ノードでは無効であるという事実を反映するために、IP アドレス リソースの依存関係は [OR] に設定されます。

  • 詳細設定インストール: インストールの完了手順で、フェールオーバー クラスター インスタンスのすべてのノードおよびサブネットについて、対応する IP アドレスを指定します。 マルチサブネット フェールオーバー クラスターの場合は複数の IP アドレスを指定できますが、サポートされる IP アドレスは、1 つのサブネットにつき 1 つだけです。 準備の対象となるすべてのノードは、少なくとも 1 つの IP アドレスを所有している必要があります。 SQL Server フェールオーバー クラスター内に複数のサブネットが存在する場合、IP アドレス リソースの依存関係を [OR] に設定するように求められます。ノードの削除:

    • 残りの IP アドレスが、残りのすべてのノードでサポートされている場合は、IP アドレス リソースの依存関係を [AND] に設定するように求められます。

    • 残りの IP アドレスが、残りのすべてのノードでサポートされていない場合は、IP アドレス リソースの依存関係は [OR] のままとなります。


クラスター ノードの構成

[image]

クラスター ノードの構成
フィードバックの送信

フェールオーバー クラスター インスタンスにノードを追加したりノードを削除したりするには、[クラスター ノードの構成] ページを使用します。SQL Server フェールオーバー クラスターをインストールまたはアップグレードするには、フェールオーバー クラスターの各ノードでセットアップ プログラムを実行する必要があります。 既存の SQL Server フェールオーバー クラスターにノードを追加するには、SQL Server フェールオーバー クラスター インスタンスに追加するノードで SQL Server セットアップを実行する必要があります。

オプション

[SQL Server インスタンス名] - ドロップダウン リスト ボックスを使用して、変更する SQL Server フェールオーバー クラスター インスタンスを選択します。

[このノードの名前] - このフィールドには、SQL Server セットアップを実行しているコンピューターの名前が代入されます。 このコンピューターが、SQL Server フェールオーバー クラスター インスタンスで追加または削除されるフェールオーバー クラスター ノードです。


クラスター ノードの構成 (完了)

[image]

クラスター ノードの構成 (完了)
フィードバックの送信

[クラスター ノードの構成] (完了) ページを使用して、クラスター化用に準備されている既存の SQL Server インスタンスを指定します。SQL Server フェールオーバー クラスターをインストールまたはアップグレードするには、フェールオーバー クラスターの各ノードでセットアップ プログラムを実行する必要があります。 既存の SQL Server フェールオーバー クラスターにノードを追加するには、SQL Server フェールオーバー クラスター インスタンスに追加するノードで SQL Server セットアップを実行する必要があります。

オプション

ドロップダウン ボックスから、次の項目を選択します。

  • [SQL Server インスタンス名] - SQL Server フェールオーバー クラスターのインスタンス名を選択します。

  • [このノードの名前] - このフィールドには、SQL Server セットアップ プログラムが実行されているコンピューターの名前があらかじめ設定されます。

  • [SQL Server フェールオーバー クラスターのネットワーク名] - このフィールドには、値があらかじめ設定されていません。 新しい SQL Server フェールオーバー クラスター インスタンスのネットワーク名を指定します。 これは、ネットワーク上のフェールオーバー クラスター インスタンスを識別する名前です。


クラスター リソース グループ

[image]

クラスター リソース グループ
関連項目 フィードバックの送信

[クラスター リソース グループ] ページを使用して、SQL Server 仮想サーバー リソースが配置されるディスクを指定します。

オプション

SQL Server クラスター リソース グループ名を指定します。 次の 2 つの方法があります。

  • ドロップダウン リストを使用して、使用する既存のグループを指定します。

  • 作成する新しいグループの名前を入力します。 "使用可能記憶域" という名前はグループ名として有効ではないことに注意してください。

関連項目

その他の技術情報

新しい SQL Server フェールオーバー クラスターを作成する方法


クラスターのセキュリティ ポリシー

[image]

クラスターのセキュリティ ポリシー
フィードバックの送信

フェールオーバー クラスター インスタンスのセキュリティ ポリシーを構成するには、[クラスターのセキュリティ ポリシー] ページを使用します。

オプション

クラスター化されるサービスのグローバルまたはローカルのドメイン グループを指定します。 すべてのリソースの権限は、SQL Server サービス アカウントがグループ メンバーとして含まれる、ドメイン レベルのグループによって制御されます。 Windows Server 2008 のサービス セキュリティ ID (SID) 機能の詳細については、「Windows サービス アカウントの設定」を参照してください。

Windows 2000 混合モード ドメインに Microsoft SQL Server 2012 フェールオーバー クラスター インスタンスをインストールする場合、SQL Server クラスター化サービスのドメイン グローバル グループを使用する必要があります。

注意 注

Windows 2000 ドメイン コントローラーは、混合モードとネイティブ モードで動作できます。 混合モードの場合は、同じドメインの下位のドメイン コントローラーを使用できます。


[完了 - イメージの完了]

[image]

[完了 - イメージの完了]
フィードバックの送信

[完了 - イメージの完了] ページを使用して、準備済みインスタンスの構成が完了したことを確認します。

オプション

このダイアログ ボックスには、この操作のセットアップ ログ ファイルへのリンクが含まれています。 インストールを完了するには、[閉じる] をクリックします。


[イメージの完了の進行状況]

[image]

[イメージの完了の進行状況]
関連項目 フィードバックの送信

SQL Server イメージの完了のセットアップ状況を監視するには、SQL Server インストール ウィザードの [イメージの完了の進行状況] ページを使用します。 このステップの完了時には、構成が済んで完了済みの各 SQL Server 機能のステータスがこのページに一覧表示されます。

関連項目

概念

SQL Server セットアップ ログ ファイルの表示と読み取り


イメージの完了ルール

[image]

イメージの完了ルール
フィードバックの送信

SQL Server セットアップによって、セットアップ操作が完了する前にコンピューターの構成が検証されます。 SQL Server セットアップの実行中、システム構成チェッカー (SCC) は SQL Server のインストール先コンピューターをスキャンします。 SCC は、SQL Server セットアップ操作の成功を妨げる条件がないかどうかを調べます。 セットアップで SQL Server インストール ウィザードが起動する前に、SCC は各項目の状態を取得します。 次に、必要な条件と取得した結果を比較し、ブロックの問題解決に関するガイダンスを提供します。

システム構成チェッカーは、実行された各ルールの簡単な記述と、実行ステータスを含むレポートを生成します。 システム構成チェッカーのレポートは %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\ に配置されます。

セットアップ操作を実行する前に、次のトピックを確認してください。

  1. SQL Server のインストールに必要なハードウェアおよびソフトウェア (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server の各エディションがサポートする機能 (http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server インストールのセキュリティに関する注意点 (http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server のローカル言語版 (http://go.microsoft.com/fwlink/?LinkId=235027)

その他の参考資料:

  1. サポートされているバージョンとエディションのアップグレード (http://go.microsoft.com/fwlink/?LinkId=235031)

  2. フェールオーバー クラスタリングをインストールする前に (http://go.microsoft.com/fwlink/?LinkId=235034)


[完了 - イメージの準備]

[image]

[完了 - イメージの準備]
フィードバックの送信

[完了 - イメージの準備] ページを使用して、イメージの準備が完了したことを確認します。

オプション

このダイアログ ボックスには、この操作のセットアップ ログ ファイルへのリンクが含まれています。 イメージの準備を完了するには、[閉じる] をクリックします。


[完了 - 修復]

[image]

[完了 - 修復]
フィードバックの送信

[完了 - 修復] ページを使用して、修復が完了したことを確認します。

オプション

このダイアログ ボックスには、この操作のセットアップ ログ ファイルへのリンクが含まれています。 続行するには、[閉じる] をクリックします。


完了 - アップグレード

[image]

完了 - アップグレード
フィードバックの送信

[完了] (アップグレード) ページを使用して、アップグレードが完了したことを確認します。

オプション

このダイアログ ボックスには、この操作のセットアップ ログ ファイルへのリンクが含まれています。 続行するには、[閉じる] をクリックします。


データベース エンジンの構成 - アカウントの準備

[image]

データベース エンジンの構成 - アカウントの準備
関連項目 フィードバックの送信

このページは、SQL Server セキュリティ モードを設定し、Windows ユーザーまたはグループを SQL Server データベース エンジン の管理者として追加するために使用します。

Windows Vista、Windows 7、Windows Server 2008 で SQL Server 2012 を実行する場合の考慮事項

以前のバージョンの SQL Server では、データベース エンジンのログインとして BUILTIN\Administrators グループが準備され、ローカル Administrators グループのメンバーは、管理者資格情報を使用してログインできました。 しかし、引き上げられたアクセス許可を使用するのはベスト プラクティスではありません。 Microsoft SQL Server 2012 では、BUILTIN\Administrators グループはログインとして準備されていません。 したがって、Microsoft SQL Server 2012 の新しいインスタンスのインストール時に、管理ユーザーごとに SQL Server ログインを作成し、そのログインを sysadmin 固定サーバー ロールに追加する必要があります。 また、SQL Server エージェント ジョブの実行に使用する Windows アカウントに対しても、同様の操作を行う必要があります。 それらのジョブには、レプリケーション エージェント ジョブも含まれます。

オプション

[セキュリティ モード]: インストール用に Windows 認証または混合モード認証を選択します。

[Windows プリンシパルの準備] : 以前のバージョンの SQL Server では、Windows の Builtin\Administrator ローカル グループが SQL Server sysadmin サーバー ロールに配置されました。これは、Windows 管理者に SQL Server インスタンスへのアクセス許可を付与する効果的な方法でした。 Microsoft SQL Server 2012 では、sysadmin サーバー ロールに Builtin\Administrator グループは用意されません。 代わりに、セットアップ時に新規インストール用の SQL Server 管理者を明示的に用意する必要があります。

重要な注意事項 重要

セットアップ時に新規インストール用の SQL Server 管理者を明示的に用意する必要があります。 セットアップは、この手順を完了するまで続行できません。

[SQL Server 管理者の指定] : SQL Server のインスタンスの Windows プリンシパルを少なくとも 1 つ指定する必要があります。 SQL Server セットアップを実行しているアカウントを追加するには、[現在のユーザー] ボタンをクリックします。 システム管理者の一覧に対してアカウントを追加または削除するには、[追加] または [削除] をクリックし、SQL Server のインスタンスについて管理者権限を持っているユーザー、グループ、またはコンピューターの一覧を編集します。

一覧の編集が完了したら、[OK] をクリックし、構成ダイアログ ボックスで管理者の一覧を確認します。 一覧が完成したら、[次へ] をクリックします。

混合モード認証を選択した場合は、組み込みの SQL Server システム管理者 (SA) アカウントのログオン資格情報を入力する必要があります。

セキュリティに関する注意 セキュリティに関する注意

空白のパスワードは使用しないでください。強力なパスワードを使用してください。

Windows 認証モード

Windows ユーザー アカウントでユーザーが接続すると、SQL Server はオペレーティング システムの Windows プリンシパル トークンを使用してアカウント名とパスワードを検証します。 これは既定の認証モードで、混合モードよりはるかに安全性に優れています。 Windows 認証では、Kerberos セキュリティ プロトコルを利用し、強力なパスワードに対して複雑な検証を行うという点で、パスワード ポリシーが強化されています。また、アカウント ロックアウトの機能を提供し、パスワード有効期限にも対応しています。

セキュリティに関する注意 セキュリティに関する注意

可能な場合は、Windows 認証を使用します。

重要な注意事項 重要

空白のパスワードは使用しないでください。強力なパスワードを使用してください。sa パスワードを空白のままにしないでください。また、推測しやすいパスワードを設定しないでください。

混合モード (Windows 認証と SQL Server 認証)

Windows 認証または SQL Server 認証を使用してユーザー接続を許可します。 Windows ユーザー アカウントで接続するユーザーは、Windows によって検証される信頼関係接続を使用することができます。

混合モード認証を選択する必要があり、レガシ アプリケーションに対応するために SQL ログインを使用する必要もある場合は、必ずすべての SQL Server アカウントに強力なパスワードを設定してください。

注意 注

SQL Server 認証は旧バージョンとの互換性を維持するためだけに提供されます。 可能な場合は、Windows 認証を使用します。

パスワードの入力

システム管理者 (sa) ログインを入力および確認します。 パスワードは侵入者に対する防御の最前線であるため、システムのセキュリティにとって強力なパスワードを設定することは不可欠です。 sa パスワードを空白のままにしないでください。また、推測しやすいパスワードを設定しないでください。

注意 注

SQL Server パスワードは、文字、記号、数字の組み合わせを含む 1 ～ 128 文字で指定できます。 混合モード認証を選択する場合、インストール ウィザードの次のページに進む前に、強力な sa パスワードを入力する必要があります。

強力なパスワードのガイドライン

強力なパスワードとは、他人によってたやすく推測されず、コンピューター プログラムを使用して簡単にはハッキングされないパスワードです。 強力なパスワードでは、次のような禁止された条件または用語を使用することはできません。

  • 空白または NULL 条件

  • "Password"

  • "Admin"

  • "Administrator"

  • "sa"

  • "sysadmin"

強力なパスワードには、インストール コンピューターに関連付けられた次のような用語を指定できません。

  • 現在、マシンにログオンしているユーザーの名前

  • コンピューター名

強力なパスワードは、長さ 9 文字以上で、以下の 4 つの条件のうち 3 つ以上を満たしている必要があります。

  • 大文字を含んでいる。

  • 小文字を含んでいる。

  • 数字を含んでいる。

  • #、%、^ など、英数字以外の文字を含んでいる。

このページで入力するパスワードは、強力なパスワード ポリシーの要件を満たす必要があります。 SQL Server 認証を使用したオートメーションを使用している場合、必ず強力なパスワード ポリシーの要件を満たすパスワードを指定してください。

関連コンテンツ

Windows 認証と SQL Server 認証のどちらを選択するかについて詳しくは、SQL Server オンライン ブックの「認証モードの選択」を参照してください。

SQL Server データベース エンジンを実行するアカウントの選択の詳細については、SQL Server オンライン ブックの「Windows サービス アカウントと権限の構成」を参照してください。

関連項目

参照

Windows サービス アカウントと権限の構成


データベース エンジンの構成 - データ ディレクトリ

[image]

データベース エンジンの構成 - データ ディレクトリ
関連項目 フィードバックの送信

このページを使用して、SQL Server データベース エンジン プログラムおよびデータ ファイルのインストール場所を指定します。 インストールの種類により、サポートされるストレージにはローカル ディスク、共有ストレージ、または SMB ファイル サーバーが含まれる場合があります。

SMB ファイル共有をディレクトリとして指定するには、サポートされている UNC パスを手動で入力する必要があります。 SMB ファイル共有を参照して指定することはできません。 サポートされている SMB ファイル共有の UNC パス形式は、"\\Servername\ShareName\..." です。

SQL Server のスタンドアロン インスタンス

次の表は、サポートされているストレージの種類と、SQL Server のスタンドアロン インスタンスで使用される既定のディレクトリの一覧です。これらのディレクトリは、SQL Server のセットアップ中にユーザーが構成できます。

説明 | サポートされているストレージの種類 | 既定のディレクトリ | 推奨事項
データ ルート ディレクトリ | ローカル ディスク、SMB ファイル サーバー、共有ストレージ 1 | C:\Program Files\Microsoft SQL Server\ | SQL Server セットアップにより、SQL Server ディレクトリの ACL が構成され、構成の一部として継承が無効になります。
ユーザー データベース ディレクトリ | ローカル ディスク、SMB ファイル サーバー、共有ストレージ 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data | ユーザー データ ディレクトリのベスト プラクティスは、ワークロードとパフォーマンスの要件によって異なります。
ユーザー データベース ログ ディレクトリ | ローカル ディスク、SMB ファイル サーバー、共有ストレージ 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data | ログ ディレクトリに十分な領域があることを確認してください。
一時データベース ディレクトリ | ローカル ディスク、SMB ファイル サーバー、共有ストレージ 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data | Temp ディレクトリのベスト プラクティスは、ワークロードとパフォーマンスの要件によって異なります。
一時データベース ログ ディレクトリ | ローカル ディスク、SMB ファイル サーバー、共有ストレージ 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data | ログ ディレクトリに十分な領域があることを確認してください。
バックアップ ディレクトリ | ローカル ディスク、SMB ファイル サーバー、共有ストレージ 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Backup | データの損失を防ぐために適切な権限を設定して、バックアップ ディレクトリに書き込むための適切な権限が SQL Server サービスのユーザー アカウントにあることを確認してください。 マップされたドライブをバックアップ ディレクトリに使用することはサポートされていません。

1 共有ディスクがサポートされていますが、これは SQL Server のスタンドアロン インスタンスで推奨される方法ではありません。

SQL Server のフェールオーバー クラスター インスタンス

次の表は、サポートされているストレージの種類と、SQL Server のフェールオーバー クラスター インスタンスで使用される既定のディレクトリの一覧です。これらのディレクトリは、SQL Server のセットアップ中にユーザーが構成できます。

説明

サポートされているストレージの種類

既定のディレクトリ

推奨事項

データ ルート ディレクトリ

共有ストレージ、SMB ファイル サーバー

<Drive:>\Program Files\Microsoft SQL Server\

ヒント ヒント

[クラスター ディスクの選択] ページで共有ディスクを選択した場合、既定値は最初の共有ディスクになります。 [クラスター ディスクの選択] ページで何も選択しなかった場合、このフィールドの既定値は空白になります。

SQL Server セットアップにより、SQL Server ディレクトリの ACL が構成され、構成の一部として継承が無効になります。

ユーザー データベース ディレクトリ

共有ストレージ、SMB ファイル サーバー

<Drive:>\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data

ヒント ヒント

[クラスター ディスクの選択] ページで共有ディスクを選択した場合、既定値は最初の共有ディスクになります。 [クラスター ディスクの選択] ページで何も選択しなかった場合、このフィールドの既定値は空白になります。

ユーザー データ ディレクトリのベスト プラクティスは、ワークロードとパフォーマンスの要件によって異なります。

ユーザー データベース ログ ディレクトリ

共有ストレージ、SMB ファイル サーバー

<Drive:>\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data

ヒント ヒント

[クラスター ディスクの選択] ページで共有ディスクを選択した場合、既定値は最初の共有ディスクになります。 [クラスター ディスクの選択] ページで何も選択しなかった場合、このフィールドの既定値は空白になります。

ログ ディレクトリに十分な領域があることを確認してください。

一時データベース ディレクトリ

ローカル ディスク、共有ストレージ、SMB ファイル サーバー

<Drive:>\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data

ヒント ヒント

[クラスター ディスクの選択] ページで共有ディスクを選択した場合、既定値は最初の共有ディスクになります。 [クラスター ディスクの選択] ページで何も選択しなかった場合、このフィールドの既定値は空白になります。

指定したディレクトリがすべてのクラスター ノードで有効であることを確認してください。 フェールオーバー中に、tempdb のディレクトリがフェールオーバーのターゲット ノード上で利用できない場合、SQL Server リソースはオンラインへの移行に失敗します。

一時データベース ログ ディレクトリ

ローカル ディスク、共有ストレージ、SMB ファイル サーバー

<Drive:>\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data

ヒント ヒント

[クラスター ディスクの選択] ページで共有ディスクを選択した場合、既定値は最初の共有ディスクになります。 [クラスター ディスクの選択] ページで何も選択しなかった場合、このフィールドの既定値は空白になります。

指定したディレクトリがすべてのクラスター ノードで有効であることを確認してください。 フェールオーバー中に、tempdb のディレクトリがフェールオーバーのターゲット ノード上で利用できない場合、SQL Server リソースはオンラインへの移行に失敗します。

バックアップ ディレクトリ

ローカル ディスク、共有ストレージ、SMB ファイル サーバー

<Drive:>\Program Files\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Backup

ヒント ヒント

[クラスター ディスクの選択] ページで共有ディスクを選択した場合、既定値は最初の共有ディスクになります。 [クラスター ディスクの選択] ページで何も選択しなかった場合、このフィールドの既定値は空白になります。

データの損失を防ぐために適切な権限を設定して、バックアップ ディレクトリに書き込むための適切な権限が SQL Server サービスのユーザー アカウントにあることを確認してください。 マップされたドライブをバックアップ ディレクトリに使用することはサポートされていません。

セキュリティに関する注意点

セットアップにより、SQL Server ディレクトリの ACL が構成され、構成の一部として継承が無効になります。

次の推奨事項は SMB ファイル サーバーに当てはまります。

  • SMB ファイル サーバーを使用する場合、SQL Server サービス アカウントはドメイン アカウントである必要があります。

  • SQL Server のインストールに使用するアカウントには、データ ディレクトリとして使用する SMB ファイル共有フォルダーに対するフル コントロールの NTFS 権限が必要です。

  • SQL Server のインストールに使用するアカウントには、SMB ファイル サーバーに対する SeSecurityPrivilege 特権を付与する必要があります。 この特権を付与するには、ファイル サーバーで [ローカル セキュリティ ポリシー] コンソールを使用して [監査とセキュリティ ログの管理] ポリシーに SQL Server セットアップ アカウントを追加します。 この設定は、[ローカル セキュリティ ポリシー] コンソールの [ローカル ポリシー] にある [ユーザー権利の割り当て] セクションで行うことができます。

注

  • 既存のインストールに機能を追加する場合、前にインストールした機能の場所は変更できません。また、新しい機能のインストール場所を指定することもできません。

  • 既定以外のインストール ディレクトリを指定する場合は、インストール フォルダーがこの SQL Server インスタンスに対して一意であることを確認します。 このダイアログ ボックスのディレクトリは、SQL Server の他のインスタンスのディレクトリと共有できません。 SQL Server のインスタンス内の データベース エンジン コンポーネントと Analysis Services コンポーネントは、別のディレクトリにインストールする必要もあります。

  • 次の状況では、プログラム ファイルとデータ ファイルをインストールすることができません。

    • リムーバブル ディスク ドライブ

    • 圧縮を使用したファイル システム

    • システム ファイルが配置されているディレクトリ

    • フェールオーバー クラスター インスタンス上のマップされたネットワーク ドライブ

関連項目

概念

SQL Server の既定のインスタンスおよび名前付きインスタンスのファイルの場所

その他の技術情報

ファイル サーバーの共有アクセス許可と NTFS アクセス許可


データベース エンジンの構成 - Filestream

[image]

データベース エンジンの構成 - Filestream
関連項目 フィードバックの送信

このページを使用すると、このインストールの Microsoft SQL Server 2012 に対して FILESTREAM を有効にすることができます。FILESTREAM は、varbinary(max) BLOB (バイナリ ラージ オブジェクト) データをファイル システム上のファイルとして格納することにより、SQL Server データベース エンジンと NTFS ファイル システムを統合します。 Transact-SQL ステートメントでは、FILESTREAM データの挿入、更新、クエリ、検索、およびバックアップを行うことができます。 Win32 ファイル システム インターフェイスによるデータへのストリーミング アクセスが可能になります。

[Transact-SQL アクセスに対して FILESTREAM を有効にする]

Transact-SQL アクセスに対して FILESTREAM を有効にする場合にオンにします。 他のコントロール オプションを使用できるようにするには、先にこのコントロールをオンにする必要があります。

[ファイル I/O ストリーム アクセスに対して FILESTREAM を有効にする]

FILESTREAM の Win32 ストリーム アクセスを有効にする場合にオンにします。

[Windows 共有名]

このコントロールは、FILESTREAM データを格納する Windows 共有の名前を入力する場合に使用します。

[リモート クライアントに FILESTREAM データへのストリーム アクセスを許可する]

このコントロールは、リモート クライアントにこのサーバー上のこの FILESTREAM データへのアクセスを許可する場合にオンにします。

関連項目

参照

sp_configure (Transact-SQL)

概念

FILESTREAM の有効化と構成


データベース エンジンの構成 - ユーザー インスタンス

[image]

データベース エンジンの構成 - ユーザー インスタンス
フィードバックの送信

[ユーザー インスタンス] ページを使用して、管理者権限のないユーザー用に、データベース エンジンの個別インスタンスを作成し、それらのユーザーを管理者ロールに追加します。

オプション

[ユーザー インスタンスを有効にする]

既定値はオンです。 ユーザー インスタンス有効化の機能を無効にするには、このチェック ボックスをオフにします。

ユーザー インスタンスは子インスタンスまたはクライアント インスタンスとも呼ばれ、ユーザーに代わって親インスタンス (SQLExpress などのサービスを実行するプライマリ インスタンス) によって作成される SQL Server のインスタンスです。 ユーザー インスタンスは、そのユーザーのセキュリティ コンテキストでのユーザーのプロセスとして実行します。 親インスタンスやコンピューター上で実行するその他のユーザー インスタンスとは分離されます。 ユーザー インスタンス機能は "通常のユーザーとして実行" (Run As Normal User : RANU) とも呼ばれます。

注意 注

セットアップ中に sysadmin 固定サーバー ロールのメンバーとして準備されたログインは、テンプレート データベース内の管理者として準備されます。 削除されない限り、これらはユーザー インスタンスのメンバー sysadmin 固定サーバー ロールです。

[ユーザーを SQL Server 管理者ロールに追加する]

既定値はオフです。 現在のセットアップ ユーザーを SQL Server 管理者ロールに追加するには、このチェック ボックスをオンにします。

BUILTIN\Administrators のメンバーである Windows Vista ユーザーは、SQL Server Express への接続時に sysadmin 固定サーバー ロールに自動的に追加されません。 サーバーレベルの管理者ロールに明示的に追加されている Windows Vista ユーザーのみが、SQL Server Express を管理できます。 Built-In\Users グループのすべてのメンバーが SQL Server Express インスタンスに接続できますが、データベース タスクの実行権限は制限されます。 このため、SQL Server Express 特権を以前のリリースの Windows の BUILTIN\Administrators および Built-In\Users から継承しているユーザーには、Windows Vista で実行している SQL Server Express のインスタンスにおいて、管理特権を明示的に付与する必要があります。

このインストール プログラムの完了後にユーザー ロールに変更を加えるには、SQL Server 2005 セキュリティ構成ツール (SQLSAC.exe) を使用します。 SQL Server システム管理者ロールのユーザー一覧を更新するには、[新しい管理者の追加] リンクをクリックします。

[準備するユーザー] フィールドに、権限を更新するユーザーが DomainName\UserName 形式で表示されることを確認します。 [使用できる特権] ペインの SQL Server インスタンスの一覧から、更新するロールを選択して、右矢印をクリックします。 SQL Server の使用可能なすべてのインスタンスの、使用できるすべてのロールにユーザーを追加するには、二重右矢印をクリックします。

選択の完了後に変更を適用するには、[OK] をクリックします。 変更を適用せずにツールを終了するには、[キャンセル] をクリックします。


必要なディスク領域

[image]

必要なディスク領域
関連項目 フィードバックの送信

[ディスク コストの概要] ページを使用して、インストール対象として選択した SQL Server の機能に必要なディスク領域を調べます。

オプション

必要なディスク領域が大きすぎる場合は、次の方法を検討してください。

  • インストール ディレクトリを、ディスク領域の大きいディスクに変更します。

  • インストールする SQL Server の機能を変更します。

  • 他のファイルやアプリケーションを移動して、指定したドライブ上の空き領域を増やします。

関連項目

その他の技術情報

SQL Server 2008 R2 のインストールに必要なハードウェアおよびソフトウェア


Distributed Replay Controller の構成

[image]

Distributed Replay Controller の構成
フィードバックの送信

SQL Server インストール ウィザードの [Distributed Replay Controller の構成] ページを使用して、Distributed Replay Controller サービスに対する管理権限を付与するユーザーを指定します。

管理権限を持つユーザーには、Distributed Replay Controller サービスへの無制限のアクセス許可が与えられます。

オプション

[現在のユーザーの追加]

Distributed Replay Controller サービスに対するアクセス許可を付与するユーザーを追加するには、このボタンをクリックします。

[追加]

Distributed Replay Controller サービスのアクセス許可を追加するには、このボタンをクリックします。

[削除]

Distributed Replay Controller サービスからアクセス許可を削除するには、このボタンをクリックします。


Distributed Replay Client の構成

[image]

Distributed Replay Client の構成
フィードバックの送信

SQL Server インストール ウィザードの [Distributed Replay Client の構成] ページを使用して、Distributed Replay Client サービスに対する管理権限を付与するユーザーを指定します。

管理権限を持つユーザーには、Distributed Replay Client サービスへの無制限のアクセス許可が与えられます。

オプション

[コントローラー名]

これは省略可能なパラメーターで、既定値は <空白> です。

Distributed Replay Client サービスと通信するクライアント コンピューターであるコントローラーの名前を入力します。 次のことを考慮してください。

  • 名前は完全修飾ドメイン名 (FQDN) である必要があります。 たとえば、Microsoft の製品階層の server1 というホストに、server1.products.microsoft.com という FQDN を設定できます。

  • コントローラーを既にセットアップしてある場合は、各クライアントを構成するときにコントローラーの名前を入力します。

  • コントローラーをまだセットアップしていない場合は、コントローラー名を空白にしておくことができます。 ただし、コントローラー名をクライアント構成ファイルに手動で入力する必要があります。

[作業ディレクトリ]

Distributed Replay Client サービス用の作業ディレクトリを指定します。

既定の作業ディレクトリは <drive letter>:\Program Files\Microsoft SQL Server\DReplayClient\WorkingDir\ です。

[結果ディレクトリ]

Distributed Replay Client サービス用の結果ディレクトリを指定します。

既定の結果ディレクトリは <drive letter>:\Program Files\Microsoft SQL Server\DReplayClient\ResultDir\ です。


エディションのアップグレード規則

[image]

エディションのアップグレード規則
関連項目 フィードバックの送信

SQL Server セットアップによって、セットアップ操作が完了する前にコンピューターの構成が検証されます。 SQL Server セットアップの実行中、システム構成チェッカー (SCC) は SQL Server のインストール先コンピューターをスキャンします。 SCC は、SQL Server セットアップ操作の成功を妨げる条件がないかどうかを調べます。 セットアップでエディションのアップグレードが起動する前に、SCC は各項目の状態を取得します。 次に、必要な条件と取得した結果を比較し、ブロックの問題解決に関するガイダンスを提供します。

システム構成チェッカーは、実行された各ルールの簡単な記述と、実行ステータスを含むレポートを生成します。 システム構成チェッカーのレポートは %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\ に配置されます。

セットアップ操作を実行する前に、次のトピックを確認してください。

  1. SQL Server のインストールに必要なハードウェアおよびソフトウェア (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server の各エディションがサポートする機能 (http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server インストールのセキュリティに関する注意点 (http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server のローカル言語版 (http://go.microsoft.com/fwlink/?LinkId=235027)

その他の参考資料:

  1. サポートされているバージョンとエディションのアップグレード (http://go.microsoft.com/fwlink/?LinkId=235031)

  2. フェールオーバー クラスタリングをインストールする前に (http://go.microsoft.com/fwlink/?LinkId=235034)

関連項目

参照

セットアップ サポート ルール


エラー報告

[image]

エラー報告
フィードバックの送信

SQL Server に関する機能のエラーと使用状況のレポート機能を有効にするには、SQL Server インストール ウィザードの [エラーと使用状況レポートの設定] ページを使用します。

オプション

Microsoft SQL Server 2012 の既定では、機能の使用状況データ収集およびエラー レポート機能は、SQL Server とそのコンポーネントで無効になっています。

[エラー報告]

エラー レポート機能を有効にすると、SQL Server は次の SQL Server コンポーネントに重大なエラーが発生した場合に、Microsoft に自動的にレポートを送信するように構成されます。

  • データベース エンジン

  • SQL Server エージェント

  • Analysis Services

  • Reporting Services

  • Integration Services

  • レプリケーション

Microsoft はエラー レポートを SQL Server 機能の強化に使用し、すべての情報を機密情報として扱います。

エラーに関する情報はセキュリティで保護された接続 (https) を経由して Microsoft に送信され、情報はアクセスが制限された場所に格納されます。 また、エラー レポートを独自の企業内エラー報告サーバーに送信することもできます。

エラー レポートには次の情報が含まれます。

  • 問題発生時の SQL Server の状態。

  • オペレーティング システムのバージョンとコンピューター ハードウェアの情報。

  • ライセンスの識別に使用されないデジタル プロダクト ID。

  • コンピューターまたはプロキシ サーバーのネットワーク IP アドレス。

  • エラーの原因となったプロセスのメモリまたはファイルからの情報。

Microsoft は、使用者のファイル、名前、住所、電子メール アドレス、またはその他の形式の個人情報を意図的に収集することはありません。 ただし、エラーの原因となったプロセスのメモリまたはファイルに格納されている個人情報が、エラー レポートとして送信される場合もあります。 この情報を使用者の ID を判断するために使用できる可能性がありますが、Microsoft はこの情報をそのような目的に使用することはありません。

SQL Server のプライバシーとデータ収集ポリシーの詳細については、「Microsoft SQL Server のプライバシーに関する声明」を参照してください。

エラー レポートを有効にしている場合に重大なエラーが発生すると、そのエラーに関するサポート技術情報の記事を示す Microsoft からの応答が Windows イベント ログに表示されることがあります。

セットアップが完了した後で、SQL Server とそのコンポーネントのすべてのインスタンスについて、エラー レポートと機能の使用状況レポートを無効にするには、[エラーと使用状況レポートの設定] ダイアログ ボックスで、機能の使用状況レポートのチェック ボックスをオフにします。 SQL Server の複数のコンポーネント (SQL Server データベース エンジン、Analysis Services、Reporting Services、および共有コンポーネント) でエラー レポートが有効になっている場合は、エラー レポート機能を 1 つのコンポーネントのインスタンスごとに無効にできます。さらに、[その他] と表示されている共有コンポーネントも無効にすることができます。


フェールオーバー クラスター レポート

[image]

フェールオーバー クラスター レポート
フィードバックの送信

[フェールオーバー クラスター レポート] ページを使用して、この操作に対するセットアップ システム スキャンのレポート結果を表示します。

オプション

スキャンの詳細なレポートを表示するには、レポート リンクをクリックします。


[機能の確認]

[image]

[機能の確認]
関連項目 フィードバックの送信

[機能の確認] ページは、準備された機能の読み取り専用の一覧です。これらの機能は、イメージの完了ステップの最後に構成されて完了となります。 機能一覧はイメージの準備ステップ時に選択されます。イメージの完了ステップで変更することはできません。 表示されている機能に加え、準備済みインスタンスには、SQL Server Browser、SQL Server Writer、および SQL Server Native Client も含まれます。

SQL Server の準備済みインスタンスの構成が完了した後、SQL Server インスタンスの準備済みインスタンスに含まれていない他の機能を追加することができます。

コンポーネント グループ

コンポーネントおよび機能

データベース エンジン サービス

SQL Server データベース エンジンには、次のコンポーネントが含まれます。

  • データベース エンジンは、データの格納、処理、セキュリティ確保のための中心的なサービスです。

    • レプリケーション: (オプション) レプリケーションは、あるデータベースから別のデータベースへデータ オブジェクトやデータベース オブジェクトのコピーと配布を行い、一貫性を維持するためにデータベース間の同期を行う一連のテクノロジです。

    • フルテキスト検索: (オプション) フルテキスト検索は、SQL Server テーブルのプレーン文字ベースのデータに対してフルテキスト クエリを実行するための機能を提供します。

    • Data Quality Services (オプション): Data Quality Services (DQS) は、データ ソース内で一貫性のない不適切なデータを発見できるデータ クレンジング ソリューションであり、データのクレンジングを自動的かつインタラクティブに行うことができます。

Reporting Services

Reporting Services には、表形式、マトリックス形式、グラフィカル形式、および自由形式のレポートを作成、管理、配置するためのサーバー コンポーネントとクライアント コンポーネントが含まれます。 Reporting Services は、レポート アプリケーション開発用の拡張可能プラットフォームとしても使用できます。

関連項目

その他の技術情報

SysPrep を使用して SQL Server をインストールする方法


インストール ルール

[image]

インストール ルール
関連項目 フィードバックの送信

SQL Server セットアップによって、セットアップ操作が完了する前にコンピューターの構成が検証されます。 SQL Server セットアップの実行中、システム構成チェッカー (SCC) は SQL Server のインストール先コンピューターをスキャンします。 SCC は、SQL Server セットアップ操作の成功を妨げる条件がないかどうかを調べます。 セットアップで SQL Server インストール ウィザードが起動する前に、SCC は各項目の状態を取得します。 次に、必要な条件と取得した結果を比較し、ブロックの問題解決に関するガイダンスを提供します。

システム構成チェッカーは、実行された各ルールの簡単な記述と、実行ステータスを含むレポートを生成します。 システム構成チェッカーのレポートは %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\ に配置されます。

セットアップ操作を実行する前に、次のトピックを確認してください。

  1. SQL Server のインストールに必要なハードウェアおよびソフトウェア (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server の各エディションがサポートする機能 (http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server インストールのセキュリティに関する注意点 (http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server のローカル言語版 (http://go.microsoft.com/fwlink/?LinkId=235027)

その他の参考資料:

  1. サポートされているバージョンとエディションのアップグレード (http://go.microsoft.com/fwlink/?LinkId=235031)

  2. フェールオーバー クラスタリングをインストールする前に (http://go.microsoft.com/fwlink/?LinkId=235034)

関連項目

参照

セットアップ サポート ルール


機能ルール

[image]

機能ルール
フィードバックの送信

SQL Server セットアップによって、セットアップ操作が完了する前にコンピューターの構成が検証されます。 SQL Server セットアップの実行中、システム構成チェッカー (SCC) は SQL Server のインストール先コンピューターをスキャンします。 SCC は、SQL Server セットアップ操作の成功を妨げる条件がないかどうかを調べます。 セットアップが起動する前に、SCC は各項目の状態を取得します。 次に、必要な条件と取得した結果を比較し、ブロックの問題解決に関するガイダンスを提供します。

システム構成チェッカーは、実行された各ルールの簡単な記述と、実行ステータスを含むレポートを生成します。 システム構成チェッカーのレポートは %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\ に配置されます。

セットアップ操作を実行する前に、次のトピックを確認してください。

  1. SQL Server のインストールに必要なハードウェアおよびソフトウェア (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server の各エディションがサポートする機能 (http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server インストールのセキュリティに関する注意点 (http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server のローカル言語版 (http://go.microsoft.com/fwlink/?LinkId=235027)

その他の参考資料:

  1. サポートされているバージョンとエディションのアップグレード (http://go.microsoft.com/fwlink/?LinkId=235031)

  2. フェールオーバー クラスタリングをインストールする前に (http://go.microsoft.com/fwlink/?LinkId=235034)


機能の選択

[image]

機能の選択
関連項目 フィードバックの送信

SQL Server のインストールに含めるコンポーネントを選択するには、SQL Server インストール ウィザードの [機能の選択] ページのチェック ボックスを使用します。

SQL Server の機能のインストール

[機能の選択] ページには、SQL Server の機能が、"インスタンス機能" と "共有機能" の大きく 2 つのセクションに分けて表示されます。

インスタンス機能は、各インスタンスにつき 1 回インストールされるコンポーネントを指します。つまり、特定のコンポーネントのコピーが複数 (インスタンスごとに 1 つ) 存在することになります。 インスタンスはそれぞれ独立して存在し、修正プログラムのレベルがインスタンスごとに異なる場合もあります。 サービス パックや累積的な更新プログラムも含め、何かの修正プログラムをインストールすると、特定のコンピューター上の 1 つのインスタンスについてのみファイルが更新されます。その際、共有機能が未更新であった場合には、共有機能も更新されます。

共有機能は、特定のコンピューター上のすべてのインスタンスに共通する機能をいいます。 共有機能はそれぞれ、サポートされる範囲内の SQL Server のバージョン (つまり、インストールされているサービス パック、累積的な更新プログラム、修正プログラムの違いによって生じる SQL Server 間の違い) との下位互換性を保つように設計されています。

注意 注

SQL Server SysPrep : SQL Server SysPrep をサポートする Microsoft SQL Server 2012 の機能は、データベース エンジンおよび Reporting Services のみです。 これらの機能およびコンポーネントは、プロセスのイメージの準備手順の間に選択できます。 SQL Server の準備済みイメージの完了時には選択できません。 詳細については、「SysPrep を使用した SQL Server 2012 のインストール」(http://go.microsoft.com/fwlink/?LinkId=190965) を参照してください。

SQL Server フェールオーバー クラスター : フェールオーバー クラスタリングをサポートする Microsoft SQL Server 2012 の機能は、データベース エンジン コンポーネントと Analysis Services コンポーネントだけです。 Reporting Services や Integration Services など、その他のコンポーネントは、フェールオーバー クラスター ノードにインストールできますが、クラスターに対応していないため、フェールオーバー クラスター ノードがオフラインになると、そのサービスはフェールオーバーしません。 詳細については、「SQL Server 2008 R2 フェールオーバー クラスタリングの概要」(http://go.microsoft.com/fwlink/?LinkId=190953) を参照してください。

インスタンス機能

コンポーネントを選択すると、[説明] ペインに、各コンポーネント グループの説明が表示されます。 チェック ボックスはいくつでもオンにできます。 続行するには、選択を行う必要があります。

機能

説明

データベース エンジン サービス

SQL Server データベース エンジンには、データを格納、処理、およびセキュリティで保護するための主要サービスであるデータベース エンジン、レプリケーション、フルテキスト検索、リレーショナル データと XML データの管理ツール、および Data Quality Services (DQS) サーバーが含まれます。

  • データベース エンジンは、データの格納、処理、セキュリティ確保のための中心的なサービスです。

  • レプリケーション : レプリケーションは、あるデータベースから別のデータベースへデータ オブジェクトやデータベース オブジェクトのコピーと配布を行い、一貫性を維持するためにデータベース間の同期を行う一連のテクノロジです。

  • フルテキスト検索 : (オプション) フルテキスト検索は、SQL Server テーブルのプレーン文字ベースのデータに対してフルテキスト クエリを実行するための機能を提供します。

  • Data Quality Services (オプション): Data Quality Services (DQS) は、データ ソース内で一貫性のない不適切なデータを発見できるデータ クレンジング ソリューションであり、データのクレンジングをコンピューター支援型のインタラクティブな方法で行うことができます。 DQS サーバーをインストールするには、このチェック ボックスをオンにします。 DQS サーバーのインストールを完了するには、SQL Server のインストールを完了した後で、DQSInstaller.exe ファイルを実行する必要があります。 たとえば、SQL Server の既定のインスタンスをインストールした場合、このファイルは通常 C:\Program Files\Microsoft SQL Server\MSSQL11.MSSQLSERVER\MSSQL\Binn に格納されます。

SQL Server フェールオーバー クラスター: データベース エンジン サービスを選択した場合、レプリケーションとフルテキスト検索のコンポーネントは必須であり、SQL Server フェールオーバー クラスタリングのインストールに対してセットアップで自動的に選択されます。

Analysis Services

Analysis Services には、オンライン分析処理 (OLAP) アプリケーションおよびデータ マイニング アプリケーションを作成、管理するためのツールが含まれます。

Reporting Services - ネイティブ

Reporting Services ネイティブ モードには、表形式、マトリックス形式、グラフィカル形式、および自由形式のレポートを作成、管理、配置するためのサーバー コンポーネントとクライアント コンポーネントが含まれます。 Reporting Services は、レポート アプリケーション開発用の拡張可能プラットフォームとしても使用できます。

重要な注意事項 重要

  1. セットアップでは、Reporting Services スケールアウト配置の複数ノードに対して負荷分散と単一 URL アドレス指定が構成されません。 スケールアウト配置を完了するには、Windows Server、Microsoft Application Center、またはサード パーティ製クラスター管理ソフトウェアを使用する必要があります。 Web ファーム配置のセットアップの詳細については、「Reporting Services のスケールアウト配置の構成」(http://go.microsoft.com/fwlink/?LinkId=199448) を参照してください。

  2. Reporting Services のレポート デザイナー コンポーネントをインストールするには、Microsoft Internet Explorer 7.0 SP 1 が必要です。

  3. 64 ビット プラットフォームと、64 ビット サーバーの 32 ビット サブシステム (WOW64) 上では、Reporting Services を並列構成で同時に実行することはできません。

共有機能

1 つのコンピューター上のすべての SQL Server インスタンスによって共有される機能は、単一のディレクトリにインストールされます。 これらの機能を次に示します。

機能

説明

Reporting Services -SharePoint

Reporting Services SharePoint モードは、電子メール、複数のファイル形式、および対話的な Web ベースの形式でレポートの作成、管理、および配信を行う、サーバー ベースのアプリケーションです。 SharePoint モードでは、レポートの表示と管理の機能を SharePoint 製品に統合します。

Reporting Services SharePoint 製品用アドイン

Reporting Services SharePoint 製品用アドインには、SharePoint 製品を SharePoint モードの Reporting Services レポート サーバーと統合するための管理コンポーネントとユーザー インターフェイス コンポーネントが含まれます。

Data Quality クライアント

Data Quality クライアントは、DQS サーバーに接続するスタンドアロン アプリケーションであり、直感的なグラフィカル ユーザー インターフェイスを使用して、データ クレンジング操作やデータ照合操作を実行したり、DQS の管理タスクを実行したりすることができます。

SQL Server データ ツール1

SQL Server データ ツール (SSDT) は、ビジネス インテリジェンス コンポーネント (Analysis Services、Reporting Services、Integration Services) のソリューションをビルドするための IDE です

(以前の Business Intelligence Development Studio)。

SSDT には、Visual Studio 内で SQL Server プラットフォーム (社内および社外の両方) のデータベース設計を行うデータベース開発者用の統合環境である "データベース プロジェクト" も含まれます。 データベース開発者は、強化された Visual Studio のサーバー エクスプローラーを使用して、データベース オブジェクトおよびデータの作成または編集、クエリの実行を簡単に行うことができます。

クライアント ツール接続

クライアント ツールには、DB-Library、OLEDB for OLAP、ODBC、ADODB、ADOMD+ 用のネットワーク ライブラリなど、クライアントとサーバー間の通信を行うためのコンポーネントが含まれます。

Integration Services

Integration Services は、データを移動、コピー、変換するためのグラフィカル ツールおよびプログラミング可能なオブジェクトのセットです。

クライアント ツールの旧バージョンとの互換性

クライアント ツールの旧バージョンとの互換性には、次のコンポーネントが含まれます。

  • SQL 分散管理オブジェクト (SQL-DMO)。 詳細については、「SQL Server 2012 で提供が中止された機能」(http://go.microsoft.com/fwlink/?LinkId=190968) を参照してください。

  • Decision Support オブジェクト (DSO)。 詳細については、「SQL Server 2012 の Analysis Services 機能における重大な変更」(http://go.microsoft.com/fwlink/?LinkId=190970) を参照してください。

クライアント ツール SDK

プログラマのためのリソースを含むソフトウェア開発キットが含まれています。

Documentation コンポーネント

Documentation コンポーネントには、ヘルプ コンテンツを表示および管理するためのコンポーネントが含まれます。

管理ツール - 基本

管理ツール - 基本: 次のコンポーネントが含まれます。

  • SQL Server Management Studio による SQL Server データベース エンジン、SQL Server Express、sqlcmd ユーティリティ、および SQL Server PowerShell プロバイダーのサポート

管理ツール - 完全 基本バージョンのコンポーネントのほかに、以下のコンポーネントも含まれます。

  • SQL Server Management Studio による Reporting Services、Analysis Services、および Integration Services のサポート

  • SQL Server Profiler

  • データベース エンジン チューニング アドバイザー

  • SQL Server ユーティリティ管理

Distributed Replay Controller

Distributed Replay Controller は、Distributed Replay Client のアクションを統制します。 各 Distributed Replay 環境には、コントローラーのインスタンスを 1 つだけ置くことができます。 詳細については、「SQL Server Distributed Replay」(http://go.microsoft.com/fwlink/?LinkId=229847) を参照してください。

Distributed Replay Client

Distributed Replay Client は、SQL Server のインスタンスに対するワークロードをシミュレートします。 各 Distributed Replay 環境には、1 つまたは複数のクライアントを置くことができます。 詳細については、「SQL Server Distributed Replay」(http://go.microsoft.com/fwlink/?LinkId=229847) を参照してください。

SQL クライアント接続 SDK

データベース アプリケーション開発用の SQL Server Native Client (ODBC/OLE DB) SDK が含まれます。

マスター データ サービス

マスター データ サービス は、情報の精度向上と監査を目的として、異種システムのデータを全社規模で単一のマスター データ ソースとして統合するプラットフォームです。 マスター データ サービス を選択すると、マスター データ サービス構成マネージャー、アセンブリ、Windows PowerShell スナップインのほか、Web アプリケーションおよび Web サービス用のフォルダーおよびファイルがインストールされます。

LocalDB

LocalDB は、プログラムの開発者を対象とした SQL Server Express の実行モードです。 特別な接続文字列によって起動されると、必要な SQL Server インフラストラクチャが自動的に作成および開始され、アプリケーションは構成および管理タスクを行わずにデータベースを使用できます。

1 SQL Server データ ツール (SSDT) をインストールするには、Internet Explorer 6.0 SP1 が必要です。

既定では、共有コンポーネントは %Program Files%Microsoft SQL Server\ にインストールされます。 インストール パスを変更するには、[参照] ボタンをクリックします。 1 つの共有コンポーネントのインストール パスを変更すると、他の共有コンポーネントのパスも変更されます。 以降のインストールでは、最初のインストールと同じ場所に共有コンポーネントがインストールされます。

x64 ベースのオペレーティング システムでは、64 ビット コンポーネントのインストール先と、32 ビット コンポーネントの WOW64 サブシステム上のインストール先を指定できます。

AdventureWorks サンプル データベースのインストール

既定では、SQL Server のセットアップ時にサンプル データベースとサンプル コードはインストールされません。 サンプル データベースとサンプル コードのインストールの詳細については、「Microsoft SQL Server コミュニティのプロジェクトとサンプル」(http://go.microsoft.com/fwlink/?LinkId=87843) を参照してください。

サンプルの詳細については、Microsoft SQL Server 2012 をインストールした後で確認できます。 [スタート] ボタンをクリックし、[すべてのプログラム]、[Microsoft SQL Server 2012]、[マニュアルとチュートリアル] の順にポイントして、[Microsoft SQL Server サンプルの概要] をクリックします。

関連項目

その他の技術情報

SQL Server 2012 のエディションとコンポーネント


機能の選択 (アンインストール)

[image]

機能の選択 (アンインストール)
フィードバックの送信

[機能の選択] (アンインストール) ページを使用して、指定した SQL Server インスタンスから削除する機能を選択します。

オプション

機能はいくつでも選択できます。


アップグレードする機能

[image]

アップグレードする機能
関連項目 フィードバックの送信

Microsoft SQL Server 2012 インストール ウィザードの [アップグレードする機能] ページを使用すると、Microsoft SQL Server 2012 にアップグレードする機能を表示できます。

オプション

  • このリリースでは、アップグレードする機能を変更することはできません。 SQL Server のこのインスタンスに機能を追加するには、アップグレード プロセスを完了し、セットアップを再起動して、インストール センターの [新規インストールを実行するか、既存のインストールに機能を追加します] をクリックします。

関連項目

その他の技術情報

バージョンとエディションのアップグレード
アップグレード アドバイザーを使用したアップグレードの準備
SQL Server の複数のバージョンの使用


フルテキスト検索アップグレード オプション

[image]

フルテキスト検索アップグレード オプション
フィードバックの送信

SQL Server インストール ウィザードの [フルテキスト検索アップグレード オプション] ページを使用すると、ここでアップグレードするデータベースに対して使用するフルテキスト検索のアップグレード オプションを選択できます。

SQL Server 2005 以前のバージョンでは、各フルテキスト インデックスは、ファイル グループに属するフルテキスト カタログに存在し、物理パスを持ち、データベース ファイルとして扱われます。 SQL Server 2008 以降では、フルテキスト カタログは、フルテキスト インデックスのグループを指す論理的概念 (仮想オブジェクト) です。 したがって、新しいフルテキスト カタログは、物理パスを持つデータベース ファイルとしては扱われません。 ただし、データ ファイルを含むフルテキスト カタログのアップグレード時に、新しいファイル グループが同じディスク上に作成されます。 これにより、アップグレード後も以前のディスク I/O 動作が維持されます。 ルート パスが存在する場合、そのカタログのフルテキスト インデックスは、すべて新しいファイル グループに配置されます。 前のフルテキスト カタログのパスが無効の場合、フルテキスト インデックスは、ベース テーブルと同じファイル グループで保持されるか、パーティション テーブルの場合にはプライマリ ファイル グループで保持されます。

オプション

SQL Server 2005 または SQL Server 2008 から Microsoft SQL Server 2012 にアップグレードする場合、次のフルテキスト アップグレード オプションのいずれかを選択します。

[インポート]

フルテキスト カタログがインポートされます。 通常、インポートの方が再構築よりもかなり高速に処理されます。 たとえば、CPU を 1 つだけ使用している場合、インポートは、再構築の約 10 倍の速さで実行されます。 ただし、SQL Server 2005 からインポートされたフルテキスト カタログでは、SQL Server 2008 で導入された新しい拡張機能であるワード ブレーカーが使用されません。そのため、最終的にはフルテキスト カタログの再構築が必要になることがあります。

注意 注

再構築はマルチスレッド モードで実行できます。10 を超える CPU が使用可能な場合に、再構築でそれらの CPU をすべて使用できるようにすると、再構築の方がインポートよりも高速に実行されることがあります。

フルテキスト カタログを使用できない場合は、関連付けられたフルテキスト インデックスが再構築されます。 このオプションは SQL Server 2005 データベースでのみ使用できます。

フルテキスト インデックスのインポートによる影響については、後の「フルテキスト アップグレード オプションの選択に関する注意点」を参照してください。

[再構築]

フルテキスト カタログは、SQL Server 2008 で導入された新しい拡張機能であるワード ブレーカーを使用して再構築されます。 インデックスの再構築には時間がかかり、アップグレード後にかなりの量の CPU とメモリが必要になる可能性があります。

[リセット]

フルテキスト カタログがリセットされます。 SQL Server 2005 からのアップグレード時には、フルテキスト カタログ ファイルは削除されますが、フルテキスト カタログのメタデータおよびフルテキスト インデックスは保持されます。 アップグレード後、すべてのフルテキスト インデックスで変更の追跡は無効化されており、クロールは自動的には開始されません。 アップグレードの完了後、手動で完全作成を実行するまで、カタログは空のままになります。

これらのすべてのアップグレード オプションによって、アップグレードされたデータベースで、SQL Server 2008 以降のバージョンのフルテキスト操作のパフォーマンス向上による効果を最大限に活用できるようになります。

重要な注意事項 重要

SQL Server 2005 フルテキスト インデックスをインポートした後で新しいワード ブレーカーを使用する方法およびノイズ ワード ファイルをストップリストにアップグレードする方法については、Microsoft SQL Server 2012 セットアップ ヘルプの「フルテキスト検索のアップグレード」を参照してください。

フルテキスト アップグレード オプションの選択に関する注意点

アップグレードのためにアップグレード オプションを選択する際は、次の点を考慮してください。

  • ワード ブレーカーをどのように使用するか。

    Microsoft SQL Server 2012 のフルテキスト検索サービスには、SQL Server 2008 で導入されたワード ブレーカーとステミング機能が含まれています。 これにより、フルテキスト クエリの結果が、特定のテキストのパターンやシナリオで SQL Server 2005 と変わってくることがあります。 そのため、ワード ブレーカーをどのように使用するかが、適切なアップグレード オプションを選択する際に重要となります。

    • 使用するフルテキスト言語のワード ブレーカーが SQL Server 2008 以降のバージョンで変更されていない場合、または再呼び出しの精度が重要でない場合は、インポートが適切です。 後で、再呼び出しに関する問題があった場合には、フルテキスト カタログを再構築するだけで、新しいワード ブレーカーにアップグレードできます。 詳細については、Microsoft SQL Server 2012 セットアップ ヘルプの「フルテキスト検索のアップグレード」を参照してください。

    • 再呼び出しの精度が重要であり、SQL Server 2008 で強化されたワード ブレーカーのいずれかを使用する場合は、再構築が適切です。

  • 整数型のフルテキスト キー列に基づいて構築されているフルテキスト インデックスがあるかどうか。

    再構築では内部最適化処理が実行されます。これにより、アップグレードされたフルテキスト インデックスのクエリ パフォーマンスが向上することがあります。 具体的には、ベース テーブルのフルテキスト キー列が整数データ型であるフルテキスト インデックスを含むフルテキスト カタログがある場合、再構築によって、アップグレード後のフルテキスト クエリのパフォーマンスが理想的なものになります。 この場合は、[再構築] オプションを使用することを強くお勧めします。

    注意 注

    Microsoft SQL Server 2012 のフルテキスト インデックスでは、フルテキスト キーとして機能する列を整数データ型にすることをお勧めします。 詳細については、Microsoft SQL Server 2012 オンライン ブックの「パフォーマンスのチューニングと最適化 (フルテキスト検索)」を参照してください。

  • サーバー インスタンスをオンラインにする場合に何を優先するか。

    アップグレード時のインポートまたは再構築では CPU リソースを大量に消費するので、その他のサーバー インスタンスがアップグレードされてオンラインになるのが遅れます。 できるだけ早くサーバー インスタンスをオンラインにすることが重要であり、アップグレード後に手動作成を実行してもよい場合は、[リセット] が最適です。


完了 - インストール

[image]

完了 - インストール
関連項目 フィードバックの送信

[閉じる] をクリックしてインストールを終了します。

関連項目

概念

SQL Server のインストールの検証


インストールの前提条件

[image]

インストールの前提条件
フィードバックの送信

SQL Server を正常にインストールするには、インストール対象のコンピューターに以下のソフトウェア コンポーネントが用意されている必要があります。 これらは SQL Server セットアップ プログラムによりインストールされます。

  • .NET Framework Version 4.0 (Microsoft SQL Server 2012 のすべてのエディション)

  • SQL Server セットアップ サポート ファイル

  • SQL Server Native Client

注意 注

セットアップに失敗した場合、またはセットアップを中止した場合でも、これらのコンポーネントは削除されません。 これらを削除するには、コントロール パネルの [プログラムの追加と削除] を使用します。

オプション

必須ファイルをインストールするには、[インストール] をクリックします。 インストールしない場合は、[キャンセル] をクリックします。


インストールの進行状況

[image]

インストールの進行状況
関連項目 フィードバックの送信

SQL Server のセットアップ状況を監視するには、SQL Server インストール ウィザードの [インストールの進行状況] ページを使用します。

関連項目

概念

SQL Server セットアップ ログ ファイルの表示と読み取り


インストールの種類

[image]

インストールの種類
フィードバックの送信

SQL Server インストール ウィザードの [インストールの種類] ページを使用して、SQL Server の新しいインスタンスをインストールするか既存のインスタンスに機能を追加するかを指定します。

オプション

選択内容を指定するオプション ボタンをクリックします。

  • [SQL Server の新規インストールを実行する]

  • [既存の SQL Server インスタンスに機能を追加する]

    既存のインスタンスに機能を追加するオプションを選択した場合、ドロップダウン リストを使用して、更新する SQL Server インスタンスを選択します。

SQL Server の準備済みイメージには、SysPrep でサポートされる機能 (データベース エンジンおよび Reporting Services) のみを追加できます。 SysPrep でサポートされない他の機能については、準備済みインスタンスの完了後にのみ追加できます。

注 フェールオーバー クラスター インスタンスがインストールされている場合、そのインスタンスに機能を追加することはできません。 既存のフェールオーバー クラスターに SQL Server の機能を追加するには、新規インストールを実行して、別の SQL Server インスタンスをインストールする必要があります。


インスタンスの構成

[image]

インスタンスの構成
フィードバックの送信

SQL Server インストール ウィザードの [インスタンスの構成] ページを使用して、SQL Server の既定のインスタンスまたは名前付きインスタンスのどちらを作成するのかを指定します。 SQL Server のインスタンスがまだインストールされていない場合は、名前付きインスタンスを指定しない限り、既定のインスタンスが作成されます。

各 SQL Server インスタンスは、照合順序などのオプションに固有の設定を持つ異なるサービス セットから構成されます。 ディレクトリ構造、レジストリ構造、およびサービス名には、すべて SQL Server セットアップ中に作成されるインスタンス名および特定のインスタンス ID が反映されます。

インスタンスには、既定のインスタンスと名前付きインスタンスがあります。 既定のインスタンス名は MSSQLSERVER です。 接続時に、クライアントでインスタンス名を指定する必要はありません。 名前付きインスタンスは、ユーザーがセットアップ中に指定します。 先に既定のインスタンスをインストールしなくても、SQL Server を名前付きインスタンスとしてインストールできます。 既定のインスタンスにできるのは、バージョンにかかわらず、一度に 1 つの SQL Server インストールだけです。

注意 注

SQL Server SysPrep では、[インスタンスの構成] ページで準備済みインスタンスを完了するときにインスタンス名を指定できます。 コンピューター上に SQL Server の既存のインスタンスがない場合は、完了しようとしている準備済みインスタンスを既存のインスタンスとして構成するように選択できます。

複数のインスタンス

SQL Server では、1 台のサーバー (1 つのプロセッサ) 上に複数の SQL Server インスタンスをインストールできます。ただし、既定のインスタンスにできるのはそのうち 1 つだけです。 その他のインスタンスはすべて、名前付きインスタンスにする必要があります。 コンピューターは SQL Server の複数のインスタンスを同時に実行でき、それぞれ他のインスタンスとは関係なく動作します。

詳細については、「SQL Server の最大容量仕様」を参照してください。

オプション

フェールオーバー クラスター インスタンスのみ - SQL Server フェールオーバー クラスターのネットワーク名を指定します。 この名前は、ネットワーク上のフェールオーバー クラスター インスタンスを識別します。

既定のインスタンスまたは名前付きインスタンス - SQL Server の既定のインスタンスと名前付きインスタンスのどちらをインストールするか決定する場合は、次の事項を考慮してください。

  • データベース サーバー上で SQL Server の単独のインスタンスをインストールする場合は、そのインスタンスは既定のインスタンスであることが必要です。

  • 同じコンピューターで複数のインスタンスの使用を計画している場合は、名前付きインスタンスを使用します。 1 台のサーバーでは、既定のインスタンスを 1 つしかホストできません。

  • SQL Server Express をインストールするアプリケーションでは、名前付きインスタンスとしてインストールする必要があります。 これにより、複数のアプリケーションが同じコンピューターにインストールされた場合に競合が発生する可能性が軽減されます。

[既定のインスタンス]

SQL Server の既定のインスタンスをインストールするには、このオプションを選択します。 1 台のコンピューターでホストできる既定のインスタンスは 1 つだけです。その他すべては名前付きインスタンスにする必要があります。 ただし、SQL Server の既定のインスタンスをインストールしている場合は、その同じコンピューターに Analysis Services の既定のインスタンスを追加できます。

[名前付きインスタンス]

新しい名前付きインスタンスを作成するには、このオプションを選択します。 SQL Server のインスタンスに名前を付ける際は、次の点に注意してください。

  • インスタンス名では大文字と小文字が区別されません。

  • インスタンス名の先頭または末尾にアンダースコア (_) を使用することはできません。

  • インスタンス名には、"Default" などの予約されたキーワードを含めることはできません。 予約されたキーワードをインスタンス名に使用すると、セットアップ エラーが発生します。 詳細については、「予約済みキーワード」を参照してください。

  • インスタンス名として MSSQLServer を指定すると、既定のインスタンスが作成されます。 SQL Server Express の場合、インスタンス名として SQLExpress を指定すると、既定のインスタンスが作成されます。

  • Microsoft SQL Server 2012 PowerPivot for SharePoint は、常に 'PowerPivot' の名前付きインスタンスとしてインストールされます。 この機能ロール用に別のインスタンス名を指定できます。

  • インスタンス名は最大 16 文字まで指定できます。

  • インスタンス名の先頭は文字にする必要があります。 使用できる文字は、Unicode 規格 2.0 で定義されている文字です。 これには、ラテン文字 a ～ z と A ～ Z、および各国言語の文字が含まれます。

  • 2 文字目以降では、Unicode 規格 2.0 で定義されている文字、Basic Latin またはその他言語の 10 進数、ドル記号 ($)、アンダースコア (_) を使用できます。

  • 埋め込み型スペースなどの特殊文字は、インスタンス名に使用できません。 円記号 (\)、コンマ (,)、コロン (:)、セミコロン (;)、単一引用符 (')、アンパサンド (&)、およびアット マーク (@) も使用できません。

    注意 注

    現在の Windows コード ページで有効な文字だけを SQL Server インスタンス名に使用できます。 サポートされていない Unicode 文字を使用すると、セットアップ エラーが発生します。

[検出されたインスタンスと機能]

SQL Server セットアップを実行中のコンピューターにインストールされている SQL Server インスタンスとコンポーネントが一覧表示されます。

[インスタンス ID]: 既定では、インスタンス名がインスタンス ID として使用されます。 これは、SQL Server のインスタンスのインストール ディレクトリとレジストリ キーを識別するために使用されます。 これは、既定のインスタンスの場合も名前付きインスタンスの場合も同様です。 既定のインスタンスの場合、インスタンス名とインスタンス ID は、MSSQLSERVER になります。 既定以外のインスタンス ID を使用するには、Instance ID フィールドで指定します。

重要な注意事項 重要

SQL Server SysPrep では、このページに表示されるインスタンス ID は SQL Server SysPrep プロセスのイメージの準備手順で指定したインスタンス ID です。 イメージの完了手順では別のインスタンス ID を指定できません。

注意 注

アンダースコア (_) で始まるインスタンス ID や、シャープ記号 (#) またはドル記号 ($) を含むインスタンス ID はサポートされません。

ディレクトリ、ファイルの場所、およびインスタンス ID の名前付けの詳細については、「SQL Server の既定のインスタンスおよび名前付きインスタンスのファイルの場所」を参照してください。

[インスタンス ルート ディレクトリ]: 既定では、インスタンス ルート ディレクトリは、C:\Program Files\Microsoft SQL Server\ になります。 既定以外のルート ディレクトリを指定するには、[参照] ボタンをクリックするか、パス名を入力します。

SQL Server の特定のインスタンスを構成するすべてのコンポーネントは 1 つの単位として管理されます。 すべての SQL Server Service Pack とアップグレードは SQL Server のインスタンスの各コンポーネントに適用されます。

同じインスタンス名を持つすべての SQL Server コンポーネントは、次の条件を満たす必要があります。

  • 同じバージョン

  • 同じエディション

  • 同じ言語設定

  • 同じクラスター状態

    注意 注

    Reporting Services はクラスターに対応していません。

  • 同じオペレーティング システム


インスタンスの選択 (アンインストール)

[image]

インスタンスの選択 (アンインストール)
フィードバックの送信

[インスタンスの選択] (アンインストール) ページのドロップダウン ボックスを使用して、アンインストールする SQL Server インスタンスを指定します。

オプション

SQL Server のインスタンス全体を指定することも、共有機能と管理ツールのみがアンインストールされるように指定することもできます。


インスタンスの選択 (アップグレード)

[image]

インスタンスの選択 (アップグレード)
フィードバックの送信

[インスタンスの選択] (アップグレード) ページを使用して、アップグレードする SQL Server インスタンスを指定します。

オプション

1 つのインスタンスのすべてのコンポーネントは、同時にアップグレードする必要があります。 アップグレード中は、機能を追加または削除できません。


アップグレードするインスタンス

[image]

アップグレードするインスタンス
関連項目 フィードバックの送信

SQL Server インストール ウィザードの [アップグレードするインスタンス] ページを使用すると、Microsoft SQL Server 2012 にアップグレードする SQL Server 2005、SQL Server 2008 または SQL Server 2008 R2 のインスタンスを指定できます。

オプション

オプション ボタンを使用して、SQL Server のインスタンスとその共有コンポーネントをアップグレードするか、共有コンポーネントだけをアップグレードするかを指定します。 この SQL Server リリースの共有コンポーネントは、次のとおりです。

  • Integration Services

  • SQL Server Browser

  • SQL Server Active Directory Helper

  • SQL Writer

サポートされるアップグレード シナリオとアップグレードの既知の問題については、「バージョンとエディションのアップグレード」を参照してください。

関連項目

その他の技術情報

アップグレード アドバイザーを使用したアップグレードの準備
SQL Server の複数のバージョンの使用


アンインストール後

[image]

アンインストール後
フィードバックの送信

[アンインストール後] ページを使用して、操作が正常に完了したことを確認します。


[イメージの準備の進行状況]

[image]

[イメージの準備の進行状況]
関連項目 フィードバックの送信

SQL Server イメージの準備のセットアップ状況を監視するには、SQL Server インストール ウィザードの [イメージの準備の進行状況] ページを使用します。 このステップの完了時には、このプロセスで準備された各 SQL Server 機能のステータスがこのページに一覧表示されます。

関連項目

概念

SQL Server セットアップ ログ ファイルの表示と読み取り


イメージの準備ルール

[image]

イメージの準備ルール
フィードバックの送信

SQL Server セットアップによって、セットアップ操作が完了する前にコンピューターの構成が検証されます。 SQL Server セットアップの実行中、システム構成チェッカー (SCC) は SQL Server のインストール先コンピューターをスキャンします。 SCC は、SQL Server セットアップ操作の成功を妨げる条件がないかどうかを調べます。 セットアップでウィザードが起動する前に、SCC は各項目の状態を取得します。 次に、必要な条件と取得した結果を比較し、ブロックの問題解決に関するガイダンスを提供します。

システム構成チェッカーは、実行された各ルールの簡単な記述と、実行ステータスを含むレポートを生成します。 システム構成チェッカーのレポートは %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\ に配置されます。

セットアップ操作を実行する前に、次のトピックを確認してください。

  1. SQL Server のインストールに必要なハードウェアおよびソフトウェア (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server の各エディションがサポートする機能 (http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server インストールのセキュリティに関する注意点 (http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server のローカル言語版 (http://go.microsoft.com/fwlink/?LinkId=235027)

その他の参考資料:

  1. サポートされているバージョンとエディションのアップグレード (http://go.microsoft.com/fwlink/?LinkId=235031)

  2. フェールオーバー クラスタリングをインストールする前に (http://go.microsoft.com/fwlink/?LinkId=235034)


[イメージの種類の準備]

[image]

[イメージの種類の準備]
フィードバックの送信

SQL Server インストール ウィザードの [イメージの種類の準備] ページを使用して、Microsoft SQL Server 2012 の新しいインスタンスをインストールするか既存のインスタンスに機能を追加するかを指定します。

オプション

選択内容を指定するオプション ボタンをクリックします。

  • Microsoft SQL Server 2012 の新しいインスタンスを準備する

  • 既存の準備済み Microsoft SQL Server 2012 インスタンスに機能を追加する

    既存のインスタンスに機能を追加するオプションを選択した場合、ドロップダウン リストを使用して、更新する SQL Server の準備済みインスタンスを選択します。

    注意 注

    SQL Server の準備済みイメージには、SQL Server SysPrep でサポートされる機能 (データベース エンジンおよび Reporting Services) を追加できます。 SQL Server SysPrep でサポートされない他の機能については、準備済みインスタンスの完了後に追加できます。


プロダクト キー

[image]

プロダクト キー
フィードバックの送信

[プロダクト キー] ページを使用して SQL Server インスタンスを検証するか、インストールする SQL Server の無償のエディションを指定します。

オプション

SQL Server の無償のエディションを指定するには、無償インストールのオプション ボタンをクリックしてから、ドロップダウン ボックスを使用してインストールするエディションを指定します。

SQL Server の有償のエディションを検証するには、プロダクト キーのオプション ボタンをクリックしてから、該当するボックスにキーを入力します。

フェールオーバー クラスターのインストールの場合、各フェールオーバー クラスター ノードに同じプロダクト キーを使用します。 SQL Server の別のエディションのプロダクト キーを使用すると、エラーが発生します。


進行状況 (アンインストール)

[image]

進行状況 (アンインストール)
関連項目 フィードバックの送信

[進行状況] (アンインストール) ページを使用して、セットアップの進行状況を監視します。

関連項目

概念

SQL Server セットアップ ログ ファイルの表示と読み取り


[イメージの完了の準備完了]

[image]

[イメージの完了の準備完了]
フィードバックの送信

[イメージの完了の準備完了] ページには、準備済みインスタンスの構成に適用される構成設定の概要が示されます。

オプション

このページには、次のオプションがあります。

  • セットアップを続行するには、[インストール] をクリックします。

  • インストール設定を変更するには、[戻る] をクリックします。

  • セットアップを終了するには、[キャンセル] をクリックします。


インストールの準備完了

[image]

インストールの準備完了
関連項目 フィードバックの送信

[インストールの準備完了] ページには、SQL Server セットアップでインストールまたは変更される機能の概要が示されます。

オプション

このページには、次のオプションがあります。

  • セットアップを続行するには、[インストール] をクリックします。

  • インストール設定を変更するには、[戻る] をクリックします。

  • セットアップを終了するには、[キャンセル] をクリックします。

関連項目

概念

SQL Server セットアップ ログ ファイルの表示と読み取り


[イメージの準備の準備完了]

[image]

[イメージの準備の準備完了]
フィードバックの送信

[イメージの準備の準備完了] ページには、SQL Server セットアップで準備される機能の概要が示されます。

オプション

このページには、次のオプションがあります。

  • セットアップを続行するには、[インストール] をクリックします。

  • インストール設定を変更するには、[戻る] をクリックします。

  • セットアップを終了するには、[キャンセル] をクリックします。


[修復の準備完了]

[image]

[修復の準備完了]
関連項目 フィードバックの送信

[修復の準備完了] ページには、SQL Server セットアップによる修復プロセスの概要が示されます。

オプション

このページには、次のオプションがあります。

  • セットアップを続行するには、[修復] をクリックします。

  • インストール設定を変更するには、[戻る] をクリックします。

  • セットアップを終了するには、[キャンセル] をクリックします。

関連項目

概念

SQL Server セットアップ ログ ファイルの表示と読み取り


SQL Server フェールオーバー クラスター ノードの削除

[image]

SQL Server フェールオーバー クラスター ノードの削除
フィードバックの送信

[フェールオーバー クラスター ノードの削除] ページを使用して、Microsoft SQL Server 2012 フェールオーバー クラスター ノードとして削除するコンピューターを特定します。


[修復の進行状況]

[image]

[修復の進行状況]
関連項目 フィードバックの送信

SQL Server の修復状況を監視するには、SQL Server インストール ウィザードの [修復の進行状況] ページを使用します。

関連項目

概念

SQL Server セットアップ ログ ファイルの表示と読み取り


Reporting Services 構成オプション (SSRS)

[image]

Reporting Services 構成オプション (SSRS)
関連項目 フィードバックの送信

Microsoft SQL Server インストール ウィザードの [Reporting Services の構成] ページを使用すると、レポート サーバーのインストール方法および構成方法を指定できます。 インストール オプションを使用できるかどうかは、これより前に [機能の選択] ページで選択したオプションや、レポート サーバーのインストール時に SQL Server データベース エンジン のローカル インスタンスを一緒にインストールするかどうかによって決まります。

SSL (Secure Sockets Layer) 証明書がコンピューターにインストールされ、強いワイルドカードにバインドされている場合は、HTTPS プレフィックスを使用して Reporting Services の URL がセットアップで作成されます。 Reporting Services の URL に証明書をマップする方法の詳細については、SQL Server オンライン ブックで「Secure Socket Layer (SSL) 接続用レポート サーバーの構成」(http://go.microsoft.com/fwlink/?LinkId=199089) を参照してください。

Reporting Services に関する最新情報、およびこのリリースのインストールと構成の詳細については、追加のインストール情報 (http://go.microsoft.com/fwlink/?LinkId=207425) を参照してください。

オプション

Reporting Services ネイティブ モード

セットアップ時に満たされていない要件があるために既定のレポート サーバーの構成を実行できない場合は、インストール ウィザードで最小限のインストール オプションしか使用できません。この場合、必要なファイルはコピーされますが、セットアップの終了後に Reporting Services の構成マネージャーを使用してネイティブ モードのレポート サーバーを構成する必要があります。

注意 注

既定のインストール オプションのいずれかを選択した場合、既存のレポート サーバー データベース ファイルによってセットアップが失敗することがあります。 既定のインストール オプションを選択すると、セットアップは既定の名前を使用してレポート サーバー データベースを作成しようとします。 既定の名前のデータベースが既に存在する場合、セットアップは失敗し、インストールのロールバックが必要になります。 この問題を回避するには、セットアップを実行する前に既存のデータベースの名前を変更するか、[インストールのみ] オプションを選択して、セットアップの完了後にデータベースのカスタム設定を指定できるようにします。

[インストールと構成]

レポート サーバー データベース、サービス アカウント、および URL 予約の既定値を使用して、ネイティブ モードのレポート サーバー インスタンスをインストールします。 このオプションを選択した場合は、セットアップが終了するとレポート サーバー インスタンスを使用できるようになります。 ローカル データベース エンジンのインスタンスを使用してレポート サーバー データベースが作成され、既定値を使用するようにレポート サーバーが構成されます。

このオプションを使用できるのは、レポート サーバーのインストールで使用される既定値が現在のシステムに対して有効な場合のみです。 このオプションは、開発者がすべてのコンポーネントをローカルにインストールする場合や、ユーザーがソフトウェアを評価する場合に適しています。

セットアップで使用される既定の設定に関する情報や、既定の構成をインストールできない理由を確認するには、[詳細] をクリックします。 ネイティブ モードのレポート サーバーの既定の構成の詳細については、「ネイティブ モード インストールの既定の構成 (Reporting Services)」(http://go.microsoft.com/fwlink/?LinkId=199091) を参照してください。

[インストールのみ]

レポート サーバーのプログラム ファイルをインストールし、レポート サーバー サービス アカウントを作成し、レポート サーバーの WMI (Windows Management Instrumentation) プロバイダーを登録します。 このインストール オプションは、"ファイルのみ" のインストールと呼ばれます。 既定の構成を使用しない場合は、このオプションを選択します。 既定の構成をインストールできない場合や、Reporting Services を含む SQL Server フェールオーバー クラスターをインストールする場合は、このオプションしか使用できません。ファイルのみのインストールの詳細については、「ファイルのみのインストール (Reporting Services)」(http://go.microsoft.com/fwlink/?LinkId=199093) を参照してください。

セットアップの終了後、レポート サーバーを使用するには、レポート サーバー データベースを作成し、レポート サーバーを構成する必要があります。 レポート サーバーの構成やデータベースの作成には、Reporting Services 構成マネージャーを使用します。 詳細については、「レポート サーバー データベースを作成する方法 (Reporting Services 構成)」(http://go.microsoft.com/fwlink/?LinkId=199094) および「レポート サーバー データベース接続の構成」(http://go.microsoft.com/fwlink/?LinkId=199095) を参照してください。

Reporting Services SharePoint モード

[インストールのみ]

レポート サーバーのプログラム ファイルと PowerShell コマンドレットをインストールします。 インストールが完了したら、Reporting Services SharePoint サービスを起動し、Reporting Services サービス アプリケーションを作成する必要があります。 詳細については、「SharePoint 統合の Reporting Services サービスのインストールおよび構成の概要」(http://go.microsoft.com/fwlink/?LinkId=207543)、「SQL Server Reporting Services サービス アプリケーション (SSRS) の作成」(http://go.microsoft.com/fwlink/?LinkId=207544)、および「Reporting Services と SharePoint の統合の概要」(http://go.microsoft.com/fwlink/?LinkID=207244) を参照してください。

SharePoint テクノロジ用 Reporting Services アドインのインストール

Microsoft SQL Server 2012 リリースから、アドインは SQL Server インストール ウィザードの機能の選択ページで SQL Server インストールの一部としてインストールすることができるようになりました。

ただし、SharePoint 2010 用 Reporting Services アドインは、次のいずれかの方法を使用してインストールできます。

  • SharePoint 2010 製品準備ツールの PreRequisiteInstaller.exe を実行します。

  • SQL Server のインストール メディアからインストールします。 SQL Server セットアップの終了後、SQL Server インストール メディアの Setup フォルダーにある rsSharePoint.msi ファイルをクリックします。

  • アドインをダウンロードし、インストールします。 詳細については、「SharePoint 製品用 Reporting Services アドインの検索場所」(http://go.microsoft.com/fwlink/?LinkID=208634) を参照してください。

関連項目

その他の技術情報

Reporting Services 構成を開始する方法
レポート サーバー データベースを作成する方法 (Reporting Services 構成)
Reporting Services のインストールに関する注意点
ネイティブ モード インストールの既定の構成 (Reporting Services)
SharePoint モードの既定の構成 (Reporting Services)
コマンド プロンプトからの SQL Server のインストール


Reporting Services SharePoint モードのアップグレード (SSRS)

[image]

Reporting Services SharePoint モードのアップグレード (SSRS)
関連項目 フィードバックの送信

[Reporting Services SharePoint モード] ページを使用して、すべての共有機能のアップグレードを確認します。 Reporting Services SharePoint モードは SQL Server 共有機能であり、その他のすべての SQL Server 共有機能と共にアップグレードされます。 SQL Server インストール ウィザードでは 1 つの共有機能のみのアップグレードはサポートされていません。 すべての SQL Server 共有機能は同時にアップグレードされます。

オプション

[次へ] ボタンは [アップグレードを続行する] チェック ボックスをオンにした場合にのみ利用できます。 チェック ボックスがオフの場合、アップグレードは続行できません。

詳細については、「Reporting Services のアップグレード」(http://go.microsoft.com/fwlink/?LinkId=199092) を参照してください。

関連項目

概念

SQL Server セットアップ ログ ファイルの表示と読み取り

その他の技術情報

コマンド プロンプトからの SQL Server のインストール


Reporting Services SharePoint モード認証

[image]

Reporting Services SharePoint モード認証
関連項目 フィードバックの送信

Microsoft SQL Server インストール ウィザードの [Reporting Services SharePoint モード認証] ページを使用すると、現在の Reporting Services インストールで使用されるサービス アカウントの資格情報を指定できます。 資格情報は新しい SharePoint アプリケーション プールの作成に使用されます。 また、1 つの新しい Reporting Services SharePoint サービス アプリケーションが作成されます。 サービス アプリケーション名には前の Reporting Services インスタンス名が含まれます。

オプション

  • [SSRS アプリケーション プールのアカウント名] オプションは読み取り専用です。 値はアップグレード中の既存の Reporting Services インストールからの現在の値で自動的に設定されます。

  • アプリケーション プール アカウントのパスワードが不要な場合、[SSRS アプリケーション プール アカウントのパスワード] オプションは無効になります。 たとえば、"NT Authority\NetworkSerivce" などです。 アプリケーション プール アカウントのパスワードが必要な場合、正しいパスワードを入力するまでアップグレードは続行できません。

詳細については、「Reporting Services のアップグレード」(http://go.microsoft.com/fwlink/?LinkId=199092) を参照してください。

関連項目

その他の技術情報

Reporting Services のアップグレード


[準備済みインスタンスの選択]

[image]

[準備済みインスタンスの選択]
フィードバックの送信

[準備済みインスタンスの選択] ページを使用して、完了させる準備済みインスタンスを指定します。

オプション

[インスタンス ID の選択] ボックスには、完了させることができる準備済みインスタンスが一覧表示されます。 完了させる準備済みインスタンスを選択します。

[インスタンス ID の選択]

SQL Server セットアップが実行されているコンピューター上の完了させることができるすべての準備済みインスタンスが一覧表示されます。 完了させる準備済みインスタンスを選択します。

[インストール済みのインスタンス]

インストールと準備が済んで完了したインスタンスが表示されます。


サーバーの構成 - 照合順序

[image]

サーバーの構成 - 照合順序
フィードバックの送信

SQL Server インストール ウィザードの [サーバーの構成 - 照合順序] ページでは、データベース エンジンおよび Analysis Services で並べ替えに使用される照合順序の設定を変更できます。 インストールされている別の SQL Server、または別のコンピューターと照合順序設定を一致させるにはこのオプションを選択します。

オプション

SQL Server および Analysis Services のカスタマイズ

SQL Server の照合順序には、Windows 照合順序と SQL Server 照合順序という 2 種類のグループがあります。 データベース エンジンおよび Analysis Services に異なる照合順序の設定を指定できます。また、両方に同じ照合順序を指定することもできます。

既定では、英語 (米国) システム ロケールには SQL Server 照合順序が選択されます。 SQL Server の他言語バージョンの既定の照合順序は、使用しているコンピューターの Windows システム ロケール設定によって決まります。 詳細については、「Using SQL Collations」を参照してください。

既定の設定は、このインストール済み SQL Server の照合順序の設定を別の SQL Server インスタンスで使用される照合順序の設定に一致させる必要がある場合、または別のコンピューターの Windows システム ロケールに一致させる必要がある場合にのみ、変更するようにします。

注 Analysis Services は Windows 照合順序のみを使用します。 Analysis Services のインストールを予定する場合は、SQL Server のセットアップ時に Windows 照合順序を選択して、SQL Server データベース エンジンと Analysis Services で一貫した結果が得られるようにしてください。

詳細については、「セットアップでの照合順序の設定」を参照してください。

ベスト プラクティス

SQL Server セットアップで使用される Windows システム ロケールと、それに対応する既定の照合順序の一覧表は、「セットアップでの照合順序の設定」を参照してください。

可能であれば、組織で単一の照合順序を使用してください。 そうすれば、データベース、列、式、または識別子ごとに照合順序を明示的に指定する必要はなくなります。 複数の照合順序とコード ページ設定を操作する必要がある場合は、照合順序の優先順位の規則を考慮してクエリを作成します。 詳細については、オンライン ブックの「照合順序の優先順位 (Transact-SQL)」を参照してください。

SQL Server の照合順序を選択する場合は、次の推奨設定を考慮してください。

  • バイナリ コード ポイント順が使用できる場合は、バイナリ 2 照合順序を選択します。

  • データ型間の比較で一貫性を保つには、Windows 照合順序を選択します。

  • 言語の並べ替えのサポートを向上させるには、新しい 100 レベルの照合順序を使用します。 詳細については、「照合順序と Unicode のサポート」を参照してください。

  • アップグレード済みの SQL Server インスタンスにデータベースを移行する場合は、データベースの既存の照合順序と一致する照合順序を選択します。


サーバーの構成 - サービス アカウント

[image]

サーバーの構成 - サービス アカウント
関連項目 フィードバックの送信

SQL Server インストール ウィザードの [サーバーの構成] ページを使用して、SQL Server サービスにログイン アカウントを割り当てます。 このページで構成する実際のサービスは、インストール時に選択した機能によって異なります。

SQL Server を開始して実行するために使用する開始アカウントは、ドメイン ユーザー アカウント、ローカル ユーザー アカウント、マネージ サービス アカウント、仮想アカウント、またはビルトイン システム アカウントのいずれでも可能です。

オプション

すべての SQL Server サービスに同じログイン アカウントを割り当てることも、各サービス アカウントを個々に構成することもできます。 サービスを自動的に開始するか、手動で開始するか、または無効にするかを指定することもできます。 ほとんどのインストールでは、既定のアカウントをお勧めします。

  • Windows 7 および Windows Server 2008 R2 では、ほとんどのアカウントが既定で仮想アカウントに設定されます。

  • Windows Vista および Windows Server 2008 では、ほとんどのアカウントが NETWORK SERVICE アカウントに設定されます。

  • Windows Server 2008 のクラスター インストールでは、ドメイン アカウントを指定する必要があります。

サービスを構成してドメイン アカウントを使用する場合、Microsoft では、各サービスに最小の権限を与えるために、サービス アカウントを個別に構成することをお勧めします。サービス アカウントを個別に構成すると、SQL Server サービスには、サービスでのタスクの実行に必要な最小権限が付与されます。 アカウントの種類の説明などの詳細については、「Windows サービス アカウントの設定」を参照してください。

[SQL Server サービス アカウントを個別に構成する (推奨)]

グリッドを使用して各 SQL Server サービスにログオン ユーザー名とパスワードを提供し、サービスのスタートアップの種類を設定します。 SQL Server サービスには、ビルトイン システム アカウント、ローカル アカウント、ローカル グループ アカウント、ドメイン グループ アカウント、またはドメイン ユーザー アカウントを使用できます。

以下のサービスのいずれかを選択し、設定をカスタマイズします。

選択するサービス

認証設定を構成する対象

SQL Server エージェント

ジョブ、モニター、および SQL Server を実行し、管理タスクの自動化を可能にするサービス。

このサービスの既定のログオン アカウントはありません。

既定のスタートアップの種類は [手動] です。

SQL Server

SQL Server データベース エンジン です。

既定のスタートアップの種類は [自動] です。

注意 注

SQL Server Browser

SQL Server Browser は、クライアント コンピューターに SQL Server 接続情報を提供する名前解決サービスです。 このサービスは複数の SQL Server および Integration Services インスタンス間で共有されます。

既定のログオン アカウントは NT Authority\Local Service で、SQL Server のセットアップ中には変更できません。 アカウントはセットアップの完了後に変更できます。

スタートアップの種類をセットアップ中に指定しない場合、種類は次のようにして決まります。

  • SQL Server Browser が [自動] に設定され、次に示すインストール シナリオで実行されます。

    • SQL Server フェールオーバー クラスター インスタンス

    • TCP または NP が有効になっている SQL Server の名前付きインスタンス

    • クラスター化されていない分析サーバーの名前付きインスタンス

  • 上記のシナリオのいずれにも該当せず、SQL Server Browser が既にインストールされている場合、SQL Server Browser の現在の状態が継続されます。

  • インストールの前に既存 (SQL Server 2005、SQL Server 2008、SQL Server 2008 R2 のいずれか) のインスタンスが存在しない場合は、スタートアップの種類が [無効] に設定され、停止しています。

Analysis Services

Analysis Services.

既定のスタートアップの種類は [自動] です。

SharePoint 統合モードの場合、Windows のドメイン ユーザー アカウントを指定する必要があります。 指定したアカウントは、Analysis Services サービスに使用されます。 現在のインスタンスに指定するアカウントは、その後に同じファームに追加した Analysis Services インスタンスにも使用する必要があります。

Reporting Services

Reporting Services. サービス アカウントはレポート サーバー データベースの接続を構成するために使用されます。 既定の認証設定を使用する場合は、組み込みのネットワーク サービスを選択します。 ドメイン ユーザー アカウントを指定する場合、レポート サーバーで Windows 認証を使用しているときは、そのドメイン ユーザー アカウントのサービス プリンシパル名 (SPN) を登録します。 詳細については、「Reporting Services で Windows 認証を構成する方法」を参照してください。

重要な注意事項 重要

ネットワーク サービスは共有可能なアカウントなので、特権の少ないアカウントが使用可能な場合は、SQL Server サービスまたは SQL Server エージェント サービスに対してネットワーク サービス アカウントを使用しないことをお勧めします。 ネットワーク サービスを SQL Server サービス アカウントとして使用するのが適切なのは、そのアカウントを使用する他のサービスがコンピューターにインストールされていないことが確実な場合のみです。 SQL Server サービスには、Windows 管理者ではないローカル ユーザー アカウントまたはドメイン ユーザー アカウントの方が適しています。

既定のスタートアップの種類は [自動] です。

Integration Services

Integration Services は、データを移動、コピー、変換するためのグラフィカル ツールおよびプログラミング可能なオブジェクトのセットです。

既定のスタートアップの種類は [自動] です。

SQL Server フルテキスト フィルター デーモン ランチャー

fdhost.exe プロセスを作成するサービスです。 このサービスは、フルテキスト インデックスのテキスト データを処理する、ワード ブレーカーおよびフィルターをホストするために必要です。

FDHOST ランチャー サービスを実行するドメイン アカウントを指定する場合は、権限の低いアカウントを使用することを強くお勧めします。 このアカウントには、SQL Server サービスに使用するアカウントとは別のアカウントを指定する必要があります。 Windows Vista および Windows Server 2008 では、FDHOST ランチャー サービス アカウントが既定で LOCAL SERVICE になります。

SQL Server Distributed Replay クライアント

Distributed Replay クライアントのサービスで使用されるサービス アカウント。

Distributed Replay クライアントのサービスを実行するアカウントを指定します。 このアカウントには、SQL Server サービスに使用するアカウントとは別のアカウントを指定する必要があります。

既定のスタートアップの種類は [手動] です。

SQL Server Distributed Replay コントローラー

Distributed Replay コントローラー サービスのサービス アカウント。

Distributed Replay コントローラー サービスを実行するアカウントを指定します。 このアカウントには、SQL Server サービスに使用するアカウントとは別のアカウントを指定する必要があります。

既定のスタートアップの種類は [手動] です。

関連項目

その他の技術情報

SQL Server インストールにおけるセキュリティの考慮事項


セットアップ ロール

[image]

セットアップ ロール
関連項目 フィードバックの送信

[機能の選択] ページを使用して個々の機能を選択するか、セットアップ ロールを使用してインストールするかを指定するには、このページを使用します。

setup role とは、事前定義された SQL サーバー構成の実装に必要なすべての機能および共有コンポーネントを選択するために用意されている設定です。

オプション

[SQL Server 機能のインストール]

個々の機能と共有コンポーネントを選択するには、このオプションを選択します。 インスタンス機能には、データベース エンジン サービス、Analysis Services (ネイティブ モード)、Reporting Services などがあります。

[SQL Server PowerPivot for SharePoint]

SharePoint 2010 ファームに Analysis Services サーバー コンポーネントをインストールするには、このオプションを選択します。 このオプションを使用すると、PowerPivot System サービスおよび Analysis Services サーバーをファームに配置して、埋め込まれた PowerPivot データを含むパブリッシュ済みの Excel ブックを対象としたクエリおよびデータ処理を有効にできます。

必要に応じて、SharePoint ファームでデータベースをホストするために必要なリレーショナル データベース エンジンのインスタンスをインストールに追加することもできます。 既にファームが構成されている場合は、このオプションをスキップできます。

セットアップが完了したら、PowerPivot 構成ツール、PowerShell コマンドレット、SharePoint 2010 サーバーの全体管理のいずれかの方法でソフトウェアを構成する必要があります。 以前のリリースとは異なり、セットアップでは PowerPivot インストールの構成タスクが実行されなくなりました。

ロール ベースのインストールには、SQL Server PowerPivot for Excel クライアント アプリケーションは含まれません。 クライアント アプリケーションは個別にインストールします。

[すべての機能に既定値を使用]

このリリースで使用できるすべての機能をインストールするには、このセットアップ ロールを選択します。 PowerPivot for SharePoint はこのロールから除外される点に注意してください。 PowerPivot for SharePoint をインストールするには、PowerPivot for SharePoint セットアップ ロールを使用する必要があります。

データベース エンジンは NT AUTHORITY\NETWORK SERVICE アカウントを使用して開始するように構成されています。 現在のユーザーは SQL Server sysadmin ロールのメンバーとなります。 このオプションで設定した値は、他のコマンド ライン パラメーターを指定してオーバーライドできます。

Windows Vista または Windows Server 2008 以降を使用していてオペレーティング システムがドメイン コントローラーでない場合、既定ではデータベース エンジンおよび Reporting Services は NTAUTHORITY\NETWORK SERVICE アカウントを、Integration Services は NTAUTHORITY\NETWORK SERVICE アカウントを、SQL フルテキスト フィルター デーモン ランチャーは NTAUTHORITY\LOCAL SERVICE アカウントを使用します。

関連項目

参照

機能の選択

その他の技術情報

PowerPivot for SharePoint のインストール
ハードウェアとソフトウェアの要件 (PowerPivot for SharePoint)


SQL Server フェールオーバー クラスター ウィザード - 完了

[image]

SQL Server フェールオーバー クラスター ウィザード - 完了
関連項目 フィードバックの送信

SQL Server セットアップによって、セットアップ操作が完了する前にコンピューターの構成が検証されます。 SQL Server セットアップの実行中、システム構成チェッカー (SCC) は SQL Server のインストール先コンピューターをスキャンします。 SCC は、SQL Server セットアップ操作の成功を妨げる条件がないかどうかを調べます。 セットアップで SQL Server インストール ウィザードが起動する前に、SCC は各項目の状態を取得します。 次に、必要な条件と取得した結果を比較し、ブロックの問題解決に関するガイダンスを提供します。

システム構成チェッカーは、実行された各ルールの簡単な記述と、実行ステータスを含むレポートを生成します。 システム構成チェッカーのレポートは %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\ に配置されます。

セットアップ操作を実行する前に、次のトピックを確認してください。

  1. SQL Server のインストールに必要なハードウェアおよびソフトウェア (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server の各エディションがサポートする機能 (http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server インストールのセキュリティに関する注意点 (http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server のローカル言語版 (http://go.microsoft.com/fwlink/?LinkId=235027)

その他の参考資料:

  1. サポートされているバージョンとエディションのアップグレード (http://go.microsoft.com/fwlink/?LinkId=235031)

  2. フェールオーバー クラスタリングをインストールする前に (http://go.microsoft.com/fwlink/?LinkId=235034)

関連項目

参照

セットアップ サポート ルール


SQL Server フェールオーバー クラスター ウィザード - インストール

[image]

SQL Server フェールオーバー クラスター ウィザード - インストール
関連項目 フィードバックの送信

SQL Server セットアップによって、セットアップ操作が完了する前にコンピューターの構成が検証されます。 SQL Server セットアップの実行中、システム構成チェッカー (SCC) は SQL Server のインストール先コンピューターをスキャンします。 SCC は、SQL Server セットアップ操作の成功を妨げる条件がないかどうかを調べます。 セットアップで SQL Server インストール ウィザードが起動する前に、SCC は各項目の状態を取得します。 次に、必要な条件と取得した結果を比較し、ブロックの問題解決に関するガイダンスを提供します。

システム構成チェッカーは、実行された各ルールの簡単な記述と、実行ステータスを含むレポートを生成します。 システム構成チェッカーのレポートは %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\ に配置されます。

セットアップ操作を実行する前に、次のトピックを確認してください。

  1. SQL Server のインストールに必要なハードウェアおよびソフトウェア (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server の各エディションがサポートする機能 (http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server インストールのセキュリティに関する注意点 (http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server のローカル言語版 (http://go.microsoft.com/fwlink/?LinkId=235027)

その他の参考資料:

  1. サポートされているバージョンとエディションのアップグレード (http://go.microsoft.com/fwlink/?LinkId=235031)

  2. フェールオーバー クラスタリングをインストールする前に (http://go.microsoft.com/fwlink/?LinkId=235034)

関連項目

参照

セットアップ サポート ルール


SQL Server フェールオーバー クラスター ウィザード - 準備

[image]

SQL Server フェールオーバー クラスター ウィザード - 準備
関連項目 フィードバックの送信

SQL Server セットアップによって、セットアップ操作が完了する前にコンピューターの構成が検証されます。 SQL Server セットアップの実行中、システム構成チェッカー (SCC) は SQL Server のインストール先コンピューターをスキャンします。 SCC は、SQL Server セットアップ操作の成功を妨げる条件がないかどうかを調べます。 セットアップで SQL Server インストール ウィザードが起動する前に、SCC は各項目の状態を取得します。 次に、必要な条件と取得した結果を比較し、ブロックの問題解決に関するガイダンスを提供します。

システム構成チェッカーは、実行された各ルールの簡単な記述と、実行ステータスを含むレポートを生成します。 システム構成チェッカーのレポートは %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\ に配置されます。

セットアップ操作を実行する前に、次のトピックを確認してください。

  1. SQL Server のインストールに必要なハードウェアおよびソフトウェア (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server の各エディションがサポートする機能 (http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server インストールのセキュリティに関する注意点 (http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server のローカル言語版 (http://go.microsoft.com/fwlink/?LinkId=235027)

その他の参考資料:

  1. サポートされているバージョンとエディションのアップグレード (http://go.microsoft.com/fwlink/?LinkId=235031)

  2. フェールオーバー クラスタリングをインストールする前に (http://go.microsoft.com/fwlink/?LinkId=235034)

関連項目

参照

セットアップ サポート ルール


概要 (アップグレード)

[image]

概要 (アップグレード)
フィードバックの送信

[概要] ページを使用すると、このアップグレードに指定したオプションを確認できます。


セットアップ サポート ルール

[image]

セットアップ サポート ルール
フィードバックの送信

SQL Server セットアップによって、セットアップ操作が完了する前にコンピューターの構成が検証されます。 SQL Server セットアップの実行中、システム構成チェッカー (SCC) は SQL Server のインストール先コンピューターをスキャンします。 SCC は、SQL Server セットアップ操作の成功を妨げる条件がないかどうかを調べます。 セットアップで SQL Server インストール ウィザードが起動する前に、SCC は各項目の状態を取得します。 次に、必要な条件と取得した結果を比較し、ブロックの問題解決に関するガイダンスを提供します。

システム構成チェッカーは、実行された各ルールの簡単な記述と、実行ステータスを含むレポートを生成します。 システム構成チェッカーのレポートは %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\ に配置されます。

セットアップ操作を実行する前に、次のトピックを確認してください。

  1. SQL Server のインストールに必要なハードウェアおよびソフトウェア (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server の各エディションがサポートする機能 (http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server インストールのセキュリティに関する注意点 (http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server のローカル言語版 (http://go.microsoft.com/fwlink/?LinkId=235027)

その他の参考資料:

  1. サポートされているバージョンとエディションのアップグレード (http://go.microsoft.com/fwlink/?LinkId=235031)

  2. フェールオーバー クラスタリングをインストールする前に (http://go.microsoft.com/fwlink/?LinkId=235034)

その他のルール トピック

シナリオ固有のセットアップ ルールについては、次のトピックを参照してください。

  • インストール ルール

  • アップグレード ルールのチェック

  • エディションのアップグレード規則

  • アンインストール ルール

  • イメージの準備ルール

  • イメージの完了ルール


アンインストール ルール

[image]

アンインストール ルール
関連項目 フィードバックの送信

[アンインストール ルール] ページでは、一連のルールを実行して、セットアップ操作が正常に完了できるようにします。

SQL Server セットアップによって、セットアップ操作が完了する前にコンピューターの構成が検証されます。 SQL Server セットアップの実行中、システム構成チェッカー (SCC) は SQL Server のインストール先コンピューターをスキャンします。 SCC は、SQL Server セットアップ操作の成功を妨げる条件がないかどうかを調べます。 セットアップで SQL Server アンインストール ウィザードが起動する前に、SCC は各項目の状態を取得します。 次に、必要な条件と取得した結果を比較し、ブロックの問題解決に関するガイダンスを提供します。

システム構成チェッカーは、実行された各ルールの簡単な記述と、実行ステータスを含むレポートを生成します。 システム構成チェッカーのレポートは %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\ に配置されます。

セットアップ操作を実行する前に、次のトピックを確認してください。

  1. SQL Server のインストールに必要なハードウェアおよびソフトウェア (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server の各エディションがサポートする機能 (http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server インストールのセキュリティに関する注意点 (http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server のローカル言語版 (http://go.microsoft.com/fwlink/?LinkId=235027)

その他の参考資料:

  1. サポートされているバージョンとエディションのアップグレード (http://go.microsoft.com/fwlink/?LinkId=235031)

  2. フェールオーバー クラスタリングをインストールする前に (http://go.microsoft.com/fwlink/?LinkId=235034)

関連項目

参照

セットアップ サポート ルール


[アップグレードの進行状況]

[image]

[アップグレードの進行状況]
関連項目 フィードバックの送信

SQL Server のアップグレード状況を監視するには、SQL Server インストール ウィザードの [アップグレードの進行状況] ページを使用します。

関連項目

概念

SQL Server セットアップ ログ ファイルの表示と読み取り


アップグレード ルールのチェック

[image]

アップグレード ルールのチェック
関連項目 フィードバックの送信

SQL Server セットアップによって、セットアップ操作が完了する前にコンピューターの構成が検証されます。 SQL Server セットアップの実行中、システム構成チェッカー (SCC) は SQL Server のインストール先コンピューターをスキャンします。 SCC は、SQL Server セットアップ操作の成功を妨げる条件がないかどうかを調べます。 セットアップでアップグレード ウィザードが起動する前に、SCC は各項目の状態を取得します。 次に、必要な条件と取得した結果を比較し、ブロックの問題解決に関するガイダンスを提供します。

システム構成チェッカーは、実行された各ルールの簡単な記述と、実行ステータスを含むレポートを生成します。 システム構成チェッカーのレポートは %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\ に配置されます。

セットアップ操作を実行する前に、次のトピックを確認してください。

  1. SQL Server のインストールに必要なハードウェアおよびソフトウェア (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. SQL Server の各エディションがサポートする機能 (http://go.microsoft.com/fwlink/?LinkId=235023)

  3. SQL Server インストールのセキュリティに関する注意点 (http://go.microsoft.com/fwlink/?LinkId=235025)

  4. SQL Server のローカル言語版 (http://go.microsoft.com/fwlink/?LinkId=235027)

その他の参考資料:

  1. サポートされているバージョンとエディションのアップグレード (http://go.microsoft.com/fwlink/?LinkId=235031)

  2. フェールオーバー クラスタリングをインストールする前に (http://go.microsoft.com/fwlink/?LinkId=235034)

関連項目

参照

セットアップ サポート ルール


アンインストール オプションの確認

[image]

アンインストール オプションの確認
フィードバックの送信

選択を確認し、続行するには [次へ] をクリックします。


探しているトピックを利用できない

[image]

探しているトピックを利用できない
フィードバックの送信

セットアップの完了後に SQL Server のドキュメントを参照するには、[ヘルプ] をクリックするか、ダイアログ ボックスまたはインターフェイス要素が表示された状態で F1 キーを押します。または、[スタート] ボタンをクリックし、[すべてのプログラム]、[Microsoft SQL Server]、[ヘルプとコミュニティ] の順にポイントして、[SQL Server オンライン ブック] をクリックします。 詳細については、「ヘルプ コレクションの追加と削除」を参照してください。