SQL Server サービスのインストールの概要

[image]

SQL Server サービスのインストールの概要
関連項目 フィードバックの送信

SQL Server 2012 サービス更新プログラムが適用された、インストール済みの SQL Server 2012 コンポーネントに更新プログラムを適用できます。既存の SQL Server 2012 コンポーネントのバージョン レベルが更新のバージョン レベルより新しい場合、そのコンポーネントは、セットアップ プログラムによって自動的にアップデートから除外されます。サービスの更新プログラムの適用の詳細については、「SQL Server 2012 サービス更新プログラムのインストール」(http://go.microsoft.com/fwlink/?LinkId=231297) を参照してください。

SQL Server 2012 の更新プログラムをインストールする際は、次の点に注意してください。

  • 1 つの SQL Server インスタンスに属する機能はすべて同時にアップデートする必要があります。たとえば、データベース エンジンをアップデートする際に、同じ SQL Server インスタンスの一部として Analysis Services と Reporting Services がインストールされている場合は、それらのコンポーネントもアップデートする必要があります。管理ツール、SQL Server データ ツール (SSDT)、SQL Server Integration Services などの共有機能は、常に最新の更新プログラムで更新しておく必要があります。機能ツリーで選択されていないコンポーネントまたはインスタンスは、更新されません。

  • 既定では、SQL Server 2012 更新プログラムのログ ファイルは %Program Files%\Microsoft SQL Server\110\Setup Bootstrap\LOG\ に保存されます。

  • SQL Server のセットアップでは、更新プログラムと元のメディアを統合して、元のメディアと更新プログラムを同時に実行できるようになりました。詳細については、「SQL Server 2012 のインストールでの製品の更新プログラム」および「SQL Server インストールの新機能」(http://go.microsoft.com/fwlink/?LinkID=219508) を参照してください。

  • SQL Server 2012 サービス更新プログラムを適用する前に、データのバックアップを検討することをお勧めします。

  • SQL Server 更新プログラムは、Microsoft Update で入手できます。SQL Server のインスタンスを最新で安全な状態に保つために、更新プログラムを定期的に確認することをお勧めします。SQL Server 2012 SP1 は、SQL Server の完全なインストールとして提供されています。このリリースでは、SQL Server 2012 RTM インスタンスに適用される標準の修正プログラム実行可能パッケージとして Service Pack が提供されるのではなく、インストール パッケージ (2 ファイルで構成) が提供されます。これを実行すると、SP1 がプレインストールされた状態で SQL Server 2012 の新しいインスタンスがインストールされます。詳細については、「SQL Server 2012 SP1 の完全インストール」を参照してください。

要件および既知の問題

パッケージをインストール、ダウンロード、および展開するために必要な推奨ディスク領域は、パッケージのサイズの約 2.5 倍です。サービス パックのインストール後は、ダウンロードしたパッケージを削除できます。一時ファイルは、すべて自動的に削除されます。

既知の問題の確認: 現在のリリースの既知の問題の詳細については、「SQL Server リリース ノート」の対応するトピックを参照してください。

インストールの概要

ここでは、SQL Server 2012 の累積更新プログラムおよびサービス パックのインストール方法について、次の各操作を含めて説明します。

  • SQL Server 2012 更新プログラムのインストールの準備

  • SQL Server 2012 更新プログラムのインストール

  • サービスとアプリケーションの再起動

SQL Server 2012 更新プログラムのインストールの準備

SQL Server 2012 更新プログラムをインストールする前に、次のように対処することを強くお勧めします。

  • SQL Server システム データベースをバックアップする - SQL Server 2012 更新プログラムをインストールする前に、master データベース、msdb データベース、および model データベースをバックアップします。SQL Server 2012 更新プログラムをインストールするとこれらのデータベースは変更され、以前のバージョンの SQL Server 2012 と互換性がなくなります。これらの更新プログラムが適用されていない SQL Server 2012 を再インストールする場合には、これらのデータベースのバックアップ データが必要になります。

    また、必要なユーザー データベースのバックアップも行ってください。

    重要な注意事項 重要

    レプリケーション トポロジに含まれる SQL Server インスタンスに更新プログラムを適用する場合は、適用前に、システム データベースに加えてレプリケートされたデータベースもバックアップする必要があります。

  • Analysis Services データベース、構成ファイル、およびリポジトリをバックアップする - Analysis Services インスタンスを更新する前には、次のバックアップを行う必要があります。

    • Analysis Services データベース。既定では、C:\Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Data\ にインストールされています。WOW のインストールの場合、既定のパスは C:\ProgramFiles (x86)\Microsft SQL Server\MSAS11.<InstanceID>\OLAP\Data\ になります。

    • msmdsrv.ini 構成ファイル内の Analysis Services の構成設定。既定では、C:\Program Files\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Config\ ディレクトリにあります。

    • (省略可) Analysis Services リポジトリが格納されているデータベース。この手順が必要になるのは、Analysis Services が Decision Support オブジェクト (DSO) ライブラリを使用するように構成された場合のみです。

    注意 注

    Analysis Services データベース、構成ファイル、およびリポジトリをバックアップしなかった場合、更新された Analysis Services インスタンスを以前のバージョンに戻すことはできなくなります。

  • システム データベースに十分な空き領域があることを確認する - master システム データベースおよび msdb システム データベースに自動拡張オプションが選択されていない場合は、これらのデータベースにそれぞれ 500 KB 以上の空き領域が必要です。データベースに十分な空き領域があるかどうかを確認するには、master データベースと msdb データベースで sp_spaceused システム ストアド プロシージャを実行します。いずれかのデータベースで未割り当て領域が 500 KB より少ない場合は、データベースのサイズを増やします。

  • サービスとアプリケーションを停止する - システムの再起動を回避するために、SQL Server 2012 更新プログラムをインストールする前に、アップグレードする SQL Server インスタンスに接続しているすべてのアプリケーションとサービスを停止します。これには、SQL Server Management Studio および SQL Server データ ツール (SSDT) も含まれます。詳細については、「データベース エンジン、SQL Server エージェント、SQL Server Browser サービスの開始、停止、一時停止、再開、および再起動」を参照してください。

    注意 注

    フェールオーバー クラスター環境ではサービスを停止できません。詳細については、後のフェールオーバー クラスターのインストールに関するセクションを参照してください。

  • 更新プログラムのインストール後にコンピューターを再起動しなくてもいいように、セットアップではファイルをロックしているプロセスの一覧が表示されます。更新プログラムのセットアップ プログラムで、インストール中にサービスを終了する必要がある場合は、インストールの完了後にそのサービスが再起動されます。

  • セットアップで、インストール中にファイルがロックされていると認識された場合、インストール終了後にコンピューターの再起動が必要になることがあります。再起動が必要な場合は、コンピューターの再起動を促すメッセージが表示されます。

SQL Server 2012 更新プログラムのインストール

ここでは、インストール プロセスについて説明します。

重要な注意事項 重要

SQL Server 2012 更新プログラムは、この更新プログラムをインストールするコンピューターに対して管理者特権があるアカウントでインストールする必要があります。ローカル インストールの場合は、セットアップを管理者として実行する必要があります。SQL Server をリモート共有からインストールする場合は、そのリモート共有に対する読み取り権限と実行権限を持つドメイン アカウントを使用する必要があります。

SQL Server 2012 更新プログラムの開始

SQL Server 2012 更新プログラムをインストールするには、自己解凍形式のパッケージ ファイルを実行します。

累積更新プログラム パッケージ (CU): <SQLServer2012>-KBxxxxxx-PPP.exe

サービス パック パッケージ (PCU): <SQLServer2012><SPx> -KBxxxxxx-PPP-LLL.exe

  • x はサービス パックの番号を表します。

  • PPP は特定のプラットフォームを表します。

  • LLL は SQL Server 言語の省略形を表します。たとえば、英語の場合は LLL は ENU です。

フェールオーバー クラスターに含まれる SQL Server 2012 コンポーネントに更新プログラムを適用するには、フェールオーバー クラスターのインストールに関するセクションを参照してください。更新プログラムのインストールを自動モードで実行する方法の詳細については、「コマンド プロンプトからの更新プログラムのインストール」を参照してください。

SQL Server 2012 インストールの製品の更新プログラム

製品の更新プログラムは、SQL Server 2012 セットアップの新機能です。セットアップでは、メインの製品と適用可能な更新プログラムが同時にインストールされるように、最新の製品の更新プログラムとメインの製品のインストールが統合されます。製品の更新プログラムは、Microsoft Update、Windows Server Update Services (WSUS)、ローカル フォルダー、またはネットワーク共有で適用可能な更新プログラムを検索できます。セットアップで最新バージョンの適用可能な更新プログラムが検出されると、ダウンロードが実行されて、現在の SQL Server のセットアップ プロセスと統合されます。製品の更新プログラムは、累積更新プログラム、サービス パック、またはサービス パックと累積更新プログラムに取り込むことができます。製品の更新プログラム機能は、SQL Server 2008 PCU1 で提供されていたスリップストリーム機能を拡張したものです。SQL Server 2012 セットアップの製品の更新プログラム機能の詳細については、「SQL Server 2012 のインストールでの製品の更新プログラム」を参照してください。

SQL Server 2012 SP1 の完全インストール

SQL Server 2012 SP1 は、SQL Server の完全なインストール パッケージとして利用することもできます。SQL Server 2012 SP1 インストール パッケージでは、SP1 がプレインストールされた状態で SQL Server の新しいインスタンスがインストールされます。

このパッケージには、実行可能ファイルと圧縮形式のインストール ファイルが含まれます。各ファイルは、SQLServer2012SP1-<アーキテクチャ>-<言語>.exe および SQLServer2012SP1-<アーキテクチャ>-<言語>.box という形式です。

SQL Server 2012 SP1 のインストール時は、次の指示を確認してください。

  • ダウンロード ページから、デバイスの一時ディレクトリに次のファイルをダウンロードします。

    • SQLServer2012SP1-architecture-language.box

    • SQLServer2012SP1-architecture-language.exe

  • ダウンロードが完了したら、SQLServer2012SP1-<アーキテクチャ>-<言語>.exe をダブルクリックしてインストール処理を開始します。

  • [抽出したファイルのディレクトリを選択します] ダイアログには、既定のディレクトリ パスとして <現在のドライブ>\<現在の作業フォルダー>\<パッケージ名> が入力されています。たとえば、%temp%\SQLServer2012SP1-x64-ENU\ です。抽出したファイルのディレクトリ パスを変更するには、[参照] をクリックします。

  • パッケージは指定したインストール パスに解凍され、インストールの完了後も選択したディレクトリ パスに残されます。将来のインストールで、抽出フォルダー内のバイナリを使用できます。

  • インストール ウィザードで SQL Server インストール センターが実行されます。「インストール ウィザードからの SQL Server 2012 のインストール (セットアップ) (http://msdn.microsoft.com/library/ms143219.aspx)」に示されているインストール手順に従ってください。

次の表に、SQL Server 2012 SP1 パッケージの抽出に使用できるコマンド ライン パラメーターのいくつかを示します。

SP1 パッケージに直接指定することが可能な、サポートされているコマンド ライン パラメーターの詳しい一覧については、「コマンド プロンプトからの SQL Server 2012 のインストール (http://msdn.microsoft.com/library/ms144259.aspx)」を参照してください。

パラメーター | 説明
/x または -x | 指定されたパスにパッケージを抽出します。[抽出したファイルのディレクトリを選択します] ダイアログを開いた後、指定されたパスにパッケージを抽出します。 セットアップは実行しません。
/x:<パス> または -x:<パス> | 指定されたパスにパッケージを抽出します。セットアップは起動しません。
/q または -q | セットアップが、ユーザー インターフェイスなしで、非表示モードで実行されるように指定します。このパラメーターは、自動インストールに使用されます。
/l:<パス> または -l:<パス> | 既定では、ログ ファイルは temp ディレクトリに SQLServer2012SPx-<アーキテクチャ>-<言語>_decompression_log.txt という名前で保存されます。 このパラメーターを使用して、指定したパスに抽出ログ ファイルを生成します。 例: SQLServer2012SP1-x64-ENU /x /l:<パス> このオプションは /x または -x と共に使用するか、/x:<パス> または -x:<パス> と共に使用する必要があります。

SQL Server の準備済みイメージの更新

未構成の準備済み SQL Server インスタンスの構成を完了しなくても、そのインスタンスに更新プログラムを適用できます。準備済み SQL Server インスタンスに更新プログラムを適用するさまざまな方法について説明します。

  • 事前に準備された SQL Server インスタンスを更新する。

    準備済みインスタンスに対する更新プログラムは、構成前に適用することができます。更新プログラム パッケージは、インスタンスが準備された状態であることを検出すると、その準備済みインスタンスに修正プログラムを適用します。その際、構成は完了しません。

  • Microsoft Update を使用して準備済みインスタンスを更新する。

    Microsoft Update を使用して、準備済み SQL Server インスタンスに更新プログラムを適用できます。Microsoft Update パッケージは、インスタンスが準備された状態であることを検出すると、その準備済みインスタンスに修正プログラムを適用します。その際、構成は完了しません。

SQL Server の準備済みイメージを更新している場合は、InstanceID パラメーターを指定する必要があります。詳細およびサンプル構文については、「コマンド プロンプトからの更新プログラムのインストール」を参照してください。

SQL Server の完了したイメージの更新

完了および構成済みの SQL Server インスタンスを更新するには、インストールされているその他の SQL Server インスタンスと同じプロセスに従います。

SQL Server 2012 フェールオーバー クラスター ノードの再構築

更新プログラムの適用後にフェールオーバー クラスター内のノードを再構築する必要がある場合は、次の手順を実行します。

  1. フェールオーバー クラスター内のノードを再構築します。ノードの再構築の詳細については、「フェールオーバー クラスター インスタンス障害からの復旧」を参照してください。

  2. 元の SQL Server 2012 セットアップ プログラムを実行して、フェールオーバー クラスター ノードに SQL Server 2012 をインストールします。

  3. 追加したノードに対して SQL Server 2012 更新プログラムのセットアップを実行します。

サービスとアプリケーションの再起動

セットアップ プログラムの完了時に、コンピューターの再起動が必要になる場合があります。システムを再起動した後、または再起動を求められることなくセットアップ プログラムが終了した後は、コントロール パネルの [サービス] ノードを使用して、SQL Server 2012 更新プログラムの適用前に停止したサービスを再起動します。たとえば、分散トランザクション コーディネーター サービスや Microsoft Search サービスのようなサービス、またはインスタンス固有のサービスなどを再起動します。

次に、SQL Server 2012 更新プログラムのセットアップの実行前に終了したアプリケーションを再起動します。インストールが正常に終了した直後に、アップグレード後の master データベース、msdb データベース、および model データベースをバックアップすることもお勧めします。

SQL Server 2012 の更新プログラムのアンインストール

SQL Server 2012 累積更新プログラムおよびサービス パックのアンインストールは、コントロール パネルの [プログラムと機能] で行うことができます。インストールされた更新プログラムの一覧を表示するには、[スタート] ボタンをクリックし、[コントロール パネル] をクリックします。[プログラム]、[プログラムと機能]、[インストールされた更新プログラムを表示] の順にクリックして、[インストールされた更新プログラム] を開きます。各累積更新プログラムは、個別に表示されています。ただし、累積更新プログラムより新しいサービス パックがインストールされていると、累積更新プログラムの項目が表示されなくなるため、サービス パックをアンインストールしないと個別の項目を利用できません。

サービス パックおよび更新プログラムをアンインストールするには、SQL Server のインスタンスに適用されている最新のものから古いものへと順番に処理していってください。以下の各例では、サービス パックおよび更新プログラムをアンインストールすることによって、SQL Server は Cumulative Update 1 の状態になります。

  • SQL Server 2012 のインスタンスに Cumulative Update 1 および SP1 がインストールされている場合、SP1 をアンインストールします。

  • SQL Server 2012 のインスタンスに Cumulative Update 1、SP1、および Cumulative Update 2 がインストールされている場合、まず Cumulative Update 2 をアンインストールし、次に SP1 をアンインストールします。

関連項目

その他の技術情報

コマンド プロンプトからの SQL Server 2012 のインストール
SQL Server 2012 サービス更新プログラムのインストール
SQL Server のインストールの検証
SQL Server セットアップ ログ ファイルの表示と読み取り
このトピックに関するフィードバックを Microsoft に送る

© 2012 Microsoft Corporation.All rights reserved.


ドキュメントの免責事項

[image]

ドキュメントの免責事項
フィードバックの送信

このドキュメントは現状有姿で提供され、 このドキュメントに記載されている情報や見解 (URL 等のインターネット Web サイトに関する情報を含む) は、将来予告なしに変更されることがあります。 お客様は、その使用に関するリスクを負うものとします。

ここで使用される例は架空のものであり、説明のためだけに使用されます。 実在するものとは一切関係ありません。

このドキュメントは、Microsoft 製品の無体財産権に関する法的な権利をお客さまに許諾するものではありません。 内部的な参照目的に限り、このドキュメントを複製して使用することができます。

© 2012 Microsoft. All rights reserved.

Microsoft、Active Directory、ActiveX、Bing Maps、Excel、IntelliSense、MSDN、MS-DOS、PivotChart、PivotTable、PowerPoint、SharePoint、SQL Server、Visual Basic、Visual C#、Visual C++、Visual Studio、Windows、Windows NT、Windows Server、および Windows Vista は、Microsoft Corporation およびその関連会社の商標です。 SAP NetWeaver は、ドイツ SAP AG のドイツおよびその他の国における登録商標または商標です。 記載されている会社名、製品名には、各社の商標のものもあります。

SQL Server のサポートおよびアップグレードに関するドキュメント ポリシー

SQL Server 2012 ソフトウェア マニュアルには、マイクロソフトによって発行された SQL Server 2012 の Microsoft オンライン ブック、インストール マニュアル、デベロッパー向けリファレンス マニュアル、チュートリアル、Readme ファイル、既知の問題、サンプル コード、サンプル データベース、サポート技術情報などがあり、それらすべてに SQL Server の特徴および機能に関する内容が含まれています。 このサポートおよびアップグレードに関するポリシーは、SQL Server 2012 リリースおよびサービス パックの Readme ファイルを含む SQL Server 2012 ドキュメントに適用されます。Readme は、SQL Server 2012 オンライン ブックの追加ファイルとして扱われます。

このマニュアルに含まれているサンプルは、概念や特定のステートメントまたは句の利用方法の説明を主目的として提供されています。 多くのサンプルは、特定の概念やステートメントの説明のみを目的としているため、通常の実稼働システムで必要となるようなデータ評価やエラー処理のコードは含んでいません。 提供されているサンプルおよびソース コードに対するテクニカル サポートは行っていません。

SQL Server 2012 の機能によっては、十分なテストまたは開発が行われていないものもあり、利用を想定していない場合があります。 多くの場合、このような機能はプレースホルダーとして含まれています。 したがって、ソフトウェアに含まれている機能の中にはドキュメントに記載されていないものもあります。 ドキュメントに記載されていない機能またはマイクロソフト内部で使用することが表記されている機能は、利用を想定していないので、マイクロソフト カスタマー サポート サービスではサポートされません。 SQL Server 2012 ドキュメントに記載されていない限り、第三者が発行した内容 (SQL Server 2012 で第三者が発行した内容を使用することによって生じた問題を含む) はマイクロソフト カスタマー サポート サービスではサポートされず、その内容を使用することでデータが失われる可能性もあります。 また、マイクロソフト カスタマー サポート サービスでは、公開されていないエントリ ポイントを使用または応用したデータベースやアプリケーションもサポートされません。このようなエントリ ポイントには、ストアド プロシージャ、拡張ストアド プロシージャ、関数、ビュー、テーブル、列、プロパティ、メタデータなどの公開されていない API が挙げられます。

また、このようなデータベースやアプリケーションについて、サーバーおよびデータベースを SQL Server 2012 の将来のバージョンにアップグレードする場合も、動作は保証されずサポート対象外となります。 SQL Server 2012 ドキュメントに記載されていない Microsoft SQL Server の機能の使用はサポートされず、そのような機能を使用することでデータが失われる可能性もあります。


コマンド プロンプトからの更新プログラムのインストール

[image]

コマンド プロンプトからの更新プログラムのインストール
関連項目 フィードバックの送信

インストール スクリプトをテストし、必要に応じて変更してください。SQL Server フェールオーバー クラスターに対する更新プログラムのインストールの詳細については、Microsoft サポート技術情報の「SQL Server 更新プログラムをフェールオーバー クラスター インスタンスに適用する方法」を参照してください。

インストールのサンプル構文

更新プログラム パッケージの名前はさまざまであり、言語、エディション、およびプロセッサ コンポーネントが含まれる場合があります。コマンド プロンプトで更新プログラムを適用する際に、<package_name> の部分は実際の更新プログラム パッケージの名前に置き換えてください。

  • SQL Server の 1 つのインスタンスと、Integration Services や管理ツールなどのすべての共有コンポーネントを更新します。インスタンスを指定するには、InstanceName パラメーターまたは InstanceID パラメーターを使用します。準備済み SQL Server インスタンスを更新するには、InstanceID パラメーターに、<package_name>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /InstanceName=MyInstance または <package_name>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /InstanceID=<Instance ID> を指定する必要があります。

  • セットアップでは、メインの製品と使用可能な更新プログラムが同時にインストールされるように、最新の製品の更新プログラムとメインの製品のインストールを統合できます。製品の更新プログラムが含まれるデータベース エンジン インスタンスのインストールを準備するには、setup.exe /q /IAcceptSQLServerLicenseTerms /ACTION=PrepareImage /UpdateEnabled=True /UpdateSource=<更新プログラムがダウンロードされたパス> /INSTANCEID=<Instance ID> /FEATURES=SQLEngine を実行します。

  • Integration Services や管理ツールなどの SQL Server 共有コンポーネントのみを更新するには、<package_name>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch を実行します。

  • コンピューター上のすべての SQL Server インスタンスと、Integration Services や管理ツールなどのすべての共有コンポーネントを更新するには、<package_name>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /AllInstances を実行します。

コマンド プロンプトで更新プログラムを削除する際に、<package_name> の部分は実際の更新プログラム パッケージの名前に置き換えてください。

  • SQL Server の 1 つのインスタンスと、Integration Services や管理ツールなどのすべての共有コンポーネントから更新プログラムを削除するには、<package_name>.exe /qs /Action=RemovePatch /InstanceName=MyInstance を実行します。

  • Integration Services や管理ツールなどの SQL Server 共有コンポーネントのみから更新プログラムを削除するには、<package_name>.exe /qs /Action=RemovePatch を実行します。

    注意 注

    更新プログラムのインストーラーによって、共有コンポーネントが常に最上位レベルのインスタンスのバージョンと同じかまたはそれ以上であることが保証されます。

サポートされているコマンド プロンプト パラメーター

重要な注意事項 重要

セキュリティ資格情報は、できるだけ実行時に入力してください。資格情報をスクリプト ファイルに含める必要がある場合は、不正なアクセスが行われないようにファイルをセキュリティで保護してください。

スイッチ | 説明
/? | 自動インストールのコマンド プロンプト ヘルプを表示します。
/action=Patch or /action=RemovePatch | インストール動作 (Patch または RemovePatch) を指定します。
/allinstances | SQL Server 更新プログラムを、すべての SQL Server インスタンスとすべての SQL Server コンポーネント (共有、インスタンス非対応) に適用します。
/instancename=InstanceName1 | SQL Server 更新プログラムを、InstanceName という名前の SQL Server インスタンスとすべての SQL Server コンポーネント (共有、インスタンス非対応) に適用します。
/InstanceID=Inst1 | SQL Server 更新プログラムを、Inst1 という SQL Server インスタンスとすべての SQL Server コンポーネント (共有、インスタンス非対応) に適用します。
/quiet | SQL Server 更新プログラムのセットアップを自動モードで実行します。
/qs | 進行状況 UI ダイアログのみを表示します。
/UpdateEnabled | SQL Server セットアップが製品の更新プログラムを検出し、それらを含める必要があるかどうかを指定します。有効値は True および False または 1 および 0 です。既定では、SQL Server セットアップには検出された更新プログラムが含まれます。
/UpdateSource | SQL Server セットアップが製品の更新プログラムを取得する場所を指定します。有効値は Microsoft Update を検索する "MU"、有効なフォルダー パス、相対パス (.\MyUpdates など)、または UNC 共有です。既定では、SQL Server セットアップは Microsoft Update または Windows Server Update Services を介して Windows Update Service を検索します。
/IAcceptSQLServerLicenseTerms | 自動インストールのために /Q パラメーターまたは /QS パラメーターを指定した場合にのみ必要になります。

1 準備済み SQL Server インスタンスに更新プログラムを適用するために、このパラメーターを指定することはできません。代わりに /instanceID パラメーターを指定してください。

関連項目

概念

SQL Server サービスのインストールの概要


SQL Server 更新プログラムのインストールが成功したかどうかを確認する方法

[image]

SQL Server 更新プログラムのインストールが成功したかどうかを確認する方法
関連項目 フィードバックの送信

SQL Server 更新プログラムのインストールが成功したかどうかを確認するには

  • SQL Server サービスがオンラインになっていることを確認します。

  • @@version クエリから返されるバージョン情報を確認します。

関連項目

概念

SQL Server サービスのインストールの概要


SQL Server の参考資料の入手

[image]

SQL Server の参考資料の入手
関連項目 フィードバックの送信

SQL Server に関して Microsoft が提供している主な情報ソースは次の 3 つです。

  • SQL Server オンライン ブックにローカル コレクションとしてインストールされているドキュメント。

  • Microsoft Developer Network (MSDN) および TechNet 上の SQL Server サイト。

  • その他の Microsoft Web サイト上の SQL Server に関する情報。

探している情報がこれらのソースで見つからない場合は、SQL Server コミュニティのフォーラムやニュースグループに質問を投稿したり、Microsoft と協力してサポート ケースを調査したりできます。

SQL Server オンライン ブック

SQL Server オンライン ブックでは、SQL Server を使用するために必要となる概念と手順について説明します。 また、オンライン ブックには、SQL Server を使用したデータの格納、取得、報告、および変更を行うための言語やプログラミング インターフェイスについての参考資料も含まれています。

オンライン ブックは次の方法で表示できます。

  • SQL Server 2012 オンライン ブックのコピーが、インターネット上の MSDN ライブラリと TechNet ライブラリの両方で公開されています。 このような SQL Server オンライン ブックのコピーのトピックには、他のユーザーからの追加情報やコード例など、コミュニティからのコメントが含まれています。 MSDN ライブラリ版は、SQL Server 2012 オンライン ブックで確認できます。

  • ヘルプ ライブラリ マネージャーを使用して、SQL Server オンライン ブックをローカル コンピューターにインストールできます。 詳細については、「ヘルプ コレクションを追加または削除する」を参照してください。

MSDN ライブラリの SQL Server オンライン ブックのコピーと、ヘルプ ライブラリ マネージャーで利用できるオンライン ブック ファイルは共に、Microsoft が SQL Server オンライン ブックへの更新を公開した時点で更新されます。

MSDN および TechNet 上の情報

Microsoft Developer Network (MSDN) では、開発者が Microsoft の製品やテクノロジを使用してアプリケーションを作成する際に役立つ、オンラインおよびオフラインのサービスを提供しています。 Microsoft TechNet プログラムによって、IT の専門家による Microsoft ソリューションの効率的な評価、配置、およびサポートを支援するための総合的な技術リソースが提供されます。

MSDN および TechNet 上のいくつかのサイトでは、MSDN または TechNet の SQL Server オンライン ブックの情報を含め、各ユーザーの業務に最も関連性の高い SQL Server 情報へのリンクが提供されています。 また、これらのサイトには、SQL Server オンライン ブックで利用可能な情報を拡張する情報も含まれています。

次の表は、これらのリソースと対象となるユーザーを示しています。

リソース | 対象ユーザー
SQL Server デベロッパー センター | SQL Server データベース、レポート システム、およびビジネス インテリジェンス ソリューションを構築し、アプリケーションと Web サイトがこれらのシステムを使用できるようにする開発者。
データ アクセスおよびストレージ デベロッパー センター | アプリケーションや Web サイトで、SQL Server や Access などの製品を使用して格納されたデータを使用できるようにする開発者。
XML デベロッパー センター | データの格納と操作を行うために XML を使用するサイトおよびアプリケーションを作成する、Web サイト作成者およびアプリケーション開発者。
SQL Server TechNet サイト | SQL Server を使用して、システムの計画、配置、管理、およびサポートを行う管理者およびオペレーター。

その他のオンライン情報

その他の SQL Server 情報は、次の Microsoft Web サイトから利用可能です。

リソース | 説明
Microsoft SQL Server | データ ストレージおよびビジネス インテリジェンス ツールとしての SQL Server の評価に関する発売前情報を提供します。
サポート技術情報 | Microsoft サポートで作成された SQL Server 記事を検索できるリポジトリを提供します。
Microsoft ラーニング | SQL Server の Microsoft トレーニングおよび認定資格について説明します。
マイクロソフト プレス | SQL Server に関する Microsoft プレスの書籍一覧です。

その他の参考資料

探している情報が製品のドキュメントや Web 上で見つからない場合は、SQL Server コミュニティのフォーラムやニュースグループで質問することができます。 また、ご購入元に問い合わせることもできます。

注意 注

MSDN ライブラリまたは TechNet ライブラリの SQL Server オンライン ブックのトピックの一番下にある「コミュニティ コンテンツ」セクションには質問を投稿しないでください。 このセクションは質問を閲覧するためのものではないため、通常は回答が得られません。 質問は、コミュニティのフォーラムまたはニュースグループに投稿してください。これらは、質問に回答できる他のユーザーによって閲覧されています。

次の表は、リソースへのリンクとその説明を示しています。

リソース | 説明
SQL Server の IT プロフェッショナル コミュニティ | SQL Server コミュニティが管理するニュースグループおよびフォーラムへのリンクを提供します。 ブログや Web サイトなど、コミュニティ情報のソースも一覧表示されます。 SQL Server コミュニティは、回答が得られるという保証はありませんが、問題解決に役立てることができます。
SQL Server デベロッパー センター コミュニティ | このサイトは、SQL Server の開発者にとって役立つニュースグループ、フォーラム、およびその他のコミュニティ リソースに焦点を当てています。
Microsoft ヘルプとサポート | この Web サイトを利用して、Microsoft のサポート担当者と共にサポート ケースを調査できます。

Microsoft 製品には、各リリースに利用できるサポート期間を定めたサポート ライフサイクルがあります。 Microsoft サポートが、Microsoft サポート ライフサイクルを定めたページを管理しています。 このページには、Microsoft 製品のサポートが利用可能かどうかを指定した別のページへのリンクが含まれています。 詳細については、Microsoft サポート ライフサイクルを参照してください。

関連項目

概念

SQL Server の製品ドキュメントの使用


[ようこそ]

[image]

[ようこそ]
フィードバックの送信

インストール ルールで、更新プログラムをインストールするコンピューターをスキャンします。


ライセンス条項

[image]

ライセンス条項
フィードバックの送信

[ライセンス条項] ページを使用して、このリリースのライセンス条項に同意します。

オプション

インストールを続行するには、SQL Server のライセンス条項に同意する必要があります。

このリリースのライセンス条項を印刷するには、[印刷] ボタンを使用します。 インストールを終了するには、[キャンセル] をクリックします。


[機能の選択]

[image]

[機能の選択]
フィードバックの送信

[機能の選択] ページを使用して、更新する SQL Server のコンポーネントおよび機能を選択します。

オプション

左ペインの機能名をクリックして、言語、オペレーティング システム、エディション、状態の詳細を確認します。

コンポーネントまたは機能を更新するには、機能名の隣のチェック ボックスをオンにします。 コンポーネントまたは機能を更新の対象外とするには、機能名の隣のチェック ボックスをオフにします。

1 台のコンピューター上にある複数の SQL Server インスタンスは個別に更新できますが、1 つの SQL Server インスタンス内のコンポーネントはすべて同時に更新する必要があります。 ワークステーション コンポーネント、MSXML パーサー、SQLXML、旧バージョンとの互換性コンポーネント、VSS Writer などの共有コンポーネントはすべて更新する必要があります。

更新できないコンポーネントがある場合は、[詳細] ペインに説明が表示されます。


使用中のファイルの確認

[image]

使用中のファイルの確認
フィードバックの送信

SQL Server 更新プログラムのインストール後に Windows が再起動されないようにするには、[使用中のファイルの確認] ページを使用して、SQL Server 更新プログラムのセットアップ プログラムで必要とされるファイルをロックしているプロセスを特定します。

更新する SQL Server インスタンスに接続しているすべてのアプリケーションとサービスを停止します。 これには SQL Server Management Studio および SQL Server データ ツール (SSDT) を停止することが含まれます。

セットアップで、インストール中にファイルがロックされていると認識された場合、インストール完了後にコンピューターの再起動が必要になることがあります。 再起動が必要な場合は、コンピューターの再起動を促すメッセージが表示されます。 セットアップ プログラムで、インストール中にサービスを終了する必要がある場合は、インストールの完了後にそのサービスが再起動されます。

インストール後にコンピューターを再起動しなくてもいいように、セットアップ時に、ファイルをロックしているプロセスの一覧が表示されます。 一覧表示されたプロセスおよびアプリケーションを停止または終了します。 次に、[確認の更新] をクリックしてチェックを再実行します。 実行中のチェックを終了するには [確認の停止] をクリックします。 ロックされているファイルが見つからなかった場合、表には何も表示されません。 ロックされていたプロセスが終了または停止したら、[次へ] をクリックして続行します。

セットアップにより、情報がログ ファイルに書き込まれます。 ログ ファイルを表示する方法の詳細については、「SQL Server セットアップ ログ ファイルを表示する方法」および「SQL Server のセットアップ ログ ファイルを読み取る方法」を参照してください。

次の情報がログ ファイルに含まれます。

  • プロセスの名前

  • SQL Server 機能の名前

  • プロセスの種類

  • プロセスが実行されているアカウント

  • プロセス ID

  • ロックされているファイルの名前

名前 | 説明
プロセス | 更新対象のファイルを使用しているプロセスの完全な名前を表示します。
型 | プロセスの種類を表示します。
アカウント | プロセスが実行されているアカウントを表示します。
プロセス ID | プロセス ID を表示します。


更新準備完了

[image]

更新準備完了
フィードバックの送信

[概要] ページを使用して、SQL Server のインスタンスに適用される変更を確認します。 インストールを続行するには、[インストール] をクリックします。


更新の進行状況

[image]

更新の進行状況
フィードバックの送信

[インストールの進行状況] ページを使用して、SQL Server インスタンスとそのコンポーネントに更新プログラムを適用する際にセットアップを監視します。

オプション

SQL Server の製品名、インスタンス名、インストールの状態が表で示されます。


完了

[image]

完了
フィードバックの送信

[完了] ページで、インストールの状態を確認します。