Visão geral da documentação de instalação do SQL Server

 Copiar imagem em foco
[image]

Visão geral da documentação de instalação do SQL Server
Enviar Comentários

A documentação de Instalação do SQL Server está disponível online e na mídia de instalação.

Documentação disponível durante a Instalação

Durante a instalação do SQL Server, clique no botão Ajuda na página Assistente de Instalação ou pressione F1 no teclado para obter informações imediatas necessárias para concluir a operação.

Visão geral dos tópicos da instalação do SQL Server

Quer você esteja usando o Assistente de Instalação do SQL Server ou o prompt de comando para instalar o SQL Server, poderá preparar-se para a instalação lendo as seguintes seções:

  • Planejando a instalação do SQL Server.

    Descreve como preparar-se para instalar o SQL Server.

  • Instalar o SQL Server 2012

    Descreve as opções para instalar o SQL Server.

  • Instalar os recursos de BI do SQL Server 2012

    Descreve as opções para instalar os recursos do SQL Server que são parte da plataforma Microsoft BI e que incluem Analysis Services, Integration Services, Reporting Services, e vários aplicativos cliente usados para criação ou funcionamento com dados analíticos.

  • Atualizar para o SQL Server 2012

    Descreve as opções para atualizar para o SQL Server.

Se você estiver instalando um cluster de failover do SQL Server, revise o seguinte:

  • Introdução ao clustering de failover do SQL Server.

  • Antes de instalar o clustering de failover.

Imagem de rodapé
Forneça comentários sobre este tópico à Microsoft

© 2012 Microsoft Corporation. Todos os direitos reservados.


Sobre os termos de licença do SQL Server

 Copiar imagem em foco
[image]

Sobre os termos de licença do SQL Server
Consulte também Enviar Comentários

Os Termos da Licença de Software do Microsoft são copiados para o computador local quando o SQL Server é instalado. Quando várias instâncias da mesma edição e do mesmo idioma do SQL Server estão instaladas no mesmo computador, uma única cópia dos termos de licença será aplicável a todas as instâncias dessa edição e idioma. Os arquivos são gravados em: %ProgramFiles%\Microsoft SQL Server\110\License Terms\ ou em %ProgramFiles(x86)%\Microsoft SQL Server\110\License Terms\.

Quando várias instâncias da mesma edição e do mesmo idioma do SQL Server estão instaladas no mesmo computador, uma única cópia dos termos da licença é aplicável a todas as instâncias dessa edição e idioma.

O nome do arquivo dos termos de licença indica a edição do SQL Server, bem como a edição do idioma do SQL Server. Por exemplo:

  • License_DEV_ENU.txt para o SQL Server Developer, edição do idioma inglês.

  • License_STD_ITA.txt para o SQL Server Standard, edição do idioma italiano.

  • License_UA_JPN.txt para o Supervisor de Atualização do SQL Server, edição do idioma japonês.

  • License_SQLNCLI_ENU.txt para SQL Server Native Client, edição no idioma inglês.

  • License_SQLXML4_KOR.txt para o SQLXML, edição do idioma coreano.

  • License_SQLBI.rtf para o SQL Server edição Business intelligence.

  • License_ENTCORE.rtf para o SQL Server edição Enterprise: Licenciamento Baseado em Núcleo.

  • License_ENT.rtf para Licenciamento de Servidor/CAL do SQL Server edição Enterprise.

Os seguintes segmentos de nome de arquivo são usados para identificar edições do SQL Server:

  • ENT – edição Enterprise: licenciamento CAL (licença servidor/cliente)

  • ENTCORE – edição Enterprise: licenciamento baseado em núcleo

  • BI – Business Intelligence

  • DEV – Developer

  • STD – Standard

  • WEB – Web

  • EXPR – Express

Os seguintes segmentos de nome de arquivo são usados para identificar idiomas do SQL Server correspondentes:

  • ENU - inglês

  • JPN - japonês

  • FRA - francês

  • ITA - italiano

  • KOR - coreano

  • DEU - alemão

  • ESN - espanhol

  • CHS - chinês simplificado

  • CHT - chinês tradicional

  • PTB - português (Brasil)

  • RUS - russo

Opções de licenciamento do SQL Server

Para obter mais informações sobre opções de preço e licenciamento do SQL Server, consulte o site do Microsoft SQL Server (http://go.microsoft.com/fwlink/?LinkId=190955).

Consulte também

Conceitos

Considerações sobre licenciamento do SQL Server
Política de privacidade do Microsoft SQL Server
Aviso legal para documentação


Considerações sobre licenciamento do SQL Server

 Copiar imagem em foco
[image]

Considerações sobre licenciamento do SQL Server
Consulte também Enviar Comentários

Para obter mais informações sobre opções de licenciamento do SQL Server, acesse este site do Microsoft SQL Server.

Consulte também

Referência

Sobre os termos de licença do SQL Server

Conceitos

Política de privacidade do Microsoft SQL Server
Aviso legal para documentação


Aviso legal para documentação

 Copiar imagem em foco
[image]

Aviso legal para documentação
Enviar Comentários

Este documento é fornecido "como está". As informações e opiniões expressas neste documento, inclusive URLs e outras referências a sites da Internet, podem ser alteradas sem aviso prévio. Você se responsabiliza por usá-lo.

Alguns exemplos representados aqui são fornecidos apenas para ilustração e são fictícios. Nenhuma associação real ou conexão é desejada ou deve ser inferida.

Este documento não dá nenhum direito legal a nenhuma propriedade intelectual em qualquer produto Microsoft. Você pode copiar e usar este documento para fins de referência interna.

© 2012 Microsoft. Todos os direitos reservados.

Microsoft, Active Directory, ActiveX, Bing Maps, Excel, IntelliSense, MSDN, MS-DOS, Gráfico Dinâmico, Tabela Dinâmica, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual Studio, Windows, Windows NT, Windows Server e Windows Vista são marcas registradas do grupo de empresas Microsoft. SAP NetWeaver é marca registrada da SAP AG na Alemanha e em vários outros países. Todas as outras marcas comerciais pertencem a seus respectivos proprietários.

Política de documentação para suporte e atualização do SQL Server

A documentação do software Microsoft SQL Server 2012 inclui Manuais Online da Microsoft para o Microsoft SQL Server 2012, documentação da instalação, documentação de referência do desenvolvedor, tutoriais, arquivos leiame, documentos sobre problemas conhecidos, código/aplicativos de exemplo, bancos de dados de exemplo e artigos da Base de Dados de Conhecimento publicados pela Microsoft, todos com conteúdo sobre os recursos e a funcionalidade do SQL Server. Essa política de suporte e atualização se aplica a toda a documentação do Microsoft SQL Server 2012, incluindo arquivos leiame de versões e service packs do Microsoft SQL Server 2012; um arquivo leiame é considerado uma extensão dos Manuais Online do Microsoft SQL Server 2012.

A principal finalidade de um exemplo contido nesta documentação é ilustrar um conceito ou uso razoável de uma determinada instrução ou cláusula. A maioria dos exemplos não inclui todo o código geralmente encontrado em um sistema de produção completo, pois algumas das funções comuns de validação de dados e tratamento de erros foram removidas para focalizar o exemplo em um determinado conceito ou instrução. Não há suporte técnico para esses exemplos nem para quaisquer códigos-fonte incluídos.

Em alguns casos, um recursos específico do Microsoft SQL Server 2012 não foi suficientemente testado ou desenvolvido e não é destinado para seu uso. Tais recursos normalmente estão lá como espaços reservados. Portanto, determinados recursos incluídos no software não estão documentados. Os recursos que não estão documentados ou que estão incluídos como uma notação para uso interno da Microsoft não são destinados para seu uso e não é dado suporte pelos Serviços de Atendimento ao Cliente da Microsoft. A menos que a documentação do Microsoft SQL Server 2012 indique o contrário, o conteúdo de terceiros, incluindo problemas resultantes do uso de tal conteúdo de terceiros com o Microsoft SQL Server 2012, não tem suporte dos Serviços de Atendimento ao Cliente da Microsoft e pode resultar em perda de dados. Os Serviços de Atendimento ao Cliente da Microsoft também não dão suporte a bancos de dados ou aplicativos que aproveitem ou usem pontos de entrada não documentados, como APIs não documentadas, incluindo, mas não se limitando a: procedimentos armazenados, procedimentos armazenados estendidos, funções, exibições, tabelas, colunas, propriedades ou metadados.

Atualizações de servidor e banco de dados para versões futuras do Microsoft SQL Server 2012 relativos a aplicativos e bancos de dados que aproveitem e usem pontos de entrada não documentados também podem não funcionar e não têm suporte. O uso de recursos e funcionalidade do SQL Server incluídos no Microsoft SQL Server que não estejam incluídos na documentação do Microsoft SQL Server 2012 para seu uso não tem suporte, e tal uso pode causar perda de dados.


Política de privacidade do Microsoft SQL Server

 Copiar imagem em foco
[image]

Política de privacidade do Microsoft SQL Server
Enviar Comentários

Para obter informações sobre componentes de coleta de dados de usuário no Microsoft SQL Server 2012, consulte a Política de privacidade do SQL Server.


Locais de arquivos para instâncias padrão e nomeadas do SQL Server

 Copiar imagem em foco
[image]

Locais de arquivos para instâncias padrão e nomeadas do SQL Server
Consulte também Enviar Comentários

Uma instalação do SQL Server consiste em uma ou mais instâncias separadas. Uma instância, seja padrão ou nomeada, tem seu próprio conjunto de arquivos de programas e de dados, bem como um conjunto de arquivos comuns compartilhados entre todas as instâncias do SQL Server no computador.

Para uma instância do SQL Server que inclui o Mecanismo de Banco de Dados, o Analysis Services e o Reporting Services, cada componente tem um conjunto completo de arquivos executáveis e de dados, além de arquivos comuns compartilhados por todos os componentes.

Para isolar locais de instalação para cada componente, IDs de instância exclusivos são gerados para cada componente em uma determinada instância do SQL Server.

Observação importante Importante

Os arquivos de programas e os arquivos de dados não podem ser instalados em uma unidade de disco removível, em um sistema de arquivos que usa compactação, em um diretório onde os arquivos do sistema estão localizados e em unidades compartilhadas em uma instância de cluster de failover.

Não exclua nenhum dos seguintes diretórios ou seus conteúdos: Binn, Data, Ftdata, HTML ou 1046. Você pode excluir outros diretórios, se necessário; entretanto, talvez você não possa recuperar alguma funcionalidade ou dados perdidos sem desinstalar e depois reinstalar o SQL Server. Não exclua, nem modifique quaisquer dos arquivos .htm no diretório de HTML. Eles são necessários para que as ferramentas do SQL Server funcionem corretamente.

Arquivos compartilhados para todas as instâncias do SQL Server

Arquivos comuns, usados por todas as instâncias em um único computador, são instalados na pasta <unidade>:\Arquivos de Programas\Microsoft SQL Server\110\, onde <drive> corresponde à letra da unidade em que os componentes estão instalados. Em geral, o padrão é a unidade C.

Locais de arquivo e mapeamento de registro

Durante a Instalação do SQL Server, um ID de instância é gerado para cada componente do servidor. Os componentes de servidor nesta versão do SQL Server são o Mecanismo de Banco de Dados, o Analysis Services e o Reporting Services.

O ID da instância padrão é construído usando o seguinte formato:

  • MSSQL para o Mecanismo de Banco de Dados, seguido pelo número de versão principal, seguido por um sublinhado e a versão secundária, quando aplicável, e um ponto, seguidos pelo nome da instância.

  • MSAS para o Analysis Services, seguido pelo número de versão principal, seguido por um sublinhado e a versão secundária, quando aplicável, e um ponto, seguidos pelo nome da instância.

  • MSRS para o Reporting Services, seguido pelo número de versão principal, seguido por um sublinhado e a versão secundária, quando aplicável, e um ponto, seguidos pelo nome da instância.

Estes são alguns exemplos de IDs de instância padrão nesta versão do Microsoft SQL Server 2012:

  • MSSQL11.MSSQLSERVER para uma instância padrão do Microsoft SQL Server 2012.

  • MSAS11.MSSQLSERVER para uma instância padrão do Analysis Services.

  • MSSQL11.MyInstance para uma instância nomeada do Microsoft SQL Server 2012 denominada "MyInstance."

A estrutura de diretórios de uma instância nomeada do Microsoft SQL Server 2012 que inclua o Mecanismo de Banco de Dados e o Analysis Services, denominada "MyInstance" e instalada nos diretórios padrão seria a seguinte:

  • C:\Arquivos de Programas\Microsoft SQL Server\MSSQL11.MyInstance\

  • C:\Arquivos de Programas\Microsoft SQL Server\MSASSQL11.MyInstance\

Você pode especificar qualquer valor para o ID da instância, mas evite caracteres especiais e palavras-chave reservadas. Para obter mais informações, consulte Reserved Keywords (Setup).

Você pode especificar um ID de instância não padrão durante a Instalação do SQL Server. Em vez de <Arquivos de Programas>\Microsoft SQL Server, um <caminho personalizado>\Microsoft SQL Server será usado se o usuário optar por alterar o diretório de instalação padrão. Observe que as IDs de instância que começam com sublinhado (_) ou contêm o sinal numérico (#) ou o cifrão ($) não têm suporte.

Observação Observação

O Integration Services e os componentes cliente não reconhecem instâncias e, portanto, não recebem uma ID de instância. Por padrão, componentes que não reconhecem instâncias são instalados em um único diretório: <unidade>:\Arquivos de Programas\Microsoft SQL Server\110\. A alteração do caminho de instalação de um componente compartilhado também o altera para os outros componentes compartilhados. Instalações subsequentes instalam componentes sem reconhecimento de instância no mesmo diretório que a instalação original.

O SQL Server Analysis Services é o único componente do SQL Server que dá suporte à renomeação de instância após a instalação. Se uma instância do Analysis Services for renomeada, o ID da instância não será alterado. Depois que a renomeação da instância for concluída, os diretórios e as chaves do registro continuarão usando o ID de instância criado durante a instalação.

A ramificação de registro é criada sob HKLM\Software\Microsoft\Microsoft SQL Server\<Instance_ID> para componentes com reconhecimento de instância. Por exemplo,

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL11.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSASSQL11.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.110

O registro também mantém um mapeamento do ID da instância para o nome da instância. O mapeamento do ID da instância para o nome da instância é mantido como segue:

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\SQL] "InstanceName"="MSSQL11"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\OLAP] "InstanceName"="MSASSQL11"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\RS] "InstanceName"="MSRSSQL11"

Especificando caminhos de arquivos

Durante a Instalação, você pode alterar o caminho de instalação dos seguintes recursos:

O caminho de instalação é exibido na Instalação somente para recursos com uma pasta de destino configurável pelo usuário:

Componente | Caminho padrão1, 2 | Caminho fixo ou configurável3
Componentes de servidor do Mecanismo de Banco de Dados | \Arquivos de Programas\Microsoft SQL Server\MSSQL11.<InstanceID>\ | Configurável
Arquivos de dados do Mecanismo de Banco de Dados | \Arquivos de Programas\Microsoft SQL Server\MSSQL11.<InstanceID>\ | Configurável
Servidor do Analysis Services | \Arquivos de Programas\Microsoft SQL Server\MSAS11.<InstanceID>\ | Configurável
Arquivos de dados do Analysis Services | \Arquivos de Programas\Microsoft SQL Server\MSAS11.<InstanceID>\ | Configurável
Servidor de relatório do Reporting Services | \Arquivos de Programas\Microsoft SQL Server\MSRS11.<InstanceID>\Reporting Services\ReportServer\Bin\ | Configurável
Gerenciador de relatórios do Reporting Services | \Arquivos de Programas\Microsoft SQL Server\MSRS11.<InstanceID>\Reporting Services\ReportManager\ | Caminho fixo
Integration Services | <Diretório de instalação>\110\DTS\ | Configurável4
Master Data Services | <Diretório de instalação>\110\Master Data Services | Configurável4
Componentes cliente | <Diretório de instalação>\110\Tools\ | Configurável4
Replicação e objetos COM do lado do servidor | <unidade>:\Arquivos de Programas\Microsoft SQL Server\110\COM\5 | Caminho fixo
DLLs de componentes do Integration Services para o mecanismo de Tempo de Execução de Transformação de Dados, o mecanismo Pipeline de Transformação de Dados e o utilitário de prompt de comando dtexec | <unidade>:\Arquivos de Programas\Microsoft SQL Server\110\DTS\Binn | Caminho fixo
DLLs que dão suporte de conexão gerenciado para o Integration Services | <unidade>:\Arquivos de Programas\Microsoft SQL Server\110\DTS\Connections | Caminho fixo
DLLs para cada tipo de enumerador cujo suporte é dado pelo Integration Services | <unidade>:\Arquivos de Programas\Microsoft SQL Server\110\DTS\ForEachEnumerators | Caminho fixo
Serviço Pesquisador do SQL Server, provedores de WMI | <unidade>:\Arquivos de Programas\Microsoft SQL Server\110\Shared\ | Caminho fixo
Componentes que são compartilhados entre todas as instâncias do SQL Server | <unidade>:\Arquivos de Programas\Microsoft SQL Server\110\Shared\ | Caminho fixo

1Assegure-se de que a pasta \Arquivos de Programas\Microsoft SQL Server\ esteja protegida com permissões limitadas.

2A unidade padrão para esses locais é systemdrive, normalmente a unidade C.

3Os caminhos de instalação para recursos filho são determinados pelo caminho de instalação do recurso pai.

4Um único caminho de instalação é compartilhado entre o Integration Services e os componentes cliente. A alteração do caminho de instalação de um componente também o altera para outros componentes. As instalações subsequentes instalam componentes no mesmo local que a instalação original.

5Esse diretório é usado por todas as instâncias do SQL Server em um computador. Se você aplicar uma atualização a alguma das instâncias no computador, quaisquer alterações em arquivos nessa pasta afetarão todas as instâncias no computador. Ao adicionar recursos a uma instalação existente, não é possível alterar o local de um recurso instalado anteriormente, nem especificar o local para o novo recurso. Você deve instalar recursos adicionais nos diretórios já estabelecidos pela Instalação ou desinstalar e reinstalar o produto.

Observação Observação

Para configurações clusterizadas, você deve selecionar uma unidade local que esteja disponível em todo nó do cluster.

Quando você especifica um caminho de instalação durante a Instalação para os componentes de servidor ou os arquivos de dados, o programa de Instalação usa o ID da instância além do local especificado para arquivos de programas e de dados. A Instalação não usa o ID da instância para ferramentas e outros arquivos compartilhados. A Instalação também não usa nenhum ID de instância para os arquivos de programas e de dados do Analysis Services, embora use o ID da instância para o repositório do Analysis Services.

Se você definir um caminho de instalação para o recurso Mecanismo de Banco de Dados, a Instalação do SQL Server usará esse caminho como o diretório raiz para todas as pastas específicas da instância para essa instalação, incluindo Arquivos de Dados SQL. Nesse caso, se você definir a raiz como "C:\Arquivos de Programas\Microsoft SQL Server\MSSQL11\MSSQL\", diretórios específicos da instância serão adicionados ao final desse caminho.

Os clientes que optarem por usar a funcionalidade de atualização USESYSDB no Assistente de Instalação do SQL Server (modo UI da Instalação) poderão facilmente colocar-se em uma situação em que o produto é instalado em uma estrutura de pastas recursiva. Por exemplo, <SQLProgramFiles>\MSSQL11\MSSQL\MSSQL11\MSSQL\Data\. Em vez disso, para usar o recurso USESYSDB, defina um caminho de instalação para o recurso Arquivos de Dados SQL no lugar do recurso Mecanismo de Banco de Dados.

Observação Observação

Espera-se que os arquivos de dados sempre estejam localizados em um diretório filho denominado Data. Por exemplo, especifique C:\Arquivos de Programas\Microsoft SQL Server\MSSQL11\ para especificar o caminho raiz do diretório de dados dos bancos de dados do sistema durante a atualização quando os arquivos de dados estiverem localizados em C:\Arquivos de Programas\Microsoft SQL Server\MSSQL11\MSSQL\Data.

Consulte também

Referência

Configuração do Mecanismo de Banco de Dados – Diretórios de dados
Configuração do Analysis Services - diretórios de dados


Exibir e ler arquivos de log da Instalação do SQL Server

 Copiar imagem em foco
[image]

Exibir e ler arquivos de log da Instalação do SQL Server
Consulte também Enviar Comentários

Cada execução da Instalação cria arquivos de log com uma nova pasta de log com carimbo de data/hora em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\. O formato de nome da pasta com carimbo de data/hora é AAAAMMDD_hhmmss. Quando a Instalação é executada em um modo autônomo, os logs são criados em % temp%\sqlsetup*.log. Todos os arquivos da pasta de logs são arquivados no arquivo Log*.cab em sua respectiva pasta de log.

Uma solicitação de Instalação típica passa por três fases de execução:

  1. Texto de regras globais

  2. Atualização de componente

  3. Ação solicitada pelo usuário

Em cada fase, a Instalação gera logs de detalhes e de resumo com logs adicionais criados conforme apropriado. A Instalação é chamada ao menos três vezes para cada ação de instalação solicitada pelo usuário.

Os arquivos de armazenamento de dados contêm um instantâneo do estado de todos os objetos de configuração que estão sendo rastreados pelo processo de instalação e são úteis para solucionar erros de configuração. Despejos de arquivo XML são criados para objetos de armazenamento de dados em cada fase de execução. Eles são salvos em sua própria subpasta de log na pasta de log com carimbo de data/hora, como a seguir:

  • Datastore_GlobalRules

  • Datastore_ComponentUpdated

  • Datastore

As seções a seguir descrevem arquivos de log da Instalação do SQL Server.

Texto resumido

Visão geral

Esse arquivo mostra os componentes do SQL Server detectados durante Instalação, o ambiente de sistema operacional, valores de parâmetros de linha de comando, caso sejam especificados, e o status global de cada MSI/MSP que foi executado.

O log é organizado nas seguintes seções:

  • Um resumo global da execução

  • As propriedades e a configuração do computador em que a Instalação do SQL Server foi executada

  • Recursos do produto SQL Server instalados previamente no computador

  • Descrição da versão de instalação e propriedades do pacote de instalação

  • Configurações de entrada em tempo de execução que são fornecidas durante instalação

  • Local do arquivo de configuração

  • Detalhes dos resultados de execução

  • Regras globais

  • Regras específicas ao cenário de instalação

  • Regras com falha

  • Local do arquivo de relatório de regras

Local

Ele está localizado em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\.

Para localizar erros no arquivo de texto resumido, pesquise o arquivo usando as palavras-chave "error" ou "failed".

Summary_engine-base_YYYYMMDD_HHMMss.txt

Visão geral

O arquivo de base summary_engine é semelhante ao arquivo de resumo e é gerado durante o fluxo de trabalho principal.

Local

Ele está localizado em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Summary_engine-base_YYYYMMDD_HHMMss_ComponentUpdate.txt

Visão geral

O arquivo de log resumido de atualização do componente é semelhante ao arquivo de resumo e é gerado durante o fluxo de trabalho de atualização de componente.

Local

Ele está localizado em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Summary_engine-base_<VersionNumber>MMDD_HHMMss_GlobalRules.txt

Visão geral

O arquivo de log resumido de regras globais é semelhante ao arquivo de resumo gerado durante o fluxo de trabalho de regras globais.

Local

Ele está localizado em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Detail.txt

Visão geral

O arquivo Detail.txt é gerado para o fluxo de trabalho principal, como instalação ou atualização, e fornece os detalhes da execução. Os logs do arquivo são gerados com base na hora em que cada ação para a instalação foi invocada, e mostram a ordem na qual as ações foram executadas e suas dependências.

Local

Ele está localizado em %programfiles%\Microsoft SQL Server\110\Setup

Bootstrap\Log\<YYYYMMDD_HHMM>\Detail.txt.

Se ocorrer um erro durante o processo de Instalação, a exceção ou o erro será registrado no final desse arquivo. Para localizar os erros nesse arquivo, primeiro examine o final do arquivo e depois efetue uma pesquisa do arquivo pelas palavras-chave "error" ou "exception".

Detail_ComponentUpdate.txt

Visão geral

O arquivo Detail_ComponentUpdate.txt é gerado para o fluxo de trabalho de atualização de componente e é semelhante ao Detail.txt.

Local

Ele está localizado em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Detail_GlobalRules.txt

Visão geral

O arquivo Detail_GlobalRules.txt é gerado para a execução de regras globais e é semelhante ao Detail.txt.

Local

Ele está localizado em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Arquivos de log MSI

Visão geral

Os arquivos de log MSI fornecem detalhes do processo de pacote de instalação. Eles são gerados pelo MSIEXEC durante a instalação do pacote especificado.

Tipos de arquivos de log MSI:

  • <Recurso>_<Arquitetura>_<Interação>.log

  • <Recurso>_<Arquitetura>_<Idioma>_<Interação>.log

  • <Recurso>_<Arquitetura>_<Interação>_<Fluxo de trabalho>.log

Local

Os arquivos de log MSI estão localizados em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\<Name>.log.

No final do arquivo, há um resumo da execução, que inclui o status de êxito ou falha e propriedades. Para localizar o erro no arquivo MSI, pesquise "value 3"; os erros geralmente são encontrados próximos à cadeia de caracteres.

ConfigurationFile.ini

Visão geral

O arquivo de configuração contém as configurações de entrada que são fornecidas durante instalação. Pode ser usado para reiniciar a instalação sem ser necessário inserir as configurações manualmente. Entretanto, as senhas das contas, o PID e alguns parâmetros não são salvos no arquivo de configuração. As configurações podem ser adicionadas ao arquivo ou fornecidas por meio da linha de comando ou da interface do usuário de Instalação. Para obter mais informações, consulte Instalar o SQL Server 2012 usando um arquivo de configuração (http://go.microsoft.com/fwlink/?LinkId=231296).

Local

Ele está localizado em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

SystemConfigurationCheck_Report.htm

Visão geral

O relatório de verificação da configuração do sistema contém uma breve descrição de cada regra executada, bem como o status de execução.

Local

Ele está localizado em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Consulte também

Conceitos

Solucionando problemas da instalação do SQL Server


Solucionando problemas da instalação do SQL Server

 Copiar imagem em foco
[image]

Solucionando problemas da instalação do SQL Server
Consulte também Enviar Comentários

Para exibir informações de solução de problemas de instalação e atualização, consulte o Leiame do SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=196910).

Consulte também

Conceitos

Exibir e ler arquivos de log da Instalação do SQL Server


Referência da interface de usuário da instalação do SQL Server

 Copiar imagem em foco
[image]

Referência da interface de usuário da instalação do SQL Server
Enviar Comentários

Esta seção descreve as opções de instalação apresentadas pelo Assistente para Instalação do SQL Server.


Aceitar termos de licença

 Copiar imagem em foco
[image]

Aceitar termos de licença
Consulte também Enviar Comentários

Use a página Aceitar Termos de Licença do Assistente de Instalação do SQL Server para aceitar os termos da licença desta versão do SQL Server.

Você pode imprimir o contrato de licença ou copiá-lo para a Área de transferência. Para continuar, aceite os termos da licença e clique em Avançar. Para fechar a instalação, clique em Cancelar.

Relatório de uso de recursos

Se você habilitar a opção de relatório de Uso de Recursos, o SQL Server será configurado para enviar, periodicamente, um relatório para a Microsoft. Relatórios incluem informações sobre sua configuração de hardware e como você usa o SQL Server e os componentes. O Microsoft usará dados de uso de recurso para melhorar o SQL Server. Os componentes do SQL Server monitorados por esse recurso incluem:

  • O Mecanismo de Banco de Dados

  • Analysis Services

  • Reporting Services

  • Integration Services

  • Replicação

  • SSDT (Ferramentas de dados do SQL Server)

  • Instalação do SQL Server

As informações sobre o uso de recursos são enviadas para a Microsoft, onde são armazenadas com acesso limitado.

Para desativar a opção Uso de Recursos, depois de finalizar a Instalação, use a ferramenta Relatório de Erro e Uso do SQL Server no menu Ferramentas de Configuração do SQL Server.

Para ações de Instalação como instalação, atualização, reparo, e assim por diante, as informações são coletadas e carregadas somente durante a execução do programa de instalação

Para todos os outros componentes do SQL Server, as informações são coletadas uma vez por dia para todas as instâncias habilitadas do SQL Server. Por padrão, a hora de coleta é meia-noite para minimizar a carga no servidor. Se quiser alterar a hora de coleta, poderá editar manualmente a chave do registro que controla isso. Cada instância do SQL Server tem sua própria chave do Registro:

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL11.<INSTANCEID>\CPE\TimeofReporting

O valor dessa chave do Registro contém a hora de coleta como o número de minutos a partir de 00h:00 (meia-noite) para executar. Por exemplo, um valor igual a 60 executará a coleta à 1:00 a.m. e um valor igual a 1200 executará a coleta às 8:00 p.m., e assim por diante.

Consulte também

Referência

Sobre os termos de licença do SQL Server


Adicionar nó de cluster de failover do SQL Server

 Copiar imagem em foco
[image]

Adicionar nó de cluster de failover do SQL Server
Consulte também Enviar Comentários

A Instalação do SQL Server valida a configuração do computador antes da conclusão da operação de Instalação. Durante a Instalação do SQL Server, o SCC (Verificador de Configuração do Sistema) examina o computador em que o SQL Server será instalado. O SCC verifica se existem condições que impedem uma operação de instalação com êxito do SQL Server. Antes que a Instalação inicie o Assistente de Instalação do SQL Server, o SCC recupera o status de cada item. Em seguida, compara o resultado com condições necessárias e fornece orientação para a remoção de problemas de bloqueio.

A verificação da configuração do sistema gera um relatório que contém uma breve descrição de cada regra executada, bem como o status de execução. O relatório de verificação da configuração do sistema está localizado em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Antes de executar a operação de instalação, reveja os seguintes tópicos:

  1. Requisitos de hardware e software para instalar o SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Recursos com suporte das edições do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerações de segurança de uma instalação do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versões de idiomas locais no SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Outras referências:

  1. Atualizações de versão e edição com suporte(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar o clustering de failover(http://go.microsoft.com/fwlink/?LinkId=235034)

Consulte também

Referência

Regras de suporte à Instalação


Configuração do Analysis Services - Provisionamento de conta

 Copiar imagem em foco
[image]

Configuração do Analysis Services - Provisionamento de conta
Consulte também Enviar Comentários

Use esta página para definir o modo de servidor e para conceder permissões administrativas a usuários ou serviços que requerem acesso irrestrito ao Analysis Services. A Instalação não adiciona automaticamente o grupo local do Windows BUILTIN\Administradores à função de administrador de servidor do Analysis Services da instância que você está instalando. Para adicionar o grupo Administradores local à função de administrador do servidor, é necessário especificar explicitamente esse grupo.

Se você estiver instalando o PowerPivot para SharePoint, conceda permissões administrativas aos administradores de farms do SharePoint ou aos administradores de serviços responsáveis por uma implantação do servidor PowerPivot em um farm do SharePoint Server 2010. Para obter mais informações sobre instalação e requisitos de conta de serviço do Serviço PowerPivot, consulte Installing PowerPivot for SharePoint (a página pode estar em inglês).

Opções

Modo de servidor - o modo de servidor especifica o tipo de bancos de dados do Analysis Services que podem ser implantados no servidor. Os modos de servidor são determinados durante a Instalação e não podem ser modificados posteriormente. Cada modo é mutuamente exclusivo, o que significa que você precisará de duas instâncias do Analysis Services, cada uma configurada para um modo diferente, para oferecer suporte às soluções de modelo OLAP e de tabela.

Especificar administradores - você deve especificar pelo menos um administrador de servidor para a instância do SQL Server. Os usuários ou grupos que você especificar se tornarão membros da função de administrador de servidor da instância do Analysis Services que está sendo instalada. Eles devem ser contas de usuário de domínio do Windows no mesmo domínio que o computador no qual você está instalando o software.

Observação Observação

O UAC (Controle de Conta de Usuário) é um recurso de segurança do Windows que requer um administrador para aprovar especificamente aplicativos ou ações administrativas para que tenham permissão de execução. Como o UAC é ativado por padrão, será solicitado que você permita operações específicas que exijam privilégios elevados. É possível configurar o UAC para alterar o comportamento padrão ou personalizar o UAC para programas específicos. Para obter mais informações sobre o UAC e sua configuração, consulte o Guia passo a passo do controle de conta de usuário e User Account Control (Wikipédia).

Consulte também

Outros recursos

Alterar contas de serviço e senhas (PowerPivot para SharePoint)
Configurando a conta de serviço do Analysis Services
Configurando as contas de serviço do Windows


Configuração do Analysis Services - diretórios de dados

 Copiar imagem em foco
[image]

Configuração do Analysis Services - diretórios de dados
Consulte também Enviar Comentários

Os diretórios padrão na tabela a seguir podem ser configurados pelo usuário durante a Instalação do SQL Server. A permissão para acessar esses arquivos é concedida a administradores locais e a membros do grupo de segurança SQLServerMSASUser$<instância> que é criado e provisionado durante a Instalação.

Descrição

Diretório padrão

Recomendações

Diretório raiz de dados

C:\Arquivos de Programas\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Data\

Assegure-se de que a pasta \Arquivos de programas\Microsoft SQL Server\ esteja protegida com permissões limitadas. O desempenho do Analysis Services depende, em muitas configurações, do desempenho do armazenamento no qual o diretório de dados está localizado. Coloque esse diretório no armazenamento de melhor desempenho conectado ao sistema. Para instalações de cluster de failover, verifique se os diretórios de dados estão colocados no disco compartilhado.

Diretório do arquivo de log

C:\Arquivos de Programas\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Log\

Este é o diretório de arquivos de log do Analysis Services e inclui o log do FlightRecorder. Se você aumentar a duração do registrador de voo, atente para que o diretório de logs tenha espaço suficiente.

Diretório temporário

C:\Arquivos de Programas\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Temp\

Coloque o diretório Temp no subsistema de armazenamento de alto desempenho.

Diretório de backup

C:\Arquivos de Programas\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Backup\

Este é o diretório dos arquivos de backup padrão do Analysis Services. Em instalações do PowerPivot para SharePoint, também é onde os Serviços de Sistema do PowerPivot armazenam em cache arquivos de dados PowerPivot.

Verifique se as permissões apropriadas estão definidas para impedir perda de dados e se o grupo de usuários do serviço do Analysis Services tem permissões suficientes para gravar no diretório de backup. O uso de uma unidade mapeada para diretórios de backup não tem suporte.

Observações

  • As instâncias do Analysis Services que são implantadas em um farm do SharePoint armazenam arquivos de aplicativos, arquivos de dados e propriedades em bancos de dados de conteúdo e bancos de dados de aplicativo de serviços.

  • Ao adicionar recursos a uma instalação existente, não é possível alterar o local de um recurso instalado anteriormente, nem especificar o local para o novo recurso.

  • Se você especificar diretórios de instalação diferentes do padrão, assegure que as pastas de instalação sejam exclusivas a esta instância do SQL Server. Nenhum dos diretórios desta caixa de diálogo deve ser compartilhado com diretórios de outras instâncias do SQL Server. Os componentes Mecanismo de Banco de Dados e Analysis Services em uma instância do SQL Server também devem ser instalados em diretórios separados.

  • Os arquivos de programas e os arquivos de dados não podem ser instalados nas seguintes situações:

    • Em uma unidade de disco removível

    • Em um sistema de arquivos que usa compactação

    • Em um diretório onde os arquivos do sistema estão localizados

    • Em unidades compartilhadas em uma instância de cluster de failover

Consulte também

Conceitos

Locais de arquivos para instâncias padrão e nomeadas do SQL Server


Seleção de Disco de Cluster

 Copiar imagem em foco
[image]

Seleção de Disco de Cluster
Enviar Comentários

Use a página Seleção de Disco de Cluster do Assistente de Instalação do SQL Server a fim de selecionar o recurso de disco de cluster compartilhado do cluster de failover do SQL Server. O disco de cluster é o local onde os dados do SQL Server são colocados.

Um disco de cluster compartilhado não é um requisito para instalações de cluster do SQL Server Mecanismo de Banco de Dados. Um servidor de arquivos SMB é um armazenamento com suporte para instalações de cluster de failover do Mecanismo de Banco de Dados do SQL Server. Ele pode ser especificado na página Mecanismo de Banco – Diretórios de Dados antes da conclusão da instalação.

Observação sobre cuidados Cuidado

Se você selecionou Analysis Services para ser instalado, especifique um disco de cluster compartilhado.

Se você pretende habilitar FILESTREAM nesta instância de cluster de failover do SQL Server, especifique um disco de cluster compartilhado.

Opções

Discos compartilhados

Selecione um único disco na lista. O disco de cluster é o local onde os dados do SQL Server são colocados.

Apenas um disco pode ser especificado. Se você selecionar o grupo que contém o recurso de quorum de cluster, será exibido um aviso. É recomendável não efetuar a instalação no recurso de quorum de cluster.

Discos compartilhados disponíveis

Exibe uma lista de discos disponíveis, onde cada um deles é qualificado como um disco compartilhado, e uma descrição de cada recurso de disco.


Configuração de rede do cluster

 Copiar imagem em foco
[image]

Configuração de rede do cluster
Enviar Comentários

Use a página Seleção de Rede de Cluster para especificar os recursos de rede para sua instância de cluster de failover.

Opções

Nome de Rede do Cluster de Failover do SQL Server - Esse é o nome usado para identificar a instância de cluster de failover na rede.

Configurações de Rede - Especifique o tipo e o endereço IP para a instância de cluster de failover.

Durante as operações Adicionar Nó e Remover Nó, o SQL Server exibe uma lista somente leitura dos endereços IP existentes para o cluster de failover do SQL Server.

  • Instalação Integrada:

    • Se você estiver adicionando um nó que tenha suporte para um conjunto idêntico de sub-redes de rede com suporte dos nós existentes do cluster de failover do SQL Server, nenhum outro endereço IP poderá ser adicionado. A configuração de dependência permanece inalterada.

    • Se você for adicionar um nó com suporte para um subconjunto das sub-redes com suporte dos nós existentes no cluster de failover do SQL Server, nenhum recurso de endereço IP adicional poderá ser adicionado. A dependência de recurso de endereço IP é definida como OR para indicar que todos os endereços IP especificados não são válidos em todos os nós de cluster.

    • Se você estiver adicionando um nó que tenha suporte para sub-redes, além das sub-redes já com suporte dos nós existentes no cluster de failover do SQL Server, terá a opção de adicionar novos endereços IP válidos. Se novos endereços IP forem especificados, a dependência de recurso de endereço IP será definida como OR para refletir que todos os endereços IP especificados não sejam válidos em todos os nós de cluster.

    • Se você estiver adicionando um nó que tenha suporte para mais sub-redes de rede, mas que não tenha suporte para nenhuma das sub-redes aceitas pelos nós existentes no cluster de failover do SQL Server, será necessário adicionar mais endereços IP. A dependência de recurso de endereço IP é definida como OR para refletir que todos os endereços IP especificados não sejam válidos em todos os nós de cluster.

  • Instalação Avançada: Durante a etapa Concluir da instalação, especifique o endereço IP de todos os nós e sub-redes da instância de cluster de failover. Você pode especificar vários endereços IP para um cluster de failover de várias sub-redes, mas há suporte para apenas um endereço IP por sub-rede. Cada nó preparado deve ser um possível proprietário de pelo menos um endereço IP. Se você tiver várias sub-redes em seu cluster de failover do SQL Server, será solicitado que defina a dependência de recurso de endereço IP como OR.Remove Node:

    • Se houver suporte para os endereços IP restantes em todos os outros nós, você deverá definir a dependência de recurso de endereço IP como AND.

    • Se não houver suporte para os endereços IP restantes em todos os outros nós, a dependência de recurso de endereço IP será deixada como OR.


Configuração do nó do cluster

 Copiar imagem em foco
[image]

Configuração do nó do cluster
Enviar Comentários

Use a página Configuração do nó do cluster para adicionar ou remover nós de uma instância de cluster da failover. Para instalar ou atualizar um cluster de failover do SQL Server, você deve executar o programa de Instalação em cada nó do cluster de failover. Para adicionar um nó a um cluster de failover existente do SQL Server, é necessário executar a instalação do SQL Server no nó a ser adicionado à instância do cluster de failover do SQL Server.

Opções

Nome da Instância do SQL Server - Use a lista suspensa para selecionar a instância de cluster de failover do SQL Server a ser modificada.

Nome desse nó - Este campo será populado com o nome do computador que está executando o programa de instalação do SQL Server. Este é o nó do cluster de failover que será adicionado ou removido da instância do cluster de failover do SQL Server.


Configuração do Nó do Cluster (concluída)

 Copiar imagem em foco
[image]

Configuração do Nó do Cluster (concluída)
Enviar Comentários

Use a página Configuração do nó do cluster (Completa) para especificar uma instância existente do SQL Server que tenha sido preparada para clustering. Para instalar ou atualizar um cluster de failover do SQL Server, você deve executar o programa de Instalação em cada nó do cluster de failover. Para adicionar um nó a um cluster de failover existente do SQL Server, é necessário executar a instalação do SQL Server no nó a ser adicionado à instância do cluster de failover do SQL Server.

Opções

Nas caixas suspensas:

  • Nome da instância do SQL Server — Selecione o nome da instância para o cluster de failover do SQL Server.

  • Nome deste nó — Este campo é pré-populado com o nome do computador em que o programa de Instalação do SQL Server está sendo executado.

  • Nome de Rede do Cluster de Failover do SQL Server — Este campo não é pré-populado. Especifique o nome de rede da nova instância do cluster de failover do SQL Server. Este é o nome que identifica a instância do cluster de failover na rede.


Grupo de Recursos de Cluster

 Copiar imagem em foco
[image]

Grupo de Recursos de Cluster
Consulte também Enviar Comentários

Use a página Grupo de Recursos de Cluster para especificar o disco onde os recursos do servidor virtual do SQL Server serão localizados.

Opções

Especifique o nome do grupo de recursos de cluster do SQL Server. Você tem duas opções:

  • Use a caixa suspensa para especificar um grupo existente a ser usado.

  • Digite o nome de um novo grupo a ser criado. Observe que o nome "Armazenamento disponível" não é um nome de grupo válido.

Consulte também

Outros recursos

Como criar um novo cluster de failover do SQL Server


Política de Segurança de Cluster

 Copiar imagem em foco
[image]

Política de Segurança de Cluster
Enviar Comentários

Use a página Política de Segurança de Cluster para configurar a política de segurança para sua instância de cluster de failover.

Opções

Especifique grupos de domínios global ou local para serviços clusterizados. Todas as permissões de recurso são controladas por grupos no nível do domínio que incluem contas de serviço do SQL Server como membros de grupo. Para obter mais informações sobre a funcionalidade de SIDs (IDs de segurança) no Windows Server 2008, consulte Configurar contas de serviço e permissões do Windows.

Se estiver instalando uma Instância do Cluster de Failover do Microsoft SQL Server 2012 em um domínio em modo misto do Windows 2000, você deverá usar grupos globais de domínio para Serviços Clusterizados do SQL Server.

Observação Observação

Os controladores de domínio do Windows 2000 podem operar em modo misto e nativo. O modo misto permite controladores de domínio de nível inferior no mesmo domínio.


Concluir - Imagem Completa

 Copiar imagem em foco
[image]

Concluir - Imagem Completa
Enviar Comentários

Use a página Concluída para verificar se a configuração da instância preparada está concluída.

Opções

Esta caixa de diálogo inclui um link com o arquivo de log de Instalação para esta operação. Para concluir a instalação, clique em Fechar.


Andamento da Imagem Completa

 Copiar imagem em foco
[image]

Andamento da Imagem Completa
Consulte também Enviar Comentários

Use a página Andamento da Imagem Completa do Assistente de Instalação do SQL Server para monitorar o status da instalação da conclusão da imagem do SQL Server. Após a conclusão desta etapa, esta página listará o status para cada recurso do SQL Server configurado e concluído.

Consulte também

Conceitos

Exibir e ler arquivos de log da Instalação do SQL Server


Regras de Conclusão de Imagem

 Copiar imagem em foco
[image]

Regras de Conclusão de Imagem
Enviar Comentários

A Instalação do SQL Server valida a configuração do computador antes da conclusão da operação de Instalação. Durante a Instalação do SQL Server, o SCC (Verificador de Configuração do Sistema) examina o computador em que o SQL Server será instalado. O SCC verifica se existem condições que impedem uma operação de instalação com êxito do SQL Server. Antes que a Instalação inicie o Assistente de Instalação do SQL Server, o SCC recupera o status de cada item. Em seguida, compara o resultado com condições necessárias e fornece orientação para a remoção de problemas de bloqueio.

A verificação da configuração do sistema gera um relatório que contém uma breve descrição de cada regra executada, bem como o status de execução. O relatório de verificação da configuração do sistema está localizado em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Antes de executar a operação de instalação, reveja os seguintes tópicos:

  1. Requisitos de hardware e software para instalar o SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Recursos com suporte das edições do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerações de segurança de uma instalação do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versões de idiomas locais no SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Outras referências:

  1. Atualizações de versão e edição com suporte(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar o clustering de failover(http://go.microsoft.com/fwlink/?LinkId=235034)


Concluir - Preparar Imagem

 Copiar imagem em foco
[image]

Concluir - Preparar Imagem
Enviar Comentários

Use a página Concluída para verificar se a preparação da imagem está concluída.

Opções

Esta caixa de diálogo inclui um link com o arquivo de log de Instalação para esta operação. Para concluir a preparação da imagem, clique em Fechar.


Concluir - Reparar

 Copiar imagem em foco
[image]

Concluir - Reparar
Enviar Comentários

Use a página Concluir - Reparar para verificar se o reparo foi concluído.

Opções

Esta caixa de diálogo inclui um link com o arquivo de log de Instalação para esta operação. Para continuar, clique em Fechar.


Concluir - Atualização

 Copiar imagem em foco
[image]

Concluir - Atualização
Enviar Comentários

Use a página Concluída (Atualização) para verificar se a atualização foi concluída.

Opções

Esta caixa de diálogo inclui um link com o arquivo de log de Instalação para esta operação. Para continuar, clique em Fechar.


Configuração do Mecanismo de Banco de Dados – Provisionamento de conta

 Copiar imagem em foco
[image]

Configuração do Mecanismo de Banco de Dados – Provisionamento de conta
Consulte também Enviar Comentários

Use esta página para definir o modo de segurança do SQL Server e adicionar grupos ou usuários do Windows como administradores do Mecanismo de Banco de Dados do SQL Server.

Considerações sobre a execução do SQL Server 2012 no Windows Vista, no Windows 7 e no Windows Server 2008

Nas versões anteriores do SQL Server, o grupo BUILTIN\Administradores foi provisionado como um logon no Mecanismo de Banco de Dados, e membros do grupo local Administradores fizeram logon usando as credenciais de Administrador. O uso de permissões elevadas não é uma prática recomendada. No Microsoft SQL Server 2012, o grupo BUILTIN\Administradores não é provisionado como logon. Por isso, você deve criar um logon do SQL Server para cada usuário administrativo e adicionar esse logon à função de servidor fixa sysadmin durante a instalação de uma nova instância do Microsoft SQL Server 2012. Você também deve fazer isso para as contas do Windows usadas para executar trabalhos de agente do SQL Server. Eles incluem trabalhos do agente de replicação.

Opções

Modo de Segurança - Selecione Autenticação do Windows ou Autenticação de Modo Misto para sua instalação.

Provisionamento de Entidade do Windows - Nas versões anteriores do SQL Server, o grupo local Windows Builtin\Administrator era colocado na função de servidor SQL Server sysadmin, concedendo efetivamente aos administradores do Windows o acesso à instância do SQL Server. No Microsoft SQL Server 2012, o grupo Builtin\Administradores não é provisionado na função de servidor sysadmin. Em vez disso, você deve provisionar explicitamente administradores do SQL Server para as novas instalações durante a Instalação.

Observação importante Importante

Você deve provisionar explicitamente administradores do SQL Server para as novas instalações durante a Instalação. A Instalação não permitirá que você continue até que conclua esta etapa.

Especificar Administradores do SQL Server - Você deve especificar pelo menos uma entidade do Windows para a instância do SQL Server. Para adicionar a conta sob a qual a Instalação do SQL Server está sendo executada, clique no botão Usuário Atual. Para adicionar ou remover contas da lista de administradores do sistema, clique em Adicionar ou Remover e edite a lista de usuários, grupos ou computadores que terão privilégios de administrador para a instância do SQL Server.

Depois de concluir a edição da lista, clique em OK e verifique a lista de administradores na caixa de diálogo de configuração. Quando a lista estiver concluída, clique em Avançar.

Se você selecionar Autenticação de Modo Misto, deverá fornecer credenciais de logon para a conta interna AS (administrador do sistema) do SQL Server.

Observação sobre segurança Observação sobre segurança

Não use uma senha em branco. Use uma senha forte.

Modo de Autenticação do Windows

Quando um usuário se conecta por uma conta de usuário do Windows, o SQL Server valida o nome e a senha da conta usando o token da entidade do Windows no sistema operacional. Este é o modo de autenticação padrão e é muito mais seguro que o Modo Misto. A Autenticação do Windows usa o protocolo de segurança Kerberos, fornece imposição de política de senha e termos de validação de complexidade para senhas fortes, dá suporte ao bloqueio de contas e dá suporte à expiração de senhas.

Observação sobre segurança Observação sobre segurança

Quando possível, use a Autenticação do Windows.

Observação importante Importante

Não use uma senha em branco. Use uma senha forte. Nunca defina uma senha de sa em branco ou fraca.

Modo Misto (Autenticação do Windows ou Autenticação do SQL Server)

Permite que os usuários se conectem usando Autenticação do Windows ou Autenticação do SQL Server. Os usuários que se conectarem por uma conta de usuário do Windows podem usar conexões confiáveis que são validadas pelo Windows.

Se você deve escolher Autenticação de Modo Misto e tem um requisito para usar logons do SQL a fim de acomodar aplicativos herdados, deverá definir senhas fortes para todas as contas do SQL Server.

Observação Observação

A autenticação do SQL Server é fornecida somente para fins de compatibilidade com versões anteriores. Quando possível, use a Autenticação do Windows.

Digite a Senha

Insira e confirme o logon de administrador de sistema (sa). As senhas são a primeira linha de defesa contra intrusos; portanto, a configuração de senhas fortes é essencial para a segurança do seu sistema. Nunca defina uma senha de sa em branco ou fraca.

Observação Observação

As senhas do SQL Server podem conter de 1 até 128 caracteres, incluindo qualquer combinação de letras, símbolos e números. Se você escolher a autenticação de Modo Misto, deverá inserir uma senha forte de sa antes de continuar na próxima página do Assistente de Instalação.

Diretrizes de Senha Forte

As senhas fortes não são prontamente adivinhadas por uma pessoa e não são facilmente violadas usando-se um programa de computador. As senhas fortes não podem usar condições ou termos proibidos, incluindo:

  • Um espaço em branco ou condição NULL

  • "Senha"

  • "Admin"

  • "Administrador"

  • "sa"

  • "sysadmin"

Uma senha forte não pode ter os termos a seguir associados ao computador de instalação:

  • O nome do usuário atualmente conectado à máquina.

  • O nome do computador.

Uma senha forte deve ter mais de 8 caracteres e satisfazer pelo menos três dos quatro critérios a seguir:

  • Deve conter letras maiúsculas.

  • Deve conter letras minúsculas.

  • Deve conter números.

  • Deve conter caracteres não alfanuméricos; por exemplo, #,% ou ^.

As senhas inseridas nessa página devem satisfazer os requisitos de política de senha forte. Se você tiver qualquer automação que use Autenticação do SQL Server, assegure-se de que a senha satisfaça os requisitos de política de senha forte.

Conteúdo relacionado

Para obter mais informações sobre como escolher a Autenticação do Windows vs. Autenticação do SQL Server, consulte o tópico Escolher um Modo de Autenticação nos Manuais Online do SQL Server.

Para obter mais informações sobre como escolher uma conta para executar o Mecanismo de Banco de Dados do SQL Server, consulte o tópico Configurar contas de serviço e permissões do Windows nos Manuais Online do SQL Server.

Consulte também

Referência

Configurar contas de serviço e permissões do Windows


Configuração do Mecanismo de Banco de Dados – Diretórios de dados

 Copiar imagem em foco
[image]

Configuração do Mecanismo de Banco de Dados – Diretórios de dados
Consulte também Enviar Comentários

Use esta página para especificar o local de instalação para arquivos de programas e dados do SQL Server Mecanismo de Banco de Dados. Com base no tipo de instalação, o armazenamento com suporte pode incluir disco local, armazenamento compartilhado ou um servidor de arquivos SMB.

Para especificar um compartilhamento de arquivos SMB como um diretório, você deve digitar o caminho UNC com suporte manualmente. Não há suporte para a navegação até um compartilhamento de arquivos SMB. Este é um formato de caminho UNC de um compartilhamento de arquivos SMB com suporte: "\\Nome_Servidor\Nome_Compartilhamento\..."

instância autônoma do SQL Server

A tabela a seguir lista os tipos de armazenamento com suporte e os diretórios padrão para uma instância autônoma do SQL Server que podem ser configurados pelo usuário durante a Instalação do SQL Server.

Descrição | Tipo de armazenamento com suporte | Diretório padrão | Recomendações
Diretório raiz de dados | Disco local, servidor de arquivos SMB, armazenamento compartilhado 1 | C:\Arquivos de Programas\Microsoft SQL Server\ | A Instalação do SQL Server irá configurar ACLs para diretórios do SQL Server e interromper a herança como parte da configuração.
Diretório do banco de dados de usuário | Disco local, servidor de arquivos SMB, armazenamento compartilhado 1 | C:\Arquivos de Programas\Microsoft SQL Server\MSSQL11.<ID_Instância>MSSQL\Data | As práticas recomendadas para diretórios de dados de usuário dependem dos requisitos de carga de trabalho e desempenho.
Diretório de log do banco de dados de usuário | Disco local, servidor de arquivos SMB, armazenamento compartilhado 1 | C:\Arquivos de Programas\Microsoft SQL Server\MSSQL11.<ID_Instância>MSSQL\Data | Verifique se o diretório de log tem espaço suficiente.
Diretório de BD temporário | Disco local, servidor de arquivos SMB, armazenamento compartilhado 1 | C:\Arquivos de Programas\Microsoft SQL Server\MSSQL11.<ID_Instância>MSSQL\Data | As práticas recomendadas para o diretório Temp dependem dos requisitos de carga de trabalho e desempenho.
Diretório de log de BD temporário | Disco local, servidor de arquivos SMB, armazenamento compartilhado 1 | C:\Arquivos de Programas\Microsoft SQL Server\MSSQL11.<ID_Instância>MSSQL\Data | Verifique se o diretório de log tem espaço suficiente.
Diretório de backup | Disco local, servidor de arquivos SMB, armazenamento compartilhado 1 | C:\Arquivos de Programas\Microsoft SQL Server\MSSQL11.<ID_Instância>\MSSQL\Backup | Defina as permissões adequadas para evitar perda de dados e verifique se a conta de usuário do serviço do SQL Server tem permissões suficientes para gravar no diretório de backup. O uso de uma unidade mapeada para diretórios de backup não tem suporte.

1 Embora haja suporte para discos compartilhados, essa não é uma prática recomendada para uma instância autônoma do SQL Server.

Instância de cluster de failover do SQL Server

A tabela a seguir lista os tipos de armazenamento com suporte e os diretórios padrão para uma instância de cluster de failover do SQL Server que podem ser configurados pelo usuário durante a Instalação do SQL Server.

Descrição

Tipo de armazenamento com suporte

Diretório padrão

Recomendações

Diretório raiz de dados

Armazenamento compartilhado, servidor de arquivos SMB

<Unidade:>\Arquivos de Programas\Microsoft SQL Server\

Dica Dica

Se o disco compartilhado tiver sido selecionado na página Seleção de Disco de Cluster, o padrão será o primeiro disco compartilhado. O padrão do campo será um espaço em branco se nenhuma seleção for feita na página Seleção de Disco de Cluster.

A Instalação do SQL Server irá configurar ACLs para diretórios do SQL Server e interromper a herança como parte da configuração.

Diretório do banco de dados de usuário

Armazenamento compartilhado, servidor de arquivos SMB

<Unidade:>Arquivos de Programas\Microsoft SQL Server\MSSQL11.<ID_Instância>\MSSQL\Data

Dica Dica

Se o disco compartilhado tiver sido selecionado na página Seleção de Disco de Cluster, o padrão será o primeiro disco compartilhado. O padrão do campo será um espaço em branco se nenhuma seleção for feita na página Seleção de Disco de Cluster.

As práticas recomendadas para diretórios de dados de usuário dependem dos requisitos de carga de trabalho e desempenho.

Diretório de log do banco de dados de usuário

Armazenamento compartilhado, servidor de arquivos SMB

<Unidade:>\Arquivos de Programas\Microsoft SQL Server\MSSQL11.<ID_Instância>\MSSQL\Data

Dica Dica

Se o disco compartilhado tiver sido selecionado na página Seleção de Disco de Cluster, o padrão será o primeiro disco compartilhado. O padrão do campo será um espaço em branco se nenhuma seleção for feita na página Seleção de Disco de Cluster.

Verifique se o diretório de log tem espaço suficiente.

Diretório de BD temporário

Disco local, armazenamento compartilhado, servidor de arquivos SMB

<Unidade:>\Arquivos de Programas\Microsoft SQL Server\MSSQL11.<ID_Instância>\MSSQL\Data

Dica Dica

Se o disco compartilhado tiver sido selecionado na página Seleção de Disco de Cluster, o padrão será o primeiro disco compartilhado. O padrão do campo será um espaço em branco se nenhuma seleção for feita na página Seleção de Disco de Cluster.

Verifique se o diretório especificado é válido para todos os nós de cluster. Durante o failover, se os diretórios tempdb não estiverem disponíveis no nó do destino de failover, o recurso do SQL Server não ficará online.

Diretório de log de BD temporário

Disco local, armazenamento compartilhado, servidor de arquivos SMB

<Unidade:>\Arquivos de Programas\Microsoft SQL Server\MSSQL11.<ID_Instância>\MSSQL\Data

Dica Dica

Se o disco compartilhado tiver sido selecionado na página Seleção de Disco de Cluster, o padrão será o primeiro disco compartilhado. O padrão do campo será um espaço em branco se nenhuma seleção for feita na página Seleção de Disco de Cluster.

Verifique se o diretório especificado é válido para todos os nós de cluster. Durante o failover, se os diretórios tempdb não estiverem disponíveis no nó do destino de failover, o recurso do SQL Server não ficará online.

Diretório de backup

Disco local, armazenamento compartilhado, servidor de arquivos SMB

<Unidade:>\Arquivos de Programas\Microsoft SQL Server\MSSQL11.<ID_Instância>\MSSQL\Backup

Dica Dica

Se o disco compartilhado tiver sido selecionado na página Seleção de Disco de Cluster, o padrão será o primeiro disco compartilhado. O padrão do campo será um espaço em branco se nenhuma seleção for feita na página Seleção de Disco de Cluster.

Defina as permissões adequadas para evitar perda de dados e verifique se a conta de usuário do serviço do SQL Server tem permissões suficientes para gravar no diretório de backup. O uso de uma unidade mapeada para diretórios de backup não tem suporte.

Considerações sobre segurança

A Instalação irá configurar ACLs para diretórios do SQL Server e interromper a herança como parte da configuração.

As seguintes recomendações se aplicam ao servidor de arquivos SMB:

  • A conta de serviço do SQL Server deverá ser uma conta de domínio se for usado um servidor de arquivos SMB.

  • A conta usada para instalar o SQL Server deve ter permissões NTFS FULL CONTROL na pasta de compartilhamento de arquivos SMB usada como o diretório de dados.

  • A conta usada para instalar o SQL Server deve ter privilégios SeSecurityPrivilege no servidor de arquivos SMB. Para conceder esse privilégio, use o console Política de Segurança Local no servidor de arquivos para adicionar a conta de instalação do SQL Server à política Gerenciar a auditoria e o log de segurança. Essa configuração está disponível na seção Atribuições de Direitos do Usuário, em Políticas Locais, no console Política de Segurança Local.

Observações

  • Ao adicionar recursos a uma instalação existente, você não pode alterar o local de um recurso instalado anteriormente, nem especificar o local para um novo recurso.

  • Se você especificar diretórios de instalação diferentes do padrão, assegure que as pastas de instalação sejam exclusivas a esta instância do SQL Server. Nenhum dos diretórios desta caixa de diálogo deve ser compartilhado com diretórios de outras instâncias do SQL Server. Os componentes Mecanismo de Banco de Dados e Analysis Services em uma instância do SQL Server também devem ser instalados em diretórios separados.

  • Os arquivos de programas e os arquivos de dados não podem ser instalados nas seguintes situações:

    • Em uma unidade de disco removível

    • Em um sistema de arquivos que usa compactação

    • Em um diretório onde os arquivos do sistema estão localizados

    • Em uma unidade de rede mapeada em uma instância de cluster de failover

Consulte também

Conceitos

Locais de arquivos para instâncias padrão e nomeadas do SQL Server

Outros recursos

Permissões de compartilhamento e NTFS em um servidor de arquivos


Configuração do Mecanismo de Banco de Dados – Fluxo de arquivos

 Copiar imagem em foco
[image]

Configuração do Mecanismo de Banco de Dados – Fluxo de arquivos
Consulte também Enviar Comentários

Use esta página para habilitar o FILESTREAM para esta instalação do Microsoft SQL Server 2012. O FILESTREAM integra o Mecanismo de Banco de Dados do SQL Server com um sistema de arquivos NTFS armazenando dados BLOB (objeto binário grande) do varbinary(max) como arquivos no sistema de arquivos. Instruções Transact-SQL podem inserir, atualizar, consultar, pesquisar e fazer backup de dados FILESTREAM. As interfaces do sistema de arquivos do Win32 fornecem acesso de streaming aos dados.

Habilitar FILESTREAM para acesso Transact-SQL

Selecione para habilitar FILESTREAM para acesso Transact-SQL. Este controle deve ser verificado antes que as demais opções de controle fiquem disponíveis.

Habilitar FILESTREAM para acesso de fluxo de E/S de arquivo

Selecione para habilitar o acesso de fluxo Win32 para FILESTREAM.

Nome de compartilhamento do Windows

Use este controle para digitar o nome do compartilhamento do Windows no qual os dados FILESTREAM serão armazenados.

Permitir que clientes remotos tenham acesso de fluxo a dados FILESTREAM

Selecione este controle para permitir que clientes remotos acessem dados FILESTREAM neste servidor.

Consulte também

Referência

sp_configure (Transact-SQL)

Conceitos

Habilitar e configurar FILESTREAM


Configuração do Mecanismo de Banco de Dados - Instância de usuário

 Copiar imagem em foco
[image]

Configuração do Mecanismo de Banco de Dados - Instância de usuário
Enviar Comentários

Use a página Instância de Usuário para gerar uma instância separada do Mecanismo de Banco de Dados para usuários sem permissões de administrador e adicione usuários à função de administrador.

Opção

Habilitar instâncias de usuário

O padrão é habilitado. Para desabilitar a funcionalidade de habilitar instâncias de usuário, desmarque a caixa de seleção.

A instância do usuário, também conhecida como instância filha ou cliente, é uma instância do SQL Server gerada pela instância pai (a instância primária executada como um serviço, como o SQLExpress) em nome de um usuário. A instância de usuário é executada como um processo de usuário no contexto de segurança daquele usuário. A instância de usuário é isolada da instância pai e de qualquer outra instância de usuário que estiver em execução no computador. O recurso de instância de usuário também é chamado de "Executar como Usuário Normal (RANU, Run As Normal User)".

Observação Observação

Logons provisionados como membros da função de servidor fixa sysadmin durante a instalação são provisionados como administradores no banco de dados de modelo. Eles são membros da função de servidor fixa sysadmin na instância de usuário, a menos que sejam removidos

Adicionar usuário à função de Administrador do SQL Server

O padrão é desabilitado. Para adicionar o usuário de instalação atual à função de Administrador do SQL Server, marque a caixa de seleção.

Os usuários do Windows Vista que são membros de BUILTIN\Administradores não são adicionados automaticamente à função de servidor fixa sysadmin quando se conectam ao SQL Server Express. Somente os usuários do Windows Vista explicitamente adicionados a uma função de administrador de nível de servidor podem administrar o SQL Server Express. Qualquer membro do grupo Built-In\Users pode se conectar à instância do SQL Server Express, mas terá permissões limitadas para executar tarefas do banco de dados. Por esse motivo, os usuários cujos privilégios do SQL Server Express sejam herdados de BUILTIN\Administradores e Built-In\Users das versões anteriores do Windows devem receber explicitamente privilégios administrativos em instâncias do SQL Server Express executadas no Windows Vista.

Para fazer qualquer alteração nas funções de usuário após a conclusão deste programa de instalação, use a ferramenta SQLSAC.exe (Configuração da Área de Superfície) do SQL Server 2005. Para atualizar a lista de usuários na função de Administrador de Sistema do SQL Server, clique em Adicionar Novo Administrador.

Verifique se o campo Usuário para provisionamento lista o NomeDeDomínio\NomeDeUsuário do usuário cujas permissões devem ser atualizadas. Selecione a função que será atualizada na lista de instâncias do SQL Server no painel Privilégios disponíveis e clique na seta à direita. Para adicionar o usuário a todas as funções para todas as instâncias disponíveis das instâncias do SQL Server e todas as funções disponíveis, clique duas vezes na seta à direita.

Para implementar as alterações quando suas seleções estiverem completas, clique em OK. Para encerrar o uso da ferramenta sem fazer alterações, clique em Cancelar.


Requisitos de espaço em disco

 Copiar imagem em foco
[image]

Requisitos de espaço em disco
Consulte também Enviar Comentários

Use a página Resumo de Espaço em Disco Necessário para examinar os requisitos de espaço em disco para os recursos do SQL Server selecionados para a instalação.

Opções

Se o espaço em disco necessário for muito alto, considere as seguintes opções:

  • Altere os diretórios de instalação para uma unidade com mais espaço em disco.

  • Altere os recursos do SQL Server para a instalação.

  • Crie mais espaço livre na unidade especificada movendo outros arquivos ou aplicativos.

Consulte também

Outros recursos

Requisitos de hardware e software para a instalação do SQL Server 2008 R2


Configuração do Distributed Replay Controller

 Copiar imagem em foco
[image]

Configuração do Distributed Replay Controller
Enviar Comentários

Use a página Configuração do Controlador DRU do Assistente de Instalação do SQL Server para especificar os usuários aos quais você deseja conceder permissões administrativas para o serviço Distributed Replay Controller.

Usuários que têm permissões administrativas terão acesso ilimitado ao serviço Distributed Replay Controller.

Opções

Adicionar Usuário Atual

Clique neste botão para adicionar os usuários aos quais você deseja conceder permissões de acesso para o serviço Distributed Replay Controller.

Adicionar

Clique neste botão para adicionar permissões de acesso para o serviço Distributed Replay Controller.

Remover

Clique neste botão para remover permissões de acesso do serviço Distributed Replay Controller.


Configuração do Distributed Replay Client

 Copiar imagem em foco
[image]

Configuração do Distributed Replay Client
Enviar Comentários

Use a página Configuração do Distributed Replay Client do Assistente de Instalação do SQL Server para especificar os usuários aos quais você deseja conceder permissões administrativas para o serviço Distributed Replay Client.

Usuários que têm permissões administrativas terão acesso ilimitado ao serviço Distributed Replay Client.

Opções

Nome do Controlador

Este é um parâmetro opcional, e o valor padrão é <blank>.

Digite o nome do controlador com o qual o computador cliente se comunicará para o serviço Distributed Replay Client. Observe o seguinte:

  • O nome deve ser um FQDN (nome de domínio totalmente qualificado). Por exemplo, um host chamado server1 na hierarquia de produtos na Microsoft pode ter um FQDN de server1.products.microsoft.com.

  • Se você já tiver configurado um controlador, digite o nome do controlador enquanto configura cada cliente.

  • Se você ainda não tiver configurado um controlador, poderá deixar o nome do controlador em branco. No entanto, digite manualmente o nome do controlador no arquivo de configuração do cliente.

Diretório de Trabalho

Especifique o diretório de trabalho para o serviço Distributed Replay Client.

O diretório de trabalho padrão é <drive letter>:\Arquivos de Programas\Microsoft SQL Server\DReplayClient\WorkingDir\.

Diretório de Resultado

Especifique o diretório de resultado para o serviço Distributed Replay Client.

O diretório de resultado padrão é <drive letter>:\Arquivos de Programas\Microsoft SQL Server\DReplayClient\ResultDir\.


Regras de atualização de edição

 Copiar imagem em foco
[image]

Regras de atualização de edição
Consulte também Enviar Comentários

A Instalação do SQL Server valida a configuração do computador antes da conclusão da operação de Instalação. Durante a Instalação do SQL Server, o SCC (Verificador de Configuração do Sistema) examina o computador em que o SQL Server será instalado. O SCC verifica se existem condições que impedem uma operação de instalação com êxito do SQL Server. Antes que a Instalação inicie a atualização da edição, o SCC recupera o status de cada item. Em seguida, compara o resultado com condições necessárias e fornece orientação para a remoção de problemas de bloqueio.

A verificação da configuração do sistema gera um relatório que contém uma breve descrição de cada regra executada, bem como o status de execução. O relatório de verificação da configuração do sistema está localizado em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Antes de executar a operação de instalação, reveja os seguintes tópicos:

  1. Requisitos de hardware e software para instalar o SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Recursos com suporte das edições do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerações de segurança de uma instalação do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versões de idiomas locais no SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Outras referências:

  1. Atualizações de versão e edição com suporte(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar o clustering de failover(http://go.microsoft.com/fwlink/?LinkId=235034)

Consulte também

Referência

Regras de suporte à Instalação


Relatório de Erros

 Copiar imagem em foco
[image]

Relatório de Erros
Enviar Comentários

Use a página Configurações do Relatório de Erro e Uso do Assistente de Instalação do SQL Server para habilitar a funcionalidade de relatório de erro e uso do SQL Server.

Opções

Por padrão, a coleta de dados sobre Uso de Recursos e o Relatório de Erros ficam habilitados para o SQL Server e seus componentes no Microsoft SQL Server 2012.

Relatório de Erros

Se você habilitar o recurso Relatório de Erros, o SQL Server será configurado para enviar, automaticamente, um relatório para a Microsoft caso um erro fatal ocorra em qualquer um dos seguintes componentes do SQL Server:

  • Mecanismo de Banco de Dados

  • SQL Server Agent

  • Analysis Services

  • Reporting Services

  • Integration Services

  • Replicação

A Microsoft usa relatórios de erros para melhorar a funcionalidade do SQL Server e trata todas as informações como confidenciais.

As informações sobre erros são enviadas através de uma conexão segura (https) para a Microsoft, onde são armazenadas com acesso limitado. Como alternativa, os relatórios de erros podem ser enviados para seu próprio servidor corporativo de relatório de erros.

Os relatórios de erros contêm as seguintes informações:

  • A condição do SQL Server quando ocorreu o problema.

  • A versão do sistema operacional e as informações de hardware.

  • Sua identificação digital do produto, que não é usado para identificar sua licença.

  • O endereço IP da rede do seu computador ou do servidor proxy.

  • Informações de memória ou do(s) arquivo(s) do processo que causou o erro.

A Microsoft não coleta seus arquivos nem seu nome, endereço, endereço de email ou qualquer outro formulário com informações pessoais intencionalmente. Entretanto, o relatório de erros pode conter informações pessoais da memória ou dos arquivos do processo que causou o erro. Apesar de essas informações poderem ser potencialmente usadas para determinar sua identidade, a Microsoft não usa essas informações com esse propósito.

Para obter mais informações sobre a política de privacidade e coleta de dados do SQL Server, consulte Política de privacidade do Microsoft SQL Server.

Se você habilitar Relatório de Erros e um erro fatal ocorrer, poderá ver uma resposta de Microsoft no log de eventos do Windows que apontará para um artigo específico na Base de Dados de Conhecimento Microsoft.

Para desabilitar os recursos de relatório de erro ou de uso para todas as instâncias do SQL Server e de seus componentes, depois de finalizar a Instalação, vá para a caixa de diálogo Configurações do Relatório de Erro e Uso e desmarque a caixa de seleção Uso de Recursos. Se a caixa Relatório de Erros estiver habilitada para vários componentes do SQL Server (Mecanismo de Banco de Dados do SQL Server, Analysis Services, Reporting Services e componentes compartilhados), você poderá desabilitar essa opção para cada instância do componente, bem como para os componentes compartilhados listados como Outros.


Relatório de cluster de failover

 Copiar imagem em foco
[image]

Relatório de cluster de failover
Enviar Comentários

Use a página Relatório de Cluster de Failover para exibir resultados de relatório do exame do sistema de Instalação para esta operação.

Opções

Para exibir um relatório detalhado do exame, clique no link de relatório.


Revisão dos recursos

 Copiar imagem em foco
[image]

Revisão dos recursos
Consulte também Enviar Comentários

A página Revisão de Recurso é uma lista somente leitura de recursos que foram preparados e serão configurados e concluídos no final da etapa de imagem completa. A lista de recursos é selecionada durante a etapa de preparação da imagem e não pode ser modificada durante a etapa de imagem completa. Além dos recursos exibidos, uma instância preparada inclui também o Navegador do SQL Server, o Gravador do SQL Server e o SQL Server Native Client.

Você pode adicionar outros recursos não incluídos na instância preparada da instância do SQL Server depois de concluir a configuração da instância preparada do SQL Server.

Grupo de componentes

Componentes e recursos

Serviços do Mecanismo de Banco de Dados

O Mecanismo de Banco de Dados do SQL Server inclui os seguintes componentes:

  • O Mecanismo de Banco de Dados é o serviço principal para armazenamento, processamento e segurança de dados.

    • Replicação: (opcional) a replicação é um conjunto de tecnologias para copiar e distribuir dados e objetos de um banco de dados para outro e, em seguida, sincronizar entre os bancos de dados para manter a consistência.

    • Pesquisa de Texto Completo: (opcional) a Pesquisa de Texto Completo fornece funcionalidade para realizar consultas de texto completo em dados baseados em caracteres não criptografados nas tabelas do SQL Server.

    • Data Quality Services (opcional): O DQS (Data Quality Services) é uma solução de limpeza de dados que permite descobrir dados inconsistentes e incorretos na fonte de dados, e fornece modos automatizados e interativos de limpar os dados.

Reporting Services

O Reporting Services inclui componentes de servidor e cliente por criar, gerenciar e implantar relatórios tabulares, de matriz, gráficos e de forma livre. O Reporting Services também é uma plataforma extensível que você pode usar para desenvolver aplicativos de relatório.

Consulte também

Outros recursos

Como instalar o SQL Server 2008 por meio de SysPrep


Regras de instalação

 Copiar imagem em foco
[image]

Regras de instalação
Consulte também Enviar Comentários

A Instalação do SQL Server valida a configuração do computador antes da conclusão da operação de Instalação. Durante a Instalação do SQL Server, o SCC (Verificador de Configuração do Sistema) examina o computador em que o SQL Server será instalado. O SCC verifica se existem condições que impedem uma operação de instalação com êxito do SQL Server. Antes que a Instalação inicie o Assistente de Instalação do SQL Server, o SCC recupera o status de cada item. Em seguida, compara o resultado com condições necessárias e fornece orientação para a remoção de problemas de bloqueio.

A verificação da configuração do sistema gera um relatório que contém uma breve descrição de cada regra executada, bem como o status de execução. O relatório de verificação da configuração do sistema está localizado em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Antes de executar a operação de instalação, reveja os seguintes tópicos:

  1. Requisitos de hardware e software para instalar o SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Recursos com suporte das edições do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerações de segurança de uma instalação do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versões de idiomas locais no SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Outras referências:

  1. Atualizações de versão e edição com suporte(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar o clustering de failover(http://go.microsoft.com/fwlink/?LinkId=235034)

Consulte também

Referência

Regras de suporte à Instalação


Regras de recurso

 Copiar imagem em foco
[image]

Regras de recurso
Enviar Comentários

A Instalação do SQL Server valida a configuração do computador antes da conclusão da operação de Instalação. Durante a Instalação do SQL Server, o SCC (Verificador de Configuração do Sistema) examina o computador em que o SQL Server será instalado. O SCC verifica se existem condições que impedem uma operação de instalação com êxito do SQL Server. Antes que a Instalação inicie, o SCC recupera o status de cada item. Em seguida, compara o resultado com condições necessárias e fornece orientação para a remoção de problemas de bloqueio.

A verificação da configuração do sistema gera um relatório que contém uma breve descrição de cada regra executada, bem como o status de execução. O relatório de verificação da configuração do sistema está localizado em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Antes de executar a operação de instalação, reveja os seguintes tópicos:

  1. Requisitos de hardware e software para instalar o SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Recursos com suporte das edições do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerações de segurança de uma instalação do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versões de idiomas locais no SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Outras referências:

  1. Atualizações de versão e edição com suporte(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar o clustering de failover(http://go.microsoft.com/fwlink/?LinkId=235034)


Seleção de recursos

 Copiar imagem em foco
[image]

Seleção de recursos
Consulte também Enviar Comentários

Use as caixas de seleção da página Seleção de Recursos do Assistente de Instalação do SQL Server para selecionar componentes para sua instalação do SQL Server.

Instalando os recursos do SQL Server

Na página Seleção de Recursos, os recursos do SQL Server estão separados em duas seções principais: Recursos da Instância e Recursos Compartilhados.

Recursos da Instância refere-se aos componentes que são instalados uma vez para cada instância para que você tenha várias cópias deles (uma para cada instância). Cada instância pode ser uma versão separada com um nível de patch diferente. Quando você instalar um patch, se for um service pack, um hotfix ou uma atualização cumulativa, ele atualizará apenas os arquivos de uma instância em determinada máquina, mais os recursos compartilhados caso não tenham sido atualizados.

Recursos Compartilhados refere-se aos recursos comuns em todas as instâncias de uma determinada máquina. Cada um desses recursos compartilhados foi criado para ser compatível com versões anteriores do SQL Server compatíveis (service packs, atualizações cumulativas e hotfixes) que podem instalar paralelamente.

Observação Observação

SQL Server SysPrep: o Mecanismo de Banco de Dados e o Reporting Services são os únicos recursos do Microsoft SQL Server 2012 com suporte para SQL Server SysPrep. Você pode selecionar estes recursos e componentes durante a etapa de preparação de imagem do processo. Não é possível fazer a seleção ao concluir uma imagem preparada do SQL Server. Para obter mais informações, consulte Instalar o SQL Server 2012 por meio de SysPrep (http://go.microsoft.com/fwlink/?LinkId=190965).

Clusters de Failover do SQL Server: os componentes Mecanismo de Banco de Dados e Analysis Services são os únicos recursos do Microsoft SQL Server 2012 com suporte para clustering de failover. Você pode instalar outros componentes, como o Reporting Services ou o Integration Services em um nó de cluster de failover, mas eles não dão suporte a cluster, e seus serviços não realizarão failover se o nó de cluster de failover ficar offline. Para obter mais informações, consulte Getting Started with SQL Server Failover Clustering (http://go.microsoft.com/fwlink/?LinkId=190953).

Recursos da Instância

Aparece uma descrição para cada grupo de componentes no painel Descrição quando você o seleciona. Você pode selecionar qualquer combinação de caixas de seleção. Para continuar, você deve fazer uma seleção.

Recursos

Descrição

Serviços do Mecanismo de Banco de Dados

O Mecanismo de Banco de Dados do SQL Server inclui o Mecanismo de Banco de Dados, o principal serviço para armazenamento, processamento e segurança de dados, replicação, pesquisa de texto completo, ferramentas para gerenciamento de dados XML ou relacionais e o servidor DQS (Data Quality Services).

  • O Mecanismo de Banco de Dados é o serviço principal para armazenamento, processamento e segurança de dados.

  • Replicação: (opcional) a replicação é um conjunto de tecnologias para copiar e distribuir dados e objetos de um banco de dados para outro e, em seguida, sincronizar entre os bancos de dados para manter a consistência.

  • Pesquisa de Texto Completo: (opcional) a Pesquisa de Texto Completo fornece funcionalidade para realizar consultas de texto completo em dados baseados em caracteres não criptografados nas tabelas do SQL Server.

  • Data Quality Services: opcional: O DQS (Data Quality Services) é uma solução de limpeza de dados que permite descobrir dados inconsistentes e incorretos na fonte de dados, e fornece modos interativos e assistidos por computador de limpar seus dados. Marque esta caixa de seleção para instalar o servidor DQS. Depois de concluir a instalação do SQL Server, você terá que executar o arquivo DQSInstaller.exe para concluir a instalação do servidor DQS. Se você instalou a instância padrão do SQL Server, esse arquivo estará disponível em C:\Arquivos de Programas\Microsoft SQL Server\MSSQL11.MSS QLSERVER\MSSQL\Binn.

Clusters de Failover do SQL Server: os componentes Replicação e Pesquisa de Texto Completo são necessários e selecionados automaticamente pela Instalação para instalações de clustering de failover do SQL Server quando você seleciona Serviços de Mecanismo de Banco de Dados.

Analysis Services

O Analysis Services inclui as ferramentas para criação e gerenciamento de aplicativos OLAP (processamento analítico online) e de mineração de dados.

Reporting Services – Nativo

O modo Nativo do Reporting Services inclui componentes de servidor e cliente para criar, gerenciar e implantar relatórios de tabelas, de matriz, gráficos e de forma livre. O Reporting Services também é uma plataforma extensível que você pode usar para desenvolver aplicativos de relatório.

Observação importante Importante

  1. A Instalação não configura o balanceamento de carga e o endereçamento de URL única para vários nós em uma implantação em expansão do Reporting Services. Para concluir uma implantação de expansão, você deve usar o Windows Server, o Microsoft Application Center ou software de gerenciamento de cluster de terceiros. Para obter mais informações sobre como configurar a implantação de Web farm, consulte Configuring Reporting Services for Scale-Out Deployment (http://go.microsoft.com/fwlink/?LinkId=199448).

  2. O Microsoft Internet Explorer 7.0 SP 1 é necessário para o componente Designer de Relatórios do Reporting Services.

  3. Não há suporte ao Reporting Services em configurações lado a lado na plataforma de 64 bits e no subsistema de 32 bits (WOW64) de uma servidor de 64 bits ao mesmo tempo.

Recursos compartilhados

Os recursos compartilhados por todas as instâncias do SQL Server em um único computador são instalados em um único diretório. Eles incluem o seguinte:

Recurso

Descrição

Reporting Services – SharePoint

O modo do SharePoint do Reporting Services é um aplicativo baseado em servidor para criar, gerenciar e entregar relatórios para email, vários formatos de arquivos e formações interativas baseadas na Web. O modo do SharePoint integra a exibição de relatórios e experiência de gerenciamento de relatórios com produtos do SharePoint.

Suplemento do Reporting Services para produtos do SharePoint

O suplemento do Reporting Services para produtos do SharePoint inclui componentes de gerenciamento e interface do usuário para integrar um produto do SharePoint com um servidor de relatórios Reporting Services no modo SharePoint.

Cliente Data Quality

O Cliente Data Quality é um aplicativo autônomo que se conecta ao servidor de DQS. Ele fornece uma interface gráfica intuitiva do usuário para executar operações de limpeza de dados e correspondência de dados, e para realizar tarefas administrativas no DQS.

Ferramentas de dados do SQL Server1

O SSDT (Ferramentas de Dados do SQL Server) oferece um IDE para criar soluções para os componentes de Business Intelligence: Analysis Services, Reporting Services e Integration Services.

(Antes chamado de Business Intelligence Development Studio).

O SSDT também inclui "Projetos de banco de dados" que oferecem um ambiente integrado para desenvolvedores de banco de dados realizarem seu trabalho de design de banco de dados para qualquer plataforma SQL Server (no local e fora do local) no Visual Studio. Os desenvolvedores de banco de dados podem usar o Gerenciador de Servidores aprimorado no Visual Studio para criar ou editar facilmente objetos de banco de dados e dados, ou executar consultas.

Conectividade das ferramentas de cliente

As Ferramentas de Cliente incluem componentes para a comunicação entre clientes e servidores, incluindo bibliotecas de rede para DB-Library, OLEDB para OLAP, ODBC, ADODB e ADOMD+.

Integration Services

O Integration Services é um conjunto de ferramentas gráficas e objetos programáveis para mover, copiar e transformar dados.

Compatibilidade com versões anteriores de ferramentas de cliente

A compatibilidade de versões anteriores de ferramentas de cliente inclui os seguintes componentes:

  • SQL Distributed Management Objects (SQL-DMO). Para obter mais informações, consulte Recursos descontinuados do SQL Server no SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=190968).

  • DSO (Decision Support Objects). Para obter mais informações, consulte Alterações recentes em recursos do Analysis Services no SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=190970).

SDK de Ferramentas de cliente

Inclui o Software Development Kit que contém recursos para programadores.

Componentes de documentação

Os componentes de documentação incluem os componentes para exibir e gerenciar o conteúdo da ajuda.

Ferramentas de Gerenciamento - Básicas

Ferramentas de Gerenciamento – Básicas: inclui o seguinte:

  • Suporte do SQL Server Management Studio para o utilitário Mecanismo de Banco de Dados do SQL Server, SQL Server Express, sqlcmd e o provedor do SQL Server PowerShell

Ferramentas de Gerenciamento – Completas: inclui os seguintes componentes, além dos componentes da versão básica:

  • Suporte do SQL Server Management Studio para Reporting Services, Analysis Services e Integration Services

  • SQL Server Profiler

  • Orientador de Otimização do Mecanismo de Banco de Dados

  • Gerenciamento do Utilitário do SQL Server

Distributed Replay Controller

O controlador Distributed Replay orquestra as ações dos clientes de reprodução distribuída. Cada ambiente de Distributed Replay pode conter apenas uma instância de controlador. Para obter mais informações, consulte SQL Server Distributed Replay (http://go.microsoft.com/fwlink/?LinkId=229847).

Distributed Replay Client

Os clientes do Distributed Replay trabalham juntos para simular cargas de trabalho em uma instância do SQL Server. Pode haver um ou mais clientes em cada ambiente do Distributed Replay. Para obter mais informações, consulte SQL Server Distributed Replay (http://go.microsoft.com/fwlink/?LinkId=229847).

SDK de Conectividade de Cliente do SQL

Inclui o SQL Server Native Client (ODBC/OLE DB) SDK para desenvolvimento de aplicativos de banco de dados.

Master Data Services

O Master Data Services é uma plataforma para integrar dados de sistemas discrepantes em uma organização em uma única fonte de dados mestre para fins de exatidão e auditoria. A opção Master Data Services instala o Gerenciador de Configuração do Master Data Services, assemblies, um snap-in do Windows PowerShell, pastas e arquivos de aplicativos e serviços Web.

LocalDB

LocalDB é um modo de execução do SQL Server Express destinado a desenvolvedores de programas. Iniciada por uma cadeia de conexão especial, a infraestrutura SQL Server necessária é criada e iniciada automaticamente, permitindo ao aplicativo usar o banco de dados sem tarefas de configuração ou de gerenciamento.

1O Internet Explorer 6.0 SP1 é necessário para instalações do SSDT (Ferramentas de dados do SQL Server).

Por padrão, os componentes compartilhados são instalados em %Arquivos de Programas%Microsoft SQL Server\. Para alterar o caminho de instalação, clique no botão Procurar. Se você alterar o caminho de instalação de um componente compartilhado, também o altera para outros componentes compartilhados. As instalações subsequentes instalarão componentes compartilhados no mesmo local que a instalação original.

Em sistemas operacionais com base em x64, você pode especificar onde os componentes de 64 bits serão instalados e onde no subsistema de 32 bits WOW64 os componentes serão instalados.

Instalando bancos de dados de exemplo AdventureWorks

Por padrão, os bancos de dados de exemplo e código de exemplo não são instalados como parte da Instalação do SQL Server. Para obter mais informações sobre como instalar bancos de dados de exemplo e o código de exemplo, consulte Exemplos e projetos da comunidade do Microsoft SQL Server (http://go.microsoft.com/fwlink/?LinkId=87843).

Informações adicionais sobre exemplos estarão disponíveis depois que o Microsoft SQL Server 2012 for instalado. No menu Iniciar, clique em Todos os Programas, clique em Microsoft SQL Server 2012, clique em Documentação e Tutoriais e clique em Visão Geral dos Exemplos do Microsoft SQL Server.

Consulte também

Outros recursos

Edições e componentes do SQL Server 2012


Seleção de recursos (desinstalação)

 Copiar imagem em foco
[image]

Seleção de recursos (desinstalação)
Enviar Comentários

Use a página Seleção de Recursos — Desinstalar para selecionar recursos a serem removidos da instância especificada do SQL Server.

Opções

Você pode selecionar qualquer combinação de recursos.


Recursos a atualizar

 Copiar imagem em foco
[image]

Recursos a atualizar
Consulte também Enviar Comentários

Use a página Recursos a Atualizar do Assistente para Instalação do Microsoft SQL Server 2012 para exibir os recursos a serem atualizados para o Microsoft SQL Server 2012.

Opções

  • Não é possível alterar os recursos a serem atualizados nesta versão. Para adicionar recursos a essa instância do SQL Server, conclua o processo de atualização, reinicie a Instalação e clique em Nova Instalação ou Adicionar Recursos a uma Instalação Existente no centro de instalação.

Consulte também

Outros recursos

Atualizações de versão e edição
Usando o Supervisor de Atualização para preparar para atualizações
Trabalhando com várias versões do SQL Server


Opções de Atualização da Pesquisa de Texto Completo

 Copiar imagem em foco
[image]

Opções de Atualização da Pesquisa de Texto Completo
Enviar Comentários

Use a página Opções de Atualização da Pesquisa de Texto Completo do Assistente de Instalação do SQL Server para selecionar as opções a serem usadas para os bancos de dados que você está atualizando no momento.

No SQL Server 2005 e em versões anteriores, cada índice de texto completo reside em um catálogo de texto completo que pertence a um grupo de arquivos, tem um caminho físico e é tratado como um arquivo de banco de dados. A partir do SQL Server 2008, um catálogo de texto completo é um conceito lógico — um objeto virtual — que se refere a um grupo de índices de texto completo. Por isso, um novo catálogo de texto completo não é tratado como um arquivo de banco de dados com um caminho físico. No entanto, durante a atualização de qualquer catálogo de texto completo que contém arquivos de dados, é criado um novo grupo de arquivos no mesmo disco. Isso mantém o antigo comportamento de E/S do disco após a atualização. Qualquer índice de texto completo desse catálogo será colocado no novo grupo de arquivos se existir o caminho raiz. Se o caminho do antigo catálogo de texto completo for inválido, a atualização manterá o índice de texto completo no mesmo grupo de arquivos que a tabela base ou, no caso de uma tabela particionada, no grupo de arquivos primário.

Opções

Ao atualizar do SQL Server 2005 ou SQL Server 2008 para Microsoft SQL Server 2012, escolha uma das opções de atualização de texto completo a seguir.

Importar

Os catálogos de texto completo são importados. A importação costuma ser consideravelmente mais rápida do que a recompilação. Por exemplo, quando é usada apenas uma CPU, a importação é executada cerca de 10 vezes mais rápido do que a recompilação. No entanto, um catálogo de texto completo importado do SQL Server 2005 não usa os separadores de palavras novos e aprimorados introduzidos no SQL Server 2008, de modo que pode ser conveniente recriar os catálogos de texto completo.

Observação Observação

A recompilação pode ser executada no modo multi-threaded e, se houver mais de 10 CPUs disponíveis, ela poderá ser executada mais rápido do que a importação se você autorizar o uso de todas as CPUs.

Se um catálogo de texto completo não estiver disponível, os índices de texto completo associados serão recompilados. Essa opção está disponível apenas para bancos de dados do SQL Server 2005.

Para obter informações sobre o impacto da importação do índice de texto completo, consulte "Considerações sobre como escolher uma opção de atualização de texto completo", mais adiante neste tópico.

Recompilar

Os catálogos de texto completo são recriados usando os separadores de palavras novos e aprimorados que foram introduzidos no SQL Server 2008. A recompilação de índices pode demorar um pouco, e uma quantidade significativa de memória e CPU pode ser necessária após a atualização.

Redefinir

Os catálogos de texto completo são redefinidos. Quando atualizados do SQL Server 2005, os arquivos de catálogo de texto completo são removidos, mas os metadados dos catálogos e dos índices de texto completo são preservados. Depois de serem atualizados, todos os índices de texto completo são desabilitados para o controle de alteração e os rastreamentos não são iniciados automaticamente. O catálogo permanecerá vazio até você executar uma população completa manualmente, depois que a atualização for concluída.

Todas essas opções de atualização garantem que os bancos de dados atualizados se beneficiem totalmente dos aprimoramentos de desempenho de texto completo do SQL Server 2008 e de versões posteriores.

Observação importante Importante

Para obter informações sobre como usar os novos separadores de palavras e atualizar os arquivos de palavras de ruído para listas de palavras irrelevantes depois de importar um índice de texto completo do SQL Server 2005, consulte o tópico "Atualização da pesquisa de texto completo" na Ajuda da Instalação do Microsoft SQL Server 2012.

Considerações sobre como escolher uma opção de atualização de texto completo

Ao escolher a opção de atualização para sua atualização, considere o seguinte:

  • Como você usa os separadores de palavras?

    O serviço de pesquisa de texto completo no Microsoft SQL Server 2012 inclui separadores de palavras e lematizadores que foram introduzidos no SQL Server 2008. Eles podem alterar os resultados de consultas de texto completo do SQL Server 2005 para um cenário ou padrão de texto específico. Portanto, a maneira como você usa os separadores de palavras é importante na hora de escolher uma opção de atualização apropriada:

    • Se os separadores de palavras do idioma de texto completo que você usa não foram alterados no SQL Server 2008 ou versões posteriores, ou se a precisão dos dados recuperados não for essencial, a importação é a opção adequada. Posteriormente, se você tiver algum problema em relação a recuperação, poderá atualizar para os novos separadores de palavras recompilando os catálogos de texto completo. Para obter mais informações, consulte o tópico "Atualização da pesquisa de texto completo" na Ajuda da Instalação do Microsoft SQL Server 2012.

    • Se a precisão dos dados recuperados for um aspecto importante e você usar um os separadores de palavras que foram aprimorados no SQL Server 2008, a recompilação será adequada.

  • Algum índice de texto completo foi compilado em colunas de chave de texto completo integer?

    A recompilação faz otimizações internas que, em alguns casos, melhoram o desempenho de consultas do índice de texto completo atualizado. Especificamente, se você tiver catálogos de texto completo que contêm índices de texto completo para os quais a coluna de chave de texto completo da tabela base é do tipo de dados integer, a recompilação atingirá o desempenho ideal de consultas de texto completo depois da atualização. Nesse caso, é altamente recomendável usar a opção Recriar.

    Observação Observação

    Para os índices de texto completo do Microsoft SQL Server 2012, é recomendável que a coluna que funciona como a chave de texto completo seja um tipo de dados integer. Para obter mais informações, consulte o tópico “Otimização e ajuste de desempenho (Pesquisa de Texto Completo)” nos Manuais Online do Microsoft SQL Server 2012 Books Online.

  • Qual é a prioridade para colocar a instância de servidor online?

    A importação ou a recompilação durante a atualização usa muitos recursos da CPU, o que faz com que o restante da instância do servidor demore para ser atualizado e ficar online. Se colocar a instância do servidor online o mais rápido possível é importante para você e se você deseja executar uma população manual depois da atualização, a opção Redefinir é a mais adequada.


Instalação - Concluída

 Copiar imagem em foco
[image]

Instalação - Concluída
Consulte também Enviar Comentários

Clique em Fechar para concluir a instalação.

Consulte também

Conceitos

Validar uma instalação do SQL Server


Pré-requisitos para instalação

 Copiar imagem em foco
[image]

Pré-requisitos para instalação
Enviar Comentários

Para que o SQL Server seja instalado com êxito, os componentes de software a seguir são necessários no computador de instalação. Eles serão instalados pela Instalação do SQL Server:

  • .NET Framework versão 4.0 para todas as outras edições do Microsoft SQL Server 2012

  • Arquivos de suporte à Instalação do SQL Server

  • SQL Server Native Client

Observação Observação

Esses componentes não serão removidos se a Instalação falhar ou for cancelada. Para removê-los, use Adicionar ou Remover Programas no Painel de Controle.

Opções

Para instalar os arquivos de pré-requisito, clique em Instalar. Para encerrar a instalação, clique em Cancelar.


Andamento da Instalação

 Copiar imagem em foco
[image]

Andamento da Instalação
Consulte também Enviar Comentários

Use a página Andamento da Instalação do Assistente de Instalação do SQL Server para monitorar o status da Instalação do SQL Server.

Consulte também

Conceitos

Exibir e ler arquivos de log da Instalação do SQL Server


Tipo de Instalação

 Copiar imagem em foco
[image]

Tipo de Instalação
Enviar Comentários

Use a página Tipo de Instalação do Assistente de Instalação do SQL Server para especificar se deseja instalar uma nova instância do SQL Server ou adicionar recursos a uma instância existente.

Opções

Selecione o botão de opção que especifica sua opção:

  • Executar uma nova instalação do SQL Server

  • Adicionar recursos a uma instância existente do SQL Server

    Se você selecionar a opção para adicionar recursos a uma instância existente, use a lista suspensa para selecionar a instância do SQL Server a ser atualizada.

Você somente pode adicionar os recursos com suporte do SysPrep — Mecanismo de Banco de Dados e Reporting Services — a imagem preparada do SQL Server. Outros recursos aos quais o SysPrep não oferece suporte só poderão ser adicionados depois que a instância preparada for concluída.

Observação Você não poderá adicionar recursos a uma instância de cluster de failover depois que ela for instalada. Para adicionar recursos do SQL Server a um cluster de failover existente, você deve executar uma nova instalação para instalar uma instância separada do SQL Server.


Configuração da instância

 Copiar imagem em foco
[image]

Configuração da instância
Enviar Comentários

Use a página Configuração da Instância do Assistente de Instalação do SQL Server para especificar se deve ser criada uma instância padrão ou nomeada do SQL Server. Se uma instância do SQL Server ainda não estiver instalada, uma instância padrão será criada, a menos que você especifique uma instância nomeada.

Cada instância do SQL Server consiste em um conjunto distinto de serviços que têm configurações específicas para agrupamentos e outras opções. A estrutura de diretórios, a estrutura do Registro e os nomes do serviço refletem o nome da instância e uma ID de instância específica criada durante a Instalação do SQL Server.

Uma instância é a instância padrão ou uma instância nomeada. O nome de instância padrão é MSSQLSERVER. Não é necessário que um cliente especifique o nome da instância para estabelecer uma conexão. Uma instância nomeada é determinada pelo usuário durante a Instalação. Você pode instalar o SQL Server como uma instância nomeada sem instalar a instância padrão em primeiro lugar. Apenas uma instalação do SQL Server, independentemente da versão, pode ser a instância padrão em determinado momento.

Observação Observação

Com o SQL Server SysPrep, você poderá especificar o nome da instância quando concluir uma instância preparada na página Configuração da Instância. Você pode optar por configurar a instância preparada que está concluindo como uma instância padrão, se não houver nenhuma instância padrão existente do SQL Server no computador.

Várias instâncias

O SQL Server dá suporte a várias instâncias do SQL Server em um único servidor ou processador, mas somente uma instância pode ser a padrão. Todas as demais devem ser instâncias nomeadas. Um computador pode executar várias instâncias do SQL Server simultaneamente e cada instância é executada independentemente das demais.

Para obter mais informações, consulte Maximum Capacity Specifications for SQL Server (em inglês).

Opções

Somente instâncias de cluster de failover — Especifique o nome de rede do cluster de failover do SQL Server. Esse nome identifica a instância do cluster de failover na rede.

Instância padrão ou nomeada — Considere as seguintes informações ao decidir se deve instalar uma instância padrão ou nomeada do SQL Server:

  • Se você planeja instalar uma única instância do SQL Server em um servidor de banco de dados, ela deve ser uma instância padrão.

  • Use uma instância nomeada para situações em que planeja ter várias instâncias no mesmo computador. Um servidor pode hospedar somente uma instância padrão.

  • Qualquer aplicativo que instale o SQL Server Express deve instalá-lo como uma instância nomeada. Isso minimizará conflitos quando vários aplicativos forem instalados no mesmo computador.

Instância padrão

Selecione esta opção para instalar uma instância padrão do SQL Server. Um computador pode hospedar apenas uma instância padrão; todas as demais devem ser nomeadas. Entretanto, se você tiver uma instância padrão do SQL Server instalada, poderá adicionar uma instância padrão do Analysis Services no mesmo computador.

Instância nomeada

Selecione esta opção para criar uma nova instância nomeada. Esteja ciente do seguinte ao nomear uma instância do SQL Server:

  • Os nomes de instância não diferenciam maiúsculas de minúsculas.

  • Nomes de instância não podem iniciar nem terminar com um sublinhado (_).

  • Os nomes de instância não podem conter o termo "Padrão" ou outras palavras-chave reservadas. Se uma palavra-chave reservada for usada em um nome de instância, ocorrerá um erro de Instalação. Para obter mais informações, consulte Reserved Keywords.

  • Se você especificar MSSQLServer para o nome de instância, uma instância padrão será criada. Para o SQL Server Express, se você especificar SQLExpress para o nome da instância, uma instância padrão será criada.

  • Uma instalação do Microsoft SQL Server 2012 PowerPivot para SharePoint sempre é instalada como uma instância nomeada do 'PowerPivot'. Você não pode especificar um nome de instância diferente para essa função de recurso.

  • Os nomes de instância estão limitados a 16 caracteres.

  • O primeiro caractere do nome da instância deve ser uma letra. As letras aceitáveis são as definidas pelo Padrão Unicode 2.0. Elas incluem os caracteres latinos de a-z, A-Z e caracteres de letra de outros idiomas.

  • Os caracteres subsequentes podem ser letras definidas pelo Padrão Unicode 2.0, números decimais de Latim Básico ou outros scripts nacionais, o sinal de cifrão ($) ou um sublinhado (_).

  • Não são permitidos espaços inseridos ou outros caracteres especiais em nomes de instância. Os caracteres barra invertida (\), vírgula (,), dois-pontos (:), ponto-e-vírgula (;), aspas simples ('), E comercial (&) e arroba (@) também não são permitidos.

    Observação Observação

    Somente caracteres que são válidos na página de código Windows atual podem ser usados em nomes de instância do SQL Server. Se um caractere Unicode sem-suporte for usado, ocorrerá um erro de Instalação.

Instâncias e recursos detectados

Exiba uma lista de instâncias e componentes instalados do SQL Server no computador em que a Instalação do SQL Server está sendo executada.

ID da Instância - Por padrão, o nome da instância é usado como a ID da Instância. Isso é usado para identificar os diretórios de instalação e as chaves do Registro da sua instância do SQL Server. Esse é o caso para instâncias padrão e instâncias nomeadas. Para uma instância padrão, o nome de instância e o ID da instância seriam MSSQLSERVER. Para usar um ID de instância não padrão, especifique-o no campo ID da Instância.

Observação importante Importante

Com o SQL Server SysPrep, a ID da Instância exibida nesta página é a ID da Instância especificada durante a etapa de preparação da imagem do processo SQL Server SysPrep. Você não poderá especificar uma ID da Instância diferente durante a etapa de conclusão de imagem.

Observação Observação

As IDs de instância que começam com sublinhado (_) ou contêm o sinal numérico (#) ou o cifrão ($) não têm suporte.

Para obter mais informações sobre diretórios, locais de arquivos e nomenclatura de IDs de instância, consulte Locais de arquivos para instâncias padrão e nomeadas do SQL Server.

Diretório raiz da instância - Por padrão, o diretório raiz da instância é C:\Arquivos de Programas\Microsoft SQL Server\. Para especificar um diretório raiz não padrão, clique no botão Procurar ou forneça um nome de caminho.

Todos os componentes de uma determinada instância do SQL Server são gerenciados como uma unidade. Todos os service packs e atualizações do SQL Server serão aplicados a cada componente de uma instância do SQL Server.

Todos os componentes do SQL Server que compartilham o mesmo nome de instância devem atender aos seguintes critérios:

  • Mesma versão

  • Mesma edição

  • Mesmas configurações de idioma

  • Mesmo estado clusterizado

    Observação Observação

    O Reporting Services não dá suporte a cluster.

  • Mesmo sistema operacional


Seleção de instância (desinstalação)

 Copiar imagem em foco
[image]

Seleção de instância (desinstalação)
Enviar Comentários

Na Seleção de Instância, página Desinstalar, use a caixa suspensa para especificar a instância do SQL Server a ser desinstalada.

Opções

Você pode especificar uma instância inteira do SQL Server ou especificar que apenas os recursos compartilhados e as Ferramentas de Gerenciamento são desinstalados.


Seleção de Instância (Atualização)

 Copiar imagem em foco
[image]

Seleção de Instância (Atualização)
Enviar Comentários

Use a página Seleção de Instância (Atualização) para especificar a instância do SQL Server a ser atualizada.

Opções

Todos os componentes de uma instância devem ser atualizados ao mesmo tempo. Você não pode adicionar ou remover recursos durante a atualização.


Instância para atualização

 Copiar imagem em foco
[image]

Instância para atualização
Consulte também Enviar Comentários

Use a página Instância para Atualização do Assistente para Instalação do SQL Server para especificar a instância do SQL Server 2005, SQL Server 2008, ou SQL Server 2008 R2 que você gostaria de atualizar para o Microsoft SQL Server 2012.

Opções

Use os botões de opção para especificar se deseja atualizar a instância do SQL Server e seus componentes compartilhados ou atualizar somente os componentes compartilhados. Os componentes compartilhados desta versão do SQL Server são os seguintes:

  • Integration Services

  • Navegador do SQL Server

  • Auxiliar do SQL Server Active Directory

  • Gravador do SQL

Para obter mais informações sobre cenários de atualização com suporte e problemas conhecidos de atualização, consulte Version and Edition Upgrades.

Consulte também

Outros recursos

Usando o Supervisor de Atualização para preparar para atualizações
Trabalhando com várias versões do SQL Server


Pós-desinstalação

 Copiar imagem em foco
[image]

Pós-desinstalação
Enviar Comentários

Use a página Pós-desinstalação para verificar se a operação foi concluída com êxito.


Progresso da Preparação de Imagem

 Copiar imagem em foco
[image]

Progresso da Preparação de Imagem
Consulte também Enviar Comentários

Use a página Progresso da Preparação de Imagem do Assistente de Instalação do SQL Server para monitorar o status da instalação da preparação de imagem do SQL Server. Após a conclusão dessa etapa, essa página listará o status para cada recurso do SQL Server preparado durante este processo.

Consulte também

Conceitos

Exibir e ler arquivos de log da Instalação do SQL Server


Regras de Preparação de Imagem

 Copiar imagem em foco
[image]

Regras de Preparação de Imagem
Enviar Comentários

A Instalação do SQL Server valida a configuração do computador antes da conclusão da operação de Instalação. Durante a Instalação do SQL Server, o SCC (Verificador de Configuração do Sistema) examina o computador em que o SQL Server será instalado. O SCC verifica se existem condições que impedem uma operação de instalação com êxito do SQL Server. Antes que a Instalação inicie o assistente, o SCC recupera o status de cada item. Em seguida, compara o resultado com condições necessárias e fornece orientação para a remoção de problemas de bloqueio.

A verificação da configuração do sistema gera um relatório que contém uma breve descrição de cada regra executada, bem como o status de execução. O relatório de verificação da configuração do sistema está localizado em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Antes de executar a operação de instalação, reveja os seguintes tópicos:

  1. Requisitos de hardware e software para instalar o SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Recursos com suporte das edições do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerações de segurança de uma instalação do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versões de idiomas locais no SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Outras referências:

  1. Atualizações de versão e edição com suporte(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar o clustering de failover(http://go.microsoft.com/fwlink/?LinkId=235034)


Preparar tipo de imagem

 Copiar imagem em foco
[image]

Preparar tipo de imagem
Enviar Comentários

Use a página Preparar Tipo de Imagem do Assistente de Instalação do SQL Server para especificar se deseja instalar uma nova instância do Microsoft SQL Server 2012 ou adicionar recursos a uma instância existente.

Opções

Selecione o botão de opção que especifica sua opção:

  • Preparar uma nova instância do Microsoft SQL Server 2012

  • Adicionar recursos a uma instância preparada existente do Microsoft SQL Server 2012

    Se você selecionar a opção para adicionar recursos a uma instância existente, use a lista suspensa para selecionar a instância preparada do SQL Server a ser atualizada.

    Observação Observação

    Você pode adicionar os recursos com suporte do SysPrep do SQL Server (Mecanismo de Banco de Dados e Reporting Services) a uma imagem preparada do SQL Server. Outros recursos aos quais o SysPrep do SQL Server não dá suporte só poderão ser adicionados depois que a instância preparada estiver concluída.


Chave do produto

 Copiar imagem em foco
[image]

Chave do produto
Enviar Comentários

Use a página Chave do Produto (Product Key) para validar a instância do SQL Server ou para especificar a edição gratuita do SQL Server a ser instalada.

Opções

Para especificar uma edição gratuita do SQL Server, selecione o botão de opção para instalações gratuitas e use a caixa suspensa para identificar a edição a ser instalada.

Para validar uma edição paga do SQL Server, selecione o botão de opção para a Chave do Produto e forneça a chave no espaço fornecido.

Para instalações de cluster de failover, use a mesma chave do produto para cada nó de cluster de failover. Se a chave do produto for de uma edição diferente do SQL Server, ocorrerá um erro.


Andamento (desinstalação)

 Copiar imagem em foco
[image]

Andamento (desinstalação)
Consulte também Enviar Comentários

Use a página Progresso (Desinstalar) para monitorar o andamento da Instalação.

Consulte também

Conceitos

Exibir e ler arquivos de log da Instalação do SQL Server


Pronto para Concluir Imagem

 Copiar imagem em foco
[image]

Pronto para Concluir Imagem
Enviar Comentários

A página Pronto para Imagem Completa fornece um resumo dos parâmetros de configuração que se aplicam à configuração da instância preparada.

Opções

Você tem as seguintes opções nesta página:

  • Para continuar a Instalação, clique em Instalar.

  • Para alterar suas configurações de instalação, clique em Voltar.

  • Para encerrar a Instalação, clique em Cancelar.


Pronto para instalar

 Copiar imagem em foco
[image]

Pronto para instalar
Consulte também Enviar Comentários

A página Pronto para Instalar apresenta um resumo dos recursos a serem instalados ou alterados pela instalação do SQL Server.

Opções

Você tem as seguintes opções nesta página:

  • Para continuar a Instalação, clique em Instalar.

  • Para alterar suas configurações de instalação, clique em Voltar.

  • Para encerrar a Instalação, clique em Cancelar.

Consulte também

Conceitos

Exibir e ler arquivos de log da Instalação do SQL Server


Pronto para Preparar Imagem

 Copiar imagem em foco
[image]

Pronto para Preparar Imagem
Enviar Comentários

A página Pronto para Preparar Imagem fornece um resumo dos recursos a serem preparados pela instalação do SQL Server.

Opções

Você tem as seguintes opções nessa página:

  • Para continuar a Instalação, clique em Instalar.

  • Para alterar suas configurações de instalação, clique em Voltar.

  • Para encerrar a Instalação, clique em Cancelar.


Pronto para Reparar

 Copiar imagem em foco
[image]

Pronto para Reparar
Consulte também Enviar Comentários

A página Pronto para Reparar fornece um resumo do processo de reparo através da Instalação do SQL Server.

Opções

Você tem as seguintes opções nesta página:

  • Para continuar a Instalação, clique em Reparar.

  • Para alterar suas configurações de instalação, clique em Voltar.

  • Para encerrar a Instalação, clique em Cancelar

Consulte também

Conceitos

Exibir e ler arquivos de log da Instalação do SQL Server


Remover nó de cluster de failover do SQL Server

 Copiar imagem em foco
[image]

Remover nó de cluster de failover do SQL Server
Enviar Comentários

Use a página Remover Nó de Cluster de Failover para identificar o computador a ser removido como um nó do cluster de failover do Microsoft SQL Server 2012.


Progresso do Reparo

 Copiar imagem em foco
[image]

Progresso do Reparo
Consulte também Enviar Comentários

Use a página Progresso do Reparo do Assistente de Instalação do SQL Server para monitorar o status de reparo do SQL Server.

Consulte também

Conceitos

Exibir e ler arquivos de log da Instalação do SQL Server


Opções de configuração do Reporting Services (SSRS)

 Copiar imagem em foco
[image]

Opções de configuração do Reporting Services (SSRS)
Consulte também Enviar Comentários

Use a página Configuração do Reporting Services do Assistente de Instalação do Microsoft SQL Server a fim de especificar como um servidor de relatório é instalado e configurado. A disponibilidade de uma opção de instalação depende das opções escolhidas anteriormente na página Seleção de Recursos e se você também está instalando uma instância local do Mecanismo de Banco de Dados do SQL Server enquanto está instalando o servidor de relatório.

Em alguns casos, se um certificado SSL estiver instalado no computador e estiver associado a um caractere curinga forte, a Instalação criará as URLs do Reporting Services usando o prefixo HTTPS. Para obter mais informações sobre como certificados são mapeados para URLs do Reporting Services, consulte Configurando um servidor de relatório para conexões de protocolo SSL (http://go.microsoft.com/fwlink/?LinkId=199089) nos Manuais Online do SQL Server.

Para obter as informações mais recentes sobre o Reporting Services e a instalação e configuração dessa versão, consulte Informações de instalação adicionais (http://go.microsoft.com/fwlink/?LinkId=207425).

Opções

Modo nativo do Reporting Services

Se a Instalação não puder executar uma configuração padrão do servidor de relatório porque um ou mais requisitos não foram atendidos, o Assistente de Instalação permitirá somente a opção de instalação mínima, copiando os arquivos que você precisa, mas exigindo que você use o Gerenciador de Configuração do Reporting Services para configurar o servidor de relatório de modo nativo depois que a instalação for concluída.

Observação Observação

Um arquivo de banco de dados do servidor de relatório existente pode causar falha na instalação se você escolher uma das opções de instalação padrão. Ao escolher uma opção de instalação padrão, a instalação tentará criar um banco de dados do servidor de relatório usando o nome padrão. Se já houver um banco de dados com esse nome, ocorrerá falha na instalação e você deverá reverter a instalação. Para evitar esse problema, renomeie o banco de dados existente antes de executar a instalação ou escolher a opção Instalar somente para que você possa especificar configurações de banco de dados personalizadas depois que a instalação for concluída.

Instalar e configurar

Instala uma instância do servidor de relatório no Modo Nativo usando os valores padrão dos bancos de dados do servidor de relatório, a conta de serviço e as reservas de URL. Ao escolher essa opção, a instância do servidor de relatório estará pronta para uso quando a Instalação for concluída. A Instalação cria o banco de dados do servidor de relatório usando uma instância local do Mecanismo de Banco de Dados e configura um servidor de relatório para usar valores padrão.

Essa opção estará disponível apenas se os valores padrão usados em uma instalação do servidor de relatório forem válidos para o seu sistema. Essa opção é recomendada para desenvolvedores que desejam instalar todos os componentes localmente e para os usuários que estejam avaliando o software.

Para exibir informações sobre as Configurações padrão que a Instalação usa ou para descobrir por que a configuração padrão não pode ser instalada, clique em Detalhes. Para obter mais informações sobre a configuração padrão para um servidor de relatório de modo nativo, consulte Configuração padrão para instalação no modo nativo (Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199091).

Instalar somente

Instala os arquivos de programas do servidor de relatório, cria a conta do serviço Servidor de Relatório e registra o provedor WMI (Instrumentação de Gerenciamento do Windows) do servidor de relatório. Essa opção de instalação é chamada de instalação "somente arquivos". Selecione-a se você não quiser usar a configuração padrão. Se a configuração padrão não puder ser instalada, ou se você estiver instalando um cluster de failover do SQL Server que inclua o Reporting Services, essa será a única opção disponível. Para obter mais informações sobre uma instalação somente de arquivos, consulte Instalação somente de arquivos (Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199093).

Depois que a Instalação for concluída, você deverá criar o banco de dados do servidor de relatório e configurar o servidor de relatório antes que ele possa ser usado. Para configurar um servidor de relatório e criar o banco de dados, use a ferramenta Gerenciador de Configurações do Reporting Services. Para obter mais informações, consulte Como criar um banco de dados do servidor de relatório (Configuração do Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199094) e Configurando uma conexão do banco de dados do servidor de relatório (http://go.microsoft.com/fwlink/?LinkId=199095).

Modo do SharePoint do Reporting Services

Instalar somente

Instala os arquivos de programa do servidor de relatório e os cmdlets do PowerShell. Depois que a instalação for concluída, você precisará iniciar os serviços do SharePoint do Reporting Services e criar um aplicativo de serviço do Reporting Services. Para obter mais informações, consulte Visão geral da instalação e configuração do serviço do Reporting Services para integração com o SharePoint (http://go.microsoft.com/fwlink/?LinkId=207543), Criar um aplicativo de serviço SSRS (SQL Server Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=207544) e Visão geral do Reporting Services e da integração com o SharePoint (http://go.microsoft.com/fwlink/?LinkID=207244).

Instalando o Suplemento Reporting Services para Tecnologias SharePoint

A partir da versão Microsoft SQL Server 2012, o suplemento pode ser instalado como parte da instalação do SQL Server na página de seleção de recursos do assistente de instalação do SQL Server.

No entanto, você pode instalar o Suplemento do Reporting Services para SharePoint 2010 usando um dos métodos a seguir:

  • Execute a ferramenta de Preparação de Produtos do SharePoint 2010 PreRequisiteInstaller.exe.

  • Execute a instalação a partir da mídia de instalação do SQL Server. Clique no arquivo rsSharePoint.msi na pasta de Instalação da mídia de instalação do SQL Server depois que a Instalação do SQL Server for concluída.

  • Baixar e instalar o suplemento. Para obter mais informações, consulte Onde encontrar o suplemento Reporting Services para produtos do SharePoint (http://go.microsoft.com/fwlink/?LinkID=208634).

Consulte também

Outros recursos

Como iniciar a ferramenta Configuração do Reporting Services
Como criar um banco de dados do servidor de relatório (Configuração do Reporting Services)
Considerações sobre a instalação do Reporting Services
Configuração padrão para instalação no modo nativo (Reporting Services)
Configuração padrão para modo do SharePoint (Reporting Services)
Instalar o SQL Server a partir do prompt de comando


Atualização do modo do SharePoint do Reporting Services (SSRS)

 Copiar imagem em foco
[image]

Atualização do modo do SharePoint do Reporting Services (SSRS)
Consulte também Enviar Comentários

Use a página do Modo do Reporting Services SharePoint para confirmar a atualização de todos os recursos compartilhados. O modo do Reporting Services SharePoint é um recurso compartilhado do SQL Server e será atualizado com todos os outros recursos compartilhados do SQL Server. O assistente de instalação do SQL Server não dá suporte à atualização de somente um recurso compartilhado. Todos os recursos compartilhados do SQL Server são atualizados ao mesmo tempo.

Opções

O botão Avançar estará disponível somente se você tiver marcado a caixa de seleção Continuar com a atualização. Se você não marcar a caixa de seleção, não poderá continuar a atualização.

Para obter mais informações, consulte Atualização do Reporting Services (http://go.microsoft.com/fwlink/?LinkId=199092).

Consulte também

Conceitos

Exibir e ler arquivos de log da Instalação do SQL Server

Outros recursos

Instalar o SQL Server do prompt de comando


Reporting Services no modo de autenticação do SharePoint

 Copiar imagem em foco
[image]

Reporting Services no modo de autenticação do SharePoint
Consulte também Enviar Comentários

Use a página Autenticação do modo do SharePoint do Reporting Services do Assistente de instalação do Microsoft SQL Server para especificar as credenciais da conta do serviço que é usado na instalação atual do Reporting Services. As credenciais serão usadas para criar um novo pool de aplicativos do SharePoint. Além disso, um novo aplicativo de serviço SharePoint do Reporting Services será criado. O nome do aplicativo de serviço conterá o nome da instância do Reporting Services anterior.

Opções

  • A opção Nome da conta do pool de aplicativos do SSRS: é somente leitura. O valor é automaticamente populado com o valor atual da instalação do Reporting Services existente que você está atualizando.

  • A opção Senha da conta do pool de aplicativos do SSRS: será desabilitada se a conta do pool de aplicativos não exigir uma senha. Por exemplo, “NT Authority\NetworkSerivce”. Se a conta do pool de aplicativos exigir uma senha, você só poderá continuar com a atualização se digitar a senha correta.

Para obter mais informações, consulte Atualização do Reporting Services (http://go.microsoft.com/fwlink/?LinkId=199092).

Consulte também

Outros recursos

Atualização do Reporting Services


Selecionar uma instância preparada

 Copiar imagem em foco
[image]

Selecionar uma instância preparada
Enviar Comentários

Use a página Selecione uma Instância Preparada para especificar a instância preparada que você deseja concluir.

Opções

A caixa Selecione uma ID de instância lista as instâncias preparadas que você pode concluir. Selecione uma instância preparada que você deseja concluir.

Selecione uma ID de instância

A lista inclui todas as instâncias preparadas que você pode concluir no computador em que a instalação do SQL Server está sendo executada. Selecione uma instância preparada que você deseja concluir.

Instâncias Instaladas

Inclui as instâncias instaladas, preparadas e concluídas.


Configuração do SQL Server - Agrupamento

 Copiar imagem em foco
[image]

Configuração do SQL Server - Agrupamento
Enviar Comentários

Na página Configuração do Servidor - Agrupamento do Assistente de Instalação do SQL Server, você pode modificar as configurações de agrupamento usadas pelo Mecanismo de Banco de Dados e pelo Analysis Services para fins de classificação. Selecione a opção para corresponder as configurações de agrupamento de instalações diferentes do SQL Server ou de outro computador.

Opções

Personalizar para o SQL Server e o Analysis Services

O SQL Server oferece dois grupos de agrupamentos: agrupamentos do Windows e agrupamentos do SQL Server. Você pode especificar configurações de agrupamento separadas para o Mecanismo de Banco de Dados e o Analysis Services ou especificar o mesmo agrupamento para ambos.

Por padrão, um agrupamento do SQL Server é selecionado para localidades do sistema do idioma inglês. O agrupamento padrão para versões localizadas do SQL Server é determinado pela configuração de localidade do sistema Windows em seu computador. Para obter mais informações, consulte Using SQL Collations.

As configurações padrão devem ser alteradas apenas se a configuração de agrupamento dessa instalação do SQL Server corresponder às configurações de agrupamento usadas por outra instância do SQL Server ou se ela corresponder à localidade do sistema Windows de outro computador.

Observação O Analysis Services usa somente agrupamentos do Windows. Se você planeja instalar o Analysis Services, selecione um agrupamento do Windows durante o processo de instalação do SQL Server para garantir a consistência dos resultados entre o Mecanismo de Banco de Dados do SQL Server e o Analysis Services.

Para obter mais informações, consulte Collation Settings in Setup.

Práticas recomendadas

Para obter mais informações sobre uma tabela de localidades de Sistema do Windows e os agrupamentos padrão correspondentes usados pela Instalação do SQL Server, consulte Collation Settings in Setup.

Se possível, use um agrupamento exclusivo para sua organização. Dessa forma, não será preciso especificar explicitamente o agrupamento para cada banco de dados, coluna, expressão ou identificador. Se você precisar trabalhar com vários agrupamentos e configurações de página de códigos diferentes, codifique suas consultas para considerar as regras da precedência de agrupamento. Para obter mais informações, consulte o tópico Collation Precedence (Transact-SQL).

Quando você selecionar um agrupamento para o SQL Server, considere as seguintes recomendações:

  • Selecione um agrupamento BINARY2 se ordenação binária baseada em ponto de código for aceitável.

  • Selecione um agrupamento do Windows para que a comparação seja consistente em todos os tipos de dados.

  • Use um novo agrupamento nível 100 para obter um suporte melhor à classificação lingüística. Para obter mais informações, consulte Suporte a agrupamentos e a Unicode.

  • Caso você pretenda migrar um banco de dados para a instância atualizada do SQL Server, selecione o agrupamento correspondente ao seu agrupamento existente do banco de dados.


Configuração do servidor - Contas de serviço

 Copiar imagem em foco
[image]

Configuração do servidor - Contas de serviço
Consulte também Enviar Comentários

Use a página Configuração do Servidor do Assistente de Instalação do SQL Server para atribuir contas de logon aos serviços do SQL Server. Os serviços reais configurados nessa página dependem dos recursos que você selecionou para instalação.

As contas de inicialização usadas para iniciar e executar o SQL Server podem ser contas de usuário de domínio, contas de usuário locais, contas de serviço gerenciado, contas virtuais ou contas de sistema internas.

Opções

Você pode atribuir a mesma conta de logon a todos os serviços do SQL Server ou configurar cada conta de serviço individualmente. Você também pode especificar se os serviços serão iniciados automaticamente ou manualmente, ou se eles serão desabilitados. A conta padrão é recomendada para a maioria das instalações.

  • No Windows 7 e no Windows Server 2008 R2, a maioria das contas assume como padrão uma conta virtual.

  • No Windows Vista e no Windows Server 2008, a maioria das contas assume como padrão a conta NETWORK SERVICE.

  • Em uma instalação de cluster no Windows Server 2008, você deve fornecer uma conta de domínio.

Se você configurar serviços para usar contas de domínio, a Microsoft recomenda que você configure as contas de serviço individualmente para fornecer privilégios mínimos a cada serviço, nos quais os serviços do SQL Server recebem as permissões mínimas necessárias para concluir suas tarefas. Para obter mais informações, inclusive descrições dos tipos de contas, consulte Configurando contas de serviço do Windows.

Configurar individualmente as contas de serviço do SQL Server (recomendado)

Use a grade para provisionar cada serviço do SQL Server com um nome de usuário e senha de logon, e para definir o tipo de inicialização para o serviço. Você pode usar contas de sistema internas, uma conta local, um grupo local, um grupo de domínio ou contas de usuário do domínio para os serviços do SQL Server.

Selecione quaisquer dos serviços a seguir para personalizar suas configurações.

Selecione este serviço

Para configurar os parâmetros de autenticação para

SQL Server Agent

O serviço que executa trabalhos, monitores, o SQL Server e permite a automação de tarefas administrativas.

Não há conta de logon padrão para esse serviço.

O tipo de inicialização padrão é Manual.

SQL Server

O Mecanismo de Banco de Dados do SQL Server.

O tipo de inicialização padrão é Automático.

Observação Observação

Navegador do SQL Server

O Navegador do SQL Server é o serviço de resolução de nomes que fornece informações de conexão do SQL Server para computadores cliente. Esse serviço é compartilhado por várias instâncias do SQL Server e do Integration Services.

A conta de logon padrão é NT Authority\Local service e não pode ser alterada durante a instalação do SQL Server. Você pode alterar a conta depois que a instalação for concluída.

Se o tipo inicial não for especificado durante a instalação, isso será determinado da seguinte maneira:

  • O Navegador do SQL Server está definido como Automático e é executado nos cenários de instalação descritos a seguir:

    • Instância de cluster de failover do SQL Server

    • Instância nomeada do SQL Server em que TCP ou NP está habilitado

    • Instância nomeada do Analysis Server e não está clusterizada

  • Se nenhum dos cenários anteriores se aplicar, e o Navegador do SQL Server já estiver instalado, o estado atual do Navegador do SQL Server será mantido.

  • O tipo de inicialização será definido como Desabilitado e parado se não houver uma instância existente do SQL Server 2005 ou SQL Server 2008 ou do SQL Server 2008 R2 anterior à instalação.

Analysis Services

Analysis Services.

O tipo de inicialização padrão é Automático.

Para o modo Integrado do SharePoint, você deve especificar uma conta de usuário do domínio Windows. A conta que você especifica é usada para o serviço do Analysis Services. A conta que você especifica para a instância atual também deve ser usada para as outras instâncias do Analysis Services que você adicionar ao mesmo farm subsequentemente.

Reporting Services

Reporting Services. As contas de serviço são usadas para configurar uma conexão de banco de dados do servidor de relatório. Escolha o serviço de rede interno se quiser usar configurações de autenticação padrão. Se você especificar uma conta de usuário de domínio, verifique se o SPN (Nome da Entidade de Serviço) está registrado para a conta, caso esteja usando a Autenticação do Windows no servidor de relatórios. Para obter mais informações, consulte How to: Configure Windows Authentication in Reporting Services.

Observação importante Importante

A Microsoft não recomenda o uso da conta Serviço de Rede para o SQL Server ou os serviços do SQL Server Agent caso a conta disponível tenha privilégios mais baixos, pois o Serviço de Rede é uma conta que pode ser compartilhada. O Serviço de Rede somente será adequado para ser usado como uma conta de serviço do SQL Server se você puder garantir que nenhum outro serviço que use a conta esteja instalado no computador. As contas Usuário Local ou Usuário de Domínio que não sejam um administrador do Windows são mais adequadas para os serviços do SQL Server.

O tipo de inicialização padrão é Automático.

Integration Services

O Integration Services é um conjunto de ferramentas gráficas e objetos programáveis para mover, copiar e transformar dados.

O tipo de inicialização padrão é Automático.

Iniciador do Daemon de Filtro de Texto Completo do SQL Server

O serviço que cria os processos de fdhost.exe. Ele é necessário para hospedar os separadores de palavras e os filtros que processam dados textuais para indexação de texto completo.

Se você fornecer uma conta de domínio na qual executará o serviço do Iniciador FDHOST, é altamente recomendável que você use uma conta de baixo privilégio. Essa conta deve ser diferente da conta usada para o serviço do SQL Server. No Windows Vista e no Windows Server 2008, a conta de serviço do Iniciador FDHOST assume como padrão LOCAL SERVICE.

SQL Server Distributed Replay Client

A conta de serviço usada para o serviço do Distributed Replay Client.

Forneça uma conta na qual executará o serviço do Distributed Replay Client. Essa conta deve ser diferente da conta usada para o serviço do SQL Server.

O tipo de inicialização padrão é Manual.

SQL Server Distributed Replay Controller

A conta de serviço usada para o serviço do Distributed Replay Controller.

Forneça uma conta na qual executará o serviço do Distributed Replay Controller. Essa conta deve ser diferente da conta usada para o serviço do SQL Server.

O tipo de inicialização padrão é Manual.

Consulte também

Outros recursos

Considerações sobre segurança para uma instalação do SQL Server


Função de instalação

 Copiar imagem em foco
[image]

Função de instalação
Consulte também Enviar Comentários

Use esta página para especificar se deseja usar a página de Seleção de Recursos para selecionar recursos individuais ou se deseja instalar usando uma função de instalação.

Uma setup role é uma seleção fixa de todos os recursos e componentes compartilhados que são necessários para implementar uma configuração do SQL Server predefinida.

Opções

Instalação de recursos do SQL Server

Escolha esta opção para selecionar recursos individuais e componentes compartilhados. Os recursos de instância incluem os Serviços de Mecanismo de Banco de Dados, o Analysis Services (modo nativo) e o Reporting Services.

SQL Server PowerPivot para SharePoint

Escolha esta opção para instalar componentes do servidor do Analysis Services em um farm do SharePoint 2010. Esta opção implanta o Serviço de Sistema do PowerPivot e o servidor do Analysis Server em um farm, habilitando o processamento de consultas e dados para pastas de trabalho do Excel publicadas que contenham dados do PowerPivot inseridos.

Opcionalmente, você poderá adicionar uma instância do mecanismo de banco de dados relacional à sua instalação se precisar hospedar bancos de dados em um farm do SharePoint. Se o farm já estiver configurado, essa opção poderá ser ignorada.

Depois que a Instalação é concluída, você deve configurar o software usando uma das seguintes abordagens: Ferramenta de Configuração do PowerPivot, cmdlets PowerShell ou Administração Central do SharePoint 2010. Ao contrário do que acontecia nas versões anteriores, a Instalação não executa mais nenhuma tarefa de configuração para uma instalação do PowerPivot.

Uma instalação baseada em função não inclui o aplicativo cliente SQL Server PowerPivot para Excel. O aplicativo cliente é instalado separadamente.

Todos os Recursos com Padrões

Escolha esta função de instalação para instalar todos os recursos que estão disponíveis para esta versão. Observe que o PowerPivot para SharePoint está excluído dessa função. Você deve usar a função de instalação do PowerPivot para SharePoint para instalar esse recurso.

O Mecanismo de Banco de Dados é configurado para iniciar usando a conta NT AUTHORITY\NETWORK SERVICE. O usuário atual será provisionado como membro da função sysadmin do SQL Server. Os valores definidos por esta opção podem ser substituídos especificando-se parâmetros de linha de comando adicionais.

No Windows Vista ou Windows Server 2008 ou superior, e quando o sistema operacional não for um controlador de domínio, por padrão o Mecanismo de Banco de Dados e o Reporting Services usarão a conta NTAUTHORITY\NETWORK SERVICE, o Integration Services usará a conta NTAUTHORITY\NETWORK SERVICE e o Iniciador do Daemon de Filtro de Texto Completo do SQL usará a conta NTAUTHORITY\LOCAL SERVICE.

Consulte também

Referência

Seleção de recursos

Outros recursos

Instalando o PowerPivot para SharePoint
Requisitos de hardware e software (PowerPivot para SharePoint)


Assistente de cluster de failover do SQL Server - Conclusão

 Copiar imagem em foco
[image]

Assistente de cluster de failover do SQL Server - Conclusão
Consulte também Enviar Comentários

A Instalação do SQL Server valida a configuração do computador antes da conclusão da operação de Instalação. Durante a Instalação do SQL Server, o SCC (Verificador de Configuração do Sistema) examina o computador em que o SQL Server será instalado. O SCC verifica se existem condições que impedem uma operação de instalação com êxito do SQL Server. Antes que a Instalação inicie o Assistente de Instalação do SQL Server, o SCC recupera o status de cada item. Em seguida, compara o resultado com condições necessárias e fornece orientação para a remoção de problemas de bloqueio.

A verificação da configuração do sistema gera um relatório que contém uma breve descrição de cada regra executada, bem como o status de execução. O relatório de verificação da configuração do sistema está localizado em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Antes de executar a operação de instalação, reveja os seguintes tópicos:

  1. Requisitos de hardware e software para instalar o SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Recursos com suporte das edições do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerações de segurança de uma instalação do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versões de idiomas locais no SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Outras referências:

  1. Atualizações de versão e edição com suporte(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar o clustering de failover(http://go.microsoft.com/fwlink/?LinkId=235034)

Consulte também

Referência

Regras de suporte à Instalação


Assistente de cluster de failover do SQL Server - Instalação

 Copiar imagem em foco
[image]

Assistente de cluster de failover do SQL Server - Instalação
Consulte também Enviar Comentários

A Instalação do SQL Server valida a configuração do computador antes da conclusão da operação de Instalação. Durante a Instalação do SQL Server, o SCC (Verificador de Configuração do Sistema) examina o computador em que o SQL Server será instalado. O SCC verifica se existem condições que impedem uma operação de instalação com êxito do SQL Server. Antes que a Instalação inicie o Assistente de Instalação do SQL Server, o SCC recupera o status de cada item. Em seguida, compara o resultado com condições necessárias e fornece orientação para a remoção de problemas de bloqueio.

A verificação da configuração do sistema gera um relatório que contém uma breve descrição de cada regra executada, bem como o status de execução. O relatório de verificação da configuração do sistema está localizado em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Antes de executar a operação de instalação, reveja os seguintes tópicos:

  1. Requisitos de hardware e software para instalar o SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Recursos com suporte das edições do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerações de segurança de uma instalação do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versões de idiomas locais no SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Outras referências:

  1. Atualizações de versão e edição com suporte(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar o clustering de failover(http://go.microsoft.com/fwlink/?LinkId=235034)

Consulte também

Referência

Regras de suporte à Instalação


Assistente de cluster de failover do SQL Server - Preparação

 Copiar imagem em foco
[image]

Assistente de cluster de failover do SQL Server - Preparação
Consulte também Enviar Comentários

A Instalação do SQL Server valida a configuração do computador antes da conclusão da operação de Instalação. Durante a Instalação do SQL Server, o SCC (Verificador de Configuração do Sistema) examina o computador em que o SQL Server será instalado. O SCC verifica se existem condições que impedem uma operação de instalação com êxito do SQL Server. Antes que a Instalação inicie o Assistente de Instalação do SQL Server, o SCC recupera o status de cada item. Em seguida, compara o resultado com condições necessárias e fornece orientação para a remoção de problemas de bloqueio.

A verificação da configuração do sistema gera um relatório que contém uma breve descrição de cada regra executada, bem como o status de execução. O relatório de verificação da configuração do sistema está localizado em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Antes de executar a operação de instalação, reveja os seguintes tópicos:

  1. Requisitos de hardware e software para instalar o SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Recursos com suporte das edições do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerações de segurança de uma instalação do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versões de idiomas locais no SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Outras referências:

  1. Atualizações de versão e edição com suporte(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar o clustering de failover(http://go.microsoft.com/fwlink/?LinkId=235034)

Consulte também

Referência

Regras de suporte à Instalação


Resumo (atualização)

 Copiar imagem em foco
[image]

Resumo (atualização)
Enviar Comentários

Use a página Resumo para exibir as opções especificadas para esta atualização.


Regras de suporte à Instalação

 Copiar imagem em foco
[image]

Regras de suporte à Instalação
Enviar Comentários

A Instalação do SQL Server valida a configuração do computador antes da conclusão da operação de Instalação. Durante a Instalação do SQL Server, o SCC (Verificador de Configuração do Sistema) examina o computador em que o SQL Server será instalado. O SCC verifica se existem condições que impedem uma operação de instalação com êxito do SQL Server. Antes que a Instalação inicie o Assistente de Instalação do SQL Server, o SCC recupera o status de cada item. Em seguida, compara o resultado com condições necessárias e fornece orientação para a remoção de problemas de bloqueio.

A verificação da configuração do sistema gera um relatório que contém uma breve descrição de cada regra executada, bem como o status de execução. O relatório de verificação da configuração do sistema está localizado em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Antes de executar a operação de instalação, reveja os seguintes tópicos:

  1. Requisitos de hardware e software para instalar o SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Recursos com suporte das edições do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerações de segurança de uma instalação do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versões de idiomas locais no SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Outras referências:

  1. Atualizações de versão e edição com suporte(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar o clustering de failover(http://go.microsoft.com/fwlink/?LinkId=235034)

Tópicos adicionais sobre regras

Consulte os seguintes tópicos para obter as regras de Instalação específicas ao cenário:

  • Regras de instalação

  • Verificação de regras de atualização

  • Regras de atualização de edição

  • Regras de desinstalação

  • Regras de Preparação de Imagem

  • Regras de Conclusão de Imagem


Regras de desinstalação

 Copiar imagem em foco
[image]

Regras de desinstalação
Consulte também Enviar Comentários

A página Regras de Desinstalação executa um conjunto de regras para garantir que a operação de Instalação pode ser concluída com êxito.

A Instalação do SQL Server valida a configuração do computador antes da conclusão da operação de Instalação. Durante a Instalação do SQL Server, o SCC (Verificador de Configuração do Sistema) examina o computador em que o SQL Server será instalado. O SCC verifica se existem condições que impedem uma operação de instalação com êxito do SQL Server. Antes que a Instalação inicie o assistente de desinstalação do SQL Server, o SCC recupera o status de cada item. Em seguida, compara o resultado com condições necessárias e fornece orientação para a remoção de problemas de bloqueio.

A verificação da configuração do sistema gera um relatório que contém uma breve descrição de cada regra executada, bem como o status de execução. O relatório de verificação da configuração do sistema está localizado em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Antes de executar a operação de instalação, reveja os seguintes tópicos:

  1. Requisitos de hardware e software para instalar o SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Recursos com suporte das edições do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerações de segurança de uma instalação do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versões de idiomas locais no SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Outras referências:

  1. Atualizações de versão e edição com suporte(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar o clustering de failover(http://go.microsoft.com/fwlink/?LinkId=235034)

Consulte também

Referência

Regras de suporte à Instalação


Andamento da atualização

 Copiar imagem em foco
[image]

Andamento da atualização
Consulte também Enviar Comentários

Use a página Andamento da Atualização do Assistente de Instalação do SQL Server para monitorar o status da atualização do SQL Server.

Consulte também

Conceitos

Exibir e ler arquivos de log da Instalação do SQL Server


Verificação de regras de atualização

 Copiar imagem em foco
[image]

Verificação de regras de atualização
Consulte também Enviar Comentários

A Instalação do SQL Server valida a configuração do computador antes da conclusão da operação de Instalação. Durante a Instalação do SQL Server, o SCC (Verificador de Configuração do Sistema) examina o computador em que o SQL Server será instalado. O SCC verifica se existem condições que impedem uma operação de instalação com êxito do SQL Server. Antes que a Instalação inicie o assistente de atualização, o SCC recupera o status de cada item. Em seguida, compara o resultado com condições necessárias e fornece orientação para a remoção de problemas de bloqueio.

A verificação da configuração do sistema gera um relatório que contém uma breve descrição de cada regra executada, bem como o status de execução. O relatório de verificação da configuração do sistema está localizado em %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Antes de executar a operação de instalação, reveja os seguintes tópicos:

  1. Requisitos de hardware e software para instalar o SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Recursos com suporte das edições do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Considerações de segurança de uma instalação do SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versões de idiomas locais no SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Outras referências:

  1. Atualizações de versão e edição com suporte(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar o clustering de failover(http://go.microsoft.com/fwlink/?LinkId=235034)

Consulte também

Referência

Regras de suporte à Instalação


Verificar opções de desinstalação

 Copiar imagem em foco
[image]

Verificar opções de desinstalação
Enviar Comentários

Verifique sua seleção e clique em Avançar para continuar.


O tópico que você está buscando está indisponível

 Copiar imagem em foco
[image]

O tópico que você está buscando está indisponível
Enviar Comentários

Depois que a instalação for concluída, você poderá ver a documentação do SQL Server clicando em Ajuda, pressionando a tecla F1 em caixas de diálogo ou elementos da interface ou (no menu Iniciar) apontando para Todos os Programas, apontando para Microsoft SQL Server, apontando para Ajuda e Comunidade e clicando em Manuais Online do SQL Server. Para obter mais informações, consulte Adicionando e removendo coleções.