Visão geral da instalação de manutenção do SQL Server

 Copiar imagem em foco
[image]

Visão geral da instalação de manutenção do SQL Server
Consulte também Enviar Comentários

Você pode aplicar uma atualização a qualquer componente do SQL Server 2012 instalado com uma atualização de manutenção do SQL Server 2012. Se o nível da versão de um componente existente do SQL Server 2012 for posterior ao da versão de atualização, o programa de Instalação o excluirá da atualização. Para obter mais informações sobre a aplicação de uma atualização de serviços, consulte Instalar atualizações de manutenção do SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=231297).

As seguintes considerações se aplicam à instalação de atualizações do SQL Server 2012:

  • Todos os recursos que pertencem a uma instância do SQL Server devem ser atualizados ao mesmo tempo. Por exemplo, quando atualizar o Mecanismo de Banco de Dados, você também deverá atualizar os componentes Analysis Services e Reporting Services se eles estiverem instalados como parte da mesma instância do SQL Server. Recursos compartilhados, como as Ferramentas de Gerenciamento, o SSDT (Ferramentas de dados do SQL Server) e o SQL Server Integration Services, sempre devem ser atualizados para a versão mais recente. Se nenhuma instância ou nenhum componente da árvore de recursos estiver selecionado, ele não será atualizado.

  • Por padrão, os arquivos de log de atualização do SQL Server 2012 são salvos em %Arquivos de Programas%\Microsoft SQL Server\110\Setup Bootstrap\LOG\.

  • A instalação do SQL Server agora pode integrar uma atualização à mídia original para executar a mídia original e a atualização ao mesmo tempo. Para obter mais informações, consulte Atualizações de produto na instalação do SQL Server 2012 e Novidades na instalação do SQL Server(http://go.microsoft.com/fwlink/?LinkID=219508).

  • Antes de aplicar uma atualização de manutenção do SQL Server 2012, é recomendável fazer backup dos dados.

  • As atualizações do SQL Server estão disponíveis por meio do Microsoft Update. Recomendamos que você procure atualizações regularmente para manter sua instância do SQL Server atualizada e segura. O SQL Server 2012 SP1 está sendo fornecido como uma instalação completa do SQL Server. Em vez de fornecer o Service Pack no pacote executável do patch padrão a ser aplicado às instâncias do SQL Server 2012 RTM, nesta versão é fornecido um pacote de instalação que consiste em 2 arquivos. Quando executado, ele instalará uma nova instância do SQL Server 2012 com o SP1 pré-instalado. Para obter mais informações, consulte Instalação completa do SQL Server 2012 SP1.

Requisitos e problemas conhecidos

Os requisitos de espaço em disco recomendados são, aproximadamente, 2,5 vezes o tamanho do pacote para instalação, download e extração do pacote. Após instalar um service pack, você pode remover o pacote baixado. Todos os arquivos temporários serão removidos automaticamente.

Examine os problemas conhecidos: para obter mais informações sobre os problemas conhecidos da versão atual, consulte o tópico de notas de versão correspondentes aqui: Notas de versão do SQL Server.

Visão geral da instalação

Esta seção aborda a instalação do SQL Server 2012 para atualizações cumulativas e service packs, inclusive como fazer o seguinte:

  • Preparar-se para uma instalação de atualização do SQL Server 2012

  • Instalar atualizações do SQL Server 2012

  • Reiniciar serviços e aplicativos

Preparar-se para uma instalação de atualização do SQL Server 2012

É altamente recomendável que você faça o seguinte antes de instalar atualizações do SQL Server 2012:

  • Faça backup dos bancos de dados de sistema do SQL Server — Antes de instalar as atualizações do SQL Server 2012, faça backup dos bancos de dados master, msdb e model. A instalação de uma atualização do SQL Server 2012 altera esses bancos de dados, tornando-os incompatíveis com versões anteriores do SQL Server 2012. Os backups desses bancos de dados serão necessários se você decidir reinstalar o SQL Server 2012 sem essas atualizações.

    Também é recomendável fazer backup dos bancos de dados de usuário.

    Observação importante Importante

    Ao aplicar atualizações a instâncias do SQL Server que participam de uma topologia de replicação, você deverá fazer backup dos bancos de dados replicados junto com os bancos de dados do sistema antes de aplicar a atualização.

  • Faça backup dos bancos de dados, do arquivo de configuração e do repositório do Analysis Services — Antes de atualizar uma instância do Analysis Services, você deve fazer backup do seguinte:

    • Bancos de dados do Analysis Services. Por padrão, eles vêm instalados em C:\Arquivos de Programas\Microsoft SQL Server\MSAS11.<ID da Instância>\OLAP\Data\. Para a instalação do WOW, o caminho padrão é C:\Arquivos de Programas (x86)\Microsft SQL Server\MSAS11.<ID da instância>\OLAP\Data\.

    • Parâmetro de configuração do Analysis Services no arquivo de configuração msmdsrv.ini. Por padrão, ele fica localizado no diretório C:\Arquivos de Programas\Microsoft SQL Server\MSAS11.\<ID da Instância>\OLAP\Config\.

    • (Opcional) O banco de dados que contém o repositório do Analysis Services. Esta etapa será necessária somente se o Analysis Services tiver sido configurado para funcionar com a biblioteca de DSO (Decision Support Objects).

    Observação Observação

    Se não for feito o backup dos bancos de dados, do arquivo de configuração e do repositório do Analysis Services, você não poderá reverter uma instância atualizada do Analysis Services para a versão anterior.

  • Verificar se os bancos de dados do sistema têm espaço livre suficiente — Se a opção de crescimento automático não estiver selecionada para os bancos de dados de sistema master e msdb, esses bancos de dados deverão ter pelo menos 500 KB de espaço livre. Para verificar se os bancos de dados têm espaço suficiente, execute o procedimento armazenado do sistema sp_spaceused nos bancos de dados master e msdb. Se o espaço não alocado de um deles for inferior a 500 KB, aumente o tamanho do banco de dados.

  • Interromper serviços e aplicativos — Para evitar que o sistema seja reiniciado, interrompa todos os aplicativos e serviços que estabelecem conexões com as instâncias do SQL Server que estão sendo atualizadas antes de instalar atualizações do SQL Server 2012. Isso inclui o SQL Server Management Studio e o SSDT (Ferramentas de dados do SQL Server). Para obter mais informações, consulte Iniciar, parar, pausar, retomar, reiniciar o mecanismo de banco de dados, o SQL Server Agent ou o serviço SQL Server Browser.

    Observação Observação

    Você não pode interromper serviços em um ambiente de cluster de failover. Para obter mais informações, consulte a seção de instalação de cluster de failover mais adiante neste tópico.

  • Para eliminar a necessidade de reiniciar o computador após a instalação da atualização, a Instalação mostrará uma lista com os processos que estão bloqueando arquivos. Se o programa de Instalação da atualização precisar encerrar um serviço durante a instalação, ele reiniciará o serviço depois que a instalação for concluída.

  • Se a Instalação determinar que os arquivos sejam bloqueados durante a instalação, talvez seja necessário reiniciar o computador após a conclusão da instalação. Se necessário, a Instalação solicitará que você reinicie o computador.

Instalar atualizações do SQL Server 2012

Esta seção descreve o processo de instalação.

Observação importante Importante

As atualizações do SQL Server 2012 devem ser instaladas com uma conta que tenha privilégios administrativos no computador em que serão instaladas. Para instalações locais, você deve executar a Instalação como um administrador. Se você instalar o SQL Server de um compartilhamento remoto, deverá usar uma conta de domínio que tenha permissões de leitura e de execução no compartilhamento remoto.

Iniciando uma atualização do SQL Server 2012

Para instalar uma atualização do SQL Server 2012, execute o arquivo de pacote autoextraível.

Pacote de atualização cumulativa (CU): <SQLServer2012>-KBxxxxxx-PPP.exe

Pacote de service pack (PCU): <SQLServer2012><SPx> -KBxxxxxx-PPP-LLL.exe

  • x indica o número do service pack

  • PPP indica a plataforma específica.

  • LLL indica a abreviação de caracteres do idioma do SQL Server, por exemplo: o LLL do inglês é ENU.

Para aplicar as atualizações aos componentes do SQL Server 2012 que fazem parte de um cluster de failover, consulte a seção sobre a instalação de cluster de failover. Para obter mais informações sobre como executar uma instalação de atualização no modo autônomo, consulte Instalando atualizações no prompt de comando.

Atualizações de produtos na instalação do SQL Server 2012

A Atualização de Produto é um novo recurso na Instalação do SQL Server 2012. Ela integra as últimas atualizações de produto com a instalação principal, para que o produto principal e suas atualizações aplicáveis sejam instalados ao mesmo tempo. A Atualização de Produto pode pesquisar atualizações aplicáveis no Microsoft Update, no WSUS (Windows Server Update Services), em uma pasta local ou em um compartilhamento de rede. Depois que a Instalação localizar as versões mais recentes das atualizações aplicáveis, ela baixará e integrará essas atualizações com o processo de instalação do SQL Server atual. A Atualização de Produto pode efetuar pull de uma atualização cumulativa, service pack ou service pack mais atualização cumulativa. A funcionalidade da Atualização de Produto é uma extensão da funcionalidade Instalação Integrada que estava disponível no PCU1 do SQL Server 2008. Para obter mais informações sobre o recurso Atualizações de Produto na Instalação do SQL Server 2012, consulte Atualizações de produto na instalação do SQL Server 2012.

Instalação completa do SQL Server 2012 SP1

O SQL Server 2012 SP1 também está disponível como um pacote de instalação completa do SQL Server. O pacote de instalação do SQL Server 2012 SP1 instalará uma nova instância do SQL Server com o SP1 pré-instalado.

O pacote tem um executável e arquivos de instalação no formato compactado. Ele também tem arquivos no formato: SQLServer2012SP1-<Arquitetura>-<Idioma>.exe e SQLServer2012SP1-<Arquitetura>-<Idioma>.box.

Examine as seguintes instruções ao instalar o SQL Server 2012 SP1:

  • Baixe os arquivos a seguir da página de download para um diretório temporário no seu dispositivo:

    • SQLServer2012SP1-arquitetura-idioma.box

    • SQLServer2012SP1-arquitetura-idioma.exe

  • Assim que os downloads forem concluídos, clique duas vezes no arquivo SQLServer2012SP1-<arquitetura>-<idioma>.exe para iniciar o processo de instalação.

  • Na caixa de diálogo Escolha o Diretório para Arquivos Extraídos, o caminho do diretório padrão é pré-populado: <Unidade atual>\<Pasta de trabalho atual>\<Nome do pacote>. Por exemplo, %temp%\SQLServer2012SP1-x64-ENU\. Clique em Procurar para alterar o caminho do diretório dos arquivos extraídos.

  • O pacote é descompactado no caminho de instalação especificado e deixado no caminho de diretório especificado após a conclusão da instalação. Um usuário poderá usar os binários da pasta extraída para futuras instalações.

  • O Assistente de Instalação executa a Central de Instalação do SQL Server. Siga as instruções de instalação em Instalar o SQL Server 2012 por meio do Assistente de Instalação (Instalação) (http://msdn.microsoft.com/library/ms143219.aspx).

A tabela a seguir tem alguns parâmetros de linha de comando que podem ser usados para extrair o pacote do SQL Server 2012 SP1:

Para obter uma lista detalhada dos parâmetros de linha de comando com suporte que podem ser diretamente fornecidos para o pacote do SP1, consulte Instalar o SQL Server 2012 do prompt de comando (http://msdn.microsoft.com/library/ms144259.aspx)

Parâmetro | Descrição
/x ou -x | Extrai o pacote no caminho especificado, abre a caixa de diálogo Escolha o Diretório para Arquivos Extraídos e extrai o pacote no caminho especificado. Ele não executa a instalação.
/x:<caminho> ou -x:<caminho> | Extrai no pacote no caminho especificado e não inicia a instalação.
/q ou -q | Especifica que a Instalação é executada em modo silencioso sem nenhuma interface do usuário. Isso é usado para instalações autônomas.
/|:<caminho> ou -|:<caminho> | Por padrão, o arquivo de log é armazenado no diretório temp com o nome SQLServer2012SPx-<Arquitetura>-<Idioma>_decompression_log.txt Use esse parâmetro para gerar o arquivo de log da extração em um caminho especificado. Por exemplo: SQLServer2012SP1-x64-ENU /x /l:<caminho> Essa opção deve ser usada apenas em conjunto com /x ou –x ou /x:<caminho> ou -x:<caminho>

Atualizando uma imagem preparada do SQL Server

É possível aplicar uma atualização a uma instância preparada não configurada do SQL Server sem concluir a configuração da instância preparada. As diferentes maneiras de aplicar uma atualização a uma instância preparada do SQL Server são explicados a seguir:

  • Atualizando uma instância previamente preparada do SQL Server

    As atualizações para uma instância preparada podem ser aplicadas antes da configuração. O pacote de atualização detecta que a instância está no estado preparado e aplica o patch à instância preparada, sem concluir a configuração.

  • Atualizações para uma instância preparada usando o Microsoft Update:

    É possível aplicar atualizações a uma instância preparada do SQL Server por meio do Microsoft Update. O pacote do Microsoft Update detectará que a instância está no estado preparado e aplicará o patch à instância preparada, sem concluir a configuração.

Se estiver atualizando uma imagem preparada do SQL Server, você precisará especificar o parâmetro InstanceID. Para obter mais informações e uma sintaxe de exemplo, consulte Instalando atualizações no prompt de comando.

Atualizando uma imagem concluída do SQL Server

A atualização de uma instância completa e configurada do SQL Server segue os mesmos processos de qualquer outra instância instalada do SQL Server.

Recriando um nó de cluster de failover do SQL Server 2012

Se você precisar recriar um nó no cluster de failover após a aplicação das atualizações, siga estas etapas:

  1. Recrie o nó no cluster de failover. Para obter mais informações sobre como recriar um nó, consulte Recuperar-se de uma falha na instância do cluster de failover.

  2. Execute o programa de Instalação do SQL Server 2012 original para instalar o SQL Server 2012 no nó do cluster de failover.

  3. Execute a Instalação das atualizações do SQL Server 2012 no nó adicionado.

Reiniciar serviços e aplicativos

Quando a Instalação estiver concluída, a reinicialização do computador poderá ser solicitada. Após a reinicialização do sistema, ou após a conclusão do programa de Instalação sem uma solicitação de reinicialização, use o nó Serviços no Painel de Controle para reiniciar os serviços que você interrompeu antes de aplicar as atualizações do SQL Server 2012. Isso inclui serviços como o Distributed Transaction Coordinator e o Microsoft Search, ou equivalentes específicos das instâncias.

Reinicie os aplicativos fechados antes de executar a Instalação da atualização do SQL Server 2012. Talvez você queira fazer outro backup dos bancos de dados atualizados master, msdb e model logo após a instalação bem-sucedida.

Desinstalando atualizações do SQL Server 2012

Você pode desinstalar as atualizações cumulativas ou os service packs do SQL Server 2012 em Programas e Recursos no Painel de Controle. Para ver a lista de atualizações instaladas, abra Atualizações Instaladas clicando em Iniciar, Painel de Controle, Programas e, em Programas e Recursos, clique em Exibir atualizações instaladas. Cada atualização cumulativa é relacionada separadamente. No entanto, quando um service pack está instalado num nível superior ao das atualizações cumulativas, as entradas de atualizações cumulativas são ocultadas e só ficarão disponíveis se você desinstalar o service pack.

Para desinstalar um service pack e uma atualização, é necessário iniciar a atualização mais recente ou o service pack aplicado à instância do SQL Server e trabalhar retroativamente. Em cada um dos exemplos a seguir, o SQL Server acaba com a Atualização Cumulativa 1 depois que a desinstalação é concluída para os outros service packs ou as outras atualizações:

  • Para uma instância do SQL Server 2012 com a Atualização Cumulativa 1 e o SP1 instalados, desinstale o SP1.

  • Para cada instância do SQL Server 2012 com a Atualização Cumulativa 1, o SP1 e a Atualização Cumulativa 2 instalados, desinstale a Atualização Cumulativa 2 primeiro e, em seguida, o SP1.

Consulte também

Outros recursos

Instalar o SQL Server 2012 do prompt de comando
Instalar atualizações de serviço do SQL Server 2012
Validar uma instalação do SQL Server
Exibir e ler arquivos de log da Instalação do SQL Server
Imagem de rodapé
Forneça comentários sobre este tópico à Microsoft

© 2012 Microsoft Corporation. Todos os direitos reservados.


Aviso legal para documentação

 Copiar imagem em foco
[image]

Aviso legal para documentação
Enviar Comentários

Este documento é fornecido "como está". As informações e opiniões expressas neste documento, inclusive URLs e outras referências a sites da Internet, podem ser alteradas sem aviso prévio. Você se responsabiliza por usá-lo.

Alguns exemplos representados aqui são fornecidos apenas para ilustração e são fictícios. Nenhuma associação real ou conexão é desejada ou deve ser inferida.

Este documento não dá nenhum direito legal a nenhuma propriedade intelectual em qualquer produto Microsoft. Você pode copiar e usar este documento para fins de referência interna.

© 2012 Microsoft. Todos os direitos reservados.

Microsoft, Active Directory, ActiveX, Bing Maps, Excel, IntelliSense, MSDN, MS-DOS, Gráfico Dinâmico, Tabela Dinâmica, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual Studio, Windows, Windows NT, Windows Server e Windows Vista são marcas registradas do grupo de empresas Microsoft. SAP NetWeaver é marca registrada da SAP AG na Alemanha e em vários outros países. Todas as outras marcas comerciais pertencem a seus respectivos proprietários.

Política de documentação para suporte e atualização do SQL Server

A documentação do software SQL Server 2012 inclui Manuais Online da Microsoft para o SQL Server 2012, documentação da instalação, documentação de referência do desenvolvedor, tutoriais, arquivos leiame, documentos sobre problemas conhecidos, código/aplicativos de exemplo, bancos de dados de exemplo e artigos da Base de Dados de Conhecimento publicados pela Microsoft, todos com conteúdo sobre os recursos e a funcionalidade do SQL Server. Essa política de suporte e atualização se aplica a toda a documentação do SQL Server 2012, incluindo arquivos leiame de versões e service packs do SQL Server 2012; um arquivo leiame é considerado uma extensão dos Manuais Online do SQL Server 2012.

A principal finalidade de um exemplo contido nesta documentação é ilustrar um conceito ou uso razoável de uma determinada instrução ou cláusula. A maioria dos exemplos não inclui todo o código geralmente encontrado em um sistema de produção completo, pois algumas das funções comuns de validação de dados e tratamento de erros foram removidas para focalizar o exemplo em um determinado conceito ou instrução. Não há suporte técnico para esses exemplos nem para quaisquer códigos-fonte incluídos.

Em alguns casos, um recursos específico do SQL Server 2012 não foi suficientemente testado ou desenvolvido e não é destinado para seu uso. Tais recursos normalmente estão lá como espaços reservados. Portanto, determinados recursos incluídos no software não estão documentados. Os recursos que não estão documentados ou que estão incluídos como uma notação para uso interno da Microsoft não são destinados para seu uso e não é dado suporte pelos Serviços de Atendimento ao Cliente da Microsoft. A menos que a documentação do SQL Server 2012 indique o contrário, o conteúdo de terceiros, incluindo problemas resultantes do uso de tal conteúdo de terceiros com o SQL Server 2012, não tem suporte dos Serviços de Atendimento ao Cliente da Microsoft e pode resultar em perda de dados. Os Serviços de Atendimento ao Cliente da Microsoft também não dão suporte a bancos de dados ou aplicativos que aproveitem ou usem pontos de entrada não documentados, como APIs não documentadas, incluindo, mas não se limitando a: procedimentos armazenados, procedimentos armazenados estendidos, funções, exibições, tabelas, colunas, propriedades ou metadados.

Atualizações de servidor e banco de dados para versões futuras do SQL Server 2012 relativos a aplicativos e bancos de dados que aproveitem e usem pontos de entrada não documentados também podem não funcionar e não têm suporte. O uso de recursos e funcionalidade do SQL Server incluídos no Microsoft SQL Server que não estejam incluídos na documentação do SQL Server 2012 para seu uso não tem suporte, e tal uso pode causar perda de dados.


Instalando atualizações no prompt de comando

 Copiar imagem em foco
[image]

Instalando atualizações no prompt de comando
Consulte também Enviar Comentários

Teste e modifique os scripts de instalação para atender às necessidades da sua organização. Para obter mais informações sobre como instalar atualizações em um cluster de failover do SQL Server, consulte Como aplicar uma atualização do SQL Server a uma instância de cluster de failover na Base de Dados de Conhecimento Microsoft.

Sintaxe de exemplo da instalação

O nome do pacote de atualização pode variar e incluir um componente de processador, edição e idioma. Aplique uma atualização em um prompt de comando substituindo <nome_do_pacote> pelo nome do seu pacote de atualização:

  • Atualize uma única instância do SQL Server e todos os componentes compartilhados, como o Integration Services e Ferramentas de Gerenciamento: você pode especificar a instância usando o parâmetro InstanceName ou o parâmetro InstanceID. Para atualizar uma instância preparada do SQL Server, especifique o parâmetro InstanceID<nome_do_pacote>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /InstanceName=MyInstance ou <nome_do_pacote>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /InstanceID=<ID da instância>

  • A instalação pode integrar as últimas atualizações de produto com a instalação principal, para que ela e as atualizações aplicáveis sejam instaladas ao mesmo tempo. Você pode preparar uma instalação da instância do mecanismo de banco de dados para incluir a atualização do produto: setup.exe /q /IAcceptSQLServerLicenseTerms /ACTION=PrepareImage /UpdateEnabled=True /UpdateSource=<caminho de onde a atualização é baixada> /INSTANCEID=<Instance ID> /FEATURES=SQLEngine

  • Atualize apenas os componentes compartilhados do SQL Server, como o Integration Services e as Ferramentas de Gerenciamento: <nome_do_pacote>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch

  • Atualize todas as instâncias do SQL Server no computador e todos os componentes compartilhados, como o Integration Services e as Ferramentas de Gerenciamento: <nome_do_pacote>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /AllInstances

Remova uma atualização pelo prompt de comando substituindo <nome_do_pacote> pelo nome do pacote de atualização:

  • Remova uma atualização de uma única instância do SQL Server e de todos os componentes compartilhados, como o Integration Services e as Ferramentas de Gerenciamento: <nome_do_pacote>.exe /qs /Action=RemovePatch /InstanceName=MyInstance

  • Remova uma atualização apenas dos componentes compartilhados do SQL Server, como o Integration Services e as Ferramentas de Gerenciamento: <nome_do_pacote>.exe /qs /Action=RemovePatch

    Observação Observação

    O instalador de atualização assegura que os componentes compartilhados sempre estejam na versão da instância no nível mais alto ou acima dela.

Parâmetros de prompt de comando suportados

Observação importante Importante

Quando possível, forneça credenciais de segurança em tempo de execução. Se você precisar armazenar credenciais em um arquivo de script, proteja o arquivo para evitar acesso não autorizado.

Opção | Descrição
/? | Exibe a ajuda do prompt de comando da instalação autônoma
/action=Patch or /action=RemovePatch | Especifica a ação da instalação: Patch ou RemovePatch.
/allinstances | Aplica a atualização do SQL Server a todas as instâncias do SQL Server e a todos os componentes compartilhados do SQL Server que não reconhecem a instância.
/instancename=InstanceName1 | Aplica a atualização do SQL Server a uma instância do SQL Server denominada InstanceName e a todos os componentes compartilhados do SQL Server que não reconhecem a instância.
/InstanceID=Inst1 | Aplica a atualização do SQL Server a uma instância do SQL Server Inst1 e a todos os componentes compartilhados do SQL Server que não reconhecem a instância.
/quiet | Executa a instalação da atualização do SQL Server em modo autônomo.
/qs | Exibe somente a caixa de diálogo de progresso na interface do usuário.
/UpdateEnabled | Especifica se a instalação do SQL Server deve descobrir e incluir atualizações de produto. Os valores válidos são True e False ou 1 e 0. Por padrão, a instalação do SQL Server incluirá as atualizações localizadas.
/UpdateSource | Especifica o local em que a instalação do SQL Server obterá as atualizações de produto. Os valores válidos são “MU” para pesquisar Microsoft Update, um caminho de pasta válido, um caminho relativo, por exemplo .\MyUpdates ou um compartilhamento UNC. Por padrão, a instalação do SQL Server pesquisará o Microsoft Update ou um serviço Windows Update por meio do Windows Server Update Services.
/IAcceptSQLServerLicenseTerms | Necessário somente quando o parâmetro /Q ou /QS é especificado para instalações autônomas.

1 Não é possível especificar este parâmetro para aplicar uma atualização a uma instância preparada do SQL Server. Em vez disso, é necessário especificar o parâmetro /instanceID.

Consulte também

Conceitos

Visão geral da instalação de manutenção do SQL Server


Como validar a instalação bem-sucedida de uma atualização do SQL Server

 Copiar imagem em foco
[image]

Como validar a instalação bem-sucedida de uma atualização do SQL Server
Consulte também Enviar Comentários

Para validar a instalação bem-sucedida de uma atualização do SQL Server:

  • Verifique se os serviços do SQL Server estão online.

  • Verifique as informações sobre versão retornadas pela consulta @@version.

Consulte também

Conceitos

Visão geral da instalação de manutenção do SQL Server


Obtendo assistência do SQL Server

 Copiar imagem em foco
[image]

Obtendo assistência do SQL Server
Consulte também Enviar Comentários

Existem três fontes principais de informações da Microsoft sobre o SQL Server:

  • A documentação instalada como uma coleção local dos Manuais Online do SQL Server.

  • Os sites do SQL Server no Microsoft Developer Network (MSDN) e TechNet.

  • Informações sobre o SQL Server em sites adicionais da Microsoft.

Se não encontrar a informações que está procurando nessas origens, você poderá postar perguntas nos fóruns e grupos de notícias da comunidade do SQL Server ou abrir um caso de suporte com a Microsoft.

Manuais Online do SQL Server

Os Manuais Online do SQL Server documentam os conceitos e procedimentos necessários para usar o SQL Server. Os Manuais Online também incluem material de referência dos idiomas e interfaces de programação para armazenamento, recuperação, relatórios e modificação de dados usando o SQL Server.

É possível acessar os Manuais Online das seguintes formas:

  • Uma cópia dos Manuais Online do SQL Server 2012 é publicada na Biblioteca MSDN e na Biblioteca do TechNet na Internet. Os tópicos nessas cópias dos Manuais Online do SQL Server incluem comentários da comunidade, como informações adicionais e exemplos de código de outros clientes. É possível exibir a cópia da Biblioteca MSDN nos Manuais Online do SQL Server 2012.

  • Você pode usar o Gerenciador da Biblioteca de Ajuda para instalar Manuais Online do SQL Server em um computador local. Para obter mais informações, consulte Adicionar ou remover coleções de ajuda.

A cópia dos Manuais Online do SQL Server na MSDN Library e os arquivos de Manuais Online disponíveis por meio do Gerenciador da Biblioteca de Ajuda são atualizados quando a Microsoft publica uma atualização dos Manuais Online do SQL Server.

Informações sobre MSDN e TechNet

O Microsoft Developer Network (MSDN) fornece serviços online e offline que ajudam os desenvolvedores a escrever aplicativos usando produtos e tecnologias da Microsoft. O Programa Microsoft TechNet fornece recursos técnicos abrangentes que ajudam os profissionais de TI a avaliar, implantar e oferecer suporte a soluções da Microsoft eficientemente.

Vários sites do MSDN e do TechNet fornecem a um público específico links para as informações do SQL Server mais relevantes para seus trabalhos, incluindo informações nas cópias dos Manuais Online do SQL Server no MSDN ou no TechNet. Esses sites também contêm informações que estendem a informações disponíveis nos Manuais Online do SQL Server.

A tabela a seguir descreve esses recursos e o público-alvo.

Recurso | Público
SQL Server Developer Center | Desenvolvedores que estão criando bancos de dados, sistemas de relatórios e soluções de business intelligence do SQL Server e estão habilitando seus aplicativos e sites para usar esses sistemas.
Data Access e Storage Developer Center | Desenvolvedores que estão habilitando seus aplicativos e sites para usar dados armazenados usando produtos, como o SQL Server e Access.
XML Developer Center | Criadores de site e desenvolvedores de aplicativos cujos sites e aplicativos utilizam XML para armazenamento e manipulação de dados.
Site do SQL Server TechNet | Administradores e operadores que planejam, implantam, administram e oferecem suporte a sistemas que usam o SQL Server.

Informações online adicionais

Informações adicionais sobre o SQL Server estão disponíveis nestes sites da Microsoft.

Recurso | Descrição
Microsoft SQL Server | Fornece informações de pré-venda sobre como avaliar o SQL Server como um armazenamento de dados e ferramenta de business intelligence.
Base de Dados de Conhecimento Microsoft | Fornece um repositório pesquisável de artigos sobre o SQL Server escritos por suporte da Microsoft.
Microsoft Learning | Descreve treinamento e certificações da Microsoft para o SQL Server.
Microsoft Press | Lista os manuais da Microsoft Press sobre o SQL Server.

Obtendo assistência de outros

Se você não encontrou as informações que está procurando na documentação do produto ou na Web, poderá fazer uma pergunta nos fóruns e grupos de notícias da comunidade do SQL Server. Você também pode pedir ajuda ao suporte ao produto.

Observação Observação

Não poste perguntas na seção Comentários da Comunidade na parte inferior dos tópicos dos Manuais Online do SQL Server na MSDN Library ou na TechNet Library. Essas seções não são monitoradas para perguntas e, normalmente, você não receberá uma resposta. Poste perguntas nos fóruns e grupos de notícias da comunidade que são monitorados por outros clientes que podem responder suas perguntas.

A tabela a seguir contém links para esses recursos e os descreve.

Recurso | Descrição
Comunidade de Profissionais de TI do SQL Server | Fornece links para grupos de notícias e fóruns monitorados pela comunidade do SQL Server. Também lista fontes de informações da comunidade, como blogs e sites da Web. A comunidade do SQL Server é muito útil, respondendo perguntas, embora não haja nenhuma garantia de resposta.
SQL Server Developer Center Community | Esse site enfoca grupos de notícias, fóruns e outros recursos de comunidade que são úteis a desenvolvedores do SQL Server.
Ajuda e Suporte da Microsoft | Você pode usar esse site para abrir um caso de suporte com um profissional de suporte da Microsoft.

Os produtos da Microsoft têm um ciclo de vida de suporte que define por quanto tempo o suporte está disponível para cada versão. O suporte da Microsoft mantém uma página que define o ciclo de vida do suporte da Microsoft. A página contém links para outras páginas que especificam a disponibilidade de suporte para produtos da Microsoft. Para obter mais informações, consulte Ciclo de Vida do Suporte da Microsoft.

Consulte também

Conceitos

Use a documentação do produto do SQL Server


Bem-vindo

 Copiar imagem em foco
[image]

Bem-vindo
Enviar Comentários

As regras de instalação examinam o computador onde a atualização será instalada.


Termos de licença

 Copiar imagem em foco
[image]

Termos de licença
Enviar Comentários

Use a página Termos de Licença para aceitar os termos da licença desta versão.

Opções

Para continuar com a instalação, você deve aceitar os termos da licença do SQL Server.

Use o botão Imprimir para imprimir uma cópia dos termos da licença desta versão. Para terminar a instalação, clique em Cancelar.


Selecionar Recursos

 Copiar imagem em foco
[image]

Selecionar Recursos
Enviar Comentários

Use a página Seleção de Recursos para selecionar componentes e recursos do SQL Server para atualização.

Opções

Clique em um nome de recurso no painel esquerdo para ver detalhes do idioma, do sistema operacional, da edição e do status.

Para atualizar um componente ou recurso, marque a caixa de seleção ao lado do nome do recurso. Para excluir um componente ou recurso desta atualização, limpe a caixa de seleção ao lado do nome do recurso.

Várias instâncias do SQL Server em um único computador podem ser atualizadas em horários diferentes, mas todos os componentes devem ser atualizados dentro de uma instância do SQL Server ao mesmo tempo. Todos os componentes compartilhados, como Componentes da Estação de trabalho, Analisador MSXML, SQLXML, componentes com compatibilidade com versões anteriores e o Gravador VSS devem ser atualizados.

Se um componente não puder ser atualizado, uma explicação será fornecida no painel Detalhes.


Verificar arquivos em uso

 Copiar imagem em foco
[image]

Verificar arquivos em uso
Enviar Comentários

Para evitar a necessidade de reiniciar o Windows após a instalação das atualizações do SQL Server, use a página Verificar Arquivos em Uso para identificar processos que estão bloqueando arquivos necessários ao programa de Instalação de atualização do SQL Server.

Pare todos os aplicativos e serviços que façam conexões com as instâncias do SQL Server que está sendo atualizado. Isso inclui parar o SQL Server Management Studio e o SSDT (Ferramentas de dados do SQL Server).

Se a Instalação determinar que arquivos estão bloqueados durante a instalação, talvez seja necessário reiniciar o computador após a conclusão da instalação. Se necessário, a Instalação solicitará que você reinicie o computador. Se o programa de Instalação precisar parar um serviço durante a instalação, ele reiniciará o serviço após a conclusão da instalação.

Para eliminar a necessidade de reiniciar o computador após a instalação, a Instalação exibirá uma lista de processos que estão bloqueando arquivos. Pare ou termine os processos e os aplicativos na lista. Em seguida, clique em Atualizar verificação para executar a verificação novamente. Clique em Parar verificação para terminar uma verificação que esteja em execução. Se arquivos bloqueados não forem encontrados, a tabela estará vazia. Quando todos os processos bloqueados tiverem sido fechados ou parados, clique em Avançar para continuar.

A Instalação registra as informações nos arquivos de log. Para obter mais informações sobre como exibir os arquivos de log, consulte Como exibir os arquivos de log da instalação do SQL Server e Como ler um arquivo de log da Instalação do SQL Server.

As seguintes informações estão incluídas no arquivo de log:

  • Nome do processo

  • Nome do recurso do SQL Server

  • Tipo de processo

  • Conta sob a qual o processo está sendo executado

  • ID do processo

  • Nome do arquivo bloqueado

Nome | Descrição
Processo | Exibe o nome completo do processo que está usando os arquivos a serem atualizados.
Tipo | Exibe o tipo de processo.
Conta | Exibe a conta sob a qual o processo está sendo executado.
ID do Processo | Exibe a ID do processo.


Pronto para Atualizar

 Copiar imagem em foco
[image]

Pronto para Atualizar
Enviar Comentários

Use a página Resumo para confirmar as alterações a serem aplicadas à sua instância do SQL Server. Para continuar com a instalação, clique em Instalar.


Progresso da Atualização

 Copiar imagem em foco
[image]

Progresso da Atualização
Enviar Comentários

Use a página Andamento da Instalação para monitorar a Instalação conforme ela se aplica à atualização de sua instância do SQL Server e de seus componentes.

Opções

A tabela fornece o nome de produto SQL Server, o nome de sua instância e o status da instalação.


Concluída

 Copiar imagem em foco
[image]

Concluída
Enviar Comentários

A página Concluída confirma o status da instalação.