Обзор документации по установке SQL Server

[image]

Обзор документации по установке SQL Server
Отправить отзыв

Документация по программе установки SQL Server доступна на установочном носителе и в сети.

Документация, доступная во время установки

Во время установки SQL Server нажмите кнопку Справка на странице мастера установки или клавишу F1 на клавиатуре, чтобы немедленно получить информацию, необходимую для завершения операции.

Общие сведения о разделах по установке SQL Server

Независимо от того, производится установка SQL Server с помощью мастера установки SQL Server или из командной строки, можно подготовиться к установке, ознакомившись со следующими разделами.

  • Планирование установки SQL Server.

    Описывает подготовку к установке SQL Server.

  • Установка SQL Server 2012

    Описывает параметры для установки SQL Server.

  • Установка компонентов бизнес-аналитики SQL Server «2012»

    Описывает параметры для установки функций SQL Server, которые являются частью платформы бизнес-аналитики Майкрософт, включающей Службы Analysis Services, Integration Services, Службы Reporting Services и несколько клиентских приложений, используемых для создания аналитических данных или работы с ними.

  • Обновление до версии SQL Server 2012

    Содержит описание параметров для обновления до SQL Server.

При установке отказоустойчивого кластера SQL Server ознакомьтесь со следующим разделом.

  • Приступая к работе с отказоустойчивой кластеризацией SQL Server.

  • Подготовка к установке отказоустойчивой кластеризации.

Изображение Нижний колонтитул
Отправьте отзыв об этом разделе в корпорацию Майкрософт

© Корпорация Майкрософт (Microsoft Corp.), 2012. Все права защищены.


Об условиях лицензионного соглашения SQL Server

[image]

Об условиях лицензионного соглашения SQL Server
См. также Отправить отзыв

Условия лицензирования программного обеспечения Майкрософт копируются на локальный компьютер во время установки SQL Server. Если на один компьютер устанавливаются нескольких экземпляров одного выпуска SQL Server на одном языке, то ко всем экземплярам выпуска на этом языке будет применена одна копия лицензионного соглашения. Этот файл сохраняется в следующей папке: %ProgramFiles%\Microsoft SQL Server\110\License Terms\ или %ProgramFiles(x86)%\Microsoft SQL Server\110\License Terms\.

Если на один компьютер устанавливаются несколько экземпляров одного выпуска SQL Server на одном языке, то ко всем экземплярам выпуска на этом языке будет применена одна копия лицензионного соглашения.

Имя файла лицензионного соглашения указывает как выпуск SQL Server, так и язык SQL Server. Например:

  • для выпуска SQL Server Developer на английском языке файл будет называться License_DEV_ENU.txt;

  • для выпуска SQL Server Standard на итальянском языке файл будет называться License_STD_ITA.txt;

  • для выпуска помощника по обновлению SQL Server на японском языке файл будет называться License_UA_JPN.txt;

  • для собственного клиента SQL Server на английском языке файл будет называться License_SQLNCLI_ENU.txt;

  • для выпуска SQLXML на корейском языке файл будет называться License_SQLXML4_KOR.txt.

  • License_SQLBI.rtf для выпуска SQL Server Business Intelligence.

  • License_ENTCORE.rtf для выпуска SQL Server Enterprise: ядро на основе лицензирования.

  • License_ENT.rtf для лицензирования доступа сервера/клиента выпуска SQL Server Enterprise.

Для обозначения выпусков SQL Server используются следующие фрагменты имен файлов:

  • ENT — выпуск Enterprise: лицензирование для доступа сервера/клиента

  • ENTCORE — выпуск Enterprise: ядро на основе лицензирования

  • BI — Business Intelligence

  • DEV — Developer

  • STD — Standard

  • WEB — Web

  • EXPR — Express

Для указания соответствующих языков SQL Server в именах файлов используются следующие обозначения:

  • ENU — английский

  • JPN — японский

  • FRA — французский

  • ITA — итальянский

  • KOR — корейский

  • DEU — немецкий

  • ESN — испанский

  • CHS — китайский (упрощенный)

  • CHT — китайский (традиционный)

  • PTB — португальский (бразильский)

  • RUS — русский

Варианты лицензирования SQL Server

Дополнительные сведения о ценах и параметрах лицензирования SQL Server см. на веб-сайте Microsoft SQL Server (http://go.microsoft.com/fwlink/?LinkId=190955).

См. также

Основные понятия

Вопросы лицензирования в SQL Server
Заявление о конфиденциальности Microsoft SQL Server
Юридическое уведомление для документации


Вопросы лицензирования в SQL Server

[image]

Вопросы лицензирования в SQL Server
См. также Отправить отзыв

Дополнительные сведения о параметрах лицензирования SQL Server см. на веб-сайте Microsoft SQL Server.

См. также

Справочник

Об условиях лицензионного соглашения SQL Server

Основные понятия

Заявление о конфиденциальности Microsoft SQL Server
Юридическое уведомление для документации


Юридическое уведомление для документации

[image]

Юридическое уведомление для документации
Отправить отзыв

Данный документ предоставляется «как есть». Сведения и представления, приведенные в этом документе, включают URL-адреса и другие ссылки на веб-сайты, которые могут изменяться без предупреждения. Вы принимаете на себя риск, связанный с пользованием этим документом.

Некоторые примеры, описанные в настоящем документе, являются вымышленными и приведены исключительно в демонстрационных целях. Примеры не рассчитаны на применение в реальных условиях, и их не следует рассматривать как относящиеся к реальным ситуациям.

Настоящий документ не предоставляет пользователям права на интеллектуальную собственность продуктов Майкрософт. Разрешается копирование и использование настоящего документа только в справочных целях.

© Корпорация Майкрософт (Microsoft Corporation), 2012. Все права защищены.

Microsoft, Active Directory, ActiveX, Bing Maps, Excel, IntelliSense, MSDN, MS-DOS, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual Studio, Windows, Windows NT, Windows Server и Windows Vista являются охраняемыми товарными знаками группы компаний Майкрософт. SAP NetWeaver является охраняемым товарным знаком SAP AG в Германии и в некоторых других странах. Все прочие товарные знаки являются собственностью их владельцев.

Политика документирования поддержки и обновления SQL Server

Документация по программному обеспечению Microsoft SQL Server 2012 включает электронную документацию по Microsoft SQL Server 2012, документацию по установке, справочную документацию для разработчика, учебники, файлы сведений, документы по известным проблемам, образцы кода и баз данных, а также статьи базы знаний, опубликованные Майкрософт и посвященные компонентам и функциям SQL Server. Эта политика поддержки и обновления относится к документации Microsoft SQL Server 2012, включая файлы сведений для выпусков и пакетов обновления Microsoft SQL Server 2012. Файл сведений следует рассматривать как дополнение электронной документации по Microsoft SQL Server 2012.

Главное назначение образца, содержащегося в документации, — иллюстрация основных понятий или обоснование использования определенной инструкции или предложения. В большинство образцов не входит весь код, который содержался бы в полноценной промышленной системе. Некоторые обычные операции проверки данных и обработки ошибок удалены из образцов намеренно, чтобы обратить внимание на конкретные концепции или инструкции, используемые в образцах. Техническая поддержка для таких образцов, равно как и для любого исходного кода, не предоставляется.

В некоторых случаях определенные компоненты Microsoft SQL Server 2012 не были в достаточной степени протестированы или разработаны, поэтому не предназначены для использования вами. Зачастую они представляют собой заполнители. Поэтому некоторые из функций, включенных в программное обеспечение, в документации не описаны. Функции, которые не задокументированы или помечены для внутреннего использования, не предназначены для использования вами и поэтому не поддерживаются службой технической поддержки Майкрософт. Если в документации по Microsoft SQL Server 2012 не указано иное, любое стороннее содержимое, включая проблемы, ставшие результатом его использования вместе с Microsoft SQL Server 2012, не поддерживаются службой технической поддержки Майкрософт и, кроме того, могут привести к потере данных. Кроме того, службы поддержки Майкрософт не обеспечивают поддержку для баз данных и приложений, в которых используются недокументированные точки входа и API-интерфейсы, включая следующие, но не ограничиваясь ими: хранимые процедуры, расширенные хранимые процедуры, функции, представления, таблицы, столбцы, свойства и метаданные.

Обновления сервера и баз данных до следующих версий Microsoft SQL Server 2012 для приложений и баз данных, в которых используются недокументированные точки входа, также могут перестать работать и не поддерживаются. Использование входящих в состав Microsoft SQL Server функций и компонентов, которые не отражены в документации по Microsoft SQL Server 2012, не поддерживается и может вызвать потерю данных.


Заявление о конфиденциальности Microsoft SQL Server

[image]

Заявление о конфиденциальности Microsoft SQL Server
Отправить отзыв

Дополнительные сведения о компонентах сбора пользовательских данных в Microsoft SQL Server 2012 см. в разделе Заявление о конфиденциальности в SQL Server.


Расположение файлов для экземпляра по умолчанию и именованных экземпляров SQL Server

[image]

Расположение файлов для экземпляра по умолчанию и именованных экземпляров SQL Server
См. также Отправить отзыв

Установка SQL Server состоит из одного или нескольких отдельных экземпляров. Как экземпляр по умолчанию, так и именованный экземпляр имеет собственный набор программных файлов и файлов данных, а также набор общих файлов, используемых всеми экземплярами SQL Server, установленными на компьютере.

Для экземпляра SQL Server, включающего Database Engine, Службы Analysis Services и Службы Reporting Services, каждый компонент имеет полный набор файлов данных и исполняемых файлов, а также общие файлы, используемые всеми компонентами.

Чтобы изолировать друг от друга папки установки, формируется уникальный идентификатор экземпляра для каждого из компонентов экземпляра SQL Server.

Важное примечание Важно!

Программные файлы и файлы данных не могут быть установлены на съемном диске, в файловой системе со сжатием данных, в каталоге расположения системных файлов, а также на общих дисках экземпляра отказоустойчивого кластера.

Не удаляйте следующие каталоги или их содержимое: Binn, Data, Ftdata, HTML или 1033. При необходимости можно удалить другие каталоги, однако возможно, что не удастся вернуть утраченную функциональность или восстановить потерянные данные без удаления и повторной установки SQL Server. Не удаляйте и не изменяйте HTM-файлы в каталоге HTML. Они необходимы для правильной работы средств SQL Server.

Общие файлы для всех экземпляров SQL Server

Общие файлы, используемые всеми экземплярами, установленными на одном компьютере, устанавливаются в папку <диск>:\Program Files\Microsoft SQL Server\110\, где <drive> — буква дисковода, где установлены компоненты. По умолчанию диск С.

Расположение файлов и сопоставление данных реестра

Во время установки SQL Server для каждого компонента сервера создается идентификатор экземпляра. В этой версии SQL Server сервер состоит из компонента Database Engine, служб Службы Analysis Services и Службы Reporting Services.

Идентификатор экземпляра по умолчанию указывается в следующем формате.

  • Для компонента Database Engine — MSSQL, за которым следуют основной номер версии, символ подчеркивания и дополнительный номер версии (если применимо), затем точка и имя экземпляра.

  • Для служб Службы Analysis Services — MSAS, за которым следуют основной номер версии, символ подчеркивания и дополнительный номер версии (если применимо), затем точка и имя экземпляра.

  • Для служб Службы Reporting Services — MSRS, за которым следуют основной номер версии, символ подчеркивания и дополнительный номер версии (если применимо), затем точка и имя экземпляра.

Ниже приведены примеры идентификаторов экземпляров по умолчанию для данного выпуска Microsoft SQL Server 2012.

  • MSSQL11.MSSQLSERVER — экземпляр Microsoft SQL Server 2012 по умолчанию.

  • MSAS11.MSSQLSERVER — экземпляр служб Службы Analysis Services по умолчанию.

  • MSSQL11.MyInstance — именованный экземпляр Microsoft SQL Server 2012 с именем «MyInstance».

Именованный экземпляр Microsoft SQL Server 2012, в состав которого входит компонент Database Engine и службы Службы Analysis Services, имеет имя «MyInstance» и устанавливается каталоге по умолчанию, имеет следующую структуру каталогов.

  • C:\Program Files\Microsoft SQL Server\MSSQL11.MyInstance\

  • C:\Program Files\Microsoft SQL Server\MSASSQL11.MyInstance\

В качестве идентификатора экземпляра может быть указано любое значение, следует только избегать применения специальных символов и зарезервированных ключевых слов. Дополнительные сведения см. в разделе Reserved Keywords (Setup).

Идентификатор экземпляра, отличный от заданного по умолчанию, можно указать во время установки SQL Server. При изменении каталога установки по умолчанию вместо «<Program Files>\Microsoft SQL Server» используется «<заданный путь>\Microsoft SQL Server». Следует заметить, что идентификаторы экземпляров, начинающиеся с символа подчеркивания (_) или содержащие символ решетки (#) или знак доллара ($), не поддерживаются.

Примечание Примечание

Службы Integration Services и клиентские компоненты не привязаны к экземпляру, поэтому им не присваивается идентификатор экземпляра. По умолчанию компоненты, не привязанные к экземпляру, устанавливаются в один каталог: <диск>:\Program Files\Microsoft SQL Server\110\. Изменение пути установки для одного компонента приводит к его изменению и для всех остальных компонентов. При последующих установках компоненты, не зависящие от экземпляра, устанавливаются в каталог исходной установки.

Службы SQL Server Службы Analysis Services являются единственным компонентом SQL Server, который поддерживает переименование экземпляра после установки. При переименовании экземпляра служб Службы Analysis Services его идентификатор экземпляра не изменится. После переименования экземпляра в каталогах и разделах реестра по-прежнему используется идентификатор экземпляра, созданный во время установки.

В разделе HKLM\Software\Microsoft\Microsoft SQL Server\<Instance_ID> создается куст реестра для компонентов, привязанных к экземпляру. Например:

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL11.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSASSQL11.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.110

В реестре также хранится сопоставление идентификаторов экземпляров с именами экземпляров. Сопоставление идентификатора экземпляра с именем экземпляра осуществляется следующим образом:

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\SQL] "InstanceName"="MSSQL11"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\OLAP] "InstanceName"="MSASSQL11"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\RS] "InstanceName"="MSRSSQL11"

Указание путей к файлам

В ходе установки можно изменить путь установки для следующих компонентов.

Путь установки отображается в программе установки только для компонентов с пользовательской целевой папкой.

Компонент | Путь по умолчанию1, 2 | Настраиваемый3 или фиксированный путь
Серверные компоненты Database Engine | \Program Files\Microsoft SQL Server\MSSQL11.<идентификатор_экземпляра>\ | Настраиваемый
Файлы данных компонента Database Engine | \Program Files\Microsoft SQL Server\MSSQL11.<идентификатор_экземпляра>\ | Настраиваемый
Сервер служб Службы Analysis Services | \Program Files\Microsoft SQL Server\MSAS11.<ИдентификаторЭкземпляра>\ | Настраиваемый
Файлы данных служб Службы Analysis Services | \Program Files\Microsoft SQL Server\MSAS11.<ИдентификаторЭкземпляра>\ | Настраиваемый
Сервер отчетов служб Службы Reporting Services | \Program Files\Microsoft SQL Server\MSRS11.<идентификатор_экземпляра>\Reporting Services\ReportServer\Bin\ | Настраиваемый
Диспетчер отчетов служб Службы Reporting Services | \Program Files\Microsoft SQL Server\MSRS11.<идентификатор_экземпляра>\Reporting Services\ReportManager\ | Фиксированный путь
Integration Services | <каталог установки>\110\DTS\ | Настраиваемый4
Master Data Services | <каталог установки>\110\Master Data Services | Настраиваемый4
Клиентские компоненты | <каталог установки>\110\Tools\ | Настраиваемый4
Объекты COM для репликации и размещения на сервере | <диск>:\Program Files\Microsoft SQL Server\110\COM\5 | Фиксированный путь
Библиотеки DLL служб Integration Services для механизмов преобразования данных в реальном режиме времени и конвейерного преобразования данных, и программа командной строки dtexec | <диск>:\Program Files\Microsoft SQL Server\110\DTS\Binn | Фиксированный путь
Библиотеки DLL, которые обеспечивают управляемое соединение, поддерживаемое для служб Integration Services | <диск>:\Program Files\Microsoft SQL Server\110\DTS\Connections | Фиксированный путь
Библиотеки DLL для каждого типа перечислителей, которые поддерживают службы Integration Services | <диск>:\Program Files\Microsoft SQL Server\110\DTS\ForEachEnumerators | Фиксированный путь
Служба браузера SQL Server, поставщики инструментария WMI | <диск>:\Program Files\Microsoft SQL Server\110\Shared\ | Фиксированный путь
Компоненты, которые разделены между всеми экземплярами SQL Server | <диск>:\Program Files\Microsoft SQL Server\110\Shared\ | Фиксированный путь

1Убедитесь, что папка \Program Files\Microsoft SQL Server\ защищена, ограничив разрешения на доступ.

2Диском по умолчанию для этих путей является systemdrive. Обычно это диск C.

3Путь установки родительского компонента определяет пути установки для дочерних компонентов.

4Общий путь установки для служб Integration Services и клиентских компонентов. Изменение пути установки для одного компонента влечет изменение пути для других компонентов. При последующих установках компоненты устанавливаются в расположение исходной установки.

5Этот каталог используется всеми экземплярами SQL Server, установленными на компьютере. При применении обновления к любому из экземпляров на компьютере все файловые изменения коснутся каждого из них. При добавлении компонентов в существующую конфигурацию невозможно ни изменить расположение ранее установленного компонента, ни указать расположение нового. Необходимо либо установить дополнительные компоненты в каталоги, созданные программой установки, либо удалить продукт и установить его заново.

Примечание Примечание

Для кластеризованных конфигураций необходимо выбрать локальный диск, доступный на всех узлах кластера.

При задании пути установки во время установки компонентов сервера или файлов данных программа установки использует идентификатор экземпляра в дополнение к заданному положению для программ и файлов данных. Программа установки не пользуется идентификаторами экземпляров для средств и других общих файлов. Идентификатор экземпляра также не используется для программных файлов и данных служб Службы Analysis Services, но используется для репозитория служб Службы Analysis Services.

При указании пути установки для компонента Database Engine программа установки SQL Server использует этот путь в качестве корневого каталога этой установки для всех папок, относящихся к экземпляру, включая файлы данных SQL. Если в этом случае указать в качестве корневого каталога «C:\Program Files\Microsoft SQL Server\MSSQL11\MSSQL\», то каталоги, относящиеся к данному экземпляру, будут добавлены в конец этого пути.

Поэтому при использовании функции обновления USESYSDB в мастере установки SQL Server (режим установки с пользовательским интерфейсом) можно попасть в ситуацию, когда продукт окажется установленным в рекурсивной структуре папок. Например, <SQLProgramFiles>\MSSQL11\MSSQL\MSSQL11\MSSQL\Data\. Поэтому при использовании функции USESYSDB вместо компонента Database Engine необходимо указывать путь установки файлов данных SQL.

Примечание Примечание

Обычно файлы данных можно найти в дочернем каталоге с именем Data. Например, чтобы при обновлении указать путь к корневому каталогу данных системных баз данных, задайте «C:\Program Files\Microsoft SQL Server\MSSQL11\», тогда файлы данных будут расположены в каталоге «C:\Program Files\Microsoft SQL Server\MSSQL11\MSSQL\Data».

См. также

Справочник

Настройка компонента Database Engine — каталоги данных
Настройка служб Analysis Services — каталоги данных


Просмотр и чтение файлов журналов программы установки SQL Server

[image]

Просмотр и чтение файлов журналов программы установки SQL Server
См. также Отправить отзыв

При каждом выполнении программы установки создаются файлы журналов в новой папке журналов с временной отметкой в %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\. Формат папки журналов с временной отметкой — ГГГГММДД_ччммсс. При запуске программы установке в автоматическом режиме журналы создаются в % temp%\sqlsetup*.log. Все файлы в папке журналов архивируются в файле Log*.cab в соответствующей папке журналов.

В процессе выполнения запрос программы установки проходит через три фазы:

  1. Текстовое содержание глобальных правил

  2. Обновление компонента

  3. Действие, указанное пользователем

На каждом этапе программа становки создает подробный и сводный журналы; при этом, если необходимо, создаются дополнительные журналы. Программа установки вызывается по меньшей мере трижды при выполнении каждого указанного пользователем действия по установке.

В файлах хранилища данных содержится моментальный снимок состояния всех объектов конфигурации, отслеживаемых процессом установки; эти файлы могут пригодиться при диагностике ошибок конфигурации. Дампы XML-файлов создаются для объектов хранилища данных в каждой фазе выполнения. Они сохраняются в собственной подпапке журналов в папке журналов с отметкой времени следующим образом:

  • Datastore_GlobalRules

  • Datastore_ComponentUpdated

  • Datastore

В следующих разделах описываются файлы журналов установки SQL Server.

Текстовое содержание сводки

Общие сведения

В этом файле отображаются компоненты SQL Server, обнаруженные на этапе установки, среда операционной системы, значения параметров командной строки (если указаны) и общее состояние всех выполненных MSI/MSP.

Журнал структурирован с использованием следующих разделов:

  • Общая сводка выполнения

  • Свойства и конфигурация компьютера, на котором была запущена программа установки SQL Server

  • Функциональные возможности продукта SQL Server, ранее установленного на компьютере

  • Описание версии установки и свойства пакета установки

  • Входные параметры среды выполнения, указанные при установке

  • Местоположение файла конфигурации

  • Данные о результатах выполнения

  • Глобальные правила

  • Правила, связанные с определенным сценарием установки

  • Правила, при выполнении которых произошла ошибка

  • Местоположение файла отчета о выполнении правил

Местоположение

Расположен в папке %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\.

Чтобы найти ошибки в текстовом файле сводки, воспользуйтесь поиском с ключевыми словами «error» или «failed».

Summary_engine-base_YYYYMMDD_HHMMss.txt

Общие сведения

Базовый файл summary_engine схож с файлом справки и создается при выполнении основного рабочего процесса.

Местоположение

Расположен в папке %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Summary_engine-base_YYYYMMDD_HHMMss_ComponentUpdate.txt

Общие сведения

Базовый файл summary_engine схож с файлом справки и создается при выполнении основного рабочего процесса.

Местоположение

Расположен в папке %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Summary_engine-base_<номер_версии>MMDD_HHMMss_GlobalRules.txt

Общие сведения

Файл сводного журнала глобальных правил схож с файлом справки и создается при выполнении рабочего процесса глобальных правил.

Местоположение

Расположен в папке %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Detail.txt

Общие сведения

Detail.txt создается при выполнении рабочего процесса основных процедур, таких как установка или обновление, и обеспечивает сведения о выполнении. Журналы в файле создаются с учетом времени инициации всех действий, связанных с установкой, и указывают на порядок выполнения действий и их зависимости.

Местоположение

Расположен в папке %programfiles%\Microsoft SQL Server\110\Setup

Bootstrap\Log\<YYYYMMDD_HHMM>\Detail.txt.

При возникновении ошибки во время процесса установки исключение или ошибка регистрируются в конце этого файла. Чтобы найти ошибки в этом файле, сначала проверьте конец файла, а затем воспользуйтесь поиском по файлу с ключевыми словами «ошибка» и «исключение».

Detail_ComponentUpdate.txt

Общие сведения

Файл Detail_ComponentUpdate.txt создается для рабочего процесса обновлений компонентов и похож на файл Detail.txt.

Местоположение

Расположен в папке %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Detail_GlobalRules.txt

Общие сведения

Файл Detail_GlobalRules.txt создается при выполнении глобальных правил и похож на файл Detail.txt.

Местоположение

Расположен в папке %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Файлы журнала MSI.

Общие сведения

В файлах журнала MSI указаны сведения о установке пакетов. Они создаются MSIEXEC при установке определенных пакетов.

Типы файлов журналов MSI:

  • <Компонент>_<Архитектура>_<Итерация>.log

  • <Компонент>_<Архитектура>_<Язык>_<Итерация>.log

  • <Компонент>_<Архитектура>_<Итерация>_<рабочий процесс>.log

Местоположение

Файлы журналов MSI расположены в %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\<Name>.log.

В конце файла приведена сводка выполнения, в которой указываются общее состояние (успешное или ошибка) и свойства. Для поиска ошибок в файле MSI воспользуйтесь поиском по ключевому выражению «value 3». Обычно ошибки можно найти рядом со строкой.

ConfigurationFile.ini

Общие сведения

В файле конфигурации содержатся входные параметры, указанные при установке. Их можно использовать для повторной установки, что избавит от необходимости их ввода вручную. Однако пароли учетных записей, PID и некоторые параметры не сохраняются в файле конфигурации. Параметры могут либо быть добавлены к файлу или указаны с помощью командной строки или пользовательского интерфейса программы установки. Дополнительные сведения см. в разделе Установка SQL Server 2012 с помощью файла конфигурации (http://go.microsoft.com/fwlink/?LinkId=231296).

Местоположение

Расположен в папке %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

SystemConfigurationCheck_Report.htm

Общие сведения

В отчете о проверке конфигурации системы содержится краткое описание всех выполняемых правил и состояния выполнения.

Местоположение

Расположен в папке %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

См. также

Основные понятия

Устранение неполадок при установке SQL Server


Устранение неполадок при установке SQL Server

[image]

Устранение неполадок при установке SQL Server
См. также Отправить отзыв

Для сведений об устранении неполадок при установке и обновлении см. Файл сведений SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=196910).

См. также

Основные понятия

Просмотр и чтение файлов журналов программы установки SQL Server


Справочник по пользовательскому интерфейсу программы установки SQL Server

[image]

Справочник по пользовательскому интерфейсу программы установки SQL Server
Отправить отзыв

В этом разделе описаны режимы установки, доступные в мастере установки SQL Server.


Принятие условий лицензионного соглашения

[image]

Принятие условий лицензионного соглашения
См. также Отправить отзыв

На странице Принять условия лицензии мастера установки SQL Server примите условия лицензии для этого выпуска SQL Server.

Лицензионное соглашение можно распечатать или скопировать в буфер обмена. Чтобы продолжить работу, примите условия лицензии, а затем нажмите кнопку Далее. Чтобы закрыть программу установки, нажмите кнопку Отмена.

Отчеты об использовании компонентов

Если включить отчеты об использовании компонентов, SQL Server будет настроен для периодической отправки отчетов в Microsoft. Отчеты будут содержать сведения о конфигурации оборудования, а также об использовании SQL Server и его компонентов. Эти данные используются корпорацией Microsoft для совершенствования SQL Server. Эта функция отслеживает следующие компоненты SQL Server.

  • Компонент Database Engine

  • Службы Analysis Services

  • Службы Reporting Services

  • Integration Services

  • Репликация

  • SQL Server Data Tools (SSDT)

  • Программа установки SQL Server

Сведения об использовании функций отправляются в Microsoft, где хранятся с ограничением доступа.

Для отключения отчетов об использовании компонентов после завершения установки воспользуйтесь средством Служба отчетов об ошибках и использовании SQL Server в меню SQL Server средства настройки.

Что же касается таких действий, осуществляемых программой установки, как установка, обновление, исправление и т. д., то сбор и передача сведений о них осуществляется только во время работы программы установки.

Применительно ко всем прочим компонентам SQL Server сбор сведений производится всего один раз в день по всем разрешенным экземплярам SQL Server. По умолчанию сбор запланирован на полночь, что позволяет свести к минимуму нагрузку на сервер. Если необходимо изменить время сбора данных, можно вручную отредактировать раздел реестра, управляющий этим временем. Каждый экземпляр SQL Server использует собственный раздел реестра:

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL11.<ИДЕНТИФИКАТОР_ЭКЗЕМПЛЯРА>\CPE\TimeofReporting

Значение этого раздела реестра содержит время сбора данных как число минут с 00:00 (полуночи) до времени запуска. Например, значение, равное 60, запустит сбор данных в 1:00, значение 1200 — в 20:00, и так далее.

См. также

Справочник

Об условиях лицензионного соглашения SQL Server


Добавление узла отказоустойчивого кластера SQL Server

[image]

Добавление узла отказоустойчивого кластера SQL Server
См. также Отправить отзыв

Программа установки SQL Server проверяет конфигурацию компьютера перед началом установки. Во время установки SQL Server средство проверки конфигурации системы (SCC) просматривает компьютер, на котором устанавливается SQL Server. Средство SCC проверяет наличие условий, препятствующих успешной установке SQL Server. Прежде чем программа установки запустит мастер установки SQL Server, SCC получает сведения о состоянии каждого элемента. Затем оно сравнивает результаты с требуемыми условиями и предоставляет рекомендации по устранению критических препятствий.

При проверке конфигурации системы создается отчет, содержащий краткое описание всех выполненных правил и состояния выполнения. Отчет о проверке конфигурации системы находится в папке %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Прежде чем начинать установку, ознакомьтесь со следующими разделами:

  1. Требования к оборудованию и программному обеспечению для установки SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Возможности, поддерживаемые различными выпусками SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Вопросы безопасности при установке SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Версии SQL Server на местных языках(http://go.microsoft.com/fwlink/?LinkId=235027)

Другие ссылки:

  1. Поддерживаемые обновления версий и выпусков(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Подготовка к установке отказоустойчивой кластеризации(http://go.microsoft.com/fwlink/?LinkId=235034)

См. также

Справочник

Правила поддержки программы установки


Настройка служб Analysis Services — провизионирование учетных записей

[image]

Настройка служб Analysis Services — провизионирование учетных записей
См. также Отправить отзыв

На этой странице можно выбрать режим сервера и предоставить административные разрешения пользователям или службам, которым требуется неограниченный доступ к службам Службы Analysis Services. Программа установки не добавляет автоматически локальную группу Windows «BUILTIN\Администраторы» в роль администратора сервера служб Службы Analysis Services устанавливаемого экземпляра. Если к роли администратора сервера требуется добавить локальную группу администраторов, необходимо явно указать эту группу.

При установке PowerPivot для SharePoint необходимо предоставить административные разрешения администраторам ферм SharePoint или администраторам служб, отвечающим за развертывание сервера PowerPivot в ферме SharePoint Server 2010. Дополнительные сведения об установке Служба PowerPivot и требованиях к учетным записям служб см. в разделе Установка PowerPivot для SharePoint.

Параметры

Режим сервера. Указывает тип баз данных служб Analysis Services, которые могут быть развернуты на сервере. Режимы сервера задаются во время установки, впоследствии изменить их будет невозможно. Каждый режим является взаимоисключающим, в силу чего необходимо будет установить два экземпляра служб Analysis Services, каждый из которых будет настроен для работы в другом режиме, чтобы обеспечить поддержку классических решений OLAP и табличных моделей.

Определить администраторов — для экземпляра SQL Server необходимо указать хотя бы одного администратора сервера. Указанные пользователи или группы станут членами роли администратора сервера устанавливаемого экземпляра служб Службы Analysis Services. В домене, где зарегистрирован компьютер, на который выполняется установка программного обеспечения, должны иметься учетные записи пользователей домена Windows.

Примечание Примечание

Контроль учетных записей представляет собой средство безопасности Windows, которое требует, чтобы администратор явно одобрил административные действия или приложения, прежде чем будет разрешено их выполнение. Поскольку контроль учетных записей включен по умолчанию, администратор получает запрос на разрешение определенных операций, требующих более высокого уровня привилегий. Можно настроить контроль учетных записей, изменив поведение по умолчанию, или задать определенную конфигурацию для конкретных программ. Дополнительные сведения о контроле учетных записей и его настройке см. в материалах Пошаговое руководство по контролю учетных записей и User Account Control (Wikipedia) (возможно, на английском языке).

См. также

Другие ресурсы

Изменение учетных записей и паролей службы (PowerPivot для SharePoint)
Настройка учетной записи службы Analysis Services
Настройка учетных записей службы Windows


Настройка служб Analysis Services — каталоги данных

[image]

Настройка служб Analysis Services — каталоги данных
См. также Отправить отзыв

Приведенные в следующей таблице каталоги по умолчанию можно изменить с помощью программы установки SQL Server. Разрешение на доступ к этим файлам предоставляется локальным администраторам и членам группы безопасности SQLServerMSASUser$<экземпляр>, которая создается и настраивается во время установки.

Описание

Каталог по умолчанию

Рекомендации

Корневой каталог данных

C:\Program Files\Microsoft SQL Server\MSAS11.<ИдентификаторЭкземпляра>\OLAP\Data\

Убедитесь, чтобы папка \Program files\Microsoft SQL Server\ была защищена ограниченными разрешениями. Во многих конфигурациях производительность служб Службы Analysis Services зависит от производительности хранилища, в котором размещается каталог данных. Поместите этот каталог в доступном хранилище, имеющем самое высокое быстродействие. При установке отказоустойчивых кластеров каталоги данных должны находиться на общем диске.

Каталог файла журнала

C:\Program Files\Microsoft SQL Server\MSAS11.<ИдентификаторЭкземпляра>\OLAP\Log\

Это каталог для файлов журнала служб Службы Analysis Services, в нем размещается журнал FlightRecorder. При увеличении времени существования «черного ящика» позаботьтесь о том, чтобы в каталоге журнала было достаточно места.

Каталог temp

C:\Program Files\Microsoft SQL Server\MSAS11.<ИдентификаторЭкземпляра>\OLAP\Temp\

Поместите каталог «Temp» в высокопроизводительном хранилище.

Каталог резервного копирования

C:\Program Files\Microsoft SQL Server\MSAS11.<ИдентификаторЭкземпляра>\OLAP\Backup\

Это каталог для файлов резервной копии служб Службы Analysis Services по умолчанию. Здесь же системная служба PowerPivot кэширует файлы данных PowerPivot для установок SharePoint.

Убедитесь, что заданы соответствующие разрешения, чтобы предотвратить потерю данных, а также что группа пользователей для служб Службы Analysis Services имеет достаточные разрешения для записи в каталог резервных копий. Использование подключенных дисков для размещения каталогов резервного копирования не поддерживается.

Примечания

  • Экземпляры служб Службы Analysis Services, развернутые в ферме SharePoint, хранят файлы приложений, файлы данных и свойства в базах данных содержимого и базах данных приложений служб.

  • При добавлении компонентов в существующую конфигурацию невозможно ни изменить расположение ранее установленного компонента, ни указать расположение нового.

  • Если при установке были указаны каталоги, отличные от каталогов по умолчанию, проверьте их уникальность для данного экземпляра SQL Server. Ни один из каталогов, заданных в этом диалоговом окне, не должен совпадать с каталогами, указанными для других экземпляров SQL Server. Компонент Database Engine и службы Службы Analysis Services должны быть установлены на экземпляре SQL Server в разные каталоги.

  • Программные файлы и файлы данных невозможно установить:

    • на съемный диск

    • в файловую систему, использующую сжатие

    • в каталог, в котором находятся системные файлы

    • на общие диски в экземпляре отказоустойчивого кластера

См. также

Основные понятия

Расположение файлов для экземпляра по умолчанию и именованных экземпляров SQL Server


Выбор диска кластера

[image]

Выбор диска кластера
Отправить отзыв

Страница Выбор диска кластера мастера установки SQL Server используется для выбора диска кластера как общего ресурса для отказоустойчивого кластера SQL Server. Данные SQL Server будут размещены на диске кластера.

Общий диск кластера не является обязательным для установки кластера SQL Server Database Engine. Файловый сервер SMB поддерживается в качестве хранилища для отказоустойчивых кластеров SQL Server Database Engine, его можно указать на странице Компонент Database Engine — каталоги данных перед завершением установки.

Предупреждение Внимание!

Если для установки были выбраны службы Analysis Services, необходимо указать общий диск кластера.

Если на этом экземпляре отказоустойчивого кластера SQL Server планируется включить параметр FILESTREAM, необходимо указать общий диск кластера.

Параметры

Общие диски

Выбирает диск из списка. Данные SQL Server будут размещены на этом диске кластера.

Можно указать только один диск. Если выбрать группу, содержащую ресурс кластерного кворума, выводится предупреждение. Рекомендуется не выполнять установку на ресурс кластерного кворума.

Доступные общие диски

Отображает список доступных дисков, указывает, определен ли отдельный диск как общий, и выводит описание дискового ресурса.


Конфигурация сети кластера

[image]

Конфигурация сети кластера
Отправить отзыв

Страница Выбор сети кластера используется для указания сетевого ресурса для экземпляра отказоустойчивого кластера.

Параметры

Сетевое имя отказоустойчивого кластера SQL Server. Имя, идентифицирующее экземпляр отказоустойчивого кластера в сети.

Параметры сети. Тип протокола IP и IP-адрес экземпляра отказоустойчивого кластера.

Во время операций добавления или удаления узла SQL Server отображает доступный только для чтения список существующих IP-адресов для отказоустойчивого кластера SQL Server.

  • Интегрированная установка:

    • При добавлении узла, поддерживающего идентичный набор подсетей, поддерживаемый существующими узлами отказоустойчивого кластера SQL Server, дополнительный IP-адрес добавить невозможно. Параметр зависимости остается неизменным.

    • При добавлении узла, поддерживающего подмножество подсетей, поддерживаемое существующими узлами отказоустойчивого кластера SQL Server, невозможно добавить дополнительные IP-адреса ресурсов. Для параметра зависимости ресурса IP-адреса задается значение ИЛИ, указывающее, что все указанные IP-адреса являются недопустимыми на всех узлах кластера.

    • При добавлении узла, поддерживающего подсети в дополнение к подсетям, поддерживаемым существующими узлами отказоустойчивого кластера SQL Server, есть возможность добавить новые допустимые IP-адреса. Если указаны новые IP-адреса, для параметра зависимости ресурса IP-адреса задается значение ИЛИ, указывающее, что все указанные IP-адреса являются недопустимыми на всех узлах кластера.

    • При добавлении узла, поддерживающего дополнительные подсети, но не поддерживающего ни одну из подсетей, поддерживаемых существующими узлами отказоустойчивого кластера SQL Server, необходимо добавить дополнительные IP-адреса. Для параметра зависимости ресурса IP-адреса задается значение ИЛИ, указывающее, что все указанные IP-адреса являются недопустимыми на всех узлах кластера.

  • Расширенная установка: На шаге завершения установки укажите IP-адрес для всех узлов и подсетей экземпляра отказоустойчивого кластера. Для отказоустойчивого кластера с несколькими подсетями можно задать несколько IP-адресов, но поддерживается только один IP-адрес для каждой подсети. Каждый подготовленный узел должен быть владельцем по крайней мере одного IP-адреса. Если в отказоустойчивом кластере SQL Server имеется несколько подсетей, появится запрос на указание для параметра зависимости ресурса IP-адреса значения ИЛИ. Удаление узла:

    • Если оставшиеся IP-адреса поддерживаются на всех оставшихся узлах, появится запрос на указание для параметра зависимости ресурса IP-адреса значения И.

    • Если оставшиеся IP-адреса не поддерживаются на всех оставшихся узлах, то для параметра зависимости ресурса IP-адреса останется значение ИЛИ.


Настройка узла кластера

[image]

Настройка узла кластера
Отправить отзыв

Для добавления или удаления узлов в экземпляре отказоустойчивого кластера используется страница «Настройка узла кластера». Чтобы установить или обновить отказоустойчивый кластер SQL Server, необходимо запустить программу установки на каждом узле кластера. Чтобы добавить узел в существующий отказоустойчивый кластер SQL Server, необходимо запустить программу установки SQL Server на узле, который добавляется к экземпляру отказоустойчивого кластера SQL Server.

Параметры

Имя экземпляра SQL Server. Для выбора экземпляра отказоустойчивого кластера SQL Server используется раскрывающийся список.

Имя узла. В этом поле отображается имя компьютера с выполняющейся программой установки SQL Server. Это узел отказоустойчивого кластера, который будет добавлен в экземпляр кластера отработки отказа SQL Server или удален из кластера.


Настройка узла кластера (Полная)

[image]

Настройка узла кластера (Полная)
Отправить отзыв

Воспользуйтесь страницей «Настройка узла кластера (полная)», чтобы указать существующий экземпляр SQL Server, который подготовлен для работы в кластере. Чтобы установить или обновить отказоустойчивый кластер SQL Server, необходимо запустить программу установки на каждом узле кластера. Чтобы добавить узел в существующий отказоустойчивый кластер SQL Server, необходимо запустить программу установки SQL Server на узле, который добавляется к экземпляру отказоустойчивого кластера SQL Server.

Параметры

Из раскрывающегося списка:

  • Имя экземпляра SQL Server: выбор имени экземпляра отказоустойчивого кластера SQL Server.

  • Имя узла: это поле содержит имя компьютера, на котором выполняется программа установки SQL Server.

  • Сетевое имя отказоустойчивого кластера SQL Server: это поле предварительно не заполнено. Укажите сетевое имя для нового экземпляра отказоустойчивого кластера SQL Server. Это имя, которое идентифицирует отказоустойчивый кластер в сети.


Группа кластерных ресурсов

[image]

Группа кластерных ресурсов
См. также Отправить отзыв

Страница «Группа кластерных ресурсов» используется для указания диска, на котором будет располагаться группа кластерных ресурсов SQL Server.

Параметры

Укажите имя группы ресурсов кластера SQL Server. Имеются две возможности.

  • Использование раскрывающегося списка, чтобы указать использование существующей группы.

  • Введите имя создаваемой группы. Обратите внимание, что имя «Доступное хранилище» является недопустимым именем группы.

См. также

Другие ресурсы

Как создать новый отказоустойчивый кластер SQL Server (программа установки)


Политика безопасности кластера

[image]

Политика безопасности кластера
Отправить отзыв

Страница «Политика безопасности кластера» используется для настройки политики безопасности для экземпляра отказоустойчивого кластера.

Параметры

Укажите глобальные или локальные группы доменов для служб, поддерживающих работу в кластере. Управление разрешениями на все ресурсы производится на уровне групп домена, членами которых являются учетные записи служб SQL Server. Сведения о функциональных возможностях идентификаторов безопасности (SID) службы в Windows Server 2008 см. в разделе Настройка учетных записей служб Windows.

Если экземпляр отказоустойчивого кластера Microsoft SQL Server 2012 устанавливается в домене Windows 2000 смешанного режима, для служб SQL Server, поддерживающих работу в кластере, необходимо использовать глобальные группы домена.

Примечание Примечание

Контроллеры домена Windows 2000 могут работать в смешанном режиме и в собственном режиме. Смешанный режим позволяет располагать контроллеры домена низкого уровня в том же домене.


Завершение (завершение образа)

[image]

Завершение (завершение образа)
Отправить отзыв

На странице Завершение можно проверить завершение настройки подготовленного экземпляра.

Параметры

Диалоговое окно содержит ссылку на файл журнала установки для данной операции. Чтобы завершить установку, нажмите кнопку Готово.


Ход выполнения завершения образа

[image]

Ход выполнения завершения образа
См. также Отправить отзыв

Страница Ход выполнения завершения образа мастера установки SQL Server позволяет наблюдать за состоянием установки завершения образа SQL Server. После завершения этого шага на данной странице будут перечислены состояния для каждого настроенного и завершенного компонента SQL Server.

См. также

Основные понятия

Просмотр и чтение файлов журналов программы установки SQL Server


Правила завершения образа

[image]

Правила завершения образа
Отправить отзыв

Программа установки SQL Server проверяет конфигурацию компьютера перед началом установки. Во время установки SQL Server средство проверки конфигурации системы (SCC) просматривает компьютер, на котором устанавливается SQL Server. Средство SCC проверяет наличие условий, препятствующих успешной установке SQL Server. Прежде чем программа установки запустит мастер установки SQL Server, SCC получает сведения о состоянии каждого элемента. Затем оно сравнивает результаты с требуемыми условиями и предоставляет рекомендации по устранению критических препятствий.

При проверке конфигурации системы создается отчет, содержащий краткое описание всех выполненных правил и состояния выполнения. Отчет о проверке конфигурации системы находится в папке %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Прежде чем начинать установку, ознакомьтесь со следующими разделами.

  1. Требования к оборудованию и программному обеспечению для установки SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Возможности, поддерживаемые различными выпусками SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Вопросы безопасности при установке SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Версии SQL Server на местных языках(http://go.microsoft.com/fwlink/?LinkId=235027)

Другие ссылки:

  1. Поддерживаемые обновления версий и выпусков(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Подготовка к установке отказоустойчивой кластеризации(http://go.microsoft.com/fwlink/?LinkId=235034)


Завершение (подготовка образа)

[image]

Завершение (подготовка образа)
Отправить отзыв

На странице Завершение можно удостовериться в том, что подготовка образа завершена.

Параметры

Диалоговое окно содержит ссылку на файл журнала установки для данной операции. Чтобы завершить подготовку образа, нажмите кнопку Готово.


Завершение (восстановление)

[image]

Завершение (восстановление)
Отправить отзыв

На странице Завершение (восстановление) можно убедиться, что восстановление завершено.

Параметры

Диалоговое окно содержит ссылку на файл журнала установки для данной операции. Чтобы продолжить, нажмите кнопку Закрыть.


Завершение — обновление

[image]

Завершение — обновление
Отправить отзыв

Используйте страницу «Завершение (обновление)» для проверки, что обновление завершено.

Параметры

Диалоговое окно содержит ссылку на файл журнала установки для данной операции. Чтобы продолжить, нажмите кнопку Закрыть.


Настройка компонента Database Engine — провизионирование учетных записей

[image]

Настройка компонента Database Engine — провизионирование учетных записей
См. также Отправить отзыв

Эта страница служит для задания режима безопасности SQL Server, а также для добавления пользователей или групп Windows в качестве администраторов компонента Компонент SQL Server Database Engine.

Рекомендации по запуску SQL Server 2012 в Windows Vista, Windows 7 и Windows Server 2008

В предыдущих версиях SQL Server группа ВСТРОЕННЫЕ\Администраторы применялась в качестве имени входа в компонент Database Engine, а члены локальной группы «Администраторы» могли входить в систему с помощью своих учетных данных администратора. Использовать повышенные разрешения не рекомендуется. В Microsoft SQL Server 2012 группа ВСТРОЕННЫЕ\Администраторы в качестве имени входа не используется. Поэтому следует создать имя входа SQL Server для каждого административного пользователя и добавить это имя входа в предопределенную роль сервера sysadmin во время установки нового экземпляра Microsoft SQL Server 2012. Это нужно также сделать для учетных записей Windows, которые используются для запуска заданий агента SQL Server. Это включает задания агента репликации.

Параметры

Режим безопасности — выберите для установки параметр «Проверка подлинности Windows» или «Смешанный режим проверки подлинности».

Провизионирование участников Windows — в предыдущих версиях SQL Server локальная группа Windows «Builtin\Администраторы» помещалась в роль сервера SQL Server sysadmin, что в сущности предоставляло администраторам Windows доступ к экземпляру SQL Server. В Microsoft SQL Server 2012 не выполняется подготовка группы «Builtin\Администраторы» в роли сервера sysadmin. Вместо этого необходимо выполнить явную подготовку администраторов SQL Server для новых экземпляров во время установки.

Важное примечание Важно!

Во время установки необходимо явно указать администраторов SQL Server для новых экземпляров. Программа установки не позволит продолжить установку, пока это не будет сделано.

Укажите администраторов SQL Server — необходимо указать по крайней мере одного участника Windows для этого экземпляра SQL Server. Чтобы добавить учетную запись, от которой запущена программа установки SQL Server, нажмите кнопку Текущий пользователь. Чтобы добавить или удалить учетные записи из списка системных администраторов, нажмите кнопку Добавить или Удалить и затем измените список пользователей, групп или компьютеров, которые будут иметь права администраторов на этот экземпляр SQL Server.

Закончив изменение списка, нажмите кнопку ОК и проверьте список администраторов в диалоговом окне конфигурации. После завершения работы со списком нажмите кнопку Далее.

При выборе параметра «Смешанный режим проверки подлинности» необходимо предоставить учетные данные регистрации для встроенной учетной записи системного администратора SQL Server.

Примечание по безопасности Примечание по безопасности

Не используйте пустые пароли. Выбирайте надежные пароли.

Режим проверки подлинности Windows

Когда пользователь выполняет подключение под пользовательской учетной записью Windows, SQL Server проверяет имя учетной записи и пароль с помощью токена участника Windows в операционной системе. Этот режим проверки подлинности используется по умолчанию, и он гораздо надежнее смешанного режима. Режим проверки подлинности Windows использует протокол безопасности Kerberos, обеспечивает соблюдение политики паролей при условии проверки сложности для надежных паролей, обеспечивает блокировки учетных записей и проверки истечения срока действия пароля.

Примечание по безопасности Примечание по безопасности

По возможности используйте проверку подлинности Windows.

Важное примечание Важно!

Не используйте пустые пароли. Выбирайте надежные пароли. Никогда не указывайте пустой или простой пароль для пользователя sa.

Смешанный режим (проверка подлинности Windows или проверка подлинности SQL Server)

Возможность подключения пользователей с помощью режима проверки подлинности Windows или проверки подлинности SQL Server. Пользователи, которые подключаются под учетной записью Windows, могут использовать доверенные соединения, которые проверяются Windows.

При выборе смешанного режима проверки подлинности и наличии условий для использования входных имен SQL для согласования унаследованных приложений необходимо установить надежные пароли для всех учетных записей SQL Server.

Примечание Примечание

Проверка подлинности SQL Server поддерживается только для обратной совместимости. По возможности используйте проверку подлинности Windows.

Ввод пароля

Введите и подтвердите имя входа для системного администратора (sa). Пароли являются основным способом защиты компьютера от несанкционированного доступа, поэтому для обеспечения безопасности системы обязательна настройка надежных паролей. Не оставляйте поле для ввода пароля пустым и не используйте пароль sa, который легко разгадать.

Примечание Примечание

Пароли SQL Server могут содержать от 1 до 128 символов, включая любое сочетание букв, символов и цифр. При выборе смешанного режима проверки подлинности необходимо ввести надежный пароль sa, прежде чем мастер установки перейдет на следующую страницу.

Рекомендации по выбору надежного пароля

Надежные пароли не могут быть легко расшифрованы человеком или взломаны при помощи компьютерных программ. При установке надежных паролей нельзя использовать определенные символы или готовые слова, в том числе:

  • незаполненный или ПУСТОЙ;

  • Password;

  • Admin;

  • Administrator;

  • sa;

  • sysadmin.

Надежный пароль не может включать в себя следующие термины, связанные с установкой компьютера:

  • имя пользователя, зарегистрированного в компьютере в настоящий момент;

  • имя компьютера.

Надежный пароль должен состоять не менее чем из восьми символов и удовлетворять как минимум трем из следующих четырех критериев.

  • Он должен включать прописные буквы.

  • Он должен включать строчные буквы.

  • Он должен включать цифры.

  • Он должен содержать неалфавитные символы, например #, % или ^.

Пароли, введенные на этой странице, должны отвечать требованиям политики надежных паролей. При использовании автоматизации с функцией проверки подлинности SQL Server убедитесь, что пароль отвечает требованиям политики надежных паролей.

См. также

Дополнительные сведения о выборе между проверкой подлинности Windows и проверкой подлинности SQL Server см. в разделе Выбор режима проверки подлинности электронной документации по SQL Server.

Дополнительные сведения о выборе учетной записи для выполнения служб Компонент SQL Server Database Engine приводятся в разделе Настройка учетных записей и разрешений служб электронной документации по SQL Server.

См. также

Справочник

Настройка учетных записей службы Windows и разрешений


Настройка компонента Database Engine — каталоги данных

[image]

Настройка компонента Database Engine — каталоги данных
См. также Отправить отзыв

На этой странице указывается расположение, в которое будут установлены программные файлы и файлы данных компонента SQL Server Database Engine. В зависимости от типа установки в качестве хранилища можно использовать локальный диск, общее хранилище или файловый сервер SMB.

Чтобы указать общую папку SMB в качестве каталога, необходимо вручную ввести путь в поддерживаемом формате UNC. Выбор общей папки SMB с помощью графического интерфейса не поддерживается. Далее приведен поддерживаемый формат UNC общей папки SMB: "\\Имя_сервера\Имя_папки\..."

Изолированный экземпляр SQL Server

В следующей таблице приведены поддерживаемые типы хранилища и каталоги по умолчанию для изолированного экземпляра SQL Server, которые можно изменять в программе установки SQL Server.

Описание | Поддерживаемые типы хранилища | Каталог по умолчанию | Рекомендации
Корневой каталог данных | Локальный диск, файловый сервер SMB, общее хранилище 1 | C:\Program Files\Microsoft SQL Server\ | Программа установки SQL Server настроит ACL для каталогов SQL Server и отменит наследование как часть конфигурации.
Каталог пользовательской базы данных | Локальный диск, файловый сервер SMB, общее хранилище 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<ИдентификаторЭкземпляра>\MSSQL\Data | Рекомендации пользователю каталогов данных зависят от рабочей нагрузки и требований производительности.
Каталог журналов пользовательской базы данных | Локальный диск, файловый сервер SMB, общее хранилище 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<ИдентификаторЭкземпляра>\MSSQL\Data | Убедитесь, что каталог журнала имеет достаточно свободного места.
Каталог базы данных temp | Локальный диск, файловый сервер SMB, общее хранилище 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<ИдентификаторЭкземпляра>\MSSQL\Data | Рекомендации по использованию временного каталога зависят от рабочей нагрузки и требований производительности.
Каталог журналов базы данных temp | Локальный диск, файловый сервер SMB, общее хранилище 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<ИдентификаторЭкземпляра>\MSSQL\Data | Убедитесь, что каталог журнала имеет достаточно свободного места.
Каталог резервного копирования | Локальный диск, файловый сервер SMB, общее хранилище 1 | C:\Program Files\Microsoft SQL Server\MSSQL11.<идентификатор_экземпляра>\MSSQL\Backup | Установите необходимые разрешения для предотвращения потери данных и удостоверьтесь, что учетная запись пользователя службы SQL Server имеет достаточно разрешений для записи в каталог резервного копирования. Использование подключенных дисков для размещения каталогов резервного копирования не поддерживается.

1 Хотя общие диски и поддерживаются, использовать их для изолированных экземпляров SQL Server не рекомендуется.

Экземпляр отказоустойчивого кластера SQL Server.

В следующей таблице приведены поддерживаемые типы хранилища и каталоги по умолчанию для экземпляра отказоустойчивого кластера SQL Server, которые можно изменить в программе установки SQL Server.

Описание

Поддерживаемые типы хранилища

Каталог по умолчанию

Рекомендации

Корневой каталог данных

Общее хранилище, файловый сервер SMB

<Диск:>\Program Files\Microsoft SQL Server\

Совет Совет

Если на странице Выбор диска кластера был указан общий диск, по умолчанию используется первый общий диск. Если на странице Выбор диска кластера не было указано никакого значения, это поле по умолчанию остается пустым.

Программа установки SQL Server настроит ACL для каталогов SQL Server и отменит наследование как часть конфигурации.

Каталог пользовательской базы данных

Общее хранилище, файловый сервер SMB

<Диск:>Program Files\Microsoft SQL Server\MSSQL11.<идентификатор_экземпляра>\MSSQL\Data

Совет Совет

Если на странице Выбор диска кластера был указан общий диск, по умолчанию используется первый общий диск. Если на странице Выбор диска кластера не было указано никакого значения, это поле по умолчанию остается пустым.

Рекомендации пользователю каталогов данных зависят от рабочей нагрузки и требований производительности.

Каталог журналов пользовательской базы данных

Общее хранилище, файловый сервер SMB

<Диск:>\Program Files\Microsoft SQL Server\MSSQL11.<идентификатор_экземпляра>\MSSQL\Data

Совет Совет

Если на странице Выбор диска кластера был указан общий диск, по умолчанию используется первый общий диск. Если на странице Выбор диска кластера не было указано никакого значения, это поле по умолчанию остается пустым.

Убедитесь, что каталог журнала имеет достаточно свободного места.

Каталог базы данных temp

Локальный диск, общее хранилище, файловый сервер SMB

<Диск:>\Program Files\Microsoft SQL Server\MSSQL11.<идентификатор_экземпляра>\MSSQL\Data

Совет Совет

Если на странице Выбор диска кластера был указан общий диск, по умолчанию используется первый общий диск. Если на странице Выбор диска кластера не было указано никакого значения, это поле по умолчанию остается пустым.

Указанный каталог должен быть допустимым для всех узлов кластера. Если во время отработки отказа каталоги tempdb недоступны на целевом узле отработки отказа, то при переводе ресурсов SQL Server в режим «в сети» произойдет ошибка.

Каталог журналов базы данных temp

Локальный диск, общее хранилище, файловый сервер SMB

<Диск:>\Program Files\Microsoft SQL Server\MSSQL11.<идентификатор_экземпляра>\MSSQL\Data

Совет Совет

Если на странице Выбор диска кластера был указан общий диск, по умолчанию используется первый общий диск. Если на странице Выбор диска кластера не было указано никакого значения, это поле по умолчанию остается пустым.

Указанный каталог должен быть допустимым для всех узлов кластера. Если во время отработки отказа каталоги tempdb недоступны на целевом узле отработки отказа, то при переводе ресурсов SQL Server в режим «в сети» произойдет ошибка.

Каталог резервного копирования

Локальный диск, общее хранилище, файловый сервер SMB

<Диск:>\Program Files\Microsoft SQL Server\MSSQL11.<идентификатор_экземпляра>\MSSQL\Backup

Совет Совет

Если на странице Выбор диска кластера был указан общий диск, по умолчанию используется первый общий диск. Если на странице Выбор диска кластера не было указано никакого значения, это поле по умолчанию остается пустым.

Установите необходимые разрешения для предотвращения потери данных и удостоверьтесь, что учетная запись пользователя службы SQL Server имеет достаточно разрешений для записи в каталог резервного копирования. Использование подключенных дисков для размещения каталогов резервного копирования не поддерживается.

Соображения безопасности

Программа установки SQL Server настроит ACL для каталогов и отменит наследование как часть конфигурации.

В отношении файлового сервера SMB действуют следующие рекомендации.

  • При использовании файлового сервера SMB учетная запись службы SQL Server должна быть учетной записью домена.

  • Учетная запись, используемая для установки SQL Server, должна иметь разрешение FULL CONTROL NTFS на общую папку файлов SMB, которая используется в качестве каталога данных.

  • Учетная запись, используемая для установки SQL Server, должна обладать правами SeSecurityPrivilege на файловом сервере SMB. Чтобы предоставить это право, используйте консоль локальной политики безопасности на файловом сервере, чтобы добавить учетную запись установки SQL Server в политику Управление журналом аудита и безопасности. Этот параметр находится в разделе Назначение прав пользователя в узле Локальные политики консоли Локальная политика безопасности.

Примечания

  • При добавлении компонентов к уже установленной конфигурации невозможно изменить расположение ранее установленного компонента или указать расположение нового компонента.

  • Если при установке были указаны каталоги, отличные от каталогов по умолчанию, проверьте их уникальность для данного экземпляра SQL Server. Ни один из каталогов, заданных в этом диалоговом окне, не должен совпадать с каталогами, указанными для других экземпляров SQL Server. Компонент Database Engine и службы Службы Analysis Services должны быть установлены на экземпляре SQL Server в разные каталоги.

  • Программные файлы и файлы данных невозможно установить:

    • на съемный диск

    • в файловую систему, использующую сжатие

    • в каталог, в котором находятся системные файлы

    • На подключенном сетевом диске экземпляра отказоустойчивого кластера

См. также

Основные понятия

Расположение файлов для экземпляра по умолчанию и именованных экземпляров SQL Server

Другие ресурсы

Разрешения на общую папку и NTFS на файловом сервере


Настройка компонента Database Engine — Filestream

[image]

Настройка компонента Database Engine — Filestream
См. также Отправить отзыв

Эта страница используется, чтобы включить FILESTREAM для этой установки Microsoft SQL Server 2012. FILESTREAM объединяет компонент Компонент SQL Server Database Engine с файловой системой NTFS, размещая данные больших двоичных объектов (BLOB) типа varbinary(max) в файловой системе в виде файлов. С помощью инструкций Transact-SQL можно вставлять, обновлять, запрашивать, искать и создавать резервные копии данных FILESTREAM. Интерфейсы файловой системы Win32 предоставляют потоковый доступ к этим данным.

Разрешить FILESTREAM при доступе через Transact-SQL

Выберите, чтобы включить FILESTREAM для доступа Transact-SQL. Необходимо выбрать этот элемент управления, прежде чем будут доступны другие параметры управления.

Разрешить FILESTREAM при потоковом доступе файлового ввода-вывода

Выберите, чтобы разрешить потоковый доступ Win32 для FILESTREAM.

Имя общего ресурса Windows

Этот элемент управления используется для ввода имени общего ресурса Windows, в котором будут храниться данные FILESTREAM.

Разрешить удаленным клиентам потоковый доступ к данным FILESTREAM

Выберите этот элемент управления, чтобы разрешить удаленным клиентам доступ к этим данным FILESTREAM на этом сервере.

См. также

Справочник

sp_configure (Transact-SQL)

Основные понятия

Включение и настройка FILESTREAM


Конфигурация компонента Database Engine — пользовательский экземпляр

[image]

Конфигурация компонента Database Engine — пользовательский экземпляр
Отправить отзыв

Страница Пользовательский экземпляр используется для создания отдельного экземпляра компонента Database Engine для пользователей, не имеющих разрешений администратора, и для добавления пользователей к роли администратора.

Параметр

Разрешить пользовательские экземпляры

По умолчанию включен. Для отключения возможности использования пользовательских экземпляров следует снять флажок.

Пользовательский экземпляр, который называют также дочерним или клиентским экземпляром, является экземпляром SQL Server, который создается родительским экземпляром (основным экземпляром, работающим как служба, например SQLExpress) от лица пользователя. Пользовательский экземпляр запускается как пользовательский процесс в контексте безопасности этого пользователя. Пользовательский экземпляр изолирован от родительского и любых других пользовательских экземпляров, выполняющихся на компьютере. О функции пользовательского экземпляра часто говорят также как о «запуске от лица обычного пользователя» (Run As Normal User, RANU).

Примечание Примечание

Логины, подготавливаемые в ходе установки в качестве членов предопределенной роли сервера sysadmin, подготавливаются в качестве администраторов в базе данных образцов. Они являются членами предопределенной роли сервера sysadmin на пользовательском экземпляре, если не удалены

Добавление пользователя к роли администратора SQL Server

По умолчанию снят. Чтобы добавить текущего пользователя, выполняющего установку, к роли администратора SQL Server, установите этот флажок.

Пользователи Windows Vista, которые являются членами группы BUILTIN\Администраторы, не добавляются автоматически к предопределенной роли сервера sysadmin при соединении с SQL Server Express. SQL Server Express могут администрировать только пользователи Windows Vista, явно добавленные к роли уровня администратора. С экземпляром SQL Server Express может соединяться любой член группы «Built-In\Пользователи», но у него будут ограниченные разрешения для выполнения задач в базе данных. По этой причине пользователям, чьи права доступа на SQL Server Express наследуются от групп «BUILTIN\Администраторы» и «Built-In\Пользователи» из предыдущих версий Windows, должны быть явно предоставлены права доступа администратора на экземплярах SQL Server Express под управлением Windows Vista.

Для изменения ролей пользователя после завершения программы установки используется средство настройки контактной зоны SQL Server 2005 (SQLSAC.exe). Чтобы обновить список пользователей роли «Системный администратор» SQL Server, щелкните ссылку Добавление нового администратора.

Убедитесь, что в списке Выделение ресурсов пользователю приводится имя пользователя в формате «Имя_домена\Имя пользователя», разрешения которого нужно обновить. Выберите роль, которую нужно обновить, из списка экземпляров SQL Server в панели Имеющиеся права доступа и щелкните стрелку справа. Чтобы добавить пользователя к имеющимся ролям для всех доступных экземпляров SQL Server и всем доступным ролям, щелкните двойную стрелку справа.

Для применения изменений после завершения работы нажмите кнопку ОК. Чтобы закрыть средство без применения изменений, нажмите кнопку Отмена.


Требования к свободному месту на диске

[image]

Требования к свободному месту на диске
См. также Отправить отзыв

На странице «Сведение о месте на диске» приводится информация о необходимом дисковом пространстве для компонентов SQL Server, выбранных для установки.

Параметры

Если требуемое место на диске слишком велико, можно:

  • изменить каталоги установки на диск, где больше свободного места;

  • изменить компоненты SQL Server для установки;

  • освободить больше места на выбранном диске, переместив другие файлы или приложения.

См. также

Другие ресурсы

Требования к оборудованию и программному обеспечению для установки SQL Server 2008 R2


Конфигурация контроллера распределенного воспроизведения

[image]

Конфигурация контроллера распределенного воспроизведения
Отправить отзыв

Страница Конфигурация контроллера распределенного воспроизведения мастера установки SQL Server позволяет указать пользователей, которым нужно предоставить административные разрешения на службу контроллера распределенного воспроизведения.

Пользователи, имеющие административные разрешения, будут иметь неограниченный доступ к службе контроллера распределенного воспроизведения.

Параметры

Добавить текущего пользователя

Нажмите эту кнопку, чтобы добавить пользователей, которым требуется предоставить разрешения на доступ к службе контроллера распределенного воспроизведения.

Добавить

Нажмите эту кнопку, чтобы добавить разрешения на доступ к службе контроллера распределенного воспроизведения.

Удалить

Нажмите эту кнопку, чтобы удалить разрешения на доступ к службе контроллера распределенного воспроизведения.


Конфигурация клиента распределенного воспроизведения

[image]

Конфигурация клиента распределенного воспроизведения
Отправить отзыв

Страница Конфигурация клиента распределенного воспроизведения мастера установки SQL Server позволяет указать пользователей, которым нужно предоставить административные разрешения на службу клиента распределенного воспроизведения.

Пользователи с административными разрешениями будут иметь неограниченный доступ к службе клиента распределенного воспроизведения.

Параметры

Имя контроллера

Это необязательный параметр со значением по умолчанию <blank>.

Введите имя контроллера, с которым будет связываться клиентский компьютер для доступа к службе клиента распределенного воспроизведения. Обратите внимание на следующие моменты.

  • Должно быть указано полное доменное имя (FQDN). Например, FQDN узла с именем server1 в иерархии продуктов Майкрософт может иметь вид server1.products.microsoft.com.

  • Если контроллер уже настроен, введите имя этого контроллера при настройке каждого клиента.

  • Если контроллер еще не настроен, имя контроллера можно оставить пустым. Однако необходимо вручную ввести имя контроллера в файл конфигурации клиента.

Рабочая папка

Укажите рабочий каталог для службы клиента распределенного воспроизведения.

Рабочим каталогом по умолчанию является <drive letter>:\Program Files\Microsoft SQL Server\DReplayClient\WorkingDir\.

Папка результатов

Укажите каталог результатов для службы клиента распределенного воспроизведения.

Каталогом результатов по умолчанию является <drive letter>:\Program Files\Microsoft SQL Server\DReplayClient\WorkingDir\.


Правила обновления выпуска

[image]

Правила обновления выпуска
См. также Отправить отзыв

Программа установки SQL Server проверяет конфигурацию компьютера перед началом установки. Во время установки SQL Server средство проверки конфигурации системы (SCC) просматривает компьютер, на котором устанавливается SQL Server. Средство SCC проверяет наличие условий, препятствующих успешной установке SQL Server. Прежде чем программа установки запустит обновление выпуска, SCC получает сведения о состоянии каждого элемента. Затем оно сравнивает результаты с требуемыми условиями и предоставляет рекомендации по устранению критических препятствий.

При проверке конфигурации системы создается отчет, содержащий краткое описание всех выполненных правил и состояния выполнения. Отчет о проверке конфигурации системы находится в папке %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Прежде чем начинать установку, ознакомьтесь со следующими разделами:

  1. Требования к оборудованию и программному обеспечению для установки SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Возможности, поддерживаемые различными выпусками SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Вопросы безопасности при установке SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Версии SQL Server на местных языках(http://go.microsoft.com/fwlink/?LinkId=235027)

Другие ссылки:

  1. Поддерживаемые обновления версий и выпусков(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Подготовка к установке отказоустойчивой кластеризации(http://go.microsoft.com/fwlink/?LinkId=235034)

См. также

Справочник

Правила поддержки программы установки


Отчет об ошибках

[image]

Отчет об ошибках
Отправить отзыв

Страница Параметры отчетов об ошибках и использовании мастера установки SQL Server позволяет включить для SQL Server функции отправки отчетов об ошибках и использовании.

Параметры

По умолчанию функции сбора данных об использовании компонентов и отчета об ошибках отключены для SQL Server и его компонентов в Microsoft SQL Server 2012.

Отчет об ошибках

Если включить функцию отчетов об ошибках, SQL Server будет настроен для автоматической отправки отчета в корпорацию Майкрософт в случае неустранимой ошибки в любом из следующих компонентов SQL Server.

  • Компонент Database Engine

  • Агент SQL Server

  • Службы Analysis Services

  • Службы Reporting Services

  • Integration Services

  • Репликация

Корпорация Майкрософт использует отчеты об ошибках, чтобы улучшить функциональность SQL Server, и любые поступающие данные расценивает как конфиденциальные.

Сведения об ошибках отправляются в корпорацию Майкрософт по защищенному (https) соединению и хранятся там с ограничением доступа. Вместо этого отчеты об ошибках можно отправлять на собственный корпоративный сервер отчетов об ошибках.

Отчеты об ошибках содержат следующие сведения:

  • состояние SQL Server при возникновении проблемы;

  • версия операционной системы и сведения об оборудовании компьютера;

  • код продукта, который не используется для идентификации лицензии;

  • сетевой IP-адрес компьютера или прокси-сервера;

  • данные из памяти или файлов процесса, вызвавшего ошибку.

Корпорация Майкрософт не собирает преднамеренно файлы, имя, адрес, адрес электронной почты или персональные данные в любой другой форме. Однако в отчет об ошибке из памяти или файлов процесса, вызвавшего ошибку, могут попасть персональные данные. Хотя потенциально эти сведения можно использовать, чтобы идентифицировать пользователя, корпорация Майкрософт не использует их с этой целью.

Дополнительные сведения о правилах сбора данных и обращения с личными сведениями в SQL Server см. в разделе Заявление о конфиденциальности Microsoft SQL Server.

Если при возникновении неустранимой ошибки отчеты об ошибках включены, в журнале событий Windows могут появиться записи Майкрософт, в которых содержатся ссылки на соответствующие статьи базу знаний Майкрософт.

Чтобы отключить отчеты об ошибках или использовании возможностей для всех экземпляров SQL Server и его компонентов после завершения установки, перейдите в диалоговое окно Настройки параметров отчета об ошибках и использовании и снимите флажки для пункта Использование возможностей. Если функция Отчет об ошибках включена для нескольких компонентов SQL Server (компонент Компонент SQL Server Database Engine, службы Службы Analysis Services, Службы Reporting Services и общие компоненты), ее можно отключить для каждого экземпляра каждого из компонентов (включая общие компоненты, которые перечислены в разделе Другие).


Отчет отказоустойчивого кластера

[image]

Отчет отказоустойчивого кластера
Отправить отзыв

Страница отчета отказоустойчивого кластера используется для просмотра отчета о результатах работы программы установки для этой операции.

Параметры

Чтобы просмотреть подробный отчет о сканировании, щелкните ссылку на отчет.


Обзор компонента

[image]

Обзор компонента
См. также Отправить отзыв

Страница «Обзор компонента» содержит список (доступный только для чтения) компонентов, которые подготовлены для настройки и будут готовы к работе по окончании шага завершения создания образа. Список компонентов выбирается на шаге подготовки изображений и не подлежит изменению на шаге завершения создания образа. Помимо отображенных компонентов, подготовленный экземпляр также включает браузер SQL Server, модуль записи SQL Server и собственный клиент SQL Server.

По окончании настройки подготовленного экземпляра SQL Server можно добавить другие компоненты, не включенные в подготовленный экземпляр SQL Server.

Группа компонентов

Компоненты и функции

Компонент Database Engine

Компонент Компонент SQL Server Database Engine включает в себя следующие компоненты.

  • Компонент Database Engine — основная служба для хранения, обработки и защиты данных.

    • Репликация. (Дополнительно.) Репликация представляет собой набор технологий копирования и распространения данных и объектов баз данных между базами данных, а также синхронизации баз данных для поддержания согласованности.

    • Полнотекстовый поиск. (Дополнительно.) Компонент «Полнотекстовый поиск» позволяет выполнять полнотекстовые запросы в таблицах SQL Server для произвольных символьных данных.

    • Службы Data Quality Services (необязательно): Службы Data Quality Services (DQS) — это решение для очистки данных, позволяющее выявлять несогласованные и неверные данные в источнике данных и предоставляющее средства для очистки данных в автоматическом и интерактивном режиме.

Службы Reporting Services

Службы Службы Reporting Services включают в себя серверные и клиентские компоненты для создания, управления и развертывания табличных, матричных и графических отчетов, а также отчетов в свободной форме. Службы Службы Reporting Services являются расширяемой платформой, которую можно использовать для разработки приложений отчетов.

См. также

Другие ресурсы

Как Установить SQL Server с помощью SysPrep


Правила установки

[image]

Правила установки
См. также Отправить отзыв

Программа установки SQL Server проверяет конфигурацию компьютера перед началом установки. Во время установки SQL Server средство проверки конфигурации системы (SCC) просматривает компьютер, на котором устанавливается SQL Server. Средство SCC проверяет наличие условий, препятствующих успешной установке SQL Server. Прежде чем программа установки запустит мастер установки SQL Server, SCC получает сведения о состоянии каждого элемента. Затем оно сравнивает результаты с требуемыми условиями и предоставляет рекомендации по устранению критических препятствий.

При проверке конфигурации системы создается отчет, содержащий краткое описание всех выполненных правил и состояния выполнения. Отчет о проверке конфигурации системы находится в папке %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Прежде чем начинать установку, ознакомьтесь со следующими разделами:

  1. Требования к оборудованию и программному обеспечению для установки SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Возможности, поддерживаемые различными выпусками SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Вопросы безопасности при установке SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Версии SQL Server на местных языках(http://go.microsoft.com/fwlink/?LinkId=235027)

Другие ссылки:

  1. Поддерживаемые обновления версий и выпусков(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Подготовка к установке отказоустойчивой кластеризации(http://go.microsoft.com/fwlink/?LinkId=235034)

См. также

Справочник

Правила поддержки программы установки


правила компонентов

[image]

правила компонентов
Отправить отзыв

Программа установки SQL Server проверяет конфигурацию компьютера перед началом установки. Во время установки SQL Server средство проверки конфигурации системы (SCC) просматривает компьютер, на котором устанавливается SQL Server. Средство SCC проверяет наличие условий, препятствующих успешной установке SQL Server. Перед запуском программы установки SCC получает сведения о состоянии каждого элемента. Затем оно сравнивает результаты с требуемыми условиями и предоставляет рекомендации по устранению критических препятствий.

При проверке конфигурации системы создается отчет, содержащий краткое описание всех выполненных правил и состояния выполнения. Отчет о проверке конфигурации системы находится в папке %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Прежде чем начинать установку, ознакомьтесь со следующими разделами:

  1. Требования к оборудованию и программному обеспечению для установки SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Возможности, поддерживаемые различными выпусками SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Вопросы безопасности при установке SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Версии SQL Server на местных языках(http://go.microsoft.com/fwlink/?LinkId=235027)

Другие ссылки:

  1. Поддерживаемые обновления версий и выпусков(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Подготовка к установке отказоустойчивой кластеризации(http://go.microsoft.com/fwlink/?LinkId=235034)


Выбор компонентов

[image]

Выбор компонентов
См. также Отправить отзыв

С помощью флажков на странице Выбор компонентов мастера установки SQL Server выберите компоненты для текущей установки SQL Server.

Установка компонентов SQL Server

На странице Выбор компонентов компоненты SQL Server разделены на два основных раздела. Компоненты экземпляра и Общие компоненты.

Раздел Компоненты экземпляра содержит список компонентов, которые устанавливаются отдельно для каждого экземпляра. Каждый экземпляр может иметь отдельную версию, имеющую свой уровень обновления. При установке обновления, вне зависимости от того, является ли оно пакетом обслуживания, исправлением или накопительным обновлением, выполняется обновление только одного экземпляра, размещенного на конкретном компьютере, а также общих компонентов, если они еще не обновлены.

Термин Общие компоненты относится к компонентам, которые являются общими для всех экземпляров на данном компьютере. Каждый из этих общих компонентов создается с учетом требований обратной совместимости с поддерживаемыми версиями SQL Server (пакеты обновления, накопительные обновления, пакеты обслуживания и исправления), которые можно установить параллельно.

Примечание Примечание

SQL Server SysPrep. Компонент Database Engine и службы Службы Reporting Services являются единственными компонентами Microsoft SQL Server 2012, поддерживающими SQL Server SysPrep. Функции и компоненты можно выбрать на шаге подготовки образа. Нельзя сделать выбор во время создания подготовленного образа SQL Server. Дополнительные сведения см. в разделе Как установить SQL Server 2012 с помощью SysPrep (http://go.microsoft.com/fwlink/?LinkId = 190965).

Отказоустойчивые кластеры SQL Server. Компонент Database Engine и службы Службы Analysis Services являются единственными компонентами Microsoft SQL Server 2012, поддерживающими создание отказоустойчивой кластеризации. На узел отказоустойчивого кластера можно установить другие компоненты, такие как службы Службы Reporting Services или Integration Services, но они не предназначены для работы в кластере, и их службы не переходят на резервный ресурс, если узел отказоустойчивого кластера переходит в автономный режим. Дополнительные сведения см. в статье Приступая к работе с отказоустойчивой кластеризацией SQL Server (http://go.microsoft.com/fwlink/?LinkId=190953).

Компоненты экземпляра

Описание каждой группы компонентов отображается в панели Описание при выборе соответствующей группы. Можно установить любое сочетание компонентов (устанавливаемые компоненты отмечаются флажками). Чтобы продолжить установку, выберите компоненты.

Компоненты

Описание

Службы Database Engine

В состав Компонент SQL Server Database Engine входит компонент Database Engine, основная служба для хранения, обработки и обеспечения безопасности данных, репликации, полнотекстового поиска, средств управления реляционными и XML-данными и сервера служб Data Quality Services (DQS).

  • Компонент Database Engine — основная служба для хранения, обработки и защиты данных.

  • Репликация: Необязательно. Репликация представляет собой набор технологий копирования и распространения данных и объектов баз данных между базами данных, а также синхронизации баз данных для поддержания согласованности.

  • Полнотекстовый поиск. Необязательно. Компонент Full-Text Search позволяет выполнять полнотекстовые запросы в таблицах SQL Server для произвольных символьных данных.

  • Службы Data Quality Services. Необязательно. Службы Data Quality Services (DQS) — это решение очистки данных, которое дает возможность обнаруживать несогласованные и неверные данные в источнике данных, предоставляют компьютерные и интерактивные методы очистки данных. Выберите этот флажок, чтобы установить сервер DQS. После завершения установки SQL Server необходимо запустить файл DQSInstaller.exe, чтобы завершить установку сервера DQS. Если установлен экземпляр SQL Server по умолчанию, то этот файл находится в папке C:\Program Files\Microsoft SQL Server\MSSQL11.MSSQLSERVER\MSSQL\Binn.

Отказоустойчивые кластеры SQL Server. Компоненты «Репликация» и «Full-text Search» являются необходимыми и автоматически выбираются программой установки для систем отказоустойчивой кластеризации SQL Server при выборе служб компонента Database Engine.

Службы Analysis Services

Службы Службы Analysis Services содержат средства создания приложений оперативной аналитической обработки (OLAP) и приложений интеллектуального анализа данных, а также средства управления ими.

Службы Службы Reporting Services в собственном режиме

Собственный режим служб Службы Reporting Services использует серверные и клиентские компоненты для создания и развертывания табличных, матричных и графических отчетов и отчетов в свободной форме, а также управления ими. Службы Службы Reporting Services являются расширяемой платформой, которую можно использовать для разработки приложений отчетов.

Важное примечание Важно!

  1. Программа установки не настраивает балансировку нагрузки и адресацию по одному URL-адресу для нескольких узлов при масштабном развертывании служб Службы Reporting Services. Для завершения масштабного развертывания необходимы Windows Server, Microsoft Application Center или программное обеспечение сторонних разработчиков для управления кластером. Дополнительные сведения о параметрах развертывания веб-фермы см. в разделе Настройка служб Reporting Services для масштабного развертывания (http://go.microsoft.com/fwlink/?LinkId=199448).

  2. Microsoft Internet Explorer 7.0 с пакетом обновления 1 (SP1) необходим для конструктора отчетов (компонента служб Службы Reporting Services).

  3. Службы Службы Reporting Services не поддерживаются в параллельных конфигурациях на 64-разрядной платформе и 32-разрядной подсистеме (WOW64) 64-разрядного сервера.

Общие функции

Компоненты, совместно используемые всеми экземплярами SQL Server на одном компьютере, устанавливаются в один и тот же каталог. В их число входят следующие компоненты.

Компонент

Описание

Службы Службы Reporting Services в режиме интеграции с SharePoint

Режим SharePoint для служб Службы Reporting Services — это серверное приложение, предназначенное для создания и доставки отчетов на адрес электронной почты, во многие форматы файлов и для интерактивных веб-структур, а также управления ими. В режиме SharePoint функции просмотра отчетов и управления ими интегрированы в продукты SharePoint.

Надстройка служб Службы Reporting Services для продуктов SharePoint

Надстройка служб Службы Reporting Services для продуктов SharePoint содержит компоненты пользовательского интерфейса и средства управления, позволяющие интегрировать продукт SharePoint с сервером отчетов служб Службы Reporting Services, работающим в режиме интеграции с SharePoint.

Клиент Data Quality

Data Quality Client — это отдельное приложение, которое подключается к серверу DQS и обеспечивает интуитивный графический пользовательский интерфейс для очистки данных, выполнения операций подбора данных и административных задач в DQS.

SQL Server Data Tools1

Службы SQL Server Data Tools содержат интегрированную среду разработки, предназначенную для создания решений для следующих компонентов бизнес-аналитики. Службы Analysis Services, Службы Reporting Services и Integration Services.

(Ранее — среда Business Intelligence Development Studio.)

SSDT также содержит компонент «проекты баз данных», который предоставляет интегрированную среду для разработчиков, предназначенную для выполнения всех работ по разработке баз данных для любой платформы SQL Server (как в основном помещении, так и вне его) в пределах Visual Studio. Разработчикам баз данных предлагается расширенный обозреватель серверов, который является компонентом Visual Studio, предназначенным для облегчения процессов создания и изменения объектов баз данных и данных в них, а также для выполнения запросов.

Средства связи клиентских средств

В клиентские средства входят компоненты, предназначенные для обеспечения взаимодействия между клиентами и серверами, в том числе сетевые библиотеки для DB-Library, OLEDB для OLAP, ODBC, ADODB и ADOMD+.

Integration Services

Службы Integration Services представляют собой набор графических средств и программируемых объектов для перемещения, копирования и преобразования данных.

Обратная совместимость клиентских средств

Обратная совместимость клиентских средств обеспечивается следующими компонентами.

  • Объекты SQL-DMO. Дополнительные сведения см. в разделе Функции SQL Server, поддержка которых прекращена в SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=190968).

  • Объекты DSO. Дополнительные сведения см. в разделе Критические изменения функций служб Analysis Services в SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=190970).

Пакет SDK клиентских средств

Содержит пакет средств разработки программного обеспечения, содержащий ресурсы для программистов.

Компоненты документации

Компоненты документации содержат компоненты для просмотра и управления содержимым справки.

Основные средства управления

Средства управления — базовые К этим средствам относятся следующие:

  • Поддержка среды Среда SQL Server Management Studio для Компонент SQL Server Database Engine, программы SQL Server Express, sqlcmd и поставщик SQL Server PowerShell

Средства управления — полный набор: Помимо компонентов базовой версии, сюда также входят:

  • Поддержка среды Среда SQL Server Management Studio для служб Службы Reporting Services, Службы Analysis Services и Integration Services

  • Приложение SQL Server Profiler

  • Помощник по настройке ядра СУБД

  • Управление программой SQL Server

Контроллер распределенного воспроизведения

Контроллер распределенного воспроизведения управляет согласованными действиями клиентов распределенного воспроизведения. В каждой среде распределенного воспроизведения можно установить только один экземпляр контроллера. Дополнительные сведения см. в разделе Распределенное воспроизведение SQL Server (http://go.microsoft.com/fwlink/?LinkId=229847).

Клиент распределенного воспроизведения

Клиенты распределенного воспроизведения работают совместно для имитации рабочей нагрузки на экземпляре SQL Server. В каждой среде распределенного воспроизведения можно установить один или несколько клиентов. Дополнительные сведения см. в разделе Распределенное воспроизведение SQL Server (http://go.microsoft.com/fwlink/?LinkId=229847).

Пакет средств разработки программного обеспечения для подключения клиентов SQL

Содержит пакет средств разработки программного обеспечения для подключения собственных клиентов Native Client SQL Server (ODBC/OLE DB) для разработки приложений для баз данных.

Master Data Services

Службы Master Data Services — это платформа для интеграции данных из различных систем на предприятии в единый источник основных данных для повышения точности и удобной организации аудита. При выборе параметра Master Data Services устанавливается Диспетчер конфигурации служб Master Data Services, сборки, оснастка Windows PowerShell, папки и файлы для веб-приложений и служб.

LocalDB

LocalDB — это режим выполнения SQL Server Express, предназначенный для разработчиков программ. Вся необходимая инфраструктура SQL Server, инициируемая строкой подключения, создается и запускается автоматически, что позволяет приложению работать с базой данных без выполнения задач по настройке и управлению.

1Для установки среды SQL Server Data Tools (SSDT) требуется Internet Explorer 6.0 с пакетом обновления 1 (SP1).

По умолчанию общие компоненты устанавливаются в каталог «%Program Files%Microsoft SQL Server\». Чтобы изменить путь установки, нажмите кнопку Обзор. Изменение пути установки для одного общего компонента приводит к его изменению для всех остальных общих компонентов. При последующей установке общие компоненты устанавливаются в каталог, заданный при начальной установке.

В операционных системах для компьютеров с процессорами x64 места установки 64-разрядных компонентов и 32-разрядных компонентов подсистемы WOW64 можно выбрать раздельно.

Установка образцов баз данных AdventureWorks

По умолчанию при установке SQL Server образцы баз данных и образцы кода не устанавливаются. Дополнительные сведения об установке образцов баз данных и образцов кода см. в разделе Проекты и образцы сообщества Microsoft SQL Server (http://go.microsoft.com/fwlink/?LinkId=87843).

Дополнительные сведения об образцах доступны после завершения установки Microsoft SQL Server 2012. В меню Пуск укажите Все программы, Microsoft SQL Server 2012, Документация и учебники, а затем выберите пункт Образцы Microsoft SQL Server.

См. также

Другие ресурсы

Выпуски и компоненты SQL Server 2012


Выбор компонентов (удаление)

[image]

Выбор компонентов (удаление)
Отправить отзыв

Указать компоненты, которые нужно удалить из указанного экземпляра SQL Server, можно на странице «Выбор компонентов — удаление».

Параметры

Можно установить любое сочетание компонентов.


Обновляемые компоненты

[image]

Обновляемые компоненты
См. также Отправить отзыв

На странице Обновляемые компоненты мастера установки Microsoft SQL Server 2012 можно просмотреть компоненты, которые должны быть обновлены до Microsoft SQL Server 2012.

Параметры

  • В данном выпуске невозможно изменить компоненты для обновления. Чтобы добавить функции в этот экземпляр SQL Server, выполните обновление, перезапустите программу установки и нажмите кнопку Новая установка и добавление компонентов к существующей установке в центре установки.

См. также

Другие ресурсы

Обновления версий и выпусков
Использование помощника по обновлению для подготовки к обновлениям
Работа с несколькими версиями SQL Server


Режимы обновления полнотекстового поиска

[image]

Режимы обновления полнотекстового поиска
Отправить отзыв

Используйте страницу «Режимы обновления полнотекстового поиска» мастера установки SQL Server для выбора параметра обновления полнотекстового поиска, который будет использоваться в базах данных, которые обновляются в данный момент.

В SQL Server 2005 и более ранних версиях все полнотекстовые индексы располагались в полнотекстовых каталогах, принадлежащих файловой группе, имели физический путь и обрабатывались как файлы базы данных. Начиная с выпуска SQL Server 2008, полнотекстовый каталог становится логическим понятием (виртуальным объектом), под которой подразумевается группа полнотекстовых индексов. В связи с этим новые полнотекстовые каталоги не обрабатываются как файлы базы данных с физическим путем. Однако при обновлении любого полнотекстового каталога, содержащего файлы данных, новая файловая группа создается на том же диске. Это обеспечивает соблюдение старого поведения дискового ввода-вывода после обновления. Если существует корневой путь, то любой полнотекстовый индекс размещается в новой файловой группе. Если старый путь полнотекстового каталога недействителен, то обновление будет хранить полнотекстовый индекс в той же файловой группе, в которой хранится базовая таблица, либо в случае с секционированной таблицей — в первичной файловой группе.

Параметры

При обновлении с SQL Server 2005 или SQL Server 2008 до Microsoft SQL Server 2012 следует выбрать один из следующих вариантов полнотекстового обновления.

Импортировать

Полнотекстовые каталоги импортируются. Обычно импорт производится значительно быстрее перестроения. Например, если используется только один ЦП, то импорт выполняется в 10 раз быстрее, чем перестроение. Однако в полнотекстовых каталогах, импортированных из SQL Server 2005, не используются новые и улучшенные средства разбиения по словам, добавленные в SQL Server 2008, поэтому со временем рекомендуется произвести перестроение полнотекстовых каталогов.

Примечание Примечание

Перестроение может выполняться в многопоточном режиме; если доступно более 10 процессоров, то перестроение может выполниться быстрее импорта, если будет разрешено использовать все процессоры.

Если полнотекстовый каталог недоступен, связанные полнотекстовые индексы перестраиваются. Этот параметр доступен только для баз данных SQL Server 2005.

Дополнительные сведения о влиянии импорта полнотекстового индекса см. в подразделе «Замечания по выбору режима полнотекстового обновления» далее в этом разделе.

Перестроение

При перестроении полнотекстовых каталогов используются новые и улучшенные средства разбиения по словам, добавленные в SQL Server 2008. Перестроение индексов может занять длительное время, а после обновления может потребоваться значительный объем ресурсов ЦП и памяти.

Сброс

Полнотекстовые каталоги сбрасываются. При обновлении с SQL Server 2005 файлы полнотекстового каталога удаляются, но метаданные для полнотекстовых каталогов и полнотекстовых индексов сохраняются. После обновления для всех полнотекстовых индексов отключается отслеживание изменений и сканирование не запускается автоматически. После завершения обновления каталог останется пустым, пока не будет вручную запущено полное заполнение.

Все эти варианты обновления обеспечивают максимальное использование улучшенных полнотекстовых возможностей SQL Server 2008 и более поздних версий в обновленных базах данных.

Важное примечание Важно!

Дополнительные сведения об использовании новых средств разбиения по словам и о преобразовании пропускаемых слов в списки стоп-слов после импорта полнотекстового индекса SQL Server 2005 см. в разделе «Обновление полнотекстового поиска» в справке по установке Microsoft SQL Server 2012.

Замечания по выбору режима полнотекстового обновления

При выборе режима обновления следует учитывать следующие соображения.

  • Как используются средства разбиения по словам?

    В службу полнотекстового поиска Microsoft SQL Server 2012 входят средства разбиения по словам и парадигматические модули, появившиеся в SQL Server 2008. Они могут повлиять на результаты полнотекстовых запросов SQL Server 2005 для определенного текстового шаблона или сценария. Следовательно, при выборе подходящего режима обновления важно учитывать то, как будут использоваться средства разбиения по словам.

    • Если средства разбиения по словам в используемом языке полнотекстового поиска не были изменены в SQL Server 2008 и более поздних версиях или если точность восстановления не играет большой роли, то импорт будет подходящим вариантом. Если позднее возникнут проблемы при восстановлении, то можно будет выполнить обновление для использования новых средств разбиения по словам, выполнив перестроение полнотекстовых каталогов. Дополнительные сведения см. в разделе «Обновление компонента Full-Text Search» в справке по установке Microsoft SQL Server 2012.

    • Если точность восстановления имеет значение, а пользователь использует средства разбиения по словам, которые были улучшены в SQL Server 2008, то целесообразно будет выполнить перестроение.

  • Были ли полнотекстовые индексы построены в целочисленных полнотекстовых ключевых столбцах?

    Перестроение выполняет внутренние оптимизации, которые в некоторых случаях могут увеличить производительность запросов обновленных полнотекстовых индексов. В частности, если в полнотекстовых каталогах пользователя содержатся полнотекстовые индексы, у которых полнотекстовый ключевой столбец базовой таблицы имеет тип данных integer, то при перестроении достигается идеальная производительность полнотекстовых запросов. В данном случае рекомендуется использовать параметр Перестроение.

    Примечание Примечание

    Применительно к полнотекстовым индексам в Microsoft SQL Server 2012 рекомендуется, чтобы столбец, который служит полнотекстовым ключом, имел тип данных integer. Дополнительные сведения см. в разделе «Настройка и оптимизация производительности полнотекстового поиска» в электронной документации по Microsoft SQL Server 2012.

  • Насколько важно перевести сервер в режим «в сети»?

    Импорт или перестроение отнимает много ресурсов процессора, что задерживает обновление остальных частей экземпляра сервера и перевод его в режим «в сети». Если важно перевести экземпляр сервера в режим «в сети» как можно скорее, а пользователь способен выполнить после обновления заполнение вручную, то целесообразно будет использовать режим Сброс.


Завершение — установка

[image]

Завершение — установка
См. также Отправить отзыв

Чтобы завершить установку, нажмите кнопку Закрыть.

См. также

Основные понятия

Проверка установки SQL Server


Компоненты, необходимые для установки

[image]

Компоненты, необходимые для установки
Отправить отзыв

Для успешной установки SQL Server на компьютере, где она производится, необходимо наличие следующих компонентов программного обеспечения (они будут установлены программой установки SQL Server):

  • .NET Framework версии 4.0 для всех выпусков Microsoft SQL Server 2012

  • Файлы поддержки программы установки SQL Server

  • Native Client SQL Server

Примечание Примечание

В случае сбоя или отмены установки, эти компоненты не удаляются. Для их удаления используйте средство Установка и удаление программ на панели управления.

Параметры

Чтобы установить предварительные файлы, нажмите кнопку Установить. Чтобы выйти из программы установки, нажмите кнопку Отмена.


Ход выполнения установки

[image]

Ход выполнения установки
См. также Отправить отзыв

Страница Выполнение установки мастера установки SQL Server позволяет наблюдать за состоянием установки SQL Server.

См. также

Основные понятия

Просмотр и чтение файлов журналов программы установки SQL Server


Тип установки

[image]

Тип установки
Отправить отзыв

На странице «Тип установки» мастера установки SQL Server укажите, следует ли установить новый экземпляр SQL Server или добавить компоненты в существующий.

Параметры

Установите переключатель в требуемое положение:

  • установить новый экземпляр SQL Server.

  • добавить компоненты в существующий экземпляр SQL Server

    При выборе параметра добавления компонентов в существующий экземпляр, в раскрывающемся списке выберите экземпляр SQL Server для обновления.

К подготовленному образу SQL Server можно добавить функции, поддерживаемые SQL Server SysPrep (компоненты Database Engine и службы Службы Reporting Services). Другие функции, не поддерживаемые SysPrep, могут быть добавлены только после завершения подготовленного экземпляра.

Примечание. После установки экземпляра отказоустойчивого кластера добавить в него компоненты невозможно. Чтобы добавить компоненты SQL Server в существующий отказоустойчивый кластер, необходимо установить отдельный экземпляр SQL Server.


Конфигурация экземпляра

[image]

Конфигурация экземпляра
Отправить отзыв

На странице Конфигурация экземпляра мастера установки SQL Server можно выбрать создание экземпляра SQL Server по умолчанию или именованного экземпляра. Если экземпляр SQL Server еще не установлен и не указано создание именованного экземпляра, то будет создан экземпляр по умолчанию.

Каждый экземпляр SQL Server состоит из отдельного набора служб с заданными настройками параметров сортировки и прочих параметров. Структура каталогов и реестра, а также имена служб соответствуют имени экземпляра и конкретному идентификатору экземпляра, созданному в процессе установки SQL Server.

Экземпляр является либо экземпляром по умолчанию, либо именованным экземпляром. Имя экземпляра по умолчанию — MSSQLSERVER. Клиенту при установлении соединения имя экземпляра указывать необязательно. Именованный экземпляр определяется пользователем при установке. Именованный экземпляр SQL Server может быть установлен без предварительной установки экземпляра по умолчанию. В один момент времени экземпляром по умолчанию может быть только один экземпляр SQL Server (независимо от версии).

Примечание Примечание

При помощи SQL Server SysPrep можно указать имя экземпляра после завершения подготовки экземпляра на странице Конфигурация экземпляра. Можно настроить подготовленный экземпляр в качестве экземпляра по умолчанию, если на компьютере нет экземпляра SQL Server по умолчанию.

Несколько экземпляров

На одиночном сервере или одном процессоре поддерживается несколько экземпляров SQL Server, однако только один из них может быть экземпляром по умолчанию. Все остальные экземпляры должны быть именованными. На одном компьютере одновременно можно запустить несколько экземпляров SQL Server, и каждый экземпляр выполняется независимо от других.

Дополнительные сведения см. в разделе Спецификации максимально допустимых параметров для SQL Server.

Параметры

Только экземпляр отказоустойчивого кластера: укажите сетевое имя отказоустойчивого кластера SQL Server. Это имя идентифицирует экземпляр отказоустойчивого кластера в сети.

Экземпляр по умолчанию или именованный экземпляр: принимая решение о типе устанавливаемого экземпляра SQL Server, следует руководствоваться следующими соображениями.

  • Если планируется установить один экземпляр SQL Server на сервере базы данных, то это должен быть экземпляр по умолчанию.

  • Именованный экземпляр следует выбирать в тех случаях, когда на одном компьютере планируется запускать несколько экземпляров. На сервере может находиться только один экземпляр по умолчанию.

  • Любое приложение, которое производит установку выпуска SQL Server Express, должно устанавливать его как именованный экземпляр. Это позволить свести к минимуму конфликты при установке на одном компьютере нескольких приложений.

Экземпляр по умолчанию

При выборе этого параметра производится установка экземпляра SQL Server по умолчанию. На компьютере может размещаться только один экземпляр по умолчанию; остальные должны быть именованными. Однако если экземпляр SQL Server по умолчанию уже установлен, то на этот же компьютер может быть установлен экземпляр служб Службы Analysis Services по умолчанию.

Именованный экземпляр

При выборе этого параметра создается новый именованный экземпляр. При выборе имени экземпляра SQL Server следует учитывать следующие моменты.

  • В именах экземпляров регистр не учитывается.

  • Имена экземпляров не могут начинаться с символа подчеркивания (_).

  • Имя экземпляра не может содержать слово «Default» и другие зарезервированные ключевые слова. Если в имени экземпляра используется зарезервированное ключевое слово, возникнет ошибка установки. Дополнительные сведения см. в разделе Зарезервированные ключевые слова.

  • Если в качестве имени экземпляра указано значение «MSSQLServer», то будет создан экземпляр по умолчанию. Если в качестве имени экземпляра выпуска SQL Server Express указано значение «SQLExpress», то будет создан экземпляр по умолчанию.

  • Microsoft SQL Server 2012 PowerPivot для SharePoint всегда устанавливается как именованный экземпляр «PowerPivot». Нельзя указать другое имя экземпляра для этой роли компонента.

  • Длина имени экземпляра ограничена шестнадцатью символами.

  • Имя экземпляра должно начинаться с буквы. Оно может состоять из букв, определенных стандартом Юникод 2.0. В их число входят символы a-z, A-z и буквы из других языков.

  • Следующими за первым символом могут быть буквы, определенные Юникодом 2.0, десятичные числа из набора символов Basic Latin и других национальных шрифтов, знак доллара ($) и символ подчеркивания (_).

  • Нельзя включать в имена экземпляров символы пробелов и другие специальные символы. В число недопустимых символов входят символы обратной косой черты (\), запятой (,), двоеточия (:), точки с запятой (;), одиночной кавычки ('), амперсанда (&) и коммерческое «эт» (@).

    Примечание Примечание

    В именах экземпляров SQL Server могут применяться только те символы, которые являются допустимыми в текущей кодовой странице Windows. При использовании неподдерживаемого символа Юникода возникает ошибка установки.

Обнаруженные экземпляры и компоненты

Просмотр перечня установленных экземпляров и компонентов SQL Server.

Идентификатор экземпляра — по умолчанию в качестве идентификатора экземпляра используется его имя. Предназначен для идентификации каталогов установки и разделов реестра для данного экземпляра SQL Server. Действует как для экземпляров по умолчанию, так и для именованных экземпляров. Для экземпляра по умолчанию именем и идентификатором экземпляра является «MSSQLSERVER». Чтобы использовать идентификатор, отличный от значения по умолчанию, укажите его в поле Идентификатор экземпляра.

Важное примечание Важно!

Идентификатор экземпляра, отображаемый на данной странице, является идентификатором, указанным на шаге подготовки образа процесса SQL Server SysPrep. Нельзя указать другой идентификатор экземпляра в момент завершения подготовки образа.

Примечание Примечание

Идентификаторы экземпляров, начинающиеся с символа подчеркивания (_), содержащие символ решетки (#) или знак доллара ($), не поддерживаются.

Дополнительные сведения о каталогах, расположениях файлов и именовании идентификаторов экземпляров см. в разделе Расположение файлов для экземпляра по умолчанию и именованных экземпляров SQL Server.

Корневой каталог экземпляра — по умолчанию «C:\Program Files\Microsoft SQL Server\». Для указания корневого каталога, отличного от заданного по умолчанию, введите его путь или нажмите кнопку Обзор.

Все компоненты экземпляра SQL Server управляются как единое целое. Все обновления SQL Server (в том числе и пакеты обновления) применяются к каждому из компонентов экземпляра SQL Server.

Все компоненты SQL Server, разделяющие одно и то же имя экземпляра, должны соответствовать следующим критериям.

  • Одинаковая версия

  • Одинаковый выпуск

  • Одинаковые параметры языка

  • Одинаковое состояние кластеризации

    Примечание Примечание

    Служба Службы Reporting Services не имеет ограничений на кластеризацию.

  • Одинаковая операционная система


Выбор экземпляра (удаление)

[image]

Выбор экземпляра (удаление)
Отправить отзыв

В раскрывающемся списке на странице «Выбор экземпляра — удаление» укажите экземпляр SQL Server для удаления.

Параметры

Можно указать, что удаляться будет весь экземпляр SQL Server или только общие компоненты и средства управления.


Выбор экземпляра (обновление)

[image]

Выбор экземпляра (обновление)
Отправить отзыв

Используйте страницу «Выбор экземпляра (обновление)» для указания обновляемого экземпляра SQL Server.

Параметры

Все компоненты экземпляра должны быть обновлены одновременно. Добавить или удалить компоненты в процессе обновления нельзя.


Обновляемый экземпляр

[image]

Обновляемый экземпляр
См. также Отправить отзыв

На странице «Обновляемый экземпляр» мастера установки SQL Server можно указать экземпляр SQL Server 2005, SQL Server 2008 или SQL Server 2008 R2, требующий обновления до уровня Microsoft SQL Server 2012.

Параметры

С помощью переключателей можно указать, следует ли обновлять экземпляр SQL Server и его общие компоненты или ограничиться обновлением общих компонентов. В данную версию SQL Server включены следующие общие компоненты.

  • Integration Services

  • Браузер SQL Server

  • Служба поддержки Active Directory SQL Server

  • Модуль записи SQL

Дополнительные сведения о поддерживаемых сценариях обновления и известных проблемах обновления см. в разделе Обновление версии и выпуска.

См. также

Другие ресурсы

Использование помощника по обновлению для подготовки к обновлениям
Работа с несколькими версиями SQL Server


Завершение удаления

[image]

Завершение удаления
Отправить отзыв

Страница «Завершение удаления» используется для проверки успешного завершения операции.


Ход выполнения подготовки образа

[image]

Ход выполнения подготовки образа
См. также Отправить отзыв

Страница Ход выполнения подготовки образа мастера установки SQL Server позволяет следить за состоянием установки подготовки образа SQL Server. После завершения этого шага на данной странице будут перечислены состояния для каждого из компонентов SQL Server, подготовленных при выполнении этой операции.

См. также

Основные понятия

Просмотр и чтение файлов журналов программы установки SQL Server


Правила подготовки образа

[image]

Правила подготовки образа
Отправить отзыв

Программа установки SQL Server проверяет конфигурацию компьютера перед началом установки. Во время установки SQL Server средство проверки конфигурации системы (SCC) просматривает компьютер, на котором устанавливается SQL Server. Средство SCC проверяет наличие условий, препятствующих успешной установке SQL Server. Прежде чем программа установки запустит мастер, SCC получает сведения о состоянии каждого элемента. Затем оно сравнивает результаты с требуемыми условиями и предоставляет рекомендации по устранению критических препятствий.

При проверке конфигурации системы создается отчет, содержащий краткое описание всех выполненных правил и состояния выполнения. Отчет о проверке конфигурации системы находится в папке %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Прежде чем начинать установку, ознакомьтесь со следующими разделами:

  1. Требования к оборудованию и программному обеспечению для установки SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Возможности, поддерживаемые различными выпусками SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Вопросы безопасности при установке SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Версии SQL Server на местных языках(http://go.microsoft.com/fwlink/?LinkId=235027)

Другие ссылки:

  1. Поддерживаемые обновления версий и выпусков(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Подготовка к установке отказоустойчивой кластеризации(http://go.microsoft.com/fwlink/?LinkId=235034)


Тип подготовки образа

[image]

Тип подготовки образа
Отправить отзыв

На странице Тип подготовки образа мастера установки SQL Server укажите, следует ли установить новый экземпляр Microsoft SQL Server 2012 или добавить компоненты в существующий.

Параметры

Установите переключатель в требуемое положение:

  • Подготовить новый экземпляр Microsoft SQL Server 2012.

  • Добавить компоненты в существующий подготовленный экземпляр Microsoft SQL Server 2012

    Если выбрано добавление компонентов в существующий экземпляр, то в раскрывающемся списке выберите подготовленный экземпляр SQL Server.

    Примечание Примечание

    К подготовленному образу SQL Server можно добавить функции, поддерживаемые SQL Server SysPrep (компоненты Database Engine и Службы Reporting Services). Другие функции, не поддерживаемые SQL Server SysPrep, могут быть добавлены только после завершения подготовленного образа.


Ключ продукта

[image]

Ключ продукта
Отправить отзыв

На странице «Ключ продукта» можно проверить экземпляр SQL Server или указать бесплатный выпуск SQL Server для установки.

Параметры

Чтобы указать бесплатный выпуск SQL Server, выберите в переключателе установку бесплатной версии, а затем выберите из раскрывающегося списка выпуск для установки.

Чтобы проверить платный выпуск SQL Server, выберите в переключателе вариант «Ключ продукта» и введите ключ в появившееся поле.

Если устанавливается отказоустойчивый кластер, введите одинаковый ключ продукта на всех узлах отказоустойчивого кластера. Если ключ продукта относится к другому выпуску SQL Server, случится ошибка.


Выполнение (удаление)

[image]

Выполнение (удаление)
См. также Отправить отзыв

Страница «Выполнение (удаление)» используется для наблюдения за процессом установки.

См. также

Основные понятия

Просмотр и чтение файлов журналов программы установки SQL Server


Все готово к завершению образа

[image]

Все готово к завершению образа
Отправить отзыв

Страница Все готово к завершению образа содержит сводные данные о параметрах конфигурации, применяемых при настройке подготовленного экземпляра.

Параметры

На этой странице доступны следующие параметры.

  • Чтобы продолжить установку, нажмите кнопку Установить.

  • Чтобы изменить настройки установки, нажмите кнопку Назад.

  • Чтобы выйти из программы установки, нажмите кнопку Отмена.


Все готово для установки

[image]

Все готово для установки
См. также Отправить отзыв

На странице «Все готово для установки» приведен сводный список компонентов, которые будут установлены или изменены программой установки SQL Server.

Параметры

На этой странице доступны следующие параметры.

  • Чтобы продолжить установку, нажмите кнопку Установить.

  • Чтобы изменить настройки установки, нажмите кнопку Назад.

  • Чтобы выйти из программы установки, нажмите кнопку Отмена.

См. также

Основные понятия

Просмотр и чтение файлов журналов программы установки SQL Server


Все готово для подготовки образа

[image]

Все готово для подготовки образа
Отправить отзыв

На странице Все готово для подготовки образа приведен сводный список компонентов, которые будут подготовлены программой установки SQL Server.

Параметры

На этой странице доступны следующие параметры.

  • Чтобы продолжить установку, нажмите кнопку Установить.

  • Чтобы изменить настройки установки, нажмите кнопку Назад.

  • Чтобы выйти из программы установки, нажмите кнопку Отмена.


Все готово для восстановления

[image]

Все готово для восстановления
См. также Отправить отзыв

Страница «Все готово для восстановления» содержит сводные данные о процессе исправления, выполняемом программой установки SQL Server.

Параметры

На этой странице доступны следующие параметры.

  • Чтобы продолжить установку, нажмите кнопку Восстановить.

  • Чтобы изменить настройки установки, нажмите кнопку Назад.

  • Чтобы выйти из программы установки, нажмите кнопку Отмена.

См. также

Основные понятия

Просмотр и чтение файлов журналов программы установки SQL Server


Удаление узла отказоустойчивого кластера SQL Server

[image]

Удаление узла отказоустойчивого кластера SQL Server
Отправить отзыв

На странице «Удаление узла отказоустойчивого кластера» выбирается компьютер, который является узлом отказоустойчивого кластера Microsoft SQL Server 2012 и должен быть удален из кластера.


Ход выполнения восстановления

[image]

Ход выполнения восстановления
См. также Отправить отзыв

Страница Состояние исправления мастера установки SQL Server позволяет наблюдать за состоянием исправления SQL Server.

См. также

Основные понятия

Просмотр и чтение файлов журналов программы установки SQL Server


параметры конфигурации служб Reporting Services (SSRS)

[image]

параметры конфигурации служб Reporting Services (SSRS)
См. также Отправить отзыв

Для задания параметров, определяющих способ установки и настройки сервера отчетов, служит страница Настройка служб Reporting Services мастера установки Microsoft SQL Server. Доступность того или иного параметра установки зависит от того, какие параметры были выбраны на странице Выбор компонентов, а также от того, устанавливается ли одновременно с сервером отчетов также и локальный экземпляр компонента Компонент SQL Server Database Engine.

В некоторых случаях, если сертификат протокола SSL установлен на компьютер и привязан к строгому шаблону, программа установки создает URL-адреса служб Reporting Services с префиксом HTTPS. Дополнительные сведения о сопоставлении сертификатов с URL-адресами служб Reporting Services см. в разделе Настройка SSL-соединений в сервере отчетов (http://go.microsoft.com/fwlink/?LinkId=199089) электронной документации по SQL Server.

Последние сведения о службах Службы Reporting Services, а также об установке и настройке этого выпуска см. в разделе Дополнительные сведения об установке (http://go.microsoft.com/fwlink/?LinkId=207425).

Параметры

Службы Reporting Services в собственном режиме

Если программа установки не может выполнить настройку сервера отчетов по умолчанию из-за того, что не выполняется одно или несколько требований, то мастер установки позволяет выполнить минимальную установку, скопировав все необходимые файлы, однако после завершения установки нужно будет выполнить сервер отчетов в собственном режиме с помощью диспетчера конфигурации служб Reporting Services.

Примечание Примечание

Существующий файл базы данных сервера отчетов может вызвать ошибку, если выбран один из параметров установки по умолчанию. В этом случае программа установки пытается создать базу данных сервера отчетов с именем по умолчанию. Если база данных с таким именем уже существует, установка завершится ошибкой и придется производить откат установки. Во избежание этой проблемы можно переименовать существующую базу данных перед запуском программы установки либо выбрать параметр Установить только, что позволяет указать пользовательские параметры базы данных после завершения установки.

Установка и настройка.

Устанавливает экземпляр сервера отчетов в собственном режиме с использованием значений по умолчанию для базы данных сервера отчетов, учетной записи службы и резервирований URL-адресов. При выборе этого параметра после завершения установки экземпляр сервера отчетов готов к использованию. Программа установки создает базу данных сервера отчетов, использующую локальный экземпляр компонента Database Engine, и настраивает сервер отчетов для работы со значениями по умолчанию.

Этот параметр доступен, только если значения по умолчанию, использованные при установке сервера отчетов, допустимы для системы. Этот вариант мы рекомендуем разработчикам, которые хотят установить все компоненты локально, и пользователям, оценивающим программное обеспечение.

Чтобы просмотреть сведения об используемых программой установки настройках по умолчанию или выяснить, почему невозможно установить конфигурацию по умолчанию, нажмите кнопку Подробности. Дополнительные сведения о конфигурации по умолчанию для сервера отчетов в собственном режиме см. в разделе Конфигурация по умолчанию для установки в собственном режиме (службы Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199091).

Только установка

Устанавливает программные файлы сервера отчетов, создает учетную запись службы сервера отчетов и регистрирует поставщик данных инструментария управления Windows (WMI) сервера отчетов. Этот параметр установки называется «Только файлы». Выберите этот параметр, если использование конфигурации по умолчанию нежелательно. В случае невозможности установить конфигурацию по умолчанию или при установке отказоустойчивого кластера SQL Server, включающего службы Службы Reporting Services, это единственно доступный параметр. Дополнительные сведения об установке в режиме «только файлы» см. в разделе Установка в режиме «только файлы» (службы Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199093).

После завершения программы установки, прежде чем сервер отчетов можно будет использовать, следует создать базу данных сервера отчетов и настроить сервер отчетов. Чтобы настроить сервер отчетов и создать базу данных, воспользуйтесь диспетчером конфигурации служб Reporting Services. Дополнительные сведения см. в разделе Как Создание базы данных сервера отчетов (настройка служб Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199094) и Настройка подключения к базе данных сервера отчетов (http://go.microsoft.com/fwlink/?LinkId=199095).

Службы Reporting Services в режиме SharePoint

Только установка

Устанавливает программные файлы сервера отчетов и командлеты PowerShell. После завершения установки необходимо запустить службы Службы Reporting Services SharePoint и создать приложение служб Службы Reporting Services. Дополнительные сведения см. в разделах Общие сведения об установке и настройке служб Reporting Services в режиме интеграции с SharePoint (http://go.microsoft.com/fwlink/?LinkId=207543), Создание служебного приложения служб SQL Server Reporting Services (SSRS) (http://go.microsoft.com/fwlink/?LinkId=207544) и Общие сведения об интеграции служб Reporting Services с SharePoint (http://go.microsoft.com/fwlink/?LinkID=207244).

Установка надстройки служб Reporting Services для технологий SharePoint

Начиная с версии Microsoft SQL Server 2012, надстройку можно установить в составе установки SQL Server на странице выбора компонентов мастера установки SQL Server.

Однако можно установить надcтройку служб Службы Reporting Services для SharePoint 2010 одним из следующих способов.

  • Запустите средство подготовки продуктов SharePoint 2010 PreRequisiteInstaller.exe.

  • Установите с установочного носителя SQL Server. После завершения работы программы установки SQL Server запустите файл rsSharePoint.msi из папки «Setup», расположенной на установочном носителе SQL Server.

  • Загрузите и установите надстройку. Дополнительные сведения см. в разделе Где найти надстройку служб Reporting Services для продуктов SharePoint (http://go.microsoft.com/fwlink/?LinkID=208634).

См. также

Другие ресурсы

Как Запустить диспетчер конфигурации служб Reporting Services
Как создать базу данных сервера отчетов (настройка служб Reporting Services)
Соображения по установке служб Reporting Services
Конфигурация по умолчанию для установки в собственном режиме (службы Reporting Services)
Конфигурация по умолчанию для режима SharePoint (службы Reporting Services)
Установка SQL Server из командной строки


обновление служб Reporting Services в режиме SharePoint (службы SSRS)

[image]

обновление служб Reporting Services в режиме SharePoint (службы SSRS)
См. также Отправить отзыв

На странице Службы Reporting Services в режиме SharePoint подтвердите обновление всех общих компонентов. Службы Службы Reporting Services в режиме SharePoint являются общим компонентом SQL Server и будут обновлены вместе со всеми остальными общими компонентами SQL Server. Мастер установки SQL Server не поддерживает обновление одиночных общих компонентов. Все общие компоненты SQL Server обновляются одновременно.

Параметры

Кнопка Далее доступна только в том случае, если выбран флажок Продолжить обновление. Если этот флажок не выбран, то продолжить обновление нельзя.

Дополнительные сведения см. в разделе Обновление служб Reporting Services (http://go.microsoft.com/fwlink/?LinkId=199092).

См. также

Основные понятия

Просмотр и чтение файлов журналов программы установки SQL Server

Другие ресурсы

Установка SQL Server из командной строки


проверка подлинности служб Reporting Services в режиме SharePoint

[image]

проверка подлинности служб Reporting Services в режиме SharePoint
См. также Отправить отзыв

На странице Проверка подлинности служб Reporting Services в режиме SharePoint мастера установки Microsoft SQL Server указываются учетные данные учетной записи службы, используемые в текущей установке служб Службы Reporting Services. Эти учетные данные будут использованы для создания нового пула приложений SharePoint. Кроме того, будет создано новое приложение службы SharePoint для служб Службы Reporting Services. Имя приложения службы будет содержать имя предыдущего экземпляра Службы Reporting Services.

Параметры

  • Параметр Имя учетной записи пула приложений служб SSRS: доступен только для чтения. Его значение автоматически заполняется текущим значением из существующей установки служб Службы Reporting Services, обновление которой производится.

  • Параметр Пароль учетной записи пула приложений служб SSRS: будет недоступен, если учетная запись пула приложений не требует пароля. Например, «NT Authority\NetworkSerivce». Если учетная запись пула приложений не требует пароля, то обновление нельзя будет продолжить до тех пор, пока не будет правильно введен пароль.

Дополнительные сведения см. в разделе Обновление служб Reporting Services (http://go.microsoft.com/fwlink/?LinkId=199092).

См. также

Другие ресурсы

Обновление служб Reporting Services


Выбор подготовленного экземпляра

[image]

Выбор подготовленного экземпляра
Отправить отзыв

На странице Выбор подготовленного экземпляра можно указать подготовленный экземпляр для завершения.

Параметры

Поле Выберите идентификатор экземпляра содержит список подготовленных экземпляров. Выберите подготовленный экземпляр для завершения.

Выберите идентификатор экземпляра

Список включает все подготовленные экземпляры, которые могут быть завершены на компьютере, где выполняется установка SQL Server. Выберите подготовленный экземпляр для завершения.

Установленные экземпляры

Список включает установленные, подготовленные и завершенные экземпляры.


Настройка сервера — параметры сортировки

[image]

Настройка сервера — параметры сортировки
Отправить отзыв

На странице «Конфигурация сервера — Параметры сортировки» мастера установки SQL Server можно изменить параметры сортировки, используемые компонентом Database Engine и службами Службы Analysis Services. Это позволят согласовать параметры сортировки для различных установок SQL Server или на разных компьютерах.

Параметры

Настроить для SQL Server и служб Службы Analysis Services

SQL Server предоставляет две группы параметров сортировки: Параметры сортировки Windows и параметры сортировки SQL Server. Параметры сортировки для компонента Database Engine и служб Службы Analysis Services могут быть индивидуальными или одинаковыми.

По умолчанию для англоязычных локалей систем выбираются параметры сортировки SQL Server. В локализованных версиях SQL Server параметры сортировки по умолчанию определяются локалью системы Windows для компьютера. Дополнительные сведения см. в разделе Using SQL Collations.

Параметры по умолчанию следует изменять только в том случае, если настройки параметров сортировки для этого экземпляра SQL Server должны соответствовать настройкам параметров сортировки другого экземпляра SQL Server или если они должны соответствовать локали системы Windows другого компьютера.

Примечание Службы Службы Analysis Services используют только параметры сортировки Windows. Если планируется установить службы Службы Analysis Services, выберите параметры сортировки Windows во время установки служб SQL Server, чтобы обеспечить согласованность результатов между Компонент SQL Server Database Engine и Службы Analysis Services.

Дополнительные сведения см. в разделе Настройка параметров сортировки в программе установки.

Рекомендации

Дополнительные сведения о таблице языков системы Windows и соответствующих им параметрах сортировки по умолчанию, используемых программой установки SQL Server, см. в разделе Настройка параметров сортировки в программе установки.

По возможности используйте единые параметры сортировки для всей организации. В этом случае не нужно будет явно устанавливать параметры сортировки для каждой базы данных, столбца, выражения или идентификатора. При работе с объектами, имеющими разные параметры сортировки и кодовые страницы, создание запросов должно производиться с учетом правил очередности параметров сортировки. Дополнительные сведения см. в разделе электронной документации Очередность параметров сортировки (Transact-SQL).

При выборе параметров сортировки для SQL Server следует придерживаться следующих рекомендаций.

  • Выберите параметры сортировки BINARY2, если допустима двоичная сортировка, основанная на элементах кода.

  • Выберите параметры сортировки Windows для достижения согласованности при сравнении разных типов данных.

  • Используйте новые параметры сортировки уровня 100 для лучшей поддержки лингвистической сортировки. Дополнительные сведения см. в разделе Поддержка параметров сортировки и Юникода.

  • Если планируется перенос базы данных на обновленный экземпляр SQL Server, выберите параметры сортировки, которые соответствуют существующим параметрам сортировки базы данных.


Настройка сервера — учетные записи служб

[image]

Настройка сервера — учетные записи служб
См. также Отправить отзыв

На странице «Настройка сервера» мастера установки SQL Server можно задать учетные записи входа для служб SQL Server. Службы, которые можно настраивать на этой странице, зависят от того, какие компоненты были выбраны во время установки.

В качестве стартовых учетных записей, используемых для запуска и выполнения SQL Server, могут использоваться учетные записи пользователей домена, учетные записи локальных пользователей, управляемые учетные записи служб, виртуальные учетные записи или встроенные системные учетные записи.

Параметры

Можно назначить одну учетную запись входа всем службам SQL Server или настроить учетные записи служб индивидуально. Можно также указать, будут службы запускаться автоматически или вручную либо будут отключены. В большинстве установок рекомендуется использовать учетную запись по умолчанию.

  • В Windows 7 и Windows Server 2008 R2 большинство учетных записей по умолчанию представлены виртуальной учетной записью.

  • В операционных системах Windows Vista и Windows Server 2008 большинство учетных записей по умолчанию представлены учетной записью NETWORK SERVICE.

  • В кластерных установках на Windows Server 2008 необходимо предоставить учетную запись домена.

При настройке служб с использованием учетных записей домена (Майкрософт) рекомендует настраивать учетные записи служб индивидуально, предоставляя каждой из служб SQL Server только права доступа, необходимые для выполнения ее задач. Дополнительные сведения, включая описание типов учетных записей, см. в разделе Настройка учетных записей служб Windows.

Выполнять настройку конфигурации учетных записей служб SQL Server отдельно (рекомендуется)

Для каждой из служб SQL Server задайте в сетке имя и пароль пользователя для входа, а также тип запуска службы. Для служб SQL Server можно указать системные или локальные учетные записи, локальные группы, группы доменов или учетные записи пользователей доменов.

Выберите службу, настройки которой требуется изменить.

Служба

Настройки проверки подлинности

Агент SQL Server

Служба, которая запускает задания, мониторы и SQL Server, а также позволяет автоматизировать задачи администрирования.

Для этой службы нет учетной записи входа по умолчанию.

Тип запуска по умолчанию — «Вручную».

SQL Server

Компонент Компонент SQL Server Database Engine.

Тип запуска по умолчанию — «Авто».

Примечание Примечание

Браузер SQL Server

Браузер SQL Server представляет службу разрешения имен, которая обеспечивает данные о соединении SQL Server с клиентскими компьютерами. Эта служба совместно используется множеством экземпляров SQL Server и служб Integration Services.

Учетная запись входа по умолчанию — NT Authority\Local Service, и она не может быть изменена в ходе установки SQL Server. Учетную запись можно изменить после завершения установки.

Если во время установки не указан тип запуска, он определяется следующим образом.

  • Служба браузера SQL Server настроена на автоматический запуск и работает в описанных ниже сценариях установки.

    • Экземпляр отказоустойчивого кластера SQL Server.

    • Именованный экземпляр SQL Server, если включен протокол TCP или NP.

    • Некластеризованный, именованный экземпляр сервера анализа данных.

  • Если ни один из указанных выше сценариев не применим и браузер SQL Server уже установлен, будет поддерживаться текущее состояние браузера SQL Server.

  • Устанавливается тип запуска «Отключено» и служба останавливается, если до установки не существовало экземпляра SQL Server 2005, SQL Server 2008 или SQL Server 2008 R2.

Службы Analysis Services

Службы Analysis Services.

Тип запуска по умолчанию — «Авто».

Для режима интеграции с SharePoint следует указать учетную запись пользователя домена Windows. Указанная учетная запись используется для службы Службы Analysis Services. Учетная запись, указанная для текущего экземпляра, также должна использоваться для дополнительных экземпляров служб Службы Analysis Services, которые, возможно, будут добавлены к ферме в будущем.

Службы Reporting Services

Службы Reporting Services. Учетные записи служб используются для настройки соединения с базой данных сервера отчетов. Если нужно использовать параметры проверки подлинности по умолчанию, выберите встроенную сетевую службу. Если указывается учетная запись пользователя домена, убедитесь, что для него зарегистрировано имя участника-службы, если на сервере отчетов используется проверка подлинности Windows. Дополнительные сведения см. в разделе Как настроить проверку подлинности Windows в службах Reporting Services.

Важное примечание Важно!

Корпорация Майкрософт не рекомендует использовать учетную запись сетевой службы для SQL Server и служб агента SQL Server, если доступна учетная запись с меньшими правами доступа, поскольку учетная запись Network Service является общей. Учетную запись Network Service можно использовать в качестве учетной записи службы SQL Server только в случае, если на компьютере не установлены другие службы, использующие эту учетную запись. Для служб SQL Server больше подходят учетные записи «Локальный пользователь» и «Пользователь домена», которые не являются администраторами Windows.

Тип запуска по умолчанию — «Авто».

Integration Services

Службы Integration Services представляют собой набор графических средств и программируемых объектов для перемещения, копирования и преобразования данных.

Тип запуска по умолчанию — «Авто».

SQL Server средство запуска управляющей программы полнотекстовой фильтрации

Служба, которая создает процессы fdhost.exe. Она необходима для размещения средств разбиений по словам и фильтров, которые обрабатывают текстовые данные для полнотекстового индексирования.

Если для запуска службы FDHOST Launcher указывается учетная запись домена, настоятельно рекомендуется использовать учетную запись с низкими правами доступа. Эта учетная запись должна отличаться от той, которая используется для службы SQL Server. В Windows Vista и Windows Server 2008 учетной записью по умолчанию для службы средства запуска FDHOST является LOCAL SERVICE.

Клиент распределенного воспроизведения SQL Server

Учетная запись службы, используемая для службы клиента распределенного воспроизведения.

Укажите учетную запись, под которой будет запускаться служба клиента распределенного воспроизведения. Эта учетная запись должна отличаться от той, которая используется для службы SQL Server.

Тип запуска по умолчанию — «Вручную».

Контроллер распределенного воспроизведения SQL Server

Учетная запись, используемая для службы контроллера распределенного воспроизведения.

Укажите учетную запись, под которой будет запускаться служба контроллера распределенного воспроизведения. Эта учетная запись должна отличаться от той, которая используется для службы SQL Server.

Тип запуска по умолчанию — «Вручную».

См. также

Другие ресурсы

Вопросы безопасности при установке SQL Server


Роль установки

[image]

Роль установки
См. также Отправить отзыв

На этой странице можно указать, будет страница «Выбор компонентов» использоваться для выбора отдельных функций или для установки с использованием роли установки.

setup role представляет собой фиксированный выбор для всех функций и общих компонентов, которые необходимы для реализации стандартной конфигурации SQL Server.

Параметры

Установка компонента SQL Server

Укажите этот параметр для выбора отдельных функций и общих компонентов. В число компонентов экземпляра входят службы Database Engine Services, Analysis Services (в собственном режиме) и Reporting Services.

SQL Server PowerPivot для SharePoint

Укажите этот параметр для установки компонентов сервера служб Analysis Services на ферме SharePoint 2010. В этом случае служба PowerPivot System и сервер служб Analysis Services развертываются на ферме, обеспечивая обработку запросов и данных для опубликованных книг Excel, которые содержат внедренные данные PowerPivot.

Дополнительно в установку можно включить экземпляр ядра СУБД для реляционных баз данных, если он необходим для размещения баз данных в ферме SharePoint. Если ферма уже настроена, этот шаг можно пропустить.

По завершении процедуры установки необходимо настроить программное обеспечение с помощью одного из следующих средств: средство настройки PowerPivot, командлеты PowerShell или центр администрирования SharePoint 2010. В отличие от предыдущих выпусков, программа установки больше не выполняет какие-либо задачи по настройке установки PowerPivot.

Установка на основе роли не включает SQL Server PowerPivot для клиентского приложения Excel. Клиентское приложение устанавливается отдельно.

Все компоненты по умолчанию

Выберите эту роль установки, чтобы установить все компоненты, доступные для этой версии. Обратите внимание, что PowerPivot для SharePoint исключен из этой роли. Чтобы установить этот компонент, необходимо использовать роль программы установки PowerPivot для SharePoint.

Компонент Database Engine настраивается для запуска с использованием учетной записи NT AUTHORITY\NETWORK SERVICE. Текущий пользователь подготавливается в качестве члена роли SQL Server sysadmin. Значения, заданные этим параметром, могут быть переопределены с помощью дополнительных параметров командной строки.

В Windows Vista, Windows Server 2008 или последующих версиях, если операционная система не является контроллером домена, по умолчанию в компоненте Database Engine и службах Reporting Services используется учетная запись NTAUTHORITY\NETWORK SERVICE, в Integration Services — учетная запись NTAUTHORITY\NETWORK SERVICE, а в средстве запуска управляющей программы полнотекстовой фильтрации — учетная запись NTAUTHORITY\LOCAL SERVICE.

См. также

Справочник

Выбор компонентов

Другие ресурсы

Установка PowerPivot для SharePoint
Требования к оборудованию и программному обеспечению (PowerPivot для SharePoint)


Мастер отказоустойчивого кластера SQL Server: завершено

[image]

Мастер отказоустойчивого кластера SQL Server: завершено
См. также Отправить отзыв

Программа установки SQL Server проверяет конфигурацию компьютера перед началом установки. Во время установки SQL Server средство проверки конфигурации системы (SCC) просматривает компьютер, на котором устанавливается SQL Server. Средство SCC проверяет наличие условий, препятствующих успешной установке SQL Server. Прежде чем программа установки запустит мастер установки SQL Server, SCC получает сведения о состоянии каждого элемента. Затем оно сравнивает результаты с требуемыми условиями и предоставляет рекомендации по устранению критических препятствий.

При проверке конфигурации системы создается отчет, содержащий краткое описание всех выполненных правил и состояния выполнения. Отчет о проверке конфигурации системы находится в папке %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Прежде чем начинать установку, ознакомьтесь со следующими разделами:

  1. Требования к оборудованию и программному обеспечению для установки SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Возможности, поддерживаемые различными выпусками SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Вопросы безопасности при установке SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Версии SQL Server на местных языках(http://go.microsoft.com/fwlink/?LinkId=235027)

Другие ссылки:

  1. Поддерживаемые обновления версий и выпусков(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Подготовка к установке отказоустойчивой кластеризации(http://go.microsoft.com/fwlink/?LinkId=235034)

См. также

Справочник

Правила поддержки программы установки


Мастер отказоустойчивого кластера SQL Server: установка

[image]

Мастер отказоустойчивого кластера SQL Server: установка
См. также Отправить отзыв

Программа установки SQL Server проверяет конфигурацию компьютера перед началом установки. Во время установки SQL Server средство проверки конфигурации системы (SCC) просматривает компьютер, на котором устанавливается SQL Server. Средство SCC проверяет наличие условий, препятствующих успешной установке SQL Server. Прежде чем программа установки запустит мастер установки SQL Server, SCC получает сведения о состоянии каждого элемента. Затем оно сравнивает результаты с требуемыми условиями и предоставляет рекомендации по устранению критических препятствий.

При проверке конфигурации системы создается отчет, содержащий краткое описание всех выполненных правил и состояния выполнения. Отчет о проверке конфигурации системы находится в папке %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Прежде чем начинать установку, ознакомьтесь со следующими разделами:

  1. Требования к оборудованию и программному обеспечению для установки SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Возможности, поддерживаемые различными выпусками SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Вопросы безопасности при установке SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Версии SQL Server на местных языках(http://go.microsoft.com/fwlink/?LinkId=235027)

Другие ссылки:

  1. Поддерживаемые обновления версий и выпусков(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Подготовка к установке отказоустойчивой кластеризации(http://go.microsoft.com/fwlink/?LinkId=235034)

См. также

Справочник

Правила поддержки программы установки


Мастер отказоустойчивой кластеризации SQL Server — подготовка

[image]

Мастер отказоустойчивой кластеризации SQL Server — подготовка
См. также Отправить отзыв

Программа установки SQL Server проверяет конфигурацию компьютера перед началом установки. Во время установки SQL Server средство проверки конфигурации системы (SCC) просматривает компьютер, на котором устанавливается SQL Server. Средство SCC проверяет наличие условий, препятствующих успешной установке SQL Server. Прежде чем программа установки запустит мастер установки SQL Server, SCC получает сведения о состоянии каждого элемента. Затем оно сравнивает результаты с требуемыми условиями и предоставляет рекомендации по устранению критических препятствий.

При проверке конфигурации системы создается отчет, содержащий краткое описание всех выполненных правил и состояния выполнения. Отчет о проверке конфигурации системы находится в папке %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Прежде чем начинать установку, ознакомьтесь со следующими разделами:

  1. Требования к оборудованию и программному обеспечению для установки SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Возможности, поддерживаемые различными выпусками SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Вопросы безопасности при установке SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Версии SQL Server на местных языках(http://go.microsoft.com/fwlink/?LinkId=235027)

Другие ссылки:

  1. Поддерживаемые обновления версий и выпусков(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Подготовка к установке отказоустойчивой кластеризации(http://go.microsoft.com/fwlink/?LinkId=235034)

См. также

Справочник

Правила поддержки программы установки


Сводка (обновление)

[image]

Сводка (обновление)
Отправить отзыв

На странице «Сводка» можно просмотреть параметры, заданные для обновления.


Правила поддержки программы установки

[image]

Правила поддержки программы установки
Отправить отзыв

Программа установки SQL Server проверяет конфигурацию компьютера перед началом установки. Во время установки SQL Server средство проверки конфигурации системы (SCC) просматривает компьютер, на котором устанавливается SQL Server. Средство SCC проверяет наличие условий, препятствующих успешной установке SQL Server. Прежде чем программа установки запустит мастер установки SQL Server, SCC получает сведения о состоянии каждого элемента. Затем оно сравнивает результаты с требуемыми условиями и предоставляет рекомендации по устранению критических препятствий.

При проверке конфигурации системы создается отчет, содержащий краткое описание всех выполненных правил и состояния выполнения. Отчет о проверке конфигурации системы находится в папке %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Прежде чем начинать установку, ознакомьтесь со следующими разделами:

  1. Требования к оборудованию и программному обеспечению для установки SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Возможности, поддерживаемые различными выпусками SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Вопросы безопасности при установке SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Версии SQL Server на местных языках(http://go.microsoft.com/fwlink/?LinkId=235027)

Другие ссылки:

  1. Поддерживаемые обновления версий и выпусков(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Подготовка к установке отказоустойчивой кластеризации(http://go.microsoft.com/fwlink/?LinkId=235034)

Дополнительные разделы по правилам

См. следующие разделы об указаниях по установке в зависимости от сценария:

  • Правила установки

  • Проверка правил обновления

  • Правила обновления выпуска

  • Правила удаления

  • Правила подготовки образа

  • Правила завершения образа


Правила удаления

[image]

Правила удаления
См. также Отправить отзыв

Страница правил удаления выполняет набор правил, чтобы гарантировать успешное завершение работы программы установки.

Программа установки SQL Server проверяет конфигурацию компьютера перед началом установки. Во время установки SQL Server средство проверки конфигурации системы (SCC) просматривает компьютер, на котором устанавливается SQL Server. Средство SCC проверяет наличие условий, препятствующих успешной установке SQL Server. Прежде чем программа установки запустит мастер удаления SQL Server, SCC получает сведения о состоянии каждого элемента. Затем оно сравнивает результаты с требуемыми условиями и предоставляет рекомендации по устранению критических препятствий.

При проверке конфигурации системы создается отчет, содержащий краткое описание всех выполненных правил и состояния выполнения. Отчет о проверке конфигурации системы находится в папке %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Прежде чем начинать установку, ознакомьтесь со следующими разделами:

  1. Требования к оборудованию и программному обеспечению для установки SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Возможности, поддерживаемые различными выпусками SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Вопросы безопасности при установке SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Версии SQL Server на местных языках(http://go.microsoft.com/fwlink/?LinkId=235027)

Другие ссылки:

  1. Поддерживаемые обновления версий и выпусков(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Подготовка к установке отказоустойчивой кластеризации(http://go.microsoft.com/fwlink/?LinkId=235034)

См. также

Справочник

Правила поддержки программы установки


Ход выполнения обновления

[image]

Ход выполнения обновления
См. также Отправить отзыв

Страница Ход выполнения обновления мастера установки SQL Server позволяет наблюдать за состоянием обновления SQL Server.

См. также

Основные понятия

Просмотр и чтение файлов журналов программы установки SQL Server


Проверка правил обновления

[image]

Проверка правил обновления
См. также Отправить отзыв

Программа установки SQL Server проверяет конфигурацию компьютера перед началом установки. Во время установки SQL Server средство проверки конфигурации системы (SCC) просматривает компьютер, на котором устанавливается SQL Server. Средство SCC проверяет наличие условий, препятствующих успешной установке SQL Server. Прежде чем программа установки запустит мастер обновления, SCC получает сведения о состоянии каждого элемента. Затем оно сравнивает результаты с требуемыми условиями и предоставляет рекомендации по устранению критических препятствий.

При проверке конфигурации системы создается отчет, содержащий краткое описание всех выполненных правил и состояния выполнения. Отчет о проверке конфигурации системы находится в папке %programfiles%\Microsoft SQL Server\110\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\.

Прежде чем начинать установку, ознакомьтесь со следующими разделами:

  1. Требования к оборудованию и программному обеспечению для установки SQL Server (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Возможности, поддерживаемые различными выпусками SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Вопросы безопасности при установке SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Версии SQL Server на местных языках(http://go.microsoft.com/fwlink/?LinkId=235027)

Другие ссылки:

  1. Поддерживаемые обновления версий и выпусков(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Подготовка к установке отказоустойчивой кластеризации(http://go.microsoft.com/fwlink/?LinkId=235034)

См. также

Справочник

Правила поддержки программы установки


Проверка параметров удаления

[image]

Проверка параметров удаления
Отправить отзыв

Проверьте свой выбор и нажмите кнопку Далее, чтобы продолжить.


Раздел, который вы ищете, недоступен

[image]

Раздел, который вы ищете, недоступен
Отправить отзыв

После завершения установки можно просмотреть документацию по SQL Server, нажав кнопку Справка, клавишу F1 во время работы с диалоговыми окнами или элементами интерфейса либо последовательно выбрав в меню Пуск пункты Все программы, Microsoft SQL Server и Справка и сообщество& и Электронная документация по SQL Server. Дополнительные сведения см. в разделе Добавление и удаление наборов разделов справки.