Общие сведения об обслуживании установки SQL Server

[image]

Общие сведения об обслуживании установки SQL Server
См. также Отправить отзыв

Можно обновить любой установленный компонент SQL Server 2012, применив сервисное обновление SQL Server 2012. Если версия существующего компонента SQL Server 2012 новее, чем версия обновления, то программа установки исключит этот компонент из списка обновления. Дополнительные сведения о применении сервисного обновления см. в разделе Установка сервисных обновлений SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=231297).

При установке обновлений для SQL Server 2012 необходимо учитывать следующие соображения.

  • Все компоненты, которые принадлежат одному экземпляру SQL Server, должны обновляться одновременно. Например, если обновляется компонент Компонент Database Engine, также необходимо обновить службы Службы Analysis Services и Службы Reporting Services, если они установлены в качестве части того же экземпляра SQL Server. Общие компоненты, такие как средства управления, среда SQL Server Data Tools (SSDT) и службы SQL Server Службы Integration Services, всегда должны быть обновлены до самой последней версии. Если компонент или экземпляр не выбран в дереве компонентов, то он не будет обновлен.

  • По умолчанию файлы журнала обновления служб SQL Server 2012 сохраняются в папке «%Program Files%\Microsoft SQL Server\110\Setup Bootstrap\LOG\».

  • Теперь в программе установки SQL Server обновление может быть интегрировано с исходным носителем, что позволяет выполнять обновление одновременно с запуском исходного носителя. Дополнительные сведения см. в разделах Обновление продуктов в установке SQL Server 2012 и Новые возможности установки SQL Server(http://go.microsoft.com/fwlink/?LinkID=219508).

  • Прежде чем применять сервисное обновление SQL Server 2012, рекомендуется создать резервную копию данных.

  • Обновления SQL Server доступны через обновления Майкрософт. Чтобы обеспечить надлежащий уровень обновления и защищенности экземпляра SQL Server, рекомендуется регулярно проверять наличие обновлений.SQL Server 2012 Пакет обновления 1 (SP1) предоставляется как полная установка SQL Server. В этом выпуске вместо пакета обновления в стандартном выполняемом пакете обновления для экземпляров SQL Server 2012 RTM предоставляется установочный пакет, состоящий из двух файлов. При его выполнении будет установлен новый экземпляр SQL Server 2012 с предустановленным пакетом обновления 1 (SP1). Дополнительные сведения см. в разделе Полная установка SQL Server 2012 с пакетом обновления 1 (SP1).

Требования и известные проблемы

Для загрузки и извлечения пакета рекомендуется, чтобы объем свободного места на диске превышал размер пакета примерно в 2,5 раза. После установки пакета обновления загруженный пакет можно удалить с компьютера. Любые временные файлы будут удалены автоматически.

Ознакомьтесь с известными проблемами. Дополнительные сведения об известных проблемах текущего выпуска см. в соответствующем разделе заметок о выпуске: Заметки о выпуске SQL Server.

Общие сведения об установке

В этом разделе описывается установка накопительных обновлений и пакетов обновлений для SQL Server 2012, включая описание следующих действий:

  • подготовка к установке обновлений для SQL Server 2012;

  • установка обновлений SQL Server 2012

  • перезапуск служб и приложений

подготовка к установке обновлений для SQL Server 2012

Настоятельно рекомендуется до установки обновлений SQL Server 2012 выполнить следующие действия.

  • Резервное копирование системных баз данных SQL Server — перед установкой обновлений SQL Server 2012 создайте резервные копии баз данных master, msdb и model. При установке обновления SQL Server 2012 эти базы данных изменяются, при этом они становятся несовместимыми с более ранними версиями SQL Server 2012. Резервные копии этих баз данных понадобятся в случае, если будет принято решение переустановить SQL Server 2012 без этих обновлений.

    Разумно также создать резервные копии пользовательских баз данных.

    Важное примечание Важно!

    Перед установкой обновлений для экземпляров SQL Server, участвующих в топологии репликации, необходимо создать резервные копии реплицируемых баз данных наряду с системными базами данных.

  • Резервное копирование баз данных служб Службы Analysis Services, файла конфигурации и репозитория — перед обновлением экземпляра служб Службы Analysis Services создайте резервные копии следующих объектов.

    • Базы данных служб Службы Analysis Services. По умолчанию они устанавливаются в папку C:\Program Files\Microsoft SQL Server\MSAS11.<Идентификатор_экземпляра>\OLAP\Data\. Для установок WOW по умолчанию задается путь C:\ProgramFiles (x86)\Microsoft SQL Server\MSAS11.<Идентификатор_экземпляра>\OLAP\Data\.

    • Параметр конфигурации служб Службы Analysis Services в файле конфигурации msmdsrv.ini. По умолчанию этот файл находится в каталоге C:\Program Files\Microsoft SQL Server\MSAS11.<Идентификатор_экземпляра>\OLAP\Config\.

    • База данных, содержащая репозиторий служб Службы Analysis Services (необязательно). Этот шаг необходим только в случае, если службы Службы Analysis Services были настроены для работы с библиотекой объектов DSO.

    Примечание Примечание

    Если не создать резервные копии файла конфигурации, репозитория и баз данных служб Службы Analysis Services, вернуть обновленный экземпляр служб Службы Analysis Services к более ранней версии будет невозможно.

  • Обеспечение достаточного свободного места в системных базах данных. Если для системных баз данных master и msdb не включен параметр автоувеличения, то в каждой из этих баз данных необходимо обеспечить как минимум 500 КБ свободного места. Чтобы убедиться, что в базах данных достаточно свободного пространства, запустите системную хранимую процедуру sp_spaceused в базах данных master и msdb. Если размер свободного места в какой-либо из этих баз данных составляет менее 500 КБ, увеличьте ее размер.

  • Остановка служб и приложений. Чтобы избежать перезапуска системы, остановите все приложения и службы, которые устанавливают соединения с обновляемыми экземплярами SQL Server, прежде чем устанавливать обновления для SQL Server 2012. Это также касается среды Среда SQL Server Management Studio и SQL Server Data Tools (SSDT). Дополнительные сведения см. в разделе Запуск, остановка, приостановка, возобновление и перезапуск ядра СУБД, агента SQL Server и обозревателя SQL Server.

    Примечание Примечание

    В среде с отказоустойчивым кластером нельзя останавливать службы. Дополнительные сведения см. в подразделе, посвященном установке отказоустойчивого кластера, далее в этом разделе.

  • Чтобы устранить необходимость в перезагрузке компьютера после установки обновления, программа установки отобразит список процессов, блокирующих файлы. Если программе установки обновления необходимо остановить работу службы во время установки, эта служба будет перезапущена после завершения установки.

  • Если программа установки обнаруживает заблокированные файлы во время установки, может возникнуть необходимость в перезагрузке компьютера после завершения установки. При необходимости программа установки предложит пользователю перезагрузить компьютер.

Установка обновлений SQL Server 2012

В этом разделе описан процесс установки.

Важное примечание Важно!

Обновления для SQL Server 2012 должны запускаться от имени учетной записи, обладающей правами администратора на компьютере, где устанавливаются обновления. Для локальной установки необходимо запустить программу установки под учетной записью администратора. При установке SQL Server из удаленной общей папки необходимо использовать учетную запись домена с разрешениями на чтение и выполнение для удаленной общей папки.

Начало обновления SQL Server 2012

Чтобы установить обновление SQL Server 2012, запустите файл самоизвлекающегося пакета.

Пакет с накопительным обновлением: <SQLServer2012>-KBxxxxxx-PPP.exe

Пакет обновления (PCU): <SQLServer2012><SPx> -KBxxxxxx-PPP-LLL.exe

  • x указывает номер пакета обновления.

  • PPP указывает конкретную платформу.

  • LLL обозначает буквенный код языка SQL Server, например: LLL для английского языка ? ENU.

Сведения об установке обновлений для компонентов SQL Server 2012, входящих в состав кластера отработки отказа, см. в подразделе по установке кластера отработки отказа. Дополнительные сведения об установке обновлений в автоматическом режиме см. в разделе Установка обновлений из командной строки.

Обновления продукта в установке SQL Server 2012

Обновление продукта — это новая функция в программе установки SQL Server 2012. Она интегрирует последние обновления продукта с основной установкой продукта таким образом, что основной продукт и соответствующие обновления устанавливаются одновременно. Функция обновления продукта может искать применимые обновления в Центре обновления Майкрософт, в службах Windows Server Update Services (WSUS), в папке локального компьютера или в общей сетевой папке. Когда программа установки обнаруживает последние версии соответствующих обновлений, эти обновления загружаются и интегрируются в текущую процедуру установки SQL Server. Функция обновления продукта может включить в установку пакет обновления, накопительное обновление или то и другое. Функция обновления продукта является расширением функции Slipstream, которая была доступна в SQL Server 2008 PCU1. Дополнительные сведения о функции обновления продуктов в программе установки SQL Server 2012 см. в разделе Обновления продукта в установке SQL Server 2012.

Полная установка SQL Server 2012 с пакетом обновления 1 (SP1)

SQL Server 2012 с пакетом обновления 1 (SP1) также доступен в виде полного установочного пакета SQL Server. Пакет установки SQL Server 2012 с пакетом обновления 1 (SP1) устанавливает новый экземпляр SQL Server с предустановленным пакетом обновления 1 (SP1).

В пакете исполняемый файл и установочные файлы находятся в сжатом формате. Пакет содержит файлы вида: SQLServer2012SP1-<Architecture>-<Language>.exe и SQLServer2012SP1-<Architecture>-<Language>.box.

При установке SQL Server 2012 с пакетом обновления 1 (SP1) соблюдайте следующие инструкции:

  • Загрузите следующие файлы со страницы загрузки во временный каталог на устройстве:

    • SQLServer2012SP1-architecture-language.box

    • SQLServer2012SP1-architecture-language.exe

  • После завершения загрузки дважды щелкните SQLServer2012SP1-<architecture>-<language>.exe, чтобы начать процесс установки.

  • В диалоговом окне Выбор каталога для извлекаемых файлов указан путь к каталогу по умолчанию: <Текущий диск>\<Текущая рабочая папка>\<Имя пакета>. Например, %temp%\SQLServer2012SP1-x64-ENU\. Чтобы изменить каталог по умолчанию для извлекаемых файлов, нажмите кнопку Обзор.

  • Пакет будет распакован по указанному пути установки, где файлы будут сохранены и после завершения процесса установки. Пользователь сможет использовать двоичные файлы из этой папки для выполнения установки в будущем.

  • Мастер установки запускает центр установки SQL Server. Следуйте указаниям по установке, приведенным в статье Установка SQL Server 2012 с помощью мастера установки (программа установки) (http://msdn.microsoft.com/library/ms143219.aspx).

В следующей таблице приведены некоторые параметры командной строки, которые можно использовать для извлечения пакета SQL Server 2012 с пакетом обновления 1 (SP1):

Подробный список поддерживаемых параметров командной строки, которые можно указывать непосредственно для пакета обновления 1 (SP1), см. в статье Установка SQL Server 2012 из командной строки (http://msdn.microsoft.com/library/ms144259.aspx)

Параметр

Описание

/x или -x

Извлекает пакет в указанный каталог. Открывает диалоговое окно «Выбор каталога для извлекаемых файлов», затем извлекает пакет в указанный каталог.

Программа установки при этом не запускается.

/x:<path> или -x:<path>

Извлекает пакет в указанный каталог и не запускает программу установки.

/q или -q

Указывает, что программа установки работает в тихом режиме (без пользовательского интерфейса). Этот параметр предназначен для автоматической установки.

/l:<path> или -l:<path>

По умолчанию файл журнала хранится во временном каталоге под именем SQLServer2012SPx-<Architecture>-<Language>_decompression_log.txt

С помощью этого параметра можно сформировать пользовательский каталог для сохранения файла журнала извлечения.

Например:

SQLServer2012SP1-x64-ENU /x /l:<path>

Этот параметр должен использоваться только совместно с параметром /x или -x или /x:<path> или -x:<path>

Обновление подготовленного образа SQL Server

Можно применить обновление к ненастроенному подготовленному экземпляру SQL Server без завершения настройки подготовленного экземпляра. Различные способы обновления подготовленного экземпляра SQL Server приведены далее.

  • Обновление ранее подготовленного экземпляра SQL Server

    Обновления к подготовленному экземпляру можно применить до настройки. Пакет обновления обнаруживает, что экземпляр находится в состоянии подготовки, и применяет обновление к подготовленному экземпляру, не завершая настройку.

  • Обновления подготовленного экземпляра с помощью центра обновления Майкрософт:

    Обновления можно применять к подготовленному экземпляру SQL Server с помощью центра обновления Майкрософт. Пакет обновления центра обновления Майкрософт обнаруживает, что экземпляр находится в состоянии подготовки и применяет обновление к подготовленному экземпляру, не завершая настройку.

При обновлении подготовленного образа SQL Server необходимо указать параметр InstanceID. Дополнительные сведения и образец синтаксиса см. в разделе Установка обновлений из командной строки.

Обновление завершенного образа SQL Server

Обновление завершенного и настроенного экземпляра SQL Server выполняется аналогично, с использованием тех же процессов, что и обновление других установленных экземпляров SQL Server.

Перестроение узла кластера отработки отказа SQL Server 2012

Если после установки обновлений необходимо перестроить узел в кластере отработки отказа, выполните следующие действия.

  1. Перестройте узел в отказоустойчивом кластере. Дополнительные сведения о перестроении узла см. в разделе Восстановление по журналу после сбоя экземпляра кластера отработки отказа.

  2. Запустите исходную программу установки SQL Server 2012, чтобы установить SQL Server 2012 на узле кластера отработки отказа.

  3. Запустите программу установки обновлений для SQL Server 2012 на добавленном узле.

Перезапуск служб и приложений

После завершения установки может появиться запрос на перезагрузку компьютера. После перезагрузки системы или после завершения программы установки без запроса на перезагрузку используйте на панели управления средство Службы, чтобы перезапустить службы, остановленные перед установкой обновлений для SQL Server 2012. В частности, к их числу относятся координатор распределенных транзакций и служба поиска Майкрософт или их эквиваленты для данного экземпляра.

Перезапустите приложения, закрытые перед запуском программы установки обновлений для SQL Server 2012. Можно также создать дополнительные резервные копии обновленных баз данных master, msdb и model сразу после успешной установки.

Удаление обновлений из SQL Server 2012

Удаление накопительных обновлений и пакетов обновлений для SQL Server 2012 можно выполнить через элемент на панели управления Установка и удаление программ. Чтобы просмотреть список установленных обновлений, откройте диалоговое окно «Установленные обновления». Для этого нажмите кнопку Пуск, выберите Панель управления, Программы, затем в разделе Программы и компоненты выберите Просмотр установленных обновлений. Каждое накопительное обновление указывается отдельной строкой. Однако если установлен пакет обновления, версия которого выше накопительного обновления, то элементы накопительного обновления будут скрыты и станут доступными только при удалении пакета обновления.

Удаление обновлений и пакетов обновления производят от самого последнего примененного на экземпляре SQL Server и к более ранним. В каждом и приведенных ниже примеров после удаления всех обновлений и пакетов обновления на SQL Server остается только с накопительным обновлением 1.

  • Для экземпляра SQL Server 2012 с установленным накопительным обновлением 1 и пакетом обновления 1 (SP1) необходимо удалить пакет обновления 1 (SP1).

  • Для экземпляра SQL Server 2012 с накопительным обновлением 1, пакетом обновления 1 (SP1) и накопительным обновлением 2 сначала необходимо удалить накопительное обновление 2, а затем пакет обновления 1 (SP1).

См. также

Другие ресурсы

Установка SQL Server 2012 из командной строки
Установка обновлений для обслуживания SQL Server 2012
Проверка установки SQL Server
Просмотр и чтение файлов журналов программы установки SQL Server
Изображение Нижний колонтитул
Отправьте отзыв об этом разделе в корпорацию Майкрософт

© Корпорация Майкрософт (Microsoft Corp.), 2012. Все права защищены.


Юридическое уведомление для документации

[image]

Юридическое уведомление для документации
Отправить отзыв

Данный документ предоставляется «как есть». Сведения и представления, приведенные в этом документе, включают URL-адреса и другие ссылки на веб-сайты, которые могут изменяться без предупреждения. Вы принимаете на себя риск, связанный с пользованием этим документом.

Некоторые примеры, описанные в настоящем документе, являются вымышленными и приведены исключительно в демонстрационных целях. Примеры не рассчитаны на применение в реальных условиях, и их не следует рассматривать как относящиеся к реальным ситуациям.

Настоящий документ не предоставляет пользователям права на интеллектуальную собственность продуктов Майкрософт. Разрешается копирование и использование настоящего документа только в справочных целях.

© Корпорация Майкрософт (Microsoft Corporation), 2012. Все права защищены.

Microsoft, Active Directory, ActiveX, Bing Maps, Excel, IntelliSense, MSDN, MS-DOS, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual Studio, Windows, Windows NT, Windows Server и Windows Vista являются охраняемыми товарными знаками группы компаний Майкрософт. SAP NetWeaver является охраняемым товарным знаком SAP AG в Германии и в некоторых других странах. Все прочие товарные знаки являются собственностью их владельцев.

Политика документирования поддержки и обновления SQL Server

Документация по программному обеспечению SQL Server 2012 включает электронную документацию по SQL Server 2012, документацию по установке, справочную документацию для разработчика, учебники, файлы сведений, документы по известным проблемам, образцы кода и баз данных, а также статьи базы знаний, опубликованные Майкрософт и посвященные компонентам и функциям SQL Server. Эта политика поддержки и обновления относится к документации SQL Server 2012, включая файлы сведений для выпусков и пакетов обновления SQL Server 2012. Файл сведений следует рассматривать как дополнение электронной документации по SQL Server 2012.

Главное назначение образца, содержащегося в документации, — иллюстрация основных понятий или обоснование использования определенной инструкции или предложения. В большинство образцов не входит весь код, который содержался бы в полноценной промышленной системе. Некоторые обычные операции проверки данных и обработки ошибок удалены из образцов намеренно, чтобы обратить внимание на конкретные концепции или инструкции, используемые в образцах. Техническая поддержка для таких образцов, равно как и для любого исходного кода, не предоставляется.

В некоторых случаях определенные компоненты SQL Server 2012 не были в достаточной степени протестированы или разработаны, поэтому не предназначены для использования вами. Зачастую они представляют собой заполнители. Поэтому некоторые из функций, включенных в программное обеспечение, в документации не описаны. Функции, которые не задокументированы или помечены для внутреннего использования, не предназначены для использования вами и поэтому не поддерживаются службой технической поддержки Майкрософт. Если в документации по SQL Server 2012 не указано иное, любое стороннее содержимое, включая проблемы, ставшие результатом его использования вместе с SQL Server 2012, не поддерживаются службой технической поддержки Майкрософт и, кроме того, могут привести к потере данных. Кроме того, службы поддержки Майкрософт не обеспечивают поддержку для баз данных и приложений, в которых используются недокументированные точки входа и API-интерфейсы, включая следующие, но не ограничиваясь ими: хранимые процедуры, расширенные хранимые процедуры, функции, представления, таблицы, столбцы, свойства и метаданные.

Обновления сервера и баз данных до следующих версий SQL Server 2012 для приложений и баз данных, в которых используются недокументированные точки входа, также могут перестать работать и не поддерживаются. Использование входящих в состав Microsoft SQL Server функций и компонентов, которые не отражены в документации по SQL Server 2012, не поддерживается и может вызвать потерю данных.


Установка обновлений из командной строки

[image]

Установка обновлений из командной строки
См. также Отправить отзыв

Проверьте скрипты установки и доработайте их в соответствии с задачами организации. Дополнительные сведения об установке обновлений на отказоустойчивом кластере SQL Server см. в статье Как применить обновление SQL Server к экземпляру отказоустойчивого кластера базы знаний Майкрософт.

Образец синтаксиса для программы установки

Имя пакета может быть разным и включает обозначение языка, выпуска и архитектуры процессора. Применение обновления из командной строки. Замените <имя_пакета> именем конкретного пакета обновления:

  • Обновление отдельного экземпляра SQL Server и всех общих компонентов, таких как службы Службы Integration Services и средства управления: Можно указать экземпляр с помощью параметра InstanceName или параметра InstanceID. Чтобы обновить подготовленный экземпляр SQL Server, необходимо указать параметр InstanceID <имя_пакета>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /InstanceName=MyInstance или <имя_пакета>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /InstanceID=<Instance ID>

  • Программа установки может интегрировать последние обновления продукта в основную установку продукта, чтобы он и применимые обновления устанавливались одновременно. Можно подготовить установку экземпляра компонента Database Engine, включающую обновление продукта: setup.exe /q /IAcceptSQLServerLicenseTerms /ACTION=PrepareImage /UpdateEnabled=True /UpdateSource=<путь, откуда загружается обновление> /INSTANCEID=<идентификатор экземпляра> /FEATURES=SQLEngine

  • Обновление только общих компонентов SQL Server, таких как службы Службы Integration Services и средства управления: <имя_пакета>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch

  • Обновление всех экземпляров SQL Server на компьютере и всех общих компонентов, таких как службы Службы Integration Services и средства управления: <имя_пакета>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /AllInstances

Удаление обновления из командной строки. Замените <имя_пакета> именем конкретного пакета обновления.

  • Удаление обновления из отдельного экземпляра SQL Server и всех общих компонентов, таких как службы Службы Integration Services и средства управления: <имя_пакета>.exe /qs /Action=RemovePatch /InstanceName=MyInstance

  • Удаление обновления только из общих компонентов SQL Server, таких как службы Службы Integration Services и средства управления: <имя_пакета>.exe /qs /Action=RemovePatch

    Примечание Примечание

    Установщик обновлений поддерживает версию общих компонентов такой же или более поздней, чем версия экземпляра, на самом высоком уровне.

Поддерживаемые параметры командной строки

Важное примечание Важно!

При возможности указывайте учетные данные безопасности в среде выполнения. Если нужно хранить учетные данные в файле скрипта, для этого файла необходимо обеспечить защиту, чтобы исключить несанкционированный доступ.

Параметр | Описание
/? | Отображает справку командной строки для автоматической установки
/action=Patch or /action=RemovePatch | Задает действие установки: Patch или RemovePatch.
/allinstances | Устанавливает обновление SQL Server для всех экземпляров SQL Server и всех общих компонентов SQL Server, не привязанных к экземпляру.
/instancename=InstanceName1 | Устанавливает обновление SQL Server для экземпляра SQL Server с именем InstanceName и всех общих компонентов SQL Server, не привязанных к экземпляру.
/InstanceID=Inst1 | Применяет обновление SQL Server для экземпляра SQL Server с именем «Inst1» и всех общих компонентов SQL Server, не привязанных к экземпляру.
/quiet | Запускает программу установки обновления для SQL Server в автоматическом режиме.
/qs | Отображается только диалоговое окно выполнения.
/UpdateEnabled | Задает, должна ли программа установки SQL Server обнаруживать и включать обновления продукта. Допустимые значения — True и False либо 1 и 0. По умолчанию программа установки SQL Server будет включать найденные обновления.
/UpdateSource | Указывает, откуда программа установки SQL Server будет получать обновления продукта. Допустимые значения: «MU» (поиск в Центре обновления Майкрософт); допустимый путь к папке, относительный путь (например, .\MyUpdates) или общая папка в формате UNC. По умолчанию программа установки SQL Server выполняет поиск в Центре обновления Майкрософт или в службе обновления Windows через службы Windows Server Update Services.
/IAcceptSQLServerLicenseTerms | Требуется только в том случае, если для автоматической установки указан параметр /Q или /QS.

1 Этот параметр нельзя указать для применения обновления к подготовленному экземпляру SQL Server. Вместо этого необходимо указать параметр /instanceID.

См. также

Основные понятия

Общие сведения об обслуживании установки SQL Server


Как проверить успешность установки обновления SQL Server

[image]

Как проверить успешность установки обновления SQL Server
См. также Отправить отзыв

Проверка успешности установки обновления SQL Server.

  • Убедитесь, что службы SQL Server находятся в сети.

  • Проверьте сведения о версии, возвращаемые запросом @@version.

См. также

Основные понятия

Общие сведения об обслуживании установки SQL Server


Получение помощи по SQL Server

[image]

Получение помощи по SQL Server
См. также Отправить отзыв

Корпорация Майкрософт предоставляет три основных источника сведений о SQL Server.

  • Документация, установленная в виде локальной коллекции электронной документации по SQL Server.

  • Сайты, посвященные SQL Server и входящие в состав порталов Microsoft MSDN и TechNet.

  • Сведения о SQL Server на дополнительных веб-сайтах Майкрософт.

Если в этих источниках не удается найти нужные сведения, можно опубликовать вопросы на форумах и в группах новостей сообщества SQL Server или обратиться в службу технической поддержки Майкрософт.

электронная документация по SQL Server

В электронной документации по SQL Server описаны основные понятия и действия, необходимые для эффективного использования SQL Server. Электронная документация также включает в себя справочные материалы по языкам и интерфейсам программирования, обеспечивающим хранение, извлечение и изменение данных, а также создание отчетов при помощи SQL Server.

Получить доступ к электронной документации можно следующими способами.

  • Копия электронной документации по SQL Server 2012 опубликована в библиотеке MSDN и в библиотеке TechNet в Интернете. Разделы этих копий электронной документации по SQL Server содержат комментарии членов сообщества, в том числе дополнительные сведения и примеры кода от других клиентов. Копию, находящуюся в библиотеке MSDN, можно просмотреть в электронной документации по SQL Server 2012.

  • Чтобы установить электронную документацию по SQL Server на локальный компьютер, можно воспользоваться диспетчером библиотек справки. Дополнительные сведения см. в разделе Добавление или удаление наборов разделов справки.

И копия электронной документации по SQL Server в библиотеке MSDN, и файлы электронной документации, доступные через диспетчер библиотек справки, обновляются, когда корпорация Майкрософт публикует обновление для электронной документации по SQL Server.

MSDN и TechNet

Библиотека Microsoft Developer Network (MSDN) предоставляет интерактивные и автономные службы, помогающие разработчикам в создании приложений с применением продуктов и технологий корпорации Microsoft. Программа Microsoft TechNet предоставляет комплексные технические ресурсы, помогающие ИТ-специалистам эффективно оценивать, развертывать и поддерживать решения Microsoft.

На некоторых веб-сайтах MSDN и TechNet специалисты смогут найти ссылки на сведения по SQL Server, которые наиболее важны для их работы, в том числе сведения, содержащиеся в копиях электронной документации по SQL Server в библиотеках MSDN или TechNet. Эти сайты также содержат информацию, которая дополняет сведения, приведенные в электронной документации по SQL Server.

Следующая таблица описывает эти ресурсы и их предполагаемую аудиторию.

Ресурс | Аудитория
Центр разработчиков SQL Server | Разработчики, которые создают базы данных SQL Server, систему отчетов, решения бизнес-аналитики, а также разрешают приложениям и веб-сайтам использовать эти системы.
Центр разработчиков доступа и хранения данных | Разработчики, которые разрешают приложениям и веб-сайтам хранить данные с помощью таких продуктов, как SQL Server и Access.
Центр разработчиков на XML | Создатели веб-сайтов и разработчики приложений, чьи веб-сайты и приложения используют XML для хранения данных и работы с ними.
Веб-сайт SQL Server TechNet | Администраторы и операторы, которые занимаются планированием, развертыванием, администрированием и поддержкой систем, в которых используется SQL Server.

Дополнительные источники сведений в Интернете

Дополнительные сведения о SQL Server можно получить на следующих веб-сайтах корпорации Майкрософт.

Ресурс | Описание
Microsoft SQL Server | Предпродажные сведения об оценке SQL Server как средства для хранения данных и бизнес-аналитики.
База знаний Майкрософт | Представляет собой репозиторий статей технической поддержки Майкрософт по SQL Server с возможностью поиска.
Программа Microsoft Learning | Обучение и сертификация Майкрософт по SQL Server.
Издательство Microsoft Press | Список книг, выпущенных издательством Microsoft Press по SQL Server.

Получение помощи от других пользователей

Если в документации по продукту или на веб-сайте отсутствуют необходимые сведения, можно задать вопрос на форумах и в группах новостей сообщества SQL Server. Также можно запросить содействие службы технической поддержки.

Примечание Примечание

Не следует публиковать вопросы в разделе комментариев сообщества, расположенном в нижней части разделов электронной документации по SQL Server в библиотеке MSDN или библиотеке TechNet. Вопросы, заданные в этих разделах, не просматриваются и обычно остаются без ответа. Публикуйте вопросы на форумах и в группах новостей сообщества, которые просматриваются другими пользователями, которые могут ответить на вопросы.

В следующей таблице указаны ссылки на эти источники, а также приведено их описание.

Ресурс | Описание
Сообщество ИТ-специалистов по SQL Server | Содержит ссылки на группы новостей и форумы, контролируемые сообществом SQL Server. Кроме того, здесь перечислены источники данных сообщества, такие как блоги и сайты. Сообщество SQL Server оказывает значительную помощь, отвечая на вопросы, однако никакой гарантии на получение ответа нет.
Сообщество центра разработчиков SQL Server | На этом сайте находятся группы новостей, форумы и другие источники сообщества, которые полезны для разработчиков SQL Server.
Справка и поддержка Майкрософт | Этот веб-сайт можно использовать для обращения к специалисту службы поддержки Майкрософт.

Продукты Microsoft имеют сроки поддержки, которые определяют, как долго для каждой версии будет доступна поддержка. Служба поддержки Microsoft ведет страницу, в которой описываются сроки поддержки Microsoft. На этой странице содержатся ссылки на другие страницы, отображающие доступность поддержки для продуктов Майкрософт. Дополнительные сведения см. в разделе Сроки поддержки продуктов корпорации Майкрософт.

См. также

Основные понятия

Использование документации по продукту SQL Server


Добро пожаловать

[image]

Добро пожаловать
Отправить отзыв

Правила установки проверяют компьютер, на который будет устанавливаться обновление.


Условия лицензии

[image]

Условия лицензии
Отправить отзыв

На странице «Условия лицензии» принимаются условия лицензии для этого выпуска.

Параметры

Чтобы продолжить установку, необходимо принять условия лицензии SQL Server.

Нажмите кнопку Печать, чтобы распечатать копию условий лицензии для этой версии. Чтобы завершить программу установки, нажмите кнопку Отмена.


Выбор компонентов

[image]

Выбор компонентов
Отправить отзыв

На странице «Выбор компонентов» выбираются компоненты и функции SQL Server для обновления.

Параметры

Щелкните имя компонента в левой панели, чтобы просмотреть сведения о языке, операционной системе, выпуске и состоянии.

Чтобы обновить компонент или функцию, установите флажок рядом с именем компонента или функции. Чтобы исключить компонент или функцию из текущего обновления, снимите флажок рядом с именем компонента или функции.

Несколько экземпляров SQL Server на одном компьютере можно обновлять в разное время, однако все компоненты одного экземпляра SQL Server должны обновляться одновременно. Должны быть обновлены все общие компоненты, в том числе компоненты рабочей станции, синтаксический анализатор MSXML, SQLXML, компоненты обратной совместимости и службы синхронизации контроля версий.

Если компонент нельзя обновить, в панели «Подробности» будет отображено пояснение.


Проверка используемых файлов

[image]

Проверка используемых файлов
Отправить отзыв

Чтобы избежать необходимости перезагрузки Windows после установки обновлений для SQL Server, на странице «Проверка используемых файлов» можно найти процессы, которые блокируют файлы, необходимые программе установки обновлений SQL Server.

Остановите все приложения и службы, которые соединяются с обновляемыми экземплярами SQL Server. Это также касается среды Среда SQL Server Management Studio и среды SQL Server Data Tools (SSDT).

Если программа установки обнаруживает заблокированные файлы во время установки, может возникнуть необходимость в перезагрузке компьютера после завершения установки. При необходимости программа установки запрашивает пользователя о перезагрузке компьютера. Если программе установки необходимо остановить работу службы во время установки, эта служба будет перезапущена после завершения установки.

Чтобы устранить необходимость в перезагрузке компьютера после установки, программа установки отобразит список процессов, блокирующих файлы. Остановите процессы или приложения, указанные в списке. После этого нажмите кнопку Обновить проверку, чтобы выполнить проверку повторно. Нажмите кнопку Остановить проверку, чтобы прервать выполнение проверки. Если заблокированные файлы не обнаружены, таблица будет пустой. После того как все заблокированные процессы были закрыты или остановлены, нажмите кнопку Далее, чтобы продолжить.

Программа установки записывает сведения в файлы журналов. Дополнительные сведения о просмотре файлов журналов см. в разделах Как просмотреть файлы журналов установки SQL Server и Как просматривать файл журнала установки SQL Server.

В файл журнала включается следующая информация.

  • Имя процесса

  • Имя компонента SQL Server

  • Тип процесса

  • Учетная запись, под которой выполняется процесс

  • Идентификатор процесса

  • Имя заблокированного файла

Название | Описание
Процесс | Отображает полное имя процесса, использующего файлы, которые будут обновлены.
Тип | Отображает тип процесса.
Учетная запись | Отображает учетную запись, под которой выполняется процесс.
Идентификатор процесса | Отображает идентификатор процесса.


Все готово для обновления

[image]

Все готово для обновления
Отправить отзыв

На странице «Сводка» можно просмотреть изменения, которые будут применены к экземпляру SQL Server. Чтобы продолжить установку, нажмите кнопку Установить.


Ход выполнения обновления

[image]

Ход выполнения обновления
Отправить отзыв

Страница «Ход выполнения установки» позволяет наблюдать за процессом установки обновления для экземпляра SQL Server и его компонентов.

Параметры

В таблице приводится название продукта SQL Server, имя его экземпляра и состояние установки.


Завершение работы мастера

[image]

Завершение работы мастера
Отправить отзыв

Страница «Завершение работы мастера» служит для подтверждения состояния установки.