Información general de la documentación de instalación de SQL Server

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Información general de la documentación de instalación de SQL Server
Enviar comentarios

La documentación de instalación de SQL Server está disponible en el medio de instalación y en línea.

Documentación disponible durante la instalación

Durante la instalación de SQL Server, haga clic en el botón Ayuda en la página Asistente para instalación o presione F1 en su teclado para obtener de forma inmediata la información necesaria para completar la operación.

Información general de los temas de instalación de SQL Server

Tanto si usa el Asistente para la instalación de SQL Server como el símbolo del sistema para instalar SQL Server, se puede preparar si lee las secciones siguientes:

  • Planear una instalación de SQL Server.

    Describe cómo preparar una instalación de SQL Server.

  • Instalar SQL Server 2012

    Describe las opciones para instalar SQL Server.

  • Instalar las características BI de SQL Server 2012

    Describe las opciones para instalar las características de SQL Server que forman parte de la plataforma de Microsoft BI, que incluyen Analysis Services, Integration Services, Reporting Services y varias aplicaciones cliente usadas para crear o trabajar con datos analíticos.

  • Actualizar a SQL Server 2012

    Describe las opciones para actualizarse a SQL Server.

Si va a instalar un clúster de conmutación por error de SQL Server, consulte lo siguiente:

  • Introducción a los clústeres de conmutación por error de SQL Server.

  • Antes de instalar los clústeres de conmutación por error.

Imagen de PieDePagina
Enviar comentarios acerca de este tema a Microsoft

© 2012 Microsoft Corporation. Todos los derechos reservados.


Acerca de los términos de licencia de SQL Server

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Acerca de los términos de licencia de SQL Server
Vea también Enviar comentarios

Los términos de licencia de software de Microsoft se copian en el equipo local cuando se instala SQL Server. En el caso de que se instalen en el mismo equipo varias instancias de la misma edición e idioma de SQL Server, se aplicará una única copia de los términos de licencia a todas las instancias de esa edición e idioma. Los archivos se copian en: %ProgramFiles%\Microsoft SQL Server\110\License Terms\ o en %ProgramFiles(x86)%\Microsoft SQL Server\110\License Terms\.

En el caso de que se instalen en el mismo equipo varias instancias de la misma edición e idioma de SQL Server, se aplicará una única copia de los términos de licencia a todas las instancias de esa edición e idioma.

El nombre de archivo de los términos de licencia indica la edición de SQL Server así como la edición de idioma de SQL Server. Por ejemplo:

  • License_DEV_ENU.txt para la edición en inglés de SQL Server Develope.

  • License_STD_ITA.txt para SQL Server Standard, edición en idioma italiano.

  • License_UA_JPN.txt para el Asesor de actualizaciones de SQL Server, edición en idioma japonés.

  • License_SQLNCLI_ENU.txt para SQL Server Native Client, edición en idioma inglés.

  • License_SQLXML4_KOR.txt para SQLXML, edición en idioma coreano.

  • License_SQLBI.rtf para SQL Server Business Intelligence Edition.

  • License_ENTCORE.rtf para SQL Server Enterprise Edition: licencia basada en núcleo.

  • License_ENT.rtf para licencia de servidor o CAL de SQL Server Enterprise Edition.

Los siguientes segmentos del nombre de archivo se usan para identificar las ediciones de SQL Server:

  • ENT – Enterprise Edition: licencia de servidor o de acceso de cliente (CAL)

  • ENTCORE – Enterprise Edition: licencia basada en núcleo

  • BI – Business Intelligence

  • DEV – Developer

  • STD – Standard

  • WEB – Web

  • EXPR – Express

Los siguientes segmentos del nombre de archivo se usan para identificar los idiomas correspondientes de SQL Server:

  • ENU - inglés

  • JPN - japonés

  • FRA - francés

  • ITA - italiano

  • KOR - coreano

  • DEU - alemán

  • ESN - español

  • CHS - chino simplificado

  • CHT - chino tradicional

  • PTB - portugués (Brasil)

  • RUS - ruso

Opciones de licencia de SQL Server

Para obtener más información acerca de las opciones de precio y licencia de SQL Server, vea el sitio web de Microsoft SQL Server (http://go.microsoft.com/fwlink/?LinkId=190955).

Vea también

Conceptos

Consideraciones acerca de las licencias para SQL Server
Declaración de privacidad de Microsoft SQL Server
Aviso legal de la documentación


Consideraciones acerca de las licencias para SQL Server

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Consideraciones acerca de las licencias para SQL Server
Vea también Enviar comentarios

Para obtener más información acerca de las opciones de licencia de SQL Server, vea este sitio web de Microsoft SQL Server.

Vea también

Referencia

Acerca de los términos de licencia de SQL Server

Conceptos

Declaración de privacidad de Microsoft SQL Server
Aviso legal de la documentación


Aviso legal de la documentación

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Aviso legal de la documentación
Enviar comentarios

Este documento se proporciona "tal cual". La información y los puntos de vista que se proporcionan en este documento, incluidas las direcciones URL y otras referencias a sitios web de Internet, pueden sufrir modificaciones sin previo aviso. Usted acepta el riesgo de utilizarlo.

Algunos ejemplos descritos aquí se proporcionan solo para servir de ilustración y son ficticios. No se pretende ni debería deducirse ninguna asociación o conexión real.

En este documento no se proporciona ningún derecho legal de ninguna propiedad intelectual de ningún producto de Microsoft. Puede copiar y utilizar este documento para su propia referencia.

© 2012 Microsoft. Reservados todos los derechos.

Microsoft, Active Directory, ActiveX, Bing Maps, Excel, IntelliSense, MSDN, MS-DOS, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual Studio, Windows, Windows NT, Windows Server y Windows Vista son marcas registradas del grupo de empresas de Microsoft. SAP NetWeaver es marca registrada de SAP AG en Alemania y otros países. Las demás marcas comerciales pertenecen a sus respectivos propietarios.

Directiva de documentación para soporte y actualización de SQL Server

La documentación del software de Microsoft SQL Server 2012 incluye los Libros en pantalla de Microsoft para Microsoft SQL Server 2012, documentación de la instalación, documentación de referencia para desarrolladores, tutoriales, archivos léame, documentos de problemas conocidos, código y bases de datos de ejemplo y artículos de Knowledge Base publicados por Microsoft, que incluyen contenido acerca de las características y funcionalidad de SQL Server. Esta directiva de compatibilidad y actualización se aplica a la documentación de Microsoft SQL Server 2012, incluidos los archivos léame de las versiones y Service Pack de Microsoft SQL Server 2012. Un archivo léame se considera una extensión de los Libros en pantalla de Microsoft SQL Server 2012.

El objetivo principal de las muestras que se incluyen en esta documentación es ilustrar un concepto o un uso razonable de una instrucción o cláusula determinada. La mayoría de las muestras no incluyen todo el código que debería tener un sistema totalmente en producción, puesto que se ha eliminado parte de la validación de datos comunes y el control de errores para resaltar en la muestra un determinado concepto o instrucción. No hay soporte técnico disponible para estas muestras ni para el código fuente incluido.

En algunos casos, una característica determinada de Microsoft SQL Server 2012 no se ha probado o desarrollado suficientemente y no está destinada a usarse. Tales características se incluyen a menudo como marcadores. Por consiguiente, ciertas características que están contenidas en el software no están documentadas. Las características que no están documentadas o que se incluyen como una anotación para uso interno de Microsoft no están destinadas a usarse y los servicios de soporte al cliente de Microsoft no las admiten en su servicio. A menos que la documentación de Microsoft SQL Server 2012 indiquen lo contrario, el contenido de terceros, incluidos los problemas que sean resultado de utilizar dicho contenido con Microsoft SQL Server 2012, no se admite en los servicios de soporte al cliente de Microsoft y también puede provocar la pérdida de datos. Los servicios de soporte al cliente de Microsoft tampoco proporcionan soporte técnico para las bases de datos o aplicaciones que aprovechen o usen puntos de entrada indocumentados, como las API que no estén documentadas; por ejemplo, procedimientos almacenados, procedimientos almacenados extendidos, funciones, vistas, tablas, columnas, propiedades o metadatos.

Puede que tampoco funcionen las actualizaciones de servidor y de base de datos a versiones futuras de Microsoft SQL Server 2012 para las aplicaciones y bases de datos que aprovechen o utilicen puntos de entrada no documentados y no se admiten. No se admite el uso de las características y funcionalidad de SQL Server que se incluyen en Microsoft SQL Server y que no se documentan en la documentación de Microsoft SQL Server 2012 para usarse y tal uso puede provocar la pérdida de datos.


Declaración de privacidad de Microsoft SQL Server

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Declaración de privacidad de Microsoft SQL Server
Enviar comentarios

Para obtener información acerca de los componentes de recopilación de datos de usuario de Microsoft SQL Server 2012, vea la declaración de privacidad de SQL Server


Ubicaciones de archivos para las instancias predeterminadas y con nombre de SQL Server

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Ubicaciones de archivos para las instancias predeterminadas y con nombre de SQL Server
Vea también Enviar comentarios

Una instalación de SQL Server se compone de una o más instancias independientes. Una instancia, ya sea predeterminada o con nombre, tiene su propio conjunto de archivos de programa y de datos, así como un conjunto de archivos comunes compartidos entre todas las instancias de SQL Server del equipo.

En una instancia de SQL Server que incluya el Motor de base de datos, Analysis Services y Reporting Services, cada componente tiene un conjunto completo de datos y de archivos ejecutables, así como de archivos comunes compartidos por todos los componentes.

Para aislar las ubicaciones de instalación de cada componente, se generan identificadores de instancia únicos para cada componente de una determinada instancia de SQL Server.

Nota importante Importante

Los archivos de programa y los archivos de datos no se pueden instalar en una unidad de disco extraíble, en un sistema de archivos que use compresión, en un directorio en el que haya ubicados archivos del sistema ni en unidades compartidas en una instancia en clúster de conmutación por error.

No elimine ninguno de los directorios siguientes ni su contenido: Binn, Data, Ftdata, HTML o 1033. Si fuera necesario, puede eliminar otros directorios; no obstante, es posible que no pueda recuperar algunas de las funciones o datos perdidos sin tener que desinstalar y volver a instalar SQL Server. No elimine ni modifique ninguno de los archivos .htm del directorio HTML. Son necesarios para que las herramientas de SQL Server funcionen correctamente.

Archivos compartidos para todas las instancias de SQL Server

Los archivos comunes que usan todas las instancias en un único equipo se instalan en la carpeta <drive>:\Archivos de programa\Microsoft SQL Server\110\, donde <drive> es la letra de unidad donde están instalados los componentes. La unidad predeterminada es normalmente la C.

Ubicaciones de archivos y asignaciones del Registro

Durante la instalación de SQL Server, se genera un identificador de instancia en cada componente de servidor. Los componentes de servidor de esta versión de SQL Server son el Motor de base de datos, Analysis Services y Reporting Services.

El identificador de instancia predeterminado se construye con el formato siguiente:

  • MSSQL para el Motor de base de datos, seguido del número de versión principal, un guión bajo y la versión secundaria cuando proceda, un punto y, a continuación, el nombre de instancia.

  • MSAS para Analysis Services, seguido del número de versión principal, un guión bajo y la versión secundaria cuando proceda, un punto y, a continuación, el nombre de instancia.

  • MSRS para Reporting Services, seguido del número de versión principal, un guión bajo y la versión secundaria cuando proceda, un punto y, a continuación, el nombre de instancia.

A continuación se enumeran algunos ejemplos de identificadores de instancia predeterminados de esta versión de Microsoft SQL Server 2012:

  • MSSQL11.MSSQLSERVER para una instancia predeterminada de Microsoft SQL Server 2012.

  • MSAS11.MSSQLSERVER para una instancia predeterminada de Analysis Services.

  • MSSQL11.MyInstance para una instancia con nombre de Microsoft SQL Server 2012 denominada "MyInstance".

La estructura de directorios para una instancia con nombre de Microsoft SQL Server 2012 que incluyera el Motor de base de datos y Analysis Services, se denominara "MyInstance" y estuviera instalada en los directorios predeterminados sería como sigue:

  • C:\Archivos de programa\Microsoft SQL Server\MSSQL11.MyInstance\

  • C:\Archivos de programa\Microsoft SQL Server\MSASSQL11.MyInstance\

Puede especificar cualquier valor para el identificador de instancia, pero evite los caracteres especiales y las palabras clave reservadas. Para obtener más información, vea Reserved Keywords (Setup).

Puede especificar un identificador de instancia no predeterminado durante la instalación de SQL Server. En lugar de <Archivos de programa>\Microsoft SQL Server, si el usuario decide cambiar el directorio de instalación predeterminado, se utilizará una <ruta de acceso personalizada>\Microsoft SQL Server. Tenga en cuenta que no se admiten identificadores de instancia que comienzan por un subrayado (_) o que contienen el signo de almohadilla (#) o el signo de dólar ($).

Nota Nota

Integration Services y los componentes de cliente no reconocen las instancias y, por consiguiente, no tienen asignado un identificador de instancia. De forma predeterminada, los componentes que no tienen en cuenta las instancias se instalan en un único directorio: <unidad>:\Archivos de programa\Microsoft SQL Server\110\. Si cambia la ruta de instalación de un componente compartido, cambiará también la de los demás componentes compartidos. Las instalaciones posteriores instalan componentes que no reconocen instancias en el mismo directorio que la instalación original.

SQL Server Analysis Services es el único componente de SQL Server que permite cambiar el nombre de las instancias después de la instalación. Si se cambia el nombre una instancia de Analysis Services, el identificador de la instancia no cambiará. Después de completarse el cambio de nombre de la instancia, los directorios y claves del Registro continuarán utilizando el identificador de instancia creado durante la instalación.

El subárbol del Registro se crea en HKLM\Software\Microsoft\Microsoft SQL Server\<Instance_ID> para los componentes que reconocen las instancias. Por ejemplo,

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL11.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSASSQL11.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.110

El Registro también mantiene una asignación de identificador de instancia a nombre de instancia. La asignación de Id. de instancia a nombre de instancia se mantiene de la siguiente forma:

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\SQL] "InstanceName"="MSSQL11"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\OLAP] "InstanceName"="MSASSQL11"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\RS] "InstanceName"="MSRSSQL11"

Especificar rutas de acceso a los archivos

Durante la instalación, puede cambiar la ruta de instalación de las siguientes características:

La ruta de instalación solo aparece para las características cuya carpeta de destino puede configurar el usuario:

Componente | Ruta de acceso predeterminada1, 2 | Ruta de acceso configurable3 o fija
Componentes de servidor de Motor de base de datos | \Archivos de programa\Microsoft SQL Server\MSSQL11.<IDDeInstancia>\ | Configurable
Archivos de datos de Motor de base de datos | \Archivos de programa\Microsoft SQL Server\MSSQL11.<IDDeInstancia>\ | Configurable
Servidor Analysis Services | \Archivos de programa\Microsoft SQL Server\MSAS11.<IDDeInstancia>\ | Configurable
Archivos de datos de Analysis Services | \Archivos de programa\Microsoft SQL Server\MSAS11.<IDDeInstancia>\ | Configurable
Servidor de informes de Reporting Services | \Archivos de programa\Microsoft SQL Server\MSRS11.<IDDeInstancia>\Reporting Services\ReportServer\Bin\ | Configurable
Administrador de informes de Reporting Services | \Archivos de programa\Microsoft SQL Server\MSRS11.<IDDeInstancia>\Reporting Services\ReportManager\ | Ruta de acceso fija
Integration Services | <Directorio de instalación>\110\DTS\ | Configurable4
Master Data Services | <Directorio de instalación>\110\Master Data Services | Configurable4
Componentes de cliente | <Directorio de instalación>\110\Tools\ | Configurable4
Objetos COM del servidor y la replicación | <unidad>:\Archivos de programa\Microsoft SQL Server\110\COM\5 | Ruta de acceso fija
DLL de componentes de Integration Services del motor en tiempo de ejecución de transformación de datos, el motor de canalización de transformación de datos y la utilidad de símbolo del sistema dtexec | <unidad>:\Archivos de programa\Microsoft SQL Server\110\DTS\Binn | Ruta de acceso fija
DLL que proporcionan compatibilidad con la conexión administrada para Integration Services | <unidad>:\Archivos de programa\Microsoft SQL Server\110\DTS\Connections | Ruta de acceso fija
DLL para cada tipo de enumeración que admita Integration Services | <unidad>:\Archivos de programa\Microsoft SQL Server\110\DTS\ForEachEnumerators | Ruta de acceso fija
Servicio Explorador de SQL Server, proveedores WMI | <unidad>:\Archivos de programa\Microsoft SQL Server\110\Shared\ | Ruta de acceso fija
Componentes que se comparten entre todas las instancias de SQL Server | <unidad>:\Archivos de programa\Microsoft SQL Server\110\Shared\ | Ruta de acceso fija

1Asegúrese de que la carpeta \Archivos de programa\Microsoft SQL Server\ está protegida con permisos limitados.

2La unidad predeterminada para estas ubicaciones es systemdrive, normalmente la unidad C.

3Las rutas de instalación para características secundarias vienen determinadas por la ruta de instalación de la característica primaria.

4Una sola ruta de instalación se comparte entre Integration Services y los componentes de cliente. Si cambia la ruta de instalación de un componente, cambiará también la de los otros componentes. Las instalaciones posteriores instalan los componentes en la misma ubicación que la instalación original.

5Este directorio es utilizado por todas las instancias de SQL Server en un equipo. Si aplica una actualización a alguna de las instancias del equipo, los cambios en los archivos de esta carpeta afectarán a todas las instancias en el equipo. Cuando agregue características a una instalación existente, no podrá cambiar la ubicación de una característica instalada anteriormente, ni especificar dicha ubicación para una característica nueva. Debe instalar características adicionales en los directorios ya establecidos por el programa de instalación, o desinstalar y volver a instalar el producto.

Nota Nota

En configuraciones en clúster, deberá seleccionar una unidad local que esté disponible en cada nodo del clúster.

Cuando especifique una ruta de instalación durante la instalación de los componentes de servidor o de los archivos de datos, el programa de instalación utilizará el identificador de instancia además de la ubicación especificada para el programa y los archivos de datos. El programa de instalación no utiliza el identificador de instancia para las herramientas y otros archivos compartidos. Tampoco utiliza ningún identificador de instancia para el programa y los archivos de datos de Analysis Services, aunque lo use para el depósito de Analysis Services.

Si establece una ruta de instalación para la característica Motor de base de datos, el programa de instalación de SQL Server utilizará dicha ruta como directorio raíz de todas las carpetas específicas de la instancia en dicha instalación, incluido SQL Data Files. En este caso, si establece el directorio raíz en "C:\Archivos de programa\Microsoft SQL Server\MSSQL11\MSSQL\", los directorios específicos de la instancia se agregarán al final de dicha ruta de acceso.

Los clientes que decidan usar la funcionalidad de actualización de USESYSDB en el Asistente para la instalación de SQL Server (modo de UI del programa de instalación) pueden llegar con facilidad a una situación en la que el producto se instale en una estructura de carpetas recursiva. Por ejemplo, <SQLProgramFiles>\MSSQL11\MSSQL\MSSQL11\MSSQL\Data\. En su lugar, para usar la característica USESYSDB, establezca una ruta de instalación para la característica de archivos de datos de SQL (SQL Data Files) y no para la característica Motor de base de datos.

Nota Nota

Los archivos de datos deberían encontrarse en un directorio secundario denominado Data. Por ejemplo, especifique C:\Archivos de programa\Microsoft SQL Server\MSSQL11\ para especificar la ruta raíz del directorio de datos de las bases de datos de sistema durante la actualización, si los archivos de datos se encuentran en C:\Archivos de programa\Microsoft SQL Server\MSSQL11\MSSQL\Data.

Vea también

Referencia

Configuración del motor de base de datos - Directorios de datos
Configuración de Analysis Services - Directorios de datos


Ver y leer los archivos de registro de instalación de SQL Server

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Ver y leer los archivos de registro de instalación de SQL Server
Vea también Enviar comentarios

Cada ejecución del programa de instalación crea archivos de registro con una nueva carpeta de registro con marca de tiempo en %Archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\. El formato del nombre de la carpeta de registro con marca de tiempo es AAAAMMDD_hhmmss. Cuando el programa de instalación se ejecuta en modo desatendido, los registros se crean en % temp%\sqlsetup*.log. Todos los archivos de la carpeta de registro se almacenan en el archivo Log*.cab en su carpeta respectiva.

Una solicitud de instalación típica pasa por tres fases de ejecución:

  1. Texto de reglas globales

  2. Actualización de componentes

  3. Acción solicitada por el usuario

En cada fase, el programa de instalación genera registros de detalle y de resumen con registros adicionales creados según corresponda. Se llama al programa de instalación al menos tres veces por acción de instalación solicitada por el usuario.

Los archivos de almacén de datos contienen una instantánea del estado de todos los objetos de configuración sometidos a seguimiento por el proceso de instalación y son útiles para solucionar errores de configuración. Se crean volcados de archivo XML para objetos de almacén de datos para cada fase de ejecución. Se guardan en su propia subcarpeta de registro debajo de la carpeta de registro con marca de tiempo, de la manera siguiente:

  • Datastore_GlobalRules

  • Datastore_ComponentUpdate

  • Datastore

En las secciones siguientes se describen los archivos de registro de instalación de SQL Server.

Texto de resumen

Información general

Este archivo muestra los componentes de SQL Server que se detectaron durante la instalación, el entorno del sistema operativo, los valores de parámetros de línea de comandos, si se especifican, y el estado general de cada MSI/MSP que se ejecutó.

El registro se organiza en las secciones siguientes:

  • Un resumen general de la ejecución

  • Las propiedades y la configuración del equipo en el que se ejecutó el programa de instalación de SQL Server

  • Las características del producto de SQL Server instaladas anteriormente en el equipo

  • Descripción de la versión de instalación y las propiedades del paquete de instalación

  • Configuración de entrada en tiempo de ejecución proporcionada durante la instalación

  • Ubicación del archivo de configuración

  • Detalles de los resultados de la ejecución

  • Reglas globales

  • Reglas específicas del escenario de instalación

  • Reglas con errores

  • Ubicación del archivo de informe de reglas

Ubicación

Se encuentra en %Archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\.

Para encontrar errores en el archivo de texto de resumen, busque en el archivo usando las palabras clave "error" o "failed".

Summary_engine-base_AAAAMMDD_HHMMss.txt

Información general

El archivo base de registro de resumen es similar al archivo de resumen y se genera durante el flujo de trabajo principal.

Ubicación

Se encuentra en %Archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMDD_HHMM>\.

Summary_engine-base_AAAAMMDD_HHMMss_ComponentUpdate.txt

Información general

El archivo de registro de resumen de actualización de componentes es similar al archivo de resumen y se genera durante el flujo de trabajo de actualización de componentes.

Ubicación

Se encuentra en %Archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMDD_HHMM>\.

Summary_engine-base_<númeroVersión>MMDD_HHMMss_GlobalRules.txt

Información general

El archivo de registro de resumen de reglas globales es similar al archivo de resumen y se genera durante el flujo de trabajo de reglas globales.

Ubicación

Se encuentra en %Archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMDD_HHMM>\.

Detail.txt

Información general

El archivo Detail.txt se genera durante el flujo de trabajo principal, como la instalación o la actualización, y proporciona los detalles de la ejecución. Los registros del archivo se generan en función del momento en que se invocó cada acción durante la instalación y muestran el orden que se ejecutaron las acciones, y sus dependencias.

Ubicación

Se encuentra en %Archivos de programa%\Microsoft SQL Server\110\Setup

Bootstrap\Log\<AAAAMMDD_HHMM>\Detail.txt.

Si se produce un error durante el proceso de instalación, la excepción o el error se registran al final de este archivo. Para encontrar los errores en este archivo, examine primero el final del archivo y, a continuación, realice una búsqueda en el mismo utilizando las palabras clave "error" o "exception".

Detail_ComponentUpdate.txt

Información general

El archivo Detail_ComponentUpdate.txt se genera durante el flujo de trabajo de actualización de componentes y es similar al archivo Detail.txt.

Ubicación

Se encuentra en %Archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMDD_HHMM>\.

Detail_GlobalRules.txt

Información general

El archivo Detail_GlobalRules.txt se genera durante la ejecución de las reglas globales y es similar al archivo Detail.txt.

Ubicación

Se encuentra en %Archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMDD_HHMM>\.

Archivos de registro de MSI

Información general

Los archivos de registro de MSI proporcionan detalles del proceso de paquete de instalación. Los genera el programa MSIEXEC durante la instalación del paquete especificado.

Tipos de archivos de registro de MSI:

  • <Característica>_<Arquitectura>_<Interacción>.log

  • <Característica>_<Arquitectura>_<Idioma>_<Interacción>.log

  • <Característica>_<Arquitectura>_<Interacción>_<flujoDeTrabajo>.log

Ubicación

Los archivos de registro de MSI se encuentran en %Archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMDD_HHMM>\<Nombre>.log.

Al final del archivo se encuentra un resumen de la ejecución que incluye el estado de corrección o error y las propiedades. Para encontrar el error en el archivo de MSI, busque "value 3" y, normalmente, los errores se mostrarán cerca de la cadena.

ConfigurationFile.ini

Información general

El archivo de configuración contiene la configuración de entrada que se proporciona durante la instalación. Se puede usar para reiniciar la instalación sin tener que especificar la configuración manualmente. Sin embargo, las contraseñas de las cuentas, los PID y algunos parámetros no se guardan en el archivo de configuración. La configuración se puede agregar al archivo o se puede proporcionar usando la línea de comandos o la interfaz de usuario del programa de instalación. Para obtener más información, vea Instalar SQL Server 2012 usando un archivo de configuración (http://go.microsoft.com/fwlink/?LinkId=231296).

Ubicación

Se encuentra en %Archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMDD_HHMM>\.

SystemConfigurationCheck_Report.htm

Información general

El informe de comprobación de la configuración del sistema contiene una descripción breve de cada regla ejecutada y el estado de ejecución.

Ubicación

Se encuentra en %Archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMDD_HHMM>\.

Vea también

Conceptos

Solucionar problemas de una Instalación de SQL Server


Solucionar problemas de una Instalación de SQL Server

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Solucionar problemas de una Instalación de SQL Server
Vea también Enviar comentarios

Para ver información acerca de la solución de problemas de instalación y actualización, vea el documento Léame de SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=196910).

Vea también

Conceptos

Ver y leer los archivos de registro de instalación de SQL Server


SQL Server Setup User Interface Reference

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

SQL Server Setup User Interface Reference
Enviar comentarios

En esta sección se describen las opciones de instalación presentadas por el Asistente para la instalación de SQL Server .


Aceptar los términos de licencia

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Aceptar los términos de licencia
Vea también Enviar comentarios

Use la página Aceptar los términos de la licencia del Asistente para la instalación de SQL Server con el fin de aceptar los términos de la licencia de esta versión de SQL Server.

Puede imprimir el contrato de licencia o copiarlo al Portapapeles. Para continuar, acepte los términos de licencia y, a continuación, haga clic en Siguiente. Para cerrar la instalación, haga clic en Cancelar.

Informes de uso de características

Si habilita la creación de informes de uso de características, SQL Server se configura para enviar periódicamente un informe a Microsoft. Los informes incluyen información acerca de la configuración del hardware y de cómo se usa SQL Server y los componentes. Microsoft utilizará los datos de uso de características para mejorar SQL Server. Entre los componentes de SQL Server que supervisa esta característica se incluyen los siguientes:

  • Motor de base de datos

  • Analysis Services

  • Reporting Services

  • Integration Services

  • Replicación

  • Herramientas de datos de SQL Server (SSDT)

  • Programa de instalación de SQL Server

La información sobre el uso de características se envía a Microsoft, donde se almacena limitando el acceso.

Para deshabilitar la creación de informes de uso de características una vez completada la instalación, utilice la herramienta Informes de errores y uso de SQL Server en el menú Herramientas de configuración de SQL Server.

En el caso de acciones del programa de instalación como la instalación, actualización, reparación, etc., la información se recopila y se carga únicamente durante la ejecución del mismo

En el caso de los demás componentes de SQL Server, la información se recopila una vez al día para todas las instancias habilitadas de SQL Server. De forma predeterminada, la hora de recopilación se establece en la medianoche para reducir la carga del servidor. Si desea cambiar la hora de recopilación, puede editar manualmente la clave del Registro que la controla. Cada instancia de SQL Server tiene su propia clave del Registro:

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL11.<INSTANCEID>\CPE\TimeofReporting

El valor de esta clave del Registro contiene la hora de la recopilación que se va a ejecutar como número de minutos a partir de las 00:00 (medianoche). Por ejemplo, un valor de 60 ejecutaría la recopilación a la 1:00 a. m., un valor de 1200 ejecutaría la recopilación a las 8:00 p. m., etc.

Vea también

Referencia

Acerca de los términos de licencia de SQL Server


Agregar nodo de clúster de conmutación por error de SQL Server

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Agregar nodo de clúster de conmutación por error de SQL Server
Vea también Enviar comentarios

El programa de instalación de SQL Server valida la configuración del equipo antes de que se complete la operación de instalación. Durante la instalación de SQL Server, el Comprobador de configuración del sistema (SCC) examina el equipo en el que se instalará SQL Server. El SCC comprueba las condiciones que impiden una operación de instalación correcta de SQL Server. Antes de que el programa de instalación inicie el Asistente para la instalación de SQL Server, el SCC recupera el estado de cada elemento. A continuación, compara el resultado con las condiciones necesarias y proporciona instrucciones para evitar problemas de bloqueo.

La comprobación de la configuración del sistema genera un informe que contiene una descripción breve de cada regla ejecutada y el estado de ejecución. El informe de comprobación de la configuración del sistema se encuentra en %archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMDD_HHMM>\.

Antes de ejecutar la operación de instalación, revise los temas siguientes:

  1. Requisitos de hardware y software para instalar SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Características compatibles con las ediciones de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Consideraciones de seguridad para una instalación de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versiones en idioma local en SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Otras referencias:

  1. Actualizaciones de ediciones y versiones admitidas(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar los clústeres de conmutación por error(http://go.microsoft.com/fwlink/?LinkId=235034)

Vea también

Referencia

Reglas auxiliares del programa de instalación


Configuración de Analysis Services - Aprovisionamiento de cuentas

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Configuración de Analysis Services - Aprovisionamiento de cuentas
Vea también Enviar comentarios

Use esta página para establecer el modo de servidor y para conceder permisos administrativos a los usuarios o servicios que requieran acceso sin restricciones a Analysis Services. La instalación no agrega automáticamente el grupo Windows local BUILTIN\Administrators al rol de administrador del servidor de Analysis Services de la instancia que está instalando. Si desea agregar el grupo local de administradores al rol de administrador del servidor, debe especificar ese grupo explícitamente.

Si está instalando PowerPivot para SharePoint, asegúrese de conceder permisos administrativos a los administradores de la granja de SharePoint o a los administradores de servicios que sean responsables de una implementación del servidor de PowerPivot en una granja de SharePoint Server 2010. Para obtener más información acerca de la instalación de Servicio PowerPivot y los requisitos de la cuenta de servicio, vea Instalar PowerPivot para SharePoint.

Opciones

Modo de servidor: permite especificar el tipo de bases de datos de Analysis Services que se pueden implementar en el servidor. Los modos de servidor se determinan durante la instalación y no se pueden modificar posteriormente. Cada modo es mutuamente exclusivo, lo que significa que se necesitarán dos instancias de Analysis Services, cada una configurada para un modo diferente, para admitir soluciones de modelo OLAP clásicas y tabulares.

Especificar administradores: debe especificar al menos un administrador de servidor para la instancia de SQL Server. Los usuarios o grupos que especifique serán miembros del rol de administrador del servidor de la instancia de Analysis Services que está instalando. Debe haber cuentas de usuario de dominio de Windows en el mismo dominio que el del equipo en el que se instala el software.

Nota Nota

Control de cuentas de usuario (UAC) es una característica de seguridad de Windows que requiere que un administrador apruebe específicamente acciones administrativas o aplicaciones antes de que se puedan ejecutar. Dado que UAC está activado de forma predeterminada, se le solicitará que permita las operaciones concretas que requieren privilegios elevados. Puede configurar UAC para cambiar el comportamiento predeterminado o personalizar UAC para programas concretos. Para obtener más información sobre UAC y la configuración de UAC, vea la Guía paso a paso de Control de cuentas de usuario de Windows y el tema sobre control de cuentas de usuario (Wikipedia).

Vea también

Otros recursos

Cambiar las cuentas de servicio y las contraseñas (PowerPivot para SharePoint)
Configurar la cuenta de servicio de Analysis Services
Configurar cuentas de servicio de Windows


Configuración de Analysis Services - Directorios de datos

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Configuración de Analysis Services - Directorios de datos
Vea también Enviar comentarios

Los directorios predeterminados de la tabla siguiente los puede configurar el usuario durante la instalación de SQL Server. Los permisos para obtener acceso a estos archivos se concede a los administradores locales y a los miembros del grupo de seguridad SQLServerMSASUser$<instancia> que se crea y suministra durante la instalación.

Descripción

Directorio predeterminado

Recomendaciones

Directorio raíz de datos

C:\Archivos de programa\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Data\

Asegúrese de que la carpeta \Archivos de programa\Microsoft SQL Server\ está protegida con permisos limitados. El rendimiento de Analysis Services depende, en muchas configuraciones, del rendimiento del espacio de almacenamiento en el que se ubica el directorio de datos. Coloque este directorio en el almacenamiento asociado al sistema cuyo rendimiento sea máximo. En las instalaciones del clúster de conmutación por error, asegúrese de que los directorios de datos están ubicados en el disco compartido.

Directorio de archivos de registro

C:\Archivos de programa\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Log\

Este es el directorio para los archivos de registro de Analysis Services e incluye el registro FlightRecorder. Si incrementa la duración de la Caja negra SQL, asegúrese de que el directorio del registro tenga espacio suficiente.

Directorio temporal

C:\Archivos de programa\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Temp\

Coloque el directorio Temp en el subsistema de almacenamiento de alto rendimiento.

Directorio de copia de seguridad

C:\Archivos de programa\Microsoft SQL Server\MSAS11.<InstanceID>\OLAP\Backup\

Este es el directorio para los archivos de copia de seguridad predeterminados de Analysis Services. En las instalaciones de PowerPivot para SharePoint, es también donde los Servicios del sistema de PowerPivot almacenan en caché los archivos de datos PowerPivot.

Asegúrese de que se han establecido los permisos adecuados para evitar la pérdida de datos y de que el grupo de usuarios del servicio Analysis Services tiene los permisos apropiados para escribir en el directorio de copia de seguridad. No se permite usar una unidad asignada para los directorios de copia de seguridad.

Notas

  • Las instancias de Analysis Services que se implementan en una granja de SharePoint almacenan archivos de aplicación, archivos de datos y propiedades de bases de datos de contenido y de aplicación de servicio.

  • Cuando agregue características a una instalación existente, no podrá cambiar la ubicación de una característica instalada anteriormente, ni especificar dicha ubicación para una característica nueva.

  • Si especifica los directorios de instalación no predeterminados, asegúrese de que las carpetas de instalación sean únicas para esta instancia de SQL Server. Ninguno de los directorios de este cuadro de diálogo se debe compartir con los de otras instancias de SQL Server. Los componentes de Motor de base de datos y Analysis Services en una instancia de SQL Server también deben instalarse en directorios independientes.

  • Los archivos de programa y los archivos de datos no se pueden instalar en las situaciones siguientes:

    • En una unidad de disco extraíble

    • En un sistema de archivos que usa compresión

    • En un directorio que contiene archivos del sistema

    • En unidades compartidas en una instancia en clúster de conmutación por error

Vea también

Conceptos

Ubicaciones de archivos para las instancias predeterminadas y con nombre de SQL Server


Selección de disco en clúster

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Selección de disco en clúster
Enviar comentarios

Utilice la página Selección de disco de clúster del Asistente para la instalación de SQL Server para seleccionar el recurso de disco de clúster compartido para el clúster de conmutación por error de SQL Server. El disco de clúster es donde se colocarán los datos de SQL Server.

Un disco de clúster compartido no es obligatorio para las instalaciones de clúster del Motor de base de datos de SQL Server. Un servidor de archivos de SMB es un almacenamiento admitido para las instalaciones de clúster de conmutación por error del Motor de base de datos de SQL Server y puede especificarse mediante la página Motor de base de datos – Directorios de datos antes de completar la instalación.

Nota de advertencia Advertencia

Si ha seleccionado Analysis Services para que se instale, debe especificar un disco de clúster compartido.

Si tiene previsto habilitar FILESTREAM en esta instancia de clúster de conmutación por error de SQL Server, debe especificar un disco de clúster compartido.

Opciones

Discos compartidos

Seleccione un disco único en la lista. El disco de clúster es donde se colocarán los datos de SQL Server.

Solo puede especificarse un disco. Si selecciona el grupo que contiene el recurso de quórum de clúster, se mostrará un mensaje de advertencia. Se recomienda no realizar la instalación en el recurso de quórum de clúster.

Discos compartidos disponibles

Muestra una lista de los discos disponibles, si cada uno está calificado como disco compartido, y una descripción de cada recurso de disco.


Configuración de red en clúster

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Configuración de red en clúster
Enviar comentarios

Utilice la página Selección de red en clúster para especificar los recursos de red para la instancia en clúster de conmutación por error.

Opciones

Nombre de red en clúster de conmutación por error de SQL Server: Este es el nombre utilizado para identificar la instancia del clúster de conmutación por error en la red.

Configuración de red: Especifique el tipo IP y la dirección IP para la instancia del clúster de conmutación por error.

Durante las operaciones Agregar nodo y Quitar nodo, SQL Server muestra una lista de solo lectura de las direcciones IP existentes para el clúster de conmutación por error de SQL Server.

  • Instalación integrada:

    • Si va a agregar un nodo que admita un conjunto idéntico de subredes de red que admitan los nodos existentes del clúster de conmutación por error de SQL Server, no se puede agregar ninguna dirección IP adicional. La configuración de dependencia permanece sin modificar.

    • Si va a agregar un nodo que admita un subconjunto de las subredes que admitan los nodos existentes en el clúster de conmutación por error de SQL Server, no se pueden agregar recursos de dirección IP adicionales. La dependencia de recursos de direcciones IP se establece en OR para reflejar que todas las direcciones IP especificadas no son válidas en todos los nodos de clúster.

    • Si va a agregar un nodo que admita subredes además de las subredes que ya admitían los nodos existentes en el clúster de conmutación por error de SQL Server, tiene la opción de agregar nuevas direcciones IP válidas. Si se especifican nuevas direcciones IP, la dependencia de recursos de direcciones IP se establece en OR para reflejar que todas las direcciones IP especificadas no son válidas en todos los nodos de clúster.

    • Si va a agregar un nodo que sea compatible con subredes de red adicionales, pero no es compatible con ninguna de las subredes admitidas por los nodos existentes en el clúster de conmutación por error de SQL Server, tiene que agregar más direcciones IP. La dependencia de recursos de direcciones IP se establece en OR para reflejar que todas las direcciones IP especificadas no son válidas en todos los nodos de clúster.

  • Instalación avanzada: durante el paso para completar la instalación, especifique la dirección IP de todos los nodos y subredes de su instancia del clúster de conmutación por error. Puede especificar varias direcciones IP para un clústeres de conmutación por error de varias subredes, pero solo se admite una dirección IP por subred. Cada nodo preparado debe ser propietario de al menos una dirección IP. Si tiene varias subredes en su clúster de conmutación por error de SQL Server, se le solicitará que establezca la dependencia de recursos de dirección IP en OR. Quitar nodo:

    • Si el resto de direcciones IP se admite en los nodos restantes, se le pide que establezca la dependencia de recursos de dirección IP en AND.

    • Si el resto de direcciones IP no se admiten en todos los nodos restantes, la dependencia de recursos de dirección IP se deja como OR.


Configuración del nodo de clúster

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Configuración del nodo de clúster
Enviar comentarios

Utilice la página Configuración de nodo clúster para agregar o quitar nodos de una instancia del clúster de conmutación por error. Para instalar o actualizar un clúster de conmutación por error de SQL Server, debe ejecutar el programa de instalación en cada nodo del clúster de conmutación por error. Para agregar un nodo a un clúster de conmutación por error de SQL Server existente, debe ejecuta el programa de instalación de SQL Server en el nodo que se va a agregar a la instancia del clúster de conmutación por error de SQL Server.

Opciones

Nombre de instancia de SQL Server: utilice la lista desplegable para seleccionar la instancia en clúster de conmutación por error de SQL Server que desea modificar.

Nombre de este nodo: Este campo se rellenará con el nombre del equipo que está ejecutando el programa de instalación de SQL Server. Este es el nodo de clúster de conmutación por error que se agregará a, o se quitará de, la instancia en clúster de conmutación por error de SQL Server.


Configuración de nodo de clúster (Completar)

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Configuración de nodo de clúster (Completar)
Enviar comentarios

Utilice la página Configuración de nodo de clúster (completada) para especificar una instancia existente de SQL Server que se ha preparado para la agrupación en clústeres. Para instalar o actualizar un clúster de conmutación por error de SQL Server, debe ejecutar el programa de instalación en cada nodo del clúster de conmutación por error. Para agregar un nodo a un clúster de conmutación por error de SQL Server existente, debe ejecutar el programa de instalación de SQL Server en el nodo que se va a agregar a la instancia del clúster de conmutación por error de SQL Server.

Opciones

En las listas desplegables:

  • Nombre de instancia de SQL Server: seleccione el nombre de instancia para el clúster de conmutación por error de SQL Server.

  • Nombre de este nodo: este campo se rellena automáticamente con el nombre del equipo en el que se ejecuta el programa de instalación de SQL Server.

  • Nombre de red en clúster de conmutación por error de SQL Server: este campo no se rellena automáticamente. Especifique el nombre de red para la nueva instancia en clúster de conmutación por error de SQL Server. Este es el nombre que identifica la instancia en clúster de conmutación por error en la red.


Grupo de recursos de clúster

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Grupo de recursos de clúster
Vea también Enviar comentarios

Use la página Grupo de recursos de clúster para especificar el disco donde se ubicarán los recursos de servidor virtual de SQL Server.

Opciones

Especifique el nombre del grupo de recursos de clúster de SQL Server. Tiene dos opciones:

  • Use la lista desplegable para especificar un grupo existente.

  • Escriba el nombre del grupo que desea crear. Tenga en cuenta que el nombre "Available storage" no es un nombre de grupo válido.

Vea también

Otros recursos

Crear un nuevo clúster de conmutación por error de SQL Server


Directiva de seguridad de clúster

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Directiva de seguridad de clúster
Enviar comentarios

Utilice la página Directiva de seguridad de clúster para configurar la directiva de seguridad de la instancia del clúster de conmutación por error.

Opciones

Especifique grupos de dominio global o local para servicios de clúster. Todos los permisos de recursos se controlan mediante grupos de nivel de dominio que incluyen cuentas de servicio de SQL Server como miembros de grupo. Para obtener más información acerca de la funcionalidad de los identificadores de seguridad de servicio (SID) de Windows Server 2008, vea Configurar cuentas de servicio de Window.

Si va a instalar una instancia de los clústeres de conmutación por error de Microsoft SQL Server 2012 en un dominio de modo mixto de Windows 2000, debe usar los grupos globales del dominio para los servicios de clúster de SQL Server.

Nota Nota

Los controladores de dominio de Windows 2000 pueden funcionar en modo mixto y modo nativo. El modo mixto permite tener controladores de dominio de nivel inferior en el mismo dominio.


Completar - Completar imagen

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Completar - Completar imagen
Enviar comentarios

Use la página Completar para comprobar que la configuración de la instancia preparada se ha completado.

Opciones

Este cuadro de diálogo incluye un vínculo al archivo de registro del programa de instalación para esta operación. Para completar la instalación, haga clic en Cerrar.


Progreso de compleción de la imagen

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Progreso de compleción de la imagen
Vea también Enviar comentarios

Use la página Progreso de compleción de la imagen del Asistente para la instalación de SQL Server para supervisar el estado de la instalación de compleción de imagen de SQL Server. Al completarse este paso, esta página enumera el estado de cada característica de SQL Server configurada y completada.

Vea también

Conceptos

Ver y leer los archivos de registro de instalación de SQL Server


Reglas de completar imagen

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Reglas de completar imagen
Enviar comentarios

El programa de instalación de SQL Server valida la configuración del equipo antes de que se complete la operación de instalación. Durante la instalación de SQL Server, el Comprobador de configuración del sistema (SCC) examina el equipo en el que se instalará SQL Server. El SCC comprueba las condiciones que impiden una operación de instalación correcta de SQL Server. Antes de que el programa de instalación inicie el Asistente para la instalación de SQL Server, el SCC recupera el estado de cada elemento. A continuación, compara el resultado con las condiciones necesarias y proporciona instrucciones para evitar problemas de bloqueo.

La comprobación de la configuración del sistema genera un informe que contiene una descripción breve de cada regla ejecutada y el estado de ejecución. El informe de comprobación de la configuración del sistema se encuentra en %archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMDD_HHMM>\.

Antes de ejecutar la operación de instalación, revise los temas siguientes:

  1. Requisitos de hardware y software para instalar SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Características compatibles con las ediciones de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Consideraciones de seguridad para una instalación de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versiones en idioma local en SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Otras referencias:

  1. Actualizaciones de ediciones y versiones admitidas(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar los clústeres de conmutación por error(http://go.microsoft.com/fwlink/?LinkId=235034)


Completar - Preparar imagen

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Completar - Preparar imagen
Enviar comentarios

Use la página Completar para comprobar que la preparación de la imagen se ha completado.

Opciones

Este cuadro de diálogo incluye un vínculo al archivo de registro del programa de instalación para esta operación. Para completar la preparación de la imagen, haga clic en Cerrar.


Completar - Reparar

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Completar - Reparar
Enviar comentarios

Use la página Completar - Reparar para comprobar que la reparación se ha completado.

Opciones

Este cuadro de diálogo incluye un vínculo al archivo de registro del programa de instalación para esta operación. Para continuar, haga clic en Cerrar.


Completar - Actualizar

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Completar - Actualizar
Enviar comentarios

Use la página Completada (Actualizar) para comprobar que la actualización se ha completado.

Opciones

Este cuadro de diálogo incluye un vínculo al archivo de registro del programa de instalación para esta operación. Para continuar, haga clic en Cerrar.


Configuración del motor de base de datos - Aprovisionamiento de cuentas

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Configuración del motor de base de datos - Aprovisionamiento de cuentas
Vea también Enviar comentarios

Use esta página para establecer el modo de seguridad en SQL Server, así como para agregar grupos o usuarios de Windows como administradores de Motor de base de datos de SQL Server.

Consideraciones para la ejecución de SQL Server 2012 en Windows Vista, Windows 7 y Windows Server 2008

En versiones anteriores de SQL Server, se incluía el grupo BUILTIN\Administradores como posibilidad en el inicio de sesión de Motor de base de datos y los miembros del grupo local Administradores podían iniciar sesión usando sus credenciales de administrador. El uso de permisos elevados no es una práctica recomendada. En Microsoft SQL Server 2012 el grupo BUILTIN\Administradores no se aprovisiona como inicio de sesión. En consecuencia, debería crear un inicio de sesión de SQL Server para cada usuario administrativo y agregarlo al rol fijo de servidor sysadmin durante la instalación de una nueva instancia de Microsoft SQL Server 2012. También debe hacer esto para las cuentas de Windows que se utilizan para ejecutar trabajos del Agente SQL Server. También se incluyen las cuentas utilizadas para ejecutar trabajos del Agente de replicación.

Opciones

Modo de seguridad: seleccione la autenticación de Windows o la autenticación de modo mixto para la instalación.

Aprovisionamiento de entidad de seguridad de Windows: en las versiones anteriores de SQL Server, el grupo local Windows Builtin\Administrator estaba ubicado en el rol de servidor sysadmin de SQL Server, con lo que se concedía a los administradores de Windows acceso a la instancia de SQL Server. En Microsoft SQL Server 2012, el grupo Builtin\Administrator no tiene aprovisionado el rol de servidor sysadmin. En su lugar, debería aprovisionar explícitamente administradores de SQL Server para las nuevas instalaciones durante la instalación.

Nota importante Importante

Debe aprovisionar explícitamente administradores de SQL Server para las nuevas instalaciones durante la instalación. El programa de instalación no le permitirá continuar hasta que complete este paso.

Especificar administradores de SQL Server: debe especificar por lo menos una entidad de seguridad de Windows para la instancia de SQL Server. Para agregar la cuenta en la que se ejecuta el programa de instalación de SQL Server, haga clic en el botón Usuario actual. Para agregar o quitar cuentas de la lista de administradores del sistema, haga clic en Agregar o en Quitar y, a continuación, modifique la lista de usuarios, grupos o equipos que tendrán privilegios de administrador para la instancia de SQL Server.

Cuando termine de modificar la lista, haga clic en Aceptar y, a continuación, compruebe la lista de administradores en el cuadro de diálogo de configuración. Cuando la lista esté completa, haga clic en Siguiente.

Si selecciona la autenticación de modo mixto, debe proporcionar las credenciales de inicio de sesión para la cuenta de administrador de sistema (SA) de SQL Server builtin.

Nota de seguridad Nota de seguridad

No utilice una contraseña en blanco. Utilice una contraseña segura.

Modo de autenticación de Windows

Cuando un usuario se conecta a través de una cuenta de usuario de Microsoft Windows, SQL Server valida el nombre de cuenta y la contraseña con el token de la entidad de seguridad de Windows del sistema operativo. Éste es el modo de autenticación predeterminado, y es mucho más seguro que el modo mixto. La autenticación de Windows utiliza el protocolo de seguridad Kerberos, cumple la directiva de contraseñas en lo que respecta a la validación de la complejidad de las contraseñas seguras, y permite el bloqueo de las cuentas y la expiración de las contraseñas.

Nota de seguridad Nota de seguridad

Siempre que sea posible, utilice la autenticación de Windows.

Nota importante Importante

No utilice una contraseña en blanco. Utilice una contraseña segura. No establezca nunca una contraseña de sa en blanco o no segura.

Modo mixto (autenticación de Windows o autenticación de SQL Server)

Permite a los usuarios conectarse con la autenticación de Windows o la autenticación de SQL Server. Los usuarios que se conectan mediante una cuenta de usuario de Windows pueden usar conexiones de confianza validadas por Windows.

Si tiene que elegir el modo de autenticación mixto y necesita utilizar inicios de sesión de SQL para incluir aplicaciones heredadas, debe establecer contraseñas seguras para todas las cuentas de SQL Server.

Nota Nota

La autenticación de SQL Server se proporciona únicamente por motivos de compatibilidad con versiones anteriores. Siempre que sea posible, utilice la autenticación de Windows.

Escribir contraseña

Escriba y confirme el inicio de sesión del administrador del sistema (sa). Las contraseñas son la primera línea de defensa contra los intrusos, por lo que establecer contraseñas seguras es esencial para la seguridad del sistema. No establezca nunca una contraseña en blanco o no segura.

Nota Nota

Las contraseñas de SQL Server pueden contener de 1 a 128 caracteres, incluida cualquier combinación de letras, símbolos y números. Si elige la autenticación de modo mixto, debe escribir una contraseña de sa segura antes de continuar con la siguiente página del Asistente para la instalación.

Directrices para contraseñas seguras

Las contraseñas seguras no pueden ser adivinadas con facilidad y tampoco son fácilmente vulnerables en caso de utilizar un programa informático. Las contraseñas seguras no pueden utilizar los siguientes términos o condiciones prohibidos:

  • Una condición en blanco o NULL

  • "Password"

  • "Admin"

  • "Administrator"

  • "sa"

  • "sysadmin"

Una contraseña segura no puede ser ninguno de los siguientes términos asociados al equipo de instalación:

  • El nombre del usuario que haya iniciado actualmente la sesión en el equipo.

  • El nombre del equipo.

Una contraseña segura debe tener más de 8 caracteres de longitud y satisfacer al menos tres de los siguientes criterios:

  • Debe contener letras mayúsculas.

  • Debe contener letras minúsculas.

  • Debe contener números.

  • Debe contener caracteres no alfanuméricos; por ejemplo, #, %, o ^.

Las contraseñas que se escriben en esta página deben cumplir los requisitos de las directivas de contraseñas seguras. Si tiene alguna automatización que use la autenticación de SQL Server, asegúrese de que la contraseña cumple los requisitos de las directivas de contraseñas seguras.

Contenido relacionado

Para más información sobre elegir la autenticación de Windows en lugar de SQL Server autentificación, vea el tema elegir un modo de autenticación enSQL Server libros en pantalla.

Para más información sobre elegir una cuenta para ejecutar Motor de base de datos de SQL Server, vea el tema Configurar los permisos y las cuentas de servicio de Windows enSQL Server libros en pantalla.

Vea también

Referencia

Configurar los permisos y las cuentas de servicio de Windows


Configuración del motor de base de datos - Directorios de datos

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Configuración del motor de base de datos - Directorios de datos
Vea también Enviar comentarios

Use esta página para especificar la ubicación de instalación de los archivos de programa y datos de SQL Server Motor de base de datos. Según el tipo de instalación, es posible que el almacenamiento compatible incluya un disco local, almacenamiento compartido o un servidor de archivos SMB.

Para especificar un recurso compartido de archivos SMB como directorio, deberá escribir manualmente la ruta UNC admitida. No se admite el desplazamiento a un recurso compartido de archivos SMB. Este es un formato de ruta de acceso UNC admitida para un recurso compartido de archivos SMB: “\\NombreServdiro\NombreRecursoCompartido\...”

Instancia independiente de SQL Server

En la tabla siguiente se indican los tipos de almacenamiento admitidos y los directorios predeterminados para una instancia independiente de SQL Server que el usuario puede configurar durante la instalación de SQL Server.

Descripción | Tipo de almacenamiento compatible | Directorio predeterminado | Recomendaciones
Directorio raíz de datos | Disco local, servidor de archivos SMB, almacenamiento compartido 1 | C:\Archivos de programa\Microsoft SQL Server\ | El programa de instalación de SQL Server configurará las ACL para los directorios de SQL Server y anulará la herencia como parte de la configuración.
Directorio de base de datos de usuario | Disco local, servidor de archivos SMB, almacenamiento compartido 1 | C:\Archivos de programa\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data | Las prácticas recomendadas para los directorios de datos del usuario dependen de los requisitos de carga de trabajo y rendimiento.
Directorio de registro de base de datos de usuario | Disco local, servidor de archivos SMB, almacenamiento compartido 1 | C:\Archivos de programa\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data | Asegúrese de que el directorio de registro tenga espacio suficiente.
Directorio de base de datos temporales | Disco local, servidor de archivos SMB, almacenamiento compartido 1 | C:\Archivos de programa\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data | Las prácticas recomendadas para el directorio Temp dependen de los requisitos de carga de trabajo y rendimiento.
Directorio del registro de base de datos temporales | Disco local, servidor de archivos SMB, almacenamiento compartido 1 | C:\Archivos de programa\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Data | Asegúrese de que el directorio de registro tenga espacio suficiente.
Directorio de copia de seguridad | Disco local, servidor de archivos SMB, almacenamiento compartido 1 | C:\Archivos de programa\Microsoft SQL Server\MSSQL11.<InstanceID>\MSSQL\Backup | Establezca los permisos apropiados para evitar la pérdida de datos, y asegúrese de que la cuenta de usuario para el servicio SQL Server tenga los permisos adecuados para escribir en el directorio de copia de seguridad. No se permite usar una unidad asignada para los directorios de copia de seguridad.

1 Aunque se admite el uso de discos compartidos, esta práctica no es recomendada para una instancia independiente de SQL Server.

Instancia de clúster de conmutación por error de SQL Server

En la tabla siguiente se indican los tipos de almacenamiento admitidos y los directorios predeterminados para una instancia de clúster de conmutación por error de SQL Server que el usuario puede configurar durante la instalación de SQL Server.

Descripción

Tipo de almacenamiento compatible

Directorio predeterminado

Recomendaciones

Directorio raíz de datos

Almacenamiento compartido, servidor de archivos SMB

<Unidad:>\Archivos de programa\Microsoft SQL Server

Sugerencia Sugerencia

Si se seleccionó un disco compartido en la página Selección de disco de clúster, el valor predeterminado es el primer disco compartido. El valor predeterminado de este campo será en blanco si no se realizó ninguna selección en la página Selección de disco de clúster.

El programa de instalación de SQL Server configurará las ACL para los directorios de SQL Server y anulará la herencia como parte de la configuración.

Directorio de base de datos de usuario

Almacenamiento compartido, servidor de archivos SMB

<Unidad:>Archivos de programa\Microsoft SQL Server\MSSQL11.<IdInstancia>\MSSQL\Data

Sugerencia Sugerencia

Si se seleccionó un disco compartido en la página Selección de disco de clúster, el valor predeterminado es el primer disco compartido. El valor predeterminado de este campo será en blanco si no se realizó ninguna selección en la página Selección de disco de clúster.

Las prácticas recomendadas para los directorios de datos del usuario dependen de los requisitos de carga de trabajo y rendimiento.

Directorio de registro de base de datos de usuario

Almacenamiento compartido, servidor de archivos SMB

<Unidad:>\Archivos de programa\Microsoft SQL Server\MSSQL11.<IdInstancia>\MSSQL\Data

Sugerencia Sugerencia

Si se seleccionó un disco compartido en la página Selección de disco de clúster, el valor predeterminado es el primer disco compartido. El valor predeterminado de este campo será en blanco si no se realizó ninguna selección en la página Selección de disco de clúster.

Asegúrese de que el directorio de registro tenga espacio suficiente.

Directorio de base de datos temporales

Disco local, almacenamiento compartido, servidor de archivos SMB

<Unidad:>\Archivos de programa\Microsoft SQL Server\MSSQL11.<IdInstancia>\MSSQL\Data

Sugerencia Sugerencia

Si se seleccionó un disco compartido en la página Selección de disco de clúster, el valor predeterminado es el primer disco compartido. El valor predeterminado de este campo será en blanco si no se realizó ninguna selección en la página Selección de disco de clúster.

Asegúrese de que el directorio especificado sea válido para todos los nodos de clúster. Durante la conmutación por error, si los directorios de tempdb no están disponibles en el nodo de destino de la conmutación por error, el recurso de SQL Server no podrá ponerse en línea.

Directorio del registro de base de datos temporales

Disco local, almacenamiento compartido, servidor de archivos SMB

<Unidad:>\Archivos de programa\Microsoft SQL Server\MSSQL11.<IdInstancia>\MSSQL\Data

Sugerencia Sugerencia

Si se seleccionó un disco compartido en la página Selección de disco de clúster, el valor predeterminado es el primer disco compartido. El valor predeterminado de este campo será en blanco si no se realizó ninguna selección en la página Selección de disco de clúster.

Asegúrese de que el directorio especificado sea válido para todos los nodos de clúster. Durante la conmutación por error, si los directorios de tempdb no están disponibles en el nodo de destino de la conmutación por error, el recurso de SQL Server no podrá ponerse en línea.

Directorio de copia de seguridad

Disco local, almacenamiento compartido, servidor de archivos SMB

<Unidad:>\Archivos de programa\Microsoft SQL Server\MSSQL11.<IdInstancia>\MSSQL\Backup

Sugerencia Sugerencia

Si se seleccionó un disco compartido en la página Selección de disco de clúster, el valor predeterminado es el primer disco compartido. El valor predeterminado de este campo será en blanco si no se realizó ninguna selección en la página Selección de disco de clúster.

Establezca los permisos apropiados para evitar la pérdida de datos y asegúrese de que la cuenta de usuario para el servicio de SQL Server tenga los permisos adecuados para escribir en el directorio de copia de seguridad. No se permite usar una unidad asignada para los directorios de copia de seguridad.

Consideraciones relativas a la seguridad

El programa de instalación configurará las ACL para los directorios de SQL Server y anulará la herencia como parte de la configuración.

Al servidor de archivos SMB se aplican las recomendaciones siguientes:

  • Si se usa un servidor de archivos SMB, la cuenta de servicio de SQL Server debe ser una cuenta de dominio.

  • La cuenta que se usa para instalar SQL Server debe los tener permisos NTFS de CONTROL TOTAL en las carpetas de recurso compartido de archivos SMB que se usan como directorio de datos.

  • Al a cuenta que se usa para instalar SQL Server se le debe conceder los privilegios SeSecurityPrivilege en el servidor de archivos SMB. Para ello, use la consola de directivas de seguridad local del servidor de archivos para agregar la cuenta de instalación de SQL Server a la directiva Administrar registro de seguridad y auditoría. Esta opción está disponible en la sección Asignaciones de derechos de usuario bajo Directivas locales de la consola Directiva de seguridad local.

Notas

  • Cuando agregue características a una instalación existente, no podrá cambiar la ubicación de una característica instalada anteriormente ni especificar dicha ubicación para una característica nueva.

  • Si especifica los directorios de instalación no predeterminados, asegúrese de que las carpetas de instalación sean únicas para esta instancia de SQL Server. Ninguno de los directorios de este cuadro de diálogo se debe compartir con los de otras instancias de SQL Server. Los componentes de Motor de base de datos y Analysis Services en una instancia de SQL Server también deben instalarse en directorios independientes.

  • Los archivos de programa y los archivos de datos no se pueden instalar en las situaciones siguientes:

    • En una unidad de disco extraíble

    • En un sistema de archivos que usa compresión

    • En un directorio que contiene archivos del sistema

    • En una unidad de red asignada en una instancia de clúster de conmutación por error

Vea también

Conceptos

Ubicaciones de archivos para las instancias predeterminadas y con nombre de SQL Server

Otros recursos

Permisos NTFS y de uso compartido en un servidor de archivos


Configuración del motor de base de datos - Secuencia de archivo

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Configuración del motor de base de datos - Secuencia de archivo
Vea también Enviar comentarios

Utilice esta página para habilitar FILESTREAM para esta instalación de Microsoft SQL Server 2012. FILESTREAM integra Motor de base de datos de SQL Server con un sistema de archivos NTFS almacenando los datos de objeto binario grande (BLOB) varbinary(max) como archivos en el sistema de archivos. Las instrucciones de Transact-SQL pueden insertar, actualizar, consultar, buscar y realizar copias de seguridad de los datos FILESTREAM. Las interfaces del sistema de archivos de Win32 proporcionan el acceso de la transmisión por secuencias a los datos.

Habilitar FILESTREAM para acceso Transact-SQL

Seleccione esta opción para habilitar FILESTREAM para el acceso a Transact-SQL. Este control debe comprobarse para que las otras opciones de control estén disponibles.

Habilitar FILESTREAM para el acceso de transmisión por secuencias de E/S de archivos

Seleccione esta opción para habilitar el acceso de transmisión por secuencias de Win32 para FILESTREAM.

Nombre de recurso compartido de Windows

Utilice este control para escribir el nombre del recurso compartido de Windows en el que los datos de FILESTREAM se almacenarán.

Permitir que los clientes remotos tengan acceso de transmisión por secuencias a los datos de FILESTREAM

Seleccione este control para permitir que los clientes remotos tengan acceso a estos datos de FILESTREAM en este servidor.

Vea también

Referencia

sp_configure (Transact-SQL)

Conceptos

Habilitar y configurar FILESTREAM


Configuración del motor de base de datos - Instancia de usuario

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Configuración del motor de base de datos - Instancia de usuario
Enviar comentarios

Utilice la página Instancia de usuario para generar una instancia independiente de Motor de base de datos para usuarios sin permisos de administrador, y para agregar usuarios al rol Administrador.

Opción

Habilitar instancias de usuario

La opción predeterminada es activado. Para deshabilitar la funcionalidad de habilitar instancias de usuario, desactive la casilla.

La instancia de usuario, también denominada instancia secundaria o cliente, es una instancia de SQL Server generada por la instancia primaria (la instancia principal que se ejecuta como servicio, como SQLExpress) en nombre de un usuario. La instancia de usuario se ejecuta como un proceso de usuario en el contexto de seguridad de dicho usuario. La instancia de usuario está aislada de la instancia primaria y de las demás instancias de usuario que se ejecutan en el equipo. La característica de instancias de usuario también se denomina "Ejecutar como usuario normal" (RANU).

Nota Nota

Los inicios de sesión suministrados como miembros del rol fijo de servidor sysadmin durante la instalación se suministran como administradores en la base de datos de plantilla. Son miembros del rol fijo de servidor sysadmin en la instancia de usuario a menos que se quiten.

Agregar usuario al rol Administrador de SQL Server

De forma predeterminada, esta casilla está desactivada. Para agregar el usuario del programa de instalación actual al rol Administrador de SQL Server, active la casilla.

Los usuarios de Windows Vista que sean miembros de BUILTIN\Administrators no se agregan automáticamente al rol fijo de servidor sysadmin al conectarse a SQL Server Express. Solo los usuarios de Windows Vista que se hayan agregado de forma explícita a un rol Administrador de servidor pueden administrar SQL Server Express. Cualquier miembro del grupo BUILTIN\Users se puede conectar a la instancia de SQL Server Express, pero tendrá permisos limitados para realizar tareas de base de datos. Por este motivo, a los usuarios que hereden los privilegios de SQL Server Express de los grupos BUILTIN\Administrators y BUILTIN\Users de versiones anteriores de Windows, se les deben conceder de forma explícita privilegios administrativos a las instancias de SQL Server Express que se ejecuten en Windows Vista.

Para realizar cambios en los roles de usuario una vez finalizado este programa de instalación, utilice la Herramienta de configuración de área expuesta (SQLSAC.exe) de SQL Server 2005. Para actualizar la lista de usuarios del rol Administrador del sistema de SQL Server, haga clic en el vínculo Agregar nuevo administrador.

Asegúrese de que en el campo Usuario para aprovisionar aparezca el nombreDeDominio\nombreDeUsuario del usuario cuyos permisos se deben actualizar. Seleccione el rol que se debe actualizar en la lista de instancias de SQL Server del panel Privilegios disponibles y, a continuación, haga clic en la flecha que señala a la derecha. Para agregar el usuario a todos los roles disponibles para todas las instancias disponibles de SQL Server y todos los roles disponibles, haga clic en la flecha doble que señala a la derecha.

Para implementar los cambios una vez completadas las selecciones, haga clic en Aceptar. Para cerrar la herramienta sin realizar cambios, haga clic en Cancelar.


Requisitos de espacio en disco

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Requisitos de espacio en disco
Vea también Enviar comentarios

Use la página Resumen de espacio en disco para examinar los requisitos de espacio en disco necesarios para las características de SQL Server seleccionadas durante la instalación.

Opciones

Si se requiere mucho espacio en disco, considere las opciones siguientes:

  • Cambie los directorios de instalación por una unidad de disco que disponga de más espacio.

  • Cambie las características de SQL Server seleccionadas durante la instalación.

  • Cree más espacio disponible en la unidad de disco especificada; para ello, mueva otros archivos o aplicaciones.

Vea también

Otros recursos

Requisitos de hardware y software para instalar SQL Server 2008 R2


Configuración de Distributed Replay Controller

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Configuración de Distributed Replay Controller
Enviar comentarios

Use la página Configuración de Distributed Replay Controller del Asistente para la instalación de SQL Server con el fin de especificar los usuarios a los que desee conceder permisos administrativos para el servicio Distributed Replay Controller.

Los usuarios con permisos administrativos tendrán acceso ilimitado al servicio Distributed Replay Controller.

Opciones

Agregar usuario actual

Haga clic en este botón para agregar los usuarios a los que desee conceder permisos de acceso para el servicio Distributed Replay Controller.

Agregar

Haga clic en este botón para agregar permisos de acceso para el servicio Distributed Replay Controller.

Quitar

Haga clic en este botón para quitar permisos de acceso del servicio Distributed Replay Controller.


Configuración de Distributed Replay Client

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Configuración de Distributed Replay Client
Enviar comentarios

Use la página Configuración de Distributed Replay Client del Asistente para la instalación de SQL Server con el fin de especificar los usuarios a los que desee conceder permisos administrativos para el servicio Distributed Replay Client.

Los usuarios con permisos administrativos tendrán acceso ilimitado al servicio Distributed Replay Client.

Opciones

Nombre del controlador

Se trata de un parámetro opcional y el valor predeterminados es <blank>.

Escriba el nombre del controlador con el que se comunicará el equipo cliente para el servicio Distributed Replay Client. Observe lo siguiente:

  • El nombre debe ser un nombre de dominio completo (FQDN). Por ejemplo, un llamado servidor1 en la jerarquía de productos de Microsoft puede tener un FQDN de servidor1.productos.microsoft.com.

  • Si ya ha configurado un controlador, escriba el nombre del controlador mientras configura cada cliente.

  • Si aún no ha configurado ningún controlador, puede dejar el nombre del controlador en blanco. Sin embargo, debe escribir manualmente el nombre del controlador en el archivo de configuración de cliente.

Directorio de trabajo

Especifique el directorio de trabajo para el servicio Distributed Replay Client.

El directorio de trabajo predeterminado es <drive letter>:\Archivos de programa\Microsoft SQL Server\DReplayClient\WorkingDir\.

Directorio de resultados

Especifique el directorio de resultados para el servicio Distributed Replay Client.

El directorio de resultados predeterminado es <drive letter>:\Archivos de programa\Microsoft SQL Server\DReplayClient\ResultDir\.


Reglas de actualización de edición

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Reglas de actualización de edición
Vea también Enviar comentarios

El programa de instalación de SQL Server valida la configuración del equipo antes de que se complete la operación de instalación. Durante la instalación de SQL Server, el Comprobador de configuración del sistema (SCC) examina el equipo en el que se instalará SQL Server. El SCC comprueba las condiciones que impiden una operación de instalación correcta de SQL Server. Antes de que el programa de instalación inicie la actualización de la edición, el SCC recupera el estado de cada elemento. A continuación, compara el resultado con las condiciones necesarias y proporciona instrucciones para evitar problemas de bloqueo.

La comprobación de la configuración del sistema genera un informe que contiene una descripción breve de cada regla ejecutada y el estado de ejecución. El informe de comprobación de la configuración del sistema se encuentra en %archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMDD_HHMM>\.

Antes de ejecutar la operación de instalación, revise los temas siguientes:

  1. Requisitos de hardware y software para instalar SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Características compatibles con las ediciones de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Consideraciones de seguridad para una instalación de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versiones en idioma local en SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Otras referencias:

  1. Actualizaciones de ediciones y versiones admitidas(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar los clústeres de conmutación por error(http://go.microsoft.com/fwlink/?LinkId=235034)

Vea también

Referencia

Reglas auxiliares del programa de instalación


Informes de errores

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Informes de errores
Enviar comentarios

Utilice la página Configuración de informes de errores y uso del Asistente para la instalación de SQL Server con el fin de habilitar la funcionalidad para crear informes de errores y uso de características en SQL Server.

Opciones

De forma predeterminada, las características Recopilación de datos de uso de características e Informes de errores están deshabilitadas en SQL Server en sus componentes de Microsoft SQL Server 2012.

Informes de errores

Si habilita la característica Informes de errores, SQL Server se configura para enviar automáticamente un informe a Microsoft si se produce un error irrecuperable en alguno de los siguientes componentes de SQL Server:

  • El Motor de base de datos

  • Agente SQL Server

  • Analysis Services

  • Reporting Services

  • Integration Services

  • Replicación

Microsoft utiliza los informes de errores para mejorar la funcionalidad de SQL Server, y trata toda la información recibida de forma confidencial.

La información sobre los errores se envía a través de una conexión segura (https) a Microsoft, donde se almacena con limitación de acceso. O bien, puede enviar los informes de errores a su propio servidor de informes de errores corporativo.

Los informes de errores contienen la información siguiente:

  • La condición de SQL Server en el momento de producirse el problema.

  • La versión del sistema operativo y del hardware del sistema.

  • El identificador del producto digital, que puede utilizarse para identificar la licencia.

  • La dirección IP de red del equipo o el servidor proxy.

  • Información procedente de la memoria o los archivos del proceso que ha causado el error.

Microsoft no pretende obtener de forma intencionada archivos o información sobre el nombre, la dirección postal, la dirección de correo electrónico o información personal de otro tipo. Sin embargo, el informe de errores puede contener información personal procedente de la memoria o los archivos del proceso que ha causado el error. A pesar de que este tipo de información podría utilizarse potencialmente para determinar la identidad del usuario, Microsoft no utiliza la información con este propósito.

Para obtener más información sobre la directiva de privacidad y recopilación de datos de SQL Server, vea Declaración de privacidad de Microsoft SQL Server.

Si habilita Informes de errores y se produce un error irrecuperable, podría ver en el registro de eventos de Windows una respuesta procedente de Microsoft que apunte a un artículo de Microsoft Knowledge Base que trate sobre un error específico.

Para deshabilitar Informes de errores o Informes de uso de características en todas las instancias de SQL Server y sus componentes una vez finalizada la instalación, vaya al cuadro de diálogo Configuración de informes de errores y uso y desactive las casillas de Uso de características. Si Informes de errores está habilitado para varios componentes de SQL Server (Motor de base de datos de SQL Server, Analysis Services, Reporting Services y componentes compartidos), puede deshabilitar Informes de errores en cada instancia de un componente individual, así como en los componentes compartidos, que se enumeran como Otros.


Informe de clústeres de conmutación por error

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Informe de clústeres de conmutación por error
Enviar comentarios

Use la página Informe de clústeres de conmutación por error para ver el resultado del informe procedente del examen realizado por el programa de instalación para esta operación.

Opciones

Para ver un informe detallado del examen, haga clic en el vínculo de informe.


Revisión de características

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Revisión de características
Vea también Enviar comentarios

La página Revisión de características es una lista de solo lectura de las características que se han preparado y se configurarán y completarán al final del paso para completar la imagen. La lista de características está seleccionada durante el paso de preparación de la imagen y no se puede modificar durante el paso de compleción de imagen. Además de las características mostradas, una instancia preparada también incluye SQL Server Browser, SQL Server Writer y SQL Server Native Client.

Puede agregar otras características no incluidas en la instancia preparada de la instancia de SQL Server después de haber completado la configuración de la instancia preparada de SQL Server.

Grupo de componentes

Componentes y características

Servicios de Motor de base de datos

Motor de base de datos de SQL Server incluye los siguientes componentes:

  • Motor de base de datos es el servicio principal para almacenar, procesar y proteger los datos.

    • Replicación: (opcional) la replicación es un conjunto de tecnologías destinadas a la copia y distribución de datos y objetos de base de datos desde una base de datos a otra, para luego sincronizar ambas bases de datos y mantener su coherencia.

    • Búsqueda de texto completo: (opcional) la búsqueda de texto completo proporciona la funcionalidad necesaria para realizar consultas de texto completo en datos formados por caracteres sin formato contenidos en tablas de SQL Server.

    • Data Quality Services: (opcional) Data Quality Services (DQS) es una solución de limpieza de datos que permite detectar datos incoherentes e incorrectos en el origen de datos y proporciona formas automatizadas e interactivas de limpiar los datos.

Reporting Services

Reporting Services incluye componentes de servidor y de cliente para crear, administrar e implementar informes tabulares, matriciales, gráficos y de forma libre. Reporting Services es también una plataforma extensible que puede utilizarse para desarrollar aplicaciones de informes.

Vea también

Otros recursos

Instalar SQL Server utilizando SysPrep


Reglas de instalación

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Reglas de instalación
Vea también Enviar comentarios

El programa de instalación de SQL Server valida la configuración del equipo antes de que se complete la operación de instalación. Durante la instalación de SQL Server, el Comprobador de configuración del sistema (SCC) examina el equipo en el que se instalará SQL Server. El SCC comprueba las condiciones que impiden una operación de instalación correcta de SQL Server. Antes de que el programa de instalación inicie el Asistente para la instalación de SQL Server, el SCC recupera el estado de cada elemento. A continuación, compara el resultado con las condiciones necesarias y proporciona instrucciones para evitar problemas de bloqueo.

La comprobación de la configuración del sistema genera un informe que contiene una descripción breve de cada regla ejecutada y el estado de ejecución. El informe de comprobación de la configuración del sistema se encuentra en %archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMDD_HHMM>\.

Antes de ejecutar la operación de instalación, revise los temas siguientes:

  1. Requisitos de hardware y software para instalar SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Características compatibles con las ediciones de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Consideraciones de seguridad para una instalación de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versiones en idioma local en SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Otras referencias:

  1. Actualizaciones de ediciones y versiones admitidas(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar los clústeres de conmutación por error(http://go.microsoft.com/fwlink/?LinkId=235034)

Vea también

Referencia

Reglas auxiliares del programa de instalación


Reglas de características

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Reglas de características
Enviar comentarios

El programa de instalación de SQL Server valida la configuración del equipo antes de que se complete la operación de instalación. Durante la instalación de SQL Server, el Comprobador de configuración del sistema (SCC) examina el equipo en el que se instalará SQL Server. El SCC comprueba las condiciones que impiden una operación de instalación correcta de SQL Server. Antes de que el programa de instalación se inicie, el SCC recupera el estado de cada elemento. A continuación, compara el resultado con las condiciones necesarias y proporciona instrucciones para evitar problemas de bloqueo.

La comprobación de la configuración del sistema genera un informe que contiene una descripción breve de cada regla ejecutada y el estado de ejecución. El informe de comprobación de la configuración del sistema se encuentra en %archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMDD_HHMM>\.

Antes de ejecutar la operación de instalación, revise los temas siguientes:

  1. Requisitos de hardware y software para instalar SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Características compatibles con las ediciones de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Consideraciones de seguridad para una instalación de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versiones en idioma local en SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Otras referencias:

  1. Actualizaciones de ediciones y versiones admitidas(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar los clústeres de conmutación por error(http://go.microsoft.com/fwlink/?LinkId=235034)


Selección de características

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Selección de características
Vea también Enviar comentarios

Utilice las casillas de la página Selección de características del Asistente para la instalación de SQL Server con el fin de seleccionar los componentes de la instalación de SQL Server.

Instalar características de SQL Server

En la página Selección de características, las características de SQL Server están separadas en dos secciones principales: Características de instancia y Características compartidas.

Características de instancia hace referencia a los componentes instalados una vez para cada instancia, de modo que tenga varias copias de ellas (una para cada instancia). Cada instancia puede ser una versión independiente que tiene otro nivel de revisión. Cuando se instala una revisión, ya sea un Service Pack, una revisión o una actualización acumulativa, solo actualiza los archivos de una instancia de un equipo determinado, más las características compartidas si no se han actualizado ya.

Características compartidas hace referencia a las características comunes a todas las instancias en un equipo determinado. Cada una de estas características compartidas se ha diseñado para ser compatible con las versiones admitidas de SQL Server (Service Pack, actualizaciones acumulativas y revisiones) que se pueden instalar en paralelo.

Nota Nota

SysPrep de SQL Server: el Motor de base de datos y Reporting Services son solo características de Microsoft SQL Server 2012 que admiten SysPrep de SQL Server. Puede seleccionar estas características y componentes durante el paso de preparación de la imagen en el proceso. No puede realizar la selección mientras se completa una imagen preparada de SQL Server. Para obtener más información, vea Instalar SQL Server 2012 con SysPrep (http://go.microsoft.com/fwlink/?LinkId=190965).

Clústeres de conmutación por error de SQL Server: el Motor de base de datos y los componentes de Analysis Services son las únicas características de Microsoft SQL Server 2012 que admiten los clústeres de conmutación por error. Puede instalar otros componentes, como Reporting Services o Integration Services, en un nodo de clúster de conmutación por error, pero estos componentes no detectan los clústeres y sus servicios no realizan la conmutación por error si el nodo de clúster de conmutación por error se queda sin conexión. Para obtener más información, vea Introducción al clúster de conmutación por error de SQL Server (http://go.microsoft.com/fwlink/?LinkId=190953).

Características de instancia

En el panel Descripción, se muestra una descripción de cada grupo de componentes cuando se selecciona. Puede activar cualquier combinación de casillas. Para continuar, debe realizar una selección.

Características

Descripción

Servicios del Motor de base de datos

El Motor de base de datos de SQL Server incluye el Motor de base de datos, el servicio principal para almacenar, procesar y proteger datos; también incluye replicación, búsqueda de texto completo y herramientas para administrar datos XML y relacionales, y el servidor Data Quality Services (DQS).

  • El Motor de base de datos es el servicio principal para almacenar, procesar y proteger los datos.

  • Replicación: (opcional) la replicación es un conjunto de tecnologías destinadas a la copia y distribución de datos y objetos de base de datos desde una base de datos a otra, para luego sincronizar ambas bases de datos y mantener su coherencia.

  • Búsqueda de texto completo: (opcional) la búsqueda de texto completo proporciona la funcionalidad necesaria para realizar consultas de texto completo en datos formados por caracteres sin formato contenidos en tablas de SQL Server.

  • Data Quality Services: (opcional) Data Quality Services (DQS) es una solución de limpieza de datos que permite detectar datos incoherentes e incorrectos en el origen de datos y proporciona formas asistidas por ordenador e interactivas de limpiar los datos. Active esta casilla para instalar el servidor DQS. Debe ejecutar el archivo DQSInstaller.exe una vez completado el programa de instalación de SQL Server para completar la instalación del servidor DQS. Si instaló la instancia predeterminada de SQL Server, este archivo está disponible en C:\Archivos de programa\Microsoft SQL Server\MSSQL11.MSSQLSERVER\MSSQL\Binn.

Clústeres de conmutación por error de SQL Server: los componentes de replicación y búsqueda de texto completo son necesarios y los selecciona automáticamente el programa de instalación para las instalaciones de clústeres de conmutación por error de SQL Server cuando se selecciona Servicios de Motor de base de datos.

Analysis Services

Analysis Services incluye las herramientas para crear y administrar aplicaciones de procesamiento analítico en línea (OLAP) y de minería de datos.

Nativo de Reporting Services

El modo nativo de Reporting Services incluye componentes de servidor y de cliente para crear, administrar e implementar informes tabulares, matriciales, gráficos y de forma libre. Reporting Services es también una plataforma extensible que se puede usar para desarrollar aplicaciones de informes.

Nota importante Importante

  1. El programa de instalación no configura el equilibro de carga ni direcciones URL únicas para varios nodos en una implementación escalada de Reporting Services. Para completar una implementación escalada, debe utilizar Windows Server, Microsoft Application Center o software de administración de clúster de terceros. Para obtener más información sobre cómo configurar una implementación de granja de servidores web, vea Configurar Reporting Services para la implementación escalada (http://go.microsoft.com/fwlink/?LinkId=199448).

  2. El componente Diseñador de informes de Reporting Services necesita Microsoft Internet Explorer 7.0 Service Pack 1.

  3. Reporting Services no se admite en configuraciones en paralelo en la plataforma de 64 bits y en el subsistema de 32 bits (WOW64) de un servidor de 64 bits.

Características compartidas

Las características que comparten todas las instancias de SQL Server en un mismo equipo se instalan en un solo directorio. Entre ellas se incluyen los siguientes:

Característica

Descripción

Reporting Services –SharePoint

El modo de SharePoint de Reporting Services es una aplicación basada servidor para crear, administrar y entregar informes por correo electrónico, varios formatos de archivo y formaciones basadas en Web interactivas. El modo de SharePoint integra la experiencia de visualización y administración de informes con los productos de SharePoint.

Complemento Reporting Services para productos de SharePoint

El complemento Reporting Services para productos de SharePoint incluye componentes de administración y de interfaz de usuario para integrar un producto de SharePoint con un servidor de informes de Reporting Services en modo de SharePoint.

Cliente de calidad de datos

El Cliente de calidad de datos es una aplicación independiente que se conecta al servidor DQS y proporciona una interfaz gráfica de usuario intuitiva para realizar operaciones de limpieza de datos y de coincidencia de datos, así como para realizar tareas administrativas en DQS.

Herramientas de datos de SQL Server1

La herramientas de datos de SQL Server (SSDT) proporcionan un IDE para compilar soluciones para los componentes de Business Intelligence: Analysis Services, Reporting Services e Integration Services.

(Anteriormente denominado Business Intelligence Development Studio).

SSDT también incluye “Proyectos de base de datos”, que proporcionan un entorno integrado para que los desarrolladores de software de bases de datos realicen todo el trabajo de diseño de base de datos para cualquier plataforma de SQL Server (tanto interna como externa) en Visual Studio. Los desarrolladores de software de base de datos pueden usar el Explorador de servidores mejorado en Visual Studio para crear o modificar objetos de base de datos y datos fácilmente, o bien para ejecutar consultas.

Conectividad con las herramientas de cliente

Herramientas de cliente incluye componentes para la comunicación entre los clientes y los servidores, incluidas las bibliotecas de red para DB-Library, OLEDB para OLAP, ODBC, ADODB y ADOMD+.

Integration Services

Integration Services es un conjunto de herramientas gráficas y objetos programables para mover, copiar y transformar datos.

Compatibilidad con las versiones anteriores de las herramientas de cliente

Compatibilidad con las versiones anteriores de las herramientas de cliente incluye los componentes siguientes:

  • Objetos de administración distribuida de SQL (SQL-DMO). Para obtener más información, vea Características de SQL Server no incluidas en SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=190968).

  • Objetos de ayuda para la toma de decisiones (DSO). Para obtener más información, vea Últimos cambios a las características de Analysis Services en SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=190970).

SDK de las herramientas de cliente

Incluye el kit de desarrollo de software que contiene los recursos para programadores.

Componentes de documentación

Los componentes de documentación incluyen componentes para ver y administrar el contenido de la ayuda.

Herramientas de administración: básicas

Herramientas de administración – Básica: esto incluye lo siguiente:

  • Compatibilidad de SQL Server Management Studio con el Motor de base de datos de SQL Server, SQL Server Express, la utilidad sqlcmd y el proveedor de SQL Server PowerShell

Herramientas de administración – Completa: incluyen los componentes siguientes, además de los componentes de la versión básica:

  • Compatibilidad de SQL Server Management Studio con Reporting Services, Analysis Services e Integration Services

  • SQL Server Profiler

  • Asistente para la optimización de motor de base de datos

  • Administración de la utilidad SQL Server

Distributed Replay Controller

El controlador de Distributed Replay orquestra las acciones de los clientes de reproducción distribuida. Solo puede haber una instancia de controlador en cada entorno de Distributed Replay. Para obtener más información, vea SQL Server Distributed Replay (http://go.microsoft.com/fwlink/?LinkId=229847).

Distributed Replay Client

Los clientes de Distributed Replay colaboran para simular cargas de trabajo en una instancia de SQL Server. Puede haber uno o más clientes en cada entorno de Distributed Replay. Para obtener más información, vea SQL Server Distributed Replay (http://go.microsoft.com/fwlink/?LinkId=229847).

SDK de conectividad de cliente SQL

Incluye el SDK de SQL Server Native Client (ODBC/OLE DB) para el desarrollo de aplicaciones de base de datos.

Master Data Services

Master Data Services es una plataforma para integrar datos de distintos sistemas de una organización en un único origen de datos maestros para lograr precisión y con fines de auditoría. La opción Master Data Services instala Administrador de configuración de Master Data Services, ensamblados, un complemento de Windows PowerShell y carpetas y archivos para las aplicaciones y los servicios web.

LocalDB

LocalDB es un modo de ejecución de SQL Server Express destinado a los desarrolladores de programas. Se inicia mediante una cadena de conexión especial y la infraestructura necesaria de SQL Server se crea automáticamente y se inicia, lo que habilita la aplicación para usar la base de datos sin tareas de configuración o administración.

1Para las instalaciones de Herramientas de datos de SQL Server (SSDT) se necesita Internet Explorer 6.0 SP1.

De forma predeterminada, los componentes compartidos se instalan en %Archivos de programa%Microsoft SQL Server\. Para cambiar la ruta de instalación, haga clic en el botón Examinar. Si cambia la ruta de instalación de un componente compartido, también cambia la de los demás componentes compartidos. En las instalaciones posteriores los componentes compartidos se instalarán en la misma ubicación que la instalación original.

En sistemas operativos basados en x64, puede especificar dónde se instalarán los componentes de 64 bits y los componentes de 32 bits del subsistema WOW64.

Instalar Bases de datos de ejemplo AdventureWorks

De forma predeterminada, las bases de datos y el código de ejemplo no se instalan como parte del programa de instalación de SQL Server. Para obtener más información acerca de la instalación de las bases de datos de muestra y el código muestra, visite el sitio web Microsoft SQL Server Community Projects & Samples (http://go.microsoft.com/fwlink/?LinkId=87843).

Una vez instalado Microsoft SQL Server 2012, está disponible la información adicional sobre los ejemplos. En el menú Inicio, haga clic en Todos los programas, Microsoft SQL Server 2012, Documentación y tutoriales y, finalmentre, en Introducción a los ejemplos de Microsoft SQL Server.

Vea también

Otros recursos

Ediciones y componentes de SQL Server 2012


Selección de características (Desinstalar)

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Selección de características (Desinstalar)
Enviar comentarios

Use la página Selección de características - Desinstalar para seleccionar las características que desea quitar de la instancia de SQL Server especificada.

Opciones

Puede seleccionar cualquier combinación de características.


Características para actualizar

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Características para actualizar
Vea también Enviar comentarios

Utilice la página Características para actualizar del Asistente para la instalación Microsoft SQL Server 2012 para ver las características que se van a actualizar a Microsoft SQL Server 2012.

Opciones

  • No es posible cambiar las características que se van a actualizar en esta versión. Para agregar las características a esta instancia de SQL Server, complete el proceso de actualización, reinicie el programa de instalación y haga clic en Nueva instalación a Agregar características a una instalación existente en el centro de instalación.

Vea también

Otros recursos

Actualizaciones de versión y edición
Usar el Asesor de actualizaciones para preparar las actualizaciones
Trabajar con varias versiones de SQL Server


Opciones de actualización de búsqueda de texto completo

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Opciones de actualización de búsqueda de texto completo
Enviar comentarios

Use la página de opciones de actualización de búsqueda de texto completo del Asistente para la instalación de SQL Server para seleccionar la opción de actualización de búsqueda de texto completo que usará con las bases de datos cuya actualización está realizando en este momento.

En SQL Server 2005 y versiones anteriores, cada índice de texto completo reside en un catálogo de texto completo que pertenece a un grupo de archivos, tiene una ruta de acceso física y es tratado como un archivo de base de datos. A partir de SQL Server 2008, un catálogo de texto completo es un concepto lógico (un objeto virtual) que hace referencia a un grupo de índices de texto completo. Por consiguiente, no se trata a cada nuevo catálogo de texto completo como un archivo de base de datos con una ruta de acceso física. Sin embargo, durante la actualización de cualquier catálogo de texto completo que contiene archivos de datos, se crea un nuevo grupo de archivos en el mismo disco. Esto conserva el comportamiento de E/S del disco antiguo después de la actualización. Si la ruta de acceso raíz existe, todos los índices de texto completo del catálogo se situarán en el nuevo grupo de archivos. Si la ruta de acceso al catálogo de texto completo antiguo no es válida, la actualización mantiene el índice de texto completo en el mismo grupo de archivos que la tabla base o, si se trata de una tabla con particiones, en el grupo de archivos principal.

Opciones

Cuando se actualice de SQL Server 2005 o SQL Server 2008 a Microsoft SQL Server 2012, elija una de las opciones de actualización de texto completo siguientes.

Importar

Se importan los catálogos de texto completo. Normalmente, el proceso de importación es significativamente más rápido que el de regeneración. Por ejemplo, si se usa solo una CPU, importar es aproximadamente 10 veces más rápido que volver a generar. Sin embargo, un catálogo de texto completo importado desde SQL Server 2005 no usa los separadores de palabras nuevos y mejorados que se introdujeron en SQL Server 2008, por lo que es posible que, al final, le interese volver a generar los catálogos de texto completo.

Nota Nota

La regeneración se puede ejecutar en modo de varios subprocesos; además, si hay más de 10 CPU disponibles y permite que el proceso de regeneración use todas ellas, dicho proceso puede resultar más rápido que el de importación.

Si un catálogo de texto completo no está disponible, se vuelven a generar los índices de texto completo asociados. Esta opción solo está disponible para bases de datos de SQL Server 2005.

Para obtener información sobre el impacto de importar un índice de texto completo, vea "Consideraciones sobre la elección de una opción de actualización de texto completo" más adelante en este tema.

Volver a generar

Los catálogos de texto completo se vuelven a generar con los separadores de palabras nuevos y mejorados que se introdujeron en SQL Server 2008. La regeneración de los índices puede llevar cierto tiempo y, después de la actualización, podría ser necesaria una cantidad significativa de CPU y de memoria.

Restablecer

Los catálogos de texto completo se restablecen. Cuando se actualizan desde SQL Server 2005, los catálogos de texto completo se quitan, pero los metadatos de los catálogos de texto completo y los índices de texto completo se conservan. Después de actualizarse, todos los índices de texto completo quedan deshabilitados para el seguimiento de cambios y los rastreos no se inician de forma automática. El catálogo permanecerá vacío hasta que se emita manualmente un rellenado completo después de que se complete la actualización.

Todas estas opciones de actualización permiten asegurarse de que las bases de datos actualizadas se benefician de las mejoras en el rendimiento del texto completo de SQL Server 2008 y versiones posteriores.

Nota importante Importante

Para obtener información sobre cómo usar los nuevos separadores de palabras y cómo actualizar los archivos de palabras irrelevantes a las listas de palabras irrelevantes después de importar un índice de texto completo de SQL Server 2005, vea el tema sobre actualización de búsqueda de texto completo en la Ayuda del programa de instalación de Microsoft SQL Server 2012.

Consideraciones sobre la elección de una opción de actualización de texto completo

Cuando elija la opción de actualización, tenga en cuenta lo siguiente:

  • ¿Cómo usa los separadores de palabras?

    El servicio de búsqueda en texto completo de Microsoft SQL Server 2012 incluye los separadores de palabras y los lematizadores que se introdujeron en SQL Server 2008. Estos podrían cambiar los resultados de las consultas de texto completo llevadas a cabo en SQL Server 2005 para un determinado escenario o patrón de texto. Por tanto, a la hora de elegir una opción de actualización adecuada, es importante que tenga en cuenta el uso que va a dar a los separadores de palabras:

    • Si los separadores de palabras del idioma de texto completo que usa no han cambiado en SQL Server 2008 o versiones posteriores, o si la precisión de la recuperación no le parece crítica, la importación es una opción adecuada. Más adelante, si experimenta problemas de recuperación y desea actualizar a los nuevos separadores de palabras, solo tendrá que volver a generar los catálogos de texto completo. Para obtener más información, vea el tema sobre actualización de búsqueda de texto completo en la Ayuda del programa de instalación de Microsoft SQL Server 2012.

    • Si le preocupa la precisión de la recuperación y usa uno de los separadores de palabras que se mejoraron en SQL Server 2008, la regeneración es la opción adecuada.

  • ¿Se han generado índices de texto completo en columnas de clave de texto completo cuyo tipo de datos es Integer?

    La regeneración realiza optimizaciones internas que, en algunos casos, mejoran el rendimiento de las consultas del índice de texto completo actualizado. En concreto, si tiene catálogos de texto completo que contienen índices de texto completo para los que la columna de clave de texto completo de la tabla base es un tipo de datos Integer, al volver a generarlos, se logra un rendimiento ideal de las consultas de texto completo después de la actualización. En este caso, es muy recomendable el uso de la opción Volver a generar.

    Nota Nota

    Para los índices de texto completo de Microsoft SQL Server 2012, se recomienda que el tipo de datos de la columna que actúa como clave de texto completo sea Integer. Para obtener más información, vea el tema sobre ajuste y optimización del rendimiento (búsqueda de texto completo) en los Libros en pantalla de Microsoft SQL Server 2012.

  • ¿Cuál es la prioridad para poner en línea la instancia del servidor?

    El proceso de importación o regeneración durante la actualización consume muchos recursos de la CPU, lo que retrasa la actualización y puesta en línea del resto de la instancia del servidor. Si es importante poner en línea lo antes posible la instancia del servidor y desea ejecutar manualmente el rellenado después de la actualización, la opción Restablecer resulta adecuada.


Completar - Instalación

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Completar - Instalación
Vea también Enviar comentarios

Haga clic en Cerrar para finalizar la instalación.

Vea también

Conceptos

Validar una instalación de SQL Server


Requisitos previos de la instalación

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Requisitos previos de la instalación
Enviar comentarios

Para que SQL Server se instale correctamente, son necesarios los siguientes componentes de software en el equipo de instalación. Los instalará el programa de instalación de SQL Server:

  • .NET Framework versión 4.0 para todas las ediciones de Microsoft SQL Server 2012

  • Archivos de soporte para la instalación de SQL Server

  • SQL Server Native Client

Nota Nota

Si el programa de instalación produce errores o se cancela, estos componentes no se quitarán. Para quitarlos, utilice Agregar o quitar programas en el Panel de control.

Opciones

Para instalar los archivos de requisitos previos, haga clic en Instalar. Para salir de la instalación, haga clic en Cancelar.


Progreso de la instalación

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Progreso de la instalación
Vea también Enviar comentarios

Utilice la página Progreso de la instalación del Asistente para la instalación de SQL Server para supervisar el estado de la instalación de SQL Server.

Vea también

Conceptos

Ver y leer los archivos de registro de instalación de SQL Server


Tipo de instalación

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Tipo de instalación
Enviar comentarios

Use la página Tipo de instalación del Asistente para la instalación de SQL Server con el fin de especificar si desea instalar una nueva instancia de SQL Server o agregar características a una instancia existente.

Opciones

Seleccione el botón de opción correspondiente a su elección:

  • Realizar una nueva instalación de SQL Server

  • Agregar características a una instancia existente de SQL Server

    Si selecciona la opción para agregar características a una instancia existente, use la lista desplegable para elegir la instancia de SQL Server que desea actualizar.

Solo puede agregar las características admitidas de SysPrep (Motor de base de datos y Reporting Services) a una imagen preparada de SQL Server. Otras características que no admita SysPrep se pueden agregar después de que se haya completado la instancia preparada.

Nota No puede agregar características a una instancia en clúster de conmutación por error una vez instalada. Para agregar características de SQL Server a un clúster de conmutación por error existente, debe realizar una nueva instalación para instalar una instancia independiente de SQL Server.


Configuración de instancia

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Configuración de instancia
Enviar comentarios

Utilice la página Configuración de instancia del Asistente para la instalación de SQL Server con el fin de especificar si desea crear una instancia predeterminada o una instancia con nombre de SQL Server. Si aún no hay instalada una instancia de SQL Server, se creará una predeterminada, a menos que especifique una instancia con nombre.

Cada instancia de SQL Server consta de un conjunto de servicios distinto con una configuración específica para intercalaciones y otras opciones. La estructura de directorios, la estructura del Registro y los nombres de los servicios reflejan todos el nombre de instancia y un identificador de instancia específico que se crearon durante la instalación de SQL Server.

La instancia puede ser una instancia predeterminada o una instancia con nombre. El nombre de instancia predeterminado es MSSQLSERVER. Para realizar una conexión, no es necesario que un cliente especifique el nombre de la instancia. La instancia con nombre queda determinada por el usuario durante la instalación. Puede instalar SQL Server como una instancia con nombre sin instalar primero la instancia predeterminada. Al mismo tiempo, solo una instalación de SQL Server, independientemente de la versión, puede ser la instancia predeterminada.

Nota Nota

Con SysPrep de SQL Server, puede especificar el nombre de instancia cuando complete una instancia preparada en la página Configuración de instancia. Puede optar por configurar la instancia preparada que está completando como una instancia predeterminada si no existe una instancia predeterminada de SQL Server en el equipo.

Instancias múltiples

SQL Server admite varias instancias de SQL Server en un solo servidor o procesador, pero solo una puede ser la predeterminada. Todas las demás deben ser instancias con nombre. Un equipo puede ejecutar varias instancias de SQL Server simultáneamente y cada instancia se ejecuta independientemente de las otras instancias.

Para obtener más información, vea Especificaciones de capacidad máxima para SQL Server.

Opciones

Solo instancias de clústeres de conmutación por error: especifique el nombre de red en clúster de conmutación por error de SQL Server. Este nombre identifica la instancia en clúster de conmutación por error en la red.

Instancia predeterminada o con nombre: tenga presente la información siguiente a la hora de decidir entre instalar una instancia predeterminada o una instancia con nombre de SQL Server:

  • Si piensa instalar una única instancia de SQL Server en un servidor de base de datos, debe ser una instancia predeterminada.

  • Use una instancia con nombre para aquellas situaciones en las que piensa tener varias instancias en el mismo equipo. Un servidor solo puede alojar una instancia predeterminada.

  • Cualquier aplicación que instale SQL Server Express debe instalarla como instancia con nombre. Con ello se reducen los conflictos en situaciones en las que se instalan varias aplicaciones en el mismo equipo.

Instancia predeterminada

Seleccione esta opción para instalar una instancia predeterminada de SQL Server. Un equipo solo puede hospedar una instancia predeterminada; todas las demás instancias deben ser instancias con nombre. No obstante, si tiene instalada una instancia predeterminada de SQL Server, podrá agregar una instancia predeterminada de Analysis Services al mismo equipo.

Instancia con nombre

Seleccione esta opción para crear una instancia con nombre nueva. Cuando asigne un nombre a una instancia de SQL Server, tenga en cuenta lo siguiente:

  • En los nombres de instancia no se distinguen mayúsculas y minúsculas.

  • Los nombres no pueden comenzar ni terminar por un guión bajo (_).

  • Los nombres de instancia no pueden contener el término "Default" ni otras palabras clave reservadas. Si se utiliza una palabra clave reservada en un nombre de instancia, se producirá un error en el programa de instalación. Para obtener más información, vea Palabras clave reservadas.

  • Si especifica MSSQLServer como nombre de instancia, se creará una instancia predeterminada. En SQL Server Express, si especifica SQLExpress como nombre de instancia, se creará una instancia predeterminada.

  • Una instalación de Microsoft SQL Server 2012 PowerPivot para SharePoint siempre se instala como una instancia con nombre de 'PowerPivot'. No puede especificar un nombre de instancia diferente para este rol de característica.

  • Los nombres de instancias están limitados a 16 caracteres.

  • El primer carácter del nombre de la instancia debe ser una letra. Las letras aceptables son las que define el estándar Unicode 2.0. Se incluyen los caracteres latinos, a-z, A-Z y los caracteres alfabéticos de otros idiomas.

  • Los siguientes caracteres pueden ser letras definidas por el estándar Unicode 2.0, números decimales del alfabeto Latín básico y de otros alfabetos nacionales, el signo de dólar ($) o un carácter de subrayado (_).

  • En los nombres de instancia no se permiten espacios insertados ni otros caracteres especiales. Tampoco se permiten la barra diagonal inversa (\), la coma (,), los dos puntos (:), el punto y coma (;), la comilla simple ('), el símbolo de y comercial (&) ni la arroba (@).

    Nota Nota

    Solo los caracteres que sean válidos en la página actual de códigos de Windows se pueden utilizar en los nombres de instancia de SQL Server. Si se utiliza un carácter Unicode no admitido, se producirá un error en el programa de instalación.

Instancias y características detectadas

Vea una lista de las instancias y los componentes de SQL Server instalados en el equipo en el que se ejecuta el programa de instalación de SQL Server.

Id. de instancia: de forma predeterminada, el nombre de instancia se utiliza como identificador de la instancia. Se usa para identificar los directorios de instalación y las claves del Registro para la instancia de SQL Server. Es así en las instancias predeterminadas y en las instancias con nombre. Con una instancia predeterminada, el nombre y el identificador serían MSSQLSERVER. Para utilizar un identificador de instancia no predeterminado, especifíquelo en el campo Id. de instancia.

Nota importante Importante

Con SysPrep de SQL Server, el identificador de instancia que se muestra en esta página es el identificador de instancia especificado durante el paso de preparación de la imagen en el proceso SysPrep de SQL Server. No podrá especificar un identificador de instancia diferente durante el paso para completar la imagen.

Nota Nota

No se admiten identificadores de instancia que comiencen por un guión bajo (_) o que contengan el signo de almohadilla (#) o el signo de dólar ($).

Para obtener más información acerca de los directorios, las ubicaciones de los archivos y la asignación de nombres a las instancias, vea Ubicaciones de archivos para las instancias predeterminadas y con nombre de SQL Server.

Directorio raíz de instancia: de forma predeterminada, el directorio raíz de la instancia es C:\Archivos de programa\Microsoft SQL Server\. Para especificar un directorio raíz no predeterminado, haga clic en el botón Examinar o proporcione un nombre de ruta.

Todos los componentes de una instancia determinada de SQL Server se administran como una unidad. Todos los Service Pack y actualizaciones de SQL Server se aplicarán a cada componente de una instancia de SQL Server.

Todos los componentes de SQL Server que comparten el mismo nombre de instancia deben cumplir los siguientes criterios:

  • La misma versión

  • La misma edición

  • La misma configuración de idioma

  • El mismo estado de clúster

    Nota Nota

    Reporting Services no detecta los clústeres.

  • El mismo sistema operativo


Seleccionar instancia (Desinstalar)

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Seleccionar instancia (Desinstalar)
Enviar comentarios

En la página Seleccionar instancia (Desinstalar), use la lista desplegable para especificar la instancia de SQL Server que va a desinstalar.

Opciones

Puede especificar una instancia completa de SQL Server o puede indicar que se desinstalen únicamente las características compartidas y las herramientas de administración.


Seleccionar instancia (Actualizar)

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Seleccionar instancia (Actualizar)
Enviar comentarios

Use la página Seleccionar instancia (Actualizar) para especificar la instancia de SQL Server que desea actualizar.

Opciones

Todos los componentes de una instancia se deben actualizar al mismo tiempo. No puede agregar o quitar características durante la actualización.


Instancia a actualizar

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Instancia a actualizar
Vea también Enviar comentarios

Utilice la página Instancia para actualizar del Asistente para la instalación de SQL Server con el fin de especificar la instancia de SQL Server 2005, SQL Server 2008 o SQL Server 2008 R2 que desea actualizar a Microsoft SQL Server 2012.

Opciones

Utilice los botones de opción para especificar si desea actualizar la instancia de SQL Server y sus componentes compartidos o si solo desea actualizar los componentes compartidos. Los componentes compartidos de esta versión de SQL Server son los siguientes:

  • Integration Services

  • Explorador de SQL Server

  • Servicio auxiliar de Active Directory de SQL Server

  • Objeto de escritura de SQL

Para obtener más información sobre los escenarios de actualización admitidos y los problemas de actualización conocidos, vea la página relativa a las actualizaciones de versión y edición.

Vea también

Otros recursos

Usar el Asesor de actualizaciones para preparar las actualizaciones
Trabajar con varias versiones de SQL Server


Finalización de la desinstalación

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Finalización de la desinstalación
Enviar comentarios

Use la página Finalización de la desinstalación para comprobar que la operación se ha completado correctamente.


Progreso de preparación de imagen

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Progreso de preparación de imagen
Vea también Enviar comentarios

Use la página Progreso de preparación de imagen del Asistente para instalación de SQL Server para supervisar el estado de la instalación de la preparación de imagen de SQL Server. Al completarse este paso, esta página enumera el estado de cada característica de SQL Server preparada durante este proceso.

Vea también

Conceptos

Ver y leer los archivos de registro de instalación de SQL Server


Reglas para preparar la imagen

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Reglas para preparar la imagen
Enviar comentarios

El programa de instalación de SQL Server valida la configuración del equipo antes de que se complete la operación de instalación. Durante la instalación de SQL Server, el Comprobador de configuración del sistema (SCC) examina el equipo en el que se instalará SQL Server. El SCC comprueba las condiciones que impiden una operación de instalación correcta de SQL Server. Antes de que el programa de instalación inicie el asistente, el SCC recupera el estado de cada elemento. A continuación, compara el resultado con las condiciones necesarias y proporciona instrucciones para evitar problemas de bloqueo.

La comprobación de la configuración del sistema genera un informe que contiene una descripción breve de cada regla ejecutada y el estado de ejecución. El informe de comprobación de la configuración del sistema se encuentra en %archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMDD_HHMM>\.

Antes de ejecutar la operación de instalación, revise los temas siguientes:

  1. Requisitos de hardware y software para instalar SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Características compatibles con las ediciones de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Consideraciones de seguridad para una instalación de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versiones en idioma local en SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Otras referencias:

  1. Actualizaciones de ediciones y versiones admitidas(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar los clústeres de conmutación por error(http://go.microsoft.com/fwlink/?LinkId=235034)


Tipo de imagen para preparar

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Tipo de imagen para preparar
Enviar comentarios

Use la página Tipo de imagen para preparar del Asistente para la instalación de SQL Server para especificar si desea instalar una nueva instancia de Microsoft SQL Server 2012 o agregar características a una instancia existente.

Opciones

Seleccione el botón de opción correspondiente a su elección:

  • Preparar una nueva instancia de Microsoft SQL Server 2012

  • Agregar características a una instancia preparada existente de Microsoft SQL Server 2012

    Si selecciona la opción para agregar características a una instancia existente, use la lista desplegable para elegir la instancia preparada de SQL Server que desea actualizar.

    Nota Nota

    Puede agregar las características admitidas de SysPrep de SQL Server (Motor de base de datos y Reporting Services) a una imagen preparada de SQL Server. Otras características que no admita SysPrep de SQL Server solo se pueden agregar después de que se haya completado la instancia preparada.


Clave de producto

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Clave de producto
Enviar comentarios

Use la página Clave del producto para validar la instancia de SQL Server o especificar la edición gratuita de SQL Server que va a instalar.

Opciones

Para especificar una edición gratuita de SQL Server, seleccione el botón de opción para instalaciones gratuitas y, a continuación, use la lista desplegable para identificar la edición que va a instalar.

Para validar una edición pagada de SQL Server, seleccione el botón de opción para la clave del producto y, a continuación, proporcione la clave en el espacio proporcionado.

En instalaciones de clúster de conmutación por error, use la misma clave del producto para cada nodo de clúster de conmutación por error. Si la clave del producto pertenece a una edición de SQL Server diferente, se producirá un error.


Progreso (Desinstalar)

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Progreso (Desinstalar)
Vea también Enviar comentarios

Use la página Progreso (Desinstalar) para supervisar el progreso de la instalación.

Vea también

Conceptos

Ver y leer los archivos de registro de instalación de SQL Server


Listo para completar la imagen

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Listo para completar la imagen
Enviar comentarios

La página Listo para completar la imagen proporciona un resumen de los valores de configuración que se aplican a la configuración de la instancia preparada.

Opciones

En esta página dispone de las siguientes opciones:

  • Para continuar con la instalación, haga clic en Instalar.

  • Para cambiar la configuración de la instalación, haga clic en Atrás.

  • Para salir de la instalación, haga clic en Cancelar.


Listo para instalar

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Listo para instalar
Vea también Enviar comentarios

La página Listo para instalar proporciona un resumen de las características que el programa de instalación de SQL Server va a instalar o cambiar.

Opciones

En esta página dispone de las siguientes opciones:

  • Para continuar con la instalación, haga clic en Instalar.

  • Para cambiar la configuración de la instalación, haga clic en Atrás.

  • Para salir de la instalación, haga clic en Cancelar.

Vea también

Conceptos

Ver y leer los archivos de registro de instalación de SQL Server


Listo para preparar la imagen

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Listo para preparar la imagen
Enviar comentarios

La página Listo para preparar la imagen proporciona un resumen de las características que va a preparar el programa de instalación de SQL Server.

Opciones

En esta página dispone de las siguientes opciones:

  • Para continuar con la instalación, haga clic en Instalar.

  • Para cambiar la configuración de la instalación, haga clic en Atrás.

  • Para salir de la instalación, haga clic en Cancelar.


Listo para reparar

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Listo para reparar
Vea también Enviar comentarios

La página Listo para reparar proporciona un resumen del proceso de reparación por parte del programa de instalación de SQL Server.

Opciones

En esta página dispone de las siguientes opciones:

  • Para continuar con la instalación, haga clic en Reparar.

  • Para cambiar la configuración de la instalación, haga clic en Atrás.

  • Para salir de la instalación, haga clic en Cancelar.

Vea también

Conceptos

Ver y leer los archivos de registro de instalación de SQL Server


Eliminar un nodo de clúster de conmutación por error de SQL Server

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Eliminar un nodo de clúster de conmutación por error de SQL Server
Enviar comentarios

Use la página Eliminar un nodo de clúster de conmutación por error para identificar el equipo que se va a quitar como nodo de clúster de conmutación por error de Microsoft SQL Server 2012.


Progreso de la reparación

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Progreso de la reparación
Vea también Enviar comentarios

Utilice la página Progreso de la reparación del Asistente para la instalación de SQL Server para supervisar el estado de la reparación de SQL Server.

Vea también

Conceptos

Ver y leer los archivos de registro de instalación de SQL Server


Opciones de configuración de Reporting Services (SSRS)

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Opciones de configuración de Reporting Services (SSRS)
Vea también Enviar comentarios

Use la página Configuración de Reporting Services del Asistente para la instalación de Microsoft SQL Server para especificar la forma en que se instala y configura un servidor de informes. La disponibilidad de una opción de instalación depende de las opciones que se seleccionaron en la página Selección de características y de si también se está instalando una instancia local del Motor de base de datos de SQL Server al mismo tiempo que se instala el servidor de informes.

En algunos casos, si un certificado de Capa de sockets seguros (SSL) se instala en el equipo y se enlaza a un carácter comodín seguro, el programa de instalación creará las direcciones URL de Reporting Services usando el prefijo HTTPS. Para obtener más información acerca de cómo se asignan los certificados a las direcciones URL de Reporting Services, vea Configurar un servidor de informes para conexiones SSL (http://go.microsoft.com/fwlink/?LinkId=199089) en los Libros en pantalla de SQL Server.

Para obtener la información más reciente relacionada con Reporting Services y la instalación y configuración de esta versión, vea Información adicional de instalación (http://go.microsoft.com/fwlink/?LinkId=207425).

Opciones

Modo nativo de Reporting Services

Si el programa de instalación no puede realizar una configuración predeterminada del servidor de informes porque no se cumplen uno o más requisitos, el Asistente para la instalación solo permitirá la opción mínima de instalación; copiará los archivos que necesita, pero le obligará a usar el Administrador de configuración de Reporting Services para configurar un servidor de informes en modo nativo una vez completada la instalación.

Nota Nota

Un archivo de base de datos del servidor de informes existente puede provocar un error en la instalación si elige una de las opciones de instalación predeterminadas. Cuando elige la opción de instalación predeterminada, el programa de instalación intenta crear una base de datos de servidor de informes empleando el nombre predeterminado. Si ya existe una base de datos con ese nombre, se producirá un error en la instalación y tendrá que revertirla. Para evitar este problema, puede cambiar el nombre de la base de datos existente antes de ejecutar la instalación o elegir la opción Solo instalar para poder especificar la configuración personalizada de la base de datos una vez terminada la instalación.

Instalar y configurar

Instala una instancia del servidor de informes en modo nativo con los valores predeterminados para las bases de datos, la cuenta de servicio y las reservas de direcciones URL del servidor de informes. Si elige esta opción, la instancia del servidor de informes estará lista para ser utilizada una vez finalizada la instalación. El programa de instalación crea la base de datos del servidor de informes utilizando una instancia de Motor de base de datos local y configura un servidor de informes para que utilice valores predeterminados.

Esta opción solo está disponible si los valores predeterminados utilizados en una instalación del servidor de informes son válidos para el sistema. Esta opción es recomendable para programadores que deseen instalar todos los componentes localmente y para usuarios que estén evaluando el software.

Para ver información sobre la configuración predeterminada que utiliza el programa de instalación, o para conocer los motivos por los que no se puede instalar la configuración predeterminada, haga clic en Detalles. Para obtener más información sobre la configuración predeterminada para un servidor de informes en modo nativo, vea Configuración predeterminada para una instalación en modo nativo (Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199091).

Solo instalar

Instala los archivos de programa del servidor de informes, crea la cuenta del servicio Servidor de informes y registra el proveedor de Instrumental de administración de Windows (WMI) del servidor de informes. Esta opción de instalación se denomina instalación de "solo archivos". Seleccione esta opción si no desea utilizar la configuración predeterminada. Si no se puede instalar la configuración predeterminada, o si va a instalar un clúster de conmutación por error de SQL Server que incluye Reporting Services, esta es la única opción disponible. Para obtener más información acerca de una instalación de solo archivos, vea Instalación de solo archivos (Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199093).

Una vez finalizada la instalación, deberá crear la base de datos del servidor de informes y configurar el servidor de informes antes de utilizarla. Para configurar un servidor de informes y crear la base de datos, utilice el Administrador de configuración de Reporting Services. Para obtener más información, vea Cómo crear una base de datos de servidor de informes (configuración de Reporting Services) (http://go.microsoft.com/fwlink/?LinkId=199094) y Configurar una conexión a la base de datos del servidor de informes (http://go.microsoft.com/fwlink/?LinkId=199095).

Modo de SharePoint de Reporting Services

Solo instalar

Instala los archivos de programa del servidor de informes y los cmdlets de PowerShell. Una vez completada la instalación, necesitará iniciar los servicios de SharePoint de Reporting Services y crear una aplicación de servicio de Reporting Services. Para obtener más información, vea Información general para instalar y configurar el servicio de Reporting Services para la integración de SharePoint (http://go.microsoft.com/fwlink/?LinkId=207543), Crear una aplicación de servicios de SQL Server Reporting Services (SSRS) (http://go.microsoft.com/fwlink/?LinkId=207544) e Información general la integración de Reporting Services y SharePoint (http://go.microsoft.com/fwlink/?LinkID=207244).

Instalar el complemento Reporting Services para tecnologías de SharePoint

A partir de la versión de Microsoft SQL Server 2012, el complemento se puede instalar como parte de la instalación de SQL Server, en la página de selección de características del asistente para la instalación de SQL Server.

No obstante, puede instalar el Complemento Reporting Services para SharePoint 2010 mediante uno de los métodos siguientes:

  • Ejecute la herramienta PreRequisiteInstaller.exe de preparación de productos de SharePoint 2010.

  • Realice la instalación desde el medio de instalación de SQL Server. Haga clic en el archivo rsSharePoint.msi de la carpeta Setup del medio de instalación de SQL Server una vez completada la instalación de SQL Server.

  • Descargue e instale el complemento. Para obtener más información, vea Dónde encontrar el complemento Reporting Services para Productos de SharePoint (http://go.microsoft.com/fwlink/?LinkID=208634).

Vea también

Otros recursos

Iniciar la herramienta Configuración de Reporting Services
Cómo crear una base de datos de servidor de informes (configuración de Reporting Services)
Consideraciones para instalar Reporting Services
Configuración predeterminada para una instalación en modo nativo (Reporting Services)
Configuración predeterminada para el modo integrado de SharePoint (Reporting Services)
Instalar SQL Server desde el símbolo del sistema


Actualización del modo de SharePoint de Reporting Services (SSRS)

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Actualización del modo de SharePoint de Reporting Services (SSRS)
Vea también Enviar comentarios

Use la página Modo de SharePoint de Reporting Services para confirmar la actualización de todas las características compartidas. El modo de SharePoint de Reporting Services es una característica compartida de SQL Server y se actualiza junto con todas las demás características compartidas de SQL Server. El asistente para la instalación de SQL Server no admite la actualización de una sola característica compartida. Todas las características compartidas de SQL Server se actualizan al mismo tiempo.

Opciones

El botón Siguiente solo se encuentra disponible si ha seleccionado la casilla Continuar con la actualización. Si no selecciona la casilla, no puede continuar con la actualización.

Para obtener más información, vea Actualización de Reporting Services (http://go.microsoft.com/fwlink/?LinkId=199092).

Vea también

Conceptos

Ver y leer los archivos de registro de instalación de SQL Server

Otros recursos

Instalar SQL Server desde el símbolo del sistema


Autenticación del modo de SharePoint de Reporting Services

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Autenticación del modo de SharePoint de Reporting Services
Vea también Enviar comentarios

Use la página Autenticación del modo de SharePoint de Reporting Services del Asistente para la instalación de Microsoft SQL Server para especificar las credenciales de la cuenta de servicio que se usa en la instalación actual de Reporting Services. Las credenciales se usarán para crear un nuevo grupo de aplicaciones de SharePoint. Además, se creará una nueva aplicación de servicio de SharePoint para Reporting Services. El nombre de la aplicación de servicio contendrá el nombre de la instancia anterior de Reporting Services.

Opciones

  • La opción Nombre de la cuenta del grupo de aplicaciones SSRS es de solo lectura. El valor se rellena automáticamente con el valor actual de la instalación de Reporting Services existente que va a actualizar.

  • La opción Contraseña de la cuenta del grupo de aplicaciones SSRS estará deshabilitada si la cuenta del grupo de aplicaciones no requiere una contraseña. Por ejemplo, “NT Authority\NetworkSerivce”. Si la cuenta del grupo de aplicaciones requiere una contraseña, no podrá continuar con la actualización hasta que escriba la contraseña correcta.

Para obtener más información, vea Actualización de Reporting Services (http://go.microsoft.com/fwlink/?LinkId=199092).

Vea también

Otros recursos

Actualización de Reporting Services


Seleccionar una instancia preparada

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Seleccionar una instancia preparada
Enviar comentarios

Use la página Seleccionar una instancia preparada para especificar la instancia preparada que desea completar.

Opciones

El cuadro Seleccione un identificador de instancia enumera las instancias preparadas que puede completar. Seleccione una instancia preparada que desee completar.

Seleccione un identificador de instancia

La lista incluye todas las instancias preparadas que puede completar en el equipo en el que se ejecuta el programa de instalación de SQL Server. Seleccione una instancia preparada que desee completar.

Instancias instaladas

Incluye las instancias instaladas, preparadas y completadas.


Configurar servidor - Intercalación

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Configurar servidor - Intercalación
Enviar comentarios

En la página Configuración del servidor - Intercalación del Asistente para la instalación de SQL Server, puede modificar los valores de intercalación que Motor de base de datos y Analysis Services utilizan para la ordenación. Seleccione la opción que coincida con los valores de intercalación de distintas instalaciones de SQL Server, o de otro equipo.

Opciones

Personalizar para SQL Server y Analysis Services

SQL Server proporciona dos grupos de intercalaciones: las de Windows y las de SQL Server. Puede especificar unos valores de intercalación independientes para el Motor de base de datos y para Analysis Services, o puede especificar la misma intercalación para ambos.

De forma predeterminada, se selecciona una intercalación de SQL Server para las configuraciones regionales en idioma inglés. El valor de configuración regional del sistema de Windows del equipo determina la intercalación predeterminada de las versiones localizadas de SQL Server. Para obtener más información, vea Using SQL Collations.

La configuración predeterminada solo se debería cambiar si la configuración de intercalación de esta instalación de SQL Server debe coincidir con la que usa otra instancia de SQL Server o con la configuración regional de Windows de otro equipo.

Nota Analysis Services solo usa las intercalaciones de Windows. Si piensa instalar Analysis Services, seleccione una intercalación de Windows durante la instalación de SQL Server para asegurarse de que los resultados son coherentes entre Motor de base de datos de SQL Server y Analysis Services.

Para obtener más información, vea Configuración de intercalación en el programa de instalación.

Prácticas recomendadas

Para obtener más información acerca de una tabla de configuraciones regionales del sistema de Windows y las intercalaciones predeterminadas correspondientes utilizadas por el programa de instalación de SQL Server, vea Configuración de intercalación en el programa de instalación.

Si es posible, utilice una sola intercalación para su organización. De esta manera no tiene que especificar explícitamente la intercalación para cada base de datos, columna, expresión o identificador. Si tiene que trabajar con varias intercalaciones y configuraciones de páginas de códigos distintas, codifique sus consultas para que tengan en cuenta las reglas de prioridad de intercalación. Para obtener más información, vea el tema de los Libros en pantalla correspondiente a Prioridad de las intercalaciones (Transact-SQL).

Al seleccionar una intercalación para SQL Server, considere las recomendaciones siguientes:

  • Seleccione una intercalación BINARY2 si la ordenación basada en el punto de código binario es aceptable.

  • Seleccione una intercalación de Windows para realizar una comparación coherente a través de los tipos de datos.

  • Use la nueva intercalación de nivel 100 para permitir una mejor ordenación lingüística. Para obtener más información, vea el tema Compatibilidad con la intercalación y Unicode.

  • Si piensa migrar una base de datos a una instancia actualizada de SQL Server, seleccione la intercalación que coincida con la intercalación existente de la base de datos.


Configuración del servidor - Cuentas de servicio

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Configuración del servidor - Cuentas de servicio
Vea también Enviar comentarios

Use la página Configuración del servidor del Asistente para la instalación de SQL Server con el fin de asignar cuentas de inicio de sesión a los servicios de SQL Server. Los servicios reales configurados en esta página dependen de las características que haya seleccionado para instalarse.

Las cuentas de inicio utilizadas para iniciar y ejecutar SQL Server pueden ser cuentas de usuario de dominio, cuentas de usuario local, cuentas de servicio administradas, cuentas virtuales o cuentas del sistema integradas.

Opciones

Puede asignar la misma cuenta de inicio de sesión a todos los servicios de SQL Server o configurar cada cuenta de servicio individualmente. También puede especificar si los servicios se inician de forma automática o manual, o si están deshabilitados. Se recomienda la cuenta predeterminada para la mayoría de las instalaciones.

  • En Windows 7 y Windows Server 2008 R2, de forma predeterminada casi todas las cuentas son virtuales.

  • En Windows Vista y Windows Server 2008, de forma predeterminada casi todas las cuentas se asignan a la cuenta SERVICIO DE RED.

  • En una instalación de clúster en Windows Server 2008, debe proporcionar una cuenta de dominio.

Si configura servicios para que usen cuentas de dominio, Microsoft recomienda que configure las cuentas de servicio de forma individual para proporcionar a cada servicio los privilegios mínimos; así, los servicios de SQL Server obtendrán los permisos mínimos que necesitan para completar sus tareas. Para obtener más información, incluidas las descripciones de los tipos de cuentas, vea Configurar cuentas de servicio de Windows.

Configurar individualmente las cuentas de los servicios de SQL Server (recomendado)

Utilice la cuadrícula para proporcionar a cada servicio de SQL Server un nombre de usuario y una contraseña de inicio de sesión, y para establecer el tipo de inicio para el servicio. Puede utilizar cuentas del sistema integradas, una cuenta local, un grupo local, un grupo de dominios o cuentas de usuario de dominio para los servicios de SQL Server.

Seleccione cualquiera de los siguientes servicios para personalizar su configuración.

Seleccione este servicio

Para configurar los valores de autenticación de

Agente SQL Server

El servicio que ejecuta trabajos, supervisa, SQL Server y permite la automatización de tareas administrativas.

No hay ninguna cuenta de inicio de sesión predeterminada para este servicio.

El tipo de inicio predeterminado es Manual.

SQL Server

El Motor de base de datos de SQL Server.

El tipo de inicio predeterminado es Automático.

Nota Nota

SQL Server Browser

SQL Server Browser es el servicio de resolución de nombres que proporciona información de conexión de SQL Server a los equipos cliente. Este servicio lo comparten varias instancias de SQL Server y de Integration Services.

La cuenta de inicio de sesión predeterminada es el servicio NT Authority\Local y no se puede cambiar durante la instalación de SQL Server. Puede cambiar la cuenta una vez completado el proceso de instalación.

Si no se especifica el tipo de inicio durante el proceso de instalación, se determina de la siguiente forma:

  • SQL Server Browser se establece en Automatic y se ejecuta en los escenarios de instalación que se describen a continuación:

    • Instancia de clúster de conmutación por error de SQL Server

    • Instancia con nombre de SQL Server donde está habilitado TCP o NP

    • Instancia con nombre de Analysis Server que no está en clúster

  • Si no se aplica ninguno de los escenarios anteriores y el Explorador de SQL Server ya está instalado, se mantendrá el estado actual del Explorador de SQL Server.

  • El tipo de inicio se establece como Deshabilitado y se detiene si no hay una instancia de SQL Server 2005, SQL Server 2008 o SQL Server 2008 R2 existente anterior a la instalación.

Analysis Services

Analysis Services.

El tipo de inicio predeterminado es Automático.

Para el modo integrado de SharePoint, debe especificar una cuenta de usuario de dominio de Windows. La cuenta especificada se utiliza para el servicio de Analysis Services. La cuenta que especifique para la instancia actual se debe usar también para las instancias de Analysis Services adicionales que se agregan a continuación a la misma granja de servidores.

Reporting Services

Reporting Services. Las cuentas de servicio se usan para configurar una conexión de base de datos del servidor de informes. Elija el servicio de red integrado si desea utilizar los valores de autenticación predeterminados. Si especifica una cuenta de usuario de dominio, asegúrese de registrar un nombre principal de servicio (SPN) para ella si está usando la autenticación de Windows en el servidor de informes. Para obtener más información, vea el tema sobre cómo configurar la autenticación de Windows en Reporting Services.

Nota importante Importante

Microsoft recomienda no usar la cuenta de servicio de red para los servicios de SQL Server o del Agente SQL Server si se dispone de una cuenta con privilegios menores, porque el servicio de red es una cuenta compartible. El servicio de red es adecuado para utilizarse como una cuenta de servicio de SQL Server solo si puede asegurarse de que ningún otro servicio que utilice la cuenta esté instalado en el equipo. Las cuentas de usuario local o de usuario de dominio que no son un administrador de Windows son más adecuadas para los servicios de SQL Server.

El tipo de inicio predeterminado es Automático.

Integration Services

Integration Services es un conjunto de herramientas gráficas y objetos programables para mover, copiar y transformar datos.

El tipo de inicio predeterminado es Automático.

SQL Server Full-text Filter Daemon Launcher

El servicio que crea los procesos fdhost.exe. Este servicio es necesario para hospedar los separadores de palabras y los filtros que procesan datos de texto en la indización de texto completo.

Si proporciona una cuenta de dominio en la que se va a ejecutar el servicio FDHOST Launcher, es muy recomendable que utilice una cuenta con pocos privilegios. Esta cuenta debe ser diferente de la usada para el servicio SQL Server. En Windows Vista y Windows Server 2008, el servicio FDHOST Launcher tiene como valor predeterminado LOCAL SERVICE.

SQL Server Distributed Replay Client

La cuenta de servicio que se usa para el servicio Distributed Replay Client.

Proporcione una cuenta en la que se ejecutará el servicio Distributed Replay Client. Esta cuenta debe ser diferente de la usada para el servicio SQL Server.

El tipo de inicio predeterminado es Manual.

SQL Server Distributed Replay Controller

La cuenta de servicio que se usa para el servicio Distributed Replay Controller.

Proporcione una cuenta en la que se ejecutará el servicio Distributed Replay Controller. Esta cuenta debe ser diferente de la usada para el servicio SQL Server.

El tipo de inicio predeterminado es Manual.

Vea también

Otros recursos

Consideraciones de seguridad para una instalación de SQL Server


Rol de instalación

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Rol de instalación
Vea también Enviar comentarios

Utilice esta página para especificar si utilizar la página Selección de características para seleccionar características individuales o para instalar utilizando un rol de instalación.

Un setup role es una selección fija de todas las características y componentes compartidos que se necesitan para implementar una configuración de SQL Server predefinida.

Opciones

Instalación de características de SQL Server

Elija esta opción para seleccionar características individuales y componentes compartidos. Entre las características de instancia se incluyen Servicios de Motor de base de datos, Analysis Services (modo nativo) y Reporting Services.

SQL Server PowerPivot para SharePoint

Elija esta opción para instalar los componentes de servidor de Analysis Services en una granja de SharePoint 2010. Esta opción implementa el servicio Sistema de PowerPivot y el servidor de Analysis Services en una granja de servidores, lo que habilita el procesamiento de datos y consultas a gran escala para los libros de Excel publicados que contienen datos de PowerPivot incrustados.

De manera opcional, puede agregar una instancia de motor de base de datos relacional a la instalación en caso que sea necesario hospedar bases de datos en una granja de servidores SharePoint. Si la granja de servidores ya está configurada, puede omitir esta opción.

Una vez finalizada la instalación, deberá configurar el software mediante uno de los métodos siguientes: herramienta de configuración de PowerPivot, cmdlets de PowerShell o SharePoint 2010 Central Administration. A diferencia de las versiones anteriores, la instalación ya no realiza ninguna tarea de configuración para una instalación de PowerPivot.

Una instalación basada en roles no incluye la aplicación cliente SQL Server PowerPivot para Excel. La aplicación cliente se instala por separado.

Todas las características con valores predeterminados

Elija este rol de instalación para instalar todas las características que están disponibles para esta versión. Observe que PowerPivot para SharePoint se excluye de este rol. Debe utilizar el rol de instalación de PowerPivot para SharePoint para instalar esa característica.

Motor de base de datos se configura para empezar a usar la cuenta NT AUTHORITY\NETWORK SERVICE. El usuario actual se proporcionará como un miembro del rol sysadmin de SQL Server. Los valores establecidos por esta opción se pueden invalidar especificando otros parámetros de línea de comandos.

En Windows Vista o Windows Server 2008 y versiones posteriores, y cuando el sistema operativo no sea un controlador de dominio, de forma predeterminada, Reporting Services y el Motor de base de datos utilizarán la cuenta NTAUTHORITY\NETWORK SERVICE, Integration Services utilizará la cuenta NTAUTHORITY\NETWORK SERVICE y el selector de demonio de filtro de texto completo de SQL utilizará la cuenta NTAUTHORITY\LOCAL SERVICE.

Vea también

Referencia

Selección de características

Otros recursos

Instalar PowerPivot para SharePoint
Requisitos de hardware y software (PowerPivot para SharePoint


Asistente para el clúster de conmutación por error de SQL Server (Completar)

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Asistente para el clúster de conmutación por error de SQL Server (Completar)
Vea también Enviar comentarios

El programa de instalación de SQL Server valida la configuración del equipo antes de que se complete la operación de instalación. Durante la instalación de SQL Server, el Comprobador de configuración del sistema (SCC) examina el equipo en el que se instalará SQL Server. El SCC comprueba las condiciones que impiden una operación de instalación correcta de SQL Server. Antes de que el programa de instalación inicie el Asistente para la instalación de SQL Server, el SCC recupera el estado de cada elemento. A continuación, compara el resultado con las condiciones necesarias y proporciona instrucciones para evitar problemas de bloqueo.

La comprobación de la configuración del sistema genera un informe que contiene una descripción breve de cada regla ejecutada y el estado de ejecución. El informe de comprobación de la configuración del sistema se encuentra en %archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMDD_HHMM>\.

Antes de ejecutar la operación de instalación, revise los temas siguientes:

  1. Requisitos de hardware y software para instalar SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Características compatibles con las ediciones de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Consideraciones de seguridad para una instalación de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versiones en idioma local en SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Otras referencias:

  1. Actualizaciones de ediciones y versiones admitidas(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar los clústeres de conmutación por error(http://go.microsoft.com/fwlink/?LinkId=235034)

Vea también

Referencia

Reglas auxiliares del programa de instalación


Asistente para el clúster de conmutación por error de SQL Server (Instalar)

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Asistente para el clúster de conmutación por error de SQL Server (Instalar)
Vea también Enviar comentarios

El programa de instalación de SQL Server valida la configuración del equipo antes de que se complete la operación de instalación. Durante la instalación de SQL Server, el Comprobador de configuración del sistema (SCC) examina el equipo en el que se instalará SQL Server. El SCC comprueba las condiciones que impiden una operación de instalación correcta de SQL Server. Antes de que el programa de instalación inicie el Asistente para la instalación de SQL Server, el SCC recupera el estado de cada elemento. A continuación, compara el resultado con las condiciones necesarias y proporciona instrucciones para evitar problemas de bloqueo.

La comprobación de la configuración del sistema genera un informe que contiene una descripción breve de cada regla ejecutada y el estado de ejecución. El informe de comprobación de la configuración del sistema se encuentra en %archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMDD_HHMM>\.

Antes de ejecutar la operación de instalación, revise los temas siguientes:

  1. Requisitos de hardware y software para instalar SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Características compatibles con las ediciones de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Consideraciones de seguridad para una instalación de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versiones en idioma local en SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Otras referencias:

  1. Actualizaciones de ediciones y versiones admitidas(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar los clústeres de conmutación por error(http://go.microsoft.com/fwlink/?LinkId=235034)

Vea también

Referencia

Reglas auxiliares del programa de instalación


Asistente para el clúster de conmutación por error de SQL Server (Preparar)

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Asistente para el clúster de conmutación por error de SQL Server (Preparar)
Vea también Enviar comentarios

El programa de instalación de SQL Server valida la configuración del equipo antes de que se complete la operación de instalación. Durante la instalación de SQL Server, el Comprobador de configuración del sistema (SCC) examina el equipo en el que se instalará SQL Server. El SCC comprueba las condiciones que impiden una operación de instalación correcta de SQL Server. Antes de que el programa de instalación inicie el Asistente para la instalación de SQL Server, el SCC recupera el estado de cada elemento. A continuación, compara el resultado con las condiciones necesarias y proporciona instrucciones para evitar problemas de bloqueo.

La comprobación de la configuración del sistema genera un informe que contiene una descripción breve de cada regla ejecutada y el estado de ejecución. El informe de comprobación de la configuración del sistema se encuentra en %archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMDD_HHMM>\.

Antes de ejecutar la operación de instalación, revise los temas siguientes:

  1. Requisitos de hardware y software para instalar SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Características compatibles con las ediciones de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Consideraciones de seguridad para una instalación de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versiones en idioma local en SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Otras referencias:

  1. Actualizaciones de ediciones y versiones admitidas(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar los clústeres de conmutación por error(http://go.microsoft.com/fwlink/?LinkId=235034)

Vea también

Referencia

Reglas auxiliares del programa de instalación


Resumen (Actualizar)

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Resumen (Actualizar)
Enviar comentarios

Use la página Resumen para ver las opciones especificadas para esta actualización.


Reglas auxiliares del programa de instalación

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Reglas auxiliares del programa de instalación
Enviar comentarios

El programa de instalación de SQL Server valida la configuración del equipo antes de que se complete la operación de instalación. Durante la instalación de SQL Server, el Comprobador de configuración del sistema (SCC) examina el equipo en el que se instalará SQL Server. El SCC comprueba las condiciones que impiden una operación de instalación correcta de SQL Server. Antes de que el programa de instalación inicie el Asistente para la instalación de SQL Server, el SCC recupera el estado de cada elemento. A continuación, compara el resultado con las condiciones necesarias y proporciona instrucciones para evitar problemas de bloqueo.

La comprobación de la configuración del sistema genera un informe que contiene una descripción breve de cada regla ejecutada y el estado de ejecución. El informe de comprobación de la configuración del sistema se encuentra en %archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMDD_HHMM>\.

Antes de ejecutar la operación de instalación, revise los temas siguientes:

  1. Requisitos de hardware y software para instalar SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Características compatibles con las ediciones de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Consideraciones de seguridad para una instalación de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versiones en idioma local en SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Otras referencias:

  1. Actualizaciones de ediciones y versiones admitidas(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar los clústeres de conmutación por error(http://go.microsoft.com/fwlink/?LinkId=235034)

Temas adicionales sobre reglas

Vea los siguientes temas sobre reglas de instalación específicas para cada escenario:

  • Reglas de instalación

  • Upgrade Rules Check

  • Reglas de actualización de edición

  • Página de desinstalación

  • Reglas para preparar la imagen

  • Reglas de completar imagen


Página de desinstalación

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Página de desinstalación
Vea también Enviar comentarios

La página de desinstalación ejecutará un conjunto de reglas para asegurarse de que la operación de instalación se pueda completar correctamente.

El programa de instalación de SQL Server valida la configuración del equipo antes de que se complete la operación de instalación. Durante la instalación de SQL Server, el Comprobador de configuración del sistema (SCC) examina el equipo en el que se instalará SQL Server. El SCC comprueba las condiciones que impiden una operación de instalación correcta de SQL Server. Antes de que el programa de instalación inicie el Asistente para desinstalar SQL Server, el SCC recupera el estado de cada elemento. A continuación, compara el resultado con las condiciones necesarias y proporciona instrucciones para evitar problemas de bloqueo.

La comprobación de la configuración del sistema genera un informe que contiene una descripción breve de cada regla ejecutada y el estado de ejecución. El informe de comprobación de la configuración del sistema se encuentra en %archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMDD_HHMM>\.

Antes de ejecutar la operación de instalación, revise los temas siguientes:

  1. Requisitos de hardware y software para instalar SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Características compatibles con las ediciones de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Consideraciones de seguridad para una instalación de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versiones en idioma local en SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Otras referencias:

  1. Actualizaciones de ediciones y versiones admitidas(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar los clústeres de conmutación por error(http://go.microsoft.com/fwlink/?LinkId=235034)

Vea también

Referencia

Reglas auxiliares del programa de instalación


Progreso de actualización

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Progreso de actualización
Vea también Enviar comentarios

Use la página Progreso de actualización del Asistente para la instalación de SQL Server para supervisar el estado de la actualización de SQL Server.

Vea también

Conceptos

Ver y leer los archivos de registro de instalación de SQL Server


Upgrade Rules Check

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Upgrade Rules Check
Vea también Enviar comentarios

El programa de instalación de SQL Server valida la configuración del equipo antes de que se complete la operación de instalación. Durante la instalación de SQL Server, el Comprobador de configuración del sistema (SCC) examina el equipo en el que se instalará SQL Server. El SCC comprueba las condiciones que impiden una operación de instalación correcta de SQL Server. Antes de que el programa de instalación inicie el Asistente para actualización, el SCC recupera el estado de cada elemento. A continuación, compara el resultado con las condiciones necesarias y proporciona instrucciones para evitar problemas de bloqueo.

La comprobación de la configuración del sistema genera un informe que contiene una descripción breve de cada regla ejecutada y el estado de ejecución. El informe de comprobación de la configuración del sistema se encuentra en %archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\Log\<AAAAMMDD_HHMM>\.

Antes de ejecutar la operación de instalación, revise los temas siguientes:

  1. Requisitos de hardware y software para instalar SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=235029)

  2. Características compatibles con las ediciones de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235023)

  3. Consideraciones de seguridad para una instalación de SQL Server(http://go.microsoft.com/fwlink/?LinkId=235025)

  4. Versiones en idioma local en SQL Server(http://go.microsoft.com/fwlink/?LinkId=235027)

Otras referencias:

  1. Actualizaciones de ediciones y versiones admitidas(http://go.microsoft.com/fwlink/?LinkId=235031)

  2. Antes de instalar los clústeres de conmutación por error(http://go.microsoft.com/fwlink/?LinkId=235034)

Vea también

Referencia

Reglas auxiliares del programa de instalación


Compruebe las opciones de desinstalación

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Compruebe las opciones de desinstalación
Enviar comentarios

Compruebe su selección y, a continuación, haga clic en Siguiente para continuar.


El tema que busca no está disponible

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

El tema que busca no está disponible
Enviar comentarios

Cuando finalice la instalación, podrá ver la documentación de SQL Server haciendo clic en Ayuda, presionando la tecla F1 en los cuadros de diálogo o elementos de la interfaz, o (en el menú Inicio) seleccionando Todos los programas, Microsoft SQL Server, Ayuda y comunidad y, a continuación, haciendo clic en Libros en pantalla de SQL Server. Para obtener más información, vea Agregar y quitar las colecciones de Ayuda.