Información general sobre la instalación de servicios de SQL Server

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Información general sobre la instalación de servicios de SQL Server
Vea también Enviar comentarios

Puede aplicar una actualización a cualquier componente instalado de SQL Server 2012 con una actualización de servicio de SQL Server 2012. Si el nivel de versión de un componente de SQL Server 2012 existente es posterior al nivel de versión de la actualización, el programa de instalación lo excluirá de la actualización. Para obtener más información sobre la aplicación de una actualización de servicio, vea el tema sobre instalación de actualizaciones de servicio de SQL Server 2012 (http://go.microsoft.com/fwlink/?LinkId=231297).

Al instalar las actualizaciones de SQL Server 2012, deben tenerse en cuenta las consideraciones siguientes:

  • Todas las características que pertenezcan a una instancia de SQL Server deben actualizarse al mismo tiempo. Por ejemplo, si actualiza Motor de base de datos, también debe actualizar los componentes Analysis Services y Reporting Services si están instalados como parte de la misma instancia de SQL Server. Las características compartidas, como Herramientas de administración, Herramientas de datos de SQL Server (SSDT) y SQL Server Integration Services, siempre deben estar totalmente actualizadas. Si un componente o una instancia del árbol de características no está seleccionado, dicho componente o instancia no se actualizará.

  • De forma predeterminada, los archivos de registro de actualización de SQL Server 2012 se guardan en %Archivos de programa%\Microsoft SQL Server\110\Setup Bootstrap\LOG\.

  • La instalación de SQL Server ahora puede integrar una actualización con el medio original para ejecutar el medio original y la actualización al mismo tiempo. Para obtener más información, vea Actualizaciones del producto en la instalación de SQL Server 2012 y Novedades de la instalación de SQL Server(http://go.microsoft.com/fwlink/?LinkID=219508).

  • Antes de aplicar una actualización de servicio de SQL Server 2012, se recomienda que haga una copia de seguridad de los datos.

  • Las actualizaciones de SQL Server están disponibles en Microsoft Update. Le recomendamos que busque actualizaciones periódicamente para garantizar la seguridad y las actualizaciones de la instancia de SQL Server.SQL Server 2012 SP1 se proporciona como una instalación completa de SQL Server. En lugar de proporcionar el Service Pack en el paquete ejecutable estándar de la revisión que se va a aplicar a las instancias de SQL Server 2012 RTM, para esta versión se ofrece un paquete de instalación que consta de 2 archivos. Cuando se ejecute, instalará una nueva instancia de SQL Server 2012 con SP1 preinstalado. Para obtener más información, vea Instalación completa de SQL Server 2012 SP1.

Requisitos y problemas conocidos

Para descargar, extraer e instalar el paquete se recomienda un espacio disponible equivalente a 2,5 veces el tamaño del paquete. Una vez instalado un Service Pack, puede eliminar el paquete descargado. Cualquier archivo temporal se quita automáticamente.

Revise los problemas conocidos: Para obtener más información sobre los problemas conocidos de la versión actual, vea el tema correspondiente de las notas del producto aquí: Notas de la versión de SQL Server.

Información general sobre la instalación

En esta sección se explica la instalación de SQL Server 2012 para las actualizaciones acumulativas y Service Pack, incluido cómo hacer lo siguiente:

  • Preparar la instalación de actualizaciones de SQL Server 2012

  • Instalar las actualizaciones de SQL Server 2012

  • Reiniciar los servicios y las aplicaciones

Preparar la instalación de actualizaciones de SQL Server 2012

Se recomienda encarecidamente que haga lo siguiente antes de instalar las actualizaciones de SQL Server 2012:

  • Haga una copia de seguridad de las bases de datos del sistema de SQL Server: antes de instalar las actualizaciones de SQL Server 2012, haga una copia de seguridad de las bases de datos master, msdb y model. Al instalar una actualización de SQL Server 2012, estas bases de datos se modifican y se vuelven incompatibles con versiones anteriores de SQL Server 2012. Las copias de seguridad de estas bases de datos son necesarias si decide volver a instalar SQL Server 2012 sin estas actualizaciones.

    Asimismo, es una medida prudente hacer una copia de seguridad de las bases de datos de usuario.

    Nota importante Importante

    Al aplicar actualizaciones a las instancias de SQL Server que participan en una topología de replicación, debe hacer una copia de seguridad de las bases de datos replicadas junto con las bases de datos del sistema antes de aplicar la actualización.

  • Haga una copia de seguridad de las bases de datos, el archivo de configuración y el repositorio de Analysis Services: antes de actualizar una instancia de Analysis Services, debe hacer una copia de seguridad de lo siguiente:

    • Bases de datos de Analysis Services. De forma predeterminada, se instalan en C:\Archivos de programa\Microsoft SQL Server\MSAS11.<IDInstancia>\OLAP\Data\. Para la instalación de WOW, la ruta de acceso predeterminada es C:\ProgramFiles (x86)\Microsft SQL Server\MSAS11.<IDInstancia>\OLAP\Data\.

    • Valor de configuración de Analysis Services en el archivo de configuración msmdsrv.ini. De forma predeterminada, este se encuentra en el directorio C:\Archivos de programa\Microsoft SQL Server\MSAS11.\<IDInstancia>\OLAP\Config\.

    • (Opcional) La base de datos que contiene el repositorio de Analysis Services. Este paso únicamente es necesario si se configuró Analysis Services para trabajar con la biblioteca de objetos de ayuda para la toma de decisiones (DSO).

    Nota Nota

    Si no realiza ninguna copia de seguridad de las bases de datos, del archivo de configuración y del repositorio de Analysis Services, no podrá revertir una instancia actualizada de Analysis Services a la versión anterior.

  • Compruebe que las bases de datos del sistema tienen espacio disponible suficiente: si no se selecciona la opción de crecimiento automático para las bases de datos master y msdb del sistema, dichas bases de datos deberán tener como mínimo 500 KB de espacio libre cada una. Para comprobar que las bases de datos tienen suficiente espacio, ejecute el procedimiento almacenado del sistema sp_spaceused en las bases de datos master y msdb. Si el espacio sin asignar de alguna de las bases de datos es inferior a 500 KB, aumente el tamaño de la base de datos.

  • Detener servicios y aplicaciones: para evitar un posible reinicio del sistema, detenga todas las aplicaciones y los servicios que establezcan conexiones con las instancias de SQL Server que se están actualizando antes de instalar actualizaciones de SQL Server 2012. Incluyen SQL Server Management Studio y Herramientas de datos de SQL Server (SSDT). Para obtener más información, vea Iniciar, detener, pausar, reanudar y reiniciar el motor de base de datos, Agente SQL Server o el Servicio SQL Server Browser.

    Nota Nota

    Los servicios no pueden detenerse en un entorno de clúster de conmutación por error. Para obtener más información, vea la sección sobre instalación de clúster de conmutación por error más adelante en este tema.

  • Para eliminar el requisito de reinicio del equipo tras la instalación de las actualizaciones, el programa de instalación mostrará una lista de los procesos que están bloqueando archivos. Si el programa de instalación de las actualizaciones debe finalizar un servicio durante el proceso de instalación, lo reiniciará una vez que concluya la instalación.

  • Si el programa de instalación determina que hay archivos bloqueados durante el proceso de instalación, puede que sea necesario reiniciar el equipo una vez finalizada la instalación. Si es necesario, el programa de instalación le indicará que reinicie el equipo.

Instalar las actualizaciones de SQL Server 2012

En esta sección se describe el proceso de instalación.

Nota importante Importante

Las actualizaciones de SQL Server 2012 se deben instalar con una cuenta que tenga privilegios de administrador en el equipo en el que se instalarán. Para instalaciones locales, debe ejecutar el programa de instalación como administrador. Si instala SQL Server desde un recurso compartido remoto, deberá usar una cuenta de dominio que tenga permisos de lectura y ejecución para dicho recurso.

Iniciar una actualización de SQL Server 2012

Para instalar una actualización de SQL Server 2012, ejecute el archivo de paquete autoextraíble.

Paquete de actualización acumulativa (CU): <SQLServer2012>-KBxxxxxx-PPP.exe

Paquete del Service Pack (PCU): <SQLServer2012><SPx> -KBxxxxxx-PPP-LLL.exe

  • Las x indican el número de Service Pack

  • PPP indica la plataforma concreta.

  • LLL indica la abreviatura de caracteres del idioma de SQL Server; por ejemplo, LLL para inglés es ENU.

Para aplicar actualizaciones a los componentes de SQL Server 2012 que forman parte de un clúster de conmutación por error, vea la sección correspondiente a la instalación de clústeres de conmutación por error. Para obtener más información sobre cómo ejecutar una instalación de actualización en modo desatendido, vea Instalar actualizaciones desde el símbolo del sistema.

Actualizaciones del producto en la instalación de SQL Server 2012

Actualización de producto es una nueva característica del programa de instalación de SQL Server 2012. Integra las actualizaciones más recientes del producto con la instalación del producto principal, de modo que este y las actualizaciones aplicables se instalan al mismo tiempo. Actualización de producto puede buscar actualizaciones aplicables en Microsoft Update, Windows Server Update Services (WSUS), una carpeta local o un recurso compartido de red. Una vez que el programa de instalación encuentra las versiones más recientes de las actualizaciones aplicables, las descarga y las integra con el proceso de instalación de SQL Server actual. Actualización de producto puede extraer una actualización acumulativa, un Service Pack o un Service Pack más la actualización acumulativa. La funcionalidad de Actualización de producto es una extensión de la funcionalidad de instalación integrada que estaba disponible en SQL Server 2008 PCU1. Para obtener más información acerca de la funcionalidad Actualizaciones de productos de SQL Server 2012, vea Actualizaciones del producto en la instalación de SQL Server 2012.

Instalación completa de SQL Server 2012 SP1

SQL Server 2012 SP1 también está disponible como un paquete de instalación completo de SQL Server. El paquete de instalación de SQL Server 2012 SP1 instalará una nueva instancia de SQL Server con SP1 preinstalado.

El paquete tiene un archivo ejecutable y archivos de instalación en formato comprimido. Los archivos del paquete tienen el formato siguiente: SQLServer2012SP1-<Architecture>-<Language>.exe y SQLServer2012SP1-<Architecture>-<Language>.box.

Lea las instrucciones siguientes mientras se instala SQL Server 2012 SP1:

  • Descargue los archivos siguientes de la página de descarga a un directorio temporal del dispositivo:

    • SQLServer2012SP1-architecture-language.box

    • SQLServer2012SP1-architecture-language.exe

  • Una vez que se hayan completado las descargas, haga doble clic en SQLServer2012SP1-<architecture>-<language>.exe para iniciar el proceso de instalación.

  • En el cuadro de diálogo Elegir directorio para archivos extraídos, la ruta de acceso predeterminada del directorio ya está rellena: <unidadActual>\<carpetaDeTrabajoActual>\<nombreDelPaquete>. Por ejemplo, %temp%\SQLServer2012SP1-x64-ENU\. Haga clic en Examinar para cambiar la ruta de acceso del directorio de los archivos extraídos.

  • El paquete se descomprimirá en la ruta de acceso de instalación especificada y quedará en la ruta de acceso del directorio seleccionada una vez completada la instalación. Otro usuario puede usar los archivos binarios de la carpeta extraída para futuras instalaciones.

  • El Asistente para instalación ejecuta el Centro de instalación de SQL Server. Siga las instrucciones descritas en Instalar SQL Server 2012 desde el Asistente para la instalación (programa de instalación) (http://msdn.microsoft.com/library/ms143219.aspx).

En la tabla siguiente se muestran algunos parámetros de la línea de comandos que se pueden usar para extraer el paquete de SQL Server 2012 SP1:

Para obtener una lista detallada de los parámetros de la línea de comandos admitidos que se pueden proporcionar directamente al paquete de SP1, vea Instalar SQL Server 2012 desde el símbolo del sistema (http://msdn.microsoft.com/library/ms144259.aspx)

Parámetro

Descripción

/x o -x

Extrae el paquete en la ruta de acceso especificada, abre el cuadro de diálogo Elegir directorio para archivos extraídos y extrae el paquete en la ruta de acceso especificada.

No ejecuta el programa de instalación.

/x:<path> o -x:<path>

Extrae el paquete en la ruta de acceso especificada y no inicia la instalación.

/q o -q

Especifica que el programa de instalación se ejecute en modo silencioso sin ninguna interfaz de usuario. Se usa en las instalaciones desatendidas.

/l:<path> o -l:<path>

De forma predeterminada, el archivo de registro se almacena en el directorio temporal con el nombre SQLServer2012SPx-<Architecture>-<Language>_decompression_log.txt

Use este parámetro para generar el archivo de registro de extracción en una ruta de acceso especificada.

Por ejemplo:

SQLServer2012SP1-x64-ENU /x /l:<path>

Esta opción solo se debe usar junto con /x, –x, /x:<path> o -x:<path>

Actualizar una imagen preparada de SQL Server

Puede aplicar una actualización a una instancia preparada no configurada de SQL Server sin completar la configuración de la instancia preparada. A continuación se explican distintas formas de aplicar una actualización a una instancia preparada de SQL Server:

  • Actualizar una instancia preparada previamente de SQL Server

    Las actualizaciones de una instancia preparada se pueden aplicar antes de la configuración. El paquete de actualización detecta que la instancia está en estado preparado y aplica la revisión a la instancia preparada, sin completar la configuración.

  • Actualizar una instancia preparada usando Microsoft Update:

    Puede aplicar las actualizaciones a una instancia preparada de SQL Server a través de Microsoft Update. El paquete de Microsoft Update detectará que la instancia está en estado preparado y aplicará la revisión a la instancia preparada, sin completar la configuración.

Si está actualizando una imagen preparada de SQL Server, tendrá que especificar el parámetro InstanceID. Para obtener más información y la sintaxis de muestra, vea Instalar actualizaciones desde el símbolo del sistema.

Actualizar una imagen completada de SQL Server

Al actualizar una instancia completada y configurada de SQL Server, se siguen los mismos procesos que con cualquier otra instancia instalada de SQL Server.

Volver a generar un nodo de clúster de conmutación por error de SQL Server 2012

Si es necesario volver a generar un nodo del clúster de conmutación por error tras aplicar las actualizaciones, lleve a cabo los pasos que se indican a continuación:

  1. Vuelva a generar el nodo en el clúster de conmutación por error. Para obtener más información acerca de cómo volver a generar un nodo, vea Recuperarse de un error en una instancia de clúster de conmutación por error.

  2. Ejecute el programa de instalación original de SQL Server 2012 para instalar SQL Server 2012 en el nodo de clúster de conmutación por error.

  3. Ejecute el programa de instalación de las actualizaciones de SQL Server 2012 en el nodo que ha agregado.

Reiniciar los servicios y las aplicaciones

Una vez finalizado el programa de instalación, es posible que se le pida que reinicie el equipo. Una vez reiniciado el sistema, o cuando el programa de instalación finalice sin solicitar el reinicio, utilice el nodo Servicios del Panel de control para reiniciar los servicios que detuvo antes de aplicar las actualizaciones de SQL Server 2012. Esto incluye servicios como Microsoft DTC (Coordinador de transacciones distribuidas) y Microsoft Search, o bien servicios equivalentes específicos de las instancias.

Reinicie las aplicaciones que cerró antes de ejecutar el programa de instalación de las actualizaciones de SQL Server 2012. Es recomendable también hacer otra copia de seguridad de las bases de datos master, msdb y model actualizadas, justo después de que finalice correctamente la instalación.

Desinstalar las actualizaciones de SQL Server 2012

Puede desinstalar las actualizaciones acumulativas o los Service Pack de SQL Server 2012 desde Programas y características en el Panel de control. Para ver la lista de actualizaciones instaladas, abra Actualizaciones instaladas; para ello, haga clic sucesivamente en el botón Inicio, Panel de control, Programas y, después, en Programas y características, haga clic en Ver actualizaciones instaladas. Cada actualización acumulativa se relaciona de forma separada. Sin embargo, cuando se instala un Service Pack posterior a las actualizaciones acumulativas, las entradas de las actualizaciones se ocultan y solamente estarán disponibles si desinstala el Service Pack.

Para desinstalar los Service Pack y las actualizaciones, inicie sesión con la actualización o el Service Pack más reciente aplicado a la instancia de SQL Server y vaya hacia atrás. En los siguientes ejemplos, SQL Server termine con la actualización acumulativa 1 después de completar la desinstalación para otros Service Pack o actualizaciones:

  • Para una instancia de SQL Server 2012 con la actualización acumulativa 1 y el SP1 instalados, desinstale el SP1.

  • En el caso de una instancia de SQL Server 2012 con las actualizaciones acumulativas 1 y 2 y el SP1 instalados, desinstale la actualización acumulativa 2 primero y, a continuación, desinstale el SP1.

Vea también

Otros recursos

Instalar SQL Server 2012 desde el símbolo del sistema
Instalar actualizaciones de servicios de SQL Server 2012
Validar una instalación de SQL Server
Ver y leer los archivos de registro de instalación de SQL Server
Imagen de PieDePagina
Enviar comentarios acerca de este tema a Microsoft

© 2012 Microsoft Corporation. Todos los derechos reservados.


Aviso legal de la documentación

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Aviso legal de la documentación
Enviar comentarios

Este documento se proporciona "tal cual". La información y los puntos de vista que se proporcionan en este documento, incluidas las direcciones URL y otras referencias a sitios web de Internet, pueden sufrir modificaciones sin previo aviso. Usted acepta el riesgo de utilizarlo.

Algunos ejemplos descritos aquí se proporcionan solo para servir de ilustración y son ficticios. No se pretende ni debería deducirse ninguna asociación o conexión real.

En este documento no se proporciona ningún derecho legal de ninguna propiedad intelectual de ningún producto de Microsoft. Puede copiar y utilizar este documento para su propia referencia.

© 2012 Microsoft. Reservados todos los derechos.

Microsoft, Active Directory, ActiveX, Bing Maps, Excel, IntelliSense, MSDN, MS-DOS, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual Studio, Windows, Windows NT, Windows Server y Windows Vista son marcas registradas del grupo de empresas de Microsoft. SAP NetWeaver es marca registrada de SAP AG en Alemania y otros países. Las demás marcas comerciales pertenecen a sus respectivos propietarios.

Directiva de documentación para soporte y actualización de SQL Server

La documentación del software de SQL Server 2012 incluye los Libros en pantalla de Microsoft para SQL Server 2012, documentación de la instalación, documentación de referencia para desarrolladores, tutoriales, archivos léame, documentos de problemas conocidos, código y bases de datos de ejemplo y artículos de Knowledge Base publicados por Microsoft, que incluyen contenido acerca de las características y funcionalidad de SQL Server. Esta directiva de compatibilidad y actualización se aplica a la documentación de SQL Server 2012, incluidos los archivos léame de las versiones y Service Pack de SQL Server 2012. Un archivo léame se considera una extensión de los Libros en pantalla de SQL Server 2012.

El objetivo principal de las muestras que se incluyen en esta documentación es ilustrar un concepto o un uso razonable de una instrucción o cláusula determinada. La mayoría de las muestras no incluyen todo el código que debería tener un sistema totalmente en producción, puesto que se ha eliminado parte de la validación de datos comunes y el control de errores para resaltar en la muestra un determinado concepto o instrucción. No hay soporte técnico disponible para estas muestras ni para el código fuente incluido.

En algunos casos, una característica determinada de SQL Server 2012 no se ha probado o desarrollado suficientemente y no está destinada a usarse. Tales características se incluyen a menudo como marcadores. Por consiguiente, ciertas características que están contenidas en el software no están documentadas. Las características que no están documentadas o que se incluyen como una anotación para uso interno de Microsoft no están destinadas a usarse y los servicios de soporte al cliente de Microsoft no las admiten en su servicio. A menos que la documentación de SQL Server 2012 indiquen lo contrario, el contenido de terceros, incluidos los problemas que sean resultado de utilizar dicho contenido con SQL Server 2012, no se admite en los servicios de soporte al cliente de Microsoft y también puede provocar la pérdida de datos. Los servicios de soporte al cliente de Microsoft tampoco proporcionan soporte técnico para las bases de datos o aplicaciones que aprovechen o usen puntos de entrada indocumentados, como las API que no estén documentadas; por ejemplo, procedimientos almacenados, procedimientos almacenados extendidos, funciones, vistas, tablas, columnas, propiedades o metadatos.

Puede que tampoco funcionen las actualizaciones de servidor y de base de datos a versiones futuras de SQL Server 2012 para las aplicaciones y bases de datos que aprovechen o utilicen puntos de entrada no documentados y no se admiten. No se admite el uso de las características y funcionalidad de SQL Server que se incluyen en Microsoft SQL Server y que no se documentan en la documentación de SQL Server 2012 para usarse y tal uso puede provocar la pérdida de datos.


Instalar actualizaciones desde el símbolo del sistema

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Instalar actualizaciones desde el símbolo del sistema
Vea también Enviar comentarios

Pruebe y modifique los scripts de instalación para adaptarlos a las necesidades de su organización. Para obtener más información acerca de cómo instalar actualizaciones para un clúster de conmutación por error de SQL Server, vea Cómo aplicar una actualización de SQL Server a una instancia de clúster de conmutación por error en Microsoft Knowledge Base.

Sintaxis de ejemplo para la instalación

El nombre del paquete de actualización puede variar y es posible que incluya un componente de idioma, edición y procesador. Aplique una actualización en una línea de comandos y reemplace <nombre_paquete> por el nombre del paquete de actualización:

  • Actualice una única instancia de SQL Server y todos los componentes compartidos, como Integration Services y Herramientas de administración: puede especificar la instancia bien utilizando el parámetro InstanceName o bien con el parámetro InstanceID. Para actualizar una instancia preparada de SQL Server, debe especificar el parámetro InstanceID<nombreDePaquete>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /InstanceName=miInstancia o <nombreDePaquete>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /InstanceID=<identificador de instancia>

  • El programa de instalación puede integrar las últimas actualizaciones del producto con la instalación del producto principal, de modo que el producto principal y las actualizaciones aplicables se instalen al mismo tiempo. Puede preparar una instalación de una instancia del motor de base de datos para que incluya la actualización del producto: setup.exe /q /IAcceptSQLServerLicenseTerms /ACTION=PrepareImage /UpdateEnabled=True /UpdateSource=<ruta donde se ha descargado la actualización> /INSTANCEID=<identificador de instancia> /FEATURES=SQLEngine

  • Actualizar solo los componentes compartidos de SQL Server, como Integration Services y las Herramientas de administración: <nombreDePaquete>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch

  • Actualizar todas las instancias de SQL Server del equipo y todos los componentes compartidos, como Integration Services y las Herramientas de administración: <nombreDePaquete>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /AllInstances

Quite una actualización de la línea de comandos y reemplace <nombreDePaquete> por el nombre del paquete de actualización:

  • Quitar una actualización de una única instancia de SQL Server y todos los componentes compartidos, como Integration Services y las herramientas de administración: <nombre_paquete>.exe /qs /Action=RemovePatch /InstanceName=MyInstance

  • Quitar una actualización únicamente de los componentes compartidos de SQL Server, como Integration Services y las herramientas de administración: <nombre_paquete>.exe /qs /Action=RemovePatch

    Nota Nota

    El instalador de la actualización se asegura de que los componentes compartidos estén siempre en, o por encima de, la versión de la instancia en el nivel más alto.

Parámetros del símbolo del sistema compatibles

Nota importante Importante

Cuando sea posible, proporcione credenciales de seguridad en tiempo de ejecución. Si debe almacenar credenciales en un archivo de script, proteja el archivo para evitar el acceso no autorizado.

Modificador | Descripción
/? | Muestra la ayuda del símbolo del sistema para la instalación desatendida
/action=Patch or /action=RemovePatch | Especifica la acción de instalación: Patch o RemovePatch.
/allinstances | Aplica la actualización de SQL Server a todas las instancias de SQL Server y a todos los componentes compartidos que no reconocen instancias de SQL Server.
/instancename=InstanceName1 | Aplica la actualización de SQL Server a una instancia de SQL Server denominada InstanceName y a todos los componentes compartidos que no reconocen instancias de SQL Server.
/InstanceID=Inst1 | Aplica la actualización de SQL Server a una instancia de SQL Server Inst1 y a todos los componentes compartidos que no reconocen instancias de SQL Server.
/quiet | Ejecuta el programa de instalación de la actualización de SQL Server en modo desatendido.
/qs | Muestra únicamente el cuadro de diálogo de progreso de la interfaz de usuario.
/UpdateEnabled | Especifica si el programa de instalación de SQL Server debe detectar e incluir actualizaciones del producto. Los valores válidos son True y False, o 1 y 0. De forma predeterminada, la instalación de SQL Server incluirá las actualizaciones que encuentre.
/UpdateSource | Especifica la ubicación en que el programa de instalación de SQL Server obtendrá las actualizaciones del producto. Los valores válidos son “MU” para buscar en Microsoft Update, una ruta de carpeta válida, una ruta relativa, como .\MisActualizaciones o un recurso compartido UNC. De forma predeterminada, el programa de instalación de SQL Server buscará en Microsoft Update o en el Servicio Windows Update a través de Windows Server Update Services.
/IAcceptSQLServerLicenseTerms | Solo se requiere cuando se especifica el parámetro /Q o /QS para las instalaciones desatendidas.

1 No puede especificar este parámetro para aplicar una actualización a una instancia preparada de SQL Server. Debe especificar el parámetro /instanceID en su lugar.

Vea también

Conceptos

Información general sobre la instalación de servicios de SQL Server


Validar una instalación correcta de una actualización de SQL Server

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Validar una instalación correcta de una actualización de SQL Server
Vea también Enviar comentarios

Para validar la instalación correcta de una actualización de SQL Server:

  • Compruebe que los servicios de SQL Server están en línea.

  • Compruebe la información de versión que devuelve la consulta @@version.

Vea también

Conceptos

Información general sobre la instalación de servicios de SQL Server


Obtener ayuda sobre SQL Server

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Obtener ayuda sobre SQL Server
Vea también Enviar comentarios

Hay tres fuentes principales de información de Microsoft acerca de SQL Server:

  • La documentación instalada como una colección local de Libros en pantalla de SQL Server.

  • Los sitios de SQL Server en Microsoft Developer Network (MSDN) y TechNet.

  • Información de SQL Server en otros sitios web de Microsoft

Si no encuentra la información que está buscando en estas fuentes, puede publicar preguntas en los grupos de noticias y foros de la comunidad de SQL Server o abrir un caso de soporte con Microsoft.

Libros en pantalla de SQL Server

Los documentos de los Libros en pantalla de SQL Server cubren los conceptos y los procedimientos necesarios para utilizar SQL Server. Los Libros en pantalla también incluyen material de referencia de los lenguajes e interfaces de programación para almacenar, recuperar, realizar informes y modificar datos con SQL Server.

Puede obtener acceso a los Libros en pantalla de varias formas:

  • En MSDN Library y TechNet Library de Internet hay publicada una copia de los Libros en pantalla de SQL Server 2012. Los temas de estas copias de los Libros en pantalla de SQL Server incluyen comentarios de la comunidad, así como información adicional y ejemplos de código de otros clientes. Puede ver la copia de MSDN Library en los Libros en pantalla de SQL Server 2012.

  • Puede usar el Administrador de bibliotecas de Ayuda para instalar los Libros en pantalla de SQL Server en un equipo local. Para obtener más información, vea Agregar o quitar colecciones de Ayuda.

Tanto la copia de los Libros en pantalla de SQL Server de MSDN Library como los archivos de los Libros en pantalla disponibles a través del Administrador de bibliotecas de Ayuda se actualizan cuando Microsoft publica una actualización de los Libros en pantalla de SQL Server.

Información sobre MSDN y TechNet

Microsoft Developer Network (MSDN) proporciona servicios en línea y sin conexión que ayudan a los desarrolladores a escribir aplicaciones mediante los productos y las tecnologías de Microsoft. El programa TechNet de Microsoft ofrece recursos técnicos completos que ayudan a los profesionales de TI a evaluar, implementar y prestar soporte para las soluciones de Microsoft.

Varios de los sitios de MSDN y TechNet proporcionan a un tipo de destinatario específico vínculos a la información de SQL Server más relevante para su trabajo, como la información incluida en las copias de los Libros en pantalla de SQL Server de MSDN o TechNet. Estos sitios también contienen información que amplía la que está disponible en los Libros en pantalla de SQL Server.

En la tabla siguiente se describen estos recursos y sus destinatarios.

Recurso | Público
Centro para programadores de SQL Server | Programadores que generan bases de datos de SQL Server, sistemas de informes y soluciones de Business Intelligence, y que habilitan sus aplicaciones y sitios web para que utilicen estos sistemas.
Centro para programadores de acceso a datos y almacenamiento | Programadores que habilitan sus aplicaciones y sitios web para usar datos almacenados mediante productos como SQL Server y Access.
Centro para programadores de XML | Creadores de sitios web y programadores de aplicaciones cuyos sitios y aplicaciones utilicen XML para la manipulación y el almacenamiento de datos.
Sitio de TechNet de SQL Server | Los administradores y operadores que planean, implementan, administran y prestan soporte a sistemas que utilizan SQL Server.

Información adicional en línea

Hay disponible información adicional de SQL Server en estos sitios web de Microsoft.

Recurso | Descripción
Microsoft SQL Server | Proporciona información previa a las ventas acerca de la evaluación de SQL Server para el almacenamiento de datos y como herramienta de Business Intelligence.
Microsoft Knowledge Base | Proporciona un repositorio de artículos de SQL Server escritos por soporte técnico de Microsoft, en el que se pueden realizar búsquedas.
Microsoft Learning | Describe los cursos y certificaciones de Microsoft para SQL Server.
Microsoft Press | Muestra los libros de Microsoft Press sobre SQL Server.

Obtener ayuda de otras personas

Si no encuentra la información que está buscando en la documentación del producto o en Internet, puede formular una pregunta en los grupos de noticias y los foros de la comunidad de SQL Server. También puede solicitar ayuda al servicio de soporte técnico.

Nota Nota

No publique preguntas en la sección de comentarios de la comunidad situada en la parte inferior de los temas de los Libros en pantalla de SQL Server en MSDN Library o TechNet Library. En estas secciones no se supervisan las preguntas y, por lo general, no recibirá ninguna respuesta. Publique sus preguntas en los grupos de noticias y foros de la comunidad, donde otros clientes podrán responderlas.

En la tabla siguiente se incluyen vínculos a estos recursos junto con una descripción de los mismos.

Recurso | Descripción
Comunidad profesional IT de SQL Server | Proporciona vínculos a grupos de noticias y foros supervisados por la comunidad de SQL Server. También muestra orígenes de información de las comunidades, como blogs y sitios web. La comunidad de SQL Server es de gran utilidad para obtener respuesta a algunas preguntas, aunque no haya una garantía de respuesta.
Comunidad del Centro para programadores de SQL Server | El sitio se centra en los grupos de noticias, foros y otros recursos de la comunidad útiles para los programadores de SQL Server.
Ayuda y soporte técnico de Microsoft | Puede usar este sitio web para abrir un caso de soporte con un profesional de soporte de Microsoft.

Los productos Microsoft tienen un ciclo de vida de soporte técnico que define cuánto tiempo está disponible el soporte técnico para cada versión. El soporte técnico de Microsoft mantiene una página que define el ciclo de vida de soporte de Microsoft. La página contiene vínculos a otras paginas que especifican la disponibilidad de soporte técnico de los productos Microsoft. Para obtener más información, vea Ciclo de vida de soporte técnico de Microsoft.

Vea también

Conceptos

Usar la documentación del producto para SQL Server


Bienvenida

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Bienvenida
Enviar comentarios

Las reglas de instalación examinan el equipo donde se instalará la actualización.


Términos de licencia

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Términos de licencia
Enviar comentarios

Use la página Términos de licencia para aceptar los términos de la licencia de esta versión.

Opciones

Para continuar con la instalación, debe aceptar los términos de la licencia de SQL Server.

Use el botón Imprimir para imprimir una copia de los términos de licencia para esta versión. Haga clic en Cancelar para finalizar la instalación.


Seleccionar características

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Seleccionar características
Enviar comentarios

Use la página Selección de características para seleccionar los componentes y las características de SQL Server que desee actualizar.

Opciones

Haga clic en el nombre de una característica en el panel de la izquierda para ver los detalles de idioma, sistema operativo, edición y estado.

Para actualizar un componente o característica, active la casilla situada junto al nombre de la característica. Para excluir un componente o característica de esta actualización, desactive la casilla situada junto al nombre de la característica.

Se pueden actualizar varias instancias de SQL Server en un equipo individual en momentos diferentes, pero todos los componentes de una instancia de SQL Server deben actualizarse al mismo tiempo. Se deben actualizar todos los componentes compartidos, como los componentes de la estación de trabajo, Analizador de MSXML, SQLXML, componentes de Compatibilidad con versiones anteriores y VSS Writer.

Si un componente no puede actualizarse, en el panel Detalles aparecerá una explicación.


Comprobar archivos en uso

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Comprobar archivos en uso
Enviar comentarios

Para no tener que reiniciar Windows después de instalar las actualizaciones de SQL Server, use la página Comprobar archivos en uso con el fin de identificar los procesos que están bloqueando los archivos requeridos por el programa de instalación de la actualización de SQL Server.

Detenga todas las aplicaciones y servicios que establecen conexiones con las instancias de SQL Server que se están actualizando. Se incluye la detención de SQL Server Management Studio y Herramientas de datos de SQL Server (SSDT).

Si el programa de instalación determina que hay archivos bloqueados durante el proceso de instalación, puede que sea necesario reiniciar el equipo una vez completada la instalación. Si es necesario, el programa de instalación le indica que reinicie el equipo. Si el programa de instalación debe detener un servicio durante el proceso de instalación, lo reiniciará una vez completada la instalación.

Para eliminar el requisito de reinicio del equipo tras la instalación, el programa de instalación muestra una lista de los procesos que están bloqueando los archivos. Detenga o finalice los procesos y las aplicaciones de la lista. A continuación, haga clic en Actualizar comprobación para volver a ejecutar la comprobación. Haga clic en Detener comprobación para finalizar una comprobación que se esté ejecutando. Si no se encuentra ningún archivo bloqueado, la tabla está vacía. Cuando todos los procesos bloqueados se hayan cerrado o detenido, haga clic en Siguiente para continuar.

El programa de instalación registra la información en los archivos de registro. Para obtener más información sobre cómo ver los archivos de registro, vea Cómo ver archivos de registro de instalación de SQL Server y Cómo leer un archivo de registro de instalación de SQL Server.

En el archivo de registro se incluye la información siguiente:

  • Nombre del proceso

  • Nombre de la característica de SQL Server

  • Tipo de proceso

  • Cuenta en la que se está ejecutando el proceso

  • Id. del proceso

  • Nombre del archivo que está bloqueado

Nombre | Descripción
Proceso | Muestra el nombre completo del proceso que está utilizando los archivos que se van a actualizar.
Tipo | Muestra el tipo de proceso.
Cuenta | Muestra la cuenta en la que se está ejecutando el proceso.
Id. del proceso | Muestra el identificador del proceso.


Listo para actualizar

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Listo para actualizar
Enviar comentarios

Use la página Resumen para confirmar los cambios que se aplicarán a la instancia de SQL Server. Para seguir con la instalación, haga clic en Instalar.


Progreso de la actualización

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Progreso de la actualización
Enviar comentarios

Use la página Progreso de la instalación para supervisar el programa de instalación mientras aplica la actualización a la instancia de SQL Server y sus componentes.

Opciones

La tabla proporciona el nombre de producto, su nombre de instancia y el estado de la instalación de SQL Server.


Completada

 Imagen de Colapsar Imagen de Expandir Imagen de Copiar Imagen de CopiarDesplazar
[image]

Completada
Enviar comentarios

La página Completada confirma el estado de la instalación.