Введение

Copyright © 2005 Paragon Software (Smart Handheld Devices Division)
Долгопрудный, Московская область, Россия

Система оперативного распознавания натурального рукописного текста PenReader 2005 для Pocket PC

Уважаемый пользователь!
Благодарим Вас за использование системы
PenReader компании Paragon Software (SHDD)!


О системе PenReader 2005

PenReader 2005 — это система распознавания рукописного ввода текста. С использованием системы PenReader у Вас появляется возможность вводить информацию на нескольких различных языках из списка поддерживаемых в полноэкранном режиме (возможность писать текст в любом месте экрана). Специально для русскоязычных пользователей существует Русская редакция системы PenReader 2005 для Pocket PC, которая из множества языков поддерживает только русский и английский языки, а также цифры, вспомогательные символы и макросы.

Система PenReader основана на двух взаимодополняющих методах распознавания рукописного текста: графическом и орфографическом анализах. При графическом анализе используется база всевозможных начертаний символов, собранная на основе огромного количества реальных почерков. В PenReader 2005 существует возможность сужения набора начертаний для каждого символа, тем самым можно улучшить распознавание любого специфического почерка. Подробнее об этой возможности читайте в разделе „Прописи“. Орфографический анализ производится на базе специально созданного словаря. Благодаря сочетанию этих двух методов система не требует обучения или настройки перед началом работы и распознаёт практически любой почерк.


Ограничения демонстрационной версии

Демонстрационная версия системы PenReader работает 30 дней без каких-либо ограничений по функциональности.

Демонстрационная и коммерческая версии PenReader устанавливаются из одного и того же инсталляционного файла. Если во время установки Вы не ввели регистрационный код, система будет установлена в демонстрационном режиме.

После того, как демонстрационная версия перестала работать, Вам следует ввести регистрационный код, который Вы получите при покупке коммерческой версии продукта, в окно для регистрации (см. раздел „Регистрация“).

Внимание! Каждая редакция (Русская, Чешская, Многоязычная и т.д.) системы PenReader 2005 имеет свой формат регистрационного кода и устанавливается независимо от любой другой.


Использование системы PenReader 2005

Общая информация

Система PenReader 2005 распознаёт рукописный текст в любом приложении, где возможен ввод текстовой информации. Вы сможете писать текст в любом месте экрана, и распознанные символы будут выводятся в место текущего положения курсора.


Использование полноэкранного режима ввода

Стандартные средства операционной системы Microsoft® Windows Mobile™ позволяют распозновать только английский рукописный текст. Система PenReader 2005 расширяет возможности ввода рукописного текста на устройствах Pocket PC. Используя систему PenReader, Вы можете вводить рукописный текст на родном языке и на любом другом из списка поддерживаемых.

Чтобы увидеть PenReader в действии, Вам необходимо открыть любое приложение, где можно вводить информацию (текст). Поместите курсор в необходимое место ввода и пишите текст в любом месте экрана:

Таким образом, система PenReader 2005 распознаёт рукописный текст, который Вы вводите, при использовании полноэкранного режима ввода в любом приложении. Распознанные буквы выводятся в место текущего положения курсора.


Основные рекомендации

Основные рекомендации по вводу рукописного текста в полноэкранном режиме

Для повышения эффективности работы с системой существуют некоторые специальные рекомендации к написанию текста:

  • PenReader — это система побуквенного распознавания рукописного текста. Это означает, что если Вы хотите написать, например, слово „образец“, то все буквы должны быть написаны раздельно – „о“ „б“ „р“ „а“ „з“ „е“ „ц“:

    Вы можете писать буквы достаточно близко друг к другу, но после каждого символа следует отрывать перо от экрана.

  • Все буквы должны быть написаны разборчиво и ясно. Это значит, что необходимо писать буквы так, чтобы каждая из них имела единственно возможный вариант распознавания. Следует писать схожие буквы „e“ и „c“, „т“, „ш“ и „м“, „д“, „у“ и „з“, „у“ и „ц“, „г“ и „ч“, „н“, „и“, „п“ и „к“ (русский алфавит) „e“ и „с“, „с“ и „l“, „d„ и „а“, „u“ и „n“, или „n“ и „h“ (английский алфавит) чётко, так чтобы можно было понять, что это за буква, независимо от слова, в котором она встретилась. Для улучшения качества распознавания схожих букв в системе PenReader 2005 реализована возможность указать используемые Вами начертания для каждого из символов. Подробнее об этой возможности читайте в разделе „Прописи“.

  • Не делайте случайных разрывов при вводе букв, как в следующем примере:

  • Пишите все строчные буквы одной фразы (или фрагмента текста) одинакового размера и все прописные буквы одной фразы также одинакового размера.

  • Пишите слова и фразы по прямой линии горизонтально. Возможность ошибки возрастает, если писать текст по кривой линии, под углом к горизонтальному уровню:


Многоязычность. Переключение между языками

Система распознавания PenReader основана на базе из более чем 500 начертаний различных символов. Этого достаточно для распознавания практически любого варианта написания любого символа. PenReader поддерживает распознавание символов русского алфавита (кириллицы), расширенного латинского алфавита (английский и другие европейские языки), цифр, вспомогательных символов (знаков пунктуации и т.д.) и функциональных росчерков (макросов).

Внимание! Русская редакция PenReader 2005 поддерживает только английский и русский языки, цифры, вспомогательные символы и макросы.

Система PenReader может распознавать текст на нескольких языках одновременно. Вы можете переключать активный язык для ввода текста на разных языках, а можете и не делать этого, то есть ввести часть текста на одном языке, а потом сразу часть текста на другом языке без каких-либо дополнительных переключений. Более подробную информацию о вводе текста на разных языках Вы можете найти в разделе „Выбранные контексты“. Под словом „контекст“ в данном документе понимается языковой режим работы системы.

При использовании системы PenReader в полноэкранном режиме Вы увидите значок в правом нижнем углу экрана:

Этот значок показывает текущий языковой контекст.

Переключаться между переключаемыми контекстами системы PenReader можно следующим образом: внизу экрана следует несколько раз нажать пером на значок текущего контекста, пока не появится тот контекст, который Вам нужен. Доступные контексты будут перебираться в таком порядке, в каком они перечислены в списке в окне Выбранные контексты. Чтобы изменить этот порядок, выделите какой-либо контекст и воспользуйтесь кнопками Вверх/Вниз для перемещения выбранного контекста в списке.

Переключиться в любой контекст из списка выбранных можно следующим образом: внизу экрана нужно нажать и удерживать перо на значке текущего контекста, после этого всплывёт меню со списком выбранных контекстов:

Контекст, который Вы использовали до вызова меню, отмечен галочкой. Вам нужно просто выбрать новый контекст в этом меню.

Ещё один способ переключения контекста — ввод специального макроса в отдельном тайм-ауте: (жирная точка указывает начало рисования).


Функциональные росчерки (Макросы) в полноэкранном режиме

Функциональные росчерки (макросы)

PenReader распознаёт текст непрерывно по истечении определённого временного интервала (тайм-аута). Вы можете использовать следующие макросы:

  • – Макрос пробела, который необходимо вводить в нижней части строки ввода. Этот макрос представляет собой горизонтальную черту, которая рисуется слева направо (точка на изображении макроса показывает начало рисования). Используйте данный макрос для явного разделения соседних слов, если неактивна опция Автоматическое распознавание пробелов в разделе „Распознавание“ настроек системы. После установки PenReader 2005 данная опция активна по умолчанию.
  • – Макрос символа „-“ („тире“), который необходимо рисовать посередине строки ввода.
  • – Макрос перехода на другую строку. Аналогичен функции клавиши Enter на клавиатуре.
  • – Макрос удаления. Функция этого макроса полностью совпадает с функцией клавиши Backspace. Поэтому его можно использовать для удаления не только отдельных символов, но и их групп. Для этого выделите удаляемые буквы или цифры и нарисуйте данный макрос. Все выделенные символы будут удалены.
  • – Макрос табуляции. Его функция совпадает с функцией клавиши Tab на клавиатуре.
  • – Макрос капитализации. Его функция аналогична клавише Shift. Этот макрос представляет собой вертикальную черту, проводимую снизу вверх перед той буквой, которую надо сделать заглавной: например, для ввода заглавной „А“ надо написать [image] [image]. Используйте данный макрос в случае, если неактивна опция Анализ прописных-строчных букв в разделе „Распознавание“ настроек системы. После установки PenReader 2005 данная опция активна по умолчанию.
  • – Макрос „CapsLock“. Используется для перехода в режим заглавных букв. Это аналог клавиши CapsLock на клавиатуре. Этот макрос представляет собой вертикальный штрих, который рисуется снизу вверх и обратно (точка обозначает начало рисования). Повторный ввод макроса возвращает PenReader в режим строчных букв. Макрос „CapsLock“ необходимо писать в отдельном тайм-ауте.
  • – Макрос для переключения контекста. Необходимо писать в отдельном тайм-ауте.


Настройки PenReader

В настройках программы PenReader можно изменять некоторые параметры системы, относящиеся к процессу распознавания и интерфейсу. Чтобы открыть диалог настроек, необходимо нажать пером на треугольный значок в правом нижнем углу экрана, выбрать в появившемся меню пункт Options/Опции и в новом диалоге нажать на кнопку Options/Опции:

В настройках программы есть пять закладок: Опции, Распознавание, Выбранные контексты, Прописи и Регистрация.


Закладка Опции

На этой закладке доступны следующие опции и информация:

  • Название системы, ее сборка „BUILD“ и версия ядра „CORE“, используемого системой.

  • Задержка Drag & Drop. Значение этого параметра используется программой PenReader для того, чтобы отличить операцию drag & drop (перемещение объектов в ОС Windows Mobile) от ввода рукописного текста. Если перо остаётся неподвижным при нажатии в одной и той же точке экрана дольше времени, установленного в этой опции, PenReader не пытается распознать как текст следующее за этим перемещение курсора. Это позволяет выполнять операции drag & drop (например, выделение текста) без отключения программы PenReader.

  • Управление свойствами пера: Tолщина определяет толщину траектории в пикселях, Цвет определяет цвет электронных „чернил“.

  • Опция Включить звук Drag & Drop. Позволяет включать и выключать звук, оповещающий о переходе в drag & drop режим.


Закладка Распознавание

На этой закладке доступны следующие опции:

  • Задержка распознавания. Позволяет установить величину паузы для распознавания (тайм-аута) в диапазоне от 0 до 3 секунд. PenReader распознаёт написанные Вами символы одновременно с их вводом, но написанное удаляется с экрана по истечении временного интервала (тайм-аута). То есть пока Вы пишете, символы остаются на экране. Поэтому Вы можете писать не только отдельные буквы, но и целые слова и фразы.

  • Всплывающая подсказка. Вы можете указать использовать или нет (если да, то как часто) всплывающую подсказку с вариантами распознавания написанного символа. Данная опция позволяет выбирать онлайн вариант распознавания любого символа:

    Варианты распознавания написанного символа в этой всплывающей подсказке располагаются в порядке убывания вероятности совпадения начертания символа и его реального значения. Если Вы выберете пункт По умолчанию, то система сама установит значение данного символа, которое совпадает со значением, указанным первым в списке. В процессе использования данной опции ядро системы подстраивается под Ваш почерк, тем самым улучшается качество распознавания практически любого почерка.

  • Автоматическое распознавание пробелов. Если эта опция включена, то PenReader распознаёт пробелы между словами автоматически (нет необходимости рисовать специальный макрос для обозначения пробела).

  • Добавлять завершающий пробел. Если эта опция включена, то PenReader в конце каждого тайм-аута автоматически добавляет пробел.

  • Анализ прописных-строчных букв. Если эта опция включена, то PenReader распознаёт буквы верхнего регистра и большие символы как заглавные буквы в соответствии с их вертикальными размерами.


Закладка Выбранные контексты

На этой закладке Вы можете указать несколько контекстов для ввода информации:

Для того, чтобы добавить любой контекст в список выбранных или удалить из него, используйте кнопки Добавить и Удалить соответственно.

Языковые контексты в программе PenReader могут быть переключаемыми и непереключаемыми. В окне выбранных языков непереключаемые контексты обозначены галочками. На данной картинке непереключаемыми являются контексты „Макросы“ и „Спецсимволы“. Таким образом, в процессе ввода рукописного текста в полноэкранном режиме Вы можете одноврменно использовать и макросы, и спецсиволы без переключения между ними. Если Вы вводите текст преимущественно только на одном языке, то рекомендуется использовать режим переключаемых контекстов. Подробную информацию о переключении между контекстами Вы можете найти в разделе „Переключение между языками“.

Для каждого из контекстов Вы можете указать использовать или нет при распознавании рукописного текста орфографический анализ, который проводится на базе специально созданного словаря, включающего в себя частно употребляемые слова в конкретном языке. После установки системы PenReader орфографический анализ активен по умолчанию для всех контекстов. Для его отключения снимите галочку в пункте Орфографический анализ.


Закладка Прописи

Если Вы заметили, что система PenReader в полноэкранном режиме распознает недостаточно качественно какой-то отдельный вводимый Вами символ, с помощью настроек на закладке „Прописи“ Вы можете повысить качество распознавания этого символа, за счет сужения набора его начертаний. Для настройки вариантов написания определенного символа выберите контекст, к которому относится данный символ, и укажите, какой из вариантов написания Вы используете часто, редко или не используете вообще:

Установив один раз необходимые настройки написаний символов, Вы можете сохранить их в отдельный файл для дальнейшего использования. Для этого просто нажмите кнопку Экспорт и укажите путь, куда именно сохранить данный файл.

Чтобы активировать свои настройки, сохраненные в отдельный файл, нажмите кнопку Импорт и укажите данный файл для загрузки.

Для восстановления настроек по умолчанию используйте кнопку Восстановить.

Таким образом, описанная возможность позволяет использовать систему PenReader нескольким пользователям, причем для каждого из них существует возможность создания своих индивидуальных настроек написаний символов.


Закладка Регистрация

На этой закладке Вы можете зарегистрировать свою копию программы PenReader, тем самым преобразовав ее из демонстрационной версии в коммерческую.

Для успешной регистрации Вам необходимо нажать кнопку Зарегистрировать и в открывшемся специальном окне ввести Ваш регистрационный код, который Вы получите при покупке программы.

Будьте внимательны при вводе регистрационного кода, не делайте лишних пробелов, не путайте заглавную букву „О“ с цифрой „0“, для ввода используйте только заглавные буквы.


Установка системы PenReader 2005

Для установки проделайте следующее:

  1. Соедините Ваш карманный компьютер с настольным компьютером с помощью программы ActiveSync.
  2. Запустите на настольном компьютере установочный файл системы PenReader (*.exe).
  3. Следуйте инструкциям программы установки. Если Вы не введете регистрационный код при установке программы, то программа будет работать в демо-режиме.
  4. Нажмите Ok в появившемся окошке на Вашем КПК и дождитесь перезагрузки устройства. Только после этого отсоединяйте КПК от настольного компьютера.


Удаление системы PenReader 2005

Чтобы удалить PenReader с Вашего КПК, нажмите Start/Пуск > Settings/Настройки > System/Система > Add/Remove Programs / Удаление программ. Затем выберите строку Paragon Software PenReader 2005 и нажмите кнопку Remove/Удалить.


Служба технической поддержки пользователей

Теперь для наших пользователей доступна База Знаний! Она была создана на основе часто задаваемых пользователями вопросов. В Базе Знаний содержится информация обо всех продуктах нашей компании, в том числе и о PenReader для Pocket PC.

Надеемся, что Вы найдёте в Базе Знаний интересующую Вас информацию:

http://support.penreader.com


Регистрация лицензионной копии

Если систему PenReader Вы получили в комплекте с устройством (OEM поставка), мы настоятельно рекомендуем Вам зарегистрироваться в нашей автоматической системе регистраций и обновлений — E-Care. Проблемы, возникающие из-за отсутствия регистрации, встречаются довольно часто. К тому же, обновления программы PenReader доступны *только* зарегистрированным пользователям через систему E-Care. Например, отсутствие регистрации в системе E-Care не даст возможности восстановить лицензию на копию программы PenReader в случае утери Вами регистрационного кода и регистрационной карточки, либо компакт-диска с программой.

Для регистрации необходим регистрационный код копии PenReader, который Вы можете найти в регистрационной карточке, либо на наклейке на диске.

C помощью автоматической системы E-Care Вы сможете:

  • получать бесплатные обновления при выходе новых версий;
  • зарегистрировать Вашу копию программного продукта в любое удобное для Вас время;
  • в любой момент скачивать текущие версии зарегистрированных программ;
  • связываться со службой технической поддержки, причем Ваш запрос будет обработан по первому приоритету;
  • ознакомиться с другими нашими программами (демо-версии, а также условия приобретения);
  • своевременно получать уведомления о выходе новых версий продукта.

Более полную информацию о системе E-Care и о процедуре регистрации Вы можете найти по адресу: http://www.penreader.com/ru/company/e_care.html


Приобретение системы PenReader

Приобретение системы PenReader 2005

Оплата коммерческой версии системы PenReader и других продуктов компании Paragon Software (SHDD) возможна следующими способами:

  • кредитной карточкой через электронный магазин;
  • у дилеров в Москве, Санкт-Петербурге, Киеве и Вильнюсе (Более подробную информацию о наличии дилеров в Вашем городе можно получить в службе поддержки пользователей.);
  • оплатой квитанции в любом отделении Сбербанка (либо другого банка) и получением версии через Интернет. Это так же просто, как заплатить за квартиру!

Более подробно о покупке системы PenReader Вы можете узнать на нашем сайте:
http://pocket-pc-software.penreader.com/ru/

Уважаемые пользователи!

Ещё раз благодарим Вас за интерес, проявленный к нашему программному обеспечению. Надеемся, что в случае, если наша система PenReader 2005 Вам понравится, Вы приобретёте ее коммерческую версию, тем самым поддержав уникальные отечественные разработки высокотехнологичного ПО для Pocket PC! Поверьте, нам чрезвычайно важна поддержка КАЖДОГО пользователя, честно заплатившего за наше программное обеспечение!

Заранее благодарим за Ваш выбор!