Общие сведения о программе

P2KTools - программа для синхронизации телефонов P2K с компьютером.

Благодаря поддержки программой работы P2K и AT режимов существенно расширился диапазон функций программы. Реализована возможность работать с файлами телефона как в обычном проводнике Windows, редактирование ячеек seem, включение и отключение различных дополнительных возможностей телефона, создание и загрузка тем, редактирование справочника, ежедневника, отправка sms и многое другое.

К сожалению, программа разрабатывалась для телефонов, имеющих древовидную файловую структуру (V300, V500, V600, c650, c550, c450).
Старые модели телефонов скорее всего работать не будут (c330, c350, v150, c350L).

Самую последнюю версию программы можно скачать отсюда.

Обсуждение проблем и пожелания по программе можно оставить на форуме MotoFan в разделе Разработчики - Bezols's P2KTools - P2ktools.

От автора программы:

ИСПОЛЬЗУЙТЕ ПРОГРАММУ НА СВОЙ СТРАХ И РИСК.
ПРОГРАММА РАСПРОСТРАНЯЕТСЯ БЕСПЛАТНО.
ЗА ПОРЧУ ДАННЫХ В ТЕЛЕФОНЕ ИЛИ САМОГО ТЕЛЕФОНА АВТОР ПРОГРАММЫ ОТВЕТСТВЕННОСТИ НЕ НЕСЕТ.
С ПРЕТЕНЗИЯМИ НЕ ОБРАЩАТЬСЯ.

ПРЕДУПРЕЖДАЮ СРАЗУ, ЧТО:
1. ПРОГРАММА ЕЩЕ ИМЕЕТ ТУЕВУ ХУЧУ ГЛЮКОВ.
2. ВРЕМЕНИ НА ИСПРАВЛЕНИЕ БАГОВ У МЕНЯ ПРАКТИЧЕСКИ НЕТ.
3. НЕ НРАВИТСЯ - НЕ ПОЛЬЗУЙТЕСЬ.
4. Я ЖАДНЫЙ И ИСХОДНИКИ НИКОМУ НЕ ДАМ.
5. ПО МЕРЕ ВОЗМОЖНОСТИ И ЖЕЛАНИЯ ПРОГРАММУ БУДУ УСОВЕРШЕНСТВОВАТЬ.

Выражаю большую благодарность товарищу Vilko aka Fantom за
предоставленную информацию о том, как общаться с телефоном посредством
TCI-команд.


Установка драйверов

Перед первым подключением телефона к компьютеру необходимо установить драйвер Motorola USB Driver. В Интернете полно ссылок на него, поэтому найти его не составит труда (размер ~1.2 Mb).

После установки перезагружаем компьютер.

Подключаем телефон к USB.

Окрываем "Свойства системы" и убеждаемся что появился Motorola USB Modem.

Открываем "Панель управления" -> "Модемы" .

Нажимаем кноку [Свойства] - > Вкладка "Диагностика". Жмём [Опросить модем]. Должны получить ответ модема примерно такого содержания:

Если "отклик модема" не получен, придётся "поиграться" с системой. Обычно проблема возникает, если в системе есть простой модем. Поробуйте переставить модем на другой COM порт.
Если "отклик модема" Motorola не получен, дальше можно не читать, т.к. работать не будет.

Если всё нормально - идём дальше.
В принципе, этого драйвера достаточно чтобы программа работала в режиме AT mode. Но этого не достаточно для работы в P2K mode.

Запускаем программу в режиме P2K mode и жмём кнопку [Подключить].

Windows должен найти новые устройства. Драйвера для них лежат в папке с программой в подкаталоге /drv.

При успешной установке должны появиться новые устройства: Accessories Interface, Data Logging MCU ... и т.д.

Если у вас Windows XP и вместо этих устройств появилось такое предупреждение:

то необходимо отредактировать реестр Windows. Как это сделать читаем здесь.


Настройка работы с Windows XP

Если после установки всех драйверов в "Диспетчере устройств" появилось предупреждение и программа не хочет устанавливать связь с телефоном в режиме P2K mode, то необходимо отредактировать реестр Windows XP.

Запускаем "regedit.exe" и переходим в ветку HKEY_LOCAL_MASHINE\SYSTEM\CurrentControlSet\Enum\USB

Меняем "Разрешения..." для ветки USB. "Все" - "Полный доступ".

Удаляем все ветки, начинающиеся на 'Vid_22b8&Pid_5801...". Внутри самой ветки Vid_22b8&Pid_5801 должна быть ещё одна ветка , не важно с каким названием, у меня она называется 5&1d9adc3c&1&1. Находим параметр "Service" со значением "usbcgp" и меняем его на "usbhub".

Внутри ветки, с которой мы только что работали, есть ещё одна, с названием "Control", в ней есть параметр "ActiveService" - изменяем его значение на "usbhub".

Вынимаем кабель из телефона, ждём 5 сек, снова включаем. Запускаем программу P2KTools и делаем попытку снова подключится. Windows находит новые устройста, указываем путь к драйверам ( драйвера находятся в папке с программой в каталоге /drv).

Если вы делали всё точно как описано выше, то получите такую картинку:

Теперь можно работать с программой!


Настройка программы

Настройки программы находятся Меню -> Options -> Configuration.

configuration
Рис. Окно настроек программы

- Общее - общие настройки программы:
- Режим - здесь необходимо установить режим, в котором программа будет загружаться по умолчанию:
AT Mode - работа со справочником, ежедневником, SMS.
P2K Mode - работа с файловым менеджером, seem, редактирование различных фич в телефоне.
- Пользоваться кнопкой "Подключить" - убирает кнопку [Подключить] с панели инструментов. В этом случае телефон автоматически подключается при смене режима.

- Внешний вид - настройка внешнего вида программы.

- P2K Mode - настройка программы в режиме работы P2K:
- Autoupdate file list - включение функции автообновления списка файлов после каждой операции с файловым менеджером.
- Auto expand - включение функции автоматического раскрывания дерева папок телефона после загрузки списка файлов.
- Preview - отображение окна предпросмотра файлов телефона.

- AT Mode - настройка программы в режиме работы AT:
- Port - порт подключения телефона. Для того, чтобы установить правильный порт, необходимо перейти Пуск - Панель управления - Телефон и модем - вкладка "Модемы" - выбираем "Motorola USB Modem" - Свойства - вкладка "Модем". Там смотрим порт, к которому подключился телефон.
- BaudRate - скорость порта для модема. Смотрим там же где смотрели порт.
- Timeout - время опроса модема. Если порт и скорость выставлены правильно, но программа всё равно не видит телефон, можно попробывать увеличить таймаут.
- Язык - настройка языка интерфейса программы. Файлы с языковыми пакетами находятся в папке /Lang. При необходимости можно перевести программу на любой язык, добавив в папку свой языковой файл.

[OK] - подтверждение настроек и выход.

[Apply] - сохранение настроек без выхода из окна.

[Cancel] - отмена всех установок. Выход из окна без сохранения.


Строка меню

Строка меню содержит основные команды для работы с программой. Содержание команд строки меню во время работы программы в режиме P2K mode и AT mode различно:

Режим P2K mode:

- File
- Обновить - загружает список файлов из телефона в программу для дальнейшей раболты с ними;
- Скачать - скачивает указанный файл из телефона на компьютер;
- Загрузить - закачивает файл с компьютера в телефон;
- Удалить - удаляет указанный файл из телефона;
- Выход - выход из программы;

- Seem
- Читать seem - читает содержимое указанной ячейки памяти (seem) из телефона;
- Записать Seem - записывает содержимое seem в указанную ячейку памяти телефона;
- Seem из файла - загружает ранне сохранённый seem с компьютера;
- Seem в файл - сохраняет содержимое seem на компьютере;

- Phone
- Подключить - устанавливает соединение компьютера с телефоном;
- Перезагрузить - перезагрузка телефона;
- Спящий режим - переводит телефон в режим "спячки". Отключает телефон от сети оператора (не принимает звонки, sms), оставляя его в рабочем состоянии. Мера предосторожности при закачке файлов в телефон.
- Нормальный режим - возвращает телефон из "спячки".

- Tools
- Log - вызывает окно лога программы;
- Предпросмотр - окно предпросмотра файлов телефона;

- Options
- Configuration - настройка параметров программы;

- Help
- О программе - информация о версии программы и разработчике;
- Справка - запуск файла помощи.

Режим AT mode:

- File
- Читать всё - считывает все записи из телефонного справочника в программу.
- Добавить - добавляет новую запись в справочник.
- Редактировать - вызывает окно редактирования записи в справочнике телефона.
- Удалить - удаляет запись справочника.
- Сохранить - сохранение данных справочника на компьютере.
- Восстановить - записывает ранее сохранённую версию справочника с компьютера на телефон.
- Выход - выход из программы.

- Seem (не используется)

- Phone
- Подключить - устанавливает соединение компьютера с телефоном.

- Tools
- Log - вызывает окно лога программы;

- Options
- Configuration - настройка параметров программы;

- Help
- О программе - информация о версии программы и разработчике;
- Справка - запуск файла помощи.


Панель инструментов

Панель инструментов содержит основные кнопки для работы с телефоном.

[Переключить в...] - переключение между режимами работы программы:
· P2K mode - работа с телефоном в режиме составного устройства - управление файлами в телефоне, редактирование ячеек памяти.
· AT mode - работа с телефоном в режиме модема - управление справочником, SMS, ежедневником, встроенным модемом.

[Подключить] - установление связи с телефоном. Корректная работа программы обеспечена только если связь с телефоном установлена. О том, что программа готова работать с телефоном соответствует значение статуса телефона в строке состояния Connected и зелёным цветом индикатора.
Кнопка активна только в случае включения параметра "Пользоваться кнопкой "Подклчить" в настроках программы.

[Перезагрузить] - перезагрузка телефона. После перезагрузки, для дальнейшей работы с программой, необходимо снова установить сввязь с телефоном с помощью кнопки [Поключить].
Кнопка активна только в режиме P2K mode.


Работа с программой

Программа P2KTools позволяет работать с телефонами P2K в двух режимах:
· Режим P2K - работа с телефоном в режиме составного устройства - управление файлами в телефоне, редактирование ячеек памяти.
· Режим AT - работа с телефоном в режиме модема - управление справочником, SMS, ежедневником, встроенным модемом.

Преключатся между режимами можно кнопкой на панели инструментов [Переключить в...]. Режим, в котором программа будет работать по умолчанию после запуска, устанавливается в настройках программы Меню -> Options -> Configuration -> Общее.

P2K mode:

Рис. Окно программы P2KTools - P2K Mode

Основными элементами окна P2K mode являются:

Проводник - менеджер файлов телефона.

Seem-редактор - встроенный редактор seem.

Разные фичи - управление скрытыми возможностями телефона.

Темы - создание тем для телефона.

AT mode:

Рис. Окно программы P2KTools - AT mode

Основными элементами окна AT mode являются:

Терминал - работа с телефоном в режиме модема.

Спарвочник - редактирование записей телефонной книги.

Ежедневник - управление ежедневником.

Сообщения - работа с SMS.

Информация - информация о телефоне.

До начала работы с программой небходимо установить связь с телефоном. Для этого подключаем телефон к компьютеру. Выбираем режим работы (P2K или AT). Жмём кнопку [Подключить] на панели инструментов. При смене режима программы необходимо снова установить связь с телефоном.
При успешном подключении в сторке состояния появится надпись Состояние: подключен, а индикатор подключения станет зелёным. Только после этого программа будет работать с телефоном. В противном случае будет выдано сообщение об ошибке "Не удалось подключится".

Причин не успешного подключения телефона может быть несколько:
- Не установлены необходимые драйвера для работы с телефоном. Как установить драйвера для работы с программой читайте здесь.
- В реестр Windows XP не внесены необходимые изменения. Как подружить программу с Windows XP читайте здесь.
- Ошибка программы. В этом случае выньте кабель из телефона на ~5 сек, потом вставьте снова. Перезапустите приложение.


Режим P2K

Функции программы, доступные в режиме P2K mode:

· Проводник - менеджер файлов телефона - позволяет работать с файловой структурой телефона как в обычном проводнике Windows.

· Seem-редактор - встроенный редактор seem - ячеек памяти телефона.

· Разные фичи - управление скрытыми возможностями телефона.

· Темы - создание тем и закачка их в телефон.

В режиме P2K mode программа работает с телефоном как с составным USB устройством. Для того, чтобы система определила телефон именно так, необходимо установить драйвера из папки /drv. Как это сделать читаем здесь.

В "Диспетчере устройств" должны отображаться следующие устройства:

dispetcher
Рис. Диспетчер устройств

Если у вас Windows XP и эти устройства не обнаружены системой, то необходимо внести изменения в реестр. Об этом написано здесь.


Проводник

Проводник (Файловый менеджер телефона)

Файловый менеджер телефона позволяет удалять, копировать, просматривать содержимое телефона, закачивать файлы в телефон...

Рис. Файловый менеджер P2KTools

После того как программа установила связь с телефоном необходимо загрузить список файлов из телефона в программу. Для этого необходимо нажать кнопку [Обновить], после чего программа начнёт загружать список. Процесс загрузки графически отображается в строке прогресс-бара.Если необходимо, чтобы после загрузки списка файлов дерево папок было развёрнутым, нужно поставить галочку напротив параметра Auto expand в настройках программы.

Для того, чтобы просмотреть файлы, находящиеся в какой-либо папке, необходимо указать её мышкой, тогда в окно списка файлов загрузится содержимое этой папки.
Теперь можно работать с самими файлами.

В окне списка файлов отображается имя файла (Имя файла), его расширение (Тип), размер в байтах (Размер) и атрибуты (Атрибуты).
Выбрав необходимый файл можно просмотреть его содержимое. Для этого активизируйте параметр Preview в настройках программы или выберите в Меню - Tools - Предпросмотр, и дважды щёлкните мышкой по названию файла. Файл загрузится программой и в окне Preview появится его содержимое и краткое описание. Файл можно сохранить на компьютере непосредственно из окна Preview, нажав на кнопку в окне - [Сохранить].

Список форматов файлов, поддерживаемых программой для предпросмотра

Для того, чтобы сохранить какой-нибудь файл с телефона на компьютер, укажите его в списке файлов, а потом нажмите [Скачать]. В открывшемся окне укажите место на компьютере для сохранения файла. Жмите [Сохранить] - файл будет сохранён на компьютере. Возможно пакетное скачивание файлов из телефона в компьютер. Для этого укажите группу файлов -> [Скачать] -> Выберите папку для сохранения -> [OK]. Файлы не удаляются с телефона, а только лишь копируются на компьютер.

Для того, чтобы удалить файл (или группу файлов), выделите его в списке файлов и нажмите [Удалить]. ВАЖНО!!! Программа перед удалением не требует подтверждения, поэтому будте внимательны!

Для изменения атрибутов файла, укажите его в списке. В окне Атрибуты отобразятся текущие атрибуты файла, укажите новые и нажмите кнопку [Изменить атрибуты].

После каждой операции с файлами (удаление, копирование, смена аттрибутов, закачка файлов), список автоматически перезагружается. Для того, чтобы это не происходило, отключите параметр Auto Refresh в настройках программы. Тогда перезагрузить список можно будет только вручную с помощью кнопки [Обновить].

Для того, чтобы загрузить в телефон файлы нажмите кнопку [Загрузить], в появившемся окне выберите файл для загрузки и нажмите [Открыть]. Возможна пакетная закачка файлов. Для этого нажмите кнопку [Загрузить], выберите несколько файлов для закачки и нажмите [Открыть].
Все файлы будут загружены в активую (содержимое которой показано в списке файлов) папку телефона. Для того, чтобы загрузить файлы в какую-нибудь другую папку, поставьте галочку напротив параметра Использовать путь загрузки, и выберите путь для загрузки из списка, либо наберите его сами. ВАЖНО!!! Если вы вводите вручную путь для загрузки, то он должен заканчиваться слэшем "/" (без кавычек), иначе файл будет загружен неправильно и после этого, возможно, вы не сможете его удалить.

Список папок телефона:
/a/
корневая папка телефона
/a/mobile/
(пусто)
/a/mobile/system/
содержит файлы системы телефона и звуки камеры
/a/mobile/picture/
папка с катинками и фотографиями
/a/mobile/audio/
папка с аудио файлами и списком аудио файлов (MyToneDB.db, TempToneDB.db)
/a/mobile/mib/
(пусто)
/a/mobile/mib/pcf/
папка с иконками для встроенного интернет браузера
/a/mobile/mms/
?
/a/mobile/mms/mmstemplate/
шаблоны mms
/a/mobile/certs/
(пусто)
/a/mobile/certs/root/
(пусто)
/a/mobile/certs/root/x509/
(пусто)
/a/mobile/certs/root/x509/kjava/
сертификаты для kjava
/a/mobile/certs/root/x509/ssl/
сертификаты
/a/mobile/kjava/
папка с файлами для kjava
/a/mobile/settings/
папка с установками
/a/mobile/video/
папка с видео клипами

Важное замечание:
Информация взята из мануала программы P2Kman (автор программы Vilko, автор мануала M.org):

ЗАГРУЗКА МЕЛОДИЙ

Прежде чем проводить какие либо операции с мелодиями, необходимо сменить ВЕЗДЕ настройки мелодий на "Вибро" или "Бесшумный". Сделать это быстро и оперативно можно сделать с помощью программы P2KTools. В окне Проводника нажмите кнопку [Все вибро] или [Все бесшумные]. Профили звонков в телефоне автоматически изменятся на "Вибро" или "Бесшумный":

Необходимость всех этих действий обусловлена тем, что в телефонах Моторола создаётся список мелодий, и в настройках профилей/абонента/группы в роли мелодии присваивается не имя файла мелодии, а её порядковый номер в списке мелодий!

Список мелодий содержится в файле MyTone.db (и его копии TempTone.db). При заходе в Стили звонка/ID звонка (где либо) телефон читает этот список, а не список файлов! Следовательно, при удалении/добавлении мелодий необходимо удалять файл MyTone.db и перезагружать телефон.

Как вариант, можно редактировать файл MyTone.db, копировать его в TempTone.db и заливать оба файла в телефон. НО! Формат этих файлов для С350 понятен и давно разгадан, а для С450 и выше – нет! Формат MyTone.db для С350 можно просмотреть тут.

Важно! Сортировка мелодий в MyTone.db идёт по следующему принципу:

1. 3 или 4 стандартные, неудаляемые мелодии (Континентальный, Классический, Сирена)
2. Мелодии с атрибутом 70004 (Стандартные), при этом сортировка идёт НЕ по имени, отображаемому на экране, а по НАСТОЯЩЕМУ имени файла! Т.е. FairGround.mid будет находится перед "Латинский танец", потому что Fairground имеет имя файла FairGround.mid, а "Латинский танец" - ~AlerFile040.mid
3. Мелодии с атрибутом 70000 (Пользовательские). Сначала на английском, потом на русском

ВНИМАНИЕ! ПОСЛЕ ЛЮБЫХ ОПЕРАЦИЙ С МЕЛОДИЯМИ НУЖНО УДАЛЯТЬ ФАЙЛ MyTone.db И ПЕРЕЗАГРУЖАТЬ ТЕЛЕФОН.

Закачка мелодий.

Непосредственно закачка мелодий осуществляется очень просто и легко. Закачиваете мелодию(и), удаляете MyTone.db, перезагружаете телефон.

Проблемы могут возникнуть, только в том случае, если вы сначала удалите MyTone.db, закачаете мелодии в телефон ПОД ЗАВЯЗКУ так, что при перезагрузке не будет свободного места для создания MyTone.db. В этом случае, просто удалите одну из закачанных мелодий и перезагрузите телефон снова.

ВАЖНО! При заливке мелодий в телефон, MyTone.db пересоздаётся, а ссылки на ячейки в настройках звонков остаются теми же, так что возможны «сдвиги» мелодий в настройках.

НЕ РЕДАКТИРУЮТСЯ СТИЛИ ЗВОНКА

Так как в настройках мелодий, мелодии сохраняются не как имена файлов, а как номер пункта в MyTone.db, следовательно при удалении мелодий Вы должны следить, чтобы в настройках не было указаний на пустые ячейки в MyTone.db! Иначе при попытке зайти в настройки профилей, Вас просто выкинет в меню.

Если же у Вас такой глюк всё-таки проявился, то есть множество способов, как его вылечить:

· Общий сброс (НЕ Общая ОЧИСТКА!!!). НО этот способ НЕ лечит ID звонков абонентов и групп абонентов!!!

· C помощью PST. File|New>New feature file. Там делаете Read data from phone, изменяете настройки мелодий во всех профилях на 0 и делаете Write data to phone. НО этот способ НЕ лечит ID звонков абонентов и групп абонентов!!!

· Закачиваете обратно мелодии. НЕ ОБЯЗАТЕЛЬНО СТАНДАРТНЫЕ! Просто нужно, чтобы количество мелодий «после», было равно количеству мелодий «до».

· Создание мелодий в телефоне *иногда не помогает*. Меню>Медиа Центр>Мои мелодии>Меню (средняя кнопка) >Создать. И создаёте мелодии С ИМЕНАМИ «Яяnn», где nn – любые числа!!!

После этого опять удаляете MyTone.db и перезагружаете телефон.

· Использование в P2KMan кнопки "Обновить базу мелодий". Просто нажмите на кнопку - и все остальное программа сделает за вас.

Ну а если все выше перечисленное вам не помогло, остается только перепрошивка.


Seem-редактор

Seem-редактор представляет собой hex-редактор для работы с ячейками памяти телефона (seem).

Рис. Редактор seem

Редактор позволяет работать с seem как с самого телефона, так и с ранее сохранёнными на компьютере.
Для того, чтобы загрузить seem из телефона в программу укажите его номер в поле seem, и запись rec. Затем нажмите кнопку [Читать seem]. Значение ячейки будет загруженно в программу, для дальнейшего его редактирования.

Перед тем, как делать какие-либо изменения в seem, желательно сделать его резервную копию на компьютере, чтобы, в далнейшем можно было сделать откат к исходным установкам. Для этого читаем seem из телефона кнопкой [Читать seem], затем сохраняем его на компьютере, нажав кнопку [Seem в файл].

Для того, чтобы редактировать seem не из телефона, а из файла, жмём кнопку [Seem из файла], указываем файл с ранее сохранённой версией seem, и загружаем его в программу.

Чтобы залить отредактированный seem в телефон, необходимо указать его номер в поле seem, номер записи в поле rec и нажать кнопку [Записать Seem].

Два окна редактора отображают содержимое seem.
Левое окно показывает содержимое каждого бита в шестнадцатеричном виде (hex). Строки и столбцы окна построены таким образом, чтобы можно было легко находить смещение (offset) каждого бита. Строки пронумерованы по старшему разряду смещения.Каждая строка содержит 16 битов (от 0 до F). Столбцы пронумерованы по младшему разряду смещения.
Правое окно редактора показывает содержимое каждого бита в ASCII.
Кнопка [Очистить] служит для очистки окон редактора.

Редактирование каждого байта возможно как в окне редактора (непосредственно вводя в каждую ячейку значение), так и с помощью Битовых операций. Для редактирования конкректного бита надо указать байт в окне редактора. На панели Битовые операции отобразится его содержимое в десятичном виде (Dec), шестнадцеричном виде (Hex) и в двоиичном виде (Binary). Двоичный вид байта графически отображен с помощью галочек. Бит, отмеченный галочкой имеет значение 1, бит, не имеющий галочки, имеет значение 0. Изменяя значение каждого бита (указывая, либо убирая галочки), можно включать и выключать различные скрытые функции телефона. Исследования в области редактирования seem, активно ведуться на форуме МотоФан. Наиболее необходимые функции телефона можно включить с помощью программы P2KTools (вкладка Фичи 32-го сима).

С помощью редактора можно сделать резервную копию (backup) всех seem, которые содержит телефон. Для этого в поле Сохранение Seem надо указать начальный seem, начиная с которого надо делать резервную коппию (от), конечный seem (до) и нажать кнопку [Читать все]. Сохранение seem графически показывается заполнением полоски прогресс-бара. Полная копия всех ячеек очень долгая операция, и если вы не уверены что доживёте до её конца - жмите кнопку [Остановить].

Про UCS->ASCI и ASCI->UCS ничего не знаю.... Поэтому допишу после разьяснений!


Разные фичи

На вкладке Разные фичи собрана различная информация про телефон, а так же редактор скрытых функций телефона.

Рис. Разные фичи

Информация - информация о версии прошивки, флекса и модели телефона.

Фичи 32-го сима - редактор дополнительных функций телефона (используется инженерный seem 0032 rec 0001).

Gain table - управление уровнем звука телефона (используется gain_table.bin).


Информация

Для получения информации о телефоне нажмите соответствующие кнопки в панели Информация. В окошке рядом с кнопкой отобразиться значение.

information
Рис. Панель "Информация"

[Прошивка] - отображает номер прошивки телефона;

[Флекс] - отображает версию флекса;

Модель телефона - выводит идентификатор модели телефона в системе. Для того, чтобы его просмотреть нажмите кнопку [Узнать]. Чтобы изменить значение - введите новое и нажмите [Изменить].


Фичи 32-го сима

Панель Фичи 32-го сима содержит несколько вкладок для редактирования различных функций seem 0032 (flex table):

Замечание: Большинство функций, включаемых на этой панели, работают только на телефонах серии Vxxx.

Рис. Панель "Фичи 32-го сима"

Java - управление функциями меню телефона Параметры - Средства JAVA.

Сообщения - управление функциями меню телефона Сообщения.

Мультимедия - управление функциями меню телефона Мультимедия.

Офисные средства - управление функциями меню Офисные средства.

Стандартные оповещения - редактирование стандартных оповещений.

Другое - остальные функции.

Чтобы узнать какие функции включены или выключены в телефоне - нажмите кнопку [Считать]. Включенные функции будут отмечены галочками. После изменения функций телефона и их сохранения, нажмите кнопку [Записать]. Изменённые функции появятся только после перезагрузки телефона.


Java

На вкладке Java возможно редактирование функций меню телефона Параметры - Средства JAVA.

java
Рис. Java

Java App Loader - активация меню Загрузка JAVA.

DNS IP viewable - делает пункт меню DNS IP видимым.

DNS IP changable - позволяет включить возможность изменения DNS IP.

Start TCK - включение пункта меню Start TCK.

Switching to Debug option - включение пункта меню Switching to debug.

App Priority, Set Stendby App, App Backlight/Blink - активизация пунктов меню"Установка приложения по умолчанию", "Функция подсветки", "Функция звука", "Функция вибро".


Сообщения

На вкладке Сообщения возможно редактирование функций меню телефона Сообщения.

messages
Рис. Сообщения

Пункты меню - включение/выключение пунктов меню Сообщения.

Другое
- Отчёт о доставке - включение пункта меню Получение.
- Отсчёт символов - изменяет вид счётчика символов при наборе sms. Включенное значение делает счетчик символов от 450 до 0. Выключенное - от 0 до 450.
- Хранение SMS - место хранения sms. Включено - sms сохраняются в телефоне (количество sms зависит от количества свободной памяти телефона, но возможна потеря sms'ок при извлечении sim-карты) , выключено - sms сохраняются на sim-карте (количество sms ограничено памятью sim-карты).
- Поле: "Тема" - отображение поля Тема при наборе sms.


Мультимедия

На вкладке Мультимедия возможно редактирование функций меню телефона Мультимедия.

multimedia
Рис. Мультимедия

Аудио/Видео Натройка (Таймер) - установка счетчика при проигрывании мелодии или видеоклипа. Можно сделать так, чтобы не отобржался бегунок, показывающий текущюю позицию трека.

Пункты меню - добавление/скрытие пунктов меню Видео, Мотомиксер, Темы.

Своя цветовая палитра - включение возможности добавления своей цветовой палитры.

Настройка изображения - настройка параметров меню Мультимедиа - Картинки.


Офисные средства

На вкладке Офисные средства возможно редактирование функций меню телефона Офисные средства.

Рис. Офисные средства

Пункты меню -включение возможности добавления пунктов меню Технология, Чат, Диктофон, Метки, Быстрый набор.


Стандартные оповещения

На вкладке Стандартные оповещения возможно редактирование стандартных оповещений.

alerts
Рис. Стандартные оповещения

Вибровызовы - добавление новых вариантов вибровызовов;

Оповещения - редактирование стандартных мелодий оповещений;


Другое

На вкладке Другое возможно включение дополнительных функций телефона.

other
Рис. Другое

меню 0 0 * * T E S T O F F * -активация выключения режима инженерного меню;

меню 0 0 * * T E S T M O D E * -активация запуска режима инженерного меню;

Две линии - деактивация второй линии телефона.


Gain table

Панель Gain table предназначена для управления уровнем звука телефона, используя файл gain_table.bin.

Рис. Gain table

Нажмите кнопку [Считать], для того, чтобы загрузить из телефона установленные уровни звуков. Установите новую громкость для внутреннего динамика, клавиатуры, внешнего динамика, звуков/видео и системных звуков. Нажмите кнопку [Сохранить] для сохранения параметров в телефоне.

Кнопка [По умолчанию] записывает в телефон параметры по умолчанию.


Темы

На закладке Темы вы можете создать свою тему и загрузить её в телефон.

theme
Рис. Создание тем для телефона

Тема для телефона представляет собой набор фоновой картинки, заставки, и мелодии звонка. Список доступных тем в телефоне можно посмотреть Меню - Мультимедиа - Темы.

Чтобы создать свою тему выберите Фоновую катинку, Заставку и Мелодию. Задайте имя темы (то как она будет отбражаться в телефоне).
Изображения фоновой картинки и заставки доступны для предпросмотра в соответствующих окошках. Мелодию темы можно прослушать используя встроенный плейер.

Для записи темы в телефон нажмите кнопку [Загрузить в телефон]. Чтобы сохранить тему в файле и загрузить её позже нажмите [Сохранить в файл].

Если необходимо залить в телефон ранее созданную и сохранённую тему, то воспользуйтесь Проводником. Файл с описанием темы (*.tcf) и картинки нужно записать в корневую папку телефона /a/. Файл с мелодией в папку /a/mobile/audio/.


Режим AT

Функции программы, доступные в режиме AT mode:

· Терминал - работа с телефоном в режиме модема.

· Справочник - редактирование, добавление и удаление записей справочника телефона.

· Ежедневник - редактирование событий ежедневника.

· Сообщения - управление возможностями SMS, сохранение архива входящих SMS на кампьютере.

· Информация - информация о телефоне, версии Flex и ПО. Синхронизация времени.

В режиме AT mode программа работает с телефоном как с модемом. Поэтому для установления связи с телефоном достаточно проинсталлировать только Motorola USB Driver. Как это правильно сделать читаем здесь.

Кроме того, необходимо праввильно установить порт в настройках программы.


Терминал

Работа с телефоном в режиме терминала позволяет отсылать AT команды встроенному модему телефона и получать ответы на эти команды.

terminal
Рис. Терминал

Выберите необходимую команду из списка AT команда или введите её вручную. Для отправки команды модему нажмите кнопку [Послать]. Результат опроса модема отобразится в окне программы. Чтобы очистить окно программы нажмите кнопку [Очистить].


Справочник

Вкладка Справочник, позволяет редактировать телефонную книгу и создавать её резервные копии на компьютере.

Рис. Справочник

Перед началом работы со справочникм нажмите кнопку [Читать все] для загрузки справочника в компьютер. Загрузка телефонной книги графически отображается заполнением полоски прогресс-бара. Кроме того, определяется заполненность памяти телефона на полосе Память телефона, и sim-карты на полоске Память SIM.

Для редактирования записи сделайте двойной щелчек по ней, либо левой кнопкой мыши вызовите Контекстное меню - Редактировать. В появившемся окне введите новые данные контакта и нажмите [Применить]. Новые данные запишутся в телефон.
Кнопка [Изменить] выполняет те же функции.

Чтобы добавить новый контакт в телефонной книге, нажмите кнопку [Добавить]. Заполните поля формы: Быстрый набор, Имя, Номер, Тип, Мелодия, Категория, Картинка и нажмите кнопку [Применить].

Чтобы удалить контакт из справочника, выберите запись и нажмите кнопку [Удалить].

Для создания резервной копии справочника нажмите кнопку [Back Up]. Формат файла резервной копии (*.csv) совместим с mobile Phone Tools.

Для восстановления резервной копии телефонной книги нажмите [Restore] и выберите ранее сохранённый файл.


Ежедневник

Вкладка Ежедневник позволяет редактировать и создавать навые события в ежедневнике вашего телефона.

dairy
Рис. Ежедневник

Чтобы считать события из ежедневника в телефон нажмите кнопку [Обновить].
В строке Событий в действии: отображется количество активных событий.

Для добавления нового события нажмите кнопку [Добавить], заполните форму события и нажмите кнопку [Применить]. Новое событие запишется в телефон.

Для редактирования события выберите его из списка и нажмите кнопку [Изменить]. Введите новые данные события и нажмите [Применить].

Для того, чтобы удалить событие выберите его из списка и нажмите [Удалить]. Программа перед удалением не требует подтверждения, поэтому будьте внимательны!

В поле Автоудаление событий устанавливается срок, после которого событие будет автоматически удалено телефоном. Выберите необходимое значение и нажмите [Применить].

Для удобства можно использовать Календарь, активировав его поставив галочку напротив этой строки.


Сообщения

На вкладке Сообщения можно просмотреть sms сообщения вашего телефона, создать новое и отправить его.

sms
Рис. Сообщения

Выберите категорию сообщений (Входящие, Исходящие, Отправленные, Черновики) чтобы загрузить их в программу.

Все сообщения из папки Входящие атоматически сохраняются на компьютере в папке Архив.

Для просмотра текста сообщения выберите его из списка. Его содержимое отобразиться в окошке Сообщение.

Для создания нового сообщения в вашем телефоне нажмите [Новое]. В появившемся окне выберите получателя из списка Получатель, или введите его вручную. Выберите кодировку сообщения (ASCI - сообщение латинскими символами, Unicode - сообщение кириллицей). Укажите действия, которые вы хотите применить к сообщению (Только сохранение - сохранение сообщения в Исходящих без отправки получателю, Сохранить и отправить - сохранение сообщения в Исходящих и отправка получателю, Отправить без сохранения - отправить сообщение получателю, не сохраняя его в телефоне). Нажмите [OK].

Чтобы сохранить сообщение (или группу сообщений) на компьютере в виде текстового файла укажите необходимые для сохранения сообщения и нажмите [Сохранить].

Чтобы удалить сообщение выберите его из списка и нажмите [Удалить]. Программа не требует подтверждения перед удалением, так что будьте внимательны!

Чтобы очистить всю категорию сообщений нажмите [Удалить все].


Информация

На вкладке Информация можно просмотреть различную информацию о вашем телефоне.

info
Рис. Информация

IMEI - номер IMEI вашего телефона;

IMSI - номер IMSI вашей SIM карты;

Производитель - торговая марка производителя телефона;

Модель - модель вашего телефона;

Частоты - диапазон частот, в которых может работать ваш телефон;

Прошивка - версия ПО вашего телефона;

Флекс - номер флекса;

Оператор - название оператора сотовой связи;

Заряд - процент зарядки аккумулятора телефона;

Уровень сигнала - уровень приема сигнала базовой станции;

Телефон - дата и системное время вашего телефона;

Компьютер - дата и системное время вашего компьютера.

Для того, чтобы синхронизировать время и дату вашего телефона с компьютером нажмите кнопку [Sync Time]. Системное время вашего компьютера запишется в телефон.


FAQ

Пока раздел пуст....
Он будет пополнятся по мере появления вопросов по программе на форуме MotoFan.


Авторы

Идея и разработка программы:

Bezols
e-mail: bezol@mail.ru
ICQ: 159702283

Автор мануала:

Dmitriy A. Karnakov aka KEO
K-Group Studio, 2004
e-mail: keo_mail@front.ru
ICQ: 341515018