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Introduction

About Autodesk’ Stitcher” Unlimited 2009

Autodesk Stitcher Unlimited 2009 is the way to build high-quality panoramas for the Web, film, print,
and 3D.

With advanced features, Autodesk Stitcher Unlimited 2009 gives photographers and artists the
power to deliver the most impressive panoramas in the formats they need. Autodesk Stitcher creates
wide-angle, high-resolution 360° x 180° panoramic images in seconds from horizontally and vertically
overlapping photos. You can create new image sets from the panorama using a virtual camera with
zoom, pan, and roll motion. Results can be rendered as a cube, plane, cylinder, sphere projection,
and as a QuickTime" movie (Cylindrical QTVR and Cubic QTVR), and in VRML format for creating high-
impact Web pages, definition mattes, environment maps, and 3D models.

Goal of this tutorial

This 5-step tutorial will guide you through the creation of a full spherical panorama image in 360° and
a QTVR interactive file. This complete project will take you step by step through the main workflow
and features of Autodesk Stitcher Unlimited 2009.

This tutorial was prepared and illustrated using Autodesk Stitcher Unlimited 2009.
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1. Loading Images

The Autodesk Stitcher Unlimited 2009 interface

Toolbar Stitching window

Live Preview

General Information

| . stitcherUntimited - Untitled. rzs*

File  Edit  Wiew titch  Render HDR  Tools  Window  Help

™ "“'H’zs 8 | N _ ' ‘ T

»

Thumbnail View

Autodesk

Status Indicators
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Loading your shots

The first step in the creation of a Stitcher project is to load the image files that you will use to
create the panorama.

To load the pictures:
1. Select File > Load Images from the main menu or click the Load Images icon in the toolbar.

The Load Images browser opens.

2. Select all the files you will use for your panorama.
3. Click Open.

Select the files to open E]
Flegarder dans: | (5 basic - e ®EerE-

- o el AT i R =il )
/j Weritian02.jpg | * Wenitian17 jpg
Venitian03.jpg  © Wenitianld.jpg
Venitian4.jpg  |* Wenitiani9.jpg
WenitianDS.jpg  |© Yenitian20.jpg
Venitian0s. jpg
‘Venitian07.jpg
Venitian0g. jpg
Wenitian03. jpg
Wenitian10.jpg
Venitiant1.ipg
Venitianl2.jpg
| Venitianl3.jpg
= 1 Weritian14.jpg
Favoris réseau |1 VenitianlS.jpg

oy

Poste de tavail

) T ) ) T T ) R T [

\
=

Nom du fichier |‘Venitian01.ipg” "Wernitian0Z.jpg" WVenitian03.j ﬂ Diurvrir
Fichiers de type |AH Supported Format [%pg ~jpeg ™ jpe ™ tif it j Anruler

When the images are loaded, Stitcher tries to read the EXIF data and proposes the
appropriate camera lens type. The following dialog lets you choose between keeping the
settings and adjusting them manually.

'®. StitcherUnlimited B

L

From the EXIF header we deduced: lens-type ‘Rectilineat’, with a Focal length of 21
L 9 ) mm. Do you want to keep these settings?

. =

s [ w |

The current example use images with EXIF data so Stitcher correctly detects all the
parameters. Click Yes to keep the settings Stitcher has read.

NOTE If for any reason you need to change the parameters you can right-click anywhere
inside the Stitcher interface and open the Properties dialog.
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ﬁ. |
Properties

Camera | Yiewing Camera || Hatspok |

Image Resclution  Width Height | 1000 Ratioc | 0.656

Camera Lens Tvpe |Recti|inear (default) M Standard Lens

Film Back  Width Height | 36.5854 mm
Focal Length |InitializedBl |21 | i 2,117 degrees

Distortion Initialized (%) |0 R | o |

Sensor Shift |InitializedM she |D | = l:l

Your images will be loaded into the Thumbnail View, as demonstrated in the screen shot
below.

| ®. StitcherUnlimited - Loading.rzs B &)
Fle Edt tiew Stich Render HDR  Tools Window Help

Open the loaded.rzs file to see the image files already loaded for this project.

Autodesk
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2. Stitching

Auto-Stitching

Autodesk Stitcher Unlimited 2009 has a fully automated stitching engine. Run the Stitch Shots
function by either:

e clicking the icon in the toolbar, or
o press ENTER (make sure no images are selected), or
e Stitch > Stitch Shots

Stitch Shots (Stitch the selected shot in
the working area or automatically stikch

{all shots otherwise)

The Stitching Window is a 3D environment in which you can navigate around using the navigation
controls (see “Navigating in Stitcher” in the Stitcher User Guide for more information on navigation).

NOTE The display can appears smoother in the Stitching window if your graphic card allows real time
linear blending; the GPU options can be set from the preferences. The icon is a status indicator to
specify that the GPU blending is activated.

Autodesk
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| & stitcherUnlimited - Untitled.rzs* =/oed

File Edt ‘“iew Stitch Render HDR  Tools  Window  Help

Manual-Stitching

In this example almost all the pictures are automatically stitched, but one is missing. For situations
like this, you can use the Manual Stitch tool to complete the panorama.

To manually stitch the missing image, you need to find a stitched image which overlaps it. You will
use the overlapping features in the shots to match the images one to each other.

1. Select the unstitched image
2. Add to the selection by holding down the Shift key and clicking an already stitched image
which has features that overlap the unstitched image (in our example use the venitian08.jpg)

Autodesk
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r! StitcherUnlimited - Autoalign.rzs® BEF]
Fie Edt Wew Stkch Render HDR Tools Window Help

Manual Stikch (select twa images in the thumbnais
o i the working arss, One must already
be stitched)

3. Do one of the following:

e Click Manual Stitch in the Toolbar, or
e Select Stitch > Manual Stitch, or
e Right-click and choose Manual Stitch from the contextual menu

Manual Stitch {select bwa images in the thumbnails

8 o in the working area, One must already
M be stitched)

When stitching images manually, you need to find at least two common points in both images.
The points should not be on the same line, but be distributed in the image for greater precision.

The manual stitch workflow is:

Autodesk
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1. Click and place a marker on a particular detail in the first image

r N

®. Manual stitch ®

2. Click to add the same marker inside the second image, then repeat step 1 and 2 to create 3
points inside each image as shown in the screen shots.

Autodesk
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3. After you have placed the three matching points, click Stitch and your image will be
positioned correctly inside the panorama.

Autodesk
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| '8, StitcherUnlimited - Autoalign.rzs*
Fle  Edit ‘View Stkch Render HDR  Tools  window Help
= Ly ¥ (. *

NOTE Manually stitched images have a yellow highlight to distinguish them from auto-stitched
images.

Load the Stitcher project file, stitched.rzs, to see this step completed.

Autodesk
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3. Alighment

Before rendering the panorama, you can change the viewpoint to determine what you see in the
final panorama. Stitcher automatically aligns the panorama.

You can align the panorama by clicking the Auto-Align icon or by selecting Tool > Automatically Align
Panorama, or pressing “A”.
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. StitcherUntimited - Autoalign.rzs* Q@ﬁ
Fie Edit Vew Sttch Render HDR Tools ‘Window Help
3

NOTE the ﬂ status indicator is displayed when the panorama is aligned.

Autodesk
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4. Equalization

When you click the Equalization icon, the Equalization tool launches in all of the images. This step is
significant and makes it possible to correct certain differences in exposures, especially in the levels of

blue in the sky.

NOTE The Equalization process can be reverted at any time by selecting Render > Unequalize. The
equalization factor can be defined in the rendering preferences.

f‘é‘ T 1 f“ m,"?\-‘ { b““??' u’l.é':
£ ‘{a\ujm]]ﬁ.g&ﬁ fi“. ,ﬁﬁ}‘% .
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5. Render

Render area and rendering options

If you need to render only a part of the panorama, do the following steps:

1. Select Render > Render Area > Set Render Area tool.
2. Right-click in the panorama, and choose Spherical View from the contextual menu

I - Autostitch.rzs®
1  Render HDR Tools  Window  Help

Equalize All Images Chrl+E

Cuick, Preview Chrl+P

Render Area r Set Render Area
Render Chrl+R ! Reset Render Area

a

NOTE the contextual menu in the fully-stitched panorama lets you choose the projection you
want to use for rendering.
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B %

F!; StitcherUnlimited - Untitled.rzs*
File Edit Views Stitch Render HDR  Toaols  Window  Help

v Spherical View
Cubical View
Cylindrical view
Snapshot Yiew

Set Render Area
Reset Render Area

3. Now draw a rectangular area in order to define and adjust the borders of the final image.

|V! Stitc herUnlimited - manual-stitch.rzs* EJ@

File Edt View Stkch Rendsr HDR  Tools ‘Window Help

4. To quit the Render Area tool, press the Space key or Render > Render Area > Set Render
Area.
5. Click Render Panorama to set the render parameters.
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or interactive panorama in the File Format I.f
aof your choice) *!

6. The last step before launching the rendering process is to define the parameters for the
image.

Stitcher gives you the option of the following rendering types:

e Cubical or cylindrical QuickTime" VR (QuickTime Player installation is required)
e Images with a spherical, a cylindrical, or a cubical projection

e Snapshot image

e 3D formats such as VRML or Pure Player’ projection

When rendering a panorama as an image, you can choose between the following file

formats:
e Jpg
o TIF

e PSD Photoshop’

Each file format has specific options which can be adjusted in the related tab.

f‘é‘ T 1 f“ m,"?\-‘ { b““??' u’l.é':
£ ‘{a\ujm]]ﬁ.g&ﬁ fi“. ,ﬁﬁ}‘% -
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®. Render Parameters

Render Properties

Tell Me More

e ) [

File Rendering  JPG Options Settings
Opkions Managerment

Filename stepsi\basicivenitian_spherical_render_area.jpg
Type |Spherical Image | Bra ™

Use GPU For rendering Use current expo

Morph - Mormal - Bilinear
CQuality 100 - Smoothing 0

Ise Defined Yiewport
width | 2048 % Best Size Ratio (%) 54,00 |3

Height | 778 &) j

The sphetical render Farmat maps the complete sphere onko a Flat image using an
equirectangular projection. The projection distorts the wertical and horizontal lines. Use this
render Format to create an artistic effect, such as a print or a spherical map to be used in
other 30 software packages,

Before rendering, you must define:

e The path and filename where you want to save the image file

e The size in pixels (for this tutorial you will set the width to 2048, the height value will
update automatically).

NOTE The size of the panorama will have an impact on the rendering time. The optimal size is
calculated as a function of the original image size that you have loaded in Stitcher, in order to
maximize quality.

e The image format.

Now verify that the Type is set to Spherical and that the Use Defined Viewport option is
checked. The Use Defined Viewport option is active when a render area is set.

Click Render.
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Spherical panorama 360° with render area.

Load the Stitcher project file, render_area.rzs, to see this step completed.

You can also see the result with the file Venitian_area.jpg.

Autodesk
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Load a Spherical panorama and convert to QTVR®

This part of the tutorial guides you through loading a full 360° panorama in Stitcher, using the
authoring control tool to set the viewing parameters of your movie and then converting the
panorama to a QTVR' file.

1. Select File > Load Panorama
The browser dialog opens.

2. Select the image file you want to load and click Open.
In our example load Venitian_Spherical.jpg.

NOTE If you are working with a cubical panorama, select one of the 6 face files.

|!,' StitcherUnlimited - Untitled.rzs
File Edit Miew Stitch  Render HDR Tools  Window  Help

Mew Projeck

Open Praject

Save

Save As..,

Revert

Recent Projecks #

Cpen Template
Save as kemplate. ..

Load Images

Load Panorama

Quik

Autodesk

Page | 20



Autodesk” Stitcher” Unlimited 2009

Getting Started Tutorial

% StitcherUntimited - Untitled.rzs* W= <)

File Edt ‘“iew Stitch Render HDR  Tools  Window  Help

‘B StitcherUnlimited - Untitled.rzs*
At el S :[..';@‘lﬁ:xﬁ.; Window  Help

Set Harizon

Hotspot Tool

Load hots

High distorkion ¥

Autodesk
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3. Use Tools > Authoring Controls to activate the interactive controller.

The General Information expands to display the Authoring Controls options.

4. Use the navigation control inside the stitching window to author (in real time) the view you
want your QTVR file to have. Adjust the zoom out and lock it by clicking Max FOV. Do the
same with the min FOV. You can real-time preview the zoom control constraint and adjust
them at any time.

NOTE The zoom out constraint is a good way to define the maximum zoom view and thereby
stop viewers from setting a huge field of view (sometimes an inelegant display for your
movie). The zoom in constraint prevents viewers from magnifying the view past the point
where you feel the image quality of your movie is compromised (too pixilated, and also an
inelegant display for your movie).

Use the Tilt constraint and the Pan constraint the same way.

In our example, the bottom part of the panorama is a black area, so we want to prevent
viewers from tilting to that position. We have therefore locked the Min TILT value.

Autodesk
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5. To quit the Authoring Controls tool, close the edit dialog, then select Tools > Authoring
Controls, or click the white cross at the top right corner of the General Information.

NOTE Do not change the point of view after setting the Authoring Control otherwise your
Authoring Control values will not make sense anymore without the initial points of reference.

6. Open the Render Parameters dialog by clicking , or select Render > Render.

Autodesk
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7. Setthe render parameters path, filename, size and QTVR options as you see them in the
next screen shot.
'E; Render Parameters
3 B
Qm:m Qulr.t:lme %ﬂ
VR VR s

File Rendering QT Oukput  QTYR Scripting Settings

Options Setup Management

|Render Properties

Filename hStitcherg) Tutorial_5_Stepstbasichvenitian, moy

Type | Cubic QTYR [v] h1A

Ilse GPU For rendering Ilse current expo

Linear - Mormal - Bicubic
Phioto - JPEG - Lossless Quality (100%4)

width | 800 2 Best SizeRatin (%) 83,00 |3

Height | 800 (= J—

| Tell Me More |

Convert Cancel

The QuickTime® cubic render creates a full spherical {cubical) QuickTimed® file, Use this render
Format when you wank to share vour panorama interactively on the Internet or on CO-Roms.

0J1

8.

Launch the Convert process.

Congratulations! You have successfully completed the full Stitcher workflow from stitching a

panorama, and to creating a QTVR movie.

View the result with the file Venitian.mov.
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