NetLook v1.4 help

Содержание

  • Введение
  • Конфигурирование NetLook
    • netlook.ini
    • ipscan.txt
    • filters.txt
  • Горячие клавиши
  • Команды
Введение

Программа NetLook предназначена для обзора и навигации машин в локальной сети.

Особенности данной программы:
  • Открытие сетевого ресурса происходит в отдельном потоке, что дает возможность одновременно открывать несколько ресурсов.

  • При сканировании машины, сразу сканируются и её сетевые ресурсы.

  • Можно отправлять и получать (со звуковым оповещением) сообщения типа NetSend.

  • Окно программы сворачивается в трэй.

  • Присутствует тематический фильтр ресурсов.

Конфигурирование NetLook

Настройки программы хранятся в файлах netlook.ini, ipscan.txt, filters.txt.

Содержание файла netlook.ini
[Screen]
Language=Язык (russian.lng, english.lng и т.д.);
ViewToolbarFlag=Отображать ли панель инструментов? (0-нет,1-да);
FlatButtonsFlag=Flat-стиль кнопок панели инструментов (0-нет,1-да);
ViewCommandLineFlag=Отображать ли командную строку? (0-нет,1-да);
CloseEquMinimizeFlag=Использовать ли кнопку "закрыть" как "свернуть"? (0-нет,1-да);
ImageWidth=Ширина значка;
ImageHeight=Высота значка;
WndX=X-координата окна;
WndY=Y-координата окна;
WndW=Ширина окна;
WndH=Высота окна.

[Items]
ViewHideSharesFlag=Отображать ли скрытые ресурсы? (0-нет,1-да);
ViewIPFlag=Отображать ли IP-адреса? (0-нет,1-да);
ViewWorkgroupsFlag=Отображать ли рабочие группы? (0-нет,1-да);
OpenEmptyHostFlag=Открывать ли по двойному клику пустую машину? (0-нет,1-да);
OpenByNameFlag=Открывать ли ресурс по имени (0-нет{открывать по IP-адресу},1-да) [Из программы можно изменять этот параметр, для этого нужно удерживать клавишу Ctrl при выборе соответствующего пункта меню];
OpenApplication=Приложение с помощью которого будет открываться ресурс (если пусто - то explorer).

[Net]
GetSharesTimeoutS=Время ожидания получения ресурсов при сканировании (с);
GetSharesTimeoutMS=Время ожидания получения ресурсов при сканировании (мс);
GetSharesTimeout2S=Время ожидания надежного получения ресурсов при сканировании (с);
GetSharesTimeout2MS=Время ожидания надежного получения ресурсов при сканировании (мс);
GetSharesTimeout3S=Время ожидания получения ресурсов при открытии (с);
GetSharesTimeout3MS=Время ожидания получения ресурсов при открытии (мс);
GetNameTimeoutS=Время ожидания получения имени (с);
GetNameTimeoutMS=Время ожидания получения имени (мс);
GetNameRepeatCount=Количество повторений сканирования имен;
GetNameRepeatTimeout=Задержка между повторениями сканирования имен;
ThreadTimeout=Задержка(в мс) между запусками потоков;
PortionSize=Количество адресов (из ip.txt) которые будут сканироваться в отдельном потоке;
MaxThreadCount=Максимальное количество потоков;
MaxComps=Максимальное количество компьютеров;
User=Логин для подключения к компьютеру;
Password=Пароль для подключения к компьютеру.

[Messngr]
StartFlag=Запускать ли собственный обработчик входящих сообщений? (0-нет,1-да);
HistoryFlag=Сохранять ли сообщения в историю? (0-нет,1-да);
PlayMessageSoundFlag=Проигрывать ли звук при получении сообщения? (0-нет,1-да);
RecvReplayMessageFlag=Получать ли подряд одинаковые сообщения? (0-нет,1-да);
MessageSound=Звук входящего сообщения;
MessageTemplate=Шаблоны заголовка сообщения NetSend в NT/2k/XP системах. При вхождении текста в шаблон, стандартное NetSend-окно будет закрыто, а текст сообщения будет добавлен в диалог NetLook'а. Соответственно пропадает необходимость в отключении стандартной службы сообщений.

Содержание файла ipscan.txt

В этом файле находятся записи диапазонов IP-адресов, которые нужно сканировать. Формат записей следующий: [#]xxx.xxx.xxx|xxx-xxx.xxx|xxx-xxx;, где xxx-число в диапазоне 0..255. Символом # помечены диапазоны, которые не нужно сканировать.

Пример:
192.168.1.1-255;
192.168.2-4.1-255;
#192.168.8.1-100;

Файл ip.txt - содержит базу IP-адресов, он создается и дополняется автоматически.

Содержание файла filters.txt

Здесь прописаны шаблоны для тематической фильтрации ресурсов. Каждый новый шаблон начинается с новой строки, фразы шаблона отделены запятой.

Пример:
film,фильм,video,видео
mus,муз,mp3
game,игр

Горячие клавиши

Главное окно

F1 | Помощь
F5 | Обновить
Ctrl+Right | Раскрыть дерево
Ctrl+Left | Свернуть дерево
F3 или Ctrl+'R' | Открыть окно ресурсов
Space | Открыть окно сообщений

Окно сообщений

Ctrl+Enter | Отправить сообщение
Esc | Закрыть окно

Окно ресурсов

Esc Закрыть окно

Команды

Начиная с версии 1.37, NetLook поддерживает работу с текстовыми командами. Команды вводятся в командной строке, которая находиться в нижней части основного окна программы.
На данный момент поддерживаются следующие команды:

ABOUT - О программе.
HELP или H или ? - Помощь.
EXIT - Выход.
RESTART - Рестарт.
EDIT или E filename - Редактировать файл filename.
EXPAND или > - Раскрыть дерево.
COLLAPSE или < - Свернуть дерево.
UPDATE - Обновить.
RESOURCES или R - Открыть окно ресурсов.
MESSAGE или M host - Открыть окно сообщений для host, где host - это имя или IP-адрес машины.
FIND или F host - Найти и выделить в дереве машину host.
\\host[\path] - Открыть машину host или ее ресурс host\path.

IP-адреса можно удобно сокращать, например если ваш IP-адрес - 192.168.31.26, то для открытия машины с адресом 192.168.31.25 достаточно написать в командной строке \\25, соответственно для открытия 192.168.33.16 можно написать \\33.16, аналогично и для сокращений до трех чисел. Если host - это IP-адрес, то \\ можно опустить, т.е. достаточно ввести только host или host\path.

© 2003 KurbetSoft
WWW: | http://kurbetsoft.has.it
E-MAIL: | kurbetsoft@hotbox.ru
ICQ: | 287657904 (KS)

Новые версии программы можно скачать на http://kurbetsoft.has.it


NetLook v1.4 about

KurbetSoft
NetLook 1.4

http://kurbetsoft.has.it
mailto:kurbetsoft@hotbox.ru