Информация о программе Proxy Checker

Программа предназначена для проверки proxy-серверов на работоспособность. Интерфейс достаточно прост и краток - программа предназначена для проверки списков прокси в "командном" режиме - запустил и пошел пить чай :-)

Преимущества по сравнению с аналогами:

  1. Proxy Checker позволяет извлечь список прокси серверов из различных файлов. При этом исходный файл может содержать не только proxy, но и другую информацию, например комментарии (в этом Proxy Checker подобен программе Proxy List Filter, однако является несколько упрощенным - Proxy List Filter может извлечь больше proxy);
  2. Позволяет работать как с текстовыми, так и с HTML файлами, извлекая из них списки proxy-серверов. Тип файла определяется по его расширению;
  3. Поскольку для проверки прокси используются средства Internet Explorer (точнее, библиотека WinInet), программа является достаточно простой (следовательно, более надежной) и гибкой - Proxy Checker может поддерживать проверку HTTP proxy серверов на:
    1. поддержку FTP или Gopher протоколов - достаточно указать соответствующий URL (и нужную подстроку для поиска);
    2. возможность построения цепочки из proxy (имеется в виду поддержка HTTP + SSL => HTTPS протокола);
  4. имеет такую функцию как "количество попыток подключения к прокси" - это может быть актуально для модемных соединений (и медленных proxy);
  5. проверка является многопоточной, т.е. одновременно может проверяться несколько прокси-серверов;
  6. умеет проверять proxy-сервера на анонимность, причем даже при работе из-за FireWall (при этом нужно указать IP адрес Firewall);
  7. поскольку Proxy Checker построен на IE, то гарантируется, что с proxy-серверами, прошедшими проверку, будет работать Ваш браузер (IE или аналогичный - NN, Opera, etc.).

Дополнительные возможности программы:

  1. Proxy Checker (как и почти любую другую программу) можно настроить на проверку proxy серверов через SOCKS Firewall: для этого необходимо использовать программу SOCKS-ификатор, например SocksCap (www.sockscap.com). Сам по себе Proxy Checker не может работать с Socks proxy, однако используя SOCKS-ификатор, Вы можете проверять proxy через Ваш Firewall. Подробнее об этом см. FAQ о программе.

Недостатки по сравнению с аналогами:

  1. не умеет проверять SOCKS прокси
  2. не отображаются "хорошие" proxy прямо в ходе проверки программ

Подробная информация о программе Proxy Checker

Proxy Checker может брать списки proxy серверов из файлов различных форматов. При этом она понимает как текстовые, так и HTML файлы.

Пример:

Исходный файл может быть таким:

proxy1.com::8080 15 мар. 2001 г. (22:47) 100% (47 из 47) ---
proxy2.com:80 15 мар. 2001 г. (10:58) 100% (32 из 32) Тайланд
proxy2.com 3128 15 мар. 2001 г. (10:55) 100% (32 из 32) Бельгия
proxy3.com.co.jp 8080 15 мар. 2001 г. (10:54) 100% (32 из 32) Япония
4 proxy4.com 3128 1995 101-02-01
5 proxy5.com.ru 3128 23162 100-12-09
6 proxy7.com 80 9892 100-12-03
proxy8.com:81
38 stat proxy9.ru 3128 2144 101-01-31

Или таким:

NN | имя сервера и порт | состояние | дата проверки
1 | proxy1.ru:80 | проверить | 2002-01-31
2 | proxy22.us:3128 | проверить | 2002-02-30

Или таким:

NN | status | имя сервера | порт
1 | stat | proxy15.ru | 80
2 | stat | proxy2.us | 3128

Из этих списков будут извлечены прокси сервера, проверены на работоспособность и в результате мы получим файл такого вида:

proxy2.com:80
proxy3.com.co.jp:8080
proxy5.com.ru:3128
proxy9.ru:3128
proxy2.us:3128


Настройка программы Proxy Checker

Работа с программой Proxy Checker

Как пользоваться программой

Главное окно программы ("Main")

1 - здесь необходимо указать файл со списком proxy серверов для проверки (source file). В качестве исходного файла может быть как текстовый файл (.txt), так и HTML файл (.htm, .html, ...). Web-страницу надо сохранить на жестком диске в виде HTML файла. Вы можете вписать сюда имя файла, или же воспользоваться кнопкой 3 и выбрать нужный файл в диалоговом окне.

2 - здесь необходимо указать файл, куда будут сохраняться рабочие proxy (destination file). Это будет текстовый файл. Вы можете вписать нужное имя файла, либо нажав кнопку 4, указать файл в диалоговом окне. Если файл существует, он будет перезаписан.

5 - Здесь отображается число уже проверенных (не рабочих, а именно проверенных прокси) и проверяемых в данный момент прокси серверов. То есть это число уже протестированных proxy + число proxy серверов, находящихся в процессе тестирования.

6 - Здесь отображается число рабочих (именно тех, 100% рабочих) proxy, которые успешно прошли проверку по заданным Вами критериям (критерии задаются во вкладке Options).

7 - для начала работы программы (когда задали source file и destination file) нажмите эту кнопку. После запуска эта кнопка из "Run" превращается в "Stop", и с ее помощью Вы можете остановить работу программы.

8 - Здесь отображается состояние программы: "Ready to work" - программа готова к работе, "Working..." - программа проверяет прокси сервера; "Please wait..." - идет завершение работы программы (после нажатия кнопки "Stop").

Для того, чтобы проверить список proxy серверов, сделайте следующее:

  1. Скачайте из Internet или возьмите где-либо еще список proxy серверов. Подробнее о том, что такое список proxy и где его взять, написано здесь.
  2. После того, как Вы получили список прокси-серверов, запустите программу Proxy Checker, и укажите ей в качестве исходного файла (source file) полученный Вами файл.
  3. В качестве файла-приемника (destination file) укажите какое-либо другое имя файла, которого не существует (если файл уже существует, он будет перезаписан).
  4. При необходимости во вкладке Options Вы можете задать нужные настройки. Как правило, пользуются настройкой (включают флажок) "check for anonymous proxy" (проверка proxy на анонимность) и нередко задают Timeout - время ожидания ответа от прокси-сервера.
  5. Нажмите кнопку "Run".

После того, как программа закончит свою работу, в файле-приемнике будет находится список рабочих прокси-серверов, в стандартном виде.

Настройка программы

Принцип работы этой программы (как и любого proxy-checker-а) прост. Программа обращается по конкретному адресу (URL) и скачивает оттуда файл (при скачивании используется прокси-сервер из списка). После этого проверяется, является ли скаченный файл тем, что расположено по этому адресе - в полученном файле ищется уникальная строка символов (букв, цифр). Если эта строка найдена - значит скачан "тот" файл, и следовательно proxy - рабочий. Если нет - значит либо это не прокси, либо этот сервер сейчас не работает (не удалось подключиться), либо Вы задали не ту строку для проверки.

Окно настроек программы ("Options")

Настройки программы представлены во вкладке "Options". Они означают:

1 - "Connect to" - это тот URL, с которого будет производиться скачивание файла. Если в URL задан префикс http:// - значит будут проверяться HTTP прокси. Если же указать ftp:// адрес - то прокси проверяется на поддержку FTP протокола (сам прокси - HTTP). Можно также указать URL c https:// префиксом - тогда HTTP proxy будет проверяться на поддержку SSL (для возможности включения в цепочку прокси).

2 - "Control string" - какую строку искать в скачанном файле. Регистр игнорируется. Это должна быть какая-то уникальная строка символов. Не рекомендуется задавать в качестве такой строки следующие варианты: "404", "file", "not found", и т.п., а также (!) не задавайте в качестве такой строки имя или фрагмент путь из URL. В случае если это не прокси, а обычный сервер, он может вернуть ответ типа: "404 file not found. http://your.url.com/yours/path not exists". Поэтому например на сайте http://www.borland.com/ лучше искать не Borland, а например строчку Delphi - тогда в случае если это не прокси, слово Delphi может встретиться разве что у "прокси" www.borland.com с портом номер 80.

3 - "User Agent" - это та строка, которая передается серверу для идентификации, кто запрашивает файл. Спокойно можете оставить как есть.

4 - "Number of retries" - количество попыток подключения к proxy-серверу. Это актуально для медленных соединений и/или медленных proxy-серверов. Если указан слишком маленький тайм-аут (или запущено параллельно очень много потоков), то бывает что с первого раза не удается подключиться к proxy-серверу. И в других программах он считается нерабочим. Здесь же программа может сделать несколько попыток подключения, чтобы убедиться, что связи с прокси действительно нет.

5 - "Your IP" - это строка (Ваш IP-адрес), которой НЕ должно быть в скачанном файле, если proxy-сервер анонимный. Обращаю внимание: если Вы укажете здесь чужой IP-адрес, то все proxy-серверы будут считаться анонимными (при включенной проверке анонимности proxy). Если же Вы работаете из-за FireWall, то вам как раз НЕОБХОДИМО указать не свой IP (который Proxy Checker определит самостоятельно), а IP Вашего FireWall. На самом деле здесь можно указывать не IP-адрес, а произвольную строку, которой не должно быть в документе. Например - "proxy detected" или что-то в этом роде. Разумеется, при этом Вам необходимо поставить соответствующий URL в поле "Connect to".

6 - "Check for anonymous proxy" - проверка proxy-серверов на анонимность. На некоторых сайтах Вы можете увидеть информацию, которую предоставляет Ваш браузер - откуда Вы пришли, какая у Вас операционная система, какой Ваш IP-адрес, и т.д. Анонимные proxy-серверы подменяют часть этой информации (или всю), и подставляют вместо Вашего IP свой. Поэтому если в документе есть Ваш IP, то это не анонимный proxy, а если нет - то анонимный.

7 - "Timeout (sec)" - это тайм-аут (в секундах). Это очень важный параметр. Он показывает, сколько времени ждать ответа от прокси-сервера. Это время можно задавать самым разным, все зависит от Вашего соединения с интернетом, и какие прокси Вам нужны. Когда мне нужны прокси побыстрее - я ставлю 1-10 секунд, когда хочу найти побольше прокси - ставлю 30-60 секунд.

8 - "Max. Threads" - это количество потоков, запускаемых для проверки прокси. Показывает (грубо говоря) сколько прокси проверяется одновременно. Чем больше это значение - тем быстрее проверится список. Но если стоит много потоков и маленький Timeout - Вы можете пропустить рабочий прокси: просто ответ (запрошенный файл) не успеет дойти по каналам связи.

9 - "Sort and remove duplicates" - результирующий список (рабочих proxy-серверов) будет отсортирован по алфавиту и из него будут убраны все дублирующиеся прокси сероверы.

10 - "Anti forced caching" - Возможно в Вашей организации установлено принудительное кеширование (что это такое см FAQ). В этом случае Вы можете воспользоваться этой опцией для того, чтобы "обойти" это кеширование и проверять прокси-сервера на работоспособность. Подробнее об этом - см. FAQ.

11 - Run - нажатие этой кнопки начинает работу программы - проверку прокси-серверов


Где скачать Proxy Checker

Где можно скачать Proxy Checker

Последнюю версию программы можно скачать с сайта www.freeproxy.ru или mikhed.narod.ru/ или http://mikhed.newmail.ru/. На этом сайте можно также получить информацию о преимуществах профессиональной версии, узнать цены, а также получить другую дополнительную информацию.

Преимущества профессиональной версии Proxy Checker:

Бесплатная версия программы является упрощенной. Если у Вас есть желание, Вы можете приобрести профессиональную версию программы Proxy Checker. Ее возможности:

  1. может одновременно обрабатывать неограниченное количество proxy-серверов (бесплатная версия - до 10);
  2. количество попыток подключения к прокси-серверам не ограничено (в бесплатной версии - не более 2-х попыток);
  3. производит регулярное сохранение результатов работы (бесплатная версия все проверенные proxy держит в RAM до конца проверки);
  4. Профессиональная версия может проверять списки proxy любой длины (использована технология подкачки: прокси сервера читаются из файла (и сохраняются в файл) блоками, по мере необходимости) Бесплатная же версия может проверять неограниченное число proxy, но сохранить может не более 5000 рабочих proxy серверов в списке;
  5. содержит INI файл, в котором находятся настройки программы по умолчанию. Вы можете изменять этот файл - и при всех последующих запусках программа будет сразу же использовать нужные Вам настройки для своей работы.


Контактная информация

Связаться со мной можно, обратившись на сайт: www.freeproxy.ru или mikhed.narod.ru или mikhed.newmail.ru в раздел "Контакты", либо написав сообщение по адресу: mikhed@newmail.ru


Что такое список прокси и где его взять?

Получить подробную информацию о том, что такое proxy сервер, как он работает, где взять списки бесплатных proxy серверов и т.п. Вы можете, обратившись на мой web-сайт по одному из следующих адресов: www.freeproxy.ru или mikhed.narod.ru или mikhed.newmail.ru.

На данных сайтах представлена подробная информация (в разделе "Бесплатные proxy" => "proxy FAQ") о прокси-серверах, имеются списки бесплатных прокси серверов и многое другое.

В качестве примера к программе прилагается файл proxylist.txt, который Вы можете использовать в качестве исходного файла (source file) для проверки программой Proxy Checker.


FAQ по программе Proxy Checker

В чем состоят преимущества / отличительные особенности программы по сравнению с аналогами?

О преимуществах и особенностях программы Proxy Checker Вы можете узнать в справке в разделе "О программе".

Программа выдает сообщения об ошибке:

Source file does not specified! - не указан файл со списком proxy-серверов. Задайте программе этот файл, чтобы она знала откуда брать proxy.

Source and destination files should be different! - файл-источник и файл-приемник не должны совпадать. Укажите в качестве файла-приемника (куда будут записаны хорошие proxy) какое-нибудь другое имя файла.

Error: You are not connected to the Intenet! - в данный момент времени Вы не подключены к Internet. Подключитесь и запустите программу заново. Если в данный момент Вы подключены к Internet, а программа выдает это сообщение - напишите об этом мне.

Invalid options: can't connect to the URL. Try to use other URL - неправильные (или устаревшие) настройки во вкладке Options. В данном случае в поле "Connect to" указан неправильный адрес: программа не может подключиться к серверу (это необходимо для проверки прокси). Скачайте новую версию программы или укажите другой URL (выберите из списка или впишите свой - во втором случае Вам нужно также указать подстроку для поиска в поле "Control string")

Invalid options: can't find control string in specified URL. Try to use other URL - неправильные (или устаревшие) настройки во вкладке Options. В данном случае в поле "Control string" указана неправильная строка для поиска: програма не может найти эту строку по адресу, указанному в поле "Connect to". (это необходимо для проверки прокси). Скачайте новую версию программы или укажите другую строку (задайте другой URL - выберите из списка (программа впишет строку для поиска сама) или впишите свой URL - во втором случае Вам нужно также указать подстроку для поиска в поле "Control string")

Invalid options: can't check for anonymity. Try to use other URL - неправильные (или устаревшие) настройки во вкладке Options. По данному адресу (в поле "Connect to") должна располагаться динамическая web-страница, которая показывает Ваш IP адрес. Программа пробует подключиться напрямую (без прокси), чтобы убедиться что проверка на анонимность работает. В данном случае адрес в поле "Connect to" уже не может использоваться для проверки анонимности (на этой web странице нет Вашего IP, даже если подключаться без proxy). Скачайте новую версию программы или укажите другой URL (выберите из списка (программа впишет строку для поиска сама) или впишите свой URL - во втором случае Вам нужно также самому указать подстроку для поиска в поле "Control string").
Такое сообщение будет также появляться, если у Вас используется Firewall - тогда см. ответ на вопрос "Как проверять proxy на анонимность из-за Firewall?".

Source file hasn't proxies to check! - программа не смогла найти прокси-серверы в указанном Вами файле. Убедитесь что это текстовый или HTML файл (а не архив например). Если прокси в этом файле точно есть, пришлите этот файл мне - постараюсь в новых версиях улучшить программу.

Can't sort and remove duplicates! - файл со списком proxy слишком большой (> 10 Mb), и программа не может отсортировать его. В этом случае для сортировки файла воспользуйтесь другими средствами.

Free version cannot send proxylist to me. A maximum size of good proxylist is 50 proxies. - бесплатная версия программы отсылает мне проверенный список proxy-серверов (это "плата" за использование программы). Если она не может этого сделать, то программа может сохранить в списке рабочих прокси не более 50 proxy-серверов.

Может ли программа проверять SOCKS proxy?

Нет, программа не умеет проверять SOCKS proxy и пока что не планируется делать эту возможность. Проверить Socks proxy Вы можете, используя Remote Proxy Checker, ссылка на который есть на моем сайте.

Может ли программа проверять proxy на включение в цепочку и как это делать?

Да, Proxy Checker может проверять HTTP proxy на возможность включения в цепочку. По вопросу "как" поясню что такое возможность включения прокси в цепочку: это означает, что proxy сервер должен иметь дополнительный механизм, называемый SSL (Secure Sockets Layer). Вообще говоря, этот механизм предназначен не для работы proxy в цепочке, а для создания защищенных (secure) соединений - при передаче номеров кредитных карт, конфиденциальных сообщений и т.д. Поддержка этого механизма proxy сервером позволяет Вам безопасно совершать покупки в Internet за счет того, что образуется так называемый "виртуальный туннель", через который могут идти данные любого рода - как web-странички, так и любая другая информация. Этот туннель может проходить через множество (цепочку) серверов, достигая в результате конечного web-узла.
Так вот, поскольку этот механизм позволяет пропускать данные через виртуальный туннель, такой способ работы называется "туннелированием запросов". Запросы шифруются и передаются от сервера к серверу по цепочке.
Для того чтобы узнать, можно ли данный HTTP proxy сервер включить в цепочку, достаточно проверить, поддерживает ли он механизм HTTP + SSL => HTTPS протокол. Проверить это очень просто - достаточно настроить Ваш браузер на работу через прокси, и обратиться к любому https:// адресу. Proxy Checker использует именно этот механизм - чтобы проверить прокси на возможность включения в цепочку, выберите во вкладке "Options" в поле "Connect to" адрес с префиксом https://. При этом прокси сервера будут проверяться на поддержку HTTPS протокола и (что то же самое) - на возможность включения в цепочку.

Может ли Proxy Checker проверять прокси на работу с FTP?

Да, конечно. Ответ полностью аналогичен предыдущему - достаточно выбрать в поле "Connect to" (вкладка "Options") адрес с префиксом ftp:// , и прокси сервера будут проверяться на поддержку FTP протокола.
Обратите внимание: Proxy Checker не может проверять на работоспособность FTP proxy. Он может проверять только HTTP proxy на поддержку FTP протокола!

У меня корпоративный Firewall - сможет ли Proxy Checker работать?

Да, Proxy Checker сможет работать из-за Firewall - но только в том случае, если Вы можете в Вашем браузере использовать бесплатные proxy серверы. То есть это должен быть либо аппаратный Firewall, либо что-то вроде MS Proxy Firewall + MS Proxy Client - то есть все данные, идущие в Internet, автоматически проходят через этот firewall (безо всяких настроек браузера).
Коротко: если Вы можете настроить Ваш браузер на работу с бесплатными proxy серверами и у Вас это работает (только сам браузер, без различных "примочек"), то и Proxy Checker сможет работать!

А если у меня корпоративный proxy?

Если в Вашей организации используется корпоративный proxy сервер (а не Firewall), то Proxy Checker (сам по себе, без дополнительных средств) не сможет у Вас работать!
Для работы через корпоративный прокси предназначена программа Remote Proxy Checker..

Как проверять proxy на анонимность из-за Firewall?

Если у Вас есть корпоративный Firewall, то Вы уже наверное заметили: Proxy Checker может проверять proxy серверы на работоспособность, а вот на анонимность не получается! Он говорит что proxy анонимный, а обратившись на любой сайт проверки анонимности, Вы видите, что это не так. Что делать?
Дело в том, что если у Вас используется Firewall, то весь трафик (все данные, передаваемые между Вами и Internet) идут через него. Firewall принимает запрос от Вас и передает этот запрос в Internet уже от своего имени. Чтобы проверять proxy на анонимность, Вам нужно указать в настройках программы IP адрес не Вашего компьютера (который определил Proxy Checker), а IP Вашего Firewall. Тогда с проверкой анонимности все будет в порядке.
Как узнать IP адрес Firewall? Простейший способ - спросить у системного администратора :) Другой способ - отключить у себя прокси и зайти на любой сайт проверки на анонимность. После чего сравните IP адрес на web странице (рядом с REMOTE_ADDR, Your IP, и т.п.) и в Proxy Checker-е (поле "Your IP" во вкладке "Options"). Если они различаются - значит на web странице показывается IP Firewall. Просто впишите в поле "Your IP" IP адрес Вашего Firewall.

У нас в организации есть корпоративный proxy, который поддерживает SOCKS протокол. Можно ли что-то сделать?

Для работы через корпоративный прокси предназначена программа Remote Proxy Checker..
Вы также сможете использовать Proxy Checker из-за SOCKS proxy, хотя это сложнее. Для этого Вам понадобится программа SocksCap (http://www.sockscap.com/reference/sockscap.html). Она может "соксифицировать" любую программу работающую с Internet - то есть заставить эту программу работать через SOCKS proxy. Достаточно настроить SocksCap и запустить из-под нее Proxy Checker - и Вы сможете работать из-за корпоративного SOCKS proxy.

Мне нужно работать из-за корпоративного proxy сервера, но он не поддерживает SOCKS (только HTTP). Можно ли что-нибудь сделать?

Для работы через корпоративный прокси предназначена программа Remote Proxy Checker..
Если же Вы хотите использовать этот Proxy Checker, то прокси можно проверять, только если Ваш HTTP proxy поддерживает протокол HTTPS (HTTP + SSL) и его можно выстраивать в цепочку. В этом случае Вам понадобится уже 2 дополнительных программы: - SocksCap (http://www.sockscap.com/reference/sockscap.html) и программа, позволяющая пропускать SOCKS протокол через HTTP (HTTPS) proxy. Это может быть программа Socks2HTTP, SOCKSChain, SocksConnector или HTTPort - любая из перечисленных или какая-либо аналогичная. Информация о них есть на моем сайте.
Для того, чтобы работать, Вам нужно запустить любую из программ, пропускающих SOCKS через HTTP, и настроить ее на Ваш корпоративный proxy. При этом локальный порт (SOCKS) настройте например на 1080. После этого запускаете SocksCap и задаете ей в качестве SOCKS proxy локальный адрес: 127.0.0.1 и порт 1080 (как было настроено в тех программах). После этого Вам нужно проверить работу этой цепочки на примере любой программы (например браузера) - запустить браузер из-под SocksCap. Если все работает, то Вы можете запускать Proxy Checker, и проверять (и использовать!) бесплатные proxy серверы.

А у меня только HTTP proxy: он не поддерживает SOCKS и HTTPS. Что делать?

Для работы через корпоративный прокси предназначена программа Remote Proxy Checker.

Что такое принудительное кеширование (forced caching)?

Представьте себе ситуацию: Proxy Checker проверяет прокси и выдает, что он рабочий. Вы устанавливаете прокси в браузере, заходите на какой-то сайт - прокси не работает. Симптомы:

  • Вы зачастую на своем компьютере не можете увидеть свежие версии web-страниц, хотя и знаете, что они обновились
  • проверяемый (и нерабочий) прокси-сервер имеет порт 80

В этом случае вполне возможно, что в Вашей организации (Вашей сети) установлено так называемое "принудительное кеширование" (forced caching). Что это значит? Это значит, что любая веб-страница, считанная 1 раз, помещается в кеш. И при следующих обращениях (скажем в течение дня) она будет в следующий раз браться уже из кеша, а не с web сайта.

Чем это хорошо: Уменьшается объем скачиваемой из интернета информации (иногда - значительно уменьшается), что означает экономию времени и денег для организации.

Чем это плохо: если веб страница обновляется (к примеру) каждые 5 минут, то Вы сможете увидеть только 1-й вариант. А потом - ждите, пока страница не будет удалена из кеша.

Что значит "anti forced caching"? Это довольно просто. В чем состоит кеширование? При каждом обращении в Internet система кеширования проверяет, скачивался ли файл (web страница) с такого-то URL. Если нет, то она берется из Internet. А если нет, то она считывается из кеша. Чтобы web страницы всегда брались из интернет, к URL, указанному в настройках Proxy Checker, добавляется уникальная строчка:
http://www.server.com/url?xxxxxxxxxx
где xxxxxxxxxx - уникальное число. При этом все равно скачивается та же самая страница, а вот "система кеширования" видит, что это другой URL - и снова лезет в Internet (что нам и надо - мы ведь прокси проверяем).

У меня программа не работает...

Что значит "не работает"? Не запускается? Или не проверяет прокси-сервера? В первом случае напишите мне письмо с подробной информацией, что и как Вы делаете. А во втором - возможно устарел (и перестал работать) URL для проверки proxy. Есть два пути:

  1. скачать последнюю версию Proxy Checker
  2. Взять другой URL, по которому будут проверяться proxy (во вкладке "Options" в поле "Connect to" выберите другой URL из выпадающего списка и все должно заработать).