Введение

Прокси-сервер Usergate – полнофункциональное решение, позволяющее администратору организовать работу пользователей локальной сети в Интернет. Позволяет централизованно управлять Интернет-подключениями с помощью гибкой системы правил, осуществляет кэширование сетевых ресурсов, ведет точный подсчет трафика с помощью драйвера NAT, имеет встроенную биллинговую систему, а также систему статистики. Программа проста в настройке и удобна в использовании.

С помощью гибкой системы правил администратор сети может блокировать доступ пользователей к определенным ресурсам, регулировать скорость соединения, задавать расписание работы различных пользователей. Программа предоставляет возможность детального мониторинга активных Интернет-сессий пользователя в реальном времени, - IP адрес, имя пользователя, точное количество переданного и полученного трафика, а также посещенные URL.

Администратор может ознакомиться с текущим балансом пользователя, установить квоты на количество трафика, продолжительность пребывания в сети, а также на количество потраченных средств, по исчерпанию которых работа пользователя будет заблокирована, или переведена в ограниченный режим. В Usergate реализована биллинговая система, позволяющая гибко управлять тарифными планами. В состав Usergate входит модуль статистики, позволяющий составлять различные статистические отчеты.

В числе других особенностей программы - различные методы авторизации пользователей; фильтры URL, позволяющие запретить доступ к нежелательным ресурсам или настроить «баннерорезку»; назначение портов для переадресации трафика с одного порта на другой; публикация ресурсов (доступ к внутренним ресурсам сети из Интернет); кэширование HTTP ресурсов; автодозвон до провайдера; возможность удаленного администрирования.
UserGate имеет интуитивно понятный интерфейс, прост в настройке и использовании.

Программа поддерживает все известные TCP/UDP протоколы - HTTP, FTP, POP3, SMTP, IMAP4, Telnet, IRC, NNTP, ICQ и другие.

eSafeLine
www.usergate.ru
Новосибирск, 630090
ул. Терешковой 29а, офис 101ц
тел. (383) 330-29-13


Обзор функциональных возможностей прокси-сервера Usergate

Программа состоит из трех модулей – сервера, клиента администрирования, и клиента авторизации. Usergate сервер, непосредственно обеспечивающий работу, может быть запущен как приложение и как сервис. Usergate Administrator (клиент администрирования) предназначен для настройки сервера Usergate и может быть запущен как локально (на одной с сервером машине), так и удаленно.

В прокси - сервере Usergate реализованы следующие возможности:

· Кэширование загруженных из Интернет файлов в общей кэш-памяти;
· Подддержка нескольких типов авторизации пользователей, в том числе через авторизацию Windows и через авторизацию Active Directory;
· Автоматический дозвон по Dial-up соединению;
· Развитая система ограничений трафика для каждого пользователя или группы пользователей;
· Ограничения по времени работы, по количесту отправленного/принятого трафика за день/месяц или по количеству используемого времени за день/месяц;
· Почасовое расписание работы пользователей в сети Интернет;
· Списки запрешенных или разрешенных доменных имён, IP адресов, частей строки URL, доступ на которые запрещается/разрешается администратором.
· Индивидуальные ограничения скорости доступа. При превышении ограничений доступ в Интернет для пользователя автоматически закрывается;
· Фильтры, позволяющие настроить высокоэффективную «баннерорезку»;
· Фильтры, позволяющие запретить пользователям доступ к нежелательной информации;
· Возможность указания диапазонов предназначенных для пользователей IP-адресов;
· Подключение к каскаду прокси с возможность авторизации;
· Автоматическая рассылка пользователям информации об их трафике по E-mail, в том числе через серверы с SMTP авторизацией;
· Мониторинг трафика в режиме реального времени;
· Автоматический расчёт стоимости работы пользователя в сети Интернет, исходя из цены времени и/или объёма трафика. Существует возможность устанавливать тарифы для каждого пользователя отдельно либо для группы пользователей, возможность переключения тарифов в зависимости от времени суток, дня недели или от адресов сайтов;
· Подсчет и просмотр статистики работы пользователя по дням и по сайтам за произвольный интервал времени. Возможность просмотра статистики работы пользователя в текущем месяце через HTTP;
· Возможность экспорта статистики в MS Excel;
· Поддержка следующих протоколов: HTTP (кэширует), FTP(кэширует), Socks 4&5, любой протокол UDP/TCP через NAT (Network Address Translation) и через Port Mapping.


Особенности новой версии Usergate

Новая версия прокси-сервера Usergate содержит обновленный клиент администрирования Usergate и встроенный файервол.

Встроенный файервол позволяет предотвратить несанкционированный доступ к данным сервера и локальной сети, запретив соединения по определенным портам. Функциональность брандмауэра позволяет открыть доступ к необходимым портам, например, для того, чтобы опубликовать веб-сервер компании в сети Интернет.

Дополнительную безопасность Интернет шлюза и локальной сети обеспечивает встроенный в прокси-сервер Usergate антивирус Касперского. Антивирус ведет проверку HTTP - и FTP - трафика на наличие вредоносного кода в режиме реального времени.

Дизайн нового клиента администрирования Usergate разработан для более удобного отображения информации о настройках прокси-сервера. Настройка прокси-сервера поясняется на конкретных примерах, представленных в контекстной помощи и в руководстве пользователя.


История изменений

Что нового в версии 4.0 (14.12.2005):
· новый удобный клиент администрирования
· встроенный межсетевой экран
· обновленный клиент авторизации

Что нового в версии 3.1.3.1388 (03.10.2005) :
· исправлен баг - ФТП подвисало соединение при http-авторизации
· исправлен баг - не работает каскадный прокси в случае задания адреса в виде доменного имени
· исправлен баг - падение сервера при попытке его отключения
· реализована авторизация на каскадном socks5 прокси
· реализован порт маппинг для udp протокола

Что нового в версии 3.1.2.1318 (30.09.2005) :
· исправлен баг, связанные с невозможностью пополнить баланс пользователю
· исправлен баг, связанный с невозможность получить список пользователей в "Статистике"
· исправлена неработоспособность SOCKS при заданных интерфейсах

Что нового в версии 3.1.2.1304 (26.09.2005) :
· исправлена ошибка, приводящая к невозможности вставить строку в базу данных в некоторых случаях
· исправлена ошибка, приводящая к падению сервера при запущенном Администратора
· добавлена возможность добавлять отрицательные суммы на баланс пользователю
· исправлен сдвиг часов в отчете "Статистики"

Что нового в версии 3.1.2.1297 (23.09.2005) :
· исправлены ошибки веб-статистики, отображаемой пользователю
· увеличена производительность протокола http - добавлена возможность использовать соединение повторно для клиентской части
· исправлена ошибка - http соединения "подвисают"
· реализован кэш dns-запросов, положительно сказывающийся на скорости работы в первую очередь http
· реализован кэш таблицы ресурсов базы данных, положительно сказывающийся на скорости работы в первую очередь http
· исправлены ошибки в реализации http (post-запросы с большим количеством данных, передаваемых на сервер)
· исправлены ошибки в работе ftp-proxy
· добавлено условие "максимальный размер файла"
· добавлено условие "тип протокола" - теперь UserGate стал гораздо гибче в настройке. по умолчанию правило действует на все протоколы
· добавлена опция "тип логики" для правил - теперь можно объединять условия по "и"/"или" в случае "и" правило сработает только при выполнении всех условий, "или" - как обычно, любого из условий
· исправлена ошибка - преждевременное отключение пользователя при недостигнутом еще лимите трафика
· исправлена ошибка, проявляющаяся при активной сессии пользователя и одновременном редактировании суммы лицевого счета этого пользователя
· увеличено быстродействие при проверке файлов антивирусом
· реализовано лечение файлов при проверке антивирусом
· драйвер NAT - повышена стабильность работы
· реализован прозрачный ftp-proxy через NAT (только пассивный режим)
· изменена структура базы данных с целью более точного подсчета трафика и отсутствия расхождения показаний между "Администратором" и "Статистикой". конвертация пройдет автоматически при установке программы - баланс пользователей сохранится, однако, уже наработанная статистика обнулится


Лицензия

Перед использованием этого ПО внимательно ознакомьтесь с Договором передачи авторских прав на использование программ для компьютера (Лицензионный договор). Использование программы рассматривается как Ваше полное согласие с условиями Лицензионного договора.
Если Вы не согласны с каким-либо из условий Лицензионного договора, то вы должны прекратить использовать это ПО.

ДОГОВОР О ПЕРЕДАЧЕ АВТОРСКИХ ПРАВ НА ИСПОЛЬЗОВАНИЕ ПРОГРАММ ДЛЯ КОМПЬЮТЕРА (ЛИЦЕНЗИОННЫЙ ДОГОВОР)

Настоящий Лицензионный договор является юридическим соглашением между Вами, конечным пользователем (физическим или юридическим лицом), и компанией «еСэйфЛайн».
Программное обеспечение (ПО) - это комплекс программ для компьютера и документации, который является объектом авторского права и охраняется законом. Везде в тексте под словом «документация» подразумеваются файлы с информацией. Документация является неотъемлемой частью ПО.

1. Предмет договора
Предметом настоящего Лицензионного договора является передача Правообладателем Конечному Пользователю неисключительного авторского права на использование ПО (Лицензии).
Все условия, оговоренные далее, относятся как к ПО в целом, так и ко всем его компонентам в отдельности.

2. Имущественные права
Имущественные права на данное ПО принадлежат компании «еСэйфЛайн».
Вам, Конечному Пользователю, предоставляется Лицензия на использование ПО в любых целях, при соблюдении нижеследующих условий.

3. Условия использования
Вы имеете право:
- использовать незарегистрированное ПО без каких либо ограничений, кроме ограничений функциональности незарегистрированного ПО
- использовать зарегистрированное ПО только персонально
Вы не имеете право:
- распространять выданную Вам регистрационную информацию
- вносить изменения в дистрибутив ПО, программу или документацию

4. Срок действия договора
Данный Лицензионный договор вступает в силу с начала использования ПО и действует на протяжении всего периода использования.
В случае несогласия, нарушения или неспособности далее выполнять Вами условия Лицензионного договора, Вы обязаны уничтожить все копии ПО, и договор прекращает свое действие.

5. Ответственность
Нелегальное использование, распространение и воспроизведение (копирование) ПО является нарушением Закона Российской Федерации «О правовой охране программ для электронных вычислительных машин и баз данных» и преследуется по Закону.
При нарушении настоящего Лицензионного договора компания «ЕСэйфЛайн» лишает Конечного Пользователя Права на использование ПО.

6. Гарантии
Компания " ЕСэйфЛайн" не гарантирует, что ПО не содержит ошибок и не несет никакой ответственности за прямые или косвенные последствия применения ПО, в том числе возникшие из-за возможных ошибок или опечаток в комплекте ПО.

eSafeLine, 2005
http://www.usergate.ru

КОНТАКТЫ
Отдел продаж: sales@usergate.ru
Отдел тех.поддержки: support@usergate.ru
http://www.usergate.ru
Телефон: +7 (383) 330-29-13
Факс: +7 (383) 333-99-08
Адрес: 630090, Новосибирск,
ул. Терешковой 29а, офис 101
Почтовый адрес
630090, Новосибирск, а/я 735

КАК ПОЛУЧИТЬ ПОЛНУЮ ВЕРСИЮ
Программа UserGate свободно распространяется только в виде демо-версии, ограниченной по сроку дейсвтия. Для того, чтобы получить полную версию программы, свяжитесь с отделом продаж по адресу sales@usergate.ru либо выпишите счет на сайте самостоятельно. После оплаты Вам будет выдан адрес, по которому можно скачать полную версию и регистрационные ключи, либо отправлен по почте компакт-диск с программой.


Системные требования

Usergate прокси сервер с поддержкой NAT (Network Address Translation) работает на операционных системах Windows 2000/2003/XP с установленным протоколом TCP/IP. Без поддержки протокола NAT Usergate способен работать на Windows95/98 и Windows NT 4.0.

Требования к аппаратному обеспечению: выделенный или слабо загруженный компьютер с минимальной конфигурацией Pentium II 400MHz, 64 RAM, 10 MB на жестком диске + место на диске для кэш и лог-файлов.


Мастер установки Usergate

Для инсталляции программы, запустите программу установки Usergate. Внимательно прочитайте лицензионное соглашение, и если вы согласны, нажмите «Согласен» для продолжения установки, следуйте инструкциям программы установки.

Программа установки произведет автоматическую установку необходимых компонент прокси-сервера Usergate.

Выборочная установка предназначена для опытных пользователей. При установке в данном режиме вам будет предложен списко компонент прокси-сервера Usergate. Двойным нажатие левой клавиши мыши можно выделить необходымый для установки компонент.


Клиент администрирования Usergate

Для удобства использования и администрирования функциональные возможности Usergate реализованы в виде двух модулей – Usergate Server и Usergate Administrator. Серверный модуль запускается на компьютере, имеющем подключение к сети Интернет. Именно серверный модуль контролирует доступ пользователей в Интернет, осуществляет подсчет трафик, ведет статистику работы пользователей в Интернет и т.п.

Usergate Administrator – это средство управления сервером Usergate. С его помощью осуществляется настройка сервера Usergate, в соответствии с необходимыми требованиями.

Существует возможность запуска Usergate Server в качестве службы и как обычной программы, запускаемой вручную или автоматически. Для запуска вручную необходимо в контекстном меню Usergate Agent выбрать пункт Start Usergate Server. При этом в System Tray появится пиктограмма запущенного сервера [image].

Что бы запустить Usergate Server как сервис, необходимо добавить его в список сервисов. Для этого необходимо запустить меню Пуск - Программы - UserGate4 - Install Service. После этого можно запустить сервис Usergate, набрав в командной строке команду net start usergate. Что бы удалить Usergate из списка сервисов, необходимо запустить меню Пуск - Программы - UserGate4 - Uninstall Service.

Клиентская часть Usergate реализована в виде Usergate Authentication Client, который устанавливается на компьютер пользователя и необходим для авторизации пользователей на сервере Usergate, если Вы хотите использовать авторизацию отличную от IP или IP + MAC авторизаций.

Изменения, сделанные в программе Usergate Administrator вступают в силу после нажатия кнопки Apply.


Traffic policy

Пункт Traffic policy предназначен для создания правил, контролирующих доступ и ограничивающих доступ пользователей локальной сети в сеть Интернет, создания и изменения тарифов, используемых прокси – сервером Usergate для подсчета затрат на Интернет подключение, а также для отображения состояния счета пользователей.

Администратор Usergate может создавать правила, редактировать тарифы в соответствии с тарифными планами Интернет-провайдера, а также пополнять счет пользователей.

Rules

В основе политики управления пользовательским трафиком в прокси сервере Usergate лежит механизм правил. С помощью правил администратор Usergate может ограничить доступ пользователей локальной сети в сеть Интернет, закрыть доступ к определенным веб – ресурсам, установить график работы с сети, осуществлять динамическое переключение тарифов и вести подсчет трафика.

Правила предназначены для управления объектами трех типов: Connection, Traffic и Tariff. Для каждого из объектов предопределено соответствующее действие. Таким образом, имеются следующие пары объект-действие: Connection - Close, Traffic - Do not count, Tariff - Change To. Правило может быть применено либо ко всем протоколам, либо только к определенному протоколу.

Срабатывания правила регулируется заданными условиями. Условия могут быть объединены как по логическому AND, так и по логическому OR. По умолчанию условия, сформулированные на разных страницах диалога создания правила, объединяются по логическлму OR.

Созданное правило необходимо применить пользователю или группе пользователей.

Создание нового правила осуществляется через нажатие кнопки Add в Control Panel или через пункт Add New всплывающего окна.

Редактирование правила осуществляется через нажатие кнопки Edit в Control Panel или через двойной клик мыши на выделенном правиле.

Для удаления правила выделите его в списке правил и нажмите кнопку Delete в Control Panel.

Дополнительная информация: создание правил, создание тарифов

Billing plans

Прокси сервер Usergate обладает встроенной биллинговой системой, позволяющей осуществлять подсчет средств, затраченных на Интернет. В основе биллинговой системы лежит тариф.

На странице отображается тарифные планы, используемые прокси сервером Usergate. В таблице представлена стоимость входящего, исходящего и временного трафика.

Администратор Usergate может создавать новые тарифы, а также редактировать или удалять существующие тарифы.

Для создания нового тарифа нажмите кнопку Add в Control Panel, введите стоимость входящего, исходящего и временного трафика.

Редактирование тарифа осуществляется через двойное нажатие левой клавиши мыши или через нажатие клавиши Edit в Control Panel.

Удаление тарифа осуществляется через нажатие кнопки Delete или соответствующий пункт всплывающего меню.

Дополнительная информация: создание тарифов


Users & Groups

На странице отображаются пользователи и группы, использующие прокси-сервер Usergate. Администратор Usergate может добавлять новых пользователей, редактировать или удалять существующих пользователей. Если компьютер с установленным прокси - сервером Usergate, входит в домен Active Directory (AD), пользователи могут быть импортированы из AD.

Группы введены для удобства администрирования и облегчения управления политикой доступа в сеть Интернет.

Users

Пункт предназначен для создания, редактирования и удаления пользователей Usergate, а также просмотра списка правил примененных пользователю. Список правил выделенного пользователя представлен в нижней половине окна.

Для создания нового пользователя необходимо указать следующие параметры:
· Name – имя пользователя;
· E-mail – электронная почта пользователя (используется для рассылки статистики);
· Authentication type – тип авторизации пользователя (перечислены ниже);
· Speed limit – ограничение скорости соединения для данного пользователя, в Кб/сек, 0 – отсутствие ограничения.
· Tariff – тарифный план, применяемый по умолчанию ко всем соединениям данного пользователя. Можно указать любой тариф, имеющийся в системе, либо, тариф группы, в которую входит пользователь.
· Group – имя группы, в которую входит пользователь.
· Account disabled – опция, позволяющая отключить данного пользователя, не удаляя его из системы.
· Select rules applicable to this user – список правил, которые будут применяться для данного пользователя. Правила, применяемые для группы, в которую входит пользователь, всегда отмечены, и их нельзя отменить.
· Select NAT applicable to this user – список правил NAT, доступных для данного пользователя. Правила, применяемые для группы, в которую входит пользователь, всегда отмечены, и их нельзя отменить.
· Dialing disabled – опция, с помощью которой можно запретить пользователю работать в сети через Dial - up соединение.

Groups

Для упрощения управления политикой доступа пользователей к сети Интернет, пользователей можно объединять в группы. Каждый пользователь в системе может относиться только к одной группе. Для группы можно настроить список правил, таким образом, все пользователи, входящие в группу, получат одинаковые настройки. Можно добавлять новые, редактировать или удалять существующие группы.

Для создания группы, необходимо указать:
· Group name - имя группы.
· Billing plan – тариф, который будет использован по умолчанию для соединений пользователей, входящих в состав группы.
· Select rules for this group - список правил, примененных к группе (в том числе, правила NAT).

Указание тарифа для группы обязательно, если нет ни одного тарифа, добавить группу нельзя.

С помощью переключателя Disable group, группа может быть отключена без удаления из системы.
Опция Dialing disabled позволяет запретить группе пользователей использовать Dial-up соединение.


Network rules

В прокси сервере Usergate реализована поддержка технологии Network Address Translation (NAT, Трансляция сетевого адреса) и Port mapping (назначение портов). Данный пункт настроек позволяет создавать и редактировать правила NAT и Port mapping.

Переключатель Enable NAT позволяет включить/отключить поддержку технологии NAT в прокси сервере.

NAT

Страница предназначена для создания и редактирования правил NAT. Правила применяются в порядке, в котором они расположены в списке. Если существует более одного правило на один и тот же порт, то первым сработает правило, расположенное в списке выше другого. Изменение порядка служат кнопки Up и Down.

Для создания правила NAT необходимо нажать кнопку Add в Control Panel.

При создании правила NAT необходимо указать следующие параметры:
· Source interface – IP адрес сетевого интерфейса, смотрящего в локальную сеть.
· Destination interface – IP адрес сетевого интерфейса, смотрящего в Интернет (или имя Dial-up подключения).
· Port range – диапазон портов.
· Protocol – протокол (TCP/UDP).

Переключатель Disable rule позволяет отключить правило NAT без удаления его из системы.

После создания правила, его необходимо присвоить пользователю или группе пользователей.
В прокси сервере Usergate имеется список предопределенных правил (SMTP, POP3, IMAP4,Telnet, News), которые не могут быть удалены и по умолчанию отключены.

Port mapping

Данный раздел позволяет создавать, редактировать и удалять назначения портов, используемые прокси – сервером Usergate. Технология Port mapping позволяет привязать выбранный порт одного из локальных сетевых интерфейсов машины с Usergate к определенному порту удалённого хоста.

Для создания назначения портов необходимо нажать кнопку Add в Control Panel.
При создании назначения портов необходимо указать:
· Mapping name – название назначение портов
· Listen IP: port – IP адрес сетевого интерфейса на котором Usergate будет прослушивать клиентские запросы на заданном порту.
· Destination address: port – адрес хоста назначения и номер порта.
· IP protocol – тип протокола (TCP/UDP)

Назначения портов, используемые Usergate, доступны всем авторизованным пользователям. Поле Assigned mapped traffic to позволяет записать трафик, реализуемый через данное назначение портов на текущего авторизованного пользователя Usergate или на заданного пользователя (выбирается из списка).

Опция Disable позволяет отключить назначение портов, не удаляя его из системы.

Редактирование назначения портов осуществляется через кнопку Edit в Control Panel или через двойное нажатие левой клавиши мыши на выделенном назначении.

Удаление назначения портов осуществляется через нажатие кнопки Delete в Control Panel.


Firewall policies

Новая версия прокси- сервера Usergate поставляется вместе со встроенным файерволом. Файервол позволяет контролировать открывать и блокировать определенные порты, а также публиковать веб-ресурсы компании в сети Интернет.

Firewall

Страница предназначена для создания правил для файервола Usergate.

Создание нового правила файервола осуществляется через нажатие клавиши Add в Control Panel.

При создании правила необходимо указать:
· Rule name – название правила.
· Action – действие (Send/Drop, Пропустить/Заблокировать).
· Select protocols – тип протокола (TCP, UDP, TCP&UDP).
· Source IP – IP адрес источника запроса или диапазон IP источника.
· Destination IP – IP адрес назначения или диапазон IP назначения.

Созданные правила отображаются в верхней половине окна.

Автоматически сгенерированные правила представлены в нижнем списке и не могут быть редактированы.

Resource publishing

Здесь можно указать, к каким внутренним ресурсам компании, прокси-сервер Usergate будет предоставлять доступ из сети Интернет.

Для открытия доступа к ресурсу локальной сети нужно нажать кнопку Add в Control Panel. В появившемся диалоговом окне необходимо указать:
· Name - имя сетевого ресурса.
· Source interface - интерфейс приемника, в данном случае IP адрес сетевого интерфейса, для Интернет.
· Destination interface – интерфейс приемника, IP адрес интерфейса, смотрящего в локальную сеть.
· Destination IP – IP адрес ресурса в локальной сети.
· Port – номер порта
· Protocol – тип используемого протокола (TCP/UDP).
· User –пользователь, на имя которого будет записываться соответствующий трафик.

Если номер порта сервиса на компьютере назначения совпадает с номером порта, на какой принимаются соединения извне, то номер порта можно не указывать повторно. Достаточно установить галочку Port as source.

Указывая в качестве порта 0, можно перенаправить весь трафик (по всем портам протокола TCP или UDP) на определенный внутренний сервер.

Правила публикации применяются в порядке, в котором они расположены в списке. Если существует более чем одно правило на один и тот же порт на внешнем интерфейсе, то будет работать всегда правило, находящееся в списке выше. Для изменения порядка применения записей служат кнопки Up и Down.

Созданные правила публикации автоматически генерируют правила файервола, пропускающие трафик по соответствующим портам.

Дополнительная информация: публикация сетевого ресурса.


Services

Страница предназначена для настройки основных сервисов прокси-сервера Usergate: HTTP, FTP, SOCKS прокси, Cache, Scheduler и Dial-up соединения.

Proxy settings

Для каждого из прокси серверов указывается список интранет-интерфесов, т.е. сетевых интерфейсов, смотрящих в локальную сеть и номер порта, на котором работает соответствующий прокси. По умолчанию список интранет-интерфейсов пуст и прокси сервер прослушивает клиентские запросы на всех интерфейсах.

Для каждого из прокси серверов имеется возможность подключения к вышестоящему прокси серверу.

По умолчанию HTTP- прокси сервер Usergate работает на порту 8080. При каскадном включении HTTP- прокси имеется возможность авторизации на родительском HTTP- прокси.

SOCKS- прокси полезен для работы программ, поддерживающих работу через протокол Socks5, например ICQ, mIRC. Socks прокси работает на порту 1080 и по умолчанию отключен.

Настройки FTP- прокси практически ничем не отличаются от настроек HTTP и Socks- прокси, кроме номера порта.

В настройке FTP- клиентов необходимо включить пассивный режим при работе через FTP- прокси сервер

Cache

Основным преимуществом использования прокси сервера является кэширование сетевых ресурсов. Кэширование снижает нагрузку на Интернет соединение, экономят средства на Интернет. Данная страница предназначена для настройки параметров кэширования.

Переключатель Enable Cache включает кэширование. Выбирая соответствующие опции, можно осуществлять кэширование POST запросов, кэшировать динамические объекты, Cookies и FTP контент.

Переключатель Calculate traffic позволяет считать трафик из кэш.
К настраиваемым парамерам Cache относятся место хранения (по умолчанию кэш расположен в директории Cache, каталога Usergate), размер кэш памяти (по умолчанию – 100 Мб) и время жизни кэшированного документа. Время жизни (Time To Live- TTL) задается в процентах от возраста документа и в часах.

Dial on demand

При использовании Dial-up подключения имеется возможность автоматического запуска соединения при наличии клиентских запросов. Пункт настроек Dialing on demand предназначен для настройки автоматического дозвона до Интернет провайдера при наличии клиентских запросов.

Переключатель Enable dialing позволяет включить автодозвон.

Для настройки необходимо указать:
· Connection name - имя Dial-up соединения (соединение должно существовать в системе, используйте средства Windows для его создания), имя пользователя и пароль для подключения к провайдеру Интернет.
· User name – имя пользователя.
· Password – пароль, для подключения.

К другим настраиваемым параметрам относятся:
Redial attempts – количество попыток подключения.
Time between redial attempts - интервал между попытками подключения.
Idle time before hanging up - таймаут, по истечении которого, сервер разорвет соединение в случае отсутствия запросов в Интернет.

Опции: Redial if line is droped, Connect at start и Hang up at shut down позволяют повоторно инициировать соединение, при сброшенной линии, инициировать соединение при запуске Usergate, завершать соединение при остановке Usergate.

Последняя опция Only if program initiated connection позволяет завершать соединение, только если оно было инициировано Usergate.

Scheduler

Планировщик представляет собой удобный инструмент для запуска определенного набора преопределенных действий в указанное время. Возможны следующие варианты действий:
· Run program – запустить указанную программу.
· Send statistics – разослать пользовательскую статистику.
· Establish dial-up connection – установить Dial-up соединение.
· Drop dial-up connection – разорвать Dial-up соединение.
· Update antivirus bases – обновить антивирусные базы.

При создании задания указывается день недели или месяца, время и тип выполняемого действия.

При рассылке пользовательской статистики необходимо указать параметры SMTP сервера, используемого для отправки почтовых сообщений. Статистика рассылается пользователям, в профиле которых был указан E-mail.

Для создания нового задания необходимо нажать кнопку Add в Control Panel.

Редактирование существующего задания осуществляется через нажатие кнопки Edit в Control Panel или через двойное нажатие левой клавиши мыши на выделенном задании.

Удаление задание выполняется через нажатие клавиши Delete в Control Panel.


Antivirus

Встроенный в прокси-сервер Usergate антивирус Касперского позволяет проверять http- и ftp- трафик на наличие вредоносного кода в режиме реального времени.

Переключатель Enable antivirus check позволяет включить/отключить антивирусную проверку трафика.

Дополнительно можно указать директорию хранения временных файлов и место хранения антивирусных баз.

Опции позволяют включить/выключить проверку HTTP, FTP трафика, а также проверку архивов.

Кнопка URLs filter позволяет определить URLs, трафик с которых не будет подвергаться антивирусной проверке.


Administration settings

Пункт предназначен для настройки административного доступа к прокси – серверу Usergate.

Кнопка Port Settings позволяет определить номера TCP портов, используемых для подключения клиента администрирование Usergate к серверной части порт авторизации пользователей. По умолчанию для подключения клиента администрирования Usergate к серверной части используется порт 2345 TCP. Для клиентской авторизации используется порт 3456 TCP.

Кнопка Database Access позволяет определить логин и пароль для доступа к базе статистики пользователей Usergate (файл log.mdb). По умолчанию логин и пароль не заданы.

Кнопка Administrative access позволяет определить логин и пароль для подключения администратора Usergate к серверной части.

Если в TCP/IP свойствах сетевого соединения на клиентских машинах в качестве DNS указан внутренний сетевой интерфейс машины с Usergate, опция DNS Forward позволит перенаправить пользовательские DNS запросы на DNS сервер провайдера. IP адрес DNS провайдера вводится в соответствующем поле.

Опция Precision traffic count позволяет осуществлять подсчет трафика на сетевом уровне, т.е. с учетом всей служебной информации. Опция доступна, если установлен драйвер NAT.

Кнопка Check for updates позволяет проверить статус вашей версии Usergate. При наличии обновлений вам будет показано информационное окно с соответствующим сообщением.


Logs

На данной странице отображается процесс запуска клиента администрирование Usergate и подключения к серверной части Usergate. Кроме того, в разделе отражаются все изменения текущих настроек прокси сервера: создание, изменение или удаление пользователей, групп, правил и т.п.


Модуль статистики Usergate

Пользовательская статистика Usergate записывается в файл log.mdb, расположенный в директории Usergate. Файл содержит информацию о параметрах соединений всех пользователей: время соединения, длительность, затраченные средства, запрошенные адреса, количество полученной и переданной информации. Отменить запись информации о пользовательских соединениях в файл статистики нельзя.

Для корректной записи информации в базу статистики на вкладке «Системный DSN» в пунтке «Источники ODBC» панели «Администрирование» должен быть указан путь к файлу log.mdb

Запуск модуля статистики Usergate осуществляется через пункт Start Usergate Statistics контекстного меню агента в системном трее или через соответствующий пункт меню Пуск. Отображение информации осуществляется после нажатия кнопки [image] на панели инструментов.

Информация может быть отфильтрована по пользователям, протоколам и интервалу времении (фильтры включаются кнопкой [image] на панели инструментом).

В модуле статистики реализована возможность экспорта отсчета в Excel (кнопка [image] на панели инструментов).

Замечание: Производительность прокси-сервера Usergate зависит от размера базы статистики. Рекомендуется периодически проводить очищать базу статистики. Очистка выполняется стандартными средствами (кнопка Stat-del на панели инструментов). При очистке из базы статистики удаляются все записи старше указанной в диалоговом окне даты.


Настройка DNS

Пусть Usergate установлен на машину с внутренним сетевым адаптером с адресом 192.168.0.1.
Настроить DNS в прокси сервере Usergate можно двумя способами:

Настройка через DNS форвардинг

В пункте Proxy Settings дерева настроек Usergate включите режим DNS forwarding, в поле укажите IP адрес DNS сервера провайдера. Если адресов несоклько, укажите их черех точку с запятой.

На клиенстких машинах откройте свойства подключения, в TCP/IP свойствах в качестве шлюза и DNS укажите IP внутреннего сетевого интерфейса машины с Usergate.

Настройка через NAT

Выберите пункт NAT дерева настроек Usergate. С помощью кнопки Add в Control panel или через пункт Add New всплывающего меню запустите диалог создания правила NAT. Расставьте IP приемника (локальный интерфейс) и IP отправителя (внешний интерфейс). Порт- 53, протокол UDP. Примените созданное правило всем пользователям локальной сети.

В TCP/IP свойствах сетевого соединения на клиентских машах в качестве DNS укажите IP адрес DNS сервера провайдера, в качестве шлюза - IP адрес машины с Usergate.

При наличии внутреннего DNS сервера можно настроить DNS через NAT, применив правило NAT для 53 UDP порта для пользователя, с машины, являющейся DNS сервером. В свойствах TCP/IP клиентских машин, указывается внутренний DNS сервер.

Правильность настройки DNS можно проверить запустив в командной строке, например, nslookup smtp.mail.ru. Если DNS настроен правильно, в результате выполнения команды получите IP адрес.


Создание пользователей и групп

Настройку прокси-сервера Usergate целесообразно проводить в несколько этапов.

1. Создание групп и пользователей
2. Настройка DNS и машин локальной сети
3. Создание тарифов
4. Создание правил

Для создания пользователей запустите Usergate Administrator. Выберите пункт Users&Groups дерева настроек. В диалоге создания группы необходимо указать только название группы. После установки в системе имеется группа default и пустой тариф - default. При создании новой группы, тариф default присваивается ей автоматически, в качестве тарифа по умолчанию. Поэтому по умолчанию соединения всех пользователей входящих в группу не тарифицируются, если тариф не переопределен в прояиле пользователя.

Диалог создания группы приведен на рисунке.

Диалог создания пользователя приведен на рисунке.


Типы авторизации пользователей

Прокси – сервер Usergate поддерживает несколько типов авторизации пользователей (для некоторых из них на машинах пользователей необходим модуль клиентской авторизации):
· IP address – авторизация по IP адресу. Необходимо указать IP адрес машины, с которой будет работать данный пользователь.
· IP+MAC address – авторизация по комбинации IP и MAC адресов (MAC адрес карты определяется автоматически).
· IP+MAC (abonement) – авторизация по комбинации IP и MAC адресов. При создании пользователя администратор Usergate задает логин и пароль, которые пользователь должен ввести на странице регистрации (http://usergate/register.html).

Привязка к IP и MAC адресу осуществляется в момент регистрации. В дальнейшем авторизация пользователя в Usergate осуществляется автоматически.
· IP range – авторизация по диапазону IP адресов.
· HTTP –авторизация через имя и пароль, указываемыми при подключении к Интернет, выполняемая средствами браузера. При авторизации таким способом, пользователь не может пользоваться NAT и назначением портов.
· Active Directory – авторизация через AD. В профиле пользователя необходимо указать Login, совпадающий с User login name в домене AD. При авторизации, пользователь должен указать Login, имя домена AD и Password. Требуется установка клиента авторизации на рабочее место пользователя.
· AD Simplified – упрощенная авторизация через AD. В профиле пользователя указывается Login, совпадающий с Login для регистрации в AD и имя домена. Требуется установка модуля клиентской авторизации на рабочее место пользователя.
· Windows login – авторизация через Login, совпадающий с именем, под которым пользователь зарегистрирован в ОС на своем компьютере. Требуется установка модуля клиентской авторизации на рабочее место пользователя.
· Name and password – авторизация осуществляется через Login и Password, заданные администратором Usergate при создании пользователя. Login и Password вводятся в модуле клиентской авторизации, установленном на машине пользователя.


Клиент авторизации Usergate

Для других видов авторизации необходима установка модуля колиентской авторизации - Usergate Authentication Client. Для этого скопируйте Usergate Authentication Client на компьютеры пользователей.

Запуск Usergate Authentication Client выполняется через меню Пуск - Программы. ВАЖНО: Тип авторизации, выбранный в Usergate Authentication Client должен совпадать с типом, установленным в профиле пользователя в Usergate Administrator. Авторизация по имени и паролю пользователя:

В этом случае необходимо выбрать Local authorization, и указать имя пользователя и пароль через кнопку Set PWD. Пароль может быть сохранен в системном реестре, тогда при следующем запуске клиента авторизации его не нужно будет вводить.

Авторизация через Windows Login:

Необходимо выбрать Current logged user. Тогда Usergate Authentication Client передает серверу Usergate имя пользователя, зарегистрированного в ОС Windows. Предполагается, что пользователь успешно прошел авторизацию при входе в ОС Windows.

Авторизация через Active Directory:

Необходимо выбрать Active Directory и указать имя пользователя, имя домена Active Directory и пароль для регистрации в домене (SetPWD).


Настройка браузеров пользователей

При работе через кэширующий прокси в свойствах браузера необходимо включить режим использования прокси и указать соответствующие параметры. На рисунках приведены соотсветствующие настройки на примере Internet Explorer.

Пользователи локальной сети могут работать и сети Интернет без указания прокси в LAN настройках браузера. Для этого необходимо создать правило NAT для 80 TCP порта, перенаправляющее запросы с внутреннего сетевого интерфейса машины с Usergate на внешний интерфейс. Важно! Однако в данном случае отсутствует возможность кэширования сетевых ресурсов, а также возможность применения различных ограничений, например, правил доступа к определенным сайтам.


Настройка почты

Настройка почты в Usergate может быть реализована двумя способами: через Назначение портов (Port mapping) и через Трансляцию сетевого адреса (NAT).

Настройка через Port mapping

В данном варианте настройка почтовые клиенты подключаются к прокси-серверу Usergate, который, в свою очередь, перенаправляет клиентские запросы на указанные почтовые сервера в сети Интернет. Таким образом, для каждого почтового ящика в сети Интернет необходимо создать два назначения портов: для smtp и для pop.

Выберите пункт Port mapping дерева настроек Usergate.
Через кнопку Add в Control panel или через пункт Add New всплывающего меню запустите диалог
создания нового назначения портов.

Ввведите параметры smtp назначения:
Mapping name - например, "Smtp на mail.ru";
Listen IP - Any, либо укажите внутренний сетевой интерейс, на котором Usergate будет прослушивать
клиентские запросы, Port - любой не занятый (например 8025);
Destination address:Port - smtp.mail.ru: 25;
IP protocol - TCP;

Аналогичным образом создаем второе назначение портов.

Параметры pop назначения:
Mapping name - например, "Pop на mail.ru";
Listen IP - Any, либо укажите внутренний сетевой интерейс, на котором Usergate будет прослушивать
клиентские запросы, Port - любой не занятый (например 8110);
Destination address:Port - pop.mail.ru: 110;
IP protocol - TCP;

Если в пункте авторизация назначения портов выбран определенный пользователь, то авторизация такого пользователя в Usergate не проводится (используется для случая, когда пользователь авторизуется через логин и пароль, например).

При настройке почты через Port mapping соответствующим образом должны быть настроены учетные записи в почтовых клиентах, а именно в качестве smtp и pop сервера должен быть указан адрес машины с Usergate.

Настройка учетной записи на примере The Bat.

Настройка почты через NAT

Более простым вариантом настройки почты является настройка через NAT. Для обеспечения работоспособности почтового клиента необходимо присвоить пользователю или группе пользователей два правила NAT: для SMTP и для POP. В этом случае выход для почтового клиента в сеть Интернет является прозрачным и учетная запись настраивается также, как если бы вы работали с Интернет напрямую. Пример правил NAT для SMTP и POP приведены на рисунках.

Прокси сервер Usergate поставляется с рядом предопределенных правил NAT, в которые входят и почтовые правила. Для обеспечения работоспособности правил необходимо указать интерфейсы приемника и отправителя, а также настроить DNS.


Настройка ftp- клиентов

Настройка ftp- клиентов на работу через прокси сервер сводится к указанию прокси в свойствах соединения и пассивного режима. Естественно, в Usergate должен быть активирован режим FTP- прокси (пункт Services дерева настроек, Proxy Settings - FTP proxy).

CuteFTP

Настройка CuteFTP выполняется через пункт Global Settings меню Tools. Альтернативный вызов Global Settings может быть выполнен комбинацией Alt+F7. В диалоговом окне Global options выбираем группу Connection. Дальнейшая настройка может быть выполнена либо через пункт Socks 4&5, либо через пункт Proxy Server. Оба варианта представлены на рисунках.

FTP Explorer

Настройка FTP Explorer выполняется аналогично. В меню View - Options - Firewall, включаем режимы Use PASV Mode и Use Firewall. В поле Host указываем IP адрес внутреннего сетевого интерфейса компьютера с Usergate, порт – 21. Создаем новое FTP соединение. В поле Host Address указываем адрес FTP сервера, к которому необходимо подключиться, включаем режим Use Firewall, порт – 21. Настроки и момент подключения показаны на рисунках.

Total Commander

Создаем новое ftp- соединение (меню Net - FTP New Connection или комбинация Ctrl+N ). В диалоговом окне нажимаем Change, в поле Host name указываем IP компьютера с Usergate, в группе Connect method можно выбрать, например – HTTP Connect. После нажатия OK, указываем адрес FTP сервера, включаем режимы anonymouse connection и Use firewall (proxy server). Результат подключения представлен на рисунке.

Far

Для настройки FTP клиента входим в пункт Options меню (F9) и выбираем раздел FTP client. В появившемся меню, в поле Firewall:Port прописываем внутренний сетевой интерфейс компьютера с Usergate и порта - 21. Включаем пассивный режим (Passive mode). Cоздаем новое FTP соединение (комбинация клавищ – Alt+F1 - FTP, Shift+F4), в настройках указываем адрес ftp- сервера и включаем режим Using firewall.


Настройка программ клиент-банк

Настройку программ типа клиент-банк проиллюстрируем на примере программы Web Money.

Настроить работу программы WMKeeper можно двумя способами: через NAT и через назначение портов.
Наиболее простым является первый способ. Перейдите в пункт NAT дерева настроек Usergate. Через кнопку Add в Control panel или через пункт Add New всплывающего меню мыши запустите диалог создания нового правила NAT. Расставьте IP приемника (локальный интерфейс) и IP отправителя (внешний интерфейс), порт - 2802 TCP. Примените созданное правило нужному пользоватенлю или группе (пункт Users дерева настроек Usergate- Edit - поле Select rules for this user). Параметры правила NAT представлены на рисунке.

Второй способ несколько сложнее. Прграмма WMKeeper подключается к сайту wmsc.webmoney.ru используя порт 2802 TCP. Обеспечить работоспособность программы можно, заставив ее подключаться к прокси серверу Usergate и перенаправляя запросы на требуемый порт сайта wmsc.webmoney.ru. Создадим соответствующее назначение портов (пункт Network rules - Port mapping - Add ). В параметрах назначения портов указываем:

При таком варианте настройки в файл hosts (Windows\System32) необходимо добавить следующую строчку:
192.168.0.1 wmsc.webmoney.ru
здесь 192.168.0.1 - внутренний сетевой интерфейс машины с Usergate.

Таким образом, при запуске WMKepper с подачи ОС будет подключаться к машине с Usergate сервером,
как к своему "родному" сайту. В свою очередь Usergate сервер, используя назначение портов, будет
перенаправлять клиентские запросы на указанный сайт (порт).

Поле Assign mapped traffic to позволяет записывать трафик, реализуемый через данное назначение портов либо на текущего авторизованного пользователя, использующего данное назначение портов или на указанного пользователя.

Как правило настройка любой программы типа клиент-банк проводится по аналогичной схеме.


Настройка менеждеров сообщений

Настройка ICQ

Настройка ICQ выполняется через свойства сетевого соединения. Выберите пункт Connection меню Main - - Preferences, включите опции Using Firewall и Using proxy.

В поле Host укажите IP адрес внутреннего сетевого интерфейса компьютера с Usergate. В выпадающем списке Protocol выберите HTTPS или Socks. Адреса и порт назначения оставьте без изменения.

Настройка Yahoo Messenger

Настройка Yahoo Messenger выполняется через пункт Connection Preferences меню Messenger. В диалоговом окне Messenger Preferences необходимо выбрать категорию Connection. Далее настроить работу Yahoo Messenger можно так же, как и ICQ, а именно указываем протокол HTTP или Socks и адрес внутреннего сетевого интерфейса компьютера с Usergate. Настройки показаны на следующих рисунках.

При работе Yahoo Messenger через прокси режим выбора Chat rooms и Video Chat не доступен!


Администрирование Usergate

В данном разделе приведено краткое описание наиболее частых задач, возникающих перед администратором Usergate. Задача администратора Usergate состоит в разработке политики доступа к сети Интернет, слежение за состоянием счета пользователей, разработка правил работы в сети Интернет.

В разделе приведено решение следующих задач:
· 1. ограничение доступа к сети (по времени, по содержанию, по состоянию счета пользователя)
· 2. динамическое переключение тарифов (по времени, по адресу назначения)
· 3. ведение статистики пользовательской активности в сети Интернет
·


Создание тарифов

Для создания тарифа в Usergate Administrator выберите пункт Billing Plans дерева настроек. Через кнопку Add или пункт Add New Tarif всплывающего меню мыши вызовите диалог создания нового тарифа. Введите стоимость входящего, исходящего и временного тарифа в соответствии с необходимыми требованиями. Для того, чтобы пользовательские соединения тарифицировались в соответствии с созданным тарифом его неорбходимо присвоить в качестве тарифа по умолчанию для пользователя или группы. В последнем случае все соединения, порожденные пользователями, входящими в состав группы будут тарифицироваться в соотсветствии с тарифным планом группы. Последовательность шагов для создания тарифа иллюстрирована ниже.

Шаг 1 (Нажмите на картинку для увеличения изображения)

Шаг 2 (Нажмите на картинку для увеличения изображения)

Шаг 3 (Нажмите на картинку для увеличения изображения)

По умолчанию пользовательские соединения тарифицируются в соответствии с тарифным планом группы (Group rate), в которую входит пользователь. Тем не менее, в профиле пользователя можно переопределить тариф по умолчанию.


Создание правил

В основе политики администрирования Usergate лежат правила. С помощью правил администратор Usergate может установить время работы в сети Интернет, регулировать расходование среств пользователей, устанавливать ограничения и т.п. Для создания правила выберите пункт Rules дерева настроек Usergate Administrator. Через кнопку Add в Control Panel или через пункт Add New Rule всплывающего меню запустите диалог создания правила. Диалог содержит несколько страниц. На страницах формулируются условия срабатывания правила. Для функционирования правила не обязательно заполнять все имеющиеся страницы.

Первая страница предназначена для выбора пары Объект-Действие, способа логического объединения условий и дополнительного параметра (доступен для объекта- Тариф).

На второй странице можно указать к каким видам протоколов будет применяться правило. По умолчанию правило применяется ко всем перечисленным протоколам.

На третьей странице задается временной интервал, в течении которого правило может сработать (правило активно). Кроме того, на данной странице можно установить специальные даты (Holidays), когда правило не будет активным.

На четвертой странице выставляются ограничения трафика, максимального размера скачиваемого файла, минимальной суммы на счету пользователя.

Последняя страница диалога предназначена для задания списка IP адресов источников или назначения, а также списко http- адресов назначения. Таким образом, имеется возможность селективного применения правил, в зависимости от источника запроса (компьютер в локальной сети) и адреса назначения.

Индикатор прогресса в правом верхнем углу окна позволяет осуществлять навигацию между окнами диалога в произвольном порядке.

После нажатия кнопки OK првило может быть применено ко всем группам. Имеется возможность применения правила к отдельному пользователю.


Ограничение доступа в Интернет

Запрет доступа на все сайты кроме нескольких

Пусть необходимо предоставить доступ к некоторым сайтам, например, www.mail.ru, www.yandex.ru, www.rambler.ru и запретить доступ ко всем остальным сайтам.

Для решения поставленной задачи создадим правило со следующими параметрами:
· Объектом – действие: Сonnection – Close;
· На пятой странице диалога (Filters), в поле "URL list", добавим * в качестве URL entry и перечислим разрешенные сайты по маске в качестве exceptions: *mail.ru*, *yandex.ru*, *rambler.ru*.
· Применим правило ко всем пользователям.
Создание такого правила показано на рисунке снизу.

Запрет доступа на определенные сайты

Для запрета доступа на определенные сайты, создадим правило по аналогии с предыдущим случаем. Однако в данном случае, на странице Filters диалога создания правила, в поле «URL list» перечислим запрещенные сайты по маске в качестве URL entry.

Имеется возможность импорта масок запрещенных сайтов из текстового файла с расширением *.flt. Файл представляет собой обычный текстовый файл в котором построчно перечислены маски запрещенных сайтов. Пример приведен на рисунке снизу.

Запрет скачивания файлов определенного расширения

Для запрета скачивания файлов по расширению, создадим правило с параметрами:
· Объект - действие: Connection – Close.
· На странице Filters диалога создания правила, в поле URL list, перечислим расширения запрещенных файлов, например, *.jpg*, *.jpeg*, *.bmp*.
· В выпадающем списке выбираем Entrire URL или Document address.
Созданное правило запрещает скачивать некоторые типы графических файлов (показано на рисунке снизу).

Автоматическое отключение пользователей с нулевым балансом

Для автоматического отключения пользователей, достигших нулевого баланса необходимо
вкулючить опцию Watch the account на странице Limits диалога создания правила. Правило
должно закрывать соединения.


Переключение тарифов

Смена тарифов по времени

Пусть имеется два тарифа – дневной (с 9:00 до 21:00) и ночной (c 21:00 до 9:00). Требуется осуществлять смену тарифов в зависимости от времени суток.

Решение задачи целесообразно начать с создания ключевого объекта Usergate, а именно тарифа. Необходимосоздать два тарифа (создание тарифов) – Ночной и Дневной.

В качестве тарифа по умолчанию для каждого пользователя (или группы) выберем Дневной тариф. Далее, создаем правило (создание правил), в качестве объекта выбираем – Tariff, действие – Change to. В выпадающем списке Parameters выбираем Ночной тариф.

На странице Time and Holidays выделяем область с понедельника по воскресенье, и с 21:00 до 9:00. Применяем созданное правило всем пользователям. Созданное правило осуществляет переключение тарифа Ночной (по умолчанию) на тариф Дневной.

Создаем правило, осуществляющее обратную смену тарифа. В данном случае правило должно сменить текущий тариф на Дневной тариф. В данном случае на странице Time and Holidays необходимо выделить область с понедельника по воскресенье и с 0 до 9:00 и с 21:00 до 24:00.

Смена тарифов по адресу назначения

Пусть имеется два тарифа – Внутренний (для сайта провайдера, например) и Внешний (для прочих сайтов). Требуется осуществлять смену тарифов в зависимости от адреса назначения.

Как и в предыдущем случае начинаем с создания двух тарифов – Внешней и Внутренний. Один из них, например, Внешний, как наиболее часто используемый, присваиваем пользователям в качестве тарифа по умолчанию.

Создаем правило с объектом – Connection и действием – Change to. В списке Parameters выбираем Внешний тариф. На странице Filters диалога создания правила, в поле URL list перечисляем сайты по маске (*mail.ru*, *yandex.ru* и т.д.). Адреса сайтов можно указать через IP, в поле IP list.


Публикация сетевых ресурсов

Публикация сетевого ресурса означает предоставление лоступа из сети Интернет к определенному ресурсу компаниии, например, к web- серверу или ftp- серверу.

Допустим, необходимо предоставить доступ к web- серверу компании. В локальной сети web- сервер имеет IP адрес 192,168.0.2. Для публикации сервера необходимо создать правило в брандмауэре, пропускающее трафик c порта 80 TCP из сети Интернет на порт 80 TCP машины 192.168.0.2.

Для публикации необходимо выполнить следующие шаги:
1. В пункте Firewall Policies выбираем раздел Resource publishing
2. Через кнопку Add в Control Panel или через пункт Add New всплывающего меню мыши, запускаем диалог публикации сетевого ресурса.
3. Указываем следующие параметры:
Name - Web-Server
Source interface - IP адрес карты, смотрящей в сеть Интернет
Destination interface - IP адрес сетевого карты, смотрящей в LAN
В поле Destination settings указываем:
Dest. IP – 192.168.0.2
Port – 80
Protocol – TCP
User – web_user

Опция Port as source позволяет не указывать порт в Destination IP. Трафик, реализуемый через данное правило будет записываться на пользователя web_user.

Публикация web- сервера показана на следующем рисунке.

Публикация FTP сервера отличается от представленной ранее публикации web- сервера только номером используемого порта. В диалоге New resource в качестве порта необходимо указать порт 21 TCP.


Учет локального трафика

Часто машина, используемая в качестве Интернет - шлюза, сама используется в качестве рабочей машины администратора. Естественно возникает необходимость учета расходования Интернет - трафика на самом шлюзе.

Задача решается через создание специального пользователя с авторизацией пл IP адресу и адресом 127.0.0.1 (т.н. Loopback adapter или адаптер замыкания на себя). Целесообразно присвоить пользователю семантическое имя, например local, что указывает на характер пользователя (локальный).

Далее, в Свойствах Обозревателя (Пуск - Настройка -Панель управления) нужно включить режим использования прокси и указать соответствующий адрес и порт. Настройка приведена на рисунках.


Администрирование машины в LAN

Часто возникает необходимость в администрировании машины в локальной сети извне, например из другого офиса или компании или даже из дома. Удаленное администрирование не представляет проблем в случае, когда локальная сеть доступна извне. Однако при работе через прокси сервер необходимо выполнить предварительные шаги. В данном пункте описана настройка наиболее часто используемых средств удаленного администрирования: Remote Desktop и RAdmin.

Настройка доступа для Remote Desktop Connection

Remote Desktop использует порт 3389 TCP. Предоставить доступ к машине в локальной сети можно через Port Mapping. Создайте новое назначение портов c параметрами:

Listen IP : Port - внешний интерфейс машины с Usergate, любой незанятый TCP порт (например 4000).
Destination address : Port - адрес машины в локальной сети, порт 3389 TCP.

Пример назначения портов и подключения приведен на рисунках.

Настройка доступа для RAdmin

В Usergate задача решается аналогичным способом. В назначении портов, в качестве порта для Listen IP
можно указат любой незанятый порт или порт, используемый RAdmin по умолчанию - 4489 TCP.

Трафик, затраченный на удаленное администрирование, будет записан на созданного пользователя, указанного в поле Assigned mapped traffic to. Доступ может быть ограничен как по времени, так и по размеру трафика, с помощью соответствующего правила.


Настройка антивируса

Антивирус Касперского, внедренный в прокси сервер Usergate имеет ряд настроек.

General
Antivirus database folder location - местоположение директории для хранения антивирусных баз. По умолчанию антивирусные базы хранятся в каталоге bases, директории Usergate. Место положения директории может быть изменено. После установки каталог с антивирусными базами пустой, необходимо выполнить Update антивирусных баз.

Temp directory location - директория для хранения временных файлов. В диреторию помещаются файлы для сканирования, в том случае, если файл не может быть загружен в память полностью. По умолчанию используется временная директория Windows.

Advanced
URLs filter - опция позволяет включить/выключить антивирусную проверку для заданных адресов URLs, (в соответствии с шаблоном) или для заданных типов документов. По умолчанию антивирус проверяет трафик со всех сайтов (первая строчка фильтра на рисунке). Трафик с сайта *mycompany.com* не будет проверяться на вирусы.

Exclude users group - опция позволяет указать группы пользователей, трафик которых не будет подвергаться антивирусной проверке.


Настройка файервола

Файервол, добавленный в прокси - сервер Usergate четвертой версии, позволяет обеспечить дополнительную защиту Интернет - шлюза за счет блокирования трафика через определенные порты (TCP, UDP, любым IP протоколам).

Файервол Usergate обрабатывает пакеты, не прошедшие обработку на уровне правил NAT. Если пакет был обработан драйвером NAT, он не обрабатывается файерволом Usergate.

По умолчанию файервол содержит единственное правило #NOUSER#.Оно служит для запрещения всего, что не разрешено или для разрешения всего, что не запрещено. Это зависит от выбранного действия (Drop или Send). По умолчанию выбрано действие Send. Если, после включения файервола, в правиле #NOUSER# выбрать действие Drop, то не будет работать НИЧЕГО, кроме трафика через NAT и через порты, открытые через Port Mapping и Proxy Settings (HTTP, FTP, Socks прокси) в Usergate.

Порты, указанные в настройках прокси (Proxy Settings - HTTP, FTP, Socks), а также порты, указанные в Port Mapping помещаются помещаются в автоматически генерируемые правила файеровола (тип auto).
В правила auto также помещается порт 2345 TCP, используемый Usergate Administrator для подключения к серверной части Usergate.

Пример страницы настройки Firewall приведен на рисунке. Для иллюстрации в Usergate были включены HTTP и Socks прокси (8080 и 1080 TCP), а также имеется два Port Mapping (8025 и 8110 TCP). Порт 2345 TCP используется Usergate Administartor.


Удаленный просмотр статистики

 Имеется возможность удаленного просмотра статистики. На удаленной машине запуститепрограмму statistics.exe, в меню Settings укажите сетевой путь к файлу config.cfg настроек Usergate (на сервере). В поле "Адрес источника" нажмите Изменить - Machine Data Source - База данных MS Access - New - укажите сетевой путь к файлу log.mdb на сервере. Настрока приведена на рисунках внизу.


Частые вопросы

1. Не получается ввести регистрационный код. Кнопка «Register» недоступна.
2. Не могу настроить почту.
3. Как настроить работу программы банк-клиент? (сетевые игры и т.д.)
4. В NAT порты открыты, но программы при попытке соединения выдают сообщение «сервер не найден».
5. Где хранятся настройки UserGate?
6. Как обновить версию UserGate?
7. Можно ли ограничивать скорость трафика для пользователя?
8. Как сделать так, чтоб из локальной сети через UserGate можно было делать ping на внешние сервера?
9. Как переместить пользователя в другую группу?
10. При попытке запустить UserGate выдается ошибка StartServiceCtrlDispatcher failed, error 0x427.
11. Что такое "количество рабочих сессий", которое мне нужно указывать при покупке UserGate?
12. Как запретить клиентам использовать ICQ?

Ответы:

1. Не получается ввести регистрационный код. Кнопка «Register» недоступна, показывается сереньким цветом и не нажимается.

Проверьте, установлено ли соединение Usergate Administartor с серверной частью UserGate. Для этого убедитесь, что на странице Logs присутствует строка вида «09:03.15 Connected to localhost, version...».
Если соединения с серверной частью нет, запустите серверную часть и нажмите кнопку Connect.

Если подключиться не удается, проверьте наличие usergate.exe на вкладке Процессы менеждера задач Windows. Проверьте файл usergate.exe.log, расположенный в директории Usergate на предмет сообщений об ошибках. Возможно Usergate сервер не запускается из-за ошибки в конфигурационном файле (config.cfg) или в базе статистики (log.mdb)

2. Не могу настроить почту.

Для работы с почтой через UserGate необходимо включить NAT с правилами POP3 и SMTP и применить
правила нужному пользователю. Проверьте работоспособность учетной записи в почтовом клиенте на машине с прямым доступом в сеть Интернет. Если учетная запись создана верно, проверьте настройку DNS. Выполните в командной строке на клиентской машине:

nslookup pop.mail.ru или
nslookup smtp.mail.ru

при правильной настройке DNS вы должнв получить IP адреса запрощенных серверов. Если IP адреса определяются правильно, а почта не работает, проверьте не заняты ли используемые порты (25 и 110 TCP) на сервере какой- либо службой (команда netstat -a).

Если порты не заняты, проверьте не блокируются ли они файерволом сторонних производителей.

3. Как настроить работу программы банк-клиент? (сетевые игры, WebMoney и т.д.)?

Для настройки необходимо выяснить, какой порт и протокол использует программа, создать соответствующее правило NAT и применить его к пользователю или группе.

4. В NAT порты открыты, но программы при попытке соединения выдают сообщение «сервер не найден».

Проверьте работоспособность настройки DNS.
Есть два способа настройки DNS в UserGate.
I. С использованием DNS forwarding.
II. С использованием NAT.
При настройке DNS через NAT убедитесь, что интерфейсы приемника и отправителя расставлены верно.

5. Где хранятся настройки UserGate ?

Настройки программы хранятся в файле config.cfg, расположенном директории UserGate. Файл хранит настройки в формате xml.

6. Как обновить версию UserGate?

Cкачайте новый установочный пакет из закрытой зоны сайта www.usergate.ru, воспользовавшись учетной записью зарегистрированного пользователя. Убедитесь, что UserGate сервер и UserGate Administrator выгружены из памяти компьютера. Запустите скачанный из закрытой зоны файл и следуйте инструкциям установочной программы. В качестве пути установки укажите каталог, куда уже установлен UserGate предыдущей версии. Перезагрузите компьютер.

7. Можно ли ограничивать скорость трафика для пользователя?

Для этого в настройках пользователя (слева, над указанием тарифа) максимально возможное количество килобайт в секунду, которое сможет получать и отправлять данный пользователь.

8. Как сделать так, чтоб из локальной сети через UserGate можно было делать ping на внешние сервера?

Никак. Usergate не пропускает ICMP трафик.

9. Как переместить пользователя в другую группу?

Убедитесь, что группа, в которую будет перенесён пользователь, уже создана.
Затем в настройках конкретного пользователя в выпадающем списке «Группа» выберите группу, в которою нужно перенести данного пользователя. Нажмите «Да».

10. При попытке запустить UserGate выдается ошибка StartServiceCtrlDispatcher failed, error 0x427 .

Эта ошибка появляется в случае, когда UserGate установлен как сервис, но производится попытка запустить его как обычную программу.
Для запуска UserGate как сервис нужно выполнить команду 'net start usergate' .
Если Вы хотите запускать UserGate как обычную программу, тогда нужно сделать Uninstall Service, после чего можно запускать UserGate как обычную программу.

11. Что такое "количество рабочих сессий", которое мне нужно указывать при покупке UserGate?

Параметр лицензии "количество одновременных рабочих сессий" означает максимально возможное количество одновременно работающих с UserGate пользователей вне зависимости от количества открытых окон и программ, использующих интернет.

12. Как запретить клиентам использовать ICQ?

Создайте правило, закрывающее соединение при запросе сайта *login.icq.com*. Примените правило всем пользователям.


TheBat

Пример учетная записи в The Bat, при настройке почты через Port Mapping

TheBat1

TheBat2