Übersicht zu Microsoft Exchange Server Best Practices Analyzer

Letztes Änderungsdatum des Themas: 2005-07-08

Microsoft® Exchange Server Best Practices Analyzer ist ein Diagnose-Tool, das die folgenden Funktionen ausführt:

  • Von einer Microsoft Exchange Server-Organisation werden Konfigurationsinformationen gesammelt.

  • Bestimmte Tests werden auf der Exchange Server-Organisation ausgeführt.

  • Die Ergebnisse dieser Tests werden gemeldet.

Mit Exchange Server Best Practices Analyzer können folgende Aufgaben ausgeführt werden:

  • Es wird proaktiv sichergestellt, dass die Konfiguration nach dem empfohlenen optimalen Verfahren erfolgt.

  • Alle von den Standardeinstellungen abweichenden Einstellungen werden gemeldet.

  • Aktuelle Änderungen in der Exchange Server-Organisation werden gemeldet. Diese Funktion trägt zum Bestimmen von Problemen bei, die durch Änderungen in der Exchange Server-Organisation verursacht werden.

  • Die Identifizierung der Problemursache in fehlerhaften Exchange Server-Organisationen wird unterstützt.

  • Eine Gruppe von Servern wird mit einer Basiskonfiguration verglichen, und Abweichungen der Konfigurationen werden gemeldet.

Hinweis:
Exchange Server Best Practices Analyzer kann aktuelle Änderungen nur für Konfigurationsobjekte melden, die eine Eigenschaft zur Uhrzeit der letzten Änderung enthalten.

Exchange Server Best Practices Analyzer bestimmt mithilfe einer Konfigurationsdatei, welche Informationen von der Exchange Server-Organisation gesammelt werden sollen. Die gesammelten Daten werden mit einer Gruppe vordefinierter Regeln für Exchange Server-Einstellungen und -Konfigurationen verglichen. Probleme werden dann gemeldet.

Für jedes Problem stellt Exchange Server Best Practices Analyzer drei Arten von Daten bereit:

  • Das Ergebnis der Suche in der Exchange Server-Organisation wird gemeldet.

  • Eine Konfiguration wird empfohlen.

  • Hyperlinks zu weiteren Informationen zu diesem Problem und zu verwandten Themen werden bereitgestellt.

Ihre Kommentare, Vorschläge und Ihr Feedback zu Exchange Server Best Practices Analyzer sind uns jederzeit willkommen. Sie können uns Ihr Feedback auf verschiedenen Wegen zukommen lassen:

  • Öffentliche Microsoft-Newsgroups Mitglieder des Entwicklungsteams von Exchange Server Best Practices Analyzer lesen regelmäßig die Newsgroup microsoft.public.exchange.tools unter news.microsoft.com. Weitere Informationen zur Teilnahme an dieser Newsgroup sowie an weiteren Microsoft-Newsgroups finden Sie auf der Website von Microsoft Exchange Server Best Practices Analyzer (http://go.microsoft.com/fwlink/?LinkId=33938) sowie auf der Website mit den Newsgroups des technischen Supports von Microsoft (http://go.microsoft.com/fwlink/?LinkId=50219).

  • Feedback zur Exchange Server Best Practices Analyzer-Dokumentation Sollten Sie Kommentare, Fragen oder Feedback zu Dokumentationen oder Artikeln im Zusammenhang mit Exchange Server Best Practices Analyzer haben, senden Sie diese Angaben bitte an exbpadoc@microsoft.com.


Installieren von Microsoft Exchange Server Best Practices Analyzer

Installieren von Microsoft Exchange Server Best Practices Analyzer |
 | Siehe auch
Übersicht zu Microsoft Exchange Server Best Practices Analyzer >

Letztes Änderungsdatum des Themas: 2006-02-08

Führen Sie zum Installieren von Microsoft® Exchange Server Best Practices Analyzer die Microsoft-Installationsdatei ExBPA.msi auf dem Computer aus, auf dem das Tool ausgeführt werden soll. Das Installationsprogramm erstellt das Verzeichnis ExBPA, das sich in der Standardeinstellung unter <Systemlaufwerk>\Programme befindet, und kopiert die erforderlichen Dateien in dieses neue Verzeichnis.

Auswählen des Computers für die Installation

Es wird empfohlen, Exchange Server Best Practices Analyzer auf einer dedizierten Verwaltungsstation zu installieren. Weitere Informationen zum Installieren und Verwenden von dedizierten Verwaltungsstationen finden Sie im Exchange Server 2003-Administrationshandbuch (http://go.microsoft.com/fwlink/?linkid=21769).

Zum Installieren des Tools auf einem Computer außerhalb der Exchange-Organisation müssen die Benutzernamen und Kennwörter für die Anmeldung beim Active Directory-Verzeichnisdienst und an den Exchange-Servern explizit festgelegt werden. Weitere Informationen zum Festlegen der Anmeldeinformationen für das Benutzerkonto, unter dem die Überprüfung ausgeführt werden soll, finden Sie unter Berechtigungen für Microsoft Exchange Server Best Practices Analyzer..

Das Tool kann auch auf einem Exchange-Server installiert werden. Das Tool kann auf einem Exchange-Server ausgeführt werden; jedoch werden dabei sehr viele Systemressourcen beansprucht, insbesondere der Prozessor und der Arbeitsspeicher. Es wird deshalb empfohlen, das Tool auf einem separaten Computer zu installieren. Wenn Sie das Tool auf einem Exchange-Server installieren, wird empfohlen, nur den Exchange-Server zu überprüfen.

Überprüfen auf Aktualisierungen

Beim Starten von Exchange Server Best Practices Analyzer wird ermittelt, ob eine neue Datei mit den Regeln für die optimale Vorgehensweise unter http://www.microsoft.com/germany/default.aspx verfügbar ist. In diesem Fall kann die neue Datei gedownloadet werden. Sie müssen als Administrator angemeldet sein, um die Datei downloaden zu können. Wenn Sie die Datei nicht downloaden möchten oder das Tool nicht auf das Internet zugreifen kann, wird die Kopie der Datei auf dem Computer verwendet, auf dem es ausgeführt wird.

Hinweis:
Wenn für den Internetzugriff eine Proxyauthentifizierung erforderlich ist, erhält das Tool keinen Zugriff auf die neue Version der Konfigurationsdatei, die Sie downloaden möchten. Die Datei kann jedoch manuell von http://www.microsoft.com/germany/default.aspx auf den lokalen Computer kopiert werden.
So kopieren Sie die neue Version der Konfigurationsdatei manuell

  1. Benennen Sie die vorhandene Datei ExBPA.Config.xml in dem Verzeichnis um, in dem das Tool installiert wird.

  2. Navigieren Sie im Webbrowser zu http://go.microsoft.com/fwlink/?LinkId=34290.

  3. Laden Sie das selbstextrahierende Paket herunter, und extrahieren Sie die neuen Dateien in das Installationsverzeichnis des Tools (normalerweise C:\Programme\ExBPA).

Siehe auch

Konzepte

Einfluss von Microsoft Exchange Server Best Practices Analyzer auf die Leistung.
Berechtigungen für Microsoft Exchange Server Best Practices Analyzer.

Weitere Ressourcen

Einrichten von Überprüfungen im Microsoft Exchange Server Best Practices Analyzer

© 2007 Microsoft Corporation. Alle Rechte vorbehalten.


Voraussetzungen zum Ausführen von Microsoft Exchange Server Best Practices Analyzer.
Übersicht zu Microsoft Exchange Server Best Practices Analyzer >

Letztes Änderungsdatum des Themas: 2005-07-08

Die Computer in der Exchange-Organisation müssen einige Voraussetzungen erfüllen, damit Microsoft® Exchange Server Best Practices Analyzer ordnungsgemäß ausgeführt werden kann. Wenn diese Voraussetzungen nicht erfüllt sind, kann das Tool in vielen Fällen zwar trotzdem ausgeführt werden, jedoch möglicherweise mit vermindertem Funktionsumfang oder geringerer Leistung.

Dieser Abschnitt enthält Informationen zu den erforderlichen Berechtigungen für das Ausführen von Exchange Server Best Practices Analyzer sowie zu allen weiteren Voraussetzungen, die die Exchange-Organisation und der Computer, auf dem das Tool ausgeführt wird, erfüllen müssen. Im Abschnitt „Weitere Voraussetzungen" sind die unterstützten Umgebungen für das Ausführen des Tools aufgeführt.

In diesem Abschnitt

Berechtigungen für Microsoft Exchange Server Best Practices Analyzer.

Weitere Voraussetzungen für Microsoft Exchange Server Best Practices Analyzer.


Berechtigungen für Microsoft Exchange Server Best Practices Analyzer.

Berechtigungen für Microsoft Exchange Server Best Practices Analyzer. |
 | Siehe auch
Übersicht zu Microsoft Exchange Server Best Practices Analyzer > Voraussetzungen zum Ausführen von Microsoft Exchange Server Best Practices Analyzer. >

Letztes Änderungsdatum des Themas: 2005-07-08

Microsoft® Exchange Server Best Practices Analyzer hat nur dann Zugriff auf den Active Directory®-Verzeichnisdienst und die Exchange-Server, wenn das Tool mithilfe der Anmeldeinformationen ausgeführt wird, die über alle erforderlichen Berechtigungen verfügen.

Berechtigungen

Um Exchange Server Best Practices Analyzer erfolgreich auszuführen, müssen Sie über folgende Berechtigungen verfügen:

  • Domänenadministrator oder Mitglied der vordefinierten Administratorgruppe auf dem Active Directory-Server, um Active Directory-Informationen aufzulisten und WMI-Anbieter (Microsoft Windows® Verwaltungsinstrumentation - Microsoft Windows® Management Instrumentation) auf Domänencontrollern und globalen Katalogservern aufzurufen.

  • Mitglied der lokalen Administratorgruppe auf jedem Exchange-Server, um WMI-Anbieter aufzurufen und auf die Registrierung und die Metabase zugreifen zu können.

  • Zumindest „Exchange-Berechtigungen - Nur Ansicht" für die Exchange-Organisation.

Wenn Sie sich an dem Computer anmelden, auf dem Exchange Server Best Practices Analyzer unter einem Konto ausgeführt wird, das nicht über ausreichende Berechtigungen verfügt, gibt es zwei Optionen:

  1. Verwenden Sie den Befehl runas, um ein Eingabeaufforderungsfenster zu öffnen, das unter einem Konto mit ausreichenden Berechtigungen ausgeführt wird, und starten Sie dann das Tool in diesem Fenster. Die Syntax dafür lautet wie folgt:

    runas /netonly /user:<Domäne>\<Benutzername> exbpa.exe

  2. Legen Sie die Anmeldeinformationen für die Konten fest, die auf der Seite zum Herstellen einer Verbindung mit Active Directory im Tool verwendet werden. Klicken Sie auf die Option zum Anzeigen erweiterter Anmeldeoptionen, um die Optionen zu erweitern. Zwei Konten können eingeben werden: Ein Konto zum Herstellen einer Verbindung mit Active Directory und ein anderes zum Herstellen einer Verbindung mit den Exchange-Servern. Wenn Sie keine dieser beiden Konten angeben, wird das Konto verwendet, unter dem das Tool ausgeführt wird.

Siehe auch

Konzepte

Weitere Voraussetzungen für Microsoft Exchange Server Best Practices Analyzer.

© 2007 Microsoft Corporation. Alle Rechte vorbehalten.


Weitere Voraussetzungen für Microsoft Exchange Server Best Practices Analyzer.

Weitere Voraussetzungen für Microsoft Exchange Server Best Practices Analyzer. |
 | Siehe auch
Übersicht zu Microsoft Exchange Server Best Practices Analyzer > Voraussetzungen zum Ausführen von Microsoft Exchange Server Best Practices Analyzer. >

Letztes Änderungsdatum des Themas: 2007-05-16

Um Microsoft® Exchange Server Best Practices Analyzer erfolgreich auszuführen, muss er unter einem Konto ausgeführt werden, das über die erforderlichen Berechtigungen für den Active Directory®-Verzeichnisdienst und über die erforderlichen Berechtigungen für die Exchange-Server verfügt. Außerdem müssen Sie einige zusätzliche Voraussetzungen überprüfen.

Voraussetzungen

Exchange Server Best Practices Analyzer kann nur richtig ausgeführt werden, wenn folgende Bedingungen erfüllt sind:

  • .NET Framework 1.1 muss auf dem Computer installiert sein, auf dem Exchange Server Best Practices Analyzer ausgeführt wird.

  • Die gemeinsamen Dateien von Internetinformationsdienste (IIS - Internet Information Services) müssen auf dem Computer installiert sein, auf dem Exchange Server Best Practices Analyzer ausgeführt wird, sodass ein Remote-Metabase-Zugriff ermöglicht wird.

    Hinweis:
    Wenn Internetinformationsdienste, Internetinformationsdienste für Administratoren oder Exchange-System-Manager installiert werden, werden die gemeinsamen Dateien von Internetinformationsdienste automatisch installiert.
  • Der Computer, auf dem Exchange Server Best Practices Analyser ausgeführt wird, muss über mindestens 256 MB RAM (Random Access Memory - Arbeitsspeicher) verfügen. Diese Speichergröße ist für die Überprüfung von bis zu 50 Exchange-Servern ausreichend. Wenn Sie der Exchange-Organisation jeweils bis zu 50 Server hinzufügen, werden auf dem Computer, auf dem das Tool ausgeführt wird, zusätzliche 256 MB RAM benötigt. Beispielsweise müssen bei einer Anzahl von 50 bis 100 Exchange-Servern in der Organisation mindestens 512 MB RAM auf dem Computer verfügbar sein, auf dem das Tool ausgeführt wird. Wenn in einer Organisation 100 bis 150 Exchange-Server vorhanden sind, müssen mindestens 768 MB RAM auf dem Computer verfügbar sein, auf dem das Tool ausgeführt wird.

  • Für jeden zu überprüfenden Exchange-Server in der Organisation müssen mindestens 2 MB auf dem Plattenspeicherplatz des Computers verfügbar sein, auf dem Exchange Server Best Practices Analyzer ausgeführt wird.

  • Active Directory muss in der Topologie unter Microsoft Windows® 2000 Server oder unter Windows Server™ 2003 installiert sein.

  • In Active Directory muss mindestens ein Exchange 2003-Server oder Exchange 2000-Server installiert sein.

  • Der Remoteregistrierungsdienst (RemoteRegistry) muss sowohl auf dem Active Directory-Server als auch auf den Exchange-Servern ausgeführt werden.

  • Der WMI-Dienst (Windows Management Instrumentation - Windows-Verwaltungsinstrumentation - winmgmt) muss auf dem Active Directory-Server und auf den Exchange-Servern ausgeführt werden.

  • Der Exchange-Verwaltungsdienst (MSExchangeMGMT) muss auf allen Exchange-Servern ausgeführt werden, bei denen es sich um einen Exchange 2000-Server oder neuere Versionen handelt.

  • Benutzer, die angemeldet sind und Exchange Server Best Practices Analyser ausführen, müssen über Lese-/Schreibzugriff auf den Ordner verfügen, in dem das Tool ausgeführt wird.

  • Um HBA-Informationen (Host Bus Adapter) zu sammeln, müssen auf dem Server, auf dem die Informationen erfasst werden, ein HBA-API-kompatibler Treiber und ein Remotedienst (z. B. der Dienst HBAnywhere von Emulex) installiert sein. Darüber hinaus muss sowohl auf dem Computer, auf dem Exchange Server Best Practices Analyzer ausgeführt wird, als auch auf dem Server, auf dem HBA installiert ist, die Installation für HBA API Managed Object Format (MOF) ausgeführt werden. Wenn kein HBA-API-kompatibler Treiber und kein Remotedienst installiert ist, kann Exchange Server Best Practices Analyzer zwar ausgeführt werden, jedoch können keine HBA-Informationen gesammelt werden.

Unterstützte Umgebungen

Exchange Server Best Practices Analyzer kann in folgenden Umgebungen ausgeführt werden:

  • Exchange Server 5.5 unter Windows 2000 Server SP3 und höheren Versionen

Hinweis:
Der Exchange Server 5.5-Server muss Bestandteil einer Exchange-Organisation im gemischten Modus sein, der in Active Directory dargestellt wird.
  • Exchange 2000 Server (alle Service Packs) unter Windows 2000 Server SP3 und höheren Versionen

Hinweis:
Weder Windows 2000 Server noch Exchange 2000 Server unterstützen komplexe WMI-Anbieter. Datensammlungen und -analysen sind möglicherweise eingeschränkt.
  • Exchange 2003 Server (alle Service Packs) unter Windows 2000 Server SP3 und höheren Versionen

Hinweis:
Windows 2000 Server unterstützt keine komplexen WMI-Anbieter. Datensammlungen und -analysen sind möglicherweise eingeschränkt.
  • Exchange Server 2003 (alle Service Packs) unter Windows Server 2003

  • Exchange Server 2007 unter Windows Server 2003

Siehe auch

Konzepte

Berechtigungen für Microsoft Exchange Server Best Practices Analyzer.

© 2007 Microsoft Corporation. Alle Rechte vorbehalten.


Überprüfen der Exchange-Organisation mit Microsoft Exchange Server Best Practices Analyzer
Übersicht zu Microsoft Exchange Server Best Practices Analyzer >

Letztes Änderungsdatum des Themas: 2005-07-08

Microsoft® Exchange Server Best Practices Analyzer überprüft die Computer in der Exchange-Organisation im ausgewählten Bereich. Dabei werden die Konfigurationseinstellungen mit einer Reihe empfohlener optimaler Methoden verglichen und ein Ergebnisbericht erstellt.

Während der Überprüfung wird die Statusanzeige dynamisch aktualisiert, und es wird angezeigt, wie viel Prozent der gesamten Überprüfung bereits abgeschlossen sind. Diese Angabe basiert auf der für den jeweiligen Überprüfungstyp gesammelten Datenmenge und der Anzahl der Server innerhalb des Überprüfungsbereichs.

Die geschätzte verbleibende Zeit wird dynamisch aktualisiert und alle 60 Sekunden neu berechnet. Exchange Server Best Practices Analyzer funktioniert in mehreren Threads, sodass mehrere Exchange-Server gleichzeitig überprüft werden können. Exchange Server Best Practices Analyzer überprüft Computer aus bis zu zehn administrativen Gruppen gleichzeitig und kann bei bis zu 50 Exchange-Servern gleichzeitig eine Überprüfung durchführen. Weitere Server werden in die Warteschlange eingereiht und überprüft, sobald andere fertiggestellt wurden.

Im Fenster mit ausführlichen Informationen zur Serverüberprüfung wird der Status des jeweils überprüften Servers angezeigt. Server können drei Status aufweisen: „Ausstehend", „In Bearbeitung" und „Abgeschlossen". Wenn sich ein Server im Status „In Bearbeitung" befindet, wird in einer Statusanzeige angezeigt, wie viel Prozent der Überprüfung bereits abgeschlossen sind. Wenn sich ein Server im Status „Abgeschlossen" befindet, wird mit einem Symbol angezeigt, ob Exchange Server Best Practices Analyzer auf den Server zugreifen konnte. Ein grünes Häkchen zeigt an, dass Exchange Server Best Practices Analyzer auf den Server zugreifen konnte, dass kein Fehler aufgetreten ist und dass während der Überprüfung keine Zeitüberschreitungen eingetreten sind. Ein gelbes Warnsymbol zeigt an, dass Exchange Server Best Practices Analyzer zwar auf den Server zugreifen konnte, jedoch entweder ein Fehler aufgetreten ist oder während der Überprüfung eine Zeitüberschreitung eingetreten ist. Ein rotes X-Symbol zeigt an, dass Exchange Server Best Practices Analyzer nicht auf den Server zugreifen konnte und der Server nicht überprüft wurde.

Exchange Server Best Practices Analyzer muss Daten nicht nur von den Exchange-Servern, sondern auch vom Active Directory®-Verzeichnisdienst sammeln. Der Fortschritt beim Sammeln der Daten aus Active Directory wird in der Statusleiste und die geschätzte verbleibende Zeit oben auf der Seite angezeigt, jedoch nicht im Fenster mit ausführlichen Informationen zur Serverüberprüfung. Daher kann der Gesamtstatus der Überprüfung auch dann „In Bearbeitung" lauten, wenn sich alle Exchange-Server im Status „Ausstehend" oder „Abgeschlossen" befinden.

Nachdem die Überprüfung aller ausgewählten Server abgeschlossen ist, kann die Seite Best Practices-Bericht anzeigen geöffnet werden.

In diesem Abschnitt

Einrichten von Überprüfungen im Microsoft Exchange Server Best Practices Analyzer

Netzwerk- und Berechtigungsüberprüfung für Microsoft Exchange Server Best Practices Analyzer.

Konfigurieren von Microsoft Exchange Server Best Practices Analyzer


Einrichten von Überprüfungen im Microsoft Exchange Server Best Practices Analyzer

Einrichten von Überprüfungen im Microsoft Exchange Server Best Practices Analyzer |
 | Siehe auch
Übersicht zu Microsoft Exchange Server Best Practices Analyzer > Überprüfen der Exchange-Organisation mit Microsoft Exchange Server Best Practices Analyzer >

Letztes Änderungsdatum des Themas: 2005-07-08

Beim Starten von Microsoft® Exchange Server Best Practices Analyzer müssen die Parameter für die Überprüfung festgelegt werden. Zunächst muss ausgewählt werden, ob die letzten Aktualisierungen der Regeln für die optimalen Methoden gedownloadet werden sollen. Weitere Informationen zum Suchen nach Aktualisierungen und Downloaden der Datei finden Sie unter Installieren von Microsoft Exchange Server Best Practices Analyzer.

Anschließend müssen Sie eine Aktion auswählen. Wählen Sie auf der Seite Willkommen die Option zum Auswählen von Optionen für eine neue Überprüfung oder die Option zum Auswählen des gewünschten Best Practices-Berichts aus. Wenn Sie einen vorhandenen Bericht anzeigen, können Sie eine Datei aus der Liste der lokal gespeicherten Ausgabedateien auswählen. Anstatt eine lokal gespeicherte Ausgabedatei auszuwählen, können Sie auch eine Ausgabedatei von einem anderen Speicherort importieren. Nachdem eine Ausgabedatei ausgewählt wurde, kann der dazugehörige Bericht angezeigt werden. Weitere Informationen zu Berichten finden Sie unter Grundlegendes zur Ausgabe von Exchange Server Best Practices Analyzer..

Wenn Sie die Option zum Auswählen von Optionen für eine neue Überprüfung auswählen, muss eine Verbindung zum Active Directory®-Verzeichnisdienst hergestellt und eine neue Überprüfung ausgeführt werden. In der Standardeinstellung erkennt der Exchange Server Best Practices Analyzer den nächsten Active Directory-Server. Sie können eine Verbindung mit diesem Server herstellen oder eine Verbindung mit einem anderen Active Directory-Server herstellen, indem Sie den Namen des anderen Servers eingeben.

Exchange Server Best Practices Analyzer verwendet das Konto, unter dem das Tool in der Standardeinstellung ausgeführt wird. Um andere Konten für die Anmeldung bei Active Directory oder bei den Exchange-Servern zu verwenden, klicken Sie auf die Option zum Anzeigen erweiterter Anmeldeoptionen, um die Optionen zu erweitern. Geben Sie im oberen Teil des erweiterten Fensters die Kontoanmeldeinformationen zur Anmeldung bei Active Directory ein. Geben Sie im unteren Teil des erweiterten Fensters die Kontoanmeldeinformationen zur Anmeldung bei den Exchange-Servern ein.

Zum Anmelden bei Active Directory und bei den Exchange-Servern können Sie die gleichen oder unterschiedliche Konten verwenden. Wenn Sie im unteren Teils des erweiterten Fensters den oberen Teil nicht ausfüllen, verwendet Exchange Server Best Practices Analyzer das gleiche Konto, unter dem Exchange Server Best Practices Analyzer ausgeführt wird.

Siehe auch

Konzepte

Installieren von Microsoft Exchange Server Best Practices Analyzer
Berechtigungen für Microsoft Exchange Server Best Practices Analyzer.
Konfigurieren von Microsoft Exchange Server Best Practices Analyzer

Weitere Ressourcen

Grundlegendes zur Ausgabe von Exchange Server Best Practices Analyzer.
Netzwerk- und Berechtigungsüberprüfung für Microsoft Exchange Server Best Practices Analyzer.

© 2007 Microsoft Corporation. Alle Rechte vorbehalten.


Netzwerk- und Berechtigungsüberprüfung für Microsoft Exchange Server Best Practices Analyzer.

Netzwerk- und Berechtigungsüberprüfung für Microsoft Exchange Server Best Practices Analyzer. |
 | Siehe auch
Übersicht zu Microsoft Exchange Server Best Practices Analyzer > Überprüfen der Exchange-Organisation mit Microsoft Exchange Server Best Practices Analyzer >

Letztes Änderungsdatum des Themas: 2005-07-08

Vor dem Starten der Überprüfung führt Microsoft® Exchange Server Best Practices Analyzer eine Netzwerk- und Berechtigungsüberprüfung durch, um sicherzustellen, dass die angegebenen Kontoanmeldeinformationen gültig sind und dass das Tool eine Verbindung mit dem Active Directory-Verzeichnisdienst herstellen kann. Wenn bei einer dieser Überprüfungen ein Fehler auftritt, wird erneut die Seite zum Verbinden mit Active Directory angezeigt, auf der sowohl der Name des Servers, auf dem Active Directory ausgeführt wird, als auch die Anmeldeinformationen für die Anmeldung bei Active Directory und an den Exchange-Servern erneut eingegeben werden können.

Siehe auch

Konzepte

Berechtigungen für Microsoft Exchange Server Best Practices Analyzer.
Konfigurieren von Microsoft Exchange Server Best Practices Analyzer

Weitere Ressourcen

Einrichten von Überprüfungen im Microsoft Exchange Server Best Practices Analyzer

© 2007 Microsoft Corporation. Alle Rechte vorbehalten.


Konfigurieren von Microsoft Exchange Server Best Practices Analyzer

Konfigurieren von Microsoft Exchange Server Best Practices Analyzer |
 | Siehe auch
Übersicht zu Microsoft Exchange Server Best Practices Analyzer > Überprüfen der Exchange-Organisation mit Microsoft Exchange Server Best Practices Analyzer >

Letztes Änderungsdatum des Themas: 2006-10-10

Vor dem Ausführen der Überprüfung müssen Sie die folgenden abschließenden Schritte ausführen:

  1. Legen Sie eine Bezeichnung für die Überprüfung fest.

  2. Legen Sie den Bereich fest.

  3. Legen Sie den Überprüfungstyp fest.

  4. Legen Sie die Netzwerkgeschwindigkeit fest.

Nach dem Festlegen der Bezeichnung, des Bereichs, des Überprüfungstyps und der Netzwerkgeschwindigkeit startet Microsoft® Exchange Server Best Practices Analyzer die Überprüfung.

Festlegen der Bezeichnung für die Überprüfung

Um eine Bezeichnung für die Überprüfung festzulegen, geben Sie auf der Seite zum Starten einer neuen Überprüfung im entsprechenden Eingabefeld eine eindeutige Bezeichnung für die Überprüfung ein. Wenn Sie später einen Bericht anzeigen möchten, können Sie die Berichte an der Bezeichnung erkennen, die Sie in diesem Eingabefeld eingegeben haben.

Es gibt zwei Möglichkeiten, einen vorhandenen Bericht anzuzeigen:

  • Wählen Sie auf der Seite Willkommen die Option zum Auswählen des gewünschten Best Practices-Berichts aus.

  • Wählen Sie im linken Navigationsbereich im Fenster Exchange Server Best Practices Analyzer Tool die Option zum Auswählen einer anzuzeigenden Überprüfung aus.

Festlegen des Bereichs einer Überprüfung

Um den Überprüfungsbereich anzugeben, wählen Sie auf der Seite zum Starten einer neuen Überprüfung die zu überprüfenden Server oder administrativen Gruppen aus.

Drei Bereiche stehen zur Auswahl:

  • Sie können die gesamte Exchange Server-Organisation auswählen.

  • Sie können eine oder mehrere administrative Gruppen auswählen.

  • Sie können einen oder mehrere Server aus einer beliebigen administrativen Gruppe in der Exchange Server-Organisation auswählen.

Auswählen des Überprüfungstyps

Anschließend wählen Sie den Überprüfungstyp aus. Drei Überprüfungstypen stehen zur Auswahl:

  • Zustandsüberprüfung

  • Zustands-/Leistungsüberprüfung

  • Verbindungstest

  • Basislinie

Bei der Zustandsüberprüfung wird eine vollständige Überprüfung durchgeführt. Dabei wird nach Fehlern, Warnungen, vom Standard abweichenden Konfigurationen, aktuellen Änderungen und anderen Konfigurationsinformationen gesucht. Wenn Sie den Zustand Ihrer Exchange Server-Organisation überprüfen oder ein bestimmtes Problem lösen möchten, sollten Sie eine Zustandsüberprüfung durchführen.

Die Zustands-/Leistungsüberprüfung führt zuerst die Zustandsüberprüfung aus und fährt dann damit fort, zwei Stunden lang eine Reihe von Exchange Server-Leistungsindikatoren zu erfassen.

Beim Verbindungstest werden Netzwerkverbindungen und Berechtigungen für alle im Bereich angegebenen Exchange Server überprüft. Führen Sie einen Verbindungstest aus, wenn ein Verdacht auf berechtigungsbedingte Zugriffsprobleme besteht oder in der Topologie Firewalls vorhanden sind. Wenn der Verbindungstest erfolgreich ausgeführt wird, können Sie eine Zustandsüberprüfung durchführen.

Der Verbindungstest wird sehr schnell ausgeführt. Exchange Server Best Practices Analyzer fragt einen Registrierungsparameter und zwei Microsoft WMI-Klassen (Windows® Management Instrumentation) ab. Die erste WMI-Abfrage überprüft den WMI-Repository-Zugriff. Die zweite WMI-Abfrage fragt die Active Directory®-Verzeichnisdienstserver ab, die von Exchange Server verwendet werden. Nach dem Überprüfen aller im Bereich angegebenen Exchange Server überprüft Exchange Server Best Practices Analyzer die Netzwerkverbindungen und Berechtigungen für von Exchange Server verwendete Active Directory-Server.

Bei der Überprüfung Basislinie werden die folgenden Aufgaben ausgeführt:

  • Eigenschaften werden ausgewählt.

  • Für diese Eigenschaften werden Basislinienwerte ausgewählt.

  • Dann werden Server ausgewählt, auf denen diese Eigenschaften verglichen werden sollen.

Mithilfe der Überprüfung Basislinie können Abweichungen von den festgelegten Basislinienwerten ermittelt werden. Der Überprüfungsbericht Basislinie identifiziert alle Eigenschaften auf den ausgewählten Servern, deren Werte sich von den Quellwerten der ausgewählten Eigenschaften unterscheiden, als Basislinienkonflikte.

So wird eine Basislinienüberprüfung ausgeführt

  1. Wählen Sie auf der Seite zum Starten einer neuen Überprüfung im Menü für die Auswahl eines Überprüfungstyps die Option Basislinie aus, und klicken Sie dann auf die Basislinienoptionen.

  2. Wählen Sie im Menü der Basislinienoptionen eine vorhandene Überprüfung aus, oder geben Sie eine neue Bezeichnung ein.

  3. Klicken Sie auf den Pfeil für die Quellwerte, um die Liste der Basislinieneigenschaften zu erweitern.

    • Diese Eigenschaften sind die von der Datei ExBPA.config.xml gesammelten Eigenschaften. Wählen Sie durch Aktivieren oder Deaktivieren der Kontrollkästchen aus, welche Eigenschaften in der Basislinien-Überprüfung verglichen werden sollen. Die Werte der Eigenschaften sind die Standardwerte aus der Datei ExBPA.config.xml. Legen Sie diese Werte in den Textfeldern fest.

  4. Klicken Sie auf den Pfeil zum Testen von Objekten, um die Liste der zu überprüfenden Server zu erweitern.

  5. Wählen Sie alle Server aus, die auf Basislinienkonflikte überprüft werden sollen.

Festlegen der Netzwerkgeschwindigkeit

Nach dem Auswählen des Überprüfungstyps legen Sie die Netzwerkgeschwindigkeit fest. Wählen Sie eine der vier folgenden Optionen aus, um die Netzwerkgeschwindigkeit festzulegen:

  • Fast LAN

  • LAN

  • Fast WAN

  • WAN

Mithilfe der Einstellungen für die Netzwerkgeschwindigkeit können Sie die bis zum Abschluss der Überprüfung erforderliche Zeit abschätzen. Mithilfe der Einstellungen für die Netzwerkgeschwindigkeit können Sie auch den Wert für das Zeitlimit festlegen.

Während der Überprüfung wartet Exchange Server Best Practices Analyzer eine festgelegte Zeit lang auf eine Antwort von einem Server. Wenn innerhalb des festgelegten Zeitlimits keine Antwort empfangen wird, setzt Exchange Server Best Practices Analyzer die Überprüfung fort, um sie abzuschließen, anstatt weiter zu warten. Bei langsameren Netzwerken ist aufgrund längerer Wartezeiten auch das Zeitlimit größer. Es wird empfohlen, für diesen Parameter die langsamste Verbindung in der Topologie auszuwählen, sodass Exchange Server Best Practices Analyzer Zeitlimitüberschreitungen nicht zu früh ermittelt.

Ausführen der Überprüfung

Nachdem alle Optionen für eine Überprüfung festgelegt wurden, können Sie auswählen, ob Sie eine Überprüfung starten oder planen möchten. Wenn Sie die Option zum Starten einer Überprüfung aktivieren, startet Exchange Server Best Practices Analyzer die Überprüfung der Exchange-Organisation sofort. Weitere Informationen finden Sie unter Überprüfen der Exchange-Organisation mit Microsoft Exchange Server Best Practices Analyzer.

Wenn Sie die Option zum Planen einer Überprüfung aktivieren, wird die Seite für das Planen einer Überprüfung angezeigt. Um eine Überprüfung zu planen, müssen Sie zuerst die erforderlichen Sicherheitsanmeldeinformationen eingeben und das Feld für die Aktivierung einer Überprüfung aktivieren. Weitere Informationen zur Eingabe der erforderlichen Sicherheitsanmeldeinformationen finden Sie unter Einrichten von Überprüfungen im Microsoft Exchange Server Best Practices Analyzer.

Anschließend legen Sie die Startzeit fest. Die Startzeit gibt Tag und Uhrzeit für die Ausführung der ersten geplanten Überprüfung an.

Abschließend müssen Sie die Frequenz festlegen. Die Frequenz gibt an, wie oft geplante Überprüfungen ausgeführt werden. Um Exchange Server Best Practices Analyzer zu schließen, klicken Sie auf die Schaltfläche zum Beenden des Tools. Exchange Server Best Practices Analyzer muss nicht ausgeführt werden, um die geplante Überprüfung durchzuführen. Wenn Sie Exchange Server Best Practices Analyzer beenden, werden die geplanten Überprüfungen im Hintergrund am angegebenen Datum zur angegebenen Uhrzeit ausgeführt. Um den Bericht zu einer geplanten Überprüfung anzuzeigen, müssen Sie Exchange Server Best Practices Analyzer neu starten.

Siehe auch

Konzepte

Typen von Ausgabeinformationen

Weitere Ressourcen

Überprüfen der Exchange-Organisation mit Microsoft Exchange Server Best Practices Analyzer

© 2007 Microsoft Corporation. Alle Rechte vorbehalten.


Erweiterte Konfiguration
Übersicht zu Microsoft Exchange Server Best Practices Analyzer > Überprüfen der Exchange-Organisation mit Microsoft Exchange Server Best Practices Analyzer >

Letztes Änderungsdatum des Themas: 2006-10-26

Microsoft® Exchange Server Analyzer verfügt über die folgenden konfigurierbaren Registrierungsparameter:

Speicherort | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
Wert | OpenRelayTest
Typ | REG_DWORD
Beschreibung | Legen Sie den Parameter auf "0x0" fest, wenn Best Practices Analyzer nicht jeden SMTP-Server auf Open Relay-Funktionen überprüfen soll. Wird der Parameter weggelassen, verwendet Best Practices Analyzer den Standardwert "0x1".

Speicherort | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
Wert | OpenRelayTestSender
Typ | REG_SZ
Beschreibung | Legen Sie diesen Parameter auf die SMTP-Adresse fest, die beim Open Relay-Test als "MAIL FROM:"-Adresse verwendet werden soll. Wird der Parameter weggelassen, verwendet Best Practices Analyzer den Standardwert "ExBPA-OpenRelayTest@Fabrikam.com".

Speicherort | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
Wert | TopoCreateTimeoutSecs
Typ | REG_SZ
Beschreibung | Legen Sie diesen Parameter auf die SMTP-Adresse fest, die beim Open Relay-Test als "RCPT TO:"-Adresse verwendet werden soll. Wird der Parameter weggelassen, verwendet Best Practices Analyzer den Standardwert "ExBPA-OpenRelayTest@Fabrikam.com".

Speicherort | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
Wert | SMTPTest
Typ | REG_DWORD
Beschreibung | Legen Sie den Parameter auf "0x0" fest, wenn Best Practices Analyzer nicht jedem überprüften SMTP-Server eine Testnachricht senden soll. Wird der Parameter weggelassen, verwendet Best Practices Analyzer den Standardwert "0x1".

Speicherort | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
Wert | SMTPTestSender
Typ | REG_SZ
Beschreibung | Legen Sie diesen Parameter auf die SMTP-Adresse fest, die beim E-Mail-Akzeptanztest als "MAIL FROM:"-Adresse verwendet werden soll. Wird der Parameter weggelassen, verwendet Best Practices Analyzer den Standardwert "ExBPA-MailAcceptTest@Fabrikam.com".

Speicherort | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
Wert | T SMTPTestRecipient
Typ | REG_SZ
Beschreibung | Legen Sie diesen Parameter auf die SMTP-Adresse fest, die beim E-Mail-Akzeptanztest als "RCPT TO:"-Adresse verwendet werden soll. Wird der Parameter weggelassen, verwendet Best Practices Analyzer standardmäßig das vom SMTP-Dienst festgelegte Postmasterkonto.


Grundlegendes zur Ausgabe von Exchange Server Best Practices Analyzer.
Übersicht zu Microsoft Exchange Server Best Practices Analyzer >

Letztes Änderungsdatum des Themas: 2006-02-08

Im Bericht zu Microsoft® Exchange Server Best Practices Analyzer wird die Analyse der in der Überprüfung der Exchange-Organisation gesammelten Daten angezeigt. Sie haben die Wahl zwischen drei Arten von Berichten, Listenberichten, Strukturberichten und sonstigen Berichten.

  • Zu den Listenberichten gehören:

    • Critical Issues (Kritische Probleme)

    • All Issues (Alle Probleme)

    • Non-Default Settings (Vom Standard abweichende Einstellungen)

    • Recent Changes (Aktuelle Änderungen)

    • Baseline (Basislinie)

    • Informational Items (Informationselemente)

  • Zu den Strukturberichten gehören:

    • Detailed View (Detailansicht)

    • Summary View (Zusammenfassungsansicht)

  • Sonstige Berichte

    • Hidden Items (Ausgeblendete Elemente)

    • Run-Time Log (Laufzeitprotokoll)

Listenberichte

Als Standardansicht wird die Liste der schwerwiegenden Probleme verwendet. In der Liste Critical Issues werden nur gefundene Fehler angezeigt. Fehler sind kritische Probleme, wenn sie sich unmittelbar auf die Leistung und Verfügbarkeit von Exchange Server auswirken. In der Liste All Issues werden Fehler, Warnungen und Verletzungen von Best Practices angezeigt. In der Liste Non-Default Settings werden Konfigurationsänderungen angezeigt, die seit der Installation des Exchange Server-Produkts am Server vorgenommen wurden. In der Liste Recent Changes werden Konfigurationsänderungen angezeigt, die innerhalb der letzten fünf Tage am Server vorgenommen wurden. Hierzu gehört auch die Installation von Service Packs und anderen Aktualisierungen. In der Liste Baseline werden Konfigurationsabweichungen zwischen Knoten in einem Cluster angezeigt.

Strukturberichte

In der Detailed View werden alle Konfigurationseinstellungen angezeigt, die von Exchange Server Analyzer erfasst wurden. In der Summary View wird eine hierarchische Darstellung aller in der Exchange-Umgebung gefundenen Probleme angezeigt.

Sonstige Berichte

Im Hidden Items-Bericht werden die Probleme angezeigt, die der Exchange-Administrator in den anderen Berichten von Exchange Server Analyzer ausgeblendet („maskiert") hat. Elemente dieser Liste können in die anderen Berichte aufgenommen werden, sofern sie „demaskiert" (eingeblendet) werden. Im Run-Time Log-Bericht wird eine Sammlung von „Milestone"-Informationen sowie alle Fehler, die während des Erfassungsprozesses zurückgegeben wurden, angezeigt.

In den Listen Critical Issues, All Issues und Non-Default Settings können Sie auf jede/n Fehler oder Warnung klicken, um eine Erklärung dazu anzuzeigen. Wenn Sie anschließend auf die Option für weitere Informationen zu diesem Problem und seiner Lösung klicken, erhalten Sie ausführlichere Informationen.

Hinweis:
Die XML-Ausgabedatendatei und die Protokolldatei der Überprüfung sind unter <Systemlaufwerk>\Dokumente und Einstellungen\<Benutzer>\Anwendungsdaten\Microsoft\ExBPA gespeichert.

In diesem Abschnitt

Typen von Ausgabeinformationen

Behandeln und Ausblenden von Problemen

Anzeigen eines vorherigen Berichts zum Microsoft Exchange Server Best Practices Analyzer.


Typen von Ausgabeinformationen

Typen von Ausgabeinformationen |
 | Siehe auch
Übersicht zu Microsoft Exchange Server Best Practices Analyzer > Grundlegendes zur Ausgabe von Exchange Server Best Practices Analyzer. >

Letztes Änderungsdatum des Themas: 2006-09-29

Der Bericht von Microsoft® Exchange Server Best Practices Analyzer enthält sechs Typen von Informationen:

  • Fehler

  • Warnung

  • Nicht dem Standard entsprechende Konfiguration

  • Aktuelle Änderung

  • Basislinienkonflikt

  • Optimale Methode

  • Informationen

Fehler

Ein Fehler zeigt ein schwerwiegendes Problem an, zu dessen Behebung eine Änderung erforderlich ist. Zum Beispiel liegt ein Fehler vor, wenn eine Instanz eines Servers inaktiv oder ein Server nicht erreichbar ist.

Fehler werden in den folgenden Berichten angezeigt:

  • Liste der schwerwiegenden Probleme

  • Vollständige Problemliste

  • Liste in der ausführlichen Ansicht

  • Vollständige Problemliste in der ausführlichen Ansicht

Wenn ein Fehler deaktiviert wird, zeigt Exchange Server Best Practices Analyzer den Fehler in der Liste der zurückgestellten Probleme an.

Exchange Server Best Practices Analyzer kennzeichnet einen Fehler durch ein rotes „X" (Abbildung 1).

Abbildung 1 Fehlersymbol

Symbol für den Fehlerstatus

Warnung

Eine Warnung gibt ein Problem an, das nicht der empfohlenen optimalen Methode entspricht. Zum Beheben des Problems muss möglicherweise eine Änderung vorgenommen werden, oder es handelt sich um ein bekanntes Problem, für das keine Änderung in der Exchange Server-Organisation erforderlich ist. Zum Beispiel stellt ein Dienst, der nicht auf einem Server gestartet wurde, eine Warnung dar.

Warnungen werden in den folgenden Berichten angezeigt:

  • Vollständige Problemliste

  • Liste in der ausführlichen Ansicht

  • Vollständige Problemliste in der ausführlichen Ansicht

Wenn eine Warnung deaktiviert wird, zeigt Exchange Server Best Practices Analyzer die Warnung in der Liste der zurückgestellten Probleme an.

Exchange Server Best Practices Analyzer kennzeichnet eine Warnung durch ein gelbes Warnsymbol (Abbildung 2).

Abbildung 2 Warnsymbol

Symbol für Warnung, gelbes Dreieck mit schwarzem Ausrufungszeichen

Nicht dem Standard entsprechende Konfiguration

Eine nicht dem Standard entsprechende Konfiguration gibt eine Einstellung an, die in einen anderen Wert als den Standardwert geändert wurde. Wenn Exchange Server Best Practices Analyzer ermittelt, dass eine nicht dem Standard entsprechende Konfiguration einem Fehler oder einer Warnung entspricht, kennzeichnet Exchange Server Best Practices Analyzer die nicht dem Standard entsprechende Konfiguration als solche und mit dem entsprechenden Fehler- oder Warnsymbol an einer anderen Position im Bericht.

Nicht dem Standard entsprechende Konfigurationen werden in den folgenden Berichten angezeigt:

  • Vollständige Problemliste

  • Liste in der ausführlichen Ansicht

  • Vollständige Problemliste in der ausführlichen Ansicht

Wenn eine nicht dem Standard entsprechende Konfiguration deaktiviert wird, zeigt Exchange Server Best Practices Analyzer die nicht dem Standard entsprechende Konfiguration in der Liste der zurückgestellten Probleme an.

Exchange Server Best Practices Analyzer kennzeichnet nicht dem Standard entsprechende Konfigurationen durch ein Zeigersymbol (Abbildung 3).

Abbildung 3 Symbol für eine nicht dem Standard entsprechende Konfiguration

Symbol für nicht standardmäßige Eigenschaften

Aktuelle Änderung

Eine aktuelle Änderung bezieht sich auf eine Änderung, die in den letzten 5 Tagen vorgenommen wurde. Exchange Server Best Practices Analyzer kann nur solche Einstellungen als aktuelle Änderung identifizieren, die die Eigenschaft für Datum und Uhrzeit der letzten Änderung aufweisen. Wenn Exchange Server Best Practices Analyzer ermittelt, dass eine aktuelle Einstellungsänderung einem Fehler, einer Warnung oder einer nicht dem Standard entsprechenden Konfiguration entspricht, kennzeichnet Exchange Server Best Practices Analyzer die aktuelle Einstellungsänderung als solche und mit dem entsprechenden Symbol für Fehler, Warnungen oder nicht dem Standard entsprechende Konfigurationen an einer anderen Position im Bericht.

Aktuelle Änderungen werden in den folgenden Berichten angezeigt:

  • Vollständige Problemliste

  • Liste in der ausführlichen Ansicht

  • Detailansicht - Vollständige Liste der Probleme

Wenn eine aktuelle Änderung deaktiviert wird, zeigt Exchange Server Best Practices Analyzer die aktuelle Änderung in der Liste der zurückgestellten Probleme an.

Exchange Server Best Practices Analyzer kennzeichnet eine aktuelle Änderung durch ein Durchstreichungssymbol (Abbildung 4).

Abbildung 4 Symbol für eine aktuelle Änderung

Symbol für kürzlich vorgenommene Änderung

Basislinienkonflikt

Ein Basislinienkonflikt weist auf eine Einstellung hin, deren Wert von der Einstellung auf dem Basisserver abweicht. Zum Anzeigen von Basislinienkonflikten müssen Sie eine Basislinienüberprüfung durchführen. Wenn Exchange Server Best Practices Analyzer ermittelt, dass ein Basislinienkonflikt einem Fehler, einer Warnung oder einer nicht dem Standard entsprechenden Konfiguration entspricht, kennzeichnet Exchange Server Best Practices Analyzer den Basislinienkonflikt als solchen und mit dem entsprechenden Symbol für Fehler, Warnungen oder nicht dem Standard entsprechende Konfigurationen.

Basislinienkonflikte werden in den folgenden Berichten angezeigt:

  • Vollständige Problemliste

  • Liste in der ausführlichen Ansicht

  • Vollständige Problemliste in der ausführlichen Ansicht

Wenn ein Basislinienkonflikt deaktiviert wird, zeigt Exchange Server Best Practices Analyzer den Basislinienkonflikt in der Liste der zurückgestellten Probleme an.

Exchange Server Best Practices Analyzer kennzeichnet einen Basislinienkonflikt durch das Symbol der Zwischenablage und durch ein Häkchen (Abbildung 5).

Abbildung 5 Symbol für einen Basislinienkonflikt

Symbol für Baselinebericht in ExBPA

Optimale Methode

Die Meldung Optimale Methode weist auf eine Einstellung hin, die nicht der optimalen Methode entspricht. Die Meldung „Optimale Methode" stellt keine Warnung dar, da sie die Gesamtstabilität der Exchange Server-Organisation nicht beeinträchtigt. Die Meldung „Optimale Methode" enthält empfohlene Aktionen. Wenn Exchange Server Best Practices Analyzer ermittelt, dass die Meldung „Optimale Methode" einer nicht dem Standard entsprechenden Konfiguration oder einer aktuellen Änderung entspricht, kennzeichnet Exchange Server Best Practices Analyzer die Meldung „Optimale Methode" als solche und mit dem entsprechenden Symbol für nicht dem Standard entsprechende Konfigurationen oder aktuelle Änderungen an einer anderen Position im Bericht.

Meldungen zu optimalen Methoden werden in den folgenden Berichten angezeigt:

  • Vollständige Problemliste

  • Liste in der ausführlichen Ansicht

  • Vollständige Problemliste in der ausführlichen Ansicht

Wenn eine Meldung „Optimale Methode" deaktiviert wird, zeigt Exchange Server Best Practices Analyzer das Element der optimalen Methode in der Liste der zurückgestellten Probleme an.

Exchange Server Best Practices Analyzer kennzeichnet eine Meldung „Optimale Methode" durch ein blaues Ausrufezeichen (Abbildung 6).

Abbildung 6 Symbol für eine optimale Methode

Symbol für Best Practice-Warnung

Informationen

Die Meldung Informationen kennzeichnet Informationen, die Exchange Server Best Practices Analyzer nicht in den anderen fünf Berichttypen bereitstellt. Zum Beispiel kann mit einem Informationselement die Anzahl der Exchange Server-Objekte im Active Directory®-Verzeichnisdienst angegeben werden.

Informationsmeldungen werden in den folgenden Berichten angezeigt:

  • Liste in der ausführlichen Ansicht

  • Vollständige Problemliste in der ausführlichen Ansicht

Exchange Server Best Practices Analyzer kennzeichnet ein Informationselement durch den Kleinbuchstaben „i" (Abbildung 7).

Abbildung 7 Symbol für Informationen

Symbol für "Informationen"

Siehe auch

Konzepte

Konfigurieren von Microsoft Exchange Server Best Practices Analyzer

Weitere Ressourcen

Behandeln und Ausblenden von Problemen

© 2007 Microsoft Corporation. Alle Rechte vorbehalten.


Behandeln und Ausblenden von Problemen
Übersicht zu Microsoft Exchange Server Best Practices Analyzer > Grundlegendes zur Ausgabe von Exchange Server Best Practices Analyzer. >

Letztes Änderungsdatum des Themas: 2006-02-08

Nach dem Ausführen von Microsoft® Exchange Server Best Practices Analyzer in der Exchange-Organisation können Sie die zu lösenden Probleme im Bericht auflisten. Wenn Sie auf ein Problem klicken, werden eine Erklärung und drei Optionen angezeigt:

  • Klicken Sie auf die erste Option, um weitere Informationen zum Problem und seiner Lösung zu erhalten.

  • Klicken Sie auf die zweite Option, um das Problem für diesen Server auszublenden.

  • Klicken Sie auf die dritte Option, um das Problem für alle Server auszublenden. Probleme, die sich in der Liste Hidden Issues (Ausgeblendete Probleme) befinden, werden in keiner der Listen Critical Issues (Kritische Probleme) oder All Issues (Alle Probleme) für diesen Bericht aufgeführt bzw. in keinem anderen angezeigten Bericht. Zum Anzeigen der maskierten Probleme wechseln Sie zur Liste Hidden Issues. In der Liste Hidden Issues können Sie die Probleme wieder „demaskieren" (einblenden), so dass sie wieder in den Listen Critical Issues und All Issues angezeigt werden.

Exchange Server Best Practices Analyzer nimmt beim Lösen von Problemen keine Änderungen an der Exchange-Organisation vor. Es werden lediglich Informationen zum Lösen von Problemen angezeigt.

In diesem Abschnitt

Typen von Ausgabeinformationen


Anzeigen eines vorherigen Berichts zum Microsoft Exchange Server Best Practices Analyzer.

Anzeigen eines vorherigen Berichts zum Microsoft Exchange Server Best Practices Analyzer. |
 | Siehe auch
Übersicht zu Microsoft Exchange Server Best Practices Analyzer > Grundlegendes zur Ausgabe von Exchange Server Best Practices Analyzer. >

Letztes Änderungsdatum des Themas: 2005-07-08

Anstatt eine neue Überprüfung auszuführen, können Sie mit Microsoft® Exchange Server Best Practices Analyzer auch Berichte einer früheren Überprüfung anzeigen.

So zeigen Sie einen früheren Bericht an

  1. Starten Sie Exchange Server Best Practices Analyzer, indem Sie ExBPA.exe ausführen.

  2. Wählen Sie aus, ob die neuesten Regeln gedownloadet werden sollen.

  3. Wählen Sie auf der Seite Willkommen die Option zum Auswählen des gewünschten Best Practices-Berichts aus.

  4. Wählen Sie in der Liste der lokal gespeicherten Berichte den Bericht aus, der angezeigt werden soll.

    Das Tool erstellt die Liste aus den unter <Systemlaufwerk>\Dokumente und Einstellungen\<Benutzer>\Anwendungsdaten\Microsoft\ExBPA gespeicherten Dateien. Wenn Sie auf einen Bericht klicken, zeigt das Tool weitere Informationen zu Größe und Bereich des jeweiligen Berichts an. Klicken Sie auf die Option zum Anzeigen des Berichts, um den vollständigen Bericht anzuzeigen.

    Wenn Sie in der oberen rechten Ecke der Seite auf die Option zum Importieren des Berichts klicken, werden auch Berichte aus einem anderen Speicherort importiert. Wenn die Version der Datei ExBPA.Config.xml nicht mit der Version übereinstimmt, mit der die Daten im importierten Bericht gesammelt wurden, überprüft das Tool die importierte Datei nach dem Importieren möglicherweise erneut.

  5. Zeigen Sie den Bericht zu Exchange Server Best Practices Analyzer an.

Siehe auch

Weitere Ressourcen

Grundlegendes zur Ausgabe von Exchange Server Best Practices Analyzer.

© 2007 Microsoft Corporation. Alle Rechte vorbehalten.


Einfluss von Microsoft Exchange Server Best Practices Analyzer auf die Leistung.

Einfluss von Microsoft Exchange Server Best Practices Analyzer auf die Leistung. |
 | Siehe auch
Übersicht zu Microsoft Exchange Server Best Practices Analyzer >

Letztes Änderungsdatum des Themas: 2005-07-08

Microsoft® Exchange Server Best Practices Analyzer kann die Leistung folgender Computer in einer Exchange-Organisation beeinflussen:

  • Die des Computers, auf dem Exchange Server Best Practices Analyzer ausgeführt wird.

  • Die des Servers, auf dem der Active Directory®-Verzeichnisdienst ausgeführt wird.

  • Die der Exchange-Server, auf die das Tool zugreift.

Leistungsdaten des Computers mit Exchange Server Best Practices Analyzer

Folgende Ressourcen werden auf dem Computer mit Exchange Server Best Practices Analyzer verwendet:

  • 5 bis 10 MB RAM pro analysierten Server

  • 50 bis 75 Prozent der Prozessorleistung während der Überprüfung der Exchange-Organisation

  • 0,5 bis 2 MB Speicherplatz für XML-Daten (Extensible Markup Language)

Weitere Informationen zum Auswählen des Computers, auf dem Exchange Server Best Practices Analyzer installiert und ausgeführt werden soll, finden Sie unter Installieren von Microsoft Exchange Server Best Practices Analyzer.

Leistungsdaten für den Active Directory-Server

Folgende Ressourcen werden auf dem Active Directory-Server mit Exchange Server Best Practices Analyzer verwendet:

  • 25 bis 50 Prozent der Prozessorleistung während des Zugriffs auf den Active Directory-Server

Hinweis:
Das Tool greift sporadisch auf den Active Directory-Server zu, wobei ein Zugriffsintervall im Durchschnitt 10 bis 15 Sekunden dauert. In sehr großen Exchange-Organisationen ist das Intervall größer.

Leistung auf den Exchange-Servern

In der Zeit, in der die Organisation von Exchange Server Best Practices Analyzer überprüft wird, sollte keine stärkere Leistungsbeeinträchtigung auf den Exchange-Servern festgestellt werden können.

Hinweis:
Die vom Tool zum Sammeln der Daten von einem Exchange-Server benötigte Zeit variiert je nach Last auf den Exchange-Servern und nach Netzwerkgeschwindigkeit. In langsamen Netzwerken benötigt das Tool eine Stunde oder länger zum Sammeln der Daten. In schnellen Netzwerken benötigt das Tool weniger als zehn Minuten zum Sammeln der Daten.

Siehe auch

Konzepte

Installieren von Microsoft Exchange Server Best Practices Analyzer

© 2007 Microsoft Corporation. Alle Rechte vorbehalten.


Verwenden des Befehlszeilenprogramms Microsoft Exchange Server Best Practices Analyzer.

Verwenden des Befehlszeilenprogramms Microsoft Exchange Server Best Practices Analyzer. |
 | Siehe auch
Übersicht zu Microsoft Exchange Server Best Practices Analyzer >

Letztes Änderungsdatum des Themas: 2005-07-08

Von Microsoft® Exchange Server Best Practices Analyzer ist auch eine Befehlszeilenprogramm-Version verfügbar. ExBPACmd.exe bildet die Programmdatei für das Befehlszeilenprogramm und wird beim Installieren der GUI-Version (grafische Benutzeroberfläche) im Verzeichnis <Systemlaufwerk>\Programme\ExBPA installiert. In einigen Fällen bevorzugen Sie möglicherweise das Befehlszeilenprogramm gegenüber der GUI-Version. Beispielsweise können Sie das Befehlszeilenprogramm verwenden, um ein Skript zum Ausführen geplanter Überprüfungen zu erstellen. Der technische Support von Microsoft empfiehlt Ihnen zum Beheben von Problemen die Ausführung des Befehlszeilenprogramms.

Syntax für ExBPACmd.exe

Verwendung: ExBPACmd.exe [-cfg <Konfigurations-XML>] [-dat <Daten-XML>] [-d <Domänencontrollername>] [-n <Name>] [-u <Kontext> <[Domäne\]Benutzer> <Kennwort | *> ...] [-rs <Bereich> <sub1> ...] [-rc <Kategorie>,...] [-rl <Ebene>] [-th <Max. Anzahl Threads>] [-to <Timeout>] [-a] [-c] [-e] [-?]

-cfg: Gibt die XML-Konfigurationsdatei an, die die abzurufenden Einstellungen bestimmt. ExBPA.Config.xml bildet den Standardwert.

-dat: Gibt die zu verwendende XML-Datendatei an. Wenn Sie einen XML-Datendateinamen angeben, der sich nicht im aktuellen Verzeichnis befindet, wird der angegebene Dateiname für die Ausgabedatei verwendet. Wenn Sie einen vorhandenen XML-Datendateinamen angeben und eine Analyseüberprüfung ausgeführt wird, liest das Tool die in der angegeben Datei gesammelten Daten, analysiert diese und überschreibt die angegebene Datei mit der Ausgabe aus der Überprüfung. Wenn Sie einen vorhandenen XML-Datendateinamen angeben und eine Sammelüberprüfung ausgeführt wird, überschreibt das Tool die angegebene Datei mit der Ausgabe aus der Überprüfung.

Der Standardwert beim Ausführen einer Analyseüberprüfung ist output.<ts>.xml, dabei bildet <ts> den Zeitstempel im aktuellen Verzeichnis. Der Standardwert beim Ausführen einer Sammelüberprüfung ist output.<ts> XML, dabei ist <ts> ein neuer Zeitstempel.

-d: Gibt den Domänencontroller an, der für den Zugriff auf den Active Directory®-Verzeichnisdienst verwendet wird. In der Standardeinstellung wird der nächste Active Directory-Server verwendet.

-n: Gibt einen Anzeigenamen für den Kunden an, dessen Topologie gerade vom Tool überprüft wird.

-u: Bietet separate Anmeldeinformationen pro Kontext.

Gültige Benutzerkontexte: ADLOGON für Anmeldeinformationen zum Anmelden bei Active Directory oderEXLOGON für Anmeldeinformationen zum Anmelden an den Exchange-Servern.

-rs: Schränkt die Überprüfung ein, sodass nur Objekte in die angegebenen Bereiche aufgenommen werden. Die <sub>-Felder bilden die Werte für den angegebenen Bereich. Wenn Sie die Option -rs nicht verwenden, umfasst die Überprüfung die gesamte Exchange-Organisation. Wenn Sie die Option -rs verwenden, kann die Überprüfung mithilfe von administrativen Gruppen oder von Servern eingeschränkt werden. Sie können eine oder mehrere administrative Gruppen und einen oder mehrere Server angeben.

Gültige Bereiche: AdminGroup, Server

-rc: Schränkt die Überprüfung ein, sodass nur Einstellungen und Objekte umfasst werden, die den angegebenen Kategorien entsprechen. Die XML-Konfigurationsdatei definiert Kategorien für Einstellungen und Objekte. Wenn Sie die Option -rc verwenden, um Überprüfungen auf eine Kategorie zu beschränken, umfasst die Überprüfung nur die Einstellungen, bei denen diese Kategorie definiert ist. Mithilfe dieser Option können mehrere Kategorien einbezogen werden.

Die gültigen Kategorien, die mit der Option -rc verwendet werden können, variieren möglicherweise je nach Version der XML-Konfigurationsdatei. Um die Kategorien zu bestimmen, die für die Version Ihrer XML-Konfigurationsdatei gültig sind, führen Sie ExBPACmd.exe -? aus.

-rl: Schränkt die Überprüfung ein, sodass nur Einstellungen und Objekte der angegebenen Detailebene oder weniger einbezogen werden. Die XML-Konfigurationsdatei definiert die Detailebenen für Einstellungen und Objekte. Der Standardwert ist 4.

Die gültigen Ebenen, die mit der Option -rl verwendet werden, variieren möglicherweise je nach Version der XML-Konfigurationsdatei. Um die Ebenen zu bestimmen, die für die Version Ihrer XML-Konfigurationsdatei gültig sind, führen Sie ExBPACmd.exe -? aus.

-th: Legt die maximale Anzahl der gleichzeitig ausgeführten Threads fest. Der Standardwert ist 25.

-to: Legt die Standardwartezeit (in Sekunden) fest, die das Tool einhält, um Daten von einem Server in der Exchange-Organisation zu sammeln. Der Standardwert beträgt 300 Sekunden.

-a: Analysiert die XML-Datendatei mithilfe der Regeln aus der XML-Konfigurationsdatei. Diese Option kann durch Angabe der XML-Datei zum Analysieren einer vorhandenen Ausgabedatei verwendet werden, die eine Sammelüberprüfung darstellt. Diese Option kann auch verwendet werden, um Daten für eine neue Überprüfung zu sammeln und zu analysieren, indem entweder eine nicht im aktuellen Verzeichnis vorhandene oder überhaupt keine XML-Datendatei angegeben wird.

-c: Sammelt die Daten aus der Exchange-Organisation, die in der XML-Konfigurationsdatei angegeben wird. Die Daten werden mithilfe der Regeln aus der XML-Konfigurationsdatei vom Tool lediglich gesammelt, nicht analysiert. Wenn weder -a (analyze) noch -c (collect) angegeben werden, sind diese Optionen in der Standardeinstellung aktiviert.

-e: Gibt an, dass die Werte der Einstellungen, die in der XML-Konfigurationsdatei mit „NotForExport" gekennzeichnet sind, vom Tool entfernt werden sollen.

-? Zeigt Syntaxinformationen an.

Siehe auch

Weitere Ressourcen

Überprüfen der Exchange-Organisation mit Microsoft Exchange Server Best Practices Analyzer

© 2007 Microsoft Corporation. Alle Rechte vorbehalten.


Microsoft Exchange Server Analyzer-Tools - Artikel

Letztes Änderungsdatum des Themas: 2006-10-06

Die Artikel in diesem Abschnitt entsprechen den Regeln und Meldungen, die von den folgenden Microsoft® Exchange Analyzer-Tools generiert werden:

  • Exchange Best Practices Analyzer

  • Exchange-Problembehandlungs-Assistent

Der Exchange-Problembehandlungs-Assistent bietet die folgenden Funktionen:

  • Exchange-Leistungsproblembehandlung

  • Exchange-Datenbankproblembehandlung

  • Exchange-Datenbankwiederherstellungs-Verwaltung

  • Exchange-Nachrichtenübermittlungs-Problembehandlung

In jedem Artikel wird genau ein Fehler, eine Warnmeldung oder eine Nachricht über eine von der Standardkonfiguration abweichende Konfiguration beschrieben, die von den Exchange Server Analyzer-Tools u. U. erkannt wird.

Die Microsoft Exchange Analyzers-Webseite unter http://go.microsoft.com/fwlink/?linkid=34707 enthält Downloads für die aktuellen Versionen von Exchange Best Practice Analyzer und dem Exchange-Problembehandlungs-Assistenten. Außerdem finden Sie auf der Seite Informationen zu Systemanforderungen und einen Link zu einer Newsgroup zur Diskussion über Analyzer.

Wenn Sie in Ihrer Systemumgebung die automatische Aktualisierungsfunktion für Exchange Best Practices nicht nutzen können, gehen Sie zur Microsoft Exchange Best Practices Analyzer-Webupdatepack-Website unter http://go.microsoft.com/fwlink/?linkid=34290. Hier können Sie die aktuellste Konfiguration und Hilfedateien herunterladen.

Hinweis:
Wenn die Updates automatisch bereitgestellt werden, ist dieser Download nicht erforderlich.


Active Directory
Microsoft Exchange Server Analyzer-Tools - Artikel >

Letztes Änderungsdatum des Themas: 2005-11-17

Die Artikel in diesem Abschnitt enthalten ausführliche Informationen über die von Microsoft® Exchange Server Analyzer in Bezug auf den Active Directory®-Verzeichnisdienst durchgeführten Auswertungen. Darüber hinaus werden Aktionen beschrieben, die Sie ausführen können, um Fehler, Warnungen und vom Standard abweichende Konfigurationen im Zusammenhang mit Active Directory beheben zu können, die von Microsoft Exchange Server Analyzer gefunden wurden.


Active Directory Connector-Server ist inaktiv oder nicht erreichbar.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer liest mithilfe von Remoteprozeduraufrufen (RPCs) den Zeichenfolgenwert CurrentVersion des folgenden Registrierungsschlüssels auf dem ADC-Server (Active Directory Connector):

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Auf einem Computer, auf dem Microsoft Windows® 2000 Server ausgeführt wird, ist der erwartete Wert für die Zeichenfolge CurrentVersion 5.0. Auf einem Computer, auf dem Microsoft Windows Server™ 2003 ausgeführt wird, ist der erwartete Wert 5.2.

Wenn Microsoft Exchange Server Analyzer den Registrierungswert aus einem beliebigen Grund nicht lesen kann, wird ein Fehler angezeigt.

So berichtigen Sie diesen Fehler

  1. Stellen Sie sicher, dass der ADC-Server gestartet wurde und mit dem Netzwerk verbunden ist.

  2. Verwenden Sie den Befehl PING, um festzustellen, ob eine Verbindung mit dem ADC-Server hergestellt werden kann.

  3. Wenn eine Firewall vorhanden ist, überprüfen Sie, ob die RPC-Anschlüsse blockiert sind.

  4. Stellen Sie sicher, dass der Dienst Remoteregistrierung auf dem ADC-Server gestartet wurde.

  5. Überprüfen Sie die Berechtigungen für das Konto, mit dem Microsoft Exchange Server Analyzer ausgeführt wird, um sicherzustellen, dass es über ausreichende Berechtigungen zum Lesen der Registrierung auf dem ADC-Server verfügt.

Weitere Informationen zum Behandeln von Problemen mit der Netzwerkverbindung finden Sie im:

  • Microsoft Knowledge Base-Artikel 325487 „Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

  • „Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" (http://go.microsoft.com/fwlink/?LinkId=56285)


Active Directory Connector-Server führt keine Verbindungsvereinbarungen aus und ist bald zu entfernen.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert für das Attribut msExchChildSyncAgreements zu bestimmen, der die auf dem ADC-Server (Active Directory Connector) ausgeführten Verbindungsvereinbarungen darstellt. Bei diesem Attribut handelt es sich um eine mehrwertige Zeichenfolge, die auf das folgende Active Directory-Objekt festgelegt ist: CN=Active Directory Connector (ServerName),CN=Exchange Settings,CN=ServerName,CN=Servers,CN=SiteName,CN=Sites,CN=Configuration,DC=Domain,DC=com

Microsoft Exchange Server Analyzer ruft die Anzahl der Einträge in diesem Attribut ab. Die Anzahl 0 zeigt an, dass keine Verbindungsvereinbarungen ausgeführt werden, und es wird eine Warnung angezeigt.

Wenn festgestellt wird, dass alle erforderlichen Verbindungsvereinbarungen auf anderen ADC-Servern ausgeführt werden, muss der ADC-Dienst auf diesem Server entweder entfernt oder deaktiviert werden. Beim Ausführen des ADC-Dienstes ohne Verbindungsvereinbarungen entstehen keine Probleme. Es wird jedoch als optimale Vorgehensweise empfohlen, nur erforderliche Dienste auszuführen. Daher muss entweder der ADC-Dienst deaktiviert oder vom ADC-Server deinstalliert werden.

So beheben Sie diese Warnmeldung

  1. Um den ADC-Dienst auf dem Server zu deaktivieren, auf dem er ausgeführt wird, klicken Sie mit der rechten Maustaste auf dem Desktop auf Arbeitsplatz, und klicken Sie dann auf Verwalten.

  2. Erweitern Sie den Knoten Dienste und Anwendungen, und klicken Sie dann auf den Knoten Dienste.

  3. Klicken Sie mit der rechten Maustaste im rechten Bereich auf Microsoft Active Directory Connector, und klicken Sie dann auf Eigenschaften.

  4. Ändern Sie den Starttyp in Deaktiviert. Beim nächsten Starten des Computers wird der ADC-Dienst nicht gestartet.

  5. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.

Sie können die Microsoft Exchange 2000 Server- oder Exchange Server 2003-CD verwenden, um den ADC-Dienst zu deinstallieren. Gehen Sie zum Ordner \ADC\I386, und doppelklicken Sie auf das Programm Setup.exe. Folgen Sie den Eingabeaufforderungen, um den ADC-Dienst zu deinstallieren.

Weitere Informationen zu Active Directory Connector finden Sie in den folgenden Microsoft Support-Webcasts:

  • „Support Webcast: Introduction to the Active Directory Connector" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325300)

  • „Support Webcast: Microsoft Advanced Active Directory Connector" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325221)

  • Weitere Informationen zum Installieren und Konfigurieren von Active Directory Connector finden Sie im Knowledge Base-Artikel 312632, „SO WIRD'S GEMACHT: Installation und Konfiguration des Active Directory Connectors in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=312632).


Der Active Directory Connector-Server führt das neuste Service Pack für Windows 2000 Server nicht aus
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_OperatingSystem ab, um den Wert des Schlüssels ServicePackMajorVersion auf dem ADC-Server (Active Directory Connector) zu bestimmen. Microsoft Exchange Server Analyzer untersucht auch den folgenden Registrierungseintrag, um die Windows-Version zu bestimmen, die auf dem ADC-Server ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Wenn Microsoft Exchange Server Analyzer ermittelt, dass auf dem ADC-Server ein Microsoft Windows 2000-Betriebssystem ausgeführt wird, aber nicht Service Pack 4 für Windows 2000 Server, wird eine Warnung angezeigt.

Microsoft empfiehlt als optimale Vorgehensweise, die neuesten Service Packs für die gesamte Software in der Exchange-Bereitstellung auszuführen, einschließlich der ADC-Server.

So beheben Sie diesen Fehler

  1. Aktualisieren Sie alle ADC-Server und andere Server, auf denen ein Windows 2000 Server-Betriebssystem ausgeführt wird, auf Service Pack 4, und wenden Sie die neuesten Hotfixes und Updates von Windows Update an.

  2. Aktualisieren Sie alle anderen Exchange Server-Computer, auf denen ein Windows 2000 Server-Betriebssystem ausgeführt wird, mit den neuesten Service Packs und Rollups.

Weitere Informationen zum Erwerb und zur Installation von Service Packs für Windows 2000 Server-Betriebssysteme finden Sie unter http://go.microsoft.com/fwlink/?LinkId=18353.

Weitere Informationen zum Erwerb und zur Installation von Service Packs und Rollups für Exchange Server finden Sie unter http://go.microsoft.com/fwlink/?LinkId=21573.


Active Directory Connector-Server ist möglicherweise überlastet.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert für das Attribut msExchChildSyncAgreements zu bestimmen, der die auf dem ADC-Server (Active Directory Connector) ausgeführten Verbindungsvereinbarungen darstellt. Bei diesem Attribut handelt es sich um eine mehrwertige Zeichenfolge, die auf das folgende Active Directory-Objekt festgelegt ist: CN=Active Directory Connector (ServerName),CN=Exchange Settings,CN=ServerName,CN=Servers,CN=SiteName,CN=Sites,CN=Configuration,DC=Domain,DC=com

Microsoft Exchange Server Analyzer ruft die Anzahl der Einträge in diesem Attribut ab. Wenn die Anzahl mehr als 80 beträgt, wird eine Warnung angezeigt.

Zum Ausführen werden weniger als 80 Verbindungsvereinbarungen pro ADC-Server empfohlen. Wenn es zusätzliche ADC-Server gibt, die nicht als Host für die maximal empfohlene Anzahl an Verbindungsvereinbarungen dienen, verschieben Sie einige der Verbindungsvereinbarungen von diesem Server auf den ADC-Server. Wenn keine weiteren ADC-Server zur Verfügung stehen, installieren Sie das ADC-Programm, das in Microsoft Exchange 2000 Server oder Exchange Server 2003 eingeschlossenen ist, auf einem anderen Computer, auf dem Microsoft Windows® 2000 Server oder Windows Server™ 2003 ausgeführt wird.

Beachten Sie, dass sich die Kernattribute einer bestimmten Verbindungsvereinbarung beim Verschieben einer Verbindungsvereinbarung von einem ADC-Server auf einen anderen nicht ändern. Beispielsweise bleiben die für Replikation verwendeten Quell- und Zielcontainer als auch die zum Replizieren konfigurierten Daten unverändert. Beim Verschieben einer Verbindungsvereinbarung wird nur der ADC-Server geändert, der die Verbindungsvereinbarung ausgeführt hat.

So beheben Sie diese Warnmeldung

  1. Klicken Sie auf Start, klicken Sie auf Programme, zeigen Sie auf Verwaltung, und klicken Sie dann auf Active Directory Connector-Verwaltung , um die ADC-Verwaltungskonsole zu öffnen.

  2. Das linke Teilfenster der MMC-Konsole zeigt eine Liste mit den Servern an, die den ADC-Dienst ausführen. Wählen Sie den ADC für den Server aus, auf dem sich die zu verschiebende Verbindungsvereinbarung befindet.

  3. Im Detailbereich der MMC-Konsole werden die Verbindungsvereinbarungen angezeigt, deren Host der von Ihnen ausgewählte ADC-Server ist.

  4. Klicken Sie mit der rechten Maustaste auf die zu verschiebende Verbindungsvereinbarung, und klicken Sie dann auf Eigenschaften.

  5. Wählen Sie auf der Registerkarte Allgemein in der Dropdownliste Wählen Sie einen Server aus, der die Verbindungsvereinbarung ausführt den Server aus, auf dem die Verbindungsvereinbarung ausgeführt werden soll, und klicken Sie auf OK.

  6. Geben Sie unter Verbinden als (Windows Server) das Konto und das Kennwort für den ADC-Dienst an, und klicken Sie auf OK.

  7. Geben Sie unter Verbinden als (Exchange Server) das Konto und das Kennwort für den Exchange-Dienst an, und klicken Sie auf OK.

Weitere Informationen zum Verschieben von Verbindungsvereinbarungen finden Sie im Microsoft Knowledge Base-Artikel 326060, „XADM: How to Move a Connection Agreement to Another Server" (http://support.microsoft.com/kb/326060/en-us).

Weitere Informationen zum Installieren des Exchange 2000 Server-ADC-Programms auf einem anderen Server finden Sie im Microsoft Knowledge Base-Artikel 312632, „SO WIRD'S GEMACHT: Installation und Konfiguration des Active Directory Connectors in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=312632).

Weitere Informationen zum Installieren des Exchange Server 2003-ADC-Programms auf einem anderen Server finden Sie im Bereitstellungshandbuch für Exchange Server 2003 unter http://www.microsoft.com/downloads/details.aspx?FamilyID=77B6D819-C7B3-42D1-8FBB-FE6339FFA1ED&DisplayLang=de.


Softwareupdate für Active Directory Connector erforderlich
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2006-10-10

Microsoft® Exchange Server Analyzer sendet eine Abfrage an die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile, um den Wert für den Schlüssel Version für die ADC-Datei (Active Directory Connector) Adc.exe zu bestimmen. Der WMI-Schlüssel Version gibt die Buildnummer für diese Datei an.

Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst auch ab, um den Wert für das Attribut msDS-Behavior-Version des Gesamtstrukturobjekts in Active Directory unter den NTDS-Einstellungen zu ermitteln. Dieser Wert gibt die Funktionsebene in der Active Directory-Gesamtstruktur an. In der folgenden Tabelle finden Sie gültige Werte für das Attribut msDS-Behavior-Version.

Wert | Funktionsebene in der Gesamtstruktur
0 | Microsoft Windows 2000 Server gemischt
1 | Windows Server™ 2003 interim
2 | Windows Server 2003 einheitlich

Wenn Exchange Server Analyzer ermittelt, dass bei einem Exchange Server-Computer in einer Active Directory-Gesamtstruktur im Interims- oder einheitlichen Modus von Windows Server 2003 die Buildnummer für Adc.exe unter 6.0.6615.0 liegt, wird ein Fehler angezeigt. Dieser Fehler gibt an, dass eine Exchange 2000 Server-Version des ADC-Programms in einer nicht kompatiblen Gesamtstrukturebene von Windows Server 2003 Active Directory ausgeführt wird. Um dieses Problem zu lösen, ist ein Update des Exchange-ADC-Programms (Active Directory Connection) erforderlich.

Wenn eine ältere Version von ADC in einer gemischten oder einheitlichen Gesamtstrukturfunktionsebene ausgeführt wird, kann dies dazu führen, dass das Verzeichnis nicht vollständig aktualisiert wird und Daten verloren gehen. Sie sollten bei allen Computern in der Organisation ein Upgrade auf die aktuellste Exchange Server 2003-Version von ADC durchführen.

Sie können die aktuelle Version von ADC zusammen mit dem neuesten Exchange Server 2003 Service Pack über ie Seite mit Downloads für Exchange Server 2003 herunterladen (http://go.microsoft.com/fwlink/?LinkId=25097). Oder installieren Sie die endgültige Exchange Server 2003-Version von ADC von der Exchange Server-CD.

So führen Sie ein Upgrade auf die aktuellste Version von ADC durch

  1. Klicken Sie auf dem Server, auf dem die ältere Version von ADC ausgeführt wird, auf Start, klicken Sie auf Ausführen, und geben Sie dann E:\setup\adc\i386\setup.exe ein. E gibt dabei den Speicherort des gedownloadeten Exchange Server-Service Packs an.

  2. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation des Active Directory Connectors auf Weiter.

  3. Klicken Sie auf der Seite Alte Installation gefunden auf Neu installieren, um ADC zu aktualisieren.

  4. Klicken Sie auf der Seite Der Assistent für die Installation des Active Directory Connectors wird beendet auf Fertig stellen.

Weitere Informationen zu den Auswirkungen der Gesamtstrukturfunktionsebene auf ADC finden Sie im Microsoft Knowledge Base-Artikel 825916, „Exchange 2000 Active Directory Connector Does Not Successfully Replicate Changes to Group Membership in Windows Server 2003 Active Directory in Forest Functional Levels 1 or 2" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=825916).

Weitere Informationen über Funktionsebenen von Domänen und Gesamtstrukturen finden Sie im Knowledge Base-Artikel 322692, „So können Sie Domänen- und Gesamtstrukturfunktionsebenen in Windows Server 2003 heraufstufen" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322692).


Diese Active Directory-Gesamtstruktur wurde für Hosted Exchange konfiguriert
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs LinkID des Schemaattributobjekts Global-Address-Listzu ermitteln. Das Objekt Global-Address-List wird auf einen Exchange-Container angewendet, um den Distinguished Name (DN) einer neu erstellten globalen Adressliste (GAL) zu speichern.

Wenn Exchange Server Analyzer erkennt, dass der Wert des Attributs LinkID des Objekts Global-Address-List auf 4048 festgelegt ist, zeigt Microsoft Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht. Ein Wert von 4048 gibt an, dass die Active Directory-Gesamtstruktur für eine Hosted Exchange-Umgebung konfiguriert wurde.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu Hosted Exchange-Umgebungen finden Sie in den folgenden Artikeln:

  • "Information for Hosters" (http://go.microsoft.com/fwlink/?LinkId=46307).

  • „Chapter 23 - Hosted Service Environments" im ExchangeServer 2000 Resource Kit (http://go.microsoft.com/fwlink/?LinkId=46326)


Active Directory-Server ist inaktiv oder nicht erreichbar.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Best Practices Analyzer liest mithilfe von Remoteprozeduraufrufen (RPCs) den Zeichenfolgenwert CurrentVersion aus dem folgenden Registrierungsschlüssel auf dem Active Directory®-Verzeichnisserver:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Auf einem Computer, auf dem Microsoft Windows® 2000 Server ausgeführt wird, ist der erwartete Wert für die Zeichenfolge CurrentVersion gleich 5.0. Auf einem Computer, auf dem Windows® Server™ 2003 ausgeführt wird, ist der erwartete Wert 5.2.

Wenn Exchange Server Best Practices Analyzer den Registrierungswert aus einem beliebigen Grund nicht lesen kann, wird ein Fehler angezeigt.

So beheben Sie diesen Fehler

  1. Stellen Sie sicher, dass der Verzeichnisserver gestartet wurde und mit dem Netzwerk verbunden ist.

  2. Verwenden Sie den Befehl PING, um festzustellen, ob eine Verbindung mit dem Verzeichnisserver hergestellt werden kann.

  3. Wenn eine Firewall vorhanden ist, überprüfen Sie, ob die RPC-Anschlüsse blockiert sind.

  4. Stellen Sie sicher, dass der Remoteregistrierungsdienst auf dem Verzeichnisserver gestartet wurde.

  5. Überprüfen Sie die Berechtigungen für das Konto, unter dem Exchange Server Best Practices Analyzer ausgeführt wird, um sicherzustellen, dass es über ausreichende Berechtigungen zum Lesen der Registrierung auf dem Active Directory-Server verfügt.

Weitere Informationen zum Behandeln von Problemen mit der Netzwerkverbindung finden Sie in:

  • Microsoft Knowledge Base-Artikel 325487 „Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

  • „Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" (http://go.microsoft.com/fwlink/?LinkId=56285)


Active Directory-Server verfügt über weniger als 1 GB Arbeitsspeicher, in der Datei „Boot.ini" wurden jedoch die Schalter „/3GB" und „/USERVA=3030" gesetzt
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt zwei WMI-Klassen (Windows Management Instrumentation) ab, um die Menge des physischen Speichers für den Active Directory®-Verzeichnisserver und den virtuellen Adressraum zu bestimmen, der Prozessen im Benutzermodus zugewiesen ist. In der folgenden Tabelle werden die Klassen und Schlüssel beschrieben, die von Microsoft Exchange Server Analyzer ausgewertet werden.

Klasse | Schlüssel | Beschreibung
Win32_OperatingSystem | MaxProcessMemorySize | Maximaler Speicher in KB, der einem Prozess zugewiesen werden kann.
Win32_OperatingSystem | OSProductSuite | Installierte und lizenzierte Systemprodukterweiterungen für das Betriebssystem.
Win32_ComputerSystem | TotalPhysicalMemory | Größe des Arbeitsspeichers (RAM, Random Access Memory), der im Computer installiert ist.

Wenn Exchange Server Analyzer feststellt, dass der Verzeichnisserver über weniger als 950 MB RAM verfügt und der Wert für MaxProcessMemorySize größer als 2097024 und kleiner als 3104640 ist, wird eine Warnung angezeigt.

In dieser Warnung wird darauf hingewiesen, dass der Verzeichnisserver in zweierlei Hinsicht nicht für die optimale Speichernutzung konfiguriert ist:

  • Der /USERVA=3030-Startschalter wurde festgelegt. Dieser Schalter ist nur auf Exchange Server-Computern mit einem Speicher ab 1 GB erforderlich, auf denen ein Windows Server™ 2003-Betriebssystem ausgeführt wird.

  • Der /3GB-Startschalter wurde festgelegt. Dieser Schalter sollte nur auf Exchange-Servern mit einem Speicher ab 1 GB verwendet werden, auf denen eines der folgenden Betriebssysteme ausgeführt wird:

    • Microsoft Windows Server 2003 Standard Edition

    • Microsoft Windows Server 2003 Enterprise Edition

    • Microsoft Windows Server 2003 Datacenter Edition

    • Microsoft Windows 2000 Advanced Server

    • Microsoft Windows 2000 Datacenter Server

Wichtig:
Der /3GB-Schalter darf nicht unter Windows 2000 Server verwendet werden, da er nicht unterstützt wird und zu Abstürzen des Betriebssystems oder von Anwendungen führen kann. Darüber hinaus wird der /3GB-Schalter unter den oben genannten Betriebssystemen nur unterstützt, wenn ein physischer Speicher von 1 GB oder mehr verfügbar ist.

Wenn diese Warnung in einem System ausgegeben wird, in dem ein physischer Speicher von 1 GB verfügbar ist, kann diese darauf verweisen, dass einer anderen Komponente (z. B. einer Videokarte) Teile des physischen Speichers auf der Hardwareebene zugewiesen wurden, wodurch dieser Speicher für das Betriebssystem nicht mehr verfügbar ist. In diesen Fällen ist die Menge des physisch installierten Speichers laut Windows kleiner als die Menge des tatsächlich auf dem Computer installierten physischen Speichers. Wenn eine solche Situation eintritt, vergleichen Sie die dem BIOS gemeldete Menge des installierten Speichers mit der von Windows gemeldeten installierten Speichermenge.

So beheben Sie diese Warnung unter Windows Server 2003

  1. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und wählen Sie Eigenschaften aus. Das Dialogfeld Systemeigenschaften wird angezeigt.

  2. Klicken Sie auf Erweitert.

  3. Klicken Sie im Bereich Starten und Wiederherstellen auf Einstellungen. Das Dialogfeld Starten und Wiederherstellen wird angezeigt.

  4. Klicken Sie im Bereich Systemstart auf Bearbeiten. Dadurch wird die Windows-Datei Boot.ini in Microsoft Editor geöffnet.

  5. Löschen Sie im Abschnitt [Operating Systems] aus allen Startzeilen die folgenden Schalter: /3GB /USERVA=3030

  6. Speichern Sie die Änderungen und schließen Sie Editor.

  7. Klicken Sie zweimal auf OK, um die geöffneten Dialogfelder zu schließen, und starten Sie den Computer anschließend neu, damit die Änderung wirksam wird.

So beheben Sie diese Warnung unter Windows 2000 Server

  1. Navigieren Sie in Windows Explorer zur Systempartition.

  2. Wenn die Datei Boot.ini nicht angezeigt wird, kann dies daran liegen, dass in den Ordneroptionen die Option Geschützte Systemdateien ausblenden festgelegt ist. Wenn dies der Fall ist, klicken Sie in Windows Explorer auf Extras und Ordneroptionen, und klicken Sie dann auf die Registerkarte Ansicht. Deaktivieren Sie das Kontrollkästchen Geschützte Systemdateien ausblenden (empfohlen). Klicken Sie im angezeigten Warnungsfeld auf Ja.

  3. Wenn die Datei Boot.ini in Windows Explorer angezeigt wird, klicken mit der rechten Maustaste auf die Datei, und klicken Sie auf Öffnen mit. Klicken Sie dann auf Editor, um die Datei zu öffnen.

  4. Löschen Sie im Abschnitt [Operating Systems] aus allen Startzeilen die folgenden Schalter: /3GB /USERVA=3030

  5. Speichern Sie die Änderungen und schließen Sie Editor.

  6. Starten Sie den Computer neu, damit die Änderung wirksam wird.

Weitere Informationen zum Verwenden der Startschalter /3GB und /USERVA finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 308356, „Memory usage by the Lsass.exe process on domain controllers that are running Windows Server 2003 or Windows 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)

  • 297812, „How to Use the 4GT RAM Tuning Feature" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, „The effects of 4GT tuning on system Page Table Entries" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739, „How to Use the /USERVA Switch in the Boot.ini File to Tune /3GB Configurations" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, „SO WIRDS GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, „Optimieren der Speichernutzung in Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Der Active Directory-Server verfügt über weniger Arbeitsspeicher als 1 GB, in der Datei „Boot.ini" wurde jedoch der Schalter „/3GB" festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt zwei WMI-Klassen (Windows Management Instrumentation) ab, um die Menge des physischen Speichers für den Active Directory®-Verzeichnisserver und den virtuellen Adressraum zu bestimmen, der Prozessen im Benutzermodus zugewiesen ist. In der folgenden Tabelle werden die Klassen und Schlüssel beschrieben, die von Exchange Server Analyzer ausgewertet werden.

Klasse | Schlüssel | Beschreibung
Win32_OperatingSystem | MaxProcessMemorySize | Maximaler Speicher in KB, der einem Prozess zugewiesen werden kann.
Win32_OperatingSystem | OSProductSuite | Installierte und lizenzierte Systemprodukterweiterungen für das Betriebssystem.
Win32_ComputerSystem | TotalPhysicalMemory | Größe des Arbeitsspeichers (RAM - Random Access Memory) in Byte, der im Computer installiert ist.

Wenn Exchange Server Analyzer feststellt, dass der Verzeichnisserver über weniger als 950 MB RAM verfügt und der Wert für MaxProcessMemorySize größer als 2097024, aber kleiner als 3104640 ist, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass der Verzeichnisserver für die optimale Speicherverwendung nicht ordnungsgemäß konfiguriert ist. Der Startschalter /3GB wurde auf diesem Computer festgelegt und muss entfernt werden. Dieser Schalter sollte nur auf Active Directory-Servern mit einem Speicher ab 1 GB verwendet werden, auf denen eines der folgenden Betriebssysteme ausgeführt wird:

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server™ 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Wichtig:
Der /3GB-Schalter darf nicht unter Windows 2000 Server verwendet werden, da er nicht unterstützt wird und zu Abstürzen des Betriebssystems oder von Anwendungen führen kann. Darüber hinaus wird der Schalter /3GB unter den oben genannten Betriebssystemen nur unterstützt, wenn mindestens 1 GB physischer Speicher verfügbar ist.

Wenn diese Warnung in einem System ausgegeben wird, in dem ein physischer Speicher von 1 GB verfügbar ist, kann sie darauf verweisen, dass einer anderen Komponente (z. B. einer Videokarte) Teile des physischen Speichers auf der Hardwareebene zugewiesen wurden, wodurch dieser Speicher für das Betriebssystem nicht mehr verfügbar ist. In diesen Fällen ist die Menge des physisch installierten Speichers laut Windows kleiner als die Menge des tatsächlich auf dem Computer installierten physischen Speichers. Wenn eine solche Situation eintritt, vergleichen Sie die dem BIOS gemeldete Menge des installierten Speichers mit der von Windows gemeldeten installierten Speichermenge.

So beheben Sie diese Warnung unter Windows Server 2003

  1. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und klicken Sie dann auf Eigenschaften. Das Dialogfeld Systemeigenschaften wird angezeigt.

  2. Klicken Sie auf Erweitert.

  3. Klicken Sie im Bereich Starten und Wiederherstellen auf Einstellungen. Das Dialogfeld Starten und Wiederherstellen wird angezeigt.

  4. Klicken Sie im Bereich Systemstart auf Bearbeiten. Dadurch wird die Windows-Datei Boot.ini in Microsoft Editor geöffnet.

  5. Löschen Sie im Abschnitt [Operating Systems] aus allen Startzeilen den folgenden Schalter: /3GB

  6. Speichern Sie die Änderungen, und schließen Sie Editor.

  7. Klicken Sie zweimal auf OK, um die geöffneten Dialogfelder zu schließen, und starten Sie den Computer anschließend neu, damit die Änderung wirksam wird.

So beheben Sie diese Warnung unter Windows 2000 Server

  1. Navigieren Sie in Windows Explorer zur Systempartition.

  2. Wenn die Datei Boot.ini nicht angezeigt wird, kann dies daran liegen, dass unter Ordneroptionen die Option Geschützte Systemdateien ausblenden festgelegt ist. Wenn dies der Fall ist, klicken Sie in Windows Explorer auf Extras, anschließend auf Ordneroptionen und dann auf Ansicht. Deaktivieren Sie das Kontrollkästchen Geschützte Systemdateien ausblenden (empfohlen). Klicken Sie im angezeigten Warnungsfeld auf Ja.

  3. Wenn die Datei Boot.ini in Windows Explorer angezeigt wird, klicken Sie mit der rechten Maustaste auf die Datei, klicken Sie dann auf Öffnen mit und schließlich auf Editor, um die Datei zu öffnen.

  4. Löschen Sie im Abschnitt [Operating Systems] aus allen Startzeilen den folgenden Schalter: /3GB

  5. Speichern Sie die Änderungen, und schließen Sie Editor.

  6. Starten Sie den Computer neu, damit die Änderung wirksam wird.

Weitere Informationen zur Verwendung des Startschalters /3GB finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 308356, „Memory usage by the Lsass.exe process on domain controllers that are running Windows Server 2003 or Windows 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)

  • 297812, „How to Use the 4GT RAM Tuning Feature" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, „The effects of 4GT tuning on system Page Table Entries" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739, „How to Use the /USERVA Switch in the Boot.ini File to Tune /3GB Configurations" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, „SO WIRD'S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, „Optimieren der Speichernutzung in Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Auf dem Active Directory-Server wird Windows 2000 Server ausgeführt, und es wurde der /3GB-Schalter festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_OperatingSystem ab, um die Größe des virtuellen Adressraums (MaxProcessMemorySize) für die Prozesse im Benutzermodus und die Version von Windows (OSProductSuite) zu bestimmen, die auf dem Server des Active Directory®-Verzeichnisdiensts ausgeführt wird. In der folgenden Tabelle werden die Klassen und Schlüssel beschrieben, die von Exchange Server Analyzer ausgewertet werden.

Wenn Exchange Server Analyzer feststellt, dass der Wert MaxProcessMemorySize 3104640 beträgt und dass der Wert OSProductSuite in Windows 2000 Server aufgelöst wird, wird ein Fehler angezeigt.

Dieser Fehler zeigt an, dass der Startschalter /3GB in der Datei Boot.ini eines Verzeichnisservers festgelegt ist, auf dem Microsoft Windows 2000 Server ausgeführt wird. Dieser Schalter wird in Windows 2000 Server nicht unterstützt und sollte nur auf Computern mit einem Arbeitsspeicher ab 1 GB verwendet werden, auf denen eines der folgenden Betriebssysteme ausgeführt wird:

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

So entfernen Sie den Schalter „/3GB" aus der Datei „Boot.ini"

  1. Navigieren Sie in Windows Explorer zur Systempartition.

  2. Wenn die Datei boot.ini nicht angezeigt wird, kann dies daran liegen, dass in den Ordneroptionen die Option Geschützte Systemdateien ausblenden festgelegt ist. Wenn dies der Fall ist, klicken Sie in Windows Explorer auf Extras und Ordneroptionen, und klicken Sie dann auf die Registerkarte Ansicht. Deaktivieren Sie das Kontrollkästchen Geschützte Systemdateien ausblenden (empfohlen). Klicken Sie im angezeigten Warnungsfeld auf Ja.

  3. Wenn die Datei Boot.ini in Windows Explorer angezeigt wird, klicken Sie mit der rechten Maustaste auf die Datei, klicken Sie auf Öffnen mit, und wählen Sie dann Editor aus, um die Datei zu öffnen.

  4. Löschen Sie im Abschnitt [Operating Systems] aus allen Startzeilen die folgenden Schalter: /3GB /USERVA=3030

  5. Speichern Sie die Änderungen, und schließen Sie Editor.

  6. Starten Sie den Verzeichnisserver neu, damit die Änderung wirksam wird.

Weitere Informationen zur Verwendung des Startschalters /3GB finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 297812, „How to Use the 4GT RAM Tuning Feature" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, „The effects of 4GT tuning on system Page Table Entries" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739, „How to Use the /USERVA Switch in the Boot.ini File to Tune /3GB Configurations" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, „HOW TO: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, „Optimieren der Speichernutzung in Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Auf die Registrierung des Active Directory-Servers konnte nicht zugegriffen werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag für jeden Domänencontroller:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion\CurrentVersion

Wenn Microsoft Exchange Server Analyzer diesen Registrierungswert aus irgendeinem Grund nicht lesen kann, wird ein Fehler angezeigt.

So beheben Sie diesen Fehler

  1. Stellen Sie sicher, dass der Domänencontroller gestartet wurde und mit dem Netzwerk verbunden ist.

  2. Verwenden Sie den Befehl PING, um festzustellen, ob auf den Domänencontroller zugegriffen werden kann.

  3. Wenn eine Firewall vorhanden ist, überprüfen Sie, ob die RPC-Anschlüsse blockiert sind.

  4. Vergewissern Sie sich, dass der Dienst Remote Registry auf dem Domänencontroller gestartet wurde.

  5. Überprüfen Sie die Berechtigungen für das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird. Das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird, muss über Administratorberechtigungen für jeden durchsuchten Domänencontroller verfügen.

Weitere Informationen zum Behandeln von Problemen mit der Netzwerkverbindung finden Sie in:

  • Microsoft Knowledge Base-Artikel 325487 „Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

  • "Microsoft Exchange Server Analyzer Tool Troubleshooting Connectivity Problems" (http://go.microsoft.com/fwlink/?LinkId=56285)

Weitere Informationen zu den Anforderungen hinsichtlich der Anschlüsse finden Sie Knowledge Base-Artikel 832017, „Dienste und Port-Anforderungen für das Microsoft Windows-Serversystem" (http://support.microsoft.com/?kbid=832017).


Softwareupdate für Active Directory-Server verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2007-02-20

Microsoft Exchange Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows Management Instrumentation) Exchange_DSAccessDC im Namespace ROOT\MicrosoftExchangeV2 ab, um den Wert für die Eigenschaft Name zu bestimmen. Die Eigenschaft Name gibt den Computernamen des Domänencontrollers an, den der Exchange-Server für Lookupvorgänge des Active Directory-Verzeichnisdiensts verwendet.

Exchange Analyzer fragt Active Directory anschließend nach Werten bestimmter Attribute dieses Domänencontrollers ab, um Folgendes zu bestimmen:

  • Führt der Active Directory-Domänencontroller das Betriebssystem Windows Server 2003 aus?

  • Führt der Active Directory-Domänencontroller eine andere als die englische Version des Betriebssystems Microsoft Windows Server 2003 aus?

  • Gibt es einen Microsoft Exchange Server 2007-Server in der Exchange-Organisation?

  • Ist der Wert des Schlüssels Version für die Datei ntdsa.dll auf dem Server kleiner als 2700?

Wenn Exchange Analyzer feststellt, dass all diese Bedingungen erfüllt sind, wird eine Warnung angezeigt.

Diese Warnung weist darauf hin, dass Exchange Outlook Web Access-Clients möglicherweise Probleme mit der Exchange-Adressbuchindizierung haben.

Mit Outlook Web Access können Benutzer die Sprache für ihre Benutzeroberfläche (UI) auswählen. Die vom Benutzer gewählte Sprache bestimmt die Einstellung des Gebietsschemas. Outlook Web Access verwendet die Sprache auch für die Sortierung der Active Directory-Ergebnisse, z. B. im Adressbuch. Wenn Exchange eine Ansicht virtueller Listen (Virtual List Views, VLV) abfragt und eine Sprache angibt, die auf dem Domänencontroller nicht verfügbar ist, tritt ein Fehler auf. Zu diesem Problem kommt es, weil aktuell kein Standardmechanismus für die Indizierung existiert, der Exchange die Verwendung einer anderen Sprache ermöglicht, wenn die für eine VLV-Abfrage angegebene Sprache nicht mit der Sprache des Domänencontrollers übereinstimmt.

Zum Beheben dieser Warnung können Sie die in Microsoft Knowledge Base-Artikel 919166, "Die Adressbuchfunktion in Exchange 2007 wird unterbrochen, wenn ein Exchange OWA-Client und ein Windows Server 2003-basierter Domänencontroller nicht dieselbe Gebietsschemaeinstellung aufweisen" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=919166) genannte Dateiaktualisierung herunterladen und installieren.


Auf die Active Directory-Server-WMI konnte nicht zugegriffen werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_ComputerSystem ab, um zu ermitteln, ob für den Schlüssel Name auf dem Domänencontroller ein Wert festgelegt wurde. Wenn die WMI-Abfrage nicht ausgeführt werden kann, zeigt Exchange Server Analyzer einen Fehler an.

Dieser Fehler kann zwei Ursachen haben:

  • Das Konto, auf dem Exchange Server Analyzer ausgeführt wird, verfügt nicht über die erforderlichen Berechtigungen, um WMI-Informationen abzufragen.

  • Wegen eines Netzwerkproblems kann Exchange Server Analyzer keine Verbindung mit dem Computer herstellen.

So beheben Sie diesen Fehler

  1. Stellen Sie sicher, dass der Exchange Server-Computer gestartet wurde und mit dem Netzwerk verbunden ist.

  2. Verwenden Sie den Befehl PING, um festzustellen, ob eine Verbindung mit dem Exchange Server-Computer hergestellt werden kann.

  3. Wenn ein Firewall vorhanden ist, überprüfen Sie, ob die RPC-Anschlüsse blockiert sind.

  4. Überprüfen Sie die Berechtigungen für das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird. Das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird, muss über lokale Administratorberechtigungen für jeden durchsuchten Exchange-Server-Computer verfügen.

    Alternativ können Sie dem Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird, bestimmte WMI-Berechtigungen erteilen.

    1. Öffnen Sie auf dem Exchange-Computer die Konsolenstruktur Computer-Management.

    2. Klicken Sie mit der rechten Maustaste unter Dienste und Anwendungen auf WMI-Steuerung, und klicken Sie dann auf Eigenschaften.

    3. Klicken Sie auf der Seite Eigenschaften von WMI-Steuerung auf die Registerkarte Sicherheit, und erweitern Sie dann Stamm.

    4. Wählen Sie den Ordner CIMV2 aus, und klicken Sie auf Sicherheit.

    5. Fügen Sie auf der Seite Sicherheit für ROOT\CIMV2 das Konto hinzu, unter dem Exchange Server Analyzer ausgeführt wird.

    6. Wählen Sie das Konto aus, das Sie in Schritt e hinzugefügt haben. Aktivieren Sie in Berechtigungen für Ausgewähltes Konto in der Spalte Zulassen die Kontrollkästchen Remote aktivieren und Sicherheit lesen, und klicken Sie dann auf OK.

Weitere Informationen zum Behandeln von Problemen mit der Netzwerkverbindung finden Sie in:

  • Microsoft Knowledge Base-Artikel 325487 „Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

  • "Microsoft Exchange Server Analyzer Tool Troubleshooting Connectivity Problems" (http://go.microsoft.com/fwlink/?LinkId=56285)

Weitere Informationen zu den Anforderungen hinsichtlich der Anschlüsse finden Sie Knowledge Base-Artikel 832017, „Dienste und Port-Anforderungen für das Microsoft Windows-Serversystem" (http://support.microsoft.com/?kbid=832017).


Es wurde das Attribut „ADCDisabledMail" erkannt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob sich die Exchange Server-Organisation im gemischten oder im einheitlichen Modus befindet. Wenn sich die Exchange-Organisation im einheitlichen Modus befindet, fragt Exchange Server Analyzer Active Directory ab, um zu bestimmen, ob für ein mailaktiviertes Objekt in den Domänen der Organisation der Wert des Attributs legacyExchangeDN auf ADCDisabledMail festgelegt wurde. Wenn mailaktivierte Objekte erkannt werden, deren legacyExchangeDN-Attribut den Wert ADCDisabledMail aufweist, wird eine Warnung angezeigt, die eine Liste der Objekte und der entsprechenden Domänen enthält.

Dieses Problem kann in Exchange 2000 Server- und Exchange Server 2003-Umgebungen auftreten, wenn ein Postfach gelöscht wird. Wenn das Postfach gelöscht wird, erhält der Wert des Attributs legacyExchangeDN des Kontos den Stempel ADCDisabledMail. Mit diesem Wert wird der ADC (Active Directory Connector) angewiesen, Objekte aus dem Verzeichnisdienst von Exchange Server 5.5 zu löschen, wenn für das zugeordnete Objekt in Active Directory E-Mail deaktiviert wurde. Wenn sich in einer großen Verteilergruppe mehrere Postfächer befinden, die gelöscht wurden, wird die Übermittlung der Nachricht verzögert, während Active Directory auf einen eindeutigen legacyExchangeDN-Attributwert von ADCDisabledMail durchsucht wird. Da mehrere Postfächer diesen gleichen legacyExchangeDN attribute value aufweisen können, dauert die Suche lange. Dadurch wird die Übermittlung von Nachrichten verzögert. Die Übermittlung von Nachrichten wird verzögert, wenn die Verteilergruppe in den Zeilen "An:/Cc:/Bcc:" der Nachricht aus einem Microsoft Office Outlook® 2003-Client erweitert wird.

Die Lösung besteht darin, entweder die Objekte zu löschen oder mit dem Tool ADSI-Bearbeitung (Active Directory Service Interfaces), dem Tool ldp.exe oder einem anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, den Inhalt des Attributs legacyExchangeDn zu entfernen. Wenn der Wert des Attributs legacyExchangeDN auf NULL festgelegt ist, wird die Suche für Active Directory auf „/O=NT5/ou=<objectGUID of the Domain>/cn=<objectGUID of the user>" festgelegt und der NDR (Non-Delivery Report, Unzustellbarkeitsbericht) wird viel schneller erstellt.

Achtung:
Wenn Sie die ADSI-Bearbeitung, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So entfernen Sie den Wert „ADCDisabledMail" des Attributs „legacyExchangeDN"

  1. Starten Sie das ADSI-Bearbeitungs-Snap-In in den Supporttools von Windows 2000 oder Windows Server 2003.

  2. Erweitern Sie die folgenden Knoten:

    • Container Domäne

    • DC=Domänenname

    • Container Benutzer

  3. Klicken Sie mit der rechten Maustaste auf Benutzername, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie in der Liste Attribute auf legacyExchangeDN, und klicken Sie dann auf Bearbeiten.

  5. Entfernen Sie den ursprünglichen Wert von legacyExchangeDN, der ADCDisabledMail enthält, indem Sie den ursprünglichen Wert markieren und auf Löschen klicken.

  6. Klicken Sie zweimal auf OK, um die Änderung zu übernehmen.

Weitere Informationen zur Verwendung der ADSI-Bearbeitung finden Sie im Abschnitt „Adsiedit.msc: ADSI Bearbeitung" in der Onlinehilfe zu Windows Server.

Weitere Informationen zur Verwendung des LDP-Tools finden Sie im Knowledge Base-Artikel 260745, „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).


Durch die Filtereinstellung für die Adressliste werden neue Empfänger in Adresslisten möglicherweise nicht angezeigt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um die Werte zu ermitteln, die für das Attribut purportedSearch für die einzelnen Empfängerrichtlinienobjekte von Exchange festgelegt wurden. Wenn Exchange Server Analyzer feststellt, dass das Attribut purportedSearch die Zeichenfolge „proxyAddresses=*" enthält, wird ein Fehler angezeigt.

Nachdem Sie ein neues Benutzerobjekt erstellt haben, weist der Empfängeraktualisierungsdienst diesem Empfängerobjekt bestimmte Attribute (z. B. Proxyadressen) zu. Möglicherweise kann der Empfängeraktualisierungsdienst das Attribut ShowInAddressBook nicht zuweisen. Das Attribut ShowInAddressBook des Empfängerobjekts gibt die Adresslisten an, zu denen der Empfänger gehört. Empfängerobjekte, denen dieses Attribut nicht zugewiesen wurde, werden nicht in der globalen Adressliste oder einer anderen Adressliste angezeigt, selbst wenn das Objekt den Filterkriterien der Adresslisten entspricht.

Diese Situation kann eintreten, wenn ein oder mehrere Adresslistenfilter das Attribut proxyAddresses enthalten. Sie können prüfen, ob dies der Fall ist, indem Sie die Eigenschaften jeder Adressliste prüfen und im Feld Filterregeln nach der folgenden Zeichenfolge suchen: „proxyAddresses=*".

Führen Sie folgende Schritte aus, um den Empfängeraktualisierungsdienst zu aktivieren und den Empfängerobjekten die Attribute ordnungsgemäß zuzuweisen, damit diese Objekte in der globalen Adressliste oder einer anderen Adressliste angezeigt werden.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So beheben Sie diesen Fehler

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Empfänger, erweitern Sie Alle Globalen Adresslisten, und wählen Sie dann Empfängerrichtlinien aus.

  3. Klicken Sie mit der rechten Maustaste auf die zu bearbeitende Adressliste, und wählen Sie Eigenschaften aus.

  4. Klicken Sie auf der Seite Eigenschaften auf der Registerkarte Allgemein unter Filterregeln auf Ändern.

  5. Wählen Sie im Dropdownmenü Nach Exchange-Empfängern suchen die Option Benutzerdefinierte Suche aus. Wenn die Adressliste ursprünglich mithilfe einer benutzerdefinierten Suche erstellt wurde, wird nach dem Klicken auf Ändern in Schritt 3 die Seite Nach benutzerdefinierter Suche suchen angezeigt.

  6. Wählen Sie in der Liste der Kriterien den Eintrag Die Proxyadresse ist (genau) * aus, und klicken Sie dann auf Entfernen.

  7. Klicken Sie auf OK, um die Dialogfelder zu schließen.

  8. Klicken Sie mit der rechten Maustaste auf die Empfängerrichtlinie, und klicken Sie dann auf Diese Richtlinie jetzt anwenden.

Weitere Informationen zum Empfängeraktualisierungsdienst finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 328738, „XADM: How the Recipient Update Service Applies Recipient Policies" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 319065, „Work with the Exchange Recipient Update Service" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319065)


Modus der administrativen Gruppe ist unbekannt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Modus der administrativen Gruppe zu überprüfen. Hierzu wird das Attribut msExchAdminGroupMode des administrativen Gruppenobjekts im Container Administrative Gruppe in Active Directory überprüft. Wenn Exchange Server Analyzer ermittelt, dass der Wert für das Attribut msExchAdminGroupMode nicht gleich 0, 1 oder 2 ist, wird ein Fehler angezeigt.

Mit dem Modus der administrativen Gruppe gibt Exchange an, ob die administrative Gruppe Server mit Exchange Server 5.5, Server mit Exchange Server 2003 oder Server mit Exchange 2000 Server enthalten kann. Falls der für das Attribut angegebene Wert nicht 0, 1 oder 2 ist, wurde dieser Wert voraussichtlich von einem Administrator manuell geändert. Exchange-Setup oder der Exchange-System-Manager legen diesen Wert nicht falsch fest.

Sie müssen den Wert mit einem Tool wie Active Directory Service Interfaces (ADSI) Edit-Snap-In, LDP (ldp.exe) oder einem beliebigen anderen Client für LDAP (Lightweight Directory Access Protocol), Version 3, korrigieren.

Achtung:
Wenn Sie die ADSI-Bearbeitung, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So ändern Sie das Attribut MSExchAdminGroupMode

  1. Verwenden Sie einen Active Directory-Editor (z. B. die ADSI-Bearbeitung), um das administrative Gruppenobjekt in Active Directory zu suchen.

    Das Attribut MSExchAdminGroupMode befindet sich unter:

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=Organization, CN=Administrative Groups, CN=Administrative Gruppe

  2. Geben Sie einen der folgenden ganzzahligen Werte ein:

    0 = einheitlicher Modus (die administrative Gruppe wurde mit Exchange 2000 Server oder Exchange Server 2003 erstellt)

    1 = Exchange Server 5.5-Modus (die administrative Gruppe wurde mit Exchange Server 5.5 erstellt und enthält nur Server mit Exchange Server 5.5)

    2 = gemischter Modus (die administrative Gruppe kann sowohl Server mit Exchange Server 5.5 als auch Server mit Exchange 2000 Server oder Exchange Server 2003 enthalten)

Weitere Informationen zur Verwendung des LDP-Tools finden Sie im Microsoft Knowledge Base-Artikel 260745, „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Weitere Informationen zur Verwendung der ADSI-Bearbeitung finden Sie im Thema „Adsiedit.msc: ADSI Bearbeitung" in der Onlinehilfe zu Windows Server.


Falsche Konfiguration für authentifizierte Benutzer für Hosted Exchange.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Microsoft Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob die Exchange Server-Umgebung als gehostete Exchange-Umgebung konfiguriert ist. Wenn die Exchange Server-Umgebung eine gehostete Exchange-Umgebung ist, fragt Exchange Server Analyzer Active Directory ab, um zu bestimmen, ob die Gruppe der authentifizierten Benutzer in der Domäne Teil der Gruppe „Prä-Windows® 2000 kompatibler Zugriff" ist.

Wenn die Gruppe der authentifizierten Benutzer ein Member der Gruppe „Prä-Windows 2000 kompatibler Zugriff" ist, zeigt Exchange Server Analyzer eine Warnung an. Dies wird nicht als Konfiguration für eine gehostete Exchange-Lösung empfohlen.

Um dieses Problem zu beheben, entfernen Sie die authentifizierten Benutzer aus der Sicherheitsgruppe „Prä-Windows 2000 kompatibler Zugriff".

  1. Öffnen Sie Active Directory-Benutzer und -Computer.

  2. Erweitern Sie den Domänenknoten, und klicken Sie dann auf den Container Vordefiniert.

  3. Klicken Sie mit der rechten Maustaste auf die Sicherheitsgruppe Prä-Windows 2000 kompatibler Zugriff, und wählen Sie Eigenschaften aus.

  4. Klicken Sie auf die Registerkarte Mitglieder.

  5. Wählen Sie Authentifizierte Benutzer aus.

  6. Klicken Sie auf Entfernen.

  7. Klicken Sie auf OK.

Weitere Informationen zu gehosteten Exchange-Umgebungen finden Sie in den folgenden Artikeln:

  • "Information for Hosters" (http://go.microsoft.com/fwlink/?LinkId=46307)

  • „Chapter 23 - Hosted Service Environments" im ExchangeServer 2000 Resource Kit (http://go.microsoft.com/fwlink/?LinkId=46326)


Fehlende Übereinstimmung bei Zertifikat-Prinzipal
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2007-01-09

Microsoft® Exchange Server Analyzer fragt das Objekt Server Certificate im Exchange Server-System ab, um verschiedene Eigenschaften von X.509-Zertifikaten abzurufen. Für jedes gefundene SSL-Zertifikat (Secure Sockets Layer) bewertet Exchange Server Analyzer das Attribut Principal, um den vollständig qualifizierten Domänennamen (Fully Qualified Domain Name, FQDN) zu bestimmen, der dem Zertifikat zugewiesen wurde, beispielsweise „www.microsoft.com".

Microsoft Exchange Server Analyzer gibt eine Warnung aus, wenn der FDQN von Principal nicht der Hostadresse oder dem Host-URL entspricht. Die Warnung vor der fehlenden Übereinstimmung bei dem Zertifikat-Principal bedeutet, dass Benutzer möglicherweise mit Microsoft Office Outlook® Web Access für Exchange Server 2003, Outlook Anywhere für Exchange Server 2007, Exchange Server ActiveSync und RPC über HTTP keine Verbindung mehr mit ihren Postfächern herstellen können.

Hinweis:
Ein Server muss über ein Serverzertifikat verfügen, wenn darauf ein SSL-Protokoll ausgeführt wird. Optional kann der Server das Zertifikat des Clients abfragen. Das Serverzertifikat enthält den Namen der Website. Der Browser überprüft, ob die Website mit dem eingegebenen Namen übereinstimmt. Beispielsweise muss bei einer Website namens „https://www.example.com" der Name des Zertifikats „www.example.com" lauten.

Eine fehlende Übereinstimmung könnte dazu führen, dass eine der folgenden Situationen eintritt:

  • Das Zertifikat wird versehentlich auf den falschen Server angewendet.

  • Der Client greift auf Daten auf einem Server über die falsche Host-URL zu, wenn Server mehr als einen Hostnamen haben.

So beheben Sie die fehlende Übereinstimmung beim Zertifikatnamen

  • Stellen Sie sicher, dass das SSL-Zertifikat für den richtigen Host ausgestellt und auf diesen angewendet wurde.

Weitere Informationen

  • Informationen zur Verwendung von Zertifikaten mit virtuellen Servern in Exchange Server 2003 finden Sie im Microsoft Knowledge Base-Artikel 823024, „Verwenden von Zertifikaten mit virtuellen Servern in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823024).

  • Informationen zur Verwendung von SSL sowie zum Erhalten und Installieren von Serverzertifikaten finden Sie unter „Konfigurieren von Exchange Server 2003 für den Clientzugriff" im Handbuch für den Clientzugriff in Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47568).

  • Informationen zur Verwendung von SSL sowie zum Abrufen und Installieren von Serverzertifikaten für Exchange Server 2007 finden Sie unter "Konfigurieren von SSL für Outlook Anywhere" (http://go.microsoft.com/fwlink/?LinkId=80875).


Der Aktivierungszeitplan für die Verbindungsvereinbarung wurde auf „Nie" festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs activationStyle für jedes Verbindungsvereinbarungsobjekt zu ermitteln. Das Attribut activationStyle stellt die Zeitplaneinstellung für die Verbindungsvereinbarung dar. Wenn der Zeitplan auf Nie festgelegt ist, wird eine Warnung angezeigt.

Wenn Sie ermittelt haben, dass diese Verbindungsvereinbarung nicht mehr benötigt wird, sollten Sie sie löschen. Wenn die Verbindungsvereinbarung noch benötigt wird, sollten Sie für sie die Ausführung nach einem geeigneten Zeitplan konfigurieren.

So beheben Sie diese Warnmeldung

  1. Klicken Sie auf Start, klicken Sie auf Programme, klicken Sie auf Verwaltung, und klicken Sie dann auf Active Directory Connector.

  2. Klicken Sie im linken Bereich auf den ADC (Active Directory Connector)-Server, auf dem sich die zu ändernde Verbindungsvereinbarung befindet.

  3. Klicken Sie im rechten Bereich mit der rechten Maustaste auf die zu ändernde Verbindungsvereinbarung, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf die Registerkarte Zeitplan.

  5. Legen Sie den Zeitplan auf Immer oder Zu ausgewählten Zeiten fest. Wenn Sie die letztgenannte Option auswählen, klicken Sie in die entsprechenden Bereiche im Raster, um die Verbindungsvereinbarung zu den festgelegten Zeiten auszuführen.

Weitere Informationen zum Konfigurieren einer bidirektionalen Empfängerverbindungsvereinbarung finden Sie im Microsoft Knowledge Base-Artikel 296260 „XGEN: How to Configure a Two-Way Recipient Connection Agreement for Exchange 5.5 Users" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=296260.


Verwaiste Verbindungsvereinbarung
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob bei jeder Verbindungsvereinbarung ein gültiger Wert für msExchHomeSyncService vorhanden ist. Wenn Microsoft Exchange Server Analyzer eine Verbindungsvereinbarung erkennt, für die kein gültiger Wert für dieses Attribut vorhanden ist, wird eine Warnung angezeigt.

Das Attribut msExchHomeSyncService enthält den ADC-Server (Active Directory Connector), auf dem sich die Verbindungsvereinbarung befindet.

Sie können diese Warnung anzeigen, wenn Sie einen ADC-Server entfernen, ohne zuvor ADC zu entfernen, oder wenn Sie die Verbindungsvereinbarungen auf dem ADC-Server entfernen. Wenn Sie den ADC-Server entfernen, wird die Verbindung zwischen den Verbindungsvereinbarungen und dem ADC-Server unterbrochen. Die Objekte, für die diese Verbindungsvereinbarungen zuständig sind, werden daher nicht mehr repliziert. Wenn Sie das ADC Manager-Snap-In auf einem anderen ADC-Server verwenden, werden die Verbindungsvereinbarungen, die sich auf dem entfernten ADC-Server befunden haben, nicht mehr angezeigt. Diese Verbindungsvereinbarungen sind jedoch noch in Active Directory vorhanden.

Um dieses Problem zu beheben, weisen Sie die alten Verbindungsvereinbarungen einem neuen ADC-Server zu. Eine Möglichkeit hierfür ist das Erstellen einer neuen Verbindungsvereinbarung auf dem neuen ADC-Server. Danach kopieren Sie das Attribut msExchHomeSyncService aus der neuen Verbindungsvereinbarung, und fügen es in der alten ein.

So ordnen Sie eine Verbindungsvereinbarung erneut einem ADC-Server zu

  1. Starten Sie das ADC Manager-Snap-In.

  2. Erstellen Sie eine neue Verbindungsvereinbarung.

  3. Starten Sie die ADSI-Bearbeitung (Active Directory Service Interfaces).

  4. Erweitern Sie Konfiguration, erweitern Sie Dienste, erweitern Sie Microsoft Exchange, und klicken Sie dann auf Active Directory-Verbindungen.

  5. Öffnen Sie im rechten Bereich die Eigenschaften der Verbindungsvereinbarung, die Sie gerade erstellt haben.

  6. Klicken Sie in der Dropdownliste Auswählen einer anzuzeigenden Eigenschaft auf msExchHomeSyncService.

  7. Kopieren Sie das gesamte Attribut aus dem Feld Wert(e), und klicken Sie dann auf OK.

  8. Öffnen Sie die Eigenschaften der Verbindungsvereinbarung, die neu zugewiesen werden soll.

  9. Klicken Sie in der Dropdownliste Auswählen einer anzuzeigenden Eigenschaft auf das Attribut msExchHomeSyncService.

  10. Fügen Sie den kopierten Wert im Feld Attribut bearbeiten ein.

  11. Klicken Sie auf Festlegen, klicken Sie auf Übernehmen, und klicken Sie dann auf OK.

Weitere Informationen zu verwaisten Verbindungsvereinbarungen finden Sie im Microsoft Knowledge Base-Artikel 319486, „XADM: Connection Agreements Disappear After You Remove Active Directory Connector" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319486).


Standardanzeigenname wurde geändert
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer sendet eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert des Attributs createDialog für Objekte der displaySpecifier-Objektklasse zu bestimmen. Objekte der displaySpecifier-Objektklasse beschreiben die Kontextmenüs und Eigenschaftenseiten, die für Objekte in Active Directory verwendet werden. Wenn Exchange Server Analyzer feststellt, dass das Attribut createDialog festgelegt wurde, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Wenn in Active Directory ein neuer Benutzer oder ein neues Kontaktobjekt erstellt wird, wird das Feld Vollständiger Name immer im Format Vorname Nachname erstellt. In diesem Feld wiederum wird beim Erstellen das Feld Anzeigename festgelegt. Daher erhalten Sie eine globale Adressliste im Format Vorname Nachname.

Bei Bedarf können Sie mit einem Active Directory-Editor (z. B. der ADSI-Bearbeitung, ADSI - Active Directory Service Interfaces) den Modus ändern, in dem das Feld Anzeigename eingerichtet wird. Die ADSI-Bearbeitung ändert nicht nur die Einrichtung dieses Felds, sondern auch das Feld Vollständiger Name. Daher werden Benutzer in dem ausgewählten Format wiedergegeben, das in Active Directory-Benutzer und -Computer angezeigt wird.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

Bevor Sie diese Änderungen vornehmen, sollten Sie beachten, dass sie sich auch nachteilig auswirken können. Weitere Informationen zu möglichen Folgen dieser Änderung finden Sie im Microsoft Knowledge Base-Artikel 276266, „Group Changes for Users with LDAP-Restricted Characters" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=276266).

So ändern Sie das Standard-Anzeigeformat für Benutzer und Kontaktobjekte

  1. Öffnen Sie einen Active Directory-Editor, z. B. die ADSI-Bearbeitung.

  2. Klicken Sie mit der rechten Maustaste auf den obersten Knoten. Anschließend klicken Sie auf Verbinden mit.

  3. Ändern Sie den Namenskontext auf Konfigurationscontainer, und klicken Sie anschließend zum Einbinden und Authentifizieren auf OK.

  4. Erweitern Sie den Knoten Konfigurationscontainer, und erweitern Sie anschließend den Knoten Konfiguration.

  5. Erweitern Sie den Knoten cn=DisplaySpecifiers, und doppelklicken Sie auf CN=407. Hinweis: 407 ist die Gebietsschema-ID für Deutsch. Wenn Sie sich in einer mehrsprachigen Umgebung befinden, müssen Sie die Änderungen mit anderen Codes vornehmen.

  6. Öffnen Sie im rechten Bereich die Eigenschaften für CN=user-Display.

  7. Führen Sie einen Bildlauf zum optionalen Attribut createDialog aus.

  8. Legen Sie das Attribut auf %<sn>.%<givenName> fest, und klicken Sie auf Festlegen. Hinweis: Die einzigen Token, die formatiert werden können, sind %<Name>, %<Vorname> und %<Initialen>.

  9. Klicken Sie auf OK, um das Dialogfeld zu schließen.

  10. Erstellen Sie einen neuen Benutzer in Active Directory, um sicherzustellen, dass Vollständiger Name und Anzeigename einwandfrei eingerichtet wurden. Hinweis: In einer Umgebung mit mehreren Domänen müssen Sie unter Umständen auf den Abschluss der Replikation warten, bevor das Tool Active Directory-Benutzer und -Computer die Änderungen verarbeitet.

Durch die oben aufgeführten Schritte wird der Anzeigename in der Form Nachname.Vorname dargestellt. Das oben genannte Verfahren eignet sich auch für Benutzerobjekte. Für Kontaktobjekte ändern Sie Schritt 6 auf contact-Display.

Weitere Informationen zum Ausführen dieser Aufgabe mit einem ADSI-Skript finden Sie im Microsoft Knowledge Base-Artikel 277717, „How to Change the Display Names of Active Directory Users with Active Directory Services Interface Script" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277717).

Die Codeseiten werden durch die International Telecommunication Union (ITU) und die International Organization for Standardization (ISO) definiert. Weitere Informationen finden Sie auf den folgenden Webseiten von ITU und ISO:

  • http://www.itu.int

  • http://www.iso.ch/iso/en/ISOOnline.openerpage

    Hinweis:
    Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.

Weitere Informationen zur Unterstützung von lokalisierten Exchange-Clients finden Sie im Microsoft Knowledge Base-Artikel 150977, „XADM: Supporting Localized Exchange Clients" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=150977).


Die Aufbewahrung gelöschter Objekte wurde für den Postfachspeicher deaktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs garbageCollPeriod für jeden Postfachspeicher zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass das Attribut garbageCollPeriod für jeden Postfachspeicher auf den Wert 0 festgelegt wurde, wird eine Meldung mit empfohlenen optimalen Methoden angezeigt.

Garbage Collection ist ein interner Bereinigungsprozess von Exchange, bei dem Speicherplatz in der Datenbank des Postfachspeichers freigegeben wird. In der Standardeinstellung werden gelöschte Objekte eine bestimmte Anzahl von Tagen in der Datenbank des Postfachspeichers gespeichert, bevor sie von Exchange dauerhaft gelöscht werden. Sie können die Länge der Aufbewahrungszeit für gelöschte Objekte festlegen, indem Sie die Standardwerte für den Postfachspeicher verwenden oder die Anzahl der Tage auswählen, die ein gelöschtes Objekt vor dem dauerhaften Löschen aufbewahrt wird.

Wenn Sie die Anzahl der Aufbewahrungstage für gelöschte Objekte festlegen, können Sie eine Zahl von 0 bis 24.855 auswählen. Es wird empfohlen, für diese Einstellung 7 Tage zu konfigurieren. Wenn die Aufbewahrungszeit für gelöschte Objekte auf 0 festgelegt wird, werden die gelöschten Objekte auf dem Server sofort dauerhaft gelöscht. Sofern genügend Speicherplatz zur Verfügung steht, wird davon abgeraten, die Aufbewahrungsfunktion für gelöschte Objekte zu deaktivieren. Folgen Sie den unten beschriebenen Verfahren, um die Anzahl der Aufbewahrungstage für gelöschte Objekte festzulegen.

So konfigurieren Sie die Aufbewahrungszeit für gelöschte Objekte im Exchange-System-Manager

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Administrative Gruppe oder Organisation, klicken Sie auf Server, und klicken Sie dann auf Postfachspeicher.

  3. Klicken Sie mit der rechten Maustaste auf den Postfachspeicher, und klicken Sie dann auf Eigenschaften.

  4. Legen Sie auf der Registerkarte Grenzwerte die Aufbewahrungszeit für gelöschte Objekte fest, indem Sie wie folgt vorgehen:

    • Um eine Aufbewahrungszeit für gelöschte Objekte festzulegen, klicken Sie auf Gelöschte Objekte aufbewahren für (Tage), und geben Sie dann einen Wert ein.

    • Um Objekte bis zur Sicherung aufzubewahren, klicken Sie auf Postfächer und Objekte erst permanent löschen, wenn eine Sicherungskopie des Informationsspeichers erstellt wurde.

So konfigurieren Sie die Aufbewahrungszeit für gelöschte Objekte in Active Directory-Benutzer und -Computer

  1. Öffnen Sie Active Directory-Benutzer und -Computer.

  2. Erweitern Sie in der Konsolenstruktur die Domäne.

  3. Doppelklicken Sie auf Benutzer, oder doppelklicken Sie auf den Knoten, der die Empfängerinformationen enthält, die Sie ändern möchten.

  4. Doppelklicken Sie im Detailbereich auf den Empfänger, den Sie ändern möchten.

  5. Klicken Sie auf der Registerkarte Exchange - Allgemein auf Speichergrenzwerte.

  6. Deaktivieren Sie im Dialogfeld Speichergrenzwerte unter Aufbewahrungszeit für gelöschte Objekte das Kontrollkästchen Standardwerte für Postfachspeicher verwenden, und geben Sie dann unter Gelöschte Objekte aufbewahren für (Tage) einen Wert ein.

    Um zu verhindern, dass Objekte endgültig gelöscht werden, bevor sie gesichert wurden, aktivieren Sie das Kontrollkästchen Objekte erst permanent löschen, wenn eine Sicherungskopie des Informationsspeichers erstellt wurde.

Weitere Informationen zum Festlegen der Speicherbegrenzungen in Postfachspeichern finden Sie im Microsoft Knowledge Base-Artikel 319583, „HOW TO: Configure Storage Limits on Public Folders in Exchange 2000" unter (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319439).


Die Aufbewahrung gelöschter Objekte wurde für den Informationsspeicher für Öffentliche Ordner deaktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs garbageCollPeriod für jeden Informationsspeicher für Öffentliche Ordner zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass das garbageCollPeriod-Attribut für jeden Informationsspeicher für Öffentliche Ordner auf 0 festgelegt wurde, wird eine Meldung mit empfohlenen optimalen Methoden angezeigt.

Die Garbage Collection ist ein interner Bereinigungsprozess von Exchange, bei dem Speicherplatz in der Datenbank des Informationsspeichers für Öffentliche Ordner freigegeben wird. In der Standardeinstellung werden gelöschte Objekte eine bestimmte Anzahl von Tagen in der Datenbank des Informationsspeichers für Öffentliche Ordner gespeichert, bevor sie von Exchange dauerhaft gelöscht werden. Sie können die Länge der Aufbewahrungszeit für gelöschte Objekte festlegen, indem Sie die Standardwerte für den Informationsspeicher für Öffentliche Ordner verwenden oder die Anzahl der Tage auswählen, die ein gelöschtes Objekt vor dem dauerhaften Löschen aufbewahrt wird.

Wenn Sie die Anzahl der Aufbewahrungstage für gelöschte Objekte festlegen, können Sie eine Zahl von 0 bis 24.855 auswählen. Es wird empfohlen, für diese Einstellung 7 Tage zu konfigurieren. Wenn die Aufbewahrungszeit für gelöschte Objekte auf 0 festgelegt wird, werden die gelöschten Objekte auf dem Server sofort dauerhaft gelöscht. Sofern genügend Speicherplatz zur Verfügung steht, wird davon abgeraten, die Aufbewahrungsfunktion für gelöschte Objekte zu deaktivieren.

So konfigurieren Sie die Aufbewahrungszeit für gelöschte Objekte im Exchange-System-Manager

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie die Administrative Gruppe oder den Server, klicken Sie auf Server, und klicken Sie dann auf Informationsspeicher für Öffentliche Ordner.

  3. Klicken Sie mit der rechten Maustaste auf den Informationsspeicher für Öffentliche Ordner, und klicken Sie dann auf Eigenschaften.

  4. Legen Sie auf der Registerkarte Grenzwerte die Aufbewahrungszeit für gelöschte Objekte fest, indem Sie wie folgt vorgehen:

    • Um eine Aufbewahrungszeit für gelöschte Objekte festzulegen, klicken Sie auf Gelöschte Objekte aufbewahren für (Tage), und geben Sie dann einen Wert ein.

    • Um Objekte bis zur Sicherung aufzubewahren, klicken Sie auf Objekte erst permanent löschen, wenn eine Sicherungskopie des Informationsspeichers erstellt wurde.

Weitere Informationen zum Festlegen der Speicherbegrenzungen in öffentlichen Ordnern finden Sie im Microsoft Knowledge Base-Artikel 319439, „HOW TO: Configure Storage Limits on Public Folders in Exchange 2000" unter (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319439).


Die Aufbewahrung gelöschter Postfächer wurde deaktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchMailboxRetentionPeriod für jeden Postfachspeicher zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass das Attribut msExchMailboxRetentionPeriod für jeden Postfachspeicher auf 0 festgelegt wurde, wird eine Meldung mit empfohlenen optimalen Methoden angezeigt.

Das Attribut msExchMailboxRetentionPeriod gibt die Anzahl der Tage an, die gelöschte Postfächer aufbewahrt werden, bevor sie gelöscht werden. Beim Angeben der Anzahl der Aufbewahrungstage für gelöschte Postfächer können Sie eine Zahl zwischen 0 und 24.855 auswählen. In der Standardeinstellung beträgt die Aufbewahrung gelöschter Postfächer 30 Tage. Wenn die Aufbewahrungszeit für gelöschte Postfächer auf 0 festgelegt wird, werden die gelöschten Postfächer auf dem Server sofort dauerhaft gelöscht. Sofern genügend Speicherplatz zur Verfügung steht, wird davon abgeraten, die Aufbewahrungsfunktion für gelöschte Postfächer zu deaktivieren.

So konfigurieren Sie die Aufbewahrung gelöschter Postfächer

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie nacheinander Administrative Gruppen, Ihre administrative Gruppe, Server und die entsprechende Speichergruppe. Wenn der Knoten Administrative Gruppen im Exchange-System-Manager nicht angezeigt wird, erweitern Sie Server und dann die entsprechende Speichergruppe.

  3. Klicken Sie mit der rechten Maustaste auf den zu konfigurierenden Postfachspeicher, und wählen Sie dann Eigenschaften aus.

  4. Geben Sie auf der Registerkarte Grenzwerte im Feld Gelöschte Postfächer aufbewahren für (Tage) eine Aufbewahrungszeit für Postfächer ein.

  5. Klicken Sie auf OK, um die Änderungen zu speichern.
Hinweis:
Sie können ein Postfach möglicherweise wiederherstellen, wenn die Aufbewahrungszeit dieses Postfachs noch nicht abgelaufen ist und das zugeordnete Benutzerobjekt nicht gelöscht wurde.

Weitere Informationen zum Wiederherstellen von gelöschten Postfächern finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 274343, „How to Recover a Deleted Mailbox in Exchange" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=274343

  • 813337, „SO WIRD'S GEMACHT: Wiederherstellen eines einzelnen Postfachs in Exchange 2000 Server" unter http://support.microsoft.com/kb/813337/de

  • 823176, „SO WIRD'S GEMACHT: Ein einzelnes Postfach in Exchange Server 2003 wiederherstellen" unter http://support.microsoft.com/kb/823176/de


Domäne verfügt über unbekannte Exchange-Signatur.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2006-12-04

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um festzustellen, welche Version von DomainPrep in der angegebenen Domäne zuletzt ausgeführt wurde. Die Versionsnummer von DomainPrep fungiert als Exchange-Signatur für die Domäne. Exchange Server Analyzer überprüft das Attribut objectVersion des angegebenen Objekts Exchange-Systemobjekte der Domäne. Es gibt zwei gültige ganze Zahlen:

  • Der Wert für objectVersion für Exchange 2000 Server lautet 4406.

  • Der Wert für objectVersion für Exchange Server 2003 lautet 6936.

  • Der Wert für objectVersion für Exchange Server 2007 lautet 10628.

Wenn Exchange Server Analyzer keinen der oben genannten Werte für das Attribut objectVersion findet, wird eine Fehlermeldung angezeigt.

Wenn Sie in der angegebenen Domäne eine Vorabversion von Exchange 2000 Server oder Exchange Server 2003 installiert haben, jedoch die veröffentlichte Version von DomainPrep nicht ausgeführt haben, ist dieser Wert wahrscheinlich falsch.

Hinweis:
In Microsoft Exchange 2000 Server und Exchange Server 2003 wurden die Vorbereitungsschritte für Active Directory durch Ausführen von setup /forestprep und setup /domainprep durchgeführt. Exchange 2007 verfügt nicht über die Optionen /forestprep und /domainprep. Für Exchange Server 2007 führen Sie den Vorgang setup /PrepareDomain oder den Setup-Assistenten mit einem Konto aus, das über die erforderlichen Berechtigungen zum Vorbereiten von Active Directory und der Domäne verfügt.

Um diesen Fehler für Exchange 2000 Server oder Exchange Server 2003 zu beheben, müssen Sie die endgültige Version von Exchange 2000 Server DomainPrep, Exchange Server 2003 DomainPrep, die endgültige Version des PrepareDomain-Vorgangs oder den Setup-Assistenten für Exchange Server 2007 ausführen. Das Konto, das Sie zum Ausführen von DomainPrep, PrepareDomain oder des Setup-Assistenten verwenden, muss ein Mitglied der Sicherheitsgruppe Domänen-Admins in der lokalen Domäne sein und über Administratorberechtigungen auf dem lokalen Computer verfügen.

  • Stammdomäne.

  • Alle Domänen, die Computer mit Exchange 2000 Server oder Exchange Server 2003 enthalten.

  • Alle Domänen, die postfachaktivierte Objekte von Exchange 2000 Server oder Exchange Server 2003 (z. B. Benutzer und Gruppen) enthalten, selbst wenn keine Exchange-Server in diesen Domänen installiert sind.

  • Alle Domänen, die globale Katalogserver enthalten, die u. U. Exchange-Verzeichnis-Zugriffskomponenten potenziell verwenden.

  • Alle Domänen, die Exchange 2000 Server- oder Exchange Server 2003-Benutzer und -Gruppen enthalten, die zum Verwalten der Exchange-Organisation verwendet werden.

So führen Sie DomainPrep für Exchange 2000 Server oder Exchange Server 2003 aus

  1. Legen Sie die Exchange-CD in das CD-ROM-Laufwerk ein. DomainPrep kann auf jedem Computer in der Domäne ausgeführt werden.

  2. Geben Sie bei der Eingabeaufforderung den Pfad <Laufwerk>:\setup\i386\setup /DomainPrep ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Vergewissern Sie sich, dass auf der Seite Auswahl der Komponenten die Option Aktion auf DomainPrep festgelegt ist. Ist dies nicht der Fall, klicken Sie auf den Dropdown-Pfeil und danach auf DomainPrep. Klicken Sie auf Weiter.

  7. Klicken Sie auf der Seite zum Fertig stellen des Microsoft Exchange-Assistenten auf Fertig stellen.

So führen Sie PrepareDomain für Exchange Server 2007 aus

  1. Führen Sie die schrittweise Anleitung unter "Vorbereiten von Active Directory und Domänen" aus (http://go.microsoft.com/fwlink/?LinkId=78453)

Weitere Informationen zum Ausführen von Exchange Server 2003 DomainPrep finden Sie im Bereitstellungshandbuch für Exchange Server 2003 unter http://www.microsoft.com/germany/technet/datenbank/articles/600270.mspx.

Weitere Informationen zum Ausführen von Exchange 2000 Server DomainPrep finden Sie in „Microsoft Exchange 2000 Server Installation and Setup" unter http://go.microsoft.com/fwlink/?LinkId=5906.

Weitere Informationen zum Vorbereiten von Active Directory und Domänen für Exchange Server 2007 finden Sie unter "Vorbereiten von Active Directory und Domänen" (http://go.microsoft.com/fwlink/?LinkId=78453).


Domänencontroller führt Virtual Server 2005 aus, wobei Exchange Server als Gast installiert ist.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt die die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_ComputerSystem ab, um zu ermitteln, ob der Wert für den Schlüssel Model auf Virtual Machine festgelegt ist.

Exchange Server Analyzer überprüft auch den folgenden Registrierungswert:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Darüber hinaus liest Exchange Server Analyzer den Schlüssel Domain Role von Win32_ComputerSystem auf dem physischen Computer, auf dem Microsoft Virtual Server 2005 ausgeführt wird. Ein Wert von mehr als 3 gibt an, dass es sich bei dem physischen Computer um einen Domänencontroller handelt.

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel Model die Zeichenfolge Virtual Machine enthält, dass der oben stehende Registrierungszweig vorhanden ist und dass Domain Role größer ist als 3, wird ein Fehler angezeigt.

Der Wert Virtual Machine für den Schlüssel Model zeigt an, dass der Exchange Server-Computer als virtueller Gastcomputer unter Virtual Server 2005 oder Microsoft Virtual PC 2004 ausgeführt wird. Da der oben genannte Registrierungszweig jedoch nur von Virtual Server 2005 erstellt wird, bedeutet sein Vorhandensein, dass der Exchange Server-Computer als virtueller Gastcomputer unter Virtual Server 2005 ausgeführt wird.

Das Ausführen einer beliebigen Version von Exchange Server auf einem virtuellen Computer oder einem Emulator wird von Microsoft nicht unterstützt. Dies gilt für Exchange Server unter Virtual Server 2005, Microsoft Virtual PC 2004 und sämtliche Anwendungen für virtuelle Computer von Drittanbietern. Microsoft Exchange-Server sind so entwickelt und getestet worden, dass sie nur auf realer Hardware, insbesondere auf den Hardwareplattformen ausgeführt werden können, die im Windows-Serverkatalog unter http://go.microsoft.com/fwlink/?linkid=17219 aufgeführt sind.

Außerdem stellt das Ausführen von Exchange als Gast eines virtuellen Servers auf einem Domänencontroller keine empfohlene Vorgehensweise dar, da dies keine ausreichende Redundanz zwischen Diensten ermöglicht.

So berichtigen Sie diesen Fehler

  1. Verschieben Sie die Postfächer aus dem Exchange-Server, der unter Virtual Server 2005 ausgeführt wird, auf einen nicht virtuellen Exchange Server-Computer.

  2. Lagern Sie beliebige Öffentliche Ordner aus, und übertragen Sie beliebige Rollen, die bei Bedarf von dem virtuellen Exchange-Server übernommen werden.

  3. Deinstallieren Sie Exchange von dem virtuellen Computer, um es außer Betrieb zu setzen und aus der Exchange-Infrastruktur und dem Active Directory ®-Verzeichnisdienst zu entfernen.

Weitere Informationen zum Verschieben von Postfächern finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 822892, „Verbesserungen von "Postfach verschieben" in Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975, „XADM: Differences Between Move Mailbox Methods" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

Weitere Informationen zur Unterstützung für in virtuellen Umgebungen ausgeführte Exchange Server-Computer finden Sie im Microsoft Knowledge Base-Artikel 320220 „Support Boundaries for Exchange Server on a Virtual Machine or an Emulation Machine" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).

Weitere Informationen zu Microsoft Virtual Server 2005 finden Sie unter http://go.microsoft.com/fwlink/?LinkId=34938.

Weitere Informationen zu Microsoft Virtual PC 2004 finden Sie unter http://go.microsoft.com/fwlink/?linkid=34663.


Domänennamen-FSMO-Rolle reagiert nicht.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs fSMORoleOwner des Domänennamen-Betriebsmasters im Konfigurationsnamenskontext zu bestimmen. Beispielsweise ist in einer Domäne contoso.com fSMORoleOwner für den Domänennamen-Betriebsmaster ein Attribut von CN=Partitions,CN=Configuration,DC=contoso,DC=com. Exchange Server Analyzer versucht dann, eine LDAP-Verbindung (Lightweight Directory Access Protocol) mit dem TCP-Anschluss 389 auf dem Domänencontroller zu öffnen, in der die Rolle aktuell vorhanden ist. Wenn Exchange Server Analyzer keine Verbindung mit dem Domänencontroller herstellen kann, wird ein Fehler angezeigt.

Der Domänennamenmaster stellt eine gesamtstrukturumfassende Betriebsmasterrolle dar, da er das Hinzufügen und Entfernen aller Verzeichnispartitionen in der Gesamtstrukturhierarchie verwaltet, ungeachtet der Domäne. Der Domänencontroller, der die Rolle des Domänennamenmasters ausführt, ist der einzige Domänencontroller, der folgende Vorgänge ausführen kann:

  • Hinzufügen neuer Domänen zur Gesamtstruktur.

  • Entfernen vorhandener Domänen aus der Gesamtstruktur.

  • Hinzufügen bzw. Entfernen von Querverweisobjekten auf externe Verzeichnisse.

In der Gesamtstruktur darf nur ein Domänennamenmaster vorhanden sein.

So berichtigen Sie diesen Fehler

  1. Überprüfen Sie, ob der im Fehler angegebene Verzeichnisserver online ist und ob andere Exchange-Server in der Organisation Zugriff darauf haben.

  2. Wenn der Verzeichnisserver außer Betrieb gesetzt wurde, müssen Sie die Rolle des Domänennamenmasters einem anderen Domänencontroller zuweisen.

Weitere Informationen über das Übertragen der Rolle des Domänennamen-Betriebsmasters auf einen anderen Domänencontroller finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • Weitere Informationen zu Microsoft Windows Server™ 2003 finden Sie in Artikel 324801 „Anzeigen und Übertragen von FSMO-Funktionen in Windows Server 2003" unter http://support.microsoft.com/?kbid=324801.

  • Weitere Informationen zu Microsoft Windows® 2000 Server finden Sie in Artikel 255690 „SO WIRD'S GEMACHT: Einsehen und Übertragen von FSMO-Funktionen in der GUI" unter http://support.microsoft.com/?kbid=255690.


Domänennamen-FSMO-Rolle wurde nicht gefunden.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Verzeichnisdienst Active Directory® ab, um das Attribut fSMORoleOwner des Domänennamen-Betriebsmasters im Konfigurationsnamenskontext zu bestimmen. Beispielsweise ist in einer Domäne mit dem Namen contoso.com fSMORoleOwner für die Domänennamensmaster ein Attribut von CN=Partitionen, CN=Konfiguration, DC=contoso, DC=com. Exchange Server Analyzer versucht dann, eine LDAP-Verbindung (Lightweight Directory Access Protocol) mit dem Domänenontroller zu öffnen. Wenn Exchange Server Analyzer feststellt, dass der im Attribut fSMORoleOwner angegebene Domänencontroller nicht antwortet, wird ein Fehler angezeigt.

Domänencontroller für Domänennamensmaster steuern das Hinzufügen oder Entfernen von Domänen in der Gesamtstruktur. In der Gesamtstruktur darf nur ein Domänennamenmaster vorhanden sein.

Sie müssen einen Domänennamensmaster für die Gesamtstruktur von Active Directory definieren. Exchange-Setup und Exchange Service Pack-Setup werden fehlschlagen, wenn ein Domänencontroller des Domänennamensmasters während des Einrichtens nicht online ist. Wenn der als Domänennamnesmaster aufgeführte Domänencontroller offline ist, muss er online geschaltet werden.

So berichtigen Sie diesen Fehler

  1. Überprüfen Sie, ob der designierte Active Directory-Server vorhanden ist.

  2. Wenn der Verzeichnisserver außer Betrieb gesetzt wurde, weisen Sie die Rolle des Domänennamensservers einem anderen Domänencontroller zu.

Weitere Informationen zum Zuweisen der Rolle des Domänennamensmasters an einen anderen Domänencontroller findne Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • Für Microsoft Windows Server™ 2003: 324801, „Anzeigen und Übertragen von FSMO-Funktionen in Windows Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801).

  • Für Microsoft Windows® 2000 Server: 255690, „Einsehen und Übertragen von FSMO-Funktionen in der GUI" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Auflösungsfehler für DNS-Namen des Verzeichnisservers
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer versucht auf den konfigurierten DNS-Servern eine DNS-Abfrage (Domain Name System) für jeden Active Directory®-Verzeichnisdienstserver durchzuführen. Diese Verbindung wird mithilfe eines benutzerdefinierten Objektprozessors hergestellt, der eine Namensauflösung anfordert und die Ergebnisse analysiert. Wenn Exchange Server Analyzer keine IP-Adresse aus den Abfrageergebnissen erhält, wird ein Fehler angezeigt.

Dieser Fehler weist darauf hin, dass in DNS kein Verzeichnisserver gefunden wurde. Für eine ordnungsgemäße Funktionsweise von Exchange Server und Active Directory ist ein ordnungsgemäß konfiguriertes und fehlerfreies DNS erforderlich. Probleme bei der DNS-Registrierung und -Auflösung können weitreichende Auswirkungen auf die Funktionen zum Senden, Übermitteln und Empfangen von Nachrichten haben.

DNS muss korrekt konfiguriert werden, um eine ordnungsgemäße Funktionsweise von Active Directory und Exchange Server zu gewährleisten. Ausführlichere Informationen zur DNS-Konfiguration für Active Directory finden Sie im Microsoft Knowledge Base-Artikel 237675, „Einrichten von DNS für Active Directory" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=237675).

So beheben Sie diesen Fehler

  1. Überprüfen Sie die folgenden Konfigurationselemente, um zu gewährleisten, dass DNS fehlerfrei funktioniert und die Active Directory-DNS-Einträge ordnungsgemäß registriert werden:

    • DNS-IP-Konfiguration

    • Dynamische Zonenaktualisierungnen

    • DNS-Weiterleitungen

  2. Überprüfen Sie, ob ein Stammzoneneintrag vorhanden ist. Zeigen Sie die Zonen für Forward Lookup in der DNS-Verwaltungskonsole an. Dort muss Eintrag für die Domäne vorliegen. Möglicherweise sind auch andere Zoneneinträge vorhanden. Es darf keine Punktzone („.") vorliegen. Wenn die Punktzone („.") vorhanden ist, löschen Sie diese. Die Punktzone („.") identifiziert den DNS-Server als Stammserver. Üblicherweise darf eine Active Directory-Domäne, die externen (Internet-) Zugriff benötigt, nicht als DNS-Stammserver konfiguriert werden. Registrieren Sie die Verzeichnisserver-IP-Adresse erneut manuell mithilfe von Ipconfig /registerdns auf dem Verzeichnisserver, nachdem Sie den Punkt („.") gelöscht haben. Der Netlogon-Dienst muss möglicherweise ebenfalls neu gestartet werden.

  3. Füllen Sie die Active Directory-DNS-Einträge mithilfe von netdiag /fix auf dem Verzeichnisserver erneut manuell auf.

Weitere Informationen zur Verwendung von DNS mit Active Directory finden Sie im Microsoft Knowledge Base-Artikel 323418, „How To Integrate DNS with an Existing DNS Infrastructure If Active Directory Is Enabled in Windows Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=323418.

Weitere Informationen zum Beheben von Problemen mit DNS und Active Directory finden Sie im Microsoft Knowledge Base-Artikel 260371, „Behandlung häufig auftretender Active Directory-Probleme in Windows 2000" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=260371.


Für Hosted Exchange ist „dSHeuristics" nicht richtig festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob es sich um eine Hosted Exchange-Bereitstellung handelt. Wenn die Exchange-Bereitstellung in einer gehosteten Umgebung ausgeführt wird, fragt Exchange Server Analyzer Active Directory ab, um zu bestimmen, ob das Attribut dSHeuristics des Verzeichnisdienstcontainers für eine Hosted Exchange-Bereitstellung richtig festgelegt ist.

Wenn der Wert von dSHeuristics nicht gleich 1 ist, wird von Exchange Server Analyzer eine Warnung angezeigt. In einer Hosted Exchange-Umgebung muss das Attribut dSHeuristics auf 1 festgelegt sein.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So beheben Sie diese Warnung

  1. Verwenden Sie einen Active Directory-Editor (z. B. das ADSI-Bearbeitungs-Snap-In), um das Verzeichnisdienstobjekt in Active Directory zu suchen.

    Das Attribut dSHeuristics befindet sich unter:

    CN=Configuration, CN=Services, CN=Windows NT, CN=Directory Service

  2. Geben Sie den Wert 1 für dSHeuristics ein.

Weitere Informationen zu Hosted Exchange-Umgebungen finden Sie in den folgenden Artikeln:

  • "Information for Hosters" (http://go.microsoft.com/fwlink/?LinkId=46307)

  • „Hosted Service Environments" im ExchangeServer 2000 Resource Kit (http://go.microsoft.com/fwlink/?LinkId=46326).


Container „Microsoft Exchange-Systemobjekte" ist in Active Directory doppelt vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob der Container Microsoft Exchange-Systemobjekte im Namenskontext der Domäne vorhanden ist.

Wenn Exchange Server Analyzer feststellt, dass der Container Microsoft Exchange-Systemobjekte in Active Directory doppelt vorhanden ist, wird von Exchange Server Analyzer ein Fehler angezeigt. „+++Die Active Directory-Domäne wurde für Exchange vorbereitet, es sind jedoch mehrere Container 'Microsoft Exchange-Systemobjekte' vorhanden. Ein Cleanup ist möglicherweise erforderlich."

Dieses Problem kann in Exchange Server-Umgebungen unter folgenden Umständen auftreten:

  • Eine bidirektionale ADC-Server-Verbindungsvereinbarung (Active Directory Connector) von Active Directory nach Exchange Server 5.5 wurde gelöscht und ersetzt.

  • Eine neue unidirektionale ADC-Server-Verbindungsvereinbarung von Exchange Server 5.5 nach Active Directory ist vorhanden.

  • Eine Umgebung im gemischten Modus, in der Exchange Server 5.5 ausgeführt wird, wurde in eine Exchange Server 2003-Umgebung migriert.

  • Eine Migration von einem fremden Mailserver nach Exchange Server 2003 wurde ausgeführt.

Wenn Exchange Server Analyzer diesen Fehler anzeigt, müssen Sie den Container bzw. die Organisationseinheit Microsoft Exchange-Systemobjekte löschen, der bzw. die falsch und doppelt vorhanden ist. Wenn ein Container Microsoft Exchange-Systemobjekte doppelt vorhanden ist, kann das Problem nicht dadurch behoben werden, dass Sie DomainPrep erneut ausführen. Sie müssen den falschen, doppelten Container Microsoft Exchange-Systemobjekte bestimmen und löschen.

So entfernen Sie den doppelten Container „Microsoft Exchange-Systemobjekte"

  1. Melden Sie sich am Domänencontroller mit Administratorenrechten an.

  2. Klicken Sie auf Start, klicken Sie auf Programme, klicken Sie auf Verwaltung, und klicken Sie dann auf Active Directory-Benutzer und -Computer.

  3. Klicken Sie im Bereich der Verwaltungskonsole Active Directory-Benutzer und -Computer im Menü der Symbolleiste auf Ansicht, und wählen Sie Erweiterte Funktionen aus.

  4. Suchen Sie im Bereich der Verwaltungskonsole Active Directory-Benutzer und -Computer den Container oder die Organisationseinheit Microsoft Exchange-Systemobjekte, der bzw. die falsch und doppelt vorhanden ist.

  5. Überprüfen Sie, dass in dem Container oder der Organisationseinheit Microsoft Exchange-Systemobjekte, der bzw. die falsch und doppelt vorhanden ist, keine gültigen Active Directory-Objekte enthalten sind.

  6. Klicken Sie mit der rechten Maustaste auf den Container oder die Organisationseinheit Microsoft Exchange-Systemobjekte, der bzw. die falsch und doppelt vorhanden ist, und klicken Sie dann auf Löschen.

  7. Bestätigen Sie den Löschvorgang, indem Sie im Dialogfeld Active Directory auf Ja klicken.

    Hinweis:
    Wenn diese Änderung sofort repliziert werden soll, müssen Sie die Replikation zwischen den Domänencontrollern manuell initiieren.

Weitere Informationen zu diesem Exchange Server-Problem finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 316280, „XADM: A Description of the 'ADC Global Names' Attribute" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=316280)

  • 252228, „XADM: ADC Appears to Create Duplicate Objects" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=252228)

  • 253800, „XADM: ADC May Create Duplicate Objects in Active Directory" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=253800)

  • 274480, „XADM: Duplicate Object Created When Replicating Objects from Exchange Server 5.5 to Windows 2000 Active Directory" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=274480)

  • 288578, „XADM: ADC Creates Duplicate Accounts in Exchange Server 5.5 and Active Directory" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=288578)


Fehler beim Zugriff auf Active Directory
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer hat festgestellt, dass ein Domänencontroller für den Active Directory®-Verzeichnisdienst eventuell nicht verfügbar ist. Stellen Sie sicher, dass Sie über das Netzwerk mit einem Active Directory-Domänencontroller verbunden sind.

So beheben Sie diesen Fehler

  • Wenn Sie in Exchange Server Analyzer einen Active Directory-Domänencontroller angegeben haben, versuchen Sie, ohne Angabe eines Domänencontrollers die Verbindung herzustellen.

  • Wenn Sie noch keinen Domänencontroller angegeben haben, geben Sie einen Domänencontroller an, der ausgeführt wird und für Sie verfügbar ist.


Fehler beim Zugriff auf administrative Gruppen von Exchange
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

The Microsoft® Exchange Server Analyzer hat festgestellt, dass eine Exchange-Organisation in der Gesamtstruktur des Active Directory®-Verzeichnisdienstes installiert wurde und dass Sie auf die Konfigurationsinformationen der Exchange-Organisation in Active Directory zugreifen konnten. Es wurden jedoch keine administrativen Gruppen, die Exchange-Server enthalten, gefunden.

So beheben Sie diesen Fehler

  • Stellen Sie sicher, dass Sie in Active Directory die entsprechenden Berechtigungen haben, um auf den Container für administrative Exchange-Gruppen zuzugreifen.

  • Wenn die Arbeitsstation, auf der Exchange Server Analyzer ausgeführt wird, zu einer anderen Active Directory-Gesamtstruktur gehört oder wenn Sie nicht bei einem Domänenkonto angemeldet sind, müssen Sie möglicherweise zu einem Active Directory-Domänencontroller von einer Gesamtstruktur, die als Host von Exchange-Servern fungiert, die Verbindung herstellen.


Fehler beim Zugriff auf den Exchange-Container „Konfiguration"
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer hat festgestellt, dass der Zugriff auf den Exchange-Container „Konfiguration" verweigert wird. Exchange-Informationen organisatorischer Art, zu administrativen Gruppen und zur Serverkonfiguration werden im Konfigurationsnamenskontext im Active Directory®-Verzeichnisdienst gespeichert. Wenn Sie auf Exchange-Konfigurationsinformationen zugreifen möchten, müssen Sie den Microsoft Exchange-Zweig des Konfigurationscontainers von Active Directory lesen können.

So beheben Sie diesen Fehler

  • Stellen Sie sicher, dass Sie die Berechtigung haben, den Konfigurationscontainer von Active Directory zu lesen.

  • Stellen Sie sicher, dass Sie über das Netzwerk mit einem Active Directory-Domänencontroller verbunden sind.


Der Sicherheitsgruppe Everyone wird nicht das Recht verweigert, Öffentliche Ordner der obersten Ebene zu erstellen
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2006-12-04

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob die Sicherheits-ID (SID) für die Sicherheitsgruppe Everyone im ntSecurityDescriptor des Exchange-Organisationsobjekts aufgelistet ist. Wenn Exchange Server Analyzer feststellt, dass die SID für die Sicherheitsgruppe Everyone im ntSecurityDescriptor des Organisationsobjekts vorhanden ist, wird eine Warnung angezeigt. Diese Warnung gibt an, dass der Gruppe Everyone nicht die Berechtigung verweigert wurde, Öffentliche Ordner der obersten Ebene zu erstellen.

In Exchange 2000 Server ist die Berechtigung zum Erstellen von Öffentlichen Ordnern der obersten Ebene in der Standardeinstellung festgelegt. Wenn jedoch die Exchange Server 2003-Version von ForestPrep oder die Exchange Server 2007-Version von PrepareAD ausgeführt wird, wird der Sicherheitsgruppe Everyone der Zugriff zum Erstellen von Öffentlichen Ordnern der obersten Ebene verweigert. Die Verweigerungsfunktion wurde als Sicherheitsmaßnahme implementiert. Wenn Sie zulassen, dass die Sicherheitsgruppe Everyone Öffentliche Ordner der obersten Ebene erstellt, wird Ihre Organisation möglicherweise anfälliger für DOS-Angriffe (Denial of Service).

Deshalb besteht die optimale Methode darin, der Sicherheitsgruppe Everyone die Berechtigung zum Erstellen von Öffentlichen Ordnern der obersten Ebene zu verweigern. Wenn Sie Exchange Server 2003 oder Exchange Server 2007 einsetzen, sollten Sie die Exchange Server 2003-Version von ForestPrep bzw. die Exchange Server 2007-Version von PrepareAD ausführen. Sie können die Exchange Server 2003-Version von ForestPrep in einer Exchange 2000 Server-Umgebung ausführen. Durch nachfolgende Installationen von Exchange 2000 Server werden die Berechtigungen so zurückgesetzt, dass für die Sicherheitsgruppe Everyone das Erstellen von Öffentlichen Ordnern zugelassen wird.

Wenn Sie weder über Exchange Server 2003 noch über Exchange Server 2007 verfügen, können Sie diese Berechtigung manuell festlegen. Beachten Sie, dass durch nachfolgende Installationen von Exchange 2000 Server diese Berechtigung zurückgesetzt wird. Daher muss nach jeder Installation von Exchange 2000 Server diese Berechtigung manuell konfiguriert werden. Bevor Sie diese Berechtigung festlegen können, müssen Sie im Exchange-System-Manager das Anzeigen der Registerkarte Sicherheit aktivieren, indem Sie beispielsweise der Registrierung auf dem Exchange Server-Computer den Eintrag ShowSecurityPage hinzufügen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So fügen Sie der Registrierung den Eintrag „ShowSecurityPage" hinzu

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKEY_CURRENT_USER\Software\Microsoft\Exchange\ExAdmin

  3. Klicken Sie auf Bearbeiten, klicken Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  4. Geben Sie für den neuen Wertnamen ShowSecurityPage ein, und drücken Sie dann die EINGABETASTE.

  5. Doppelklicken Sie auf ShowSecurityPage, geben Sie im Feld Datenwerte den Wert 1 ein, und klicken Sie dann auf OK.

So verweigern Sie der Sicherheitsgruppe Everyone manuell das Recht zum Erstellen von Öffentlichen Ordnern der obersten Ebene in einer Exchange 2000 Server-Umgebung

  1. Öffnen Sie den Exchange-System-Manager.

  2. Klicken Sie mit der rechten Maustaste auf den Namen der Organisation, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Eigenschaftenseite für die Organisation auf die Registerkarte Sicherheit.

  4. Wählen Sie auf der Registerkarte Sicherheit unter Gruppen- und Benutzernamen den Eintrag Everyone aus. Führen Sie im Feld mit den Berechtigungen für Everyone einen Bildlauf nach unten zu der Berechtigung zum Erstellen von Öffentlichen Ordnern der obersten Ebene aus, deaktivieren Sie in der Spalte Zulassen das Kontrollkästchen, und klicken Sie dann auf Übernehmen.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Weitere Informationen zum Ausführen von Exchange Server 2003 ForestPrep finden Sie im Bereitstellungshandbuch für Exchange Server 2003 unter http://go.microsoft.com/fwlink/?LinkId=47569.

Weitere Informationen zum Ausführen von Exchange Server 2007 PrepareAD finden Sie unter "Vorbereiten von Active Directory und Domänen" (http://go.microsoft.com/fwlink/?LinkId=78453).

Weitere Informationen dazu, wie der Sicherheitsgruppe Everyone das Recht zum Erstellen von Öffentlichen Ordnern der obersten Ebene in Exchange 2000 Server verweigert wird, finden Sie im Knowledge Base-Artikel 328808 „HOW TO: Remove User Permission from the Create Top-Level Public Folder in Exchange 2000" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328808.


Containerproblem der Exchange-Domäne
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob der Container Microsoft Exchange-Systemobjekte im Namenskontext der Domäne vorhanden ist. Wenn Exchange Server Analyzer feststellt, dass der Container Microsoft Exchange-Systemobjekte nicht vorhanden ist oder anderweitig ungültig oder fehlerhaft ist, wird ein Fehler angezeigt.

Der Container Microsoft Exchange-Systemobjekte wird beim Ausführen von Exchange DomainPrep in jeder Domäne erstellt.

Sie müssen DomainPrep in der Domäne ausführen, in der der Fehler gefunden wurde. Der Domänenname, bei dem der Container Microsoft Exchange-Systemobjekte fehlt, wird in der Ausgabe von Exchange Server Analyzer aufgeführt.

Das Konto, das Sie zum Ausführen von DomainPrep verwenden, muss ein Mitglied der Sicherheitsgruppe Domänen-Admins in der lokalen Domäne und ein Administrator des lokalen Computers sein.

I. d. R wird DomainPrep in den folgenden Domänen ausgeführt:

  • Stammdomäne.

  • Alle Domänen, die Computer mit Exchange 2000 Server oder Exchange Server 2003 enthalten.

  • Alle Domänen, die postfachaktivierte Objekte von Exchange 2000 Server oder Exchange Server 2003 (wie Benutzer und Gruppen) enthalten, selbst wenn keine Exchange-Server in diesen Domänen installiert sind.

  • Alle Domänen, die globale Katalogserver enthalten, die u. U. Exchange-Verzeichnis-Zugriffskomponenten potenziell verwenden.

  • Alle Domänen, die Exchange 2000 Server- oder Exchange Server 2003-Benutzer und -Gruppen enthalten, die zum Verwalten der Exchange-Organisation verwendet werden.

So führen Sie DomainPrep aus

  1. Legen Sie die Exchange-CD in das CD-ROM-Laufwerk ein. DomainPrep kann auf jedem Computer in der Domäne ausgeführt werden.

  2. Geben Sie bei der Eingabeaufforderung den Pfad <Laufwerk>:\setup\i386\setup /DomainPrep ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Product Key ein, und klicken Sie dann auf Weiter.

  6. Vergewissern Sie sich, dass auf der Seite Auswahl der Komponenten die Option Aktion auf DomainPrep festgelegt ist. Ist dies nicht der Fall, klicken Sie auf den Dropdown-Pfeil und danach auf DomainPrep. Klicken Sie auf Weiter.

  7. Klicken Sie auf der Seite Fertigstellen des Microsoft Exchange-Assistenten auf Fertig stellen.

Weitere Informationen zum Ausführen von Exchange Server 2003 DomainPrep finden Sie im Bereitstellungshandbuch für Exchange Server 2003 unter http://www.microsoft.com/germany/technet/datenbank/articles/600270.mspx.

Weitere Informationen zum Ausführen von Exchange 2000 Server DomainPrep finden Sie in „Microsoft Exchange 2000 Server Installation and Setup" unter http://go.microsoft.com/fwlink/?LinkId=5906.


Exchange-Domänenservergruppe wurde nicht gefunden.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert für das Attribut ntSecurityDescriptor des Objekts Microsoft Exchange-Systemobjekte und damit die in der Domäne ausgeführten Version von DomainPrep zu ermitteln.

Es gibt zwei gültige ganze Zahlen:

  • Der Wert für ntSecurityDescriptor für Exchange 2000 Server lautet 4406.

  • Der Wert für ntSecurityDescriptor für Exchange Server 2003 lautet 6936.

Wenn festgestellt wird, dass eine der oben genannten Versionen von DomainPrep verwendet wurden, fragt Exchange Server Analyzer Active Directory ab, um den Wert des Attributs objectGuid des Objekts Microsoft Exchange-Systemobjekte zu ermitteln und festzustellen, ob die Gruppe Exchange Domain Servers vorhanden ist. Wenn Microsoft Exchange Server Analyzer feststellt, dass diese Gruppe nicht vorhanden ist, wird ein Fehler angezeigt.

Führen Sie zum Beheben dieses Fehlers die endgültige Version von Exchange 2000 Server DomainPrep oder Exchange Server 2003 DomainPrep aus. Das Konto, das Sie zum Ausführen von DomainPrep verwenden, muss ein Mitglied der Sicherheitsgruppe Domänen-Admins in der lokalen Domäne sein und über Administratorberechtigungen auf dem lokalen Computers verfügen.

Sie müssen DomainPrep in den folgenden Domänen ausführen:

  • Stammdomäne.

  • Alle Domänen, die Computer mit Exchange 2000 Server oder Exchange Server 2003 enthalten.

  • Alle Domänen, die postfachaktivierte Objekte von Exchange 2000 Server oder Exchange Server 2003 (z. B. Benutzer und Gruppen) enthalten, selbst wenn keine Exchange-Server in diesen Domänen installiert sind.

  • Alle Domänen, die globale Katalogserver enthalten, die u. U. Exchange-Verzeichnis-Zugriffskomponenten potenziell verwenden.

  • Alle Domänen, die Exchange 2000 Server- oder Exchange Server 2003-Benutzer und -Gruppen enthalten, die zum Verwalten der Exchange-Organisation verwendet werden.

So führen Sie DomainPrep aus

  1. Legen Sie die Exchange-CD in das CD-ROM-Laufwerk ein. DomainPrep kann auf jedem Computer in der Domäne ausgeführt werden.

  2. Geben Sie an der Eingabeaufforderung den Pfad <Laufwerk>:\setup\i386\setup /DomainPrep ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Product Key ein, und klicken Sie dann auf Weiter.

  6. Vergewissern Sie sich, dass auf der Seite Auswahl der Komponenten die Option Aktion auf DomainPrep festgelegt ist. Ist dies nicht der Fall, klicken Sie auf den Dropdown-Pfeil und danach auf DomainPrep. Klicken Sie auf Weiter.

  7. Klicken Sie auf der Seite Fertigstellen des Microsoft Exchange-Assistenten auf Fertig stellen.

Weitere Informationen zum Ausführen von Exchange Server 2003 DomainPrep finden Sie im Bereitstellungshandbuch für Exchange Server 2003 unter http://www.microsoft.com/germany/technet/datenbank/articles/600270.mspx.

Weitere Informationen zum Ausführen von Exchange 2000 Server DomainPrep finden Sie in „Microsoft Exchange 2000 Server Installation and Setup" unter http://go.microsoft.com/fwlink/?LinkId=5906.


Exchange Enterprise Server-Gruppe wurde nicht gefunden.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert für das Attribut ntSecurityDescriptor des Objekts Microsoft Exchange-Systemobjekte und damit die in der Domäne ausgeführten Version von DomainPrep zu ermitteln.

Es gibt zwei gültige ganze Zahlen:

  • Der Wert für ntSecurityDescriptor für Exchange 2000 Server lautet 4406.

  • Der Wert für ntSecurityDescriptor für Exchange Server 2003 lautet 6936.

Wenn festgestellt wird, dass beide der oben aufgeführten Versionen von DomainPrep verwendet wurden, fragt Exchange Server Best Practice Analyzer Active Directory ab, um den Wert des Attributs objectGuid des Objekts Microsoft Exchange-Systemobjekte zu bestimmen, um festzustellen, ob die Gruppe Exchange Enterprise Server vorhanden ist. Wenn Microsoft Exchange Server Analyzer feststellt, dass diese Gruppe nicht vorhanden ist, wird ein Fehler angezeigt.

Führen Sie zum Beheben dieses Fehlers die endgültige Version von Exchange 2000 Server DomainPrep oder Exchange Server 2003 DomainPrep aus. Das Konto, das Sie zum Ausführen von DomainPrep verwenden, muss ein Mitglied der Sicherheitsgruppe Domänen-Admins in der lokalen Domäne sein und über Administratorberechtigungen auf dem lokalen Computers verfügen.

Sie müssen DomainPrep in den folgenden Domänen ausführen:

  • Stammdomäne.

  • Alle Domänen, die Computer mit Exchange 2000 Server oder Exchange Server 2003 enthalten.

  • Alle Domänen, die postfachaktivierte Objekte von Exchange 2000 Server oder Exchange Server 2003 (z. B. Benutzer und Gruppen) enthalten, selbst wenn keine Exchange-Server in diesen Domänen installiert sind.

  • Alle Domänen, die globale Katalogserver enthalten, die u. U. Exchange-Verzeichnis-Zugriffskomponenten potenziell verwenden.

  • Alle Domänen, die Exchange 2000 Server- oder Exchange Server 2003-Benutzer und -Gruppen enthalten, die zum Verwalten der Exchange-Organisation verwendet werden.

So führen Sie DomainPrep aus

  1. Legen Sie die Exchange-CD in das CD-ROM-Laufwerk ein. DomainPrep kann auf jedem Computer in der Domäne ausgeführt werden.

  2. Geben Sie an der Eingabeaufforderung den Pfad <Laufwerk>:\setup\i386\setup /DomainPrep ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Product Key ein, und klicken Sie dann auf Weiter.

  6. Vergewissern Sie sich, dass auf der Seite Auswahl der Komponenten die Option Aktion auf DomainPrep festgelegt ist. Ist dies nicht der Fall, klicken Sie auf den Dropdown-Pfeil und danach auf DomainPrep. Klicken Sie auf Weiter.

  7. Klicken Sie auf der Seite Fertigstellen des Microsoft Exchange-Assistenten auf Fertig stellen.

Weitere Informationen zum Ausführen von Exchange Server 2003 DomainPrep finden Sie im Bereitstellungshandbuch für Exchange Server 2003 unter http://www.microsoft.com/germany/technet/datenbank/articles/600270.mspx.

Weitere Informationen zum Ausführen von Exchange 2000 Server DomainPrep finden Sie in „Microsoft Exchange 2000 Server Installation and Setup" unter http://go.microsoft.com/fwlink/?LinkId=5906.


Exchange-Objekt im Container „Lost and Found"
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2006-12-01

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob im Container LostAndFoundConfig unter dem Container Configuration Objekte vorhanden sind. Wenn Exchange Server Analyzer ermittelt, dass Objekte im Container LostAndFoundConfig vorhanden sind, wird ein Fehler zusammen mit dem Objekt und der Objektklasse angezeigt, von der das Objekt abgeleitet wurde.

Der Container LostAndFoundConfig enthält Objekte, die von Active Directory nicht in Übereinstimmung gebracht werden können. Löschen Sie alle Objekte, die sich im Container LostAndFoundConfig befinden, da Exchange andernfalls versuchen wird, diese Objekte zu verwenden. Wenn beispielsweise Active Directory von Exchange nach Objektklassen (d. h. Servern) abgefragt wird, werden alle Objekte, ungeachtet dessen, ob sie sich möglicherweise im Container LostAndFoundConfig befinden, als gültige Objekte zurückgegeben. In der Folge versucht Exchange möglicherweise, eine Verbindung mit dem Server herzustellen, der sich unter dem Container the LostAndFoundConfig befindet, statt eine Verbindung mit dem tatsächlichen Objekt herzustellen. Dies könnte zu einem unvorhersehbaren Verhalten von Exchange und möglicherweise zum Ausfall des Servers führen Die Präsenz dieser Objekte kann auch verhindern, dass Objekte derselben Klasse erstellt werden.

Um dieses Problem zu beheben, müssen Sie die Einträge im Container LostAndFoundConfig mithilfe der ADSI-Bearbeitung (ADSI - Active Directory Service Interfaces) aus Active Directory entfernen.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, von Exchange Server 2003 bzw. Exchange Server 2007 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
Hinweis:
Bei der ADSI-Bearbeitung handelt es sich um ein Tool, das mit den Supporttools von Windows 2000 Server und Windows Server 2003 geliefert wird.

So beheben Sie diesen Fehler

  1. Öffnen Sie das ADSI-Bearbeitungs-MMC-Snap-In.

  2. Klicken Sie im Menü Aktion auf Verbinden mit.

  3. Geben Sie im Dialogfeld Verbindungseinstellungen im Feld Name den Namen der ADSI-Verbindung ein. Unter Verbindungspunkt wählen Sie die Option zum Auswählen eines bekannten Namenskontexts aus. Anschließend wählen Sie im Dropdownmenü Konfiguration aus. Klicken Sie auf OK.

  4. Im linken Bereich doppelklicken Sie auf das Objekt Konfiguration. Anschließend doppelklicken Sie auf LostAndFoundConfig.

  5. Löschen Sie im rechten Bereich alle Objekte und Container. Klicken Sie mit der rechten Maustaste auf das Objekt oder den Container, klicken Sie auf Löschen und auf Ja.

  6. Beenden Sie die ADSI-Bearbeitung.


Die Exchange-Organisation verfügt nicht über Empfängerrichtlinien
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs Name im Empfängerrichtlinienobjekt für jede Exchange-Organisation zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass kein Empfängerrichtlinienobjekt vorhanden ist oder dass das Empfängerrichtlinienobjekt keine Empfängerrichtlinien enthält, wird ein Fehler angezeigt.

Wenn Exchange Server installiert ist, wird eine Standardempfängerrichtlinie erstellt, die SMTP-Adressen (Simple Mail Transfer Protocol) und X.400-Adressen auf alle Empfänger in der Exchange-Organisation anwendet. Sie können die Standardrichtlinie ändern oder neue Richtlinien erstellen. Die Standardrichtlinie darf jedoch keinesfalls gelöscht werden. Alle Empfänger in einer Exchange-Organisation müssen über SMTP- und X.400-Adressen verfügen. Wenn die Exchange-Organisation über keine Empfängerrichtlinien verfügt, können Zuverlässigkeitsprobleme auftreten.

So erstellen Sie eine Empfängerrichtlinie

  1. Klicken Sie auf Start, klicken Sie auf Alle Programme, klicken Sie auf Microsoft Exchange, und klicken Sie dann auf System-Manager.

  2. Erweitern Sie im linken Teilfenster des Exchange-System-Manager die Organisation, erweitern Sie Empfänger, und klicken Sie mit der rechten Maustaste auf Empfängerrichtlinien. Zeigen Sie auf Neu, und klicken Sie anschließend auf Empfängerrichtlinie.

  3. Wählen Sie im Dialogfeld Neue Richtlinie den Richtlinientyp aus, den Sie erstellen möchten, indem Sie das Kontrollkästchen E-Mail-Adressen, das Kontrollkästchen Postfach-Managereinstellungen oder beide aktivieren und auf OK klicken.

  4. Geben Sie im Dialogfeld Eigenschaften einen Namen für die Empfängerrichtlinie ein, und klicken Sie auf Ändern, um einen Filter für die Empfängerrichtlinie zu erstellen.

    Hinweis:
    Wenn Sie keinen Filter erstellen, wird die Richtlinie nicht auf die Empfänger angewendet.

  5. Sie können die Empfängerrichtlinie anpassen, indem Sie zur Registerkarte E-Mail-Adressen (Richtlinie) oder zur Registerkarte Postfach-Managereinstellungen (Richtlinie) im Dialogfeld Eigenschaften wechseln. Mit den Einstellungen auf diesen Registerkarten können Sie die Empfängerrichtlinie konfigurieren. Klicken Sie anschließend auf OK, um die Richtlinie zu erstellen.

  6. Klicken Sie im Exchange-System-Manager mit der rechten Maustaste auf die Empfängerrichtlinie, und klicken Sie auf Diese Richtlinie jetzt anwenden.

Weitere Informationen zu Empfängern und Empfängerrichtlinien finden Sie unter „Verwalten von Empfängern und Empfängerrichtlinien" im Exchange Server 2003-Administratorhandbuch (http://go.microsoft.com/fwlink/?linkid=21769).

Weitere Informationen zum Erstellen und Konfigurieren von Empfängerrichtlinien finden Sie im Microsoft Knowledge Base-Artikel 249299 „SO WIRD'S GEMACHT: Konfigurieren der Empfängerrichtlinien in Exchange" (http://support.microsoft.com/?scid=kb%3Bde%3B249299&x=12&y=7).


Die Exchange-Organisation verfügt nicht über Systemrichtlinien
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Namen der einzelnen Systemrichtlinien im Systemrichtlinienobjekt für jede Exchange-Organisation zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass kein Systemrichtlinienobjekt vorhanden ist oder dass das Systemrichtlinienobjekt keine Systemrichtlinien enthält, wird ein Fehler angezeigt.

Mit den Systemrichtlinienobjekten können Sie die Systemverwaltung durch das Konfigurieren von Parametern für mehrere Exchange-Server mit einem einzigen Konfigurationsobjekt wie beispielsweise Postfachspeicher, Informationsspeicher für Öffentliche Ordner oder Servereinstellungen vereinfachen. Wenn Sie in Ihrer Organisation ForestPrep ausführen, werden standardmäßig folgende Systemrichtlinien erstellt:

  • Ausgeblendete Verteilerlistenmitgliedschaft

  • E-Mail-aktivierter Empfänger

  • Postfachaktivierter Benutzer

Wenn diese standardmäßigen Systemrichtlinien in Ihrer Exchange-Organisation nicht vorhanden sind, können Zuverlässigkeitsprobleme auftreten. Um die standardmäßigen Systemrichtlinien erneut zu erstellen, muss ForestPrep ausgeführt werden.

So führen Sie Exchange Server 2003 ForestPrep aus

  1. Legen Sie die Exchange-CD in Ihr CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend Laufwerk:\setup\i386\setup /ForestPrep ein, wobei Laufwerk für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Product Key ein, und klicken Sie dann auf Weiter.

  6. Überprüfen Sie, ob auf der Seite Auswahl der Komponenten die Option Aktion auf ForestPrep festgelegt ist. Wenn dies nicht der Fall ist, klicken Sie auf den Dropdown-Pfeil und danach auf ForestPrep. Klicken Sie auf Weiter.

    Wichtig:
    Wenn ForestPrep unter der Option Aktion nicht angezeigt wird, haben Sie den Befehl für ForestPrep unter Schritt 2 möglicherweise falsch eingegeben. Wenn Sie den Befehl ForestPrep falsch eingegeben haben, gehen Sie zu Schritt 2 zurück, und geben Sie den Befehl erneut ein.

  7. Geben Sie auf der Seite Konto für Microsoft Exchange Server Administrator im Feld Konto den Namen des Kontos oder der Gruppe ein, von dem/der die Installation von Exchange ausgeführt wird.

    Hinweis:
    Das von Ihnen angegebene Konto ist auch berechtigt, den Assistenten für die Zuweisung von Verwaltungsberechtigungen auf Exchange-Objekte zu verwenden, um weitere Exchange-Administratorkonten zu erstellen. Weitere Informationen über den Assistenten für die Zuweisung von Verwaltungsberechtigungen auf Exchange-Objekte finden Sie im Verwaltungshandbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47617).

  8. Klicken Sie auf Weiter, um ForestPrep zu starten. Wenn ForestPrep gestartet wurde, kann der Vorgang nicht mehr abgebrochen werden.

    Hinweis:
    Die Fertigstellung von ForestPrep ist von der Topologie des Netzwerks und der Geschwindigkeit der Domänencontroller für Microsoft Windows® 2000 Server oder Microsoft Windows Server™ 2003 abhängig.

  9. Klicken Sie auf der Seite Fertigstellen des Microsoft Exchange-Assistenten auf Fertig stellen.

Weitere Informationen über die Verwendung von Systemrichtlinien in Exchange finden Sie im Knowledge Base-Artikel 253838, „XADM: der Empfängeraktualisierungsdienst wendet Systemrichtlinie an" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=253838)

Weitere Informationen über Systemrichtlinien finden Sie unter „Architektur des Exchange-System-Managers" im Technischen Referenzhandbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47891).

Weitere Informationen über das Erstellen nicht standardmäßiger Systemrichtlinien in Exchange finden Sie im Knowledge Base-Artikel 256141, „How to Create System Policies in Exchange" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256141).


Der NSPI-Anschluss des globalen Katalogs wurde außer Kraft gesetzt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2007-01-15

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag auf globalen Katalogservern, um festzustellen, ob der Registrierungsschlüssel TCP/IP Port festgelegt wurde:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters\TCP/IP Port

Wenn Exchange Server Analyzer feststellt, dass der Registrierungsschlüssel TCP/IP Port erstellt und festgelegt wurde, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Registrierungsschlüssel TCP/IP Port ist erforderlich, wenn ein globaler Katalogserver, der Daten für MAPI-Clients bereitstellt, einen bestimmten Port verwenden muss. Ist dies in Ihrer Exchange-Umgebung nicht erforderlich, können Sie diesen Schlüssel entfernen.

.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So entfernen Sie den TCP/IP-Anschluss auf dem globalen Katalogserver

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\NTDS\Parameters

  3. Klicken Sie mit der rechten Maustaste auf den Schlüssel TCP/IP Port, und klicken Sie dann auf Löschen.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den Computer neu, damit die Einstellung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Konfigurieren von RPC-über-HTTP finden Sie in den folgenden Knowledge Base-Artikeln:

  • 833401, „Konfigurieren von RPC-über-HTTP auf einem einzelnen Server in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, „Behandlung von Problemen bei RPC-über-HTTP-Clientverbindungen in Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)

  • 298369, „How to Configure a Global Catalog Server to Use a Specific Port When Servicing MAPI Clients" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298369)

  • 24823, „Exchange Server 2003 RPC over HTTP Deployment Scenarios" unter http://go.microsoft.com/fwlink/?linkid=47577.


Der Anschluss 3268 des globalen Katalogs reagiert nicht.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Microsoft Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs isGlobalCatalogReady für diesen Server zu ermitteln. Der Wert True für dieses Attribut gibt an, dass der Verzeichnisserver auch als globaler Katalogserver fungiert. Der Wert False gibt an, dass der Verzeichnisserver kein globaler Katalogserver ist.

Danach stellt Exchange Server Analyzer eine Verbindung mit dem Anschluss 3268 auf dem Exchange-Server her, um zu überprüfen, dass der Anschluss reagiert.

Microsoft Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Bei dem Server handelt es sich um einen globalen Katalogserver.

  • Der Anschluss 3268 reagiert nicht.

Hinweis:
Diese Nachricht wird möglicherweise zu Unrecht angezeigt, wenn sich zwischen dem Computer, auf dem Microsoft Exchange Server Analyzer ausgeführt wird, und dem globalen Katalogserver eine Firewall befindet.

Dieses Problem tritt normalerweise auf, wenn das Kontrollkästchen für den globalen Katalogserver aktiviert wurde, der Server jedoch nicht erneut gestartet wurde.

So beheben Sie dieses Problem

  • Starten Sie den Server erneut.

Weitere Informationen zum Heraufstufen von Domänencontrollern finden Sie im Microsoft Knowledge Base-Artikel 304403 „XADM: Exchange Considerations for Promoting a Domain Controller to a Global Catalog Server" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=304403.


Fehler in Gruppenklassenschema
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2006-12-01

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob die Klasse msExchBaseClass im auxiliaryClass-Attribut des Gruppenobjekts im Active Directory-Schema vorhanden ist.

Active Directory verfügt über vordefinierte Klassen, die all die unterschiedlichen Objekttypen definieren, die das Verzeichnis benötigt, um ordnungsgemäß funktionieren zu können. Objektdefinitionen werden durch das Ineinanderverschachteln von Klassen erstellt. Durch das Schachteln von Klassen wir eine hierarchische Beziehung (übergeordnet/untergeordnet) zwischen den Klassen erzeugt.

Die Klasse msExchBaseClass wird dem Active Directory hinzugefügt, wenn Exchange 2000 Server, Exchange Server 2003 oder Exchange Server 2007 installiert wird. Die Klasse msExchBaseClass ist die Basiserweiterungsklasse, die auf alle Klassen angewendet wird, die von CDO für Exchange 2000 Server, Exchange Server 2003 und Exchange Server 2007 (CDOEX) erweitert werden. CDOEX stellt die grundlegenden COM-Klassen und -Schnittstellen (Component Object Model, Komponentenobjektmodell) zur Verfügung, die zum Verwalten der meisten Arten von Informationen im Exchange-Informationsspeicher verwendet werden.

Fehlerhaftes Ändern des Active Directory-Schemas kann zur Unterbrechung der Beziehung zwischen der Klasse msExchBaseClass und dem Attribut auxiliaryClass von Gruppenobjekten führen. Diese Unterbrechung kann zur Instabilität von Exchange Server führen, z. B. Verarbeitungsfehler des Empfängeraktualisierungsdiensts oder ein Fehlschlagen der Installation neuer Exchange 200x-Server in der Organisation.

Wenn Exchange Server Analyzer feststellt, dass die Klasse msExchBaseClass nicht im Attribut auxiliaryClass der Gruppenobjekte im Active Directory-Schema vorhanden ist, weist dies auf eine Unterbrechung dieser Beziehung hin. Wenn die Klasse msExchBaseClass nicht im Attribut auxiliaryClass der Gruppenobjekte im Active Directory-Schema vorhanden ist, zeigt Exchange Server Analyzer einen Fehler an.

Wenden Sie wegen der Behandlung dieses Fehlers an den Microsoft-Kundensupport (http://go.microsoft.com/fwlink/?LinkId=41364).


Hosted Exchange erfordert eine Exchange-Organisation im einheitlichen Modus
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Microsoft Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob die Exchange Server-Umgebung als gehostete Exchange-Umgebung konfiguriert ist. Wenn es sich bei der Exchange Server-Umgebung um eine Hosted Exchange-Umgebung handelt, sendet Exchange Server Analyzer eine Anfrage an Active Directory, um zu bestimmen, ob die Exchange-Organisation im gemischten Modus ausgeführt wird.

Wenn die Exchange-Organisation im gemischten Modus ausgeführt wird, wird eine Warnung angezeigt. Für Hosted Exchange-Lösungen ist eine Organisation mit einheitlichem Modus erforderlich.

Nach einem Wechsel in den einheitlichen Modus kann kein Wechsel zurück in den gemischten Modus erfolgen.

So wechseln Sie in den einheitlichen Modus

  1. Starten Sie den Exchange-System-Manager: Klicken Sie auf Start, zeigen Sie auf Alle Programme, zeigen Sie auf Microsoft Exchange, und klicken Sie dann auf System-Manager.

  2. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf die Organisation, die in den einheitlichen Modus wechseln soll, und klicken Sie anschließend auf Eigenschaften.

  3. Klicken Sie im Eigenschaftenfenster für die Organisation klicken Sie unter Betriebsmodus ändern auf Modus ändern.

  4. Klicken Sie im Dialogfeld mit der Warnmeldung auf Ja, wenn Sie dauerhaft in den einheitlichen Modus wechseln möchten. Klicken Sie auf Übernehmen, um den neuen Exchange-Modus zu bestätigen.

Um den einheitlichen Exchange-Modus vollständig nutzen zu können, müssen Sie den Microsoft Exchange-Informationsspeicherdienst auf allen Exchange-Servern der Organisation neu starten. Es ist nicht erforderlich, alle Instanzen des Microsoft Exchange-Informationsspeicherdienstes gleichzeitig neu zu starten. Sie müssen den Dienst jedoch auf jedem Server neu starten, damit die Server die Vorteile des einheitlichen Exchange-Modus nutzen kann. Starten Sie den Dienst auf den Servern erneut, nachdem der Wechsel in den einheitlichen Modus auf dem lokalen Microsoft Windows®-Domänencontroller repliziert wurde.

So starten Sie den Microsoft Exchange-Informationsspeicherdienst neu

  1. Klicken Sie auf Start, klicken Sie auf Ausführen, und geben Sie services.msc ein. Klicken Sie anschließend auf OK.

  2. Suchen Sie im Bereich Dienste (Lokal) den Microsoft Exchange-Informationsspeicherdienst.

  3. Klicken Sie mit der rechten Maustaste auf den Dienst, und klicken Sie dann auf Neu starten.

Weitere Informationen zu Hosted Exchange-Umgebungen finden Sie in den folgenden Artikeln:

  • "Information for Hosters" (http://go.microsoft.com/fwlink/?LinkId=46307)

  • „Chapter 23 - Hosted Service Environments" im ExchangeServer 2000 Resource Kit (http://go.microsoft.com/fwlink/?LinkId=46326)

Weitere Informationen zum Konvertieren vom gemischten Modus in den einheitlichen Modus finden Sie im Microsoft Knowledge Base-Artikel 32779, „How To Convert from Mixed Mode to Native Mode in Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779).


Infrastruktur-FSMO-Server-Rolle reagiert nicht.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft®Microsoft Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs fSMORoleOwner des Infrastrukturmasters im Domänennamenskontext zu bestimmen. Beispielsweise ist fSMORoleOwner in einer Domäne mit dem Namen contoso.com für den Infrastrukturmaster ein Attribut von CN=Infrastructure,DC=contoso,DC=com. Exchange Server Analyzer versucht dann, eine LDAP-Verbindung (Lightweight Directory Access Protocol) mit dem TCP-Anschluss 389 auf dem Domänencontroller zu öffnen, in der die Rolle aktuell vorhanden ist. Wenn Exchange Server Analyzer keine Verbindung mit dem Domänencontroller herstellen kann, wird ein Fehler angezeigt.

Der Infrastrukturmaster aktualisiert die Gruppe-zu-Benutzer-Verweise , wenn die Mitglieder von Gruppen innerhalb einer Domäne umbenannt oder geändert werden. Der Domänencontroller mit der Infrastrukturmasterrolle für die Domäne der Gruppe aktualisiert den domänenübergreifenden Gruppe-zu-Benutzer-Verweis , um den neuen Namen des Benutzers zu aktualisieren. Der Infrastrukturmaster überprüft regelmäßig die Domänenkonten und die Mitgliedschaft der Gruppen. Wenn ein Benutzerkonto in eine Domäne verschoben wird, identifiziert der Infrastrukturmaster die neue Domäne des Benutzerkontos und aktualisiert die Gruppe dementsprechend. Nach dem lokalen Aktualisieren der Verweise durch den Infrastrukturmaster, werden alle anderen Replikate der Domäne mithilfe von Replikation aktualisiert. Wenn der Infrastrukturmaster nicht verfügbar ist, werden die Aktualisierungen verzögert. In jeder Domäne kann jeweils nur ein Domänencontroller als Infrastrukturmaster fungieren.

So berichtigen Sie diesen Fehler

  1. Überprüfen Sie, ob der im Fehler angegebene Verzeichnisserver online ist und ob andere Exchange-Server in der Organisation Zugriff darauf haben.

  2. Wenn der Verzeichnisserver außer Betrieb gesetzt wurde, weisen Sie die Rolle des Infrastrukturmasters einem anderen Domänencontroller zu.

Weitere Informationen zur Übertragung der Infrastrukturmasterrolle von einem Domänencontroller auf einen anderen Domänencontroller finden Sie in den Microsoft Knowledge Base-Artikeln:

  • Für Microsoft Windows Server™ 2003: „Anzeigen und Übertragen von FSMO-Funktionen in Windows Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801).

  • Für Microsoft Windows 2000 Server: 255690 „SO WIRD'S GEMACHT: Einsehen und Übertragen von FSMO-Funktionen in der GUI" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Ungültiges Versionsattribut für das Exchange-Organisationsobjekt
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2007-02-28

Microsoft Exchange Server Analyzer fragt den Active Directory-Verzeichnisdienst ab, um die Schemaversionsinformationen für Exchange zu ermitteln. Exchange Server Analyzer untersucht insbesondere das folgende Active Directory-Objekt, um den aktuellen Wert für das Attribut rangeUpper zu bestimmen:

CN=ms-Exch-Schema-Version-Pt,CN=Schema,CN=Configuration,DC=<DN-der-Stammdomäne-der-Gesamtstruktur>

Ein Wert für rangeUpper von 4397 gibt an, dass Exchange 2000 Server installiert ist.

Ein Wert für rangeUpper von 6870 gibt an, dass Exchange Server 2003 installiert ist.

Ein Wert für rangeUpper von 10637 gibt an, dass Exchange Server 2007 installiert ist.

Wenn der Exchange Server Analyzer einen anderen Wert für rangeUpper ermittelt, wird ein Fehler angezeigt.

Der Wert für rangeUpper wird von Exchange 2000 Server oder Exchange Server 2003 während des Vorgangs ForestPrep eingegeben. Ein anderer Wert als 4397, 6870 oder 10637 gibt normalerweise an, dass eine Betaversion oder Vorabversion von Exchange zum Ausführen von ForestPrep oder im Falle von Exchange Server 2007, zum Ausführen von PrepareDomain verwendet wurde.

Um dieses Problem für Exchange 2000 Server oder Exchange Server 2003 zu beheben, führen Sie den Vorgang ForestPrep noch einmal mit der Version von Exchange aus, die derzeit in der Umgebung installiert ist. Bei Exchange Server 2007 führen Sie den Vorgang PrepareSchema noch einmal mit der Version von Exchange aus, die derzeit in der Umgebung installiert ist. Sie müssen ForestPrep bzw. PrepareSchema ausführen und mit einem Konto angemeldet sein, das mindestens über die folgenden Rechte verfügt:

  • Organisationsadministrator

  • Schemaadministrator

  • Domänenadministrator

  • Administrator des lokalen Computers (bei ausschließlicher Ausführung auf einem Mitgliedsserver)

So beheben Sie diesen Fehler in Exchange 2000 Server oder Exchange Server 2003

  1. Führen Sie setup.exe /forestprep aus.

  2. Vergewissern Sie sich, dass der Vorgang ForestPrep erfolgreich abgeschlossen wurde.

So beheben Sie den Fehler in Exchange Server 2007

  1. Führen Sie setup.exe /PrepareSchema aus.

  2. Vergewissern Sie sich, dass der Vorgang PrepareSchema erfolgreich abgeschlossen wurde.

Weitere Informationen über das Installieren von Exchange und das Ausführen des Vorgangs PrepareSchema finden Sie in der folgenden Produktdokumentation:

  • "Vorbereiten von Active Directory und Domänen" http://go.microsoft.com/fwlink/?LinkId=78453

Weitere Informationen über das Installieren von Exchange und das Ausführen des Vorgangs ForestPrep finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 312371, „SO WIRD´S GEMACHT: In Exchange 2000 Server die Gesamtstruktur mit "ForestPrep" vorbereiten" unter http://support.microsoft.com/kb/312371/de. Dieser Artikel bezieht sich sowohl auf Exchange 2000 Server als auch auf Exchange Server 2003.

  • 274737, „Sicherstellen, dass ,ForestPrep' und ,DomainPrep' in Exchange 2000 Server oder Exchange Server 2003 erfolgreich abgeschlossen wurde" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=274737).

  • 828765, „Berechtigungen, über die Sie zum Installieren von Komponenten in Exchange Server 2003 verfügen müssen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828765).


In administrativer Gruppe im einheitlichen Modus sind ältere Kontoinformationen vorhanden.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisserver ab, um zu ermitteln, ob das Attribut msExchLegacyAccount für die jeweiligen administrativen Exchange-Gruppenobjekte Daten enthält.

Exchange Server Analyzer fragt auch Active Directory ab, um für jede administrative Gruppe den Wert des Attributs msExchAdminGroupMode zu ermitteln. Der Wert 0 für das Attribut msExchAdminGroupMode zeigt an, dass sich die administrative Gruppe im einheitlichen Exchange-Modus befindet. Ein Wert von 1 zeigt eine reine Exchange Server 5.5-Umgebung an, und ein Wert von 2 einen gemischten Exchange-Modus.

Wenn Exchange Server Analyzer ermittelt, dass das Attribut msExchLegacyAccount Daten enthält, und dass der Wert für das Attribut msExchAdminGroupMode 0 ist, wird eine Fehlermeldung angezeigt.

Wenn Sie in den einheitlichen Exchange-Modus wechseln, wird das Attribut msExchLegacyAccount gelöscht. Dieses Attribut wird nur bei Exchange-Organisationen im gemischten Modus verwendet, in denen Exchange Server 5.5 noch vorhanden ist. Die tatsächlichen Attributdaten stellen das Exchange Server 5.5-Servicekonto dar, und deren Anwesenheit im Attribut msExchLegacyAccount in einer Exchange-Organisation im einheitlichen Modus führt zu Fehlfunktionen bei Aktualisierungen und Installationen von Service Packs. Tatsächlich verursacht allein das Vorhandensein des Attributs Fehlfunktionen, auch wenn keine Daten darin enthalten sind. Dies liegt daran, dass Exchange-Setup diese Attribute dazu verwendet, zu ermitteln, ob sich eine Exchange-Organisation im gemischten oder im einheitlichen Modus befindet. Wenn dieses Attribut vorhanden ist, wird Exchange-Setup in der Konfiguration für den gemischten Modus ausgeführt, obwohl sich die Installation tatsächlich im einheitlichen Modus befindet.

Wenn Sie mit dem ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces) manuell Daten aus Active Directory entfernt haben, ist das Attribut msExchLegacyAccount wahrscheinlich immer noch vorhanden.

Sie müssen diese Daten aus msExchLegacyAccount entfernen, indem Sie das Attribut manuell mit dem LDP-Tool (ldp.exe) bearbeiten. Damit sowohl die Daten als auch das Attribut aus dem Verzeichnis entfernt werden, ist das LDP-Tool oder ein anderer LDAP-Client (Lightweight Directory Access Protocol), Version 3, erforderlich. Das ADSI-Bearbeitungs-Snap-In reicht in diesem Fall nicht aus, da es nur die Daten entfernt und nicht das Attribut. LDP.exe ist im Paket der Windows®-Supporttools enthalten.

Achtung:
Wenn Sie die ADSI-Bearbeitung, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So entfernen Sie das Attribut msExchLegacyAccount

  1. Starten Sie LDP.exe.

  2. Klicken Sie im Menü Verbindung auf Verbinden, geben Sie im Dialogfeld Verbinden den Namen eines Domänencontrollers ein, der sich in derselben Active Directory-Gesamtstruktur befindet wie Ihre Exchange-Organisation, und klicken Sie dann auf OK.

  3. Klicken Sie im Menü Verbindung auf Gebunden, geben Sie im Dialogfeld Gebunden Anmeldeinformationen ein, die mindestens über vollständige Exchange-Administratorenrechte auf der Ebene administrativer Gruppen verfügen, und klicken Sie dann auf OK.

  4. Klicken Sie im Menü Ansicht auf Struktur. Lassen Sie im Dialogfeld Strukturansicht das Feld frei, wenn Sie von der Stammdomäne aus verbunden sind. Geben Sie andernfalls für CN=Konfiguration, DC=Domänenname, DC=Domänensuffix ein, wobei Domänenname die Stammdomäne in der Active Directory-Gesamtstruktur ist und Domänensuffix das Domänensuffix, z. B. com, net oder org. Klicken Sie auf OK.

  5. Erweitern Sie die Hierarchieansicht im linken Teilfenster von LDP, bis Ihre administrative Gruppe geöffnet wird. Doppelklicken Sie dazu in der folgenden Reihenfolge auf die Knoten (beachten Sie, dass jeder Knoten in LDP vor dem vollständigen Distinguished Name (DN) steht; hier werden aus Gründen der Übersichtlichkeit nur die am weitesten links stehenden CNs aufgeführt):

    1. DC=Domänenname

    2. CN=Konfiguration

    3. CN=Services

    4. CN=Microsoft Exchange

    5. CN=Name_der_Organisation

    6. CN=Administrative_Gruppen

    7. CN=Name_der_administrativen_Gruppe

    Führen Sie im rechten Detailfenster von LDP einen Bildlauf nach unten durch, um die Attribute Ihrer administrativen Gruppe anzuzeigen. Wenn Sie dort das Attribut msExchLegacyAccount finden, müssen Sie es löschen. Wenn das Attribut msExchLegacyDomain dort vorhanden ist, sind wahrscheinlich die Attribute msExchLegacyDomain und msExchEncryptedPassword auch vorhanden. Wenn dies der Fall ist, müssen diese ebenfalls gelöscht werden.

  6. Klicken Sie im (linken) Hierarchiefenster von LDP mit der rechten Maustaste auf Administrative_group_name, und klicken Sie dann auf Ändern.

  7. Achten Sie im Dialogfeld Ändern darauf, dass der im Feld Dn aufgeführte vollständige DN die zu ändernde administrative Gruppe richtig identifiziert. Er sollte folgendermaßen lauten: CN=Name_der_administrativen_Gruppe,CN=Administrative_Gruppen,CN=Name_der_Organisation,CN=Microsoft Exchange,CN=Services,CN=Konfiguration,DC=Domänenname.

  8. Wählen Sie im Dialogfeld Ändern unter Vorgänge, die Option Löschen aus, geben Sie unter Eintrag bearbeiten im Feld Attribut den Text msExchLegacyAccount ein, und klicken Sie dann auf Eingabe. Dadurch wird msExchLegacyAccount zur Liste der Einträge hinzugefügt. Die Liste der Einträge definiert die Attribute, die gelöscht werden, wenn Sie auf Ausführen klicken.

  9. Wenn in der administrativen Gruppe entweder das Attribut msExchLegacyDomain oder das Attribut msExchEncryptedPassword vorhanden ist, fügen Sie die Attribute, wie in Schritt 8 beschrieben, zur Liste der Einträge hinzu.

  10. Wenn die Liste der Einträge die Attribute enthält, die Sie löschen müssen, klicken Sie auf Ausführen. Im LDP-Detailfenster wird eine Statusmeldung angezeigt.

  11. Klicken Sie im Menü Verbindung auf Neu, um das LDP-Detailfenster zu löschen.

  12. Wechseln Sie zu CN=Name der administrativen Gruppe, und doppelklicken Sie auf das Objekt. Überprüfen Sie den Inhalt des rechten Bereichs, um sicherzustellen, dass die Attribute gelöscht wurden.

Weitere Informationen zum Ändern von Active Directory mit dem LDP-Tool finden Sie im Microsoft Knowledge Base-Artikel 260745, „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).


Das Attribut „LegacyExchangeDN" für die Exchange-Organisation ist ungültig.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2007-02-01

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um das Format des Attributs legacyExchangeDN auf dem Exchange-Organisationsobjekt zu ermitteln. Wenn Exchange Server Analyzer ermittelt, dass das Attribut legacyExchangeDN ungültig oder beschädigt ist, wird eine Fehlermeldung angezeigt.

Dieser Wert für dieses Attribut entspricht der Form /o=Organisation, wobei Organisation der Name der Exchange-Organisation ist. Wenn der Wert mit einer anderen Zeichenfolge als /o= oder /O= beginnt, wird er als beschädigt betrachtet. Dieses Problem muss so schnell wie möglich gelöst werden.

So beheben Sie diesen Fehler in Exchange 2000 Server oder Exchange Server 2003

  1. Führen Sie den Exchange Server ForestPrep-Vorgang aus. Wenn das Setup-Programm während dieses Vorgangs ermittelt, dass legacyExchangeDN im falschen Format vorliegt, korrigiert es automatisch das Problem.

So beheben Sie den Fehler in Exchange Server 2007

  1. Führen Sie den Exchange Server PrepareAD-Vorgang aus. Wenn das Setup-Programm während dieses Vorgangs ermittelt, dass legacyExchangeDN im falschen Format vorliegt, korrigiert es automatisch das Problem.

Weitere Informationen zum ForestPrep-Vorgang finden Sie im Microsoft Knowledge Base-Artikel 312371 „SO WIRD'S GEMACHT: In Exchange 2000 Server die Gesamtstruktur mit "ForestPrep" vorbereiten" unter http://support.microsoft.com/kb/312371/de.

Weitere Informationen über den PrepareAD-Vorgang finden Sie unter "Vorbereiten von Active Directory und Domänen" (http://go.microsoft.com/fwlink/?LinkId=78453).

Weitere Informationen zum Attribut legacyExchangeDN und seiner Änderung finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 324606, „XADM: Verwenden von Legacydn.exe zum Korrigieren der Namen von Exchange-Organisationen oder administrativen Gruppen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324606).

  • 286783, „XADM: Fehlermeldung beim Aktualisieren von Frei/Gebucht-Daten in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286783).

  • 301585, „XADM: Anweisungen zur Umgehung von Problemen mit MBconn.exe" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301585).


In der administrativen Gruppe im einheitlichen Modus sind Informationen über Legacy-Domänen vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob das Attribut msExchLegacyDomain für die einzelnen administrativen Exchange-Gruppenobjekte Daten enthält.

Exchange Server Analyzer fragt auch Active Directory ab, um für jede administrative Gruppe den Wert des Attributs msExchAdminGroupMode zu ermitteln. Der Wert 0 für das Attribut msExchAdminGroupMode zeigt an, dass sich die administrative Gruppe im einheitlichen Exchange-Modus befindet. Der Wert 1 zeigt eine reine Exchange Server 5.5-Umgebung an, und der Wert 2 einen gemischten Exchange-Modus.

Wenn Exchange Server Analyzer ermittelt, dass das Attribut msExchLegacyDomain Daten enthält und dass der Wert für das Attribut msExchAdminGroupMode gleich 0 ist, wird eine Fehlermeldung angezeigt.

Wenn Sie in den einheitlichen Exchange-Modus wechseln, wird das Attribut msExchLegacyDomain gelöscht. Dieses Attribut wird nur bei Exchange-Organisationen im gemischten Modus verwendet, in denen Exchange Server 5.5 noch vorhanden ist. Die tatsächlichen Attributdaten enthalten die Exchange Server 5.5-Dienstkontodomäne. Wenn diese Daten im Attribut msExchLegacyDomain einer Exchange-Organisation im einheitlichen Modus vorhanden sind, führt dies zu Fehlfunktionen beim Durchführen von Updates und beim Installieren von Service Packs. Tatsächlich verursacht allein das Vorhandensein des Attributs Fehlfunktionen, auch wenn keine Daten darin enthalten sind. Dies liegt daran, dass Exchange-Setup mithilfe dieser Attribute ermittelt, ob sich eine Exchange-Organisation im gemischten oder im einheitlichen Modus befindet. Wenn dieses Attribut vorhanden ist, wird Exchange-Setup in der Konfiguration für den gemischten Modus ausgeführt, obwohl sich die Installation tatsächlich im einheitlichen Modus befindet.

Wenn Sie mit dem ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces) manuell Daten aus Active Directory entfernt haben, ist das Attribut msExchLegacyDomain wahrscheinlich immer noch vorhanden.

Sie müssen diese Daten aus msExchLegacyDomain entfernen, indem Sie das Attribut manuell mit dem LDP-Tool (ldp.exe) bearbeiten. Damit sowohl die Daten als auch das Attribut aus dem Verzeichnis entfernt werden, ist das LDP-Tool oder ein anderer LDAP-Client (Lightweight Directory Access Protocol), Version 3, erforderlich. Das ADSI-Bearbeitungs-Snap-In reicht in diesem Fall nicht aus, da es nur die Daten entfernt jedoch nicht das Attribut. LDP.exe ist im Paket der Windows®-Supporttools enthalten.

Achtung:
Wenn Sie die ADSI-Bearbeitung, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So entfernen Sie das Attribut „msExchLegacyDomain"

  1. Starten Sie LDP.exe.

  2. Klicken Sie im Menü Verbindung auf Verbinden, geben Sie im Dialogfeld Verbinden den Namen eines Domänencontrollers ein, der sich in derselben Active Directory-Gesamtstruktur wie die Exchange-Organisation befindet, und klicken Sie dann auf OK.

  3. Klicken Sie im Menü Verbindung auf Gebunden, geben Sie im Dialogfeld Gebunden Anmeldeinformationen ein, die mindestens über vollständige Exchange-Administratorenrechte auf der Ebene administrativer Gruppen verfügen, und klicken Sie dann auf OK.

  4. Klicken Sie im Menü Ansicht auf Struktur. Lassen Sie im Dialogfeld Strukturansicht das Feld frei, wenn Sie von der Stammdomäne aus verbunden sind. Geben Sie andernfalls für CN=Konfiguration, DC=Domänenname, DC=Domänensuffix ein, wobei Domänenname die Stammdomäne in der Active Directory-Gesamtstruktur ist und Domänensuffix das Domänensuffix, z. B. com, net oder org. Klicken Sie auf OK.

  5. Erweitern Sie die Hierarchieansicht im linken Teilfenster von LDP, bis die administrative Gruppe geöffnet wird. Doppelklicken Sie dazu in der folgenden Reihenfolge auf die Knoten (beachten Sie, dass jeder Knoten in LDP vor dem vollständigen Distinguished Name (DN) steht; hier werden aus Gründen der Übersichtlichkeit nur die am weitesten links stehenden CNs aufgeführt):

    • DC=Domänenname

    • CN=Configuration

    • CN=Services

    • CN=Microsoft Exchange

    • CN=Name der Organisation

    • CN=Administrative Groups

    • CN=Name der administrativen Gruppe

    Führen Sie im rechten Detailfenster von LDP einen Bildlauf nach unten durch, um die Attribute der administrativen Gruppe anzuzeigen. Wenn Sie dort das Attribut msExchLegacyDomain finden, löschen Sie es. Wenn das Attribut msExchLegacyDomain dort vorhanden ist, sind wahrscheinlich die Attribute msExchLegacyDomain und msExchEncryptedPassword auch vorhanden. Wenn dies der Fall ist, müssen diese ebenfalls gelöscht werden.

  6. Klicken Sie im (linken) Hierarchiefenster von LDP mit der rechten Maustaste auf Name der administrativen Gruppe, und klicken Sie dann auf Ändern.

  7. Achten Sie im Dialogfeld Ändern darauf, dass der im Feld Dn aufgeführte vollständige DN die zu ändernde administrative Gruppe richtig identifiziert. Er sollte folgendermaßen lauten: CN=Name der administrativen Gruppe,CN=Administrative Groups,CN=Name der Organisation,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Domänenname.

  8. Wählen Sie im Dialogfeld Ändern unter Vorgänge, die Option Löschen aus, geben Sie unter Eintrag bearbeiten im Feld Attribut den Text msExchLegacyAccount ein, und klicken Sie dann auf Eingabe. Dadurch wird msExchLegacyAccount zu Liste der Einträge hinzugefügt. Die Liste der Einträge definiert die Attribute, die gelöscht werden, wenn Sie auf Ausführen klicken.

  9. Wenn in der administrativen Gruppe entweder das Attribut msExchLegacyAccount oder das Attribut msExchEncryptedPassword vorhanden ist, fügen Sie der Liste der Einträge die Attribute entsprechend der Beschreibung in Schritt 8 hinzu.

  10. Wenn die Liste der Einträge die Attribute enthält, die Sie löschen müssen, klicken Sie auf Ausführen. Im LDP-Detailfenster wird eine Statusmeldung angezeigt.

  11. Klicken Sie im Menü Verbindung auf Neu, um das LDP-Detailfenster zu löschen.

  12. Wechseln Sie zu CN=Name der administrativen Gruppe, und doppelklicken Sie auf das Objekt. Überprüfen Sie den Inhalt des rechten Bereichs, um sicherzustellen, dass die Attribute gelöscht wurden.

Weitere Informationen zum Ändern von Active Directory mit dem LDP-Tool finden Sie im Microsoft Knowledge Base-Artikel 260745, „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).


Der LegacyExchangeDN für diese administrative Gruppe entspricht nicht der übergeordneten Organisation.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2006-11-30

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um das Format des Attributs legacyExchangeDN im Containerobjekt der adminstrativen Gruppen zu bestimmen. Wenn Exchange Server Analyzer feststellt, dass das Attribut legacyExchangeDN in der administrativen Gruppe nicht legacyExchangeDN für die Exchange-Organisation entspricht, wird ein Fehler angezeigt.

Exchange verwendet den Wert legacyExchangeDN zur Identifizierung der Exchange-Objekte in Active Directory. Der Wert legacyExchangeDN ist ein Distinguished Name (DN), der die Position eines Objekts in der Exchange-Organisation angibt, z. B.:

/o= Organisation /ou= Administrative Gruppe

Objekte wie z. B. Server und Ordnerhierarchien erben einen Teil der legacyExchangeDN-Werte von der administrativen Gruppe. Falls also ein Problem beim Wert der administrativen Gruppe auftritt, kann dieses Problem möglicherweise von anderen Objekten geerbt werden.

Probleme mit dem legacyExchangeDN treten i. A. dann auf, wenn ein Administrator eine direkte Änderung dieses Wertes vornimmt. Sie müssen den Wert mit einem Tool wie Active Directory Service Interfaces (ADSI) Edit-Snap-In, LDP (ldp.exe) oder einem beliebigen anderen Client für LDAP (Lightweight Directory Access Protocol), Version 3, korrigieren.

Achtung:
Wenn Sie die ADSI-Bearbeitung, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, von Exchange Server 2003 bzw. Exchange Server 2007 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So beheben Sie diesen Fehler

  1. Verwenden Sie einen Active Directory-Editor (z. B. die ADSI-Bearbeitung), um das administrative Gruppenobjekt in Active Directory zu suchen.

    Das Attribut legacyExchangeDN befindet sich unter:

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=Organization, CN=Administrative Groups, CN= Administrative Gruppe

  2. Geben Sie einen neuen Zeichenfolgenwert in folgender Form ein:

    /o= Organisation /ou= Administrative Gruppe

Weitere Informationen zum Verwenden des LDP-Tools finden Sie im Microsoft Knowledge Base-Artikel 260745 „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Weitere Informationen zum Verwenden der ADSI-Bearbeitung finden Sie im Abschnitt „Adsiedit.msc: ADSI Bearbeitung" in der Hilfe zu Windows Server.


LegacyExchangeDN für diese administrative Gruppe ist ungültig.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert legacyExchangeDN für eine administrative Gruppe zu überprüfen. Dieser Fehler wird angezeigt, wenn die Organisation oder die administrative Gruppe, die im Wert legacyExchangeDN benannt wird, nicht dem tatsächlichen Namen der Organisation bzw. der administrativen Gruppe entspricht, oder falls generell Teile des Werts fehlen.

Exchange verwendet den Wert legacyExchangeDN zur Identifizierung der Exchange-Objekte in Active Directory. Der Wert legacyExchangeDN ist ein Distinguished Name (DN), der die Position eines Objekts in der Exchange-Organisation angibt, z. B.:

/o=Organisation/ou=Administrative Gruppe

Objekte wie z. B. Server und Ordnerhierarchien erben einen Teil der legacyExchangeDN-Werte von der administrativen Gruppe. Falls also ein Problem beim Wert der administrativen Gruppe auftritt, kann dieses Problem möglicherweise auch bei vielen anderen Objekten auftreten.

Probleme mit legacyExchangeDN treten i. d. R. auf, wenn ein Administrator versucht, diesen Wert direkt zu ändern. Sie müssen den Wert mit einem Tool wie Active Directory Service Interfaces (ADSI) Edit-Snap-In, LDP (ldp.exe) oder einem beliebigen anderen Client für LDAP (Lightweight Directory Access Protocol), Version 3, korrigieren.

Achtung:
Wenn Sie die ADSI-Bearbeitung, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So beheben Sie diesen Fehler

  1. Verwenden Sie einen Active Directory-Editor (z. B. die ADSI-Bearbeitung), um das administrative Gruppenobjekt in Active Directory zu suchen.

    Das Attribut legacyExchangeDN befindet sich unter:

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=Organization, CN=Administrative Groups, CN=Administrative Gruppe

  2. Geben Sie einen neuen Zeichenfolgenwert in folgender Form ein:

    /o=Organisation/ou=Administrative Gruppe

Weitere Informationen zum Verwenden des LDP-Tools finden Sie im Microsoft Knowledge Base-Artikel 260745 „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Weitere Informationen zum Verwenden der ADSI-Bearbeitung finden Sie im Abschnitt „Adsiedit.msc: ADSI Bearbeitung" in der Onlinehilfe zu Windows Server.


E-Mail-aktivierte, nicht universelle Gruppen vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um die Anzahl der Domänen in der Umgebung zu ermitteln. Wenn Microsoft Exchange Server Analyzer mehrere getrennte Active Directory-Domänen in der Gesamtstruktur feststellt, wird jede Domäne abgefragt, um zu bestimmen, ob in diesen Domänen eine oder mehr E-Mail-aktivierte, nicht universelle Gruppen vorhanden sind.

If the Exchange Server Analyzer determines that mail enabled non-universal groups exist in the multiple-domain forest, the Exchange Server Analyzer displays a warning.

Wenn Sie in einer Gesamtstruktur aus mehreren Domänen lokale Verteilergruppen für eine Domäne oder globale Verteilergruppen verwenden, können aus folgenden Gründen Probleme bei der Übermittlung von E-Mail-Nachrichten auftreten:

  • Um Verteilergruppen in einzelne Empfänger aufzugliedern, kontaktiert Exchange einen globalen Katalogserver.

  • Obwohl der globale Katalogserver über eine Auflistung von Gruppen aller Typen aus jeder Domäne verfügt, enthält er nicht die Mitgliedschaftsliste für lokale Gruppen der Domäne oder für globale Gruppen, die in Remotedomänen erstellt wurden.

  • Wenn eine Nachricht an eine globale Verteilergruppe gesendet, aber in einer anderen als der Stammdomäne erweitert wird, kann Exchange die Nachricht an Mitglieder der Gruppe nicht ordnungsgemäß übermitteln.

  • Da das Kategorisierungsmodul die Verteilerliste nicht erweitern kann, erhalten die Benutzer in der globalen Verteilergruppe eine Nachricht möglicherweise nicht, die ein Benutzer an eine globale Verteilergruppe oder eine E-Mail-aktivierte Sicherheitsgruppe in einer Gesamtstruktur aus mehreren Domänen sendet.

  • Der letzte Eintrag in den Verfolgungsprotokollen ist eine Übergabe an das Kategorisierungsmodul. Der Absender der Nachricht erhält keinen Non-Delivery Report (NDR - Unzustellbarkeitsbericht).

Um dieses Problem zu beheben und die Übermittlung der E-Mail sicherzustellen, verwenden Sie in einer Umgebung mit mehreren Domänen universelle Verteilergruppen. Die Mitgliedschaft universeller Verteilergruppen wird in jeden globalen Katalogserver in allen Domänen repliziert.

Weitere Informationen zu diesem speziellen Problem und zu universellen Verteilergruppen im Allgemeinen finden Sie in den folgenden Themen:

  • „Using Mail-Enabled Groups in Multi-Domain Environments" im Exchange Server 2003-Administratorhandbuch (http://go.microsoft.com/fwlink/?LinkId=47617).

  • „Group scope" unter „Understanding Groups" in Active Directory (http://go.microsoft.com/fwlink/?LinkId=51276).

  • „Guidelines for Creating Query-Based Distribution Groups" im Exchange Server 2003-Administratorhandbuch (http://go.microsoft.com/fwlink/?LinkId=47617).

Beachten Sie auch die folgenden Microsoft Knowledge Base-Artikel:

  • 231273, „XADM: Message Delivery to Global Groups Does Not Work" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=271930).

  • 283051, „XCON: E-Mail Sent to Mail-Enabled Global Group May Disappear" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=283051).

  • 231273, „Verwendung von Gruppentypen und -bereichen in Windows 2000" (http://support.microsoft.com/?kbid=231273).


Änderung der Systemrichtlinie „Mailbox Enable User" ist erforderlich
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2006-08-10

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs purportedSearch für jedes Exchange-Systemrichtlinienobjekt zu ermitteln. Mit dem Attribut purportedSearch wird das Suchargument angegeben, das beim Anwenden der Richtlinie verwendet wird.

Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst auch ab, um den Wert für das Attribut msDS-Behavior-Version des Gesamtstrukturobjekts in Active Directory unter den NTDS-Einstellungen zu ermitteln. Dieser Wert gibt die Funktionsebene in der Active Directory-Gesamtstruktur an. In der folgenden Tabelle finden Sie gültige Werte für das Attribut msDS-Behavior-Version.

Wert | Funktionsebene in der Gesamtstruktur
0 | Microsoft Windows® 2000 Server gemischt
1 | Windows Server™ 2003 interim
2 | Microsoft Windows Server 2003 einheitlich

Exchange Server Analyzer fragt Active Directory auch ab, um den Wert für das Attribut revision des Containers Windows2003Update zu ermitteln. Der Wert dieses Attributs gibt an, ob das Active Directory-Vorbereitungsprogramm (ADPrep.exe) ausgeführt wurde.

Exchange Server Analyzer fragt schließlich die Microsoft Windows®-Verwaltungsinstrumentationsklasse (Windows® Management Instrumentation, WMI) Win32_OperatingSystem ab, um den Wert des Schlüssels OSProductSuite zu bestimmen. Der Wert des Schlüssels OSProductSuite gibt die Version von Windows an, die auf dem Computer ausgeführt wird.

Wenn Exchange Server Analyzer feststellt, dass folgende Kriterien erfüllt sind, wird eine Warnung angezeigt:

  • Der Wert des Attributs purportedSearch der Systemrichtlinie Mailbox Enable User entspricht nicht (&(objectCategory=person)(objectClass=user)(mailnickname=*)(homeMdb=*))

  • Die Funktionsebene der Active Directory-Gesamtstruktur lautet Windows Server 2003 interim oder Windows Server 2003 einheitlich.

  • Auf dem Exchange Server-Computer wird nicht Windows Small Business Server 2003 ausgeführt.

Um Probleme mit dem Zuweisen von Postfächern zu vermeiden, müssen die Systemrichtlinien geändert werden. Diese Aktualisierung kann mithilfe der ADSI-Bearbeitung (Active Directory Service Interfaces) (AdsiEdit.msc), dem LDP-Tool (ldp.exe) oder einem anderen Active Directory-Editor erfolgen.

Wenn Sie Windows Server 2003 als Domänencontroller verwenden, ohne die Richtlinie Mailbox Enable User zu aktualisieren, wird bei der Replikation verknüpfter Werte unter Windows Server 2003 der Wert des Attributs homeMDB neuer Benutzer durch den Empfängeraktualisierungsdienst überschrieben, und die zugehörigen Postfächer werden dem ersten Informationsspeicher auf dem Server zugewiesen.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In, das LDP-Tool oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Windows Server 2003, Exchange Server 2003 oder beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So beheben Sie diesen Fehler

  1. Starten Sie die ADSI-Bearbeitung.

  2. Doppelklicken Sie auf den Container Konfiguration, erweitern Sie CN=Services, erweitern Sie CN=Microsoft Exchange, und erweitern Sie dann CN=<Name der Exchange-Organisation>.

  3. Wählen Sie CN=System Policies aus.

  4. Klicken Sie im rechten Bereich auf CN=Mailbox Enable User und dann auf Eigenschaften.

  5. Führen Sie einen Bildlauf nach unten durch, wählen Sie das Attribut purportedSearch aus, und klicken Sie auf Bearbeiten.

  6. Löschen Sie das Attribut, und konfigurieren Sie es anschließend mit dem folgenden Filter:

    (&(objectCategory=person)(objectClass=user)(mailnickname=*)(homeMdb=*))

    Hinweis:
    Der in Schritt 6 dargestellte Filter wurde zur besseren Lesbarkeit mit Umbrüchen dargestellt. Achten Sie darauf, dass der Filter ohne Leerzeichen oder Zeilenumbrüche eingegeben wird.

  7. Klicken Sie zum Speichern der Änderung erneut auf OK, und schließen Sie dann das ADSI-Bearbeitungs-Snap-In.

Weitere Informationen zum Verwenden des LDP-Tools finden Sie im Microsoft Knowledge Base-Artikel 260745 „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Weitere Informationen zu diesem Problem und seinen Auswirkungen finden Sie im Microsoft Knowledge Base-Artikel 903291 "Empfängeraktualisierungsdienst kann den Wert des HomeMDB-Attributs für neue Benutzer von Exchange Server 2003 überschreiben" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=903291).


MAPI-Schnittstelle für globalen Katalog wurde deaktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungsschlüssel, um festzustellen, ob der Registrierungsschlüssel vorhanden ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NTDS\Parameters\Initialize MAPI interface

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel Initialize MAPI interface vorhanden ist für einen beliebigen numerischen Wert konfiguriert wurde, zeigt Exchange Server Analyzer einen Fehler an.

Wenn der Registrierungsschlüssel Initialize MAPI interface vorhanden ist, können Microsoft Office Outlook®-Clients keine Verbindung mit dem Adressbuch auf diesem Server herstellen. Um dieses Problem zu beheben, müssen Sie den Registrierungsschlüssel Initialize MAPI interface entfernen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So beheben Sie diese Warnung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\NTDS\Parameters\Initialize MAPI interface

  3. Klicken Sie mit der rechten Maustaste auf den Schlüssel Initialize MAPI interface, und klicken Sie dann auf Löschen.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Exchange-Server erneut.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zum Registrierungsschlüssel Initialize MAPI interface finden Sie im Microsoft Knowledge Base-Artikel 275127, „XADM:How to Configure Exchange Server 5.5 to Run on a Domain Controller that is a Global Catalog" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=275127.


MaxActiveQueries wurde geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um die Maximalzahl der LDAP-Abfragen (Lightweight Directory Access Protocol) zu bestimmen, die gleichzeitig verarbeitet werden können. Dieser Wert wird durch Untersuchen der aktuellen LDAP-Administrationsrichtlinien bestimmt. Insbesondere überprüft Exchange Server Analyzer, ob MaxActiveQueries vorhanden ist. Wenn Exchange Server Analyzer feststellt, dass MaxActiveQueries vorhanden ist und mit einem anderen Wert als 20 konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Anhand der administrativen Grenzwerte von LDAP können die operativen Fähigkeiten und die Leistung von Active Directory miteinander in Beziehung gesetzt werden. Diese Grenzwerte verhindern, dass bestimmte Vorgänge die Leistung des Servers beeinträchtigen. Eine Erhöhung dieser Einstellung über den Standardwert kann die Infrastruktur von Active Directory beeinträchtigen.

Der Wert MaxActiveQueries des Attributs LDAPAdminLimits steuert die Maximalzahl gleichzeitiger LDAP-Abfragen für die Standard-Abfragerichtlinie. In der Standardeinstellung gilt eine Einschränkung von 20 aktiven Abfragen. Wenn der Grenzwert erreicht wird, gibt Active Directory LDAP_ADMIN_LIMIT_EXCEEDED zurück und bearbeitet keine weiteren LDAP-Abfragen.

So starten Sie „Ntdsutil.exe"

  1. Klicken Sie auf Start, und klicken Sie dann auf Ausführen.

  2. Geben Sie im Textfeld zum Öffnen ntdsutil ein, und drücken Sie dann die EINGABETASTE. Sie können jederzeit die Hilfe aufrufen, indem Sie an der Eingabeaufforderung ? eingeben.

So zeigen Sie Richtlinieneinstellungen an

  1. Geben Sie an der Eingabeaufforderung von Ntdsutil.exe den Befehl LDAP policies ein, und drücken Sie dann die EINGABETASTE.

  2. Geben Sie an der Eingabeaufforderung der LDAP-Richtlinie connections ein, und drücken Sie dann die EINGABETASTE.

  3. Geben Sie an der Eingabeaufforderung der Serververbindung Verbindung mit dem Server herstellen den DNS-Name des Servers ein, und drücken Sie dann die EINGABETASTE. Sie möchten eine Verbindung mit dem Server herstellen, mit dem Sie gerade arbeiten.

  4. Geben Sie an der Eingabeaufforderung der Serververbindung q ein, und drücken Sie dann die EINGABETASTE, um zum vorherigen Menü zurückzukehren.

  5. Geben Sie an der Eingabeaufforderung der LDAP-Richtlinie Show Values ein, und drücken Sie dann die EINGABETASTE.

    Die vorhandenen Richtlinien werden angezeigt.
Hinweis:
Durch diesen Vorgang werden nur die Einstellungen für die Standarddomänenrichtlinien angezeigt. Wenn Sie eigene Richtlinieneinstellungen anwenden, werden diese nicht angezeigt.

So ändern Sie Richtlinieneinstellungen

  1. Geben Sie an der Eingabeaufforderung von Ntdsutil.exe den Befehl LDAP policies ein, und drücken Sie dann die EINGABETASTE.

  2. Geben Sie an der Eingabeaufforderung der LDAP-Richtlinie Set MaxActiveQueries to 20 ein, und drücken Sie dann die EINGABETASTE.

    Mit dem Befehl Show Values können Sie die Änderungen überprüfen.

  3. Verwenden Sie zum Speichern der Änderungen den Befehl Commit Changes.

  4. Geben Sie zum Beenden q ein, und drücken Sie dann die EINGABETASTE.

  5. Geben Sie zum Beenden von Ntdsutil.exe an der Eingabeaufforderung q ein, und drücken Sie dann die EINGABETASTE.

Weitere Informationen zum Konfigurieren von LDAP-Richtlinien finden Sie im Microsoft Knowledge Base-Artikel 315071, „SO WIRD'S GEMACHT: Anzeigen und Einrichten von LDAP-Richtlinien mit Ntdsutil.exe in Windows 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071).


Der Parameter „MaxPageSize" weicht vom Standardwert ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer überprüft die LDAP-Konfiguration (Lightweight Directory Access Protocol) von Domänencontrollern, indem er die Attribute des Standardabfragerichtlinienobjekts im Container für Abfragerichtlinien im Active Directory®-Verzeichnisdienst überprüft. Wenn Exchange Server Analyzer feststellt, dass der Wert MaxPageSize des Attributs LDAPAdminLimits von seinem Standardwert 1000 abweicht, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Anhand der administrativen Grenzwerte von LDAP können die operativen Fähigkeiten und die Leistung von Active Directory miteinander in Beziehung gesetzt werden. Diese Grenzwerte verhindern, dass bestimmte Vorgänge die Leistung des Servers beeinträchtigen, und schützen den Server vor DOS-Angriffen (DOS, Denial-of-Service). Eine Erhöhung dieser Einstellung über den Standardwert kann die Infrastruktur von Active Directory beeinträchtigen.

LDAP-Richtlinien werden über Objekte der Klasse queryPolicy implementiert. Diese Objekte können im Container für Abfragerichtlinien erstellt werden. Bei diesem Container handelt es um einen untergeordneten Container des Containers für den Verzeichnisdienst im Konfigurationsnamenskontext.

Der Wert MaxPageSize des Attributs LDAPAdminLimits steuert die Anzahl der Datensätze, die für eine LDAP-Abfrage zurückgegeben werden können. Der Standardwert liegt bei 1000 Datensätzen. Wenn mehr als 1000 Datensätze zurückgegeben werden, erkennt Active Directory den Maximalwert und gibt nichts zurück.

Dieser Grenzwert steuert die Anzahl der verschiedenen Active Directory-Objekte, die unterstützt werden. Jede Organisation kann beispielsweise über bis zu 1000 Server, über bis zu 1000 administrative Gruppen und über bis zu 1000 Adresslisten verfügen. Jede administrative Gruppe kann bis zu 1000 Routinggruppen und jede Routinggruppe bis zu 1000 Connectors besitzen.

Sie sollten diesen Wert auf 1000 zurücksetzen, es sei denn, Sie wurden vom technischen Support von Microsoft angewiesen, einen anderen Wert zu verwenden.

So starten Sie Ntdsutil.exe

  1. Klicken Sie auf Start, und klicken Sie dann auf Ausführen.

  2. Geben Sie im Textfeld Öffnen die Zeichenfolge ntdsutil ein, und drücken Sie anschließend die EINGABETASTE. Sie können jederzeit die Hilfe aufrufen, indem Sie an der Eingabeaufforderung ? eingeben.

So zeigen Sie Richtlinieneinstellungen an

  1. Geben Sie an der Eingabeaufforderung Ntdsutil.exe den Befehl LDAP policies ein, und drücken Sie anschließend die EINGABETASTE.

  2. Geben Sie an der Eingabeaufforderung LDAP policy den Befehl connections ein, und drücken Sie anschließend die EINGABETASTE.

  3. Geben Sie an der Eingabeaufforderung server connection den Befehl connect to server DNS-Name des Servers ein, und drücken Sie dann die EINGABETASTE. Sie möchten eine Verbindung mit dem Server herstellen, mit dem Sie gerade arbeiten.

  4. Geben Sie an der Eingabeaufforderung server connection den Befehl q ein. Drücken Sie anschließend die EINGABETASTE, um zum vorherigen Menü zurückzukehren.

  5. Geben Sie an der Eingabeaufforderung LDAP policy den Befehl Show Values ein, und drücken Sie anschließend die EINGABETASTE.

    Die vorhandenen Richtlinien werden angezeigt.

    Hinweis:
    Durch diesen Vorgang werden nur die Einstellungen für die Standarddomänenrichtlinien angezeigt. Wenn Sie eigene Richtlinieneinstellungen anwenden, werden diese nicht angezeigt.

So ändern Sie Richtlinieneinstellungen

  1. Geben Sie an der Eingabeaufforderung Ntdsutil.exe den Befehl LDAP policies ein, und drücken Sie anschließend die EINGABETASTE.

  2. Geben Sie an der Eingabeaufforderung LDAP policy den Befehl Set MaxPageSize to 1000 ein, und drücken Sie anschließend die EINGABETASTE.

    Mit dem Befehl Show Values können Sie die Änderungen überprüfen.

  3. Verwenden Sie zum Speichern der Änderungen den Befehl Commit Changes.

  4. Geben Sie zum Beenden des Vorgangs den Befehl q ein, und drücken Sie dann die EINGABETASTE.

  5. Zum Verlassen von Ntdsutil.exe geben Sie an der Eingabeaufforderung den Befehl q ein, und drücken Sie anschließend die EINGABETASTE.

Weitere Informationen zum Konfigurieren von LDAP-Richtlinien finden Sie im Microsoft Knowledge Base-Artikel 315071, „SO WIRD'S GEMACHT: Anzeigen und Einrichten von LDAP-Richtlinien mit Ntdsutil.exe in Windows 2000" (http://support.microsoft.com/kb/315071/de).


Der Wert „MaxPageSize" ist zu hoch festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um die Einstellung für den Wert MaxPageSize für das Attribut LDAPAdminLimits des Standardabfragerichtlinien-Objekts im Container für Abfragerichtlinien zu ermitteln. Wenn Exchange Server Analyzer ermittelt, dass der Wert für MaxPageSize größer als 2500 ist, wird ein Fehler angezeigt.

Die administrativen Grenzwerte von LDAP (Lightweight Directory Access Protocol) stellen die operativen Fähigkeiten und die Leistung von Active Directory gegenüber. Diese Grenzwerte verhindern, dass bestimmte Vorgänge die Leistung des Servers beeinträchtigen. Diese Grenzwerte schützen den Server auch vor DOS-Angriffen (Denial-of-Service). Eine Erhöhung dieser Einstellung über den Standardwert kann die Infrastruktur von Active Directory beeinträchtigen.

LDAP-Richtlinien werden über Objekte der Klasse queryPolicy implementiert. Diese Objekte können im Container für Abfragerichtlinien erstellt werden. Bei diesem Container handelt es um einen untergeordneten Container des Containers für den Verzeichnisdienst im Konfigurationsnamenskontext.

Der Wert MaxPageSize des Attributs LDAPAdminLimits steuert die Anzahl der Datensätze, die für eine LDAP-Abfrage zurückgegeben werden können. Der Standardanzahl liegt bei 1.000 Datensätzen. Wenn mehr als 1.000 Datensätze zurückgegeben werden, erkennt Active Directory den Maximalwert und gibt nichts zurück.

Dieser Grenzwert steuert die Anzahl der verschiedenen Active Directory-Objekte, die unterstützt werden. Zum Beispiel kann jede Organisation über bis zu 1.000 Server, 1.000 administrative Gruppen und 1.000 Adresslisten verfügen. Jede administrative Gruppe kann über bis zu 1.000 Routinggruppen und jede Routinggruppe über bis zu 1.000 Connectors verfügen.

Sie sollten diesen Wert auf 1.000 zurücksetzen, es sei denn, Sie werden vom technischen Support von Microsoft angewiesen, einen anderen Wert zu verwenden.

So starten Sie „Ntdsutil.exe"

  1. Klicken Sie auf Start, und klicken Sie dann auf Ausführen.

  2. Geben Sie im Textfeld zum Öffnen ntdsutil ein, und drücken Sie dann die EINGABETASTE. Sie können jederzeit die Hilfe aufrufen, indem Sie an der Eingabeaufforderung ? eingeben.
So zeigen Sie Richtlinieneinstellungen an

  1. Geben Sie an der Eingabeaufforderung von Ntdsutil.exe die Zeichenfolge LDAP policies ein, und drücken Sie dann die EINGABETASTE.

  2. Geben Sie an der Eingabeaufforderung für die LDAP-Richtilinie connections ein, und drücken Sie anschließend die EINGABETASTE.

  3. Geben Sie an der Eingabeaufforderung der Serververbindung connect to server <DNS-Name des Servers> ein, und drücken Sie dann die EINGABETASTE. Stellen Sie eine Verbindung mit dem Server her, mit dem Sie gerade arbeiten.

  4. Geben Sie an der Eingabeaufforderung der Serververbindung q ein, und drücken Sie dann die EINGABETASTE, um zum vorherigen Menü zurückzukehren.

  5. Geben Sie an der Eingabeaufforderung für die LDAP-Richtlinie die Zeichenfolge Show Values ein, und drücken Sie anschließend die EINGABETASTE.

    Die vorhandenen Richtlinien werden angezeigt.

    Hinweis:
    Durch diesen Vorgang werden nur die Standardeinstellungen für die Domänenrichtlinien angezeigt. Wenn Sie eigene Richtlinieneinstellungen anwenden, werden diese nicht angezeigt.
So ändern Sie Richtlinieneinstellungen

  1. Geben Sie an der Eingabeaufforderung von Ntdsutil.exe die Zeichenfolge LDAP policies ein, und drücken Sie dann die EINGABETASTE.

  2. Geben Sie an der Eingabeaufforderung für die LDAP-Richtlinie Set MaxPageSize to 1000 ein, und drücken Sie anschließend die EINGABETASTE.

    Mit dem Befehl Show Values können Sie die Änderungen überprüfen.

  3. Verwenden Sie zum Speichern der Änderungen den Befehl Commit Changes.

  4. Geben Sie zum Beenden des Vorgangs den Befehl q ein, und drücken Sie dann die EINGABETASTE.

  5. Geben Sie zum Beenden von Ntdsutil.exe an der Eingabeaufforderung q ein, und drücken Sie dann die EINGABETASTE.

Weitere Informationen zum Konfigurieren von LDAP-Richtlinien finden Sie im Microsoft Knowledge Base-Artikel 315071, „SO WIRD'S GEMACHT: Anzeigen und Einrichten von LDAP-Richtlinien mit Ntdsutil.exe in Windows 2000" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071.


Es sind mehr als 800 Adresslisten vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob die Anzahl der Adresslisten in der Gruppe Alle Adresslisten in Active Directory mehr als 800 beträgt. Wenn Exchange Server Analyzer feststellt, dass mehr als 800 Adresslisten in der Exchange Server-Organisation vorhanden sind, zeigt Exchange Server Analyzer eine Warnung an.

Es wird empfohlen, die Anzahl der Adresslisten in der Gruppe Alle Adresslisten auf weniger als 800 zu reduzieren, um lange Wartezeiten während Operationen des Empfängeraktualisierungsdienstes zu vermeiden. Wenn mehr als 800 Adresslisten in der Exchange Server-Organisation vorhanden sind, verursacht der Empfängeraktualisierungsdienst lange Wartezeiten beim Stempeln mailaktivierter Objekte.

Sie können auch den Empfängeraktualisierungsdienst deaktivieren und mit Skripts die Aufgaben bearbeiten, die der Empfängeraktualisierungsdienst ausführt.

Weitere Informationen zum Deaktivieren des Empfängeraktualisierungsdiensts finden Sie im Microsoft Knowledge Base-Artikel 296479, „Requirements for Disabling the Recipient Update Service" unter http://go.microsoft.com/fwlink/?Linkid=3052&kbid=296479.

Weitere Informationen zu Adresslisten und dem Empfängeraktualisierungsdienst finden Sie unter „Verwalten von Empfängern und Empfängerrichtlinien" in Technisches Referenzhandbuch für Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=98e45481-1458-4809-97d6-50d8aeebd8a1&DisplayLang=de).


Es sind mehr als 800 globale Adresslisten vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob die Anzahl der Adresslisten in der Gruppe Alle Globalen Adresslisten in Active Directory mehr als 800 beträgt. Wenn Exchange Server Analyzer feststellt, dass mehr als 800 globale Adresslisten in der Exchange Server-Organisation vorhanden sind, zeigt Exchange Server Analyzer eine Warnung an.

Es wird empfohlen, die Anzahl der Adresslisten in der Gruppe Alle Globalen Adresslisten auf weniger als 800 zu reduzieren, um lange Wartezeiten während Operationen des Empfängeraktualisierungsdiensts zu vermeiden. Wenn mehr als 800 globale Adresslisten in der Exchange Server-Organisation vorhanden sind, verursacht der Empfängeraktualisierungsdienst lange Wartezeiten beim Stempeln E-Mail-aktivierter Objekte.

Sie können auch den Empfängeraktualisierungsdienst deaktivieren und mit Skripts die Aufgaben bearbeiten, die der Empfängeraktualisierungsdienst ausführt.

Weitere Informationen zum Deaktivieren des Empfängeraktualisierungsdiensts finden Sie im Microsoft Knowledge Base-Artikel 296479, „Requirements for Disabling the Recipient Update Service" unter http://go.microsoft.com/fwlink/?Linkid=3052&kbid=296479.

Weitere Informationen zu Adresslisten und dem Empfängeraktualisierungsdienst finden Sie unter „Verwalten von Empfängern und Empfängerrichtlinien" in Technisches Referenzhandbuch für Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=98e45481-1458-4809-97d6-50d8aeebd8a1&DisplayLang=de).


Das Attribut „MsExchHomeMDB" ist indiziert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob das Attribut Routing Group Back-Link zum Indizieren in Active Directory konfiguriert wurde. Insbesondere fragt Exchange Server Analyzer Active Directory ab, um den aktuellen Indizierungswert für das Attribut msExchHomeMDB zu bestimmen, bei dem es sich um ein Attribut postfachaktivierter Objekte in Active Directory handelt. Dieses Attribut ist in der Standardeinstellung nicht indiziert. Wenn Exchange Server Analyzer erkennt, dass dieses Attribut zum Indizieren konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Die Auswirkungen des Indizierens des Attributs msExchHomeMDB sind minimal. Durch das Verbleiben des Index im Speicher vergrößert sich die auf globalen Katalogservern verwendete Menge von Speicherplatz etwas.

Wenn eine der folgenden Bedingungen für Ihre Organisation zutrifft, profitieren Sie möglicherweise vom Indizieren dieses Attributs:

  • Sie verfügen über viele mailaktivierte Objekte. In sehr großen Umgebungen - mit 100.000 oder mehr mailaktivierten Objekten - kann das Indizieren dieses Attributs auch die Leistung des Exchange-System-Manager steigern, sowie die der Exchange-spezifischen Aufgaben, die mit Active Directory-Benutzer und -Computer ausgeführt werden können.

  • Wenn Sie das Exchange Mailbox Merge Program (ExMerge) häufig verwenden, ist das Indizieren des Attributs msExchHomeMDB in mittleren bis großen Umgebungen, die ExMerge verwenden, manchmal erforderlich. Das Indizieren des Attributs msExchHomeMDB steigert erwiesenermaßen die Geschwindigkeit und Leistung von ExMerge.

Wenn keine dieser Situationen vorliegt, wird empfohlen, die Einstellungen auf den Standardwert der Nicht-Indizierung zurückzusetzen.

So berichtigen Sie diesen Fehler

  • Es ist keine Aktion erforderlich, da die von Microsoft Exchange Server Analyzer erzeugte Meldung nur zu Informationszwecken dient.


Das Attribut „msExchRoutingGroupMembersBL" ist indiziert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob das Attribut Routing Group Back-Link zum Indizieren in Active Directory konfiguriert wurde. Exchange Server Analyzer untersucht insbesondere das folgende Active Directory-Objekt, um den aktuellen Indexwert für das Attribut msExchRoutingGroupMembersBL zu bestimmen:

CN=Configuration,DC=domain,DC=com, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=AdministrativeGroupName, CN=Routing Groups, CN=RoutingGroupName

Dieses Attribut ist in der Standardeinstellung nicht indiziert. Wenn Exchange Server Analyzer erkennt, dass dieses Attribut zum Indizieren konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In einer verteilten oder Filialbereitstellung von Exchange mit einer großen Anzahl von Routinggruppen kann es zu Leistungsabfällen kommen, wenn dieses Attribut nicht indiziert belassen wird. Wenn in der Exchange-Organisation Hunderte von Routinggruppen vorhanden sind, stellen Sie möglicherweise alle 15 Minuten eine erhöhte Aktivität auf einem oder mehreren globalen Katalogservern fest. Diese erhöhte Aktivität tritt auf, da die DSAccess-Komponente in Exchange die Routinggruppenkonfiguration erneut liest. In schweren Fällen wird der globale Katalog von dieser Aktivität voll beansprucht.

Um diese Belastung des globalen Katalogs zu verringern, kann das Attribut Routing Group Back-Link indiziert werden, wodurch die Zeit, die DSAccess zum Lesen der Routinggruppeninformationen benötigt, sowie die Belastung des globalen Katalogs durch diese Aktivität reduziert werden.

So beheben Sie diesen Fehler

  • Es ist keine Aktion erforderlich, da die von Microsoft Exchange Server Analyzer erzeugte Meldung nur zu Informationszwecken dient.

Weitere Informationen zum Optimieren der Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=de).


Es wurden mehrere Öffentliche Ordner-Hierarchien gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um die Anzahl der Öffentlichen Ordner-Hierarchien zu ermitteln, deren Attribut msExchPFTreeType den Wert 1 aufweist. Der Wert 1 für das msExchPFTreeType-Attribut zeigt an, dass die Öffentliche Ordner-Hierarchie die für MAPI-Clients festgelegte Öffentliche Ordner-Hierarchie ist. Wenn Exchange Server Analyzer feststellt, dass mehr als eine Öffentliche Ordner-Hierarchie in der Exchange-Organisation für das msExchPFTreeType-Attribut den Wert 1 aufweist, zeigt Exchange Server Analyzer einen Fehler an.

Dieser Fehler gibt an, dass in der Exchange-Organisation mehr als eine Öffentliche Ordner-Hierarchie für MAPI-Clients gefunden wurde. Wenn mehrere Öffentliche Ordner-Hierarchien für MAPI-Clients vorhanden sind, können Probleme auftreten.

Um dieses Problem zu beheben, können Sie mit einem Active Directory-Bearbeitungstool den Wert des msExchPFTreeType-Attributs aller Öffentliche Ordner-Hierarchien außer der Öffentlichen MAPI-Ordner-Hierarchie auf 0 festlegen. Konfigurieren Sie bei Bedarf die Postfachspeicher auf den Exchange-Servern so, dass diese auf die Öffentliche MAPI-Ordnerhierarchie als Standardspeicher für Öffentliche Ordner von MAPI-Clients zeigen.

Die folgenden Tools sind Active Directory-Bearbeitungstools:

  • Starten Sie die ADSI-Bearbeitung (Active Directory Service Interfaces; AdsiEdit.msc).

  • LDP-Tool (ldp.exe)

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In, das LDP-Tool oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So beheben Sie diesen Fehler

  1. Suchen Sie mit einem Active Directory-Bearbeitungstool die Objekte der Öffentlichen Ordner in Active Directory. Die Objekte der Öffentlichen Ordner befinden sich unter: CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Folder Hierarchies

  2. Ändern Sie das msExchPFTreeType-Attribut für alle Objekte der Öffentlichen Ordner-Hierarchie, außer der Öffentlichen MAPI-Ordner-Hierarchie, indem Sie als neuen Wert 0 eingeben.

  3. Schließen Sie den Active Directory-Editor.

  4. Öffnen Sie den Exchange-System-Manager.

  5. Um auf die Eigenschaften der einzelnen Postfachspeicher zuzugreifen, klicken Sie auf Administrative Gruppen, erweitern Sie die entsprechende administrative Gruppe, erweitern Sie Server, und erweitern Sie den entsprechenden Server sowie die Speichergruppe. Klicken Sie dann mit der rechten Maustaste auf den Postfachspeicher, dessen Eigenschaften Sie ändern möchten, und wählen Sie Eigenschaften aus.

  6. Klicken Sie auf der Registerkarte Allgemein für das Feld Öffentlicher Standardinformationsspeicher auf Durchsuchen.

  7. Wählen Sie die Öffentliche Ordner-Hierarchie für MAPI-Clients aus, und klicken Sie zweimal auf OK, um die Änderungen zu speichern.

  8. Wiederholen Sie die Schritte 5 bis 7 für jeden Postfachspeicher.

Weitere Informationen zum Ändern von Active Directory mit dem LDP-Tool finden Sie im Microsoft Knowledge Base-Artikel 260745, „XADM: Verwenden des LDP-Dienstprogramms, um Active Directory-Objektattribute zu ändern" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Weitere Informationen zu Öffentlichen Ordner-Hierarchien für MAPI-Clients und Anwendungen finden Sie in den folgenden Ressourcen:

  • Microsoft Knowledge Base-Artikel 258509, „Description of public folder tree types in Exchange 2000 Server and in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258509)

  • Exchange Team Blog-Eintrag „How mail-enabled Public Folders work" (http://go.microsoft.com/fwlink/?LinkId=41913)


Der Parameter 'NeverPing' wird empfohlen
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2006-03-16

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um die Anzahl der für jede Domäne vorhandenen Vertrauensstellungen zu ermitteln. Wenn für mindestens einen Domänencontroller in jeder Domäne der Wert NeverPing festgelegt ist, zeigt das Tool eine Best Practices-Meldung mit der empfohlenen Methode an.

Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen für jede Domäne in der Exchange Server 2003-Umgebung erfüllt („True") sind:

  • Die Domäne verfügt über mehr als 50 vorhandene Vertrauensstellungen.

  • Für die in der Domäne vorhandenen Domänencontroller ist der Wert des Registrierungsunterschlüssels NeverPing auf „Null (0)" festgelegt.

Diese Warnung zeigt an, dass der Prozess LSASS.exe oder der Prozess zum Authentifizieren von Benutzern in der Domäne nicht verzögert werden konnte. LSASS (Local Security Authority Subsystem Service, Subsystemdienst für die lokale Sicherheitsautorität) ist ein im Betriebssystem Microsoft Windows vorhandener Prozess, der die Benutzer überprüft, die sich bei einem Computer oder Server unter Windows anmelden.

Zur Behebung des Problems legen Sie den Wert des Registrierungsunterschlüssels NeverPing für die Domänencontroller wie folgt auf „1" fest.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So legen Sie den Parameter „NeverPing" für die in Ihrer Exchange 2003-Umgebung vorhandenen Domänencontroller fest

  1. Klicken Sie im Menü Start auf Ausführen, geben Sie regedit ein, und klicken Sie auf OK.

  2. Suchen Sie folgenden Registrierungsunterschlüssel: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters.

  3. Klicken Sie mit der rechten Maustaste auf diesen Unterschlüssel, zeigen Sie auf Neu, klicken Sie auf DWORD-Wert, geben Sie NeverPing ein, und drücken Sie die EINGABETASTE.

  4. Klicken Sie mit der rechten Maustaste auf NeverPing, klicken Sie auf Ändern, geben Sie in das Datenfeld Wert die Zahl 1 ein, und klicken Sie auf OK.

  5. Beenden Sie den Registrierungs-Editor.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zu diesem Problem und zum Festlegen des Parameterwerts von NeverPing für Ihre Domänencontroller finden Sie im Microsoft Knowledge Base-Artikel 825107, „Wenn auf einem Domänencontroller unter Windows 2000 Server zahlreiche externe Vertrauensstellungen vorhanden sind, reagiert der Prozess 'Lsass.exe' möglicherweise nicht mehr" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=825107).

Hinweis:
Obwohl dieser Artikel Microsoft Windows 2000 Server behandelt, sind die Informationen auch für Windows Server™ 2003 gültig. Die in dem Artikel erwähnte Aktualisierung ist für Windows Server 2003 nicht erforderlich.


Eine neuere Version von Active Directory Connector ist verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer sendet eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert des Attributs versionNumber für jedes Verbindungsvereinbarungsobjekt zu ermitteln. Das Attribut versionNumber stellt die Version von Active Directory Connector (ADC) dar, die auf dem Computer ausgeführt wird.

Microsoft® Exchange Server Analyzer sendet eine Abfrage an die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile, um den Wert für den Schlüssel Version für die ADC-Datei (Active Directory Connector) Adc.exe zu bestimmen. Der WMI-Schlüssel Version gibt die Buildnummer für diese Datei an.

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Das Attribut versionNumber ist auf dem Verbindungsvereinbarungsobjekt ist auf 16973842 festgelegt.

  • Das Attribut versionNumber für das Verbindungsvereinbarungsobjekt ist auf 16973843 gesetzt und der Wert des Schlüssels Version für Adc.exe ist kleiner als 7250.0.

Der Wert 16973842 bedeutet, dass auf dem Computer die kommerzielle ADC-Originalversion von der Exchange Server 2003-CD aus ausgeführt wird, und der Wert 16973843 mit einem Schlüssel Version für Adc.exe von weniger als 7250.0 bedeutet, dass auf dem Computer die ADC-Version von Exchange Server 2003 Service Pack 1 (SP1) ausgeführt wird.

Eine neuere Version von ADC ist mit Service Pack 2 für Exchange Server 2003 verfügbar. Es wird empfohlen, die neueste Version von ADC zu verwenden.

So beheben Sie diese Warnmeldung

  1. Wechseln Sie zu Service Pack 2 für Exchange Server 2003 http://www.microsoft.com/downloads/details.aspx?FamilyId=42656083-784D-4E7E-B032-2CB6433BEC00&DisplayLang=de können Sie die neueste Version von ADC downloaden.

  2. Deinstallieren Sie die vorhandene ADC-Version, und installieren Sie die aktualisierte ADC-Version.

Weitere Informationen zu ADC-Verbindungsvereinbarungen finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 823601, „Anforderungen und Auswirkungen von Active Directory Connector innerhalb eines Netzwerks" unter http://support.microsoft.com/default.aspx?scid=kb;de;823601

  • 303180, „Active Directory Connector Connection Agreement Requirements for Mixed Administrative Groups" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180

  • 317721, „XADM: Exchange Server 5.5 Mailbox Owner Rights Are Removed When You Change the ADC Connection Agreement from a One-Way Connection Agreement to a Two-Way Connection Agreement" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721


Der benannte Exchange Server für diese Verbindungsvereinbarung ist in der Organisation nicht vorhanden.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs msExchServer2NetworkAddress für jedes Verbindungsvereinbarungsobjekt zu bestimmen. Das Attribut msExchServer2NetworkAddress steht für die Netzwerkadresse des Servers, der an dieser Verbindungsvereinbarung beteiligt ist. Microsoft Exchange Server Analyzer führt die administrativen Gruppen in Active Directory auf, um zu ermitteln, ob dieser Servername für Verbindungsvereinbarungsmitglieder einer administrativen Gruppe aufgelistet ist. Wenn der Servername in keiner administrativen Gruppe aufgelistet ist, wird ein Fehler angezeigt.

Dieser Fehler gibt eine verwaiste Verbindungsvereinbarung an. Dies kann der Fall sein, wenn ein Exchange Server-Computer außer Betrieb genommen wurde. Wenn ein Exchange Server-Computer aus der Organisation entfernt wurde, sollten Sie den Namen des Exchange-Servers im ADC-Administrationstool (Active Directory Connector) in den Eigenschaften der Verbindungsvereinbarung auf der Registerkarte Verbindungen ändern. Wenn sich der entsprechende Exchange-Server zur Wartung oder aus anderen bekannten Gründen offline befindet, können Sie diesen Fehler ignorieren.

So beheben Sie diesen Fehler

  1. Klicken Sie auf Start, klicken Sie auf Programme, klicken Sie auf Verwaltung, und klicken Sie dann auf Active Directory Connector.

  2. Klicken Sie im linken Bereich auf den ADC-Server, auf dem sich die zu ändernde Verbindungsvereinbarung befindet.

  3. Klicken Sie im rechten Bereich mit der rechten Maustaste auf die zu ändernde Verbindungsvereinbarung, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf die Registerkarte Verbindungen.

  5. Ändern Sie den Namen des Servers für Verbindungen in den Namen eines vorhandenen Servers.

Weitere Informationen zu ADC-Verbindungsvereinbarungen finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 823601, „Anforderungen und Auswirkungen von Active Directory Connector innerhalb eines Netzwerks" unter http://support.microsoft.com/default.aspx?scid=kb;de;823601

  • 303180, „Active Directory Connector Connection Agreement Requirements for Mixed Administrative Groups" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180


Der benannte Offline-Adressbuchserver ist in der Organisation nicht vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2006-12-03

Microsoft® Exchange Server Analyzer sendet eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert des Attributs offLineABServer für das Konfigurationsobjekt des Offlineadressbuchs zu bestimmen. Bei dem Attribut offLineABServer handelt es sich um ein Distinguished-Name-Attribut, das nur einen Wert haben darf. Es speichert den Distinguished Name des Exchange Server-Computers, der für das Generieren von Offlineadressbüchern zuständig ist.

Exchange Server Analyzer überprüft auch den Wert für das Attribut distinguishedName von Exchange Server-Objekten in Active Directory.

Wenn Exchange Server Analyzer feststellt, dass das Attribut offLineABServer nicht mit dem gefundenen Attribut distinguishedName der Exchange Server-Objekte übereinstimmt und das Attribut offLineABServer die Zeichenfolge DEL: nicht enthält, wird ein Fehler angezeigt.

Exchange generiert und speichert die Offlineadressbuchdateien aller Offlinadressbücher in einer Sammlung von Öffentlichen Ordnern auf einem angegebenen Server. Wenn diese Meldung angezeigt wird, ist der im Offlineadresslistenobjekt angegebene Server nicht vorhanden. Dies kann der Fall sein, wenn der alte Offlineadressbuchserver außer Betrieb genommen oder versehentlich aus der Topologie entfernt wurde. Exchange generiert das Offlineadressbuch erst dann, wenn ein neuer Server angegeben wird.

So beheben Sie diesen Fehler in Exchange 2000 Server und Exchange Server 2003

  1. Klicken Sie im Exchange-System-Manager unter Empfänger auf Offlineadresslisten. Klicken Sie im rechten Bereich mit der rechten Maustaste auf Standard-Offlineadressliste (oder auf jede andere Offlineadressliste, die diese Meldung erzeugt), und klicken Sie dann auf Eigenschaften.

  2. Klicken Sie auf der Registerkarte Allgemein unter Server für Offlineadresslisten auf Durchsuchen, und klicken Sie dann auf den Server, der verwendet werden soll.

So beheben Sie diese Warnung in Exchange Server 2007

  1. Öffnen Sie die Exchange-Verwaltungskonsole.

  2. Erweitern Sie Microsoft Exchange, dann Organisationskonfiguration, und wählen Sie Postfach aus.

  3. Klicken Sie im Ergebnisbereich auf die Registerkarte Offlineadressbuch.

  4. Wählen Sie auf der Registerkarte Offlineadressbuch die Option Standard-Offlineadressbuch aus. Klicken Sie im Aktionsbereich auf Verschieben, um den Assistenten zum Verschieben von Offlineadressbüchern zu starten. Mit diesem Assistenten können Sie die Erstellung von Offlineadressbüchern auf einen anderen Server verlagern. Außerdem werden vorhandene Offlineadressbuchdateien auf den angegebenen Server kopiert.

So verwenden Sie die Exchange-Verwaltungsshell zum Festlegen des Servers, auf dem das Offlineadressbuch erstellt wird

  • Führen Sie den folgenden Befehl aus:

    Code kopieren
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    Dabei gilt Folgendes: <OAB> gibt den DN (Distinguished Name), den Domänen-\Kontonamen oder die GUID des Offlineadressbuchs an, und <Server> gibt den Exchange-Server an, auf dem die ausgewählte Aktion durchgeführt wird.

    Zum Verlagern der Erstellung von Offlineadressbüchern auf SERVER01, geben Sie z. B. Folgendes ein:
Code kopieren
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Weitere Informationen zum Verwenden von Offlineadressbüchern in Exchange Server 2003 finden Sie in Arbeiten mit dem Exchange Server 2003-Informationsspeicher (http://go.microsoft.com/fwlink/?LinkId=47595) unter „Konfigurieren der Offlineadressbücher von Exchange Server 2003".

Weitere Informationen zum Verwenden von Offlineadressbüchern in Exchange Server 2007 finden Sie in unter „Organisationskonfiguration > Postfach > Offlineadressbücher" (http://go.microsoft.com/fwlink/?LinkId=79247).


Der benannte Exchange-Server für den Empfängeraktualisierungsdienst ist in der Organisation nicht vorhanden.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2006-03-29

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert für das Attribut distinguishedName für sämtliche Exchange Server-Objekte im Verzeichnis zu ermitteln. Darüber hinaus fragt Exchange Server Analyzer Active Directory ab, um den Wert für das Attribut msExchAddressListServiceLink für jedes Objekt Recipient Update Service im Verzeichnis zu ermitteln. Das Attribut msExchAddressListServiceLink stellt eine Verknüpfung zwischen dem Adressenlistendienst und dem Exchange Server-Computer dar, auf dem es ausgeführt werden soll. Wenn Exchange Server Analyzer feststellt, dass der Wert für das Attribut msExchAddressListServiceLink die Zeichenfolge DEL: nicht enthält und das Attribut mit dem Attribut distinguishedName für die einzelnen Exchange Server-Objekte im Verzeichnis nicht übereinstimmt, wird eine Fehlermeldung angezeigt.

Jede Instanz des Empfängeraktualisierungsdienstes ist einem Exchange Server-Computer zugeordnet, auf dem der Empfängeraktualisierungsdienst ausgeführt wird. Wenn Sie diese Meldung erhalten, ist die Instanz des Empfängeraktualisierungsdienstes einem Exchange Server-Computer zugeordnet, der in der Exchange-Organisation nicht vorhanden ist. Der Server wurde möglicherweise außer Funktion gesetzt oder anderweitig aus der Topologie entfernt.

Um die Instanz des Empfängeraktualisierungsdienstes ausführen zu können, muss sie einem anderen vorhandenen Exchange-Server zugeordnet werden.

So beheben Sie diesen Fehler

  1. Öffnen Sie den Exchange-System-Manager.

  2. Klicken Sie unter Empfänger auf Empfängeraktualisierungsdienste. Klicken Sie im rechten Bereich mit der rechten Maustaste auf die entsprechende Instanz des Empfängeraktualisierungsdienstes, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Allgemein unter Exchange-Server auf Durchsuchen, und geben Sie einen neuen Server an, auf dem die Instanz ausgeführt werden soll.

  4. Klicken Sie auf OK. Klicken Sie anschließend erneut auf OK, damit die Änderung wirksam wird.

  5. Schließen Sie den Exchange-System-Manager.

Weitere Informationen zum Empfängeraktualisierungsdienst finden Sie in den folgenden Themen und Microsoft Knowledge Base-Artikeln:

  • „Verwalten von Empfängern und Empfängerrichtlinien" im Technischen Referenzhandbuch für Exchange Server 2003 (http://www.microsoft.com/austria/technet/articles/referenzhandbuch_exchange.mspx).

  • 328738, „XADM: How the Recipient Update Service Applies Recipient Policies" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828, „How the Recipient Update Service Populates Address Lists" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127, „XADM: How to Check the Progress of the Recipient Update Service" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127).

  • 253770, „XADM: Tasks Performed by the Recipient Update Service" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


Der benannte Routinggruppen-Masterserver wurde in dieser administrativen Gruppe nicht erkannt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs msExchRoutingMasterDN für jeden Routinggruppencontainer zu bestimmen. Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs msExchRoutingMasterDN keinen gültigen Servernamen enthält und das Attribut nicht die Zeichenfolge „DEL:" enthält, wird eine Warnung angezeigt.

Dieses Problem kann auftreten, wenn der vorherige Routinggruppen-Master außer Betrieb gesetzt wurde oder nicht ordnungsgemäß aus der Topologie entfernt wurde. Exchange benötigt einen Routinggruppenmaster, um die Routingtopologie ordnungsgemäß aktualisieren und verwalten zu können.

Beim Erstellen einer Routinggruppe wird dem ersten Server in dieser Routinggruppe die Rolle des Routinggruppenmasters zugewiesen. Der Routinggruppen-Master verwaltet die aktuellen Verbindungsstatusinformationen seiner Routinggruppe und gibt diese an die anderen Server in der Routinggruppe weiter. Der Routinggruppen-Master überwacht nur die in Active Directory eingetragene Routingkonfiguration seiner Routinggruppe. Mitgliedsserver können alle Connectorzustands- und Serververfügbarkeitsinformationen an den Routinggruppen-Master übertragen. Wenn beispielsweise ein Mitgliedsserver versucht, eine Verbindung zu einem anderen Server in einer anderen Routinggruppe über einen Connector herzustellen, diese Verbindung aber nicht verfügbar ist, benachrichtigt der Mitgliedsserver sofort den Routinggruppen-Master. Entsprechend überträgt ein Server, der nicht als Routinggruppenmaster fungiert, Connectorzustandsinformationen an den Routinggruppenmaster, wenn er neue Verbindungszustandsinformationen erhält, damit die anderen Server diese Routingänderungsinformationen erhalten.

So beheben Sie diese Warnmeldung

  1. Erweitern Sie in Exchange-System-Manager unter Administrative Gruppen den Eintrag AdministrativeGroup und dann Routinggruppen.

  2. Erweitern Sie die Routinggruppe, und klicken Sie anschließend auf Mitglieder.

  3. Klicken Sie im rechten Bereich mit der rechten Maustaste auf den Exchange-Computer, den Sie als Routinggruppenmaster konfigurieren möchten, und klicken Sie dann auf Als Master festlegen.

Weitere Informationen zu Routinggruppenmastern finden Sie im Transport- und Routing-Handbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47579) unter „Konfigurieren der Routingtopologie".


Die Anzahl von Verbindungsvereinbarungen für Öffentliche Ordner ist geringer als die Anzahl von Konfigurationsverbindungsvereinbarungen.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob Sie über eine Verbindungsvereinbarung für Öffentliche Ordner zwischen Active Directory und jedem Exchange Server 5.5-Standort verfügen. Hierbei wird sowohl die Anzahl der Verbindungsvereinbarungen für Öffentliche Ordner als auch die Anzahl der Konfigurationsverbindungsvereinbarungen abgefragt. Wenn Microsoft Exchange Server Analyzer feststellt, dass die Anzahl der Verbindungsvereinbarungen für Öffentliche Ordner geringer als die Anzahl der Konfigurationsverbindungsvereinbarungen ist, wird eine Warnung angezeigt.

Diese Warnung weist darauf hin, dass zumindest ein Exchange Server 5.5-Standort über keine Verbindungsvereinbarungen für Öffentliche Ordner mit Active Directory verfügt und Verzeichnisobjekte für Öffentliche Ordner nicht in Active Directory repliziert werden können. Daher können Nachrichten nicht von Exchange 2000 Server- oder Exchange Server 2003-Postfächern an Öffentliche Ordner in Exchange Server 5.5 übertragen werden. Ebenso können Nachrichten nicht von Exchange Server 5.5-Postfächern an E-Mail-aktivierte Öffentliche Ordner in Exchange 2000 Server oder Exchange Server 2003 übertragen werden.

Konfigurationsverbindungsvereinbarungen werden automatisch generiert, wenn Sie einen Exchange 2000 Server- oder Exchange Server 2003-Computer an einem reinen Exchange Server 5.5-Standort installieren. Verbindungsvereinbarungen für Öffentliche Ordner sind benutzerdefiniert. Wenn eine Verbindungsvereinbarung für Öffentliche Ordner zwischen jedem Exchange Server 5.5-Standort und Active Directory vorhanden ist, gibt es zumindest genauso viele Verbindungsvereinbarungen für Öffentliche Ordner wie Konfigurationsverbindungsvereinbarungen.

So erstellen Sie eine Verbindungsvereinbarung für Öffentliche Ordner

  1. Starten Sie auf einem ADC-Server (Active Directory Connector) den Active Directory Connector-Manager. (Zeigen Sie im Menü Start auf Programme oder Alle Programme, zeigen Sie auf Microsoft Exchange, und klicken Sie dann auf Active Directory Connector).

  2. Klicken Sie in der Konsolenstruktur auf Active Directory Connector. Im rechten Fenster werden alle Verbindungsvereinbarungen aufgelistet. Bestimmen Sie mithilfe dieser Liste, welche Standorte nicht über Verbindungsvereinbarungen für Öffentliche Ordner verfügen.

  3. Zeigen Sie im Menü Vorgang auf Neu, und klicken Sie dann auf Öffentlicher Ordner-Verbindungsvereinbarung, um das Dialogfeld Eigenschaften anzuzeigen.

  4. Geben Sie auf der Registerkarte Allgemein in Name einen Namen für die Verbindungsvereinbarung ein.

  5. Wählen Sie im Feld Active Directory Connector-Dienst einen Server aus, um die Verbindungsvereinbarung auszuführen.

  6. Wählen Sie auf der Registerkarte Verbindungen den Active Directory-Server und den Exchange Server 5.5-Server aus, die die Objekte Öffentlicher Ordner replizieren sollen, indem Sie für jeden das entsprechende Konto und die Anmeldeinformationen angeben.

  7. Wählen Sie auf der Registerkarte Zeitplan den Replikationszeitplan aus.

  8. Klicken Sie auf OK.

Weitere Informationen zu Verbindungsvereinbarungen für Öffentliche Ordner und zu Konfigurationsverbindungsvereinbarungen finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 264889, „XADM: Public Folder Connection Agreements" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=264889)

  • 281223, „Understanding Connection Agreements in Exchange" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=281223).


Für die Offlineadressbuchgenerierung wurde eine fortlaufende Aktualisierung konfiguriert
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2006-12-04

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob der Wert für das Attribut offLineABSchedule in der Klasse msExchOAB für die Generierung des Offlineadressbuchs konfiguriert wurde. Mit dem Attribut offLineABSchedule wird der Aktualisierungszeitplan für die Offlineadressliste festgelegt. Wenn Exchange Server Analyzer feststellt, dass der Zeitplan für die Generierung des Offlineadressbuchs für die Offlineadressliste so konfiguriert wurde, dass eine fortlaufende Aktualisierung erfolgt, wird von Exchange Server Analyzer eine Fehlermeldung angezeigt.

Beim Offlineadressbuch handelt es sich um einen Container, in dem eine Auflistung von Offlineadresslisten gespeichert ist. Verfügbare Offlineadressbücher werden von Administratoren konfiguriert. Benutzer von Microsoft Office Outlook® 2003 und Outlook 2007 können entscheiden, welche Offlineadresslisten sie herunterladen möchten. MAPI-Clients, z. B. Outlook 2003 und Outlook 2007, können Offlineadresslisten herunterladen. Somit sind Benutzer in der Lage, auch dann E-Mail-Nachrichten zu verfassen, wenn keine Verbindung mit dem Exchange-Server besteht.

Sie können den Zeitpunkt planen, zu dem Offlineadresslisten aktualisiert werden sollen. Stellen Sie dabei jedoch sicher, dass der Aktualisierungszeitplan so konfiguriert wird, dass genügend Zeit vorhanden ist, um den Generierungsvorgang der Offlineadressliste abzuschließen, bevor der nächste Aktualisierungsvorgang gestartet wird. Wenn die folgenden Bedingungen erfüllt sind, muss z. B. ein Zeitraum von mindestens vier Stunden zwischen den einzelnen Aktualisierungsintervallen liegen:

  • Es werden drei Aktualisierungsvorgänge innerhalb von 24 Stunden festgelegt.

  • Das Aktualisieren der Offlineadressliste nimmt vier Stunden in Anspruch.

Im Allgemeinen wird davon abgeraten, den Aktualisierungsvorgang häufig zu wiederholen, da häufige Aktualisierungen möglicherweise die Leistung von Client und Server auf folgende Weise beeinträchtigen:

  • Es ist eine häufigere Aktualisierung des Offlineadressbuchs durch den Server erforderlich. Dieser Vorgang kann je nach Größe des Active Directory u. U. mehrere Stunden in Anspruch nehmen.

  • Bei jeder Aktualisierung muss auf dem lokalen Computer von Outlook eine Kopie des Offlineadressbuchs erstellt und die vom Server abgerufenen inkrementellen Änderungen müssen angewendet werden. Wenn das Offlineadressbuch auf dem lokalen Computer eine Größe von 150 MB aufweist, muss Outlook bei jedem Aktualisierungsvorgang eine Kopie mit dieser Datenmenge erstellen.

  • Outlook verfügt über einen Drosselungsmechanismus, mit dem die Aktualisierung des Offlineadressbuchs verlangsamt wird, sobald Benutzeraktivitäten festgestellt werden. Bei fortlaufender Benutzeraktivität wirkt sich die Größe des Offlineadressbuchs auf die für den Aktualisierungsvorgang erforderliche Zeit aus. Diese Zeitspanne kann von einer bis zu acht Stunden umfassen.

Wenn Sie die Aktualisierungshäufigkeit erhöhen möchten, stellen Sie zuvor sicher, dass das Offlineadressbuch nicht zu umfangreich ist. Die empfohlene Größe in nicht komprimiertem Zustand liegt zwischen 1 MB und 25 MB.

So planen Sie eine Zeit für die Aktualisierung der Offlineadresslisten in Exchange 2000 Server und Exchange Server 2003

  1. Doppelklicken Sie im System-Manager auf Empfänger, und klicken Sie dann auf Offlineadresslisten.

  2. Doppelklicken Sie im Detailbereich auf die Offlineadressliste, für die Sie einen Aktualisierungszeitplan festlegen möchten.

    1. Wenn Sie ein vorkonfiguriertes Aktualisierungsintervall verwenden möchten, wählen Sie auf der Registerkarte Allgemein in der Dropdownliste Aktualisierungsintervall eins der angegebenen Intervalle aus.

      Wichtig:
      Wenn Sie in der Dropdownliste die Option Nie ausführen auswählen, wird die Offlineadressliste nicht aktualisiert.
    2. Wenn Sie einen speziellen Aktualisierungszeitplan festlegen möchten, klicken Sie auf Anpassen. Legen Sie den Aktualisierungszeitplan im Dialogfeld Zeitplan mithilfe des angezeigten Tages- und Zeitrasters fest, und klicken Sie dann auf OK.

So beheben Sie diese Warnung in Exchange Server 2007

  1. Öffnen Sie die Exchange-Verwaltungskonsole.

  2. Erweitern Sie Microsoft Exchange, dann Organisationskonfiguration, und wählen Sie Postfach aus.

  3. Klicken Sie im Ergebnisbereich auf die Registerkarte Offlineadressbuch.

  4. Wählen Sie auf der Registerkarte Offlineadressbuch die Option Standard-Offlineadressbuch aus. Klicken Sie im Aktionsbereich auf Eigenschaften.

  5. Wählen Sie auf der Registerkarte Allgemein die Laufzeit aus der Dropdown-Liste Aktualisierungszeitplan aus, oder klicken Sie auf Anpassen, um einen benutzerdefinierten Zeitplan festzulegen.

  6. Klicken Sie auf OK, um die Änderungen zu speichern.
So verwenden Sie die Exchange-Verwaltungsshell zum Einrichten des Zeitplans für die Generierung des Offlineadressbuchs

  • Führen Sie den folgenden Befehl aus:

    Code kopieren
    Set-OfflineAddressBook -Identity <OAB Name> -Schedule <Schedule>

    Dabei gilt Folgendes: <OAB> gibt den DN (Distinguished Name), den Domänen-\Kontonamen oder die GUID des Offlineadressbuchs an, und <Zeitplan> gibt die geplanten Zeiten für den Beginn der OAB-Generierung an. Das Format lautet Starttag.Stunde:Minute [AM/PM]. Folgende Werte können für die Tage verwendet werden:

    • Vollständiger Name des Tags

    • Abgekürzter Name des Tags

    • Ganze Zahl von 0 bis 6, wobei 0 für Sonntag steht

    Wenn Sie das 24-Stunden-Format verwenden, lassen Sie die Angabe "AM/PM" weg.

    Wenn das Standard-Offlineadressbuch beispielsweise täglich zwischen 13.00 Uhr und 15.00 Uhr generiert werden soll, geben Sie Folgendes ein:
Code kopieren
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -Schedule 0.01:00-0.03:00,1.01:00-1.03:00,2.01:00-2.03:00,3.01:00-3.03:00,4.01:00-4.03:00,5.01:00-5.03:00,6.01:00-6.03:00

Weitere Informationen finden Sie unter Offline Address Book Best Practices Guide (http://go.microsoft.com/fwlink/?LinkId=47583).

Weitere Informationen zum Verwenden von Offlineadressbüchern in Exchange Server 2003 finden Sie in Arbeiten mit dem Exchange Server 2003-Informationsspeicher (http://go.microsoft.com/fwlink/?LinkId=47595) unter „Konfigurieren der Offlineadressbücher von Exchange Server 2003".

Weitere Informationen zum Verwenden von Offlineadressbüchern in Exchange Server 2007 finden Sie in unter „Organisationskonfiguration > Postfach > Offlineadressbücher" (http://go.microsoft.com/fwlink/?LinkId=79247).


Der Erstellungsplan für das Offlineadressbuch wurde auf „Nie" festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2006-12-04

Microsoft® Exchange Server Analyzer sendet eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert des Attributs offLineABSchedule für das Konfigurationsobjekt des Offlineadressbuchs zu bestimmen. Das Attribut offLineABSchedule stellt den Offlineadressbuch-Erstellungsplan für das Standardobjekt der Offlineadressliste im Adresslistencontainer in Active Directory dar. Wenn Exchange Server Analyzer feststellt, dass das Attribut offLineABSchedule auf Nie festgelegt ist, wird eine Warnung angezeigt.

In der Standardeinstellung wartet Exchange Server ein einzelnes Offlineadressbuch. Exchange Server aktualisiert dieses Offlineadressbuch bei jedem nächtlichen Wartungszyklus (oder erzeugt eine neue Version davon). Sie können zusätzliche Offlineadressbücher erstellen und die folgenden Vorgehensweisen verwenden, um deren Erstellungsplan zu prüfen.

Diese Warnung gibt an, dass der Zeitplan auf Nie geändert wurde. Exchange Server aktualisiert die bestehenden Offlineadressbücher solange nicht, bis Sie einen neuen Zeitplan festlegen. Dies bedeutet, dass Benutzer die Möglichkeit haben, das bestehende Offlineadressbuch zu downloaden, jedoch keine Aktualisierungen erhalten.

So beheben Sie diese Warnung in Exchange 2000 Server und Exchange Server 2003

  1. Öffnen Sie den Exchange-System-Manager.

  2. Klicken Sie unter Empfänger auf Offlineadresslisten.

  3. Klicken Sie im rechten Bereich mit der rechten Maustaste auf Standard, Offlineadressliste, und klicken Sie dann auf Eigenschaften. Wenn Sie kein Offlineadressbuch verwenden möchten, klicken Sie mit der rechten Maustaste auf StandardOfflineadressbuch, und klicken Sie dann auf Löschen. Andernfalls verwenden Sie des Rest dieses Vorgangs, um einen Zeitplan festzulegen.

  4. Wählen Sie auf der Registerkarte Allgemein die Laufzeit aus der Dropdown-Liste Aktualisierungsintervall aus, oder klicken Sie auf Anpassen, um einen benutzerdefinierten Zeitplan festzulegen.

  5. Klicken Sie auf OK, um die Änderungen zu speichern.

So beheben Sie diese Warnung in Exchange Server 2007

  1. Öffnen Sie die Exchange-Verwaltungskonsole.

  2. Erweitern Sie Microsoft Exchange, dann Organisationskonfiguration, und wählen Sie Postfach aus.

  3. Klicken Sie im Ergebnisbereich auf die Registerkarte Offlineadressbuch.

  4. Wählen Sie auf der Registerkarte Offlineadressbuch die Option Standard-Offlineadressbuch aus. Klicken Sie im Aktionsbereich auf Eigenschaften.

  5. Wählen Sie auf der Registerkarte Allgemein die Laufzeit aus der Dropdown-Liste Aktualisierungszeitplan aus, oder klicken Sie auf Anpassen, um einen benutzerdefinierten Zeitplan festzulegen.

  6. Klicken Sie auf OK, um die Änderungen zu speichern.

So verwenden Sie die Exchange-Verwaltungsshell zum Einrichten des Zeitplans für die Generierung des Offlineadressbuchs

  • Führen Sie den folgenden Befehl aus:

    Code kopieren
    Set-OfflineAddressBook -Identity <OAB Name> -Schedule <Schedule>

    Dabei gilt Folgendes: <OAB> gibt den DN (Distinguished Name), den Domänen-\Kontonamen oder die GUID des Offlineadressbuchs an, und <Zeitplan> gibt die geplanten Zeiten für den Beginn der OAB-Generierung an. Das Format lautet Starttag.Stunde:Minute [AM/PM]. Folgende Werte können für die Tage verwendet werden:

    • Vollständiger Name des Tags

    • Abgekürzter Name des Tags

    • Ganze Zahl von 0 bis 6, wobei 0 für Sonntag steht

    Wenn Sie das 24-Stunden-Format verwenden, lassen Sie die Angabe "AM/PM" weg.

    Wenn das Standard-Offlineadressbuch beispielsweise täglich zwischen 13.00 Uhr und 15.00 Uhr generiert werden soll, geben Sie Folgendes ein:
Code kopieren
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -Schedule 0.01:00-0.03:00,1.01:00-1.03:00,2.01:00-2.03:00,3.01:00-3.03:00,4.01:00-4.03:00,5.01:00-5.03:00,6.01:00-6.03:00

Weitere Informationen zum Verwenden von Offlineadressbüchern in Exchange Server 2003 finden Sie in Arbeiten mit dem Exchange Server 2003-Informationsspeicher (http://go.microsoft.com/fwlink/?LinkId=47595) unter „Konfigurieren der Offlineadressbücher von Exchange Server 2003".

Weitere Informationen zum Verwenden von Offlineadressbüchern in Exchange Server 2007 finden Sie in unter „Organisationskonfiguration > Postfach > Offlineadressbücher" (http://go.microsoft.com/fwlink?LinkId=79247).


Alte Verbindungsvereinbarungsversion wurde erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs versionNumber in jeder ADC-Verbindungsvereinbarung (Active Directory Connector) zu bestimmen.

Wenn Exchange Server Analyzer feststellt, dass der Wert für das Attribut versionNumber einer Verbindungsvereinbarung in einer Exchange-Organisation mit einem oder mehreren ExchangeServer 2003-Computern weniger als 16973842 beträgt, wird eine Warnung angezeigt.

Ein kleinerer Wert als 16973842 gibt an, dass die Verbindungsvereinbarung erstellt wurde und von einem Exchange 2000 Server-ADC verwaltet wird. Wenn Sie eine Instanz von Exchange Server 2003 in einer Organisation ausführen, in der entweder Exchange 2000 Server oder Exchange Server 5.5 ausgeführt wird, müssen Sie alle Versionen von ADC auf die in Exchange Server 2003 enthaltene Version aktualisieren. Nach dem Aktualisieren auf die ADC-Version Exchange Server 2003 oder Exchange Server 2003 Service Pack 1 (SP1) werden die Verbindungsvereinbarungen im Besitz dieser Version von ADC ebenfalls aktualisiert. Das Attribut versionNumber jeder Verbindungsvereinbarung wird mit dem neuesten Wert aktualisiert.

So beheben Sie diese Warnmeldung

  1. Downloaden Sie Exchange 2003 Server SP1 unter http://go.microsoft.com/fwlink/?LinkId=29090.

  2. Führen Sie eine vollständige Sicherung des Exchange Server-Computers durch.

  3. Klicken Sie auf dem Server, auf dem Exchange 2000 Server-ADC ausgeführt wird, auf Start, klicken Sie auf Ausführen, und geben Sie dann <Pfad>\adc\i386\setup.exe ein, wobei <path> den Speicherort für den Download von Exchange Server 2003 SP1 darstellt.

  4. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation des Active Directory Connectors auf Weiter.

  5. Klicken Sie auf der Seite Alte Installation gefunden auf Neu installieren, um von Exchange 2000 Server-ADC auf Exchange Server 2003-ADC zu aktualisieren.

  6. Klicken Sie auf der Seite Der Assistent für die Installation des Active Directory Connectors wird beendet auf Fertig stellen.

Weitere Informationen zum Installieren und Aktualisieren von ADC finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 823601, „Anforderungen und Auswirkungen von Active Directory Connector innerhalb eines Netzwerks" unter http://support.microsoft.com/default.aspx?scid=kb;de;823601

  • „Was bei der Aktualisierung auf Exchange Server 2003 zu beachten ist" unter http://support.microsoft.com/?scid=kb%3Bde%3B822942&x=7&y=5


Keine Rückmeldung von FSMO-Funktion für PDC-Emulator.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs fSMORoleOwner im Stamm der Domänenverzeichnispartition im Domänennamenskontext zu bestimmen. In einer Domäne mit dem Namen contoso.com ist beispielsweise fSMORoleOwner für den PDC-Emulator (Primary Domain Controller - primärer Domänencontroller) ein Attribut von DC=contoso,DC=com. Exchange Server Analyzer versucht dann, eine LDAP-Verbindung (Lightweight Directory Access Protocol) mit dem TCP-Anschluss 389 auf dem Domänencontroller zu öffnen, in der die Rolle aktuell vorhanden ist. Wenn Exchange Server Analyzer keine Verbindung mit dem Domänencontroller herstellen kann, wird ein Fehler angezeigt.

Der PDC-Emulator dient als primärer Domänencontroller für die Kompatibilität mit früheren Microsoft Windows®-Betriebssystemen. Microsoft Windows 2000 Server und Microsoft Windows Server™ 2003 interagieren mit Microsoft Windows NT®-Workstations, Mitgliedsservern und Sicherungsdomänencontrollern. Der PDC in einer Microsoft Windows NT 3.51- oder Microsoft Windows NT 4.0-Domäne führt folgende Aufgaben aus:

  • Verarbeitung der geänderten Kennwörter von Benutzern und Computern

  • Replikation von Updates auf Sicherungsdomänencontroller

  • Ausführen des Hauptsuchdienstes der Domäne

Die Rolle des PDC-Emulatormasters kann immer nur einem Domänencontroller pro Domäne zugewiesen werden.

So beheben Sie diesen Fehler

  1. Überprüfen Sie, ob der im Fehler angegebene Verzeichnisserver online ist und ob andere Exchange-Server in der Organisation Zugriff darauf haben.

  2. Wenn der Verzeichnisserver außer Betrieb gesetzt wurde, weisen Sie die Rolle des PDC-Emulators einem anderen Domänencontroller zu.

Weitere Informationen zur Übertragung der Rolle des PDC-Emulators von einem Domänencontroller auf einen anderen Domänencontroller finden Sie in den Microsoft Knowledge Base-Artikeln:

  • Weitere Informationen zu Windows Server™ 2003 finden Sie in Artikel 324801 „Anzeigen und Übertragen von FSMO-Funktionen in Windows Server 2003" unter http://support.microsoft.com/?kbid=324801.

  • Weitere Informationen zu Windows 2000 Server finden Sie in Artikel 255690 „SO WIRD'S GEMACHT: Einsehen und Übertragen von FSMO-Funktionen in der GUI" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Sperre der Vererbung von Berechtigungen für Objekt Konfiguration
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2006-04-13

Microsoft® Exchange Server Analyzer fragt jedes Exchange-Konfigurationsobjekt in der Active Directory®-Datenbank ab, um festzustellen, ob bei einem Objekt die Vererbung von Berechtigungen gesperrt ist. Wenn für ein Exchange-Konfigurationsobjekt die Vererbung von Berechtigungen gesperrt ist, zeigt Exchange Server Analyzer einen Fehler an.

Exchange Server Analyzer identifiziert das Konfigurationsobjekt, für das die Vererbung von Berechtigungen gesperrt ist.

Exchange Server Analyzer ruft für Exchange-Konfigurationsobjekte freigegebene Zugriffssteuerungslisten (Discretionary Access Control List, DACL) aus Active Directory ab. Standardmäßig werden Konfigurationsobjekte wie Computer mit Exchange Server und Exchange Server-Protokolle bei der Installation von Exchange so festgelegt, dass Berechtigungen vererbt werden. Wenn Berechtigungen versehentlich deaktiviert oder geändert werden, kann die Vererbung von Berechtigungen für ein Konfigurationsobjekt gesperrt werden. In diesem Zustand kann die Reaktionsgeschwindigkeit von Exchange Server durch Probleme mit der Nachrichtenübermittlung, z. B. feststeckende Nachrichten in Warteschlangen, sowie durch Probleme bei der Bereitstellung von Informationsspeichern herabgesetzt werden.

Hinweis:
Bei der Zugriffssteuerungsliste (Access Control List, ACL) handelt es sich um eine Liste von Sicherungen, die auf alle Eigenschaften eines Objekts, auf einen Satz von Eigenschaften des Objekts oder auf eine einzelne Eigenschaft eines Objekts angewendet werden. Es gibt zwei Arten von Zugriffssteuerungslisten: freigegeben und System.

Das Problem kann durch erneutes Aktivieren der Vererbung von Berechtigungen für das Objekt behoben werden.

So aktivieren Sie die Vererbung von Berechtigungen für ein Exchange-Konfigurationsobjekt erneut

  1. Aktivieren Sie die Registerkarte Sicherheit für das Objekteigenschaftenfeld des Exchange-System-Managers, indem Sie einen Registrierungsparameter festlegen. Detaillierte Anleitungsschritte finden Sie im Microsoft Knowledge Base-Artikel 264733, „Aktivieren der Registerkarte 'Sicherheit' für das Organisationsobjekt in Exchange 2000 und Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264733).

    Hinweis:
    Standardmäßig ist die Registerkarte Sicherheit im Eigenschaftenfeld des Konfigurationsobjekts deaktiviert.

  2. Öffnen Sie den Exchange-System-Manager, suchen Sie das fragliche Objekt, und aktivieren Sie die Vererbung von Berechtigungen erneut.

  3. Starten Sie Exchange Server erneut.

Weitere Informationen zu freigegebenen Zugriffssteuerungslisten (Discretionary Access Control List, DACL) in Windows Server 2003 Active Directory finden Sie unter „How Security Descriptors and Access Control Lists Work"

(http://go.microsoft.com/fwlink/?LinkId=64193).

Weitere Informationen zur Vererbung von Berechtigungen finden Sie unter „How Permissions Work" (http://go.microsoft.com/fwlink/?LinkId=64195).


Sperre der Vererbung von Berechtigungen für Objekt Domäne
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2006-04-13

Microsoft® Exchange Server Analyzer überprüft Active Directory®-Domänenobjekte wie Container und Organisationseinheiten. Wenn in den Containern oder Organisationseinheiten die Vererbung von Berechtigungen gesperrt ist, zeigt Exchange Server Analyzer einen Fehler an.

Exchange Server Analyzer identifiziert das spezifische Objekt.

Durch Änderungen an einem Active Directory-Domänenobjekt werden Änderungen an der Zugriffssteuerungsliste (Access Control List, ACL) überschrieben. Auch wenn Inherit from parent manuell aktiviert ist, wird die angewendete Vererbung bei Änderungen an der ACL deaktiviert. Aus diesem Zustand resultieren Probleme mit dem Empfängeraktualisierungsdienst (Recipient Update Service, RUS), weil dieser nicht über ausreichende Berechtigungen für eine Active Directory-Organisationseinheit verfügt, in der sich die Konten befinden.

Zu diesem Verhalten kann es kommen, wenn in der Active Directory-Organisationseinheit, in der sich die Konten befinden, das Kontrollkästchen Berechtigungen übergeordneter Objekte, sofern vererbbar, über alle untergeordneten Objekte verbreiten deaktiviert wurde.

Um das Problem zu beheben, verwenden Sie das Snap-In „Active Directory-Benutzer und -Computer" oder ADSI-Bearbeitung (Active Directory Service Interfaces), um vererbbare Berechtigungen für die Organisationseinheit wiederherzustellen. Befolgen Sie die unter Szenario 2 beschriebenen detaillierten Anleitungsschritte im Microsoft Knowledge Base-Artikel 254030, „Durch fehlende Berechtigungen werden Konten in Exchange 2000 Server und Exchange Server 2003 vom Empfängeraktualisierungsdienst nicht verarbeitet" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=254030).

Weitere Informationen zu Zugriffssteuerungslisten (Access Control List, ACL) in Microsoft Windows Server 2003™ Active Directory finden Sie unter „How Security Descriptors and Access Control Lists Work" (http://go.microsoft.com/fwlink/?LinkId=64193).

Weitere Informationen zur Vererbung von Berechtigungen finden Sie unter „How Permissions Work" (http://go.microsoft.com/fwlink/?LinkId=64195).


Die Öffentliche Ordner-Hierarchie wurde nicht gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um die Anzahl der Öffentlichen Ordner-Hierarchien zu ermitteln, deren Attribut msExchPFTreeType den Wert 1 aufweist. Der Wert 1 für das Attribut msExchPFTreeType zeigt an, dass eine bestimmte Öffentliche Ordner-Hierarchie die für MAPI-Clients festgelegte Öffentliche Ordner-Hierarchie ist. Wenn Exchange Server Analyzer feststellt, dass keine der Öffentlichen Ordner-Hierarchien in der Exchange-Organisation für das Attribut msExchPFTreeType den Wert 1 aufweist, zeigt Exchange Server Analyzer einen Fehler an.

Dieser Fehler gibt an, dass in der Organisation keine Öffentliche Ordner-Hierarchie für MAPI-Clients vorhanden ist. Wenn keine Öffentliche Ordner-Hierarchie für MAPI-Clients vorhanden ist, können Probleme auftreten. Das Fehlen einer Öffentlichen Ordner-Hierarchie für MAPI-Clients kann beispielsweise dazu führen, dass Exchange Virtual Server, das in einem Microsoft Windows®-Servercluster ausgeführt wird, nicht aktualisiert werden kann.

Um dieses Problem zu beheben, können Sie mit einem Active Directory-Bearbeitungstool den Wert des Attributs msExchPFTreeType der Öffentlichen Ordner-Hierarchie für MAPI-Clients auf 1 festlegen. Die folgenden Tools sind Active Directory-Bearbeitungstools:

  • ADSI-Bearbeitung (Active Directory Service Interfaces; AdsiEdit.msc).

  • LDP-Tool (ldp.exe)

Sie sollten nur die Öffentliche Ordner-Hierarchie für MAPI-Clients ändern. Wenn Ihre Exchange-Organisation Öffentliche Ordner-Hierarchien für Anwendungen enthält, müssen Sie sicherstellen, dass nur das Attribut für die Öffentliche Ordner-Hierarchie für MAPI-Clients geändert wird.

Nachdem Sie den Wert für das Attribut msExchPFTreeType für die Öffentliche Ordner-Hierarchie für MAPI-Clients auf 1 festgelegt haben, konfigurieren Sie die Postfachspeicher auf den Exchange-Servern so, dass sie auf die Öffentliche Ordner-Hierarchie für MAPI-Clients als den Standardspeicher für Öffentliche Ordner zeigen.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In, das LDP-Tool oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Windows Server™ 2003, Exchange Server 2003 oder beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So beheben Sie diesen Fehler

  1. Suchen Sie mit einem Active Directory-Bearbeitungstool die Objekte der Öffentlichen Ordner-Hierarchie in Active Directory. Die Objekte der Öffentlichen Ordner befinden sich unter CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Folder Hierarchies.

  2. Ändern Sie das Attribut msExchPFTreeType, indem Sie 1 als neuen Wert eingeben.

  3. Schließen Sie den Active Directory-Editor.

  4. Öffnen Sie den Exchange-System-Manager.

  5. Um auf die Eigenschaften der einzelnen Postfachspeicher zuzugreifen, klicken Sie auf Administrative Gruppen, erweitern Sie die entsprechende administrative Gruppe, erweitern Sie Server, erweitern Sie den entsprechenden Server und die Speichergruppe. Klicken Sie dann mit der rechten Maustaste auf den Postfachspeicher, dessen Eigenschaften Sie ändern möchten, und wählen Sie Eigenschaften aus.

  6. Klicken Sie auf der Registerkarte Allgemein für das Feld Öffentlicher Standardinformationsspeicher auf Durchsuchen.

  7. Wählen Sie die Öffentliche Ordner-Hierarchie für MAPI-Clients aus, und klicken Sie zweimal auf OK, um die Änderungen zu speichern.

  8. Wiederholen Sie die Schritte 5 bis 7 für jeden Postfachspeicher.

Weitere Informationen zum Ändern von Active Directory mit dem LDP-Tool finden Sie im Microsoft Knowledge Base-Artikel 260745, „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Weitere Informationen zu Öffentlichen Ordner-Hierarchien für MAPI-Clients und Anwendungen finden Sie in den folgenden Ressourcen:

  • Microsoft Knowledge Base-Artikel 258509, „Description of public folder tree types in Exchange 2000 Server and in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258509)

  • Exchange Team Blog-Eintrag „How mail-enabled Public Folders work" (http://go.microsoft.com/fwlink/?LinkId=41913)


Replikationszeitplan für die Verbindungsvereinbarung des Empfängers ist nicht auf „Immer" festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, auf welchen Wert das Attribut activationStyle für jede ADC-Verbindungsvereinbarung (Active Directory Connector) festgelegt ist. Das Attribut activationStyle entspricht der Häufigkeit, mit der eine ADC-Verbindungsvereinbarung ausgeführt wird. Der Wert 0 gibt an, dass der Replikationszeitplan auf Nie festgelegt ist. Der Wert 1 gibt an, dass der Zeitplan auf Zu ausgewählten Zeiten festgelegt ist. Der Wert 2 gibt an, dass der Zeitplan auf Immer festgelegt ist.

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst außerdem ab, um den Wert des Attributs msExchServer2SearchFilter für jedes ADC-Verbindungsvereinbarungsobjekt zu ermitteln. Das Attribut msExchServer2SearchFilter stellt den Suchfilter dar, der bei der Verzeichnissuche verwendet wird.

Wenn Exchange Server Analyzer feststellt, dass das Attribut activationStyle nicht auf Always festgelegt ist und das Attribut msExchServer2SearchFilter die Empfängerinformationen repliziert, wird eine Warnung angezeigt.

Im Allgemeinen wird als optimale Methode empfohlen, den Replikationszeitplan für die Empfängerverbindungsvereinbarung auf Always festzulegen. In einigen Fällen kann das Festlegen der Verbindungsvereinbarung auf einen anderen Zeitplan zu Unzustellbarkeitsberichten führen, nachdem Postfächer von Exchange Server 5.5-Standorten zu Exchange Server 2003-Organisationen verschoben werden.

So beheben Sie dieses Problem

  1. Öffnen Sie das MMC-Snap-In Active Directory Connector-Dienste.

  2. Öffnen Sie die Verbindungsvereinbarung.

  3. Auf der Seite mit den Eigenschaften der Verbindungsvereinbarung wählen Sie die Registerkarte Zeitplan aus, wählen Sie Immer aus, und klicken Sie dann auf OK.

Weitere Informationen zum Bereitstellen von ADC und zum Konfigurieren von Verbindungsvereinbarungen finden Sie im Bereitstellungshandbuch für Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?displaylang=de&FamilyID=77b6d819-c7b3-42d1-8fbb-fe6339ffa1ed).


Empfängerrichtlinie enthält Variable
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs gatewayProxy für jedes Empfängerrichtlinienobjekt zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass ein Empfängerrichtlinienobjekt vorhanden ist, in dessen Attribut gatewayProxy die Zeichenfolge SMTP:% enthalten ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Wenn Sie zum Generieren von SMTP-Adressen (Simple Mail Transfer Protocol) mithilfe von Ersetzungszeichenfolgen Änderungen an einer Empfängerrichtlinie vorgenommen haben, sind in der Empfängerrichtlinie Variablen enthalten. Die Verwendung von Variablen in der Standardempfängerrichtlinie kann bei der Replikation in Exchange 2000 Server-Versionen vor Service Pack 2 (SP2) zu Problemen führen. Daher empfiehlt es sich, in Empfängerrichtlinien keine Variablen zu verwenden oder Exchange 2000 Server auf das aktuellste Service Pack zu aktualisieren. In Exchange 2000 Server SP2 und höher werden Variablen in der Standardempfängerrichtlinie unterstützt.

So ändern Sie Empfängerrichtlinien

  1. Starten Sie den Exchange-System-Manager.

  2. Klicken Sie auf Organisation, klicken Sie anschließend auf Empfänger und dann auf Empfängerrichtlinien.

  3. Doppelklicken Sie auf die zu ändernde Richtlinie.

  4. Klicken Sie auf die Registerkarte E-Mail-Adressen, und bearbeiten Sie die entsprechende SMTP-Adresse oder Generierungsregel.

Weitere Informationen zu Konfigurationsverfahren für Empfängerrichtlinien finden Sie im Microsoft Knowledge Base-Artikel 249299 „SO WIRD'S GEMACHT: Konfigurieren der Empfängerrichtlinien in Exchange" (http://support.microsoft.com/?scid=kb%3Bde%3B249299&x=12&y=7).

Weitere Informationen zum Verwenden von Generierungsregeln zum Anpassen von SMTP-Adressen finden Sie im Knowledge Base-Artikel 822447, „How to Modify an SMTP E-mail Address by Using Recipient Policies" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822447).

Weitere Informationen zu möglichen Problemen in Exchange 2000 Server bei Variablen in Empfängerrichtlinien finden Sie im Knowledge Base-Artikel 271339, „XADM: Cannot Mount Database and Event ID 9546 Occurs" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=271339).

Die aktuellen Service Packs für Exchange 2000 Server finden Sie unter „Downloads for Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=33457).


Der Empfängeraktualisierungsdienst scheint blockiert zu sein
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert für das Attribut msExchServer1HighestUSN von jedem Empfängeraktualisierungsdienst-Objekt in Active Directory zu bestimmen. Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert für das Attribut activationStyle von jedem Empfängeraktualisierungsdienst-Objekt in Active Directory zu bestimmen. Das Attribut activationStyle gibt das Aktualisierungsintervall des Empfängeraktualisierungsdienstes an.

Exchange Server Analyzer fragt auch Active Directory ab, um den Wert für das Attribut highestCommittedUSN für das Attribut RootDSE des vom Empfängeraktualisierungsdienst verwendeten Domänencontrollers zu bestimmen. Das Attribut highestCommittedUSN ist die höchste Update Sequence Number (USD - Aktualisierungssequenznummer) für jedes Objekt auf dem Server, dass an die Datenbank auf diesem Domänencontroller übergeben wurde.

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert für das Attribut msExchServer1LastUpdateTime von jedem Empfängeraktualisierungsdienst-Objekt zu bestimmen. Das Attribut msExchServer1LastUpdateTime gibt das Datum und die Uhrzeit der letzten Aktualisierung der letzten erfolgreichen Synchronisierung für dieses Verzeichnis an.

Wenn Exchange Server Analyzer feststellt, dass die folgenden drei Bedingungen erfüllt sind, wird eine Warnung angezeigt:

  • Das Attribut activationStyle ist auf 2 festgelegt, wodurch angezeigt wird, dass der Zeitplan dieses Empfängeraktualisierungsdienstes auf Immer festgelegt ist.

  • Die im Wert msExchServer1HighestUSN angegebene Sequenznummer ist mindestens 5.000 hinter der in highestCommittedUSN aufgelisteten Sequenznummer.

  • Seit der Aufzeichnung des Zeitstempels im Attribut msExchServer1LastUpdateTime sind mindestens sechs Stunden vergangen.

Diese Warnung gibt an, dass der angegebene Empfängeraktualisierungsdienst seit mehreren Stunden nicht ausgeführt wurde und möglicherweise blockiert ist.

So beheben Sie diese Warnung

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Empfänger, und wählen Sie dann Empfängeraktualisierungsdienste aus.

  3. Klicken Sie mit der rechten Maustaste auf den angegebenen Empfängeraktualisierungsdienst, und wählen Sie dann Jetzt aktualisieren aus.

  4. Warten Sie 30 Minuten, und führen Sie dann den Exchange Server Analyzer erneut aus, um zu überprüfen, ob die Warnung noch angezeigt wird. Wenn dies der Fall ist, fahren Sie mit Schritt 5 fort. Wenn die Warnung nicht mehr angezeigt wird, sind keine weiteren Aktionen erforderlich.

  5. Starten Sie den Dienst Microsoft Exchange-Systemaufsicht erneut.

Weitere Informationen zum Empfängeraktualisierungsdienst finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 253770, „Tasks performed by the Recipient Update Service" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828, „How the Recipient Update Service Populates Address Lists" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838, „XADM: How the Recipient Update Service Applies System Policies" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738, „XADM: How the Recipient Update Service Applies Recipient Policies" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


Der Empfängeraktualisierungsdienst hat nicht alle Änderungen verarbeitet
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2006-03-16

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um zu ermitteln, ob für das Attribut gatewayProxy eines Empfängeraktualisierungsdienst-Objekts in Active Directory Werte vorhanden sind. Wenn Exchange Server Analyzer feststellt, dass für das Attribut gatewayProxy eines Empfängeraktualisierungsdienst-Objekts Werte festgelegt sind, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass das Attribut gatewayProxy eines Empfängeraktualisierungsdienst-Objekts alte Daten enthält, die nicht vollständig bearbeitet wurden. Diese Daten müssen manuell entfernt werden.

Alte Daten aus dem gatewayProxy-Attribut müssen entfernt werden. Andernfalls sind diese Adressen in einem Zustand 'angenwendet'. Wenn der Administrator eine Richtlinie mithilfe einer der Optionen 'Neu erstellen' oder 'Jetzt aktualisieren' ändert, können gültige Benutzeradressen versehentlich überschrieben werden, wodurch die SMTP-Adressen für jeden der Benutzer geändert werden. Weitere Informationen finden Sie im Exchange-Blog-Artikel Recipient Policies and pure Exchange 2000/2003 sites.

Hinweis:
Der Link zu diesen Blog dient ausschließlich Informationszwecken. Der Inhalt kann jederzeit ohne vorherige Ankündigung geändert werden.

Das Attribut gatewayProxy eines Empfängeraktualisierungsdienst-Objekts enthält möglicherweise alte, nicht vollständig bearbeitete Daten, wenn eine der folgenden Bedingungen erfüllt ist:

  • Es sind Probleme mit der Active Directory-Replikation aufgetreten. Wenn Exchange-System-Manager einen Domänencontroller verwendet, der nicht von dem den Empfängeraktualisierungsdienst ausführenden Exchange-Server verwendet wird, treten möglicherweise Probleme mit Wartezeiten oder andere Probleme mit der Active Directory-Replikation auf.

  • Es sind von Transaktionen unabhängige, zeitliche Probleme aufgetreten, durch die Änderungen verloren gegangen sind. Dieses Verhalten tritt möglicherweise auf, wenn der Exchange-System-Manager und die Systemaufsicht gleichzeitig auf das Attribut gatewayProxy zugreifen. Sowohl der Exchange-System-Manager als auch die Systemaufsicht versuchen, das Attribut zu lesen, Änderungen vorzunehmen und das Attribut dann zurück zu schreiben.

Sie müssen die alten Daten mithilfe eines Tools entfernen, z. B. mit dem ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces, AdsiEdit.msc), dem LDP-Tool (ldp.exe) oder einem anderen LDAP-Client (Lightweight Directory Access Protocol, Version 3).

Achtung:
Wenn Sie die ADSI-Bearbeitung, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So beheben Sie diese Warnung

  1. Legen Sie folgendermaßen das Aktualisierungsintervall des Empfängeraktualisierungsdienstes auf Nie fest:

    1. Öffnen Sie den Exchange-System-Manager.

    2. Erweitern Sie Empfänger, und erweitern Sie dann Empfängeraktualisierungsdienste.

    3. Klicken Sie mit der rechten Maustaste auf den zu ändernden Empfängeraktualisierungsdienst, und wählen sie Eigenschaften aus.

    4. Legen Sie auf der Registerkarte Allgemein mithilfe der Liste Aktualisierungsintervall den Zeitplan auf Nie ausführen fest.

  2. Warten Sie etwa ein bis zwei Minuten.

  3. Suchen Sie als nächsten Schritt mithilfe des ADSI-Bearbeitungs-Snap-Ins oder einem vergleichbaren Tool das Empfängeraktualisierungsdienst-Objekt, in dem im Attribut gatewayProxy alte Daten enthalten sind. Empfängeraktualisierungsdienst-Objekte befinden sich an folgender Position:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organisation,CN=Address Lists Container,CN=Recipient Update Services

    1. Klicken Sie mit der rechten Maustaste auf das Empfängeraktualisierungsdienst-Objekt, das alte Daten enthält, und wählen sie Eigenschaften aus.

    2. Führen Sie auf der Registerkarte Attribut-Editor einen Bildlauf nach unten durch, und wählen Sie das Attribut gatewayProxy aus.

    3. Klicken Sie zum Bearbeiten dieses Attributs auf Bearbeiten.

    4. Wählen Sie im Feld Wert(e) den übernommenen Adressentyp, der entfernt werden soll, klicken Sie auf Entfernen, und klicken Sie dann auf OK. Wiederholen Sie diesen Schritt, bis alle Adresstypen entfernt wurden.

    5. Klicken Sie zum Speichern der Änderung auf OK, und schließen Sie dann das ADSI-Bearbeitungs-Snap-In.

  4. Erzwingen Sie eine Verzeichnisreplikation, nachdem Sie die alten Daten im Attribut gatewayProxy gelöscht haben. Stellen Sie sicher, dass die Replikation erfolgt, bevor Sie den Empfängeraktualisierungsdienst der Domäne erneut ausführen.

  5. Konfigurieren Sie den Empfängeraktualisierungsdienst wieder auf den ursprünglichen Zeitplan.

  6. Wenden Sie ggf. die jeweiligen Empfängerrichtlinien erneut an. Führen Sie mit dem Snap-In „Active Directory-Standorte und -Dienste" eine manuelle Active Directory-Replikation durch.

Weitere Informationen zu diesem Problem finden Sie im Microsoft Knowledge Base-Artikel 821743, „Das gatewayProxy-Attribut des Empfängeraktualisierungsdienst-Objekts wird nicht gelöscht" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821743).

Weitere Informationen zur Verwendung des LDP-Tools finden Sie im Microsoft Knowledge Base-Artikel 260745, „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Weitere Informationen zum Erzwingen der Verzeichnisreplikation finden Sie im Microsoft Knowledge Base-Artikel 232072, „Einleiten der Replikation zwischen direkten Replikationspartnern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Weitere Informationen zum Verwenden von ADSI-Bearbeitung finden Sie im Thema „Adsiedit.msc: ADSI-Bearbeitung" in der Hilfe zu Windows Server 2003.


Vollständige Neuerstellung des Empfängeraktualisierungsdienstes
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert für das Attribut msDS-ReplAttributeMetaData des Empfängeraktualisierungsdienst-Objekts des von Exchange Server verwendeten Konfigurationsdomänencontrollers zu ermitteln. Das Attribut msDS-ReplAttributeMetaData enthält das Datum und die Uhrzeit der letzten Änderung dieses Attributs sowie weitere Informationen. Wenn Exchange Server Analyzer feststellt, dass weniger als fünf Tage seit der im Attribut msDS-ReplAttributeMetaData aufgelisteten Datums- und Uhrzeitangabe vergangen sind, wird eine Warnung angezeigt.

Diese Warnung gibt an, dass vor Kurzem eine vollständige Neuerstellung dieses Empfängeraktualisierungsdiensts geplant wurde. Wenn eine vollständige Neuerstellung konfiguriert wird, wird beim nächsten Start des Empfängeraktualisierungsdiensts, ausgelöst durch den Zeitplan oder den Befehl Jetzt aktualisieren, vom Empfängeraktualisierungsdienst jedes Objekt untersucht und nicht nur nach neuen Objekten abgefragt. Dieser Vorgang nimmt möglicherweise einen längeren Zeitraum in Anspruch und führt u. U. zu Verzögerungen im System.

Wenn eine vollständige Neuerstellung beabsichtigt ist, kann diese Warnung ignoriert werden. Wenn keine vollständige Neuerstellung beabsichtigt ist, kann dieses Problem mithilfe des ADSI-Bearbeitungs-Snap-Ins (AdsiEdit.msc; ADSI - Active Directory Service Interfaces) und dem folgenden Verfahren zum Ändern des Werts für das Attribut msExchDoFullReplication in Active Directory von True in False behoben werden.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So beheben Sie diese Warnung

  1. Suchen Sie mit dem ADSI-Bearbeitungs-Snap-In oder einem vergleichbaren Tool nach dem Attribut msExchDoFullReplication des angegebenen Empfängeraktualisierungsdienst-Objekts. Empfängeraktualisierungsdienst-Objekte befinden sich an folgender Position: CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organisation,CN=Address Lists Container,CN=Recipient Update Services

  2. Klicken Sie mit der rechten Maustaste auf den angegebenen Empfängeraktualisierungsdienst, und wählen Sie dann Eigenschaften aus.

  3. Führen Sie auf der Registerkarte Attribut-Editor einen Bildlauf nach unten durch, und wählen Sie das Attribut msExchDoFullReplication aus.

  4. Klicken Sie zum Bearbeiten dieses Attributs auf Bearbeiten.

  5. Ändern Sie im angezeigten Dialogfeld die Auswahl von True in False, und klicken Sie auf OK.

  6. Klicken Sie erneut auf OK, um die Änderungen zu speichern, und schließen Sie das ADSI-Bearbeitungs-Snap-In.

Weitere Informationen zum Empfängeraktualisierungsdienst finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 253770, „Tasks performed by the Recipient Update Service" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828, „How the Recipient Update Service Populates Address Lists" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838, „XADM: How the Recipient Update Service Applies System Policies" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738, „XADM: How the Recipient Update Service Applies Recipient Policies" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


Der Empfängeraktualisierungsdienst ist für eine vollständige Neuerstellung konfiguriert
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert für das Attribut msExchDoFullReplication von jedem Empfängeraktualisierungsdienst-Objekt in Active Directory zu bestimmen. Wenn Exchange Server Analyzer feststellt, dass der Wert für das Attribut msExchDoFullReplication für jedes Empfängeraktualisierungsdienst-Objekt auf True festgelegt ist, wird eine Warnmeldung angezeigt.

Diese Warnung gibt an, dass der Empfängeraktualisierungsdienst dafür konfiguriert ist, im nächsten Verarbeitungszyklus eine vollständige Neuerstellung auszuführen. Wenn das Attribut msExchDoFullReplication auf True festgelegt ist, überprüft der Empfängeraktualisierungsdienst beim nächsten Start (nach Zeitplan oder über den Befehl Jetzt aktualisieren) jedes einzelne Objekt, statt nur eine Abfrage nach neuen Objekten zu starten. Dieser Vorgang nimmt möglicherweise einen längeren Zeitraum in Anspruch und führt u. U. zu Verzögerungen im System.

Wenn eine vollständige Neuerstellung beabsichtigt ist, kann diese Warnung ignoriert werden. Wenn keine vollständige Neuerstellung beabsichtigt ist, kann dieses Problem mithilfe des ADSI-Bearbeitungs-Snap-Ins (AdsiEdit.msc; ADSI - Active Directory Service Interfaces) und dem folgenden Verfahren zum Ändern des Werts für das Attribut msExchDoFullReplication in Active Directory von True in False behoben werden.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So beheben Sie diese Warnmeldung

  1. Suchen Sie mit dem ADSI-Bearbeitungs-Snap-In oder einem vergleichbaren Tool nach dem Attribut msExchDoFullReplication des angegebenen Empfängeraktualisierungsdienst-Objekts. Empfängeraktualisierungsdienst-Objekte befinden sich an folgender Position: CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organisation,CN=Address Lists Container,CN=Recipient Update Services

  2. Klicken Sie mit der rechten Maustaste auf den angegebenen Empfängeraktualisierungsdienst, und wählen Sie dann Eigenschaften aus.

  3. Führen Sie auf der Registerkarte Attribut-Editor einen Bildlauf nach unten durch, und wählen Sie das Attribut msExchDoFullReplication aus.

  4. Klicken Sie zum Bearbeiten dieses Attributs auf Bearbeiten.

  5. Ändern Sie im angezeigten Dialogfeld die Auswahl von True in False, und klicken Sie auf OK.

  6. Klicken Sie erneut auf OK, um die Änderungen zu speichern, und schließen Sie das ADSI-Bearbeitungs-Snap-In.

Weitere Informationen zum Empfängeraktualisierungsdienst finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 253770, „Tasks performed by the Recipient Update Service" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828, „How the Recipient Update Service Populates Address Lists" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838, „XADM: How the Recipient Update Service Applies System Policies" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738, „XADM: How the Recipient Update Service Applies Recipient Policies" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


Der Empfängeraktualisierungsdienst ist inaktiv
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert für das Attribut activationStyle von jedem Empfängeraktualisierungsdienst-Objekt in Active Directory zu bestimmen. Wenn Exchange Server Analyzer feststellt, dass der Wert für das Attribut activationStyle für jedes Empfängeraktualisierungsdienst-Objekt auf 0 festgelegt ist, wird eine Warnmeldung angezeigt.

Diese Warnmeldung weist darauf hin, dass der Zeitplan für diesen Empfängeraktualisierungsdienst auf Nie festgelegt wurde. Wenn der Zeitplan für einen Empfängeraktualisierungsdienst auf Nie festgelegt wurde, werden keine neuen Objekte verarbeitet.

Wenn Sie dieses Empfängeraktualisierungsdienst-Objekt nicht mehr benötigen, ist es empfehlenswert, das Objekt zu löschen. Wenn Sie dieses Empfängeraktualisierungsdienst-Objekt noch benötigen, ist es empfehlenswert, den Zeitplan des Objekts zu konfigurieren.

So beheben Sie diese Warnung durch Konfigurieren des Zeitplans

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie den Eintrag Empfänger, und wählen Sie dann Empfängeraktualisierungsdienste aus.

  3. Klicken Sie mit der rechten Maustaste auf den Empfängeraktualisierungsdienst, für den der Zeitplan auf Nie festgelegt wurde, und wählen Sie dann Eigenschaften aus.

  4. Wählen Sie in der Liste Aktualisierungsintervall einen vordefinierten Zeitplan aus, oder klicken Sie auf Anpassen, um einen benutzerdefinierten Zeitplan zu erstellen.

  5. Klicken Sie auf OK, um die Änderungen zu speichern.

  6. Klicken Sie mit der rechten Maustaste auf diesen Empfängeraktualisierungsdienst, und wählen Sie Jetzt aktualisieren aus.

Weitere Informationen zum Empfängeraktualisierungsdienst finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 253770, "Tasks Performed by the Recipient Update Service" (http://support.microsoft.com/kb/253770/en-us)

  • 253828, „How the Recipient Update Service Populates Address Lists" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838, „XADM: How the Recipient Update Service Applies System Policies" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738, „XADM: How the Recipient Update Service Applies Recipient Policies" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


Softwareupdate für den Empfängeraktualisierungsdienst erforderlich
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für die Adressbuchansicht und den dynamischen Gruppendienst (abv_dg.dll) zu ermitteln, der auch als Empfängeraktualisierungsdienst bezeichnet wird. Der WMI-Schlüssel Version gibt die Buildnummer für diese Datei an.

Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um den Wert für das Attribut msDS-Behavior-Version des Objekts der NTDS-Einstellungen zu ermitteln. Dieser Wert gibt die Funktionsebene in der Active Directory-Gesamtstruktur an. In der folgenden Tabelle finden Sie gültige Werte für das Attribut msDS-Behavior-Version.

Wert | Funktionsebene in der Gesamtstruktur
0 | Microsoft Windows 2000 Server gemischt
1 | Windows Server™ 2003 interim
2 | Microsoft Windows Server 2003 einheitlich

Wenn Exchange Server Analyzer ermittelt, dass bei einem Exchange-Server in einer Active Directory-Gesamtstruktur im Interims- oder einheitlichen Modus von Windows Server 2003 die Buildnummer für abv_dg.dll unter 6.0.6615.0 liegt, wird ein Fehler angezeigt. Dieser Fehler gibt an, dass eine Exchange 2000 Server-Version des Empfängeraktualisierungsdiensts in einer nicht kompatiblen Gesamtstrukturebene von Windows Server 2003 Active Directory ausgeführt wird. Um dieses Problem zu lösen, ist eine Aktualisierung des Empfängeraktualisierungsdiensts erforderlich.

Wenn Sie zum Aktualisieren der Empfängerobjekte in einer Windows Server 2003-Gesamtstruktur den Empfängeraktualisierungsdienst in Exchange 2000 Server verwenden, aktualisiert der Empfängeraktualisierungsdienst die Objekte nicht richtig. Der Empfängeraktualisierungsdienst erkennt z. B. keine Änderungen der Gruppenmitgliedschaft. Wenn Sie Exchange 2000 Server Active Directory Connector (ADC) verwenden, repliziert ADC möglicherweise die Änderungen der Gruppenmitgliedschaft von Active Directory nicht in das Exchange Server 5.5-Verzeichnis.

So führen Sie ein Upgrade auf die aktuellste Version des Empfängeraktualisierungsdiensts aus

  1. Um das erforderliche Upgrade zu erhalten, folgen Sie den Anweisungen im Microsoft Knowledge Base-Artikel 873059, „The Recipient Update Service does not update objects correctly when Exchange 2000 Server is running in a Windows Server 2003 forest" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=873059.

  2. Wenden Sie das Update an. Der Computer muss nach dem Anwenden dieses Updates nicht neu gestartet werden. Dienste, die im Zusammenhang mit Exchange stehen, werden jedoch nach dem Anwenden dieses Updates automatisch neu gestartet.


Für die Domäne ist keine Instanz des Empfängeraktualisierungsdiensts (RUS) vorhanden.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Microsoft Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um eine Liste der Domänen in der Gesamtstruktur zurückzugeben. Exchange Server Analyzer fragt auch das Attribut msExchangeDomainLink nach einer Liste der vorhandenen Domänen-RUS-Instanzen (Recipient Update Service -Empfängeraktualisierungsdienst) ab. Microsoft Exchange Server Analyzer vergleicht anschließend die Liste der zurückgegebenen Domänen mit der Liste der zurückgegebenen RUS-Instanzen und ermittelt Übereinstimmungen. Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Eine Domäne ist vorhanden.

  • Für diese Domäne ist keine RUS-Instanz vorhanden.

Exchange Server Analyzer zeigt diesen Fehler an, wenn die Domäne durch die Verwendung von DomainPrep vorbereitet wurde, jedoch keine RUS-Instanz für die Domäne vorhanden ist. Eine Nichtübereinstimmung kann dann auftreten, wenn ein Administrator der Gesamtstruktur eine neue Active Directory-Domäne hinzufügt, die Domäne mit DomainPrep für die Verwendung von Exchange vorbereitet, anschließend jedoch vergisst, eine RUS-Instanz für die Domäne hinzuzufügen. Wenn dieses Verhalten auftritt, erhalten neue, in der Domäne erstellte Benutzerobjekte die für sie ausgestellten E-Mail-Nachrichten nicht. Wenn Sie diese Fehlermeldung erhalten, erstellen Sie einen neuen Empfängeraktualisierungsdienst für die Domäne.

So beheben Sie diesen Fehler

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Empfänger.

  3. Klicken Sie mit der rechten Maustaste auf den Knoten Empfängeraktualisierungsdienste, klicken Sie auf Neu, und klicken Sie dann auf Empfängeraktualisierungsdienst.

  4. Klicken Sie im Fenster Neues Objekt auf Durchsuchen, um zum Namen der Domäne zu navigieren.

  5. Wählen Sie den Namen der Domäne aus, und klicken Sie dann auf OK.

  6. Klicken Sie im Fenster Neues Objekt auf Weiter, und klicken Sie anschließend auf Fertig stellen.

Weitere Informationen zum Empfängeraktualisierungsdienst finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 328738, „How the Recipient Update Service Applies Recipient Policies" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828, „How the Recipient Update Service Populates Address Lists" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127, „How to Check the Progress of the Recipient Update Service" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770, „Tasks performed by the Exchange Recipient Update Service" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


Ändern der Replikationsepoche
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob das Attribut ms-DS-ReplicationEpoch des NTDS Settings-Objekts für einen Domänencontroller festgelegt wurde.

Eine Epoche entspricht der Zeitspanne, während der eine Domäne über einen bestimmten Namen verfügt. Eine neue Epoche beginnt mit dem Erstellen einer Domäne oder wenn sich der Domänenname ändert.

Das Attribut ms-DS-ReplicationEpoch wird auf die Epoche angewendet, unter der alle Domänencontroller replizieren. Wenn Exchange Server Analyzer feststellt, dass für dieses Attribut ein Wert festgelegt wurde, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Das Vorhandensein eines Werts für das Attribut ms-DS-ReplicationEpoch zeigt in der Regel an, dass die Domäne, in der sich der betreffende Server befindet, neu benannt wurde. In Microsoft Windows Server™ 2003, Standard Edition, Windows Server 2003, Enterprise Edition und Windows Server 2003, Datacenter Edition können Administratoren Domänen in einer Active Directory-Gesamtstruktur umbenennen, nachdem die Struktur erstellt wurde. Im Betriebssystem Windows® 2000 Server können Administratoren Domänen in einer Active Directory-Gesamtstruktur nicht umbenennen, nachdem die Struktur erstellt wurde.

Die Active Directory-Gesamtstruktur wird von der Erstellungsreihenfolge der Domänen und den hierarchischen Namen dieser Domänen bestimmt. Beginnen Sie mit der Stammdomäne der Gesamtstruktur. Die Distinguished Names und die Standard-DNS-Namen aller untergeordneten Domänen werden vom Stammdomänennamen der Gesamtstruktur abgeleitet. Gehen Sie für jede weitere Ebene in der Gesamtstruktur ebenso vor.

Ändern Sie die hierarchische Struktur einer vorhandenen Domänenstruktur, indem Sie die Domänen umbenennen. Sie können beispielsweise eine untergeordnete Domäne umbenennen, sodass diese über ein anderes übergeordnetes Element verfügt, oder Sie können eine untergeordnete Domäne als neues Strukturelement der Stammdomäne umbenennen. In beiden Beispielen positionieren Sie eine vorhandene Domäne neu, um eine andere Domänenstruktur zu erstellen.

Sie können Domänen auch umbenennen, ohne die Struktur dadurch zu beeinflussen. Wenn Sie beispielsweise eine Stammdomäne umbenennen, ändern Sie die Namen aller dieser Stammdomäne untergeordneten Domänen. Dadurch ändern Sie die Domänenstruktur nicht.

Das Umbenennen von Domänen wird nicht für Gesamtstrukturen unterstützt, die Exchange 2000 Server oder Exchange Server 5.5 enthalten. Die Tools zum Umbenennen von Domänen für Windows Server 2003 wurden dazu entwickelt, Domänen in Active Directory-Gesamtstrukturen umzubenennen, die keine Exchange 2000 Server- oder Exchange Server 5.5-Server enthalten. Für die Tools zum Umbenennen von Domänen für Windows Server 2003 sind diese Beschränkungen aufgrund der folgenden Bedingungen vorhanden:

  • Das Umbenennen einer Domäne hat Auswirkungen auf mehrere Exchange-Attribute.

  • Die Tools zum Umbenennen von Domänen für Windows Server 2003 verfügen nicht über Funktionen zum Korrigieren dieser Attribute.

Das Umbenennen von Domänen wird für Gesamtstrukturen unterstützt, die Exchange Server 2003 enthalten. Das Korrekturprogramm für Exchange-Domänenumbenennungen (XDR-fixup.exe) korrigiert Exchange Server-Attribute nach dem Umbenennen von Domänen, die Exchange 2003 Server-Server enthalten. Sie können das Korrekturprogramm für Exchange-Domänenumbenennungen zusammen mit dem Windows Server 2003-Tool zum Umbenennen von Verzeichnissen (Rendom.exe) verwenden.

Weitere Informationen zum Windows Server 2003-Active Directory-Tool zum Umbenennen von Domänen und zum Downloaden des Tools finden Sie auf der Seite „Windows Server 2003 Active Directory Domain Rename Tools" unter http://go.microsoft.com/fwlink/?LinkId=40992.

Zum Umbenennen einer Domäne müssen Sie das XDR-Korrekturprogramm ausführen. Das XDR-Korrekturprogramm ändert Active Directory-Attribute in Exchange Server so, dass der neue Domänennamen wiedergegeben wird. Das XDR-Korrekturprogramm ersetzt nicht das Windows Server 2003-Tool zum Umbenennen von Domänen. Das XDR-Korrekturprogramm erweitert auch nicht die Funktionalität der Windows Server 2003-Tools zum Umbenennen von Domänen. Sie müssen das XDR-Korrekturprogramm immer ausführen, wenn Sie Rendom.exe ausführen.

Weitere Informationen zum Prozess zum Umbenennen von Domänen und zu den Auswirkungen dieses Prozesses auf Exchange Server finden Sie in den folgenden Tools und Dokumenten:

  • „Windows Server 2003 Active Directory Domain Rename Tools" unter http://go.microsoft.com/fwlink/?LinkId=40992

  • „Understanding How Domain Rename Works" unter http://go.microsoft.com/fwlink/?LinkId=41906

  • „Step-by-Step Guide to Implementing Domain Rename" unter http://go.microsoft.com/fwlink/?LinkId=41359

  • „Exchange Server Domain Rename Fixup" unter http://go.microsoft.com/fwlink/?LinkId=34171

  • „Exchange and Domain Rename Operations" unter http://go.microsoft.com/fwlink/?LinkId=41908


Kopien von Offlineadressbuch, Version 2, wurden nicht gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2007-01-29

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation -Windows®-Verwaltungsinstrumentation) Exchange_Public_Folder ab, um den aktuellen Wert für HasLocalReplica zu bestimmen. Wenn Exchange Server Analyzer feststellt, dass der Wert für HasLocalReplica für die Instanz des Offlineadressbuchs, Version 2, einer Offlineadressliste auf False festgelegt ist, wird ein Fehler angezeigt.

Wenn HasLocalReplica für die Instanz des Offlineadressbuchbooks, Version 2, einer Offlineadressliste auf False festgelegt ist, werden Offlineadresslisten nicht ordnungsgemäß generiert. Demzufolge können Benutzer von Microsoft Outlook® 2002 und früheren Versionen keine Offlineadresslisten downloaden.

Dieses Problem kann auftreten, wenn Sie die Informationsspeicher für Öffentliche Ordner nicht so konfiguriert haben, dass sie Replikate für das Offlineadressbuch, Version 2, enthalten. In der Standardeinstellung wird der Inhalt des Offlineadressbuchs im Informationsspeicher für Öffentliche Ordner des Servers repliziert, auf dem es installiert ist. Wenn der Informationsspeicher für Öffentliche Ordner aus der Replikationskonfiguration des Offlineadressbuchs entfernt wurde, tritt das oben beschriebene Problem auf.

So beheben Sie diesen Fehler

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Administrative Gruppen, und klicken Sie dann auf Ordner.

  3. Klicken Sie mit der rechten Maustaste auf Öffentliche Ordner, und klicken Sie dann auf Systemordner anzeigen.

  4. Klicken Sie auf das Objekt OFFLINEADRESSBUCH, um es zu erweitern.

  5. Klicken Sie unter OFFLINEADRESSBUCH mit der rechten Maustaste auf o=org/cn=addrlists/cn=oabs/cn=Standard-Offlineadressliste, und klicken Sie dann auf Eigenschaften.

  6. Vergewissern Sie sich auf der Registerkarte Replikation, dass im Feld Inhalte in diese Öffentlichen Informationsspeicher replizieren ein Informationsspeicher für Öffentliche Ordner eingegeben ist. Wenn kein Informationsspeicher für Öffentliche Ordner eingegeben ist, klicken Sie auf Hinzufügen, und geben Sie den entsprechenden Informationsspeicher für Öffentliche Ordner für das Offlineadressbuch ein.

  7. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.

  8. Klicken Sie auf o=org/cn=addrlists/cn=oabs/cn=Standard-Offlineadressliste, um den Eintrag zu erweitern.

  9. Klicken Sie unter o=org/cn=addrlists/cn=oabs/cn=Standard-Offlineadressliste mit der rechten Maustaste auf Offlineadressbuch, Version 2, und klicken Sie dann auf Eigenschaften.

  10. Vergewissern Sie sich auf der Registerkarte Replikation, dass im Feld Inhalte in diese Öffentlichen Informationsspeicher replizieren ein Informationsspeicher für Öffentliche Ordner eingegeben ist. Wenn kein Informationsspeicher für Öffentliche Ordner eingegeben ist, klicken Sie auf Hinzufügen, und geben Sie dann den entsprechenden Informationsspeicher für Öffentliche Ordner für das Offlineadressbuch ein.

  11. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.

Weitere Informationen zu diesem Problem finden Sie im Microsoft Knowledge Base-Artikel 286328 „Offline Address Book Is Missing and Cannot Be Generated in Microsoft Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328).

Weitere Informationen zur Offlinegenerierung von Adressenlisten finden Sie unter "Offline Address List Generation Overview" (http://go.microsoft.com/fwlink/?LinkId=82242).

Weitere Informationen zum ordnungsgemäßen Entfernen des ersten Exchange Server 2003-Computers aus einer administrativen Gruppe finden Sie im Microsoft Knowledge Base-Artikel 822931 „Entfernen des ersten Exchange Server 2003-Computers aus der administrativen Gruppe" (http://support.microsoft.com/default.aspx?scid=kb;de;822931).


Kopie von Offlineadressbuch, Version 3a, wurde nicht gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation -Windows®-Verwaltungsinstrumentation) Exchange_Public_Folder ab, um den aktuellen Wert für HasLocalReplica zu bestimmen. Wenn Exchange Server Analyzer feststellt, dass der Wert für HasLocalReplica für die Instanz des Offlineadressbuchs, Version 3a, einer Offlineadressliste auf False festgelegt ist, wird eine Fehlermeldung angezeigt.

Wenn HasLocalReplica für die Instanz des Offlineadressbuchs, Version 3a, für eine Offlineadressliste auf False festgelegt ist, werden Offlineadresslisten nicht ordnungsgemäß generiert. Demzufolge können Benutzer von Microsoft Office Outlook® 2003 keine Offlineadresslisten downloaden.

Dieses Problem kann auftreten, wenn Sie die Informationsspeicher für Öffentliche Ordner nicht so konfiguriert haben, dass sie Kopien für das Offlineadressbuch, Version 3a, enthalten. In der Standardeinstellung wird der Inhalt des Offlineadressbuchs im Informationsspeicher für Öffentliche Ordner des Servers repliziert, auf dem es installiert ist. Wenn der Informationsspeicher für Öffentliche Ordner aus der Replikationskonfiguration des Offlineadressbuchs entfernt wurde, tritt das oben beschriebene Problem auf.

So beheben Sie diesen Fehler

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Administrative Gruppen, und klicken Sie dann auf Ordner.

  3. Klicken Sie mit der rechten Maustaste auf Öffentliche Ordner, und klicken Sie anschließend auf Systemordner anzeigen.

  4. Klicken Sie auf OFFLINEADRESSBUCH, um das Objekt zu erweitern.

  5. Klicken Sie unter OFFLINEADRESSBUCH mit der rechten Maustaste auf o=org/cn=addrlists/cn=oabs/cn=Standard-Offlineadressliste, und klicken Sie dann auf Eigenschaften.

  6. Vergewissern Sie sich auf der Registerkarte Replikation, dass im Feld Inhalte in diese Öffentlichen Informationsspeicher replizieren ein Informationsspeicher für Öffentliche Ordner eingegeben ist. Wenn kein Informationsspeicher für Öffentliche Ordner eingegeben ist, klicken Sie auf Hinzufügen, und geben Sie dann den entsprechenden Informationsspeicher für Öffentliche Ordner für das Offlineadressbuch ein.

  7. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.

  8. Klicken Sie auf o=org/cn=addrlists/cn=oabs/cn=Standard-Offlineadressliste, um den Eintrag zu erweitern.

  9. Klicken Sie unter o=org/cn=addrlists/cn=oabs/cn=Standard-Offlineadressliste mit der rechten Maustaste auf Offlineadressbuch, Version 3a, und klicken Sie dann auf Eigenschaften.

  10. Vergewissern Sie sich auf der Registerkarte Replikation, dass im Feld Inhalte in diese Öffentlichen Informationsspeicher replizieren ein Informationsspeicher für Öffentliche Ordner eingegeben ist. Wenn kein Informationsspeicher für Öffentliche Ordner eingegeben ist, klicken Sie auf Hinzufügen, und geben Sie dann den entsprechenden Informationsspeicher für Öffentliche Ordner für das Offlineadressbuch ein.

  11. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.

Weitere Informationen zu diesem Problem finden Sie im Microsoft Knowledge Base-Artikel 286328 „Offline Address Book Is Missing and Cannot Be Generated in Microsoft Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328).

Weitere Informationen zum ordnungsgemäßen Entfernen des ersten Exchange Server 2003-Computers aus einer administrativen Gruppe finden Sie im Microsoft Knowledge Base-Artikel 822931 „Entfernen des ersten Exchange Server 2003-Computers aus der administrativen Gruppe" (http://support.microsoft.com/default.aspx?scid=kb;de;822931).


Connectorzeitplan für die Verzeichnisreplikation
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, auf welchen Wert das Attribut activationSchedule für jedes ADC-Verbindungsvereinbarungsobjekt (Active Directory Connector) festgelegt ist. Das Attribut activationSchedule entspricht der Häufigkeit, mit der eine ADC-Verbindungsvereinbarung ausgeführt wird. Der Wert 0 gibt an, dass der Replikationszeitplan auf Nie festgelegt ist. Der Wert 1 gibt an, dass der Zeitplan auf Zu ausgewählten Zeiten festgelegt ist. Der Wert 2 gibt an, dass der Zeitplan auf Immer festgelegt ist.

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst außerdem ab, um den Wert des Attributs msExchServer2SearchFilter für jedes ADC-Verbindungsvereinbarungsobjekt zu ermitteln. Das Attribut msExchServer2SearchFilter stellt den Suchfilter dar, der bei der Verzeichnissuche verwendet wird.

Wenn Exchange Server Analyzer feststellt, dass das Attribut activationSchedule auf Zu ausgewählten Zeiten mit einem Replikationsintervall von mehr als 6 Stunden festgelegt ist und das Attribut msExchServer2SearchFilter Empfängerdaten repliziert, wird eine Warnung angezeigt.

Im Allgemeinen empfiehlt es sich, den Replikationszeitplan der Empfängerverbindung auf eine permanente Replikation (Immer) festzulegen. In einigen Fällen kann das Festlegen der Verbindungsvereinbarung auf einen anderen Zeitplan zu Unzustellbarkeitsberichten (Non-Delivery Report, NDR) führen, nachdem Postfächer von Exchange Server 5.5-Standorten zu Exchange 2000 Server oder Exchange Server 2003 verschoben wurden.

So beheben Sie dieses Problem

  1. Öffnen Sie das MMC-Snap-In Active Directory Connector-Dienste.

  2. Öffnen Sie die Verbindungsvereinbarung.

  3. Auf der Seite mit den Eigenschaften der Verbindungsvereinbarung klicken Sie auf Zeitplan, anschließend auf Immer und auf OK.

Weitere Informationen zum Bereitstellen von ADC und zum Konfigurieren von Verbindungsvereinbarungen finden Sie im Bereitstellungshandbuch für Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?displaylang=de&FamilyID=77b6d819-c7b3-42d1-8fbb-fe6339ffa1ed).


Die RID-FSMO-Serverrolle reagiert nicht.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs fSMORoleOwner des RID-Betriebsmasters (Relative ID) im Domänennamenskontext zu bestimmen. Beispielsweise ist in einer Domäne mit dem Namen fSMORoleOwner für den RID-Betriebsmaster ein Attribut von CN=RID Manager$, CN=System, DC=contoso, DC=com. Exchange Server Analyzer versucht dann, eine LDAP-Verbindung (Lightweight Directory Access Protocol) mit dem TCP-Anschluss 389 auf dem Domänencontroller zu öffnen, in der die Rolle aktuell vorhanden ist. Wenn Exchange Server Analyzer keine Verbindung mit dem Domänencontroller herstellen kann, wird ein Fehler angezeigt.

Um sicherzustellen, dass alle Sicherheitsprinzipale einen eindeutigen Bezeichner haben, weist der RID-Master allen Domänencontrollern relative IDs zu. Neue Sicherheitsprinzipalobjekte wie Benutzer, Gruppen oder Computer können auf jedem Domänencontroller erstellt werden. Beim Erstellen eines Sicherheitsprinzipalobjekts fügt der Domänencontroller dem Objekt eine eindeutige SID (Sicherheits-ID) hinzu. Eine Domänen-SID besteht aus vier Elementen, von denen eines die RID für die Domäne ist. Der RID-Betriebsmaster ist für die Verarbeitung der RID-Poolanforderungen aller Domänencontroller in einer bestimmten Domäne verantwortlich. In jeder Domäne kann jeweils nur ein Domänencontroller als RID-Master fungieren.

So beheben Sie diesen Fehler

  1. Überprüfen Sie, ob der im Fehler angegebene Verzeichnisserver online ist und ob andere Exchange-Server in der Organisation Zugriff darauf haben.

  2. Wenn der Verzeichnisserver außer Betrieb gesetzt wurde, weisen Sie die Rolle des RID-Masters einem anderen Domänencontroller zu.

Weitere Informationen zur Übertragung der RID-Betriebsmasterrolle auf einen anderen Domänencontroller finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • Weitere Informationen zu Microsoft Windows Server™ 2003 finden Sie unter „Anzeigen und Übertragen von FSMO-Funktionen in Windows Server 2003" (http://support.microsoft.com/?kbid=324801).

  • Weitere Informationen zu Microsoft Windows® 2000 Server finden Sie in Artikel 255690 „SO WIRD'S GEMACHT: Einsehen und Übertragen von FSMO-Funktionen in der GUI" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Schema-FSMO-Funktion wurde nicht gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Domänencontroller zu bestimmen, der als Schema FSMO (fSMORoleOwner im Schemanamenskontext) angegeben ist. Wenn Exchange Server Analyzer feststellt, dass der im Attribut fSMORoleOwner angegebene Domänencontroller in der Gesamtstruktur nicht vorhanden ist, wird ein Fehler angezeigt.

Das Attribut fSMORoleOwner im Schemanamenskontext (CN=Schema,CN=Configuration,DC=domain,DC=com) definiert den Schemamaster-Domänencontroller für die Gesamtstruktur. Der Schemamaster-Domänencontroller steuert alle Aktualisierungen und Änderungen des Schemas. Um das Schema einer Struktur zu aktualisieren, müssen Sie über Zugriff auf den Schemamaster verfügen. In der Gesamtstruktur darf nur ein Schemamaster vorhanden sein.

Sie müssen einen Schemamaster für die Gesamtstruktur von Active Directory definieren. Das Setup von Exchange 2000 Server und Exchange 2000 Server Service Pack schlägt fehl, wenn ein Schemamaster-Domänencontroller während des Setups nicht online ist (selbst wenn das Schema nicht aktualisiert wird). Wenn der als Domänencontroller aufgeführte Schemamaster offline ist, muss er wieder online geschaltet werden. Dies trifft nicht für Exchange Server 2003 zu. Das Setup von Exchange Server 2003 kontaktiert den Schemamaster nur, wenn festgestellt wird, dass das Schema nicht erweitert wurde.

So beheben Sie diesen Fehler

  1. Überprüfen Sie, ob der designierte Active Directory-Server vorhanden ist.

  2. Wenn der Verzeichnisserver außer Betrieb gesetzt wurde, weisen Sie die Rolle des Schemamasters einem anderen Domänencontroller zu.

Weitere Informationen zum Zuweisen der Schemamasterfunktion an einen anderen Domänencontroller finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 280178, „XADM: Exchange 2000 Installation Requires Access to Schema Master" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=280178)

  • Weitere Informationen zu Microsoft Windows Server™ 2003 finden Sie unter „Anzeigen und Übertragen von FSMO-Funktionen in Windows Server 2003" (http://support.microsoft.com/?kbid=324801).

  • Weitere Informationen zu Microsoft Windows® 2000 Server finden Sie in Artikel 255690 „SO WIRD'S GEMACHT: Einsehen und Übertragen von FSMO-Funktionen in der GUI" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Keine Rückmeldung von Schema-FSMO-Funktion
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs fSMORoleOwner des Schemabetriebsmasters im Schemanamenskontext zu bestimmen. Beispielsweise ist in der Domäne contoso.com fSMORoleOwner für den Schemabetriebsmaster ein Attribut von CN=Schema,CN=System,DC=contoso,DC=com. Exchange Server Analyzer versucht dann, eine LDAP-Verbindung (Lightweight Directory Access Protocol) mit dem TCP-Anschluss 389 auf dem Domänencontroller zu öffnen, in der die Rolle aktuell vorhanden ist. Wenn Exchange Server Analyzer keine Verbindung mit dem Domänencontroller herstellen kann, wird ein Fehler angezeigt.

Der Domänencontroller, der die Rolle des Schemamasters inne hat, ist der einzige Domänencontroller, der Schreibvorgänge im Verzeichnisschema vornehmen kann. Diese Schemaaktualisierungen werden vom Schemamaster in alle anderen Domänencontroller in der gleichen Struktur repliziert. Der Schemamaster hat eine Betriebsmasterrolle für die jeweilige Struktur, da sich unabhängig von der Anzahl der Domänen nur ein Schema in der Struktur befindet. Um das Schema einer Struktur zu aktualisieren, müssen Sie über Zugriff auf dem Schemamaster verfügen. In der Gesamtstruktur darf nur ein Schemamaster vorhanden sein.

So berichtigen Sie diesen Fehler

  1. Überprüfen Sie, ob der im Fehler angegebene Verzeichnisserver online ist und ob andere Exchange-Server in der Organisation Zugriff darauf haben.

  2. Wenn der Verzeichnisserver außer Betrieb gesetzt wurde, weisen Sie die Rolle des Schemamasters einem anderen Domänencontroller zu.

Weitere Informationen zur Übertragung der Schemabetriebsmasterrolle von einem Domänencontroller auf einen anderen Domänencontroller finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • Weitere Informationen zu Microsoft Windows Server™ 2003 finden Sie in Artikel 324801 „Anzeigen und Übertragen von FSMO-Funktionen in Windows Server 2003" unter http://support.microsoft.com/?kbid=324801.

  • Weitere Informationen zu Microsoft Windows® 2000 Server finden Sie in Artikel 255690 „SO WIRD'S GEMACHT: Einsehen und Übertragen von FSMO-Funktionen in der GUI" unter http://support.microsoft.com/?kbid=255690.


Ein SSL-Zertifikat läuft bald ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2007-01-09

Microsoft® Exchange Server Analyzer fragt das Objekt Server Certificate im Exchange Server-System ab, um verschiedene Eigenschaften von X.509-Zertifikaten abzurufen. Fu¨r jedes gefundene SSL-Zertifikat (Secure Sockets Layer) bewertet Exchange Server Analyzer das Attribut ExpirationDate, um das Ablaufdatum des Zertifikats zu bestimmen.

Hinweis:
Ein Server muss u¨ber ein Serverzertifikat verfu¨gen, wenn darauf ein SSL-Protokoll ausgefu¨hrt wird. Das Serverzertifikat entha¨lt den Namen der Website. Der Browser u¨berpru¨ft, ob die Website mit dem eingegebenen Namen u¨bereinstimmt. Beispielsweise muss bei einer Website namens „https://www.example.com" der Name des Zertifikats „www.example.com" lauten.

Exchange Server Analyzer zeigt eine Warnung an, wenn das ExpirationDate zwischen 3 und 20 Tagen in der Zukunft liegt. Exchange Server Analyzer zeigt einen Fehler an, wenn das ExpirationDate weniger als 3 Tage in der Zukunft liegt.

Wenn das Zertifikat abgelaufen ist, schlagen SSL-Verbindungen mit der in diesem Meldung angegebenen URL fehl. Analog schlagen RPC u¨ber HTTP- und Exchange Server ActiveSync-Verbindungen fehl, die diesen URL verwenden.

Um diese/n Zertifikatablaufwarnung bzw. -fehler zu beheben, erneuern Sie das in der Meldung angegebene Zertifikat. Die zur Erneuerung eines Zertifikats erforderlichen Schritte ha¨ngen von der verwendeten Zertifizierungsstelle ab.

Weitere Informationen

Weitere Informationen zu SSL und der Verwendung von Zertifikaten mit virtuellen Servern in Exchange Server finden Sie in den folgenden Exchange-Ressourcen:

  • Informationen zur Verwendung von Zertifikaten mit virtuellen Servern in Exchange Server 2003 finden Sie im Microsoft Knowledge Base-Artikel 823024, „Verwenden von Zertifikaten mit virtuellen Servern in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823024).

  • Informationen zur Verwendung von SSL sowie zum Erhalten und Installieren von Serverzertifikaten finden Sie unter „Konfigurieren von Exchange Server 2003 fu¨r den Clientzugriff" im Handbuch fu¨r den Clientzugriff in Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47568).

  • Informationen zur Verwendung von SSL sowie zum Abrufen und Installieren von Serverzertifikaten für Exchange Server 2007 finden Sie unter "Konfigurieren von SSL für Outlook Anywhere" (http:// go.microsoft.com/fwlink/?LinkId =80875).


Der Servercontainer fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2006-08-21

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs distingushedName für jedes in der aktuellen administrativen Gruppe gefundene Routing Group-Objekt zu ermitteln.

Anschließend fragt Exchange Server Analyzer Active Directory ab, um zu ermitteln, ob die aktuelle administrative Gruppe den Container Server enthält.

Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Die aktuelle administrative Gruppe enthält eine oder mehrere Routinggruppen.

  • Der Container Server ist nicht vorhanden.

Dieser Fehler weist darauf hin, dass in der administrativen Gruppe keine Server installiert sind und dass Routinginformationen möglicherweise nicht ordnungsgemäß zwischen den Servern in der gesamten Exchange-Organisation weitergegeben wurden.

Um diesen Fehler zu beheben, müssen Sie sicherstellen, dass sich die Exchange-Organisation im einheitlichen Modus befinden. Führen Sie dann die folgenden Schritte aus.

Lösungsschritte

  1. Erstellen Sie eine neue administrative Gruppe.

  2. Erstellen Sie in der neuen administrativen Gruppen den neuen Container Routinggruppen.

  3. Ziehen Sie die vorhandenen Routinggruppen aus dem alten Container Routinggruppen in den neuen Container.

  4. Starten Sie alle Exchange-Dienste neu.

Weitere Informationen zu diesem Fehler finden Sie im Microsoft Knowledge Base-Artikel 318491 "XADM: Routinginformationen werden in einer Exchange 2000-Organisation nicht weitergegeben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=318491).


Der Dienstprinzipalname fehlt auf dem globalen Katalogserver
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2006-05-12

Microsoft® Exchange Server Analyzer fragt den globalen Katalogserver des Active Directory ®-Verzeichnisdiensts ab, um die Werte zu ermitteln, die für den vollqualifizierten Domänennamen (Fully Qualified Domain Name, FQDN) und den NetBIOS-Namen des Attributs servicePrincipalName der exchangeAB- und HOST-Ressource zurückgegeben wurden.

Exchange Server Analyzer zeigt einen Fehler an, wenn eine der folgenden Bedingungen erfüllt ist:

  • Dem servicePrincipalName-Attribut für die exchangeAB-Ressource fehlt einer der erwarteten FQDN- oder NetBIOS-Namenswerte.

  • Dem servicePrincipalName-Attribut für die Exchange-Ressource HOST fehlt einer der erwarteten FQDN- oder NetBIOS-Namenswerte.

Ein Dienstprinzipalname (Service Principal Name, SPN) ist ein eindeutiger Name, der eine Instanz eines Diensts identifiziert und dem Anmeldekonto zugeordnet ist, unter dem die Dienstinstanz ausgeführt wird. Kerberos-Authentifizierung ist für Exchange-Dienste nur mit ordnungsgemäß festgelegten SPNs möglich.

  • Wenn bei Clients mit Microsoft Outlook® 2003 oder höher Active Directory-Authentifizierungsprobleme auftreten, können diese darauf hindeuten, dass ein gültiger SPN für die exchangeAB-Ressource fehlt.

  • Authentifizierungsfehler zwischen Servern können darauf hindeuten, dass ein gültiger SPN für die HOST-Ressource fehlt.

Verfahren Sie wie folgt, um dieses Problem zu beheben, indem Sie die fehlenden Wert für das betroffene servicePrincipalName-Attribut hinzufügen.

Fügen Sie mithilfe des Tools SETSPN.exe einen SPN mit den fehlenden Werten hinzu.

  1. Installieren Sie das Tool Setspn.exe. Das Tool Setspn.exe können Sie unter "Windows 2000 Resource Kit Tool: Setspn.exe" (http://go.microsoft.com/fwlink/?LinkId=28103) herunterladen.

    Die Windows Server 2003-Version des Befehlszeilentools Setspn.exe ist in den Windows Server 2003 Support Tools verfügbar, die sich auf der Windows Server 2003-CD befinden. Doppelklicken sie zum Installieren der Server 2003 Support Tools auf die Datei Suptools.msi im Ordner Support/Tools.

  2. Befolgen Sie die Anleitung in der Datei Setspn_d.txt von SETSPN.EXE, um dem Active Directory-Objekt für Ihren Server mit Exchange den fehlenden Wert hinzuzufügen. In dem folgenden Beispiel wird gezeigt, wie für den SPN eines virtuellen SMTP-Servers der FQDN-Wert hinzugefügt wird:

    • Starten Sie eine Eingabeaufforderung, und wechseln Sie in das Verzeichnis, in dem Sie Setspn.exe installiert haben.

    • Geben Sie an der Eingabeaufforderung den folgenden Befehl ein:

      setspn.exe-a SMTPSVC/ mail.IhreDomäne.com IHRSERVERNAME

      Hinweis:
      Ersetzen Sie mail.IhreDomäne.com durch den FQDN Ihres virtuellen SMTP-Servers und IHRSERVERNAME durch den Namen des Servers mit Exchange.
      Drücken Sie dann die EINGABETASTE.


Der Informationsspeicher für Öffentliche Ordner des Servers für Standortordner für diese administrative Gruppe ist in dieser administrativen Gruppe nicht vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des distinguishedName für jeden Informationsspeicher für Öffentliche Ordner zu ermitteln. Zusätzlich fragt Exchange Server Analyzer Active Directory ab, um die Werte der Attribute siteFolderServer und msExchAdminGroupMode für jede administrative Gruppe zu ermitteln. Das Attribut siteFolderServer stellt den Namen des Server dar, der als Host für die Standortordner dient (normalerweise der erste Server am Standort oder in der administrativen Gruppe). Das Attribut msExchAdminGroupMode stellt den Modus für die administrative Gruppe dar, für den es folgende Möglichkeiten gibt:

  • Exchange Server 5.5 pur

  • Exchange Server 5.5, Exchange 2000 Server und Exchange Server 2003 im gemischten Modus

  • Exchange 2000 Server oder Exchange Server 2003 im einheitlichen Modus

Wenn Exchange Server Analyzer ermittlet, dass sich die administrative Gruppe nicht im einheitlichen Modus befindet, und der Wert für den siteFolderServer nicht mit dem Wert des distinguishedName eines Informationsspeichers für Öffentliche Ordner übereinstimmt, und der Attributwert für siteFolderServer nicht die Zeichenfolge DEL: enthält, wird eine Warnung angezeigt.

Als Standard ist der Server für Standortordner der erste Server, der in der administrativen Gruppe installiert wird. Der Informationsspeicher für Öffentliche Ordner auf diesem Server ist der Standard-Speicherort der Frei/Gebucht-Ordner und der Offline-Adressbuchordner für die administrative Gruppe. Wenn Sie den Server für Standortordner außer Betrieb setzen oder entfernen, ohne diese Ordner zu einem anderen Server zu replizieren und diesen Server als Offline-Adressbuchserver zu kennzeichnen, bekommen Outlook-Benutzer Probleme mit dem Offline-Adressbuch und mit Frei/Gebucht-Daten.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Active Directory-Editor, z. B. die ADSI-Bearbeitung.

  2. Suchen Sie den Informationsspeicher für Öffentliche Ordner, den Sie als Server für Standortordner festlegen möchten, und erweitern Sie Folgendes: CN=<PublicFolderStoreName>, CN=<StorageGroupName>, CN=InformationStore, CN=<ServerName>, CN=Servers, CN=<AdministrativeGroupName> ,CN=Administrative Groups, CN=<OrganizationName>, CN=Microsoft Exchange, CN=Services, CN=Configuration,DC=<DomainName>,DC=com.

  3. Klicken Sie im rechten Bereich auf CN=<PublicFolderStoreName>, und wählen Sie Eigenschaften aus.

  4. Führen Sie im Feld Attribute einen Bildlauf nach unten durch, und wählen Sie das Attribut distinguishedName aus.

  5. Klicken Sie auf die Schaltfläche Bearbeiten, und kopieren Sie das gesamte Attribut in die Zwischenablage.

  6. Erweitern Sie den Container Konfiguration und anschließend CN=Administrative Groups,CN=<OrganizationName>,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=<DomainName>,DC=com.

  7. Klicken Sie mit der rechten Maustaste auf die zu ändernde administrative Gruppe, und wählen Sie Eigenschaften aus.

  8. Führen Sie im Feld Attribute einen Bildlauf nach unten durch, und wählen Sie das Attribut siteFolderServer aus.

  9. Klicken Sie auf die Schaltfläche Bearbeiten, und fügen Sie dem Wert für das Attribut distinguishedName in das Feld Wert ein.

  10. Überprüfen Sie den Inhalt des Feldes Wert genau, um sicherzustellen, dass die Einfügung richtig stattgefunden hat, und klicken Sie dann auf OK, um die Änderung zu speichern.

  11. Klicken Sie auf OK, um das Dialogfeld der Eigenschaften der administrativen Gruppe zu schließen.

  12. Beenden Sie die ADSI-Bearbeitung, und starten Sie auf allen Exchange Server-Computern des Standorts den Microsoft Exchange Server-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Weitere Informationen zum Neuerstellen von Systemordnern und Rücksetzen des Servers für Standortordner finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 275171, „XADM: Zurücksetzen von Systemordnern auf einem Exchange 2000 Server" (http://support.microsoft.com/kb/275171/DE/)

  • 284200, „Schedule+ Free/Busy System Folder Is Missing" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=284200).

Weitere Informationen zum Verwenden des LDP-Tools finden Sie im Microsoft Knowledge Base-Artikel 260745 „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Weitere Informationen zum Verwenden der ADSI-Bearbeitung finden Sie im Abschnitt „Adsiedit.msc: ADSI-Bearbeitung" in der Hilfe zu Windows Server 2003.


Der Speicher für Öffentliche Ordner des Servers für Standortordner, der vom Offlineadressbuch verwendet wird, wurde nicht erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2007-02-01

Microsoft® Exchange Server Analyzer Tool fragt den Active® Directory-Verzeichnisdienst ab, um den Wert für das Attribut siteFolderServer in allen Exchange-Informationsspeichern für Öffentliche Ordner zu ermitteln (Informationsspeicher mit einer objectClass aus objectClass=msExchPublicMDB). Das Attribut siteFolderServer stellt den Informationsspeicher für Öffentliche Ordner dar, der für den Offlineadressbuch-Server verwendet wird.

Wenn Exchange Server Analyzer ermittelt, dass der Server nicht aufgeführt ist, inaktiv ist oder nicht vorhanden ist, wird eine Warnung angezeigt. Wenn das Attribut siteFolderServer die Zeichenfolge DEL: enthält, zeigt Exchange Server Analyzer eine Fehlermeldung an.

In der Standardeinstellung erstellt Exchange Server 2003 Offlineadressbuch-Dateien auf dem Server für Standortordner (der erste in der administrativen Gruppe installierte Server). Wenn Sie einen anderen Server als Offlineadressbuch-Server angegeben haben, stellt der in diesem Attribut aufgelistete Informationsspeicher für Öffentliche Ordner den Speicher auf dem neuen Offlineadressbuch-Server dar, und nicht den Speicher auf dem aktuellen Server für Standortordner der administrativen Gruppe.

Wenn Exchange Server 2003 Offlineadressbuch-Dateien erstellt, werden die Dateien an E-Mail-Nachrichten angefügt und in besondere Öffentliche Ordner gestellt. Microsoft Office Outlook® 2003 ruft die Nachrichten aus dem Ordner ab und downloadet die angefügten Dateien.

In Exchange Server 2003 werden die Offline-Adressbuchnachrichten in Unterordnern des Ordners OFFLINEADDRESSBUCH gespeichert, der einen der Systemordner im Standardbaum für Öffentliche Ordner darstellt. Der Ordner verfügt über einen Unterordner für jede administrative Gruppe oder jeden Standort in Ihrer Topologie. In der Standardeinstellung ist ein Inhaltsreplikat einer speziellen administrativen Gruppe auf dem ersten Server gespeichert, der in der administrativen Gruppe installiert wurde (als Server für Standortordner bezeichnet).

Wenn es sich bei Ihrer Exchange-Organisation um Exchange Server 2007 ohne Clients älterer Versionen (Outlook 2003 oder früher) handelt, können Sie diese Warnung oder diesen Fehler ignorieren. Wenn sich in Ihrer Exchange Server 2007-Organisation Clients mit Outlook 2003 oder früher befinden, führen Sie das unten stehende Verfahren aus, um die Verteilung der Offlineadressbuchdateien in Öffentlichen Ordnern zu aktivieren. Bei der Verteilung in Öffentlichen Ordnern handelt es sich um ein Verteilungsverfahren für den Zugriff auf das Offlineadressbuch durch Clients mit Outlook 2003 oder früheren Versionen, die offline oder über eine DFÜ-Verbindung arbeiten.

So beheben Sie diese Warnung in Exchange Server 2003

  1. Wenn Sie wissen, dass der Server nicht vorhanden ist, erweitern Sie in Exchange-System-Manager unter Server den Server, und klicken Sie auf Informationsspeicher für Öffentliche Ordner. Überprüfen Sie den rechten Bereich, um sicherzustellen, dass der Informationsspeicher ausgeführt wird.

  2. Um einen neuen Offlineaddressbuch-Server anzugeben, klicken Sie unter Empfänger auf Offlineadresslisten. Klicken Sie anschließend im rechten Bereich auf Standard-Offlineadressliste (oder auf jede andere Offlineadressenliste, die diese Nachricht erstellt).

    Wenn Sie kein Offlineadressbuch verwenden möchten, klicken Sie mit der rechten Maustaste auf Standard-Offlineadressbuch, und klicken Sie dann auf Löschen. Andernfalls können Sie den restlichen Vorgang zum Festlegen eines Zeitplans verwenden.

  3. Klicken Sie mit der rechten Maustaste auf Standard-Offlineadressliste, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf der Registerkarte Allgemein unter Offlineaddressbuch-Serverauf Durchsuchen, um einen Server auszuwählen.

So beheben Sie diese Warnung in Exchange Server 2007

  1. Öffnen Sie die Exchange-Verwaltungskonsole.

  2. Erweitern Sie Microsoft Exchange, dann Organisationskonfiguration, und wählen Sie Postfach aus.

  3. Klicken Sie im Ergebnisbereich auf die Registerkarte Offlineadressbuch.

  4. Wählen Sie auf der Registerkarte Offlineadressbuch die Option Standard-Offlineadressbuch aus.

    1. Zum Aktivieren der Verteilung des Offlineadressbuchs in Öffentlichen Ordnern wählen Sie auf der Registerkarte Verteilung die Option Verteilung in öffentlichen Ordnern aktivieren.

    2. Klicken Sie auf OK, um die Änderungen zu speichern.

  5. Zum Festlegen eines neuen Offlineadressbuchservers klicken Sie im Aktionsbereich auf Verschieben, um den Assistenten zum Verschieben von Offlineadressbüchern zu starten. Mit diesem Assistenten können Sie die Erstellung von Offlineadressbüchern auf einen anderen Server verlagern. Außerdem werden vorhandene Offlineadressbuchdateien auf den angegebenen Server kopiert.

So verwenden Sie die Exchange-Verwaltungsshell, um die Verteilung von Offlineadressbuchdateien in Öffentlichen Ordnern zu aktivieren

  • Führen Sie den folgenden Befehl aus:

    Code kopieren
    Set-OfflineAddressBook -Identity <OAB> -PublicFolderDistributionEnabled $true

    Dabei gilt Folgendes: <OAB> gibt den DN (Distinguished Name), den Domänen-\Kontonamen oder die GUID des Offlineadressbuchs an.

    Zum Aktivieren der Verteilung des Standardofflineadressbuchs in Öffentlichen Ordnern geben Sie z. B. Folgendes ein:
Code kopieren
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -PublicFolderDistributionEnabled $true

So verwenden Sie die Exchange-Verwaltungsshell zum Festlegen des Servers, auf dem das Offlineadressbuch erstellt wird

  • Führen Sie den folgenden Befehl aus:

    Code kopieren
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    Dabei gilt Folgendes: <OAB> gibt den DN (Distinguished Name), den Domänen-\Kontonamen oder die GUID des Offlineadressbuchs an, und <Server> gibt den Exchange-Server an, auf dem die ausgewählte Aktion durchgeführt wird.

    Zum Verlagern der Erstellung von Offlineadressbüchern auf SERVER01, geben Sie z. B. Folgendes ein:
Code kopieren
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Weitere Informationen zum Verwenden von Offlineadressbüchern in Exchange Server 2003 finden Sie in Arbeiten mit dem Exchange Server 2003-Informationsspeicher (http://go.microsoft.com/fwlink/?LinkId=47595) unter „Konfigurieren der Offlineadressbücher von Exchange Server 2003".

Weitere Informationen zum Verwenden von Offlineadressbüchern in Exchange Server 2007 finden Sie in unter „Organisationskonfiguration > Postfach > Offlineadressbücher" (http:// go.microsoft.com/fwlink/?LinkId =79247).


„SiteName" ist hartcodiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob der Registrierungswert SiteName auf dem Exchange-Server vorhanden ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netlogon\Parameters\SiteName

Wenn Exchange Server Analyzer feststellt, dass der Registrierungswert SiteName vorhanden ist, wird eine Warnung angezeigt.

Diese Warnung gibt an, dass die Standortmitgliedschaft des Active Directory®-Verzeichnisdiensts auf diesem Microsoft Windows®-Computer hartcodiert wurde. Diese Konfiguration wird für Exchange Server nicht empfohlen.

Wenn Sie einen Windows-Standort hartcodieren, können dadurch Fehler im Microsoft Exchange-Systemaufsichtsdienst und allgemeine Exchange Server-Fehler verursacht werden. Sie sollten möglicherweise den Registrierungswert SiteName entfernen. Wenn Sie den Registrierungswert SiteName entfernen, wird der Standort von Windows automatisch auf den entsprechenden Active Directory-Standort verlegt.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So entfernen Sie den Registrierungswert „SiteName"

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\Netlogon\Parameters

  3. Suchen Sie im rechten Bereich den Registrierungswert SiteName, und löschen Sie ihn.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den Server neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zum Registrierungswert SiteName finden Sie im Knowledge Base-Artikel 322834 „XADM: Event 1005, System Attendant Does Not Start" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322834.


In der Exchange-Organisation befinden sich mehr als 900 administrative Gruppen.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2006-04-21

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um die Anzahl der administrativen Gruppen in einer Exchange-Organisation festzustellen. Stellt Exchange Server Analyzer dabei fest, dass die Anzahl der administrativen Gruppen 900 übersteigt, wird eine Warnmeldung anzeigt.

Es wird empfohlen, maximal 900 Instanzen pro Exchange-Objekttyp zu verwenden. Diese Empfehlung beruht darauf, dass die maximal zurückgegebene Seitengröße pro Anforderung in Active Directory in der Standardeinstellung 1.000 beträgt. Das heißt, dass bei einer gesendeten LDAP-Anforderung (Lightweight Directory Access Protocol) für ein Objekt und mehr als 1.000 vorhandenen Instanzen des betreffenden Objekts in Active Directory keine Ergebnisse zurückgegeben werden, da die maximale Seitengröße überschritten wurde.

Für Exchange Server ist bei einer Reihe von Prozessen das Erstellen von Instanzen für bestimmte Objekttypen erforderlich. Exchange-System-Manager sendet beispielsweise eine LDAP-Anforderung an Active Directory, um eine Listenansicht aller administrativen Gruppen innerhalb einer Exchange-Organisation zu erstellen. Bei mehr als 1.000 administrativen Gruppen wird Active Directory keine Ergebnisse zurückgeben. Im Exchange-System-Manager wird stattdessen lediglich ein Fehler angezeigt.

Die maximale Seitengröße für Active Directory kann zwar vergrößert werden, dies wird jedoch für Exchange Server nicht empfohlen und nicht unterstützt. In Exchange-Umgebungen, in denen der Wert für die maximale Seitengröße heraufgesetzt wurde, waren ein ungewöhnliches Verhalten und Fehler zu beobachten.

Zwar wird empfohlen, für einen einzigen Objekttyp in Exchange Server einen Höchstwert von 900 einzuhalten, es werden jedoch bis zu 1.000 Objekttypen unterstützt.

Um dieses Problem zu beheben, können Sie die administrativen Gruppen konsolidieren.

Weitere Informationen über das Konsolidieren von Exchange-Standorten und administrativen Gruppen finden Sie in folgenden Dokumenten:

  • Deploying a Worldwide Site Consolidation Solution for Exchange Server 2003 at Microsoft (http://go.microsoft.com/fwlink/?LinkId=33531)


In der Exchange-Organisation befinden sich mehr als 900 Exchange-Server.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2006-03-30

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um die Zahl der im Verzeichnis enthaltenen Objekte zu ermitteln, die eine objectCategory von msExchExchangeServer aufweisen. Die Zahl stellt die Anzahl der in Active Directory gefundenen Exchange Server-Computer dar. Wenn Exchange Server Analyzer dabei mehr als 900 Exchange Server-Computer findet, wird eine Warnmeldung anzeigt.

Es empfiehlt sich, für einen einzigen Exchange-Objekttyp maximal 900 Instanzen zu verwenden. Dies ist darauf zurückzuführen, dass die maximal zurückgegebene Seitengröße pro Anforderung in Active Directory in der Standardeinstellung 1.000 beträgt. Das heißt, dass bei einer gesendeten LDAP-Anforderung (Lightweight Directory Access Protocol) für ein Objekt und mehr als 1.000 vorhandenen Instanzen des betreffenden Objekts in Active Directory keine Ergebnisse zurückgegeben werden, da die maximale Seitengröße überschritten wurde.

Für Exchange Server erfordert eine Reihe von Prozessen das Erstellen von Instanzen für bestimmte Objekttypen. Der Exchange-System-Manager sendet beispielsweise eine LDAP-Anforderung an Active Directory, um eine Listenansicht aller Exchange-Server innerhalb der Exchange-Organisation zu erstellen. Bei mehr als 1.000 Exchange-Servern gibt Active Directory keine Ergebnisse zurück. Im Exchange-System-Manager wird daher ein Fehler, jedoch keine Exchange Server-Computer angezeigt.

Die maximale Seitengröße für Active Directory kann zwar vergrößert werden, doch wird dies für Exchange nicht empfohlen und nicht unterstützt. In Exchange-Umgebungen, in denen der Wert für die maximale Seitengröße heraufgesetzt wurde, waren ein ungewöhnliches Verhalten und Fehler zu beobachten.

Zwar wird empfohlen, für jeden einzelnen Objekttyp in Exchange Server einen Höchstwert von 900 einzuhalten, doch werden bis zu 1.000 Objekttypen unterstützt.

So beheben Sie diese Warnmeldung

  1. Sie können die Exchange-Server in Ihrer Organisation konsolidieren.

  2. Durchsuchen Sie Active Directory nach verwaisten Exchange Server-Computern, und entfernen Sie diese aus Active Directory.

Weitere Informationen zum Konsolidieren von Computern mit Exchange Server finden Sie unter „Server Consolidation Using Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=47586).


Auf der Organisationsebene sind mehr als zehn Administratoren zugewiesen
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2006-12-03

Microsoft® Exchange Server Analyzer sendet Abfragen an den Active Directory®-Verzeichnisdienst, um die Anzahl der Benutzer zu bestimmen, die über Berechtigungen als Exchange-Administrator oder über vollständige Berechtigungen verfügen. Exchange Server Analyzer zählt die Einträge, die im Attribut msExchAdmins aufgelistet sind. Dieses stellt eine Verknüpfung zu allen Exchange-Administratoren innerhalb der Organisation zusammen mit den entsprechenden Berechtigungen dar. Wenn Exchange Server Analyzer feststellt, dass mehr als 10 Benutzer mit Berechtigungen als Exchange-Administrator oder mit vollständigen Berechtigungen ausgestattet sind, wird eine Warnung angezeigt.

msExchAdmins ist ein Attribut mit mehreren Werten des Containers der Exchange-Stammorganisation. Es enthält eine Liste von Sicherheits-IDs (SIDs), die die Benutzerkonten mit delegierten Exchange-Berechtigungen darstellen.

Es hat sich bewährt, die Anzahl der Benutzer mit Schreibzugriff auf die Exchange-Organisation zu beschränken. Ziehen Sie auch in Betracht, die Anzahl der Exchange-Administratoren und der Exchange-Administratoren mit vollständigen Berechtigungen auf der Organisationsebene zu reduzieren. Wenn Sie Administratorfunktionen mit den Anforderungen Ihrer Meldungsinfrastruktur vergleichen, stellen Sie möglicherweise fest, dass Sie viele dieser Benutzer in Exchange-Administratoren mit reiner Ansichtberechtigung auf der Organisationsebene umwandeln können, indem Sie ihnen auf der Verwaltungsgruppenebene die Funktion eines Exchange-Administrators zuweisen.

So beheben Sie diese Warnmeldung

  1. Ziehen Sie in Betracht, die Anzahl der Benutzer zu verringern, die über Berechtigungen als Exchange-Administrator oder über vollständige Berechtigungen verfügen.

  2. Überprüfen Sie in Ihrer Organisation ggf. die Exchange Server-Berechtigungen, um sicherzustellen, dass diese angemessen sind.

Weitere Informationen zum Planen und Konfigurieren von Berechtigungen in Exchange finden Sie unter:

  • "Arbeiten mit Active Directory-Berechtigungen in Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=47592).

  • Microsoft Exchange Server 2007, Operationen, "Konfigurieren von Berechtigungen" (http://go.microsoft.com/fwlink/?LinkId=78432).

  • Microsoft Exchange Server 2007, Planung und Architektur, Planen von Active Directory "Überlegungen zu Berechtigungen" (http://go.microsoft.com/fwlink/?LinkId=78433).

Weitere Informationen zu Administratorfunktionen in Exchange Server 2003 finden Sie im Microsoft Knowledge Base-Artikel 823018 „Overview of Exchange Administrative Role Permissions in Exchange 2003" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823018.

Weitere Informationen über Administratorfunktionen in Exchange 2000 Server finden Sie im Knowledge Base-Artikel 289811 „XGEN: Exchange 2000 Role Permissions" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=289811.


Diese Verbindungsvereinbarung kann bei einer Diskrepanz keine deaktivierten Kontos erstellen.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchServer1AlwaysCreateAs für jedes Verbindungsvereinbarungsobjekt zu bestimmen. Wenn Exchange Server Analyzer feststellt, dass das Attribut msExchServer1AlwaysCreateAs nicht auf 1 festgelegt ist, wird eine Warnung angezeigt.

Das Attribut msExchServer1AlwaysCreateAs legt fest, wie X.500-Objekte mit Active Directory synchronisiert werden. Der Wert 0 zeigt an, dass die Verbindungsvereinbarung konfiguriert wurde, um Microsoft Windows®-Kontakte zu erstellen. Der Wert 1 für dieses Attribut zeigt an, dass die Verbindungsvereinbarung konfiguriert wurde, um deaktivierte Windows-Benutzerkonten in Active Directory zu erstellen. Der Wert 2 zeigt an, dass die Verbindungsvereinbarung konfiguriert wurde, um neue Windows-Benutzerkonten zu erstellen.

Microsoft Exchange Server Analyzer löst eine Warnung aus, da es in einer Situation, in der Exchange Server 5.5 und Active Directory gleichzeitig installiert sein müssen und in der eine volle Migration zu Exchange Server 2003 geplant ist, wichtig ist, dass ADC (Active Directory Connector) deaktivierte Windows-Benutzerkonten erstellt. Diese deaktivierten Windows-Benutzerkonten sind postfachaktiviert, was bedeutet, dass sie logisch an ein Postfach auf dem Exchange Server 5.5-Computer angehängt sind. Das Erstellen deaktivierter Windows-Benutzerkonten ist notwendig, damit das Benutzerobjekt, das dieses deaktivierte Windows-Konto darstellt, schließlich Zugriff auf öffentliche Ordner und andere gesicherte Objekte in Active Directory erhält.

In der ADC-Benutzeroberfläche gibt es drei Optionen zum Erstellen neuer Objekte für den Fall, dass in Active Directory kein passendes Objekt für ein Postfach in Exchange Server 5.5 gefunden wird. Diese sind auf der Registerkarte Erweitert bei den Eigenschaften der Verbindungsvereinbarung wie folgt aufgelistet:

  • Windows-Kontakt erstellen Dies wird nicht empfohlen, da ein Objekt vom Typ Kontakt keinen Sicherheitskontext enthält.

  • Neues Windows-Benutzerkonto erstellen Dies wird nicht empfohlen, da das neu erstellte Konto eine neue Sicherheits-ID bekommt und daher der SID-Verlauf eines Microsoft Windows NT® Server 4.0-Benutzerkontos während der Migration nicht in dieses neue Konto übernommen wird (weil die SIDs verschieden sind).

  • Deaktiviertes Benutzerkonto erstellen Dies wird empfohlen, da Windows NT Server 4.0-Benutzer (mit dem korrekten Ressourcenzugriff) weiter bestehen können, bis die Migration vollständig abgeschlossen ist.

So beheben Sie diese Warnmeldung

  1. Konfigurieren Sie die Active Directory-Empfängerverbindungsvereinbarung, um postfachaktivierte deaktivierte Windows-Benutzerkonten zu erstellen.

  2. Verwenden Sie das Tool Active Directory Migration, mit dem Windows NT Server 4.0-Benutzerkonten nach Active Directory migriert und aktivierte Windows-Konten erstellt werden. Diese aktivierten Windows-Konten haben dieselbe SID wie die von ADC erstellten deaktivierten Windows-Konten.

  3. Verwenden Sie den Assistenten für die Active Directory-Kontenbereinigung (ADClean), der die Informationen aus dem vom Tool Active Directory Migration erstellten Konto in das durch ADC erstellte Konto integriert.

Weitere Informationen über Active Directory Connector-Empfängerverbindungsvereinbarungen finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 823601, „Anforderungen und Auswirkungen von Active Directory Connector innerhalb eines Netzwerks" unter http://support.microsoft.com/default.aspx?scid=kb;de;823601

  • 303180, „Active Directory Connector Connection Agreement Requirements for Mixed Administrative Groups" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180

  • 296260, „XGEN: How to Configure a Two-Way Recipient Connection Agreement for Exchange 5.5 Users" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=296260.

  • Weitere Informationen zum Assistenten für die Active Directory-Kontenbereinigung finden Sie im folgenden Knowledge Base-Artikel:

  • 270652 „Possible Uses of the Active Directory Account Cleanup Wizard" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=270652.

  • Weitere Informationen zum Tool Active Directory Migration finden Sie im folgenden Knowledge Base-Artikel:

  • 260871, „SO WIRD'S GEMACHT: Einrichten von ADMT für die Migration von Windows NT 4.0 nach Windows 2000" unter http://support.microsoft.com/default.aspx?scid=kb;de;260871.


Dies ist eine Exchange-Verbindungsvereinbarung in eine Richtung.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer sendet eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert des Attributs msExchSynchronizationDirection für jedes Verbindungsvereinbarungsobjekt zu ermitteln. Das Attribut msExchSynchronizationDirection stellt die Richtung dar, in der die Verzeichnisse synchronisiert werden. Wenn dieses Attribut auf 2 festgelegt ist, wird eine Warnung angezeigt.

Das Attribut msExchSynchronizationDirection kann den Wert 0 oder 2 annehmen. Ein Wert 0 für das Attribut zeigt eine bidirektionale Verbindungsvereinbarung an. Hat das Attribut den Wert 2, handelt es sich um eine unidirektionale Verbindungsvereinbarung vom Exchange Server-Computer.

Als optimale Methode wird empfohlen, dass Sie bidirektionale Verbindungsvereinbarungen verwenden. Exchange-Umgebungen im gemischten Modus (in denen Exchange Server 5.5 zusammen mit Exchange 2000 Server und/oder Exchange Server 2003 betrieben wird) erfordern eine bidirektionale Verbindungsvereinbarung.

So beheben Sie diese Warnmeldung

  1. Entfernen Sie die vorhandene Vereinbarung über Verbindungen in eine Richtung.

  2. Erstellen Sie als Ersatz eine Vereinbarung über Verbindungen in beide Richtungen.

Weitere Informationen zu ADC-Verbindungsvereinbarungen (Active Directory Connector) finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 823601, „Anforderungen und Auswirkungen von Active Directory Connector innerhalb eines Netzwerks" unter http://support.microsoft.com/default.aspx?scid=kb;de;823601

  • 303180, „Active Directory Connector Connection Agreement Requirements for Mixed Administrative Groups" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180

  • 317721, „XADM: Exchange Server 5.5 Mailbox Owner Rights Are Removed When You Change the ADC Connection Agreement from a One-Way Connection Agreement to a Two-Way Connection Agreement" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721


Dies ist eine Windows-Verbindungsvereinbarung in eine Richtung.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer sendet eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert des Attributs msExchSynchronizationDirection für jedes Verbindungsvereinbarungsobjekt zu ermitteln. Das Attribut msExchSynchronizationDirection stellt die Richtung dar, in der die Verzeichnisse synchronisiert werden. Wenn dieses Attribut auf 1 festgelegt ist, wird eine Warnung angezeigt.

Das Attribut msExchSynchronizationDirection kann einen Wert von 0, 1 oder 2 aufweisen. Ein Wert von 0 gibt eine Vereinbarung über eine Verbindung in zwei Richtungen an, ein Wert von 1 gibt eine Verbindung in eine Richtung von Active Directory an, und ein Wert von 2 gibt eine Vereinbarung über eine Verbindung in eine Richtung vom Exchange Server-Computer an.

Es wird als optimale Methode empfohlen, Vereinbarungen über Verbindungen in zwei Richtungen zu verwenden. Exchange-Umgebungen im gemischten Modus (in denen Exchange Server 5.5 zusammen mit Exchange 2000 Server und/oder Exchange Server 2003 betrieben wird) erfordern eine Vereinbarung über Verbindungen in zwei Richtungen.

So beheben Sie diese Warnmeldung

  1. Entfernen Sie die vorhandene Vereinbarung über Verbindungen in eine Richtung.

  2. Erstellen Sie als Ersatz eine Vereinbarung über Verbindungen in beide Richtungen.

Weitere Informationen zu ADC-Verbindungsvereinbarungen (Active Directory Connector) finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 823601, „Anforderungen und Auswirkungen von Active Directory Connector innerhalb eines Netzwerks" unter http://support.microsoft.com/default.aspx?scid=kb;de;823601

  • 303180, „Active Directory Connector Connection Agreement Requirements for Mixed Administrative Groups" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180

  • 317721, „XADM: Exchange Server 5.5 Mailbox Owner Rights Are Removed When You Change the ADC Connection Agreement from a One-Way Connection Agreement to a Two-Way Connection Agreement" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721


Zeitstempelvergleich zwischen Exchange und Active Directory ergibt eine Abweichung von mehr als 5 Minuten
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_UTCTime ab, um das Datum und die Uhrzeit für jeden Exchange-Server zu bestimmen. Microsoft Exchange Server Analyzer ruft außerdem das aktuelle Datum und die aktuelle Uhrzeit des Standarddomänencontrollers ab. Wenn Microsoft Exchange Server Analyzer eine Abweichung von 5 Minuten oder mehr zwischen den beiden Servern feststellt, wird ein Fehler angezeigt.

In Microsoft Windows 2000 Server und Windows Server™ 2003 werden Datum und Uhrzeit auf Computern in einem Windows-Netzwerk mit dem Windows-Zeitdienst synchronisiert. Das Synchronisieren der Uhrzeit ist in Windows 2000 Server und Windows Server 2003 von entscheidender Bedeutung, weil das Standardauthentifizierungsprotokoll beim Erstellen des Authentifizierungstickets auf die Uhrzeit auf den Computern zurückgreift. Als Standardauthentifizierungsprotokoll wird MIT Kerberos, Version 5, verwendet.

Auf allen Windows-Servern in einer Active Directory®-Verzeichnisdienstdomäne konfiguriert sich der Windows-Zeitdienst automatisch und verwendet hierfür den auf den Domänencontrollern verfügbaren Windows-Zeitdienst. Der Windows-Zeitdienst konfiguriert einen Domänencontroller in der eigenen Domäne als zuverlässige Quelle für die Uhrzeit und synchronisiert sich selbst in regelmäßigen Abständen mit dieser Quelle.

Synchronisieren Sie zum Beheben dieses Fehlers die Uhr auf dem Exchange-Server mit dem Verzeichnisserver.

So synchronisieren Sie die Uhr auf einem Server in einer Active Directory-Domäne

  1. Öffnen Sie eine Eingabeaufforderung.

  2. Geben Sie w32tm /resync ein, und drücken Sie dann die EINGABETASTE.

Wenn der Fehler weiterhin besteht oder dieser Fehler auf vielen Computern in der Organisation ausgegeben wird, müssen Sie überprüfen, ob der Windows-Zeitdienst in der Active Directory-Gesamtstruktur bereitgestellt und konfiguriert wurde. Weitere Informationen über den Windows-Zeitdienst finden Sie unter http://go.microsoft.com/fwlink/?LinkId=40648 im Abschnitt „Windows Time Service Technical Reference".

Wenn Exchange-Front-End-Server nicht mit der Active Directory-Zeit synchronisiert sind, erhalten Clients u. U. Fehlermeldungen vom Typ „HTTP 500 . interner Serverfehler", wenn sie versuchen, Verbindung mit Microsoft Office Outlook® Web Access herzustellen. Weitere Informationen zu dieser Situation finden Sie im Microsoft Knowledge Base-Artikel 841546 „Known issues that cause the 'HTTP 500 internal server error' error message in Exchange 2000 Outlook Web Access" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841546.


Zeitstempelvergleich zwischen dem Active Directory Connector-Server und Active Directory ergibt eine Abweichung von mehr als 5 Minuten
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_UTCTime ab, um das Datum und die Uhrzeit für die einzelnen ADC-Server (Active Directory Connector) zu bestimmen. Microsoft Exchange Server Analyzer ruft außerdem das aktuelle Datum und die aktuelle Uhrzeit des Standarddomänencontrollers ab. Wenn Microsoft Exchange Server Analyzer eine Abweichung von 5 Minuten oder mehr zwischen den beiden Servern feststellt, wird ein Fehler angezeigt.

In Microsoft Windows 2000 Server und Windows Server™ 2003 werden Datum und Uhrzeit auf Computern in einem Windows-Netzwerk mit dem Windows-Zeitdienst synchronisiert. Das Synchronisieren der Uhrzeit ist in Windows 2000 Server und Windows Server 2003 von entscheidender Bedeutung, weil das Standardauthentifizierungsprotokoll beim Erstellen des Authentifizierungstickets auf die Uhrzeit auf den Computern zurückgreift. Als Standardauthentifizierungsprotokoll wird MIT Kerberos, Version 5, verwendet.

Auf allen Windows-Servern in einer Active Directory®-Verzeichnisdienstdomäne konfiguriert sich der Windows-Zeitdienst automatisch und verwendet hierfür den auf den Domänencontrollern verfügbaren Windows-Zeitdienst. Der Windows-Zeitdienst konfiguriert einen Domänencontroller in der eigenen Domäne als zuverlässige Quelle für die Uhrzeit und synchronisiert sich selbst in regelmäßigen Abständen mit dieser Quelle.

Synchronisieren Sie zum Beheben dieses Fehlers die Uhr auf dem ADC-Server mit dem Verzeichnisserver.

So synchronisieren Sie die Uhr auf einem Server in einer Windows 2000 Server- oder Windows Server 2003-Domäne

  1. Öffnen Sie eine Eingabeaufforderung.

  2. Geben Sie w32tm /resync ein, und drücken Sie dann die EINGABETASTE.

Wenn der Fehler weiterhin besteht oder dieser Fehler auf vielen Computern in der Organisation ausgegeben wird, müssen Sie überprüfen, ob der Windows-Zeitdienst in der Active Directory-Gesamtstruktur bereitgestellt und konfiguriert wurde. Weitere Informationen über den Windows-Zeitdienst finden Sie unter http://go.microsoft.com/fwlink/?LinkId=40648 im Abschnitt „Windows Time Service Technical Reference".


Unter Windows Server 2003 wird nicht der neueste freigegebene Build ausgeführt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_OperatingSystem ab, um den Wert des Schlüssels Version für ADC-Server (Active Directory Connector) in der Exchange-Organisation zu bestimmen. Exchange Server Analyzer untersucht auch den folgenden Registrierungseintrag, um die Windows-Version zu bestimmen, die auf den ADC-Servern ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Wenn Exchange Server Analyzer feststellt, dass der Wert für die zweite Instanz von CurrentVersion 5.2 beträgt und der Wert Version ungleich 5.2.3790 ist, wird ein Fehler angezeigt.

Der Wert 5.2 für CurrentVersion gibt an, dass auf dem Computer ein Windows Server 2003-Betriebssystem ausgeführt wird. Der Wert Version für die veröffentlichte Version aller Betriebssysteme von Windows Server 2003 ist 5.2.3790. Jeder andere Wert für den Schlüssel Version gibt an, dass eine Vorabversion von Windows Server 2003 verwendet wird.

Wenn Sie nicht an einem Technology Adoption Program (TAP) oder einem ähnlichen von Microsoft geförderten Programm beteiligt sind, rät Microsoft vom Einsatz von Software einer Vorabversion in Produktionsumgebungen ab und gewährt keinen Support für einen solchen Einsatz.

So berichtigen Sie diesen Fehler

  1. Aktualisieren Sie alle Server der Exchange-Infrastruktur, einschließlich Domänencontroller, globaler Katalogserver, ADC-Server und Exchange Server-Computer auf die Software der aktuell veröffentlichten Version.

  2. Wenn die Option zum Aktualisieren verfügbar ist bzw. unterstützt wird, installieren Sie das Betriebssystem neu, und stellen Sie die Einstellungen und Daten von Exchange Server wieder her.

Aktualisieren Sie alle Server der Exchange-Infrastruktur, einschließlich Domänencontroller, globaler Katalogserver, ADC-Server und Exchange Server-Computer auf die Software der aktuell veröffentlichten Version.

Weitere Informationen zu Softwareaktualisierungen für Windows Server 2003 finden Sie auf der Website „Windows Server 2003 Software Updates" (http://go.microsoft.com/fwlink/?LinkId=33760).


Auf Windows Server 2003 wird vorab veröffentlichte Software ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_OperatingSystem ab, um den Wert für den Schlüssel ServicePackMajorVersion zu bestimmen. Exchange Server Analyzer untersucht auch den folgenden Registrierungseintrag, um die Windows-Version zu ermitteln, die auf dem Zielcomputer ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Wenn der Wert für die zweite Instanz von CurrentVersion 5.2 beträgt und wenn der Wert von ServicePackMajorVersion größer als 1 ist, wird von Exchange Server Analyzer eine Warnmeldung angezeigt.

Der Wert 5.2 für CurrentVersion gibt an, dass auf dem Computer ein Microsoft Windows Server™ 2003-Betriebssystem ausgeführt wird. Ein Wert größer als 1 für ServicePackMajorVersion gibt an, dass ein Service Pack höher als Service Pack 1 installiert ist. Da SP1 das einzige für Windows Server 2003 veröffentlichte Service Pack ist, handelt es sich bei Windows Server 2003 Service Pack 2 oder höher in jedem Fall um Software einer Vorabversion.

Wenn Sie nicht an einem Technology Adoption Program (TAP) oder einem ähnlichen, von Microsoft gesponserten Programm beteiligt sind, wird empfohlen, vorab veröffentlichte Software nicht in Produktionsumgebungen auszuführen.

So beheben Sie diese Warnung

  1. Deinstallieren Sie sämtliche installierte vorab veröffentlichte Software.

  2. Wenn die Option zum Deinstallieren verfügbar ist, erstellen Sie das Betriebssystem neu, und stellen Sie die Einstellungen und Daten von Exchange Server wieder her.

Weitere Informationen zu Softwareaktualisierungen für Windows Server 2003 finden Sie auf der Website „Windows Server 2003 Software Updates" (http://go.microsoft.com/fwlink/?LinkId=33760).


Windows 2000 Server führt Service Pack 4 nicht aus
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_OperatingSystem ab, um den Wert für den Schlüssel ServicePackMajorVersion zu bestimmen. Exchange Server Analyzer überprüft außerdem den folgenden Registrierungseintrag, um die auf dem Zielcomputer ausgeführte Version von Windows zu ermitteln:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Wenn Exchange Server Analyzer ermittelt, dass im Zielsystem ein Windows 2000 Server-Betriebssystem ausgeführt wird, jedoch nicht Service Pack 4 für Windows 2000 Server, wird eine Warnung angezeigt.

Als beste Vorgehensweise wird empfohlen, dass Sie die neuesten Service Packs für die gesamte Software in Ihrer Exchange-Bereitstellung installieren.

So beheben Sie diese Warnmeldung

  1. Aktualisieren Sie alle Domänen-Controller und globalen Katalogserver, auf denen ein Windows 2000 Server-Betriebssystem ausgeführt wird, auf Service Pack 4 sowie die neuesten Hotfixes und Updates von Windows Update.

  2. Aktualisieren Sie alle Exchange Server-Computer mit dem neuesten Service Pack und Updaterollup.

Weitere Informationen zum Erwerb und zur Installation von Service Packs für Windows 2000 Server-Betriebssysteme finden Sie auf der Website „Windows 2000 Service Packs" (http://go.microsoft.com/fwlink/?linkid=18353).

Weitere Informationen zum Erwerb und zur Installation von Service Packs und Rollups für Exchange Server finden Sie auf der Website für Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=21573).


Auf dem Windows 2000 Server wird nicht der neueste veröffentlichte Build ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2005-11-17

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_OperatingSystem ab, um den Wert für den Schlüssel Version zu bestimmen.

Exchange Server Analyzer überprüft auch den folgenden Registrierungseintrag, um die Windows-Version zu bestimmen, die auf dem Computer ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Ein Wert für CurrentVersion von 5.0 gibt an, dass auf dem Computer das Betriebssystem Microsoft Windows Server 2000 ausgeführt wird. Der Wert von Version für die veröffentlichte Version aller Windows 2000 Server-Betriebssysteme lautet 5.0.2195. Jeder andere Wert für den Schlüssel Version gibt an, dass eine Vorabversion von Windows 2000 Server verwendet wird.

Wenn Exchange Server Analyzer feststellt, dass der Wert für die zweite Instanz von CurrentVersion 5.0 beträgt und der Wert Version ungleich 5.0.2195 ist, wird ein Fehler angezeigt.

Wenn Sie nicht an einem Technology Adoption Program (TAP) oder einem ähnlichen von Microsoft geförderten Programm beteiligt sind, rät Microsoft vom Einsatz von Software einer Vorabversion in Produktionsumgebungen ab und gewährt keinen Support für einen solchen Einsatz.

So beheben Sie diesen Fehler

  1. Aktualisieren Sie alle Server der Exchange-Infrastruktur, einschließlich Domänencontroller, globaler Katalogserver, ADC-Server (Active Directory Connector) und Exchange Server-Computer, auf die Software der aktuell veröffentlichten Version.

  2. Wenn die Option zum Aktualisieren verfügbar ist bzw. unterstützt wird, installieren Sie das Betriebssystem neu, und stellen Sie die Einstellungen und Daten von Exchange Server wieder her.

Weitere Informationen zum Anfordern und Installieren von Windows 2000 Service Pack 4 finden Sie auf der Website „Windows 2000 Service Pack 4" unter http://go.microsoft.com/fwlink/?LinkId=33241.


Die X.400-Adresse verfügt über ein ungültiges Endzeichen.
Microsoft Exchange Server Analyzer-Tools - Artikel > Active Directory >

Letztes Änderungsdatum des Themas: 2006-12-03

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert von gatewayProxy für Empfängerrichtlinien zu ermitteln und zu überprüfen, dass die X.400-Adresse mit einem Semikolon endet.

Die korrekte Formatierung einer X.400-Adresse in einer Empfängerrichtlinie erfordert, dass die Adresse mit einem Semikolon endet. Wenn das Semikolon fehlt, wird das Nachrichtenrouting an die X.400-Adresse unterbrochen.

Um dieses Problem zu beheben, müssen Sie unter Verwendung von ADSI-Bearbeitung (Active Directory Service Interfaces) oder des LDP-Tools am Ende der Adresse ein Semikolon hinzufügen.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, von Exchange Server 2003 bzw. Exchange Server 2007 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So beheben Sie diesen Fehler

  1. Öffnen Sie einen Active Directory-Editor, z. B. die ADSI-Bearbeitung.

  2. Erweitern Sie Konfiguration [Domänenname], erweitern Sie CN=Configuration, DC=Domänenname, DC=Domänensuffix.

  3. Erweitern Sie CN=Services, und erweitern Sie dann CN=Microsoft Exchange.

  4. Erweitern Sie CN=Organisationsname, erweitern Sie CN=Administrative Groups, und erweitern Sie dann CN=Recipient Policies.

  5. Klicken Sie mit der rechten Maustaste auf CN=Richtlinienname, und wählen Sie Eigenschaften aus.

  6. Führen Sie einen Bildlauf nach unten durch, um gatewayProxy zu finden, markieren Sie den Eintrag, und klicken Sie dann auf Bearbeiten.

  7. Geben Sie im Feld Wert den korrekten Wert für gatewayProxy ein.

  8. Schließen Sie den Active Directory-Editor, und starten Sie den Exchange Server-Computer neu, damit die Änderung wirksam wird.


Datenbankwiederherstellung
Microsoft Exchange Server Analyzer-Tools - Artikel >

Letztes Änderungsdatum des Themas: 2007-01-22

Die Artikel in diesem Abschnitt enthalten Details zu Datenbankfehlern und -warnungsereignissen, die vom Microsoft® Exchange-Tool Datenbank-Problembehandlung im Ereignisprotokoll Anwendung erkannt wurden. Das Tool Datenbank-Problembehandlung verwendet dasselbe Modul wie der Microsoft Exchange-Problembehebungs-Assistent zum programmgesteuerten Ausführen einer Reihe von Schritten, durch die die Ursachen von Problemen bei der Bereitstellung von Datenbanken ermittelt werden. Darüber hinaus enthalten diese Artikel schrittweise Anleitungen zum Bestimmen und Beheben datenbankbezogener Probleme.

Weitere Informationen zu diesem Tool und seinem Download finden Sie unter Microsoft Exchange Troubleshooting Assistant v1.0.


ESE 428 (0xfffff8f0): Nicht ausreichend freier Speicherplatz auf dem Transaktionsprotokolllaufwerk
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-04-02

Das Microsoft® Exchange-Tool Datenbank-Problembehandlung hat im Protokoll Anwendung ein oder mehrere ESE 428-Ereignisse festgestellt. Dieses Ereignis weist darauf hin, dass nicht ausreichend freier Speicherplatz auf dem Transaktionsprotokolllaufwerk vorliegt. Wird dieser Fehler generiert, kann Exchange Server keine neue Transaktionsprotokolldatei erstellen. Dadurch werden alle Datenbanken in der betroffenen Speichergruppe offline geschaltet, weil Aktualisierungen an Datenbanken im Transaktionsprotokoll gespeichert werden müssen.

Erklärung

Exchange Server stellt zwei Mechanismen bereit, um zu verhindern, dass sich das Transaktionsprotokolllaufwerk füllt:

  • Umlaufprotokollierung. Transaktionsprotokolle werden automatisch gelöscht, nachdem der Datenbankprüfpunkt sie passiert hat. Der für Transaktionsprotokolldateien verwendete Festplattenspeicher liegt in den meisten Fällen unter 50 MB. Während der Sicherung wird das Entfernen der Transaktionsprotokolle möglicherweise so lange ausgesetzt, bis die Sicherung abgeschlossen ist.

    Hinweis:
    Standardmäßig ist die Umlaufprotokollierung in Microsoft Exchange 2000 Server und höheren Versionen nicht aktiviert.
  • Speichergruppensicherung. Exchange Server entfernt überschüssige Protokolle nach der Durchführung einer vollständigen oder inkrementellen Onlinesicherung aller Datenbanken in einer Speichergruppe mit einer Sicherungsmethode, die den Volumeschattenkopie-Dienst (Volume Shadow Copy, VSS) oder APIs für die Streamingonlinesicherung für Exchange Server implementiert.

Wenn die Umlaufprotokollierung nicht aktiviert ist und eine der folgenden Bedingungen vorliegt, erhöht sich die Anzahl der Transaktionsprotokolldateien, bis der Speicherplatz auf dem Festplattenlaufwerk erschöpft ist:

  • Das Sicherungsprogramm entfernt die Transaktionsprotokolldateien nicht.

  • Das Sicherungsprogramm wurde unterbrochen.

  • Die Transaktionsprotokolldateien werden nicht mit einer anderen Methode bereinigt.

Gelegentlich müssen Sie ggf. Transaktionsprotokolldateien manuell entfernen, wenn der Speicherplatz auf der Festplatte nicht ausreichend ist. Möglicherweise müssen Sie Transaktionsprotokolldateien auch manuell entfernen, wenn Sie erwarten, dass der Speicherplatz auf der Festplatte erschöpft sein wird, bevor Sie eine vollständige oder inkrementelle Onlinesicherung aller Datenbanken in einer bestimmten Speichergruppe durchführen können. Wenn Sie Protokolle entfernen, die noch vor einem Datenbankprüfpunkt liegen, und die Datenbank dann mit einem Fehler beendet wird, kann die Datenbank erst nach der Wiederherstellung der erforderlichen Protokolle wieder bereitgestellt werden. Daher müssen Sie vor dem manuellen Entfernen von Exchange Server-Transaktionsprotokolldateien erst überprüfen, welche Protokolle ohne Bedenken entfernt werden können.

Der Fehler kann auch als JET_errDiskFull oder Fehlercode 0xfffff8f0 gemeldet werden. Dieser Fehler tritt in den folgenden Versionen von Exchange Server auf:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Benutzeraktion

Wählen Sie zum Beheben des Fehlers eine der folgenden Lösungen aus:

  • Führen Sie das Tool Database Recovery Management aus. In Microsoft Exchange Server 2007 ist das Tool unter den Datenbankwiederherstellungstools der Toolbox in der Exchange-Verwaltungskonsole aufgeführt. Exchange Server Analyzer kann automatisch die Protokolldateien ermitteln, deren Entfernung unbedenklich ist, und kopiert sie in einen Sicherungsspeicherort. Es empfiehlt sich dringend, Exchange Server Analyzer zum Verschieben von Protokolldateien zu verwenden.

    Hinweis:
    Exchange Server Analyzer funktioniert in Exchange 2007 nicht, wenn für die Speichergruppe, in der die Datenbank enthalten ist, die fortlaufende Clusterreplikation (Cluster Continuous Replication, CCR) aktiviert ist.
  • Überprüfen Sie die Werte von State und Log Required in jedem Datenbankheader, um zu ermitteln, welche Transaktionsprotokolldateien ohne Bedenken manuell entfernt werden können.

    Hinweis:
    Entfernen einer Transaktionsprotokolldatei bedeutet in diesem Artikel, dass die Transaktionsprotokolldatei an einen anderen Speicherort verschoben wird, wo sie dann gesichert, gespeichert oder gelöscht werden kann. Welche Aktion ausgeführt wird, hängt von Ihren Anforderungen an. Löschen einer Transaktionsprotokolldatei bedeutet in diesem Artikel, dass die Transaktionsprotokolldatei endgültig entfernt wird und nicht mehr gesichert oder wiederhergestellt werden kann.

Führen Sie die folgenden ausführlichen Anweisungen aus, um zu ermitteln, welche Transaktionsprotokolldateien ohne Bedenken manuell entfernt werden können.

Überpüfen des Headers der Datenbank und Entfernen überflüssiger Protokolldateien

  1. Heben Sie die Bereitstellung der Datenbank auf, deren Header Sie überprüfen möchten.

  2. Klicken Sie auf Start, anschließend auf Ausführen, und geben Sie dann cmd ein, um das Eingabeaufforderungsfenster zu öffnen:

  3. Wechseln Sie an der Eingabeaufforderung zum Verzeichnispfad, unter dem sich die Datenbankdatei befindet.

    Hinweis:
    Exchange 2000 Server und Exchange Server 2003: Um den Pfad und den Dateinamen der EDB- und STM-Dateien für eine Datenbank zu ermitteln, verwenden Sie Exchange-System-Manager, und zeigen Sie die Registerkarte Datenbank im Dialogfeld Eigenschaften für jedes Datenbankobjekt an. Exchange Server 2007: Um den Pfad und den Dateinamen der Datenbankdatei zu ermitteln, erweitern Sie die Exchange-Verwaltungskonsole unter Serverkonfiguration, klicken Sie auf Mailbox, und zeigen Sie die Registerkarte Datenbankverwaltung an.

  4. Geben Sie den folgenden Eseutil-Befehl zusammen mit dem Schalter /MH an der Eingabeaufforderung ein:

    Code kopieren
    "eseutil /MH databasefilename.edb"
    Hinweis:
    In der Syntax gibt databasefilename den Namen der Datenbank an, die Sie überprüfen möchten.

  5. Überprüfen Sie die Werte von State und Log Required in den angezeigten Headerinformationen.

    Der Wert von State liefert die folgenden Informationen darüber, ob die Datenbank ordnungsgemäß abgekoppelt wurde:

    • Wenn die Datenbank ordnungsgemäß abgekoppelt wurde, lautet der Wert von State entweder "Ordnungsgemäß beendet" oder "Konsistent". Dieser Wert hängt von der ausgeführten Version von Exchange Server ab. Sie können alle Transaktionsprotokolldateien außer der aktuellen Transaktionsprotokolldatei entfernen.

      Hinweis:
      Wenn sich alle Datenbanken im Status "Ordnungsgemäß beendet" befinden und Sie die aktuelle Protokolldatei entfernen, wird die Protokolldateisequenz zurückgesetzt. Datenbanken können weiterhin gestartet werden. Durch das Zurücksetzen der Transaktionsprotokolldateien kann jedoch kein Rollforward für die Datenbank aus einer früheren Sicherung mehr erfolgen.
    • Wenn die Datenbank nicht ordnungsgemäß abgekoppelt wurde, lautet der Wert für State entweder "Nicht ordnungsgemäß beendet" oder "Inkonsistent". Überprüfen Sie anhand des Feldes Log Required im Datenbankheader, welche Transaktionsprotokolldateien entfernt werden können.

      Hinweis:
      Wenn die Datenbank sich im Status "Nicht ordnungsgemäß beendet" oder "Inkonsistent" befindet, enthalten einige der vorhandenen Transaktionsprotokolldateien ausstehende Transaktionen, die von der Datenbank benötigt werden. Wenn Sie die Transaktionsprotokolldateien in dieser Situation entfernen, kann die Datenbank erst wieder gestartet werden, nachdem sie aus einer Sicherung wiederhergestellt wurde. Alternativ dazu können Sie die Datenbank mithilfe der Befehle Eseutil und Isinteg reparieren.
      Sie sollten die Werte von Log Required für jede Datenbank in einer Speichergruppe überprüfen, bevor Sie Protokolle für diese Speichergruppe entfernen.

      Im Feld Log Required ist ein Bereich nummerierter Protokolldateien angegeben, die zum Starten der Datenbank erforderlich sind. Lautet der Bereich "0 - 0", sind keine Protokolldateien zum Starten der Datenbank erforderlich. Dies zeigt an, dass die Datenbank sich im Zustand "Ordnungsgemäß beendet" oder "Konsistent" befindet. Wenn Protokolldateien vorliegen, die älter als das Prüfpunktprotokoll sind, können Sie diese Protokolldateien (aber nicht das Prüfpunktprotokoll) entfernen.

      Wenn Sie eine Version von Exchange Server ausführen, die älter als Exchange Server 2003 Service Pack 1 (SP1) ist, müssen Sie den im Feld Log Required angegebenen Bereich in Hexadezimalwerte konvertieren. Lautet der Wert von Log Required beispielsweise "28217 - 28221", benötigt die Datenbank die Protokolle von 06E39 bis 06E3D. In Exchange 2003 SP1 wurde das Feld Log Required erweitert und gibt sowohl die Dezimal- als auch die Hexadezimalwerte an.

      Hinweis:
      Mithilfe des wissenschaftlichen Modus im Windows-Rechner können Sie die Werte von dezimal in hexadezimal konvertieren. Starten Sie den Rechner, und klicken Sie dann im Menü Ansicht auf Wissenschaftlich. Wählen Sie eine Dezimalzahl aus, und klicken Sie anschließend auf Hex.
      Da in Exchange 2000 und Exchange 2003 bis zu vier Speichergruppen mit jeweils einem eigenen Satz Protokolldateien vorliegen können, enthalten die Transaktionsprotokoll-Dateinamen nicht den Präfix "Edb". In Exchange 2000 und Exchange 2003 wird der Präfix "Edb" ersetzt durch "E00", "E01", "E02" oder "E03". Bei Speichergruppen für die Wiederherstellung wird der Präfix "Edb" ersetzt durch "R00". Der Dateinamenpräfix der Transaktionsprotokolle wird im Exchange-System-Manager auf der Registerkarte Allgemein im Dialogfeld Eigenschaften für das jeweilige Speichergruppenobjekt angezeigt. Lautet der Speichergruppenpräfix beispielsweise "E01" und der Log Required-Eintrag "28217 - 28221 (0x06E39 - 0x06E3D)", werden die Protokolle E0106E39.log bis E0106E3D.log benötigt.

  6. Sie können daher alle nummerierten Protokolldateien ohne Bedenken entfernen, deren Nummer kleiner ist als der niedrigste Eintrag in den Log Required-Feldern für alle Datenbanken der Speichergruppe.

    Hinweis:
    Denken Sie daran, die Protokolldateien zu verschieben und nicht zu löschen.
    Hinweis:
    Dabei sollten Sie die jüngste Transaktionsprotokolldatei in keinem Fall entfernen. Dies ist die Protokolldatei mit dem aktuellsten Zeitstempel, die noch keine Sequenznummer im Dateinamen trägt. Selbst wenn Sie ermittelt haben, dass es unbedenklich ist, diese Datei zu entfernen, verzichten Sie darauf, damit die Protokolldateisequenz nicht auf "0" zurückgesetzt wird. Wenn Sie die Protokolldateisequenz zurücksetzen, hat dies Auswirkungen auf die Sicherungszyklen. Sie können möglicherweise kein Rollforward der Datenbank aus einer vor dem Zurücksetzen erzeugten Sicherung vornehmen.


ESE 454 -515: Fehlende erforderliche Transaktionsprotokolldatei
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-01-23

Microsoft® Exchange Server Analyzer hat das ESE-Ereignis 454 mit dem Fehlercode -515 festgestellt. Dieser Fehler bedeutet, dass die Exchange-Datenbank nicht bereitgestellt werden konnte, da eine erforderliche Transaktionsprotokolldatei fehlt.

Erklärung

Das ESE-Ereignis 454 mit dem Fehlercode -515 kann auftreten, wenn die ESE (Extensible Storage Engine) versucht, während eines Wiederherstellungsvorgangs alle Datenbanken in einer Speichergruppe in einen einheitlichen Status zu versetzen. Wenn erforderliche Transaktionsprotokolldateien fehlen, schlägt der Wiederherstellungsvorgang fehl, weshalb die Datenbank mit dem Fehlercode -515 nicht bereitgestellt werden kann.

Benutzeraktion

Um dieses Problem zu beheben, führen Sie einen oder mehrere der folgenden Schritte aus:

  • Bestimmen Sie anhand der folgenden Anweisungen, welche Transaktionsprotokolldateien fehlen und an welchem Speicherort sie sich befinden. Verschieben Sie sie anschließend in das Transaktionsprotokollverzeichnis der Speichergruppe zurück.

  • Stellen Sie die betroffenen Datenbanken aus einer Sicherung wieder her.

Achtung:
Sie sollten nicht versuchen, die Datenbank wiederherzustellen, es sei denn, die vorherige Lösung zum Ermitteln und Wiederherstellen der spezifischen fehlenden Transaktionsprotokolldateien ist fehlgeschlagen. Dadurch werden alle neuen Daten seit der letzten Sicherung überschrieben.
Hinweis:
Verschieben oder löschen Sie vor dem Wiederherstellen der Datenbanken Transaktionsprotokolldateien, die zu der betroffenen Speichergruppe gehören, aus dem Zielpfad.
So ermitteln Sie in Exchange Server 2003 und Exchange Server 2007 mit dem Microsoft Exchange-Problembehandlungs-Assistenten fehlende Transaktionsprotokolldateien

  1. Klicken Sie im Microsoft Exchange-Problembehandlungs-Assistenten im Fenster Display Examining Event Log Results auf den Hyperlink Use related Database Recovery Management task to verify and resolve this issue, um die fehlenden erforderlichen Transaktionsprotokolldateien zu ermitteln.

  2. Zeichnen Sie die in Schritt 1 gemeldeten Protokolldateinamen auf.

  3. Bestimmen Sie den aktuellen Speicherort der Protokolldateien, und verschieben Sie sie zurück an den erwarteten Speicherort.
Hinweis:
Durchsuchen Sie beim Ermitteln des aktuellen Speicherorts der fehlenden Transaktionsprotokolldateien auch den Papierkorb und etwaige Quarantäneordner von Antivirenprogrammen.
  1. Versuchen Sie, die betroffene Exchange-Datenbank bereitzustellen.

 So werden in Exchange 2000 Server und Exchange Server 2003 fehlende Transaktionsprotokolle manuell ermittelt und wiederhergestellt

  1. Starten Sie den Exchange-System-Manager.

  2. Erweitern Sie Administrative Gruppen, danach Ihre administrative Gruppe, dann Server, klicken Sie mit der rechten Maustaste auf Ihre Speichergruppe, und klicken Sie dann auf Eigenschaften.

  3. Zeichnen Sie den auf der Registerkarte Allgemein unter Pfad des Transaktionsprotokolls angegebenen Pfad der Transaktionsprotokolldateien auf.

  4. Öffnen Sie an einer Eingabeaufforderung das Verzeichnis, in dem sich Eseutil.exe befindet. Der Standardpfad von Eseutil.exe in Exchange 2000 Server und Exchange Server 2003 ist C:\Programme\exchsrvr\bin.

  5. Geben Sie an der Eingabeaufforderung den folgenden Befehl ein:

    Code kopieren
    eseutil /ml "logpath\logprefix"

    logpath ist der in Schritt 3 aufgezeichnete Pfad der Transaktionsprotokolldateien. logprefix ist das Präfix der Transaktionsprotokolldateien, in der Regel e00.

    Ein Beispiel dieses Befehls mit den Standardeinstellungen sieht so aus:

    eseutil /ml "c:\program files\exchsrvr\mdbdata\e00".

  6. Fehlende Transaktionsprotokolldateien werden abhängig von der jeweils fehlenden Transaktionsprotokolldatei in einem der beiden folgenden Formate gemeldet:

    • Fehlende Protokolldatei: c:\Programme\exchsrvr\mdbdata\E0002BE2.log

    • FEHLER: Fehlende Protokolldatei(en): Die Protokolldatei hat die Generierungsnummer 11,235 (0x2BE3), erwartet wird die Generierungsnummer 11,234 (0x2BE2).

    0x2BE2 ist die fehlende Transaktionsprotokolldatei E0002BE2.log.

  7. Zeichnen Sie die in Schritt 6 gemeldeten Protokolldateinamen auf.

  8. Bestimmen Sie den aktuellen Speicherort der Protokolldateien, und verschieben Sie sie zurück an den Speicherort in Schritt 3.
Hinweis:
Durchsuchen Sie beim Ermitteln des aktuellen Speicherorts der fehlenden Transaktionsprotokolldateien auch den Papierkorb und etwaige Quarantäneordner von Antivirenprogrammen.
  1. Versuchen Sie, die betroffene Exchange-Datenbank bereitzustellen.

 So werden in Exchange Server 2007 fehlende Transaktionsprotokolle manuell ermittelt und wiederhergestellt

  1. Starten Sie die Exchange-Verwaltungskonsole auf dem Server, auf dem sich die Speichergruppe befindet.

  2. Erweitern Sie in der Konsolenstruktur Serverkonfiguration, und klicken Sie dann auf Postfach.

  3. Klicken Sie im Ergebnisbereich auf den Postfachserver mit der Speichergruppe, deren fehlende Transaktionsprotokolldatei Sie wiederherstellen möchten.

  4. Klicken Sie mit der rechten Maustaste auf die Speichergruppe, und klicken Sie dann auf Eigenschaften.

  5. . Zeichnen Sie den auf der Registerkarte Allgemein unter Protokollpfad angegebenen Pfad der Transaktionsprotokolldateien auf.

  6. Öffnen Sie an einer Eingabeaufforderung das Verzeichnis, in dem sich Eseutil.exe befindet. In Exchange Server 2007 befindet sich Eseutil im Standardinstallationsordner von Exchange: <Systemlaufwerk>:\Programme\Microsoft\Exchange Server\Bin.

  7. Geben Sie an der Eingabeaufforderung den folgenden Befehl ein:

    Code kopieren
    eseutil /ml "logpath\logprefix"

    logpath ist der in Schritt 5 aufgezeichnete Pfad der Transaktionsprotokolldateien. logprefix ist das Präfix der Transaktionsprotokolldateien, in der Regel e00.

    Ein Beispiel dieses Befehls mit den Standardeinstellungen sieht so aus:

    eseutil /ml "c:\Program Files\Microsoft\Exchange Server\Bin\e00".

  8. Fehlende Transaktionsprotokolldateien werden abhängig von der jeweils fehlenden Transaktionsprotokolldatei in einem der beiden folgenden Formate gemeldet:

    • Fehlende Protokolldatei: c:\Programme\Microsoft\Exchange Server\Bin\E000000049A.log

    • FEHLER: Fehlende Protokolldatei(en): Die Protokolldatei hat die Generierungsnummer 11,235 (0x2BE3), erwartet wird die Generierungsnummer 11,234 (0x2BE2).

    0x2BE2 ist die fehlende Transaktionsprotokolldatei E0002BE2.log.

  9. Zeichnen Sie die in Schritt 8 gemeldeten Protokolldateinamen auf.

  10. Bestimmen Sie den aktuellen Speicherort der Protokolldateien, und verschieben Sie sie zurück an den Speicherort in Schritt 5.
Hinweis:
Durchsuchen Sie beim Ermitteln des aktuellen Speicherorts der fehlenden Transaktionsprotokolldateien auch den Papierkorb und etwaige Quarantäneordner von Antivirenprogrammen.
  1. Versuchen Sie, die betroffene Exchange-Datenbank bereitzustellen.

Weitere Informationen zum ESE-Ereignis 454 finden Sie im "Events and Errors Message Center" (http://go.microsoft.com/fwlink/?LinkId=81883).


ESE 455 -1811 (0xfffff8ed): Fehlende aktuelle Transaktionsprotokolldatei (Exx.log)
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-05-31

Das Microsoft Exchange-Tool Datenbank-Problembehandlung hat im Anwendungsprotokoll mindestens ein ESE 455-Ereignis mit dem Fehlercode -1811 (0xfffff8ed) festgestellt. Dieses Ereignis bedeutet, dass das aktuelle Transaktionsprotokoll (exx.log) entweder fehlt, der Zugriff darauf nicht möglich ist, oder es eine nicht übereinstimmende Signatur hat.

Erläuterung

Mögliche Ursachen für diesen Fehler:

  • Fehler 1811, der JET_errFileNotFound entspricht. Dieser Fehler kann in einer Exchange-Protokolldatei auftauchen, die eine nicht übereinstimmende Signatur und eine interne Protokollgenerierungsnummer (LGeneration) hat. Die Exchange-Protokolldatei heißt normalerweise E00.log. Wenn die Datei E00.log eine nicht übereinstimmende Signatur hat, kann der Informationsspeicher nicht bereitgestellt werden, selbst wenn die Datenbank konsistent ist.

  • Ein Antivirenprogramm legt die Exchange-Protokolldatei in einem Quarantäneordner ab oder löscht sie.

  • Der Reparaturbefehl eseutil /p wurde auf die betroffenen Datenbanken angewendet, und die Protokolldateien wurden nicht entfernt.

  • Der Wiederherstellungsbefehl eseutil /r wurde mit einem falschen Protokolldatei-Basisnamen ausgeführt (z. B. mit eseutil /r Exx.log, wobei Exx.log der aus drei Zeichen bestehende Protokolldatei-Basisname ist).

Dieser Fehler kann auch als -1404, JET_errIndexNotFound auftreten. Dieser Fehler tritt in den folgenden Versionen von Exchange Server auf:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Benutzeraktion

Um den Fehler zu beheben, führen Sie einen oder mehrere der folgenden Schritte aus:

  • Wenn die Protokolldatei über eine nicht übereinstimmende Signatur und Protokollgenerierungsnummer verfügt, wenden Sie sich an Microsoft Support Services. Weitere Informationen finden Sie auf der Seite Kontakt der Website Microsoft Hilfe und Support.

  • Wenn ein Antivirenprogramm die aktuelle Exchange-Protokolldatei in Quarantäne setzt oder löscht, gehen Sie wie folgt vor:

    • Untersuchen Sie die Konfiguration des Antivirenprogramms.

    • Stellen Sie sicher, dass das Antivirenprogramm keine Exchange Server-Verzeichnisse scannt.

    • Standardmäßig sind einige Antivirenprogramme so konfiguriert, dass sie Laufwerke und Verzeichnisse wöchentlich in einem manuellen oder automatischen Modus scannen. Diese Einstellung kann schnell übersehen werden. Stellen Sie sicher, dass Sie die Exchange Server-Verzeichnisse im Antivirenprogramm zur Liste der ausgeschlossenen Speicherorte hinzufügen. Weitere Informationen dazu, wie Sie Antivirenprogramme für den Betrieb mit Exchange konfigurieren, finden Sie in Microsoft Knowledge Base-Artikel 823166, "Überblick über Exchange Server 2003 und Antivirussoftware".

    • Überprüfen Sie in den Protokolldateien des Antivirenprogramms, ob die Exchange-Protokolldatei in Quarantäne gesetzt oder gelöscht wurde.

    Verwenden Sie eine der folgenden Methoden zum Wiederherstellen der Exchange-Protokolldatei:

Methode 1: Wenn die Exchange-Protokolldatei in das Quarantäneverzeichnis verschoben wurde:

  1. Stellen Sie die Exchange-Protokolldatei in den Ordner wieder her, der die Protokolldateien Ihrer Produktionsumgebung enthält.

  2. Starten Sie den Microsoft Exchange-Informationsspeicherdienst. Wenn keine anderen Protokolldateien fehlen, wird die Datenbank bereitgestellt. Fehlen weitere Protokolldateien, überprüfen Sie, ob diese sich im Quarantäneordner des Antivirenprogramms befinden. Wenn die Protokolldateien sich nicht im Quarantäneordner befinden, lesen Sie Methode 2.

Wenn die Exchange-Protokolldatei gelöscht wurde, müssen Sie die Speichergruppendatenbank aus einer Sicherung wiederherstellen. Führen Sie anschließend eine Wiedergabe der Protokolldateien durch. Führen Sie folgende Schritte durch, um eine verfügbare Datenbank wiederherzustellen:

Methode 2: Wenn die Exchange-Protokolldatei gelöscht wurde:

  1. Verschieben Sie alle inkonsistenten Datenbanken in einen Sicherungsordner.

  2. Wenn eine neue E00.log-Datei erstellt wurde, verschieben Sie diese in den Sicherungsordner. Verschieben Sie außerdem die Datei E00.chk in den Sicherungsordner.

  3. Kopieren Sie alle vorhandenen Protokolldateien in den Sicherungsordner. Hinweis Sie müssen die Protokolldateien kopieren. Verschieben Sie die Protokolldateien nicht.

  4. Benennen Sie die letzte E00*.log-Protokolldatei in E00.log um.

  5. Stellen Sie die Datenbank aus einer Sicherung wieder her. Führen Sie anschließend eine Wiedergabe der Protokolldateien durch. Dadurch wird die Datenbank wieder in einen konsistenten Zustand gebracht. Die in den Sicherungsordner kopierte Datei E00.log ist in der Datenbank jedoch nicht enthalten. Es liegt zwar ein geringer Verlust von Daten vor, Sie verfügen nun aber über eine Datenbank, die bereitgestellt werden kann.

    Hinweis:
    Wenn Sie die Datenbank nicht aus einer Sicherung wiederherstellen können, bringen Sie die Datenbank mithilfe von Reparaturdienstprogrammen in einen konsistenten Zustand.

  6. Starten Sie den Microsoft Exchange-Informationsspeicherdienst.

Wenn der Reparaturbefehl eseutil /p auf die betroffene Datenbank angewendet wurde und die Protokolldateien nicht entfernt wurden, gehen Sie wie folgt vor:

So überprüfen Sie, ob der Befehl "eseutil /p" ausgeführt wurde

  1. Klicken Sie auf Start, klicken Sie auf Ausführen, und geben Sie cmdein. Klicken Sie anschließend auf OK.

  2. Geben Sie Folgendes an der Eingabeaufforderung ein:

    Code kopieren
    c:\program files\exchsrvr\bin\eseutil /mh "c:\program files\exchsrvr\mdbdata\<name of Exchange database.edb>"

    Die voranstehende Syntax geht von folgenden Voraussetzungen aus:

    • Die Exchange Server-Programmdateien wurden im Ordner c:\Programme\exchsrvr installiert.

    • Ihre Datenbank befindet sich im Ordner c:\Programme\exchsrvr\mdbdata.

  3. Lesen Sie das Attribut Reparaturanzahl. Weist das Attribut Reparaturanzahl den Wert "0" (Null) auf, wurde der Befehl eseutil /p nicht ausgeführt. Weist das Attribut Reparaturanzahl einen anderen Wert als "0" (Null) auf, wurde der Befehl eseutil /p auf die Datenbank angewendet.

Wenn sich die öffentlichen und privaten Datenbanken in einem konsistenten Zustand bzw. im Status "Clean Shutdown" befinden, können Sie die Transaktionsprotokolldateien in einen anderen Ordner verschieben. Führen Sie die folgenden Schritte aus, um zu ermitteln, ob die Datenbanken sich in einem konsistenten Zustand bzw. im Status "Clean Shutdown" befinden:

So ermitteln Sie, ob die Datenbanken sich in einem konsistenten Zustand bzw. im Status "Clean Shutdown" befinden

  1. Klicken Sie auf Start, dann auf Ausführen, und geben Sie cmd ein. Klicken Sie anschließend auf OK.

  2. Geben Sie Folgendes ein, um den privaten Informationsspeicher zu untersuchen:

    Code kopieren
    c:\program files\exchsrvr\bin>eseutil /mh "drive:\program files\exchsrvr\mdbdata\priv1.edb"

  3. Geben Sie Folgendes ein, um den öffentlichen Informationsspeicher zu untersuchen:

    Code kopieren
    c:\program files\exchsrvr\bin>eseutil /mh "drive:\program files\exchsrvr\mdbdata\pub1.edb"

    Die Syntax in den Schritten 2 und 3 geht von folgenden Voraussetzungen aus:

    • Die Exchange Server-Programmdateien wurden im Ordner c:\Programme\exchsrvr installiert.

    • Ihre Datenbank befindet sich im Ordner c:\Programme\exchsrvr\mdbdata.

  4. Schauen Sie sich die Ergebnisse der Konsistenzprüfung an. Wenn eine Datenbank konsistent ist (Status = "Clean Shutdown"), wurden alle Protokolldateien an den Informationsspeicher übergeben. Wenn die Datenbank nicht konsistent ist (Status = "Dirty Shutdown"), muss die Datenbank nicht unbedingt beschädigt sein. Möglicherweise wurden die Protokolldateien nur noch nicht an die Datenbank übergeben.

  5. Liegt der Status Clean Shutdown vor, verschieben Sie alle Protokolldateien aus allen mdbdata-Verzeichnissen in einen Sicherungsordner.

  6. Stellen Sie die Datenbank bereit.
  • Wenn der Wiederherstellungsbefehl eseutil /r mit einem falschen Protokolldatei-Basisnamen ausgeführt wurde, verwenden Sie die richtige Option, um den Befehl erfolgreich auszuführen. Die üblichen Protokolldatei-Basisnamen sind "e00", "e01", "e02" und "e03". Der folgende Befehl enthält beispielsweise einen richtigen Protokolldatei-Basisnamen:

    Code kopieren
    eseutil /r e00
  • Wenn das Problem weiterhin besteht, kontaktieren Sie Microsoft Support Services. Weitere Informationen finden Sie auf der Seite Kontakt der Website Microsoft Hilfe und Support.


ESE 474 -1018: Nicht behebbarer Fehler in Datenbank
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-03-28

Das Microsoft Exchange-Tool Datenbank-Problembehandlung hat mindestens ein ESE 474-Ereignis mit dem Fehlercode -1018 im Anwendungsprotokoll erkannt. Dieser Fehler wird generiert, wenn die Überprüfungskomponente für die Integrität von Microsoft Exchange feststellt, dass Exchange Server Daten der Exchange-Datenbankdatei nicht ordnungsgemäß auf dem Festplattenteilsystem speichern oder von diesem abrufen konnte.

Erläuterung

Ein ESE 474-Ereignis mit einem Fehler -1018 kann aufgrund einer defekten Festplattenteilsystem-Hardwarekomponente oder aufgrund veralteter oder inkompatibler Treiber und/oder Firmware im Festplattenteilsystem auftreten.

Nachdem ein Fehler -1018 aufgetreten ist, melden Diagnosehardwaretests, die für den Server ausgeführt werden, möglicherweise keine Festplattenteilsystem-Hardwareprobleme, und die Annahme liegt nahe, dass Exchange Server für das Problem verantwortlich ist.

Umfangreiche Untersuchungen durch Microsoft und die Hardwarehersteller haben ergeben, dass komplexe Probleme mit den Festplattenteilsystem-Hardwarekomponenten und den unterstützenden Treibern bzw. der Firmware für die meisten Fehler -1018 verantwortlich sind.

Exchange meldet einen Fehler -1018, wenn eine initialisierte Seite in der Datenbankdatei gefunden wird, für die eine der folgenden Bedingungen gilt:

  • Die auf der Seite gespeicherte Prüfsumme entspricht nicht dem Ergebnis der Prüfsummenneuberechnung, die beim Lesen der Seite durchgeführt wird.

  • Die auf der Seite gespeicherte Seitennummer entspricht nicht der Seitennummer, die sich unter Berücksichtigung des physikalischen Speicherorts in der Datenbankdatei auf der Seite befinden sollte.

Exchange kann dafür verantwortlich sein, selbst einen Fehler -1018 zu generieren, wenn eines der folgenden Szenarien eintritt:

  • Exchange erstellt eine Seite, die die falsche Prüfsumme aufweist.

  • Exchange erstellt eine Seite ordnungsgemäß, weist das Betriebssystem jedoch an, diese an den falschen Speicherort zu schreiben.

Exchange generiert eine Prüfsumme für eine Seite, die auf den Datenträger geschrieben werden soll, nachdem alle Daten auf die Seite geschrieben wurden. Hierzu gehört auch die Seitennummer selbst. Nachdem Exchange der Seite die Prüfsumme hinzugefügt hat, weist Exchange das Betriebssystem Windows an, die Seite mithilfe von veröffentlichten, auf Windows basierenden Standard-APIs auf den Datenträger zu schreiben.

Vorübergehende Speicherfehler können dann bewirken, dass die Seite an den falschen Speicherort auf der Festplatte geschrieben wird.

Obwohl die Prüfsumme der Seite richtig ist, meldet Exchange einen Fehler -1018, weil die logische Seitennummer nicht der physikalischen Seitennummer entspricht.

Ein einzelner Fehler -1018, der in einer Exchange-Datenbank gemeldet wird, bewirkt im Allgemeinen nicht, dass die Exchange-Datenbank beendet wird. Als einziges Symptom tritt das Vorhandensein des Fehlers -1018 auf. Die betroffene Seite befindet sich möglicherweise in einem Ordner, auf den nur selten zugegriffen wird (z. B. im Ordner Gesendete Elemente oder Gelöschte Elemente), oder in einer Anlage, die selten geöffnet wird oder sogar leer ist.

Es ist unwahrscheinlich, dass ein einzelner Fehler -1018 große Datenverluste verursacht. Fehler -1018 stellen jedoch ein Problem dar, weil sie anzeigen können, dass ein Speichersystem mindestens einmal Daten nicht zuverlässig gespeichert oder abgerufen hat. Der Fehler -1018 ist eine frühzeitige Warnung zu einem Problem, dass sich wahrscheinlich laufend verschlimmert. Selbst wenn der erste Fehler -1018 für eine leere Seite in der Datenbank gemeldet wird, ist nicht bekannt, welche Seite als nächstes beschädigt wird. Wenn eine wichtige globale Tabelle beschädigt wird, wird die Exchange-Datenbank möglicherweise nicht gestartet, und die Datenbankreparatur ist ggf. nicht oder nur teilweise erfolgreich.

Nachdem ein Fehler -1018 protokolliert wurde, sollten Sie die Möglichkeit eines drohenden Ausfalls oder zusätzlicher zufälliger Beschädigungen an der Datenbank in Betracht ziehen und bei Ihrer Planung berücksichtigen, bis Sie die eigentliche Ursache des Fehlers ermittelt haben.

Benutzeraktion

Bevor Sie versuchen, den oder die im Anwendungsprotokoll protokollierten Fehler ESE 474 -1018 zu korrigieren, vergewissern Sie sich, dass das Festplattenteilsystem des Servers stabil ist.

Gehen Sie folgendermaßen vor, um die Problembehandlung des Festplattenteilsystems durchzuführen:

  1. Öffnen Sie das Anwendungsprotokoll, und suchen Sie nach ESE 474-Ereignissen. Notieren Sie sich in jedem Ereignis den vollständigen Pfad der betroffenen Datenbank. Nachdem Sie eine Liste der betroffenen Datenbanken zusammengestellt haben, notieren Sie sich die Laufwerkbuchstaben, auf die in den Datenbankpfaden verwiesen wird. Diese Informationen ermöglichen Ihnen, die Problembehandlungsbemühungen direkt auf diese physikalischen Datenträger zu richten.

  2. Überprüfen Sie das Systemprotokoll, und vergewissern Sie sich, dass keine Lese-, Schreib- oder Timeoutfehler für den Datenträger protokolliert werden.

  3. Verwenden Sie vom Hersteller bereitgestellte Diagnosedienstprogramme für das Festplattenteilsystem, und wenden Sie sich an den Hersteller der Festplattenteilsystem-Hardware, um weitere Unterstützung zum Überprüfen der Integrität des Festplattenteilsystems zu erhalten.

Nachdem Sie alle Probleme des Festplattenteilsystems korrigiert oder dessen Stabilität auf andere Weise überprüft haben, verwenden Sie die folgenden Methoden, um den Fehler -1018 zu beheben. Diese Methoden werden in der bevorzugten Reihenfolge oder Verwendung aufgelistet:

Erste Methode Verschieben Sie Postfächer aus den Datenbanken, auf die in den ESE 474-Ereignissen aus dem Anwendungsprotokoll verwiesen wird. Verschieben Sie die Postfächer an einen vorhandenen, einwandfreien Speicherort, oder erstellen Sie mindestens einen neuen Postfachspeicher ausschließlich für diesen Zweck. Nachdem alle Postfächer verschoben wurden, löschen Sie den oder die fehlerhaften Postfachspeicher.

So verschieben Sie Postfächer (Exchange 2000 Server oder Exchange Server 2003)

  1. Wählen Sie in Active Directory-Benutzer und -Computer den oder die Benutzer aus, deren Postfächer Sie verschieben möchten.

  2. Klicken Sie mit der rechten Maustaste auf die Benutzerliste, die Sie im vorherigen Schritt ausgewählt haben, und klicken Sie dann auf Exchange-Aufgaben.

  3. Klicken Sie im Assistent für Exchange-Aufgaben auf der Seite Verfügbare Aufgaben auf Postfach verschieben und dann auf Weiter.

  4. Lesen Sie die verbleibenden Schritte im Assistenten sorgfältig, und folgen Sie den Anweisungen.
So verschieben Sie Postfächer (nur Exchange Server 2003)

  1. Erweitern Sie im Exchange-System-Manager den Eintrag Server, erweitern Sie den Server, von dem Sie Postfächer verschieben möchten, erweitern Sie die Speichergruppe, von der Sie Postfächer verschieben möchten, erweitern Sie den Postfachspeicher, der die Postfächer enthält, die Sie verschieben möchten, und klicken Sie dann auf Postfächer.

  2. Klicken Sie im Detailbereich mit der rechten Maustaste auf den oder die Benutzer, deren Postfächer Sie verschieben möchten, und klicken Sie dann auf Exchange-Aufgaben.

  3. Klicken Sie im Assistenten für Exchange-Aufgaben auf der Seite Verfügbare Aufgaben auf Postfach verschieben und dann auf Weiter.

  4. Lesen Sie die verbleibenden Schritte im Assistenten sorgfältig, und folgen Sie den Anweisungen.
So verschieben Sie nur für Exchange Server 2007 Postfächer mithilfe der Exchange-Verwaltungskonsole

  1. Starten Sie die Exchange-Verwaltungskonsole.

  2. Erweitern Sie in der Konsolenstruktur Empfängerkonfiguration, und klicken Sie dann auf Postfach.

  3. Klicken Sie im Ergebnisbereich auf die Postfächer, die Sie verschieben möchten.

  4. Klicken Sie im Aktionsbereich auf Postfach verschieben.

  5. Wählen Sie im Assistenten zum Verschieben von Postfächern auf der Seite Einführung den Server, die Speichergruppe und die Postfachdatenbank aus, in den oder die das Postfach verschoben werden soll, und klicken Sie dann auf Weiter.

  6. Wählen Sie auf der Seite Verschiebeoptionen eine Option für die Behandlung fehlerhafter Nachrichten in einem Postfach aus, und klicken Sie dann auf Weiter.

  7. Geben Sie auf der Seite Zeitplan für Verschiebevorgänge an, wann der Verschiebevorgang stattfinden soll, und klicken Sie dann auf Weiter.

  8. Überprüfen Sie auf der Seite Postfach verschieben die Zusammenfassung, um die Postfachverschiebevorgänge zu bestätigen, und klicken Sie dann auf Verschieben.

  9. Klicken Sie auf der Seite Fertigstellung auf Fertig stellen.

Weitere Informationen zu den Szenarien für die Verwendung des Assistenten zum Verschieben von Postfächern sowie zum Cmdlet Move-Mailbox finden Sie in der Exchange Server 2007-Produktdokumentation unter "Verschieben von Postfächern" (http://go.microsoft.com/fwlink/?LinkId=85754).

Zweite Methode Stellen Sie die Datenbanken aus einer funktionierenden Sicherung wieder her. Weitere Informationen zum Wiederherstellen von Exchange Server-Datenbanken finden Sie in den folgenden Artikeln:

  • Exchange Server 2007 "Wiederherstellung nach Datenverlust" (http://go.microsoft.com/fwlink/?LinkId=85802)

  • "Exchange Server 2003-Handbuch zur Wiederherstellung nach Datenverlust" (http://go.microsoft.com/fwlink/?linkid=30250)

Dritte Methode Verwenden Sie Eseutil, um eine Hard Recovery der betroffenen Datenbanken durchzuführen. Diese Methode sollte nur verwendet werden, wenn die zuvor beschriebenen beiden Methoden nicht erfolgreich waren. Nachdem Sie die Hard Recovery durchgeführt haben, müssen Sie außerdem eine Offlinedefragmentierung der reparierten Datenbank sowie das Tool Isinteg ausführen, um die logischen Fehler zu reparieren. Diese Schritte können mithilfe des Reparaturtasks der Datenbank-Problembehandlung von Exchange durchgeführt werden. Auf diese Weise werden automatisch die Reparaturprogramme Eseutil /P, Eseutil /D und Isinteg ausgeführt.

Weitere Informationen

Weitere Informationen zu diesem Problem finden Sie in den folgenden Microsoft Knowledge Base-Artikeln und Exchange-Ressourcen:

  • 314917, "Verstehen und Analysieren der Exchange-Datenbankfehler -1018, -1019, and -1022" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314917)

  • 867626, "Neuer Fehlerkorrekturcode ist in Exchange Server 2003 SP1 enthalten" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=867626)

  • 259851, "Auswirkungen der Ausführung des Befehls eseutil /p oder edbutil /d /r in Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=259851)

  • "Exchange Server-Fehler -1018" (http://go.microsoft.com/fwlink/?LinkId=85807)


MSExchangeIS 1003: Nicht genügend freier Speicherplatz auf dem Exchange-Datenbanklaufwerk
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-01-22

Das Microsoft® Exchange-Tool Datenbank-Problembehandlung hat im Protokoll Anwendung ein oder mehrere MSExchangeIS 1003-Ereignisse festgestellt. Dieser Fehler kann auftreten, wenn auf dem Laufwerk mit den Datenbanken, die Sie bereitstellen möchten, nicht genügend freier Speicherplatz vorhanden ist.

Erklärung

Wenn auf dem Datenträger mit den Exchange-Datenbanken zu wenig freier Speicherplatz vorhanden ist, protokolliert der Microsoft Exchange-Informationsspeicherdienst das Ereignis MSExchangeIS 1003, woraufhin die Bereitstellung der betroffenen Datenbanken aufgehoben wird. Tritt dies ein, können Sie die Datenbanken nicht für die betroffene Speichergruppe bereitstellen. Dieser Fehler tritt in den folgenden Versionen von Exchange Server auf:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Benutzeraktion

Um dieses Problem zu beheben, geben Sie Speicherplatz auf dem Datenbanklaufwerk frei, und versuchen Sie anschließend, die Datenbanken erneut bereitzustellen. Führen Sie dazu einen oder mehrere der folgenden Schritte aus:

  • Wenn die Exchange-Datenbankdateien die einzigen Dateien auf der Festplatte sind, müssen Sie ggf. zum Freigeben von Speicherplatz eine Offlinedefragmentierung der Datenbanken ausführen.

    Hinweis:
    Je nachdem, wie viel freier Speicherplatz in der Datenbank verfügbar ist, wird dadurch Ihr Problem ggf. nicht gelöst.
    Weitere Informationen zum Ausführen dieses Schritts finden Sie im Microsoft Knowledge Base-Artikel 328804, So defragmentieren Sie Exchange-Datenbanken.

    Siehe außerdem How to Run Eseutil /D ( Defragmentation ).

  • Wenn sich die Exchange-Transaktionsprotokolldatei ebenfalls auf diesem Laufwerk befinden, können Speicherplatz freigeben, indem Sie nicht benötigte Protokolldateien entfernen.

    Weitere Informationen zum Ausführen dieses Schritts finden Sie im Microsoft Knowledge Base-Artikel 240145, Entfernen von Exchange Server-Transaktionsprotokolldateien.


MSExchangeIS 1088: Datenbank kann aufgrund eines ungültigen Attributs "legacyExchangeDN" nicht bereitgestellt werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-01-23

Das Microsoft® Exchange-Tool Datenbank-Problembehandlung hat ein MSExchangeIS 1088-Ereignis festgestellt. Dieses Ereignis bedeutet, dass die Exchange-Datenbank nicht bereitgestellt werden konnte, da sie einen legacyExchangeDN-Attributwert aufweist, der sich von dem in Active Directory gespeicherten Wert unterscheidet.

Erklärung

Ein MSExchangeIS 1088-Ereignis kann auftreten, wenn eine Exchange-Datenbank in einer administrativen Gruppe wiederhergestellt wird, die für das Attribut legacyExchangeDN einen anderen Wert aufweist als die ursprüngliche administrative Gruppe. Dieses Verhalten ist beabsichtigt. Um Informationsspeicher auf einem Computer mit Exchange Server bereitzustellen, müssen der Wert des Attributs legacyExchangeDN der Organisation und die administrative Gruppe der Exchange-Datenbanken dem Wert des Attributs legacyExchangeDN der Organisation und der administrativen Gruppe in Active Directory entsprechen.

Benutzeraktion

Um dieses Problem zu beheben, führen Sie folgende Schritte aus:

  • Stellen Sie die Exchange-Datenbank in ihrer ursprünglichen administrativen Gruppe wieder her.

  • Wenn die Exchange-Datenbank nicht in ihrer ursprünglichen administrativen Gruppe wiederhergestellt werden kann, benennen Sie die Active Directory-Objekte des vorgesehenen Ziels so um, dass sie für das Attribut legacyExchangeDN denselben Wert wie die Exchange-Datenbank haben. Sie können den Wert mit einem Tool wie ADSI-Bearbeitung (Active Directory Service Interfaces), LDP (ldp.exe) oder einem beliebigen anderen Client für LDAP (Lightweight Directory Acess Protocol), Version 3, korrigieren.

Achtung:
Wenn Sie ADSI-Bearbeitung, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, von Exchange Server 2003 bzw. Exchange Server 2007 oder beider Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So beheben Sie diesen Fehler

  1. Verwenden Sie ADSI-Bearbeitung oder ein vergleichbares Tool, um das administrative Gruppenobjekt in Active Directory zu suchen.

    Das Attribut legacyExchangeDN befindet sich unter:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organisation,CN=Administrative Groups,CN=Administrative Gruppe

  2. Geben Sie einen neuen Zeichenfolgenwert in folgender Form ein:

    /o= Organisation /ou= Administrative Gruppe

Weitere Informationen zum Verwenden des LDP-Tools finden Sie im Microsoft Knowledge Base-Artikel 260745 „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Weitere Informationen zur Verwendung von ADSI-Bearbeitung finden Sie im Abschnitt „Adsiedit.msc: ADSI-Bearbeitung" in der Hilfe zu Windows Server 2003.

Weitere Informationen zum MSExchangeIS-Ereignis 1088 finden Sie in den folgenden Quellen:

  • Events and Errors Message Center

  • Microsoft Knowledge Base-Artikel 280652, "XADM: "Event ID 1088" Is Logged and Store Fails to Mount" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=280652)


MSExchangeIS 5000 (0x3f5): Für den Informationsspeicherdienst wurde ein ungültiges Dienstkonto konfiguriert
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-02-27

Das Microsoft® Exchange-Tool Datenbank-Problembehandlung hat im Protokoll Anwendung ein oder mehrere MSExchangeIS 5000-Ereignisse mit dem Fehlercode 0x3f5 festgestellt. Dieser Fehler tritt auf, wenn der Microsoft Exchange-Informationsspeicherdienst so konfiguriert ist, dass er mit einem anderen Konto als Lokales System gestartet wird.

Erklärung

Dieser Fehler kann auftreten, wenn der Microsoft Exchange-Informationsspeicherdienst (Store.exe) ein anderes Konto als Lokales System verwendet oder die Domänencontroller-, Domänen- oder lokale Sicherheitsrichtlinie nicht das Konto Lokaler Dienst in der Richtlinie Sicherheitsüberprüfung generieren aufweist. Wenn dieses Problem auftritt, kann der Exchange-Informationsspeicherdienst nicht initialisiert werden. Der Fehler tritt in den folgenden Versionen von Exchange Server auf:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Benutzeraktion

Um dieses Problem zu beheben, führen Sie einen oder mehrere der folgenden Schritte aus:

  • Der Exchange-Informationsspeicherdienst verwendet standardmäßig das Konto Lokales System, um den Informationsspeicherdienst (MACHINENAME$) zu starten. Überprüfen Sie mithilfe des Snap-Ins Services.msc, mit welchem Konto der Informationsspeicherdienst gestartet wird. Handelt es sich beim Konto um Lokales System, müssen Sie diesem Konto das Recht Sicherheitsüberprüfung generieren erteilen. Befolgen Sie dazu eine der folgenden Methoden:

    • Führen Sie auf dem aktuellen Computer den Exchange-Setupbefehl /domainprep erneut aus.

    • Erteilen Sie dem Konto Lokales System manuell das Recht Sicherheitsüberprüfung generieren für eine der folgenden Richtlinien:

    1. Richtlinie des Domänencontrollers

    2. Domänenrichtlinie

    3. Lokale Sicherheitsrichtlinie

      Um dieses Recht der lokalen Sicherheitsrichtlinie eines Mitgliedsservers erneut zu erteilen, führen Sie diese Schritte aus.

      Hinweis:
      Dies ist die empfohlene Lösung, wenn dieses Problem nur auf einem Server auftritt.
      So erteilen Sie der lokalen Sicherheitsrichtlinie eines Mitgliedsservers erneut Überprüfungsrechte

      1. Klicken Sie auf Start, dann auf Verwaltung und anschließend auf Lokale Sicherheitsrichtlinie.

      2. Erweitern Sie Sicherheitseinstellungen, klicken Sie auf Lokale Richtlinien und anschließend auf Zuweisen von Benutzerrechten.

      3. Doppelklicken Sie im rechten Bereich auf Sicherheitsüberprüfung generieren, klicken Sie auf Hinzufügen, geben Sie die MACHINENAME$ ein, und klicken Sie anschließend zweimal auf OK.

      4. Beenden Sie das Snap-In Gruppenrichtlinie.
  • Wenn Sie den Informationsspeicherdienst mithilfe eines anderen Kontos als Lokales System starten, müssen Sie zum Konto Lokales System (MACHINENAME$) zurückkehren. Versuchen Sie anschließend, den Informationsspeicherdienst zu starten. Weitere Informationen zu den Gründen, warum Exchange 2000 Server und Exchange Server 2003 das Konto Lokales System zum Starten von Exchange-Diensten verwenden, finden Sie im Microsoft Knowledge Base-Artikel 239762, Exchange Services Run Under LocalSystem.

Weitere Informationen

Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 281850, Information store does not start with event ID 9530 and 5000 messages in Exchange 2000 Server and in Exchange Server 2003.


MSExchangeIS 5000 (0x80004005): Datenbank kann aufgrund eines falschen Dienstkontos, fehlender "SeSecurityPrivilege"-Berechtigungen oder falscher Gruppenmitgliedschaft nicht bereitgestellt werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-02-19

Das Microsoft Exchange-Tool Datenbank-Problembehandlung hat im Anwendungsprotokoll ein oder mehrere MSExchangeIS 5000-Ereignisse mit dem Fehlercode 0x80004005 festgestellt. Das Ereignis bedeutet, dass auf dem Server mit Exchange eine oder mehrere Datenbanken aufgrund eines falschen Dienstkontos, fehlender "SeSecurityPrivilege"-Berechtigungen oder falscher Gruppenmitgliedschaft nicht bereitgestellt werden können.

Erklärung

Dieses Ereignis kann auftreten, wenn eine der folgenden Bedingungen vorliegt:

  • Die Berechtigung Überwachungs- und Sicherheitsprotokoll verwalten (SeSecurityPrivilege) wurde auf einem oder mehreren Domänencontrollern aus der Gruppe Exchange Enterprise Servers entfernt. Die Gruppe Exchange Enterprise Servers benötigt die Berechtigung Überwachungs- und Sicherheitsprotokoll verwalten auf allen Domänencontrollern in der Domäne. Wenn diese Bedingung zutrifft, können ein oder mehrere Exchange Server-bezogene Dienste nicht gestartet werden.

  • Der Microsoft Exchange-Informationsspeicherdienst wird mit einem anderen Konto als Lokales System gestartet, oder die Domänencontroller-, Domänen- oder lokale Sicherheitsrichtlinie enthält nicht das Konto Lokaler Dienst in der Richtlinie Sicherheitsüberprüfung generieren. Liegt diese Bedingung vor, wird der Exchange-Informationsspeicherdienst nicht gestartet.

  • Die Gruppe Exchange Enterprise Servers in der übergeordneten Domäne enthält nicht die Gruppe Exchange Domain Servers in der untergeordneten Domäne.

Das Ereignis kann auch als MAPI_E_CALL_FAILED auftreten. Dieses Ereignis tritt in den folgenden Versionen von Exchange Server auf:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Benutzeraktion

Um das Problem zu beheben, führen Sie einen oder mehrere der folgenden Schritte aus:

  • Wenn die Berechtigung zum Verwalten des Überwachungs- und Sicherheitsprotokolls (SeSecurityPrivilege) auf einem oder mehreren Domänencontrollern aus der Gruppe Exchange Enterprise Servers entfernt wurde, führen Sie diese Schritte aus.

    So fügen Sie Berechtigungen auf einem oder mehreren Domänencontrollern hinzu

    1. Verwenden Sie Policytest.exe zum Beheben von Problemen mit Berechtigungen. Policytest.exe befindet sich im Ordner Support\Utils\I386 auf der Exchange 2000 Server-CD bzw. im Ordner Support\ExDeploy auf der Exchange Server 2003-CD. Ermitteln Sie mithilfe von Policytest.exe, ob die Berechtigung zum Verwalten des Überwachungs- und Sicherheitsprotokolls für die Gruppe Exchange Enterprise Servers auf einem Domänencontroller fehlt. Ein erfolgreiches Ergebnis gibt Informationen ähnlich den folgenden zurück:

      Local domain is "<contoso.com>" (contoso) Account is "CONTOSO\Exchange Enterprise Servers" DC = "<ComputerName>" In site = "<Default-First-Site-Name>" Right found: "SeSecurityPrivilege"

      Hinweis Ein erfolgreiches Ergebnis zeigt, dass die Berechtigung zum Verwalten des Überwachungs- und Sicherheitsprotokolls vorliegt. Zum Ausführen von Policytest.exe müssen Sie über Berechtigungen der Gruppe Domänenadministratoren verfügen. Weitere Informationen über das Dienstprogramm Policytest.exe finden Sie im Microsoft Knowledge Base-Artikel 281537, XADM: Beschreibung des Dienstprogramms "Policytest.exe".

    2. Setzen Sie die Exchange Enterprise Server-Standardberechtigungen auf Domänenebene zurück. Führen Sie dazu die folgenden Schritte durch:

      1. Führen Sie den Befehl setup /domainprep von der Exchange Server-CD oder von einem Netzwerkinstallationspunkt aus. Der Befehl setup /domainprep fügt die Gruppe Exchange Enterprise Servers zur Domäne mit den Standardberechtigungen hinzu. Wenn Sie den Befehl setup /domainprep ausführen, werden die Berechtigungen sofort zu einem Domänencontroller hinzugefügt. Anschließend wird die Änderung auf die anderen Domänencontroller repliziert.

      2. Stellen Sie die Berechtigungsvererbung auf andere Organisationseinheiten wieder her. Warten Sie anschließend, bis die Änderungen von den Domänencontrollern in der gesamten Domäne repliziert wurden.

      3. Führen Sie Policytest.exe aus. Achten Sie darauf, welche Domänencontroller das folgende erfolgreiche Ergebnis zurückgeben:

        Right found: "SeSecurityPrivilege"

        Wenn alle Domänencontroller über die korrekten Berechtigungen verfügen, starten Sie die Exchange Server-Dienste neu. Wenn kein Domänencontroller über die korrekten Berechtigungen verfügen, lesen Sie unter Schritt 3 weiter.

    3. Überprüfen Sie die Richtlinie des Standarddomänencontrollers. Führen Sie dazu die folgenden Schritte durch:

      1. Starten Sie das Snap-In Active Directory-Benutzer und -Computer.

      2. Klicken Sie mit der rechten Maustaste auf den Container Domänencontroller, und klicken Sie dann auf Eigenschaften.

      3. Klicken Sie auf die Registerkarte Gruppenrichtlinie, und vergewissern Sie sich, dass Standard-Domänencontrollerrichtlinie im Feld Gruppenrichtlinienobjekt-Verknüpfungen aufgeführt ist.Hinweis Wenn Standard-Domänencontrollerrichtlinie nicht angezeigt wird, klicken Sie auf Hinzufügen und dann auf Standard-Domänencontrollerrichtlinie. Klicken Sie anschließend auf OK. Warten Sie, bis diese Änderung auf alle anderen Domänencontroller repliziert wurde.

      4. Führen Sie den Befehl setup /domainprep von der Exchange Server-CD oder von einem Netzwerkinstallationspunkt aus. Der Befehl setup /domainprep fügt die Gruppe Exchange Enterprise Servers zur Domäne mit den Standardberechtigungen hinzu.

      5. Führen Sie Policytest.exe aus. Achten Sie darauf, welche Domänencontroller das folgende erfolgreiche Ergebnis zurückgeben:

      Right found: "SeSecurityPrivilege"

      Wenn alle Domänencontroller über die korrekten Berechtigungen verfügen, starten Sie die Exchange Server-Dienste neu. Wenn einige Domänencontroller nicht über die korrekten Berechtigungen verfügen, lesen Sie unter Schritt 4 weiter.

    4. Fügen Sie manuell Berechtigungen zum Domänencontroller hinzu. Möglicherweise wird die aktualisierte Sicherheitsrichtlinie vom Dateireplikationsdienst (FRS) nach Ausführen des Befehls setup /domainprep auf einen oder mehrere Domänencontroller nicht repliziert. Wenn dieses Problem auftritt, müssen Sie der Gruppe Exchange Enterprise Servers die korrekten Berechtigungen manuell zuweisen. Wenn einige oder alle Domänencontroller nicht über die korrekten Berechtigungen verfügen, weisen Sie der Gruppe Exchange Enterprise Servers die Berechtigung zum Verwalten des Überwachungs- und Sicherheitsprotokolls zu. Warten Sie, bis diese Einstellung auf die anderen Domänencontroller repliziert wurde. Führen Sie dazu die folgenden Schritte durch:

      1. Starten Sie das Snap-In Active Directory-Benutzer und -Computer.

      2. Klicken Sie mit der rechten Maustaste auf den Container Domänencontroller, und klicken Sie dann auf Eigenschaften.

      3. Klicken Sie auf die Registerkarte Gruppenrichtlinie, klicken Sie dann auf Standard-Domänencontrollerrichtlinie im Feld Gruppenrichtlinienobjekt-Verknüpfungen, und klicken Sie schließlich auf Bearbeiten.

      4. Erweitern Sie Computerkonfiguration, erweitern Sie Windows-Einstellungen, erweitern Sie Sicherheitseinstellungen, erweitern Sie Lokale Richtlinien, und klicken Sie dann auf Zuweisen von Benutzerrechten.

      5. Doppelklicken Sie im rechten Bereich auf Verwalten von Überwachungs- und Sicherheitsprotokollen, klicken Sie auf Hinzufügen, klicken Sie auf Durchsuchen, und fügen Sie dann die Gruppe Exchange Enterprise Servers hinzu.

      6. Klicken Sie im Dialogfeld Benutzer oder Gruppe hinzufügen auf OK. Klicken Sie noch einmal auf OK.

      7. Beenden Sie das Snap-In Gruppenrichtlinie, und klicken Sie dann im Dialogfeld mit den Domänencontrollereigenschaften auf OK.Hinweis Manchmal wird die Gruppe Exchange Enterprise Servers nicht angezeigt, wenn Sie im Dialogfeld Benutzer oder Gruppe hinzufügen auf Durchsuchen klicken. Tritt dies auf, fügen Sie die Gruppe Exchange Domain Servers hinzu. Führen Sie den Befehl setup /domainprep anschließend erneut aus. Hierdurch wird die Hinzufügung der Gruppe Exchange Enterprise Servers auf alle Domänencontroller übernommen.
  • Wird der Exchange-Informationsspeicherdienst mit einem anderen Konto als Lokales System gestartet, oder enthält die Domänencontroller-, Domänen- oder lokale Sicherheitsrichtlinie nicht das Konto Lokaler Dienst in der Richtlinie Sicherheitsüberprüfung generieren, befolgen Sie die hier beschriebene Auflösung.

    Der Exchange-Informationsspeicherdienst verwendet standardmäßig das Konto Lokales System, um den Informationsspeicherdienst (MACHINENAME$) zu starten. Überprüfen Sie mithilfe des Snap-Ins Services.msc, mit welchem Konto der Informationsspeicherdienst gestartet wird. Handelt es sich bei dem Konto um Lokales System, müssen Sie diesem Konto das Recht Sicherheitsüberprüfung generieren erneut erteilen. Befolgen Sie dazu eine der folgenden Methoden:

    So erteilen Sie dem Konto "Lokales System" das Recht "Sicherheitsüberprüfung generieren" erneut

    1. Führen Sie auf dem aktuellen Computer den Exchange-Befehl Setup /domainprep erneut aus.

    2. Erteilen Sie dem Konto Lokales System manuell das Recht Sicherheitsüberprüfung generieren für eine der folgenden Richtlinien:

      • Richtlinie des Domänencontrollers

      • Domänenrichtlinie

      • Lokale Sicherheitsrichtlinie

    So erteilen Sie der lokalen Sicherheitsrichtlinie eines Mitgliedsservers erneut das Recht "Sicherheitsüberprüfung generieren"

    1. Klicken Sie auf Start, dann auf Verwaltung und anschließend auf Lokale Sicherheitsrichtlinie.

    2. Erweitern Sie Sicherheitseinstellungen, klicken Sie auf Lokale Richtlinien und anschließend auf Zuweisen von Benutzerrechten.

    3. Doppelklicken Sie im rechten Bereich auf Sicherheitsüberprüfung generieren, klicken Sie auf Hinzufügen, geben Sie die MACHINENAME$ ein, und klicken Sie anschließend zweimal auf OK.

    4. Beenden Sie das Snap-In Gruppenrichtlinie.

    Wenn Sie den Informationsspeicherdienst mithilfe eines anderen Kontos als Lokales System starten, müssen Sie zum Konto Lokales System (MACHINENAME$) zurückkehren. Versuchen Sie anschließend, den Informationsspeicherdienst zu starten. Weitere Informationen zu den Gründen, warum Exchange 2000 Server und Exchange Server 2003 das Konto Lokales System zum Starten von Exchange-Diensten verwenden, finden Sie im Microsoft Knowledge Base-Artikel 239762, Exchange-Dienste werden unter LocalSystem ausgeführt.

  • Wenn die Gruppe Exchange Enterprise Servers in der übergeordneten Domäne nicht die Gruppe Exchange Domain Servers in der untergeordneten Domäne enthält, fügen Sie die Exchange Domain Servers in der untergeordneten Domäne der Gruppe Exchange Enterprise Servers in der übergeordneten Domäne hinzu. Sie können dieses Problem auch beheben, indem Sie in der Stammdomäne den Empfängeraktualisierungsdienst erstellen.

    Zum Beheben dieses Problems führen Sie das Exchange-Setup mit der Option /domainprep auf einem Server in der Windows-Remotedomäne aus. Verwenden Sie dann auf dem Exchange-Server den Exchange-System-Manager, um einen Empfängeraktualisierungsdienst für die Remotedomäne zu erstellen. Führen Sie dazu die folgenden Schritte durch:

    So erstellen Sie eine Empfängeraktualisierungsdienst für die Remotedomäne

    1. Klicken Sie auf Start, klicken Sie auf Programme, klicken Sie auf Microsoft Exchange, und klicken Sie dann auf System-Manager.

    2. Erweitern Sie das Objekt Organisation, und erweitern Sie dann den Container Empfänger.

    3. Klicken Sie auf Empfängeraktualisierungsdienst.

    4. Klicken Sie im rechten Bereich mit der rechten Maustaste auf Neu, und klicken Sie dann auf Empfängeraktualisierungsdienst.

    5. Klicken Sie auf die Domäne, die Benutzer enthält, die von Exchange aktualisiert werden müssen, aber über keine Instanz des Empfängeraktualisierungsdiensts verfügt.

    6. Klicken Sie auf Weiter.

    7. Wählen Sie den Server aus, auf dem Sie den Empfängeraktualisierungsdienst ausführen und alle erforderlichen Benutzer mit den Exchange-Attributen verarbeiten möchten.

    8. Klicken Sie auf Weiter.

    9. Klicken Sie auf Fertig stellen.

    10. Um eine Aktualisierung der Empfänger in dieser Domäne manuell durchzuführen, klicken Sie mit der rechten Maustaste auf Empfängeraktualisierungsdienst, und klicken Sie dann auf Jetzt aktualisieren, um eine Aktualisierung zu erzwingen.
    Weitere Informationen finden Sie in Microsoft Knowledge Base-Artikel 253770 Tasks, die vom Empfängeraktualisierungsdienst von Exchange ausgeführt werden.


MSExchangeIS 5000 (0x80040154): Fehlende oder beschädigte SMTP-Diensterweiterungen
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-02-19

Das Microsoft Exchange-Tool Datenbank-Problembehandlung hat im Anwendungsprotokoll ein oder mehrere MSExchangeIS 5000-Ereignisse mit dem Fehlercode 0x80040154 festgestellt. Dieser Fehler kann auftreten, wenn die SMTP-Diensterweiterungen (Simple Mail Transfer Protocol) für Exchange Server entweder fehlen oder beschädigt sind.

Erklärung

Diese Problem tritt auf, da die SMTP-Diensterweiterungen für Exchange Server entweder fehlen oder beschädigt sind. Dieser Umstand führt zu einem Funktionalitätsverlust zwischen Exchange und dem SMTP-Dienst. Der SMTP-Dienst ist ein erforderlicher Dienst, der als Unterkomponente von Microsoft-Internetinformationsdienste (IIS) installiert wird.

Dieser Fehler kann aus folgenden Gründen auftreten:

  • IIS wurde entfernt.

  • Die Unterkomponente SMTP-Dienst wurde aus IIS entfernt.

  • IIS wurde entfernt und anschließend als eine Windows-Komponente neu installiert, die nicht die erforderliche Unterkomponente SMTP-Dienst aufweist.

  • IIS wurde entfernt und anschließend als eine Windows-Komponente neu installiert, die die entsprechende Liste von Unterkomponenten aufweist. Allerdings wurden die SMTP-Diensterweiterungen für Exchange nicht erneut installiert.

Dieser Fehler tritt in den folgenden Versionen von Exchange Server auf:

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Benutzeraktion

Um diesen Fehler zu beheben, lesen Sie den Microsoft Knowledge Base-Artikel 326305, Der Informationsspeicher startet nicht, und in Exchange 2000 Server und Exchange Server 2003 treten MSExchangeIS-Meldungen mit der Ereignis-ID 5000 und 9538 auf.

So stellen Sie SMTP-Diensterweiterungen wieder her

  1. Überprüfen Sie, ob die Exchange SMTP-Diensterweiterungen fehlen. Führen Sie dazu die folgenden Schritte durch:

    1. Melden Sie sich beim Microsoft Exchange-Computer mit einem Konto an, das über Administratorberechtigungen verfügt.

    2. Klicken Sie im Menü Start auf Ausführen, geben Sie cmd ein, und klicken Sie auf OK.

    3. Geben Sie telnet 127.0.0.1 25 an der Eingabeaufforderung ein, um den Eintrag "220 server.domain.com Microsoft ESMTP Mail Service" anzuzeigen.

    4. Geben Sie EHLO ein, und drücken Sie die EINGABETASTE, um eine Liste der 250-Befehlsverben anzuzeigen. Wenn keine Verben vorliegen, deren Namen mit "X" beginnen, fehlen die SMTP-Diensterweiterungen.

  2. Erstellen Sie eine vollständige Sicherungskopie der Systempartition. Sichern Sie dabei auch den Systemstatus und die Exchange-Datenbankdateien. Weitere Informationen zur Vorgehensweise finden Sie im Microsoft Knowledge Base-Artikel 258243, Sichern und Wiederherstellen eines Exchange-Computers mithilfe des Windows-Sicherungsprogramms.

  3. Vergewissern Sie sich, dass IIS ordnungsgemäß neu installiert wurde und die erforderlichen Exchange-abhängigen Unterkomponenten enthält.

    IIS 6.0

    1. Klicken Sie auf Start, zeigen Sie auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

    2. Doppelklicken Sie auf Software.

    3. Klicken Sie im linken Bereich auf Windows-Komponenten hinzufügen/entfernen.

    4. Suchen Sie im Assistenten für Windows-Komponenten den Eintrag Anwendungsserver in der Liste der Komponenten, und klicken Sie dann auf Details.

    5. Wenn eine oder mehrere der folgenden Komponenten nicht aufgeführt sind, installieren Sie sie:

      ASP.NET

      COM+-Netzwerkzugriff aktivieren

      IIS (Internetinformationsdienste)

    6. Klicken Sie auf Internetinformationsdienste (IIS) und dann auf Details.

    7. Wenn eine oder mehrere der folgenden Komponenten nicht aufgeführt sind, installieren Sie sie:

      Gemeinsame Dateien

      Internetinformationsdienste-Manager

      NNTP-Dienst

      SMTP-Dienst

      WWW-Dienst

    8. Klicken Sie zweimal auf OK. Klicken Sie auf der Hauptseite der Windows-Komponenten auf Weiter und anschließend auf Fertig stellen.

    IIS 5.0

    1. Klicken Sie auf Start, zeigen Sie auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

    2. Doppelklicken Sie auf Software.

    3. Klicken Sie im linken Bereich auf Windows-Komponenten hinzufügen/entfernen.

    4. Suchen Sie im Dialogfeld des Assistenten für Windows-Komponenten in der Liste der Komponenten die Internetinformationsdienste (IIS). Ist das Kontrollkästchen Internetinformationsdienste (IIS) aktiviert, ist IIS installiert. Zum Anzeigen der installierten IIS-Unterkomponenten klicken Sie auf Internetinformationsdienste (IIS) und dann auf Details.

    5. Ist IIS nicht installiert, aktivieren Sie das Kontrollkästchen Internetinformationsdienste (IIS), und klicken Sie dann auf Details. Installieren Sie die IIS 5.0-Unterkomponenten, und klicken Sie dann auf OK. Folgende IIS 5.0-Unterkomponenten müssen vor der Installation von Exchange 2000 mindestens vorhanden sein:

      Gemeinsame Dateien

      Internetinformationsdienste-Snap-In

      SMTP-Dienst

      NNTP-Dienst (für Newsgroups)

      WWW-Dienst

    6. Klicken Sie auf Weiter und dann auf Fertig stellen.

  4. Stellen Sie die Exchange SMTP-Diensterweiterungen wieder her.

    Exchange Server 2003

    Wenn Sie Exchange 2003 über eine vorhandene Exchange 2003-Installation neu installieren, bleiben die Datenbankdateien und Berechtigungen erhalten. Führen Sie dazu die folgenden Schritte durch:

    1. Legen Sie die Exchange 2003-CD ein.

    2. Doppelklicken Sie im Ordner \SETUP\I386 auf die Datei Setup.exe.

    3. Klicken Sie auf der Seite Willkommen auf Weiter, bis Sie auf die Seite Auswahl der Komponenten gelangen.

    4. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Aktion auf Neu installieren, und klicken Sie dann auf Weiter.

    5. Überprüfen Sie die Auswahl auf der Seite Installationszusammenfassung, und klicken Sie dann auf Weiter, um mit der Exchange 2003-Installation fortzufahren.

    Exchange 2000 Server

    Welche Methoden Sie zum Wiederherstellen der Exchange 2000 SMTP-Diensterweiterungen verwenden können, hängt davon ab, wie viele IIS-Unterkomponenten entfernt wurden. Wenn nur die IIS-Unterkomponente SMTP-Dienst entfernt und Exchange 2000 Server Service Pack 2 (SP2) oder ein höheres Service Pack installiert wurde, verwenden Sie das Befehlszeilenprogramm Smtpreinstall.exe. Das Befehlszeilenprogramm Smtpreinstall.exe befindet sich im Ordner Server\Support\Utils\I386.

    So verwenden Sie das Dienstprogramm "Smtpreinstall.exe"

    1. Kopieren Sie die Datei Smtpreinstall.exe in den Ordner \Exchsrvr\Bin.

    2. Wechseln Sie an der Eingabeaufforderung in den Ordner \Exchsrvr\Bin, und geben Sie den folgenden Befehl ein:

      smtpreinstall.exe

    3. Starten Sie den Computer neu, wenn Sie dazu aufgefordert werden.

    Wenn die Komponente IIS 5.0 entfernt wurde, oder wenn außer dem SMTP-Dienst noch weitere IIS 5.0-Unterkomponenten entfernt wurden, installieren Sie Exchange 2000 über die vorhandene Installation als Teil des integrierten Setups von Microsoft Small Business Server 2000 neu.

    So installieren Sie Exchange 2000 Server neu

    Hinweis:
    Wenn Sie Exchange 2000 über eine vorhandene Exchange 2000-Installation neu installieren, bleiben die Datenbankdateien und Berechtigungen erhalten.
    1. Legen Sie die Exchange 2000 Server-CD ein.

    2. Doppelklicken Sie im Ordner \SETUP\I386 auf die Datei Setup.exe.

    3. Klicken Sie auf der Seite Willkommen auf Weiter.

    4. Geben Sie den CD-Schlüssel ein, wenn Sie dazu aufgefordert werden, und klicken Sie dann auf Weiter.

    5. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Aktion auf Neu installieren, und klicken Sie dann auf Weiter.

    6. Überprüfen Sie die Auswahl auf der Seite Installationszusammenfassung, und klicken Sie dann auf Weiter, um mit der Exchange 2000-Installation fortzufahren.

  5. Installieren Sie die Exchange-Service Packs und -Hotfixes neu.

    Weitere Informationen finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

    836993 Wie Sie die neuesten Service Packs für Exchange Server 2003 erhalten.

    301378 Wie Sie das neueste Service Pack für Exchange 2000 Server erhalten.


MSExchangeIS 5000 (0xc004038a): Datenbank kann aufgrund falscher Berechtigungen oder gelöschter Routinggruppe nicht bereitgestellt werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-05-31

Das Microsoft Exchange-Tool Datenbank-Problembehandlung hat im Anwendungsprotokoll ein oder mehrere MSExchangeIS 5000-Ereignisse mit dem Fehlercode 0xc004038a festgestellt. Tritt dieser Fehler auf, wird der Microsoft Exchange-Informationsspeicherdienst nicht initialisiert, und Datenbanken werden nicht bereitgestellt.

Erklärung

Das Ereignis MSExchangeIS 5000 mit dem Fehlercode 0xc004038a kann aufgrund falscher Berechtigungen oder einer gelöschten Routinggruppe auftreten. Dieses Ereignis kann aufgrund einer oder mehrerer der folgenden Ursachen auftreten:

  • Der Server mit Exchange Server gehört keiner Routinggruppe mehr an, oder seine Routinggruppe wurde aus Active Directory gelöscht.

  • Die Gruppe Exchange Domain Servers verfügt in Active Directory nicht über die benötigten Berechtigungen.

Diese Ereignis tritt in den folgenden Versionen von Exchange Server auf:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Benutzeraktion

Um den Fehler zu beheben, führen Sie einen oder mehrere der folgenden Schritte aus:

  • Wenn die Gruppe Exchange Domain Servers nicht über die entsprechenden Berechtigungen verfügt, verwenden Sie das Dienstprogramm ADSI-Bearbeitung (Active Directory Service Interfaces), um sicherzustellen, dass die Gruppe Exchange Domain Servers über die benötigten Berechtigungen in Active Directory verfügt. Stellen Sie sicher, dass auf der Registerkarte Sicherheit das Kontrollkästchen Berechtigungen übergeordneter Objekte, sofern vererbbar, über alle untergeordneten Objekte verbreiten in der Gruppe Administratoren, der Gruppe Exchange Domain Servers und allen anderen für Ihre Konfiguration relevanten Gruppen aktiviert ist.

    Hinweis:
    Erzwingen Sie, falls erforderlich, die Replikation unter den Domänencontrollern, um dafür zu sorgen, dass die Änderungen in der gesamten Domäne verbreitet werden.
    Hinweis:
    Das Tool ADSI-Bearbeitung ist in den Microsoft Windows 2000- und Microsoft Windows Server 2003-Supporttools enthalten, die Sie auf der Windows 2000- und Windows 2003-Installations-CD finden.
  • Wenn der Server mit Exchange keiner Routinggruppe mehr angehört oder seine Routinggruppe aus Active Directory gelöscht wurde, fügen Sie die Routinggruppe hinzu, oder stellen Sie die Routinggruppe wieder her. Befolgen Sie die hier beschriebene Auflösung für das Problem, das Ihrem Szenario am besten entspricht:

Auflösung 1: Fügen Sie den Server zur Routinggruppe hinzu. Vergewissern Sie sich anhand der folgenden Schritte, dass der Server kein Mitglied der Routinggruppe mehr ist:

  1. Starten Sie den Exchange-System-Manager.

  2. Erweitern Sie Organisation, Administrative Gruppen und AdministrativeGroupName, und erweitern Sie dann Routinggruppen.

    Hinweis:
    In diesem Schritt ist AdministrativeGroupName der Name der administrativen Gruppe.
  3. Durchsuchen Sie alle verfügbaren Routinggruppen, und vergewissern Sie sich, dass der Server nicht aufgelistet ist.

    Hinweis:
    Wenn keine Routinggruppen angezeigt werden, lesen Sie unter Auflösung 2 weiter.
  4. Nachdem Sie überprüft haben, dass dieser Server kein Mitglied einer Routinggruppe ist, fügen Sie den Server wieder zu einer vorhandenen Routinggruppe hinzu. Führen Sie dazu die folgenden Schritte durch:

    Wichtig:
    Falls Sie das ADSI-Bearbeitungs-Snap-In, das LDAP-Dienstprogramm oder einen anderen LDAP-Client Version 3 verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme können dazu führen, dass Sie Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003 oder sowohl Windows als auch Exchange neu installieren müssen. Microsoft übernimmt keine Garantie dafür, dass Probleme, die durch eine nicht ordnungsgemäße Änderung der Active Directory-Objektattribute verursacht werden, auch behoben werden können. Die Änderung der Attribute liegt in Ihrer Verantwortung.
So fügen Sie den Server wieder zur Routinggruppe hinzu

  1. Klicken Sie im Menü Start auf Ausführen, geben Sie adsiedit.msc ein, und klicken Sie auf OK.

    Hinweis:
    Das Tool ADSI-Bearbeitung ist in den Microsoft Windows 2000- und Microsoft Windows Server 2003-Supporttools enthalten. Zum Installieren dieser Supporttools führen Sie die folgenden Schritte aus:
    • Doppelklicken Sie für Windows 2000 Server-basierte Computer auf Setup.exe im Ordner Support\Tools auf der Windows 2000-CD, und befolgen Sie die Schritte im Setup-Assistenten für die Windows-Supporttools, um die Windows 2000-Supporttools zu installieren.

    • Klicken Sie für Windows Server 2003-basierte Computer mit der rechten Maustaste auf Suptools.msi im Ordner Support\Tools auf der Windows Server 2003-CD, klicken Sie auf Installieren, und befolgen Sie die Schritte im Setup-Assistenten für die Windows-Supporttools, um die Windows Server 2003-Supporttools zu installieren.

  2. Erweitern Sie Configuration [ servername.domain_name.com ], erweitern Sie CN=Configuration, DC= domain_name, DC= com, erweitern Sie CN=Services, erweitern Sie CN=Microsoft Exchange, erweitern Sie CN= OrganizationName, erweitern Sie CN=Administrative Gruppen, erweitern Sie CN= AdministrativeGroupName, und klicken Sie dann auf CN=Routinggruppen.

    Hinweis:
    In diesem Schritt ist "servername" der Name des Servers, "domain_name.com" der Name der Domäne, "OrganizationName" der Name der Exchange Server-Organisation und "AdministrativeGroupName" der Name der administrativen Gruppe.

  3. Klicken Sie mit der rechten Maustaste auf die Routinggruppe, zu der Sie den Server als Mitglied hinzufügen möchten, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf das Attribut distinguishedName, und klicken Sie anschließend auf Bearbeiten.

  5. Kopieren Sie den Wert des Attributs distinguishedName in den Editor.

  6. Klicken Sie zweimal auf Abbrechen, um die Eigenschaften zu schließen.

  7. Im Tool ADSI-Bearbeitung erweitern Sie Configuration [ servername.domain_name.com ], erweitern Sie CN=Configuration,DC= domain_name, DC= com, erweitern Sie CN=Services, erweitern Sie CN=Microsoft Exchange, erweitern Sie CN= OrganizationName, erweitern Sie CN=Administrative Gruppen, erweitern Sie CN= AdministrativeGroupName, und erweitern Sie dann CN=Servers.

  8. Klicken Sie mit der rechten Maustaste auf servername, und klicken Sie dann auf Eigenschaften.

  9. Klicken Sie auf das Attribut msExchHomeRoutingGroup, und klicken Sie anschließend auf Bearbeiten.

  10. Fügen Sie den Wert ein, den Sie in Schritt 5 in den Editor kopiert haben, und klicken Sie dann zweimal auf OK, um den neuen Wert zu speichern.

  11. Suchen Sie im Exchange-System-Manager die Routinggruppe, zu der Sie diesen Server hinzugefügt haben.

  12. Aktualisieren Sie den Exchange-System-Manager, um diesen Server anzuzeigen.

    Hinweis:
    Wenn der Exchange-Server nicht sofort angezeigt wird, warten Sie, bis die Active Directory-Replikation erfolgt.

  13. Ist für keine anderen Exchange-Server in dieser Routinggruppe der Servertyp auf Master festgelegt, klicken Sie mit der rechten Maustaste auf diesen Exchange-Server, und klicken Sie dann auf Als Master festlegen.

  14. Starten Sie den Informationsspeicherdienst und den Dienst MTA-Stacks.

Auflösung 2: Stellen Sie die Routinggruppe wieder her. Wenn Sie versehentlich eine Routinggruppe entfernen, stellen Sie diese aus der jüngsten Sicherung der Systemstatusdaten wieder her. Verfügen Sie über keine kürzliche Sicherung der Systemstatusdaten, setzen aber mehrere Domänencontroller ein, führen Sie eine autorisierende Wiederherstellung der gelöschten Routinggruppe durch.

So stellen Sie die Routinggruppe wieder her

  1. Starten Sie den Exchange-System-Manager, und erstellen Sie eine neue Routinggruppe mit demselben Namen wie die gelöschte Routinggruppe. Führen Sie dazu die folgenden Schritte durch:

    1. Erweitern Sie Administrative Gruppen und AdministrativeGroupName, und erweitern Sie dann Routinggruppen.

      In diesem Schritt ist AdministrativeGroupName der Name der administrativen Gruppe.

    2. Klicken Sie mit der rechten Maustaste auf Routinggruppen, zeigen Sie auf Neu, und klicken Sie dann auf Routinggruppe.

    3. Geben Sie im Feld Name den Namen der Routinggruppe ein, und klicken Sie dann auf OK.

      Verwenden Sie den Namen der versehentlich entfernten Routinggruppe.

    4. Beenden Sie den Exchange-System-Manager.

  2. Starten Sie die ADSI-Bearbeitung. Dazu klicken Sie auf Start und dann auf Ausführen. Geben Sie adsiedit.msc in das Feld Öffnen ein, und klicken Sie anschließend auf OK.

    Hinweis:
    Das Tool ADSI-Bearbeitung ist in den Microsoft Windows 2000- und Microsoft Windows Server 2003-Supporttools enthalten. So installieren Sie diese Supporttools
    • Doppelklicken Sie für Windows 2000 Server-basierte Computer auf Setup.exe im Ordner Support\Tools auf der Windows 2000-CD, und befolgen Sie die Schritte im Setup-Assistenten für die Windows-Supporttools, um die Windows 2000-Supporttools zu installieren.

    • Klicken Sie für Windows Server 2003-basierte Computer mit der rechten Maustaste auf Suptools.msi im Ordner Support\Tools auf der Windows Server 2003-CD, klicken Sie auf Installieren, und befolgen Sie die Schritte im Setup-Assistenten für die Windows-Supporttools, um die Windows Server 2003-Supporttools zu installieren.

  3. Erweitern Sie Configuration [servername.domain_name.com], erweitern Sie CN=Configuration, DC=domain_name, DC=com, erweitern Sie CN=Services, erweitern Sie CN=Microsoft Exchange, erweitern Sie CN=OrganizationName, erweitern Sie CN=Administrative Gruppen, erweitern Sie CN=AdministrativeGroupName, und klicken Sie dann auf CN=Routinggruppen.

    In diesem Schritt ist "servername" der Name des Servers, "domain_name.com" der Name der Domäne, "OrganizationName" der Name der Exchange Server-Organisation und "AdministrativeGroupName" der Name der administrativen Gruppe.

  4. Klicken Sie im rechten Bereich mit der rechten Maustaste auf die neu erstellte Routinggruppe, und klicken Sie dann auf Eigenschaften.

  5. Aktivieren Sie die Kontrollkästchen Verbindliche Attribute anzeigen und Optionale Attribute anzeigen, sofern sie nicht bereits aktiviert sind.

  6. Klicken Sie in der Liste Attribute auf msExchRoutingGroupMembersBL, und klicken Sie dann auf Bearbeiten.

    Die Liste Werte ist leer.

  7. Klicken Sie auf Abbrechen.

  8. Doppelklicken Sie in der Liste Attribute auf distinguishedName.

  9. Klicken Sie mit der rechten Maustaste auf den DN (Distinguished Name) im Feld Wert, und klicken Sie dann auf Kopieren.

  10. Starten Sie einen Texteditor, z. B. Editor, und klicken Sie dann im Menü Bearbeiten auf Einfügen, um den DN einzufügen.

  11. Klicken Sie im Dialogfeld Attribut-Editor für Zeichenfolgen auf Abbrechen, und klicken Sie dann erneut auf Abbrechen, um das Dialogfeld CN=RoutingGroupName zu schließen.

    In diesem Schritt ist RoutingGroupName der Name der Routinggruppe.

  12. Klicken Sie im Tool ADSI-Bearbeitung unter CN=AdministrativeGroupName auf CN=Servers.

  13. Klicken Sie mit der rechten Maustaste im rechten Bereich auf CN=ServerName, und klicken Sie dann auf Eigenschaften.

    In diesem Schritt ist ServerName einer der Exchange-Computer in dieser Routinggruppe.

  14. Klicken Sie in der Liste Attribute auf msExchHomeRoutingGroup, und klicken Sie dann auf Bearbeiten.

  15. Fügen Sie den DN (Distinguished Name), den Sie in den Schritten 9 und 10 kopiert haben, in das Feld Wert ein, und klicken Sie dann auf OK.

  16. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.

  17. Wiederholen Sie die Schritte 13 bis 15 für jeden Server, der Mitglied der versehentlich entfernten Routinggruppe war.

  18. Klicken Sie unter CN=AdministrativeGroupName auf CN=Routinggruppen.

  19. Klicken Sie im rechten Bereich mit der rechten Maustaste auf die neu erstellte Routinggruppe, und klicken Sie dann auf Eigenschaften.

  20. Klicken Sie in der Liste Attribute auf msExchRoutingGroupMembersBL, und klicken Sie dann auf Bearbeiten.

    Die Liste Werte ist nicht mehr leer.

  21. Klicken Sie zweimal auf Abbrechen.

  22. Beenden Sie ADSI-Bearbeitung.

  23. Legen Sie den Routinggruppenmaster mithilfe des Exchange-System-Managers fest. Führen Sie dazu die folgenden Schritte durch:

    1. Starten Sie den Exchange-System-Manager.

    2. Erweitern Sie Administrative Gruppen und AdministrativeGroupName, und erweitern Sie dann Routinggruppen.

    3. Erweitern Sie die neu erstellte Routinggruppe, und klicken Sie anschließend auf Mitglieder.

    4. Klicken Sie im rechten Bereich mit der rechten Maustaste auf den Exchange-Computer, den Sie als Routinggruppenmaster konfigurieren möchten, und klicken Sie dann auf Als Master festlegen.

    5. Beenden Sie den Exchange-System-Manager.

  24. Warten Sie, bis die Änderungen in der gesamten Domäne verbreitet wurden.

  25. Starten Sie die beendeten Microsoft Exchange-Dienste.


MSExchangeIS 5000 (0x8004010f): Datenbank kann aufgrund falscher Berechtigungen oder ungültiger Zeichen im Organisationsnamen nicht bereitgestellt werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-01-23

Das Microsoft® Exchange-Tool Datenbank-Problembehandlung hat im Protokoll Anwendung ein oder mehrere MSExchangeIS 5000-Ereignisse mit dem Fehlercode 0x8004010f festgestellt. Das Ereignis bedeutet, dass auf dem Server mit Exchange eine oder mehrere Datenbanken aufgrund falscher Berechtigungen oder ungültiger Zeichen im Exchange-Organisationsnamen nicht bereitgestellt werden können.

Erklärung

Das Ereignis MSExchangeIS 5000 mit dem Fehlercode 0x8004010f kann nur auftreten, wenn eine der folgenden Bedingungen vorliegt:

  • Der authentifizierte Benutzer hat keinen Lesezugriff auf die Active Directory-Container Domain oder Configuration. Wenn diese Bedingung beim Versuch der Installation eines zweiten Servers mit Exchange in einer administrativen Gruppe vorliegt, die bereits einen Server mit Exchange enthält, können Sie den zweiten Server ggf. nicht installieren. Darüber hinaus kann der Microsoft Exchange-Informationsspeicherdienst ggf. nicht gestartet werden.

  • Die Lesezugriffsberechtigung für das Konto Jeder fehlt in Active Directory im Container WellKnown Security Principals unterhalb des Containers Configuration. Liegt diese Bedingung vor, wird der Exchange-Informationsspeicherdienst auf einem Mitgliedsserver nicht gestartet.

  • Der Exchange-Organisationsname enthält nicht unterstützte Zeichen. Liegt diese Bedingung nach der Installation von Exchange 2000 Server oder Exchange Server 2003 vor, kann der Exchange-Informationsspeicherdienst ggf. nicht gestartet werden, und die Ereignisse MSExchangeIS 5000 und MSExchangeIS 1121 werden ggf. im Protokoll Anwendung aufgezeichnet.

Das Ereignis kann auch als MAPI_E_NOT_FOUND auftreten. Dieses Ereignis tritt in den folgenden Versionen von Exchange Server auf:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Benutzeraktion

Um das Problem zu beheben, führen Sie einen oder mehrere der folgenden Schritte aus.

Wichtig:
Falls Sie das Snap-In ADSI-Bearbeitung (Active Directory Service Interfaces), das LDP-Dienstprogramm oder einen anderen LDAP Version 3-Client verwenden und die Attribute des Active Directory-Verzeichnisdiensts nicht ordnungsgemäß ändern, können schwerwiegende Probleme auftreten. Diese Probleme können dazu führen, dass Sie Microsoft Windows® 2000 Server, Microsoft Windows Server™ 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003 oder sowohl Windows als auch Exchange neu installieren müssen. Microsoft übernimmt keine Garantie dafür, dass Probleme, die durch eine nicht ordnungsgemäße Änderung der Active Directory-Objektattribute verursacht werden, behoben werden können. Die Änderung der Attribute liegt in Ihrer Verantwortung.
  • Wenn authentifizierte Benutzer in Active Directory in den Containern Domain oder Configuration keinen Lesezugriff haben, verwenden Sie das Tool ADSI-Bearbeitung in Exchange Server 2003 und Exchange 2000 Server, um authentifizierten Benutzer in Active Directory in den Containern Domain oder Configuration Lesezugriff zu gewähren. Gehen Sie folgendermaßen vor:

    Hinweis:
    Das Tool ADSI-Bearbeitung ist in den Microsoft Windows 2000- und Microsoft Windows Server 2003-Supporttools enthalten. Führen Sie zur Installation der Windows-Supporttools im Ordner Support\Tools auf der Windows-CD das Setup aus. Weitere Informationen zu den Windows-Supporttools finden Sie in der Datei Sreadme.doc im Ordner Support\Tools auf der Windows-CD.
So gewähren Sie authentifizierten Benutzern in den Active Directory-Containern "Domain" und "Configuration" Lesezugriff

  1. Klicken Sie im Menü Start auf Ausführen, geben Sie adsiedit.msc ein, und klicken Sie auf OK.

  2. Erweitern Sie den Container Domain NC, klicken Sie mit der rechten Maustaste auf den Ordner der Domäne (DC=domain,DC=com), und klicken Sie dann auf Eigenschaften, um die Ordnereigenschaften zu öffnen.

  3. Klicken Sie auf die Registerkarte Sicherheit, und stellen Sie sicher, dass für die Gruppe Authentifizierte Benutzer der Zugriff Lesen in der Spalte Zulassen festgelegt ist. Falls Lesen nicht ausgewählt ist, klicken Sie auf Lesen und anschließend auf OK.

  4. Erweitern Sie den Ordner Configuration, klicken Sie mit der rechten Maustaste auf den Ordner der Konfiguration (CN=Configuration,DC=domain,DC=com), und klicken Sie dann auf Eigenschaften, um die Ordnereigenschaften zu öffnen.

  5. Klicken Sie auf die Registerkarte Sicherheit, und stellen Sie sicher, dass für die Gruppe Authentifizierte Benutzer der Zugriff Lesen in der Spalte Zulassen festgelegt ist. Falls Lesen nicht ausgewählt ist, klicken Sie auf Lesen und anschließend auf OK.

  6. Beenden Sie ADSI-Bearbeitung.

  7. Warten Sie ab, bis die Änderung auf die Domänencontroller repliziert wurde.

  8. Starten Sie den Informationsspeicherdienst.
  • Falls die Lesezugriffsberechtigung für das Konto Jeder in Active Directory im Container WellKnown Security Principals unterhalb des Containers Configuration fehlt, befolgen Sie zur Behebung des Problems die folgenden Schritte:

So gewähren Sie die Lesezugriffsberechtigung für das Konto Jeder in Active Directory im Container WellKnown Security Principals

  1. Melden Sie sich als Domänenadministrator an, und starten Sie anschließend ADSI-Bearbeitung.

  2. Erweitern Sie den Container Configuration, und klicken Sie auf den Container CN=WellKnown Security Principals.

  3. Klicken Sie mit der rechten Maustaste auf Eigenschaften, und klicken Sie dann auf die Registerkarte Sicherheit.

  4. Klicken Sie auf Hinzufügen, geben Sie Jeder, und klicken Sie anschließend auf OK.

  5. Aktivieren in der Spalte Zulassen das Kontrollkästchen Lesen.
  • Wenn der Exchange-Organisationsname ungültige Zeichen enthält, entfernen Sie diese Zeichen aus dem Organisationsnamen. Weitere Informationen zu ungültigen Zeichen finden Sie im Microsoft Knowledge Base-Artikel 329599, Exchange-Informationsspeicher wird nicht gestartet und Ereignisse 1121 und 5000 werden protokolliert.


MSExchangeIS 9518 (0xfffffddc): Die maximale Anzahl der für diese Speichergruppe verfügbaren Transaktionsprotokolle wurde überschritten
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-01-22

Das Microsoft® Exchange Server-Tool Datenbank-Problembehandlung hat ein oder mehrere MSExchangeIS 9518-Ereignisse mit dem Fehlercode 0xfffffddc im Protokoll Anwendung entdeckt. Dies bedeutet, dass die maximale Anzahl der für diese Speichergruppe verfügbaren Transaktionsprotokolle überschritten wurde.

Erklärung

Das MSExchangeIS-Ereignis 9518 mit dem Fehlercode 0xfffffddc wird aufgezeichnet, wenn versucht wird, die Datenbanken einer Speichergruppe bereitzustellen, und beide der folgenden Bedingungen wahr sind:

  • Die maximale Anzahl der für diese Speichergruppe verfügbaren Transaktionsprotokolle wurde überschritten.

  • Alle Datenbanken in der Speichergruppe befinden sich im Status Clean Shutdown.

Darüber hinaus muss das MSExchangeIS-Ereignis 1159 mit dem Fehlercode 0xfffffdf9 im Protokoll Anwendung aufgezeichnet werden, bevor die betroffenen Datenbanken heruntergefahren werden. Dieses Ereignis bedeutet, dass der Computer mit Exchange Server alle verfügbaren Transaktionsprotokolldateien für diese Speichergruppe verwendet hat. Nachdem das letzte Transaktionsprotokoll aufgefüllt wurde, wird die Bereitstellung aller Datenbanken innerhalb dieser Speichergruppe aufgehoben, sodass diese nicht neu gestartet werden können.

Exchange verwendet durchlaufend nummerierte Transaktionsprotokolldateien. In Exchange 2000 Server und Exchange Server 2003 beginnen Transaktionsprotokolldateien mit Exx00001.log und werden anschließend durchlaufend bis ExxFFFF0.log nummeriert. Die maximale Anzahl von Transaktionsprotokolldateien, die ein einer einzelnen Sequenz generiert werden kann, ist 1.048.560 (0xFFFF0). Normalerweise sind mehrere Betriebsjahre erforderlich, um eine solche Anzahl von Protokolldateien zu generieren.

In Exchange Server 2007 sind die Transaktionsprotokolldateien größer. Ein Protokolldatenstrom kann maximal 2.147.483.647 Protokolldateien enthalten (hexadezimal 0x7FFFFFFF, da Protokolldateinamen im Hexadezimalformat vorliegen). Die Transaktionsprotokolldateien sind jeweils 1 MB groß. Dieser Fehler sollte in Exchange Server 2007 nicht auftreten.

Benutzeraktion

Um diesen Fehler zu beheben, müssen Sie alle Transaktionsprotokolldateien entfernen und die Sequenznummer der Transaktionsprotokolldateien auf 1 zurücksetzen. Nach diesem Vorgang lautet der Protokolldateiname in Versionen bis Exchange Server 2003 Exx00001.log und in Exchange Server 2007 Exx00000001.log.

Verwenden Sie im Tool Datenbankwiederherstellungs-Verwaltung, das zum Exchange-Problembehandlungs-Assistenten gehört, den Task Protokollgenerierungsnummer zurücksetzen, um diesen Vorgang auszuführen. Das Tool überprüft, ob alle Datenbanken ordnungsgemäß heruntergefahren wurden, und verschiebt anschließend alle Transaktionsprotokolldateien sicher an den Speicherort der Sicherung.

Hinweis:
Die Transaktionsprotokolldateien können auch manuell entfernt werden, doch eine manuelle Entfernung kann dazu führen, dass eine Datenbank in der Speichergruppe nicht ordnungsgemäß heruntergefahren wird und diese Datenbank nicht erneut bereitgestellt werden kann. Um solche Probleme zu vermeiden, wird empfohlen, das Tool Datenbankwiederherstellungs-Verwaltung zu verwenden.

Weitere Informationen zu diesem Tool und seinem Download finden Sie unter Microsoft Exchange Troubleshooting Assistant v1.0.


MSExchangeIS 9518 (0xfffff745): Erstellen von oder Zugriff auf TMP-Dateien nicht möglich
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-01-23

Das Microsoft® Exchange-Tool Datenbank-Problembehandlung hat ein oder mehrere MSExchangeIS 9518-Ereignisse mit dem Fehlercode 0xfffff745 im Protokoll Anwendung entdeckt. Dieser Fehler tritt auf, wenn Exchange Dateien in den Ordnern, die in den Systemumgebungsvariablen TMP oder TEMP angegeben sind, nicht erstellen bzw. nicht darauf zugreifen kann.

Erklärung

Dieses Problem kann auftreten, wenn eine der folgenden Bedingungen vorliegt:

  • Der Pfad, auf den die Umgebungsvariable TMP oder TEMP zeigt, ist nicht verfügbar oder schreibgeschützt. Dieser Fehler tritt beispielsweise auf, wenn die Umgebungsvariable TMP einem Remotelaufwerk oder Speichernetzwerk (SAN) zugeordnet ist und das entsprechende Laufwerk oder SAN nicht mehr verfügbar ist.

  • Die Umgebungsvariable TMP oder TEMP enthält eine falsche Registrierungseinstellung.

  • Exchange hat keine Vollzugriffsberechtigung ausgehend vom Stammverzeichnis des Laufwerks zu den Transaktionsprotokollen und Datenbanken.

Benutzeraktion

Um dieses Problem zu beheben, führen Sie einen oder mehrere der folgenden Schritte aus:

Hinweis Da es mehrere Versionen von Microsoft Windows gibt, können die Schritte auf Ihrem Computer ggf. unterschiedlich sein. Ist dies der Fall, konsultieren Sie die Produktdokumentation, um diese Schritte auszuführen.

  • Prüfen Sie, ob die Umgebungsvariablen TMP und TEMP auf einen gültigen Pfad unter Windows zeigen. Führen Sie dazu die folgenden Schritte durch:

    So legen Sie einen gültigen Pfad für die Variablen TEMP und TMP fest

    1. Klicken Sie auf Start, zeigen Sie auf Einstellungen, und klicken Sie auf Systemsteuerung.

    2. Doppelklicken Sie auf System, klicken Sie auf die Registerkarte Erweitert, und klicken Sie dann auf Umgebungsvariablen.

    3. Klicken Sie unter Systemvariablen auf TEMP, und klicken Sie dann auf Bearbeiten.

    4. Wird im Feld Wert der Variablen kein gültiger Pfad angezeigt, geben Sie einen gültigen Pfad für die Variable TEMP ein, und klicken Sie dann auf OK. Geben Sie beispielsweise %systemroot%\Temp ein, und klicken Sie dann auf OK.

    5. Klicken Sie unter Systemvariablen auf TMP, und klicken Sie dann auf Bearbeiten.

    6. Wird im Feld Wert der Variablen kein gültiger Pfad angezeigt, geben Sie einen gültigen Pfad für die Variable TMP ein, und klicken Sie dann auf OK. Geben Sie beispielsweise %systemroot%\Temp ein, und klicken Sie dann auf OK.

    7. Klicken Sie zweimal auf OK, um das Dialogfeld Systemeigenschaften zu schließen.

    8. Starten Sie den Computer neu.
  • Weisen Sie bei Bedarf der lokalen Gruppe Administratoren oder dem Konto SYSTEM Vollzugriffsberechtigungen für den Ordner Temp zu. Es reicht nicht aus, der Gruppe Domänen-Admins Vollzugriffsberechtigungen zuzuweisen. Standardmäßig wird den Umgebungsvariablen TMP und TEMP der folgende Pfad zugewiesen:

    %SYSTEMROOT%\Temp

    Exchange muss auf diesen Ordnerspeicherort mithilfe des Kontos SYSTEM zugreifen. Um diese Berechtigungen anzuzeigen, befolgen Sie folgende Schritte:

    So überprüfen Sie die Berechtigungen für den Ordner "Temp"

    1. Klicken Sie mit der rechten Maustaste auf Start, und klicken Sie dann auf Explorer.

    2. Klicken Sie mit der rechten Maustaste auf den Ordner Temp, der in der Systemumgebungsvariablen angegeben ist, und klicken Sie dann auf Eigenschaften. Die Angabe lautet in der Regel %systemroot%\Temp.

    3. Klicken Sie auf die Registerkarte Sicherheit.

    4. Klicken Sie in der Liste Name auf SYSTEM, und untersuchen Sie anschließend in der Liste Berechtigungen die zugewiesenen Berechtigungen.
    Wenn die für den Ordner Temp festgelegten Berechtigungen ordnungsgemäß sind, überprüfen Sie die Berechtigungen für jedes Laufwerk mit Exchange-Datenbank- oder -Protokolldateien. Das Konto SYSTEM benötigt Vollzugriffsberechtigungen ab dem Stammverzeichnis des Laufwerks und für jeden Ordner mit Exchange-Datenbank- oder -Transaktionsprotokolldateien. Beispiel: Wenn der Ordner C:\Exchsrvr\Mdbdata Transaktionsprotokolldateien enthält, benötigt das Konto SYSTEM Vollzugriffsberechtigungen für das Stammverzeichnis von Laufwerk C, den Ordner Exchsrvr und den Ordner Mdbdata.

  • Prüfen Sie, ob falsche Registrierungseinstellungen die Ursache des Problems sind. Gehen Sie folgendermaßen vor:

    So überprüfen Sie Registrierungseinstellungen

    1. Klicken Sie auf Start, klicken Sie auf Ausführen, und geben Sie Regedt32.exe ein. Klicken Sie anschließend auf OK.

    2. Suchen Sie den folgenden Registrierungsschlüssel:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

    3. Suchen Sie den Namen TMP (oder TEMP). Dieser Schlüssel muss den Typ REG_EXPAND_SZ haben.

    4. Wenn einer der Schlüssel falsch ist, sichern Sie den Unterschlüssel Environment und löschen anschließend auf der rechten Seite den Wert von TMP oder TEMP.

    5. Klicken Sie auf Start, dann auf Ausführen, und geben Sie Sysdm.cpl ein. Klicken Sie anschließend auf OK.

    6. Klicken Sie auf der Registerkarte Erweitert auf Umgebungsvariablen.

    7. Bestätigen Sie in der Liste Systemvariablen, dass die in Schritt 4 gelöschten Werte nicht in der Liste vorhanden sind.

      Hinweis:
      Sie müssen ggf. einen Bildlauf nach unten ausführen, um die Variable TEMP oder TMP anzeigen zu können.

    8. Klicken Sie auf Neu. Geben Sie in das Feld Name der Variablen die in Schritt 4 gelöschten Namen ein, z. B. C:\Winnt\TEMP.

    9. Klicken Sie dreimal auf OK, und starten Sie anschließend den Computer neu.


MSExchangeIS 9518 0xfffffbc4: Protokolldateipfad ist bereits in Gebrauch
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-05-14

Das Microsoft Exchange-Tool Datenbank-Problembehandlung hat mindestens ein MSExchangeIS 9518-Ereignis mit dem Fehlercode 0xfffffbc4 im Anwendungsprotokoll erkannt. Dieser Fehlercode zeigt an, dass mindestens eine Speichergruppe für die Verwendung des gleichen Protokolldateipfads oder Systemdateipfads konfiguriert ist.

Erläuterung

Dieser Fehler kann auftreten, wenn mehrere Speichergruppen für die Verwendung des gleichen Protokolldateipfads oder Systemdateipfads konfiguriert wurden. Exchange verlangt, dass jede Speichergruppe einen eindeutigen Pfad für Protokoll- und Systemdateien besitzt.

Benutzeraktion

Um dieses Problem zu beheben, stellen Sie sicher, dass jede Speichergruppe mit einem eindeutigen Protokolldateipfad und Systemdateipfad konfiguriert ist.

Hinweis:
Eine getrennte Speichergruppe kann den gleichen Protokolldateipfad und Systemdateipfad verwenden. Der gleiche Pfad kann jedoch nicht als Protokolldateipfad oder Systemdateipfad für eine andere Speichergruppe verwendet werden.
So überprüfen Sie die Protokolldatei- und Systemdateipfade für Exchange 2000 Server oder Exchange Server 2003 bzw. legen diese fest

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Administrative Gruppen, erweitern Sie Ihre administrative Gruppe, erweitern Sie Server, klicken Sie mit der rechten Maustaste auf Ihre Speichergruppe, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Allgemein unter Pfad des Transaktionsprotokolls auf Durchsuchen.

  4. Vergewissern Sie sich, dass der Protokolldateipfad und der Systemdateipfad eindeutig für die Speichergruppe ist.

  5. Wenn der Protokolldateipfad und der Systemdateipfad für die Speichergruppe nicht eindeutig ist, geben Sie den Pfad des neuen Speicherorts für die Protokolldateien bzw. Systemdateien ein, und klicken Sie dann auf OK.

  6. Klicken Sie auf OK.
So überprüfen Sie die Protokolldatei- und Systemdateipfade für eine Speichergruppe für Exchange Server 2007 bzw. legen diese fest

  1. Öffnen Sie die Exchange-Verwaltungskonsole.

  2. Erweitern Sie Serverkonfiguration, und markieren Sie die Option Postfach.

  3. Wählen Sie im Bereich Postfach den Server aus, mit dem Sie arbeiten möchten.

  4. Klicken Sie mit der rechten Maustaste im Bereich Datenbankverwaltung auf die Speichergruppe, mit der Sie arbeiten möchten, und wählen Sie dann Eigenschaften aus.

  5. Vergewissern Sie sich, dass der Protokolldateipfad und der Systemdateipfad eindeutig für die Speichergruppe ist.

  6. Wenn der Protokolldateipfad bzw. der Systemdateipfad nicht eindeutig für die Speichergruppe ist, befolgen Sie die Anweisungen in der Exchange Server 2007-Dokumentation unter "Festlegen oder Ändern des Speicherorts der Speichergruppen-Protokolldateien" (http://go.microsoft.com/fwlink/?LinkId=80702), um die Dateipfade für jede Speichergruppe auf einen eindeutigen Speicherort festzulegen.

Weitere Informationen zum Verschieben von Protokolldateien unter Exchange Server 2003 finden Sie im Microsoft Knowledge Base-Artikel 821915 "So verschieben Sie Exchange-Datenbanken und -Protokolle in Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915).

Weitere Informationen zum Verschieben von Protokolldateien unter Exchange 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 239944, "XADM: Verschieben der Transaktions- oder Systemprotokolle an einen anderen Speicherort" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239944).


MSExchangeIS 9518 (0xfffffd9a): Fehlende Prüfpunktdatei und mehr als 1008 Transaktionsprotokolldateien vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-01-23

Das Microsoft® Exchange-Tool Datenbank-Problembehandlung hat ein oder mehrere MSExchangeIS 9518-Ereignisse mit dem Fehlercode 0xfffffd9a im Protokoll Anwendung entdeckt. Dieser Fehler bedeutet, dass die Prüfpunktdatei (Exx.chk) für diese Speichergruppe fehlt oder gelöscht wurde und dass mehr als 1008 Transaktionsprotokolldateien zum Zurückspielen in die Datenbank vorhanden sind.

Erklärung

Dieses Problem kann auftreten, wenn die folgenden Bedingungen vorliegen:

  • Die Protokolldateien und Datenbanken wurden ordnungsgemäß heruntergefahren. Deshalb liegt kein Systemabsturz vor, auf den eine Wiederherstellung folgen müsste.

  • Sie haben die Prüfpunktdatei Exx.chk umbenannt oder gelöscht.

  • Es gibt mehr als 1008 Protokolldateien zwischen Prüfpunkten, die auf den Server zurückgespielt werden müssen.

  • Bei einer Rollforward-Wiederherstellung sind eine oder mehrere Datenbanken in der Speichergruppe verloren gegangen, doch die Protokolldateien sind zum Zeitpunkt der Wiederherstellung auf dem Server intakt geblieben. Der Rollforward-Wiederherstellungsvorgang wurde nicht erfolgreich abgeschlossen.

In dieser Situation führt der Microsoft Exchange-Informationsspeicherdienst einen Soft Recovery-Vorgang aus, bei dem während des Systemstarts alle Protokolldateien zurückgespielt werden. Da die Protokolldateien und die Datenbank ordnungsgemäß heruntergefahren wurden, ist keine Wiederherstellung durchzuführen. Da es keinen Prüfpunkt gibt, verarbeitet Exchange alle Protokolle, bis ein Eintrag mit dem Status "Clean Shutdown" erreicht wird. Und weil mehr als 1008 Protokolldateien vorhanden sind, erreicht Exchange den Grenzwert von 1008 Protokolldateien, bevor der Eintrag mit dem Status "Clean Shutdown" gefunden werden kann.

Hinweis:
Die beschriebenen Symptome können ebenfalls auftreten, wenn die zuvor genannten Bedingungen vorliegen und Sie die Protokolldateien mithilfe des Befehls eseutil /r zurückspielen. Der Befehl eseutil /r führt auch eine Soft Recovery des Postfachspeichers aus.

Das Ereignis kann auch als Fehler -614, JET_errCheckpointDepthTooDeep auftreten. Dieser Fehler tritt nur in Microsoft Exchange Server 2003 auf.

Benutzeraktion

Um dieses Problem in Exchange Server 2003 zu beheben, spielen Sie den im Microsoft Knowledge Base-Artikel 836611, Information Store databases do not mount and you receive an "Operation terminated with error -614" error message when you start a computer that is running Exchange Server 2003 beschriebenen Hotfix auf.


MSExchangeIS 9518 0xfffffb40: Fehlende Datenbankdatei
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-05-23

Das Microsoft Exchange-Tool Datenbank-Problembehandlung hat mindestens ein MSExchangeIS 9518-Ereignis mit dem Fehlercode 0xfffffb40 im Anwendungsprotokoll erkannt. Dies zeigt an, dass mindestens eine Datenbankdatei für die Speichergruppe fehlt.

Erläuterung

Dieser Fehler kann auftreten, wenn die ESE-Komponente (Extensible Storage Engine) versucht, alle Datenbanken in einer Speichergruppe während der Wiederherstellung in einen konsistenten Zustand zu überführen, dabei jedoch feststellt, dass Datenbankdateien fehlen oder durch andere Versionen ersetzt wurden.

Wenn eine Datenbankdatei in der Speichergruppe fehlt oder durch eine andere Version ersetzt wurde, gibt ESE den Fehler -1216 zurück, bricht die Wiederherstellung ab und startet die Speichergruppe nicht.

Benutzeraktion

Um dieses Problem zu beheben, führen Sie einen oder mehrere der folgenden Schritte aus:

  • Methode eins: Wenn die fehlende Datenbankdatei verschoben oder umbenannt wurde, suchen Sie alle ESE 494-Ereignisse im Ereignisprotokoll, die nach dem Bereitstellungsversuch der Datenbank aufgetreten sind. Notieren Sie sich für jedes Ereignis die betreffende Datenbankdatei, die als fehlend gemeldet wird, ermitteln Sie den aktuellen Speicherort der Datei, und verschieben Sie sie dann an den richtigen Speicherort.

Hinweis:
Wenn Antivirussoftware auf Dateiebene auf diesem Server installiert ist und Ausschlüsse nicht ordnungsgemäß konfiguriert wurden, ist es möglich, dass die Datenbank durch die Antivirussoftware gelöscht oder in das Quarantäneverzeichnis verschoben wurde. Überprüfen Sie das Quarantäne- und Löschprotokoll der Antivirussoftware daraufhin, ob dies geschehen ist.
  • Methode zwei:

    • Methode zwei A: Wenn die fehlende Datenbankdatei gelöscht wurde oder verlorengegangen ist, stellen Sie die Datei aus einer Sicherung in der Produktionsspeichergruppe wieder her. Sie können den Task Datenbank- und Transaktionsprotokolldateien überprüfen des Tools Exchange Datenbankwiederherstellungs-Verwaltung verwenden, um die Verfügbarkeit der wiederhergestellten Datenbank für die Durchführung einer Wiederherstellung zu überprüfen.

      Während Sie diese Datenbankdatei wiederherstellen, können Sie die nicht betroffenen Datenbanken in der Speichergruppe ebenfalls bereitstellen und darauf zugreifen, indem Sie die folgenden Schritte ausführen:

So erlauben Sie den Benutzerpostfachzugriff auf nicht betroffene Datenbanken

  1. Führen Sie eseutil /R /L <Pfad_zu_den_Protokolldateien> /S <Path to System Files> Log Base Name /I aus (dabei besteht "Log Base Name" aus den ersten drei Buchstaben der Protokolldateien für diese Speichergruppe, z. B. "E00", "E01" usw.). Auf diese Weise kann ESE die vorhandenen Datenbankdateien in einen konsistenten Zustand bringen, wobei die fehlenden Datenbankdateien ignoriert werden. Nachdem dieser Befehl ausgeführt wurde, müssen alle fehlenden Datenbankdateien aus der Sicherung wiederhergestellt werden.
Hinweis:
Die Parameter /L und /S sind optional und müssen nicht verwendet werden, wenn Eseutil aus dem gleichen Pfad wie die Protokoll- und Systemdateien ausgeführt wird.
  1. Stellen Sie die Datenbankdateien, die nun vorhanden und konsistent sind, in der Speichergruppe wieder her.

  2. Benutzer mit Postfächern, die in der aktuell bereitgestellten Datenbank gespeichert sind, können nun auf ihre Nachrichten zugreifen.
  • Methode zwei B: Stellen Sie die Datenbankdatei aus einer Sicherung in einer Speichergruppe für die Wiederherstellung wieder her. Sie können Sende-/Empfangsfunktionen sofort bereitstellen, indem Sie so bald wie möglich mit einer neuen Datenbank beginnen (diese Vorgehensweise wird als "Dial-Tone"-Wiederherstellung bezeichnet). Clients wird ein leeres Postfach angezeigt, sie erhalten jedoch schneller Sende- und Empfangsfunktionen, als wenn sie warten müssten, bis die Wiederherstellung bzw. Reparatur abgeschlossen ist.

Hinweis:
Die "Dial-Tone"-Option erfordert das nachträgliche Zusammenführen aller neuen Daten (der Daten, die nach der "Dial-Tone"-Wiederherstellung gespeichert wurden) mit den wiederhergestellten Daten.

Weitere Informationen zur "Dial-Tone"-Wiederherstellung finden Sie unter "Dial-Tone-Portabilität" im Thema zur Wiederherstellung nach Datenverlust in der Exchange 2007-Produktdokumentation.

Weitere Informationen zu Speichergruppen für die Wiederherstellung finden Sie unter "Informationen zu Speichergruppen für die Wiederherstellung" im Thema zur Wiederherstellung nach Datenverlust in der Exchange 2007-Produktdokumentation.
  • Methode drei: Wenn ein Hard-Repair-Vorgang entweder manuell oder über den Task Datenbank reparieren des Microsoft Exchange-Problembehandlungs-Assistenten für mindestens eine Datenbank in der Speichergruppe ausgeführt wurde und die Datenbanken sich in einem konsistenten Zustand befinden, kann es sein, dass die Protokolldateien für die Speichergruppe nicht entfernt wurden. Wenn sich alle Datenbanken für die Speichergruppe am richtigen Speicherort befinden, überprüfen Sie, ob sich alle Datenbanken in einem konsistenten Zustand befinden, indem Sie den folgenden Befehl ausführen.

So überprüfen Sie die Konsistenz der Datenbankdatei manuell

  1. Führen Sie eseutil /mh <path to database .edb file> aus.

  2. Suchen Sie in der Ausgabe dieses Befehls nach dem Feld Status:, und vergewissern Sie sich, dass der Wert des Felds Clean Shutdown lautet.

  3. Wenn alle Datenbanken für die Speichergruppe den Status "Clean Shutdown" aufweisen, verschieben Sie alle Transaktionsprotokolle und Systemprotokolle für die Speichergruppe an einen Sicherungsspeicherort, und versuchen Sie dann, den Informationsspeicher bereitzustellen. Wenn Sie in der Lage sind, alle Datenbanken ordnungsgemäß bereitzustellen, wird empfohlen, sofort eine Sicherung der Speichergruppe zu erstellen.

Weitere Informationen

Weitere Informationen zum Ereignis MSExchangeIS 9518 mit dem Fehlercode 0xfffffb40 finden Sie im "Events and Errors Message Center" (http://go.microsoft.com/fwlink/?LinkId=91705).

Weitere Informationen zur Wiederherstellung nach diesem Fehler finden Sie im Microsoft Knowledge Base-Artikel 296843, "Wiederherstellung einer Exchange 2000 Server-Datenbank nach dem Fehler -1216 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=296843).

Weitere Informationen zur Exchange-Planung für die Wiederherstellung nach Datenverlusten finden Sie unter "Ein Handbuch zum Planen der Notfallwiederherstellung in Exchange" (http://go.microsoft.com/fwlink/?LinkId=91706).

Weitere Informationen zur Verwaltung der Datenbankwiederherstellung und zu den Assistenten für die Datenbank-Problembehandlung finden unter "Database Recovery Management and Database Troubleshooter Tool" (http://go.microsoft.com/fwlink/?LinkId=91707).

Weitere Informationen zur "Dial-Tone"-Wiederherstellung finden Sie unter "Dial-Tone-Portabilität" (http://go.microsoft.com/fwlink/?LinkId=91703) im Thema zur Wiederherstellung nach Datenverlust in der Exchange 2007-Produktdokumentation.

Weitere Informationen zu Speichergruppen für die Wiederherstellung finden Sie unter "Informationen zu Speichergruppen für die Wiederherstellung" (http://go.microsoft.com/fwlink/?LinkID=80784) im Thema zur Wiederherstellung nach Datenverlust in der Exchange 2007-Produktdokumentation.


MSExchangeIS 9518 (0xfffffea8): Nicht übereinstimmender Datenbankzeitstempel in der Datenbankdatei
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-01-23

Das Microsoft® Exchange-Tool Datenbank-Problembehandlung hat ein oder mehrere MSExchangeIS 9518-Ereignisse mit dem Fehlercode 0xfffffea8 im Protokoll Anwendung entdeckt. Dieser Fehler tritt auf, wenn der Datenbankzeitstempel auf der aktuelle Seite der betroffenen Datenbank größer als der globale Datenbankzeitstempel der Datenbank ist.

Erklärung

Wenn dieser Fehler auftritt, werden die betroffenen Postfach- bzw. Öffentlichen Ordner-Datenbanken nicht bereitgestellt. Der Fehler kann auch als JET_errDbTimeCorrupted auftreten.

Der Fehler tritt in den folgenden Versionen von Exchange Server auf:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Benutzeraktion

Um die fehlende Übereinstimmung beim Datenbankzeitstempel zu beseitigen, führen Sie den Befehl eseutil /d aus, um die Datenbank zu defragmentieren, in der der Fehler auftritt. Stellen Sie anschließend die Datenbank bereit. Weitere Informationen zum Ausführen von eseutil /d finden Sie unter How to Run Eseutil /D ( Defragmentation ). Lesen Sie außerdem den Microsoft Knowledge Base-Artikel 328804, So defragmentieren Sie Exchange-Datenbanken.


MSExchangeIS 9518 (0xfffff764): Streamingdatei fehlt oder auf die Streamingdatei ist kein Zugriff möglich
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-01-23

Das Microsoft® Exchange-Tool Datenbank-Problembehandlung hat ein oder mehrere MSExchangeIS 9518-Ereignisse mit dem Fehlercode 0xfffff764 im Protokoll Anwendung entdeckt. Dieser Fehler kann auftreten, wenn Exchange nicht auf die Streamingdatei (.stm) zugreifen kann, die einer Datenbank zugeordnet ist.

Erklärung

Dieser Fehler kann auftreten, wenn die einer Datenbank zugeordnete Streamingdatei (.stm) gelöscht oder entfernt wurde oder Exchange aufgrund einer Berechtigungsänderung nicht auf die Streamingdatei zugreifen kann.

Hinweis:
Unter bestimmten Umständen können Antivirenprogramme die Berechtigungen für Exchange-Dateien, einschließlich STM-Datei, ändern oder löschen, wenn Sie die Exchange-Verzeichnisse nicht aus Scanvorgängen gemäß den für Microsoft Exchange empfohlenen Vorgehensweisen ausgeschlossen haben. Weitere Informationen zu diesem Thema finden Sie im Microsoft Knowledge Base-Artikel 823166, Überblick über Exchange Server 2003 und Antivirus-Software.

Dieser Fehler kann auch als -2204 auftreten und tritt in den folgenden Versionen von Exchange Server auf:

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Benutzeraktion

Um dieses Problem zu beheben, führen Sie einen oder mehrere der folgenden Schritte aus:

  • Stellen Sie die Streamingdatei aus einer Sicherungskopie der Datenbank wieder her.

  • Prüfen Sie, ob die Antivirensoftware die Streamingdatei in den Quarantäneordner verschoben hat. Ist dies der Fall, verschieben Sie sie an den ursprünglichen Speicherort, und konfigurieren Sie dann das Antivirenprogramm so, dass die Exchange Server 2003-Ordner nicht gescannt werden.

    Hinweis:
    Einige Antivirenprogramme ändern die Dateieigenschaften in Schreibgeschützt, wenn die Dateien in den Quarantäneordner verschoben werden. Sollte sich die Streamingdatei im Quarantäneordner befinden, klicken Sie mit der rechten Maustaste auf die Datei und klicken anschließend auf Eigenschaften. Deaktivieren Sie das Kontrollkästchen Schreibgeschützt, bevor Sie versuchen, die Datenbank bereitzustellen.
  • Sie können das Tool Datenbankwiederherstellungs-Verwaltung ausführen, das zum Microsoft Exchange-Problembehandlungs-Assistenten gehört. Das Tool Datenbankwiederherstellungs-Verwaltung ermöglicht die Analyse der Datenbank- und Transaktionsprotokolldateien für die jeweilige Speichergruppe und bietet zusätzliche Informationen zum Problem. Weitere Informationen zu diesem Tool und seinem Download finden Sie unter Microsoft Exchange Troubleshooting Assistant v1.0.


MSExchangeIS 9518 (0xfffffbf8): Fehlende erforderliche Berechtigungen für Exchange-Datenbankordner oder -Laufwerk
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-03-15

Das Microsoft Exchange-Tool Datenbank-Problembehandlung hat mindestens ein MSExchangeIS 9518-Ereignis mit dem Fehlercode 0xfffffbf8 im Anwendungsprotokoll erkannt. Dies weist darauf hin, dass dem Ordner oder dem Laufwerk, der oder das die Exchange-Datenbank(en) enthält, nicht die erforderlichen Berechtigungen zugewiesen wurden.

Erläuterung

Dieser Fehler weist darauf hin, dass dem Ordner oder dem Laufwerk, der oder das die Exchange-Datenbankdateien enthält, nicht die Berechtigungen zugewiesen wurden, die erforderlich sind, um die Mindestfunktionen auszuführen. Es können Schwierigkeiten beim Zugriff auf die Postfachspeicher oder die Informationsspeicher für Öffentliche Ordner oder bei deren Bereitstellung auftreten.

Benutzeraktion

Um dieses Problem zu beheben, gewähren Sie dem Ordner, der die Exchange-Datenbanken enthält, und dem Laufwerk, auf dem dieser Ordner gespeichert ist, Standardberechtigungen.

So gewähren Sie dem Ordner, der die Exchange-Datenbanken enthält, in Exchange 2007 Standardberechtigungen

  1. Starten Sie Windows-Explorer, und navigieren Sie dann zu dem Ordner, der die Exchange-Datenbanken enthält. Standardmäßig ist dies C:\Programme\Microsoft\Exchange\Mailbox\Name_der_Speichergruppe\.

  2. Klicken Sie mit der rechten Maustaste auf diesen Ordner, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf die Registerkarte Sicherheit, und gewähren Sie dann die folgenden Standardberechtigungen:

Konto | Berechtigungen
Administratoren | Vollzugriff
System | Vollzugriff
 So gewähren Sie dem Laufwerk, auf dem die Exchange-Datenbanken gespeichert sind, in Exchange 2007 Standardberechtigungen

  1. Starten Sie Windows-Explorer.

  2. Klicken Sie mit der rechten Maustaste auf das lokale Datenträgerobjekt, das den Exchange-Datenbankordner enthält, und klicken Sie dann auf Eigenschaften.

  3. Wählen Sie die Registerkarte Sicherheit aus, und gewähren Sie dann abhängig vom installierten Betriebssystem die folgenden Standardberechtigungen:

Für Windows 2000 Server:

Konto | Berechtigungen
Jeder | Vollzugriff

Für Windows Server 2003:

Konto | Berechtigungen
Administratoren | Vollzugriff
Ersteller-Besitzer | Keine
Jeder | Keine
System | Vollzugriff
Benutzer | Lesen und Ausführen, Ordnerinhalt ausführen, Lesen
 So gewähren Sie dem Ordner "Mdbdata" in Exchange 2000 Server and Exchange Server 2003 Standardberechtigungen

  1. Starten Sie Windows-Explorer, und navigieren Sie dann zum Ordner Exchsvr. Erweitern Sie diesen Ordner.

  2. Klicken Sie mit der rechten Maustaste auf den Ordner Mdbdata, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf die Registerkarte Sicherheit, und gewähren Sie dann die folgenden Standardberechtigungen:

Konto | Berechtigungen
Administratoren | Vollzugriff
Authentifizierte Benutzer | Lesen und Ausführen, Ordnerinhalt ausführen, Lesen
Ersteller-Besitzer | Keine
Server-Operatoren | Ändern, Lesen und Ausführen, Ordnerinhalt ausführen, Lesen, Schreiben
System | Vollzugriff
 So gewähren Sie dem Laufwerk, auf dem der Ordner "Mdbdata" gespeichert ist, in Exchange 2000 Server and Exchange Server 2003 Standardberechtigungen

  1. Starten Sie Windows-Explorer.

  2. Klicken Sie mit der rechten Maustaste auf das lokale Datenträgerobjekt, das den Ordner Mdbdata enthält, und klicken Sie dann auf Eigenschaften.

  3. Wählen Sie die Registerkarte Sicherheit aus, und gewähren Sie dann abhängig vom installierten Betriebssystem die folgenden Standardberechtigungen:

Für Windows 2000 Server:

Konto | Berechtigungen
Jeder | Vollzugriff

Für Windows Server 2003:

Konto | Berechtigungen
Administratoren | Vollzugriff
Ersteller-Besitzer | Keine
Jeder | Keine
System | Vollzugriff
Benutzer | Lesen und Ausführen, Ordnerinhalt ausführen, Lesen

Weitere Informationen

Weitere Informationen zu diesem Problem finden Sie im Microsoft Knowledge Base-Artikel 823022, "Ereignis-ID 490 wird protokolliert, und Sie erhalten die folgende Fehlermeldung, wenn Sie versuchen, den Postfachspeicher oder den Informationsspeicher für Öffentliche Ordner in Exchange Server bereitzustellen: "ID-Nr.: c1041724"" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823022).


MSExchangeIS 9518 (0xfffff743): Zu viele temporäre Dateien
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-03-14

Das Microsoft Exchange-Tool Datenbank-Problembehandlung hat mindestens ein MSExchangeIS 9518-Ereignis mit dem Fehlercode 0xfffff743 im Anwendungsprotokoll erkannt. Dies zeigt an, dass der Namespace für temporäre Dateien für einen Server erschöpft ist oder nicht genügend Speicherplatz verfügbar ist, um in den Ordner Temp zu schreiben.

Erläuterung

Exchange 2000 Server und Exchange Server 2003 erstellen temporäre Dateien im Ordner Temp, wenn ein großes Objekt wie z. B. eine Nachricht oder Datei mittels Streaming in den Informationsspeicher geschrieben wird und die STM-Datei zu fragmentiert ist, um das gesamte Objekt in diese Datei zu schreiben.

Während des normalen Betriebs werden diese Dateien aus dem Ordner Temp entfernt, wenn die Exchange-Dienste beendet werden. Wenn der Servercomputer mit Exchange unerwartet heruntergefahren wird oder die Exchange-Dienste unerwartet beendet werden, werden diese Dateien nicht entfernt. Wenn die Exchange-Dienste später neu gestartet werden, werden neue temporäre Dateien erstellt. Dies führt zu einer Leistungsverschlechterung. Wenn der 64.000-Namespace für temporäre Dateien erschöpft ist, werden die Exchange-Dienste nicht gestartet, und Ereignisse vom Typ 9518 mit dem Fehlercode 0xfffff743 werden im Anwendungsprotokoll der Ereignisanzeige protokolliert.

Benutzeraktion

Um das Problem zu beheben, führen Sie die folgenden Schritte aus:

  • Überprüfen Sie den Windows-Ordner Temp auf das Vorhandensein von lb*.tmp-Dateien. Wenn diese Dateien vorhanden sind, führen Sie die im folgenden Verfahren beschriebenen Schritte aus, um sie zu entfernen.

  • Überprüfen Sie das Laufwerk, auf dem der Ordner Temp gespeichert ist, auf freien Speicherplatz. Wenn der Speicherplatz des Datenträgers erschöpft ist, verwenden Sie das folgende Verfahren, um die Ordner Temp und Tmp auf ein anderes Laufwerk zu verschieben.

So entfernen Sie die lb*.tmp-Dateien aus dem Windows-Ordner "Temp"

  1. Klicken Sie auf Start, wählen Sie Programme aus, wählen Sie Verwaltung aus, und klicken Sie dann auf Dienste.

  2. Führen Sie einen Bildlauf durch, bis der Microsoft Exchange-Informationsspeicherdienst angezeigt wird.

  3. Wenn der Status des Diensts Started lautet, klicken Sie mit der rechten Maustaste auf den Dienst, und klicken Sie dann auf Beenden
Hinweis:
Hierdurch werden alle Benutzer von ihren Postfächern getrennt.
  1. Navigieren Sie zum Ordner %windir%\temp, wobei %windir% der Windows-Systemstammordner ist. Standardmäßig ist dies C:\Windows\Temp.

  2. Löschen Sie alle lb*.tmp-Dateien.

  3. Klicken Sie in der Verwaltungskonsole Dienste mit der rechten Maustaste auf den Dienst Microsoft Exchange-Informationsspeicher, und klicken Sie dann auf Start.

 So verschieben Sie die Ordner "Temp" und "Tmp" auf ein anderes Laufwerk

  1. Klicken Sie auf dem Computer mit Exchange Server auf Start, klicken Sie auf Systemsteuerung, und doppelklicken Sie dann auf System.

  2. Klicken Sie auf die Registerkarte Erweitert, und klicken Sie dann auf Umgebungsvariablen.

  3. Klicken Sie unter Systemvariablen auf die Zeile, die die Variable TEMP und das Laufwerk enthält, klicken Sie auf Bearbeiten, und geben Sie dann den Speicherort des neuen Laufwerks ein.

  4. Klicken Sie unter Systemvariablen auf die Zeile, die die Variable TMP und das Laufwerk enthält, klicken Sie auf Bearbeiten, und geben Sie dann den Speicherort des neuen Laufwerks ein.
Hinweis:
Stellen Sie sicher, dass diese Änderung auf die Systemvariablen und nicht die Benutzervariablen angewendet wird.
Hinweis:
Wenn das Problem durch das hier beschriebene Verfahren nicht behoben wird, finden Sie weitere Informationen im Microsoft Knowledge Base-Artikel 827281 307242, "Der Informationsspeicher wird mit den Fehlern 0xfffff745 und -2235 nicht bereitgestellt" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307242).

Weitere Informationen

Weitere Informationen zu diesem Problem finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 294462, "Exchange lb*.tmp-Dateien im Windows-Ordner "Temp" verursachen den Fehler ESE -2237" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=294462)

  • 307242, "Der Informationsspeicher wird mit den Fehlern 0xfffff745 und -2235 nicht bereitgestellt" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307242)


MSExchangeIS 9519 (0xfffffb3a): Mehrere Datenbanken mit derselben Signatur wurden erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-01-23

Das Microsoft® Exchange-Tool Datenbank-Problembehandlung hat im Protokoll Anwendung ein oder mehrere MSExchangeIS 9519-Ereignisse mit dem Fehlercode 0xfffffb3a festgestellt. Dieser Fehler bedeutet, dass eine andere Kopie derselben Datenbank bereits ausgeführt wird.

Erklärung

Jede Exchange-Datenbank hat eine eigene eindeutige Signatur. Wenn der Microsoft Exchange-Informationsspeicherdienst mehrere Datenbanken mit derselben Signatur erkennt, wird das Bereitstellen einer anderen Kopie der Datenbank verhindert.

Das Ereignis kann auch als Fehler -1222, JET_errDatabaseSignInUse auftreten.

Benutzeraktion

Sie können feststellen, ob zwei Kopien derselben Datenbank in einer einzelnen Speichergruppe vorhanden sind, indem Sie die folgenden Schritte ausführen:

  1. Heben Sie die Bereitstellung aller anderen Datenbanken in der Speichergruppe auf, und versuchen Sie, die Datenbank bereitzustellen, welche die Fehlermeldung verursacht hat.

  2. Wenn die Datenbank bereitgestellt werden kann, müssen Sie anschließend versuchen, alle anderen Datenbanken in der Speichergruppe bereitzustellen.

  3. Wenn für eine andere Datenbank in der Speichergruppe nun derselbe Fehler im Protokoll Anwendung angezeigt wird, haben zwei Datenbanken dieselbe Signatur, was bedeutet, dass es sich um zwei Kopien derselben Datenbank handelt.

Um das Problem zu beheben, müssen Sie sicherstellen, dass nur eine Kopie der Datenbank in dieser bestimmten Speichergruppe vorhanden ist.


MSExchangeIS 9519 (0xfffffe07): Datenbank kann aufgrund eines laufenden Sicherungsvorgangs nicht bereitgestellt werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-02-27

Das Microsoft Exchange-Tool Datenbank-Problembehandlung hat ein oder mehrere MSExchangeIS 9519-Ereignisse mit dem Fehlercode 0xfffffe07 im Anwendungsprotokoll festgestellt. Dieser Fehler bedeutet, dass die angegebene Datenbank aufgrund eines laufenden Sicherungsvorgangs nicht bereitgestellt werden kann.

Erklärung

Dieser Fehler kann auftreten, wenn die Speichergruppe, zu der die Datenbank gehört, mehrere Datenbanken (entweder Postfach- oder Öffentliche Ordner-Datenbanken) enthält und eine dieser Datenbanken zu dem Zeitpunkt gesichert wird, zu dem Sie versucht haben, diese Datenbank bereitzustellen. Dieses Verhalten ist beabsichtigt. Sie können eine Datenbank nicht in einer Speichergruppe bereitstellen, währen Sie eine andere Datenbank in derselben Speichergruppe sichern.

Dieses Ereignis kann auch als -505, JET_errBackupInProgress auftreten.

Benutzeraktion

Vergewissern Sie sich, dass keine anderen Datenbanken in der Speichergruppe gerade gesichert werden, und versuchen Sie anschließend, die Datenbank bereitzustellen. Sie können auch warten, bis die Sicherung der anderen Datenbanken in der Speichergruppe abgeschlossen ist, und dann versuchen, diese Datenbank bereitzustellen.


MSExchangeIS 9519 (0x3f3): Deaktiviertes Kontrollkästchen "Diese Datenbank kann bei einer Wiederherstellung überschrieben werden" nach einer Wiederherstellung
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-01-23

Das Microsoft® Exchange-Tool Datenbank-Problembehandlung hat im Protokoll Anwendung ein oder mehrere MSExchangeIS 9519-Ereignisse mit dem Fehlercode 0x3f3 festgestellt. Dieser Fehler bedeutet, dass eine Wiederherstellung auf eine Datenbank angewendet wurde, ohne dass das Kontrollkästchen Diese Datenbank kann bei einer Wiederherstellung überschrieben werden aktiviert war.

Erklärung

Dieses Ereignis tritt auf, wenn eine Datenbankwiederherstellung erfolgt ist und Exchange erkennt, dass das Kontrollkästchen Diese Datenbank kann bei einer Wiederherstellung überschrieben werden in den Eigenschaften des Informationsspeichers nicht aktiviert war.

Benutzeraktion

Um dieses Problem zu beheben, stellen Sie sicher, dass die Datenbank bei einer Wiederherstellung überschrieben werden kann, indem Sie die folgenden Schritte ausführen.

So aktivieren Sie die Option in Exchange Server 2003 und Exchange 2000 Server

  1. Starten Sie den Exchange-System-Manager.

  2. Erweitern Sie Administrative Gruppen (falls vorhanden).

  3. Erweitern Sie Server, dann <Servername>, danach <Speichergruppe>, und klicken Sie auf die wiederhergestellte Datenbank.

  4. Klicken Sie mit der rechten Maustaste auf die Datenbank, und klicken Sie dann auf Eigenschaften.

  5. Klicken Sie auf die Registerkarte Datenbank.

  6. Aktivieren das Kontrollkästchen Diese Datenbank kann bei einer Wiederherstellung überschrieben werden.

  7. Klicken Sie auf OK.

  8. Um die Datenbank bereitzustellen, klicken Sie mit der rechten Maustaste auf die Datenbank und klicken dann auf Informationsspeicher bereitstellen.
So aktivieren Sie die Option in Exchange Server 2007

  1. Starten Sie die Exchange-Verwaltungskonsole.

  2. Wählen Sie unter Serverkonfiguration die Option Postfach aus.

  3. Klicken Sie im Bereich Datenbankverwaltung mit der rechten Maustaste auf die wiederhergestellte Datenbank.

  4. Klicken Sie auf Eigenschaften.

  5. Klicken Sie auf die Registerkarte Allgemein.

  6. Aktivieren das Kontrollkästchen Diese Datenbank kann bei einer Wiederherstellung überschrieben werden.

  7. Klicken Sie auf OK.

  8. Um die Datenbank bereitzustellen, klicken Sie mit der rechten Maustaste auf die Datenbank und klicken dann auf Datenbank bereitstellen.


MSExchangeIS 9518 (0xfffffc01): Falsches Datenbank- bzw. Transaktionsprotokolllaufwerk- oder verzeichnis
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-01-23

Das Tool Microsoft® Exchange-Datenbank-Problembehandlung hat ein oder mehrere MSExchangeIS 9518-Ereignisse mit dem Fehlercode 0xfffffc01 im Protokoll Anwendung entdeckt. Dies bedeutet, dass für die Exchange-Datenbank- oder -Protokolldateien ein falscher Laufwerksbuchstabe oder Pfad festgelegt wurde.

Erklärung

Dieser Fehler ist ein Hinweis, dass der Datenbank- oder Protokolldateipfad in den betroffenen Speichergruppen auf einen ungültigen Laufwerksbuchstaben zeigt oder dass der Dateipfad falsch ist. Tritt dieser Fehler auf, können keine Datenbanken in der betroffenen Speichergruppe bereitgestellt werden.

Dieses Problem kann auch auftreten, wenn Antivirensoftware den Schreibzugriff auf die Laufwerke mit den Exchange-Datenbank- oder -Transaktionsprotokolldateien verhindert.

Das Ereignis kann auch als Fehler -1023, JET_errInvalidPath auftreten.

Benutzeraktion

Um das Problem zu beheben, führen Sie einen oder mehrere der folgenden Schritte aus:

  • Um zu ermitteln, ob Antivirensoftware das Problem verursacht, deaktivieren Sie die Antivirensoftware vorübergehend in der Konsole Dienste. Versuchen Sie anschließend, die betroffenen Datenbanken bereitzustellen. Wenn die Datenbanken bereitgestellt werden können, fordern Sie beim Hersteller der Antivirensoftware die neueste Version der Software an.

  • Überprüfen und definieren Sie die ordnungsgemäßen System-, Datenbank- und Transaktionsprotokolldatei-Pfade für alle von diesem Fehler betroffenen Speichergruppen und Datenbanken. Gehen Sie folgendermaßen vor:

So werden in Exchange Server 2003 und Exchange 2000 Server die ordnungsgemäßen Dateipfade überprüft und festgelegt

  1. Starten Sie den Exchange-System-Manager. Klicken Sie auf Start, zeigen Sie auf Programme, dann auf Microsoft Exchange, und klicken Sie anschließend auf System-Manager.

  2. Wenn im Exchange-System-Manager administrative Gruppen angezeigt werden, erweitern Sie Administrative Gruppen und danach die administrative Gruppe, in der das Problem auftritt.

  3. Erweitern Sie Server und dann den Server, auf dem das Problem auftritt.

  4. Klicken Sie mit der rechten Maustaste auf die Speichergruppe mit der Datenbank, die nicht bereitgestellt werden kann, und klicken Sie dann auf Eigenschaften.

  5. Untersuchen Sie auf der Registerkarte Allgemein den im Feld Pfad des Transaktionsprotokolls angezeigten Pfad. Untersuchen Sie den Pfad im Feld Systempfad.

    Sind diese Pfade falsch, fordern Sie beim Microsoft Software Service Hilfe zur Behebung dieses Problems an.

  6. Befolgen Sie die Schritte 3 und 5 für jede vorhandene Speichergruppe, um den Pfad der Datenbank und Transaktionsprotokolldatei zu überprüfen.

  7. Nachdem Sie den Systempfad und Pfad der Transaktionsprotokolldateien für alle Speichergruppen überprüft haben, überprüfen Sie die Datenbankpfade aller Datenbanken in allen Speichergruppen. Führen Sie dazu die folgenden Schritte durch:

    1. Erweitern Sie eine Speichergruppe, z. B. Erste Speichergruppe.

    2. Klicken Sie mit der rechten Maustaste auf StoreName (ServerName), und klicken Sie dann auf Eigenschaften.

    3. Klicken Sie auf die Registerkarte Datenbank, und überprüfen Sie den im Feld Exchange-Datenbank angezeigten Pfad. Überprüfen Sie anschließend den Pfad im Feld Exchange-Streamingdatenbank.

      Ist ein bestimmter Pfad falsch, fordern Sie beim Microsoft Software Service Hilfe zur Behebung dieses Problems an.

    4. Wiederholen Sie die Schritte 7b und 7c, um die Pfade der einzelnen Postfachspeicher- bzw. Öffentlichen Ordner-Datenbanken in allen Speichergruppen zu überprüfen.

  8. Stellen Sie die Postfach- oder Öffentliche Ordner-Datenbank bereit.

So werden in Exchange Server 2007 die ordnungsgemäßen Dateipfade überprüft und festgelegt

  1. Starten Sie die Exchange-Verwaltungskonsole. Klicken Sie auf Start, zeigen Sie auf Programme, dann auf Microsoft Exchange, und klicken Sie anschließend auf Exchange-Verwaltungskonsole.

  2. Wählen Sie unter Serverkonfiguration die Option Postfach aus.

  3. Wählen Sie im Bereich Datenbankverwaltung die Speichergruppe mit den Datenbanken aus, die nicht bereitgestellt werden können.

  4. Klicken Sie mit der rechten Maustaste auf die Speichergruppe, und klicken Sie dann auf Eigenschaften.

  5. Untersuchen Sie auf der Registerkarte Allgemein die Pfade in den Feldern Protokollfald und Systempfad.

    Sind die Pfade falsch, klicken Sie mit der rechten Maustaste auf die Speichergruppe und wählen Speichergruppenpfad verschieben. Klicken Sie unter Pfad für Protokolldateien und Pfad der Systemdateien auf Durchsuchen, um den Ordner mit den Transaktionsprotokoll- oder Datenbankdateien zu suchen. In der Standardeinstellung befinden sich die Transaktionsprotokoll- und Datenbankdateien in folgendem Ordner:

    %PROGRAMFILES%\Microsoft\Exchange Server\Mailbox\<Name der Speichergruppe>

  6. Klicken Sie auf OK.

  7. Befolgen Sie die Schritte 3 und 5 für jede vorhandene Speichergruppe, um den Systempfad und den Pfad der Transaktionsprotokolldateien zu überprüfen.

  8. Nachdem Sie den Systempfad und Pfad der Transaktionsprotokolldateien für alle Speichergruppen überprüft haben, überprüfen Sie die Datenbankpfade aller Datenbanken in allen Speichergruppen. Führen Sie dazu die folgenden Schritte durch:

    1. Erweitern Sie eine Speichergruppe, z. B. Erste Speichergruppe.

    2. Überprüfen Sie im Bereich Datenbankverwaltung den Pfad unter Datenbank-Dateipfad.

    3. Ist ein bestimmter Pfad falsch, klicken Sie mit der rechten Maustaste auf die Datenbank und klicken anschließend auf Datenbankpfad verschieben.

    4. Klicken Sie auf Durchsuchen, um den ordnungsgemäßen Ordner der Datenbankdatei auszuwählen. In der Standardeinstellung befindet sich die Exchange Datenbankdatei (.edb) in folgendem Ordner:

      %PROGRAMFILES%\Microsoft\Exchange Server\Mailbox\<Name der Speichergruppe>\<Datenbankbane.edb>

    5. Klicken Sie auf OK.

    6. Wiederholen Sie die Schritte 8b bis 8e, um die Pfade der einzelnen Postfachspeicher- bzw. Öffentlichen Ordner-Datenbanken in allen Speichergruppen zu überprüfen.

  9. Stellen Sie die Postfach- oder Öffentliche Ordner-Datenbank bereit.


MSExchangeIS 9519 (0xfffffbda): Fehlendes DBCS-Gebietsschema (Double Byte Character Set) als standardmäßiges Systemgebietsschema konfiguriert
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-01-23

Das Microsoft® Exchange-Tool Datenbank-Problembehandlung hat im Protokoll Anwendung ein oder mehrere MSExchangeIS 9519-Ereignisse mit dem Fehlercode 0xfffffbda festgestellt. Das Ereignis ist ein Hinweis darauf, dass ein nicht englisches Standardgebietsschema installiert wurde. Nach der Installation von Exchange Server wurde das Standardgebietsschema deinstalliert.

Erklärung

Wenn das Ereignis MSExchangeIS 9519 mit dem Fehlercode 0xfffffbda beim Neustarten des Servers mit Exchange ausgelöst wird, können die Exchange-Datenbanken nicht bereitgestellt werden. Darüber hinaus werden die Fehlerereignisse ESE 604 und MSExchangeIS 9519 im Ereignisprotokoll Anwendung aufgezeichnet.

Dieses Verhalten kann auftreten, wenn Sie zuvor ein nicht englisches Gebietsschema als Standardgebietsschema festgelegt hatten. Wenn Sie ein anderes Gebietsschema als Standardgebietsschema ausgewählt haben, das nicht englische Gebietsschema entfernt haben und anschließend den Server mit Exchange 2000 Server oder Exchange Server 2003 neu gestartet haben, tritt dieses Ereignis auf.

Das Ereignis kann auch als -1062, JET_errInvalidLanguageId auftreten. Dieses Ereignis tritt in den folgenden Versionen von Exchange Server auf:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Benutzeraktion

Um das Problem zu beheben, müssen Sie das nicht englische Gebietsschema neu installieren oder neue Datenbanken anlegen. Wenn Sie das nicht englische Gebietsschema neu installieren, muss es nicht als Standardgebietsschema festgelegt werden.


MSExchangeIS 9519 (0xfffff05b): Datenbanken oder Protokolle auf einem Server, auf dem Exchange Server 2000 SP3 oder höher ausgeführt wird und die Dateisystemkomprimierung aktiviert ist
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-02-19

Das Microsoft Exchange-Tool Datenbank-Problembehandlung hat im Anwendungsprotokoll ein oder mehrere MSExchangeIS 9519-Ereignisse mit dem Fehlercode 0xfffff05b festgestellt. Dieser Fehler bedeutet, dass sich die Exchange-Datenbank- oder Transaktionsprotokolldateien auf einem Laufwerk befinden, auf dem die Dateisystemkomprimierung aktiviert ist.

Erklärung

Dieses Ereignis kann eintreten, wenn Sie Exchange 2000 Server Service Pack 3 (SP3) auf einen Computer mit Exchange 2000 Server mit einer Informationsspeicher-Datenbank aufspielen, die mithilfe der NTFS-Dateisystemkomprimierung komprimiert wurde. Dieses Problem kann auch auftreten, wenn ein Computer mit Exchange 2000 Server auf Exchange Server 2003 aktualisiert wird. Exchange 2000 Server SP3, Exchange Server 2003 und Exchange Server 2007 verhindern die Bereitstellung komprimierter Informationsspeicher-Datenbanken.

Dieser Fehler kann auch als -4005, JET_errFileCompressed auftreten. Dieser Fehler tritt in den folgenden Versionen von Exchange Server auf:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server SP3

Benutzeraktion

Zum Beheben dieses Problems müssen Sie die Ordner dekomprimieren, in denen sich die Informationsspeicher-Datenbanken und Protokolle befinden, dann die Datenbanken defragmentieren und anschließend eine für Exchange geeignete Onlinesicherung der Informationsspeicher-Speichergruppen ausführen, in denen sich die Datenbanken und Protokolle befinden. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 327772, Database does not mount, and you receive error 0xfffff05b after you apply SP3 to Exchange 2000.


MSExchangeIS 9519 (0xfffffa84): Fehlende oder beschädigte Datenbankindizes
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-01-22

Das Microsoft® Exchange-Tool Datenbank-Problembehandlung hat im Protokoll Anwendung ein oder mehrere MSExchangeIS 9519-Ereignisse mit dem Fehlercode 0xfffffa84 festgestellt. Dieses Ereignis bedeutet, dass die Indizes dieser Datenbank entweder beschädigt sind oder fehlen.

Erklärung

Ein beschädigter oder fehlender Datenbankindex kann folgende Ursachen haben:

  • Eine Indexbereinigung einer Exchange-Datenbank nach dem Aufspielen eines neuen Microsoft Windows Service Pack. Nach dem Aufspielen des Service Pack können Sie auf dem Server mit Exchange das Postfach oder die Öffentlichen Ordner-Datenbanken nicht bereitstellen. Darüber hinaus werden die Ereignisse ESE 609 und ESE 611 im Ereignisprotokoll Anwendung aufgezeichnet.

  • Dies kann nach dem Ausführen einer Datenbankreparatur (eseutil /p) vorkommen. Dadurch kann ein Index entfernt werden, der bei der Ersterstellung der Datenbank generiert wird. Durch Ausführen des Reparaturbefehls Eseutil wird der Index entfernt.

Dieses Ereignis kann auch als -1404, JET_errIndexNotFound auftreten. Dieser Fehler tritt in den folgenden Versionen von Exchange Server auf:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Benutzeraktion

Um dieses Problem zu beheben, befolgen Sie die Anweisung, die dem zuvor beschriebenen Problemszenario entspricht:

  • Wenn ein Index während der Indexbereinigung einer Exchange-Datenbank nach dem Aufspielen eines neuen Windows Service Pack beschädigt wird, befolgen Sie diese Schritte:

    1. Stellen Sie das betroffene Postfach bzw. die betroffene Öffentliche Ordner-Datenbank aus einer als funktionierend bekannten Sicherung wieder her.

    2. Führen Sie eine Offlinedefragmentierung der betroffenen Datenbank durch Ausführen von eseutil /d durch. Informationen zur Offlinedefragmentierung der betroffenen Datenbank finden Sie unter den folgenden Themen:

      Exchange 2000 Server- oder Exchange Server 2003-Datenbanken: Ausführen von Eseutil /D (Defragmentierung)

      Exchange Server 2007-Datenbanken: Ausführen von Eseutil /D (Defragmentierung)

  • Wenn ein Index fehlt, nachdem Sie eine Datenbankreparatur (eseutil /p) ausgeführt haben, spielen Sie den im Microsoft Knowledge Base-Artikel 924627, Wenn Sie versuchen, eine Datenbank bereitzustellen, nachdem Sie die Programme Eseutil und Isinteg zum Wiederherstellen der Datenbank in Exchange 2003 verwenden, wird die Ereignis-ID 9519 mit dem Fehler 0xfffffa84 protokolliert beschriebenen Hotfix auf.


MSExchangeIS 9519 0x972: Container für Öffentliche Ordner gelöscht oder fehlende erforderliche Attribute
Microsoft Exchange Server Analyzer-Tools - Artikel > Datenbankwiederherstellung >

Letztes Änderungsdatum des Themas: 2007-08-30

Das Microsoft Exchange-Tool Datenbank-Problembehandlung hat im Anwendungsprotokoll mindestens ein MSExchangeIS 9519-Ereignis mit dem Fehlercode 0x3f3 erkannt. Dies zeigt einen Fehler bei der Bereitstellung der Öffentlichen Ordner-Datenbanken an, weil der Container für Öffentliche Ordner gelöscht wurde oder ihm erforderliche Attribute fehlen.

Erklärung

Dieser Fehler kann auftreten, wenn der Container für Öffentliche Ordner aus Active Directory gelöscht wurde oder der betroffene Öffentliche Informationsspeicher nicht für die Verwendung des Containers für Öffentliche Ordner konfiguriert ist, d. h., der Wert für das Attribut msExchOwningPFTreeBL des Containers für Öffentliche Ordner nicht auf den Öffentlichen Informationsspeicher verweist. Die wahrscheinlichste Ursache für diesen Fehler ist, dass die administrative Gruppe, die den Container für Öffentliche Ordner enthielt, gelöscht wurde, ohne dass der Container für Öffentliche Ordner zuvor in eine neue administrative Gruppe verschoben wurde.

Benutzeraktion

Um dieses Problem zu beheben, verwenden Sie die ADSI-Bearbeitung oder ein ähnliches Tool. Ermitteln Sie mit diesem, ob der Container für Öffentliche Ordner vorhanden und das Attribut msExchOwningPFTreeBL ordnungsgemäß konfiguriert ist und auf den relevanten Öffentlichen Informationsspeicher verweist.

Achtung:
Wenn Sie die ADSI-Bearbeitung, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, von Exchange Server 2003 bzw. Exchange Server 2007 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So ermitteln Sie die Ursache des Fehlers

  1. Verwenden Sie die ADSI-Bearbeitung oder ein vergleichbares Tool, um alle administrativen Gruppenobjekte in Active Directory zu suchen.

    Das administrative Gruppenobjekt befindet sich unter:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group

  2. Erweitern Sie jede der administrativen Gruppen, und überprüfen Sie, ob ein Container CN=Folder Hierarchies vorhanden ist. Ist dies der Fall, markieren Sie den Container und vergewissern sich, dass ein Objekt CN=Public Folders im rechten Bereich vorhanden ist. Wenn kein Objekt CN=Public Folders unter einer der administrativen Gruppen vorhanden ist, fahren Sie mit Lösung 1 fort und erstellen Ordnerhierarchien und Container für Öffentliche Ordner neu. Wenn Sie einen Container CN=Public Folders finden, fahren Sie mit Schritt 3 fort.

  3. Klicken Sie mit der rechten Maustaste auf das Objekt CN=Public Folders, und klicken Sie dann auf Eigenschaften.

  4. Wählen Sie in der Liste Attribute das Attribut msExchOwningPFTreeBL aus, und klicken Sie dann auf Bearbeiten.

  5. Stellen Sie sicher, dass der betroffene Informationsspeicher für Öffentliche Ordner in der Liste Werte angezeigt wird. Wenn er nicht in der Liste enthalten ist, fahren Sie mit Lösung 2 fort.
Lösung 1: Erneutes Erstellen der Ordnerhierarchien und Container für Öffentliche Ordner

  1. Verwenden Sie die ADSI-Bearbeitung oder ein vergleichbares Tool, um die Administrative Gruppe von Exchange (FYDIBOHF23SPDLT) zu suchen und zu erweitern.

    Das Objekt Administrative Gruppe von Exchange (FYDIBOHF23SPDLT) befindet sich unter:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups

  2. Klicken Sie mit der rechten Maustaste auf das Objekt Administrative Gruppe von Exchange (FYDIBOHF23SPDLT), klicken Sie auf Neu und dann auf Objekt.

  3. Wählen Sie aus der Liste Wählen Sie eine Klasse aus den Eintrag msExchPublicFolderTreeContainer aus, und klicken Sie dann auf Weiter.

  4. Geben Sie im Feld Wert die Angabe Ordnerhierarchien ein, klicken Sie dann auf Weiter und anschließend auf Fertig stellen.

  5. Klicken Sie mit der rechten Maustaste auf das neu erstellte Objekt Ordnerhierarchien, klicken Sie auf Neu und dann auf Objekt.

  6. Wählen Sie aus der Liste Wählen Sie eine Klasse aus den Eintrag msExchPFTree aus, und klicken Sie dann auf Weiter.

  7. Geben Sie im Feld Wert die Angabe Öffentliche Ordner ein, und klicken Sie dann auf Weiter.

  8. Klicken Sie auf Weitere Attribute.

  9. Wählen Sie aus dem Dropdownfeld Anzuzeigende Eigenschaft auswählen die Angabe msExchPFTree aus.

  10. Geben Sie im Feld Attribut bearbeiten den Wert 1 ein, klicken Sie auf Festlegen, klicken Sie auf OK und dann auf Fertig stellen.

  11. Um den Container für Öffentliche Ordner den einzelnen Öffentlichen Informationsspeichern zuzuweisen, klicken Sie mit der rechten Maustaste auf den Container Öffentliche Ordner und wählen dann Eigenschaften aus.

  12. Wählen Sie aus der Liste Attribute die Angabe distinguishedName aus, und klicken Sie dann auf Bearbeiten.

  13. Kopieren Sie den Inhalt des Felds Wert in die Zwischenablage, und klicken Sie dann auf Abbrechen.

  14. Navigieren Sie auf jedem Server, auf dem der Fehler "MSExchangeIS 9519" mit dem Fehlercode 0x972 aufgetreten ist, zum Objekt für den Informationsspeicher für Öffentliche Ordner. Der Standardspeicherort für dieses Objekt lautet folgendermaßen:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups, CN=Exchange Administrative Group (FYDIBOHF23SPDLT), CN=Servers, CN= ServerName , CN= InformationStore , CN=Second Storage Group.

  15. Klicken Sie mit der rechten Maustaste auf das Objekt für den Informationsspeicher für Öffentliche Ordner, und klicken Sie dann auf Eigenschaften.

  16. Wählen Sie aus der Liste Attribute die Angabe msExchOwningPFTree aus, und klicken Sie dann auf Bearbeiten.

  17. Fügen Sie den in Schritt 13 in die Zwischenablage kopierten Wert in das Feld Wert ein, und klicken Sie dann zweimal auf OK, um den Vorgang abzuschließen.

  18. Wiederholen Sie die Schritte 15 bis 17 für jeden Server, der das Ereignis "MSExchangeIS 9519" mit dem Fehlercode 0x972 aufweist.

  19. Starten Sie den Microsoft Exchange-Informationsspeicherdienst auf den betroffenen Servern neu.

Lösung 2: Erneutes Auffüllen des Attributwerts "msExchOwningPFTreeBL" für das Objekt für den Container für Öffentliche Ordner mit Daten

  1. Verwenden Sie die ADSI-Bearbeitung oder ein vergleichbares Tool, um das Objekt Öffentliche Ordner in Active Directory zu suchen.

    Das Objekt Öffentliche Ordner befindet sich unter:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Folder Hierarchies,CN=Public Folders

  2. Klicken Sie mit der rechten Maustaste auf den Container Öffentliche Ordner, und wählen Sie dann Eigenschaften aus.

  3. Wählen Sie aus der Liste Attribute die Angabe distinguishedName aus, und klicken Sie dann auf Bearbeiten.

  4. Kopieren Sie den Inhalt des Felds Wert in die Zwischenablage, und klicken Sie dann auf Abbrechen.

  5. Navigieren Sie auf jedem Server, auf dem der Fehler "MSExchangeIS 9519" mit dem Fehlercode 0x972 aufgetreten ist, zum Objekt für den Informationsspeicher für Öffentliche Ordner. Der Standardspeicherort für dieses Objekt lautet folgendermaßen:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups, CN=Exchange Administrative Group (FYDIBOHF23SPDLT), CN=Servers, CN= ServerName , CN= InformationStore , CN=Second Storage Group.

  6. Klicken Sie mit der rechten Maustaste auf das Objekt für den Informationsspeicher für Öffentliche Ordner, und klicken Sie dann auf Eigenschaften.

  7. Wählen Sie aus der Liste Attribute die Angabe msExchOwningPFTree aus, und klicken Sie dann auf Bearbeiten.

  8. Fügen Sie den in Schritt 4 in die Zwischenablage kopierten Wert in das Feld Wert ein, und klicken Sie dann zweimal auf OK, um den Vorgang abzuschließen.

  9. Wiederholen Sie die Schritte 6 bis 8 für jeden Server, der das Ereignis "MSExchangeIS 9519" mit dem Fehlercode 0x972 aufweist.

  10. Starten Sie den Microsoft Exchange-Informationsspeicherdienst auf den betroffenen Servern neu.


Exchange-Cluster
Microsoft Exchange Server Analyzer-Tools - Artikel >

Letztes Änderungsdatum des Themas: 2005-11-18

In den Artikeln in diesem Abschnitt erhalten Sie ausführliche Informationen über die Daten, die Microsoft® Exchange Server Analyzer in Bezug auf Exchange-Cluster auswertet. Darüber hinaus werden in diesen Artikeln Aktionen beschrieben, die Sie durchführen können, um Fehler, Warnungen und vom Standard abweichende Konfigurationen im Zusammenhang mit Exchange beheben zu können, die von Exchange Server Analyzer gefunden wurden.


Debuggen von Clustern ist aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange-Cluster >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungswert, um zu bestimmen, ob das Debuggen von Clustern auf dem Server aktiviert ist:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Cluster\Debug

Wenn Exchange Server Analyzer ermittelt, dass der Wert Debug gleich 1 ist, wird eine Warnmeldung angezeigt.

Das Debuggen von Clustern führt bei diesem Registrierungswert dazu, dass Clusterressourcen kein Failover zwischen Knoten durchführen. Sie sollten diesen Registrierungswert nur beim Debuggen von Fehlern verwenden, bei denen Clusterressourcen kein Failover durchführen sollen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So deaktivieren Sie den Registrierungsschlüssel zum Debuggen von Clustern

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu HKLM\Software\Microsoft\Exchange\Cluster.

  3. Ändern Sie den Wert Debug in 0.

  4. Beenden Sie den Registrierungs-Editor.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Weitere Informationen über Exchange-Cluster finden Sie im Thema „Verwalten von Exchange-Clustern" im Technischen Referenzhandbuch für Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=3768246d-c9ed-45d8-bece-a666143cba4e&DisplayLang=de).


Priorität für dediziertes Cluster-Heartbeat-Netzwerk ist falsch festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange-Cluster >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Priorität für die Anforderung der einzelnen Netzwerkschnittstellen im Exchange-Servercluster zu ermitteln:

HKEY_LOCAL_MACHINE\Cluster\Networks\<NetworkInterfaceGUID>\Priority

Der Wert für Priority gibt die für die Netzwerkschnittstellenressource konfigurierte Priorität im Netzwerk an. Die Netzwerkschnittstellenressource mit der höchsten Priorität erhält den Wert 1, die nächst niedrigere Priorität den Wert 2 usw.

Exchange Server Analyzer liest außerdem den folgenden Registrierungseintrag, um die für jedes Netzwerk definierte Rolle im Exchange Server-Cluster zu bestimmen:

HKLM\Cluster\Networks\<GUID der Netzwerkschnittstelle>\Role

Der Wert 1 gibt an, dass die Netzwerkressource als dediziertes privates Netzwerk (Heartbeat-Netzwerk) konfiguriert wurde. Der Wert 2 gibt an, dass die Netzwerkressource als dediziertes öffentliches Netzwerk (Clientzugriff) konfiguriert wurde. Der Wert 3 gibt an, dass die Netzwerkressource als gemischtes Netzwerk konfiguriert wurde, das Datenverkehr sowohl über Heartbeat-Verbindungen als auch über Clientverbindungen zulässt.

Wenn Exchange Server Analyzer feststellt, dass eine Netzwerkschnittstellenressource für Role den Wert 1 und für Priority einen Wert größer als 1 aufweist, wird eine Warnung angezeigt. Diese Warnung zeigt an, dass ein dediziertes Heartbeat-Netzwerk gefunden wurde, dessen Netzwerkpriorität nicht ordnungsgemäß festgelegt wurde.

Das Konfigurieren eines dedizierten privaten Netzwerks für die Cluster-Heartbeat-Verbindungen ist eine empfohlene optimale Methode für alle Exchange Server-Cluster. Die Kommunikation zwischen Knoten ist für reibungslose Clustervorgänge entscheidend. Anhand der folgenden Anweisungen können Sie die Netzwerkpriorität für das dedizierte Heartbeat-Netzwerk richtig konfigurieren.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie das Cluster-Administratorprogramm, und stellen Sie eine Verbindung mit dem Exchange-Servercluster her.

  2. Klicken Sie im linken Bereich mit der rechten Maustaste auf das Objekt Cluster ganz oben in der Hierarchie, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf Netzwerkpriorität.

  4. Wählen Sie die dedizierte Heartbeat-Netzwerkressource aus.

  5. Klicken Sie auf Nach oben, bis sich die dedizierte Heartbeat-Netzwerkressource oben in der Liste der Netzwerkressourcen befindet.

  6. Klicken Sie auf OK.

Weitere Informationen zu Cluster Heartbeat-Netzwerken finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 258750, „Empfehlungen für die private Heartbeat-Konfiguration auf einem Clusterserver" (http://support.microsoft.com/kb/258750/de)

  • 307962, „Multicast Support Enabled for the Cluster Heartbeat" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307962)

Weitere Einzelheiten finden Sie in Exchange Server 2003 Cluster Configuration Checklist unter http://go.microsoft.com/fwlink/?linkid=36083.


Clusterknoten der Windows-Buildnummer passt nicht zum ersten Knoten
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange-Cluster >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Kernversion des Microsoft Windows-Betriebssystems zu bestimmen, das auf den einzelnen Clusterknoten ausgeführt wird:

HKEY_LOCAL_MACHINE\Cluster\Nodes\<Knotennummer>\BuildNumber

Wenn Exchange Server Analyzer auf dem zweiten oder folgenden Knoten im Exchange-Cluster einen Wert für BuildNumber ermittelt, der sich vom Wert für BuildNumber auf dem ersten Knoten im Exchange-Cluster unterscheidet, wird ein Fehler angezeigt.

Wenn ein Exchange-Cluster über verschiedene Versionen von Windows ausgeführt wird, tritt ein Failover möglicherweise nicht wie erwartet oder konfiguriert auf. In einer Windows-Umgebung mit verschiedenen Versionen tritt ein Failover nur von einer früheren Version des Betriebssystems auf eine spätere Version des Betriebssystems auf (z. B. von Windows 2000 Advanced Server auf Windows Server™ 2003 Enterprise Edition). Ein Failover tritt nicht von einer späteren Version des Betriebssystems auf eine frühere Version des Betriebssystems auf (z. B. von Windows Server 2003 auf Windows 2000 Server).

Zum Beheben dieses Problems müssen Sie alle Knoten auf dasselbe Betriebssystem und Service Pack aktualisieren. Um die Ausfallzeit zu verringern, können Sie ein Rolling Upgrade des Clusters ausführen.

So beheben Sie diesen Fehler

  1. Machen Sie sich mit den Anweisungen zum Ausführen eines Rolling Upgrades für einen Cluster vertraut. Informationen hierzu finden Sie im Microsoft Knowledge Base-Artikel 811272 „How to Perform a Rolling Upgrade of Windows Server 2003 Server Clusters" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=811272.

  2. Lesen Sie den Artikel „Windows 2000 Clustering: Performing a Rolling Upgrade" unter http://go.microsoft.com/fwlink/?linkid=1718.

  3. Führen Sie ein Rolling Upgrade für jeden Knoten aus, dessen Wert für BuildNumber nicht mit dem entsprechenden Wert des ersten Knotens im Cluster übereinstimmt.

Informationen zu alternativen Vorgehensweisen finden Sie im Dokument „Alternatives to rolling upgrades" unter http://go.microsoft.com/fwlink/?LinkId=41363.


Clusterknoten der Windows-Service-Pack-Version stimmt nicht mit dem ersten Knoten überein.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange-Cluster >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Version des Microsoft Windows® Service Packs zu bestimmen, das auf den einzelnen Clusterknoten installiert ist:

HKEY_LOCAL_MACHINE\Cluster\Nodes\<Knotennummer>\CSDVersion

Wenn Exchange Server Analyzer auf dem zweiten oder folgenden Knoten im Exchange-Cluster einen Wert für CSDVersion ermittelt, der sich vom Wert für CSDVersion auf dem ersten Knoten im Exchange-Cluster unterscheidet, wird ein Fehler angezeigt.

Dieser Fehler gibt an, dass die Knoten im Exchange-Cluster nicht die gleiche Windows Service Pack-Ebene ausführen. Als optimale Methode wird empfohlen, dass alle Knoten in einem Exchange-Cluster die gleiche Stufe von Betriebssystem und Service Pack ausführen.

Zum Beheben dieses Problems müssen Sie alle Knoten auf das gleiche Betriebssystem und Service Pack aktualisieren. Um die Ausfallzeit zu verringern, können Sie eine Aktualisierung im Wechsel (Rolling Upgrade) des Clusters ausführen.

So beheben Sie diese Warnmeldung

  1. Machen Sie sich mit den Anweisungen zum Ausführen eines Rolling Upgrades für einen Cluster vertraut. Informationen hierzu finden Sie im Microsoft Knowledge Base-Artikel 811272 „How to Perform a Rolling Upgrade of Windows Server 2003 Server Clusters" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=811272.

  2. Lesen Sie den Artikel „Windows 2000 Clustering: Performing a Rolling Upgrade" unter http://go.microsoft.com/fwlink/?linkid=34288.

  3. Führen Sie eine Aktualisierung im Wechsel für jeden Knoten aus, dessen Wert für CSDVersion nicht mit dem entsprechenden Wert des ersten Knotens im Cluster übereinstimmt.

Informationen zu alternativen Vorgehensweisen finden Sie im Dokument „Alternatives to rolling upgrades" unter http://go.microsoft.com/fwlink/?linkid=34289.


Der Pfad für „Cluster TEMP/TMP" befindet sich auf demselben Laufwerk wie die Systempartition.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange-Cluster >

Letztes Änderungsdatum des Themas: 2005-11-18

Auf einem Exchange-Server, der nicht Teil eines Clusters ist, liest Microsoft® Exchange Server Analyzer die folgenden Registrierungseinträge, um den Wert für die Umgebungsvariablen TEMP und TMP zu bestimmen.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

HKLM\System\CurrentControlSet\Control\Session Manager\Environment\TMP

Wenn Exchange Server Analyzer für einen virtuellen Exchange-Server (Exchange Virtual Server, EVS) in einem Microsoft Windows®-Servercluster ausgeführt wird, wird die Registrierungsstruktur HKLM nicht gelesen. Stattdessen werden die folgenden Registrierungseinträge gelesen:

HKEY_USERS\<Clusterdienstkonto-SID>\Environment\TEMP

HKEY_USERS\<Clusterdienstkonto-SID>\Environment\TMP

Wenn Exchange Server Analyzer feststellt, dass die Umgebungsvariable TEMP bzw. TMP mit %SYSTEMROOT anfängt, wird eine Warnung angezeigt.

Der Prozess des Microsoft Exchange-Informationsspeicherdiensts verwendet den Ordner TEMP und den Ordner TMP während verschiedener Vorgänge als temporären Speicher, z. B. beim Konvertieren von Nachrichten und beim Verschieben von Postfächern. Auf einem Exchange-Server, der sich nicht in einem Cluster befindet, verwendet der Microsoft Exchange-Informationsspeicherdienst das SYSTEM (z. B. Lokales System), für das eine Umgebungsvariablen-Standardeinstellung von %Systemroot%\Temp für TEMP und TMP gilt.

Virtuelle Exchange-Server, die in einem Windows-Servercluster ausgeführt werden, verwenden die Umgebungsvariableneinstellungen des Cluster-Dienstkontos, das im Kontext des Sicherheitsprinzips eines bestimmten Benutzers ausgeführt wird. Für Benutzerkonten wird die Standardumgebungsvariable für TEMP und TMP auf %Userprofile%\temp festgelegt.

Mithilfe der Umgebungsvariablen TEMP und TMP wird festgelegt, welche Ordner im Dateisystem (z. B. welcher Pfad) von Anwendungen verwendet werden sollen, die einen temporären Arbeitsbereich erfordern. TEMP wird üblicherweise von Anwendungen (z. B. Exchange) verwendet; TMP wird üblicherweise von Entwicklungstools verwendet, z. B. von Microsoft Visual C++®. Der Pfad für die einzelnen Variablen bezieht sich normalerweise auf den Sicherheitskontext der Anwendung bzw. des Tools.

Zur Optimierung der Leistung empfiehlt es sich, dass für die von Exchange verwendeten Ordner TEMP und TMP nicht die Festplatte mit dem Betriebssystem verwendet wird. Darüber hinaus müssen Sie sicherstellen, dass diese Umgebungsvariablen auf Pfade auf einer schnellen Festplatte bzw. einem Festplattenteilsystem (z. B. Gruppe von RAID 0+1-Spindeln) festgelegt sind. Es wird außerdem empfohlen, dass für die von Exchange bzw. virtuellen Exchange-Servern verwendeten Ordner TEMP und TMP nicht der Datenträger verwendet wird, auf dem sich das Betriebssystem befindet.

So beheben Sie dieses Problem

  1. Melden Sie sich bei einem Knoten im Cluster mit dem Cluster-Dienstkonto an.

  2. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und wählen Sie Eigenschaften aus.

  3. Klicken Sie auf Erweitert.

  4. Klicken Sie auf Umgebungsvariablen.

  5. Im Bereich Benutzervariablen für <Kontoname> wählen Sie TEMP aus, und klicken Sie auf Bearbeiten.

  6. Im Feld Variablenwert geben Sie den neuen Pfad für die Umgebungsvariable TEMP ein, und klicken Sie auf OK.

  7. Im Bereich Benutzervariablen für <Kontoname> wählen Sie TMP aus, und klicken Sie auf Bearbeiten.

  8. Im Feld Variablenwert geben Sie den neuen Pfad für die Umgebungsvariable TMP ein, und klicken Sie auf OK.

  9. Klicken Sie auf OK, um das Dialogfeld Umgebungsvariablen zu schließen und nochmals auf OK, um das Dialogfeld Systemeigenschaften zu schließen.

  10. Starten Sie den Knoten neu, um die Änderung zu übernehmen.

  11. Wiederholen Sie die Schritte 1 bis 10 für jeden Knoten des Clusters.

Informationen zum Ändern der Umgebungsvariablen TEMP und TMP auf einem Exchange-Server, der sich nicht in einem Cluster befindet, finden Sie unter: Die TEMP/TMP-Variable zeigt anscheinend auf einen ungültigen oder unpassenden Ordner..


Dedizierter Cluster Heartbeat wurde nicht gefunden.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange-Cluster >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die definierte Rolle für die jeweiligen Ressourcen der Netzwerkschnittstellen im Exchange-Servercluster zu bestimmen:

HKEY_LOCAL_MACHINE\Cluster\Networks\<NetworkInterfaceGUID>\Role

Der Wert 1 gibt an, dass die Netzwerkressource als dediziertes privates Netzwerk (Heartbeat-Netzwerk) konfiguriert wurde. Der Wert 2 gibt an, dass die Netzwerkressource als dediziertes öffentliches Netzwerk (Clientzugriff) konfiguriert wurde. Der Wert 3 gibt an, dass die Netzwerkressource als gemischtes Netzwerk konfiguriert wurde, das Datenverkehr sowohl über Heartbeat-Verbindungen als auch über Clientverbindungen zulässt.

Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_Service ab, um den Wert des Schlüssels Started für den Clusterdienst (ClusSvc) zu bestimmen. Der Wert True gibt an, dass der Clusterdienst gestartet ist, der Wert False gibt an, dass der Clusterdienst nicht ausgeführt wird.

Wenn Microsoft Exchange Server Analyzer keine Netzwerkressource in einem als dediziertes privates Netzwerk konfigurierten Exchange-Cluster findet, wird eine Warnung angezeigt.

Das Konfigurieren eines dedizierten privaten Netzwerks für die Cluster-Heartbeat-Verbindungen ist eine empfohlene optimale Methode für alle Exchange Server-Cluster. Die Kommunikation zwischen Knoten ist für reibungslose Clustervorgänge entscheidend. Sie müssen die für die Clusterkommunikation verwendeten Netzwerke optimal konfigurieren und sämtliche Anforderungen in der Hardwarekompatibilitätsliste erfüllen. Für die Netzwerkkonfiguration müssen die Knoten eines Clusters durch mindestens zwei unabhängige Netzwerke verbunden werden, um ein Versagen aufgrund einer einzelnen Fehlerstelle zu vermeiden. Normalerweise werden zwei lokale Bereichsnetzwerke verwendet. Der technische Support von Microsoft unterstützt nicht die Konfiguration von Clustern, deren Knoten nur durch ein Netzwerk verbunden sind.

So beheben Sie diese Warnmeldung

  1. Wenn nicht bereits vorhanden, fügen Sie Netzwerkschnittstellenkarten für jeden Knoten im Exchange-Cluster hinzu, und konfigurieren Sie die Netzwerkschnittstellenkarten im Cluster-Administrationsprogramm als privates Netzwerk.

  2. Wenn zusätzliche Netzwerkkarten vorhanden sind, jedoch für gemischte Netzwerke verwendet werden, muss die Konfiguration geändert werden, indem Sie das entsprechende Netzwerk als dediziertes privates Netzwerk neu konfigurieren.

Weitere Informationen zu Cluster Heartbeat-Netzwerken finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 258750, „Empfehlungen für die private Heartbeat-Konfiguration auf einem Clusterserver" (http://support.microsoft.com/kb/258750/de)

  • 307962, „Multicast Support Enabled for the Cluster Heartbeat" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307962)

Weitere Einzelheiten finden Sie im Dokument Exchange Server 2003 Cluster Configuration Checklist unter http://go.microsoft.com/fwlink/?linkid=36083.


Die Standardgröße für die Datei „cluster.log" muss auf 32 erhöht werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange-Cluster >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Parameter ClusterLogSize festgelegt wurde:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment\

Wenn Exchange Server Analyzer feststellt, dass der Wert für ClusterLogSize nicht vorhanden ist oder der Wert für ClusterLogSize kleiner als oder gleich 8 ist, wird eine Warnung angezeigt. Auf einem ausgelasteten Cluster wird die Datei cluster.log so schnell aktualisiert, dass Einträge verloren gehen können, wenn Sie Ausfallsicherungen unter folgenden Bedingungen beheben:

  • Das Beheben des Fehlers erfordert eine genaue Überprüfung der Datei cluster.log.

  • Der Cluster verwaltet viele Ressourcen.

Wenn die Datei cluster.log im Rahmen der Problembehandlung verwendet werden muss, erstellen Sie deshalb den Parameter ClusterLogSize (sofern noch nicht vorhanden) und erhöhen die Standardgröße auf mindestens 32, 64 oder 96.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So erstellen Sie den Parameter „ClusterLogSize" und legen dessen Wert fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment.

  3. Klicken Sie im linken Bereich auf Environment.

  4. Zeigen Sie im Menü Bearbeiten auf Neu, und klicken Sie dann auf DWORD-Wert.

  5. Geben Sie ClusterLogSize ein, und drücken Sie dann die EINGABETASTE, um dem neuen Registrierungseintrag einen Namen zuzuweisen.

  6. Klicken Sie mit der rechten Maustaste auf ClusterLogSize, und klicken Sie dann auf Ändern.

  7. Ändern Sie den Datenwert ClusterLogSize entsprechend der neuen Größe der Protokolldatei. Ändern Sie den Wert ClusterLogSize z. B. in 32, 64 oder 96, und drücken Sie dann die EINGABETASTE.

  8. Beenden Sie den Registrierungs-Editor.
So ändern Sie die Standardgröße der Datei „cluster.log"

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment.

  3. Klicken Sie mit der rechten Maustaste auf ClusterLogSize, und klicken Sie dann auf Ändern.

  4. Ändern Sie den Datenwert ClusterLogSize entsprechend der neuen Größe der Protokolldatei. Ändern Sie den Wert ClusterLogSize z. B. in 32, 64 oder 96, und drücken Sie dann die EINGABETASTE.

  5. Beenden Sie den Registrierungs-Editor.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zur Clusterprotokollierung unter Microsoft Cluster Server finden Sie im Microsoft Knowledge Base-Artikel 168801 „Aktivieren der Clusterprotokollierung in Microsoft Cluster Server" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=168801.


Aktivieren von Kerberos-Authentifizierung für SMTP
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange-Cluster >

Letztes Änderungsdatum des Themas: 2006-05-12

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob der Wert des Attributs servicePrincipalName der SMTPSVC-Ressource eines Computers mit Microsoft Exchange Server 2003 Server, der in einem Windows™ Server 2003 Clusterdienst installiert ist, der vollqualifizierte Domänenname (Fully Qualified Domain Name, FQDN) des Servers ist.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs servicePrincipalName der Exchange-Ressource SMTPSVC im Clusterdienst nicht der FQDN des Servers ist, zeigt Exchange Server Analyzer eine Meldung mit der bewährten Methode an.

Es handelt sich um eine bewährte Methode, die Kerberos-Authentifizierung für SMTP-Dienste (Simple Mail Transfer Protocol) auf Clusterservern unter Windows Server 2003, auf denen Exchange Server 2003 ausgeführt wird, zu aktivieren. Die Kerberos-Authentifizierung kann manuell aktiviert werden, indem für die Exchange-Ressource SMTPSVC ein neuer Dienstprinzipalname (Service Principal Name, SPN) als Wert festgelegt wird.

Standardmäßig verwendet Windows Server 2003 NTLM-Authentifizierung. Das Kerberos-Protokoll ist flexibler und wirkungsvoller als NTLM und darüber hinaus sicherer. Folgende Vorteile bringt die Verwendung von Kerberos-Authentifizierung mit sich:

  • Schnellere Verbindungen. Bei der NTLM-Authentifizierung muss eine Anwendungsserver zum Authentifizieren jedes Clients eine Verbindung mit einem Domänencontroller herstellen. Bei der Kerberos-Authentifizierung muss der Server keinen Domänencontroller verwenden. Der jeweilige Client kann durch Überprüfen der vom Client angegebenen Anmeldeinformationen authentifiziert werden. Clients können einmalige Anmeldeinformationen für einen bestimmten Server erhalten und diese während einer gesamten Netzwerkanmeldesitzung verwenden.

  • Gegenseitige Authentifizierung. NTLM ermöglicht Servern die Überprüfung der Identitäten ihrer Clients. NTLM ermöglicht Clients nicht das Überprüfen der Identität eines Servers. Auch können Server untereinander nicht ihre Identität prüfen. NTLM-Authentifizierung wurde für Netzwerkumgebungen entwickelt, in denen vorausgesetzt wird, dass Server "echt" sind. Das Kerberos-Protokoll trifft keine solchen Annahmen. Die Parteien an beiden Enden einer Netzwerkverbindung können davon ausgehen, dass die Partei am anderen Ende diejenige ist, die sie zu sein behauptet.

  • Delegierte Authentifizierung. Windows-Dienste geben beim Zugriff auf Ressourcen im Namen eines Clients vor, dieser Client zu sein. Häufig kann ein Dienst seine Arbeit für den Client abschließen, indem er auf Ressourcen zugreift, die sich auf dem lokalen Computer befinden. Sowohl NTLM als auch Kerberos liefern die Informationen, die ein Dienst benötigt, um die Identität seines Clients lokal anzunehmen. Manche verteilte Anwendungen sind aber so konzipiert, dass ein Front-End-Dienst die Identität eines Clients annehmen muss, wenn er mit Back-End-Diensten auf anderen Computern eine Verbindung herstellen möchte. Das Kerberos-Protokoll verfügt über einen Proxymechanismus, der es einem Dienst ermöglicht, die Identität seines Clients anzunehmen, wenn er eine Verbindung mit anderen Diensten herstellt. Bei NTLM ist kein entsprechender Mechanismus vorhanden.

Verfahren Sie wie folgt, um dieses Problem zu beheben, indem Sie die fehlenden Wert für die betroffenen Attribute hinzufügen.

Fügen Sie mithilfe des Tools SETSPN.exe einen SPN mit den fehlenden Werten hinzu.

  1. Installieren Sie das Tool Setspn.exe. Das Tool Setspn.exe können Sie unter "Windows 2000 Resource Kit Tool: Setspn.exe" (http://go.microsoft.com/fwlink/?LinkId=28103) herunterladen.

    Die Windows Server 2003-Version des Befehlszeilentools Setspn.exe ist in den Windows Server 2003 Support Tools verfügbar, die sich auf der Windows Server 2003-CD befinden. Doppelklicken sie zum Installieren der Server 2003 Support Tools auf die Datei Suptools.msi im Ordner Support/Tools.

  2. Befolgen Sie die Anleitung in der Datei Setspn_d.txt von SETSPN.EXE, um dem Active Directory-Objekt für Ihren Server mit Exchange den fehlenden Wert hinzuzufügen. In dem folgenden Beispiel wird gezeigt, wie für den SPN eines virtuellen SMTP-Servers der FQDN-Wert hinzugefügt wird:

    • Starten Sie eine Eingabeaufforderung, und wechseln Sie in das Verzeichnis, in dem Sie Setspn.exe installiert haben.

    • Geben Sie an der Eingabeaufforderung den folgenden Befehl ein:

      setspn.exe-a SMTPSVC/ mail.IhreDomäne.com IHRSERVERNAME

      Hinweis:
      Ersetzen Sie mail.IhreDomäne.com durch den FQDN Ihres virtuellen SMTP-Servers und IHRSERVERNAME durch den Namen des Servers mit Exchange.
    • Drücken Sie dann die EINGABETASTE.


Exchange-Clusterknoten konnte nicht kontaktiert werden.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange-Cluster >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_Service ab, um den Wert des Schlüssels Started für Clusterdienst (ClusSvc) zu bestimmen. Der Wert True gibt an, dass der Clusterdienst gestartet ist, der Wert False gibt an, dass der Clusterdienst nicht ausgeführt wird.

Exchange Server Analyzer liest außerdem den folgenden Registrierungseintrag, um die Windows-Version zu bestimmen, die auf dem Exchange Server-Computer ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Der Wert 4.0 für CurrentVersion gibt an, dass auf dem Computer Microsoft Windows NT Server 4.0 ausgeführt wird. Der Wert 5.0 gibt an, dass auf dem Computer Windows 2000 Server ausgeführt wird, und der Wert 5.2 gibt an, dass auf dem Computer Windows Server™ 2003 ausgeführt wird.

Wenn Microsoft Exchange Server Analyzer die Version von Windows im Cluster nicht bestimmen kann oder wenn Microsoft Exchange Server Analyzer nicht ermitteln kann, ob der Clusterdienst ausgeführt wird, wird ein Fehler angezeigt. Dieser Fehler gibt an, dass Exchange Server Analyzer keine Verbindung mit einem Knoten in einem Exchange Server-Cluster herstellen konnte.

So berichtigen Sie diesen Fehler

  1. Stellen Sie sicher, dass Exchange Server-Computer gestartet wurde und mit dem Netzwerk verbunden ist.

  2. Verwenden Sie den Befehl ping, um festzustellen, ob eine Verbindung mit Exchange Server-Computer hergestellt werden kann.

  3. Wenn ein Firewall vorhanden ist, überprüfen Sie, ob die RPC-Anschlüsse (Remote Procedure Call) blockiert sind.

  4. Stellen Sie sicher, dass der Remoteregistrierungsdienst auf dem Exchange Server-Computer gestartet wurde.

  5. Überprüfungen Sie die Berechtigungen für das Konto, mit dem Exchange Server Analyzer ausgeführt wird, um sicherzustellen, dass dieses über ausreichende Berechtigungen verfügt, um die Registrierung auf dem Exchange Server-Computer zu lesen.

Weitere Informationen zum Behandeln von Problemen mit Netzwerkverbindungen finden Sie im Microsoft Knowledge Base-Artikel 325487, „Behandlung von Problemen mit der Netzwerkverbindung" (http://support.microsoft.com/kb/325487/DE/).


Exchange-Datenpfad in Active Directory stimmt nicht mit der Cluster-Registrierung überein
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange-Cluster >

Letztes Änderungsdatum des Themas: 2006-04-28

Microsoft® Exchange Server Analyzer fragt die Clusterregistrierung (HKEY_LOCAL_MACHINE\Cluster) und den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob die Pfade für Exchange-Datendateien (z. B. Protokolldateien für die Nachrichtenverfolgung) an beiden Orten übereinstimmen. Exchange Server konfiguriert diese Werte in der Registrierung und in Active Directory, wenn Exchange mit dem Setupprogramm von Exchange auf einem Knoten in einem Microsoft Windows®-Servercluster installiert wird.

Der Registrierungswert, der von Exchange Setup erstellt und von Exchange Server Analyzer gelesen wird, lautet:

HKLM\Cluster\Resources\<Ressourcen-GUID der Informationsspeicherressource>\Parameters\DestPath

Der Active Directory-Wert, der von Exchange Setup erstellt und von Exchange Server Analyzer gelesen wird, lautet: msExchDataPath. Dieser Wert ist ein Attribut des Exchange Server-Computerobjekts in Active Directory und befindet sich unter:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN= OrganisationsName =Administrative Groups, CN= AdministrativerGruppenName , CN=Servers, CN= ServerName

Wenn Exchange Server Analyzer feststellt, dass die Werte für DestPath und msExchDataPath nicht übereinstimmen, wird ein Fehler angezeigt.

Eine häufige Ursache für unterschiedliche Werte besteht in geänderten Speicherorten einiger oder aller Exchange-Datendateien, nachdem Exchange in der Produktion verwendet wurde. Wenn z. B. bei der Hardware-Aktualisierung Protokolldateien für die Nachrichtenverfolgung verschoben werden und ein Laufwerksbuchstabe geändert wird, wird die Änderung in der Clusterregistrierung, jedoch nicht in Active Directory widergespiegelt. Nach einer solchen Änderung können Fehler beim Starten von Diensten, Probleme beim Bereitstellen von Datenbanken sowie weitere Probleme auftreten, insbesondere bei der Anwendung eines Exchange Service Packs oder bei der Installation eines Rollup-Pakets.

Hinweis:
Diese Abweichung muss so schnell wie möglich behoben werden. Installieren Sie keine Service Packs oder Updates für Exchange Server, bis dieses Problem behoben ist.

Zum Ausführen des nachfolgenden Verfahrens benötigen Sie einen Active Directory-Editor, z. B. die ADSI-Bearbeitung (Active Directory Service Interfaces) oder das LDP-Tool (ldp.exe).

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In, das LDP-Tool oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So beheben Sie diesen Fehler

  1. Ändern Sie den betreffenden Wert des virtuellen Exchange-Servers (EVS) für msExchDataPath, sodass er mit dem Wert für DestPath in der Clusterregistrierung übereinstimmt. Das Attribut msExchDataPath befindet sich unter: CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName=Administrative Groups, CN=AdministrativeGroupName, CN=Servers, CN=ServerName

  2. Starten Sie die Ressource Exchange-Systemaufsicht des virtuellen Servers neu, damit die Änderung wirksam wird.

Weitere Informationen zum Ändern von Active Directory mit dem LDP-Tool finden Sie im Microsoft Knowledge Base-Artikel 260745, „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260745).

Weitere Informationen zum Verwenden der ADSI-Bearbeitung zum Ändern des Attributs msExchDataPath finden Sie im Knowledge Base-Artikel 288362 „XADM: 'The System Cannot Find the Path Specified' Event ID 5007 Message is Logged by the Microsoft Exchange System Attendant" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=288362).


Ereignisprotokollreplikation ist aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange-Cluster >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag für die einzelnen Server, die als Clusterknoten fungieren:

HKEY_LOCAL_MACHINE\Cluster\Nodes\X\EnableEventLogReplication

Hinweis:
X ist die Nummer des Knotens, beginnend mit 1.

Wenn Exchange Server Analyzer erkennt, dass der Wert des Attributs EnableEventLogReplication gleich 1 ist, zeigt Exchange Server Analyzer eine Meldung mit der optimalen Methode an.

Wenn der Registrierungseintrag EnableEventLogReplication auf 1 festgelegt ist, repliziert der Clusterknoten Ereignisse im Ereignisprotokoll auf alle anderen Knoten im Cluster. Wenn die Ereignisprotokollreplikation aktiviert ist, melden Tools zum Überwachen mehrerer Server, z. B. MOM (Microsoft Operations Manager), ein einzelnes Ereignis mehrmals, und zwar einmal pro Knoten. Bei automatischer Überwachung wird empfohlen, die Ereignisprotokollreplikation für Clusterknoten zu deaktivieren.

So deaktivieren Sie die Ereignisprotokollreplikation auf allen Knoten eines Clusters

  1. Melden Sie sich an einem beliebigen Knoten des Clusters mit einem Konto an, bei dem es sich um eine Domänenbenutzerkonto handelt oder das Mitglied einer globalen Gruppe ist.

  2. Klicken Sie auf Start und auf Ausführen, und geben Sie dann Folgendes ein:

    cluster /prop EnableEventLogReplication=0
So deaktivieren Sie die Ereignisprotokollreplikation auf einem einzelnen Knoten eines Clusters

  1. Melden Sie sich an einem beliebigen Knoten des Clusters mit einem Konto an, bei dem es sich um eine Domänenbenutzerkonto handelt oder das Mitglied einer globalen Gruppe ist.

  2. Klicken Sie auf Start und auf Ausführen, und geben Sie dann Folgendes ein:

    Cluster <Name des zu deaktivierenden Knotens> /prop EnableEventLogReplication=0

Weitere Informationen zu Konfigurationsverfahren für die Ereignisprotokollreplikation finden Sie im Microsoft Knowledge Base-Artikel 224969 „SO WIRD'S GEMACHT: Die Ereignisprotokollreplikation auf Windows 2000-Clusterservern konfigurieren" (http://support.microsoft.com/default.aspx?scid=kb;de;224969).

Weitere Informationen zum Verwalten von Serverclustern finden Sie unter Verwalten von Serverclustern (http://www.microsoft.com/technet/prodtechnol/windowsserver2003/de/library/ServerHelp/02bbfe81-2a63-4144-8cce-75bee92a2668.mspx).


Kerberos wurde für Netzwerknamensressource deaktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange-Cluster >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Version des Microsoft Windows®-Betriebssystems zu bestimmen, die auf dem Server ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Ein Wert für CurrentVersion von 4.0 gibt an, dass auf dem Computer Windows NT® Server 4.0 ausgeführt wird. Ein Wert von 5.0 zeigt an, dass auf dem Computer ein Windows 2000 Server-Betriebssystem ausgeführt wird, und ein Wert von 5.2 zeigt an, dass auf dem Computer Windows Server™ 2003 ausgeführt wird.

Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Objekte mit der Objektklasse msExchExchangeServer zu ermitteln. Wenn der Zeichenfolgenwert „Version 5.5" enthält, wird auf dem Computer Microsoft Exchange Server 5.5 ausgeführt. Wenn der Zeichenfolgenwert „Version 6.0" enthält, wird auf dem Computer Microsoft Exchange 2000 Server ausgeführt. Wenn der Zeichenfolgenwert „Version 6.5" enthält, wird auf dem Computer Microsoft Exchange Server 2003 ausgeführt.

Schließlich liest Exchange Server Analyzer den folgenden Registrierungswert, um zu bestimmen, ob Exchange Server in einem Cluster mit einer Kerberos-fähigen Netzwerknamens-Clusterressource ausgeführt wird:

HKLM\Cluster\Resources\<Resource GUID for Network Name resource>\Parameters\RequireKerberos

Ein Wert von 0 für RequireKerberos gibt an, dass die Netzwerknamensressource nicht für Kerberos aktiviert ist, und ein Wert von 1 gibt an, dass die Netzwerknamensressource für Kerberos aktiviert ist.

Wenn Exchange Server Analyzer feststellt, dass der Wert für RequireKerberos auf einem virtuellen Exchange Server 2003-Server, der in einem serverbasierten Windows Server 2003-Cluster ausgeführt wird, auf 0 festgelegt ist, wird eine Warnung angezeigt.

Diese Warnung verweist darauf, dass keine Kerberos-fähige Netzwerknamens-Clusterressource für einen virtuellen Exchange Server 2003-Server verwendet wird. Hierbei handelt es sich um keine unterstützte Konfiguration, und der Fehler sollte so schnell wie möglich behoben werden.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie das Cluster-Administrationsprogramm.

  2. Verlegen Sie die Netzwerknamensressource in den Offllinemodus. Dadurch werden auch alle anderen Ressourcen in den Offlinemodus versetzt, die von der Netzwerknamensressource abhängen, einschließlich der Systemaufsicht für Microsoft Exchange.

  3. Klicken Sie mit der rechten Maustaste auf die Netzwerknamensressource, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf der Registerkarte Parameter auf die Option Kerberos-Authentifizierung, und klicken Sie dann auf OK.

  5. Schalten Sie die Netzwerknamensressource und anschließend die übrigen Offlineressourcen online.

Weitere Informationen zum Verwenden von Kerberos-fähigen Netzwerknamensressourcen in einem Windows Server 2003-Cluster finden Sie im Microsoft Knowledge Base-Artikel 302389 „Description of the Properties of the Cluster Network Name Resource in Windows Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=302389.

Weitere Informationen zu Clustern finden Sie in den folgenden Themen:

  • „Bereitstellen von Exchange 2003 in einem Cluster" im Bereitstellungshandbuch für Exchange Server 2003 unter .

  • „Planen von Exchange-Clustering" im Exchange Server 2003-Handbuch für hohe Verfügbarkeit unter (http://go.microsoft.com/fwlink/?linkid=47571


Kerberos wurde für Netzwerknamensressource aktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange-Cluster >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Version des Microsoft Windows®-Betriebssystems zu bestimmen, die auf dem Server ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Ein Wert für CurrentVersion von 4.0 gibt an, dass auf dem Computer Windows NT® Server 4.0 ausgeführt wird. Ein Wert von 5.0 zeigt an, dass auf dem Computer ein Windows 2000 Server-Betriebssystem ausgeführt wird, und ein Wert von 5.2 zeigt an, dass auf dem Computer Windows Server™ 2003 ausgeführt wird.

Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Objekte mit der Objektklasse msExchExchangeServer zu ermitteln. Wenn der Zeichenfolgenwert „Version 5.5" enthält, wird auf dem Computer Microsoft Exchange Server 5.5 ausgeführt. Wenn der Zeichenfolgenwert „Version 6.0" enthält, wird auf dem Computer Microsoft Exchange 2000 Server ausgeführt. Wenn der Zeichenfolgenwert „Version 6.5" enthält, wird auf dem Computer Microsoft Exchange Server 2003 ausgeführt.

Schließlich liest Microsoft Exchange Server Analyzer den folgenden Registrierungswert, um zu bestimmen, ob Exchange in einem Cluster mit einer Kerberos-fähigen Netzwerknamens-Clusterressource ausgeführt wird:

HKLM\Cluster\Resources\<Resource GUID for Network Name resource>\RequireKerberos

Ein Wert von 0 für RequireKerberos gibt an, dass die Netzwerknamensressource nicht für Kerberos aktiviert ist, und ein Wert von 1 gibt an, dass die Netzwerknamensressource für Kerberos aktiviert ist.

Wenn Exchange Server Analyzer feststellt, dass der Wert für RequireKerberos auf einem virtuellen Server mit Exchange 2000 Server, der in einem serverbasierten Windows 2000 Server-Cluster ausgeführt wird, auf 1 festgelegt ist, wird eine Warnung angezeigt.

Diese Warnung verweist darauf, dass keine Kerberos-fähige Netzwerknamens-Clusterressource für einen virtuellen Server mit Exchange 2000 Server verwendet wird. Hierbei handelt es sich um keine unterstützte Konfiguration, und der Fehler muss so schnell wie möglich behoben werden. Wie im Microsoft Knowledge Base-Artikel 235529, „Kerberos support on Windows 2000-based server clusters" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=235529) dargelegt ist, wird die Kerberos-Authentifizierung für Exchange 2000 Server-Netzwerknamensressource nicht unterstützt. Exchange 2000 Server ist nicht dahingehend getestet worden, ob sichergestellt ist, dass ein virtueller Server mit Exchange 2000 Server, der Teil eines Clusters ist, die Kerberos-Authentifizierung unterstützt.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie die Eingabeaufforderung an jedem Knoten im Cluster.

  2. Führen Sie den folgenden Befehl aus: cluster res "Name der Netzwerknamensressource" /priv requirekerberos=0:dword

    Hinweis:
    Der Ressourcenname muss in Anführungszeichen eingeschlossen sein.

  3. Bringen Sie die Netzwerknamensressource in den Offline-Zustand, und löschen Sie sie.

  4. Öffnen Sie „Active Directory-Benutzer und -Computer".

  5. Suchen Sie das Kontoobjekt des Computers für die gelöschte Netzwerknamensressource, und löschen Sie es aus Active Directory.

  6. Erstellen Sie eine neue Netzwerknamensressource für den Exchange Virtual Server (EVS), und aktivieren Sie für diese nicht Kerberos. Sie können denselben Namen und dieselbe Konfiguration wie die der in Schritt 3 gelöschten Netzwerknamenressource verwenden.

  7. Versetzen Sie die neue Netzwerknamensressource in den Onlinemodus, und versetzen Sie anschließend die übrigen Ressourcen im EVS in den Onlinemodus.

Weitere Informationen zum Verwenden von Kerberos-fähigen Netzwerknamensressourcen in einem Windows Server 2000-Cluster finden Sie im Microsoft Knowledge Base-Artikel 235529, „Kerberos support on Windows 2000-based server clusters" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=235529).


MSDTC scheint im Cluster zu fehlen
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange-Cluster >

Letztes Änderungsdatum des Themas: 2006-04-20

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob die MSDTC-Ressource (Microsoft Distributed Transaction Coordinator) in einem Cluster vorhanden ist:

HKEY_LOCAL_MACHINE\Cluster\Resources\

Wenn der Wert von ClusterMSDTCInstance gleich 0 ist, zeigt Exchange Server Analyzer eine Warnung an.

Die MSDTC-Ressource muss in einem Exchange Server-Cluster vorhanden sein, damit anfängliche Installationen und Service Pack-Aktualisierungen unterstützt werden. Es handelt sich jedoch nicht um eine kritische Komponente, die auch während der Ausführung von Exchange nicht benötigt wird.

Ein Administrator in Ihrer Organisation hat möglicherweise die MSDTC-Ressource entfernt, weil bekannt ist, dass sie zur Ausführung von Exchange nicht benötigt wird.

Es wird allerdings empfohlen, die MSDTC-Ressource nach der ersten Installation von Exchange Server 2003 nicht zu entfernen Wenn die MSDTC-Ressource im Cluster verbleibt, können Sie Service Packs und andere Aktualisierungen installieren.

Um diese Warnung zu beheben, erstellen Sie eine neue MSDTC-Ressource. Spezifische schrittweise Anleitungen zum Erstellen einer MSDTC-Ressource finden Sie unter „Installieren des Microsoft Distributed Transaction Coordinator in einem Windows Server 2003-Servercluster" im Kapitel „Bereitstellen von Exchange Server 2003 in einem Cluster" im Bereitstellungshandbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).

Weitere Informationen

Weitere Informationen zu MSDTC und Exchange finden Sie unter „Clustergruppen" in „Grundlagen zur Exchange Server 2003-Clusterbildung" im Kapitel „Planen der Exchange-Clusterbildung" im Exchange 2003-Handbuch für hohe Verfügbarkeit (http://go.microsoft.com/fwlink/?LinkId=47571).

Weitere Informationen zum Hinzufügen der MSDTC-Ressource in Microsoft Windows Server™ 2003 finden Sie im Microsoft Knowledge Base-Artikel 301600 „Konfigurieren des Microsoft Distributed Transaction Coordinator auf einem Windows Server 2003-Cluster" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301600).

Hinweis:
Der Knowledge Base-Artikel 301600 enthält einen Verweis auf den Artikel 817064, „Aktivieren von DTC-Netzwerkzugriff in Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=817064). Es handelt sich um eine optimale Sicherheitsmethode für Exchange Server, den DTC-Netzwerkzugriff für einen Exchange-Cluster nicht zu aktivieren. Aktivieren Sie nicht den DTC-Netzwerkzugriff, wenn die DTC-Ressource (Distributed Transaction Coordinator) für einen Exchange-Cluster konfiguriert wird.


MSDTC-Ausfälle wirken sich auf die Clustergruppe aus
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange-Cluster >

Letztes Änderungsdatum des Themas: 2006-03-16

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob eine Konfiguration vorliegt, bei der sich Fehler der MSDTC-Ressource (Microsoft Distributed Transaction Coordinator) auf die Gruppe auswirken:

HKEY_LOCAL_MACHINE\Cluster\Resources\

Wenn der Wert von ClusterMSDTCInstance gleich 2 ist, zeigt Exchange Server Analyzer eine Warnung an.

Die MSDTC-Ressource muss in einem Exchange Server-Cluster vorhanden sein, damit anfängliche Installationen und Service Pack-Aktualisierungen unterstützt werden. Sie wird jedoch nicht während der Ausführung von Exchange benötigt.

Standardmäßig wirkt sich ein Fehler der MSDTC-Ressource auf die Gruppe aus. Im Folgenden finden Sie zwei Beispiele für Ressourcenfehler:

  • Die Größe der Protokolldatei übersteigt die Kapazität des Datenträgers.

  • Der physikalische Datenträger für die MSDTC-Ressource hat einen Fehler.

Ein Fehler der MSDTC-Ressource verursacht somit ein Failover aller Exchange-Dienste, die auf dem Clusterknoten ausgeführt werden, auf einen anderen im Cluster vorhandenen Knoten. Da die MSDTC-Ressource jedoch für den Betrieb nicht erforderlich ist, muss sie nicht so konfiguriert sein, dass die Gruppe davon betroffen wird.

Um diese Warnung zu beheben, konfigurieren Sie den Exchange-Cluster so, dass ein Fehler der MSDTC-Ressource sich nicht auf die Gruppe auswirkt.

So konfigurieren Sie Exchange, dass ein Fehler der MSDTC-Ressource sich nicht auf die Gruppe auswirkt

  1. Melden Sie sich bei einem beliebigen Knoten des Clusters an.

  2. Klicken Sie auf das Menü Start, zeigen Sie dort auf Programme und Verwaltung, und klicken Sie auf Cluster Administrator.

  3. Klicken Sie unterhalb von Gruppen mit der rechten Maustaste auf die Clustergruppe, in der die MSDTC-Ressource enthalten ist.

  4. Klicken Sie mit der rechten Maustaste auf die MSDTC-Ressource, und klicken Sie dann auf Eigenschaften.

  5. Deaktivieren Sie auf der Registerkarte Erweitert das Kontrollkästchen Affect the group, und klicken Sie dann auf OK.

Weitere Informationen

Spezifische schrittweise Anleitungen zum Erstellen einer MSDTC-Ressource finden Sie unter „Installieren des Microsoft Distributed Transaction Coordinator in einem Windows Server 2003-Servercluster" im Kapitel „Bereitstellen von Exchange Server 2003 in einem Cluster" im Bereitstellungshandbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).

Weitere Informationen zu MSDTC und Exchange finden Sie unter „Clustergruppen" in „Grundlagen zur Exchange Server 2003-Clusterbildung" im Kapitel „Planen der Exchange-Clusterbildung" im Exchange 2003-Handbuch für hohe Verfügbarkeit (http://go.microsoft.com/fwlink/?LinkId=47571).

Weitere Informationen zum Hinzufügen der MSDTC-Ressource in Microsoft Windows Server™ 2003 finden Sie im Microsoft Knowledge Base-Artikel 301600 „Konfigurieren des Microsoft Distributed Transaction Coordinator auf einem Windows Server 2003-Cluster" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301600).

Hinweis:
Der Knowledge Base-Artikel 301600 enthält einen Verweis auf den Artikel 817064, „Aktivieren von DTC-Netzwerkzugriff in Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=817064). Es handelt sich um eine optimale Sicherheitsmethode für Exchange Server, den DTC-Netzwerkzugriff für einen Exchange-Cluster nicht zu aktivieren. Aktivieren Sie nicht den DTC-Netzwerkzugriff, wenn die DTC-Ressource (Distributed Transaction Coordinator) für einen Exchange-Cluster konfiguriert wird.


MTA-Ausfälle wirken sich auf die Clustergruppe aus
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange-Cluster >

Letztes Änderungsdatum des Themas: 2006-03-16

Microsoft® Exchange Server Analyzer untersucht die Registrierungseinstellungen Cluster\Resources des Systems mit Exchange Server.

HKEY_LOCAL_MACHINE\Cluster\Resources

Wenn Exchange Server Analyzer feststellt, dass die MTA-Stacks-Dienstressourcen (Message Transfer Agent) auf dem Exchange Server 2003-Cluster in einer Organisation im einheitlichen Modus ausgeführt werden, zeigt Exchange Server Analyzer eine Best Practices-Meldung an.

Als optimale Methode wird empfohlen, dass der Exchange-Administrator die MTA-Ressource so konfiguriert, dass der MTA keinen möglichen Failover des virtuellen Exchange-Servers verursacht, wenn der MTA beendet wird oder fehlschlägt.

Hinweis:
Der MTA-Stacks-Dienst in Microsoft Exchange 2000 Server und in Microsoft Exchange Server 2003 wird häufig verwendet, um abwärtskompatible Nachrichtenübermittlungsdienste zwischen Servern mit Exchange 2000 Server oder Exchange Server 2003 und Servern mit Microsoft Exchange Server 5.5 in einer Umgebung im gemischten Modus anzubieten. Wenn der Übergang zu einer reinen Exchange 2000 Server- oder Exchange Server 2003-Umgebung im einheitlichen Modus abgeschlossen ist, ist der MTA keine kritische Ressource mehr, die benötigt wird, damit Exchange-Dienste ausgeführt werden können.

Wenn der MTA-Stacks-Dienst beendet wird oder fehlschlägt, kann ein möglicher Failover des virtuellen Exchange-Servers ausgelöst werden. Um einen möglichen Failover des virtuellen Exchange-Servers (Exchange Virtual Server, EVS) zu verhindern, wird als optimale Methode empfohlen, den MTA-Stacks-Dienst auf folgende Weise zu konfigurieren, sodass ein Failover vermieden wird.

So konfigurieren Sie den MTA-Stacks-Dienst in einem Exchange Server-Cluster, dass eventuelle Probleme mit ihm keine Auswirkungen haben

  1. Öffnen Sie Cluster Administrator.

  2. Deaktivieren Sie die Option Affect this Group für die MTA-Stack-Dienstressource.

Weitere Informationen

Informationen zu den Unterstützungsrichtlinien für den MTA-Stacks-Dienst für Exchange Server 2003 finden Sie im Microsoft Knowledge Base-Artikel 810489, „Unterstützungsrichtlinien für den MTA-Stacks-Dienst für Exchange 2000 Server und Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810489).

Weitere Informationen zum MTA in der Exchange Server 2003-Architektur finden Sie unter „Exchange MTA" in „Exchange Server 2003 Architecture" (http://go.microsoft.com/fwlink/?LinkId=63496).

Informationen zum Bereitstellen von Exchange Server 2003 in einem Cluster finden Sie in „Deploying Exchange Server 2003 in a Cluster" (http://go.microsoft.com/fwlink/?LinkId=63495).

Informationen zum Verwenden von Cluster Administrator finden Sie unter „Using Cluster Administrator to Manage Exchange Clusters" (http://go.microsoft.com/fwlink/?LinkId=63493).


Dies ist ein 2-knotiger Active/Active Cluster
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange-Cluster >

Letztes Änderungsdatum des Themas: 2006-04-28

Darüber hinaus fragt Microsoft® Exchange Server Analyzer auch die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_Service ab, um den Wert des Schlüssels Started für den Clusterdienst ClusSvc zu bestimmen. Der Wert True gibt an, dass der Clusterdienst ausgeführt wird, und der Wert False gibt an, dass er nicht ausgeführt wird.

Außerdem liest Exchange Server Analyzer den folgenden Registrierungseintrag, um die Anzahl der Knoten im Cluster zu ermitteln:

HKEY_LOCAL_MACHINE\Cluster\Nodes\ <Knotennummer> \NodeName

Die Anzahl der Instanzen von NodeName entspricht der Anzahl von Knoten im Cluster. Darüber hinaus liest Exchange Server Analyzer den folgenden Registrierungseintrag, um die Anzahl der Exchange Server-Ressourcen im Cluster zu ermitteln:

HKLM\Cluster\Resources\ <GUID der Clusterressource> \Parameters\DestPath

Die folgenden Ressourcen eines Exchange Server-Clusters verfügen über einen Wert DestPath:

  • Microsoft Exchange Message Transfer Agent

  • Microsoft Exchange-Informationsspeicher

Die Anzahl der Instanzen von DestPath gibt die Anzahl der Server an, auf denen Exchange Virtual Server (EVS) ausgeführt wird.

Wenn Exchange Server Analyzer feststellt, dass in einem Cluster, der über 2 Instanzen von NodeName verfügt, 3 Instanzen von DestPath vorhanden sind, wird eine Warnung angezeigt. Diese Warnung zeigt an, dass es sich hier um einen zweiknotigen Cluster mit Servern handelt, auf denen EVS ausgeführt wird. Dies wird als Active/Active-Cluster bezeichnet.

  • Im Active/Active-Cluster-Modell ist die Anzahl virtueller Exchange-Server im Cluster größer oder gleich der Anzahl der im Cluster enthaltenen physischen Knoten.

Hinweis:
Exchange-Active/Active-Cluster können nur in Clustern erstellt werden, die aus zwei Knoten bestehen. Wenn Ihr Cluster über drei oder mehr Knoten verfügt, müssen Sie das Active/Passive-Modell verwenden.
  • Im Active/Passive-Cluster-Modell ist die Anzahl virtueller Exchange-Server im Cluster kleiner als die Anzahl der im Cluster enthaltenen physischen Knoten.

Obwohl Microsoft das Active/Active-Clustern für Exchange Server unterstützt, wird dringend empfohlen, dass für Exchange-Cluster Active/Passive-Implementierungen verwendet werden. Microsoft unterstützt nur Exchange-Active/Active-Cluster, die den folgenden Skalierungsgrenzen entsprechen:

  • Die Anzahl gleichzeitiger Benutzerverbindungen pro virtuellem Exchange-Server pro physischem Knoten sollte 1900 nie übersteigen. Wenn ein Knoten des Clusters nicht verfügbar ist und alle virtuellen Exchange-Server über einen einzigen Knoten online sind, verbleiben die Skalierungsgrenzen für die beiden virtuellen Exchange-Server bei 3800 Verbindungen. Da jeder Benutzer mehrere Verbindungen verwenden kann, kann die Anzahl der Verbindungen nicht anhand der Anzahl der Postfächer festgestellt werden.

  • Die durchschnittliche CPU-Auslastung pro Exchange-Speichervorgang sollte nicht mehr als 40 Prozent betragen. Wenn die gesamte durch den Vorgang STORE.EXE verursachte CPU-Auslastung auf einem Knoten für einen Zeitraum von 10 oder mehr Minuten über 40 Prozent beträgt, müssen Sie Benutzer auf einen anderen Exchange-Server oder einen virtuellen Exchange-Server verschieben. Beachten Sie, dass in dieser Last die durch administrative Aufgaben verursachte CPU-Auslastung nicht enthalten ist.

Die Migration von einer Active/Active-Cluster-Konfiguration auf eine Active/Passive-Konfiguration beinhaltet, dass die Ressourcen vom zweiten EVS-Server weggenommen werden und dieser außer Betrieb gesetzt wird.

So führen Sie eine Migration von einem Active/Active-Cluster zu einem Active/Passive-Cluster durch

  1. Verschieben Sie die auf dem zweiten EVS gehosteten Postfächer auf den ersten EVS im Cluster. Der erste EVS im Cluster enthält immer die einzige im Cluster vorhandene Microsoft Exchange MTA-Ressource (Message Transfer Agent).

  2. Wenn alle Postfächer auf den ersten EVS verschoben wurden, versetzen Sie den zweiten EVS in den Offlinemodus.

  3. Entfernen Sie den zweiten EVS, indem Sie einen der folgenden Schritte ausführen:

    • Klicken Sie auf einem Exchange Server 2003-Cluster mit der rechten Maustaste auf die Ressource Microsoft Exchange Systemaufsicht, und klicken Sie dann auf Virtuellen Exchange-Server entfernen.

    • Klicken Sie auf einem Exchange Server 2000-Cluster mit der rechten Maustaste auf die Ressource Microsoft Exchange Systemaufsicht, und klicken Sie dann auf Löschen.

  4. Überprüfen Sie, ob das EVS-Objekt aus dem Active Directory®-Verzeichnisdienst entfernt wurde. Durch Änderungen der Kontoberechtigungen für den Clusterdienst unter Exchange Server 2003 muss Ihr Konto die Berechtigung zum Löschen von Active Directory-Objekten aufweisen.

  5. Versetzen Sie die verbleibenden Ressourcen auf dem EVS (z. B. den physischen Datenträger, den Netzwerknamen und die IP-Adresse) in den Offlinemodus, und löschen Sie sie.

  6. Löschen Sie die Ressourcengruppe, die den zweiten EVS enthielt.

Weitere Informationen zum Entfernen eines EVS finden Sie in Deploying Microsoft Exchange 2000 Server Clusters Exchange (http://go.microsoft.com/fwlink/?LinkId=9393) im Abschnitt „Removing an Exchange virtual server from a Cluster".

Weitere Informationen zu optimalen Methoden und Empfehlungen für Exchange-Cluster finden Sie im Bereitstellungshandbuch für Exchange Server 2003 unter http://go.microsoft.com/fwlink/?LinkId=47569.

Weitere Informationen zum Bereitstellen von Exchange in einem Windows-Servercluster finden Sie im Knowledge Base-Artikel 815180, „Considerations when deploying Exchange on an Active/Active cluster" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=815180.


Quorum-Protokoll zu klein.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange-Cluster >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Größe des für den Cluster konfigurierten Quorum-Protokolls zu bestimmen:

HKEY_LOCAL_MACHINE\Cluster\Quorum\MaxQuorumLogSize

Wenn Exchange Server Analyzer feststellt, dass der Wert für MaxQuorumLogSize kleiner ist als die Dezimale 4194304 (0x400000 hexadezimal), wird eine Warnung angezeigt.

Der Registrierungswert MaxQuorumLogSize stellt den aktuell für den Cluster-Quorum-Parameter konfigurierten Wert für Quorumprotokoll zurücksetzen auf dar. Diese Warnung wird generiert, wenn MaxQuorumLogSize kleiner ist als 4096 Kilobytes (KB).

Der Cluster zeichnet alle Änderungen in der Clusterdatenbank der Quorumprotokolldatei auf. Wenn das Quorumprotokoll die angegebene Größe erreicht, speichert der Cluster die Datenbank und setzt die Protokalldatei zurück. In Microsoft Windows® 2000 Server-basierten Clustern liegt die maximale Standardquorumgröße bei 64 KB. In Windows Server™ 2003-basierten Clustern liegt die maximale Standardquorumgröße bei 4096 KB. Für Exchange Server-Cluster wird es empfohlen, die EigenschaftQuorumprotokoll zurücklegen auf auf 4096 KB zu konfigurieren. Dadurch kann sichergestellt werden, dass genügend Platz zum Speichern der Clusterkonfigurationsinformationen vorhanden ist, z. B. darüber, welche Server Teil des Clusters sind, welche Ressourcen im Cluster installiert werden und in welchem Zustand sich die Ressourcen befinden (z. B. online oder offline).

So beheben Sie diese Warnmeldung

  1. Öffnen Sie Cluster Administrator.

  2. Klicken Sie im linken Bereich mit der rechten Maustaste auf das Objekt, das den Cluster darstellt, und klicken Sie dann auf Eigenschaften.

  3. Konfigurieren Sie auf der Registerkarte Quorum die Option Quorumprotokoll zurücklegen auf mit einem Wert von 4096.

  4. Klicken Sie auf OK, um die Änderungen zu speichern.

Weitere Informationen zur maximalen Standardquorumprotokollgröße finden Sie im Microsoft Knowledge Base-Artikel 225081, „Cluster Resources Quorum Log Size Defaults to 64 KB" (http://support.microsoft.com/kb/225081/en-us).


Exchange Server
Microsoft Exchange Server Analyzer-Tools - Artikel >

Letztes Änderungsdatum des Themas: 2005-11-18

Die Artikel in diesem Abschnitt enthalten Details darüber, was Microsoft® Exchange Server Analyzer in Bezug auf Exchange Server-Computer auswertet. Darüber hinaus werden in diesen Artikeln Aktionen beschrieben, die Sie durchführen können, um Fehler, Warnungen und vom Standard abweichende Konfigurationen im Zusammenhang mit Exchange beheben zu können, die von Microsoft Exchange Server Analyzer gefunden wurden.


Kontosperrung ist installiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-08-28

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) CIM_Datafile ab, um zu ermitteln, ob eine Datei mit dem Namen ALockout.dll im Ordner System32 auf dem Exchange-Server vorhanden ist. ALockout.dll ist Bestandteil der Account Lockout and Management Tools (ALTools.exe). Diese Tools unterstützen die Administratoren bei der Kontenverwaltung und ermöglichen zum Beheben von Problemen die Kontosperrung.

Wenn Exchange Server Analyzer feststellt, dass auf einem Exchange-Server ALockout.dll vorhanden ist, wird von dem Tool ein Fehler angezeigt.

Die Account Lockout and Management Tools sollten nicht auf Servern verwendet werden, die als Host für Netzwerkanwendungen oder Netzwerkdienste, einschließlich Exchange-Server, fungieren. Wenn die Account Lockout and Management Tools auf einem Exchange-Server installiert sind, könnte dies das Starten der Exchange-Dienste verhindern. Deshalb wird dringend empfohlen, dass auf diesem Exchange-Server die Account Lockout and Management Tools deinstalliert werden.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So beheben Sie diesen Fehler

  1. Geben Sie an der Eingabeaufforderung regsvr32 /u alockout.dll ein.

  2. Löschen Sie den Wert ALockout.dll unter dem folgenden Registrierungsschlüssel: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Windows\AppInit_DLLs
Hinweis:
Nach dem Löschen des Werts ALockout.dll ist der Registrierungseintrag AppInit_DLLs leer. Starten Sie den Computer neu.
  1. Löschen Sie im Ordner System32 die Datei ALockout.dll.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zu den Account Lockout and Management Tools finden Sie in „Account Lockout Tools" in Account Passwords and Policies unter (http://go.microsoft.com/fwlink/?LinkId=52465).


Keine Übereinstimmung bei Active Directory-Standort
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-03-16

Microsoft® Exchange Server Analyzer Tool implementiert die Win32-API-Funktion DsGetSiteName zum Abfragen des Standortnamens des Active Directory®-Verzeichnisdiensts des Domänencontrollers und des Active Directory-Standortnamens des lokalen Computers mit Exchange Server.

Wenn Exchange Server Analyzer feststellt, dass der Active Directory-Standortname des Domänencontrollers mit dem Active Directory-Standortnamen des lokalen Computers mit Exchange Server nicht übereinstimmt, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass der Verzeichnisdienstzugriffs-Prozess (Directory Service Access, DSAccess) seine LDAP-Anforderungen (Lightweight Directory Access Protocol) außerhalb des lokalen Active Directory-Standorts verarbeiten lässt, was zu schwerwiegenden Leistungseinbußen bei Exchange Server führen kann.

Diese Situation kann durch die statische Konfiguration eines außerhalb des Standorts liegenden Domänencontrollers verursacht werden, durch einen Ausfall des Netzwerks oder des Domänencontrollercomputers, wodurch der im Standort vorhandene Domänencontroller unerreichbar wird, oder von einer fehlerhaft entworfenen Active Directory-Topologie, die im Standort des Computers mit Exchange Server keinen Active Directory-Domänencontroller vorsieht.

DSAccess ist eine gemeinsam verwendete Exchange Server-Komponente, die auf Verzeichnisinformationen in einem Cache zugreift und dort speichert. DSAccess ermittelt dynamisch die Verzeichnisserver, mit denen andere Exchange-Komponenten eine Verbindung herstellen müssen, auf der Grundlage von Kriterien wie der Active Directory-Standortkonfiguration und der Active Directory-Servervrfügbarkeit. Front-End-Server mit Exchange verwenden DSAccess, um zu ermitteln, welcher Server das Postfach eines bestimmten Benutzers enthält, zur Ermittlung der SMTP-Adressen (Simple Mail Transfer Protocol), die für ein Benutzerobjekt vorhanden sind, und der Server, die Informationsspeicher für Öffentliche Ordner enthalten.

Im Anschluss an die Initialisierung verwendet DSAccess, wenn kein Satz statisch konfigurierter Domänencontroller oder globaler Kataloge in der Registrierung gefunden wurde, einen Ermittlungsprozess, um die Netzwerktopologie zu identifizieren und die Verfügbarkeit und Eignung von Verzeichnisservern zu bewerten. Ein Teil der Bestimmung der Eignung eines Domänencontrollers besteht darin, dass sich der Domänencontroller im selben Active Directory-Standort wie der Computer mit Exchange Server befindet.

Zur Verkürzung der Wartezeit, zu der es durch standortübergreifende LDAP-Anforderungen kommen kann, sollten sich Computer mit Exchange Server in einem Active Directory-Standort mit einem lokalen Domänencontroller befinden.

So beheben Sie dieses Problem

  • Beurteilen Sie die Standortdefinitionen für die Active Directory-Topologie, um sicherzustellen, dass jeder Computer mit Exchange Server über Zugriff auf einen Domänencontroller im selben Active Directory-Standort verfügt.

  • Stellen Sie sicher, dass sich alle statisch konfigurierten Domänencontroller im selben Active Directory-Standort wie der Computer mit Exchange Server befinden.

Weitere Informationen

Weitere Informationen zum Konfigurieren und Behandeln von Problemen mit DSAccess finden Sie in den folgenden Exchange-Ressourcen:

  • Verzeichnisintegration und Exchange Server (http://go.microsoft.com/fwlink/?LinkId=63447)

  • Grundlagen und Problembehandlung von Verzeichniszugriff (http://go.microsoft.com/fwlink/?LinkId=39012)

  • Microsoft Knowledge Base-Artikel 250570, „Verzeichnisdienst-Servererkennung und DSAccess-Verwendung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)


Administrative Dateifreigaben deaktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die administrativen Standardfreigaben deaktiviert wurden:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters\AutoShareServer

Wenn Exchange Server Analyzer feststellt, dass der Wert von AutoShareServer auf 0 festgelegt ist, wird ein Fehler angezeigt.

Dieser Fehler weist darauf hin, dass die vom Server erzeugten administrativen Standardfreigaben auf diesem Server deaktiviert sind. Wenn die administrativen Standardfreigaben deaktiviert sind, kann eine Onlinesicherung oder -wiederherstellung von Exchange Server möglicherweise nicht ordnungsgemäß ausgeführt werden. Je nach dem von Ihnen verwendeten Sicherungsprogramm wird u. U. eine Fehlermeldung angezeigt, wenn Sie versuchen, Daten wiederherzustellen. Möglicherweise finden Sie auch Fehlermeldungen im Sicherungsprotokoll auf Band.

Ein Entfernen der administrativen Freigaben kann außerdem zur Folge haben, dass Sie während einer Onlinesicherung von Exchange Server folgende Meldung erhalten: Unerwarteter Fehler 0xc0040000. Der Microsoft Exchange Server-Computer ist nicht verfügbar. Es wird empfohlen, die administrativen Standardfreigaben durch Bearbeiten der Registrierung und einen Neustart des Serverdienstes zu reaktivieren, um dieses Problem zu beheben.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So beheben Sie diesen Fehler

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

  3. Suchen Sie im rechten Bereich AutoShareServer, und doppelklicken Sie darauf.

  4. Ändern Sie den Wert von 0 auf 1.

  5. Beenden Sie den Registrierungs-Editor, und starten Sie den Serverdienst neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zum Wiederherstellen der administrativen Standardfreigaben in Microsoft Windows Server™ 2003 finden Sie im Knowledge Base-Artikel 816113, „HOW TO: Use Registry Editor to Restore Administrative Shares in Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816113).


Interoperabilität von AFD.SYS-Treiber und X.400-Connector
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Version von Microsoft Windows® zu bestimmen, die auf dem Exchange Server-Computer ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Der Wert 4.0 von CurrentVersion gibt an, dass auf dem ExchangeServer-Computer Microsoft Windows NT® Server 4.0 ausgeführt wird. Der Wert 5.0 zeigt an, dass auf dem Exchange Server-Computer Windows 2000 Server ausgeführt wird, und der Wert 5.2 zeigt an, dass auf dem Exchange Server-Computer Windows Server™ 2003 ausgeführt wird.

Exchange Server Analyzer fragt außerdem die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_ComputerSystem ab, um den Wert des Schlüssels NumberOfProcessors zu bestimmen. Dieser Wert stellt die Anzahl der Prozessoren dar, die im Computer installiert sind. Diese Prozessoren enthalten sowohl physische als auch logische Prozessoren. Mithilfe der Hyper-Threading-Technologie von Intel kann ein physischer Prozessor in zwei logische Prozessoren aufgeteilt werden.

Exchange Server Analyzer liest auch den folgenden Registrierungseintrag, um festzustellen, ob der Exchange-Server ein Bridgehead für einen X.400-Connector ist:

HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeMTA

Exchange Server Analyzer fragt außerdem die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile ab, um den Wert des Schlüssels Version für die Datei Afd.sys zu bestimmen.

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Der Exchange Server-Computer wird auf Windows Server 2000 ausgeführt.

  • Der Wert NumberOfProcessors ist größer als 1.

  • Der Exchange Server fungiert als Bridgehead für einen X.400-Connector.

  • Der Wert des Schlüssels Version für WINDOWSPATH%\\system32\\drivers\\afd.sys liegt im Bereich von 5.0.2195.7036 bis 5.0.2195.7060.

Diese Warnung zeigt an, dass die auf dem Server installierte Version von Afd.sys bei X.400-Connectors auf diesem Server Probleme bei der Mailübermittlung verursachen kann.

Um dieses Problem zu lösen, beschaffen Sie sich das Update, auf das Microsoft Knowledge Base-Artikel 904712 „Mail delivery is slower than expected, or mail delivery stops, on an X.400 connector to a remote site in Exchange Server 5.5" unter (http://go.microsoft.com/fwlink/?linkid=3052&kbid=904712) verweist.


Das Aging Keep Time-Intervall für die Datenbank entspricht nicht dem Standardwert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob das Attribut msExchAgingKeepTime festgelegt wurde. Dieses Attribut stellt den Zeitwert dar, mit dem ermittelt wird, wann Indizes, Ansichten und Kategorisierungen entfernt werden. Wenn Exchange Server Analyzer erkennt, dass dieses Attribut festgelegt ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Für Ansichten verwendete Indizes, die von einem Exchange-Client in Exchange-Datenbanktabellen erstellt und über einen bestimmten Zeitraum nicht verwendet wurden, werden zu diesem Zeitpunkt gelöscht. Das Attribut msExchAgingKeepTime gibt das Mindestalter für einen Index an, bevor dieser gelöscht wird. Der Standardwert in der Originalversion von Exchange 2000 Server entsprach acht Tagen. In Service Pack 1 (SP1) für Exchange 2000 Server und in allen nachfolgenden Versionen von Exchange Server, einschließlich Exchange Server 2003 und Exchange Server 2007, entspricht der Standardwert 40 Tagen.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, von Exchange Server 2003 bzw. Exchange Server 2007 oder beider Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So zeigen Sie den Wert „Aging Keep Time" an und ändern diesen

  1. Starten Sie die ADSI-Bearbeitung.

  2. Doppelklicken Sie auf den Container Konfiguration, erweitern Sie CN=Services, erweitern Sie CN=Microsoft Exchange, und erweitern Sie dann CN=<Name der Exchange-Organisation>.

  3. Erweitern Sie CN=Administrative Groups, erweitern Sie CN=<Name der administrativen Gruppe>, und erweitern Sie dann CN=Servers.

  4. Erweitern Sie CN=<Name des Servers>, erweitern Sie CN=InformationStore, und wählen Sie dann CN=<Name der Speichergruppe> aus.

  5. Klicken Sie mit der rechten Maustaste im Detailbereich auf CN=<Name des Postfachspeichers>, und klicken Sie dann auf Eigenschaften.

  6. Klicken Sie im Attribut-Editor auf das Attribut msExchAgingKeepTime, und klicken sie anschließend auf Bearbeiten.

  7. Klicken Sie im Feld Attribut bearbeiten auf Löschen, um den Wert zu löschen.

  8. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.

  9. Schließen Sie die ADSI-Bearbeitung. Wenn eine Änderung vorgenommen wurde, starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Weitere Informationen zum Verwenden des LDP-Tools finden Sie im Microsoft Knowledge Base-Artikel 260745 „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Weitere Informationen zu möglichen Problemen beim Zugriff auf Informationen in Informationsspeicherordnern in Exchange Server finden Sie im Microsoft Knowledge Base-Artikel 216076, "In Exchange kann das Zugreifen auf Informationsspeicherordner langsam werden" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=216076).


Antigen-Aktualisierung verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-06-20

Das Tool Microsoft Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows Management Instrumentation, Windows-Verwaltungsinstrumentation) CIM_Datafile ab, um den Wert für den Versionsschlüssel für MimeNavigator.dll zu ermitteln: Dieses Modul ist in Microsoft Antigen, Version 8 und 9, enthalten.

Wenn Exchange Analyzer feststellt, dass der Wert des Versionsschlüssels für MimeNavigator.dll kleiner als 8.00.1517.0 für Version 8 und kleiner als 9.00.1055.0 für Version 9 ist, zeigt Exchange Analyzer eine Warnung an.

Diese Warnung zeigt an, dass Microsoft Antigen, Version 8 oder 9, auf dem Servercomputer mit Exchange installiert und eine Softwareaktualisierung verfügbar ist. Es wird dringend empfohlen, diese Aktualisierung anzuwenden. Sie erhöht die Gesamtleistung und Zuverlässigkeit des Servers.

Um dieses Problem zu beheben, lesen Sie die Empfehlungen im Microsoft Knowledge Base-Artikel 928082, Die Größe von SMTP-Nachrichten kann während des Scanvorgangs in Antigen zunehmen () und wenden diese an.


Größe des Anwendungsprotokolls
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-11-09

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die maximale Größe der Anwendungsprotokolldatei zu ermitteln:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Eventlog\Application\MaxSize

Wenn Exchange Server Analyzer erkennt, dass der Wert von MaxSize niedriger als 41.943.040 Byte (40 MB) ist, zeigt Exchange Server Analyzer eine Best Practices-Meldung mit der empfohlenen Methode an.

In der Standardeinstellung beträgt die maximale Größe der Anwendungsprotokolldatei unter Windows Server 2003 16.777.216 Byte (16.348 KB) und unter Windows 2000 Server 524288 Byte (512 KB). Für Computer, auf denen Exchange Server ausgeführt wird, besteht die bewährte Methode darin, die maximale Größe der Anwendungsprotokolldatei auf 40 MB (Eingabe: 40960KB) oder mehr festzulegen. Durch Erhöhen der Anwendungsprotokollgröße behalten Sie mehr Anwendungsereignisse bei. Die zusätzlichen Ereignisinformationen sind bei der Behandlung von Problemen hilfreich.

So erhöhen Sie die maximale Größe des Anwendungsprotokolls

  1. Öffnen Sie das MMC-Snap-In (Microsoft Management Console) Ereignisanzeige.

  2. Klicken Sie mit der rechten Maustaste auf das Protokoll Anwendung, und klicken Sie dann auf Eigenschaften.

  3. Geben Sie auf der Registerkarte Allgemein unter Protokollgröße im Feld Maximale Protokollgröße den Wert 40960 oder einen höheren Wert ein, und klicken Sie dann auf OK.


Rootver für ASP.NET ist beschädigt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um den Wert zu bestimmen, der für den Schlüssel Rootver für ASP.NET festgelegt ist:

HKEY_LOCAL_MACHINE\Software\Microsoft\ASP.NET

Microsoft Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Exchange Server Analyzer ermittelt, dass der Wert für Rootver auf 0.0.0.0 festgelegt ist.

  • Der Clusterdienst wird ausgeführt.

In einigen Fällen schlägt das ASP.NET-Setup fehl, ohne dass eine Benachrichtigung über den Fehler ausgegeben wird. In solchen Fällen wird der Schlüssel Rootver auf 0.0.0.0 festgelegt. Wenn der Wert für Rootver auf 0.0.0.0 festgelegt wird, kann die Microsoft Exchange-Systemaufsicht oder ein anderer Exchange Server-Dienst nicht für Exchange Server 2003- oder Exchange Server 2007-Cluster gestartet werden. Sie müssen diesen Fehler beheben, indem Sie den Wert für Rootver auf einen der folgenden Werte festlegen.

  • Exchange Server 2003 Rootver-Schlüssel = 1.1.4322.0.

  • Exchange Server 2007 Rootver-Schlüssel = 2.0.50727.0

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So legen Sie Rootver auf 1.1.4322.0 fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\Software\Microsoft\ASP.NET\

  3. Doppelklicken Sie im Detailbereich auf den Schlüssel RootVer.

  4. Legen Sie im Dialogfeld Zeichenfolge bearbeiten den Wert von Wert auf die entsprechende zuvor genannt Angabe fest, und klicken Sie dann auf OK.

  5. Beenden Sie den Registrierungs-Editor.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Das automatische Debuggen des Betriebssystems wurde deaktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob das Debuggen des Betriebssystems deaktiviert wurde:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AeDebug\Auto

Wenn Exchange Server Analyzer feststellt, dass der Wert Auto auf 0 festgelegt ist, wird eine Warnung angezeigt.

In der Standardeinstellung wird mit den Betriebssystemen Microsoft Windows® 2000 Server und Microsoft Windows Server™ 2003 ein Anwendungsdebugger mit dem Namen Dr. Watson installiert. Ein Debugger ist ein Programm, das das Erkennen, Suchen und Berichtigen von Fehlern in einem anderen Programm unterstützt, indem es einen Programmierer schrittweise durch das Programm führt und ihm so ermöglicht, Daten zu überprüfen und Bedingungen (z. B. die Werte von Variablen) zu überwachen.

Die Standardoptionen werden beim erstmaligen Ausführen von Dr. Watson festgelegt. Dieses Programm wird dann ausgeführt, wenn ein Programmfehler auftritt, oder wenn Sie Dr. Watson selbst starten.

Wenn ein Anwendungsfehler auftritt, sucht Windows nach einem Programmfehlerhandler. Ein Programmfehlerhandler behandelt Fehler dann, wenn sie während der Ausführung eines Programms auftreten. Wenn Windows keinen Programmfehlerhandler erkennt, prüft es, dass für das Programm derzeit kein Debug-Prozess ausgeführt wird und betrachtet den Fehler als nicht behandelt. Windows verarbeitet nicht behandelte Fehler, indem es in der Registrierung nach einem Programmfehlerdebugger sucht.

Das Verhalten von Windows ist dabei abhängig von den Einstellungen der beiden Registrierungswerte unter: HKLM\Software\Microsoft\Windows NT\CurrentVersion\AeDebug

Die Einträge haben die Namen Debugger und Auto. Der Wert für den Eintrag Debugger legt den Befehl für den Debugger fest, der zur Analyse von Programmfehlern verwendet wird. Wenn der Wert für den Eintrag Debugger ermittelt wird, prüft Windows, ob der Wert für den Eintrag Auto auf 0 oder 1 festgelegt ist:

  • Ist der Wert für den Eintrag Auto auf 0 festgelegt, erzeugt Windows ein Meldungsfeld, in dem angezeigt wird, dass ein Programmfehler aufgetreten ist. Wenn der Wert für den Eintrag Debugger den Befehl für einen gültigen Debugger festlegt, werden im Meldungsfeld zwei Schaltflächen angezeigt: OK und Abbrechen. Wenn Sie auf OK klicken, wird das Programm angehalten. Wenn Sie auf Abbrechen klicken, wird der angegebene Debugger gestartet. Wenn der Wert für den Eintrag Debugger leer ist, wird im Meldungsfeld lediglich OK angezeigt. Es wird kein Debugger gestartet.

  • Wenn der Wert für den Eintrag Auto auf 1 festgelegt ist, und der Wert für den Eintrag Debugger den Befehl für einen gültigen Debugger angibt, startet das System den Debugger automatisch. Es wird kein Meldungsfeld angezeigt.

Wenn Windows installiert ist, wird der Wert für den Eintrag Auto in der Standardeinstellung auf 1 festgelegt, und der Wert für den Eintrag Debugger gibt den Befehl zum Starten von Dr. Watson an (drwtsn32 -p %ld -e %ld -g). Das bedeutet, dass Dr. Watson im Fall eines Programmfehlers den Fehler automatisch diagnostiziert und die entsprechende Diagnoseinformation protokolliert.

Es wird als optimale Vorgehensweise empfohlen, auf Exchange Server-Computern einen Programmfehlerdebugger zu verwenden. Wenn Sie ein anderes Programm als Dr. Watson als Standarddebugger verwendet haben, und nun stattdessen Dr. Watson verwenden möchten, rufen Sie die Eingabeaufforderung auf, und geben Sie dort den Befehl drwtsn32 -i ein, um Dr. Watson zu starten. Die Angabe -i veranlasst, dass die erforderlichen Änderungen an der Registrierung vorgenommen werden.

So können Sie Dr. Watson über die Eingabeaufforderung als Standarddebugger registrieren

  1. Öffnen Sie ein Eingabeaufforderungsfenster.

  2. Führen Sie den folgenden Befehl aus: drwtsn32 -i

  3. Sie erhalten die Nachricht „Dr. Watson wurde als Standardanwendungs-Debugger installiert." Klicken Sie auf OK, um diese Nachricht zu bestätigen.

So können Sie Dr. Watson über die Benutzerschnittstelle als Standarddebugger registrieren

  1. Klicken Sie auf Start und dann auf Ausführen, geben Sie drwtsn32 ein, und drücken Sie anschließend die EINGABETASTE. Die Benutzeroberfläche von Dr. Watson für Windows wird angezeigt.

  2. Aktivieren Sie das Kontrollkästchen Datei für Absturzspeicherabbild erstellen.

  3. Klicken Sie auf OK, um die Änderungen zu speichern und die Benutzeroberfläche von Dr. Watson für Windows zu schließen.

Weitere Informationen zu Dr. Watson für Windows finden Sie in der Dr. Watson-Hilfedatei, die angezeigt wird, wenn Sie in der Dr. Watson-Benutzeroberfläche die Taste F1 drücken.

Wenn Sie vorhaben, einen anderen Programmfehlerdebugger als Dr. Watson zu verwenden, können Sie Dr. Watson mit der im Microsoft Knowledge Base-Artikel 188296, „Deaktivieren von Dr. Watson für Windows NT" (http://support.microsoft.com/default.aspx?scid=kb;de;188296), beschriebenen Vorgehensweise deaktivieren.


Die durchschnittliche Wartezeit beim LDAP-Lesevorgang hat 50 Millisekunden überschritten
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-03-14

Das Tool Microsoft Exchange Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem LDAP Read Time-Leistungsindikator des MSExchangeDSAccess Process-Leistungsobjekts.

Der Leistungsindikator LDAP Read Time zeigt die Zeit in Millisekunden an, die für das Ausführen einer LDAP-Leseanforderung (Lightweight Directory Access Protocol) benötigt wird. Exchange Analyzer ruft fünf Minuten lang alle fünf Sekunden einen Messwert ab. Anschließend meldet Exchange Analyzer den Maximalwert des Leistungsindikators innerhalb des Erfassungszeitraums. Wenn der Durchschnittswert 50 Millisekunden übersteigt, zeigt Exchange Analyzer eine Warnung an.

Lange Wartezeiten bei LDAP-Lesevorgängen können von langen RPC-Wartezeiten (Remote Procedure Call, Remoteprozeduraufruf) und wachsenden Warteschlangen verursacht werden. Generell weisen lange Wartezeiten bei LDAP-Lesevorgängen auf eins der folgenden Probleme hin:

  • Ein Leistungsproblem bei der Netzwerkverbindung mit dem Domänencontroller.

  • Leistungsprobleme mit dem Domänencontroller selbst.

Hinweis:
LDAP-Wartezeiten sind im Allgemeinen höher, wenn Benutzer eine Verbindung mit Domänencontrollern herstellen, die sich physisch an anderen Standorten befinden. Dennoch sollten die in diesem Artikel empfohlenen Maximalwerte für Wartezeiten grundsätzlich eingehalten werden.

Befindet sich der Domänencontroller, auf dem diese Warnung protokolliert wurde, physisch an einem anderen Standort, können Sie diesen Fehler möglicherweise gefahrlos ignorieren, wenn Sie ermitteln können, dass der Domänencontroller, der diese Warnung ausgibt, nicht vom Exchange-Server verwendet wird. Eine Möglichkeit zur Ermittlung, ob ein Domänencontroller von Exchange verwendet wird, besteht darin, das Diagnoseprotokoll für die Topologie-Komponente des MSExchangeDSAccess-Diensts auf den Wert Minimum festzulegen. Finden Sie im Protokoll nicht die MSExchangeDSAccess-Ereignis-ID 2080, können Sie diese Warnung gefahrlos ignorieren.

Um diese Warnung zu beheben, führen Sie die folgenden Schritte aus:

  • Vergewissern Sie sich, dass alle Netzwerkverbindungen zum Domänencontroller funktionstüchtig sind und ICMP-Datenverkehr (Internet Control Monitoring Protocol) unterstützen.

  • Berücksichtigen Sie die in den folgenden Artikeln aufgeführten bewährten Methoden:

    • Informationen zum LDAP Read Time-Leistungsindikator und andere Leistungsindikatoren, die für die Problembehandlung von Active Directory-bezogenen Problemen herangezogen werden können, finden Sie unter dem Thema "Ruling Out Active Directory-Bound Problems" im Handbuch Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588). Dieser Artikel enthält ebenfalls Informationen zu Möglichkeiten der Leistungssteigerung von Active Directory.

    • Weitere Informationen zum Optimieren der Leistung von Active Directory finden Sie unter dem Thema „Active Directory Integration Tuning" im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

    • Informationen zum Sichern der Hochverfügbarkeit für Ihre Active Directory-Server finden Sie in den Abschnitten unter "Ensuring Reliable Access to Active Directory and Domain Name System" im Thema "System-Level Fault Tolerant Measures" im Handbuch Exchange Server 2003 High Availability Guide (http://go.microsoft.com/fwlink/?LinkId=47571).

    • Informationen zu Aspekten der Netzwerkbandbreite finden Sie im Abschnitt „Network Performance" des Themas „Understanding Exchange Performance" im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).


Die maximale Wartezeit beim LDAP-Lesevorgang hat 100 Millisekunden überschritten
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-03-14

Das Tool Microsoft Exchange Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem LDAP Read Time-Leistungsindikator des MSExchangeDSAccess Process-Leistungsobjekts.

Der Leistungsindikator LDAP Read Time zeigt die Zeit in Millisekunden an, die für das Ausführen einer LDAP-Leseanforderung (Lightweight Directory Access Protocol) benötigt wird. Exchange Analyzer ruft fünf Minuten lang alle fünf Sekunden einen Messwert ab. Anschließend meldet Exchange Analyzer den Maximalwert des Leistungsindikators innerhalb des Erfassungszeitraums. Wenn der Höchstwert 100 Millisekunden übersteigt, zeigt Exchange Analyzer einen Fehler an.

Lange Wartezeiten bei LDAP-Lesevorgängen können von langen RPC-Wartezeiten (Remote Procedure Call, Remoteprozeduraufruf) und wachsenden Warteschlangen verursacht werden. Generell weisen lange Wartezeiten bei LDAP-Lesevorgängen auf eins der folgenden Probleme hin:

  • Ein Leistungsproblem bei der Netzwerkverbindung mit dem Domänencontroller.

  • Leistungsprobleme mit dem Domänencontroller selbst.

Hinweis:
LDAP-Wartezeiten sind im Allgemeinen höher, wenn Benutzer eine Verbindung mit Domänencontrollern herstellen, die sich physisch an anderen Standorten befinden. Dennoch sollten die in diesem Artikel empfohlenen Maximalwerte für Wartezeiten grundsätzlich eingehalten werden.

Server mit Exchange fragen domänenexterne globale Katalogserver alle 15 Minuten ab, um stets über eine aktuelle Liste der globalen Katalogserver und Domänencontroller zu verfügen. Da einige dieser Verzeichnisserver ggf. Remoteserver sind, kann die Wartezeit für diese Abfragen lang sein. Dies ist akzeptabel, solange die Abfragen selten sind, d. h. die Rate kleiner als 0,5 Abfragen pro Sekunde ist.

Befindet sich der Domänencontroller, auf dem dieser Fehler protokolliert wurde, physisch an einem anderen Standort, können Sie diesen Fehler möglicherweise gefahrlos ignorieren, wenn Sie ermitteln können, dass der Domänencontroller, der diesen Fehler ausgibt, nicht vom Servercomputer mit Exchange verwendet wird. Eine Möglichkeit zur Ermittlung, ob ein Domänencontroller von Exchange verwendet wird, besteht darin, das Diagnoseprotokoll für die Topologie-Komponente des MSExchangeDSAccess-Diensts auf den Wert Minimum festzulegen. Finden Sie im Protokoll nicht die MSExchangeDSAccess-Ereignis-ID 2080, können Sie diesen Fehler gefahrlos ignorieren.

Wichtig:
Für Umgebungen im gemischten Modus wurde zum Zeitpunkt der Freigabe von Exchange 2000 SP2 ein bestimmtes Verhalten für spezifische sicherheitsbezogene Benutzerattribute wie tokenGroups und tokengroupsGlobalandUniversal eingeführt. Diese dienen der Bestimmung, welchen Sicherheitsgruppen ein Benutzer angehört und welche Berechtigungen er zum Absichern von Ressourcen wie z. B. Öffentlichen Ordnern hat. Dazu muss der Server mit Exchange einen Domänencontroller abfragen, der für die Stammdomäne des Benutzers autorisierend ist. Der autorisierende Domänencontroller kann sich an einem Remotestandort befinden. Abfragen einer großen Anzahl von Benutzern in Remotestammdomänen, die auf lokale Öffentliche Ordner zugreifen, können zu langen RPC-Wartezeiten beitragen.

Weitere Informationen zu diesem Verhalten finden Sie im folgenden Exchange Server-Blog-Thema:

  • Exchange Does Not Always Use Local GCs

    Hinweis:
    Links zu Blogs werden bereitgestellt, um Sie bei der Suche nach den benötigten technischen Informationen zu unterstützen. Der Inhalt jedes Blogs und die dazugehörigen URLs können jederzeit ohne vorherige Ankündigung geändert werden.

Um diesen Fehler zu beheben, führen Sie folgende Schritte aus:

  • Vergewissern Sie sich, dass alle Netzwerkverbindungen zum Domänencontroller funktionstüchtig sind und ICMP-Datenverkehr (Internet Control Monitoring Protocol) unterstützen.

  • Berücksichtigen Sie die in den folgenden Artikeln aufgeführten bewährten Methoden:

    • Informationen zum LDAP Read Time-Leistungsindikator und andere Leistungsindikatoren, die für die Problembehandlung von Active Directory-bezogenen Problemen herangezogen werden können, finden Sie unter dem Thema "Ruling Out Active Directory-Bound Problems" im Handbuch Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588). Dieser Artikel enthält ebenfalls Informationen zu Möglichkeiten der Leistungssteigerung von Active Directory.

    • Weitere Informationen zum Optimieren der Leistung von Active Directory finden Sie unter dem Thema „Active Directory Integration Tuning" im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

    • Informationen zum Sichern der Hochverfügbarkeit für Ihre Active Directory-Server finden Sie in den Abschnitten unter "Ensuring Reliable Access to Active Directory and Domain Name System" im Thema "System-Level Fault Tolerant Measures" im Handbuch Exchange Server 2003 High Availability Guide (http://go.microsoft.com/fwlink/?LinkId=47571).

    • Informationen zu Aspekten der Netzwerkbandbreite finden Sie im Abschnitt „Network Performance" des Themas „Understanding Exchange Performance" im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).


Die durchschnittliche Wartezeit bei der LDAP-Suche hat 50 Millisekunden überschritten
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-03-14

Das Tool Microsoft Exchange Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem LDAP Search Time-Leistungsindikator des MSExchangeDSAccess Process-Leistungsobjekts.

Der Leistungsindikator LDAP Search Time zeigt die Zeit in Millisekunden an, die für das Ausführen einer LDAP-Suchanforderung (Lightweight Directory Access Protocol) benötigt wird. Exchange Analyzer ruft fünf Minuten lang alle fünf Sekunden einen Messwert ab. Anschließend meldet Exchange Analyzer den Maximalwert des Leistungsindikators innerhalb des Erfassungszeitraums. Wenn der Durchschnittswert 50 Millisekunden übersteigt, zeigt Exchange Analyzer eine Warnung an.

Lange Wartezeiten bei der LDAP-Suche können von langen RPC-Wartezeiten (Remote Procedure Call, Remoteprozeduraufruf) und wachsenden Warteschlangen verursacht werden. Generell weisen lange Wartezeiten bei LDAP-Suchen auf eins der folgenden Probleme hin:

  • Ein Leistungsproblem bei der Netzwerkverbindung mit dem Domänencontroller.

  • Leistungsprobleme mit dem Domänencontroller selbst.

Hinweis:
LDAP-Wartezeiten sind im Allgemeinen höher, wenn Benutzer eine Verbindung mit Domänencontrollern herstellen, die sich physisch an anderen Standorten befinden. Dennoch sollten die in diesem Artikel empfohlenen Maximalwerte für Wartezeiten grundsätzlich eingehalten werden.

Befindet sich der Domänencontroller, auf dem diese Warnung protokolliert wurde, physisch an einem anderen Standort, können Sie diesen Fehler möglicherweise gefahrlos ignorieren, wenn Sie ermitteln können, dass der Domänencontroller, der diese Warnung ausgibt, nicht vom Exchange-Server verwendet wird. Eine Möglichkeit zur Ermittlung, ob ein Domänencontroller von Exchange verwendet wird, besteht darin, das Diagnoseprotokoll für die Topologie-Komponente des MSExchangeDSAccess-Diensts auf den Wert Minimum festzulegen. Finden Sie im Protokoll nicht die MSExchangeDSAccess-Ereignis-ID 2080, können Sie diese Warnung gefahrlos ignorieren.

Um diese Warnung zu beheben, führen Sie die folgenden Schritte aus:

  • Vergewissern Sie sich, dass alle Netzwerkverbindungen zum Domänencontroller funktionstüchtig sind und ICMP-Datenverkehr (Internet Control Monitoring Protocol) unterstützen.

  • Berücksichtigen Sie die in den folgenden Artikeln aufgeführten bewährten Methoden:

    • Informationen zum LDAP Read Time-Leistungsindikator und andere Leistungsindikatoren, die für die Problembehandlung von Active Directory-bezogenen Problemen herangezogen werden können, finden Sie unter dem Thema "Ruling Out Active Directory-Bound Problems" im Handbuch Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588). Dieser Artikel enthält ebenfalls Informationen zu Möglichkeiten der Leistungssteigerung von Active Directory.

    • Weitere Informationen zum Optimieren der Leistung von Active Directory finden Sie unter dem Thema „Active Directory Integration Tuning" im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

    • Informationen zum Sichern der Hochverfügbarkeit für Ihre Active Directory-Server finden Sie in den Abschnitten unter "Ensuring Reliable Access to Active Directory and Domain Name System" im Thema "System-Level Fault Tolerant Measures" im Handbuch Exchange Server 2003 High Availability Guide (http://go.microsoft.com/fwlink/?LinkId=47571).

    • Informationen zu Aspekten der Netzwerkbandbreite finden Sie im Abschnitt „Network Performance" des Themas „Understanding Exchange Performance" im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).


Die maximale Wartezeit bei der LDAP-Suche hat 100 Millisekunden überschritten
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-03-14

Das Tool Microsoft Exchange Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem LDAP Search Time-Leistungsindikator des MSExchangeDSAccess Process-Leistungsobjekts.

Der Leistungsindikator LDAP Search Time zeigt die Zeit in Millisekunden an, die für das Ausführen einer LDAP-Suchanforderung (Lightweight Directory Access Protocol) benötigt wird. Exchange Analyzer ruft fünf Minuten lang alle fünf Sekunden einen Messwert ab. Anschließend meldet Exchange Analyzer den Maximalwert des Leistungsindikators innerhalb des Erfassungszeitraums. Wenn der Höchstwert 100 Millisekunden übersteigt, zeigt Exchange Analyzer einen Fehler an.

Lange Wartezeiten bei der LDAP-Suche können von langen RPC-Wartezeiten (Remote Procedure Call, Remoteprozeduraufruf) und wachsenden Warteschlangen verursacht werden. Generell weisen lange Wartezeiten bei LDAP-Suchen auf eins der folgenden Probleme hin:

  • Ein Leistungsproblem bei der Netzwerkverbindung mit dem Domänencontroller.

  • Leistungsprobleme mit dem Domänencontroller selbst.

Hinweis:
LDAP-Wartezeiten sind im Allgemeinen höher, wenn Benutzer eine Verbindung mit Domänencontrollern herstellen, die sich physisch an anderen Standorten befinden. Dennoch sollten die in diesem Artikel empfohlenen Maximalwerte für Wartezeiten grundsätzlich eingehalten werden.

Server mit Exchange fragen domänenexterne globale Katalogserver alle 15 Minuten ab, um stets über eine aktuelle Liste der globalen Katalogserver und Domänencontroller zu verfügen. Da einige dieser Verzeichnisserver ggf. Remoteserver sind, kann die Wartezeit für diese Abfragen lang sein. Dies ist akzeptabel, solange die Abfragen selten sind, d. h. die Rate kleiner als 0,5 Abfragen pro Sekunde ist.

Befindet sich der Domänencontroller, auf dem dieser Fehler protokolliert wurde, physisch an einem anderen Standort, können Sie diesen Fehler möglicherweise gefahrlos ignorieren, wenn Sie ermitteln können, dass der Domänencontroller, der diesen Fehler ausgibt, nicht vom Exchange-Server verwendet wird. Eine Möglichkeit zur Ermittlung, ob ein Domänencontroller von Exchange verwendet wird, besteht darin, das Diagnoseprotokoll für die Topologie-Komponente des MSExchangeDSAccess-Diensts auf den Wert Minimum festzulegen. Finden Sie im Protokoll nicht die MSExchangeDSAccess-Ereignis-ID 2080, können Sie diesen Fehler gefahrlos ignorieren.

Wichtig:
Ausschließlich für Umgebungen im gemischten Modus wurde etwa zeitgleich mit Exchange 2000 SP2 Verhalten für bestimmte sicherheitsbezogene Benutzerattribute wie z. B. tokenGroups und tokengroupsGlobalandUniversal bereitgestellt. Diese wurden für die Ermittlung verwendet, in welcher Sicherheitsgruppe ein Benutzer Mitglied ist und über welche Berechtigungen er für sichere Ressource wie z. B. Öffentliche Ordner verfügt, die es erfordern, dass der Servercomputer mit Exchange einen Domänencontroller abfragt, der autorisierend für die Stammdomäne des Benutzers ist. Der autorisierende Domänencontroller kann sich an einem Remotestandort befinden. Abfragen einer großen Anzahl von Benutzern in Remotestammdomänen, die auf lokale Öffentliche Ordner zugreifen, können zu langen RPC-Wartezeiten beitragen.

Weitere Informationen zu diesem Verhalten finden Sie im folgenden Exchange Server-Blog-Artikel:

  • Exchange Does Not Always Use Local GCs

    Hinweis:
    Links zu Blogs werden bereitgestellt, um Sie bei der Suche nach den benötigten technischen Informationen zu unterstützen. Der Inhalt jedes Blogs und die dazugehörigen URLs können jederzeit ohne vorherige Ankündigung geändert werden.

Um diesen Fehler zu beheben, führen Sie folgende Schritte aus:

  • Vergewissern Sie sich, dass alle Netzwerkverbindungen zum Domänencontroller funktionstüchtig sind und ICMP-Datenverkehr (Internet Control Monitoring Protocol) unterstützen.

  • Berücksichtigen Sie die in den folgenden Artikeln aufgeführten bewährten Methoden:

    • Informationen zum LDAP Read Time-Leistungsindikator und andere Leistungsindikatoren, die für die Problembehandlung von Active Directory-bezogenen Problemen herangezogen werden können, finden Sie unter dem Thema "Ruling Out Active Directory-Bound Problems" im Handbuch Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588). Dieser Artikel enthält ebenfalls Informationen zu Möglichkeiten der Leistungssteigerung von Active Directory.

    • Weitere Informationen zum Optimieren der Leistung von Active Directory finden Sie unter dem Thema „Active Directory Integration Tuning" im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

    • Informationen zum Sichern der Hochverfügbarkeit für Ihre Active Directory-Server finden Sie in den Abschnitten unter "Ensuring Reliable Access to Active Directory and Domain Name System" im Thema "System-Level Fault Tolerant Measures" im Handbuch Exchange Server 2003 High Availability Guide (http://go.microsoft.com/fwlink/?LinkId=47571).

    • Informationen zu Aspekten der Netzwerkbandbreite finden Sie im Abschnitt „Network Performance" des Themas „Understanding Exchange Performance" im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).


Das angegebene Exchange-Gateway kann nicht identifiziert werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-08-08

Microsoft® Exchange Server Analyzer fragt den Namen (cn) jedes Verzeichnisobjekts, das die Objektklasse msExchExchangeServer aufweist, im Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob eine Übereinstimmung mit dem vom Benutzer angegebenen Exchange-Gatewayserver vorhanden ist.

Der Wert cn ist eine Zeichenfolge, die den Kurznamen des Exchange Server-Computers enthält.

Wenn Exchange Server Analyzer in Active Directory für den vom Benutzer angegebenen Exchange-Gatewayserver keine Übereinstimmung mit dem Wert cn findet, zeigt Exchange Server Analyzer einen Fehler an.

Dieser Fehler weist darauf hin, dass eine der folgenden Bedingungen vorliegt:

  • Der vom Benutzer angegebene Exchange-Gatewayserver ist in der lokalen Exchange Server-Organisation nicht vorhanden.

  • Der vom Benutzer angegebene Exchange-Gatewayserver wurde nicht korrekt eingegeben.

Um diesen Fehler zu beheben, überprüfen Sie, ob der angegebene Exchange-Gatewayserver korrekt eingegeben wurde, und führen Sie den Vorgang dann erneut aus.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So überprüfen Sie den Wert des Servernamens (cn)

  1. Verwenden Sie die ADSI-Bearbeitung oder ein vergleichbares Tool, um das Serverobjekt in Active Directory zu suchen.

    Das Attribut CN befindet sich unter:

    Code kopieren
    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Servers,CN=Server.


Die Länge der Warteschlange des Kategorisierungsmoduls hat den Schwellenwert überschritten
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-02-13

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Categorizer Queue Length-Leistungsindikator des SMTP Server-Leistungsobjekts.

Wenn Exchange Server Analyzer feststellt, dass der Leistungsindikator Categorizer Queue Length den Spitzenwert von 10 während des Erfassungszeitraums überschritten hat, wird ein Fehler angezeigt.

Der Leistungsindikator SMTP Server\Categorizer Queue Length gibt die Anzahl der Meldungen in der SMTP-Warteschlange (Simple Mail Transfer Protocol) des Kategorisierungsmoduls an, die auf Suchvorgänge in den Verzeichnisdienstattributen mithilfe globaler Katalogserver warten.

Das Kategorisierungsmodul führt die folgenden Kernoperationen aus:

  • Auflösen und Validieren aller Empfänger.

  • Ermitteln von Grenzwerten und Einschränkungen für alle Empfänger.

  • Erweitern von Verteilerlisten, falls erforderlich.

  • Ermitteln, ob eine Nachricht für die lokale oder Remoteübermittlung bestimmt ist.

Dieser Fehler zeigt an, dass möglicherweise Probleme bei der Server- oder Netzwerkleistung, bei DSAccess (Directory Service Access), beim Active Directory®-Verzeichnisdienst oder Ausfälle bei den Schlüsselservern in der Exchange Server-Organisation vorliegen. Ein Anstieg des Leistungsindikators Categorizer Queue Length kann entweder auf ein Verlangsamen oder Ausbleiben von Antworten bei Anfragen an Active Directory bzw. beim Übergeben von Nachrichten zur lokalen Übermittlung oder an SMTP hinweisen. Dies kann zu Verzögerungen bei der Nachrichtenübermittlung führen.

So beheben Sie diesen Fehler

  • Überprüfen Sie, dass dem Exchange-Server ausreichende Active Directory-Ressourcen zur Verfügung stehen. Hierzu gehören sowohl Domänencontroller als auch globale Katalogserver. In der Praxis wird empfohlen, ein Verhältnis von 4:1 zwischen Exchange-Server-Prozessoren und Prozessoren des globalen Katalogservers mit gleicher Geschwindigkeit aufrechtzuerhalten.

  • Überprüfen Sie im Exchange-System-Manager, dass alle auf der Registerkarte DSAccess des Exchange-Servers aufgeführten Domänencontroller ordnungsgemäß arbeiten. Hierzu gehören auch die Server, die unter den Serverfunktionen ConfigDC, Domänencontroller und globaler Katalogserver aufgeführt werden.

  • Überwachen Sie die Netzwerkleistung zwischen dem Exchange-Server und seinen gewählten Domänencontrollern und globalen Katalogservern, um zu ermitteln, ob dort ein Engpass bei der Netzwerkleistung vorliegt.

  • Überwachen Sie die Prozessornutzung auf dem Exchange-Server sowie die Prozessornutzung des Prozesses Inetinfo.exe. Hierzu gehört auch die Kategorisierungsmodulkomponente.

  • Überprüfen Sie den Zustand Exchange-bezogener Benutzer- und Gruppenobjekte unter Verwendung des e2kdsinteg-Konfigurationsobjekts des Tools ConfigDSInteg aus den Microsoft Exchange Server-Bereitstellungstools (http://go.microsoft.com/fwlink/?LinkId=21231). Objekte mit fehlerhaften Adressen oder unvollständigen Informationen können Verzögerungen bei der Empfängerermittlung verursachen sowie die Kategorisierung verzögern.

Weitere Informationen

Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange Server finden Sie im Handbuch Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Datei „CDO.DLL" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für Ihr CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Product Key ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


CimWin32.dll-Aktualisierung verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-09-19

Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Version von Microsoft Windows® zu bestimmen, die auf dem Exchange Server-Computer ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Der Wert 4.0 von CurrentVersion gibt an, dass auf dem ExchangeServer-Computer Microsoft Windows NT® Server 4.0 ausgeführt wird. Der Wert 5.0 zeigt an, dass auf dem Exchange Server-Computer Windows 2000 Server ausgeführt wird, und der Wert 5.2 zeigt an, dass auf dem Exchange Server-Computer Windows Server™ 2003 ausgeführt wird.

Darüber hinaus fragt Exchange Server Analyzer die WMI-Klasse CIM_Datafile (Microsoft Windows® Management Instrumentation) ab, um den Wert zu ermitteln, der für den Schlüssel Version der Datei Cimwin32.dll festgelegt ist.

Microsoft Exchange Server Analyzer zeigt eine Meldung mit der optimalen Methode an, wenn die folgenden Bedingungen erfüllt sind:

  • Der Exchange Server-Computer wird unter Windows 2000 Server ausgeführt.

  • Der Wert des Schlüssels Version entspricht einer bestimmten Version der Datei Cimwin32.dll.

Es gibt eine Aktualisierung der Datei Cimwin32.dll, mit der Exchange Server Analyzer effizienter arbeiten kann.

Um dieses Problem zu beheben, richten Sie sich nach dem Empfehlungen im Microsoft Knowledge Base-Artikel 820608, "CIM_DataFile-Klasse gibt in Windows 2000 einen falschen Wert oder einen Nullwert für Dateien mit mehr als 2 GB zurück" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=820608).


Einfluss der Clientanwendungen auf die Serverleistung
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer hat festgestellt, dass bei Ihnen bestimmte Arten von Client-Computern oder clientseitigen Anwendungen eingesetzt werden, durch die sich die Serverlast in Ihrer Exchange-Organisation erhöht.

Viele Anwendungen erhöhen die Last auf dem Server. Wenn die Last gestiegen ist, sollten Sie analysieren, welche Anwendungen Ihre Benutzer ausführen, und entscheiden, ob Sie den Einsatz bestimmter Anwendungen durch die Benutzer einschränken. Manche Anwendungen, die auf E-Mail zugreifen (Anwendungen von Drittanbietern oder Plug-Ins für Microsoft Office Outlook®) könnendie Last auf dem Server erhöhen. Wenn es auf dem Server zu einem Anstieg der RPC-Wartezeiten (Remote Procedure Call - Remoteprozeduraufruf) oder einer Zunahme der Last kommt, ist es geboten, die Ursache dafür zu untersuchen.

Sie können mit Exchange Server User Monitor (ExMon) Benutzer identifizieren, bei denen es zu langen Wartezeiten kommt, oder die die Last auf dem Server erhöhen. Downloaden Sie ExMon vom Microsoft Download Center unter (http://go.microsoft.com/fwlink/?linkid=54983).

Verfahren

So beheben Sie diese Warnung

  • Mit ExMon können Sie bestimmen, welche Benutzer den Anstieg der Serverlast verursachen. Nachdem die Benutzer ermittelt wurden, wenden Sie sich an die Benutzer, und stellen Sie fest, ob die folgenden Anwendungen die zusätzliche Belastung verursachen:

    • Plug-Ins von Drittanbietern für Client-Computer

    • Desktop-Synchronisierungstools, z. B. Exchange ActiveSync® oder Blackberry

    • Andere MAPI-Anwendungen wie Virensuchprogramme

    Wenn diese Anwendungen für Ihre geschäflichen Zwecke nicht erforderlich sind, oder wenn es für die Anwendungen einen Hotfix gibt, deaktivieren Sie die Anwendungen oder aktualisieren Sie diese, um die Last auf ein angemesseneres Niveau abzusenken.

  • Konfigurieren Sie die Clientcomputer, deren Betrieb am aufwändigsten ist (insbesondere diejenigen mit langen Wartezeiten bei den Vorgängen Restrict, SetColumns oder FindRow), für die Verwendung im Exchange-Cache-Modus. Im Exchange-Cache-Modus wird der Server von nahezu allem überschüssigen RPC-Verkehr isoliert.

    Ermutigen Sie außerdem Benutzer mit vielen Objekten in ihren Ordnern, ältere Daten in einer PST-Datei zu archivieren. Wenn diese Benutzer Ihre Daten auf dem Server lassen möchten, fordern Sie sie auf, ältere Elemente in neu angelegte Ordner zu verschieben.

    Schließlich wird noch empfohlen, dass Sie weniger als 5.000 Elemente in den Ordnern des Posteingangs, des Kalenders, der gesendeten Objekte, der Kontakte und der gelöschten Objekte speichern.
Hinweis:
Manchen Anwendungen können die Serverlast deutlich erhöhen, ohne eine große Anzahl von MAPI-Operationen zu verursachen. Dies liegt daran, dass manche Operationen aufwändiger als andere sind. Es kann zwar sein, dass die Anzahl der aufwändigen Operationen nur geringfügig ansteigt, dass dies aber einen deutlichen Einfluss auf die Serverleistung hat. ExMon meldet diese Benutzer mit einem relativ starken Einfluss auf die CPU, ohne dass sie notwendigerweise eine hohe Anzahl von MAPI-Operationen durchgeführt haben.

Weitere Informationen

  • Weitere Informationen zur Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=de).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=de).

  • Weitere Informationen zu Behebung von Problemen mit der Leistung von Outlook-Clients finden Sie unter „Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803).

  • Weitere Informationen zu Antivirussoftware finden Sie im Microsoft Knowledge Base-Artikel 905184, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184).


Der TEMP-Pfad für Cluster ist ungültig oder weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Auf einem Exchange-Server-Computer, der nicht Teil eines Clusters ist, liest Microsoft® Exchange Server Analyzer die folgenden Registrierungseinträge, um den Wert für die Umgebungsvariable TEMP zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

Wenn Exchange Server Analyzer für einen virtuellen Exchange-Server (EVS) in einem Microsoft Windows®-Servercluster ausgeführt wird, wird die Registrierungsstruktur HKLM nicht gelesen. Stattdessen liest Exchange Server Analyzer den folgenden Registrierungseintrag:

HKEY_USERS\<Clusterdienstkonto-SID>\Environment\TEMP

Wenn Exchange Server Analyzer feststellt, dass die Umgebungsvariable TEMP nicht für einen auf dem aktuellen System verfügbaren Pfad festgelegt ist, wird eine Warnung angezeigt. Wenn dieser Pfad ungültig ist, treten in der Organisation u. U. Fehler bei der E-Mail-Übermittlung auf. Exchange Server Analyzer erwartet in der Standardkonfiguration, dass dieser Pfad auf %USERPROFILE%\Local Settings\Temp festgelegt ist. Auch wenn dieser Pfad so geändert werden kann, dass er auf andere Speicherorte zeigt, erwartet das System möglicherweise, dass der Pfad auf die Standardeinstellung festgelegt ist, nachdem ein Hotfix oder eine Aktualisierung angewendet und der Clusterknoten neu gestartet wurde.

Mit der Umgebungsvariable TEMP wird festgelegt, welche Ordner im Dateisystem von Anwendungen verwendet werden sollen, die einen temporären Arbeitsbereich erfordern. TEMP wird i. d. R. von Anwendungen verwendet, z. B. von Exchange Server. Der Pfad für die einzelnen Variablen bezieht sich i. d. R. auf den Kontext der Anwendung. Der Microsoft Exchange-Informationsspeicherdienst verwendet den Ordner TEMP während verschiedener Vorgänge als temporären Speicher, beispielsweise bei der Nachrichtenkonvertierung und beim Verschieben von Postfächern.

So beheben Sie diese Warnung

  1. Melden Sie sich bei einem Knoten im Cluster mit dem Cluster-Dienstkonto an.

  2. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und wählen Sie Eigenschaften aus.

  3. Klicken Sie auf Erweitert.

  4. Klicken Sie auf Umgebungsvariablen.

  5. Wählen Sie im Bereich Benutzervariablen für <Kontoname> den Eintrag TEMP aus, und klicken Sie auf Bearbeiten.

  6. Geben Sie im Feld Variablenwert den Standardpfad für die Umgebungsvariable TEMP ein, und klicken Sie auf OK.

  7. Klicken Sie auf OK, um das Dialogfeld Umgebungsvariablen zu schließen und nochmals auf OK, um das Dialogfeld Systemeigenschaften zu schließen.

  8. Starten Sie den Knoten neu, um die Änderung zu übernehmen.

  9. Wiederholen Sie die Schritte 1 bis 8 für jeden Knoten im Cluster, der nicht die Standardeinstellung aufweist.


Ziehen Sie mehrere Replikate des Offlineadressbuchs in Betracht
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-08-14

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Exchange_PublicFolder ab, um die Anzahl der Einträge beim Schlüssel ReplicaList zu bestimmen. Die Anzahl der Einträge gibt die Anzahl der in jeder Verwaltungsgruppe vorhandenen Offlineadressbuch-Replikate wieder.

Exchange Server Analyzer fragt außerdem den Active Directory®-Verzeichnisdienst ab, um die Anzahl der Datenbankobjekte in öffentlichen Ordnern zu ermitteln, deren Attribut legacyExchangeDN gesetzt ist Die Anzahl der Objekte, bei denen dieses Attribut gesetzt ist, gibt die Anzahl der Informationsspeicher für Öffentliche Ordner innerhalb der Organisation wieder.

Wenn Exchange Server Analyzer feststellt, dass nur ein Replikat eines Offlineadressbuchs in einer Exchange-Organisation vorhanden ist, die über mehrere Informationsspeicher für Öffentliche Ordner verfügt, zeigt Exchange Server Analyzer eine Meldung mit einer optimalen Methode an.

Um eine bessere Verfügbarkeit und Leistung zu gewährleisten, sollten Sie in Erwägung ziehen, mehrere Replikate für jedes Offlineadressbuch bereitzustellen. Manchmal können mehrere Replikate des Offline-Adressbuchs die Leistung und Flexibilität erhöhen. In großen Exchange-Organisationen kann ein einzelnes Replikat eines Offline-Adressbuchs überlastet werden. In allen Exchange-Organisationen stellt ein einzelnes Replikat eines Offline-Adressbuchs eine einzelne Fehlerstelle dar.

Es wird empfohlen, mehrere Replikate zu verwenden, auch wenn dies dazu führt, dass zusätzlicher Replikationsverkehr über das Netzwerk übertragen wird. Es sollte minimal zwei Replikate jedes Offline-Adressbuchs geben.

So fügen Sie einer Exchange-Organisation Replikate eines Offlineadressbuchs hinzu

  1. Öffnen Sie den Exchange-System-Manager.

  2. Vergrößern Sie Ordner, klicken Sie mit der rechten Maustaste auf Öffentliche Ordner und wählen Sie Systemordner anzeigen. Hinweis Wenn der Knoten Ordner nicht sichtbar ist, erweitern Sie Administrative Gruppen, und erweitern Sie dann die administrative Gruppe, die die Systemordner enthält, die Sie anzeigen möchten. Klicken Sie dann mit der rechten Maustaste auf Öffentliche Ordner, und wählen Sie dann Systemordner anzeigen.

  3. Erweitern Sie den Container OFFLINEADRESSBUCH, klicken Sie dann mit der rechten Maustaste auf das Offlineadressbuch, dem Sie ein Replikat hinzufügen möchten, und wählen Sie aus dem Kontextmenü die Option Eigenschaften aus.

  4. Wählen Sie die Registerkarte Replikation, und klicken Sie dann auf Hinzufügen, um den Öffentlichen Informationsspeicher auszuwählen, zu dem das Replikat hinzugefügt werden soll. Klicken Sie zum Abschluss auf OK.

  5. Wiederholen Sie die Schritte 3 und 4 für alle Objekte, die dem Container des Offline-Adressbuchs untergeordnet sind, für das Sie ein Replikat wünschen. Durch diese Wiederholung wird sichergestellt, dass alle unterstützten Formate im Replikat enthalten sind. Dies bedeutet, dass Sie die untergeordneten Objekte OAB Version 2, OAB Version 3a und so weiter ausdrücklich Hinzufügen .

Weitere Informationen über die Steuerung und Konfiguration von Offline-Adressbüchern finden Sie in den folgenden Artikeln des TechCenters für Microsoft Exchange Server:

  • „Offline Address Book - Things to Consider" (http://go.microsoft.com/fwlink/?LinkId=57581)

  • „Working with Exchange Server 2003 Stores" (http://go.microsoft.com/fwlink/?LinkId=47595).

  • „Offline Address Book Best Practices Guide" (http://go.microsoft.com/fwlink/?LinkId=47583).

  • „OAB Version 4 in Exchange Server 2003 Service Pack 2" (http://go.microsoft.com/fwlink/?linkid=53097).

  • „How Outlook 2003 SP2 and Exchange Server 2003 SP2 OAB Version 4 Work Together" (http://go.microsoft.com/fwlink/?linkid=53099).


Verbindung zum Domänencontroller des Empfängeraktualisierungsdiensts
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-05-18

Microsoft® Microsoft Exchange Server Analyzer öffnet auf jedem Domänencontroller eine TCP-Socketverbindung mit Anschluss 389. Diese Verbindung wird durch die Verwendung eines benutzerdefinierten Objektprozessors hergestellt, der eine bestimmte Zeichenfolge zurückgibt, wenn die Verbindung erfolgreich ist.

Wenn 389 Available nicht in der an Exchange Server Analyzer zurückgegebenen Zeichenfolge enthalten ist, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass der Domänencontroller nicht auf einen Verbindungsversuch auf TCP-Anschluss 389 geantwortet hat. Der TCP-Anschluss ist der Standardanschluss für LDAP-Kommunikationen (Lightweight Directory Access Protocol). Wenn diese Warnung angezeigt wird, ist möglicherweise eine der folgenden Bedingungen erfüllt:

  • Es liegen Verbindungsprobleme zwischen Microsoft Exchange Server Analyzer und dem Domänencontroller vor.

  • Der Server ist inaktiv.

  • Der Server wurde außer Betrieb gesetzt.

Es gibt viele Gründe dafür, warum LDAP-Anforderungen möglicherweise nicht ordnungsgemäß von Domänencontrollern verarbeitet werden können, wenn sie von Microsoft Exchange Server Analyzer abgefragt werden.

So beheben Sie diese Warnmeldung

  1. Überprüfen Sie, ob das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird, berechtigt ist, den Domänencontroller abzufragen. Sie benötigen in der Domäne, in der der Domänencontroller ausgeführt wird, Berechtigungen auf Benutzerebene. Weitere Informationen zu den Berechtigungen, die zum Ausführen von Microsoft Exchange Server Analyzer erforderlich sind, finden Sie in der im Lieferumfang von Microsoft Exchange Server Analyzer enthaltenen Hilfedatei. Klicken Sie zum Öffnen der Exchange Server Analyzer-Hilfedatei in Exchange Server Analyzer im Hilfemenü auf die Option für die Hilfe zu Microsoft Exchange Server Analyzer.

  2. Vergewissern Sie sich, dass zwischen dem Computer, auf dem Exchange Server Analyzer ausgeführt wird, und dem Domänencontroller, der nicht reagiert hat, keine Firewalls oder Anschlussbeschränkungen vorhanden sind.

  3. Vergewissern Sie sich, dass der Domänencontroller mit dem Netzwerk verbunden ist und ordnungsgemäß funktioniert.

  4. Überprüfen Sie, dass der Server nicht außer Betrieb gesetzt wurde und nach wie vor als verfügbarer Domänencontroller für Exchange Server aufgeführt wird.

Weitere Informationen finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 319065, Informationen zum Arbeiten mit dem Exchange-Empfängeraktualisierungsdienst (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319065)

  • 816103, Informationen zur Vorgehensweise bei der Problembehandlung von Active Directory-Verbindungsproblemen mit "Portqry" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103)


Inhaltsaktualisierung verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-06-21

Weitere Informationen finden Sie auf der Seite Exchange Server 2007 Documentation Download.


Für diesen Informationsspeicher für Öffentliche Ordner ist die Inhaltsindizierung aktiviert, es sind jedoch keine Aktualisierungen geplant
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchCIAvailable für jeden Informationsspeicher für Öffentliche Ordner zu ermitteln. Der Wert dieses Attributs gibt an, ob die Inhaltsindizierung für den Informationsspeicher für Öffentliche Ordner aktiviert wurde. Der Wert True gibt an, dass ein Inhaltsindex für einen Informationsspeicher für Öffentliche Ordner vorhanden und die Exchange-System-Manager-Einstellung Dieser Index kann aktuell von Clients durchsucht werden aktiviert ist. Der Wert False gibt an, dass ein Inhaltsindex für einen Informationsspeicher für Öffentliche Ordner vorhanden ist, die Exchange-System-Manager-Einstellung Dieser Index kann aktuell von Clients durchsucht werden ist jedoch nicht aktiviert. Der Wert <Not Set> gibt an, dass kein Inhaltsindex für den Informationsspeicher für Öffentliche Ordner vorhanden ist.

Exchange Server Analyzer fragt auch Active Directory ab, um für jeden Informationsspeicher für Öffentliche Ordner den Wert des Attributs msExchCIRebuildSchedule zu ermitteln. Der Wert dieses Attributs gibt die Einstellungen für den Wiederherstellungszeitplan für den Inhaltsindex an. Dieses Attribut wird als Oktettzeichenfolge mit 82 Paaren von Hexadezimalwerten gespeichert.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs msExchCIAvailable auf True festgelegt ist, der Oktett-Zeichenfolgenwert für das Attribut msExchCIRebuildSchedule jedoch mit Nie ausführen übersetzt wird, wird eine Warnung angezeigt.

Die empfohlene optimale Methode für das Festlegen des Aktualisierungsintervalls besteht darin, die mindestens tägliche Ausführung inkrementeller Aktualisierungen zu planen. Sie können die Aktualisierungen auch für eine häufigere als die tägliche Ausführung planen, da der Index nur den Aktualisierungszustand aufweist wie zu dem Zeitpunkt, zu dem er zuletzt aufgefüllt wurde. Nicht regelmäßig aktualisierte Indizes können zu ungenauen und veralteten Ergebnissen führen.

Berücksichtigen Sie auch die Zeit, die für ein inkrementelles Auffüllen benötigt wird. In einem typischen Zeitplan sind inkrementelle Aktualisierungen auf den Anfang jeder Stunde festgelegt. Wenn die Aktualisierung jedoch länger als eine Stunde dauert, beginnt die nächste inkrementelle Auffüllung zu Beginn der darauffolgenden Stunde.

Im Allgemeinen können Sie bei einer Größe des Informationsspeichers für Öffentliche Ordner von bis zu 6 Gigabyte (GB) stündliche inkrementelle Aktualisierungen ausführen. Wenn der Informationsspeicher größer als 6 GB oder der Speicher des Servers stark ausgelastet ist, empfiehlt sich eine weniger häufige Aktualisierung des Index.

So legen Sie das Volltextindizierungs-Aktualisierungsintervall für einen Informationsspeicher für Öffentliche Ordner fest

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Administrative Gruppen und Ihre administrative Gruppe, erweitern Sie Server und Ihren Server, erweitern Sie Ihre Speichergruppe, klicken Sie mit der rechten Maustaste auf Ihren Informationsspeicher für Öffentliche Ordner, und klicken Sie dann auf Eigenschaften. Wenn der Knoten Administrative Gruppen im Exchange-System-Manager nicht angezeigt wird, erweitern Sie Server, klicken Sie mit der rechten Maustaste auf Ihren Server, und klicken Sie dann auf Eigenschaften.

  3. Wählen Sie auf der Registerkarte Volltextindizierung eine andere Option als Nie ausführen aus.

  4. Wenn Sie Benutzerdefinierten Zeitplan verwenden auswählen, klicken Sie auf Anpassen, legen Sie einen eigenen Zeitplan fest, und klicken Sie dann auf OK.

  5. Klicken Sie auf Übernehmen.

Weitere Informationen zur Volltextindizierung für Exchange Server finden Sie unter Best Practices for Deploying Full-Text Indexing unter http://go.microsoft.com/fwlink/?linkid=5223.


Für diesen Postfachspeicher ist die Inhaltsindizierung aktiviert, es sind jedoch keine Aktualisierungen geplant.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchCIAvailable für jeden Postfachspeicher zu ermitteln. Der Wert dieses Attributs gibt an, ob die Inhaltsindizierung für den Postfachspeicher aktiviert wurde. Der Wert TRUE gibt an, dass ein Inhaltsindex für einen Postfachspeicher vorhanden und die Exchange-System-Manager-Einstellung Dieser Index kann aktuell von Clients durchsucht werden aktiviert ist. Der Wert FALSE gibt an, dass ein Inhaltsindex für einen Postfachspeicher vorhanden, aber die Exchange-System-Manager-Einstellung Dieser Index kann aktuell von Clients durchsucht werden deaktiviert ist. Ein Wert von <Nicht festgelegt> gibt an, dass für den Postfachspeicher kein Inhaltsindex vorhanden ist.

Exchange Server Analyzer fragt auch Active Directory ab, um für jeden Postfachspeicher den Wert des Attributs msExchCIRebuildSchedule zu ermitteln. Der Wert dieses Attributs gibt die Einstellungen für den Wiederherstellungszeitplan für den Inhaltsindex an. Dieses Attribut wird als Oktettzeichenfolge mit 82 Paaren von Hexadezimalwerten gespeichert.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs msExchCIAvailable auf TRUE festgelegt ist, der Oktett-Zeichenfolgenwert für das Attribut msExchCIRebuildSchedule jedoch mit Nie ausführen übersetzt wird, wird eine Warnung angezeigt.

Die empfohlene optimale Methode für das Festlegen des Aktualisierungsintervalls besteht darin, die mindestens tägliche Ausführung inkrementeller Aktualisierungen zu planen. Sie können die Aktualisierungen auch für eine häufigere als die tägliche Ausführung planen, da der Index nur den Aktualisierungszustand aufweist wie zu dem Zeitpunkt, zu dem er zuletzt aufgefüllt wurde. Nicht regelmäßig aktualisierte Indizes können zu ungenauen und veralteten Ergebnissen führen.

Berücksichtigen Sie auch die Zeit, die für ein inkrementelles Auffüllen benötigt wird. In einem typischen Zeitplan sind inkrementelle Aktualisierungen auf den Anfang jeder Stunde festgelegt. Wenn die Aktualisierung jedoch länger als eine Stunde dauert, beginnt die nächste inkrementelle Auffüllung zu Beginn der darauffolgenden Stunde.

Im Allgemeinen können Sie bei einer Größe des Postfachspeichers von bis zu 6 GB stündliche inkrementelle Aktualisierungen ausführen. Wenn der Informationsspeicher größer als 6 GB oder der Speicher des Servers stark ausgelastet ist, empfiehlt sich eine weniger häufige Aktualisierung des Index.

So legen Sie das Volltextindizierungs-Aktualisierungsintervall für einen bestimmten Postfachspeicher fest

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Administrative Gruppen und Ihre administrative Gruppe, erweitern Sie Server und Ihren Server, erweitern Sie Ihre Speichergruppe, klicken Sie mit der rechten Maustaste auf Ihren Postfachspeicher, und klicken Sie dann auf Eigenschaften. Wenn der Knoten Administrative Gruppen im Exchange-System-Manager nicht angezeigt wird, erweitern Sie Server, klicken Sie mit der rechten Maustaste auf Ihren Server, und klicken Sie dann auf Eigenschaften.

  3. Wählen Sie auf der Registerkarte Volltextindizierung eine andere Option als Nie ausführen aus.

  4. Wenn Sie Benutzerdefinierten Zeitplan verwenden auswählen, klicken Sie auf Anpassen, legen Sie einen eigenen Zeitplan fest, und klicken Sie dann auf OK.

  5. Klicken Sie auf Übernehmen.

Weitere Informationen zum Konfigurieren und zum Behandeln von Fehlern der Volltextindizierung in Exchange finden Sie in den Microsoft Knowledge Base-Artikeln 822932, „HOW TO: Configure Full-Text Indexing on Mailbox Stores in Exchange 2003" (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=822932) und 319436, „How to configure full-text indexing on mailbox stores in Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319436).

Weitere Informationen zur Volltextindizierung für Exchange Server finden Sie unter Best Practices for Deploying Full-Text Indexing unter http://go.microsoft.com/fwlink/?linkid=5223.


CQPCIDRV.SYS: Eine Treiberaktualisierung ist verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-08-14

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Version von Microsoft Windows® zu ermitteln, die auf dem Server mit Exchange Server ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Der Wert 4.0 für CurrentVersion gibt an, dass auf dem Exchange-Server Microsoft Windows NT® Server 4.0 ausgeführt wird. Der Wert 5.0 gibt an, dass Windows 2000 Server auf dem Exchange-Server ausgeführt wird. Der Wert 5.2 gibt an, dass auf dem Computer mit Exchange Server Windows Server™ 2003 ausgeführt wird.

Exchange Server Analyzer untersucht außerdem die WMI-Klasse (Windows Management Instrumentation) Win32_Processor, um den Wert für den Schlüssel DataWidth zu ermitteln.

Der Wert 32 des Schlüssels DataWidth gibt an, dass auf dem Server eine 32-Bit-Version des Betriebssystems Windows ausgeführt wird. Der Wert 64 des Schlüssels DataWidth gibt an, dass auf dem Server eine 64-Bit-Version des Betriebssystems Windows ausgeführt wird.

Abschließend fragt Exchange Server Analyzer die WMI-Klasse CIM_Datafile ab, um den Wert des Schlüssels Version für die Datei CpqCiDrv.sys zu ermitteln.

Exchange Server Analyzer zeigt einen Fehler an, wenn folgende Bedingungen zutreffen:

  • Auf dem Exchange-Server wird Windows Server 2003 ausgeführt.

  • Auf dem Exchange-Server wird eine 64-Bit-Version des Betriebssystems Windows ausgeführt.

  • Die Version des HP Integrated Lights-Out Management Interface-Treibers, CPQCIDRV.sys ist eine älter als die Version 1.8.

Dieser Fehler gibt an, dass auf dem Server installierte Version von CPQCIDRV.sys möglicherweise Probleme bei der Kernelspeicherreservierung verursacht.

Um dieses Problem zu beheben, befolgen Sie die Anweisungen im folgenden Dokument des Herstellers: c00688313 (http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c00688313).

Hinweis:
Die Informationen zur Website des Drittanbieters in diesem Thema werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.


CrashOnAuditFail ist aktiv.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Parameter CrashOnAuditFail festgelegt wurde:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\LSA\CrashOnAuditFail

Wenn Exchange Server Analyzer feststellt, dass der Wert für CrashOnAuditFail gleich 2 ist, wird ein Fehler angezeigt.

Der Registrierungsschlüssel CrashonAuditFail dient dazu, einen Server so zu konfigurieren, dass den Endbenutzern nach Erreichen des konfigurierten Grenzwerts für die Größe der Sicherheitsprotokolle kein Zugriff auf den Computer gewährt wird. Durch das Sperren des Zugriffs auf den Computer wird sichergestellt, dass keine Überwachungsinformationen verloren gehen, die in der Regel protokolliert werden.

Wenn der Registrierungsschlüssel CrashonAuditFail aktiviert ist, beträgt der festgelegte Wert 1. Wenn jedoch der Grenzwert für die Größe des Sicherheitsprotokolls erreicht ist, wird der Registrierungsschlüssel vom Server auf den Wert 2 festgelegt, wodurch wiederum die Verarbeitung auf dem Server beendet wird. Manchmal verursacht dieser Vorgang einen vollständigen Ausfall oder den Fehler STOP 0xC0000244, der auch als Abbruchfehler bezeichnet wird. Zumindest aber können die Benutzer nicht auf die Serverressourcen zugreifen, und die Leistung ist stark reduziert. Darüber hinaus können nur Benutzer mit Administratorberechtigungen auf den Computer zugreifen, wenn sich der Server in diesem Zustand befindet.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diesen Fehler

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Control\LSA.

  3. Löschen Sie den Wert CrashOnAuditFail (Sie müssen den gesamten Wert löschen, nicht nur den Datenwert).

  4. Kopieren Sie die Sicherheitsereignisprotokolle an einen separaten Speicherort. In der Standardeinstellung werden die Sicherheitsereignisprotokolle (SecEvent.Evt) unter %Systemstamm%\System32\Config gespeichert, wobei es sich bei %Systemstamm% um den Pfad zum Installationsverzeichnis des Microsoft Windows®-Betriebssystems handelt.

  5. Öffnen Sie die Ereignisanzeige, klicken Sie mit der rechten Maustaste auf Sicherheit, und klicken Sie dann auf Eigenschaften.

  6. Klicken Sie auf der Seite Eigenschaften von Sicherheit auf Protokoll löschen. Wenn Sie zum Speichern des Protokolls aufgefordert werden, klicken Sie auf Ja, und geben Sie dann einen Speicherort für die Protokolldatei an.

    Hinweis Auf der Seite Eigenschaften von Sicherheit können Sie auch die Größe des Protokolls erhöhen, indem Sie das Feld Maximale Protokollgröße bearbeiten, und anschließend auf Übernehmen klicken.

  7. Starten Sie den Server erneut.

  8. Stellen Sie sicher, dass die Benutzer auf die Serverressourcen zugreifen können, wenn sie sich bei einem Exchange-Postfach anmelden.

  9. Erstellen Sie den Registrierungsschlüssel CrashonAuditFail neu, und legen Sie den Datenwert auf 1 fest.

  10. Starten Sie den Server neu, damit die CrashonAuditFail-Einstellungen wirksam werden.

  11. Löschen und speichern Sie die Sicherheitsprotokolle des Servers regelmäßig, damit die maximale Protokollgröße nicht überschritten wird. Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 312571 „The event log stops logging events before reaching the maximum log size" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=312571.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unterhttp://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zur Wiederherstellung nach CrashOnAuditFail-Fehlern finden Sie in den folgenden Knowledge Base-Artikeln:

  • 232564, „STOP 0xC0000244 when security log full" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232564)

  • 829082, „You receive a "Stop error 0xC0000244 {Audit Failed}" error message when the crashonauditfail registry key is set to 1 on a Windows Server 2003-based computer" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=829082)


Benutzerdefinierte Liste der Verweise auf Öffentliche Ordner
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-09

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob das Attribut msExchFolderAffinityCustom Namen von Exchange-Servern enthält. Wenn Exchange Server Analyzer erkennt, dass das Attribut msExchFolderAffinityCustom Servernamen enthält, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In der Standardeinstellung bestimmt Exchange Server 2003 mithilfe von Routinggruppen Verweise auf Öffentliche Ordner.

Exchange Server 2007 verwendet standardmäßig die standortübergreifenden Kosten des Verzeichnisdiensts Active Directory, um das Routing für Verweise auf Öffentliche Ordner zu bestimmen.

Wenn das Attribut msExchFolderAffinityCustom Servernamen enthält, wurden auf dem Exchange-Server benutzerdefinierte Verweise konfiguriert. Das Attribut msExchFolderAffinityCustom ist ein Attribut für einzelne Server.

Als optimale Methode wird empfohlen, dass Sie für Verweise auf Öffentliche Ordner das Standardverhalten befolgen. Sie müssen jedoch u. U. eine benutzerdefinierte Verweisliste erstellen. Die Meldung, dass die Konfiguration nicht dem Standard entspricht, dient nur zu Informationszwecken. Es ist keine Aktion erforderlich.

So kehren Sie in Exchange Server 2003 zur Standardkonfiguration zurück

  1. Öffnen Sie den Exchange-System-Manager.

  2. Navigieren Sie zu dem Serverobjekt, in dem benutzerdefinierte Verweise auf Öffentliche Ordner konfiguriert werden. Der Name des Exchange-Servers, auf dem Verweise auf Öffentliche Ordner konfiguriert werden, wird in der Nachricht von Exchange Server Analyzer angegeben.

  3. Klicken Sie mit der rechten Maustaste auf Servername, und klicken Sie dann auf Eigenschaften.

  4. Wählen Sie auf der Registerkarte Verweise auf Öffentliche Ordner im Dropdown-Feld Optionen für Verweise auf Öffentliche Ordner auf die Option Routinggruppen verwenden.

  5. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.
So kehren Sie in Exchange Server 2007 zur Standardkonfiguration zurück

  1. Der folgende Code ist ein Beispiel des Exchange-Verwaltungsshellbefehls Set-PublicFolderDatabase, mit dem die Verwendung von PublicFolderRefferalServerList für die Öffentliche Ordner-Datenbank MyServer\First Storage Group\Public Folder Database deaktiviert wird.
Code kopieren
Set-PublicFolderDatabase -Identity "MyServer\First Storage Group\Public Folder Database" -UseCustomReferralServerList $false

Der Parameter UseCustomReferralServerList gibt an, ob die vom Parameter PublicFolderReferralServerList angegebenen Serverkosten verwendet werden sollen. Wenn der Wert $true festgelegt ist, verwendet der Server die Kosten des Parameters PublicFolderReferralServerList, um auf Öffentliche Ordner zu verweisen. Wenn der Wert $false festgelegt ist, verwendet der Server die standortübergreifenden Active Directory-Kosten, um auf Öffentliche Ordner zu verweisen.

Hinweis:
Wenn für diesen Parameter der Wert $false festgelegt ist, wird auch der Parameter PublicFolderReferralServerList gelöscht.

Weitere Informationen zum Exchange-Verwaltungsshellbefehl Set-PublicFolderDatabase finden Sie unter "Set-PublicFolderDatabase" in der technischen Referenz zu Exchange Server 2007 (http://www.microsoft.com/technet/prodtechnol/exchange/E2k7/DE/Help/ExchHelp/34ec3385-778a-43b8-9bf2-707fbf60ac23.mspx?mfr=true).

Weitere Informationen zur Replikation Öffentlicher Ordner finden Sie in Best Practices for Exchange Server Public Folders (http://go.microsoft.com/fwlink/?LinkId=46437).


Das Objekt zur Überwachung der Datenbankleistung ist nicht vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Log Record Stalls/sec-Leistungsindikator des Database-Leistungsobjekts. Wenn gültige Daten nicht vom Indikator zurückgegeben werden, zeigt Microsoft Exchange Server Analyzer eine Basislinienmeldung an.

Wenn keine gültigen Daten vom Erfassungsmodul für Leistungsdaten zurückgegeben werden, liegt mindestens eine der folgenden Bedingungen vor:

  • Das Database-Leistungsobjekt ist deaktiviert.

  • Das Database-Leistungsüberwachungsobjekt wurde nicht gefunden, oder es ist beschädigt.

  • Microsoft Exchange Server Analyzer verfügt nicht über entsprechende Berechtigungen zum Zugreifen auf die Leistungsobjekte.

Die ersten beiden Bedingungen treten auf, wenn die Registrierung von bestimmten erweiterbaren Indikatoren beschädigt wird oder wenn die Registrierung von auf Microsoft WMI (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) basierten Programmen geändert wird.

Im folgenden Verfahren wird die Behebung der ersten beiden Bedingungen erläutert. Überprüfen Sie vor dem Ausführen des Verfahrens, ob Microsoft Exchange Server Analyzer über entsprechende Berechtigungen verfügt. Weitere Informationen zu den Berechtigungen, die zum Ausführen von Microsoft Exchange Server Analyzer erforderlich sind, finden Sie in der im Lieferumfang von Microsoft Exchange Server Analyzer enthaltenen Hilfedokumentation. Wenn Sie Hilfe erhalten möchten, öffnen Sie Exchange Server Analyzer, und drücken Sie F1.

So beheben Sie diesen Fehler

  1. Überprüfen Sie, ob das Database-Leistungsobjekt aktiviert ist.

    1. Downloaden und installieren Sie das Tool „Extensible Performance Counter List" (Exctrlst.exe). Sie können Exctrlst.exe unter „Exctrlst.exe: Extensible Performance Counter List" (http://go.microsoft.com/fwlink/?LinkId=34436) downloaden.

    2. Öffnen Sie die Datei Exctrlst.exe, klicken Sie auf Sortierreihenfolge und anschließend auf Dienst.

    3. Suchen Sie den Dienst, über den das Leistungsobjekt eine Meldung ausgeben soll, und überprüfen Sie, ob das Kontrollkästchen Leistungsindikatoren aktiviert aktiviert ist.

      Wenn das Kontrollkästchen Leistungsindikatoren aktiviert nicht aktiviert ist, aktivieren Sie es, und starten Sie den Dienst neu, der dem Leistungsindikator zugeordnet ist, um zu überprüfen, ob die Leistungsindikatoren betriebsbereit sind. Wenn die Leistungsindikatoren nicht betriebsbereit sind oder wenn das Kontrollkästchen Leistungsindikatoren aktiviert bereits aktiviert wurde, fahren Sie mit Schritt 2 fort.

  2. Erstellen Sie die nicht vorhandenen oder beschädigten Leistungsindikatoren wie im Microsoft Knowledge Base-Artikel 300965 „Manuelles Neuerstellen der Werte der Leistungsindikatorenbibliothek" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) beschrieben neu.

  3. Wenn Sie das Problem anhand dieses Knowledge Base-Artikels nicht beheben können, müssen Sie Exchange Server im Modus Reparieren erneut installieren und die aktuellsten Exchange Server-Service Packs installieren.


Datei „DAVEX.DLL" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Beim Ausführen von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Product Key ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


DHCP-Clientdienst wird nicht ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) Win32_Service ab, um den Wert des Schlüssels Started für den DHCP-Dienst (DHCP - Dynamic Host Configuration-Protokoll) zu bestimmen. Wenn Exchange Server Analyzer feststellt, dass der Wert des Schlüssels Started für den DHCP-Clientdienst auf einem Exchange-Server auf False festgelegt wurde, zeigt Exchange Server Analyzer eine Warnung an.

Diese Warnung gibt an, dass der DHCP-Clientdienst nicht ausgeführt wird. Der DHCP-Clientdienst führt dynamische DNS-Updates (DNS - Domain Name System) durch. Wenn der DHCP-Clientdienst nicht ausgeführt wird, treten bei den dynamischen Updates Fehler auf. Wenn dieser Dienst auf einem Exchange-Server nicht ausgeführt wird, sind Probleme bei der Nachrichtenübermittlung die am häufigsten auftretenden Probleme.

Um dieses Problem zu beheben, legen Sie fest, dass der DHCP-Clientdienst automatisch gestartet wird, und starten Sie dann den Dienst.

Hinweis:
Der DHCP-Clientdienst muss auch ausgeführt werden, wenn der Server für die Verwendung statischer IP-Adressen anstelle von DHCP konfiguriert ist.
So aktivieren Sie den DHCP-Clientdienst

  1. Öffnen Sie das Snap-In Dienste.

  2. Klicken Sie mit der rechten Maustaste im Detailbereich auf DHCP Clientdienst, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Allgemein auf Starttyp, und wählen Sie Automatisch aus.

  4. Klicken Sie auf Starten, und klicken Sie dann auf OK.

Weitere Informationen zum DHCP-Clientdienst finden Sie im Microsoft Knowledge Base-Artikel 264539, „Dynamic DNS updates do not work if the DHCP client service stops", unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=264539.

Weitere Informationen zum dynamischen DNS-Updateprotokoll finden Sie im Microsoft Knowledge Base-Artikel 816592, „Konfigurieren der dynamischen DNS-Updates in Windows Server 2003", unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592.


Dr. Watson ist nicht aktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den Wert für den folgenden Registrierungsschlüssel, um zu bestimmen, ob Dr. Watson im Betriebssystem Microsoft Windows® als Standarddebugger für Anwendungen konfiguriert ist:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger

Wenn Exchange Server Analyzer feststellt, dass der Wert für Debugger nicht mit drwtsn32 beginnt, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Durch diese Meldung wird angegeben, dass Dr. Watson nicht aktiviert ist. Seit Windows NT® ist der Anwendungsmodus-Debugger Dr. Watson in Windows integriert. Wenn eine Anwendung abstürzt, kann der Fehler von Dr. Watson abgefangen werden. Dieser Debugger protokolliert eine Vielzahl von Informationen, beispielsweise Informationen zur Plattform, eine Liste der ausgeführten Prozesse, die Identifizierung des fehlerhaften Prozesses, ein Speicherabbild für den fehlerhaften Prozess, einen oder mehrere Aufrufstapel und einen direkten Zeiger auf den Fehler. Die meisten der gesammelten Informationen sind allgemeine Debuggingangaben für den Entwickler des fehlerhaften Prozesses.

Die empfohlene optimale Methode besteht in der Ausführung von Windows mit einem aktivierten Anwendungsmodus-Debugger. Wenn Dr. Watson nicht aktiviert ist und Sie einen alternativen Anwendungsdebugger verwenden, empfiehlt es sich, Dr. Watson wie folgt zu aktivieren.

So aktivieren Sie Dr. Watson

  1. Öffnen Sie ein Eingabeaufforderungsfenster.

  2. Geben Sie an der Eingabeaufforderung den Befehl drwtsn32 -i ein.

Weitere Informationen über das Aktivieren bzw. Deaktivieren von Dr. Watson finden Sie im Microsoft Knowledge Base-Artikel 188296, „Deaktivieren von Dr. Watson für Windows NT" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=188296).


Namenskonflikt bei DSA-Computer
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft®Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Einstellung für den Registrierungswert DSA Computer zu ermitteln:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer sendet auch eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert des Attributs name für jedes Exchange Server-Objekt zu ermitteln.

Exchange Server Analyzer fragt schließlich die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_Service ab, um den Wert des Schlüssels Started für den Clusterdienst (ClusSvc) zu bestimmen. Der Wert True gibt an, dass der Clusterdienst gestartet ist, und der Wert False gibt an, dass der Clusterdienst nicht ausgeführt wird.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel DSA Computer für keinen ExchangeServer-Computer, der nicht in einem Windows-Servercluster ausgeführt wird, mit dem Wert des Attributs name des Serverobjekts in Active Directory übereinstimmt, wird ein Fehler angezeigt.

Um diesen Fehler zu beheben, müssen Sie den Registrierungsschlüssel DSA Computer so ändern, dass er mit dem Wert des Attributs name in Active Directory übereinstimmt.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Bearbeiten der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diesen Fehler

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Doppelklicken Sie im rechten Bereich auf DSA Computer, geben Sie den richtigen Namen für diesen Computer ein, und klicken Sie dann auf OK.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den Exchange Server-Computer neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Datei „DSACCESS.DLL" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Product Key ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Der DSAccess-Konfigurationscache ist voll.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-05-24

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_PerfRawData_MSExchangeDSAccess_MSExchangeDSAccessCaches ab, um den aktuellen Wert für TotalEntriesMemoryConfigurationData zu bestimmen. If the Exchange Server Analyzer Tool finds that the value for TotalEntriesMemoryConfigurationData equals the total size of the Directory Service Access (DSAccess) configuration cache (MaxMemoryConfig), a warning is displayed.

Bei DSAccess handelt es sich um eine interne Komponente von Exchange 2000 Server und Exchange Server 2003, die den Zugriff der Exchange-Komponenten auf den Active Directory®-Verzeichnisdienst steuert. Die primäre Funktion von DSAccess stellt das Verwalten von Informationen zu verschiedenen verzeichnisbezogenen Ereignissen und Vorgängen dar. Zum Beispiel ermittelt DSAccess die Active Directory-Topologie und stellt fest, ob Domänencontroller und globale Katalogserver verfügbar sind und auf Abfragen reagieren. Außerdem werden alle Verzeichnisabfragen von internen Exchange-Komponenten, z. B. vom Microsoft Exchange-Speicher, über DSAccess weitergeleitet. Diese Abfragen betreffen u. a. die Empfängeradressauflösung sowie die Konfigurationseinstellungssuche. Zu den Aufgaben von DSAccess gehört die Verwaltung eines Caches im Arbeitsspeicher, in dem ein Teil der Ergebnisse dieser Abfragen vorgehalten werden, sodass diese bei einer erneuten Anforderung derselben Informationen aus dem DSAccess-Cache abgerufen werden können, anstatt eine erneute LDAP-Abfrage (Lightweight Directory Access Protocol) an Active Directory zu stellen.

Da die Standardeinstellung für die maximale Größe des DSAccess-Konfigurationscache von 25 MB bei Exchange 2000 Server auf 5 MB bei Exchange Server 2003 verringert wurde, kann diese Warnmeldung bei beiden Exchange-Versionen auftreten. Unabhängig davon, welche Version von Exchange diese Warnmeldung generiert, sollte dieses Problem so schnell wie möglich behoben werden.

Der Wert MaxMemoryConfig wird häufig in Verbindung mit dem Wert MaxMemoryUser verwendet, der die maximale Speichergröße steuert, die für Benutzerdatenobjekte im DSAccess-Cache zur Verfügung steht. Wenn Sie den Wert für MaxMemoryConfig wie unten beschrieben bearbeiten bzw. entfernen, sollten Sie auch den Wert für MaxMemoryUser bearbeiten bzw. entfernen (weitere Informationen dazu finden Sie unter Der Wert „DSAccess user cache" weicht vom Standardwert ab).

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Erhöhen Sie den Wert für MaxMemoryConfig. Wenn der Schlüssel Instance0 oder der DWORD-Wert MaxMemoryConfig nicht vorhanden ist, können Sie ihn manuell erstellen. Der Datenwert für den Registrierungsschlüssel MaxMemoryConfig wird in KB angegeben, d. h., ein Dezimalwert von 15.000 entspricht 15 MB. Wenn der Wert vorhanden ist, erhöhen Sie ihn um 10 Prozent. Andernfalls sollte ein Ausgangswert von 10 MB verwendet werden.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Microsoft Exchange-Systemaufsichtsdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung enthält.


Der Wert „DSAccess configuration cache" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-17

Microsoft® Exchange Server Analyzer liest die folgenden Registrierungseinträge, um zu bestimmen, ob die Größe des DSAccess-Konfigurationsobjektscaches vom Standardwert abweicht:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0\MaxMemoryConfig

Wenn Exchange Server Analyzer feststellt, dass der Wert MaxMemoryConfig vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

MaxMemoryConfig stellt einen Registrierungsparameter für Exchange 2000 Server dar, der in Exchange Server 2003 nicht mehr benötigt wird. MaxMemoryConfig steuert den maximalen Speicher, der von den Konfigurationsdatenobjekten im DSAccess-Konfigurationscache beansprucht werden kann. Bei DSAccess handelt es sich um eine interne Komponente in Exchange 2000 Server und Exchange Server 2003, mit deren Hilfe der Zugriff aller Exchange-Komponenten auf den Active Directory®-Verzeichnisdienst gesteuert werden kann. Die primäre Funktion von DSAccess stellt das Verwalten von Informationen zu verschiedenen verzeichnisbezogenen Ereignissen und Vorgängen dar. Zum Beispiel ermittelt DSAccess die Active Directory-Topologie und stellt fest, ob Domänencontroller und globale Katalogserver verfügbar sind und auf Abfragen reagieren. Außerdem werden alle Verzeichnisabfragen von internen Exchange-Komponenten, z. B. vom Microsoft Exchange-Speicher, über DSAccess weitergeleitet. Diese Abfragen betreffen u. a. die Empfängeradressauflösung sowie die Konfigurationseinstellungssuche. Zu den Aufgaben von DSAccess gehört die Verwaltung eines Caches im Arbeitsspeicher, in dem ein Teil der Ergebnisse dieser Abfragen vorgehalten werden, sodass diese bei einer erneuten Anforderung derselben Informationen aus dem DSAccess-Cache abgerufen werden können, anstatt eine erneute LDAP-Abfrage (Lightweight Directory Access Protocol) an Active Directory zu stellen.

In Exchange 2000 Server wurde für den Konfigurationscache anfangs eine Größe von 25 MB festgelegt. Auf den meisten Exchange-Servern war diese Einstellung viel größer als benötigt. Die Einstellung MaxMemoryConfig wurde verwendet, um einen Teil des vom DSAccess-Konfigurationscache verwendeten Speichers freizugeben und neu zuzuweisen. Er wurde in der Regel für 5 MB konfiguriert. Basierend auf internen Tests und Kunden-Feedback hat Microsoft 3 MB als optimale Größe festgelegt, die Exchange Server 2003 als Out-of-the-box-Einstellung verwendet. Beim Aktualisieren von Exchange 2000 Server auf Exchange Server 2003 werden alle manuellen Einstellungen beibehalten. Wenn der Exchange-Server von Exchange 2000 Server auf Exchange Server 2003 aktualisiert wurde, stellen Sie sicher, dass der Wert für MaxMemoryConfig nicht größer ist als 5 MB.

Der Wert MaxMemoryConfig wird häufig in Verbindung mit dem Wert MaxMemoryUser verwendet, der die maximale Speichergröße steuert, die für Benutzerdatenobjekte im DSAccess-Cache zur Verfügung steht. Wenn Sie den Wert für MaxMemoryConfig wie im folgenden Verfahren beschrieben bearbeiten bzw. entfernen, sollten Sie auch den Wert für MaxMemoryUser bearbeiten bzw. entfernen. Weitere Informationen hierzu finden Sie unter Der Wert „DSAccess user cache" weicht vom Standardwert ab.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So verwenden Sie den Registrierungswert „MaxMemoryConfig"

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Ermitteln Sie den Wert für MaxMemoryConfig, oder bearbeiten Sie diesen.
Hinweis:
Der Wert für diesen Registrierungseintrag wird in Kilobyte (KB) angegeben. Wenn der Wert auf 3000 oder weniger festgelegt ist, löschen Sie MaxMemoryConfig, und starten Sie den Dienst Microsoft Exchange-Systemaufsicht neu, um die Exchange Server 2003-Einstellung als Standard festzulegen.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zu DSAccess finden Sie im Microsoft Knowledge Base-Artikel 250570, „Directory Service Server Detection and DSAccess Usage" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


Der DSAccess-Registrierungsparameter „DisableNetLogonCheck" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob DSAccess (Directory Service Access - Verzeichnisdienstzugriff) für die Verwendung eines von der Standardeinstellung abweichenden Pingprotokolls konfiguriert wurde.

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\DisableNetLogonCheck

Wenn Microsoft Exchange Server Analyzer feststellt, dass DisableNetLogonCheck vorhanden und mit einem Wert größer als 0 konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Nachdem DSAccess die Active Directory®-Verzeichnisdiensttopologie erkannt hat, wird bestimmt, ob die ermittelten Domänencontroller und globalen Katalogserver für die Verwendung geeignet sind. Während der anfänglichen Ermittlung und des weiteren Ermittlungsprozesses bestimmt DSAccess anhand einer Reihe von Tests, ob der Server geeignet ist. Bei einem Test wird ein Remoteprozeduraufruf (RPC) an den Verzeichnisserver gesendet, um dessen allgemeine Kompatibilität zu überprüfen. In einem Szenario mit einem Umkreisnetzwerk, in dem Datenverkehr über RPC normalerweise nicht zulässig ist, schlägt die RPC-Anforderung von DSAccess fehl. Von DSAccess werden jedoch weiterhin RPCs ausgegeben, bis ein Fehler angezeigt wird. Dieser Vorgang nimmt möglicherweise einen längeren Zeitraum in Anspruch. Solche wiederholten Überprüfungen können die Leistung der Computer beeinträchtigen, auf denen Exchange Server ausgeführt wird. Daher fügen Administratoren für Exchange-Server, die sich in einem Umkreisnetzwerk befinden, häufig den Registrierungsschlüssel DisableNetLogonCheck hinzu und konfigurieren ihn mit dem Wert 1.

Wenn der Exchange-Server, der die Meldung über die von der Standardeinstellung abweichende Konfiguration generiert hat, zu einem Umkreisnetzwerk gehört, in dem RPC deaktiviert ist, oder wenn DSAccess diesen Eignungstest nicht ausführen soll, legen Sie den Schlüssel DisableNetLogonCheck auf 1 fest. Andernfalls sollten Sie den Schlüssel DisableNetLogonCheck löschen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So verwenden Sie den Schlüssel „DisableNetLogonCheck"

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Doppelklicken Sie auf den Schlüssel DisableNetLogonCheck, und legen Sie den DWORD-Wert auf 1. fest.

  4. Schließen Sie den Registrierungs-Editor. Es müssen keinerlei Neustarts von Diensten vorgenommen werden, damit die Änderungen wirksam werden.

So löschen Sie den Schlüssel „DisableNetLogonCheck"

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Löschen Sie den Wert DisableNetLogonCheck.

  4. Schließen Sie den Registrierungs-Editor. Es müssen keinerlei Neustarts von Diensten vorgenommen werden, damit die Änderungen wirksam werden.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Registrierungsschlüssel DisableNetLogonCheck finden Sie im Knowledge Base-Artikel 320228 „XGEN: The DisableNetLogonCheck Registry Value and How to Use It" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320228).


DSAccess ist hartcodiert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Exchange_DSAccessDC im Namespace ROOT\MicrosoftExchangeV2 ab, um den Wert für den Schlüssel ConfigurationType zu bestimmen. Beträgt der Wert für den Schlüssel 0, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Die Eigenschaft ConfigurationType gibt an, ob die Instanz einen automatisch erkannten oder manuell angegebenen Domänencontroller beschreibt. Die DSAccess-Komponente (Directory Service Access) in Exchange Server erkennt die Active Directory®-Verzeichnisdiensttopologie und findet Domänencontroller und globale Katalogserver automatisch. Auf Computern, auf denen Exchange Server 2000 Service Pack 2 oder höher oder Exchange Server 2003 ausgeführt wird, kann in Exchange-System-Manager eine hartcodierte Liste mit Active Directory-Servern eingeben, die von DSAccess verwendet werden.

Entfernen Sie die Liste der Server, und stellen Sie die Standardeinstellung für die automatische Suche wieder her, es sei denn, die harte Codierung von Verzeichnisservern für DSAccess wurde aus einen bestimmten Grund durchgeführt. Es wird empfohlen, die automatische Topologiesuche zu verwenden, um die Vorteile globaler Katalogfailover zu nutzen.

So stellen Sie die Standardeinstellung wieder her

  1. Klicken Sie auf Start, klicken Sie auf Programme, klicken Sie auf Microsoft Exchange, und klicken Sie dann auf System-Manager.

  2. Erweitern Sie Administrative Gruppen, <Name der administrativen Gruppe>, Server und <Servername> (wobei Name der administrativen Gruppe den Namen der administrativen Gruppe darstellt, die den Exchange-Server enthält, und Servername den Namen des zu konfigurierenden Exchange-Servers).

  3. Klicken Sie mit der rechten Maustaste auf den Exchange-Server, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf die Registerkarte Verzeichniszugriff.

  5. Wählen Sie im Listenfeld Anzeigen die Option Konfigurationsdomänencontroller aus.

  6. Aktivieren Sie das Kontrollkästchen Server automatisch finden.

  7. Klicken Sie auf Ja, wenn die folgende Exchange-System-Manager-Eingabeaufforderung angezeigt wird: „Die manuell ausgewählten Server, die angegeben wurden, werden gelöscht. Möchten Sie fortfahren?"

  8. Wählen Sie im Listenfeld Anzeigen die Option Domänencontroller aus.

  9. Aktivieren Sie das Kontrollkästchen Server automatisch finden.

  10. Klicken Sie auf Ja, wenn die folgende Exchange-System-Manager-Eingabeaufforderung angezeigt wird: „Die manuell ausgewählten Server, die angegeben wurden, werden gelöscht. Möchten Sie fortfahren?"

  11. Wählen Sie im Listenfeld Anzeigen die Option Globale Katalogserver aus.

  12. Aktivieren Sie das Kontrollkästchen Server automatisch finden.

  13. Klicken Sie auf Ja, wenn die folgende Exchange-System-Manager-Eingabeaufforderung angezeigt wird: „Die manuell ausgewählten Server, die angegeben wurden, werden gelöscht. Möchten Sie fortfahren?"

  14. Klicken Sie auf OK, um die Änderungen zu speichern.

Weitere Informationen über DSAccess und die Erkennung von Verzeichnisdiensten finden Sie im Microsoft Knowledge Base-Artikel 250570, „Directory Service Server Detection and DSAccess Usage" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


DSAccess verwendet nicht Anschluss 389 für LDAP-Domänencontrolleranforderungen.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Exchange_DSAccessDC im Namespace ROOT\MicrosoftExchangeV2 ab, um den Wert für den Schlüssel LDAPPort zu bestimmen. Wenn der Wert für den Schlüssel LDAPPort nicht auf 389 festgelegt ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Schlüssel LDAPPort stellt die Nummer des TCP-Anschlusses dar, über den der Domänencontroller LDAP-Anforderungen (Lightweight Directory Access Protocol) empfängt. Administratoren können als Sicherheitsmaßnahme LDAP mit SSL-Verschlüsselung (Secure Socket Layer) über TCP-Anschluss 636 (Domänencontroller) oder TCP-Anschluss 3269 (Globaler Katalog) verwenden.

In der Standardeinstellung verwenden globale Katalogserver den Anschluss 3268 für die LDAP-Kommunikation. Wenn jedoch eine Unternehmenszertifizierungsstelle installiert ist, fordern alle Domänencontroller automatisch ein Zertifikat an und unterstützen die LDAP-Kommunikation mit SSL über TCP-Anschluss 636. Wenn ein Domänencontroller außerdem als globaler Katalog konfiguriert ist, unterstützt er zusätzlich die LDAP-Kommunikation mit SSL über den TCP-Anschluss 3269.

So beheben Sie diesen Fehler

  • Es ist keine Aktion erforderlich. Exchange Server Analyzer hat eine Konfiguration erkannt, die nicht der Standardkonfiguration entspricht.

Weitere Informationen zu DSAccess und LDAP-Anschlüssen finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 247078, „Aktivieren von Secure Socket Layer (SSL)-Verbindungen über LDAP" unter http://support.microsoft.com/?kbid=247078

  • 246228, „XGEN: DSAccess Profiles" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=246228.


DSAccess verwendet für LDAP-Anforderungen für den globalen Katalog nicht Anschluss 3268.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Exchange_DSAccessDC im Namespace ROOT\MicrosoftExchangeV2 ab, um den Wert für den Schlüssel LDAPPort zu bestimmen. Wenn der Wert für den Schlüssel LDAPPort nicht auf 3268 festgelegt ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Schlüssel LDAPPort stellt die Nummer des TCP-Anschlusses dar, über den der Domänencontroller LDAP-Anforderungen (Lightweight Directory Access Protocol) empfängt. Administratoren können als Sicherheitsmaßnahme LDAP mit SSL-Verschlüsselung (Secure Socket Layer) über TCP-Anschluss 636 (Domänencontroller) oder TCP-Anschluss 3269 (Globaler Katalog) verwenden.

In der Standardeinstellung verwenden globale Katalogserver den Anschluss 3268 für die LDAP-Kommunikation. Wenn jedoch eine Unternehmenszertifizierungsstelle installiert ist, fordern alle Domänencontroller automatisch ein Zertifikat an und unterstützen die LDAP-Kommunikation mit SSL über TCP-Anschluss 636. Wenn ein Domänencontroller außerdem als globaler Katalog konfiguriert ist, unterstützt er zusätzlich die LDAP-Kommunikation mit SSL über den TCP-Anschluss 3269.

Weitere Informationen zu DSAccess und LDAP-Anschlüssen finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 247078, „Aktivieren von Secure Socket Layer (SSL)-Verbindungen über LDAP" unter http://support.microsoft.com/?kbid=247078

  • 246228, „XGEN: DSAccess Profiles" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=246228.


Der DSAccess-Registrierungsparameter „LdapKeepAliveSecs" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob DSAccess (Directory Service Access -Verzeichnisdienstzugriff) für das LDAP der Microsoft Windows®-Betriebssystem-Implementierung (wLDAP) konfiguriert wurde:

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\ LdapKeepAliveSecs

Wenn MicrosoftMicrosoft Exchange Server Analyzer feststellt, dass LdapKeepAliveSecs vorhanden und mit einem Wert von 0 konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Nachdem DSAccess die Active Directory®-Verzeichnisdiensttopologie erkannt hat, wird bestimmt, ob die ermittelte Liste von aktiven Domänencontrollern und globalen Katalogservern für die Verwendung geeignet ist. Während der anfänglichen Ermittlung und des weiteren Ermittlungsprozesses bestimmt DSAccess anhand einer Reihe von Tests, ob der Server geeignet ist. In der Standardeinstellung wird einem der Eignungstests das ICMP (Internet Control Message Protocol) verwendet, um mit dem Ping-Signal Domänencontroller aufzufordern, die Verfügbarkeit der Server zu bestätigen.

Möglicherweise unterstützen nicht alle Verbindungen in ihrem Netzwerk ICMP. Ein Beispiel für solch eine Situation ist ein Umkreisnetzwerk, in dem ICMP-Verbindungen zwischen dem Exchange-Server und Domänencontrollern nicht zulässig ist. In diesen Fällen wird DSAccess durch Festlegen des Registrierungsparameters LdapKeepAliveSecs auf den Wert 0 gezwungen, die Windows-Implementierung von LDAP (wLDAP) für Eignungstests zu verwenden.

Wenn sich der Exchange-Server, der die Meldung wegen der nicht dem Standard entsprechenden Konfiguration generiert hat, in einem Umkreisnetzwerk befindet, in dem RPC (Remote Procedure Call) deaktiviert ist oder in einem Netzwerk, in dem ICMP nicht zulässig ist, sollte die Konfiguration des Schlüssels LdapKeepAliveSecs beibehalten werden. Andernfalls sollten Sie den Schlüssel löschen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So löschen Sie den Schlüssel „LdapKeepAliveSecs"

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Löschen Sie den Wert LdapKeepAliveSecs.

  4. Schließen Sie den Registrierungs-Editor. Es müssen keinerlei Neustarts von Diensten vorgenommen werden, damit die Änderungen wirksam werden.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Registrierungsschlüssel LdapKeepAliveSecs finden Sie im Knowledge Base-Artikel 320529 „XADM: Using DSAccess in a Perimeter Network Firewall Scenario Requires a Registry Key Setting" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320529).


Der DSAccess-Registrierungsparameter „LdapKeepAliveSecs" wurde auf einen nicht unterstützten Wert festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob DSAccess (Directory Service Access -Verzeichnisdienstzugriff) für das LDAP der Microsoft Windows®-Betriebssystem-Implementierung (wLDAP) konfiguriert wurde:

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\ LdapKeepAliveSecs

Wenn Microsoft Exchange Server Analyzer feststellt, dass LdapKeepAliveSecs vorhanden und mit einem anderen Wert als 0 konfiguriert ist, wird eine Warnung angezeigt.

Nachdem DSAccess die Active Directory®-Verzeichnisdiensttopologie erkannt hat, wird bestimmt, ob die ermittelte Liste von aktiven Domänencontrollern und globalen Katalogservern für die Verwendung geeignet ist. Während der anfänglichen Ermittlung und des weiteren Ermittlungsprozesses bestimmt DSAccess anhand einer Reihe von Tests, ob der Server geeignet ist. In der Standardeinstellung wird bei einem der Eignungstests das ICMP (Internet Control Message Protocol) verwendet, um mit dem Ping-Signal Domänencontroller aufzufordern, die Verfügbarkeit der Server zu bestätigen.

Möglicherweise unterstützen nicht alle Verbindungen in ihrem Netzwerk ICMP. Ein Beispiel für solch eine Situation ist ein Umkreisnetzwerk, in dem ICMP-Verbindungen zwischen dem Exchange-Server und Domänencontrollern nicht zulässig ist. In diesen Fällen wird DSAccess durch Festlegen des Registrierungsparameters LdapKeepAliveSecs auf den Wert 0 gezwungen, wLDAP für Eignungstests zu verwenden.

Wenn sich der Exchange-Server, der diese Warnung generiert hat, in einem Umkreisnetzwerk mit deaktiviertem Remoteprozeduraufruf (RPC - Remote Procedure Call) oder einem Netzwerk befindet, in dem ICMP nicht zulässig ist, legen Sie den Schlüssel LdapKeepAliveSecs auf 0 fest. Andernfalls sollten Sie den Schlüssel löschen. Andere Werte als 0 werden für diesen Registrierungsschlüssel nicht unterstützt.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So ändern Sie den Schlüssel „LdapKeepAliveSecs"

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Doppelklicken Sie auf den Schlüssel LdapKeepAliveSecs, und legen Sie den DWORD-Wert auf 0 fest.

  4. Schließen Sie den Registrierungs-Editor. Es müssen keinerlei Neustarts von Diensten vorgenommen werden, damit die Änderungen wirksam werden.

So löschen Sie den Schlüssel „LdapKeepAliveSecs"

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Löschen Sie den Wert LdapKeepAliveSecs.

  4. Schließen Sie den Registrierungs-Editor. Es müssen keinerlei Neustarts von Diensten vorgenommen werden, damit die Änderungen wirksam werden.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Registrierungsschlüssel LdapKeepAliveSecs finden Sie im Knowledge Base-Artikel 320529 „XADM: Using DSAccess in a Perimeter Network Firewall Scenario Requires a Registry Key Setting" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320529).


Der Registrierungsparameter „DSAccess PreloadBaseDNs" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die DSAccess-Funktion (Directory Service Access -Verzeichnisdienstzugriff) zum Laden von Suchergebnissen vom Standardwert abweicht:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\PreloadBaseDNs

Der Standardwert für PreloadBaseDNs ist:

'"'

'"'

'"'

'"'

'"'

Wenn Exchange Server Analyzer feststellt, dass der Wert für PreloadBaseDNs von den Standardwerten abweicht, wird eine Warnmeldung angezeigt. Microsoft Exchange Server Analyzer meldet diese Konfiguration, da die Registrierungseinstellung nur nach Absprache mit dem technischen Support von Microsoft geändert werden darf.

Der DSAccess-Cache befindet sich auf dem Exchange-Server und erfasst Konfigurations- und Benutzerdatensätze, die aus dem Active Directory®-Verzeichnisdienst abgerufen werden. Auf Datensätze im DSAccess-Cache wird zugegriffen, indem der Distinguished Name eines Objekts, die GUID (Globally Unique Identifier) eines Objekts oder ein aus dem Bereich erzeugter Schlüssel, der BaseDN, und der Suchfilter zum Suchen des Objekts in Active Directory verwendet wird. Bei nachfolgenden Zugriffen, bei denen derselbe Distinguished Name, dieselbe GUID oder derselbe Schlüssel verwendet wird, wird der Datensatz im Cache gefunden. Unnötige Ladevorgänge in Active Directory für identische Suchvorgänge werden daher verhindert. DSAccess verhindert Ladevorgänge in Active Directory jedoch nicht, wenn der Suchfilter von dem Suchfilter im Cache abweicht, auch wenn DSAccess die gleichen Attribute für das Benutzerobjekt anfordert.

Durch das Laden von Suchergebnissen kann das Ausführen mehrerer Active Directory-Suchvorgänge vermieden werden. Dieses Problem tritt u. U. auf, wenn verschiedene Suchfilter für das gleiche Benutzerobjekt angewendet werden. Das Laden von Suchergebnissen wird über die zuvor erwähnte Schlüsselerzeugung ausgeführt, bei der über den Bereich, den BaseDN und den Suchfilter ein Sucheintrag erzeugt wird.

Weitere Informationen zur Konfiguration der DSAccess-Funktion zum Laden von Suchergebnissen finden Sie im Microsoft Knowledge Base-Artikel 250572, "XCON: Preloading and the DSAccess Cache" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250572).


Der Registrierungsparameter „DSAccess PreloadFilters" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die DSAccess-Funktion (Directory Service Access -Verzeichnisdienstzugriff) zum Laden von Suchergebnissen vom Standardwert abweicht:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\PreloadFilters

Der Standardwert für PreloadFilters ist:

(&(|(msExchMasterAccountSID=%)(objectSid=%))(!(objectClass=foreignSecurityPrincipal)))(|(msExchMailboxGUID=%)(objectGUID=%))(legacyExchangeDN=%)(msExchMailboxGUID=%)(&(proxyAddresses=%)(|(objectClass=user)(objectClass=contact)))

Wenn Exchange Server Analyzer feststellt, dass der Wert für PreloadFilters vom Standardwert abweicht, wird eine Warnung angezeigt. Exchange Server Analyzer meldet diese Konfiguration, da die Registrierungseinstellung PreloadFilters nur nach Absprache mit dem technischen Support von Microsoft geändert werden sollte.

Der DSAccess-Cache befindet sich auf dem Exchange-Server und erfasst Konfigurations- und Benutzerdatensätze, die vom Active Directory®-Verzeichnisdienst abgerufen werden. Auf Datensätze im Cache wird zugegriffen, indem der Distinguished Name eines Objekts, die GUID (Globally Unique Identifier) eines Objekts oder ein aus dem Bereich erzeugter Schlüssel, der BaseDN und der Suchfilter zum Suchen des Objekts in Active Directory verwendet wird. Bei nachfolgenden Zugriffen, bei denen derselbe Distinguished Name, dieselbe GUID oder derselbe Schlüssel verwendet wird, wird der Datensatz im Cache gefunden. Unnötige Ladevorgänge in Active Directory für identische Suchvorgänge werden daher verhindert. DSAccess verhindert jedoch nicht das Laden in Active Directory, wenn der Suchfilter von dem Suchfilter im Cache abweicht, auch wenn DSAccess die gleichen Attribute für das Benutzerobjekt anfordert.

Das Laden von Suchergebnissen stellt eine Möglichkeit dar, Probleme bei mehreren Active Directory-Suchvorgängen zu vermeiden, die auftreten können, wenn verschiedene Suchfilter auf dasselbe Benutzerobjekt angewendet werden. Das Laden von Suchergebnissen wird über die zuvor erwähnte Schlüsselerzeugung ausgeführt, bei der über den Bereich, den BaseDN und den Suchfilter ein Sucheintrag erzeugt wird.

Weitere Informationen zur Konfiguration der Suchergebnis-Ladefunktion von DSAccess finden Sie im Microsoft Knowledge Base-Artikel 250572, "XCON: Preloading and the DSAccess Cache" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250572).


DSAccess meldet, dass dieser Active Directory-Server nicht funktionsfähig ist.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Exchange_DSAccessDC im Namespace ROOT\MicrosoftExchangeV2 ab, um den Wert für den Schlüssel IsUp zu bestimmen. Wenn der Schlüssel IsUp auf False festgelegt ist, wird ein Fehler angezeigt.

Wenn der Schlüssel IsUp auf True festgelegt ist, wird angezeigt, dass der Domänencontroller geantwortet hat, als der Exchange-Server das letzte Mal versucht hat, eine Verbindung herzustellen. Wenn IsUp auf False festgelegt ist, wird angezeigt, dass der Domänencontroller nicht auf die Verbindungsversuche geantwortet hat.

Das Fehlen einer Antwort bedeutet nicht zwangsläufig, dass der Domänencontroller oder der globale Katalog inaktiv ist oder nicht funktioniert. Es kann vorkommen, dass Netzwerkverbindungsprobleme zwischen dem Exchange-Server und dem Domänencontroller auftreten, die diese Fehlfunktion verursacht haben könnten. So eine Fehlfunktion kann auch das Ergebnis einer Firewall zwischen dem Exchange-Server und dem Domänencontroller sein, für die die entsprechenden Anschlüsse nicht geöffnet worden sind.

So berichtigen Sie diesen Fehler

  1. Prüfen Sie, ob der Domänencontroller ausgeführt wird, indem Sie versuchen, ein PING-Signal an den Domänencontroller zu senden.

  2. Falls es eine Firewall gibt, prüfen Sie, ob bei dieser Firewall die richtigen Anschlüsse geöffnet sind. Ziehen Sie in Betracht, dass Firewalls so konfiguriert sein können, dass sie auch PING-Pakete verwerfen. Prüfen Sie die Dokumentation Ihrer Firewall auf Einzelheiten darüber, wie bestimmte Anschlüsse geöffnet und geschlossen werden können.

  3. Vergewissern Sie sich, dass keine anderen netzwerkbezogenen Probleme, z. B. fehlerhafte Schalter, Router oder Kabel, vorliegen.

Weitere Informationen über DSAccess und die Erkennung von Verzeichnisdiensten finden Sie im Microsoft Knowledge Base-Artikel 250570, „Directory Service Server Detection and DSAccess Usage" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).

Weitere Informationen zum Behandeln von Problemen mit Netzwerkverbindungen finden Sie im Knowledge Base-Artikel 325487, „Behandlung von Problemen mit der Netzwerkverbindung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.


DSAccess meldet, dass dieser Active Directory-Server nicht mit der restlichen Topologie synchronisiert ist.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-04-21

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Exchange_DSAccessDC im Namespace ROOT\MicrosoftExchangeV2 ab, um die Werte für den Schlüssel IsInSync zu bestimmen. Wenn IsInSync den Wert False besitzt, wird ein Fehler angezeigt.

Der Schlüssel IsInSync gibt an, ob der Domänencontroller mit dem globalen Katalogserver und dem Konfigurationsdomänencontroller synchronisiert ist. Der Wert True gibt an, dass der Server synchronisiert ist, und der Wert False gibt an, dass der Domänencontroller nicht synchronisiert ist.

So beheben Sie diesen Fehler

  1. Überprüfen Sie die Zeit auf dem Domänencontroller oder globalen Controller. Vergewissern Sie sich, dass der Zeitdienst gestartet wurde, oder synchronisieren Sie manuell die Zeit auf dem Exchange-Server mit dem globalen Katalogserver oder Konfigurationsdomänencontroller.

  2. Mit dem Replikationsmonitor-Tool (Replmon) können Sie Probleme bei der Domänencontrollerreplikation überprüfen, erkennen und ggf. beheben. Replmon gehört zu den Supporttools für Microsoft® Windows 2000 Server und Microsoft® Windows Server™ 2003, die sich im Ordner Support\Tools der Windows Server-CD befinden.

Weitere Informationen über DSAccess und die Erkennung von Verzeichnisdiensten finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 316300, „Event ID 2080 and MSExchangeDSAccess" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=316300

  • 250570, „Verzeichnisdienst-Servererkennung und DSAccess-Verwendung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)


DSAccess meldet, dass dieser Active Directory-Server länger als 2 Sekunden benötigt, um auf LDAP-Anforderungen zu antworten.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Exchange_DSAccessDC im Namensbereich ROOT\MicrosoftExchangeV2 ab, um die Werte für den Schlüssel IsFast und den Schlüssel IsUp zu bestimmen. Wenn der Wert für den Schlüssel IsUp True ist, wird damit angegeben, dass der von der DSAccess-Komponente (Directory Service Access) in Exchange Server verwendete Verzeichnisserver mit dem Netzwerk verbunden ist und reagiert. Der Wert False gibt an, dass der Verzeichnisserver nicht reagiert. Wenn der Wert IsFast True ist, wird damit angegeben, dass die Reaktionszeit dieses Verzeichnisservers weniger als 2 Sekunden beträgt. Der Wert False gibt an, dass die Reaktionszeit mehr als 2 Sekunden beträgt. Wenn der Wert IsUp True ist, der Wert von IsFast jedoch False, wird ein Fehler angezeigt.

So berichtigen Sie diesen Fehler

  1. Untersuchen Sie die Last auf dem Domänencontroller und dem globalen Katalog. Durch die Überlastung von Domänencontroller und globalem Katalog kann sich die Reaktion auf LDAP-Aufrufe (Lightweight Directory Access Protocol) verlangsamen.

  2. Stellen Sie zur Optimierung der Leistung sicher, dass mindestens ein globaler Katalog auf der lokalen Site mit dem Active Directory®-Verzeichnisdienst vorhanden ist.

Weitere Informationen über DSAccess und die Erkennung von Verzeichnisdiensten finden Sie im Microsoft Knowledge Base-Artikel 250570, „Directory Service Server Detection and DSAccess Usage" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


Der Registrierungsparameter „DSAccess TopoCreateTimeoutSecs" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob die Standardeinstellung für den DSAccess-Initialisierungstimeout (Directory Service Access - Verzeichnisdienstzugriff) geändert wurde:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess\TopoCreateTimeoutSecs

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel TopoCreateTimeoutSecs vorhanden ist und einen Wert aufweist, der größer als 0 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht dem Standard entspricht.

Mithilfe einer Suche beim Start ermittelt DSAccess die Active Directory®-Verzeichnisdiensttopologie und bewertet die Verfügbarkeit von Domänencontrollern und globalen Katalogservern. Mithilfe nahezu des gleichen Verfahrens überprüft DSAccess nach Abschluss des Startvorgangs und dann in Abständen von 15 Minuten die Topologie und ggf. Änderungen der Serververfügbarkeit. In der Standardeinstellung muss die DSAccess-Initialisierung beim Start innerhalb einer Minute abgeschlossen sein. Andernfalls wird DSAccess beendet. In der Regel reicht eine Minute zum Initialisieren von DSAccess aus.

Hinweis:
Wenn die von DSAccess verwendeten Verzeichnisserver mit vordefiniertem Code versehen werden, überspringt DSAccess den Suchvorgang und führt lediglich eine Überprüfung auf Serverkompatibilität auf.
Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess

  3. Löschen Sie den Wert TopoCreateTimeoutSecs.

  4. Schließen Sie den Registrierungs-Editor.

Wenn der Registrierungsschlüssel vorhanden ist, empfiehlt es sich, die Netzwerktopologie auszuwerten. Wenn in der Organisation zusätzliche Zeit zum Initialisieren von DSAccess erforderlich ist, kann dies auf ein Entwurfs- oder Netzwerkproblem hindeuten. Um einen optimalen Betrieb von Exchange sicherzustellen, ist ein schneller und zuverlässiger Zugriff auf Domänencontroller erforderlich, insbesondere auf globale Katalogserver.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen über den Verzeichniszugriff finden Sie unter Understanding and Troubleshooting Directory Access (http://go.microsoft.com/fwlink/?LinkId=39012).


Der DSAccess-Benutzercache ist voll
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-04-20

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_PerfRawData_MSExchangeDSAccess_MSExchangeDSAccessCaches ab, um den aktuellen Wert für TotalEntriesMemoryUserData zu bestimmen. Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert für TotalEntriesMemoryUserData gleich der Gesamtgröße (MaxMemoryUser) des DSAccess-Benutzercaches (Directory Service Access -Verzeichnisdienstzugriff) ist, wird eine Warnung angezeigt.

Bei DSAccess handelt es sich um eine interne Komponente von Exchange 2000 Server und Exchange Server 2003, die den Zugriff der Exchange-Komponenten auf den Active Directory®-Verzeichnisdienst steuert. Die primäre Funktion von DSAccess stellt das Verwalten von Informationen zu verschiedenen verzeichnisbezogenen Ereignissen und Vorgängen dar. Zum Beispiel ermittelt DSAccess die Active Directory-Topologie und stellt fest, ob Domänencontroller und globale Katalogserver verfügbar sind und auf Abfragen reagieren. Außerdem werden alle Verzeichnisabfragen von internen Exchange-Komponenten, z. B. vom Exchange-Speicher, über DSAccess weitergeleitet. Diese Abfragen betreffen u. a. die Empfängeradressauflösung sowie die Konfigurationseinstellungssuche. Zu den Aufgaben von DSAccess gehört die Verwaltung eines Caches im Arbeitsspeicher, in dem ein Teil der Ergebnisse dieser Abfragen vorgehalten werden, sodass diese bei einer erneuten Anforderung derselben Informationen aus dem DSAccess-Cache abgerufen werden können, anstatt eine erneute LDAP-Abfrage (Lightweight Directory Access Protocol) an Active Directory zu stellen.

In Exchange 2000 Server wurde für den Benutzercache anfangs eine Größe von 25 MB festgelegt. Auf Exchange 2000 Server-Computern, die eine große Anzahl von Microsoft Office Outlook® 2003-Clients verwalten, war die als Standard vorgegebene Größe des DSAccess-Benutzercache nicht ausreichend. Um die Leistung zu steigern, wurde der Standardwert für den Benutzercache optimiert und in Exchange Server 2003 auf 140 MB festgelegt.

Da die Standardeinstellung für die maximale Größe des DSAccess-Benutzercaches von 25 MB bei Exchange 2000 Server in 140 MB bei Exchange Server 2003 geändert wurde, wird diese Warnmeldung wahrscheinlich bei Exchange 2000 Server-Computern angezeigt. Unabhängig davon, welche Version von Exchange diese Warnmeldung generiert, sollte dieses Problem so schnell wie möglich behoben werden. In Systemen mit zu kleinem DSAcess-Cache ist die lokale Nachrichtenübermittlung und die Namensauflösung des Adressbuchs unter Umständen langsamer als gewünscht.

Die maximale Größe des Benutzercaches kann manuell über einen Registrierungseintrag auf dem Exchange-Server konfiguriert werden. MaxMemoryUser ist ein Exchange 2000 Server-Registrierungsparameter, mit dem ein Exchange-Administrator die maximale Speichermenge steuern kann, die Benutzerdatenobjekte im DSAccess-Cache belegen dürfen.

Der Wert MaxMemoryUser wird häufig in Verbindung mit dem Wert MaxMemoryConfig verwendet, der die maximale Speichergröße steuert, die für Benutzerdatenobjekten im DSAccess-Cache zur Verfügung stehen. Wenn Sie den Wert für MaxMemoryUser wie im folgenden Verfahren beschrieben bearbeiten bzw. entfernen, sollten Sie auch den Wert für MaxMemoryConfig bearbeiten bzw. entfernen. Weitere Informationen hierzu finden Sie unter Der Wert „DSAccess configuration cache" weicht vom Standardwert ab.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie dieses Problem auf einem Exchange 2000 Server-Computer

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Erhöhen Sie den Wert für MaxMemoryUser. Wenn dieser Wert DWORD nicht vorhanden ist, kann er manuell erstellt werden. Der Datenwert für den Registrierungsschlüssel wird in Kilobyte (KB) angegeben, d. h., ein Dezimalwert von 140000 entspricht 140 MB.

  4. Erhöhen Sie den Wert für MaxMemoryConfig. Wenn dieser Wert DWORD nicht vorhanden ist, kann er manuell erstellt werden. Der Wert für diesen Registrierungseintrag wird in Kilobyte (KB) angegeben. Es wird ein Wert von 5000 (dezimal) empfohlen. Dies entspricht 5 MB.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Systemaufsichtsdienst neu, damit die Änderung wirksam wird.

So beheben Sie dieses Problem auf einem Exchange Server 2003-Computer

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Wenn MaxMemoryUser vorhanden und auf einen Wert unter 140 MB konfiguriert ist, löschen Sie den Wert MaxMemoryUser. Wenn MaxMemoryUser vorhanden und auf einen höheren Wert als 140 MB festgelegt wurde, erhöhen Sie den Wert um 10 Prozent.

  4. Wenn MaxMemoryConfig vorhanden ist, löschen Sie den Wert.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie den Exchange-Systemaufsichtsdienst neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zu DSAccess finden Sie im Knowledge Base-Artikel 250570, „Verzeichnisdienst-Servererkennung und DSAccess-Verwendung" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570).


Der Wert „DSAccess user cache" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest die folgenden Registrierungseinträge, um zu ermitteln, ob die Größe des DSAccess-Benutzerobjekt-Cache vom Standardwert abweicht:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0\MaxMemoryUser

Wenn Exchange Server Analyzer feststellt, dass MaxMemoryUser vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

MaxMemoryUser ist ein Exchange Server-Registrierungsparameter, der einem Exchange-Administrator die Kontrolle über die maximale Speichermenge gibt, die Benutzerdatenobjekte im DSAccess-Cache belegen dürfen.

Bei DSAccess handelt es sich um eine interne Komponente von Exchange 2000 Server und Exchange Server 2003, die den Zugriff der Exchange-Komponenten auf den Active Directory®-Verzeichnisdienst steuert. Die primäre Funktion von DSAccess stellt das Verwalten von Informationen zu verschiedenen verzeichnisbezogenen Ereignissen und Vorgängen dar. Zum Beispiel ermittelt DSAccess die Active Directory-Topologie und stellt fest, ob Domänencontroller und globale Katalogserver verfügbar sind und auf Abfragen reagieren. Außerdem werden alle Verzeichnisabfragen von internen Exchange-Komponenten, z. B. vom Exchange-Speicher, über DSAccess weitergeleitet. Diese Abfragen betreffen u. a. die Empfängeradressauflösung sowie die Konfigurationseinstellungssuche. Zu den Aufgaben von DSAccess gehört die Verwaltung eines Caches im Arbeitsspeicher, in dem ein Teil der Ergebnisse dieser Abfragen vorgehalten werden, sodass diese bei einer erneuten Anforderung derselben Informationen aus dem DSAccess-Cache abgerufen werden können, anstatt eine erneute LDAP-Abfrage (Lightweight Directory Access Protocol) an Active Directory zu stellen.

In Exchange 2000 Server wurde für den Benutzercache anfangs eine Größe von 25 MB festgelegt. Auf Exchange 2000 Server-Computern, die eine große Anzahl von Microsoft Office Outlook® 2003-Clients verwalten, war die als Standard vorgegebene Größe des DSAccess-Benutzercache nicht ausreichend. Auf Systemen mit zu kleinem DSAccess-Cache ist die lokale Nachrichtenübermittung und die Namensauflösung des Adressbuchs möglicherweise langsamer als gewünscht.

Zum Steigern der Leistung wurde der Standardwert für den Benutzercache optimiert und in Exchange Server 2003 auf 140 MB festgelegt. Beim Aktualisieren von Exchange 2000 Server auf Exchange Server 2003 werden sämtliche manuellen Einstellungen beibehalten. Wenn der Exchange-Server von Exchange 2000 Server auf Exchange Server 2003 aktualisiert wurde, stellen Sie sicher, dass der Wert für MaxMemoryUser mindestens 140 MB beträgt.

Der Wert MaxMemoryUser wird häufig in Verbindung mit dem Wert MaxMemoryConfig verwendet, der die maximale Speichergröße steuert, die für Konfigurationsdatenobjekte im DSAccess-Cache zur Verfügung steht. Wenn Sie den Wert für MaxMemoryUser wie unten beschrieben bearbeiten oder entfernen, sollten Sie auch den Wert für MaxMemoryConfig bearbeiten bzw. entfernen (weitere Informationen hierzu finden Sie unter Der Wert „DSAccess configuration cache" weicht vom Standardwert ab).

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So verwenden Sie den Registrierungsschlüssel „MaxMemoryUser"

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Ermitteln Sie den Wert für MaxMemoryUser, oder bearbeiten Sie diesen.

    Der Wert für diesen Registrierungseintrag wird in Kilobyte (KB) angegeben. Wenn der Wert auf 140000 oder kleiner festgelegt ist, löschen Sie MaxMemoryUser, und starten Sie den Dienst Microsoft Exchange-Systemaufsicht neu, um die Exchange Server 2003-Einstellung als Standard festzulegen.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://support.microsoft.com/kb/256986/DE/).

Weitere Informationen zu DSAccess finden Sie im Microsoft Knowledge Base-Artikel 250570, „Directory Service Server Detection and DSAccess Usage" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


DSProxy-RFR-Dienst wurde deaktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Proxyverweisdienst für Verzeichnisdienste (DSProxy RFR) deaktiviert wurde:

HKEY_LOCAL_MACHINE\ System\CurrentControlSet\Services\MSExchangeSA\Parameters\ No RFR Service

Wenn Exchange Server Analyzer erkennt, dass der Wert No RFR Service vorhanden und auf 1 gesetzt ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Die Komponente DSProxy in Exchange 2000 Server und Exchange Server 2003 ermöglicht den Verzeichniszugriff auf einen Domänencontroller oder einen globalen Katalog für Microsoft Office Outlook® 98- und Outlook 97-Clients. Outlook 2000 Service Release 2 (SR-2) und höhere Versionen können einen globalen Katalogserver direkt abfragen.

Wenn sich ein Client mit Outlook 2000 SR-2 oder einer höheren Version mit einem Exchange 2000-Server oder einem Computer mit einer höheren Version verbindet, sucht dieser nach dem Verzeichnisdienst auf dem Exchange-Stammserver. Outlook verarbeitet zunächst für die erste Sitzung den DSProxy-Vorgang. Nachdem ein Client eine Verbindung mit dem DSProxy-Dienst hergestellt hat (dabei werden alle verfügbaren Transportprotkolle versucht), wird ein Verweis an den Client zurückgegeben. In diesem wird er informiert, dass alle künftigen Verzeichnisanforderungen an den globalen Katalogserver erfolgen sollen. Outlook legt den Verweis im MAPI-Profil in der Registrierung fest. Der DSProxy-Verweismechanismus verringert die Last auf dem Exchange-Server und die Latenz für Suchvorgänge in Adressbüchern. Wenn ein expliziter Servername im Profil eingegeben wird, muss Outlook neu gestartet werden, wenn auf diesem Server für den Active Directory®-Verzeichnisdienst ein Fehler auftritt. Wenn eine solche Situation eintritt, sendet der Exchange-Server einen neuen Verweis an Outlook.

In einigen möchten Sie möglicherweise Outlook-Clients, auch solche mit den neuesten Versionen, zwingen, immer den DSProxy-Vorgang zu passieren, ohne dass auf sie verwiesen wird. Dies müssen Sie beispielsweise unternehmen, wenn zwischen dem Outlook- und dem Exchange-Server eine Firewall besteht.

Wenn Sie den Registrierungseintrag No RFR Service hinzufügen, und seinen Wert auf 1 festlegen, verhält sich der Exchange-Server wie ein Proxy für Outlook-Clients, anstatt die Clients auf den entsprechenden globalen Katalogserver für direkte Kommunikation zu verweisen. Wenn Sie den Registrierungsparameter No RFR Service auf 1 setzen, nimmt die Leistung des Exchange-Servers ab, da der Exchange-Server als Proxy für alle Outlook-Clients fungiert, darunter die Clients mit Outlook 2000 SR-2 und höheren Versionen, die direkt mit Active Directory kommunizieren können.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So aktivieren Sie den DSProxy RFR-Dienst

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Erstellen Sie einen neuen DWORD-Wert mit der Bezeichnung No RFR Service.

  4. Konfigurieren Sie den Wert No RFR Service, und setzen Sie ihn auf 1.

Um den DSProxy RFR-Dienst zu deaktivieren, löschen Sie entweder den Registrierungswert No RFR Service, oder setzen Sie ihn auf 0.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen über die Interaktion von Outlook 2000 SR-2-Clients und Clients unter höheren Versionen mit Active Directory finden Sie im Knowledge Base-Artikel 256976, „XCCC: How Outlook 2000 Accesses Active Directory" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914

Informationen über den Zugriff von MAPI-Clients auf Active Directory finden Sie im Knowledge Base-Artikel 256976, „XCLN: How MAPI Clients Access Active Directory" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976.


Datei „EMSMTA.EXE" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Beim Ausführen von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Registrierungsschlüssel „EnableAuthEpResolution" ist aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Registrierungsschlüssel Interface Restrictions für RPC (Remote Procedure Call - Remoteprozeduraufruf) aktiviert ist:

HKEY_LOCAL_MACHINE\ Software\Policies\Microsoft\Windows NT\RPC

Wenn Exchange Server Analyzer feststellt, dass der Registrierungsschlüssel EnableAuthEpResolution vorhanden ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

RPC-Schnittstelleneinschränkungen stellen eine Verbesserung der Netzwerksicherheit bereit, durch die Systeme weniger anfällig für Angriffe über das Netzwerk sind.

Eine RPC-Schnittstelle, die remote und anonym verfügbar ist und in der Standardeinstellung bei Microsoft Windows® XP registriert wird, stellt eine erhebliche Angriffsfläche dar. RPC muss eine solche Schnittstelle selbst registrieren, um eine Endpunktlösung für Aufrufe bereitzustellen, die dynamische Endpunkte verwenden. Der Registrierungsschlüssel RestrictRemoteClients ändert das Verhalten aller RPC-Schnittstellen im System. In der Standardeinstellung verhindert der Registrierungsschlüssel RestrictRemoteClients den anonymen Remotezugriff auf RPC-Schnittstellen im System. Es gibt jedoch einige Ausnahmen. Daher ist die RPC-Endpunktzuordnung nicht mehr anonym verfügbar.

Ein RPC-Client, der versucht, einen Aufruf unter Verwendung eines dynamischen Endpunkts durchzuführen, fragt zuerst die RPC-Endpunktzuordnung auf dem Server ab, um zu bestimmen, mit welchem dynamischen Endpunkt der RPC-Client verbunden werden soll. Diese Abfrage wird anonym durchgeführt, auch wenn der RPC-Clientaufruf selbst mithilfe der RPC-Sicherheit ausgeführt wird. In der Standardeinstellung schlagen anonyme Aufrufe an die RPC-Endpunktzuordnungsschnittstelle unter Microsoft Windows XP Service Pack 2 fehl, da die Standardfunktion RestrictRemoteClients den anonymen Remotezugriff auf RPC-Schnittstellen im System verhindert. Wegen dieser RPC-Schnittstelleneinschränkung wird die RPC-Clientlaufzeit geändert, um eine authentifizierte Abfrage an die Endpunktzuordnung durchzuführen. Diese RPC-Schnittstelleneinschränkung ist das Standardverhalten in Windows XP Service Pack 2. Die RPC-Clientlaufzeit verwendet dann für die Authentifizierung bei der Endpunktzuordnung die integrierte Windows-Authentifizierung, früher als NTLM bezeichnet. Die integrierte Windows-Authentifizierung erfolgt, wenn der tatsächliche RPC-Clientaufruf diese Art der Authentifizierung verwendet. Wenn die folgenden Bedingungen zutreffen, entspricht die Konfiguration nicht der Standardkonfiguration:

  • Der beschriebene RPC-Registrierungsschlüssel und der Wert EnableAuthEpResolution wurden erstellt.

  • Der Registrierungswert EnableAuthEpResolution wurde auf 0 festgelegt.

Weitere Informationen zu Änderungen am RPC-Dienst in Windows XP Service Pack 2 finden Sie unter „RPC Interface Restrictions" (http://go.microsoft.com/fwlink/?LinkId=47371).


Der Epoxy-Leistungsindikator „Warteschlangenlänge ab Client" (IMAP) hat den Schwellenwert überschritten
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-02-13

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Client Out Queue Length (IMAP)-Leistungsindikator des Epoxy-Leistungsobjekts.

Der Leistungsindikator Client Out Queue Length (IMAP) zeigt die Anzahl der Nachrichten in der Warteschlange der IMAP4-Nachrichten an, die vom Prozess Inetinfo.exe an den Prozess Store.exe gesendet wurden. Die Warteschlangen dürfen nie mehr als 50 Elemente enthalten. Wenn Exchange Server Analyzer feststellt, dass der Client Out Queue Length (IMAP) -Leistungsindikator den Spitzenwert von 50 während des Erfassungszeitraums überschritten hat, wird ein Fehler angezeigt.

Epoxy (ExIPC) ist ein Mechanismus für die Nutzung von freigegebenem Arbeitsspeicher, der es den Prozessen von Microsoft IIS (Internet Information Services, Internetinformationsdienste) (Inetinfo.exe) sowie den Microsoft Exchange-Informationsspeicherdiensten (Store.exe) erlaubt, Daten schnell hin- und her zu verlagen. Dies ermöglicht eine bidirektionale Kommunikation zwischen den Prozessen Inetinfo.exe und Store.exe.

Hinweis:
Inetinfo.exe akzeptiert Anforderungen von Internetprotokollen wie WebDAV, IMAP4, NNTP, POP3 und SMTP.

Dieser Speicher wird ebenfalls von DSAccess verwendet, der Exchange-Komponente, die Active Directory®-Informationen zwischenspeichert.

Dieser Fehler weist auf Leistungsprobleme beim Store.exe-Prozess bzw. bei Ressourcen hin, von denen der Store.exe-Prozess abhängt, die das Wachstum dieser Warteschlange verursachen. Hierdurch wird es zu verlängerten Serverreaktionszeiten kommen.

Um dieses Problem zu beheben, verwenden Sie die im Abschnitt „Weitere Informationen" aufgeführten Ressourcen, um den Leistungsengpass bei Store.exe oder damit zusammenhängenden Ressourcen zu ermitteln. Dieser Engpass kann mit schlechter Festplattenleistung oder einer hohen CPU-Auslastung zusammenhängen.

Weitere Informationen

  • Weitere Informationen zum Ermitteln wachsender Warteschlangen in Epoxy finden Sie unter „Identifying Rising Queues in Epoxy" im Handbuch Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen über Leistungsengpässe bei Prozessoren finden Sie unter Prozessorengpass.

  • Weitere Informationen über Leistungsengpässe bei Festplatten finden Sie unter Datenträgerengpass wurde festgestellt.

  • Weitere Informationen zur Behandlung von Problemen mit der Speicherleistung finden Sie im Microsoft Knowledge Base-Artikel 257725, „XADM: Sammeln von Diagnosedaten zur Problembehandlung des Informationsspeichers" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

  • Weitere Informationen zur Leistung von Exchange Server finden Sie im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange Server finden Sie im Handbuch Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Der Epoxy-Leistungsindikator „Warteschlangenlänge ab Client" (POP) hat den Schwellenwert überschritten
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-02-13

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Client Out Queue Length (POP)-Leistungsindikator des Epoxy-Leistungsobjekts.

Der Leistungsindikator Client Out Queue Length (POP) zeigt die Anzahl der Nachrichten in der Warteschlange der POP3-Nachrichten an, die vom Prozess Inetinfo.exe an den Prozess Store.exe gesendet wurden. Die Warteschlangen dürfen nie mehr als 50 Elemente enthalten. Exchange Server Analyzer ruft fünf Minuten lang alle fünf Sekunden einen Messwert für diesen Leistungsindikator ab. Wenn Exchange Server Analyzer feststellt, dass der Client Out Queue Length (POP) -Leistungsindikator den Spitzenwert von 50 während des Erfassungszeitraums überschritten hat, wird ein Fehler angezeigt.

Epoxy (ExIPC) ist ein Mechanismus für die Nutzung von freigegebenem Arbeitsspeicher, der es den Prozessen von Microsoft IIS (Internet Information Services, Internetinformationsdienste) (Inetinfo.exe) sowie den Microsoft Exchange-Informationsspeicherdiensten (Store.exe) erlaubt, Daten schnell hin- und her zu verlagen. Dies ermöglicht eine bidirektionale Kommunikation zwischen den Prozessen Inetinfo.exe und Store.exe.

Hinweis:
Inetinfo.exe akzeptiert Anforderungen von Internetprotokollen wie WebDAV, IMAP4, NNTP, POP3 und SMTP.

Dieser Speicher wird ebenfalls von DSAccess verwendet, der Exchange-Komponente, die Active Directory®-Informationen zwischenspeichert.

Dieser Fehler weist auf Leistungsprobleme beim Store.exe-Prozess bzw. bei Ressourcen hin, von denen der Store.exe-Prozess abhängt, die das Wachstum dieser Warteschlange verursachen. Hierdurch wird es zu verlängerten Serverreaktionszeiten kommen.

Um dieses Problem zu beheben, verwenden Sie die im Abschnitt „Weitere Informationen" aufgeführten Ressourcen, um den Leistungsengpass bei Store.exe oder damit zusammenhängenden Ressourcen zu ermitteln. Dieser Engpass kann mit schlechter Festplattenleistung oder einer hohen CPU-Auslastung zusammenhängen.

Weitere Informationen

  • Weitere Informationen zum Ermitteln wachsender Warteschlangen in Epoxy finden Sie unter „Identifying Rising Queues in Epoxy" im Handbuch Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen über Leistungsengpässe bei Prozessoren finden Sie unter Prozessorengpass.

  • Weitere Informationen über Leistungsengpässe bei Festplatten finden Sie unter Datenträgerengpass wurde festgestellt.

  • Weitere Informationen zur Behandlung von Problemen mit der Speicherleistung finden Sie im Microsoft Knowledge Base-Artikel 257725, „XADM: Sammeln von Diagnosedaten zur Problembehandlung des Informationsspeichers" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

  • Weitere Informationen zur Leistung von Exchange Server finden Sie im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange Server finden Sie im Handbuch Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Datei „EPOXY.DLL" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung des Setup-Programms im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Das Objekt „Epoxy" zur Überwachung der Leistung ist nicht vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Client Out Queue Length-Leistungsindikator des Epoxy-Leistungsobjekts. Wenn gültige Daten nicht vom Indikator zurückgegeben werden, zeigt Microsoft Exchange Server Analyzer eine Basislinienmeldung an.

Wenn gültige Daten nicht vom Erfassungsmodul für Leistungsdaten zurückgegeben werden, ist eine Kombination der folgenden Bedingungen gültig:

  • Das Epoxy-Leistungsüberwachungsobjekt wurde deaktiviert.

  • Das Epoxy-Leistungsüberwachungsobjekt wurde nicht gefunden, oder es ist beschädigt.

  • Exchange Server Analyzer verfügt nicht über entsprechende Berechtigungen zum Zugreifen auf die Leistungsobjekte.

Die ersten beiden Bedingungen treten auf, wenn die Registrierung von bestimmten erweiterbaren Indikatoren beschädigt wird oder wenn die Registrierung von auf Microsoft WMI (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) basierten Programmen geändert wird. Im folgenden Verfahren wird die Behebung der ersten beiden Bedingungen erläutert. Überprüfen Sie vor dem Ausführen des Verfahrens, ob Exchange Server Analyzer über entsprechende Berechtigungen verfügt. Weitere Informationen zu den Berechtigungen, die zum Ausführen von Microsoft Exchange Server Analyzer erforderlich sind, finden Sie in der im Lieferumfang von Microsoft Exchange Server Analyzer enthaltenen Hilfedokumentation. Wenn Sie Hilfe erhalten möchten, öffnen Sie Exchange Server Analyzer, und drücken Sie F1.

So beheben Sie diesen Fehler

  1. Überprüfen Sie, ob das Epoxy-Leistungsobjekt aktiviert ist:

    1. Downloaden und installieren Sie das Tool „Extensible Performance Counter List" (Exctrlst.exe). Sie können Exctrlst.exe auf der folgenden Website downloaden: „Exctrlst.exe: Extensible Performance Counter List" (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Öffnen Sie die Datei Exctrlst.exe, klicken Sie auf Sortierreihenfolge und anschließend auf Dienst.

    3. Suchen Sie den Dienst, über den das Leistungsobjekt eine Meldung ausgeben soll, und überprüfen Sie, ob das Kontrollkästchen Leistungsindikatoren aktiviert aktiviert ist.

      Wenn das Kontrollkästchen Leistungsindikatoren aktiviert nicht aktiviert ist, aktivieren Sie es, und starten Sie den Dienst neu, der dem Leistungsindikator zugeordnet ist, um zu überprüfen, ob die Leistungsindikatoren betriebsbereit sind. Wenn die Leistungsindikatoren nicht betriebsbereit sind oder wenn das Kontrollkästchen Leistungsindikatoren aktiviert bereits aktiviert wurde, fahren Sie mit Schritt 2 fort.

  2. Erstellen Sie die nicht vorhandenen oder beschädigten Leistungsindikatoren wie im Microsoft Knowledge Base-Artikel 300956 „Manuelles Neuerstellen der Werte der Leistungsindikatorenbibliothek" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) beschrieben neu.

  3. Wenn Sie das Problem anhand dieses Knowledge Base-Artikels nicht beheben können, müssen Sie Exchange Server im Modus Reparieren erneut installieren und die aktuellsten Exchange Server-Service Packs installieren.


Der Epoxy-Leistungsindikator „Warteschlangenlänge ab Informationsspeicher" (IMAP) hat den Schwellenwert überschritten
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-02-13

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Store Out Queue Length (IMAP)-Leistungsindikator des Epoxy-Leistungsobjekts.

Der Leistungsindikator Store Out Queue Length (IMAP) zeigt die Anzahl der Nachrichten in der Warteschlange der IMAP4-Nachrichten an, die vom Prozess Store.exe an den Prozess Inetinfo.exe gesendet wurden. Die Warteschlange darf nie mehr als 50 Elemente enthalten. Exchange Server Analyzer ruft fünf Minuten lang alle fünf Sekunden einen Messwert für diesen Leistungsindikator ab. Wenn Exchange Server Analyzer feststellt, dass der Store Out Queue Length (IMAP) -Leistungsindikator den Spitzenwert von 50 während des Erfassungszeitraums überschritten hat, wird ein Fehler angezeigt.

Epoxy (ExIPC) ist ein Mechanismus für die Nutzung von freigegebenem Arbeitsspeicher, der es den Prozessen von Microsoft IIS (Internet Information Services, Internetinformationsdienste) (Inetinfo.exe) sowie den Microsoft Exchange-Informationsspeicherdiensten (Store.exe) erlaubt, Daten schnell hin- und her zu verlagen. Dies ermöglicht eine bidirektionale Kommunikation zwischen den Prozessen Inetinfo.exe und Store.exe.

Hinweis:
Inetinfo.exe akzeptiert Anforderungen von Internetprotokollen wie WebDAV, IMAP4, NNTP, POP3 und SMTP.

Dieser Speicher wird ebenfalls von DSAccess verwendet, der Exchange-Komponente, die Active Directory®-Informationen zwischenspeichert.

Dieser Fehler weist auf Leistungsprobleme beim Inetinfo.exe-Prozess bzw. bei Ressourcen hin, von denen der Inetinfo.exe-Prozess abhängt, die das Wachstum dieser Warteschlange verursachen. Hierdurch kann es zu verlängerten Serverreaktionszeiten kommen. Aus diesem Grund wird es auf Benutzerseite zu Verzögerungen bei Serverantworten kommen.

Um dieses Problem zu beheben, verwenden Sie die im Abschnitt „Weitere Informationen" aufgeführten Ressourcen, um den Leistungsengpass bei Inetinof.exe oder damit zusammenhängenden Ressourcen zu ermitteln. Dieser Engpass kann mit schlechter Festplattenleistung oder einer hohen CPU-Auslastung zusammenhängen.

Weitere Informationen

  • Weitere Informationen zum Ermitteln wachsender Warteschlangen in Epoxy finden Sie unter „Identifying Rising Queues in Epoxy" im Handbuch Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen über Leistungsengpässe bei Prozessoren finden Sie unter Prozessorengpass.

  • Weitere Informationen über Leistungsengpässe bei Festplatten finden Sie unter Datenträgerengpass wurde festgestellt.

  • Weitere Informationen zur Behandlung von Problemen mit der Speicherleistung finden Sie im Microsoft Knowledge Base-Artikel 257725, „XADM: Sammeln von Diagnosedaten zur Problembehandlung des Informationsspeichers" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

  • Weitere Informationen zur Leistung von Exchange Server finden Sie im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange Server finden Sie im Handbuch Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Der Epoxy-Leistungsindikator „Warteschlangenlänge ab Informationsspeicher" (POP) hat den Schwellenwert überschritten
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-02-13

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Store Out Queue Length (POP)-Leistungsindikator des Epoxy-Leistungsobjekts.

Der Leistungsindikator Store Out Queue Length (POP) zeigt die Anzahl der Nachrichten in der Warteschlange der POP3-Nachrichten an, die vom Prozess Store.exe an den Prozess Inetinfo.exe gesendet wurden. Die Warteschlange darf nie mehr als 50 Elemente enthalten. Exchange Server Analyzer ruft fünf Minuten lang alle fünf Sekunden einen Messwert für diesen Leistungsindikator ab. Wenn Exchange Server Analyzer feststellt, dass der Store Out Queue Length (POP) -Leistungsindikator den Spitzenwert von 50 während des Erfassungszeitraums überschritten hat, wird ein Fehler angezeigt.

Epoxy (ExIPC) ist ein Mechanismus für die Nutzung von freigegebenem Arbeitsspeicher, der es den Prozessen von Microsoft IIS (Internet Information Services, Internetinformationsdienste) (Inetinfo.exe) sowie den Microsoft Exchange-Informationsspeicherdiensten (Store.exe) erlaubt, Daten schnell hin- und her zu verlagen. Dies ermöglicht eine bidirektionale Kommunikation zwischen den Prozessen Inetinfo.exe und Store.exe.

Hinweis:
Inetinfo.exe akzeptiert Anforderungen von Internetprotokollen wie WebDAV, IMAP4, NNTP, POP3 und SMTP.

Dieser Speicher wird ebenfalls von DSAccess verwendet, der Exchange-Komponente, die Active Directory®-Informationen zwischenspeichert.

Dieser Fehler weist auf Leistungsprobleme beim Inetinfo.exe-Prozess bzw. bei Ressourcen hin, von denen der Inetinfo.exe-Prozess abhängt, die das Wachstum dieser Warteschlange verursachen. Hierdurch kann es zu verlängerten Serverreaktionszeiten kommen. Aus diesem Grund wird es auf Benutzerseite zu Verzögerungen bei Serverantworten kommen.

Um dieses Problem zu beheben, verwenden Sie die im Abschnitt „Weitere Informationen" aufgeführten Ressourcen, um den Leistungsengpass bei Inetinof.exe oder damit zusammenhängenden Ressourcen zu ermitteln. Dieser Engpass kann mit schlechter Festplattenleistung oder einer hohen CPU-Auslastung zusammenhängen.

Weitere Informationen

  • Weitere Informationen zum Ermitteln wachsender Warteschlangen in Epoxy finden Sie unter „Identifying Rising Queues in Epoxy" im Handbuch Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen über Leistungsengpässe bei Prozessoren finden Sie unter Prozessorengpass.

  • Weitere Informationen über Leistungsengpässe bei Festplatten finden Sie unter Datenträgerengpass wurde festgestellt.

  • Weitere Informationen zur Behandlung von Problemen mit der Speicherleistung finden Sie im Microsoft Knowledge Base-Artikel 257725, „XADM: Sammeln von Diagnosedaten zur Problembehandlung des Informationsspeichers" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

  • Weitere Informationen zur Leistung von Exchange Server finden Sie im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange Server finden Sie im Handbuch Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Fehler bei Zugriff auf Exchange Server
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer kann nicht auf Ihren Exchange-Server zugreifen. Dieser Fehler zeigt an, dass die Konfigurationsdaten für den von Ihnen angegebenen Exchange-Server im der Active Directory®-Verzeichnisdienst nicht gefunden wurden.

So beheben Sie diesen Fehler

  • Vergewissern Sie sich, dass Sie den Servernamen richtig geschrieben haben.

  • Geben Sie nur den Host- oder NetBIOS-Namen des Servers (z. B. Server1) statt des vollqualifizierten Domänennamens (z. B. Server1.example.com) ein.

  • Stellen Sie sicher, dass Sie die Berechtigung haben, auf die Konfigurationsinformationen von Active Directory für diesen Server zuzugreifen.


Fehler bei Zugriff auf Exchange Server-Informationen
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer hat ein Problem mit dem Zugriff auf die Konfigurationsinformationen des Active Directory®-Verzeichnisdienstes für den Exchange-Server.

So beheben Sie diesen Fehler

  • Stellen Sie sicher, dass Ihr aktuelles Anmeldekonto die Berechtigung hat, in Active Directory die Konfigurationsinformationen für den Exchange-Server zu lesen.

  • Stellen Sie sicher, dass Sie über das Netzwerk mit einem Active Directory-Domänencontroller verbunden sind.

  • Geben Sie die expliziten Kontoanmeldeinformationen im Exchange Server Analyzer ein, damit Sie auf Active Directory zugreifen können.

  • Bestimmen Sie in Exchange Server Analyzer einen Active Directory-Domänencontroller.

  • Gewährleisten Sie, dass der von Ihnen angegebene Exchange-Server vorhanden ist und dass Sie den Servernamen richtig geschrieben haben.


Fehler beim Zugriff auf das Nachrichtenverfolgungsprotokoll
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-06

Microsoft® Exchange Server Analyzer fragt die MessageID-Eigenschaft aller Instanzen der Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Exchange_MessageTrackingEntry ab.

Wenn Exchange Server Analyzer kein Abfrageergebnis erhält, wird ein Fehler angezeigt.

Die wahrscheinlichste Ursache dieses Fehlers ist, dass das der Nachrichtenstatus deaktiviert ist.

Der Nachrichtenstatus protokolliert (sofern aktiviert) Informationen über den Absender, die E-Mail-Nachricht und den Nachrichtenempfänger. Sie können insbesondere Statistiken überprüfen, z. B. den Zeitpunkt des Sendens und des Empfangs der Nachricht, die Nachrichtengröße und -priorität sowie eine Liste der Empfänger der Nachricht. Sie können auch die Betreffzeile von E-Mail-Nachrichten protokollieren. Mit dem Nachrichtenstatus können Sie nach Nachrichten suchen, einschließlich Systemmeldungen, Nachrichten in öffentlichen Ordnern und E-Mail-Nachrichten.

Sie müssen den Nachrichtenstatus auf allen Servern aktivieren, auf denen Sie Nachrichten verfolgen möchten. Sofern aktiviert, werden sämtliche über einen Server weitergeleiteten Nachrichten zu den Nachrichtenverfolgungsprotokollen hinzugefügt.

Die Nachrichtenverfolgung muss aktiviert sein, damit Exchange Server Analyzer seine Prüfungen beginnen kann.

Hinweis:
Zur Durchführung dieses Verfahrens benötigen Sie folgende Berechtigungen: Mitglied der lokalen Administratorgruppe und einer Gruppe, der die Funktion Exchange-Administrator auf der Ebene der administrativen Gruppen zugewiesen ist
So aktivieren Sie den Nachrichtenstatus auf einem Server

  1. Erweitern Sie im Exchange-System-Manager Server, klicken Sie mit der rechten Maustaste auf den Server, für den Sie die Nachrichtenverfolgung aktivieren möchten, und klicken Sie dann auf Eigenschaften.

  2. Aktivieren Sie auf der Registerkarte Allgemein das Kontrollkästchen Nachrichtenverfolgung aktivieren.

  3. Aktivieren Sie das Kontrollkästchen Nachrichtenbetreff protokollieren und anzeigen, um die Betreffzeile aufzuzeichnen, die an, von oder über einen Server gesendet wurde.

    Hinweis:
    Wenn Sie die Protokollierung des Betreffs aktivieren, kann die Leistung beeinträchtigt werden.

  4. Unter Wartung der Protokolldateien können Sie festlegen, wie lange Protokolle gespeichert werden und ob die Protokolldateien entfernt werden. Die Standardeinstellung für den Speicherzeitraum ist sieben Tage.

    Hinweis:
    Auf Servern, die große Mengen an E-Mail-Nachrichten verarbeiten, nimmt die Größe der Verfolgungsprotokolle schnell zu. Stellen Sie sicher, dass genügend freier Speicherplatz für die Protokolldateien und andere Dienste oder Anwendungen zur Verfügung steht.

  5. Klicken Sie auf OK oder auf Übernehmen. Sie müssen die Dienste neu starten, damit die Änderungen übernommen werden.

Weitere Informationen zur Verwendung des Nachrichtenstatus finden Sie im Microsoft Knowledge Base-Artikel 262162, "XADM: Verwenden des Nachrichtenstatus, um eine Nachricht zu verfolgen" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162)

Weitere Informationen zur Behandlung von Exchange Server-Transportproblemen finden Sie im Microsoft Knowledge Base-Artikel 821910, "Beheben von Transportproblemen mit Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821910).


Fehler beim Aktualisieren von ACLs
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-02-15

Microsoft Exchange Analyzer fragt die Microsoft WMI-Klasse (Windows Management Instrumentation - Windows-Verwaltungsinstrumentation) Win32_NTLogEvent ab, um zu ermitteln, ob innerhalb der letzten Stunde für MSExchangeIS ein Fehler aufgrund von Ereignis 9551 aufgetreten ist.

Stellt der Exchange Analyzer fest, dass innerhalb der letzten Stunde ein Fehler aufgrund von Ereignis 9551 protokolliert wurde, zählt er die Gesamtanzahl der in dieser Stunde erfassten 9551-Ereignisfehler.

Wenn Exchange Analyzer feststellt, dass in der letzten Stunde 20 oder mehr 9551-Ereignisfehler protokolliert wurden, wird eine Warnung angezeigt.

Dieser Fehler weist darauf hin, dass möglicherweise Benutzerkonten in einer Zugriffssteuerungsliste (Access Control List, ACL) für eine Postfachressource oder einen Öffentlichen Ordner enthalten sind, die keinem gültigen Active Directory-Verzeichnisdienstobjekt zugeordnet sind.

Ein Postfach auf einem Server mit Microsoft Exchange Server 2003 oder Exchange 2000 Server ist nur verfügbar, wenn es in Active Directory durch ein gültiges Active Directory-Verzeichnisdienst-Benutzerkonto dargestellt wird.

Ein Konto ohne gültige Darstellung in Active Directory entsteht beispielsweise, wenn eine Postfachressource oder ein Öffentlicher Ordner in Exchange 2000 Server oder Exchange Server 2003 nach dem Löschen eines Postfachs auf dem Exchange Server 5.5-basierten Computer nicht aktualisiert wird.

Wenn das gelöschte Postfachkonto in der ACL einer Postfachressource oder eines Öffentlichen Ordners verbleibt, dann kann jedes Mal, wenn auf die Postfachressource bzw. den Öffentlichen Ordner zugegriffen wird und Exchange versucht, die Konten in der Liste aufzulösen, das Konto ohne gültige Darstellung in Active Directory nicht aufgelöst werden. Dies kann zu einem Leistungsproblem führen.

So beheben Sie dieses Problem

  • Stellen Sie sicher, dass Exchange 2000 Server Service Pack 3 (SP3) oder höher installiert ist. Informationen zum Beziehen des neuesten Service Packs für Exchange 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 301378, "Wie Sie das neueste Service Pack für Exchange 2000 Server erhalten" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378).

  • Verwenden Sie den Exchange-System-Manager, um die ungültigen Postfachkonten manuell aus der ACL zu entfernen.

  • Führen Sie in einer Exchange-Umgebung im gemischten Modus die DS/IS-Konsistenzprüfung für den Informationsspeicher aus.

  • Befolgen Sie in einer Exchange-Umgebung im einheitlichen Modus die Anweisungen in Microsoft Knowledge Base-Artikel 324323, "XADM: Auslassen von Benutzerkonten, die bei der Konvertierung von Zugriffssteuerungslisten in Active Directory nicht dargestellt werden" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323).

So verwenden Sie den Exchange-System-Manager, um die ungültigen Konten manuell aus der ACL zu entfernen

  1. Starten Sie den Exchange-System-Manager, und suchen Sie den im Fehler 9551 angegebenen Ordner.

  2. Klicken Sie mit der rechten Maustaste auf den Ordner, und wählen Sie Eigenschaften aus.

  3. Wählen Sie die Registerkarte Berechtigungen aus, und klicken Sie dann auf Clientberechtigungen.

  4. Wählen Sie im Bereich Name das im Fehler 9551 angegebene Benutzerkonto aus, und klicken Sie dann auf die Schaltfläche Entfernen, um das Konto aus der ACL zu löschen.
Führen Sie die DS/IS-Konsistenzprüfung für den Informationsspeicher im gemischten Exchange-Modus aus.

  1. Klicken Sie im Exchange Server 5.5-Administrator auf den Exchange 5.5 Server-Computer, der den Informationsspeicher enthält.

  2. Klicken Sie im Menü Datei auf Eigenschaften, und klicken Sie anschließend auf die Registerkarte Erweitert.

  3. Klicken Sie auf Konsistenzanpassung.

  4. Aktivieren Sie die Kontrollkästchen Unbekannte Benutzerkonten aus Berechtigungen für Öffentliche Ordner entfernen und Unbekannte Benutzerkonten aus Postfachberechtigungen entfernen, und klicken Sie dann auf Alle Inkonsistenzen.

  5. Deaktivieren Sie alle anderen Kontrollkästchen, und klicken Sie auf OK.

Weitere Informationen

Weitere Informationen zu diesem Problem finden Sie in den folgenden Microsoft Knowledge Base-Artikeln und Exchange Server-Ressourcen:

  • Events and Errors Message Center: Ereignisdetails: MSExchangeIS-Postfachspeicher: Details zum Ereignis 9551 (http://go.microsoft.com/fwlink/?LinkId=83189).

  • Microsoft Knowledge Base-Artikel 301378, "Wie Sie das neueste Service Pack für Exchange 2000 Server erhalten" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378).

  • Microsoft Knowledge Base-Artikel 324323, "XADM: Auslassen von Benutzerkonten, die bei der Konvertierung von Zugriffssteuerungslisten in Active Directory nicht dargestellt werden" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323).


Datei „ESE.DLL" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-04-21

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Datei „ESEUTIL.EXE" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Datei „EXCDO.DLL" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Beim Ausführen von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Datei „EXCHMEM.DLL" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft sowohl im Ordner System32 als auch im Ordner \Exchsrvr\bin)

  • Mapi32.dll (überprüft sowohl im Ordner System32 als auch im Ordner \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuellste Service Pack, oder Sie führen ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Product Key ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Datei „EXMIME.DLL" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung des Setup-Programms im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Datei „EXOLEDB.DLL" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Beim Ausführen von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden weder Benutzer- noch Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Product Key ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Datei „EXPOP3.DLL" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung des Setup-Programms im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Datei „EXPROX.DLL" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Datei „EXRES.DLL" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Datei „EXSMTP.DLL" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Die Version der Datei „EXSMTP.DLL" ist veraltet.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Fehlermeldung

Einführung

Microsoft® Exchange Server Analyzer sendet eine Abfrage an die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile, um den Wert des Schlüssels Version für EXSMTP.DLL zu bestimmen. Wenn Exchange Server Analyzer feststellt, dass der Schlüssel Version für EXSMTP.DLL nicht gleich 6556.0 ist, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass die Version von EXSMTP.DLL auf diesem Exchange Server-Computer aus der Version Exchange 2000 Server Post-Service Pack 3 Rollup vom 1. Mai 2004 stammt. Ein neueres Updaterollup steht für einen Download zur Verfügung.

So beheben Sie diese Warnmeldung

  1. Downloaden Sie das neueste Update (August 2004) von der Exchange 2000 Server-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).

  2. Informationen zur neuesten Aktualisierung finden Sie im Microsoft Knowledge Base-Artikel 870540 „Availability of the August 2004 Exchange 2000 Server Post-Service Pack 3 Update Rollup" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540.

  3. Nehmen Sie eine vollständige Sicherung des Exchange Server-Computers vor.

  4. Wenden Sie das Update von August 2004 an.

Weitere Informationen zum Installieren dieser und anderer Exchange Server-Updates finden Sie im Microsoft Knowledge Base-Artikel 328839 „Wie Sie Service Packs und Hotfixes für Exchange anwenden" unter http://support.microsoft.com/kb/328839/de.


Die Ablaufverfolgung für Exchange ActiveSync ist zurzeit aktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungswert, um zu ermitteln, ob für Exchange ActiveSync® die Ablaufverfolgung aktiviert ist:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Tracing\Microsoft Server ActiveSync\MasSync\Enabled

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert für Enabled vorhanden und mit einem Wert über 0 konfiguriert ist, wird eine Warnung angezeigt.

Exchange ActiveSync wird in IIS (Internet Information Services) als ISAPI-Erweiterung (Internet Server Application Programming Interface) implementiert. IIS, Exchange ActiveSync und viele der Client-Geräte, die Exchange ActiveSync verwenden, beinhalten native Ablaufverfolgungsfähigkeiten. Daher ist es überflüssig, die nativen Ablaufverfolgungsfähigkeiten von Microsoft Windows Server™ 2003 zu verwenden.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\Software\Microsoft\Windows NT\CurrentVersion\Tracing\Microsoft Server ActiveSync\MasSync

  3. Löschen Sie den Wert Enabled.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den Exchange Server-Computer neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://support.microsoft.com/kb/256986/DE/).

Weitere Informationen zur Ablaufverfolgung und Protokollierung für Exchange ActiveSync und Exchange ActiveSync-Clients finden Sie in folgenden Knowledge Base-Artikeln:

  • 330463, „XCCC: How to troubleshoot server ActiveSync HTTP error codes" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=330463)

  • 330461, „HOW TO: Troubleshoot Server ActiveSync" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=330461)

  • 822176, „Fehlerbehebung bei der Benachrichtigung über fortlaufenden Datenabgleich in Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822176)


Die Version der Exchange-Binärdatei ist neuer als die installierte Version von Exchange Server
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft sowohl im Ordner System32 als auch im Ordner \Exchsrvr\bin)

  • Mapi32.dll (überprüft sowohl im Ordner System32 als auch im Ordner \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass der Wert für Version für eine der Dateien größer ist, als der Wert für Version für Exchange Server, wird eine Warnung angezeigt. Eine höhere Versionsnummer bedeutet, dass eine Datei neuer als erwartet ist. Dies kann der Fall sein, wenn ein Hotfix installiert wurde.

So beheben Sie diese Warnungmeldung

  1. Es ist keine Aktion erforderlich. Die Warnung zeigt lediglich das Vorhandensein neuerer Dateien an, die vermutlich über einen Hotfix oder eine andere Aktualisierung installiert wurden.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Dieser Exchange-Clusterknoten ist auch ein Domänencontroller.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer sendet eine Abfrage an das Microsoft WMI-Objekt (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) der Win32_ComputerSystem-Klasse, um den Wert DomainRole für den Server zu bestimmen. Der Wert DomainRole stellt die Rolle eines Computers in einer Domäne dar. In der folgenden Tabelle werden die gültigen Werte für DomainRole aufgelistet.

Wert | Bedeutung
0 | Eigenständige Workstation
1 | Mitgliedsworkstation
2 | Eigenständiger Server
3 | Mitgliedsserver
4 | Sicherungsdomänencontroller
5 | Primärer Domänencontroller

Zusätzlich sendet Exchange Server Analyzer eine Abfrage an das WMI-Objekt ClusSvc (Windows-Clusterdienstobjekt, Klasse Win32_Service), um für dieses den Wert Started zu bestimmen. Der Wert True gibt an, dass der Clusterdienst gestartet wurde, und der Wert False gibt an, dass der Clusterdienst nicht gestartet wurde.

Wenn Exchange Server Analyzer feststellt, dass der Wert für DomainRole auf einem ExchangeServer-Computer, auf dem der Clusterdienst gestartet wurde, größer als 3 ist, wird ein Fehler angezeigt. Dieser Fehler zeigt an, dass ein Exchange-Server in einem Windows-Servercluster ausgeführt wird, bei dessen Knoten es sich um Domänencontroller handelt.

Das Ausführen eines Exchange Server-Clusterknotens als Domänencontroller ist keine unterstützte Konfiguration.

So beheben Sie diesen Fehler

  1. Wählen Sie als Domänencontroller einen Server, der nicht Teil eines Clusters ist, und führen Sie den Assistenten für die Installation von Active Directory (dcpromo) so aus, um diesen Server heraufzustufen.

  2. Nachdem der Verzeichnisdienst Active Directory® auf dem neuen Domänencontroller konfiguriert ist, warten Sie darauf, dass der vorhandene Inhalt von Active Directory auf dem neuen Server repliziert wird.

    In Abhängigkeit von der Größe von Active Directory kann dieser Vorgang mehrere Stunden dauern.

  3. Führen Sie den Assistenten zur Installation von Active Directory (dcpromo) auf dem Clusterserver aus, um den Server herabzustufen, und entfernen Sie Active Directory.

Weitere Informationen zum Heraufstufen und Herabstufen von Domänencontrollern finden Sie im Microsoft Knowledge Base-Artikel „SO WIRD'S GEMACHT: Herauf-/Herabstufen eines Domänencontrollers auf Mitgliedsserver in Windows 2000" (http://support.microsoft.com/default.aspx?scid=kb;de;238369).


Exchange-Fehlerberichterstattung ist deaktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-04-21

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungswert, um zu bestimmen, ob die Exchange-Fehlerberichterstattung aktiviert ist:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\DisableErrorReporting

Wenn Exchange Server Analyzer feststellt, dass der Wert von DisableErrorReporting auf 1 festgelegt ist, wird eine Warnung angezeigt. Der Wert 1 zeigt an, dass die Fehlerberichterstattung von Exchange deaktiviert ist.

Die Unterstu¨tzung fu¨r Microsoft-Fehlerberichterstattung (die auch als Windows-Fehlerberichterstattung, Microsoft-Ereignisberichterstattung und Automatische Fehlerberichterstattung bezeichnet wird) wurde erstmalig in Exchange 2000 Server Service Pack 2 eingefu¨hrt. Exchange Server 2003 bietet eine erweiterte Version der Microsoft-Fehlerberichterstattung, die Exchange-Fehlerberichterstattung. Diese optimiert die Meldung von Fehlern an Administratoren, sie ist mit dem Feature Corporate Error Reporting integriert und bietet zudem die erweiterte Fehlerberichterstattung fu¨r den Exchange Server 2003-Empfa¨ngeraktualisierungsdienst.

Die Exchange-Fehlerberichterstattung ermo¨glicht Exchange Server-Administratoren das U¨bermitteln von Informationen u¨ber Abstu¨rze und andere schwerwiegende Fehler per HTTPS u¨ber das Internet an einen Fehlerberichterstattungsserver von Microsoft. Es wird empfohlen, dass Sie Fehlerberichte an die Microsoft Online Crash Analysis (Microsoft-Absturzanalyse) senden. Das Sammeln von Daten u¨ber schwerwiegende Fehler von Exchange-Servern unterstu¨tzt das Exchange-Produktteam beim Ermitteln und Beheben von Fehlern in der von Ihnen verwendeten Software.

Wenn ein schwerwiegender Fehler bei der Arbeit mit dem Exchange-System-Manager oder beim Ausfu¨hren einer Exchange-Aufgabe mit Active Directory-Benutzer und -Computer auf einem Computer auftritt, auf dem der Exchange-System-Manager installiert ist, benachrichtigt die Exchange-Fehlerberichterstattung Administratoren u¨ber den Fehler und fragt, ob der Fehler an Microsoft gemeldet werden soll. Zudem fa¨ngt die Exchange-Fehlerberichterstattung von der Microsoft Exchange-Systemaufsicht, dem Microsoft Exchange-Informationsspeicher und anderen Exchange-Diensten festgestellte Fehler auf und meldet diese. Da Fehler des Empfa¨ngeraktualisierungsdienstes zu einem fehlerhaften Zustand der Systemaufsicht fu¨hren ko¨nnen, meldet die Exchange-Fehlerberichterstattung außerdem Zugriffsverletzungen und sonstige interne Fehler, die im Empfa¨ngeraktualisierungsdienst auftreten.

Sie ko¨nnen jeden Exchange-Server so konfigurieren, dass Informationen u¨ber schwerwiegende Fehler gesendet werden, indem Sie ein Kontrollka¨stchen auf der Servereigenschaftenseite im Exchange-System-Manager aktivieren.

So konfigurieren Sie Exchange 2000 Server bzw. Exchange Server 2003, dass Daten u¨ber schwerwiegende Fehler auf Servern an Microsoft gesendet werden

  1. O¨ffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Administrative Gruppen, erweitern Sie die administrative Gruppe, erweitern Sie Server, klicken Sie mit der rechten Maustaste auf den Server, und klicken Sie dann auf Eigenschaften. Wenn der Knoten Administrative Gruppen im Exchange-System-Manager nicht angezeigt wird, erweitern Sie Server, klicken Sie mit der rechten Maustaste auf Ihren Server, und klicken Sie dann auf Eigenschaften.

  3. Aktivieren Sie auf der Seite Eigenschaften von<Servername> auf der Registerkarte Allgemein das Kontrollka¨stchen Informationen u¨ber schwerwiegende Dienstfehler automatisch an Microsoft senden, und klicken Sie dann auf U¨bernehmen.

  4. Klicken Sie auf Ja, um zu besta¨tigen, dass die Exchange-Fehlerberichterstattung aktiviert werden soll.

  5. Klicken Sie auf OK.

Wenn ein schwerwiegender Fehler aufgetreten ist, wird eine komprimierte Fehlerberichtsdatei (von normalerweise 10 bis 50 Kilobyte) erstellt. Dieser Bericht entha¨lt u. a. eine Abbilddatei. Eine Abbilddatei ist eine Datei mit Informationen u¨ber den Prozess, in dem der Fehler aufgetreten ist. Obwohl Fehler auf verschiedenen Programmebenen auftreten ko¨nnen (beispielsweise auf der Threadebene, auf der Schnittstellenebene und auf der Methoden- bzw. Funktionsebene), ko¨nnen alle Fehler im Kontext eines einzigen Prozesses auftreten. Die Abbilddatei entha¨lt typischerweise Informationen u¨ber den fehlerhaften Prozess, beispielsweise Angaben u¨ber die von den einzelnen Threads ausgefu¨hrten Vorga¨nge, Informationen u¨ber die verschiedenen vom Prozess verwendeten Speicherbereiche, Systeminformationen und andere relevante Debuginformationen. In Exchange Server enthalten die Fehlerberichte außerdem Informationen u¨ber den Status von Exchange Server, Versionsinformationen zum Betriebssystem, Einzelheiten zur Hardware des Computers, die IP-Adresse des betreffenden Computers sowie eine digitale Produkt-ID, mit der die Produktlizenz identifiziert wird.

Das Ziel von Microsoft besteht nicht im Erfassen perso¨nlicher Daten. Es wird jedoch darauf verwiesen, dass Ihr System anhand einiger der erfassten Informationen eindeutig identifiziert werden ko¨nnte. Microsoft verwendet die Daten jedoch nicht zu diesen Zwecken, sondern ausschließlich zum Erstellen von Absturzberichten und zum Beheben von Bugs. Weitere Informationen finden Sie in den Richtlinien zur Fehlerberichterstattung, „Data Collection Policy" unter (http://go.microsoft.com/fwlink/?LinkId=33818).


Für diesen Exchange-Front-End-Server ist in der Datei „Boot.ini" der Startschalter „/3GB" festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_OperatingSystem ab, um die Größe des virtuellen Adressraums zu bestimmen, der Benutzermodusprozessen (MaxProcessMemorySize) auf dem ExchangeServer-Computer zugewiesen ist. Microsoft Exchange Server Analyzer überprüft auch die WMI-Klasse Exchange_Server im Namespace root\MicrosoftExchangeV2, um den Wert für den Schlüssel IsFrontEndServer zu bestimmen. Der Wert False gibt an, dass der Exchange Server-Computer kein Front-End-Server ist. Der Wert True gibt an, dass der Exchange Server-Computer ein Front-End-Server ist.

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel MaxProcessMemorySize nicht 2097024 beträgt und dass der Schlüssel IsFrontEndServer auf den Wert True festgelegt ist, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass der Exchange Server-Computer für die optimale Speicherverwendung nicht ordnungsgemäß konfiguriert ist, da in der Datei Boot.ini der Startschalter /3GB festgelegt wurde. Dieser Schalter sollte nur auf Exchange Servern mit einem Speicher ab 1 GB verwendet werden, auf denen eines der folgenden Betriebssysteme ausgeführt wird:

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Wichtig:
Der /3GB-Schalter darf nicht unter Windows 2000 Server verwendet werden, da er nicht unterstützt wird und zu Abstürzen des Betriebssystems oder von Anwendungen führen kann. Darüber hinaus wird der /3GB-Schalter unter den oben genannten Betriebssystemen nur unterstützt, wenn ein physischer Speicher von mindestens 1 GB verfügbar ist.

Wenn der /3GB-Parameter in der Datei Boot.ini eines Servers unter Microsoft Windows 2000 Server oder Windows Server 2003 enthalten ist, weist Windows 3 GB des maximal 4 GB großen virtuellen Adressraums dem Benutzerprozess und 1 GB dem Kernel zu. Normalerweise (wenn der /3GB-Parameter nicht verwendet wird) weist Windows dem Benutzerprozess und dem Kernel jeweils 2 GB zu. Speicherintensive Anwendungen können daher bei Verwendung des /3GB-Schalters über einen größeren virtuellen Adressraum verfügen, sodass die Leistung verbessert wird.

Die Verwendung des /3GB-Schalters ist in erster Linie für speicherintensive Anwendungsprozesse wie Store.exe auf Exchange-Servern mit Benutzerpostfächern hilfreich. Auf Front-End-Servern befinden sich keine Benutzerpostfächer. Daher profitieren Front-End-Server nicht von der Verwendung des /3GB-Schalters.

So beheben Sie diese Warnmeldung

  1. Navigieren Sie in Windows Explorer zur Systempartition.

  2. Wenn die Datei boot.ini nicht angezeigt wird, kann dies daran liegen, dass in den Ordneroptionen die Option Geschützte Systemdateien ausblenden festgelegt ist. Wenn dies der Fall ist, klicken Sie im Windows Explorer auf Extras, klicken Sie auf Ordneroptionen, und klicken Sie dann auf die Registerkarte Ansicht. Deaktivieren Sie das Kontrollkästchen Geschützte Systemdateien ausblenden (empfohlen). Klicken Sie im angezeigten Warnungsfeld auf Ja.

  3. Wenn die Datei Boot.ini in Windows Explorer angezeigt wird, klicken Sie mit der rechten Maustaste auf die Datei, klicken Sie auf Öffnen mit, und wählen Sie dann Editor aus, um die Datei zu öffnen.

  4. Löschen Sie im Abschnitt [Operating Systems] aus allen Startzeilen die folgenden Schalter: /3GB

  5. Speichern Sie die Änderungen, und schließen Sie Editor.

  6. Starten Sie den Computer neu, damit die Änderung wirksam wird.

Weitere Details zum Verwenden des /3GB-Startschalters finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 297812, „How to Use the 4GT RAM Tuning Feature" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, „The effects of 4GT tuning on system Page Table Entries" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 31679, „How to Use the /USERVA Switch in the Boot.ini File to Tune /3GB Configurations" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, „SO WIRD'S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" (http://support.microsoft.com/?kbid=325044)

  • 815372, „Optimieren der Speichernutzung in Exchange Server 2003" (http://support.microsoft.com/default.aspx?scid=kb;de;815372)


Exchange-IFS-Laufwerk wurde nicht ausdrücklich von Windows Backup ausgeschlossen.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Dateien und Ordner zu ermitteln, die von mithilfe von Backup durchgeführten Sicherungsvorgängen ausgenommen wurden:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

Exchange Server Analyzer sucht insbesondere nach einem Zeichenfolgenwert mit dem Namen Exchange IFS.

Exchange Server Analyzer liest zudem den folgenden Registrierungseintrag, um den Laufwerksbuchstaben abzurufen, der das IFS-Laufwerk (Installable File System) von Exchange darstellt:

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

Unter Exchange 2000 Server lautet der Standardlaufwerksbuchstabe M. Das IFS-Laufwerk ist in Exchange Server 2003 in der Standardeinstellung deaktiviert.

Wenn Exchange Server Analyzer ermittelt, dass der Schlüssel FilesNotToBackup keine Zeichenfolge mit dem Namen Exchange IFS enthält, oder wenn er Exchange IFS enthält, aber der Wert von Exchange IFS nicht gleich M:\* /s ist (wobei M für den Laufwerksbuchstaben steht, der IFS repräsentiert), wird eine Warnung angezeigt.

In der Standardeinstellung, wenn die IFS-Laufwerksbuchstabenzuordnung aktiviert ist, wird Exchange IFS zum Registrierungsschlüssel FilesNotToBackup hinzugefügt. Das Laufwerk M:\ ist kein echtes Laufwerk, sondern eine logische Ansicht des Exchange-Speichers, und dessen Sicherung kann erhebliche Probleme verursachen, z. B. dass Anhänge verloren gehen. Außerdem kann es vorkommen, dass die Aktualisierungssoftware die Protokolldateien nicht richtig abschneidet, was dazu führen kann, dass der Server unerwartet zu wenig Festplattenspeicherplatz zur Verfügung hat.

Wenn Sie Backup nicht verwenden, können Sie diese Warnung ignorieren. Andernfalls wird empfohlen, das IFS-Laufwerk von allen Sicherungsaufträgen auszuschließen. Wenn Sie das IFS-Laufwerk mit Backup oder einem beliebigen anderen Sicherungsprogramm sichern, werden möglicherweise die Informationsspeicherdatenbanken beschädigt, und Sie verlieren Daten und können keine Daten von einer Sicherung des IFS-Laufwerks wiederherstellen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie dieses Problem

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

  3. Klicken Sie mit der rechten Maustaste auf FilesNotToBackup, und klicken Sie dann auf New | Multi-string value. Geben Sie als Namen Exchange IFS ein, und drücken Sie die EINGABETASTE.

  4. Doppelklicken Sie im rechten Bereich auf Exchange IFS, und geben Sie den Wert M:\* /s ein. Stellen Sie sicher, dass Sie den richtigen Laufwerksbuchstaben eingeben, falls Ihr System den Laufwerksbuchstaben M nicht verwendet.

  5. Schließen Sie den Registrierungs-Editor.

Weitere Informationen zur Microsoft Windows-Registrierung finden Sie im Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" (http://support.microsoft.com/kb/256986/de).

Weitere Informationen zum Sichern und Wiederherstellen von Exchange finden Sie im Exchange Server 2003-Handbuch zur Wiederherstellung nach Datenverlust (http://www.microsoft.com/downloads/details.aspx?FamilyID=a58f49c5-1190-4fbf-aede-007a8f366b0e&DisplayLang=de). Weitere Informationen finden Sie in den folgenden Knowledge Base-Artikeln:

  • 258243, „SO WIRD'S GEMACHT: Sichern und Wiederherstellen eines Exchange-Computers mithilfe des Windows-Sicherungsprogramms" (http://support.microsoft.com/kb/258243/de).

  • 233427, „Files and folders that are not backed up when the Ntbackup.exe tool is used in Windows Server 2003, Windows XP, and Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=233427).

Weitere Informationen zu Problemen, die beim Prüfen des IFS-Laufwerks durch Antivirus-Software auftreten können, finden Sie in den folgenden Knowledge Base-Artikeln:

  • 298924, „XADM: Durch eine Sicherung bzw. Überprüfung des Laufwerks "M" von Exchange 2000 verursachte Probleme" unter http://support.microsoft.com/kb/298924/de.

  • 300608, „XADM:C1041737 Err Msg Displayed When You Mount Databases" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, „XADM: Kalenderelemente verschwinden aus Benutzerordnern" (http://support.microsoft.com/kb/299046/DE/)


Dieser Exchange-Postfachserver verfügt über 1 GB Arbeitsspeicher oder mehr, allerdings ist für ihn in der Datei „Boot.ini" der Schalter „/3GB" nicht festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer fragt zwei WMI-Klassen (Microsoft Windows® Management Instrumentation) ab, um die Menge des physischen Speichers für den Exchange-Server und den virtuellen Adressraum zu bestimmen, der für Prozesse im Benutzermodus zugewiesen ist. In der folgenden Tabelle werden die Klassen und Schlüssel beschrieben, die von Exchange Server Analyzer ausgewertet werden.

Abgefragte Klasse | Abgefragte Schlüssel | Beschreibung
Win32_OperatingSystem | MaxProcessMemorySize | Maximaler Speicher in KB, der einem Prozess zugewiesen werden kann.
Win32_OperatingSystem | OSProductSuite | Installierte und lizenzierte Systemprodukterweiterungen für das Betriebssystem.
Win32_ComputerSystem | TotalPhysicalMemory | Größe des Arbeitsspeichers (RAM - Random Access Memory) in Byte, der im Computer installiert ist.

Wenn Exchange Server Analyzer feststellt, dass auf dem Exchange Server-Computer nicht Windows 2000 Server ausgeführt wird, mindestens 1 Gigabyte (GB) an physischem Speicher installiert ist und der Wert für MaxProcessMemorySize größer als 2097024 und kleiner als 3104640 ist, wird eine Warnung angezeigt.

Diese Warnung gibt an, dass der Exchange-Server nicht den Anforderungen entspricht, die im Microsoft Knowledge Base-Artikel 266096 „XGEN: Exchange 2000 erfordert Befehlszeilenoption "/3GB" bei mehr als 1 Gigabyte physischem RAM" unter http://support.microsoft.com/?kbid=266096 festgelegt sind. Dies ist keine empfohlene Produktionskonfiguration.

Microsoft Windows Server™ 2003 bietet Unterstützung für zwei Startschalter (/3GB und /USERVA), mit denen die Zuweisung des verwendeten Speichers und Speicheradressraums festgelegt werden kann. Ungeachtet der Menge des physischen Speichers im System verwendet Windows einen virtuellen Adressraum von 4 GB, wobei 2 GB Prozessen im Benutzermodus (z. B. Anwendungen) und 2 GB Prozessen im Kernelmodus (z. B. Treiber für das Betriebssystem und den Kernelmodus) zugewiesen sind. In Systemen mit mindestens 1 GB an physischem Speicher kann mithilfe dieser beiden Startschalter Anwendungen mehr Speicher (3 GB) und dem Betriebssystem weniger Speicher (1 GB) zugewiesen werden. Durch diesen zusätzlichen virtuellen Adressraum wird das Ausmaß der Speicherfragmentierung im virtuellen Adressraum für den Prozess des Exchange-Informationsspeichers verringert.

Der /3GB-Schalter wird verwendet, um diese Zuordnungsänderung zu bewirken. Der Schalter wird in der Boot.ini des Systems eingegeben, und die Änderung wird nach einem Neustart des Systems wirksam. Dieser Schalter sollte nur auf Exchange-Servern mit einem Speicher ab 1 GB verwendet werden, auf denen eines der folgenden Betriebssysteme ausgeführt wird:

  • Microsoft Windows Server 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Wichtig:
Der /3GB-Schalter darf nicht unter Windows 2000 Server verwendet werden, da er nicht unterstützt wird und zu Abstürzen des Betriebssystems oder von Anwendungen führen kann. Darüber hinaus wird der /3GB-Schalter unter den oben genannten Betriebssystemen nur unterstützt, wenn ein physischer Speicher von mindestens 1 GB verfügbar ist.

Der Schalter /USERVA wurde neu in Windows Server 2003 eingeführt. Mithilfe des Schalters kann die Unterteilung des virtuellen Adressraums zwischen Prozessen im Benutzermodus und Prozessen im Kernelmodus präziser gesteuert werden. Dieser Schalter darf nur für Anwendungen verwendet werden, die ihn unterstützen (beispielsweise von Exchange 2000 Server und Exchange Server 2003), und mit den jeweiligen von diesen Anwendungen unterstützten Werten.

Hinweis:
Der technische Support von Microsoft unterstützt keine willkürlichen Einstellungen für /USERVA. Diese Einstellung sollte von Kunden nur auf ausdrückliche Empfehlung des Herstellers zur Datei Boot.ini hinzugefügt werden.

Bei Verwendung in Exchange Server 2003-Systemen ist der einzige unterstützte Wert von /USERVA 3030 (z. B. /USERVA=3030). Dieser Wert bewirkt, dass dem Betriebssystem zusätzlich 40 MB zugewiesen werden, sodass Sie weitere Benutzer hinzufügen können, ohne dass alle verfügbaren Systemressourcen belegt werden.

So beheben Sie diese Warnmeldung

  1. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und wählen Sie Eigenschaften aus. Das Dialogfeld Systemeigenschaften wird angezeigt.

  2. Klicken Sie auf die Registerkarte Erweitert.

  3. Klicken Sie im Bereich Starten und Wiederherstellen auf Einstellungen. Das Dialogfeld Starten und Wiederherstellen wird angezeigt.

  4. Klicken Sie im Bereich Systemstart auf Bearbeiten. Dadurch wird die Windows-Datei Boot.ini in Microsoft Editor geöffnet.

  5. Fügen Sie im Abschnitt [Operating Systems] am Ende der Zeile startup mit dem Schalter /fastdetect die folgenden Schalter hinzu: /3GB /USERVA=3030

  6. Speichern Sie die Änderungen, und schließen Sie Editor.

  7. Klicken Sie zweimal auf OK, um die geöffneten Dialogfelder zu schließen, und starten Sie den Exchange Server-Computer neu, damit die Änderung wirksam wird.

Weitere Informationen über das Optimieren der Speicherverwendung und Leistung in Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 266096, „Exchange 2000 erfordert Befehlszeilenoption "/3GB" bei mehr als 1 Gigabyte physischem RAM" unter http://support.microsoft.com/?kbid=266096

  • 325044, „SO WIRDS GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044

  • 815372, „Optimieren der Speichernutzung in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372

  • 810371, „XADM: Using the /Userva Switch on Windows Server 2003-Based Exchange Servers" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371

  • 823440, „Sie müssen die Startoption "/3GB" verwenden, wenn Sie Exchange Server 2003 auf einem Windows Server 2003-System installieren" unter http://support.microsoft.com/kb/823440/de

  • 822178, „Überblick über Abhängigkeiten und Anforderungen für Exchange Server 2003-Funktionen" (http://support.microsoft.com/?kbid=822178)


Die Exchange-Anbieterverfolgung ist aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-06-20

Das Tool Microsoft Exchange Server Analyzer fragt den Active Directory-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Objekte mit der Objektklasse msExchExchangeServer zu ermitteln. Wenn der Zeichenfolgenwert "Version 5.5" enthält, wird auf dem Computer Microsoft Exchange Server 5.5 ausgeführt. Wenn der Zeichenfolgenwert "Version 6.0" einschließt, wird auf dem Computer Microsoft Exchange 2000 Server ausgeführt. Wenn der Zeichenfolgenwert "Version 6.5" enthält, wird auf dem Computer Microsoft Exchange Server 2003 ausgeführt. Wenn der Zeichenfolgenwert "Version 8.0" enthält, wird auf dem Computer Exchange Server 2007 ausgeführt.

Exchange Analyzer fragt außerdem die WMI-Klasse (Windows Management Instrumentation, Windows-Verwaltungsinstrumentation) CIM_Datafile ab, um den Wert des Schlüssels Version für Emsmdb32.dll (den Exchange-Transportanbieter) zu bestimmen. Der WMI-Schlüssel Version gibt die Buildnummer für diese Datei an.

Exchange Analyzer fragt schließlich den folgenden Registrierungseintrag ab, um zu ermitteln, ob Exchange-Anbieterverfolgung konfiguriert und aktiviert wurde.

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Enable Tracing

Exchange Analyzer zeigt eine Fehlermeldung an, wenn folgende Bedingungen zutreffen:

  • Der Server führt nicht Exchange-Server 2007 aus.

  • Der Schlüssel Version für Emsmdb32.dll ist 6.5.7233.47 oder eine höhere Version.

  • Der Eintrag HKML\Software\Microsoft\Exchange\Exchange Provider\Enable Tracing ist vorhanden und auf einen anderen Wert als 0 festgelegt.

Dieser Fehler zeigt an, dass Exchange-Transportanbieterverfolgung auf dem Computer aktiviert ist.

Die Versionen des Exchange-Transportanbieters ab Version 6.5.7233.47 und höher verfügen über integrierte Verfolgungsfunktionen. Eine TTD-Datei ermöglicht das Verfolgen der folgenden Programme:

  • Aller Programme, die MAPI auf dem Server verwenden, der Exchange Server 2003 ausführt.

  • Aller Programme, die mithilfe der Microsoft Exchange-Systemverwaltungstools installiert wurden.

Exchange-Transportanbieterverfolgung sollte nur für aktive Problembehandlung aktiviert werden. Andernfalls können negative Auswirkungen auf die normale Serverleistung auftreten.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema "Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So deaktivieren Sie Exchange-Anbieterverfolgung für Exchange Server 2003

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Suchen Sie nach dem folgenden Schlüssel: HKML\Software\Microsoft\Exchange\Exchange Provider\

  3. Gehen Sie im rechten Navigationsbereich folgendermaßen vor:

    1. Klicken Sie mit der rechten Maustaste, und löschen Sie den Unterschlüssel Enable Tracing, oder

    2. Doppelklicken Sie auf Enable Tracing.

  4. Konfigurieren Sie den Unterschlüssel Enable Tracing mit einem Wert von 0.

  5. Schließen Sie den Registrierungs-Editor.

  6. Starten Sie den Exchange-Informationsspeicher neu, damit die Änderungen wirksam werden.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, Beschreibung der Microsoft Windows-Registrierung.


Der Exchange-Verwaltungsdienst wird nicht als „LocalSystem" ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Service ab, um den Wert der StartName-Eigenschaft für den Microsoft Exchange-Verwaltungsdienst (MSExchangeMGMT) zu bestimmen. Wenn Exchange Server Analyzer ermittelt, dass der Dienst Exchange-Verwaltung unter einem anderen Konto als LocalSystem (SYSTEM) ausgeführt wird, zeigt Exchange Server Analyzer einen Fehler an.

Dieser Fehler gibt an, dass der Dienst Exchange-Verwaltung nicht in einer unterstützten Konfiguration ausgeführt wird. Wenn Sie den Dienst Exchange-Verwaltung unter einem anderen Konto ausführen, führt dies zu Berechtigungs- und Zugriffsfehlern.

Um diesen Fehler zu beheben, müssen Sie den Exchange-Verwaltungsdienst so konfigurieren, dass er unter dem Konto LocalSystem (auch SYSTEM) startet.

So konfigurieren Sie das Konto für den Dienst Exchange-Verwaltung

  1. Öffnen Sie das MMC-Snap-In (Microsoft Management Console) Dienste.

  2. Suchen Sie den Dienst Microsoft Exchange-Verwaltung, und beenden Sie ihn.

  3. Doppelklicken Sie auf den Dienst Microsoft Exchange-Verwaltung.

  4. Wählen Sie auf der Seite Eigenschaften von Microsoft Exchange-Verwaltung auf der Registerkarte Anmelden unter Anmelden als das Konto Lokales Systemkonto aus, und klicken Sie dann auf Übernehmen.

  5. Klicken Sie unter Dienststatus auf Start, und klicken Sie dann auf OK.

  6. Schließen Sie das Snap-In Dienste.

Weitere Informationen über das Ausführen von Exchange-Diensten unter dem Konto LocalSystem finden Sie im Microsoft Knowledge Base-Artikel 239762, „Exchange Services Run Under LocalSystem" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762.


Der Exchange-Verwaltungsdienst wird beendet.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_Process ab, um den Wert des Schlüssels Started für die MSExchangeMGMT-Instanz zu bestimmen, die den Dienst Microsoft Exchange-Verwaltung darstellt. Wenn Exchange Server Analyzer feststellt, dass der Wert des Schlüssels Started für die MSExchangeMGMT-Instanz nicht True ist, wird eine Warnung angezeigt.

Der Dienst Exchange-Verwaltung wurde in Exchange 2000 Service Pack 2 eingeführt. Unter anderem hängt die Ausführung von Funktionen des Exchange Server-Nachrichtenstatus sowie von bestimmten Funktionen des Exchange-System-Managers von diesem Dienst ab.

Mithilfe des Dienstes Exchange-Verwaltung können Sie über die Benutzeroberfläche festlegen, mit welchem Domänencontroller oder globalem Katalogserver Exchange Server 2003 bzw. Exchange 2000 Server auf den Active Directory®-Verzeichnisdienst zugreifen. Dieser Dienst ist auch für die Verfolgung von Nachrichten erforderlich. Sie können diesen Dienst deaktivieren, ohne dass die Kernfunktionen von Exchange beeinträchtigt werden. Wenn Sie jedoch die Exchange Server-Funktionen überwachen, benötigen Sie u. U. Funktionen zum Verfolgen von Nachrichten für alle Exchange Server-Computer, von denen E-Mail-Nachrichten weitergeleitet werden.

Hinweis:
Da von Front-End-Servern häufiger auf E-Mail-Nachrichten zugegriffen wird, anstatt diese weiterzuleiten, muss der Dienst Exchange-Verwaltung möglicherweise auf den Front-End-Servern nicht ausgeführt werden.

So konfigurieren Sie den Dienst Exchange-Verwaltung, sodass er automatisch gestartet wird

  1. Öffnen Sie das MMC-Snap-In (Microsoft Management Console) Dienste.

  2. Doppelklicken Sie auf den Dienst Microsoft Exchange-Verwaltung.

  3. Wählen Sie auf der Seite Eigenschaften von Microsoft Exchange-Verwaltung auf der Registerkarte Allgemein im Dialogfeld Starttyp die Option Automatisch aus, und klicken Sie dann auf Übernehmen.

  4. Klicken Sie unter Serverstatus auf Start, und klicken Sie dann auf OK.

Weitere Informationen über den Dienst Exchange-Verwaltung finden Sie im Microsoft Knowledge Base-Artikel 307413 „XGEN: General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105).

Weitere allgemeine Informationen zur Verwaltung von Exchange finden Sie im Exchange Server 2003-Administratorhandbuch (http://go.microsoft.com/fwlink/?LinkId=47617).


Exchange 2000 Server führt das neueste Service Pack nicht aus.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs versionNumber für jedes ExchangeServer-Objekt zu ermitteln. Das Attribut versionNumber gibt die Exchange Server-Version an, die auf dem Computer ausgeführt wird.

Exchange Server Analyzer fragt außerdem die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile ab, um den für den Prozess STORE.EXE festgelegten Wert des Schlüssels Version zu ermitteln. Falls Exchange Server Analyzer bestimmt, dass der Schlüssel Version für STORE.EXE einen größeren Wert als 4416 aufweist und kleiner oder gleich 6249 ist, wird eine Warnmeldung angezeigt.

Diese Warnung gibt an, dass auf dem Exchange Server-Computer nicht der neueste verfügbare Code für die Exchange-Version auf dem Computer ausgeführt wird.

So beheben Sie diese Warnmeldung

  1. Downloaden Sie Exchange Server 2000 Service Pack 3 unter http://go.microsoft.com/fwlink/?LinkId=17058.

  2. Lesen Sie das Handbuch für die Bereitstellung von Exchange 2000 Server Service Pack 3 (http://go.microsoft.com/fwlink/?LinkId=12337).

  3. Downloaden Sie das neueste Update (August 2004) von http://go.microsoft.com/fwlink/?LinkId=33457.

  4. Weitere Informationen zum neuesten Update erhalten Sie im Microsoft Knowledge Base-Artikel 870540 „Availability of the August 2004 Exchange 2000 Server Post-Service Pack 3 Update Rollup" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540.

  5. Nehmen Sie eine vollständige Sicherung des Exchange Server-Computers vor.

  6. Wenden Sie das Service Pack 3 von Exchange 2000 Server an.

  7. Wenden Sie das Update von August 2004 an.

Weitere Informationen zum Beziehen des neuesten Service Packs für Exchange 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 301378, „Wie Sie das neueste Service Pack für Exchange 2000 Server erhalten" unter (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378).

Weitere Informationen zum Installieren dieser und anderer Exchange Server-Updates finden Sie im Knowledge Base-Artikel 328839 „Wie Sie Service Packs und Hotfixes für Exchange anwenden" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839.


Exchange 2000 Server wird unter Windows Server 2003 nicht unterstützt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Version des Microsoft Windows®-Betriebssystems zu bestimmen, die auf dem Exchange Server-Computer ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Der Wert 4.0 für CurrentVersion gibt an, dass auf dem Computer Microsoft Windows NT Server 4.0 ausgeführt wird. Der Wert 5.0 gibt an, dass auf dem Computer Windows 2000 Server ausgeführt wird, und der Wert 5.2 gibt an, dass auf dem Computer Windows Server™ 2003 ausgeführt wird.

Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber aller Verzeichnisobjekte mit der Objektkategorie msExchExchangeServer zu ermitteln. Wenn der Zeichenfolgenwert Version 5.5 einschließt, wird auf dem Computer Microsoft Exchange Server Version 5.5 ausgeführt. Wenn der Zeichenfolgenwert Version 6.0 enthält, wird auf dem Computer Microsoft Exchange 2000 Server ausgeführt. Wenn der Zeichenfolgenwert Version 6.5 enthält, wird auf dem Computer Microsoft Exchange Server 2003 ausgeführt.

Wenn Exchange Server Analyzer feststellt, dass der Wert CurrentVersion 5.2 entspricht, und der Wert für serialNumber Version 6,0 einschließt, wird ein Fehler angezeigt. Hierbei handelt es sich um keine unterstützte Konfiguration, und der Fehler sollte so schnell wie möglich behoben werden.

So berichtigen Sie diesen Fehler

  1. Führen Sie einen der folgenden Schritte aus:

    • Installieren Sie Exchange 2000 Server auf einem Server, auf dem ein unterstütztes Betriebssystem ausgeführt wird, und verschieben Sie die Postfächer auf den Server.

    • Aktualisieren Sie Exchange 2000 Server auf Exchange Server 2003.

Weitere Informationen zu unterstützten Konfigurationen finden Sie im Bereitstellungshandbuch für Exchange Server 2003 unter http://go.microsoft.com/fwlink/?LinkId=47569.

Weitere Informationen zu Exchange Server und Windows Server 2003 finden Sie im Microsoft Knowledge Base-Artikel 810591 „Kompatibilität zwischen Exchange Server und Windows Server 2003" unterhttp://support.microsoft.com/default.aspx?scid=kb;de;810591.


Vorabversion von Exchang 2007 ist installiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-02-20

Microsoft Exchange Server Analyzer fragt den Active Directory-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Exchange Server-Objekte im Verzeichnis zu bestimmen. Das Attribut serialNumber ist ein Zeichenfolgenwert, der die Version von Exchange Server und die Version des Service Packs umfasst, falls dieses installiert wurde. Falls z. B. auf einem Exchange Server 2007-Computer kein Service Pack installiert ist, ist das Attribut serialNumber gleich Version 8.0 (Build 0685).

Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs serialNumber in seiner Zeichenfolge 8.0, aber eine Buildnummer kleiner als 0685 enthält, wird ein Fehler angezeigt.

Dieser Fehler weist darauf hin, dass auf dem Exchange Server 2007-Computer eine Vorabversion von Exchange Server 2007 ausgeführt wird.

Installationen von Exchange Server 2007-Vorabversionen werden für Produktionsumgebungen nicht unterstützt.

Um diesen Fehler zu beheben, installieren Sie eine Produktionsversion von Exchange Server 2007.


Das Exchange 2007-Serverobjekt wurde in eine andere administrative Gruppe verschoben
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-08-11

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Exchange Server-Objekte im Verzeichnis zu bestimmen.

Exchange Server Analyzer fragt darüber hinaus den Wert des Attributs cn der administrativen Gruppe ab, in der sich der Server mit Exchange Server befindet und kann auf diese Weise ermitteln, ob dies die dedizierte administrative Gruppe von Exchange 2007 ist: Exchange - Administrative Gruppe (FYDIBOHF23SPDLT).

Wenn Exchange Server Analyzer feststellt, dass auf dem Server Microsoft Exchange Server 2007 ausgeführt wird, wobei sich der Server jedoch in einer anderen administrativen Gruppe als Exchange - Administrative Gruppe (FYDIBOHF23SPDLT) befindet, zeigt Exchange Server Analyzer einen Fehler an.

Dieser Fehler weist darauf hin, dass der Server möglicherweise aus der dedizierten administrativen Exchange 2007-Gruppe verschoben wurde und möglicherweise Probleme mit der Nachrichtenübermittlung verursacht.

Das Attribut serialNumber ist ein Zeichenfolgewert, der die Version von Exchange Server und ggf. die Version des Service Packs enthält. Wenn das Attribut serialNumber den Wert Version 8.0 auf, bedeutet dies, dass auf dem Server Exchange 2007 ausgeführt wird.

In Microsoft Exchange Server 2003 und Microsoft Exchange 2000 Server werden Exchange-Objekte in administrativen Gruppen zusammengefasst, um die Berechtigung zum Verwalten dieser Objekte zu delegieren. In Exchange 2007 werden administrative Gruppen nicht als logische Verwaltungseinheit eingesetzt. Zur Unterstützung der Koexistenz von Exchange Server 2003 oder Exchange 2000 Server und Exchange 2007 werden alle Server mit Exchange 2007 beim Installieren von Exchange 2007 automatisch in einer einzigen administrativen Gruppe hinzugefügt. Diese administrative Gruppe wird im Exchange-System-Manager von in Exchange Server 2003 als Exchange - Administrative Gruppe (FYDIBOHF23SPDLT) erkannt.

Um dieses Problem zu beheben, müssen Sie den Server entfernen und anschließend neu installieren.


Exchange auf einem Domänencontroller, der kein globaler Katalogserver ist
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-09

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_ComputerSystem ab, um den aktuellen Wert des Schlüssels DomainRole zu bestimmen. In der folgenden Tabelle werden die gültigen Werte für diesen Schlüssel aufgeführt.

Wert | Bedeutung
0 | Eigenständige Workstation
1 | Mitgliedsworkstation
2 | Eigenständiger Server
3 | Mitgliedsserver
4 | Sicherungsdomänencontroller
5 | Primärer Domänencontroller

Exchange Server Analyzer fragt außerdem die WMI-Klasse Win32_Service ab, um den Wert des Schlüssels Started für den Windows-Clusterdienst ClusSvc zu bestimmen. Darüber hinaus fragt Exchange Server Analyzer die WMI-Klasse Win32_OperatingSystem ab, um den Wert des Schlüssels OSProductSuite zu ermitteln. Der Wert des Schlüssels OSProductSuite gibt die Version von Windows an, die auf dem Computer ausgeführt wird.

Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Verzeichnisobjekte mit der Objektkategorie msExchExchangeServer zu ermitteln. Der Wert für das Attribut serialNumber gibt die verwendete Version von Exchange Server an.

Schließlich sendet Exchange Server Analyzer eine Abfrage an Active Directory, um den Wert des Attributs isGlobalCatalogReady für diesen Server zu ermitteln. Der Wert True für dieses Attribut gibt an, dass der Verzeichnisserver auch als globaler Katalogserver fungiert. Der Wert False gibt an, dass der Verzeichnisserver kein globaler Katalogserver ist.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel DomainRole auf einem Exchange Server-Computer größer ist als 3, dass auf dem Exchange Server-Computer nicht Windows Small Business Server oder Exchange Server 5.5 ausgeführt wird oder er in einem Windows-Cluster ausgeführt wird und dass das Attribut isGlobalCatalogReady auf False festgelegt ist, wird eine Warnung angezeigt.

Diese Warnung verweist darauf, dass Exchange Server auf einem Verzeichnisserver ausgeführt wird, der nicht als globaler Katalogserver fungiert. Diese Konfiguration wird nicht unterstützt und kann zu Fehlern bei Exchange-Diensten führen.

Wenn Sie Exchange Server auf einem Domänencontroller ohne Small Business Server ausführen, müssen Sie Folgendes berücksichtigen:

  • Sowohl Exchange Server als auch Active Directory sind ressourcenintensive Anwendungen. Es sind Leistungseinschränkungen zu bedenken, wenn beide Anwendungen auf demselben Computer ausgeführt werden.

  • Wenn Exchange Server auf einem Domänencontroller ausgeführt wird, muss dieser Domänencontroller auch als globaler Katalogserver konfiguriert werden.

  • Mehrere Verzeichniskomponenten von Exchange Server, z. B. der Verzeichnisdienstzugriff (DSAccess), der Verzeichnisdienstproxy (DSProxy) und das Nachrichtenkategorisierungsmodul, führen keinen Failover zu anderen Domänencontrollern oder zum globalen Katalogserver durch.

  • Sie sollten keinen Gebrauch vom Startschalter /3GB in Windows machen, weil dies dazu führen könnte, dass Exchange Server den ganzen Speicher verbraucht und damit für Active Directory nicht genügend Speicher bleibt.

  • Das Herunterfahren des Systems dauert erheblich länger, wenn die Exchange Server-Dienste nicht vor dem Herunterfahren und Neustarten des Servers beendet werden.

  • Diese Konfiguration ist weniger sicher, weil Exchange-Administratoren über lokalen administrativen Zugriff auf Active Directory verfügen, womit sie ihre eigenen Rechte weiter ausbauen können. Außerdem zwingt jede in Exchange Server oder Active Directory gefundene Sicherheitslücke die anderen zum Kompromiss.

  • Wenn Sie Exchange Server 2003 oder Exchange Server 2007 auf einem Domänencontroller ausführen, wird die Verwendung des Tools zum Hochstufen von Domänencontrollern (DCPromo) für eine Änderung der Rolle des Computers nicht unterstützt, weil dadurch Komponenten wie Microsoft Outlook® Mobile Access nicht mehr ordnungsgemäß funktionieren.

  • Die Ausführung von Exchange Server 2003 oder Exchange Server 2007 auf einem Clusterknoten, der auch ein Active Directory-Domänencontroller ist, wird nicht unterstützt und sollte niemals erfolgen. D. h., wenn Sie Exchange 2000 Server auf einem Knoten in einem Cluster ausführen, der auch ein Domänencontroller ist, müssen Sie den Server zu einem Mitgliedsserver degradieren, bevor Sie auf diesem ein Upgrade von Exchange 2000 Server auf Exchange Server 2003 durchführen.

Wenn auf dem Computer Exchange 2000 Server ausgeführt wird, ist es empfehlenswert, dass Sie den Server bei nächster Gelegenheit unter Verwendung von DCPromo zu einem Mitgliedsserver herabstufen. Wenn auf dem Computer Exchange Server 2003 oder Exchange Server 2007ausgeführt wird, verwenden Sie eines der folgenden Verfahren, um dieses Problem zu beheben.

So vermeiden Sie diese Warnung, indem Sie Exchange auf einen anderen Computer übertragen

  1. Installieren Sie Exchange Server auf einem anderen Computer.

  2. Verwenden Sie im Assistenten für Exchange-Aufgaben die Option Postfach verschieben, um alle vorhandenen Postfächer vom Domänencontroller zum neuen Exchange-Server zu verschieben.

  3. Ändern Sie den Stammserver für alle Öffentlichen Ordner und Rollen, die sich auf dem alten Exchange Server-Computer befinden, indem Sie sie auf den neuen Exchange Server-Computer verschieben.

  4. Deinstallieren Sie Exchange Server vom Domänencontroller.
So vermeiden Sie diese Warnung, indem Sie den Exchange-Server zu einem globalen Katalogserver machen

  1. Öffnen Sie Active Directory-Standorte und -Dienste.

  2. Erweitern Sie Standorte, erweitern Sie den Standort, und erweitern Sie dann Server.

  3. Wählen Sie den Domänencontroller aus, den Sie als globalen Katalogserver angeben möchten.

  4. Klicken Sie im rechten Bereich auf NTDS-Einstellungen, und wählen Sie Eigenschaften aus.

  5. Aktivieren Sie auf der Registerkarte Allgemein das Kontrollkästchen Globaler Katalogserver. Wenn auf dem Verzeichnisserver Windows 2000 Server mit Service Pack 2 oder einer früheren Version ausgeführt wird, starten Sie den Server neu, damit die Änderung wirksam wird. Wenn auf dem Verzeichnisserver Windows 2000 Server mit Service Pack 3 bzw. einen höheren Version oder Windows Server™ 2003 ausgeführt wird, wird die Änderung dynamisch ohne Neustart des Servers wirksam.

Weitere Informationen über die Installation von Exchange Server auf einem Domänencontroller finden Sie im Microsoft Knowledge Base-Artikel 250989 „XADM: Installieren des ADC auf einem Windows 2000-Domänencontroller, der auch Exchange Server ausführt" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250989).


Exchange Server 5.5 wurde erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-10-06

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Objekte mit der Objektklasse msExchExchangeServer zu ermitteln. Wenn der Zeichenfolgenwert Version 5.5 enthält, wird auf dem Computer Microsoft Exchange Server, Version 5.5, ausgeführt. Wenn der Zeichenfolgenwert Version 6.0 enthält, wird auf dem Computer Microsoft Exchange 2000 Server ausgeführt. Wenn der Zeichenfolgenwert Version 6.5 enthält, wird auf dem Computer Microsoft Exchange Server 2003 ausgeführt.

Wenn Exchange Server Analyzer feststellt, dass der Wert für serialNumber die Angabe Version 5.5 enthält, wird ein Fehler angezeigt.

Dieser Fehler weist darauf hin, dass die erkannte Version von Exchange Server mit dieser Version von Exchange Server Analyzer nicht weiter analysiert werden kann.

Exchange Server Analyzer ist von verschiedenen spezifischen Programmschnittstellen abhängig, die in der erkannten Version von Exchange Server nicht verfügbar sind.

Zum Beheben dieses Fehlers geben Sie einen Exchange-Server an, auf dem Exchange 2000 oder eine höhere Version ausgeführt wird.

Wenn Sie denken, dass diese Regel fälschlicherweise ausgelöst wurde, überprüfen Sie, ob der Wert für das Attribut serialNumber des Exchange Server-Objekts in Active Directory richtig eingestellt ist.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme können eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder beiden Anwendungen erforderlich machen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So zeigen Sie den Wert des Attributs "serialNumber" an

  1. Starten Sie die ADSI-Bearbeitung.

  2. Doppelklicken Sie auf den Container Konfiguration, erweitern Sie CN=Services, erweitern Sie CN=Microsoft Exchange, und erweitern Sie dann CN=<Name der Exchange-Organisation>.

  3. Erweitern Sie CN=Administrative Groups, erweitern Sie CN=<Name der administrativen Gruppe>, und erweitern Sie dann CN=Servers.

  4. Klicken Sie mit der rechten Maustaste auf das Serverobjekt, und klicken Sie dann auf Eigenschaften.

  5. Doppelklicken Sie auf das Attribut serialNumber, um den aktuellen Wert anzuzeigen.

Weitere Informationen zur Bereitstellung von Exchange Server 2003 finden Sie im "Bereitstellungshandbuch für Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47569).

Weitere Informationen zur Migration von Exchange Server 5.5 zu Exchange Server 2003 finden Sie im Knowledge Base-Artikel 259912, "Voraussetzungen für die Aktualisierung von Exchange Server 5.5 auf Exchange 2000 Server oder Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=259912).

Informationen zur Migration und Aktualisierung auf Exchange Server 2003 finden Sie unter "Aktualisierung auf Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=34186).


Exchange Server 5.5 führt das neueste Service Pack nicht aus.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs versionNumber für jedes ExchangeServer-Objekt zu ermitteln. Das Attribut versionNumber gibt die Exchange Server-Version an, die auf dem Computer ausgeführt wird.

Exchange Server Analyzer fragt außerdem die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile ab, um den für den Prozess STORE.EXE festgelegten Wert des Schlüssels Version zu ermitteln. Falls Exchange Server Analyzer feststellt, dass der Schlüssel Version für STORE.EXE einen Wert größer als 1959, aber kleiner als 2653 aufweist, wird eine Warnmeldung angezeigt. Dies weist darauf hin, dass auf dem Computer eine Vorversion von Exchange Server 5.5 Service Pack 4 ausgeführt wird.

Diese Warnung gibt an, dass auf dem Exchange Server-Computer nicht der neueste verfügbare Code für die Exchange-Version auf dem Computer ausgeführt wird.

So beheben Sie diese Warnmeldung

  1. Downloaden Sie Exchange Server 5,5 Service Pack 4 unter http://go.microsoft.com/fwlink/?LinkId=33456.

  2. Downloaden Sie das neueste Update (Mai 2004) für Exchange Server 5.5 im Microsoft Download Center (http://go.microsoft.com/fwlink/?LinkId=33456).

  3. Weitere Informationen zu diesem Update finden Sie im Microsoft Knowledge Base-Artikel 841765 „May 2004 Update Rollup for Exchange Server 5.5" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=841765.

  4. Nehmen Sie eine vollständige Sicherung des Exchange Server-Computers vor.

  5. Übernehmen Sie Exchange Server 5.5 Service Pack 4.

  6. Verwenden Sie die Aktualisierung vom November 2004.

Weitere Informationen zum Installieren dieser und anderer Exchange Server-Updates finden Sie im Microsoft Knowledge Base-Artikel 328839 „Wie Sie Service Packs und Hotfixes für Exchange anwenden" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839.


Exchange Server 5.5 wird unter Windows 2003 nicht unterstützt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Version des Microsoft Windows®-Betriebssystems zu bestimmen, die auf dem Exchange Server-Computer ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Der Wert 4.0 für CurrentVersion gibt an, dass auf dem Computer Microsoft Windows NT Server 4.0 ausgeführt wird. Der Wert 5.0 zeigt an, dass auf dem Computer Windows 2000 Server ausgeführt wird, und der Wert 5.2 zeigt an, dass auf dem Computer Windows™ Server 2003 ausgeführt wird.

Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber aller Verzeichnisobjekte mit der Objektkategorie msExchExchangeServer zu ermitteln. Wenn der Zeichenfolgenwert Version 5.5 enthält, wird auf dem Computer Microsoft Exchange Server, Version 5.5, ausgeführt. Wenn der Zeichenfolgenwert Version 6.0 enthält, wird auf dem Computer Microsoft Exchange 2000 Server ausgeführt. Wenn der Zeichenfolgenwert Version 6.5 enthält, wird auf dem Computer Microsoft Exchange Server 2003 ausgeführt.

Wenn Exchange Server Analyzer feststellt, dass der Wert CurrentVersion 5.2 entspricht, und der Wert für serialNumber Version 5.5 einschließt, wird ein Fehler angezeigt. Hierbei handelt es sich um keine unterstützte Konfiguration, und der Fehler sollte so schnell wie möglich behoben werden.

So berichtigen Sie diesen Fehler

  • Führen Sie einen der folgenden Schritte aus:

    • Installieren Sie Exchange 5.5 Server auf einem Server, auf dem ein unterstütztes Betriebssystem ausgeführt wird, und verschieben Sie dann die Postfächer auf diesen Server.

    • Führen Sie die Migration von Exchange 5.5 Server zu Exchange Server 2003 aus.

Weitere Informationen zur Bereitstellung von Exchange Server 2003 finden Sie im Bereitstellungshandbuch für Exchange Server 2003 unter http://go.microsoft.com/fwlink/?LinkId=47569.

Weitere Informationen zu Exchange Server und Windows Server 2003 finden Sie im Microsoft Knowledge Base-Artikel 810591, „Kompatibilität zwischen Exchange Server und Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810591).

Weitere Informationen zur Migration von Exchange Server 5.5 zu Exchange Server 2003 finden Sie im Knowledge Base-Artikel 259912, „Prerequisites for Upgrading Exchange Server 5.5 to Exchange 2000 Server or to Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=259912).

Informationen zur Migration und Aktualisierung auf Exchange Server 2003 finden Sie auf der Seite zu Migration und Aktualisierung unter http://go.microsoft.com/fwlink/?LinkId=34186.


Exchange Server 5.0 führt das neuste Service Pack oder das Updaterollup nicht aus
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs versionNumber für jedes ExchangeServer-Objekt zu ermitteln. Das Attribut versionNumber gibt die Exchange Server-Version an, die auf dem Computer ausgeführt wird.

Exchange Server Analyzer fragt außerdem die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile ab, um den für den Prozess STORE.EXE festgelegten Wert des Schlüssels Version zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass der Schlüssel Version für STORE.EXE einen Wert zwischen 1456 und 1460 aufweist, wird eine Warnmeldung angezeigt.

Diese Warnung gibt an, dass auf dem Exchange Server-Computer nicht der neueste verfügbare Code für die Exchange-Version auf dem Computer ausgeführt wird.

So beheben Sie diese Warnmeldung

  1. Downloaden Sie Service Pack 2 für Exchange Server 5.0 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168858).

  2. Lesen Sie die README.TXT-Datei für Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168735).

  3. Downloaden Sie im Microsoft Download Center unter http://go.microsoft.com/fwlink/?LinkId=41361 das neueste Sicherheitsupdate (April 2004) für Exchange Server 5.0.

  4. Informationen zu diesem Update finden Sie im Microsoft Knowledge Base-Artikel 834130 „Update Rollup für Microsoft Exchange 5.0" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=834130.

  5. Nehmen Sie eine vollständige Sicherung des Exchange Server-Computers vor.

  6. Wenden Sie das Service Pack 2 für Exchange Server 5.0 an.

  7. Wenden Sie das Update von April 2004 an.

Weitere Informationen zum Installieren dieser und anderer Exchange Server-Updates finden Sie im Microsoft Knowledge Base-Artikel 328839 „Wie Sie Service Packs und Hotfixes für Exchange anwenden" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839.


Exchange Server 5.5 auf einem Active Directory-Domänencontroller
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_ComputerSystem ab, um den aktuellen Wert des Schlüssels DomainRole zu bestimmen. In der folgenden Tabelle finden Sie gültige Werte für diesen Schlüssel.

Wert | Bedeutung
0 | Eigenständige Workstation
1 | Mitgliedsworkstation
2 | Eigenständiger Server
3 | Mitgliedsserver
4 | Sicherungsdomänencontroller
5 | Primärer Domänencontroller

Exchange Server Analyzer fragt außerdem die WMI-Klasse Win32_Service ab, um den Wert des Schlüssels Started für den Windows-Clusterdienst ClusSvc zu bestimmen.

Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Verzeichnisobjekte mit der Objektkategorie msExchExchangeServer zu ermitteln. Der Wert für das Attribut serialNumber gibt die verwendete Version von Exchange Server an.

Wenn Exchange Server Analyzer ermittelt, dass der Wert des Schlüssels DomainRole auf einem Exchange Server-Computer größer als 3 ist, dass der ExchangeServer-Computer nicht in einem Windows-Cluster ausgeführt wird und dass es sich bei der ausgeführten Exchange-Version um Version 5.5 handelt, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass Exchange Server 5.5 auf einem Active Directory-Server ausgeführt wird. Dies kann Probleme mit dem ADC (Active Directory-Connector) aufgrund eines möglichen Anschlusskonflikts hervorrufen. Wenn ein ADC diesen Server als Ziel verwendet, muss sichergestellt werden, dass die richtige Exchange-LDAP-Anschlussnummer (Lightweight Directory Access Protocol) verwendet wird. In der Standardeinstellung hört der Verzeichnisserver über den TCP-Anschluss 389 LDAP-Anforderungen ab. ADC kann nur mit Exchange kommunizieren, wenn der Anschluss für Exchange geändert wird und ADC für die Verwendung des Exchange-Anschlusses konfiguriert wurde.

Active Directory verwendet den Standard-LDAP-Anschluss 389 für LDAP-Zugriff. Die Verwendung der Standard-Anschlussnummer überschreibt jedoch der Exchange-Server, der sich auf einem Server befindet, der ebenfalls versucht, den LDAP-Anschluss 389 abzuhören. Sie müssen den Exchange-LDAP-Anschluss neu zuordnen, um dem Exchange-Server LDAP-Zugriff auf dessen Verzeichnis zu gewähren.

So beheben Sie diese Warnung

  1. Öffnen Sie den Exchange-Administrator.

  2. Erweitern Sie Standortname, erweitern Sie Konfiguration, erweitern Sie Protokolle, und erweitern Sie dann LDAP (Verzeichnis)-Standortparameter.

  3. Ändern Sie die Zuweisung des Anschlusses von 389 auf einen Anschluss, der zurzeit nicht verwendet wird.

  4. Klicken Sie auf OK, um die Änderung zu speichern.

  5. Starten Sie den Microsoft Exchange-Verzeichnisdienst, sodass die Änderung wirksam wird.

  6. Konfigurieren Sie bei Bedarf einen ADC, für den dieser Server als Ziel festgelegt ist, auf die Verwendung des neues Anschlusses.

Weitere Informationen zum Ändern der LDAP-Anschlusszuweisung in Exchange Server 5.5 finden Sie im Microsoft Knowledge Base-Artikel 224447, „XADM: How to Change LDAP Port Assignments in Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=224447).


Fehler bei der Auflösung des Exchange-Server-DNS-Namens
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer versucht eine DNS-Abfrage (Domain Name System) bei den konfigurierten DNS-Servern für jeden Exchange Server-Computer. Diese Verbindung wird mithilfe eines benutzerdefinierten Objektprozessors hergestellt, der eine Namensauflösung anfordert und die Ergebnisse analysiert. Wenn Microsoft Exchange Server Analyzer keine IP-Adresse aus den Abfrageergebnissen erhält, wird ein Fehler angezeigt.

Dieser Fehler weist darauf hin, dass in DNS kein Exchange Server-Computer gefunden wurde. Für eine ordnungsgemäße Funktionsweise von Exchange Server und dem Active Directory®-Verzeichnisdienst ist ein ordnungsgemäß konfiguriertes und fehlerfreies DNS erforderlich. Probleme bei der DNS-Registrierung und -Auflösung können weitreichende Auswirkungen auf die Funktionen zum Senden, Übermitteln und Empfangen von Nachrichten haben.

DNS muss korrekt konfiguriert werden, um eine ordnungsgemäße Funktionsweise von Active Directory und Exchange Server zu gewährleisten. Ausführlichere Informationen zur DNS-Konfiguration für Active Directory finden Sie im Microsoft Knowledge Base-Artikel 237675, „Einrichten von DNS für Active Directory" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=237675).

So beheben Sie diesen Fehler

  1. Überprüfen Sie die folgenden Konfigurationpunkte, um sicherzustellen, dass DNS einwandfrei funktioniert und die Exchange Server-DNS-Einträge korrekt registriert werden.

    • DNS-IP-Konfiguration

    • Dynamische Zonenaktualisierungnen

    • DNS-Weiterleitungen

  2. Überprüfen Sie, ob ein Stammzoneneintrag vorhanden ist. Zeigen Sie die Zonen für Forward Lookup in der DNS-Verwaltungskonsole an. Dort muss Eintrag für die Domäne vorliegen. Möglicherweise sind auch andere Zoneneinträge vorhanden. Es darf keine Punktzone („.") vorliegen. Ist die Punktzone („.") vorhanden, löschen Sie diese. Die Punktzone („.") identifiziert den DNS-Server als Stammserver. Üblicherweise darf eine Active Directory-Domäne, die externen (Internet-) Zugriff benötigt, nicht als DNS-Stammserver konfiguriert werden. Registrieren Sie manuell die Exchange Server-IP-Adresse mithilfe von Ipconfig /registerdns auf dem Verzeichnisserver erneut , nachdem der Punkt („.") gelöscht wurde. Der Netlogon-Dienst muss möglicherweise ebenfalls neu gestartet werden.

  3. Füllen Sie die Exchange Server-DNS-Einträge mithilfe von netdiag /fix auf dem Exchange Server-Computer erneut manuell auf.

Weitere Informationen zur Verwendung von DNS mit Active Directory finden Sie im Microsoft Knowledge Base-Artikel 323418, „How To Integrate DNS with an Existing DNS Infrastructure If Active Directory Is Enabled in Windows Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=323418.

Weitere Informationen zum Beheben von Problemen mit DNS und Active Directory finden Sie im Knowledge Base-Artikel 260371, „Behandlung häufig auftretender Active Directory-Probleme in Windows 2000" unter http://support.microsoft.com/?kbid=260371.


Der Exchange-Server wurde als Front-End festgelegt und scheint als Host für Postfächer zu dienen.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt das Exchange Server-Microsoft-WMI-Objekt (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) (Klasse Exchange_Server) ab, um den Wert IsFrontEndServer für den Server zu bestimmen. Wenn der Wert True ist, wird der Exchange-Server als Front-End-Server verwendet. Wenn der Server über Postfachspeicher verfügt, fragt Exchange Server Analyzer den Active Directory®-Verzeichnisdienst ab, um die Anzahl der auf dem Server vorhandenen Postfächer zu ermitteln. Jedes Postfachspeicherobjekt (Klasse msExchPrivateMDB) besitzt ein mehrwertiges Attribut homeMDBBL, das alle Postfächer im Speicher auflistet. Durch Zählen dieser Werte erhält Exchange Server Analyzer die Gesamtzahl der Postfächer auf dem Server.

Wenn der Exchange-Server als Front-End-Server festgelegt ist und über mehr als 20 konfigurierte Postfächer verfügt, wird eine Warnung angezeigt.

Je nach Konfiguration kann es für Exchange erforderlich sein, Dienstpostfächer auf dem Front-End-Server einzurichten. Wenn der Front-End-Server z. B. SMTP-Mail (Simple Mail Transfer Protocol) aus dem Internet akzeptiert, benötigt der Exchange-SMTP-Dienst möglicherweise ein spezielles Postfach auf dem Server. Microsoft Exchange Server Analyzer berücksichtigt diese Dienstpostfächer, indem er nur dann eine Warnung anzeigt, wenn mehr als 20 Postfächer auf dem Exchange-Server konfiguriert sind.

Sie sollten keine Benutzerpostfächer auf dem Front-End-Server einrichten. Eine derartige Konfiguration wird nicht unterstützt.

Wenn sich auf dem Front-End-Server Benutzerpostfächer befinden, verschieben Sie diese mit Exchange-System-Manager (nur Exchange Server 2003) oder Active Directory-Benutzer und -Computer auf einen geeigneten Back-End-Server.

So verschieben Sie Postfächer (Exchange 2000 Server oder Exchange Server 2003)

  1. Wählen Sie in Active Directory-Benutzer und -Computer den oder die Benutzer aus, deren Postfächer Sie verschieben möchten.

  2. Klicken Sie mit der rechten Maustaste auf die Benutzerliste, die Sie im vorherigen Schritt ausgewählt haben, und klicken Sie dann auf Exchange-Aufgaben.

  3. Klicken Sie im Assistent für Exchange-Aufgaben auf der Seite Verfügbare Aufgaben auf Postfach verschieben und dann aufWeiter.

  4. Lesen Sie die verbleibenden Schritte im Assistenten sorgfältig und folgen Sie den Anweisungen.

So verschieben Sie Postfächer (nur Exchange Server 2003)

  1. Erweitern Sie im Exchange-System-Manager den Eintrag Server, erweitern Sie den Server, von dem Sie Postfächer verschieben möchten, erweitern Sie die Speichergruppe, von der Sie Postfächer verschieben möchten, erweitern Sie den Postfachspeicher, der die Postfächer enthält, die Sie verschieben möchten, und klicken Sie dann auf Postfächer.

  2. Klicken Sie im Detailbereich mit der rechten Maustaste auf den oder die Benutzer, deren Postfächer Sie verschieben möchten, und klicken Sie dann auf Exchange-Aufgaben.

  3. Klicken Sie im Assistent für Exchange-Aufgaben auf der Seite Verfügbare Aufgaben auf Postfach verschieben und dann aufWeiter.

  4. Lesen Sie die verbleibenden Schritte im Assistenten sorgfältig, und folgen Sie den Anweisungen.

Weitere Informationen zur ordnungsgemäßen Konfigurationen von Exchange Front-End-Servern finden Sie im Microsoft Knowledge Base-Artikel 822443, „Front-End Server Considerations in Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822443)

Allgemeine Empfehlungen zum Bereitstellen und Konfigurieren von Exchange Front-End-Servern finden Sie im Bereitstellungshandbuch für Exchange 2003 Server (http://go.microsoft.com/fwlink/?LinkId=21768).

Weitere Informationen zu Fehlern, die durch das Ausführen von Benutzerpostfächern auf einem Exchange Front-End-Server auftreten können, finden Sie im Knowledge Base-Artikel 273296, „XCON: Users Cannot Retrieve Mail on a Front-End Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=273296).

Weitere Informationen zum Verschieben von Postfächern auf Exchange Server 2003 finden Sie in den folgenden Knowledge Base-Artikeln:

  • 821829, „Moving Mailboxes in Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

  • 822892, „Verbesserungen von "Postfach verschieben" in Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)


Dieser Exchange-Server ist auch ein Domänencontroller, dies entspricht nicht einer empfohlenen Konfiguration
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-03-28

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_ComputerSystem ab, um den Wert für den Schlüssel DomainRole zu bestimmen. In der folgenden Tabelle werden die gültigen Werte für diesen Schlüssel aufgeführt.

Wert | Bedeutung
0 | Eigenständige Workstation
1 | Mitgliedsworkstation
2 | Eigenständiger Server
3 | Mitgliedsserver
4 | Sicherungsdomänencontroller
5 | Primärer Domänencontroller

Darüber hinaus fragt der Exchange Server Analyzer auch die WMI-Klasse Win32_Service ab, um den Wert des Schlüssels Started für den Clusterdienst ClusSvc zu bestimmen.

Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Verzeichnisobjekte mit der Objektkategorie msExchExchangeServer zu ermitteln. Der Wert für das Attribut serialNumber gibt die verwendete Version von Exchange Server an.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel DomainRole auf einem Exchange Server-Computer größer als 3 ist, dass auf dem Exchange Server-Computer nicht Exchange Server, Version 5.5, ausgeführt oder dieser in keinem Windows-Cluster ausgeführt wird, wird eine Warnung angezeigt.

Wenn Sie Exchange Server als Teil von Windows Small Business Server 2000 oder Windows Small Business Server 2003 ausführen, können Sie Exchange Server auf einem Domänencontroller installieren. Wenn Sie jedoch Exchange Server nicht als Teil von Small Business Server ausführen, empfiehlt es sich, Exchange Server nicht auf einem Domänencontroller auszuführen.

Wenn Sie Exchange Server auf einem Domänencontroller ohne Small Business Server ausführen, müssen Sie Folgendes berücksichtigen:

  • Sowohl Exchange Server als auch Active Directory sind ressourcenintensive Anwendungen. Wenn beide Anwendungen auf demselben Computer ausgeführt werden, müssen Sie möglicherweise mit Leistungsminderungen rechnen.

  • Wenn Exchange Server auf einem Domänencontroller ausgeführt wird, muss dieser Domänencontroller auch als globaler Katalogserver konfiguriert werden. Weitere Informationen zum Erstellen eines globalen Katalogservers finden Sie im Microsoft Knowledge Base-Artikel 313994, "Erstellen oder Verschieben eines globalen Katalogs in Windows Server 2003, Windows 2000 oder Small Business Server 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid= 313994).

  • Mehrere Verzeichniskomponenten von Exchange Server, z. B. der Verzeichnisdienstzugriff (DSAccess), der Verzeichnisdienstproxy (DSProxy) und das Nachrichtenkategorisierungsmodul, führen keinen Failover zu anderen Domänencontrollern oder zum globalen Katalogserver durch.

  • Sie sollten keinen Gebrauch vom Startschalter /3GB in Windows machen, weil dies dazu führen könnte, dass Exchange Server den ganzen Speicher verbraucht und damit für Active Directory nicht genügend Speicher bleibt.

  • Das Herunterfahren des Systems dauert erheblich länger, wenn die Exchange Server-Dienste nicht vor dem Herunterfahren und Neustarten des Servers angehalten werden.

  • Diese Konfiguration ist weniger sicher, weil Exchange-Administratoren über lokalen administrativen Zugriff auf Active Directory verfügen, womit sie ihre eigenen Rechte weiter ausbauen können. Außerdem erfordert jede in Exchange Server oder Active Directory gefundene Sicherheitslücke Kompromisse auf der jeweils anderen Seite.

  • Wenn Sie Exchange Server 2003 oder Exchange Server 2007 auf einem Domänencontroller ausführen, wird die Verwendung des Tools zum Hochstufen von Domänencontrollern (DCPromo) für eine Änderung der Rolle des Computers nicht unterstützt, weil dadurch Komponenten wie Microsoft Outlook® Mobile Access nicht ordnungsgemäß weiter funktionieren.

  • Die Ausführung von Exchange Server 2003 oder Exchange Server 2007 auf einem Clusterknoten, der auch ein Active Directory-Domänencontroller ist, wird nicht unterstützt und sollte niemals erfolgen. Diese bedeutet, dass Sie, wenn Sie Exchange 2000 Server auf einem Knoten in einem Cluster ausführen, der auch ein Domänencontroller ist, den Server zu einem Mitgliedsserver degradieren müssen, bevor Sie auf diesem ein Upgrade von Exchange 2000 Server auf Exchange Server 2003 durchführen.

Wenn auf dem Computer Exchange 2000 Server ausgeführt wird, ist es empfehlenswert, dass Sie den Server bei nächster Gelegenheit unter Verwendung von DCPromo zu einem Mitgliedsserver degradieren. Wenn auf dem Computer Exchange Server 2003 ausgeführt wird, verwenden Sie das nachstehende Verfahren, um die Ursache dieser Warnung zu beheben.

So beheben Sie die Ursache dieser Warnmeldung

  1. Installieren Sie Exchange Server auf einem anderen Computer.

  2. Verwenden Sie im Assistenten für Exchange-Aufgaben die Option Postfach verschieben, um alle vorhandenen Postfächer vom Domänencontroller zum neuen Exchange-Server zu verschieben.

  3. Ändern Sie den Stammserver für alle Öffentlichen Ordner und Rollen, die sich auf dem alten Exchange Server-Computer befinden, indem Sie sie auf den neuen Exchange Server-Computer verschieben.

  4. Deinstallieren Sie Exchange Server vom Domänencontroller.

Weitere Informationen über die Installation von Exchange Server auf einem Domänencontroller finden Sie im Microsoft Knowledge Base-Artikel 250989 „XADM: Installieren des ADC auf einem Windows 2000-Domänencontroller, der auch Exchange Server ausführt" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250989).


Dieser Exchange-Server ist inaktiv oder nicht erreichbar.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-04-20

Microsoft® Exchange Server Best Practices Analyzer liest mithilfe von Remoteprozeduraufrufen (RPCs) den Zeichenfolgenwert CurrentVersion aus dem folgenden Registrierungsschlüssel auf dem Exchange Server-Computer:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Wenn Exchange Server Best Practices Analyzer den Registrierungswert aus einem beliebigen Grund nicht lesen kann, wird ein Fehler angezeigt.

So beheben Sie diesen Fehler

  1. Stellen Sie sicher, dass der Exchange Server-Computer gestartet wurde und mit dem Netzwerk verbunden ist.

  2. Verwenden Sie den Befehl Ping, um festzustellen, ob eine Verbindung mit dem Exchange Server-Computer hergestellt werden kann.

  3. Wenn eine Firewall vorhanden ist, überprüfen Sie, ob die RPC-Anschlüsse blockiert sind.

  4. Stellen Sie sicher, dass der Remoteregistrierungsdienst auf dem Exchange Server-Computer gestartet wurde.

  5. Überprüfen Sie die Berechtigungen für das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird, um sicherzustellen, dass Microsoft Exchange Server Analyzer über ausreichende Berechtigungen zum Lesen der Registrierung auf dem Exchange Server-Computer verfügt.

Weitere Informationen zum Behandeln von Problemen mit Netzwerkverbindungen finden Sie im Microsoft Knowledge Base-Artikel 325487, „Behandlung von Problemen mit der Netzwerkverbindung" (http://support.microsoft.com/kb/325487/DE/).

Weitere Informationen zur Behandlung von Verbindungsproblemen bei Exchange Server Best Practices Analyzer finden Sie unter „Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" (http://go.microsoft.com/fwlink/?LinkId=56285).


Dieser Exchange-Server wird auf Windows NT 4.0 ausgeführt; es sind begrenzte Diagnoseinformationen verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Version des Microsoft Windows®-Betriebssystems zu bestimmen, die auf dem Exchange Server-Computer ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Der Wert 4.0 für CurrentVersion gibt an, dass auf dem Computer Microsoft Windows NT Server 4.0 ausgeführt wird. Der Wert 5.0 gibt an, dass auf dem Computer Windows 2000 Server ausgeführt wird, und der Wert 5.2 gibt an, dass auf dem Computer Windows Server™ 2003 ausgeführt wird.

Wenn Exchange Server Analyzer feststellt, dass der Wert für CurrentVersion gleich 4.0 ist, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass auf diesem Exchange Server-Computer Windows NT Server 4.0 ausgeführt wird. Windows NT Server 4.0 stellt nicht so viele Diagnoseinformationen bereit wie höhere Versionen von Windows Server. Daher kann Exchange Server Analyzer nur eine begrenzte Menge an Informationen sammeln und analysieren.

So beheben Sie dieses Problem

  1. Es ist keine sofortige Aktion erforderlich. Diese Warnung dient nur Informationszwecken.

  2. Da Windows NT 4.0 und Exchange Server 5.5 das Ende ihres Produktlebenszyklus erreichen, sollten Sie eine Aktualisierung auf Windows Server 2003 und Exchange Server 2003 in Erwägung ziehen.

Weitere Informationen zum Produktlebenszyklus von Windows NT Server 4.0 und Exchange Server 5.5 finden Sie auf der Webseite „Microsoft Support Lifecycle" unter http://go.microsoft.com/fwlink/?LinkId=21759.

Weitere Informationen zu Windows Server 2003 finden Sie auf der Produkthomepage „Microsoft Windows Server 2003" unter http://go.microsoft.com/fwlink/?LinkId=26095.

Weitere Informationen zu Exchange Server 2003 finden Sie auf der Produkthomepage „Microsoft Exchange Server 2003" unter http://go.microsoft.com/fwlink/?LinkId=21573.


Auf diesem Exchange Server 2003-Server wird nicht der endgültige Service Pack 2-Build ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Exchange Server-Objekte im Verzeichnis zu bestimmen. Das Attribut serialNumber ist ein Zeichenfolgenwert, der die Version von Exchange Server und ggf. die Version des Service Packs enthält. Wenn beispielsweise auf einem Exchange Server 2003-Computer Service Pack 1 installiert ist, weist das Attribut serialNumber den Wert Version 6.5 (Build 7638: Service Pack 2) auf.

Wenn Exchange Server Analyzer feststellt, dass der Wert für das Attribut serialNumber in seiner Zeichenfolge 6.5 und Service Pack 2, jedoch nicht 7638 enthält, zeigt Exchange Server Analyzer eine Warnung an.

Diese Warnung weist darauf hin, dass auf dem Exchange Server 2003-Computer eine Vorabversion von Exchange Server 2003 Service Pack 2 ausgeführt wird.

Hinweis:
Da Service Packs für Exchange Server nicht deinstalliert werden können, wird dringend empfohlen, vor dem Anwenden von Service Packs eine vollständige Sicherungskopie für den Exchange Server-Computer zu erstellen.
So beheben Sie diese Warnung

  1. Rufen Sie die neueste Version von Exchange Server 2003 Service Pack 2 von der Exchange Server 2003 Service Pack 2-Website unter http://www.microsoft.com/downloads/details.aspx?FamilyId=535BEF85-3096-45F8-AA43-60F1F58B3C40&DisplayLang=de ab.

  2. Lesen Sie die Versionsanmerkungen zu Exchange Server 2003 Service Pack 2 unter http://go.microsoft.com/fwlink/?LinkId=52072.

  3. Erstellen Sie eine vollständige Sicherungskopie des Exchange Server-Computers.

  4. Wenden Sie das Service Pack 2 für Exchange Server 2003 an.

  5. Erstellen Sie eine weitere vollständige Sicherungskopie des Exchange Server-Computers.

Weitere Informationen zum Installieren eines Service Packs für ExchangeServer finden Sie im Microsoft Knowledge Base-Artikel 328839, „Wie Sie Service Packs und Hotfixes für Exchange anwenden", unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839.


Unter Exchange Server wird SharePoint Portal Server ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_Service ab, um den Wert des Schlüssels Started für Microsoft Windows SharePoint® Portal Server (MSDMSERV) zu bestimmen. Der Wert True gibt an, dass SharePoint Portal Server auf diesem Exchange-Server ausgeführt wird.

Wenn Exchange Server Analyzer feststellt, dass SharePoint Portal Server auf einem Exchange Server-Computer ausgeführt wird, wird eine Warnmeldung angezeigt.

SharePoint Portal Server ist nicht mit Exchange Server kompatibel und muss entfernt werden. SharePoint Portal Server und Exchange Server sind für die Interoperation konzipiert, sodass sie eine Rolle in der Umgebung für die Zusammenarbeit Ihres Unternehmens spielen. Allerdings werden SharePoint Portal Server und Exchange Server parallel zueinander ausgeführt, und sie können nicht auf derselben Hardware betrieben werden.

So beheben Sie diese Warnung

  • Verschieben Sie entweder Exchange Server oder SharePoint Portal Server auf einen anderen Computer. Es wird empfohlen, eines der beiden Programme vom Computer zu entfernen.

Weitere Informationen zum Verschieben von Postfächern in Exchange Server 2003 finden Sie im Microsoft Knowledge Base-Artikel 821829, „Moving Mailboxes in Exchange Server 2003", unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829.

Weitere Informationen zur Kompatibilität von Exchange Server und SharePoint Portal Server finden Sie im Knowledge Base-Artikel 277567, „Cannot Install SharePoint Portal Server on a Computer Running Exchange Server", unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=277567.


Exchange Server führt Virtual Server 2005 aus, wobei ein weiterer Exchange Server als Gast installiert ist.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest Werte im folgenden Registrierungsschlüssel, um zu ermitteln, ob der Server ein virtueller Server ist:

HKEY_LOCAL_MACHINE\Software\Classes\Installer\Products\354F2D7F395B57846953B997DF778AC1

Exchange Server Analyzer überprüft auch den folgenden Registrierungswert:

HKLM\Software\Microsoft\Virtual Machine\Guest\Parameters

Zusätzlich fragt Exchange Server Analyzer die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_Service ab, um zu ermitteln, ob der Microsoft Exchange-Informationsspeicherdienst (MSExchangeIS) auf dem physischen Computer ausgeführt wird, auf dem auch Microsoft Virtual Server 2005 ausgeführt wird.

Wenn Exchange Server Analyzer feststellt, dass es sich bei dem Server um einen virtuellen Server handelt, dass der oben beschriebene Registrierungszweig vorhanden ist und dass MSExchangeIS auf dem physischen Computer ausgeführt wird, wird ein Fehler angezeigt.

Das Vorhandensein des Schlüssels HKLM\Software\Classes\Installer\Products\354F2D7F395B57846953B997DF778AC1 zeigt an, dass auf dem Exchange Server-Computer virtuelle Computererweiterungen installiert sind. Dieser Umstand und das Vorhandensein des Schlüssels HKLM\Software\Microsoft\Virtual Machine\Guest\Parameters bedeuten, dass der Exchange Server-Computer als virtueller Gastcomputer in Virtual Server 2005 ausgeführt wird.

Das Ausführen einer beliebigen Version von Exchange Server auf einem virtuellen Computer oder einem Emulator wird von Microsoft nicht unterstützt. Dies gilt für Exchange Server unter Virtual Server 2005, Microsoft Virtual PC 2004 und sämtliche Anwendungen für virtuelle Computer von Drittanbietern. Exchange-Server wurden so entwickelt und getestet, dass sie nur auf realer Hardware, insbesondere auf den Hardwareplattformen ausgeführt werden können, die im Windows-Serverkatalog unter http://go.microsoft.com/fwlink/?linkid=17219 aufgeführt sind.

Außerdem stellt das Ausführen von Exchange als Gast eines virtuellen Servers auf einem Computer, auf dem Exchange Server ausgeführt wird, keine empfohlene Vorgehensweise dar, da dies keine ausreichende Redundanz zwischen den Diensten ermöglicht.

So berichtigen Sie diesen Fehler

  1. Verschieben Sie die Postfächer aus dem Exchange Server, der unter Virtual Server 2005 ausgeführt wird, auf einen nicht virtuellen Exchange Server-Computer.

  2. Lagern Sie beliebige Öffentliche Ordner aus, und übertragen Sie beliebige Rollen, die bei Bedarf von dem virtuellen Exchange-Server übernommen werden.

  3. Deinstallieren Sie Exchange von dem virtuellen Computer, um es außer Betrieb zu setzen und aus Ihrer Exchange-Infrastruktur und aus dem Active Directory®-Verzeichnisdienst zu entfernen.

Weitere Informationen zum Verschieben von Postfächern finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 822892, „Move Mailbox improvements in Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975, „XADM: Differences Between Move Mailbox Methods" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

Weitere Informationen zur Unterstützung von in virtuellen Umgebungen ausgeführten Exchange Server-Computern finden Sie im Knowledge Base-Artikel 320220 „Support Boundaries for Exchange Server on a Virtual Machine or an Emulation Machine" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).

Weitere Informationen zu Virtual Server 2005 finden Sie unter „Microsoft Virtual Server 2005" (http://go.microsoft.com/fwlink/?linkid=34938).

Weitere Informationen zu Virtual Server 2004 finden Sie unter „Microsoft Virtual PC 2004" (http://go.microsoft.com/fwlink/?linkid=34663).


Auf dem Exchange-Server werden DNS-Dienste ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Service ab, um den Wert für den Schlüssel Started für den Microsoft SQL Server™-Dienst (MSSQLSERVER) zu bestimmen. Der Wert True gibt an, dass der DNS-Serverdienst auf diesem Exchange-Server ausgeführt wird.

Exchange Server Analyzer sendet auch eine Abfrage an die WMI-Klasse Win32_OperatingSystem, um den Wert des Schlüssels OSProductSuite zu ermitteln. Der für diesen Schlüssel zurückgegebene Wert gibt die Version des Windows-Betriebssystems an, das auf dem Exchange Server-Computer ausgeführt wird.

Um die Anzahl der Einträge zu ermitteln, die im Attribut homeMDBBL der einzelnen Postfachspeicher aufgelistet sind, fragt Exchange Server Analyzer außerdem den Active Directory®-Verzeichnisdienst ab. Der Zählwert dieses Attributs stellt die Zahl der Postfächer im Postfachspeicher dar.

Wenn Exchange Server Analyzer ermittelt, dass der DNS-Serverdienst auf einem Exchange Server-Computer gestartet wird, der die folgenden Kriterien erfüllt, wird eine Warnung angezeigt:

  • Der Exchange Server-Computer dient als Host für mindestens 100 Postfächer.

  • Der Exchange Server-Computer wird nicht unter Windows Small Business Server 2003 oder Small Business Server 2000 ausgeführt.

Die Ausführung des DNS Server-Service auf dem Computer, auf dem auch der Exchange-Mailboxserver für die Produktion ausgeführt wird, wird nicht empfohlen. Die Verwendung nur eines einzigen Computers als Host für den DNS-Serverdienst und für Exchange Server in Produktionsumgebungen führt mit Wahrscheinlichkeit zu Leistungsproblemen auf mindestens einem der Server.

So beheben Sie diese Warnmeldung

  1. Beim Beheben dieses Problems sollten Sie eine der folgenden Optionen erwägen:

    • Verschieben Sie entweder Exchange Server oder den DNS-Serverdienst von dem Computer. Es wird empfohlen, einen der beiden Server vollständig vom Computer zu entfernen.

    • Verschieben Sie die Exchange-Postfächer vom Server. Es wird empfohlen, zumindest die Postfächer zu entfernen und den Exchange Server in einen Protokoll- oder Infrastrukturserver zu konvertieren. Dadurch wird die Datenträger-E/A-Last und insbesondere die CPU-Last reduziert (letztere ist abhängig von der Exchange-Infrastrukturrolle).

    • Erwägen Sie, stattdessen Small Business Server zu installieren. Wenn Sie Exchange in einer kleinen Umgebung mit weniger als 75 Benutzern ausführen, in der nur ein Exchange Server erforderlich ist, profitieren Sie möglicherweise von der Installation von Small Business Server. Small Business Server umfasst sowohl SQL Server als auch Exchange Server sowie weitere wichtige Microsoft-Serveranwendungen. Small Business Server wurde für die Installation auf einem einzelnen Computer entwickelt, getestet und optimiert.

Weitere Informationen zum Verschieben und Exchange-Servern finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 822892, „Move Mailbox improvements in Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975, „XADM: Differences Between Move Mailbox Methods" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

  • 297289 „SO WIRD'S GEMACHT: Verschieben von Exchange 2000 auf neue Hardware unter Beibehaltung des Servernamens" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=297289)

Weitere Informationen zu Small Business Server finden Sie in „Microsoft Windows Small Business Server 2003" unter http://www.microsoft.com/germany/sbserver/downloads/default.mspx),


Auf dem Exchange-Server wird SQL Server ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_Service ab, um den Wert für den Schlüssel Started für den Microsoft SQLServer™-Dienst (MSSQLSERVER) zu bestimmen. Der Wert True gibt an, dass der SQL-Serverdienst auf diesem Exchange-Server ausgeführt wird.

Exchange Server Analyzer sendet auch eine Abfrage an die WMI-Klasse Win32_OperatingSystem, um den Wert des Schlüssels OSProductSuite zu ermitteln. Der für diesen Schlüssel zurückgegebene Wert gibt die Version des Windows-Betriebssystems an, das auf dem Exchange Server-Computer ausgeführt wird.

Um die Anzahl der Einträge zu ermitteln, die im Attribut homeMDBBL der einzelnen Postfachspeicher aufgelistet sind, fragt Exchange Server Analyzer außerdem den Active Directory®-Verzeichnisdienst ab. Der Zählwert dieses Attributs stellt die Zahl der Postfächer im Postfachspeicher dar.

Wenn Exchange Server Analyzer ermittelt, dass der SQL Server-Dienst auf einem Exchange Server-Computer gestartet wird, der die folgenden Kriterien erfüllt, wird eine Warnung angezeigt:

  • Der Exchange Server-Computer dient als Host für mindestens 100 Postfächer.

  • Der Exchange Server-Computer wird nicht unter Windows Small Business Server 2003 oder Small Business Server 2000 ausgeführt.

Es wird nicht empfohlen, SQL Server auf demselben Computer auszuführen, auf dem auch der Exchange-Postfachserver für die Produktion ausgeführt wird. Sowohl SQL Server als auch die Exchange-Postfachserver beanspruchen für den optimalen Betrieb eine große Menge an Arbeitsspeicher und Laufwerkressourcen. Die Verwendung nur eines einzigen Computers als Host für SQL Server und für Exchange Server in Produktionsumgebungen führt mit Wahrscheinlichkeit zu Leistungsproblemen auf mindestens einem der Server. Außerdem ist die Problembehandlung und das Sichern solcher Installationen nicht genug untersucht.

Es gibt zudem eine Anzahl bekannter Interoperabilitätsprobleme, die auftreten können, wenn SQL Server und Exchange Server auf demselben Computer ausgeführt werden. Die meisten dieser Probleme sind auf Versionsinkonsistenzen mit den gemeinsamen Dateien oder Programmen der beiden Server zurückzuführen, z. B Microsoft Distributed Transaction Coordinator (MS DTC), Microsoft ActiveX Data Objects (ADO) und OLE Database (OLE DB).

So beheben Sie diese Warnmeldung

  • Beim Beheben dieses Problems sollten Sie eine der folgenden Optionen erwägen:

    • Verschieben Sie entweder Exchange Server oder SQL Server von dem Computer. Es wird empfohlen, eines der beiden Programme vollständig vom Computer zu entfernen.

    • Verschieben Sie die Exchange-Postfächer vom Server. Es wird empfohlen, zumindest die Postfächer zu entfernen und den Exchange Server in einen Protokoll- oder Infrastrukturserver zu konvertieren. Dadurch wird die Datenträger-E/A-Last und insbesondere die CPU-Last reduziert (letztere ist abhängig von der Exchange-Infrastrukturrolle).

    • Erwägen Sie stattdessen, Small Business Server zu installieren. Wenn Sie Exchange in einer kleinen Umgebung ausführen, in der nur ein Exchange Server erforderlich ist, profitieren Sie möglicherweise von der Installation von Small Business Server. Small Business Server umfasst sowohl SQL Server als auch Exchange Server sowie weitere wichtige Microsoft-Serveranwendungen. Small Business Server wurde für die Installation auf einem einzelnen Computer entwickelt, getestet und optimiert.

Weitere Informationen zum Verschieben und Exchange-Servern finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 822892, „Move Mailbox improvements in Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975, „XADM: Differences Between Move Mailbox Methods" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

  • 297289 „SO WIRD'S GEMACHT: Verschieben von Exchange 2000 auf neue Hardware unter Beibehaltung des Servernamens" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=297289)

Weitere Informationen zu Small Business Server finden Sie in „Microsoft Windows Small Business Server 2003" unter http://www.microsoft.com/germany/sbserver/downloads/default.mspx),


Exchange-Server, der unter VMware ausgeführt wird.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-10-26

Weitere Informationen zur Unterstützung für in virtuellen Umgebungen ausgeführte Exchange Server-Computer finden Sie im Knowledge Base-Artikel 897615 „Support policy for Microsoft software running in non-Microsoft hardware virtualization software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=897615).


Dieser Exchange-Server verfügt über weniger als 1 GB Arbeitsspeicher, trotzdem wurden für ihn in der Datei „boot.ini" die Schalter /3GB und USERVA=3030 aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt zwei Microsoft WMI-Klassen (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) ab, um die Menge des physischen Speichers für den Exchange Server-Computer und den virtuellen Adressraum zu bestimmen, der für Prozesse im Benutzermodus zugewiesen ist. In der folgenden Tabelle werden die Klassen und Schlüssel beschrieben, die von Exchange Server Analyzer ausgewertet werden.

Klasse | Schlüssel | Beschreibung
Win32_OperatingSystem | MaxProcessMemorySize | Maximaler Speicher in KB, der einem Prozess zugewiesen werden kann.
Win32_OperatingSystem | OSProductSuite | Installierte und lizenzierte Systemprodukterweiterungen für das Betriebssystem.
Win32_ComputerSystem | TotalPhysicalMemory | Größe des Arbeitsspeichers (RAM, Random Access Memory) in Byte, der im Computer installiert ist.

Wenn Exchange Server Analyzer feststellt, dass der Exchange Server-Computer über weniger als 950 MB RAM verfügt und der Wert für MaxProcessMemorySize größer als 2097024 und kleiner als 3104640 ist, wird eine Warnung angezeigt.

In dieser Warnung wird darauf hingewiesen, dass der Exchange Server-Computer in zweierlei Hinsicht nicht für die optimale Speichernutzung konfiguriert ist:

  • Der /USERVA=3030-Startschalter wurde festgelegt. Dieser Schalter ist nur auf Exchange Server-Computern mit einem Speicher ab 1 GB erforderlich, auf denen das Betriebssystem Windows Server™ 2003 ausgeführt wird.

  • Der /3GB-Startschalter wurde festgelegt. Dieser Schalter sollte nur auf Exchange-Servern mit einem Speicher ab 1 GB verwendet werden, auf denen eines der folgenden Betriebssysteme ausgeführt wird:

    • Microsoft Windows Server 2003 Standard Edition

    • Microsoft Windows Server 2003 Enterprise Edition

    • Microsoft Windows Server 2003 Datacenter Edition

    • Microsoft Windows 2000 Advanced Server

    • Microsoft Windows 2000 Datacenter Server

Wichtig:
Der /3GB-Schalter darf nicht unter Windows 2000 Server verwendet werden, da er nicht unterstützt wird und zu Abstürzen des Betriebssystems oder von Anwendungen führen kann. Darüber hinaus wird der /3GB-Schalter unter den oben genannten Betriebssystemen nur unterstützt, wenn ein physischer Speicher von mindestens 1 GB verfügbar ist.

Wenn diese Warnung in einem System ausgegeben wird, in dem ein physischer Speicher von 1 GB verfügbar ist, kann sie darauf verweisen, dass einer anderen Komponente (z. B. einer Videokarte) Teile des physischen Speichers auf der Hardwareebene zugewiesen wurden, wodurch dieser Speicher für das Betriebssystem nicht mehr verfügbar ist. In diesen Fällen zeigt Windows für die Größe des tatsächlich auf dem Computer installierten physischen Speichers einen zu geringen Wert an. Wenn eine solche Situation eintritt, vergleichen Sie die dem BIOS gemeldete Menge des installierten Speichers mit der von Windows gemeldeten installierten Speichermenge.

So beheben Sie diese Warnung unter Windows Server 2003

  1. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und klicken Sie dann auf Eigenschaften. Das Dialogfeld Systemeigenschaften wird angezeigt.

  2. Klicken Sie auf Erweitert.

  3. Klicken Sie im Bereich Starten und Wiederherstellen auf Einstellungen. Das Dialogfeld Starten und Wiederherstellen wird angezeigt.

  4. Klicken Sie im Bereich Systemstart auf Bearbeiten. Dadurch wird die Windows-Datei Boot.ini in Microsoft Editor geöffnet.

  5. Löschen Sie im Abschnitt [Operating Systems] aus allen Startzeilen die folgenden Schalter: /3GB /USERVA=3030

  6. Speichern Sie die Änderungen, und schließen Sie Editor.

  7. Klicken Sie zweimal auf OK, um die geöffneten Dialogfelder zu schließen, und starten Sie den Computer anschließend neu, damit die Änderung wirksam wird.

So beheben Sie diese Warnung unter Windows 2000 Server

  1. Navigieren Sie in Windows Explorer zur Systempartition.

  2. Wenn die Datei Boot.ini nicht angezeigt wird, kann dies daran liegen, dass in den Ordneroptionen die Option Geschützte Systemdateien ausblenden festgelegt ist. Wenn dies der Fall ist, klicken Sie im Windows Explorer-Fenster auf Extras und Ordneroptionen, und klicken Sie dann auf Ansicht. Deaktivieren Sie das Kontrollkästchen Geschützte Systemdateien ausblenden (empfohlen). Klicken Sie im angezeigten Warnungsfeld auf Ja.

  3. Wenn die Datei Boot.ini in Windows Explorer angezeigt wird, klicken Sie mit der rechten Maustaste auf die Datei, klicken dann auf Öffnen mit und schließlich auf Editor, um die Datei zu öffnen.

  4. Entfernen Sie /3GB und, falls vorhanden, /USERVA=3030.

  5. Speichern Sie die Änderungen und schließen Sie Editor.

  6. Starten Sie den Computer neu, damit die Änderung wirksam wird.

Weitere Informationen zum Verwenden der Startschalter /3GB und /USERVA finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 308356, „Memory usage by the Lsass.exe process on domain controllers that are running Windows Server 2003 or Windows 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)

  • 297812, „How to Use the 4GT RAM Tuning Feature" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, „The effects of 4GT tuning on system Page Table Entries" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739, „How to Use the /USERVA Switch in the Boot.ini File to Tune /3GB Configurations" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, „SO WIRD´S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, „Optimieren der Speichernutzung in Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Dieser Exchange-Server verfügt über weniger als 1 GB Arbeitsspeicher, aber für ihn ist in der Datei „Boot.ini" der Schalter „/3GB" festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft ® Exchange Server Analyzer fragt zwei Microsoft WMI-Klassen (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) ab, um die Größe des physischen Speichers des Exchange Server-Computers und die Größe des virtuellen Adressraums zu bestimmen, der für Benutzer-Modus-Prozesse reserviert wird, die auf dem Exchange Server-Computer ausgeführt werden. In der folgenden Tabelle werden die Klassen und Schlüssel beschrieben, die von Exchange Server Analyzer ausgewertet werden.

Abgefragte Klasse | Abgefragte Schlüssel | Beschreibung
Win32_OperatingSystem | MaxProcessMemorySize | Maximaler Speicher in KB, der einem Prozess zugewiesen werden kann.
Win32_ComputerSystem | TotalPhysicalMemory | Größe des Arbeitsspeichers (RAM, Random Access Memory) in Byte, der im Computer installiert ist.

Wenn Exchange Server Analyzer ermittelt, dass der Wert für TotalPhysicalMemory unter 1073741824 liegt und dass der Wert für MaxProcessMemorySize gleich 3145600 ist, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass das System über weniger als 950 MB physischen Speicher verfügt, aber mit dem /3GB-Startschalter in der Datei Boot.ini konfiguriert wurde. Dieser Schalter sollte nur auf Exchange-Servern mit einem Speicher ab 1 GB verwendet werden, auf denen eines der folgenden Betriebssysteme ausgeführt wird:

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Wichtig:
Der /3GB-Schalter darf nicht unter Windows 2000 Server verwendet werden, da er nicht unterstützt wird und zu Abstürzen des Betriebssystems oder von Anwendungen führen kann. Darüber hinaus wird der /3GB-Schalter unter den oben genannten Betriebssystemen nur unterstützt, wenn ein physischer Speicher von mindestens 1 GB verfügbar ist.

Wenn diese Warnung in einem System ausgegeben wird, in dem ein physischer Speicher von 1 GB verfügbar ist, kann sie darauf verweisen, dass einer anderen Komponente (z. B. einer Videokarte) Teile des physischen Speichers auf der Hardwareebene zugewiesen wurden, wodurch dieser Speicher für das Betriebssystem nicht mehr verfügbar ist. In diesen Fällen ist die Menge des physisch installierten Speichers laut Windows kleiner als die Menge des tatsächlich auf dem Computer installierten physischen Speichers. Wenn eine solche Situation eintritt, vergleichen Sie die dem BIOS gemeldete Menge des installierten Speichers mit der von Windows gemeldeten installierten Speichermenge.

So beheben Sie diese Warnung unter Windows Server 2003

  1. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und klicken Sie dann auf Eigenschaften. Das Dialogfeld Systemeigenschaften wird angezeigt.

  2. Klicken Sie auf Erweitert.

  3. Klicken Sie im Bereich Starten und Wiederherstellen auf Einstellungen. Das Dialogfeld Starten und Wiederherstellen wird angezeigt.

  4. Klicken Sie im Bereich Systemstart auf Bearbeiten. Dadurch wird die Windows-Datei Boot.ini in Microsoft Editor geöffnet.

  5. Löschen Sie im Abschnitt [Operating Systems] aus allen Startzeilen die folgenden Schalter: /3GB

  6. Speichern Sie die Änderungen, und schließen Sie Editor.

  7. Klicken Sie zweimal auf OK, um die geöffneten Dialogfelder zu schließen, und starten Sie den Computer anschließend neu, damit die Änderung wirksam wird.

So beheben Sie diese Warnung unter Windows 2000 Server

  1. Navigieren Sie in Windows Explorer zur Systempartition. Auf dieser Partition befinden sich hardwarespezifische Dateien wie Boot.ini und NTLDR.

  2. Wenn die Datei Boot.ini nicht angezeigt wird, kann dies daran liegen, dass unter Ordneroptionen die Option Geschützte Systemdateien ausblenden festgelegt ist. Wenn dies der Fall ist, klicken Sie in Windows Explorer-Fenster auf Extras und Ordneroptionen, und klicken Sie dann auf Ansicht. Deaktivieren Sie das Kontrollkästchen Geschützte Systemdateien ausblenden (empfohlen). Klicken Sie bei der Eingabeaufforderung auf Ja.

  3. Wenn die Datei Boot.ini in Windows Explorer angezeigt wird, klicken Sie mit der rechten Maustaste auf die Datei, klicken dann auf Öffnen mit und schließlich auf Editor, um die Datei zu öffnen.

  4. Löschen Sie im Abschnitt [Operating Systems] aus allen Startzeilen die folgenden Schalter: /3GB

  5. Speichern Sie die Änderungen, und schließen Sie Editor.

  6. Starten Sie den Computer neu, damit die Änderung wirksam wird.

Weitere Informationen zum Optimieren der Speicherverwendung für Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 325044, „SO WIRD'S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, „Optimieren der Speichernutzung in Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Für diesen Exchange-Server ist in der Datei „Boot.ini" der Startschalter „/3GB" festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_OperatingSystem ab, um die Größe des virtuellen Adressraums zu bestimmen, der Benutzermodusprozessen (MaxProcessMemorySize) auf dem ExchangeServer-Computer zugewiesen ist.

Microsoft Exchange Server Analyzer überprüft auch die WMI-Klasse Exchange_Server im Namespace root\MicrosoftExchangeV2, um den Wert für den Schlüssel IsFrontEndServer zu bestimmen. Der Wert False gibt an, dass der Exchange Server-Computer kein Front-End-Server ist. Der Wert True zeigt an, dass der Exchange Server-Computer ein Front-End-Server ist.

Exchange Server Analyzer sendet auch eine Abfrage an die WMI-Klasse Win32_Service, um zu ermitteln, ob der Clusterdienst (ClusSvc) vorhanden ist und ausgeführt wird.

Schließlich sendet Exchange Server Analyzer eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Zähler für das Attribut homeMDBBL des Postfachspeicherobjekts (msExchPrivateMDB) zu bestimmen. Die resultierende Anzahl ist die Zahl der Postfächer, die auf dem Exchange Server-Computer gefunden werden.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel MaxProcessMemorySize nicht gleich 2097024 ist, dass der Schlüssel IsFrontEndServer auf False festgelegt ist, dass der Clusterdienst nicht ausgeführt wird, dass der Postfachspeicher von Exchange Server weniger als 20 Postfächer enthält, und dass Exchange nicht auf Microsoft Windows Small Business Server 2003 ausgeführt wird, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass der Verzeichnisserver für die optimale Speicherverwendung nicht ordnungsgemäß konfiguriert ist, weil der /3GB-Startschalter in der Datei Boot.ini festgelegt worden ist. Dieser Schalter sollte nur auf Exchange Servern mit einem Speicher ab 1 GB verwendet werden, auf denen eines der folgenden Betriebssysteme ausgeführt wird:

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Wichtig:
Der /3GB-Schalter darf nicht unter Windows 2000 Server verwendet werden, da er nicht unterstützt wird und zu Abstürzen des Betriebssystems oder von Anwendungen führen kann. Darüber hinaus wird der /3GB-Schalter unter den oben genannten Betriebssystemen nur unterstützt, wenn ein physischer Speicher von mindestens 1 GB verfügbar ist.

Wenn der /3GB-Parameter in der Datei Boot.ini eines unterstütztem Betriebssystems enthalten ist, weist Windows dem Benutzerprozess 3 GB des maximal 4 GB großen virtuellen Adressraums und 1 GB dem Kernel zu. Normalerweise (wenn der /3GB-Parameter nicht verwendet wird) weist Windows dem Benutzerprozess und dem Kernel jeweils 2 GB zu. Speicherintensive Anwendungen können daher bei Verwendung des /3GB-Schalters über einen größeren virtuellen Adressraum verfügen, sodass die Leistung verbessert wird.

Die Verwendung des /3GB-Schalters ist in erster Linie für speicherintensive Anwendungsprozesse wie Store.exe auf Exchange-Servern mit Benutzerpostfächern hilfreich. Auf Front-End-Servern befinden sich keine Benutzerpostfächer. Daher profitieren Front-End-Server nicht von der Verwendung des /3GB-Schalters.

So beheben Sie diese Warnmeldung

  1. Navigieren Sie in Windows Explorer zur Systempartition.

  2. Wenn die Datei boot.ini nicht angezeigt wird, kann dies daran liegen, dass in den Ordneroptionen die Option Geschützte Systemdateien ausblenden festgelegt ist. Wenn dies der Fall ist, klicken Sie im Windows Explorer auf Extras, klicken Sie auf Ordneroptionen, und klicken Sie dann auf die Registerkarte Ansicht. Deaktivieren Sie das Kontrollkästchen Geschützte Systemdateien ausblenden (empfohlen). Klicken Sie im angezeigten Warnungsfeld auf Ja.

  3. Wenn die Datei Boot.ini in Windows Explorer angezeigt wird, klicken Sie mit der rechten Maustaste auf die Datei, klicken Sie auf Öffnen mit, und wählen Sie dann Editor aus, um die Datei zu öffnen.

  4. Löschen Sie im Abschnitt [Operating Systems] aus allen Startzeilen die folgenden Schalter: /3GB

  5. Speichern Sie die Änderungen und schließen Sie Editor.

  6. Starten Sie den Computer neu, damit die Änderung wirksam wird.

Weitere Informationen zur Verwendung des Schalters /3GB finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 325044, „SO WIRD'S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000"

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372, „Optimieren der Speichernutzung in Exchange Server 2003"

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)


Auf diesem Exchange 2003-Server wird der neueste Service Pack 1 Build (7226.6) nicht ausgeführt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-04-21

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs SerialNumber für alle Exchange Server-Objekte im Verzeichnis zu bestimmen. Das Attribut serialNumber ist ein Zeichenfolgenwert, der die Version von Exchange Server und die Version des Service Packs umfasst, falls dieses installiert wurde. Falls z. B. auf einem Exchange Server 2003-Computer Service Pack 1 installiert ist, ist das Attribut serialNumber gleich Version 6.5 (Build 7226.6: Service Pack 1).

Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs serialNumber in seiner Zeichenfolge 6.5 und Service Pack 1 enthält, jedoch nicht 7226.6, wird eine Warnung angezeigt.

Diese Warnung weist darauf hin, dass auf dem Exchange Server 2003-Computer eine Vorabversion von Exchange Server 2003 Service Pack 1 ausgeführt wird.

Hinweis:
Da Exchange-Service Packs nicht deinstalliert werden können, wird dringend empfohlen, dass Sie eine vollständige Sicherung des Exchange Server-Computers vor der Anwendung von Service Packs vornehmen.

So beheben Sie diese Warnmeldung

  1. Rufen Sie die die endgültige Version von Exchange Server 2003 Service Pack 1 unter (http://go.microsoft.com/fwlink/?linkid=29090) ab.

  2. Lesen Sie auch die Versionsinformationen zu Exchange Server 2003 unter http://go.microsoft.com/fwlink/?linkid=23235.

  3. Prüfen Sie die in Service Pack 1 enthaltenen Updates (http://go.microsoft.com/fwlink/?linkid=34272).

  4. Nehmen Sie eine vollständige Sicherung des Exchange Server-Computers vor.

  5. Wenden Sie das Service Pack 1 für Exchange Server 2003 an.

  6. Nehmen Sie eine weitere vollständige Sicherung des Exchange Server-Computers vor.

Weitere Informationen zum Installieren von Exchange Server-Service Packs finden Sie im Microsoft Knowledge Base-Artikel 328839 „Wie Sie Service Packs und Hotfixes für Exchange anwenden" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Dieser Exchange-Server führt Windows 2000 Server aus, allerdings ist für ihn in der Datei „boot.ini" der Schalter „/3GB" festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt zwei Microsoft WMI-Klassen (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) ab, um die Menge des physischen Speichers für den Exchange Server-Computer und den virtuellen Adressraum zu bestimmen, der für Prozesse im Benutzermodus zugewiesen ist. In der folgenden Tabelle werden die Klassen und Schlüssel beschrieben, die von Exchange Server Analyzer ausgewertet werden.

Klasse | Schlüssel | Beschreibung
Win32_OperatingSystem | MaxProcessMemorySize | Maximaler Speicher in KB, der einem Prozess zugewiesen werden kann.
Win32_OperatingSystem | OSProductSuite | Installierte und lizenzierte Systemprodukterweiterungen für das Betriebssystem.
Win32_ComputerSystem | TotalPhysicalMemory | Größe des Arbeitsspeichers (RAM - Random Access Memory) in Byte, der im Computer installiert ist.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel MaxProcessMemorySize nicht 2097024 beträgt und dass der Wert des Schlüssels OSProductSuite in Windows 2000 Server aufgelöst wird, wird ein Fehler angezeigt.

Diese Warnung zeigt an, dass der Verzeichnisserver für die optimale Speicherverwendung nicht ordnungsgemäß konfiguriert ist, weil der /3GB-Startschalter in der Datei Boot.ini festgelegt wurde. Dieser Schalter sollte nur auf Exchange-Servern mit einem Speicher ab 1 GB verwendet werden, auf denen eines der folgenden Betriebssysteme ausgeführt wird:

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Wichtig:
Der /3GB-Schalter darf nicht unter Windows 2000 Server verwendet werden, da er nicht unterstützt wird und zu Abstürzen des Betriebssystems oder von Anwendungen führen kann. Darüber hinaus wird der /3GB-Schalter unter den oben genannten Betriebssystemen nur unterstützt, wenn ein physischer Speicher von mindestens 1 GB verfügbar ist.

So beheben Sie diese Fehler unter Windows Server 2003

  1. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und wählen Sie Eigenschaften aus. Das Dialogfeld Systemeigenschaften wird angezeigt.

  2. Klicken Sie auf die Registerkarte Erweitert.

  3. Klicken Sie im Bereich Starten und Wiederherstellen auf Einstellungen. Das Dialogfeld Starten und Wiederherstellen wird angezeigt.

  4. Klicken Sie im Bereich Systemstart auf die Schaltfläche Bearbeiten. Dadurch wird die Windows-Datei Boot.ini in Microsoft Editor geöffnet.

  5. Löschen Sie im Abschnitt [Operating Systems] aus allen Startzeilen die folgenden Schalter: /3GB.

  6. Speichern Sie die Änderungen, und schließen Sie Editor.

  7. Klicken Sie zweimal auf OK, um die geöffneten Dialogfelder zu schließen, und starten Sie den Verzeichnisserver anschließend neu, damit die Änderung wirksam wird.

So beheben Sie diese Fehler unter Windows 2000 Server

  1. Navigieren Sie in Windows Explorer zur Systempartition.

  2. Wenn die Datei boot.ini nicht angezeigt wird, kann dies daran liegen, dass in den Ordneroptionen die Option Geschützte Systemdateien ausblenden festgelegt ist. Wenn dies der Fall ist, klicken Sie im Windows Explorer auf Extras, klicken Sie auf Ordneroptionen, und klicken Sie dann auf die Registerkarte Ansicht. Deaktivieren Sie das Kontrollkästchen Geschützte Systemdateien ausblenden (empfohlen). Klicken Sie im angezeigten Warnungsfeld auf Ja.

  3. Wenn die Datei Boot.ini in Windows Explorer angezeigt wird, klicken Sie mit der rechten Maustaste auf die Datei, klicken Sie auf Öffnen mit, und wählen Sie dann Editor aus, um die Datei zu öffnen.

  4. Entfernen Sie /3GB, und speichern Sie die Datei.

  5. Starten Sie den Verzeichnisserver neu, damit die Änderung wirksam wird.

Weitere Informationen zum Verwenden der Startschalter /3GB und /USERVA finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 297812, „How to Use the 4GT RAM Tuning Feature" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, „The effects of 4GT tuning on system Page Table Entries" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739, „How to Use the /USERVA Switch in the Boot.ini File to Tune /3GB Configurations" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044, „SO WIRD'S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372, „Optimieren der Speichernutzung in Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Auf die Exchange Server-WMI konnte nicht zugegriffen werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-08-24

Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_ComputerSystem ab, um zu ermitteln, ob für den Schlüssel Name ein Wert festgelegt wurde. Wenn die WMI-Abfrage fehlschlägt und Exchange Server nicht unter Microsoft Windows NT® Server°4.0 ausgeführt wird, zeigt Exchange Server Analyzer einen Fehler an.

Dieser Fehler kann zwei Ursachen haben:

  • Das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird, verfügt nicht über die nötigen Berechtigungen, um WMI-Klassen abzufragen.

  • Wegen eines Netzwerkproblems kann Exchange Server Analyzer keine Verbindung mit dem Computer herstellen.

So beheben Sie diesen Fehler

  1. Stellen Sie sicher, dass der Exchange Server-Computer gestartet wurde und mit dem Netzwerk verbunden ist.

  2. Verwenden Sie den Befehl PING, um festzustellen, ob eine Verbindung mit dem Exchange Server-Computer hergestellt werden kann.

  3. Wenn ein Firewall vorhanden ist, überprüfen Sie, ob die RPC-Anschlüsse (Remote Procedure Call) blockiert sind.

  4. Überprüfen Sie die Berechtigungen für das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird. Das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird, muss über lokale Administratorberechtigungen für jeden durchsuchten Exchange-Server verfügen.

    Alternativ können Sie dem Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird, bestimmte WMI-Berechtigungen erteilen:

    1. Öffnen Sie auf dem Exchange-Computer die MMC-Struktur (Microsoft Management Console) Computerverwaltung.

    2. Klicken Sie mit der rechten Maustaste unter Dienste und Anwendungen auf WMI-Steuerung, und klicken Sie dann auf Eigenschaften.

    3. Klicken Sie auf der Seite Eigenschaften von WMI-Steuerung auf die Registerkarte Sicherheit, und erweitern Sie dann Stamm.

    4. Wählen Sie den Ordner CIMV2 aus, und klicken Sie auf Sicherheit.

    5. Fügen Sie auf der Seite Sicherheit für ROOT\CIMV2 das Konto hinzu, unter dem Exchange Server Analyzer ausgeführt wird.

  5. Wählen Sie das Konto aus, dass Sie oben in Schritt 5 hinzugefügt haben. Aktivieren Sie unter Berechtigungen für Ausgewähltes_Konto in der Spalte Zulassen die Kontrollkästchen Remote aktivieren und Sicherheit lesen, und klicken Sie dann auf OK.

Weitere Informationen zum Behandeln von Problemen mit Netzwerkverbindungen finden Sie im Microsoft Knowledge Base-Artikel 325487, „Behandlung von Problemen mit der Netzwerkverbindung" (http://support.microsoft.com/kb/325487/DE/).

Weitere Informationen zur Behandlung von Verbindungsproblemen bei Exchange Server Best Practices Analyzer finden Sie unter „Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" (http://go.microsoft.com/fwlink/?LinkId=56285).

Weitere Informationen zu den Anforderungen hinsichtlich der Anschlüsse finden Sie im Knowledge Base-Artikel 832017, "Dienste und Netzwerk-Port-Anforderungen für das Microsoft Windows-Serversystem" (http://support.microsoft.com/?kbid=832017).


Der Exchange-Systemaufsichtsdienst kann auf diesem Front-End-Server nicht ausgeführt werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation -Windows®-Verwaltungsinstrumentation) Win32_Service ab, um den Wert des Schlüssels Started für den Microsoft Exchange-Systemaufsichtsdienst zu bestimmen. Der Wert False gibt an, dass der Microsoft Exchange-Systemaufsichtsdienst nicht ausgeführt wird. Der Wert True gibt an, dass der Microsoft Exchange-Systemaufsichtsdienst ausgeführt wird.

Microsoft Exchange Server Analyzer untersucht auch die WMI-Klasse Exchange_Server im Namespace root\MicrosoftExchangeV2, um den Wert für den Schlüssel IsFrontEndServer zu bestimmen. Der Wert False gibt an, dass der Exchange Server-Computer kein Front-End-Server ist. Der Wert True zeigt an, dass der Exchange Server-Computer ein Front-End-Server ist.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel Started auf einem Exchange-Front-End-Server auf False eingestellt ist, wird eine Warnung angezeigt.

Im allgemeinen wird auf den meisten Exchange-Servern die Systemaufsicht ständig ausgeführt. Gelegentlich ist die Ausführung der Systemaufsicht jedoch nicht erforderlich. Auf einem Front-End-Server ist die Systemaufsicht nur für das Vornehmen von Konfigurationsänderungen auf dem Server erforderlich.

Bei Exchange Server werden alle Konfigurationsinformationen im Active Directory®-Verzeichnisdienst gespeichert. Hierzu zählen u. a. Informationen über Empfängerrichtlinien, die Konfiguration virtueller SMTP-Server (SMTP - Simple Mail Transfer Protocol), die Einstellungen für RPC über HTTP (RPC - Remote Procedure Call; HTTP - Hypertext Transfer Protocol) und Benutzerpostfächer. SMTP liest jedoch die eigenen Einstellungen aus der IIS-Metabase (Internet Information Services). Um die IIS-Metabase mit den Informationen zu füllen, die Exchange für SMTP- und RPC-über-HTTP-Funktionen benötigt, repliziert die DS2MB-Komponente (Directory Service To Metabase) der Systemaufsicht die Konfigurationsinformationen aus Active Directory mit der IIS-Metabase. Wenn die Systemaufsicht nicht ausgeführt wird, werden die an Einstellungen der Exchange Server-Konfiguration vorgenommenen Änderungen aus Active Directory nicht in die IIS-Metabase von Exchange Server kopiert. Wenn keine Konfigurationsänderungen vorgenommen und keine SMTP-Nachrichten verarbeitet werden, kann der Systemaufsichtsdienst im angehaltenen Zustand verbleiben.

Wenn Konfigurationsänderungen vorgenommen werden müssen, starten Sie den Systemaufsichtsdienst, nehmen Sie die Änderungen an der Konfiguration vor, und warten Sie anschließend, bis diese Änderungen auf die IIS-Metabase repliziert werden. Um festzustellen, ob die Änderungen von Active Directory auf die IIS-Metabase repliziert wurden, überprüfen Sie, ob im Anwendungsereignisprotokoll von Exchange Server drei Einträge mit der Ereignisquelle MSExchangeMU und der Ereignis-ID 1005 vorhanden sind. Diese Ereignisse werden nach einer erfolgreichen DS2MB-Replikation protokolliert. Sobald diese Ereignisse protokolliert wurden, können Sie den Systemaufsichtsdienst beenden.

Wenn auf einem Front-End-Server kein SMTP verwendet wird, besteht die empfohlene Konfiguration im Anhalten des Systemaufsichtsdiensts, der anschließend deaktiviert werden muss. Auf Front-End-Servern, die SMTP verwenden, und auf allen anderen Exchange Server-Computern muss der Exchange-Systemaufsichtsdienst ausgeführt werden, um Nachrichten zu übermitteln, SMTP- und Postfachspeichertransaktionen zu verarbeiten und die DS2MB-Replikation auszuführen.

Es wird empfohlen, den Exchange-Systemaufsichtsdienst jeweils auf den Back-End-Servern und allen anderen Exchange-Servern auszuführen, auf denen sich Postfächer oder Öffentliche Ordner befinden.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie das MMC-Snap-In (Microsoft Management Console) Dienste.

  2. Führen Sie im rechten Bereich einen Bildlauf bis zum Dienst Microsoft Exchange-Systemaufsicht aus, und doppelklicken Sie darauf. Das Dialogfeld Eigenschaften von Systemaufsichtsdienst wird angezeigt.

  3. Legen Sie den Wert in der Dropdownliste Starttyp auf Automatisch fest.

  4. Klicken Sie auf Starten, um den Systemaufsichtsdienst zu starten.

  5. Klicken Sie auf OK, um die Änderungen zu speichern und das Dialogfeld Eigenschaften von Systemaufsichtsdienst zu schließen.

  6. Schließen Sie das Snap-In Dienste.

Weitere Informationen zum Deaktivieren des Systemaufsichtsdiensts und zum Sichern von Exchange-Servern finden Sie in folgenden Themen zu Exchange Server:

  • „Securing Exchange 2000 Servers Based on Role" unter http://go.microsoft.com/fwlink/?LinkId=35585.

  • „Exchange Server 2003-Sicherheitshandbuch" unter http://www.microsoft.com/germany/technet/datenbank/articles/600363.mspx.


Der Exchange-Systemaufsichtsdienst ist nicht aktiv.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-09

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation -Windows®-Verwaltungsinstrumentation) Win32_Service ab, um den Wert des Schlüssels Started für den Microsoft Exchange-Systemaufsichtsdienst zu bestimmen. Der Wert False gibt an, dass der Microsoft Exchange-Systemaufsichtsdienst nicht ausgeführt wird. Der Wert True gibt an, dass der Microsoft Exchange-Systemaufsichtsdienst ausgeführt wird.

Microsoft Exchange Server Analyzer überprüft auch die WMI-Klasse Exchange_Server im Namespace root\MicrosoftExchangeV2, um den Wert für den Schlüssel IsFrontEndServer zu bestimmen. Der Wert False gibt an, dass der Exchange Server-Computer kein Front-End-Server ist. Der Wert True gibt an, dass der Exchange Server-Computer ein Front-End-Server ist.

Wenn Exchange Server Analyzer feststellt, dass für einen Exchange Server-Computer, der kein Front-End-Server ist, der Wert für den Schlüssel Started auf False festgelegt ist, wird eine Warnung angezeigt.

Im allgemeinen wird auf den meisten Exchange-Servern die Systemaufsicht ständig ausgeführt. Gelegentlich ist die Ausführung der Systemaufsicht jedoch nicht erforderlich. Auf einem Front-End-Server mit Exchange 2000 Server oder Exchange Server 2003 ist der Systemaufsichtsdienst nur für das Vornehmen von Konfigurationsänderungen auf dem Server erforderlich.

Bei Exchange Server werden alle Konfigurationsinformationen im Active Directory®-Verzeichnisdienst gespeichert. Hierzu zählen u. a. Informationen über Empfängerrichtlinien, die Konfiguration virtueller SMTP-Server (SMTP - Simple Mail Transfer Protocol), die Einstellungen für RPC über HTTP (RPC - Remote Procedure Call; HTTP - Hypertext Transfer Protocol) und Benutzerpostfächer. SMTP liest jedoch die eigenen Einstellungen aus der IIS-Metabase (Internet Information Services). Um die IIS-Metabase mit den Informationen zu füllen, die Exchange für SMTP- und RPC-über-HTTP-Funktionen benötigt, repliziert die DS2MB-Komponente (Directory Service To Metabase) der Systemaufsicht die Konfigurationsinformationen aus Active Directory mit der IIS-Metabase. Wenn die Systemaufsicht nicht ausgeführt wird, werden die an Einstellungen der Exchange Server-Konfiguration vorgenommenen Änderungen aus Active Directory nicht in die IIS-Metabase von Exchange Server kopiert. Wenn keine Konfigurationsänderungen vorgenommen und keine SMTP-Nachrichten verarbeitet werden, kann der Systemaufsichtsdienst im angehaltenen Zustand verbleiben.

Wenn Konfigurationsänderungen vorgenommen werden müssen, starten Sie den Systemaufsichtsdienst, nehmen Sie die Änderungen an der Konfiguration vor, und warten Sie anschließend, bis diese Änderungen auf die IIS-Metabase repliziert werden. Um festzustellen, ob die Änderungen von Active Directory auf die IIS-Metabase repliziert wurden, überprüfen Sie, ob im Anwendungsereignisprotokoll von Exchange Server drei Einträge mit der Ereignisquelle MSExchangeMU und der Ereignis-ID 1005 vorhanden sind. Diese Ereignisse werden nach einer erfolgreichen DS2MB-Replikation protokolliert. Sobald diese Ereignisse protokolliert wurden, können Sie den Systemaufsichtsdienst beenden.

Wenn auf einem Front-End-Server mit Exchange 2000 Server oder Exchange Server 2003 kein SMTP verwendet wird, besteht die empfohlene Konfiguration im Beenden des Systemaufsichtsdiensts, der anschließend deaktiviert werden muss. Auf Front-End-Servern mit Exchange 2000 Server oder Exchange Server 2003, auf denen SMTP verwendet wird, sowie auf allen anderen Computern mit Exchange Server muss der Exchange-Systemaufsichtsdienst ausgeführt werden, um Nachrichten zu übermitteln, SMTP- und Postfachspeichertransaktionen zu verarbeiten und die DS2MB-Replikation auszuführen.

Es wird empfohlen, den Exchange-Systemaufsichtsdienst jeweils auf den Back-End-Servern und allen anderen Exchange-Servern auszuführen, auf denen sich Postfächer oder Öffentliche Ordner befinden.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie das MMC-Snap-In (Microsoft Management Console) Dienste.

  2. Führen Sie im rechten Bereich einen Bildlauf bis zum Dienst Microsoft Exchange-Systemaufsicht aus, und doppelklicken Sie darauf. Das Dialogfeld Eigenschaften von Systemaufsichtsdienst wird angezeigt.

  3. Legen Sie den Wert im Dropdownmenü Starttyp auf Automatisch fest.

  4. Klicken Sie auf Starten, um den Systemaufsichtsdienst zu starten.

  5. Klicken Sie auf OK, um die Änderungen zu speichern und das Dialogfeld Eigenschaften von Systemaufsichtsdienst zu schließen.

  6. Schließen Sie das Snap-In Dienste.

Weitere Informationen zum Deaktivieren des Systemaufsichtsdiensts und zum Sichern von Exchange-Servern finden Sie unter „Securing Exchange 2000 Servers Based on Role" unter http://go.microsoft.com/fwlink/?linkid=35585.


Exchmem-Heaps weisen auf Leistungsprobleme hin.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer hat die Leistungsindikatoren Exchmem Heap unter dem Leistungsobjekt MSExchangeIS analysiert, um zu bestimmen, ob die Leistung auf dem Exchange-Server gesunken ist. Exchange Server Analyzer Tool wertet die Exchmem-Zähler in folgender Weise aus:

  • Wenn die Anzahl von Exchmem: Number of heaps with memory errors größer als null ist, meldet Exchange Server Analyzer eine Warnung. Wenn dieser Wert größer als fünf ist, meldet Exchange Server Analyzer einen Fehler.

  • Wenn die Anzahl von Exchmem: Number of memory errors ist größer als drei. Exchange Server Analyzer meldet einen Fehler.

  • Wenn die Anzahl von Exchmem: Number Additional Heaps ist größer als drei. Exchange Server Analyzer meldet einen Fehler.

Der Prozess Store.exe verwendet seine eigenen Mechanismen und Strukturen für die Heap-Zuordnung. Diese werden als Exchmem bezeichnet. Beim Systemstart erstellt der Prozess Store.exe mehrere Exchmem-Heaps. Store.exe erhöht die Anzahl der Heaps erst, wenn die vorhandenen Heaps vollständig belegt oder so stark fragmentiert sind, dass eine Zuordnung nicht ausreichend zusammenhängenden Speicher finden kann, um erfolgreich zu sein.

Wenn es Probleme bei der Speicherverwendung gibt oder interne Fragmentierung auftritt (d. h. Fragmentierung in den Exchmem-Heaps, die sich im virtuellen Speicher des Exchange-Informationsspeichers befinden), erstellt der Prozess Store.exe neue Exchmem-Heaps.

Wenn der Prozess „Store.exe" wiederholt zusätzliche Heaps erstellen muss, wird im Allgemeinen der gesamte virtuelle Speicher von Exchange-Informationsspeicher fragmentiert oder stark reduziert. Durch Verfolgen der o. g. Leistungsindikatoren können Sie ermitteln, ob die Exchmem-Heaps eine Ursache des Problems sind oder ob deren Leistung mit zunehmender Fragmentierung abnimmt.

So beheben Sie die Warnung oder den Fehler

  • Downloaden und installieren Sie die neuesten Updates für Exchange-Informationsspeicher.

    • Die aktuellen Service Packs für Exchange Server 2003 finden Sie auf der Website „Downloads for Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

    • Die aktuellen Downloads für Exchange 2000 Server finden Sie auf der Website „Downloads for Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=33457).

  • Downloaden und installieren Sie die neuesten Updates für alle Anwendungen, die im Prozess „Store.exe" ausgeführt werden. Manchmal können Anwendungen von Drittanbietern, die im Store.exe-Prozess ausgeführt werden, Heap-Fragmentierung verursachen.

  • Ziehen Sie in Betracht, Postfächer vom betroffenen Server zu einem anderen zu verschieben, um die Server-Last zu reduzieren. Weitere Informationen finden Sie unter Verschieben von Benutzerpostfächern auf einen anderen Server.

  • Sie können den Speicher so lange wie erforderlich durch Neustart zurückzusetzen, bis Sie die Ursache für das Problem identifiziert haben.

Weitere Informationen

  • Weitere Informationen zur Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=de).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=de).


EXCHMEM.DLL im Windows System32-Ordner vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) CIM_Datafile ab, um zu ermitteln, ob sie den Wert des Schlüssels Version für \Windows\System32\Exchmem.dll lesen kann. Wenn Exchange Server Analyzer den Schlüssel lesen kann, befindet sich Exchmem.dll im Ordner System32.

Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Objekte mit der Objektklasse msExchExchangeServer zu ermitteln. Wenn der Zeichenfolgenwert „Version 6" enthält, wird auf dem Computer Exchange 2000 Server oder Exchange Server 2003 ausgeführt.

Microsoft Exchange Server Analyzer zeigt eine Meldung mit der optimalen Methode an, wenn die folgenden Bedingungen erfüllt sind:

  • EXCHMEM.DLL ist im Windows System32-Ordner vorhanden

  • Auf dem Computer wird Exchange 2000 Server oder Windows Server 2003 ausgeführt.

Gewöhnlich gibt es keine zwei Kopien der Datei Exchmem.dll auf einem Server. Manchmal wird jedoch durch die direkte Aktualisierung von früheren Versionen des Produkts eine zweite Datei Exchmem.dll hinzugefügt. Wenn es zwei Versionen dieser Datei gibt, kann die Installation von Service Packs fehlschlagen. Um Probleme zu vermeiden, wird empfohlen, dass Sie die Datei Exchmem.dll im Ordner \Windows\System32 umbenennen oder aus dem Ordner entfernen.

So entfernen Sie eine zweite Version von Exchmem.dll oder benennen sie um

  1. Beenden Sie alle Exchange-Dienste.

  2. Benennen Sie die Datei Exchmem.dll im Ordner \Windows\System32 um.

  3. Starten Sie alle Exchange-Dienste neu.


Es wurde ein schwerwiegender Fehler gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-10-06

Microsoft® Exchange Server Analyzer versucht auf verschiedene spezielle Ressourcen zuzugreifen, um Analysen durchzuführen:

  • Microsoft Active Directory®-Verzeichnisdienst

  • Exchange Server-Nachrichtenstatus

  • Microsoft Windows®-Registrierung

  • Microsoft Windows®-Verwaltungsinstrumentation (WMI)

  • IIS-Metabasis (Internetinformationsdienste)

Wenn Exchange Server Analyzer auf eine oder mehrere der erforderlichen Ressourcen nicht zugreifen kann, wird von Exchange Server Analyzer ein Fehler angezeigt.

Dieser Fehler zeigt an, dass weitere Analysen erforderlich sind, weil auf eine oder mehrere dieser Basisressourcen nicht zugreifen werden kann.

Um dieses Problem zu beheben, müssen Sie die von Exchange Server Analyzer bereitgestellten Anweisungen und Links zu dem ressourcenspezifischen Fehler überprüfen.


FCL-Protokollierung ist für den Server nicht aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-20

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert serialNumber-Attributs für alle Objekte mit der Objektklasse msExchExchangeServer zu ermitteln. Wenn der Zeichenfolgenwert Version 5.5 enthält, wird auf dem Computer Microsoft Exchange Server, Version 5.5, ausgeführt. Wenn der Zeichenfolgenwert Version 6.0 enthält, wird auf dem Computer Microsoft Exchange 2000 Server ausgeführt. Wenn der Zeichenfolgenwert Version 6.5 enthält, wird auf dem Computer Microsoft Exchange 2003 Server ausgeführt.

Exchange Server Analyzer fragt weiterhin ab, ob im folgenden Registrierungseintrag der Unterschlüssel Disable Call Tracing vorhanden ist, um zu ermitteln, ob das FCL-Feature (Function Call Logging) von Microsoft Exchange für den Exchange-Server aktiviert ist:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server kann die Leistung interner Aufrufe des Microsoft Exchange-Informationsspeicherdienstes (Store.exe) verfolgen. Mithilfe von FCL können Sie die Komponente und den Funktionsaufruf eingrenzen, der als mögliche Grundursache für das Leistungsproblem in Frage kommt.

Die FCL-Funktionalität des Microsoft Exchange-Informationsspeicherdienstes verfolgt die relevanten Aufrufe der folgenden Komponenten:

  • Local Security Authentication Server (Lsass.exe)

  • DSAccess

  • Extensible Storage Engine (ESE)

  • IMAIL

  • Virenscanner

Bei FCL handelt es sich um eine Protokollierung mit geringem Aufwand, die Daten zu Problemszenarios erfasst, wie z. B. Probleme beim Herunterfahren von Exchange Server oder Situationen, in denen der Exchange-Informationsspeicherdienst (Store.exe) eine verringerte Leistung zeigt oder nicht reagiert.

Sobald FCL aktiviert ist, werden die Daten für Funktionsaufrufe automatisch protokolliert. Benutzereingriffe oder eine spezielle Konfiguration, wie z. B. Abrufen einer Benutzerabbilddatei des Produktionsservers oder die Verwendung eines Debuggers, sind nicht erforderlich.

FCL ist standardmäßig in Exchange Server 2003 aktiviert, muss aber in Exchange 2000 Server speziell aktiviert werden.

Exchange Server Analyzer zeigt eine Best Practices-Meldung an, wenn folgende Bedingungen erfüllt sind:

  • Auf dem Server wird Exchange 2000 Server ausgeführt. Der Unterschlüssel Disable Call Tracing ist nicht vorhanden oder weist einen anderen Wert als 0 auf.

  • Auf dem Server wird Exchange Server 2003 ausgeführt. Der Unterschlüssel Disable Call Tracing ist vorhanden und weist einen anderen Wert als 0 auf.

Diese Best Practices-Meldung zeigt an, dass FCL deaktiviert ist.

Im Rahmen bewährter Methoden wird empfohlen, FCL auf allen Exchange-Servern zu aktivieren.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema "Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So aktivieren Sie die Protokollierung von Funktionsaufrufen in Exchange 2000 Server

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Disable Call Tracing.

  3. Doppelklicken Sie im rechten Bereich auf Disable Call Tracing. Erstellen Sie einen neuen DWORD-Wert mit der Bezeichnung Disable Call Tracing, wenn dieser Unterschlüssel nicht vorhanden ist.

  4. Legen Sie den Wert des Unterschlüssels Disable Call Tracing auf 0 fest.
Hinweis:
Standardmäßig ist FCL in Exchange 2000 Server deaktiviert und dieser Wert auf 1 festgelegt.
  1. Schließen Sie den Registrierungs-Editor.

  2. Starten Sie den Exchange-Informationsspeicher neu, damit die Änderungen wirksam werden.

 So aktivieren Sie die Protokollierung von Funktionsaufrufen in Exchange Server 2003

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Disable Call Tracing.

  3. Doppelklicken Sie im rechten Bereich auf Disable Call Tracing.

  4. Legen Sie den Wert des Unterschlüssels Disable Call Tracing auf 0 fest.
Hinweis:
FCL ist in Exchange Server 2003 standardmäßig aktiviert. Der Unterschlüssel Disable Call Tracing ist daher vorhanden und weist einen von 0 verschiedenen Wert auf.
  1. Schließen Sie den Registrierungs-Editor.

  2. Starten Sie den Exchange-Informationsspeicher neu, damit die Änderungen wirksam werden.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 "Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Die aus freien Seiten bestehenden Tabelleneinträge befinden sich an der kritischen Schwelle.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation -Windows®-Verwaltungsinstrumentation) Win32_PerfRawData_PerfOS_Memory ab, um den aktuellen Wert für das Objekt FreeSystemPageTableEntries zu ermitteln. Wenn der Wert für FreeSystemPageTableEntries kleiner oder gleich 5000 ist, wird ein Fehler angezeigt.

Microsoft Windows Server™ 2003 und Windows 2000 Server können bis zu 4 GB Speicheradressraum direkt adressieren, unabhängig von der Größe des installierten physischen Arbeitsspeichers. Jedes Element einer virtuellen Adresse weist aus Prozesssicht konzeptionell auf ein Byte physischen Speichers. Es gehört zu den Aufgaben des Virtual Memory-Managers (VMM) zusammen mit der Speichermanagereinheit (MMU, Memory Manager Unit) des Prozessors, jede virtuelle Adresse in die entsprechende physische Adresse zu übersetzen bzw. sie darauf abzubilden. VMM führt diese Abbildung durch, indem er den RAM in Seitenframes mit fester Größe aufteilt, Seitentabelleneinträge (PTEs, Page Table Entries) zum Speichern der Informationen über diese Seitenframes erstellt und diese abbildet. Seitentabelleneinträge sind kleine Kernelmodus-Speicherpuffer, die verwendet werden, um mit dem Datenträger-E/A-Teilsystem und dem Netzwerk zu kommunizieren. Jeder Tabelleneintrag stellt einen Seitenframe dar und enthält die für VMM notwendigen Informationen, um eine Seite zuzuordnen.

In einem x86-basierten System, das eine Seitengröße von 4 KB verwendet, beträgt die Maximalanzahl der Seitentabelleneinträge, die zum Abbilden von 2 GB Adressraum benötigt wird, 524.288 (2 GB/4 KB). Auf einem vergleichbaren System, das den /3GB-Schalter verwendet, ist die Anzahl der Seitentabelleneinträge, die benötigt werden, um 3 GB Adressraum abzubilden, 786.432 (3 GB/4 KB). Auf einem typischen System wird dieser Raum wie folgt verwendet:

  • Ein Maximum von 50.000 Seitentabelleneinträgen (ungefähr 195 MB Adressraum) wird für allgemeine Verwendung reserviert.

  • Der Rest wird zum Abbilden von Systemcache, Hyperspace, ausgelagertem Pool, nicht ausgelagertem Pool, Bereich für Absturzspeicherabbild usw. verwendet.

Diese Poolgröße für Seitentabelleneinträge wird, basierend auf der im System vorhandenen Menge an physischem Speicher, automatisch beim Systemstart bestimmt. Dieser Pool wird zwischen ausgelagertem Pool und nicht ausgelagertem Pool eingefügt, der ebenfalls mit der Größe des physischen Speichers im System wächst.

Der Pool mit Seitentabelleneinträgen kann stark verwendet und hochgradig fragmentiert werden. Dies kann zu Situationen führen, in denen ein Treiber nicht geladen wird. Wenn der PTE-Pool des Systems auf null reduziert wird, werden davon andere Teile des Systems beeinträchtigt. Dies führt sogar dazu, dass Threads nicht erstellt werden, dass das System blockiert und möglicherweise abstürzt.

Ein gesunder Exchange Server-Computer sollte mindestens 8.000 Seitentabelleneinträge jederzeit verfügbar haben. Wenn die Anzahl freier Seitentabelleneinträge unter 8.000 fällt, jedoch über 5.000 bleibt, wird die in Freie Seitentabelleneinträge befinden sich an der Warnschwelle. beschriebene Warnung angezeigt. Wenn die Anzahl freier Seitentabelleneinträge unter 5.000 fällt, wird dieser Fehler angezeigt.

Um dieses Problem zu beheben, können Sie die nachfolgend beschriebene Vorgehensweise verwenden, um den Registrierungswert SystemPages für das Betriebssystem Ihres Exchange Server-Computers entsprechend zu konfigurieren. Wenn Sie Exchange Server 2003 Service Pack 1 (SP1) auf Windows Server 2003 mit einem RAM von 1 GB oder mehr ausführen, wird empfohlen, dass Sie den Registrierungsschlüssel SystemPages auf null festlegen. Diese Empfehlung unterscheidet sich von der Empfehlung für Windows 2000 Server, die besagt, dass SystemPages auf den Wert 31000 (dezimal) festgelegt werden soll.

Nachdem Sie die nachfolgend beschriebene Prozedur ausgeführt haben, sollten Sie die Anzahl freier Seitentabelleneinträge überwachen. Das kann geschehen, indem Sie den Leistungsindikator Memory | Free System Page Table Entries mit dem Windows-Systemmonitor überwachen. Wenn die Anzahl der freien Seitentabelleneinträge niedrig bleibt, nachdem Sie die Änderungen an der Registrierung vorgenommen haben, sollten Sie Folgendes prüfen, um sicherzugehen, dass der Exchange Server-Computer optimal konfiguriert ist:

  • Treiber Ein beschädigter Treiber stellt eine der Hauptursachen für eine geringe Anzahl von Seitentabelleneinträgen im System dar. Wenden Sie sich an Ihren Hardwarehersteller, um sich zu vergewissern, ob Sie die aktuellsten Treiber für Ihre Hardware verwenden. Es kann aber auch die Möglichkeit geben, zu einem einfacheren Treiber zurückzukehren. Beispielsweise brauchen Computer, auf denen serverbasierte Anwendungen wie Exchange Server ausgeführt werden, im Allgemeinen nicht die fortgeschrittensten Videotreiber mit all ihren Eigenschaften. Stattdessen ist ein einfacherer Treiber oft ausreichend. Das Wechseln von einem fortgeschrittenen Videotreiber zu einem einfachen Videotreiber sollte die Anzahl freier Seitentabelleneinträge erhöhen.

  • Systemkonfiguration Wenn auf Ihrem Windows Server 2003-System 1 GB oder mehr an physischem Speicher installiert ist, sollten Sie überprüfen, ob die Datei boot.ini ordnungsgemäß mit den Schaltern /3GB und /USERVA=3030 konfiguriert ist, wie in den folgenden Microsoft Knowledge Base-Artikeln beschrieben: 823440, „Sie müssen die Startoption "/3GB" verwenden, wenn Sie Exchange Server 2003 auf einem Windows Server 2003-System installieren" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440 und 810371, „XADM: „Using the /Userva switch on Windows Server 2003-based computers that are running Exchange Server" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371.

  • Ereignisprotokolle Prüfen Sie das Ereignisprotokoll der Anwendung auf dem Exchange-Server auf Fehler und Warnungen, insbesondere auf die MSExchangeIS-Ereignisse 9582 (Fehler und Warnungen), 9665 (Warnung) und 12880 (Fehler). Das Vorhandensein von Ereignis 9665 könnte auch anzeigen, dass SystemPages nicht für eine optimale Leistung konfiguriert ist. Weitere Informationen zu diesen Ereignissen finden Sie im Microsoft Knowledge Base-Artikel 325044, „SO WIRD'S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diesen Fehler auf einem Windows 2000 Server-Computer

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Doppelklicken Sie im rechten Bereich auf SystemPages.

  4. Geben Sie im Feld Wert den Wert 31000 (dezimal) ein. (31000 ist die dezimale Darstellung des Hexadezimalwerts 7918. Regedit.exe verwendet in der Standardeinstellung Hexadezimalwerte.) Klicken Sie anschließend auf OK.

  5. Beenden Sie den Registrierungs-Editor, und starten Sie den Computer neu, damit die Änderung wirksam wird.

So beheben Sie diesen Fehler auf einem Windows Server 2003-Computer mit Originalversion

  • Lesen Sie zum Bestimmen der tatsächlich verfügbaren freien Seitentabelleneinträge den Microsoft Knowledge Base-Artikel 894067, „The Performance tool does not accurately show the available Free System Page Table entries in Windows Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067.

So beheben Sie diesen Fehler auf einem Windows Server 2003-Computer mit SP1

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Doppelklicken Sie im rechten Bereich auf SystemPages.

  4. Geben Sie im Feld Wert den Wert 0 ein, und klicken Sie dann auf OK.

  5. Schließen Sie den Registrierungs-Editor.

  6. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und klicken Sie dann auf Eigenschaften. Das Dialogfeld Systemeigenschaften wird angezeigt.

  7. Klicken Sie auf Erweitert.

  8. Klicken Sie im Bereich Starten und Wiederherstellen auf Einstellungen. Das Dialogfeld Starten und Wiederherstellen wird angezeigt.

  9. Klicken Sie im Bereich Systemstart auf Bearbeiten. Dadurch wird die Windows-Datei Boot.ini in Microsoft Editor geöffnet.

  10. Überprüfen Sie den Abschnitt [Operating Systems].

    1. Wenn der Schalter /3GB vorhanden ist, nicht aber der Schalter /USERVA=3030, fügen Sie der Zeile startup den Schalter /USERVA=3030 hinzu, um die Konfiguration /3GB /USERVA=3030 zu erhalten.

    2. Wenn die Schalter /3GB /USERVA=3030 bereits konfiguriert sind, ändern Sie den Wert des Schalters /USERVA in /USERVA=2970.

  11. Speichern Sie die Änderungen, und schließen Sie Editor.

  12. Klicken Sie zweimal auf OK, um die geöffneten Dialogfelder zu schließen, und starten Sie den Computer anschließend neu, damit die Änderungen wirksam werden.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Optimieren des Speichers für Exchange Server finden Sie in den folgenden Artikeln der Knowledge Base:

  • 894067, „The Performance tool does not accurately show the available Free System Page Table entries in Windows Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067

  • 325044, „SO WIRD'S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044

  • 823150, „So ermitteln Sie Daten für die Behandlung von Problemen mit dem virtuellen Speicher in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=823150

  • 815372, „Optimieren der Speichernutzung in ExchangeServer 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372

  • 311901, „The effects of 4GT tuning on System Page Table Entries" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901


Freie Seitentabelleneinträge befinden sich an der Warnschwelle.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation -Windows®-Verwaltungsinstrumentation) Win32_PerfRawData_PerfOS_Memory ab, um den aktuellen Wert für das Objekt FreeSystemPageTableEntries zu ermitteln. Wenn der Wert für FreeSystemPageTableEntries größer als 5000, jedoch kleiner als oder gleich 8000 ist, wird eine Warnung angezeigt.

Microsoft Windows Server™ 2003 und Windows 2000 Server können bis zu 4 GB Speicheradressraum direkt adressieren, unabhängig von der Größe des installierten physischen Arbeitsspeichers. Jedes Element einer virtuellen Adresse weist aus Prozesssicht konzeptionell auf ein Byte physischen Speichers. Der VMM (Virtual Memory Manager) ist zusammen mit der MMU (Memory Manager Unit, Speicherverwaltungseinheit) des Prozessors dafür zuständig, jede virtuelle Adresse in eine entsprechende physischen Adresse zu übersetzen bzw. einer solchen zuzuordnen. VMM führt diese Abbildung durch, indem er den RAM in Seitenframes mit fester Größe aufteilt, Seitentabelleneinträge (PTEs, Page Table Entries) zum Speichern der Informationen über diese Seitenframes erstellt und diese abbildet. Seitentabelleneinträge sind kleine Kernelmodus-Speicherpuffer, die verwendet werden, um mit dem Datenträger-E/A-Teilsystem und dem Netzwerk zu kommunizieren. Jeder Tabelleneintrag stellt einen Seitenframe dar und enthält die für VMM notwendigen Informationen, um eine Seite zuzuordnen.

In einem x86-basierten System, das eine Seitengröße von 4 KB verwendet, beträgt die Maximalanzahl der Seitentabelleneinträge, die zum Abbilden von 2 GB Adressraum benötigt wird, 524.288 (2 GB/4 KB). Auf einem vergleichbaren System, das den /3GB-Schalter verwendet, ist die Anzahl der Seitentabelleneinträge, die benötigt werden, um 3 GB Adressraum abzubilden, 786.432 (3 GB/4 KB). Auf einem typischen System wird dieser Raum wie folgt verwendet:

  • Ein Maximum von 50.000 Seitentabelleneinträgen (ungefähr 195 MB Adressraum) wird für allgemeine Verwendung reserviert.

  • Der Rest wird zum Abbilden von Systemcache, Hyperspace, ausgelagertem Pool, nicht ausgelagertem Pool, Bereich für Absturzspeicherabbild usw. verwendet.

Diese Poolgröße für Seitentabelleneinträge wird, basierend auf der im System vorhandenen Menge an physischem Speicher, automatisch beim Systemstart bestimmt. Dieser Pool wird zwischen ausgelagertem Pool und nicht ausgelagertem Pool eingefügt, der ebenfalls mit der Größe des physischen Speichers im System wächst.

Der Pool mit Seitentabelleneinträgen kann stark verwendet und hochgradig fragmentiert werden. Dies kann zu Situationen führen, in denen ein Treiber möglicherweise nicht geladen wird. Außerdem kann sich, wenn der PTE-Pool des Systems vollständig entleert wird, die Leistungsfähigkeit anderer Teile des Systems verschlechtern, was dazu führen kann, dass Threads nicht erstellt werden, dass das System blockiert und möglicherweise abstürzt.

Ein gesunder Exchange Server-Computer sollte mindestens 8.000 Seitentabelleneinträge jederzeit verfügbar haben. Wenn die Anzahl der freien Seitentabelleneinträge unter 5.000 fällt, wird der unter Die aus freien Seiten bestehenden Tabelleneinträge befinden sich an der kritischen Schwelle. beschriebene Fehler angezeigt: Wenn die Anzahl der freien Seitentabelleneinträge des Systems unter 8.000 fällt, jedoch noch über 5.000 beträgt, wird diese Warnung angezeigt.

Um dieses Problem zu beheben, können Sie die nachfolgend beschriebene Vorgehensweise verwenden, um den Registrierungswert SystemPages für das Betriebssystem Ihres Exchange Server-Computers entsprechend zu konfigurieren. Wenn Sie Exchange Server 2003 Service Pack 1 (SP1) auf Windows Server 2003 mit einem RAM von 1 GB oder mehr ausführen, wird empfohlen, dass Sie den Registrierungsschlüssel SystemPages auf null festlegen. Diese Empfehlung unterscheidet sich von der Empfehlung für Windows 2000 Server, die besagt, dass SystemPages auf den Wert 31.000 (dezimal) festgelegt werden soll.

Nachdem Sie die folgende Prozedur ausgeführt haben, überwachen Sie die Anzahl der freien Seitentabelleneinträge des Systems. Das kann geschehen, indem Sie den Leistungsindikator Memory | Free System Page Table Entries mit dem Windows-Systemmonitor überwachen. Wenn die Anzahl der freien Seitentabelleneinträge des Systems niedrig bleibt, nachdem Sie die Änderungen an der Registrierung wie beschrieben vorgenommen haben, sollten Sie Folgendes prüfen, um sicherzustellen, dass der Exchange Server-Computer optimal konfiguriert ist:

  • Treiber Ein beschädigter Treiber stellt eine der Hauptursachen für eine geringe Anzahl von Seitentabelleneinträgen im System dar. Wenden Sie sich an den Hardwarehersteller, um zu prüfen, ob Sie die aktuellen Treiber für Ihre Hardware verwenden. Es kann aber auch die Möglichkeit geben, zu einem einfacheren Treiber zurückzukehren. Beispielsweise brauchen Computer, auf denen serverbasierte Anwendungen wie Exchange Server ausgeführt werden, im Allgemeinen nicht die fortgeschrittensten Videotreiber mit all ihren Eigenschaften. Stattdessen ist ein einfacherer Treiber oft ausreichend. Das Wechseln von einem fortgeschrittenen Videotreiber zu einem einfachen Videotreiber sollte die Anzahl freier Seitentabelleneinträge erhöhen.

  • Systemkonfiguration Wenn auf Ihrem Windows Server 2003-System 1 GB oder mehr an physischem Speicher installiert ist, sollten Sie überprüfen, ob die Datei boot.ini ordnungsgemäß mit den Schaltern /3GB und /USERVA=3030 konfiguriert ist, wie in den folgenden Microsoft Knowledge Base-Artikeln beschrieben: 823440, „Sie müssen die Startoption "/3GB" verwenden, wenn Sie Exchange Server 2003 auf einem Windows Server 2003-System installieren" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440 und 810371, „XADM: „Using the /Userva switch on Windows Server 2003-based computers that are running Exchange Server" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371.

  • Ereignisprotokolle Prüfen Sie das Ereignisprotokoll der Anwendung auf dem Exchange-Server auf Fehler und Warnungen, insbesondere auf die MSExchangeIS-Ereignisse 9582 (Fehler und Warnungen), 9665 (Warnung) und 12880 (Fehler). Ereignis 9665 kann auch anzeigen, dass SystemPages nicht für eine optimale Leistung konfiguriert ist. Weitere Informationen zu diesen Ereignissen finden Sie im Microsoft Knowledge Base-Artikel 324044, „SO WIRD'S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" unter http://support.microsoft.com/default.aspx?scid=kb;de;325044.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diese Warnung auf einem Windows 2000 Server-Computer

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Doppelklicken Sie im rechten Teilfenster auf SystemPages.

  4. Geben Sie im Feld Wert den Wert 31000 (dezimal) ein. (31000 ist die dezimale Darstellung des Hexadezimalwerts 7918. Regedit.exe verwendet in der Standardeinstellung Hexadezimalwerte.) Klicken Sie anschließend auf OK.

  5. Beenden Sie den Registrierungs-Editor, und starten Sie den Computer neu, damit die Änderung wirksam wird.

So beheben Sie diese Warnung auf einem Windows Server 2003-Computer mit Originalversion

  • Lesen Sie zum Bestimmen der tatsächlich verfügbaren freien Seitentabelleneinträge den Microsoft Knowledge Base-Artikel 894067, „The Performance tool does not accurately show the available Free System Page Table entries in Windows Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067.

So beheben Sie diese Warnung auf einem Windows Server 2003-Computer mit SP1

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Doppelklicken Sie im rechten Teilfenster auf SystemPages.

  4. Geben Sie im Feld Wert den Wert 0 ein, und klicken Sie dann auf OK.

  5. Schließen Sie den Registrierungs-Editor.

  6. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und klicken Sie dann auf Eigenschaften. Das Dialogfeld Systemeigenschaften wird angezeigt.

  7. Klicken Sie auf Erweitert.

  8. Klicken Sie im Bereich Starten und Wiederherstellen auf Einstellungen. Das Dialogfeld Starten und Wiederherstellen wird angezeigt.

  9. Klicken Sie im Bereich Systemstart auf Bearbeiten. Dadurch wird die Windows-Datei Boot.ini in Microsoft Editor geöffnet.

  10. Überprüfen Sie den Abschnitt [Operating Systems].

    1. Wenn der Schalter /3GB vorhanden ist, nicht aber der Schalter /USERVA=3030, fügen Sie der Zeile startup den Schalter /USERVA=3030 hinzu, um die Konfiguration /3GB /USERVA=3030 zu erhalten.

    2. Wenn die Schalter /3GB /USERVA=3030 bereits konfiguriert sind, ändern Sie den Wert des Schalters /USERVA in /USERVA=2970.

  11. Speichern Sie die Änderungen, und schließen Sie Editor.

  12. Klicken Sie zweimal auf OK, um die geöffneten Dialogfelder zu schließen, und starten Sie den Computer anschließend neu, damit die Änderungen wirksam werden.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Optimieren des Speichers für Exchange Server finden Sie in den folgenden Artikeln der Knowledge Base:

  • 894067, „The Performance tool does not accurately show the available Free System Page Table entries in Windows Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067

  • 325044, „SO WIRD'S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044

  • 823150, „So ermitteln Sie Daten für die Behandlung von Problemen mit dem virtuellen Speicher in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=823150

  • 815372, „Optimieren der Speichernutzung in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372

  • 311901, „The effects of 4GT tuning on System Page Table Entries" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901


Auf dem Front-End-Server wird der Standortreplikationsdienst ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt das Exchange Server-Microsoft-WMI-Objekt (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) (Klasse Exchange_Server) ab, um den Wert IsFrontEndServer für den Server zu bestimmen. Wenn der Wert True ist, wird der Exchange-Server als Front-End-Server verwendet. Exchange Server Analyzer fragt auch das WMI-Objekt MSExchangeSRS (Klasse Win32_Service) ab, um den Wert für die Eigenschaft Started des Objekts zu bestimmen. Wenn der Wert True ist, wird der Standortreplikationsdienst auf diesem Server ausgeführt.

Wenn Exchange-Server als Front-End-Server angegeben ist und auch weiterhin über eine aktive Instanz des Standortreplikationsdienstes verfügt, wird eine Warnung angezeigt.

Exchange verwendet den Standortreplikationsdienst, wenn in der Topologie Server vorhanden sind, auf denen Exchange Server, Version 5.5, und Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Mit diesem Dienst können höhere Versionen von Exchange Informationen zur Serverkonfiguration auf Exchange Server 5.5-Servern in einer mit dem Exchange Server 5.5-Verzeichnis kompatiblen Form replizieren. Außerdem können sie vom Exchange Server 5.5-Verzeichnis replizierte Konfigurationsinformationen korrekt verarbeiten, sodass diese im Active Directory®-Verzeichnisdienst gespeichert werden können. Wenn die Topologie für die Verwendung von Front-End- und Back-End-Servern konfiguriert ist, sollte der Standortreplikationsdienst nur auf Back-End-Servern ausgeführt werden. Da der Standortreplikationsdienst zu Exchange 2000 Server Service Pack 2 gehört, funktioniert er auf Front-End-Servern nicht ordnungsgemäß und kann Probleme verursachen.

Um dieses Problem zu beheben, konvertieren Sie den Front-End-Server in einen Back-End-Server und konfigurieren einen neuen Front-End-Server. Es wird nicht empfohlen, den Standortreplikationsdienst vom Server zu entfernen.

So beheben Sie diesen Fehler

  1. Konfigurieren Sie einen neuen Front-End-Server.

  2. Klicken Sie auf dem fehlerhaften Front-End-Server im Exchange-System-Manager unter Server mit der rechten Maustaste auf den fehlerhaften Server, und klicken Sie auf Eigenschaften.

  3. Deaktivieren Sie das Kontrollkästchen Dies ist ein Front-End-Server.

Weitere Informationen zu Front-End-Servern und Standortreplikationsdiensten finden Sie im Microsoft Knowledge Base-Artikel 313646, „Services are Disabled on Front-end Servers After an Exchange 2000 Server SP2 Upgrade" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313646).


Datei „GAPI32.DLL" befindet sich nicht in Ordner „bin"
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft sowohl im Ordner System32 als auch im Ordner \Exchsrvr\bin)

  • Mapi32.dll (überprüft sowohl im Ordner System32 als auch im Ordner \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Beim Ausführen von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Product Key ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Die Datei „GAPI32.DLL" befindet sich nicht im Ordner „system32"
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Beim Ausführen von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


GlobalFlag wurde festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft ® Exchange Server Analyzer liest die folgenden Registrierungseinträge, um den Wert für den Eintrag GlobalFlag zu bestimmen:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\MAD.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\INETINFO.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\EMSMTA.EXE

Wenn Microsoft Exchange Analyzer feststellt, dass der Wert für GlobalFlag vorhanden ist und mit einem Wert ungleich 0 oder null konfiguriert ist, wird eine Warnung angezeigt.

Der Registrierungswert GlobalFlag stellt eine Bitmaske dar, in der die für einen bestimmten Prozess aktivierten Debugging-Optionen festgelegt sind. In diesem Fall sucht Microsoft Exchange Server Analyzer speziell nach Debugging-Optionen, die für eine Reihe von Exchange-Komponenten aktiviert wurden:

  • STORE.EXE (der Informationsspeicherprozess)

  • MAD.EXE (der Systemaufsichtsprozess)

  • INETINFO.EXE (der IIS-Verwaltungsprozess und der übergeordnete Prozess)

  • EMSMTA.EXE (der MTA-Prozess)

Wenn Sie kein Problem mit der Unterstützung des technischen Supports von Microsoft debuggen oder verfolgen, sollte der Wert GlobalFlag auf 0 festgelegt oder (mit der gleichen Wirkung) gelöscht werden.

In der Standardeinstellung ist der Registrierungswert GlobalFlag nicht vorhanden und muss manuell hinzugefügt werden, wenn das Debugging des Prozesses STORE.EXE (oder eines anderen Prozesses) erforderlich ist. Sie können das Tool Gflags in den Microsoft® Windows Server™ 2003-Supporttools verwenden, das sich im Ordner \Support auf der Windows-CD befindet. Sie können den Wert auch manuell auf 0 festlegen oder den Wert GlobalFlag mit einem Registrierungs-Editor löschen. Beide Verfahren werden im vorliegenden Artikel dargestellt.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diesen Fehler mithilfe von Gflags

  1. Klicken Sie auf Start und dann auf Ausführen. Im Feld Öffnen führen Sie GFlags aus. Die Benutzeroberfläche von Global Flags wird angezeigt.

  2. Im Feld Bilddateiname geben Sie STORE.EXE ein.

  3. Wählen Sie Bilddateioptionen aus.

  4. Deaktivieren Sie alle Kontrollkästchen, und klicken Sie auf Übernehmen.

  5. Wiederholen Sie Schritt 2 bis 4 für jeden der in diesem Artikel aufgeführten Exchange-Prozesse.

  6. Klicken Sie auf OK, um das GFlags-Tool zu verlassen. Starten Sie die betreffenden Dienste erneut, damit die Änderungen wirksam werden.

So beheben Sie diesen Fehler mit einem Registrierungs-Editor

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

  3. Löschen Sie den Wert mit dem Namen GlobalFlag.

  4. Wiederholen Sie Schritt 2 und 3 für jeden der in diesem Artikel aufgeführten Exchange-Prozesse.

  5. Beenden Sie den Registrierungs-Editor, und starten Sie die betreffenden Dienste neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Es wurde eine große Anzahl von Fehlern bei der ACL-Aktualisierung festgestellt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_PerfRawData_MSExchangeIS_MSExchangeIS ab, um den aktuellen Wert des Schlüssels ACLUpgradefailures zu bestimmen. Der Schlüssel ACLUpgradefailures stellt den Leistungsindikator ACL Upgrade: failures für das Leistungsobjekt MSExchangeIS dar.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Registrierungsschlüssels ACLUpgradefailures mehr als 500 beträgt, zeigt Exchange Server Best Practices Analyzer eine Warnung an.

Diese Warnung besagt, dass der Exchange-Server bei der Aktualisierung von Access Control Lists (ACL - Zugriffssteuerungslisten) zahlreiche Fehler gemeldet hat. Durch übermäßig viele ACL-Aktualisierungsfehler kann es zu schwerwiegenden Leistungsproblemen kommen, wozu auch zufällige Unterbrechungen der Informationsspeicherprozesse (store.exe) gehören.

ACL-Aktualisierungsfehler können aus vielerlei Gründen angezeigt werden und treten meist auf, wenn die folgenden Bedingungen erfüllt sind:

  • In einer Exchange-Organisation mit gemischtem Modus wurde die Konsistenzanpassung von Exchange Server, Version 5.5, nicht ausgeführt, bevor Sie den ADC-Server (Active Directory Connector) implementiert haben. Die Exchange Server 5.5-Konsistenzanpassung entfernt verwaiste ACLs.

  • Die Replikation von Active Directory erfolgt nicht ordnungsgemäß.

  • Die Active Directory Connector-Replikation repliziert die Konten von Exchange Server 5.5 nicht ordnungsgemäß nach Active Directory.

  • Die Migration von Benutzerkonten erfolgte nicht ordnungsgemäß.

So beheben Sie diese Warnung

  1. Lesen Sie den Microsoft Knowledge Base-Artikel 812963, „Using the Ignore Zombie Users Registry Key" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812963).

  2. Nachdem Sie sich über die Auswirkungen der Verwendung des Registrierungsschlüssels Ignore Zombie Users informiert haben, fügen Sie auf eigenes Risiko den Schlüssel hinzu.

  3. Führen Sie Exchange Server Analyzer aus, oder überwachen Sie den Leistungsindikator ACL Upgrade: failures, um nach übermäßigen ACL-Aktualisierungsfehlern zu suchen.


Hochaktiver ExMon-Benutzer
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-04-21

Microsoft® Exchange Server Analyzer verwendet Exchange Server User Monitor (ExMon), um festzustellen, ob ein Benutzer oder ein Prozess (oder eine Gruppe von Benutzern oder Prozessen) die Ursache für einen überproportional hohen Anteil der aktuellen Serverlast bildet.

Es gibt verschiedene Szenarien, die von ExMon ausgewertet werden:

  • Clienteinschränkungen

  • Massenweise ausgeführte RPC-Operationen (Remote Procedure Call)

  • Hohe Werte für RPC-Synchronisierungsvorgänge

  • Eine große Anzahl von Onlineoperationen auf Clients

  • Anzeigevorgänge von Benutzern

Die folgenden Abschnitte enthalten genaue Informationen über jedes Szenario sowie entsprechende Maßnahmenempfehlungen.

Clienteinschränkungen

In diesem Szenario weisen die RPC-Daten von ExMon darauf hin, dass die Einschränkungen des Clientcomputers auf diesem Server eine hohe Last verursachen. Im Kontext von MAPI verweist eine Einschränkung auf die MAPI-Operation mit dem Namen Restrict. Diese Operation dient dazu, solche Objekte auszusuchen, die bestimmten Kriterien entsprechen. Die Operation Restrict ist Teil des Prozesses mit der Anforderung, dass Exchange eine Sicht auf einen Ordner oder eine Ordnergruppe erstellen soll (eigentlich also eine Datenbanktabelle mit zugehörigen Kriterien). Wenn die Ansicht auf den Ordner oder auf die Menge von Ordnern bereits über eine passende Einschränkung verfügt, verwendet der Server die vorhandene Ansicht, um die Benutzeranforderung zu erfüllen. Wenn eine Ansicht nicht über eine passende Einschränkung verfügt, wird von Exchange eine neue Ansicht erstellt. Das Erstellen einer Ansicht ist speicheraufwändiger als das Verwenden einer vorhandenen Ansicht.

Nach vielen Postfachverschiebungen werden die Client-Beschränkungen kurzzeitig rechenintensiver. Die Operation move-mailbox bewirkt, dass ein Server die Indexe für Ordner neu aufbaut. Deshalb müssen alle Einschränkungen aufs Neue erstellt werden, wenn Clients erstmals Ordner auf neuem Server anzeigen, und dies kann im Ergebnis zu schwacher Leistung führen. Wenn Sie nicht erst kürzlich Postfächer verschoben haben, untersuchen Sie Folgendes:

  • Eine andere MAPI-Anwendung ist auf den Client-Computern nicht installiert. Microsoft Office Outlook®-Add-Ins oder andere MAPI-Anwendungen bewirken möglicherweise, dass zu viele Einschränkungen erstellt werden.

  • Postfächer haben eine bestimmte Größte, und dementsprechend sind innerhalb der Organisation Grenzwerte festgelegt.

Weitere Informationen über die Größe von Postfächern die Objektanzahl finden Sie im Blog des Microsoft Exchange Teams in „Recommended Mailbox Size Limits" unter (http://go.microsoft.com/fwlink/?linkid=55097).

Massenweise ausgeführte RPC-Operationen

Beispiele für massenweise ausgeführte RPC-Operationen umfassen das Verschieben, Löschen oder Festlegen von Eigenschaften (d. h. die Lesekennzeichnung) auf Hunderten oder Tausenden Elementen in einem Arbeitsgang. Diese Operationsarten können kurzzeitig die Serverleistung verschlechtern. Wenn Sie häufig massenweise RPC-Vorgänge ausführen und es auf dem Server zu Engpässen mit dem Datenträger oder dem Prozessor kommt, sinkt die Outlook-Leistung für die anderen Benutzer auf demselben Server.

So beheben Sie diesen Fehler

  1. Stellen Sie sicher, dass die Postfachbegrenzungen eingestellt sind.

  2. Empfehlen Sie Ihren Benutzern, ihre Elemente in PST-Dateien zu archivieren.

    Hinweis:
    Als allgemeine optimale Methode sollten Ordner, die häufig verwendet werden, weniger als 5.000 Objekte enthalten.

Hohe Werte für RPC-Synchronisierungsvorgänge

Hohe Werte für RPC-Synchronisierungsvorgänge weisen darauf hin, dass zur Zeit viele Benutzer Elemente synchronisieren. Im Ergebnis ist die Serverlast erhöht.

So beheben Sie diesen Fehler

  • Gewährleisten Sie, dass die Exchange-Server entsprechend der Anzahl von Clientcomputern, die Outlook im Exchange-Cache-Modus ausführen, skaliert wurden. Weitere Informationen finden Sie in Exchange Server 2003 RPC over HTTP Deployment Scenarios unter http://go.microsoft.com/fwlink/?linkid=47577.

  • Durch Verlangsamen von Client-Anforderungen im Exchange-Modus mit Zwischenspeicherung wird verhindert, dass ein Leistungsproblem aufgrund einer hohen Anzahl von RPC-Synchronisierungsoperationen entsteht. Weitere Informationen finden Sie im Knowledge Base-Artikel 818484, „Registry Values and Counters That You Can Use to Configure and Monitor Outlook Client Synchronization" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484.

Eine große Anzahl von Onlineoperationen auf Clients

Manchmal tritt in Exchange ein ungewöhnlich heftiger Anstieg von Leistungsproblemen auf, der durch hohe Last verursacht wird, die über die Benutzer verteilt ist. Dies kann das Ergebnis schlechter Planung beim Wachsen der Organisation sein. Wenn Sie bei der Skalierung Ihrer Organisation die optimalen Methoden von Microsoft befolgt haben, aber dennoch eine schwache Leistung feststellen, die durch Onlinevorgänge von Clients verursacht wird, kann dies ein Hinweis darauf sein, dass die Benutzer MAPI-Anwendungen von Drittanbietern oder Outlook-Plug-Ins ausführen.

Vorgänge mit Benutzeransichten

Die ExMon-RPC-Daten weisen darauf hin, dass ein Benutzer neue Ansichten erstellt, woraus eine hohe Serverbelastung resultiert. In diesem Szenario ist ein einzelner Benutzer für eine starke RPC-Prozessorauslastung verantwortlich.

Für die Untersuchung dieses Problems betrachten Sie die folgenden Szenarien:

  • Möglicherweise führt der Benutzer Operationen auf einem Ordner mit vielen Elementen durch. Um dieses Problem zu beheben, fordern Sie die Benutzer auf, die Anzahl der Elemente in den einzelnen Ordner zu reduzieren. Allgemein wird es als optimal angesehen, wenn Ordner weniger als 2.000 Objekte enthalten.

  • Möglicherweise führt der Benutzer eine schlecht programmierte Anwendung ausführt, die eine übermäßige Last verursacht. Sie beheben das Problem durch Entfernen der Anwendung.

Weitere Informationen

  • Weitere Informationen zur Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen über die Größe von Postfächern die Objektanzahl finden Sie im Blog des Microsoft Exchange Teams in „Recommended Mailbox Size Limits" unter (http://go.microsoft.com/fwlink/?linkid=55097).

  • Weitere Informationen über die Einschränkungen für Postfächer finden Sie im Blog des Microsoft Exchange Teams unter „Putting the Restrictions on Restrictions" in (http://go.microsoft.com/fwlink/?LinkId=55098).

  • Weitere Informationen zu ExMon finden Sie auf der Website zum Herunterladen von ExMon (http://go.microsoft.com/fwlink/?LinkId=54983).


IIS erstellt 32-Bit-Prozesse auf einem 64-Bit-Computer
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-05-03

Das Tool Microsoft Exchange Server Analyzer fragt die IIS-Metabase (Internet Information Services) auf allen 64-Bit-Servercomputern mit Windows Server 2003 SP1 (Service Pack 1), die Exchange Server 2007 ausführen, nach einem Wert für die Metabaseeigenschaft w3svc/AppPools/Enable32BitAppOnWin64 ab, um zu ermitteln, ob IIS für die Erstellung von 32-Bit-Arbeitsprozessen konfiguriert ist.

Ein Wert von 1 (wahr) zeigt an, dass IIS für die Erstellung von 32-Bit-Arbeitsprozessen konfiguriert ist. Ein Wert von 0 (falsch) zeigt an, dass IIS für die Erstellung von 64-Bit-Arbeitsprozessen konfiguriert ist.

Wenn Exchange Analyzer feststellt, dass der Wert für die Metabaseeigenschaft w3svc/AppPools/Enable32BitAppOnWin64 auf 1 (wahr) festgelegt ist, zeigt Exchange Analyzer einen Fehler an. Dieser Fehler zeigt an, dass IIS für das Erstellen von 32-Bit-Arbeitsprozessen auf einem 64-Bit-Windows-Server konfiguriert ist, der Exchange 2007 ausführt. Diese Konfiguration bewirkt, dass die virtuellen Exchange 2007-Verzeichnisse nicht mehr funktionieren.

Um diesen Fehler zu beheben, konfigurieren Sie IIS so, dass 64-Bit-Arbeitsprozesse auf dem 64-Bit-Servercomputer mit Windows Server 2003 (SP1) erstellt werden, der Exchange 2007 ausführt.

So schalten Sie IIS in den 64-Bit-Modus um

  1. Öffnen Sie eine Eingabeaufforderung.

  2. Geben Sie Folgendes ein:

    cscript c:\inetpub\adminscripts\adsutil.vbs SET /w3svc/AppPools/Enable32BitAppOnWin64 False

  3. Drücken Sie die EINGABETASTE.

Weitere Informationen zum Ausführen von IIS 6.0 32-Bit-Arbeitsprozessen auf 64-Bit-Servercomputern mit Windows Server 2003 SP1 finden Sie im Microsoft Knowledge Base-Artikel 895976 "Windows Server 2003 SP1 ermöglicht WOW64-Kompatibilität für 32-Bit-Webanwendungen in IIS 6.0" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=895976).


Verbessern des Kernel-Speichers
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer testet die Systemspeicher, um sicherzustellen, dass die Speichergröße im akzeptablen Bereich liegt. Wenn Exchange Server Analyzer feststellt, das einer oder mehrere der Kernelspeicherindikatoren des Systemmonitors (Perfmon) unterhalb der angemessenen Werte liegen, zeigt Exchange Server Analyzer eine Problembehandlungsnachricht an.

Der Microsoft Windows®-Kernelspeicher besteht aus mehreren Speicherstrukturen, wie dem ausgelagerten und nicht ausgelagerten Speicherpool sowie den Seitentabelleneinträgen. Diese auch als Kernelspeicher bezeichneten Speicherstrukturen werden vom Betriebssystem verwendet, um eine Umgebung für Anwendungen wie Exchange zu schaffen. Um eine solide Exchange-Bereitstellung zu erhalten, müssen Sie den Kernelspeicher überwachen.

Die Optimierung des Kernel/Speichers kann kompliziert sein. Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588). Eine Möglichkeit zum Freigeben von Serverressourcen besteht darin, die Serverlast durch Benutzerpostfächer zu analysieren. Ziehen Sie in Betracht, Postfächer zu einem anderen Server zu verschieben, um die Server-Last zu reduzieren. Kontrollieren Sie anschließend, ob das Problem behoben ist. Weitere Informationen finden Sie unter Verschieben von Benutzerpostfächern auf einen anderen Server.

Weitere Informationen

Weitere Informationen zur Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=de).

Weitere Informationen zum Verschieben von Postfächern der Benutzer zur Reduzierung der Serverlast finden Sie unter Verschieben von Benutzerpostfächern auf einen anderen Server


Verbessern des Speichers für Benutzer
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-04-28

Microsoft® Exchange Server Analyzer hat festgestellt, dass die Leistungsindikatoren für den Benutzerspeicher oberhalb der Grenze dessen liegen, was für den Exchange-Server als zuträglich angesehen wird. Exchange Server Analyzer fragt den Leistungsindikator Available Mbytes und den Zähler Memory Pages/sec unter dem Leistungsobjekt Memory ab. Wenn der Server nur noch über wenig Speicher verfügt oder viel auslagern muss, so deutet dies auf einen Speicherengpass hin.

Der Leistungsindikator Available MBytes zeigt die Größe des physischen Arbeitsspeichers in MB an, die unmittelbar für die Zuweisung zu einem Prozess oder für die Systemverwendung verfügbar ist. Die Größe des verfügbaren Speichers ist gleich der Standbylisten (zwischengespeichert), freien Listen und Nullseitenlisten zugewiesenen Speichersumme.

Der Leistungsindikator Memory Pages/sec zeigt die Rate an, mit der die Seiten vom Datenträger gelesen bzw. auf den Datenträger geschrieben werden, um harte Seitenfehler aufzulösen. Wenn der Server immer mehr Speicher nutzt und freier Speicher knapp wird, beginnt das Betriebssystem, den aktiven Teil des Prozesses zu beschneiden und die Auslagerungsdatei intensiver zu nutzen. Der Einsatz einer Auslagerungsdatei beeinflusst die Gesamtleistung, weil Festplattenoperationen länger dauern als Speicheroperationen. Bei diesem Indikator handelt es sich um einen primären Indikator der Fehlertypen, die systemweite Verzögerungen bewirken. Er umfasst die abgerufenen Seiten, um den Seitenfehlern im Dateisystemzwischenspeicher zu entsprechen. Diese Seiten werden gewöhnlich von Anwendungen angefordert. Dieser Zähler muss immer unter 1.000 liegen.

Wenn Exchange Server Analyzer feststellt, dass der Leistungsindikator Available Mbytes weniger als 50 MB verfügbaren Speicher anzeigt oder dass die Rate für das Schreiben oder Lesen von Speicherseiten auf oder vom Datenträger mehr als 1000 Seiten/Sekunde beträgt, wird von Exchange Server Analyzer ein Fehler angezeigt.

Die folgende Liste beschreibt, wie Sie die Leistung des Speichers für den Benutzerraum verbessern können.

So beheben Sie dieses Problem

  1. Verwenden Sie Microsoft Exchange Server Analyzer (http://go.microsoft.com/fwlink/?LinkId=34705), um sicherzustellen, dass die Speichereinstellungen für den Server in geeigneter Weise konfiguriert sind.

  2. Entfernen Sie überflüssige Software. Damit Exchange mehr Speicherressourcen zur Verfügung stehen, entfernen Sie Softwaretools von Drittanbietern, die Überwachungsfunktionen oder andere nicht essentielle Dienste ausführen. Das Leistungs-Snap-In (Perfmon.msc) kann Ihnen helfen zu verstehen, wie viel Speicher von verschiedenen Anwendungen beansprucht wird.

  3. Führen Sie die Serverwartung außerhalb der Spitzenlastzeiten durch. Wenn Wartungstools (wie Eseutil) oder Wartungsaufgaben (beispielsweise Postfachmanagement) zu Spitzenlastzeiten durchgeführt werden, kann Speicher verbraucht werden, der anderenfalls von Exchange verwendet wird. Als optimale Methode führen Sie diese Tools und Aufgaben nicht zu Zeiten mit Spitzenauslastung bzw. zu Zeiten mit geringer Auslastung aus.

  4. Ziehen Sie in Betracht, Postfächer vom betroffenen Server zu einem anderen zu verschieben, um die Server-Last zu reduzieren. Weitere Informationen finden Sie unter Verschieben von Benutzerpostfächern auf einen anderen Server.

Weitere Informationen

Weitere Informationen finden Sie in den folgenden Microsoft-Ressourcen:

  • Verschieben von Benutzerpostfächern auf einen anderen Server

  • Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588).

  • „Optimieren der Speichernutzung in Exchange Server 2003" im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576)

  • Microsoft Exchange Server Best Practices Analyzer (http://go.microsoft.com/fwlink/?LinkId=34705)

  • Microsoft Knowledge Base-Artikel 815372, „Optimieren der Speichernutzung in Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)

  • "Exchange 2003 Memory Configuration change for Windows 2003 (PAE Support)" (http://go.microsoft.com/fwlink/?LinkId=54979)

    Hinweis:
    Der Inhalt jedes Blogs und die dazugehörigen URLs können jederzeit ohne vorherige Ankündigung geändert werden.


Verbessern des virtuellen Speichers
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer hat festgestellt, dass Ihr Server Probleme mit der Fragmentierung des virtuellen Speichers hat.

In 32-Bit-Systemen von Microsoft Windows® gibt es zwei Arten von Arbeitsspeicher:

  • Physischer Speicher Größe des tatsächlich im System installierten Speichers

  • Virtueller Speicheradressraum Ein virtueller Speicherbereich von 4 GB

Die Gesamtgröße des virtuellen Adressraums bleibt immer gleich, unabhängig von der Größe des im System installierten physischen Arbeitsspeichers: 4 GB. Auch wenn dies nicht für alle 32-Bit-Anwendungen gilt: Bei Exchange Server entspricht der virtuelle Adressraum dem virtuellen Speicher. Die Begriffe werden austauschbar verwendet.

Zum normalen Betrieb des Exchange-Datenspeichers gehört das wiederholte Zuweisen, Verwenden und Freigeben von virtuellem Speicher. Häufiges Zuweisen, Verwenden und Freigeben von virtuellem Speicher kann eine Fragmentierung des virtuellen Speichers verursachen. Die Fragmentierung des virtuellen Speichers entspricht der Fragmentierung des Dateisystems, die im Lauf der Zeit auftreten kann. Nach einer gewissen Zeit sind die zugewiesenen Segmente des virtuellen Speichers nicht mehr zusammenhängend, und die Leistung wird beeinträchtigt. Im Fall des Dateisystems können Sie eine Anwendung ausführen, die die Datei defragmentiert. In den meisten Fällen ist dies möglich, während das System online ist und auf das System zugegriffen wird. Für die Fragmentierung von virtuellen Speicher ist kein Defragmentierungstool vorhanden. Stattdessen müssen Sie den Microsoft Exchange-Informationsspeicherdienst beenden und neu starten, um das Problem zu beheben.

Die Fragmentierung des virtuellen Speichers kann durch Software von Drittanbietern verursacht sein, die in den store/inetinfo-Prozessen ausgeführt wird. Überprüfen Sie, dass Sie über die neuesten Treiber für alle Anwendungen von Drittanbietern verfügen. Wenn das Problem nach einem Neustart weiter besteht, ziehen Sie in Betracht, die Software von Drittanbietern zu deaktivieren oder Postfächer auf einen anderen Server zu verschieben, um die Server-Last zu reduzieren. Kontrollieren Sie anschließend, ob das Problem behoben ist. Weitere Informationen finden Sie unter Verschieben von Benutzerpostfächern auf einen anderen Server.

Weitere Informationen

  • Weitere Informationen zur Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=de).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=de).

  • Weitere Informationen zur Problembehandlung bei der Fragmentierung des virtuellen Speichers in Microsoft Exchange Server 2003 und Exchange 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 325044, „SO WIRD'S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" unter http://support.microsoft.com/kb/325044/de&kbid=325044.

  • Weitere Informationen zum Optimieren der Nutzung des virtuellen Speichers finden Sie im Microsoft Knowledge Base-Artikel 815372 „Optimieren der Speichernutzung in Exchange Server 2003" unter http://support.microsoft.com/?kbid=815372.

  • Weitere Informationen zum Verschieben von Postfächern der Benutzer zur Reduzierung der Serverlast finden Sie unter Verschieben von Benutzerpostfächern auf einen anderen Server


Intelligent Message Filter ist auf einem oder mehreren Servern mit Exchange Server 2003 nicht installiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert für das Attribut msExchExchangeServer für jedes Exchange Server-Objekt in der Organisation zu ermitteln. Exchange Server Analyzer verwendet die Ergebnisse dieser Abfrage zum Bestimmen der Gesamtzahl von Servern in der Organisation, auf denen Exchange Server 2003 ausgeführt wird. Microsoft Exchange Server Analyzer fragt außerdem die WMI-Klasse (Windows® Management Instrumentation) CIM_Datafile ab, um zu bestimmen, ob der intelligente Nachrichtenfilter von Exchange auf allen Exchange Server 2003-Servern in der Organisation installiert ist. Wenn Exchange Server Analyzer feststellt, dass der intelligente Nachrichtenfilter auf einem oder mehreren Servern mit Exchange Server 2003 nicht installiert ist, wird von dem Tool eine Meldung mit der optimalen Methode ausgegeben.

Der intelligente Nachrichtenfilter identifiziert Meldungen, bei denen es sich wahrscheinlich um unerwünschte kommerzielle E-Mail-Nachrichten (UCE) handelt. In den meisten Exchange Server 2003-Topologien wird der intelligente Nachrichtenfilter auf Gatewayservern installiert, um aus dem Internet eingehende E-Mail-Nachrichten zu filtern. Wenn Sie als Internet-Gatewayserver ein E-Mail-System verwenden, das nicht von Microsoft stammt, sollten Sie den intelligenten Nachrichtenfilter auf dem Exchange-Bridgeheadserver installieren, der aus dem Internet eingehende E-Mail-Nachrichten von den Gatewayservern annimmt.

Verwenden Sie zum Installieren des intelligenten Nachrichtenfilters ein Konto mit den Rechten eines lokalen Administrators, das Mitglied einer Gruppe ist, der die Funktion als Exchange-Administrator zugewiesen wurde.

Weitere Informationen finden Sie unter „Exchange Intelligent Message Filter" (http://go.microsoft.com/fwlink/?LinkId=21607).


AktuaIisierung für ISA Server 2000 ist verfügbar.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um die Version der Datei smtpfltr.dll zu bestimmen, die von der ISA Server 2000-Funktion SMTP Message Screener verwendet wird (ISA = Microsoft Internet Security and Acceleration, SMTP = Simple Mail Transfer Protocol). Wenn Exchange Server Analyzer feststellt, dass der Wert für die Versionsnummer älter als 2004 ist, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass eine aktuellere Version von ISA Server 2000 verfügbar ist. Es wird empfohlen, dass Sie ISA Server 2000 Service Pack 2 installieren. Eine Aktualisierung auf Service Pack 2 ist insbesondere dann essenziell, wenn bei Ihnen die Funktion SMTP Message Screener ausgeführt wird. Ältere Versionen von SMTP Message Screener verursachen einen Engpass und führen zu einem Leistungsabfall beim Gesamtnachrichtendurchsatz.

So beheben Sie diese Warnmeldung

  1. Downloaden Sie ISA Server 2000 Service Pack 2 vom Microsoft Download Center unter http://www.microsoft.com/downloads/details.aspx?displaylang=de&FamilyID=c8d3d98b-1cd4-406a-a04a-2aa2547d09a3.

  2. Lesen Sie auch die Versionsinformationen zu Service Pack 2 unter http://go.microsoft.com/fwlink/?linkid=37584.

  3. Installieren Sie Service Pack 2 gemäß den Anweisungen in den Anmerkungen zu dieser Version.

Weitere Informationen zu ISA Server-Downloads, einschließlich ISA Server 2000 Service Pack 2, finden Sie in "ISA Server 2000 Downloads" unter http://go.microsoft.com/fwlink/?LinkId=18919.


Journalempfänger ist ungültig
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-03-27

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob der Wert des Attributs mailNickname für das Journalempfängerobjekt gültig ist. Der Spitzname muss definiert sein, damit das Attribut mailNickname gültig ist. Bei einem ungültigen mailNickname-Attribut für das benannte Journalempfängerobjekt werden die Aufzeichnungsnachrichten in die Wartestelle gestellt. Auch kann ein ungültiger mailNickname anzeigen, dass die Journalaufzeichnung so konfiguriert wurde, dass Journalnachrichten an ein Empfängerobjekt mit deaktiviertem Postfach kopiert werden. Wenn Exchange Server Analyzer feststellt, dass der Wert für das Attribut mailNickname für jedes Journalempfängerobjekt ungültig ist, zeigt Exchange Server Analyzer eine Warnmeldung an.

Um diesen Fehler für Exchange Server 2003 zu beheben, verwenden Sie Active Directory-Benutzer und -Computer und Exchange-System-Manager, um bei Bedarf folgende Aufgaben zu erledigen:

  • Aktivieren Sie das Postfach des Journalempfängerobjekts.

  • Bestimmen Sie ein neues Benutzerpostfach als Journalempfänger.

Um diesen Fehler für Exchange Server 2003 zu beheben, verwenden Sie Active Directory-Benutzer und -Computer und Exchange-System-Manager, um bei Bedarf folgende Aufgaben zu erledigen:

So aktivieren Sie das Postfach des Journalempfängerobjekts für Exchange Server 2003

  1. Öffnen Sie „Active Directory-Benutzer und -Computer".

  2. Erweitern Sie in der Konsolenstruktur die Domäne.

  3. Navigieren Sie zum übergeordneten Container des Empfängers, den Sie ändern möchten.

  4. Klicken Sie im Detailbereich mit der rechten Maustaste auf die zu bearbeitenden Empfänger, und wählen Sie Exchange-Aufgaben aus.

  5. Wählen Sie im Assistent für Exchange-Aufgaben aus dem Dialogfeld Verfügbare Aufgaben den Befehl Postfach erstellen, und klicken Sie dann auf Weiter.

  6. Überprüfen Sie im Dialogfeld Postfach erstellen die Informationen für die Felder Alias, Speicher und Postfachserver, und klicken Sie dann auf Weiter.

  7. Klicken Sie auf Fertig stellen, um den Assistenten für Exchange-Aufgaben zu schließen.
So bestimmen Sie in Exchange Server 2003 ein neues Benutzerpostfach als Journalempfänger

  1. Starten Sie den Exchange-System-Manager.

  2. Erweitern Sie Server, und erweitern Sie <Ihren Exchange-Server>. Erweitern Sie die <Speichergruppe>, und klicken Sie mit der rechten Maustaste auf den Postfachspeicher und wählen Sie Eigenschaften.

  3. Klicken Sie rechts neben dem Text Alle von Postfächern in diesem Informationsspeicher gesendeten oder empfangenen Nachrichten archivieren auf Durchsuchen, um ein Postfach als Aufzeichnungspostfach zu bestimmen.

    Hinweis:
    Alle aufgezeichneten Nachrichten für Absender an diesem Postfachspeicher werden an das von Ihnen angegebene Postfach gesendet.

Um diesen Fehler für Exchange Server 2007 zu beheben, verwenden Sie die Exchange-Verwaltungskonsole oder die Exchange-Verwaltungsshell, um bei Bedarf folgende Aufgaben zu erledigen:

  • Erstellen Sie ein Postfach für das Journalempfängerobjekt.

  • Bestimmen Sie ein neues Benutzerpostfach als Journalempfänger.

So aktivieren Sie das Postfach des Journalempfängerobjekts für Exchange Server 2007 mithilfe der Exchange-Verwaltungskonsole

  1. Erweitern Sie in der Exchange-Verwaltungskonsole Empfängerkonfiguration, klicken Sie mit der rechten Maustaste auf das Postfachobjekt, und wählen Sie Neues Postfach aus, um den Assistenten für neue Postfächer zu starten.

  2. Wählen Sie im Fenster Einführung die Option Benutzerpostfach aus, und klicken Sie auf Weiter.

  3. Wählen Sie im Fenster Benutzertyp die Option Vorhandener Benutzer aus, und klicken Sie auf die Schaltfläche Durchsuchen, um das Journalempfängerobjekt auszuwählen, für welches das Postfach erstellt werden soll.

  4. Überprüfen Sie im Dialogfeld Postfacheinstellungen die Informationen in den Feldern Alias, Server, Speichergruppe und Postfachdatenbank, und klicken Sie dann auf Weiter.

  5. Klicken Sie im Fenster Neues Postfach auf Neu, um das Postfach für das Journalempfängerobjekt zu erstellen.

  6. Klicken Sie auf Fertig stellen, um den Assistenten für neue Postfächer zu beenden.
So aktivieren Sie das Postfach des Journalempfängerobjekts für Exchange Server 2007 mithilfe der Exchange-Verwaltungsshell

  1. Befolgen Sie die Anleitung in der Exchange Server 2007-Produktdokumentation unter "Enable-Mailbox" (http://go.microsoft.com/fwlink/?LinkID=80827).

So bestimmen Sie in Exchange Server 2007 ein neues Benutzerpostfach als Journalempfänger

  1. Erweitern Sie in der Exchange-Verwaltungskonsole Serverkonfiguration und dann <Ihren Server mit Exchange>. Erweitern Sie die <Speichergruppe>, klicken Sie mit der rechten Maustaste auf die Postfachdatenbank, und wählen Sie anschließend Eigenschaften aus.

  2. Klicken Sie auf der Registerkarte Allgemein unter Journalempfänger auf Durchsuchen, und geben Sie ein Postfach als Journalpostfach an.

Weitere Informationen zum Bereitstellen einer Journallösung für Exchange Server 2003 finden Sie unter Journaling with Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).

Weitere Informationen zum Bereitstellen einer Journallösung für Exchange Server 2007 finden Sie unter Übersicht über Journale (http://www.microsoft.com/technet/prodtechnol/exchange/E2k7/DE/Help/ExchHelp/6a20f207-4485-44ef-b010-ec760eb5165b.mspx?mfr=true).


Aufzeichnungsempfänger verweist auf ein gelöschtes Objekt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-02-01

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob der Wert des Attributs msExchMessageJournalRecipient die Zeichenfolge DEL: enthält. Dieses Attribut zeigt eine Konfiguration der Journalaufzeichnung an, bei der die Nachrichten in ein gelöschtes Postfach kopiert werden sollen. Damit die Journalfunktion korrekt funktioniert, muss ein gültiges Postfach als Journalempfänger vorhanden sein, an das die kopierten Meldungen gesendet werden. Das Attribut msExchMessageJournalRecipient wird gesetzt, wenn die Aufzeichnung für eine Postfachdatenbank aktiviert ist. Dieses Attribut für die Postfachdatenbank enthält den DN (Distinguished Name) des Aufzeichnungspostfachs.

Wenn das Postfach des Journalempfängers gelöscht wurde, werden Aufzeichnungsnachrichten in die Warteschlange gestellt. Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert für das Attribut msExchMessageJournalRecipient die Zeichenfolge DEL: enthält, zeigt Exchange Server Analyzer einen Fehler an.

Um diesen Fehler zu beheben, verwenden Sie Exchange-System-Manager oder die Exchange-Verwaltungskonsole, um ein neues Postfach als Journalempfänger zu bestimmen.

So bestimmen Sie in Exchange Server 2003 ein neues Benutzerpostfach als Journalempfänger

  1. Starten Sie den Exchange-System-Manager.

  2. Erweitern Sie Server, und erweitern Sie <Ihren Exchange-Server>. Erweitern Sie die <Speichergruppe>, klicken Sie dann mit der rechten Maustaste auf den Postfachspeicher und wählen Sie Eigenschaften.

  3. Klicken Sie rechts neben dem Text Alle von Postfächern in diesem Informationsspeicher gesendeten oder empfangenen Nachrichten archivieren auf Durchsuchen, um ein Postfach als Aufzeichnungspostfach zu bestimmen.

    Hinweis:
    Alle aufgezeichneten Nachrichten für Absender an diesem Postfachspeicher werden an das von Ihnen angegebene Postfach gesendet.
So bestimmen Sie in Exchange Server 2007 ein neues Benutzerpostfach als Journalempfänger

  1. Erweitern Sie in der Exchange-Verwaltungskonsole Serverkonfiguration und dann <Ihren Server mit Exchange>. Erweitern Sie die <Speichergruppe>, klicken Sie mit der rechten Maustaste auf die Postfachdatenbank, und wählen Sie anschließend Eigenschaften aus.

  2. Klicken Sie auf der Registerkarte Allgemein unter Journalempfänger auf Durchsuchen, und geben Sie ein Postfach als Journalpostfach an.

Weitere Informationen zum Bereitstellen einer Journallösung für Exchange Server 2003 finden Sie unter Journaling with Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).

Weitere Informationen zum Bereitstellen einer Journallösung für Exchange Server 2007 finden Sie unter Übersicht über Journale (http://www.microsoft.com/technet/prodtechnol/exchange/E2k7/DE/Help/ExchHelp/6a20f207-4485-44ef-b010-ec760eb5165b.mspx?mfr=true).


Aufzeichnungsempfänger verweist auf ein deaktiviertes Konto
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-09

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob der Wert des Attributs msExchUserAccountControl für das Journalempfängerobjekt so gesetzt, dass damit ein deaktiviertes Benutzerkonto angegeben wird. Wenn der Wert des msExchUserAccountControl-Attributs des Journalempfängerobjekts 2 beträgt, zeigt dies an, dass die Journalfunktion so konfiguriert wurde, dass Aufzeichnungsnachrichten an ein deaktiviertes Benutzerkonto kopiert werden. Diese Konfiguration kann bewirken, dass die Aufzeichnungsnachrichten in die Warteschlange eingestellt oder an den Badmail-Ordner gesendet werden. Wenn Exchange Server Analyzer feststellt, dass der Wert für das Attribut msExchUserAccountControl ein deaktiviertes Benutzerkonto als Journalempfänger angibt, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Um diesen Fehler für Exchange Server 2003 zu beheben, verwenden Sie Active Directory-Benutzer und -Computer und Exchange-System-Manager, um bei Bedarf folgende Aufgaben zu erledigen:

  • Aktivieren Sie das Benutzerkonto des aktuellen Journalempfängers.

  • Bestimmen Sie ein neues Benutzerpostfach als Journalempfänger.

So aktivieren Sie das Journalempfängerkonto für Exchange Server 2003

  1. Öffnen Sie „Active Directory-Benutzer und -Computer".

  2. Erweitern Sie in der Konsolenstruktur die Domäne.

  3. Navigieren Sie zum übergeordneten Container des Journalempfängers, den Sie ändern möchten.

  4. Klicken Sie im Detailbereich mit der rechten Maustaste auf die zu bearbeitenden Empfänger, und wählen Sie Konto aktivieren aus.
So bestimmen Sie in Exchange Server 2003 ein neues Benutzerpostfach als Journalempfänger

  1. Starten Sie den Exchange-System-Manager.

  2. Erweitern Sie Server, und erweitern Sie <Ihren Exchange-Server>. Erweitern Sie die <Speichergruppe>, und klicken Sie mit der rechten Maustaste auf den Postfachspeicher und wählen Sie Eigenschaften.

  3. Klicken Sie rechts neben dem Text Alle von Postfächern in diesem Informationsspeicher gesendeten oder empfangenen Nachrichten archivieren auf Durchsuchen, um ein Postfach als Aufzeichnungspostfach zu bestimmen.

    Hinweis:
    Alle aufgezeichneten Nachrichten für Absender an diesem Postfachspeicher werden an das von Ihnen angegebene Postfach gesendet.

Um diesen Fehler für Exchange Server 2007 zu beheben, verwenden Sie die Exchange-Verwaltungskonsole oder die Exchange-Verwaltungsshell, um bei Bedarf folgende Aufgaben zu erledigen:

  • Erstellen Sie ein Postfach für das Journalempfängerobjekt.

  • Bestimmen Sie ein neues Benutzerpostfach als Journalempfänger.

So aktivieren Sie das Postfach des Journalempfängerobjekts für Exchange Server 2007 mithilfe der Exchange-Verwaltungskonsole

  1. Erweitern Sie in der Exchange-Verwaltungskonsole Empfängerkonfiguration, klicken Sie mit der rechten Maustaste auf das Postfachobjekt, und wählen Sie Neues Postfach aus, um den Assistenten für neue Postfächer zu starten.

  2. Wählen Sie im Fenster Einführung die Option Benutzerpostfach aus, und klicken Sie auf Weiter.

  3. Wählen Sie im Fenster Benutzertyp die Option Vorhandener Benutzer aus, und klicken Sie auf die Schaltfläche Durchsuchen, um das Journalempfängerobjekt auszuwählen, für welches das Postfach erstellt werden soll.

  4. Überprüfen Sie im Dialogfeld Postfacheinstellungen die Informationen in den Feldern Alias, Server, Speichergruppe und Postfachdatenbank, und klicken Sie dann auf Weiter.

  5. Klicken Sie im Fenster Neues Postfach auf Neu, um das Postfach für das Journalempfängerobjekt zu erstellen.

  6. Klicken Sie auf Fertig stellen, um den Assistenten für neue Postfächer zu beenden.
So aktivieren Sie das Postfach des Journalempfängerobjekts für Exchange Server 2007 mithilfe der Exchange-Verwaltungsshell

  1. Befolgen Sie die Anleitung in der Exchange Server 2007-Produktdokumentation unter "Enable-Mailbox" (http://www.microsoft.com/technet/prodtechnol/exchange/E2k7/DE/Help/ExchHelp/58de5b3c-05c3-4a1f-84c6-f082d990f22b.mspx?mfr=true).

So bestimmen Sie in Exchange Server 2007 ein neues Benutzerpostfach als Journalempfänger

  1. Erweitern Sie in der Exchange-Verwaltungskonsole Serverkonfiguration und dann <Ihren Server mit Exchange>. Erweitern Sie die <Speichergruppe>, klicken Sie mit der rechten Maustaste auf die Postfachdatenbank, und wählen Sie anschließend Eigenschaften aus.

  2. Klicken Sie auf der Registerkarte Allgemein unter Journalempfänger auf Durchsuchen, und geben Sie ein Postfach als Journalpostfach an.

Weitere Informationen zum Bereitstellen einer Journallösung für Exchange Server 2003 finden Sie unter Journaling with Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).

Weitere Informationen zum Bereitstellen einer Journallösung für Exchange Server 2007 finden Sie unter Übersicht über Journale (http://www.microsoft.com/technet/prodtechnol/exchange/E2k7/DE/Help/ExchHelp/6a20f207-4485-44ef-b010-ec760eb5165b.mspx?mfr=true).


Aufzeichnungsempfänger verweist auf den lokalen Server
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-09

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob der Wert für das Attribut msExchHomeServerName über den Journalempfänger für einen Postfachspeicher dem Wert für das Attribut legacyExchangeDN des lokalen Servers entspricht. Wenn die Werte dieser Attribute übereinstimmen, zeigt dies an, dass die Aufzeichnungsnachrichten in ein Postfach auf dem Server kopiert werden, für den die aktive Journalaufzeichnung ausgeführt wird. Wenn des in großem Umfang generierten Journalverkehrs wird empfohlen, dass das Postfach des Journalempfängers auf einem dedizierten Journalserver gespeichert ist.

Wenn Exchange Server Analyzer erkennt, dass der Registrierungswert msExchHomeServerName für das Journalempfängerobjekt dem Wert für legacyExchangeDN auf dem lokalen Server entspricht, zeigt der Exchange Server Analyzer eine Meldung mit der optimalen Methode an.

Weitere Informationen zum Bereitstellen einer Journallösung für Exchange Server 2003 finden Sie unter Journaling with Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).

Weitere Informationen zum Bereitstellen einer Journallösung für Exchange Server 2007 finden Sie unter Übersicht über Journale (http://www.microsoft.com/technet/prodtechnol/exchange/E2k7/DE/Help/ExchHelp/6a20f207-4485-44ef-b010-ec760eb5165b.mspx?mfr=true).


Aufzeichnungsempfänger sollte ausgeblendet sein
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-09

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob der Wert des Attributs msExchHideFromAddressLists für das Journalempfängerobjekt auf True gesetzt ist. Jeder von True abweichende Wert für dieses Attribut zeigt an, dass der Journalempfänger für den Postfachspeicher nicht aus den Adresslisten von Exchange Server ausgeblendet wird und auch Empfänger von Nachrichten sein kann, die nicht auf die Journalfunktion bezogen sind. Wenn Exchange Server Analyzer feststellt, dass der Wert für das Attribut msExchHideFromAddressLists für das Journalempfängerobjekt nicht auf True gesetzt ist, zeigt Exchange Server Analyzer eine Meldung mit der optimalen Methode an.

Dieses Problem lösen Sie für Exchange Server 2003 mit dem Tool Active Directory-Benutzer und -Computer, mit dem Sie das Postfach des Journalempfängers aus den Adresslisten von Exchange Server ausblenden.

Dieses Problem lösen Sie für Exchange Server 2007 mithilfe der Exchange-Verwaltungskonsole, über die Sie das Postfach des Journalempfängers aus den Adresslisten von Exchange Server ausblenden.

So blenden Sie in Exchange Server 2003 das angegebene Journalempfängerpostfach aus den Exchange Server-Adresslisten aus

  1. Öffnen Sie „Active Directory-Benutzer und -Computer".

  2. Erweitern Sie in der Konsolenstruktur die Domäne.

  3. Navigieren Sie zum übergeordneten Container des Empfängers, den Sie ändern möchten.

  4. Doppelklicken Sie im Detailbereich auf den Empfänger, den Sie ändern möchten.

  5. Aktivieren Sie auf der Registerkarte Erweitert das Kontrollkästchen Nicht in Exchange-Adresslisten anzeigen.

  6. Klicken Sie auf OK.
So blenden Sie in Exchange Server 2007 das angegebene Journalempfängerpostfach aus den Exchange Server-Adresslisten aus

  1. Öffnen Sie die Exchange-Verwaltungskonsole.

  2. Wechseln Sie in der Konsolenstruktur zum übergeordneten Container des Empfängers, den Sie ändern möchten.

  3. Doppelklicken Sie im Detailbereich auf das Postfachobjekt des vorgesehenen Journalempfängers, um dessen Eigenschaften anzuzeigen.

  4. Aktivieren Sie auf der Registerkarte Allgemein das Kontrollkästchen Nicht in Exchange-Adresslisten anzeigen.

  5. Klicken Sie auf OK.

Weitere Informationen zum Bereitstellen einer Journallösung für Exchange Server 2003 finden Sie unter Journaling with Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).

Weitere Informationen zum Bereitstellen einer Journallösung für Exchange Server 2007 finden Sie unter Übersicht über Journale (http://www.microsoft.com/technet/prodtechnol/exchange/E2k7/DE/Help/ExchHelp/6a20f207-4485-44ef-b010-ec760eb5165b.mspx?mfr=true).


Junk store threshold not configured
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-07-30

Das Microsoft Exchange Analyzer Tool fragt die Exchange-Umgebung nach dem Vorhandensein der Serverfunktionen Hub-Transport und Mailbox von Exchange Server 2007 ab.

Wenn die Serverfunktionen Hub-Transport oder Mailbox von Exchange Server 2007 gefunden wurden, führt Exchange Analyzer das folgende Cmdlet der Exchange-Verwaltungsshell aus, um den Wert des Parameters SCLJunkThreshold für die Exchange-Organisation abzufragen:

Get-OrganizationConfig

Der Parameter SCLJunkThreshold für eine Organisation gibt den SCL-Wert (Spam Confidence Level) an, ab dem eine Nachricht in den Junk-E-Mail-Ordner verschoben wird.

Wenn Exchange Analyzer feststellt, dass der Parameter SCLJunkThreshold für eine Organisation auf den Standardwert 8 festgelegt wurde, zeigt Exchange Analyzer eine Warnung an.

Diese Warnung zeigt an, dass der SCL-Schwellenwert für das Verschieben von Nachrichten in den Junk-E-Mail-Ordner so festgelegt wurde, dass ggf. E-Mail-Nachrichten von legitimen Benutzern gefiltert und als Junk-E-Mail in den Junk-E-Mail-Ordner verschoben werden. Der empfohlene Wert für den Parameter SCLJunkThreshold ist 4.

Um diese Warnung zu beheben, verwenden Sie das Cmdlet Set-OrganizationConfig in der Exchange-Verwaltungsshell, um den Wert des Parameters SCLJunkThreshold auf 4 festzulegen.

So legen Sie den Wert des Parameters "SCLJunkThreshold" mithilfe des Cmdlets "Set-OrganizationConfig" auf 4 fest

  1. Der folgende Code ist ein Beispiel für den Befehl Set-OrganizationConfig, der den Wert des Parameters SCLJunkThreshold auf 4 festlegt.

  2. Set-OrganizationConfig -SCLJunkThreshold 4


Kernelspeicher erschöpft
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-02-15

Microsoft Exchange Analyzer fragt die Microsoft WMI-Klasse (Windows Management Instrumentation - Windows-Verwaltungsinstrumentation) Win32_NTLogEvent ab, um zu ermitteln, ob innerhalb der letzten 24 Stunden für die SRV- (Server) oder NCP-Serverquelle ein Fehler aufgrund von Ereignis 2000, Ereignis 2019 oder Ereignis 2020 protokolliert wurde.

  • Eine SRV- (Server) Ereignis-ID 2000 zeigt an, dass der Aufruf eines Systemdiensts durch einen Server aufgrund einer allgemeinen Systemkernel-Speicherverringerung unerwartet fehlgeschlagen ist.

  • Eine SRV-Ereignis-ID 2019 zeigt an, dass der nicht ausgelagerte Systempoolspeicher erschöpft ist.

  • Eine SRV-Ereignis-ID 2020 zeigt an, dass der ausgelagerte Systempoolspeicher erschöpft ist.

Wenn Exchange Analyzer feststellt, dass in den letzten 24 Stunden ein oder mehrere dieser Ereignisse protokolliert wurden, wird ein Fehler angezeigt.

Diese Warnung zeigt an, dass der Kernelspeicher des Servers erschöpft ist und es zu Leistungsproblemen auf dem Server kommen kann.

Der Microsoft Windows-Kernelspeicher besteht aus mehreren Speicherstrukturen, wie dem ausgelagerten und nicht ausgelagerten Speicherpool sowie den Seitentabelleneinträgen. Diese auch als Kernelspeicher bezeichneten Speicherstrukturen werden vom Betriebssystem verwendet, um eine Umgebung für Anwendungen wie Exchange zu schaffen.

Um dieses Problem zu beheben, befolgen Sie die Anweisungen in den jeweiligen problemspezifischen Exchange Analyzer-Artikeln:

  • Verbessern des Kernel-Speichers

  • Der ausgelagerte Pool hat den Warnschwellenwert überschritten

  • Nicht ausgelagerter Pool befindet sich über der Warnschwelle

  • Der ausgelagerte Pool hat den Fehlerschwellenwert überschritten

Um eine solide Exchange-Bereitstellung zu erhalten, sollten Sie den Exchange Server-Kernelspeicher regelmäßig überwachen.

Weitere Informationen

Weitere Informationen zu den SRV-Ereignissen 2000, 2019 oder 2020 finden Sie im "Events and Errors Message Center: Ereignisdetails"

  • SRV-Ereignis-ID 2000 http://go.microsoft.com/fwlink/?LinkId=83250

  • SRV-Ereignis-ID 2019 http://go.microsoft.com/fwlink/?LinkId=83251

  • SRV-Ereignis-ID 2020 http://go.microsoft.com/fwlink/?LinkId=83252

Weitere Informationen zum Optimieren des Speichers für Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 912376, "Überwachen der Verwendung von ausgelagertem Poolspeicher in Exchange Server 2003 oder Exchange 2000 Server sowie Problembehandlung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=912376)

  • 815372, "Optimieren der Speichernutzung in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 894067, "Im Leistungsüberwachungstool werden die verfügbaren freien Seitentabelleneinträge des Systems in Windows Server 2003 nicht genau angezeigt" http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067

  • 311901, "Auswirkungen der 4GT-Optimierung auf Seitentabelleneinträge des Systems" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 912376, "Überwachen der Verwendung von ausgelagertem Poolspeicher in Exchange Server 2003 oder Exchange 2000 Server sowie Problembehandlung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=912376)


Kernelressourcen erschöpft: Aktualisierung des Volumeschattenkopie-Diensts
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-02-13

Microsoft® Exchange Server Analyzer fragt die Microsoft Windows®-Verwaltungsinstrumentationsklasse (Windows® Management Instrumentation, WMI) CIM_Datafile ab, um zu überprüfen, dass die Datei Vssvc.exe vorhanden ist.

In der Registrierung fragt Exchange Server Analyzer folgenden Schlüssel ab, um zu ermitteln, ob der Volumeschattenkopie-Dienst (Volume Shadow Copy Service, VSS) oder der Dienst für virtuelle Datenträger (Virtual Disk Service, VDS) auf dem Windows-Server ausgeführt wird:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS

Darüber hinaus liest Exchange Server Analyzer folgenden Registrierungswert, um die Version des Microsoft Windows®-Betriebssystems zu ermitteln, das auf dem Exchange-Server ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Wenn für CurrentVersion der Wert 5.0 angegeben ist, führt der Exchange-Server Microsoft Windows 2000 Server aus. Wenn für CurrentVersion der Wert 5.2 angegeben ist, führt der Exchange-Server Microsoft Windows Server™ 2003 aus.

Schließlich fragt Exchange Server Analyzer die Windows-Verwaltungsinstrumentationsklasse (Windows Management Instrumentation, WMI) Win32_OperatingSystem ab, um den Wert des Schlüssels ServicePackMajorVersion zu ermitteln. Der Wert des Schlüssels ServicePackMajorVersion gibt das Windows Service Pack an, das auf dem Computer installiert ist.

Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Exchange Server ist unter Windows Server 2003 Service Pack 1 (SP1) installiert.

  • Der Volumeschattenkopie-Dienst (VSS) oder der Dienst für virtuelle Datenträger (VDS) wird unter Windows Server 2003 SP1 ausgeführt.

  • Die VSS-Aktualisierung ist in dieser Exchange Server-Konfiguration nicht installiert.

Wenn Sie die VSS-Aktualisierung installieren, werden dadurch Probleme wie erschöpfte Kernelressourcen behoben.

So beheben Sie diesen Fehler

  • Installieren Sie die VSS-Aktualisierung, die im Microsoft Knowledge Base-Artikel 891957, „Update zum Beheben verschiedener Volumeschattenkopie-Dienst-Probleme in Windows Server 2003 verfügbar" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=891957), heruntergeladen werden kann.

Informationen über Best Practices bei der Verwendung des VSS mit Exchange Server 2003 finden Sie unter „Best Practices for Using Volume Shadow Copy Service with Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=56571).


„LeakDiag" ist installiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob LeakDiag.exe auf dem Computer installiert wurde:

HKEY_LOCAL_MACHINE\Software\Microsoft\LeakDiag

Wenn Microsoft Exchange Server Analyzer erkennt, dass dieser Registrierungszweig vorhanden ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Bei LeakDiag handelt es sich um eine Reihe von Tools, die Entwicklern, Support-Experten und IT-Personal dabei unterstützen, Arbeitsspeicherverluste, Fragmentierungen und andere Probleme im Zusammenhang mit Arbeitsspeichern in Anwendungen oder Diensten zu erkennen, die auf Computern unter Microsoft Windows NT® Server 4.0, Windows® 2000 Server, Windows XP und Windows Server™ 2003 ausgeführt werden.

Die LeakDiag-Tools können verwendet werden, um Arbeitsspeicherverluste bis zur Codezeile festzustellen. Mithilfe der Detours-Technologie von Microsoft fängt LeakDiag Aufrufe zu bestimmten Arbeitsspeicherreservierungen ab und verfolgt die verschiedenen Aufrufstapelspeicher. LeakDiag berichtet über Arbeitsspeicher, die zwar zugeordnet, jedoch noch nicht verfügbar sind. Sie können mithilfe dieser Informationen Probleme im Zusammenhang mit Arbeitsspeicherverlusten behandeln und die für die Zuordnungen verantwortlichen Komponenten festlegen. Mit richtigen Debug-Symbolen kann sogar die Codezeile, die die Reservierungen angefordert hat, erkannt werden.

Es wird empfohlen, LeakDiag nicht auf Exchange-Servern in Produktionsumgebungen auszuführen. Wird LeakDiag aktiviert, werden alle Arbeitsspeicherreservierungen für alle Prozesse jedesmal beim Starten des Exchange-Servers verfolgt. Dadurch werden sehr viele Prozessor- und Arbeitsspeicherressourcen verbraucht. Dies wird aus diesem Grund nur dann empfohlen, wenn Probleme im Zusammenhang mit Arbeitsspeichern aktiv behandelt werden. Wenn Sie Probleme im Zusammenhang mit Arbeitsspeichern nicht aktiv behandeln, deaktivieren Sie LeakDiag. Das Ausführen von LeakDiag in einer Exchange Server-Produktionsumgebung kann zu Arbeitsspeicherfragmentierung und -belastung und letztendlich zu Exchange-Fehlern führen.

Hinweis:
Beheben Sie Probleme mit LeakDiag immer außerhalb der Spitzenzeiten. Das Verwenden von LeakDiag zu Spitzenzeiten kann zu einer erheblichen Leistungsminderung des Exchange Server-Computers führen.

Informationen zu dieser Meldung

  1. Diese Meldung ist ausschließlich zum Zwecke der Information. Solange LeakDiag weder aktiviert ist noch ausgeführt wird, wirkt sich die Installation allein nicht auf die Exchange Server-Leistung aus. LeakDiag erfordert fast 4 MB Festplattenspeicher (Protokolle nicht eingeschlossen).

  2. Um diesen Speicherplatz verfügbar zu machen, können Sie LeakDiag.exe entfernen, indem Sie zu Systemsteuerung gehen, auf Programme hinzufügen/entfernen klicken, auf LeakDiag klicken und dann auf Entfernen klicken.

Die aktuellste LeakDiag-Version finden Sie auf der öffentlichen Microsoft FTP-Site unter http://go.microsoft.com/fwlink/?LinkId=41401.


„LeakDiag" ist aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob LeakDiag.exe auf dem Computer aktiviert wurde:

HKEY_LOCAL_MACHINE\Software\Microsoft\LeakDiag\EnableAutoStart

Wenn Exchange Server Analyzer feststellt, dass der Wert EnableAutoStart auf 1 festgelegt wurde, wird eine Warnung angezeigt. EnableAutoStart wird mithilfe der LeakDiag-Benutzerschnittstelle konfiguriert. Der Standardwert ist 0. Der Wert 1 zeigt an, dass LeakDiag aktiviert wurde und aktiv ist.

Bei LeakDiag handelt es sich um eine Reihe von Tools, die Entwickler, Support-Experten und IT-Personal dabei unterstützen, Arbeitsspeicherverluste, Fragmentierungen und andere Probleme im Zusammenhang mit Arbeitsspeichern in Anwendungen oder Diensten zu erkennen, die auf Computern unter Microsoft Windows NT® Server 4.0, Windows® 2000 Server, Windows XP und Windows Server™ 2003 ausgeführt werden.

Die LeakDiag-Tools können verwendet werden, um Arbeitsspeicherverluste bis zur Codezeile festzustellen. Mithilfe der Detours-Technologie von Microsoft fängt LeakDiag Aufrufe zu bestimmten Arbeitsspeicherreservierungen ab und verfolgt die verschiedenen Aufrufstapelspeicher. LeakDiag berichtet über Arbeitsspeicher, die zwar reserviert, jedoch noch nicht verfügbar sind. Mithilfe dieser Informationen können Probleme im Zusammenhang mit Arbeitsspeicherverlusten behandelt und die für die Reservierungen verantwortlichen Komponenten festlegt werden. Mit richtigen Debug-Symbolen kann sogar die Codezeile, die die Reservierungen angefordert hat, erkannt werden.

Es wird empfohlen, LeakDiag nicht auf Exchange-Servern in Produktionsumgebungen auszuführen. Im aktivierten Zustand überwacht LeakDiag bei jedem Start des Exchange-Servers alle Arbeitsspeicherreservierungen für alle Prozesse. Dadurch werden sehr viele Prozessor- und Arbeitsspeicherressourcen verbraucht. Dies wird aus diesem Grund nur dann empfohlen, wenn Probleme im Zusammenhang mit Arbeitsspeichern aktiv behandelt werden. Wenn Sie nicht Probleme im Zusammenhang mit Arbeitsspeichern aktiv behandeln, deaktivieren Sie LeakDiag. Das Ausführen von LeakDiag in einer Exchange Server-Produktionsumgebung kann zu Arbeitsspeicherfragmentierung und -belastung und letztendlich zu Exchange-Fehlern führen.

Hinweis:
Beheben Sie Probleme mit LeakDiag immer außerhalb der Spitzenzeiten. Das Verwenden von LeakDiag zu Spitzenzeiten kann zu einer erheblichen Leistungsminderung des Exchange Server-Computers führen.

So deaktivieren Sie Autostart in LeakDiag.exe

  1. Klicken Sie auf Start, und klicken Sie dann auf LeakDiag.

  2. Klicken Sie im Menü Extra auf Optionen.

  3. Deaktivieren Sie auf der Seite Optionen das Kontrollkästchen AutoStart zulassen, und klicken Sie dann auf OK.

Die aktuellste LeakDiag-Version finden Sie auf der öffentlichen Microsoft FTP-Site unter http://go.microsoft.com/fwlink/?LinkId=41401.


Es verbleiben weniger als sieben Tage Protokollspeicher
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-04-13

Microsoft Exchange Server Analyzer schätzt die verbleibende Zeit ab, bis der Speicherplatz für Transaktionsprotokolle in einer Exchange Server-Speichergruppe verbraucht sein wird. Exchange Server Analyzer schätzt die verbleibende Zeit für das Protokolllaufwerk bis zum Erreichen der Kapazitätsgrenze ab, indem die Zeitstempel der auf dem Laufwerk vorhandenen Transaktionsprotokolldateien überprüft werden. Wenn Exchange Server Analyzer erkennt, dass weniger als sieben Tage verbleiben, bis das Protokolllaufwerk voll sein wird, wird ein Fehler angezeigt.

Auf dem Laufwerk, auf dem die Protokolldateien der Exchange Server-Datenbank gespeichert werden, ist nur noch wenig freier Speicherplatz vorhanden.

Wenn kein freier Speicherplatz mehr auf dem Protokolllaufwerk vorhanden ist, können folgende Probleme auftreten:

  • Die Datenbank lässt sich nicht mehr starten oder herunterfahren.

  • Die Datenbank fährt fehlerhaft herunter („Dirty Shutdown") und wird inkonsistent.

  • Benutzer können nicht mehr auf E-Mail- und/oder Öffentliche Ordner zugreifen.

Möglicherweise ist auf dem Protokolllaufwerk zu wenig Speicherplatz, weil die Umlaufprotokollierung deaktiviert ist. Aus diesem Grund verbleiben Transaktionsprotokolldateien auf dem Laufwerk, bis eine vollständige oder inkrementelle Onlinesicherung unter Verwendung von für Exchange Server geeigneter Sicherungssoftware durchgeführt wurde.

In Exchange Server-Versionen vor Exchange 2003 erreichen Datenbanken möglicherweise den Zustand „Clean Shutdown" nicht vor dem Beenden. Zwei Reservetransaktionsdateien, Res1.log und Res2.log, werden im Falle eines Speicherplatzengpasses in normale Transaktionsprotokolle umgewandelt.

In Exchange Server 2003 wurden Optimierungen vorgenommen, sodass die Datenbanken ordnungsgemäß heruntergefahren werden können, solange die Reserveprotokolldateien noch nicht voll sind. Wenn eine Datenbank nicht ordnungsgemäß heruntergefahren wurde, ist es besonders wichtig, dass die letzten der Datenbank zugeordneten Transaktionsprotokolle nicht gelöscht werden. Diese Transaktionsprotokolle enthalten immer noch wichtige Informationen, die zur Wiederherstellung der Konsistenz in die Datenbank eingebracht werden müssen. Wenn diese Protokolldateien gelöscht werden, kann die Datenbank erst wieder gestartet werden, wenn sie repariert oder wiederhergestellt wurde.

Wenn sich alle Datenbanken in einer Speichergruppe in einem „Clean Shutdwon"-Zustand befinden, wird das Starten der Datenbanken durch das Entfernen aller Transaktionsprotokolle nicht verhindert. Wenn die Transaktionsprotokolle entfernt werden, werden jedoch vorangegangene Sicherungen dadurch ungültig. Das Entfernen bedeutet allerdings nicht, dass vorherige Sicherungen nicht wiederhergestellt werden können. Es heißt vielmehr, dass für eine Datenbank kein Rollforward über den Punkt hinaus ausgeführt werden kann, an dem die Protokolldateien gelöscht wurden.

Der in Exchange Server Analyzer enthaltene Assistent für Protokollspeicher analysiert die vorhandenen Transaktionsprotokolldateien und hilft Ihnen beim Verschieben der von der Datenbank nicht mehr benötigten Dateien. Der Assistent für Protokollspeicher stellt auch dann, wenn sich alle Datenbanken in einem „Clean Shutdwon"-Zustand befinden, sicher, dass die aktuelle Protokolldatei nicht entfernt wird. Wenn die aktuelle Protokolldatei nicht entfernt wird, bleiben die vorherigen Sicherungen gültig.

Um Speicherplatz für Protokolle freizugeben, müssen Sie nicht mehr benötigte Protokolldateien löschen. Folgende Aktionen werden empfohlen.

So geben Sie bei Speicherplatzproblemen Speicherplatz für Protokolle frei

  • Erstellen Sie eine für Exchange geeignete Onlinestreamingsicherung oder eine Sicherung mit dem Volumeschattenkopie-Dienst (Volume Shadow Copy Service, VSS) der Datenbank. Weitere Informationen zu VSS-Sicherungen finden Sie unter „Best Practices for Using Volume Shadow Copy Service with Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=56571).

    Hinweis:
    Die bevorzugte Methode zum Löschen nicht mehr benötigter Protokolldateien besteht im Erstellen einer Onlinestreamingsicherung oder einer VSS-Sicherung.

  • Wenn die Datenbank heruntergefahren wird, weil der Protokollspeicherplatz bald erschöpft ist, können Sie den Assistenten für die Protokollspeicherverwaltung von Exchange Server Analyzer verwenden. Mithilfe des Assistenten können überschüssige Protokolldateien verschoben werden. Alternativ können Sie überschüssige Protokolldateien manuell verschieben, bevor die Datenbank wieder bereitgestellt wird.

    Verwenden Sie zum manuellen Entfernen von Protokolldateien die Verfahren und Empfehlungen im Microsoft Knowledge Base-Artikel 240145, „Entfernen von Exchange Server-Transaktionsprotokolldateien" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240145).


Der LegacyExchangeDN für diesen Exchange-Server entspricht nicht der übergeordneten administrativen Gruppe.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-09

Microsoft® Exchange Server Analyzer sendet eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert des legacyExchangeDN für einen Server durch Überprüfung der Attribute des Serverobjekts im Container Servers in Active Directory zu verifizieren, indem ein Vergleich mit dem tatsächlichen Namen der Organisation und der administrativen Gruppe, in der sich der Server befindet, erfolgt. Wenn der Wert legacyExchangeDN des Servers von dem der Organisation oder administrativen Gruppe abweicht, wird ein Fehler angezeigt.

Exchange verwendet den Wert legacyExchangeDN zur Identifizierung der Exchange-Objekte in Active Directory. Der Wert legacyExchangeDN ist ein Distinguished Name (DN), der angibt, wohin ein Objekt in die Exchange-Organisation passt, z. B.:

/o= Organisation /ou= Administrative Gruppe /ou= Server

Objekte wie Postfachspeicher und Informationsspeicher für öffentliche Ordner erben einen Teil ihrer legacyExchangeDN-Werte vom Server. Falls also ein Problem beim Wert des Servers auftritt, kann dieses Problem möglicherweise auch bei anderen Objekten auftreten.

Probleme mit dem legacyExchangeDN treten i. d. R. dann auf, wenn ein Administrator eine direkte Änderung dieses Wertes vornimmt. Sie müssen den Wert mit einem Tool wie Active Directory Service Interfaces (ADSI) Edit, LDP (ldp.exe) oder einem beliebigen anderen Client für LDAP (Lightweight Directory Acess Protocol), Version 3, korrigieren.

Achtung:
Wenn Sie die ADSI-Bearbeitung, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, von Exchange Server 2003 bzw. Exchange Server 2007 oder beider Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So beheben Sie diesen Fehler

  1. Verwenden Sie die ADSI-Bearbeitung oder ein vergleichbares Tool, um das administrative Gruppenobjekt in Active Directory zu suchen.

    Das Attribut legacyExchangeDN befindet sich unter:

    CN=Konfiguration,CN=Dienste,CN=Microsoft Exchange,CN=Organisation,CN=Administrative Gruppen,CN=Administrative Gruppe,CN=Server,CN=Server

  2. Geben Sie einen neuen Zeichenfolgenwert in folgender Form ein:

    /o= Organisation /ou= Administrative Gruppe /ou= Server

Weitere Informationen zum Verwenden des LDP-Tools finden Sie im Microsoft Knowledge Base-Artikel 260745 „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Weitere Informationen zur Verwendung der ADSI-Bearbeitung finden Sie im Abschnitt „Adsiedit.msc: ADSI-Bearbeitung" in der Hilfe zu Windows Server 2003.


Der LegacyExchangeDN für diesen Exchange-Server ist ungültig.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-09

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des legacyExchangeDN für den Exchange-Server zu überprüfen. Dieser Fehler wird angezeigt, wenn die Organisation oder die administrative Gruppe, die im Wert legacyExchangeDN benannt wird, nicht dem tatsächlichen Namen der Organisation bzw. der administrativen Gruppe entspricht, oder falls generell Teile des Werts fehlen.

Exchange verwendet den Wert legacyExchangeDN zur Identifizierung der Exchange-Objekte in Active Directory. Der Wert legacyExchangeDN ist ein Distinguished Name (DN), der angibt, wohin ein Objekt in die Exchange-Organisation passt, z. B.:

/o= Organisation /ou= Administrative Gruppe

Objekte wie z. B. Server und Ordnerhierarchien erben einen Teil der legacyExchangeDN-Werte von der administrativen Gruppe. Falls also ein Problem beim Wert der administrativen Gruppe auftritt, kann dieses Problem möglicherweise auch bei vielen anderen Objekten auftreten.

Probleme mit dem legacyExchangeDN treten i. d. R. dann auf, wenn ein Administrator eine direkte Änderung dieses Werts vornimmt. Sie müssen den Wert mit einem Tool wie Active Directory Service Interfaces (ADSI) Edit, dem LDP-Tool (ldp.exe) oder einem beliebigen anderen LDAP-Client (Lightweight Directory Acess Protocol), Version 3, korrigieren.

Achtung:
Wenn Sie die ADSI-Bearbeitung, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, von Exchange Server 2003 bzw. Exchange Server 2007 oder beider Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So beheben Sie diesen Fehler

  1. Verwenden Sie die ADSI-Bearbeitung oder ein vergleichbares Tool, um das administrative Gruppenobjekt in Active Directory zu suchen.

    Das Attribut legacyExchangeDN befindet sich unter:

    CN=Konfiguration,CN=Dienste,CN=Microsoft Exchange,CN=Organisation,CN=Administrative Gruppen,CN=Administrative Gruppe

  2. Geben Sie einen neuen Zeichenfolgenwert in folgender Form ein:

    /o= Organisation /ou= Administrative Gruppe

Weitere Informationen zum Verwenden des LDP-Tools finden Sie im Microsoft Knowledge Base-Artikel 260745 „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Weitere Informationen zur Verwendung der ADSI-Bearbeitung finden Sie im Abschnitt „Adsiedit.msc: ADSI-Bearbeitung" in der Hilfe zu Windows Server 2003.


Lizenzprotokollierdienst wird auf „Automatisch" festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_Service ab, um den Wert für den Schlüssel Started für den Lizenzprotokollierdienst (LicenseService) zu bestimmen. Der Wert False zeigt an, dass der Lizenzprotokollierdienst auf diesem Exchange-Server nicht ausgeführt wird. Der Wert True zeigt an, dass der Lizenzprotokollierdienst ausgeführt wird.

Exchange Server Analyzer sendet auch eine Abfrage an die WMI-Klasse Exchange_Server im Namespace root\MicrosoftExchangeV2, um den Wert für den Schlüssel IsFrontEndServer zu bestimmen. Der Wert False gibt an, dass der Exchange Server-Computer kein Front-End-Server ist. Der Wert True zeigt an, dass der Exchange Server-Computer ein Front-End-Server ist.

Exchange Server Analyzer sendet auch eine Abfrage an die WMI-Klasse Win32_OperatingSystem, um den Wert des Schlüssels OSProductSuite zu ermitteln. Der für diesen Schlüssel zurückgegebene Wert gibt die Version des Windows-Betriebssystems an, das auf dem Exchange Server-Computer ausgeführt wird.

Um die Anzahl der Einträge zu ermitteln, die im Attribut homeMDBBL der einzelnen Postfachspeicher aufgelistet sind, fragt Exchange Server Analyzer außerdem den Active Directory®-Verzeichnisdienst ab. Der Zählwert dieses Attributs stellt die Zahl der Postfächer im Postfachspeicher dar.

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Lizenzprotokollierdienst auf einem Exchange Server-Computer gestartet wird, der die folgenden Kriterien erfüllt, wird eine Warnung angezeigt:

  • Der Exchange Server-Computer ist kein Front-End-Server.

  • Der Exchange Server-Computer dient als Host für 20 Postfächer.

  • Der Exchange Server-Computer wird nicht unter Microsoft Windows Small Business Server 2003 oder Microsoft Small Business Server 2000 ausgeführt.

Der Lizenzprotokollierdienst ist ein Tool, das ursprünglich dazu bestimmt ist, Kunden zu helfen, Lizenzen für Microsoft-Server-Produkte zu verwalten, die im Terminalserver-Clientzugriffslizenz-Modell (CAL) lizenziert sind.

Der Lizenzprotokollierdienst ist in der Microsoft Windows Server™ 2003-Standardeinstellung deaktiviert. Aufgrund der Beschränkungen des Originalentwurfs und der Einbeziehung der Lizenzbedingungen und -bestimmungen kann der Lizenzprotokollierdienst keine genaue Sicht auf die Anzahl der gekauften Terminalserver-Clientzugriffslizenzen im Vergleich zur Gesamtanzahl der Terminalserver-Clientzugriffslizenzen geben, die unternehmensweit oder auf einem einzelnen Server verwendet werden. Die Terminalserver-Clientzugriffslizenzen, die vom Lizenzprotokollierdienst erfasst werden, können der Auslegung des Endbenutzer-Lizenzvertrages (EULA) und den Produktnutzungsrechten (PUR) widersprechen. Der Lizenzprotokollierdienst wird in späteren Versionen des Windows-Betriebssystems nicht mehr zur Verfügung stehen.

Microsoft hat bestimmte Anforderungen und Empfehlungen für die Verwendung des Lizenzprotokollierdienstes auf Exchange Server-Computern:

  • Auf Front-End-Exchange-Servern, die SSL (Secure Sockets Layer) verwenden, müssen Sie den Lizenzprotokollierdienst aktivieren und starten. Wenn der Lizenzprotokollierdienst nicht ausgeführt wird, beschränkt IIS (Internet Information Services) die Anzahl der gleichzeitig authentifizierten SSL-Verbindungen auf 10.

  • Bei Back-End-Exchange-Servern wird empfohlen, den Lizenzprotokollierdienst anzuhalten und zu deaktivieren.

  • Bei Exchange-Servern innerhalb eines Clusters wird empfohlen, den Lizenzprotokollierdienst anzuhalten und zu deaktivieren.

  • Bei Exchange-Servern, die auf Microsoft Windows Small Business Server 2003 oder Small Business Server 2000 ausgeführt werden, ist der Lizenzprotokollierdienst nur erforderlich, wenn mehr als 10 authentifizierte SSL-Verbindungen benötigt werden.

So legen Sie den Status des Lizenzprotokollierdiensts fest

  1. Starten Sie das Snap-in Dienste aus dem Menü Verwaltung.

  2. Suchen Sie Lizenzprotokollierdienst, und doppelklicken Sie darauf.

  3. Wählen Sie in der Dropdownliste Starttyp die entsprechende Option aus:

    • Legen Sie auf Front-End-Exchange-Servern, die SSL verwenden, für den Dienst den Wert Automatisch fest.

    • Legen Sie auf Back-End-Exchange-Servern und gruppierten Exchange-Servern für den Dienst Deaktiviert fest.

  4. Wenn Sie den Lizenzprotokollierdienst deaktivieren, müssen Sie auch auf Beenden klicken, um den Dienst zu beenden.

  5. Klicken Sie zum Speichern der Änderungen auf OK, und schließen Sie das Snap-In Dienste.

Weitere Informationen zum Lizenzprotokollierdienst finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 824196, „Beschreibung des Lizenzprotokollierdiensts in Windows Server-Betriebssystemen" unter http://support.microsoft.com/kb/824196/de.

  • 316631, „How to Turn Off the License Logging Service" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=316631.


Protokolldateiname stimmt nicht mit der Protokollgenerierungsnummer überein
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-07

Microsoft® Exchange Server Analyzer vergleicht den Wert der internen Generierungsnummer lGeneration aus dem Header der Transaktionsprotokolldatei mit dem Dateinamen der Transaktionsprotokolldatei, um zu ermitteln, ob sie übereinstimmen.

Wenn die interne Generierungsnummer aus der Transaktionsprotokolldatei nicht mit der Darstellung der internen Generierungsnummer im Namen der Transaktionsprotokolldatei übereinstimmt, zeigt Exchange Server Analyzer einen Fehler an.

Die neueste verfügbare Protokolldatei muss einen Dateinamen aufweisen, der mit der Generierungsnummer übereinstimmt, solange es sich bei der Protokolldatei nicht um das aktuelle Protokoll handelt. Wenn eine Protokolldatei das aktuelle Protokoll ist, darf der Dateiname nicht die Generierungsnummer enthalten, sondern nur das Protokollpräfix für die Speichergruppe. Die früheren Transaktionsprotokolle in einer Sequenz können beispielsweise E0154321.LOG, E0154322.LOG, E0154323.LOG usw. heißen, während das aktuelle Protokoll den Namen E01.LOG aufweist.

Mit dem Befehl Eseutil /ML LOGFILE können Sie den internen lGeneration-Wert für eine Protokolldatei anzeigen.

Weitere Informationen zur Exchange Server-Transaktionsprotokollierung finden Sie unter "Exchange Transaction Logging in Exchange Server 2003" in Using Recovery Storage Groups in Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589).


Fehlende Signaturübereinstimmung bei Protokollsequenz
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-07

Microsoft® Exchange Server Analyzer vergleicht den Signature-Wert einer Protokolldatei mit dem Signature-Wert der nachfolgenden Protokolldatei, um zu ermitteln, ob sie übereinstimmen.

Wenn der Signature-Wert einer Protokolldatei nicht mit dem Signature-Wert der nachfolgenden Protokolldatei übereinstimmt, zeigt Exchange Server Analyzer einen Fehler an.

Exchange verwendet eine Sequenz von Protokolldateien, die jeweils genau 5 MB groß sind, anstatt alle Protokollinformationen in eine einzige große Datei zu schreiben. Wenn die Protokolldatei voll ist, wird sie geschlossen und mit einer Sequenznummer umbenannt.

Wenn für eine Exchange-Speichergruppe eine neue Sequenz von Transaktionsprotokolldateien initialisiert wird, wird ein Signature-Wert in die erste Protokolldatei geschrieben, der in alle nachfolgenden Protokolldateien kopiert wird. Der Signature-Wert identifiziert eine bestimmte Protokolldatei eindeutig als Bestandteil einer bestimmten Protokollsequenz.

Es darf niemals sein, dass Protokolldateien mit unterschiedlichen Signaturen im selben Ordner vorhanden sind. In diesem Fall wurden fremde Protokolldateien in die Speichergruppe kopiert oder die Protokolldateien zurückgesetzt, ohne dass alle früheren Protokolldateien zuerst gelöscht wurden.

Mit dem Befehl Eseutil /ML LOGFILE können Sie den Signature-Wert für eine Protokolldatei anzeigen.

Weitere Informationen zur Exchange Server-Transaktionsprotokollierung finden Sie unter "Exchange Transaction Logging in Exchange Server 2003" in Using Recovery Storage Groups in Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589).


Problem bei der Protokollsignatur
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-07

Microsoft® Exchange Server Analyzer vergleicht die Signatur im Header der aktuellen Exchange-Transaktionsprotokolldatei auf einem Server mit der Protokollsignatur in der Datenbankdatei der Speichergruppe.

Wenn Signatur der Transaktionsprotokolldatei nicht mit der Protokollsignatur in den Datenbankdateien übereinstimmt, zeigt Exchange Server Analyzer einen Fehler an.

Dieser Fehler weist darauf hin, dass eine der folgenden Bedingungen vorliegt:

  • Die aktuelle Transaktionsprotokolldatei ist nicht vorhanden.

  • Die aktuelle Transaktionsprotokolldatei entspricht keiner Datenbank in der Speichergruppe.

Dieses Verhalten kann aus einem der folgenden Gründe auftreten:

  • Die Transaktionsprotokolle für die Speichergruppe wurden manuell gelöscht.

  • Eine Datenbank einer anderen Speichergruppe wurde in diese Speichergruppe wiederhergestellt oder kopiert.

  • In diese Speichergruppe wurden Transaktionsprotokolldateien einer anderen Sequenz oder Speichergruppe kopiert.

Ob diese Bedingung die Bereitstellung einer Datenbank verhindert, hängt davon ab, ob eine Datenbankdatei den Status Ordnungsgemäß beendet oder den Status Fehlerhaft beendet aufweist.

Hinweis:
Eine Datenbank kann sich im Status Ordnungsgemäß beendet befinden, aber dennoch nicht bereitgestellt werden, weil andere Datenbanken in der Speichergruppe nicht bereitgestellt werden können. Mit Exchange Server Disaster Recovery Analyzer können Sie in diesen Fällen eine Diagnose ausführen und ermitteln, wie die Datenbanken bereitgestellt werden können.

Wenn eine Exchange-Datenbank ordnungsgemäß beendet wird, werden alle ausstehenden Daten in die Datenbankdateien geschrieben. Nach einer normalen Beendigung wird der Datenbankdateisatz (mit den Erweiterungen EDB und STM) als konsistent betrachtet. Exchange trennt dann den Datenbankdateisatz vom Protokollstream. Die Datenbankdateien sind jetzt eigenständig, d. h. sie befinden sich vollständig auf dem aktuellen Stand. Zum Starten der Datenbankdateien sind keine früheren Transaktionsprotokolle erforderlich.

Datenbanken im Status Ordnungsgemäß beendet wurden von den zugehörigen Protokolldateien getrennt und können mit einem anderen Protokollstream verbunden sein. Die fehlende Übereinstimmung zwischen den Protokolldateien und der Datenbank muss daher nicht notwendigerweise ein Problem sein.

Datenbanken im Status Fehlerhaft beendet wurden fehlerhaft von ihren Protokolldateien getrennt. Diese Datenbanken müssen mithilfe der zugehörigen Protokolldateien wiederhergestellt werden. Wenn die zugehörigen Protokolldateien nicht gefunden werden können, kann die Datenbank nicht bereitgestellt werden. Sie müssen die Datenbank anhand der Sicherung wiederherstellen oder reparieren, bevor sie bereitgestellt werden kann.

Mit dem Befehl Eseutil /mh können Sie feststellen, ob eine Datenbank ordnungsgemäß beendet wurde, indem Sie die Dateiheader untersuchen. In Microsoft Exchange 2000 Service Pack 1 und höher lautet eine Zeile im Header entweder "State: Clean Shutdown" oder "State: Dirty Shutdown". In früheren Exchange-Versionen wird der Status als "State: Consistent" oder "State: Inconsistent" gemeldet.

Weitere Informationen zur Exchange Server-Transaktionsprotokollierung finden Sie unter "Exchange Transaction Logging in Exchange Server 2003" in Using Recovery Storage Groups in Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589).


"Protokolldatensatzbytes/Sek." überschreitet Fehlerschwellenwert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-23

Das Tool Microsoft® Exchange Server Analyzer verwendet das Tool Exchange Server User Monitor (ExMon), um zu bestimmen, ob MAPI-Benutzeroperationen so erfolgen, wie auf einem stabilen Server mit Exchange erwartet werden sollte.

Im Rahmen seiner Untersuchung überprüft Exchange Server Analyzer die Transaktionsprotokollverwendung, um zu bestimmen, ob MAPI-Benutzeroperationen dafür sorgen, dass mehr als 5 MB Daten pro Minute in die Exchange-Transaktionsprotokolle geschrieben werden.

Ein übermäßiges Anwachsen der Transaktionsprotokolldatei aufgrund von MAPI-Operationen kann zu Engpässen bei den Serverressourcen und Fehlern führen, z. B. Überschreitung der Prüfpunkttiefe, Datenträger-E/A-Engpässen und unzureichender Datenträgerspeicherplatz.

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere MAPI-Benutzeroperationen dafür sorgen, dass mehr als 5 MB Daten in die Exchange-Transaktionsprotokolle geschrieben werden, zeigt Exchange Server Analyzer eine Fehlermeldung an.

MAPI-Operationen, die mehr als 5 MB Daten in die Exchange-Transaktionsprotokolle schreiben, sind nicht unbedingt immer problematisch. Schreibvorgänge mit einer hohen Rate sind bei bestimmten Aktionen zu erwarten, z. B. bei Postfachverschiebungen oder anderen Massenoperationen, die auf viele Nachrichten angewendet werden und sehr große Mengen von Transaktionsprotokolldaten generieren. In diesem Fall sollten die hohen Raten jedoch nicht länger als einige Minuten auftreten.

Wenn auf dem Server andere Probleme, z. B. lange RPC-Wartezeiten auftreten, arbeiten Sie mit dem Benutzer zusammen, der die Transaktionsprotokolldaten generiert, um zu bestimmen, welche Aktivität die hohe Schreibrate in den Protokolldatensatz verursacht.

Weitere Informationen

Weitere Informationen finden Sie in den folgenden Ressourcen zu Exchange Server:

  • Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Behandlung von Leistungsproblemen bei Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Exchange Server 2003 Performance: 10 Things to Think About (http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft Knowledge Base-Artikel 905803, "Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Das Objekt zur Leistungsüberwachung „LogicalDisk" ist nicht vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Avg. Disk sec/Read-Leistungsindikator des LogicalDisk-Leistungsobjekts. Wenn gültige Daten nicht vom Indikator zurückgegeben werden, zeigt Microsoft Exchange Server Analyzer eine Basislinienmeldung an.

Wenn keine gültigen Daten vom Erfassungsmodul für Leistungsdaten zurückgegeben werden, liegt mindestens eine der folgenden Bedingungen vor:

  • Das LogicalDisk-Leistungsobjekt ist deaktiviert. Unter Microsoft Windows Server™ 2003 ist das LogicalDisk-Leistungsobjekt der Standardeinstellung aktiviert. Unter Microsoft Windows® 2000 Server ist LogicalDisk in der Standardeinstellung jedoch nicht aktiviert.

  • Das LogicalDisk-Leistungsüberwachungsobjekt fehlt oder ist beschädigt.

  • Microsoft Exchange Server Analyzer verfügt nicht über entsprechende Berechtigungen zum Zugreifen auf die Leistungsobjekte.

Die ersten beiden Bedingungen treten auf, wenn die Registrierung von bestimmten erweiterbaren Indikatoren beschädigt wird oder wenn die Registrierung von auf Microsoft WMI (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) basierten Programmen geändert wird.

Im folgenden Verfahren wird die Behebung der ersten beiden Bedingungen erläutert. Überprüfen Sie vor dem Ausführen des Verfahrens, ob Microsoft Exchange Server Analyzer über entsprechende Berechtigungen verfügt. Weitere Informationen zu den Berechtigungen, die zum Ausführen von Microsoft Exchange Server Analyzer erforderlich sind, finden Sie in der im Lieferumfang von Microsoft Exchange Server Analyzer enthaltenen Hilfedokumentation. Wenn Sie Hilfe erhalten möchten, öffnen Sie Exchange Server Analyzer, und drücken Sie F1.

So beheben Sie diesen Fehler

  1. Überprüfen Sie, ob das LogicalDisk-Leistungsobjekt aktiviert ist:

    1. Downloaden und installieren Sie das Tool Extensible Performance Counter List (Exctrlst.exe). Sie können Exctrlst.exe unter „Exctrlst.exe: Extensible Performance Counter List" (http://go.microsoft.com/fwlink/?LinkId=34436) downloaden.

    2. Öffnen Sie die Datei Exctrlst.exe, klicken Sie auf Sortierreihenfolge und anschließend auf Dienst.

    3. Suchen Sie den Dienst, über den das Leistungsobjekt eine Meldung ausgeben soll, und überprüfen Sie, ob das Kontrollkästchen Leistungsindikatoren aktiviert aktiviert ist.

      Wenn das Kontrollkästchen Leistungsindikatoren aktiviert nicht aktiviert ist, aktivieren Sie es, und starten Sie den Dienst neu, der dem Leistungsindikator zugeordnet ist, um zu überprüfen, ob die Leistungsindikatoren betriebsbereit sind. Wenn die Leistungsindikatoren nicht betriebsbereit sind oder wenn das Kontrollkästchen Leistungsindikatoren aktiviert bereits aktiviert wurde, fahren Sie mit Schritt 2 fort.

  2. Erstellen Sie die nicht vorhandenen oder beschädigten Leistungsindikatoren wie im Microsoft Knowledge Base-Artikel 300956 „Manuelles Neuerstellen der Werte der Leistungsindikatorenbibliothek" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) beschrieben neu.

  3. Wenn Sie das Problem anhand dieses Knowledge Base-Artikels nicht beheben lässt, müssen Sie das Windows-Betriebssystem im Modus Reparieren erneut installieren und die aktuellsten Windows-Service Packs anwenden.


MAPI-Operationen mit langen Wartezeiten erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-11-22

Das Tool Microsoft® Exchange Server Analyzer verwendet das Tool Exchange Server User Monitor (ExMon) zum Erfassen von Daten (über einen Zeitraum von fünf Minuten), um zu bestimmen, ob MAPI-Benutzeroperationen länger dauern, als auf einem stabilen Server mit Exchange erwartet werden sollte.

Wenn Exchange Server Analyzer feststellt, dass im Zeitraum der Datenerfassung eine oder mehrere MAPI-Operationen länger als 30 Sekunden gedauert haben, zeigt Exchange Server Analyzer eine Fehlermeldung an und führt eine zusätzliche Analyse der Aktionen der Benutzer aus, die den Fehler ausgelöst haben.

MAPI-Operationen, die länger als 30 Sekunden dauern, sind nicht unbedingt immer problematisch. Das Speichern großer Mengen von Nachrichtendaten oder Dateianlagen kann beispielsweise dazu führen, dass MAPI-Operationen länger als normal dauern.

Wenn bei dem Benutzer oder den Benutzern häufig Verzögerungen bzw. Verzögerungen auftreten, die sich negativ auf die Messagingumgebung auswirken, sollten diese MAPI-Operationen weiter untersucht werden, um sicherzustellen, dass sie nicht symptomatisch für ernstere Wartezeitenprobleme sind, z. B. Ressourcenengpässe oder geschachtelte Abhängigkeiten.

So beheben Sie diesen Fehler

  • Mit dem Tool ExMon können Sie eine größere Beispieldatenmenge erfassen, um sie von Exchange Server Analyzer untersuchen zu lassen. Aufgrund des großen von ExMon generierten Datenvolumens wird empfohlen, die Erfassung der Beispieldatenmenge auf maximal 30 Minuten zu beschränken.

  • Überprüfen Sie alle Wartezeiten verursachenden Fehler und die Begleitartikel, in denen die entsprechende Operation und die Schritte zur Problemlösung beschrieben werden. Wenn Exchange Server Analyzer keine Wartezeiten verursachenden Fehler meldet, gab die zusätzliche Analyse der Benutzeraktionen keine Probleme zurück.


Lange dauernde MAPI-Massenoperation
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-23

Das Tool Microsoft® Exchange Server Analyzer verwendet das Tool Exchange Server User Monitor (ExMon), um zu bestimmen, ob MAPI-Benutzeroperationen länger dauern, als auf einem stabilen Server mit Exchange erwartet werden sollte.

Im Rahmen dieser Analyse überprüft Exchange Server Analyzer die ExMon-Daten auf von Benutzern ausgelöste MAPI-Massenoperationen, die länger als 30 Sekunden gedauert haben.

MAPI-Massenoperationen sind Operationen, die auf mehrere Objekte angewendet werden und meist aufwändig sind (d. h. viele E/As erfordern).

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere MAPI-Massenoperationen eines Benutzers länger als 30 Sekunden gedauert haben, zeigt Exchange Server Analyzer eine Fehlermeldung an.

MAPI-Massenoperationen, die länger als 30 Sekunden dauern, sind nicht unbedingt immer problematisch. Wenn der Benutzer Operationen (Kopieren, Löschen, Festlegen von Attributkennzeichen usw.) auf 1000 oder mehr Nachrichten gleichzeitig anwendet, können die MAPI-Massenoperationen länger als normal dauern.

Wenn bei dem Benutzer oder den Benutzern häufig Verzögerungen bzw. Verzögerungen auftreten, die sich negativ auf die Messagingumgebung auswirken, sollten diese MAPI-Massenoperationen weiter untersucht werden, um sicherzustellen, dass sie nicht symptomatisch für ernstere Wartezeitenprobleme sind, z. B. Ressourcenengpässe oder geschachtelte Abhängigkeiten.

So beheben Sie diesen Fehler

  • Mit dem Tool ExMon können Sie eine größere Beispieldatenmenge erfassen, um sie von Exchange Server Analyzer untersuchen zu lassen. Aufgrund des großen von ExMon generierten Datenvolumens wird empfohlen, die Erfassung der Beispieldatenmenge auf maximal 30 Minuten zu beschränken.

Weitere Informationen

Weitere Informationen finden Sie in den folgenden Ressourcen zu Exchange Server:

  • Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Behandlung von Leistungsproblemen bei Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Exchange Server 2003 Performance: 10 Things to Think About (http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft Knowledge Base-Artikel 905803, "Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Lange dauernde MAPI-Operation "FindRow"
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-11-22

Das Tool Microsoft® Exchange Server Analyzer verwendet das Tool Exchange Server User Monitor (ExMon), um zu bestimmen, ob MAPI-Benutzeroperationen länger dauern, als auf einem stabilen Server mit Exchange erwartet werden sollte.

Im Rahmen dieser Analyse überprüft Exchange Server Analyzer die ExMon-Daten auf von Benutzern ausgelöste MAPI-Operationen vom Typ FindRow, die länger als 30 Sekunden gedauert haben.

Eine Zunahme der Anzahl von Ansichten für jeden Ordner kann viele MAPI-Operationen ebenfalls mit zusätzlichem Verarbeitungsaufwand belasten. Clientanwendungen verschieben mithilfe der MAPI-Operationen SeekRow oder FindRow den Cursor zwischen Zeilen in einer Ansicht. SeekRow gibt an, um wie viele Zeilen der Cursor verschoben werden soll, und ist in Bezug auf die CPU-Zeit sehr wenig aufwändig. FindRow ist sehr aufwändig, weil damit der Cursor zum ersten Element in einer nicht materialisierten (nicht zwischengespeicherten) Ansicht verschoben wird, die die Beschränkungskriterien erfüllt. Anschließend wird die Ansicht verworfen, nachdem die Clientanwendung den Vorgang abgeschlossen hat. Der endgültige CPU-Verarbeitungsaufwand von FindRow hängt von der Komplexität der Beschränkung und davon ab, wie viele Zeilen der Speicher überprüfen muss, bis er das erste den Kriterien entsprechende Objekt findet. Auf diese Weise sind sie lose mit der Anzahl der Elemente im Ordner korreliert.

Der möglicherweise hohe Verarbeitungsaufwand in Verbindung mit FindRow lassen diese Operation als guten Kandidaten für die Ausführung im Cachemodus erscheinen, weil damit der Server von dem Verarbeitungsaufwand befreit wird. Seien Sie sich bewusst, dass der davon beanspruchte hohe Anteil an der CPU-Leistung manchmal durch gemeinsam genutzte Kalender verursacht sein kann. In diesem Fall hilft auch Cachemodus nicht. Hoher Verbrauch von CPU-Zeit durch FindRow-Operationen könnte darauf hindeuten, dass viele oder aufwändige Ansichten erstellt werden oder viele Objekte in den Ordnern enthalten sind.

Wenn Exchange Server Analyzer feststellt, dass eine von einem Benutzer ausgelöste MAPI-Operation vom Typ FindRow länger als 30 Sekunden gedauert hat, zeigt Exchange Server Analyzer eine Fehlermeldung an.

MAPI-Operationen vom Typ FindRow, die länger als 30 Sekunden dauern, sind nicht unbedingt immer problematisch. Wenn bei den ermittelten Benutzern häufig Verzögerungen bzw. Verzögerungen auftreten, die sich negativ auf die Messagingumgebung auswirken, sollten Sie die Gründe kennen. Arbeiten Sie mit dem Benutzer zusammen, bei dem lange Verzögerungen auftreten, um Folgendes zu bestimmen:

  • Ist die Anzahl der Elemente in Ordnern hoch?

  • Welche Anwendungen führt der Benutzer aus?

So beheben Sie dieses Problem

  • Bitten Sie Benutzer mit zahlreichen Elementen in ihren Ordnern, die Anzahl der Elemente pro Ordner zu reduzieren. Es wird empfohlen, dass Sie weniger als 5000 Elemente in den Ordnern Posteingang, Kalender, Gesendete Elemente, Kalender und Gelöschte Elemente speichern.

  • Konfigurieren Sie die Clientcomputer, deren Betrieb am aufwändigsten ist (insbesondere diejenigen mit langen Wartezeiten bei den Vorgängen Restrict, SetColumns oder FindRow) für die Verwendung im Exchange-Cachemodus. Im Exchange-Cachemodus wird der Server von nahezu allem überschüssigen RPC-Datenverkehr isoliert.

  • Deaktivieren Sie sämtliche Anwendungen, und aktivieren Sie sie anschließend einzeln nacheinander, um die Anwendung zu bestimmen, die das Problem ggf. verursacht. Wenn diese Anwendungen für Ihre geschäftlichen Zwecke nicht erforderlich sind oder es für die Anwendungen einen veröffentlichten Hotfix gibt, deaktivieren Sie die Anwendungen, oder aktualisieren Sie sie, um die Verarbeitungslast auf ein angemesseneres Niveau abzusenken.

Hinweis:
Manche Anwendungen können die Serverlast deutlich erhöhen, ohne eine große Anzahl von MAPI-Operationen zu verursachen. Dies liegt daran, dass manche Operationen aufwändiger als andere sind. Es kann zwar sein, dass die Anzahl der aufwändigen Operationen nur geringfügig ansteigt, dass dies aber einen deutlichen Einfluss auf die Serverleistung hat. ExMon meldet diese Benutzer mit einem starken Einfluss auf die CPU, ohne dass sie notwendigerweise eine hohe Anzahl von MAPI-Operationen durchgeführt haben.

Beachten Sie auch, dass die Wartezeiten für FindRow-Operationen zunehmen, wenn es einen Ressourcenengpass (im Allgemeinen einen Datenträger- oder CPU-Engpass) gibt.

Weitere Informationen

Weitere Informationen finden Sie in den folgenden Ressourcen zu Exchange Server:

  • Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Behandlung von Leistungsproblemen bei Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Exchange Server 2003 Performance: 10 Things to Think About (http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft Knowledge Base-Artikel 905803 "Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Lange dauernde MAPI-Onlineoperation
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-23

Das Tool Microsoft® Exchange Server Analyzer verwendet das Tool Exchange Server User Monitor (ExMon), um zu bestimmen, ob MAPI-Onlineoperationen von Benutzern länger dauern, als auf einem stabilen Server mit Exchange erwartet werden sollte.

Ein Beispiel einer MAPI-Onlineoperation ist QueryRows.

Die Operation QueryRows dient zum Zurückgeben von Zeilen in der aktuellen Ansicht. QueryRows nutzt die Daten in einer Tabelle zum Erfüllen der Benutzeranforderung. Die Operation SetColumns bestimmt die Daten, die für QueryRows verfügbar sind. Der Verarbeitungsaufwand von QueryRows nimmt mit der Größe und Anzahl der angeforderten Eigenschaften sowie der Anzahl der angeforderten Datenzeilen zu. QueryRows kann auch aufwändig sein, wenn viele Spalten und Zeilen angefordert werden.

Bei zunehmender Anzahl der Elemente in den Exchange Server 2003-Hauptordnern nimmt auch der Verarbeitungsaufwand einiger Operationen auf dem physikalischen Datenträger für Benutzer von Outlook zu. Das erstmalige Sortieren des Ordners Posteingang ist sehr aufwändig (da viele Datenträger-E/As erforderlich sind). Auch künftige Sortiervorgänge im Ordner Posteingang sind sehr aufwändig.

Wenn Exchange Server Analyzer feststellt, dass im Zeitraum der Datenerfassung eine oder mehrere MAPI-Onlineoperationen länger als 30 Sekunden gedauert haben, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Lange Wartezeiten bei MAPI-Onlineoperationen können ein Hinweis auf einen Engpass einer Serverressource sein. Bei der Operation QueryRows kann dies auch eine hohe Anzahl von Elementen in einem Ordner oder viele für die internen Tabellen festgelegte Eigenschaften bedeuten.

Wenn eine Onlineoperation mit langer Wartezeit gleichzeitig auf viele Daten angewendet wird, ist die lange Wartezeit ggf. kein Hinweis auf ein Problem mit der Serverleistung. Ein Beispiel hierfür ist, wenn ein Benutzer alle Elemente in einem Ordner auswählt und diese in einer einzigen Operation als gelesen markiert. Arbeiten Sie mit dem Benutzer zusammen, bei dem lange Verzögerungen auftreten, um Folgendes zu bestimmen:

  • Ist die Anzahl der Elemente in Ordnern hoch?

  • Welche Anwendungen führt der Benutzer aus?

So beheben Sie dieses Problem

  • Bitten Sie Benutzer mit zahlreichen Elementen in ihren Ordnern, die Anzahl der Elemente pro Ordner zu reduzieren. Es wird empfohlen, dass Sie weniger als 5000 Elemente in den Ordnern Posteingang, Kalender, Gesendete Elemente, Kalender und Gelöschte Elemente speichern.

  • Deaktivieren Sie sämtliche Anwendungen, und aktivieren Sie sie anschließend einzeln nacheinander, um die Anwendung zu bestimmen, die das Problem ggf. verursacht. Wenn diese Anwendungen für Ihre geschäftlichen Zwecke nicht erforderlich sind oder es für die Anwendungen einen veröffentlichten Hotfix gibt, deaktivieren Sie die Anwendungen, oder aktualisieren Sie sie, um die Verarbeitungslast auf ein angemesseneres Niveau abzusenken.

Hinweis:
Manche Anwendungen können die Serverlast deutlich erhöhen, ohne eine große Anzahl von MAPI-Onlineoperationen zu verursachen. Dies liegt daran, dass manche Operationen aufwändiger als andere sind. Es kann zwar sein, dass die Anzahl der aufwändigen Operationen nur geringfügig ansteigt, dass dies aber einen deutlichen Einfluss auf die Serverleistung hat. ExMon meldet diese Benutzer mit einem relativ starken Einfluss auf die CPU, ohne dass sie notwendigerweise eine hohe Anzahl von MAPI-Operationen durchgeführt haben.

Beachten Sie auch, dass die Wartezeiten für MAPI-Onlineoperationen zunehmen, wenn es einen Ressourcenengpass (im Allgemeinen einen Datenträger- oder CPU-Engpass) gibt. Ermitteln Sie Engpässe bei Serverressourcen, und erhöhen Sie entweder die Serverressourcenkapazität, oder verschieben Sie Benutzer auf weniger ausgelastete Server.

Weitere Informationen

Weitere Informationen finden Sie in den folgenden Ressourcen zu Exchange Server:

  • Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Behandlung von Leistungsproblemen bei Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Exchange Server 2003 Performance: 10 Things to Think About (http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft Knowledge Base-Artikel 905803, "Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Lange dauernde MAPI-Operation
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-11-22

Das Tool Microsoft® Exchange Server Analyzer verwendet das Tool Exchange Server User Monitor (ExMon), um zu bestimmen, ob MAPI-Benutzeroperationen länger dauern, als auf einem stabilen Server mit Exchange erwartet werden sollte.

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere MAPI-Operationen eines Benutzers länger als 30 Sekunden gedauert haben, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Eine Zunahme der Anzahl von Ansichten für jeden Ordner kann viele MAPI-Operationen ebenfalls mit zusätzlichem Verarbeitungsaufwand belasten. Die beiden gängigsten Operationen, SeekRow und FindRow, werden in diesem Thema behandelt. Andere MAPI-Operationen, die von Exchange Server Analyzer als "lange dauernd" bestimmt werden, können in der Regel mithilfe derselben Aktionen wie die MAPI-Operationen SeekRow und FindRow aufgelöst werden.

Clientanwendungen verschieben mithilfe der MAPI-Operationen SeekRow oder FindRow den Cursor zwischen Zeilen in einer Ansicht. SeekRow gibt an, um wie viele Zeilen der Cursor verschoben werden soll, und ist in Bezug auf die CPU-Zeit sehr wenig aufwändig. FindRow ist sehr aufwändig, weil damit der Cursor zum ersten Element in einer nicht materialisierten (nicht zwischengespeicherten) Ansicht verschoben wird, die die Beschränkungskriterien erfüllt. Anschließend wird die Ansicht verworfen, nachdem die Clientanwendung den Vorgang abgeschlossen hat. Der letztliche CPU-Verarbeitungsaufwand von FindRow hängt von der Komplexität der Beschränkung, der Anzahl der Nachrichteneigenschaften, auf die für jede Nachricht zugegriffen wird, und der Anzahl der Zeilen ab, die der Informationsspeicher überprüfen muss, bis er das erste den Kriterien entsprechende Element findet. Auf diese Weise sind sie lose mit der Anzahl der Elemente im Ordner korreliert.

MAPI-Operationen, die länger als 30 Sekunden dauern, sind nicht unbedingt immer problematisch. Wenn bei den ermittelten Benutzern häufig Verzögerungen bzw. Verzögerungen auftreten, die sich negativ auf die Messagingumgebung auswirken, sollten Sie die Gründe kennen. Arbeiten Sie mit dem Benutzer zusammen, bei dem lange Verzögerungen auftreten, um Folgendes zu bestimmen:

  • Ist die Anzahl der Elemente in Ordnern hoch?

  • Welche Anwendungen führt der Benutzer aus?

So beheben Sie dieses Problem

  • Bitten Sie Benutzer mit zahlreichen Elementen in ihren Ordnern, die Anzahl der Elemente pro Ordner zu reduzieren. Es wird empfohlen, dass Sie weniger als 5000 Elemente in den Ordnern Posteingang, Kalender, Gesendete Elemente, Kalender und Gelöschte Elemente speichern.

  • Konfigurieren Sie die Clientcomputer, deren Betrieb am aufwändigsten ist (insbesondere diejenigen mit langen Wartezeiten bei den Vorgängen Restrict, SetColumns oder FindRow), für die Verwendung im Exchange-Cachemodus. Im Exchange-Cachemodus wird der Server von nahezu allem überschüssigen RPC-Datenverkehr isoliert.

  • Deaktivieren Sie sämtliche Anwendungen, und aktivieren Sie sie anschließend einzeln nacheinander, um die Anwendung zu bestimmen, die das Problem ggf. verursacht. Wenn diese Anwendungen für Ihre geschäftlichen Zwecke nicht erforderlich sind oder es für die Anwendungen einen veröffentlichten Hotfix gibt, deaktivieren Sie die Anwendungen, oder aktualisieren Sie sie, um die Verarbeitungslast auf ein angemesseneres Niveau abzusenken.

Hinweis:
Manche Anwendungen können die Serverlast deutlich erhöhen, ohne eine große Anzahl von MAPI-Operationen zu verursachen. Dies liegt daran, dass manche Operationen aufwändiger als andere sind. Es kann zwar sein, dass die Anzahl der aufwändigen Operationen nur geringfügig ansteigt, dass dies aber einen deutlichen Einfluss auf die Serverleistung hat. ExMon meldet diese Benutzer mit einem starken Einfluss auf die CPU, ohne dass sie notwendigerweise eine hohe Anzahl von MAPI-Operationen durchgeführt haben.

Beachten Sie auch, dass die Wartezeiten für MAPI-Operationen zunehmen, wenn es einen Ressourcenengpass (im Allgemeinen einen Datenträger- oder CPU-Engpass) gibt. Ermitteln Sie Engpässe bei Serverressourcen, und erhöhen Sie entweder die Serverressourcenkapazität, oder verschieben Sie Benutzer auf weniger ausgelastete Server.

Weitere Informationen

Weitere Informationen finden Sie in den folgenden Ressourcen zu Exchange Server:

  • Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Behandlung von Leistungsproblemen bei Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Exchange Server 2003 Performance: 10 Things to Think About (http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft Knowledge Base-Artikel 905803, "Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Lange dauernde MAPI-Operation "SaveChangesMessage"
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-11-22

Das Tool Microsoft® Exchange Server Analyzer verwendet das Tool Exchange Server User Monitor (ExMon), um zu bestimmen, ob MAPI-Benutzeroperationen länger dauern, als auf einem stabilen Server mit Exchange erwartet werden sollte.

Im Rahmen dieser Analyse überprüft Exchange Server Analyzer die ExMon-Daten auf von Benutzern ausgelöste MAPI-Operationen vom Typ SaveChangesMessage, die länger als 30 Sekunden gedauert haben.

Die MAPI-Operation SaveChangesMessage wird aufgerufen, wenn eine Anwendung den Inhalt und/oder die Eigenschaften einer Nachricht auf dem Server speichert. Die Dauer dieser Operation hängt von den zu schreibenden Daten, der Geschwindigkeit der Datenbank- und Transaktionsprotokoll-Datenträger, auf die geschrieben wird, und davon ab, ob ein Ressourcenengpass vorliegt.

Wenn Exchange Server Analyzer feststellt, dass eine von einem Benutzer ausgelöste MAPI-Operation vom Typ SaveChangesMessage länger als 30 Sekunden gedauert hat, zeigt Exchange Server Analyzer eine Fehlermeldung an.

MAPI-Operationen vom Typ SaveChangesMessage, die länger als 30 Sekunden dauern, sind nicht unbedingt immer problematisch. Das Speichern großer Mengen von Nachrichtendaten oder Dateianlagen kann beispielsweise dazu führen, dass MAPI-Operationen vom Typ SaveChangesMessage länger als normal dauern. Wenn bei den Benutzern häufig Verzögerungen bzw. Verzögerungen auftreten, die sich negativ auf die Messagingumgebung auswirken, ist die wahrscheinlichste Ursache ein Datenträgerengpass.

Weitere Informationen

  • Weitere Informationen zu Leistungsengpässen bei Datenträgern finden Sie unter Datenträgerengpass wurde festgestellt.

  • Weitere Informationen zur Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen zu den bewährten Methoden für das Entwerfen von Speicherarchitekturen finden Sie unter Bewährte Methoden für mehrere Architekturen (http://go.microsoft.com/fwlink/?LinkId=72988).

  • Weitere Informationen zum Verschieben von Benutzerpostfächern zur Verringerung der Serverlast finden Sie unter Verschieben von Benutzerpostfächern auf einen anderen Server.

  • Weitere Informationen zu Datenträgerbemessung, Wartezeiten und -E/A-Raten finden Sie in den folgenden Blogs auf der Microsoft Exchange Team-Blog-Website:

    • „A few basic concepts in disk sizing" (http://go.microsoft.com/fwlink/?linkid=39538)

    • "Some more thoughts on disk IO and calculations…." (http://go.microsoft.com/fwlink/?linkid=23456)

    • Berechnung der Anforderungen an die Datenträger-E/A (http://go.microsoft.com/fwlink/?linkid=69747)


Lange dauernde MAPI-Operation "SetColumns"
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-23

Das Tool Microsoft® Exchange Server Analyzer verwendet das Tool Exchange Server User Monitor (ExMon), um zu bestimmen, ob MAPI-Benutzeroperationen länger dauern, als auf einem stabilen Server erwartet werden sollte, auf dem Exchange Server ausgeführt wird.

Im Rahmen dieser Analyse überprüft Exchange Server Analyzer die ExMon-Daten auf von Benutzern ausgelöste MAPI-Operationen vom Typ SetColumns, die länger als 30 Sekunden gedauert haben.

Über den MAPI-Aufruf SetColumns wird eine Basisansicht erstellt. Der Aufruf von SetColumns bestimmt die Eigenschaften, die in der neuen Ansichtstabelle als Spalten angezeigt werden.

Beim erstmaligen Anfordern einer Eigenschaft in einer Ansicht muss der Server zusätzliche Aufgaben ausführen, um die Ansicht zu generieren. Nachdem eine bestimmte Eigenschaft in einer Ansicht angefordert wurde, ist sie für künftige Ansichten stets vorhanden. Dies bedeutet, dass beim ersten Anfordern neuer Eigenschaften der Aufruf von SetColumns wesentlich längern dauern kann. Die erforderliche Zeit ist proportional zur Anzahl neuer Eigenschaften und der Anzahl der Elemente im Ordner. Beispiel: Wenn ein Benutzer seinen Posteingang nach einer Postfachverschiebung erstmals anzeigt, benötigt der Server zur Generierung der Ansicht mehr Zeit. Dies liegt daran, dass Ansichten bei einer Postfachverschiebung nicht verschoben, sondern neu erstellt werden.

Allgemein ist es sehr verarbeitungsaufwändig, der Ansicht Eigenschaften hinzuzufügen. Der Verarbeitungsaufwand für das Hinzufügen von Eigenschaften ist proportional zur Anzahl der Elemente im Ordner und zur Anzahl der hinzugefügten Eigenschaften. In der Regel führt die Nutzung von Microsoft Office® Outlook® nicht zum Hinzufügen vieler Eigenschaften zur Nachrichtenordnertabelle. Weitere Eigenschaften können jedoch manuell hinzugefügt werden. Dies ist nicht generell ein Problem. Es kann jedoch zu Verzögerungen kommen, wenn eine Anwendung Spalten regelmäßig hinzufügt, viele Spalten hinzufügt oder ein beliebiger Client mehrere Spalten für zahlreiche Elemente hinzufügt. Je mehr Spalten die Nachrichtenordnertabelle enthält, desto höher ist der Verarbeitungsaufwand für alle anderen Aktionen, die auf Elemente in dem jeweiligen Ordner angewendet werden. Nachdem eine Spalte hinzugefügt wurde, kann sie nicht mehr entfernt werden. Jede Eigenschaft in der Tabelle Message-Folder erhöht den Verarbeitungsaufwand beim Einfügen von Elementen in den jeweiligen Ordner.

Wenn Exchange Server Analyzer feststellt, dass eine von einem Benutzer ausgelöste MAPI-Operation vom Typ SetColumns länger als 30 Sekunden gedauert hat, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Wenn ein Benutzer erstmals auf sein Postfach zugreift, nachdem es in eine neue Datenbank oder auf einen neuen Server verschoben wurde, muss der Server neue Ansichten erstellen. In diesem Fall ist zu erwarten, dass der Aufruf von SetColumns und Restrict lange dauert. Sie können diese Fehlermeldungen mehrere Tage nach dem Verschieben eines Postfachs bedenkenlos ignorieren.

Einige Anwendungen erstellen neue Ansichten und bewirken, dass Eigenschaften zu internen Informationsspeicherdaten heraufgestuft werden. Dies kann sich langfristig negativ auf die Leistung des Servers auswirken, wenn der Server auf Daten des jeweiligen Benutzers zugreift. Wenn bei den ermittelten Benutzern häufig Verzögerungen bzw. Verzögerungen auftreten, die sich negativ auf die Messagingumgebung auswirken, sollten Sie die Gründe kennen. Arbeiten Sie mit dem Benutzer zusammen, bei dem lange Verzögerungen auftreten, um Folgendes zu bestimmen:

  • Ist die Anzahl der Elemente in Ordnern hoch?

  • Welche Anwendungen führt der Benutzer aus?

Führen Sie zum Beheben des Problems die folgenden Schritte durch:

  • Bitten Sie Benutzer mit zahlreichen Elementen in ihren Ordnern, die Anzahl der Elemente pro Ordner zu reduzieren. Es wird empfohlen, dass Sie weniger als 5000 Elemente in den Ordnern Posteingang, Kalender, Gesendete Elemente, Kalender und Gelöschte Elemente speichern.

  • Konfigurieren Sie die Clientcomputer mit dem betriebsbedingten höchsten Verarbeitungsaufwand für den Exchange-Cachemodus. Beachten Sie besonders Clientcomputer mit langen Wartezeiten bei den Operationen Restrict, SetColumns und FindRow. Im Exchange-Cachemodus wird der Server von nahezu allem überschüssigen RPC-Datenverkehr isoliert.

  • Deaktivieren Sie alle Anwendungen. Aktivieren Sie diese anschließend nacheinander, um herauszufinden, welche das Problem verursacht. Deaktivieren Sie problematische Anwendungen dauerhaft, oder aktualisieren Sie sie, um die Verarbeitungslast auf einen angemessenen Grad zu reduzieren, wenn eine der folgenden Bedingungen vorliegt:

    • Die Anwendung ist für das Unternehmen nicht erforderlich.

    • Für die Anwendung gibt es eine verfügbare Aktualisierung.

Hinweis:
Manche Anwendungen können die Serverlast deutlich erhöhen, ohne eine große Anzahl von MAPI-Operationen zu verursachen. Dies liegt daran, dass manche Operationen aufwändiger als andere sind. Es kann zwar sein, dass die Anzahl der aufwändigen Operationen nur geringfügig ansteigt, dass dies aber einen deutlichen Einfluss auf die Serverleistung hat. ExMon meldet Benutzer mit einem starken Einfluss auf die CPU, ohne dass sie notwendigerweise eine hohe Anzahl von MAPI-Operationen durchgeführt haben.

Beachten Sie auch, dass die Wartezeiten für MAPI-Operationen vom Typ SetColumns zunehmen, wenn es einen Ressourcenengpass (im Allgemeinen einen Datenträger- oder CPU-Engpass) gibt.

Weitere Informationen

Weitere Informationen finden Sie in den folgenden Ressourcen zu Exchange Server:

  • Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Exchange Server 2003 Performance: 10 Things to Think About (http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft Knowledge Base-Artikel 905803, "Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Lange dauernde MAPI-Synchronsierungsoperation
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-23

Das Tool Microsoft® Exchange Server Analyzer verwendet das Tool Exchange Server User Monitor (ExMon), um zu bestimmen, ob MAPI-Benutzeroperationen länger dauern, als auf einem stabilen Server mit Exchange erwartet werden sollte.

Im Rahmen dieser Analyse überprüft Exchange Server Analyzer die ExMon-Daten auf von Benutzern ausgelöste MAPI-Synchronisierungsoperationen, die länger als 30 Sekunden gedauert haben.

MAPI-Synchronisierungsoperationen erfolgen, um die Microsoft Office® Outlook® Offlineordnerdatei (.ost) bzw. lokale Kopie des Benutzerpostfachs mit den Postfachdaten des Benutzers auf dem Server synchron zu halten.

MAPI-Synchronisierungsoperationen, die länger als 30 Sekunden dauern, sind nicht unbedingt immer problematisch. Standardmäßig werden sämtliche E-Mail-Nachrichten auf dem Computer mit Exchange Server gespeichert und vollständige Kopien der globalen Adressenliste auf den Computer des Benutzers heruntergeladen, wenn der Exchange-Cachemodus erstmals in Outlook 2003 aktiviert wird.

Bei der ersten Synchronisierung mit dem Computer mit Exchange Server können für Outlook 2003-Benutzer Wartezeiten auftreten.

Wenn bei dem Benutzer oder den Benutzern häufig Verzögerungen bzw. Verzögerungen im Anschluss an die Auslösung der Synchronisierung für den Cachemodus auftreten, die sich negativ auf die Messagingumgebung auswirken, sollten diese MAPI-Synchronisierungsoperationen weiter untersucht werden, um sicherzustellen, dass sie nicht symptomatisch für ernstere Wartezeitenprobleme sind, z. B. Ressourcenengpässe.

Beachten Sie, dass die Wartezeiten für MAPI-Synchronisierungsoperationen zunehmen, wenn es einen Ressourcenengpass (im Allgemeinen einen Datenträger- oder CPU-Engpass) gibt. Ermitteln Sie Engpässe bei Serverressourcen, und erhöhen Sie entweder die Serverressourcenkapazität, oder verschieben Sie Benutzer auf weniger ausgelastete Server.

Weitere Informationen

Weitere Informationen finden Sie in den folgenden Ressourcen zu Exchange Server:

  • Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Behandlung von Leistungsproblemen bei Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Exchange Server 2003 Performance: 10 Things to Think About (http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft Knowledge Base-Artikel 905803 "Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Lange dauernde MAPI-Operation "TaskQ"
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-02-20

Microsoft Exchange Analyzer verwendet das Tool Exchange Server User Monitor (ExMon), um zu bestimmen, ob MAPI-Benutzeroperationen länger dauern, als auf einem stabilen Server mit Exchange zu erwarten ist.

Im Rahmen dieser Analyse überprüft Exchange Analyzer die ExMon-Daten auf von Benutzern ausgelöste MAPI-Operationen vom Typ TaskQ, die länger als 30 Sekunden gedauert haben.

TaskQ-Operationen sind asynchrone Tasks, die außerhalb des Kontexts eines RPC-Aufrufs ausgeführt werden. TaskQ und TaskQ User Unknown-Operationen sind Tasks, die auf Anforderung von Exchange ausgeführt werden, z. B. Speicherwartung. TaskQ User Known-Operationen sind asynchrone Tasks, die durch eine direkte Benutzeranfrage initiiert werden. Dabei handelt es sich beispielsweise um das Auffüllen von Suchordnern, Sortiervorgänge und Massenoperationen wie das gleichzeitige Verschieben, Kopieren, Löschen oder Kennzeichnen mehrerer Nachrichten als gelesen.

Wenn Exchange Analyzer feststellt, dass eine von einem Benutzer ausgelöste MAPI-Operation vom Typ TaskQ länger als 30 Sekunden gedauert hat, wird eine Fehlermeldung angezeigt.

Dies muss nicht immer auf ein Leistungsproblem hinweisen, weil es sich bei TaskQ-Operationen typischerweise um Ausgaben handelt, deren Ausführung längere Zeit in Anspruch nehmen kann.

Um dieses Problem zu beheben, führen Sie folgende Schritte aus:

  • Mit dem Tool ExMon können Sie eine größere Beispieldatenmenge erfassen, um sie von Exchange Server Analyzer untersuchen zu lassen. Aufgrund des großen von ExMon generierten Datenvolumens wird empfohlen, die Erfassung der Beispieldatenmenge auf maximal 30 Minuten zu beschränken.

Weitere Informationen

Weitere Informationen finden Sie in den folgenden Ressourcen zu Exchange Server:

  • Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Behandlung von Leistungsproblemen bei Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Exchange Server 2003 Performance: 10 Things to Think About (http://go.microsoft.com/fwlink/?LinkId=56460)


Lang laufende Operation aufgrund der MAPI-Operation "Restrict"
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-23

Das Tool Microsoft® Exchange Server Analyzer verwendet das Tool Exchange Server User Monitor (ExMon), um zu bestimmen, ob MAPI-Benutzeroperationen länger dauern, als auf einem stabilen Server erwartet werden sollte, auf dem Exchange Server ausgeführt wird.

Im Rahmen dieser Analyse überprüft Exchange Server Analyzer die ExMon-Daten auf von Benutzern ausgelöste MAPI-Operationen vom Typ Restrict, die länger als 30 Sekunden gedauert haben.

Die MAPI-Operation Restrict wird von Clientanwendungen verwendet, um Elemente auszuwählen, die bestimmten Kriterien entsprechen. Der Server erstellt eine Ansicht (eine Tabelle mit zugehörigen Kriterien), die als Einschränkung bezeichnet wird. Wenn es die Ansicht mit einer passenden Einschränkung bereits gibt, verwendet der Server die vorhandene Ansicht, um die Benutzeranforderung zu erfüllen. Wenn der Server diese Ansicht verwendet, ist dieser Vorgang weniger verarbeitungsaufwändig, als wenn der Server eine neue Ansicht erstellt. In der Standardeinstellung werden im Speicher nur 11 Ansichten pro Ordner zwischengespeichert. Wenn der Server aufgefordert wird, eine zwöfte Ansicht zu erstellen, löscht er die älteste Ansicht aus dem Zwischenspeicher und erstellt eine neue. Ansicht erhöhen den Verarbeitungsaufwand aller Aktionen, die auf Elemente angewendet werden.

Wenn Exchange Server Analyzer feststellt, dass eine von einem Benutzer ausgelöste MAPI-Operation vom Typ Restrict länger als 30 Sekunden gedauert hat, zeigt Exchange Server Analyzer eine Fehlermeldung an.

MAPI-Operationen vom Restrict, die länger als 30 Sekunden dauern, sind nicht immer unbedingt problematisch. Wenn bei dem Benutzer oder den Benutzern häufig Verzögerungen bzw. Verzögerungen auftreten, die sich negativ auf die Messagingumgebung auswirken, kann dies ein Hinweis darauf sein, dass eine Benutzeranwendung für die Erstellung neuer Ansichten sorgt.

Um dieses Problem zu beheben, arbeiten Sie mit dem Benutzer zusammen, bei dem lange Wartezeiten auftreten, um Folgendes zu ermitteln:

  • Ist die Anzahl der Elemente in Ordnern hoch?

  • Welche Anwendungen führt der Benutzer aus?

Führen Sie zum Beheben des Problems die folgenden Schritte durch:

  • Bitten Sie Benutzer mit zahlreichen Elementen in ihren Ordnern, die Anzahl der Elemente pro Ordner zu reduzieren. Es wird empfohlen, dass Sie weniger als 5000 Elemente in den Ordnern Posteingang, Kalender, Gesendete Elemente, Kalender und Gelöschte Elemente speichern.

  • Konfigurieren Sie die Clientcomputer mit dem betriebsbedingten höchsten Verarbeitungsaufwand für den Exchange-Cachemodus. Beachten Sie besonders Clientcomputer mit langen Wartezeiten bei den Operationen Restrict, SetColumns und FindRow. Im Exchange-Cachemodus wird der Server von nahezu allem überschüssigen RPC-Datenverkehr isoliert.

  • Befolgen Sie die Anleitungen im Exchange Team Blog (siehe den folgenden Abschnitt), um die Nachverfolgung im Ereignisprotokoll auf Einschränkungen zu aktivieren. Aktivieren Sie anschließend nacheinander die Benutzeranwendungen, um nachzuverfolgen, welche Anwendung die lang dauernde Einschränkung bewirkt.

  • Deaktivieren Sie alle Anwendungen. Aktivieren Sie diese anschließend nacheinander, um herauszufinden, welche das Problem verursacht. Deaktivieren Sie problematische Anwendungen dauerhaft, oder aktualisieren Sie sie, um die Verarbeitungslast auf einen angemessenen Grad zu reduzieren, wenn eine der folgenden Bedingungen vorliegt:

    • Die Anwendung ist für das Unternehmen nicht erforderlich.

    • Für die Anwendung gibt es eine verfügbare Aktualisierung.

Hinweis:
Manche Anwendungen können die Serverlast deutlich erhöhen, ohne eine große Anzahl von MAPI-Operationen zu verursachen. Dies liegt daran, dass manche Operationen aufwändiger als andere sind. Es kann zwar sein, dass die Anzahl der aufwändigen Operationen nur geringfügig ansteigt, dass dies aber einen deutlichen Einfluss auf die Serverleistung hat. ExMon meldet Benutzer mit einem starken Einfluss auf die CPU, ohne dass sie notwendigerweise eine hohe Anzahl von MAPI-Operationen durchgeführt haben.

Beachten Sie auch, dass die Wartezeiten für MAPI-Operationen vom Typ Restrict zunehmen, wenn es einen Ressourcenengpass (im Allgemeinen einen Datenträger- oder CPU-Engpass) gibt.

Weitere Informationen

Weitere Informationen zu MAPI-Operationen vom Typ Restrict finden Sie im Blog des Microsoft Exchange Teams unter „Putting the Restrictions on Restrictions" (http://go.microsoft.com/fwlink/?linkid=55098).

Hinweis:
Der Inhalt jedes Blogs und die dazugehörige URL kann ohne vorherige Ankündigung geändert werden.

Weitere Informationen finden Sie in den folgenden Ressourcen zu Exchange Server:

  • Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Exchange Server 2003 Performance: 10 Things to Think About (http://go.microsoft.com/fwlink/?LinkId=56460)

  • Microsoft Knowledge Base-Artikel 905803, "Outlook users experience poor performance when they work with a folder that contains many items on a server that is running Exchange Server 2003 or Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Datei „MAD.EXE" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft sowohl im Ordner System32 als auch im Ordner \Exchsrvr\bin)

  • Mapi32.dll (überprüft sowohl im Ordner System32 als auch im Ordner \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


MAD NSPI-Anschlussnummer liegt unter 5000
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Einstellung TCP/IP NSPI Port für den Microsoft Exchange-Systemaufsichtsdienst zu ermitteln:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

Wenn Exchange Server Analyzer feststellt, dass der Wert für TCP/IP NSPI Port auf einen Wert unter 5000 (Dezimalwert) festgelegt ist, wird eine Warnung angezeigt.

Wenn Sie TCP/IP NSPI Port auf einen statischen Wert festlegen müssen, empfiehlt es sich, diesen auf einen Wert festzulegen, der etwas höher als 5000 ist. Das Zuweisen von statischen Anschlussnummern unter 5000 kann zu einem Anschlusskonflikt mit einem anderen Prozess und zu einem Fehler beim Prozess des Exchange-Systemaufsichtsdiensts führen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den Registrierungsschlüssel für den TCP/IP-NSPI-Anschluss fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Doppelklicken Sie auf den Schlüssel TCP/IP NSPI Port, und legen Sie im Feld Datenwerte eine ganze Zahl fest, die etwas größer als 5000 (Dezimalwert) ist.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den Microsoft Exchange-Systemaufsichtsdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen über Anschlussbeschränkungen finden Sie im Knowledge Base-Artikel 194952, „XADM: Statically Mapped Port Limitations for Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952).


Der MAD RFR-Anschluss wurde manuell überschrieben
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob der Verzeichnisverweisanschluss für die Microsoft Exchange-Systemaufsicht manuell überschrieben wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

Wenn Exchange Server Analyzer erkennt, dass der TCP/IP Port vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Dieser Wert wird in den meisten Fällen konfiguriert, um MAPI-Clients das Herstellen einer Verbindung mit einem Exchange-Server zu ermöglichen, der sich auf der anderen Seite einer Firewall befindet. Hierfür müssen mehrere Ports einer Firewall geöffnet werden, damit Microsoft Office Outlook® 2003-Clients mithilfe von MAPI (in der Regel über das Internet) eine Verbindung mit einem Exchange-Server herstellen können. Diese Konfiguration wird unterstützt. Weitere Informationen zum Konfigurieren von MAPI-Clients zum Herstellen einer Verbindung mit Exchange über eine Firewall finden Sie im Microsoft Knowledge Base-Artikel 270836, „Statische Anschlusszuordnungen in Exchange 2000 und Exchange 2003" (http://support.microsoft.com/default.aspx?scid=kb;de;270836). Wenn Sie dieses Szenario nicht verwenden, sollten Sie den Registrierungsschlüssel entfernen.

Für die Verwendung von Outlook im MAPI-Modus zum Herstellen einer Verbindung mit einem Exchange-Server über das Internet wird der Einsatz der Funktionen von RPC-über-HTTP (Remote Procedure Call over Hypertext Transfer Protocol) in Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003 und Windows® XP Professional empfohlen. Der MAPI-Modus wurde früher als „Firmenmodus" oder „Arbeitsgruppenmodus" bezeichnet.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So entfernen Sie den Registrierungswert für den TCP/IP-Anschluss

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Löschen Sie den Registrierungswert TCP/IP Port.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Systemaufsichtdienst erneut.

So stellen Sie RPC-über-HTTPS bereit

  1. Lesen Sie Exchange Server 2003 RPC over HTTP Deployment Scenarios unter http://go.microsoft.com/fwlink/?linkid=47577.

  2. Lesen Sie den Knowledge Base-Artikel 833401, „Konfigurieren von RPC-über-HTTP auf einem einzelnen Server in Exchange Server 2003"(http://support.microsoft.com/default.aspx?scid=kb;de;833401).

  3. Lesen Sie den Knowledge Base-Artikel 827330, „Behandlung von Problemen bei RPC-über-HTTP-Clientverbindungen in Office Outlook 2003"unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  4. Lesen Sie den Microsoft Support WebCast „Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unterhttp://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


MAD RFR-Anschlussnummer liegt unter 5000
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Einstellung TCP/IP Port für den Microsoft Exchange-Systemaufsichtsdienst zu ermitteln:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

Wenn Exchange Server Analyzer feststellt, dass der Wert für TCP/IP Port auf einen Wert unter 5000 (Dezimalwert) festgelegt ist, wird eine Warnung angezeigt.

Wenn Sie den TCP/IP Port auf einen statischen Wert festlegen müssen, empfiehlt es sich, diesen auf einen Wert festzulegen, der etwas höher als 5000 ist. Das Zuweisen von statischen Anschlussnummern unter 5000 kann ein zu einem Anschlusskonflikt mit einem anderen Vorgang und zu einem Fehler beim Prozess des Microsoft Exchange-Systemaufsichtsdiensts führen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den Registrierungsschlüssel für den TCP/IP-Anschluss fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Doppelklicken Sie auf den Schlüssel TCP/IP Port, und legen Sie im Feld Datenwerte eine ganze Zahl fest, die etwas größer als 5000 (Dezimalwert) ist.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den Microsoft Exchange-Systemaufsichtsdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen über Anschlusseinstellungen finden Sie im Knowledge Base-Artikel 194952, „XADM: Statically Mapped Port Limitations for Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952).


Datei „MAPI32.DLL" befindet sich nicht im Ordner „bin"
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Die Datei „MAPI32.DLL" befindet sich nicht im Ordner „system32"
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Datei „MAPISTUB.DLL" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft sowohl im Ordner System32 als auch im Ordner \Exchsrvr\bin)

  • Mapi32.dll (überprüft sowohl im Ordner System32 als auch im Ordner \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Datei „MAPISP32.EXE" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Beim Ausführen von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Die maximale ESE-Cachegröße übersteigt 1,2 GB
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-02-13

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem DataBase Cache Size (DBCacheSize)-Leistungsindikator des DataBase-Leistungsobjekts.

Der Leistungsindikator DataBase Cache Size (DBCacheSize) gibt die aktuell vom Informationsspeicher verwendete Cachegröße an. Wenn Exchange Server Analyzer feststellt, dass der Wert des Leistungsindikators DataBase Cache Size (DBCacheSize) größer als 307200 (1,2 GB) ist, wird ein Fehler angezeigt.

Dieser Fehler zeigt an, dass der Wert des msExchESEParamCacheSizeMax-Attributs für das Microsoft Exchange-Informationsspeicherobjekt (MSExchangeIS) auf einen Wert festgelegt wurde, der den empfohlene Höchstwert von 307200 (1,2 GB) übersteigt.

Der Informationsspeicher-Datenbankcache wird auch als ESE-Puffer (Extensible Storage Engine) bezeichnet. In ihm werden Datenbanktransaktionen zwischengespeichert, bevor sie an die Datenbank übergeben werden.

Bei Exchange 2000 Server wird ein Großteil des von Store.exe verwendeten virtuellen Speichers dem ESE-Puffer zugewiesen. Exchange 2000 Server verwendet fu¨r diesen Puffer einen hartcodierten Standardwert von 858 MB. Bei Exchange Server 2003 richtet sich die ESE-Pufferzuweisung nach dem Vorhandensein des Schalters /3GB in der Datei Boot.ini. Wenn der Schalter /3GB vorhanden ist, wird der ESE-Puffer auf 896 MB festgelegt. Andernfalls wird der ESE-Puffer auf 576 MB festgelegt. Obwohl eine automatische Feinabstimmung grundsätzlich nützlich ist, mo¨chten Sie jedoch möglicherweise den automatisch festgelegten Wert u¨berschreiben und einen fu¨r Ihre Umgebung besser geeigneten Wert manuell festlegen.

Sie ko¨nnen diesen Wert, der dem tatsächlich zugewiesenen Speicher entspricht, zwar auf ein beliebiges Vielfaches von 8192 Bytes festlegen, es wird jedoch empfohlen, nur einen der Werte aus der folgenden Tabelle zu verwenden.

Empfohlener Wert | Zugewiesener Speicher | Kommentare
147456 | 576 MB | Dies ist der empfohlene Mindestwert. Legen Sie den Wert nicht darunter fest. Dieser Wert eignet sich fu¨r Server mit eingeschra¨nktem virtuellen Speicher und fu¨r Exchange Server 2003-Computer, die unter Microsoft Windows® 2000 Server ausgefu¨hrt werden. In dieser Konfiguration wird der Schalter /3GB nicht unterstützt. Dies ist auch der Standardwert fu¨r Systeme, die den Schalter /3GB nicht verwenden.
196608 | 768 MB | Dieser Wert wird fu¨r Server mit großem virtuellen Speicherplatz empfohlen, die ha¨ufig das Ereignis 9582 protokollieren.
219726 | 858 MB | Dies ist der Standardwert für Exchange 2000 Server. Dieser Wert ist darüber hinaus gut für Systeme geeignet, die im laufenden Betrieb aktualisiert werden und über großen virtuellen Speicherplatz verfügen.
229376 | 896 MB | Dies ist der Standardwert fu¨r Exchange Server 2003. Dieser Wert ist daru¨ber hinaus auch gut fu¨r neue Systeme geeignet, sofern das Ereignisprotokoll der Anwendung keine anderen Vorgaben macht, z. B. bei vorhandenen Ereignissen vom Typ 9582.
307200 | 1,2 GB | Dies ist der ho¨chste Wert, der festgelegt werden kann. Dieser Wert wird nur fu¨r Systeme mit mindestens 2 GB physischem Speicher empfohlen.

Vor dem Neukonfigurieren dieses Werts empfiehlt es sich, den vom Prozess Store.exe belegten virtuellen Speicherplatz zu u¨berwachen. U¨berwachen Sie hierzu unter Microsoft Windows das Leistungsobjekt Process. Bei Systemen mit dem Schalter /3GB sollte der Leistungsindikator Virtual Bytes für die Store.exe-Instanz des Process-Objekts unter 2,8 GB liegen. Bei Systemen ohne den Schalter /3GB sollte der Leistungsindikator Virtual Bytes für die Store.exe-Instanz des Process-Objekts unter 1,8 GB liegen. Wenn die Werte u¨ber diesen Betra¨gen liegen, muss mo¨glicherweise der Wert fu¨r msExchESEParamCacheSizeMax verringert werden. Wenn die Werte darunter liegen, muss mo¨glicherweise der Wert fu¨r msExchESEParamCacheSizeMax erho¨ht werden.

Achtung:
Wenn Sie bei der Verwendung des ADSI-Bearbeitung-Snap-Ins (Active Directory Service Interfaces), des LDP-Tools (ldp.exe) oder eines anderen LDAP-Clients (Lightweight Directory Access Protocol), Version 3, die Attribute der Active Directory®-Objekte fehlerhaft ändern, können schwer wiegende Probleme verursacht werden. Diese Probleme erfordern mo¨glicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie a¨ndern Active Directory-Objektattribute auf eigenes Risiko.
So nehmen Sie die Feinabstimmung fu¨r das Attribut „msExchESEParamCacheSizeMax" vor

  1. O¨ffnen Sie einen Active Directory-Editor, z. B. die ADSI-Bearbeitung.

  2. Doppelklicken Sie auf den Container Konfiguration.

  3. Erweitern Sie CN=Services.

  4. Erweitern Sie CN=Microsoft Exchange.

  5. Erweitern Sie CN=<Name der Exchange-Organisation>.

  6. Erweitern Sie CN=Administrative Groups.

  7. Erweitern Sie CN=<Name der administrativen Gruppe>.

  8. Erweitern Sie CN=Servers.

  9. Erweitern Sie CN=<Name des Exchange-Servers>.

  10. Klicken Sie mit der rechten Maustaste auf CN=InformationStore, und klicken Sie dann auf Eigenschaften.

  11. Fu¨hren Sie im Feld Attribute einen Bildlauf zu msExchESEParamCacheSizeMax aus, und doppelklicken Sie darauf.

  12. Geben Sie im Feld Wert den gewu¨nschten Wert ein. Bestimmen Sie anhand der Tabelle den optimalen Wert fu¨r das von Ihnen verwendete System.

  13. Klicken Sie zuerst auf OK und anschließend erneut auf OK.

  14. Schließen Sie den Active Directory-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Weitere Informationen zum Optimieren der Speichernutzung finden Sie unter „Optimizing Memory Usage for Exchange Server 2003" im Handbuch Planning a Microsoft Exchange Server 2003 Messaging System (http://go.microsoft.com/fwlink/?LinkId=47584).

Weitere Informationen über das Attribut msExchESEParamCacheSizeMax finden Sie im Microsoft Knowledge Base-Artikel 266768, „Ändern der maximalen Store Database Cache-Größe in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768).


Die Empfängerhöchstgrenze wurde geändert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob das Attribut msExchRecipLimit auf einen vom Standard abweichenden Wert festgelegt wurde. Das Attribut msExchRecipLimit speichert den Wert für die globale Höchstanzahl der Empfänger für jede E-Mail-Nachricht. Der Standardwert des Attributs msExchRecipLimit beträgt 5000. Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs msExchRecipLimit ungleich 5000 ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Die globale Empfängerhöchstgrenze gilt für die gesamte Exchange-Organisation. Der Wert des Attributs msExchRecipLimit begrenzt die Anzahl der Empfänger einer einzelnen E-Mail-Nachricht. Die globale Empfängerhöchstgrenze gilt für Systemnachrichten und Nicht-Systemnachrichten. Zu den Systemnachrichten gehören auch Replikationsnachrichten für Öffentliche Ordner.

Hinweis:
Sie können mithilfe von Active Directory-Benutzer und -Computer auch Empfängerbeschränkungen für einzelne Benutzer festlegen. Die Einstellung für einzelne Benutzer hat Vorrang vor der globalen Einstellung und setzt diese außer Kraft. In der Standardeinstellung entspricht die Empfängerbeschränkung für einzelne Benutzer der globalen Empfängerhöchstgrenze.
Hinweis:
Auf einem virtuellen SMTP-Server (Simple Mail Transfer Protocol) können Sie die Anzahl der Empfänger pro Nachricht für Nachrichten begrenzen, die von Internetbenutzern empfangen wurden. Diese Grenze entspricht nicht der globalen Empfängerhöchstgrenze und der Empfängerbeschränkung für einzelne Benutzer. Die globale Empfängerhöchstgrenze und die Empfängerbeschränkung für einzelne Benutzer begrenzen beide die Anzahl der Empfänger, an die ein Exchange-Benutzer eine Nachricht senden kann.
So ändern Sie die globale Empfängerhöchstgrenze in den Standardwert

  1. Starten Sie den Exchange-System-Manager.

  2. Erweitern Sie im linken Bereich Globale Einstellungen.

  3. Klicken Sie mit der rechten Maustaste auf Nachrichtenübermittlung, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf der Registerkarte Standardeinstellungen unter Empfängerbeschränkungen auf Höchstzahl Empfänger, und geben Sie dann 5000 ein.

  5. Starten Sie den Microsoft Exchange-Informationsspeicherdienst erneut.

Weitere Informationen zum Festlegen von Empfängerbeschränkungen und zum Konfigurieren von Microsoft Office Outlook® Web Access-Clients finden Sie im Exchange Server 2003 Message Security Guide (http://go.microsoft.com/fwlink/?LinkId=47574) unter „Outlook Web Access S/MIME Control-Related Settings".

Weitere Informationen zum Verlauf der Empfängerhöchstgrenze finden Sie im Exchange-Weblog-Artikel „Me Too!" unter (http://go.microsoft.com/fwlink/?LinkId=41848).


Die Empfängerhöchstgrenze ist hoch
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob der Wert msExchRecipLimit für Nachrichten größer als 7500 ist. Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs msExchRecipLimit größer als 7500 ist, wird eine Warnung angezeigt.

Das Attribut msExchRecipLimit speichert den Wert für die globale Höchstanzahl der Empfänger für jede E-Mail-Nachricht. Der Wert begrenzt die Anzahl der Empfänger für eine einzelne E-Mail-Nachricht. Der Wert gilt auch für Systemnachrichten und Nicht-Systemnachrichten. Zu den Systemnachrichten gehören auch Replikationsnachrichten für Öffentliche Ordner. Der Standardwert des Attributs msExchRecipLimit beträgt 5000.

Wenn der Wert des Attributs msExchRecipLimit größer als 7500 ist, steigt das Risiko von Problemen, die durch Nachrichten mit vielen Empfängern verursacht werden.

Hinweis:
Sie können mithilfe von Active Directory-Benutzer und -Computer auch Empfängerbeschränkungen für einzelne Benutzer festlegen. Die Einstellung für einzelne Benutzer hat Vorrang vor der globalen Einstellung und setzt diese außer Kraft. In der Standardeinstellung entspricht die Empfängerbeschränkung für einzelne Benutzer der globalen Empfängerhöchstgrenze.
Hinweis:
Auf einem virtuellen SMTP-Server (Simple Mail Transfer Protocol) können Sie die Anzahl der Empfänger pro Nachricht für Nachrichten begrenzen, die von Internetbenutzern empfangen wurden. Diese Grenze entspricht nicht der globalen Empfängerhöchstgrenze und der Empfängerbeschränkung für einzelne Benutzer. Die globale Empfängerhöchstgrenze und die Empfängerbeschränkung für einzelne Benutzer begrenzen beide die Anzahl der Empfänger, an die ein Exchange-Benutzer eine Nachricht senden kann.
So ändern Sie die globale Empfängerhöchstgrenze in den Standardwert

  1. Starten Sie den Exchange-System-Manager.

  2. Erweitern Sie im linken Bereich Globale Einstellungen.

  3. Klicken Sie mit der rechten Maustaste auf Nachrichtenübermittlung, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf der Registerkarte Standardeinstellungen unter Empfängerbeschränkungen auf Höchstzahl Empfänger, und geben Sie dann 5000 ein.

  5. Starten Sie den Microsoft Exchange-Informationsspeicherdienst erneut.

Weitere Informationen zum Festlegen von Empfängerbeschränkungen und zum Konfigurieren von Microsoft Office Outlook® Web Access-Clients finden Sie im Exchange Server 2003 Message Security Guide (http://go.microsoft.com/fwlink/?LinkId=47574) unter „Outlook Web Access S/MIME Control-Related Settings".

Weitere Informationen zum Verlauf der globalen Empfängerhöchstgrenze finden Sie im Exchange-Weblog-Artikel „Me Too!" unter (http://go.microsoft.com/fwlink/?LinkId=41848).


Die Empfängerhöchstgrenze ist zu niedrig
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob der Wert msExchRecipLimit für Nachrichten kleiner ist als die Anzahl der Informationsspeicher für Öffentliche Ordner in der Exchange-Organisation. Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs msExchRecipLimit kleiner ist als die Anzahl der Informationsspeicher für Öffentliche Ordner, zeigt Exchange Server Analyzer einen Fehler an.

Das Attribut msExchRecipLimit speichert den Wert für die globale Höchstanzahl der Empfänger für jede E-Mail-Nachricht. Der Wert begrenzt die Anzahl der Empfänger für eine einzelne E-Mail-Nachricht. Der Wert gilt auch für Systemnachrichten und Nicht-Systemnachrichten. Zu den Systemnachrichten gehören auch Replikationsnachrichten für Öffentliche Ordner. Der Standardwert des Attributs msExchRecipLimit beträgt 5000. Wenn der Wert des Attributs msExchRecipLimit kleiner ist als die Anzahl der Informationsspeicher für Öffentliche Ordner in der Exchange-Organisation, treten bei der Replikation der Öffentlichen Ordner-Hierarchie Probleme auf.

Hinweis:
Sie können mithilfe von Active Directory-Benutzer und -Computer auch Empfängerbeschränkungen für einzelne Benutzer festlegen. Die Einstellung für einzelne Benutzer hat Vorrang vor der globalen Einstellung und setzt diese außer Kraft. In der Standardeinstellung entspricht die Empfängerbeschränkung für einzelne Benutzer der globalen Empfängerhöchstgrenze.
Hinweis:
Auf einem virtuellen SMTP-Server (Simple Mail Transfer Protocol) können Sie die Anzahl der Empfänger pro Nachricht für Nachrichten begrenzen, die von Internet-Benutzern empfangen wurden. Diese Grenze entspricht nicht der globalen Empfängerhöchstgrenze und der Empfängerbeschränkung für einzelne Benutzer. Die globale Empfängerhöchstgrenze und die Empfängerbeschränkung für einzelne Benutzer begrenzen beide die Anzahl der Empfänger, an die ein Exchange-Benutzer eine Nachricht senden kann.
So ändern Sie die globale Empfängerhöchstgrenze in den Standardwert

  1. Starten Sie den Exchange-System-Manager.

  2. Erweitern Sie im linken Bereich Globale Einstellungen.

  3. Klicken Sie mit der rechten Maustaste auf Nachrichtenübermittlung, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf der Registerkarte Standardeinstellungen unter Empfängerbeschränkungen auf Höchstzahl Empfänger, und stellen Sie sicher, dass der Wert nicht kleiner als die Anzahl der Informationsspeicher für Öffentliche Ordner in der Exchange-Organisation ist.

  5. Starten Sie den Microsoft Exchange-Informationsspeicherdienst erneut.

Weitere Informationen zum Festlegen von Empfängerbeschränkungen und zum Konfigurieren von Microsoft Office Outlook® Web Access-Clients finden Sie im Exchange Server 2003 Message Security Guide (http://go.microsoft.com/fwlink/?LinkId=47574) unter „Outlook Web Access S/MIME Control-Related Settings".

Weitere Informationen zum Verlauf der globalen Empfängerhöchstgrenze finden Sie im Exchange-Weblog-Artikel „Me Too!" unter (http://go.microsoft.com/fwlink/?LinkId=41848.


Der Schlüssel "MaxUserPort" fehlt oder weist nicht den Standardwert auf
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-03-23

Das Tool Microsoft Exchange Analyzer fragt den Active Directory-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Objekte mit der Objektklasse msExchExchangeServer zu ermitteln. Wenn der Zeichenfolgenwert "Version 5.5" enthält, führt der Computer Exchange Server 5.5 aus. Wenn der Zeichenfolgenwert "Version 6.0" enthält, wird auf dem Computer Microsoft Exchange 2000 Server ausgeführt. Wenn der Zeichenfolgenwert "Version 6.5" enthält, wird auf dem Computer Exchange Server 2003 ausgeführt. Wenn der Zeichenfolgenwert "Version 8.0" enthält, wird auf dem Computer Exchange Server 2007 ausgeführt.

Das Tool Exchange Analyzer liest dann den folgenden Registrierungszweig für jeden gefundenen Servercomputer mit Exchange Server 2007, um festzustellen, ob der Wert für den Schlüssel MaxUserPort auf den Standardwert von 60000 festgelegt ist.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Der Wert MaxUserPort gibt die höchste Portnummer an, die von TCP zugewiesen werden kann, wenn eine Anwendung einen verfügbaren Benutzerport vom System anfordert.

Microsoft Windows Server 2003 legt den Wert MaxUserPort standardmäßig auf 5000 fest. Microsoft Windows 2000 fügt den Wert MaxUserPort nicht der Registrierung hinzu. Er kann jedoch manuell hinzugefügt werden. Unter Windows Server 2003 und Windows 2000 Server legen Exchange Server 2003 und Exchange Server 2007 den Standardwert jedoch auf 60000 fest. Exchange 2000 Server legt keinen Wert fest.

Es empfiehlt sich, den Wert MaxUserPort auf 60000 festzulegen. Wenn MaxUserPort auf einen niedrigeren Wert als 60000 festgelegt wird, kann dies zu NSPI-Proxywarnungen (Name Service Provider Interface) führen, z. B. zu Ereignis 9040. Dieses Ereignis ist in der folgenden Tabelle dokumentiert.

Ereignis-ID | 9040
Ereigniskategorie | NSPI-Proxy
Ereignisquelle | MSExchangeSA
Ereignistyp | Warnung
Ereignisbeschreibung | NSPI-Proxy hat beim Empfangen eines Pakets einen Fehler festgestellt. Der Zieldomänencontroller oder das Netzwerk bzw. ein Client ist möglicherweise inaktiv. Das Winsock-Subsystem hat den Fehlercode [0x2746] zurückgegeben. Der Kreis, der diesen Fehler empfangen hat, wird getrennt.
Wichtig:
Dieses Thema enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema "Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So vermeiden Sie diese Warnung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

  3. Doppelklicken Sie auf MaxUserPort, legen Sie das Feld Wert auf 60000 (Dezimalwert) fest, und klicken Sie dann auf OK.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den Computer neu, damit diese Einstellung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986, "Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung enthält.

Dieses Problem steht im Beziehung zum Analyzer-Problem Der Schlüssel "TcpTimedWaitDelay" fehlt oder weist nicht den Standardwert auf.

Weitere Informationen zu den Auswirkungen der Schlüssel MaxUserPort und TcpTimedWaitDelay finden Sie im Thema zum Übertragungssteuerungsprotokoll im Windows 2000 Resource Kit (http://go.microsoft.com/fwlink/?LinkId=85654).


Der Wert „MaxUserPort" ist zu niedrig
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um den Maximalwert für den vorübergehend vergebenen TCP-Anschluss zu bestimmen:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\MaxUserPort

Ein vorübergehend vergebener Anschluss ist ein Anschluss, der nur kurzzeitig verwendet wird.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Registrierungsschlüssels MaxUserPort weniger als 50000 beträgt, zeigt ExchangeServer Analyzer eine Warnung an.

Der Wert MaxUserPort gibt die höchste Anschlussnummer an, die von TCP zugewiesen werden kann, wenn eine Anwendung einen verfügbaren Benutzeranschluss vom System anfordert. Vorübergehend vergebenen Anschlüssen werden in der Regel Anschlussnummern von 1024 bis 5000 zugewiesen.

Microsoft Windows Server™ 2003 legt den Wert MaxUserPort auf 5000 fest. Microsoft Windows® 2000 fügt den Wert MaxUserPort nicht der Registrierung hinzu. Sie können den Wert MaxUserPort manuell in die Registrierung einfügen. Unter Windows Server 2003 und Windows 2000 Server legt Exchange Server 2003 den Standardwert jedoch auf 60000 fest. Exchange 2000 Server legt keinen Wert fest.

Es empfiehlt sich, dass Sie den Wert MaxUserPort auf 60000 festlegen. Wenn MaxUserPort auf einen geringeren Wert als 60000 festgelegt wird, kann dies zu NSPI-Proxywarnungen (Name Service Provider Interface) führen, z. B. Ereignis 9040. Dies ist in der folgenden Tabelle dokumentiert.

Ereignis-ID | 9040
Ereigniskategorie | NSPI-Proxy
Ereignisquelle | MSExchangeSA
Ereignistyp | Warnung
Ereignisbeschreibung | NSPI-Proxy hat beim Empfangen eines Pakets einen Fehler festgestellt. Der Zieldomänencontroller oder das Netzwerk oder ein Client ist möglicherweise inaktiv. Das Winsock-Subsystem hat den Fehlercode [0x2746] zurückgegeben. Der Kreis, der diesen Fehler empfangen hat, wird getrennt.

Legen Sie zum Beheben dieser Warnmeldung den Wert des Registrierungsschlüssels MaxUserPort auf 60000 fest.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So beheben Sie diese Warnung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

  3. Doppelklicken Sie auf MaxUserPort, legen Sie das Feld Wert auf ea60 (Hexadezimalwert) fest, und klicken Sie anschließend auf OK.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den Computer neu, damit diese Einstellung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Datei „MDBSZ.DLL" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuellste Service Pack, oder Sie führen ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setup-Programm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Das Leistungsüberwachungsobjekt „Memory" ist nicht vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Available Mbytes-Leistungsindikator des Memory-Leistungsobjekts. Wenn gültige Daten nicht vom Indikator zurückgegeben werden, zeigt Microsoft Exchange Server Analyzer eine Basislinienmeldung an.

Wenn keine gültigen Daten vom Erfassungsmodul für Leistungsdaten zurückgegeben werden, liegt mindestens eine der folgenden Bedingungen vor:

  • Das Memory-Leistungsobjekt ist deaktiviert.

  • Das Memory-Leistungsüberwachungsobjekt wurde nicht gefunden, oder es ist beschädigt.

  • Exchange Server Analyzer verfügt nicht über entsprechende Berechtigungen zum Zugreifen auf die Leistungsobjekte.

Die ersten beiden Bedingungen treten auf, wenn die Registrierung von bestimmten erweiterbaren Indikatoren beschädigt wird oder wenn die Registrierung von auf Microsoft WMI (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) basierten Programmen geändert wird.

Überprüfen Sie vor dem Ausführen des Verfahrens, ob Exchange Server Analyzer über entsprechende Berechtigungen verfügt. Weitere Informationen zu den Berechtigungen, die zum Ausführen von Microsoft Exchange Server Analyzer erforderlich sind, finden Sie in der im Lieferumfang von Microsoft Exchange Server Analyzer enthaltenen Hilfedokumentation. Wenn Sie Hilfe erhalten möchten, öffnen Sie Exchange Server Analyzer, und drücken Sie F1.

So beheben Sie diesen Fehler

  1. Überprüfen Sie, ob das Memory-Leistungsobjekt aktiviert ist:

    1. Downloaden und installieren Sie das Tool „Extensible Performance Counter List" (Exctrlst.exe). Sie können Exctrlst.exe unter „Exctrlst.exe: Extensible Performance Counter List" (http://go.microsoft.com/fwlink/?LinkId=34436) downloaden.

    2. Öffnen Sie die Datei Exctrlst.exe, klicken Sie auf Sortierreihenfolge und anschließend auf Dienst.

    3. Suchen Sie den Dienst, über den das Leistungsobjekt eine Meldung ausgeben soll, und überprüfen Sie, ob das Kontrollkästchen Leistungsindikatoren aktiviert aktiviert ist.

      Wenn das Kontrollkästchen Leistungsindikatoren aktiviert nicht aktiviert ist, aktivieren Sie es, und starten Sie den Dienst neu, der dem Leistungsindikator zugeordnet ist, um zu überprüfen, ob die Leistungsindikatoren betriebsbereit sind. Wenn die Leistungsindikatoren nicht betriebsbereit sind oder wenn das Kontrollkästchen Leistungsindikatoren aktiviert bereits aktiviert wurde, fahren Sie mit Schritt 2 fort.

  2. Erstellen Sie die nicht vorhandenen oder beschädigten Leistungsindikatoren wie im Microsoft Knowledge Base-Artikel 300956 „Manuelles Neuerstellen der Werte der Leistungsindikatorenbibliothek" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) beschrieben neu.

  3. Wenn Sie das Problem anhand dieses Knowledge Base-Artikels nicht beheben lässt, müssen Sie das Windows-Betriebssystem im Modus Reparieren erneut installieren und die aktuellsten Windows-Service Packs anwenden.


Das Objekt „MSExchangeDSAccess" zur Überwachung der Prozessorleistung ist nicht verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem LDAP Read Time-Leistungsindikator des MSExchangeDSAccess-Leistungsobjekts. Wenn gültige Daten nicht vom Indikator zurückgegeben werden, zeigt Microsoft Exchange Server Analyzer eine Basislinienmeldung an.

Wenn gültige Daten nicht vom Erfassungsmodul für Leistungsdaten zurückgegeben werden, liegt mindestens eine der folgenden Bedingungen vor:

  • Das MSExchangeDSAccess-Leistungsobjekt ist deaktiviert.

  • Das MSExchangeDSAccess-Leistungsüberwachungsobjekt wurde nicht gefunden, oder es ist beschädigt.

  • Exchange Server Analyzer verfügt nicht über entsprechende Berechtigungen zum Zugreifen auf die Leistungsobjekte.

Die ersten beiden Bedingungen treten auf, wenn die Registrierung von bestimmten erweiterbaren Indikatoren beschädigt wird oder wenn die Registrierung von auf Microsoft WMI (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) basierten Programmen geändert wird. Im folgenden Verfahren wird die Behebung der ersten beiden Bedingungen erläutert. Überprüfen Sie vor dem Ausführen des Verfahrens, ob Exchange Server Analyzer über entsprechende Berechtigungen verfügt.

Weitere Informationen zu den Berechtigungen, die zum Ausführen von Microsoft Exchange Server Analyzer erforderlich sind, finden Sie in der im Lieferumfang von Microsoft Exchange Server Analyzer enthaltenen Hilfedokumentation. Wenn Sie Hilfe erhalten möchten, öffnen Sie Exchange Server Analyzer, und drücken Sie F1.

So beheben Sie diesen Fehler

  1. Überprüfen Sie, ob das MSExchangeDSAccess-Leistungsobjekt aktiviert ist:

    1. Downloaden und installieren Sie das Tool „Extensible Performance Counter List" (Exctrlst.exe). Sie können Exctrlst.exe unter „Exctrlst.exe: Extensible Performance Counter List" (http://go.microsoft.com/fwlink/?LinkId=34436) downloaden.

    2. Öffnen Sie die Datei Exctrlst.exe, klicken Sie auf Sortierreihenfolge und anschließend auf Dienst.

    3. Suchen Sie den Dienst, über den das Leistungsobjekt eine Meldung ausgeben soll, und überprüfen Sie, ob das Kontrollkästchen Leistungsindikatoren aktiviert aktiviert ist.

      Wenn das Kontrollkästchen Leistungsindikatoren aktiviert nicht aktiviert ist, aktivieren Sie es, und starten Sie den Dienst neu, der dem Leistungsindikator zugeordnet ist, um zu überprüfen, ob die Leistungsindikatoren betriebsbereit sind. Wenn die Leistungsindikatoren nicht betriebsbereit sind oder wenn das Kontrollkästchen Leistungsindikatoren aktiviert bereits aktiviert wurde, fahren Sie mit Schritt 2 fort.

  2. Erstellen Sie die nicht vorhandenen oder beschädigten Leistungsindikatoren wie im Microsoft Knowledge Base-Artikel 300956 „Manuelles Neuerstellen der Werte der Leistungsindikatorenbibliothek" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) beschrieben neu.

  3. Wenn Sie das Problem anhand dieses Knowledge Base-Artikels nicht beheben können, müssen Sie Exchange Server im Modus Reparieren erneut installieren und die aktuellsten Exchange Server-Service Packs installieren.


Das Objekt „MSExchangeIS Mailbox" zur Überwachung der Postfachleistung ist nicht verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Send Queue Size-Leistungsindikator des MSExchangeIS Mailbox-Leistungsobjekts. Wenn gültige Daten nicht vom Indikator zurückgegeben werden, zeigt Microsoft Exchange Server Analyzer eine Basislinienmeldung an.

Wenn gültige Daten nicht vom Erfassungsmodul für Leistungsdaten zurückgegeben werden, liegt mindestens eine der folgenden Bedingungen vor:

  • Das MSExchangeIS Mailbox-Leistungsobjekt ist deaktiviert.

  • Das MSExchangeIS Mailbox-Leistungsüberwachungsobjekt wurde nicht gefunden, oder es ist beschädigt.

  • Exchange Server Analyzer verfügt nicht über entsprechende Berechtigungen zum Zugreifen auf die Leistungsobjekte.

Die ersten beiden Bedingungen treten auf, wenn die Registrierung von bestimmten erweiterbaren Indikatoren beschädigt wird oder wenn die Registrierung von auf Microsoft WMI (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) basierten Programmen geändert wird.

Überprüfen Sie vor dem Ausführen des Verfahrens, ob Exchange Server Analyzer über entsprechende Berechtigungen verfügt. Weitere Informationen zu den Berechtigungen, die zum Ausführen von Microsoft Exchange Server Analyzer erforderlich sind, finden Sie in der im Lieferumfang von Microsoft Exchange Server Analyzer enthaltenen Hilfedokumentation. Wenn Sie Hilfe erhalten möchten, öffnen Sie Exchange Server Analyzer, und drücken Sie F1.

So beheben Sie diesen Fehler

  1. Überprüfen Sie, ob das MSExchangeIS Mailbox-Leistungsobjekt aktiviert ist:

    1. Downloaden und installieren Sie das Tool „Extensible Performance Counter List" (Exctrlst.exe). Sie können Exctrlst.exe unter „Exctrlst.exe: Extensible Performance Counter List" (http://go.microsoft.com/fwlink/?LinkId=34436) downloaden.

    2. Öffnen Sie die Datei Exctrlst.exe, klicken Sie auf Sortierreihenfolge und anschließend auf Dienst.

    3. Suchen Sie den Dienst, über den das Leistungsobjekt eine Meldung ausgeben soll, und überprüfen Sie, ob das Kontrollkästchen Leistungsindikatoren aktiviert aktiviert ist.

      Wenn das Kontrollkästchen Leistungsindikatoren aktiviert nicht aktiviert ist, aktivieren Sie es, und starten Sie den Dienst neu, der dem Leistungsindikator zugeordnet ist, um zu überprüfen, ob die Leistungsindikatoren betriebsbereit sind. Wenn die Leistungsindikatoren nicht betriebsbereit sind oder wenn das Kontrollkästchen Leistungsindikatoren aktiviert bereits aktiviert wurde, fahren Sie mit Schritt 2 fort.

  2. Erstellen Sie die nicht vorhandenen oder beschädigten Leistungsindikatoren wie im Microsoft Knowledge Base-Artikel 300956 „Manuelles Neuerstellen der Werte der Leistungsindikatorenbibliothek" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) beschrieben neu.

  3. Wenn Sie das Problem anhand dieses Knowledge Base-Artikels nicht beheben können, müssen Sie Exchange Server im Modus Reparieren erneut installieren und die aktuellsten Exchange Server-Service Packs installieren.


Das Leistungsüberwachungsobjekt „MSExchangeIS" ist nicht verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-04-03

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem RPC Operations/sec-Leistungsindikator des MSExchangeIS-Leistungsobjekts. Wenn gültige Daten nicht vom Indikator zurückgegeben werden, zeigt Microsoft Exchange Server Analyzer eine Basislinienmeldung an.

Wenn keine gültigen Daten vom Erfassungsmodul für Leistungsdaten zurückgegeben werden, liegt mindestens eine der folgenden Bedingungen vor:

  • Das MSExchangeIS-Leistungsobjekt ist deaktiviert.

  • Das MSExchangeIS-Leistungsüberwachungsobjekt wurde nicht gefunden, oder es ist beschädigt.

  • Microsoft Exchange Server Analyzer verfügt nicht über entsprechende Berechtigungen zum Zugreifen auf die Leistungsobjekte.

Die ersten beiden Bedingungen treten auf, wenn die Registrierung von bestimmten erweiterbaren Indikatoren beschädigt wird oder wenn die Registrierung von auf Microsoft WMI (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) basierten Programmen geändert wird. Überprüfen Sie vor dem Ausführen des Verfahrens, ob Microsoft Exchange Server Analyzer über entsprechende Berechtigungen verfügt. Weitere Informationen zu den Berechtigungen, die zum Ausführen von Microsoft Exchange Server Analyzer erforderlich sind, finden Sie in der im Lieferumfang von Microsoft Exchange Server Analyzer enthaltenen Hilfedokumentation. Wenn Sie Hilfe erhalten möchten, öffnen Sie Exchange Server Analyzer, und drücken Sie F1.

So beheben Sie diesen Fehler

  1. Überprüfen Sie, ob das MSExchangeIS-Leistungsobjekt aktiviert ist:

    1. Downloaden und installieren Sie das Tool „Extensible Performance Counter List" (Exctrlst.exe). Sie können Exctrlst.exe unter „Exctrlst.exe: Extensible Performance Counter List" (http://go.microsoft.com/fwlink/?LinkId=34436) downloaden.

    2. Öffnen Sie die Datei Exctrlst.exe, klicken Sie auf Sortierreihenfolge und anschließend auf Dienst.

    3. Suchen Sie den Dienst, über den das Leistungsobjekt eine Meldung ausgeben soll, und überprüfen Sie, ob das Kontrollkästchen Leistungsindikatoren aktiviert aktiviert ist.

      Wenn das Kontrollkästchen Leistungsindikatoren aktiviert nicht aktiviert ist, aktivieren Sie es, und starten Sie den Dienst neu, der dem Leistungsindikator zugeordnet ist, um zu überprüfen, ob die Leistungsindikatoren betriebsbereit sind. Wenn die Leistungsindikatoren nicht betriebsbereit sind oder wenn das Kontrollkästchen Leistungsindikatoren aktiviert bereits aktiviert wurde, fahren Sie mit Schritt 2 fort.

  2. Erstellen Sie die nicht vorhandenen oder beschädigten Leistungsindikatoren wie im Microsoft Knowledge Base-Artikel 300956 „Manuelles Neuerstellen der Werte der Leistungsindikatorenbibliothek" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) beschrieben neu.

  3. Wenn Sie das Problem anhand dieses Knowledge Base-Artikels nicht beheben können, müssen Sie Exchange Server im Modus Reparieren erneut installieren und die aktuellsten Exchange Server-Service Packs installieren.

Weitere Informationen zur Behandlung von Verbindungsproblemen bei Exchange Server Best Practices Analyzer finden Sie unter „Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" (http://go.microsoft.com/fwlink/?LinkId=56285).


Das öffentliche Leistungsüberwachungsobjekt „MSExchangeIS" ist nicht verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Send Queue Size-Leistungsindikator des MSExchangeIS Public-Leistungsobjekts. Wenn gültige Daten nicht vom Indikator zurückgegeben werden, zeigt Microsoft Exchange Server Analyzer eine Basislinienmeldung an.

Wenn gültige Daten nicht vom Erfassungsmodul für Leistungsdaten zurückgegeben werden, liegt mindestens eine der folgenden Bedingungen vor:

  • Das MSExchangeIS Public-Leistungsobjekt ist deaktiviert.

  • Das MSExchangeIS Public-Leistungsüberwachungsobjekt wurde nicht gefunden, oder es ist beschädigt.

  • Microsoft Exchange Server Analyzer verfügt nicht über entsprechende Berechtigungen zum Zugreifen auf die Leistungsobjekte.

Die ersten beiden Bedingungen treten auf, wenn die Registrierung von bestimmten erweiterbaren Indikatoren beschädigt wird oder wenn die Registrierung von auf Microsoft WMI (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) basierten Programmen geändert wird. Überprüfen Sie vor dem Ausführen des Verfahrens, ob Microsoft Exchange Server Analyzer über entsprechende Berechtigungen verfügt. Weitere Informationen zu den Berechtigungen, die zum Ausführen von Microsoft Exchange Server Analyzer erforderlich sind, finden Sie in der im Lieferumfang von Microsoft Exchange Server Analyzer enthaltenen Hilfedokumentation. Wenn Sie Hilfe erhalten möchten, öffnen Sie Exchange Server Analyzer, und drücken Sie F1.

So beheben Sie diesen Fehler

  1. Überprüfen Sie, ob das MSExchangeIS Public-Leistungsobjekt aktiviert ist:

    1. Downloaden und installieren Sie das Tool „Extensible Performance Counter List" (Exctrlst.exe). Sie können Exctrlst.exe unter „Exctrlst.exe: Extensible Performance Counter List" (http://go.microsoft.com/fwlink/?LinkId=34436) downloaden.

    2. Öffnen Sie die Datei Exctrlst.exe, klicken Sie auf Sortierreihenfolge und anschließend auf Dienst.

    3. Suchen Sie den Dienst, über den das Leistungsobjekt eine Meldung ausgeben soll, und überprüfen Sie, ob das Kontrollkästchen Leistungsindikatoren aktiviert aktiviert ist.

      Wenn das Kontrollkästchen Leistungsindikatoren aktiviert nicht aktiviert ist, aktivieren Sie es, und starten Sie den Dienst neu, der dem Leistungsindikator zugeordnet ist, um zu überprüfen, ob die Leistungsindikatoren betriebsbereit sind. Wenn die Leistungsindikatoren nicht betriebsbereit sind oder wenn das Kontrollkästchen Leistungsindikatoren aktiviert bereits aktiviert wurde, fahren Sie mit Schritt 2 fort.

  2. Erstellen Sie die nicht vorhandenen oder beschädigten Leistungsindikatoren wie im Microsoft Knowledge Base-Artikel 300956 „Manuelles Neuerstellen der Werte der Leistungsindikatorenbibliothek" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) beschrieben neu.

  3. Wenn Sie das Problem anhand dieses Knowledge Base-Artikels nicht beheben können, müssen Sie Exchange Server im Modus Reparieren erneut installieren und die aktuellsten Exchange Server-Service Packs installieren.


MSGINA.DLL: Eine Treiberaktualisierung ist verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-08-21

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Version von Microsoft Windows® zu ermitteln, die auf dem Server mit Exchange Server ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Der Wert 4.0 für CurrentVersion gibt an, dass auf dem Exchange-Server Microsoft Windows NT® Server 4.0 ausgeführt wird. Der Wert 5.0 gibt an, dass Windows 2000 Server auf dem Exchange-Server ausgeführt wird. Der Wert 5.2 gibt an, dass Windows Server™ 2003 auf dem Exchange-Server ausgeführt wird.

Exchange Server Analyzer untersucht außerdem die Microsoft WMI-Klasse (Microsoft Windows Management Instrumentation) Win32_OperatingSystem, um den Wert für den Schlüssel ServicePackMajorVersion zu ermitteln.

Der Wert 1 für den Schlüssel ServicePackMajorVersion gibt an, dass Service Pack 1 (SP1) auf dem Server installiert ist.

Abschließend fragt Exchange Server Analyzer die WMI-Klasse CIM_Datafile ab, um den Wert des Schlüssels Version für die Datei Msgina.dll zu ermitteln.

Exchange Server Analyzer zeigt einen Fehler an, wenn folgende Bedingungen zutreffen:

  • Auf dem Server wird Windows Server™ 2003 SP1 ausgeführt.

  • Die Buildnummer der Datei Msgina.dll ist niedriger als 5.2.3790.2525.

Dieser Fehler weist darauf hin, dass die Version der auf dem Server installierten Datei Msgina.dll zu übermäßiger Aktivität hinsichtlich der Auslagerungsdatei führen und die Leistung herabsetzen kann.

Um dieses Problem zu beheben, beziehen Sie das Update, das im Microsoft Knowledge Base-Artikel 905865, "Die Größe der Arbeitssätze aller Prozesse in einer Konsolensitzung wird möglicherweise abgeschnitten, wenn zum An- oder Abmelden auf einem Computer, auf dem Windows Server 2003 ausgeführt wird, die Terminaldienste verwendet werden" erläutert wird (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905865).


MTA-Parameter „APDU logging required" entspricht nicht dem Standardwert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um seinen aktuellen Wert zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\APDU logging required

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert für APDU logging required vorhanden und ungleich 0 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

APDU-Textprotokolle (Application Protocol Data Unit) sind binäre Darstellungen der Kommunikation zwischen Exchange-MTAs (Message Transfer Agents) an unterschiedlichen Standorten und zwischen MTA- und Client-Anwendungen innerhalb eines Standorts. APDU-Protokolle können bei der Diagnose eines Problems mit dem MTA nützlich sein. Es werden jedoch nur diejenigen daraus Nutzen ziehen können, die mit den ASCII-Übersetzungen des X.400-Protokolls vertraut sind.

Wenn der Registrierungsparameter APDU logging required vorhanden und mit dem Wert 0 konfiguriert ist, werden alle APDUs, die vom MTA gesendet oder empfangen werden, als binäre Daten zu binären Daten in MTADATA\BF*.LOG protokolliert.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Bearbeiten der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration für MTA-APDU-Protokollierung wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Suchen Sie im rechten Bereich den Wert APDU logging required, und doppelklicken Sie darauf.

  4. Geben Sie im Datenfeld Wert den Wert 0 ein, und klicken Sie auf OK.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Dienst Microsoft Exchange MTA-Stacks neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zu den APDU-Protokollen finden Sie im Knowledge Base-Artikel 163324 „XCON: Application Protocol Data Unit (APDU) Logs (BF0.LOG)" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=163324.


Der MTA-Parameter „Call-stack diagnostics required" entspricht nicht dem Standardwert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um seinen aktuellen Wert zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Call-stack diagnostics required

Wenn Microsoft Exchange Server Analyzer ermittelt, dass der Wert für Call-stack diagnostics required vorhanden und ungleich 1 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Registrierungswert Call-stack diagnostics required wird nur für fortgeschrittenes Debuggen verwendet und nur von einer Debug-Version des MTA (Message Transfer Agent) gelesen. Sein Datenwert sollte immer auf 1 festgelegt sein. Wenn eine Debug-Version der MTAs verwendet wird, stellt dieser Wert beim Beenden einen Aufrufstapel für jeden MTA-Thread bereit.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diesen Fehler

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Suchen Sie im rechten Bereich den Wert Call-stack diagnostics required, und doppelklicken Sie darauf.

  4. Geben Sie im Datenfeld Wert den Wert 1 ein, und klicken Sie auf OK.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Dienst Microsoft Exchange MTA-Stacks neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://support.microsoft.com/kb/256986/DE/).


Namenskonflikt bei MTA-Computer
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Einstellung des Werts für den MTA-Computer (Message Transfer Agent) zu bestimmen: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer sendet auch eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert des Attributs name für jedes Exchange Server-Objekt zu ermitteln.

Schließlich sendet Exchange Server Analyzer eine Abfrage an die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_Service, um den Wert des Schlüssels Started für den Clusterdienst (ClusSvc) zu bestimmen. Der Wert True gibt an, dass der Clusterdienst gestartet wurde, der Wert False gibt an, dass der Clusterdienst nicht ausgeführt wird.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel MTA Computer für keinen Exchange Server-Computer, der nicht in einem Windows-Servercluster ausgeführt wird, mit dem Wert des Attributs name des Serverobjekts in Active Directory übereinstimmt, wird ein Fehler angezeigt.

Um diesen Fehler zu beheben, müssen Sie den Registrierungsschlüssel MTA Computer so ändern, dass er mit dem Wert des Attributs name in Active Directory übereinstimmt.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Bearbeiten der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diesen Fehler

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Doppelklicken Sie im rechten Bereich auf MTA Computer, geben Sie den korrekten Namen für diesen Computer ein, und klicken Sie auf OK.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den Exchange Server-Computer neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung enthält.


MTA-Parameter „Concurrent connections to LAN-MTAs" entspricht nicht dem Standardwert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um seinen aktuellen Wert zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent connections to LAN-MTAs

Wenn Microsoft Exchange Server Analyzer Tool erkennt, dass der Wert für Concurrent connections to LAN-MTAs vorhanden und ungleich 0x28 (Hexadezimalwert) oder 40 (Dezimalwert) ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Registrierungswert Concurrent connections to LAN-MTAs bestimmt die maximale Anzahl gleichzeitiger Verbindungen mit MTAs (Message Transfer Agents) über das LAN (lokales Netzwerk - Local Area Network). MTAs, die über ein LAN miteinander kommunizieren, werden als LAN-MTAs bezeichnet. Der lokale MTA kann entsprechend seiner Konfiguration und der Systemlast über mehrere Verbindungen mit einem Remote-MTA verfügen. Die maximale Anzahl gleichzeitiger LAN-basierter MTA-Verbindungen beträgt 240.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration für gleichzeitige MTA-Verbindungen wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Suchen Sie im rechten Bereich den Wert Concurrent connections to LAN-MTAs, und doppelklicken Sie darauf.

  4. Stellen Sie sicher, dass Basis auf Hexadezimalwerte festgelegt ist, geben Sie im Feld Datenwerte den Wert 28 ein, und klicken Sie auf OK.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Dienst Microsoft Exchange MTA-Stacks neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen über die maximale Anzahl von gleichzeitigen LAN-basierten MTA-Verbindungen finden Sie im Knowledge Base-Artikel „XCON: Exchange Server MTA Event ID 9280" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=243402)


MTA-Parameter „Concurrent connections to X.400 gateways" entspricht nicht dem Standardwert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um seinen aktuellen Wert zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent connections to X.400 gateways

Wenn Microsoft Exchange Server Analyzer ermittelt, dass der Wert für Concurrent connections to X.400 gateways vorhanden und ungleich 6 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Bei dem Registrierungswert Concurrent connections to X.400 gateways handelt es sich um die maximale Anzahl gleichzeitiger Verbindungen mit Remote-X.400-MTAs (Message Transfer Agents). Der Standardwert 6 ist für die meisten Organisationen ausreichend. Ein bekanntes Problem ist die Verwendung von mehr als 4 EDK-Connectors auf einem Server, auf dem Microsoft® Exchange Server 5.5 ausgeführt wird, welche erfordert, den Wert für Concurrent connections to X.400 gateways auf 0x12 (hexadezimal) oder 18 (dezimal) zu erhöhen. Weitere Informationen zu diesem Problem finden Sie im Microsoft Knowledge Base-Artikel 282115 „If more than 4 Exchange EDK connectors are installed, mail flow stops" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=282115. Wenn bei Ihnen das in diesem Artikel beschriebene Problem nicht auftaucht, sollten Sie den Registrierungswert Concurrent connections to X.400 gateways bei 6 belassen.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Suchen Sie im rechten Bereich den Wert Concurrent connections to X.400 gateways, und doppelklicken Sie darauf.

  4. Geben Sie im Datenfeld Wert den Wert 6ein, und klicken Sie anschließend auf OK.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Dienst Microsoft Exchange MTA-Stacks neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Der MTA-Parameter „Concurrent MDB/delivery queue clients" entspricht nicht dem Standardwert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um seinen aktuellen Wert zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent MDB/delivery queue clients

Wenn Microsoft Exchange Server Analyzer ermittelt, dass der Wert für Concurrent MDB/delivery queue clients vorhanden und ungleich 3 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert Concurrent MDB/delivery queue clients stellt die maximale Anzahl von MDB- (Messaging Database) und Exchange-API-MA Delivery Queue-Clients dar, die der MTA (Message Transfer Agent) unterstützen kann. Jeder Client kann über mehr als eine Sitzung verfügen. Dieser Wert sollte mindestens zwei betragen, um die privaten und öffentlichen MDB-Einheiten zu unterstützen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So berichtigen Sie diesen Fehler

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Suchen Sie im rechten Bereich den Wert Concurrent MDB/delivery queue clients, und doppelklicken Sie darauf.

  4. Geben Sie im Datenfeld Wert den Wert 3 ein, und klicken Sie auf OK.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Dienst Microsoft Exchange MTA-Stacks neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://support.microsoft.com/?scid=kb%3Bde%3B256986&x=2&y=12, der weitere Informationen zum Bearbeiten der Registrierung enthält.


MTA-Datendateien werden in einen komprimierten Ordner geschrieben
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Directory ab, um den Wert für den Schlüssel Compressed für den MTA-Datenpfad (Message Transfer Agent) zu ermitteln. Wenn Exchange Server Analyzer ermittelt, dass der Schlüssel Compressed den Wert True aufweist, wird ein Fehler angezeigt.

Das Speichern von Exchange-Datendateien in einem komprimierten Volume mit dem NTFS-Dateisystem wird von Microsoft nicht unterstützt. Wenn Sie Exchange-Datendateien auf einem komprimierten Datenträger speichern, wirkt sich der zusätzliche Overhead entscheidend auf die Exchange-Leistung aus. Wenn zudem eine Exchange-Informationsspeicher-Datenbank eine bestimmte Größe (etwa 4 GB) erreicht, kann die Datenbank möglicherweise nicht bereitgestellt werden oder u. U. fehlerhaft sein.

Zu den Exchange-Datendateien gehören folgende Dateien:

  • EDB-Dateien

  • STM-Dateien

  • LOG-Dateien

  • DAT-Dateien

  • EML-Dateien

  • CHK-Dateien

Dateien, die mit ESE (Extensible Storage Engine) verwaltet werden, können nicht auf einem komprimierten Laufwerk gespeichert werden. ESE ist bei der protokollbasierten Wiederherstellung auf Sektorunabhängigkeit angewiesen. Durch das Komprimieren von Dateien wird die Sektorunabhängigkeit jedoch aufgehoben. Die Komprimierung sollte für Datenträger deaktiviert werden, die als Host für ESE-Datenbanken oder für Write-Ahead-Logging verwendende Datenbanken dienen.

Vor Exchange 2000 Server Service Pack 3 war die Bereitstellung komprimierter Exchange-Informationsspeicher-Datenbanken möglich. Allerdings können in allen Exchange 2000-Informationsspeicher-Datenbanken oder -Protokollen, die mit NTFS-Komprimierung komprimiert wurden, Beschädigungen auftreten.

Unter Exchange 2000 Server Service Pack 3 werden komprimierte Informationsspeicher-Datenbankdateien mit einer Größe von 128 MB oder geringer automatisch dekomprimiert. Wenn Datenbankdateien eine Größe von 128 MB überschreiten, kann die Datenbank nicht bereitgestellt werden, und in der Anwendungsprotokollierung werden Fehlermeldungen erzeugt. Unter Exchange 2000 Server Service Pack 3 können komprimierte Datenbanken mit einer Größe von mehr als 128 MB nicht bereitgestellt werden.

So deaktivieren Sie die Dateikomprimierung für einen bestimmten Ordner

  1. Klicken Sie mit der rechten Maustaste auf den Ordner, für den Sie die Dateikomprimierung deaktivieren möchten, und klicken Sie dann auf Eigenschaften.

  2. Klicken Sie auf der Registerkarte Allgemein auf Erweitert.

  3. Deaktivieren Sie im Dialogfeld Erweiterte Attribute das Kontrollkästchen Inhalt komprimieren, um Speicherplatz zu sparen, und klicken Sie dann auf OK.

So verschieben Sie den Speicherort der MTA-Datenbankdateien

  1. Bei Exchange Server, Version 5.5, können Sie den Speicherort der MTA-Datenbankdateien mithilfe von Performance Optimizer verschieben. Weitere Informationen zur Vorgehensweise für Exchange 2000 Server oder Exchange Server 2003 finden Sie im Microsoft Knowledge Base-Artikel 259896, „XCON: How to Change the Location of the MTA Database and Run Directory" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=259896.

Weitere Informationen zu Exchange-Datendateien und NTFS-Komprimierung finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 170009, „XADM: NTFS Compressed Volume Causes Store to Fail" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=170009

  • 327772, „XADM: Database Does Not Mount and You Receive Error 0xfffff05b After You Apply SP3" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=327772.


MTA-Datendateien werden in einen verschlüsselten Ordner geschrieben.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Directory ab, um den Wert für den Schlüssel Encrypted für den MTA-Datenpfad (Message Transfer Agent) zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass der Wert für diesen Schlüssel auf True festgelegt ist, wird ein Fehler angezeigt.

Auf einem Exchange 2000 Server- oder Exchange Server 2003-Computer werden die MTA-Dateien in den folgenden Standard-Speicherort geschrieben:

<Laufwerk> :\Programme\Exchsrvr\MTAdata

Microsoft unterstützt nicht das Speichern von Exchange-Datendateien auf verschlüsselten Datenträgern in verschlüsselnden Dateisystemen (Encrypting File Systems, EFS). Wenn Sie Exchange-Datendateien auf einem verschlüsselten Datenträger speichern, wirkt sich der zusätzliche Overhead entscheidend auf die Exchange-Leistung aus. Zu den Exchange-Datendateien gehören folgende Dateien:

  • EDB-Dateien

  • STM-Dateien

  • LOG-Dateien

  • DAT-Dateien

  • EML-Dateien

  • CHK-Dateien

Um die Sicherheit der Exchange-Datendateien zu gewährleisten, empfiehlt es sich, den unbefugten Zugriff auf den Exchange-Computer zu verhindern und Nachrichtendaten mithilfe des S/MIME-Nachrichtenformats zu verschlüsseln.

So deaktivieren Sie die Dateiverschlüsselung für einen bestimmten Ordner

  1. Klicken Sie mit der rechten Maustaste auf den Ordner, für den die Dateikomprimierung deaktiviert werden soll, und klicken Sie dann auf Eigenschaften.

  2. Klicken Sie auf der Registerkarte Allgemein auf Erweitert.

  3. Deaktivieren Sie im Dialogfeld Erweiterte Attribute das Kontrollkästchen Inhalt verschlüsseln, um Daten zu schützen, und klicken Sie dann auf OK.

Weitere Informationen über Exchange Server-Datendateien und EFS finden Sie im Microsoft Knowledge Base-Artikel „Information about the storage of data files on an encrypted volume in Exchange Server" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638.

Informationen zum Sichern von Nachrichten in Microsoft Exchange Server 2003 finden Sie im Handbuch zur Nachrichtensicherheit in Exchange Server 2003 unter http://go.microsoft.com/fwlink/?linkid=47574.


MTA-Datendateien werden in eine Nicht-NTFS-Partition geschrieben.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Directory ab, um den Wert für den Schlüssel FSName für den MTA-Datenordner (Message Transfer Agent) zu ermitteln. Wenn Exchange Server Analyzer ermittelt, dass der Wert für den Schlüssel FSName nicht NTFS ist, wird ein Fehler angezeigt.

Das Speichern von Exchange-Datendateien auf einem Nicht-NTFS-Datenträger wird von Microsoft nicht unterstützt. Zu den Exchange-Datendateien gehören folgende Dateien:

  • EDB-Dateien

  • STM-Dateien

  • LOG-Dateien

  • DAT-Dateien

  • EML-Dateien

  • CHK-Dateien

Wenn dieser Fehler auftritt, müssen Sie den MTA-Datenordner auf ein NTFS-Laufwerk verschieben. Wenn das Laufwerk, auf dem der MTA-Datenordner gespeichert ist, als FAT-Laufwerk (File Allocation Table) formatiert ist, können Sie zum Konvertieren des Laufwerks in NTFS auch das Befehlszeilentool convert.exe verwenden.

So verschieben Sie den Exchange-MTA-Datenordner

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Administrative Gruppen, erweitern Sie Ihre administrative Gruppe, erweitern Sie Server, klicken Sie mit der rechten Maustaste auf Ihre Speichergruppe, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Eigenschaftenseite für die Speichergruppe neben dem Feld Systempfad auf Durchsuchen.

  4. Geben Sie den neuen Pfad für den MTA-Datenordner ein, und klicken Sie dann auf OK.

  5. Klicken Sie auf OK.

Wenn das Laufwerk, auf dem die Dateien gespeichert sind, als FAT-Laufwerk formatiert ist, können Sie alternativ zur obigen Vorgehensweise zum Konvertieren des Laufwerks in NTFS auch das Befehlszeilentool convert.exe verwenden. Weitere Informationen zum Konvertieren einer FAT-Partition in eine NTFS-Partition mit dem Befehlszeilentool convert.exe finden Sie im Microsoft Knowledge Base-Artikel 214579 „Konvertieren einer Partition in NTFS mit "Convert.exe"" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579).


MTA-Parameter „DB data buffers per object" weicht vom Standardwert ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um seinen aktuellen Wert zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\DB data buffers per object

Wenn Exchange Server Analyzer feststellt, dass der Wert für DB data buffers per object vorhanden und größer null, jedoch ungleich 3 oder 6 ist, wird eine Meldung ausgegeben, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert für DB data buffers per object ist die Anzahl der 4 KB-Datenbankserverpuffer, die für die einzelnen Datenbankobjekte konfiguriert sind. Für eine höhere Anzahl von Puffern ist mehr Speicher erforderlich. Dadurch wird jedoch wegen des fehlenden Pufferplatzes ein Rollout der Datenbankobjekte auf die Festplatte weniger wahrscheinlich. Das Ändern dieses Werts wird u. a. dann empfohlen, wenn ein MTA (Message Transfer Agent) mit mehreren Exchange Server 5.5-Computern innerhalb einer Website oder zwischen mehreren Websites kommuniziert. In diesem Fall empfiehlt es sich, den Wert auf 6 zu ändern. Wenn der MTA diesem Kriterium nicht entspricht, sollten Sie den Wert zurück auf den Standardwert 3 ändern.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Suchen Sie im rechten Bereich den Wert DB data buffers per object, und doppelklicken Sie darauf.

  4. Geben Sie im Datenfeld Wert den Wert 3ein, und klicken SIe anschließend auf OK.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Dienst Microsoft Exchange MTA-Stacks neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


MTA-Parameter "DB file handles" weicht vom Standardwert ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um seinen aktuellen Wert zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\DB file handles

Wenn Exchange Server Analyzer ermittelt, dass der Wert für DB file handles vorhanden und ungleich 192 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert DB file handles steht für die Anzahl der konfigurierten Datenbankserver-Dateizugriffsnummern. Dadurch wird die maximale Anzahl der Datenbankdateien bestimmt, die gleichzeitig geöffnet sein können. Wenn eine größere Anzahl von geöffneten Dateien erforderlich ist, als der konfigurierte Wert zulässt, werden Datenbankobjekte auf die Festplatte kopiert.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So berichtigen Sie diesen Fehler

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Suchen Sie im rechten Bereich den Wert DB file handles, und doppelklicken Sie darauf.

  4. Geben Sie im Datenfeld Wert den Wert 192 ein, und klicken Sie auf OK.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Dienst Microsoft Exchange MTA-Stacks neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Die MTA-Ebene „Diagnoseprotokoll" ist größer als 5 (MTA befindet sich im Debugmodus).
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer Tool liest mehrere Registrierungsschlüssel, um die MTA-Diagnoseprotokollebene (Message Transfer Agent) zu bestimmen, die auf dem Exchange-Server festgelegt ist. Die Registrierungsschlüssel befinden sich in:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Diagnostics

Der Standardwert für diese Schlüssel ist 0. Wenn Exchange Server Analyzer feststellt, dass der Wert eines dieser Schlüssel größer ist als 5, wird ein Fehler angezeigt.

Diese Registrierungsschlüssel werden vom Exchange System-Manager festgelegt, wenn Sie die Protokollebenen auf der Eigenschaftenseite eines bestimmten Servers auf der Registerkarte Diagnoseprotokoll einstellen. Mit dem Exchange System-Manager kann ein Administrator die angegebene Protokollebene auf Keine, Minimum, Mittel oder Maximum festlegen. Die entsprechenden Werte der Registrierungsschlüssel sind jeweils 0, 1, 3 oder 5.

Daher kann ein größerer Wert als 5 nur durch manuelles Bearbeiten der Registrierung festgelegt werden. Dies sollte nur außerhalb der Spitzenstunden sehr kurzzeitig zum Debuggen und zur Problembehandlung erfolgen. Durch das Festlegen dieser Schlüssel auf ganze Zahlen, die größer sind als 5, werden Protokollebenen auf Debug-Ebenen heraufgesetzt. Dies ist sehr ressourcenaufwändig. Zusätzlich zur Protokollierung auf Debug-Ebene führt das Festlegen dieser Schlüssel auf Werte höher als 5 dazu, dass in Abständen von einigen Sekunden eine Debug-Ablaufverfolgungsdatei („call.out") von ca. 40 Megabyte (MB) Größe ausgegeben wird. Das Ereignisprotokoll des Computers kann dadurch in weniger als einer Minute gefüllt werden.

Die folgende Tabelle enthält die MTA-Protokollkategorien, wie sie im Exchange System-Manager auf der Registerkarte Diagnoseprotokoll aufgelistet sind, und die entsprechenden Schlüsselnamen in der Registrierung.

Kategorie wie in Exchange-System-Manager angezeigt | Entsprechender Registrierungsschlüsselname
X.400-Dienst | 1 X.400-Dienst
Ressource | 2 Ressource
Sicherheit | 3 Sicherheit
Schnittstelle | 4 Schnittstelle
Field Engineering | 5 Field Engineering
MTA-Administration | 6 MTA-Administration
Konfiguration | 7 Konfiguration
Verzeichniszugriff | 8 Verzeichniszugriff
Betriebssystem | 9 Betriebssystem
Interne Verarbeitung | 10 Interne Verarbeitung
Interoperabilität | 11 Interoperabilität
APDU (Application Protocol Data Unit) | 12 APDU

Die Verweise am Ende dieses Artikels stellen weitere Informationen zu den von den einzelnen MTA-Kategorien protokollierten Daten bereit.

Es wird empfohlen, die Protokollierung für jede MTA-Kategorie auf Keine (0) festzulegen, vorausgesetzt, Sie sind nicht gerade aktiv mit einer Problembehandlung beschäftigt. Mit dieser Empfehlung soll für die Verwaltung eine handhabbare Anzahl von zu protokollierenden Ereignissen erreicht werden. Selbst die Ebene Minimum (1) liefert im Laufe von wenigen Tagen Hunderte von Ereignisprotokollen, in Abhängigkeit von der Kategorie, für die die Ebene festgelegt worden ist.

Wenn Sie nicht gerade mit einer Problembehandlung beschäftigt sind, wurden diese Werte möglicherweise bei einer Problembehebungsübung auf einen höheren Wert festgelegt und dann versehentlich beibehalten. Diese Werte müssen mindestens auf Maximum (5) festgelegt werden. Sie sollten jedoch in Erwägung ziehen, die Protokollierungsebene für jede MTA-Diagnoseprotokollebene auf Keine (0) festzulegen, wenn Sie nicht gerade aktiv mit einer Problembehandlung beschäftigt sind.

So legen Sie die MTA-Diagnoseprotokollierungskategorien auf Keine fest

  1. Starten Sie den Exchange-System-Manager: Klicken Sie auf Start, zeigen Sie auf Alle Programme, zeigen Sie auf Microsoft Exchange, und klicken Sie dann auf System-Manager.

  2. Erweitern Sie in der Konsolenstruktur Server, erweitern Sie den gewünschten Server, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie in <Server>Eigenschaften auf die Registerkarte Diagnoseprotokoll.

  4. Wählen Sie unter Dienste die Option MSExchangeMTA aus.

  5. Für jeden Eintrag unter Kategorien legen Sie die Protokollebene auf Keine fest, indem Sie die Kategorie auswählen und dann unter Protokollebene die Option Keine auswählen.

  6. Wenn Sie alle Kategorien auf Keine festgelegt haben, klicken Sie auf Übernehmen, und klicken Sie dann auf OK.

Weitere Informationen über MTA-Diagnoseprotokolle in Exchange 2000 Server und Exchange Server 2003 finden Sie im Microsoft Knowledge Base-Artikel 163033. „XCON: Description of Diagnostics Categories for MTA" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163033.

Weitere Informationen zu MTA-Diagnoseprotokollen in Exchange Server 5.5 finden Sie im Microsoft Knowledge Base-Artikel 163032, „XCON: Description of Diagnostics Logging for MTA" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163032.


MTA-Diagnoseprotokollebene ist ungleich Null
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer Tool liest mehrere Registrierungsschlüssel, um die MTA-Diagnoseprotokollebene (Message Transfer Agent) zu bestimmen, die auf dem Exchange-Server festgelegt ist. Die Registrierungsschlüssel befinden sich in:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Diagnostics

Der Standardwert für diese Schlüssel ist 0. Wenn Exchange Server Analyzer feststellt, dass der Wert eines dieser Schlüssel mehr als 1 und weniger als 6 beträgt, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Diese Registrierungsschlüssel werden vom Exchange-System-Manager festgelegt, wenn Sie die Protokollebenen auf der Eigenschaftenseite eines angegebenen Servers auf der Registerkarte Diagnoseprotokoll einstellen. Der Exchange-System-Manager ermöglicht es einem Administrator, die jeweilige Protokollebene auf Keine, Minimum, Mittel oder Maximum festzulegen. Die entsprechenden Werte der Registrierungsschlüssel sind jeweils 0, 1, 3 oder 5.

Die folgende Tabelle enthält die MTA-Protokollkategorien, wie sie im Exchange System-Manager auf der Registerkarte Diagnoseprotokoll aufgelistet sind, und die entsprechenden Schlüsselnamen in der Registrierung.

Kategorie wie in Exchange-System-Manager angezeigt | Entsprechender Registrierungsschlüsselname
X.400-Dienst | 1 X.400-Dienst
Ressource | 2 Ressource
Sicherheit | 3 Sicherheit
Schnittstelle | 4 Schnittstelle
Field Engineering | 5 Field Engineering
MTA-Administration | 6 MTA-Administration
Konfiguration | 7 Konfiguration
Verzeichniszugriff | 8 Verzeichniszugriff
Betriebssystem | 9 Betriebssystem
Interne Verarbeitung | 10 Interne Verarbeitung
Interoperabilität | 11 Interoperabilität
APDU (Application Protocol Data Unit) | 12 APDU

Die Verweise am Ende dieses Artikels stellen weitere Informationen zu den von den einzelnen MTA-Kategorien protokollierten Daten bereit.

Die allgemein beste Verfahrensweise beim Diagnoseprotokoll besteht darin, das Protokoll für jede MTA-Kategorie auf Keine (0) festzulegen, vorausgesetzt, Sie sind nicht gerade mit einer Problembehandlung beschäftigt. Diese Empfehlung dient dazu, eine handhabbare Anzahl von zu protokollierenden Ereignissen zu verwalten. Selbst die Ebene Minimum (1) wird im Laufe von wenigen Tagen Hunderte von Ereignisprotokollen liefern, je nach der Kategorie, für die die Ebene festgelegt worden ist.

Wenn Sie nicht gerade mit einer Problembehandlung beschäftigt sind, wurden diese Werte möglicherweise bei einer Problembehebungsübung auf einen höheren Wert festgelegt und dann unbeabsichtigt beibehalten. Legen Sie die Protokollebene für jede MTA-Diagnoseprotokollkategorie auf Keine (0) fest.

So beheben Sie diesen Fehler in Exchange Server 2003 oder Exchange 2000 Server

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie in der Konsolenstruktur Server, erweitern Sie den gewünschten Server, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf <Server>Eigenschaften, klicken Sie auf die Registerkarte Diagnoseprotokoll.

  4. Unter Dienste, wählen Sie MSExchangeMTA aus.

  5. Für jeden Eintrag unter Kategorien legen Sie die Protokollebene auf Keine fest, indem Sie die Kategorie auswählen und dann unter Protokollebene die Option Keine auswählen.

  6. Wenn Sie alle Kategorien auf Keine festgelegt haben, klicken Sie auf Übernehmen, und klicken Sie dann auf OK.

So beheben Sie den Fehler unter Exchange Server, Version 5.5

  1. Starten Sie das Programm Microsoft Exchange Server-Administrator.

  2. Öffnen Sie das Objekt, das den Server darstellt, bei dem Probleme mit dem MTA aufgetreten sind.

  3. Doppelklicken Sie im rechten Bereich auf Message Transfer Agent-Objekt.

  4. Auf der Registerkarte Diagnoseprotokoll, wählen Sie X.400-Dienst aus und klicken dann auf Maximum.

  5. Wählen Sie Ressource aus.

  6. Halten Sie die STRG-Taste gedrückt, und klicken Sie dann auf jede Ressource, die Sie debuggen möchten.

  7. Klicken Sie auf Option für die Protokollebene Keine.

  8. Klicken Sie auf OK.

Weitere Informationen über MTA-Diagnoseprotokolle auf Exchange 2000 Server finden Sie im Artikel 163033 der Microsoft Knowledge Base „XCON: Description of Diagnostics Categories for MTA" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163033.

Weitere Informationen zum Rollback erweiterter Protokolle unter Exchange 5.5 Server finden Sie im Microsoft Knowledge Base-Artikel 168906, „XCON: Setting up Advanced Logging on the Exchange 5.0 and 5.5 MTAs" (http://go.microsoft.com/fwlink/?Linkid=3052&kbid=168906).

Weitere Informationen zu MTA-Diagnoseprotokollen unter Exchange Server 5.5 finden Sie im Knowledge Base-Artikel 163032, „XCON: Description of Diagnostics Categories for MTA" (http://go.microsoft.com/fwlink/?Linkid=3052&kbid=163032).


Der MTA-Parameter „Dispatcher threads" weicht vom Standardwert ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Fehlermeldung

Einführung

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um seinen aktuellen Wert zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Dispatcher threads

Wenn Microsoft Exchange Server Analyzer ermittelt, dass der Wert für Dispatcher threads vorhanden, größer als 0 und ungleich 1 oder 2 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert Dispatcher threads entspricht der Anzahl der MTA-Dispatcher-Threads. Dieser Wert wird für die drei Untertypen (Router, Fanout, Result) des Dispatcher-Threads mit 3 multipliziert. Ein Anlass zum Ändern dieses Werts kann gegeben sein, wenn ein MTA mit mehr als 5 Computern, auf denen Exchange Server, Version 5.5, ausgeführt wird, innerhalb eines Standorts oder zwischen Standorten kommuniziert oder wenn die Verteilerlisten stark beansprucht werden. In diesem Fall empfiehlt es sich, den Wert auf 3 zu ändern. Wenn der MTA diesem Kriterium nicht entspricht, sollten Sie den Wert zurück auf den Standardwert 1 ändern.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Suchen Sie im rechten Bereich den Wert Dispatcher threads, und doppelklicken Sie darauf.

  4. Geben Sie im Datenfeld Wert den Wert 1 ein, und klicken Sie anschließend auf OK.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Dienst Microsoft Exchange MTA-Stacks neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


MTA wird nicht unter dem Konto „LocalSystem" ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) Win32_Service ab, um den Wert des Schlüssels StartName für den Dienst Microsoft Exchange MTA-Stacks zu ermitteln. Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für jedes ExchangeServer-Objekt im Verzeichnis zu ermitteln. Das Attribut serialNumber auf dem Exchange Server-Objekt ermittelt die Version von Exchange Server, die auf dem durch das Objekt dargestellten Computer ausgeführt wird. Wenn auf einem Exchange Server unter Exchange 2000 Server oder Exchange Server 2003 der Wert für StartName nicht LocalSystem ist, wird ein Fehler angezeigt.

Das Ausführen des Diensts Exchange MTA-Stacks unter einem anderen Konto führt zu Berechtigungs- und Zugriffsfehlern und zählt nicht zu den unterstützten Konfigurationen.

Um diesen Fehler zu beheben, müssen Sie den Dienst Exchange MTA-Stacks so konfigurieren, dass er unter dem Konto LocalSystem (auch SYSTEM) startet.

Hinweis:
Dieser Fehler bezieht sich nicht auf Exchange Server, Version 5.5. Das Ausführen des Dienstes Exchange MTA-Stacks unter dem Konto LocalSystem ist nur für Exchange 2000 Server und Exchange Server 2003 erforderlich.

So konfigurieren Sie das Konto für den Dienst „Exchange MTA-Stacks"

  1. Öffnen Sie das MMC-Snap-In (Microsoft Management Console) Dienste.

  2. Suchen Sie den Dienst Microsoft Exchange MTA-Stacks, und beenden Sie ihn.

  3. Doppelklicken Sie auf den Dienst Microsoft Exchange MTA-Stacks.

  4. Wählen Sie auf der Eigenschaften von Microsoft Exchange MTA-Stacks auf der Registerkarte Anmelden unter Anmelden als das Konto LocalSystem aus, und klicken Sie dann auf Übernehmen.

  5. Klicken Sie unter Dienststatus auf Start, und klicken Sie dann auf OK.

  6. Schließen Sie das Snap-In Dienste.

Weitere Informationen über das Ausführen von Exchange-Diensten unter dem Konto LocalSystem finden Sie im Microsoft Knowledge Base-Artikel 239762, „Exchange Services Run Under LocalSystem" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762.


Der MTA-Parameter „Kernel threads" weicht vom Standardwert ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um seinen aktuellen Wert zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Kernel threads

Stellt Exchange Server Analyzer fest, dass der Wert für Kernel threads vorhanden und größer als 0, aber ungleich 1 oder 3 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert Kernel threads entspricht der Anzahl von Plattform-Threads, die die Präsentations- und Sitzungsstufe des OSI-Stapels (Open Systems Interconnection) ausführen. Diese Threads bilden den Kern der MTA-Nachrichtenverarbeitung (Message Transfer Agent). Wenn dieser MTA mit vielen anderen Exchange Servern, Version 5.5, kommuniziert und dazu RPC (Remote Procedure Call) über langsame oder hochgradig latente Netzwerkverbindungen verwendet, wird empfohlen, einen Wert zu verwenden, der in der folgenden Tabelle aufgelistet ist.

Wert | Beschreibung
0x3 (hexadezimal) | Standardempfehlung. Verwenden Sie diesen Wert für alle MTAs, die mit anderen Exchange Server 5.5-Servern unter Verwendung von RPC über langsame oder hochgradig latente Netzwerkverbindungen kommunizieren.
0x8 (hexadezimal) | Verwenden Sie diesen Wert für Exchange 2000 Server- oder Exchange Server 2003-MTAs, die zu einem Standort gehören, an dem mehr als 15 Exchange Server 5.5-Computer vorhanden sind.
0xC (hexadezimal) | Verwenden Sie diesen Wert für Exchange 2000 Server- oder Exchange Server 2003-MTAs, die zu einem Standort gehören, an dem mehr als 30 Exchange Server 5.5-Computer vorhanden sind.
Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Bearbeiten der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So konfigurieren Sie den Wert „Kernel Threads"

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Suchen Sie im rechten Bereich den Wert Kernel threads, und doppelklicken Sie darauf.

  4. Geben Sie im Datenfeld Wert den für Ihre Organisation geeigneten Wert ein, und klicken Sie auf OK.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Dienst Microsoft Exchange MTA-Stacks neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://support.microsoft.com/?scid=kb%3Bde%3B256986&x=2&y=12, der weitere Informationen zum Bearbeiten der Registrierung enthält.


MTA-Parameter „LAN-MTAs" entspricht nicht dem Standardwert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um seinen aktuellen Wert zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\LAN-MTAs

Wenn Microsoft Exchange Server Analyzer Tool erkennt, dass der Wert für LAN-MTAs vorhanden und ungleich 20 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert für LAN-MTAs stellt die Anzahl der von MTA unterstützten MTAs (Network Message Transfer Agents) dar. Es wird empfohlen, für diesen Registrierungseintrag den Wert 20 zu verwenden.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Suchen Sie im rechten Bereich den Wert LAN-MTAs, und doppelklicken Sie darauf.

  4. Geben Sie im Datenfeld Wert den Wert 20ein, und klicken Sie anschließend auf OK.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Dienst Microsoft Exchange MTA-Stacks neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Der MTA-Parameter „MDB users" weicht vom Standardwert ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um seinen aktuellen Wert zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\MDB users

Wenn Microsoft Exchange Server Analyzer ermittelt, dass der Wert für MDB users vorhanden und ungleich 500 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert MDB users gibt die maximale Anzahl von MDB-Benutzern (Message Database) an, die vom MTA (Message Transfer Agent) unterstützt werden. In der Standardeinstellung sind alle Benutzer von Exchange Server MDB-Benutzer, sofern für sie nicht explizit eine andere Einstellung festgelegt wurde.

Der Registrierungswert MDB users definiert die Anzahl von DNs (Distinguished Names), die aus dem Verzeichnis zwischengespeichert werden sollen. Wenn Ihre Organisation mehr als 1500 Benutzer umfasst, legen Sie den Wert auf ein Drittel der Größe der globalen Adressliste fest, wobei die maximale Anzahl nicht mehr als 5000 betragen sollte.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diesen Fehler

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Suchen Sie im rechten Bereich den Wert MDB users, und doppelklicken Sie darauf.

  4. Geben Sie im Datenfeld Wert den Wert 500 ein, und klicken Sie anschließend auf OK.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Dienst Microsoft Exchange MTA-Stacks neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Der MTA-Parameter „Max RPC calls outstanding" weicht vom Standardwert ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um seinen aktuellen Wert zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Max RPC Calls Outstanding

Wenn Exchange Server Analyzer feststellt, dass der Wert für Max RPC Calls Outstanding vorhanden und ungleich 50 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert Max RPC Calls Outstanding stellt die maximale Anzahl der RPC-Threads (Remoteprozeduraufruf, RPC) dar. Durch diesen Wert wird die maximale Anzahl der Remoteprozeduraufrufe begrenzt, die gleichzeitig verarbeitet werden. Dieser Wert wird von RpcServerUseAllProtSeqs() und RpcServerListen() verwendet.

In Szenarios mit gemischten Modellen, in denen Computer mit Exchange 2000 Server und/oder Exchange Server 2003 zusammen mit Exchange Server 5.5-Computern verwendet werden und in denen die Anzahl der E/A-Threads für das Gateway im Prozess Store.exe erhöht wurde, empfiehlt es sich, den Wert auf 0x80 (Hexadezimalwert) oder 128 (Dezimalwert) zu erhöhen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Suchen Sie im rechten Bereich den Wert Max RPC Calls Outstanding, und doppelklicken Sie darauf.

  4. Geben Sie im Datenfeld Wert den Wert 50 ein, und klicken Sie auf OK.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Dienst Microsoft Exchange MTA-Stacks neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


MTA-Parameter „Min RPC threads" weicht vom Standardwert ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Fehlermeldung

Einführung

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um seinen aktuellen Wert zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Min RPC Threads

Wenn Microsoft Exchange Server Analyzer ermittelt, dass der Wert für Min RPC Threads vorhanden und ungleich 4 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert Min RPC Threads gibt die Mindestanzahl der RPC-Threads (Remote Procedure Call - Remoteprozeduraufruf) an. Dies kennzeichnet die Mindestanzahl von Thread-Aufrufen. Dieser Wert wird von RpcServerListen() verwendet. Im Allgemeinen sollten Sie diesen Registrierungswert nicht ändern, sondern die Standardeinstellung beibehalten.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diesen Fehler

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Suchen Sie im rechten Bereich den Wert Min RPC Threads, und doppelklicken Sie darauf.

  4. Geben Sie im Datenfeld Wert den Wert 4 ein, und klicken Sie anschließend auf OK.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Dienst Microsoft Exchange MTA-Stacks neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Der MTA-Parameter „RTS threads" weicht vom Standardwert ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um seinen aktuellen Wert zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\RTS threads

Wenn Microsoft Exchange Server Analyzer ermittelt, dass der Wert für RTS threads vorhanden, größer als 0 und nicht gleich 1 oder 3 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert RTS threads entspricht der Anzahl von Plattform-Threads, die die RTSE-Stufe (Reliable Transfer Service Element) des OSI-Stapels (Open Systems Interconnection) ausführen. RTS-Threads sind dafür verantwortlich, Daten an die Warteschlangen weiterzugeben. Wenn dieser MTA (Message Transfer Agent) mit mehreren Exchange Server 5.5-Computern entweder innerhalb eines Standorts oder zwischen Standorten kommuniziert, sollten Sie den Registrierungswert RTS threads vom Standardwert 1 in einen Wert von 3 ändern.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So optimieren Sie den Registrierungswert „RTS threads"

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Suchen Sie im rechten Bereich den Wert RTS threads, und doppelklicken Sie darauf.

  4. Geben Sie im Datenfeld Wert den geeigneten Wert ein (1 oder 3), und klicken Sie auf OK.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Dienst Microsoft Exchange MTA-Stacks neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://support.microsoft.com/?scid=kb%3Bde%3B256986&x=2&y=12, der weitere Informationen zum Bearbeiten der Registrierung enthält.


MTA-Dienst ist nicht aktiv.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-02-19

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) Win32_Service ab, um zu bestimmen, ob der Schlüssel Started für die folgenden Dienste auf True oder False festgelegt ist:

  • Microsoft Exchange MTA-Stacks

  • Clusterdienst

Der Wert False gibt an, dass der Dienst auf diesem Exchange Server-Computer nicht ausgeführt wird. Der Wert True gibt an, dass der Dienst ausgeführt wird.

Microsoft Exchange Server Analyzer überprüft auch die WMI-Klasse Exchange_Server im Namespace root\MicrosoftExchangeV2, um den Wert für den Schlüssel IsFrontEndServer zu bestimmen. Der Wert False gibt an, dass der Exchange Server-Computer kein Front-End-Server ist. Der Wert True zeigt an, dass der Exchange Server-Computer ein Front-End-Server ist.

Wenn der Wert für alle drei ausgewerteten Schlüssel False ist, wird eine Warnung angezeigt.

Es wird empfohlen, dass auf allen Exchange Server-Computern, die Nachrichten weiterleiten, der Dienst Exchange MTA-Stacks bereits gestartet wurde. Dies ist besonders wichtig in einer Umgebung mit gemischtem Modus, in der Nachrichten zwischen Exchange Server, Version 5.5, und Exchange Server 2003 und/oder Exchange 2000 Server übertragen werden. Außerdem benötigt jeder X.400-Connector den Dienst Exchange MTA-Stacks. Daher führt das Deaktivieren des Diensts zu Fehlern, und es kommt u. U. zu Fehlfunktionen. Für das Verschieben von Postfächern muss ebenfalls der Dienst Exchange MTA-Stacks gestartet werden.

Um diese Warnung zu beheben, starten Sie den Dienst Exchange MTA-Stacks.

So starten Sie den Dienst „Microsoft Exchange MTA-Stacks"

  1. Klicken Sie im Menü Start auf Programme, Verwaltung und dann auf das MMC-Snap-In Dienste (Microsoft Management Console).

  2. Klicken Sie mit der rechten Maustaste auf den Dienst Microsoft Exchange MTA-Stacks, und klicken Sie dann auf Eigenschaften.

  3. Vergewissern Sie sich, ob auf der Eigenschaftenseite Microsoft Exchange MTA-Stacks auf der Registerkarte Allgemein für Starttyp die Option Automatisch festgelegt ist. Wenn das nicht zutrifft, klicken Sie auf Übernehmen und dann auf OK.

  4. Klicken Sie mit der rechten Maustaste auf den Dienst Microsoft Exchange MTA-Stacks, und klicken Sie dann auf den Befehl zum Starten.

  5. Schließen Sie das Snap-In Dienste.

Weitere Informationen zum Ausführen des Diensts Microsoft Exchange MTA-Stacks in einer Exchange-Umgebung im gemischtem Modus finden Sie im Microsoft Knowledge Base-Artikel 810489 „MTA Stacks service supportability guidelines for Exchange 2000 and Exchange 2003" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810489.


MTA-Dienst ist auf „Disabled" festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation -Windows®-Verwaltungsinstrumentation) Win32_Service ab, um den Wert für den Schlüssel StartMode zu bestimmen, der für den Dienst Microsoft Exchange MTA-Stacks festgelegt ist. Der Wert Disabled zeigt an, dass der Dienst Microsoft Exchange MTA-Stacks deaktiviert wurde und nicht gestartet werden kann, bevor der StartMode-Wert auf entweder Manual oder Automatic geändert wird.

Exchange Server Analyzer fragt außerdem die WMI-Klasse Win32_Service ab, um den Wert des Schlüssels Started für den SMPT-Dienst (Simple Mail Transfer Protocol) zu ermitteln. Der Wert False gibt an, dass der Dienst nicht ausgeführt wird. Der Wert True gibt an, dass der Dienst ausgeführt wird.

Abschließend fragt Exchange Server Analyzer die WMI-Klasse Win32_OperatingSystem ab, um den Wert des Schlüssels OSProductSuite zu ermitteln. Der Wert dieses Schlüssels entspricht einer bestimmten Version des Betriebssystems Microsoft Windows Server™ 2003.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel StartMode auf einem Exchange Server-Computer, auf dem der SMTP-Dienst gestartet wurde, auf Disabled festgelegt ist, und dass der Exchange Server-Computer nicht Teil einer Microsoft® Windows® Small Business Server 2003-Installation ist, wird eine Warnung angezeigt.

Wenn der Server nicht Bestandteil einer Installation von Microsoft Windows Small Business Server 2003 ist oder sich in einer reinen Exchange Server 2003-Umgebung im einheitlichen Modus befindet, muss bei allen Exchange Server-Computern, die Nachrichten routen, der Dienst Microsoft Exchange MTA-Stacks auf Automatic festgelegt werden. Durch das Routen von Nachrichten auf einem Server, auf dem der Dienst Exchange MTA-Stacks deaktiviert ist, werden möglicherweise mehrere verschiedene Fehlermeldungen verursacht. In einigen Fällen werden Fehler protokolliert, wenn Sie unter Exchange 2000 Server oder Exchange Server 2003 arbeiten und gleichzeitig noch Exchange Server, Version 5.5, ausgeführt wird. Außerdem benötigt jeder X.400-Connector den Dienst Exchange MTA-Stacks. Daher führt das Deaktivieren des Diensts zu Fehlern, und es kommt u. U. zu Fehlfunktionen.

Hinweis:
Außer bei direkter Verbindung mit externen X.400-E-Mail-Systemen oder beim Ausführen von Connectors für Exchange Development Kit (EDK), z. B. Novell GroupWise-Connector, Lotus Notes-Connector oder Fax-Connectors eines Drittanbieters, wurden in Exchange Server 2003 die Abhängigkeiten vom Dienst MTA Stacks beseitigt. Somit werden von Microsoft nunmehr reine Exchange Server 2003-Bereitstellungen im einheitlichen Modus unterstützt, in denen der Dienst MTA Stacks deaktiviert ist.

Um diesen Fehler zu beheben, müssen Sie den Dienst Microsoft Exchange MTA-Stacks so konfigurieren, dass er auf Servern, die Nachrichten routen, automatisch gestartet wird.

So konfigurieren Sie den Dienst „Microsoft Exchange MTA-Stacks" zum automatischen Starten

  1. Öffnen Sie das MMC-Snap-In (Microsoft Management Console) Dienste.

  2. Doppelklicken Sie auf den Dienst Microsoft Exchange MTA-Stacks.

  3. Wählen Sie auf der Seite Eigenschaften von Microsoft Exchange MTA-Stacks auf der Registerkarte Allgemein im Dropdown-Dialogfeld Starttyp die Option Automatisch aus, und klicken Sie dann auf Übernehmen.

  4. Klicken Sie unter Serverstatus auf Start, und klicken Sie dann auf OK.

  5. Schließen Sie das Snap-In Dienste.

Weitere Informationen zum Aufrechterhalten des Diensts Microsoft Exchange MTA Stacks unter Exchange finden Sie im Microsoft Knowledge Base-Artikel 810489, „MTA Stacks service supportability guidelines for Exchange 2000 Server and Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810489).


MTA-Parameter „Submit/deliver threads" weicht vom Standardwert ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um seinen aktuellen Wert zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\ Submit/deliver threads

Wenn Microsoft Exchange Server Analyzer ermittelt, dass der Wert für Submit/deliver threads vorhanden und ungleich 2 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert Submit/deliver threads entspricht der Anzahl von MTA-Threads zum Absenden/Übermitteln. Der MTA verwendet diese Threads zum Weitergeben von Nachrichten an den Informationsspeicher. Auf einigen Exchange Server 5.5-Computern ist es möglich, dass dieser Wert durch den Exchange Performance Optimizer von seinem Standardwert 2 automatisch auf einen Wert festgelegt wird, der für den Exchange-Server besser geeignet ist.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Bearbeiten der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Suchen Sie im rechten Bereich den Wert Submit/deliver threads, und doppelklicken Sie darauf.

  4. Stellen Sie sicher, dass im Feld Wert der Wert 2 eingegeben ist, und klicken Sie dann auf OK.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Dienst Microsoft Exchange MTA-Stacks neu, damit die Änderung wirksam wird.

Auf Exchange 2000 Server- und Exchange Server 2003-Computern sollte der Wert für diesen Eintrag nicht größer als 3 sein. Für Exchange Server 5.5-Computer können Sie alternativ zur beschriebenen Vorgehensweise den Exchange Performance Optimizer im ausführlichen Modus ausführen (perfwiz.exe -v) und mit diesem Tool den Wert ändern.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://support.microsoft.com/?scid=kb%3Bde%3B256986&x=2&y=12, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zu Situationen, in denen der MTA-Registrierungswert Submit/deliver threads von seinem Standardwert abweichend festgelegt werden sollte, finden Sie in den folgenden Knowledge Base-Artikeln:

  • 234280, „XCON: How to Increase the Ability of the MTA to Pass Mail over Slow Network Connections" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=234280.

  • 265186, „XCON: MTA Fanout Slows on Multiprocessor Servers and Messages Back Up in Information Store" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=265186.

  • 234702, „XGEN: MTA Queue to Information Store Processing Slowly" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=234702.

  • 327260, „MTA slows down or stalls in Exchange Server 5.5 and messages back up in the private information store" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=327260.

  • Weitere Informationen zur Verwendung des Exchange Performance Optimizer im ausführlichen Modus finden Sie im Knowledge Base-Artikel 246125 „XADM: Exchange Server 5.5 Performance Optimizer Verbose Mode" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=246125.


Der Parameter „MTA TCP/IP control blocks" weicht vom Standardwert ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Fehlermeldung

Einführung

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um seinen aktuellen Wert zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\TCP/IP control blocks

Wenn MicrosoftMicrosoft Exchange Server Analyzer ermittelt, dass der Wert für TCP/IP control blocks vorhanden und nicht auf 20 festgelegt ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert für TCP/IP control blocks stellt die maximale Anzahl der gleichzeitig unterstützten RFC1006-Verbindungen (TCP/IP) dar. Die Einstellung steuert die Anzahl der für X.400-Verbindungen vorhandenen Puffer. Wenn der Message Transfer Agent (MTA) als Host für mehr als eine X.400-Connector dient, muss der Wert für TCP/IP-Kontrollblöcke angepasst werden. Für jeden gehosteten X.400-Connector sollten 10 Kontrollblöcke vorhanden sein, und ein Kontrollblock für den Service eingehender Verbindungen. Der geeignete Wert für ein System mit drei X.400-Verbindungen ist daher 33.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So konfigurieren Sie den Wert für TCP/IP-Kontrollblöcke

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Suchen Sie im rechten Bereich den Wert TCP/IP control blocks, und doppelklicken Sie darauf.

  4. Geben Sie im Datenfeld Wert den für diesen MTA geeigneten Wert ein, und klicken Sie auf OK.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Dienst Microsoft Exchange MTA-Stacks neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


MTA-Parameter „TCP/IP threads" weicht vom Standardwert ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Fehlermeldung

Einführung

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um seinen aktuellen Wert zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\TCP/IP threads

Wenn Microsoft Exchange Server Analyzer ermittelt, dass der Wert für TCP/IP threads vorhanden und ungleich 2 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert für TCP/IP threads gibt die maximale Anzahl der MTA DMOD-Threads (MTA, Message Transfer Agent; DMOD, Dynamic Address Module) an, die RFC1006-Verbindungen verarbeiten. Diese Zahl wird für die beiden Untertypen (Driver und Async Notify) von RFC1006-Threads mit 2 multipliziert. Auf X.400-Bridgeheadservern mit Verzeichnisreplikation und dedizierten Servern für Öffentliche Ordner, die eine große Anzahl von Verbindungen verwalten, empfiehlt es sich, dass der Standardwert von 2 in einen Wert von 10 geändert wird.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Bearbeiten der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So konfigurieren Sie den Wert für „TCP/IP threads"

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Suchen Sie im rechten Bereich den Wert TCP/IP threads, und doppelklicken Sie darauf.

  4. Geben Sie im Datenfeld Wert den geeigneten Wert ein, und klicken Sie auf OK.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Dienst Microsoft Exchange MTA-Stacks neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Der MTA-Parameter „Transfer threads" weicht vom Standardwert ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Fehlermeldung

Einführung

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um seinen aktuellen Wert zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Transfer threads

Wenn Exchange Server Analyzer feststellt, dass der Wert für Transfer threads vorhanden und größer als 0, aber ungleich 1 oder 2 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert Transfer threads entspricht der Anzahl der MTA-Transfer-Threads (Message Transfer Agent). Er wird für die beiden Untertypen (Transfer In und Transfer Out) des jeweiligen Transfer-Threads mit zwei multipliziert. Das Ergebnis entspricht dem Wert Submit/deliver threads (der sich auf den MTA und die Nachrichtenübertragung des Informationsspeichers bezieht), gilt aber für Gateways und MTAs. Weitere Informationen zum Wert Submit/deliver threads finden Sie unter MTA-Parameter „Submit/deliver threads" weicht vom Standardwert ab..

Wenn es sich um einen Exchange 2000 Server- oder um einen Exchange Server 2003-MTA handelt, der mit mehr als einem Exchange Server-Computer, Version 5.5, innerhalb einer Site oder zwischen mehreren Sites kommuniziert, wird empfohlen, den Wert für Transfer threads auf 3 festzulegen.

Auf einigen Exchange Server 5.5-Computern ist es möglich, dass dieser Wert durch den Exchange Performance Optimizer von seinem Standardwert 2 automatisch auf einen Wert festgelegt wird, der für den Exchange Server-Computer besser geeignet ist.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So konfigurieren Sie den Wert „Transfer threads"

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Suchen Sie im rechten Bereich den Wert Transfer threads, und doppelklicken Sie darauf.

  4. Geben Sie im Datenfeld Wert den geeigneten Wert ein, und klicken Sie auf OK.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Dienst Microsoft Exchange MTA-Stacks neu, damit die Änderung wirksam wird.

Auf Exchange 2000 Server- und Exchange Server 2003-Computern sollte der Wert für diesen Eintrag nicht größer als 3 sein. Alternativ zur beschriebenen Vorgehensweise können Sie den Exchange Performance Optimizer im ausführlichen Modus ausführen (perfwiz.exe -v) und den Wert mit diesem Tool festlegen.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://support.microsoft.com/kb/256986/DE/).

Weitere Informationen zu Situationen, in denen der MTA-Registrierungswert Transfer threads abweichend vom Standardwert festgelegt werden sollte, finden Sie in den folgenden Knowledge Base-Artikeln:

  • 234280, „XCON: How to Increase the Ability of the MTA to Pass Mail over Slow Network Connections" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=234280.

  • 265186, „XCON: MTA Fanout Slows on Multiprocessor Servers and Messages Back Up in Information Store" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=265186.

  • 327260, „MTA slows down or stalls in Exchange Server 5.5 and messages back up in the private information store" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=327260.


Der MTA-Parameter „Transport threads" weicht vom Standardwert ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Fehlermeldung

Einführung

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um seinen aktuellen Wert zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Transport threads

Wenn Microsoft Exchange Server Analyzer ermittelt, dass der Wert für Transport threads vorhanden und ungleich 1 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert Transport threads entspricht der Anzahl der MTA-Transfer-Threads (Message Transfer Agent). Der Standardwert 1 reicht im Allgemeinen für Organisationen aus. Wenn Sie keine anderen Informationen vom technischen Support von Microsoft erhalten, sollten Sie die Einstellung dieses Wertes bei 1 belassen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So konfigurieren Sie den Wert „Transport threads"

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Suchen Sie im rechten Bereich den Wert Transport threads, und doppelklicken Sie darauf.

  4. Geben Sie im Datenfeld Wert den Wert 1 ein, und klicken Sie auf OK.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Dienst Microsoft Exchange MTA-Stacks neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Nachrichtenverfolgung deaktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-06

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob die messageTrackingEnabled-Eigenschaft des Serverobjekts auf TRUE (aktiviert) oder auf FALSE (deaktiviert) eingestellt ist.

Wenn Exchange Server Analyzer feststellt, dass die messageTrackingEnabled-Eigenschaft des Serverobjekts auf False eingestellt ist, wird ein Fehler angezeigt.

Die messageTrackingEnabled-Eigenschaft des Serverobjekts bestimmt den Status des Nachrichtenstatus für den Server.

Der Nachrichtenstatus protokolliert (sofern aktiviert) Informationen über den Absender, die E-Mail-Nachricht und den Nachrichtenempfänger. Sie können insbesondere Statistiken überprüfen, z. B. den Zeitpunkt des Sendens und des Empfangs der Nachricht, die Nachrichtengröße und -priorität sowie eine Liste der Empfänger der Nachricht. Sie können auch die Betreffzeile von E-Mail-Nachrichten protokollieren. Mit dem Nachrichtenstatus können Sie nach Nachrichten suchen, einschließlich Systemmeldungen, Nachrichten in öffentlichen Ordnern und E-Mail-Nachrichten.

Sie müssen den Nachrichtenstatus auf allen Servern aktivieren, auf denen Sie Nachrichten verfolgen möchten. Sofern aktiviert, werden sämtliche über einen Server weitergeleiteten Nachrichten zu den Nachrichtenverfolgungsprotokollen hinzugefügt.

Die Nachrichtenverfolgung muss aktiviert sein, damit Exchange Server Analyzer seine Prüfungen beginnen kann.

Hinweis:
Zur Durchführung dieses Verfahrens benötigen Sie folgende Berechtigungen: Mitglied der lokalen Administratorgruppe und einer Gruppe, der die Funktion Exchange-Administrator auf der Ebene der administrativen Gruppen zugewiesen ist
So aktivieren Sie den Nachrichtenstatus auf einem Server

  1. Erweitern Sie im Exchange-System-Manager Server, klicken Sie mit der rechten Maustaste auf den Server, für den Sie die Nachrichtenverfolgung aktivieren möchten, und klicken Sie dann auf Eigenschaften.

  2. Aktivieren Sie auf der Registerkarte Allgemein das Kontrollkästchen Nachrichtenverfolgung aktivieren.

  3. Aktivieren Sie das Kontrollkästchen Nachrichtenbetreff protokollieren und anzeigen, um die Betreffzeile aufzuzeichnen, die an, von oder über einen Server gesendet wurde.

    Hinweis:
    Wenn Sie die Protokollierung des Betreffs aktivieren, kann die Leistung beeinträchtigt werden.

  4. Unter Wartung der Protokolldateien können Sie festlegen, wie lange Protokolle gespeichert werden und ob die Protokolldateien entfernt werden. Die Standardeinstellung für den Speicherzeitraum ist sieben Tage.

    Hinweis:
    Auf Servern, die große Mengen an E-Mail-Nachrichten verarbeiten, nimmt die Größe der Verfolgungsprotokolle schnell zu. Stellen Sie sicher, dass genügend freier Speicherplatz für die Protokolldateien und andere Dienste oder Anwendungen zur Verfügung steht.

  5. Klicken Sie auf OK oder auf Übernehmen. Sie müssen die Dienste neu starten, damit die Änderungen übernommen werden.

Weitere Informationen zur Verwendung des Nachrichtenstatus finden Sie im Microsoft Knowledge Base-Artikel 262162, "XADM: Verwenden des Nachrichtenstatus, um eine Nachricht zu verfolgen" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162)

Weitere Informationen zur Behandlung von Exchange Server-Transportproblemen finden Sie im Microsoft Knowledge Base-Artikel 821910, "Beheben von Transportproblemen mit Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821910).


Nachrichtenverfolgungsprotokolle werden in einen komprimierten Ordner geschrieben.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-17

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_Directory ab, um den Wert für den Schlüssel Compressed für den Dateipfad der Nachrichtenverfolgungsprotokolle zu ermitteln. Wenn Exchange Server Analyzer ermittelt, dass der Schlüssel Compressed den Wert True aufweist, wird ein Fehler angezeigt.

Wenn die Nachrichtenverfolgung auf einem Exchange 2000 Server- oder Exchange Server 2003-Computer aktiviert ist, werden die Verfolgungsprotokolle in den folgenden Standardspeicherort geschrieben:

<Laufwerk> :\Programme\Exchsrvr\ ServerName .log

Dabei steht <Laufwerk> für das Laufwerk mit dem Pfad \Programme\Exchsrvrn und Servername stellt den Hostnamen des Exchange Server-Computers dar.

Das Speichern von Exchange-Datendateien auf einem NTFS-komprimierten Datenträger wird von Microsoft nicht unterstützt. Wenn Sie Ihre Exchange-Datendateien auf einem komprimierten Datenträger speichern, beeinträchtigt der zusätzliche Aufwand die Leistung von Exchange erheblich. Wenn die Informationsspeicher-Datenbank eine bestimmte Größe (etwa 4 GB) erreicht, kann sie möglicherweise nicht bereitgestellt werden oder fehlerhaft sein.

Zu den Exchange-Datendateien gehören folgende Dateien:

  • EDB-Dateien

  • STM-Dateien

  • LOG-Dateien

  • DAT-Dateien

  • EML-Dateien

  • CHK-Dateien

Dateien, die mit ESE (Extensible Storage Engine) verwaltet werden, können nicht auf einem komprimierten Laufwerk gespeichert werden. Die ESE hängt von der Sektorunabhängigkeit für protokollbasierte Wiederherstellung ab, und durch die Komprimierung von Dateien wird die Sektorunabhängigkeit ungültig gemacht. Die Komprimierung sollte für Datenträger deaktiviert werden, die als Host für ESE-Datenbanken oder für Write-Ahead-Logging verwendende Datenbanken dienen.

Vor Exchange 2000 Server Service Pack 3 war die Bereitstellung komprimierter Informationsspeicher-Datenbanken möglich. Allerdings können in allen Informationsspeicher-Datenbanken oder Informationsspeicher-Protokollen von Exchange 2000 Server, die mit NTFS-Komprimierung komprimiert wurden, Beschädigungen auftreten.

Unter Exchange 2000 Server Service Pack 3 werden komprimierte Informationsspeicher-Datenbankdateien mit einer Größe von 128 Megabyte (MB) oder geringer automatisch dekomprimiert. Wenn Datenbankdateien eine Größe von 128 MB überschreiten, kann die Datenbank nicht bereitgestellt werden, und in der Anwendungsprotokollierung werden Fehlermeldungen erzeugt. Unter Exchange 2000 Server Service Pack 3 können komprimierte Datenbanken mit einer Größe von mehr als 128 MB nicht bereitgestellt werden.

So deaktivieren Sie die Dateikomprimierung für einen bestimmten Ordner

  1. Klicken Sie mit der rechten Maustaste auf den Ordner, für den Sie die Dateikomprimierung deaktivieren möchten, und klicken Sie dann auf Eigenschaften.

  2. Klicken Sie auf der Registerkarte Allgemein auf Erweitert.

  3. Deaktivieren Sie im Dialogfeld Erweiterte Attribute das Kontrollkästchen Inhalt komprimieren, um Speicherplatz zu sparen, und klicken Sie dann auf OK.

Als Alternative zum zuvor beschriebenen Vorgang können Sie die Protokolldateien für die Nachrichtenverfolgung auch in einen anderen, nicht komprimierten Ordner verschieben. Weitere Informationen zum Verschieben der Protokolldateien für die Nachrichtenverfolgung finden Sie in den folgenden Artikeln in der Microsoft Knowledge Base:

  • 84103, „How to change the location of the message tracking logs in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=841089).

  • 317700, „How to change the location of the message tracking logs in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700).

Weitere Informationen zu Exchange-Datendateien und NTFS-Komprimierung finden Sie in den folgenden Knowledge Base-Artikeln:

  • 170009, „XADM: NTFS Compressed Volume Causes Store to Fail" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=170009)

  • 327772, „XADM: Database Does Not Mount and You Receive Error 0xfffff05b After You Apply SP3" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=327772.


Protokolle zur Nachrichtenverfolgung werden in eine Nicht-NTFS-Partition geschrieben.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Directory ab, um den Wert für den Schlüssel FSName für den Dateipfad der Nachrichtenverfolgungsprotokolle in Exchange zu ermitteln. Wenn Exchange Server Analyzer ermittelt, dass der Wert für den Schlüssel FSName nicht NTFS ist, wird ein Fehler angezeigt.

Das Speichern von Exchange-Datendateien auf einem Nicht-NTFS-Datenträger wird von Microsoft nicht unterstützt. Zu den Exchange-Datendateien gehören folgende Dateien:

  • EDB-Dateien

  • STM-Dateien

  • LOG-Dateien

  • DAT-Dateien

  • EML-Dateien

  • CHK-Dateien

Wenn dieser Fehler auftritt, müssen Sie die Nachrichtenverfolgungsprotokolle in einen Ordner auf einem NTFS-Laufwerk verschieben. Wenn das Laufwerk, auf dem die Nachrichtenverfolgungsprotokolle gespeichert sind, als FAT-Laufwerk formatiert ist, können Sie zum Konvertieren des Laufwerks in NTFS auch das Befehlszeilentool convert.exe verwenden.

So verschieben Sie Nachrichtenverfolgungsprotokolle in Exchange Server 2003

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Administrative Gruppen, erweitern Sie Ihre administrative Gruppe, erweitern Sie Server, klicken Sie mit der rechten Maustaste auf Ihren Server, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Allgemein auf Ändern.

  4. Geben Sie den neuen Pfad der Nachrichtenverfolgungsprotokolle ein, und klicken Sie auf OK.

  5. Klicken Sie auf OK.
Hinweis:
In der Standardeinstellung wird die Änderung des Speicherortes der Protokolldatei für Nachrichtenverfolgung um Mitternacht (UTC, Coordinated Universal Time) wirksam. Nachdem diese Änderung wirksam geworden ist, erstellt die Exchange-Nachrichtenverfolgungskomponente neue Protokolldateien an dem neuen von Ihnen angegebenen Speicherort. Frühere Protokolldateien werden jedoch nicht an den neuen Speicherort verschoben. Warten Sie daher so lange, bis die Änderung des Speicherortes der Protokolldatei wirksam wird, und verschieben Sie die Protokolldateien dann manuell vom alten Speicherort an den neuen Speicherort für Protokolldateien. Wenn der Microsoft Exchange-Systemaufsichtsdienst neu gestartet wird, wird der Pfad der Protokolldatei unmittelbar in den neuen Speicherort geändert. In diesem Szenario erstellt die Exchange-Nachrichtenverfolgung eine neue Protokolldatei am neuen Speicherort, wenn ein Benutzer eine Nachricht sendet. In diesem Szenario haben Sie eventuell zwei Protokolldateien mit demselben Namen: eine Protokolldatei am ursprünglichen Speicherort und eine Protokolldatei am neuen, von Ihnen angegebenen Speicherort. Wenn dies geschieht, benennen Sie die Protokolldatei um, die am ursprünglichen Speicherort für Protokolldateien gespeichert ist, bevor Sie sie an den neuen Speicherort für Protokolldateien verschieben. Verwenden Sie die gleichen Namenskonventionen, die von der Exchange-Nachrichtenverfolgung verwendet werden (jjjjmmtt). Verwenden Sie jedoch in diesem Fall ein früheres Datum als bei den bestehenden Protokolldateien, damit diese umbenannte Protokolldatei keine zukünftige Protokolldatei behindert.

Weitere Informationen zum Verschieben der Protokolldateien für die Nachrichtenverfolgung auf einem Computer, auf dem Exchange 2000 Server ausgeführt wird, finden Sie im Microsoft Knowledge Base-Artikel 317700 „How to change the location of the message tracking logs in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700).

Wenn das Laufwerk, auf dem die Dateien gespeichert sind, als FAT-Laufwerk formatiert ist, können Sie alternativ zur vorherigen Vorgehensweise zum Konvertieren des Laufwerks in NTFS auch das Befehlszeilentool convert.exe verwenden. Weitere Informationen zum Konvertieren einer FAT-Partition in eine NTFS-Partition mit dem Befehlszeilentool convert.exe finden Sie im Microsoft Knowledge Base-Artikel 214579 „Konvertieren einer Partition in NTFS mit "Convert.exe"" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579).


Nachrichtenverfolgungsprotokolle werden in einen verschlüsselten Ordner geschrieben.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Directory ab, um den Wert für den Schlüssel Encrypted für die Nachrichtenverfolgungsprotokolle zu ermitteln. Wenn der Wert für diesen Schlüssel True ist, wird ein Fehler angezeigt.

Wenn die Nachrichtenverfolgung auf einem Exchange 2000 Server- oder Exchange Server 2003-Computer aktiviert ist, werden die Verfolgungsprotokolle in den folgenden Standardspeicherort geschrieben:

<Laufwerk>:\Programme\Exchsrvr\ ServerName .log

wobei <Laufwerk> für das Laufwerk mit dem Pfad \Programme\Exchsrvr steht und Servername den Hostnamen des Exchange Server-Computers darstellt.

Microsoft unterstützt nicht das Speichern von Exchange-Datendateien auf verschlüsselten Datenträgern in verschlüsselnden Dateisystemen (Encrypting File Systems, EFS). Wenn Exchange-Datendateien auf einem verschlüsselten Datenträger gespeichert werden, beeinträchtigt der zusätzliche Aufwand die Leistung von Exchange erheblich. Zu den Exchange-Datendateien gehören folgende Dateien:

  • EDB-Dateien

  • STM-Dateien

  • LOG-Dateien

  • DAT-Dateien

  • EML-Dateien

  • CHK-Dateien

Um die Sicherheit der Exchange-Datendateien zu gewährleisten, empfiehlt es sich, den unbefugten Zugriff auf den Exchange-Computer zu verhindern und Nachrichtendaten mithilfe des S/MIME-Nachrichtenformats zu verschlüsseln.

So deaktivieren Sie die Dateiverschlüsselung für einen angegebenen Ordner

  1. Klicken Sie mit der rechten Maustaste auf den Ordner, für den Sie die Dateiverschlüsselung deaktivieren möchten, und klicken Sie dann auf Eigenschaften.

  2. Klicken Sie auf der Registerkarte Allgemein auf Erweitert.

  3. Deaktivieren Sie im Dialogfeld Erweiterte Attribute das Kontrollkästchen Inhalt verschlüsseln, um Daten zu schützen, und klicken Sie dann auf OK.

Als Alternative zum oben beschriebenen Verfahren können Sie die Protokolldateien für die Nachrichtenverfolgung auch in einen anderen, nicht verschlüsselten Ordner verschieben. Weitere Informationen über das Verschieben der Protokolldateien für die Nachrichtenverfolgung finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 841089, „How to change the location of the message tracking logs in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=841089).

  • 317700, „How to change the location of the message tracking logs in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700).


Kein Zugriff auf die Metabasis möglich
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-02-13

Microsoft® Exchange Server Analyzer versucht, verschiedene Eigenschaften der virtuellen SMTP-Serverinstanz (Simple Mail Transfer Protocol) über den IIS-Metabasispfad (Internet Information Services) abzufragen.

/LM/SmtpSvc/<virtuelle SMTP-Serverinstanz>

Exchange Server Analyzer zeigt einen Fehler an, wenn folgende Bedingungen zutreffen:

  • Die Metabasisabfrage schlägt fehl.

  • Exchange Server wird nicht auf Microsoft Windows NT® Server 4.0 ausgeführt.

Dieser Fehler weist darauf hin, dass Exchange Server Analyzer keine Verbindung zur IIS-Metabasis herstellen kann.

Die IIS-Metabasis enthält Informationen, die Exchange Server betreffen, z. B. Protokolleinstellungen für HTTP, virtuelle Verzeichnisse für den Zugriff auf Postfächer und mobile Geräte sowie HTTP-Sicherheitseinstellungen.

Um dieses Problem zu beheben, müssen Sie die Integrität der Metabasis überprüfen und sicherstellen, dass IIS ordnungsgemäß installiert ist.

Um zu prüfen, ob die Metabasis nicht beschädigt und IIS ordnungsgemäß installiert ist, lesen Sie die folgenden Quellen:

  • Microsoft Knowledge Base-Artikel 240225, "Beschreibung von Adsutil und MetaEdit-Dienstprogrammen, die verwandt werden, um die Metabasis zu ändern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240225).

  • Microsoft Knowledge Base-Artikel 317678 mit Informationen zum Neustarten von Internetinformationsdienste (IIS) in Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317678).

Wenn anhand der Anleitungen in diesen Quellen das Problem nicht behoben werden kann, müssen Sie Internetinformationsdienste (IIS) de- und anschließend neu installieren.

So deinstallieren Sie IIS über die Option "Software" in der Systemsteuerung

  1. Klicken Sie auf Start und dann auf Systemsteuerung.

  2. Doppelklicken Sie auf Software.

  3. Klicken Sie auf Windows-Komponenten hinzufügen/entfernen.

  4. Aktivieren Sie in der Liste Komponenten das Kontrollkästchen Anwendungsserver.

  5. Klicken Sie auf Details.

  6. Deaktivieren Sie Internetinformationsdienste-Manager.

  7. Klicken Sie auf Weiter.

  8. Klicken Sie auf Fertig stellen, wenn IIS installiert ist.
So installieren Sie ASP.NET über die Systemsteuerung

  1. Klicken Sie auf Start und dann auf Systemsteuerung.

  2. Doppelklicken Sie auf Software.

  3. Klicken Sie auf Windows-Komponenten hinzufügen/entfernen.

  4. Aktivieren Sie in der Liste Komponenten das Kontrollkästchen Anwendungsserver.

  5. Klicken Sie auf Details.

  6. Aktivieren Sie das Kontrollkästchen Internetinformationsdienste-Manager.

  7. Klicken Sie mehrfach auf OK, bis der Assistent für Windows-Komponenten wieder angezeigt wird.

  8. Klicken Sie auf Weiter, und schließen Sie den Assistenten für Windows-Komponenten ab.


Der Wert „MinUserDC" weicht vom Standardwert ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-02-08

Microsoft® Microsoft Exchange Server Analyzer liest die folgenden Registrierungseintra¨ge, um zu bestimmen, ob der als PDC-Emulator (Prima¨rer Doma¨nencontroller) eingesetzte Verzeichnisdienst-Doma¨nencontroller fu¨r Active Directory® manuell aus der Liste der fu¨r die Verwendung durch Exchange verfu¨gbaren Doma¨nencontroller ausgeschlossen wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

Wenn Exchange Server Analyzer feststellt, dass der Wert MinUserDC vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Bei einem PDC-Emulator handelt es sich um einen Active Directory-Betriebsmaster-Rollencomputer, der Replikationsanforderungen von Microsoft Windows NT® Server 4.0-Sicherungsdoma¨nencontrollern und alle Kennwortaktualisierungen fu¨r Clients verarbeitet, die keine Active Directory-kompatible Clientsoftware ausfu¨hren. Da es sich bei PDC-Emulatoren ebenfalls um Doma¨nencontroller handelt, ko¨nnen sie auch von Anwendungen, z. B. Exchange, verwendet werden.

Bei DSAccess (Directory Service Access) handelt es sich um eine interne Komponente von Exchange 2000 Server und Exchange Server 2003, die den Zugriff der Exchange-Komponenten auf Active Directory® steuert. Die prima¨re Funktion von DSAccess stellt das Verwalten von Informationen zu verschiedenen verzeichnisbezogenen Ereignissen und Vorga¨ngen dar. Beispielsweise ermittelt DSAccess die Active Directory-Topologie und stellt fest, ob Doma¨nencontroller und globale Katalogserver verfu¨gbar sind und auf Abfragen reagieren.

In der Standardeinstellung ist der PDC-Emulator-Computer in der Liste der verfu¨gbaren und verwendbaren Doma¨nencontroller von DSAccess enthalten. Wenn Programme, die keine Exchange-Programme sind, den PDC-Emulator in starkem Ausmaß verwenden, kann die Verwendung des PDC-Emulators durch DSAccess zu Leistungsproblemen auf dem PDC-Emulatorcomputer, dem Exchange-Server sowie den Computern fu¨hren, die nicht mit Exchange-Programmen kompatibel sind.

Um solche Leistungsprobleme zu vermeiden, kann der Registrierungswert MinUserDC zur Registrierung auf einem Exchange-Server hinzugefu¨gt werden, sodass DSAccess gezwungen ist, alle anderen verfu¨gbaren Doma¨nencontroller abzufragen, bevor der Doma¨nencontroller mit der PDC-Emulator-Betriebsmasterrolle abgefragt wird.

Hinweis:
Ein Exchange-Server, der mit dem Registrierungswert MiniUserDC konfiguriert ist, versucht, zuerst andere Server in derselben Doma¨ne zu verwenden. Deshalb ist es empfehlenswert, diese Konfiguration nur zu verwenden, wenn der Standort u¨ber mindestens zwei Doma¨nencontroller fu¨r die Doma¨ne verfu¨gt, in der sich die Exchange-Server befinden.
Wichtig:
Dieser Artikel entha¨lt Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie fu¨r den Fall eines Problems mit dem Wiederherstellungsprozess fu¨r die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So u¨berpru¨fen und bearbeiten Sie den Registrierungswert MinUserDC

  1. O¨ffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

  3. Suchen Sie den Wert MinUserDC, und nehmen Sie die erforderlichen A¨nderungen vor. Wenn dieser Wert DWORD nicht vorhanden ist, kann er manuell erstellt werden.

  4. Die fu¨r den Registrierungseintrag MinUserDC konfigurierten Datenwerte entsprechen der maximalen Anzahl der Doma¨nencontroller, die vor dem PDC-Emulator kontaktiert werden. Beispielsweise wird durch das Festlegen von MinUserDC auf 4 DSAccess konfiguriert, den PDC-Emulator nur dann auszuschließen, wenn vier Doma¨nencontroller verfu¨gbar sind. Bei Erfu¨llung dieser Bedingung wird der PDC-Emulator von der Verwendung ausgeschlossen, und DSAccess kommuniziert ausschließlich mit den drei verbleibenden Doma¨nencontrollern.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung entha¨lt.

Weitere Informationen zur Verwendung des Registrierungseintrags MinUserDC finden Sie im Knowledge Base-Artikel 298879, „XADM: Exchange 2000 May Experience Performance Problems When PDC Emulator Is Used for DSAccess" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=298879.


Es sind über 1000 Postfachspeicher vorhanden.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-12-13

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab und führt eine Zählung von Microsoft Exchange-Informationsspeicherobjekten mit der Objektklasse msExchPrivateMDB durch. Wenn Microsoft Exchange Server Analyzer erkennt, dass in einer Organisation mehr als 1.000 Postfachspeicher vorhanden sind, wird eine Warnung angezeigt.

Diese Warnung wird angezeigt, weil ein bekanntes Problem besteht, dass Benutzer in Organisationen mit mehr als 1.000 Postfachspeichern von Microsoft Office Outlook® Web Access 2003 aus über Front-End-Server nicht auf ihre Postfächer zugreifen können. Dieses Problem wird durch die Art und Weise verursacht, wie der Exchange Front-End-Server die Authentifizierungsanforderung auf dem Exchange-Back-End-Server zwischenspeichert.

Wenn Benutzer auf ihre Postfachspeicher von Exchange-Front-End-Servern aus zugreifen und diese Warnung angezeigt wird, müssen Sie eine der folgenden Aktionen durchführen:

  • Beschaffen und installieren Sie den Exchange Server-Hotfix, der im Microsoft Knowledge Base-Artikel 899902 „Users receive a 401 error message when they try to access a mailbox that is in an Exchange Server 2003 front-end server by using Outlook Web Access" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841561) beschrieben ist.

  • Fassen Sie, falls möglich, Postfächer in weniger Postfachspeichern zusammen.

  • legen Sie fest, dass sich die Front-End-Server mit Standardauthentifizierung bei den Back-End-Servern anmelden. Im Rest dieses Artikels wird diese Option erläutert.

Als Standard verwenden Exchange 2003 Server-Front-End-Server die Kerberos-Authentifizierung, um die Anmeldeinformationen der Benutzer zwischen den Front-End- und Back-End-Servern zu schützen. Wenn die Kerberos-Authentifizierung fehlschlägt, wird eine Warnung protokolliert, und der Front-End-Server verwendet stattdessen NTLM. Wen NTLM fehlschlägt, wird ein Fehler protokolliert. Die Kerberos-Authentifizierung wird nach 30 Minuten wiederholt. Wenn sich Exchange 2000 Server- oder Exchange Server 2003-Front-End-Computer bei Exchange 2000 Server-Back-End-Computern anmelden, wird NTLM verwendet. In IIS (Internetinformationsdienste - Internet Information Services) oder im Exchange-System-Manager ist keine Benutzeroberfläche zum Auswählen von Authentifizierungsverfahren vorhanden.

Zum Konfigurieren des Exchange-Front-End-Servers zur Verwendung von Standardauthentifizierung ist es erforderlich, dass Sie auf allen Front-End-Servern in Ihrer Organisation einen Registrierungsschlüssel festlegen. Nachfolgend wird das manuelle Festlegen des Schlüssels erläutert.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So konfigurieren Sie Exchange-Front-End-Server zur Verwendung von Standardauthentifizierung an Exchange-Back-End-Servern

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

    Navigieren Sie zu: = HKEY_LOCAL_MACHINE\System\CurrentControlSet\Service\MSExchangeWeb

  2. Klicken Sie mit der rechten Maustaste auf MSExchangeWeb, zeigen Sie auf Neu, und klicken Sie dann auf Schlüssel. Nennen Sie den neuen Schlüssel DAV.

  3. Klicken Sie mit der rechten Maustaste auf ParametersSystem, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  4. Nennen Sie den neuen Wert UseBasicAuthToBE, und legen Sie ihn auf 1 fest.

  5. Öffnen Sie das Dienste-MMC-Snap-In (Microsoft-Verwaltungskonsole - Microsoft Management Console). Klicken Sie mit der rechten Maustaste auf IIS-Verwaltungsdienst, und klicken Sie dann auf Neu starten.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://support.microsoft.com/?scid=kb%3Bde%3B256986&x=2&y=12, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Die meisten fortlaufenden store.exe-Aufrufe warten auf eine Antwort von ESE
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-13

Microsoft® Exchange Server Analyzer Tool untersucht das FCL-Protokoll (Function Call Log) von Exchange, die Datei Store.fcl, auf Ereignisse, die auf fortlaufende komponentenübergreifende Aufrufe des Microsoft Exchange-Informationsspeicherdienstes (Store.exe) an die Exchange ESE-Komponente (Extensible Storage Engine) hinweisen.

Fortlaufende Aufrufe sind Anforderungen vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an andere Komponenten, die noch keine Antwort erhalten haben, wenn die Exchange FCL-Daten in die Datei Store.fcl geschrieben werden.

Der Microsoft Exchange-Informationsspeicher befindet sich oberhalb einer ESE-Datenbank. ESE ist ein hochentwickeltes transaktionsbasiertes Datenbankmodul. Bei einer Transaktion handelt es sich um eine Folge von Operationen, die als unteilbare Einheit gelten. Entweder sind alle Operationen in einer Transaktion abgeschlossen und dauerhaft gespeichert, oder es werden keine Operationen durchgeführt.

In Exchange Server wird ESE als integriertes Datenbankmodul zum Festlegen der Struktur der Datenbanken sowie zum Verwalten des Arbeitsspeichers verwendet. Mit dem Datenbankmodul werden die Datenbanken im Arbeitsspeicher zwischengespeichert, indem 4-KB-Datenblöcke (Seiten) in und aus dem Arbeitsspeicher übertragen werden. Die Seiten werden im Arbeitsspeicher aktualisiert. Anschließend werden die neuen oder aktualisierten Seiten wieder auf Festplatte geschrieben. Bei Systemanforderungen können die Daten vom Datenbankmodul im Arbeitsspeicher gepuffert werden, sodass nicht permanent auf die Festplatte zugegriffen werden muss.

Obwohl Daten über die Zwischenspeicherung im Arbeitsspeicher am schnellsten und effizientesten verarbeitet werden, bedeutet dies jedoch auch, dass die Informationen auf der Festplatte bei der Ausführung von Exchange nie vollständig aktuell sind. Die aktuellste Version der Datenbank befindet sich im Speicher. Da viele Änderungen im Arbeitsspeicher noch nicht auf der Festplatte vorhanden sind, sind Datenbank und Arbeitsspeicher nicht synchronisiert. Der Transaktionsprotokolldatenträger wird ständig mit den Informationen zu den einzelnen Transaktionen aktualisiert.

Wenn Exchange Server Analyzer feststellt, dass Ereignisse in der Datei Store.fcl überwiegend Aufrufe vom Exchange-Informationsspeicherdienst (Store.exe) an die ESE-Komponente darstellen, wird ein Fehler angezeigt.

Wenn komponentenübergreifende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) auf eine Antwort warten, können RPC-Threads (Remote Procedure Call, Remoteprozeduraufruf) diese Anforderungen im Hintergrund unterstützen, sodass es zu Exchange Server-Leistungsproblemen kommt, z. B. zu Verzögerungen der Serverantworten an die Clients.

Fortlaufende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst an ESE können folgende Ursachen haben:

  • Exchange-Onlinedefragmentierung

  • Datensicherungen

    Hinweis:
    Wenn während der Erfassung der Exchange-Ablaufverfolgungsprotokollierung für Aufrufe eine Datensicherung oder eine Onlinedefragmentierung eingeleitet wurde, können Sie die Fehlermeldung als Hinweis auf ein Exchange Server-Leistungsproblem ignorieren.
  • Engpässe bei den Datenbanklaufwerken, z. B. unzureichende Kapazität für die Anzahl der Benutzer auf dem Server

  • Engpässe bei den TEMP- und TMP-Laufwerken

Um diesen Fehler zu beheben, führen Sie folgende Schritte aus:

  • Im Rahmen bewährter Methoden sollte darauf geachtet werden, dass sich Sicherungsfenster nicht mit Onlinewartungs- oder Spitzennutzungsintervallen überlappen.

  • Vergewissern Sie sich, dass die Datenbankfestplattenlaufwerke sich in einem einwandfreien Zustand befinden und über genügend Durchsatz für die E/A-Last verfügen.

  • Führen Sie Exchange Server Analyzer aus, um eine weitere Analyse des Servers auszuführen. Sie können Exchange Server Analyzer unter "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" (http://go.microsoft.com/fwlink/?LinkId=34705) herunterladen.

  • Im Abschnitt "Weitere Informationen" dieses Themas finden Sie weitere Artikel.

Weitere Informationen

Weitere Informationen zum Konfigurieren der Zeitfenster für die Onlinedefragmentierung finden Sie im Microsoft Knowledge Base-Artikel 244524, "XADM: Konfigurieren des Exchange Server Online-Fragmentierungszeitfensters" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524).

Weitere Informationen zu Exchange Server-Problemen aufgrund von Datenträgerengpässen finden Sie unter Datenträgerengpass wurde festgestellt.

Weitere Informationen zum Festlegen der Größe und zum Optimieren von Datenträgern für Exchange Server finden Sie unter "Berechnung der Anforderungen an die Datenträger-E/A" und "Best Practices für mehrere Architekturen" in Optimieren von Speichersystemen für Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=49324).

Weitere Informationen zu ESE finden Sie unter "Extensible Storage Engine Architecture" (http://go.microsoft.com/fwlink/?linkid=67009).


Die meisten fortlaufenden store.exe-Aufrufe warten auf eine Antwort von IMAIL
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-13

Microsoft® Exchange Server Analyzer Tool untersucht das FCL-Protokoll (Function Call Log) von Exchange Server, die Datei Store.fcl, auf Ereignisse, die überwiegend auf fortlaufende komponentenübergreifende Aufrufe des Microsoft Exchange-Informationsspeicherdienstes (Store.exe) an die IMAIL-Komponente des MAPI-Clients hinweisen.

Fortlaufende Aufrufe sind Anforderungen vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an andere Komponenten, die noch keine Antwort erhalten haben, wenn die Exchange FCL-Daten in die Datei Store.fcl geschrieben werden.

Bei der IMAIL-Komponente von Exchange Server handelt es sich um einen flexiblen Konvertierungsdienst, der vom Microsoft Exchange-Informationsspeicherdienst zwischen Internet- und MAPI-Nachrichten verwendet wird. Dadurch wird die Interoperabilität zwischen Clients ermöglicht, die das RFC-822- oder Internetformat verwenden, und Clients, die das interne Exchange Server-Speicherformat verwenden, z. B. MAPI-Clients oder interne Speichertasks.

Exchange wendet mithilfe des IMAIL-Mechanismus Nachrichtenformate auf den Inhalt an. Maßgeblich sind hierbei die Festlegungen für Internetdomänen im Exchange-System-Manager bzw. die Festlegungen des Benutzers für den jeweiligen Empfänger in Microsoft Office Outlook®. Werden keine Formatierungsparameter an IMAIL übergeben, werden MAPI-Nachrichten für die Übertragung zwischen Servern in S/TNEF formatiert.

Wenn Exchange Server Analyzer feststellt, dass Ereignisse in der Datei Store.fcl überwiegend fortlaufende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an die IMAIL-Komponente des MAPI-Clients darstellen, wird ein Fehler angezeigt.

Wenn komponentenübergreifende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) auf eine Antwort warten, können RPC-Threads (Remote Procedure Call, Remoteprozeduraufruf) diese Anforderungen im Hintergrund unterstützen, sodass es zu Exchange Server-Leistungsproblemen kommt, z. B. zu Verzögerungen der Serverantworten an die Clients.

Fortlaufende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst an die IMAIL-Komponente des MAPI-Clients können folgende Ursachen haben:

  • IMAIL versucht, umfangreiche Daten in einer Nachricht oder Anlage zu verarbeiten.

  • Viele Clients fordern eine Datenkonvertierung an.

  • DSAccess-Anforderungen weisen eine langsame Reaktion auf.

  • Es gibt Engpässe bei den TEMP- und TMP-Laufwerken.

  • Es gibt fortlaufende Postfachverschiebungen.

Um diesen Fehler zu beheben, führen Sie folgende Schritte aus:

  • Planen Sie Postfachverschiebungen in Zeiten geringer Nutzung.

  • Führen Sie Exchange Server Analyzer aus, um eine weitere Analyse von Serverproblemen auszuführen, wie z. B. Größenbeschränkungen für Nachrichten und Anlagen. Sie können Exchange Server Analyzer unter "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" (http://go.microsoft.com/fwlink/?LinkId=34705) herunterladen.

  • Im Abschnitt "Weitere Informationen" dieses Themas finden Sie weitere Artikel.

Weitere Informationen

Weitere Informationen zu Exchange Server-Problemen aufgrund von Engpässen bei Festplatten finden Sie unter Datenträgerengpass wurde festgestellt.

Weitere Informationen zum Festlegen der Größe und zum Optimieren von Datenträgern für Exchange Server finden Sie unter "Berechnung der Anforderungen an die Datenträger-E/A" und "Best Practices für mehrere Architekturen" in Optimieren von Speichersystemen für Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=49324).

Weitere Informationen zu bewährten Verfahren für Größenbegrenzungen für Nachrichten von Exchange Server finden Sie unter Maximale Größe für ausgehende Nachrichten wurde nicht festgelegt..

Weitere Informationen zu DSAccess und zur Leistung von Exchange Server finden Sie unter "Konfigurieren des DSAccess-Benutzercaches" im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Weitere Informationen zur Behandlung von Leistungsproblemen von Exchange Server finden Sie im Handbuch "Troubleshooting Microsoft Exchange Server Performance" (http://go.microsoft.com/fwlink/?LinkId=47588).

Weitere Informationen zur Behandlung von Leistungsproblemen von Informationsspeichern finden Sie im Microsoft Knowledge Base-Artikel 257725, "XADM: Sammeln von Diagnosedaten zur Problembehandlung des Informationsspeichers" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Die meisten fortlaufenden store.exe-Aufrufe warten auf eine Antwort von LSASS
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-11

Microsoft® Exchange Server Analyzer Tool untersucht das FCL-Protokoll (Function Call Log) von Exchange, die Datei Store.fcl, auf Ereignisse, die auf überwiegend fortlaufende komponentenübergreifende Aufrufe des Microsoft Exchange-Informationsspeicherdienstes (Store.exe) an den LSASS-Prozess (Local Security Authentication Server) hinweisen.

Fortlaufende Aufrufe sind Anforderungen vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an andere Komponenten, die noch keine Antwort erhalten haben, wenn die Exchange FCL-Daten in die Datei Store.fcl geschrieben werden.

Der LSASS-Prozess (Lsass.exe) ist ein Sicherheitssubsystem, das von anderen Prozessen aufgerufen wird, um Kontoinformationen zu überprüfen und Anmeldungen zu validieren.

Bei jeder Exchange-Clientanmeldung wird vom Server, auf dem Exchange Server ausgeführt wird, eine Anforderung gesendet, um die Konto-SID (Security Identifier) des Clients zu ermitteln, und ein Aufruf im LSASS-Prozess erstellt.

Wenn Exchange Server Analyzer feststellt, dass Ereignisse in der Datei Store.fcl überwiegend fortlaufende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an den LSASS-Prozess (Local Security Authentication Server) darstellen, wird ein Fehler angezeigt.

Wenn komponentenübergreifende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) auf eine Antwort warten, können RPC-Threads (Remote Procedure Call, Remoteprozeduraufruf) diese Anforderungen im Hintergrund unterstützen, sodass es zu Exchange Server-Leistungsproblemen kommt, z. B. zu Verzögerungen der Serverantworten an die Clients.

Fortlaufende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst an den LSASS-Prozess können folgende Ursachen haben:

  • Serverressourcenprobleme in Bezug auf die Anzahl der Benutzer, die gleichzeitig eine Authentifizierung durchführen

  • Netzwerkwartezeit zwischen dem Exchange-Server und dem Domänencontroller oder dem globalen Katalogserver

  • Probleme aufgrund von Engpässen bei Serverressourcen

Um diesen Fehler zu beheben, führen Sie folgende Schritte aus:

  • Erwägen Sie, den NeverPing-Parameter zu implementieren (siehe Beschreibung in Der Parameter 'NeverPing' wird empfohlen).

  • Im Abschnitt "Weitere Informationen" dieses Themas finden Sie weitere Artikel.

Weitere Informationen

Weitere Informationen zum Lsass.exe-Prozess sowie zu Speichernutzung finden Sie im Microsoft Knowledge Base-Artikel 308356, "Speichernutzung durch den Prozess "Lsass.exe" auf Domänencontrollern unter Windows Server 2003 oder Windows 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356).

Weitere Informationen zu Exchange-Clientanmeldungen und LSASS-Problemen finden Sie im Microsoft Knowledge Base-Artikel 161938, "Verlangsamung von Exchange-Clientanmeldungen aufgrund von Ressourcen-Deadlocks" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938).

Weitere Informationen zu Netzwerkwartezeiten zwischen dem Exchange-Server und dem Domänencontroller oder dem globalen Katalogserver finden Sie im Exchange Server Team Blog-Artikel, "Exchange Does Not Always Use Local GCs" (http://go.microsoft.com/fwlink/?LinkId=69166).

Hinweis:
Der Inhalt jedes Blogs und die dazugehörigen URLs können jederzeit ohne vorherige Ankündigung geändert werden.

Weitere Informationen zu Problemen aufgrund von Engpässen bei Serverressourcen finden Sie unter Prozessorengpass.

Weitere Informationen zur Leistung von Exchange Server finden Sie im "Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47576).

Weitere Informationen zur Behandlung von Leistungsproblemen von Exchange Server finden Sie im Handbuch "Troubleshooting Microsoft Exchange Server Performance" (http://go.microsoft.com/fwlink/?LinkId=47588).

Weitere Informationen zur Behandlung von Leistungsproblemen von Informationsspeichern finden Sie im Microsoft Knowledge Base-Artikel 257725, "XADM: Sammeln von Diagnosedaten zur Problembehandlung des Informationsspeichers" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Die meisten fortlaufenden store.exe-Aufrufe warten auf eine Antwort vom Verzeichnis
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-14

Microsoft® Exchange Server Analyzer Tool untersucht das FCL-Protokoll (Function Call Log) von Exchange, die Datei Store.fcl, auf Ereignisse, die überwiegend auf fortlaufende komponentenübergreifende Aufrufe des Microsoft Exchange-Informationsspeicherdienstes (Store.exe) an den Active Directory®-Verzeichnisdienst hinweisen.

Fortlaufende Aufrufe sind Anforderungen vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an andere Komponenten, die noch keine Antwort erhalten haben, wenn die Exchange FCL-Daten in die Datei Store.fcl geschrieben werden.

Active Directory stellt alle Postfachinformationen, Adresslistendienste und andere Informationen zu Empfängern bereit. Die meisten Exchange Server 2003-Konfigurationsinformationen werden ebenfalls in Active Directory gespeichert.

Exchange Server-Dienste greifen auf die in Active Directory gespeicherten Informationen zu und schreiben Informationen in Active Directory.

Wenn Exchange Server Analyzer feststellt, dass Ereignisse in der Datei Store.fcl überwiegend Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an Active Directory darstellen, wird ein Fehler angezeigt.

Wenn komponentenübergreifende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) auf eine Antwort warten, können RPC-Threads (Remote Procedure Call, Remoteprozeduraufruf) diese Anforderungen im Hintergrund unterstützen, sodass es zu Exchange Server-Leistungsproblemen kommt, z. B. zu Verzögerungen der Serverantworten an die Clients.

Fortlaufende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst an Active Directory können folgende Ursachen haben:

  • Netzwerkwartezeit zwischen dem Exchange-Server und dem Domänencontroller

  • Statische oder anderweitig fehlerhafte Konfiguration von DSAccess

  • Überlasteter Domänencontroller und überlasteter globaler Katalog

  • Fehlerhafter Entwurf der Active Directory-Topologie

Um diesen Fehler zu beheben, führen Sie folgende Schritte aus:

  • Führen Sie Exchange Server Analyzer aus, um eine weitere Analyse von Serverproblemen auszuführen, wie z. B. Größenbeschränkungen für Nachrichten und Anlagen. Sie können Exchange Server Analyzer unter "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" (http://go.microsoft.com/fwlink/?LinkId=34705) herunterladen.

  • Überprüfen Sie die Leistung der Active Directory-Domänencontrollerserver.

  • Im Abschnitt "Weitere Informationen" dieses Themas finden Sie weitere Artikel.

Weitere Informationen

Weitere Informationen zur Exchange-Leistung und DSAccess finden Sie im Microsoft Knowledge Base-Artikel 250570, "Directory service server detection and DSAccess usage" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570).

Weitere Informationen zur Leistung von Exchange Server finden Sie im "Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47576).

Weitere Informationen zur Behandlung von Leistungsproblemen von Exchange Server finden Sie im Handbuch "Troubleshooting Microsoft Exchange Server Performance" (http://go.microsoft.com/fwlink/?LinkId=47588).

Weitere Informationen zur Behandlung von Leistungsproblemen von Informationsspeichern finden Sie im Microsoft Knowledge Base-Artikel 257725, "XADM: Sammeln von Diagnosedaten zur Problembehandlung des Informationsspeichers" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

Weitere Informationen zur Leistung von Domänencontrollern finden Sie in den folgenden Windows Server-Ressourcen:

  • "Planning Domain Controller Capacity" (http://go.microsoft.com/fwlink/?LinkId=70191)

  • "Active Directory Monitoring of Domain Controllers" in Windows 2000 Server Active Directory Planning and Deployment Guides (http://go.microsoft.com/fwlink/?LinkId=70193)


Die meisten fortlaufenden store.exe-Aufrufe warten auf eine Antwort vom Virenscanner
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-13

Microsoft® Exchange Server Analyzer Tool untersucht das FCL-Protokoll (Function Call Log) von Exchange, die Datei Store.fcl, auf Ereignisse, die überwiegend auf fortlaufende komponentenübergreifende Aufrufe des Exchange-Informationsspeicherdienstes (Store.exe) an die VAPI-Komponente (Virusscan Virus API) hinweisen.

Fortlaufende Aufrufe sind Anforderungen vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an andere Komponenten, die noch keine Antwort erhalten haben, wenn die Exchange FCL-Daten in die Datei Store.fcl geschrieben werden.

Wenn Exchange Server Analyzer feststellt, dass Ereignisse in der Datei Store.fcl überwiegend fortlaufende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an die VAPI-Komponente darstellen, wird ein Fehler angezeigt.

Wenn komponentenübergreifende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) auf eine Antwort warten, können RPC-Threads (Remote Procedure Call, Remoteprozeduraufruf) diese Anforderungen im Hintergrund unterstützen, sodass es zu Exchange Server-Leistungsproblemen kommt, z. B. zu Verzögerungen der Serverantworten an die Clients.

Fortlaufende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst an die Virusscan VAPI-Komponente können folgende Ursachen haben:

  • Aktualisierungen eines Virenscanners, die dazu führen, dass die Objekte im Informationsspeicher erneut geprüft werden

  • Ein fehlerhaft konfigurierter Virenscanner

  • Verarbeitung einer umfangreichen Nachricht oder Anlage durch die Virenscannersoftware

Um diesen Fehler zu beheben, führen Sie folgende Schritte aus:

  • Planen Sie Aktualisierungen des Antivirenmoduls in Zeiten mit geringer Ressourcenbelastung, d. h. außerhalb von Spitzennutzungszeiten.

  • Erwägen Sie, die Virenscannersoftware neu zu installieren (außerhalb von Spitzennutzungsintervallen)

  • Untersuchen Sie die Konfiguration Ihres Virenscannermoduls hinsichtlich der ordnungsgemäßen Threadkonfiguration, Ausschlüssen auf Dateiebene usw. Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 823166, "Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Im Abschnitt "Weitere Informationen" dieses Themas finden Sie weitere Artikel.

Weitere Informationen

Weitere Informationen zu den in Microsoft Exchange Server 2003 üblicherweise verwendeten Virenprüfprogrammen finden Sie im Microsoft Knowledge Base-Artikel 823166, "Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Weitere Informationen zu den in Microsoft Exchange 2000 Server üblicherweise verwendeten Virenprüfprogrammen finden Sie im Knowledge Base-Artikel 328841, "XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Weitere Informationen zur Leistung von Exchange Server finden Sie im "Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47576).

Weitere Informationen zur Behandlung von Leistungsproblemen von Exchange Server finden Sie im Handbuch "Troubleshooting Microsoft Exchange Server Performance" (http://go.microsoft.com/fwlink/?LinkId=47588).

Weitere Informationen zur Behandlung von Leistungsproblemen von Informationsspeichern finden Sie im Microsoft Knowledge Base-Artikel 257725, "XADM: Sammeln von Diagnosedaten zur Problembehandlung des Informationsspeichers" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Die meisten fortlaufenden store.exe-Aufrufe warten auf eine Antwort von VSS-Snapshot
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-13

Microsoft® Exchange Server Analyzer Tool untersucht das FCL-Protokoll (Function Call Log) von Exchange, die Datei Store.fcl, auf Ereignisse, die auf fortlaufende komponentenübergreifende Aufrufe des Exchange-Informationsspeicherdienstes (Store.exe) an die VSS-Snapshot-Komponente (Volume Shadow Copy Service, Volumeschattenkopie-Dienst) hinweisen.

Fortlaufende Aufrufe sind Anforderungen vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an andere Komponenten, die noch keine Antwort erhalten haben, wenn die Exchange FCL-Daten in die Datei Store.fcl geschrieben werden.

Bei VSS handelt es sich um eine Reihe von COM-APIs, die ein Framework implementieren, das die Durchführung von Volumesicherungen ermöglicht, während die Anwendungen in einem System weiterhin auf die Datenträger schreiben können.

Microsoft Exchange Server 2003 verwendet den Volumeschattenkopie-Dienst, der im Betriebssystem Microsoft Windows Server™ 2003 enthalten ist, um Volumeschattenkopien von Exchange Server 2003-Datenbanken und Transaktionsprotokolldateien zu erstellen.

Ein VSS-Snapshot ist nicht vollkommen unabhängig von den Originaldaten. Snapshots werden im Allgemeinen erstellt, wenn Sie eine zeitliche Markierung definieren und gewährleistet wird, dass die Daten zu diesem Zeitpunkt wiederhergestellt werden können.

Wenn Exchange Server Analyzer feststellt, dass Ereignisse in der Datei Store.fcl fortlaufende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an die VSS-Snapshot-Komponente darstellen, wird eine entsprechende Meldung angezeigt.

Wenn komponentenübergreifende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) auf eine Antwort warten, können RPC-Threads (Remote Procedure Call, Remoteprozeduraufruf) diese Anforderungen im Hintergrund unterstützen, sodass es zu Exchange Server-Leistungsproblemen kommt, z. B. zu Verzögerungen der Serverantworten an die Clients.

Hinweis:
Wenn innerhalb von 20 Sekunden der Erfassung der Exchange-Ablaufverfolgungsprotokollierung für Aufrufe absichtlich ein VSS-Snapshot eingeleitet wurde, können Sie diese Meldung als Hinweis auf ein Exchange Server-Leistungsproblem ignorieren.

Im Rahmen bewährter Methoden sollte darauf geachtet werden, dass sich Sicherungsfenster nicht mit Onlinewartungs- oder Spitzennutzungsintervallen überlappen.

Weitere Informationen

Weitere Informationen zu VSS finden Sie unter "Best Practices for Using Volume Shadow Copy Service with Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=56571).


Falsche Version der Datei MOUNTMGR.SYS
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-02-13

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungsschlüssel, um festzustellen, ob Microsoft Windows® Server 2003 installiert ist: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\

Exchange Server Analyzer führt außerdem folgende Abfragen aus:

  • Die Microsoft Windows®-Verwaltungsinstrumentationsklasse (Windows® Management Instrumentation, WMI) Win32_OperatingSystem, um zu ermitteln, ob Windows Server 2003 Service Pack 1 installiert ist.

  • Die WMI-Klasse Win32_Service, um zu ermitteln, ob der Clusterdienst ausgeführt wird.

  • Die WMI-Klasse Win32_Volume, um zu ermitteln, ob Volumebereitstellungspunkte vorhanden sind.

  • Die WMI-Klasse CIM_Datafile, um zu ermitteln, ob der Wert des Schlüssels Version für Mountmgr.sys kleiner als 2443 ist.

Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Der Versionsschlüssel für Mountmgr.sys ist kleiner als 2443.

  • Der Server ist ein Knoten eines Clusters, in dem Windows Server 2003 Service Pack 1 ausgeführt wird.

  • Der Server verfügt über Volumebereitstellungspunkte.

Die auf dem Clusterknoten installierte Version von Mountmgr.sys kann zu Fehlern bei Volumebereitstellungspunkten führen. Dieses Problem tritt wegen eines Problems im Mountmgr.sys-Treiber auf. Es handelt sich hierbei um ein periodisches Timingproblem, das auftreten kann, wenn ein Datenträger in einem Bereitstellungspunkt bereitgestellt werden soll.

Hinweis:
Im Allgemeinen tritt dieses Problem in Umgebungen ohne Cluster nicht auf. In einer Umgebung ohne Cluster ist das Timing des Bereitstellungsprozesses von Datenträgern anders.

Weitere Informationen zu diesem Problem finden Sie im Microsoft Knowledge Base-Artikel 898790, „Nachdem Sie Windows Server 2003 Service Pack 1 installieren, können Datenträgerbereitstellungspunkte auf Datenträgern in einem Servercluster zeitweise nicht mehr verfügbar sein" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790).


Verschieben von Temp- und TMP-Verzeichnis
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-09-01

Microsoft® Exchange Server Analyzer hat festgestellt, dass die Ordner TEMP und TMP sich möglicherweise nicht an Speicherplätzen befinden, die optimale Datenträgerleistung ermöglichen. Als optimale Methode wird empfohlen, die TEMP- und TMP-Ordner auf einem Datenträgerteilsystem zu speichern, das nicht gemeinsam mit dem Systemordner oder den Exchange-Datendateien verwendet wird.

Der Microsoft Exchange-Informationsspeicherdienst verwendet den Ordner TEMP und den Ordner TMP während verschiedener Vorgänge als temporären Speicher, beispielsweise bei der Nachrichtenkonvertierung, Arbeiten mit großen Anlagen und beim Verschieben von Postfächern. Mithilfe der Umgebungsvariablen TEMP und TMP wird festgelegt, welche Ordner im Dateisystem (z. B. welcher Pfad) von Anwendungen verwendet werden sollen, die einen temporären Arbeitsbereich erfordern. TEMP wird typischerweise von Anwendungen wie Microsoft Exchange verwendet, und TMP wird i. d. R. von Entwicklungstools wie Microsoft Visual C++® verwendet. Der Pfad für die einzelnen Variablen bezieht sich normalerweise auf den Sicherheitskontext der Anwendung bzw. des Tools.

Auf einem Exchange-Server, der sich nicht in einem Cluster befindet, verwendet der Exchange-Speicher den Ordner SYSTEM (z. B. Lokales System), für das eine Umgebungsvariablen-Standardeinstellung von %Systemroot%\Temp TEMP und TMP gilt. Virtuelle Exchange-Server, die in einem Microsoft Windows®-Cluster ausgeführt werden, verwenden die Umgebungsvariableneinstellungen des Cluster-Dienstkontos, das im Kontext eines spezifischen benutzerbedingten Sicherheitsprinzips ausgeführt wird. Für Benutzerkonten wird die Standardumgebungsvariable für TEMP und TMP auf %Userprofile%\Tempfestgelegt.

Dieser Artikel erläutert, wie die Verzeichnisse TEMP und TMP in Umgebungen mit und ohne Cluster verschoben werden. Ehe Sie die Verfahren aus diesem Artikel durchführen, berücksichtigen Sie die folgenden Empfehlungen:

  • Zur Optimierung der Leistung empfiehlt es sich, dass für die von Exchange verwendeten Ordner TEMP und TMP nicht die Festplatte mit dem Betriebssystem verwendet wird. Darüber hinaus müssen Sie sicherstellen, dass diese Umgebungsvariablen auf Pfade auf einer schnellen Festplatte bzw. einem Festplattenteilsystem (z. B. Gruppe von RAID 0+1-Spindeln) festgelegt sind.

  • Es wird außerdem empfohlen, dass für die Ordner TEMP und TMP nicht der Datenträger verwendet wird, auf dem sich Exchange befindet.

So verschieben Sie den TEMP- oder TMP-Ordner in einer Umgebung ohne Cluster

  1. Melden Sie sich beim Exchange Server-Computer mit einem Konto an, das über Administratorrechte verfügt.

  2. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und Wählen Sie dann Eigenschaften.

  3. Wählen Sie die Registerkarte Erweitert aus.

  4. Klicken Sie auf Umgebungsvariablen.

  5. Wählen Sie im Bereich Systemvariablen den Eintrag TEMP aus, und klicken Sie dann auf die Schaltfläche Bearbeiten.

  6. Im Feld Variablenwert geben Sie den neuen Pfad für die Umgebungsvariable TEMP ein, und klicken Sie auf OK.

  7. Wählen Sie im Bereich Systemvariablen den Eintrag TMP aus, und klicken Sie dann auf die Schaltfläche Bearbeiten.

  8. Im Feld Variablenwert geben Sie den neuen Pfad für die Umgebungsvariable TMP ein, und klicken Sie auf OK.

  9. Klicken Sie zuerst auf OK, um das Dialogfeld Umgebungsvariablen zu schließen und dann auf OK, um das Dialogfeld Systemeigenschaften zu schließen.

  10. Starten Sie den Server neu, um sämtliche Änderungen zu übernehmen.
So verschieben Sie den TEMP- oder TMP-Ordner in einer Cluster-Umgebung

  1. Melden Sie sich bei einem Knoten im Cluster mit dem Cluster-Dienstkonto an.

  2. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und Wählen Sie dann Eigenschaften.

  3. Klicken Sie auf Erweitert.

  4. Klicken Sie auf Umgebungsvariablen.

  5. Wählen Sie im Bereich Benutzervariablen für <Kontoname> den Eintrag TEMP aus, und klicken Sie auf Bearbeiten.

  6. Im Feld Variablenwert geben Sie den neuen Pfad für die Umgebungsvariable TEMP ein, und klicken Sie auf OK.

  7. Wählen Sie im Bereich Benutzervariablen für <Kontoname> den Eintrag TMP aus, und klicken Sie auf Bearbeiten.

  8. Im Feld Variablenwert geben Sie den neuen Pfad für die Umgebungsvariable TMP ein, und klicken Sie auf OK.

  9. Klicken Sie zuerst auf OK, um das Dialogfeld Umgebungsvariablen zu schließen und dann auf OK, um das Dialogfeld Systemeigenschaften zu schließen.

  10. Starten Sie den Knoten neu, um die Änderung zu übernehmen.

  11. Wiederholen Sie die Schritte 1 bis 10 für jeden Knoten des Clusters.
Wichtig:
Sie müssen dem Konto Authentifizierte Benutzer die entsprechenden Berechtigungen für den neuen Pfad mit den Ordnern TMP und TEMP erteilen.
So weisen Sie der Gruppe Authentifizierte Benutzer Berechtigungen für die Ordner TMP und TEMP zu

  1. Starten Sie Windows-Explorer, klicken Sie mit der rechten Maustaste auf den Ordner, auf den die Variable TEMP oder TMP verweist, und klicken Sie dann auf Eigenschaften.

  2. Klicken Sie im Dialogfeld mit den TEMP-Eigenschaften auf die Registerkarte Sicherheit, und klicken Sie dann auf Hinzufügen.

  3. Fügen Sie im Dialogfeld Benutzer, Computer oder Gruppen auswählen die Gruppe Authentifizierte Benutzer in der Liste der Objektnamen hinzu, und klicken Sie dann auf OK.

  4. Klicken Sie auf Erweitert, um auf weitere Sicherheitseinstellungen zuzugreifen.

  5. Wählen Sie Authentifizierte Benutzer in der Liste Name aus, und klicken Sie dann auf Bearbeiten, um das Dialogfeld Berechtigungseintrag anzuzeigen.

  6. Mithilfe der Felder im Berechtigungsbereich können Sie die folgenden speziellen Berechtigungen zulassen:

    Ordner durchsuchen / Datei ausführen

    Dateien erstellen / Daten schreiben

    Ordner erstellen / Daten anhängen

  7. Klicken Sie dreimal auf OK, um die Änderungen zu übernehmen und das Dialogfeld zu schließen.

Weitere Informationen

  • Weitere Informationen zur Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange finden Sie unter Behandeln von Leistungsproblemen bei Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Verschieben von Benutzerpostfächern auf einen anderen Server
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-09-06

Microsoft® Exchange Server Analyzer hat festgestellt, dass eine Ihrer Datenbanken nicht ordnungsgemäß beendet wurde. Die aktuelle Benutzerlast verursacht Leistungsprobleme. Es empfiehlt sich, die Benutzer an einen anderen Speicherort zu verschieben. Gehen Sie dabei so vor, dass Sie jede Nacht einige wenige (normalerweise 5% aller Benutzer) verschieben, bis die Leistungsprobleme behoben sind.

Dies ist der empfohlene Ansatz, weil eines der folgenden Probleme aufgetreten ist:

  • Manche Exchange-Datenbankdateien befinden sich auf Datenträgern, die ihre Durchsatzgrenze erreicht oder überschritten haben.

  • Andere Serverressourcen (z. B. Speicher oder CPU) sind über der Kapazitätsgrenze.

  • Die Kapazitätsgrenze eines Datenträgers ist überschritten. Dies bedeutet, dass das Datenträgerteilsystem, das einen oder mehrere Ihrer Exchange-Informationsspeicher unterstützt, eine durchschnittliche Wartezeit für Datenträger-E/A oberhalb der empfohlenen Werte aufweist. Bis das Problem behoben ist, sollten Sie fünf Prozent Ihrer Benutzer zu einer Datenbank auf einem anderen Plattenteilsystem verschieben. Wenn sich die Laufwerke mit den Datenbanken als Engpass erweisen, verschieben Sie die Benutzer in eine Datenbank, die sich auf einem anderen Laufwerk befindet. Wenn sich eine Speichergruppe als Engpass erweist, verschieben Sie die Benutzer in eine Datenbank in einer anderen Speichergruppe, die sich in einer anderen Datenbank befindet. Wenn die Laufwerke von einer anderen Ressource mit gemeinsam verwendet werden, besteht eine andere mögliche Lösung darin, die Last der anderen Anwendungen auf diesen Laufwerken zu verringern.

  • Ihr physischer Server ist über seiner Kapazität. Sie haben aktuell nicht ausreichend Prozessorleistung oder Speicher, um die von Ihren Benutzern generierte Serverlast zu verarbeiten. Bis das Leistungsproblem behoben ist, sollten Sie fünf Prozent Ihrer Benutzer zu einem anderen Server verschieben.

Hinweis:
Die Verbindung zwischen Exchange-Clients und den Postfächern muss zwar während einer Postfachoperation nicht getrennt werden, es empfiehlt sich jedoch, Postfachverschiebungen bei geringer Clientaktivität (zum Beispiel in Zeiten geringer Nutzung) durchzuführen, um eine mögliche Unterbrechung des Dienstes zu vermeiden.
So verschieben Sie Postfächer auf Exchange Server 2003

  1. Starten Sie Exchange-System-Manager auf dem Exchange Server 2003-Computer, auf dem der Prozess ausgeführt werden soll.

  2. Doppelklicken Sie auf Server, und suchen Sie dann den Servercontainer, in dem sich die Postfächer der Benutzer befinden.

    Wenn Sie beispielsweise Postfächer aus dem Standardspeichergruppen- und Postfachspeicher verschieben möchten, doppelklicken Sie auf Erste Speichergruppe, doppelklicken Sie auf Postfachspeicher, und klicken Sie dann auf Postfächer.

  3. Klicken Sie im Detailbereich auf die Postfächer, die Sie verschieben möchten.

  4. Klicken Sie mit der rechten Maustaste auf die markierten Benutzer, und klicken Sie dann auf Exchange-Aufgaben.

  5. Klicken Sie im Assistenten für Exchange-Aufgaben auf Weiter.

  6. Klicken Sie auf der Seite Verfügbare Aufgaben unter Auszuführende Aufgabe auswählen auf Postfach verschieben, und klicken Sie dann auf Weiter.

  7. Klicken Sie auf der Seite Postfach verschieben in der Liste Server auf den gewünschten Server, und klicken Sie dann im Postfachspeicher auf den gewünschten Postfachspeicher.

  8. Klicken Sie auf Weiter.

  9. Konfigurieren Sie, wie die beim Verschieben gefundenen, beschädigten Nachrichten behandelt werden sollen, und klicken Sie anschließend auf Weiter.

  10. Klicken Sie auf Weiter.

Weitere Informationen

  • Weitere Informationen zur Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange finden Sie unter Behandeln von Leistungsproblemen bei Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen zum Verschieben von Postfächern in Exchange Server 2003 finden Sie im Microsoft-Knowledge Base-Artikel 821829, „Moving Mailboxes in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829.

  • Weitere Informationen zum Verschieben von Postfächern in Exchange 2000 Server und Exchange Server 5.5 finden Sie im Microsoft-Knowledge Base-Artikel 328810 „Moving mailboxes between servers" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810.


NAS-Konfigurationsproblem
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer sendet eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert des Attributs msExchESEParamLogFilePath für jedes Speichergruppenobjekt zu bestimmen. Dieses Attribut gibt den Speicherort der Transaktionsprotokolle an, die von den Datenbanken in der Speichergruppe verwendet werden.

Exchange Server Analyzer sendet außerdem eine Abfrage an Active Directory, um die Anzahl der Einträge zu ermitteln, die im Attribut homeMDBBL jedes Postfachspeichers aufgelistet sind. Der Zählwert dieses Attributs stellt die Zahl der Postfächer im Postfachspeicher dar.

Zusätzlich sendet Exchange Server Analyzer eine Abfrage an die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Service, um den Wert des Schlüssels Started für den Microsoft Windows Storage Server 2003-Funktionspaketdienst (wssexchmap) zu bestimmen. Der Wert False gibt an, dass der Windows Storage Server 2003-Funktionspaketdienst auf diesem Exchange-Server nicht ausgeführt wird. Der Wert True gibt an, dass der Windows Storage Server 2003-Funktionspaketdienst ausgeführt wird.

Wenn Exchange Server Analyzer feststellt, dass der Wert für ein msExchESEParamLogFilePath-Attribut mit S:\{ beginnt und der Windows Storage Server 2003-Funktionspaketdienst auf einem Exchange Server-Computer mit mehr als 1500 Postfächern gestartet wird, wird eine Warnung angezeigt.

Windows Storage Server 2003 ist die Microsoft-Plattform für NAS-Geräte. Die Speicherauslegung, die für Windows Storage Server 2003 bei der Verwendung mit Exchange Server 2003 empfohlen wird, weicht von der Exchange Server-Standardauslegung ab. Die empfohlene Konfiguration besteht darin, die Exchange Server-Datenbanken auf Windows Storage Server 2003 zu installieren und die Transaktionsprotokolldateien auf einen lokalen Datenträger innerhalb des Exchange Server-Computers zu speichern.

Das Microsoft Windows Storage Server 2003-Funktionspaket wurde für drei bestimmte Arten von Arbeitslast entwickelt:

  • Geringe Arbeitslasten für bis zu 250 Postfächer, die von einem mit einem Windows Storage Server-Computer verbundenen Exchange-Server verwaltet werden. In diesem Szenario wird eine Konfiguration für Windows Storage Server mit einem Prozessor mit 1 GHz oder schneller, 512 MB Arbeitsspeicher (RAM), vier SCSI- oder IDE/SATA-Festplatten als RAID-5-Volume und zwei Netzwerkschnittstellenkarten (NIC - Network Interface Card) empfohlen: ein Adapter für eine LAN-Verbindung und ein privater Gigabit-Ethernet-Adapter für eine direkte Verbindung mit dem Exchange-Server. Die Exchange-Datenbanken werden in dem RAID-5-Volume gespeichert; Transaktionsprotokolle verbleiben auf dem lokalen RAID-1 des Exchange-Servers.

  • Mittlere Arbeitslasten mit bis zu 750 Postfächern in einer Speichergruppe, die von einem Exchange-Server und einem einzelnen Windows Storage Server-Computer verwaltet werden. In dieser Konfiguration sollte der Windows Storage Server-Computer über ein Paar von 1 GHz-Prozessoren (oder schneller), 1 GB Arbeitsspeicher (RAM), sechs SCSI-Festplatten und ein Paar Netzwerkschnittstellenkarten verfügen. Die Festplatten sollten als RAID-5-Array (4 Festplatten) für Datenbanken und einem separaten Spiegel (2 Laufwerke) für die Transaktionsprotokolle konfiguriert werden.

  • Große Arbeitslasten mit einem oder zwei Exchange Server 2003-Servern, die bis zu 1.500 Postfächer in zwei Speichergruppen verwalten. In dieser Konfiguration sollte der Windows Storage Server-Computer über zwei 1 GHz-Prozessoren (oder schneller), 2 GB RAM und insgesamt 14 Festplatten verfügen: 10 für ein RAID-0+1-Array zum Halten der Datenbanken und zwei Sätze gespiegelter Festplatten für Transaktionsprotokolle.

Diese Warnung zeigt an, dass der Exchange Server-Computer so konfiguriert wurde, dass er Windows Storage Server 2003 zur Speicherung verwendet. Bei der Verwendung von Windows Storage Server zur Datenspeicherung für Exchange Server wird empfohlen, dass weniger als 1.500 Benutzer gleichzeitig auf den Exchange-Server zugreifen.

So beheben Sie diese Warnmeldung

  • Führen Sie einen der folgenden Schritte aus:

    • Verschieben Sie die Transaktionsprotokolle auf einen lokalen Datenträger im Exchange Server-Computer.

    • Verschieben Sie einige der Postfächer auf diesem Exchange Server-Computer auf einen anderen Exchange Server-Computer, sodass sich 1.500 oder weniger Postfächer auf dem Exchange Server-Computer befinden, der Windows Storage Server verwendet.

Weitere Informationen zur Verwendung des Windows Storage Server 2003-Funktionspakets mit Exchange Server 2003 finden Sie im Dokument Managing Exchange Storage with the Windows Storage Server 2003 Feature Pack (http://go.microsoft.com/fwlink/?linkid=34942).

Weitere Informationen finden Sie in den folgenden zusätzlichen Ressourcen:

  • Introduction to Windows Storage Server 2003 Architecture and Deployment (http://go.microsoft.com/fwlink/?linkid=34943)

  • Building Better Protected Storage using Windows Storage Server 2003 (http://go.microsoft.com/fwlink/?linkid=34944)

  • Server Consolidation Using Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47586)


Das Attribut „networkAddress" wurde nicht ordnungsgemäß festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob das Attribut networkAddress die Zeichenfolge ncacn_ip_tcp enthält. Exchange Server Analyzer zeigt einen Fehler an, wenn eine der folgenden Bedingungen erfüllt ist:

  • Die Zeichenfolge ncacn_ip_tcp ist nicht vorhanden.

  • Die Zeichenfolge ncacn_ip_tcp ist beschädigt.

In Microsoft Office Outlook® Web Access für Exchange Server 2003 untersucht der Front-End-Server beim Versuch, eine Verbindung mit einem Exchange-Back-End-Server herzustellen, den Attributwert networkaddress.

Hinweis:
Exchange 2000 Server führt diesen Vorgang mit Outlook Web Access nicht aus.

Für den Front-End-Server ist ein Wert für den vollqualifizierten Domänennamen erforderlich. Der Front-End-Server überprüft den Wert, der für networkaddress ncacn_ip_tcp zurückgegeben wurde, auf einen Punkt. Die Verbindungsanforderung für das Postfach des bestimmten Back-End-Server kann nicht ausgeführt werden, und der Front-End-Server gibt eine „HTTP 500 Internal Server Error"-Fehlermeldung an den Benutzer zurück, wenn die folgenden Bedingungen erfüllt sind:

  • Der Wert networkaddress ncacn_ip_tcp stellt lediglich einen Hostnamen oder einen NetBIOS-Namen (Network Basic Input/Output System) dar.

  • Der Wert networkaddress ncacn_ip_tcp ist kein vollqualifizierter Domänenname.

Sie müssen den Wert networkaddress ncacn_ip_tcp für das Serverobjekt in Active Directory aktualisieren, um die entsprechenden Funktionen von Outlook Web Access 2003 sicherzustellen. Der betroffene Servername wird in der Fehlermeldung von Microsoft Exchange Server Analyzer bereitgestellt.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
Hinweis:
Bevor Sie den Wert ncacn_ip_tcp aktualisieren, lesen Sie den Rest dieses Artikels. Um die Ausfallzeit bei einem Neustart der Exchange Server-Dienste so gering wie möglich zu halten, sollten Sie vor dem Neustart der Exchange Server-Dienste ein weiteres Verfahren ausführen.
So aktualisieren Sie den Wert ncacn_ip_tcp für das Attribut networkAddress

  1. Starten Sie das ADSI-Bearbeitungs-Snap-In in den Supporttools von Windows 2000 Server oder Windows Server 2003.

  2. Erweitern Sie die folgenden Knoten:

    • Container Konfiguration

    • Konfiguration

    • Dienste

    • Microsoft Exchange

    • Organisationsname

    • Administrative Gruppen

    • Name der administrativen Gruppe

    • Server

  3. Klicken Sie mit der rechten Maustaste auf Name des Exchange-Servers, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie in der Liste Attribute auf Netzwerkadresse, und klicken Sie dann auf Bearbeiten.

  5. Fügen Sie einen neuen Wert für ncacn_ip_tcp hinzu. Verwenden Sie den vollqualifizierten Domänennamen des Servers anstelle des NetBIOS-Namen oder des Hostnamen des Servers.

    Verwenden Sie für diesen Wert die Syntax ncacn_ip_tcp:FQDN. Wenn Ihr Exchange-Back-End-Server beispielsweise den Hostnamen EXCHANGE1 und den vollqualifizierten Domänennamen EXCHANGE1.contoso.com aufweist, verwenden Sie den folgenden Wert für ncacn_ip_tcp: ncacn_ip_tcp:EXCHANGE1.contoso.com

  6. Klicken Sie zweimal auf OK, um die Änderung zu übernehmen.

  7. Starten Sie alle Exchange Server-Dienste auf dem Server neu.

  8. Wenn mehrere Domänencontroller vorhanden sind, warten Sie auf die Ausführung der Replikation, bevor Sie sich vom Front-End-Server aus anmelden. Wenn das Problem nach dem Abschluss der Replikation weiterhin besteht, starten Sie den IIS Admin-Dienst auf dem Front-End-Server neu.

Wenn Sie Hostdateien auf Back-End-Servern verwalten, um eine Server-IP-Adresse mit einem kurzen Hostnamen zu korrelieren, müssen Sie auch den Wert UpdateProtocols registry aktualisieren. Wenn eine Hostdatei verwendet wird, setzt Exchange Server möglicherweise bei einem Neustart der Microsoft-Systemaufsicht den Wert ncacn_ip_tcp zurück. Wenn sich der Back-End-Server in einem Cluster befindet, setzt Exchange Server möglicherweise nach der Durchführung eines Failovers den Wert ncacn_ip_tcp zurück.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So ändern Sie den Registrierungswert UpdateProtocols für Back-End-Server, die Hostdateien verwenden

  1. Verwenden Sie einen Registrierungs-Editor zum Konfigurieren des folgenden Registrierungswerts für den bzw. die Back-End-Server: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\UpdateProtocols

    Hinweis:
    Wenn der Wert UpdateProtocols nicht vorhanden ist, muss dieser erstellt werden. Führen Sie hierzu die folgenden Schritte aus:

  2. Öffnen Sie einen Registrierungs-Editor, und suchen Sie den folgenden Registrierungsunterschlüssel: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\

    1. Klicken Sie mit der rechten Maustaste auf Parameter, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

    2. Geben Sie UpdateProtocols ein, und drücken Sie dann die EINGABETASTE.

  3. Klicken Sie mit der rechten Maustaste auf UpdateProtocols, klicken Sie auf Ändern, geben Sie im Feld Wert den Wert 0 ein, und klicken Sie dann auf OK.

  4. Wenn im Netzwerk eine Hosts-Datei für den Back-End-Clusterknoten verwendet wird, ändern Sie die Reihenfolge der Einträge UpdateProtocols folgendermaßen:

    IPAddress to FQDN

    IPAddress to NetBIOS

    anstelle von:

    IPAddress to NetBIOS

    IPAddress to FQDN

  5. Starten Sie alle Exchange Server-Dienste auf dem Server neu.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Das Leistungsüberwachungsobjekt „Network Interface" ist nicht vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Bytes Total/sec-Leistungsindikator des Network Interface-Leistungsobjekts. Wenn gültige Daten nicht vom Indikator zurückgegeben werden, zeigt Microsoft Exchange Server Analyzer eine Basislinienmeldung an.

Wenn keine gültigen Daten vom Erfassungsmodul für Leistungsdaten zurückgegeben werden, liegt mindestens eine der folgenden Bedingungen vor:

  • Das Network Interface-Leistungsobjekt ist deaktiviert.

  • Das Network Interface-Leistungsüberwachungsobjekt wurde nicht gefunden, oder es ist beschädigt.

  • Exchange Server Analyzer verfügt nicht über entsprechende Berechtigungen zum Zugreifen auf die Leistungsobjekte.

Die ersten beiden Bedingungen treten auf, wenn die Registrierung von bestimmten erweiterbaren Indikatoren beschädigt wird oder wenn die Registrierung von auf Microsoft WMI (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) basierten Programmen geändert wird. Überprüfen Sie vor dem Ausführen des Verfahrens, ob Exchange Server Analyzer über entsprechende Berechtigungen verfügt. Weitere Informationen zu den Berechtigungen, die zum Ausführen von Microsoft Exchange Server Analyzer erforderlich sind, finden Sie in der im Lieferumfang von Microsoft Exchange Server Analyzer enthaltenen Hilfedokumentation. Wenn Sie Hilfe erhalten möchten, öffnen Sie Exchange Server Analyzer, und drücken Sie F1.

So beheben Sie diesen Fehler

  1. Überprüfen Sie, ob das Network Interface-Leistungsobjekt aktiviert ist.

    1. Downloaden und installieren Sie das Tool „Extensible Performance Counter List" (Exctrlst.exe). Sie können Exctrlst.exe unter „Exctrlst.exe: Extensible Performance Counter List" (http://go.microsoft.com/fwlink/?LinkId=34436) downloaden.

    2. Öffnen Sie die Datei Exctrlst.exe, klicken Sie auf Sortierreihenfolge und anschließend auf Dienst.

    3. Suchen Sie den Dienst, über den das Leistungsobjekt eine Meldung ausgeben soll, und überprüfen Sie, ob das Kontrollkästchen Leistungsindikatoren aktiviert aktiviert ist.

      Wenn das Kontrollkästchen Leistungsindikatoren aktiviert nicht aktiviert ist, aktivieren Sie es, und starten Sie den Dienst neu, der dem Leistungsindikator zugeordnet ist, um zu überprüfen, ob die Leistungsindikatoren betriebsbereit sind. Wenn die Leistungsindikatoren nicht betriebsbereit sind oder wenn das Kontrollkästchen Leistungsindikatoren aktiviert bereits aktiviert wurde, fahren Sie mit Schritt 2 fort.

  2. Erstellen Sie die nicht vorhandenen oder beschädigten Leistungsindikatoren wie im Microsoft Knowledge Base-Artikel 300956 „Manuelles Neuerstellen der Werte der Leistungsindikatorenbibliothek" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) beschrieben neu.

  3. Wenn Sie das Problem anhand dieses Knowledge Base-Artikels nicht beheben lässt, müssen Sie das Windows-Betriebssystem im Modus Reparieren erneut installieren und die aktuellsten Windows Server-Service Packs anwenden.


Neuere Version von MSGTRACK.dll verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-10-05

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst Daten mehrerer Leistungsindikatoren des Leistungsobjekts "Prozessor" zur Analyse von Leistungsdaten.

Exchange Server Analyzer fragt außerdem die WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert des Schlüssels Version für die Datei Msgtrak.dll zu bestimmen.

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Der Server weist eine hohe CPU-Auslastung auf.

  • Der Wert des Schlüssels Version der Datei Msgtrak.dll ist niedriger als "6.0.6373.0".

Diese Warnung zeigt an, dass es durch die ermittelte Version von Msgtrack.dll möglicherweise zu einer hohen CPU-Auslastung kommen kann. Außerdem kann die ermittelte Version von Msgtrack.dll zu einer sehr hohen Arbeitsspeicherauslastung durch den Prozess Inetinfo.exe führen.

Um dieses Problem zu beheben, installieren Sie das im Microsoft Knowledge Base-Artikel 811409, "XADM: Die Nachrichtenverfolgung kann zu einer sehr hohen Arbeitsspeicherauslastung durch den Prozess Inetinfo.exe führen" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=811409) genannte Update.


Neuere WLDAP32.DLL verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-10-06

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst Daten mehrerer Leistungsindikatoren des Leistungsobjekts "Prozessor" zur Analyse von Leistungsdaten.

Microsoft Exchange Server Analyzer liest außerdem den folgenden Registrierungseintrag, um die Microsoft Windows®-Version zu bestimmen, die auf dem Exchange Server-Computer ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Der Wert 4.0 von CurrentVersion gibt an, dass auf dem ExchangeServer-Computer Microsoft Windows NT® 4.0 ausgeführt wird. Der Wert 5.0 zeigt an, dass auf dem Exchange Server-Computer Windows 2000 Server ausgeführt wird, und der Wert 5.2 zeigt an, dass auf dem Exchange Server-Computer Windows Server™ 2003 ausgeführt wird.

Exchange Server Analyzer fragt außerdem die WMI-Klasse (Windows-Verwaltungsinstrumentation - Windows Management Instrumentation) CIM_Datafile ab, um den Wert des Schlüssels Version für die Datei Wldap32.dll zu bestimmen.

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Exchange Server Analyzer hat eine hohe CPU-Auslastung auf dem analysierten Server festgestellt.

  • Auf dem Exchange Server-Computer wird Windows 2000 Server ausgeführt.

  • Der Wert des Schlüssels Version der Datei Wldap32.dll ist niedriger als "5.0.2195.7044".

Die Warnung weist darauf hin, dass durch die Version von Wldap32.dll der Prozess Inetinfo.exe möglicherweise zu einer 100% CPU-Auslastung auf Windows 2000 Server-Systemen führt.

Um dieses Problem zu beheben, installieren Sie das im Microsoft Knowledge Base-Artikel 899019, "Der Prozess Inetinfo.exe verbraucht die CPU-Ressourcen auf einem Windows 2000 Server-Computer mit Exchange 2000 Server möglicherweise zu 100 Prozent" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=899019) genannte Update.


NNTP-Dienst ist aktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Service ab, um den Wert des Schlüssels Started für den NNTP-Dienst (Network News Transfer Protocol) NntpSvc zu bestimmen. Der Wert True gibt an, dass der NNTP-Dienst (Network News Transfer Protocol) auf diesem Exchange-Server ausgeführt wird.

Microsoft Exchange Server Analyzer liest außerdem die folgende Eigenschaft in der IIS-Metabase (Internet Information Services), um zu bestimmen, ob ein NNTP-Newsfeed für den Exchange-Server konfiguriert ist:

/LM/NNTPSVC/1/Feeds

Wenn Microsoft Exchange Server Analyzer feststellt, dass der NNTP-Dienst gestartet wurde, jedoch keine Newsfeeds für den Server konfiguriert sind, wird eine Warnung angezeigt.

Um Ressourcen zu sparen und als allgemeine Sicherheitsmaßnahme sollten Sie keine Dienste für Komponenten ausführen, die nicht verwendet werden. Jeder ausgeführte Dienst legt Funktionen offen, die von bösartigen Benutzern ausgenutzt werden können. Es wird empfohlen, alle nicht verwendeten Dienste zu deaktivieren.

So deaktivieren Sie den NNTP-Dienst

  1. Klicken Sie auf Start, klicken Sie auf Programme, klicken Sie auf Verwaltung, und klicken Sie dann auf Dienste.

  2. Klicken Sie mit der rechten Maustaste auf den Dienst Network News Transfer Protocol (NNTP), und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Allgemein auf Beenden.

  4. Wählen Sie unter Starttyp die Option Deaktiviert aus, und klicken Sie dann auf OK.

Weitere Informationen zur Bereitstellung von Exchange Server 2003 finden Sie im Exchange Server 2003-Sicherheitshandbuch unter http://go.microsoft.com/fwlink/?linkid=47578.


Keine DNS-Server für Tests verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-12-05

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse Win32_NetworkAdapterConfiguration (Microsoft Windows® Management Instrumentation) nach dem Attribut DNSServerSearchOrder für Remoteserver ab, dem der Server mit Exchange Server Nachrichten zu senden versucht. Dieses Attribut ist ein Array von IP-Adressen von Servern, die zum Abfragen von DNS-Servern verwendet werden.

Exchange Server Analyzer fragt außerdem den Microsoft Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchSMTPExternalDNSServers in der protocolCfgSMTPServer-Klasse für die Exchange 2000 Server- und Exchange Server 2003-Serverobjekte zu ermitteln. Die Klasse protocolCfgSMTPServer enthält die Einstellungen für einen virtuellen SMTP-Server (Simple Mail Transfer Protocol). Wenn das Attribut msExchSMTPExternalDNSServers festgelegt ist, verwendet der virtuelle SMTP-Server einen externen DNS-Server.

Schließlich verwendet Exchange Server Analyzer das folgende Cmdlet der Exchange-Verwaltungsshell, um die Werte der Eigenschaften ExternalDNSServers und InternalDNSServers aller Serverfunktionen des Exchange 2007-Zieltransportservers abzufragen. Die Eigenschaft ExternalDNSServers gibt die Liste der externen DNS-Server an, die vom Server beim Auflösen einer Remotedomäne abgefragt werden. Die Eigenschaft InternalDNSServers gibt die Liste der DNS-Server an, die beim Auflösen eines lokalen Domänennamens für den Zielserver verwendet werden sollen.

Code kopieren
get-TransportServer -Identity %ExchangeServerName% -DomainController %DomainControllerName%

Exchange Server Analyzer zeigt einen Fehler an, wenn folgende Bedingungen zutreffen:

  • Exchange Server Analyzer kann den Wert des Attributs DNSServerSearchOrder nicht abrufen, oder das Attribut enthält keine Daten.

  • Das Attribut msExchSMTPExternalDNSServers für die Exchange 2000 Server- und Exchange Server 2003-Serverobjekte ist nicht festgelegt.

  • Die Werte der Eigenschaften ExternalDNSServers und InternalDNSServers für die Serverfunktionen des Exchange 2007-Zieltransportservers enthalten keine Daten.

Dieser Fehler zeigt an, dass Exchange Server Analyzer keine DNS-Server identifizieren kann, die vom Exchange-Zielserver verwendet werden. Außerdem kann die Nachrichtenübermittlung von dieser Situation beeinträchtigt werden.

Mögliche Ursachen:

  • Die DNS-Konfiguration auf den Zielserver ist nicht richtig.

  • WMI ist ausgefallen oder der Zugriff darauf ist nicht möglich.

So beheben Sie dieses Problem

  • Überprüfen Sie die DNS-Konfiguration des Zielservers.

  • Vergewissern Sie sich, dass der Zugriff auf die Exchange-WMI möglich ist.

So vergewissern Sie sich, dass der Zugriff auf die Exchange-WMI möglich ist

  1. Stellen Sie sicher, dass der Exchange-Server gestartet wurde und mit dem Netzwerk verbunden ist.

  2. Verwenden Sie den Befehl PING, um festzustellen, ob eine Verbindung mit dem Exchange-Server hergestellt werden kann.

  3. Wenn eine Firewall vorhanden ist, überprüfen Sie, ob die RPC-Anschlüsse (Remote Procedure Call) blockiert sind.

  4. Überprüfen Sie die Berechtigungen für das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird. Das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird, muss über lokale Administratorberechtigungen für jeden durchsuchten Exchange-Server verfügen.

    Alternativ können Sie dem Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird, bestimmte WMI-Berechtigungen erteilen:

    1. Öffnen Sie auf dem Exchange-Server die MMC-Struktur (Microsoft Management Console) Computerverwaltung.

    2. Klicken Sie mit der rechten Maustaste unter Dienste und Anwendungen auf WMI-Steuerung, und klicken Sie dann auf Eigenschaften.

    3. Klicken Sie auf der Seite Eigenschaften von WMI-Steuerung auf die Registerkarte Sicherheit, und erweitern Sie dann Stamm.

    4. Wählen Sie den Ordner CIMV2 aus, und klicken Sie dann auf Sicherheit.

    5. Fügen Sie auf der Seite Sicherheit für ROOT\CIMV2 das Konto hinzu, unter dem Exchange Server Analyzer ausgeführt wird.

  5. Wählen Sie das Konto aus, das Sie in Schritt 4 hinzugefügt haben. Aktivieren Sie in Berechtigungen für Ausgewähltes_Konto in der Spalte Zulassen die Kontrollkästchen Remote aktivieren und Sicherheit lesen, und klicken Sie dann auf OK.

Weitere Informationen zum Konfigurieren von DNS für Exchange Server finden Sie im Microsoft Knowledge Base-Artikel 322856, „SO WIRD'S GEMACHT: Konfigurieren von DNS für eine Verwendung mit Exchange Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322856).

Weitere Informationen zu Problemen mit Netzwerkverbindungen finden Sie im Microsoft Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Weitere Informationen zu Verbindungsproblemen bei Exchange Server Analyzer finden Sie unter "Problembehandlung bei Verbindungsproblemen mit Microsoft Exchange Server Best Practices Analyzer" (http://go.microsoft.com/fwlink/?LinkId=56285).

Weitere Informationen zu den Anforderungen hinsichtlich der Anschlüsse finden Sie im Knowledge Base-Artikel 832017, "Dienste und Netzwerk-Port-Anforderungen für das Microsoft Windows-Serversystem" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Keine Hauptkonto-SID
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-02-14

Microsoft Exchange Analyzer fragt die Microsoft WMI-Klasse (Windows Management Instrumentation - Windows-Verwaltungsinstrumentation) Win32_NTLogEvent ab, um zu ermitteln, ob innerhalb der letzten Stunde für MSExchangeIS eine Warnung für ein Ereignis 9548 aufgetreten ist.

Stellt der Exchange Analyzer fest, dass innerhalb der letzten Stunde eine 9548-Ereigniswarnung protokolliert wurde, zählt er die Gesamtanzahl der in dieser Stunde erfassten Warnungen für das Ereignis 9548.

Wenn Exchange Analyzer feststellt, dass in der letzten Stunde 20 oder mehr Warnungen für ein Ereignis 9548 protokolliert wurden, wird eine Warnung angezeigt.

Diese Warnung weist darauf hin, dass möglicherweise deaktivierte Active Directory-Verzeichnisdienst-Benutzerkonten vorliegen, die Exchange Server-Postfächern zugeordnet sind und über ungültige msExchMasterAccountSID-Attribute verfügen.

Ein Postfach auf einem Server mit Microsoft Exchange Server 2003 oder Exchange 2000 Server ist nur verfügbar, wenn es einem Active Directory-Verzeichnisdienst-Benutzerkonto zugeordnet ist. Diese Verknüpfung wird teilweise durch Festlegen des Active Directory-Attributs msExchMasterAccountSid für das Postfach erreicht. Das Active Directory-Konto, mit der das Exchange-Postfach verknüpft ist, kann entweder aktiviert oder deaktiviert sein. Die Benutzer von deaktivierten Konten sollten allerdings über das Attribut msExchMasterAccountSid verfügen.

Ist der Wert des Attributs msExchMasterAccountSid eines deaktivierten Benutzerkontos leer oder beschädigt, und wird eine Zugriffssteuerungsliste (Access Control List, ACL) erstellt, die dieses Benutzerkonto enthält, können Leistungsprobleme auftreten, wenn die ACL zum Zugriff auf Postfach- oder Öffentliche Ordner-Ressourcen verwendet wird.

So beheben Sie diese Warnung

  • Stellen Sie sicher, dass Exchange Server 2003 Service Pack 2 (SP2) mit dem in Microsoft Knowledge Base-Artikel 916783, "Ein Hotfix ist verfügbar, das ändert, wie Exchange Server 2003 SP2 ein deaktiviertes Active Directory-Benutzerkonto behandelt, das einem Exchange Server 2003-Postfach zugeordnet ist, behandelt" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=916783) angegebenen Hotfix installiert ist.

  • Untersuchen Sie die ACL und das Benutzerkonto, auf das sich die 9548-Ereigniswarnung bezieht, um zu ermitteln, ob der Wert des Attributs msExchMasterAccountSid leer oder beschädigt ist. Generieren Sie bei Bedarf einen gültigen msExchMasterAccountSID-Attributwert für das Konto mithilfe der Anweisungen in Microsoft Knowledge Base-Artikel 328880, "Beheben von Problemen mit der Leistung Öffentlicher Ordner aufgrund von ACL-Konvertierungen in Exchange 2000 und in Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328880)

  • Entfernen Sie das deaktivierte Benutzerkonto aus der ACL. Beachten Sie dazu die Anweisungen in Microsoft Knowledge Base-Artikel 278966, "Verschieben eines Exchange-Ressourcenpostfachs oder Anmelden bei diesem Postfach nicht möglich" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=278966)

Weitere Informationen

Weitere Informationen zu diesem Problem finden Sie in den folgenden Microsoft Knowledge Base-Artikeln und Exchange Server-Ressourcen:

  • Events and Errors Message Center: Ereignisdetails: MSExchangeIS-Postfachspeicher: Details zum Ereignis 9548 (http://go.microsoft.com/fwlink/?LinkId=83135)

  • Microsoft Knowledge Base-Artikel 916783, "Ein Hotfix ist verfügbar, das ändert, wie Exchange Server 2003 SP2 ein deaktiviertes Active Directory-Benutzerkonto behandelt, das einem Exchange Server 2003-Postfach zugeordnet ist, behandelt" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=916783)

  • Microsoft Knowledge Base-Artikel 328880 "Beheben von Problemen mit der Leistung Öffentlicher Ordner aufgrund von ACL-Konvertierungen in Exchange 2000 und in Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328880)

  • Microsoft Knowledge Base-Artikel 278966, "Verschieben eines Exchange-Ressourcenpostfachs oder Anmelden bei diesem Postfach nicht möglich" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=278966)


Es wurde keine SMTP-Instanz gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-08-08

Microsoft® Exchange Server Analyzer fragt das Active Directory®-Verzeichnisdienstattribut distingushedName der Objektklasse protocolCfgSMTPServer ab, um zu bestimmen, ob eine Instanz eines virtuellen SMTP-Servers (Simple Mail Transfer Protocol) für den vom Benutzer angegebenen Exchange-Gatewayserver ausgeführt wird.

Wenn Exchange Server Analyzer keine Instanz des virtuellen SMTP-Dienstes für den vom Benutzer angegebenen Exchange-Gatewayserver findet, zeigt Exchange Server Analyzer einen Fehler an.

Ursache für diesen Fehler sind möglicherweise temporäre Netzwerkprobleme. Er kann jedoch auch auf falsche Informationen in Active Directory hindeuten.

Um dieses Problem zu beheben, überprüfen Sie die Konfiguration des virtuellen Servers für den vom Benutzer angegebenen Exchange-Gatewayserver.

So zeigen Sie die Konfiguration der virtuellen SMTP-Serverinstanz an

  1. Starten Sie den Exchange-System-Manager:

    Klicken Sie auf Start, zeigen Sie auf Programme, zeigen Sie auf Microsoft Exchange, und klicken Sie dann auf System-Manager.

  2. Navigieren Sie zum folgenden Container:

    \Administrative Groups\GroupName\Servers\ServerName\Protocols\SMTP\SMTP Virtual Server Instance\

  3. Klicken Sie mit der rechten Maustaste auf die Instanz des gewünschten virtuellen SMTP-Server, und wählen Sie dann Eigenschaften aus.

  4. Überprüfen Sie, ob die Konfiguration der Instanz des virtuellen SMTP-Servers korrekt ist.

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Knowledge Base-Artikeln:

  • 266686, "XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

Weitere Informationen zum Aufbau des SMTP-Dienstes finden Sie unter "Entwurf des SMTP-Dienstes" im Technischen Referenzhandbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=58876).

Weitere Informationen zu Problemen mit Netzwerkverbindungen finden Sie im Microsoft Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).


NSPI-Zielserver wurde manuell außer Kraft gesetzt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest die folgenden Registrierungseinträge, um zu bestimmen, ob der Zielserver für die Namensdienstanbieterschnittstelle (NSPI target server) manuell außer Kraft gesetzt wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\NSPI Target Server

Wenn Exchange Server Analyzer erkennt, dass NSPI Target Server vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Verschiedene Clienttypen verwenden Domänencontroller und globale Katalogserver auf verschiedene Art und Weise, um Zugriff auf die Globale Adressenliste (GAL) zu erlangen. Exchange-Clients mit früheren Versionen als Microsoft Outlook® 2000 Service Release 2 (SR-2) erwarten, auf dem Exchange-Server einen Verzeichnisdienst vorzufinden. Exchange 2000 Server und Exchange Server 2003 verwenden einen Mechanismus mit dem Namen Verzeichnisdienst-Proxy (DSProxy), um eine Verbindung zum nächsten globalen Katalogserver im Namen des Client und Proxy-Kommunikation zwischen Outlook und dem globalen Katalogserver herzustellen. Ausgehend von Ihren Bereitstellungserfordernissen können Sie u. U. explizit einen bestimmten globalen Katalogserver angeben, mit dessen Hilfe die DSProxy-Anforderungen verarbeitet werden. Nehmen Sie hierzu eine harte Kodierung des Registrierungseintrags NSPI Target Server auf dem Exchange-Server vor.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So geben Sie manuell einen NSPI-Server an

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Erstellen Sie einen neuen REG_MULTISZ-Wert mit der Bezeichnung NSPI Target Server.

  4. Konfigurieren Sie den Wert NSPI Target Server mit dem vollqualifizierten Domänennamen für die gewünschten Server.

Um eine statische Einstellung für den NSPI-Server zu deaktivieren, entfernen Sie den Eintrag mit dem vollqualifizierten Domänenamen für den zu entfernenden Server. Wenn nur ein NSPI-Zielserver eingegeben ist, löschen Sie den Registrierungswert NSPI Target Server.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Interaktion von Outlook 2000 SR-2-Clients und Clients unter höheren Versionen mit dem Active Directory®-Verzeichnisdienst finden Sie in den folgenden Knowledge Base-Artikeln:

  • 302914, „XCCC: How Outlook 2000 Accesses Active Directory" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914

  • 256976, „XCLN: How MAPI Clients Access Active Directory" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976


Ein nicht zu Exchange Server gehörendes MAPI-Teilsystem ist installiert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

The Microsoft® Exchange Server Analyzer Tool queries the CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) class to determine the version of MAPI32.dll that is in the two following folders:

<Laufwerk>:\Programme\Exchsrvr\Bin

%Systemroot%\System32

Wenn in den beiden Ordnern nicht die gleiche Version von MAPI32.dll gefunden wird, wird ein Fehler angezeigt.

Um sicherzustellen, dass eine einzige Version von MAPI verwendet wird, kopiert das Setup-Programm von Exchange Server die Datei MAPI32.DLL sowohl in das Verzeichnis <Laufwerk>:\Programme\Exchsrvr\Bin als auch in das Verzeichnis %Systemroot%\system32. Wenn eine andere MAPI-Anwendung, beispielsweise Microsoft Office Outlook® 2003 oder ein Programm eines Drittanbieters auf dem Exchange Server-Computer installiert ist, kann diese eine unterschiedliche Version von MAPI32.dll in den Ordner System32 kopieren und möglicherweise die Funktionalität von Exchange aufheben. Diese Probleme treten auf, da Versionen dieser beiden Produkte einen Konflikt auf dem MAPI-Teilsystem hervorrufen, der nicht ordnungsgemäß behoben werden kann, ohne dass entweder Exchange Server oder die andere MAPI-Anwendung abgebrochen wird.

Es wird dringend empfohlen, Outlook 2000 oder eine neuere Version von Outlook und Exchange Server 2003, Exchange 2000 Server oder Exchange Server 5.5 nicht auf demselben Computer zu installieren.

Ein verbreiteter Grund für die Installation von Outlook zusammen mit Exchange Server auf demselben Computer ist es, die Vorteile bestimmter Komponenten von Outlook in serverseitigen Programmen zu nutzen. Für die meisten Programmentwicklungsanforderungen wird Outlook auf einem Exchange-Computer nicht benötigt. Exchange Server enthält Datenobjekte für die Zusammenarbeit (CDO - Collaboration Data Objects), die ähnlich funktionieren wie das Objektmodell unter Outlook. Datenobjekte für die Zusammenarbeit sind für eine serverseitige Verwendung konzipiert und vermeiden die Implikationen, die in neueren Outlook-Versionen enthalten sind. Weitere Informationen hierzu finden Sie im Microsoft Knowledge Base-Artikel „OL2002: Entwicklerinformationen zu E-Mail-Sicherheitsfeatures" unter http://support.microsoft.com/?kbid=290500.

Ein weiterer gängiger Grund ist die Notwendigkeit der Erstellung von MAPI-Profilen. Exchange Server enthält alle Funktionen, die für die Erstellung von MAPI-Profilen erforderlich sind, und benötigt Outlook dazu nicht. Weitere Informationen zum Erstellen von MAPI-Profilen ohne die Installation von Outlook finden Sie im Knowledge Base-Artikel 306962 „SO WIRD'S GEMACHT: Erstellen von MAPI-Profilen ohne Installation von Outlook" unter http://support.microsoft.com/?kbid=306962.

Wenn Sie Outlook und Exchange Server aus Demonstrationszwecken auf demselben Computer installieren müssen, wird Ihnen empfohlen, eine der beiden folgenden Konfigurationen zu verwenden, die für Demonstrationszwecke getestet wurden:

  • Gemeinsame Verwendung von Exchange 2000 Server und Outlook 2000

  • Gemeinsame Verwendung von Exchange 2000 Server und Outlook 2002

So beheben Sie diesen Fehler

  1. Deinstallieren Sie Microsoft Outlook oder die MAPI-Anwendung des Drittanbieters vom Exchange-Server.

  2. Führen Sie das Setup-Programm von Exchange Server erneut aus, und klicken Sie auf Neu installieren.

Weitere Informationen zur Verwendung von Microsoft Office Outlook 2003 und Microsoft Exchange Server auf demselben Computer finden Sie im Microsoft Knowledge Base-Artikel 266418 „Microsoft does not support installing Exchange Server components and Outlook on the same computer" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=266418.

Weitere Informationen zum Beheben von MAPI-Konflikten finden Sie im Knowledge Base-Artikel 229700 „How to locate the correct path to the Mapisvc.inf file in Microsoft Outlook" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=229700.

Weitere Informationen über die MAPI32-Stub-Bibliothek finden Sie unter „Messaging API (MAPI)" (http://go.microsoft.com/fwlink/?linkid=34395).


Es wurde ein nicht von Microsoft stammendes ESE-Modul erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für Ese.dll zu ermitteln, das auch als ESE (Extensible Storage Engine) bekannte Exchange-Datenbank-Speichermodul.

Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber aller Verzeichnisobjekte mit der Objektkategorie msExchExchangeServer zu ermitteln. Wenn der Zeichenfolgenwert Version 5,5 enthält, wird auf dem Computer Microsoft Exchange Server 5,5 ausgeführt. Wenn der Zeichenfolgenwert Version 6.0 einschließt, wird auf dem Computer Microsoft Exchange 2000 Server ausgeführt. Wenn der Zeichenfolgenwert Version 6.5 enthält, wird auf dem Computer Microsoft Exchange Server 2003 ausgeführt.

Wenn Exchange Server Analyzer feststellt, dass der Wert für Version keine Unterzeichenfolge von 6 als Teil seiner Versionsinformation enthält, aber der Wert für serialNumber anzeigt, dass Exchange 2000 Server oder Exchange Server 2003 installiert ist, wird eine Warnung angezeigt. Diese Warnung zeigt an, dass eine nicht von Microsoft stammende Version von Ese.dll installiert ist und auf diesem Exchange Server-Computer verwendet wird. Dieses Problem muss so schnell wie möglich gelöst werden.

Ein Grund dafür kann die Verwendung ESE-basierter Antivirussoftware sein. Manche Antivirusprogramme auf ESE-Basis verwenden zwischen dem Exchange-Informationsspeicher und der ESE eine nicht unterstützte Schnittstelle. Wenn Sie eine solche Software verwenden und deren Implementierung fehlerhaft ist, besteht das Risiko, dass die Datenbank beschädigt wird und Datenverlust auftritt.

Während der Installation ändert die auf ESE basierende Virenprüfung den Microsoft Exchange-Informationsspeicherdienst so, dass dieser auf den Dienst des auf ESE basierenden Antivirusprogramms angewiesen ist. Dadurch wird sichergestellt, dass der Dienst des auf ESE basierenden Antivirusprogramms vor dem Microsoft Exchange-Informationsspeicherdienst startet. Wenn das auf ESE basierende Antivirenprogramm startet, wird die in Exchange Server enthaltene Version von Ese.dll vorübergehend in Xese.dll umbenannt, und die Version von Ese.dll, die zu dem auf ESE basierenden Antivirusprogramm gehört, ersetzt die Ursprungsdatei. Nach dem Laden der zum ESE-Antiusprogramm gehörenden Version von Ese.dll wird die in Exchange Server enthaltene Version wieder in Ese.dll zurück benannt, und der Microsoft Exchange-Informationsspeicherdienst schließt den Startvorgang ab.

Es wird dringend empfohlen, keine Implementierungen der ESE auf Exchange Server-Computern zu verwenden, die nicht von Microsoft stammen. Kunden, die den technischen Support von Microsoft kontaktieren, werden möglicherweise gebeten, das auf ESE basierende Antivirusprogramm zum Zweck der Problemsuche zu deaktivieren. Nachdem die Grundursache des Problems richtig erkannt wurde, können diese Kunden dann ihre Software wieder aktivieren.

Das meistverwendete Antivirus-Programm auf ESE-Basis ist Antigen für Microsoft Exchange von Sybari Software. Microsoft und Sybari stimmen darin überein, dass das Deaktivieren von Sybari Antigen ein sinnvoller Schritt zum Ermittlen der Ursachen von Problemen ist. Wenn Sie Kontakt mit Sybari Software aufnehmen möchten, besuchen Sie die Sybari Software-Website unter http://www.sybari.com.

Hinweis:
Die Informationen zur Website des Drittanbieters werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.

Außerdem wird die Verwendung von Antivirus-Programmen empfohlen, die die VSAPI (Virus Scanning Application Programming Interface) unterstützen, auch bekannt als Antivirus-API (AVAPI).

So beheben Sie diese Warnmeldung

  1. Führen Sie eine vollständige Sicherung des Exchange Server-Computers durch.

  2. Deinstallieren Sie Exchange Server von dem Computer.

  3. Installieren Sie Exchange Server erneut auf dem Computer.

  4. Verwenden Sie das neuste Service Pack/Updaterollup für Exchange Server 2003.

Weitere Informationen zum Ausführen von Antivirusensoftware auf Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" unter http://support.microsoft.com/kb/823166/de&kbid=823166.

  • 328841, „XADM: Exchange und Antivirus-Software" unter http://support.microsoft.com/kb/328841/DE/.


Eine nicht von Microsoft stammende ESE (Extensible Storage Engine) wurde erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert des Schlüssels Version für das Exchange-Datenbankspeichermodul Ese.dll zu ermitteln, das auch als ESE (Extensible Storage Engine) bezeichnet wird.

Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Objekte mit der Objektklasse msExchExchangeServer zu ermitteln. Wenn der Zeichenfolgenwert Version 5,5 enthält, wird auf dem Computer Microsoft Exchange Server 5,5 ausgeführt. Wenn der Zeichenfolgenwert Version 6.0 einschließt, wird auf dem Computer Microsoft Exchange 2000 Server ausgeführt. Wenn der Zeichenfolgenwert Version 6.5 enthält, wird auf dem Computer Microsoft Exchange Server 2003 ausgeführt.

Wenn der Exchange Server Analyzer feststellt, dass der Wert für Version keine Unterzeichenfolge 5.5 als Teil seiner Versionsinformation enthält, der Wert für serialNumber jedoch angibt, dass Exchange Server 5.5 installiert ist, wird eine Warnung angezeigt. Diese Warnung zeigt an, dass eine nicht von Microsoft stammende Version von Ese.dll installiert ist und auf diesem Exchange Server-Computer verwendet wird. Dieses Problem muss so schnell wie möglich gelöst werden.

Ein Grund dafür kann die Verwendung ESE-basierter Antivirussoftware sein. Manche Antivirusprogramme auf ESE-Basis verwenden zwischen dem Exchange-Informationsspeicher und der ESE eine nicht unterstützte Schnittstelle. Wenn Sie eine solche Software verwenden und deren Implementierung fehlerhaft ist, besteht das Risiko, dass die Datenbank beschädigt wird und Datenverlust auftritt.

Während der Installation ändert die auf ESE basierende Virenprüfung den Microsoft Exchange-Informationsspeicherdienst so, dass dieser auf den Dienst des auf ESE basierenden Antivirusprogramms angewiesen ist. Dadurch wird sichergestellt, dass der Dienst des auf ESE basierenden Antivirusprogramms vor dem Microsoft Exchange-Informationsspeicherdienst startet. Wenn das auf ESE basierende Antivirenprogramm startet, wird die in Exchange Server enthaltene Version von Ese.dll vorübergehend in Xese.dll umbenannt, und die Version von Ese.dll, die zu dem auf ESE basierenden Antivirenprogramm gehört, ersetzt die Ursprungsdatei. Nach dem Laden der zum ESE-Antivirenprogramm gehörenden Version von Ese.dll wird die in Exchange Server enthaltene Version wieder in Ese.dll zurück benannt, und der Microsoft Exchange-Informationsspeicherdienst beendet den Startvorgang.

Es wird dringend empfohlen, keine Implementierungen der ESE auf Exchange Server-Computern zu verwenden, die nicht von Microsoft stammen. Kunden, die den technischen Support von Microsoft kontaktieren, werden möglicherweise gebeten, das auf ESE basierende Antivirusprogramm zum Zweck der Problemsuche zu deaktivieren. Nachdem die Grundursache des Problems richtig erkannt wurde, können diese Kunden dann ihre Software wieder aktivieren.

So beheben Sie diese Warnmeldung

  1. Führen Sie eine vollständige Sicherung des Exchange Server-Computers durch.

  2. Installieren Sie Exchange Server erneut auf dem Computer.

  3. Verwenden Sie das aktuellste Service Pack und die neusten Aktualisierungen, die Sie auf der Website von Microsoft Exchange Server unter http://go.microsoft.com/fwlink/?LinkId=21573 erhalten können.
  • Weitere Informationen zum Ausführen von Antivirussoftware auf Exchange Server finden Sie im Microsoft Knowledge Base-Artikel 328841 „XADM: Exchange und Antivirus-Software" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841.

  • Weitere Informationen über das Wiederherstellen eines Exchange Server 5.5-Computers mit demselben Computernamen finden Sie im Knowledge Base-Artikel 155216, „XADM: Verschieben eines Exchange Servers auf einen neuen Computer mit demselben Namen" unter http://support.microsoft.com/kb/155216/de.


Nicht ausgelagerter Pool befindet sich über der Warnschwelle
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer sendet eine Abfrage an die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_PerfRawData_PerfOS_Memory, um den aktuellen Wert für den Schlüssel PoolNonpagedBytes zu ermitteln. Die von Exchange Server Analyzer ausgeführten Aktionen hängen vom verwendeten Betriebssystem, des Vorhandenseins oder Fehlens des Schalters /3GB in der Windows-Datei Boot.ini und des für den Schlüssel ermittelten Werts ab.

In der folgenden Tabelle wird die Matrix der Berechnungen angezeigt, die vom Exchange Server Analyzer verwendet wird, um zu ermitteln, ob dieser Wert für einen bestimmten Exchange-Server nicht geeignet ist. Wenn die Bedingungen in der folgenden Tabelle erfüllt werden, wird eine Warnung angezeigt.

Betriebssystem | Einstellungen von Boot.ini | Aktueller nicht ausgelagerter Pool ist
Microsoft® Windows 2000 Server oder Advanced Server | /3GB | 100 MB oder größer
Microsoft® Windows 2000 Server oder Advanced Server | Nicht vorhanden | 200 MB oder größer
Microsoft Windows Server™ 2003 | /3GB | 100 MB oder größer
Microsoft Windows Server 2003 | Nicht vorhanden | 200 MB oder größer

Der Wert des Schlüssels PoolNonpagedBytes ist die Größe (in Bytes) des nicht ausgelagerten Kernel-Speicher-Pools. Dies ist ein Bereich des physischen Systemspeichers für Objekte, die auch dann nicht auf den Datenträger geschrieben werden können, wenn sie nicht verwendet werden. Dieser Wert für den Schlüssel entspricht dem zuletzt beobachteten Wert. Auf einem optimal funktionierenden Exchange-Server sollte nicht mehr als 85 MB Speicher für den nicht ausgelagerten Pool verwendet werden, es sei denn, es erfolgt eine Sicherung oder Wiederherstellung.

In Windows 2000 Server und Windows 2000 Advanced Server beträgt der Maximalwert für den nicht ausgelagerten Speicher-Pool 256 MB. Da es nicht möglich ist, die Größe des nicht ausgelagerten Speicherpools über die oben angeführten Werte hinaus zu vergrößern, sollte dieser Zustand so schnell wie möglich korrigiert werden. Unabhängig vom verwendeten Betriebssystem und der An- oder Abwessenheit des „/3GB"-Schalters kann von Windows nur auf eine bestimmte Menge nicht ausgelagerten Speicher-Pool zugegriffen werden. Wenn unter Windows der Kernel-Speicherplatz zur Neige geht, werden möglicherweise Fehlermeldungen angezeigt, und das System stürzt ab. Kernel-Speicher ist für den ordnungsgemäßen Betrieb des Systems unabdingbar und sollte deshalb sorgfältig überwacht werden.

Wenn dieser Zustand nach dem Neustart des Exchange-Servers erneut auftritt, muss als nächster Schritt sichergestellt werden, dass das System ordnungsgemäß feineingestellt ist und dass sämtliche Software und Hardware auf dem neusten Stand ist. Dazu sollten die neusten Versionen folgender Komponenten installiert werden:

  • Service Pack für das Windows-Betriebssystem

  • Service Pack für Exchange Server

  • Hardware-Firmware und -Treiber

  • Aktualisierungen des System-BIOS

  • Aktualisierungen sämtlicher installierter und ausgeführter Anwendungen von Drittanbietern

Wenn Aktualisierungen der Software und Hardware dieses Problem nicht lösen, sollten Sie sämtliche Software von Drittanbietern deaktivieren, den Exchange Server-Computer erneut starten und den Kernel-Speicher überwachen.

So berichtigen Sie diesen Fehler

  1. Starten Sie den Exchange-Server bei der nächsten Gelegenheit neu.

  2. Überwachen Sie den Leistungsindikator Memory | Pool Nonpaged Bytes, um sicherzustellen, dass er den oben angeführten Grenzwert für Ihr System nicht überschreitet.

Weitere Informationen zum Feineinstellen des Exchange-Servers finden Sie in den folgenden Microsoft Knowledge Base-Artikeln und Whitepapers:

  • 815372, „Optimieren der Speichernutzung in Exchange Server 2003" unter http://support.microsoft.com/default.aspx?scid=kb;%5Bln%5D;815372

  • 266096, „XGEN: Exchange 2000 Requires /3GB Switch with More Than 1 Gigabyte of Physical RAM" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096).

  • „Troubleshooting Exchange Server 2003 Performance" (http://go.microsoft.com/fwlink/?LinkId=47588).

  • „Troubleshooting Exchange 2000 Performance" (http://go.microsoft.com/fwlink/?LinkId=18177).

  • „Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003" (http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=de).

Weitere Informationen zu Speicher für den nicht ausgelagerten Pool und verwandten Themen finden Sie in den folgenden Knowledge Base-Artikeln:

  • 294418, „Vergleich von 32-Bit- und 64-Bit-Speicherarchitektur" unter http://support.microsoft.com/default.aspx?scid=kb;de;294418

  • 177415, „"Poolmon"-Verwendung bei Speicherfehlern im Kernelmodus" unter http://support.microsoft.com/search/default.aspx?qu=177415&catalog=LCID%3D1031

  • 268343, „Umdhtools.exe: How to Use Umdh.exe to Find Memory Leaks" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=268343.


Die Anzahl der aus freien Seiten bestehenden Tabelleneinträge ist gering. Dies kann zu Systeminstabilität führen.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Einstellung für den Registrierungswert SystemPages zu ermitteln:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

Wenn Exchange Server Analyzer feststellt, dass der Wert für SystemPages auf 0 festgelegt ist und die Anzahl der freien PTEs (Page Table Entries, Seitentabelleneinträge) des Systems weniger als 3001 beträgt, wird eine Warnung angezeigt.

Microsoft Windows Server™ 2003 und Windows® 2000 Server können bis zu 4 Gigabyte (GB) Speicheradressraum direkt adressieren, unabhängig von der Größe des installierten physischen Arbeitsspeichers. Jedes Element einer virtuellen Adresse weist aus Prozesssicht konzeptionell auf ein Byte physischen Speichers. Es gehört zu den Aufgaben des Virtual Memory-Managers (VMM) zusammen mit der Speicherverwaltungseinheit (MMU, Memory Management Unit) des Prozessors, jede virtuelle Adresse in die entsprechende physische Adresse zu übersetzen bzw. sie darauf abzubilden. VMM führt diese Abbildung durch, indem er den RAM in Seitenframes mit fester Größe aufteilt, Seitentabelleneinträge (PTEs, Page Table Entries) zum Speichern der Informationen über diese Seitenframes erstellt und diese abbildet. Die Seitentabelleneinträge des Systems sind kleine Kernelmodus-Speicherpuffer, die verwendet werden, um mit dem Datenträger-E/A-Teilsystem und dem Netzwerk zu kommunizieren. Jeder Tabelleneintrag stellt einen Seitenframe dar und enthält die für VMM notwendigen Informationen, um eine Seite zuzuordnen.

Auf einem x86-basierten System, das eine Seitengröße von 4 KB verwendet, beträgt die Maximalanzahl der Seitentabelleneinträge, die zum Abbilden von 2 GB Adressraum benötigt wird, 524.288 (2 GB/4 KB). Auf einem vergleichbaren System, das den /3GB-Schalter verwendet, ist die Anzahl der Seitentabelleneinträge, die benötigt werden, um 3 GB Adressraum abzubilden, 786.432 (3 GB/4 KB). Auf einem typischen System wird dieser Raum wie folgt verwendet:

  • Ein Maximum von 50.000 Seitentabelleneinträgen (ungefähr 195 MB Adressraum) wird für allgemeine Verwendung reserviert.

  • Der Rest wird zum Abbilden von Systemcache, Hyperspace, ausgelagertem Pool, nicht ausgelagertem Pool, Bereich für Absturzspeicherabbild usw. verwendet.

Diese Poolgröße für Seitentabelleneinträge wird, basierend auf der im System vorhandenen Menge an physischem Speicher, automatisch beim Systemstart bestimmt. Dieser Pool wird zwischen ausgelagertem Pool und nicht ausgelagertem Pool gequetscht, der ebenfalls mit der Größe des physischen Speichers im System wächst.

Der Pool mit Seitentabelleneinträgen kann stark verwendet und hochgradig fragmentiert werden. Dies kann zu Situationen führen, in denen ein Treiber nicht geladen wird. Wenn der PTE-Pool des Systems auf null reduziert wird, werden davon auch andere Teile des Systems beeinträchtigt. Dies führt sogar dazu, dass Threads nicht erstellt werden, dass das System blockiert und möglicherweise abstürzt.

Ein gesunder Exchange Server-Computer sollte mindestens 5.000 Seitentabelleneinträge jederzeit verfügbar haben. Wenn die Anzahl freier Seitentabelleneinträge unter 5.000 fällt, aber über 3.001 bleibt, wird die in Freie Seitentabelleneinträge befinden sich an der Warnschwelle. beschriebene Warnung angezeigt. Wenn die Anzahl freier Seitentabelleneinträge unter 3.001 fällt, wird dieser Fehler angezeigt. Um dieses Problem zu beheben, können Sie die nachfolgend beschriebene Vorgehensweise verwenden, um den Registrierungswert SystemPages für das Betriebssystem Ihres Exchange Server-Computers entsprechend zu konfigurieren. Wenn Sie Exchange Server 2003 Service Pack 1 (SP1) unter Windows Server 2003 mit 1 GB oder mehr RAM ausführen, wird empfohlen, dass Sie den Registrierungsschlüssel SystemPages auf 0 festlegen. Diese Empfehlung unterscheidet sich von der Empfehlung für Microsoft Windows 2000 Server. Dort wird empfohlen, SystemPages auf einen Wert zwischen 24.000 und 31.000 festzulegen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

Nachdem Sie die nachfolgend beschriebene Prozedur ausgeführt haben, sollten Sie die Anzahl freier Seitentabelleneinträge überwachen. Das kann geschehen, indem Sie den Leistungsindikator Memory | Free System Page Table Entries mit dem Windows-Systemmonitor überwachen. Wenn die Anzahl der freien Seitentabelleneinträge niedrig bleibt, nachdem Sie die Änderungen an der Registrierung wie beschrieben vorgenommen haben, sollten Sie Folgendes prüfen, um sicherzugehen, dass der Exchange Server-Computer optimal konfiguriert ist:

  • Treiber Ein beschädigter Treiber ist eine der Hauptursachen für eine geringe Zahl von Seitentabelleneinträgen des Systems. Wenden Sie sich an Ihren Hardwarehersteller, um sich zu vergewissern, ob Sie die aktuellsten Treiber für Ihre Hardware verwenden. Es kann aber auch die Möglichkeit geben, zu einem einfacheren Treiber zurückzukehren. Beispielsweise brauchen Computer, auf denen serverbasierte Anwendungen wie Exchange Server ausgeführt werden, im Allgemeinen nicht die fortgeschrittensten Videotreiber mit all ihren Eigenschaften. Stattdessen ist ein einfacherer Treiber oft ausreichend. Das Wechseln von einem fortgeschrittenen Videotreiber zu einem einfachen Videotreiber sollte die Anzahl freier Seitentabelleneinträge erhöhen.

  • Systemkonfiguration Wenn in Ihrem System 1 GB oder mehr an physikalischem Speicher installiert ist, sollten Sie sich vergewissern, dass die Datei Boot.ini ordnungsgemäß mit den Schaltern /3GB und /USERVA=3030 konfiguriert ist, wie in den folgenden Microsoft Knowledge Base-Artikeln beschrieben:

    • 823440, „Sie müssen die Startoption "/3GB" verwenden, wenn Sie Exchange Server 2003 auf einem Windows Server 2003-System installieren" unter http://support.microsoft.com/kb/823440/de

    • 810371, „XADM: Using the /Userva Switch on Windows Server 2003-Based Exchange Servers" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371

  • Ereignisprotokolle Prüfen Sie das Ereignisprotokoll der Anwendung auf dem Exchange-Server auf Fehler und Warnungen, insbesondere auf die MSExchangeIS-Ereignisse 9582 (Fehler und Warnungen), 9665 (Warnung) und 12880 (Fehler). Das Vorhandensein von Ereignis 9665 könnte auch anzeigen, dass SystemPages nicht für eine optimale Leistung konfiguriert ist. Weitere Informationen zu diesen Ereignissen finden Sie im Microsoft Knowledge Base-Artikel 325044, „SO WIRD'S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" unter http://support.microsoft.com/default.aspx?scid=kb;de;325044.

So beheben Sie diese Warnung unter Windows 2000 Server

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Doppelklicken Sie im rechten Teilfenster auf SystemPages.

  4. Geben Sie in das Feld Wert einen Wert zwischen 24000 und 31000 (Dezimalwert) ein, und klicken Sie dann auf OK.

  5. Beenden Sie den Registrierungs-Editor, und starten Sie den Computer neu, damit die Änderung wirksam wird.

So beheben Sie diese Warnung unter Windows Server 2003

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Doppelklicken Sie im rechten Teilfenster auf SystemPages.

  4. Geben Sie im Feld Wert den Wert 0 ein, und klicken Sie dann auf OK.

  5. Beenden Sie den Registrierungs-Editor, und starten Sie den Computer neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Optimieren des Speichers für Exchange Server finden Sie in den folgenden Artikeln der Knowledge Base:

  • 325044, „SO WIRD'S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044

  • 815372, „Optimieren der Speichernutzung in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372

  • 311901, „The effects of 4GT tuning on System Page Table Entries" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901


Die Anzahl der fortlaufenden Aufrufe, die zurzeit auf den Virenscanner warten, befindet sich in der Nähe des Grenzwerts
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-13

Microsoft® Exchange Server Analyzer Tool untersucht das FCL-Protokoll (Function Call Log) von Exchange, die Datei Store.fcl, um die Anzahl aktueller, fortlaufender komponentenübergreifender Aufrufe des Microsoft Exchange-Informationsspeicherdienstes (Store.exe) an die VAPI-Komponente (Virus API) zu ermitteln.

Exchange Server Analyzer fragt außerdem den Schlüssel ScanningThreads aus dem folgenden Registrierungseintrag ab, um die maximal zulässige Anzahl von Threads für VAPI-Komponentenaufrufe zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Fortlaufende Aufrufe sind Anforderungen vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an andere Komponenten, die noch keine Antwort erhalten haben, wenn die Exchange FCL-Daten in die Datei Store.fcl geschrieben werden.

Wenn Exchange Server Analyzer feststellt, dass die Anzahl fortlaufender Aufrufe vom Exchange-Informationsspeicherdienst (Store.exe) an die VAPI-Komponente die maximal zulässige Anzahl von Threads erreicht, wird ein Fehler angezeigt.

Wenn komponentenübergreifende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) auf eine Antwort warten, können RPC-Threads (Remote Procedure Call, Remoteprozeduraufruf) diese Anforderungen im Hintergrund unterstützen, sodass es zu Exchange Server-Leistungsproblemen kommt, z. B. zu Verzögerungen der Serverantworten an die Clients.

Fortlaufende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst an die VAPI-Komponente können folgende Ursachen haben:

  • Aktualisierungen eines Virenscanners, die dazu führen, dass die Objekte im Informationsspeicher erneut geprüft werden

  • Ein fehlerhaft konfigurierter Virenscanner

  • Verarbeitung einer umfangreichen Nachricht oder Anlage durch die Virenscannersoftware

Um diesen Fehler zu beheben, führen Sie folgende Schritte aus:

  • Planen Sie Aktualisierungen des Antivirenmoduls in Zeiten mit geringer Ressourcenbelastung, d. h. außerhalb von Spitzennutzungsintervallen.

  • Erwägen Sie, die Virenscannersoftware neu zu installieren (außerhalb von Spitzennutzungsintervallen)

  • Untersuchen Sie die Konfiguration Ihres Virenscannermoduls hinsichtlich der ordnungsgemäßen Threadkonfiguration, Ausschlüssen auf Dateiebene usw. Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 823166, "Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Vergrößern Sie die Threadanzahl für die Virenscanner-API:

    Der optimale Wert für ScanningThreads ist gleich (2 x NumberOfProcessors) + 1. Auf einem Server, auf dem Exchange Server ausgeführt wird, mit zwei Prozessoren ist beispielsweise der optimale Wert für ScanningThreads gleich 5.

    Hinweis:
    Bei aktiviertem Hyper-Threading beträgt der Wert für NumberOfProcessors das Zweifache der Anzahl der physikalischen Prozessoren. Es wird empfohlen, sich beim Hersteller Ihrer Antivirussoftware zu erkundigen, ob in dieser Formel physische oder logische Prozessoren verwendet werden sollen.
Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema "Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So vergrößern Sie die Threadanzahl

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. Doppelklicken Sie im rechten Bereich auf ScanningThreads.

  4. Geben Sie den Wert ein, der aus der obigen Formel zurückgegeben wird.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie anschließend den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 "Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

  • Im Abschnitt "Weitere Informationen" dieses Themas finden Sie weitere Artikel.

Weitere Informationen

Weitere Informationen zu den in Microsoft Exchange Server 2003 üblicherweise verwendeten Virenprüfprogrammen finden Sie im Microsoft Knowledge Base-Artikel 823166, "Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Weitere Informationen zu den in Microsoft Exchange 2000 Server üblicherweise verwendeten Virenprüfprogrammen finden Sie im Knowledge Base-Artikel 328841, "XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Weitere Informationen zur Leistung von Exchange Server finden Sie im "Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47576).

Weitere Informationen zur Behandlung von Leistungsproblemen von Exchange Server finden Sie im Handbuch "Troubleshooting Microsoft Exchange Server Performance" (http://go.microsoft.com/fwlink/?LinkId=47588).

Weitere Informationen zur Behandlung von Leistungsproblemen von Informationsspeichern finden Sie im Microsoft Knowledge Base-Artikel 257725, "XADM: Sammeln von Diagnosedaten zur Problembehandlung des Informationsspeichers" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

Weitere Informationen zur Hyper-Threading-Technologie finden Sie auf der Intel-Webseite (http://www.intel.com/technology/hyperthread).

Hinweis:
Die Informationen zur Website des Drittanbieters in diesem Thema werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.


Datei „OABGEN.DLL" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere der obigen Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Product Key ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Abrufen des neusten Service Packs/Updaterollups für Exchange Server 5.0
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs versionNumber für jedes ExchangeServer-Objekt zu ermitteln. Das Attribut versionNumber stellt die Exchange Server-Version dar, die auf dem Computer ausgeführt wird.

Exchange Server Analyzer fragt außerdem die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile ab, um den für den Prozess STORE.EXE festgelegten Wert des Schlüssels Version zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass der Schlüssel Version für STORE.EXE einen Wert aufweist, der größer oder gleich 1460, aber kleiner als 1462 ist, wird eine Warnung angezeigt.

Diese Warnung gibt an, dass auf dem Exchange Server-Computer nicht der neueste verfügbare Code für die Exchange-Version auf dem Computer ausgeführt wird.

So beheben Sie diese Warnmeldung

  1. Downloaden Sie im Microsoft Download Center unter http://go.microsoft.com/fwlink/?LinkId=41361 das neueste Sicherheitsupdate (April 2004) für Exchange Server 5.0.

  2. Informationen zu diesem Update finden Sie im Microsoft Knowledge Base-Artikel 834130 „Update Rollup für Microsoft Exchange 5.0" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=834130.

  3. Nehmen Sie eine vollständige Sicherung des Exchange Server-Computers vor.

  4. Wenden Sie das Update von April 2004 an.

Wie Sie das neueste Updaterollup für Exchange Server 5.0 Service Pack 2 erhalten können, erfahren Sie im Knowledge Base-Artikel 168858 „XGEN: How to Obtain Exchange Server 5.0 U.S. Service Pack 2" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168858.

Weitere Informationen zum Installieren dieser und anderer Exchange Server-Updates finden Sie im Knowledge Base-Artikel 328839 „Wie Sie Service Packs und Hotfixes für Exchange anwenden" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839.


Abrufen des neusten Service Pack/Updaterollup für Exchange Server 5.5
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs versionNumber für jedes ExchangeServer-Objekt zu ermitteln. Das Attribut versionNumber stellt die Exchange Server-Version dar, die auf dem Computer ausgeführt wird.

Exchange Server Analyzer fragt außerdem die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile ab, um den für den Prozess STORE.EXE festgelegten Wert des Schlüssels Version zu ermitteln. Falls Exchange Server Analyzer feststellt, dass der Schlüssel Version für STORE.EXE einen Wert größer oder gleich 2653, aber kleiner als 2658 aufweist, wird eine Warnmeldung angezeigt. Dies zeigt an, dass auf dem Computer Exchange Server 5.5 Service Pack 4 oder Exchange Server 5.5 Service Pack 4 mit Hotfixes ausgeführt wird.

Diese Warnung gibt an, dass auf dem Exchange Server-Computer nicht der neueste verfügbare Code für die Exchange-Version auf dem Computer ausgeführt wird.

So beheben Sie diese Warnmeldung

  1. Downloaden Sie im Microsoft Download Center unter http://go.microsoft.com/fwlink/?LinkId=33456 das aktuelle Update (Mai 2004) für Exchange Server 5.5.

  2. Weitere Informationen zu diesem Update finden Sie im Microsoft Knowledge Base-Artikel 841765 „May 2004 Update Rollup for Exchange Server 5.5" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=841765.

  3. Nehmen Sie eine vollständige Sicherung des Exchange Server-Computers vor.

  4. Verwenden Sie die Aktualisierung vom Mai 2004.

Weitere Informationen zum Installieren dieser und anderer Exchange Server-Updates finden Sie im Microsoft Knowledge Base-Artikel 328839 „Wie Sie Service Packs und Hotfixes für Exchange anwenden" unter http://support.microsoft.com/kb/328839/de.


Abrufen des neusten Service Packs/Updaterollups für Exchange Server 2003
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs versionNumber für jedes ExchangeServer-Objekt zu ermitteln. Das Attribut versionNumber stellt die Exchange Server-Version dar, die auf dem Computer ausgeführt wird.

Exchange Server Analyzer fragt außerdem die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile ab, um den für den Prozess STORE.EXE festgelegten Wert des Schlüssels Version zu ermitteln.

  • Der Wert 7638 beim Schlüssel Version bedeutet, dass Exchange Server 2003 Service Pack 2 installiert ist

  • Der Wert 7226 beim Schlüssel Version bedeutet, dass Exchange Server 2003 Service Pack 1 installiert ist

  • Der Wert 6944 beim Schlüssel Version bedeutet, dass die Originalversion von Exchange Server 2003 installiert ist

  • Ein Wert zwischen den obigen Versionen zeigt an, dass der Server eine Hotfix-Aktualisierungsversion des Prozesses STORE.EXE ausführt.

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel Version für Store.exe einen Wert kleiner als 7638 aufweist, wird eine Warnmeldung angezeigt.

Diese Warnung zeigt an, dass auf dem Exchange Server-Computer nicht der neueste verfügbare Code für die Version von Exchange Server auf dem Computer ausgeführt wird.

So beheben Sie diese Warnmeldung

  1. Downloaden oder bestellen Sie Service Pack 2 für Exchange Server 2003 von entsprechenden Website unter http://go.microsoft.com/fwlink/?LinkId=54751.

  2. Lesen Sie die Versionsinformationen für Service Pack 2 auf der Website für Exchange Server 2003 SP1-Versionsinformationen (http://go.microsoft.com/fwlink/?LinkId=52072).

  3. Nehmen Sie eine vollständige Sicherung des Exchange Server-Computers vor.

  4. Wenden Sie das Service Pack 2 für Exchange Server 2003 an.

Weitere Informationen zum Installieren dieser und anderer Exchange Server-Updates finden Sie im Microsoft Knowledge Base-Artikel 328839 „Wie Sie Service Packs und Hotfixes für Exchange anwenden" unter http://support.microsoft.com/kb/328839/de.


Abrufen des neusten Service Pack/Updaterollup für Exchange Server 2000
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs versionNumber für jedes ExchangeServer-Objekt zu ermitteln. Das Attribut versionNumber stellt die Exchange Server-Version dar, die auf dem Computer ausgeführt wird.

Exchange Server Analyzer fragt außerdem die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile ab, um den für den Prozess STORE.EXE festgelegten Wert des Schlüssels Version zu ermitteln. Falls Exchange Server Analyzer bestimmt, dass der Schlüssel Version für STORE.EXE einen Wert in einem der folgenden Bereiche hat, wird eine Warnung angezeigt.

  • Größer als 6249 und kleiner als oder gleich 6396

  • Größer als 6396 und kleiner als oder gleich 6487

  • Größer als 6487 und kleiner als oder gleich 6556

  • Größer als 6556 und kleiner als oder gleich 6603

  • Größer als 6603 und kleiner als 6700

Diese Warnung gibt an, dass auf dem Exchange Server-Computer nicht der neueste verfügbare Code für die Exchange-Version auf dem Computer ausgeführt wird.

So beheben Sie diese Warnmeldung

  1. Downloaden Sie das neueste Update (August 2004) von der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).

  2. Lesen Sie zur neuesten Aktualisierung den Artikel 870540 „Availability of the August 2004 Exchange 2000 Server Post-Service Pack 3 Update Rollup" in der Microsoft Knowledge Base unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540.

  3. Nehmen Sie eine vollständige Sicherung des Exchange Server-Computers vor.

  4. Wenden Sie die Aktualisierung vom August 2004 an.

Weitere Informationen zum Installieren dieser und anderer Exchange Server-Aktualisierungen finden Sie im Knowledge Base-Artikel 328839 „Wie Sie Service Packs und Hotfixes für Exchange anwenden" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839.


Der Offline-Adressbuchserver wurde gelöscht
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-12-03

Microsoft® Exchange Server Analyzer sendet eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert des Attributs offLineABServer für das Konfigurationsobjekt des Offlineadressbuchs zu bestimmen. Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert des Attributs offLineABServer die Zeichenfolge „DEL:" enthält, wird ein Fehler angezeigt.

Bei dem Attribut offLineABServer handelt es sich um ein Distinguished-Name-Attribut, das nur einen Wert haben darf. Es speichert den Distinguished Name des Exchange Server-Computers, der für das Generieren von Offlineadressbüchern zuständig ist. Exchange generiert und speichert die Offlineadressbuchdateien aller Offlinadressbücher in einer Sammlung von Öffentlichen Ordnern auf einem angegebenen Server. Dieser Fehler zeigt an, dass der im Attribut offLineABServer des Konfigurationsobjekts für das Offlineadressbuch angegebene Server nicht vorhanden ist. Dies kann der Fall sein, wenn der alte Offlineadressbuchserver außer Betrieb genommen oder nicht ordnungsgemäß aus der Topologie entfernt wurde. Exchange generiert das Offlineadressbuch erst dann, wenn ein neuer Server angegeben wird.

So beheben Sie diesen Fehler in Exchange 2000 Server und Exchange Server 2003

  1. Klicken Sie im Exchange-System-Manager unter Empfänger auf Offlineadresslisten. Klicken Sie im rechten Bereich mit der rechten Maustaste auf Standard-Offlineadressliste (oder auf jede andere Offlineadressliste, die diese Meldung erzeugt), und klicken Sie dann auf Eigenschaften.

  2. Klicken Sie auf der Registerkarte Allgemein unter Server für Offlineadresslisten auf Durchsuchen, und klicken Sie dann auf den Server, der verwendet werden soll.

So beheben Sie diese Warnung in Exchange Server 2007

  1. Öffnen Sie die Exchange-Verwaltungskonsole.

  2. Erweitern Sie Microsoft Exchange, dann Organisationskonfiguration, und wählen Sie Postfach aus.

  3. Klicken Sie im Ergebnisbereich auf die Registerkarte Offlineadressbuch.

  4. Wählen Sie auf der Registerkarte Offlineadressbuch die Option Standard-Offlineadressbuch aus. Klicken Sie im Aktionsbereich auf Verschieben, um den Assistenten zum Verschieben von Offlineadressbüchern zu starten. Mit diesem Assistenten können Sie die Erstellung von Offlineadressbüchern auf einen anderen Server verlagern. Außerdem werden vorhandene Offlineadressbuchdateien auf den angegebenen Server kopiert.

So verwenden Sie die Exchange-Verwaltungsshell zum Festlegen des Servers, auf dem das Offlineadressbuch erstellt wird

  • Führen Sie den folgenden Befehl aus:

    Code kopieren
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    Dabei gilt Folgendes: <OAB> gibt den DN (Distinguished Name), den Domänen-\Kontonamen oder die GUID des Offlineadressbuchs an, und <Server> gibt den Exchange-Server an, auf dem die ausgewählte Aktion durchgeführt wird.

    Zum Verlagern der Erstellung von Offlineadressbüchern auf SERVER01, geben Sie z. B. Folgendes ein:
Code kopieren
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Weitere Informationen zum Verwenden von Offlineadressbüchern in Exchange Server 2003 finden Sie in Arbeiten mit dem Exchange Server 2003-Informationsspeicher (http://go.microsoft.com/fwlink/?LinkId=47595) unter „Konfigurieren der Offlineadressbücher von Exchange Server 2003".

Weitere Informationen zum Verwenden von Offlineadressbüchern in Exchange Server 2007 finden Sie in unter „Organisationskonfiguration > Postfach > Offlineadressbücher" (http://go.microsoft.com/fwlink/?LinkId=79247).


Der Offlineadressbuchserver wird auf einem Front-End-Server ausgeführt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer sendet eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert des Attributs offLineABServer für das Konfigurationsobjekt des Offlineadressbuchs zu bestimmen. Bei dem Attribut offLineABServer handelt es sich um ein Distinguished-Name-Attribut, das nur einen Wert haben darf. Es speichert den Distinguished Name des Exchange Server-Computers, der für das Generieren von Offlineadressbüchern zuständig ist.

Exchange Server Analyzer fragt außerdem die WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Exchange_Server Microsoft ab, um den Wert des Schlüssels IsFrontEndServer für den Exchange-Server zu bestimmen. Wenn True der Wert für den Schlüssel IsFrontEndServer ist, wird der Exchange-Server als Front-End-Server verwendet.

Wenn Microsoft Exchange Server Analyzer feststellt, dass ein als Offlineadressbuchserver verwendeter Server auch als Front-End-Server fungiert, zeigt Microsoft Exchange Server Analyzer eine Fehlermeldung an.

Dieser Fehler gibt an, dass der zum Generieren von Offlineadressbüchern benannte Exchange-Server ein Front-End-Server ist. Wenn der angegebene Offlineadressbuchserver zugleich als Front-End-Server fungiert, kann das Offlineadressbuch nicht generiert werden. Für diese Aufgabe sollte ein neuer Server benannt werden. Wenn ein Server, auf dem Microsoft Exchange 2000 Server mit Service Pack 2 oder höher ausgeführt wird, als Front-End-Server festgelegt wird, werden die folgenden Dienste nicht mehr ausgeführt:

  • DSProxy

  • Generieren von Offlineadresslisten

  • Empfängeraktualisierungsdienst

  • Freie und gebuchte Aufgaben

  • Cleanup-Agent für Postfächer

  • Exchange-Ereignisdienst

  • Standortreplikationsdienst (SRS, Site Replication Service)

Front-End-Server wurden für die Verarbeitung von Clientanforderungen entwickelt, die von Microsoft Office Outlook® Web Access-, POP3-, IMAP4-, Exchange ActiveSync-, Outlook Mobile Access- und Outlook-Clients eingehen, die für die Verwendung von RPC-über-HTTP konfiguriert wurden. Über Front-End-Server werden auch gelegentlich SMTP-Nachrichten an interne Exchange-Server weitergeleitet.

Zum Beheben dieses Problems wird empfohlen, einen Back-End-Exchange-Server als Offlineadressbuchserver festzulegen.

So beheben Sie diesen Fehler

  1. Öffnen Sie den Exchange-System-Manager.

  2. Klicken Sie unter Empfänger auf Offlineadresslisten.

  3. Klicken Sie im rechten Bereich mit der rechten Maustaste auf Standard-Offlineadressliste, und klicken Sie dann auf Eigenschaften.

    Hinweis:
    Gehen Sie für alle anderen Offlineadresslisten, bei denen diese Meldung angezeigt wird, in gleicher Weise vor.

  4. Klicken Sie auf der Registerkarte Allgemein unter Server für Offlineadresslisten auf Durchsuchen, und klicken Sie dann auf den zu verwendenden Back-End-Exchange-Server.

Weitere Informationen zum Arbeiten mit Offlineadressbüchern finden Sie in Working with Exchange Server 2003 Stores (http://go.microsoft.com/fwlink/?LinkId=47595) unter „Configuring Exchange Server 2003 Offline Address Books".


Der Öffentliche Ordner mit dem Offlineadressbuch-Standort wurde gelöscht
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-12-03

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs siteFolderServer für jedes Objekt im Informationsspeicher für Öffentliche Ordner zu ermitteln. Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert des Attributs siteFolderServer die Zeichenfolge „DEL:" enthält, wird ein Fehler angezeigt.

Das Attribut siteFolderServer stellt den Informationsspeicher für Öffentliche Ordner dar, der für den Offlineadressbuch-Server verwendet wird. In der Standardeinstellung erstellt Exchange Server Offlineadressbuch-Dateien auf dem Server für Standortordner (der erste in der administrativen Gruppe installierte Server). Wenn Sie einen anderen Server als Offlineadressbuch-Server angegeben haben, stellt der in diesem Attribut aufgelistete Informationsspeicher für Öffentliche Ordner den Speicher auf dem neuen Offlineadressbuch-Server dar, und nicht den Speicher auf dem aktuellen Server für Standortordner der administrativen Gruppe.

Wenn Exchange Server 2003 Offlineadressbuch-Dateien erstellt, werden die Dateien an E-Mail-Nachrichten angefügt und in besondere Öffentliche Ordner gestellt. Microsoft Office Outlook® 2003 ruft die Nachrichten aus dem Ordner ab und downloadet die angefügten Dateien.

Die Offline-Adressbuchnachrichten werden in Unterordnern des Ordners Offlineadressbuch gespeichert, der einen der Systemordner in der Standardstruktur für Öffentliche Ordner darstellt. Der Ordner verfügt über einen Unterordner für jede administrative Gruppe oder jeden Standort in Ihrer Topologie. In der Standardeinstellung ist ein Inhaltsreplikat einer speziellen administrativen Gruppe auf dem ersten Server gespeichert, der in der administrativen Gruppe installiert wurde (als Server für Standortordner bezeichnet).

Wenn es sich bei Ihrer Exchange-Organisation um Exchange Server 2007 ohne Clients älterer Versionen (Outlook 2003 oder früher) handelt, können Sie diese Warnung oder diesen Fehler ignorieren. Wenn sich in Ihrer Exchange Server 2007-Organisation Clients mit Outlook 2003 oder früher befinden, führen Sie das unten stehende Verfahren aus, um die Verteilung der Offlineadressbuchdateien in Öffentlichen Ordnern zu aktivieren. Bei der Verteilung in Öffentlichen Ordnern handelt es sich um ein Verteilungsverfahren für den Zugriff auf das Offlineadressbuch durch Clients mit Outlook 2003 oder früheren Versionen, die offline oder über eine DFÜ-Verbindung arbeiten.

So beheben Sie diesen Fehler

  1. Wenn Sie wissen, dass der Server vorhanden ist, erweitern Sie im Exchange-System-Manager unter Server den Server, erweitern Sie die Speichergruppe, und klicken Sie auf Informationsspeicher für Öffentliche Ordner. Überprüfen Sie den rechten Bereich, um sicherzustellen, dass der Exchange-Informationsspeicher ausgeführt wird.

  2. Um einen neuen Offlineaddressbuch-Server anzugeben, klicken Sie unter Empfänger auf Offlineadresslisten. Klicken Sie anschließend im rechten Bereich auf Standard-Offlineadressliste (oder auf jede andere Offlineadressenliste, die diese Nachricht erstellt).

    Wenn Sie kein Offlineadressbuch verwenden möchten, klicken Sie mit der rechten Maustaste auf Standard-Offlineadressbuch, und klicken Sie dann auf Löschen. Gehen Sie andernfalls wie im restlichen Teil der Beschreibung dieses Vorgangs vor, um einen Zeitplan festzulegen.

  3. Klicken Sie mit der rechten Maustaste auf Standard-Offlineadressliste, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf der Registerkarte Allgemein unter Offlineaddressbuch-Serverauf Durchsuchen, um einen Server auszuwählen.

So beheben Sie diese Warnung in Exchange Server 2007

  1. Öffnen Sie die Exchange-Verwaltungskonsole.

  2. Erweitern Sie Microsoft Exchange, dann Organisationskonfiguration, und wählen Sie Postfach aus.

  3. Klicken Sie im Ergebnisbereich auf die Registerkarte Offlineadressbuch.

  4. Wählen Sie auf der Registerkarte Offlineadressbuch die Option Standard-Offlineadressbuch aus.

    1. Zum Aktivieren der Verteilung des Offlineadressbuchs in Öffentlichen Ordnern wählen Sie auf der Registerkarte Verteilung die Option Verteilung in öffentlichen Ordnern aktivieren.

    2. Klicken Sie auf OK, um die Änderungen zu speichern.

  5. Zum Festlegen eines neuen Offlineadressbuchservers klicken Sie im Aktionsbereich auf Verschieben, um den Assistenten zum Verschieben von Offlineadressbüchern zu starten. Mit diesem Assistenten können Sie die Erstellung von Offlineadressbüchern auf einen anderen Server verlagern. Außerdem werden vorhandene Offlineadressbuchdateien auf den angegebenen Server kopiert.

So verwenden Sie die Exchange-Verwaltungsshell, um die Verteilung von Offlineadressbuchdateien in Öffentlichen Ordnern zu aktivieren

  • Führen Sie den folgenden Befehl aus:

    Code kopieren
    Set-OfflineAddressBook -Identity <OAB> -PublicFolderDistributionEnabled $true

    Dabei gilt Folgendes: <OAB> gibt den DN (Distinguished Name), den Domänen-\Kontonamen oder die GUID des Offlineadressbuchs an.

    Zum Aktivieren der Verteilung des Standardofflineadressbuchs in Öffentlichen Ordnern geben Sie z. B. Folgendes ein:
Code kopieren
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -PublicFolderDistributionEnabled $true

So verwenden Sie die Exchange-Verwaltungsshell zum Festlegen des Servers, auf dem das Offlineadressbuch erstellt wird

  • Führen Sie den folgenden Befehl aus:

    Code kopieren
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    Dabei gilt Folgendes: <OAB> gibt den DN (Distinguished Name), den Domänen-\Kontonamen oder die GUID des Offlineadressbuchs an, und <Server> gibt den Exchange-Server an, auf dem die ausgewählte Aktion durchgeführt wird.

    Zum Verlagern der Erstellung von Offlineadressbüchern auf SERVER01, geben Sie z. B. Folgendes ein:
Code kopieren
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Weitere Informationen zum Verwenden von Offlineadressbüchern in Exchange Server 2003 finden Sie in Arbeiten mit dem Exchange Server 2003-Informationsspeicher (http://go.microsoft.com/fwlink/?LinkId=47595) unter „Konfigurieren der Offlineadressbücher von Exchange Server 2003".

Weitere Informationen zum Verwenden von Offlineadressbüchern in Exchange Server 2007 finden Sie in unter „Organisationskonfiguration > Postfach > Offlineadressbücher" (http://go.microsoft.com/fwlink/?LinkId=79247).


Es wurde eine ältere Datei „CDO.DLL" erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuellste Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Beim Ausführen von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Es wurde eine ältere Datei „DAVEX.DLL" erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Beim Ausführen von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Es wurde eine ältere Datei „DRVIIS.DLL" erkannt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-10-06

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um den Wert des Schlüssels Version für mehrere entscheidende Binärdateien von Exchange zu bestimmen.

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • DrvIis.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine dieser Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Updates neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie auf Start und dann auf Ausführen. Geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Wenn Sie den Bedingungen zustimmen, klicken Sie auf Ich stimme zu, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie anschließend auf Weiter.

  6. Klicken Sie auf dem Bildschirm Auswahl der Komponenten in der Spalte Vorgang auf den Dropdownpfeil neben dem Knoten Microsoft Exchange, und wählen Sie Erneut installieren aus. Klicken Sie anschließend auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Es wurde eine ältere Datei „DSACCESS.DLL" erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuellste Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Es wurde eine ältere Datei „EMSMTA.EXE" erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuellste Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Beim Ausführen von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Es wurde eine ältere Datei „EPOXY.DLL" erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuellste Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Beim Ausführen von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Es wurde eine ältere Datei „ESE.DLL" erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-06-20

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Product Key ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Es wurde eine ältere Datei „ESEUTIL.EXE" erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuellste Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Beim Ausführen von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Eine ältere Datei „EXCDO.DLL" wurde erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuellste Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Es wurde eine ältere Datei „EXCHMEM.DLL" erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Product Key ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Ältere EXCHMEM.DLL vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um den Wert des Schlüssels Version für mehrere entscheidende Binärdateien von Exchange Server zu bestimmen. Zu diesen Dateien gehört Exchmem.dll. Wenn Exchange Server Analyzer feststellt, dass die Datei Exchmem.dll im Ordner \%systemroot%\system32 älter als die Datei Exchmem.dll im Ordner \%exchangeroot%\bin folder ist, zeigt Exchange Server Analyzer eine Warnung an.

Normalerweise gibt es keine zwei Kopien der Datei Exchmem.dll auf einem Server. Manchmal wird jedoch durch die direkte Aktualisierung von früheren Versionen des Produkts eine zweite Datei Exchmem.dll hinzugefügt. Wenn es zwei Versionen dieser Datei gibt, kann die Installation von Service Packs fehlschlagen. Um Probleme zu vermeiden, wird empfohlen, dass Sie die Datei Exchmem.dll im Ordner \%systemroot%\system32 umbenennen.

So beheben Sie diese Warnung

  1. Beenden Sie alle Exchange-Dienste.

  2. Benennen Sie die Datei Exchmem.dll im Ordner \%systemroot%\system32 in Exchmem.dll.old um.

  3. Starten Sie alle Exchange-Dienste neu.


Es wurde eine ältere Datei „EXMIME.DLL" erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuellste Service Pack, oder führen Sie ein Updatefollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Es wurde eine ältere Datei „EXOLEDB.DLL" erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Product Key ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Es wurde eine ältere Datei „EXPOP3.DLL" erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Beim Ausführen des Setup-Programms im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden weder Benutzer- noch Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Product Key ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Es wurde eine ältere Datei „EXPROX.DLL" erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Beim Ausführen von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Es wurde eine ältere Datei „EXRES.DLL" erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Beim Ausführen des Setup-Programms im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden weder Benutzer- noch Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Product Key ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Ältere Datei „EXSMTP.DLL" wurde erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuellste Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Es wurde eine ältere Datei „MAD.EXE" erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Beim Ausführen von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Product Key ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Es wurde eine ältere Datei „MAPI32.DLL" erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Beim Ausführen des Setup-Programms im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden weder Benutzer- noch Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Product Key ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Es wurde eine ältere Datei „MAPI32.DLL" im Ordner „system32" erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuellste Service Pack, oder führen Sie ein Updaterollups für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Beim Ausführen von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Es wurde eine ältere Datei „MDBSZ.DLL" erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuellste Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Es wurde eine ältere Datei „OABGEN.DLL" erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuellste Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Eine ältere Datei „PHATCAT.DLL" wurde erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Beim Ausführen von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Eine ältere Datei „PHATQ.DLL" wurde erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuellste Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Es wurde eine ältere Datei „REAPI.DLL" erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuellste Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Es wurde eine ältere Datei „RESVC.DLL" erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für mehrere binäre Exchange-Kerndateien zu bestimmen:

  • Exres.dll

  • Gapi32.dll (überprüft sowohl im Ordner System32 als auch im Ordner \Exchsrvr\bin)

  • Mapi32.dll (überprüft sowohl im Ordner System32 als auch im Ordner \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine der oben genannten Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Es wurde eine ältere Datei „STORE.EXE" erkannt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-10-06

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um den Wert des Schlüssels Version für mehrere entscheidende Binärdateien von Exchange zu bestimmen.

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert Version für eine dieser Dateien kleiner ist als der Wert Version für ExchangeServer, wird eine Warnung angezeigt. Eine frühere Versionsnummer weist darauf hin, dass möglicherweise veraltete Dateien verwendet werden.

Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Updaterollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Updates neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie auf Start und dann auf Ausführen. Geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Wenn Sie den Bedingungen zustimmen, klicken Sie auf Ich stimme zu, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie anschließend auf Weiter.

  6. Klicken Sie auf dem Bildschirm Auswahl der Komponenten in der Spalte Vorgang auf den Dropdownpfeil neben dem Knoten Microsoft Exchange, und wählen Sie Erneut installieren aus. Klicken Sie anschließend auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2000 finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Fortlaufende Aufrufe an Active Directory gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-14

Microsoft® Exchange Server Analyzer Tool untersucht das FCL-Protokoll (Function Call Log) von Exchange, die Datei Store.fcl, auf Ereignisse, die auf fortlaufende komponentenübergreifende Aufrufe des Microsoft Exchange-Informationsspeicherdienstes (Store.exe) an den Active Directory®-Verzeichnisdienst hinweisen.

Fortlaufende Aufrufe sind Anforderungen vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an andere Komponenten, die noch keine Antwort erhalten haben, wenn die Exchange FCL-Daten in die Datei Store.fcl geschrieben werden.

Active Directory stellt alle Postfachinformationen, Adresslistendienste und andere Informationen zu Empfängern bereit. Die meisten Exchange Server 2003-Konfigurationsinformationen werden ebenfalls in Active Directory gespeichert.

Exchange Server-Dienste greifen auf die in Active Directory gespeicherten Informationen zu und schreiben Informationen in Active Directory.

Wenn Exchange Server Analyzer feststellt, dass Ereignisse in der Datei Store.fcl fortlaufende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an Active Directory darstellen, wird eine Warnung angezeigt.

Diese Warnung weist darauf hin, dass es bei diesem Server zu einem Leistungsproblem kommen kann. Gelegentliche fortlaufende Aufrufe weisen im Gegensatz zu wiederholten fortlaufenden Aufrufen nicht notwendigerweise auf ein Problem hin.

Wenn komponentenübergreifende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) auf eine Antwort warten, können RPC-Threads (Remote Procedure Call, Remoteprozeduraufruf) diese Anforderungen im Hintergrund unterstützen, sodass es zu Exchange Server-Leistungsproblemen kommt, z. B. zu Verzögerungen der Serverantworten an die Clients.

Fortlaufende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst an Active Directory können folgende Ursachen haben:

  • Netzwerkwartezeit zwischen dem Exchange-Server und dem Domänencontroller

  • Statische oder anderweitig fehlerhafte Konfiguration von DSAccess

  • Überlasteter Domänencontroller und überlasteter globaler Katalog

  • Fehlerhafter Entwurf der Active Directory-Topologie

Um diese Warnung zu beheben, führen Sie folgende Schritte aus:

  • Führen Sie Exchange Server Analyzer aus, um eine weitere Analyse von Serverproblemen auszuführen. Sie können Exchange Server Analyzer unter "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" (http://go.microsoft.com/fwlink/?LinkId=34705) herunterladen.

  • Überprüfen Sie die Leistung der Active Directory-Domänencontrollerserver.

  • Im Abschnitt "Weitere Informationen" dieses Themas finden Sie weitere Artikel.

Weitere Informationen

Weitere Informationen zur Exchange-Leistung und DSAccess finden Sie im Microsoft Knowledge Base-Artikel 250570, "Directory service server detection and DSAccess usage" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570).

Weitere Informationen zur Leistung von Exchange Server finden Sie im "Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47576).

Weitere Informationen zur Behandlung von Leistungsproblemen von Exchange Server finden Sie im Handbuch "Troubleshooting Microsoft Exchange Server Performance" (http://go.microsoft.com/fwlink/?LinkId=47588).

Weitere Informationen zur Behandlung von Leistungsproblemen von Informationsspeichern finden Sie im Microsoft Knowledge Base-Artikel 257725, "XADM: Sammeln von Diagnosedaten zur Problembehandlung des Informationsspeichers" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

Weitere Informationen zur Leistung von Domänencontrollern finden Sie in den folgenden Windows Server-Ressourcen:

  • "Planning Domain Controller Capacity" (http://go.microsoft.com/fwlink/?LinkId=70191)

  • "Active Directory Monitoring of Domain Controllers" in Windows 2000 Server Active Directory Planning and Deployment Guides (http://go.microsoft.com/fwlink/?LinkId=70193)


Fortlaufende Aufrufe an ESE gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-13

Microsoft® Exchange Server Analyzer Tool untersucht das FCL-Protokoll (Function Call Log) von Exchange, die Datei Store.fcl, auf Ereignisse, die auf fortlaufende komponentenübergreifende Aufrufe des Exchange-Informationsspeicherdienstes (Store.exe) an die Exchange ESE-Komponente (Extensible Storage Engine) hinweisen.

Fortlaufende Aufrufe sind Anforderungen vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an andere Komponenten, die noch keine Antwort erhalten haben, wenn die Exchange FCL-Daten in die Datei Store.fcl geschrieben werden.

Der Microsoft Exchange-Informationsspeicher befindet sich oberhalb einer ESE-Datenbank (Extensible Storage Engine). ESE ist ein hochentwickeltes transaktionsbasiertes Datenbankmodul. Bei einer Transaktion handelt es sich um eine Folge von Operationen, die als unteilbare Einheit gelten. Entweder sind alle Operationen in einer Transaktion abgeschlossen und dauerhaft gespeichert, oder es werden keine Operationen durchgeführt.

In Exchange Server wird ESE als integriertes Datenbankmodul zum Festlegen der Struktur der Datenbanken sowie zum Verwalten des Arbeitsspeichers verwendet. Mit dem Datenbankmodul werden die Datenbanken im Arbeitsspeicher zwischengespeichert, indem Datenblöcke (Seiten) in und aus dem Arbeitsspeicher übertragen werden. Die Seiten werden im Arbeitsspeicher aktualisiert. Anschließend werden die neuen oder aktualisierten Seiten wieder auf Festplatte geschrieben. Bei Systemanforderungen können die Daten vom Datenbankmodul im Arbeitsspeicher gepuffert werden, sodass nicht permanent auf die Festplatte zugegriffen werden muss.

Obwohl Daten über die Zwischenspeicherung im Arbeitsspeicher am schnellsten und effizientesten verarbeitet werden, bedeutet dies jedoch auch, dass die Informationen auf der Festplatte bei der Ausführung von Exchange nie vollständig aktuell sind. Die aktuellste Version der Datenbank befindet sich im Speicher. Da viele Änderungen im Arbeitsspeicher noch nicht auf der Festplatte vorhanden sind, sind Datenbank und Arbeitsspeicher nicht synchronisiert. Der Transaktionsprotokolldatenträger wird ständig mit den Informationen zu den einzelnen Transaktionen aktualisiert.

Wenn Exchange Server Analyzer feststellt, dass Ereignisse in der Datei Store.fcl fortlaufende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an die ESE-Komponente (Extensible Storage Engine) darstellen, wird eine Warnung angezeigt.

Diese Warnung weist darauf hin, dass es bei diesem Server zu einem Leistungsproblem kommen kann. Gelegentliche fortlaufende Aufrufe weisen im Gegensatz zu wiederholten fortlaufenden Aufrufen nicht notwendigerweise auf ein Problem hin.

Wenn komponentenübergreifende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) auf eine Antwort warten, können RPC-Threads (Remote Procedure Call, Remoteprozeduraufruf) diese Anforderungen im Hintergrund unterstützen, sodass es zu Exchange Server-Leistungsproblemen kommt, z. B. zu Verzögerungen der Serverantworten an die Clients.

Fortlaufende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst an ESE (Extensible Storage Engine) können folgende Ursachen haben:

  • Exchange-Onlinedefragmentierung

  • Datensicherungen

    Hinweis:
    Wenn während der Erfassung der Exchange-Ablaufverfolgungsprotokollierung für Aufrufe eine Datensicherung oder eine Onlinedefragmentierung eingeleitet wurde, können Sie diese Warnung als Hinweis auf ein Exchange Server-Leistungsproblem ignorieren.
  • Engpässe bei den Datenbanklaufwerken, z. B. unzureichende Kapazität für die Anzahl der Benutzer auf dem Server

  • Engpässe bei den TEMP- und TMP-Laufwerken

Um diesen Fehler zu beheben, führen Sie folgende Schritte aus:

  • Im Rahmen bewährter Methoden sollte darauf geachtet werden, dass sich Sicherungsfenster nicht mit Onlinewartungs- oder Spitzennutzungsintervallen überlappen.

  • Vergewissern Sie sich, dass die Datenbankfestplattenlaufwerke sich in einem einwandfreien Zustand befinden und über genügend Durchsatz für die E/A-Last verfügen.

  • Führen Sie Exchange Server Analyzer aus, um eine weitere Analyse von Serverproblemen auszuführen, wie z. B. Größenbeschränkungen für Nachrichten und Anlagen. Sie können Exchange Server Analyzer unter "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" (http://go.microsoft.com/fwlink/?LinkId=34705) herunterladen.

  • Im Abschnitt "Weitere Informationen" dieses Themas finden Sie weitere Artikel.

Weitere Informationen

Weitere Informationen zum Konfigurieren der Zeitfenster für die Onlinedefragmentierung finden Sie im Microsoft Knowledge Base-Artikel 244524, "XADM: Konfigurieren des Exchange Server Online-Fragmentierungszeitfensters" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524).

Weitere Informationen zu Exchange Server-Problemen aufgrund von Datenträgerengpässen finden Sie unter Datenträgerengpass wurde festgestellt.

Weitere Informationen zum Festlegen der Größe und zum Optimieren von Datenträgern für Exchange Server finden Sie unter "Berechnung der Anforderungen an die Datenträger-E/A" und "Best Practices für mehrere Architekturen" in Optimieren von Speichersystemen für Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=49324).

Weitere Informationen zu ESE finden Sie unter "Extensible Storage Engine Architecture" (http://go.microsoft.com/fwlink/?linkid=67009).


Fortlaufende Aufrufe an IMAIL gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-13

Microsoft® Exchange Server Analyzer Tool untersucht das FCL-Protokoll (Function Call Log) von Exchange, die Datei Store.fcl, auf Ereignisse, die auf fortlaufende komponentenübergreifende Aufrufe des Microsoft Exchange-Informationsspeicherdienstes (Store.exe) an die IMAIL-Komponente des MAPI-Clients hinweisen.

Fortlaufende Aufrufe sind Anforderungen vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an andere Komponenten, die noch keine Antwort erhalten haben, wenn die Exchange FCL-Daten in die Datei Store.fcl geschrieben werden.

Bei der IMAIL-Komponente von Exchange Server handelt es sich um einen flexiblen Konvertierungsdienst, der vom Microsoft Exchange-Informationsspeicherdienst zwischen Internet- und MAPI-Nachrichten verwendet wird. Dadurch wird die Interoperabilität zwischen Clients ermöglicht, die das RFC-822- oder Internetformat verwenden, und Clients, die das interne Exchange Server-Speicherformat verwenden, z. B. MAPI-Clients oder interne Speichertasks.

Exchange wendet mithilfe des IMAIL-Mechanismus Nachrichtenformate auf den Inhalt an. Maßgeblich sind hierbei die Festlegungen für Internetdomänen im Exchange-System-Manager bzw. die Festlegungen des Benutzers für den jeweiligen Empfänger in Microsoft Office Outlook®. Werden keine Formatierungsparameter an IMAIL übergeben, werden MAPI-Nachrichten für die Übertragung zwischen Servern in S/TNEF formatiert.

Wenn Exchange Server Analyzer feststellt, dass Ereignisse in der Datei Store.fcl fortlaufende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an die IMAIL-Komponente des MAPI-Clients darstellen, wird eine Warnung angezeigt.

Diese Warnung weist darauf hin, dass es bei diesem Server zu einem Leistungsproblem kommen kann. Gelegentliche fortlaufende Aufrufe weisen im Gegensatz zu wiederholten fortlaufenden Aufrufen nicht notwendigerweise auf ein Problem hin.

Wenn komponentenübergreifende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) auf eine Antwort warten, können RPC-Threads (Remote Procedure Call, Remoteprozeduraufruf) diese Anforderungen im Hintergrund unterstützen, sodass es zu Exchange Server-Leistungsproblemen kommt, z. B. zu Verzögerungen der Serverantworten an die Clients.

Fortlaufende Aufrufe vom Exchange-Informationsspeicherdienst an die IMAIL-Komponente des MAPI-Clients können folgende Ursachen haben:

  • IMAIL versucht, umfangreiche Daten in einer Nachricht oder Anlage zu verarbeiten.

  • Viele Clients fordern eine Datenkonvertierung an.

  • DSAccess-Anforderungen weisen eine langsame Reaktion auf.

  • Es gibt Engpässe bei den TEMP- und TMP-Laufwerken.

  • Es gibt fortlaufende Postfachverschiebungen.

Um diese Warnung zu beheben, führen Sie folgende Schritte aus:

  • Planen Sie Postfachverschiebungen in Zeiten geringer Nutzung.

  • Führen Sie Exchange Server Analyzer aus, um eine weitere Analyse von Serverproblemen auszuführen, wie z. B. Größenbeschränkungen für Nachrichten und Anlagen. Sie können Exchange Server Analyzer unter "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" (http://go.microsoft.com/fwlink/?LinkId=34705) herunterladen.

  • Im Abschnitt "Weitere Informationen" dieses Themas finden Sie weitere Artikel.

Weitere Informationen

Weitere Informationen zu Exchange Server-Problemen aufgrund von Engpässen bei Festplatten finden Sie unter Datenträgerengpass wurde festgestellt.

Weitere Informationen zum Festlegen der Größe und zum Optimieren von Datenträgern für Exchange Server finden Sie unter "Berechnung der Anforderungen an die Datenträger-E/A" und "Best Practices für mehrere Architekturen" in Optimieren von Speichersystemen für Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=49324).

Weitere Informationen zu bewährten Verfahren für Größenbegrenzungen für Nachrichten von Exchange Server finden Sie unter Maximale Größe für ausgehende Nachrichten wurde nicht festgelegt..

Weitere Informationen zu DSAccess und zur Leistung von Exchange Server finden Sie unter "Konfigurieren des DSAccess-Benutzercaches" im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Weitere Informationen zur Behandlung von Leistungsproblemen von Exchange Server finden Sie im Handbuch "Troubleshooting Microsoft Exchange Server Performance" (http://go.microsoft.com/fwlink/?LinkId=47588).

Weitere Informationen zur Behandlung von Leistungsproblemen von Informationsspeichern finden Sie im Microsoft Knowledge Base-Artikel 257725, "XADM: Sammeln von Diagnosedaten zur Problembehandlung des Informationsspeichers" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Fortlaufende Aufrufe an LSASS gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-13

Microsoft® Exchange Server Analyzer Tool untersucht das FCL-Protokoll (Function Call Log) von Exchange, die Datei Store.fcl, auf Ereignisse, die auf fortlaufende komponentenübergreifende Aufrufe des Exchange-Informationsspeicherdienstes (Store.exe) an den LSASS-Prozess (Local Security Authentication Server) hinweisen.

Fortlaufende Aufrufe sind Anforderungen vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an andere Komponenten, die noch keine Antwort erhalten haben, wenn die Exchange FCL-Daten in die Datei Store.fcl geschrieben werden.

Der LSASS-Prozess (Lsass.exe) ist ein Sicherheitssubsystem, das von anderen Prozessen aufgerufen wird, um Kontoinformationen zu überprüfen und Anmeldungen zu validieren.

Bei jeder Exchange-Clientanmeldung wird vom Server, auf dem Exchange Server ausgeführt wird, eine Anforderung gesendet, um die Konto-SID (Security Identifier) des Clients zu ermitteln, und ein Aufruf im LSASS-Prozess erstellt.

Wenn Exchange Server Analyzer feststellt, dass Ereignisse in der Datei Store.fcl fortlaufende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an den LSASS-Prozess (Local Security Authentication Server) darstellen, wird eine Warnung angezeigt.

Diese Warnung weist darauf hin, dass es bei diesem Server zu einem Leistungsproblem kommen kann. Gelegentliche fortlaufende Aufrufe weisen im Gegensatz zu wiederholten fortlaufenden Aufrufen nicht notwendigerweise auf ein Problem hin.

Wenn komponentenübergreifende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) auf eine Antwort warten, können RPC-Threads (Remote Procedure Call, Remoteprozeduraufruf) diese Anforderungen im Hintergrund unterstützen, sodass es zu Exchange Server-Leistungsproblemen kommt, z. B. zu Verzögerungen der Serverantworten an die Clients.

Fortlaufende Aufrufe vom Exchange-Informationsspeicherdienst an den LSASS-Prozess können folgende Ursachen haben:

  • Serverressourcenprobleme in Bezug auf die Anzahl der Benutzer, die gleichzeitig eine Authentifizierung durchführen

  • Netzwerkwartezeit zwischen dem Exchange-Server und dem Domänencontroller oder dem globalen Katalogserver

  • Probleme aufgrund von Engpässen bei Serverressourcen

Um diese Warnung zu beheben, führen Sie folgende Schritte aus:

  • Erwägen Sie, den NeverPing-Parameter zu implementieren (siehe Beschreibung in Der Parameter 'NeverPing' wird empfohlen).

  • Im Abschnitt "Weitere Informationen" dieses Themas finden Sie weitere Artikel.

Weitere Informationen

Weitere Informationen zum Lsass.exe-Prozess sowie zu Speichernutzung finden Sie im Microsoft Knowledge Base-Artikel 308356, "Speichernutzung durch den Prozess "Lsass.exe" auf Domänencontrollern unter Windows Server 2003 oder Windows 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356).

Weitere Informationen zu Exchange-Clientanmeldungen und LSASS-Problemen finden Sie im Microsoft Knowledge Base-Artikel 161938, "Verlangsamung von Exchange-Clientanmeldungen aufgrund von Ressourcen-Deadlocks" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938).

Weitere Informationen zu Netzwerkwartezeiten zwischen dem Exchange-Server und dem Domänencontroller oder dem globalen Katalogserver finden Sie im Exchange Server Team Blog-Artikel, "Exchange Does Not Always Use Local GCs" (http://go.microsoft.com/fwlink/?LinkId=69166).

Hinweis:
Der Inhalt jedes Blogs und die dazugehörigen URLs können jederzeit ohne vorherige Ankündigung geändert werden.

Weitere Informationen zu Problemen aufgrund von Engpässen bei Serverressourcen finden Sie unter Prozessorengpass.

Weitere Informationen zur Leistung von Exchange Server finden Sie im "Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47576).

Weitere Informationen zur Behandlung von Leistungsproblemen von Exchange Server finden Sie im Handbuch "Troubleshooting Microsoft Exchange Server Performance" (http://go.microsoft.com/fwlink/?LinkId=47588).

Weitere Informationen zur Behandlung von Leistungsproblemen von Informationsspeichern finden Sie im Microsoft Knowledge Base-Artikel 257725, "XADM: Sammeln von Diagnosedaten zur Problembehandlung des Informationsspeichers" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Fortlaufende Aufrufe an Virenscanner gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-13

Microsoft® Exchange Server Analyzer Tool untersucht das FCL-Protokoll (Function Call Log) von Exchange, die Datei Store.fcl, auf Ereignisse, die auf fortlaufende komponentenübergreifende Aufrufe des Microsoft Exchange-Informationsspeicherdienstes (Store.exe) an die VAPI-Komponente (Virusscan Virus API) hinweisen.

Fortlaufende Aufrufe sind Anforderungen vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an andere Komponenten, die noch keine Antwort erhalten haben, wenn die Exchange FCL-Daten in die Datei Store.fcl geschrieben werden.

Wenn Exchange Server Analyzer feststellt, dass Ereignisse in der Datei Store.fcl fortlaufende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an die VAPI-Komponente darstellen, wird eine Warnung angezeigt.

Diese Warnung weist darauf hin, dass es bei diesem Server zu einem Leistungsproblem kommen kann. Gelegentliche fortlaufende Aufrufe weisen im Gegensatz zu wiederholten fortlaufenden Aufrufen nicht notwendigerweise auf ein Problem hin.

Wenn komponentenübergreifende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) auf eine Antwort warten, können RPC-Threads (Remote Procedure Call, Remoteprozeduraufruf) diese Anforderungen im Hintergrund unterstützen, sodass es zu Exchange Server-Leistungsproblemen kommt, z. B. zu Verzögerungen der Serverantworten an die Clients.

Fortlaufende Aufrufe vom Exchange-Informationsspeicherdienst an die VAPI-Komponente können folgende Ursachen haben:

  • Aktualisierungen eines Virenscanners, die dazu führen, dass die Objekte im Informationsspeicher erneut geprüft werden

  • Ein fehlerhaft konfigurierter Virenscanner

  • Verarbeitung einer umfangreichen Nachricht oder Anlage durch die Virenscannersoftware

Um diese Warnung zu beheben, führen Sie folgende Schritte aus:

  • Planen Sie Aktualisierungen des Antivirenmoduls in Zeiten mit geringer Ressourcenbelastung, d. h. außerhalb von Spitzennutzungsintervallen.

  • Erwägen Sie, die Virenscannersoftware neu zu installieren (außerhalb von Spitzennutzungsintervallen)

  • Untersuchen Sie die Konfiguration Ihres Virenscannermoduls hinsichtlich der ordnungsgemäßen Threadkonfiguration, Ausschlüssen auf Dateiebene usw. Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 823166, "Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Im Abschnitt "Weitere Informationen" dieses Themas finden Sie weitere Artikel.

Weitere Informationen

Weitere Informationen zu den in Microsoft Exchange Server 2003 üblicherweise verwendeten Virenprüfprogrammen finden Sie im Microsoft Knowledge Base-Artikel 823166, "Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Weitere Informationen zu den in Microsoft Exchange 2000 Server üblicherweise verwendeten Virenprüfprogrammen finden Sie im Knowledge Base-Artikel 328841, "XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Weitere Informationen zur Leistung von Exchange Server finden Sie im "Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47576).

Weitere Informationen zur Behandlung von Leistungsproblemen von Exchange Server finden Sie im Handbuch "Troubleshooting Microsoft Exchange Server Performance" (http://go.microsoft.com/fwlink/?LinkId=47588).

Weitere Informationen zur Behandlung von Leistungsproblemen von Informationsspeichern finden Sie im Microsoft Knowledge Base-Artikel 257725, "XADM: Sammeln von Diagnosedaten zur Problembehandlung des Informationsspeichers" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


„GlobalFlag" des Betriebssystems wurde festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um den Wert für den Eintrag GlobalFlag zu festzulegen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager

Wenn Microsoft Exchange Analyzer feststellt, dass der Wert für GlobalFlag vorhanden ist und mit einem Wert ungleich 0 oder null konfiguriert ist, wird eine Warnung angezeigt.

  • Die Einstellung für den Registrierungswert GlobalFlag ist eine a Bitmaske zur Bestimmung der Debugoptionen, die für das Betriebssystem aktiviert sind. Wenn Sie nicht aktiv mit dem Debugging oder der Verfolgung eines Problems mithilfe des technischen Supports von Microsoft beschäftigt sind, wird empfohlen, dass Sie den Wert für GlobalFlag stets auf 0 festlegen.

Der Registrierungswert GlobalFlag ist in der Standardeinstellung auf 0 festgelegt. Wenn dieser Wert geändert wird und nicht mehr dem Standardwert 0 entspricht, können Sie das Tool Gflags verwenden, das in den Microsoft Windows Server™ 2003 Support Tools enthalten ist, die sich auf der Windows Server 2003-CD-ROM im Ordner \Support befinden. In einem Registrierungs-Editor können Sie den Wert auch manuell auf 0 festlegen. Beide Vorgehensweisen sind unten beschrieben.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diesen Fehler mithilfe von Gflags

  1. Klicken Sie auf Start und dann auf Ausführen, und geben Sie im Feld Öffnen die Zeichenfolge GFlags ein. Die Benutzeroberfläche von Global Flags wird angezeigt.

  2. Deaktivieren Sie sämtliche Kontrollkästchen, und klicken Sie auf Übernehmen.

  3. Klicken Sie auf OK, um das Tool GFlags zu beenden, und starten Sie den Computer neu, damit die Änderung wirksam wird.

So beheben Sie diesen Fehler mit einem Registrierungs-Editor

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\ System\CurrentControlSet\Control\Session Manager

  3. Doppelklicken Sie auf den Wert GlobalFlag, und legen Sie seine Wertdaten auf 0 fest.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den Computer neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986.


Das Betriebssystem befindet sich im Debugmodus.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) Win32_OperatingSystem ab, um zu bestimmen, ob für die Eigenschaft Debug ein Wert festgelegt wurde. Wenn der Wert für diesen Schlüssel auf einem Exchange Server-Computer auf True festgelegt wurde, wird ein Fehler angezeigt.

Der Windows-Debugmodus wird durch Hinzufügen des Parameters /debug in der Datei Boot.ini aktiviert oder deaktiviert. Wenn in der Datei Boot.ini eines Windows Server-Computers /debug angegeben ist, wird der Kernel-Debugger während des Starts geladen und permanent im Speicher behalten. Dadurch können die Mitarbeitern des technischen Supports von Microsoft sich in das System einwählen, in dem gerade der Debug-Prozess ausgeführt wird, und den Debugger abbrechen. Dies ist selbst dann möglich, wenn das System nicht über eine Kernel-STOP-Anzeige angehalten wird. Der Schalter /debug verwendet im Gegensatz zum Schalter /crashdebug den COM-Anschluss, unabhängig davon, ob ein Debuggen erfolgt oder nicht. Dieser Schalter wird beim Debuggen von regulär reproduzierbaren Problemen verwendet. Der Parameter /debug wurde vermutlich für die Problembehandlung festgelegt und versehentlich beibehalten.

Das Ausführen zusätzlicher Prozesse wirkt sich negativ auf die Systemleistung aus. Es ist daher nicht empfehlenswert, Exchange Server auf einem Computer auszuführen, auf dem Windows im Debugmodus ausgeführt wird.

Um diesen Fehler zu beheben, bearbeiten Sie die Datei Boot.ini, und löschen Sie den Parameter /debug.

So beheben Sie diesen Fehler

  1. Navigieren Sie in Windows Explorer zur Systempartition. Auf dieser Partition befinden sich hardwarespezifische Dateien wie Boot.ini und NTLDR.

  2. Wenn die Datei Boot.ini nicht angezeigt wird, kann dies daran liegen, dass unter Ordneroptionen die Option Geschützte Systemdateien ausblenden festgelegt ist. Wenn dies der Fall ist, klicken Sie in Windows Explorer-Fenster auf Extras und Ordneroptionen, und klicken Sie dann auf Ansicht. Deaktivieren Sie das Kontrollkästchen Geschützte Systemdateien ausblenden (empfohlen). Klicken Sie bei der Eingabeaufforderung auf Ja.

  3. Wenn die Datei Boot.ini in Windows Explorer angezeigt wird, klicken Sie mit der rechten Maustaste auf die Datei, klicken dann auf Öffnen mit und schließlich auf Editor, um die Datei zu öffnen.

  4. Entfernen Sie im Abschnitt [Operating Systems] den Parameter /debug.

  5. Speichern Sie die Datei, und schließen Sie sie. Starten Sie dann den Exchange Server-Computer neu, damit die Änderung wirksam wird.

Weitere Informationen zu den Parametern, die in der Datei Boot.ini verwendet werden können, finden Sie im Microsoft Knowledge Base-Artikel 833721 „Verfügbare Befehlszeilenoptionen für die Boot.ini-Dateien von Windows XP und Windows Server 2003 " (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833721).


Outlook Web Access erfordert einen Hotfix für Windows Server 2003 SP1
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-08-28

Microsoft® Microsoft Exchange Server Analyzer fragt verschiedene WMI-Klassen (Microsoft Windows® Management Instrumentation) ab, um die folgenden Informationen zu erhalten:

  • Unter welcher Version des Betriebssystems Microsoft Windows® Server ist Exchange Server installiert?

  • Wird der Exchange-Server in einem Cluster ausgeführt?

Wenn Microsoft Exchange Server Analyzer ermittelt, dass die folgenden Bedingungen erfüllt sind, zeigt das Tool eine Warnung an:

  • Exchange Server 2003 Service Pack 1 (SP1) ist installiert.

  • Microsoft Windows Server™ 2003 SP1 ist nicht installiert.

  • Der Clusterdienst wird ausgeführt.

  • Der Wert Version von Davex.dll ist kleiner als 6.5.7232.

Wenn Sie diese Konfiguration ausführen, müssen Sie einen Exchange Server-Hotfix downloaden und installieren, bevor Sie Windows Server 2003 SP1 installieren. Wenn Sie den Exchange Server-Hotfix nicht installieren, können Benutzer von Microsoft Office Outlook® Web Access für Exchange Server 2003 ihre Postfächer nicht verwenden. Benutzer mit Postfächern, die auf den Clustern gehostet werden, empfangen die folgende Fehlermeldung, wenn Sie mit Outlook Web Access eine Verbindung herstellen möchten:

  • „500 - Interne Serverfehler"

Dieser Fehler wird durch einige Sicherheitsverbesserungen in Windows Server 2003 SP 1 verursacht.

Wenn ein Benutzer versucht, sich mit Outlook Web Access an einem Postfach anzumelden, übermittelt HTTP Anforderungen an die Cluster-API, indem es die Identität des angemeldeten Benutzers annimmt. Unter Windows Server 2003 SP1 wurden jedoch Sicherheitsänderungen vorgenommen. Die Sicherheitseinschränkungen für die APIs, die Remoteregistrierungszugriffe ausführen, wurden geändert. Daher ist der Anmeldeversuch nicht erfolgreich.

Um diesen Fehler zu beheben, müssen Sie den ExchangeServer-Hotfix herunterladen und installieren, der im Microsoft Knowledge Base-Artikel „'500 - Internal server error' error message when a user tries to access a clustered Exchange Server 2003 back-end server by using Outlook Web Access" beschrieben ist (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841561).


Konflikt bei der Vorlagendatei für Outlook Web Access
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um die Versionsnummer der Datei Wmtemplates.dll zu bestimmen. Exchange Server Analyzer vergleicht anschließend die Versionsnummer von Wmtemplates.dll auf allen Servern in der Administrativen Gruppe. Wenn Exchange Server Analyzer feststellt, dass die Versionsnummer von Wmtemplates.dll bei Front-End- und Back-End-Exchange Servern nicht übereinstimmt, zeigt Microsoft Exchange Server Analyzer eine Meldung mit der optimalen Methode an.

Die Datei Wmtemplates.dll wird von Microsoft Office Outlook® Web Access-Steuerelementen verwendet. Unterschiedliche Versionen von Wmtemplates.dll auf den Front-End- und Back-End-Exchange-Servern können zu 400-Ebenen-Fehlern führen, wenn Benutzer versuchen, sich bei Outlook Web Access über einen Zugriff auf den Front-End-Exchange-Server anzumelden.

Für Wmtemplates.dll wurden von Microsoft zwei aktuelle Aktualisierungen veröffentlicht:

  • „Microsoft Exchange Information Store service crashes periodically after you install Exchange Server 2003 SP1" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=872963)

  • „Das S/MIME-Steuerelement wird nicht in OWA geladen, wenn Sie den Exchange Server 2003-OWA-Client auf einem Computer mit Windows XP Service Pack 2 ausführen" (http://support.microsoft.com/?kbid=883543)

Wenn Sie kürzlich eine dieser Aktualisierungen installiert haben, sind die folgenden Bedingungen möglicherweise erfüllt:

  • Die Aktualisierungen wurden nicht in der richtigen Reihenfolge installiert.

  • Die Aktualisierung wurde nicht auf Front-End- und Back-End-Server installiert.

Beim Installieren von Aktualisierungen für Outlook Web Access sollten Sie die Aktualisierung auf dem Front-End-Server installieren, den Server neu starten und anschließend die Aktualisierung auf dem Back-End-Server installieren.

Wenn Sie noch keine dieser Aktualisierungen installiert haben, stellen Sie sicher, dass auf allen Servern die neuesten Exchange Server Service Packs und Aktualisierungen ausgeführt werden.

Weitere Informationen zu den neuesten Service Packs und Aktualisierungen für Exchange Server finden Sie auf den folgenden Websites:

  • Downloads for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=21236)

  • Downloads for Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457)


Die ausstehenden RPC-Anforderungen haben den maximalen Schwellenwert erreicht
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-02-13

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem RPC Requests-Leistungsindikator des MSExchangeIS-Leistungsobjekts.

Wenn Exchange Server Analyzer feststellt, dass die Anzahl der RPC-Anforderungen den Spitzenwert von 100 während des Erfassungszeitraums erreicht hat, wird ein Fehler angezeigt.

Der Leistungsindikator RPC Requests gibt die Anzahl der Anforderungen eines MAPI-Remoteprozeduraufrufs (Remote Procedure Call, RPC) oder Clients an, die aktuell vom Microsoft Exchange-Informationsspeicherdienst verarbeitet werden. Der durchschnittliche Wert des Leistungsindikators RPC Requests sollte immer unter 30 liegen. Standardmäßig beträgt der Höchstwert für RPC-Anforderungen 100. Daher kann der Microsoft Exchange-Informationsspeicherdienst, falls er nicht anders konfiguriert wurde, nur 100 RPC-Anforderungen gleichzeitig bedienen, bevor alle neuen RPC-Vorgänge zurückgewiesen werden und Benutzer nicht mehr in der Lage sind, eine Verbindung mit dem Server herzustellen, bis die Anzahl der RPC-Anforderungen wieder unter 100 gesunken ist. Der Server wird nicht mehr reagieren und der Mailflow wird möglicherweise unterbrochen. Outlook-Benutzern wird möglicherweise das Dialogfeld RPC cancel Request (RPC-Abbruchanforderung) angezeigt.

Dieser Fehler zeigt an, dass der Server einen Leistungsengpass aufweist oder dass ein Prozess nicht mehr reagiert.

Ein Leistungsengpass kann mit dem Prozessor (CPU), der Festplatte, dem Netzwerk oder dem Arbeitsspeicher in Zusammenhang stehen. Außerdem kann er von einem Ansteigen der Last auf dem Server oder durch nicht ausreichende Serverressourcen verursacht werden. Ermitteln Sie mithilfe des Systemmonitors (Perfmon.msc), ob der Engpass von einer erhöhten Serverlast verursacht wird oder weil der Server unterdimensioniert ist. Wenn die Serverlast angestiegen ist, müssen Sie die Quelle der Last ausfindig machen und sie verringern. Verfügt der Server nicht über ausreichende Ressourcen, erhöhen Sie die notwendigen Ressourcen oder verschieben Benutzer von diesem Server auf einen anderen.

Ein Prozess reagiert möglicherweise nicht mehr, weil der Informationsspeicher auf eine Ressource wartet, die nicht mehr verfügbar wird. Beispiele hierfür wären ein Cluster, der das Laufwerk verliert, auf dem die Nachrichtenverfolgung stattfindet, oder ein Problem mit dem Virenscanner. Wenn ein Prozess nicht mehr reagiert, kann die Anzahl der RPC-Anforderungen nicht mehr sinken, weshalb der Informationsspeicher neu gestartet werden muss.

Weitere Informationen

  • Weitere Informationen über Prozessorengpässe finden Sie unter Prozessorengpass.

  • Weitere Informationen über Leistungsengpässe bei Festplatten finden Sie unter Datenträgerengpass wurde festgestellt.

  • Weitere Informationen zur Leistung von Exchange Server finden Sie im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange Server finden Sie im Handbuch Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen zum Planen der Leistung von Exchange Server finden Sie unter Exchange Server 2003 Performance: 10 Things to Think About (http://go.microsoft.com/fwlink/?LinkID=56460).

  • Weitere Informationen zum Verschieben von Benutzerpostfächern zur Verringerung der Serverlast finden Sie unter Verschieben von Benutzerpostfächern auf einen anderen Server.


Datei „PHATCAT.DLL" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere der obigen Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Datei „PHATQ.DLL" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere dieser Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung des Setup-Programms im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Leistungsproblem bei Auslagerungsdatei
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-09-06

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus den Leistungsindikatoren Avg Disk sec/Read und Avg Disk sec/Write für die PAGEDISK-Instanz des LogicalDisk-Leistungsobjekts.

Wenn Exchange Server Analyzer feststellt, dass die Leistungsindikatoren Avg Disk sec/Read und Avg Disk sec/Write 10 Millisekunden während des Erfassungszeitraums überschritten haben, wird ein Fehler angezeigt.

Das Leistungsobjekt LogicalDisk besteht aus Leistungsindikatoren, z. B. Avg Disk sec/Read und Avg Disk sec/Write, die logische Partitionen von Festplatten überwachen. Der Leistungsindikator Avg Disk sec/Read zeigt die durchschnittliche Zeit eines Lesevorgangs von Daten von der Festplatte in Sekunden an. Der Leistungsindikator Avg Disk sec/Write zeigt die durchschnittliche Zeit eines Schreibvorgangs von Daten auf die Festplatte in Sekunden an. Der durchschnittliche Wert der Leistungsindikatoren Avg Disk sec/Read und Avg Disk sec/Write sollte unter 10 Millisekunden liegen.

Die PAGEDISK-Instanz des LogicalDisk-Leistungsobjekts auf einem Server stellt die Auslagerungsdatei (Pagefile.sys) dar. Pagefile.sys ist eine ausgeblendete Systemdatei, in der Microsoft Windows® temporäre Dateien auf der Festplatte speichert, wenn dem System wenig Arbeitsspeicher (RAM) zur Verfügung steht. Die Auslagerungsdatei wird auch als Paging- oder Swap-Datei bezeichnet.

Dieser Fehler zeigt an, dass ein Problem mit Wartezeiten bei der Festplatte vorliegt, auf der sich die Auslagerungsdatei befindet.

Um diesen Fehler zu beheben, führen Sie folgende Schritte aus:

  • Identifizieren Sie die Ursache für die Wartezeiten. Wenn das Problem von übermäßigen Auslagerungsvorgängen verursacht wird, kann dies von Problemen mit dem Speicher des Servers ausgelöst worden sein.

  • Ziehen Sie in Betracht, die Auslagerungsdatei auf eine dedizierte Partition oder eine Hochgeschwindigkeits-Festplatte zu verlagern.

  • Erwägen Sie das Erstellen einer sekundären Auslagerungsdatei auf einem anderen Laufwerk, wie es im Microsoft Knowledge Base-Artikel 197379, „Konfigurieren von Auslagerungsdateien für die Optimierung und Wiederherstellung unter Windows Server 2003, Windows 2000 und Windows NT" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379), beschrieben wird.

  • Führen Sie Wartungsaufgaben des Servers außerhalb der Spitzenlastzeiten aus. Wenn Wartungstools wie Exchange Server Database Utilities (Eseutil.exe) oder Aufgaben wie die Postfachverwaltung währen Spitzenlastzeiten ausgeführt werden, wird möglicherweise Speicher belegt, der andernfalls von Exchange benötigt würde. Führen Sie diese Tools und Aufgaben als Best Practice außerhalb der Spitzenlastzeiten oder während Phasen geringer Nutzung aus.

Weitere Informationen

  • Weitere Informationen über Leistungsengpässe bei Festplatten finden Sie unter Datenträgerengpass wurde festgestellt.

  • Weitere Informationen zum Optimieren der Auslagerungsdateileistung finden Sie im Microsoft Knowledge Base-Artikel 197379, „Konfigurieren von Auslagerungsdateien für die Optimierung und Wiederherstellung unter Windows Server 2003, Windows 2000 und Windows NT" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379).

  • Weitere Informationen zur Leistung von Exchange Server finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange Server finden Sie im Handbuch Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen zu den bewährten Methoden für das Entwerfen von Speicherarchitekturen finden Sie unter Bewährte Methoden für mehrere Architekturen (http://go.microsoft.com/fwlink/?LinkId=72988).

  • Weitere Informationen zu Größe, Wartezeiten und E/A-Raten von Festplatten finden Sie in folgenden Blogs auf der Microsoft Exchange Team Blog-Website:

    • A Few Basic Concepts in Disk Sizing (http://go.microsoft.com/fwlink/?linkid=39538).

    • Some More Thoughts on Disk IO and Calculations... (http://go.microsoft.com/fwlink/?linkid=39539).

    • Berechnung der Anforderungen an die Datenträger-E/A (http://go.microsoft.com/fwlink/?linkid=69747)


Der Leistungsindikator für die Auslagerungsdateiverwendung ist größer als 50 %
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-09-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem % Usage-Leistungsindikator des Paging File-Leistungsobjekts.

Wenn Exchange Server Analyzer feststellt, dass der Leistungsindikator % Usage 50 % während des Erfassungszeitraums überschritten hat, wird ein Fehler angezeigt.

Bei der Auslagerungsdatei (Pagefile.sys) handelt es sich um eine ausgeblendete Systemdatei, mit der Windows temporäre Dateien speichert, wenn das System über wenig RAM verfügt. Die Auslagerungsdatei wird auch als Paging- oder Swap-Datei bezeichnet. Die Verwendung der Auslagerungsdatei beeinflusst die Gesamtleistung, weil Festplattenvorgänge länger benötigen als Speichervorgänge. Außerdem kann es möglicherweise zu einem Festplattenengpass und Leistungseinbußen kommen, wenn die Anzahl der Auslagerungsvorgänge auf und von der Festplatte hoch genug wird. In diesem Fall liegt das tatsächliche Problem beim Arbeitsspeicher, und der Festplattenengpass stellt lediglich ein Symptom dar.

Konkurrierender Speicherzugriff ist so lange tolerierbar, bis das System einen Punkt erreicht, an dem es im Verhältnis zu der für die tatsächliche Arbeit erforderlichen Zeit beträchtliche Zeit mit der Verwaltung des begrenzten Speichers verbringt. Bei einer grafischen Darstellung des konkurrierenden Speicherzugriffs über den durchschnittlichen Antwortzeiten werden Sie eine relativ gerade Linie vom Nullpunkt bis zu dem Punkt sehen, an dem die Werte der Antwortzeiten beträchtlich zu steigen beginnen. Dieser Punkt wird als Überlastungspunkt (Thrashing, wörtlich: Prügelei) bezeichnet. Überschreitet der konkurrierende Speicherzugriff diesen Punkt, beginnen die Antwortzeiten exponentiell zu steigen. Vorübergehende Überlastungen sind in manchen Umgebungen tolerierbar, Sie sollten jedoch darauf bedacht sein, diese zu vermeiden.

Dieser Fehler zeigt an, dass ein Leistungsproblem bei der Festplatte vorliegt, auf der sich die Auslagerungsdatei befindet. Dieses Problem kann letztendlich auf ein Speicherproblem auf dem Server zurückgeführt werden.

Um diesen Fehler zu beheben, führen Sie folgende Schritte aus:

  • Erwägen Sie das Erstellen einer sekundären Auslagerungsdatei auf einem anderen Laufwerk, wie es im Microsoft Knowledge Base-Artikel 197379, „Konfigurieren von Auslagerungsdateien für die Optimierung und Wiederherstellung unter Windows Server 2003, Windows 2000 und Windows NT" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379), beschrieben wird.

  • Ziehen Sie in Betracht, die Auslagerungsdatei auf eine dedizierte Partition oder eine Hochgeschwindigkeits-Festplatte zu verlagern.

  • Entfernen Sie Überflüssige Software. Entfernen Sie alle Dritthersteller-Softwaretools, die Überwachungsfunktionen ausführen, sowie alle nicht unbedingt erforderlichen Dienste, um Exchange mehr Speicherressourcen zur Verfügung zu stellen. Das Performance-Snap-In (http://go.microsoft.com/fwlink/?LinkId=56118) kann Ihnen dabei helfen herauszufinden, wie viel Speicher von den Anwendungen verwendet wird.

  • Führen Sie Wartungsaufgaben des Servers außerhalb der Spitzenlastzeiten aus. Wenn Wartungstools wie Exchange Server Database Utilities (Eseutil.exe) oder Aufgaben wie die Postfachverwaltung währen Spitzenlastzeiten ausgeführt werden, wird möglicherweise Speicher belegt, der andernfalls von Exchange benötigt würde. Führen Sie diese Tools und Aufgaben als Best Practice außerhalb der Spitzenlastzeiten oder während Phasen geringer Nutzung aus.

  • Ziehen Sie in Betracht, Postfächer vom betroffenen Server auf einen anderen zu verschieben, um die Serverlast zu reduzieren. Weitere Informationen finden Sie unter Verschieben von Benutzerpostfächern auf einen anderen Server.

Weitere Informationen

  • Weitere Informationen über Engpässe bei Festplatten finden Sie unter Datenträgerengpass wurde festgestellt.

  • Weitere Informationen zum Optimieren der Auslagerungsdateileistung finden Sie im Microsoft Knowledge Base-Artikel 197379, „Konfigurieren von Auslagerungsdateien für die Optimierung und Wiederherstellung unter Windows Server 2003, Windows 2000 und Windows NT" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379).

  • Weitere Informationen zur Verbesserung der Speicherleistung finden Sie unter Verbessern des Speichers für Benutzer.

  • Weitere Informationen zur Leistung von Exchange Server finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange Server finden Sie im Handbuch Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen zu den bewährten Methoden für das Entwerfen von Speicherarchitekturen finden Sie unter Bewährte Methoden für mehrere Architekturen (http://go.microsoft.com/fwlink/?LinkId=72988).

  • Weitere Informationen zu Größe, Wartezeiten und E/A-Raten von Festplatten finden Sie in folgenden Blogs auf der Microsoft Exchange Team Blog-Website:

    • Basiskonzepte für die Datenträgerbemessung (http://go.microsoft.com/fwlink/?linkid=39538).

    • Some More Thoughts on Disk IO and Calculations... (http://go.microsoft.com/fwlink/?linkid=39539).

    • Berechnung der Anforderungen an die Datenträger-E/A (http://go.microsoft.com/fwlink/?linkid=69747).


PageHeapFlags wurde festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um den Wert für den Eintrag PageHeapFlags zu bestimmen:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\MAD.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\INETINFO.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\EMSMTA.EXE

Wenn Exchange Server Analyzer feststellt, dass der Wert für PageHeapFlags vorhanden ist und mit einem Wert ungleich 0 oder null konfiguriert ist, wird eine Warnung angezeigt.

Die Option PageHeapFlags wird zusammen mit dem Registrierungswert GlobalFlag verwendet (weitere Informationen finden Sie unter GlobalFlag wurde festgelegt.). Über die Option PageHeapFlags können Sie eine Standard-Heapüberprüfung, die Füllmuster an das Ende jeder Heapzuweisung schreibt und die Muster nach der Freigabe überprüft, oder eine ganzseitige Heapüberprüfung auswählen. In diesem Fall wird an das Ende jeder Zuweisung eine Seite gestellt, auf die nicht zugegriffen werden kann, sodass das Programm sofort beendet wird, wenn es auf Speicher außerhalb der Zuweisung zugreift. Da bei der ganzseitigen Heapüberprüfung für jede Zuweisung eine vollständige Speicherseite verwendet wird, kann deren umfangreiche Verwendung zu Systemspeichermangel führen.

In diesem Fall sucht Microsoft Exchange Server Analyzer Tool speziell nach Werten für PageHeapFlags, die für eine Reihe von Exchange-Komponenten aktiviert wurden:

  • STORE.EXE - der Informationsspeicherprozess

  • MAD.EXE - der Systemaufsichtsprozess

  • INETINFO.EXE - der Administratorprozess und der übergeordnete Prozess von IIS

  • EMSMTA.EXE - der Message Transfer Agent-Prozess

Wenn Sie nicht gerade aktiv mit dem Debugging oder der Verfolgung eines Problems mithilfe des technischen Supports von Microsoft beschäftigt sind, wird empfohlen, den Wert für PageHeapFlags stets auf 0 festzulegen, oder ihn vollständig zu löschen (wodurch die gleiche Wirkung erzielt wird).

Der Registrierungswert PageHeapFlags ist in der Standardeinstellung nicht vorhanden und muss daher manuell hinzugefügt werden, wenn ein Debugging für den Prozess STORE.EXE (oder einen anderen Prozess) erforderlich ist. Hierzu können Sie das Dienstprogramm Gflags verwenden, das im Lieferumfang der Microsoft® Windows Server™ 2003-Supporttools enthalten ist. Diese befinden sich auf der Windows Server 2003-CD im Ordner \Support. Sie können den Wert für PageHeapFlags jedoch auch mithilfe des Registrierungs-Editor manuell auf 0 setzen oder ihn vollständig löschen. In diesem Artikel werden beide Verfahren beschrieben.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diesen Fehler mithilfe von Gflags

  1. Klicken Sie auf Start | Ausführen, und führen Sie im Feld Öffnen den Befehl GFlags aus. Die Benutzeroberfläche von Global Flags wird angezeigt.

  2. Geben Sie im Feld Abbilddateiname die Zeichenfolge STORE.EXE ein.

  3. Klicken Sie auf Image File Options.

  4. Deaktivieren Sie sämtliche Kontrollkästchen, und klicken Sie dann auf Übernehmen.

  5. Wiederholen Sie die Schritte 2 bis 4 für jeden der oben aufgeführten Exchange-Prozesse.

  6. Klicken Sie zum Verlassen des Dienstprogramms GFlags auf OK, und starten Sie die betreffenden Dienste neu, damit die Änderung wirksam wird.

  7. Wenn Sie diesen Wert mithilfe des Dienstprogramms GFlags löschen, wird der Wert für PageHeapFlags nicht gelöscht oder geändert. Der Wert GlobalFlag wird stattdessen auf 0 festgelegt. Dadurch wird das mit dem Eintrag PageHeapFlags konfigurierte Verhalten überschrieben und deaktiviert.

So beheben Sie diesen Fehler mit einem Registrierungs-Editor

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

  3. Löschen Sie den Wert mit der Bezeichnung PageHeapFlags.

  4. Wiederholen Sie die Schritte 2 und 3 für jeden der oben aufgeführten Exchange-Prozesse.

  5. Beenden Sie den Registrierungs-Editor, und starten Sie die betreffenden Dienste neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Der ausgelagerte Pool hat den Fehlerschwellenwert überschritten
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer sendet eine Abfrage an die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_PerfRawData_PerfOS_Memory, um den aktuellen Wert für den Schlüssel PoolNonpagedBytes zu ermitteln. Die von Exchange Server Analyzer ausgeführten Aktionen hängen vom verwendeten Betriebssystem, des Vorhandenseins oder Fehlens des Schalters /3GB in der Windows-Datei Boot.ini und des für den Schlüssel ermittelten Werts ab.

Im Folgenden wird die Matrix der Berechnungen angezeigt, die von Exchange Server Analyzer verwendet wird, um zu ermitteln, ob dieser Wert für einen bestimmten Exchange-Server nicht geeignet ist. Wenn die Bedingungen der Matrix erfüllt werden, wird ein Fehler gemeldet.

Betriebssystem | Einstellungen von Boot.ini | Der aktuelle, nicht ausgelagerte Pool ist
Windows 2000 Server oder Advanced Server | /3GB | 110 MB oder größer
Windows 2000 Server oder Advanced Server | Nicht vorhanden | 220 MB oder größer
Windows Server™ 2003 | /3GB | 110 MB oder größer
Windows Server 2003 | Nicht vorhanden | 220 MB oder größer

Der Wert des Schlüssels PoolNonpagedBytes ist die Größe (in Bytes) des nicht ausgelagerten Kernel-Speicher-Pools. Der nicht ausgelagerte Pool ist ein Bereich des physischen Systemspeichers für Objekte, die nicht auf den Datenträger geschrieben werden können, sondern im physischen Speicher verbleiben müssen, während sie zugewiesen sind. Dieser Wert für den Schlüssel entspricht dem zuletzt beobachteten Wert. Auf einem einwandfrei funktionierenden Exchange-Server bleibt dieser Wert unverändert. Wenn der Wert für diesen Leistungsindikator ständig zunimmt, könnte dies auf einen Arbeitsspeicherverlust hinweisen.

Da es nicht möglich ist, die Menge für nicht ausgelagerten Speicher-Pool über die oben angeführten Werte hinaus zu vergrößern, sollte dieser Zustand so schnell wie möglich korrigiert werden. Unabhängig vom verwendeten Betriebssystem und der An- oder Abwesenheit des Schalters /3GB kann vom Windows-Betriebssystem nur auf eine bestimmte Menge nicht ausgelagerten Speicher-Pool zugegriffen werden. Wenn unter Windows der Kernel-Speicherplatz zur Neige geht, werden möglicherweise Fehlermeldungen angezeigt, und das System stürzt ab. Der Kernel-Speicher ist für den ordnungsgemäßen Betrieb des Systems erforderlich und sollte deshalb sorgfältig überwacht werden.

Wenn dieser Zustand nach dem Neustart des Exchange-Servers erneut auftritt, muss als nächster Schritt sichergestellt werden, dass das System ordnungsgemäß feineingestellt ist und sämtliche Software und Hardware auf dem neuesten Stand sind. Dazu sollten die neusten Versionen folgender Komponenten installiert werden:

  • Service Pack für das Windows-Betriebssystem

  • Service Pack für Exchange Server

  • Hardware-Firmware und -Treiber

  • Aktualisierungen des System-BIOS

  • Aktualisierungen sämtlicher installierter und ausgeführter Anwendungen von Drittanbietern

Wenn Aktualisierungen der Software und Hardware dieses Problem nicht lösen, sollten Sie sämtliche Software von Drittanbietern deaktivieren, den Exchange Server-Computer erneut starten und den Kernel-Speicher überwachen.

So beheben Sie diesen Fehler

  1. Starten Sie den Exchange-Server bei der nächsten Gelegenheit neu.

  2. Überwachen Sie den Leistungsindikator Memory | Pool Nonpaged Bytes, um sicherzustellen, dass er den oben angeführten Grenzwert für Ihr System nicht überschreitet.

Weitere Informationen zur korrekten Einstellung für Exchange Server finden Sie in den folgenden Artikeln und Themen der Microsoft Knowledge Base:

  • 815372, „Optimieren der Speichernutzung in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372

  • 266096, „XGEN: Exchange 2000 erfordert Befehlszeilenoption "/3GB" bei mehr als 1 Gigabyte physischem RAM" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096.

  • „Troubleshooting Exchange Server 2003 Performance" (http://go.microsoft.com/fwlink/?LinkId=47588).

  • „Troubleshooting Exchange 2000 Server Performance" unter http://go.microsoft.com/fwlink/?LinkId=18177.

  • „Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003" (http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=de).


Der ausgelagerte Pool hat den Warnschwellenwert überschritten
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-03-16

Microsoft® Exchange Server Analyzer sendet eine Abfrage an die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_PerfRawData_PerfOS_Memory, um den aktuellen Wert für den Schlüssel PoolPagedBytes zu ermitteln. Die von Exchange Server Analyzer ausgeführten Aktionen hängen vom verwendeten Betriebssystem, des Vorhandenseins oder Fehlens des Schalters /3GB in der Windows-Datei Boot.ini und des für den Schlüssel ermittelten Werts ab.

In der Tabelle wird die Matrix der Berechnungen angezeigt, die von Microsoft Exchange Server Analyzer verwendet wurde, um zu ermitteln, ob dieser Wert für einen angegebenen Exchange-Server außerhalb des gültigen Bereichs liegt. Wenn die Bedingungen in der Tabelle erfüllt werden, wird eine Warnung angezeigt.

Betriebssystem | Einstellungen von Boot.ini | Der aktuelle, ausgelagerte Pool ist
Windows 2000 Server oder Advanced Server | /3GB | 180 MB oder größer
Windows 2000 Server oder Advanced Server | Nicht vorhanden | 180 MB oder größer
Windows Server™ 2003 | /3GB | 200 MB oder größer
Windows Server 2003 | Nicht vorhanden | 300 MB oder größer

Der Wert des Schlüssels PoolPagedBytes ist die Größe (in Bytes) des ausgelagerten Kernel-Speicher-Pools. Dies ist ein Bereich des physischen Systemspeichers für Objekte, die auch dann auf den Datenträger geschrieben werden können, wenn sie nicht verwendet werden. Dieser Wert für den Schlüssel entspricht dem zuletzt beobachteten Wert. Auf einem optimal eingerichteten Exchange-Server sollten nicht mehr als 180 MB Speicher für den ausgelagerten Speicher-Pool verwendet werden, außer wenn eine Sicherung oder Wiederherstellung stattfindet.

Unter Windows 2000 Server und Windows 2000 Advanced Server beträgt der Maximalwert für den ausgelagerten Speicher-Pool 470 MB. Wenn der Schalter /3GB auf dem Windows 2000 Advanced Server-Computer verwendet wird, beträgt der Maximalwert für den ausgelagerten Speicher-Pool 192 MB. Auf einem Windows Server 2003-Computer ohne den Schalter /3GB beträgt der Maximalwert für den ausgelagerten Pool 491 MB. Auf einem Windows Server 2003-Computer ohne den Schalter /3GB beträgt der Maximalwert für den ausgelagerten Pool 256 MB.

Da es nicht möglich ist, den Grenzwert für den ausgelagerten Speicher-Pool über die oben angeführten Werte hinaus zu erhöhen, sollte dieser Zustand so schnell wie möglich korrigiert werden. Unabhängig vom verwendeten Betriebssystem und der An- oder Abwessenheit des „/3GB"-Schalters kann von Windows nur auf eine bestimmte Menge ausgelagerten Speicher-Pool zugegriffen werden. Wenn unter Windows der Kernel-Speicherplatz zur Neige geht, werden möglicherweise Fehlermeldungen angezeigt, und das System stürzt ab. Kernel-Speicher ist für den ordnungsgemäßen Betrieb des Systems unabdingbar und sollte deshalb sorgfältig überwacht werden.

Wenn dieser Zustand nach dem Neustart des Exchange-Servers erneut auftritt, muss als nächster Schritt sichergestellt werden, dass das System ordnungsgemäß eingerichtet ist und dass sämtliche Software und Hardware auf dem neusten Stand ist. Dazu sollten die neusten Versionen folgender Komponenten installiert werden:

  • Service Pack für das Windows-Betriebssystem

  • Service Pack für Exchange Server

  • Hardware-Firmware und -Treiber

  • Aktualisierungen des System-BIOS

  • Aktualisierungen sämtlicher installierter und ausgeführter Anwendungen von Drittanbietern

Wenn Aktualisierungen der Software und Hardware dieses Problem nicht lösen, sollten Sie sämtliche Software von Drittanbietern deaktivieren, den Exchange Server-Computer erneut starten und den Kernel-Speicher überwachen.

So beheben Sie diese Warnmeldung

  1. Starten Sie den Exchange-Server bei der nächsten Gelegenheit neu.

  2. Überwachen Sie den Leistungsindikator Memory | Paged Pool Bytes, um sicherzustellen, dass er den oben angeführten Grenzwert für Ihr System nicht überschreitet.

Weitere Informationen zum optimalen Einstellen von Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln und Exchange-Themen:

  • 815372, „Optimieren der Speichernutzung in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372

  • 266096, „XGEN: Exchange 2000 erfordert Befehlszeilenoption "/3GB" bei mehr als 1 Gigabyte physischem RAM" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096.

  • „Troubleshooting Microsoft Exchange Server Performance" unter http://go.microsoft.com/fwlink/?LinkId=47588.

  • „Troubleshooting Exchange 2000 Server Performance" unter http://go.microsoft.com/fwlink/?LinkId=18177.

  • „Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47576)

Weitere Informationen finden Sie in den folgenden Exchange-Blog-Artikeln:

  • „Microsoft Windows Kernel Memory Management and Microsoft Exchange Server" (http://go.microsoft.com/fwlink/?LinkId=63477)

  • „Configuring Hot-Add and Large Memory for Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=63478)

  • „Large Security Tokens and Kernel Memory Exhaustion" (http://go.microsoft.com/fwlink/?LinkId=63479)

    Hinweis:
    Die Links zu diesen Blogs dienen ausschließlich Informationszwecken. Der Inhalt kann jederzeit ohne vorherige Ankündigung geändert werden.


Der Pfad der RPC-Proxyservererweiterung ist falsch
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest die folgende Eigenschaft in der IIS-Metabasis (Internet Information Services), um zu ermitteln, ob der Wert richtig konfiguriert wurde:

LM/W3SVC/Filters/RpcProxy

Diese Metabasiseigenschaft entspricht der RPC-Proxyservererweiterungseigenschaft (Remote Procedure Call) in den Webdiensterweiterungen in IIS. Für diese Eigenschaft ist der folgende Wert richtig:

<Windows-Verzeichnis>\system32\rpcproxy\rpcproxy.dll

Wenn Microsoft Exchange Server Analyzer feststellt, dass die Eigenschaft nicht den richtigen Wert aufweist, wird eine Warnung angezeigt.

Die RPC-Proxyservererweiterungseigenschaft ist festgelegt, wenn Sie die Proxy-Teilkomponente RPC über HTTP der Microsoft Windows®-Netzwerkdienstkomponente installieren. Wenn die Eigenschaft falsch festgelegt wurde oder Sie den Wert manuell geändert haben, sollten Sie folgende Schritte ausführen:

  1. Entfernen Sie die falsche RPC-Proxyservererweiterungseigenschaft.

  2. Entfernen Sie die Proxy-Subkomponente RPC über HTTP.

  3. Installieren Sie die Proxy-Subkomponente RPC über HTTP erneut.

So entfernen Sie die falsche RPC-Proxyservererweiterungseigenschaft

  1. Öffnen Sie Internetinformationsdienste-Manager.

  2. Erweitern Sie im linken Bereich des Fensters Internetinformationsdienste-Manager den Servernamen, und klicken Sie dann auf Web-Erweiterungen.

  3. Klicken Sie im rechten Bereich des Fensters Internetinformationsdienste-Manager auf RPC-Proxyservererweiterungen, und klicken Sie dann auf Eigenschaften.

  4. Wählen Sie auf der Registerkarte Erforderliche Dateien aus der Dateiliste die falsche Datei aus, klicken Sie auf Entfernen, und klicken Sie dann auf OK.

    Hinweis:
    Um den vollständigen Pfad sehen zu können, passen Sie in der Dateiliste die Breite der Spalte Dateiname an.
So entfernen Sie die Proxy-Subkomponente RPC über HTTP

  1. Klicken Sie auf Start, klicken Sie auf Systemsteuerung, und klicken Sie dann auf Software.

  2. Klicken Sie im linken Bereich auf Windows-Komponenten hinzufügen/entfernen.

  3. Wählen Sie Netzwerkdienste aus, und klicken Sie dann auf Details.

  4. Deaktivieren Sie das Kontrollkästchen RPC über HTTP-Proxy, klicken Sie auf OK, und klicken Sie dann auf Weiter.

  5. Wenn der Assistent für Windows-Komponenten abgeschlossen wurde, klicken Sie auf Fertig stellen, um den Assistenten zu schließen.
So installieren Sie die Proxy-Subkomponente RPC über HTTP erneut

  1. Klicken Sie auf Start, klicken Sie auf Systemsteuerung, und klicken Sie dann auf Software.

  2. Klicken Sie im linken Bereich auf Windows-Komponenten hinzufügen/entfernen.

  3. Wählen Sie Netzwerkdienste aus, und klicken Sie dann auf Details.

  4. Aktivieren Sie das Kontrollkästchen RPC über HTTP-Proxy, klicken Sie auf OK, und klicken Sie dann auf Weiter.

  5. Wenn der Assistent für Windows-Komponenten abgeschlossen wurde, klicken Sie auf Fertig stellen, um den Assistenten zu schließen.

Weitere Informationen zu Problemen beim Laden der RPC-Proxyservererweiterung finden Sie im Abschnitt „Problembehandlung" im Microsoft Knowledge Base-Artikel 833401, „Konfigurieren von RPC-über-HTTP auf einem einzelnen Server in Exchange Server 2003" unter http://support.microsoft.com/kb/833401/de.

Weitere Informationen zu RPC über HTTP auf Exchange Server 2003 finden Sie in Exchange Server 2003 RPC over HTTP Deployment Scenarios unter http://go.microsoft.com/fwlink/?LinkId=24823.


PDC-Emulator wurde nicht aus der DSAccess-Topologie ausgeschlossen
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest die folgenden Registrierungseinträge, um zu bestimmen, ob der als PDC-Emulator (PDC - Primärer Domänencontroller) fungierende Active Directory®-Domänencontroller manuell aus der Liste der für die Verwendung durch Exchange Server verfügbaren Domänencontroller ausgeschlossen wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default\MinUserDC

Wenn Microsoft Exchange Server Analyzer feststellt, dass der als PDC-Emulator fungierende Domänencontroller nicht manuell aus der Liste der für die Verwendung durch Exchange Server verfügbaren Domänencontroller ausgeschlossen wurde, zeigt Microsoft Exchange Server Analyzer eine empfohlene optimale Methode an.

Bei einem PDC-Emulator handelt es sich um einen Active Directory-Betriebsmaster-Rollencomputer, der Replikationsanforderungen von Microsoft Windows NT® Server 4.0-Sicherungsdomänencontrollern und alle Kennwortaktualisierungen für Clients verarbeitet, die keine Active Directory-kompatible Clientsoftware ausführen. Da es sich bei PDC-Emulatoren ebenfalls um Domänencontroller handelt, können sie auch von Anwendungen (z. B. Exchange Server) verwendet werden.

Bei DSAccess (Verzeichnisdienstzugriff) handelt es sich um eine interne Komponente von Exchange 2000 Server und Exchange Server 2003, die den Zugriff der Exchange Server-Komponenten auf Active Directory® steuert. Die primäre Funktion von DSAccess stellt das Verwalten von Informationen zu verschiedenen verzeichnisbezogenen Ereignissen und Vorgängen dar. Zum Beispiel ermittelt DSAccess die Active Directory-Topologie und stellt fest, ob Domänencontroller und globale Katalogserver verfügbar sind und auf Abfragen reagieren.

In der Standardeinstellung ist der PDC-Emulator-Computer in der Liste der verfügbaren und verwendbaren Domänencontroller von DSAccess enthalten. Wenn der PDC-Emulator von Programmen, die keine Exchange-Programme sind, stark ausgelastet wird, kann die Verwendung des PDC-Emulators durch DSAccess zu Leistungsproblemen auf dem PDC-Emulatorcomputer sowie auf dem Exchange-Server und dem nicht für Exchange Server-Anwendungen verwendeten Computer führen.

Zum Vermeiden dieser Leistungsprobleme kann der Registrierung auf einem Exchange-Server der Registrierungswert MinUserDC hinzugefügt werden, um zu erzwingen, dass DSAccess vor dem Abfragen des Domänencontrollers mit der PDC-Emulator-Betriebsmasterrolle zuerst alle anderen verfügbaren Domänencontroller abfragt.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So überprüfen und ändern Sie den Registrierungswert „MinUserDC"

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

  3. Wechseln Sie zu dem Wert MinUserDC, und nehmen Sie die erforderlichen Änderungen vor. Wenn der Wert DWORD nicht vorhanden ist, kann er manuell erstellt werden.

    Hinweis:
    Der für den Registrierungseintrag MinUserDC konfigurierte Datenwert entspricht der maximalen Anzahl der Domänencontroller, die vor dem PDC-Emulator kontaktiert werden sollen. Beispielsweise wird durch das Festlegen von MinUserDC auf 4 DSAccess so konfiguriert, dass der PDC-Emulator erst bei insgesamt vier verfügbaren Domänencontrollern ausgeschlossen wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zum Verwenden des Registrierungseintrags MinUserDC finden Sie im Knowledge Base-Artikel 298879, „Exchange 2000 may experience performance problems when PDC emulator is used for DSAccess", unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=298879.


Leistungsdaten für verfügbare MBytes-Indikator
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Available MBytes-Leistungsindikator des Memory-Leistungsobjekts. Wenn Exchange Server Analyzer Daten aus dem Available MBytes-Leistungsindikator erfasst, zeigt Exchange Server Analyzer Informationen zu den erfassten Daten als Basislinieninformationen an.

Der Available MBytes-Leistungsindikator zeigt die Größe des physischen Arbeitsspeichers in MB an, die unmittelbar für die Zuweisung zu einem Prozess oder für die Systemverwendung verfügbar ist. Die Größe des verfügbaren Speichers ist gleich der Standbylisten (zwischengespeichert), freien Listen und Nullseitenlisten zugewiesenen Speichersumme.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In manchen Fällen entspricht der maximale Wert einem Spitzenwert im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten vom Indikator „Average Disk sec/Read" des Leistungsobjekts „LogicalDisk".
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Avg. Disk sec/Read-Leistungsindikator des LogicalDisk-Leistungsobjekts. Wenn Exchange Server Analyzer Daten aus dem Avg. Disk sec/Read-Leistungsindikator erfasst, zeigt Exchange Server Analyzer Informationen zu den erfassten Daten als Basislinieninformationen an.

Das Leistungsobjekt Logical Disk besteht aus Indikatoren, z. B. Avg. Disk sec/Read, die logische Partitionen von Festplatten überwachen. Der Leistungsindikator Avg. Disk sec/Read zeigt die durchschnittliche Zeit eines Lesevorgangs von Daten von der Festplatte in Sekunden an. Der durchschnittliche Wert des Leistungsindikators Avg. Disk sec/Read sollte unter 10 Millisekunden betragen. Der maximale Wert des Leistungsindikators Avg. Disk sec/Read darf 50 Millisekunden nicht übersteigen.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In einigen Fällen ist der maximale Wert der Wert an einem Scheitelpunkt im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zum Optimieren des Speichersystems für Exchange Server 2003 finden Sie in Optimieren von Speichersystemen für Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=c6084d20-9730-4ffc-805d-b957327604c6&DisplayLang=de).

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten vom Indikator „Average Disk sec/Read" des Leistungsobjekts „PhysicalDisk"
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Avg. Disk sec/Read-Leistungsindikator des PhysicalDisk-Leistungsobjekts. Wenn Exchange Server Analyzer Daten aus dem Avg. Disk sec/Read-Leistungsindikator erfasst, zeigt Exchange Server Analyzer Informationen zu den erfassten Daten als Basislinieninformationen an.

Der Leistungsindikator Avg. Disk sec/Read zeigt die durchschnittliche Zeit eines Lesevorgangs von Daten von der Festplatte in Sekunden an. Der durchschnittliche Wert des Leistungsindikators Avg. Disk sec/Read sollte unter 10 Millisekunden betragen. Der maximale Wert des Leistungsindikators Avg. Disk sec/Read darf 50 Millisekunden nicht übersteigen.

Wenn Sie Ergebnisse der Indikatoren Disk Reads/sec und Disk Writes/sec sammeln, können Sie bestimmen, ob die von Exchange Server generierte E/A mit der Zeit zu- oder abnimmt. Wenn Sie Ergebnisse der Indikatoren Avg. Disk sec/Read und Avg. Disk sec/Write sammeln, können Sie bestimmen, ob sich die Wartezeit des Speichers mit der Zeit geändert hat. Führen Sie die folgenden Schritte aus, um vorherzusagen, ob der Speicherdurchsatz einen (möglichen) Engpass darstellt:

  1. Nehmen Sie monatliche Messungen vor, vorzugsweise am gleichen Tag des Monats und zur gleichen Uhrzeit.

  2. Analysieren die gesammelten Daten.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In manchen Fällen entspricht der maximale Wert einem Spitzenwert im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten vom Indikator „Average Disk sec/Write" des Leistungsobjekts „LogicalDisk".
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Avg. Disk sec/Write-Leistungsindikator des LogicalDisk-Leistungsobjekts. Wenn Exchange Server Analyzer Daten aus dem Avg. Disk sec/Write-Leistungsindikator erfasst, zeigt Exchange Server Analyzer Informationen zu den erfassten Daten als Basislinieninformationen an.

Das Leistungsobjekt Logical Disk besteht aus Indikatoren, z. B. Avg. Disk sec/Write, die logische Partitionen von Festplatten überwachen. Der Leistungsindikator Avg. Disk sec/Write zeigt die durchschnittliche Zeit für das Schreiben von Daten auf die Festplatte in Sekunden an. Der durchschnittliche Wert des Leistungsindikators Avg. Disk sec/Write sollte unter 10 Millisekunden betragen. Der maximale Wert des Leistungsindikators Avg. Disk sec/Write darf 50 Millisekunden nicht übersteigen.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In manchen Fällen entspricht der maximale Wert einem Spitzenwert im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zum Optimieren des Speichersystems für Exchange Server 2003 finden Sie auf der Microsoft TechNet-Website in Optimieren von Speichersystemen für Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=c6084d20-9730-4ffc-805d-b957327604c6&DisplayLang=de).

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten für den Indikator „Average Disk sec/Write"
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Avg. Disk sec/Write-Leistungsindikator des Physical Disk-Leistungsobjekts. Wenn Exchange Server Analyzer Daten aus dem Avg. Disk sec/Write-Leistungsindikator erfasst, zeigt Exchange Server Analyzer Informationen zu den erfassten Daten als Basislinieninformationen an.

Der Leistungsindikator Avg. Disk sec/Write zeigt die durchschnittlich verwendetet Zeit für das Schreiben von Daten auf die Festplatte in Sekunden an. Der durchschnittliche Wert des Leistungsindikators Avg. Disk sec/Write sollte unter 10 Millisekunden betragen. Der maximale Wert des Leistungsindikators Avg. Disk sec/Write darf 50 Millisekunden nicht übersteigen.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In einigen Fällen ist der maximale Wert der Wert an einem Scheitelpunkt im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten vom Epoxy-Indikator „Client Out Queue Length (DSAccess)"
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Client Out Queue Length (DSAccess) -Leistungsindikator des Epoxy-Leistungsobjekts. Wenn Exchange Server Analyzer Daten aus dem Client Out Queue Length (DSAccess) -Leistungsindikator erfasst, zeigt Exchange Server Analyzer Informationen zu den erfassten Daten als Basislinieninformationen an.

Der Leistungsindikator Client Out Queue Length (DSAccess) zeigt die Anzahl der Nachrichten in der Warteschlange der DSAccess-Nachrichten (Directory Service Access) an, die vom Prozess Inetinfo.exe gesendet wurden. Die Warteschlangen dürfen nie mehr als 10 Elemente enthalten.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In manchen Fällen entspricht der maximale Wert einem Spitzenwert im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten vom Epoxy-Indikator „Client Out Queue Length" (SMTP)
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Client Out Queue Length (SMTP)-Leistungsindikator des Epoxy-Leistungsobjekts. Wenn Exchange Server Analyzer Daten aus dem Client Out Queue Length (SMTP)-Leistungsindikator erfasst, zeigt Exchange Server Analyzer Informationen zu den erfassten Daten als Basislinieninformationen an.

Der Leistungsindikator Client Out Queue Length (SMTP) zeigt die Anzahl der Nachrichten in der Warteschlange der SMTP-Anlagen (Simple Mail Transfer Protocol) an, die vom Prozess Inetinfo.exe gesendet wurden. Die Warteschlangen dürfen nie mehr als 50 Elemente enthalten, es sei denn, eine Mail-Warteschlange ist vorhanden.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In einigen Fällen ist der maximale Wert der Wert an einem Scheitelpunkt im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten vom Epoxy-Indikator „Store Out Queue Length" (DSAccess)
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Store Out Queue Length-Leistungsindikator (DSAccess) des Epoxy-Leistungsobjekts. Wenn Exchange Server Analyzer Daten aus dem Store Out Queue Length-Leistungsindikator (DSAccess) erfasst, zeigt Exchange Server Analyzer Informationen zu den erfassten Daten als Basislinieninformationen an.

Der Store Out Queue Length-Leistungsindikator (DSAccess) zeigt die Anzahl der Nachrichten in der Warteschlange der DSAccess-Nachrichten (DSAccess) an, die vom Prozess Store.exe gesendet wurden. Die Warteschlangen dürfen nie mehr als 10 Elemente enthalten.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In einigen Fällen ist der maximale Wert der Wert an einem Scheitelpunkt im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten vom Epoxy-Indikator „Store Out Queue Length" (SMTP)
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Leistungsindikator Store Out Queue Length (SMTP) des Epoxy-Leistungsobjekts. Wenn Exchange Server Analyzer Daten aus dem Leistungsindikator Store Out Queue Length (SMTP) erfasst, zeigt Exchange Server Analyzer Informationen zu den erfassten Daten als Basislinieninformationen an.

Der Leistungsindikator Store Out Queue Length (SMTP) zeigt die Anzahl der Nachrichten in der Warteschlange der SMTP-Anlagen (Simple Mail Transfer Protocol) an, die vom Prozess Store.exe gesendet wurden. Die Warteschlangen dürfen nie mehr als 50 Elemente enthalten, es sei denn, eine Mail-Warteschlange ist vorhanden.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In einigen Fällen ist der maximale Wert der Wert an einem Scheitelpunkt im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten des Leistungsindikators für die durchschnittliche RPC-Wartezeit
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem RPC Averaged Latency-Leistungsindikator des MSExchangeIS-Leistungsobjekts. Wenn Exchange Server Analyzer Daten aus dem RPC Averaged Latency-Leistungsindikator erfasst, zeigt Exchange Server Analyzer Informationen zu den erfassten Daten als Basislinieninformationen an.

Der Leistungsindikator RPC Averaged Latency gibt die durchschnittliche RPC-Wartezeit Remote Procedure Call) für die letzten 1.024 Pakete in Millisekunden an. Der Maximalwert des Leistungsindikators RPC Averaged Latency sollte stets weniger als 50 Millisekunden betragen.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In manchen Fällen entspricht der maximale Wert einem Spitzenwert im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten aus dem Indikator für „RPC Operations/sec"
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem RPC Operations/sec-Leistungsindikator des MSExchangeIS-Leistungsobjekts. Wenn Exchange Server Analyzer Daten aus dem RPC Operations/sec-Leistungsindikator erfasst, zeigt Exchange Server Analyzer Informationen zu den erfassten Daten als Basislinieninformationen an.

Der RPC Operations/sec-Leistungsindikator zeigt die Rate der RPC-Vorgänge (Remote Procedure Call) an. Der RPC Operations/sec-Leistungsindikator ist ein guter Ratenindikator für die Messung der Arbeitslast von Exchange Server, da alle MAPI-basierten Aktionen das RPC-Protokoll verwenden.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In einigen Fällen ist der maximale Wert der Wert an einem Scheitelpunkt im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten vom „RPC Requests"-Leistungsindikator
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem RPC Requests-Leistungsindikator des MSExchangeIS-Leistungsobjekts. Wenn Exchange Server Analyzer Daten aus dem RPC Requests-Leistungsindikator erfasst, zeigt Exchange Server Analyzer Informationen zu den erfassten Daten als Basislinieninformationen an.

Der RPC Requests-Leistungsindikator gibt die Anzahl der Anforderungen eines MAPI-Remote Procedure Call (RPC - Remoteprozeduraufruf) oder Clients an, die aktuell vom Exchange-Informationsspeicherdienst verarbeitet werden. Der durchschnittliche Wert des Leistungsindikators RPC Requests sollte zu keiner Zeit mehr als 30 betragen. Standardmäßig beträgt der Höchstwert für RPC-Anforderungen 100. Daher kann der Microsoft Exchange-Informationsspeicherdienst, falls er nicht anders konfiguriert wurde, nur 100 RPC-Anforderungen gleichzeitig bedienen, bevor er Clientanforderungen zurückweist.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In manchen Fällen entspricht der maximale Wert einem Spitzenwert im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten des Leistungsindikators für die Länge der SMTP-Warteschlange des Kategorisierungsmoduls
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Categorizer Queue Length-Leistungsindikator des SMTP Server-Leistungsobjekts. Exchange Server Analyzer meldet die Gesamtanzahl der Meldungen, die sich in der Warteschlange des Kategorisierungsmoduls befinden.

Der Leistungsindikator SMTP Server\Categorizer Queue Length gibt die Anzahl der Meldungen in der SMTP-Warteschlange (Simple Mail Transfer Protocol) des Kategorisierungsmoduls an, die auf Suchvorgänge in den Verzeichnisdienstattributen mithilfe globaler Katalogserver warten. Als allgemeine Richtlinie sollte der Höchstwert kleiner als 10 sein.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In manchen Fällen entspricht der maximale Wert einem Spitzenwert im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Der Leistungsindikator für Categorizer Queue Length gibt die Anzahl der Meldungen in der Warteschlange des Nachrichtenkategorisierungsmoduls an. Das Kategorisierungsmodul führt die folgenden Kernoperationen aus:

  • Auflösen und Validieren aller Empfänger

  • Festlegen von Grenzwerten und Einschränkungen für alle Empfänger

  • Erweitern der Verteilerlisten (falls erforderlich)

  • Ermitteln, ob eine Nachricht für die lokale oder Remoteübermittlung bestimmt ist

Ein Anstieg im Categorizer Queue Length-Leistungsindikator bedeutet, dass u. U. Probleme bei der Serverleistung, bei DSAccess (Directory Service Access), beim Active Directory®-Verzeichnisdienst oder Ausfälle bei den Schlüsselservern in der Exchange Server-Organisation auftreten können. Ein Anstieg im Categorizer Queue Length-Leistungsindikator würde Verlangsamen oder Ausbleiben der Antworten bei Anfragen an Active Directory oder beim Übergeben von Nachrichten für die lokale Übermittlung oder SMTP bedeuten.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten des SMTP-Leistungsindikators für die Länge der lokalen Warteschlange
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Local Queue Length-Leistungsindikator des SMTP Server-Leistungsobjekts. Microsoft Exchange Server Analyzer meldet die Gesamtzahl der in der lokalen SMTP-Warteschlange (Simple Mail Transfer Protocol) gefundenen Nachrichten.

Der Leistungsindikator SMTP Server\Local Queue Length gibt die Anzahl der Nachrichten in der SMTP-Warteschlange zur lokalen Übermittlung an. Als allgemeine Richtlinie sollte der Maximalwert weniger als 1.000 betragen. Für die Warteschlange sollte der Durchschnittswert beibehalten werden, wobei geringfügige Unterschiede möglich sind.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In manchen Fällen entspricht der maximale Wert einem Spitzenwert im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Der Stau von Nachrichten in der Warteschlange für die lokale Übermittlung weist auf ein Leistungsproblem oder auf Ausfälle auf dem Server hin, weil der Server die eingehenden E-Mail-Nachrichten nicht mehr zeitgerecht übermitteln kann. Durch die folgenden Bedingungen kann diese Verzögerung verursacht werden:

  • Der Active Directory®-Verzeichnisdienst wird nicht unverzüglich abgefragt.

  • Nachrichten werden nicht unverzüglich zur lokalen Übermittlung oder an SMTP übergeben.

  • Die Bereitstellung der Datenbanken ist aufgehoben.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten des Leistungsindikators für die Länge der SMTP-Remotewarteschlange
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Remote Queue Length-Leistungsindikator des SMTP Server-Leistungsobjekts. Microsoft Exchange Server Analyzer meldet die Gesamtzahl der in der SMTP-Remotewarteschlange (Simple Mail Transfer Protocol) gefundenen Nachrichten.

Der Leistungsindikator SMTP Server\Remote Queue Length gibt die Anzahl der Nachrichten in der SMTP-Warteschlange zur Remoteübermittlung an. Als allgemeine Richtlinie sollte der Maximalwert weniger als 1.000 betragen. Für die Warteschlange sollte der Durchschnittswert beibehalten werden, wobei geringfügige Unterschiede möglich sind.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In manchen Fällen entspricht der maximale Wert höher als die anderen Werte im Zeitraum. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Eine Vergrößerung der Länge der Remotewarteschlange bedeutet, dass E-Mail-Nachrichten nicht an andere Server gesendet werden. Dieser Fehler beim Senden von E-Mail-Nachrichten entsteht durch Ausfälle oder Leistungsprobleme der Netzwerk- oder der Remoteserver. Durch diese Ausfälle oder Leistungsprobleme wird verhindert, dass die Netzwerk- oder Remoteserver E-Mail-Nachrichten auf effiziente Weise empfangen.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten des Leistungsindikators „Virus Scan Queue Length"
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Virus Scan Queue Length-Leistungsindikator des MSExchangeIS-Leistungsobjekts. Wenn Exchange Server Analyzer Daten aus dem Leistungsindikator Virus Scan Queue Length erfasst, zeigt Exchange Server Analyzer Informationen zu den erfassten Daten-Basislinieninformationen an.

Der Leistungsindikator Virus Scan Queue Length gibt die aktuelle Anzahl der ausstehenden Anforderungen an, die sich in der Warteschlange für die Virenprüfung befinden. Der empfohlene Wert für diesen Indikator hängt von ihrer Organisation ab.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In einigen Fällen ist der maximale Wert der Wert an einem Scheitelpunkt im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten für den Indikator „Protokolldatensatzverzögerungen/Sek."
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Log Record Stalls/sec-Leistungsindikator des Database-Leistungsobjekts. Wenn Exchange Server Analyzer Daten aus dem Log Record Stalls/sec-Leistungsindikator erfasst, zeigt Exchange Server Analyzer Informationen zu den erfassten Daten als Basislinieninformationen an.

Der Log Record Stalls/sec-Leistungsindikator zeigt die Anzahl der Protokolldatensätze an, die pro Sekunde nicht zu den Protokollpuffern hinzugefügt werden können, da diese voll sind. Der durchschnittliche Wert des Leistungsindikators Log Record Stalls/sec sollte unter 10 pro Sekunde betragen. Der maximale Wert sollte 100 pro Sekunde nicht überschreiten.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In einigen Fällen ist der maximale Wert der Wert an einem Scheitelpunkt im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten für den Indikator „Log Threads Waiting"
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Log Threads Waiting-Leistungsindikator des Database-Leistungsobjekts. Wenn Exchange Server Analyzer Daten aus dem Log Threads Waiting-Leistungsindikator erfasst, zeigt Exchange Server Analyzer Informationen zu den erfassten Daten als Basislinieninformationen an.

Der Leistungsindikator Log Threads Waiting zeigt die Anzahl der Threads an, die auf den Abschluss der Aktualisierung einer Datenbank warten, indem die Daten ins Protokoll geschrieben werden. Wenn der Wert des Leistungsindikators Log Threads Waiting zu hoch ist, stellt das Protokoll möglicherweise eine Engpass für andere Transaktionen dar.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In einigen Fällen ist der maximale Wert der Wert an einem Scheitelpunkt im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten für den Indikator „Seiten/s"
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Pages/sec-Leistungsindikator des Memory-Leistungsobjekts. Wenn Exchange Server Analyzer Daten aus dem Leistungsindikator Pages/sec erfasst, zeigt Exchange Server Analyzer Informationen zu den erfassten Daten-Basislinieninformationen an.

Der Leistungsindikator Pages/sec zeigt die Rate an, mit der die Seiten vom Datenträger gelesen bzw. auf den Datenträger geschrieben werden, um harte Seitenfehler aufzulösen. Bei diesem Indikator handelt es sich um einen primären Indikator der Fehlertypen, die systemweite Verzögerungen bewirken. Der Indikator enthält Seiten, die abgerufen wurden, weil sie den Seitenfehlern im Dateisystemzwischenspeicher entsprechen. Diese Seiten werden gewöhnlich von Anwendungen angefordert. Dieser Zähler darf nie mehr als 1.000 Elemente enthalten.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In manchen Fällen entspricht der maximale Wert einem Spitzenwert im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten für den Leistungsindikator „% Processor Time"
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem % Processor Time-Leistungsindikator des Processor-Leistungsobjekts. Wenn Exchange Server Analyzer Daten aus dem % Processor Time-Leistungsindikator erfasst, zeigt Exchange Server Analyzer Informationen zu den erfassten Daten als Basislinieninformationen an.

Der % Processor Time-Leistungsindikator zeigt den Dauer in Prozent an, in der nicht im Leerlauf befindliche Threads vom Prozessor ausgeführt werden. Mithilfe dieses Leistungsindikators können Sie die Gesamtauslastung der Prozessoren bzw. die Auslastung pro Prozessor überwachen. Die durchschnittliche CPU-Auslastung sollte zu jedem Zeitpunkt unter 90 Prozent betragen.

Hinweis:
Die von Exchange Server Analyzer angezeigte % Processor Time ist ein verdichteter Wert aus der Gesamtzahl der festgestellten CPUs, physische wie auch logische, geteilt durch die Summe der CPU-Zeit.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In manchen Fällen entspricht der maximale Wert einem Spitzenwert im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten für den Indikator „Bytes/s insgesamt"
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Bytes Total/sec-Leistungsindikator des Network Interface-Leistungsobjekts. Wenn Exchange Server Analyzer Daten aus dem Bytes Total/sec-Leistungsindikator erfasst, zeigt Exchange Server Analyzer Informationen zu den erfassten Daten als Basislinieninformationen an.

Der Bytes Total/sec-Leistungsindikator zeigt die Rate an, mit der der Netzwerkadapter Datenbytes verarbeitet. Dieser Indikator berücksichtigt zusätzlich zu den Protokollinformationen alle Anwendungs- und Dateidaten, z. B. die Kopfzeilen von Paketen. Für einen Netzwerkadapter mit 100 Megabit pro Sekunde (Mbps) sollte der Wert des Bytes Total/sec-Leistungsindikators unter 7 Megabyte/Sekunde liegen. Für einen Netzwerkadapter mit 1000 Mbps sollte der Wert des Bytes/s insgesamt-Leistungsindikators unter 70 Megabyte/Sekunde liegen.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In einigen Fällen ist der maximale Wert der Wert an einem Scheitelpunkt im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten vom „LDAP Read Time"-Leistungsindikator
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-02-06

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem LDAP Read Time-Leistungsindikator des MSExchangeDSAccess Process-Leistungsobjekts. Wenn Exchange Server Analyzer Daten aus dem Leistungsindikator LDAP Read Time Erfasst, zeigt Exchange Server Analyzer Informationen zu den erfassten Daten als Basislinieninformationen an.

Der Leistungsindikator LDAP Read Time zeigt die Zeit in Millisekunden an, die für das Ausführen einer LDAP-Leseanforderung (Lightweight Directory Access Protocol) benötigt wird. Der Durchschnittswert sollte unter 50 Millisekunden betragen. Die Höchstwerte sollten 100 Millisekunden nicht überschreiten.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In manchen Fällen entspricht der maximale Wert einem Spitzenwert im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Leistungsdaten vom „LDAP Search Time"-Leistungsindikator
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem LDAP Search Time-Leistungsindikator des MSExchangeDSAccess Processes-Leistungsobjekts. Wenn Exchange Server Analyzer Daten aus dem LDAP Search Time-Leistungsindikator erfasst, zeigt Exchange Server Analyzer Informationen zu den erfassten Daten als Basislinieninformationen an.

Der LDAP Search Time-Leistungsindikator zeigt die Zeit im Millisekunden an, die für das Erfüllen einer LDAP-Suchanforderung (Lightweight Directory Access Protocol) benötigt wird. Der Durchschnittswert sollte unter 50 Millisekunden betragen. Die Höchstwerte sollten 100 Millisekunden nicht überschreiten.

In der Standardeinstellung ruft Microsoft Exchange Server Analyzer zwei Stunden lang alle 30 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Microsoft Exchange Server Analyzer meldet außerdem den Wert, der sich am neunzigsten Perzentil aller erfassten Werte befindet.

Hinweis:
Wenn Sie in aufsteigender Folge sämtliche von Microsoft Exchange Server Analyzer erfassten Werte auflisten, ist das neunzigste Perzentil der Wert an der Position von 90 Prozent in der Liste. Der neunzigste Perzentilwert gibt die hohen Werte dieses Indikators während des Erfassungszeitraums an.

In manchen Fällen entspricht der maximale Wert einem Spitzenwert im Intervall. Daher ist der maximale Wert nicht für den gesamten Zeitraum repräsentativ. Der Mittelwert gibt die Belastung nicht immer genau an, da der Mittelwert die Leerlaufzeit während des Zeitraums enthält. Daher meldet Microsoft Exchange Server Analyzer den maximalen Wert und den Wert des neunzigsten Perzentils.

Die Informationen in dieser Basislinienmeldung dienen lediglich zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu empfohlenen Schwellenwerten für Leistungsindikatoren finden Sie unter Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Das Objekt zur Leistungsüberwachung „PhysicalDisk" ist nicht vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Avg. Disk sec/Read-Leistungsindikator des PhysicalDisk-Leistungsobjekts. Wenn gültige Daten nicht vom Indikator zurückgegeben werden, zeigt Microsoft Exchange Server Analyzer eine Basislinienmeldung an.

Wenn keine gültigen Daten vom Erfassungsmodul für Leistungsdaten zurückgegeben werden, liegt mindestens eine der folgenden Bedingungen vor:

  • Das PhysicalDisk-Leistungsobjekt ist deaktiviert.

  • Das PhysicalDisk-Leistungsüberwachungsobjekt wurde nicht gefunden, oder es ist beschädigt.

  • Microsoft Exchange Server Analyzer verfügt nicht über entsprechende Berechtigungen zum Zugreifen auf die Leistungsobjekte.

Die ersten beiden Bedingungen treten auf, wenn die Registrierung von bestimmten erweiterbaren Indikatoren beschädigt wird oder wenn die Registrierung von auf Microsoft WMI (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) basierten Programmen geändert wird. Im folgenden Verfahren wird die Behebung der ersten beiden Bedingungen erläutert. Überprüfen Sie vor dem Ausführen des Verfahrens, ob Microsoft Exchange Server Analyzer über entsprechende Berechtigungen verfügt. Weitere Informationen zu den Berechtigungen, die zum Ausführen von Microsoft Exchange Server Analyzer erforderlich sind, finden Sie in der im Lieferumfang von Microsoft Exchange Server Analyzer enthaltenen Hilfedokumentation. Wenn Sie Hilfe erhalten möchten, öffnen Sie Exchange Server Analyzer, und drücken Sie F1.

So beheben Sie diesen Fehler

  1. Überprüfen Sie, ob das PhysicalDisk-Leistungsobjekt aktiviert ist.

    1. Downloaden und installieren Sie das Tool „Extensible Performance Counter List" (Exctrlst.exe). Sie können Exctrlst.exe auf der Microsoft-Website downloaden: „Exctrlst.exe: Extensible Performance Counter List" (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Öffnen Sie die Datei Exctrlst.exe, klicken Sie auf Sortierreihenfolge und anschließend auf Dienst.

    3. Suchen Sie den Dienst, über den das Leistungsobjekt eine Meldung ausgeben soll, und überprüfen Sie, ob das Kontrollkästchen Leistungsindikatoren aktiviert aktiviert ist.

      Wenn das Kontrollkästchen Leistungsindikatoren aktiviert nicht aktiviert ist, aktivieren Sie es, und starten Sie den Dienst neu, der dem Leistungsindikator zugeordnet ist, um zu überprüfen, ob die Leistungsindikatoren betriebsbereit sind. Wenn die Leistungsindikatoren nicht betriebsbereit sind oder wenn das Kontrollkästchen Leistungsindikatoren aktiviert bereits aktiviert wurde, fahren Sie mit Schritt 2 fort.

  2. Erstellen Sie die nicht vorhandenen oder beschädigten Leistungsindikatoren wie im Microsoft Knowledge Base-Artikel 300956 „Manuelles Neuerstellen der Werte der Leistungsindikatorenbibliothek" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) beschrieben neu.

  3. Wenn Sie das Problem anhand dieses Knowledge Base-Artikels nicht beheben lässt, müssen Sie das Windows-Betriebssystem im Modus Reparieren erneut installieren und die aktuellsten Windows-Service Packs anwenden.


Anschlusskonflikt: Standortreplikationsdienst
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob Anschlusskonflikte vorliegen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Wenn Exchange Server Analyzer ermittelt, dass der Wert für HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP mit einem der Werte übereinstimmt, die in den zuvor in diesem Artikel aufgeführten anderen sechs Registrierungswerten angegeben sind, wird ein Fehler angezeigt. Exchange Server Analyzer zeigt außerdem einen Fehler für den Anschluss an, bei dem ein Konflikt mit HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP vorliegt.

Um diesen Fehler zu beheben, müssen Sie den Wert für diesen Schlüssel oder den Schlüssel, bei dem wie von der Ausgabe in Microsoft Exchange Server Analyzer angegeben ein Konflikt vorliegt, in einen eindeutigen Wert ändern.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den TCP/IP-Registrierungsparameter fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters

  3. Doppelklicken Sie auf den Schlüssel TCP/IP, und legen Sie im Feld Datenwerte einen eindeutigen Wert fest, der etwas größer als 5000 (dezimal) ist.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den Computer neu, damit die Einstellung wirksam wird.

So stellen Sie RPC-über-HTTP bereit

  1. Lesen Sie „Exchange Server 2003 RPC over HTTP Deployment Scenarios" unter http://go.microsoft.com/fwlink/?linkid=47577.

  2. Lesen Sie den Microsoft Knowledge Base-Artikel 833401, „Konfigurieren von RPC-über-HTTP auf einem einzelnen Server in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  3. Lesen Sie den Knowledge Base-Artikel 827330, „Behandlung von Problemen bei RPC-über-HTTP-Clientverbindungen in Office Outlook 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  4. Lesen Sie den Microsoft Support WebCast „Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unterhttp://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zur statischen Zuordnung von Anschlüssen, die von Exchange verwendet werden, finden Sie in den folgenden Knowledge Base-Artikeln:

  • 194952, „XADM: Statically Mapped Port Limitations for Exchange Server" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952

  • 270836, „Statische Anschlusszuordnungen in Exchange 2000 und Exchange 2003" unter http://support.microsoft.com/kb/270836/de


Portkonflikt: HTTP-Speicher
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-03-21

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob Portkonflikte vorliegen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Mit dem Registrierungsschlüssel Rpc/HTTP Port unterstützt Exchange die Features Microsoft Office Outlook® 2003 RPC/HTTP und Exchange Server 2007 Outlook Anywhere. Wenn Exchange Server Analyzer ermittelt, dass der Wert für HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters\Rpc/HTTP Port mit einem der Werte übereinstimmt, die in den zuvor in diesem Artikel aufgeführten anderen sechs Registrierungswerten angegeben sind, wird ein Fehler angezeigt. Exchange Server Analyzer zeigt außerdem einen Fehler für den Port an, bei dem ein Konflikt mit HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters\Rpc/HTTP Port vorliegt.

Um diesen Fehler zu beheben, müssen Sie den Wert für diesen Schlüssel oder den Schlüssel, bei dem wie von der Ausgabe in Microsoft Exchange Server Analyzer angegeben ein Konflikt vorliegt, in einen eindeutigen Wert ändern.

Wenn Sie RPC/HTTP Outlook 2003- oder Outlook 2007-Clients unterstützen, müssen Sie den Schlüssel Rpc/HTTP Port auf den Dezimalwert 6001 festlegen. Darüber hinaus müssen Sie die RPC/HTTP-Konfigurationen in der Umgebung überprüfen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den Registrierungswert für den Rpc/HTTP-Port fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters

  3. Doppelklicken Sie auf den Schlüssel Rpc/HTTP Port, und legen Sie im Feld Datenwerte einen eindeutigen Wert fest, der etwas größer als 5000 (dezimal) ist.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den Computer neu, damit die Einstellung wirksam wird.

So überprüfen Sie die Konfigurationen für RPC-über-HTTP

  1. Lesen Sie „Exchange Server 2003 RPC over HTTP Deployment Scenarios" unter http://go.microsoft.com/fwlink/?linkid=47577.

  2. Lesen Sie "Bereitstellen von Outlook Anywhere" (http://www.microsoft.com/technet/prodtechnol/exchange/E2k7/DE/Help/ExchHelp/7b2d1ce2-b6df-4604-80fd-2f6cafc47e82.mspx?mfr=true).

  3. Lesen Sie den Microsoft Knowledge Base-Artikel 833401, „Konfigurieren von RPC-über-HTTP auf einem einzelnen Server in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  4. Lesen Sie den Knowledge Base-Artikel 827330, „Behandlung von Problemen bei RPC-über-HTTP-Clientverbindungen in Office Outlook 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  5. Lesen Sie den Microsoft Support WebCast „Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unterhttp://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Anschlusskonflikt: TCP-Speicher
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-30

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob Anschlusskonflikte vorliegen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Wenn Exchange Server Analyzer ermittelt, dass der Wert für HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port mit einem der Werte übereinstimmt, die in den zuvor in diesem Artikel aufgeführten anderen sechs Registrierungswerten angegeben sind, wird ein Fehler angezeigt. Exchange Server Analyzer zeigt außerdem einen Fehler für den Port an, bei dem ein Konflikt mit HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port vorliegt.

Dieser Wert wird in den meisten Fällen konfiguriert, um MAPI-Clients das Herstellen einer Verbindung mit einem Exchange-Server zu ermöglichen, der sich auf der anderen Seite einer Firewall befindet. Hierfür müssen mehrere Anschlüsse in einer Firewall geöffnet werden, damit Microsoft Office Outlook® 2003 oder Outlook 2007-Clients mithilfe von MAPI (in der Regel über das Internet) eine Verbindung mit einem Server mit Exchange herstellen können.

Für die Verwendung von Outlook im MAPI-Modus zum Herstellen einer Verbindung mit einem Server mit Exchange über das Internet wird der Einsatz der Funktionen von RPC-über-HTTP in Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 und Microsoft Windows® XP Professional empfohlen. Der MAPI-Modus wurde früher als „Firmenmodus" oder „Arbeitsgruppenmodus" bezeichnet.

Um diesen Fehler zu beheben, müssen Sie den Wert für diesen Schlüssel oder den Schlüssel, bei dem wie von der Ausgabe in Microsoft Exchange Server Analyzer angegeben ein Konflikt vorliegt, in einen eindeutigen Wert ändern.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den Registrierungswert für den TCP/IP-Port fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Doppelklicken Sie auf den Schlüssel TCP/IP Port, und legen Sie im Feld Wert einen eindeutigen Wert fest, der etwas größer als 5000 (dezimal) ist.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den Computer neu, damit die Einstellung wirksam wird.

So stellen Sie RPC-über-HTTP bereit

  1. Lesen Sie „Exchange Server 2003 RPC over HTTP Deployment Scenarios" unter http://go.microsoft.com/fwlink/?linkid=47577.

  2. Lesen Sie "Bereitstellen von Outlook Anywhere" (http://www.microsoft.com/technet/prodtechnol/exchange/E2k7/DE/Help/ExchHelp/7b2d1ce2-b6df-4604-80fd-2f6cafc47e82.mspx?mfr=true).

  3. Lesen Sie den Microsoft Knowledge Base-Artikel 833401, „Konfigurieren von RPC-über-HTTP auf einem einzelnen Server in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  4. Lesen Sie den Knowledge Base-Artikel 827330, „Behandlung von Problemen bei RPC-über-HTTP-Clientverbindungen in Office Outlook 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  5. Lesen Sie den Microsoft Support WebCast „Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unterhttp://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zum statischen Zuweisen von Anschlüssen, die von Exchange verwendet werden, finden Sie im Microsoft Knowledge Base-Artikel 270836, "Statische Anschlusszuordnungen in Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)


Portkonflikt: Systemaufsicht HTTP
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-03-21

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob Portkonflikte vorliegen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Mit dem Schlüssel HTTP Port unterstützt Exchange die Features Microsoft Office Outlook® 2003 RPC/HTTP und Exchange Server 2007 Outlook Anywhere. Wenn Exchange Server Analyzer ermittelt, dass der Wert für HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port mit einem der Werte übereinstimmt, die in den zuvor in diesem Artikel aufgeführten anderen sechs Registrierungswerten angegeben sind, wird ein Fehler angezeigt. Exchange Server Analyzer zeigt außerdem einen Fehler für den Port an, bei dem ein Konflikt mit HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port vorliegt.

Um diesen Fehler zu beheben, müssen Sie den Wert für diesen Schlüssel oder den Schlüssel, bei dem wie von der Ausgabe in Microsoft Exchange Server Analyzer angegeben ein Konflikt vorliegt, in einen eindeutigen Wert ändern.

Wenn Sie RPC/HTTP Outlook 2003- oder Outlook 2007-Clients unterstützen, müssen Sie den Schlüssel HTTP Port auf den Dezimalwert 6002 festlegen. Darüber hinaus müssen Sie die RPC/HTTP-Konfigurationen in der Umgebung überprüfen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den Registrierungswert für den HTTP-Port fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Doppelklicken Sie auf den Schlüssel HTTP Port, und legen Sie im Feld Datenwerte einen eindeutigen Wert fest, der etwas größer als 5000 (dezimal) ist.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den Computer neu, damit die Einstellung wirksam wird.

So überprüfen Sie die Konfigurationen für RPC-über-HTTP

  1. Lesen Sie „Exchange Server 2003 RPC over HTTP Deployment Scenarios" unter http://go.microsoft.com/fwlink/?linkid=47577.

  2. Lesen Sie "Bereitstellen von Outlook Anywhere" (http://www.microsoft.com/technet/prodtechnol/exchange/E2k7/DE/Help/ExchHelp/7b2d1ce2-b6df-4604-80fd-2f6cafc47e82.mspx?mfr=true).

  3. Lesen Sie den Microsoft Knowledge Base-Artikel 833401, „Konfigurieren von RPC-über-HTTP auf einem einzelnen Server in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  4. Lesen Sie den Knowledge Base-Artikel 827330, „Behandlung von Problemen bei RPC-über-HTTP-Clientverbindungen in Office Outlook 2003"unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  5. Lesen Sie den Microsoft Support WebCast „Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unterhttp://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Anschlusskonflikt: HTTP NSPI zur Systemaufsicht
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-30

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob Anschlusskonflikte vorliegen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Mit dem Registrierungsschlüssel Rpc/HTTP NSPI Port unterstützt Exchange die Features Microsoft Office Outlook® 2003 RPC/HTTP und Exchange Server 2007 Outlook Anywhere. Wenn Exchange Server Analyzer ermittelt, dass der Wert für HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port mit einem der Werte übereinstimmt, die in den zuvor in diesem Artikel aufgeführten anderen sechs Registrierungswerten angegeben sind, wird ein Fehler angezeigt. Exchange Server Analyzer zeigt außerdem einen Fehler für den Anschluss an, bei dem ein Konflikt mit HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\ Rpc/HTTP NSPI Port vorliegt.

Um diesen Fehler zu beheben, müssen Sie den Wert für diesen Schlüssel oder den Schlüssel, bei dem wie von der Ausgabe in Microsoft Exchange Server Analyzer angegeben ein Konflikt vorliegt, in einen eindeutigen Wert ändern.

Wenn Sie RPC/HTTP Outlook 2003- oder Outlook 2007-Clients unterstützen, müssen Sie den Schlüssel Rpc/HTTP NSPI Port auf den Dezimalwert 6004 festlegen. Darüber hinaus müssen Sie die RPC/HTTP-Konfigurationen in der Umgebung überprüfen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den Registrierungswert für den Rpc/HTTP NSPI-Anschluss fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Doppelklicken Sie auf den Schlüssel Rpc/HTTP NSPI Port, und legen Sie im Feld Wert einen eindeutigen Wert fest, der etwas größer als 5000 (dezimal) ist.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den Computer neu, damit die Einstellung wirksam wird.

So überprüfen Sie die Konfigurationen für RPC-über-HTTP

  1. Lesen Sie „Exchange Server 2003 RPC over HTTP Deployment Scenarios" unter http://go.microsoft.com/fwlink/?linkid=47577.

  2. Lesen Sie "Bereitstellen von Outlook Anywhere" (http://www.microsoft.com/technet/prodtechnol/exchange/E2k7/DE/Help/ExchHelp/7b2d1ce2-b6df-4604-80fd-2f6cafc47e82.mspx?mfr=true).

  3. Lesen Sie den Microsoft Knowledge Base-Artikel 833401, „Konfigurieren von RPC-über-HTTP auf einem einzelnen Server in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  4. Lesen Sie den Knowledge Base-Artikel 827330, „Behandlung von Problemen bei RPC-über-HTTP-Clientverbindungen in Office Outlook 2003"unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  5. Lesen Sie den Microsoft Support WebCast „Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unterhttp://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Portkonflikt: NSPI-Port der Systemaufsicht
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-03-21

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob Portkonflikte vorliegen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Wenn Exchange Server Analyzer ermittelt, dass der Wert für HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port mit einem der Werte übereinstimmt, die in den zuvor in diesem Artikel aufgeführten anderen sechs Registrierungswerten angegeben sind, wird ein Fehler angezeigt. Exchange Server Analyzer zeigt außerdem einen Fehler für den Port an, bei dem ein Konflikt mit HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port vorliegt.

Dieser Wert wird in den meisten Fällen konfiguriert, um MAPI-Clients das Herstellen einer Verbindung mit einem Exchange-Server zu ermöglichen, der sich auf der anderen Seite einer Firewall befindet. Hierfür müssen mehrere Ports in einer Firewall geöffnet werden, damit Microsoft Office Outlook® 2003 oder Outlook 2007-Clients mithilfe von MAPI (in der Regel über das Internet) eine Verbindung mit einem Server mit Exchange herstellen können.

Für die Verwendung von Outlook im MAPI-Modus zum Herstellen einer Verbindung mit einem Server mit Exchange über das Internet wird der Einsatz der Funktionen von RPC-über-HTTP in Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 und Microsoft Windows® XP Professional empfohlen. Der MAPI-Modus wurde früher als „Firmenmodus" oder „Arbeitsgruppenmodus" bezeichnet.

Um diesen Fehler zu beheben, müssen Sie den Wert für diesen Schlüssel oder den Schlüssel, bei dem wie von der Ausgabe in Microsoft Exchange Server Analyzer angegeben ein Konflikt vorliegt, in einen eindeutigen Wert ändern.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den Registrierungswert für den TCP/IP NSPI-Port fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Doppelklicken Sie auf den Schlüssel TCP/IP NSPI Port, und legen Sie im Feld Datenwerte einen eindeutigen Wert fest, der etwas größer als 5000 (dezimal) ist.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den Computer neu, damit die Einstellung wirksam wird.

So stellen Sie RPC-über-HTTP bereit

  1. Lesen Sie „Exchange Server 2003 RPC over HTTP Deployment Scenarios" unter http://go.microsoft.com/fwlink/?linkid=47577.

  2. Lesen Sie "Bereitstellen von Outlook Anywhere" (http://www.microsoft.com/technet/prodtechnol/exchange/E2k7/DE/Help/ExchHelp/7b2d1ce2-b6df-4604-80fd-2f6cafc47e82.mspx?mfr=true).

  3. Lesen Sie den Microsoft Knowledge Base-Artikel 833401, „Konfigurieren von RPC-über-HTTP auf einem einzelnen Server in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  4. Lesen Sie den Knowledge Base-Artikel 827330, „Behandlung von Problemen bei RPC-über-HTTP-Clientverbindungen in Office Outlook 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  5. Lesen Sie den Microsoft Support WebCast „Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unterhttp://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zur statischen Zuordnung von Ports, die von Exchange verwendet werden, finden Sie im folgenden Knowledge Base-Artikel:

  • 270836, "Statische Portzuordnungen in Exchange 2000 und Exchange 2003" (http://support.microsoft.com/kb/270836/de)


Anschlusskonflikt: RFR zur Systemaufsicht
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-30

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob Anschlusskonflikte vorliegen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Wenn Exchange Server Analyzer ermittelt, dass der Wert für HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port mit einem der Werte übereinstimmt, die in den zuvor in diesem Artikel aufgeführten anderen sechs Registrierungswerten angegeben sind, wird ein Fehler angezeigt. Exchange Server Analyzer zeigt außerdem einen Fehler für den Anschluss an, bei dem ein Konflikt mit HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port vorliegt.

Dieser Wert wird in den meisten Fällen konfiguriert, um MAPI-Clients das Herstellen einer Verbindung mit einem Exchange-Server zu ermöglichen, der sich auf der anderen Seite einer Firewall befindet. Hierfür müssen mehrere Anschlüsse in einer Firewall geöffnet werden, damit Microsoft Office Outlook® 2003 oder Outlook 2007-Clients mithilfe von MAPI (in der Regel über das Internet) eine Verbindung mit einem Server mit Exchange herstellen können.

Für die Verwendung von Outlook im MAPI-Modus zum Herstellen einer Verbindung mit einem Server mit Exchange über das Internet wird der Einsatz der Funktionen von RPC-über-HTTP in Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 und Microsoft Windows® XP Professional empfohlen. Der MAPI-Modus wurde früher als „Firmenmodus" oder „Arbeitsgruppenmodus" bezeichnet.

Um diesen Fehler zu beheben, müssen Sie den Wert für diesen Schlüssel oder den Schlüssel, bei dem wie von der Ausgabe in Microsoft Exchange Server Analyzer angegeben ein Konflikt vorliegt, in einen eindeutigen Wert ändern.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den Registrierungswert für den TCP/IP-Anschluss fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Doppelklicken Sie auf den Schlüssel TCP/IP Port, und legen Sie im Feld Datenwerte einen eindeutigen Wert fest, der etwas größer als 5000 (dezimal) ist.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den Computer neu, damit die Einstellung wirksam wird.

So stellen Sie RPC-über-HTTP bereit

  1. Lesen Sie „Exchange Server 2003 RPC over HTTP Deployment Scenarios" unter http://go.microsoft.com/fwlink/?linkid=47577.

  2. Lesen Sie "Bereitstellen von Outlook Anywhere" (http://www.microsoft.com/technet/prodtechnol/exchange/E2k7/DE/Help/ExchHelp/7b2d1ce2-b6df-4604-80fd-2f6cafc47e82.mspx?mfr=true).

  3. Lesen Sie den Microsoft Knowledge Base-Artikel 833401, „Konfigurieren von RPC-über-HTTP auf einem einzelnen Server in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  4. Lesen Sie den Knowledge Base-Artikel 827330, „Behandlung von Problemen bei RPC-über-HTTP-Clientverbindungen in Office Outlook 2003"unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  5. Lesen Sie den Microsoft Support WebCast „Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unterhttp://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zum statischen Zuweisen von Anschlüssen, die von Exchange verwendet werden, finden Sie im Microsoft Knowledge Base-Artikel 270836, "Statische Anschlusszuordnungen in Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)


Vorab veröffentlichtes Updaterollup für Service Pack wurde erkannt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs versionNumber für jedes ExchangeServer-Objekt zu ermitteln. Das Attribut versionNumber stellt die Exchange Server-Version dar, die auf dem Computer ausgeführt wird.

Microsoft® Exchange Server Analyzer sendet eine Abfrage an die WMI-Klasse (Microsoft Windows® Management Instrumentation) CIM_Datafile, um den Wert des Schlüssels Version für die Bibliotheksdatei Exchange Collaboration Data Object ( ExCDO, ExCDO.dll) zu bestimmen. Wenn der Exchange Server Analyzer feststellt, dass der Schlüssel Version für ExCDO.dll den Wert 6603.0 aufweist, wird eine Warnung angezeigt.

Ein Exchange 2000 Server-Computer, auf dem die Version 6603.0 von ExCDO.dll ausgeführt wird, zeigt damit an, dass auf dem Server das Update-Rollup von August 2004 (Version 1 Exchange 2000 Server Post-Service Pack 3 (SP3)) ausgeführt wird. Version 2 dieses Update-Rollups ist jetzt verfügbar. Es wird empfohlen, dass Sie das Update-Rollup vom August 2004 installieren.

So beheben Sie dieses Problem

  1. Informationen zum aktuellen Update finden Sie im Microsoft Knowledge Base-Artikel 870540 „Availability of the August 2004 Exchange 2000 Server Post-Service Pack 3 Update Rollup" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540.

  2. Downloaden Sie das neueste Update (August 2004) von der Exchange 2000 Server-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).

  3. Nehmen Sie eine Sicherung des Exchange Server-Computers vor.

  4. Wenden Sie das Updaterollup von August 2004 an.

Weitere Informationen zum Beziehen des neuesten Service Packs für Exchange 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 301378, „Wie Sie das neueste Service Pack für Exchange 2000 Server erhalten" unter (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378).

Weitere Informationen zum Installieren dieser und anderer Exchange Server-Updates finden Sie im Knowledge Base-Artikel 328839 „Wie Sie Service Packs und Hotfixes für Exchange anwenden" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839.


Probleme mit dem Speicherort der Auslagerungsdatei
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer hat festgestellt, dass sich Ihre Auslagerungsdatei an einem Speicherplatz befindet, durch den die Serverperformance beeinträchtigt wird. Die Auslagerungsdatei sollte nicht auf derselben Platte wie die Exchange-Datenbanken oder das Exchange-Protokoll speichert werden. Es empfiehlt sich außerdem, die Auslagerungsdatei von den Systemdateien zu trennen.

Es empfiehlt sich, die Auslagerungsdatei auf einer dedizierten Partition oder auf einem Hochgeschwindigkeitsdatenträger zu speichern.

So beheben Sie dieses Problem

  • Verschieben Sie die Auslagerungsdatei an einen Speicherort ohne Exchange-Datenbanken oder Protokolldateien und, wenn möglich, an einen Speicherort, der keine Systempartition enthält.

Weitere Informationen

  • Weitere Informationen zum Konfigurieren der Auslagerungsdatei finden Sie im Microsoft Knowledge Base-Artikel 197379, „Auslagerungsdateien konfigurieren: Optimierung/Wiederherstellung" unter http://support.microsoft.com/kb/197379/de

  • Weitere Informationen zur Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=de).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=de).


Prozessorengpass
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-02-24

Microsoft® Exchange Server Analyzer hat festgestellt, dass auf Ihrem Server ein CPU-Engpass vorliegt. Die CPU-Auslastung Ihres Servers hat einen empfohlenen Schwellenwert überschritten. Zu den Leistungsindikatoren, mit deren Hilfe Prozessorengpässe oder Probleme bei der Prozessorverwendung festgestellt werden, gehören folgende:

  • Leistungsindikator Context Switches/sec unter dem Leistungsobjekt System.

  • Leistungsindikator % Processor Time (_Total) unter dem Leistungsobjekt Processor.

  • Leistungsindikator Länge der Prozessorwarteschlange unter dem Leistungsobjekt System.

Feststellen eines Prozessorengpasses

Exchange Server Analyzer stellt einen Engpas fest, wenn eine der folgenden Bedingungen erfüllt ist:

  • Der Durchschnittswertwert des Leistungsindikators % Processor Time (_Total) unter dem Leistungsobjekt Process ist größer als 70 Prozent.

  • Der Maximalwert des Leistungsindikators % Processor Time (_Total) unter dem Leistungsobjekt Process ist größer als 90 Prozent.

  • Der Durchschnitt des Leistungsindikators Context Switches/sec unter dem Leistungsobjekt System ist größer als 20.000.

  • Der Leistungsindikator Länge der Prozessorwarteschlange unter dem Leistungsobjekt System ist größer als zwei.

  • Der Leistungsindikator % Processor Time (_Total) unter dem Leistungsobjekt Process stellt die Gesamtauslastung des Prozessors dar. Die durchschnittliche CPU-Auslastung sollte immer unter 80 Prozent liegen. Höhere Durchschnittswerte deuten auf einen Prozessorengpass hin. Wenn die durchschnittliche Prozessorauslastung höher als 70 Prozent ist, wird eine Warnung angezeigt. Häufige Spitzen in der Prozessorzeit über 90 Prozentz hinaus sind ebenfalls ein Hinweis auf einen Prozessorengpass.

  • Der Leistungsindikator Processor Queue Length unter dem Leistungsobjekt System gibt die Anzahl der Threads in der Prozessorwarteschlange an. Es gibt sogar auf Computern mit mehreren Prozessoren nur eine einzige Warteschlange für die Prozessorzeit. Eine Zahl über zwei zeigt an, dass Threads auf Prozessorzeit warten, und dass es einen Prozessorengpass gibt.

Ermitteln von Quellen der Prozessorbelastung

Wenn ein Prozessorengpass festgestellt wird, müssen Sie feststellen, woraus die CPU-Auslastung hauptsächlich resultiert. Auf einem Exchange-Back-End-Server resultiert die CPU-Auslastung hauptsächlich aus dem Prozess Store.exe. Wenn mehr als 20 Prozent der CPU-Auslastung aus einem anderen Prozess als Store.exe resultiert, müssen Sie unbedingt feststellen, welche anderen Prozesse die CPU beanspruchen.

Wenn die CPU-Auslastung für die in der nachfolgenden Tabelle aufgeführten Prozesse über dem Schwellenwert liegt, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Prozess | Schwellenwert für % Processor Time unter dem Leistungsobjekt Process.
Speicher | 90 %
Inetinfo | 20 %
Emsmts | 40 %
Lsass | 40 %
System | 40 %
Mad | 40 %
ExMGMT | 20 %
W3WP | 40 %

Exchange Server Analyzer misst auch die Differenz zwischen der Prozessorleerlaufzeit, die mit dem Leistungsindikator %Processor Time gemessen wird (Idle-Instanz) und dem Leistungsindikator %Processor Time (_Total-Instanz) unter dem Leistungsobjekt Process. Auf einem ordnungsgemäß arbeitenden Exchange-Back-End-Server, sollten mindestens 70 Prozent der genutzten Prozessorzeit vom Prozess Store.exe verursacht sein.

Microsoft Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Der Anteil der Prozessorzeit, der nicht für Prozesse im Zusammenhang mit dem Exchange-Server (Store.exe, inetinfo.exe, emsmta.exe, lsass.exe, w3wp.exe, exmgmt.exe oder mad.exe) verwendet wird, ist größer als 35 Prozent.

  • Der Anteil der nicht auf Exchange bezogenen Prozessorzeit ist größer als 20 Prozent.

  • Es gibt einen Prozessorengpass, und weniger als 70 Prozent der Prozessorzeit werden für Store.exe aufgewendet.

In all diesen Fällen wird empfohlen festzustellen, welche anderen Prozesse die CPU-Zeit Ihres Servers beanspruchen.

Hauptursachen für Prozessorengpässe auf Back-End-Servern

Es gibt viele mögliche Ursachen für einen Leistungsengpass:

  • Andere Anwendungen auf dem Server nutzen die CPU

  • Hohe RPC-Raten

  • Wachsen von Verteilerlisten

  • Sicherung und Wartung werden zu Spitzenlastzeiten ausgeführt

  • Konvertierung von Nachrichteninhalt in Nachrichten aufgrund folgender Ursachen:

    • Mehrere Protokolle werden ausgeführt (zum Beispiel: HTTP, POP3, IMAP4, Microsoft Office Outlook®)

    • Outlook 2000 oder ältere Versionen verwenden Offline-Ordner (OST-Dateien)

Beheben von Prozessorengpässen

Es gibt viele Möglichkeiten, um Prozessorengpässe auf Ihrem Exchange-Server zu beheben.

So beseitigen Sie Prozessorengpässe

  • Fügen Sie möglichenfalls zusätzliche oder schnellere Prozessoren zum Server hinzu. Aktivieren Sie zudem Hyper-Threading, wenn dies von den Prozessoren unterstützt wird. Sie aktivieren Hyper-Threading, indem Sie das System-BIOS entsprechend konfigurieren. Weitere Informationen finden Sie in der Hilfedokumentation Ihres Computerherstellers.

  • Wenn sich die Prozessorleistung nicht steigern lässt, müssen Sie die Last auf den Prozessoren reduzieren. Um die Gesamtauswirkung auf den Server zu reduzieren, muss unbedingt sichergestellt werden, dass Aufgaben mit vielen E/A oder intensiver Nutzung von CPU und Speicher außerhalb der normalen Betriebszeiten erledigt werden.

    Stellen Sie zunächst fest, welche Anwendungen oder Aufgaben die Serverbelastung verursachen. Wenn eine andere Anwendung als Exchange für den Server nicht wichtig ist, führen Sie diese Anwendung auf einem anderen Server aus. Verschieben Sie möglichenfalls auch Serverrollen auf andere Computer. Wenn beispielsweise der Inetinfo-Prozess einen großen Teil der CPU-Verwendung beansprucht, sollten Sie Front-End-Server hinzufügen, damit diese die Aufgaben der Protokollarbeit, die von Inetinfo ausgeführt wird, übernehmen. Sie können den Zugriff auf den Öffentlichen Ordner auch auf einen dedizierten Server für Öffentliche Ordner umlenken. Wenn ein Server viele Erweiterungen der Verteilerlisten vornimmt, können Sie schließlich die CPU-Verwendung verringern, indem Sie das Erweitern von Verteilerlisten auf einen speziell für die Erweiterung von Verteilerlisten vorgesehenen Server verschieben.

  • Stellen Sie sicher, dass prozessorintensive Aufgaben (wie Sicherungs- und Wartungsaufgaben) außerhalb der Spitzenlastzeiten ausgeführt werden. Vergewissern Sie sich außerdem, dass diese Aufgaben in einer systematischen Abfolge ausgeführt werden. Unter dem Planen einer Aufgabe ist zu verstehen, dass unterschiedliche Startzeiten und vorzugsweise auch Endzeiten für jede Aufgabe definiert werden. Durch Planen der Wartung und Sicherung von Datenbanken oder Speichergruppen, werden die Auswirkungen dieser ressourcenintensiven Aufgaben abgeschwächt.

  • Wenn Sie alle verzichtbaren Lastursachen beseitigt haben, und die CPU-Auslastung immer noch zu hoch ist, müssen Sie Benutzer auf einen anderen Server verschieben, um die Last zu senken. Weitere Informationen finden Sie unter Verschieben von Benutzerpostfächern auf einen anderen Server.

Weitere Informationen

  • Weitere Informationen zur Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen zum Verschieben von Benutzerpostfächern zum Verringern der Serverlast finden Sie unter Verschieben von Benutzerpostfächern auf einen anderen Server.


Das Objekt zur Überwachung der Prozessorleistung ist nicht vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem % Processor Time-Leistungsindikator des Processor-Leistungsobjekts. Wenn gültige Daten nicht vom Indikator zurückgegeben werden, zeigt Microsoft Exchange Server Analyzer eine Basislinienmeldung an.

Wenn keine gültigen Daten vom Erfassungsmodul für Leistungsdaten zurückgegeben werden, liegt mindestens eine der folgenden Bedingungen vor:

  • Das Processor-Leistungsobjekt ist deaktiviert.

  • Das Processor-Leistungsüberwachungsobjekt wurde nicht gefunden, oder es ist beschädigt.

  • Microsoft Exchange Server Analyzer verfügt nicht über entsprechende Berechtigungen zum Zugreifen auf die Leistungsobjekte.

Die ersten beiden Bedingungen treten auf, wenn die Registrierung von bestimmten erweiterbaren Indikatoren beschädigt wird oder wenn die Registrierung von auf Microsoft WMI (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) basierten Programmen geändert wird. Im folgenden Verfahren wird die Behebung der ersten beiden Bedingungen erläutert. Überprüfen Sie vor dem Ausführen des Verfahrens, ob Microsoft Exchange Server Analyzer über entsprechende Berechtigungen verfügt. Weitere Informationen zu den Berechtigungen, die zum Ausführen von Microsoft Exchange Server Analyzer erforderlich sind, finden Sie in der im Lieferumfang von Microsoft Exchange Server Analyzer enthaltenen Hilfedokumentation. Wenn Sie Hilfe erhalten möchten, öffnen Sie Exchange Server Analyzer, und drücken Sie F1.

So beheben Sie diesen Fehler

  1. Überprüfen Sie, ob das Processor-Leistungsobjekt aktiviert ist.

    1. Downloaden und installieren Sie das Tool „Extensible Performance Counter List" (Exctrlst.exe). Sie können Exctrlst.exe unter „Exctrlst.exe: Extensible Performance Counter List" (http://go.microsoft.com/fwlink/?LinkId=34436) downloaden.

    2. Öffnen Sie die Datei Exctrlst.exe, klicken Sie auf Sortierreihenfolge und anschließend auf Dienst.

    3. Suchen Sie den Dienst, über den das Leistungsobjekt eine Meldung ausgeben soll, und überprüfen Sie, ob das Kontrollkästchen Leistungsindikatoren aktiviert aktiviert ist.

      Wenn das Kontrollkästchen Leistungsindikatoren aktiviert nicht aktiviert ist, aktivieren Sie es, und starten Sie den Dienst neu, der dem Leistungsindikator zugeordnet ist, um zu überprüfen, ob die Leistungsindikatoren betriebsbereit sind. Wenn die Leistungsindikatoren nicht betriebsbereit sind oder wenn das Kontrollkästchen Leistungsindikatoren aktiviert bereits aktiviert wurde, fahren Sie mit Schritt 2 fort.

  2. Erstellen Sie die nicht vorhandenen oder beschädigten Leistungsindikatoren wie im Microsoft Knowledge Base-Artikel 300956 „Manuelles Neuerstellen der Werte der Leistungsindikatorenbibliothek" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) beschrieben neu.

  3. Wenn Sie das Problem anhand dieses Knowledge Base-Artikels nicht beheben lässt, müssen Sie das Windows-Betriebssystem im Modus Reparieren erneut installieren und die aktuellsten Windows-Service Packs anwenden.


Die Inhaltsreplikation für Öffentliche Ordner wurde angehalten.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob das Attribut heuristics in der Exchange Server-Organisation festgelegt wurde. Wenn Exchange Server Analyzer feststellt, dass für heuristics das Bit 1024 festgelegt wurde, zeigt Exchange Server Analyzer eine Warnung an.

Mit Exchange Server 2003 SP2 wurde die Berechtigung für Administratoren eingeführt, alle Inhaltsreplikationen Öffentlicher Ordner in der Organisation anzuhalten. Sie können die Inhaltsreplikationen Öffentlicher Ordner anhalten, indem Sie mit der rechten Maustaste in der Exchange-Systemverwaltung auf den Organisationsnamen und anschließend auf Inhaltsreplikation für Öffentliche Ordner anhalten klicken. Wenn auf Inhaltsreplikation für Öffentliche Ordner anhalten geklickt wird, wird im Attribut heuristics das Bit 1024 festgelegt. Die Replikation sollte nur in Ausnahmefällen für alle Öffentlichen Ordner angehalten werden, z. B. bei der Behandlung von organisationsweiten Problemen mit Öffentlichen Ordnern oder dem Nachrichtenfluss.

Die Inhaltsreplikation Öffentlicher Ordner muss fortgesetzt werden, wenn die folgenden Bedingungen zutreffen:

  • Es findet keine Problembehandlung statt.

  • Es ist aus keinem anderen Grund notwendig, die Inhaltsreplikation aller Öffentlichen Ordner anzuhalten.

So wird die Inhaltsreplikation Öffentlicher Ordner auf der Organisationsebene fortgesetzt

  1. Öffnen Sie den Exchange-System-Manager.

  2. Klicken Sie mit der rechten Maustaste auf Name der Organisation, und klicken Sie dann auf Inhaltsreplikation für Öffentliche Ordner fortsetzen.

Weitere Informationen zur Replikation Öffentlicher Ordner finden Sie in Best Practices for Exchange Server Public Folders (http://go.microsoft.com/fwlink/?LinkId=46437).


Auf dem Front-End-Server ist ein Informationsspeicher für Öffentliche Ordner vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-09-07

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob ein auf jedem Exchange-Server ein Öffentlicher Ordnerspeicher vorhanden ist. Wenn Exchange Server Analyzer feststellt, dass das Objekt InformationStore der Objektklasse msExchPublicMDB angehört, dient der Server als Host für einen öffentlichen Ordnerspeicher.

Darüber hinaus fragt Exchange Server Analyzer die WMI-Klasse MicrosoftExchangeV2 (Microsoft Windows®Management Instrumentation) ab, um zu ermitteln, ob für den Schlüssel IsFrontEndServer ein Wert festgelegt ist. Der Wert True zeigt an, dass der Exchange-Server als Front-End-Server konfiguriert ist, und der Wert False zeigt an, dass er nicht als Front-End-Server festgelegt ist. Wenn der Exchange Server Analyzer ermittelt, dass ein als Front-End-Server konfigurierter Exchange-Server für einen öffentlichen Informationsspeicher als Host dient, wird eine Warnung angezeigt.

Es wird empfohlen, dass Sie auf Front-End-Servern keine Nicht-Öffentlichen Ordnerspeicher ausführen. Öffentliche Ordnerspeicher werden auf Front-End-Servern nicht benötigt, da Front-End-Server nicht als Host für Postfächer dienen. Darüber hinaus bestehen bekannte Probleme bei der Replikation Öffentlicher Ordner, bei Verweisen auf Öffentliche Ordner und bei Speicherverlusten, wenn sich die Informationsspeicher für Öffentliche Ordner auf Front-End-Servern unter Exchange 2000 Server befinden. Deshalb sollten Sie alle Öffentlichen Ordnerspeicher auf allen Front-End-Servern aufheben.

Nach dem Aufheben der Öffentlichen Ordnerspeicher können Sie den Microsoft Exchange-Informationsspeicherdienst deaktivieren, da er auf den Front-End-Servern keine Funktion mehr erfüllt. Indem Sie unnötige Dienste entfernen, reduzieren Sie die Belastung und verbessern die Sicherheit und Leistung.

Hinweis:
Wenn der Front-End-Server auch SMTP-Nachrichten (Simple Mail Transfer Protocol) aus dem Internet erhält, sollte der Microsoft Exchange-Informationsspeicherdienst weiterhin ausgeführt werden, und ein Postfachspeicher muss aktiv bleiben. Allerdings sollte sich ein Informationsspeicher für Öffentliche Ordner nie auf einem Front-End-Server befinden.

So beenden und deaktivieren Sie die Datenbanken für das Postfach und die Öffentlichen Ordner

  1. Erweitern Sie im Exchange-System-Manager Server, erweitern Sie Ihren Server, und erweitern Sie dann Erste Speichergruppe.

    Klicken Sie mit der rechten Maustaste auf Postfachspeicher (ServerName), klicken Sie auf Bereitstellung des Informationsspeichers aufheben und anschließend auf Ja, um die Bereitstellung des Informationsspeichers aufzuheben.

    Wichtig:
    Wenn Sie den Front-End-Server als SMTP-Bridgeheadserver verwenden, müssen Sie einen Postfachspeicher auf dem Server bereitstellen. Heben Sie in diesem Fall die Bereitstellung dieses Speichers nicht auf, und löschen Sie ihn nicht, aber stellen Sie sicher, dass auf diesem Server keine Postfächer gespeichert sind.

  2. Klicken Sie mit der rechten Maustaste auf Postfachspeicher (ServerName), und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf die Registerkarte Datenbank, aktivieren Sie das Kontrollkästchen Diesen Informationsspeicher beim Start nicht bereitstellen, und klicken Sie dann auf OK.

    Klicken Sie mit der rechten Maustaste auf Informationsspeicher für Öffentliche Ordner (ServerName), und klicken Sie dann auf Bereitstellung des Informationsspeichers aufheben.

    Achtung:
    Vergewissern Sie sich vor dem Aufheben der Bereitstellung des Informationsspeichers für Öffentliche Ordner, dass die Öffentlichen Ordner über ein Replikat in einem anderen Informationsspeicher für Öffentliche Ordner verfügen. Andernfalls könnten Sie Informationen verlieren.

  4. Klicken Sie auf Ja, um die Bereitstellung des Informationsspeichers für Öffentliche Ordner aufzuheben.

So deaktivieren Sie den Microsoft Exchange-Informationsspeicher

  1. Klicken Sie im Services MMC-Snap-In (Microsoft Management Console) in der Liste Name mit der rechten Maustaste auf Microsoft Exchange-Informationsspeicher, und klicken Sie dann auf Eigenschaften.

  2. Wählen Sie in der Liste Starttyp die Option Deaktiviert aus, und klicken Sie dann auf Beenden.

So löschen Sie die Datenbanken für das Postfach und die Öffentlichen Ordner dauerhaft

  • Befolgen Sie die Anleitungen im Exchange Server-Sicherheitshandbuch, Löschen und Aufheben der Bereitstellung von Postfachspeichern und Informationsspeichern für Öffentliche Ordner (http://go.microsoft.com/fwlink/?LinkId=25210)

Weitere Informationen zu Themen, die sich auf das Ausführen von Speicherdiensten auf Front-End-Servern beziehen, finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 286822, „XCCC: Front-End Servers Establish Large Number of Connections to Themselves" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=286822).

  • 320298, „Large number of connections established on front-end servers that are running Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320298)

Weitere Informationen zu Front-End- und Back-End-Servern finden Sie im Handbuch Exchange Server 2003 and Exchange 2000 Server Front-End and Back-End Topology (http://go.microsoft.com/fwlink/?linkid=34216).


Datei „REAPI.DLL" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere der obigen Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Recipient Update Service is missing or is not configured
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-07-11

Das Tool Microsoft Exchange Server Analyzer fragt den Active Directory-Verzeichnisdienst ab, um den Wert des Attributs msExchAddressListServiceLink für jedes Objekt Empfängeraktualisierungsdienst im Verzeichnis zu ermitteln. Das Attribut msExchAddressListServiceLink stellt eine Verknüpfung zwischen dem Adressenlistendienst und dem Exchange Server-Computer dar, auf dem es ausgeführt werden soll. Wenn Exchange Analyzer feststellt, dass kein Attribut msExchAddressListServiceLink für ein Empfängeraktualisierungsdienst-Objekt vorhanden oder der Attributwert msExchAddressListServiceLink für das Objekt nicht mit Daten aufgefüllt ist, wird ein Fehler angezeigt.

Jede Instanz des Empfängeraktualisierungsdienstes ist normalerweise einem Computer mit Exchange Server zugeordnet, auf dem der Empfängeraktualisierungsdienst ausgeführt wird. Wenn Sie diese Meldung erhalten, ist die Instanz des Empfängeraktualisierungsdiensts keinem Computer mit Exchange Server zugeordnet. Dies kann dazu führen, dass Exchange-Adresslisten und -Empfänger nicht aktualisiert werden.

Um die Instanz des Empfängeraktualisierungsdiensts ausführen zu können, muss sie einem anderen vorhandenen Servercomputer mit zugeordnet werden.

So beheben Sie diesen Fehler

  1. Öffnen Sie den Exchange-System-Manager.

  2. Klicken Sie unter Empfänger auf Empfängeraktualisierungsdienste. Klicken Sie im rechten Bereich mit der rechten Maustaste auf die entsprechende Instanz des Empfängeraktualisierungsdiensts, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Allgemein unter Exchange-Server auf Durchsuchen, und geben Sie einen Server an, auf dem diese Instanz ausgeführt werden soll.

  4. Klicken Sie auf OK. Klicken Sie anschließend nochmals auf OK, damit die Änderung wirksam wird.

  5. Schließen Sie den Exchange-System-Manager.

Weitere Informationen zum Empfängeraktualisierungsdienst finden Sie in den folgenden Themen und Microsoft Knowledge Base-Artikeln:

  • "Verwalten von Empfängern und Empfängerrichtlinien in Exchange Server 2003" im Technischen Referenzhandbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47617)

  • 328738, "Anwenden von Empfängerrichtlinien durch den Empfängeraktualisierungsdienst" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828, "Auffüllen von Daten in Adresslisten durch den Empfängeraktualisierungsdienst" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127, "Überprüfen des Status des Exchange-Empfängeraktualisierungsdiensts" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770, "Vom Empfängeraktualisierungsdienst durchgeführte Aufgaben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


Empfohlene Updates für Windows 2000 Server SP 4 sind Teil eines Clusters
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Version des Microsoft Windows®-Betriebssystems zu bestimmen, die auf dem Exchange-Server ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion

Hinweis:
Der Wert 4.0 für CurrentVersion gibt an, dass auf dem Computer Microsoft Windows NT Server 4.0 ausgeführt wird. Der Wert 5.0 gibt an, dass auf dem Computer Microsoft Windows 2000 Server ausgeführt wird. Der Wert 5.2 gibt an, dass auf dem Computer Microsoft Windows Server™ 2003 ausgeführt wird.

Exchange Server Analyzer fragt außerdem die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_OperatingSystem ab, um den Wert des Schlüssels ServicePackMajorVersion zu bestimmen.

Schließlich fragt Exchange Server Analyzer die WMI-Klasse Win32_Service ab, um zu bestimmen, ob der Dienst „ClusSvc" gestartet wurde.

Microsoft Exchange Server Analyzer zeigt eine Meldung mit der optimalen Konfigurationsmethode an, wenn die folgenden Bedingungen erfüllt sind:

  • Der Exchange-Server befindet sich auf einem Computer, auf dem Windows 2000 Server mit Service Pack 4 ausgeführt wird.

  • Der Dienst „ClusSvc" wurde gestartet.

Es wird empfohlen, die verfügbaren Aktualisierungen und Hotfixes auszuwerten und zu bestimmen, ob diese die Probleme in der Umgebung lösen können.

Weitere Informationen und eine Liste der verfügbaren Aktualisierungen für Server mit Windows 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 895090 „Recommended hotfixes for Windows 2000 Service Pack 4-based server clusters" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=895090.


Die Länge der Remotewarteschlange hat den Schwellenwert überschritten
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-04-09

Das Tool Microsoft Exchange Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Remote Queue Length-Leistungsindikator des SMTP Server-Leistungsobjekts.

Wenn Exchange Analyzer feststellt, dass der Leistungsindikator Remote Queue Length den Spitzenwert von 100 während des Erfassungszeitraums überschritten hat, wird ein Fehler angezeigt.

Der Leistungsindikator SMTP Server\Remote Queue Length gibt die Anzahl der Nachrichten in der SMTP-Warteschlange (Simple Mail Transfer Protocol) zur Remoteübermittlung an. Ein Ansteigen der Remote Queue Length bedeutet, dass E-Mail-Nachrichten nicht an andere Server gesendet werden.

Dieser Fehler beim Senden von E-Mail-Nachrichten entsteht durch Ausfälle oder Leistungsprobleme der Netzwerk- oder Remoteserver. Durch diese Ausfälle oder Leistungsprobleme wird verhindert, dass die Netzwerk- oder Remoteserver E-Mail-Nachrichten auf effiziente Weise empfangen.

Um dieses Fehler zu beheben, verwenden Sie die Ressourcen der folgenden Links, um die problematischen Server oder Netzwerkkomponenten zu ermitteln und die Leistungsprobleme zu beheben.

Weitere Informationen

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange Server finden Sie unter „Identifying Rising Mail Queues" im Abschnitt „Identifying Symptoms of Poor Performance" des Handbuchs Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen zur Leistung von Exchange Server finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Leistung von Exchange Server finden Sie unter Exchange Server 2003 Performance: 10 Things to Think About (http://go.microsoft.com/fwlink/?LinkID=56460).


Die Länge der Warteschlange für Remotewiederholungsversuche hat den Schwellenwert überschritten
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-02-13

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Remote Retry Queue Length-Leistungsindikator des SMTP Server-Leistungsobjekts.

Der Leistungsindikator SMTP Server\Remote Retry Queue Length zeigt die Anzahl der Nachrichten in der SMTP-Warteschlange für Remotewiederholungsversuche (Simple Mail Transfer Protocol) an, die nicht an einen Zielserver gesendet werden können. Wenn Exchange Server Analyzer feststellt, dass der Leistungsindikator Remote Retry Queue Length den Spitzenwert von 100 während des Erfassungszeitraums überschritten hat, wird ein Fehler angezeigt.

Dieser Fehler beim Senden von E-Mail-Nachrichten entsteht durch Ausfälle oder Leistungsprobleme der Netzwerk- oder Remoteserver. Durch diese Ausfälle oder Leistungsprobleme wird verhindert, dass die Netzwerk- oder Remoteserver E-Mail-Nachrichten auf effiziente Weise empfangen.

Um dieses Fehler zu beheben, verwenden Sie die Ressourcen der folgenden Links, um die problematischen Server oder Netzwerkkomponenten zu ermitteln und die Leistungsprobleme zu beheben.

Weitere Informationen

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange Server finden Sie unter „Identifying Rising Mail Queues" im Abschnitt „Identifying Symptoms of Poor Performance" des Handbuchs Troubleshooting Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen zur Leistung von Exchange Server finden Sie im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Leistung von Exchange Server finden Sie unter Exchange Server 2003 Performance: 10 Things to Think About (http://go.microsoft.com/fwlink/?LinkID=56460).


Replikat von Offlineadressbuch, Version 4, wurde nicht gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-02-13

Microsoft® Exchange Server Best Practices Analyzer fragt die Microsoft Windows®-Verwaltungsinstrumentationsklasse (Windows® Management Instrumentation, WMI) Exchange_Public_Folder ab, um den aktuellen Wert für HasLocalReplica zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass der Wert für HasLocalReplica für die Instanz des Offlineadressbuchs, Version 4, einer Offlineadressliste auf False festgelegt ist, wird ein Fehler angezeigt.

Wenn HasLocalReplica für die Instanz des Offlineadressbuchs, Version 4, für eine Offlineadressliste auf False festgelegt ist, werden Offlineadresslisten nicht ordnungsgemäß generiert. Demzufolge können Benutzer von Microsoft Office Outlook® 2003 keine Offlineadresslisten herunterladen.

Dieses Problem kann auftreten, wenn Sie keinen Informationsspeicher für Öffentliche Ordner so konfiguriert haben, dass dieser Replikate für das Offlineadressbuch, Version 4, enthält. In der Standardeinstellung wird der Inhalt des Offlineadressbuchs in den Informationsspeicher für Öffentliche Ordner des Servers repliziert, auf dem es installiert ist. Wenn der Informationsspeicher für Öffentliche Ordner aus der Replikationskonfiguration des Offlineadressbuchs entfernt wird, tritt das zuvor beschriebene Problem auf.

So beheben Sie diesen Fehler

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Administrative Gruppen, und klicken Sie dann auf Ordner.

  3. Klicken Sie mit der rechten Maustaste auf Öffentliche Ordner, und klicken Sie anschließend auf Systemordner anzeigen.

  4. Klicken Sie auf OFFLINEADRESSBUCH, um das Objekt zu erweitern.

  5. Klicken Sie unter OFFLINEADRESSBUCH mit der rechten Maustaste auf o=org/cn=addrlists/cn=oabs/cn=Standard-Offlineadressliste, und klicken Sie dann auf Eigenschaften.

  6. Vergewissern Sie sich auf der Registerkarte Replikation, dass im Feld Inhalte in diese Öffentlichen Informationsspeicher replizieren ein Informationsspeicher für Öffentliche Ordner eingegeben ist. Wenn kein Informationsspeicher für Öffentliche Ordner eingegeben ist, klicken Sie auf Hinzufügen und geben dann den entsprechenden Informationsspeicher für Öffentliche Ordner für das Offlineadressbuch ein.

  7. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.

  8. Klicken Sie auf o=org/cn=addrlists/cn=oabs/cn=Standard-Offlineadressliste, um den Eintrag zu erweitern.

  9. Klicken Sie unter o=org/cn=addrlists/cn=oabs/cn=Standard-Offlineadressliste mit der rechten Maustaste auf Offlineadressbuch, Version 4, und klicken Sie dann auf Eigenschaften.

  10. Vergewissern Sie sich auf der Registerkarte Replikation, dass im Feld Inhalte in diese Öffentlichen Informationsspeicher replizieren ein Informationsspeicher für Öffentliche Ordner eingegeben ist. Wenn kein Informationsspeicher für Öffentliche Ordner eingegeben ist, klicken Sie auf Hinzufügen, und geben Sie dann den entsprechenden Informationsspeicher für Öffentliche Ordner für das Offlineadressbuch ein.

  11. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.

Weitere Informationen zu diesem Problem finden Sie im Microsoft Knowledge Base-Artikel 286328, „Offlineadressbuch fehlt und kann nicht in Microsoft Exchange generiert werden" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328).

Weitere Informationen zum ordnungsgemäßen Entfernen des ersten Exchange Server 2003-Computers aus einer administrativen Gruppe finden Sie im Microsoft Knowledge Base-Artikel 822931, „Entfernen des ersten Exchange Server 2003-Computers aus der administrativen Gruppe" (http://support.microsoft.com/default.aspx?scid=kb;de;822931).

Weitere Informationen zu Problemen mit Offlineadressbüchern finden Sie in den folgenden Ressourcen zu Exchange Server:

  • Offline Address Book - Things to Consider (http://go.microsoft.com/fwlink/?LinkId=57581)

  • How Outlook 2003 SP2 and Exchange Server 2003 SP2 OAB Version 4 Work Together (http://go.microsoft.com/fwlink/?linkid=53099)

  • OAB Version 4 in Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=53097)


Die Länge der Replikations-Empfangswarteschlange hat den Schwellenwert überschritten
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-02-13

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Replication Receive Queue Size-Leistungsindikator des MSExchangeIS Public-Leistungsobjekts.

Wenn Exchange Server Analyzer feststellt, dass der Leistungsindikator Replication Receive Queue Size den Spitzenwert von 100 während des Erfassungszeitraums überschritten hat, wird ein Fehler angezeigt.

Replikationsnachrichten für Öffentliche Ordner werden von SMTP empfangen, kategorisiert und an die lokale SMTP-Warteschlange übergeben. Die Nachrichten werden dann an den Informationsspeicher für Öffentliche Ordner übermittelt. Nach der Übermittlung an den Informationsspeicher für Öffentliche Ordner werden die Nachrichten in die Replikations-Empfangswarteschlange gestellt. Die in der Replikations-Empfangswarteschlange enthaltenen Nachrichten werden dann verarbeitet und die Änderungen an dem entsprechenden Öffentlichen Ordner vorgenommen. Der Leistungsindikator Replication Receive Queue Size gibt die Anzahl der Replikationsnachrichten für Öffentliche Ordner an, die auf ihre Verarbeitung warten.

Je länger die Replikationswarteschlange wird, desto stärker ist der Inhalt der Ordner nicht mehr synchron. Bei wachsenden Replikationswarteschlangen kommt es zu einem Anstieg der Ressourcenauslastung, wenn die Nachrichten in der Replikationswarteschlange verarbeitet werden. Außerdem zeigen wachsende Replikationswarteschlangen an, dass der Inhalt von Öffentlichen Ordnern auf dem Server veraltet ist.

In den beiden Fällen, wo das Anwachsen der Replikations-Empfangswarteschlange erwartungsgemäß ist und geplant werden kann, ist kein Eingreifen erforderlich:

  • Bei einem neu eingeführten Server für Öffentliche Ordner kann ein Anwachsen der Replikations-Empfangswarteschlange durch die erwartungsgemäße anfängliche Abgleichreplikation erfolgen.

  • Werden eine Standortkonsolidierung oder andere wesentliche Änderungen an der Exchange-Topologie vorgenommen, ist damit zu rechnen, dass es bei der Verschiebung des Inhalts zu einem hohen Replikationsaufkommen kommt.

Bei bereits vorhandenen, stabilen Servern, auf denen keine Replikate öffentlicher Ordner massenweise geändert werden, kann dieser Fehler auf Folgendes hinweisen:

  • Leistungsengpässe bei Serverressourcen wie Festplatten, Prozessoren, Netzwerk oder Arbeitsspeicher. Liegt auf dem Server tatsächlich ein Ressourcenengpass vor, wird der Store.exe-Prozess nicht in der Lage sein, die Replikationsnachrichten schnell genug zu verarbeiten, weshalb eine Warteschlange anwachsen wird.

  • Das Replikationsintervall für Öffentliche Ordner ist zu kurz, so dass die Replikation nicht abgeschlossen werden kann, bevor der nächste Replikationszyklus beginnt.

Um diesen Fehler zu beheben, führen Sie folgende Schritte aus:

  • Verlängern Sie das Replikationsintervall, und überwachen Sie die MSExchangeIS Public\Replication Receive Queue Size, bis sie anzeigt, dass die Replikation abgeschlossen wurde, bevor der nächste Replikationszyklus begonnen hat.

  • Verwenden Sie die Ressourcen der folgenden Links, um festzustellen, ob das Warteschlangenwachstum durch einen Leistungsengpass verursacht wird, und um diesen dann zu beseitigen.

  • Ziehen Sie eine Verringerung der Gesamtanzahl der Replikate in der Exchange-Organisation in Betracht, um das erforderliche Replikationsaufkommen zu verringern.

Weitere Informationen

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange Server finden Sie unter „Handling Special Exchange Roles and Performance" im Handbuch Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen zur Replikation von Öffentlichen Ordnern in Exchange Server finden Sie unter "Controlling Exchange Server 2003 Public Folder Replication" in Working with the Exchange Server 2003 Store (http://go.microsoft.com/fwlink/?LinkId=47595).

  • Weitere Informationen zu Best Practices für Öffentliche Ordner in Exchange finden Sie in Exchange Public Folder Best Practices: Implementing Replication (http://go.microsoft.com/fwlink/?LinkId=46440).

  • Weitere Informationen zu den Verbesserungen bei der Verwaltung Öffentlicher Ordner, die mit dem Exchange Server 2003 Service Pack 2 eingeführt wurden, finden Sie in den Versionsanmerkungen zu Microsoft Exchange Server2003 Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=52072).


Datei „RESVC.DLL" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere der obigen Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Beim Ausführen des Setup-Programms im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden weder Benutzer- noch Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


Registrierungsschlüssel „RestrictRemoteClients" ist aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die Schnittstelleneinschränkungen für Remote Procedure Call (RPC - Remoteprozeduraufruf) aktiviert sind:

HKEY_LOCAL_MACHINE\ Software\Policies\Microsoft\Windows NT\RPC

Wenn Exchange Server Analyzer feststellt, dass der Registrierungsschlüssel RestrictRemoteClients konfiguriert ist, zeigt das Tool eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

RPC-Schnittstelleneinschränkungen stellen eine Verbesserung der Netzwerksicherheit bereit, durch die Systeme weniger anfällig für Angriffe über das Netzwerk sind. Der Registrierungswert RestrictRemoteClients ändert das Verhalten aller RPC-Schnittstellen im System. In der Standardeinstellung verhindert der Registrierungswert RestrictRemoteClients den anonymen Remotezugriff auf RPC-Schnittstellen im System. Es gibt jedoch einige Ausnahmen.

Wenn eine Schnittstelle mithilfe von RpcServerRegisterIf registriert wird, lässt RPC zu, dass die Serveranwendung den Zugriff auf die Schnittstelle einschränkt; dies geschieht im Allgemeinen über ein Sicherheitscallback. Durch den Registrierungswert RestrictRemoteClients kann RPC weitere Sicherheitsprüfungen für alle Schnittstellen durchführen, auch wenn eine Schnittstelle nicht über ein registriertes Sicherheitscallback verfügt.

Hinweis:
Für RPC-Clients, die die benannte Pipe-Protokollreihenfolge verwenden, gelten die Einschränkungen nicht. Die Pipe-Protokollreihenfolge kann aufgrund von erheblichen Problemen bei der Abwärtskompatibilität nicht eingeschränkt werden.
Hinweis:
Sie können den Registrierungsschlüssel auch mit dem the RestrictRemoteClients Editor für Gruppenrichtlinienobjekte konfigurieren.

Der Registrierungsschlüssel RestrictRemoteClients wird mithilfe von DWORD-Werten konfiguriert. Wenn der Registrierungswert nicht vorhanden ist, entspricht der fehlende Wert dem Wert RPC_Restrict_Remote_Client_Default.

Die folgende Tabelle enthält Informationen zu dem Konfigurationseinstellungen für RestrictRemoteClients.

Registrierungsschlüsselwert (DWORD) Beschreibung

0 (Standard)

RPC_RESTRICT_REMOTE_CLIENT_NONE (0) stellt den Standardwert in Microsoft Windows Server™ 2003 Service Pack 1 dar. Durch die Einstellung des Standardwerts umgeht das System die RPC-Schnittstelleneinschränkung.

Die Einstellung für den Standardwert entspricht dem Wert RPC_RESTRICT_REMOTE_CLIENT_NONE. Die Serveranwendung ist dafür verantwortlich, die entsprechenden RPC-Einschränkungen durchzusetzen. Diese Standardeinstellung entspricht der Einstellung RestrictRemoteClients in früheren Windows-Versionen.

1

Der Wert 1 für den RestrictRemoteClients-Registrierungsschlüssel stellt den Standardwert in Windows® XP Service Pack 2 dar. Die Einstellung für den Wert 1 schränkt den Zugriff auf alle RPC-Schnittstellen ein. Alle anonymen Remoteaufrufe werden von der RPC-Laufzeit abgelehnt.

Diese Einstellung für den Wert entspricht dem Wert RPC_RESTRICT_REMOTE_CLIENT_DEFAULT. Wenn eine Schnittstelle ein Sicherheitscallback registriert und das Flag RPC_IF_ALLOW_CALLBACKS_WITH_NO_AUTH bereitstellt, wird die Einschränkung nicht auf diese Schnittstelle angewendet.

2

Der Wert 2 für den Registrierungsschlüssel RestrictRemoteClients gibt an, dass alle anonymen Remoteaufrufe ohne Ausnahmen von der RPC-Laufzeit abgelehnt werden.

Diese Einstellung für den Wert entspricht dem Wert RPC_RESTRICT_REMOTE_CLIENT_HIGH. Wenn der Wert RestrictRemoteClients mit 2 konfiguriert ist, kann ein System keine anonymen Remoteaufrufe über RPC empfangen.

Weitere Informationen zu Änderungen am RPC-Dienst in Windows XP Service Pack 2 finden Sie im MSDN®-Artikel „RPC Interface Restrictions" (http://go.microsoft.com/fwlink/?LinkId=47371).


RFR-Zielserver wurde manuell außer Kraft gesetzt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag auf dem Exchange-Server, um zu bestimmen, ob der Proxyverweisdienst für Verzeichnisdienste (DSProxy referral) manuell außer Kraft gesetzt wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\RFR Target Server

Wenn Exchange Server Analyzer erkennt, dass der Wert RFR Target Server vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Wenn ein Client unter Microsoft Outlook® 2000 Service Release 2 (SR-2) oder höher erstmalig eine Verbindung mit einem Exchange 2000 Server- oder Exchange Server 2003-Computer herstellt, wird auf dem Exchange-Stammserver eine Suche nach dem Verzeichnisdienst ausgeführt. Outlook verarbeitet für die erste Sitzung den DSProxy-Vorgang. Nach dem Herstellen der Verbindung mit dem DSProxy-Dienst durch den Client wird ein DSProxy-Verweis an den Client zurückgegeben. In dieser wird er informiert, dass alle künftigen Verzeichnisanforderungen an den globalen Katalogserver erfolgen sollen. Outlook legt die DSProxy-Verweisinformationen im MAPI-Profil in der Registrierung fest.

Der DSProxy-Verweismechanismus verringert die Last auf dem Exchange-Server und die Latenz für Suchvorgänge in Adressbüchern. Wenn ein expliziter Servername im Profil eingegeben wird, muss Outlook neu gestartet werden, wenn ein Fehler auf dem betreffenden globalen Katalogserver auftritt. Wenn eine solche Situation eintritt, sendet der Exchange-Server einen neuen Verweis an Outlook.

Gelegentlich empfiehlt es sich, den Eintrag RFR Target Server mit vordefiniertem Code zu versehen, um die Server anzugeben, die für den MAPI-Clientverweisdienst verwendet werden sollen. Beispielsweise sollten Sie eine Woche vor dem Herabstufen eines globalen Katalogservers zu einem Mitgliedsserver den Eintrag RFR Target Server so mit vordefiniertem Code versehen, dass eine definierte Gruppe von globalen Katalogservern festgelegt ist. Dadurch wird sichergestellt, dass in den MAPI-Dateien auf den Outlook-Clients nicht mehr auf den zurückgestuften globalen Katalogserver verwiesen wird. Weitere Informationen zu dieser Verwendung des Registrierungeintrags RFR Target Server finden Sie im Microsoft Knowledge Base-Artikel 305065 „XADM: Exchange Server-Related Considerations for Demoting a Global Catalog Server to a Domain Controller" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=305065.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So verwenden Sie den Registrierungswert „RFR Target Server"

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Erstellen Sie einen neuen REG_MULTISZ-Wert mit der Bezeichnung RFR Target Server.

  4. Konfigurieren Sie den Wert RFR Target Server mit dem vollqualifizierten Domänennamen für den bzw. die gewünschten Server.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Dienst Microsoft Exchange-Systemaufsicht neu, damit die Änderung wirksam wird.

Um eine statische Einstellung für den RFR-Server zu deaktivieren, entfernen Sie den Eintrag mit dem vollqualifizierten Domänenamen für den zu entfernenden Server. Wenn nur ein RFR-Zielserver eingegeben ist, löschen Sie den Registrierungswert RFR Target Server.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Interaktion von Outlook 2000 SR-2-Clients und Clients unter höheren Versionen mit dem Active Directory®-Verzeichnisdienst finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 302914, „XCCC: How Outlook 2000 Accesses Active Directory" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914

  • 256976, „XCLN: How MAPI Clients Access Active Directory" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976


RegTrace ist derzeit aktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Best Practices Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob auf dem Exchange Server-Computer die erweiterte Diagnoseablaufverfolgung aktiviert ist:

HKEY_LOCAL_MACHINE\Software\Microsoft\MosTrace\CurrentVersion\DebugAsyncTrace\EnabledTraces

Wenn Microsoft Exchange Server Best Practices Analyzer feststellt, dass der Registrierungseintrag EnabledTraces vorhanden und mit einem anderen Wert als 0 konfiguriert ist, wird ein Fehler angezeigt.

Die erweiterte Diagnoseablaufverfolgung von Transport- und Routingkomponenten von Exchange Server kann über das Dienstprogramm Regtrace (Regtrace.exe) ausgeführt werden. Regtrace ist insbesondere bei der Diagnose und Fehlerbehebung im Fall von Unzustellbarkeitsberichten hilfreich. Das Dienstprogramm Regtrace finden Sie auf der Exchange Server-CD im Ordner \Support\Utils\I386.

Die Ablaufverfolgungsdatei ist in dem Verzeichnis verfügbar, das auf der Registerkarte Outputdes Dienstprogramms Regtrace angegeben ist. Der Standardspeicherort für die Datei ist C:\Trace.atf. Die Ablaufverfolgungsdatei ist eine binär codierte Datei, die auf Debug-Ebene Informationen zu den nachverfolgten Transport- und Routingkomponenten enthält. Aus diesem Grunde fordert der technische Support von Microsoft, dass die Kunden zur internen Analyse die Ablaufverfolgungsdateien einsenden.

Sofern Sie nicht mit einer Fehlerbehandlung befasst sind, rät Microsoft von der Aktivierung von Regtrace ab, da dadurch die Serverleistung stark beeinträchtigt wird. Zudem sollte das Tool nur über einen kurzen Zeitraum und unter Anleitung des technischen Kundendiensts von Microsoft verwendet werden. Neben der Beeinträchtigung der Leistung kann die Ablaufverfolgungsdatei pro Minute einen Speicherplatz von bis zu 10 MB oder mehr belegen. Wenn Sie nicht gerade mit der Fehlerbehebung beschäftigt sind, können Sie dieses Problem beheben, indem Sie die Ablaufverfolgung über Regtrace deaktivieren.

So deaktivieren Sie die erweiterte Diagnoseablaufverfolgung mit Regtrace

  1. Kopieren Sie Regtrace.exe von der Exchange Server-CD auf den Exchange Server-Computer.

  2. Führen Sie Regtrace.exe auf dem Exchange Server-Computer aus. Die Benutzeroberfläche von Regtrace wird angezeigt.

  3. Deaktivieren Sie auf der Registerkarte Traces sämtliche Kontrollkästchen.

  4. Wählen Sie die Registerkarte Output aus, und aktivieren Sie dann die Option No Tracing.

  5. Klicken Sie auf OK, um die Änderungen zu speichern und das Dienstprogramm Regtrace zu schließen.
  • Weitere Informationen zum Tool Regtrace finden Sie im Microsoft Knowledge Base-Artikel 238614, „XCON: How to Set Up Regtrace for Exchange 2000" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=238614.

  • Weitere Informationen zur allgemeinen Fehlerbehebung für Nachrichten finden Sie im Knowledge Base-Artikel 281800, „XCON: Troubleshooting Message Failures in Exchange 2000" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=281800.


Rejection threshold not configured
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-07-30

Das Tool Microsoft Exchange Analyzer sendet eine Abfrage an den Active Directory-Verzeichnisdienst, um den Wert der folgenden Attribute für alle Objekte der Klasse ContentFilterConfig abzufragen:

msExchAgentsFlags Der Wert des Attributs msExchAgentsFlag gibt den Status des Inhaltsfilter-Agents von Microsoft Exchange Server 2007 sowie die SCL-Zurückweisungsaktion (Spam Confidence Level) an. Wenn der Inhaltsfilter-Agent auf einem Computer aktiviert ist, filtert er alle Nachrichten, die über alle Empfangsconnectors auf diesem Computer eingehen. Wenn die SCL-Zurückweisungsaktion aktiviert ist, sendet sie während der SMTP-Transaktion eine Zurückweisungsantwort für alle Nachrichten, die den SCL-Zurückweisungsschwellenwert überschreiten.

msExchMessageHygieneSCLRejectThreshold Der Wert des Attributs msExchMessageHygieneSCLRejectThreshold gibt die Stufe an, die für die SCL-Zurückweisungsaktion festgelegt ist. Dieser Wert stellt die SCL-Bewertung dar, die eine bestimmte Nachricht überschreiten muss, damit der Inhaltsfilter-Agent die Nachricht zurückweist und einen Unzustellbarkeitsbericht an den Absender übermittelt.

Exchange Analyzer führt außerdem das folgenden Cmdlet der Exchange-Verwaltungsshell aus, um alle Serverfunktionen Hub-Transport abzufragen, für die die Antispam-Agents installiert sind:

Get-TransportServer | where { $_.AntispamAgentsEnabled -eq $True}

Wenn Exchange Analyzer feststellt, dass die folgenden Bedingungen für einen Server ausnahmslos erfüllt sind, zeigt das Tool eine Warnung an:

  • Inhaltsfilterung ist aktiviert.

  • Die SCL-Zurückweisungsaktion ist aktiviert.

  • Der SCL-Zurückweisungsschwellenwert ist auf den Wert 9 festgelegt.

  • Auf dem Server sind die Antispam-Agents aktiviert.

Diese Warnung zeigt an, dass der Schwellenwert für die SCL-Zurückweisungsaktion auf den Standardwert 9 festgelegt wurde, obwohl Inhaltsfilterung und die SCL-Zurückweisungsaktion aktiviert sind. Dies kann zu einer Zurückweisung von Nachrichten führen, die von legitimen Benutzern stammen. Die empfohlene Einstellung für den Schwellenwert für die SCL-Zurückweisungsaktion ist 7.

Um diese Warnung zu beheben, legen Sie mithilfe der Registerkarte Antispam in der Exchange-Verwaltungskonsole oder mit dem Cmdlet Set-ContentFilterConfig in der Exchange-Verwaltungsshell den Schwellenwert für die SCL-Zurückweisungsaktion auf 7 fest.

Um den Schwellenwert für die SCL-Zurückweisungsaktion zu konfigurieren, befolgen Sie die Anweisungen im Thema "Aktivieren und Konfigurieren der SCL-Schwellenwerte" (http://go.microsoft.com/fwlink/?LinkId=96099) in der Exchange Server 2007-Produktdokumentation.

Weitere Informationen

Weitere Informationen zum Verwalten der Antispam- und Antivirenfeatures von Exchange Server 2007 finden Sie unter "Verwalten der Antispam- und Antivirenfeatures" (http://go.microsoft.com/fwlink/?LinkId=96103) in der Exchange Server 2007-Produktdokumentation.


Empfängeraktualisierungsdienst wurde gelöscht.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-04-20

Microsoft®Microsoft Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchAddressListServiceLink für jedes Empfängeraktualisierungsdienst-Objekt im Verzeichnis zu bestimmen. Das Attribut msExchAddressListServiceLink stellt eine Verknüpfung zwischen dem Adressenlistendienst und dem Exchange Server-Computer dar, auf dem es ausgeführt werden soll. Wenn Exchange Server Analyzer feststellt, dass der Wert für das Attribut msExchAddressListServiceLink auf „DEL:" festgelegt ist, wird ein Fehler angezeigt.

Jede Instanz des Empfängeraktualisierungsdienstes ist einem Exchange Server-Computer zugeordnet, auf dem der Empfängeraktualisierungsdienst ausgeführt wird. Wenn Sie diese Meldung erhalten, wird die Empfängeraktualisierungsdienst-Instanz einem Exchange Server-Computer zugeordnet, der in der Exchange-Organisation nicht vorhanden ist. Der Server wurde möglicherweise außer Funktion gesetzt oder anderweitig aus der Topologie entfernt.

Um die Empfängeraktualisierungsdienst-Instanz ausführen zu können, muss sie einem anderen vorhandenen Exchange-Server zugeordnet werden.

So berichtigen Sie diesen Fehler

  1. Öffnen Sie den Exchange-System-Manager.

  2. Klicken Sie unter Empfänger auf Empfängeraktualisierungsdienste. Klicken Sie im rechten Bereich mit der rechten Maustaste auf die entsprechende Instanz des Empfängeraktualisierungsdienstes, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Allgemein unter Exchange-Server auf Durchsuchen, und geben Sie einen neuen Server an, auf dem die Instanz ausgeführt werden soll.

  4. Klicken Sie auf OK. Klicken Sie anschließend erneut auf OK, damit die Änderung wirksam wird.

  5. Schließen Sie den Exchange-System-Manager.

Weitere Informationen zum Empfängeraktualisierungsdienst finden Sie in den folgenden Exchange-Themen und Microsoft Knowledge Base-Artikeln:

  • „Verwalten von Empfängern und Empfängerrichtlinien" im Technischen Referenzhandbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47617)

  • 328738, „XADM: How the Recipient Update Service Applies Recipient Policies" (http://support.microsoft.com/kb/328738/en-us)

  • 253828, „How the Recipient Update Service Populates Address Lists" (http://support.microsoft.com/kb/253828/en-us)

  • 246127, „XADM: How to Check the Progress of the Recipient Update Service" unter http://support.microsoft.com/kb/246127/en-us).

  • 253770, „XADM: Tasks Performed by the Recipient Update Service" (http://support.microsoft.com/kb/253770/en-us)


Die RPC-Bindung enthält keinen FQDN
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob der Wert ncacn_ip_tcp für das Attribut networkAddress einen vollqualifizierten Domänennamen enthält. Wenn Exchange Server Analyzer feststellt, dass der Wert ncacn_ip_tcp keinen Punkt (.) enthält, zeigt Exchange Server Analyzer einen Fehler an.

In Microsoft Office Outlook® Web Access für Exchange Server 2003 untersucht der Front-End-Server beim Versuch, eine Verbindung mit einem Exchange-Back-End-Server herzustellen, den Attributwert networkaddress.

Hinweis:
In Outlook Web Access für Exchange 2000 Server erfolgt dies nicht. Für den Front-End-Server ist ein Wert für den vollqualifizierten Domänennamen erforderlich.

Der Front-End-Server überprüft den Wert, der für networkaddress ncacn_ip_tcp zurückgegeben wurde, auf einen Punkt. Die Verbindungsanforderung für das Postfach des bestimmten Back-End-Server kann nicht ausgeführt werden, und der Front-End-Server gibt eine „HTTP 500 Internal Server Error"-Fehlermeldung an den Benutzer zurück, wenn die folgenden Bedingungen erfüllt sind:

  • Der Wert ncacn_ip_tcp stellt lediglich einen Hostnamen oder einen NetBIOS-Namen (Network Basic Input/Output System) dar.

  • Der Wert ncacn_ip_tcp ist kein vollqualifizierter Domänenname.

Sie müssen den Wert ncacn_ip_tcp für das Serverobjekt in Active Directory aktualisieren, um sicherzustellen, dass Outlook Web Access für Exchange Server 2003 ordnungsgemäß funktioniert. Microsoft Exchange Server Analyzer gibt den Namen des betroffenen Servers aus.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
Hinweis:
Bevor Sie den Wert ncacn_ip_tcp aktualisieren, lesen Sie den Rest dieses Artikels. Möglicherweise muss vor dem Neustart der Exchange Server-Dienste eine zusätzliche Prozedur durchgeführt werden.
So aktualisieren Sie den Wert ncacn_ip_tcp für das Attribut networkAddress

  1. Starten Sie das ADSI-Bearbeitungs-Snap-In in den Supporttools von Windows 2000 Server oder Windows Server 2003.

  2. Erweitern Sie die folgenden Knoten:

    • Container Konfiguration

    • Konfiguration

    • Dienste

    • Microsoft Exchange

    • Organisationsname

    • Administrative Gruppen

    • Name der administrativen Gruppe

    • Server

  3. Klicken Sie mit der rechten Maustaste auf Name des Exchange-Servers, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie in der Liste Attribute auf networkaddress, und klicken Sie dann auf Bearbeiten.

  5. Fügen Sie einen neuen Wert für ncacn_ip_tcp hinzu. Verwenden Sie den vollqualifizierten Domänennamen des Servers anstelle des NetBIOS-Namen oder des Hostnamen des Servers.

    Verwenden Sie für den Wert die folgende Syntax: ncacn_ip_tcp:[vollqualifizierter Domännename]. Wenn Ihr Exchange-Back-End-Server beispielsweise den Hostnamen EXCHANGE1 und den vollqualifizierten Domänennamen EXCHANGE1.contoso.com aufweist, verwenden Sie den folgenden Wert für ncacn_ip_tcp: ncacn_ip_tcp:EXCHANGE1.contoso.com.

  6. Entfernen Sie den ursprünglichen Wert für ncacn_ip_tcp, der den NetBIOS-Namen oder den Hostnamen des Back-End-Servers enthält, indem Sie den ursprünglichen Wert markieren und auf Entfernen klicken. Klicken Sie zweimal auf OK, um die Änderung zu übernehmen.

  7. Starten Sie alle Exchange Server-Dienste auf dem Server neu.

  8. Wenn mehrere Domänencontroller vorhanden sind, warten Sie auf die Ausführung der Replikation, bevor Sie sich vom Front-End-Server aus anmelden. Wenn das Problem nach dem Abschluss der Replikation weiterhin besteht, starten Sie den IIS Admin-Dienst auf dem Front-End-Server neu.

Wenn Sie Hostdateien auf Back-End-Servern verwalten, um eine Server-IP-Adresse mit einem kurzen Hostnamen zu korrelieren, müssen Sie auch den Registrierungswert UpdateProtocols aktualisieren. Wenn eine Hostdatei verwendet wird, setzt Exchange Server möglicherweise bei einem Neustart der Microsoft-Systemaufsicht den Wert für ncacn_ip_tcp zurück. Wenn sich der Back-End-Server in einem Cluster befindet, setzt Exchange Server möglicherweise nach der Durchführung eines Failovers den Wert für ncacn_ip_tcp zurück.

Um die Ausfallzeit bei einem Neustart der Exchange Server-Dienste so gering wie möglich zu halten, sollten Sie vor dem Neustart der Exchange Server-Dienste das folgende Verfahren ausführen, indem Sie den Wert ncacn_ip_tcp für das Attribut networkaddress wie nachfolgend beschrieben aktualisieren.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So ändern Sie den Registrierungswert UpdateProtocols für Back-End-Server, die Hostdateien verwenden

  1. Verwenden Sie einen Registrierungs-Editor zum Konfigurieren des folgenden Registrierungswertes für den bzw. die Back-End-Server: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\UpdateProtocols

    Hinweis:
    Wenn der Wert UpdateProtocols nicht vorhanden ist, muss dieser erstellt werden. Führen Sie hierzu die folgenden Schritte aus:
    1. Öffnen Sie einen Registrierungs-Editor, und suchen Sie den folgenden Registrierungsunterschlüssel: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\

    2. Klicken Sie mit der rechten Maustaste auf Parameter, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

    3. Geben Sie UpdateProtocols ein, und drücken Sie dann die EINGABETASTE.

  2. Klicken Sie mit der rechten Maustaste auf UpdateProtocols, klicken Sie auf Ändern, geben Sie im Feld Daten den Wert 0 ein, und klicken Sie dann auf OK.

  3. Wenn im Netzwerk eine Hosts-Datei für den Back-End-Clusterknoten verwendet wird, ändern Sie die Reihenfolge der Einträge UpdateProtocols folgendermaßen:

    IPAddress to FQDN

    IPAddress to NetBIOS

    anstelle von:

    IPAddress to NetBIOS

    IPAddress to FQDN

  4. Starten Sie alle Exchange Server-Dienste auf dem Server neu.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Die RPC-Bindung stimmt nicht mit dem aufgelösten DNS-Namen überein.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-03-21

Microsoft® Exchange Server Analyzer versucht eine DNS-Abfrage (Domain Name System) bei den konfigurierten DNS-Servern für jeden Exchange Server-Computer. Diese Verbindung wird mithilfe eines benutzerdefinierten Objektprozessors hergestellt, der eine Namensauflösung anfordert und die Ergebnisse analysiert. Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob der Serverwert ncacn_ip_tcp für das Attribut networkAddress und der vollqualifizierte Domänenname, der nach der DNS-Auflösung zurückgegeben wurde, verschieden sind. Das Attribut networkAddress ist ein Attribut für jedes Exchange Server-Objekt in Active Directory. Wenn Exchange Server Analyzer feststellt, dass der Serverwert ncacn_ip_tcp in Active Directory nicht mit dem vollqualifizierten Domänennamen nach der DNS-Auflösung übereinstimmt, wird eine Warnung angezeigt.

Dies ist der Fall, wenn der vollqualifizierte Domänenname des Servers nach der Installation von Exchange geändert wurde. Für eine ordnungsgemäße Funktionsweise von Exchange Server und Active Directory ist ein ordnungsgemäß konfiguriertes und fehlerfreies DNS erforderlich. Registrierungs- und Auflösungsprobleme von Domänennamensdiensten können die Funktionen eines Exchange Server-Computers zum Senden, Empfangen und Übermitteln von Nachrichten wesentlich beeinträchtigen. Diese Probleme können Sie vermeiden, wenn Sie die zwei Adressen durch manuelles Bearbeiten des Attributs networkAddress für das Exchange Server-Objekt in Active Directory in Übereinstimmung bringen.

Sie müssen den Wert ncacn_ip_tcp für das Serverobjekt in Active Directory aktualisieren, damit der Wert ncacn_ip_tcp mit dem vollqualifizierten DNS-Domänennamen des Servers übereinstimmt. Microsoft Exchange Server Analyzer gibt den Namen des betroffenen Servers aus.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, von Exchange Server 2003 bzw. Exchange Server 2007 oder beider Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So aktualisieren Sie den Wert ncacn_ip_tcp für das Attribut networkAddress

  1. Starten Sie das ADSI-Bearbeitungs-Snap-In in den Supporttools von Windows® 2000 oder Windows Server 2003.

  2. Erweitern Sie die folgenden Knoten:

    • Container Konfiguration

    • Konfiguration

    • Dienste

    • Microsoft Exchange

    • Organisationsname

    • Administrative Gruppen

    • Name der administrativen Gruppe

    • Server

  3. Klicken Sie mit der rechten Maustaste auf Name des Exchange-Servers, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie in der Liste Attribute auf Netzwerkadresse, und klicken Sie dann auf Bearbeiten.

  5. Fügen Sie einen neuen Wert für ncacn_ip_tcp hinzu. Verwenden Sie den vollqualifizierten Domänennamen des Servers anstelle des aktuellen Werts.

    Verwenden Sie für den Wert die folgende Syntax: ncacn_ip_tcp:[vollqualifizierter Domännename]. Wenn der Exchange-Server beispielsweise den Hostnamen EXCHANGE1 und den vollqualifizierten Domänennamen EXCHANGE1.contoso.com aufweist, verwenden Sie den folgenden Wert für ncacn_ip_tcp: ncacn_ip_tcp:EXCHANGE1.contoso.com.

  6. Entfernen Sie den ursprünglichen Wert für ncacn_ip_tcp, der den falschen Namen des Servers enthält, indem Sie den ursprünglichen Wert markieren und auf Entfernen klicken. Klicken Sie zweimal auf OK, um die Änderung zu übernehmen.

  7. Starten Sie alle Exchange Server-Dienste auf dem Server neu.

Weitere Informationen zur Verwendung von DNS mit Active Directory finden Sie im Microsoft Knowledge Base-Artikel 323418, „How To Integrate DNS with an Existing DNS Infrastructure If Active Directory Is Enabled in Windows Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=323418.


Die RPC-Bindungsreihenfolge ist nicht korrekt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die RPC-Bindungsreihenfolge (Remote Procedure Call, Remoteprozeduraufruf) zu ermitteln, die vom Exchange Server-Computer verwendet wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Svr_Binding_Order

Wenn Exchange Server Analyzer ermittelt, dass der Wert für Rpc_Svr_Binding_Order nicht mit ncacn_ip_tcp beginnt, wird ein Fehler angezeigt.

Der Registrierungseintrag Rpc_Svr_Binding_Order wird beim Installieren von Exchange Server auf einem Computer erstellt. Dieser Eintrag bestimmt die Protokollreihenfolge, die für die RPC-Kommunikation von Server zu Server verwendet wird.

In der Standardeinstellung enthält der Eintrag Rpc_Svr_Binding_Order die folgenden Wertdaten:

ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp

Hinweis:
Wenn auf dem Exchange Server-Computer noch weitere Protokolle installiert sind, können in der Zeichenfolge zusätzliche Werte enthalten sein.

Dieser Eintrag gibt die Reihenfolge an, in der Exchange Server Netzwerkkommunikationsprotokolle zur RPC-Kommunikation mit anderen Servern ausprobiert. Besipiel: wenn TCP/IP als Erstes angegeben ist, versucht Exchange zuerst, mit anderen Servern unter Verwendung von RPC über TCP/IP zu kommunizieren, bevor er versucht, dies mit RPC über anderen Protokollen durchzuführen.

Es wird empfohlen, den Standardwert für die RPC-Bindungsreihenfolge nicht zu ändern. Wenn der Standardwert verändert wird, können Probleme beim Start des Servers oder des Dienstes oder bei der Kommunikation zwischen Servern auftreten.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So berichtigen Sie diesen Fehler

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\Software\Microsoft\Exchange\Exchange Provider

  3. Doppelklicken Sie im rechten Teilfenster auf Rpc_Svr_Binding_Order.

  4. Geben Sie im Dialogfeld Wert die Zeichenfolge cacn_ip_tcp,ncacn_spx,ncacn_vns_spp ein.

  5. Klicken Sie auf OK, und schließen Sie dann den Registrierungs-Editor.

  6. Starten Sie alle Exchange Server-Dienste oder den Exchange Server-Computer neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://support.microsoft.com/?scid=kb%3Bde%3B256986&x=2&y=12, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur RPC-Bindungsreihenfolge finden Sie im Knowledge Base-Artikel 325930 „Behandlung von Verbindungsproblemen durch Registrierungseinträge für RPC-Clientprotokolle" unter http://support.microsoft.com/kb/325930/de.


Der Registrierungseintrag „Rpc_Binding_Order" ist vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die RPC-Bindungsreihenfolge (Remote Procedure Call, Remoteprozeduraufruf) zu bestimmen, die vom Exchange Server-Computer verwendet wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Binding_Order

Wenn Exchange Server Analyzer feststellt, dass Rpc_Binding_Order vorhanden ist, wird eine Warnung angezeigt.

Wenn der Wert Rpc_Binding_Order vorhanden ist, bedeutet dies, dass mindestens einer der folgenden Dienste auf dem Computer installiert ist:

  • Exchange Server, Version 5.5

  • Microsoft Office Outlook® 2003

  • Windows Clustering

  • Der Eintrag RPC_Binding_Order bestimmt die Protokollreihenfolge, die beim Initiieren der Outlook-RPC-Kommunikation verwendet wird. In Exchange Server 2003 oder Exchange 2000 Server wird dieser Eintrag nicht erstellt. Dieser Eintrag wird nur in Exchange Server 5.5 und in früheren Versionen von Exchange erstellt. Wenn Exchange Server 5.5 oder Microsoft Outlook zuvor auf diesem Computer installiert war und entfernt wurde, können Sie diesen Registrierungseintrag manuell entfernen. Außerdem sollten Sie Outlook von jedem Computer entfernen, der Exchange Server ausführt, da diese Konfiguration nicht unterstützt wird. Weitere Informationen zum Ausführen von Exchange und Outlook auf demselben Computer finden Sie im Microsoft Knowledge Base-Artikel 266418 „Microsoft does not recommend installing Exchange Server and Outlook on the same computer" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=266418.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So entfernen Sie den Registrierungseintrag „Rpc_Binding_Order"

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\Software\Microsoft\Exchange\Exchange Provider

  3. Löschen Sie den Wert Rpc_Binding_Order.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie alle Exchange Server-Dienste oder den Exchange Server-Computer neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Registrierungseintrag RPC_Binding_Order finden Sie in den folgenden Knowledge Base-Artikeln:

  • 325930, „Behandlung von Verbindungsproblemen durch Registrierungseinträge für RPC-Clientprotokolle" unter http://support.microsoft.com/?kbid=325930

  • 326036, „XADM: Cannot Log On to Exchange 2000 Server Computer by Using the Correct Credentials" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=326036


Der Registrierungswert „Rpc_Svr_Binding_Order" wurde von seinem Standardwert in einen anderen Wert geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die RPC-Bindungsreihenfolge (Remote Procedure Call, Remoteprozeduraufruf) zu ermitteln, die vom Exchange Server-Computer verwendet wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Svr_Binding_Order

Wenn Exchange Server Analyzer feststellt, dass der Wert für Rpc_Svr_Binding_Order nicht auf ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp festgelegt ist, wird eine Warnung angezeigt.

Der Registrierungseintrag Rpc_Svr_Binding_Order wird beim Installieren von Exchange Server auf einem Computer erstellt. Dieser Eintrag bestimmt die Protokollreihenfolge, die für die RPC-Kommunikation von Server zu Server verwendet wird.

In der Standardeinstellung enthält der Eintrag Rpc_Svr_Binding_Order die folgenden Wertdaten:

ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp

Hinweis:
Wenn auf dem Exchange Server-Computer noch weitere Protokolle installiert sind, können in der oben stehenden Zeichenfolge zusätzliche Werte enthalten sein.

Dieser Eintrag gibt die Reihenfolge an, in der Exchange Server Netzwerkkommunikationsprotokolle zur RPC-Kommunikation mit anderen Servern ausprobiert. Beispiel: Wenn TCP/IP als erstes Protokoll angegeben ist, versucht Exchange Server zuerst, mit anderen Servern unter Verwendung von RPC über TCP/IP zu kommunizieren, bevor das Programm versucht, mit RPC über andere Protokollen zu kommunizieren.

Microsoft empfiehlt, die in der Standardeinstellung angegebene RPC-Bindungsreihenfolge nicht zu ändern. Wenn der Standardwert verändert wird, können Probleme beim Start des Servers oder des Dienstes oder bei der Kommunikation zwischen Servern auftreten.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diesen Fehler

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\Software\Microsoft\Exchange\Exchange Provider

  3. Doppelklicken Sie im rechten Teilfenster auf Rpc_Svr_Binding_Order.

  4. Geben Sie im Dialogfeld Wert die Zeichenfolge cacn_ip_tcp,ncacn_spx,ncacn_vns_spp ein.

  5. Klicken Sie auf OK, und schließen Sie dann den Registrierungs-Editor.

  6. Starten Sie alle Exchange Server-Dienste oder den Exchange Server-Computer neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur RPC-Bindungsreihenfolge finden Sie im Knowledge Base-Artikel 325930 „Behandlung von Verbindungsproblemen durch Registrierungseinträge für RPC-Clientprotokolle" unter http://support.microsoft.com/kb/325930/de.


Round-Trip-Zeiten zum Active Directory-Server sind länger als 100 ms
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-03-16

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) WIN32_PingStatus im Namespace root\\cimv2 ab, um den Wert für den Schlüssel ResponseTime zu bestimmen. Wenn Exchange Server Analyzer ermittelt, dass der Wert für den Schlüssel ResponseTime mehr als 100 ms (Millisekunden) beträgt, wird eine Fehlermeldung angezeigt.

Der Schlüssel ResponseTime stellt die Zeit (in Millisekunden) für die Antwort auf die ICMP-Echoanforderung (ping; ICMP - Internet Control Message Protocol) dar. Von einem Exchange Server-Computer verwendete Domänencontroller sollten immer über eine Antwortzeit von höchstens 10 ms verfügen. Wenn die Antwortzeit 100 ms überschreitet, kann es zu Leistungs- oder Verbindungsproblemen kommen.

So beheben Sie diesen Fehler

  1. Stellen Sie sicher, dass der entsprechende Domänencontroller nicht überlastet ist. Testen Sie den Domänencontroller mit dem Tool ADTest.Exe, um zu ermitteln, ob die Hardware die erwartete Belastung verarbeiten kann.

  2. Überprüfen Sie die Ereignisprotokolle des Exchange-Servers und des Domänencontrollers, um festzustellen, ob netzwerkbezogene Ereignisse protokolliert wurden, die auf ein oder mehrere Probleme hinweisen.

  3. Wenden Sie die Befehle DCDiag.exe und NetDiag.exe auf den Domänencontroller an, um zu überprüfen, ob er richtig konfiguriert und in gutem Zustand ist.

  4. Überprüfen Sie abschließend das Standortdesign des Active Directory®-Verzeichnisdiensts. Ein Active Directory-Standort ist ein Netzwerkbereich, der über hohe Bandbreite und geringe Wartezeit verfügt. Wenn das Netzwerk nicht entsprechend dieser Spezifikation konfiguriert ist, sollten Sie es möglicherweise in mehr Active Directory-Standorte partitionieren.
Hinweis:
Wenn die WMI-Abfrage für den Ping-Test von Analyzer ausgeführt wird, werden die Standardwerte für Paketgröße und Timeout außer Kraft gesetzt. Stattdessen verwendet Analyzer eine ICMP-Paketgröße von 4096 (statt dem Standard von 32 Byte) und einen Timeoutwert von 2000 ms (statt dem Standard von 1000 ms).

Führen Sie die folgenden Schritte aus, um das Ping-Verhalten von Analyzer manuell zu emulieren.

So führen Sie den Ping-Test manuell aus

  • Führen Sie den folgenden Befehl im Befehlszeilenfenster des Computers mit Exchange Server aus: ping -L 4096 -N 6 <Active Server server name>Hinweis Der Befehl initiiert sechs Ping-Anforderungen mit jeweils 4096 Bytes.

Weitere Informationen zum Tool ADTest.exe finden Sie auf der Website „Active Directory Performance Testing Tool (ADTest.exe)" (http://go.microsoft.com/fwlink/?LinkId=33758).

Weitere Informationen zur WMI-Klasse Win32_PingStatus finden Sie im MSDN®-Artikel „Win32_PingStatus" (http://go.microsoft.com/fwlink/?linkid=33549).

Weitere Informationen zum Active Directory-Standortdesign finden Sie auf der Website „Designing the Site Topology" (http://go.microsoft.com/fwlink/?LinkId=33551).


Round-Trip-Zeiten zum Active Directory-Server sind länger als 10 ms.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-03-16

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) WIN32_PingStatus im Namespace root\\cimv2 ab, um den Wert für den Schlüssel ResponseTime zu bestimmen. Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel ResponseTime größer ist als 10 Millisekunden (ms), jedoch kleiner als 100 ms, wird eine Warnung angezeigt.

Der Schlüssel ResponseTime stellt die Zeit (in Millisekunden) für die Antwort auf die ICMP-Echoanforderungspakete (ping) dar, die vom Exchange-Server zum Domänencontroller gesendet wurden. Von einem Exchange Server-Computer verwendete Domänencontroller sollten immer über eine Antwortzeit von höchstens 10 ms verfügen. Wenn die Antwortzeit 10 ms überschreitet, kann es zu Leistungs- oder Verbindungsproblemen kommen.

So beheben Sie diese Warnmeldung

  1. Stellen Sie sicher, dass der entsprechende Domänencontroller nicht überlastet ist. Testen Sie den Domänencontroller mit dem Tool ADTest.Exe, um zu ermitteln, ob die Hardware die erwartete Belastung verarbeiten kann.

  2. Überprüfen Sie die Ereignisprotokolle des Exchange-Servers und des Domänencontrollers, um festzustellen, ob netzwerkbezogene Ereignisse protokolliert wurden, die auf ein oder mehrere Probleme hinweisen.

  3. Wenden Sie die Befehle DCDiag.exe und NetDiag.exe auf den Domänencontroller an, um zu überprüfen, ob er richtig konfiguriert und in gutem Zustand ist.

  4. Überprüfen Sie abschließend das Standortdesign des Active Directory®-Verzeichnisdiensts. Eine Active Directory-Site ist ein Netzwerkbereich, der eine hohe Bandbreite und geringe Wartezeiten aufweist. Wenn das Netzwerk nicht entsprechend dieser Spezifikation konfiguriert ist, sollten Sie es möglicherweise in mehrere Active Directory-Standorte aufteilen.
Hinweis:
Wenn die WMI-Abfrage für den Ping-Test von Analyzer ausgeführt wird, werden die Standardwerte für Paketgröße und Timeout außer Kraft gesetzt. Stattdessen verwendet Analyzer eine ICMP-Paketgröße von 4096 (statt dem Standard von 32 Bytes) und einen Timeoutwert von 2000 ms (statt dem Standard von 1000 ms).

Führen Sie die folgenden Schritte aus, um das Ping-Verhalten von Analyzer manuell zu emulieren.

So führen Sie den Ping-Test manuell aus

  • Führen Sie den folgenden Befehl im Befehlszeilenfenster des Computers mit Exchange Server aus: ping -L 4096 -N 6 <Active Server server name>Hinweis Der Befehl initiiert sechs Ping-Anforderungen mit jeweils 4096 Bytes.

Weitere Informationen zum Tool ADTest.exe finden Sie auf der Website „Active Directory Performance Testing Tool (ADTest.exe)" (http://go.microsoft.com/fwlink/?LinkId=33758).

Weitere Informationen zur WMI-Klasse Win32_PingStatus finden Sie im MSDN®-Artikel „Win32_PingStatus" (http://go.microsoft.com/fwlink/?linkid=33549).

Weitere Informationen zum Active Directory-Standortdesign finden Sie auf der Website „Designing the Site Topology" (http://go.microsoft.com/fwlink/?LinkId=33551).


Roundtrip-Zeiten zum globalen Katalogserver sind länger als 100 ms
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-03-16

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) WIN32_PingStatus im Namespace root\\cimv2 ab, um den Wert für den Schlüssel ResponseTime zu bestimmen. Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel ResponseTime mehr als 100 Millisekunden (ms) beträgt, wird ein Fehler angezeigt.

Der Schlüssel ResponseTime stellt die Zeit (in Millisekunden) für die Antwort auf die ICMP-Echoanforderungspakete (Ping) dar, die vom Exchange-Server zum globalen Katalogserver gesendet wurden. Von einem Exchange-Server-Computer verwendete globale Katalogserver sollten immer über eine Antwortzeit von kleiner oder gleich 10 ms verfügen. Wenn die Antwortzeit länger als 10 ms ist, kann es zu Leistungs- oder Verbindungsproblemen kommen.

So beheben Sie diesen Fehler

  1. Stellen Sie sicher, dass der entsprechende globale Katalogserver nicht überlastet ist. Testen Sie den globalen Katalogserver mit dem Tool ADTest.exe, um zu ermitteln, ob die Hardware die erwartete Belastung verarbeiten kann.

  2. Untersuchen Sie die Ereignisprotokolle des Exchange-Servers und des globalen Katalogservers, um festzustellen, ob netzwerkbezogene Ereignisse protokolliert wurden, die auf ein oder mehrere Probleme hinweisen.

  3. Wenden Sie die Befehle DCDiag.exe und NetDiag.exe auf den globalen Katalogserver an, um zu überprüfen, ob er richtig konfiguriert und in gutem Zustand ist.

  4. Überprüfen Sie dann abschließend das Standortdesign des Active Directory®-Verzeichnisdienstes. Eine Active Directory-Site ist ein Netzwerkbereich, der eine hohe Bandbreite und geringe Wartezeiten aufweist. Wenn das Netzwerk nicht entsprechend dieser Spezifikation konfiguriert ist, sollten Sie es möglicherweise in mehr Active Directory-Sites partitionieren.
Hinweis:
Wenn die WMI-Abfrage für den Ping-Test von Analyzer ausgeführt wird, werden die Standardwerte für Paketgröße und Timeout außer Kraft gesetzt. Stattdessen verwendet Analyzer eine ICMP-Paketgröße von 4096 (statt dem Standard von 32 Byte) und einen Timeoutwert von 2000 ms (statt dem Standard von 1000 ms).

Führen Sie die folgenden Schritte aus, um das Ping-Verhalten von Analyzer manuell zu emulieren.

So führen Sie den Ping-Test manuell aus

  • Führen Sie den folgenden Befehl im Befehlszeilenfenster des Computers mit Exchange Server aus: ping -L 4096 -N 6 <Active Server server name>Hinweis Der Befehl initiiert sechs Ping-Anforderungen mit jeweils 4096 Bytes.

Weitere Informationen zum Tool ADTest.exe finden Sie auf der Website „Active Directory Performance Testing Tool (ADTest.exe)" (http://go.microsoft.com/fwlink/?LinkId=33758).

Weitere Informationen zur WMI-Klasse Win32_PingStatus finden Sie im MSDN®-Artikel „Win32_PingStatus" (http://go.microsoft.com/fwlink/?LinkId=33549).

Weitere Informationen zum Active Directory-Standortdesign finden Sie auf der Website „Designing the Site Topology" (http://go.microsoft.com/fwlink/?LinkId=33551).

Weitere Informationen zum Installieren der Windows 2000 Server-Supporttools finden Sie im Microsoft Knowledge Base-Artikel 301423 „SO WIRD'S GEMACHT: Installation der Windows 2000-Supporttools auf einem bestehenden Computer unter Windows 2000 Server" unter http://support.microsoft.com/kb/301423/dehttp://go.microsoft.com/fwlink/?linkid=3052&kbid=301423.

Informationen zum Installieren der Windows Server 2003-Supporttools finden Sie in „To install Windows Support Tools" unter http://go.microsoft.com/fwlink/?LinkId=41362.


Roundtrip-Zeiten zum globalen Katalogserver sind länger als 10 ms
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-03-16

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) WIN32_PingStatus im Namespace root\\cimv2 ab, um den Wert für den Schlüssel ResponseTime zu bestimmen. Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel ResponseTime größer ist als 10 Millisekunden (ms), jedoch kleiner als 100 ms, wird eine Warnung angezeigt.

Der Schlüssel ResponseTime stellt die Zeit (in Millisekunden) für die Antwort auf die ICMP-Echoanforderungspakete (ping) dar, die vom Exchange-Server zum globalen Katalogserver gesendet wurden. Die Antwortzeit globaler Katalogserver, die von einem Exchange Server-Computer verwendet werden, sollte immer kleiner oder gleich 10 Millisekunden sein. Wenn die Antwortzeit 10 Millisekunden überschreitet, können Leistungs- oder Verbindungsprobleme auftreten.

So beheben Sie dieses Problem

  1. Stellen Sie sicher, dass der entsprechende globale Katalogserver nicht überlastet ist. Testen Sie den globalen Katalogserver mit dem Tool ADTest.exe, um zu ermitteln, ob die Hardware die erwartete Belastung verarbeiten kann.

  2. Überprüfen Sie die Ereignisprotokolle des Exchange-Servers und des globalen Katalogservers, um festzustellen, ob netzwerkbezogene Ereignisse protokolliert wurden, die auf ein oder mehrere Probleme hinweisen.

  3. Wenden Sie die Befehle DCDiag.exe und NetDiag.exe auf den globalen Katalogserver an, um zu überprüfen, ob er richtig konfiguriert und in gutem Zustand ist.

  4. Überprüfen Sie dann abschließend das Standortdesign des Active Directory®-Verzeichnisdienstes. Eine Active Directory-Site ist ein Netzwerkbereich, der über hohe Bandbreite und geringe Wartezeit verfügt. Wenn das Netzwerk nicht entsprechend dieser Spezifikation konfiguriert ist, sollten Sie es möglicherweise in mehr Active Directory-Sites partitionieren.
Hinweis:
Wenn die WMI-Abfrage für den Ping-Test von Analyzer ausgeführt wird, werden die Standardwerte für Paketgröße und Timeout außer Kraft gesetzt. Stattdessen verwendet Analyzer eine ICMP-Paketgröße von 4096 (statt dem Standard von 32 Byte) und einen Timeoutwert von 2000 ms (statt dem Standard von 1000 ms).

Führen Sie die folgenden Schritte aus, um das Ping-Verhalten von Analyzer manuell zu emulieren.

So führen Sie den Ping-Test manuell aus

  • Führen Sie den folgenden Befehl im Befehlszeilenfenster des Computers mit Exchange Server aus:

    ping -L 4096 -N 6 <Active Server server name>

    Hinweis:
    Der Befehl initiiert sechs Ping-Anforderungen mit jeweils 4096 Bytes.

Weitere Informationen zum Tool ADTest.exe finden Sie auf der Website „Active Directory Performance Testing Tool (ADTest.exe)" (http://go.microsoft.com/fwlink/?LinkId=33758).

Weitere Informationen zur WMI-Klasse Win32_PingStatus finden Sie im MSDN®-Artikel „Win32_PingStatus" (http://go.microsoft.com/fwlink/?linkid=33549).

Weitere Informationen zum Active Directory-Standortdesign finden Sie unter „Designing the Site Topology" (http://go.microsoft.com/fwlink/?LinkId=33551).


Suchfilter für Empfängerrichtlinie muss geändert werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-02-21

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs purportedSearch fu¨r jedes Exchange-Empfa¨ngerrichtlinienobjekt zu ermitteln. Mit dem Attribut purportedSearch wird das Suchargument angegeben, das beim Anwenden der Richtlinie verwendet wird.

Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst auch ab, um den Wert fu¨r das Attribut msDS-Behavior-Version des Gesamtstrukturobjekts in Active Directory unter den NTDS-Einstellungen zu ermitteln. Dieser Wert gibt die Funktionsebene in der Active Directory-Gesamtstruktur an. In der folgenden Tabelle finden Sie gu¨ltige Werte fu¨r das Attribut msDS-Behavior-Version.

Wert | Funktionsebene in der Gesamtstruktur
0 | Microsoft Windows® 2000 Server gemischt
1 | Windows Server™ 2003 interim
2 | Windows Server 2003 einheitlich

Exchange Server Analyzer fragt Active Directory auch ab, um den Wert fu¨r das Attribut revision des Containers Windows2003Update zu ermitteln. Der Wert dieses Attributs gibt an, ob das Active Directory-Vorbereitungsprogramm (ADPrep.exe) ausgefu¨hrt wurde.

Exchange Server Analyzer fragt außerdem die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_OperatingSystem ab, um den Wert des Schlu¨ssels OSProductSuite zu bestimmen. Der Wert des Schlu¨ssels OSProductSuite gibt die Version von Windows an, die auf dem Computer ausgefu¨hrt wird.

Wenn Microsoft Exchange Server Analyzer feststellt, dass die folgenden Kriterien zutreffen, wird eine Warnung angezeigt:

  • Der Wert des Attributs purportedSearch der Empfa¨ngerrichtlinie entha¨lt die Zeichenfolge homeMdb.

  • Die Funktionsebene der Active Directory-Gesamtstruktur lautet Windows Server 2003 interim oder Windows Server 2003 einheitlich.

  • Auf dem Exchange Server-Computer wird nicht Microsoft Windows Small Business Server 2003 ausgefu¨hrt.

Diese Warnung zeigt an, dass die Active Directory-Gesamtstruktur fu¨r Windows Server 2003 vorbereitet wurde. Wenn Probleme beim Stempeln von E-Mail-Adressen beim vollsta¨ndigen Aktualisieren der Gesamtstrukturfunktionsebene auf Windows Server 2003 vermieden werden sollen, muss die Empfa¨ngerrichtlinie gea¨ndert werden. Die betreffende Empfa¨ngerrichtlinie wird in der Ausgabe von Microsoft Exchange Server Analyzer angegeben.

Wenn Windows Server 2003 als Doma¨nencontroller verwendet und die Empfa¨ngerrichtlinie nicht aktualisiert wird, werden bei der Replikation verknu¨pfter Werte unter Windows Server 2003 E-Mail-Adressen neuer Benutzer durch den Empfa¨ngeraktualisierungsdienst falsch geschrieben. Der Empfa¨ngeraktualisierungsdienst erkennt den Benutzer aufgrund der Replikation verknu¨pfter Werte zwischen dem Zeitpunkt, zu dem mailnickname repliziert, und dem Zeitpunkt, zu dem homeMDB repliziert. Daher gilt zu diesem Zeitpunkt fu¨r den Benutzer die Standardrichtlinie anstelle der auf homeMDB basierenden Richtlinie. Einige Minuten spa¨ter, wenn die Replizierung fu¨r homeMDB ausgefu¨hrt wird, gilt fu¨r den Benutzer die homeMDB-Richtlinie. Der Benutzer verfu¨gt jedoch bereits u¨ber Adressen, die mit der Standardrichtlinie u¨bereinstimmen.

So beheben Sie dieses Problem

  1. O¨ffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Empfa¨nger, markieren Sie Empfa¨ngerrichtlinien, klicken Sie mit der rechten Maustaste auf RecipientPolicyName, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Seite Eigenschaften von RecipientPolicyName auf der Registerkarte Allgemein unter Filterregeln auf A¨ndern.

  4. Wa¨hlen Sie im Menu¨ Nach Exchange-Empfa¨ngern suchen die Option Benutzerdefinierte Suche aus. Wenn die Empfa¨ngerrichtlinie urspru¨nglich mithilfe einer benutzerdefinierten Suche erstellt wurde, wird nach dem Klicken auf A¨ndern in Schritt 3 die Seite Nach benutzerdefinierter Suche suchen angezeigt.

  5. A¨ndern Sie die LDAP-Abfrage (Lightweight Directory Access Protocol) so, dass das Attribut homeMdb nicht als Teil der Filterbedingung verwendet wird. Attribute wie extensionAttribute, msExchHomeServerName oder UPN stellen gu¨ltige Argumente dar, mit deren Hilfe u. U. das gleiche Suchergebnis erzielt werden kann.

  6. Klicken Sie zum Speichern der A¨nderung zweimal auf OK, und schließen Sie dann den Exchange-System-Manager.


Suchfilter für Empfängerrichtlinie muss geändert werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs purportedSearch für jedes Exchange-Empfängerrichtlinienobjekt zu ermitteln. Mit dem Attribut purportedSearch wird das Suchargument angegeben, das beim Anwenden der Richtlinie verwendet wird.

Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst auch ab, um den Wert für das Attribut msDS-Behavior-Version des Gesamtstrukturobjekts in Active Directory unter den NTDS-Einstellungen zu ermitteln. Dieser Wert gibt die Funktionsebene in der Active Directory-Gesamtstruktur an. In der folgenden Tabelle finden Sie gültige Werte für das Attribut msDS-Behavior-Version.

Wert | Funktionsebene in der Gesamtstruktur
0 | Microsoft® 2000 Server gemischt
1 | Windows Server™ 2003 interim
2 | Windows Server 2003 einheitlich

Exchange Server Analyzer fragt Active Directory auch ab, um den Wert für das Attribut revision des Containers Windows2003Update zu ermitteln. Der Wert dieses Attributs gibt an, ob das Active Directory-Vorbereitungsprogramm (ADPrep.exe) ausgeführt wurde.

Exchange Server Analyzer fragt außerdem die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_OperatingSystem ab, um den Wert des Schlüssels OSProductSuite zu bestimmen. Der Wert des Schlüssels OSProductSuite gibt die Version von Windows an, die auf dem Computer ausgeführt wird.

Wenn Exchange Server Analyzer feststellt, dass die folgenden Kriterien erfüllt sind, wird eine Warnung angezeigt:

  • Der Wert des Attributs purportedSearch der Empfängerrichtlinie enthält die Zeichenfolge (homeMdb=).

  • Bei der Active Directory-Funktionsebene in der Gesamtstruktur handelt es sich um Windows 2000 Server gemischt.

  • Die Active Directory-Gesamtstruktur wurde für Windows Server 2003-Domänencontroller vorbereitet.

  • Auf dem Exchange Server-Computer wird nicht Microsoft Windows Small Business Server 2003 ausgeführt.

Diese Warnung zeigt an, dass die Active Directory-Gesamtstruktur für Windows Server 2003 vorbereitet wurde. Wenn Probleme beim Stempeln von E-Mail-Adressen beim vollständigen Aktualisieren der Active Directory-Gesamtstrukturfunktionsebene auf Windows Server 2003 vermieden werden sollen, muss die Empfängerrichtlinie geändert werden. Die betreffendene Empfängerrichtlinie wird in der Ausgabe von Microsoft Exchange Server Analyzer angegeben.

Wenn Windows Server 2003 als Domänencontroller verwendet und die Empfängerrichtlinie nicht aktualisiert wird, werden bei der Replikation verknüpfter Werte unter Windows Server 2003 E-Mail-Adressen neuer Benutzer durch den Empfängeraktualisierungsdienst falsch geschrieben.

Aufgrund der Replikation verknüpfter Werte erkennt der Empfängeraktualisierungsdienst möglicherweise einen neuen Benutzer zum ersten Mal zwischen den Zeiträumen, in denen mailnickname und homeMdb repliziert werden. Daher gilt zu diesem Zeitpunkt für den Benutzer die Standardrichtlinie anstelle der auf der homeMdb basierenden Richtlinie. Einige Minuten später, wenn homeMdb repliziert wird, gilt für den Benutzer die homeMdb-Richtlinie. Der Benutzer verfügt jedoch bereits über Adressen, die mit der Standardrichtlinie übereinstimmen.

So beheben Sie dieses Problem

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Empfänger, markieren Sie Empfängerrichtlinien, klicken Sie mit der rechten Maustaste auf RecipientPolicyName, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Seite Eigenschaften von RecipientPolicyName auf der Registerkarte Allgemein unter Filterregeln auf Ändern.

  4. Wählen Sie im Menü Nach Exchange-Empfängern suchen die Option Benutzerdefinierte Suche aus. Wenn die Empfängerrichtlinie ursprünglich mithilfe einer benutzerdefinierten Suche erstellt wurde, wird nach dem Klicken auf Ändern in Schritt 3 die Seite Nach benutzerdefinierter Suche suchen angezeigt.

  5. Ändern Sie die LDAP-Abfrage (Lightweight Directory Access Protocol) so, dass das Attribut homeMdb nicht als Teil der Filterbedingung verwendet wird. Attribute wie extensionAttribute, msExchHomeServerName oder UPN stellen gültige Argumente dar, mit deren Hilfe u. U. das gleiche Suchergebnis erzielt werden kann.

  6. Klicken Sie zum Speichern der Änderung zweimal auf OK, und schließen Sie dann den Exchange-System-Manager.


Sender ID nicht konfiguriert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-05-10

Das Tool Microsoft Exchange Best Practices Analyzer verwendet das folgende Cmdlet der Exchange-Verwaltungsshell, um die Werte der Eigenschaften Enabled und ExternalMailEnabled des Objekts SenderIdConfig für alle Exchange Server 2007-Zielserverfunktionen EdgeTransport oder Hub-Transport abzufragen.

Code kopieren
- get-SenderIdConfig

Der Wert der Eigenschaft Enabled gibt an, ob der Sender ID-Agent aktiviert ist. Gültige Eingaben für den Parameter Enabled sind die Werte $true und $false. Der Standardwert ist $true. Wenn der Parameter Enabled auf $true festgelegt wird, ist der Sender ID-Agent aktiviert.

Der Wert der Eigenschaft ExternalMailEnabled gibt an, ob alle Nachrichten aus nicht authentifizierten Verbindungen den Sender ID-Agent zur Verarbeitung durchlaufen. Gültige Eingaben für den Parameter ExternalMailEnabled sind die Werte $true und $false. Der Standardwert ist $true. Wenn der Parameter ExternalMailEnabled auf $true festgelegt wird, durchlaufen alle Nachrichten aus nicht authentifizierten Verbindungen den Sender ID-Agent zur Verarbeitung.

Wenn Exchange Best Practices Analyzer feststellt, dass die Werte für die Eigenschaften Enabled oder ExternalMailEnabled des Objekts SenderIdConfig nicht auf $true festgelegt sind, zeigt Exchange Best Practices Analyzer eine Meldung zu bewährten Methoden an.

Diese Meldung besagt, dass Sender ID für die Exchange 2007-Zielserverfunktionen Edge-Transport oder Hub-Transport nicht aktiviert ist.

Sender ID versucht sicherzustellen, dass jede E-Mail-Nachricht von der Internetdomäne stammt, von der sie angibt, gesendet worden zu sein.

Wenn Sender ID auf einem Computer aktiviert ist, werden alle Nachrichten, die über alle Empfangsconnectors auf diesem Computer eingehen, gefiltert. Es werden ausschließlich Nachrichten gefiltert, die von externen Quellen stammen. Externe Quellen sind als nicht authentifizierte Quellen definiert. Diese werden als anonyme Internetquellen betrachtet.

Um dieses Problem zu beheben, aktivieren Sie Sender ID für die Exchange 2007-Zielserverfunktionen Edge-Transport oder Hub-Transport.

So verwenden Sie die Exchange-Verwaltungsshell zum Aktivieren der Sender ID-Funktion

  • Um Absenderfilterung zu aktivieren, führen Sie den folgenden Befehl aus:

    Code kopieren
    Set-SenderIdConfig -Enabled $true -ExternalMailEnabled $true

Weitere Informationen zu Sender ID finden Sie unter den folgenden Themen:

  • Sender ID-Startseite (http://go.microsoft.com/fwlink/?linkid=50977)

  • Exchange 2007 Sender ID (http://go.microsoft.com/fwlink/?LinkId=89719)

  • Konfigurieren von Sender ID (http://go.microsoft.com/fwlink/?LinkId=89720)


Konflikt bei Groß-/Kleinschreibung des Servernamens
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den in Active Directory gespeicherten Wert für den Namen des Exchange-Servers zu bestimmen (CN=<ExchangeServerName>). Nach dem Abrufen dieses Namens zählt Microsoft Exchange Server Analyzer die in dem Namen enthaltenen Zeichen.

Microsoft Exchange Server Analyzer liest auch den folgenden Registrierungseintrag, um den Wert zu bestimmen, der in der Registrierung des Exchange Server-Computers für den Hostnamen des Exchange-Servers gespeichert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

Exchange Server Analyzer fragt außerdem die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_Service ab, um den Wert des Schlüssels Started für ClusSvc zu bestimmen, den Windows®-Clusterdienst.

Microsoft Exchange Server Analyzer zeigt eine Meldung an, dass die Konfiguration nicht dem Standard entspricht, wenn alle folgenden Bedingungen erfüllt sind:

  • Der Wert CN=<ExchangeServerName> stimmt in der Groß- und Kleinschreibung nicht mit dem Wert Hostname überein. Beispielsweise ist CN=ComputerName, während der Hostname auf COMPUTERNAME festgelegt ist.

    Hinweis:
    Obgleich das Ändern der Groß- und Kleinschreibung von Servernamen in der Registrierung unterstützt wird, wird diese Vorgehensweise nicht empfohlen.
  • Der Name des Exchange-Servers hat eine Länge von höchstens 15 Zeichen.

  • Der Exchange-Server wird nicht in einem Windows-Cluster ausgeführt.

Die häufigste Ursache dieses Fehlers besteht darin, dass der Name des Exchange-Servers manuell in der Registrierung geändert wurde.


Namenskonflikt für Server
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft®Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Einstellung für den Registrierungswert This Server zu ermitteln:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer sendet auch eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert des Attributs name für jedes Exchange Server-Objekt zu ermitteln.

Exchange Server Analyzer fragt schließlich die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_Service ab, um den Wert des Schlüssels Started für den Clusterdienst (ClusSvc) zu bestimmen. Der Wert True gibt an, dass der Clusterdienst gestartet wurde, und der Wert False gibt an, dass der Clusterdienst nicht ausgeführt wird.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel This Server für Exchange Server-Computer, die nicht in einem Servercluster ausgeführt werden, nicht mit dem Wert des Attributs name des Serverobjekts in Active Directory übereinstimmt, wird ein Fehler angezeigt.

Um diesen Fehler zu beheben, müssen Sie den Registrierungsschlüssel This Server so ändern, dass er mit dem Wert des Attributs name in Active Directory übereinstimmt.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diesen Fehler

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem.

  3. Doppelklicken Sie im rechten Bereich auf This Server, geben Sie den richtigen Namen für diesen Computer ein, und klicken Sie dann auf OK.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den Exchange Server-Computer neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Servername ist zu lang.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-02-22

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um die Namen (cn) aller Verzeichnisobjekte mit einer Objektklasse msExchExchangeServer zu ermitteln. Der Wert cn ist eine Zeichenfolge, die den Kurznamen des Exchange Server-Computers enthält. Exchange Server Analyzer ruft cn ab und bestimmt dann die Länge der Zeichenfolge. Die Länge der Zeichenfolge entspricht der Anzahl von Zeichen im Exchange-Servernamen. Wenn Exchange Server Analyzer feststellt, dass ein Exchange-Servername länger als 15 Zeichen ist, wird ein Fehler angezeigt.

Für Exchange Server 2007, Exchange Server 2003 und Exchange 2000 Server bestehen einige NetBIOS-Abhängigkeiten, die erfordern, dass Sie abhängig von der Netzwerktopologie über verschiedene Subnetze hinweg NetBIOS-Namensauflösung verwenden, um den erfolgreichen Betrieb aller Exchange-Komponenten zu gewährleisten. Der NetBIOS-Namenskonvention zufolge kann ein NetBIOS-Name aus 16 Zeichen bestehen. Microsoft allerdings beschränkt NetBIOS-Namen auf 15 Zeichen und verwendet das sechzehnte Zeichen als NetBIOS-Suffix.

Da Exchange Server über NetBIOS-Abhängigkeiten verfügt, und weil die Länge von NetBIOS-Namen 15 Zeichen nicht überschreiten darf, werden in einer Exchange-Organisation keine Servernamen mit mehr als 15 Zeichen unterstützt. Darüber hinaus wird das Umbenennen eines Exchange Server-Computers nicht unterstützt, da dies erhebliche Auswirkungen auf Active Directory und die Exchange-Organisation haben könnte.

So beheben Sie diesen Fehler

  1. Entfernen Sie den falsch benannten Exchange Server-Computer mit der Option Enfernen.

  2. Geben Sie dem Computer einen neuen Namen, der aus maximal 15 Zeichen besteht.

  3. Installieren Sie Exchange Server erneut auf dem Computer.

Weitere Informationen zum Entfernen von Exchange Server 2007 finden Sie im Bereitstellungshandbuch für Microsoft Exchange Server 2007 unter "Vollständiges Entfernen von Exchange 2007 von einem Server" (http://go.microsoft.com/fwlink/?LinkId=79246).

Weitere Informationen zum Entfernen von Exchange Server 2003 finden Sie unter „Deinstallieren von Exchange 2003" im Bereitstellungshandbuch für Exchange Server 2003 unter http://go.microsoft.com/fwlink/?LinkId=47569.

Weitere Informationen finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 833396, „How to manually remove Exchange 2003 from your computer" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=833396).

  • 260378, „XADM: Manuelles Entfernen einer Installation von Exchange 2000" (http://support.microsoft.com/default.aspx?scid=kb;de;260378).

  • 328810, „Moving mailboxes between servers" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810).

  • 821829, „Moving Mailboxes in Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).


Server-RPC-Netzwerkadresse stimmt nicht mit dem Namen des Exchange-Servers überein.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs networkAddress für jedes Exchange Server-Objekt im Verzeichnis zu bestimmen. Normalerweise sind für dieses Attribut mit mehreren Zeichenfolgen mehrere Einträge aufgelistet, wie in den folgenden Beispielen dargestellt ist:

ncacn_ip_tcp:<Vollqualifizierter Domänenname von Exchange Server>

ncacn_np:<Hostname von Exchange Server>

ncacn_spx:<Hostname von Exchange Server>

ncacn_vns_spp:<Hostname von Exchange Server>

ncalrpc:<Hostname von Exchange Server>

netbios:<Hostname von Exchange Server>

Exchange Server Analyzer sendet auch eine Abfrage an Active Directory, um den Wert des Attributs name für jedes Exchange Server-Objekt zu ermitteln.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs name mit dem Namensteil keiner im Attribut networkAddress gefundenen Zeichenfolge übereinstimmt, wird ein Fehler angezeigt.

Dieser Fehler kann auftreten, wenn der Wert cn des Serverobjekts manuell von einem Administrator geändert wurde. Das Attribut networkAddress wird von Exchange Server erstellt und verwaltet, und es enthält mehrfache Zeichenfolgenwerte, um die verschiedenen von Exchange Server unterstützten Netzwerkkommunikationsprotokolle zu unterstützen. Jeder Wert verknüpft ein Protokoll mit der entsprechenden Form des Servernamens, je nach Anforderung des Protokolls.

Um diesen Fehler zu beheben, überprüfen Sie, ob der Servername geändert wurde oder ob der Wert ungültig ist, und gehen Sie entsprechend vor:

  • Wenn der Servername geändert wurde, verwenden Sie das später in diesem Artikel angegebene Verfahren, um die Werte entsprechend zu korrigieren.

  • Wenn die Werte aus einem anderen Grund ungültig sind, führen Sie Exchange-Setup auf dem Server erneut aus.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So beheben Sie diesen Fehler

  1. Verwenden Sie die ADSI-Bearbeitung oder ein vergleichbares Tool, um das administrative Gruppenobjekt in Active Directory zu suchen.

    Das Attribut networkAddress befindet sich unter:

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=Name der Organisation=Administrative Groups, CN=Name der administrativen Gruppe, CN=Servers, CN=Servername

  2. Notieren Sie sich das Format jedes einzelnen Werts in der Liste. Aktualisieren Sie die Werte je nach Bedarf, und ändern Sie nur den Servernamensteil der einzelnen Werte.

    Hinweis:
    Stellen Sie sicher, dass der Servername für den Wert ncacn_ip_tcp die Form eines vollqualifizierten Domänencontrollers besitzt und nicht die eines NetBIOS-Namens oder einer IP-Adresse (Internet Protocol).

  3. Schließen Sie den Active Directory-Editor, und starten Sie den Microsoft Exchange-Routingmodul-Dienst neu.

Weitere Informationen zum Verwenden des LDP-Tools finden Sie im Microsoft Knowledge Base-Artikel 260745 „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Weitere Informationen zu Exchange-Routingproblemen finden Sie unter „Troubleshooting Routing" im Exchange Server 2003 Transport and Routing Guide (http://go.microsoft.com/fwlink/?LinkId=47579).


Fehlender Dienstprinzipalname
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-08-14

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um die Werte zu ermitteln, die für das Attribut servicePrincipalName des Computers mit Exchange Server für die Konten der in der folgenden Liste aufgeführten Exchange-Ressourcen zurückgegeben wurden.

Wert von servicePrincipalName für die Exchange-Ressource | Erwarteter Rückgabewert
exchangeMDB | FQDN (Fully Qualified Domain Name)
exchangeMDB | NetBIOS-Name
exchangeRFR | FQDN (Fully Qualified Domain Name)
exchangeRFR | NetBIOS-Name
SMTP | FQDN (Fully Qualified Domain Name, vollqualifizierter Domänenname)
SMTP | NetBIOS-Name
SMTPSVC | FQDN (Fully Qualified Domain Name)
SMTPSVC | NetBIOS-Name
HOST | FQDN (Fully Qualified Domain Name)
HOST | NetBIOS-Name

Wenn Exchange Server Analyzer feststellt, dass dem Attribut servicePrincipalName für das Computerkonto einer Exchange-Ressource einer der hier aufgeführten erwarteten Werte fehlt, wird ein Fehler angezeigt.

Ein Dienstprinzipalname (Service Principal Name, SPN) ist ein eindeutiger Name, der eine Instanz eines Diensts identifiziert und dem Anmeldekonto zugeordnet ist, unter dem die Dienstinstanz ausgeführt wird. Kerberos-Authentifizierung ist für Exchange-Dienste nur mit ordnungsgemäß festgelegten SPNs möglich.

  • Authentifizierungsprobleme zwischen Clients, auf denen Microsoft Office Outlook® 2003 oder höher ausgeführt wird, und dem Exchange-Informationsspeicher (Postfachdaten) können darauf hindeuten, dass ein gültiger SPN für die exchangeMDB-Ressource fehlt.

  • Clients mit Outlook 2003 oder höher, die Active Directory-Authentifizierungsprobleme haben, können darauf hindeuten, dass ein gültiger SPN für die exchangeRFR-Ressource fehlt.

  • Authentifizierungsfehler zwischen virtuellen SMTP-Servern (Simple Mail Transport Protocol) können darauf hindeuten, dass ein gültiger SPN für die SMTPSVC- oder die HOST-Ressource fehlt.

Verfahren Sie wie folgt, um dieses Problem zu beheben, indem Sie die fehlenden Wert für die betroffenen Attribute hinzufügen.

Fügen Sie mithilfe des Tools SETSPN.exe einen SPN mit den fehlenden Werten hinzu.

  1. Installieren Sie das Tool Setspn.exe. Das Tool Setspn.exe können Sie unter "Windows 2000 Resource Kit Tool: Setspn.exe" (http://go.microsoft.com/fwlink/?LinkId=28103) herunterladen.

    Die Windows Server 2003-Version des Befehlszeilentools Setspn.exe ist in den Windows Server 2003 Support Tools verfügbar, die sich auf der Windows Server 2003-CD befinden. Doppelklicken sie zum Installieren der Server 2003 Support Tools auf die Datei Suptools.msi im Ordner Support/Tools.

  2. Befolgen Sie die Anleitung in der Datei Setspn_d.txt von SETSPN.EXE, um dem Active Directory-Objekt für Ihren Server mit Exchange den fehlenden Wert hinzuzufügen. In dem folgenden Beispiel wird gezeigt, wie für den SPN eines virtuellen SMTP-Servers der FQDN-Wert hinzugefügt wird:

    • Starten Sie eine Eingabeaufforderung, und wechseln Sie in das Verzeichnis, in dem Sie Setspn.exe installiert haben.

    • Geben Sie an der Eingabeaufforderung den folgenden Befehl ein:

      setspn.exe-a SMTPSVC/ mail.IhreDomäne.com IHRSERVERNAME

      Hinweis:
      Ersetzen Sie mail.IhreDomäne.com durch den FQDN Ihres virtuellen SMTP-Servers und IHRSERVERNAME durch den Namen des Servers mit Exchange.
      Drücken Sie dann die EINGABETASTE.


Ein Dienst wurde innerhalb der letzten 24 Stunden unerwartet beendet.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-02-14

Microsoft Exchange Analyzer fragt die Microsoft WMI-Klasse (Windows Management Instrumentation - Windows-Verwaltungsinstrumentation) Win32_NTLogEvent ab, um zu ermitteln, ob für den Dienststeuerungs-Manager innerhalb der letzten 24 Stunden eine Warnung für ein Ereignis 7031 protokolliert wurde.

Eine 7031-Ereigniswarnung bedeutet, dass der angegebene Dienst unterbrochen wurde. Der Dienst ist so konfiguriert, dass er die Anzahl der Fehler meldet. Nach einer bestimmten Anzahl von Fehlern führt der Dienststeuerungs-Manager die für den angegebenen Dienst festgelegte Wiederherstellungsaktion aus.

Wenn Exchange Analyzer feststellt, dass in den letzten 24 Stunden ein oder mehrere dieser Ereignisse protokolliert wurden, wird eine Informationsmeldung angezeigt.

Dieses Problem kann verschiedene Ursachen haben, von denen die folgenden am häufigsten auftreten:

  • Verarbeitung einer beschädigten Nachricht

  • Konfigurationsprobleme der Antivirusanwendung

So beheben Sie dieses Problem

  • Befolgen Sie die Anweisungen in Microsoft Knowledge Base-Artikel 286350, "Verwenden von ADPlus zur Problembehandlung, wenn der Computer hängt bzw. abstürzt" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286350), um die Ursache zu isolieren, warum ein Computer nicht mehr reagiert ("hängt") oder unerwartet beendet wird ("abstürzt").

  • Holen Sie sich das neueste Service Pack für Microsoft Windows 2000.

  • Holen Sie sich das neueste Service Pack für Microsoft Exchange Server.

  • Wenden Sie sich an den Anbieter der Antivirusanwendung, um die neuesten Updates sowie Konfigurationsinformationen zu erhalten.

Weitere Informationen

Weitere Informationen und Details zur 7031-Ereigniswarnung finden Sie unter "Events and Errors Message Center: Ereignisdetails" (http://go.microsoft.com/fwlink/?LinkId=83114).

Weitere Informationen zum Beziehen des neuesten Service Packs für Windows 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 260910, "Wie Sie das neueste Service Pack für Windows 2000 erhalten" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260910).

Weitere Informationen zum Beziehen des neuesten Service Packs für Exchange 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 301378, "Wie Sie das neueste Service Pack für Exchange 2000 Server erhalten" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378).

Weitere Informationen zum Beziehen des neuesten Service Packs für Exchange Server 2003 finden Sie unter "Why Try Service Pack 2 for Exchange Server 2003?" (http://go.microsoft.com/fwlink/?LinkId=52073).

Weitere Informationen zum Verwenden von Antivirussoftware mit Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 328841, "Exchange und Antivirussoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Überblick über Exchange Server 2003 und Antivirussoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Die Position von Microsoft zum Thema Antiviruslösungen für Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "Empfehlungen für die Problembehandlung bei einem Exchange Server-Computer mit installierter Antivirussoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie auf der Exchange Server Partners: Antivirus-Website (http://go.microsoft.com/fwlink/?LinkId=16226).


Services Value is Missing or Inaccessible
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-07-24

Das Tool Microsoft Exchange Analyzer liest den folgenden Registrierungseintrag, um das Vorhandensein des Zeichenfolgenwerts Services zu überprüfen:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Setup

Wenn Exchange Analyzer feststellt, dass der Zeichenfolgenwert Services fehlt oder nicht darauf zugegriffen werden kann, zeigt Exchange Analyzer einen Fehler an.

Dieser Fehler zeigt an, dass der Zeichenfolgenwert Services, der den Pfad für den Exchange-Installationsstamm enthält, fehlt oder dass nicht darauf zugegriffen werden kann. Das Nichtvorhandensein des Pfads für den Exchange-Installationsstamm kann zu einem Fehler bei der Initialisierung wichtiger Treiber und Protokolle führen. Dies bewirkt einen Fehler beim Start des Exchange-Informationsspeichers und von diesem abhängigen Diensten.

Um diesen Fehler zu beheben, befolgen Sie die Anweisungen im Microsoft Knowledge Base-Artikel 285116, "Der Exchange-Informationsspeicher wird nicht gestartet: Fehler 7024, 1026, 9542 und 5000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285116).


Nur ein Replikat des Frei/Gebucht-Ordners gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Exchange_PublicFolder im Namespace root\MicrosoftExchangeV2 ab, um die Anzahl der Frei/Gebucht-Replikate in den verschiedenen administrativen Gruppen zu bestimmen.

Wenn Exchange Server Analyzer ermittelt, dass in den verschiedenen administrativen Gruppen nur ein Frei/Gebucht-Replikat vorhanden ist, zeigt Exchange Server Analyzer eine empfohlene optimale Methode an.

Im Allgemeinen wird empfohlen, dass es in jeder administrativen Gruppe mehrere Replikate der Frei/Gebucht-Ordner gibt. Manchmal können mehrere Frei/Gebucht-Replikate die Leistung und Flexibilität erhöhen. In großen Exchange-Organisationen kann ein einzelnes Replikat der Frei/Gebucht-Daten überlastet werden. In allen Exchange-Organisationen stellt ein einzelnes Replikat der Frei/Gebucht-Daten eine einzelne Fehlerstelle dar.

Trotz der nachfolgenden Überlegungen wird empfohlen, mehrere Replikate zu verwenden:

  • Mehrere Replikate verursachen zusätzlichen Replikationsverkehr im Netzwerk.

  • Das Risiko von Planungskonflikten steigt bei mehreren Replikaten.

Es sollte minimal ein Replikat pro 10.000 Postfächer geben.

Weitere Informationen zu Frei/Gebucht-Ordnern und zur Veröffentlichung von Frei/Gebucht-Informationen finden Sie unter „Working with Exchange Server 2003 Stores" (http://go.microsoft.com/fwlink/?LinkId=47595).


Nur ein Replikat des Frei/Gebucht-Ordners für eine hohe Anzahl von Postfächern gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Exchange_PublicFolder ab, um die Anzahl der Einträge beim Schlüssel ReplicaList zu bestimmen. Die Anzahl der Einträge gibt die Anzahl der in jeder Verwaltungsgruppe vorhandenen Frei/Gebucht-Replikate wieder.

Um die Anzahl der Einträge zu ermitteln, die im Attribut homeMDBBLhomeMDBBL jedes Postfachspeichers aufgelistet sind, sendet Microsoft Exchange Server Analyzer eine Abfrage an den Active Directory®-Verzeichnisdienst. Der Zählwert dieses Attributs stellt die Zahl der Postfächer im Postfachspeicher dar.

Wenn Exchange Server Analyzer ermittelt, dass in einer administrativen Gruppe mit mehr als 10 000 Postfächern nur ein Frei/Gebucht-Replikat vorhanden ist, zeigt Exchange Server Analyzer einen Fehler an.

Im Allgemeinen wird empfohlen, dass es in jeder administrativen Gruppe mehrere Replikate der Frei/Gebucht-Ordner gibt. Manchmal können mehrere Frei/Gebucht-Replikate die Leistung und Flexibilität erhöhen. In großen Exchange-Organisationen kann ein einzelnes Replikat der Frei/Gebucht-Daten überlastet werden. In allen Exchange-Organisationen stellt ein einzelnes Replikat der Frei/Gebucht-Daten eine einzelne Fehlerstelle dar.

Trotz der nachfolgenden Überlegungen wird empfohlen, mehrere Replikate zu verwenden:

  • Mehrere Replikate verursachen zusätzlichen Replikationsverkehr im Netzwerk.

  • Das Risiko von Planungskonflikten steigt bei mehreren Replikaten.

Es sollte minimal ein Replikat pro 10.000 Postfächer geben.

Weitere Informationen zu Frei/Gebucht-Ordnern und zur Veröffentlichung von Frei/Gebucht-Informationen finden Sie unter „Working with Exchange Server 2003 Stores" (http://go.microsoft.com/fwlink/?LinkId=47595).


In der Topologie ist ein einzelner globaler Katalog vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-09

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Exchange_DSAccess im Namespace root\MicrosoftExchangeV2 ab, um die Anzahl der in der Topologie vorhandenen globalen Katalogserver zu bestimmen. Die Anzahl der globalen Katalogserver wird durch das Zählen der Einträge für den WMI-Schlüssel DSAccessNameGC ermittelt. Wenn Exchange Server Analyzer ermittelt, dass in der Topologie nur ein einziger globaler Katalogserver vorhanden ist, zeigt Exchange Server Analyzer eine empfohlene optimale Methode an.

Aus Gründen der Fehlertoleranz ist es eine optimale Methode, für Exchange-Server und Benutzer mindestens zwei globale Katalogserver zur Verfügung zu stellen. Ein einzelner globaler Katalogserver kann eine einzelne Fehlerstelle darstellen. Exchange 2000 Server, Exchange Server 2003 und Exchange Server 2007 bieten eine Vielzahl von Funktionen, die von globalen Katalogservern abhängen. Wenn kein globaler Katalogserver verfügbar ist, verlangsamt sich u. U. die Mail-Übermittlung, oder sie wird völlig eingestellt. Außerdem können bei einem nicht verfügbaren globalen Katalogserver Exchange Server-Dienste möglicherweise nicht gestartet werden. Wenn Exchange Server-Dienste nicht gestartet werden, können Benutzer nicht auf ihre Postfächer zugreifen.

Um Skalierbarkeit und Fehlertoleranz zu gewährleisten, wird empfohlen, dass Sie an jedem Standort des Active Directory®-Verzeichnisdiensts mindestens zwei globale Katalogserver konfigurieren. Wenn sich ein Standort über mehrere Domänen erstreckt, wird empfohlen, dass Sie für jede Domäne, in der sich Computer mit Exchange 2000 Server oder Exchange Server 2003 bzw. Computer und Clients mit Exchange Server 2007 befinden, einen globalen Katalogserver konfigurieren. Außerdem wird empfohlen, dass Sie jeweils für vier Exchange Server-Computerprozessoren einen globalen Katalogserver bereitstellen.

Weitere Informationen zum Erstellen zusätzlicher globaler Katalogserver finden Sie im Microsoft Knowledge Base-Artikel 313994, „How To Create or Move a Global Catalog in Windows 2000" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=313994.

Weitere Informationen zur Platzierung und Verfügbarkeit globaler Katalogserver in Bezug auf Exchange Server finden Sie in folgenden Knowledge Base-Artikeln:

  • 875427, „Global catalog server placement and ratios in an Exchange 2000 Server organization or in an Exchange Server 2003 organization", unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=875427

  • 322801, „Exchange System Attendant Does Not Start, and You Receive a "Global Catalog Servers Not Responding" Error Message" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=322801

  • 829361 „Exchange Server 2003 Computer Takes Longer Than You Expect to Shut Down" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=829361

  • 304403, „Exchange Considerations for Promoting a Domain Controller to a Global Catalog Server" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=304403

  • 305065, „Exchange Server-Related Considerations for Demoting a Global Catalog Server to a Domain Controller" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=305065


Server für Standortordner wurde gelöscht
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-03-01

Microsoft® Exchange Server Analyzer sendet auch eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert des Attributs siteFolderServer für die einzelnen administrativen Gruppenobjekte zu ermitteln. Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert für das Attribut siteFolderServer die Zeichenfolge DEL: enthält, wird ein Fehler angezeigt.

Das Attribut siteFolderServer stellt den Distinguished Name (DN) des Informationsspeichers für Öffentliche Ordner dar, der als Host für die Standortordner dient (normalerweise der erste Server am Standort oder in der administrativen Gruppe).

Als Standard ist der Server für Standortordner der erste Server, der in der administrativen Gruppe installiert wird. Der Informationsspeicher für Öffentliche Ordner auf diesem Server ist der Standard-Speicherort der Frei/Gebucht-Ordner und der Offline-Adressbuchordner für die administrative Gruppe. Wenn Sie diesen Server außer Betrieb setzen oder entfernen, ohne diese Ordner auf einem anderen Server zu replizieren und diesen Server als Offline-Adressbuchserver zu kennzeichnen, entstehen für Benutzer von Microsoft Office Outlook® 2003 Probleme mit dem Offlineadressbuch und mit Frei/Gebucht-Daten.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So beheben Sie diesen Fehler

  1. Öffnen Sie einen Active Directory-Editor, z. B. die ADSI-Bearbeitung.

  2. Suchen Sie den Informationsspeicher für Öffentliche Ordner, den Sie als Server für Standortordner festlegen möchten, indem Sie die folgenden Knoten im Konfigurationscontainer erweitern:

    CN=Configuration,DC=<Domänenname>,DC=com, CN=Services, CN=Microsoft Exchange, CN=<Name der Organisation>, CN=Administrative Groups, CN=<Name der administrativen Gruppe> CN=Servers, CN=<Servername>, CN=InformationStore, CN=<Name der Speichergruppe>

  3. Klicken Sie im rechten Bereich mit der rechten Maustaste auf CN=<PublicFolderStoreName>,, und klicken Sie dann auf Eigenschaften.

  4. Führen Sie im Feld Attribute einen Bildlauf nach unten durch, und wählen Sie das Attribut distinguishedName aus.

  5. Klicken Sie auf Bearbeiten, und kopieren Sie das gesamte Attribut in die Zwischenablage.

  6. Erweitern Sie den Container Konfiguration, und erweitern Sie dann CN=Configuration,CN=<Domänenname>,CN=com, CN=Services, CN=Microsoft Exchange, CN=<Name der Organisation>, CN=Administrative Groups

  7. Klicken Sie mit der rechten Maustaste auf die zu ändernde administrative Gruppe, und klicken Sie dann auf Eigenschaften.

  8. Führen Sie im Feld Attribute einen Bildlauf nach unten durch, und wählen Sie das Attribut siteFolderServer aus.

  9. Klicken Sie auf Bearbeiten, und fügen Sie dem Wert für das Attribut distinguishedName in das Feld Wert ein.

  10. Überprüfen Sie den Inhalt des Feldes Wert genau, um sicherzustellen, dass die Einfügung richtig stattgefunden hat, und klicken Sie dann auf OK, um die Änderung zu speichern.

  11. Klicken Sie auf OK, um das Dialogfeld der Eigenschaften der administrativen Gruppe zu schließen.

  12. Beenden Sie den Active Directory-Editor, und starten Sie auf allen Exchange Server-Computern des Standorts den Microsoft Exchange Server-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Weitere Informationen zum Neuerstellen von Systemordnern und Zurücksetzen des Servers für Standortordner finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 822444, „Zurücksetzen eines Systemordners in Exchange Server 2003" (http://support.microsoft.com/?kbid=822444)

  • 275171, „XADM: Zurücksetzen von Systemordnern auf einem Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=275171)

  • 284200, „Schedule+ Free/Busy System Folder Is Missing" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=284200).

Weitere Informationen zum Verwenden des LDP-Tools finden Sie im Knowledge Base-Artikel 260745, „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Weitere Informationen zum Verwenden der ADSI-Bearbeitung finden Sie im Thema „Adsiedit.msc: ADSI Bearbeitung" in der Hilfe zu Windows Server.


Langsame Active Directory-Verzeichnisdienstaufrufe
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-14

Microsoft® Exchange Server Analyzer Tool untersucht das FCL-Protokoll (Function Call Log) von Exchange, die Datei Store.fcl, auf Ereignisse der Active Directory®-Verzeichnisdienstkomponente, die eine Antwortzeit von 2,5 Sekunden überschreiten.

Ereignisse der Exchange FCL-Active Directory-Komponente stellen Funktionsaufrufe des Microsoft Exchange-Informationsspeicherdienstes (Store.exe) an die Active Directory-Komponente dar.

Active Directory stellt alle Postfachinformationen, Adresslistendienste und andere Informationen zu Empfängern bereit. Die meisten Exchange Server 2003-Konfigurationsinformationen werden ebenfalls in Active Directory gespeichert.

Exchange Server-Dienste greifen auf die in Active Directory gespeicherten Informationen zu und schreiben Informationen in Active Directory.

Wenn Exchange Server Analyzer feststellt, dass Ereignisse in der FCL-Datei für Funktionsaufrufe von Active Directory vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) eine Antwortzeit von mehr als 2,5 Sekunden aufweisen, wird ein Fehler angezeigt.

Wenn komponentenübergreifende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) auf eine Antwort warten, können RPC-Threads (Remote Procedure Call, Remoteprozeduraufruf) diese Anforderungen im Hintergrund unterstützen, sodass es zu Exchange Server-Leistungsproblemen kommt, z. B. zu Verzögerungen der Serverantworten an die Clients.

Aufrufe vom Microsoft Exchange-Informationsspeicherdienst an Active Directory, die länger als 2,5 Sekunden benötigen, können folgende Ursachen haben:

  • Netzwerkwartezeit zwischen dem Exchange-Server und dem Domänencontroller

  • Statische oder anderweitig fehlerhafte Konfiguration von DSAccess

  • Überlasteter Domänencontroller und überlasteter globaler Katalog

  • Fehlerhafter Entwurf der Active Directory-Topologie

Um diesen Fehler zu beheben, führen Sie folgende Schritte aus:

  • Führen Sie Exchange Server Analyzer aus, um eine weitere Analyse von Serverproblemen auszuführen. Sie können Exchange Server Analyzer unter "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" (http://go.microsoft.com/fwlink/?LinkId=34705) herunterladen.

  • Überprüfen Sie die Leistung der Active Directory-Domänencontrollerserver.

  • Im Abschnitt "Weitere Informationen" dieses Themas finden Sie weitere Artikel.

Weitere Informationen

Weitere Informationen zur Exchange-Leistung und DSAccess finden Sie im Microsoft Knowledge Base-Artikel 250570, "Directory service server detection and DSAccess usage" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570).

Weitere Informationen zur Leistung von Exchange Server finden Sie im "Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47576).

Weitere Informationen zur Behandlung von Leistungsproblemen von Exchange Server finden Sie im Handbuch "Troubleshooting Microsoft Exchange Server Performance" (http://go.microsoft.com/fwlink/?LinkId=47588).

Weitere Informationen zur Behandlung von Leistungsproblemen von Informationsspeichern finden Sie im Microsoft Knowledge Base-Artikel 257725, "XADM: Sammeln von Diagnosedaten zur Problembehandlung des Informationsspeichers" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

Weitere Informationen zur Leistung von Domänencontrollern finden Sie in den folgenden Windows Server-Ressourcen:

  • "Planning Domain Controller Capacity" (http://go.microsoft.com/fwlink/?LinkId=70191)

  • "Active Directory Monitoring of Domain Controllers" in Windows 2000 Server Active Directory Planning and Deployment Guides (http://go.microsoft.com/fwlink/?LinkId=70193)


Langsame ESE-Aufrufe
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-13

Microsoft® Exchange Server Analyzer Tool untersucht das FCL-Protokoll (Function Call Log) von Exchange, die Datei Store.fcl, auf Ereignisse der Exchange ESE-Komponente (Extensible Storage Engine), die eine Antwortzeit von 2,5 Sekunden überschreiten.

Ereignisse der Exchange FCL-ESE-Komponente stellen Funktionsaufrufe des Microsoft Exchange-Informationsspeicherdienstes (Store.exe) an die ESE-Komponente dar.

Der Exchange-Informationsspeicher befindet sich oberhalb einer ESE-Datenbank. ESE ist ein hochentwickeltes transaktionsbasiertes Datenbankmodul. Bei einer Transaktion handelt es sich um eine Folge von Operationen, die als unteilbare Einheit gelten. Entweder sind alle Operationen in einer Transaktion abgeschlossen und dauerhaft gespeichert, oder es werden keine Operationen durchgeführt.

In Exchange Server wird ESE als integriertes Datenbankmodul zum Festlegen der Struktur der Datenbanken sowie zum Verwalten des Arbeitsspeichers verwendet. Mit dem Datenbankmodul werden die Datenbanken im Arbeitsspeicher zwischengespeichert, indem 4-KB-Datenblöcke (Seiten) in und aus dem Arbeitsspeicher übertragen werden. Die Seiten werden im Arbeitsspeicher aktualisiert. Anschließend werden die neuen oder aktualisierten Seiten wieder auf Festplatte geschrieben. Bei Systemanforderungen können die Daten vom Datenbankmodul im Arbeitsspeicher gepuffert werden, sodass nicht permanent auf die Festplatte zugegriffen werden muss.

Obwohl Daten über die Zwischenspeicherung im Arbeitsspeicher am schnellsten und effizientesten verarbeitet werden, bedeutet dies jedoch auch, dass die Informationen auf der Festplatte bei der Ausführung von Exchange nie vollständig aktuell sind. Der Transaktionsprotokolldatenträger wird jedoch laufend mit Informationen zu den einzelnen Transaktionen aktualisiert. Da viele Änderungen im Arbeitsspeicher noch nicht auf der Festplatte vorhanden sind, sind Datenbank und Arbeitsspeicher nicht synchronisiert.

Wenn Exchange Server Analyzer feststellt, dass Ereignisse in der Datei Store.fcl für Funktionsaufrufe der ESE-Komponente vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) eine Antwortzeit von mehr als 2,5 Sekunden aufweisen, wird ein Fehler angezeigt.

Wenn komponentenübergreifende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) auf eine Antwort warten, können RPC-Threads (Remote Procedure Call, Remoteprozeduraufruf) diese Anforderungen im Hintergrund unterstützen, sodass es zu Exchange Server-Leistungsproblemen kommt, z. B. zu Verzögerungen der Serverantworten an die Clients.

Fortlaufende Aufrufe von ESE können folgende Ursachen haben:

  • Exchange-Onlinedefragmentierung

  • Datensicherungen

    Hinweis:
    Wenn während der Erfassung der Exchange-Ablaufverfolgungsprotokollierung für Aufrufe absichtlich eine Datensicherung oder eine Onlinedefragmentierung eingeleitet wurde, können Sie diese Meldung als Hinweis auf ein Exchange Server-Leistungsproblem ignorieren.
  • Engpässe auf einem Datenbanklaufwerk

Um diesen Fehler zu beheben, führen Sie folgende Schritte aus:

  • Im Rahmen bewährter Methoden sollte darauf geachtet werden, dass sich Sicherungsfenster nicht mit Onlinewartungs- oder Spitzennutzungsintervallen überlappen.

  • Führen Sie Exchange Server Analyzer aus, um eine weitere Analyse des Servers auszuführen. Sie können Exchange Server Analyzer unter "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" (http://go.microsoft.com/fwlink/?LinkId=34705) herunterladen.

  • Im Abschnitt "Weitere Informationen" dieses Themas finden Sie weitere Artikel.

Weitere Informationen

Weitere Informationen zum Konfigurieren der Zeitfenster für die Onlinedefragmentierung finden Sie im Microsoft Knowledge Base-Artikel 244524, "XADM: Konfigurieren des Exchange Server Online-Fragmentierungszeitfensters" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524).

Weitere Informationen zu Exchange Server-Problemen aufgrund von Datenträgerengpässen finden Sie unter Datenträgerengpass wurde festgestellt.

Weitere Informationen zum Festlegen der Größe und zum Optimieren von Datenträgern für Exchange Server finden Sie unter "Berechnung der Anforderungen an die Datenträger-E/A" und "Best Practices für mehrere Architekturen" in Optimieren von Speichersystemen für Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=49324).

Weitere Informationen zu ESE finden Sie unter "Extensible Storage Engine Architecture" (http://go.microsoft.com/fwlink/?linkid=67009).


Langsame IMAIL-Aufrufe
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-12

Microsoft® Exchange Server Analyzer Tool untersucht das FCL-Protokoll (Function Call Log) von Exchange, die Datei Store.fcl, auf Ereignisse der IMAIL-Komponente des MAPI-Clients, die eine Antwortzeit von 2,5 Sekunden überschreiten.

Ereignisse der Exchange FCL-IMAIL MAPI-Komponente stellen Funktionsaufrufe des Microsoft Exchange-Informationsspeicherdienstes (Store.exe) zum Konvertieren von Nachrichten zwischen dem Internetformat dem MAPI-Format dar.

Bei der IMAIL-Komponente von Exchange Server handelt es sich um einen flexiblen Konvertierungsdienst, der vom Microsoft Exchange-Informationsspeicherdienst zwischen Internet- und MAPI-Nachrichten verwendet wird. Dadurch wird die Interoperabilität zwischen Clients ermöglicht, die das RFC-822- oder Internetformat verwenden, und Clients, die das interne Exchange Server-Speicherformat verwenden, z. B. MAPI-Clients oder interne Speichertasks.

Exchange wendet mithilfe des IMAIL-Mechanismus Nachrichtenformate auf den Inhalt an. Maßgeblich sind hierbei die Festlegungen für Internetdomänen im Exchange-System-Manager bzw. die Festlegungen des Benutzers für den jeweiligen Empfänger in Microsoft Office Outlook®. Werden keine Formatierungsparameter an IMAIL übergeben, werden MAPI-Nachrichten für die Übertragung zwischen Servern in S/TNEF formatiert.

Wenn Exchange Server Analyzer feststellt, dass Ereignisse in der Datei Store.fcl für Funktionsaufrufe der IMAIL-Komponente des MAPI-Clients vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) eine Antwortzeit von mehr als 2,5 Sekunden aufweisen, wird ein Fehler angezeigt.

Wenn komponentenübergreifende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) auf eine Antwort warten, können RPC-Threads (Remote Procedure Call, Remoteprozeduraufruf) diese Anforderungen im Hintergrund unterstützen, sodass es zu Exchange Server-Leistungsproblemen kommt, z. B. zu Verzögerungen der Serverantworten an die Clients.

Lange Antwortzeiten für Funktionsaufrufe vom Exchange-Informationsspeicherdienst (Store.exe) an die IMAIL-Komponente können folgende Ursachen haben:

  • IMAIL versucht, umfangreiche Daten in einer Nachricht oder Anlage zu verarbeiten.

  • Viele Clients fordern eine Datenkonvertierung an.

  • DSAccess-Anforderungen weisen eine langsame Reaktion auf.

  • Es gibt Engpässe bei den TEMP- und TMP-Laufwerken.

  • Es gibt fortlaufende Postfachverschiebungen.

  • Um diesen Fehler zu beheben, führen Sie folgende Schritte aus:

  • Planen Sie Postfachverschiebungen in Zeiten geringer Nutzung.

  • Führen Sie Exchange Server Analyzer aus, um eine weitere Analyse von Serverproblemen auszuführen, wie z. B. Größenbeschränkungen für Nachrichten und Anlagen. Sie können Exchange Server Analyzer unter "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" (http://go.microsoft.com/fwlink/?LinkId=34705) herunterladen.

  • Im Abschnitt "Weitere Informationen" dieses Themas finden Sie weitere Artikel.

Weitere Informationen

Weitere Informationen zu Exchange Server-Problemen aufgrund von Datenträgerengpässen finden Sie unter Datenträgerengpass wurde festgestellt.

Weitere Informationen zum Festlegen der Größe und zum Optimieren von Datenträgern für Exchange Server finden Sie unter "Berechnung der Anforderungen an die Datenträger-E/A" und "Best Practices für mehrere Architekturen" in Optimieren von Speichersystemen für Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=49324).

Weitere Informationen zu bewährten Verfahren für Größenbegrenzungen für Nachrichten von Exchange Server finden Sie unter Maximale Größe für ausgehende Nachrichten wurde nicht festgelegt..


Langsame LSASS-Aufrufe
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-12-04

Microsoft® Exchange Server Analyzer Tool untersucht das FCL-Protokoll (Function Call Log) von Exchange, die Datei Store.fcl, auf Ereignisse der LSASS-Prozesskomponente (Local Security Authentication Server), die eine Antwortzeit von 25 Millisekunden überschreiten.

Ereignisse der Exchange FCL-LSASS-Prozesskomponente stellen Funktionsaufrufe des Microsoft Exchange-Informationsspeicherdienstes (Store.exe) an die LSASS-Prozesskomponente (Lsass.exe) dar.

Der LSASS-Prozess (Lsass.exe) ist ein Sicherheitssubsystem, das von anderen Prozessen aufgerufen wird, um Kontoinformationen zu überprüfen und Anmeldungen zu validieren.

Bei jeder Exchange-Clientanmeldung wird vom Server, auf dem Exchange Server ausgeführt wird, eine Anforderung gesendet, um die Konto-SID (Security Identifier) des Clients zu ermitteln, und ein Aufruf im LSASS-Prozess erstellt.

Wenn Exchange Server Analyzer feststellt, dass Ereignisse in der Datei Store.fcl für Funktionsaufrufe der LSASS-Komponente vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) eine Antwortzeit von mehr als 25 Millisekunden aufweisen, wird ein Fehler angezeigt.

Wenn komponentenübergreifende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) auf eine Antwort warten, können RPC-Threads (Remote Procedure Call, Remoteprozeduraufruf) diese Anforderungen im Hintergrund unterstützen, sodass es zu Exchange Server-Leistungsproblemen kommt, z. B. zu Verzögerungen der Serverantworten an die Clients.

Lange Antwortzeiten für Funktionsaufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an die LSASS-Komponente können folgende Ursachen haben:

  • Serverressourcenprobleme in Bezug auf die Anzahl der Benutzer, die gleichzeitig eine Authentifizierung durchführen

  • Netzwerkwartezeit zwischen dem Exchange-Server und dem Domänencontroller oder dem globalen Katalogserver

  • Probleme aufgrund von Engpässen bei Serverressourcen

Um diesen Fehler zu beheben, führen Sie folgende Schritte aus:

  • Erwägen Sie, den NeverPing-Parameter zu implementieren (siehe Beschreibung in Der Parameter 'NeverPing' wird empfohlen).

  • Führen Sie Exchange Server Analyzer aus, um eine weitere Analyse von Serverproblemen auszuführen, wie z. B. Größenbeschränkungen für Nachrichten und Anlagen. Sie können Exchange Server Analyzer unter "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" (http://go.microsoft.com/fwlink/?LinkId=34705) herunterladen.

  • Im Abschnitt "Weitere Informationen" dieses Themas finden Sie weitere Artikel.

Weitere Informationen

Weitere Informationen zum Lsass.exe-Prozess sowie zu Speichernutzung finden Sie im Microsoft Knowledge Base-Artikel 308356, "Speichernutzung durch den Prozess "Lsass.exe" auf Domänencontrollern unter Windows Server 2003 oder Windows 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356).

Weitere Informationen zu Exchange-Clientanmeldungen und LSASS-Problemen finden Sie im Microsoft Knowledge Base-Artikel 161938, "Verlangsamung von Exchange-Clientanmeldungen aufgrund von Ressourcen-Deadlocks" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938).

Weitere Informationen zu Netzwerkwartezeiten zwischen dem Exchange-Server und dem Domänencontroller oder dem globalen Katalogserver finden Sie im Exchange Server Team Blog-Artikel, "Exchange Does Not Always Use Local GCs" (http://go.microsoft.com/fwlink/?LinkId=69166).

Hinweis:
Der Inhalt jedes Blogs und die dazugehörigen URLs können jederzeit ohne vorherige Ankündigung geändert werden.

Weitere Informationen zu Problemen aufgrund von Engpässen bei Serverressourcen finden Sie unter Prozessorengpass.

Weitere Informationen zur Leistung von Exchange Server finden Sie im "Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47576).

Weitere Informationen zur Behandlung von Leistungsproblemen von Exchange Server finden Sie im Handbuch "Troubleshooting Microsoft Exchange Server Performance" (http://go.microsoft.com/fwlink/?LinkId=47588).

Weitere Informationen zur Behandlung von Leistungsproblemen von Informationsspeichern finden Sie im Microsoft Knowledge Base-Artikel 257725, "XADM: Sammeln von Diagnosedaten zur Problembehandlung des Informationsspeichers" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Langsame Virenscanneraufrufe
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-11

Microsoft® Exchange Server Analyzer Tool untersucht das FCL-Protokoll (Function Call Log) von Exchange, die Datei Store.fcl, auf Ereignisse der VAPI-Komponente (Virusscan Virus API), die eine Antwortzeit von 2,5 Sekunden überschreiten.

Ereignisse der Exchange FCL-Virusscan VAPI-Komponente stellen Funktionsaufrufe des Microsoft Exchange-Informationsspeicherdienstes (Store.exe) an die externe Virenscannersoftware dar.

Zur Verbesserung der Behandlung von VAPI-Problemen ist in Exchange Server eine Ereignisprotokollierung implementiert, mit der die Leistung der Virenscanner-API verfolgt werden kann.

Zu den protokollierten Ereignissen zählen:

  • Laden und Entladen von herstellerspezifischen DLLs

  • Erfolgreiche Überprüfung von Objekten

  • Feststellen von Viren im Informationsspeicher

  • Unerwartetes Verhalten der VAPI

Wenn Exchange Server Analyzer feststellt, dass Ereignisse in der Datei Store.fcl für Funktionsaufrufe der externen Virenscannersoftware vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) eine Antwortzeit von mehr als 2,5 Sekunden aufweisen, wird ein Fehler angezeigt.

Wenn komponentenübergreifende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) auf eine Antwort warten, können RPC-Threads (Remote Procedure Call, Remoteprozeduraufruf) diese Anforderungen im Hintergrund unterstützen, sodass es zu Exchange Server-Leistungsproblemen kommt, z. B. zu Verzögerungen der Serverantworten an die Clients.

Lange Antwortzeiten für Funktionsaufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) an die Virenscannersoftware können folgende Ursachen haben:

  • Aktualisierungen eines Virenscanners, die dazu führen, dass die Objekte im Informationsspeicher erneut geprüft werden

  • Ein fehlerhaft konfigurierter Virenscanner

  • Verarbeitung einer umfangreichen Nachricht oder Anlage durch die Virenscannersoftware

Um diesen Fehler zu beheben, führen Sie folgende Schritte aus:

  • Planen Sie Aktualisierungen des Antivirenmoduls in Zeiten mit geringer Ressourcenbelastung, d. h. außerhalb von Spitzennutzungsintervallen.

  • Erwägen Sie, die Virenscannersoftware neu zu installieren (außerhalb von Spitzennutzungsintervallen)

  • Untersuchen Sie die Konfiguration Ihres Virenscannermoduls hinsichtlich der ordnungsgemäßen Threadkonfiguration, Ausschlüssen auf Dateiebene usw. Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 823166, "Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Im Abschnitt "Weitere Informationen" dieses Themas finden Sie weitere Artikel.

Weitere Informationen

Weitere Informationen zu den in Microsoft Exchange Server 2003 üblicherweise verwendeten Virenprüfprogrammen finden Sie im Microsoft Knowledge Base-Artikel 823166, "Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Weitere Informationen zu den in Microsoft Exchange 2000 Server üblicherweise verwendeten Virenprüfprogrammen finden Sie im Knowledge Base-Artikel 328841, "XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Weitere Informationen zur Leistung von Exchange Server finden Sie im "Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47576).

Weitere Informationen zur Behandlung von Leistungsproblemen von Exchange Server finden Sie im Handbuch "Troubleshooting Microsoft Exchange Server Performance" (http://go.microsoft.com/fwlink/?LinkId=47588).

Weitere Informationen zur Behandlung von Leistungsproblemen von Informationsspeichern finden Sie im Microsoft Knowledge Base-Artikel 257725, "XADM: Sammeln von Diagnosedaten zur Problembehandlung des Informationsspeichers" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Langsame VSS-Snapshot-Aufrufe
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-13

Microsoft® Exchange Server Analyzer Tool untersucht das FCL-Protokoll (Function Call Log) von Exchange, die Datei Store.fcl, auf Ereignisse der VSS-Snapshot-Komponente (Volume Shadow Copy Service, Volumeschattenkopie-Dienst), die eine Antwortzeit von 20 Sekunden überschreiten.

Ereignisse der Exchange FCL-VSS-Komponente stellen Funktionsaufrufe des Microsoft Exchange-Informationsspeicherdienstes (Store.exe) an die VSS-Snapshot-Komponente dar.

Bei VSS handelt es sich um eine Reihe von COM-APIs, die ein Framework implementieren, das die Durchführung von Volumesicherungen ermöglicht, während die Anwendungen in einem System weiterhin auf die Datenträger schreiben können.

Microsoft Exchange Server 2003 verwendet den Volumeschattenkopie-Dienst, der im Betriebssystem Microsoft Windows Server™ 2003 enthalten ist, um Volumeschattenkopien von Exchange Server 2003-Datenbanken und Transaktionsprotokolldateien zu erstellen.

Ein VSS-Snapshot ist nicht vollkommen unabhängig von den Originaldaten. Snapshots werden im Allgemeinen erstellt, wenn Sie eine zeitliche Markierung definieren und gewährleistet wird, dass die Daten zu diesem Zeitpunkt wiederhergestellt werden können.

Wenn Exchange Server Analyzer feststellt, dass Ereignisse in der Datei Store.fcl für Funktionsaufrufe der VSS-Snapshot-Komponente vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) eine Antwortzeit von mehr als 20 Sekunden aufweisen, wird ein Fehler angezeigt.

Wenn komponentenübergreifende Aufrufe vom Microsoft Exchange-Informationsspeicherdienst (Store.exe) auf eine Antwort warten, können RPC-Threads (Remote Procedure Call, Remoteprozeduraufruf) diese Anforderungen im Hintergrund unterstützen, sodass es zu Exchange Server-Leistungsproblemen kommt, z. B. zu Verzögerungen der Serverantworten an die Clients.

Hinweis:
Wenn ein VSS-Snapshot absichtlich innerhalb von 20 Sekunden der Erfassung der Exchange-Ablaufverfolgungsprotokollierung für Aufrufe eingeleitet wurde, können Sie diese Fehlermeldung als Hinweis auf ein Exchange Server-Leistungsproblem ignorieren.

Im Rahmen bewährter Methoden sollte darauf geachtet werden, dass sich Sicherungsfenster nicht mit Onlinewartungs- oder Spitzennutzungsintervallen überlappen.

Weitere Informationen

Weitere Informationen zu VSS finden Sie unter "Best Practices for Using Volume Shadow Copy Service with Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=56571).


Ein Fehlerereignis "SMTPSVC" (ID: 429) wurde innerhalb der letzten 24 Stunden protokolliert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-03-16

Das Tool Microsoft Exchange Analyzer fragt die IIS-Metabase ab, um den Wert der Eigenschaft LM/SmtpSvc/%SMTPInstance%/ServerState für jede Instanz eines virtuellen SMTP-Servers (Simple Mail Transfer Protocol) zu ermitteln.

Die Eigenschaft ServerState zeigt den aktuellen Zustand der Serverinstanz. Die Zustände und entsprechenden Codes lauten wie folgt: 1 (Wird gestartet), 2 (Gestartet), 3 (Wird beendet), 4 (Beendet), 5 (Wird angehalten), 6 (Angehalten) oder 7 (Wird fortgesetzt).

Wenn Exchange Analyzer feststellt, dass der Wert für die Eigenschaft ServerState für eine virtuelle SMTP-Serverinstanz nicht gleich 2 (Gestartet) ist, fragt Exchange Analyzer die Microsoft WMI-Klasse (Windows Management Instrumentation, Windows-Verwaltungsinstrumentation) Win32_NTLogEvent ab, um zu ermitteln, ob innerhalb der letzten 24 Stunden ein Ereignisfehler 429 für den SMTP-Dienst (SMTPSVC) protokolliert wurde.

Wenn Exchange Analyzer feststellt, dass die virtuelle SMTP-Serverinstanz nicht gestartet wurde und innerhalb der letzten 24 Stunden mindestens ein Ereignisfehler 429 für den SMTPSVC protokolliert wurde, zeigt Exchange Analyzer eine Warnung an.

Diese Warnung zeigt an, dass möglicherweise Probleme mit den angegebenen Verzeichnissen für die virtuelle SMTP-Serverinstanz aufgetreten sind.

SMTP ist das systemeigene E-Mail-Protokoll von Exchange Server für die Übermittlung und den Transport von E-Mail. Dies bedeutet, dass Clients SMTP zum Senden von Nachrichten und Server mit Exchange SMTP für die Zustellung von Nachrichten und Nachrichtendaten verwenden.

Wenn Nachrichten über den SMTP-Dienst auf dem Exchange-Computer eingehen, werden die Daten als EML-Datei auf die Festplatte geschrieben. In der Standardeinstellung werden diese Dateien im Ordner <Laufwerk>:\Programme\Exchsrvr\Mailroot auf der Partition gespeichert, auf der auch Exchange installiert ist.

Mögliche Ursachen für dieses Problem:

  • Der Verzeichnispfad <Laufwerk>:\Programme\Exchsrvr\Mailroot (oder die Ordner unter diesen Verzeichnispfad) wurde verschoben, fehlt oder ist fehlerhaft.

  • Die Berechtigungen für den Ordner <Laufwerk>:\Programme\Exchsrvr\Mailroot oder für Ordner unter diesem Verzeichnispfad wurden nicht ordnungsgemäß festgelegt.

  • Eine Antivirusanwendung scannt den Verzeichnispfad <Laufwerk>:\Programme\Exchsrvr\Mailroot oder Ordner unter diesem Verzeichnispfad.

Um diese Warnung zu beheben, führen Sie einen oder mehrere der folgenden Schritte aus:

  • Überprüfen Sie den Speicherort und die Integrität des Verzeichnispfads <Laufwerk>:\Programme\Exchsrvr\Mailroot oder der Ordner unter diesem Verzeichnispfad.

  • Überprüfen Sie die Berechtigungen für den Verzeichnispfad <Laufwerk>:\Programme\Exchsrvr\Mailroot und für die Ordner unter diesem Verzeichnispfad.

  • Stellen Sie sicher, dass keine Antivirusanwendungen die Ordner im Verzeichnispfad <Laufwerk>:\Programme\Exchsrvr\Mailroot scannen.

So überprüfen Sie den Verzeichnispfad "Mailroot" unter Exchange Server 2003

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Server, erweitern Sie einen Exchange-Server, erweitern Sie Protokolle, und erweitern Sie dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise den virtuellen Standardserver für SMTP), und klicken Sie dann auf Beenden.

  4. Klicken Sie mit der rechten Maustaste erneut auf den virtuellen SMTP-Server, und klicken Sie dann auf Eigenschaften.

  5. Klicken Sie auf die Registerkarte Nachrichten.

  6. Überprüfen Sie im Feld Warteschlangenverzeichnis den vollständigen Pfad des entsprechenden Ordners Mailroot. Sie können auf Durchsuchen klicken, um den Pfad auf dem lokalen Computer zu suchen.

  7. Klicken Sie auf OK, um die Änderungen zu speichern.

  8. Klicken Sie mit der rechten Maustaste auf Ihren virtuellen SMTP-Server, und klicken Sie dann auf Starten.
So überprüfen Sie den Verzeichnispfad "Mailroot" unter Exchange 2000 Server

  1. Beenden Sie auf dem Computer mit Exchange 2000 Server, dessen Ordner Mailroot des virtuellen SMTP-Servers Sie überprüfen möchten, alle Exchange Server- und IIS-Dienste.

  2. Vergewissern Sie sich, dass der Wert für msExchSmtpQueueDirectory des betroffenen virtuellen SMTP-Servers für den entsprechenden Pfad konfiguriert ist.

  3. Warten Sie darauf, dass Active Directory diese Änderung auf die globalen Katalogserver repliziert, die von diesem Exchange-Server verwendet werden.

  4. Starten Sie den Dienst Microsoft Exchange-Systemaufsicht.

  5. Überprüfen Sie den Computer mit Exchange Server darauf, ob im Ereignisprotokoll der Anwendung drei Instanzen der Ereignis-ID 1005 vorhanden sind, die über eine Ereignisquelle von MSExchangeMU und eine Kategorie von General verfügen.

  6. Starten Sie den Computer mit Exchange Server neu, damit die Änderungen wirksam werden.
So überprüfen Sie die Standardberechtigungen für den Verzeichnispfad "Mailroot" in Exchange 2000 Server and Exchange Server 2003

  1. Starten Sie Windows-Explorer, und navigieren Sie dann zum Ordner Exchsvr. Erweitern Sie diesen Ordner.

  2. Klicken Sie mit der rechten Maustaste auf den Ordner Mailroot, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf die Registerkarte Sicherheit, und überprüfen Sie dann die folgenden Standardberechtigungen:

Konto | Berechtigungen
Administratoren | Vollzugriff
Authentifizierte Benutzer | Lesen und Ausführen, Ordnerinhalt ausführen, Lesen
Ersteller-Besitzer | Keine
Server-Operatoren | Ändern, Lesen und Ausführen, Ordnerinhalt ausführen, Lesen, Schreiben
System | Vollzugriff
  1. Vergewissern Sie sich, dass diese Standardberechtigungen für alle Ordner für jede virtuelle Serverinstanz vorhanden sind.

Weitere Informationen zu den beschriebenen Verfahren finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 822933, "Ändern des Speicherorts des SMTP-Mailroot-Ordners von Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822933)

  • 318230, „XCON: Ändern des Speicherorts des SMTP-Mailroot-Verzeichnisses von Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=318230)

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 266686, "XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163, "XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

Weitere Informationen zum Konfigurieren von Antivirusanwendungen für die Verwendung mit Exchange finden Sie unter Es wurden keine Ausschlüsse von Anti-Virus-Ordnern konfiguriert.

Detaillierte Informationen zum Konfigurieren von Ausschlüssen für die Virusüberprüfung mit RealTime in Symantec AntiVirus Corporate Edition finden Sie auf der Website von Symantec (http://www.symantec.com/).

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.

Weitere Informationen zum Schutz von Exchange Server-Umgebungen vor durch E-Mail-Nachrichten übertragenen Viren und Würmern finden Sie unter "Behindern und Blockieren von E-Mail-Viren in einer Exchange 2003-Umgebung" (http://go.microsoft.com/fwlink/?LinkId=47587).

Weitere Informationen zum Verwenden von Antivirussoftware mit Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 328841, "Exchange und Antivirussoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, "Überblick über Exchange Server 2003 und Antivirussoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, "XGEN: Die Position von Microsoft zum Thema Antiviruslösungen für Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, "XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie unter "Exchange Server 2007-Partners: Antivirus, Antispam" (http://go.microsoft.com/fwlink/?linkid=16226).


Vollqualifizierter Domänenname der SMTP-Instanz stimmt nicht mit dem Servernamen überein
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-07

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um zu ermitteln, ob der Wert der ncacn_ip_tcp:-Zeichenfolge des networkAddress-Attributs für das Serverobjekt mit dem vollqualifizierten Domänennamen (Fully Qualified Domain Name, FQDN) des msExchSmtpFullyQualifiedDomainName-Attributs für das virtuelle SMTP-Serverobjekt (Simple Mail Transfer Protocol) übereinstimmt.

Wenn Exchange Server Analyzer feststellt, dass die Werte dieser Attribute nicht übereinstimmen, wird eine Warnung angezeigt:

Diese Warnung weist darauf hin, dass die Werte dieser Attribute möglicherweise manuell geändert wurden und Nachrichtenflussprobleme auf diesem Server verursachen können.

Der Wert des msExchSmtpFullyQualifiedDomainName-Attributs gibt den FQDN des virtuellen SMTP-Servers an und muss vom DNS-Netzwerkprotokoll (Domain Name System) aufgelöst werden können.

Für den Wert dieses Attributs muss ein gültiger HOST (A)-Eintrag in DNS vorhanden sein, damit Messagingserver, die den FQDN des virtuellen SMTP-Servers auflösen müssen, die richtige IP-Adresse abrufen und die Nachrichten entsprechend weiterleiten können.

Weitere Informationen zum DNS-Reverse-Lookup-Feature in Exchange finden Sie unter "Add a resource record to a DNS zone" unter http://go.microsoft.com/fwlink/?LinkId=63002.

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Knowledge Base-Artikeln:

  • 266686, "XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163, "XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

Weitere Informationen zum Aufbau des SMTP-Dienstes finden Sie unter "SMTP Service Design" in Technical Reference Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=58876).


Die Länge der lokalen SMTP-Warteschlange hat den Schwellenwert überschritten
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-04-20

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Local Queue Length-Leistungsindikator des SMTP Server-Leistungsobjekts.

Wenn Exchange Server Analyzer feststellt, dass der Leistungsindikator Local Queue Length den Spitzenwert von 100 während des Erfassungszeitraums überschritten hat, wird ein Fehler angezeigt.

Der Leistungsindikator SMTP Server\Local Queue Length gibt die Anzahl der Nachrichten in der SMTP-Warteschlange (Simple Mail Transfer Protocol) zur lokalen Übermittlung an den Microsoft Exchange-Informationsspeicherdienst an. Daten der lokalen SMTP-Warteschlange (Verzeichnis Mailroot) werden vorübergehend im Speichergerät zurückgehalten, während sie von Exchange Server verarbeitet werden. Dieses Design verhindert, dass Daten verloren gehen, wenn es zu Serverfehlern kommt. Sollte also beispielsweise ein Zielserver nicht erreichbar sein, werden die Nachrichten, die an diesen Server weitergeleitet werden sollten, im Warteschlangenverzeichnis auf dem lokalen Server gespeichert, bis sie übermittelt werden können.

Dieser Fehler weist auf ein Leistungsproblem oder auf Ausfälle auf dem Server hin, weil der Server die eingehenden E-Mail-Nachrichten nicht mehr zeitgerecht übermitteln kann. Durch die folgenden Bedingungen kann diese Verzögerung verursacht werden:

  • Der Active Directory®-Verzeichnisdienst wird nicht unverzüglich abgefragt.

  • Nachrichten werden nicht unverzüglich zur lokalen Übermittlung oder an SMTP übergeben.

  • Die Bereitstellung von Datenbanken (Postfachspeicher und Informationsspeicher für Öffentliche Ordner) wurde aufgehoben.

  • Um dieses Problem zu beheben, führen Sie folgende Schritte aus:

  • Stellen Sie sicher, dass alle Datenbanken (Postfachspeicher und Informationsspeicher für Öffentliche Ordner) bereitgestellt sind.

  • Identifizieren Sie die Ursache für den Leistungsengpass. Ein Leistungsengpass kann mit dem Prozessor (CPU), der Festplatte, dem Netzwerk oder dem Arbeitsspeicher in Zusammenhang stehen. Außerdem kann er von einem Ansteigen der Last auf dem Server oder durch nicht ausreichende Serverressourcen verursacht werden. Ermitteln Sie mithilfe des Systemmonitors (Perfmon.msc), ob der Engpass von einer erhöhten Serverlast verursacht wird oder weil der Server unterdimensioniert ist. Wenn die Serverlast angestiegen ist, müssen Sie die Quelle der Last ausfindig machen und sie verringern. Verfügt der Server nicht über ausreichende Ressourcen, erhöhen Sie die notwendigen Ressourcen oder verschieben Benutzer von diesem Server auf einen anderen.

  • Überwachen Sie externe Abhängigkeiten, wie z. B. den Active Directory-Verzeichnisdienst, auf Leistungsprobleme und analysieren und behandeln Sie diese entsprechend.

Weitere Informationen

  • Weitere Informationen zur Feinabstimmung des SMTP-Transports finden Sie unter „SMTP Transport Tuning" im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen bei der Nachrichtenübermittlung finden Sie im Microsoft Knowledge Base-Artikel 823489, „So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Weitere Informationen zur Behandlung von Transportproblemen finden Sie im Microsoft Knowledge Base-Artikel 257265, „Allgemeine Behandlung von Transportproblemen in Exchange 2000 Server und in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265).

  • Weitere Informationen über Leistungsengpässe bei Prozessoren finden Sie unter Prozessorengpass.

  • Weitere Informationen über Leistungsengpässe bei Festplatten finden Sie unter Datenträgerengpass wurde festgestellt.

  • Weitere Informationen zur Leistung von Exchange Server finden Sie im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange Server finden Sie im Handbuch Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen zum Verschieben von Benutzerpostfächern zur Verringerung der Serverlast finden Sie unter Verschieben von Benutzerpostfächern auf einen anderen Server.


Das Leistungsüberwachungsobjekt „SMTP Server" ist nicht vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Local Queue Length-Leistungsindikator des SMTP Server-Leistungsobjekts. Wenn gültige Daten nicht vom Indikator zurückgegeben werden, zeigt Microsoft Exchange Server Analyzer eine Basislinienmeldung an.

Wenn vom Erfassungsmodul für Leistungsdaten keine gültigen Daten zurückgegeben werden, liegt mindestens eine der der folgenden Bedingungen vor:

  • Das SMTP Server-Leistungsobjekt ist deaktiviert.

  • Das SMTP Server-Leistungsüberwachungsobjekt fehlt oder ist beschädigt.

  • Microsoft Exchange Server Analyzer verfügt nicht über entsprechende Berechtigungen zum Zugreifen auf die Leistungsobjekte.

Die ersten beiden Bedingungen treten auf, wenn die Registrierung von bestimmten erweiterbaren Indikatoren beschädigt wird oder wenn die Registrierung von auf Microsoft WMI (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) basierten Programmen geändert wird. Im folgenden Verfahren wird die Behebung der ersten beiden Bedingungen erläutert. Überprüfen Sie vor dem Ausführen des Verfahrens, ob Microsoft Exchange Server Analyzer über entsprechende Berechtigungen verfügt. Weitere Informationen zu den Berechtigungen, die zum Ausführen von Microsoft Exchange Server Analyzer erforderlich sind, finden Sie in der im Lieferumfang von Microsoft Exchange Server Analyzer enthaltenen Hilfedokumentation. Wenn Sie Hilfe erhalten möchten, öffnen Sie Exchange Server Analyzer, und drücken Sie F1.

So beheben Sie diesen Fehler

  1. Überprüfen Sie, ob das SMTP Server-Leistungsobjekt aktiviert ist.

    1. Downloaden und installieren Sie das Tool Extensible Performance Counter List (Exctrlst.exe). Sie können Exctrlst.exe downloaden von der Website „Exctrlst.exe: Extensible Performance Counter List" (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Öffnen Sie die Datei Exctrlst.exe, klicken Sie auf Sortierreihenfolge und anschließend auf Dienst.

    3. Suchen Sie den Dienst, über den das Leistungsobjekt eine Meldung ausgeben soll, und überprüfen Sie, ob das Kontrollkästchen Leistungsindikatoren aktiviert aktiviert ist.

      Wenn das Kontrollkästchen Leistungsindikatoren aktiviert nicht aktiviert ist, aktivieren Sie es, und starten Sie den Dienst neu, der dem Leistungsindikator zugeordnet ist, um zu überprüfen, ob die Leistungsindikatoren betriebsbereit sind. Wenn die Leistungsindikatoren nicht betriebsbereit sind oder wenn das Kontrollkästchen Leistungsindikatoren aktiviert bereits aktiviert wurde, fahren Sie mit Schritt 2 fort.

  2. Erstellen Sie die nicht vorhandenen oder beschädigten Leistungsindikatoren wie im Microsoft Knowledge Base-Artikel 300956 „Manuelles Neuerstellen der Werte der Leistungsindikatorenbibliothek" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956) beschrieben neu.

  3. Wenn Sie das Problem anhand dieses Knowledge Base-Artikels nicht beheben lässt, müssen Sie das Windows-Betriebssystem im Modus Reparieren erneut installieren und die aktuellsten Windows-Service Packs anwenden.


SQL Server führt Virtual Server 2005 aus, wobei Exchange Server als Gast installiert ist.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_ComputerSystem ab, um zu ermitteln, ob der Wert für den Schlüssel Model auf Virtual Machine festgelegt ist.

Exchange Server Analyzer überprüft auch den folgenden Registrierungswert:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Zusätzlich fragt Exchange Server Analyzer die WMI-Klasse Win32_Services ab, um zu ermitteln, ob der Microsoft SQLServer™-Dienst (MSSQLSERVER) auf dem physischen Computer aktiv ist, auf dem auch Microsoft Virtual Server 2005 ausgeführt wird.

Wenn Exchange Server Analyzer erkennt, dass der Schlüssel Model die Zeichenfolge Virtual Machine enthält, dass der obige Registrierungszweig vorhanden ist und dass MSSQLSERVER ausgeführt wird, wird eine Fehlermeldung angezeigt.

Der Wert Virtual Machine für den Schlüssel Model zeigt an, dass der Exchange Server-Computer als virtueller Gastcomputer unter Virtual Server 2005 oder Microsoft Virtual PC 2004 ausgeführt wird. Da der oben genannte Registrierungszweig jedoch nur von Virtual Server 2005 erstellt wird, bedeutet sein Vorhandensein, dass der Exchange Server-Computer als virtueller Gastcomputer unter Virtual Server 2005 ausgeführt wird.

Das Ausführen einer beliebigen Version von Microsoft Exchange auf einem virtuellen Computer oder einem Emulator wird von Microsoft nicht unterstützt. Dies gilt für Exchange Server unter Microsoft Virtual Server 2005, Microsoft Virtual PC 2004 und sämtliche Anwendungen für virtuelle Computer von Drittanbietern. Microsoft Exchange-Server wurden so entwickelt und getestet, dass sie nur auf realer Hardware, insbesondere auf den Hardwareplattformen ausgeführt werden können, die im Windows-Serverkatalog unter http://go.microsoft.com/fwlink/?linkid=17219 aufgeführt sind.

Außerdem stellt das Ausführen von Exchange als Gast eines virtuellen Servers auf einem SQL Server-Computer keine empfohlene Vorgehensweise dar, da dies keine ausreichende Redundanz zwischen Diensten ermöglicht.

So berichtigen Sie diesen Fehler

  1. Verschieben Sie die Postfächer aus dem Exchange Server, der unter Virtual Server 2005 ausgeführt wird, auf auf einen nicht virtuellen Exchange Server-Computer.

  2. Lagern Sie beliebige Öffentliche Ordner aus, und übertragen Sie beliebige Rollen, die bei Bedarf von dem virtuellen Exchange-Server übernommen werden.

  3. Deinstallieren Sie Exchange von dem virtuellen Computer, um das Produkt außer Betrieb zu nehmen und aus Ihrer Exchange-Infrastruktur und aus dem Active Directory®-Verzeichnisdienst zu entfernen.

Weitere Informationen zum Verschieben von Postfächern finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 822892, „Move Mailbox improvements in Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975, „XADM: Differences Between Move Mailbox Methods" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

Weitere Informationen zu Unterstützung für in virtuellen Umgebungen ausgeführte Exchange Server-Computer finden Sie im Knowledge Base-Artikel 320220 „Support Boundaries for Exchange Server on a Virtual Machine or an Emulation Machine" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).

Weitere Informationen zu Microsoft Virtual Server 2005 finden Sie auf der Microsoft Virtual Server 2005-Website unter http://go.microsoft.com/fwlink/?linkid=34938.

Weitere Informationen zu Microsoft Virtual PC 2004 finden Sie auf der Microsoft Virtual PC 2004-Website unter http://go.microsoft.com/fwlink/?linkid=34663.


SRS port is below 5000
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Einstellung TCP/IP für den Microsoft Exchange-Standortreplikationsdienst zu ermitteln:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

Wenn Exchange Server Analyzer feststellt, dass TCP/IP auf einen Wert unter 5.000 (Dezimalwert) festgelegt ist, wird eine Warnung angezeigt.

Wenn Sie TCP/IP auf einen statischen Wert festlegen müssen, empfiehlt es sich, diesen auf einen Wert festzulegen, der etwas höher als 5.000 ist. Das Zuweisen von statischen Anschlussnummern unter 5.000 kann zu einem Anschlusskonflikt mit einem anderen Prozess und zu einem Fehler beim Prozess des Microsoft Exchange-Standortreplikationsdiensts führen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den Registrierungsschlüssel für TCP/IP fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters

  3. Doppelklicken Sie auf den Schlüssel TCP/IP, und legen Sie im Feld Datenwerte eine ganze Zahl fest, die etwas größer als 5000 (Dezimalwert) ist.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den Microsoft Exchange-Standortreplikationsdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen über Anschlussbeschränkungen finden Sie im Knowledge Base-Artikel 194952, „XADM: Statically Mapped Port Limitations for Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952).


Der SRS-Anschluss wurde manuell überschrieben
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob der Anschluss für den Microsoft Exchange-Standortreplikationsdienst manuell überschrieben wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

Wenn Exchange Server Analyzer erkennt, dass der TCP/IP vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Dieser Wert wird in den meisten Fällen konfiguriert, um MAPI-Clients das Herstellen einer Verbindung mit einem Exchange-Server zu ermöglichen, der sich auf der anderen Seite einer Firewall befindet. Hierfür müssen mehrere Ports einer Firewall geöffnet werden, damit Microsoft Office Outlook® 2003-Clients mithilfe von MAPI (in der Regel über das Internet) eine Verbindung mit einem Exchange-Server herstellen können. Die ist eine unterstützte Konfiguration. Weitere Informationen zum Konfigurieren von MAPI-Clients zum Herstellen einer Verbindung mit Exchange über eine Firewall finden Sie im Microsoft Knowledge Base-Artikel 270836, „Statische Anschlusszuordnungen in Exchange 2000 und Exchange 2003" (http://support.microsoft.com/default.aspx?scid=kb;de;270836). Wenn Sie dieses Szenario nicht verwenden, sollten Sie den Registrierungsschlüssel entfernen.

Für die Verwendung von Outlook im MAPI-Modus zum Herstellen einer Verbindung mit einem Exchange-Server über das Internet wird der Einsatz der Funktionen von RPC-über-HTTP in Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003 und Microsoft Windows® XP Professional empfohlen. Der MAPI-Modus wurde früher als „Firmenmodus" oder „Arbeitsgruppenmodus" bezeichnet.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So entfernen Sie den TCP/IP-Registrierungsschlüssel

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters

  3. Löschen Sie den Registrierungswert TCP/IP.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Standortreplikationsdienst neu.

So stellen Sie RPC-über-HTTP bereit

  1. Lesen Sie „Exchange Server 2003 RPC over HTTP Deployment Scenarios" unter http://go.microsoft.com/fwlink/?linkid=47577.

  2. Lesen Sie den Microsoft Knowledge Base-Artikel 833401, „Konfigurieren von RPC-über-HTTP auf einem einzelnen Server in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  3. Lesen Sie den Knowledge Base-Artikel 827330, „Behandlung von Problemen bei RPC-über-HTTP-Clientverbindungen in Office Outlook 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  4. Lesen Sie den Microsoft Support WebCast „Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Das für die Systemaufsicht konfigurierte Startkonto wird nicht unterstützt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Windows® Management Instrumentation) Win32_Services ab, um zu ermitteln, ob das in der Eigenschaft StartName des Microsoft Exchange-Systemaufsichtsdienstes (MSExchangeISA) angegebene Startkonto das Konto LocalSystem verwendet. Wenn Exchange Server Analyzer feststellt, dass der Wert der Eigenschaft StartName auf einem Exchange 2000 Server oder einem Exchange Server 2003-Computer ein anderes Konto als das Konto LocalSystem ist, wird eine Fehlermeldung angezeigt. Das Konto LocalSystem wird auch als SYSTEM bezeichnet.

MSExchangeSA muss in Exchange 2000 Server und Exchange Server 2003 im Sicherheitskontext LocalSystem gestartet werden. MSExchangeSA darf nicht durch das Zuweisen eines bestimmten Benutzerkontos gestartet werden. Wenn ein als LocalSystem ausgeführter Exchange-Dienst auf einen Remoteserver zugreift, erfolgt anhand der Anmeldeinformationen des Computerkontos die Authentifizierung des Exchange-Dienstes.

Durch den Standardmechanismus zum Ändern von Kennwörtern wird das Kennwort des Computerkontos alle sieben Tage geändert. Durch das Ändern des Kennworts im Intervall von sieben Tagen wird die Sicherheit des Computerkontos erhöht. Aus den folgenden Gründen ist das Computerkonto sicherer als ein typisches Benutzerkonto:

  • Das Kennwort eines typischen Benutzerkontos wird seltener geändert.

  • Das Kennwort eines typischen Benutzerkontos ist weniger zufällig als ein nach dem Zufallsprinzip erstelltes Computerkontokennwort.

In Exchange Server 5.5 werden Benutzerkonten für Dienste verwendet. Einige Administratoren, die Erfahrung mit Exchange Server 5.5 haben, ändern das Startkonto für Exchange 2000 Server-Dienste und Exchange Server 2003-Dienste aus dem Standardkonto LocalSystem in ein Benutzerkonto.

Für Exchange 2000 Server und Exchange Server 2003 wird das Ausführen von MSExchangeSA auf einem anderen Konto als LocalSystem nicht von Microsoft unterstützt.

So beheben Sie diesen Fehler

  1. Klicken Sie auf das Menü Start, zeigen Sie dort auf Programme und Verwaltung, und klicken Sie auf Dienste.

  2. Klicken Sie in der Liste der Dienste mit der rechten Maustaste auf Microsoft Exchange-Systemaufsicht, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Anmelden unter Anmelden als auf Lokales Systemkonto, und klicken Sie dann auf OK.

  4. Klicken Sie mit der rechten Maustaste auf den Dienst Microsoft Exchange-Systemaufsicht, und klicken Sie dann auf Neu starten.

Weitere Informationen über Exchange-Dienste finden Sie im Microsoft Knowledge Base-Artikel 239762, „Exchange Services Run Under LocalSystem" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762.


Datei „STORE.EXE" fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um das Vorhandensein einer Reihe von binären Exchange-Kerndateien zu ermitteln:

  • Exres.dll

  • Gapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapi32.dll (überprüft in den Ordnern System32 und \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere der obigen Dateien nicht vorhanden sind, wird ein Fehler angezeigt. Um diesen Fehler zu beheben, installieren Sie das aktuelle Service Pack, oder führen Sie ein Rollup für die vorhandene Exchange-Version aus. Wenn der Fehler weiterhin auftritt, führen Sie das Setupprogramm für Exchange 2000 Server oder Exchange Server 2003 aus, und wählen Sie die Option Erneut installieren aus. Bei der Ausführung von Setup im Modus Erneut installieren werden nur binäre Dateien installiert. Dabei werden keine Benutzer- oder Konfigurationsdaten entfernt oder zurückgesetzt. Wenn Sie Exchange Server erneut installieren, müssen Sie auch die zuvor installierten Exchange-Service Packs und -Hotfixes neu installieren.

So installieren Sie Exchange 2000 Server oder Exchange Server 2003 erneut

  1. Melden Sie sich an dem Server an, auf dem Exchange erneut installiert werden soll. Legen Sie die Exchange 2000 Server- bzw. Exchange Server 2003-CD in das CD-ROM-Laufwerk ein.

  2. Klicken Sie im Menü Start auf Ausführen, und geben Sie anschließend <Laufwerk>:\setup\i386\setup ein, wobei <Laufwerk> für das CD-ROM-Laufwerk steht.

  3. Klicken Sie auf der Seite Willkommen beim Assistenten für die Installation von Exchange auf Weiter.

  4. Lesen Sie auf der Seite Lizenzvertrag den Lizenzvertrag durch. Klicken Sie auf Ich stimme zu, falls Sie den Bestimmungen zustimmen, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der Seite Product ID den 25-stelligen Produktschlüssel ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der Seite Auswahl der Komponenten in der Spalte Vorgang neben dem Knoten Microsoft Exchange auf den Dropdownpfeil, wählen Sie die Option Erneut installieren aus, und klicken Sie dann auf Weiter.

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange Server 2003 finden Sie auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu den aktuellen Service Packs, Update-Rollups und Add-Ins für Exchange 2000 Server finden Sie auf der Exchange Server 2000-Website für Downloads (http://go.microsoft.com/fwlink/?LinkId=33457).


"Store HTTP"-Portnummer liegt unter 5000
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-03-21

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Einstellung Rpc/HTTP Port für den Microsoft Exchange-Informationsspeicherdienst zu ermitteln:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

Wenn Exchange Server Analyzer feststellt, dass der Wert für Rpc/HTTP Port auf einen Wert unter 5000 (Dezimalwert) festgelegt ist, wird eine Warnung angezeigt.

Der Registrierungsschlüssel Rpc/HTTP Port wird vom Setup von Exchange Server 2003 und Exchange Server 2007 auf 6001 festgelegt. Mit dem Registrierungsschlüssel Rpc/HTTP Port wird die RPC-über-HTTP-Funktion für Microsoft Office Outlook® 2003 und Microsoft Office Outlook 2007 unterstützt.

Wenn Sie die RPC-über-HTTP-Bereitstellung nicht mithilfe von Microsoft Consulting Services oder nach Empfehlung des technischen Supports von Microsoft angepasst haben, wird empfohlen, RPC-über-HTTP mit den Standardportwerten bereitzustellen.

Wenn Sie die Einstellung für Rpc/HTTP Port auf einen Wert ungleich 6001 festlegen müssen, sollten Sie sie auf einen Wert festlegen, der etwas höher als 5000 ist. Das Zuweisen von statischen Portnummern unter 5000 kann zu einem Portkonflikt mit einem anderen Vorgang und zu einem Fehler beim Prozess für die Microsoft Exchange-Systemaufsicht führen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den Registrierungswert Rpc/HTTP Port auf den Standardwert fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

  3. Doppelklicken Sie auf den Schlüssel Rpc/HTTP Port, und legen Sie das Feld Datenwerte auf 6001 (Dezimalwert) oder auf eine ganze Zahl fest, die etwas größer als 5000 (Dezimalwert) ist.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den Computer neu, damit die Einstellung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Konfigurieren von RPC-über-HTTP finden Sie in den folgenden Knowledge Base-Artikeln:

  • 833401, „Konfigurieren von RPC-über-HTTP auf einem einzelnen Server in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, „Behandlung von Problemen bei RPC-über-HTTP-Clientverbindungen in Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


Speicher: Der HTTP-Anschluss weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-09

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob HTTP Port auf den Standardwert festgelegt ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

Wenn Exchange Server Analyzer feststellt, dass der Wert für Rpc/HTTP Port nicht 6001 (Dezimalwert) beträgt, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Registrierungsschlüssel Rpc/HTTP Port wird vom Setup von Exchange Server 2003 und Exchange Server 2007 auf 6001 festgelegt. Mit dem Registrierungsschlüssel Rpc/HTTP Port wird die RPC-über-HTTP-Funktion für Microsoft Office Outlook® 2003 und Microsoft Office Outlook 2007 unterstützt.

Wenn Sie die RPC-über-HTTP-Bereitstellung nicht mithilfe von Microsoft Consulting Services oder nach Empfehlung des technischen Supports von Microsoft angepasst haben, wird empfohlen, RPC-über-HTTP mit den Standardanschlusswerten bereitzustellen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den Registrierungsschlüssel für den RPC/HTTP-Anschluss auf den Standardwert fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Doppelklicken Sie auf den Schlüssel Rpc/HTTP Port, und legen Sie das Feld Wert auf 6001 (Dezimalwert) fest.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den Computer neu, damit die Einstellung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Konfigurieren von RPC-über-HTTP finden Sie in den folgenden Knowledge Base-Artikeln:

  • 833401, „Konfigurieren von RPC-über-HTTP auf einem einzelnen Server in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, „Behandlung von Problemen bei RPC-über-HTTP-Clientverbindungen in Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


Nicht optimale Speichereinstellungen
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-02-15

Microsoft Exchange Analyzer fragt die Microsoft WMI-Klasse (Windows Management Instrumentation - Windows-Verwaltungsinstrumentation) Win32_NTLogEvent ab, um zu ermitteln, ob innerhalb der letzten 24 Stunden für MSExchangeIS eine Warnung für ein Ereignis 9665 aufgetreten ist.

Microsoft Exchange Server 2003 überprüft zu Beginn des Speicherprozesses, ob eine optimale Speicherkonfiguration vorliegt. Sind die Speichereinstellungen nicht optimal, wird das Ereignis 9665 in der Ereignisanzeige angezeigt.

Wenn Exchange Analyzer feststellt, dass das Ereignis 9665 in den letzten 24 Stunden protokolliert wurde, liest er das Datenfeld des Ereignisses, um zu ermitteln, welches der möglichen Flags aus der nachfolgenden Tabelle für das Ereignis vorliegt.

Ereignisdatenfeld-Flag | Angezeigte Exchange Server Analyzer-Warnung | Exchange Server 2003-Problem
0x00000001 | Die Option /3GB wurde nicht festgelegt. | Auf dem Server wird Microsoft Windows 2000 Advanced Server oder Microsoft Windows 2000 Datacenter Server ausgeführt, er verfügt über 1 GB oder mehr physischen Arbeitsspeicher, aber in der Datei BOOT.INI wurde die Option /3GB nicht festgelegt.
0x00000002 | Die Option /Userva wurde nicht ordnungsgemäß festgelegt. | Auf dem Server wird Microsoft Windows Server 2003 Standard Edition, Microsoft Windows Server 2003 Enterprise Edition oder Microsoft Windows Server 2003 Datacenter Edition ausgeführt, er verfügt über 1 GB oder mehr physischen Arbeitsspeicher, und die Option /3GB wurde festgelegt, aber in der Datei BOOT.INI wurde die /USERVA-Einstellung nicht festgelegt.
0x00000004 | Die SystemPages-Einstellung muss festgelegt werden. | Auf dem Server wird eine beliebige Edition von Microsoft Windows 2000 Server ausgeführt, und der Registrierungsschlüssel SystemPages ist nicht auf einen Wert zwischen 24.000 und 31.000 festgelegt.
0x00000008 | Die SystemPages-Einstellung muss zurückgesetzt werden. | Auf dem Server wird Microsoft Windows Server 2003 Standard, Microsoft Windows Server 2003 Enterprise oder Microsoft Windows Server 2003 Datacenter Edition ausgeführt, und der Registrierungsschlüssel SystemPages ist nicht auf "0" festgelegt.
0x00000010 | Die HeapDecommitFreeBlockThreshold-Einstellung ist nicht ordnungsgemäß festgelegt. | Auf dem Server wird eine beliebige Edition von Microsoft Windows 2000 Server oder Microsoft Windows Server 2003 ausgeführt, und der Registrierungsschlüssel HeapDeCommitFreeBlockThreshold ist nicht auf den Wert "0x00040000" festgelegt.

Abhängig vom Flag im Datenfeld des Ereignisses 9665 zeigt Exchange Analyzer die entsprechende Warnung aus der oben dargestellten Tabelle an.

Diese Warnungen weisen darauf hin, dass die Konfiguration des Exchange Server-Speichers nicht optimal ist.

Um diese Warnungen zu beheben, befolgen Sie die Anweisungen in den jeweiligen problemspezifischen Exchange Analyzer-Artikeln:

  • Dieser Exchange-Postfachserver verfügt über 1 GB Arbeitsspeicher oder mehr, allerdings ist für ihn in der Datei „Boot.ini" der Schalter „/3GB" nicht festgelegt

  • USERVA wird falsch festgelegt

  • SystemPages wurde zu hoch festgelegt.

  • Dieser Server führt Windows Server 2003 aus, und der SystemPages-Wert ist ungleich 0.

  • Dieser Server verfügt über 1 GB oder mehr physischen Arbeitsspeicher, und „HeapDeCommitFreeBlockThreshold" wurde nicht auf „262144" festgelegt

Weitere Informationen

Weitere Informationen zu diesen Problemen finden Sie im Microsoft Knowledge Base-Artikel 325044, "Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange Server 2003 und Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044).

Weitere Informationen zum MSExchangeIS-Ereignis 9665 finden Sie unter "Events and Errors Message Center: Ereignisdetails".

  • Weitere Informationen zum Postfachspeicher-Ereignis 9665 finden Sie unter http://go.microsoft.com/fwlink/?LinkId=83210.

  • Weitere Informationen zum öffentlichen Speicher-Ereignis 9665 finden Sie unter http://go.microsoft.com/fwlink/?LinkId=83213.


Verdächtige Virensuchprogramme auf Clients installiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-09-05

Microsoft® Exchange Server Analyzer hat festgestellt, dass viele Ihrer Benutzer eine Antivirussoftware verwenden. Antivirussoftware kann viele Remoteprozeduraufrufe (RPCs) an bereitgestellte Postfächer eines Benutzers erstellen sowie erheblichen Verkehr zu den Öffentlichen Ordnern verursachen, weil die Antivirussoftware die Dateistruktur des Informationsspeicher für Öffentliche Ordner langsam durchsucht. Viele Suchalgorithmen durchsuchen öffentliche Ordner nur dann, wenn diese zur Favoritenliste der öffentlichen Ordner des Benutzers gehören. Deshalb ist es nicht sicher, dass Sie die aus dem Einsatz von Antivirussoftware resultierende Last auf den Servern mit Öffentlichen Ordners erkennen.

Die folgenden Maßnahmen können Sie ergreifen, um dieses Problem zu umgehen:

  • Lassen Sie Ihre Benutzer die Microsoft Office Outlook®-Funktionen des Virensuchprogramms deaktivieren oder die Suche auf ihr persönliches Postfach beschränken.

  • Führen Sie Outlook im Zwischenspeicherungsmodus von Exchange aus, damit die Suche nur die lokale Arbeitsstation, nicht aber den Server betrifft..

  • Befolgen Sie die Anweisungen im Microsoft Knowledge Base-Artikel 889086, "Wenn Sie versuchen, auf Öffentliche Ordner in Exchange 2000 Server zuzugreifen, kann auf einem Computer unter Windows XP ein unerwartetes Verhalten auftreten" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=889086), um das Hotfix zu erhalten und den Registrierungsschlüssel MaxObjsPerMapiSession auf Computern mit Exchange Server zu setzen, auf die Benutzer mit Virensuchprogrammen zugreifen.

Wenn Sie überprüfen möchten, ob ein Virensuchprogramm die Ursache für die hohe Last eines bestimmten Benutzers ist, überwachen Sie die RPC-Operationen des Virensuchprogramms mit Microsoft Exchange Server User Monitor (ExMon). Stellen Sie sicher, dass Daten über einen ausreichend langen Zeitraum (mindestens fünf Minuten) gesammelt werden. Dann entfernen Sie die Suchmaschine, und starten Sie das ExMon-Tool erneut. Wenn die RPC-Rate signifikant abgenommen hat, haben Sie bestätigt, dass das Virensuchprogramm den Lastanstieg verursacht hat. Wenn Sie beobachten, dass die durchschnittliche RPC-Wartezeit zurückgeht, haben Sie bestätigt, dass die hohe Last zu längeren RPC-Wartezeiten geführt hat.

Hinweis:
Die RPC-Wartezeiten schwanken im Laufe eines Tages ganz erheblich. Deshalb kann ein fünfminütiger Test unzulänglich sein. Sie müssen möglicherweise über einen längeren Zeitraum messen.

Downloaden Sie ExMon vom Microsoft Download Center unter (http://go.microsoft.com/fwlink/?linkid=54983).

Weitere Informationen

  • Weitere Informationen zu Virensuchsoftware finden Sie im:

    • Microsoft Knowledge Base-Artikel 905184, „Überblick über Exchange Server 2003 und Antivirussoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184).

    • Blog des Microsoft Exchange Teams: „Are your clients using desktop search engines that index Exchange mailboxes or public folders?" (http://go.microsoft.com/fwlink/?LinkId=54475).

  • Weitere Informationen zur Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange finden Sie im Behandeln von Leistungsproblemen bei Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


SystemPages wurde zu hoch festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-03-13

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um den Wert für SystemPages zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

Wenn Exchange Server Analyzer feststellt, dass der Wert für SystemPages größer ist als 50000, zeigt Exchange Server Analyzer eine Warnung an.

Microsoft Windows Server™ 2003 und Microsoft Windows® 2000 Server können bis zu 4 GB Speicheradressraum direkt adressieren, unabhängig von der Größe des installierten physischen Arbeitsspeichers. Jedes Element einer virtuellen Adresse weist aus Prozesssicht konzeptionell auf ein Byte physischen Speichers. Es gehört zu den Aufgaben des Virtual Memory-Managers (VMM) zusammen mit der Speichermanagereinheit (MMU, Memory Manager Unit) des Prozessors, jede virtuelle Adresse in die entsprechende physische Adresse zu übersetzen bzw. sie darauf abzubilden. Der VMM führt diese Abbildung durch, indem er den RAM in Seitenframes mit fester Größe aufteilt, Seitentabelleneinträge (PTEs, Page Table Entries) zum Speichern der Informationen über diese Seitenframes erstellt und diese abbildet. Die Seitentabelleneinträge des Systems sind kleine Kernelmodus-Speicherpuffer, die verwendet werden, um mit dem Datenträger-E/A-Teilsystem und dem Netzwerk zu kommunizieren. Jeder Tabelleneintrag stellt einen Seitenframe dar und enthält die für VMM notwendigen Informationen, um eine Seite zuzuordnen.

Auf einem x86-basierten System, das eine Seitengröße von 4 KB verwendet, beträgt die Maximalanzahl der Seitentabelleneinträge, die zum Abbilden von 2 GB Adressraum benötigt wird, 524.288 (2 GB/4 KB). Auf einem vergleichbaren System, das den /3GB-Schalter verwendet, ist die Anzahl der Seitentabelleneinträge, die benötigt werden, um 3 GB Adressraum abzubilden, 786.432 (3 GB/4 KB). In einem typischen System wird dieser Raum wie folgt verwendet:

  • Ein Maximum von 50.000 Seitentabelleneinträgen (ungefähr 195 MB Adressraum) wird für allgemeine Verwendung reserviert.

  • Der Rest wird zum Abbilden von Systemcache, Hyperspace, ausgelagertem Pool, nicht ausgelagertem Pool, des Bereichs für Absturzspeicherabbild usw. verwendet.

Diese Poolgröße für Seitentabelleneinträge wird, basierend auf der im System vorhandenen Menge an physischem Speicher, automatisch beim Systemstart bestimmt. Dieser Pool wird zwischen ausgelagerten und nicht ausgelagerten Pool eingefügt, der ebenfalls mit der Größe des physischen Speichers im System wächst.

Der Pool mit Seitentabelleneinträgen kann stark verwendet und hochgradig fragmentiert werden. Dies kann z. B. zu Situationen führen, in denen ein Treiber nicht geladen wird. Wenn der PTE-Pool des Systems auf null reduziert wird, werden davon auch andere Teile des Systems beeinträchtigt. Dies führt sogar dazu, dass Threads nicht erstellt werden, dass das System blockiert und möglicherweise abstürzt.

Um die erhebliche Fragmentierung des PTE-Pools zu verhindern, sollten Sie den Registrierungswert SystemPages immer passend zum Betriebssystem Ihres Exchange Server-Computers konfigurieren. Wenn Sie Exchange Server unter Windows Server 2003 ausführen, wird empfohlen, den Registrierungsschlüssel SystemPages auf 0 festzulegen. Diese Empfehlung widerspricht der Empfehlung für Windows 2000 Server, nach der SystemPages auf einen Wert zwischen 24000 und 31000 festzulegen ist.

Nachdem Sie die nachfolgend beschriebene Prozedur ausgeführt haben, sollten Sie die Anzahl freier Seitentabelleneinträge überwachen. Hierzu können Sie den Leistungsindikator Memory | Free System Page Table Entries mit dem Windows-Systemmonitor überwachen. Wenn die Anzahl der freien Seitentabelleneinträge niedrig bleibt, nachdem Sie die Änderungen an der Registrierung wie beschrieben vorgenommen haben, sollten Sie Folgendes prüfen, um sicherzugehen, dass der Exchange Server-Computer optimal konfiguriert ist:

  • TreiberEin beschädigter Treiber ist eine der Hauptursachen einer geringen Zahl von Seitentabelleneinträgen. Außerdem ist bekannt, dass bestimmte Versionen des S3 Savage 4-Videokartentreibers den Wert für SystemPages auf 208896 festlegen. Dieser Treiber ist oft auf Servern der IBM E-Serie vorhanden. Wenden Sie sich an Ihren Hardwarehersteller, um sich zu vergewissern, ob Sie die aktuellsten Treiber für Ihre Hardware verwenden. Es kann aber auch die Möglichkeit geben, zu einem einfacheren Treiber zurückzukehren. Beispielsweise brauchen Computer, auf denen serverbasierte Anwendungen wie Exchange Server ausgeführt werden, im Allgemeinen nicht die fortgeschrittensten Videotreiber mit all ihren Eigenschaften. Stattdessen ist ein einfacherer Treiber oft ausreichend. Das Wechseln von einem fortgeschrittenen Videotreiber zu einem einfachen Videotreiber sollte die Anzahl freier Seitentabelleneinträge erhöhen.

  • Systemkonfiguration Wenn in Ihrem Windows Server 2003-System 1 GB oder mehr an physischem Speicher installiert ist, sollten Sie sich vergewissern, dass die Datei Boot.ini ordnungsgemäß mit den Schaltern /3GB und /USERVA=3030 konfiguriert ist, wie in den folgenden Microsoft Knowledge Base-Artikeln beschrieben:

    • 823440, „Sie müssen die Startoption "/3GB" verwenden, wenn Sie Exchange Server 2003 auf einem Windows Server 2003-System installieren" unter http://support.microsoft.com/kb/823440/de

    • 810371, „Using the /Userva switch on Windows Server 2003-based computers that are running Exchange Server" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371.

  • Ereignisprotokolle Prüfen Sie das Ereignisprotokoll der Anwendung auf dem Exchange-Server auf Fehler und Warnungen, insbesondere auf die MSExchangeIS-Ereignisse 9582 (Fehler und Warnungen), 9665 (Warnung) und 12880 (Fehler). Das Vorhandensein von Ereignis 9665 könnte auch anzeigen, dass SystemPages nicht für eine optimale Leistung konfiguriert ist. Weitere Informationen zu diesen Ereignissen finden Sie im Microsoft Knowledge Base-Artikel 325044, „SO WIRD'S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" unter http://support.microsoft.com/default.aspx?scid=kb;de;325044.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie unter Windows 2000 Server dieses Problem, indem Sie den Wert für „SystemPages" ändern

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Doppelklicken Sie im rechten Bereich auf SystemPages.

  4. Geben Sie im Feld Wert einen Wert zwischen 24000 und 31000 (Dezimalwert) ein, und klicken Sie dann auf OK. Wenn Sie unsicher sind, welcher Wert verwendet werden sollte, wird die Verwendung von 31000 (dezimal) empfohlen.

  5. Beenden Sie den Registrierungs-Editor, und starten Sie den Computer neu, damit die Änderung wirksam wird.

So beheben Sie unter Windows Server 2003 dieses Problem, indem Sie den Wert für „SystemPages" ändern

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Doppelklicken Sie im rechten Bereich auf SystemPages.

  4. Geben Sie im Feld Wert den Wert 0 ein, und klicken Sie dann auf OK.

  5. Beenden Sie den Registrierungs-Editor, und starten Sie den Computer neu, damit die Änderung wirksam wird.

So beheben Sie dieses Problem, indem Sie den Videotreiber aktualisieren oder ihn durch eine frühere Versionen ersetzen

  • Führen Sie einen der folgenden Schritte aus:

    • Wenden Sie sich an Ihren Hardwarehersteller, um einen aktualisierten Videotreiber zu erhalten, der die Einstellung SystemPages nicht konfiguriert.

    • Ersetzen Sie den Videotreiber durch einen Standard-VGA-Treiber, und korrigieren Sie den Wert SystemPages wie oben beschrieben.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Optimieren des Speichers für Exchange Server finden Sie in den folgenden Artikeln der Knowledge Base:

  • 325044, „SO WIRDS GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044

  • 815372, „Optimieren der Speichernutzung in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372

  • 311901, „The effects of 4GT tuning on System Page Table Entries" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901


HTTP-Portnummer zur Systemaufsicht liegt unter 5000
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-03-21

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Einstellung HTTP Port für den Microsoft Exchange-Systemaufsichtsdienst zu ermitteln:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

Wenn Exchange Server Analyzer feststellt, dass der Wert für HTTP Port auf einen Wert unter 5000 (Dezimalwert) festgelegt ist, wird eine Warnung angezeigt.

Der Registrierungsschlüssel HTTP Port wird vom Setup von Exchange Server 2003 und Exchange Server 2007 auf 6002 festgelegt. Mit dem Registrierungsschlüssel HTTP Port wird die RPC-über-HTTP-Funktion für Microsoft Office Outlook® 2003 und Microsoft Office Outlook 2007 unterstützt.

Wenn Sie die RPC-über-HTTP-Bereitstellung nicht mithilfe von Microsoft Consulting Services oder nach Empfehlung des technischen Supports von Microsoft angepasst haben, wird empfohlen, RPC-über-HTTP mit den Standardportwerten bereitzustellen.

Wenn Sie HTTP Port auf einen Wert ungleich 6002 festlegen müssen, empfiehlt es sich, einen Wert zu verwenden, der etwas höher als 5000 ist. Durch das Zuweisen statischer Portnummern unter 5000 kann ein Portkonflikt mit einem anderen Prozess verursacht werden. Dies kann zu einem Fehler beim Prozess für den Microsoft Exchange-Systemaufsichtsdienst führen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den Registrierungsschlüssel für den HTTP-Port auf den Standardwert fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Doppelklicken Sie auf den Schlüssel HTTP Port, und legen Sie das Feld Datenwerte auf 6002 (Dezimalwert) oder auf eine ganze Zahl fest, die etwas größer als 5000 (Dezimalwert) ist.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den Computer neu, damit die Einstellung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Konfigurieren von RPC-über-HTTP finden Sie in den folgenden Knowledge Base-Artikeln:

  • 833401, „Konfigurieren von RPC-über-HTTP auf einem einzelnen Server in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, „Behandlung von Problemen bei RPC-über-HTTP-Clientverbindungen in Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


HTTP NSPI-Portnummer zur Systemaufsicht liegt unter 5000
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-03-21

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Einstellung Rpc/HTTP NSPI Port für den Microsoft Exchange-Systemaufsichtsdienst zu ermitteln:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

Wenn Exchange Server Analyzer feststellt, dass der Wert für Rpc/HTTP NSPI Port auf einen Wert unter 5000 (Dezimalwert) festgelegt ist, wird eine Warnung angezeigt.

Der Registrierungsschlüssel Rpc/HTTP NSPI Port wird vom Setup von Exchange Server 2003 und Exchange Server 2007 auf 6004 festgelegt. Mit dem Registrierungsschlüssel Rpc/HTTP NSPI Port wird die RPC-über-HTTP-Funktion für Microsoft Office Outlook® 2003 und Microsoft Office Outlook 2007 unterstützt.

Wenn Sie die RPC-über-HTTP-Bereitstellung nicht mithilfe von Microsoft Consulting Services oder nach Empfehlung von Microsoft Software Services angepasst haben, wird empfohlen, RPC-über-HTTP mit den Standardportwerten bereitzustellen.

Wenn Sie die Einstellung für Rpc/HTTP NSPI Port auf einen Wert ungleich 6004 festlegen müssen, sollten Sie sie auf einen Wert festlegen, der etwas höher als 5000 ist. Das Zuweisen von statischen Portnummern unter 5000 kann zu einem Portkonflikt mit einem anderen Vorgang und zu einem Fehler beim Ablauf der Microsoft Exchange-Systemaufsicht führen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den Registrierungsschlüssel Rpc/HTTP NSPI Port auf den Standardwert fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Doppelklicken Sie auf den Schlüssel Rpc/HTTP NSPI Port, und legen Sie das Feld Datenwerte auf 6004 (Dezimalwert) oder auf eine ganze Zahl fest, die etwas größer als 5000 (Dezimalwert) ist.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den Computer neu, damit die Einstellung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Konfigurieren von RPC-über-HTTP finden Sie in den folgenden Knowledge Base-Artikeln:

  • 833401, „Konfigurieren von RPC-über-HTTP auf einem einzelnen Server in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, „Behandlung von Problemen bei RPC-über-HTTP-Clientverbindungen in Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


Systemaufsicht: Der HTTP NSPI-Anschluss weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob HTTP Port auf den Standardwert festgelegt ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

Wenn Exchange Server Analyzer feststellt, dass der Wert für Rpc/HTTP NSPI Port nicht 6004 (Dezimalwert) beträgt, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Registrierungsschlüssel Rpc/HTTP NSPI Port wird von Exchange Server 2003-Setup auf 6004 festgelegt. Mit dem Registrierungsschlüssel Rpc/HTTP NSPI Port wird die RPC-über-HTTP-Funktion für Microsoft Office Outlook® 2003 unterstützt.

Wenn Sie die RPC-über-HTTP-Bereitstellung nicht mithilfe von Microsoft Consulting Services oder nach Empfehlung des technischen Supports von Microsoft angepasst haben, wird empfohlen, RPC-über-HTTP mit den Standardanschlusswerten bereitzustellen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den Registrierungswert für den Rpc/HTTP NSPI-Anschluss fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Doppelklicken Sie auf den Schlüssel Rpc/HTTP NSPI Port, und legen Sie das Feld Wert auf 6004 (Dezimalwert) fest.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den Computer neu, damit die Einstellung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Konfigurieren von RPC-über-HTTP finden Sie in den folgenden Knowledge Base-Artikeln:

  • 833401, „Konfigurieren von RPC-über-HTTP auf einem einzelnen Server in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, „Behandlung von Problemen bei RPC-über-HTTP-Clientverbindungen in Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


Systemaufsicht: Der Wert des HTTP-Anschlusses weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-09

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob HTTP Port auf den Standardwert festgelegt ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

Wenn Exchange Server Analyzer feststellt, dass der Wert für HTTP Port nicht 6002 (Dezimalwert) beträgt, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Registrierungsschlüssel HTTP Port wird vom Setup von Exchange Server 2003 und Exchange Server 2007 auf 6002 festgelegt. Mit dem Registrierungsschlüssel HTTP Port wird die RPC-über-HTTP-Funktion für Microsoft Office Outlook® 2003 und Microsoft Office Outlook 2007 unterstützt.

Wenn Sie die RPC-über-HTTP-Bereitstellung nicht mithilfe von Microsoft Consulting Services oder nach Empfehlung des technischen Supports von Microsoft angepasst haben, wird empfohlen, RPC-über-HTTP mit den Standardanschlusswerten bereitzustellen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den Registrierungsschlüssel für den HTTP-Anschluss auf den Standardwert fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Doppelklicken Sie auf den Schlüssel HTTP Port, und legen Sie das Feld Wert auf 6002 (Dezimalwert) fest.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den Computer neu, damit die Einstellung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Konfigurieren von RPC-über-HTTP finden Sie in den folgenden Knowledge Base-Artikeln:

  • 833401, „Konfigurieren von RPC-über-HTTP auf einem einzelnen Server in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, „Behandlung von Problemen bei RPC-über-HTTP-Clientverbindungen in Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


Der Wert für „legacyExchangeDN" für die Systemaufsicht fehlt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-09

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs legacyExchangeDN für das Systemaufsichtobjekt für jeden Exchange Server-Computer zu ermitteln. Wenn Exchange Server Analyzer keinen Wert für das Attribut legacyExchangeDN für jedes Systemaufsichtobjekt findet, wird vom Exchange Server Analyzer eine Fehlermeldung angezeigt.

Ein fehlender legacyExchangeDN kann darauf zurückzuführen sein, dass ein Administrator Active Directory geändert hat, um die Datenbank nach einer fehlgeschlagenen Wiederherstellung wiederherzustellen. Diesen Fehler beheben Sie, indem Sie das Attribut legacyExchangeDN mithilfe eines Active Directory-Editors, z. B. des LDP-Tools (LDP.exe) oder der ADSI-Bearbeitung (Active Directory Service Interfaces) ändern.

Um sicherzustellen, dass das Attribut legacyExchangeDN korrekt ist, sollten Sie auch die anderen Systemaufsichtobjekte für diesen Server oder einen anderen Exchange-Server überprüfen, der nicht diesen Fehler generiert, weil diese einen ähnlichen Wert für das Attribut legacyExchangeDN aufweisen sollten.

Wenn das Attribut legacyExchangeDN in einer Datenbank nicht vorhanden ist, fehlt es möglicherweise auch in anderen Systemobjekten. Wenn Sie mithilfe des LDP-Tools oder der ADSI-Bearbeitung einen neuen Wert für legacyExchangeDN hinzufügen, müssen Sie auch für alle anderen Systemobjekte einen neuen legacyExchangeDN-Wert hinzufügen.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In, das LDP-Tool oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, von Exchange Server 2003 bzw. Exchange Server 2007 oder beider Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So beheben Sie diesen Fehler

  1. Öffnen Sie einen Active Directory-Editor, z. B. die ADSI-Bearbeitung.

  2. Erweitern Sie Configuration[Domänenname], erweitern Sie CN=Configuration,DC=Domänenname, DC=Domänensuffix.

  3. Erweitern Sie CN=Services, und erweitern Sie dann CN=Microsoft Exchange.

  4. Erweitern Sie CN=Organisationsname, erweitern Sie CN=Administrative Groups, und erweitern Sie dann CN=Administratorengruppenname.

  5. Erweitern Sie CN=Servers, und erweitern Sie CN=Servername.

  6. Klicken Sie mit der rechten Maustaste auf CN=Microsoft-Systemaufsicht, und wählen Sie Eigenschaften aus.

  7. Führen Sie einen Bildlauf nach unten durch, um legacyExchangeDN zu finden, markieren Sie den Eintrag, und klicken Sie auf Bearbeiten.

  8. Geben Sie im Feld Wert den korrekten Wert für legacyExchangeDN ein.

  9. Schließen Sie den Active Directory-Editor, und starten Sie den Exchange Server-Computer neu, damit die Änderung wirksam wird.

Weitere Informationen zum Erstellen eines neuen Attributs legacyExchangeDN mithilfe der ADSI-Bearbeitung finden Sie im Microsoft Knowledge Base-Artikel 273863, „How to Change the LegacyExchangeDN Attribute in Native Mode with ADSI Edit" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863.


NSPI-Anschluss zur Systemaufsicht wurde manuell außer Kraft gesetzt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-17

Microsoft® Exchange Server Analyzer liest die folgenden Registrierungseinträge, um zu bestimmen, ob der Zielserver für die Namensdienstanbieterschnittstelle (NSPI target server) manuell außer Kraft gesetzt wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

Wenn Exchange Server Analyzer feststellt, dass TCP/IP NSPI Port vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Dieser Wert wird in den meisten Fällen konfiguriert, um MAPI-Clients das Herstellen einer Verbindung mit einem Exchange-Server zu ermöglichen, der sich auf der anderen Seite einer Firewall befindet. Hierfür müssen mehrere Anschlüsse in einer Firewall geöffnet werden, damit Microsoft Office Outlook® 2003-Clients mithilfe von MAPI (in der Regel über das Internet) eine Verbindung mit einem Exchange-Server herstellen können.

Für die Verwendung von Outlook im Firmen- oder Arbeitsgruppenmodus zum Herstellen einer Verbindung mit einem Exchange-Server über das Internet wird der Einsatz der Funktionen von RPC-über-HTTP (Remote Procedure Call over Hypertext Transfer Protocol) in Microsoft® Windows Server™ 2003, Exchange Server 2003, Outlook 2003 und Windows® XP Professional empfohlen.

Bei Verwendung von RPC-über-HTTP wird keine VPN-Verbindung (Virtual Private Network) benötigt, und es müssen für den MAPI-Zugriff von Outlook 2003 auf Exchange Server 2003 nicht mehrere Firewallports geöffnet werden. Benutzer von Outlook 2003 können über das Internet eine Verbindung mit einem Exchange-Server herstellen. Der RPC-Client stellt die Internetverbindung durch „Tunneln" des RPC-Verkehrs über das HTTP-Protokoll her. Wenn der RPC-Client eine HTTP/HTTPS-Verbindung mit einem Remotecomputer herstellen kann, auf dem Internetinformationsdienste (IIS - Internet Information Services) ausgeführt werden, kann dieser RPC-Client eine Verbindung mit einem beliebigen Server im Remotenetzwerk herstellen. Der Server im Remotenetzwerk muss für den Zugriff über das Internet mit RPC-über- HTTP konfiguriert sein. Darüber hinaus können der RPC-Client und die RPC-Serverprogramme auch dann eine Verbindung über das Internet herstellen, wenn beide Programme durch Firewalls geschützt werden, die sich in verschiedenen Netzwerken befinden.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So entfernen Sie den Registrierungseintrag TCP/IP NSPI Port

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Löschen Sie den Registrierungswert mit der Bezeichnung TCP/IP NSPI Port.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Exchange-Systemaufsichtsdienst neu.

So stellen Sie RPC-über-HTTP bereit

  1. Lesen Sie „Exchange Server 2003 RPC over HTTP Deployment Scenarios" unter http://go.microsoft.com/fwlink/?linkid=47577.

  2. Lesen Sie den Microsoft Knowledge Base-Artikel 833401, „Konfigurieren von RPC-über-HTTP auf einem einzelnen Server in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  3. Lesen Sie den Knowledge Base-Artikel 827330, „Behandlung von Problemen bei RPC-über-HTTP-Clientverbindungen in Office Outlook 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  4. Lesen Sie den Microsoft Support WebCast „Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Verwendung des Registrierungswerts TCP/IP NSPI Port in einer Firewallumgebung finden Sie im Knowledge Base-Artikel 270836 „Statische Anschlusszuordnungen in Exchange 2000 und Exchange 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836.


Der Systemaufsichtsdienst wurde für die Zusammenarbeit mit dem Desktop konfiguriert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_Service ab, um den Wert der Eigenschaft DesktopInteract für den Microsoft Exchange-Systemaufsichtsdienst (MSExchangeSA) zu ermitteln. Wenn Microsoft Exchange Server Analyzer feststellt, dass der Exchange-Systemaufsichtsdienst für die Zusammenarbeit mit dem Desktop konfiguriert ist, wird ein Fehler ausgegeben.

Diese Konfiguration sollte nur unter Anleitung des Technischen Supports von Microsoft verwendet werden. Wenn Sie vom Technischen Support von Microsoft nicht angewiesen wurden, den Systemaufsichtsdienst in dieser Konfiguration auszuführen, wird empfohlen, die Eigenschaften des Systemaufsichtsdienstes neu zu konfigurieren, sodass keine Zusammenarbeit mit dem Desktop möglich ist.

So konfigurieren Sie das Konto für den Systemaufsichtsdienst

  1. Öffnen Sie das MMC-Snap-In (Microsoft Management Console) Dienste.

  2. Suchen Sie den Dienst Microsoft Exchange-Systemaufsicht, und beenden Sie ihn. Beachten Sie, dass beim Beenden des Systemaufsichtsdienstes auch alle anderen Dienste beendet werden, die vom Systemaufsichtsdienst abhängig sind. Dies schließt den Microsoft Exchange-Informationsspeicherdienst ein.

  3. Doppelklicken Sie auf den Dienst Microsoft Exchange-Systemaufsicht.

  4. Wählen Sie auf der Seite Eigenschaften von Microsoft Exchange-Systemaufsicht auf der Registerkarte Anmelden unter Anmelden als Lokales Systemkonto aus.

  5. Deaktivieren Sie das Kontrollkästchen Datenaustausch zwischen Dienst und Desktop zulassen, und klicken Sie dann auf Übernehmen.

  6. Klicken Sie unter Dienststatus auf Start, und klicken Sie dann auf OK.

  7. Schließen Sie das Snap-In Dienste.

Weitere Informationen zur richtigen Konfiguration von Exchange-Diensten finden Sie im Microsoft Knowledge Base-Artikel 239762 „Exchange Services Run Under LocalSystem" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762.


Der Systemaufsichtsdienst wird nicht als „LocalSystem" ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-01-09

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_Service ab, um den Wert der Eigenschaft StartName für den Microsoft Exchange-Systemaufsichtsdienst (MSExchangeSA) zu ermitteln. Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für jedes ExchangeServer-Objekt im Verzeichnis zu bestimmen. Das Attribut serialNumber auf dem Exchange Server-Objekt bezeichnet die Version von Exchange Server, die auf dem durch das Objekt dargestellten Computer ausgeführt wird. Wenn Exchange Server Analyzer feststellt, dass der Exchange-Systemaufsichtsdienst unter einem anderen Konto als dem Konto LocalSystem (SYSTEM) auf einem Exchange-Server ausgeführt wird, auf dem Exchange 2000 Server, Exchange Server 2003 oder Exchange Server 2007 ausgeführt wird, zeigt Exchange Server Analyzer einen Fehler an.

Dieser Fehler gibt an, dass der Systemaufsichtsdienst nicht in einer unterstützten Konfiguration ausgeführt wird. Wenn Sie den Systemaufsichtsdienst unter einem anderen Konto ausführen, führt dies zu Berechtigungs- und Zugriffsfehlern.

Um diesen Fehler zu beheben, müssen Sie den Exchange-Systemaufsichtsdienst so konfigurieren, dass er unter dem Konto LocalSystem (auch SYSTEM) startet.

Hinweis:
Dieser Fehler bezieht sich nicht auf Exchange Server, Version 5.5. Das Ausführen des Exchange-Systemaufsichtsdiensts unter dem Konto LocalSystem ist nur für Exchange 2000 Server, Exchange Server 2003 und Exchange Server 2007 erforderlich.
So konfigurieren Sie das Konto für den Systemaufsichtsdienst

  1. Öffnen Sie das MMC-Snap-In (Microsoft Management Console) Dienste.

  2. Suchen Sie den Dienst Microsoft Exchange-Systemaufsicht, und beenden Sie ihn. Beachten Sie, dass beim Beenden des Systemaufsichtsdienstes auch alle anderen Dienste beendet werden, die vom Systemaufsichtsdienst abhängig sind. Dies schließt den Microsoft Exchange-Informationsspeicherdienst ein.

  3. Doppelklicken Sie auf den Dienst Microsoft Exchange-Systemaufsicht.

  4. Wählen Sie auf der Seite Eigenschaften von Microsoft Exchange-Systemaufsicht auf der Registerkarte Anmelden unter Anmelden als das Konto Lokales Systemkonto aus, und klicken Sie dann auf Übernehmen.

  5. Klicken Sie unter Dienststatus auf Start, und klicken Sie dann auf OK.

  6. Schließen Sie das Snap-In Dienste.

Weitere Informationen über das Ausführen von Exchange-Diensten unter dem Konto LocalSystem finden Sie im Microsoft Knowledge Base-Artikel 239762, „Exchange Services Run Under LocalSystem" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762.


Der Schlüssel "TcpTimedWaitDelay" fehlt oder weist nicht den Standardwert auf
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-03-13

Das Tool Microsoft Exchange Analyzer fragt den Active Directory-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Objekte mit der Objektklasse msExchExchangeServer zu ermitteln. Wenn der Zeichenfolgenwert "Version 5.5" enthält, führt der Computer Exchange Server 5.5 aus. Wenn der Zeichenfolgenwert "Version 6.0" enthält, wird auf dem Computer Microsoft Exchange 2000 Server ausgeführt. Wenn der Zeichenfolgenwert "Version 6.5" enthält, wird auf dem Computer Exchange Server 2003 ausgeführt. Wenn der Zeichenfolgenwert "Version 8.0" enthält, wird auf dem Computer Exchange Server 2007 ausgeführt.

Das Tool Exchange Analyzer liest dann den folgenden Registrierungszweig für jeden gefundenen Servercomputer mit Exchange Server 2007, um festzustellen, ob der Wert für den Schlüssel TcpTimedWaitDelay auf den Standardwert von 60 festgelegt ist.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Der Schlüssel TcpTimedWaitDelay legt die Zeit fest, die verstreichen muss, bevor TCP eine geschlossene Verbindung freigeben und ihre Ressourcen erneut verwenden kann. Dieses Intervall zwischen dem Schließen und der Freigabe wird als TIME_WAIT-Status oder 2MSL-Status bezeichnet. Während dieses Zeitraums kann die Verbindung zu erheblich niedrigeren Kosten für den Client und den Server erneut geöffnet werden, als beim Herstellen einer neuen Verbindung entstehen würden.

Wenn Sie einen niedrigeren Wert für diesen Eintrag angeben, kann TCP geschlossene Verbindungen schneller freigeben und auf diese Weise mehr Ressourcen für neue Verbindungen bereitstellen. Wenn der Wert jedoch zu niedrig ist, gibt TCP möglicherweise Verbindungsressourcen frei, bevor die Verbindung abgeschlossen ist. Dann muss der Server zusätzliche Ressourcen verwenden, um die Verbindung erneut einzurichten.

Wenn Exchange Analyzer feststellt, dass der Wert für den Schlüssel TcpTimedWaitDelay fehlt oder nicht dem Standardwert von 60 entspricht, zeigt Exchange Analyzer eine Warnung an.

Für optimale Leistung wird empfohlen, den Schlüssel TcpTimedWaitDelay auf Servercomputern mit Exchange Server 2007 auf den Standardwert 60 festzulegen.

Wichtig:
Dieses Thema enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema "Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So legen Sie den Registrierungsschlüssel "TcpTimedWaitDelay" auf seinen Standardwert fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. Doppelklicken Sie auf den Schlüssel TcpTimedWaitDelay, und legen Sie das Feld Wert auf 60 (Dezimalwert) fest.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Computer neu.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986, "Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung enthält.

Dieses Problem steht im Beziehung zum Analyzer-Problem Der Schlüssel "MaxUserPort" fehlt oder weist nicht den Standardwert auf.

Weitere Informationen zu den Auswirkungen der Schlüssel MaxUserPort und TcpTimedWaitDelay finden Sie im Thema zum Übertragungssteuerungsprotokoll im Windows 2000 Resource Kit (http://go.microsoft.com/fwlink/?LinkId=85654).


Die TEMP/TMP-Variable zeigt anscheinend auf einen ungültigen oder unpassenden Ordner.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Auf einem Exchange-Server, der nicht Teil eines Clusters ist, liest Microsoft® Exchange Server Analyzer die folgenden Registrierungseinträge, um den Wert für die Umgebungsvariablen TEMP und TMP zu bestimmen.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

HKLM\System\CurrentControlSet\Control\Session Manager\Environment\TMP

Der Microsoft Exchange-Informationsspeicherdienst verwendet den Ordner TEMP und den Ordner TMP während verschiedener Vorgänge als temporären Speicher, beispielsweise bei der Nachrichtenkonvertierung und beim Verschieben von Postfächern. Auf einem Exchange-Server, der sich nicht in einem Cluster befindet, verwendet der Microsoft Exchange-Informationsspeicherdienst das SYSTEM (z. B. Lokales System), für das eine Umgebungsvariablen-Standardeinstellung von %Systemroot%\Temp für TEMP und TMP gilt. Wenn die Umgebungsvariablen TEMP und/oder TMP von Exchange Server mit %SYSTEMROOT beginnen, wird eine Warnung angezeigt.

Mithilfe der Umgebungsvariablen TEMP und TMP wird festgelegt, welche Ordner im Dateisystem (welcher Pfad) von Anwendungen verwendet werden sollen, die einen temporären Arbeitsbereich erfordern. TEMP wird typischerweise von Anwendungen wie Microsoft Exchange verwendet, und TMP wird i. d. R. von Entwicklungstools wie Microsoft Visual C++® verwendet. Der Pfad für die einzelnen Variablen bezieht sich normalerweise auf den Sicherheitskontext der Anwendung bzw. des Tools.

Wenn Exchange Server Analyzer für einen virtuellen Exchange-Server in einem Microsoft Windows Server™ 2003-Cluster ausgeführt wird, wird die Registrierungsstruktur HKLM nicht gelesen. Stattdessen werden die folgenden Registrierungseinträge gelesen:

HKEY_USERS\<Clusterdienstkonto-SID>\Environment\TEMP

HKEY_USERS\<Clusterdienstkonto-SID>\Environment\TMP

Virtuelle Exchange-Server, die in einem Windows Server 2003-Cluster ausgeführt werden, verwenden die Umgebungsvariableneinstellungen des Cluster-Dienstkontos, das im Kontext des Sicherheitsprinzips eines bestimmten Benutzers ausgeführt wird. Für Benutzerkonten wird die Standardumgebungsvariable für TEMP und TMP auf %Userprofile%\temp festgelegt. Wenn die Umgebungsvariablen TEMP und/oder TMP des virtuellen Exchange-Servers mit %SYSTEMROOT beginnen, wird eine Warnung angezeigt.

Zur Optimierung der Leistung empfiehlt es sich, dass für die von Exchange verwendeten Ordner TEMP und TMP nicht die Festplatte mit dem Betriebssystem verwendet wird. Darüber hinaus müssen Sie sicherstellen, dass diese Umgebungsvariablen auf Pfade auf einer schnellen Festplatte bzw. einem Festplattenteilsystem (z. B. Gruppe von RAID 0+1-Spindeln) festgelegt sind. Es wird außerdem empfohlen, dass für die von Exchange bzw. virtuellen Exchange-Servern verwendeten Ordner TEMP und TMP nicht der Datenträger verwendet wird, auf dem sich das Betriebssystem befindet.

So beheben Sie diese Warnmeldung

  1. Melden Sie sich beim Exchange Server-Computer mit einem Konto an, das über Administratorrechte verfügt.

  2. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und wählen Sie Eigenschaften aus.

  3. Wählen Sie die Registerkarte Erweitert aus.

  4. Klicken Sie auf die Schaltfläche Umgebungsvariablen.

  5. Wählen Sie im Bereich Systemvariablen den Eintrag TEMP aus, und klicken Sie auf die Schaltfläche Bearbeiten.

  6. Im Feld Variablenwert geben Sie den neuen Pfad für die Umgebungsvariable TEMP ein, und klicken Sie auf OK.

  7. Wählen Sie im Bereich Systemvariablen den Eintrag TMP aus, und klicken Sie auf die Schaltfläche Bearbeiten.

  8. Geben Sie im Feld Variablenwert den neuen Pfad für die Umgebungsvariable TMP ein, und klicken Sie auf OK.

  9. Klicken Sie auf OK, um das Dialogfeld Umgebungsvariablen zu schließen und nochmals auf OK, um das Dialogfeld Systemeigenschaften zu schließen.

  10. Starten Sie den Knoten neu, um die Änderung zu übernehmen.

Weitere Informationen zum Ändern der Umgebungsvariablen TEMP und TMP auf einem Exchange-Clusterserver finden Sie unter Der Pfad für „Cluster TEMP/TMP" befindet sich auf demselben Laufwerk wie die Systempartition..


Dieser Server verfügt über 1 GB oder mehr physischen Arbeitsspeicher, und „HeapDeCommitFreeBlockThreshold" wurde nicht auf „262144" festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-08-14

Fehlermeldung

Einführung

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob Exchange in Bezug auf die Größe des physischen Arbeitsspeichers im System optimal konfiguriert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\HeapDeCommitFreeBlockThreshold

Wenn Exchange Server Analyzer ermittelt, dass der Wert für HeapDeCommitFreeBlockThreshold auf einem Exchange Server-Computer mit 1 GB oder mehr physischem Arbeitsspeicher nicht festgelegt wurde, wird eine Warnmeldung angezeigt.

Wenn an einer definierten Adresse Arbeitsspeicher freigegeben wird, überprüft der Heap-Manager des Betriebssystems, wie viel Speicher (zusammenhängende Bytes) an dieser Adresse zur Verfügung steht. Nach dieser Überprüfung kann der Heap-Manager einen von zwei Vorgängen ausführen:

  • Den zusammenhängenden Speicherblock als gültig beibehalten.

  • Den zusammenhängenden Speicherblock aufheben und ihn nur als reserviert kennzeichnen.

Der Registrierungsschlüssel HeapDeCommitFreeBlockThreshold gibt die Anzahl von zusammenhängenden Bytes an, über die hinaus die Freigabe des Arbeitsspeichers aufgehoben ist. In der Standardeinstellung kombiniert der Heap-Manager nicht notwendigerweise alle freien Blöcke oder nimmt neue Zuordnungen vor. Dies kann u. U. dazu führen, dass Blöcke aufgehoben werden und damit nutzlose Lücken im virtuellen Speicheradressraum entstehen. Dies kann zur Fragmentierung des virtuellen Speichers, zu schlechter Leistung und letztlich zur Systeminstabilität führen.

Auf Systemen mit einem physischen Arbeitspeicher von mindestens 1 GB wird die Leistung dadurch optimiert, dass die Größe der Abschnitte des Speichers überprüft wird, dessen Freigabe aufgehoben wurde. Der Registrierungsschlüssel HeapDeCommitFreeBlockThreshold steuert die Verwendung des Speichers nach seiner Freigabe. Beim Hinzufügen dieses Werts in der Registrierung müssen Sie ihn auf 0x00040000 (Hexadezimalwert) oder 262144 (Dezimalwert) festlegen.

Microsoft unterstützt keinen anderen Wert für den Registrierungsschlüssel HeapDeCommitFreeBlockThreshold als 0x00040000 (Hexadezimalwert) bzw. 262144 (Dezimalwert).

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Control\Session Manager

  3. Erstellen Sie einen DWORD-Wert mit der Bezeichnung HeapDeCommitFreeBlockThreshold.

  4. Doppelklicken Sie auf den Wert HeapDeCommitFreeBlockThreshold, und geben Sie den Hexadezimalwert 0x00040000 (262144 als Dezimalwert) ein.

  5. Beenden Sie den Registrierungs-Editor, und starten Sie den Exchange Server-Computer neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Registrierungsschlüssel HeapDeCommitFreeBlockThreshold finden Sie in den folgenden Knowledge Base-Artikeln:

  • 315407, „XADM: Der Registrierungsschlüssel 'HeapDeCommitFreeBlockThreshold'" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=315407.

  • 815372, „Optimieren der Speichernutzung in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372

  • 325044, „HOW TO: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044


Dieser Server führt Windows Server 2003 aus, und der SystemPages-Wert ist ungleich 0.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Einstellung für den Registrierungswert SystemPages zu ermitteln:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

Exchange Server Analyzer fragt außerdem die WMI-Klasse (Microsoft Windows ® Management Instrumentation) Win32_OperatingSystem ab, um den Wert für den Schlüssel OSProductSuite zu bestimmen. Der Wert dieses Schlüssels entspricht einer bestimmten Version eines Microsoft Windows-Betriebssystems.

Wenn Exchange Server Analyzer feststellt, dass der Wert für SystemPages nicht auf 0 festgelegt ist, wird eine Warnung angezeigt. Dies gilt für Exchange Server-Computer, auf denen Microsoft Windows Server™ 2003 ausgeführt wird, ohne Teil einer Installation von Microsoft Windows Small Business Server 2003 zu sein.

Wenn Sie Exchange Server 2003 Service Pack 1 (SP1) auf Microsoft Windows Server 2003 mit 1 GB oder mehr RAM ausführen, wird empfohlen, dass Sie den Registrierungsschlüssel SystemPages auf 0 festlegen. Diese Empfehlung unterscheidet sich von der Empfehlung für Microsoft Windows 2000 Server. Dort wird empfohlen, SystemPages auf einen Wert zwischen 24.000 und 31.000 festzulegen.

Auf einem Windows Server 2003-Computer, der nicht Teil einer Installation von Microsoft Windows Small Business Server 2003 ist, dürfen Sie den Registrierungswert SystemPages nur auf den Wert 0 festlegen. Wenn dieser Wert geändert wird, kann das System den optimalen Wert für Ihr System nicht berechnen, und das System kann bei Änderungen des Systems den Wert nicht anpassen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
Achtung:
Durch das Festlegen des Registrierungswerts SystemPages auf Computern, auf denen Windows Server 2003 ausgeführt wird, wird die maximale Größe des ausgelagerten Pools kleiner. Dies kann zur Auslastung des ausgelagerten Pools und zu Serverinstabilität führen.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Doppelklicken Sie im rechten Teilfenster auf SystemPages.

  4. Geben Sie im Feld Wert den Wert 0 ein, und klicken Sie dann auf OK.

  5. Beenden Sie den Registrierungs-Editor, und starten Sie den Computer neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Optimieren des Speichers für Exchange Server finden Sie in den folgenden Artikeln der Knowledge Base:

  • 325044, „SO WIRDS GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044

  • 815372, „Optimieren der Speichernutzung in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372

  • 311901, „The effects of 4GT tuning on System Page Table Entries" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901


Für diesen Exchange-Server ist in der Datei „Boot.ini" der Startschalter „/PAE" festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_ComputerSystem ab, um die in der Eigenschaft SystemStartupOptions festgelegten Optionen zu bestimmen. Exchange Server Analyzer sendet auch eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Zähler für das Attribut homeMDBBL des Postfachspeicherobjekts (msExchPrivateMDB) zu bestimmen. Das Ergebnis ist die Anzahl der Postfächer auf dem Exchange Server-Computer.

Wenn Exchange Server Analyzer feststellt, dass der Startschalter /PAE in der Datei boot.ini auf einem Exchange-Server festgelegt wurde, der über weniger als 500 Postfächer verfügt und auf einem Windows 2000-Server ausgeführt wird, wird eine Warnung angezeigt.

Mithilfe von physikalischen Adresserweiterungen (Physical Addressing Extensions - PAE) kann ein Computer auf mehr als 4 GB physischen Arbeitsspeicher (RAM) zugreifen. Exchange Server unterstützt PAE nicht. PAE ermöglicht Windows den Zugriff auf über 4 GB physischen Arbeitsspeicher. Exchange Server kann nicht mehr als 4 GB physischen Arbeitsspeichers verwenden. Die Installation von mehr als 4 GB RAM auf einem für die Ausführung von Exchange Server dedizierten Computer bietet keinen Vorteil. PAE wird aktiviert, wenn der Startschalter /PAE in der Datei Boot.ini vorhanden ist.

Um diese Warnung zu beheben (nur für Windoes 2000), wird empfohlen, den Schalter /PAE aus der Datei Boot.ini zu entfernen.

So beheben Sie diese Warnmeldung

  1. Navigieren Sie in Windows Explorer zur Systempartition. Auf dieser Partition befinden sich hardwarespezifische Dateien wie Boot.ini und NTLDR.

  2. Wenn die Datei Boot.ini nicht angezeigt wird, kann dies daran liegen, dass unter Ordneroptionen die Option Geschützte Systemdateien ausblenden festgelegt ist. Wenn dies der Fall ist, klicken Sie im Explorer-Fenster auf Extras und Ordneroptionen, und klicken Sie dann auf Ansicht. Klicken Sie auf die Option zum Anzeigen von verborgenen Dateien und Ordnern. Deaktivieren Sie das Kontrollkästchen Geschützte Systemdateien ausblenden (empfohlen). Klicken Sie bei der Eingabeaufforderung auf Ja.

  3. Wenn die Datei Boot.ini in Windows Explorer angezeigt wird, klicken Sie mit der rechten Maustaste auf die Datei, klicken dann auf Öffnen mit und schließlich auf Editor, um die Datei zu öffnen.

  4. Entfernen Sie im Abschnitt [Operating Systems] die Option /PAE.

  5. Speichern und schließen Sie die Datei. Starten Sie dann den Exchange Server-Computer neu, damit die Änderung wirksam wird.

Weitere Informationen zum Schalter /PAE in der Datei Boot.ini finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 268363: „Intel Physical Addressing Extensions (PAE) in Windows 2000"

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882: „Exchange Memory Use and the /3GB Switch"

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)


Beim Ausführen dieses Exchange-Servers sind physische Adresserweiterungen aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-05-08

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_OperatingSystem ab, um die aktuellen Werte für die folgenden Schlüssel zu bestimmen.

  • PAEEnabled Der Wert dieses Schlüssels gibt an, ob physikalische Adresserweiterungen (Physical Address Extensions, PAE) aktiviert sind. Der Wert True gibt an, dass PAE aktiviert sind, der Wert False, dass PAE nicht aktiviert sind.

  • Version Der Wert dieses Schlüssels gibt die Version des Microsoft Windows-Betriebssystems an, das auf dem Computer ausgeführt wird. Der Wert 5.0.2195 gibt an, dass ein Microsoft Windows 2000 Server-Betriebssystem ausgeführt wird, und der Wert 5.2.3790 gibt an, dass ein Microsoft Windows Server™ 2003-Betriebssystem ausgeführt wird.

  • ServicePackMajorVersion Der Wert dieses Schlüssels gibt die Hauptversionsnummer des installierten Windows-Service Packs an.

Exchange Server Analyzer fragt außerdem die WMI-Klasse CIM_Datafile ab, um die Nebenversion der Datei ntoskrnl.exe zu ermitteln, die auf dem System ausgeführt wird. So wird ermittelt, ob das Sicherheitsupdate MS04-032 auf dem Computer installiert ist. Wenn die Nebenversion von ntoskrnl.exe 174 oder weniger beträgt, gibt dies an, dass MS04-032 nicht installiert ist. Wenn die Nebenversion von ntoskrnl.exe mehr als 174 beträgt, gibt dies an, dass MS04-032 installiert ist.

Wenn ein Exchange-Server unter Windows Server 2003 ausgeführt wird, bei dem das Sicherheitsupdate MS04-032 nicht ausgeführt wird, und Exchange Server Analyzer ermittelt, dass der Wert für PAEEnabled auf True festgelegt ist, wird ein Fehler angezeigt. Dieser Fehler gibt an, dass auf dem Computer ein bekanntes Problem vorliegt, das zum Ausfallen des Microsoft Exchange-Informationsspeicherdienstes (Store.exe) führen kann.

PAE wird von Exchange Server nicht verwendet. PAE ermöglicht Windows den Zugriff auf über 4 Gigabyte (GB) physischen Arbeitsspeicher. Exchange Server kann nicht mehr als 4 GB physischen Arbeitsspeichers verwenden. Die Installation von mehr als 4 GB RAM auf einem für die Ausführung von Exchange Server dedizierten Computer bietet keinen Vorteil. PAE ist aktiviert, wenn der Startschalter /PAE beim Start in der Datei Boot.ini vorhanden ist oder das Betriebssystem Windows Server 2003 Hot-Add-Speichergeräte erkennt. Unter Windows Server 2003 Enterprise Edition und Windows Server 2003 Datacenter Edition wird PAE nur dann automatisch aktiviert, wenn auf dem Server Hot-Add-Speichergeräte verwendet werden.

So beheben Sie diesen Fehler durch Installieren des Updates MS04-032

  1. Informationen darüber, wie Sie das Update MS04-032 erhalten können, finden Sie im Microsoft Knowledge Base-Artikel 840987, „MS04-032: Sicherheitsupdate für Microsoft Windows" (http://support.microsoft.com/kb/840987/de).

  2. Erstellen Sie eine vollständige Sicherungskopie des Systems.

  3. Wenden Sie das Update an, und starten Sie dann den Computer neu, damit das Update wirksam wird.

Weitere Informationen zu PAE finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 268363: „Intel Physical Addressing Extensions (PAE) in Windows 2000"

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882: „Speicherverwendung in Exchange und die Befehlszeilenoption /3GB'"

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)

Weitere Informationen zum Schalter /NOPAE in der Datei Boot.ini finden Sie im MSDN-Artikel, „/nopae" (http://go.microsoft.com/fwlink/?LinkId=51490).


Dieser Exchange-Server wird mit aktivierten physikalischen Adresserweiterungen und dem Startschalter „/3GB" ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_OperatingSystem ab, um den aktuellen Wert des Schlüssels PAEEnabled zu bestimmen. Der Wert dieses Schlüssels gibt an, ob physikalische Adresserweiterungen (Physical Address Extensions - PAE) aktiviert sind. Der Wert True gibt an, dass PAE aktiviert sind, der Wert False, dass PAE nicht aktiviert sind. Exchange Server Analyzer fragt außerdem die WMI-Klasse Win32_OperatingSystem ab, um den Wert des Schlüssels MaxProcessMemorySize zu ermitteln.

Wenn Exchange Server Analyzer feststellt, dass für PAEEnabled der Wert True festgelegt wurde und der Wert für MaxProcessMemorySize größer als 2097024 ist, wird eine Warnung angezeigt. Diese Warnung zeigt an, dass es sich bei diesen Werten nicht um Standardwerte handelt. Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu PAE finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 268363: „Intel Physical Addressing Extensions (PAE) in Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882: „Speicherverwendung in Exchange und die Befehlszeilenoption" /3GB'„ (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)


Dieser Exchange-Server wird mit den Startschaltern /PAE und /3GB ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_ComputerSystem ab, um zu ermitteln, welche Optionen im Schlüssel SystemStartupOptions festgelegt sind. Exchange Server Analyzer fragt außerdem die WMI-Klasse Win32_OperatingSystem ab, um den Wert des Schlüssels MaxProcessMemorySize zu ermitteln.

Wenn Exchange Server Analyzer feststellt, dass /PAE im Wert des Schlüssels SystemStartupOptions enthalten ist, der Wert Win32_OperatingSystem Microsoft Windows 2000 Server angibt und der Wert für MaxProcessMemorySize größer als 2097024 ist, wird ein Fehler angezeigt.

Dieser Fehler gibt an, dass die Startschalter /PAE und /3GB in der Datei Boot.ini festgelegt wurden. Mithilfe der Physical Addressing Extension (PAW - physikalische Adresserweiterung) kann ein Computer auf mehr als 4 GB physischen Arbeitsspeicher (RAM) zugreifen. Exchange Server unterstützt PAE nicht. Exchange Server kann nicht mehr als 4 GB physischen Arbeitsspeicher verwenden. Die Installation von mehr als 4 GB RAM auf einem für die Ausführung von Exchange Server dedizierten Computer bietet keinen Vorteil. PAE wird aktiviert, wenn beim Systemstart die Startoption /PAE in der Datei Boot.ini vorhanden ist.

Um diese Warnung zu beheben, wird empfohlen, den Schalter /PAE aus der Datei Boot.ini zu entfernen.

So beheben Sie diesen Fehler

  1. Navigieren Sie in Windows Explorer zur Systempartition. Auf dieser Partition befinden sich hardwarespezifische Dateien wie Boot.ini und NTLDR.

  2. Wenn die Datei Boot.ini nicht angezeigt wird, kann dies daran liegen, dass unter Ordneroptionen die Option Geschützte Systemdateien ausblenden festgelegt ist. Wenn dies der Fall ist, klicken Sie im Windows Explorer-Fenster auf Extras und Ordneroptionen, und klicken Sie dann auf Ansicht. Klicken Sie auf Alle Dateien und Ordner anzeigen. Deaktivieren Sie das Kontrollkästchen Geschützte Systemdateien ausblenden (empfohlen). Klicken Sie bei der Eingabeaufforderung auf Ja.

  3. Wenn die Datei Boot.ini in Windows Explorer angezeigt wird, klicken Sie mit der rechten Maustaste auf die Datei, klicken dann auf Öffnen mit und schließlich auf Editor, um die Datei zu öffnen.

  4. Entfernen Sie im Abschnitt [Operating Systems] die Option /PAE.

  5. Speichern Sie die Datei, und schließen Sie sie. Starten Sie dann den Exchange Server-Computer neu, damit die Änderung wirksam wird.

Weitere Informationen zur Option /PAE in der Datei Boot.ini finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 268363, „Intel Physical Addressing Extensions (PAE) in Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882, „Speicherverwendung in Exchange und die Befehlszeilenoption /3GB" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)


Dieser Front-End-Server wurde mit dem Empfängeraktualisierungsdienst konfiguriert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs msExchAddressListServiceLink für jedes Objekt Recipient Update Service im Verzeichnis zu ermitteln. Das Attribut msExchAddressListServiceLink stellt eine Verknüpfung zwischen dem Adresslistendienst und dem Exchange Server-Computer dar, auf dem der Empfängeraktualisierungsdienst (Recipient Update Service - RUS) ausgeführt wird. Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Exchange Server ist als Front-End-Server konfiguriert.

  • Auf dem Exchange Server-Computer wird der Empfängeraktualisierungsdienst ausgeführt.

Der Empfängeraktualisierungsdienst ist eine Komponente im Exchange-Systemaufsichtsdienst. Der Empfängeraktualisierungsdienst erstellt und verwaltet Exchange-spezifische Attributwerte in Active Directory. Beim Erstellen eines Posteingangs für einen Benutzer ist der Empfängeraktualisierungsdienst dafür verantwortlich, die SMTP-Adresse (Simple Mail Transfer Protocol) und alle anderen in den Empfängerrichtlinien definierten Proxyadressen automatisch zu generieren.

Wenn ein Exchange Server, der für die Verwendung des Empfängeraktualisierungsdiensts konfiguriert ist, auch als Front-End-Server konfiguriert wird, werden neu erstellte Benutzerobjekte vom Empfängeraktualisierungsdienst nicht verarbeitet. Dies hat zur Folge, dass Benutzerobjekte möglicherweise keine E-Mail-Adressen erhalten und die Empfänger in der Adressliste nicht angezeigt werden. Darüber hinaus werden auch Aktualisierungen für das Offlineadressbuch nicht verarbeitet.

Wenn Sie diese Meldung erhalten, wird der Empfängeraktualisierungsdienst auf einem als Front-End-Server konfigurierten Exchange Server ausgeführt.

So beheben Sie diesen Fehler

  1. Öffnen Sie den Exchange-System-Manager.

  2. Klicken Sie unter Empfänger auf Empfängeraktualisierungsdienste. Klicken Sie im rechten Bereich mit der rechten Maustaste auf die entsprechende Instanz des Empfängeraktualisierungsdiensts, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Allgemein unter Exchange-Server auf Durchsuchen, und geben Sie dann einen neuen Server an, auf dem die RUS-Instanz ausgeführt werden soll.

  4. Klicken Sie auf OK. Klicken Sie anschließend erneut auf OK, damit die Änderung wirksam wird.

Weitere Informationen zum Empfängeraktualisierungsdienst finden Sie in den folgenden Themen und Microsoft Knowledge Base-Artikeln:

  • 328738, „How the Recipient Update Service Applies Recipient Policies" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828, „How the Recipient Update Service Populates Address Lists" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127, „How to Check the Progress of the Recipient Update Service" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770, „XADM: Tasks Performed by the Recipient Update Service" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770).


Zwischen der Registrierung und Active Directory besteht eine Abweichung in Bezug auf den Exchange-Servernamen.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-12-03

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den in Active Directory gespeicherten Wert für den Namen des Exchange-Servers zu bestimmen (CN=<ExchangeServerName>). Nach dem Abrufen des Namens zählt Microsoft Exchange Server Analyzer die Anzahl der Zeichen im Namen.

Microsoft Exchange Server Analyzer liest auch den folgenden Registrierungseintrag, um den Wert zu bestimmen, der in der Registrierung des Exchange Server-Computers für den Hostnamen des Exchange-Servers gespeichert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

Darüber hinaus fragt Exchange Server Analyzer auch die WMI-Klasse (Windows® Management Instrumentation) Win32_Service ab, um den Wert des Schlüssels Started für den Clusterdienst ClusSvc zu bestimmen.

Wenn Exchange Server Analyzer feststellt, dass die folgenden Kriterien alle erfüllt sind, wird ein Fehler angezeigt:

  • Der Wert für CN=<ExchangeServerName> stimmt nicht mit dem Wert für Hostname überein.

  • Der Name des Exchange-Servers hat eine Länge von 15 Zeichen oder weniger.

  • Der Exchange-Server wird nicht in einem Windows-Cluster ausgeführt.

Die häufigste Ursache dieses Fehlers ist die Änderung des Namens des Exchange-Servers. Wenn der Name auf diese Weise geändert wird, wird er in der Registrierung des Computers geändert, und der Name für das Konto des Computers in Active Directory wird geändert. Die vielen Verweise auf den Namen des Exchange-Servers, die in Active Directory in Exchange-Attributen und -Objekten vorhanden sind, werden jedoch nicht geändert.

Hinweis:
Bei Software von Drittanbietern wird mitunter auch der Computername geändert, um die Clusterfunktionalität zu gewährleisten. Wenn Sie derartige Software verwenden, müssen Sie dieses Problem möglicherweise ignorieren.

Das Umbenennen eines Exchange Server-Computers wird nicht unterstützt und verursacht bekanntermaßen Probleme, beispielsweise kann der Microsoft Exchange-Systemaufsichtsdienst nicht gestartet werden, nachdem der Computername geändert wurde. Wenn der umbenannte Exchange Server-Computer nicht in jeder Hinsicht ordnungsgemäß zu funktionieren scheint, können Sie Exchange Server manuell mit dem in diesem Artikel beschriebenen Vorgang vom Computer entfernen. Wenn der umbenannte Exchange Server-Computer in jeder Hinsicht ordnungsgemäß zu funktionieren scheint, sollten Sie den Exchange-Server mit der unten beschriebenen Prozedur zur Neuerstellung neu erstellen, da diese Konfiguration nicht unterstützt wird und in Zukunft Probleme verursachen kann.

So beheben Sie diesen Fehler durch manuelles Entfernen von Exchange Server

  1. Beenden Sie alle Exchange Server-Dienste, und erstellen Sie eine Sicherungskopie des gesamten Computers.

  2. Je nach der ausgeführten Version von Exchange Server finden Sie weitere Informationen im folgenden Microsoft Knowledge Base-Artikel:

    • Wenn Sie Exchange Server 2007 ausführen, folgen Sie dem Verfahren in der Exchange Server 2007-Dokumentation, "Vollständiges Entfernen von Exchange 2007 von einem Server" (http://go.microsoft.com/fwlink/?LinkId=79246).

    • Wenn Sie Exchange Server 2003 ausführen, folgen Sie dem Verfahren im Artikel 833396 der Knowledge Base „Exchange Server 2003 vom Computer entfernen" unter http://support.microsoft.com/kb/833396/de.

    • Wenn Sie Exchange 2000 Server ausführen, folgen Sie dem Verfahren im Artikel 260378 der Knowledge Base „Manuelles Entfernen einer Installation von Exchange 2000" unter http://support.microsoft.com/kb/260378/de.

  3. Wenn Exchange 2000 Server oder Exchange Server 2003 der einzige in Ihrer Organisation ausgeführte Exchange-Server ist, folgen Sie dem Verfahren im Artikel 273478 der Knowledge Base, „So entfernen Sie Exchange 2000 oder Exchange 2003 vollständig aus Active Directory" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=273478).

So beheben Sie diesen Fehler durch Neuerstellung des Exchange Server-Computers

  1. Verschieben Sie Postfächer, Öffentliche Ordner, Connectors und Rollen auf einen anderen Exchange Server-Computer in der Organisation.

  2. Deinstallieren Sie Exchange Server von dem Computer.

  3. Zum Bereinigen der Registrierung eines Computers, auf dem Exchange Server 2003 oder Exchange Server 2000 ausgeführt wird, folgen Sie den Abschnitten über die Bereinigung der Registrierung der in den folgenden Artikeln der Microsoft Knowledge Base beschriebenen Verfahren:

    • 833396, „Exchange Server 2003 vom Computer entfernen" (http://support.microsoft.com/kb/833396/de)

    • 260378, „XADM: Manuelles Entfernen einer Installation von Exchange 2000" (http://support.microsoft.com/kb/260378/de).

    Alternativ können Sie das Betriebssystem neu erstellen.

  4. Installieren Sie Exchange Server auf dem Computer.

  5. Verschieben Sie Postfächer, Öffentliche Ordner, Connectors und Rollen in den neu erstellten Exchange Server-Computer.

Weitere Informationen zur Bereitstellung von Exchange Server 2003 auf Clustern finden Sie im Artikel 810986 der Microsoft Knowledge Base „Microsoft support policy for Exchange Server installations that are running with a third-party Cluster service" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810986http://go.microsoft.com/fwlink/?linkid=3052&kbid=810986).


Es ist eine Diskrepanz bezüglich des Exchange-Servernamens in Active Directory aufgetreten.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-12-03

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um festzustellen, ob die Attribute Name und cn eines Servers (Objektklasse msExchExchangeServer) übereinstimmen. Wenn Exchange Server Analyzer einen Unterschied zwischen beiden Attributen feststellt, wird eine Fehlermeldung angezeigt.

Exchange verwendet den Wert cn des Serverobjekts für die interne Identifizierung des Servers. Der Wert Name wird verwendet, um den Server auf der Benutzeroberfläche von Microsoft Exchange-System-Manager zu identifizieren.

Dieser Fehler kann auftreten, wenn ein Administrator den Wert von Name mit einem Tool wie der ADSI-Bearbeitung (Active Directory Service Interfaces) oder dem LDP-Tool (ldp.exe) geändert hat. Dadurch erfolgt zwar keine Änderung des Servernamens auf der Benutzeroberfläche, die entstehende Diskrepanz löst jedoch Informationsspeicher- und Systemüberwachungsereignisse aus. Der Wert kann jedoch nur mithilfe eines Tools wie z. B. des ADSI-Bearbeitungs-Snap-Ins, des LDP-Tools oder eines anderen LDAP-Clients, Version 3, (Lightweight Directory Access Protocol) korrigiert werden.

Achtung:
Wenn Sie die ADSI-Bearbeitung, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, von Exchange Server 2003 bzw. Exchange Server 2007 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So beheben Sie diesen Fehler

  1. Verwenden Sie die ADSI-Bearbeitung oder ein vergleichbares Tool, um das Serverobjekt in Active Directory zu suchen.

    Die Attribute CN und Name befinden sich unter:

    Code kopieren
    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Servers,CN=Server

  2. Geben Sie für das Attribut Name einen neuen Zeichenfolgenwert ein, der mit dem Wert des Attributs CN übereinstimmt.

Weitere Informationen zum Verwenden des LDP-Tools finden Sie im Microsoft Knowledge Base-Artikel 260745 „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Weitere Informationen zur Verwendung der ADSI-Bearbeitung finden Sie im Abschnitt „Adsiedit.msc: ADSI Bearbeitung" in der Hilfe zu Windows Server.


Zwischen dem Active Directory-Server und diesem Exchange-Server bestehen mehrere Netzwerke.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) WIN32_PingStatus im Namespace root\\cimv2 ab, um den Wert für den Schlüssel RouteRecord zu bestimmen. Der Schlüssel RouteRecord enthält einen Eintrag der zwischenzeitlichen Hops (beispielsweise die Anzahl der Router) zwischen dem Exchange-Server und dem Domänencontroller. Exchange Server Analyzer zählt die Router, die im Schlüssel RouteRecord aufgeführt sind. Wenn Exchange Server Analyzer ermittelt, dass mehr als ein Router aufgeführt ist, wird ein Fehler gemeldet.

Ein optimaler Active Directory®-Verzeichnisdienst ist so konzipiert, dass der Exchange Server-Computer mit einem Domänencontroller oder globalen Katalogserver des Subnetzes kommunizieren kann. Dieser Fehler weist darauf hin, dass der Exchange Server-Computer mit Domänencontrollern in Netzwerken kommunziert, die mehr als einen Hop entfernt sind.

So berichtigen Sie diesen Fehler

  1. Prüfen Sie die Netzwerktopologie, und bewerten Sie die Aufstellung der Active Directory-Server neu.

  2. Überwachen Sie die Ereignisprotokolle des Exchange-Servers und des Domänencontrollers, um festzustellen, ob netzwerkbezogene Ereignisse protokolliert wurden, die auf ein oder mehrere Probleme hinweisen.

  3. Überprüfen Sie das Design des Active Directory-Standorts. Wenn das Netzwerk nicht entsprechend dieser Spezifikation konfiguriert ist, sollten Sie es möglicherweise in mehrere Active Directory-Standorte aufteilen.

Weitere Details zur WMI-Klasse Win32_PingStatus finden Sie im MSDN-Artikel „Win32_PingStatus" (http://go.microsoft.com/fwlink/?linkid=33549).

Weitere Informationen zum Active Directory-Standortdesign finden Sie unter „Designing the Site Topology" (http://go.microsoft.com/fwlink/?LinkId=33551).


Zu viele Hops
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-07-06

Das Tool Microsoft® Exchange Server Analyzer sendet eine Testnachricht vom Server mit Exchange an das Postmasterkonto oder ein benutzerdefiniertes Konto für die SMTP-Domäne (Simple Mail Transfer Protocol) und untersucht anschließend die Nachrichtenverfolgungsprotokolle des Servers, um zu bestimmen, ob bei der Übermittlung der Testnachricht Probleme aufgetreten sind.

Im Rahmen dieser Untersuchung fragt Exchange Server Analyzer für jeden Server, an den die Nachricht übertragen wird, die Eigenschaft MessageID der Microsoft WMI-Klasse (Windows® Management Instrumentation, Windows®-Verwaltungsinstrumentation) Exchange_MessageTrackingEntry unter dem Namespace root\MicrosoftExchangeV2 ab.

Eine Nachricht kann über viele verschiedene SMTP-Server geroutet werden, bevor die Nachricht ihr endgültiges Ziel erreicht. Jeder Server in dieser Route wird als Hop bezeichnet.

Wenn die Anzahl der Exchange_MessageTrackingEntry-Instanzen für die jeweilige MessageID auf 30 anwächst, zeigt Exchange Server Analyzer einen Fehler an.

Dieser Fehler weist darauf hin, dass die Testnachricht u. U. in einer Schleife übertragen wird. Von Exchange Server Analyzer wurde daher die Abfrage weiterer Exchange_MessageTrackingEntry-Instanzen als Sicherheitsmaßnahme vor einer möglicherweise unendlichen Schleife eingestellt.

Mithilfe einer weiteren Analyse des Abschnitts Protokoll der Nachrichtenverfolgung der Exchange Server Analyzer-Ausgabe können Sie ermitteln, ob eine Schleifenbedingung vorhanden ist.


Nicht unterstützte Konfiguration des virtuellen Computers - Exchange Server-Cluster erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_ComputerSystem ab, um zu ermitteln, ob für den Schlüssel Model der Wert „Virtual Machine" festgelegt wurde.

Exchange Server Analyzer fragt außerdem die WMI-Klasse Win32_Service ab, um den Wert des Schlüssels Started für den Windows-Clusterdienst ClusSvc zu bestimmen. Der Wert True für den Sschlüssel Started gibt an, dass der Clusterdienst gestartet wurde, der Wert False bedeutet, dass der Clusterdienst nicht ausgeführt wird.

Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Der Wert für den Schlüssel Model ist auf „Virtual Machine" festgelegt.

  • Der Wert für den Schlüssel Started wurde für den Cluster-Dienst auf True gesetzt.

Dieser Fehler zeigt an, dass der Exchange-Server in einem Cluster und in einer Umgebung mit virtuellen Computern ausgeführt wird. Diese Konfiguration wird nicht unterstützt.

So beheben Sie diesen Fehler

  1. Bauen Sie einen physischen Cluster auf und verschieben Sie die Postfächer aus dem Exchange Server-Cluster, auf dem die virtuelle Umgebung ausgeführt wird, in den physischen Cluster.

  2. Wenn Sie kein physisches Cluster erstellen können, können Sie diesen Fehler folgendermaßen beheben:

    1. Verschieben Sie die Postfächer aus dem Exchange Server, der in der virtuellen Umgebung ausgeführt wird, auf auf einen nicht virtuellen, unabhängigen Exchange Server-Computer.

    2. Lagern Sie bei Bedarf Öffentliche Ordner aus, und übertragen Sie Rollen, die von dem Exchange-Server im Cluster ausgeführt werden.

    3. Deinstallieren Sie Exchange Server von dem virtuellen Computer, um das Produkt außer Betrieb zu nehmen und aus Ihrer Exchange Server-Infrastruktur und aus Active Directory zu entfernen.

Weitere Informationen zur Unterstützung durch Microsoft für den Betrieb von Exchange Server 2003 in virtuellen Umgebungen finden Sie im Microsoft Knowledge Base-Artikel 320220 „Support Boundaries for Exchange Server on a Virtual Machine or an Emulation Machine" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).


Nicht unterstützte Konfiguration des virtuellen Computers - Exchange Server 2003 Service Pack 2 oder höher nicht erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_ComputerSystem ab, um zu ermitteln, ob für den Schlüssel Model der Wert „Virtual Machine" festgelegt wurde.

Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Objekte mit der Objektklasse msExchExchangeServer zu ermitteln. If the string value includes "Version 5.5", the computer is running Exchange Server 5.5. Wenn der Zeichenfolgenwert „Version 6.0" enthält, wird auf dem Computer Microsoft Exchange 2000 Server ausgeführt. Wenn der Wert die Zeichenfolge „Version 6.5" enthält, wird auf dem Computer Exchange Server 2003 ausgeführt. Wenn der Wert die Zeichenfolgen „Version 6.5" und „Service Pack 2" enthält, wird auf dem Computer Exchange Server 2003 mit Service Pack 2 (SP2) ausgeführt.

Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Der Schlüssel Model ist auf „Virtual Machine" festgelegt.

  • Der Computer führt nicht Exchange Server 2003 mit Service Pack 2 oder höher aus.

Dieser Fehler zeigt an, dass der Exchange-Server ein virtueller Computer ist, dass aber Exchange Server 2003 Service Pack 2 oder höher nicht installiert ist. Diese Konfiguration wird nicht unterstützt.

So beheben Sie diesen Fehler

  1. Installieren Sie Exchange Server 2003 Service Pack 2 oder höher.

  2. Lesen Sie den Microsoft Knowledge Base-Artikel 320220, „Support policy for Exchange Server 2003 running on hardware virtualization software" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220.

  3. Wenn Sie Service Pack 2 oder höher nicht anwenden können, können Sie diesen Fehler wie folgt beheben:

    1. Verschieben Sie die Postfächer aus dem Exchange Server, der unter Virtual Server 2005 ausgeführt wird, auf auf einen nicht virtuellen Exchange Server-Computer.

    2. Lagern Sie bei Bedarf Öffentliche Ordner aus, und übertragen Sie Rollen, die von dem virtuellen Exchange-Server ausgeführt werden.

    3. Deinstallieren Sie Exchange Server von dem virtuellen Computer, um das Produkt außer Betrieb zu nehmen und aus Ihrer Exchange Server-Infrastruktur und aus Active Directory zu entfernen.


Nicht unterstützte Konfiguration des virtuellen Computers - Erweiterungen für virtuelle Computer nicht erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_ComputerSystem ab, um zu ermitteln, ob für den Schlüssel Model der Wert „Virtual Machine" festgelegt wurde.

Exchange Server Analyzer liest auch den folgenden Registrierungseintrag, um zu bestimmen, ob zusätzlich virtuelle Computer installiert wurden:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Die Existenz dieses Registrierungspfades zeigt an, dass Erweiterungen für virtuelle Computer installiert worden sind. Wenn dieser Registrierungspfad nicht vorhanden ist, gibt dies an, dass die Erweiterungen für virtuelle Maschinen nicht installiert wurden.

Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Der Wert für den Schlüssel Model ist auf „Virtual Machine" festgelegt.

  • Der Registrierungspfad ist vorhanden.

Dieser Fehler zeigt an, dass der Exchange-Server ein virtueller Computer ist, dass aber die Erweiterungen für virtuellen Computer nicht installiert sind. Diese Konfiguration wird nicht unterstützt.

So installieren Sie die Erweiterungen für Virtuelle Computer

  1. Sichern Sie den Exchange-Server, der in der virtuellen Umgebung ausgeführt wird.

  2. Installieren Sie mithilfe der Verwaltungskonsole von Virtual Server 2005 oder der Website die Erweiterungen für virtuelle Computer.

Weitere Informationen zum Betrieb von Exchange Server 2003 in einer virtuellen Umgebung finden Sie im Microsoft Knowledge Base-Artikel 320220 „Support policy for Exchange Server 2003 running on hardware virtualization software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).


Aktualisierung für Sommerzeit verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-07-30

Das Tool Microsoft Exchange Analyzer fragt den Active Directory-Verzeichnisdienst ab, um den Wert des Attributs versionNumber für jedes Exchange Server-Objekt zu ermitteln. Das Attribut versionNumber gibt die Exchange Server-Version an, die auf dem Computer ausgeführt wird.

Exchange Analyzer fragt außerdem die Microsoft WMI-Klasse (Windows Management Instrumentation) CIM_Datafile ab, um den Wert des Schlüssels Version für den Prozess Store.exe zu ermitteln.

  • Der Wert 7638 für den Schlüssel Version bedeutet, dass Exchange Server 2003 Service Pack 2 installiert ist.

  • Der Wert 7226 für den Schlüssel Version bedeutet, dass Exchange Server 2003 Service Pack 1 installiert ist.

  • Der Wert 6944 für den Schlüssel Version bedeutet, dass die Originalversion von Exchange Server 2003 installiert ist.

  • Ein Wert zwischen den oben genannten Versionen zeigt an, dass der Server eine Hotfix-Aktualisierungsversion des Prozesses Store.exe ausführt.

Wenn Exchange Analyzer feststellt, dass der Schlüssel Version für Store.exe auf einem Servercomputer mit Exchange Server 2003 SP2 einen Wert aufweist, der kleiner als 7561 ist, oder auf einem Servercomputer mit Exchange Server 2003 SP1 einen Wert aufweist, der kleiner als 7234 ist, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass der Computer mit Exchange Server die Version Exchange Server 2003 Service Pack 1 oder Exchange Server 2003 SP2 ohne die Aktualisierung für die Änderungen der Sommerzeit im Jahr 2007 ausführt.

Ohne diese Aktualisierung verhalten sich Kalenderelemente in CDO-basierten Programmen und in Outlook Web Access während der zusätzlichen Wochen der Sommerzeit so, als würde die Standardzeit gelten.

So beheben Sie dieses Problem für Exchange Server 2003 SP2

  1. Befolgen Sie die Anweisungen im Microsoft Knowledge Base-Artikel 926666, "Aktualisierung für Änderungen der Sommerzeit im Jahr 2007 für Exchange 2003 Service Pack 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=926666).
So beheben Sie dieses Problem für Exchange Server 2003 SP1

  1. Befolgen Sie die Anweisungen im Microsoft Knowledge Base-Artikel 931978, "Aktualisierung für Änderungen der Sommerzeit im Jahr 2007 für Exchange 2003 Service Pack 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=931978).


Das Updaterollup für Windows 2000 SP4 wurde nicht installiert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) ab, um den aktuellen Wert für den Schlüssel ServicePackMajorVersion zu bestimmen. Microsoft Exchange Server Analyzer untersucht auch den folgenden Registrierungseintrag, um die Windows-Version zu ermitteln, die auf dem Zielcomputer ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Wenn Microsoft Exchange Server Analyzer ermittelt, dass das Zielsystem das Windows 2000 Server-Betriebssystem ausführt, aber nicht das Update-Rollup für Service Pack 4 von Windows 2000 Server, wird eine Warnung angezeigt.

Als optimale Vorgehensweise wird empfohlen, dass Sie die neuesten Service Packs und Rollups für die gesamte Software in der Exchange-Bereitstellung installieren.

So beheben Sie diese Warnung

  1. Aktualisieren Sie alle Domänencontroller und globalen Katalogserver, auf denen ein Produkt der Windows 2000 Server-Produktfamilie ausgeführt wird, auf das Update-Rollup für Service Pack 4, und wenden Sie die neuesten Hotfixes und Updates von Windows Update an.

  2. Aktualisieren Sie alle Exchange Server-Computer mit dem neuesten Rollup und Update-Rollup.

Weitere Informationen zum Update-Rollup für Windows 2000 SP4 finden Sie im Microsoft Knowledge Base-Artikel 891861, „Update-Rollup 1 für Windows 2000 SP4 und bekannte Probleme" (http://support.microsoft.com/kb/891861/de).

Weitere Informationen zum Erwerb und zur Installation von Service Packs und Rollups für Exchange Server finden Sie auf der Exchange Server-Website unter http://go.microsoft.com/fwlink/?LinkId=21573.


URLScan ist installiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-04-20

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um zu ermitteln, ob die folgende Datei unter folgendem Pfad auf dem Exchange-Server vorhanden ist:

%WINDOWSPATH%\\SYSTEM32\\INETSRV\URLSCAN\URLSCAN.DLL

Wenn Urlscan.dll vorhanden ist, bedeutet dies, dass auf dem Exchange-Server das Dienstprogramm URLScan installiert ist. Wenn Microsoft Exchange Server Analyzer feststellt, dass URLScan auf einem Exchange-Server installiert ist, wird eine Meldung mit empfohlenen optimalen Methoden angezeigt.

Bei URLScan handelt es sich um einen ISAPI-Filter (Internet Server Application Programming Interface), mit dessen Hilfe Administratoren von Websites festlegen ko¨nnen, welche HTTP-Anforderungen vom Server verarbeitet werden sollen. Durch das Blockieren bestimmter HTTP-Anforderungen verhindert der URLScan-Filter, dass potenziell gefa¨hrliche Anforderungen den Server erreichen und Schaden verursachen ko¨nnen.

Wenn Sie URLScan auf einem Exchange-Server ausfu¨hren, empfiehlt es sich, Urlscan.ini fu¨r die Rolle des jeweiligen Exchange-Servers zu konfigurieren. Zur Gewa¨hrleistung einer erho¨hten Sicherheit des Exchange-Servers muss die Konfigurationsdatei Urlscan.ini bearbeitet werden. Entfernen Sie hierzu alle nicht erforderlichen Funktionen. Zum Anpassen der Datei Urlscan.ini fu¨r eine bestimmte Exchange Server 2003-Computerrolle mu¨ssen Sie im Abschnitt [AllowVerbs] der Datei Urlscan.ini Verben entfernen. Vergewissern Sie sich jedoch, dass die fu¨r die jeweilige Computerrolle empfohlenen Verben enthalten bleiben, um eine ordnungsgema¨ße Funktion zu gewa¨hrleisten. Wenn auf einem einzelnen Computer mehrere webbasierte Features erforderlich sind, mu¨ssen die entsprechenden Anforderungen fu¨r den Abschnitt [AllowVerbs] zusammengefu¨hrt werden.

Sie ko¨nnen die Datei Urlscan.ini mithilfe der in der Urlscan-Vorlage fu¨r Exchange Server 2003 enthaltenen Informationen an die Exchange Server 2003-Computerrolle anpassen. Die Vorlage finden Sie im Microsoft Knowledge Base-Artikel 823175 „Fine-tuning and known issues when you use the Urlscan utility in an Exchange 2003 environment" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823175).

Weitere Informationen zu URLScan finden Sie unter „UrlScan Security Tool" (http://go.microsoft.com/fwlink/?LinkId=24490).

Weitere Informationen zum Verwenden von URLScan in einer Exchange Server-Umgebung finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 309677, „XADM: Bekannte Probleme und Feineinstellung bei Verwendung des IIS-Sicherheits-Assistenten in einer Exchange 2000-Umgebung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=309677)

  • 309508, „XCCC: IIS-Lockdown- und URLscan-Konfigurationen in einer Exchange-Umgebung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=309508)

  • 325965, „The URLScan tool may cause problems in Outlook Web Access" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325965)

  • 326444, „SO WIRD'S GEMACHT: Konfigurieren des Dienstprogramms URLScan" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326444)


USERVA wird falsch festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-09-19

Microsoft® Exchange Server Analyzer fragt drei Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) ab, um die Größe des physischen Speichers in dem Exchange Server-Computer und die Größe des virtuellen Adressenspeicherplatzes zu bestimmen, der für Prozesse im Benutzermodus reserviert wird, die auf dem Exchange Server-Computer ausgeführt werden. In der folgenden Tabelle werden die Klassen und Schlüssel beschrieben, die von Microsoft Exchange Server Analyzer ausgewertet werden.

Abgefragte Klasse | Abgefragte Schlüssel | Beschreibung
Win32_OperatingSystem | MaxProcessMemorySize | Maximaler Speicher in KB, der einem Prozess zugewiesen werden kann.
Win32_ComputerSystem | TotalPhysicalMemory | Größe des Arbeitsspeichers (RAM, Random Access Memory) in Byte, der im Computer installiert ist.
Win32_Service | Started | Status der Dienstinstanz. Der Wert True gibt an, dass der Dienst ausgeführt wird; der Wert False gibt an, dass der Dienst nicht ausgeführt wird.

Microsoft Exchange Server Analyzer liest außerdem den folgenden Registrierungseintrag, um die Microsoft Windows-Version zu bestimmen, die auf dem Exchange Server-Computer ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Der Wert 4.0 für CurrentVersion gibt an, dass auf dem Exchange Server-Computer Microsoft Windows NT® 4.0 ausgeführt wird. Der Wert 5.0 zeigt an, dass auf dem Exchange Server-Computer Windows 2000 Server ausgeführt wird, und der Wert 5.2 zeigt an, dass auf dem Exchange Server-Computer Windows Server™ 2003 ausgeführt wird.

Schließlich sendet Exchange Server Analyzer eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Zähler für das Attribut homeMDBBL des Postfachspeicherobjekts (msExchPrivateMDB) zu bestimmen. Das Ergebnis ist die Anzahl der Postfächer auf dem Exchange Server-Computer.

Wenn Exchange Server Analyzer feststellt, dass alle folgende Kriterien erfüllt sind, wird eine Warnmeldung angezeigt:

  • Der Exchange Server-Computer wird auf Windows Server 2003 ausgeführt.

  • Der Wert TotalPhysicalMemory ist größer als 1073741824.

  • Der Wert MaxProcessMemorySize ist gleich 3145600.

  • Der Clusterdienst (ClusSvc) hat für Win32_Service\Started den Wert True, oder der Exchange Server-Computer enthält mehr als 20 Postfächer.

Diese Warnung gibt an, dass der Exchange Server-Computer nicht optimal für die Verwendung von virtuellem Speicher konfiguriert ist. Speziell /USERVA 3030 = Startschalter ist in der Datei Boot.ini des Exchange Server-Computers nicht vorhanden. Das Hinzufügen dieses Schalters ermöglicht eine größere Skalierbarkeit und bessere Leistung.

Windows Server 2003 unterstützt für boot.ini zwei Startschalter (/3GB und /USERVA), mit denen Sie die Zuweisung und Verwendung des Speichers und Speicheradressraums festlegen können. Ungeachtet der Menge des physischen Speichers im System verwendet Windows einen virtuellen Adressraum von 4 GB, wobei 2 GB Prozessen im Benutzermodus (z. B. Anwendungen) und 2 GB Prozessen im Kernelmodus (z. B. Treibern für das Betriebssystem und den Kernelmodus) zugewiesen sind. Diese Startschalter können zum Reservieren von mehr Speichers für Anwendungen (3 GB) und weniger Arbeitsspeicher für das Betriebssystem (1 GB) auf Systemen verwendet werden, die über mindestens 1 GB physischen Arbeitsspeicher verfügen. Dieser zusätzliche virtuelle Adressenspeicherplatz hilft beim Reduzieren des Grads der Speicherfragmentierung im Informationsspeicherprozess auf einem Exchange Server-Computer. Der /3GB-Schalter wird verwandt, um diese Zuordnungsänderung zu beeinflussen. Der Schalter wird in der Datei Boot.ini des Systems eingegeben und tritt nach einem Neu-Start in Kraft. Dieser Schalter sollte nur auf Exchange-Servern mit einem Speicher ab 1 GB verwendet werden, auf denen eines der folgenden Betriebssysteme ausgeführt wird:

  • Microsoft Windows Server 2003, Standard Edition

  • Microsoft Windows Server 2003, Enterprise Edition

  • Microsoft Windows Server 2003, Datacenter Edition

Wichtig:
Der /3GB-Schalter darf nicht unter Windows 2000 Server verwendet werden, da er nicht unterstützt wird und zu Abstürzen des Betriebssystems oder von Anwendungen führen kann. Darüber hinaus wird der /3GB-Schalter unter den oben genannten Betriebssystemen nur unterstützt, wenn ein physischer Speicher von mindestens 1 GB verfügbar ist. Darüber hinaus sollte der /3GB-Schalter nicht auf Active Directory-Servern (Domänencontrollern und globalen Katalogservern) verwendet werden, auf denen Windows Server 2003, Standard Edition, ausgeführt wird.

Der Schalter /USERVA wurde neu in Windows Server 2003 eingeführt. Mithilfe des Schalters kann die Unterteilung des virtuellen Adressraums zwischen Prozessen im Benutzermodus und Prozessen im Kernelmodus präziser gesteuert werden. Dieser Schalter sollte nur für Anwendungen verwendet werden, z. B. Exchange Server 2003, und zwar mit den bestimmten Werten, die von den Anwendungen unterstützt werden. Bei der Verwendung in Exchange Server 2003-Systemen sollte /USERVA immer 3030 entsprechen (d. h. /USERVA=3030). Dieser Wert bewirkt, dass dem Betriebssystem zusätzlich 40 MB zugewiesen werden, sodass Sie weitere Benutzer hinzufügen können, ohne dass alle verfügbaren Systemressourcen belegt werden.

So beheben Sie diese Warnung unter Windows Server 2003

  1. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und wählen Sie Eigenschaften aus. Das Dialogfeld Systemeigenschaften wird angezeigt.

  2. Klicken Sie auf die Registerkarte Erweitert.

  3. Klicken Sie im Bereich Starten und Wiederherstellen auf Einstellungen. Das Dialogfeld Starten und Wiederherstellen wird angezeigt.

  4. Klicken Sie im Bereich Systemstart auf Bearbeiten. Dadurch wird die Windows-Datei Boot.ini in Microsoft Editor geöffnet.

  5. Fügen Sie der Startzeile im Abschnitt [Operating Systems] die folgenden Optionen hinzu: /3GB /USERVA=3030

  6. Speichern Sie die Änderungen, und schließen Sie Editor.

  7. Klicken Sie zweimal auf OK, um die geöffneten Dialogfelder zu schließen, und starten Sie den Verzeichnisserver anschließend neu, damit die Änderung wirksam wird.

Weitere Informationen zum Verwenden der Startschalter /3GB und /USERVA finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 297812, "Verwenden der 4GT RAM-Optimierungsfunktion" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901, "Auswirkungen der 4GT-Optimierung auf Seitentabelleneinträge des Systems" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901

  • 316739, "Verwenden der Befehlszeilenoption /userva mit der Befehlszeilenoption /3GB, um den Speicherbereich für den Benutzermodus auf einen Wert zwischen 2 GB und 3 GB festzulegen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739).

  • 325044, "SO WIRDS GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).

  • 815372, "Optimieren der Speichernutzung in Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Für die auf diesem Computer installierte Datei „Tcpip.sys" ist möglicherweise ein Hotfix erforderlich
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile ab, um zu ermitteln, ob für den Schlüssel Version der Datei Tcpip.sys ein Wert festgelegt wurde. Wenn Exchange Server Analyzer feststellt, dass der Wert des Schlüssels Version einer bestimmten Version der Datei Tcpip.sys entspricht, zeigt Exchange Server Analyzer eine Warnung an.

Weitere Informationen zu dieser Warnung erhalten Sie in den Empfehlungen im Microsoft Knowledge Base-Artikel 898060 „Die Installation des Sicherheitsupdates MS05-019 oder von Windows Server 2003 Service Pack 1 kann dazu führen, dass die Netzwerkverbindungen zwischen Clients und Servern fehlschlagen" (http://support.microsoft.com/kb/898060/de).


Konfiguration mit virtuellem Computer festgestellt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_ComputerSystem ab, um zu ermitteln, ob für den Schlüssel Model der Wert „Virtual Machine" festgelegt wurde.

Exchange Server Analyzer fragt außerdem die WMI-Klasse Win32_Service ab, um den Wert des Schlüssels Started für den Windows-Clusterdienst ClusSvc zu bestimmen. Der Wert „True" für den Schlüssel Started gibt an, dass der Cluster-Dienst gestartet wurde. Der Wert False gibt an, dass der SMSMSE-Dienst nicht ausgeführt wird.

Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Objekte mit der Objektklasse msExchExchangeServer zu ermitteln. Wenn die Zeichenfolge den Wert „Version 6.5" and „Service Pack 2" enthält, wird auf dem Computer Microsoft Exchange Server 2003 mit Service Pack 2 (SP2) ausgeführt.

Schließlich liest Exchange Server Analyzer den folgenden Registrierungseintrag, um zu bestimmen, ob zusätzlich virtuelle Computer installiert wurden:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Die Existenz dieses Registrierungspfades zeigt an, dass Erweiterungen für virtuelle Computer installiert worden sind. Das Fehlen dieses Registrierungspfades zeigt an, dass keine Erweiterungen für virtuelle Computer installiert worden sind.

Microsoft Exchange Server Analyzer zeigt eine Meldung mit der optimalen Methode an, wenn die folgenden Bedingungen erfüllt sind:

  • Der Exchange-Server läuft als Gast unter Microsoft Virtual Server 2005.

  • Auf dem Exchange-Server wird Exchange Server 2003 mit Service Pack 2 oder höher ausgeführt.

  • Bei dem Server handelt es sich nicht um einen Exchange-Server, der Teil eines Clusters ist.

  • Die Erweiterungen für virtuelle Computer mit Virtual Server 2005 wurden auf dem Exchange-Server installiert.

Es gibt verschiedene Anforderungen, aufgrund derer diese Konfiguration eingesetzt wird, obwohl Exchange Server Analyzer sie nicht erkennen kann. Deshalb empfehlen wir, dass Sie aus dem folgenden Artikel aktuellste Informationen über Supporteignung und Durchsatzverbesserung in dieser Konfiguration gewinnen, ehe Sie Exchange Server 2003 in einer Umgebung mit Virtual Server 2005 einsetzen:

Microsoft Knowledge Base-Artikel 320220, „Support policy for Exchange Server 2003 running on hardware virtualization software" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220.


Virtueller Speicher ist fragmentiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2007-02-15

Microsoft Exchange Analyzer fragt die Microsoft WMI-Klasse (Windows Management Instrumentation - Windows-Verwaltungsinstrumentation) Win32_NTLogEvent ab, um zu ermitteln, ob innerhalb der letzten 24 Stunden für MSExchangeIS eine Warnung für ein Ereignis 9582 aufgetreten ist.

Wenn Exchange Analyzer feststellt, dass in den letzten 24 Stunden ein Ereignisse 9582 protokolliert wurde, wird ein Fehler angezeigt.

Dieser Fehler zeigt an, dass der zum Ausführen des Exchange-Servers benötigte virtuelle Speicher fragmentiert ist.

In 32-Bit-Systemen von Microsoft Windows gibt es zwei Arten von Arbeitsspeicher:

  • Physischer Speicher Größe des tatsächlich im System installierten Speichers

  • Virtueller Speicheradressraum Ein virtueller Speicherbereich von 4 GB

Die Gesamtgröße des virtuellen Adressraums bleibt immer gleich, unabhängig von der Größe des im System installierten physischen Arbeitsspeichers: 4 GB. Auch wenn dies nicht für alle 32-Bit-Anwendungen gilt: Bei Exchange Server entspricht der virtuelle Adressraum dem virtuellen Speicher. Die Begriffe werden austauschbar verwendet.

Zum normalen Betrieb des Exchange-Datenspeichers gehört das wiederholte Zuweisen, Verwenden und Freigeben von virtuellem Speicher. Häufiges Zuweisen, Verwenden und Freigeben von virtuellem Speicher kann eine Fragmentierung des virtuellen Speichers verursachen. Die Fragmentierung des virtuellen Speichers entspricht der Fragmentierung des Dateisystems, die im Lauf der Zeit auftreten kann. Nach einer gewissen Zeit sind die zugewiesenen Segmente des virtuellen Speichers nicht mehr zusammenhängend, und die Leistung wird beeinträchtigt. Im Dateisystem können Sie eine Anwendung ausführen, die das Dateisystem defragmentiert. In den meisten Fällen ist dies möglich, während das System online ist und auf das System zugegriffen wird. Für die Fragmentierung von virtuellem Speicher ist kein Defragmentierungstool vorhanden. Stattdessen müssen Sie den Microsoft Exchange-Informationsspeicherdienst beenden und neu starten, um das Problem zu beheben.

So beheben Sie dieses Problem

  • Die Fragmentierung des virtuellen Speichers kann durch Software von Drittanbietern verursacht sein, die in den store/inetinfo-Prozessen ausgeführt wird. Vergewissern Sie sich, dass Sie über die neuesten Treiber für alle Anwendungen von Drittanbietern verfügen.

  • Verwenden Sie das Tool Leistungsprotokolle und Warnungen zum Überwachen des Leistungsindikators Gesamtanzahl von Bytes in freien großen Blöcken im VS für das Leistungsobjekt MSExchangeIS. Ermitteln Sie anhand der von diesem Leistungsindikator erfassten Daten das günstigste Zeitfenster innerhalb der nächsten 36 bis 72 Stunden, um den Server herunterzufahren und neu zu starten.

Hinweis:
Wenn es sich um einen Server handelt, der Teil eines Clusters ist, müssen Sie den passiven Knoten beenden und neu starten, bevor Sie die Clusterressourcen darauf verschieben, um sicherzustellen, dass der virtuelle Zielspeicher-Adressraum bereinigt ist.
  • Wenn das Problem nach einem Neustart weiter besteht, ziehen Sie in Betracht, die Software von Drittanbietern zu deaktivieren.

  • Ziehen Sie in Betracht, Postfächer zu einem anderen Server zu verschieben, um die Serverlast zu reduzieren. Kontrollieren Sie anschließend, ob das Problem behoben ist. Weitere Informationen finden Sie unter Verschieben von Benutzerpostfächern auf einen anderen Server.

Weitere Informationen

  • Weitere Informationen zum MSExchangeIS-Ereignis 9852 finden Sie unter "Events and Errors Message Center: Ereignisdetails" (http://go.microsoft.com/fwlink/?LinkId=83209).

  • Weitere Informationen zur Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen zur Problembehandlung bei Fragmentierung des virtuellen Speichers in Microsoft Exchange Server 2003 und Exchange 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 325044, "Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange Server 2003 und Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).

  • Weitere Informationen zum Optimieren der Nutzung des virtuellen Speichers finden Sie im Microsoft Knowledge Base-Artikel 815372 "Optimieren der Speichernutzung in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372).

  • Weitere Informationen zum Verschieben von Benutzerpostfächern zur Verringerung der Serverlast finden Sie unter Verschieben von Benutzerpostfächern auf einen anderen Server.


Virtual Server 2005 R2 oder später nicht erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-12-15

The Microsoft® Exchange Server Analyzer Tool queries the CIM_Datafile Microsoft Windows® Management Instrumentation (WMI) class to determine the value of the Version key for Vssrvc.exe, the process represented by the Virtual Server service included with Microsoft Virtual Server 2005. If the Exchange Server Analyzer finds the value of the Version key for Vssrvc.exe equal to 1.1.465.0, the Exchange Server Analyzer displays an error.

Dieser Fehler zeigt an, dass dieser Exchange-Server als Gast in einer Microsoft Virtual Server 2005-Umgebung ausgeführt wird, in der nicht Virtual Server 2005 R2 oder höher läuft. Diese Konfiguration wird nicht unterstützt. Exchange Server 2003 mit Service Pack 2 oder eine höhere Version wird als Gast in einer virtuellen Umgebung nur dann unterstützt, wenn es unter Microsoft Virtual Server 2005 R2 oder einer höheren Version ausgeführt wird.

So beheben Sie diesen Fehler

  1. Lesen Sie den Microsoft Knowledge Base-Artikel 320220, „Support policy for Exchange Server 2003 running on hardware virtualization software" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220.

  2. Installieren Sie Virtual Server 2005 R2 oder später Weitere Informationen zu Microsoft Virtual Server 2005 R2 finden Sie auf der Microsoft Virtual Server 2005 R2-Website unter http://go.microsoft.com/fwlink/?linkid=34938.

  3. Wenn Sie Virtual Server 2005 R2 oder höher nicht installieren können, können Sie diesen Fehler wie folgt beheben:

    1. Verschieben Sie die Postfächer aus dem Exchange Server, der unter Virtual Server 2005 ausgeführt wird, auf einen nicht virtuellen Exchange Server-Computer oder auf einen virtuellen Exchange Server-Computer, der unter Virtual Server 2005 R2 ausgeführt wird.

    2. Lagern Sie beliebige Öffentliche Ordner aus, und übertragen Sie Rollen, die ggf. von dem nicht unterstützten virtuellen Exchange-Server übernommen werden.

    3. Deinstallieren Sie Exchange Server von dem nicht unterstützten virtuellen Computer, um das Produkt außer Betrieb zu nehmen und aus Ihrer Exchange Server-Infrastruktur und aus Active Directory zu entfernen.


Der Leistungsindikator „Virenscanner - Warteschlangenlänge" hat den Schwellenwert überschritten
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-02-27

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Virus Scan Queue Length-Leistungsindikator des MSExchangeIS-Leistungsobjekts.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Leistungsindikator Virus Scan Queue Length auf dem 90. Perzentil während des Erfassungszeitraums größer als 10 ist, wird ein Fehler angezeigt.

Der Leistungsindikator Virus Scan Queue Length gibt die aktuelle Anzahl der ausstehenden Anforderungen an, die sich in der Warteschlange für die Virenprüfung befinden.

Dieser Fehler kann auf Leistungsprobleme im Zusammenhang mit folgenden Ursachen hinweisen:

  • Gesunkene Serverleistung, in der Regel verursacht durch einen Prozessorengpass.

  • Ungewöhnlich große Serverlast.

  • Ein veraltetes Virenscannermodul.

  • Ein fehlerhaft konfiguriertes Virenscannermodul.

Um diesen Fehler zu beheben, führen Sie folgende Schritte aus:

  • Suchen Sie nach Aktualisierungen für das Virenscannermodul.

  • Ziehen Sie es in Betracht, die Virenscannersoftware erneut zu installieren.

  • Untersuchen Sie die Konfiguration Ihres Virenscannermoduls hinsichtlich der ordnungsgemäßen Threadkonfiguration, Ausschlüssen auf Dateiebene usw. Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Ermitteln Sie mithilfe des Systemmonitors (Perfmon.msc), ob der Engpass von einer erhöhten Serverlast verursacht wird oder weil der Server unterdimensioniert ist. Wenn die Serverlast angestiegen ist, müssen Sie die Quelle der Last ausfindig machen und sie verringern. Verfügt der Server nicht über ausreichende Ressourcen, erhöhen Sie die notwendigen Ressourcen oder verschieben Benutzer von diesem Server auf einen anderen.

Beheben von Prozessorengpässen

Es gibt viele Möglichkeiten, um Prozessorengpässe auf Ihrem Exchange-Server zu beheben.

  • Überprüfen Sie zunächst die Anwendungen oder Aufgaben, die Serverlast verursachen. Ermitteln Sie, ob die Anwendung die tatsächlich verwendete Prozessorzeit wirklich benötigt, oder ob es möglicherweise ein Problem mit dem Prozess gibt.

  • Wenn eine nicht zu Exchange gehörende Anwendung für den Server nicht wichtig ist, führen Sie diese Anwendung auf einem anderen Server aus. Wenn diese Anwendung auf einem anderen Server ausgeführt werden kann, verschieben Sie ebenfalls Serverfunktionen auf andere Computer. Wenn beispielsweise der Inetinfo-Prozess einen großen Teil der CPU-Auslastung beansprucht, sollten Sie Front-End-Server hinzufügen, damit diese die Aufgaben der Protokollarbeit übernehmen, die von Inetinfo ausgeführt wird. Sie können auch den Zugriff auf Öffentliche Ordner auf einen dedizierten Server für Öffentliche Ordner umlenken. Schließlich können Sie bei einem Server, der viele Erweiterungen von Verteilerlisten vornimmt, die CPU-Auslastung verringern, indem Sie das Erweitern von Verteilerlisten auf einen speziell für die Erweiterung von Verteilerlisten vorgesehenen Server verschieben.

  • Fügen Sie dem Server zusätzliche oder schnellere Prozessoren hinzu, sofern dies möglich ist. Aktivieren Sie außerdem Hyper-Threading, wenn dies von den Prozessoren unterstützt wird. Sie aktivieren Hyper-Threading, indem Sie das System-BIOS entsprechend konfigurieren. Weitere Informationen finden Sie in der Hilfedokumentation des Computerherstellers.

  • Wenn sich die Prozessorleistung nicht steigern lässt, müssen Sie die Last auf den Prozessoren reduzieren. Um die Gesamtauswirkung auf den Server zu verringern, muss sichergestellt werden, dass E/A-intensive Aufgaben sowie CPU-intensive oder besonders speicherintensive Aufgaben außerhalb der normalen Betriebszeiten verarbeitet werden.

  • Stellen Sie sicher, dass prozessorintensive Aufgaben wie Sicherungs- und Wartungsaufgaben außerhalb der Spitzenlastzeiten ausgeführt werden. Sorgen Sie außerdem dafür, dass diese Aufgaben in einer phasenweisen Abfolge (Staging) ausgeführt werden. Unter dem Staging (Phasenplanung) einer Aufgabe ist zu verstehen, dass für jede Aufgabe unterschiedliche Start- und vorzugsweise auch Endzeiten definiert werden. Durch Staging der Wartung und Sicherung von Datenbanken oder Speichergruppen werden die Auswirkungen dieser ressourcenintensiven Aufgaben verringert.

Weitere Informationen

  • Eine Übersicht über Exchange Server und Virenscanner finden Sie im Microsoft Knowledge Base-Artikel 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Weitere Informationen über Virenscanner und Exchange Server finden Sie im Microsoft Knowledge Base-Artikel 285667, „XADM: Informationen zur Virus Scanning API 2.0 in Exchange 2000 Server SP1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285667).

  • Weitere Informationen über Leistungsengpässe bei Prozessoren finden Sie unter Prozessorengpass.

  • Weitere Informationen zur Leistung von Exchange Server finden Sie im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange Server finden Sie im Handbuch Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen zum Verschieben von Benutzerpostfächern zur Verringerung der Serverlast finden Sie unter Verschieben von Benutzerpostfächern auf einen anderen Server.


Der Leistungsindikator „Virenscanner - Warteschlangenlänge" hat den Warnungsschwellenwert überschritten
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-04-20

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Virus Scan Queue Length-Leistungsindikator des MSExchangeIS-Leistungsobjekts.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Leistungsindikator Virus Scan Queue Length auf dem 90. Perzentil während des Erfassungszeitraums größer als 5 ist, wird eine Warnung angezeigt.

Der Leistungsindikator Virus Scan Queue Length gibt die aktuelle Anzahl der ausstehenden Anforderungen an, die sich in der Warteschlange für die Virenprüfung befinden.

Diese Warnung weist darauf hin, dass es bei diesem Server zu einem Leistungsproblem kommen kann. Die Leistungsprobleme könnten mit folgenden Ursachen in Zusammenhang stehen:

  • Gesunkene Serverleistung, in der Regel verursacht durch einen sich anbahnenden Prozessorengpass.

  • Ungewöhnlich große Serverlast.

  • Ein veraltetes Virenscannermodul.

  • Ein fehlerhaft konfiguriertes Virenscannermodul.

Um diese Warnung zu beheben, führen Sie folgende Schritte aus:

  • Suchen Sie nach Aktualisierungen für das Virenscannermodul.

  • Ziehen Sie es in Betracht, die Virenscannersoftware erneut zu installieren.

  • Untersuchen Sie die Konfiguration Ihres Virenscannermoduls hinsichtlich der ordnungsgemäßen Threadkonfiguration, Ausschlüssen auf Dateiebene usw. Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Ermitteln Sie mithilfe des Systemmonitors (Perfmon.msc), ob der sich anbahnende Engpass von einer erhöhten Serverlast verursacht wird oder weil der Server unterdimensioniert ist. Wenn die Serverlast angestiegen ist, müssen Sie die Quelle der Last ausfindig machen und sie verringern. Verfügt der Server nicht über ausreichende Ressourcen, erhöhen Sie die notwendigen Ressourcen oder verschieben Benutzer von diesem Server auf einen anderen.

Beheben von Prozessorengpässen

Es gibt viele Möglichkeiten, um Prozessorengpässe auf Ihrem Exchange-Server zu beheben:

  • Überprüfen Sie zunächst die Anwendungen oder Aufgaben, die Serverlast verursachen. Ermitteln Sie, ob die Anwendung die tatsächlich verwendete Prozessorzeit wirklich benötigt, oder ob es möglicherweise ein Problem mit dem Prozess gibt.

  • Wenn eine nicht zu Exchange gehörende Anwendung für den Server nicht wichtig ist, führen Sie diese Anwendung auf einem anderen Server aus. Ist dies möglich, verschieben Sie ebenfalls Serverfunktionen auf andere Computer. Wenn beispielsweise der Inetinfo-Prozess einen großen Teil der CPU-Auslastung beansprucht, sollten Sie Front-End-Server hinzufügen, damit diese die Aufgaben der Protokollarbeit übernehmen, die von Inetinfo ausgeführt wird. Sie können auch den Zugriff auf Öffentliche Ordner auf einen dedizierten Server für Öffentliche Ordner umlenken. Schließlich können Sie bei einem Server, der viele Erweiterungen von Verteilerlisten vornimmt, die CPU-Auslastung verringern, indem Sie das Erweitern von Verteilerlisten auf einen speziell für die Erweiterung von Verteilerlisten vorgesehenen Server verschieben.

  • Fügen Sie dem Server zusätzliche oder schnellere Prozessoren hinzu, sofern dies möglich ist. Aktivieren Sie außerdem Hyper-Threading, wenn dies von den Prozessoren unterstützt wird. Sie aktivieren Hyper-Threading, indem Sie das System-BIOS entsprechend konfigurieren. Weitere Informationen finden Sie in der Hilfedokumentation des Computerherstellers.

  • Wenn sich die Prozessorleistung nicht steigern lässt, müssen Sie die Last auf den Prozessoren reduzieren. Um die Gesamtauswirkung auf den Server zu verringern, muss sichergestellt werden, dass E/A-intensive Aufgaben sowie CPU-intensive oder besonders speicherintensive Aufgaben außerhalb der normalen Betriebszeiten verarbeitet werden.

  • Stellen Sie sicher, dass prozessorintensive Aufgaben wie Sicherungs- und Wartungsaufgaben außerhalb der Spitzenlastzeiten ausgeführt werden. Sorgen Sie außerdem dafür, dass diese Aufgaben in einer phasenweisen Abfolge (Staging) ausgeführt werden. Unter dem Staging (Phasenplanung) einer Aufgabe ist zu verstehen, dass für jede Aufgabe unterschiedliche Start- und vorzugsweise auch Endzeiten definiert werden. Durch Staging der Wartung und Sicherung von Datenbanken oder Speichergruppen werden die Auswirkungen dieser ressourcenintensiven Aufgaben verringert.

Weitere Informationen

  • Eine Übersicht über Exchange Server und Virenscanner finden Sie im Microsoft Knowledge Base-Artikel 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Weitere Informationen über Virenscanner und Exchange Server finden Sie im Microsoft Knowledge Base-Artikel 285667, „XADM: Informationen zur Virus Scanning API 2.0 in Exchange 2000 Server SP1" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285667).

  • Weitere Informationen über Leistungsengpässe bei Prozessoren finden Sie unter Prozessorengpass.

  • Weitere Informationen zur Leistung von Exchange Server finden Sie im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange Server finden Sie im Handbuch Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen zum Verschieben von Benutzerpostfächern zur Verringerung der Serverlast finden Sie unter Verschieben von Benutzerpostfächern auf einen anderen Server.


Fehler bei Volumebereitstellungspunkt: Windows Server 2003 SP1 ist nicht installiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2006-02-13

Microsoft® Exchange Server Analyzer fragt die Windows®-Verwaltungsinstrumentationsklasse (Windows® Management Instrumentation, WMI) CIM_Datafile ab, um zu überprüfen, dass der Mountmgr.sys-Treiber vorhanden ist.

Danach liest Exchange Server Analyzer folgenden Registrierungswert, um die Version des Microsoft Windows®-Betriebssystems zu ermitteln, das auf dem Exchange-Server ausgeführt wird: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Wenn für CurrentVersion der Wert 5.0 angegeben ist, führt der Exchange-Server Microsoft Windows 2000 Server aus. Wenn für CurrentVersion der Wert 5.2 angegeben ist, führt der Exchange-Server Microsoft Windows Server™ 2003 aus.

Exchange Server Analyzer fragt außerdem die Microsoft Windows®-Verwaltungsinstrumentationsklasse (Windows® Management Instrumentation, WMI) Win32_Service ab, um den Wert des Schlu¨ssels Started für den Clusterdienst (ClusSvc) zu ermitteln. Der Wert TRUE gibt an, dass der Clusterdienst gestartet wurde, und der Wert FALSE gibt an, dass der Clusterdienst nicht ausgeführt wird.

Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Der Exchange Server-Computer wird unter Windows Server 2003 ausgeführt.

  • Windows Server 2003 SP1 ist nicht installiert.

  • Der Exchange-Server wird in einer Clusterumgebung ausgeführt.

  • Es sind Volumebereitstellungspunkte vorhanden.

Die Warnung weist darauf hin, dass bei einer Aktualisierung der Exchange-Clusterknotenumgebung auf Windows Server 2003 SP1 die im folgenden Abschnitt angeführte Aktualisierung erforderlich sein wird. Ohne diese weitere Aktualisierung kann es nach der ersten Aktualisierung zu Fehlern bei Volumebereitstellungspunkten kommen.

So beheben Sie diese Warnung

  • Installieren Sie die Aktualisierung, auf die in Microsoft Knowledge Base-Artikel 898790, „Nachdem Sie Windows Server 2003 Service Pack 1 installieren, können Datenträgerbereitstellungspunkte auf Datenträgern in einem Servercluster zeitweise nicht mehr verfügbar sein" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790), Bezug genommen wird.


Der Windows Firewall-Dienst auf Exchange Server ist aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Service ab, um den Wert des Schlüssels Started für den Windows-Firewall-Dienst zu bestimmen. Der Wert True gibt an, dass der Windows-Firewall-Dienst auf diesem Exchange-Server aktiviert ist.

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Windows-Firewall-Dienst auf einem Exchange Server-Computer aktiviert ist, wird eine Warnmeldung angezeigt. Bei aktiviertem Windows-Firewall-Dienst können u. U. die folgenden Probleme auftreten:

  • Einige Komponenten von Exchange Server, z. B. der Dienst für die Nachrichtenverfolgung oder die Kommunikation mit Remoteprozeduraufruf (RPC), antworten möglicherweise nicht mehr.

  • Möglicherweise erhalten Sie eine Fehlermeldung über zu geringen freien Speicherplatz.

Beim Installieren von Microsoft Windows Server™ 2003 Service Pack 1 (SP1) wird der Windows-Firewall-Dienst in der Standardeinstellung angehalten. Der Dienst wird jedoch automatisch ausgeführt, wenn eine der folgenden Bedingungen erfüllt ist:

  • Der Windows-Firewall-Dienst wird manuell von einem Administrator aktiviert.

  • Sie aktivieren den Windows-Firewall-Dienst nach dem Ausführen des Sicherheitskonfigurations-Assistenten.

So beheben Sie diese Warnung

  • Überprüfen Sie den Ausschluss von Programmen.

  • Überprüfen Sie den Ausschluss von Anschlüssen.

  • Wenn Clients keine Verbindung mit dem Exchange-Server herstellen können, überprüfen Sie die Firewallausnahmen.

  • Öffnen Sie die entsprechenden Anschlüsse in der Firewall manuell, sodass der Exchange-System-Manager und Microsoft Exchange-Administrator ausgeführt werden können. Durch das Öffnen von Anschlüssen im Windows-Firewall-Dienst besteht die erhöhte Gefahr, dass möglicherweise andere Programme über diese Anschlüsse auf den Computer zugreifen. Wägen Sie die Anforderungen an die Netzwerksicherheit sorgfältig ab, bevor Sie Anschlüsse im Windows-Firewall-Dienst öffnen.

  • Halten Sie den Windows-Firewall-Dienst an.


Der Windows Management Instrumentation-Dienst wird nicht als „LocalSystem" ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um den Datenwert für den Wert ObjectName zu ermitteln:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winmgmt

Der Wert ObjectName in diesem Registrierungszweig gibt die Einstellungen des Dienstkontos für den Microsoft WMI-Dienst (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) an, der auch als Winmgmt-Dienst bezeichnet wird. Wenn Exchange Server Analyzer feststellt, dass der Datenwert für ObjectName nicht gleich LocalSystem ist, wird von Exchange Server Analyzer ein Fehler angezeigt.

Dieser Fehler gibt an, dass der WMI-Dienst nicht in einer unterstützten Konfiguration ausgeführt wird. Das Ausführen des WMI-Diensts unter einem anderen Konto als LocalSystem kann zu Berechtigungs- und Zugriffsfehlern führen.

Um diesen Fehler zu beheben, müssen Sie den WMI-Dienst so konfigurieren, dass er unter dem Konto LocalSystem (auch SYSTEM) startet.

So konfigurieren Sie das WMI-Dienstkonto

  1. Öffnen Sie das MMC-Snap-In (Microsoft Management Console) Dienste.

  2. Suchen Sie den Dienst Windows Management Instrumentation, und beenden Sie ihn.

  3. Doppelklicken Sie auf den Dienst Windows Management Instrumentation.

  4. Wählen Sie auf der Seite Eigenschaften von Windows Management Instrumentation auf der Registerkarte Anmelden unter Anmelden als das Konto Lokales Systemkonto aus, und klicken Sie dann auf Übernehmen.

  5. Klicken Sie unter Dienststatus auf Start, und klicken Sie dann auf OK.

  6. Schließen Sie das Snap-In Dienste.


Windows Server 2003 SP1: Outlook Web Access-Hotfix ist erforderlich
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer fragt verschiedene WMI-Klassen (Microsoft Windows® Management Instrumentation) ab, um die folgenden Informationen zu erhalten:

  • Unter welcher Version des Betriebssystems Microsoft Windows® Server ist Exchange Server installiert?

  • Wird Exchange Server auf einem Cluster ausgeführt?

Wenn Exchange Server Analyzer ermittelt, dass die folgenden Bedingungen erfüllt sind, zeigt das Tool einen Fehler an:

  • Exchange Server 2003 Service Pack 1 (SP1) ist installiert.

  • Microsoft Windows Server™ 2003 Service Pack 1 (SP1) ist installiert.

  • Der Clusterdienst wird ausgeführt.

  • Der Wert Version von Davex.dll ist kleiner als 6.5.7232.

Wenn Sie diese Konfiguration ausführen, müssen Sie einen Exchange Server-Hotfix downloaden und installieren, bevor Sie Windows Server 2003 SP1 installieren. Wenn Sie den Exchange Server-Hotfix nicht installieren, können Benutzer von Microsoft Office Outlook® Web Access für Exchange Server 2003 ihre Postfächer nicht verwenden. Benutzer mit Postfächern, die auf den Clustern gehostet werden, empfangen die folgende Fehlermeldung, wenn Sie mit Outlook Web Access eine Verbindung herstellen möchten:

  • „500 - Interne Serverfehler"

Dieser Fehler wird durch einige Sicherheitsverbesserungen in Windows Server 2003 SP 1 verursacht.

Wenn ein Benutzer versucht, sich mit Outlook Web Access an einem Postfach anzumelden, übermittelt HTTP Anforderungen an die Cluster-API, indem es die Identität des angemeldeten Benutzers annimmt. Unter Windows Server 2003 SP1 wurden jedoch Sicherheitsänderungen vorgenommen. Die Sicherheitseinschränkungen für die APIs, die Remoteregistrierungszugriff durchführen, wurden geändert. Daher ist der Anmeldeversuch nicht erfolgreich.

Um diesen Fehler zu beheben, müssen Sie den ExchangeServer-Hotfix downloaden und installieren, der im Microsoft Knowledge Base-Artikel „'500 - Internal server error' error message when a user tries to access a clustered Exchange Server 2003 back-end server by using Outlook Web Access" beschrieben ist (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841561).


Der Windows Server 2003 SP1 Sicherheitskonfigurations-Assistent wurde erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungswert, um die Version des Microsoft Windows®-Betriebssystems zu bestimmen, die auf dem Exchange-Server ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Wenn für CurrentVersion der Wert 5.0 angegeben ist, führt der Exchange-Server Microsoft Windows 2000 Server aus. Wenn für CurrentVersion der Wert 5.2 angegeben ist, führt der Exchange-Server Microsoft Windows Server™ 2003 aus.

Außerdem liest Exchange Server Analyzer den folgenden Registrierungswert, um den Pfad für das Windows-Verzeichnis Programme zu bestimmen:

HKLM\Software\Microsoft\Windows\CurrentVersion\ProgramFilesDir

Exchange Server Analyzer überprüft dann das Windows-Verzeichnis Programme, um zu ermitteln, ob der Ordner \Exchsrvr für ExchangeServer enthalten ist.

Exchange Server Analyzer fragt außerdem die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_OperatingSystem ab, um den Wert des Schlüssels ServicePackMajorVersion zu bestimmen. Der Wert des Schlüssels ServicePackMajorVersion gibt das Windows Service Pack an, das auf dem Computer installiert ist.

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Microsoft Exchange Server Analyzer stellt fest, dass auf dem Exchange Server-Computer Windows Server 2003 Service Pack 1 ausgeführt wird.

  • Exchange Server Analyzer stellt fest, dass Exchange Server 2003 nicht unter dem Standardpfad \Programme\Exchsrvr installiert wurde.

Diese Warnung zeigt an, dass Exchange Server 2003 nicht im Standardordner Programme auf dem Server installiert wurde und der Sicherheitskonfigurations-Assistent (Security Configuration Wizard - SCW) auf dem Exchange-Server installiert ist. Beim Sicherheitskonfigurations-Assistent handelt es sich um ein Tool, das als optionale Komponente im Windows Server 2003 Service Pack 1 enthalten ist. Wenn der Sicherheitskonfigurations-Assistent auf dem Exchange-Server installiert wurde, ist eine manuelle Konfiguration im Abschnitt für Netzwerksicherheit erforderlich.

Hinweis:
Wenn Sie den Sicherheitskonfigurations-Assistenten installieren möchten, müssen Sie zunächst Windows Server 2003 Service Pack 1 installieren. Öffnen Sie nach dem Installieren von Service Pack 1 über die Systemsteuerung das Dialogfeld Software, um den Sicherheitskonfigurations-Assistenten zu installieren.

Mithilfe des Sicherheitskonfigurations-Assistenten kann die Angriffsfläche von Windows-Servern verringert werden. Dazu werden dem Benutzer eine Reihe von Fragen gestellt, mit denen die funktionellen Anforderungen an einen Server ermittelt werden können. Der Sicherheitskonfigurations-Assistent kann u. a. beim Ausführen der folgenden Aufgaben verwendet werden:

  • Unnötige Dienste werden automatisch deaktiviert.

  • Nicht verwendete Anschlüsse werden automatisch blockiert.

  • Zusätzliche Adresseinschränkungen oder Sicherheitseinschränkungen für Anschlüsse, die weiterhin geöffnet bleiben, werden unterstützt.

  • Unnötige Web-Erweiterungen für Internet Information Services (IIS) werden ggf. verhindert.

  • Der Grad der Protokolloffenlegung für SMB (Server Message Block), LanMan und LDAP (Lightweight Directory Access Protocol) wird verringert.

  • Eine Überwachungsrichtlinie für hohen Rauschabstand wird definiert.

Der Sicherheitskonfigurations-Assistent führt Sie durch das Erstellen, Bearbeiten, Anwenden oder Rückgängigmachen einer Sicherheitsrichtlinie, der ausgewählte Rollen des Servers zugrunde liegen. Bei den mithilfe des Sicherheitskonfigurations-Assistenten erstellten Sicherheitsrichtlinien handelt es sich um XML-Dateien, mit denen Dienste, die Netzwerksicherheit, bestimmte Registrierungswerte und Überwachungsrichtlinien konfiguriert werden können. Gegebenenfalls können auch Internet Information Services (IIS) konfiguriert werden.

Der Sicherheitskonfigurations-Assistent enthält ein Netzwerksicherheits-Feature, das zusätzlich zu anderen Funktionen auch Ausnahmen für Windows Firewall konfiguriert und hinzufügt. Windows Firewall ist die neue Version des statusbehafteten Paketfilters von Windows Server 2003 Service Pack 1. Windows Firewall wurde erstmalig mit Windows XP Service Pack 2 eingeführt und als Internetverbindungsfirewall (ICF, Internet Connection Firewall) bezeichnet.

Ein bekanntes Problem tritt auf, wenn das Netzwerksicherheits-Feature im Sicherheitskonfigurations-Assistenten auf einem Exchange-Server ausgeführt wird, auf dem Exchange Server nicht im Standardpfad installiert wurde. In dieser Konfiguration kann die Anwendung der resultierenden Richtlinie dazu führen, dass Client-Computer nicht auf Exchange Server zugreifen können. Wenn das Netzwerksicherheits-Feature auf einem Exchange-Server verwendet wird, auf dem Exchange Server nicht im Standardpfad installiert ist, kann der Sicherheitskonfigurations-Assistent Windows Firewall so konfigurieren, dass der Zugriff auf den TPC/IP-Anschluss durch Exchange Server-Prozesse blockiert wird, z. B. die Systemaufsicht (Mad.exe), den Microsoft Exchange-Informationsspeicher (Store.exe) oder den MTA (Message Transfer Agent, Emsmta.exe). In dieser Konfiguration zeigt der Sicherheitskonfigurations-Assistent Nicht gefunden neben jedem Prozess an. Wenn der Sicherheitskonfigurations-Assistent ausgeführt wird, bis er mit einem Prozess abgeschlossen wurde, neben dem Nicht gefunden angezeigt wird, wendet der Sicherheitskonfigurations-Assistent eine Sicherheitsrichtlinie auf Windows Firewall an, die den Netzwerkzugriff durch diesen Prozess verhindert.

Wenn der blockierte Prozess einen oder mehrere Exchange Server-Prozesse enthält, kann dies dazu führen, dass Client-Computer und andere Server nicht mehr auf Exchange Server zugreifen können. Wenn diese Bedingung zutrifft, sollte eine der folgenden Prozeduren ausgeführt werden, um das Problem zu beheben.

So beheben Sie diesen Fehler

  • Führen Sie eine der folgenden Prozeduren aus, um das Problem zu beheben:

    • Verwenden Sie das Rollback-Feature des Sicherheitskonfigurations-Assistenten, um eine Sicherheitsrichtlinie nach deren Anwendung rückgängig zu machen. Weitere Informationen darüber finden Sie in der Hilfedatei des Sicherheitskonfigurations-Assistenten, die im Windows Server 2003 Service Pack 1 enthalten ist. Weitere Informationen über Windows Server 2003 Service Pack 1 und den Sicherheitskonfigurations-Assistenten finden Sie im TechNet unter Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=45315).

    • Geben Sie im Sicherheitskonfigurations-Assistenten im Feld Anwendungspfad den Speicherort der ausführbaren Verarbeitungsdateien von Exchange Server manuell ein. Wählen Sie hierzu den Prozess aus, neben dem Nicht gefunden angezeigt wird, und klicken Sie auf Bearbeiten. Es wird empfohlen, den Sicherheitskonfigurations-Assistenten auf dem Exchange-Server auszuführen, um sicherzustellen, dass die Pfade der ausführbaren Dateien der einzelnen Exchange Server-Prozesse korrekt sind. Nachdem die ausführbaren Dateien der einzelnen Prozesse überprüft wurden, kann die Sicherheitsrichtlinie des Sicherheitskonfigurations-Assistenten angewendet werden. Danach sollte Exchange Server über den für seine Funktionen erforderlichen Netzwerkzugriff verfügen.

Weitere Informationen über Windows Server 2003 Service Pack 1 und den Sicherheitskonfigurations-Assistenten finden Sie finden Sie im TechNet unter Windows Server 2003 (http://www.microsoft.com/germany/technet/datenbank/produkte.mspx).


Datei „XESE.DLL" ist vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um den Wert für den Schlüssel Version für die Datei Xese.dll zu ermitteln:

Wenn Exchange Server Analyzer einen Wert für Version für diese Datei findet, betrachtet er die Datei als vorhanden, und ein Fehler wird angezeigt.

Einige ESE-basierte Antivirusprogramme verwenden zwischen dem Exchange-Informationsspeicher und der ESE (Extensible Storage Engine - erweiterbares Speichermodul) eine nicht unterstützte Schnittstelle. Wenn Sie eine solche Software verwenden und deren Implementierung fehlerhaft ist, besteht das Risiko, dass die Datenbank beschädigt wird und Datenverlust auftritt.

Während der Installation ändert das ESE-basierte Antivirusprogramm den Microsoft Exchange-Informationsspeicherdienst so, dass dieser auf den Dienst des auf ESE-basierten Antivirusprogramms angewiesen ist. Dadurch wird sichergestellt, dass der Dienst des ESE-basierten Antivirusprogramms vor dem Microsoft Exchange-Informationsspeicherdienst startet. Wenn das ESE-basierte Antivirusprogramm startet, wird die in Exchange Server enthaltene Version von Ese.dll vorübergehend in Xese.dll umbenannt, und die Version von Ese.dll, die zu dem ESE-basierten Antivirusprogramm gehört, ersetzt die Ursprungsdatei. Nach dem Laden der zum ESE-basierten Antivirusprogramm gehörenden Version von Ese.dll wird die in Exchange Server enthaltene Version wieder in Ese.dll umbenannt, und der Microsoft Exchange-Informationsspeicherdienst schließt den Startvorgang ab.

So beheben Sie diese Warnungmeldung

  1. Es wird dringend empfohlen, keine Implementierungen der ESE auf Exchange Server-Computern zu verwenden, die nicht von Microsoft stammen. Kunden, die den technischen Support von Microsoft kontaktieren, werden möglicherweise gebeten, das ESE-basierte Antivirusprogramm für die Problemsuche zu deaktivieren. Nachdem die Grundursache des Problems richtig erkannt wurde, können diese Kunden dann ihre Software wieder aktivieren.

  2. Das meistverwendete Antivirusprogramm auf ESE-Basis ist Antigen für Microsoft Exchange von Sybari Software. Microsoft und Sybari stimmen darin überein, dass das Deaktivieren von Sybari Antigen ein sinnvoller Schritt zum Ermittlen der Ursachen von Problemen ist. Wenn Sie Kontakt mit Sybari Software aufnehmen möchten, besuchen Sie die Sybari Software-Website unter http://www.sybari.com.

    Hinweis:
    Die Informationen zur Website des Drittanbieters werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.

  3. Es wird die Verwendung von Antivirusprogrammen empfohlen, die die VSAPI (Virus Scanning Application Programming Interface) unterstützen, auch bekannt als AntiVirus-API (AVAPI).

Weitere Informationen zum Ausführen von Antivirussoftware auf Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

  • 328841, „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).


Hardware
Microsoft Exchange Server Analyzer-Tools - Artikel >

Letztes Änderungsdatum des Themas: 2005-11-18

In den Artikeln in diesem Abschnitt erhalten Sie ausführliche Informationen über die Daten, die Microsoft® Exchange Server Analyzer in Bezug auf die Hardware auswertet. Darüber hinaus beschreiben diese Artikel Aktionen, die Sie durchführen können, um hardwarebezogene Fehler, Warnungen und vom Standard abweichende Konfigurationen beheben zu können, die der Exchange Server Analyzer gefunden hat.


BIOS ist veraltet
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_BIOS ab, um den Wert der Schlüssel SMBIOSBIOSVersion und ReleaseDate zu bestimmen. Der zurückgegebene Wert stellt die Versionsnummer und das Veröffentlichungsdatum des auf dem Computer installierten BIOS dar. Exchange Server Analyzer analysiert auch die WMI-Klasse Win32_ComputerSystem, um den Wert des Schlüssels Model zu bestimmen.

Wenn Exchange Server Analyzer feststellt, dass der Wert für ReleaseDate mehr als ein Jahr zurückliegt und dass der Schlüssel Model eine der folgenden Zeichenfolgen enthält, wird eine Warnung angezeigt:

  • ProLiant DL320

  • ProLiant DL320 G2

  • ProLiant DL320 G3

  • ProLiant DL360

  • ProLiant DL360 G2

  • ProLiant DL360 G3

  • ProLiant DL360 G4

  • ProLiant DL380

  • ProLiant DL380 G2

  • ProLiant DL380 G3

  • ProLiant DL380 G4

  • ProLiant DL560

  • ProLiant DL570 G3

  • ProLiant DL580

  • ProLiant DL580 G2

  • ProLiant DL580 G3

  • ProLiant DL585 G1

  • ProLiant ML350

  • ProLiant ML350 G2

  • ProLiant ML350 G3

  • ProLiant ML350 G4

  • ProLiant ML370

  • ProLiant ML370 G2

  • ProLiant ML370 G3

  • ProLiant ML370 G4

  • ProLiant ML530

  • ProLiant ML530 G2

  • ProLiant ML570

  • ProLiant ML570 G2

  • ProLiant ML750

Informationen zum Beheben dieser Warnung sowie weitere Informationen zum Beziehen und Aktualisieren einer neueren BIOS-Version finden Sie auf der Website von Hewlett-Packard „ROM-BIOS/Firmware Updates" unter http://h18023.www1.hp.com/support/files/server/us/romtabl.html.

Weitere Informationen zu Hewlett-Packard ProLiant-Servern finden Sie auf der Website von Hewlett-Packard unter http://www.hp.com.

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.


Auf dem Dell PowerEdge-Server ist das BIOS veraltet
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_BIOS ab, um den Wert des Schlüssels SMBIOSBIOSVersion zu bestimmen. Der zurückgegebene Wert stellt die Versionsnummer des auf dem Computer installierten BIOS dar. Exchange Server Analyzer analysiert auch die WMI-Klasse Win32_ComputerSystem, um den Wert des Schlüssels Model zu bestimmen.

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel Model eine der folgenden Zeichenfolgen enthält und die SMBIOSBIOSVersion nicht die aktuelle Version für das Modell ist, wird eine Warnung angezeigt:

  • PowerEdge 2400

  • PowerEdge 2450

  • PowerEdge 2500

  • PowerEdge 2550

  • PowerEdge 2600

  • PowerEdge 2650

  • PowerEdge 2800

  • PowerEdge 2850

  • PowerEdge 3250

  • PowerEdge 4300

  • PowerEdge 4350

  • PowerEdge 4400

  • PowerEdge 4600

  • PowerEdge 6300

  • PowerEdge 6350

  • PowerEdge 6400

  • PowerEdge 6450

  • PowerEdge 6600

  • PowerEdge 6650

  • PowerEdge 6800

  • PowerEdge 6850

  • PowerEdge 7150

  • PowerEdge 7250

  • PowerEdge 8450

Um diese Warnung zu beheben, besuchen Sie die Website „Downloads" von Dell (http://support.dell.com/support/downloads), um weitere Informationen über das Abrufen und Aktualisieren einer neueren BIOS-Version zu erhalten.

Weitere Informationen über PowerEdge-Server von Dell finden Sie auf der Dell-Website (http://www.dell.com/).

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.


BIOS-Aktualisierung ist verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_BIOS ab, um den aktuellen Wert des Schlüssels SMBIOSBIOSVersion zu bestimmen. Der zurückgegebene Wert stellt die Versionsnummer und das Veröffentlichungsdatum des auf dem Computer installierten BIOS dar. Exchange Server Analyzer fragt außerdem die WMI-Klasse Win32_ComputerSystem ab, um den Wert des Schlüssels Model zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass es sich bei dem Computer um ein IBM X445-System mit einer älteren BIOS-Version als REJT48A handelt, wird von dem Tool ein Feher angezeigt.

Um diesen Fehler zu beheben und um weitere Informationen zum Abrufen und Aktualisieren auf eine neuere BIOS-Version zu erhalten, besuchen Sie die Website von IBM „Flash BIOS update (DOS update package) with RSA I and RSA II EXA support - IBM eServer xSeries 445" (http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-54089).

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.


Für die Cluster-Netzwerkschnittstellenkarte ist DHCP aktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_NetworkAdapterConfiguration ab, um den Wert für den Schlüssel DHCPEnabled für alle Netzwerkschnittstellen im Cluster zu bestimmen. Wenn Exchange Server Analyzer feststellt, dass der Wert DHCPEnabled auf True festgelegt ist, wird ein Fehler angezeigt.

Der Wert True für den WMI-Schlüssel DHCPEnabled gibt an, dass eine Netzwerkschnittstelle darauf konfiguriert ist, das Dynamic Host Configuration Protocol (DHCP) zu verwenden. Microsoft unterstützt DHCP nicht für Knoten im privaten Netzwerk eines Windows-Serverclusters. Außerdem wird empfohlen, dass Sie für Knoten in öffentlichen Netzwerken eines Windows-Serverclusters statische IP-Adressen verwenden. Der Einsatz einer dynamischen Konfiguration für öffentliche Netzwerke über DHCP wird nicht empfohlen, da der Clusterbetrieb gestört werden kann, wenn die Erneuerung des DHCP-Lease fehlschlägt. Zudem wird die dynamische Konfiguration privater Netzwerke über DHCP nicht unterstützt und sollte nie vorgenommen werden.

Um dieses Problem zu beheben, müssen Sie die Netzwerkschnittstellen für die privaten Netzwerke auf die Verwendung einer statischen IP-Adresse konfigurieren. Es wird empfohlen, Adressen aus folgenden Bereichen auszuwählen:

  • 10.0.0.0 - 10.255.255.255 (Klasse-A-Netzwerk)

  • 172.16.0.0 - 172.31.255.255 (Klasse-B-Netzwerk)

  • 192.168.0.0 - 192.168.255.255 (Klasse-C-Netzwerk)

So berichtigen Sie diesen Fehler

  1. Klicken Sie unter Netzwerkverbindungen mit der rechten Maustaste auf die Netzwerkverbindung für den privaten Netzwerkadapter und klicken anschließend auf Eigenschaften.

  2. Klicken Sie auf Internetprotokoll (TCP/IP) und anschließend auf Eigenschaften.

  3. In der Registerkarte Allgemein geben Sie eine statische IP-Adresse ein, die sich nicht im gleichen Subnetz oder Netzwerk wie die öffentlichen Netzwerkadapter befindet. Beispiele geeigneter IP-Adressen zur Verwendung für private Adapter sind 10.10.10.10 auf Knoten 1 und 10.10.10.11 auf Knoten 2 mit einer Subnetzmaske von 255.0.0.0. Wenn Ihr öffentliches Netzwerk das 10.x.x.x-Netzwerk und die Subnetzmaske 255.0.0.0 verwendet, setzen Sie eine andere private Netzwerk-IP und eine andere Subnetzmaske ein.

  4. Stellen Sie sicher, dass im Feld Standardgateway kein Wert eingestellt ist.

  5. Stellen Sie sicher, dass im Feld Folgende DNS-Serveradressen verwenden keine Werte definiert sind.

  6. Klicken Sie auf Erweitert.

  7. Stellen Sie sicher, dass auf der Registerkarte DNS keine Werte definiert sind. Stellen Sie sicher, dass die Kontrollkästchen Adressen dieser Verbindung in DNS registrieren und DNS-Suffix dieser Verbindung in DNS-Registrierung verwenden deaktiviert sind.

  8. Stellen Sie sicher, dass auf der Registerkarte WINS keine Werte definiert sind. Klicken Sie auf NetBIOS über TCP/IP deaktivieren.

  9. Wenn Sie das Dialogfeld schließen, erscheint unter Umständen folgende Eingabeaufforderung. Wenn diese Meldung erscheint, klicken Sie auf Ja. Diese Verbindung besitzt eine leere primäre WINS-Adresse. Möchten Sie fortfahren?

  10. Um die Änderungen zu speichern, klicken Sie auf OK.

  11. Führen Sie die genannten Schritte auf allen anderen Knoten des Clusters aus.

Weitere Informationen zur optimalen Netzwerkkonfiguration für Windows-Servercluster finden Sie in „Server Clusters: Network Configuration Best Practices for Windows 2000 and Windows Server 2003" unter http://go.microsoft.com/fwlink/?linkid=34304.

Weitere Informationen zur richtigen Cluster-Heartbeat-Konfiguration finden Sie im Microsoft Knowledge Base-Artikel 258750 „Empfehlungen für die private Heartbeat-Konfiguration auf einem Clusterserver" unterhttp://support.microsoft.com/kb/258750/de.


Das primäre DNS-Suffix des Computers entspricht nicht dem FQDN der Domäne, in der sich der Computer befindet
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2006-05-18

Microsoft® Exchange Server Analyzer liest die folgenden Registrierungseinträge, um das primäre DNS-Suffix (Domain Name System) für diesen Exchange-Server zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\NV Domain

HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Domain

Wenn Microsoft Exchange Server Analyzer feststellt, dass die Werte für NV Domain und Domain nicht übereinstimmen, wird eine Warnung angezeigt.

Der Registrierungswert NV Domain enthält das primäre DNS-Suffix des Computers. Der Registrierungswert Domain enthält die primäre DNS-Domäne des Computers. Der Teil des primären DNS-Suffixes des vollständig qualifizierten Domänennamens (FQDN) eines Computers muss in der Standardeinstellung dem Namen der Domäne des Active Directory®-Verzeichnisdienstes entsprechen, in der sich der Computer befindet. Unterschiedliche Namen können verhindern, dass eine DNS-Registrierung korrekt ausgeführt wird. Wenn der DNS-Domänenname für den Computer nicht dem Domänennamen für Active Directory entspricht, werden alle 22 Minuten Fehler im Systemereignisprotokoll angezeigt. Dieser Zustand ist als "zusammenhangloser Namespace" bekannt. Um verschiedene primäre DNS-Suffixe zu ermöglichen, können Sie eine eingeschränkte Liste zugelassener Suffixe erstellen, indem Sie ein Active Directory-Attribut mit dem Namen msDS-AllowedDNSSuffixes im Domänenobjekt-Container erstellen.

Die Vorgehensweise zum Überprüfen, ob der nicht zur Domäne gehörende Namespace korrekt konfiguriert ist, hängt vom Betriebssystem ab, das für Ihren Active Directory-Domänencontroller verwendet wird.

  • Wenn Sie auf Ihren Active Directory-Domänencontrollern ein Microsoft Windows® 2000 Server-Betriebssystem ausführen, können Sie die Vorgehensweise verwenden, die im Microsoft Knowledge Base-Artikel 258503 „DNS-Registrierungsfehler 5788 und 5789" unter (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258503) beschrieben ist, um Ihren Namespace korrekt zu konfigurieren. Dieser Artikel enthält Vorgehensweisen für das Korrigieren eines unbeabsichtigten nicht zu der Domäne gehörenden Namespaces und für das korrekte Konfigurieren eines nicht zu der Domäne gehörenden Namespaces, falls dieser beabsichtigt ist.

  • Wenn Sie auf den Active Directory-Domänencontrollern Microsoft Windows Server™ 2003 ausführen und der nicht zur Domäne gehörende Namespace nicht beabsichtigt ist, können Sie die erste der folgenden Vorgehensweisen verwenden, um den unbeabsichtigten nicht zur Domäne gehörenden Namespace zu korrigieren und diese Warnung zu beheben. Wenn Sie auf den Active Directory-Domänencontrollern Windows Server 2003 ausführen und der nicht zur Domäne gehörende Namespace beabsichtigt ist, können Sie ihn mit der zweiten der folgenden Vorgehensweisen ordnungsgemäß konfigurieren.

Zum Ausführen der nachfolgenden zweiten Vorgehensweise benötigen Sie einen Active Directory-Editor, z. B. die ADSI-Bearbeitung (Active Directory Service Interfaces) oder das LDP-Tool (ldp.exe). Weitere Informationen zum Ändern von Active Directory mit dem LDP-Tool finden Sie im Microsoft Knowledge Base-Artikel 260745, „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260745).

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In, das LDP-Tool oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Windows Server 2003, Exchange Server 2003 oder beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

Der nicht zur Domäne gehörende Namespace ist nicht beabsichtigt

  1. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und klicken Sie dann auf Eigenschaften. Das Dialogfeld Systemeigenschaften wird angezeigt.

  2. Klicken Sie auf die Registerkarte Computername.

  3. Klicken Sie auf Ändern. Das Dialogfeld Computernamen ändern wird angezeigt.

  4. Klicken Sie auf Weiter. Das Dialogfeld DNS-Suffix und NetBIOS-Computername wird angezeigt.

  5. Aktivieren Sie das Kontrollkästchen Primäres DNS-Suffix bei Domänenmitgliedschaftsänderung ändern.

  6. Klicken Sie auf OK, um die Änderungen zu speichern, und klicken Sie dann auf OK, um das DialogfeldComputernamen ändern zu schließen.

  7. Klicken Sie auf OK, um das Dialogfeld Systemeigenschaften zu schließen, und starten Sie den Computer anschließend neu, damit die Änderung wirksam wird.

Der nicht zur Domäne gehörende Namespace ist beabsichtigt

  1. Verwenden Sie die oben beschriebene Vorgehensweise, um sicherzustellen, dass das Kontrollkästchen Primäres DNS-Suffix bei Domänenmitgliedschaftsänderung ändern deaktiviert ist.

  2. Ändern Sie das Active Directory-Attribut msDS-AllowedDNSSuffixes im Domänenobjekt-Container. Sie können dazu die ADSI-Bearbeitung verwenden, wenn Sie die folgenden Schritte durchführen:

    1. Doppelklicken Sie auf die Domänenverzeichnispartition für die zu ändernde Domäne.

    2. Klicken Sie mit der rechten Maustaste auf das Domänencontainerobjekt, und klicken Sie dann auf Eigenschaften.

    3. Doppelklicken Sie auf der Registerkarte Attribut-Editor im Feld Attribute auf das Attribut msDS-AllowedDNSSuffixes.

    4. Geben Sie im Dialogfeld zum Bearbeiten mehrwertiger Zeichenfolgen im Feld für den hinzuzufügenden Wert ein DNS-Suffix ein, und klicken Sie dann auf Hinzufügen.

    5. Wenn Sie alle DNS-Suffixe für die Domäne hinzugefügt haben, klicken Sie auf OK.

    6. Klicken Sie auf OK, um das Dialogfeld Eigenschaften für diese Domäne zu schließen.

    7. Wiederholen Sie diese Schritte, wenn Sie mehrere Domänen auf ähnliche Weise konfigurieren möchten.

Weitere Informationen über das Attribut msDS-AllowedDNSSuffixes finden Sie im Hilfe- und Supportcenter für Windows Server 2003. Weitere Informationen zum Ändern dieses Attributs finden Sie in „Step-by-Step Guide to Implementing Domain Rename" (http://go.microsoft.com/fwlink/?LinkId=41359).


Wichtige Bios-Aktualisierung ist verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2006-04-20

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_BIOS ab, um den aktuellen Wert des Schlüssels SMBIOSBIOSVersion zu bestimmen. Der Wert des Schlüssels SMBIOSBIOSVersion stellt die Version des auf dem Server installierten BIOS dar. Exchange Server Analyzer fragt außerdem die WMI-Klasse Win32_ComputerSystem ab, um den Wert des Schlüssels Model zu ermitteln. Der Wert des Schlüssels Model steht für die vom Hardwarehersteller gelieferten Hardware-Modellinformationen.

Wenn Exchange Server Analyzer ermittelt, dass auf einem Server, dessen Schlüssel Model mit eserver xSeries 445 beginnt, der Schlüssel Version den Wert 42B aufweist, wird ein Fehler ausgegeben. Dieser Fehler zeigt an, dass das BIOS des Servers IBM xSeries 445 aktualisiert werden muss.

Hierbei handelt es sich um ein bekanntes Problem mit Version 42B der BIOS-Firmware, in dessen Folge Daten beschädigt werden können. Das Problem tritt nur bei X445-Systemen auf, die mit BIOS 42B (Version 1.5) ausgestattet sind. Das Problem wird in BIOS 45A behoben. Sie sollten möglichst bald das BIOS auf diesem Server auf 45A oder höher aktualisieren.

So beheben Sie diesen Fehler

  1. Weitere Informationen über dieses Problem finden Sie auf der Website von IBM, „Flash BIOS Update (DOS update package) - IBM eServer xSeries 445" (http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-54089#BIOSVersion).

  2. Weitere Informationen finden Sie in der Infodatei der BIOS-Aktualisierung (ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers/39y4888.txt).

  3. Downloaden Sie die BIOS-Aktualisierung von der IBM-Website unter http://www-307.ibm.com/pc/support/site.wss/license.do?filename=pc_servers/26r0663.exe.

  4. Aktualisieren Sie das BIOS auf diesem Server.

Weitere Informationen zum Anwenden dieser wichtigen BIOS-Aktualisierung finden Sie auf der IBM-Website unter http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=DSHY-3TEPF6.

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.


Die aktuelle Prozessorgeschwindigkeit ist geringer als die mögliche Maximalgeschwindigkeit
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Processor ab, um die aktuellen Werte für die Schlüssel MaxClockSpeed und CurrentClockSpeed zu bestimmen. Wenn Exchange Server Analyser feststellt, dass der Wert für CurrentClockSpeed kleiner ist als der Wert für MaxClockSpeed, wird eine Warnung angezeigt.

Der Wert CurrentClockSpeed gibt die aktuelle Prozessorgeschwindigkeit in Megahertz (MHz) an. MaxClockSpeed gibt die maximale Prozessorgeschwindigkeit in Megahertz an. Durch das Anzeigen dieser Warnmeldung wird darauf hingewiesen, dass eine oder mehrere Prozessoren auf dem Exchange-Server nicht mit voller Geschwindigkeit betrieben werden. Es gibt einige bekannte Ursachen dafür:

  1. Exchange Server wird auf einem Microsoft Windows® 2000 Server- oder Windows 2000 Advanced Server-Computer ausgeführt, auf dem nicht mindestens Windows 2000 Service Pack 3 installiert ist. Mithilfe von Windows 2000 Service Pack 3 wurde ein Problem behoben, bei dem WMI nicht die richtigen Werte für MaxClockSpeed oder CurrentClockSpeed zurückgegeben hat.

  2. Durch eine falsche energiesparende Einstellung im BIOS des Exchange-Servers kann erzwungen werden, dass der Prozessor mit einer niedrigeren Geschwindigkeit im energiesparenden Modus ausgeführt wird.

So beheben Sie diese Warnmeldung

  1. Wenn Exchange-Server auf einem Windows 2000 Server- oder Windows 2000 Advanced Server-Computer ausgeführt wird, auf dem nicht mindestens Windows 2000 Server Service Pack 3 installiert ist, muss das aktuelle Service Pack installiert werden. Weitere Informationen zu den aktuellen Windows 2000 Service Packs finden Sie auf der Microsoft Windows 2000-Website (http://go.microsoft.com/fwlink/?LinkId=18353).

  2. Wenn Exchange Server auf einem Computer installiert ist, auf dem Windows 2000 Server oder Windows 2000 Advanced Server ausgeführt wird und auf dem Windows 2000 Service Pack 3 oder eine höhere Version installiert ist, überprüfen Sie die BIOS-Einstellungen auf dem Exchange-Server. Überprüfen Sie auch die Energieverwaltungseinstellungen im BIOS sowie in der Systemsteuerung oder im Geräte-Manager.

Für weitere Informationen zum Anzeigen und Konfigurieren von System-BIOS, Prozessoren und Energieverwaltungseinstellungen wenden Sie sich an Ihren Hardwarehersteller.

Weitere Informationen zu den Energieverwaltungsfunktionen von Windows 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 244806 „Überblick über die Energieverwaltung in Windows 2000" (http://support.microsoft.com/kb/244806/de).

Weitere Informationen zu den Energieverwaltungsfunktionen in Windows Server 2003 finden Sie unter den Stichworten „Energieverwaltung" und „Energieoptionen" im Hilfe- und Supportcenter von Windows Server 2003, das vom Startmenü des Windows Server 2003-Computers ausgeführt werden kann.

Weitere Informationen zu den Energieverwaltungsfunktionen in Windows 2000 finden Sie in den Abschnitten „Energieverwaltung" und „Energieoptionen" in der Windows 2000 Server-Hilfe, die vom Startmenü eines Windows 2000 Server-Computers aus ausgeführt werden kann.


„DisableDHCPMediaSense" ist für Windows Server 2003 nicht korrekt festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2006-10-02

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob die Media Sense-Erkennung richtig konfiguriert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\DisableDHCPMediaSense

Microsoft Exchange Server Analyzer untersucht auch den folgenden Registrierungseintrag, um die Windows-Version zu ermitteln, die auf dem Zielcomputer ausgeführt wird:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Der Wert 4.0 für CurrentVersion gibt an, dass auf dem Computer Microsoft Windows NT Server 4.0 ausgeführt wird. Der Wert 5.0 zeigt an, dass auf dem Computer ein Windows® 2000 Server-Betriebssystem ausgeführt wird, und der Wert 5.2 zeigt an, dass auf dem Computer Windows Server™ 2003 ausgeführt wird.

Darüber hinaus fragt Exchange Server Analyzer auch die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_Service ab, um den Wert des Schlüssels Started für den Microsoft Windows-Clusterdienst ClusSvc zu bestimmen. Der Wert True gibt an, dass der Windows-Clusterdienst ausgeführt wird, und der Wert False gibt an, dass er nicht ausgeführt wird.

Wenn Exchange Server Analyzer erkennt, dass der Windows-Clusterdienst auf Windows Server 2003 Enterprise Edition oder Windows Server 2003 Datacenter Edition ausgeführt wird und der Wert für den Registrierungsschlüssel DisableDHCPMediaSense auf 1 festgelegt ist, wird eine Warnung angezeigt.

Wenn Sie den Windows Server 2003-Clusterdienst verwenden und dabei die Netzwerkverbindung unterbrochen wird, wird der TCP/IP-Stapel in der Standardeinstellung nicht entladen, wie dies in Windows 2000 Server der Fall war. Deshalb müssen Sie den Registrierungsschlüssel DisableDHCPMediaSense nicht mehr festlegen. Bei einer Netzwerkunterbrechung unter Windows 2000 Server wurde der TCP/IP-Stapel entladen, was dazu führte, dass alle von IP-Adressen abhängigen Cluster-Ressourcen, einschließlich solcher in einem virtuellen Exchange-Server, in den Offline-Zustand versetzt wurden. Beim Zurückwechseln der Netzwerke in den Onlinezustand wurde ihre Netzwerkrolle auf die Standardeinstellungen zurückgesetzt (d. h. „Client" und „Privat"). Durch das standardmäßige Deaktivieren von Media Sense wird die Netzwerkrolle bewahrt, und alle von IP-Adressen abhängigen Ressourcen werden im Online-Zustand belassen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. Klicken Sie mit der rechten Maustaste in den rechten Fensterbereich, um den Registrierungswert DisableDHCPMediaSense zu ändern (zum Deaktivieren auf 0 festlegen) oder zu löschen.

  4. Schließen Sie den Registrierungseditor.

  5. Verschieben Sie alle Cluster-Ressourcen an einen anderen Knoten oder bringen Sie sie in den Offline-Zustand. Starten Sie dann den Cluster-Knoten neu, damit die Änderung wirksam wird.

  6. Wiederholen Sie den Vorgang für alle weiteren Knoten des Clusters, der diese Warnung verursacht hat.

Weitere Informationen zur Microsoft Windows-Registrierung finden Sie im Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" (http://support.microsoft.com/kb/256986/de).

Weitere Informationen zu Media Sense-Erkennung und Windows-Clustern finden Sie in den folgenden Knowledge Base-Artikeln:

  • 254651, „Funktion des Clusternetzwerks ändert sich automatisch" (http://support.microsoft.com/kb/254651/de)

  • 239924, „Deaktivieren der Funktion "Media Sense" für TCP/IP in Windows" (http://support.microsoft.com/kb/239924/de)

  • 242430, „Network Adapter Not Available During Cluster Configuration with a Crossover Cable" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=242430)

  • 278007, „Verfügbare Features in Windows Server 2003-Clustern" (http://support.microsoft.com/default.aspx?scid=kb;de;278007)


„DisableDHCPMediaSense" ist für Windows 2000 Server nicht ordnungsgemäß festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob die Media Sense-Erkennung richtig konfiguriert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\DisableDHCPMediaSense

Exchange Server Analyzer überprüft außerdem den folgenden Registrierungseintrag, um die auf dem Zielcomputer ausgeführte Version von Windows zu ermitteln:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Der Wert 4.0 für CurrentVersion gibt an, dass auf dem Computer Microsoft Windows NT Server 4.0 ausgeführt wird. Der Wert 5.0 zeigt an, dass auf dem Computer ein Microsoft Windows 2000 Server-Betriebssystem ausgeführt wird, und der Wert 5.2 zeigt an, dass auf dem Computer Microsoft Windows Server™ 2003 ausgeführt wird.

Darüber hinaus fragt Exchange Server Analyzer auch die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_Service ab, um den Wert des Schlüssels Started für den Microsoft Windows-Clusterdienst ClusSvc zu bestimmen. Der Wert True gibt an, dass der Windows-Clusterdienst ausgeführt wird, und der Wert False gibt an, dass er nicht ausgeführt wird.

Wenn Exchange Server Analyzer feststellt, dass der Windows-Clusterdienst unter Windows 2000 Advanced Server oder Windows 2000 Datacenter Server ausgeführt wird und der Wert für den Registrierungsschlüssel DisableDHCPMediaSense vorhanden und nicht auf 1 festgelegt ist, wird eine Warnung angezeigt.

Wenn Sie den Windows 2000 Server-Clusterdienst verwenden, wird bei Unterbrechung der Netzwerkverbindung der TCP/IP-Stapel entladen. Dies führte dazu, dass alle von IP-Adressen abhängigen Cluster-Ressourcen, einschließlich solcher in einem virtuellen Exchange-Server, in den Offline-Zustand versetzt wurden. Beim Zurückwechseln der Netzwerke in den Online-Zustand wurde ihre Netzwerkrolle auf die Standardeinstellungen zurückgesetzt („Client" und „Privat"). Um dies zu verhindern, sollten Sie die Media Sense-Erkennung auf allen Windows 2000 Server-basierten Clustern deaktivieren. Die Media Sense-Erkennung wird auf Windows 2003 Server-basierten Clustern automatisch deaktiviert.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. Klicken Sie mit der rechten Maustaste auf Parameter. Anschließend klicken Sie auf Neu | DWORD-Wert. Geben Sie als Namen DisableDHCPMediaSense ein, und drücken Sie die EINGABETASTE.

  4. Doppelklicken Sie im rechten Bereich auf DisableDHCPMediaSense, und geben Sie den Wert 1 ein.

  5. Schließen Sie den Registrierungs-Editor.

  6. Verschieben Sie alle Cluster-Ressourcen an einen anderen Knoten oder bringen Sie sie in den Offline-Zustand. Starten Sie dann den Cluster-Knoten neu, damit die Änderung wirksam wird.

  7. Wiederholen Sie den Vorgang für alle Knoten des Clusters, der diese Warnung verursacht hat.

Weitere Informationen zur Microsoft Windows-Registrierung finden Sie im Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986.

Weitere Informationen zu Media Sense-Erkennung und Windows-Clustern finden Sie in den folgenden Knowledge Base-Artikeln:

  • 254651, „Funktion des Clusternetzwerks ändert sich automatisch" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=254651)

  • 239924, „Deaktivieren der Funktion "Media Sense" für TCP/IP in Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=239924)

  • 242430, „Network Adapter Not Available During Cluster Configuration with a Crossover Cable" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=242430)

  • 278007, „Verfügbare Features in Windows Server 2003-Clustern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=278007)


„Disk timeout" weicht vom Standardwert ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Wert des Datenträger-Timeouts vom Standardwert abweicht:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Disk\TimeOutValue

Wenn Exchange Server Analyzer feststellt, dass ein TimeOutValue vorhanden ist, der auf einen anderen Wert als 10 festgelegt ist, und der Server nicht Teil eines Clusters ist, wird eine Meldung angezeigt, dass die Konfiguration von der Standardkonfiguration abweicht. Wenn Exchange Server Analyzer feststellt, dass ein TimeOutValue vorliegt, der auf einen anderen Wert als 20 festgelegt ist, und der Server Teil eines Clusters ist, wird eine Meldung angezeigt, dass ein vom Standardwert abweichender Wert gefunden wurde.

Der Datenträger-Timeout ist eine Registrierungseinstellung, die die Wartezeit von Windows® definiert, bis die Festplatte auf einen Befehl reagiert. In einem System, das nicht Teil eines Clusters ist, ist dieser Schlüssel nicht vorhanden, und es wird ein Standardwert von 10 Sekunden für alle Datenträger verwendet. In einem Windows-Cluster ist dieser Schlüssel vorhanden, und es wird ein Standardwert von 20 Sekunden verwendet. Wenn die Timeoutzeit den Wert in dieser Registrierungseinstellung überschreitet, wird von Windows ein Fehler angezeigt, und der Zugriff auf den Datenträger wird abgebrochen. Manchmal ist er u. U. auf einen größeren Wert festgelegt, wenn Sie eine Software mit Multipath-Datenträgerzugriff ausführen. Multipath-Software gestattet Ihnen, die Verbindung zu einem einzelnen Laufwerk aus Redundanzgründen über mehrere physikalische Pfade (z. B. Fiber) herzustellen. Multipath-Software verwaltet die mehrfachen physikalischen Verbindungen so, dass Windows nur mit einem einzigen Handle zum Datenträger zu tun hat.

Beim Installieren von Host-Busadaptern (HBA) oder anderen Speicher-Controllern wird dieser Schlüssel möglicherweise erstellt und konfiguriert. Wenn Sie diese Treiber installieren oder neu installieren, wird der Registrierungswert von TimeOutValue mit dem Wert überschrieben, der für jene Treiber erforderlich ist. Dann müssen Sie sich u. U. mit dem Hardwareanbieter in Verbindung setzen, um den korrekten Registrierungswert von TimeOutValue für Ihre Konfiguration zu bestimmen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\Disk\TimeOutValue

  3. Löschen Sie im rechten Bereich den Eintrag TimeOutValue. Sie können auch auf den Eintrag TimeOutValue doppelklicken und einen der folgenden Werte festlegen:

    • Legen Sie für einen Server, der nicht Teil eines Clusters ist, den Wert 10 fest.

    • Legen Sie für einen Server, der Teil eines Clusters ist, den Wert 20 fest.

    • Falls Ihr Hardwarehersteller einen anderen Wert für Systeme, die Teil oder nicht Teil eines Clusters sind, empfiehlt, verwenden Sie stattdessen den Wert des Hardwareherstellers.

  4. Schließen Sie den Registrierungseditor, und starten Sie dann den Computer neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum TimeOutValue-Eintrag in Systemen als Teil eines Clusters finden Sie im Knowledge Base-Artikel 818877, „Cluster Servers May Experience Connection Timeouts to Drives After You Install or Upgrade to the Windows Clustering Feature in Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818877)).


Die DNS-Suchreihenfolge ist leer.
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_NetworkAdapterConfiguration ab, um zu bestimmen, ob ein Wert für DNSServerSearchOrder festgelegt ist. Wenn der Wert für diesen Schlüssel auf einem Exchange-Server leer ist, wird eine Warnung angezeigt.

Diese Warnung gibt an, dass mindestens einem Netzwerkadapter auf diesem Computer keine IP-Adresse eines DNS-Servers zugeordnet ist. Wenn also von diesem Computer aus versucht wird, eine Verbindung mit einem anderen Computer herzustellen, erfolgt eine Übertragung von IP-Adressen über das lokale Netzwerk. Daher erfolgt die Namensauflösung langsam, und die Leistung von Exchange kann beeinträchtigt werden.

Es wird empfohlen, eine IP-Adresse mindestens eines gültigen DNS-Servers einzugeben. Wenn mehrere Adapter auf dem Computer vorhanden sind, vergewissern Sie sich, dass alle Adapter über mindestens eine IP-Adresse eines gültigen DNS-Servers verfügen.

So legen Sie die DNS-IP-Adresse für einen Netzwerkadapter fest.

  1. Klicken Sie in Netzwerkverbindungen mit der rechten Maustaste auf den entsprechenden LAN-Adapter (Local Area Network), und klicken Sie dann auf Eigenschaften.

  2. Doppelklicken Sie auf der Registerkarte Allgemein auf Internetprotokoll (TCP/IP).

  3. Geben Sie auf der Seite Internetprotokoll (TCP/IP) auf der Registerkarte Allgemein mindestens eine IP-Adresse eines gültigen DNS-Servers ein, und klicken Sie dann auf OK.

Weitere Informationen zum Konfigurieren von DNS für Exchange finden Sie im Microsoft Knowledge Base-Artikel 322856 „SO WIRD'S GEMACHT: Konfigurieren von DNS für eine Verwendung mit Exchange Server" (http://support.microsoft.com/?kbid=322856).


Die Heartbeat-Verbindung verfügt über ein Standardgateway.
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation) Win32_NetworkAdapter ab, um den Wert des Schlüssels NetConnectionID zu bestimmen. Wenn der Wert für den Schlüssel NetConnectionID die Zeichenfolge Internal oder HEART enthält, zeigt dies an, dass es sich bei der Schnittstelle um ein privates Clusternetzwerk (Heartbeat-Netzwerk) handelt.

Exchange Server Analyzer fragt die WMI-Klasse Win32_NetworkAdapterConfiguration ab, um zu bestimmen, ob für den Schlüssel DefaultIPGateway ein Wert festgelegt ist. Ein festgelegter Wert zeigt an, dass das Standardgateway für diese Netzwerkschnittstelle konfiguriert wurde.

Wenn Microsoft Exchange Server Analyzer feststellt, dass für die vom Cluster-Heartbeat-Netzwerk verwendete Netzwerkschnittstelle ein Wert für den Schlüssel DefaultIPGateway festgelegt ist, wird eine Warnung angezeigt.

Da private Clusternetzwerke für interne Clusterkommunikation verwendet werden, ist das Konfigurieren eines Standardgateways nicht erforderlich. Zum Beseitigen möglicher Kommunikationsprobleme sollte über den Netzwerkadapter, der als privater Clusternetzwerkadapter verwendet wird, kein unnötiger Netzwerkverkehr fließen.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie das Fenster Netzwerkverbindungen. Klicken Sie mit der rechten Maustaste auf Netzwerkumgebung und dann auf Eigenschaften. Falls Netzwerkumgebung auf dem Desktop nicht angezeigt wird, können Sie auch auf Start, anschließend auf Programme, dann auf Zubehör, danach auf Kommunikation und abschließend auf Netzwerkverbindungen klicken.

  2. Klicken Sie im Fenster Netzwerkverbindungen mit der rechten Maustaste auf den Netzwerkadapter, der für das private Netzwerk verwendet wird, und klicken Sie anschließend auf Eigenschaften.

  3. Wählen Sie Internetprotokoll (TCP/IP) aus, und klicken Sie dann auf Eigenschaften.

  4. Löschen Sie im Bereich Folgende IP-Adresse verwenden die Standardgateway-IP-Adresse.

  5. Klicken Sie zweimal auf OK, um die Änderungen zu speichern.

  6. Wiederholen Sie die Schritte 1 bis 5 für jeden Knoten des Clusters.

Weitere Informationen zu empfohlenen Einstellungen für private Netzwerke in einem Windows-Servercluster finden Sie im Microsoft Knowledge Base-Artikel 258750 „Empfehlungen für die private Heartbeat-Konfiguration auf einem Clusterserver" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750).


Heartbeat-Verbindung verfügt über DNS-Suchadresse.
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation) Win32_NetworkAdapter ab, um den Wert des Schlüssels NetConnectionID zu bestimmen. Wenn der Wert für den Schlüssel NetConnectionID die Zeichenfolge Internal oder HEART enthält, zeigt dies an, dass es sich bei der Schnittstelle um ein privates Clusternetzwerk (Heartbeat-Netzwerk) handelt.

Exchange Server Analyzer fragt die WMI-Klasse Win32_NetworkAdapterConfiguration ab, um zu bestimmen, ob für den Schlüssel DNSServerSearchOrder ein Wert festgelegt ist. Wenn ein Wert festgelegt ist, zeigt dies an, dass eine DNS-Suchadresse (Domain Name System) für diese Netzwerkschnittstelle konfiguriert wurde.

Wenn Microsoft Exchange Server Analyzer feststellt, dass für die vom Cluster-Heartbeat-Netzwerk verwendete Netzwerkschnittstelle ein Wert für den Schlüssel DNSServerSearchOrder festgelegt ist, wird eine Warnung angezeigt.

Da private Clusternetzwerke für interne Clusterkommunikation verwendet werden, ist das Konfigurieren eines DNS-Servers nicht erforderlich. Zum Beseitigen möglicher Kommunikationsprobleme sollte über den Netzwerkadapter, der als privater Clusternetzwerkadapter verwendet wird, kein unnötiger Netzwerkverkehr fließen.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie das Fenster Netzwerkverbindungen. Klicken Sie entweder mit der rechten Maus auf Netzwerkumgebung, und klicken dann auf Eigenschaften. Falls Netzwerkumgebung auf dem Desktop nicht angezeigt wird, klicken Sie auf Start, anschließend auf Programme, dann auf Zubehör, danach auf Kommunikation und abschließend auf Netzwerkverbindungen.

  2. Klicken Sie im Fenster Netzwerkverbindungen mit der rechten Maustaste auf den Netzwerkadapter, der für das private Netzwerk verwendet wird, und klicken Sie anschließend auf Eigenschaften.

  3. Wählen Sie Internetprotokoll (TCP/IP) aus, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf Erweitert.

  5. Wählen Sie auf der Registerkarte DNS eine DNS-Serveradresse aus, und klicken Sie dann auf Entfernen. Wiederholen Sie diesen Schritt für alle aufgeführten DNS-Serveradressen.

  6. Deaktivieren Sie die Kontrollkästchen Adressen dieser Verbindung in DNS registrieren und DNS-Suffix dieser Verbindung in DNS-Registrierung verwenden.

  7. Klicken Sie dreimal auf OK, um die Änderungen zu speichern.

  8. Wiederholen Sie die Schritte 1 bis 7 für jeden Knoten des Clusters.

Weitere Informationen zu empfohlenen Einstellungen für private Netzwerke in einem Windows-Servercluster finden Sie im Microsoft Knowledge Base-Artikel 258750 „Empfehlungen für die private Heartbeat-Konfiguration auf einem Clusterserver" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750).


Heartbeat-Verbindung besitzt WINS-Adresse.
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation) Win32_NetworkAdapter ab, um den Wert des Schlüssels NetConnectionID zu bestimmen. Wenn der Wert für den Schlüssel NetConnectionID die Zeichenfolge Internal oder HEART enthält, zeigt dies an, dass es sich bei der Schnittstelle um ein privates Clusternetzwerk (Heartbeat-Netzwerk) handelt.

Microsoft Exchange Server Analyzer fragt die WMI-Klasse Win32_NetworkAdapterConfiguration ab, um zu bestimmen, ob für den Schlüssel WINSPrimaryServer ein Wert festgelegt ist. Wenn ein Wert festgelegt ist, zeigt dies an, dass eine primäre WINS-Adresse (Windows Internet Name Service) für diese Netzwerkschnittstelle konfiguriert wurde.

Wenn Exchange Server Analyzer feststellt, dass für die vom Cluster-Heartbeat-Netzwerk verwendete Netzwerkschnittstelle ein Wert für den Schlüssel WINSPrimaryServer festgelegt ist, wird eine Warnung angezeigt.

Da private Clusternetzwerke für interne Clusterkommunikation verwendet werden, ist das Konfigurieren eines WINS-Servers oder die Verwendung von NetBIOS nicht erforderlich. Zum Beseitigen möglicher Kommunikationsprobleme sollte über den Netzwerkadapter, der als privater Clusternetzwerkadapter verwendet wird, kein unnötiger Netzwerkverkehr fließen.

So beheben Sie dieses Problem

  1. Öffnen Sie das Fenster Netzwerkverbindungen. Klicken Sie entweder mit der rechten Maus auf Netzwerkumgebung, und klicken dann auf Eigenschaften. Falls Netzwerkumgebung auf dem Desktop nicht angezeigt wird, klicken Sie auf Start, anschließend auf Programme, dann auf Zubehör, danach auf Kommunikation und abschließend auf Netzwerkverbindungen.

  2. Klicken Sie im Fenster Netzwerkverbindungen mit der rechten Maustaste auf den Netzwerkadapter, der für das private Netzwerk verwendet wird, und klicken Sie anschließend auf Eigenschaften.

  3. Wählen Sie Internetprotokoll (TCP/IP) aus, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf Erweitert.

  5. Wählen Sie auf der Registerkarte WINS eine WINS-Adresse aus, und klicken Sie dann auf Entfernen. Wiederholen Sie diesen Schritt für alle aufgeführten WINS-Adressen.

  6. Wählen Sie im Bereich der NetBIOS-Einstellung NetBIOS über TCP/IP deaktivieren aus.

  7. Klicken Sie dreimal auf OK, um die Änderungen zu speichern. Nachdem Sie das erste Mal auf OK geklickt haben, wird möglicherweise die folgende Eingabeaufforderung angezeigt. Wenn diese Eingabeaufforderung angezeigt wird, klicken Sie auf Ja: "Diese Verbindung besitzt eine leere primäre WINS-Adresse. Möchten Sie fortfahren?"

  8. Wiederholen Sie die Schritte 1 bis 7 für jeden Knoten des Clusters.

Weitere Informationen zu empfohlenen Einstellungen für private Netzwerke in einem Windows-Servercluster finden Sie im Microsoft Knowledge Base-Artikel 258750 „Empfehlungen für die private Heartbeat-Konfiguration auf einem Clusterserver" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750).


Die Heartbeat-Verbindung steht in der TCP/IP-Bindungsreihenfolge an erster Stelle, aber nicht in der öffentlichen Verbindung.
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt zwei Microsoft WMI-Klassen (Microsoft Windows® Management Instrumentation) ab, um folgende Vorgänge auszuführen:

  • Die WMI-Klasse Win32_NetworkConfiguration wird abgefragt, um den Wert des Schlüssels SettingID für alle Netzwerkschnittstellen im Cluster zu bestimmen. Der Wert für den Schlüssel SettingsID ist eine GUID, die einen eindeutigen Netzwerkadapter darstellt.

  • Die WMI-Klasse Win32_NetworkAdapter wird abgefragt, um zu bestimmen, welche Netzwerkadapter für die Kommunikation im privaten Netzwerk in einem Exchange-Cluster verwendet werden. Das private Netzwerk wird für die clusterinterne Kommunikation verwendet, einschließlich der Heartbeat-Verbindungen des Clusters.

  • Exchange Server Analyzer untersucht außerdem den folgenden Registrierungsschlüssel, um die Bindungsreihenfolge für Netzwerkadapter zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Linkage\Bind

Der Registrierungswert Bind ist ein Wert mit mehreren Zeichenfolgen, der eine Liste der Netzwerkadapter in der Bindungsreihenfolge enthält. Der erste Eintrag in der Liste ist der zuerst gebunde Netzwerkadapter, der zweite Eintrag ist der zweite Netzwerkadapter in der Bindungsreihenfolge usw.

Wenn Exchange Server Analyzer feststellt, dass der Cluster-Heartbeat-Netzwerkadapter in der Bindungsreihenfolge an erster Stelle steht, wird eine Warnung angezeigt.

Um dieses Problem zu beheben, stellen Sie sicher, dass der öffentliche Netzwerkadapter die erste Bindung an oberster Stelle in der Bindungsliste darstellt. Wenn Sie über mehrere öffentliche Netzwerkadapter verfügen, stellen Sie sicher, dass der private Heartbeat-Netzwerkadapter an letzter Stelle aufgelistet wird. Wenn der Heartbeat-Netzwerkadapter an erster Stelle aufgelistet wird, kann er die ordnungsgemäße Installation von Service Packs und Updates verhindern.

So beheben Sie diese Warnmeldung

  1. Klicken Sie im Fenster Netzwerkverbindungen auf Erweitert, und klicken Sie dann auf Erweiterte Einstellungen.

  2. Klicken Sie auf die Registerkarte Netzwerkkarten und Bindungen.

  3. Wählen Sie im Feld Verbindungen den privaten Netzwerkadapter aus, und verschieben Sie mithilfe der Schaltfläche Nach unten den privaten Netzwerkadapter in der Liste an die unterste Position.

  4. Wiederholen Sie diese Schritte für jeden Knoten des Clusters.

Weitere Informationen zur optimalen Netzwerkkonfiguration für Windows-Servercluster finden Sie in „Server Clusters: Network Configuration Best Practices for Windows 2000 and Windows Server 2003" unter http://go.microsoft.com/fwlink/?linkid=34304.

Weitere Informationen zur richtigen Cluster-Heartbeat-Konfiguration finden Sie im Microsoft Knowledge Base-Artikel 258750 „Empfehlungen für die private Heartbeat-Konfiguration auf einem Clusterserver" unterhttp://support.microsoft.com/kb/258750/de.


Heartbeat-Netzwerkdatenrate wird auf „Auto Sense/Auto Detect" festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation) Win32_NetworkAdapter ab, um den Wert des Schlüssels NetConnectionID zu bestimmen. Wenn der Wert für den Schlüssel NetConnectionID die Zeichenfolge Internal oder HEART enthält, zeigt dies an, dass es sich bei der Schnittstelle um ein privates Clusternetzwerk (Heartbeat-Netzwerk) handelt.

Exchange Server Analyzer liest auch den folgenden Registrierungswert, um die Verbindungsgeschwindigkeit und die Duplexeinstellungen für die vom Cluster-Heartbeat-Netzwerk verwendete Netzwerkschnittstellenkarte zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\<NetworkCardDeviceID>\SpeedDuplex

Darüber hinaus liest Exchange Server Analyzer auch den folgenden Registrierungswert, um zu bestimmen, ob die automatische Erkennung der Netzwerkgeschwindigkeit aktiviert ist:

HKLM\System\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\%NICDEVICEID%\Ndi\Params\SpeedDuplex\enum\0

Wenn der Wert für den Schlüssel 0 die Zeichenkette AUTO enthält, ist die automatische Erkennung der Netzwerkgeschwindigkeit aktiviert.

Wenn Exchange Server Analyzer feststellt, dass SpeedDuplex auf 0 festgelegt ist und die automatische Erkennung der Netzwerkgeschwindigkeit für das Cluster-Heartbeat-Netzwerk aktiviert ist, wird eine Warnung angezeigt.

Die Kommunikation zwischen Serverclusterknoten ist für reibungslose Clustervorgänge entscheidend. Wenn Sie für die Clusterkommunikation einen Ethernet-Netzwerkadapter verwenden, der mehrere Geschwindigkeiten unterstützt, und den Adapter für die automatische Erkennung der Netzwerkgewschwindigkeit konfigurieren, verursacht der Adapter möglicherweise Probleme im Cluster. Während des Erkennungsvorgangs kann der Adapter keine Pakete bearbeiten. Diese müssen in eine Warteschlange aufgenommen werden. Manche Adapter lösen unabsichtlich den automatischen Erkennungsvorgang aus, sodass dieser gelegentlich wieder auftritt. Daher entsteht eine Warteschlange und die Datenkommunikation verzögert sich. Verzögerungen dieser Art können dazu führen, dass Clusterknoten wichtige Pakete nicht sofort erhalten und ein vorzeitiges Failover der Clusterressourcen auftritt. Es wird empfohlen, das Heartbeat-Netzwerk in einem Cluster manuell auf 10 Megabit und Halbduplex festzulegen. Diese Konfiguration stellt eine ausreichende Bandbreite bereit und führt zu einer zuverlässigen Kommunikation .

So beheben Sie dieses Problem

  • Konfigurieren Sie die Heartbeat-Netzwerkschnittstellenkarte für eine Verbindungsgeschwindigkeit von 10 Megabit und für eine Halbduplex-Einstellung. Da sich die Konfigurationsschritte für die verschiedenen Netzwerkkarten unterscheiden, folgen Sie den Anweisungen des Hardwareanbieters, um das Heartbeat-Netzwerk ordnungsgemäß zu konfigurieren. Für die Konfiguration dieser Optionen ist möglicherweise ein aktualiserter Treiber erforderlich.

Weitere Informationen zu empfohlenen Einstellungen für private Netzwerke in einem Windows-Servercluster finden Sie im Microsoft Knowledge Base-Artikel 258750 „Empfehlungen für die private Heartbeat-Konfiguration auf einem Clusterserver" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750).


Warteschlangentiefe für Hostbusadapter ist auf 32 festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2006-10-11

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Warteschlangentiefe der Hostbusadapter (HBAs), die im Exchange Server-Computer installiert sind, zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\elxstor\Parameters\Device\DriverParameter

Wenn Exchange Server Analyzer feststellt, dass der Wert für DriverParameter auf 32 festgelegt ist, wird eine Warnung angezeigt.

Ein HBA ist ein Datenträgercontroller für Speicherbereichsnetzwerke (Storage Area Networks, SANs). Die HBA-Warteschlangentiefe legt die maximale Anzahl unbearbeiteten Warteschlangenanforderungen fest. Im Allgemeinen liegt der empfohlene Wert für DriverParameter bei 128. Dieser Wert ist möglicherweise nicht der optimale Wert für die HBA-Warteschlangentiefe für jeden HBA auf allen Exchange Server-Computern. Daher sollten Sie sich beim Hersteller Ihres HBAs nach dem optimalen Wert für Ihre Hardware erkundigen.

So beheben Sie diese Warnmeldung

  1. Wenden Sie sich an den Hardwarehersteller, um die optimale Einstellung für die HBAs zu bestimmen.

  2. Überwachen Sie die Leistung des Datenträgers mit dem Dienstprogramm Microsoft Windows®-Systemmonitor.

  3. Aktualisieren Sie Ihre HBA-Hardware auf die neueste Firmware und die aktuellen Treiber.

Weitere Informationen zu Speicherdesign und -optimierung von Exchange Server finden Sie in „Optimieren von Speichersystemen für Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=49324).


Hot-Add-Speicherkonfiguration
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2006-02-22

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_Computer System ab, um zu ermitteln, ob der Server Hot-Add-Speicherfunktionen unterstützt. Exchange Server Analyzer fragt außerdem die WMI-Klasse Win32_OperatingSystem ab, um folgendes zu ermitteln.

  • Wurde die Option /3GB in der Datei Boot.ini festgelegt.

  • Wurde der Kernel für die physischen Adresserweiterungen (PAE) geladen.

  • Welche Edition des Betriebssystems wird auf dem Server ausgeführt.

Schließlich fragt Exchange Server Analyzer den folgenden Registrierungseintrag ab, um zu bestimmen, ob der Parameter DynamicMemory vorhanden ist und richtig festgelegt wurde:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Wenn Microsoft Exchange Server Analyzer ermittelt, dass die folgenden Kriterien zutreffen, zeigt das Tool einen Fehler an:

  • Der Computer unterstützt Hot-Add-Speicher, und die Funktion ist standardmäßig aktiviert.

  • Der Computer führt Microsoft Windows Server™ 2003, Enterprise Edition oder Windows Server 2003, Datacenter Edition aus.

  • Der PAE-Kernel wurde geladen.

  • Die Option /3GB wurde in der Datei Boot.ini festgelegt.

  • Der Registrierungsparameter DynamicMemory ist gar nicht, auf Null oder auf einen Wert größer als 3 festgelegt.

Hinweis:
Wenn der Computer Hot-Add-Speicher unterstützt, aber der Hersteller der Hardware hat diese Funktion standardmäßig deaktiviert, zeigt Exchange Server Analyzer eine Warnung, aber keine Fehlermeldung an.

Die Hot-Add-Speicherfunktion wurde mit Windows Server 2003, Enterprise Edition und Windows Server 2003, Datacenter Edition eingeführt, damit Systemadministratoren den physischen Speicher eines Computers ergänzen können, ohne ihn neu starten zu müssen. Diese Funktion ist auf Servern nützlich, die speicherintensive relationale Datenbankanwendungen wie Microsoft SQL Server ausführen. Da Exchange Server aber nicht mehr als 4 GB of physischen Speicher verwenden kann, ist diese Funktion für Exchange Server nicht nützlich.

Nicht alle Computer unterstützen Hot-Add-Speicher. Einige Hardwarehersteller haben bei den entsprechenden Computern die Funktion standardmäßig aktiviert, andere bieten Steuerungsmöglichkeiten innerhalb von BIOS (Basic Input Output System) an. Wenn beim Starten Hot-Add-Speicher aktiviert wird, muss der Betriebssystemkernel vorab Speicherplatz zuweisen, damit auch später zum Computer hinzugefügter Speicher verwaltet werden kann. Deshalb werden Kernelressourcen auf der Grundlage der Fähigkeiten des Computers und nicht auf der Grundlage des tatsächlich Installierten zugewiesen. Kernelspeicher ist auf Computern, die Microsoft Exchange Server ausführen, eine wertvolle Ressource. Aufgrund der Natur des von Exchange Server verwendeten physischen Speichers, können durch Deaktivieren der Hot-Add-Speicherfunktion zusätzliche Leistung und mehr Skalierbarkeit erzielt werden, da der Kernel eventuell in erheblichem Umfang Ressourcen zu Speicher zuordnet, der möglicherweise nie installiert wird. Bleibt diese Funktion aktiviert, so kann die maximale Größe des Auslagerungspools erheblich kleiner als erwartet sein. Dies kann einen deutlichen Leistungsrückgang, Systemstillstand und letztlich auch einen Ausfall des Dienstes verursachen.

Beispiele für die erwartete maximale Größe des ausgelagerten Pools (höhere Werte wären besser):

  • 240 MB Ein Computer mit 4 GB physischen Speichers, ohne oder mit deaktiviertem Hot-Add-Speicher

  • 210 MB Ein Computer mit 4 GB physischen Speichers, der aber bis zu 32 GB Hot-Add-Speicher unterstützen kann

  • 160 MB Ein Computer mit 4 GB physischen Speichers, der aber bis zu 64 GB Hot-Add-Speicher unterstützen kann

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So beheben Sie dieses Problem auf Computern, die Windows Server 2003 Service Pack 1 (SP1) oder höher ausführen

  1. Setzen Sie den folgenden Registrierungsparameter, um die Hot-Add-Speicherfunktion zu deaktivieren:

    Pfad

    HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

    Wert

    DynamicMemory

    Typ

    REG_DWORD

    Daten

    0x1
    Hinweis:
    Der Wert für diesen Konfigurationsparameter gibt die Größe des maximal adressierbaren physischen Speichers in GB an, einschließlich des Hot-Add-Speichers, wenn der zum Startzeitpunkt installierte Speicher nicht größer ist. Wenn der Wert auf 1 festgelegt wird, reserviert der Kernel Speicherplatz von insgesamt 1 GB Systemspeicher oder den gesamten, beim Start installierten physischen Speicher, falls dieser größer ist.

  2. Starten Sie den Computer neu
So beheben Sie dieses Problem auf Computern, die Windows Server 2003 ohne Service Pack 1 ausführen

  • Wenden Sie sich an Ihren Hardwareanbieter, um zu ermitteln, ob die Hot-Add-Speicherfunktion in BIOS deaktiviert werden kann.

  • Wenn der Hot-Add-Speicher nicht über die Hardware gesteuert werden kann, empfiehlt es sich, die Aktualisierung auf Windows Server 2003 Service Pack 1 durchzuführen und dann dieses Verfahren zur Lösung des Problems zu befolgen, um den Parameter DynamicMemory zu implementieren. Wenn Sie nicht auf Service Pack 1 aktualisieren können, besteht auch die Möglichkeit, die Option /NOPAE in der Datei Boot.ini festzulegen. Durch Aktivieren dieser Option, wird der Computer gezwungen, Speicher oberhalb der 4 GB-Grenze nicht mehr zu erkennen. Verwenden Sie diese Option auf Computern unter Windows Server 2003 vor Service Pack 1, nicht aber auf Computern mit Service Pack 1, weil dadurch unbeabsichtigt neue Funktionen wie die Unterstützung für Data Execution Prevention (DEP) deaktiviert werden können.

Weitere Informationen

Weitere Informationen zur Unterstützung von Hot-Add-Speicher in Windows Server 2003, finden Sie unter "Hot-Add Memory Support in Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=57183).


Die Internet-SCSI-Initiator-Software ist veraltet
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2006-04-03

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_SCSIController ab, um den Wert für den Schlüssel DriverName für den Treiber iScsciPrt zu ermitteln. Exchange Server Analyzer fragt die WMI-Klasse CIM_Datafile ab, um den in der Treiberdatei iScsciPrt aufgeführten Schlüssel Version zu bestimmen. Wenn Exchange Server Analyzer einen Unterzeichenfolgenwert im Schlüssel Version des Treibers iScsciPrt findet, der unter 1748 liegt, wird eine Warnung angezeigt.

Internet small computer system interface (iSCSI) ist eine auf dem Internetprotokoll basierende (IP-basierte) Methode zum Versenden von in IP-Paketen eingepackten SCSI-Befehlen (Small Computer Systems Interface) über TCP/IP-Netzwerke. Da iSCSI auf IP basiert, können Daten über LANs (Local Area Networks), über WANs (Wide Area Networks) und über das Internet an Remotespeicherorte übertragen werden. Microsoft Windows-Betriebssysteme stellen iSCSI-Festplatten für Programme wie Exchange Server 2003 oder Exchange 2000 Server als Festplatten dar, die direkt mit dem Exchange Server-Computer verbunden sind.

Microsoft empfiehlt eine umsichtige Vorgehensweise bei der Bereitstellung von Exchange Server 2003 mit iSCSI oder Exchange 2000 Server mit iSCSI. Da iSCSI das SCSI-Transportprotokoll zur Übertragung von Blockdaten über TCP/IP-Netzwerke verwendet, könnten durch den Einsatz eines Netzwerks Komponenten einbezogen werden, die nicht als Hochgeschwindigkeits-E/A-Pfade im herkömmlichen Sinne gelten. Zur Optimierung des Durchsatzes müssen Sie Exchange-Server so konfigurieren, dass Zwischenspeicherungsaktivitäten maximiert werden. Zudem sollten Sie prüfen, ob die im iSCSI-Datenverkehr auftretende Latenz minimiert ist. Wenn keine anderen Angaben der Herstellers der Speicherlösung vorliegen, wird dringend empfohlen, den neuesten Build von Microsoft iSCSI Software Initiator zu verwenden.

So beheben Sie diese Warnmeldung

  1. Downloaden Sie die neueste Version von Microsoft iSCSI Software Initiator im Microsoft Download Center unter http://go.microsoft.com/fwlink/?LinkId=33817.

  2. Lesen Sie auch die Versionsinformationen auf der Microsoft-Website unter http://go.microsoft.com/fwlink/?LinkId=40951.

  3. Lesen Sie auch das Benutzerhandbuch auf der Microsoft-Website unter http://go.microsoft.com/fwlink/?LinkId=40963.

  4. Nehmen Sie eine vollständige Sicherung des Computers vor.

  5. Wenden Sie das Update der neuesten Version an.

Weitere Informationen zur Unterstützung von iSCSI in Exchange 2000 Server und Exchange Server 2003 finden Sie im Knowledge Base-Artikel 839686, „Support for iSCSI technology components in Exchange Server" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839686.

Weitere Informationen zur iSCSI-Technologie und der iSCSI-Unterstützung durch Microsoft finden Sie auf der Microsoft-Website „Microsoft Storage Technologies - iSCSI" unter http://go.microsoft.com/fwlink/?LinkId=27514.


Leistungsindikatoren für logische und physische Datenträger sind deaktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest die folgenden Registrierungseinträge, um zu bestimmen, ob die Leistungsindikatoren für logische und physische Datenträger deaktiviert sind:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Perfdisk\Performance\Disable Performance Counters

Wenn Exchange Server Analyzer feststellt, dass der Wert für Leistungsindikatoren deaktivieren vorhanden und mit dem Wert 1 konfiguriert ist, wird eine Warnung angezeigt.

Es gibt zwei Typen von datenträgerbezogenen Leistungsindikatoren, die auf einem Server-Computer mit dem Betriebssystem Microsoft Windows® veröffentlicht sind:

  • Der eine Typ wird vom Microsoft Win32®-Leistungsteilsystem und von der WMI (Windows-Verwaltungsinstrumentation - Windows Management Instrumentation) verwendet.

  • Der andere Typ wird von älteren Anwendungen verwendet, die mithilfe der IOCTL_DISK_PERFORMANCE-API Raw-Leistungsindikatorinformationen abrufen.

  • Die von Win32 und der WMI verwendeten Leistungsindikatoren sind in der Standardeinstellung auf Microsoft Windows Server™ 2003 und Windows 2000 Server aktiviert. Raw-Leistungsindikatoren sind als Standard unter beiden Betriebssystemen deaktiviert. Wenn der Registrierungswert Leistungsindikatoren deaktivieren, der in der Standardeinstellung auf keinem der beiden Betriebssystem vorhanden ist, hinzugefügt und mit dem Wert 1 konfiguriert wird, sind die Win32-/WMI-Leistungsindikatoren deaktiviert, und es können keine Leistungsdaten dieser Leistungsindikatoren gesammelt werden.

Am häufigsten werden die Win32-/WMI-Leistungsindikatoren mithilfe des ECL-Tools ExCtrLst.exe (Extensible Counter List) deaktiviert. Dieses grafische Tool, das mit dem Resource Kit von Windows 2000 Server und Windows Server 2003 verfügbar ist, ermöglicht es dem Administrator, selektiv die Veröffentlichung von Leistungsobjekten zu aktivieren oder deaktivieren. Wenn mit ExCtrLst.exe ein Leistungsobjekt deaktiviert wird, wird in der Registrierung der Eintrag Leistungsindikatoren deaktivieren hinzugefügt und mit dem Wert 1 konfiguriert. Wenn mit ExCtrLst.exe anschließend ein deaktivierter Leistungsindikator erneut aktiviert wird, wird der Wert für Leistungsindikatoren deaktivieren auf 0 festgelegt (Beachten Sie, dass der Eintrag Leistungsindikatoren deaktivieren nicht gelöscht wird).

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\Perfdisk\Performance

  3. Doppelklicken Sie im rechten Bereich auf Leistungsindikatoren deaktivieren, und legen Sie den Wert auf 0 fest. Sie können auch den Eintrag Leistungsindikatoren deaktivieren löschen, um die Leistungsindikatoren wieder zu aktivieren.

  4. Schließen Sie den Registrierungseditor, und starten Sie die Anwendung, die die Leistungsdaten sammelt, erneut, damit die Änderung wirksam wird.

Weitere Informationen zu ExCtrLst.exe finden Sie unter „ExCtrLst.exe: Extensible Performance Counter List" (http://go.microsoft.com/fwlink/?LinkId=34436).


Mehrere Standardgateways wurden gefunden.
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_NetworkAdapterConfiguration ab, um die Anzahl der Instanzen des Schlüssels DefaultIPGateway zu bestimmen. Jeder Netzwerkadapter veröffentlicht seine konfigurierten Standardgatewayadressen an WMI über diesen Schlüssel. Wenn Exchange Server Analyzer feststellt, dass mehrere konfigurierte Instanzen des Schlüssels DefaultIPGateway vorhanden sind, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass mehrere Netzwerkadapter gefunden wurden und dass mehr als einer dieser Adapter über ein konfiguriertes Standardgateway verfügt. Wenn mehrere Adapter verwendet werden und mit getrennten Standardgateways konfiguriert sind, geht u. U. die Verbindung zu Computern in Remotenetzwerken verloren. Außerdem verursachen mehrere Standardgateways, die mit unterschiedlichen Netzwerksubnetzen verbunden sind, Probleme bei der DNS-Auflösung (Domänennamenssystem), bei der SMTP-Nachrichtenübermittlung (Simple Message Transfer Protocol), bei LDAP-Abfragen (Lightweight Directory Access Protocol) und bei Benachrichtigungen über neue Nachrichten an Microsoft® Office Outlook® 2003-Clients. Viele dieser Probleme können verhindern, dass Exchange Server startet oder Nachrichten sendet und empfängt.

Es wird empfohlen, dass Sie bis auf einen einzelnen Standardgateway alle Standardgateways von einem der Netzwerkschnittstellenadapter im Exchange Server-Computer entfernen. Exchange Server-Computer sind oft mehrfach vernetzt, wenn ISA Server (Microsoft Internet Security and Acceleration) auf demselben Computer installiert ist. Sogar dann, wenn Sie Exchange Server und ISA Server auf demselben Computer ausführen, ist die Verwendung von mehreren Standardgateways nicht empfehlenswert. Wenn Exchange Server und ISA Server nicht auf demselben Computer installiert sind, empfiehlt es sich, dass Sie einen Exchange Server-Computer nicht mehrfach vernetzen.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie das Fenster Netzwerkverbindungen. Klicken Sie mit der rechten Maustaste auf Netzwerkumgebung und dann auf Eigenschaften. Falls Netzwerkumgebung auf dem Desktop nicht angezeigt wird, können Sie auch auf Start, anschließend auf Programme, dann auf Zubehör, danach auf Kommunikation und abschließend auf Netzwerkverbindungen klicken.

  2. Klicken Sie im Fenster Netzwerkverbindungen mit der rechten Maustaste auf die Netzwerkverbindung, die den zu entfernenden Standardgatewayeintrag enthält, und klicken Sie dann auf Eigenschaften.

  3. Wählen Sie Internetprotokoll (TCP/IP) aus, und klicken Sie dann auf Eigenschaften.

  4. Löschen Sie die IP-Adresse aus dem Feld Standardgateway.

  5. Klicken Sie zweimal auf OK, um die Änderungen zu speichern.

  6. Wiederholden Sie diesen Prozess für alle anderen Netzwerkverbindungen, die einen Standardgatewayeintrag enthalten, bis auf den einen Eintrag, den Sie behalten möchten.

Weitere Informationen zu Problemen, die auf Computern auftreten, die mehrere Standardgateways verwenden, finden Sie im Microsoft Knowledge Base-Artikel 159168, „Mehrere Standardgateways können Konnektivitätsprobleme verursachen" unter (http://support.microsoft.com/kb/159168/de).

Weitere Informationen zum Konfigurieren von Standardgateways auf mehrfach vernetzten Computern finden Sie im Microsoft Knowledge Base-Artikel 157025, „Standardgateway-Konfiguration für mehrfach vernetzte Computer" (http://support.microsoft.com/kb/157025/de).


"PageFile" größer als physikalischer Gesamtspeicher
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2007-07-30

Das Tool Microsoft Exchange Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation) Win32_PageFile ab, um den Wert für den Schlüssel MaximumSize zu ermitteln. Dieser Schlüssel gibt die zurzeit konfigurierte maximale Größe für die Auslagerungsdatei an.

Exchange Analyzer fragt außerdem die WMI-Klasse Win32_ComputerSystem ab, um den für den Schlüssel TotalPhysicalMemory festgelegten Wert zu ermitteln. Dieser Wert stellt die Größe des auf dem Computer installieren Arbeitsspeichers (RAM) dar.

Wenn Exchange Analyzer ermittelt, dass die Größe für den Schlüssel Win32_PageFile MaximumSize das 1,5-fache des Werts für den Schlüssel Win32_ComputerSystem TotalPhysicalMemory übersteigt, wird ein Fehler angezeigt.

Bei der Auslagerungsdatei (pagefile.sys) handelt es sich um eine versteckte Datei, mit der Windows temporäre Dateien speichert, wenn das System über wenig RAM verfügt. Die Auslagerungsdatei wird auch als Paging- oder Swapdatei bezeichnet. Der virtuelle Speicher besteht aus der Auslagerungsdatei und RAM.

Die empfohlene Größe für die Auslagerungsdatei beträgt das 1,05-fache des RAM. Der Wert sollte jedoch 4.095 MB nicht überschreiten. Dies bedeutet, dass die maximale Größe, die für eine Auslagerungsdatei auf einem Datenträger festgelegt werden kann, 4.095 MB beträgt.

Hinweis:
Um eine Fragmentierung der Auslagerungsdatei zu verhindern, wird empfohlen, den Anfangs- und den Maximalwert für die Größe der Auslagerungsdatei auf den gleichen Wert festzulegen. Wenn Sie den Anfangs- oder Maximalwert für die Auslagerungsdatei verringern, müssen Sie den Computer erneut starten, damit die Änderungen wirksam werden. Wenn Sie die Werte erhöhen, ist im Allgemeinen kein Neustart erforderlich.
So ändern Sie die Einstellungen für die Auslagerungsdatei

  1. Klicken Sie auf Start, klicken Sie auf Systemsteuerung, und klicken Sie dann auf System.

  2. Klicken Sie auf der Registerkarte Erweitert unter Systemleistung auf Einstellungen.

  3. Klicken Sie im Dialogfeld Leistungsoptionen auf der Registerkarte Erweitert unter Virtueller Arbeitsspeicher auf Speichern.

  4. Klicken Sie unter Laufwerk [Bezeichnung] auf das Laufwerk, das die zu ändernde Auslagerungsdatei enthält.

  5. Klicken Sie unter Größe der Auslagerungsdatei für ein bestimmtes Laufwerk auf Benutzerdefinierte Größe, und geben Sie in den Feldern Anfangsgröße (MB) und Maximale Größe (MB) die empfohlene Größe für die Auslagerungsdatei in MB an. Klicken Sie dann auf Festlegen.

Weitere Informationen zu Auslagerungsdateien finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 197379, "Konfigurieren von Auslagerungsdateien für die Optimierung und Wiederherstellung unter Windows Server 2003, Windows 2000 und Windows NT" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379)

  • 307973, "Konfigurieren von Wiederherstellungstechniken unter Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307973)

  • 254649, "Überblick über Optionen für Speicherabbilddateien in Windows Server 2003, Windows XP und Windows 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=254649)

  • 241046, "Eine Datei 'Memory.dmp' kann nicht auf Computern mit mehr als 4 GB RAM erstellt werden" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=241046)


Die Adresse des sekundären WINS-Servers ist leer
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_NetworkAdapterConfiguration ab, um zu bestimmen, ob ein Wert für den WINSSecondaryServer-Schlüssel festgelegt ist. Wenn der Wert für diesen Schlüssel auf einem Exchange-Server leer ist, wird eine Warnung angezeigt.

Exchange Server 2003 und Exchange 2000 Server verfügen über mehrere NetBIOS-Abhängigkeiten. Außerdem benötigen Clients, auf denen ältere Versionen von Microsoft Outlook® als Microsoft Office Outlook 2003 ausgeführt werden, auch eine NetBIOS-Namensauflösung. Die folgenden Exchange-Funktionen sind z. B. von der NetBIOS-Namensauflösung abhängig:

  • Die Setupprogramme von Exchange Server 2003 und Exchange 2000 Server, insbesondere auf Servern, die Teil eines Clusters sind.

  • Der Exchange Mailbox Merge-Assistent (ExMerge) auf Exchange Server 2003- oder Exchange 2000 Server-Computern.

  • Das Ändern des Kennworts für ein Exchange Server 2003- oder Exchange 2000 Server-Postfach über Outlook Web Access.

  • Der Exchange-System-Manager auf einem Exchange Server 2003- oder Exchange 2000 Server-Computer.

Je nach Netzwerktopologie der Organisation können Sie diese Warnung auch ignorieren. In Netzwerken, die aus einem einzigen Subnetz bestehen, können NetBIOS-Broadcasts normalerweise mit den Anforderungen an die NetBIOS-Namensauflösung einer Exchange-Bereitstellung umgehen.

In großen Organisationen funktioniert die NetBIOS-Namensauflösung über Broadcasts u. U. nicht ordnungsgemäß. Da NetBIOS-Broadcasts typischerweise keine Subnetze kreuzen, erfordern geroutete Netzwerke eine andere Methode für die NetBIOS-Namensauflösung. Als bevorzugte Methode hierfür wird WINS (Windows Internet Name Service) verwendet. WINS stellt eine verteilte Datenbank für das Registrieren und Abfragen dynamischer Zuordnungen von NetBIOS-Namen für die im Netzwerk verwendeten Computer und Gruppen bereit. WINS ordnet NetBIOS-Namen IP-Adressen zu und soll Probleme bei der NetBIOS-Namensauflösung in gerouteten Umgebungen lösen. WINS ist am besten für die NetBIOS-Namensauflösung in Netzwerken mit Routern geeignet, in denen NetBIOS über TCP/IP verwendet wird.

Der Betrieb und die Funktionen von Exchange Server 2003 und Exchange 2000 Server in großen Organisationen oder Organisationen mit mehreren Subnetzen ohne WINS wurden nicht vollständig getestet. Microsoft sucht Unternehmen, die Exchange in gerouteten oder segmentierten Netzwerken mit WINS für die NetBIOS-Namensauflösung ausführen. Das Ausführen von Exchange in einer gerouteten oder segmentierten Umgebung ohne WINS wird nicht unterstützt.

Es wird empfohlen, eine fehlertolerante WINS-Umgebung bereitzustellen, die zumindest zwei WINS-Server enthält. WINS-Server können entweder als primärer WINS-Server oder als sekundärer WINS-Server bei einem Client fungieren. Der Unterschied zwischen primären und sekundären WINS-Servern besteht darin, mit welcher Priorität Clients zu ihnen die Verbindung herstellen. Ein primärer WINS-Server ist der erste Server, zu dem ein Client die Verbindung herstellt, um die NetBIOS-Namensdienstservice-Vorgänge auszuführen. Ein Client stellt nur dann eine Verbindung mit einem sekundären WINS-Server her, wenn ein primärer WINS-Server die Abfrage nicht beantworten kann. Das ist z. B. der Fall, wenn der primäre WINS-Server zu dem Zeitpunkt, wenn die Abfrage vom Client erfolgt, nicht zur Verfügung steht, oder wenn ein Name für den Client nicht aufgelöst werden kann.

Wenn ein primärer WINS-Server die Abfrage nicht beantworten kann, richtet der Client die gleiche Abfrage an den sekundären WINS-Server. Wenn mehr als zwei WINS-Server für den Client konfiguriert sind, versucht der Client es bei den anderen sekundären WINS-Servern, bis die Liste abgearbeitet ist oder einer der WINS-Server erfolgreich auf die Abfrage reagiert. Nachdem ein Client einen sekundären WINS-Server verwendet hat, versucht er in regelmäßigen Abständen, für künftige Namensdienstabfragen zu seinem primären WINS-Server zurückzukehren.

Es hat sich bewährt, zumindest einen sekundären WINS-Server auf Exchange Server-Computern in einem gerouteteten oder segmentierten Netzwerk zu konfigurieren.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie das Fenster Netzwerkverbindungen.

  2. Klicken Sie mit der rechten Maustaste auf die zu konfigurierende Netzwerkverbindung, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Allgemein (für eine LAN-Verbindung) bzw. auf der Registerkarte Netzwerk (für alle anderen Verbindungen) auf Internetprotokoll (TCP/IP) und dann auf Eigenschaften.

  4. Klicken Sie auf Erweitert, klicken Sie auf die Registerkarte WINS und dann auf Hinzufügen.

  5. Geben Sie in TCP/IP WINS-Server die IP-Adresse eines sekundären WINS-Servers ein, und klicken Sie dann auf Hinzufügen.

  6. Wiederholen Sie die Schritte 4 und 5 für jede weitere WINS-Server-IP-Adresse, die Sie hinzufügen möchten, und klicken Sie dann auf OK. Sie können die Präferenzreihenfolge für WINS-Server mithilfe der Pfeiltasten ändern.

  7. Vergewissern Sie sich, dass NetBIOS über TCP/IP aktivieren aktiviert ist.

  8. Klicken Sie zum Speichern der Änderungen auf OK.

Weitere Informationen zu den Anforderungen an die NetBIOS-Namensauflösung für Exchange finden Sie im Microsoft Knowledge Base-Artikel 837391 „Exchange Server 2003 and Exchange 2000 Server require NetBIOS name resolution for full functionality" auf der Seite http://support.microsoft.com/?kbid=837391.


Beim Server handelt es sich um einen Virtual PC-Server
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2007-03-28

Microsoft® Exchange Server Best Practices Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) Win32_ComputerSystem ab, um den Wert des Schlüssels Model für den Exchange Server-Computer zu bestimmen. Wenn der Wert für diesen Schlüssel die Zeichenfolge Virtual Machine enthält, wird eine Fehlermeldung angezeigt.

Durch die Zeichenfolge Virtual Machine wird angegeben, dass der Exchange Server-Computer auf einem virtuellen Microsoft Virtual PC 200x-Computer ausgeführt wird. Bei Virtual PC 200x handelt es sich um eine Softwarevirtualisierungslösung, mit deren Hilfe auf einem Computer mehrere PC-basierte Betriebssysteme gleichzeitig ausgeführt werden können. Das Ausführen einer beliebigen Version von Microsoft Exchange Server auf einem virtuellen Computer oder einem Emulator wird von Microsoft nicht unterstützt. Dies gilt für Exchange Server unter Microsoft Virtual Server 200x, Microsoft Virtual PC 200x und sämtliche Anwendungen für virtuelle Computer von Drittanbietern. Microsoft Exchange-Server wurden so entwickelt und getestet, dass sie nur auf realer Hardware, insbesondere auf den Hardwareplattformen ausgeführt werden können, die im Windows-Serverkatalog unter http://go.microsoft.com/fwlink/?linkid=17219 aufgeführt sind.

So beheben Sie diesen Fehler

  1. Verschieben Sie die Postfächer aus dem Exchange Server, der unter Virtual PC 200x ausgeführt wird, auf einen nicht virtuellen Computer mit Exchange Server.

  2. Lagern Sie beliebige Öffentliche Ordner aus, und übertragen Sie beliebige Rollen, die bei Bedarf von dem virtuellen Exchange-Server übernommen werden.

  3. Deinstallieren Sie Exchange von dem virtuellen Rechner, um es außer Betrieb zu setzen und aus Ihrer Exchange-Infrastruktur und aus dem Active Directory ®-Verzeichnisdienst zu entfernen.

Weitere Informationen zur Unterstützung für Computer mit Exchange Server, die in virtuellen Umgebungen ausgeführt werden, finden Sie im Microsoft Knowledge Base-Artikel 320220 "Unterstützungsrichtlinie für Exchange Server 2003 mit Hardwarevirtualisierungssoftware" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320220).

Weitere Informationen zu Microsoft Virtual PC finden Sie auf der Startseite von Microsoft Virtual PC (http://go.microsoft.com/fwlink/?linkid=34663).


Dieser Datenträger meldet einen Fehler
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_DiskDrive ab, um den Wert für den Schlüssel Status der einzelnen Datenträger zu bestimmen. Wenn Exchange Server Analyzer ermittelt, dass der Wert für den Schlüssel Status eines Datenträgers nicht OK ist, wird ein Fehler angezeigt.

Der Schlüssel Status steht für den aktuellen Status des Datenträgers. Es können verschiedene betriebsbereite oder nicht betriebsbereite Zustände definiert werden. Die betriebsbereiten Statuswerte:

  • OK

  • Heruntergestuft

  • Künftiger Fehler (ein Element, etwa eine SMART-aktivierte Festplatte, funktioniert möglicherweise einwandfrei, kann aber in naher Zukunft ausfallen).

  • Die nicht betriebsbereiten Statuswerte:

  • Fehler

  • Starten

  • Beenden

  • Dienst (kann beim erneuten Spiegeln eines Datenträgers, beim erneuten Laden einer Benutzerberechtigungsliste oder einem anderen Verwaltungsvorgang auftreten).

Der Schlüssel Status kann von der WMI-Klasse CIM_ManagedSystemElement übernommen werden, zu der folgende Werte gehören:

  • OK

  • Fehler

  • Heruntergestuft

  • Unbekannt

  • Künftiger Fehler

  • Starten

  • Beenden

  • Dienst

  • Beansprucht

  • Keine Wiederherstellung

  • Kein Kontakt

  • Kommunikation abgebrochen

Microsoft stellt keine Dokumentation zur Behebung von Fehlern der Datenträger bestimmter Hardwarehersteller zur Verfügung.

So berichtigen Sie diesen Fehler

  1. Prüfen Sie alle Datenträger und Kabelverbindungen, warten Sie 10 Minuten, und prüfen Sie dann den Wert von Status.

  2. Wenn es sich bei dem zurückgegebenen Wert nicht um einen Wert des Wartungsmodus handelt (der Wert ist beispielsweise nicht gleich Dienst), befolgen Sie die vom Hersteller Ihrer Festplatte zur Verfügung gestellten Anweisungen zur Fehlerbehebung. Unter Umständen verfügt der Festplattenhersteller über entsprechende Software, die Sie zum Analysieren des Problems installieren können.

Allgemeine Speicherungsinformationen zu Exchange finden Sie unter „Storage Solutions for Microsoft Exchange 2000 Server" im Microsoft Download Center unter http://go.microsoft.com/fwlink/?LinkId=1715.

Allgemeine Speicherungsinformationen zu Microsoft Windows Server™ 2003 finden Sie unter „Windows Server 2003 Storage Services" im Microsoft Windows Server 2003 TechCenter unter http://go.microsoft.com/fwlink/?LinkId=33811.

Allgemeine Speicherungsinformationen zu Windows 2000 Server finden Sie unter „Windows Server 2000 Storage Services" auf der Windows 2000-Website unter http://go.microsoft.com/fwlink/?LinkId=33812.


Dieser Exchange-Server verfügt über mehr als 8 Prozessoren
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Best Practices Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) Win32_ComputerSystem ab, um den aktuellen Wert für NumberOfProcessors zu bestimmen. Wenn Exchange Server Best Practices Analyzer feststellt, dass der Wert für NumberOfProcessors größer als 8 ist, wird eine Warnung angezeigt. Wenn dieser Server jedoch für die Verwendung von Intel Hyper-Threading-Technologie konfiguriert ist, kann diese Warnung einfach ignoriert werden. Die Hyper-Threading-Technologie ermöglicht das parallele Ausführen von Threads durch Multi-Thread-Software. Für Hyper-Threading-Technologie ist ein Computersystem mit einem Intel Pentium 4-Prozessor erforderlich, das Hyper-Threading-Technologie unterstützt. Darüber hinaus müssen Chipsatz, BIOS und Betriebssystem ebenfalls für die Verwendung von HT-Technologie ausgelegt sein.

Exchange 2000 Server und Exchange Server 2003 können auf einem Computer nur acht Prozessoren effektiv nutzen. Insbesondere der Microsoft Exchange-Informationsspeicherdienst ist für maximal acht Prozessoren optimiert.

Auf Computern mit mehr als acht Prozessoren wird empfohlen, dass Sie den Computer anhand von Hardwarepartitionierung in mehrere Computer mit acht Prozessoren oder in mehrere Computer mit vier Prozessoren partitionieren. Alternativ dazu können Sie die Prozessoraffinität für den Microsoft Exchange-Informationsspeicherprozess (Store.exe) auf nur acht Prozessoren konfigurieren.

Sobald der Microsoft Exchange-Informationsspeicherprozess über die Prozessoraffinität oder über Hardwarepartitionierung auf acht Prozessoren beschränkt wurde, wird empfohlen, eine Aktualisierung auf den neusten erhältlichen Service Pack und die aktuellsten Exchange-Updaterollups durchführen. Dies ist besonders unter Exchange Server 2003 wichtig.

Früher hat sich die Leistung des Exchange-Servers geringfügig verbessert, wenn die Anzahl der Prozessoren in Back-End-Servern auf mehr als vier erhöht wurde. Bei mehr als acht Prozessoren wird die Leistung bestenfalls geringfügig verbessert, und in einigen Fällen kann sie sich sogar verschlechtern. Der Rückgang von Leistungszuwachs bei mehr Prozessoren hat sich mit den in neueren Computern verwendeten Prozessortypen verstärkt. Mit Exchange Server 2003 Service Pack 1 wurde die Skalierbarkeit bei zusätzlichen Prozessoren erheblich verbessert. Bei aktiviertem Hyper-Threading bieten Server mit acht Prozessoren jetzt eine 50-prozentige Leistungssteigerung gegenüber Servern mit vier Prozessoren. Nun können in vielen Szenarios Computer mit acht Prozessoren auch für Back-End-Server verwendet werden. Für Front-End-Server werden jedoch immer noch Server mit zwei Prozessoren empfohlen.

Wie bereits angeführt, kann diese Warnung bei Exchange Server-Computern, die für die Verwendung von Hyper-Threading-Technologie konfiguriert sind, einfach ignoriert werden.

So beheben Sie diese Warnung bei Systemen, die keine Hyper-Threading-Technologie verwenden

  1. Wenden Sie das aktuellste Service Pack und die neusten Updaterollups für Exchange an, die auf der Exchange Server 2003-Website für Downloads (http://go.microsoft.com/fwlink/?linkid=25097) verfügbar sind.

  2. Legen Sie die Prozessoraffinität für den Microsoft Exchange-Informationsspeicherdienst (Store.exe) auf acht Prozessoren fest, oder verwenden Sie Hardwarepartitionierung zum Erstellen eines Exchange-Servers mit acht Prozessoren. Wenn Sie zur Durchführung dieses Vorgangs detaillierte Fragen haben, wenden Sie sich an den Hersteller Ihrer Hardware.

Weitere Informationen zur Skalierbarkeit von ExchangeServer-Ressourcen finden Sie im Microsoft Knowledge Base-Artikel 827281 „CPU and Memory Scalability for Exchange 2000 and Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827281).

Weitere Informationen finden Sie auch im Microsoft Knowledge Base-Artikel 271088, „XGEN: Optimizing Windows 2000 Active Directory Servers with Six or Eight Processors to Run with Exchange 2000" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=271088.

Weitere Informationen zur Hyper-Threading-Technologie finden Sie auf der Intel-Website (http://www.intel.com/info/hyperthreading).

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.


Dieser Exchange-Server verfügt über mehr als 4 GB Arbeitsspeicher.
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2006-06-20

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_ComputerSystem ab, um den Wert des Schlüssels TotalPhysicalMemory für den Exchange Server-Computer zu ermitteln.

Wenn Exchange Server Analyzer feststellt, dass der Wert für TotalPhysicalMemory auf einen Wert größer als 4294967296 aber kleiner als 6442450944 festgelegt ist, wird eine Warnung angezeigt.

Wenn Exchange Server Analyzer feststellt, dass der Wert für TotalPhysicalMemory größer als 6442450944 ist, wird ein Fehler angezeigt.

Ein Wert von mehr als 4294967296 für TotalPhysicalMemory bedeutet, dass auf dem Computer, auf dem Exchange Server ausgeführt wird, mehr als 4 Gigabyte (GB) Speicher installiert sind, und ein Wert von mehr als 6442450944 für TotalPhysicalMemory bedeutet, dass auf dem Computer, auf dem Exchange Server ausgeführt wird, mehr als 6 Gigabyte (GB) Speicher installiert sind. Auf Computern mit 4 GB physischem Arbeitsspeicher verwendet Exchange Server nicht mehr als 3 GB. Wenn der Computer ausschließlich für die Ausführung von Exchange Server vorgesehen ist, entsteht daher bei Installation von mehr als 4 GB Arbeitsspeicher kein Vorteil.

Noch wichtiger ist: Je mehr physischer RAM vorhanden ist, desto mehr Kernel-Adresseinträge des Betriebssystems werden benötigt, um die Zuordnung „virtuell-physisch" vorzunehmen. Da hierdurch sowohl die freien Seitentabelleneinträge (PTE) als auch der für das System verfügbare ausgelagerte Poolspeicher reduziert wird, kann Instabilität verursacht werden.

So hat beispielsweise ein Computer mit 8 GB physischem RAM-Speicher eine um 3.000 niedrigere Anzahl von freien Seitentabelleneinträgen (PTE) und eine um 30 MB geringere Größe des ausgelagerten Pools als ein Computer mit nur 4 GB physischem RAM-Speicher.

Es wird empfohlen, eine der folgenden beiden Lösungen zu verwenden:

  • Verringern des Arbeitsspeichers im System auf 4 GB

  • Festlegen des Parameters BurnMemory in der Datei Boot.ini zum Verringern des physischen Speichers auf 4 GB, wie später in diesem Artikel beschrieben.

Wenn Sie zudem mehrere Anwendungen ausführen, die zusätzlichen Arbeitsspeicher erfordern, können Sie einen Windows-Hotfix verwenden, mit dem Speicherfehler bei Exchange-Informationen verhindert werden, die bei mehr als 4 GB verfügbarem RAM auftreten könnten. Die empfohlene Vorgehensweise besteht jedoch in der ausschließlichen Verwendung des betreffenden Computers für die Ausführung von Exchange Server. Weitere Informationen zu dem Hotfix finden Sie im Microsoft Knowledge Base-Artikel 834628, "Daten sind beschädigt, wenn PAE auf einem Windows Server 2003-Computer aktiviert ist" (http://go.microsoft.com/fwlink/?linkid=3052).

So beheben Sie diese Warnmeldung

  1. Navigieren Sie in Windows Explorer zur Systempartition.

  2. Wenn die Datei Boot.ini nicht angezeigt wird, kann dies daran liegen, dass in den Ordneroptionen die Option Geschützte Systemdateien ausblenden festgelegt ist. Wenn dies der Fall ist, klicken Sie in Windows Explorer auf Extras und Ordneroptionen, und klicken Sie dann auf die Registerkarte Ansicht. Deaktivieren Sie das Kontrollkästchen Geschützte Systemdateien ausblenden (empfohlen). Klicken Sie im angezeigten Warnungsfeld auf Ja.

  3. Wenn die Datei Boot.ini in Windows Explorer angezeigt wird, klicken Sie mit der rechten Maustaste auf die Datei, klicken Sie auf Öffnen mit und wählen dann Editor aus, um die Datei zu öffnen.

  4. Fügen Sie im Abschnitt [Operating Systems] der Startzeile den folgenden Schalter hinzu: /BURNMEMORY=<Wert in MB>

    Beispiel:

    Sind mehr als 6 GB physischer Arbeitsspeicher installiert, verwenden Sie /BURNMEMORY=2048 zum Verringern des verfügbaren Arbeitsspeichers auf 4 GB. Sind 8 GB physischer Arbeitsspeicher installiert, verwenden Sie /BURNMEMORY=4096

  5. Speichern Sie die Änderungen, und schließen Sie Editor.

  6. Starten Sie den Computer mit Exchange Server neu, damit die Änderung wirksam wird.

Weitere Informationen zu den Parametern, die in der Datei boot.ini verwendet werden können, finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 833721: "Verfügbare Befehlszeilenoptionen für die Boot.ini-Dateien von Windows XP und Windows Server 2003" (http://support.microsoft.com/kb/833721/de)

  • 102873: "Namenskonventionen und Verwendung für BOOT.INI und ARC-Pfade" (http://support.microsoft.com/kb/102873/de)


Dieses logische Laufwerk verfügt über weniger als 3 GB freien Speicherplatz.
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2007-03-14

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_LogicalDisk ab, um den Wert für den Schlüssel FreeSpace für die Datenträger zu bestimmen, deren Schlüssel Win32_LogicalDisk DriveType auf den Wert 3 festgelegt ist (dies gibt einen lokalen Datenträger an). Wenn der Wert des Schlüssels FreeSpace für einen lokalen Datenträger auf einem Exchange Server-Computer kleiner als 3 GB ist, wird eine Warnung angezeigt. Es wird empfohlen, auf allen Datenträgern auf Exchange Server-Computern, auf denen sich Postfächer befinden, ständig mindestens 50 % der Speicherkapazität frei zu halten.

Ausreichende Speicherkapazität ist ein wesentlicher Faktor. Wenn der Speicherplatz eines Datenbankdatenträgers erschöpft ist, wird die Datenbank offline geschaltet. Wenn der Speicherplatz eines Transaktionsprotokolldatenträgers erschöpft ist, bewirkt dies, dass alle Datenbanken in dieser Speichergruppe offline geschaltet werden. Es ist häufig schwierig, schnell zusätzlichen Speicherplatz bereitzustellen, und das Durchführen einer Offlinekomprimierung zum Freigeben von Speicherplatz kann langwierig sein . In den meisten Fällen führt eine Erschöpfung des Speicherplatzes zu einer Unterbrechung der Verfügbarkeit mindestens einer Datenbank für einen Zeitraum, der normalerweise die meisten RTOs (Recovery Time Objectives, Ziele für die Wiederherstellungszeit) übersteigt.

So beheben Sie diese Warnmeldung

  1. Löschen Sie unnötige Dateien vom Datenträger, um Speicherplatz auf dem Datenträger freizugeben.

  2. Wenn der Datenträger, auf dem weniger als 50 % freier Speicherplatz verfügbar ist, Daten enthält, die sicher auf einen anderen Datenträger verschoben werden können (beispielsweise Postfächer oder die Windows-Auslagerungsdatei), führen Sie die zum Verschieben der Daten notwendigen Schritte aus.

  3. Fügen Sie Speicherkapazität für den Datenträger auf dem Exchange Server-Computer hinzu.

Weitere Informationen zum Verschieben von Postfächern mit Exchange Server 2003 finden Sie im Microsoft Knowledge Base-Artikel 821829, "Verschieben von Postfächern in Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

Weitere Informationen zum Verschieben von Postfächern in Exchange 2000 Server und Exchange Server 5.5 finden Sie im Knowledge Base-Artikel 328810 „Moving mailboxes between servers" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810.

Weitere Informationen zum Festlegen von Postfachbegrenzungen mit Systemrichtlinie unter Exchange Server 2003 finden Sie im Microsoft Knowledge Base-Artikel 822938 „HOW TO: Use System Policies to Configure Mailbox Storage Limits in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=822938.

Weitere Informationen zum Festlegen von Postfachbegrenzungen mit Systemrichtlinie unter Exchange 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 319130 „HOW TO: Use System Policies to Configure Mailbox Storage Limits in Exchange Server 2000" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=822938.

Weitere Informationen:


Dieser Bereitstellungspunkt verfügt über weniger als 3 GB freien Speicherplatz.
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer sendet eine Abfrage an die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Volume, um den Wert des Schlüssels FreeSpace für die Volumebereitstellungspunkte zu ermitteln, die der Exchange Server-Computer verwendet. Ist der Wert von FreeSpace, geteilt durch 1.000.000.000 und auf die nächste ganze Zahl aufgerundet, kleiner als 4, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass weniger als 3 GB Speicherplatz für einen Volumebereitstellungspunkt verfügbar sind. In Exchange Server 2003 werden Volumebereitstellungspunkte (auch als Abzweigungspunkte des NTFS-Dateisystems bezeichnet) als Speicherort zur Speicherung von Daten in einer Clusterkonfiguration unterstützt, wenn Exchange Server 2003 auf einem Computer installiert wird, auf dem Microsoft Windows Server™ 2003 Enterprise Edition oder Windows Server 2003 Datacenter Edition ausgeführt wird. Mit der NTFS-Volumebereitstellungspunkt-Funktion können Sie die Laufwerkbuchstabenbegrenzung von 26 Buchstaben umgehen. Wenn Sie Volumebereitstellungspunkte verwenden, können Sie eine Zielpartition in einen Ordner oder einen anderen physischen Datenträger übertragen, oder sie für diese bereitstellen. Volumebereitstellungspunkte sind für Programme wie Exchange Server 2003 erkennbar.

Bereitstellungspunkte werden in den folgenden Szenarios nicht unterstützt:

  • Wenn sie als Speicherort für Exchange Server 2003-Binärdateien verwendet werden.

  • Wenn sie zusammen mit Exchange-Clustern verwendet werden, in denen Microsoft Exchange 2000 Server oder eine frühere Version ausgeführt wird.

  • Wenn sie zusammen mit Windows-Clustern verwendet werden, in denen Microsoft Windows 2000 Server oder eine frühere Version ausgeführt wird.

Unabhängig davon, ob das von Exchange Server verwendete Volume ein physischer Datenträger, eine logisches Volume oder ein Volumebereitstellungspunkt ist, erfordern die optimalen Methoden für Exchange Server-Implementierungen mindestens 50 Prozent freien Speicherplatz, der auf allen Laufwerken zur Verfügung stehen muss. Als Faustregel empfiehlt Microsoft für die Wartung von Exchange mindestens 25 bis 30 Prozent freien Speicherplatz auf dem Datenträger verfügbar zu haben, z. B. für die Aufgaben, die mit den Datenbankdienstprogrammen Eseutil und Isinteg ausgeführt werden. Zusätzlich empfiehlt Microsoft für einige Wartungsoperationen, z. B. die Offline-Defragmentierung, mindestens einen freien Speicherplatz von der Größe des zu defragmentierenden Bereiches zur Verfügung zu haben. Wenn Sie beispielsweise eine Datenbank mit einer Größe von 1 GB defragmentieren, sollte Ihnen mindestens 1 GB freier Speicherplatz zur Verfügung stehen.

Eine große Menge an freiem Speicherplatz zur Verfügung zu haben, wirkt sich auch positiv im Hinblick auf Sicherheit und Verfügbarkeit aus. Ein DOS-Angriff (denial-of-service), eine Nachrichtenschleife oder ein Virenausbruch, der sich verbreitet, können aufgrund erhöhten Nachrichtendatenverkehrs, von Transaktionsprotokollierungsaktivitäten usw. zu einem exzessiven Verbrauch von Speicherplatz führen.

So beheben Sie diese Warnmeldung

  1. Prüfen Sie die Bereiche des Datenträgers, um Speicherplatz freizugeben, und erhöhen Sie den verfügbaren Speicherplatz.

  2. Wenn nur sehr wenig Speicherplatz zur Verfügung steht, sollten Sie Daten auf einen anderen Exchange Server-Computer oder auf einen virtuellen Exchange Server verschieben, bei dem der Speicherplatz nicht eingeschränkt ist. Wenn Sie dies nicht bereits getan haben, können Sie auch Postfachbegrenzungen festlegen, die auch nützlich bei der Verwaltung der Datenträgerverwendung sein können.

Weitere Informationen zum Verwenden von Volumebereitstellungspunkten in einem Exchange Server 2003-Cluster finden Sie im Microsoft Knowledge Base-Artikel 318458 „Volume Mount Point Support for an Exchange Server 2003 Cluster on a Windows Server 2003-based System" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=318458.

Weitere Informationen zum Verwenden von Volumebereitstellungspunkten in einem Windows Server 2003-Cluster finden Sie im Microsoft Knowledge Base-Artikel 280297 „How to configure Volume Mount Points on a clustered server" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=280297.


Diese Netzwerkkarte ist DHCP-fähig.
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_NetworkAdapterConfiguration ab, um zu bestimmen, ob ein Wert für die DHCPEnabled-Eigenschaft festgelegt ist. Wenn der Wert für diese Eigenschaft auf einem Exchange-Server eins (1) ist, wird ein Fehler angezeigt.

Das Ausführen von Exchange über eine DHCP-fähige Netzwerkkarte ist eine unterstützte Konfiguration. Diese Konfiguration wird jedoch nicht empfohlen. Das Ausführen von Exchange auf DHCP-fähigen Computern ist keine optimale Methode, da Exchange die Übermittlung von Post anhalten kann oder anderweitig fehlschlagen kann, wenn der DHCP-Dienst einen Fehler hervorruft oder unterbrochen wird.

Es wird empfohlen, alle Computer, auf denen Exchange ausgeführt wird, so zu konfigurieren, dass sie statische IP-Adressen haben.

Weitere Informationen zum Entwerfen von Windows-TCP/IP-Netzwerken finden Sie auf der Microsoft TechNet-Website zu Networking unter http://go.microsoft.com/fwlink/?LinkId=33819.


Die primäre WINS-Serveradresse ist leer.
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_NetworkAdapterConfiguration ab, um zu bestimmen, ob ein Wert für den WINSPrimaryServer-Schlüssel festgelegt ist. Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert für diesen Schlüssel auf einem Exchange-Server leer ist, wird eine Warnung angezeigt.

Exchange Server 2003 und Exchange 2000 Server verfügen über mehrere NetBIOS-Abhängigkeiten. Außerdem benötigen Clients, auf denen ältere Versionen von Microsoft Outlook® als Microsoft Office Outlook 2003 ausgeführt werden, auch eine NetBIOS-Namensauflösung. Die folgenden Exchange-Funktionen sind z. B. von der NetBIOS-Namensauflösung abhängig:

  • Die Setupprogramme von Exchange Server 2003 und Exchange 2000 Server, insbesondere auf Servern, die Teil eines Clusters sind.

  • Der Exchange Mailbox Merge-Assistent (ExMerge) auf Exchange Server 2003- oder Exchange 2000 Server-Computern.

  • Das Ändern des Kennworts für ein Exchange Server 2003- oder Exchange 2000 Server-Postfach über Outlook Web Access.

  • Der Exchange-System-Manager auf einem Exchange Server 2003- oder Exchange 2000 Server-Computer.

Je nach Netzwerktopologie der Organisation können Sie diese Warnung auch ignorieren. In Netzwerken, die aus einem einzigen Subnetz bestehen, können NetBIOS-Broadcastnachrichten normalerweise mit den Anforderungen an die NetBIOS-Namensauflösung einer Exchange-Bereitstellung umgehen.

In großen Organisationen funktioniert die NetBIOS-Namensauflösung über Broadcasts u. U. nicht ordnungsgemäß. Da NetBIOS-Broadcasts typischerweise keine Subnetze kreuzen, erfordern geroutete Netzwerke eine andere Methode für die NetBIOS-Namensauflösung. Als bevorzugte Methode hierfür wird WINS (Windows Internet Name Service) verwendet. WINS stellt eine verteilte Datenbank für das Registrieren und Abfragen dynamischer Zuordnungen von NetBIOS-Namen für die im Netzwerk verwendeten Computer und Gruppen bereit. WINS ordnet NetBIOS-Namen IP-Adressen zu und soll Probleme bei der NetBIOS-Namensauflösung in gerouteten Umgebungen lösen. WINS ist am besten für die NetBIOS-Namensauflösung in Netzwerken mit Routern geeignet, in denen NetBIOS über TCP/IP verwendet wird.

Der Betrieb und die Funktionen von Exchange Server 2003 und Exchange 2000 Server in großen Organisationen oder Organisationen mit mehreren Subnetzen ohne WINS wurden nicht vollständig getestet. Microsoft sucht Unternehmen, die Exchange in gerouteten oder segmentierten Netzwerken mit WINS für die NetBIOS-Namensauflösung ausführen. Das Ausführen von Exchange in einer gerouteten oder segmentierten Umgebung ohne WINS wird nicht unterstützt.

Es wird empfohlen, eine fehlertolerante WINS-Umgebung bereitzustellen, die zumindest zwei WINS-Server enthält. WINS-Server können entweder als primärer WINS-Server oder als sekundärer WINS-Server bei einem Client fungieren. Der Unterschied zwischen primären und sekundären WINS-Servern besteht nur darin, mit welcher Priorität Clients die Verbindung zu ihnen herstellen. Ein primärer WINS-Server ist der erste Server, zu dem ein Client die Verbindung herstellt, um die NetBIOS-Namensdienstservice-Vorgänge auszuführen. Ein Client stellt nur dann eine Verbindung mit einem sekundären WINS-Server her, wenn ein primärer WINS-Server die Abfrage nicht beantworten kann. Das ist z. B. der Fall, wenn der primäre WINS-Server zu dem Zeitpunkt, wenn die Abfrage vom Client erfolgt, nicht zur Verfügung steht, oder wenn ein Name für den Client nicht aufgelöst werden kann.

Wenn ein primärer WINS-Server die Abfrage nicht beantworten kann, richtet der Client die gleiche Abfrage an den sekundären WINS-Server. Wenn mehr als zwei WINS-Server für den Client konfiguriert sind, fragt der Client die zusätzlichen sekundären WINS-Server nacheinander ab oder einer der WINS-Server reagiert erfolgreich auf die Abfrage. Nachdem ein Client einen sekundären WINS-Server verwendet hat, versucht er in regelmäßigen Abständen, für künftige Namensdienstabfragen zu seinem primären WINS-Server zurückzukehren.

Es hat sich bewährt, zumindest einen sekundären WINS-Server auf Exchange Server-Computern in einem gerouteteten oder segmentierten Netzwerk zu konfigurieren.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie das Fenster Netzwerkverbindungen.

  2. Klicken Sie mit der rechten Maustaste auf die zu konfigurierende Netzwerkverbindung, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Allgemein (für eine LAN-Verbindung) bzw. auf der Registerkarte Netzwerk (für alle anderen Verbindungen) auf Internetprotokoll (TCP/IP) und dann auf Eigenschaften.

  4. Klicken Sie auf Erweitert, klicken Sie auf die Registerkarte WINS und dann auf Hinzufügen.

  5. Geben Sie in TCP/IP-WINS-Server die IP-Adresse des WINS-Servers ein, und klicken Sie dann auf Hinzufügen.

  6. Wiederholen Sie die Schritte 4 und 5 für jede weitere WINS-Server-IP-Adresse, die Sie hinzufügen möchten, und klicken Sie dann auf OK. Sie können die Präferenzreihenfolge für WINS-Server mithilfe der Pfeiltasten ändern.

  7. Vergewissern Sie sich, dass NetBIOS über TCP/IP aktivieren aktiviert ist.

  8. Klicken Sie zum Speichern der Änderungen auf OK.

Weitere Informationen zu den Anforderungen an die NetBIOS-Namensauflösung für Exchange finden Sie im Knowledge Base-Artikel 837391, „Exchange Server 2003 and Exchange 2000 Server require NetBIOS name resolution for full functionality", unter http://support.microsoft.com/?kbid=837391.


Virtueller Server wurde erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Hardware >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_ComputerSystem ab, um zu ermitteln, ob der Wert für den Schlüssel Model auf Virtual Machine festgelegt ist.

Exchange Server Analyzer überprüft auch den folgenden Registrierungswert:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel Model die Zeichenfolge Virtual Machine enthält und der oben genannte Registrierungszweig vorhanden ist, wird ein Fehler angezeigt.

Der Wert Virtual Machine für den Schlüssel Model zeigt an, dass der Exchange Server-Computer als virtueller Gastcomputer unter Virtual Server 2005 oder Microsoft Virtual PC 2004 ausgeführt wird. Da der oben genannte Registrierungszweig nur von Virtual Server 2005 erstellt wird, bedeutet sein Vorhandensein, dass der Exchange Server-Computer als virtueller Gastcomputer unter Virtual Server 2005 ausgeführt wird.

Das Ausführen einer beliebigen Version von Microsoft Exchange Server auf einem virtuellen Computer oder einem Emulator wird von Microsoft nicht unterstützt. Dies gilt für Exchange Server unter Microsoft Virtual Server 2005, Microsoft Virtual PC 2004 und sämtliche Anwendungen für virtuelle Computer von Drittanbietern. Microsoft Exchange-Server wurden so entwickelt und getestet, dass sie nur auf realer Hardware, insbesondere auf den Hardwareplattformen ausgeführt werden können, die im Windows-Serverkatalog unter http://go.microsoft.com/fwlink/?linkid=17219 aufgeführt sind.

So beheben Sie diesen Fehler

  1. Verschieben Sie die Postfächer aus dem Exchange Server, der unter Virtual Server 2005 ausgeführt wird, auf einen nicht virtuellen Exchange Server-Computer.

  2. Lagern Sie beliebige Öffentliche Ordner aus, und übertragen Sie beliebige Rollen, die bei Bedarf von dem virtuellen Exchange-Server übernommen werden.

  3. Deinstallieren Sie Exchange von dem virtuellen Computer, um es außer Betrieb zu setzen und aus der Exchange-Infrastruktur und dem Active Directory ®-Verzeichnisdienst zu entfernen.

Weitere Informationen zum Verschieben von Postfächern finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 822892, „Verbesserungen von "Postfach verschieben" in Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975, „XADM: Differences Between Move Mailbox Methods" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

Weitere Informationen zu Microsoft Virtual Server 2005 finden Sie auf der Microsoft Virtual Server 2005-Website unter http://go.microsoft.com/fwlink/?linkid=34938.

Weitere Informationen zu Microsoft Virtual PC 2004 finden Sie auf der Microsoft Virtual PC 2004-Website unter http://go.microsoft.com/fwlink/?linkid=34663.


Netzwerk
Microsoft Exchange Server Analyzer-Tools - Artikel >

Letztes Änderungsdatum des Themas: 2005-11-18

In den Artikeln in diesem Abschnitt erhalten Sie ausführliche Informationen darüber, welche Bestandteile eines Netzwerkes Microsoft® Exchange Server Analyzer auswertet. Darüber hinaus werden in diesen Artikeln Aktionen beschrieben, die Sie durchführen können, um Fehler, Warnungen und vom Standard abweichende Konfigurationen im Zusammenhang mit dem Netzwerk beheben zu können, die von Exchange Server Analyzer gefunden wurden.


Der DNS-Eintrag 'Host' scheint zu fehlen
Microsoft Exchange Server Analyzer-Tools - Artikel > Netzwerk >

Letztes Änderungsdatum des Themas: 2006-04-13

Microsoft® Exchange Server Analyzer führt einen DNS-Lookup (Domain Name System) auf dem DNS-Server aus, um den Eintrag 'Host (A)' für den Computer mit Exchange Server abzurufen. Wenn der DNS-Lookupvorgang keine IP-Adresse zurückgibt, wird eine Warnung angezeigt, dass der Eintrag 'Host (A)' zu fehlen scheint.

Der DNS-Lookup des Eintrags 'Host (A)' des Computers mit Exchange Server 2003 kann aus folgenden Gründen fehlschlagen:

  • Möglicherweise ist der DNS-Server wegen eines Netzwerkfehlers oder aus anderen Gründen nicht verfügbar oder antwortet nicht.

  • Der Eintrag 'Host (A)' für Exchange Server 2003 könnte auf dem DNS-Server fehlen, weil der Eintrag nicht verfügbar oder fehlerhaft ist, oder weil der DNS-Server möglicherweise so konfiguriert ist, dass keine dynamischen Aktualisierungen von Hosteinträgen zulässig sind.

Wenn der DNS-Server nicht verfügbar ist, kann es zu Verzögerungen beim Nachrichtenrouting und anderen Dienstfehlern kommen.

Hinweis:
Exchange Server 2003 ist von der Hostnamensauflösung für lokale und externe SMTP-basierte Messagingsysteme im Netzwerk abhängig. Die Hostnamensauflösung basiert primär auf DNS, wobei es sich um einen kritischen Netzwerkdienst handelt. Der Ausfall eines DNS-Servers kann dazu führen, dass Benutzer ihr Messagingsystem nicht mehr finden können. Active Directory und Exchange Server 2003-Organisationen sind ohne DNS nicht funktionsfähig. Messagingclients fragen DNS ab, um interne Ressourcen wie Domänencontroller und Postfachserver aufzufinden. Auch ist Exchange Server 2003 von DNS abhängig, um IP-Adressen von Domänencontrollern für Verzeichnissuchen und von externen SMTP-Hosts (Simple Mail Transfer Protocol) abzurufen, wenn Exchange Server 2003 Nachrichten über das Internet versendet.

Zur Behebung dieses Problems stellen Sie sicher, dass der DNS-Server ausgeführt wird und dass der Eintrag 'Host (A)' registriert ist.

So stellen Sie sicher, dass der DNS-Server online ist und dass der Hosteintrag vorhanden ist

  1. Überprüfen Sie, ob der DNS-Server ausgeführt wird, indem Sie die folgenden Schritte ausführen:

    • Untersuchen Sie den Status des DNS-Servers mithilfe des DNS-Administrationsprogramms auf dem DNS-Server.

    • Starten Sie den DNS-Server neu. Weitere Informationen finden Sie unter „Start, stop, pause, or restart a DNS server" (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Untersuchen Sie die Reaktionsbereitschaft des DNS-Servers mithilfe von nslookup. Weitere Informationen finden Sie unter „Verify DNS server responsiveness using the nslookup command" (http://go.microsoft.com/fwlink/?LinkId=63000).

  2. Verwenden Sie nslookup, um zu überprüfen, ob der Eintrag 'Host (A)' auf dem DNS-Server vorhanden ist. Weitere Informationen finden Sie unter „To verify A resource records exist in DNS" (http://go.microsoft.com/fwlink/?LinkId=63001).

  3. Wenn der Eintrag 'Host (A)' nicht vorhanden ist, fügen Sie den A-Ressourceneintrag manuell hinzu oder ändern ihn bzw. konfigurieren den DNS-Server so, dass dynamische Eintragsaktualisierungen zulässig sind.

    • Fügen Sie manuell einen A-Ressourceneintrag hinzu. Weitere Informationen finden Sie unter „Add a resource record to a DNS zone" (http://go.microsoft.com/fwlink/?LinkId=63002).

    • Ändern Sie manuell einen A-Ressourceneintrag. Weitere Informationen finden Sie unter „Modify an existing resource record" (http://go.microsoft.com/fwlink/?LinkId=63014).

    • Aktivieren Sie auf dem DNS-Server die dynamische Aktualisierung von Hosteinträgen. Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 816592, „Konfigurieren der dynamischen DNS-Updates in Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592).
  • Weitere Informationen zur Verwendung von DNS durch Exchange Server 2003 zum Auflösen externer IP-Adressen finden Sie unter „Transport Dependencies for Exchange Server 2003" im Transport- und Routing-Handbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Informationen zur DNS-Namensauflösung finden Sie im Microsoft Knowledge Base-Artikel 322856, „Konfigurieren von DNS für eine Verwendung mit Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • Informationen zur Behandlung von DNS-Problemen finden Sie unter „Troubleshooting DNS" (http://go.microsoft.com/fwlink/?LinkId=63003).

Informationen zur Exchange Server 2003-Systemüberwachung finden Sie unter „System Monitoring with Exchange Server 2003 Management Pack" im Exchange Server 2003 Management Pack-Handbuch für MOM 2000 SP1 (http://go.microsoft.com/fwlink/?LinkId=47573).

  • Informationen zu 'Host (A)'-Ressourceneinträgen finden Sie unter „Managing resource records" (http://go.microsoft.com/fwlink/?LinkId=63004).


Die DNS-Antworten unterscheiden sich für UDP und TCP
Microsoft Exchange Server Analyzer-Tools - Artikel > Netzwerk >

Letztes Änderungsdatum des Themas: 2007-03-16

Das Tool Microsoft Exchange Analyzer fragt die Microsoft WMI-Klasse (Windows Management Instrumentation, Windows-Verwaltungsinstrumentation) Win32_NetworkAdapterConfiguration ab, um das Attribut DNSServerSearchOrder abzurufen. Dieses Attribut ist ein Array von Server-IP-Adressen, die zum Abfragen von DNS-Servern (Domain Name System) verwendet werden.

Nachdem die Adresse des primären DNS-Servers abgerufen wurde, versucht Exchange Analyzer, die konfigurierten DNS-Server für jeden Active Directory-Verzeichnisdienstserver abzufragen. Diese Verbindung wird mithilfe eines benutzerdefinierten Objektprozessors hergestellt, der eine TCP- (Transmission Control Protocol) und eine UDP-Namensauflösung (User Datagram Protocol) anfordert.

Wenn die TCP- und UDP-Namensauflösungsanforderungen erfolgreich sind, vergleicht Exchange Analyzer die zurückgegebenen Antworten der erfolgreichen Anforderungen. Wenn die zurückgegebenen Antworten der TCP- und UDP-Anforderungen nicht übereinstimmen, zeigt Exchange Analyzer eine Warnung an.

Diese Warnung zeigt an, dass möglicherweise Konfigurationsprobleme des DNS-Servers vorliegen, die sich negativ auf die Leistung der Nachrichtenübermittlung auswirken.

SMTP (Simple Mail Transfer Protocol) ist das systemeigene E-Mail-Protokoll von Exchange Server für die Übermittlung und den Transport von E-Mail. Dies bedeutet, dass Clients SMTP zum Senden von Nachrichten und Server mit Exchange SMTP für die Zustellung von Nachrichten und Nachrichtendaten verwenden.

Damit Exchange Server eine ausgehende Internetnachricht über den SMTP-Dienst zustellen kann, wird DNS mithilfe der folgenden Methode bereitgestellt:

  1. Ein interner Benutzer sendet eine Nachricht an einen Empfänger in einer Remotedomäne.

  2. Der virtuelle SMTP-Server auf dem Servercomputer mit Exchange des Absenders verwendet interne Transportfunktionen, um die Empfängeradresse vom globalen Katalogserver abzufragen und so zu bestimmen, ob der Empfänger lokal oder remote ist. Wenn die Empfängeradresse für die Nachricht keine Empfängerrichtlinie ist, ist sie nicht in Active Directory gespeichert. Daher legt Exchange fest, dass das Ziel der Nachricht eine Remotedomäne ist.

  3. Wenn erforderlich, stellt der Servercomputer mit Exchange die Nachricht dem entsprechenden virtuellen SMTP-Server zu.

  4. Der virtuelle SMTP-Server verwendet seine IIS-Metabaseinformationen, um die Methode zum Zustellen einer Nachricht an eine Remotedomäne zu bestimmen.

  5. Der virtuelle SMTP-Server auf dem Servercomputer mit Exchange führt anschließend eine von zwei Aktionen aus:

    • Er verwendet DNS, um die IP-Adresse für die Zieldomäne zu ermitteln und versucht dann, die Nachricht zuzustellen.

    • Er leitet die Nachricht an einen Smarthost weiter, der die Verantwortung für die DNS-Auflösung und Zustellung der Nachricht übernimmt.

Weitere Informationen zum Beheben dieser Warnung finden Sie in den Anleitungen im Microsoft Knowledge Base-Artikel 820284, "Nachrichten werden bestimmten Domänen nicht zugestellt, wenn das Serverbetriebssystem Windows Server 2003 ist" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=820284).

Weitere Informationen zu DNS und Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln und im WebCast:

  • 322856, "Konfigurieren von DNS für die Verwendung mit Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237, "XCON: Windows 2000- und Exchange 2000-SMTP verwendet TCP DNS-Abfragen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759, "Support WebCast: Microsoft Exchange 2000 Server: DNS Troubleshooting in Transports" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


DNS-Server führt Virtual Server 2005 aus, wobei Exchange Server als Gast installiert ist.
Microsoft Exchange Server Analyzer-Tools - Artikel > Netzwerk >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_ComputerSystem ab, um zu ermitteln, ob der Wert für den Schlüssel Model auf Virtual Machine festgelegt ist.

Exchange Server Analyzer überprüft auch den folgenden Registrierungswert:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Zusätzlich fragt Exchange Server Analyzer die WMI-Klasse Win32_Services ab, um zu ermitteln, ob der DNS-Dienst (Domain Name System, DNS) auf dem physischen Computer aktiv ist, auf dem auch Microsoft Virtual Server 2005 ausgeführt wird.

Wenn Exchange Server Analyzer erkennt, dass der Schlüssel Model die Zeichenfolge Virtual Machine enthält, dass der oben stehende Registrierungszweig vorhanden ist und dass DNS ausgeführt wird, wird eine Fehlermeldung angezeigt.

Der Wert Virtual Machine für den Schlüssel Model zeigt an, dass der Exchange Server-Computer als virtueller Gastcomputer unter Virtual Server 2005 oder Microsoft Virtual PC 2004 ausgeführt wird. Da der oben genannte Registrierungszweig jedoch nur von Virtual Server 2005 erstellt wird, bedeutet sein Vorhandensein, dass der Exchange Server-Computer als virtueller Gastcomputer unter Virtual Server 2005 ausgeführt wird.

Das Ausführen einer beliebigen Version von Microsoft Exchange Server auf einem virtuellen Computer oder einem Emulator wird von Microsoft nicht unterstützt. Dies gilt für Exchange Server unter Virtual Server 2005, Microsoft Virtual PC 2004 und sämtliche Anwendungen für virtuelle Computer von Drittanbietern. Microsoft Exchange-Server wurden so entwickelt und getestet, dass sie nur auf realer Hardware, insbesondere auf den Hardwareplattformen ausgeführt werden können, die im Windows-Serverkatalog unter http://go.microsoft.com/fwlink/?linkid=17219 aufgeführt sind.

Außerdem stellt das Ausführen von Exchange als Gast eines Virtual Server 2005 auf einem Computer, auf dem Domänennamensdienste ausgeführt werden, keine empfohlene Vorgehensweise dar, da dies keine ausreichende Redundanz zwischen Diensten ermöglicht.

So beheben Sie diesen Fehler

  1. Verschieben Sie die Postfächer aus dem Exchange Server, der unter Virtual Server 2005 ausgeführt wird, auf einen nicht virtuellen Exchange Server-Computer.

  2. Lagern Sie beliebige Öffentliche Ordner aus, und übertragen Sie beliebige Rollen, die bei Bedarf von dem virtuellen Exchange-Server übernommen werden.

  3. Deinstallieren Sie Exchange von dem virtuellen Rechner, um es außer Betrieb zu setzen und aus Ihrer Exchange-Infrastruktur und aus dem Active Directory ®-Verzeichnisdienst zu entfernen.

Weitere Informationen zum Verschieben von Postfächern finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 822892, „Verbesserungen von "Postfach verschieben" in Exchange 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975, „XADM: Differences Between Move Mailbox Methods" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

Weitere Informationen zu Unterstützung für in virtuellen Umgebungen ausgeführte Exchange Server-Computer finden Sie im Knowledge Base-Artikel 320220 „Support Boundaries for Exchange Server on a Virtual Machine or an Emulation Machine" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).

Weitere Informationen zu Microsoft Virtual Server 2005 finden Sie auf der Microsoft Virtual Server 2005-Website unter http://go.microsoft.com/fwlink/?linkid=34938.

Weitere Informationen zu Microsoft Virtual PC 2004 finden Sie auf der Microsoft Virtual PC 2004-Website unter http://go.microsoft.com/fwlink/?linkid=34663.


Die Antworten des externen DNS-Servers unterscheiden sich für UDP und TCP
Microsoft Exchange Server Analyzer-Tools - Artikel > Netzwerk >

Letztes Änderungsdatum des Themas: 2007-03-16

Microsoft Exchange Analyzer fragt den Active Directory-Verzeichnisdienst ab, um den Wert des Attributs msExchSmtpExternalDNSServers in der Klasse protocolCfgSMTPServer für jedes Exchange Server-Objekt zu bestimmen. Wenn der Wert des Attributs msExchSmtpExternalDNSServers festgelegt wurde, gibt er die Adresse des externen DS-Servers (Domain Name System) an, den die Instanz des virtuellen SMTP-Servers (Simple Mail Transfer Protocol) verwendet.

Nachdem die Adresse des primären externen DNS-Servers (Domain Name System) abgerufen wurde, versucht Exchange Analyzer, die konfigurierten DNS-Server für jeden Active Directory-Verzeichnisdienstserver abzufragen. Diese Verbindung wird mithilfe eines benutzerdefinierten Objektprozessors hergestellt, der eine TCP- (Transmission Control Protocol) und eine UDP-Namensauflösung (User Datagram Protocol) anfordert.

Wenn die TCP- und UDP-Namensauflösungsanforderungen erfolgreich sind, vergleicht Exchange Analyzer die zurückgegebenen Antworten der erfolgreichen Anforderungen. Wenn die zurückgegebenen Antworten der TCP- und UDP-Anforderungen nicht übereinstimmen, zeigt Exchange Analyzer eine Warnung an.

Diese Warnung zeigt an, dass möglicherweise Konfigurationsprobleme des externen DNS-Servers vorliegen, die sich negativ auf die Leistung der Nachrichtenübermittlung auswirken.

SMTP ist das systemeigene E-Mail-Protokoll von Exchange Server für die Übermittlung und den Transport von E-Mail. Dies bedeutet, dass Clients SMTP zum Senden von Nachrichten und Server mit Exchange SMTP für die Zustellung von Nachrichten und Nachrichtendaten verwenden.

Damit Exchange Server eine ausgehende Internetnachricht über den SMTP-Dienst zustellen kann, wird DNS mithilfe der folgenden Methode bereitgestellt:

  1. Ein interner Benutzer sendet eine Nachricht an einen Empfänger in einer Remotedomäne.

  2. Der virtuelle SMTP-Server auf dem Servercomputer mit Exchange des Absenders verwendet interne Transportfunktionen, um die Empfängeradresse vom globalen Katalogserver abzufragen und so zu bestimmen, ob der Empfänger lokal oder remote ist. Wenn die Empfängeradresse für die Nachricht keine Empfängerrichtlinie ist, ist sie nicht in Active Directory gespeichert. Daher legt Exchange fest, dass das Ziel der Nachricht eine Remotedomäne ist.

  3. Wenn erforderlich, stellt der Servercomputer mit Exchange die Nachricht dem entsprechenden virtuellen SMTP-Server zu.

  4. Der virtuelle SMTP-Server verwendet seine IIS-Metabaseinformationen, um die Methode zum Zustellen einer Nachricht an eine Remotedomäne zu bestimmen.

  5. Der virtuelle SMTP-Server auf dem Servercomputer mit Exchange führt anschließend eine von zwei Aktionen aus:

    • Er verwendet DNS, um die IP-Adresse für die Zieldomäne zu ermitteln und versucht dann, die Nachricht zuzustellen.

    • Er leitet die Nachricht an einen Smarthost weiter, der die Verantwortung für die DNS-Auflösung und Zustellung der Nachricht übernimmt.

Weitere Informationen zum Beheben dieser Warnung finden Sie im Microsoft Knowledge Base-Artikel 820284, "Nachrichten werden bestimmten Domänen nicht zugestellt, wenn das Serverbetriebssystem Windows Server 2003 ist" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=820284).

Weitere Informationen zu DNS und Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln und im WebCast:

  • 322856, "Konfigurieren von DNS für die Verwendung mit Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237, "XCON: Windows 2000- und Exchange 2000-SMTP verwendet TCP DNS-Abfragen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759, "Support WebCast: Microsoft Exchange 2000 Server: DNS Troubleshooting in Transports" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


Die Gesamtzahl von Netzwerkbytes pro Sekunde hat den Schwellenwert überschritten
Microsoft Exchange Server Analyzer-Tools - Artikel > Netzwerk >

Letztes Änderungsdatum des Themas: 2006-02-13

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Bytes Total/sec-Leistungsindikator des Network Interface-Leistungsobjekts.

Der Leistungsindikator Bytes Total/sec zeigt die Rate an, mit der der Netzwerkadapter Datenbytes verarbeitet. Dieser Indikator berücksichtigt zusätzlich zu den Protokollinformationen alle Anwendungs- und Dateidaten, z. B. die Kopfzeilen von Paketen. Der Leistungsindikator Bytes Total/sec ist die Summe aus den Leistungsindikatoren Network Interface\Bytes Received/sec und Network Interface/Bytes Sent/sec.

Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Für einen 100 MBit/s-Netzwerkadapter (Megabits pro Sekunde) sollte der Wert des Leistungsindikators Bytes Total/sec unter 7 MB/s (Megabytes pro Sekunde) liegen. Für einen 1000 MBit/s-Netzwerkadapter (Megabits pro Sekunde) sollte der Wert des Leistungsindikators Bytes Total/sec unter 70 MB/s (Megabytes pro Sekunde) liegen. Wenn Bytes Total/sec 7 % der Bandbreite des Netzwerks überschreitet, zeigt Exchange Server Analyzer einen Fehler an.

Dieser Fehler weist normalerweise darauf hin, dass der Server zeitweise nicht mehr reagiert, was zu einer Verlangsamung oder vollständigen Unterbrechung der Mailübermittlung führt. Zusätzlich kann auf Microsoft Outlook®-Clients, die eine Verbindung mit diesem Server herstellen, das Dialogfeld RPC cancel Request (RPC-Abbruchanforderung) angezeigt werden.

Im Folgenden finden Sie einige mögliche Ursachen für diesen Fehler:

  • Eine Netzwerkschnittstellenkarte (Network Interface Card, NIC) des Computers kann die von der Netzwerkinfrastruktur unterstützte maximale Bandbreite nicht unterstützen.

  • Die Auslastung des Servers ist zu hoch.

  • Viren oder Spam führen zu plötzlich erhöhten Netzwerkverwendungsmustern.

So beheben Sie diesen Fehler

  • Wenn eine NIC die maximale Bandbreite der Netzwerkinfrastruktur nicht unterstützt, aktualisieren Sie diese so, dass eine höhere Bandbreite unterstützt wird.

  • Verringern Sie die Serverlast. Dies können Sie erreichen, indem Sie Postfächer auf einen Server mit weniger Postfächern verschieben. Erforderlichenfalls fügen Sie Ihrer Umgebung einen zusätzlichen Exchange-Server hinzu.

  • Wenn Sie befürchten, dass die ungewöhnlich hohe Auslastung nicht von zu vielen Postfächern auf dem Server herrührt, versuchen Sie, die Quelle für die außergewöhnlich hohe Auslastung zu ermitteln, und beseitigen Sie diese dann.

  • Berücksichtigen Sie die in den folgenden Artikeln ausgeführten Best Practices:

    • Informationen zu Aspekten der Netzwerkbandbreite finden Sie im Abschnitt „Network Performance" des Themas „Understanding Exchange Performance" im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

    • Informationen zur Behandlung von Netzwerkproblemen finden Sie unter „Ruling Out Network-Bound Problems" im Handbuch Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Das Zusammenführung von Netzwerkschnittstellenkarten ist aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Netzwerk >

Letztes Änderungsdatum des Themas: 2006-10-16

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_NetworkAdapter nach allen an das TCP/IP-Protokoll gebundenen Netzwerkschnittstellenkarten ab.

Exchange Server Analyzer fragt anschließend den folgenden Registrierungszweig ab, um zu ermitteln, ob der Schlüssel TeamAdapters für die Adapter vorhanden ist:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\%NICDEVICEID%\

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel TeamAdapters für eine oder mehrere Netzwerkschnittstellenkarten auf dem analysierten Server existiert, zeigt Exchange Server Analyzer eine Warnung an.

Diese Warnung weist darauf hin, dass die Zusammenführung von Netzwerkschnittstellenkarten (Teaming) auf dem analysierten Exchange-Server aktiviert ist. Obwohl die Zusammenführung von Netzwerkschnittstellenkarten generell kein Problem bei der Nachrichtenübermittlung darstellt, empfiehlt es sich sicherzustellen, dass die Zusammenführung ordnungsgemäß konfiguriert ist und die aktuellsten verfügbaren Treiber für die Netzwerkschnittstellenkarte verwendet werden.

So beheben Sie dieses Problem

  • Wenn auf dem Server, auf dem die Zusammenführung von Netzwerkschnittstellenkarten aktiviert ist, Probleme bei der Nachrichtenübermittlung auftreten, deaktivieren Sie die Zusammenführung vorübergehend, und prüfen Sie, ob die Probleme dadurch behoben sind.

  • Aktualisieren Sie die Treiber für die Netzwerkschnittstellenkarte auf die aktuellste Version des Netzwerkschnittstellenkarten-Herstellers.

  • Halten Sie sich bei der Konfiguration der Zusammenführung genau an die Empfehlungen des Netzwerkschnittstellenkarten-Herstellers.

Weitere Informationen zur Zusammenführung von Netzwerkschnittstellenkarten finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 278431, "Verwenden von Teamingadaptern mit Netzwerklastenausgleich kann zu Netzwerkproblemen führen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=278431).

  • 814607, "Microsoft-Unterstützung für Servercluster mit Systemkomponenten von Drittparteien" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=814607).


Ausgehende Netzwerkpakete haben den Schwellenwert überschritten
Microsoft Exchange Server Analyzer-Tools - Artikel > Netzwerk >

Letztes Änderungsdatum des Themas: 2006-02-13

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte abgefragt werden. Das Erfassungsmodul für Leistungsdaten erfasst Daten des Leistungsindikators Packet Outbound errors des Network Interface-Leistungsobjekts zur Analyse von Leistungsdaten.

Der Leistungsindikator Packet Outbound errors gibt die Anzahl ausgehender Pakete an, die aufgrund eines Fehlers nicht übermittelt werden konnten. Der Wert des Leistungsindikators Packet Outbound errors sollte null sein. Wenn Exchange Server Analyzer feststellt, dass der Wert des Leistungsindikators Packet Outbound errors größer als null ist, wird ein Fehler angezeigt.

Dieser Fehler weist normalerweise darauf hin, dass der Server zeitweise nicht mehr reagiert, was zu einer Verlangsamung oder vollständigen Unterbrechung der Mailübermittlung führt. Zusätzlich kann auf Microsoft Outlook®-Clients, die eine Verbindung mit diesem Server herstellen, das Dialogfeld RPC cancel Request (RPC-Abbruchanforderung) angezeigt werden.

Dieser Fehler wird höchstwahrscheinlich von einer fehlerhaften oder beschädigten Netzwerkschnittstellenkarte (Network Interface Card, NIC) verursacht.

Um diesen Fehler zu beheben, müssen Sie die Ursache des ausgehenden Paketfehlers ermitteln und dann beseitigen. Werden die ausgehenden Paketfehler von einer fehlerhaften NIC verursacht, tauschen Sie die Karte sofort aus.

Berücksichtigen Sie die in den folgenden Artikeln ausgeführten Best Practices:

  • Informationen zu Aspekten der Netzwerkbandbreite finden Sie im Abschnitt „Network Performance" des Themas „Understanding Exchange Performance" im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Informationen zur Behandlung von Netzwerkproblemen finden Sie unter „Ruling Out Network-Bound Problems" im Handbuch Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Die Länge der Netzwerkausgabewarteschlange hat den Schwellenwert überschritten
Microsoft Exchange Server Analyzer-Tools - Artikel > Netzwerk >

Letztes Änderungsdatum des Themas: 2007-02-13

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem Output Queue Length-Leistungsindikator des Network Interface-Leistungsobjekts.

Der Leistungsindikator Output Queue Length gibt die Länge der Ausgabepakete-Warteschlange in Paketen an. Microsoft Exchange Server Analyzer meldet den maximalen Wert des Leistungsindikators innerhalb des Erfassungszeitraums. Wenn der Durchschnittswert 10 übersteigt, zeigt Exchange Server Analyzer einen Fehler an.

Dieser Fehler weist normalerweise darauf hin, dass der Server zeitweise nicht mehr reagiert, was zu einer Verlangsamung oder vollständigen Unterbrechung der Mailübermittlung führt. Zusätzlich kann auf Outlook-Clients, die eine Verbindung mit diesem Server herstellen, das Dialogfeld RPC cancel Request (RPC-Abbruchanforderung) angezeigt werden.

Im Folgenden finden Sie einige mögliche Ursachen für diesen Fehler:

Hinweis:
Unter bestimmten Umständen zeigt der Leistungsindikator Output Queue Length auf einem Computer mit dem Betriebssystem Microsoft Windows 2000 Server ständig einen Zufallswert an, der größer als Null ist. Weitere Informationen zu den Umständen, in denen der Leistungsindikator Output Queue Length gegebenenfalls den Zufallswert anzeigt, und Anleitungen zum Beheben dieses Problems finden Sie im Microsoft Knowledge Base-Artikel 834940, "Systemmonitor zeigt möglicherweise hohe Werte für den Leistungsindikator der Ausgabewarteschlangenlänge in Windows 2000 an" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834940).
  • Eine Netzwerkschnittstellenkarte (Network Interface Card, NIC) des Computers kann die von der Netzwerkinfrastruktur unterstützte maximale Bandbreite nicht unterstützen.

  • Die Auslastung des Servers ist zu hoch.

  • Viren oder Spam führen zu plötzlich erhöhten Netzwerkverwendungsmustern.

Führen Sie folgende Schritte aus, um diesen Fehler zu beheben:

  • Wenn eine NIC die maximale Bandbreite der Netzwerkinfrastruktur nicht unterstützt, aktualisieren Sie diese so, dass eine höhere Bandbreite unterstützt wird.

  • Verringern Sie die Serverlast. Dies können Sie erreichen, indem Sie Postfächer auf einen Server mit weniger Postfächern verschieben. Erforderlichenfalls fügen Sie Ihrer Umgebung einen zusätzlichen Exchange-Server hinzu.

  • Wenn Sie befürchten, dass die ungewöhnlich hohe Auslastung nicht von zu vielen Postfächern auf dem Server herrührt, versuchen Sie, die Quelle für die außergewöhnlich hohe Auslastung zu ermitteln, und beseitigen Sie diese dann.

Berücksichtigen Sie die in den folgenden Artikeln ausgeführten Best Practices:

  • Informationen zu Aspekten der Netzwerkbandbreite finden Sie im Abschnitt „Network Performance" des Themas „Understanding Exchange Performance" im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Informationen zur Behandlung von Netzwerkproblemen finden Sie unter „Ruling Out Network-Bound Problems" im Handbuch Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Fehler: Der primäre DNS-Server hat nicht auf eine UDP-Verbindung geantwortet
Microsoft Exchange Server Analyzer-Tools - Artikel > Netzwerk >

Letztes Änderungsdatum des Themas: 2007-03-16

Das Tool Microsoft Exchange Analyzer fragt die Microsoft WMI-Klasse (Windows Management Instrumentation, Windows-Verwaltungsinstrumentation) Win32_NetworkAdapterConfiguration ab, um das Attribut DNSServerSearchOrder abzurufen. Dieses Attribut ist ein Array von Server-IP-Adressen, die beim Abfragen von DNS-Servern verwendet werden.

Nachdem die Adresse des primären DNS-Servers (Domain Name System) abgerufen wurde, versucht Exchange Analyzer, die konfigurierten DNS-Server für jeden Active Directory-Verzeichnisdienstserver abzufragen. Diese Verbindung wird mithilfe eines benutzerdefinierten Objektprozessors hergestellt, der eine UDP-Namensauflösung (User Datagram Protocol) anfordert und die Ergebnisse analysiert.

Wenn die Anforderung der UDP-Namensauflösung einen Fehler verursacht, zeigt Exchange Analyzer eine Warnung an.

Diese Warnung zeigt an, dass der primäre DNS-Server möglicherweise so konfiguriert ist, dass nur TCP-Abfragen akzeptiert werden.

SMTP (Simple Mail Transfer Protocol) ist das systemeigene E-Mail-Protokoll von Exchange Server für die Übermittlung und den Transport von E-Mail. Dies bedeutet, dass Clients SMTP zum Senden von Nachrichten und Server mit Exchange SMTP für die Zustellung von Nachrichten und Nachrichtendaten verwenden.

Damit Exchange Server eine ausgehende Internetnachricht über den SMTP-Dienst zustellen kann, wird DNS mithilfe der folgenden Methode bereitgestellt:

  1. Ein interner Benutzer sendet eine Nachricht an einen Empfänger in einer Remotedomäne.

  2. Der virtuelle SMTP-Server auf dem Servercomputer mit Exchange des Absenders verwendet interne Transportfunktionen, um die Empfängeradresse vom globalen Katalogserver abzufragen und so zu bestimmen, ob der Empfänger lokal oder remote ist. Wenn die Empfängeradresse für die Nachricht keine Empfängerrichtlinie ist, ist sie nicht in Active Directory gespeichert. Daher legt Exchange fest, dass das Ziel der Nachricht eine Remotedomäne ist.

  3. Wenn erforderlich, stellt der Servercomputer mit Exchange die Nachricht dem entsprechenden virtuellen SMTP-Server zu.

  4. Der virtuelle SMTP-Server verwendet seine IIS-Metabaseinformationen, um die Methode zum Zustellen einer Nachricht an eine Remotedomäne zu bestimmen.

  5. Der virtuelle SMTP-Server auf dem Servercomputer mit Exchange führt anschließend eine von zwei Aktionen aus:

    • Er verwendet DNS, um die IP-Adresse für die Zieldomäne zu ermitteln und versucht dann, die Nachricht zuzustellen.

    • Er leitet die Nachricht an einen Smarthost weiter, der die Verantwortung für die DNS-Auflösung und Zustellung der Nachricht übernimmt.

Standardmäßig überwachen DNS-Server die Kommunikation wie z. B. Namensauflösungsabfragen an UDP-Socket 53.

Wenn der SMTP-Dienst auf dem Servercomputer mit Exchange Server so konfiguriert ist, dass nur UDP-Abfragen gesendet werden, und der primäre DNS-Server so konfiguriert ist, dass nur TCP-Abfragen akzeptiert werden, können Nachrichtenroutingfehler auftreten, die die Leistung der Nachrichtenübermittlung negativ beeinflussen.

Um diese Warnung zu beheben, führen Sie die folgenden Schritte aus:

  1. Stellen Sie sicher, dass der DNS-Server gestartet wurde und mit dem Netzwerk verbunden ist.

  2. Vergewissern Sie sich, dass bekannte DNS-Ports (wie z. B. UDP-Port 53) nicht absichtlich durch Netzwerkfirewalls oder Paketfilter blockiert werden.

  3. Vergewissern Sie sich, dass der primäre DNS-Server so konfiguriert ist, dass UDP-Namesauflösungsabfragen unterstützt werden.

Weitere Informationen zu DNS und Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln und im WebCast:

  • 322856, "Konfigurieren von DNS für die Verwendung mit Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237, "XCON: Windows 2000- und Exchange 2000-SMTP verwendet TCP DNS-Abfragen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759, "Support WebCast: Microsoft Exchange 2000 Server: DNS Troubleshooting in Transports" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


Der primäre DNS-Server ist nicht erreichbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Netzwerk >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_NetworkAdapterConfiguration ab, um das Attribut DNSServerSearchOrder abzurufen. Dieses Attribut ist ein Array von IP-Adressen von Servern, die beim Abfragen von DNS-Servern verwendet werden. Nach dem Abrufen der Adresse des primären DNS-Servers öffnet Exchange Server Analyzer auf dem Server eine TCP-Socketverbindung mit Anschluss 53. Diese Verbindung wird mithilfe eines benutzerdefinierten Objektprozessors hergestellt, der eine bestimmte Zeichenfolge zurückgibt, wenn die Verbindung erfolgreich ist. Wenn 53 Available nicht in der an Exchange Server Analyzer zurückgegebenen Zeichenfolge enthalten ist, wird eine Warnung angezeigt.

Diese Warnung gibt an, dass der Server auf einen Verbindungsversuch an Anschluss 53 nicht reagiert hat. In der Standardeinstellung überwachen DNS-Server TCP-Socket 53 auf Kommunikationsversuche, z. B. Abfragen für Namensauflösungen.

Wenn der primäre DNS-Server nicht erreichbar ist und Sie Exchange 2000 Server ausführen, wird die E-Mail-Übermittlung langsam ausgeführt. Von Microsoft ist ein unterstützter Hotfix verfügbar, mit dem das Problem der verlangsamten Nachrichtenübermittlung an externe Empfänger bei Nichterreichbarkeit des primären DNS-Servers korrigiert werden kann. Den Hotfix erhalten Sie vom technischen Support von Microsoft.

Weiterhin können Sie die Ursache der Nichterreichbarkeit des primären DNS-Servers beheben oder die DNS-Einstellungen für den Exchange-Server ändern, um für die Namensauflösung einen anderen DNS-Server zu verwenden.

So beheben Sie diese Warnung

  1. Stellen Sie sicher, dass der DNS-Server gestartet wurde und mit dem Netzwerk verbunden ist.

  2. Verwenden Sie den Befehl PING, um festzustellen, ob der DNS-Server erreichbar ist.

Weitere Informationen zur langsamen E-Mail-Übermittlung bei Nichterreichbarkeit des primären DNS-Servers sowie zum Hotfix für dieses Problem finden Sie im Microsoft Knowledge Base-Artikel 829722, „Mail delivery is slow in Exchange 2000 when the primary DNS server is not available" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829722).

Weitere Informationen zu DNS und Exchange Server finden Sie in den folgenden Knowledge Base-Artikeln und im WebCast:

  • 322856, „How to configure DNS for use with Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237, „XCON: Windows 2000 and Exchange 2000 SMTP Use TCP DNS Queries" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759, „Support WebCast: Microsoft Exchange 2000 Server: DNS Troubleshooting in Transports" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


Fehler: Primärer externer DNS-Server hat nicht auf eine TCP-Verbindung geantwortet
Microsoft Exchange Server Analyzer-Tools - Artikel > Netzwerk >

Letztes Änderungsdatum des Themas: 2007-03-16

Microsoft Exchange Analyzer fragt den Active Directory-Verzeichnisdienst ab, um den Wert des Attributs msExchSmtpExternalDNSServers in der Klasse protocolCfgSMTPServer für jedes Exchange Server-Objekt zu bestimmen. Wenn der Wert des Attributs msExchSmtpExternalDNSServers festgelegt wurde, gibt er die Adresse des externen DS-Servers (Domain Name System) an, den die Instanz des virtuellen SMTP-Servers (Simple Mail Transfer Protocol) verwendet.

Nach dem Abrufen der Adresse des primären externen DNS-Servers öffnet Exchange Server Analyzer auf dem Server eine TCP-Socketverbindung mit Port 53. Diese Verbindung wird durch die Verwendung eines benutzerdefinierten Objektprozessors hergestellt, der eine bestimmte Zeichenfolge zurückgibt, wenn die Verbindung erfolgreich ist. Wenn 53 Available nicht in der an Exchange Server Analyzer zurückgegebenen Zeichenfolge enthalten ist, wird eine Warnung angezeigt.

Diese Warnung gibt an, dass der Server auf einen Verbindungsversuch an TCP-Port 53 nicht reagiert hat. In der Standardeinstellung überwachen DNS-Server TCP-Socket 53 auf Kommunikationsversuche, z. B. Abfragen für Namensauflösungen.

SMTP ist das systemeigene E-Mail-Protokoll von Exchange Server für die Übermittlung und den Transport von E-Mail. Dies bedeutet, dass Clients SMTP zum Senden von Nachrichten und Server mit Exchange SMTP für die Zustellung von Nachrichten und Nachrichtendaten verwenden.

Damit Exchange Server eine ausgehende Internetnachricht über den SMTP-Dienst zustellen kann, wird DNS mithilfe der folgenden Methode bereitgestellt:

  1. Ein interner Benutzer sendet eine Nachricht an einen Empfänger in einer Remotedomäne.

  2. Der virtuelle SMTP-Server auf dem Servercomputer mit Exchange des Absenders verwendet interne Transportfunktionen, um die Empfängeradresse vom globalen Katalogserver abzufragen und so zu bestimmen, ob der Empfänger lokal oder remote ist. Wenn die Empfängeradresse für die Nachricht keine Empfängerrichtlinie ist, ist sie nicht in Active Directory gespeichert. Daher legt Exchange fest, dass das Ziel der Nachricht eine Remotedomäne ist.

  3. Wenn erforderlich, stellt der Servercomputer mit Exchange die Nachricht dem entsprechenden virtuellen SMTP-Server zu.

  4. Der virtuelle SMTP-Server verwendet seine IIS-Metabaseinformationen, um die Methode zum Zustellen einer Nachricht an eine Remotedomäne zu bestimmen.

  5. Der virtuelle SMTP-Server auf dem Servercomputer mit Exchange führt anschließend eine von zwei Aktionen aus:

    • Er verwendet DNS, um die IP-Adresse für die Zieldomäne zu ermitteln und versucht dann, die Nachricht zuzustellen.

    • Er leitet die Nachricht an einen Smarthost weiter, der die Verantwortung für die DNS-Auflösung und Zustellung der Nachricht übernimmt.

Wenn der primäre externe DNS-Server nicht erreichbar ist und Sie Exchange 2000 Server ausführen, ist die Nachrichtenzustellung langsam. Von Microsoft ist ein unterstützter Hotfix verfügbar, mit dem das Problem der verlangsamten Nachrichtenübermittlung an externe Empfänger bei Nichterreichbarkeit des primären externen DNS-Servers korrigiert werden kann. Den Hotfix erhalten Sie vom technischen Support von Microsoft.

Weiterhin können Sie die Ursache der Nichterreichbarkeit des primären externen DNS-Servers beheben oder die DNS-Einstellungen für den Exchange-Server ändern, um für die Namensauflösung einen anderen DNS-Server zu verwenden.

Um diese Warnung zu beheben, führen Sie die folgenden Schritte aus:

  1. Stellen Sie sicher, dass der DNS-Server gestartet wurde und eine Verbindung mit dem Exchange-Netzwerk besteht.

  2. Verwenden Sie den Befehl PING, um festzustellen, ob der externe DNS-Server erreichbar ist.

Weitere Informationen zur langsamen Nachrichtenzustellung bei Nichterreichbarkeit des primären DNS-Servers sowie zum Hotfix für dieses Problem finden Sie im Microsoft Knowledge Base-Artikel 829722, "Die Nachrichtenzustellung in Exchange 2000 ist langsam, wenn der primäre DNS-Server nicht verfügbar ist" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829722).

Weitere Informationen zu DNS und Exchange Server finden Sie in den folgenden Knowledge Base-Artikeln und im WebCast:

  • 322856, "Konfigurieren von DNS für die Verwendung mit Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237, "XCON: Windows 2000- und Exchange 2000-SMTP verwendet TCP DNS-Abfragen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759, "Support WebCast: Microsoft Exchange 2000 Server: DNS Troubleshooting in Transports" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


Fehler: Primärer externer DNS-Server hat nicht auf eine UDP-Verbindung geantwortet
Microsoft Exchange Server Analyzer-Tools - Artikel > Netzwerk >

Letztes Änderungsdatum des Themas: 2007-03-16

Microsoft Exchange Analyzer fragt den Active Directory-Verzeichnisdienst ab, um den Wert des Attributs msExchSmtpExternalDNSServers in der Klasse protocolCfgSMTPServer für jedes Exchange Server-Objekt zu bestimmen. Wenn der Wert des Attributs msExchSmtpExternalDNSServers festgelegt wurde, gibt er die Adresse des externen DS-Servers (Domain Name System) an, den die Instanz des virtuellen SMTP-Servers (Simple Mail Transfer Protocol) verwendet.

Nachdem die Adresse des primären externen DNS-Servers (Domain Name System) abgerufen wurde, versucht Exchange Analyzer, die konfigurierten externen DNS-Server für jeden Active Directory-Verzeichnisdienstserver abzufragen. Diese Verbindung wird mithilfe eines benutzerdefinierten Objektprozessors hergestellt, der eine UDP-Namensauflösung (User Datagram Protocol) anfordert und die Ergebnisse analysiert.

Wenn die Anforderung der UDP-Namensauflösung einen Fehler verursacht, zeigt Exchange Analyzer eine Warnung an.

Diese Warnung zeigt an, dass der primäre externe DNS-Server möglicherweise so konfiguriert ist, dass nur TCP-Abfragen akzeptiert werden.

SMTP ist das systemeigene E-Mail-Protokoll von Exchange Server für die Übermittlung und den Transport von E-Mail. Dies bedeutet, dass Clients SMTP zum Senden von Nachrichten und Server mit Exchange SMTP für die Zustellung von Nachrichten und Nachrichtendaten verwenden.

Damit Exchange Server eine ausgehende Internetnachricht über den SMTP-Dienst zustellen kann, wird DNS mithilfe der folgenden Methode bereitgestellt:

  1. Ein interner Benutzer sendet eine Nachricht an einen Empfänger in einer Remotedomäne.

  2. Der virtuelle SMTP-Server auf dem Servercomputer mit Exchange des Absenders verwendet interne Transportfunktionen, um die Empfängeradresse vom globalen Katalogserver abzufragen und so zu bestimmen, ob der Empfänger lokal oder remote ist. Wenn die Empfängeradresse für die Nachricht keine Empfängerrichtlinie ist, ist sie nicht in Active Directory gespeichert. Daher legt Exchange fest, dass das Ziel der Nachricht eine Remotedomäne ist.

  3. Wenn erforderlich, stellt der Servercomputer mit Exchange die Nachricht dem entsprechenden virtuellen SMTP-Server zu.

  4. Der virtuelle SMTP-Server verwendet seine IIS-Metabaseinformationen, um die Methode zum Zustellen einer Nachricht an eine Remotedomäne zu bestimmen.

  5. Der virtuelle SMTP-Server auf dem Servercomputer mit Exchange führt anschließend eine von zwei Aktionen aus:

    • Er verwendet DNS, um die IP-Adresse für die Zieldomäne zu ermitteln und versucht dann, die Nachricht zuzustellen.

    • Er leitet die Nachricht an einen Smarthost weiter, der die Verantwortung für die DNS-Auflösung und Zustellung der Nachricht übernimmt.

Standardmäßig überwachen DNS-Server die Kommunikation wie z. B. Namensauflösungsabfragen an UDP-Socket 53.

Wenn der SMTP-Dienst auf dem Servercomputer mit Exchange so konfiguriert ist, dass nur UDP-Abfragen gesendet werden, und der primäre externe DNS-Server so konfiguriert ist, dass nur TCP-Abfragen akzeptiert werden, können Nachrichtenroutingfehler auftreten, die die Leistung der Nachrichtenübermittlung negativ beeinflussen.

Um diese Warnung zu beheben, führen Sie die folgenden Schritte aus:

  1. Stellen Sie sicher, dass der DNS-Server gestartet wurde und eine Verbindung mit dem Netzwerk besteht.

  2. Vergewissern Sie sich, dass bekannte DNS-Ports (wie z. B. UDP-Port 53) nicht absichtlich durch Netzwerkfirewalls oder Paketfilter blockiert werden.

  3. Vergewissern Sie sich, dass der primäre externe DNS-Server so konfiguriert ist, dass UDP-Namesauflösungsabfragen unterstützt werden.

Weitere Informationen zu DNS und Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln und im WebCast:

  • 322856, "Konfigurieren von DNS für die Verwendung mit Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237, "XCON: Windows 2000- und Exchange 2000-SMTP verwendet TCP DNS-Abfragen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759, "Support WebCast: Microsoft Exchange 2000 Server: DNS Troubleshooting in Transports" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


Keine Rückmeldung vom primären WINS-Server
Microsoft Exchange Server Analyzer-Tools - Artikel > Netzwerk >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_NetworkAdapterConfiguration ab, um das Attribut WINSPrimaryServer abzurufen. Dieses Attribut ist die IP-Adresse des primären WINS-Servers (Windows Internet Name Service) für den Exchange Server-Computer. Nachdem Microsoft Exchange Server Analyzer die Adresse des primären WINS-Servers abgerufen hat, öffnet Microsoft Exchange Server Analyzer eine TCP-Socketverbindung mit Anschluss 137 auf dem Server. Diese Verbindung wird mithilfe eines benutzerdefinierten Objektprozessors hergestellt, der eine bestimmte Zeichenfolge zurückgibt, wenn die Verbindung erfolgreich ist. Wenn 137 Available nicht in der an Exchange Server Analyzer zurückgegebenen Zeichenfolge enthalten ist, wird von Exchange Server Analyzer eine Warnung angezeigt.

Diese Warnung gibt an, dass der Server auf einen Verbindungsversuch mit TCP-Anschluss 137 nicht reagiert hat. In der Standardeinstellung überwachen WINS-Server TCP-Socket 137 auf Kommunikationsversuche, z. B. Abfragen für Namensauflösungen.

Wenn der primäre WINS-Server nicht erreichbar ist und Sie Exchange Server ausführen, wird die E-Mail-Übermittlung besonders in größeren Organisationen langsam ausgeführt. Sie sollten die Ursache der Nichterreichbarkeit des primären WINS-Servers beheben oder die WINS-Einstellungen auf dem Exchange-Server ändern, um für die Namensauflösung einen anderen WINS-Server zu verwenden.

So beheben Sie diese Warnung

  1. Stellen Sie sicher, dass der WINS-Server gestartet wurde und mit dem Netzwerk verbunden ist.

  2. Verwenden Sie den Befehl PING, um festzustellen, ob der WINS-Server erreichbar ist.

Informationen zu den Gründen, warum WINS für Exchange 2000 Server und Exchange Server 2003 erforderlich ist, finden Sie im Microsoft Knowledge Base-Artikel 837391 „Exchange Server 2003 and Exchange 2000 Server require NetBIOS name resolution for full functionality" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=837391.


Keine Rückmeldung von Anschluss 389
Microsoft Exchange Server Analyzer-Tools - Artikel > Netzwerk >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs dNSHostName für sämtliche Domänencontroller in Active Directory zu ermitteln. Nach dem Abrufen der Domänencontrollernamen öffnet Exchange Server Analyzer auf jedem Domänencontroller eine TCP-Socketverbindung mit Anschluss 389. Diese Verbindung wird durch die Verwendung eines benutzerdefinierten Objektprozessors hergestellt, der eine bestimmte Zeichenfolge zurückgibt, wenn die Verbindung erfolreich ist. Wenn 389 Available nicht in der an den Exchange Server Analyzer zurückgegebenen Zeichenfolge enthalten ist, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass der Domänencontroller nicht auf einen Verbindungsversuch auf TCP-Anschluss 389 geantwortet hat. Der TCP-Anschluss ist der Standardanschluss für LDAP-Kommunikationen (Lightweight Directory Access Protocol).

Diese Warnung können Sie auch aufgrund von Verbindungsproblemen zwischen Exchange Server Analyzer und dem Domänencontroller erhalten. Es gibt viele Gründe dafür, warum LDAP-Anforderungen möglicherweise nicht von Domänencontrollern verarbeitet werden können, wenn sie von Exchange Server Analyzer abgefragt werden.

So beheben Sie diese Warnmeldung

  1. Überprüfen Sie, ob das Konto, unter dem das Tool ausgeführt wird, berechtigt ist, den Domänencontroller abzufragen. Sie benötigen in der Domäne, in dem der Domänencontroller ausgeführt wird, Berechtigungen auf Benutzerebene. Weitere Informationen zu den erforderlichen Berechtigungen zum Ausführen von Exchange Server Analyzer finden Sie in der Hilfedatei, die dem Tool beigefügt ist. Öffnen Sie die Hilfedatei, indem Sie zunächst Exchange Server Analyzer öffnen. Klicken Sie im Hilfemenü auf die Option für die Hilfe zu Microsoft Exchange Server Analyzer.

  2. Vergewissern Sie sich, dass zwischen dem Computer, auf dem Microsoft Exchange Server Analyzer ausgeführt wird, und dem Domänencontroller, der nicht geantwortet hat, keine Firewalls oder Anschlussbeschränkungen vorhanden sind.

  3. Vergewissern Sie sich, dass der Domänencontroller mit dem Netzwerk verbunden ist und ordnungsgemäß funktioniert.

Weitere Informationen über das Behandeln von Verbindungsproblemen in Active Directory finden Sie im Microsoft Knowledge Base-Artikel 816103, „HOW TO: Use Portqry to Troubleshoot Active Directory Connectivity Issues" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103.

Weitere Informationen zum Konfigurieren von Microsoft Windows® Time auf Domänencontrollern finden Sie im Knowledge Base-Artikel 816042 „How to configure an authoritative time server in Windows Server 2003" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816042.


Keine Rückmeldung von Anschluss 636
Microsoft Exchange Server Analyzer-Tools - Artikel > Netzwerk >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs dNSHostName sämtlicher Domänencontroller in Active Directory zu ermitteln. Nach dem Abrufen der Domänencontrollernamen öffnet Exchange Server Analyzer auf jedem Domänencontroller eine TCP-Socketverbindung mit Anschluss 636. Diese Verbindung wird durch die Verwendung eines benutzerdefinierten Objektprozessors hergestellt, der eine bestimmte Zeichenfolge zurückgibt, wenn die Verbindung erfolreich ist. Wenn 636 Available nicht in der an den Exchange Server Analyzer zurückgegebenen Zeichenfolge enthalten ist, wird eine Warnung angezeigt.

Diese Warnung gibt an, dass der Domänencontroller auf einen Verbindungsversuch an TCP-Anschluss 636 nicht geantwortet hat. Beim TCP-Anschluss 636 handelt es sich um den Standardanschluss für sichere LDAP-Verbindungen (Lightweight Directory Access Protocol) (LDAP über SSL).

Mit der Einführung von Exchange 2000 Server, Service Pack 3 stellt Exchange Server Verbindungen mit LDAP über SSL her, wenn im lokalen Zertifikatsspeicher auf dem Exchange Server-Computer ein gültiges Zertifikat vorhanden ist. Wenn ein solches Zertifikat nicht vorhanden ist oder ein Fehler im Zusammenhang mit dem Zertifikat zurückgegeben wird (z. B. wenn der Domänencontroller dem Zertifikat von Exchange nicht vertraut oder das verwendete Zertifikat starken Schlüsselschutz erfordert), verwendet Exchange Server automatisch LDAP ohne SSL. Diese Warnung können Sie auch aufgrund von Verbindungsproblemen zwischen Exchange Server Analyzer und dem Domänencontroller erhalten. Probleme mit der PKI (Public Key Infrastructure) oder andere Zertifikatsprobleme werden durch diese Warnung nicht erfasst.

Es gibt viele Ursachen dafür, warum LDAP-über-SSL-Anforderungen möglicherweise nicht von Domänencontrollern verarbeitet werden können, wenn sie von Exchange Server Analyzer abgefragt werden.

So beheben Sie diese Warnmeldung

  1. Überprüfen Sie, ob das Konto, unter dem das Tool ausgeführt wird, berechtigt ist, den Domänencontroller abzufragen. Sie benötigen in der Domäne, in dem der Domänencontroller ausgeführt wird, Berechtigungen auf Benutzerebene. Weitere Informationen zu den erforderlichen Berechtigungen zum Ausführen von Exchange Server Analyzer finden Sie in der Hilfedatei, die dem Tool beigefügt ist. Öffnen Sie die Hilfedatei, indem Sie zunächst Exchange Server Analyzer öffnen. Klicken Sie im Hilfemenü auf die Option für die Hilfe zu Microsoft Exchange Server Analyzer.

  2. Vergewissern Sie sich, dass zwischen dem Computer, auf dem Microsoft Exchange Server Analyzer ausgeführt wird, und dem Domänencontroller, der nicht geantwortet hat, keine Firewalls oder Anschlussbeschränkungen vorhanden sind.

  3. Vergewissern Sie sich, dass der Domänencontroller mit dem Netzwerk verbunden ist und ordnungsgemäß funktioniert.

  4. Vergewissern Sie sich, dass die Zeit auf dem Computer, auf dem Microsoft Exchange Server Analyzer ausgeführt wird, und dem Domänencontroller, der nicht geantwortet hat, synchronisiert ist. Wenn der Microsoft Windows®-Zeitdienst auf dem Domänencontroller angehalten oder deaktiviert wurde, ist die lokale Zeit auf dem Domänencontroller möglicherweise nicht mehr synchron. In diesem Fall antwortet der Domänencontroller erst nach einer Synchronisierung der Uhrzeit auf Anfragen mit LDAP über SSL.

Weitere Informationen zum Verwenden von LDAP über SSL finden Sie im Microsoft Knowledge Base-Artikel 321051, „Aktivieren von LDAP über SSL mit einer Drittanbieter-Zertifizierungsstelle" (http://support.microsoft.com/kb/321051/de).

Weitere Informationen zum Behandeln von Verbindungsproblemen in Active Directory finden Sie im Knowledge Base-Artikel 816103, „HOW TO: Use Portqry to Troubleshoot Active Directory Connectivity Issues" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103.

Weitere Informationen zum Windows-Zeitdienst finden Sie im Knowledge Base-Artikel 816042, „Konfigurieren eines autorisierenden Zeitservers in Windows Server 2003" (http://support.microsoft.com/default.aspx?scid=kb;de;816042).


X-LINK2STATE-Verb wird vom SMTP-Server nicht unterstützt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Netzwerk >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer initiiert eine SMTP-Sitzung beim Exchange-Server, um die richtigen Exchange-SMTP-Verben aufzulisten. Wenn das X-LINK2STATE-Verb nicht aufgelistet ist, wird eine Warnung angezeigt.

Das X-LINK2STATE-Verb wird von Exchange zum Aktualisieren der Verbindungsstatustabellen für die Routing-Master verwendet. In den Verbindungsstatustabellen werden aktuelle Informationen zum Status der SMTP-Verbindungen in der gesamten Exchange-Organisation erfasst. Exchange verwendet diese Informationen beim Routing von Nachrichten, um die geringsten Kosten zu erzielen und die zuverlässigsten Routen auszuwählen. Diese Funktion wird auch als „Intelligentes Routing" bezeichnet.

Das X-LINK2STATE-Verb ist für das effiziente Routing in Exchange erforderlich und wird von anderen SMTP-Anbietern nicht verwendet. Die Funktion selbst wird in einer Datei (xlsasink.dll) bereitgestellt, die beim Setup von Exchange installiert und registriert wird.

Diese Warnung wird möglicherweise aus zwei bekannten Gründen ausgegeben: Erstens könnte ein Administrator xlsasink.dll deaktiviert haben, um die bereitgestellte intelligente Routingfunktion zu umgehen. Dies entspricht nicht der empfohlenen optimalen Methode und führt mit einiger Wahrscheinlichkeit zu Leistungs- und Stabilitätsproblemen. In diesem Fall wird empfohlen, Exchange auf dem betreffenden Computer neu zu installieren und xlsasink.dll zu registrieren.

Zweitens kann diese Warnung zurückgegeben werden, wenn Sie ein Antivirusprodukt verwenden, das zum Prüfen von Nachrichten einen eigenen SMTP-Protokollstapel installiert und verwendet. In diesem Fall verwendet die Antivirussoftware möglicherweise einen eigenen SMTP-Stapel, um Nachrichten abzufangen und zu prüfen, bevor sie den SMTP-Stapel von Exchange erreichen. In diesem Fall wird das LINK2STATE-Verb vom SMTP-Stapel der Antivirussoftware nicht verwendet. Es wird empfohlen, die Antivirussoftware in einem Modus auszuführen, in dem es nicht erforderlich ist, einen eigenen SMTP-Stapel auf dem Exchange-Server zu installieren.

Weitere Informationen zu X-LINK2STATE und anderen von Exchange verwendeten proprietären Verben finden Sie im Microsoft Knowledge Base-Artikel 812455 „Definitions of Verbs That Are Used Between 2 Exchange Servers" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=812455).

Weitere Informationen zum Anzeigen der Befehlsverben in Exchange und zum erneuten Installieren von Exchange 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 319885 „XCON: Messages Sent in the Exchange 2000 Server Organization Are Not Delivered" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319885).

Weitere Informationen zum Anzeigen der Exchange-Befehlsverben und zum erneuten Installieren von Exchange Server 2003 finden Sie im Knowledge Base-Artikel 822939 „Messages That Are Sent in the Exchange Server 2003 Organization Are Not Delivered" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822939).


Mail-Annahmetest für SMTP-Server fehlgeschlagen.
Microsoft Exchange Server Analyzer-Tools - Artikel > Netzwerk >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer versucht, eine Nachricht an das Postmaster-Konto für die SMTP-Domäne zu senden, indem folgende Aufgaben ausgeführt werden:

  • Öffnen einer Socket-Verbindung mit dem SMTP-Server. Wenn Exchange Server Analyzer den Antwortcode 220 empfängt, wurde dieser Schritt erfolgreich ausgeführt.

  • Übermitteln des SMTP-Befehlsverbs EHLO. Wenn Exchange Server Analyzer mehrere Antwortcodes mit dem Wert 250 sowie eine Antwort empfängt, die 250-X-LINK2STATE und 250-XEXCH50 enthält, wurde dieser Schritt erfolgreich ausgeführt.

  • Übermitteln des SMTP-Befehlsverbs MAIL FROM: ExBPA-MailAcceptTest@Fabrikam.com. Wenn Exchange Server Analyzer den Antwortcode 250 empfängt, wurde dieser Schritt erfolgreich ausgeführt.

  • Übermitteln des SMTP-Befehlsverbs RCPT TO: Postmaster@<Domänenname>.com. Wenn Exchange Server Analyzer den Antwortcode 250 empfängt, wurde dieser Schritt erfolgreich ausgeführt.

Wenn Exchange Server Analyzer nicht alle Schritte erfolgreich ausführen kann, wird ein Fehler angezeigt. Der Fehler weist darauf hin, dass u. U. ein allgemeines Problem beim Nachrichenfluss besteht. Die folgenden Verknüpfungen sind in der Reihenfolge angegeben, in der Sie bei der Problembehebung vorgehen sollen, beginnend auf der Serverebene bis hin zur Netzwerkebene.

So berichtigen Sie diesen Fehler

  1. Informationen zur Problembehandlung beim Routing finden Sie in Transport- und Routing-Handbuch für ExchangeServer 2003 (http://www.microsoft.com/germany/technet/datenbank/articles/600421.mspx).

  2. Microsoft Knowledge Base-Artikel 324867 „Support WebCast: Microsoft Exchange 2000 Server: Troubleshooting Mail Flow Problems (Revisited)" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324867).

  3. Microsoft Knowledge Base-Artikel 823489 „How to Use Queue Viewer to Troubleshoot Mail Flow Issues" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489).

  4. Microsoft Knowledge Base-Artikel 324759 „Support WebCast: Microsoft Exchange 2000 Server: DNS Troubleshooting in Transports" (http://go.microsoft.com/fwlink/?linkId=3052&kbid=324759).

Weitere Informationen zum Postmaster-Konto in Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 223860, „XCON: SMTP Postmaster Mailbox Must Be Set Manually" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=223860)

  • 313832, „SO WIRD´S GEMACHT: SMTP-Postmaster-Konto in Exchange 2000 Server einrichten" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313832).


Der SMTP-Server hat den Test auf offenes Relay nicht bestanden.
Microsoft Exchange Server Analyzer-Tools - Artikel > Netzwerk >

Letztes Änderungsdatum des Themas: 2007-03-14

Microsoft® Exchange Server Analyzer versucht, für eine Nachricht ein Relay über einen SMTP-Server (Simple Mail Transfer Protocol) durchzuführen, indem folgende Aufgaben ausgeführt werden:

  • Öffnen einer Socket-Verbindung mit dem SMTP-Server. Wenn Exchange Server Analyzer den Antwortcode 220 empfängt, wurde dieser Schritt erfolgreich ausgeführt.

  • Übermitteln des SMTP-Befehlsverbs EHLO. Wenn Exchange Server Analyzer mehrere Antwortcodes mit dem Wert 250 sowie eine Antwort empfängt, die 250-X-LINK2STATE und 250-XEXCH50 enthält, wurde dieser Schritt erfolgreich ausgeführt.

  • Übermitteln des SMTP-Befehlsverbs MAIL FROM: ExBPA-OpenRelayTest@Fabrikam.com. Wenn Exchange Server Analyzer den Antwortcode 250 empfängt, wurde dieser Schritt erfolgreich ausgeführt.

  • Übermitteln des SMTP-Befehlsverbs RCPT TO: ExBPA-OpenRelayTest@Fabrikam.com. Wenn Exchange Server Analyzer den Antwortcode 250 empfängt, wurde dieser Schritt erfolgreich ausgeführt.

Exchange Server Analyzer fragt außerdem die WMI-Klasse (Microsoft Windows ® Management Instrumentation) Win32_OperatingSystem ab, um den Wert für den Schlüssel OSProductSuite zu bestimmen. Der Wert dieses Schlüssels entspricht einer bestimmten Version eines Windows Server-Betriebssystems.

Wenn Exchange Server Analyzer auf einem Exchange Server-Computer, der Teil einer Installation von Microsoft Windows Small Business Server 2000 oder Microsoft Windows Small Business Server 2003 ist, alle Schritte erfolgreich ausführen kann, wird ein Fehler angezeigt.

Der Fehler weist darauf hin, dass dieser Server als offenes Relay konfiguriert ist.

Das Zulassen von offenem Relay ist keine empfohlene bewährte Methode.

Ein offenes Relay tritt auf, wenn ein E-Mail-Server das Durchführen eines Relays für E-Mail-Nachrichten über das System ermöglicht, ohne dabei Einschränkungen oder Kontrolle über diese Nachrichten auszuüben.

Hinweis:
Dieser Fehler kann auftreten, wenn Ihre Exchange-Organisation aus beliebigem Grund eine SMTP-Domäne mit dem Namen Fabrikam.com verwendet. Falls dies den Grund darstellt, können Sie diesen Fehler unbesorgt ignorieren. Die Domäne Fabrikam.com ist Eigentum von Microsoft Corporation und wird für Ausbildung, Dokumentation und ähnliche Zwecke verwendet.

Relay ist nicht unbedingt nachteilig, da SMTP für diesen Zweck entwickelt wurde (vgl. das RFC 2821-Document, Abschnitte 2.1 und 3.7, unter http://ietf.org. Wenn Relay jedoch nicht gesteuert wird (ein nicht gesteuerter Host ist als offener Relay-Host bekannt), kann ein böswilliger Benutzer Relay theoretisch zum Senden großer Mengen unerwünschter kommerzieller E-Mail-Nachrichten (Spam oder UCE) verwenden. Durch das Weiterleiten dieser unerwünschten E-Mail-Nachrichten über einen zwischengeschalteten Host versucht dieser böswillige Benutzer, ihre Identität zu verschleiern. Dies bindet Ressourcen auf dem Relay-Host und kann diesen daran hindern, ordnungsgemäße E-Mail-Nachrichten zu senden. Insbesondere können die meisten Benutzer, die solche unaufgeforderten E-mail-Nachrichten senden, eine einzelne Nachricht an sehr viele Empfänger gleichzeitig senden, ohne dass ihre eigene Bandbreite verwendet wird.

Stellen Sie sicher, dass Sie auf Ihren mit dem Internet verbundenen virtuellen SMTP-Servern kein anonymes Relay ermöglichen. In der Standardkonfiguration ermöglicht Exchange nur authentifizierten Benutzern das Weiterleiten von Nachrichten per Relay. Nur authentifizierte Benutzer können Exchange dazu verwenden, E-Mail an eine externe Domäne zu senden. Wenn Sie die Relay-Standardeinstellungen ändern, um nicht authentifizierten Benutzern das Weiterleiten per Relay zu ermöglichen, oder wenn Sie auf einer Domäne offenes Relay über einen Connector ermöglichen, können nicht autorisierte Benutzer oder bösartige Würmer Ihren Exchange-Server zum Senden von Spam verwenden. Ihr Server kann blockiert und dadurch daran gehindert werden, Mail an legitime Remoteserver zu senden. Verwenden Sie mindestens die Standard-Relayeinschränkungen, um nicht autorisierte Benutzer daran zu hindern, Ihren Exchange-Server zum Weiterleiten von E-Mail per Relay zu verwenden.

Wenn Sie legitime Gründe zum Weiterleiten per Relay haben, gehen Sie anhand der Richtlinien vor, um sicherzustellen, dass in Ihrer Implementierung die Sicherheit gewährleistet ist. Behalten Sie dazu die Standardwerte zum vollständigen Verweigern bei, und fügen Sie nur die IP-Adressen hinzu, von denen Sie Relay-Mail akzeptieren, und deaktivieren Sie den Zugriff authentifizierter Benutzer.

Überprüfen Sie, wie auf Ihren Gateway-Servern Review vordefinierte Konten (für lokalen Administrator) und andere Benutzer verwendet werden. Es ist unwahrscheinlich, dass vordefinierte Konten für Weitergabe per Relay verwendet werden. Wenn Sie per Relay weiterleiten, erfolgt dies wahrscheinlich über bekannte Benutzer oder Computer. Es wird empfohlen, Relay-Berechtigungen auf bestimmte Benutzer und Computer oder auf eine IP-Adresse zu beschränken.

Auch das Konfigurieren expliziter Relay-Berechtigungen trägt zur Sicherheit Ihres Servers bei. Böswillige Benutzer können durch einen Brute-Force-Angriff versuchen, die Kennwörter für in Internet gefundene vordefinierte Konten oder Benutzerkonten zu ermitteln, um Ihren Server als Spam-Proxy zu verwenden. Deshalb wird die Standardeinstellung, die allen authentifizierten Computern die Weitergabe per Relay ermöglicht, für vom Internet aus zugängliche Computer nicht empfohlen. Es wird empfohlen, diese Einstellung zu deaktivieren.

In deb folgenden Verfahren wird das Deaktivieren anonymer Weitergabe per Relay in Abhängigkeit davon erläutert, ob der virtuelle SMTP-Server mit dem Internet verbunden ist. Wie bereits in diesem Artikel erwähnt, sollte jegliche Form anonymen Relays nur dann aktiviert werden, wenn das Sicherheitsrisiko bekannt und für Ihre Organisation akzeptabel ist. Weitere Informationen zum Verwenden der Weitergabe per Relay finden Sie in den Verweisen am Schluss dieses Artikels.

Wenn ein virtueller SMTP-Server nicht vom Internet aus zugänglich ist, wird empfohlen, dass Sie die Relay-Konfigurationen auf die Standardwerte zurücksetzen. Dadurch werden die virtuellen SMTP-Server auf das interne Relay von authentifizierten Computern beschränkt.

Für aus dem Internet zugängliche virtuelle SMTP-Server wird empfohlen, die Standard-Relay-Konfigurationen zusätzlich zu sichern, sodass nur solche Benutzer und Computer per Relay weiterleiten können, die ausdrücklich dazu berechtigt sind.

Wenn Sie sichergestellt haben, dass Exchange zum Blockieren von Weiterleitung per Relay konfiguriert ist, und dieser Fehler im Exchange Server Analyzer immer noch auftritt, sollten Sie darauf achten, dass keine Proxys oder Prozesse wie Firewall-, Antiviren- oder Anti-Spam-Software anonymes Weiterleiten per Relay ermöglichen.

So setzen Sie auf virtuellen SMTP-Servern die anonymen Relay-Konfigurationen auf die Standardeinstellungen zurück

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie in der Konsolenstruktur den Eintrag Server, erweitern Sie den gewünschten Server, erweitern Sie Protokolle, und erweitern Sie anschließend SMTP.

  3. Klicken Sie mit der rechten Maustaste auf den virtuellen SMTP-Server, für den Sie Relay-Einschränkungen festlegen möchten, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie in >Eigenschaften von <Virtueller SMTP-Server auf die Registerkarte Zugriff, und klicken Sie dann auf Relay.

  5. Wählen Sie in den Relayeinschränkungen unter Legen Sie fest, welchen Computern das Relay über diesen virtuellen Server erlaubt ist die Option Nur Computer in der Liste unten aus, aktivieren Sie das Kontrollkästchen Jedem Computer, der erfolgreich authentifiziert ist, unabhängig von der Liste oben das Relay erlauben, und klicken Sie dann auf OK.

So konfigurieren Sie in Exchange Server 2003 explizite Relay-Berechtigungen auf virtuellen SMTP-Servern mit Internetzugang

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie in der Konsolenstruktur den Eintrag Server, erweitern Sie den gewünschten Server, erweitern Sie Protokolle, und erweitern Sie anschließend SMTP.

  3. Klicken Sie mit der rechten Maustaste auf den virtuellen SMTP-Server, für den Sie Relay-Einschränkungen festlegen möchten, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie in >Eigenschaften von <Virtueller SMTP-Server auf die Registerkarte Zugriff, und klicken Sie dann auf Relay.

  5. Deaktivieren Sie in den Relayeinschränkungen das Kontrollkästchen Jedem Computer, der erfolgreich authentifiziert ist, unabhängig von der Liste oben das Relay erlauben, und klicken Sie dann auf Benutzer, um eine Untergruppe von Benutzern auszuwählen, denen Sie die Relay-Berechtigungen auf diesem virtuellen SMTP-Server erteilen möchten.

  6. Wählen Sie zum Entfernen eines Benutzers oder einer Gruppe in den Berechtigungen für Übermittlung und Relay einen Benutzer oder eine Gruppe aus, und klicken Sie dann auf Entfernen.

  7. Klicken Sie zum Hinzufügen einer Gruppe oder eines Benutzers auf Hinzufügen, und wählen Sie dann den Benutzer oder die Gruppe aus, für die Sie Berechtigungen festlegen möchten. Wählen Sie eine der folgenden Optionen aus:

    • Geben Sie unter Microsoft Windows Server™ 2003 in Benutzer, Computer oder Gruppen auswählen unter Geben Sie die zu verwendenden Objektnamen ein den Namen des Benutzers oder der Gruppe ein. Wenn Sie nach einem Benutzer oder einer Gruppe suchen möchten, klicken Sie auf Erweitert, suchen Sie nach dem Namen des Benutzers oder der Gruppe, und klicken Sie dann auf Namen überprüfen, um Ihre Eingaben zu überprüfen.

      Tipp:
      Klicken Sie auf die Verknüpfung Beispiele, um die möglichen Eingabeformate anzuzeigen.
    • Wählen Sie unter Windows 2000 Server in Benutzer, Computer oder Gruppen auswählen die Gruppe oder den Benutzer aus, der oder dem Sie Übermittlungsberechtigungen erteilen möchten, und klicken Sie dann auf Hinzufügen.

  8. Klicken Sie auf OK, um zum Dialogfeld der Berechtigungen für Übermittlung und Relay zurückzukehren.

  9. Wählen Sie in der Liste Gruppen- und Benutzernamen die neu hinzugefügte Gruppe aus.

  10. Aktivieren Sie ggf. unter Berechtigungen für <ausgewählte Gruppe>, neben Übermittlungsberechtigung das Kontrollkästchen unter Zulassen, um zuzulassen, dass der ausgewählte Benutzer oder die ausgewählte Gruppe über diesen virtuellen SMTP-Server Nachrichten weiterleiten kann.

  11. Aktivieren Sie neben den Relay-Berechtigungen das Kontrollkästchen unter Zulassen, um dem ausgewählten Objekt die Weiterleitung per Relay über diesen virtuellen SMTP-Server zu ermöglichen, oder aktivieren Sie das Kontrollkästchen unter Verweigern, um dem ausgewählten Objekt die Weiterleitung per Relay über diesen virtuellen Server zu verweigern.

    Hinweis:
    Wenn Sie Relay-Berechtigungen zulassen möchten, müssen Sie Übermittlungsberechtigungen zulassen.

  12. Klicken Sie auf OK.

So konfigurieren Sie in Exchange Server 2000 Relay-Berechtigungen auf virtuellen SMTP-Servern mit Internetzugang

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie in der Konsolenstruktur den Eintrag Server, erweitern Sie den gewünschten Server, erweitern Sie Protokolle, und erweitern Sie dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf den virtuellen SMTP-Server, für den Sie Relay-Einschränkungen festlegen möchten, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie in >Eigenschaften von <Virtueller SMTP-Server auf die Registerkarte Zugriff, und klicken Sie dann auf Relay.

  5. Wählen Sie unter Legen Sie fest, welchen Computern das Relay über diesen virtuellen Server erlaubt ist in den Relay-Einschränkungen die Option Nur Computer in der Liste unten aus.

  6. Klicken Sie auf Hinzufügen, um einen einzelnen Computer, eine Gruppe von Computern oder einen SMTP-Domänennamen hinzuzufügen, und klicken Sie dann auf OK. Wiederholen Sie diesen Schritt für jeden zusätzlichen Eintrag, den Sie hinzufügen möchten.

  7. Wählen Sie Jedem Computer, der erfolgreich authentifiziert ist, unabhängig von der Liste oben das Relay erlauben aus, und klicken Sie dann zweimal auf OK.

Weitere Informationen zum Weiterleiten von Nachrichten per Relay finden Sie in den folgenden Handbüchern der technischen Bibliothek für Exchange Server 2003:

  • Transport- und Routing-Handbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47579).

  • Slowing and Stopping E-mail Transmitted Viruses in an Exchange 2003 Environment (http://go.microsoft.com/fwlink/?linkid=47587)

Weitere Informationen zum Testen und Sichern des Verhaltens offener Relays in einer Exchange- und Microsoft Windows®-Umgebung finden Sie im Microsoft Knowledge Base-Artikel 304897, „SMTP relay behavior in Windows 2000, Windows XP, and Exchange Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=304897).


Das XEXCH50-Verb wird von der aktiven SMTP-Version nicht unterstützt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Netzwerk >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer initiiert eine SMTP-Sitzung beim Exchange-Server, um die richtigen Exchange-SMTP-Verben aufzulisten. Wenn das XEXCH50-Verb nicht aufgelistet wird, wird eine Warnung angezeigt.

Unter anderem wird das XEXCH50-Verb von Exchange für eine Replikation Öffentlicher Ordner verwendet. Wenn Sie eine SMTP-Version auf einem Exchange-Server verwenden, der das XEXCH50-Verb nicht unterstützt, wird die Replikation Öffentlicher Ordner abgebrochen.

Das XEXCH50-Verb wird von anderen SMTP-Anbietern nicht verwendet. Daher wird diese Funktion in einer Datei bereitgestellt (peexch50.dll), die beim Exchange-Setup installiert und registriert wird.

Microsoft Exchange Server Analyzer gibt möglicherweise diese Warnung zurück, wenn Sie ein Antivirusprodukt verwenden, das zum Prüfen von Nachrichten seinen eigenen SMTP-Protokollstapel installiert und verwendet. In diesem Fall verwendet die Antivirussoftware ihren eigenen SMTP-Stapel, um Nachrichten abzufangen und zu prüfen, bevor sie den SMTP-Stapel von Exchange erreichen. In diesem Fall wird das XEXCH50-Verb durch den SMTP-Stapel in der Antivirussoftware nicht verwendet.

Es wird empfohlen, die Antivirussoftware in einem Modus auszuführen, bei dem es nicht erforderlich ist, einen eigenen SMTP-Stapel auf dem Exchange-Server zu installieren, oder eine solche Software am eingehenden Umkreis Ihres SMTP-Netzwerks auszuführen. Wenn Sie den SMTP-Stapel für die Antivirussoftware deaktiviert haben und diese Warnung nach wie vor erhalten, installieren Sie Exchange neu, um peexch50.dll ordnungsgemäß zu installieren und zu registrieren.

Weitere Informationen zu XEXCH50 und anderen von Exchange verwendeten proprietären Verben finden Sie im Microsoft Knowledge Base-Artikel 812455 „Definitions of Verbs That Are Used Between 2 Exchange Servers" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=812455).

Weitere Informationen zum Anzeigen der Befehlsverben in Exchange und zum erneuten Installieren von Exchange 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 319885 „XCON: Messages Sent in the Exchange 2000 Server Organization Are Not Delivered" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319885).

Weitere Informationen zum Anzeigen der Exchange-Befehlsverben und zum erneuten Installieren von Exchange Server 2003 finden Sie im Knowledge Base-Artikel 822939 „Messages That Are Sent in the Exchange Server 2003 Organization Are Not Delivered" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822939).


Protokolle
Microsoft Exchange Server Analyzer-Tools - Artikel >

Letztes Änderungsdatum des Themas: 2005-11-18

In den Artikeln in diesem Abschnitt erhalten Sie ausführliche Informationen darüber, welche Daten in Bezug auf Internetprotokolle Microsoft® Exchange Server Analyzer auswertet. Darüber hinaus beschreiben diese Artikel Aktionen, die Sie durchführen können, um die von Microsoft Exchange Server Analyzer gefundenen Fehler, Warnungen und vom Standard abweichende Konfigurationen im Zusammenhang mit den Internetprotokollen zu beheben.


Antwortfehler bei Active Directory-Round-Trip
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_PingStatus ab, um den Wert (Schlüssel StatusCode) zu bestimmen, der vom Active Directory®-Verzeichnisdienstserver zurückgegeben wird. Win32_PingStatus gibt ein Objekt mit 24 Eigenschaften zurück, die umfangreiche Informationen über die von dieser Klasse gesendeten Ping-Pakete liefern.

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert für diesen Schlüssel mit einem der Werte in der folgenden Tabelle übereinstimmt, wird ein Fehler angezeigt.

Exchange Server Analyzer zeigt den Namen des Active Directory-Servers und den entsprechenden Wert von StatusCode an, der bei diesem Fehler zurückgegeben wird.

Wert StatusCode Bedeutung Beschreibung

11001

Puffer ist zu klein

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11002

Zielnetz ist nicht erreichbar

Anforderung ist fehlgeschlagen, weil das den Zielcomputer enthaltende Netz nicht erreichbar ist. Es gibt keine gültige Route zum Zielcomputer.

Informationen finden Sie im Microsoft Knowledge Base-Artikel 325487 „Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11003

Zielhost ist nicht erreichbar

Die Anforderung ist fehlgeschlagen, weil der Zielcomputer nicht erreichbar ist.

Weitere Informationen finden Sie unter Active Directory-Server ist inaktiv oder nicht erreichbar..

Alternativ kann dieser Fehler durch eine Firewall zwischen dem Computer, auf dem Microsoft Exchange Server Analyzer ausgeführt wird, und dem Zieldomänencontroller oder auch durch einen DNS-Fehler verursacht werden.

Informationen finden Sie im Knowledge Base-Artikel 325487 „Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11004

Zielprotokoll ist nicht erreichbar

Die Anforderung ist fehlgeschlagen, weil der Zielcomputer nicht auf das Protokoll des Pakets antwortet.

Dieser Fehler wird u. U. durch eine Firewall zwischen dem Computer, auf dem Microsoft Exchange Server Analyzer ausgeführt wird, und dem Zieldomänencontroller verursacht.

11005

Zielanschluss ist nicht erreichbar

Die Anforderung ist fehlgeschlagen, weil der Anschluss auf dem Zielcomputer nicht verfügbar ist.

Informationen finden Sie im Knowledge Base-Artikel 325487 „Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11006

Keine Ressourcen

Die Anforderung ist aufgrund unzureichender Netzwerkressourcen fehlgeschlagen.

Informationen finden Sie im Knowledge Base-Artikel 325487 „Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11007

Ungültige Option

Die Anforderung ist fehlgeschlagen, weil sie eine ungültige Option enthält.

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11008

Hardwarefehler

Die Anforderung ist aufgrund eines Hardwarefehlers fehlgeschlagen.

Stellen Sie sicher, dass sich der Domänencontroller in einem geeigneten Betriebszustand befindet, indem Sie das Tool des Computerherstellers zur Hardwarefunktionsüberprüfung ausführen.

11009

Paket ist zu groß

Die Anforderung ist fehlgeschlagen, weil das Paket mit der Anforderung größer ist als die maximale Übertragungseinheit (MTU - Maximum Transmission Unit) eines zwischen Quelle und Ziel befindlichen Knotens (Router oder Gateway). Die MTU definiert die maximale Größe eines zu übertragenden Pakets.

Die von Microsoft Exchange Server Analyzer gesendete Anforderung hat eine maximale Größe von 10 KB. Stellen Sie sicher, dass die Router und Gateways der Organisation ordnungsgemäß konfiguriert sind.

Informationen hierzu finden Sie im Knowledge Base-Artikel 159211, „Diagnose und Behandlung von Black-Hole-Routern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

11010

Anfragetimeout

In der vorgegebenen Zeit ist keine Antwort erfolgt. Die Standardantwortzeit beträgt fünf Sekunden.

Informationen finden Sie im Knowledge Base-Artikel 325487 „Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11011

Ungültige Anforderung

Die Anforderung ist aufgrund einer falschen Verschlüsselung fehlgeschlagen.

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11012

Ungültige Route

Die Anforderung ist fehlgeschlagen, da keine gültige Route zwischen Quell- und Zielcomputer vorhanden ist.

Informationen finden Sie im Knowledge Base-Artikel 325487 „Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11013

TTL-Übertragungsüberschreitung

Die Anforderung ist fehlgeschlagen, weil TTL (Time to Live) den Wert null erreicht hat. Dies führt dazu, dass der Weiterleitungsknoten (Router oder Gateway) das Paket verwirft.

Informationen finden Sie im Knowledge Base-Artikel 325487 „Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11014

Gültigkeitsdauer für Reassemblierung abgelaufenen

Die Anforderung ist fehlgeschlagen, weil das Paket für die Übertragung fragmentiert wurde und nicht alle Fragmente innerhalb der angegebenen Reassemblierungszeit empfangen wurden. RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) legt 60 Sekunden als Zeitlimit fest, innerhalb dessen alle Fragmente des Pakets empfangen werden müssen.

Informationen finden Sie im Knowledge Base-Artikel 325487 „Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11015

Parameterfehler

Die Anforderung ist fehlgeschlagen, da an einem Knoten (Router oder Gateway) Fehler bei der Verarbeitung der Paketkopfzeile aufgetreten sind. Dieser Status kann auftreten, wenn die Kopfzeile z. B. ungültige Felddaten oder nicht erkannte Optionen enthält.

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11016

Quelldrosselung

Die Anforderung ist fehlgeschlagen, da das Paket verworfen wurde. Dies ist der Fall, wenn die Ausgabewarteschlage des Quellcomputers nicht genügend Speicherplatz aufweist oder wenn Pakete den Zielcomputer zu schnell erreichen und deshalb nicht verarbeitet werden können.

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11017

Wert für Option zu groß

Die Anforderung ist fehlgeschlagen, weil sie eine ungültige Option enthält.

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11018

Ungültige Zieladresse

Die Anforderung ist fehlgeschlagen, weil die IP-Adresse des Zielcomputers keine PING-Anforderungen empfangen kann oder nicht in einem Zieladressfeld eines IP-Datagramms enthalten sein soll.

Dies wird möglicherweise durch eine Firewall zwischen dem Computer, auf dem Microsoft Exchange Server Analyzer ausgeführt wird, und dem Zieldomänencontroller verursacht.

11032

IPSEC-Aushandlung

Die Anforderung ist fehlgeschlagen, da keine IPsec-Verbindung ausgehandelt werden konnte.

11050

Allgemeiner Fehler

Die Anforderung ist aufgrund eines unbekannten Fehlers fehlgeschlagen.

Informationen finden Sie im Knowledge Base-Artikel 325487 „Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).


Antwortfehler bei Round-Trip zwischen Active Directory und Exchange Server
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2006-05-15

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_PingStatus ab, um den Schlüsselwert StatusCode zu bestimmen, der vom Active Directory®-Verzeichnisdienstserver zurückgegeben wird. Win32_PingStatus gibt ein Objekt mit 24 Eigenschaften zurück, die umfangreiche Informationen zu der von dieser Klasse gesendeten Ping-Pakete liefern.

Wenn Exchange Server Analyzer feststellt, dass der Wert dieses Schlüssels mit einem der Werte in der folgenden Tabelle übereinstimmt, wird ein Fehler angezeigt.

Exchange Server Analyzer zeigt den Namen des Active Directory-Servers, den Namen des Servers mit Exchange und den entsprechenden Wert von StatusCode an, der bei diesem Fehler zurückgegeben wird.

Wert StatusCode Bedeutung Beschreibung

11001

Puffer ist zu klein

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11002

Zielnetz ist nicht erreichbar

Die Anforderung ist fehlgeschlagen, weil das Netzwerk mit dem Zielcomputer nicht erreichbar ist. Zum Zielcomputer gibt es keine gültige Route.

Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 325487 "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11003

Zielhost ist nicht erreichbar

Die Anforderung ist fehlgeschlagen, weil der Zielcomputer nicht erreichbar ist.

Weitere Informationen finden Sie unter Active Directory-Server ist inaktiv oder nicht erreichbar..

Alternativ kann dieser Fehler folgende Ursachen haben:

  • Eine Firewall zwischen dem Computer, auf dem Microsoft Exchange Server Analyzer ausgeführt wird, und dem Zieldomänencontroller.

  • Ein DNS-Fehler.

Weitere Informationen finden Sie im Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11004

Zielprotokoll ist nicht erreichbar

Die Anforderung ist fehlgeschlagen, weil der Zielcomputer nicht auf das Protokoll des Pakets antwortet.

Dieser Fehler wird u. U. durch eine Firewall zwischen dem Computer, auf dem Microsoft Exchange Server Analyzer ausgeführt wird, und dem Zieldomänencontroller verursacht.

11005

Zielanschluss ist nicht erreichbar

Die Anforderung ist fehlgeschlagen, weil der Port auf dem Zielcomputer nicht verfügbar ist.

Weitere Informationen finden Sie im Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11006

Keine Ressourcen

Die Anforderung ist aufgrund unzureichender Netzwerkressourcen fehlgeschlagen.

Weitere Informationen finden Sie im Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11007

Ungültige Option

Die Anforderung ist fehlgeschlagen, weil sie eine ungültige Option enthält.

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11008

Hardwarefehler

Die Anforderung ist aufgrund eines Hardwarefehlers fehlgeschlagen.

Stellen Sie sicher, dass sich der Domänencontroller in einem geeigneten Betriebszustand befindet, indem Sie das Tool des Computerherstellers zur Hardwarefunktionsüberprüfung ausführen.

11009

Paket ist zu groß

Die Anforderung ist fehlgeschlagen, weil das Paket mit der Anforderung größer ist als die maximale Übertragungseinheit (MTU - Maximum Transmission Unit) eines zwischen Quelle und Ziel befindlichen Knotens (Router oder Gateway). Die MTU definiert die maximale Größe eines zu übertragenden Pakets.

Die von Microsoft Exchange Server Analyzer gesendete Anforderung hat eine maximale Größe von 10 KB. Stellen Sie sicher, dass die Router und Gateways der Organisation ordnungsgemäß konfiguriert sind.

Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 159211, "Diagnose und Behandlung von Black-Hole-Routern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

11010

Anfragetimeout

In der vorgegebenen Zeit ist keine Antwort erfolgt. Die Standardantwortzeit beträgt fünf Sekunden.

Weitere Informationen finden Sie im Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11011

Ungültige Anforderung

Die Anforderung ist aufgrund einer falschen Verschlüsselung fehlgeschlagen.

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11012

Ungültige Route

Die Anforderung ist fehlgeschlagen, da keine gültige Route zwischen Quell- und Zielcomputer vorhanden ist.

Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 325487 „Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11013

TTL-Übertragungsüberschreitung

Die Anforderung ist fehlgeschlagen, weil TTL (Time to Live) den Wert Null erreicht hat. Dies führt dazu, dass der Weiterleitungsknoten (Router oder Gateway) das Paket verwirft.

Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11014

Gültigkeitsdauer für Reassemblierung abgelaufenen

Die Anforderung ist fehlgeschlagen, weil das Paket für die Übertragung fragmentiert wurde und nicht alle Fragmente innerhalb der angegebenen Reassemblierungszeit empfangen wurden. RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) legt 60 Sekunden als Zeitlimit fest, innerhalb dessen alle Fragmente des Pakets empfangen werden müssen.

Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 325487 „Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11015

Parameterfehler

Die Anforderung ist fehlgeschlagen, da an einem Knoten (Router oder Gateway) Fehler bei der Verarbeitung der Paketkopfzeile aufgetreten sind. Dieser Status kann auftreten, wenn die Kopfzeile ungültige Felddaten oder nicht erkannte Optionen enthält.

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11016

Quelldrosselung

Die Anforderung ist fehlgeschlagen, da das Paket verworfen wurde. Dies ist der Fall, wenn die Ausgabewarteschlage des Quellcomputers nicht genügend Speicherplatz aufweist oder wenn Pakete den Zielcomputer zu schnell erreichen und deshalb nicht verarbeitet werden können.

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11017

Wert für Option zu groß

Die Anforderung ist fehlgeschlagen, weil sie eine ungültige Option enthält.

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11018

Ungültige Zieladresse

Die Anforderung ist aus einem der folgenden Gründe fehlgeschlagen:

  • Die IP-Adresse des Zielcomputers kann keine PING-Anforderungen empfangen.

  • Die IP-Adresse des Zielcomputers darf nicht in einem Zieladressfeld eines IP-Datagramms enthalten sein.

Dies wird möglicherweise durch eine Firewall zwischen dem Computer, auf dem Microsoft Exchange Server Analyzer ausgeführt wird, und dem Zieldomänencontroller verursacht.

11032

IPSEC-Aushandlung

Die Anforderung ist fehlgeschlagen, da keine IPsec-Verbindung ausgehandelt werden konnte.

11050

Allgemeiner Fehler

Die Anforderung ist aufgrund eines unbekannten Fehlers fehlgeschlagen.

Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).


Anonymer Zugriff auf die internen virtuellen SMTP-Server und die speziellen virtuellen SMTP-Server für IMAP- und POP-Clients zulässig
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchAuthenticationFlags in der protocolCfgSMTPServer-Klasse für das ExchangeServer-Objekt zu ermitteln. Die Klasse protocolCfgSMTPServer enthält die Einstellungen für einen virtuellen SMTP-Server. Das Attribut msExchAuthenticationFlags stellt die auf dem SMTP-Server zugelassene Art der Authentifizierung dar. Exchange Server Analyzer zeigt eine Warnmeldung an, wenn die folgenden Bedingungen vorliegen:

  • Die Authentifizierung des Attributs msExchAuthenticationFlags wurde für den anonymen Zugriff auf den SMTP-Server konfiguriert.

  • Der Server wird nicht unter Microsoft Small Business Server 2000 oder Microsoft Windows® Small Business Server 2003 ausgeführt.

  • Der Exchange Server-Computer dient als Host für mindestens 20 Postfächer.

Deaktivieren Sie für eine höhere Sicherheit den anonymen Zugriff auf die internen virtuellen SMTP-Server, die keine aus dem Internet eingehenden E-Mail-Nachrichten annehmen. Deaktivieren Sie für eine höhere Sicherheit außerdem den anonymen Zugriff auf die speziellen virtuellen SMTP-Server für ferne IMAP- oder POP-Benutzer.

Wichtig:
Deaktivieren Sie nicht den anonymen Zugriff auf die virtuellen Internet-Bridgehead-SMTP-Server. Die virtuellen SMTP-Server, die E-Mail-Nachrichten aus dem Internet zulassen, müssen für den anonymen Zugriff konfiguriert sein.

Beim Versenden interner Nachrichten authentifizieren sich die Exchange Server in der Organisation gegenseitig für das Senden von Nachrichten. Daher ist es nicht erforderlich, den anonymen Zugriff auf den internen virtuellen SMTP-Servern zu aktivieren. Da der anonyme Zugriff auf interne Server verhindert wird, wird der Nachrichtenfluss nicht unterbrochen. Zusätzlich ist dadurch eine weitere Sicherheitsstufe für die internen virtuellen SMTP-Server gewährleistet.

In ähnlicher Weise authentifizieren sich IMAP- und POP-Clients an den virtuellen SMTP-Servern, bevor sie Nachrichten an die virtuellen SMTP-Server senden. Wenn Sie also spezielle virtuelle SMTP-Server für die IMAP- und POP-Clients verwenden, können Sie diese Server so konfigurieren, dass nur ein authentifizierter Zugriff möglich ist. Wenn Sie den anonymen Zugriff auf diese Server deaktivieren, verhindern Sie damit den Zugriff nicht autorisierter Benutzer auf diese Server.

Wenn Sie aus geschäftlichen Gründen (z. B. Authentifizierung durch ein Partnerunternehmen) den authentifizierten Zugriff auf den virtuellen SMTP-Server nicht deaktivieren können, führen Sie die folgenden Schritte aus, um die Sicherheit auf Ihrem Gatewayserver zu erhöhen:

  • Erzwingen Sie Richtlinien für sichere Kennwörter für alle Benutzerkonten, besonders für Administratorkonten.

  • Deaktivieren Sie das Gastkonto. Weitere Informationen zum Deaktivieren des Gastkontos finden Sie im Microsoft Knowledge Base-Artikel 320053, „How to rename the administrator and guest account in Windows 2000" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320053. Dieser Artikel bezieht sich auf Windows® 2000 Server, jedoch gelten vergleichbare Prinzipien für Windows Server™ 2003.

So deaktivieren Sie die anonyme Zugriffsauthentifizierung für einen virtuellen SMTP-Server

  1. Erweitern Sie im Exchange-System-Manager die Option Server, erweitern Sie <your inbound Exchange server>, erweitern Sie anschließend Protokolle und dann SMTP.

  2. Klicken Sie mit der rechten Maustaste auf Ihren virtuellen SMTP-Eingangsserver, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Zugriff auf Authentifizierung.

  4. Deaktivieren Sie unter Authentifizierung das Kontrollkästchen Anonymer Zugriff.

Weitere Informationen zum Konfigurieren Ihrer Exchange Server 2003-Organisation für das sicherere Senden und Empfangen von E-Mails über das Internet finden Sie im Transport- und Routing-Handbuch für Exchange Server 2003 (http://www.microsoft.com/technet/prodtechnol/exchange/guides/E2k3TransnRouting/52b1df56-0437-47a6-bb66-043f110962c6.mspx).


Hintergrund-Antivirenprüfung wurde aktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungswert, um zu bestimmen, ob die Hintergrund-Antivirenprüfung aktiviert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Eintrag BackgroundScanning auf 1 festgelegt ist, wird eine Warnung angezeigt.

Wenn der Registrierungseintrag BackgroundScanning vorhanden und auf 1 festgelegt wurde, werden alle Nachrichten im Hintergrund jedes Mal erneut überprüft, sobald die Signaturdatei des Antivirenprogramms aktualisiert wird. Da dieses Verhalten jedes Mal, wenn eine Signaturdatei des Antivirenprogramms aktualisiert wird, die Leistung deutlich beeinträchtigt, wird dies nicht von Microsoft empfohlen.

Wenn Sie ein Antivirenprogramm verwenden, das auf VSAPI 2.0 (Virus Scanning Application Programming Interface) basiert, und ein Client versucht, eine Nachricht zu öffnen, wird ein Vergleich ausgeführt, um sicherzustellen, dass der Nachrichtentext und die Anlage von der aktuellen Antiviren-Signaturdatei geprüft wurden. Wenn der Inhalt nicht mithilfe der aktuellen Signaturmusterdatei geprüft wurde, wird die entsprechende Nachricht an das Antivirenprogramm übergeben, bevor die Nachricht dem Client zur Verfügung steht.

Wenn das installierte Antivirenprogramm keine Benutzerschnittstelle enthält, womit die Hintergrundprüfung deaktiviert werden kann, können Sie die unten angegebene Prozedur zum Steuern dieses Verhaltens verwenden, indem Sie die Registrierung auf dem Exchange Server-Computer ändern.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. Doppelklicken Sie im rechten Bereich auf den Wert BackgroundScanning.

  4. Ändern Sie im Feld Datenwerte den Wert in 0.

  5. Schließen Sie den Registrierungseditor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst und Ihre Antivirensoftwaredienste neu, damit die Änderung wirksam wird.
  • Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

  • Weitere Informationen zu den verschiedenen Typen der von Exchange verwendeten Virenprüfprogramme finden Sie im Knowledge Base-Artikel 328841 „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).


Der Wert für „CheckPop3Tail" wurde geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob der folgende Registrierungswert vorhanden ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\CheckPop3Tail

Wenn Exchange Server Analyzer feststellt, dass der Wert für CheckPop3Tail vorhanden und mit 1 konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

IETF (Internet Engineering Task Force) RFC (Request for Comments) 1939 (http://www.ietf.org/rfc/rfc1939.txt) legt die Beendigungssequenz CRLF für POP3-Nachrichten fest. Im Exchange-Sprachgebrauch wird eine CRLF-Sequenz mit POP3Tail bezeichnet. Wenn ein POP3-Client wie Microsoft Office Outlook® 2003 oder Microsoft Outlook Express eine beschädigte Nachricht mit einem falschen POP3Tail findet (wenn beispielsweise CRLF fehlt), kann es vorkommen, dass er nicht mehr reagiert und ein Fehler beim Download der Nachrichten aus dem Posteingang auftritt. Der Registrierungswert CheckPop3Tail stellt eine Konfigurationsmöglichkeit für Administratoren dar, um den Microsoft Exchange-POP3-Dienst anzuweisen, POP3Tail für jede POP3-Nachricht zu prüfen und die korrekte Beendigungssequenz hinzuzufügen, wenn diese fehlt.

Hinweis:
Mit dieser Einstellung werden beschädigte Nachrichten korrigiert, sodass der POP3-Client alle Nachrichten im Posteingang des Benutzers downloaden kann. Es wird jedoch auch zu einer gewissen Leistungsbeeinträchtigung kommen, da jede Nachricht nach einem geeigneten POP3Tail durchsucht wird.

Wenn Sie möchten, können Sie die unten stehende Vorgehensweise verwenden, um den Registrierungswert CheckPop3Tail zu entfernen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So löschen Sie den Registrierungswert „CheckPop3Tail"

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Löschen Sie den Wert mit dem Namen CheckPop3Tail.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Dienst Microsoft Exchange POP3 neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Verwendung des Registrierungswerts CheckPop3Tail finden Sie im Microsoft Knowledge Base-Artikel 816896 „XCCC: POP3 Client Stops Responding (Hangs) or Times Out When You Try to Download Messages" unter (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816896).


Das DMS (Defense Message System) ist aktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob das Attribut heuristics konfiguriert wurde, um das DMS (Defense Message System) zu aktivieren. In der Standardeinstellung ist das Attribut heuristics nicht konfiguriert. Wenn Exchange Server Analyzer erkennt, dass das Attribut heuristics auf 256 festgelegt ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich.

Das DMS-Programm (Defense Message System) wurde vom stellvertretenden Minister für Verteidigung (Akquise) entworfen, um die Entwicklung eines integrierten Nachrichtensystems für alle Benutzer zu fördern und zu koordinieren, das den Anforderungen vom Verfasser bis zum Empfänger der Nachrichten gerecht wird sowie Kosten und Personal einspart. Außerdem sollen damit Funktionalität, Sicherheit, Verfügbarkeit und Belastbarkeit verbessert werden.

Weitere Informationen zum Defense Message System finden Sie auf der Website von Lockheed Martin (http://www.lockheedmartin.com).

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.


Warnung „Disable MAPI clients"
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2007-05-01

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob die MAPI-Client-Blockierung festgelegt wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable MAPI Clients

Wenn Exchange Server Analyzer feststellt, dass der Wert für Disabled MAPI Clients auf einen Wert festgelegt wurde, der mit -10, -11 oder -12 beginnt, zeigt Exchange Server Analyzer eine Warnung an.

In der Standardeinstellung ist der Schlüssel Disable MAPI Clients nicht aktiviert. Daher kann ein Administrator verhindern, dass bestimmte Versionen von Microsoft Office Outlook® eine Verbindung mit einem Computer herstellen, auf dem Exchange 2000 Server, Exchange Server 2003 oder Exchange Server 2007 ausgeführt wird.

Wenn der Schlüssel Disabled MAPI Clients so festgelegt ist, dass der Wert mit -10, -11 oder -12 beginnt, werden ganze Bereiche von MAPI-Versionen blockiert. Diese Bereiche entsprechen den Versionen Outlook 2000, Outlook 2003 und Outlook 2007 sowie der Exchange-Systemaufsicht in Exchange Server 2003. Das Blockieren der Exchange-Systemaufsicht führt häufig zu Fehlfunktionen von Exchange Server.

Um diese Warnung zu vermeiden, befolgen Sie die Empfehlungen und Anweisungen unter Alle Versionen von Outlook können auf den Server zugreifen.

Weitere Informationen zum Verhindern der Verbindung bestimmter MAPI-Clients mit einem Computer, auf dem Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird, finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 328240, „How to put server-side restrictions on clients that are used to access Exchange 2000 mailboxes" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328240)

  • 288894, "How to disable MAPI client access to an Exchange Server 2003 computer or to an Exchange 2000 Server computer" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=288894)

Informationen zum Hindern bestimmter MAPI-Clients am Herstellen einer Verbindung mit einem Computer, auf dem Exchange Server 2007 ausgeführt wird, finden Sie in der Exchange Server 2007-Produktdokumentation unter dem Thema zum Cmdlet "Set-CasMailbox" (http://www.microsoft.com/technet/prodtechnol/exchange/E2k7/DE/Help/ExchHelp/ff7d4dc5-755e-4005-a0a3-631eed3f9b3b.mspx?mfr=true).

Weitere Informationen zum Herunterladen von Sicherheitsupdates für ältere Versionen von Outlook und zum Blockieren anderer Versionen von Outlook finden Sie unter Behindern und Blockieren von E-Mail-Viren in einer Exchange 2003-Umgebung (http://go.microsoft.com/fwlink/?LinkId=30732).


Der Wert "DisableSMTPMailboxAddressing" ist festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2006-08-11

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob der Wert so gesetzt ist, dass die SMTP-Postfachadressierung (Simple Mail Transfer Protocol) deaktiviert wird:

HKeyLocalMachine\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\DisableSMTPMailboxAddressing

Der Wert 1 für den Schlüssel DisableSMTPMailboxAddressing gibt an, dass die SMTP-Postfachadressierung deaktiviert ("true") ist, während der Wert 0 angibt, dass die SMTP-Postfachadressierung nicht deaktiviert ("false") ist.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Schlüssels DisableSMTPMailboxAddressing auf 1 gesetzt ist und somit die SMTP-Postfachadressierung deaktiviert ist, zeigt Exchange Server Analyzer eine Warnung an.

Dieser Fehler weist darauf hin, dass die SMTP-Postfachadressierung deaktiviert ist. Dies kann bei Microsoft Exchange ActiveSync-Clients, die eine Verbindung zu diesem Server herstellen, zu Synchronisierungsfehlern führen.

Um diese Warnung zu beheben, setzen Sie den Wert des Schlüssels DisableSMTPMailboxAddressing auf 0.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema "Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So ändern Sie den Wert des Schlüssels DisableSMTPMailboxAddressing

  1. Öffnen Sie einen Registrierungs-Editor wie zum Beispiel Regedit.exe oder Regedt32.exe.

  2. Navigieren Sie zu:

HKeyLocalMachine\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA

  1. Doppelklicken Sie im rechten Bereich auf DisableSMTPMailboxAddressing

  2. Ändern Sie den Wert von 1 in 0.

  3. Beenden Sie den Registrierungs-Editor, und starten Sie den Serverdienst neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986 "Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zu dem Synchronisierungsfehler, auf den sich diese Warnung bezieht, finden Sie im Microsoft Knowledge Base-Artikel 886346, "Beim Synchronisieren Ihres mobilen Geräts mit Microsoft Exchange Server 2003 wird eine 'HTTP 500'-Fehlermeldung angezeigt" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=886346).


Verteilung der Benutzerlast
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2006-09-06

Microsoft® Exchange Server Analyzer hat festgestellt, dass Ihr Server eine hohe Anzahl von RPC-Operationen pro Sekunde aufweist.

Wenn der Server einen hohen Wert fu¨r RPC-Operationen/Sekunde aufweist, ko¨nnen Sie mithilfe von Exchange Server User Monitor (ExMon) feststellen, wie die Last verteilt ist. Es ist wichtig festzustellen, ob die Last durch einen der folgenden Umsta¨nde bewirkt ist:

  • Es gibt eine relativ kleine Anzahl aktiver Benutzer.

  • Die Last wird auf viele Benutzer verteilt.

Wenn als Ursache fu¨r die hohe Auslastung ein einzelner Benutzer festgestellt wird, zeigt Exchange Server Analyzer eine Warnung an, die besagt, dass der hohe Verbrauch auf einen einzelnen Benutzer zuru¨ckzufu¨hren ist. Wenn dies nicht der Fall ist, zeigt Exchange Server Analyzer eine Nachricht an, die besagt, dass die Belastung u¨ber viele Benutzer verteilt ist.

Hinweis:
RPC-Verkehr schwankt im zeitlichen Verlauf. Wenn Sie statistisch relevante Daten daru¨ber erfassen mo¨chten, wie Benutzer Exchange verwenden, kann es deshalb sein, dass Sie mehrmals Daten erfassen mu¨ssen.

Außerdem ist es typisch, dass einige ha¨ufig verwendete Operationen von Benutzern die CPU kurzzeitig in hohem Maße auslasten. Seien Sie angesichts dieser Aktivita¨ten unbesorgt, vorausgesetzt, derselbe Benutzer lastet große Anteile der CPU-Verwendung nicht ha¨ufig und nicht u¨ber lange Zeitra¨ume aus.

Hinweis:
Diese Warnung können Sie ignorieren, wenn die Ursache der hohen Auslastung ein bekannter Dienst oder Prozess ist, der üblicherweise stark ausgelastet ist, Anforderungen für viele Benutzer verarbeitet und eine höhere Auslastung generiert als einzelne Benutzer. Beispiele für Dienste oder Prozesse, die zu einer höheren Auslastung als einzelne Benutzer führen, sind einige Dienste für die Synchronisierung mobiler Geräte, Serverprozesse, die Frei-/Gebucht-Daten verwalten, Voicemail- oder Unified Messaging-Dienste und Serverprozesse, die Benutzer verschieben.
So beheben Sie dieses Problem

  • Wenn die RPC-Rate hoch ist (fu¨r einen einzelnen oder beliebige Benutzer), finden Sie heraus, ob es Benutzer gibt, die Virensuchprogramme, Plug-Ins von Drittanbietern fu¨r Client-Computer oder mobile Gera¨te verwenden, mit denen die E-Mail mit dem Postfach des Benutzers synchronisiert wird. Weitere Information u¨ber die Fehlerbehebung bei Anwendungen von Drittanbietern finden Sie unter Deaktivieren Sie Add-Ins von Drittanbietern auf dem Client.

  • Benutzer sollten im Standardordner und den intensiv genutzten Ordnern weniger als 5.000 Elemente halten.

  • Als optimale Methode sollten Postfa¨cher 1 GB oder kleiner sein. Benutzer, die die hohe Belastung verursachen, sollten ihre Postfachelemente in einer PST-Datei archivieren. Anschließend ko¨nnen Sie das Tool zur Leistungsu¨berwachung fu¨r Exchange (Perfmon) erneut ausfu¨hren, um festzustellen, ob der Benutzer sta¨ndig hohe Last verursacht.

  • Wenden Sie sich an die Benutzer, um die Clientanwendungen herauszufinden, die mo¨glicherweise auf das Client-E-Mailprogramm zugreifen. Entfernen Sie diese Anwendungen und installieren Sie diese dann einzeln, um ihren Einfluss auf den Server zu beobachten.

  • Fa¨lschlich blockierte Nachrichten sind bei der Problembehebung im Falle von Benutzerlast u¨blich. Deshalb wird empfohlen, dass Sie ExMon nochmals zu einer Zeit mit hoher Last ausfu¨hren. So erkennen Sie, ob die Analyse konsistent ist.

Weitere Informationen

  • Der Exchange Server User Monitor (ExMon) kann im Microsoft Download Center heruntergeladen werden (http://go.microsoft.com/fwlink/?linkid=54474).

  • Weitere Informationen zur Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen zum Beheben von Problemen mit der Leistung von Outlook-Clients finden Sie im Microsoft Knowledge Base-Artikel 905803, „Outlook-Benutzer erfahren Leistungsprobleme bei der Arbeit mit einem Ordner, der zahlreiche Elemente entha¨lt, auf einem Server mit Exchange Server 2003 oder Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803).

  • Weitere Informationen zu Antivirussoftware finden Sie im Microsoft Knowledge Base-Artikel 905184, „Wenn Such-Modul-Desktopsoftware auf Outlook oder anderen MAPI-Client-Computern läuft, kann Leistung von Exchange 2000 Server und Exchange Server 2003 beeinträchtigt werden" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184).


Virtuelles Exchange-Verzeichnis für OMA und EAS wurde außer Kraft gesetzt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die SMTP-Proxyadresse für Exchange ActiveSync® außer Kraft gesetzt wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MasSync\Parameters\ExchangeVDir

Wenn Exchange Server Analyzer erkennt, dass der Registrierungseintrag ExchangeVDir vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Registrierungseintrag ExchangeVDir wird von Microsoft Outlook® Mobile Access und von Exchange ActiveSync verwendet. Er gibt das virtuelle Verzeichnis an, das Outlook Mobile Access und Exchange ActiveSync verwenden, um auf Vorlagen von Microsoft Office Outlook Web Access für Exchange Server 2003 und WebDAV auf den Exchange Server 2003-Back-End-Servern zuzugreifen, auf denen die Benutzerpostfächer gespeichert sind.

Wenn der Eintrag ExchangeVDir nicht vorhanden oder nicht festgelegt ist, wird der Standardwert von /Exchange verwendet. Andernfalls enthält er den Namen des virtuellen Verzeichnisses (einschl. des Zeichens „/"). Sie können diesen Wert konfigurieren, wenn Sie ein virtuelles Verzeichnis für Outlook Mobile Access oder Exchange ActiveSync angeben möchten.

Es gibt ein bekanntes Problem: Unter Exchange Server 2003 funktionieren mobile Exchange-Dienste nicht, wenn die formularbasierte Authentifizierung in einer Topologie mit einem einzigen Exchange Server 2003-Computer verwendet wird. Wenn das virtuelle Verzeichnis /Exchange auf einem Exchange Server 2003-Back-End-Server so konfiguriert ist, dass SSL (Secure Sockets Layer) erforderlich ist, oder wenn die formularbasierte Authentifizierung aktiviert ist, kann Outlook Mobile Access nicht auf dieses virtuelle Verzeichnis zugreifen. Dieses Problem wird umgangen, wenn Sie diese Einstellungen im virtuellen Verzeichnis /Exchange auf einem Front-End-Server aktivieren.

Es gibt eine Konfigurationsmöglichkeit zur Lösung dieses Problems, die die Erstellung des Registrierungswerts ExchangeVDir einschließt.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\MasSync\Parameters

  3. Überprüfen und ändern Sie bei Bedarf den Wert ExchangeVDir.

  4. Schließen Sie den Registrierungs-Editor. Wenn eine Änderung vorgenommen wurde, starten Sie den Exchange Server-Computer neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Beheben dieses Problems finden Sie im Microsoft Knowledge Base-Artikel 817317 „Mapping Multiple Proxy Addresses to Multiple Back-End Virtual Root Directories on the Same Server Is Not Supported" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=817317.


Ein Exchange Virus Scanning API kompatibles Produkt wurde erkannt, das derzeit nicht aktiviert ist.
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die auf dem Computer ausgeführte VSAPI-kompatible Software (Virus Scanning Application Programming Interface) auf dem Exchange Server-Computer aktiviert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Exchange Server Analyzer sendet eine Abfrage an die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile, um den Wert des Schlüssels Version für das Exchange-Datenbankspeichermodul Ese.dll zu ermitteln, das auch als ESE (Extensible Storage Engine) bezeichnet wird.

Schließlich sendet Exchange Server Analyzer auch eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert des Attributs serialNumber für alle Verzeichnisobjekte mit der Objektklasse msExchExchangeServer zu ermitteln. Wenn der Zeichenfolgenwert Version 5,5 einschließt, führt der Computer Microsoft Exchange Server 5,5 aus. Wenn der Zeichenfolgenwert Version 6.0 enthält, wird auf dem Computer Microsoft Exchange 2000 Server ausgeführt. Wenn der Zeichenfolgenwert Version 6.5 einschließt, führt der Computer Microsoft Exchange Server 2003 aus.

Wenn Exchange Server Analyzer feststellt, dass der Wert für Version nicht die Unterzeichenfolge 6 als Teil seiner Versionsinformation enthält, der Wert für serialNumber jedoch angibt, dass Exchange 2000 Server oder Exchange Server 2003 installiert ist, wird auf dem Exchange-Server eine ESE mit einer Nicht-Exchange-Version ausgeführt.

Wenn Exchange Server Analyzer feststellt, dass keine ESE mit einer Nicht-Exchange-Version ausgeführt wird, und dass der Wert des Registrierungsschlüssels VirusScan \Enabled gleich 0 ist, wird eine Warnung angezeigt. Wenn Exchange Server Analyzer feststellt, dass auf dem Exchange Server eine ESE mit einer Nicht-Exchange-Version ausgeführt wird, wird eine separate Warnung angezeigt.

Es wird im Allgemeinen empfohlen, Antivirussoftware bereitzustellen, die für Messaging-Systeme im SMTP-Gateway (Simple Mail Transfer Protocol) oder auf Exchange Server-Computern entwickelt wurden, auf denen sich Postfächer befinden. Für optimalen Schutz führen Sie die Antivirussoftware auf dem Gateway aus, auf dem die eingehenden MIME-Nachrichten überprüft werden. Führen Sie außerdem ein Antivirusprogramm auf dem Exchange Server-Computer aus, der VSAPI 2.0 (Exchange 2000 Server) oder VSAPI 2.5 (Exchange Server 2003) verwendet.

Zusätzlich sollte auf den Client-Computern eine Antivirussoftware ausgeführt werden. Wenn Sie die für Messaging-Systeme entwickelte Antivirussoftware (d. h. Software, die MIME analysieren und überprüfen kann) im Gateway oder auf dem Exchange-Server ausführen, ist es ausreichend, wenn Sie auf den Client-Computern nur ein Antivirenprogramm auf der Dateiebene ausführen.

So beheben Sie diese Warnmeldung

  1. Aktivieren Sie in der Benutzerschnittstelle der Antivirussoftware die VSAPI-Prüfung.

  2. Wenn das Problem nach dem Aktivieren des VSAPI-Scanning bestehen bleibt, wenden Sie sich an den Lieferanten Ihrer Antivirussoftware.

Weitere Informationen zu den in Microsoft Exchange Server 2003 üblicherweise verwendeten Virenprüfprogrammen finden Sie im Microsoft Knowledge Base-Artikel 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Weitere Informationen zu den in Microsoft Exchange 2000 Server üblicherweise verwendeten Virenprüfprogrammen finden Sie im Knowledge Base-Artikel 328841, „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Informationen zum Schutz von Exchange-Umgebungen vor durch E-Mails übertragenen Viren und Würmern finden Sie unter „Behindern und Blockieren von E-Mail-Viren in einer Exchange 2003-Umgebung" (http://go.microsoft.com/fwlink/?LinkId=47587).


Ein Exchange Virus Scanning API-kompatibles Produkt wurde erkannt, das nicht richtig installiert ist.
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag um zu bestimmen, ob die auf dem Computer ausgeführte VSAPI-kompatible Software (Virus Scanning Application Programming Interface) auf eine gültige Bibliothek verweist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Wenn Exchange Server Analyzer ermittelt, dass der Wert für Library keinen gültigen Pfad zu einer VSAPI-Antivirus-Bibliotheksdatei (DLL) enthält, wird eine Warnung angezeigt.

Es wird im Allgemeinen empfohlen, Antivirussoftware bereitzustellen, die für Messaging-Systeme im SMTP-Gateway (Simple Mail Transfer Protocol) oder auf Exchange Server-Computern entwickelt wurden, auf denen sich Postfächer befinden. Für optimalen Schutz führen Sie die Antivirussoftware auf dem Gateway aus, auf dem die eingehenden MIME-Nachrichten überprüft werden. Führen Sie außerdem ein Antivirusprogramm auf dem Exchange Server-Computer aus, der VSAPI 2.0 (Exchange 2000 Server) oder VSAPI 2.5 (Exchange Server 2003) verwendet.

Zusätzlich sollte auf den Client-Computern eine Antivirussoftware ausgeführt werden. Wenn Sie die für Messaging-Systeme entwickelte Antivirussoftware (d. h. Software, die MIME analysieren und überprüfen kann) im Gateway oder auf dem Exchange-Server ausführen, ist es ausreichend, wenn Sie auf den Client-Computern nur ein Antivirenprogramm auf der Dateiebene ausführen.

So beheben Sie diese Warnmeldung

  1. Deinstallieren Sie die Antivirus-Software, und installieren Sie sie anschließend neu.

  2. Wenn das Problem auch nach dem Neuinstallieren bestehen bleibt, wenden Sie sich an den Antivirus-Softwarehersteller.

Weitere Informationen zu den in Microsoft Exchange Server 2003 üblicherweise verwendeten Virenprüfprogrammen finden Sie im Microsoft Knowledge Base-Artikel 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Weitere Informationen zu den in Microsoft Exchange 2000 Server üblicherweise verwendeten Virenprüfprogrammen finden Sie im Knowledge Base-Artikel 328841, „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Informationen zum Schutz von Exchange-Umgebungen vor durch E-Mails übertragenen Viren und Würmern finden Sie unter „Behindern und Blockieren von E-Mail-Viren in einer Exchange 2003-Umgebung" (http://go.microsoft.com/fwlink/?LinkId=47587).


Exchange Virus Scanning API mit geringer Threadanzahl
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um den Wert für ScanningThreads zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Der Registrierungswert ScanningThreads stellt die maximale Anzahl der Virus-Scanning-API-Threads (VSAPI-Threads) dar, die für das Scannen bereitgestellt werden.

Exchange Server Analyzer liest außerdem den folgenden Registrierungseintrag, um zu bestimmen, ob das Scannen von VSAPI-Nachrichten aktiviert ist:

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Der Wert 1 für Enabled gibt an, dass VSAPI-Scanning aktiviert ist. Der Wert 0 gibt an, dass das VSAPI-Scanning nicht aktiviert ist.

Darüber hinaus fragt Exchange Server Analyzer die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_ComputerSystem ab, um den Wert zu bestimmen, der für den Schlüssel NumberOfProcessors festgelegt ist. Dieser Wert stellt die Anzahl der auf dem Computer installierten Prozessoren dar und enthält sowohl die physikalischen als auch die logischen Prozessoren. Mithilfe der Hyper-Threading-Technologie von Intel kann ein physikalischer Prozessor in zwei logische Prozessoren aufgeteilt werden.

Wenn Exchange Server Analyzer feststellt, dass der Wert für ScanningThreads auf einem Exchange Server-Computer mit aktiviertem VSAPI-Scannen kleiner als (2 x Anzahl der Prozessoren) + 1 ist, wird eine Warnmeldung angezeigt. Der optimale Wert für ScanningThreads ist gleich (2 x NumberOfProcessors) + 1. Auf einem Exchange Server-Computer mit zwei Prozessoren ist beispielsweise der optimale Wert für ScanningThreads gleich 5.

Hinweis:
Bei aktiviertem Hyper-Threading beträgt der Wert für NumberOfProcessors das Zweifache der Anzahl der physikalischen Prozessoren. Es wird empfohlen, sich beim Hersteller Ihrer Antivirussoftware zu erkundigen, ob in der obigen Formel physische oder logische Prozessoren verwendet werden sollen.
Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. Doppelklicken Sie im rechten Bereich auf ScanningThreads.

  4. Geben Sie den Wert ein, der aus der obigen Formel zurückgegeben wird.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Hyper-Threading-Technologie finden Sie auf der Intel-Webseite (http://www.intel.com/technology/hyperthread).

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.


Externer DNS-Server wird für SMTP verwendet
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchSMTPExternalDNSServers in der protocolCfgSMTPServer-Klasse für das ExchangeServer-Objekt zu ermitteln. Die Klasse protocolCfgSMTPServer enthält die Einstellungen für einen virtuellen SMTP-Server. Wenn das Attribut msExchSMTPExternalDNSServers festgelegt ist, verwendet der virtuelle SMTP-Server einen externen DNS-Server. Wenn Exchange Server Analyzer feststellt, dass das Attribut msExchSMTPExternalDNSServers festgelegt ist, wird eine Warnung angezeigt.

Wenn Sie Ihren virtuellen SMTP-Server zum Verwenden eines externen DNS-Servers konfigurieren, führt dies möglicherweise zu Leistungsproblemen. Deshalb wird diese Konfiguration nicht empfohlen.

So ändern Sie die Einstellung für externe DNS-Server auf einem virtuellen SMTP-Server

  1. Erweitern Sie im Exchange-System-Manager die Option Server, erweitern Sie <Ihren eingehenden Exchange-Server>, erweitern Sie dann Protokolle, und erweitern Sie anschließend SMTP.

  2. Klicken Sie mit der rechten Maustaste auf den virtuellen SMTP-Server, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Übermittlung auf Erweitert.

  4. Klicken Sie zum Konfigurieren externer DNS-Server auf Konfigurieren.

  5. Klicken Sie zum Hinzufügen eines externen DNS-Servers auf Hinzufügen, geben Sie im Dialogfeld Hinzufügen die IP-Adresse des externen DNS-Servers ein, und klicken Sie dann auf OK.

  6. Sie können einen externen DNA-Server entfernen, indem Sie die IP-Adresse auswählen und auf Entfernen klicken.

  7. Klicken Sie auf OK.

Weitere Informationen zum Konfigurieren von DNS in der Exchange Server 2003-Organisation finden Sie unter „Configuring DNS" im Exchange Server 2003 Transport and Routing Guide (http://go.microsoft.com/fwlink/?LinkId=26041).

Weitere Informationen über das Konfigurieren von SMTP-Connectors zum Verknüpfen von Internetdomänen in Exchange finden Sie im Microsoft Knowledge Base-Artikel „How To Configure the SMTP Connector to Link to Internet Domains in Exchange" unter http://go.microsoft.com/fwlink/?Linkid=3052&kbid=319426.


Der Front-End-Server verwendet die Standardauthentifizierung.
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob die Standardauthentifizierung zwischen einem Front-End-Server und einem Back-End-Server konfiguriert ist:

HKEY_LOCAL_MACHINE\CurrentControlSet\Services\MSExchangeWeb\DAV\UseBasicAuthToBE

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel UseBasicAuthToBE festgelegt wurde, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Als Standard verwenden Exchange 2003 Server-Front-End-Server die Kerberos-Authentifizierung, um die Anmeldeinformationen der Benutzer zwischen den Front-End- und Back-End-Servern zu schützen. Wenn die Kerberos-Authentifizierung fehlschlägt, wird ein Warnereignis protokolliert, und der Front-End-Server verwendet stattdessen NTLM. Wenn NTLM fehlschlägt, wird ein Fehler protokolliert. Der Kerberos-Versuch wird nach 30 Minuten wiederholt. Bei der Authentifizierung von Exchange 2000 Server- oder Exchange Server 2003-Front-End-Computer mit Exchange 2000 Server-Back-End-Computern wird NTLM verwendet.

Wenn der Registrierungsschlüssel UseBasicAuthToBE festgelegt wird, wird diese Standardlogik überschrieben, und die Exchange-Front-End-Server müssen für die gesamte Kommunikation mit Back-End-Server die Standardauthentifizierung verwenden. Wenn mehr als 1000 Postfächer in der Exchange-Organisation vorhanden sind, müssen Sie diesen Registrierungsschlüssel festlegen. Ein bekanntes Problem besteht, wenn Benutzer in Organisationen mit mehr als 1.000 Postfachspeichern von Microsoft Office Outlook® Web Access für Exchange Server 2003 aus über Front-End-Server nicht auf ihre Postfächer zugreifen können.

Wenn nicht mehr als 1.000 Postfächern vorhanden sind und Sie keinen Grund haben, die Standardauthentifizierung zu erzwingen, erwägen Sie, den Registrierungsschlüssel UseBasicAuthToBE zu löschen.

Die Standardauthentifizierung sendet Anmeldeinformationen in Klartext. Wenn Sie einen Exchange-Front-End-Server mit festgelegtem Registrierungsschlüssel UseBasicAuthToBE ausführen, wird die Verwendung der IPSec-Verschlüsselung dringend empfohlen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So löschen Sie den Registrierungsschlüssel UseBasicAuthToBE

  1. Öffnen Sie auf dem Exchange-Front-End-Server einen Registrierungs-Editor, z. B. Regedit.exe oder Regedt32.exe.

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Service\MSExchangeWeb\Dav\ UseBasicAuthToBE.

  3. Klicken Sie mit der rechten Maustaste auf UseBasicAuthToBE, klicken Sie auf Löschen und dann auf Ja.

  4. Öffnen Sie das Dienste-MMC-Snap-In. Klicken Sie mit der rechten Maustaste auf IIS-Verwaltungsdienst, und klicken dann auf Neu starten.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


PING des Gatewayservers nicht erfolgreich
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_PingStatus ab, um den Schlüsselwert StatusCode zu bestimmen, der von einem Nicht-Exchange-Gatewayserver zurückgegeben wird. Win32_PingStatus gibt ein Objekt mit 24 Eigenschaften zurück, die umfangreiche Informationen zu der von dieser Klasse gesendeten Ping-Pakete liefern.

Wenn Exchange Server Analyzer feststellt, dass der Wert dieses Schlüssels mit einem der Werte in der folgenden Tabelle übereinstimmt, wird ein Fehler angezeigt.

Exchange Server Analyzer zeigt den Namen des Gatewayservers, den Namen des Servers mit Exchange und den entsprechenden Wert von StatusCode an, der bei diesem Fehler zurückgegeben wird.

Wert StatusCode Bedeutung Beschreibung

11001

Puffer ist zu klein

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11002

Zielnetz ist nicht erreichbar

Die Anforderung ist fehlgeschlagen, weil das Netzwerk mit dem Zielcomputer nicht erreichbar ist. Zum Zielcomputer gibt es keine gültige Route.

Informationen finden Sie im Microsoft Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11003

Zielhost ist nicht erreichbar

Die Anforderung ist fehlgeschlagen, weil der Zielcomputer nicht erreichbar ist.

Weitere Informationen finden Sie unter Active Directory-Server ist inaktiv oder nicht erreichbar..

Alternativ kann dieser Fehler folgende Ursachen haben:

  • Eine Firewall zwischen dem Computer, auf dem Microsoft Exchange Server Analyzer ausgeführt wird, und dem Zieldomänencontroller.

  • Ein DNS-Fehler.

Weitere Informationen finden Sie im Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11004

Zielprotokoll ist nicht erreichbar

Die Anforderung ist fehlgeschlagen, weil der Zielcomputer nicht auf das Protokoll des Pakets antwortet.

Dieser Fehler wird u. U. durch eine Firewall zwischen dem Computer, auf dem Microsoft Exchange Server Analyzer ausgeführt wird, und dem Zieldomänencontroller verursacht.

11005

Zielanschluss ist nicht erreichbar

Die Anforderung ist fehlgeschlagen, weil der Port auf dem Zielcomputer nicht verfügbar ist.

Weitere Informationen finden Sie im Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11006

Keine Ressourcen

Die Anforderung ist aufgrund unzureichender Netzwerkressourcen fehlgeschlagen.

Weitere Informationen finden Sie im Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11007

Ungültige Option

Die Anforderung ist fehlgeschlagen, weil sie eine ungültige Option enthält.

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11008

Hardwarefehler

Die Anforderung ist aufgrund eines Hardwarefehlers fehlgeschlagen.

Stellen Sie sicher, dass sich der Domänencontroller in einem geeigneten Betriebszustand befindet, indem Sie das Tool des Computerherstellers zur Hardwarefunktionsüberprüfung ausführen.

11009

Paket ist zu groß

Die Anforderung ist fehlgeschlagen, weil das Paket mit der Anforderung größer ist als die maximale Übertragungseinheit (MTU - Maximum Transmission Unit) eines zwischen Quelle und Ziel befindlichen Knotens (Router oder Gateway). Die MTU definiert die maximale Größe eines zu übertragenden Pakets.

Die von Microsoft Exchange Server Analyzer gesendete Anforderung hat eine maximale Größe von 10 KB. Stellen Sie sicher, dass die Router und Gateways der Organisation ordnungsgemäß konfiguriert sind.

Informationen hierzu finden Sie im Knowledge Base-Artikel 159211, "Diagnose und Behandlung von Black-Hole-Routern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

11010

Anfragetimeout

In der vorgegebenen Zeit ist keine Antwort erfolgt. Die Standardantwortzeit beträgt fünf Sekunden.

Weitere Informationen finden Sie im Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11011

Ungültige Anforderung

Die Anforderung ist aufgrund einer falschen Verschlüsselung fehlgeschlagen.

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11012

Ungültige Route

Die Anforderung ist fehlgeschlagen, da keine gültige Route zwischen Quell- und Zielcomputer vorhanden ist.

Weitere Informationen finden Sie im Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11013

TTL-Übertragungsüberschreitung

Die Anforderung ist fehlgeschlagen, weil TTL (Time to Live) den Wert null erreicht hat. Dies führt dazu, dass der Weiterleitungsknoten (Router oder Gateway) das Paket verwirft.

Weitere Informationen finden Sie im Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11014

Gültigkeitsdauer für Reassemblierung abgelaufenen

Die Anforderung ist fehlgeschlagen, weil das Paket für die Übertragung fragmentiert wurde und nicht alle Fragmente innerhalb der angegebenen Reassemblierungszeit empfangen wurden. RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) legt 60 Sekunden als Zeitlimit fest, innerhalb dessen alle Fragmente des Pakets empfangen werden müssen.

Weitere Informationen finden Sie im Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11015

Parameterfehler

Die Anforderung ist fehlgeschlagen, da an einem Knoten (Router oder Gateway) Fehler bei der Verarbeitung der Paketkopfzeile aufgetreten sind. Dieser Status kann auftreten, wenn die Kopfzeile ungültige Felddaten oder nicht erkannte Optionen enthält.

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11016

Quelldrosselung

Die Anforderung ist fehlgeschlagen, da das Paket verworfen wurde. Dies ist der Fall, wenn die Ausgabewarteschlage des Quellcomputers nicht genügend Speicherplatz aufweist oder wenn Pakete den Zielcomputer zu schnell erreichen und deshalb nicht verarbeitet werden können.

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11017

Wert für Option zu groß

Die Anforderung ist fehlgeschlagen, weil sie eine ungültige Option enthält.

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11018

Ungültige Zieladresse

Die Anforderung ist aus einem der folgenden Gründe fehlgeschlagen:

  • Die IP-Adresse des Zielcomputers kann keine PING-Anforderungen empfangen.

  • Die IP-Adresse des Zielcomputers darf nicht in einem Zieladressfeld eines IP-Datagramms enthalten sein.

Dies wird möglicherweise durch eine Firewall zwischen dem Computer, auf dem Microsoft Exchange Server Analyzer ausgeführt wird, und dem Zieldomänencontroller verursacht.

11032

IPSEC-Aushandlung

Die Anforderung ist fehlgeschlagen, da keine IPsec-Verbindung ausgehandelt werden konnte.

11050

Allgemeiner Fehler

Die Anforderung ist aufgrund eines unbekannten Fehlers fehlgeschlagen.

Weitere Informationen finden Sie im Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).


Der Parameter „IIS 6.0 MaxFieldLength" wurde nicht ordnungsgemäß festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob die maximale Feldlänge für HTTP-Anforderungen in der Registrierung hart codiert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters\MaxFieldLength

Microsoft Exchange Server Analyzer untersucht auch den folgenden Registrierungseintrag, um die Version des Microsoft Windows®-Betriebssystems zu ermitteln, das auf dem Zielcomputer ausgeführt wird:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Der Wert 4.0 für CurrentVersion gibt an, dass auf dem Computer Microsoft Windows NT Server 4.0 ausgeführt wird. Der Wert 5.0 zeigt an, dass auf dem Computer ein Microsoft Windows 2000 Server-Betriebssystem ausgeführt wird, und der Wert 5.2 zeigt an, dass auf dem Computer Microsoft Windows Server™ 2003 ausgeführt wird.

Außerdem untersucht Microsoft® Exchange Server Analyzer die WMI-Klasse Exchange_Server im Namespace root\MicrosoftExchangeV2, um den Wert für den Schlüssel IsFrontEndServer zu ermitteln. Der Wert False zeigt an, dass es sich bei dem Exchange Server-Computer um keinen Front-End-Server handelt. Der Wert True zeigt an, dass der Exchange Server-Computer ein Front-End-Server ist.

Exchange Server Analyzer zeigt eine Warnung an, wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert für MaxFieldLength auf einem Exchange-Back-End-Server, für den die folgenden Bedingungen erfüllt sind, nicht auf 32768 festgelegt ist:

  • Auf dem Exchange-Back-End-Server wird Windows Server 2003 ausgeführt.

  • Der Exchange-Back-End-Server ist nicht als Front-End-Server konfiguriert.

  • Der -Back-End-Server mit Exchange hat mehr als 500 Postfächer.

Der IIS-Registrierungsparameter MaxFieldLength (in der Standardeinstellung nicht vorhanden) gibt die maximale Größe für jede einzelne HTTP-Clientanforderung an. Dieser Wert wird i. d. R. zusammen mit dem zugehörigen Wert MaxRequestBytes festgelegt. Wenn diese Werte in größeren Umgebungen nicht auf 32768 festgelegt sind, können für Benutzer von Microsoft Office Outlook® Web Access für Exchange Server Anmeldefehler auftreten. Insbesondere kann eine Abweichung von diesen Werten Fehler der Art „HTTP 400 - Ungültige Anforderung" verursachen. Beim Konfigurieren des Registrierungswerts MaxFieldLength muss auch der Parameter MaxRequestBytes auf 32768 festgelegt werden, damit Benutzer, die Mitglieder von mehr als 75 Gruppen sind, sich bei Outlook Web Access anmelden können. Der Registrierungswert MaxRequestBytes legt die obere Grenze für die Gesamtgröße der Anforderungszeile und der Header fest. Wenn dessen Wert kleiner als MaxFieldLength ist, wird der Wert für MaxFieldLength angepasst.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie die Parameter MaxRequestBytes und MaxFieldLength fest.

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\HTTP\Parameters

  3. Klicken Sie mit der rechten Maustaste auf Parameter, klicken Sie auf Neu | DWORD-Wert, und geben Sie dem Wert den Namen MaxFieldLength.

  4. Klicken Sie mit der rechten Maustaste auf Parameter, klicken Sie auf Neu | DWORD-Wert, und geben Sie dem Wert den Namen MaxRequestBytes.

  5. Doppelklicken Sie im rechten Bereich auf MaxFieldLength, und legen Sie den entsprechenden Wert auf 32768 (dezimal) fest.

  6. Doppelklicken Sie im rechten Bereich auf MaxRequestBytes, und legen Sie den entsprechenden Wert auf 32768 (dezimal) fest.

  7. Beenden Sie den Registrierungs-Editor, und starten Sie den IIS-Administratordienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zu den HTTP-Registrierungseinträgen für IIS (Internetinformationsdienste - Internet Information Service) finden Sie im Knowledge Base-Artikel 820129, „INF: Http.sys Registry Settings for IIS" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=820129.


Der Parameter „IIS 6.0 MaxRequestBytes" wurde nicht ordnungsgemäß festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2007-01-05

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die maximale Größe für HTTP-Anforderungen in der Registrierung hartcodiert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters\MaxRequestBytes

Microsoft Exchange Server Analyzer untersucht auch den folgenden Registrierungseintrag, um die Version des Microsoft Windows®-Betriebssystems zu ermitteln, das auf dem Zielcomputer ausgeführt wird:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Der Wert 4.0 für CurrentVersion gibt an, dass auf dem Computer Microsoft Windows NT Server 4.0 ausgeführt wird. Der Wert 5.0 zeigt an, dass auf dem Computer ein Microsoft Windows 2000 Server-Betriebssystem ausgeführt wird, und der Wert 5.2 zeigt an, dass auf dem Computer Microsoft Windows Server™ 2003 ausgeführt wird.

Abschließend untersucht Microsoft Exchange Server Analyzer die WMI-Klasse Exchange_Server im Namespace root\MicrosoftExchangeV2, um den Wert für den Schlüssel IsFrontEndServer zu bestimmen. Der Wert False zeigt an, dass es sich bei dem Exchange Server-Computer um keinen Front-End-Server handelt. Der Wert True zeigt an, dass der Exchange Server-Computer ein Front-End-Server ist.

Wenn Exchange Server Analyzer feststellt, dass auf einem Exchange-Back-End-Server, für den die nachfolgend genannten Bedingungen gelten, der Wert MaxRequestBytes auf 32768 festgelegt ist, wird eine Warnung angezeigt:

  • Auf dem Exchange-Back-End-Server wird Windows Server 2003 ausgeführt.

  • Der Exchange-Back-End-Server ist nicht als Front-End-Server konfiguriert.

  • Der -Back-End-Server mit Exchange hat mehr als 500 Postfächer.

Der Registrierungswert MaxRequestBytes, der in der Standardeinstellung nicht vorhanden ist, bestimmt die obere Grenze der Gesamtgröße der Anforderungszeile und der Header. Dieser Wert wird normalerweise zusammen mit dem zugehörigen Wert MaxRequestBytesfestgelegt. Der Registrierungsparameter MaxFieldLength IIS gibt die maximale Größe jeder einzelnen HTTP-Clientanforderung an. Wenn diese Werte in größeren Umgebungen nicht auf 32768 festgelegt sind, können für Benutzer von Microsoft Office Outlook® Web Access für Exchange Server Anmeldefehler auftreten. Insbesondere kann eine Abweichung von diesen Werten Fehler der Art „HTTP 400 - Ungültige Anforderung" verursachen. Beim Konfigurieren des Registrierungswerts MaxFieldLength müssen Sie auch den Parameter MaxRequestBytes auf 32768 festlegen, um Benutzern, die Mitglieder in mehr als 75 Gruppen sind, das Anmelden an Outlook Web Access zu ermöglichen. Wenn sein Wert kleiner als MaxFieldLength ist, wird der Wert MaxFieldLength angepasst.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie die Parameter MaxRequestBytes und MaxFieldLength fest.

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\HTTP\Parameters

  3. Klicken Sie mit der rechten Maustaste auf Parameter, klicken Sie auf Neu | DWORD-Wert, und geben Sie als Namen für den Wert MaxFieldLength ein.

  4. Klicken Sie mit der rechten Maustaste auf Parameter, klicken Sie auf Neu | DWORD-Wert, und geben Sie als Namen für den Wert MaxRequestBytes ein.

  5. Doppelklicken Sie im rechten Bereich auf MaxFieldLength, und legen Sie den entsprechenden Wert auf 32768 (dezimal) fest.

  6. Doppelklicken Sie im rechten Bereich auf MaxRequestBytes, und legen Sie den entsprechenden Wert auf 32768 (dezimal) fest.

  7. Beenden Sie den Registrierungs-Editor, und starten Sie den IIS-Administratordienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zu den HTTP-Registrierungseinträgen für IIS (Internetinformationsdienste - Internet Information Service) finden Sie im Knowledge Base-Artikel 820129, „INF: Http.sys Registry Settings for IIS" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=820129.


In der Registrierung wurde das Flag für IMAP4-Kompatibilität festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob der folgende Registrierungswert vorhanden ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\Compatibility

Wenn Microsoft Exchange Server Analyzer Tool erkennt, dass der Wert für Compatibility vorhanden und auf den Wert 0xfffffffe (hexadezimal) konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

IP-Clientcomputer (Internetprotokoll, IP) in Exchange Server mit IMAP4 und POP3 (Post Office Protocol 3) verwenden die Streamingspeicherdatei (STM-Datei) vollständig zum Lesen und Schreiben von Daten. Wenn ein IP-Client das Downloaden von Nachrichten unter Verwendung von POP3 oder IMAP4 anfordert, berechnet der Exchange-Informationsspeicher, der das Postfach des Benutzers enthält, vor dem Übertragen der Nachrichten die genaue Größe der Nachrichten im Posteingang, die an den Client gesendet werden sollen. In großen Umgebungen, besonders in gehosteten Exchange-Umgebungen, kann der Zeitaufwand für die Berechnung sehr hoch sein. Der Wert Compatibility stellt eine Konfigurationsmöglichkeit für Administratoren dar, mit der der Exchange-Informationsspeicher angewiesen werden kann, anstelle der genau berechneten Nachrichtengröße eine ungefähre Nachrichtengröße zu verwenden.

Der Registrierungswert Compatibility ist entsprechend den Angaben in diesem Artikel für den Exchange-Dienst IMAP4 verfügbar. Informationen zum Verwenden des Registrierungswerts mit dem Exchange-Dienst POP3 finden Sie unter In der Registrierung wurde das Flag für POP3-Kompatibilität festgelegt..

Der Registrierungswert Compatibility ist auch nützlich beim Verschieben einer großen Anzahl von Postfächern bzw. von Postfächern mit mehreren MIME-Nachrichten. Beim Verschieben von Daten werden die Daten vom Streamingspeicher in den MAPI-Speicher (EDB-Datei) heraufgestuft. Bei Clients, die mithilfe von POP3 und IMAP4 auf Postfächer zugreifen, treten möglicherweise Leistungsprobleme auf, nachdem ihre Postfächer zwischen Datenbanken oder Servern verschoben wurden. Nachdem sich der Benutzer angemeldet hat, müssen die Nachrichtengrößen berechnet werden, und sowohl im Speicher als auch auf dem Datenträger des Servers wird eine MAPI-zu-MIME-Konvertierung durchgeführt. In Extremfällen werden dabei auf dem Exchange Server-Computer sehr große temporäre Dateien erstellt.

Nicht alle POP3- und IMAP4-Clients funktionieren einwandfrei, wenn der Registrierungswert Compatibility festgelegt ist. Durch Ändern dieser Einstellung können einige ältere Mail-Clients (z. B. Fetchmail) unterbrochen werden. Durch das Festlegen dieses Registrierungsschlüssels wird auch die RFC-Kompatibilität für das IMAP4-Protokoll aufgehoben. Wenn beim Downloaden von Nachrichten mithilfe von POP3 und IMAP4 Probleme auftreten und Sie den Registrierungswert Compatibility verwenden, können Sie den Registrierungswert löschen. Anweisungen hierzu finden Sie in der nachfolgenden Prozedur, die zum Beheben von Fehlern beim Downloaden von Nachrichten verwendet wird.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So löschen Sie den Registrierungswert Compatibility

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. Löschen Sie den Wert mit dem Namen Compatibility.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst und den IIS Verwaltungsdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Verwendung des Registrierungswerts Compatibility finden Sie in den folgenden Knowledge Base-Artikeln:

  • 317722, „XADM: Client Latencies Occur When Exchange 2000 Converts Mail from MAPI to MIME Format" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=317722.

  • 329067, „XADM: Move Mailbox Functionality Promotes Contents of .stm Files" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=329067.


Der IMAP4-Wert „MaxBufferSize" wurde geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2007-08-07

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob der folgende Registrierungswert vorhanden ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

Wenn Exchange Server Analyzer feststellt, dass der Wert MaxBufferSize vorhanden und mit einem numerischen Wert größer als 0 konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Registrierungswert MaxBufferSize wird für die Exchange-Front-End-/Back-End-Topologie verwendet. Er definiert die Größe des TCP/IP-Puffers zwischen Front-End-Server und Back-End-Server. Der Standardwert für die Puffergröße beträgt 1 KB. In Netzwerken mit hoher Wartezeit kann durch Anpassen des Wertes für MaxBufferSize die Leistung von IMAP4-Clients verbessert werden.

Wenn die TCP/IP-Puffergröße über den Registrierungswert MaxBufferSize festgelegt wird, muss sie immer als Vielfaches von 1024 festgelegt werden. Es wird empfohlen, die Leistung der Front-End-/Back-End-Serverkonfiguration mit den folgenden Puffergrößen zu testen, um den optimalen Wert für die betreffende Organisation zu bestimmen:

  • 8192 Bytes

  • 16384 Bytes

  • 32768 Bytes

Es wird empfohlen, für den Registrierungseintrag MaxBufferSize keinen Wert größer als 32768 festzulegen. Wenn Sie für die Puffergröße den Wert 65.536 festlegen, werden Sie möglicherweise feststellen, dass sich die Leistung entsprechend der vorhandenen Netzwerkbedingungen erhöht. Eine höhere Puffergröße beansprucht mehr Arbeitsspeicher auf dem Exchange Server-Computer und kann zu einer Verringerung der Anzahl der Benutzer führen, die auf den Front-End-Server zugreifen können. Der maximale Größe des Registrierungswertes MaxBufferSize ist zwar nicht beschränkt, ein zu großer Wert kann jedoch zu instabiler Leistung und zu Speicherproblemen führen.

Hinweis:
Sie müssen Exchange 2000 Server Service Pack 2 oder höher ausführen, um den Registrierungswert MaxBufferSize verwenden zu können.

Wenn der Registrierungswert MaxBufferSize zu niedrig festgelegt ist, wird keine Leistungssteigerung erzielt und von Exchange Server Analyzer wird eine Fehlermeldung angezeigt (siehe hierzu Der IMAP4-Wert „MaxBufferSize" ist zu niedrig.). Wenn der Registrierungswert MaxBufferSize zu hoch festgelegt ist, kann dies u. U. zu einer Systeminstabilität führen und vom Exchange Server Analyzer wird eine Fehlermeldung angezeigt (siehe hierzu Der IMAP4-Wert „MaxBufferSize" ist zu groß.).

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So konfigurieren Sie den Wert MaxBufferSize

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. Erstellen Sie einen neuen DWORD-Wert mit der Bezeichnung MaxBufferSize.

  4. Doppelklicken Sie auf den Wert MaxBufferSize, und legen Sie den neuen Wert für die Puffergröße (in Byte) fest. Sie können beispielsweise 8192 eingeben, um den Wert auf 8192 Bytes festzulegen.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie den Dienst Microsoft Exchange IMAP4 neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Verwendung des Registrierungswerts MaxBufferSize finden Sie im Knowledge Base-Artikel 823857 „XADM: IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


Der IMAP4-Wert „MaxBufferSize" ist zu groß.
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2007-08-07

Microsoft® Exchange Server Analyzer liest die Registrierung auf dem Exchange Server-Computer, um festzustellen, ob der folgende Registrierungswert vorhanden ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

Wenn Exchange Server Analyzer feststellt, dass der Wert MaxBufferSize vorhanden und mit einem numerischen Wert über 32768 konfiguriert ist, wird eine Warnung angezeigt.

Der Registrierungswert MaxBufferSize wird für die Exchange-Front-End-/Back-End-Topologie verwendet. Er definiert die Größe des TCP/IP-Puffers zwischen Front-End-Server und Back-End-Server. Der Standardwert für die Puffergröße beträgt 1 KB. In Netzwerken mit hoher Wartezeit kann durch Anpassen des Wertes für MaxBufferSize die Leistung von IMAP4-Clients verbessert werden.

Wenn die TCP/IP-Puffergröße über den Registrierungswert MaxBufferSize festgelegt wird, muss sie immer als Vielfaches von 1.024 festgelegt werden. Es wird empfohlen, die Leistung der Front-End-/Back-End-Serverkonfiguration mit den folgenden Puffergrößen zu testen:

  • 8.192 Byte

  • 16.384 Byte

  • 32.768 Byte

Bei Verwendung des Registrierungseintrags muss dieser mindestens auf 1.024 festgelegt werden. Für den Registrierungseintrag MaxBufferSize sollte kein höherer Wert als 32.768 festgelegt werden. Je nach Netzwerkbedingungen kann jedoch eine Puffergröße von 65.536 zu einer Steigerung der Leistung führen. Eine höhere Puffergröße beansprucht mehr Arbeitsspeicher auf dem Exchange Server-Computer und kann zu einer Verringerung der Anzahl der Benutzer führen, die auf den Front-End-Server zugreifen können. Der maximale Wert für den Registrierungswert MaxBufferSize ist zwar nicht beschränkt, ein zu großer Wert kann jedoch zu instabiler Leistung und Speicherproblemen führen.

Hinweis:
Sie müssen Exchange 2000 Server Service Pack 2 oder höher ausführen, um den Registrierungswert MaxBufferSize verwenden zu können.

Wenn Sie für den Registrierungswert MaxBufferSize einen zu niedrigen Wert festlegen, wird sich keine Leistungssteigerung ergeben, und Exchange Server Analyzer zeigt eine Fehlermeldung an (weitere Informationen dazu finden Sie unter Der IMAP4-Wert „MaxBufferSize" ist zu niedrig.). Wenn Sie für den Registrierungswert MaxBufferSize einen zu hohen Wert festlegen, kann das System instabil werden, und Exchange Server Analyzer zeigt eine Fehlermeldung an (weitere Informationen finden Sie in diesem Artikel).

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. Erstellen Sie einen neuen DWORD-Wert mit der Bezeichnung MaxBufferSize.

  4. Doppelklicken Sie auf den Wert MaxBufferSize, und legen Sie den neuen Wert für die Puffergröße (in Byte) fest. Sie können beispielsweise 8192 eingeben, um den Wert auf 8.192 Byte festzulegen.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie den Dienst Microsoft Exchange IMAP4 neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Verwendung des Registrierungswerts MaxBufferSize finden Sie im Knowledge Base-Artikel 823857 „XADM: IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


Der IMAP4-Wert „MaxBufferSize" ist zu niedrig.
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2007-08-07

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob der folgende Registrierungswert vorhanden ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

Wenn Exchange Server Analyzer feststellt, dass der Wert MaxBufferSize vorhanden ist und mit einem numerischen Wert größer als 0 aber kleiner als 1024 konfiguriert ist, wird eine Warnung angezeigt.

Der Registrierungswert MaxBufferSize wird für die Exchange-Front-End-/Back-End-Topologie verwendet. Er definiert die Größe des TCP/IP-Puffers zwischen Front-End-Server und Back-End-Server. Der Standardwert für die Puffergröße beträgt 1 KB. In Netzwerken mit hoher Wartezeit kann durch Anpassen des Wertes für MaxBufferSize die Leistung von IMAP4-Clients verbessert werden.

Wenn die TCP/IP-Puffergröße über den Registrierungswert MaxBufferSize festgelegt wird, muss sie immer als Vielfaches von 1.024 festgelegt werden. Es wird empfohlen, die Leistung der Front-End-/Back-End-Serverkonfiguration mit den folgenden Puffergrößen zu testen, um den optimalen Wert für die betreffende Organisation zu bestimmen:

  • 8.192 Byte

  • 16.384 Byte

  • 32.768 Byte

Bei Verwendung des Registrierungseintrags muss dieser mindestens auf 1.024 festgelegt werden. Für den Registrierungseintrag MaxBufferSize sollte kein höherer Wert als 32.768 festgelegt werden. Je nach Netzwerkbedingungen kann jedoch eine Puffergröße von 65.536 zu einer Steigerung der Leistung führen. Eine höhere Puffergröße beansprucht mehr Arbeitsspeicher auf dem Exchange Server-Computer und kann zu einer Verringerung der Anzahl der Benutzer führen, die auf den Front-End-Server zugreifen können. Der maximale Wert für den Registrierungswert MaxBufferSize ist zwar nicht beschränkt, ein zu großer Wert kann jedoch zu instabiler Leistung und Speicherproblemen führen.

Hinweis:
Sie müssen Exchange 2000 Server Service Pack 2 oder höher ausführen, um den Registrierungswert MaxBufferSize verwenden zu können.

Wenn Sie für den Registrierungswert MaxBufferSize einen zu niedrigen Wert festlegen, wird sich keine Leistungssteigerung ergeben, und Microsoft Exchange Server Analyzer zeigt eine Fehlermeldung an (weitere Informationen dazu finden Sie in diesem Artikel). Wenn Sie für den Registrierungswert MaxBufferSize einen zu hohen Wert festlegen, kann das System instabil werden, und Microsoft Exchange Server Analyzer zeigt eine Fehlermeldung an (weitere Informationen finden Sie unter Der IMAP4-Wert „MaxBufferSize" ist zu groß.).

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So berichtigen Sie diesen Fehler

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. Erstellen Sie einen neuen DWORD-Wert mit der Bezeichnung MaxBufferSize.

  4. Doppelklicken Sie auf den Wert MaxBufferSize, und legen Sie den neuen Wert für die Puffergröße (in Byte) fest. Sie können beispielsweise 8192 eingeben, um den Wert auf 8.192 Byte festzulegen.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie den Dienst Microsoft Exchange IMAP4 neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://support.microsoft.com/?scid=kb%3Bde%3B256986&x=2&y=12, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Verwendung des Registrierungswerts MaxBufferSize finden Sie im Knowledge Base-Artikel 823857 „XADM: IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


Fehler bei MAPI-Operationen
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer hat festgestellt, dass für den Server viele MAPI-Fehler gemeldet werden. Einige MAPI-Operationen geben erwartungsgemäß gelegentlich Fehler zurück. Es kann jedoch zuweilen vorkommen, dass eine Clientanwendung auf einen Fehler nicht ordnungsgemäß reagiert. Im Ergebnis kann die Anwendung erneut die RPC-Anforderung ausgeben, die den Fehler verursachte, als sie dadurch nämlich die Last auf dem Server erhöhte.

Ein Beispiel für einen häufigen Client-Fehler besteht darin, dass ein MAPI-Client eine Liste von Objekten in Stapeln anfordert und diese Elemente auch weiter anfordert, nachdem die Anforderung von Exchange zurückgegeben worden ist. Ein Clientcomputer kann z. B. alle Elemente in einem bestimmten Ordner abfragen, die eine Anlage enthalten. Die Client kann weiterhin fordern, dass die Elemente in Gruppen von jeweils 30 zurückgegeben werden. Manchmal fordert der Client einen neuen Stapel von 30 Elementen an, nachdem der Exchange-Server das letzte Element in der Anforderung zurückgegeben hat. In diesen Fällen gibt Exchange den Fehler „Nicht gefunden" zurück. Wenn der Clientcomputer sogar noch nach der Zurückgabe des Fehlers „Nicht gefunden" weiterhin Elemente anfordert, reagiert der Clientcomputer auf den Fehler nicht ordnungsgemäß. In diesem Szenario würde Exchange Server User Monitor (ExMon) mehrere MAPI-Fehler melden. Obgleich das Verhältnis von Fehlern zur Anzahl der Operationen hoch ist, ist in diesem Fall die hohe Fehlerrate erwartet. Bei folgenden MAPI-Operationen sind hohe Fehlerraten zu erwarten: GetPerUserGuid, ImportMsgMove und Logon.

So beheben Sie diesen Fehler

  1. Mit ExMon können Sie bestimmen, welcher Benutzer oder welche Gruppe von Benutzern die hohe Anzahl von MAPI-Fehlern verursacht.

  2. Stellen Sie fest, welche Anwendung auf dem Clientcomputer dieses Problem verursacht.

  3. Reparieren oder entfernen Sie die Anwendung, die das Problem verursacht.

Weitere Informationen

  • Weitere Informationen zur Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=de).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=de).


„MaxClientRequestBuffer" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungsschlüssel, um festzustellen, ob der Schlüssel vorhanden ist:

HKEY_LOCAL_MACHINE System\CurrentControlSet\w3svc\Parameters\MaxClientRequestBuffer

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel MaxClientRequestBuffer festgelegt ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In der Standardeinstellung ist dieser Registrierungswert nicht vorhanden.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zum Registrierungsschlüssel MaxClientRequestBuffer finden Sie im Microsoft Knowledge Base-Artikel 260694 „Description of the MaxClientRequestBuffer Registry Value" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260694).


Der Wert für „MaxClientRequestBuffer" ist zu niedrig.
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungsschlüssel, um den Datenwert für MaxClientRequestBuffer zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

Wenn Exchange Server Analyzer feststellt, dass der Datenwert für MaxClientRequestBuffer geringer als 16384 ist, wird von dem Tool eine Warnung ausgegeben.

Wenn der Wert für MaxClientRequestBuffer zu niedrig ist, kann dies bei Microsoft Office Outlook® Web Access-Benutzern zu Fehlern führen. Insbesondere kann es dazu kommen, dass HTTP 400 - Bad Request an den Browser zurückgegeben wird. Um diese Warnung zu beheben, wird empfohlen, entweder den Wert auf eine Zahl größer als 16.384 zu erhöhen oder den Registrierungswert zu entfernen und auf diese Weise zu den Standardeinstellungen zurückzukehren. Der Wert MaxClientRequestBuffers ist in der Standardeinstellung nicht vorhanden.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So beheben Sie diese Warnung durch Erhöhen des Datenwerts

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

  3. Doppelklicken Sie auf den Wert MaxClientRequestBuffer, und bearbeiten Sie die Datenwerte. Legen Sie den Datenwert auf eine Dezimalzahl fest, die gleich oder größer als 16384 ist.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie anschließend den Exchange-Server erneut.
So beheben Sie die Warnung durch Entfernen des Werts

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

  3. Klicken Sie mit der rechten Maustaste auf den Wert MaxClientRequestBuffer, und klicken Sie dann auf Löschen.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Exchange-Server erneut.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zum Registrierungswert MaxClientRequestBuffer finden Sie im Microsoft Knowledge Base-Artikel 260694 „Description of the MaxClientRequestBuffer Registry Value" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260694).


Mehrere SMTP-Anschlussbindungen konfiguriert
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob der eingestellte Wert für das Attribut msExchServerBindings für mehrere Anschlussbindungen konfiguriert ist. In der Standardeinstellung ist das Attribut msExchServerBindings für TCP-Anschluss 25 konfiguriert. Wenn Microsoft Exchange Server Analyzer feststellt, dass das Attribut msExchServerBindings für mehrere Anschlussbindungen konfiguriert ist, zeigt Exchange Server Analyzer an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Das Attribut msExchServerBindings stellt den TCP-Anschluss dar, der vom SMTP-Server (Simple Mail Transfer Protocol) auf eingehende Verbindungen überwacht wird. Sie können virtuelle SMTP-Server für die Überwachung eines oder mehrerer TCP-Anschlüsse konfigurieren. In der Standardeinstellung sind alle virtuellen SMTP-Server für die Überwachung von TCP-Anschluss 25 konfiguriert. Wenn Sie Ihre interne Messagingstruktur entsprechend anpassen, können Sie den Wert für den Abhöranschluss für SMTP ändern. Für virtuelle SMTP-Server, die direkt aus dem Internet eingehende Nachrichten akzeptieren, sollte jedoch im Allgemeinen der Anschluss 25 verwendet werden, da SMTP-Server im Internet Nachrichten über Anschluss 25 senden.

Beachten Sie, dass Exchange Server Analyzer den Wert für den virtuellen Exchange-SMTP-Protokollserver untersucht. Bei diesem virtuellen Exchange-SMTP-Protokollserver kann es sich um den SMTP-Server handeln, der Nachrichten direkt aus dem Internet empfängt, dies muss aber nicht der Fall sein. Manche Antivirus- und Anti-Spam-Produkte sind dafür entwickelt, SMTP-Nachrichten aus dem Internet über Anschluss 25 zu empfangen und sie an einen virtuellen Exchange-SMTP-Server oder einen anderen Anschluss weiterzuleiten.

So können Sie den Abhöranschluss des virtuellen SMTP-Servers anzeigen oder ändern

  1. Erweitern Sie im Exchange-System-Manager die Option Server, erweitern Sie einen Exchange-Server, erweitern Sie dann Protokolle, und erweitern Sie anschließend SMTP.

  2. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise Virtueller Standardserver für SMTP), und klicken Sie dann auf Eigenschaften.

  3. Wählen Sie die Registerkarte Allgemein aus, und klicken Sie dann auf Erweitert.

  4. Eine Liste mit IP-Adressen und Anschlüssen wird angezeigt.

    • Sie können den vorhandenen Anschluss ändern, indem Sie die IP-Adresse auswählen und auf Bearbeiten klicken.

    • Sie können einen vorhandenen Port entfernen, indem Sie die IP-Adresse auswählen und auf Entfernen klicken.

  5. Klicken Sie auf OK, um die Änderungen zu speichern. Klicken Sie dann auf OK, um das Dialogfeld Erweitert zu schließen.

  6. Klicken Sie auf OK, um das Dialogfeld Eigenschaften des virtuellen SMTP-Servers zu schließen.

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 266686, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


PING-Antwot hat eine unterschiedliche Größe
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_PingStatus mit bestimmten Einstellungswerten für BufferSize ab und vergleicht diese mit den zurückgegebenen Werten für BufferSize, um zu bestimmen, ob sie identisch sind.

Wenn der zurückgegebene Wert von BufferSize sich vom gesendeten Wert unterscheidet, wird von Exchange Server Analyzer eine Warnung angezeigt.

Diese Warnung gibt an, dass das Paket irgendwann während der Übertragung abgeschnitten wurde. Dies kann ein Hinweis auf einen allgemeinen Netzwerkfehler oder das Vorhandensein eines so genannten Black-Hole-Routers in der Umgebung sein.

In einem TCP/IP-WAN (Wide Area Network) kann die Kommunikation über bestimmte Routen fehlgeschlagen, wenn Netzwerkzwischensegmente kleinere Paketgrößen als die kommunizierenden Hosts aufweisen und wenn Router nicht die entsprechenden ICMP-Antworten auf diese Bedingung senden. Auch die Firewall im Pfad kann für ein Löschen solcher Antworten sorgen. Ein Router, der diese Bedingung verursacht, wird mitunter als Black-Hole-Router bezeichnet.

Das Vorhandensein eines Black-Hole-Routers kann eine Vielzahl von Fehlern verursachen, die nicht auftreten, wenn ein Programm sich mit einem Computer im lokalen Subnetz verbindet. Das Verhalten scheint ggf. nur zeitweise aufzutreten, doch wenn Sie die Umstände sorgfältiger untersuchen, werden Sie u. U. feststellen, dass Sie das Verhalten reproduzieren können, indem Sie z. B. einen Client eine von einem Remotehost gesendete große Datei lesen lassen.

Weitere Informationen finden Sie in den Anleitungen im Microsoft Knowledge Base-Artikel 314825, "Behebung von Problemen mit Black-Hole-Routern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825).

Weitere Informationen

Weitere Informationen zum Erkennen von und dem Umgang mit Black-Hole-Routern finden Sie in den folgenden Ressourcen:

  • Microsoft Knowledge Base-Artikel 159211, "Diagnose und Behandlung von Black-Hole-Routern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

  • "Path Maximum Transmission Unit (PMTU) Black Hole Routers" (http://go.microsoft.com/fwlink/?LinkId=66963).


Es wurde kein Ping-Test ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2006-08-09

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_PingStatus ab, um das Antwortobjekt im Hinblick auf verschiedene Konfigurationseinstellungen zu überprüfen, die sich speziell auf die Nachrichtenübermittlung beziehen.

Win32_PingStatus gibt in der Regel ein Objekt mit 24 Eigenschaften zurück, die umfangreiche Informationen zu den von dieser Klasse gesendeten Ping-Pakete liefern.

Wenn Exchange Server Analyzer nach sechs aufeinander folgenden Versuchen das erwartete Objekt nicht auf seine Abfrage erhält, zeigt Exchange Server Analyzer eine Warnung an.

Diese Warnung gibt an, dass Win32_PingStatus nicht durchgeführt werden konnte.

Die häufigste Ursache für diesen Fehler ist, dass auf dem Computer, auf dem der Befehl Win32_PingStatus ausgeführt wird, das Betriebssystem Microsoft Windows® 2000 Server ausgeführt wird. Windows 2000 Server bietet keine Unterstützung der WMI-Klasse Win32_PingStatus.

Wird auf dem Computer, auf dem der Befehl Win32_PingStatus ausgeführt wird, nicht das Betriebssystem Windows 2000 Server ausgeführt, können die Ursache des Problems allgemeine Netzwerkprobleme oder Probleme mit Berechtigungen sein.

So beheben Sie diesen Fehler

  1. Stellen Sie sicher, dass der Exchange Server-Computer gestartet wurde und mit dem Netzwerk verbunden ist.

  2. Führen Sie den Befehl PING auf dem Computer aus, auf dem Exchange Server Analyzer ausgeführt wird, um festzustellen, ob eine Verbindung mit dem Exchange Server-Computer hergestellt werden kann.

  3. Führen Sie den Befehl PING auf einem Server aus, der sich im selben Subnetz wie der als Ziel fungierende Exchange-Server befindet, um festzustellen, ob eine Verbindung mit dem als Ziel fungierenden Exchange Server-Computer hergestellt werden kann.

  4. Wenn eine Firewall vorhanden ist, überprüfen Sie, ob die RPC-Anschlüsse (Remote Procedure Call) blockiert sind.

  5. Überprüfen Sie die Berechtigungen für das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird. Das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird, muss über lokale Administratorberechtigungen für jeden durchsuchten Exchange-Server verfügen.

Weitere Informationen zu Problemen mit Netzwerkverbindungen finden Sie im Microsoft Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Weitere Informationen zu Verbindungsproblemen und Exchange Server Best Practices Analyzer finden Sie unter "Problembehandlung bei Verbindungsproblemen mit Microsoft Exchange Server Best Practices Analyzer" (http://go.microsoft.com/fwlink/?LinkId=56285).

Weitere Informationen zu der WMI-Klasse Win32_PingStatus finden Sie im MSDN®-Artikel, "Win32_PingStatus" (http://go.microsoft.com/fwlink/?linkid=33549).


Die Antivirusprüfung für unformatierten Text wurde deaktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um den Wert für die Virenprüfung von RTF-Nachrichten (Rich Text Format) zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Wenn Exchange Server Analyzer feststellt, dass der Wert von ScanPlainText auf 0 festgelegt ist, wird eine Warnung angezeigt.

Der Registrierungsschlüssel ScanPlainText wurde von externen Antivirus-Lieferanten gesetzt, die Exchange Virus Scanning API (VSAPI) verwenden. Es wird empfohlen, alle Nachrichtentypen, also auch Nur-Text-Nachrichten, auf Viren zu prüfen. Sie sollten eine Virusprüfung für alle Nachrichten aktivieren, die einen Exchange Server-Computer passieren.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diesen Fehler

  • Aktivieren Sie in Ihrer Exchange-Antivirenanwendung die Virenprüfung aller Nachrichten.

    - oder -

  • Verändern Sie manuell den Eintrag in Ihrer Registrierung, indem Sie den folgenden Vorgang ausführen:

    1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

    2. Navigieren Sie zu:

      HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

    3. Doppelklicken Sie auf den Registierungswert ScanPlainText, und legen Sie den Datenwert auf 1 fest.

    4. Beenden Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst und die Exchange-Antivirensoftwaredienste neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Virenbekämpfung finden Sie auf der Website „Behindern und Blockieren von E-Mail-Viren in einer Exchange 2003-Umgebung" unter http://go.microsoft.com/fwlink/?LinkId=47587.


In der Registrierung wurde das Flag für POP3-Kompatibilität festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob der folgende Registrierungswert vorhanden ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\Compatibility

Wenn Microsoft Exchange Server Analyzer Tool erkennt, dass der Wert für Compatibility vorhanden und auf den Wert 0xfffffffe (hexadezimal) konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

IP-Clientcomputer (Internetprotokol, IP) in Exchange Server mit IMAP4 und POP3 (Post Office Protocol 3) verwenden die Streamingspeicherdatei (STM-Datei) vollständig zum Lesen und Schreiben von Daten. Wenn ein IP-Client das Downloaden von Nachrichten unter Verwendung von POP3 oder IMAP4 anfordert, berechnet der Exchange-Informationsspeicher, der das Postfach des Benutzers enthält, vor dem Übertragen der Nachrichten die genaue Größe der Nachrichten im Posteingang, die an den Client gesendet werden sollen. In großen Umgebungen, vor allem in gehosteten Exchange-Umgebungen, kann diese Berechnung viel Zeit beanspruchen. Der Wert Compatibility stellt eine Konfigurationsmöglichkeit für Administratoren dar, mit der der Exchange-Informationsspeicher angewiesen werden kann, anstelle der genau berechneten Nachrichtengröße eine ungefähre Nachrichtengröße zu verwenden.

Der Registrierungswert Compatibility ist entsprechend den Angaben in diesem Artikel für den Exchange-Dienst POP3 verfügbar. Informationen zum Verwenden des Registrierungswertes mit dem Exchange-Dienst IMAP4 finden Sie unter In der Registrierung wurde das Flag für IMAP4-Kompatibilität festgelegt..

Der Registrierungswert Compatibility ist außerdem nützlich beim Verschieben einer großen Anzahl von Postfächern oder von Postfächern mit einer großen Anzahl von MIME-Nachrichten (Multipurpose Internet Mail Extensions). Beim Verschieben von Daten werden die Daten vom Streamingspeicher in den MAPI-Speicher (EDB-Datei) heraufgestuft. Bei Clients, die mithilfe von POP3 und IMAP4 auf Postfächer zugreifen, treten möglicherweise Leistungsprobleme auf, nachdem ihre Postfächer zwischen Datenbanken oder Servern verschoben wurden. Nachdem sich der Benutzer angemeldet hat, müssen die Nachrichtengrößen berechnet werden, und sowohl im Speicher als auch auf dem Datenträger des Servers wird eine MAPI-zu-MIME-Konvertierung durchgeführt. In Extremfällen werden dabei auf dem Exchange Server-Computer sehr große temporäre Dateien erstellt.

Nicht alle POP3- und IMAP4-Clients funktionieren einwandfrei, wenn der Registrierungswert Compatibility festgelegt ist. Durch das Ändern dieser Einstellung werden einige ältere E-Mail-Clients (z. B: Fetchmail) unterbrochen. Durch das Festlegen dieses Registrierungsschlüssels wird auch die RFC-Kompatibilität für das POP3-Protokoll aufgehoben. Wenn beim Downloaden von Nachrichten mithilfe von POP3 und IMAP4 Probleme auftreten und Sie den Registrierungswert Compatibility verwenden, können Sie den Registrierungswert löschen. Anweisungen finden Sie in der unten stehenden Vorgehensweise, die zum Beheben von Fehlern beim Downloaden von Nachrichten verwendet wird.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So löschen Sie den Registrierungswert Compatibility

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Löschen Sie den Wert Compatibility.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst und den IIS Verwaltungsdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Verwendung des Registrierungswerts Compatibility finden Sie in den folgenden Knowledge Base-Artikeln:

  • 317722, „XADM: Client Latencies Occur When Exchange 2000 Converts Mail from MAPI to MIME Format" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=317722.

  • 329067, „XADM: Move Mailbox Functionality Promotes Contents of .stm Files" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=329067.


Der Wert „POP3-MaxBufferSize" wurde geändert
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob der folgende Registrierungswert vorhanden ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

Wenn Exchange Server Analyzer feststellt, dass der Wert MaxBufferSize vorhanden und mit einem numerischen Wert größer als 0 konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Registrierungswert MaxBufferSize wird für die Exchange-Front-End-/Back-End-Topologie verwendet. Er definiert die Größe des TCP/IP-Puffers zwischen Front-End-Server und Back-End-Server. Der Standardwert für die Puffergröße beträgt 1 KB. In Netzwerken mit hoher Wartezeit kann durch Anpassen des Wertes für MaxBufferSize die Leistung für POP3-Clients verbessert werden.

Wenn die TCP/IP-Puffergröße durch den Registrierungswert MaxBufferSize festgelegt wird, muss sie immer als Vielfaches von 1.024 festgelegt werden. Es wird empfohlen, die Leistung der Front-End-/Back-End-Serverkonfiguration mit den folgenden Puffergrößen zu testen:

  • 8.192 Bytes

  • 16.384 Bytes

  • 32.768 Bytes

Bei Verwendung dieses Registrierungseintrags muss dieser mindestens auf 1.024 gesetzt werden. Für den Registrierungseintrag MaxBufferSize sollte kein höherer Wert als 32.768 festgelegt werden. Je nach Netzwerkbedingungen kann jedoch eine Puffergröße von 65.536 zu einer Steigerung der Leistung führen. Eine höhere Puffergröße beansprucht mehr Arbeitsspeicher auf dem Exchange Server-Computer und kann zu einer Verringerung der Anzahl der Benutzer führen, die auf den Front-End-Server zugreifen können. Der maximale Größe des Registrierungswertes MaxBufferSize ist zwar nicht beschränkt, ein zu großer Wert kann jedoch zu instabiler Leistung und zu Speicherproblemen führen.

Hinweis:
Sie müssen Exchange 2000 Server Service Pack 2 oder höher ausführen, um den Registrierungswert MaxBufferSize verwenden zu können.

Wenn Sie für den Registrierungswert MaxBufferSize einen zu niedrigen Wert festlegen, wird sich keine Leistungssteigerung ergeben, und Exchange Server Analyzer zeigt eine Fehlermeldung an (weitere Informationen dazu finden Sie unter Der POP3-Wert „MaxBufferSize" ist zu niedrig.). Wenn Sie für den Registrierungswert MaxBufferSize einen zu hohen Wert festlegen, kann das System instabil werden, und MicrosoftMicrosoft Exchange Server Analyzer zeigt eine Fehlermeldung an (weitere Informationen finden Sie unter POP3-MaxBufferSize-Wert ist zu groß.).

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So berichtigen Sie diesen Fehler

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Erstellen Sie einen neuen DWORD-Wert mit der Bezeichnung MaxBufferSize.

  4. Doppelklicken Sie auf den Wert MaxBufferSize, und legen Sie den neuen Wert für die Puffergröße (in Byte) fest. Sie können beispielsweise 8192 eingeben, um den Wert auf 8192 Bytes festzulegen.

  5. Beenden Sie den Registrierungs-Editor, und starten Sie den Dienst Microsoft Exchange POP3 neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Verwendung des Registrierungswerts MaxBufferSize finden Sie im Knowledge Base-Artikel 823857 „XADM: IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


POP3-MaxBufferSize-Wert ist zu groß.
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob der folgende Registrierungswert vorhanden ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

Wenn Microsoft Exchange Server Analyzer Tool feststellt, dass der Wert MaxBufferSize vorhanden und mit einem numerischen Wert größer als 32768 konfiguriert ist, wird eine Warnung angezeigt.

Der Registrierungswert MaxBufferSize wird für die Exchange-Front-End-/Back-End-Topologie verwendet. Er definiert die Größe des TCP/IP-Puffers zwischen Front-End-Server und Back-End-Server. Der Standardwert für die Puffergröße beträgt 1 KB. In Netzwerken mit hoher Wartezeit kann durch Anpassen des Wertes für MaxBufferSize die Leistung für POP3-Clients verbessert werden.

Wenn die TCP/IP-Puffergröße durch den Registrierungswert MaxBufferSize festgelegt wird, muss sie immer als Vielfaches von 1.024 festgelegt werden. Es wird empfohlen, die Leistung der Front-End-/Back-End-Serverkonfiguration mit den folgenden Puffergrößen zu testen:

  • 8192 Byte

  • 16384 Byte

  • 32768 Byte

Bei Verwendung des Registrierungseintrags muss dieser mindestens auf 1.024 festgelegt werden. Für den Registrierungseintrag MaxBufferSize sollte kein höherer Wert als 32.768 festgelegt werden. Je nach Netzwerkbedingungen kann jedoch eine Puffergröße von 65.535 zu einer Steigerung der Leistung führen. Eine höhere Puffergröße beansprucht mehr Arbeitsspeicher auf dem Exchange Server-Computer und kann zu einer Verringerung der Anzahl der Benutzer führen, die auf den Front-End-Server zugreifen können. Der maximale Größe des Registrierungswertes MaxBufferSize ist zwar nicht beschränkt, ein zu großer Wert kann jedoch zu instabiler Leistung und zu Speicherproblemen führen.

Hinweis:
Sie müssen Exchange 2000 Server Service Pack 2 oder höher ausführen, um den Registrierungswert MaxBufferSize verwenden zu können.

Wenn Sie für den Registrierungswert MaxBufferSize einen zu niedrigen Wert festlegen, wird sich keine Leistungssteigerung ergeben, und Exchange Server Analyzer zeigt eine Fehlermeldung an (weitere Informationen dazu finden Sie unter Der POP3-Wert „MaxBufferSize" ist zu niedrig.). Wenn Sie für den Registrierungswert MaxBufferSize einen zu hohen Wert festlegen, kann das System instabil werden, und Exchange Server Analyzer zeigt eine Fehlermeldung an (weitere Informationen finden Sie in diesem Artikel).

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diesen Fehler

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Erstellen Sie einen neuen DWORD-Wert mit der Bezeichnung MaxBufferSize.

  4. Doppelklicken Sie auf den Wert MaxBufferSize, und legen Sie den neuen Wert für die Puffergröße (in Byte) fest. Sie können beispielsweise 8192 eingeben, um den Wert auf 8192 Bytes festzulegen.

  5. Beenden Sie den Registrierungs-Editor, und starten Sie den Dienst Microsoft Exchange POP3 neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Verwendung des Registrierungswerts MaxBufferSize finden Sie im Knowledge Base-Artikel 823857 „XADM: IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


Der POP3-Wert „MaxBufferSize" ist zu niedrig.
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob der folgende Registrierungswert vorhanden ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

Wenn Exchange Server Analyzer feststellt, dass der Wert MaxBufferSize vorhanden ist und mit einem numerischen Wert größer als 0 aber kleiner als 1024 konfiguriert ist, wird eine Warnung angezeigt.

Der Registrierungswert MaxBufferSize wird für die Exchange-Front-End-/Back-End-Topologie verwendet. Er definiert die Größe des TCP/IP-Puffers zwischen Front-End-Server und Back-End-Server. Der Standardwert für die Puffergröße beträgt 1 KB. In Netzwerken mit hoher Wartezeit kann durch Anpassen des Werts für MaxBufferSize die Leistung für POP3-Clients verbessert werden.

Wenn die TCP/IP-Puffergröße über den Registrierungswert MaxBufferSize festgelegt wird, muss sie immer als Vielfaches von 1024 festgelegt werden. Es wird empfohlen, die Leistung der Front-End-/Back-End-Serverkonfiguration mit den folgenden Puffergrößen zu testen, um den optimalen Wert für die betreffende Organisation zu bestimmen:

  • 8.192 Bytes

  • 16.384 Bytes

  • 32.768 Bytes

Bei Verwendung des Registrierungseintrags muss dieser mindestens auf 1.024 festgelegt werden. Für den Registrierungseintrag MaxBufferSize sollte kein höherer Wert als 32.768 festgelegt werden. Je nach Netzwerkbedingungen kann jedoch eine Puffergröße von 65.535 zu einer Steigerung der Leistung führen. Eine höhere Puffergröße beansprucht mehr Arbeitsspeicher auf dem Exchange Server-Computer und kann zu einer Verringerung der Anzahl der Benutzer führen, die auf den Front-End-Server zugreifen können. Der maximale Größe des Registrierungswertes MaxBufferSize ist zwar nicht beschränkt, ein zu großer Wert kann jedoch zu instabiler Leistung und zu Speicherproblemen führen.

Hinweis:
Sie müssen Exchange 2000 Server Service Pack 2 oder höher ausführen, um den Registrierungswert MaxBufferSize verwenden zu können.

Wenn Sie für den Registrierungswert MaxBufferSize einen zu niedrigen Wert festlegen, wird sich keine Leistungssteigerung ergeben, und Microsoft Exchange Server Analyzer zeigt eine Fehlermeldung an (weitere Informationen dazu finden Sie in diesem Artikel). Wenn Sie für den Registrierungswert MaxBufferSize einen zu hohen Wert festlegen, kann das System instabil werden, und Microsoft Exchange Server Analyzer zeigt eine Fehlermeldung an (weitere Informationen finden Sie unter POP3-MaxBufferSize-Wert ist zu groß.).

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diesen Fehler

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Erstellen Sie einen neuen DWORD-Wert mit der Bezeichnung MaxBufferSize.

  4. Doppelklicken Sie auf den Wert MaxBufferSize, und legen Sie den neuen Wert für die Puffergröße (in Byte) fest. Sie können beispielsweise 8192 eingeben, um den Wert auf 8192 Bytes festzulegen.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Microsoft Exchange POP3-Dienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Verwendung des Registrierungswerts MaxBufferSize finden Sie im Knowledge Base-Artikel 823857 „XADM: IMAP4 and POP3 Performance Is Slow Between Front-End and Back-End Servers" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


Port hat nicht geantwortet
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2006-05-16

Microsoft® Exchange Server Analyzer fragt den benutzerdefinierten Server ab und versucht, eine Socketverbindung mit dem angegebenen Server am standardmäßig konfigurierten TCP-Port 25 oder einem benutzerdefinierten Port herzustellen. Wenn Exchange Server Analyzer nicht die erwartete benutzerdefinierte Antwort xx verfügbar erhält, wobei "xx" die standardmäßige Portnummer oder eine andere vom Benutzer angegebene Portnummer ist, wird eine Fehlermeldung angezeigt.

Dieser Fehler bedeutet, dass auf den Server nicht über den gewünschten TCP-Port zugegriffen werden kann und dass Fehler auftreten können. Um diesen Fehler zu korrigieren, müssen Sie das Verbindungsproblem mit dem Server beheben.

So behandeln Sie das Verbindungsproblem mit dem Server

  1. Können Sie vom Server aus eine Telnet-Verbindung mit dem gewünschten Port herstellen? Falls nein, wird das Problem nicht vom Netzwerk verursacht.

  2. Sind alle Stecker angeschlossen? Funktioniert die gesamte Hardware fehlerfrei?

  3. Ist DNS aktiv und richtig konfiguriert?

  4. Funktioniert der Router fehlerfrei?

  5. Sind Firewalls vorhanden, die das Herstellen einer Verbindung verhindern können?

Weitere Informationen zum Behandeln von Problemen mit Serververbindungen finden Sie unter "Microsoft Exchange Server Analyzer Tool Troubleshooting Connectivity Problems" (http://go.microsoft.com/fwlink/?LinkId=56285)


Potenzielle Black-Hole-Router
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) WIN32_PingStatus mit verschiedenen Werten für die Einstellungen BufferSize und NoFragmentation ab, um zu bestimmen, ob in der WAN-Umgebung Black-Hole-Router vorhanden sind.

Einstellung BufferSize | Einstellung NoFragmentation
548 | Wahr
1472 | Wahr
1472 | Falsch
4096 | Wahr
4096 | Falsch

Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • PING mit einem kleineren Wert für BufferSize und NoFragmentation = "Wahr" ist erfolgreich

  • PING mit einem größeren Wert für BufferSize und NoFragmentation = "Wahr" sorgt für eine Zeitüberschreitung

  • PING mit einem größeren Wert für BufferSize und NoFragmentation = "Falsch" ist erfolgreich, doch die BufferSize-Größe der Antwort unterscheidet sich von der gesendeten BufferSize-Größe.

Dieser Fehler bedeutet, dass möglicherweise ein oder mehrere Black-Hole-Router im WAN vorhanden sind.

In einem TCP/IP-WAN kann die Kommunikation über einige Routen fehlschlagen, wenn die folgenden Bedingungen gelten:

  • Zwischengeschaltete Netzwerksegmente weisen kleinere Paketgrößen als die kommunizierenden Hosts auf.

  • Router senden nicht die entsprechenden ICMP-Antworten auf diese Bedingung.

Auch die Firewall im Pfad kann für ein Löschen solcher Antworten sorgen. Ein Router, der diese Bedingung verursacht, wird mitunter als Black-Hole-Router bezeichnet.

Das Vorhandensein eines Black-Hole-Routers kann eine Vielzahl von Fehlern verursachen, die nicht auftreten, wenn ein Programm sich mit einem Computer im lokalen Subnetz verbindet. Das Verhalten scheint ggf. nur zeitweise aufzutreten, doch Sie werden feststellen, dass Sie das Verhalten reproduzieren können, indem Sie z. B. einen Client eine von einem Remotehost gesendete große Datei lesen lassen.

Weitere Informationen finden Sie in den Anleitungen im Microsoft Knowledge Base-Artikel 314825, "Behebung von Problemen mit Black-Hole-Routern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825).

Weitere Informationen

Weitere Informationen zum Erkennen von und dem Umgang mit Black-Hole-Routern finden Sie in den folgenden Ressourcen:

  • Microsoft Knowledge Base-Artikel 159211, "Diagnose und Behandlung von Black-Hole-Routern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

  • "Path Maximum Transmission Unit (PMTU) Black Hole Routers" in der Spalte The Cable Guy - July 2004(http://go.microsoft.com/fwlink/?LinkId=66963).


PING des Remotehosts nicht erfolgreich
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2006-05-03

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_PingStatus mithilfe verschiedener Einstellungen für BufferSize und NoFragmentation ab, um die Größe der maximalen Übertragungseinheit (MTU - Maximum Transmission Unit) für das Netzwerk und mögliche Black-Hole-Router zu bestimmen. Exchange Server Analyzer untersucht dazu den Schlüsselwert StatusCode, der von einem Remotehost für jede Einstellungskombination zurückgegeben wird.

"BufferSize"-Einstellung | "NoFragmentation"-Einstellung
548 | Wahr
1472 | Wahr
1472 | Falsch
4096 | Wahr
4096 | Falsch

Win32_PingStatus gibt ein Objekt mit 24 Eigenschaften zurück, die umfangreiche Informationen zu der von dieser Klasse gesendeten Ping-Pakete liefern.

Wenn Exchange Server Analyzer feststellt, dass der Wert dieses Schlüssels mit einem der Werte in der folgenden Tabelle übereinstimmt, wird ein Fehler angezeigt.

Exchange Server Analyzer zeigt den Namen des Remotehosts, den Namen des Servers mit Exchange und den entsprechenden Wert von StatusCode an, der bei diesem Fehler zurückgegeben wird.

Wert StatusCode Bedeutung Beschreibung

11001

Puffer ist zu klein

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11002

Zielnetz ist nicht erreichbar

Die Anforderung ist fehlgeschlagen, weil das Netzwerk mit dem Zielcomputer nicht erreichbar ist. Zum Zielcomputer gibt es keine gültige Route.

Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 325487 "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11003

Zielhost ist nicht erreichbar

Die Anforderung ist fehlgeschlagen, weil der Zielcomputer nicht erreichbar ist.

Weitere Informationen finden Sie unter Active Directory-Server ist inaktiv oder nicht erreichbar..

Alternativ kann dieser Fehler folgende Ursachen haben:

  • Eine Firewall zwischen dem Computer, auf dem Microsoft Exchange Server Analyzer ausgeführt wird, und dem Zieldomänencontroller.

  • Ein DNS-Fehler.

Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 325487 "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11004

Zielprotokoll ist nicht erreichbar

Die Anforderung ist fehlgeschlagen, weil der Zielcomputer nicht auf das Protokoll des Pakets antwortet.

Dieser Fehler wird u. U. durch eine Firewall zwischen dem Computer, auf dem Microsoft Exchange Server Analyzer ausgeführt wird, und dem Zieldomänencontroller verursacht.

11005

Zielanschluss ist nicht erreichbar

Die Anforderung ist fehlgeschlagen, weil der Port auf dem Zielcomputer nicht verfügbar ist.

Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 325487 "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11006

Keine Ressourcen

Die Anforderung ist aufgrund unzureichender Netzwerkressourcen fehlgeschlagen.

Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11007

Ungültige Option

Die Anforderung ist fehlgeschlagen, weil sie eine ungültige Option enthält.

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11008

Hardwarefehler

Die Anforderung ist aufgrund eines Hardwarefehlers fehlgeschlagen.

Stellen Sie sicher, dass sich der Domänencontroller in einem geeigneten Betriebszustand befindet, indem Sie das Tool des Computerherstellers zur Hardwarefunktionsüberprüfung ausführen.

11009

Paket ist zu groß

Die Anforderung ist fehlgeschlagen, weil das Paket mit der Anforderung größer ist als die maximale Übertragungseinheit (MTU - Maximum Transmission Unit) eines zwischen Quelle und Ziel befindlichen Knotens (Router oder Gateway). Die MTU definiert die maximale Größe eines zu übertragenden Pakets.

Die von Microsoft Exchange Server Analyzer gesendete Anforderung hat eine maximale Größe von 10 KB. Stellen Sie sicher, dass die Router und Gateways der Organisation ordnungsgemäß konfiguriert sind.

Weitere Informationen finden Sie im Knowledge Base-Artikel 159211, "Diagnose und Behandlung von Black-Hole-Routern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

11010

Anfragetimeout

In der vorgegebenen Zeit ist keine Antwort erfolgt. Die Standardantwortzeit beträgt fünf Sekunden.

Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11011

Ungültige Anforderung

Die Anforderung ist aufgrund einer falschen Verschlüsselung fehlgeschlagen.

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11012

Ungültige Route

Die Anforderung ist fehlgeschlagen, da keine gültige Route zwischen Quell- und Zielcomputer vorhanden ist.

Weitere Informationen finden Sie im Knowledge Base-Artikel 325487 „Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11013

TTL-Übertragungsüberschreitung

Die Anforderung ist fehlgeschlagen, weil TTL (Time to Live) den Wert Null erreicht hat. Dies führt dazu, dass der Weiterleitungsknoten (Router oder Gateway) das Paket verwirft.

Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11014

Gültigkeitsdauer für Reassemblierung abgelaufenen

Die Anforderung ist fehlgeschlagen, weil das Paket für die Übertragung fragmentiert wurde und nicht alle Fragmente innerhalb der angegebenen Reassemblierungszeit empfangen wurden. RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) legt 60 Sekunden als Zeitlimit fest, innerhalb dessen alle Fragmente des Pakets empfangen werden müssen.

Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11015

Parameterfehler

Die Anforderung ist fehlgeschlagen, da an einem Knoten (Router oder Gateway) Fehler bei der Verarbeitung der Paketkopfzeile aufgetreten sind. Dieser Status kann auftreten, wenn die Kopfzeile ungültige Felddaten oder nicht erkannte Optionen enthält.

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11016

Quelldrosselung

Die Anforderung ist fehlgeschlagen, da das Paket verworfen wurde. Dies ist der Fall, wenn die Ausgabewarteschlage des Quellcomputers nicht genügend Speicherplatz aufweist oder wenn Pakete den Zielcomputer zu schnell erreichen und deshalb nicht verarbeitet werden können.

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11017

Wert für Option zu groß

Die Anforderung ist fehlgeschlagen, weil sie eine ungültige Option enthält.

Es ist unwahrscheinlich, dass dieser Fehler zurückgegeben wird, da Exchange Server Analyzer eine Standardanforderung generiert.

11018

Ungültige Zieladresse

Die Anforderung ist aus einem der folgenden Gründe fehlgeschlagen:

  • Die IP-Adresse des Zielcomputers kann keine PING-Anforderungen empfangen.

  • Die IP-Adresse des Zielcomputers darf nicht in einem Zieladressfeld eines IP-Datagramms enthalten sein.

Dies wird möglicherweise durch eine Firewall zwischen dem Computer, auf dem Microsoft Exchange Server Analyzer ausgeführt wird, und dem Zieldomänencontroller verursacht.

11032

IPSEC-Aushandlung

Die Anforderung ist fehlgeschlagen, da keine IPsec-Verbindung ausgehandelt werden konnte.

11050

Allgemeiner Fehler

Die Anforderung ist aufgrund eines unbekannten Fehlers fehlgeschlagen.

Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Weitere Informationen zu diesen Tests finden Sie im Microsoft Knowledge Base-Artikel 314825, "Behebung von Problemen mit Black-Hole-Routern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825).


Routingmodul wurde angehalten
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_Service ab, um zu bestimmen, ob der Dienst Microsoft Exchange-Routingmodul (RESvc) und der SMTP-Dienst (Simple Mail Transfer Protocol) SMTPSVC ausgeführt werden. Microsoft Exchange Server Analyzer zeigt einen Fehler an, wenn das Tool feststellt, dass eine der folgenden Bedingungen erfüllt ist:

  • SMTPSVC wird ausgeführt.

  • RESvc wird nicht ausgeführt.

Wenn RESvc nicht auf allen Exchange-Servern ausgeführt wird, die ein Relay für Nachrichten durchführen, können Routingprobleme auftreten. Eine Konfiguration von Exchange Server, die ein Relay für Nachrichten durchführt, ohne dass RESvc ausgeführt wird, wird nicht unterstützt.

Genau wie Exchange 2000 Server verwendet Exchange Server 2003 einen Routingalgorithmus für den Verbindungsstatus und ein Routingprotokoll, um die Informationen über den Verbindungsstatus in Form einer Verbindungsstatustabelle weiterzugeben. Die Verbindungsstatustabelle wird in der Organisation auf allen Exchange 2000 Server- und Exchange Server 2003-Servern gespeichert.

Ein Algorithmus für den Verbindungsstatus bietet folgende Vorteile:

  • Jeder Exchange-Server kann bereits an der Quelle die optimale Weiterleitung der Nachricht auswählen, anstatt Nachrichten an eine nicht verfügbare Verbindung weiterzuleiten.

  • Die Nachrichten werden nicht mehr zwischen den Servern weitergeleitet, da jeder Exchange-Server aktuelle Informationen hinsichtlich der Verfügbarkeit alternativer oder redundanter Routen erhält.

  • Die Nachrichten werden nicht mehr in eine Schleife weitergeleitet. Das Weiterleiten der Nachrichten in eine Schleife bereitete in früheren Versionen von Exchange Server häufig Probleme.

Die folgenden Informationen werden von Exchange Server aus der Verbindungsstatustabelle abgerufen:

  • In der Verbindungsstatustabelle wird die Routingtopologie der gesamten Organisation von Exchange dokumentiert.

  • In der Verbindungsstatustabelle wird die Verfügbarkeit aller Connectors in der Topologie dokumentiert. Eine verfügbare Topologie ist „aktiv". Eine nicht verfügbare Topologie ist „inaktiv".

  • In der Verbindungsstatustabelle werden die mit den einzelnen Connectors verbundenen Kosten und Adressräume dokumentiert.

Exchange Server verwendet diese Informationen, um für die Zieladresse die Route mit den geringsten Kosten zu bestimmen. Wenn ein Connector entlang der Route mit den geringsten Kosten nicht verfügbar ist, bestimmt Exchange Server auf der Grundlage der Kosten und der Connectorverfügbarkeit die beste alternative Route. Der Dienst RESvc ist für das Weiterleiten des Verbindungsstatus erforderlich.

Um diesen Fehler zu beheben, müssen Sie den Dienst RESvc so konfigurieren, dass er automatisch gestartet wird. Sie müssen außerdem sicherstellen, dass der Dienst RESvc während den Produktionsstunden ausgeführt wird.

So beheben Sie diesen Fehler

  1. Klicken Sie auf das Menü Start, zeigen Sie dort auf Programme und Verwaltung, und klicken Sie dann auf Dienste.

  2. Klicken Sie in der Liste der Dienste mit der rechten Maustaste auf Microsoft Exchange-Routingmodul, und klicken Sie dann auf Eigenschaften.

  3. Wählen Sie auf der Registerkarte Allgemein im Menü Starttyp die Option Automatisch aus, und klicken Sie auf OK.

  4. Klicken Sie mit der rechten Maustaste auf den Dienst Microsoft Exchange Routingmodul, und klicken Sie dann auf Start.

Weitere Informationen zum Weiterleiten von Nachrichten unter Exchange Server 2003 finden Sie im Transport- und Routing-Handbuch für Exchange Server (http://www.microsoft.com/downloads/details.aspx?FamilyID=c092b7a7-9034-4401-949c-b29d47131622&DisplayLang=de).


RPC Performance Counters Indicate Poor Server Performance
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2006-08-24

Microsoft® Exchange Server Analyzer hat festgestellt, dass Ihr Server nicht mit optimaler Leistung arbeitet. Exchange Server Analyzer wertet zahlreiche RPC-Leistungsindikatoren (Remote Procedure Call, Remoteprozeduraufruf) aus. Weichen die gemeldeten Daten der RPC-Leistungsindikatoren von den in der folgenden Tabelle aufgeführten Stufen ungünstig ab, wird eine Warnung angezeigt.

Anzahl der Benutzer auf dem Exchange-Server | Schwellenwert für durchschnittliche RPC-Wartezeit
Unter 500 | Im Durchschnitt über 15
Größer als oder gleich 500, aber unter 3000 | Im Durchschnitt über 30
Über 3000 | Im Durchschnitt über 50

Die folgenden Leistungsindikatoren werden in diesem Artikel erörtert, und sie werden mit dem Leistungsobjekt MSExchangeIS verwaltet:

  • Durchschnittliche Wartezeit für RPC

  • Anforderungen von RPC

Durchschnittliche Wartezeit für RPC

Der Leistungsindikator RPC Averaged Latency zeichnet, in Millisekunden (ms), die durchschnittliche Verarbeitungszeit für die letzten 1024 Pakete auf. Die Wartezeit stellt dar, wie lange es dauert, bis der Prozess Store.exe ein Paket nach Erhalt wieder zurückgibt. Der Leistungsindikator RPC Averaged Latency enthält keinerlei Netzwerkwartezeiten oder solche Wartezeiten, die durch Einflüsse außerhalb des Prozesses Store.exe eingeführt werden. Obwohl die Leistungsindikatordaten aus RPC Averaged Latency keine Netzwerkübertragungszeiten beinhalten, stellen sie Daten über den kürzesten Zeitraum zur Verfügung, den Client-Computer auf eine Antwort vom Server gewartet haben. Wenn die Daten des Leistungsindikators RPC Averaged Latency einen geringeren Wert als 50 ms aufweisen, kann der Server die Anforderungen in einer angemessenen Zeitspanne verarbeiten. Wenn der Leistungsindikator mehrere Sekunden lang mehr als 50 ms anzeigt, bedeutet dies, dass der Server Probleme hat, mit der Belastung Schritt zu halten. Im Ergebnis kann dies dazu führen, dass Benutzer Verzögerungen beim Zugriff auf Ihre E-Mail erleben. Wenn die durchschnittliche Wartezeit mehr als 100 ms beträgt, wird den Benutzern das folgende Popup-Fenster auf den Microsoft Office Outlook®-Clientcomputern angezeigt. "Abrufen von Daten aus Exchange Server."

Interpretieren Leistungsindikators für die durchschnittliche RPC-Wartezeit

Der Zähler RPC Averaged Latency kann in den beiden folgenden Situationen irreführend sein:

  • Zuerst wird vermutet, dass einige MAPI-Operationen viel Zeit benötigen. Wenn der Clientcomputer z. B. nach einem Ordner sucht, der Tausende von Elementen enthält, um alle Elemente zu finden, die komplexen Kriterien entsprechen, ist es völlig normal, dass eine solche Operation mehrere Sekunden dauert. Wenn auf dem Server wenige Benutzer vorhanden sind, verursacht dieser fortlaufende Vorgang eine Spitze für den Wert von RPC Average Latency. Wenn die RPC-Last auf dem Server gering ist, beobachten Sie den Durchschnittswert über einen längeren Zeitraum (mindestens einige Minuten lang), statt auf das kurzzeitige, veränderliche Verhalten zu reagieren.

  • Es kann aber auch die zweite Situation eintreten, dass die RPC/Last auf dem Server sehr niedrig ist. Manchmal kann sich die Wartezeit je nach der Aktivität des am stärksten ausgelasteten Benutzers dramatisch ändern. Weil die Serverlastung besonders hoch ist, können besonders umfangreiche Operationen durch einen einzelnen Benutzer dazu führen, dass die Daten über die durchschnittliche RPC-Wartezeiten ungewollt verzerrt werden.

Anforderungen von RPC

Der Leistungsindikator RPC Averaged Latency zeichnet die Anzahl der Anforderungen von Client-Computern, die von Exchange zum jeweiligen Zeitpunkt verarbeitet werden. Der Zähler hat einen Maximalwert von 100. Sobald der Exchange-Datenspeicher 100 RPC-Operationen verarbeitet, lehnt er neue Verbindungen regelmäßig ab. Auf einem gut konfigurierten Server sollte die Anzahl der unbearbeiteten Anforderungen kleiner als 50 sein. Wenn diese Zahl über einen längeren Zeitraum hinweg größer als 50 ist, bedeutet dies, das RPCs gesichert werden und auf Verarbeitung warten. In solch einer Situation müssen Client-Computer wahrscheinlich Wartezeiten in Kauf nehmen.

Interpretieren von RPC-Anforderungen

Der Schwellenwert von 50 Anforderungen ist nicht strikt einzuhalten. Bei einem gering ausgelasteten Server beginnen möglicherweise Leistungsprobleme aufzutreten, bevor der Leistungsindikator den Wert 30 erreicht. Ein stark ausgelasteter Server funktioniert jedoch u. U. auch bei 50 Anforderungen noch ordnungsgemäß. Idealerweise sollte für jeden Server ein Basiswert für diesen Leistungsindikator gemessen werden. Exchange Server Performance Troubleshooting Analyzer verwendet den Schwellenwert 50, der für die meisten großen Server geeignet ist.

Im Vergleich zu einem stark ausgelasteten Server besitzt ein wenig ausgelasteter Server einen geringeren Wert für RPC-Anfragen. Dies liegt daran, dass auf einem gering belasteten Server weniger Threads mit der Last mithalten müssen. Damit ein stärker ausgelasteter Server nicht in Rückstand gerät und einen höheren RPC-Anforderungswert erhält, muss er mehr Arbeiten gleichzeitig ausführen. Deshalb impliziert der größere RPC-Anforderungswert auf einem schwer belasteten Server für sich allein kein Leistungsproblem. Um die „Langsamkeit" des Servers zu beurteilen, müssen Sie auch den Leistungsindikator RPC Average Latency berücksichtigen.

Ursachen von Latenz

Eine Zunahme der Wartezeiten kann folgende Ursachen haben:

  • Eine Zunahme der RPC-Last

  • Ein Engpass bei einer oder mehreren Serverressourcen

Eine Zunahme der Wartezeiten kann folgende Ursachen haben:

  • Hohe RPC-Last (oder jede andere Serverbelastung)

  • Hardwarefehlfunktion oder Konfigurationsfehler

So beheben Sie diesen Fehler

  • Befolgen Sie die Empfehlungen und Vorgehensweisen, die in den folgenden Handbüchern zu Exchange Server 2003 enthalten sind:

    • Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576)

    • Troubleshooting Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Der RPC-Anschlussbereich wurde für einen Server festgelegt, der nicht Teil eines Clusters ist.
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungsschlüssel, um den Datenwert für die Anschlüsse zu bestimmen:

HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\Internet\Ports

Wenn Microsoft Exchange Server Analyzer feststellt, dass die folgenden Bedingungen erfüllt sind, zeigt das Tool einen Fehler an:

  • Der Schlüssel HKLM\Software\Microsoft\Rpc\Internet\Ports ist vorhanden.

  • Bei dem Server handelt es sich nicht um einen Exchange-Server, der Teil eines Clusters ist.

  • Bei diesem Server sind andere Fehler aufgetreten.

Wenn der Registrierungsschlüssel vorhanden ist, ist Exchange Server auf einen bestimmten Bereich von Anschlüssen für RPC-Aufrufe eingeschränkt. Wenn der Exchange-Server ausgelastet ist und mehr Anschlüsse benötigt, als zurzeit verfügbar sind, können Fehler auftreten.

Um dieses Problem zu beheben, sollten Sie dem Schlüssel HKLM\Software\Microsoft\Rpc\Internet\Ports weitere 100 Anschlüsse hinzufügen, bis das Problem behoben ist.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So beheben Sie diese Warnung

  1. Öffnen Sie den Registrierungs-Editor Regedt32.exe.

    Hinweis:
    Zum Bearbeiten eines REG_MULTI_SZ-Werts müssen Sie Regedt32.exe anstelle von Regedit.exe verwenden.

  2. Navigieren Sie zu: HKLM\Software\Microsoft\Rpc\Internet.

  3. Doppelklicken Sie im Detailbereich auf den Schlüssel Ports. Erhöhen Sie im Wertfeld den Anschlussbereich.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Exchange-Server erneut.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zu HKLM\Software\Microsoft\Rpc\Internet-Registrierungsschlüsseln finden Sie im Microsoft Knowledge Base-Artikel 154596, „Konfigurieren der dynamischen RPC-Portzuweisung für Firewall-Einsatz" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=154596).


Der RPC-Anschlussbereich wurde für einen Server festgelegt, der Teil eines Clusters ist.
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungsschlüssel, um den Datenwert für die Anschlüsse zu bestimmen: HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\Internet\Ports

Wenn Microsoft Exchange Server Analyzer feststellt, dass die folgenden Bedingungen erfüllt sind, zeigt das Tool einen Fehler an:

  • Der Schlüssel HKLM\Software\Microsoft\Rpc\Internet\Ports ist vorhanden.

  • Bei dem Server handelt es sich um einen Exchange-Server, der Teil eines Clusters ist.

  • Bei diesem Server sind andere Fehler aufgetreten.

Wenn der Registrierungsschlüssel vorhanden ist, ist Exchange Server auf einen bestimmten Bereich von Anschlüssen für RPC-Aufrufe eingeschränkt. Wenn der Exchange-Server ausgelastet ist und mehr Anschlüsse benötigt, als zurzeit verfügbar sind, können Fehler auftreten.

Um dieses Problem zu beheben, sollten Sie dem Schlüssel HKLM\Software\Microsoft\Rpc\Internet\Ports weitere 100 Anschlüsse hinzufügen, bis das Problem behoben ist.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So beheben Sie diese Warnmeldung

  1. Öffnen Sie den Registrierungs-Editor Regedt32.exe.

    Hinweis:
    Zum Bearbeiten eines REG_MULTI_SZ-Werts müssen Sie Regedt32.exe anstelle von Regedit.exe verwenden.

  2. Navigieren Sie zu: HKLM\Software\Microsoft\Rpc\Internet.

  3. Doppelklicken Sie im Detailbereich auf den Schlüssel Ports. Erhöhen Sie im Wertfeld den Anschlussbereich.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Exchange-Server erneut.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zu den HKLM\Software\Microsoft\Rpc\Internet-Registrierungsschlüsseln finden Sie im Microsoft Knowledge Base-Artikel 154596, „Konfigurieren der dynamischen RPC-Portzuweisung für Firewall-Einsatz" (http://support.microsoft.com/default.aspx?scid=kb;de;154596).


RPC-Benutzeraktivität aus Leistungsindikatoren
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2007-02-14

Microsoft® Exchange Server Analyzer hat festgestellt, dass Ihr Server eine hohe Anzahl von RPC-Operationen pro Sekunde aufweist.

Die Anzahl der RPC-Operationen pro Sekunde stellt einen Hinweis darauf dar, wie hoch die RPC-Last auf dem Server ist. Manchmal kann eine unerwartete Zunahme der Last aus RPC-Operationen zu schlechter Serverleistung führen. Wenn Ihr Server ein Leistungsproblem aufweist, müssen Sie zuerst feststellen, ob die Last auf dem Server höher als erwartet ist. Es gibt verschiedene Leistungsindikatoren, die Information über die RPC-Aktivitäten auf dem Server zur Verfügung stellen. Die folgenden Leistungsindikatoren, die in diesem Artikel erörtert werden, fallen sämtlich unter die Leistungsobjekte MSExchangeIS, MSExchangeIS Public oder MSExchangeIS Mailbox:

  • RPC-Operationen/Sekunde

  • Anzahl aktiver Benutzer

  • Aktive Clients (MSExchangeIS Public)

  • Aktive Clients (MSExchangeIS Mailbox)

Bestimmen der RPC-Last durch Clients

Es gibt zwei Zähler, mit denen Sie die aktuelle Aktivitätsrate der Client-Computer bestimmen können.

  • RPC-Operationen/Sekunde Dieser Zähler gibt die Anzahl der RPC-Operationen pro Sekunde an, die Client-Computer gerade vom Server anfordern. Sie können Benutzer auf folgende Weise zählen:

    • Sie können die Gesamtzahl der Postfächer auf dem Server zählen.

    • Sie können die Gesamtzahl der Anmeldungen zählen (aus der Summe von Aktive Clients für MSExchangeIS Public und Aktive Clients für MSExchangeIS Mailbox).

    • Sie können die Gesamtzahl der Anmeldungen anhand der Anzahl aktiver Benutzer zählen.

    Exchange Server Analyzer verwendet die letzte Methode. Um die Rate pro aktivem Benutzer zu berechnen, teilen Sie den Wert für RPC-Operationen/Sekunde durch den Wert von Anzahl aktiver Benutzer.

  • RPC-Operationen/Sekunde und Benutzer Dieser Zähler liefert einen Hinweis darauf, wie aktiv die Benutzer auf dem Server sind. Normalerweise haben Wissensarbeiter, die Microsoft Office Outlook® verwenden, auf einem Postfachserver eine Rate von 0,1 Operationen pro Sekunde und Benutzer. Wenn die Benutzer auf dem Server zusätzliche Anwendungen ausführen, kann dieser Wert zunehmen.

Wenn Exchange Server Analyzer feststellt, dass der Wert der RPC-Operationen pro Sekunde und Benutzer größer 0,15 aber kleiner als 0,25 ist, gelten die Benutzer als mittelmäßig aktiv und Exchange Server Analyzer zeigt eine Warnung an.

Wenn Exchange Server Analyzer feststellt, dass der Wert der RPC-Operationen pro Sekunde und Benutzer größer 0,15 aber kleiner als 0,25 ist, gelten die Benutzer als mittelmäßig aktiv und Exchange Server Analyzer zeigt eine Warnung an.

Was ist zu tun bei hoher RPC-Last

Wenn der Wert für die Operationen pro Sekunde größer als erwartet ist, müssen Sie zuerst versuchen, die Ursache der hohen Last zu bestimmen und sie dann zu reduzieren. Sie können mit Exchange Server User Monitor (ExMon) einen Benutzer identifizieren, der eine große Anzahl von RPC-Operationen verursacht.

Wenn Sie die Last auf dem Server nicht reduzieren können, müssen Sie die Leistungsengpässe ermitteln und die Kapazität auf dem Server erhöhen.

Ermitteln einer großen Anzahl von Anmeldungen

Es ist erforderlich, dass der Server eine gewisse Menge an Informationen über die Anmeldungen im Speicher führt (im Benutzer- und im Kernelspeicher). Es wurde eine geringe Speichermenge reserviert. Wenn dieser Speicher verwendet wird, kann es auf dem Server zu einem Speicherengpass kommen. Aus diesem Grund sollten Sie bei Auftreten eines Leistungsproblems auf einem Exchange-Server sicherstellen, dass die Gesamtzahl von Anmeldungen pro Benutzer nicht übermäßig groß ist.

Ein typischer Wissensarbeiter verfügt über zwei bis drei Anmeldungen. Wenn Benutzer andere Anwendungen ausführen, kann die Anzahl der Anmeldungen ansteigen. Exchange Server Analyzer berechnet die Anzahl der Anmeldungen pro Benutzer. Hierzu wird die Gesamtzahl der Anmeldungen beim Server durch die Anzahl der Postfächer auf dem Server dividiert. Sie können die Gesamtzahl der Server-Anmeldungen bestimmen, indem Sie die Leistungsindikatoren Aktive Clients unter den Leistunsobjekten MSExchangeIS Postfach und MSExchangeIS Public addieren. Bei Postfachservern oder gemischten Postfachservern und Servern für Öffentliche Ordner wird von Exchange Server Analyzer nur dieses Verhältnis berücksichtigt.

Hinweis:
Wenn viele Benutzer die freigegebenen Ordner anderer Benutzer anzeigen (beispielsweise gemeinsame Kalender), kann die Anzahl der Anmeldungen ebenfalls höher sein.

Wenn die durchschnittliche Anzahl der Anmeldungen pro Benutzer über fünf liegt, und der Server weist einen Speicherengpass auf, so kann dies darauf hinweisen, dass Benutzer Anwendungen ausführen, die eine große Anzahl von Anmeldungen generieren. Wenn Benutzer Anwendungen ausführen, die nicht den geschäftlichen Zwecken dienen, fordern Sie sie auf, diese Anwendungen nicht auszuführen, weil dadurch der Exchange-Server durch übermäßig viele Anmeldungen belastet wird.

Wenn Sie die Anzahl der von Benutzern ausgeführten Anwendungen nicht reduzieren können, müssen Sie die Anzahl der Benutzer pro Server reduzieren. Verschieben Sie zu diesem Zweck Benutzer auf einen anderen Server. Wenn Sie festellen möchten, ob die Anmeldungen von vielen Benutzern verursacht werden oder ob ein einzelner Benutzer eine unverhältnismäßig hohe Anzahl von Anmeldungen benutzt, können Sie Exchange-System-Manager einsetzen, um die aktiven Anmeldungen für jeden Benutzer anzuzeigen.

Weitere Informationen

  • Weitere Informationen zur Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Die RTF-Antivirusprüfung wurde deaktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um den Wert für die Virenprüfung von RTF-Nachrichten (Rich Text Format) zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Wenn Exchange Server Analyzer feststellt, dass der Wert von ScanRTF auf 0 festgelegt ist, wird eine Warnung angezeigt.

Der Registrierungsschlüssel ScanRTF wurde von externen Antivirus-Lieferanten festgelegt, die Exchange Virus Scanning API (VSAPI) verwenden. In RTF-Nachrichten können Farben, Schriftarten und Formatierungen verwendet werden. RTF ist jedoch nur in Microsoft Office Outlook® 2003 lesbar. Das RTF-Format in Exchange Server unterscheidet sich von der Ausgabe einer RTF-Datei in einem Textverarbeitungsprogramm wie Microsoft Word.

Es wird empfohlen, alle Nachrichtentypen, also auch RTF-Nachrichten, auf Viren zu prüfen. Sie sollten eine Virusprüfung für alle Nachrichten aktivieren, die einen Exchange Server-Computer passieren.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diesen Fehler

  1. Aktivieren Sie in Ihrer Exchange-Antivirenanwendung die Virenprüfung aller Nachrichten.

    oder

  2. Verändern Sie manuell den Eintrag in Ihrer Registrierung, indem Sie den folgenden Vorgang ausführen:

    • Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

    • Navigieren Sie zu:

      HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

    • Doppelklicken Sie auf den Registierungswert ScanRTF, und legen Sie den Datenwert auf 1 fest.

    • Beenden Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst und die Exchange-Antivirensoftwaredienste neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Virenbekämpfung finden Sie auf der Website „Behindern und Blockieren von E-Mail-Viren in einer Exchange 2003-Umgebung" unter http://www.microsoft.com/downloads/details.aspx?FamilyID=fb3f649a-2b0a-443d-92a5-8f8cf4bf9fdb&DisplayLang=de.


SMTP-Banner wurde angepasst
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer versucht, eine Nachricht an das Postmasterkonto oder ein benutzerdefiniertes Konto für die SMTP-Domäne zu senden. Exchange Server Analyzer zeigt eine Warnung an, wenn von diesem Konto eine Antwort empfangen wird, die sich von der folgenden Standardantwort unterscheidet:

"220 Computername . Domänenname.com Microsoft ESMTP MAIL Service, Version: Versionsnummer ready at Datum Uhrzeit +0000"

Diese Warnung bedeutet, dass die Standardantwort, die angezeigt wird, wenn sich das Programm mit einem virtuellen SMTP-Server von Exchange verbindet, angepasst wurde.

Ein angepasstes SMTP-Banner ist ggf. kein Problem, wenn der Exchange Server-Administrator das Banner gemäß den Anweisungen im Microsoft Knowledge Base-Artikel 281224 absichtlich geändert hat, "XCON: Ändern des SMTP-Banners" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281224).

Wenn das standardmäßige SMTP-Banner nicht vom Exchange Server-Administrator absichtlich geändert wurde, kann diese Warnung bedeuten, dass sich der Server mit Exchange hinter einer Firewall oder einem SMTP-Proxy befindet, die/der die ESMTP-Befehle (Exchange Server Extended SMPT) filtert.

Wenn die Exchange Server-ESMTP-Befehle gefiltert werden, kann sich dies wesentlich auf die Exchange-Leistung auswirken und zu einem Verhalten führen, das im Microsoft Knowledge Base-Artikel 320027, "Cannot send or receive e-mail messages behind a Cisco PIX firewall" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027) beschrieben wird.

Weitere Informationen zu angepassten SMTP-Banners finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • "XCON: Ändern des SMTP-Banners" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281224).

  • "E-Mail-Nachrichten können hinter Cisco PIX-Firewall nicht gesendet oder empfangen werdenl" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027).


SMTP-Instanz angehalten
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2006-05-16

Microsoft® Exchange Server Analyzer fragt die Metabasis von Internetinformationsdienste (IIS) ab, um den Wert der Eigenschaft ServerState für die einzelnen Instanzen eines virtuellen SMTP-Servers (Simple Mail Transfer Protocol) zu ermitteln.

Die Eigenschaft ServerState zeigt den aktuellen Zustand der Serverinstanz. Die Zustände und entsprechenden Codes lauten wie folgt: 1 (Wird gestartet), 2 (Gestartet), 3 (Wird beendet), 4 (Beendet), 5 (Wird angehalten), 6 (Angehalten) oder 7 (Wird fortgesetzt).

Wenn Exchange Server Analyzer feststellt, dass der Wert der Eigenschaft ServerState für eine virtuelle SMTP-Serverinstanz 6 (Angehalten) lautet, wird eine Warnung angezeigt.

SMTP ist das systemeigene E-Mail-Protokoll von Exchange Server für die Übertragung und den Transport von E-Mail. Dies bedeutet, dass Clients SMTP zum Senden von Nachrichten und Server mit Exchange SMTP zum Übermitteln von Nachrichten und Nachrichtendaten verwenden.

Virtuelle Server werden unter einem Serverprozess ausgeführt, den Sie wie die meisten anderen Serverprozesse starten, beenden und anhalten können. Wenn Sie beispielsweise die Konfiguration eines virtuellen Servers ändern oder andere Wartungsaufgaben ausführen möchten, können Sie den virtuellen Server beenden, die Änderungen vornehmen und ihn anschließend neu starten. Wenn Sie einen virtuellen Server beenden, akzeptiert dieser keine Benutzerverbindungen und kann nicht zum Übermitteln oder Abrufen von E-Mail verwendet werden.

Eine Alternative zum Beenden eines virtuellen Servers ist das Anhalten. Wenn Sie einen virtuellen Server anhalten, werden neue Clientverbindungen verhindert, aktuelle Verbindungen jedoch nicht getrennt. Beim Anhalten eines virtuellen SMTP-Servers können aktive Clients weiter Nachrichten übermitteln, und der virtuelle Server kann vorhandene Nachrichten zustellen, die in Warteschlangen auf die Übermittlung warten. Neue Verbindungen sind jedoch nicht möglich.

Für gewöhnliche Messagingvorgänge müssen virtuelle SMTP-Server von Exchange Server gestartet sein.

Um diesen Fehler zu beheben, befolgen Sie diese Anweisungen, um die virtuelle SMTP-Serverinstanz zu starten.

So starten Sie die virtuelle SMTP-Serverinstanz

  1. Klicken Sie in Exchange System-Manager mit der rechten Maustaste auf die virtuelle Serverinstanz, die Sie starten möchten.

  2. Klicken Sie im Menü Aktion auf Starten.

Weitere Informationen zum Starten, Beenden und Anhalten virtueller SMTP-Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • "XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • "XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

  • "XIMS: Leeren der SMTP-Mail-Warteschlange in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=251087).

  • "XGEN: Deaktivieren von Protokollen in Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=291330).


SMTP-Instanz beendet
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2006-05-16

Microsoft® Exchange Server Analyzer fragt die Metabasis von Internetinformationsdienste (IIS) ab, um den Wert der Eigenschaft ServerState für die einzelnen Instanzen eines virtuellen SMTP-Servers (Simple Mail Transfer Protocol) zu ermitteln.

Die Eigenschaft ServerState zeigt den aktuellen Zustand der Serverinstanz. Die Zustände und entsprechenden Codes lauten wie folgt: 1 (Wird gestartet), 2 (Gestartet), 3 (Wird beendet), 4 (Beendet), 5 (Wird angehalten), 6 (Angehalten) oder 7 (Wird fortgesetzt).

Wenn das Tool Exchange Server Analyzer feststellt, dass der Wert der Eigenschaft ServerState für eine virtuelle SMTP-Serverinstanz 4 (Beendet) lautet, wird eine Warnung angezeigt.

SMTP ist das systemeigene E-Mail-Protokoll von Exchange Server für die Übertragung und den Transport von E-Mail. Dies bedeutet, dass Clients SMTP zum Senden von Nachrichten und Server mit Exchange SMTP zum Übermitteln von Nachrichten und Nachrichtendaten verwenden.

Virtuelle Server werden unter einem Serverprozess ausgeführt, den Sie wie die meisten anderen Serverprozesse starten, beenden und anhalten können. Wenn Sie beispielsweise die Konfiguration eines virtuellen Servers ändern oder andere Wartungsaufgaben ausführen möchten, können Sie den virtuellen Server beenden, die Änderungen vornehmen und ihn anschließend neu starten. Wenn Sie einen virtuellen Server beenden, akzeptiert dieser keine Benutzerverbindungen und kann nicht zum Übermitteln oder Abrufen von E-Mail verwendet werden.

Für gewöhnliche Messagingvorgänge müssen virtuelle SMTP-Server von Exchange Server gestartet sein.

Um diesen Fehler zu beheben, befolgen Sie diese Anweisungen, um die virtuelle SMTP-Serverinstanz zu starten.

So starten Sie die virtuelle SMTP-Serverinstanz

  1. Klicken Sie in Exchange System-Manager mit der rechten Maustaste auf die virtuelle Serverinstanz, die Sie starten möchten.

  2. Klicken Sie im Menü Aktion auf Starten.

Weitere Informationen zum Starten, Beenden und Anhalten virtueller SMTP-Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • "XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • "XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

  • "XIMS: Leeren der SMTP-Mail-Warteschlange in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=251087).

  • "XGEN: Deaktivieren von Protokollen in Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=291330).


Der Wert für die maximale Anzahl der SMTP-Empfänger ist möglicherweise zu niedrig festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob der für das Attribut msExchSmtpMaxRecipients konfigurierte Wert unter 250 liegt. In der Standardeinstellung ist das Attribut msExchSmtpMaxRecipients für 64000 Empfänger konfiguriert. Wenn Exchange Server Analyzer feststellt, dass das Attribut msExchSmtpMaxRecipients auf einen Wert kleiner als 250 festgelegt wurde, zeigt Microsoft Exchange Server Analyzer eine Warnung an.

Aus Gründen der Sicherheit wird empfohlen, die maximal zulässige Anzahl der Empfänger pro Nachricht zu begrenzen. Ändern Sie daher den für das Attribut msExchSmtpMaxRecipients festgelegten Standardwert 64000 nicht.

Jede Organisation sollte die maximal zulässige Anzahl der Empfänger entsprechend den jeweiligen geschäftlichen Anforderungen festlegen. Es wird jedoch empfohlen, die maximal zulässige Anzahl der Empfänger auf einen Wert kleiner als 250 festzulegen. Nachrichten, die an mehrere Verteilerlisten adressiert sind, weisen vermutlich mehr als 250 Empfänger auf. Wenn Sie für die maximal zulässige Anzahl der Empfänger einen Wert kleiner als 250 festlegen, muss Exchange die verbleibenden Empfänger unter Verwendung zusätzlicher Kopien der Nachricht verarbeiten. Diese zusätzlichen Kopien führen zu einem erhöhten Datenverkehr im Netzwerk.

So wird die maximale Anzahl der Empfänger angezeigt und konfiguriert

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie nacheinander Server, einen Exchange-Server, Protokolle und dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise Virtueller Standardserver für SMTP), und klicken Sie dann auf Eigenschaften.

  4. Wählen Sie die Registerkarte Nachrichten aus.

  5. Aktivieren Sie zum Zurücksetzen der Einstellung auf den Standardwert 64000 das Kontrollkästchen Zahl d. Nachrichten pro Empfänger beschränken auf:, und geben Sie den Wert 64000 ein. Sie können in dieses Feld auch einen beliebigen Wert eingeben oder das Kontrollkästchen deaktivieren, um eine unbegrenzte Anzahl Empfänger zuzulassen.

  6. Klicken Sie auf OK, um die Änderungen zu speichern und das Dialogfeld Eigenschaften des virtuellen SMTP-Servers zu schließen.

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 266686, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


SMTP-Proxy-Adresse für EAS wurde außer Kraft gesetzt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Fehlermeldung

Einführung

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob die SMTP-Proxyadresse für Exchange ActiveSync® außer Kraft gesetzt wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MasSync\Parameters\SMTPProxy

Wenn Exchange Server Analyzer erkennt, dass der Registrierungseintrag SMTPProxy vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

SMTP-Adressen werden verwendet, um den Pfad eines Postfachs in Exchange Server zu identifizieren. Sie müssen eindeutig sein. Jede Adresse verfügt über eine linke Seite (LS) und einen rechte Seite (RS), die durch das Symbol @ getrennt werden. Das Format einer SMTP-Adresse sieht beispielsweise folgendermaßen aus:

Benutzername@Domäne.de = linke_Seite@rechte_Seite (oder LS@RS)

Exchange ActiveSync greift mithilfe einer WebDAV-Anforderung auf die Postfachinformationen des Exchange-Servers zu. Exchange ActiveSync wählt einen zugehörigen RHS-Wert aus, wobei LHS@RHS eine SMTP-Proxyadresse darstellt, die in der WebDAV-Anforderung verwendet werden soll. In Umgebungen mit einer RHS-Standardadresse, die von der primären SMTP-Adresse eines Benutzers abweicht, stellt der Registrierungswert SMTPProxy eine Konfigurationsmöglichkeit dar, die Exchange ActiveSync die Verwendung einer anderen SMTP-Proxyadresse ermöglicht.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So zeigen Sie den Registrierungswert „SMTPProxy" an oder ändern ihn

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\MasSync\Parameters

  3. Überprüfen und ändern Sie bei Bedarf den Wert SMTPProxy.

  4. Wenn eine Änderung vorgenommen wurde, schließen Sie den Registrierungs-Editor, und starten Sie dann den Exchange Server-Computer neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://support.microsoft.com/?scid=kb%3Bde%3B256986&x=2&y=12, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen über Exchange ActiveSync finden Sie unter „Exchange Server 2003 ActiveSync Architecture" (http://go.microsoft.com/fwlink/?linkid=34203).

Weitere Informationen über Mobile Access und Exchange Server 2003 finden Sie unter „Mobile Access Using Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=20098).


Der SMTP-Server akzeptiert die Standardauthentifizierung
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchAuthenticationFlags in der protocolCfgSMTPServer-Klasse für das ExchangeServer-Objekt zu ermitteln. Die Klasse protocolCfgSMTPServer enthält die Einstellungen für einen virtuellen SMTP-Server. Das Attribut msExchAuthenticationFlags stellt die auf dem SMTP-Server zugelassene Art der Authentifizierung dar. Wenn Microsoft Exchange Server Analyzer ermittelt, dass auf dem SMTP-Server die Standardauthentifizierung konfiguriert wurde und es sich bei dem Server nicht um einen Microsoft Small Business Server 2000- oder Microsoft Windows® Small Business Server 2003-Server handelt, zeigt Microsoft Exchange Server Analyzer eine Warnmeldung an.

Wenn auf dem SMTP-Server die Standardauthentifizierung konfiguriert wurde, steigt das Risiko einer Sicherheitsverletzung. Die Standardauthentifizierung ermöglicht das Senden von Benutzernamen und Kennwörtern in Klartext über das Netzwerk. Benutzernamen und Kennwörter können unverschlüsselt leicht im Internet abgefangen werden.

Bei der Verwendung der Standardauthentifizierung wird dringend empfohlen, auch die TLS-Verschlüsselung (Transport Layer Security) zu verwenden, um die Sicherheit zu erhöhen. TLS verschlüsselt Benutzernamen, Kennwörter und Nachrichtendaten. Sie können festlegen, dass für Clients zum Verbinden mit dem virtuellen SMTP-Server TLS-Verschlüsselung erforderlich ist. TLS wurde entwickelt, um ausgehende Nachrichten zu schützen, es schützt jedoch nicht die Übertragungen von Clients zu Servern.

TLS wird von Microsoft Outlook Express unterstützt. Zum Verwenden der TLS-Verschlüsselung für den virtuellen SMTP-Server müssen Schlüsselpaare erstellt und Schlüsselzertifikate konfiguriert werden. Clients können dann die Sitzung mit dem SMTP-Dienst mit TLS verschlüsseln. Deshalb werden alle Nachrichten gesendet. Der SMTP-Dienst kann auch Sitzungen mit Remoteservern mit TLS verschlüsseln.

Hinweis:
Clients, die TLS nicht unterstützen, können kein Relay für E-Mail-Nachrichten über den virtuellen Server durchführen.

Wenn Sie aus geschäftlichen Gründen (z. B. Authentifizierung durch ein Partnerunternehmen) den authentifizierten Zugriff auf den virtuellen SMTP-Server nicht deaktivieren können, führen Sie die folgenden Schritte aus, um die Sicherheit auf Ihrem Gatewayserver zu erhöhen:

  • Erzwingen Sie Richtlinien für sichere Kennwörter für alle Benutzerkonten, besonders für Administratorkonten.

  • Deaktivieren Sie das Gastkonto. Weitere Informationen zum Deaktivieren des Gastkontos finden Sie im Microsoft Knowledge Base-Artikel 320053, „How to rename the administrator and guest account in Windows 2000" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320053. Dieser Artikel bezieht sich auf Microsoft Windows 2000 Server, jedoch gelten vergleichbare Prinzipien für Windows Server™ 2003.

So deaktivieren Sie die Standardauthentifizierung

  1. Erweitern Sie im Exchange-System-Manager die Option Server, erweitern Sie <Ihren eingehenden Exchange-Server>, erweitern Sie dann Protokolle, und erweitern Sie anschließend SMTP.

  2. Klicken Sie mit der rechten Maustaste auf Ihren virtuellen SMTP-Eingangsserver, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Zugriff auf Authentifizierung.

    Dialogfeld „Authentifizierung"

  4. Deaktivieren Sie unter Authentifizierung das Kontrollkästchen Standardauthentifizierung.

    Wichtig:
    Wenn Sie die Standardauthentifizierung verwenden, sollten Sie möglicherweise TLS implementieren, um die Sicherheit zu erhöhen. Wenn Sie über ein digitales Zertifikat verfügen, verwenden Sie das Kontrollkästchen TLS-Verschlüsselung erforderlich. In Hochsicherheitsumgebungen werden häufig digitale Zertifikate verwendet. Wenn Sie dieses Kontrollkästchen aktivieren, müssen Sie im entsprechenden Feld Standarddomäne den Domänennamen für Windows 2000 Server oder Windows Server 2003 eingeben, den der Benutzer zur Authentifizierung verwenden kann, wenn der Benutzer keine Domäne angibt. Weitere Informationen zu TLS-Verschlüsselung finden Sie in der Exchange-Onlinedokumentation.

Weitere Informationen zum Konfigurieren der Exchange Server 2003-Organisation für das sicherere Senden und Empfangen von E-Mails über das Internet finden Sie im Transport- und Routing-Handbuch für Exchange Server 2003 unter http://go.microsoft.com/fwlink/?LinkId=26041.


SMTP-Dienst deaktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2006-05-16

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Microsoft Windows Management Instrumentation) Win32_Service ab, um den Wertesatz für den Schlüssel StartMode des SMTP-Diensts (Simple Mail Transfer Protocol) zu bestimmen. Der Wert Disabled zeigt an, dass der SMTP-Dienst deaktiviert wurde und erst gestartet werden kann, nachdem der Wert StartMode entweder in Manual oder Automatic geändert wurde.

Exchange Server Analyzer fragt die WMI-Klasse Win32_Service ab, um den Wert des Schlüssels Started für den SMTP-Dienst zu bestimmen. Der Wert False gibt an, dass der Dienst nicht ausgeführt wird. Der Wert True gibt an, dass der Dienst ausgeführt wird.

Wenn Exchange Server Analyzer feststellt, dass auf einem Computer mit Exchange Server, auf dem der SMTP-Dienst gestartet wurde, der Wert des Schlüssels StartMode auf Disabled festgelegt ist, wird eine Warnung angezeigt.

Der SMTP-Dienst in Windows ist eine Komponente von Internetinformationsdienste (IIS) und wird als Teil von Inetinfo.exe ausgeführt. Exchange Server verwendet den SMTP-Dienst als systemeigenes Transportprotokoll. Deshalb verwendet Exchange SMTP für das Routing aller in- und externen Nachrichten.

Auf sämtlichen Computern mit Exchange Server muss der SMTP-Dienst auf Automatic festgelegt sein.

Um diesen Fehler zu beheben, müssen Sie den SMTP-Dienst so konfigurieren, dass er auf Servern, die Nachrichten routen, automatisch gestartet wird.

So konfigurieren Sie den SMTP-Dienst für einen automatischen Start

  1. Öffnen Sie das MMC-Snap-In (Microsoft Management Console) Dienste.

  2. Doppelklicken Sie auf den Dienst Simple Mail Transfer Protocol (SMTP).

  3. Wählen Sie auf der Seite Eigenschaften von Simple Mail Transfer Protocol (SMTP) auf der Registerkarte Allgemein im Dropdowndialogfeld Starttyp die Option Automatisch aus, und klicken Sie dann auf Übernehmen.

  4. Klicken Sie unter Serverstatus auf Start, und klicken Sie dann auf OK.

  5. Schließen Sie das Snap-In Dienste.

Weitere Informationen zum SMTP-Dienst und Exchange Server finden Sie im Abschnitt zur SMTP-Transportarchitektur im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Weitere Informationen zum Konfigurieren des SMTP-Diensts für Exchange finden Sie unter "Configuring SMTP in Microsoft Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=24866).


SMTP-Dienst nicht gestartet
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2007-03-13

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Microsoft Windows® Management Instrumentation - Microsoft Windows®-Verwaltungsinstrumentation) Win32_Service ab, um den Wert des Schlüssels Started des SMTP-Diensts (Simple Mail Transfer Protocol) zu bestimmen. Der Wert False gibt an, dass der SMTP-Dienst nicht ausgeführt wird. Der Wert True gibt an, dass der SMTP-Dienst ausgeführt wird.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Schlüssels Started auf False festgelegt ist, wird von Exchange Server Analyzer ein Fehler angezeigt.

Der SMTP-Dienst in Windows ist eine Komponente von Internetinformationsdienste (IIS) und wird als Teil von Inetinfo.exe ausgeführt. Exchange Server verwendet den SMTP-Dienst als systemeigenes Transportprotokoll. Deshalb verwendet Exchange SMTP für das Routing aller in- und externen Nachrichten.

Der SMTP-Dienst muss stets auf Servern mit Exchange ausgeführt werden.

So beheben Sie diesen Fehler

  1. Öffnen Sie das MMC-Snap-In (Microsoft Management Console) Dienste.

  2. Führen Sie im rechten Bereich einen Bildlauf zum Dienst Simple Mail Transfer Protocol (SMTP) aus, und doppelklicken Sie darauf. Das Dialogfeld Eigenschaften von Simple Mail Transfer Protocol (SMTP) wird angezeigt.

  3. Legen Sie den Wert im Dropdownmenü Starttyp auf Automatisch fest.

  4. Klicken Sie auf Starten, um den Systemaufsichtsdienst zu starten.

  5. Klicken Sie auf OK, um die Änderungen zu speichern und das Dialogfeld Eigenschaften von Simple Mail Transfer Protocol (SMTP) zu schließen.

  6. Schließen Sie das Snap-In Dienste.

Weitere Informationen zum SMTP-Dienst und Exchange Server finden Sie unter "SMTP-Transportarchitektur" in Technisches Referenzhandbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47891).

Weitere Informationen zum Konfigurieren des SMTP-Diensts für Exchange finden Sie unter "Configuring SMTP in Microsoft Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=24866).


SMTP-Dienst auf "Manuell" festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2006-05-16

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Microsoft Windows® Management Instrumentation - Microsoft Windows®-Verwaltungsinstrumentation) Win32_Service ab, um den Wertesatz für den Schlüssel StartMode des SMTP-Diensts (Simple Mail Transfer Protocol) zu bestimmen. Der Wert Manual bedeutet, dass der SMTP-Dienst so festgelegt wurde, dass ein manueller Start erfolgen muss und kein automatischer Start stattfindet.

Exchange Server Analyzer fragt außerdem die WMI-Klasse Win32_Service ab, um den Wert des Schlüssels Started für den SMTP-Dienst zu bestimmen. Der Wert False gibt an, dass der Dienst nicht ausgeführt wird. Der Wert True gibt an, dass der Dienst ausgeführt wird.

Wenn Exchange Server Analyzer feststellt, dass auf einem Computer mit Exchange Server, auf dem der SMTP-Dienst gestartet wurde, der Wert des Schlüssels StartMode auf Manual festgelegt ist, wird eine Warnung angezeigt.

Der SMTP-Dienst in Windows ist eine Komponente von Internetinformationsdienste (IIS) und wird als Teil von Inetinfo.exe ausgeführt. Exchange Server verwendet den SMTP-Dienst als systemeigenes Transportprotokoll. Deshalb verwendet Exchange SMTP für das Routing aller in- und externen Nachrichten.

Wenn der SMTP-Dienst nicht beim Systemstart automatisch gestartet wird, kann er übersehen werden. Dies kann zu schwerwiegenden Nachrichtenflussproblemen führen.

Auf sämtlichen Computern mit Exchange Server muss der SMTP-Dienst auf Automatic festgelegt sein.

Um diesen Fehler zu beheben, müssen Sie den SMTP-Dienst so konfigurieren, dass er auf Servern, die Nachrichten routen, automatisch gestartet wird.

So konfigurieren Sie den SMTP-Dienst für einen automatischen Start

  1. Öffnen Sie das MMC-Snap-In (Microsoft Management Console) Dienste.

  2. Doppelklicken Sie auf den Dienst Simple Mail Transfer Protocol (SMTP).

  3. Wählen Sie auf der Seite Eigenschaften von Simple Mail Transfer Protocol (SMTP) auf der Registerkarte Allgemein im Dropdowndialogfeld Starttyp die Option Automatisch aus, und klicken Sie dann auf Übernehmen.

  4. Klicken Sie unter Serverstatus auf Start, und klicken Sie dann auf OK.

  5. Schließen Sie das Snap-In Dienste.

Weitere Informationen zum SMTP-Dienst und Exchange Server finden Sie im Abschnitt zur SMTP-Transportarchitektur im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Weitere Informationen zum Konfigurieren des SMTP-Diensts für Exchange finden Sie unter "Configuring SMTP in Microsoft Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=24866).


Status des SMTP-Diensts unbekannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2006-10-06

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Microsoft Windows® Management Instrumentation - Microsoft Windows®-Verwaltungsinstrumentation) Win32_Service ab, um den Wert des Schlüssels Started des SMTP-Diensts (Simple Mail Transfer Protocol) zu bestimmen. Der Wert False gibt an, dass der SMTP-Dienst nicht ausgeführt wird. Der Wert True gibt an, dass der SMTP-Dienst ausgeführt wird.

Wenn Exchange Server Analyzer den Wert des Schlüssels Started nicht ermitteln kann, wird von Exchange Server Analyzer ein Fehler angezeigt.

Dieser Fehler weist darauf hin, dass die angeforderten Daten von der WMI-Abfrage nicht abgerufen werden konnten.

Wahrscheinliche Ursachen für diesen Fehler:

  • Das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird, verfügt nicht über die nötigen Berechtigungen, um WMI-Klassen abzufragen.

  • Wegen eines Netzwerkproblems kann Exchange Server Analyzer keine Verbindung mit dem Computer herstellen.

  • Ein vorübergehender Zustand unbekannten Ursprungs hat zu einem Timeout für die Abfrage geführt.

So beheben Sie diesen Fehler

  1. Stellen Sie sicher, dass der Server, auf dem Exchange Server ausgeführt wird, gestartet wurde und mit dem Netzwerk verbunden ist.

  2. Verwenden Sie den Befehl PING, um festzustellen, ob eine Verbindung mit dem Exchange-Server hergestellt werden kann.

  3. Wenn eine Firewall vorhanden ist, überprüfen Sie, ob die RPC-Anschlüsse (Remote Procedure Call) blockiert sind.

  4. Überprüfen Sie die Berechtigungen für das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird. Das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird, muss über lokale Administratorberechtigungen für jeden durchsuchten Exchange-Server verfügen.

    Alternativ können Sie dem Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird, bestimmte WMI-Berechtigungen erteilen:

    1. Öffnen Sie auf dem Exchange-Server die MMC-Struktur (Microsoft Management Console) Computerverwaltung.

    2. Klicken Sie mit der rechten Maustaste unter Dienste und Anwendungen auf WMI-Steuerung, und klicken Sie dann auf Eigenschaften.

    3. Klicken Sie im Dialogfeld Eigenschaften von WMI-Steuerung auf die Registerkarte Sicherheit, und erweitern Sie dann Stamm.

    4. Wählen Sie den Ordner CIMV2 aus, und klicken Sie dann auf Sicherheit.

    5. Fügen Sie auf der Seite Sicherheit für ROOT\CIMV2 das Konto hinzu, unter dem Exchange Server Analyzer ausgeführt wird.

  5. Wählen Sie das Konto aus, das Sie in Schritt 5 hinzugefügt haben. Aktivieren Sie in Berechtigungen für Ausgewähltes_Konto in der Spalte Zulassen die Kontrollkästchen Remote aktivieren und Sicherheit lesen, und klicken Sie dann auf OK.

Weitere Informationen zum SMTP-Dienst und Exchange Server finden Sie unter "SMTP-Transportarchitektur" in Technisches Referenzhandbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47891).

Weitere Informationen zum Konfigurieren des SMTP-Diensts für Exchange finden Sie unter "Konfigurieren von SMTP in Microsoft Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=24866).

Weitere Informationen zur Behandlung von Problemen mit Netzwerkverbindungen finden Sie im Microsoft Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Weitere Informationen zur Behandlung von Verbindungsproblemen bei Exchange Server Analyzer finden Sie unter "Problembehandlung bei Verbindungsproblemen mit Microsoft Exchange Server Best Practices Analyzer" (http://go.microsoft.com/fwlink/?LinkId=56285).


Die Registrierungswerte „UseAltRegionalCharset" und „UseRegionalCharset" sind aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft® Exchange Server Analyzer liest die folgenden Registrierungseinträge, um die Spracheinstellungen zu ermitteln, die von Microsoft Outlook® Web Access-Clients verwendet werden:

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

    Der Wert 1 bewirkt, dass Nachrichtentexte in UTF-8 im regionalen Zeichensatz oder der regionalen Codeseite und nicht im UTF-8-Format im Speicher bleiben. Dies ist die Standardeinstellung für den Registrierungswert UseRegionalCharset von Exchange Server 2003.

  • HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseAltRegionalCharset

Die Browserstufe bestimmt die Meldungscodierung, wenn die folgenden Bedingungen erfüllt sind:

  • Der Schlüssel UseAltRegionalCharset ist nicht oder ist auf 0 festgelegt.

  • Der entsprechende Schlüssel UseRegionalCharset ist dementsprechend ebenfalls nicht oder auf 0 festgelegt.

Eine spätere Browserversion wie Internet Explorer 5 oder höher sendet Meldungen in UTF-8. Eine frühere Browserversion oder ein anderer als Internet Explorer 5 sendet Nachrichten in der entsprechenden Codierung für die akzeptierte Sprache eben dieses Browsers.

Der Schlüssel UseAltRegionalCharset verändert nur das Verhalten bei Browsern, die auf Sprachen der folgenden Auflistung konfiguriert sind:

  • Koreanisch: KS_C_5601-1987

  • Japanisch: shift_jis

  • Westeuropa: windows-1252

  • Russisch: windows-1251

  • Mitteleuropa: windows-1250

Wenn der Schlüssel the UseAltRegionalCharset auf 1 festgelegt ist, senden ältere und jüngere Browser die Nachrichten in folgenden Codierungen:

  • Koreanisch: euc_kr

  • Japanisch: iso-2022-jp (JIS)

  • Westeuropa: iso-8859-1

  • Russisch: koi8-r

  • Mitteleuropa: iso-8859-2

Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Objekte mit der Objektklasse msExchExchangeServer zu ermitteln.

  • Wenn der Zeichenfolgenwert „Version 6.0" enthält, wird auf dem Computer Microsoft Exchange 2000 Server ausgeführt.

  • Wenn die Zeichenfolge den Wert „Version 6.5" enthält, wird auf dem Computer Microsoft Exchange Server 2003 ausgeführt.

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Sowohl UseAltRegionalCharset als auch UseRegionalCharset sind vorhanden

  • Sowohl UseAltRegionalCharset als auch UseRegionalCharset sind so konfiguriert, dass Sie bei einem Exchange 2000-Server wie auch einem Exchange 2003-Server den Wert 1 verwenden.

Bei Exchange 2000 Server und Exchange Server 2003 haben die alternativen Zeichensätze den Vorrang, wenn die folgenden Bedingungen erfüllt sind:

  • Die Verwendung regionaler Zeichen ist aktiviert - der UseRegionalCharset Wert des Registrierungsschlüssels REG_DWORD lautet -1.

  • Die Verwendung alternativer Zeichensätze ist aktiviert - der UseAltRegionalCharset Wert des Registrierungsschlüssels REG_DWORD lautet 0x1.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So beheben Sie dieses Problem

  1. Öffnen Sie auf dem Exchange-Computer einen Registrierungs-Editor, z. B. Regedit.exe oder Regedt32.exe.

  2. Stellen Sie fest, welche Outlook Web Access-Spracheinstellungen für die Exchange Server-Umgebung geeignet sind, und entfernen Sie den nicht geeigneten Schlüssel.

    1. Navigieren Sie zu: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

    2. Wählen Sie den Schlüssel, der entfernt werden soll, klicken Sie mit der rechten Maustaste auf diesen Schlüssel, und wählen Sie dann aus der Dropdown-Liste Löschen.

  3. Schließen Sie den Registrierungs-Editor.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen über die Spracheinstellungen für Outlook Web Access finden Sie in den folgenden Informationsquellen zu Exchange Server:

„Exchange Server Client Access Guide" unter http://go.microsoft.com/fwlink/?LinkId=47568.

Microsoft Knowledge Base-Artikel 311342, „XCCC: Exchange 2000 Server SP2 Server-Side OWA Registry Keys" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311342).


Der Registrierungswert „UseAltRegionalCharset" ist auf Exchange 2000 Server aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob UseAltRegionalCharset für Microsoft Outlook® Web als Spracheinstellung der Client-Sprache verwendet wird:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseAltRegionalCharset

Die Browserstufe bestimmt die Meldungscodierung, wenn die folgenden Bedingungen erfüllt sind:

  • Der Schlüssel UseAltRegionalCharset ist nicht oder ist auf 0 festgelegt.

  • Der entsprechende Schlüssel UseRegionalCharset ist dementsprechend ebenfalls nicht oder auf 0 festgelegt.

Der Schlüssel UseAltRegionalCharset verändert nur das Verhalten bei Browsern, die auf Sprachen der folgenden Auflistung konfiguriert sind:

  • Koreanisch: KS_C_5601-1987

  • Japanisch: shift_jis

  • Westeuropa: windows-1252

  • Russisch: windows-1251

  • Mitteleuropa: windows-1250

Wenn der Schlüssel the UseAltRegionalCharset auf 1 festgelegt ist, senden ältere und jüngere Browser die Nachrichten in folgenden Codierungen:

  • Koreanisch: euc_kr

  • Japanisch: iso-2022-jp (JIS)

  • Westeuropa: iso-8859-1

  • Russisch: koi8-r

  • Mitteleuropa: iso-8859-2

Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Objekte mit der Objektklasse msExchExchangeServer zu ermitteln. Wenn der Zeichenfolgenwert „Version 6.0" enthält, wird auf dem Computer Microsoft Exchange 2000 Server ausgeführt.

Wenn Exchange Server Analyzer feststellt, dass UseAltRegionalCharset auf einem Computer mit Exchange Server 2000 für die Verwendung eines Wertes größer als 0 konfiguriert ist, wird von Exchange Server Analyzer eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Diese Meldung zeigt an, dass der Registrierungsparameter UseAltRegionalCharset auf diesem Exchange 2003-Server aktiviert ist. Wenn Sie erwarten, dass Benutzer von Outlook Web Access in Ihrer Organisation regelmäßig E-Mails an Empfänger senden, die eine Vielzahl von Zeichensätzen verwenden, können Sie die Registrierungseinstellungen so modifizieren, dass Benutzer mit Internet Explorer 5 oder späteren Versionen auch UNICODE-Zeichen in UTF-8 zum Versenden von E-Mail verwenden können. Wenn Sie keine mehrere Zeichensätze benötigen, können Sie die Standardkonfiguration mit dem folgenden Verfahren wiederherstellen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardspracheinstellung für Outlook Web Access wieder her

  1. Öffnen Sie auf dem Exchange-Computer einen Registrierungs-Editor, z. B. Regedit.exe oder Regedt32.exe.

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. Löschen Sie im rechten Fenster den Registrierungswert UseAltRegionalCharSet.

  4. Schließen Sie den Registrierungs-Editor.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen über die Spracheinstellungen für Outlook Web Access finden Sie im Microsoft Knowledge Base-Artikel 311342 „XCCC: Exchange 2000 Server SP2 Server-Side OWA Registry Keys" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311342).


Der Registrierungswert „UseAltRegionalCharset" ist auf Exchange Server 2003 aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu überprüfen, ob es den Registrierungswert UseAltRegionalCharset gibt:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\

Der Registrierungswert UseAltRegionalCharset ermöglicht es Benutzern von Microsoft Outlook® Web Access, E-Mails mit einem alternativen Zeichensatz zu codieren.

Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Objekte mit der Objektklasse msExchExchangeServer zu ermitteln. Wenn die Zeichenfolge den Wert „Version 6.5" enthält, wird auf dem Computer Microsoft Exchange Server 2003 ausgeführt.

Wenn Exchange Server Analyzer feststellt, dass der Registrierungswert für UseAltRegionalCharset auf einem Exchange-Server auf einen Wert größer als 0 festgelegt ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Diese Meldung zeigt an, dass UseAltRegionalCharset auf diesem Exchange 2003-Server konfiguriert wurde. Diese Einstellung kann zu ungewünschter Codierung von Zeichensätzen bei Outlook Web Access-Nachrichten führen, sodass einige Nachrichten für manche Clients nicht lesbar sind. Wir empfehlen sicherzustellen, dass die Spracheinstellungen des Client richtig sind.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardspracheinstellung für Outlook Web Access unter Exchange Server 2003 wieder her

  1. Öffnen Sie auf dem Exchange-Computer einen Registrierungs-Editor, z. B. Regedit.exe oder Regedt32.exe.

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. Löschen Sie im rechten Fenster den Registrierungswert UseAltRegionalCharSet.

  4. Wenn der Registrierungswert UseRegionalCharset nicht existiert, gehen Sie folgendermaßen vor, um ihn zu erstellen:

    1. Klicken Sie im Menü Bearbeiten auf Neu, und klicken Sie dann auf DWORD-Wert.

    2. Geben Sie für DWORD den Namen UseRegionalCharset ein, und drücken Sie dann die EINGABETASTE.

  5. Wenn UseRegionalCharset vorhanden ist, doppelklicken Sie darauf, um den Wert zu bearbeiten.

  6. Geben Sie im Feld Datenwerte den Wert 1 ein, und klicken Sie dann auf OK.

  7. Schließen Sie den Registrierungs-Editor.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zu den Registrierungswerten UseAltRegionalCharSet und UseRegionalCharset finden Sie im Microsoft Knowledge Base-Artikel 283214 „XCCC: Outlook Web Access May Send a Japanese-Language Message in SJIS" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=283214).


Der Registrierungswert „UseRegionalCharset" ist auf Exchange 2000 Server aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Spracheinstellungen zu ermitteln, die von Microsoft Outlook® Web Access-Clients verwendet werden:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

Der Registrierungswert UseRegionalCharset bewirkt, dass Nachrichtentexte in UTF-8 im regionalen Zeichensatz oder der regionalen Codeseite und nicht im UTF-8-Format im Speicher bleiben.

Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Objekte mit der Objektklasse msExchExchangeServer zu ermitteln. Wenn der Zeichenfolgenwert „Version 6.0" enthält, wird auf dem Computer Microsoft Exchange 2000 Server ausgeführt.

Wenn Exchange Server Analyzer feststellt, dass UseRegionalCharset auf einem Computer mit Exchange 2000 Server für die Verwendung eines Wertes von 1 oder mehr konfiguriert ist, wird von Exchange Server Analyzer eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Diese Meldung zeigt an, dass der Registrierungsparameter UseRegionalCharset auf diesem Exchange 2000-Server aktiviert ist. Wenn Sie erwarten, dass Benutzer von Outlook Web Access in Ihrer Organisation regelmäßig E-Mails an Empfänger senden, die eine Vielzahl von Zeichensätzen verwenden, können Sie die Registrierungseinstellungen so modifizieren, dass Benutzer mit Internet Explorer 5 oder späteren Versionen auch UNICODE-Zeichen in UTF-8 zum Versenden von E-Mail verwenden können. Wenn Sie keine mehrere Zeichensätze benötigen, können Sie die Standardkonfiguration mit dem folgenden Verfahren wiederherstellen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardspracheinstellung für Outlook Web Access wieder her

  1. Öffnen Sie auf dem Exchange-Computer einen Registrierungs-Editor, z. B. Regedit.exe oder Regedt32.exe.

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. Löschen Sie im rechten Fenster den Registrierungswert UseRegionalCharSet.

  4. Schließen Sie den Registrierungs-Editor.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Registrierungswert UseRegionalCharset ist deaktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Spracheinstellungen zu ermitteln, die von Microsoft Outlook® Web Access-Clients verwendet werden:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

Der Registrierungswert UseRegionalCharset bewirkt, dass Nachrichtentexte in UTF-8 im regionalen Zeichensatz oder der regionalen Codeseite und nicht im UTF-8-Format im Speicher bleiben.

Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Objekte mit der Objektklasse msExchExchangeServer zu ermitteln. Wenn die Zeichenfolge den Wert „Version 6.5" enthält, wird auf dem Computer Microsoft Exchange Server 2003 ausgeführt.

Wenn Exchange Server Analyzer feststellt, dass UseRegionalCharset auf einem Computer mit Exchange Server 2003 für die Verwendung eines Wertes von 0 konfiguriert ist, wird von Exchange Server Analyzer eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Diese Meldung zeigt an, dass der Registrierungsparameter UseRegionalCharset auf diesem Exchange 2003-Server deaktiviert ist. Diese Einstellung kann zu ungewünschter Codierung von Zeichensätzen bei Outlook Web Access-Nachrichten führen, sodass einige Nachrichten für manche Clients nicht lesbar sind.

Wenn Sie Microsoft Internet Explorer 5 oder spätere Versionen verwenden, um auf Outlook Web Access zuzugreifen, verwendet Exchange Server 2003 die Spracheinstellungen des Browsers, um zu bestimmen, welcher Zeichensatz verwendet werden muss, um Informationen wie E-Mail-Nachrichten und Besprechungseinladungen zu codieren.

Wenn Sie erwarten, dass Benutzer von Outlook Web Access in Ihrer Organisation regelmäßig E-Mails an Empfänger senden, die eine Vielzahl von Zeichensätzen verwenden, können Sie die Registrierungseinstellungen so modifizieren, dass Benutzer mit Internet Explorer 5 oder späteren Versionen auch UNICODE-Zeichen in UTF-8 zum Versenden von E-Mail verwenden können.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardspracheinstellung für Outlook Web Access wieder her

  1. Öffnen Sie auf dem Exchange-Computer einen Registrierungs-Editor, z. B. Regedit.exe oder Regedt32.exe.

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. Wenn UseRegionalCharset nicht existiert, gehen Sie folgendermaßen vor, um ihn zu erstellen:

    1. Klicken Sie im Menü Bearbeiten auf Neu, und klicken Sie dann auf DWORD-Wert.

    2. Geben Sie für DWORD den Namen UseRegionalCharset ein, und drücken Sie dann die EINGABETASTE.

  4. Wenn UseRegionalCharset vorhanden ist, doppelklicken Sie darauf, um den Wert zu bearbeiten.

  5. Geben Sie im Feld Datenwerte den Wert 1 ein, und klicken Sie dann auf OK.

  6. Schließen Sie den Registrierungs-Editor.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zu den Spracheinstellungen für Outlook Web Access finden Sie im „Exchange Server Client Access Guide" (http://go.microsoft.com/fwlink/?LinkId=47568).


Der Registrierungswert UseRegionalCharset ist deaktiviert oder fehlt unter Exchange Server 2003
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Spracheinstellungen zu ermitteln, die von Microsoft Outlook® Web Access-Clients verwendet werden:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

Der Registrierungswert UseRegionalCharset bewirkt, dass Nachrichtentexte in UTF-8 im regionalen Zeichensatz oder der regionalen Codeseite und nicht im UTF-8-Format im Speicher bleiben.

Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Objekte mit der Objektklasse msExchExchangeServer zu ermitteln. Wenn die Zeichenfolge den Wert „Version 6.5" enthält, wird auf dem Computer Microsoft Exchange Server 2003 ausgeführt.

Exchange Server Analyzer zeigt eine Warnmeldung an, wenn eine der beiden folgenden Bedingungen erfüllt ist:

  • Der Eintrag UseRegionalCharset ist für einen Exchange 2003-Server nicht vorhanden.

  • Der Wert von UseRegionalCharset beträgt nicht 1.

Diese Meldung zeigt an, dass der Registrierungsparameter UseRegionalCharset auf diesem Exchange 2003-Server deaktiviert ist oder fehlt. Diese Einstellung kann zu ungewünschter Codierung von Zeichensätzen bei Outlook Web Access-Nachrichten führen, sodass einige Nachrichten für manche Clients nicht lesbar sind.

Wenn Sie Microsoft Internet Explorer 5 oder spätere Versionen verwenden, um auf Outlook Web Access zuzugreifen, verwendet Exchange Server 2003 die Spracheinstellungen des Browsers, um zu bestimmen, welcher Zeichensatz verwendet werden muss, um Informationen wie E-Mail-Nachrichten und Besprechungseinladungen zu codieren.

Wenn Sie erwarten, dass Benutzer von Outlook Web Access in Ihrer Organisation regelmäßig E-Mails an Empfänger senden, die eine Vielzahl von Zeichensätzen verwenden, können Sie die Registrierungseinstellungen so modifizieren, dass Benutzer mit Internet Explorer 5 oder späteren Versionen auch UNICODE-Zeichen in UTF-8 zum Versenden von E-Mail verwenden können.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardspracheinstellung für Outlook Web Access wieder her

  1. Öffnen Sie auf dem Exchange-Computer einen Registrierungs-Editor, z. B. Regedit.exe oder Regedt32.exe.

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. Wenn UseRegionalCharset nicht existiert, gehen Sie folgendermaßen vor, um ihn zu erstellen:

    1. Klicken Sie im Menü Bearbeiten auf Neu, und klicken Sie dann auf DWORD-Wert.

    2. Geben Sie für DWORD den Namen UseRegionalCharset ein, und drücken Sie dann die EINGABETASTE.

  4. Wenn UseRegionalCharset vorhanden ist, doppelklicken Sie darauf, um den Wert zu bearbeiten.

  5. Geben Sie im Feld Datenwerte den Wert 1 ein, und klicken Sie dann auf OK.

  6. Schließen Sie den Registrierungs-Editor.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zu den Spracheinstellungen für Outlook Web Access finden Sie im „Exchange Server Client Access Guide" (http://go.microsoft.com/fwlink/?LinkId=47568).


Benutzerlast und MAPI-Operationen
Microsoft Exchange Server Analyzer-Tools - Artikel > Protokolle >

Letztes Änderungsdatum des Themas: 2006-10-17

Microsoft® Exchange Server Analyzer hat festgestellt, dass einige wenige MAPI-Operationen auf dem Server einen erheblichen Anteil zu der Benutzerlast auf dem Server beitragen. Dies wird durch Abfrage von Operationen festgestellt, die, bezogen auf die insgesamt verbrauchte CPU-Zeit, mehr als 4 Prozent der CPU-Zeit verbrauchen, die für die Verarbeitung aller RPC-Anforderungen aufgewendet wird.

Hauptursachen für MAPI-Vorgänge mit hoher CPU-Auslastung

Wenn Administratoren eine schlechte Leistung von Exchange Server untersuchen möchten, sollten sie prüfen, ob die durchschnittliche Postfachgröße auf Servern mit schlechter Leistung hoch ist. Sie sollten feststellen, ob einzelne Ordner zu groß sind (mehr als 5.000 Elemente im Posteingang, bei den gesendeten oder den gelöschten Objekten oder im Kalender). Große Ordner und das Anwachsen des Postfachs können zu höherer CPU- und E/A-Last führen. Eine Zunahme der Anzahl von Sichten für jeden Ordner kann viele MAPI-Operationen ebenfalls mit zusätzlichem Overhead belasten.

Ansichten

Viele der häufig verwendeten und lange laufenden MAPI-Operationen stehen im Zusammenhang mit Ansichten. Zwei bekante davon sind Restrict und FindRow. Diese Operationen dauern nicht immer lange. Wenn deren Leistung also ein Problem darstellt, sollten Sie den Grund dafür ermitteln. Beachten Sie zusätzlich zu den folgenden Gründen auch, dass die Wartezeiten für Operationen zunehmen, wenn es einen Ressourcen-Engpass (im Allgemeinen einen Datenträger- oder CPU-Engpass) gibt.

Hinweis:
Manchmal resultiert hoher Aufwand durch TaskQ User Known in Verbindung mit Restrict oder FindRow. Dies liegt daran, dass ein Teil der Arbeit für diese Operationen in einer TaskQ durchgeführt wird und der Aufwand TaskQ User Known zugerechnet wird.

Einschränkungen

Die MAPI-Operation Restrict dient dazu, solche Objekte auszusuchen, die bestimmten Kriterien entsprechen. Der Server erstellt eine Ansicht, also eigentlich eine Tabelle mit zugehörigen Kriterien, die als Einschränkung bezeichnet wird. Wenn es die Ansicht mit einer passenden Einschränkung bereits gibt, verwendet der Server die vorhandene Ansicht, um die Benutzeranforderung zu erfüllen. Das Verwenden dieser Ansicht verursacht relativ geringen Aufwand, während das Erstellen einer neuen Ansicht ziemlich aufwändig ist. In der Standardeinstellung werden im Speicher nur 11 Ansichten pro Ordner zwischengespeichert. Wenn der Server aufgefordert wird, eine zwöfte Ansicht zu erstellen, löscht er die älteste Ansicht im Zwischenspeicher und erstellt eine neue. Ansichten erhöhen den Overhead aller Aktionen auf Elemente, auf die die Beschränkungen dieser Sicht zutreffen.

Findrow

Clientanwendungen verschieben mithilfe der MAPI-Vorgänge SeekRow oder FindRow den Cursor zwischen den Datensätzen in einer Ansicht. SeekRowLegt fest, um wie viele Reihen der Cursor verschoben werden soll, und ist in Bezug auf die CPU-Zeit sehr wenig aufwändig. FindRow ist ziemlich aufwändig, weil damit der Cursor zum ersten Element in einer nicht materialisierten (wird nicht zwischengespeichert) Ansicht verschoben wird, die die Beschränkungskriterien erfüllt. Anschließend wird die Ansicht verworfen, nachdem die Client-Anwendung den Vorgang abgeschlossen hat. Die endgültigen CPU-Kosten von FindRow hängen von der Komplexität der Beschränkung und davon ab, wieviele Reihen der Speicher überprüfen muss, bis er das erste den Kriterien entsprechende Objekt findet. Auf diese Weise sind sie schwach mit der Anzahl der Elemente im Ordner korreliert.

Der möglicherweise hohe Kosten in Verbindung mit Restrict und FindRow lassen diese beiden als gute Kandidaten für Zwischenspeicherungsmodus erscheinen, weil damit der Server von den Kosten befreit wird. Seien Sie sich bewusst, dass der von diesen beanspruchte hohe Anteil an der CPU-Leistung manchmal durch gemeinsame Kalender verursacht sein kann. In diesem Fall hilft auch Zwischenspeicherung nicht. Hoher Verbrauch von CPU-Zeit durch diese Operationen könnte darauf hindeuten, dass viele oder aufwändige Ansichten erstellt werden oder dass viele Objekte in den Ordnern sind.

Weitere Informationen

Weitere Informationen finden Sie in den folgenden Ressourcen zu Exchange Server:

  • „Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47576).

  • „Exchange Server 2003 Performance: 10 Things to Think About" (http://go.microsoft.com/fwlink/?LinkId=56460)


Speicher
Microsoft Exchange Server Analyzer-Tools - Artikel >

Letztes Änderungsdatum des Themas: 2005-11-18

Die Artikel in diesem Abschnitt enthalten Details darüber, welche Daten Microsoft® Exchange Server Analyzer bezüglich des Speichers auswertet. Darüber hinaus werden darin Aktionen beschrieben, die Sie durchführen können, um Fehler, Warnungen und Meldungen zu vom Standard abweichenden Konfigurationen im Zusammenhang mit dem Speicher zu beheben, die vom Microsoft Exchange Server Analyzer gefunden werden.


Das Aging-Clean-Intervall für einen Postfachspeicher entspricht nicht der Standardeinstellung
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-05

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob das Intervall zum Entfernen von nicht verwendeten Datenbankindizes von der Standardeinstellung abweicht:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Aging Clean Interval

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel Aging Clean Interval vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Eine der Funktionen von ESE (Extensible Storage Engine) dient zum dynamischen Erstellen von Indizes, wenn Informationen neu sortiert oder in einer anderen Sortierreihenfolge angefordert werden. Daraus ergibt sich möglicherweise eine Exchange-Speicherdatenbank mit Tausenden Indizes für eine Tabelle. Der Exchange-Speicher löst dieses Problem, indem Indizes eine Verfallszeit zugewiesen wird. Einer als Indexalterungstabelle bezeichneten internen Tabelle werden Informationen zum Index hinzugefügt. Während der Online-Wartung wird die Indexalterungstabelle überprüft, und für jeden Eintrag wird der Wert des Löschzeitpunkts mit der aktuellen Uhrzeit verglichen. Nach Ablauf der Verfallszeit wird der Index entfernt. In der Standardeinstellung wird dieser Prozess alle 24 Stunden während des Exchange-Speicherwartungzyklus ausgeführt. Dabei werden alle Einträge für Exchange Server 5.5 entfernt, die älter als acht Tage sind. Dies gilt auch für alle Einträge für Exchange 2000 Server, Exchange Server 2003 und Exchange Server 2007, die älter als 40 Tage sind. Der Schlüssel Aging Clean Interval ist das Intervall in Millisekunden, in dem der Exchange-Speicher versucht, nicht verwendete Indizes zu entfernen. Mit dem Registrierungsschlüssel kann dieser Standardwert überschrieben werden und diese Funktion in einem benutzerdefinierten Intervall ausgeführt werden.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Löschen Sie den Schlüssel Aging Clean Interval.

  4. Schließen Sie den Registrierungs-Editor.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Schlüssel Aging Clean Interval finden Sie in den folgenden Knowledge Base-Artikeln:

  • 159197, „XADM: Steuern der Indexverfallszeit von Ordnern" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=159197

  • 216076, „Accessing information store folders may become slow in Exchange" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=216076


Das Aging-Clean-Intervall für einen Informationsspeicher für Öffentliche Ordner entspricht nicht der Standardeinstellung
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob das Intervall zum Entfernen von nicht verwendeten Datenbankindizes von der Standardeinstellung abweicht:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\Aging Clean Interval

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel Aging Clean Interval vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Eine der Funktionen von ESE (Extensible Storage Engine) dient zum dynamischen Erstellen von Indizes, wenn Informationen neu sortiert oder in einer anderen Sortierreihenfolge angefordert werden. Daraus ergibt sich möglicherweise eine Exchange-Speicherdatenbank mit Tausenden Indizes für eine Tabelle. Der Exchange-Speicher löst dieses Problem, indem Indizes eine Verfallszeit zugewiesen wird. Einer als Indexalterungstabelle bezeichneten internen Tabelle werden Informationen zum Index hinzugefügt. Während der Online-Wartung wird die Indexalterungstabelle überprüft, und für jeden Eintrag wird der Wert des Löschzeitpunkts mit der aktuellen Uhrzeit verglichen. Nach Ablauf der Verfallszeit wird der Index entfernt. In der Standardeinstellung wird dieser Prozess alle 24 Stunden während des Exchange-Speicherwartungzyklusses ausgeführt. Dabei werden alle Einträge für Exchange Server 5.5 entfernt, die älter als acht Tage sind. Dies gilt auch für alle Einträge von Exchange 2000 Server und Exchange Server 2003, die älter als 40 Tage sind. Der Schlüssel Aging Clean Interval ist das Intervall in Millisekunden, in dem der Exchange-Speicher versucht, Indizes zu entfernen. Mit dem Registrierungsschlüssel kann dieser Standardwert überschrieben werden und diese Funktion in einem benutzerdefinierten Intervall ausgeführt werden.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. Löschen Sie den Schlüssel Aging Clean Interval.

  4. Schließen Sie den Registrierungs-Editor.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Schlüssel Aging Clean Interval finden Sie in den folgenden Knowledge Base-Artikeln:

  • 159197, „XADM: Steuern der Indexverfallszeit von Ordnern" unter http://support.microsoft.com/?scid=kb%3Bde%3B159197&x=17&y=10&kbid=159197

  • 216076, „Accessing information store folders may become slow in Exchange" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=216076


Alle Versionen von Outlook können auf den Server zugreifen
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-05

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob Versionen von Microsoft Office Outlook® am Herstellen einer Verbindung mit Exchange Server gehindert werden:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Stellt Exchange Server Analyzer fest, dass der Schlüssel Disable MAPI Clients nicht vorhanden ist, wird eine Warnung angezeigt.

Mithilfe des Schlüssels Disable MAPI Clients, der in der Standardeinstellung nicht aktiviert ist, kann ein Administrator verhindern, dass bestimmte Versionen von Outlook eine Verbindung mit einem Computer herstellen, auf dem Exchange 2000 Server, Exchange Server 2003 oder Exchange Server 2007 ausgeführt wird.

Die aktuellen Versionen und Service Packs von Outlook enthalten viele Verbesserungen in Bezug auf Sicherheit und Virenschutz. Von Outlook 2002 an ist Object Model Guard und das Blockieren von Anlagen als Standard einbezogen und aktiviert. Diese Funktionen stellen im Kampf gegen Viren eine entscheidende Komponente dar. Die älteste Version von Outlook, die vom technischen Support von Microsoft unterstützt wird, ist Outlook 2000 Service Pack 3 (SP3). Wenn Sie in Ihrer Organisation ältere Versionen von Outlook verwenden, aktualisieren Sie auf Outlook 2003, oder aktualisieren Sie zumindest den Outlook-Client mit den neuesten Sicherheitsveröffentlichungen.

Nach dem Aktualisieren von Outlook können Sie den Zugriff nicht aktualisierter früherer Versionen von Outlook auf Exchange sperren. Durch das Blockieren früherer Versionen von Outlook, die Object Model Guard und das Sperren von Anlagen nicht unterstützen, wird das Herstellen einer vorgegebenen Stufe von Client-Sicherheit für MAPI-Client-Verbindungen unterstützt.

Um Schutz vor allen früheren Versionen von Outlook (Outlook 97, Outlook 98, Outlook 2000 vor SP3 und frühere Versionen) zu gewährleisten, wird dringend empfohlen, dass Sie alle Versionen von Outlook mit Build-Nummern von 5.3164.0.0 oder früher am Herstellen von Verbindungen zu Exchange Server hindern.

Die Versionszeichenfolge des Clients wird von diesem selbst bestimmt. Diese Zeichenfolge ähnelt der Versionsnummer, die im Dialogfeld Info für den Client angegeben ist. Verlassen Sie sich jedoch nicht auf diese Versionsnummer. Verwenden Sie stattdessen den Exchange-System-Manager, um auf der Anmeldeseite für den Postfachspeicher die Eigenschaft Client Version anzuzeigen.

Wichtig:
Beachten Sie, bevor Sie irgendwelche Änderungen vornehmen, dass Hotfixes und Service Pack-Versionen die Clientversion-Zeichenfolge möglicherweise beeinflussen. Seien Sie umsichtig, wenn Sie den Clientzugriff beschränken, weil auch serverseitige Exchange-Komponenten zum Anmelden MAPI verwenden müssen. Von einigen Komponenten wird die Clientversion als Komponentenname, z. B. SMTP oder OLEDB, mitgeteilt, während von anderen die Exchange-Buildnummer, z. B. 6.0.4712.0, mitgeteilt wird. Aus diesem Grund sollten Sie vermeiden, Clients mit Versionsnummern zu beschränken, die mit 6.<x.x> beginnen. Um beispielsweise den MAPI-Zugriff vollständig zu verhindern, geben Sie anstelle von 0.0.0-65535.65535.65535 wie folgt zwei Bereiche an, sodass sich die Serverkomponenten anmelden können: 0.0.0-5.9.9; 7.0.0-65535.65535.65535.
Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Erstellen Sie den neuen Zeichenfolgenwerteintrag Disable MAPI Clients.

  4. Doppelklicken Sie auf den Registrierungseintrag Disable MAPI Clients, und legen Sie die Datenwerte auf die gewünschte Ebene fest. Die Liste von Werten in der Wertdaten-Zeichenfolge stellt die verschiedenen Methoden zum Deaktivieren von Bereichen von MAPI-Client-Versionen dar. Die Versionen (VX) liegen normalerweise in den folgenden Formaten vor:

    • Für Microsoft Outlook 2003 und Outlook 2007: Maj.Min.Build

    • Für Microsoft Outlook 2000: Maj.Build.Dot

    • Für frühere Versionen von Microsoft Outlook: Maj.Min.Build

    In dieser Zeichenfolge können Sie alle bestimmten Versionen oder Versionsbereiche angeben, die deaktiviert werden sollen. Verwenden Sie den Exchange-System-Manager, um in Exchange Server 2003 die Version der MAPI-Clients zu ermitteln, die eine Verbindung zum Postfachspeicher herstellen. Suchen Sie im Exchange-System-Manager nach dem Container Anmeldungen des Postfachspeichers. Die Spalte Clientversion enthält die Version der MAPI-Clients, die mit dem Postfachspeicher verbunden sind.

    Verwenden Sie in Exchange Server 2007 in der Exchange-Verwaltungsshell das Cmdlet Get-LogonStatistics, um die Version der MAPI-Clients abzurufen, die mit der Postfachdatenbank verbunden sind.
Wichtig:
Die Version des MAPI-Clients wird im Exchange-System-Manager und in der Exchange-Verwaltungsshell im Format X.0.Y.Z angegeben. Die Version muss als X.Y.Z in den Registrierungswert eingegeben werden. Wenn im Exchange-System-Manager die MAPI-Clientversion 5.0.2819.0 angegeben ist, geben Sie im Registrierungswert Disable MAPI Clients Folgendes ein: 5.2819.0.
  1. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Weitere Informationen zum Blockieren der Herstellung einer Verbindung von bestimmten MAPI-Clients mit einem Exchange 2000 Server- oder Exchange Server 2003-Computer finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 328240, „How to put server-side restrictions on clients that are used to access Exchange 2000 mailboxes" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328240)

  • 288894, "XADM: Feature to Disable MAPI Client Access" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=288894)

Weitere Informationen zum Downloaden von Sicherheits-Updates für ältere Versionen von Outlook und zum Blockieren anderer Versionen von Outlook finden Sie unter Behindern und Blockieren von E-Mail-Viren in einer Exchange 2003-Umgebung (http://go.microsoft.com/fwlink/?LinkId=47587).

Weitere Informationen zum Cmdlet Get-LogonStatistics finden Sie in der Exchange Server 2007-Produktdokumentation unter "Get-LogonStatistics" (http://go.microsoft.com/fwlink/?LinkId=80699).


„AssertOnEvent" wurde festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungswert, um zu ermitteln, ob für den Microsoft Exchange-Informationsspeicher das Debuggen aktiviert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\AssertOnEvent

Wenn Exchange Server Analyzer feststellt, dass für AssertOnEvent ein Wert festgelegt wurde, zeigt Exchange Server Analyzer eine Warnung an.

Der Registrierungswert AssertOnEvent enthält Dezimalwerte, die angeben, bei welchen Speicherereignissen in den Debugmodus des Microsoft Exchange-Informationsspeichers gewechselt werden soll. Der Registrierungswert AssertOnEvent gibt nur Meldungen aus, wenn die Debug-Version von store.exe ausgeführt wird. Der Microsoft Exchange-Informationsspeicher verwendet im Debugmodus eine Vielzahl von Ressourcen. Es wird davon abgeraten, den Speicher in einer Produktionsumgebung zu debuggen.

Sofern Sie nicht gerade mithilfe des Technischen Supports von Microsoft aktiv ein Problem mit dem Exchange-Informationsspeicher beheben, sollten Sie den Registrierungswert AssertOnEvent löschen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So löschen Sie den Registrierungsschlüssel AssertOnEvent

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Suchen Sie im rechten Bereich den Wert AssertOnEvent, und löschen Sie ihn.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Es wurde mindestens eine beschädigte Nachricht erkannt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-05

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Anzahl der Einträge im Wert PoisonIDs zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <GUID des privaten Informationsspeichers>

Wenn Exchange Server Analyzer feststellt, dass die Anzahl der Einträge im Wert PoisonIDs größer als 0 ist, wird eine Warnung angezeigt.

In Versionen von Exchange Server höher als Exchange Server 2003 Service Pack 1 wurde ein neues Verhalten implementiert, mit dessen Hilfe verhindert werden kann, dass beschädigte oder ungültige Nachrichten zum unerwarteten Beenden des Exchange-Informationsspeicherdiensts führen oder dessen erfolgreichen Start verhindern.

In Versionen ab Exchange Server 2003 Service Pack 1 werden Nachrichten nachverfolgt, die ein unerwartetes Beenden des Exchange-Informationsspeicherdiensts während der Konvertierung vom MAPI-Format zum MIME-Format verursachen. Die Nachrichten-ID der beschädigten Nachricht wird beim Auftreten des Absturzes in der Registrierung gespeichert. Wenn eine beschädigte Nachricht dreimal zum unerwarteten Beenden des Informationsspeichers führt, wird mithilfe der Informationen beim vierten Neustart des Exchange-Informationsspeicherdienstes eine erneute Verarbeitung der Nachricht verhindert.

Wird der Exchange-Informationsspeicherdienst aufgrund einer beschädigten Nachricht unerwartet beendet, wird der Registrierungswert PoisonIDs am folgendenden Speicherort erstellt:

HKLM\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <GUID des privaten Informationsspeichers>

Darüber hinaus kann ein Administrator den Registrierungseintrag PoisonThreshold erstellen. Der Schlüssel PoisonThreshold steuert die maximale Häufigkeit, die eine Nachricht durch den Exchange-Informationsspeicherdienst transportiert werden kann, bevor sie zum Registrierungsschlüssel PoisonIDs hinzugefügt wird. In der Standardeinstellung lautet der Schwellenwert 2. Um das Verhalten auszulösen, muss die Schwelle überschritten werden. Daher kann der Exchange-Informationsspeicherdienst aufgrund einer beschädigten Datei 3 Mal beendet werden, bevor die Nachricht blockiert wird. Wenn eine Nachricht beispielsweise Ursache von 3 Abstürzen ist, wird sie blockiert, weil drei den Schwellenwert von 2 überschreitet.

Wenn ein beschädigtes Meldungsereignis in die Registrierung geschrieben wird, werden im Anwendungsereignisprotokoll Fehlerereignismeldungen (Ereignis-IDs 9680 und 9681) angezeigt. Nach dem erfolgreichen Start des Exchange-Informationsspeicherdienstes blockiert Exchange anschließend die Nachricht und versucht, einen Unzustellbarkeitsbericht dafür zu senden. In einigen Fällen ist Exchange möglicherweise nicht in der Lage, einen Unzustellbarkeitsbericht zu senden. In diesen Fällen verbleibt die blockierte Nachricht in der Warteschlange, bis sie abläuft. Der Registrierungsschlüssel PoisonIDs enthält bis zu zehn Nachrichten-ID-Werte. Wenn die Grenze von zehn überschritten wird, wird ein neues beschädigtes Nachrichtenereignis hinzugefügt. Das beschädigte Nachrichtenereignis mit dem ältesten Absturzdatum wird entfernt.

So beheben Sie dieses Problem

  1. Wenn beim Postfachspeicher Probleme mit einer beschädigten Nachricht auftreten, ist eine weitere Überprüfung des Problems erforderlich. Informationen dazu, wie Microsoft IT eine Wiederherstellung aus beschädigten Exchange-Datenbanken ausführt, finden Sie unter http://go.microsoft.com/fwlink/?LinkId=56372.

  2. Wenn Sie aufgrund beschädigter Nachrichten Probleme beim Herunterfahren von Exchange Server 2003 feststellen, kann es hilfreich sein, die automatische Fehlerberichterstattung auf dem Computer mit Exchange Server zu aktivieren. Fehlerberichtdaten werden zum Finden und Beheben von Problemen in der von Ihnen verwendeten Software verwendet. Weitere Informationen zum Aktivieren der Exchange-Fehlerberichterstattung finden Sie unter Exchange-Fehlerberichterstattung ist deaktiviert.

Weitere Informationen zum Exchange Server 2003 Service Pack 1, finden Sie auf der Website „Servicepack 1 für Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=29090).


Der Hintergrund-Cleanup für einen Postfachspeicher ist kein Standardcleanup
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die aktuellen Datenwerte für den Registrierungswert Background Cleanup festzulegen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Background Cleanup

Wenn Exchange Server Analyzer feststellt, dass der Datenwert für Background Cleanup auf einen anderen Wert als 60.000 (dezimal) oder 0xEA60 (hexadezimal) festgelegt ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht. Es wird empfohlen, Background Cleanup auf den Standardwert festzulegen.

Wird Background Cleanup auf einen zu hohen Wert festgelegt, wird der Hintergrund-Cleanup-Prozess u. U. nicht häufig genug ausgeführt, und es können u. a. folgende Probleme auftreten:

  • Das Verschieben von Postfächern schlägt u. U. fehl, und es wird möglicherweise das Ereignis 1205 mit dem Fehlercode 0x4e3 protokolliert.

  • Die im Exchange-System-Manager oder in der Exchange-Verwaltungskonsole angezeigte Größe von Ordnern und die Anzahl der angezeigten Elemente unterscheidet sich möglicherweise deutlich von den in Microsoft Outlook® angezeigten Werten. Außerdem kann der von diesen Elementen belegte Speicherplatz für Datenbanken möglicherweise nicht freigegeben werden.

  • Unter bestimmten Umständen kann für Elemente, die gelöscht wurden, ohne sie zuvor zu lesen, keine Benachrichtigung erzeugt werden.

  • Alte Einträge in der Tabelle DeliveredTo werden nicht gelöscht. Die Tabelle DeliveredTo wird vom Exchange-Informationsspeicher verwendet, um das Senden doppelter Nachrichten zu verhindern.

Wenn Background Cleanup auf einen zu niedrigen Wert festgelegt wird, verursacht der Hintergrund-Cleanup-Prozess u. U. eine unnötige Belastung des Servers.

Achtung:
Wenn Sie die in diesem Thema beschriebene Vorgehensweise befolgen, um einen überhöhten Wert wieder auf die Standardkonfiguration zurückzusetzen, kann dies zu einer verstärkten Belastung des Servers führen, solange der Hintergrund-Cleanup-Prozess noch nicht für alle Elemente abgeschlossen ist, die normalerweise während des Standardintervalls bereinigt worden wären. Es wird daher empfohlen, diese Änderungen zu einem Zeitpunkt vorzunehmen, zu dem die Beeinträchtigung der Benutzer möglichst gering gehalten werden kann. Nachdem Sie diese Warnung behoben haben, wird weiterhin für jede mit einer Lesebestätigungsanforderung versehene Nachricht, die gelöscht wurde, ohne sie zu lesen, und die aufgrund dieses Problems nicht bereinigt wurde, eine Benachrichtigung erzeugt.
Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Ändern Sie den Wert von Background Cleanup in 60.000 (dezimal) oder 0xEA60 (hexadezimal).

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Das Hintergrund-Cleanup-Intervall für einen Postfachspeicher fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob der Registrierungswert Background Cleanup vorhanden ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Background Cleanup

Wenn Exchange Server Analyzer feststellt, dass der Wert Background Cleanup fehlt, wird eine Warnung angezeigt.

Wenn der Wert Background Cleanup fehlt, wird der Hintergrund-Cleanup-Prozess u. U. nicht ausgeführt, und es können u. a. folgende Probleme auftreten:

  • Das Verschieben von Postfächern schlägt u. U. fehl, und es wird möglicherweise das Ereignis 1205 mit dem Fehlercode 0x4e3 protokolliert.

  • Die im Exchange-System-Manager oder in der Exchange-Verwaltungskonsole angezeigte Größe von Postfächern und die Anzahl der angezeigten Elemente unterscheidet sich möglicherweise deutlich von den in Microsoft Outlook® angezeigten Werten. Außerdem kann der von diesen Elementen belegte Speicherplatz für Datenbanken möglicherweise nicht freigegeben werden.

  • Unter bestimmten Umständen kann für Elemente, die gelöscht wurden, ohne sie zuvor zu lesen, keine Benachrichtigung erzeugt werden.

  • Für die Tabelle DeliveredTo wird kein Cleanup ausgeführt. Die Tabelle DeliveredTo wird vom Exchange-Informationsspeicher verwendet, um das Senden doppelter Nachrichten zu verhindern. Mit dem Wert Track Duplicates wird der Zeitraum gesteuert, für den Einträge in der Tabelle DeliveredTo beibehalten werden. Wenn der Wert Background Cleanup vorhanden ist, der Wert Track Duplicates jedoch fehlt, werden Einträge, die älter als 24 Stunden sind, beim Hintergrund-Cleanup gelöscht. Der vorgeschlagene Wert für Track Duplicates ist 1 (dezimal oder hexadezimal).

Es wird empfohlen, Background Cleanup auf den Standardwert festzulegen, der 60.000 (Dezimalwert) oder 0xEA60 (Hexadezimalwert) beträgt.

Achtung:
Wenn das nachfolgend beschriebene Verfahren zum Entfernen dieser Warnung ausgeführt wird, kann dies zu einer erhöhten Serverlast führen, bis das Hintergrund-Cleanup für alle Elemente abgeschlossen ist, die üblicherweise regelmäßig gelöscht werden. Es wird daher empfohlen, diese Änderungen zu einem Zeitpunkt vorzunehmen, zu dem die Beeinträchtigung der Benutzer möglichst gering gehalten werden kann. Nachdem Sie diese Warnung behoben haben, wird weiterhin für jede mit einer Lesebestätigungsanforderung versehene Nachricht, die gelöscht wurde, ohne sie zu lesen, und die aufgrund dieses Problems nicht bereinigt wurde, eine Benachrichtigung erzeugt.
Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So vermeiden Sie diese Warnung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Erstellen Sie den DWORD-Wert für Background Cleanup mit dem Wert 60000 (dezimal) oder 0xEA60 (hexadezimal).

  4. Schließen Sie den Registrierungs-Editor. Führen Sie einen der folgenden Schritte aus, damit die Änderungen wirksam werden:

    • Heben Sie die Bereitstellung der betroffenen Informationsspeicher auf, und stellen Sie sie erneut bereit.

    • Starten Sie den Microsoft Exchange-Informationsspeicherdienst neu.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Das Hintergrund-Cleanup-Intervall für einen Informationsspeicher für Öffentliche Ordner entspricht nicht der Standardeinstellung
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die aktuellen Datenwerte für den Registrierungswert Background Cleanup festzulegen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<PublicStoreGUID>\Background Cleanup

Wenn Exchange Server Analyzer feststellt, dass der Datenwert für Background Cleanup auf einen anderen Wert als 60.000 (dezimal) oder 0xEA60 (hexadezimal) festgelegt ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht. Es wird empfohlen, Background Cleanup auf den Standardwert festzulegen.

Wenn Background Cleanup auf einen zu hohen Wert festgelegt wird, wird der Hintergrund-Cleanup-Prozess u. U. nicht häufig genug ausgeführt, und es können u. a. folgende Probleme auftreten:

  • Die im Exchange-System-Manager angezeigte Größe von Ordnern und die Anzahl der angezeigten Elemente unterscheidet sich möglicherweise deutlich von den in Microsoft Outlook® angezeigten Werten. Außerdem kann der von diesen Elementen belegte Speicherplatz für Datenbanken möglicherweise nicht freigegeben werden.

  • Unter bestimmten Umständen kann für Elemente, die gelöscht wurden, ohne sie zuvor zu lesen, keine Benachrichtigung erzeugt werden.

  • Alte Einträge in der Tabelle DeliveredTo werden nicht gelöscht. Die Tabelle DeliveredTo wird vom Exchange-Informationsspeicher verwendet, um das Senden doppelter Nachrichten zu verhindern.

Wenn Background Cleanup auf einen zu niedrigen Wert festgelegt wird, verursacht der Hintergrund-Cleanup-Prozess u. U. eine unnötige Belastung des Servers.

Achtung:
Wenn Sie die unten beschriebene Vorgehensweise befolgen, um einen überhöhten Wert wieder auf die Standardkonfiguration zurückzusetzen, kann dies zu einer verstärkten Belastung des Server führen, solange der Hintergrund-Cleanup-Prozess noch nicht für alle Elemente abgeschlossen ist, die normalerweise während des Standardintervalls bereinigt worden wären. Es wird daher empfohlen, diese Änderungen zu einem Zeitpunkt vorzunehmen, zu dem die Beeinträchtigung der Benutzer möglichst gering gehalten werden kann. Nachdem Sie diese Warnung behoben haben, wird weiterhin für jede mit einer Lesebestätigungsanforderung versehene Nachricht, die gelöscht wurde, ohne sie zu lesen, und die aufgrund dieses Problems nicht bereinigt wurde, eine Benachrichtigung erzeugt.
Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<PublicStoreGUID>

  3. Ändern Sie den Wert von Background Cleanup auf 60.000 (dezimal) oder 0xEA60 (hexadezimal).

  4. Schließen Sie den Registrierungseditor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Das Hintergrund-Cleanup-Intervall für einen Informationsspeicher für Öffentliche Ordner fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-05

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob der Registrierungswert Background Cleanup vorhanden ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>\Background Cleanup

Wenn Exchange Server Analyzer feststellt, dass der Wert Background Cleanup fehlt, wird eine Warnung angezeigt.

Wenn der Wert Background Cleanup fehlt, wird der Hintergrund-Cleanup-Prozess u. U. nicht ausgeführt, und es können u. a. folgende Probleme auftreten:

  • Die im Exchange-System-Manager oder in der Exchange-Verwaltungskonsole angezeigte Größe von Ordnern und die Anzahl der angezeigten Elemente unterscheidet sich möglicherweise deutlich von den in Microsoft Outlook® angezeigten Werten. Außerdem kann der von diesen Elementen belegte Speicherplatz für Datenbanken möglicherweise nicht freigegeben werden.

  • Unter bestimmten Umständen kann für Elemente, die gelöscht wurden, ohne sie zuvor zu lesen, keine Benachrichtigung erzeugt werden.

  • Für die Tabelle DeliveredTo wird kein Cleanup ausgeführt. Die Tabelle DeliveredTo wird vom Exchange-Informationsspeicher verwendet, um das Senden doppelter Nachrichten zu verhindern. Mit dem Wert Track Duplicates wird der Zeitraum gesteuert, für den Einträge in der Tabelle DeliveredTo beibehalten werden. Wenn der Wert Background Cleanup vorhanden ist, der Wert Track Duplicates jedoch fehlt, werden Einträge, die älter als 24 Stunden sind, beim Hintergrund-Cleanup gelöscht. Der vorgeschlagene Wert für Track Duplicates ist 1 (dezimal oder hexadezimal).

Es wird empfohlen, Background Cleanup auf den Standardwert festzulegen, der 60.000 (dezimal) oder 0xEA60 (hexadezimal) beträgt.

Achtung:
Wenn das nachfolgend beschriebene Verfahren zum Entfernen dieser Warnung ausgeführt wird, kann dies zu einer erhöhten Serverlast führen, bis das Hintergrund-Cleanup für alle Elemente abgeschlossen ist, die üblicherweise regelmäßig gelöscht werden. Es wird daher empfohlen, diese Änderungen zu einem Zeitpunkt vorzunehmen, zu dem die Beeinträchtigung der Benutzer möglichst gering gehalten werden kann. Nachdem Sie diese Warnung behoben haben, wird weiterhin für jede mit einer Lesebestätigungsanforderung versehene Nachricht, die gelöscht wurde, ohne sie zu lesen, und die aufgrund dieses Problems nicht bereinigt wurde, eine Benachrichtigung erzeugt.
Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>

  3. Erstellen Sie den DWORD-Wert für Background Cleanup mit dem Wert 60000 (dezimal) oder 0xEA60 (hexadezimal).

  4. Schließen Sie den Registrierungs-Editor. Führen Sie einen der folgenden Schritte aus, damit die Änderungen wirksam werden:

    • Aufheben der Bereitstellung und erneute Bereitstellung der betroffenen Informationsspeicher

    • Neustarten des Microsoft Exchange-Informationsspeicherdiensts

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


„BreakOnEvent" wurde festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungswert, um zu ermitteln, ob für den Microsoft Exchange-Informationsspeicher das Debuggen aktiviert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\BreakOnEvent

Wenn Exchange Server Analyzer feststellt, dass für den Registrierungswert BreakOnEvent ein Wert festgelegt wurde, wird von dem Tool eine Warnung ausgegeben.

Der Registrierungswert BreakOnEvent enthält Dezimalwerte, die angeben, durch welche Speicherereignisse in den Debugmodus des Microsoft Exchange-Informationsspeichers gewechselt wird. Der Microsoft Exchange-Informationsspeicher verwendet im Debugmodus eine Vielzahl von Ressourcen. Es wird davon abgeraten, den Speicher in einer Produktionsumgebung zu debuggen.

Sofern Sie nicht gerade mithilfe des Technischen Supports von Microsoft aktiv ein Problem mit dem Exchange-Informationsspeicher beheben, sollten Sie den Registrierungswert BreakOnEvent löschen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So löschen Sie den Registrierungsschlüssel „BreakOnEvent"

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Suchen Sie im rechten Bereich den Wert BreakOnEvent, und löschen Sie ihn.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Die Aufrufverfolgung wurde deaktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungswert, um zu bestimmen, ob die Aufrufverfolgungsprotokollierung aktiviert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable Call Tracing

Wenn Exchange Server Analyzer feststellt, dass der Registrierungswert für Disable Call Tracing vorhanden ist, mit einem Wert von 1 konfiguriert ist und auf dem Computer ExchangeServer 2003 ausgeführt wird, wird von Microsoft Exchange Server Analyzer eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Wenn die Aufrufverfolgungsprotokollierung aktiviert ist, werden die Funktionsaufrufdaten für Prozesse von Store.exe aufgezeichnet. In der Standardeinstellung ist die Aufrufverfolgung für Computer aktiviert, auf denen Exchange Server 2003 ausgeführt wird. Beachten Sie, dass diese Funktion in der Standardeinstellung für Exchange 2000 Server deaktiviert ist. Wenn Sie jedoch Exchange Server 2003 ausführen, sollten Sie die Aufrufverfolgung aktivieren, sofern Sie keine andere Anweisung vom technischen Support von Microsoft erhalten. Wenn die Aufrufverfolgung aktiviert ist, werden wichtige Informationen erfasst, die Sie zur Behandlung aller beim Speichervorgang auftretenden Probleme verwenden können.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Legen Sie den Registrierungswert Disable Call Tracing auf 0 fest.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Die Aufrufverfolgung ist aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungswert, um zu bestimmen, ob die Aufrufverfolgungsprotokollierung aktiviert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable Call Tracing

Wenn MicrosoftMicrosoft Exchange Server Analyzer feststellt, dass der Registrierungswert für Disable Call Tracing vorhanden und mit einem Wert von 0 konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Wenn die Aufrufverfolgungsprotokollierung aktiviert ist, werden die Funktionsaufrufdaten für Prozesse von Store.exe aufgezeichnet. Durch die Protokollierung der Aufrufverfolgung wird eine Leistungsminderung von bis zu 4 Prozent verursacht. Sie sollten diese Funktion nur für die Fehlerdiagnose bei langsamen oder nicht reagierenden Prozessen von Store.exe aktivieren.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Legen Sie den Registrierungswert Disable Call Tracing auf 1 fest. Die Schlüssel Flush Call Traces , RPC Requests Threshold und Call Tracing Logging Interval werden nicht verwendet, wenn die Aufrufverfolgung deaktiviert ist.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den Exchange-Server neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Für diesen Cluster ist die Prüfpunkttiefe nicht richtig festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchESEParamCheckpointDepthMax für jede Speichergruppe zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass der Wert für msExchESEParamCheckpointDepthMax auf einem Exchange 2000-Cluster ungleich 5242880 ist, wird eine Warnung angezeigt.

Die msExchESEParamCheckpointDepthMax wird in Byte festgelegt und bestimmt die maximale Prüfpunkttiefe. Bei der Prüfpunkttiefe handelt es sich um die Menge der Daten, die auf die Übergabe an den Exchange-Speicher warten. Die maximale Prüfpunkttiefe stellt die maximale Menge der Daten dar, die jeweils ausstehen dürfen. Wenn also die maximale Prüfpunkttiefe auf 20 MB festgelegt ist, darf die Menge der jeweils austehenden Daten (nicht an den Exchange-Speicher übergebene Daten) diesen Wert nicht übersteigen. In einer Cluster-Umgebung führt ein geringerer Wert für diesen Parameter zu kürzeren Failoverzeiten. Tests mit Exchange Server 2003 haben ergeben, dass mit dem Wert 5 MB (5242880 Bytes) für diesen Parameter (anstelle von 20 MB, dem Standardwert für Exchange 2000 Server) sehr viel kürzere Failoverzeiten erreicht wurden, ohne dass dabei die E/A-Leistung des Servers ernsthaft beeinträchtigt wird.

In Exchange 2000 Server-Clustern wird empfohlen, diesen Wert immer auf 5242880 festzulegen.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute von Objekten des Active Directory®-Verzeichnisdiensts nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So legen Sie das Attribut „msExchESEParamCheckpointDepthMax" mithilfe der ADSI-Bearbeitung fest

  1. Führen Sie die ADSI-Bearbeitung (ADSI, Active Directory Service Interfaces) aus. Die ADSI-Bearbeitung wird mit den Supporttools von Microsoft Windows® 2000 Server und Microsoft™ Windows Server™ 2003 Server bereitgestellt.

  2. Klicken Sie in der Konsolenstruktur auf ADSIEdit, klicken Sie auf Verbinden mit, und stellen Sie dann eine Verbindung mit Configuration Naming Context her.

  3. Erweitern Sie den Konfigurationscontainer, CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<Name der Organisation>, CN=Administrative Groups, CN=<Name der administrativen Gruppe>, CN=Servers, CN=<Name des Servers>, CN=Information Store.

  4. Klicken Sie mit der rechten Maustaste auf CN=<Name der Speichergruppe>, und klicken Sie dann auf Eigenschaften.

  5. Wählen Sie in der Liste der Eigenschaften den Eintrag msExchESEParamCheckpointDepthMax aus.

  6. Klicken Sie auf Bearbeiten, und geben Sie die gewünschte Größe ein. Die Erhöhung des Wertes erfolgt dabei in Schritten von jeweils 5 MB. Der Wert muss in Byte eingegeben werden. Eine Prüfpunkttiefe von 5 MB entspricht beispielsweise 5242880 Bytes, und eine Prüfpunkttiefe von 10 MB entspricht 10485760 Bytes. Der einzugebende Mindestwert beträgt 5 MB. Wenn Sie einen Wert über 20 MB eingeben, erhöht sich die Failoverzeit für die Microsoft Exchange-Informationsspeicherdienstressource.

  7. Schließen Sie ADSIEdit, und starten Sie den Microsoft Exchange-Informationspeicherdienst neu.

Weitere Informationen zum Bereitstellen von Exchange 2000 Server-Clustern finden Sie in „Deploying Microsoft Exchange 2000 Server Clusters" unter http://go.microsoft.com/fwlink/?LinkID=14578.


Platzierung der Prüfpunktdatei
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-05

Microsoft® Exchange Server Analyzer Tool fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob der Pfad für die Prüfpunktdatei (msExchESEParamSystemPath) für die einzelnen Speichergruppen auf einem Exchange-Server mit dem Pfad für das Transaktionsprotokoll (msExchESEParamLogFilePath) für die entsprechende Speichergruppe übereinstimmt. Wenn Exchange Server Analyzer ermittelt, dass der Pfad für die Prüfpunktdatei nicht mit dem Pfad für das Transaktionsprotokoll für die Speichergruppe übereinstimmt, zeigt Exchange Server Analyzer eine Meldung mit optimalen Methoden an.

Wenn der Speicherort der Prüfpunktdatei nicht mit dem Speicherort der Transaktionsprotokolldateien übereinstimmt, kann es bei Festplattenfehlern zu längeren Ausfällen kommen.

So ändern Sie in Exchange 2000 Server und Exchange Server 2003 den Speicherort der Prüfpunkdatei einer Exchange-Speichergruppe

  1. Klicken Sie in Exchange System-Manager mit der rechten Maustaste auf die Speichergruppe, und klicken Sie dann auf Eigenschaften.

  2. Klicken Sie auf der Registerkarte Allgemein unter Systempfad auf Durchsuchen, und wählen Sie dann einen Speicherort für die Prüfpunktdatei aus.
So ändern Sie in Exchange 2000 Server und Exchange Server 2003 den Speicherort der Transaktionsprotokolldateien einer Exchange-Speichergruppe

  1. Klicken Sie in Exchange System-Manager mit der rechten Maustaste auf die Speichergruppe, und klicken Sie dann auf Eigenschaften.

  2. Klicken Sie auf der Registerkarte Allgemein unter Pfad des Transaktionsprotokolls auf Durchsuchen, und wählen Sie dann einen Speicherort für die Transaktionsprotokolldateien aus.
So ändern Sie in Exchange Server 2007 den Speicherort von Transaktionsprotokolldateien in einer Exchange-Speichergruppe

  1. Befolgen Sie die Anweisungen in der Exchange Server 2007-Hauptdokumentation unter "How to Set or Change the Location of Storage Group Log Files" (http://go.microsoft.com/fwlink/?LinkId=80702).

Weitere Informationen zum Speicherort der Transaktionsprotokolldateien finden Sie im Abschnitt „Verwalten von Postfachspeichern und Informationsspeichern für Öffentliche Ordner" im Exchange Server 2003-Administratorhandbuch unter http://go.microsoft.com/fwlink/?LinkId=47617.

Weitere Informationen zur Prüfpunktdatei finden Sie im Abschnitt „Transaction Log File Replay: Soft Recovery and Hard Recovery in Exchange Server 2003" in Using Exchange Server 2003 Recovery Storage Groups (http://go.microsoft.com/fwlink/?LinkId=47589).


Auf diesem Front-End-Server ist die Umlaufprotokollierung deaktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2006-03-27

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den für das Umlaufprotokollierungsattribut (msExchESEParamCircularLog) konfigurierten Wert zu ermitteln. Wenn Microsoft Exchange Server Analyzer Tool feststellt, dass dieses Attribut mit dem Wert 0 konfiguriert ist, wird eine Warnung angezeigt.

Der Wert 1 für das Attribut msExchESEParamCircularLog gibt an, dass die Umlaufprotokollierung aktiviert ist. Der Wert 0 für das Attribut msExchESEParamCircularLog gibt an, dass die Umlaufprotokollierung deaktiviert ist.

Bei der von Exchange Server verwendeten Standardtransaktionsprotokollierung werden alle Datenbanktransaktionen innerhalb einer Speichergruppe in eine Protokolldatei und dann in die Datenbank geschrieben. Wenn die Protokolldatei eine bestimmte Größe erreicht, wird sie umbenannt, und eine neue Protokolldatei wird erstellt. Mit der Zeit ergibt dies eine Sammlung von Protokolldateien. Nach einem Absturz können Sie die Transaktionen wiederherstellen, indem Sie die Daten aus den Protokolldateien erneut in die Datenbank einspielen.

Bei der Umlaufprotokollierung wird die erste Protokolldatei, nachdem die in ihr enthaltenen Daten in die Datenbank geschrieben wurden, überschrieben und wiederverwendet. In der Standardeinstellung ist die Umlaufprotokollierung in Exchange Server deaktiviert. Durch die Aktivierung verringern sich zwar die Festplatten-Speicherplatzanforderungen, aber ohne den vollständigen Satz Transaktionsprotokolldateien kann nur der Stand der letzten vollständigen Sicherung wiederhergestellt werden. Daher sollte auf Produktionsservern mit Postfächern oder Daten aus Öffentlichen Ordnern die Umlaufprotokollierung nicht verwendet werden. Bei Front-End-Exchange-Servern, die über keine Postfächer oder Öffentliche Ordner verfügen, werden als einzige Nachrichten NDRs (Non-Delivery Reports, Unzustellbarkeitsberichte) übermittelt. Auf diesen Servern besteht weder die Notwendigkeit, Transaktionsdateien aufzubewahren, noch, Sicherungen dieser Server anzulegen. Das Aktivieren der Umlaufprotokollierung auf Front-End-Servern ermöglicht das Überschreiben der Transaktionsprotokolldateien, sodass sie niemals mehr als 20 MB Daten enthalten.

So aktivieren Sie die Umlaufprotokollierung

  1. Erweitern Sie im Exchange-System-Manager den Eintrag Server, und erweitern Sie anschließend einen Exchange-Server.

  2. Klicken Sie mit der rechten Maustaste auf die Speichergruppe, für die Sie die Umlaufprotokollierung aktivieren möchten, und wählen Sie Eigenschaften aus. Das Eigenschaftendialogfeld für die Speichergruppe wird angezeigt.

  3. Aktivieren Sie das Kontrollkästchen Umlaufprotokollierung aktivieren, und klicken Sie anschließend auf OK, um die Änderung zu speichern.

  4. Schließen Sie den Exchange-System-Manager, und starten Sie den Microsoft Exchange-Informationsspeicher neu, damit die Änderung wirksam wird.

Weitere Informationen zur Umlaufprotokollierung finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 258470, „XADM: How to Modify the Circular Logging Setting" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=258470.

  • 147524, „XADM: How Circular Logging Affects the Use of Transaction Logs" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524.

  • 296788, „Offline Backup and Restoration Procedures for Exchange" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788.

  • 314605, „SO WIRD´S GEMACHT: Turn On or Turn Off Circular Logging in Exchange 2000 Server" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314605.


Die Umlaufprotokollierung ist aktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-05

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs msExchESEParamCircularLog für jede Speichergruppe auf dem Exchange-Server zu bestimmen. Der Wert 1 gibt an, dass die Umlaufprotokollierung für die Speichergruppe aktiviert ist. Der Wert 2 gibt an, dass die Umlaufprotokollierung für die Speichergruppe deaktiviert ist. Außerdem fragt Exchange Server Analyzer Active Directory ab, um die Anzahl der Einträge zu ermitteln, die im Attribut homeMDBBL der einzelnen Postfachspeicher aufgelistet sind. Der Zählwert dieses Attributs stellt die Zahl der Postfächer im Postfachspeicher dar.

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Windows Management Instrumentation) Exchange_Server im Namespace root\MicrosoftExchangeV2 ab, um den Wert für den Schlüssel IsFrontEndServer zu bestimmen. Der Wert True zeigt an, dass der Exchange Server-Computer ein Front-End-Server ist. Der Wert False gibt an, dass der Exchange Server-Computer kein Front-End-Server ist.

Wenn Exchange Server Analyzer feststellt, dass der Wert für das Attribut msExchESEParamCircularLog auf 1 festgelegt ist, der Wert für den Schlüssel IsFrontEndServer auf False festgelegt und der Wert des Attributs homeMDBBL größer als 20 ist, wird eine Warnung angezeigt.

Diese Kombination von Werten gibt an, dass die Umlaufprotokollierung auf einem Postfachserver mit mehr als 20 Postfächern aktiviert ist. Bei der von Exchange 2000 Server, Exchange Server 2003 und Exchange Server 2007 verwendeten Standardtransaktionsprotokollierung werden alle Datenbanktransaktionen innerhalb einer Speichergruppe in eine Protokolldatei und dann in die Datenbank geschrieben. Wenn die Protokolldatei eine bestimmte Größe erreicht, wird sie umbenannt und eine neue Protokolldatei erstellt. Mit der Zeit ergibt dies eine Sammlung von Protokolldateien. Nach einem Absturz können Sie die Transaktionen wiederherstellen, indem Sie die Daten aus den Protokolldateien erneut in die Datenbank einspielen.

Bei der Umlaufprotokollierung wird die erste Protokolldatei, nachdem die in ihr enthaltenen Daten in die Datenbank geschrieben wurden, überschrieben und wiederverwendet. In Exchange 2000 Server, Exchange Server 2003 und Exchange Server 2007 ist die Umlaufprotokollierung in der Standardeinstellung deaktiviert. Durch die Aktivierung verringeren sich zwar die Festplattenspeicherplatzanforderungen, aber ohne den vollständigen Satz Transaktionsprotokolldateien kann nur die letzte vollständige Sicherung wiederhergestellt werden. Daher wird die Umlaufprotokollierung für eine normale Produktionsumgebung nicht empfohlen.

So vermeiden Sie diese Warnung in Exchange 2000 Server und Exchange Server 2003

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Server, und erweitern Sie dann den zu ändernden Server.

  3. Klicken Sie mit der rechten Maustaste auf die zu ändernde Speichergruppe, und klicken Sie dann auf Eigenschaften.

  4. Deaktivieren Sie im Dialogfeld Eigenschaften das Kontrollkästchen Umlaufprotokollierung aktivieren.

  5. Klicken Sie zum Speichern der Einstellung auf OK.

  6. Schließen Sie den Exchange-System-Manager, und starten Sie dann den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

So vermeiden Sie diese Warnung für Exchange Server 2007 mithilfe der Exchange-Verwaltungskonsole

  1. Öffnen Sie die Exchange-Verwaltungskonsole.

  2. Erweitern Sie Serverkonfiguration und dann den zu ändernden Server.

  3. Klicken Sie mit der rechten Maustaste auf die zu ändernde Speichergruppe, und klicken Sie dann auf Eigenschaften.

  4. Deaktivieren Sie im Dialogfeld Eigenschaften das Kontrollkästchen Umlaufprotokollierung aktivieren.

  5. Klicken Sie zum Speichern der Einstellung auf OK.

  6. Schließen Sie die Exchange-Verwaltungskonsole, und starten Sie dann den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

So vermeiden Sie diese Warnung in Exchange Server 2007 mithilfe der Exchange-Verwaltungsshell

  1. Der folgende Code ist ein Beispiel des Befehls Set-StorageGroup zum Deaktivieren der Umlaufprotokollierung für die Speichergruppe 'MyStorageGroup'.
Code kopieren
Set-StorageGroup -Identity MyStorageGroup -CircularLoggingEnabled $false
  • Weitere Informationen zur Umlaufprotokollierung finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 147524, "How Circular Logging affects the Use of Transaction Logs" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524)

  • 240145, „How to Tell Which Transaction Log Files Can Be Safely Removed" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=240145)


Umlaufprotokollierung ist deaktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-03-23

Das Tool Microsoft Exchange Analyzer fragt den Active Directory-Verzeichnisdienst ab, um den für das Attribut msExchESEParamCircularLog konfigurierten Wert zu bestimmen.

Der Wert 1 für das Attribut msExchESEParamCircularLog gibt an, dass die Umlaufprotokollierung aktiviert ist. Der Wert 0 für das Attribut msExchESEParamCircularLog gibt an, dass die Umlaufprotokollierung deaktiviert ist.

Exchange Analyzer ermittelt weiterhin, ob die folgenden Bedingungen gegeben sind:

  • Exchange Server ist als Front-End-Server konfiguriert.

  • Der SMTP-Dienst wird ausgeführt und ermittelt die konfigurierte Anzahl von Postfächern.

Wenn Exchange Analyzer ermittelt, dass die folgenden Bedingungen gegeben sind, zeigt das Tool eine Warnung an:

  • Das Attribut msExchESEParamCircularLog ist mit dem Wert 0 konfiguriert.

  • Der Server ist nicht als Front-End-Server konfiguriert.

  • Es sind weniger als 20 Postfächer konfiguriert.

Bei der von Exchange Server verwendeten Standardtransaktionsprotokollierung werden alle Datenbanktransaktionen innerhalb einer Speichergruppe in eine Protokolldatei und dann in die Datenbank geschrieben. Wenn die Protokolldatei eine bestimmte Größe erreicht, wird sie umbenannt, und eine neue Protokolldatei wird erstellt. Im Lauf der Zeit entstehen durch die Standardtransaktionsprotokollierung eine Reihe von Protokolldateien. Nach einem Systemabsturz können Sie die Transaktionen wiederherstellen, indem Sie die Daten aus den Protokolldateien erneut in die Datenbank einspielen.

Bei der Umlaufprotokollierung wird die erste Protokolldatei, nachdem die in ihr enthaltenen Daten in die Datenbank geschrieben wurden, überschrieben und wiederverwendet. In der Standardeinstellung ist die Umlaufprotokollierung in Exchange Server deaktiviert.

Wichtig:
Durch das Aktivieren der Umlaufprotokollierung verringern sich die Anforderungen an den Festplattenspeicherplatz. Wenn Sie jedoch nicht über vollständige Transaktionsprotokolldateien verfügen, können Sie jeweils nur die letzte vollständige Sicherung wiederherstellen. Daher sollte auf Produktionsservern mit Daten aus Postfächern oder aus Öffentlichen Ordnern die Umlaufprotokollierung nicht verwendet werden.

Auf Front-End-Servern mit Exchange, Nachrichtenroutingservern (auch als Infrastrukturserver bezeichnet) und Bridgeheadservern, die keine Benutzerpostfächer oder Öffentlichen Ordner aufweisen, werden nur Unzustellbarkeitsberichte übermittelt. Aus diesem Grund besteht keine Notwendigkeit, die Transaktionsdateien für diese Server zu speichern. Es ist auch nicht erforderlich, eine Sicherungskopie dieser Server zu erstellen. Wenn Sie die Umlaufprotokollierung auf Servern aktivieren, auf denen keine Benutzerpostfächer gehostet werden, können Sie die Transaktionsprotokolldateien überschreiben und so deren Größe auf höchstens 20 MB begrenzen.

So aktivieren die Umlaufprotokollierung für Exchange 2000 Server und Exchange Server 2003

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Server, und erweitern Sie anschließend einen Exchange-Server.

  3. Klicken Sie mit der rechten Maustaste auf die Speichergruppe, für die Sie die Umlaufprotokollierung aktivieren möchten, und wählen Sie Eigenschaften aus. Das Eigenschaftendialogfeld für die Speichergruppe wird angezeigt.

  4. Aktivieren Sie das Kontrollkästchen Umlaufprotokollierung aktivieren, und klicken Sie anschließend auf OK, um die Änderung zu speichern.

  5. Schließen Sie den Exchange-System-Manager, und starten Sie dann den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.
So aktivieren die Umlaufprotokollierung für Exchange Server 2007 mithilfe der Exchange-Verwaltungskonsole

  1. Öffnen Sie die Exchange-Verwaltungskonsole.

  2. Erweitern Sie Serverkonfiguration und dann den zu ändernden Server.

  3. Klicken Sie mit der rechten Maustaste auf die zu ändernde Speichergruppe, und klicken Sie dann auf Eigenschaften.

  4. Aktivieren Sie im Dialogfeld Eigenschaften das Kontrollkästchen Umlaufprotokollierung aktivieren.

  5. Klicken Sie zum Speichern der Einstellung auf OK.

  6. Schließen Sie die Exchange-Verwaltungskonsole, und starten Sie dann den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.
So aktivieren die Umlaufprotokollierung für Exchange Server 2007 mithilfe der Exchange-Verwaltungsshell

  1. Der folgende Code ist ein Beispiel des Befehls Set-StorageGroup zum Aktivieren der Umlaufprotokollierung für die Speichergruppe "MyStorageGroup".
Code kopieren
Set-StorageGroup -Identity MyStorageGroup -CircularLoggingEnabled $true

Weitere Informationen zur Umlaufprotokollierung finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 258470, „XADM: How to Modify the Circular Logging Setting" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=258470.

  • 147524, „XADM: How Circular Logging Affects the Use of Transaction Logs" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524.

  • 296788, „Offline Backup and Restoration Procedures for Exchange" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788.

  • 314605, "Aktivieren bzw. Deaktivieren der Umlaufprotokollierung in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314605)


Client/Server-RPC-Komprimierung ist deaktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-05

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die Remote Procedure Call-Komprimierung (RPC -Remoteprozeduraufruf) aktiviert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Rpc Compression Enabled

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert für Rpc Compression Minimum Size vorhanden und mit einem Wert von 0 konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In der Standardeinstellung werden alle RPC-Daten, die zwischen Microsoft Office Outlook® 2003 oder Outlook 2007 und Exchange Server 2003 oder Exchange Server 2007 übertragen werden, unabhängig von ihrer Größe komprimiert. In einigen Szenarien können Sie die RPC-Komprimierung steuern. Wenn Sie z. B. Verbindungsprobleme beheben möchten, indem Sie die über das Netzwerk gesendeten Pakete anzeigen, kann die Analyse durch die RPC-Komprimierung erschwert werden, da Sie nur die komprimierten Daten verfolgen können.

Um die Einstellungen für die RPC-Komprimierung zu konfigurieren, können Sie den Systemeinstellungen drei Registrierungsschlüsselwerte hinzufügen:

  • Rpc Compression Minimum Size

  • Rpc Compression Enabled

  • Rpc Packing Enabled

Der Registrierungswert Rpc Compression Enabled bestimmt, ob die RPC-Komprimierungsalgorithmen verwendet werden. Wenn dieser Schlüssel nicht vorhanden ist, ist die RPC-Komprimierung aktiviert und wird verwendet.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Löschen Sie den Schlüssel Rpc Compression Enabled. Wenn die Schlüssel Rpc Compression Minimum Size und Rpc Packing Enabled vorhanden sind, löschen Sie auch diese.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den Exchange-Server neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Steuern der RPC-Komprimierung finden Sie im Knowledge Base-Artikel 825371, „Modify Remote Procedure Call Compression in Exchange Server 200" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371.


Der Parameter „ClientMonitoringReportLevel" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungsschlüssel, um zu ermitteln, wie Exchange Server 2003 die Daten zur Netzwerkleistung für Microsoft Office Outlook® 2003 überwacht:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Wenn Exchange Server Analyzer erkennt, dass der Wert des Registrierungsschlüssels ClientMonitoringReportLevel nicht auf 1 festgelegt ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Mithilfe des für den Registrierungsschlüssel ClientMonitoringReportLevel festgelegten Werts erfasst Exchange Server Netzwerkfehler und Probleme bei der Wartezeit bei Outlook 2003-Clients. Es gibt drei mögliche Einstellungen für den Wert des Registrierungsschlüssels ClientMonitoringReportLevel.

Wert | Funktion
0 | Es werden keine Leistungsdaten von Outlook 2003-Clients erfasst.
1 | Es werden nur Leistungsdaten von Outlook 2003-Clients erfasst, die über eine Hochgeschwindigkeitsnetzwerkverbindung verfügen.
2 | Es werden Leistungsdaten von allen Outlook 2003-Clients erfasst.

Wenn der Registrierungsschlüssel ClientMonitoringReportLevel mit dem Wert 1 oder 2 aktiviert wird, werden Daten von den Outlook 2003-Clients an den Server gesendet. Die an den Server gesendeten Daten geben den Status und den Zustand der Netzwerkverbindung an. Diese Daten enthalten Informationen zu Fehlern bei RPC-Anforderungen (RPC, Remoteprozeduraufruf) und Fehlerbedingungen. Die Informationen werden auf dem Server gesammelt und in Ereignisprotokolleinträgen erfasst.

Der Registrierungsschlüssel ClientMonitoringReportLevel wird von Exchange-Setup nicht erstellt. Als Standardverhalten in Exchange Server 2003 ist das Erfassen von Leistungsdaten nur von Outlook 2003-Clients mit Hochgeschwindigkeitsnetzwerkverbindung festgelegt. Dieses Standardverhalten von Exchange Server 2003 entspricht dem für den Registrierungsschlüssel ClientMonitoringReportLevel festgelegten Wert 1.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich. Sie können den Wert des Registrierungsschlüssels ClientMonitoringReportLevel jedoch bearbeiten, um den Standardwert wiederherzustellen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Doppelklicken Sie auf ClientMonitoringReportLevel.

  4. Geben Sie im Feld Wert den Wert 1 ein, und klicken Sie dann auf OK.

  5. Schließen Sie den Registrierungs-Editor.

Der Microsoft Exchange-Informationsspeicherdienst erkennt innerhalb weniger Minuten die Änderungen. Sie müssen den Computer nicht neu starten.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Empfohlene Vorgehensweise: Implementieren von Speicherkontingenten
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-03-21

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob für die einzelnen privaten Nachrichten-Datenbankobjekte (MDB) Postfachquoten festgelegt wurden. Wenn Microsoft Exchange Server Analyzer feststellt, dass eine bestimmte private MDB mehr als 20 Postfächer enthält und für die MDB keine Quoten festgelegt wurden, zeigt Microsoft Exchange Server Analyzer eine Meldung mit der optimalen Konfigurationsmethode an.

Eine optimale Methode besteht darin, Quoten für alle Datenbanken auf Exchange Server-Computern zu verwenden, die Benutzerpostfächer hosten. Sie sollten auf Datenbankebene drei Grenzwerte festlegen. Die Grenzwerte werden auf der Seite Eigenschaften des Postfachspeichers auf der Registerkarte Grenzwerte festgelegt. Die Grenzwerte werden in KB angegeben.

  • Warnung Der Grenzwert Issue warning definiert die Größe des Postfachs, bei der eine Warnung per E-Mail an den Benutzer gesendet wird. In der E-Mail-Nachricht mit der Warnung wird dem Benutzer mitgeteilt, dass die Größe des Postfachs den Grenzwert Prohibit send fast erreicht hat.

  • Senden verbieten Der Grenzwert Prohibit send definiert die Postfachgröße, ab der ein Benutzer keine E-Mails mehr senden darf. Der Benutzer erhält eine E-Mail-Nachricht vom Exchange-Server, in der erläutert wird, dass der Grenzwert für die Größe des Postfachs überschritten wurde.

  • Senden/Empfangen verbieten Der Grenzwert Prohibit send and receive definiert die Postfachgröße, ab der ein Benutzer keine E-Mail-Nachrichten mehr senden und empfangen darf. Alle an den Benutzer gesendeten E-Mail-Nachrichten werden mit einem NDR (Non-Delivery Report, Unzustellbarkeitsbericht) an den Absender zurückgesendet.

Stellen Sie beim Festlegen dieser Regeln sicher, dass ein ausreichend großer Abstand zwischen dem Grenzwert Senden verbieten und dem Grenzwert Senden/Empfangen verbieten vorhanden ist. Wenn der Unterschied zwischen den beiden Grenzwerten zu klein ist, weist das Postfach möglicherweise Nachrichten zurück, bevor der Benutzer die Möglichkeit hat, das Postfach zu leeren. Die optimale Methode bestehtl deshalb darin, einen Puffer von mindestens 20 Prozent zwischen dem Grenzwert Senden verbieten und dem Grenzwert Senden/Empfangen verbieten vorzusehen. Wenn Benutzer beispielsweise keine Nachrichten mehr senden dürfen, sobald ihr Postfach 100 MB erreicht, sollte der Grenzwert Senden/Empfangen verbieten mindestens 120 MB betragen.

So legen Sie Postfachbegrenzungen für Exchange 2000 Server und Exchange Server 2003 fest

  1. Öffnen Sie den Exchange-System-Manager.

  2. Suchen Sie den Postfachspeicher, der in der entsprechenden Nachricht von Microsoft Exchange Server Analyzer angegeben ist.

  3. Klicken Sie mit der rechten Maustaste auf Postfachspeichername, und wählen Sie Eigenschaften aus.

  4. Wählen Sie die Registerkarte Grenzwerte aus.

  5. Ändern Sie die Grenzwerte Warnmeldung senden ab (KB), Senden verbieten ab (KB) und Senden/Empfangen verbieten ab (KB).

  6. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.
So legen Sie in Exchange Server 2007 mithilfe der Exchange-Verwaltungskonsole Postfachbegrenzungen fest

  1. Öffnen Sie die Exchange-Verwaltungskonsole.

  2. Suchen Sie den Postfachspeicher, der in Exchange Server Analyzer zu diesem Problem angegeben ist.

  3. Klicken Sie mit der rechten Maustaste auf Postfachspeichername, und wählen Sie Eigenschaften aus.

  4. Wählen Sie die Registerkarte Grenzwerte aus.

  5. Ändern Sie die Grenzwerte Warnmeldung senden ab (KB), Senden verbieten ab (KB) und Senden/Empfangen verbieten ab (KB).

  6. Klicken Sie auf Übernehmen und dann auf OK.
So legen Sie in Exchange Server 2007 mithilfe der Exchange-Verwaltungsshell Postfachbegrenzungen fest

  1. Das folgende Beispiel zeigt, wie die Größe des Postfachs festgelegt wird, ab der eine Warnmeldung an den Benutzer gesendet wird. Dieses Attribut gilt für alle Postfächer in dieser Postfachdatenbank, für die kein eigenes Attribut zur Überschreitungswarnung festgelegt ist. Sie müssen entweder eine ganze Zahl oder "Unbegrenzt" angeben. Der Standardwert ist 1,9 GB.

    Code kopieren
    Set-MailboxDatabase "Mailbox Database Name" -IssueWarningQuota 1991680

  2. Das folgende Beispiel zeigt, wie die Größe des Postfachs festgelegt wird, ab der Benutzer, die Postfächern in dieser Postfachdatenbank zugeordnet sind, keine Nachrichten mehr senden können. Dieses Attribut gilt für alle Postfächer in dieser Postfachdatenbank, für die keine eigenen Attribute für das Kontingent für "Senden verbieten" festgelegt sind. Der Grenzwert muss entweder als ganze Zahl oder "Unbegrenzt" festgelegt werden.

    Code kopieren
    Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendQuota 2097152

  3. Das folgende Beispiel zeigt, wie die Größe des Postfachs angegeben wird, ab der der diesem Postfach zugeordnete Benutzer keine Nachrichten mehr senden oder empfangen kann. Dieses Attribut gilt für alle Postfächer in dieser Postfachdatenbank, für die keine eigenen Attribute für das Kontingent für "Empfangen verbieten" festgelegt sind. Sie müssen entweder eine ganze Zahl oder "Unbegrenzt" angeben.

    Code kopieren
    Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendReceiveQuota 2411520

Weitere Informationen zur Verwaltung von Exchange-Postfächern finden Sie unter Working with Exchange Server 2003 Stores (http://go.microsoft.com/fwlink/?LinkId=47595).

Weitere Informationen zum Verwalten von Exchange-Postfachbegrenzungen in Exchange Server 2007 finden Sie unter "How to Configure Database Limits and Properties" (http://go.microsoft.com/fwlink/?LinkId=80746).


Für diesen Postfachspeicher wurde eine Inhaltsindizierung aktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um festzustellen, ob das Attribut für den Wiederherstellungszeitplan für den Inhaltsindex (msExchCIRebuildSchedule) auf einen Wert ungleich NULL festgelegt und das Attribut für das Wiederherstellungsformat für den Inhaltsindex (msExchCIRebuildStyle) ebenfalls festgelegt wurde. Diese Attribute sind Bestandteil jeder privaten Postfachdatenbank. Wenn Microsoft Exchange Server Analyzer feststellt, dass diese Attribute für Indizierung konfiguriert sind, wird eine Warnung ausgegeben.

Es wird nicht empfohlen, die auch als „Volltextindizierung" bezeichnete Inhaltsindizierung in einem Postfachspeicher auszuführen, da diese Art der Indizierung viele Ressourcen bindet und dort eine hohe Datenfluktuation vorherrscht. Bei der Verwaltung eines aktuellen Indexes für eine bestimmte Datenbank handelt es sich daher um einen ressourcenintensiven Vorgang. Eine Volltextindizierung empfiehlt sich eher für Öffentliche Ordner.

Sehen Sie vor dem Ausführen einer Volltextindizierung in einem Postfachspeicher im Zeitplan für die Indizierung eine häufige Aktualisierung vor, und überwachen Sie die Leistung des Computers, um sicherzustellen, dass der Computer während der Indizierung des Inhalts nicht überlastet ist und weiterhin Nachrichten zustellen und auf Clientanforderungen reagieren kann.

Andernfalls wird empfohlen, die Volltextindizierung durch Löschen der Volltextindizierung im Postfachspeicher zu deaktivieren.

So deaktivieren Sie die Volltextindizierung in einem bestimmten Postfachspeicher

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Administrative Gruppen, erweitern Sie die administrative Gruppe und erweitern Sie dann Server. Erweitern Sie anschließend Ihren Server, erweitern Sie die Speichergruppe, klicken Sie mit der rechten Maustaste auf Postfachspeicher, und klicken Sie dann auf Volltextindex löschen.

Weitere Informationen zum Konfigurieren und für die Fehlerbehebung für die Volltextindizierung in Exchange finden Sie im Microsoft Knowledge Base-Artikel „HOW TO: Configure Full-Text Indexing on Mailbox Stores in Exchange 2003" unter http://go.microsoft.com/fwlink/?LinkID=3052&kbid=822932


In diesem Speicher für Öffentliche Ordner wurde eine Inhaltsindizierung aktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob das Attribut Content Indexing Rebuild Schedule (msExchCIRebuildSchedule) und das Attribut Content Indexing Rebuild Style (msExchCIRebuildStyle) vorhanden und auf einen anderen Wert als 0 festgelegt sind. Diese Attribute sind Bestandteil jeder öffentlichen Informationsspeicherdatenbank.

Wenn Exchange Server Analyzer feststellt, dass diese beiden Attribute vorhanden sind und auf einen Wert ungleich 0 festgelegt sind, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Wenn beide Attribute auf 1 festgelegt sind, wird angegeben, dass die Volltextindizierung für die Informationsspeicherdatenbank aktiviert wurde. Die Volltextindizierung ermöglicht leistungsfähige und schnelle Suchvorgänge, da alle Wörter einer gewünschten Datenbank indiziert werden. Wenn Sie die Volltextindizierung bereitstellen, wählen Sie einen einzelnen Öffentlichen Ordner oder einen Postfachspeicher, der indiziert werden soll. Die Benutzer können anschließend Volltextsuchen in den Nachrichten und Anlagen des Öffentlichen Ordners oder des Postfachspeichers ausführen.

In der Standardeinstellung enthält der Index den Betreff und Nachrichtentext einer Nachricht, die Namen von Absender und Empfänger und die Namen, die in den Feldern Cc und Bcc stehen. Der Index enthält auch Text aus den folgenden Anlagetypen: DOC-, XLS-, PPT-, HTML-, HTM-, ASP-, TXT- und EML-Dateien (Embedded Multipurpose Internet Mail Extensions (MIME) Messages). Binäre Anlagen (z. B. Bilder oder Sounds), werden nicht indiziert.

Suchergebnisse beziehen sich immer nur auf den Zeitpunkt, an dem der Index zuletzt aktualisiert wurde. Wenn sich der Inhalt der Öffentlichen Ordner oder Postfachspeicher ändert, muss der Index aktualisiert werden, um den neuen Inhalt wiederzugeben. Indexaktualisierungen können manuell oder automatisch in einem Zeitplan ausgeführt werden.

Es gibt vier Hauptkategorien für Volltextindizierungsdateien. Sie können die Leistung der Volltextindizierung optimieren, indem Sie den Speicherort dieser Dateien folgendermaßen anordnen:

  • Kataloge Kataloge sind die Hauptindizes. Für jeden Exchange-Informationsspeicher kann ein Katalog verfügbar sein. Legen Sie Ihren Katalog in einem RAID-0+1-Array ab. Den Katalogspeicherort können Sie im Exchange-System-Manager angeben, wenn Sie den Katalog erstellen.

  • Eigenschaftenspeicher Diese Datenbank enthält unterschiedliche Eigenschaften der im Katalog indizierten Elemente. Es ist nur ein Eigenschaftenspeicher pro Server verfügbar. Legen Sie den Volltext-Eigenschaftenspeicher im RAID-Array ab. In der Standardeinstellung werden die Dateien und der Exchange-Server auf demselben Laufwerk installiert.

  • Temporäre Dateien Diese Dateien enthalten temporäre Informationen, die vom Microsoft-Suchdienst verwendet werden. Legen Sie das temporäre Verzeichnis für den Volltextindex im RAID-Array ab. In der Standardeinstellung werden diese Dateien auf dem Systemlaufwerk installiert, das üblicherweise nicht über den E/A-Durchsatz des RAID-Array verfügt.

  • Gathererprotokolle Diese Dateien enthalten Protokollinformationen für den Indizierungsdienst. Für jeden Katalog liegt ein Protokollsatz vor. Die Gathererprotokolle können am Standardspeicherort bleiben. Falls gewünscht, können Sie sie auch verschieben.

So können Sie die Volltextindizierung aktivieren oder deaktivieren

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Server. Erweitern Sie anschließend einen Exchange-Server und die Speichergruppe, die den Informationsspeicher für Öffentliche Ordner enthält, mit dem Sie arbeiten.

  3. Klicken Sie mit der rechten Maustaste auf den Informationsspeicher für Öffentliche Ordner, und wählen Sie Eigenschaften aus.

  4. Wählen Sie die Registerkarte Volltextindizierung.

  5. Bearbeiten Sie das Feld Aktualisierungsintervall gemäß Ihren Anforderungen.

  6. Klicken Sie auf OK, um die Änderungen zu speichern und die Eigenschaften des Informationsspeichers für Öffentliche Ordner zu verlassen.

Weitere Informationen zur Volltextindizierung von öffentlichen Ordnern finden Sie im Microsoft Knowledge Base-Artikel 319433, „HOW TO: Configure Full-Text Indexing on Public Folders" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319433).

Weitere Informationen zu Konfiguration und Fehlerbehebung für die Volltextindizierung von Postfachspeichern finden Sie in folgenden Artikeln der Microsoft Knowledge Base:

  • 822932, „HOW TO: Configure Full-Text Indexing on Mailbox Stores in Exchange 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=822932

  • 319436, „HOW TO: Configure Full-Text Indexing on Mailbox Stores in Exchange 2000" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=319436

Informationen zur Volltextindizierung in einer mehrsprachigen Umgebung finden Sie im Knowledge Base-Artikel 325624, „XGEN: Full-Text Indexing with Multiple Languages" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325624).

Weitere Informationen zu optimalen Vorgehensweisen bei der Volltextindizierung finden Sie im Knowledge Base-Artikel 326186, „XADM: White Paper - The Best Practices for Deploying Full-Text Indexing" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326186).


DSNs werden derzeit als Meldungen wiedergegeben
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-03-21

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die Benachrichtigungen zum Übermittlungsstatus (DSNs) auf dem Exchange Server-Computer als Standardnachrichten wiedergegeben werden:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent\RenderDSNsAsMessages

Wenn Microsoft Exchange Server Analyzer erkennt, dass der Registrierungswert RenderDSNsAsMessages vorhanden und größer als 0 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Wie der Name des Registrierungseintrags RenderDSNsAsMessages erkennen lässt, steht dieser Registrierungseintrag für eine Konfigurationsmöglichkeit, über die Administratoren die Wiedergabe der DSNs auf Computern mit Exchange 2000 Server, Exchange Server 2003 und Exchange Server 2007 steuern kann:

  • Wenn der Wert für RenderDSNsAsMessages auf 0 festgelegt ist, werden die Benachrichtigungen (zu denen Zustellbarkeitsberichte und Unzustellbarkeitsberichte gehören) als Standard-MAPI-Nachrichten wiedergegeben.

  • Wenn der Wert für RenderDSNsAsMessages auf einen größeren Wert als 0 festgelegt ist, werden die Benachrichtigungen als Multipart- bzw. gemischte MIME-Nachrichten wiedergegeben.

Der Registrierungswert ist in der Standardeinstellung nicht vorhanden und muss manuell hinzugefügt werden. Außerdem muss zuvor auf dem Computer mindestens das Exchange 2000 Server Post-Service Pack 3-Rollup von September 2003 ausgeführt werden, damit sich dieser Eintrag in gewünschter Weise auf Exchange 2000 Server auswirkt.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

  3. Löschen Sie den Registrierungseintrag RenderDSNsAsMessages.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.
  • Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 "Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung enthält.

  • Weitere Informationen zu Formatproblemen bei Benachrichtigungen über den Übermittlungsstatus betreffen, finden Sie im Knowledge Base-Artikel 812806, "Der Exchange-Benutzer empfängt unerwarteterweise einen Standardunzustellbarkeitsbericht anstatt eines benutzerdefinierten Unzustellbarkeitsberichts" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=812806).

  • Weitere Informationen zum Exchange 2000 Server Post-Service Pack 3 Rollup finden Sie im Knowledge Base-Artikel 824282, "Rollup Exchange 2000 Server nach Service Pack 3 aus September 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=824282).


„Aging Keep Time-Datenbankintervall" wurde vom Standardwert auf einen anderen Wert geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Standardablaufwert für Datenbankindizes von Exchange-Clientansichten überschrieben wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Private-<GUID des privaten Informationsspeichers>\Aging Keep Time

Wenn Exchange Server Analyzer ermittelt, dass der Registrierungseintrag Aging Keep Time vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Für Ansichten verwendete Indizes, die von einem Exchange-Client in Exchange-Datenbanktabellen erstellt und über einen bestimmten Zeitraum nicht verwendet wurden, werden zu diesem Zeitpunkt gelöscht. Mithilfe der folgenden Registrierungseinträge wird der Ablauf von Indizes gesteuert:

  • Aging Keep Time Das Mindestalter eines Index, bevor dieser gelöscht wird. Der Standardwert ist 8 Tage für Exchange Server 5.5 und 40 Tage für Exchange 2000 Server, Exchange Server 2003 und Exchange Server 2007.

  • Aging Clean Interval Der Mindestzeitraum (Millisekunden) zwischen Ausführungen von Indexalterungsaufgaben. Der Standardwert ist 24 Stunden.

  • Reset Views Wenn diese Einstellung vorhanden und ungleich 0 ist, wird beim Ausführen der nächsten Indexalterungsaufgabe das Löschen aller zwischengespeicherten Indizes erzwungen. Wenn der Ablauf von Indizes erfolgt ist, wird der Wert für Reset Views auf 0 festgelegt.

Es empfiehlt sich, den Registrierungswert Aging Keep Time nicht hinzuzufügen, es sei denn, Sie werden vom technischen Support von Microsoft dazu aufgefordert.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So zeigen Sie den Registrierungswert „Aging Keep Time" an und ändern diesen

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Private-<GUID des privaten Informationsspeichers>

  3. Untersuchen Sie den Wert für Aging Keep Time, und ändern Sie diesen bei Bedarf.

  4. Schließen Sie den Registrierungseditor. Wenn eine Änderung vorgenommen wurde, starten Sie den Exchange Server-Computer neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Datenbank- und Protokolldateien sind auf demselben Datenträger-Volume gespeichert
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-05

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob sich die Datenbankdateien für diesen Postfachspeicher auf demselben physischen Datenträger befinden wie die Transaktionsprotokolldateien für diese Speichergruppe. Insbesondere fragt Exchange Server Analyzer Active Directory ab, um Folgendes zu ermitteln:

  • Ob der Postfachspeicher mehr als 100 Postfächer umfasst. Dies wird durch Zählen der Werte des Attributs homeMDBBL des Postfachspeicherobjekts (Klasse msExchPrivateMDB) ermittelt. Wenn der Postfachspeicher über weniger als 100 Postfächer verfügt, ist der Einfluss des Dateispeicherorts auf die Leistung begrenzt.

  • Den Pfad der Datenbankdateien für den Postfachspeicher, der durch das Lesen des Werts von msExchEDBFile des Postfachspeicherobjekts ermittelt wird.

  • Den Pfad der Transaktionsprotokolldateien für die Speichergruppe, der durch Lesen des Werts von msExchESEParamLogFilePath des Speichergruppenobjekts (Klasse msExchStorageGroup) ermittelt wird.

  • Ob sich der Pfad in msExchESEParamLogFilePath auf demselben Laufwerk befindet wie der Pfad in msExchEDBFile.

Darüber hinaus ermittelt Exchange Server Analyzer Folgendes:

  • Ob die Exchange Server-Erweiterungen für von Windows unterstützte NAS auf dem Server ausgeführt werden, wird durch das Abfragen der WMI-Klasse (Windows Management Instrumentation) Win32_Service auf den Wert des Attributs Started für die Exchange Server-NAS-Erweiterungen (wssexchmap) ermittelt. Wenn die Exchange Server-Erweiterungen für von Windows unterstützte NAS ausgeführt werden, bedeutet dies, dass die betreffenden Dateien sich möglicherweise nicht auf einem lokalen Laufwerk befinden und Überlegungen zur Systemleistung möglicherweise nicht anwendbar sind.

  • Ob sich die Dateien auf einem Datenträger-Volume befinden, dessen Name länger als drei Zeichen ist. Dies wird durch die Abfrage der WMI-Klasse Win32_Volume ermittelt. Auch dies kann bedeuten, dass sich die Dateien sich nicht auf einem lokalen Laufwerk befinden und Überlegungen zur Systemleistung möglicherweise nicht anwendbar sind.

Um im Fall eines Festplattenfehlers Fehlertoleranz zu gewährleisten, sollten Sie Ihre Exchange-Transaktionen und Datenbankdateien auf getrennten physischen Festplatten speichern. Durch das Speichern dieser Protokolldateien und Datenbankdateien auf getrennten Festplatten können Sie die E/A-Leistung von Festplatten erheblich steigern.

Hinweis:
Damit im Fall einer erforderlichen Wiederherstellung einer Datenbank Fehlertoleranz gewährleistet ist, verfügt jede Speichergruppe über die eigenen Transaktionsdateien. Transaktionsprotokolldateien enthalten für jede Änderung an jeder Datenbank in der Speichergruppe einen Datensatz. Transaktionsprotokolldateien werden nicht gelöscht, bevor eine vollständige Sicherung aller Datenbanken in einer Speichergruppe erstellt wird.

Die folgenden Beispiele veranschaulichen, wie Daten auch unter extremen Umständen (wie der Verlust einer Festplatte, die die Datenbankdateien oder Transaktionsprotokolldateien enthält) wiederhergestellt werden können, wenn Sie über eine Sicherung verfügen und sich die Transaktionsprotokolldateien auf einem separaten Datenträger befinden.

  • Fällt die Festplatte aus, die die Datenbankdateien enthält, können Sie die ausgefallene Festplatte ersetzen, die neuste Sicherung der Datenbankdateien wiederherstellen und dann die auf einer separaten Festplatte gespeicherten aktuellen Protokolldateien dazu verwenden, die Daten auf dem Exchange-Server wiederherzustellen und sie für den Zeitpunkt des Ausfalls der Festplatte zu konfigurieren.

  • Wenn die Festplatte ausfällt, die die Transaktionsprotokolle enthält, die Festplatte mit den Datenbankdateien aber weiterhin funktionsfähig ist und die Datenbank-Speicherdatei ordnungsgemäß geschlossen wurde, kann es möglich sein, den ausgefallenen Transaktionsprotokoll-Datenträger zu reparieren und den Datenbankspeicher erneut bereitzustellen. Wenn die Datenbank-Speicherdatei nicht ordnungsgemäß geschlossen wurde, verbleibt sie in einem inkonsistenten Zustand und kann möglicherweise erst dann erneut bereitgestellt werden, nachdem ein Hard-Repair-Vorgang mit eseutil.exe durchgeführt wurde, der zu Datenverlust führen kann. Die andere Option ist, die Datenbank-Speicherdatei aus der Sicherung wiederherzustellen, die keine neuen Postfachdaten enthält, die nach der Sicherung erstellt wurden.

Wichtig:
Wenn Sie ihre Exchange-Datenbanken und ihre Transaktionsprotokolldateien auf derselben physischen Festplatte speichern und diese Festplatte ausfält, gehen die Daten verloren, die nach der letzten Sicherung erstellt wurden.

Darüber hinaus erhöht das Speichern von Datenbankdateien und Transaktionsprotokolldateien auf separaten physischen Datenträgern die Gesamtleistung des Systems. Exchange schreibt jede Transaktion zuerst in die Transaktionsprotokolldatei und dann in die Datenbankdatei. Darüber hinaus werden die Transaktionsprotokolldateien von allen Postfachspeichern in der Speichergruppe gemeinsam verwendet. Wenn sich diese Dateien auf demselben physischem Datenträger befinden, muss sich der Laufwerkskopf zwischen dem Speicherort der aktuellen Transaktionsprotokolldatei und den Speicherorten der Datenbankdateien hin und her bewegen, um die Schreibvorgänge durchzuführen. Wenn die Dateien sich auf separaten Datenträgern befinden, verbleibt einer der Laufwerkskopfs zum Beschreiben der Transaktionsprotokolldatei in derselben Position. Dadurch können Transaktionen schneller durchgeführt werden, als wenn die sich Dateien auf einem einzigen Datenträger befänden. Für eine einzelne Transaktion ist der Leistungsunterschied gering, aber bei hoher Systembelastung kann er bemerkbar werden.

Zum Korrigieren Ihrer Konfiguration können Sie entweder die Transaktionsprotokolldateien oder die Datenbankdateien verschieben.

So verschieben Sie in Exchange 2000 Server und Exchange Server 2003 die Transaktionsprotokolldateien auf ein neues Laufwerk

  1. Erweitern Sie im Exchange-System-Manager das passende Exchange-Serverobjekt, klicken Sie mit der rechten Maustaste auf die gewünschte Speichergruppe, und klicken Sie dann auf Eigenschaften.

  2. Geben Sie auf der Registerkarte Allgemein einen neuen Speicherort für die Dateien an.

    Wenn z. B. das Laufwerk E:\ nur Protokolldateien für diese Speichergruppe enthält, klicken Sie in Pfad des Transaktionsprotokolls auf Durchsuchen, und wählen Sie dann das Laufwerk E:\ aus.

So ändern Sie in Exchange Server 2007 den Speicherort von Transaktionsprotokolldateien in einer Exchange-Speichergruppe

  1. Befolgen Sie die Anweisungen in der Exchange Server 2007-Hauptdokumentation unter "How to Set or Change the Location of Storage Group Log Files" (http://go.microsoft.com/fwlink/?LinkId=80702).

So verschieben Sie in Exchange 2000 Server und Exchange Server 2003 die Transaktionsprotokolldateien auf ein neues Laufwerk

  1. Erweitern Sie im Exchange-System-Manager das Exchange Server-Objekt, auf dem sich der Informationsspeicher befindet. Erweitern Sie dann den entsprechenden Speichergruppencontainer, klicken Sie mit der rechten Maustaste auf das Postfachspeicherobjekt, das Sie verschieben möchten, und klicken Sie dann auf Eigenschaften.

  2. Geben Sie im Dialogfeld Eigenschaften auf der Registerkarte Datenbank den neuen Speicherort der Dateien an.
Achtung:
Zum Verschieben einer Datenbankdatei muss die Bereitstellung der Datenbank vorübergehend aufgehoben und die Datenbank anschließend erneut bereitgestellt werden. Dies wird automatisch vom Assistenten ausgeführt, wobei die Benutzer während des Vorgangs nicht auf die Datenbank zugreifen können.

So verschieben Sie in Exchange Server 2007 die Dateibankdateien mit dem Assistenten zum Verschieben des Datenbankpfads auf ein neues Laufwerk

  1. Starten Sie die Exchange-Verwaltungskonsole auf dem Server, auf dem sich die Speichergruppe befindet.

  2. Erweitern Sie in der Konsolenstruktur Serverkonfiguration, und klicken Sie dann auf Postfach.

  3. Erweitern Sie im Ergebnisbereich den entsprechenden Speichergruppencontainer, klicken Sie mit der rechten Maustaste auf das gewünschte Postfach-Datenbankobjekt, und klicken Sie dann auf Datenbankpfad verschieben. Der Assistent zum Verschieben des Datenbankpfads wird gestartet.

  4. Auf der Seite Einführung wird im Feld mit dem Pfad der Datenbankdateien der aktuelle Speicherort der Datenbankdateien angezeigt. Klicken Sie auf Durchsuchen, um einen Speicherort anzugeben, an den diese Dateien verschoben werden sollen.

  5. Klicken Sie auf Verschieben.

  6. Bestätigen Sie auf dem Abschlussbildschirm, dass der Datenbankdateipfad erfolgreich verschoben wurde. Der Status Abgeschlossen gibt an, dass der Assistent die Aufgabe erfolgreich ausgeführt hat. Der Status Fehlgeschlagen gibt an, dass die Aufgabe nicht erfolgreich ausgeführt wurde. Wenn die Aufgabe fehlschlägt, durchsuchen Sie die Zusammenfassung nach einer Erklärung, und klicken Sie dann auf Zurück, um Konfigurationsänderungen vorzunehmen. Klicken Sie auf Fertigstellen, um den Assistenten zum Verschieben des Datenbankpfads abzuschließen.
Hinweis:
In Exchange Server 2007 können Sie auch die Exchange-Verwaltungsshell zum Verschieben von Datenbankdateien verwenden. Weitere Informationen finden Sie unter Move-DatabasePath.

Weitere Informationen zu Exchange Server-Datenbankdateien finden Sie unter den folgenden Themen:

  • Kapitel 7 „Verwalten von Postfachspeichern und Informationsspeichern für Öffentliche Ordner" im Exchange Server 2003-Administratorhandbuch (http://www.microsoft.com/germany/technet/datenbank/articles/600271.mspx).

  • „Informationen zum Exchange-Informationsspeicher" im Handbuch Arbeiten mit dem Exchange Server 2003-Informationsspeicher (http://www.microsoft.com/downloads/details.aspx?displaylang=de).

Weitere Informationen zum Verwalten von Exchange Server-Datenbankdateien finden Sie im Microsoft Knowledge Base-Artikel 328794 „How to protect Exchange Data from Hard Disk Failure" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328794)

Weitere Informationen zum Durchführen eines Hard-Repair-Vorgangs für Exchange-Datenbankspeicher finden Sie im Microsoft Knowledge Base-Artikel 296788 „Offlinesicherungs- und Wiederherstellungsverfahren für Exchange Server" (http://support.microsoft.com/kb/296788/de).

Weitere Informationen zum Durchführen eines Hard-Repair-Vorgangs für eine Exchange-Datenbankspeicherdatei finden Sie im Microsoft Knowledge Base-Artikel 810190, „XADM: 'the information store terminated abnormally' error message and event ID 447 is logged" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810190).


Alle Protokolldateien der Datenbank sind vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer hat festgestellt, dass alle für die Wiederherstellung der Datenbank erforderlichen Protokolldateien vorhanden sind und sich an dem für die Wiederherstellung benötigten Speicherort befinden. Deshalb wird der Wiederherstellungsfehler nicht von einer fehlenden oder unpassenden Transaktionsprotokolldatei verursacht.

Möglicherweise sind die Datenbanken oder Transaktionsprotokolldateien beschädigt, oder andere Dateien stören den Wiederherstellungsvorgang.

So beheben Sie diesen Fehler

  • Verwenden Sie Exchange-System-Manager, um eine der Datenbanken in der Speichergruppe bereitzustellen, und untersuchen Sie dann das Anwendungsprotokoll auf Fehler, aus denen die Ursache für den Ausfall hervorgehen könnte.

  • Stellen Sie die isolierte Datenbank wieder her. Nach der Analyse der Datenbank zeigt Exchange Server Analyzer die Anweisungen für das Wiederherstellen der Datenbank an.

  • Führen Sie Eseutil.exe /ML aus, um die Integrität der benötigten Protokolldateien sicherzustellen. Weitere Informationen über die Verwendung von Eseutil finden Sie im Microsoft Knowledge Base-Artikel 248122 „How to use Eseutil to test transaction log files for damage in Exchange 2000 Server and in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=248122.


Die Datenbank befindet sich im Status „Clean Shutdown".
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer hat festgestellt, dass Ihre Exchange-Datenbank sich im Zustand „Clean Shutdown" befindet.

Eine Datenbank, die sich im Status „Clean Shutdown" befindet, wurde ordnungsgemäß beendet und vom Protokolldateistrom abgekoppelt. Wenn Sie die Datenbank wieder bereitstellen möchten, können Sie dies völlig ohne Wiederherstellungsvorgänge durchführen.

Wenn Sie eine Datenbank im Zustand „Clean Shutdown" nicht bereitstellen können, ist der Grund dafür nicht darin zu suchen, dass für die Datenbank weitere Transaktionsprotokolle eingespielt werden müssen. Es ist allerdings möglich, dass eine Datenbank mit dem Zustand „Clean Shutdown" nicht bereitgestellt werden kann, weil Transaktionsprotokolle für andere Datenbanken in der gleichen Speichergruppe wieder eingespielt werden müssen. Ehe eine Datenbank in einer Exchange-Speichergruppe bereitgestellt werden kann, müssen alle Datenbanken in dieser Speichergruppe wiederhergestellt und in einen bereitstellbaren Zustand gebracht werden.

Eine Datenbank, die sich im Status „Clean Shutdown" befindet, kann mit ihren vorangegangenen Transaktionsprotokollen oder mit einer anderen Gruppe von Transaktionsprotokollen bereitgestellt werden. Wenn Sie eine Datenbank im Zustand „Clean Shutdown" bereitstellen, und es gibt kein Transaktionsprotokoll, so wird eine neue Transaktionsprotokollgruppe generiert.

Hinweis:
Generell sollten vorhandene Transaktionsprotokolldateien nicht gelöscht werden, selbst wenn sich alle Datenbanken in einer Speichergruppe im Status „Clean Shutdown" befinden. Wenn Sie vorhandene Transaktionsprotokolldateien löschen, besteht keine Möglichkeit mehr, ein Rollforward aus älteren Sicherungen vorzunehmen. Das Löschen von Transaktionsprotokolldateien hat allerdings keinen Einfluss auf die aktuellen Datenbanken, wenn sich alle Datenbanken in einer Speichergruppe im Status „Clean Shutdown" befinden. Wenn Sie alle Transaktionsprotokolldateien für eine Speichergruppe löschen möchten, sollten Sie als optimale Methode sofort eine Vollsicherung aller Datenbanken in der Speichergruppe durchführen.


Die Datenbank befindet sich im Status „Dirty Shutdown", und es sind keine Protokolle erforderlich.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2006-08-10

Microsoft® Exchange Server Analyzer hat festgestellt, dass Ihre Datenbank sich im Zustand „Dirty Shutdown" befindet.

Per Definition ist für eine Datenbank im Zustand „Dirty Shutdown" die Wiedergabe von mindestens einer Transaktionsprotokolldatei erforderlich. „Dirty Shutdown" ist kein Status, in dem die Datenbank bereitgestellt werden kann, und sollte nicht während des allgemeinen Betriebs auftreten.

So beheben Sie diesen Fehler

  • Wenn Sie eine genauere Analyse der Datenbank- und Protokolldateien vornehmen möchten, sollten Sie gegebenenfalls zuerst Microsoft Hilfe und Support kontaktieren (http://go.microsoft.com/fwlink/?linkid=3052&kbid=31845).


Die Datenbank befindet sich in einem unbekannten Status.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer hat festgestellt, dass Ihre Datenbank sich in einem unbekannten Zustand befindet. Normalerweise sollten Ihre Datenbanken entweder im Zustand „Clean Shutdown" oder „Dirty Shutdown" befinden. (In Exchange 2000 Server und Vorversionen werden diese Zustände als „konsistent" beziehungsweise „inkonsistent" bezeichnet).

So beheben Sie diesen Fehler

  • Wenn Sie eine genauere Analyse des Datenbankzustands vornehmen möchten, sollten Sie möglicherweise zuerst Microsoft Hilfe- und Support unter (http://go.microsoft.com/fwlink/?LinkId=31845) kontaktieren.


In der Datenbank fehlen optionale und erforderliche Protokolldateien.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer hat festgestellt, dass einige der für die Wiederherstellung der Datenbank erforderlichen Protokolldateien sich nicht im Ordner für Protokolldateien befinden. Wenn eine erforderliche Protokolldatei fehlt, kann eine Datenbank erst dann wiederhergestellt werden, wenn die Protokolldatei gefunden wurde.

Wenn eine Exchange-Datenbank nicht ordnungsgemäß beendet worden ist, gibt es immer Protokolldateien, die wieder in die Datenbank eingespielt werden müssen, ehe sie wieder bereitgestellt werden kann. Minimal gibt es nur eine einzige Protokolldatei, die wieder eingespielt werden muss. Normalerweise gibt jedoch es mehrere Protokolldateien.

Zusätzlich zu den erforderlichen Protokolldateien kann es zusätzliche Protokolldateien geben, die in die Datenbank eingespielt werden können. Auch wenn es nicht notwendig ist, dass diese optionalen Protokolldateien wieder eingespielt werden, bevor die Datenbank bereitgestellt werden kann, können Sie diese Protokolldateien verwenden, um weitere Daten wiederherzustellen. Wenn Sie diese optionalen Protokolldateien nicht wieder einspielen, gehen alle darin enthaltenen Daten verloren.

So beheben Sie diesen Fehler

  • Suchen Sie die fehlenden Transaktionsprotokolldateien, und kopieren Sie diese in den entsprechenden Ordner.

  • Wenn Sie nicht alle optionalen Protokolldateien finden können, besteht die Möglichkeit, die Datenbank isoliert nur mit den erforderlichen Protokolldateien wiederherzustellen. Um die Datenbank ohne die optionalen Protokolldateien wiederherzustellen, befolgen Sie die Anweisungen in Exchange Server Analyzer. Denken Sie daran, dass Sie die Daten aus diesen optionalen Dateien verlieren, wenn Sie die Datenbank ohne die optionalen Protokolldateien wiederherstellen.

    In Abhängigkeit davon, welche Protokolldatei fehlt, können Sie jedoch möglicherweise einige der optionalen Protokolldateien wieder in die Datenbank einspielen. Stellen Sie sich zum Beispiel das folgende Szenario vor. Sie haben Protokolldateien, die von eins bis zehn durchnummeriert sind. Die zehnte Protokolldatei ist erforderlich (die übrigen Dateien sind optional) und die sechste Protokolldatei fehlt. In diesem Fall wären Sie in der Lage, die Protokolldateien sieben bis zehn wieder einzuspielen, weil die Reihenfolge bis zur erforderlichen Datei konstant ist.

  • Reparieren Sie die aktuelle Datenbank.

    Hinweis:
    Obwohl Sie beim Reparieren der Datenbank wahrscheinlich Erfolg haben werden, ist dies nicht garantiert. Selbst eine erfolgreiche Reparatur kann zu geringfügigem oder größerem Datenverlust führen. For more information about repairing an Exchange database, see Microsoft Knowledge Base article 812357, "How to maintain your Exchange database after you repair by using the Eseutil /p tool in Exchange Server 5.5, in Exchange 2000 Server, and in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812357).

  • Implementieren Sie eine hybride Strategie, bei der die Datenbank repariert und wiederhergestellt wird. Manchmal sind Sie vielleicht in der Lage, eine Datenbank wiederherzustellen, obwohl mit zusätzlichen Protokolldateien kein Rollforward durchgeführt werden kann. In solchen Fällen können Sie möglicherweise eine ältere Kopie der Datenbank wiederherstellen, während sie gleichzeitig die aktuelle Kopie reparieren, die nicht mehr bereitgestellt werden kann. Sie können dann den Inhalt der Datenbanken mischen, um die größtmögliche Datenmenge zu retten. Dies ist eine Strategie für Fortgeschrittene, und Sie sollten möglicherweise zuerst Microsoft Hilfe- und Support unter (http://go.microsoft.com/fwlink/?LinkId=31845) kontaktieren, ehe Sie diese Strategie umsetzen. Weitere Informationen zu dieser Strategie finden Sie in Using Recovery Storage Groups in Exchange Server 2003 unter (http://go.microsoft.com/fwlink/?LinkId=47589).


In der Datenbank fehlen optionale, aber keine erforderlichen Protokolldateien.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer hat festgestellt, dass eine Ihrer Datenbanken nicht ordnungsgemäß beendet wurde.

Wenn eine Exchange-Datenbank nicht ordnungsgemäß beendet worden ist, gibt es immer Protokolldateien, die wieder in die Datenbank eingespielt werden müssen, ehe sie wieder bereitgestellt werden kann. Minimal gibt es nur eine einzige Protokolldatei, die wieder eingespielt werden muss. Normalerweise gibt jedoch es mehrere Protokolldateien.

Zusätzlich zu den erforderlichen Protokolldateien kann es zusätzliche Protokolldateien geben, die in die Datenbank eingespielt werden können. Auch wenn es nicht notwendig ist, dass diese optionalen Protokolldateien wiedergegeben werden, bevor die Datenbank bereitgestellt werden kann, können Sie diese Protokolldateien verwenden, um weitere Daten wiederherzustellen. Wenn Sie diese optionalen Protokolldateien nicht wieder einspielen, gehen alle darin enthaltenen Daten verloren.

So beheben Sie diesen Fehler

  • Suchen Sie die fehlenden optionalen Protokolldateien, und kopieren Sie diese in den entsprechenden Ordner.

  • Wenn Sie nicht alle optionalen Protokolldateien finden können, besteht die Möglichkeit, die Datenbank isoliert nur mit den erforderlichen Protokolldateien wiederherzustellen. Um die Datenbank ohne die optionalen Protokolldateien wiederherzustellen, befolgen Sie die Anweisungen in Exchange Server Analyzer. Denken Sie daran, dass Sie die Daten aus diesen optionalen Dateien verlieren, wenn Sie die Datenbank ohne die optionalen Protokolldateien wiederherstellen.

    In Abhängigkeit davon, welche Protokolldatei fehlt, können Sie jedoch möglicherweise einige der optionalen Protokolldateien wieder in die Datenbank einspielen. Stellen Sie sich zum Beispiel das folgende Szenario vor. Sie haben Protokolldateien, die von eins bis zehn durchnummeriert sind. Die zehnte Protokolldatei ist erforderlich (die übrigen Dateien sind optional) und die sechste Protokolldatei fehlt. In diesem Fall wären Sie in der Lage, die Protokolldateien sieben bis zehn wieder einzuspielen, weil die Reihenfolge bis zur erforderlichen Datei konstant ist.


In der Datenbank fehlen erforderliche Protokolldateien.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer hat festgestellt, dass einige der für die Wiederherstellung der Datenbank erforderlichen Protokolldateien sich nicht im Ordner für Protokolldateien befinden. Wenn eine erforderliche Protokolldatei fehlt, kann eine Datenbank erst dann wiederhergestellt werden, wenn die Protokolldatei gefunden wurde.

So beheben Sie diesen Fehler

  • Suchen Sie die fehlenden Transaktionsprotokolldateien, und kopieren Sie diese in den entsprechenden Ordner.

  • Stellen Sie die Datenbank aus einer Sicherung wieder her. Führen Sie dann ein Rollforward der Datenbank durch. Hierzu spielen Sie die verbleibenden Transaktionsprotokolldateien in die Datenbank ein.

    Wichtig:
    Die Daten in der fehlenden Protokolldatei und in den nachfolgenden Protokolldateien werden verloren gehen. Ehe Sie eine Datenbank aus der Sicherung wiederherstellen, sollten Sie eine Kopie der aktuellen Datenbank anlegen. Wenn die Wiederherstellung nicht glückt, müssen Sie u. U. die aktuelle Datenbank reparieren.

  • Reparieren Sie die aktuelle Datenbank.

    Hinweis:
    Obwohl Sie beim Reparieren der Datenbank wahrscheinlich Erfolg haben werden, ist dies nicht garantiert. Selbst eine erfolgreiche Reparatur kann zu geringfügigem oder größerem Datenverlust führen. Weitere Informationen zum Reparieren einer Exchange-Datenbank finden Sie im Microsoft Knowledge Base-Artikel 812357 „How to maintain your Exchange database after you repair by using the Eseutil /p tool in Exchange Server 5.5, in Exchange 2000 Server, and in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679).

  • Implementieren Sie eine hybride Strategie, bei der die Datenbank repariert und wiederhergestellt wird. Manchmal sind Sie vielleicht in der Lage, eine Datenbank wiederherzustellen, obwohl mit zusätzlichen Protokolldateien kein Rollforward durchgeführt werden kann. In solchen Fällen können Sie möglicherweise eine ältere Kopie der Datenbank wiederherstellen, während sie gleichzeitig die aktuelle Kopie reparieren, die nicht mehr bereitgestellt werden kann. Sie können dann den Inhalt der Datenbanken mischen, um die größtmögliche Datenmenge zu retten. Dies ist eine Strategie für Fortgeschrittene, und Sie sollten möglicherweise zuerst Microsoft Hilfe- und Support unter (http://go.microsoft.com/fwlink/?LinkId=31845) kontaktieren, ehe Sie diese Strategie umsetzen. Weitere Informationen zu dieser Strategie finden Sie in Using Recovery Storage Groups in Exchange Server 2003 unter (http://go.microsoft.com/fwlink/?LinkId=47589).


Datenbanken in dieser Speichergruppe werden während der Datensicherung auf null Seiten festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-05

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs msExchESEParamZeroDatabaseDuringBackup für jede Speichergruppe auf dem Server zu bestimmen. Wenn Exchange Server Analyzer feststellt, dass das Attribut msExchESEParamZeroDatabaseDuringBackup auf 1 festgelegt ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Das Attribut msExchESEParamZeroDatabaseDuringBackup stellt eine Konfigurationseinstellung dar, die während des Sicherungsvorgangs das Überschreiben gelöschter Datensätze/langer Werte mit Nullen ermöglicht. Dieser Vorgang wird als unwiderruflich löschen bezeichnet. Sie können das unwiderrufliche Löschen von Datenbankseiten auf der Speichergruppenebene steuern. Jede Speichergruppe kann über eine separate Richtlinie zum unwiderruflischen Löschen von Datenbankseiten verfügen.

In der Standardeinstellung ist das unwiderrufliche Löschen deaktiviert, und der Wert für das Attribut msExchESEParamZeroDatabaseDuringBackup ist auf 0 festgelegt. Wenn das Attribut auf 1 festgelegt ist, werden gelöschte Datenbankseiten am Ende von Onlinesicherungen beliebiger Datenbanken in dieser Speichergruppe mit anderen Zeichen überschrieben.

Das Aktivieren und Deaktivieren des unwiderruflichen Löschens für Exchange 2000 Server und Exchange Server 2003 kann mit dem Exchange-System-Manager durchgeführt werden (wie in diesem Artikel beschrieben). Das Aktivieren und Deaktivieren des unwiderrufliche Löschens für Exchange Server 2007 kann über die Exchange-Verwaltungsshell durchgeführt werden (wie in diesem Artikel beschrieben). Diese Option bietet zwar höhere Sicherheit, beeinträchtigt aber die Serverleistung.

Hinweis Wenn Sie das unwiderrufliche Löschen eines Exchange 2000 Server-Computers aktivieren, wird empfohlen, dass Sie Exchange 2000 Server Service Pack 3 oder eine höhere Version installieren. Service Pack 3 bereinigt ein bekanntes Problem, das dazu führen kann, dass der Exchange-Informationsspeicher nicht mehr antwortet. Weitere Informationen zu diesem Problem finden Sie im Microsoft Knowledge Base-Artikel 320883 „XADM: The Information Store Stops Responding During an Online Backup If Database Zeroing Is Turned On" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=320883.

So aktivieren bzw. deaktivieren Sie das unwiderrufliche Löschen für Exchange 2000 Server und Exchange Server 2003

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Server, und erweitern Sie dann den zu ändernden Server.

  3. Klicken Sie mit der rechten Maustaste auf die zu ändernde Speichergruppe, und klicken Sie dann auf Eigenschaften.

  4. Aktivieren oder deaktivieren Sie nach Bedarf im Dialogfeld Eigenschaften das Kontrollkästchen Gelöschte Datenbankseiten unwiderruflich löschen. Das unwiderrufliche Löschen wird durch das Aktivieren des Kontrollkästchens aktiviert und durch das Deaktivieren des Kontrollkästchens deaktiviert.

  5. Klicken Sie zum Speichern der Einstellung auf OK.

  6. Schließen Sie den Exchange-System-Manager, und starten Sie Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

So aktivieren bzw. deaktivieren Sie das unwiderrufliche Löschen gelöschter Seiten für Exchange Server 2007

  1. Der folgende Code ist ein Beispiel des Befehls Set-StorageGroup zum Aktivieren bzw. Deaktivieren des unwiderruflichen Löschens für Datenbanken in der Speichergruppe 'MyStorageGroup'.
Code kopieren
Set-StorageGroup -Identity MyStorageGroup -ZeroDatabasePages
 $false
Set-StorageGroup -Identity MyStorageGroup -ZeroDatabasePages
 $true

Weitere Informationen zu Auswirkungen des Überschreibens gelöschter Datenbankseiten auf die Leistung finden Sie im Knowledge Base-Artikel 815068 „XADM: Online Backup Performance Decreases Over Time" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=815068.


„Debug Break At Startup" wurde festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungswert, um zu ermitteln, ob für den Microsoft Exchange-Informationsspeicher das Debuggen aktiviert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Debug Break At Startup

Wenn Exchange Server Analyzer feststellt, dass für Debug Break At Startup ein Wert festgelegt wurde, zeigt Exchange Server Analyzer eine Warnung an.

Der Registrierungswert Debug Break At Startup aktiviert beim nächsten Start des Microsoft Exchange-Informationsspeicherdiensts den Debugmodus. Der Microsoft Exchange-Informationsspeicher verwendet im Debugmodus eine Vielzahl von Ressourcen. Es wird davon abgeraten, den Speicher in einer Produktionsumgebung zu debuggen.

Sofern Sie nicht gerade mithilfe des technischen Supports von Microsoft aktiv ein Speicherproblem beheben, sollten Sie den Registrierungswert Debug Break At Startup löschen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So löschen Sie den Registrierungsschlüssel „Debug Break At Startup"

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Suchen Sie im rechten Bereich den Wert Debug Break At Startup, und löschen Sie ihn.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Standard-ESE-Protokollpuffer wurden geändert
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchESEParamLogBuffers für jede Speichergruppe auf dem Exchange Server-Computer zu bestimmen. Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs msExchESEParamLogBuffers dem Wert 512 entspricht, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Das Speichergruppenattribut msExchESEParamLogBuffers bestimmt die Anzahl der vom Exchange-Informationsspeicher verwendeten ESE-Protokollpuffer (Extensible Storage Engine). ESE (Extensible Storage Engine) verwendet mehrere Protokollpuffer, um Informationen im RAM zu halten, bevor es in die Transaktionsprotokolle schreibt. Die Verwendung dieser Puffer verbessert die Leistung der Transaktionsprotokollierung. Bei großen Servern ist der Standardwert 84 zu niedrig. Es kann zu exzessiven Datenträger-E/A-Operationen auf dem Laufwerk mit dem Transaktionsprotokoll kommen, also zu einer deutlichen Leistungsminderung für den Fall, dass der Server unter Belastung steht oder Benutzer umfangreiche Nachrichten senden. Eine Erhöhung der Anzahl an ESE-Protokollpuffern verbessert die Leistung, obwohl es auch zu einer verstärkten Nutzung virtuellen Speichers kommt.

Gehen Sie zum richtigen Einstellen dieses Wertes folgendermaßen vor:

  • Legen Sie diesen Wert für Exchange 2000 Server, Exchange 2000 Server Service Pack 1 (SP1) oder Exchange 2000 Server Service Pack 2 (SP2) auf 9000 fest.

  • Legen Sie diesen Wert für Exchange 2000 Server Service Pack 3 (SP3) auf 512 fest.

  • Für Exchange Server 2003 wird ein Standardwert von 500 verwendet, und Sie sollten diesen Wert für das Attribut msExchESEParamLogBuffers auf 9000 einstellen.

Hinweis:
Wenn Sie die Protokollpuffer vorher auf 9000 festgelegt haben, müssen Sie diese Einstellung nach dem Installieren von Exchange 2000 Server SP3 manuell in einen kleineren Wert ändern. Diese Änderung wird beim Installieren von Exchange 2000 Server SP3 nicht automatisch ausgeführt.

Wenn Protokolle blockiert werden, kann dies an einem zu kleinen Puffer liegen. Sie können diesen Wert bis auf 9000 anheben. Der Leistungsindikator Database\Log Record Stalls/sec kann überwacht werden, um zu bestimmen, ob Protokollblockaden auftreten. Verwenden Sie keine Werte, die größer als 9000 sind, da andernfalls die Transaktionsprotokolldatei beschädigt werden kann.

Hinweis:
Log Record Stalls/sec ist die Anzahl der Protokolldatensätze, die pro Sekunde nicht zu den Protokollpuffern hinzugefügt werden können, da diese voll sind. Wenn dieser Indikator die meiste Zeit nicht null ist, kann die Größe des Protokollpuffers eine Engstelle darstellen.

Sie müssen den Wert mit einem Tool wie Active Directory Service Interfaces (ADSI) Edit-Snap-In, LDP (ldp.exe) oder einem beliebigen anderen Client für LDAP (Lightweight Directory Access Protocol), Version 3, korrigieren.

Achtung:
Wenn Sie die ADSI-Bearbeitung, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So stellen Sie die Standardkonfiguration wieder her

  1. Starten Sie die ADSI-Bearbeitung.

  2. Doppelklicken Sie auf den Container Konfiguration, erweitern Sie CN=Services, erweitern Sie CN=Microsoft Exchange, und erweitern Sie dann CN=<Name der Exchange-Organisation>.

  3. Erweitern Sie CN=Administrative Groups, erweitern Sie CN=<Name der administrativen Gruppe>, und erweitern Sie dann CN=Servers.

  4. Erweitern Sie CN=<ServerName>, erweitern Sie CN=InformationStore, klicken Sie mit der rechten Maustaste auf <StorageGroupName>, und klicken Sie dann auf Eigenschaften.

  5. Klicken Sie im Attribut-Editor auf das Attribut msExchESEParamLogBuffers, und klicken Sie anschließend auf Bearbeiten.

  6. Legen Sie im Feld Attribut bearbeitenden Wert für Exchange 2000 Server auf 512 oder für Exchange Server 2003 auf 9000 fest.

  7. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.

  8. Schließen Sie die ADSI-Bearbeitung, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Weitere Informationen über ESE-Protokollpuffer finden Sie im Microsoft Knowledge Base-Artikel 328466, „XADM: ESE Log Buffers That Are Set Too Low Can Cause the Store to Stop Responding" unter http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466.

Weitere Informationen zum Verwenden des LDP-Tools finden Sie im Knowledge Base-Artikel 260745, „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Weitere Informationen zur Verwendung der ADSI-Bearbeitung finden Sie im Thema „Adsiedit.msc: ADSI Bearbeitung" in der Hilfe zu Windows Server.


Bei dem Standardinformationsspeicher für Öffentliche Ordner handelt es sich um einen Remotespeicher
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-03

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob das Attribut msExchHomePublicMDB für jeden Postfachspeicher den lokalen Exchange Server enthält. In der Standardeinstellung ist der Informationsspeicher für öffentliche Ordner für einen Postfachspeicher auf dem lokalen Exchange Server vorhanden. Wenn das Attribut msExchHomePublicMDB nicht den lokalen Exchange Server enthält, verfügt der Postfachspeicher über einen Standard-Remoteinformationsspeicher für Öffentliche Ordner. Wenn Microsoft Exchange Server Analyzer feststellt, dass ein Postfachspeicher über einen Standard-Remoteinformationsspeicher für Öffentliche Ordner verfügt, zeigt Microsoft Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

So ändern Sie den Standard-Remoteinformationsspeicher für Öffentliche Ordner

  1. Erweitern Sie im Exchange-System-Manager <Ihren Exchange-Server>. Erweitern Sie die <Speichergruppe>, klicken Sie mit der rechten Maustaste auf den Postfachspeicher, und wählen Sie anschließend Eigenschaften aus.

  2. Klicken Sie auf der Registerkarte Allgemein unter Öffentlicher Standardinformationsspeicher auf Durchsuchen, um einen Informationsspeicher für Öffentliche Ordner auszuwählen.

Weitere Informationen zur Verwaltung öffentlicher Ordner finden Sie im Abschnitt „Verwalten von Postfachspeichern und Informationsspeichern für Öffentliche Ordner" im Exchange Server 2003-Administratorhandbuch unter http://go.microsoft.com/fwlink/?LinkId=47617.


„Deletion Thread Period" für einen Postfachspeicher weicht von der Standardeinstellung ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob das Intervall zum Entfernen gelöschter Elemente von der Standardeinstellung abweicht:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Deletion Thread Period

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel Deletion Thread Period vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Wenn Sie eine Nachricht löschen, markiert Exchange die Nachricht für den Löschvorgang. Exchange markiert die Nachricht auch als ausgeblendet, bis sie dauerhaft aus dem Exchange-Speicher gelöscht wird. Wenn der Exchange-Speicher eine Anforderung empfängt, eine Nachricht in einem bestimmten Ordner zu löschen, auf den durch eine Nachrichten-ID verwiesen wird, bestimmt der Exchange-Speicher, ob die Nachricht nur entfernt oder dauerhaft gelöscht werden soll. Die Nachricht wird dauerhaft gelöscht, nachdem die Aufbewahrungszeit für gelöschte Objekte abgelaufen ist. „Entfernen" wird auch als logisches Löschen bezeichnet. „Dauerhaftes Löschen" wird auch als physisches Löschen bezeichnet.

In der Standardeinstellung wird alle 24 Stunden eine Dumpster-Bereinigung ausgeführt, bei der entschieden wird, ob ein Element dauerhaft gelöscht werden soll. Die Dumpster-Bereinigung ist Teil des Online-Exchange-Speicherwartungsprozesses. Wenn die Aufbewahrungszeit für gelöschte Objekte abgelaufen ist, wird das Element dauerhaft gelöscht. Mit dem Registrierungswert Deletion Thread Period wird das Standardintervall von 24 Stunden überschrieben und ein benutzerdefiniertes Intervall für die Dumpster-Bereinigung angegeben.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Löschen Sie den Schlüssel Deletion Thread Period.

  4. Schließen Sie den Registrierungs-Editor.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Aufbewahrungszeit und zur Wiederherstellung von gelöschten Objekten finden Sie in den folgenden Knowledge Base-Artikeln:

  • 249680, „XADM: Understanding Deleted Item Retention and Message Deletion Process" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249680)

  • 287544, „XADM: Public Information Store Grows Significantly When the Deleted Item Retention Functionality Is Enabled" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=287544)

  • 822938, „HOW TO: Use System Policies to Configure Mailbox Storage Limits in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=822938.


„Deletion Thread Period" für einen Informationsspeicher für Öffentliche Ordner weicht von der Standardeinstellung ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob das Intervall zum Entfernen von nicht verwendeten Elementen von der Standardeinstellung abweicht:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\Deletion Thread Period

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel Deletion Thread Period vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Wenn Sie eine Nachricht löschen, markiert Exchange die Nachricht für den Löschvorgang. Exchange markiert die Nachricht auch als ausgeblendet, bis sie dauerhaft aus dem Exchange-Speicher gelöscht wird. Wenn der Informationsspeicher eine Anforderung empfängt, eine Nachricht in einem bestimmten Ordner zu löschen, auf den von einer Nachrichtenkennung verwiesen wird, bestimmt der Exchange-Speicher, ob die Nachricht nur entfernt oder dauerhaft gelöscht werden soll. Das Entfernen wird auch als logisches Löschen bezeichnet, und das dauerhafte Löschen wird auch als physisches Löschen bezeichnet. Die Nachricht wird dauerhaft gelöscht, nachdem die Aufbewahrungszeit für gelöschte Objekte abgelaufen ist.

In der Standardeinstellung wird alle 24 Stunden eine Dumpster-Bereinigung ausgeführt, bei der entschieden wird, ob ein Element dauerhaft gelöscht werden soll. Die Dumpster-Bereinigung ist Teil des Onlineprozesses der Exchange-Speicherwartung. Wenn die Aufbewahrungszeit für gelöschte Objekte abgelaufen ist, wird das Element dauerhaft gelöscht. Mit dem Registrierungswert Deletion Thread Period wird das Standardintervall von 24 Stunden überschrieben und ein benutzerdefiniertes Intervall für die Dumpster-Bereinigung angegeben.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. Löschen Sie den Schlüssel Deletion Thread Period.

  4. Schließen Sie den Registrierungs-Editor.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Aufbewahrungszeit und zur Wiederherstellung von gelöschten Objekten finden Sie in den folgenden Knowledge Base-Artikeln:

  • 249680, „XADM: Understanding Deleted Item Retention and Message Deletion Process" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249680)

  • 287544, „XADM: Public Information Store Grows Significantly When the Deleted Item Retention Functionality Is Enabled" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=287544)

  • 319098, "HOW TO: Use System Policies to Configure Public Folder Storage Limits in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319098)


Datenträgerengpass wurde festgestellt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2006-11-14

Microsoft® Exchange Server Analyzer hat festgestellt, dass Ihr Festplattensystem derzeit mit nur 20 Prozent des erwarteten maximalen Durchsatzes arbeitet. Dies wird anhand von mindestens einer der folgenden Berechnungen festgestellt:

  • Messen der Datenträgerwartezeiten. Die folgenden Leistungsindikatoren zeigen die Wartezeit an: LogicalDisk\Avg. Disk sec/Read und LogicalDisk\Avg. Disk sec/Write.

  • Vergleich des maximal möglichen Datenträger-E/A pro Sekunde (IOPS) der aktuellen Datenträgerkonfiguration und Spindleanzahl mit dem aktuellen IOPS-Wert, der vom Systemmonitor (Perfmon) aufgezeichnet wurde.

Akzeptable Wartezeiten

Je nach Typ der Daten, auf die zugegriffen wird, weist der Exchange-Server eine unterschiedliche Toleranz gegenüber Verzögerungen auf. Aus diesem Grund wird die maximal akzeptable Wartezeitgrenze auf der Grundlage der Ressourcenart auf dem Datenträger bestimmt. In allen Fällen (mit Ausnahme der Fälle, auf die in der folgenden Liste hingewiesen wird) beträgt der akzeptable Höchstwert für Wartezeiten bei Lese- oder Schreibvorgängen 50 Millisekunden (ms).

  • Transaktionsprotokolllaufwerke Das Laufwerk mit dem Transaktionsprotokoll sollte eine durchschnittliche Schreibwartezeit unter 10 ms aufweisen. Spitzenwerte der Schreibwartezeit sollten 50 ms nicht übersteigen. Schreibvorgänge in das Transaktionsprotokoll sind synchron. Dies bedeutet, dass jeder Thread bis zum Ende der Schreiboperation warten muss, ehe ein Thread im Prozess Store.exe eine andere Aufgabe ausführen kann. Kurze Schreibwartezeiten bei den Transaktionsprotokollen sind für die Serverleistung wichtig. Die durchschnittliche Lesewartezeit für das Laufwerk mit dem Transaktionsprotokoll sollte unter 20 ms liegen. Spitzenwerte der Lesewartezeit dürfen 50 ms nicht übersteigen. „Database Log Record Stalls/sec" und „Database Log Threads Waiting" sollten jeweils kleiner als 10 sein.

    Im Normalfall lesen Exchange-Servers die Transaktionsprotokolle nicht. Deshalb sind die Wartezeiten beim Lesen von diesem Laufwerk nicht wichtig. Da jedoch die Wartezeiten beim Schreiben von Transaktionsprotokollen für die Exchange-Leistung so wichtig sind, empfiehlt es sich, auf großen Servern die Laufwerke, auf denen sich die Transaktionsprotokolle befinden, nicht für andere Zwecke zu verwenden. Hierbei sollte die Rate der Lesevorgänge (gemessen in LogicalDisk\Disk Reads/sec) im Vergleich zur Rate der Schreibvorgänge (LogicalDisk\Disk Writes/sec) gering sein. Exchange Server Analyzer erkennt, ob das Verhältnis der Lesevorgänge zu den Schreibvorgängen auf dem Transaktionsprotokolllaufwerk größer als 0,10 ist (mehr als ein Lesevorgang auf zehn Schreibvorgänge).

    Wenn pro jeden Schreibvorgang mehr als 0,10 Lesevorgänge auftreten, sollten Sie ermitteln, welche Anwendung vom Transaktionsprotokolllaufwerk liest, und danach diesen Vorgang verhindern.

  • Datenbanklaufwerke Die akzeptable Wartezeit für die Laufwerke mit den Exchange-Datenbankdateien (*EDB- und *STM-Dateien) entsprechen den nachfolgend dargestellten Werten (höhere Werte weisen auf einen Datenträgerengpass hin:)

    • Der Maximalwert für Logical Disk\Avg. Disk sec/Read sollte auf einem Datenbanklaufwerk weniger als 50 ms (0,050 Sekunden) betragen

    • Der Durchschnittswert für Logical Disk\Avg. Disk sec/Read sollte auf einem Datenbanklaufwerk weniger als 20 ms (0,020 Sekunden) betragen

  • TEMP- und TMP-Laufwerke Die Wartezeit für die Laufwerke mit TEMP- und TMP-Verzeichnissen sollte beim Lesen und Schreiben unter 10 ms betragen. Der Maximalwert für die Lese- oder Schreibwartezeit sollte weniger als 50 ms betragen.

  • Auslagerungs- und Systemlaufwerk Die Wartezeit für die Laufwerke mit Auslagerungsdateien und Windows-Systemdateien sollten beim Lesen und Schreiben unter 10 ms betragen.

  • SMTP-Laufwerk Die Wartezeit für Laufwerke mit SMTP-Serverdateien sollte beim Lesen und Schreiben unter 10 ms betragen.

Ursachen von Latenz

Datenträger, auf die mit einer höheren Rate zugegriffen wird, als das Datenträgerteilsystem unterstützen kann, sind eine der häufigsten Ursachen für Datenträgerwartezeiten. In diesem Fall handelt es sich bei dem Datenträger um einen Engpass. Dies bedeutet auch, dass das Plattenteilsystem seine Durchsatzgrenze erreicht oder überschritten hat.

Wenn die Rate der Datenträger-IOPS (LogicalDisk\Disk Transfers/sec) nahezu gleich oder größer als die geschätzte Kapazität ist, wird der Datenträger als „außerhalb der Durchsatzkapazität" oder „außerhalb der Kapazität" charakterisiert. Um in diesen Fällen die Serverleistung zu verbessern, müssen Sie entweder die Last auf den Datenträgerteilsystemen verringern (Benutzer auf einen anderen Server verschieben) oder die Kapazität des Laufwerks erhöhen (durch Hinzufügen weiterer oder schnellerer Spindles).

In solchen Fällen, wenn die Hardware nicht die erwartete Leistung bringt, können Sie Wartezeiten selbst dann beobachten, wenn die E/A-Rate weit unter der geschätzten Kapazität liegt.

Senken der Datenträgerwartezeiten

Um die Last auf dem Plattenteilsystem zu vermindern, können Sie einige der vom Server ausgeführten Aufgaben reduzieren. Insbesondere sollten Sie optionale Anwendungen entfernen, die zu Plattenlast beitragen. Der Prozess Store.exe sollte als einzige Anwendung auf die Laufwerke mit der Datenbank und dem Transaktionsprotokoll zugreifen.

Je nach der aktuellen Konfiguration des Datenträgersystems können Sie mehrere Maßnahmen ergreifen, um die Auswirkungen dieses Problems zu verringern.

So reduzieren Sie die Festplattenwartezeit

  • Wenn sich ein Laufwerk mit der Datenbank oder dem Transaktionsprotokoll als Engpass erweist, können Sie die Last auf diesem Laufwerk verringern, indem Sie Benutzer in eine Datenbank oder Speichergruppe auf einem Laufwerk verschieben, das sich nicht kurz vor seiner Kapazitätsgrenze befindet. Wenn alle Datenbanken oder Laufwerke für Transaktionsprotokolle sich der Kapazitätsgrenze nähern, müssen Sie möglicherweise Benutzer zu einem anderen Server verschieben. Weitere Informationen finden Sie unter Verschieben von Benutzerpostfächern auf einen anderen Server.

  • Manchmal ist der Zeitraum mit einer hohen E/A-Rate kurz, weil er durch eine aufwändige MAPI-Operation verursacht wird. Um zu bestimmen, welcher Benutzer oder welche Aktion die hohen E/A-Raten verursacht, können Sie Exchange Server User Monitor (ExMon) in Verbindung mit den Leistungsindikatoren des logischen Datenträgers verwenden. Wenn Sie den Benutzer ermitteln können, können Sie möglicherweise herausfinden, welche Clientanwendung die größere Last verursacht. Sie können ExMon vom Microsoft Download Center unter (http://go.microsoft.com/fwlink/?linkid=54983) downloaden.

  • Wenn Sie ein RAID-5-Datenträgerarray ausführen, möchten Sie ggf. stattdessen ein RAID-10-Datenträgerarray verwenden, um die verfügbaren, unterstützten IOPS des Datenträgerteilsystems zu verbessern.

  • Wenn Sie die den Wert der unterstützten, verfügbaren IOPS erhöhen möchten, sollten Sie Ihr Festplattensystem durch weitere Festplatten ergänzen.

Weitere Informationen

  • Weitere Informationen zur Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange finden Sie im Behandeln von Leistungsproblemen bei Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen zu den bewährten Methoden für das Entwerfen von Speicherarchitekturen finden Sie unter Bewährte Methoden für mehrere Architekturen (http://go.microsoft.com/fwlink/?LinkId=72988).

  • Weitere Informationen zum Verschieben von Benutzerpostfächern zum Verringern der Serverlast finden Sie unter Verschieben von Benutzerpostfächern auf einen anderen Server.

  • Weitere Informationen zu Datenträgerbemessung, -wartezeiten und -E/A-Raten finden Sie in den folgenden Blogs auf der Microsoft Exchange Team-Blog-Website:

    • „A few basic concepts in disk sizing" (http://go.microsoft.com/fwlink/?linkid=39538)

    • "Noch ein paar Gedanken zu Datenträger-E/A und Berechnungen…." (http://go.microsoft.com/fwlink/?linkid=23456)

    • Berechnung der Anforderungen an die Datenträger-E/A (http://go.microsoft.com/fwlink/?linkid=69747)


Engpass auf der Festplatte mit dem Transaktionsprotokoll
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer hat festgestellt, dass das Festplattensystem mit den Exchange Server-Protokolldateien überlastet ist und einen Leistungsengpass verursacht. Dies wird durch Überprüfung von mindestens einem der folgenden Leistungsindikatoren festgestellt:

  • Es treten durchschnittlich mehr als 10 Database\Log Record Stalls/sec auf.

  • Es treten maximal mehr als 100 Database\Log Record Stalls/sec auf.

  • Es treten durchschnittlich mehr als 10 Database\Log Threads Waiting auf.

  • Es treten maximal mehr als 20 Database\Log Threads Waiting auf.

Wird einer dieser Schwellenwerte überschritten, so wird in einer Fehlermeldung angezeigt, dass Ihr Protokolllaufwerk einen Engpass darstellt. Protokolldateien erfordern kurze Schreibwartezeiten. Jede Sicherung oder eine Blockierung beim Schreiben in eine Protokolldatei, kann Probleme mit der Serverleistung verursachen. Protokollstillstand kann durch eine niedrige Einstellung für den Protokollpuffer msExchESEParamLogBuffers oder dadurch verursacht werden, dass zu viele Benutzer eine Serververbindung aufbauen möchten.

So reduzieren Sie die Wartezeit des Protokolllaufwerks

  • Sie können den Wert für den ESE-Pufferparameter, msExchESEParamLogBuffers, auf 9.000 erhöhen. Verwenden Sie keine Werte, die größer als 9000 sind, da andernfalls die Transaktionsprotokolldatei beschädigt werden kann. Weitere Informationen finden Sie unter Standard-ESE-Protokollpuffer wurden geändert.

  • Wenn das Laufwerk mit der Datenbank oder dem Transaktionsprotokoll den Engpass bildet, können Sie die Last auf diesem Laufwerk verringern, indem Sie Benutzer in eine Datenbank oder Speichergruppe auf einem Laufwerk verschieben, das sich nicht kurz vor seiner Kapazitätsgrenze befindet. Wenn alle Datenbanken oder Laufwerke für Transaktionsprotokolle sich der Kapazitätsgrenze nähern, müssen Sie möglicherweise Benutzer zu einem anderen Server verschieben. Weitere Informationen finden Sie unter Verschieben von Benutzerpostfächern auf einen anderen Server.


„EnableChangeNotification" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungswert, um zu ermitteln, ob die Dateiänderungsbenachrichtigung für das installierbare Exchange-Dateisystem (Exchange Installable File System - ExIFS) aktiviert wurde.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIFS\Parameters\ EnableChangeNotification

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel EnableChangeNotification vorhanden und mit einem Wert konfiguriert ist, der größer ist als 0, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In der Standardeinstellung ist die Dateiänderungsbenachrichtigung für ExIFS deaktiviert. Wenn ExIFS Änderungsbenachrichtigungen für eine Datei oder ein Verzeichnis sendet, wird die zwischengespeicherte Version der Datei oder des Verzeichnisses nicht gelöscht. Wenn eine Anwendung, z. B. Exchange Server oder Microsoft SharePoint® Portal Server, eine Änderungsmeldung erhält und die Datei oder das Verzeichnis erneut lädt, erhält die Anwendung infolgedessen die zwischengespeicherte Version und nicht die gerade geänderte Datei oder das gerade geänderte Verzeichnis.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\EXIFS\Parameters

  3. Löschen Sie den Schlüssel EnableChangeNotification.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den Exchange-Server neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum installierbaren Exchange-Dateisystem finden Sie in folgenden Quellen:

  • „Chapter 26 - Exchange 2000 Architecture" im Exchange 2000 Server Resource Kit (http://go.microsoft.com/fwlink/?LinkId=51224)

  • Technisches Referenzhandbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47891)


Fehler beim Zugriff auf das Protokollverzeichnis
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer hat festgestellt, dass der auf dem Exchange-Server für die Transaktionsprotokolle dieser Speichergruppe definierte Pfad nicht verfügbar ist.

So beheben Sie diesen Fehler

  • Stellen Sie sicher, dass der Pfad auf dem Server tatsächlich existiert.

  • Stellen Sie sicher, dass Sie die Berechtigung haben, die im Transaktionsprotokollpfad gespeicherten Dateien zu lesen.


Fehler beim Zugriff auf die Streaming-Datenbankdatei
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer hat festgestellt, dass der Zugriff auf die Datei der Streamingdatenbank (STM) von Exchange nicht möglich ist.

Jede Datenbank in Exchange 2000 Server und Exchange Server 2003 besteht aus zwei Dateien: Exchange-Datenbankdatei (EDB) und Streamingdatenbankdatei (STM). Auf diese Dateien muss zusammen zugegriffen, und sie müssen zusammen verarbeitet werden.

So beheben Sie diesen Fehler

  • Suchen Sie den vollständigen Pfad für die STM-Datei. Im Exchange-System-Manager ist dieser Pfad für jedes Datenbankobjekt auf der Eigenschaftenseite der Datenbank definiert.

  • Stellen Sie sicher, dass die STM-Datei für diese Datenbank existiert.

  • Stellen Sie sicher, dass Sie die Berechtigung haben, auf den Ordner zuzugreifen, in dem sich die STM-Datei befindet.

  • Stellen Sie sicher, dass die Datei nicht exklusiv von einem anderen Prozess gesperrt wurde. Der Versuch, die Datei umzubenennen, ist eine der Möglichkeiten, um dies festzustellen. Wenn Sie die Datei umbenennen können, bedeutet dies, dass die Datei nicht exklusiv gesperrt ist. (Vergessen Sie nicht, die Datei wieder auf ihren ursprünglichen Namen zurückzusetzen.)


Fehler beim Zugriff auf Protokolldateien
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft ® Exchange Server Analyzer war außerstande, die Transaktionsprotokolldateien zu lesen.

So beheben Sie diesen Fehler

  • Stellen Sie sicher, dass Sie die Berechtigung haben, auf den Ordner zuzugreifen, in dem sich das Transaktionsprotokoll befindet.

  • Stellen Sie sicher, dass die Datei nicht exklusiv von einem anderen Prozess gesperrt wurde. Der Versuch, die Datei umzubenennen, ist eine der Möglichkeiten, um dies festzustellen. Wenn Sie die Datei umbenennen können, bedeutet dies, dass die Datei nicht exklusiv gesperrt ist. (Vergessen Sie nicht, die Datei wieder auf ihren ursprünglichen Namen zurückzusetzen.)


Für diese Speichergruppe ist die maximale Anzahl der ESE-Protokollpuffer erreicht
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs msExchESEParamLogBuffers für jede Speichergruppe zu bestimmen. Wenn Exchange Server Analyzer erkennt, dass der Wert des Attributs msExchESEParamLogBuffers gleich 9.000 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

ESE (Extensible Storage Engine) verwendet mehrere Protokollpuffer, um Informationen im RAM zu halten, bevor es in die Transaktionsprotokolle schreibt. Mit diesen Puffern wird die Leistung der Transaktionsprotokollierung verbessert. Für große Server ist der Standardwert 84 zu niedrig. Es kann zu exzessiven Datenträger-E/A-Operationen auf dem Laufwerk mit dem Transaktionsprotokoll kommen, also zu einer deutlichen Leistungsminderung für den Fall, dass der Server unter Belastung steht oder Benutzer umfangreiche Nachrichten senden. Eine Erhöhung der Anzahl an ESE-Protokollpuffern verbessert die Leistung, obwohl es auch zu einer verstärkten Nutzung virtuellen Speichers kommt.

Gehen Sie zum richtigen Einstellen dieses Wertes folgendermaßen vor:

  • Legen Sie diesen Wert für Exchange 2000 Server, Exchange 2000 Server Service Pack 1 (SP1) oder Exchange 2000 Server Service Pack 2 (SP2) auf 9000 fest.

  • Legen Sie diesen Wert für Exchange 2000 Server Service Pack 3 (SP3) auf 512 fest.

  • Für Exchange Server 2003 wird ein Standardwert von 500 verwendet, und Sie sollten diesen Wert für das Attribut msExchESEParamLogBuffers auf 9000 einstellen.

Hinweis:
Wenn Sie die Protokollpuffer vorher auf 9000 festgelegt haben, müssen Sie diese Einstellung nach dem Installieren von Exchange 2000 Server SP3 manuell in einen kleineren Wert ändern. Diese Änderung wird beim Installieren von Exchange 2000 Server SP3 nicht automatisch durchgeführt.

Wenn Protokolle blockiert werden, kann dies an einem zu kleinen Puffer liegen. Sie können diesen Wert bis auf 9000 anheben. Der Leistungsindikator Database\Log Record Stalls/sec kann überwacht werden, um zu bestimmen, ob Protokollblockaden auftreten. Verwenden Sie keine Werte, die größer als 9000 sind, da andernfalls die Transaktionsprotokolldatei beschädigt werden kann.

Hinweis:
Log Record Stalls/sec ist die Anzahl der Protokolldatensätze, die nicht pro Sekunde zu den Protokollpuffern hinzugefügt werden können, da diese voll sind. Wenn dieser Indikator die meiste Zeit nicht null ist, kann die Größe des Protokollpuffers eine Engstelle darstellen.

Sie müssen den Wert mit einem Tool wie Active Directory Service Interfaces (ADSI) Edit-Snap-In, LDP (ldp.exe) oder einem beliebigen anderen Client für LDAP (Lightweight Directory Access Protocol), Version 3, korrigieren.

Achtung:
Wenn Sie die ADSI-Bearbeitung, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So stellen Sie die Standardkonfiguration wieder her

  1. Starten Sie die ADSI-Bearbeitung.

  2. Doppelklicken Sie auf den Container Konfiguration, erweitern Sie CN=Services, erweitern Sie CN=Microsoft Exchange, und erweitern Sie dann CN=<Name der Exchange-Organisation>.

  3. Erweitern Sie CN=Administrative Groups, erweitern Sie CN=<AdministrativeGroupName>, und erweitern Sie dann CN=Servers.

  4. Erweitern Sie CN=<ServerName>, erweitern Sie CN=InformationStore, klicken Sie mit der rechten Maustaste auf CN=<StorageGroupName>, und klicken Sie dann auf Eigenschaften.

  5. Klicken Sie im Attribut-Editor auf das Attribut msExchESEParamLogBuffers, und klicken Sie anschließend auf Bearbeiten.

  6. Legen Sie im Feld Attribut bearbeitenden Wert für Exchange 2000 Server auf 512 oder für Exchange Server 2003 auf 9000 fest.

  7. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.

  8. Schließen Sie die ADSI-Bearbeitung, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Weitere Informationen zum Einstellen von ESE-Protokollpuffern finden Sie im Microsoft Knowledge Base-Artikel 328466 „XADM: ESE Log Buffers That Are Set Too Low Can Cause the Store to Stop Responding" unter http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466.


ESE-Protokollpuffer sind für diese Speichergruppe zu niedrig eingestellt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer sendet eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert msExchESEParamLogBuffers für jedes Speichergruppenobjekt (Klasse msExchStorageGroup) im Container Informationsspeicher zu ermitteln. Stellt Exchange Server Analyzer fest, dass der Wert für dieses Attribut kleiner als 500 ist, wird eine Warnung angezeigt.

ESE (Extensible Storage Engine) verwendet eine Menge von Protokollpuffern, um Informationen im RAM zu halten, bevor es in die Transaktionsprotokolle schreibt. Die Verwendung dieser Puffer verbessert die Leistung der Transaktionsprotokollierung. Für große Server ist der Standardwert 84 zu niedrig. Es kann zu exzessiven Datenträger-E/A-Operationen auf dem Laufwerk mit dem Transaktionsprotokoll kommen, also zu einer deutlichen Leistungsminderung für den Fall, dass der Server unter Belastung steht oder Benutzer große Nachrichten senden. Eine Erhöhung der Anzahl an ESE-Protokollpuffern verbessert die Leistung, obwohl es auch zu einer verstärkten Nutzung virtuellen Speichers kommt.

Gehen Sie zum richtigen Einstellen dieses Wertes folgendermaßen vor:

  • Legen Sie diesen Wert für Exchange 2000 Server, Exchange 2000 Server Service Pack 1 (SP1) oder Exchange 2000 Server Service Pack 2 (SP2) auf 9000 fest.

  • Legen Sie diesen Wert für Exchange 2000 Server Service Pack 3 (SP3) auf 512 fest.

  • Für Exchange Server 2003 wird ein Standardwert von 500 verwendet, und Sie sollten diesen Wert für das Attribut msExchESEParamLogBuffers auf 9000 einstellen.

Hinweis:
Wenn Sie die Protokollpuffer vorher auf 9000 festgelegt haben, müssen Sie diese Einstellung nach dem Installieren von Exchange 2000 Server SP3 manuell in einen kleineren Wert ändern. Diese Änderung wird beim Installieren von Exchange 2000 Server SP3 nicht automatisch ausgeführt.

Wenn Protokolle blockiert werden, kann dies an einem zu kleinen Puffer liegen. Sie können diesen Wert bis auf 9000 anheben. Der Leistungsindikator Database\Log Record Stalls/sec kann überwacht werden, um zu bestimmen, ob Protokollblockaden auftreten. Verwenden Sie keinen Wert, der größer ist als 9000, da sonst die Transaktionsprotokolldatei beschädigt werden kann.

Hinweis:
Log Record Stalls/sec ist die Anzahl der Protokolldatensätze, die nicht pro Sekunde zu den Protokollpuffern hinzugefügt werden können, da diese voll sind. Wenn dieser Indikator die meiste Zeit nicht null ist, kann die Größe des Protokollpuffers eine Engstelle darstellen.

Sie müssen den Wert mit einem Tool wie Active Directory Service Interfaces (ADSI) Edit-Snap-In, LDP (ldp.exe) oder einem beliebigen anderen Client für LDAP (Lightweight Directory Access Protocol), Version 3, korrigieren.

Achtung:
Wenn Sie die ADSI-Bearbeitung, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So beheben Sie diese Warnmeldung

  1. Starten Sie die ADSI-Bearbeitung.

  2. Doppelklicken Sie auf den Container Konfiguration, erweitern Sie CN=Services, erweitern Sie CN=Microsoft Exchange, und erweitern Sie dann CN=<Name der Exchange-Organisation>.

  3. Erweitern Sie CN=Administrative Groups, erweitern Sie CN=<Name der administrativen Gruppe>, und erweitern Sie dann CN=Servers.

  4. Erweitern Sie CN=<ServerName>, erweitern Sie CN=InformationStore, klicken Sie mit der rechten Maustaste auf <StorageGroupName>, und klicken Sie dann auf Eigenschaften.

  5. Klicken Sie im Attribut-Editor auf das Attribut msExchESEParamLogBuffers, und klicken Sie anschließend auf Bearbeiten.

  6. Legen Sie im Feld zum Bearbeiten von Attributen den Wert für Exchange 2000 Server auf 512 oder für Exchange Server 2003 auf 9000 fest.

  7. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.

  8. Schließen Sie die ADSI-Bearbeitung, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Weitere Informationen über ESE-Protokollpuffer finden Sie im Microsoft Knowledge Base-Artikel 328466, „XADM: ESE Log Buffers That Are Set Too Low Can Cause the Store to Stop Responding" unter http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466.

Weitere Informationen zum Verwenden des LDP-Tools finden Sie im Knowledge Base-Artikel 260745, „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Weitere Informationen zum Einstellen von ESE-Protokollpuffern finden Sie im Microsoft Knowledge Base-Artikel 328466 „XADM: ESE Log Buffers That Are Set Too Low Can Cause the Store to Stop Responding" unter http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466.

Weitere Informationen zur Verwendung der ADSI-Bearbeitung finden Sie im Abschnitt „Adsiedit.msc: ADSI Bearbeitung" in der Hilfe zu Windows Server.


ESE-Protokollpuffer sind für diese Speichergruppe zu hoch festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs msExchESEParamLogBuffers für jede Speichergruppe zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs msExchESEParamLogBuffers für eine beliebige Speichergruppe größer als 9.000 ist, wird ein Fehler angezeigt.

ESE (Extensible Storage Engine) verwendet mehrere Protokollpuffer, um Informationen im RAM zu halten, bevor es in die Transaktionsprotokolle schreibt. Mit diesen Puffern wird die Leistung der Transaktionsprotokollierung verbessert. Für große Server ist der Standardwert 84 zu niedrig. Es kann zu exzessiven Datenträger-E/A-Operationen auf dem Laufwerk mit dem Transaktionsprotokoll kommen, also zu einer deutlichen Leistungsminderung für den Fall, dass der Server unter Belastung steht oder Benutzer umfangreiche Nachrichten senden. Eine Erhöhung der Anzahl an ESE-Protokollpuffern verbessert die Leistung, obwohl es auch zu einer verstärkten Nutzung virtuellen Speichers kommt.

Gehen Sie zum richtigen Einstellen dieses Wertes folgendermaßen vor:

  • Legen Sie diesen Wert für Exchange 2000 Server, Exchange 2000 Server Service Pack 1 (SP1) oder Exchange 2000 Server Service Pack 2 (SP2) auf 9000 fest.

  • Legen Sie diesen Wert für Exchange 2000 Server Service Pack 3 (SP3) auf 512 fest.

  • Für Exchange Server 2003 wird ein Standardwert von 500 verwendet, und Sie sollten diesen Wert für das Attribut msExchESEParamLogBuffers auf 9000 einstellen.

Hinweis:
Wenn Sie die Protokollpuffer vorher auf 9000 festgelegt haben, müssen Sie diese Einstellung nach dem Installieren von Exchange 2000 Server SP3 manuell in einen kleineren Wert ändern. Diese Änderung wird beim Installieren von Exchange 2000 Server SP3 nicht automatisch durchgeführt.

Wenn Protokolle blockiert werden, kann dies an einem zu kleinen Puffer liegen. Sie können diesen Wert bis auf 9000 anheben. Der Leistungsindikator Database\Log Record Stalls/sec kann überwacht werden, um zu bestimmen, ob Protokollblockaden auftreten. Verwenden Sie keine Werte, die größer als 9000 sind, da andernfalls die Transaktionsprotokolldatei beschädigt werden kann.

Hinweis:
Log Record Stalls/sec ist die Anzahl der Protokolldatensätze, die nicht pro Sekunde zu den Protokollpuffern hinzugefügt werden können, da diese voll sind. Wenn dieser Indikator die meiste Zeit nicht null ist, kann die Größe des Protokollpuffers eine Engstelle darstellen.

Sie müssen den Wert mit einem Tool wie Active Directory Service Interfaces (ADSI) Edit-Snap-In, LDP (ldp.exe) oder einem beliebigen anderen Client für LDAP (Lightweight Directory Access Protocol), Version 3, korrigieren.

Achtung:
Wenn Sie die ADSI-Bearbeitung, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So berichtigen Sie diesen Fehler

  1. Starten Sie die ADSI-Bearbeitung.

  2. Doppelklicken Sie auf den Container Konfiguration, erweitern Sie CN=Services, erweitern Sie CN=Microsoft Exchange, und erweitern Sie dann CN=<Name der Exchange-Organisation>.

  3. Erweitern Sie CN=Administrative Groups, erweitern Sie CN=<Name der administrativen Gruppe>, und erweitern Sie dann CN=Servers.

  4. Erweitern Sie CN=<ServerName>, erweitern Sie CN=InformationStore, klicken Sie mit der rechten Maustaste auf CN=<StorageGroupName>, und klicken Sie dann auf Eigenschaften.

  5. Klicken Sie im Attribut-Editor auf das Attribut msExchESEParamLogBuffers, und klicken Sie anschließend auf Bearbeiten.

  6. Legen Sie im Feld zum Bearbeiten von Attributen den Wert für Exchange 2000 Server auf 512 oder für Exchange Server 2003 auf 9000 fest.

  7. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.

  8. Schließen Sie die ADSI-Bearbeitung, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Weitere Informationen zum Verwenden des LDP-Tools finden Sie im Microsoft Knowledge Base-Artikel 260745 „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Weitere Informationen zum Einstellen von ESE-Protokollpuffern finden Sie im Microsoft Knowledge Base-Artikel 328466 „XADM: ESE Log Buffers That Are Set Too Low Can Cause the Store to Stop Responding" unter http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466.


Die Größe der ESE-Protokolldatei wurde manuell geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchESEParamLogFileSize für den InformationStore-Container zu ermitteln. Wenn Exchange Server Analyzer ermittelt, dass der Wert für das msExchESEParamLogFileSize-Attribut nicht gleich 5120 ist, wird ein Fehler angezeigt.

Dieser Wert gilt für alle Speichergruppen auf dem Server. Dieser spezielle Fehler tritt auf, wenn der Wert dieses Attributs geändert wurde und von seinem Standardwert (5120 KB oder 5 MB) abweicht. Nur dieser Wert wird unterstützt und sollte daher nie geändert werden.

Sie müssen den Wert mit einem Dienstprogramm wie Active Directory Service Interfaces (ADSI) Edit-Snap-In, LDP (ldp.exe) oder einem beliebigen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, korrigieren.

Achtung:
Wenn Sie die ADSI-Bearbeitung, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So beheben Sie diesen Fehler

  1. Öffnen Sie einen Active Directory-Editor, z. B. die ADSI-Bearbeitung, und suchen Sie das InformationStore-Objekt für diesen Exchange Server-Computer in Active Directory.

    Das Attribut msExchESEParamLogFileSize befindet sich unter:

    CN=Configuration, DC=Domain, CN=Services, CN=Microsoft Exchange, CN=Organisationsname, CN=Administrative Groups, CN=Name der administrativen Gruppe, CN=Servers, CN=Servername, CN=InformationStore

  2. Doppelklicken Sie auf das Attribut msExchESEParamLogFileSize, und legen Sie seinen Wert auf 5120 fest.

  3. Schließen Sie den Active Directory-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Weitere Informationen zum Bearbeiten von Active Directory-Attributen mithilfe von LDP.exe finden Sie im Microsoft Knowledge Base-Artikel 260745, „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Weitere Informationen zur Verwendung der ADSI-Bearbeitung finden Sie im Abschnitt „Adsiedit.msc: ADSI Bearbeitung" in der Hilfe zu Windows Server.


Die maximale Anzahl offener ESE-Tabellen wurde hartcodiert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob das Attribut msExchESEParamMaxOpenTables für ein oder mehrere der Speichergruppenobjekte unter dem InformationStore-Objekt des Exchange Server-Objekts vorhanden ist. Wenn Exchange Server Analyzer erkennt, dass das Attribut msExchESEParamMaxOpenTables vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In der Standardeinstellung für Exchange 2000 Server und Exchange Server 2003 ist dieses Attribut vorhanden, aber nicht mit einem Wert festgelegt. Exchange Server speichert Daten über Ordner, auf die momentan nicht zugegriffen wird. In manchen Fällen trägt dies zur Fragmentierung des virtuellen Speichers bei. Eine Methode, dies zu umgehen, besteht darin, die mögliche Anzahl gleichzeitig geöffneter Datenbanktabellen zu reduzieren. Der tatsächlich dafür vorgeschlagene Wert ist abhängig von der installierten Version von Exchange Server und Exchange Service Pack. Für Exchange 2000 Server Service Pack 2 beträgt die als Standard vorgegebene Einstellung für 8-Prozessor-Server 85.000 Tabellen pro Speichergruppe. In Exchange 2000 Server Service Pack 3 für 8-Prozessor-Server wird dieser Wert auf 27.600 verringert. Für 4-Prozessor-Server beträgt der Wert 13800. Dieser Wert kann reduziert werden, um Probleme mit der Fragmentierung des virtuellen Speichers zu beheben. Das Verringern dieses Wertes kann allerdings Situationen verursachen, in denen Operationen aufgrund zu wenig offener Tabellen fehlschlagen. Die Fehler treten auf, weil die maximal mögliche Anzahl offener Tabellen reduziert und deshalb das Maximum schneller erreicht wird.

Exchange Server 2003 verwendet eine andere Methode zum Zwischenspeichern von Daten über Ordner, auf die momentan nicht zugegriffen wird. Deshalb ist das Verringern der maximalen Anzahl offener Tabellen zum Reduzieren von Fehlern aufgrund von Fragmentierung des virtuellen Speichers weder nötig noch effektiv. Dieses Attribut sollte auf einem Exchange Server 2003-Server nicht festgelegt werden.

Wenn Sie nicht vom technischen Support von Microsoft angewiesen wurden, hier einen Wert einzugeben, verwenden Sie das Tool ADSI-Bearbeitung (Active Directory Service Interfaces) zum Löschen des Werts, der für dieses Attribut festgelegt wurde.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So löschen Sie den Attributwert msExchESEParamMaxOpenTables

  1. Öffnen Sie einen Active Directory-Editor, z. B. die ADSI-Bearbeitung.

  2. Doppelklicken Sie auf den Container Configuration, erweitern Sie CN=Services, erweitern Sie CN=Microsoft Exchange, und erweitern Sie dann CN=ExchangeOrganizationName.

  3. Erweitern Sie CN=Administrative Groups, erweitern Sie CN=AdministrativeGroupName, und erweitern Sie dann CN=Servers.

  4. Erweitern Sie CN=ExchangeServerName, erweitern Sie CN=InformationStore, klicken Sie mit der rechten Maustaste auf CN=StorageGroupName, und klicken Sie dann auf Eigenschaften.

  5. Klicken Sie im Feld zum Auswählen einer anzuzeigenden Eigenschaft, auf msExchESEParamMaxOpenTables.

  6. Klicken Sie im Feld Attribut bearbeiten auf Löschen, um das Festlegen des Wertes rückgängig zu machen.

  7. Klicken Sie auf OK, und klicken Sie anschließend erneut auf OK.

  8. Schließen Sie den Active Directory-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Weitere Informationen zu diesem Attribut finden Sie im Microsoft Knowledge Base-Artikel 325044 „SO WIRD'S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" unter http://support.microsoft.com/default.aspx?scid=kb;de;325044.

Weitere Informationen zum Verwenden des LDP-Tools finden Sie im Knowledge Base-Artikel 260745, „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.


Die Exchange-Datenbank überschreitet die Größe von 100 GB
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Microsoft Windows® Management Instrumentation) CIM_Datafile ab, um den Wert für den Schlüssel FileSize für jede Datenbank des Exchange-Informationsspeichers zu bestimmen. Wenn die Summe der Größen der EDB-Datei und der STM-Datei des Informationsspeichers 100 GB überschreitet, wird eine Warnung angezeigt.

Microsoft empfiehlt für Datenbanken für Informationsspeicher eine maximale Größe von 50 GB. Richtige Pflege vorausgesetzt, entstehen keine Betriebsprobleme beim Ausführen von Postfachspeichern mit einer Größe von über 50 GB; aufgrund der Sicherungs- und Wiederherstellungszeiten sind jedoch große Postfachspeicher für einige Leistungsverträge (SLA, Service Level Agreement) ungeeignet.

Wenn Sie Postfachspeicher mit einer Größe von über 50 GB ausführen, prüfen Sie, ob Ihre Hardware so zu dem Leistungsvertrag passt, dass die Wiederherstellung großer Datenbanken inbegriffen ist. Andernfalls wird empfohlen, Postfächer über mehrere Postfachspeicher so zu verteilen, dass die Größe eines beliebigen Postfachspeichers 50 GB nicht überschreitet.

So beheben Sie diese Warnmeldung

  1. Ziehen Sie in Betracht, einige Postfächer aus dem großen Informationsspeicher in einen neuen Informationsspeicher auf diesem oder einem anderen Exchange Server-Computer zu verschieben.

  2. Wenn Sie gerade Postfächer von diesem Informationsspeicher in einen anderen Speicher verschoben haben, oder wenn Sie gerade Postfächer aus diesem Informationsspeicher gelöscht haben, führt möglicherweise eine Offlinedefragmentierung zu einer Verringerung der Dateigröße.

  3. Ziehen Sie in Betracht, für Postfächer oder Nachrichten Größenbegrenzungen festzulegen, um ein unbegrenztes Wachstum der Datenbank des Informationsspeichers zu verhindern.

Weitere Informationen zu STM- und EDB-Dateien finden Sie im Microsoft Knowledge Base-Artikel 232323, „Native Content Storage in Microsoft Exchange" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323.

Weitere Informationen zum Verschieben von Postfächern in Exchange Server 2003 finden Sie im Knowledge Base-Artikel 821829, „Moving Mailboxes in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829.

Weitere Informationen zum Verschieben von Postfächern in Exchange 2000 Server finden Sie im Knowledge Base-Artikel 328810, „Moving mailboxes between servers" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810.

Weitere Informationen zum Durchführen von Offlinedefragmentierungen von Exchange Server-Datenbanken finden Sie im Knowledge Base-Artikel 328804, „So defragmentieren Sie Exchange-Datenbanken" (http://support.microsoft.com/kb/328804/DE/).

Weitere Informationen zum Festlegen von Größenbegrenzungen für Nachrichten finden Sie im Knowledge Base-Artikel 322679, „How to set size limits for messages in Exchange Server" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679.


Exchange-Datenbankdateien werden in einen komprimierten Ordner geschrieben
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_Directory ab, um den Wert des Schlüssels Compressed für den Ordner zu bestimmen, der die Datenbankdateien des Exchange-Informationsspeichers enthält. Wenn der Wert für Compressed für diesen Ordner auf True gesetzt ist, wird eine Fehlermeldung angezeigt.

Auf einem Exchange 2000 Server oder Exchange Server 2003-Computer werden die Informationsspeicher-Datenbanken in den folgenden Standard-Speicherort geschrieben:

<Laufwerk> :\Programme\Exchsrvr\mdbdata

Auf einem Computer mit Exchange Server 2007 werden die Datenbankdateien in den folgenden Standardspeicherort geschrieben:

<Laufwerk> :\Programme\Microsoft\Exchange Server\Mailbox\<Name der Speichergruppe>

Das Speichern von Exchange-Datendateien auf einem NTFS-komprimierten Datenträger wird von Microsoft nicht unterstützt. Wenn Sie Ihre Exchange-Datendateien auf einem komprimierten Datenträger speichern, beeinträchtigt der zusätzliche Aufwand die Leistung von Exchange erheblich. Wenn die Informationsspeicher-Datenbank eine bestimmte Größe (etwa 4 GB) erreicht, kann sie möglicherweise nicht bereitgestellt werden oder kann fehlerhaft sein.

Zu den Exchange-Datendateien gehören folgende Dateien:

  • EDB-Dateien

  • STM-Dateien

  • LOG-Dateien

  • DAT-Dateien

  • EML-Dateien

  • CHK-Dateien

Dateien, die mit ESE (Extensible Storage Engine) verwaltet werden, können nicht auf einem komprimierten Laufwerk gespeichert werden. Die ESE hängt von der Sektorunabhängigkeit für protokollbasierte Wiederherstellung ab, und durch die Komprimierung von Dateien wird die Sektorunabhängigkeit ungültig gemacht. Die Komprimierung sollte für Datenträger deaktiviert werden, die als Host für ESE-Datenbanken oder für Write-Ahead-Logging verwendende Datenbanken dienen.

Vor Exchange 2000 Server Service Pack 3 war die Bereitstellung komprimierter Informationsspeicher-Datenbanken möglich. Allerdings können in allen Informationsspeicher-Datenbanken oder Informationsspeicher-Protokollen von Exchange 2000 Server, die mit NTFS-Komprimierung komprimiert wurden, Beschädigungen auftreten.

Unter Exchange 2000 Server Service Pack 3 werden komprimierte Informationsspeicher-Datenbankdateien mit einer Größe von 128 MB oder geringer automatisch dekomprimiert. Wenn Datenbankdateien eine Größe von 128 MB überschreiten, kann die Datenbank nicht bereitgestellt werden, und in der Anwendungsprotokollierung werden Fehlermeldungen erzeugt. Unter Exchange 2000 Server Service Pack 3 können komprimierte Datenbanken mit einer Größe von mehr als 128 MB nicht bereitgestellt werden.

So deaktivieren Sie die Dateikomprimierung für einen angegebenen Ordner:

  1. Klicken Sie mit der rechten Maustaste auf den Ordner, für den Sie die Dateikomprimierung deaktivieren möchten, und klicken Sie dann auf Eigenschaften.

  2. Klicken Sie auf der Registerkarte Allgemein auf Erweitert.

  3. Deaktivieren Sie im Dialogfeld Erweiterte Attribute das Kontrollkästchen Inhalt komprimieren, um Speicherplatz zu sparen, und klicken Sie dann auf OK.

So verschieben Sie die Datenbankdateien auf Exchange 2000 Server oder Exchange Server 2003:

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Administrative Gruppen, erweitern Sie Ihre administrative Gruppe, erweitern Sie Server, erweitern Sie Ihren Server, erweitern Sie Ihre Speichergruppe, klicken Sie mit der rechten Maustaste auf Postfachspeicher, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Datenbank unter Exchange-Datenbank oder Exchange-Streamingdatenbank, auf Durchsuchen, geben Sie den Pfad zu einem Ordner ein, für den keine Komprimierung aktiviert ist, und klicken Sie dann auf OK.

  4. Klicken Sie auf OK oder Übernehmen, um Ihre Änderungen zu übernehmen, und klicken Sie dann in der Warnmeldung auf Ja.

    Nach dem Klicken auf Ja wird die Bereitstellung der Speicher (Datenbanken) aufgehoben, und dann werden diese verschoben und erneut bereitgestellt. Nach dem erfolgreichen Abschließen dieser Vorgänge wird die folgende Informationsmeldung angezeigt:

    Die Datenbankdateien wurden erfolgreich verschoben.

So verschieben Sie den Speicherort von Datenbankdateien in einer Exchange-Speichergruppe unter Exchange Server 2007

  1. Befolgen Sie die Anweisungen in der Exchange Server 2007-Hauptdokumentation unter "Verschieben eines Speichergruppenpfads" (http://www.microsoft.com/technet/prodtechnol/exchange/E2k7/DE/Help/ExchHelp/fdc108d0-6c9e-4454-9c04-ac4e27c07017.mspx?mfr=true).

Weitere Informationen zu STM- und EDB-Dateien finden Sie im Microsoft Knowledge Base-Artikel 232323, „Native Content Storage in Microsoft Exchange" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323.


Exchange-Datenbankdateien werden in eine Nicht-NTFS-Partition geschrieben
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Directory ab, um den Wert des Schlüssels FSName für den Pfad der Exchange-Datenbankdatei zu ermitteln. Wenn Exchange Server Analyzer ermittelt, dass der Wert für den Schlüssel FSName nicht NTFS File System ist, wird ein Fehler angezeigt.

Das Speichern von Exchange-Datendateien auf einem Nicht-NTFS-Datenträger wird von Microsoft nicht unterstützt. Zu den Exchange-Datendateien gehören folgende Dateien:

  • EDB-Dateien

  • STM-Dateien

  • LOG-Dateien

  • DAT-Dateien

  • CHK-Dateien

  • EML-Dateien

Wenn dieser Fehler auftritt, müssen Sie die Datenbankdateien in einen Ordner auf einem NTFS-Laufwerk verschieben. Wenn das Laufwerk, auf dem die Datenbankdateien gespeichert sind, als FAT-Laufwerk formatiert ist, können Sie zum Konvertieren des Laufwerks in NTFS auch das Befehlszeilentool convert.exe verwenden.

So verschieben Sie die Exchange-Datenbankdateien in Exchange 2000 Server oder Exchange Server 2003

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Administrative Gruppen, erweitern Sie Ihre administrative Gruppe, erweitern Sie Server, erweitern Sie Ihren Server, erweitern Sie Ihre Speichergruppe, klicken Sie mit der rechten Maustaste auf Postfachspeicher, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Datenbank unter Exchange-Datenbank oder Exchange-Streamingdatenbank auf Durchsuchen, geben Sie den Pfad zu einem Ordner auf einem NTFS-Volume ein, und klicken Sie dann auf OK.

  4. Klicken Sie auf OK oder auf Übernehmen, um die Änderungen zu übernehmen, oder klicken Sie auf Abbrechen, wenn Sie die Änderungen nicht übernehmen möchten.

  5. Wenn Sie auf OK oder auf Übernehmen klicken, wird folgende Meldung angezeigt:

    Hinweis Sie sind im Begriff, den folgenden Vorgang bzw. die folgenden Vorgänge auszuführen:

    • Ändern des Speicherorts der Exchange-Datenbank

    • Ändern des Speicherorts der Exchange-Streamingdatenbank

    Um die erforderlichen Vorgänge auszuführen, ist es erforderlich, die Bereitstellung des Informationsspeichers vorübergehend aufzuheben. Der Speicher steht dann für Benutzer nicht zur Verfügung.

    Möchten Sie fortfahren?

    Hinweis:
    In der Warnmeldung werden nur die von Ihnen ausgewählten Vorgänge aufgeführt. Die Warnmeldung enthält die Schaltflächen Ja und Nein.

  6. Klicken Sie auf Ja, wenn Sie fortfahren möchten. Andernfalls klicken Sie auf Nein.

  7. Wenn Sie auf Ja geklickt haben, wird die Bereitstellung der Speicher (Datenbanken) aufgehoben. Die Speicher werden dann verschoben und erneut bereitgestellt. Nach dem erfolgreichen Abschließen dieser Vorgänge wird die folgende Informationsmeldung angezeigt:

    Die Datenbankdateien wurden erfolgreich verschoben.

So verschieben Sie in Exchange Server 2007 den Speicherort von Datenbankdateien in einer Exchange-Speichergruppe

  1. Befolgen Sie die Anweisungen in der Exchange Server 2007-Hauptdokumentation unter "Verschieben eines Speichergruppenpfads" (http://www.microsoft.com/technet/prodtechnol/exchange/E2k7/DE/Help/ExchHelp/fdc108d0-6c9e-4454-9c04-ac4e27c07017.mspx?mfr=true).

Wenn das Laufwerk, auf dem das Transaktionsprotokollverzeichnis gespeichert ist, als FAT-Laufwerk formatiert ist, können Sie alternativ zur obigen Vorgehensweise zum Konvertieren des Laufwerks in NTFS auch das Befehlszeilentool convert.exe verwenden. Weitere Informationen zum Konvertieren einer FAT-Partition in eine NTFS-Partition mit dem Befehlszeilentool convert.exe finden Sie im Microsoft Knowledge Base-Artikel 214579 „Konvertieren einer Partition in NTFS mit "Convert.exe"" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579).


Exchange-Datenbankdateien werden in einen verschlüsselten Ordner geschrieben.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Directory ab, um den Wert des Schlüssels Encrypted für den Ordner zu bestimmen, der die Datenbankdateien des Microsoft Exchange-Informationsspeichers enthält. Wenn Exchange Server Analyzer feststellt, dass der Wert für Encrypted auf True festgelegt ist, wird ein Fehler angezeigt.

Auf einem Exchange 2000 Server- oder Exchange Server 2003-Computer werden die Datenbankdateien in den folgenden Standard-Speicherort geschrieben:

<Laufwerk> :\Programme\Exchsrvr\mdbdata

Auf einem Computer mit Exchange Server 2007 werden die Datenbankdateien in den folgenden Standardspeicherort geschrieben:

<Laufwerk> :\Programme\Microsoft\Exchange Server\Mailbox\<Name der Speichergruppe>

Microsoft unterstützt nicht das Speichern von Exchange-Datendateien auf verschlüsselten Datenträgern in verschlüsselnden Dateisystemen (Encrypting File Systems, EFS). Wenn Sie Exchange-Datendateien auf einem verschlüsselten Datenträger speichern, wirkt sich der zusätzliche Overhead entscheidend auf die Exchange-Leistung aus. Zu den Exchange-Datendateien gehören folgende Dateien:

  • EDB-Dateien

  • STM-Dateien

  • LOG-Dateien

  • DAT-Dateien

  • EML-Dateien

  • CHK-Dateien

Um die Sicherheit der Exchange-Datendateien zu gewährleisten, empfiehlt es sich, den unbefugten Zugriff auf den Exchange-Computer zu verhindern und Nachrichtendaten mithilfe des S/MIME-Nachrichtenformats zu verschlüsseln.

Um diesen Fehler zu beheben, müssen Sie entweder die Dateiverschlüsselung für den Ordner deaktivieren, in den die Datenbankdateien geschrieben werden, oder die Datenbankdateien in einen Ordner verschieben, in dem die Verschlüsselung nicht aktiviert ist.

So deaktivieren Sie die Dateiverschlüsselung für den angegebenen Ordner:

  1. Klicken Sie mit der rechten Maustaste auf den Ordner, für den die Verschlüsselung deaktiviert werden soll, und klicken Sie dann auf Eigenschaften.

  2. Klicken Sie auf der Registerkarte Allgemein auf Erweitert.

  3. Deaktivieren Sie im Dialogfeld Erweiterte Attribute das Kontrollkästchen Inhalt verschlüsseln, um Daten zu schützen, und klicken Sie dann auf OK.

So verschieben Sie die Datenbankdateien auf Exchange 2000 Server oder Exchange Server 2003:

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Administrative Gruppen, erweitern Sie Ihre administrative Gruppe, erweitern Sie Server, erweitern Sie Ihren Server, erweitern Sie Ihre Speichergruppe, klicken Sie mit der rechten Maustaste auf Postfachspeicher, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Datenbank unter Exchange-Datenbank oder Exchange-Streamingdatenbank auf Durchsuchen, geben Sie den Pfad zu einem Ordner ein, für den keine Verschlüsselung aktiviert ist, und klicken Sie dann auf OK.

  4. Klicken Sie auf OK oder Übernehmen, um Ihre Änderungen zu übernehmen, und klicken Sie dann in der Warnmeldung auf Ja.

  5. Nach dem Klicken auf Ja wird die Bereitstellung der Speicher (Datenbanken) aufgehoben. Anschließend werden diese verschoben und erneut bereitgestellt. Nach dem erfolgreichen Abschließen dieser Vorgänge wird die folgende Informationsmeldung angezeigt:

    Die Datenbankdateien wurden erfolgreich verschoben.

So verschieben Sie in Exchange Server 2007 den Speicherort von Datenbankdateien in einer Exchange-Speichergruppe

  1. Befolgen Sie die Anweisungen in der Exchange Server 2007-Hauptdokumentation unter "Verschieben eines Speichergruppenpfads" (http://www.microsoft.com/technet/prodtechnol/exchange/E2k7/DE/Help/ExchHelp/fdc108d0-6c9e-4454-9c04-ac4e27c07017.mspx?mfr=true).

Weitere Informationen zum Verschieben von Datenbankdateien finden Sie im Microsoft Knowledge Base-Artikel 821915, „So verschieben Sie Exchange-Datenbanken und -Protokolle in Exchange Server 2003", unter http://support.microsoft.com/kb/821915/de.

Weitere Informationen über Exchange Server-Datendateien und EFS finden Sie im Knowledge Base-Artikel 834638, „Information about the storage of data files on an encrypted volume in Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638).

Informationen zum Sichern von Nachrichten in Microsoft Exchange Server 2003 finden Sie im Handbuch zur Nachrichtensicherheit in Exchange Server 2003 unter http://go.microsoft.com/fwlink/?linkid=47574.


Die Exchange-Datenbank befindet sich im Status „Dirty Shutdown".
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2006-10-30

Microsoft® Exchange Server Analyzer hat festgestellt, dass eine Ihrer Datenbanken nicht ordnungsgemäß beendet wurde. Deshalb sind die Datenbankdateien immer noch den Protokolldateien zugeordnet.

Der Status „Dirty Shutdown" bedeutet nicht, dass die Datenbank beschädigt oder defekt ist. Der Status „Dirty Shutdown" zeigt nur an, dass die Datenbankdateien nicht ordnungsgemäß vom Protokollstrom getrennt wurden. Deshalb müssen Sie erst die Datenbankdateien wiederherstellen, ehe Sie die Datenbank neu starten können.

Beim nächsten Bereitstellen der Datenbank wird diese Wiederherstellung automatisch durchgeführt. Wenn die automatische Wiederherstellung fehlschlägt, können Sie mithilfe von Microsoft Exchange Server Disaster Recovery Analyzer die Fehlerursache analysieren. Nach der Analyse gibt Exchange Server Disaster Recovery Analyzer Empfehlungen dafür ab, wie Sie die Datenbankdateien manuell wiederherstellen können.

So beheben Sie diesen Fehler

  • Bringen Sie die Datenbank in den Zustand „Clean Shutdown". Hierzu spielen Sie die erforderlichen Transaktionsprotokolldateien wieder in die Datenbank ein. Um die Protokolldateien wieder einzuspielen, stellen Sie die Datenbank bereit. Wenn dies fehlschlägt, können Sie mithilfe von Microsoft Exchange Server Disaster Recovery Analyzer versuchen, die Fehlerursache zu analysieren.

Weitere Informationen zu Exchange Server Disaster Recovery Analyzer finden Sie im Microsoft Knowledge Base-Artikel 922247 "Beschreibung von Exchange Server Disaster Recovery Analyzer für Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=922247).


Der Online-Wartungszeitplan für die Exchange-Datenbank ist auf „Nie" festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-05

Microsoft® Exchange Server Best Practices Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert für das Attribut activationSchedule für die Postfachspeicher und die Öffentlichen Informationsspeicher zu bestimmen. Wenn Exchange Server Best Practices Analyzer feststellt, dass der Wert für activationSchedule zu Nie aufgelöst wird, wird eine Warnung angezeigt.

Das Attribut activationSchedule stellt die Einstellung für den Onlinewartungszeitplan für Datenbanken dar. Die Onlinewartung für Datenbanken in Exchange Server ist unerlässlich. Während dieses Intervalls werden Aufgaben wie die Dumpster-Bereinigung (das Löschen von Nachrichten, deren Zeitlimit für die Aufbewahrung gelöschter Elemente überschritten wurde), Bereinigung nach Ablauf für Öffentliche Ordner (Nachrichten in Öffentlichen Ordnern sind abgelaufen, deren Alter ein bestimmtes Datum überschreitet), Bereinigung gelöschter Postfachelemente und Onlinedefragmentierung (Ermitteln und Entfernen von nicht mehr verwendeten Datenbankobjekten, wodurch mehr Speicherplatz für Datenbanken verfügbar wird) ausgeführt. Durch diese Prozesse werden ein optimaler Betrieb und eine stabile Leistung von Exchange Server-Computern sichergestellt. Die Onlinewartung sollte mindestens für mindestens vier Stunden täglich angesetzt werden. Andernfalls ist mit der Zeit ein Leistungsabfall zu verzeichnen.

Es empfiehlt sich, dass Sie die Ausführung der Onlinewartung für Datenbanken für jede Datenbank (jeden Postfachspeicher bzw. Informationsspeicher für Öffentliche Ordner) für täglich vier Stunden konfigurieren. Planen Sie die Intervalle für die Onlinewartung versetzt zu den Sicherungszeitplänen. Wenn beispielsweise die Sicherung von Mitternacht bis 02:00 Uhr ausgeführt wird, führen Sie die Onlinewartung von 03:00 Uhr bis 07:00 Uhr aus.

Dies ist wichtig, da die Onlinewartung nicht gestartet werden kann, wenn die Sicherungssitzung noch ausgeführt wird. Bei einer Überlappung beider Vorgänge hat die Sicherung Priorität gegenüber der Wartung. In diesem Fall überprüft Exchange alle 15 Minuten, ob die Sicherung abgeschlossen wurde. Nach Abschluss der Sicherung wird die Wartung gestartet.

Für die Ausführung der Wartung werden vom Informationsspeicher 18 Aufgaben abgearbeitet. Wenn eine Aufgabe gestartet wurde, wird die Aufgabe ungeachtet des Zeitfensters für die Wartung fertiggestellt. Nach Ablauf des Zeitfensters wird von der Wartung jedoch keine neue Aufgabe mehr gestartet. Somit werden in einigen Fällen nicht alle Aufgaben in einem bestimmten Wartungsintervall fertiggestellt. Wenn die Wartung abgebrochen wurde, wird der Vorgang während des nächsten Wartungszyklus an der betreffenden Stelle wiederaufgenommen.

So aktivieren die Online-Datenbankwartung für Exchange 2000 Server und Exchange Server 2003

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Server, und erweitern Sie dann den Server, mit dem gearbeitet werden soll.

  3. Erweitern Sie die Speichergruppe, mit der Sie arbeiten möchten.

  4. Klicken Sie in der Liste der verfügbaren Datenspeicher im Detailbereich mit der rechten Maustaste auf den gewünschten Informationsspeicher, und klicken Sie dann auf Eigenschaften.

  5. Klicken Sie im Dialogfeld Eigenschaften von Informationsspeicher auf die Registerkarte Datenbank.

  6. Führen Sie einen der folgenden Schritte aus:

    • Wählen Sie in der Intervallliste Wartung ein Intervall aus.

    • Klicken Sie auf Anpassen, um auf das Dialogfeld Zeitplan zuzugreifen, und erstellen Sie ein benutzerdefiniertes Intervall.

  7. Klicken Sie auf OK.

So vermeiden Sie diese Warnung in Exchange Server 2007

  1. Öffnen Sie die Exchange-Verwaltungskonsole.

  2. Erweitern Sie Serverkonfiguration und dann den Server, mit dem Sie arbeiten möchten.

  3. Erweitern Sie die Speichergruppe, mit der Sie arbeiten möchten.

  4. Klicken Sie mit der rechten Maustaste auf den Informationsspeicher, mit dem Sie arbeiten möchten, und klicken Sie dann auf Eigenschaften.

  5. Klicken Sie auf der Registerkarte Allgemein auf die Dropdownliste Wartungsintervall, und wählen Sie ein Intervall aus. Sie können auch auf Anpassen klicken, um einen benutzerdefinierten Zeitplan zu erstellen.

Weitere Informationen zu Onlinewartungsaufgaben für Datenbanken finden Sie im Microsoft Knowledge Base-Artikel 159196, „XADM: Vom IS-Wartungsplan gesteuerte Aufgaben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159196).


Der Exchange-Informationsspeicherdienst ist nicht für die Ausführung als LocalSystem konfiguriert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-02-27

Microsoft® Exchange Server Best Practices Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) Win32_Services ab, um zu bestimmen, ob das für die Eigenschaft StartName des Microsoft Exchange-Informationsspeicherdiensts (MSExchangeIS) angegebene Startkonto das Konto LocalSystem verwendet. Wenn Exchange Server Analyzer feststellt, dass der Wert für diese Eigenschaft auf einem Computer mit Exchange 2000 Server, Exchange Server 2003 oder Exchange Server 2007 ein anderes Konto als LocalSystem (auch SYSTEM genannt) darstellt, wird eine Warnung angezeigt. Diese Warnung wird nicht für Exchange Server 5.5-Computer ausgelöst, auf denen vorausgesetzt wird und erforderlich ist, dass der Microsoft Exchange-Informationsspeicherdienst mit einem Benutzerkonto ausgeführt wird.

Exchange 2000 Server, Exchange Server 2003 und Exchange Server 2007 müssen im Sicherheitskontext LocalSystem ausgeführt werden. Es darf kein bestimmtes Benutzerkonto mit Kennwort für den Start dieser Dienste zugewiesen werden. Dadurch wird sichergestellt, dass durch das Ändern von Kennwörtern oder das Löschen von Benutzerkonten nicht die ordnungsgemäße Ausführung von Exchange verhindert wird. Wenn ein als LocalSystem ausgeführter Exchange-Dienst auf einen Remoteserver zugreift, erfolgt anhand der Anmeldeinformationen des Benutzerkontos die Authentifizierung durch Microsoft Windows 2000 Server bzw. Windows Server™ 2003.

Das Kennwort für das Computerkonto wird unter Verwendung des Standardmechanismus zum Ändern von Kennwörtern alle sieben Tage geändert. Dadurch wird das Computerkonto sicherer als ein typisches Benutzerkonto, für welches das Kennwort weniger häufig geändert wird. Es ist jedoch auch weniger zufällig als ein nach dem Zufallsprinzip erstelltes Computerkonto.

Einige Administratoren, die mit Exchange Server 5.5 vertraut sind, ändern bei Verwendung eines Benutzerkontos für Dienste das Startkonto für Exchange 2000 Server-, Exchange Server 2003 und Exchange Server 2007-Dienste vom Standardkonto LocalSystem in ein Benutzerkonto.

Für Exchange 2000 Server, Exchange Server 2003 und Exchange Server 2007 bietet Microsoft keinen Support für die Ausführung des Microsoft Exchange-Informationsspeicherdiensts mit einem anderen Konto als LocalSystem.

So beheben Sie diesen Fehler

  1. Klicken Sie auf Start, zeigen Sie auf Programme, dann auf Verwaltung, und klicken Sie dann auf Dienste.

  2. Klicken Sie in der Liste der Dienste mit der rechten Maustaste auf Microsoft Exchange-Informationsspeicher, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Anmelden unter Anmelden als auf Lokales Systemkonto, und klicken Sie dann auf OK.

  4. Klicken Sie mit der rechten Maustaste auf den Dienst Microsoft Exchange-Informationsspeicher, und klicken Sie dann auf Neu starten.

Weitere Informationen über Exchange-Dienste finden Sie im Microsoft Knowledge Base-Artikel 239762, "Exchange-Dienste werden unter LocalSystem ausgeführt" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762.


Der Exchange-Informationsspeicherdienst wird nicht ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-05

Microsoft® Exchange Server Best Practices Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) Win32_Service ab, um zu bestimmen, ob der für den Schlüssel Started im Microsoft Exchange-Informationsspeicherdienst angegebene Wert auf True oder False festgelegt ist.

Der Wert False gibt an, dass der Microsoft Exchange-Informationsspeicherdienst auf diesem Exchange Server-Computer nicht ausgeführt wird. Der Wert True gibt an, dass der Microsoft-Informationsspeicherdienst ausgeführt wird.

Microsoft Exchange Server Best Practices Analyzer überprüft auch die WMI-Klasse Exchange_Server im Namespace root\MicrosoftExchangeV2, um den Wert für den Schlüssel IsFrontEndServer zu bestimmen. Der Wert False gibt an, dass der Exchange Server-Computer kein Front-End-Server ist. Der Wert True bedeutet, dass der Computer mit Exchange Server ein Front-End-Server mit Exchange Server 2003 oder Exchange 2000 Server ist.

Wenn der Wert auf Systemen mit Exchange 2000 Server und Exchange Server 2003 für beide ausgewerteten Schlüssel False lautet, wird eine Warnung angezeigt.

Wird der Wert False für den Schlüssel Win32_Service Started zurückgegeben und auf dem Computer die Exchange Server 2007 ausgeführt, wird eine Warnung angezeigt.

Falls die Versuche, den Microsoft Exchange-Informationsspeicherdienst zu starten, fehlschlagen, könnte dies auf ein größeres Problem auf diesem Exchange Server-Computer hinweisen. In diesem Fall sollten Sie die Ereignisprotokolle nach Einzelheiten zu dem Fehler untersuchen. Sie sollten sich ebenso vergewissern, dass Sie das neueste Service Pack für Ihre Exchange Server-Version ausführen.

Das neueste Service Pack für Exchange Server 2003 erhalten Sie unter „Downloads for Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=25097).

Weitere Informationen zu bekannten Fehlerursachen für den Microsoft Exchange-Informationsspeicherdienst finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 827915 „The Information Store service may stop unexpectedly while converting a message that does not contain the PR_MESSAGE_CLASS property in Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827915)

  • 830602 „Exchange Server 2003 Information Store service stops responding" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=830602)

  • 839115 „The Information Store service does not start after you upgrade to Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839115)

  • 330197 „The Information Store service stops unexpectedly when a message with a null Internet message ID is delivered locally" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=330197)

  • 831130 „The Folders pane does not appear or the Information Store service quits unexpectedly when you use OWA to access your mailbox on your Exchange Server 2003 computer" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=831130)

  • 823163 „'Setup Cannot Locate a Qualifying Global Catalog Server' Error Message When You Try to Start the Information Store Service" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823163)

  • 822579 „Event ID 7024 After You Install Exchange Server 2003, and Exchange Information Store Service Does Not Start" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822579)

  • 833841 „The Microsoft Exchange Information Store service unexpectedly stops responding" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833841)

Weitere Informationen zum Verwenden von Front-End-Servern mit Exchange Server 2003 und Exchange 2000 Server finden Sie auf den folgenden Websites:

  • Using Microsoft Exchange 2000 Front-End Servers (http://go.microsoft.com/fwlink/?linkid=12055).

  • Exchange Server 2003 and Exchange 2000 Server Front-End and Back-End Topology (http://go.microsoft.com/fwlink/?linkid=47567)


Der Exchange-Informationsspeicherdienst wird auf diesem Front-End-Server nicht ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer sendet eine Abfrage an die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_Service, um die für den Schlüssel Started festgelegten Werte für den Microsoft Exchange-Informationsspeicherdienst und den SMTP-Dienst (Simple Message Transfer Protocol) zu ermitteln. Der Wert False gibt an, dass der Dienst nicht ausgeführt wird. Der Wert True gibt an, dass der Dienst ausgeführt wird.

Microsoft Exchange Server Analyzer untersucht auch die WMI-Klasse Exchange_Server im Namespace root\MicrosoftExchangeV2, um den Wert für den Schlüssel IsFrontEndServer zu bestimmen. Der Wert False zeigt an, dass der Exchange Server-Computer kein Front-End-Server ist. Der Wert True zeigt an, dass der Exchange Server-Computer ein Front-End-Server ist.

Wenn Exchange Server Analyzer feststellt, dass der Wert von Started für den SMTP-Dienst True ist, dass der Wert von Started für den Microsoft Exchange-Informationsspeicherdienst False ist, und dass der Wert von IsFrontEndServer auf True festgelegt ist, wird eine Warnung angezeigt.

Exchange 2000 Server und Exchange Server 2003 verwenden Front-End-Server, um Client-Anforderungen über POP3, IMAP4 und Microsoft Office Outlook® Web Access zu bearbeiten. Zusätzlich können sie als internettaugliche SMTP-Server verwendet werden. Wenn dieser Front-End-Server SMTP-Nachrichten akzeptiert und routet, IMAP-Clients unterstützt (die SMTP für die Nachrichtenübertragung verwenden) oder wenn auf diesem Front-End-Server VSAPI-kompatible Software (Virus Scan API) ausgeführt wird, muss der Microsoft Exchange-Informationsspeicherdienst ausgeführt werden. Andernfalls ist der Front-End-Server nicht in der Lage, SMTP-Nachrichten zu verarbeiten oder Nachrichten mit VSAPI zu prüfen.

Soweit nicht eine SMTP- oder VSAPI-kompatible Antivirussoftware auf dem Front-End-Server verwendet wird, besteht die empfohlene Konfiguration darin, alle Informationsspeicher für Öffentliche Ordner auf dem Front-End-Server zu trennen und zu löschen, den Microsoft Exchange-Informationsspeicherdienst zu beenden und dann den Microsoft Exchange-Informationsspeicherdienst auf deaktiviert festzulegen. Zusätzlich sollte der SMTP-Dienst angehalten werden, wenn er nicht verwendet wird. Auf Exchange Server-Computern, die SMTP oder VSAPI-kompatible Software verwenden, muss der Microsoft Exchange-Informationsspeicherdienst ausgeführt werden, um Nachrichten zu übermitteln und Messaging-Clients zu bedienen.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie das MMC-Snap-In Dienste.

  2. Klicken Sie mit der rechten Maustaste auf den Dienst Microsoft Exchange-Informationsspeicher, und klicken Sie dann auf Eigenschaften.

  3. Auf der Eigenschaftenseite von Microsoft Exchange-Informationsspeicher auf der Registerkarte Allgemein vergewissern Sie sich, dass für Starttyp die Option Automatisch festgelegt ist. Ist dies nicht der Fall, legen Sie Automatisch fest, klicken Sie auf Übernehmen und dann auf OK.

  4. Klicken Sie mit der rechten Maustaste auf den Dienst Microsoft Exchange-Informationsspeicher, und klicken Sie dann auf Start.

  5. Schließen Sie das Snap-In Dienste.

Falls die Versuche, den Microsoft Exchange-Informationsspeicherdienst zu starten, fehlschlagen, könnte dies auf ein größeres Problem auf diesem Exchange Server-Computer hinweisen. In diesem Fall sollten Sie die Ereignisprotokolle nach Einzelheiten zu dem Fehler untersuchen. Sie sollten sich ebenso vergewissern, dass Sie das neueste Service Pack für Ihre Exchange Server-Version ausführen. Das neueste Service Pack für Exchange Server erhalten Sie auf der Microsoft Exchange Server-Homepage (http://go.microsoft.com/fwlink/?LinkId=21573).

Weitere Informationen zu bekannten Fehlerursachen für den Microsoft Exchange-Informationsspeicherdienst finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 827915 „The Information Store service may stop unexpectedly while converting a message that does not contain the PR_MESSAGE_CLASS property in Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827915)

  • 830602 „Exchange Server 2003 Information Store service stops responding" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=830602)

  • 839115 „The Information Store service does not start after you upgrade to Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839115)

  • 330197 „The Information Store service stops unexpectedly when a message with a null Internet message ID is delivered locally" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=330197)

  • 831130 „The Folders pane does not appear or the Information Store service quits unexpectedly when you use OWA to access your mailbox on your Exchange Server 2003 computer" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=831130)

  • 823163 „'Setup Cannot Locate a Qualifying Global Catalog Server' Error Message When You Try to Start the Information Store Service" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823163)

  • 822579 „Event ID 7024 After You Install Exchange Server 2003, and Exchange Information Store Service Does Not Start" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822579)

  • 833841 „The Microsoft Exchange Information Store service unexpectedly stops responding" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833841)

Weitere Informationen zur Verwendung von Front-End-Servern finden Sie im Handbuch Exchange Server 2003 and Exchange 2000 Server Front-End and Back-End Topology (http://go.microsoft.com/fwlink/?linkid=47567).


Exchange-IFS-Laufwerk (Installable File System) ist aktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2006-02-28

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die Laufwerkbuchstabenzuordnung des installierbaren Exchange-Dateisystems (ExIFS oder IFS) aktiviert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

Wenn Exchange Server Analyzer feststellt, dass der Registrierungswert DriveLetter mit einem Laufwerkbuchstaben (z. B. M) konfiguriert wurde, wird ein Fehler angezeigt.

In Exchange 2000 Server wurde ein Feature mit dem Namen IFS eingeführt. IFS ist ein Treiber auf Kernel-Ebene, der einige der Daten in den Exchange-Informationsspeichern in das Microsoft Windows®-Dateisystem überträgt. Auf neuen Exchange 2000 Server-Installationen und bei der Aktualisierung von Exchange Server 5.5 auf Exchange 2000 Server ist IFS automatisch installiert, und ein Laufwerkbuchstabe (in der Standardeinstellung Laufwerk M) wird zugewiesen und dem Informationsspeicher zugeordnet. Dies wurde unter Verwendung des Namespaces \\.\BackOfficeStorage\ ausgeführt.

Exchange Server 2003 unterstützt IFS, in der Standardeinstellung ist die Laufwerkbuchstabenzuordnung jedoch deaktiviert. Der Registrierungswert DriveLetter ist in neuen Installationen von Exchange Server 2003 nicht vorhanden, und bei einer Aktualisierung von Exchange 2000 Server auf Exchange Server 2003 sind die Registrierungswertdaten nicht vorhanden, und daher wird die Laufwerkbuchstabenzuordnung entfernt.

Als günstigste Verfahrensweise wird empfohlen, die IFS-Laufwerkbuchstabenzuordnung in Exchange Server 2003 nicht zu aktivieren und sie in Exchange 2000 Server zu entfernen. Es sind Probleme bekannt, die auftreten können, wenn Antiviren- oder dateisystembasierte Anwendungen auf den dem IFS zugeordneten Laufwerkbuchstaben zugreifen bzw. diesen untersuchen. Infolgedessen wird empfohlen, die Laufwerkbuchstabenzuordnung zu entfernen, wenn die IFS-Funktion nicht verwendet wird.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So berichtigen Sie diesen Fehler

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\EXIFS\Parameters

  3. Doppelklicken Sie im rechten Bereich auf den Wert von DriveLetter.

  4. Löschen Sie im Feld Wert den angegebenen Buchstaben, sodass das Feld Wert leer ist.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Systemaufsichtsdienst und den World Wide Web-Veröffentlichungsdienst neu, damit die Änderung wirksam wird. Bei einem erneuten Starten des Systemaufsichtsdiensts werden auch alle Dienste neu gestartet, die vom Systemaufsichtsdienst abhängen, z. B. der Dienst Microsoft Exchange MTA-Stacks und der Microsoft Exchange-Informationsspeicherdienst.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Entfernen der Zuordnung von Laufwerk M in Exchange 2000 Server finden Sie im Knowledge Base-Artikel 305145, „SO WIRD'S GEMACHT: XADM: Entfernen der IFS-Zuordnung für Laufwerk M" (http://support.microsoft.com/kb/305145/de).

Weitere Informationen zum Entfernen der Zuordnung für Laufwerk M in Exchange 2003 Server finden Sie im Knowledge Base-Artikel 821836, „SO WIRD'S GEMACHT: XADM: Entfernen der IFS-Zuordnung für Laufwerk M" (http://support.microsoft.com/kb/305145/de).


Konfiguration und Leistung von Exchange Server
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2006-09-06

Microsoft® Exchange Server Analyzer hat festgestellt, dass Ihr Exchange-Server nicht für optimale Leistung konfiguriert ist.

Im normalen Betrieb greifen die Exchange-Server auf verschiedene Dateien zu. Der Speicherort der Dateien kann zu einem Leistungsengpass beitragen. Gruppen von untereinander abhängigen Dateiten, z. B. Laufwerke für Transaktionsprotokolle, werden auch als Ressourcen bezeichnet.

Wenn die Verteilung dieser Ressourcen zu einem Datenträgerengpass beiträgt, zeigt Exchange Server Analyzer möglicherweise eine Warnung oder einen Fehler zum Speicherort der Ressourcen auf dem Exchange-Server an. Wenn Sie sicherstellen möchten, dass bestimmte Ressourcen von anderen Lastanforderungen isoliert sind, verschieben Sie diese Ressourcen auf ein dediziertes Speichergerät. Die folgende Liste beschreibt, wie Ressourcen verwendet werden, und sie enthält Empfehlungen dafür, wie Sie die jeweiligen Ressourcen konfigurieren können.

  • Transaktionsprotokolllaufwerke Die Transaktionsprotokolldateien verwalten den Zustand und die Integrität der EDB- und STM-Dateien. Dies bedeutet, dass in Wirklichkeit die Protokolldateien die Daten darstellen. Es wurde für jede Speichergruppe eine Transaktionsprotokolldatei eingestellt. Da die Transaktionsprotokolle eine kritische Sicherungskomponente für die Daten in den Datenbankdateien von Exchange Server darstellen, muss Exchange Server alle Daten an die Protokolldatei übergeben, ehe viele der Transaktionen auf Daten beendet werden können. Verzögerungen beim Schreiben auf dem Transaktionsprotokolllaufwerk können die Leistung des Servers erheblich beeinträchtigen. Deshalb ist es wichtig, dass Sie die Laufwerke für das Transaktionsprotokoll isolieren, damit die Laufwerke ihr eigenes Festplattenteilsystem haben, das nicht auch von anderen Servern, Anwendungen oder Ressourcen genutzt wird. Um die beste Leistung zu erzielen, sollte jedes Transaktionsprotokoll über ein dediziertes Laufwerk verfügen.

  • Speicherort des TEMP-Laufwerks Bei erstmaliger Installation legt das Betriebssystem den Speicherort der temporären Datei auf das Laufwerk fest, das vom Betriebssystem verwendet wird. Dies bedeutet, dass jede E/A auf dem TEMP-Laufwerk mit den E/A konkurriert, die von diesem Laufwerk für Programme und Auslagerungsdateioperationen ausgeführt werden. Dieser Wettbewerb um E/A beeinträchtigt die Leistung. Das TEMP-Laufwerk wird für die Mail-Übermittlung und für die Inhaltskonvertierung von großen Nachrichten genutzt. Wenn das TEMP-Laufwerk zum Engpass wird, werden der Nachrichtenfluss und einige Clientanwendungen beeinträchtigt. Damit das Betriebssystem nicht mit dem TEMP-Laufwerk um E/A konkurrieren muss, und um die Gefahr von Leistungsproblemen auf dem Exchange-Server zu senken, wird empfohlen, das Sie:

    • Ändern Sie die globale Umgebungseinstellung für TEMP, damit sie auf einen anderen Datenträger zeigt.

    • Verschieben Sie das TEMP-Laufwerk auf einen eigenen Datenträger.

  • Speicherort der EDB- und STM-Dateien Eine Exchange-Datenbank besteht aus zwei Dateien:

    • Eine edb-Datei (MAPI-Inhalt) Diese Datei speichert alle MAPI-Meldungen und -Tabellen, die vom Prozess Store.exe verwendet werden, um alle Meldungen und Prüfsummen der EDB- und STM-Dateien und die MAPI-Meldungen zu suchen.

    • Eine STM-Datei (kein MAPI-Inhalt) Diese Datei enthält Meldungen, die mit ihrem einheitlichen Internetinhalt gesendet werden.

    Da der Zugriff auf Dateien jedes dieser Typen im Allgemeinen zufällig erfolgt, können beide Dateitypen auf demselben Datenträger-Volume gespeichert werden. Es dürfen jedoch auf keinen Fall auf dem Laufwerk, auf dem sich die Transaktionsprotokolle befinden, EDB- und STM-Dateien gespeichert werden. Da es wichtig ist, Leistungsengpässe auf den Laufwerken mit Datenbankdateien zu vermeiden, wird außerdem empfohlen, dass Sie diese Dateien auf dedizierte Laufwerke für jede Speichergruppe platzieren.

  • Speicherort des SMTP-Verzeichnisses Die SMTP-Warteschlange speichert SMTP-Meldungen solange, bis Exchange sie in eine Datenbank (den Postfachspeicher oder den Informationsspeicher für Öffentliche Ordner) schreibt oder die Meldungen an einen anderen Server oder Connector sendet. Im Allgemeinen treten SMTP-Warteschlangen bei zufälligen, kleinen E/As auf. Exchange Server Analyzer zeigt eine Warnung an, wenn das SMTP-Verzeichnis sich auf einem Laufwerk befindet, das von den folgenden Elementen gemeinsam benutzt wird:

    • Jede andere Exchange-Datendatei

    • Das TEMP- oder TMP-Verzeichnis

    • Die Auslagerungsdatei

    • Das Systemlaufwerk

    Wenn im SMTP-Verzeichnis kein Datenträgerengpass besteht, können Sie diese Warnung getrost ignorieren. Wenn jedoch der Datenverkehr zu diesem Laufwerk hoch ist und es auf dem Laufwerk zu einem Leistungsengpass kommt, sollten Sie das SMTP-Verzeichnis auf ein eigenes Laufwerk verschieben oder die Kapazität des Laufwerks mit dem SMTP-Verzeichnis erhöhen.

  • Speicherort der Auslagerungsdatei Die Auslagerungsdatei dient als Erweiterung des physischen Speichers. In der Auslagerungsdatei speichert das System unbenutzte Seiten oder Seiten, die das System später brauchen wird. Die Auslagerungsdatei ist immer verwendet, und sogar von Servern, die eine ausreichende Menge an freiem Speicher besitzen. Diese dauerhafte Nutzung ist darauf zurückzuführen, dass das Betriebssystem versucht, nur notwendige Seiten zu speichern und ausreichend Speicherplatz für Operationen frei zu halten. Beispielsweise wird u. U. bei einem Drucktool, das nur beim Start verwendet wird, ein Teil seines Speichers auf einen Datenträger ausgelagert und niemals zurückgeholt, falls er nie wieder verwendet wird.

    Stellen Sie sicher, dass auf Servern, deren physischer Speicher stark ausgelastet wird, der Zugriff auf die Auslagerungsdatei so schnell wie möglich ist. Es wird empfohlen, eine zweite Auslagerungsdatei auf einem Laufwerk zu erstellen, dass für die Auslagerungsdatei dediziert ist.

Weitere Informationen

  • Weitere Informationen zur Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange finden Sie unter Behandeln von Leistungsproblemen bei Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen zu den bewährten Methoden für das Entwerfen von Speicherarchitekturen finden Sie unter Bewährte Methoden für mehrere Architekturen (http://go.microsoft.com/fwlink/?LinkId=72988).

  • Weitere Informationen zu Datenträgerbemessung, -wartezeiten und -E/A-Raten finden Sie unter Berechnung der Anforderungen an die Datenträger-E/A (http://go.microsoft.com/fwlink/?linkid=69747).


Der TCP/IP-Port des Exchange-Informationsspeichers wurde manuell überschrieben
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-03-21

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob der Port für die Schnittstelle des Exchange-Informationsspeichers manuell überschrieben wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Wenn Exchange Server Analyzer erkennt, dass der TCP/IP Port vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Dieser Wert wird in den meisten Fällen konfiguriert, um MAPI-Clients das Herstellen einer Verbindung mit einem Exchange-Server zu ermöglichen, der sich auf der anderen Seite einer Firewall befindet. Hierfür müssen mehrere Ports in einer Firewall geöffnet werden, damit Microsoft Office Outlook® 2003 oder Outlook 2007-Clients mithilfe von MAPI (in der Regel über das Internet) eine Verbindung mit einem Server mit Exchange herstellen können. Die ist eine unterstützte Konfiguration. Weitere Informationen zum Konfigurieren von MAPI-Clients zum Herstellen einer Verbindung mit Exchange über eine Firewall finden Sie im Microsoft Knowledge Base-Artikel 270836, "Statische Portzuordnungen in Exchange 2000 und Exchange 2003" (http://support.microsoft.com/default.aspx?scid=kb;de;270836). Wenn Sie dieses Szenario jedoch nicht verwenden, sollten Sie den Registrierungsschlüssel entfernen.

Für die Verwendung von Outlook im MAPI-Modus zum Herstellen einer Verbindung mit einem Server mit Exchange über das Internet wird der Einsatz der Funktionen von RPC-über-HTTP in Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 und Microsoft Windows® XP Professional empfohlen. Der MAPI-Modus wurde früher als „Firmenmodus" oder „Arbeitsgruppenmodus" bezeichnet.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So entfernen Sie den Registrierungsschlüssel für den TCP/IP-Port

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Löschen Sie den Registrierungswert TCP/IP Port.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst erneut.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 "Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

So stellen Sie RPC-über-HTTPS bereit

  1. Lesen Sie "Exchange Server 2003 RPC over HTTP Deployment Scenarios" unter http://go.microsoft.com/fwlink/?linkid=47577.

  2. Lesen Sie den Knowledge Base-Artikel 833401, „Konfigurieren von RPC-über-HTTP auf einem einzelnen Server in Exchange Server 2003"(http://support.microsoft.com/default.aspx?scid=kb;de;833401).

  3. Lesen Sie den Knowledge Base-Artikel 827330, "Behandlung von Problemen bei RPC-über-HTTP-Clientverbindungen in Office Outlook 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  4. Lesen Sie den Microsoft Support WebCast „Using Microsoft Exchange over the Internet (RPC/HTTP) with Microsoft Office Outlook 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.


Die TCP/IP-Anschlussnummer des Exchange-Informationsspeichers liegt unter 5000
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2006-01-11

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Einstellung für TCP/IP Port für den Exchange-Informationsspeicher zu ermitteln:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Wenn Exchange Server Analyzer feststellt, dass der Wert für TCP/IP Port auf einen Wert unter 5000 (Dezimalwert) festgelegt ist, wird eine Warnung angezeigt.

Wenn Sie die Einstellung für TCP/IP Port auf einen statischen Wert festlegen müssen, wird empfohlen, einen Wert zu wählen, der gleich oder größer als 5000 ist. Wird ein Wert festgelegt, der kleiner als 5000 ist, kann dies dazu führen, dass Exchange Server das Abhören dieses Ports beendet. Exchange Server verbleibt in diesem Zustand, bis ein Dienst erneut gestartet wird (der erneut zu startende Dienst ist von der Exchange-Komponente abhängig, die hartcodiert wurde).

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den Registrierungsschlüssel für den TCP/IP-Port fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Doppelklicken Sie auf den Schlüssel TCP/IP Port, und legen Sie im Feld Datenwerte eine ganze Zahl fest, die etwas größer als 5000 (Dezimalwert) ist.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit diese Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Weitere Informationen zu Porteinstellungen finden Sie im Knowledge Base-Artikel 270836, „Statische Anschlusszuordnungen in Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836).


Exchange-Transaktionsprotokolle werden in eine Nicht-NTFS-Partition geschrieben.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-02-27

Fehlermeldung

Einführung

Microsoft Exchange Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows Management Instrumentation) Win32_Directory ab, um den Wert für den Schlüssel FSName für den Dateipfad des Exchange-Transaktionsprotokolls zu ermitteln. Wenn Exchange Server Analyzer ermittelt, dass der Wert für den Schlüssel FSName nicht NTFS ist, wird ein Fehler angezeigt.

Das Speichern von Exchange-Datendateien auf einem Nicht-NTFS-Datenträger wird von Microsoft nicht unterstützt. Zu den Exchange-Datendateien gehören folgende Dateien:

  • EDB-Dateien

  • STM-Dateien

  • LOG-Dateien

  • DAT-Dateien

  • EML-Dateien

Wenn dieser Fehler auftritt, müssen Sie die Transaktionsprotokolle in einen Ordner auf einem NTFS-Laufwerk verschieben. Wenn das Laufwerk, auf dem das Transaktionsprotokollverzeichnis gespeichert ist, als FAT-Laufwerk formatiert ist, können Sie zum Konvertieren des Laufwerks in NTFS auch das Befehlszeilentool convert.exe verwenden.

So verschieben Sie die Transaktionsprotokolle auf Exchange 2000 Server oder Exchange Server 2003

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Administrative Gruppen, erweitern Sie Ihre administrative Gruppe, erweitern Sie Server, klicken Sie mit der rechten Maustaste auf Ihre Speichergruppe, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Allgemein unter Pfad des Transaktionsprotokolls auf Durchsuchen.

  4. Geben Sie den Pfad zum neuen Speicherort für die Protokolldateien ein, und klicken Sie dann auf OK.

  5. Klicken Sie auf OK.

So verschieben Sie in Exchange Server 2007 den Speicherort von Transaktionsprotokolldateien in einer Exchange-Speichergruppe

  1. Befolgen Sie die Anweisungen in der Exchange Server 2007-Hauptdokumentation unter "How to Set or Change the Location of Storage Group Log Files" (http://go.microsoft.com/fwlink/?LinkID=80702).

Wenn das Laufwerk, auf dem das Transaktionsprotokollverzeichnis gespeichert ist, als FAT-Laufwerk formatiert ist, können Sie alternativ zur obigen Vorgehensweise zum Konvertieren des Laufwerks in NTFS auch das Befehlszeilentool convert.exe verwenden. Weitere Informationen zum Konvertieren einer FAT-Partition in eine NTFS-Partition mit dem Befehlszeilentool convert.exe finden Sie im Microsoft Knowledge Base-Artikel 214579 „Konvertieren einer Partition in NTFS mit "Convert.exe"" unter (http://support.microsoft.com/kb/214579/de).


Exchange-Transaktionsprotokolle werden in einen komprimierten Ordner geschrieben.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-05

Microsoft Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Directory ab, um den Wert des Schlüssels Compressed für den Ordner zu bestimmen, der die Transaktionsprotokolle des Exchange-Informationsspeichers enthält. Wenn der Wert für Compressed für diesen Ordner auf True festgelegt ist, wird eine Fehlermeldung angezeigt.

Wenn eine Nachricht an Exchange übermittelt wird, wird sie zuerst in die Transaktionsprotokolle geschrieben, bevor sie an den Speicher übermittelt und weitergeleitet wird. Auf einem Exchange 2000 Server- oder Exchange Server 2003-Computer werden die Transaktionsprotokolle in den folgenden Standardspeicherort geschrieben:

<Laufwerk> :\Programme\Exchsrvr\mdbdata

Auf einem Computer mit Exchange Server 2007 werden die Transaktionsprotokolldateien in den folgenden Standardspeicherort geschrieben:

<Laufwerk> :\Programme\Microsoft\Exchange Server\Mailbox\<Name der Speichergruppe>

Das Speichern von Exchange-Datendateien auf einem NTFS-komprimierten Datenträger wird von Microsoft nicht unterstützt. Wenn Sie Ihre Exchange-Datendateien auf einem komprimierten Datenträger speichern, beeinträchtigt der zusätzliche Aufwand die Leistung von Exchange erheblich. Wenn die Informationsspeicher-Datenbank eine bestimmte Größe (etwa 4 GB) erreicht, kann sie möglicherweise nicht bereitgestellt werden oder kann fehlerhaft sein.

Zu den Exchange-Datendateien gehören folgende Dateien:

  • EDB-Dateien

  • STM-Dateien

  • LOG-Dateien

  • DAT-Dateien

  • EML-Dateien

  • CHK-Dateien

Dateien, die mit ESE (Extensible Storage Engine) verwaltet werden, können nicht auf einem komprimierten Laufwerk gespeichert werden. Die ESE hängt von der Sektorunabhängigkeit für protokollbasierte Wiederherstellung ab, und durch die Komprimierung von Dateien wird die Sektorunabhängigkeit ungültig gemacht. Die Komprimierung sollte für Datenträger deaktiviert werden, die als Host für ESE-Datenbanken oder für Write-Ahead-Logging verwendende Datenbanken dienen.

Vor Exchange 2000 Server Service Pack 3 war die Bereitstellung komprimierter Informationsspeicher-Datenbanken möglich. Allerdings können in allen Informationsspeicher-Datenbanken oder Informationsspeicher-Protokollen von Exchange 2000 Server, die mit NTFS-Komprimierung komprimiert wurden, Beschädigungen auftreten.

Unter Exchange 2000 Server Service Pack 3 werden komprimierte Informationsspeicher-Datenbankdateien mit einer Größe von 128 MB oder kleiner automatisch dekomprimiert. Wenn Datenbankdateien eine Größe von 128 MB überschreiten, kann die Datenbank nicht bereitgestellt werden, und in der Anwendungsprotokollierung werden Fehlermeldungen generiert. Unter Exchange 2000 Server Service Pack 3 können komprimierte Datenbanken mit einer Größe von mehr als 128 MB nicht bereitgestellt werden.

So deaktivieren Sie die Komprimierung für einen bestimmten Ordner

  1. Klicken Sie mit der rechten Maustaste auf den Ordner, für den Dateikomprimierung deaktiviert werden soll, und klicken Sie dann auf Eigenschaften.

  2. Klicken Sie auf der Registerkarte Allgemein auf Erweitert.

  3. Deaktivieren Sie im Dialogfeld Erweiterte Attribute das Kontrollkästchen Inhalt komprimieren, um Speicherplatz zu sparen, und klicken Sie dann auf OK.

So verschieben Sie die Transaktionsprotokolle auf Exchange 2000 Server oder Exchange Server 2003

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Administrative Gruppen, erweitern Sie Ihre administrative Gruppe, erweitern Sie Server, klicken Sie mit der rechten Maustaste auf Ihre Speichergruppe, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Allgemein unter Pfad des Transaktionsprotokolls auf Durchsuchen.

  4. Geben Sie den Pfad zum neuen Speicherort für die Protokolldateien ein, und klicken Sie dann auf OK.

  5. Klicken Sie auf OK.

So verschieben Sie in Exchange Server 2007 den Speicherort von Transaktionsprotokolldateien in einer Exchange-Speichergruppe

  1. Befolgen Sie die Anweisungen in der Exchange Server 2007-Hauptdokumentation unter "How to Set or Change the Location of Storage Group Log Files" (http://go.microsoft.com/fwlink/?LinkId=80702).

Weitere Informationen zum Verschieben von Protokolldateien unter Exchange Server 2003 finden Sie im Microsoft Knowledge Base-Artikel 821915 „So verschieben Sie Exchange-Datenbanken und -Protokolle in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915.

Weitere Informationen zum Verschieben von Protokolldateien unter Exchange Server 2000 finden Sie im Microsoft Knowledge Base-Artikel 239944 „How to Move the Transaction or System Logs to Another Location" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239944.


Exchange-Transaktionsprotokolle werden in einen verschlüsselten Ordner geschrieben
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-02-27

Microsoft Exchange Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows Management Instrumentation) Win32_Directory ab, um den Wert des Schlüssels Encrypted für den Ordner zu ermitteln, der die Transaktionsprotokolle des Informationsspeichers enthält. Wenn Exchange Analyzer feststellt, dass der Wert für Encrypted auf True festgelegt ist, wird ein Fehler angezeigt.

Wenn eine Nachricht an Exchange übermittelt wird, wird sie zuerst in die Transaktionsprotokolle geschrieben, bevor sie an den Speicher übermittelt und weitergeleitet wird. Auf einem Exchange 2000 Server- oder Exchange Server 2003-Computer werden die Transaktionsprotokolle in den folgenden Standardspeicherort geschrieben:

<Laufwerk> :\Programme\Exchsrvr\mdbdata

Auf einem Computer mit Exchange Server 2007 werden die Transaktionsprotokolldateien in den folgenden Standardspeicherort geschrieben:

<Laufwerk> :\Programme\Microsoft\Exchange Server\Mailbox\<Name der Speichergruppe>

Microsoft unterstützt nicht das Speichern von Exchange-Datendateien auf verschlüsselten Datenträgern in verschlüsselnden Dateisystemen (Encrypting File Systems, EFS). Wenn Sie Exchange-Datendateien auf einem verschlüsselten Datenträger speichern, wirkt sich der zusätzliche Overhead entscheidend auf die Exchange-Server-Leistung aus. Zu den Exchange-Datendateien gehören folgende Dateien:

  • EDB-Dateien

  • STM-Dateien

  • LOG-Dateien

  • DAT-Dateien

  • EML-Dateien

  • CHK-Dateien

Um die Sicherheit der Exchange-Datendateien zu gewährleisten, empfiehlt es sich, den unbefugten Zugriff auf den Exchange-Computer zu verhindern und Nachrichtendaten mithilfe des S/MIME-Nachrichtenformats zu verschlüsseln.

Um diesen Fehler zu beheben, müssen Sie entweder die Dateiverschlüsselung für den Ordner deaktivieren, auf dem die Transaktionsprotokolle geschrieben werden, oder die Transaktionsprotokolle in einen Ordner verschieben, für den die Verschlüsselung nicht aktiviert ist.

So deaktivieren Sie die Dateiverschlüsselung für einen bestimmten Ordner

  1. Klicken Sie mit der rechten Maustaste auf den Ordner, für den die Verschlüsselung deaktiviert werden soll, und klicken Sie dann auf Eigenschaften.

  2. Klicken Sie auf der Registerkarte Allgemein auf Erweitert.

  3. Deaktivieren Sie im Dialogfeld Erweiterte Attribute das Kontrollkästchen Inhalt verschlüsseln, um Daten zu schützen, und klicken Sie dann auf OK.

So verschieben Sie die Transaktionsprotokolle auf Exchange 2000 Server oder Exchange Server 2003

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Administrative Gruppen, erweitern Sie Ihre administrative Gruppe, erweitern Sie Server, klicken Sie mit der rechten Maustaste auf Ihre Speichergruppe, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Allgemein unter Pfad des Transaktionsprotokolls auf Durchsuchen.

  4. Geben Sie den Pfad zum neuen Speicherort für die Protokolldateien ein, und klicken Sie dann auf OK.

  5. Klicken Sie auf OK.

So verschieben Sie in Exchange Server 2007 den Speicherort von Transaktionsprotokolldateien in einer Exchange-Speichergruppe

  1. Befolgen Sie die Anweisungen in der Exchange Server 2007-Hauptdokumentation unter "How to Set or Change the Location of Storage Group Log Files" (http://go.microsoft.com/fwlink/?LinkID=80702).

Weitere Informationen über das Verschieben von Protokolldateien finden Sie im Microsoft Knowledge Base-Artikel 821915 „So verschieben Sie Exchange-Datenbanken und -Protokolle in Exchange Server 2003" unter http://support.microsoft.com/kb/821915/de.

Weitere Informationen über Exchange Server-Datendateien und EFS finden Sie im Microsoft Knowledge Base-Artikel 834638, "Informationen zum Speichern von Datendateien auf einem verschlüsselten Datenträger in Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638).

Informationen zum Sichern von Nachrichten in Microsoft Exchange Server 2003 finden Sie im Handbuch zur Nachrichtensicherheit in Exchange Server 2003 unter http://go.microsoft.com/fwlink/?linkid=47574.


Die erweiterten ESE-Leistungsindikatoren sind aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die erweiterten Leistungsindikatoren der Extensible Storage Engine (ESE) in der Bibliothek der Leistungsindikatoren des Exchange-Servers vorhanden sind:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ESE\Performance\Show Advanced Counters

Wenn Exchange Server Analyzer erkennt, dass der Datenwert des Registrierungsschlüssels Show Advanced Counters auf 1 festgelegt ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So deaktivieren Sie die erweiterten ESE-Leistungsindikatoren

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Löschen Sie unter dem Schlüssel HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ESE\Performance in der Registrierung den Wert Show Advanced Counters.

  3. Schließen Sie den Registrierungs-Editor.

  4. Starten Sie den Systemmonitor neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Die Leistungsindikatoren für den erweiterten Speicher sind aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungsschlüssel, um zu ermitteln, ob Mdbperfx.dll in der Exchange-Serverbibliothek der Leistungsindikatoren vorhanden ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\Performance

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert für die Bibliothek die Zeichenfolge „mdbperfx.dll" enthält, wird eine Meldung angezeigt, dass eine nicht dem Standard entsprechende Konfiguration gefunden wurde.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich.

Die DLL Mdbperf.dll enthält die Standard-Speicherleistungsindikatoren. Die DLL Mdbperfx.dll enthält die gleichen Standard-Speicherleistungsindikatoren und eine erweiterte Gruppe Speicherleistungsindikatoren.

Die Wertdaten für die Bibliothek schließen in der Standardeinstellung die DLL Mdbperf.dll ein, die DLL Mdbperfx.dll jedoch nicht. In der folgenden Tabelle werden die in der DLL Mdbperfx.dll enthaltenen erweiterten Speicherleistungsindikatoren aufgelistet.

Indikator | Ziel
FXGetBufferRopsCalled | Die Gesamtzahl der FXGetBuffer-Remoteprozeduraufruf-Operationen (RPC).
FXGetBufferRopsCalledPerSec | Die Anzahl der FXGetBuffer-RPC-Operationen pro Sekunde.
FXGetBufferRopsAcceptedPerSec | Die Anzahl der pro Sekunde angenommenen FXGetBuffer-RPC-Operationen.
FXGetBufferRopsDenied | Die Gesamtzahl der verweigerten FXGetBuffer-RPC-Operationen.
FXGetBufferRopsDeniedPerSec | Die Anzahl der pro Sekunde verweigerten FXGetBuffer-RPC-Operationen.
FXGetBufferCurrentCallerCount | Die Anzahl der gleichzeitigen FXGetBuffer-RPC-Operationen.
FXGetBufferCurrentUsersExecuting | Die Anzahl der ausgeführten gleichzeitigen FXGetBuffer-RPC-Operationen.
Als MIME gescannte Nachrichten | Die Gesamtanzahl der Nachrichten der obersten Ebene, die vom Virenscanner als MIME bearbeitet werden.
Als MIME/Sekunde gescannte Nachrichten | Die Rate, mit der Nachrichten der obersten Ebene vom Virenscanner als MIME bearbeitet werden.
Als MAPI gescannte Nachrichten | Die Gesamtanzahl der Nachrichten der obersten Ebene, die vom Virenscanner als MAPI behandelt werden.
Als MAPI/Sek gescannte Nachrichten | Die Rate, mit der Nachrichten der obersten Ebene vom Virenscanner als MAPI bearbeitet werden.
Gelesene Bytes | Die Gesamtzahl der vom Virenscanner gelesenen Bytes.
Geschriebene Bytes | Die Gesamtzahl der vom Virenscanner geschriebenen Bytes.
Warteschlangenlänge (Priorität: Niedrig) | Die aktuelle Anzahl ausstehender Anforderungen mit niedriger Priorität, die zum Virenscannen in die Warteschlange gestellt wurden.
Threads | Die aktuelle Anzahl von Threads in einem Threadpool, die zum Virenscannen verwendet werden. Diese Anzahl umfasst nicht die Zahl der zum Scannen im Hintergrund verwendeten Threads.
Durch MFT-Stempel erfüllte Kontrollen | Die Anzahl der Überprüfungen mit einem Virenscanner, die durch einen Stempel in der Nachrichtenordnertabelle (MFT) erfüllt wurden.
Durch MFT-Stempel erfüllte Kontrollen/Sek | Die Rate, mit der Überprüfungen mit einem Virenscanner durch einen Stempel in der Nachrichtenordnertabelle (MFT) erfüllt wurden.
Durch einen Instanzstempel erfüllte Kontrollen | Die Anzahl der Überprüfungen mit einem Virenscanner, die durch einen Instanzstempel erfüllt wurden.
Durch einen Instanzstempel erfüllte Kontrollen/Sek | Die Anzahl der Überprüfungen mit einem Virenscanner, die durch einen Masterinstanzstempel erfüllt wurden.
Durch einen Masterinstanzstempel erfüllte Kontrollen/Sek | Die Rate, mit der Überprüfungen mit einem Virenscanner durch einen Masterinstanzstempel erfüllt wurden.
Nicht erfüllte Kontrollen | Die Anzahl der Überprüfungen mit einem Virenscanner, die nicht durch einen Stempel erfüllt wurden.
Nicht erfüllte Kontrollen/Sek | Die Rate, mit der Überprüfungen mit einem Virenscanner nicht durch einen Stempel erfüllt wurden.
Blockierte Kontrollen | Die Anzahl der durch das Warten auf den Abschluss des Virenscanvorgangs blockierten Verarbeitungen.
Blockierte Kontrollen/Sek | Die Rate, mit der Verarbeitungen durch das Warten auf den Abschluss des Virenscanvorgangs blockiert werden.
Timeouts | Die Anzahl der Zeitüberschreitungen von Operationen, die auf den Abschluss des Virenscanvorgangs warten.
Timeouts/Sek | Die Rate der Zeitüberschreitungen von Operationen, die auf den Abschluss des Virenscanvorgangs warten.
Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So aktivieren Sie nur die Standard-Speicherleistungsindikatoren

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Suchen Sie den Bibliothekswert unter dem folgenden Registrierungsschlüssel:

    HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\Performance

  3. Klicken Sie im Menü Bearbeiten auf Ändern.

  4. Ändern Sie im Feld Wert den Wert von c:\Programme\Exchsrvr\bin\mdbperfx.dll in c:\Programme\exchsrvr\bin\mdbperf.dll.

  5. Klicken Sie auf OK, und schließen Sie den Registrierungs-Editor.

  6. Starten Sie den Systemmonitor neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Sammeln von Leistungsdaten über den Exchange-Speicher finden Sie im Knowledge Base-Artikel 821912, "How to Collect Diagnostic Data to Help Troubleshoot Information Store Issues" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821912).


Der Parameter „FXGetBuffer Backoff Constant" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungsschlüssel, um festzustellen, ob der Wert FXGetBuffer Backoff Constant erstellt wurde:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Wenn Exchange Server Analyzer erkennt, dass der Wert FXGetBuffer Backoff Constant unter dem Registrierungsschlüssel ParametersSystem erstellt wurde, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Anhand des Werts FXGetBuffer Backoff Constant können Sie die Anzahl der Microsoft Office Outlook® 2003-Clients steuern, die gleichzeitig eine Synchronisierung mit einem Exchange Server 2003-Server ausführen können. Legen Sie den Wert FXGetBuffer Backoff Constant fest, um die Wartezeit von Outlook-Clients zu konfigurieren, bevor ein erneuter Synchronisierungsversuch ausgeführt wird. Der Standardwert für FXGetBuffer Backoff Constant beträgt 500 Millisekunden.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich. Sie können allerdings den Registrierungsschlüssel FXGetBuffer Backoff Constant löschen, wenn Sie die Standardkonfiguration wiederherstellen möchten.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Löschen Sie den Wert FXGetBuffer Backoff Constant.

  4. Schließen Sie den Registrierungs-Editor.

Der Microsoft Exchange-Informationsspeicherdienst erkennt innerhalb weniger Minuten die Änderungen. Sie müssen den Computer nicht neu starten.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Festlegen von Registrierungsschlüsseln zum Steuern der Anzahl der Outlook-Clients, die eine Synchronisierung mit Exchange Server 2003 ausführen können, finden Sie im Knowledge Base-Artikel 818484, „Registry Values and Counters That You Can Use to Configure and Monitor Outlook Client Synchronization" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484).


Der Parameter „FXGetBuffer Retry Count" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungsschlüssel, um festzustellen, ob der Wert FXGetBuffer Retry Count erstellt wurde:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Wenn Exchange Server Analyzer erkennt, dass der Wert FXGetBuffer Retry Count unter dem Registrierungsschlüssel ParametersSystem erstellt wurde, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Anhand des Werts FXGetBuffer Retry Count können Sie die Anzahl der Microsoft Office Outlook® 2003-Clients steuern, die gleichzeitig eine Synchronisierung mit einem Exchange Server 2003-Server ausführen können. Legen Sie den Wert FXGetBuffer Retry Count fest, um die Anzahl der Synchronisierungsversuche zu konfigurieren, die ein Outlook-Client zum Erlangen des Zugriffs ausführen kann. Der Standardwert ist 10.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich. Sie können allerdings den Registrierungsschlüssel FXGetBuffer Retry Count löschen, wenn Sie die Standardkonfiguration wiederherstellen möchten.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Löschen Sie den Wert FXGetBuffer Retry Count.

  4. Schließen Sie den Registrierungs-Editor.

Der Microsoft Exchange-Informationsspeicherdienst erkennt innerhalb weniger Minuten die Änderungen. Sie müssen den Computer nicht neu starten.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Festlegen von Registrierungsschlüsseln zum Steuern der Anzahl der Outlook-Clients, die eine Synchronisierung mit Exchange Server 2003 ausführen können, finden Sie im Knowledge Base-Artikel 818484, „Registry Values and Counters That You Can Use to Configure and Monitor Outlook Client Synchronization" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484).


Der Registrierungsparameter „Ignore Bad Oof Rule" wurde festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer liest die Registrierung des Exchange Server-Computers, um zu überprüfen, ob der Registrierungseintrag Ignore Bad Oof Rule vorhanden ist. Dieser Registrierungswert befindet sich unter:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

Wenn Exchange Server Analyzer feststellt, dass der Registrierungswert Ignore Bad Oof Rule vorhanden und mit dem Wert 1 oder höher konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Bei dem Registrierungseintrag Ignore Bad Oof Rule handelt es sich um eine Konfigurationseinstellung für Exchange 2000 Server, Exchange Server 2003 und Exchange Server 2007, die speziell für die Verwendung mit dem Hotfix konzipiert ist, der im Microsoft Knowledge Base-Artikel 828875 „You cannot move an Exchange mailbox after you use the Exmerge.exe utility" (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=828875) beschrieben wird.

Wenn Nachrichten und andere Objekte von einem Postfach in einem bestimmten Postfachspeicher in ein Postfach in einem anderen Postfachspeicher verschoben werden und dazu das Programm Microsoft Exchange Mailbox Merge (Exmerge.exe) verwendet wird, ist es möglich, dass ein anschließender Versuch zum Verschieben des zweiten Postfachs möglicherweise nicht ausgeführt werden kann. Die Ursache hierfür kann eine ungültige Abwesenheitsnachrichten-Regel in diesem Postfach sein. Mithilfe des nachfolgend beschriebenen Verfahrens kann die Standardkonfiguration nach Wunsch wiederhergestellt werden.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. Suchen Sie im rechten Bereich den Wert Ignore Bad Oof Rule, und löschen Sie diesen.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Der Registrierungsparameter „Ignore Zombie Users" wurde festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer überprüft die Registrierung des Exchange Server-Computers, um festzustellen, ob der Registrierungseintrag Ignore Zombie users vorhanden ist. Dieser Registrierungswert befindet sich unter:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Wenn Exchange Server Analyzer feststellt, dass der Registrierungswert Ignore Zombie users vorhanden und mit dem Wert 1 oder höher konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In einer Exchange Server-Organisation im gemischtem Modus, die Exchange Server 5.5 und Exchange 2000 Server enthält, oder in einer zuvor gemischten Umgebung können unter den folgenden Bedingungen Probleme auftreten:

  • Sie aktualisieren die Zugriffssteuerungsliste (Access Control List, ACL) der Postfächer und Öffentlichen Ordner von Exchange Server 5.5 auf Exchange 2000 Server.

  • Die ACL enthält Benutzerkonten, die nicht im Active Directory®-Verzeichnisdienst dargestellt sind.

Diese nicht verwendeten Einträge in der Zugriffssteuerungsliste (Access Control Entries, ACEs) werden auch als Zombie User bezeichnet. Mit dem Post-Service Pack 3 Rollup für Exchange 2000 Server von März 2003 hat sich das Standardverhalten für die Verarbeitung von Zombie Usern geändert. Sie können dieses Verhalten mit dem Registrierungsschlüssel Ignore Zombie users steuern.

Der Registrierungswert Ignore Zombie users kann auf Servern verwendet werden, bei denen Exchange 2000 Server Service Pack 3 oder eine neuere Version installiert ist. Sie sollten diesen Registrierungseintrag sorgfältig und nur dann verwenden, wenn Sie sicher sind, dass die Zombie User nicht das Ergebnis von Problemen bei der ADC-Replikation (z. B. der Wartezeit) sind. Durch diesen Registrierungswert ignoriert Exchange Server die Zombie User und entfernt sie aus der ACL der Postfächer oder der Öffentlichen Ordner. Wenn ein Benutzer gültig ist, jedoch zum Zeitpunkt der Aktualisierung der ACL nicht im Active Directory vorhanden war, wird der Benutzer entfernt, und Sie müssen ihn später manuell jeder ACL hinzufügen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Suchen Sie im rechten Bereich den Wert Ignore Zombie users, und löschen Sie ihn.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Weitere Informationen zum Registrierungsschlüssel Ignore Zombie Users finden Sie in den folgenden Knowledge Base-Artikeln:

  • 812963, „Using the Ignore Zombie Users Registry Key" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812963)

  • 324323, „XADM: Skipping User Accounts That Are Not Represented in Active Directory During Access Control List Conversion" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323)


Die IMAIL-Ausnahmebehandlung wurde manuell deaktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-17

Microsoft® Exchange Server Analyzer überprüft den folgenden Registrierungseintrag, um die Einstellung für den Registrierungswert ExceptionHandling zu ermitteln:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Wenn Exchange Server Analyzer feststellt, dass der Registrierungswert ExceptionHandling mit dem Wert 0 konfiguriert ist, wird eine Warnung angezeigt.

In Exchange Server ist die IMAIL-Ausnahmebehandlung in der Standardeinstellung aktiviert und kann nicht über die Benutzeroberfläche deaktiviert werden. Sie kann jedoch mithilfe der Registrierung deaktiviert werden.

Microsoft empfiehlt, die IMAIL-Ausnahmebehandlung nur dann zu deaktivieren, wenn Sie gerade aktiv ein Problem beheben. Sie sollten die IMAIL-Ausnahmebehandlung beispielsweise deaktivieren, wenn benutzerdefinierte Anwendungen Ereignisse auf der Grundlage ungültiger MIME-Inhalte (Multipurpose Internet Mail Extensions) oder MAPI-Inhalte auslösen. Microsoft empfiehlt, die IMAIL-Ausnahmebehandlung nur auf Empfehlung bzw. nach Anweisung von Mitarbeitern des technischen Supports von Microsoft zu deaktivieren.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent.

  3. Doppelklicken Sie auf ExceptionHandling:

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zum Registrierungswert ExceptionHandling finden Sie im Knowledge Base-Artikel 832174, „There is no option to turn off IMAIL exception handling in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832174).


Der Informationsspeicherdienst wurde für die Zusammenarbeit mit dem Desktop konfiguriert
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_Service ab, um den Wert der Eigenschaft DesktopInteract für den Microsoft Exchange-Informationsspeicherdienst (MSExchangeIS) zu bestimmen. Wenn Exchange Server Analyzer feststellt, dass der Microsoft Exchange-Informationsspeicherdienst für die Zusammenarbeit mit dem Desktop konfiguriert ist, wird von dem Tool ein Fehler angezeigt.

Diese Konfiguration sollte nur unter Anleitung des Technischen Supports von Microsoft verwendet werden. Wenn Sie vom technischen Support von Microsoft nicht angewiesen wurden, den Microsoft Exchange-Informationsspeicherdienst in dieser Konfiguration auszuführen, wird empfohlen, die Eigenschaften des Microsoft Exchange-Informationsspeicherdiensts neu zu konfigurieren, sodass keine Zusammenarbeit mit dem Desktop möglich ist.

So konfigurieren Sie das Konto für den Exchange-Informationsspeicherdienst

  1. Öffnen Sie das MMC-Snap-In Dienste.

  2. Suchen Sie den Dienst Microsoft Exchange-Informationsspeicher, und beenden Sie ihn.

  3. Doppelklicken Sie auf den Dienst Microsoft Exchange-Informationsspeicher.

  4. Wählen Sie auf der Seite Eigenschaften von Microsoft Exchange-Informationsspeicher auf der Registerkarte Anmelden unter Anmelden als die Option Lokales Systemkonto aus.

  5. Deaktivieren Sie das Kontrollkästchen Datenaustausch zwischen Dienst und Desktop zulassen, und klicken Sie dann auf Übernehmen.

  6. Klicken Sie unter Dienststatus auf Start, und klicken Sie dann auf OK.

  7. Schließen Sie das Snap-In Dienste.

Weitere Informationen zur richtigen Konfiguration von Exchange-Diensten finden Sie im Microsoft Knowledge Base-Artikel 239762 „Exchange Services Run Under LocalSystem" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762.


Erhöhen Sie die maximale Datenbankgröße für den Postfachspeicher
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation -Windows®-Verwaltungsinstrumentation) CIM_DataFile ab, um die folgenden Informationen zu bestimmen.

  • Der vollständige Pfad für die Exchange-Datenbankdateien.

  • Die aktuelle Größe des Postfachspeichers.

Exchange Server Analyzer fragt außerdem die WMI-Klasse Win32_OperatingSystem ab, um zusätzliche Informationen zu ermitteln.

  • Die Version des Windows-Betriebssystems, das auf dem Exchange Server ausgeführt wird.

  • Die installierte Version von Exchange Server.

  • Die installierte Edition von Exchange Server.

  • Das installierte Service Pack für Exchange Server.

Schließlich liest Exchange Server Analyzer den folgenden Registrierungseintrag, um zu bestimmen, ob der Wert Database Size in Gb festgelegt wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Auf dem Server wird Exchange Server 2003 ausgeführt.

  • Der Dienst arbeitet unter Service Pack 2 von Exchange Server 2003.

  • Die Exchange Server-Datenbank ist größer als 16 Gigabyte (GB).

  • Der Registrierungswert Database Size in Gb wurde nicht festgelegt.

Dieser Fehler zeigt an, dass die erkannte Exchange-Datenbank fast ihre Maximalgröße erreicht hat. Services Pack 2 für Exchange Server 2003 erhöht die Datenbankspeichergrenzen von 16 GB auf 75 GB. Jedoch müssen Sie, um die neuen Höchstwerte zu verwenden, den Registrierungswert Database Size in Gb auf dem Exchange Server manuell hinzufügen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So beheben Sie dieses Problem durch Hinzufügen des Registrierungswertes „Database Size in Gb"

  1. Öffnen Sie auf dem Computer, auf dem Exchange Server ausgeführt wird, einen Registrierungs-Editor, z. B. Regedit.exe oder Regedt32.exe.

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Private-<Postfachspeicher-GUID>

  3. Klicken Sie mit der rechten Maustaste auf MailboxStoreGUID, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  4. Geben Sie für den neuen Wertnamen Database Size Limit in Gb ein.

  5. Doppelklicken Sie auf Database Size Limit in Gb. Geben Sie unter Wert einen entsprechenden Wert für die maximale Datenbankgröße in GB ein. Klicken Sie auf OK.

  6. Klicken Sie mit der rechten Maustaste auf MailboxStoreGUID, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  7. Geben Sie für den neuen WertnamenDatabase Size Buffer in Percentage ein.

  8. Doppelklicken Sie auf Database Size Buffer in Percentage. Geben Sie unter Wert einen Wert zwischen 1 und 100 ein. Mit diesem Wert geben Sie an, ab welchem Zeitpunkt Ereignisse protokolliert werden sollen, um Sie zu warnen, dass der Wert für die maximale Größe der Datenbank bald erreicht wird. Klicken Sie auf OK.

    Hinweis:
    Beim Standardwert 10 werden Warnereignisse protokolliert, sobald nur noch 10 % der Kapazität verfügbar sind, bevor die maximale Größe für die Datenbank erreicht wird.

  9. Klicken Sie mit der rechten Maustaste auf MailboxStoreGUID, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  10. Geben Sie für den neuen Namen Database Size Check Start Time in Hours From Midnight ein.

  11. Doppelklicken Sie auf Database Size Check Start Time in Hours From Midnight. Geben Sie unter Wert einen Wert zwischen 0 und 23 ein, um anzugeben, wann die Datenbankgröße von Exchange kontrolliert werden soll. Klicken Sie auf OK.

    Hinweis:
    Beim Standardwert 5 wird die Datenbankgröße 5 Stunden nach 0:00 Uhr (05:00:00 Uhr) von Exchange Server kontrolliert.

  12. Schließen Sie den Registrierungs-Editor.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zum Konfigurieren und Verwalten der Größenbeschränkungen von Exchange Server-Datenbanken finden unter "Database Size Limit Configuration and Management" (http://go.microsoft.com/fwlink/?LinkId=57029).

Informationen zum Erreichen der maximalen Datenbankgröße in Exchange Server 2003 Standard Edition und Exchange 2000 Server Standard Edition finden Sie im Knowledge Base-Artikel 828070, „Exchange Server-Postfachspeicher wird nicht bereitgestellt, wenn die Postfachspeicher-Datenbank das 16-GB-Limit erreicht" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070.

Weitere Informationen zu SP2 für Exchange Server 2003 finden Sie auf der Website zu Exchange Server 2003 Service Pack 2 unter „Why Try Service Pack 2 for Exchange Server 2003?". (http://go.microsoft.com/fwlink/?LinkId=41848.


Erhöhen der maximalen Datenbankgröße für den Informationsspeicher für Öffentliche Ordner
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation -Windows®-Verwaltungsinstrumentation) CIM_DataFile ab, um die folgenden Informationen zu bestimmen.

  • Der vollständige Pfad für die Exchange Server-Datenbankdateien.

  • Die aktuelle Größe des Speichers für Öffentliche Ordner.

Exchange Server Analyzer fragt außerdem die WMI-Klasse Win32_OperatingSystem ab, um zusätzliche Informationen zu ermitteln.

  • Die Version des Windows-Betriebssystems, das auf dem Exchange Server ausgeführt wird.

  • Die installierte Version von Exchange Server.

  • Die installierte Edition von Exchange Server.

  • Das installierte Service Pack für Exchange Server.

Schließlich liest Exchange Server Analyzer den folgenden Registrierungseintrag, um zu bestimmen, ob der Wert Database Size in Gb festgelegt wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>

Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Auf dem Server wird Exchange Server 2003 ausgeführt.

  • Der Dienst arbeitet unter Service Pack 2 von Exchange Server 2003.

  • Die Exchange-Datenbank ist größer als 16 Gigabyte (GB).

  • Der Registrierungswert Database Size in Gb wurde nicht festgelegt.

Dieser Fehler zeigt an, dass die erkannte Exchange Server-Datenbank fast ihre Maximalgröße erreicht hat. Services Pack 2 für Exchange Server 2003 erhöht die Datenbankspeichergrenzen von 16 GB auf 75 GB. Jedoch müssen Sie, um die neuen Höchstwerte zu verwenden, den Registrierungswert Database Size in Gb auf dem Exchange Server manuell hinzufügen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So beheben Sie dieses Problem durch Hinzufügen des Registrierungswertes „Database Size in Gb"

  1. Öffnen Sie auf dem Computer, auf dem Exchange Server ausgeführt wird, einen Registrierungs-Editor, z. B. Regedit.exe oder Regedt32.exe.

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des Öffentlichen Ordnerspeichers>

  3. Klicken Sie mit der rechten Maustaste auf PublicStoreGUID, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  4. Geben Sie für den neuen Wertnamen Database Size Limit in Gb ein.

  5. Doppelklicken Sie auf Database Size Limit in Gb. Geben Sie unter Wert einen entsprechenden Wert für die maximale Datenbankgröße in GB ein. Klicken Sie auf OK.

  6. Klicken Sie mit der rechten Maustaste auf PublicStoreGUID, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  7. Geben Sie für den neuen WertnamenDatabase Size Buffer in Percentage ein.

  8. Doppelklicken Sie auf Database Size Buffer in Percentage. Geben Sie unter Wert einen Wert zwischen 1 und 100 ein. Mit diesem Wert geben Sie an, ab welchem Zeitpunkt Ereignisse protokolliert werden sollen, um Sie zu warnen, dass der Wert für die maximale Größe der Datenbank bald erreicht wird. Klicken Sie auf OK.

    Hinweis:
    Beim Standardwert 10 werden Warnereignisse protokolliert, sobald nur noch 10 % der Kapazität verfügbar sind, bevor die maximale Größe für die Datenbank erreicht wird.

  9. Klicken Sie mit der rechten Maustaste auf PublicStoreGUID, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  10. Geben Sie für den neuen Namen Database Size Check Start Time in Hours From Midnight ein.

  11. Doppelklicken Sie auf Database Size Check Start Time in Hours From Midnight. Geben Sie unter Wert einen Wert zwischen 0 und 23 ein, um anzugeben, wann die Datenbankgröße von Exchange kontrolliert werden soll. Klicken Sie auf OK.

    Hinweis:
    Beim Standardwert 5 wird die Datenbankgröße 5 Stunden nach 0:00 Uhr (05:00:00 Uhr) von Exchange Server kontrolliert.

  12. Schließen Sie den Registrierungs-Editor.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zum Konfigurieren und Verwalten der Größenbeschränkungen von Exchange-Datenbanken finden unter "Database Size Limit Configuration and Management" (http://go.microsoft.com/fwlink/?LinkId=57029).

Informationen zum Erreichen der maximalen Datenbankgröße in Exchange Server 2003 Standard Edition und Exchange 2000 Server Standard Edition finden Sie im Knowledge Base-Artikel 828070, „Exchange Server-Postfachspeicher wird nicht bereitgestellt, wenn die Postfachspeicher-Datenbank das 16-GB-Limit erreicht" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070.

Weitere Informationen zu SP2 für Exchange Server 2003 finden Sie auf der Website zu Exchange Server 2003 Service Pack 2 unter „Why Try Service Pack 2 for Exchange Server 2003?". (http://go.microsoft.com/fwlink/?LinkId=41848.


Erhöhen der Protokollpuffereinstellung für das Transaktionsprotokoll
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer hat festgestellt, dass die Anzahl der Protokollpuffer auf Ihrem Server zu niedrig ist. Das Tool hat erkannt, dass der Wert für "Database (Information Store Instance)\Log Record Stalls/sec" für Ihren Server größer als 10 Verzögerungen pro Sekunde ist. Ein Wert von mehr als 10 weist darauf hin, dass zurzeit ein Sicherungsvorgang in das Transaktionsprotokoll schreibt. Diese Situation kann eintreten, weil das Transaktionsprotokolllaufwerk "außerhalb der Durchsatzkapazität" liegt oder weil die Protokollpuffer auf einen zu niedrigen Wert festgelegt sind.

E/A-Vorgänge beim Schreiben des Protokolls sind sequentiell und werden in einem Thread durchgeführt. Deshalb ist die Wartezeit für Protokoll-E/A oftmals ein Engpass im System. Protokoll-E/As werden zuerst in die Protokollpuffer geschrieben. Danach wird der Puffer durch entweder nicht verzögerte Übergabe (non-lazy commit) oder Kapazitätsübergabe (capacity commit) gelöscht. Non-lazy commit heißt, dass der Protokollpuffer sofort auf den Datenträger geschrieben wird. Capacity commit heißt, dass der Protokollpuffer erst auf den Datenträger geschrieben wird, wenn der Puffer voll ist.

Durch das Erhöhen der Protokollpuffergröße verringert sich die Häufigkeit von Kapazitätsleerungen, und die Größe des geschriebenen Protokolls wird erhöht, woraus wiederum resultiert, dass die Gesamtwartezeit beim Schreiben des Protokolls sinkt. Die Verringerung der Wartezeit bei E/A-Schreibvorgängen ist eine wirkungsvolle Methode zur Verbesserung der Leistung/Skalierbarkeit der Exchange-Bereitstellung.

Allgemein empfohlen wird, die Puffergröße auf den Maximalwert von "9.000" für Exchange Server 2003 und auf "512" für Exchange 2000 Server zu erhöhen.

Achtung:
Wenn Sie die ADSI-Bearbeitung, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute von Active Directory-Objekten nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So beheben Sie diese Warnmeldung

  1. Starten Sie die ADSI-Bearbeitung.

  2. Doppelklicken Sie auf den Container Konfiguration, erweitern Sie CN=Services, erweitern Sie CN=Microsoft Exchange, und erweitern Sie dann CN=ExchangeOrganizationName.

  3. Erweitern Sie CN=Administrative Groups, erweitern Sie CN=AdministrativeGroupName, und erweitern Sie dann CN=Servers.

  4. Erweitern Sie CN=ExchangeServerName, erweitern Sie CN=InformationStore, klicken Sie mit der rechten Maustaste auf CN=Storage Group Name, und klicken Sie anschließend auf Eigenschaften.

  5. Klicken Sie im Feld Anzuzeigende Eigenschaft auswählen auf msExchESEParamLogBuffers.

  6. Geben Sie im Feld zum Bearbeiten von Attributen den für Ihre Version von Exchange geeigneten Wert für msExchESEParamLogBuffers ein, und klicken Sie dann auf Festlegen.

    Hinweis:
    Legen Sie diesen Wert für Computer mit Exchange 2000 Server, Exchange 2000 Server Service Pack 1 (SP1), Exchange 2000 Server SP2 oder Exchange 2000 SP3 auf "512" fest. Legen Sie diesen Wert für Computer mit der Originalversion von Exchange Server 2003 oder Exchange Server 2003 SP1 auf "9.000" fest.

  7. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.

Weitere Informationen

  • Weitere Informationen zur Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen zum Arbeiten mit Protokollpufferung finden Sie im Microsoft Knowledge Base-Artikel mit Informationen dazu, dass zu niedrig festgelegte ESE-Protokollpuffer dazu führen können, dass der Microsoft Exchange-Informationsspeicherdienst nicht mehr reagiert (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328466).


„Initial Memory Percentage" wurde festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-05

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Wert Initial Memory Percentage festgelegt wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Wenn Exchange Server Analyzer feststellt, dass der Wert für Initial Memory Percentage vorhanden und mit einem Wert größer als 0 konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Die Registrierungseinstellung Initial Memory Percentage wurde als Methode zum Feinabstimmen des anfänglich zugewiesenen Arbeitsspeichers für den Exchange-Informationsspeicher auf 10 Prozent des auf dem Exchange-Server vorhandenen physischen Gesamtspeichers eingeführt. Wenn Sie - ausgehend von diesem Anfangswert - die Speicherzuweisung schrittweise erhöhen, tritt eine Fragmentierung des virtuellen Speichers seltener auf. Dieser Registrierungswert sollte nicht beliebig festgelegt werden und darf nur auf Empfehlung und nach Anweisung durch den technischen Support von Microsoft verwendet werden.

Exchange Server-Versionen ab Exchange Server 2003 bieten eine Unterstützung für spezielle Startparameter unter Microsoft Windows® 2000 Advanced Server und Windows Server™ 2003, mit deren Hilfe die Fragmentierung des virtuellen Speichers reduziert werden kann. Darüber hinaus wurden zusätzliche Änderungen vorgenommen, die die Fragmentierung des virtuellen Speichers in Exchange Server-Clustern verhindern sollen. Aus diesem Grund wird der Registrierungswert Initial Memory Percentage in Exchange Server-Versionen ab Exchange Server 2003 nicht mehr benötigt.

Der Registrierungswert Initial Memory Percentage kann nur auf Computern verwendet werden, auf denen Exchange 2000 Server ausgeführt wird. Wenn dieser Wert vorhanden ist, wird er von Exchange Server 2003 und Exchange Server 2007 ignoriert und ist unwirksam. Es wird daher empfohlen, diesen Registrierungseintrag vor dem Aktualisieren dieses Exchange-Servers von Exchange 2000 Server auf Exchange Server 2003 zu entfernen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So entfernen Sie die Registrierungseinstellung „Initial Memory Percentage"

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Löschen Sie im rechten Bereich den Wert Initial Memory Percentage.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.
  • Weitere Informationen zu bekannten Problemen bei der Verwendung dieses Registrierungswerts finden Sie im Microsoft Knowledge Base-Artikel 810883, „"Initial Memory Percentage" Registry Value Has No Effect" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810883).

  • Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://support.microsoft.com/kb/256986/de).


Registrierungseintrag „Initial Reserve Size KB" wurde festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2006-04-27

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Registrierungseintrag Initial Reserve Size KB vorhanden ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

Wenn Microsoft Exchange Server Analyzer erkennt, dass der Registrierungswert Initial Reserve Size KB vorhanden und mit einem Wert größer 0 konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Registrierungswert Initial Reserve Size KB wird verwendet, um zusätzlichen Heapspeicher freizugeben. Der Wert wird in Kilobyte (KB) angegeben. Der Standardwert für die meisten Computer mit Exchange Server beträgt 655.360 KB, was 640 MB entspricht. Sie können diesen Wert verringern, um die Größe des verfügbaren Speichers zu erhöhen und die Fragmentierung des virtuellen Speichers zu reduzieren. Der Wert sollte nur auf Anraten eines Produktsupportspezialisten des technischen Supports von Microsoft festgelegt werden. Diese Meldung dient nur zu Informationszwecken. Wenn der Registrierungswert auf Anraten eines Produktsupportspezialisten des technischen Supports von Microsoft hinzugefügt wurde, müssen keine Korrekturmaßnahmen durchgeführt werden.

Wenn Sie der Meinung sind, dass dieser Eintrag falsch festgelegt wurde, können Sie ihn entfernen und die Standardkonfiguration wiederherstellen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Einstellungen für die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

  3. Löschen Sie den Wert mit der Bezeichnung Initial Reserve Size KB.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie dann den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Problembehandlung bei der Fragmentierung des virtuellen Speichers finden Sie im Knowledge Base-Artikel „SO WIRD'S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).


„LegacyExchangeDN" für diese Exchange-Datenbank entspricht nicht dem Exchange-Server
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs legacyExchangeDN für alle Postfachspeicher-Datenbanken auf einem Exchange Server-Computer zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs legacyExchangeDN in einem beliebigen Postfachspeicher nicht dem ExchangeServer-Computer entspricht, auf dem sich der Postfachspeicher befindet, wird ein Fehler angezeigt.

Die Attribute für legacyExchangeDN können beispielsweise nicht übereinstimmen, wenn ein Administrator Änderungen an Active Directory vorgenommen hat, um eine Datenbank nach einem Datenverlust wiederherzustellen. Diesen Fehler beheben Sie, indem Sie das Attribut legacyExchangeDN mithilfe eines Active Directory-Editors (z. B: dem LDP-Tool ldp.exe oder der ADSI-Bearbeitung (Active Directory Service Interfaces)) ändern.

Um sicherzustellen, dass das Attribut legacyExchangeDN richtig ist, überprüfen Sie das Attribut legacyExchangeDN des Servers, auf dem die Datenbank gespeichert ist. Da es sich bei der Datenbank um ein untergeordnetes Objekt des Servers handelt, stimmt das Attribut legacyExchangeDN bei Datenbank und Server überein.

Überprüfen Sie auch andere Datenbanken auf diesem Exchange-Server, bei denen dieser Fehler nicht aufgetreten ist, da sie über das gleiche Attribut legacyExchangeDN verfügen. Beachten Sie, dass es auch einige andere Systemobjekte mit diesem Attribut gibt. Bei einem Namenskonflikt des Attributs legacyExchangeDN in einer Datenbank ist es wahrscheinlich, dass für dieses Attribut ebenfalls bei verschiedenen anderen Systemobjekten Namenskonflikte auftreten. Wenn Sie LDP oder das ADSI-Bearbeitungs-Snap-In verwenden, um den Wert legacyExchangeDN zu korrigieren, müssen Sie diese Änderung auch an allen anderen Systemobjekten vornehmen.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In, das LDP-Tool oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, von Exchange Server 2003 bzw. Exchange Server 2007 oder beider Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So beheben Sie diesen Fehler

  1. Öffnen Sie einen Active Directory-Editor, z. B. die ADSI-Bearbeitung.

  2. Erweitern Sie Configuration[Domänenname], erweitern Sie CN=Configuration,DC=Domänenname,DC=Domänensuffix.

  3. Erweitern Sie CN=Services, und erweitern Sie dann CN=Microsoft Exchange.

  4. Erweitern Sie CN=Organisationsname, erweitern Sie CN=Administrative Groups, und erweitern Sie dann CN=Administratorengruppenname.

  5. Erweitern Sie CN=Servers, erweitern Sie CN=Servername, und erweitern Sie dann CN=InformationStore.

  6. Wählen Sie CN=Speichergruppenname aus, klicken Sie im rechten Bereich mit der rechten Maustaste auf den Postfachspeicher mit dem ungültigen Attribut legacyExchangeDN, und klicken Sie dann auf Eigenschaften.

  7. Führen Sie einen Bildlauf nach unten durch, um legacyExchangeDN zu finden, markieren Sie den Eintrag, und klicken Sie auf Bearbeiten.

  8. Geben Sie im Feld Wert den korrekten Wert für legacyExchangeDN ein.

  9. Schließen Sie den Active Directory-Editor, und starten Sie den Exchange Server-Computer neu, damit die Änderung wirksam wird.

Weitere Informationen zum Erstellen eines neuen Attributs legacyExchangeDN mithilfe der ADSI-Bearbeitung finden Sie im Microsoft Knowledge Base-Artikel, „How to Change the LegacyExchangeDN Attribute in Native Mode with ADSI Edit" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863.


Der Wert für „LegacyExchangeDN" ist in dieser Exchange-Datenbank nicht vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs legacyExchangeDN für alle Postfachspeicher-Datenbanken auf einem Exchange Server-Computer zu ermitteln. Wenn Exchange Server Analyzer in keinem der Postfachspeicher einen Wert für das Attribut legacyExchangeDN findet, wird ein Fehler angezeigt.

Das Attribut legacyExchangeDN kann beispielsweise nicht vorhanden sein, wenn ein Administrator Änderungen an Active Directory vorgenommen hat, um eine Datenbank nach einem Datenverlust wiederherzustellen. Diesen Fehler beheben Sie, indem Sie das Attribut legacyExchangeDN mithilfe eines Active Directory-Editors (z. B: dem LDP-Tool ldp.exe oder der ADSI-Bearbeitung (Active Directory Service Interfaces)) ändern.

Um sicherzustellen, dass das Attribut legacyExchangeDN richtig ist, überprüfen Sie das Attribut legacyExchangeDN des Servers, auf dem die Datenbank gespeichert ist. Da es sich bei der Datenbank um ein untergeordnetes Objekt des Servers handelt, stimmt das Attribut legacyExchangeDN bei Datenbank und Server überein.

Überprüfen Sie auch andere Datenbanken auf diesem Exchange-Server, bei denen dieser Fehler nicht aufgetreten ist, da sie über das gleiche Attribut legacyExchangeDN verfügen. Es gibt noch weitere Systemobjekte mit diesem Attribut. Wenn das Attribut legacyExchangeDN in einer Datenbank fehlt, fehlt es wahrscheinlich auch in verschiedenen anderen Systemobjekten. Wenn Sie mithilfe von LDP oder der ADSI-Bearbeitung einen neuen Wert für legacyExchangeDN hinzufügen, müssen Sie diese Änderung daher auch an allen anderen Systemobjekten vornehmen.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In, das LDP-Tool oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, von Exchange Server 2003 bzw. Exchange Server 2007 oder beider Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So beheben Sie diesen Fehler

  1. Öffnen Sie einen Active Directory-Editor, z. B. die ADSI-Bearbeitung.

  2. Erweitern Sie Configuration[Domänenname], erweitern Sie CN=Configuration,DC=Domänenname,DC=Domänensuffix.

  3. Erweitern Sie CN=Services, und erweitern Sie dann CN=Microsoft Exchange.

  4. Erweitern Sie CN=Organisationsname, erweitern Sie CN=Administrative Groups, und erweitern Sie dann CN=Administratorengruppenname.

  5. Erweitern Sie CN=Servers, erweitern Sie CN=Servername, und erweitern Sie dann CN=InformationStore.

  6. Wählen Sie CN=Speichergruppenname aus, und klicken Sie im rechten Bereich mit der rechten Maustaste auf den Postfachspeicher, in dem das Attribut legacyExchangeDN fehlt, und klicken Sie dann auf Eigenschaften.

  7. Führen Sie einen Bildlauf nach unten durch, um legacyExchangeDN zu finden, markieren Sie den Eintrag, und klicken Sie auf Bearbeiten.

  8. Geben Sie im Feld Wert den korrekten Wert für legacyExchangeDN ein.

  9. Schließen Sie den Active Directory-Editor, und starten Sie den Exchange Server-Computer neu, damit die Änderung wirksam wird.

Weitere Informationen zum Erstellen eines neuen Attributs legacyExchangeDN mithilfe der ADSI-Bearbeitung finden Sie im Microsoft Knowledge Base-Artikel, „How to Change the LegacyExchangeDN Attribute in Native Mode with ADSI Edit" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863.


Der Parameter „LimitBodyParts" wurde manuell festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Standardgrenzwert für Anlagen in einer Nachricht geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent\LimitBodyParts

Wenn Exchange Server Analyzer erkennt, dass der Registrierungseintrag LimitBodyParts vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Exchange Server ist aus Sicherheitsgründen so konzipiert, dass die Anzahl der Anhänge (als Textkörper bezeichnet) auf 250 eingeschränkt wird. Wenn eine Nachricht mehr als 250 Anhänge enthält, wird ein Fehler vom Typ MAPI_E_TOO_BIG generiert. Außerdem beansprucht der Microsoft Exchange-Informationsspeicherdienst möglicherweise beim Verarbeiten von Nachrichten mit einer großen Anzahl von Anlagen übermäßig viel Speicherplatz und CPU-Ressourcen.

Es gibt eine Konfigurationsmöglichkeit, mit deren Hilfe Administratoren den Registrierungswert LimitBodyParts hinzufügen und ihn für einen höheren Wert als 250 konfigurieren können. Ohne diesen Eintrag wird der Standardwert 250 verwendet.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So zeigen Sie den Registrierungswert LimitBodyParts an oder ändern ihn

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

  3. Überprüfen und ändern Sie bei Bedarf den Wert LimitBodyParts. Jede ganze Zahl zwischen 250 und 4294967295 ist als Registrierungswert möglich.

  4. Wenn eine Änderung vorgenommen wurde, starten Sie den Exchange Server-Computer neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Der Parameter „LimitEmbeddingDepth" wurde manuell festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-30

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob Standard-MIME-Headerlimits geändert wurden:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Wenn Exchange Server Analyzer feststellt, dass einer der Werte für LimitEmbeddingDepth festgelegt wurde, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Exchange 2000 Server Service Pack 3, Exchange Server 2003 und Exchange Server 2007 enthalten aktualisierte Funktionen für den Informationsspeichervorgang (store.exe) für die Behandlung umfangreicher oder unregelmäßig geformter MIME-Nachrichten. Diese Funktion wurde hinzugefügt, um Exchange Server noch besser gegen DOS-Angriffe (Denial-of-Service) durch MIME-Nachrichten zu schützen, die mit bösartiger Absicht gesendet wurden oder unbeabsichtigt umfangreich und komplex sind. An den Speicher gesendete MIME-Nachrichten sind unter anderem hinsichtlich der Anzahl von Empfängern, der Anzahl eingebetteter Nachrichten sowie der Größe einzelner MIME-Header eingeschränkt.

Die Standardwerte der unterschiedlichen Einschränkungen für MIME-Header werden innerhalb des Speicherprozesses festgelegt. Wenn jedoch als Definition einer dieser Einschränkungen ein Registrierungsschlüssel festgelegt wurde, überschreibt dieser den Standardwert von store.exe. Wenn in einer MIME-Nachricht eine der verschiedenen Einschränkungen überschritten wurde, wird an den Absender ein Unzustellbarkeitsbericht gesendet.

Die Einschränkungen der MIME-Einbettungstiefe bezieht sich auf die Anzahl von MIME-Nachrichten, die ineinander eingebettet werden können. Angenommen, Sie erhalten eine Nachricht (m1) mit einer angefügten Nachricht (m2). Wenn Sie die angefügte Nachricht (m2) öffnen, sehen Sie, dass an diese Nachricht (m2) ebenso eine Nachricht (m3) angefügt ist. Entsprechend sind in die ursprüngliche Nachricht (m1) Nachrichten mit einer Tiefe von 3 Ebenen eingebettet. In der Standardeinstellung sind in Exchange Nachrichten mit einer Einbettungtiefe von bis zu 100 Ebenen zulässig. Bei Nachrichten mit einer Einbettungstiefe von mehr als 100 Ebenen ist möglicherweise die gesamte Speicherkapazität eines Exchange-Servers erforderlich, um diese auszupacken, zu verarbeiten und in MAPI zu konvertieren. Es ist höchst unwahrscheinlich, dass ein E-Mail-Client oder -Server eine Nachricht mit einer solchen Einbettungstiefe generiert. Es ist wahrscheinlicher, dass eine solche Nachricht mit bösartiger Absicht gesendet wird, um einen DOS-Angriff auf Ihr Messaging-System durchzuführen.

So stellen Sie die Standardkonfiguration wieder her

  • Es ist keine Aktion erforderlich. Dieser Registrierungseintrag ist nur vorhanden, wenn der Hotfix aus dem Microsoft Knowledge Base-Artikel 833607 „The Microsoft Exchange Information Store service uses 100 percent of the CPU resources on an Exchange 2000 server or an Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=833607 installiert wurde. Dieser Hotfix erstellt den Registrierungseintrag LimitEmbeddingDepth und legt diesen auf den Wert 10 fest.

Weitere Informationen zum Installieren von Exchange Server-Service Packs und Hotfixes finden Sie im Microsoft Knowledge Base-Artikel 328839 „Wie Sie Service Packs und Hotfixes für Exchange anwenden" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839.


Der Parameter „LimitNestingLevels" wurde manuell festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die Standard-MIME-Headerlimits (Multipurpose Internet Mail Extensions) in Exchange geändert wurden:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Wenn Exchange Server Analyzer feststellt, dass ein Wert für LimitNestingLevels festgelegt wurde, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

MIME-Textkörper in Nachrichtenelementen können verschachtelt sein. Wenn die Verschachtelungsebene hoch ist, erfordert der Konvertierungsprozess immer mehr Ressourcen, um die gesamte Nachricht zu decodieren. Es kann bis zu 10 Minuten dauern, um eine einzlene Nachricht mit einem MIME-Textkörper zu verarbeiten, dessen Verschachtelung sich über 700 Ebenen erstreckt. Wenn Sie aus dem Internet Nachrichten mit verschachtelten MIME-Textkörpern erhalten, kann der Konvertierungsprozess für die MIME-Textkörper die langsame Lieferung dieser Nachrichten verursachen. Da die Nachrichten geliefert werden, benötigt der Server sehr viele Systemressourcen, vor allem Arbeitsspeicher. Wenn eine große Anzahl dieser Nachrichten gleichzeitig erhalten wird, kann das System möglicherweise berichten, dass nicht genügend virtuelle Arbeitsspeicher vorhanden sind.

Die Begrenzung der Verschachtelungsebenen von MIME bezieht sich auf die Anzahl der MIME-Inhaltstypen (z. B: mehrteilig/gemischt oder mehrteilig/alternativ), die ineinander verschachtelt sein können. Die Nachrichten, die von den meisten E-Mail-Clients (einschließlich Microsoft Outlook® und Outlook Express) und E-Mail-Servern erstellt werden, enthalten sehr wenige verschachtelte MIME-Inhaltstypen. Beispielsweise wird eine typische Nachricht (sogar mit mehreren Antworten) in einer MIME-Nachricht nur als einzelner Inhaltstyp dargestellt. Mehrfache Verschachtelungsebenen sind normalerweise entweder das Ergebnis automatisierter Vorgänge, die MIME-Nachrichten für bestimmte Verwendungszwecke (z. B. Workflowanwendungen) erstellen, oder von Nachrichten, die mit der bösartigen Absicht erstellt wurden, Ressourcen auf dem E-Mail-Server zu verbrauchen.

Zusätzlich zum Erzwingen von Verschachtelungsebenen nach Inhaltstyp verwendet Exchange Server den Wert LimitNestingLevels (entweder als Registrierungswert oder als Standardwert im Speichervorgang definiert), um eine Grenze für eingebettete Nachrichten zu erzwingen. Wenn der Registrierungswert LimitNestingLevels nicht definiert ist, wird der Standardwert von 30 Verschachtelungebenen erzwungen. Die eingebttete Nachrichtengrenze wird durch Multiplikation des Wertes LimitNestingLevels mit 16 definiert. Aus diesem Grund beträgt der Standardwert für die Anzahl der eingebetteten Nachrichten 480. Wenn LimitNestingLevels beispielsweise mit einem Wert von 5 konfiguriert wird, dann werden maximal 80 Anlagen angenommen.

So stellen Sie die Standardkonfiguration wieder her

  • Es ist keine Aktion erforderlich. Microsoft Exchange Server Analyzer zeigt zu Informationszwecken die Konfiguration an, die nicht dem Standard entspricht.

Weitere Informationen zum Exchange 2000 Server-Hotfix für den Registrierungswert LimitNestingLevels finden Sie im Microsoft Knowledge Base-Artikel 289775, „XADM: Exchange 2000 Server Experiences Memory Leaks Because of Many Embedded Messages", (http://go.microsoft.com/fwlink/?linkid=3052&kbid=289775).


Der Parameter „LimitRecipients" wurde manuell festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob Standard-MIME-Headerlimits geändert wurden:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Wenn Exchange Server Analyzer feststellt, dass einer der Werte für LimitRecipients festgelegt wurde, wird eine Warnung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Exchange 2000 Server Service Pack 2 (SP2) und neuere Versionen von Exchange Server enthalten aktualisierte Funktionen für den Informationsspeicherprozess (store.exe) zum Behandeln umfangreicher oder unregelmäßig geformter MIME-Nachrichten. Diese Funktion wurde hinzugefügt, um Exchange noch besser gegen DOS (Denial-of-Service)-Angriffe durch MIME-Nachrichten zu schützen, die mit bösartiger Absicht gesendet wurden oder außergewöhnliche Merkmale besitzen (unbeabsichtigt umfangreich und zu komplex sind). An den Speicher gesendete MIME-Nachrichten sind unter anderem hinsichtlich der Anzahl von Empfängern, der Anzahl eingebetteter Nachrichten sowie der Größe einzelner MIME-Header eingeschränkt. In früheren Versionen von Exchange, in denen unbegrenzte MIME-Header im Exchange-Speicher zur Verarbeitung zugelassen sind, können außergewöhnlich umfangreiche oder komplexe MIME-Nachrichten durch die anfallende Analyse, Indizierung und Verarbeitung der MIME den Großteil der Ressourcen (vor allem der CPU) beanspruchen.

Die Standardwerte der unterschiedlichen Einschränkungen für MIME-Header werden innerhalb des Speicherprozesses festgelegt. Wenn jedoch als Definition einer dieser Einschränkungen ein Registrierungsschlüssel festgelegt wurde, überschreibt dieser den Standardwert von store.exe. Wenn in einer MIME-Nachricht eine der verschiedenen Einschränkungen überschritten wurde, wird an den Absender ein Unzustellbarkeitsbericht gesendet.

Wenn der Registrierungsschlüssel LimitRecipients festgelegt wurde, erfolgte dies wahrscheinlich auf Anraten des technischen Supports von Microsoft, da dieser Schlüssel nicht veröffentlicht wurde. Microsoft empfiehlt die Änderung dieser Einstellung nicht.

Wenn kein Registrierungsschlüssel vorhanden ist, ist der Standardwert für LimitRecipients im Speichervorgang 65.535 Empfänger pro MIME-Nachricht.


Die Protokollpuffer sind nicht für Server mit repliziertem Datenträgerspeicher optimiert, auf denen Exchange Server 2003 ausgeführt wird.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob die folgenden Bedingungen erfüllt sind:

  • Auf dem Computer wird Exchange Server 2003 ausgeführt.

  • Der Wert von msExchESEParamLogBuffers liegt zwischen 0 und 8.960.

Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_MSExchangeIS_MSExchangeIS ab, um zu bestimmen, ob die folgende Bedingung erfüllt ist:

  • Der Wert VMLargestBlockSize ist größer als 150.000.000.

Exchange Server Analyzer ermittelt, ob einer der folgenden Dienste ausgeführt wird:

  • GeoSpanService

  • SRDFService

Wenn alle oben angegebenen Bedingungen erfüllt sind, wird ein Fehler angezeigt.

ESE (Extensible Storage Engine) verwendet Protokollpuffer, um Transaktionen im Arbeitsspeicher aufzubewahren, bevor sie an die Transaktionsprotokolle übermittelt werden. Wenn die verfügbaren Protokollpuffer nicht ausreichen, kann es zu übermäßigen Datenträger-E/As auf dem Laufwerk mit dem Transaktionsprotokoll kommen, wodurch eine Leistungsminderung eintritt.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So beheben Sie diesen Fehler

  1. Doppelklicken Sie in der ADSI-Bearbeitung (Active Directory Service Interfaces) auf den Container Konfiguration, erweitern Sie CN=Services, erweitern Sie CN=Microsoft Exchange, und erweitern Sie dann CN=ExchangeOrganizationName.

  2. Erweitern Sie CN=Administrative Groups, erweitern Sie CN=AdministrativeGroupName, und erweitern Sie dann CN=Servers.

  3. Erweitern Sie CN=ExchangeServerName, erweitern Sie CN=InformationStore, klicken Sie mit der rechten Maustaste auf CN=Storage Group Name, und klicken Sie anschließend auf Eigenschaften.

  4. Klicken Sie im Feld Anzuzeigende Eigenschaft auswählen auf msExchESEParamLogBuffers.

  5. Geben Sie im Feld zum Bearbeiten von Attributen den Wert 9000 für msExchESEParamLogBuffers ein, und klicken Sie dann auf Festlegen.

  6. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.

  7. Der Microsoft Exchange-Informationsspeicherdienst muss neu gestartet werden, damit die Änderung wirksam wird.

Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 328466, „ESE log buffers that are set too low can cause the Microsoft Exchange Information Store service to stop responding" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466).


Die Protokollpuffer sind für Server mit einer großen Anzahl von Postfächern, auf denen Exchange Server 2003 ausgeführt wird, möglicherweise nicht ausreichend.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-03-27

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob die folgenden Bedingungen erfüllt sind:

  • Auf dem Computer wird Exchange Server 2003 ausgeführt.

  • Der Wert von msExchESEParamLogBuffers liegt zwischen 0 und 8.960.

  • Die Anzahl der Postfächer in der Speichergruppe ist größer als 500.

Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_MSExchangeIS_MSExchangeIS ab, um zu bestimmen, ob die folgende Bedingung erfüllt ist:

  • Der Wert für VMLargestBlockSize liegt über 150 Millionen.

Wenn alle diese Bedingungen erfüllt sind, wird eine Warnung angezeigt.

ESE (Extensible Storage Engine) verwendet Protokollpuffer, um Transaktionen im RAM zu halten, bevor sie an die Transaktionsprotokolle übermittelt werden. Wenn die verfügbaren Protokollpuffer nicht ausreichen, kann es zu übermäßigen Datenträger-E/As auf dem Laufwerk mit dem Transaktionsprotokoll kommen, was zu einer Leistungsminderung führen kann.

So beheben Sie diese Warnmeldung

  1. Doppelklicken Sie in der ADSI-Bearbeitung (Active Directory Service Interfaces) auf den Container Konfiguration, erweitern Sie CN=Services, erweitern Sie CN=Microsoft Exchange, und erweitern Sie dann CN=ExchangeOrganizationName.

  2. Erweitern Sie CN=Administrative Groups, erweitern Sie CN=AdministrativeGroupName, und erweitern Sie dann CN=Servers.

  3. Erweitern Sie CN=ExchangeServerName, erweitern Sie CN=InformationStore, klicken Sie mit der rechten Maustaste auf CN=Storage Group Name, und klicken Sie anschließend auf Eigenschaften.

  4. Klicken Sie im Feld zum Auswählen einer anzuzeigenden Eigenschaft auf msExchESEParamLogBuffers.

  5. Geben Sie im Feld zum Bearbeiten von Attributen den Wert 9000 für msExchESEParamLogBuffers ein, und klicken Sie dann auf Festlegen.

  6. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.

  7. Der Microsoft Exchange-Informationsspeicherdienst muss neu gestartet werden, damit die Änderung wirksam wird.
Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 328466, "Zu niedrig festgelegte ESE-Protokollpuffer können dazu führen, dass der Microsoft Exchange-Informationsspeicherdienst nicht mehr reagiert" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466).


Protokolldateien werden auf Netzlaufwerk gespeichert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer sendet eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert des Attributs msExchESEParamLogFilePath für jedes Speichergruppenobjekt zu bestimmen. Dieses Attribut gibt den Speicherort der Transaktionsprotokolle an, die von den Datenbanken in der Speichergruppe verwendet werden.

Exchange Server Analyzer sendet außerdem eine Abfrage an Active Directory, um die Anzahl der Einträge zu ermitteln, die im Attribut homeMDBBL jedes Postfachspeichers aufgelistet sind. Der Zählwert dieses Attributs stellt die Zahl der Postfächer im Postfachspeicher dar.

Wenn Exchange Server Analyzer dabei feststellt, dass das Attribut msExchESEParamLogFilePath auf einem Exchange-Server mit mehr als 50 Postfächern mit \\ beginnt, wird ein Fehler angezeigt.

Dieser Fehler zeigt an, dass die Transaktionsprotokolldateien für eine Speichergruppe auf dem Netzlaufwerk gespeichert werden. Wenn das Attribut msExchESEParamLogFilePath mit \\ beginnt, bedeutet dies, dass der Protokolldateipfad einen Pfad gemäß der UNC (Universal Naming Convention) verwendet. Diese Vorgehensweise wird jedoch nicht empfohlen, da sie zu Unterbrechungen der Netzwerkverbindung und damit zu Fehlern in Transaktionsprotokollen und Datenbanken, dem Verlust von Daten oder der Beschädigung von Datenbanken führen könnte. Es wird daher empfohlen, dieses Problem so schnell wie möglich zu beheben.

So beheben Sie diesen Fehler

  • Verschieben Sie die Transaktionsprotokolle vom Netzlaufwerk auf einen lokalen Datenträger. Um optimale Leistung zu erzielen, legen Sie die Transaktionsprotokolle auf gesonderten Laufwerken ab.

Informationen zum Verschieben der Transaktionsprotokolle an einen anderen Speicherort finden Sie im Microsoft Knowledge Base-Artikel 239944, „XADM: How to Move the Transaction or System Logs to Another Location" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=239944).


Diskrepanz bei der Protokollerstellung
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

The Microsoft® Exchange Server Analyzer Tool has determined that you have a log file generation discrepancy. Dieser Fehler zeigt an, dass eine Transaktionsprotokolldatei mit einer unpassenden Sequenznummer umbenannt worden ist.

Exchange-Transaktionsprotokolldateien werden entsprechend dem folgenden Format benannt: EnnXXXXX.log

  • XXXXX = Eine fünfstellige hexadezimale Sequenznummer. Wenn eine neues Gruppe von Transaktionsprotokolldateien generiert wird, erhält das erste Protokoll in der Sequenz die Nummer 000001, das nächste die Nummer 00002 usw. Da jedes Transaktionsprotokoll seine eigene Sequenznummer im Header aufzeichnet, können Sie feststellen, ob der Protokolldateiname geändert worden ist.

  • Enn = Das Protokollpräfix, also eine drei Zeichen lange Folge, die von jedem Transaktionsprotokoll für diese Speichergruppe gemeinsam verwendet wird. Normalerweise lautet das Präfix E00, E01, E02, E03 oder R00 (für eine Speichergruppe für die Wiederherstellung).

Aktuell wird in ein Protokoll geschrieben, das nur mit dem Protokollpräfix benannt ist. Dieses Protokoll erhält seine Sequenznummer erst, wenn es geschlossen und ein neues aktuelles Protokoll generiert worden ist. Deshalb kann die aktuelle Protokolldatei als E00.log bezeichnet werden. Wenn diese Protokolldatei voll ist, kann sie in E0012345.log umbenannt werden. Es würde eine neue Datei E00.LOG mit der internen Sequenznummer 12346 generiert werden.

So beheben Sie diesen Fehler

  • Rename the log file to the appropriate sequence number.
So zeigen Sie die interne Sequenznummer an

  • Führen Sie den folgenden Befehl aus:

    C:\Program Files\Exchsrvr\Bin\Eseutil.exe /ML [log filename]

    Der Wert „lGeneration" in der Ausgabe dieses Befehls listet die tatsächliche Sequenznummer der Protokolldatei auf.


Die Protokollpaare sind inkonsistent
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer hat festgestellt, dass einige der erforderlichen Protokolldateien inkonsistent sind. Dieser Fehler zeigt an, dass möglicherweise Protokolldateien manipuliert, manuell verschoben, kopiert, umbenannt oder gelöscht wurden.

So beheben Sie diesen Fehler

  • Wenn Sie eine genauere Analyse der Protokolldateien vornehmen möchten, sollten Sie möglicherweise zuerst Microsoft Hilfe- und Support unter (http://go.microsoft.com/fwlink/?LinkId=31845) kontaktieren.


Diskrepanz bei der Protokollsignatur
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer hat festgestellt, dass die Protokollsignatur in einem oder mehreren Ihrer Protokolldateien nicht mit der von anderen Protokolldateien im gleichen Ordner übereinstimmt.

Dieses Problem tritt nur auf, wenn Protokolldateien manuell verschoben, gelöscht oder falsch angeordnet wurden.

Hinweis:
Dies ist ein Szenario für Fortgeschrittene, und Sie sollten möglicherweise zuerst Microsoft Hilfe- und Support unter (http://go.microsoft.com/fwlink/?LinkId=31845) kontaktieren, ehe Sie diese Strategie umsetzen.

Jede Exchange-Transaktionsprotokolldatei wird mit einer Signatur gestempelt, die als Protokollsignatur bezeichnet wird. Diese Signatur identifiziert einzelne Protokolldateien, die derselben Serie von Protokollen angehören. Jede Exchange-Datenbank zeichnet die Protokollsignatur der Transaktionsprotokollserie auf, mit der die Datenbank zuletzt verknüpft war.

Exchange-Datenbanken verfügen auch über eine als DB-Signatur bezeichnete Signatur. Die Datenbanksignatur wird generiert, wenn eine Datenbank erstmals angelegt wird. Wenn Sie mithilfe von Eseutil eine Datenbank defragmentieren oder reparieren, ändert sich diese Signatur, weil während der Reparatur und Defragmentierung Änderungen an der Datenbank erfolgen, ohne dass diese Änderungen in den Transaktionsprotokollen protokolliert werden. Aus Prokollgründen stellt die Datenbank, die durch Reparatur oder Defragmentierung entsteht, eine neue oder andere Datenbank dar.

Anders als Datenbanksignaturen, ändern sich die Protokollsignaturen während der Lebensdauer einer Serie von Protokolldateien niemals.

Protokolldateien zeichnen die DB-Signaturen aller angehängten Datenbanken auf, sobald die Protokolldatei erstellt wurde. Datenbanken zeichnen die Protokollsignatur der aktuellsten Protokollserie auf, mit der die Datenbank verknüpft wurde. Deshalb sind Datenbank- und Protokollsignaturen nützlich, um Datenbanken mit Transaktionsprotokolldateien abzugleichen.

Sie können eine Exchange-Datenbank von einem Protokollsatz trennen und sie einem anderen zuordnen. Sie können dieses tun, indem Sie die Datenbank zu einer anderen Speichergruppe verschieben oder alle Transaktionsprotokolle für eine Speichergruppe entfernen und eine neuen Protokollserie beginnen.

Bei Datenbanken im Zustand „Dirty Shutdown" können nur Transaktionsprotokolldateien erfolgreich in die Datenbank eingespielt werden, deren Signaturen mit der Protokollsignatur im Datenbankheader übereinstimmen. Im Zustand „ Dirty Shutdown" ist eine Datenbank immer noch an einen bestimmten Protokollstrom angehängt und kann nur mit diesem Protokollstrom wiederhergestellt werden.

Bei Datenbanken im Zustand „ Clean Shutdown" können möglicherweise Transaktionsprotokolldateien eingespielt werden, deren Signaturen nicht mit der aktuellen Protokollsignatur im Datenbankheader übereinstimmen. Dies ist nur in folgender Situation erfolgreich:

  1. Die Datenbank wurde beim Abschluss einer vorangegangenen Protokolldateisequenz ordnungsgemäß beendet.

  2. Die Datenbank wurde danneiner neuen Sequenz von Transaktionsprotokolldateien zugeordnet, und Sie haben Zugriff auf das Transaktionsprotokoll, in dem die Datenbank erstmals dem neuen Protokollsatz zugeordnet wurde.

So beheben Sie diesen Fehler

  • Sie müssen den Verlauf der Datenbank und die Umstände kennen, unter denen Transaktionsprotokolle im Hinblick auf die Datenbank generiert wurden.

  • Vor einem Wiederherstellungsversuch sollten Sie in so einer Situation immer eine Kopie von beiden Transaktionsprotokollen und von den Datenbankdateien machen. Infolge eines verfehlten Wiederherstellungsversuchs können das Transaktionsprotokoll oder die Datenbankdateien derart verändert werden, dass ein weiterer Wiederherstellungsversuch u. U. nicht mehr durchführbar ist.

  • Spielen Sie in die Datenbank jeweils immer nur einen Satz von Transaktionsprotokollen ein. Verschieben Sie andere Transaktionsprotokolle aus dem Wiederherstellungsordner.

  • Wenn sich die Datenbank im Zustand „Dirty Shutdown" befindet, müssen Sie zuerst die Transaktionsprotokolle der betreffenden Datenbank einspielen und die Datenbank in den Zustand „Clean Shutdown" bringen. Anschließend können Sie möglicherweise die zweite Gruppe von Protokolldateien in die Datenbank einspielen.

  • Wenn sich die Datenbank im Zustand „Clean Shutdown" befindet, können Sie nicht durch Prüfung der Protokolle oder der Datenbank schlüssig feststellen, welche Menge von Transaktionsprotokollen zu allererst eingespielt werden muss.


Die Anmeldung wurde auf bestimmte Benutzer beschränkt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag auf dem Exchange Server-Computer, um zu ermitteln, ob die Liste der zum Anmelden am Exchange-Informationsspeicher berechtigten Benutzer eingeschränkt wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Logon Only As

Wenn Exchange Server Analyzer feststellt, dass der Registrierungswert Logon Only As vorhanden ist, wird eine Warnung angezeigt.

Bei dem Registrierungswert Logon Only As handelt es sich um einen Wert mit mehreren Zeichenfolgen (REG_MULTI_SZ), der die Liste mit den Attributen legacyExchangeDN für die Konten enthält, die zum Anmelden am Exchange-Informationsspeicher berechtigt sind. Der in der Standardeinstellung nicht vorhandene Registrierungswert wird i. d. R. während Problembehandlungs-, Wartungs- und Postfachverschiebevorgängen hinzugefügt.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie dieses Problem

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Löschen Sie im rechten Bereich den Registrierungswert Logon Only As.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Weitere Informationen zum Registrierungswert Logon Only As finden Sie im Microsoft Knowledge Base-Artikel 146764, „Limiting Logons to the Information Store" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=146764.

Informationen zum Beschränken von Anmeldungen während Postfachverschiebevorgängen finden Sie im Knowledge Base-Artikel 218920, „XADM: How to Prevent Logons During Move Mailbox" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=218920).


Der Registrierungswert „Lookup SID Cache Expire" wurde festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungsschlüssel, um zu bestimmen, ob der Registrierungseintrag Lookup Sid Cache Expire vorhanden ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Microsoft Exchange Server Analyzer zeigt eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht, wenn die folgenden Bedingungen erfüllt sind:

  • Der Registrierungseintrag Lookup Sid Cache Expire ist vorhanden.

  • Der Wert des Registrierungseintrags Lookup Sid Cache Expire beträgt nicht 3.600.

Der Informationsspeicher erstellt auf Exchange-Servern, auf denen Exchange 2000 Server Service Pack 3 oder höher ausgeführt wird, einen Cache mit Sicherheits-IDs (SIDs) und gibt an, ob es sich bei der SID um ein Benutzerobjekt oder ein Gruppenobjekt handelt. Dieser Cache wird erstellt und aufgefüllt, wenn auf einen öffentlichen Ordner zum ersten Mal zugegriffen wird. Nach dem Auffüllen des Caches werden alle Aufrufe zum Durchsuchen von Konto-SIDs zuerst an den Cache des Informationsspeichers weitergeleitet. Wenn sich die SID nicht im Cache des Informationsspeichers befindet, wird der Aufruf an den Domänencontroller weitergeleitet, und anschließend werden die Informationen zu dieser SID dem Cache hinzugefügt.

In der Standardeinstellung wird der Cacheinhalt eine Stunde aufrechterhalten. Wenn im Cache der Standardwert 8 KB für die Einträge überschritten wird, werden ältere Cacheeinträge entfernt, um Speicherplatz für neue Einträge freizugeben. Mithilfe von zwei Registrierungsschlüsseln können Sie die Standardwerte für die Zwischenspeicherungszeit (Lookup Sid Cache Expire) und die Cachegröße (Lookup Sid Cache Size) anpassen. Es wird empfohlen, diese Standardeinstellungen nicht zu ändern, solange es keine Hinweise darauf gibt, dass durch eine Änderung eine Leistungssteigerung erzielt werden kann.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. Wechseln Sie im rechten Bereich zu dem Wert Lookup Sid Cache Expire, und löschen Sie ihn. Wenn der Wert Lookup SID Cache Size ebenfalls festgelegt wurde, löschen Sie ihn auch.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zum Registrierungswert Lookup Sid Cache Expire finden Sie im Microsoft Knowledge Base-Artikel 328907 „XADM: Access Control List Upgrades Cause Slow Public Folder Performance; Fix Requires Exchange 2000 SP2" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=328907.


Der Registrierungswert „Lookup SID Cache Size" wurde festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungsschlüssel, um zu bestimmen, ob der Registrierungseintrag Lookup Sid Cache Size vorhanden ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Microsoft Exchange Server Analyzer zeigt eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht, wenn die folgenden Bedingungen erfüllt sind:

  • Der Registrierungseintrag Lookup Sid Cache Size ist vorhanden.

  • Der Wert des Registrierungseintrags Lookup Sid Cache Size beträgt nicht 1.024.

Der Informationsspeicher erstellt auf Exchange-Servern, auf denen Exchange 2000 Server Service Pack 3 oder höher ausgeführt wird, einen Cache mit Sicherheits-IDs (SIDs) und gibt an, ob es sich bei der SID um ein Benutzerobjekt oder ein Gruppenobjekt handelt. Dieser Cache wird erstellt und aufgefüllt, wenn auf einen öffentlichen Ordner zum ersten Mal zugegriffen wird. Nach dem Auffüllen des Caches werden alle Aufrufe zum Durchsuchen von Konto-SIDs zuerst an den Cache des Informationsspeichers weitergeleitet. Wenn sich die SID nicht im Cache des Informationsspeichers befindet, wird der Aufruf an den Domänencontroller weitergeleitet, und anschließend werden die Informationen zu dieser SID dem Cache hinzugefügt.

In der Standardeinstellung wird der Cacheinhalt eine Stunde aufrechterhalten. Wenn im Cache der Standardwert 8 KB für die Einträge überschritten wird, werden ältere Cacheeinträge entfernt, um Speicherplatz für neue Einträge freizugeben. Mithilfe von zwei Registrierungsschlüsseln können Sie die Standardwerte für die Zwischenspeicherungszeit (Lookup Sid Cache Expire) und die Cachegröße (Lookup Sid Cache Size) anpassen. Es wird empfohlen, diese Standardeinstellungen nicht zu ändern, solange es keine Hinweise darauf gibt, dass durch eine Änderung eine Leistungssteigerung erzielt werden kann.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. Wechseln Sie im rechten Bereich zu dem Wert Lookup Sid Cache Size, und löschen Sie ihn. Wenn der Wert Lookup SID Cache Expire ebenfalls festgelegt wurde, löschen Sie ihn auch.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zum Registrierungswert Lookup Sid Cache Size finden Sie im Microsoft Knowledge Base-Artikel 328907 „XADM: Access Control List Upgrades Cause Slow Public Folder Performance; Fix Requires Exchange 2000 SP2" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=328907.


Fehlerereignis für niedrigen virtuellen Speicher wurde außer Kraft gesetzt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft ® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Schwellenwert für die Protokollierung eines Ereignisses, das sich auf die Fragmentierung des virtuellen Speichers bezieht, manuell außer Kraft gesetzt wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\VM Error Level

Wenn Exchange Server Analyzer erkennt, dass der Registrierungswert VM Error Level vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In 32-Bit-Systemen von Microsoft Windows® gibt es zwei Arten von Arbeitsspeicher: den physischen Arbeitsspeicher (den tatsächlich im System installierten Arbeitsspeicher) und den virtuellen Speicheradressraum (einen virtualisierten 4-Gigabyte-Speicher). Die Gesamtgröße des virtuellen Adressraums bleibt immer gleich, unabhängig von der Größe des im System installierten physischen Arbeitsspeichers: 4 GB. Auch wenn dies nicht für alle 32-Bit-Anwendungen gilt: Bei Exchange Server entspricht der virtuelle Adressraum dem virtuellen Speicher. Die Begriffe sind daher austauschbar.

Zum normalen Betrieb des Exchange-Informationsspeichers gehört das wiederholte Zuweisen, Verwenden und Freigeben von virtuellem Speicher. Häufiges Zuweisen, Verwenden und Freigeben von virtuellem Speicher kann eine Fragmentierung des virtuellen Speichers verursachen. Die Fragmentierung des virtuellen Speichers entspricht der Fragmentierung des Dateisystems, die im Lauf der Zeit auftreten kann. Nach einer gewissen Zeit sind die zugewiesenen Segmente des virtuellen Speichers nicht mehr zusammenhängend, und die Leistung wird beeinträchtigt. Beim Dateisystem können Sie eine Anwendung ausführen, die eine Defragmentierung des Dateisystems durchführt. In den meisten Fällen kann dies erfolgen, während auf das System zugegriffen wird und es online ist. Bei einer Fragmentierung des virtuellen Speichers steht kein Tool zur Defragmentierung zur Verfügung. Stattdessen müssen Sie den Microsoft Exchange-Informationsspeicherdienst beenden und neu starten oder das System neu starten, um das Problem zu beheben.

Wenn ein Exchange Server-Computer über weniger als 16 MB zusammenhängenden freien virtuellen Adressraums verfügt, wird im Anwendungsereignisprotokoll die folgende Fehlermeldung protokolliert:

Quelle: | MSExchangeIS
Kategorie: | Leistung
ID: | 9582
Typ: | Fehler
Beschreibung: | Der für die Ausführung des Exchange-Servers erforderliche virtuelle Speicher ist so fragmentiert, dass normale Vorgänge nicht ausgeführt werden können. Es wird dringend empfohlen, alle Exchange-Dienste neu zu starten, um dieses Problem zu beheben.

Der Registrierungswert VM Error Level stellt eine Konfigurationsmöglichkeit dar, mit der ein Administrator die Standardwarnung bei 16 MB außer Kraft setzen und einen anderen Wert festlegen kann.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Löschen Sie im rechten Bereich den Wert für VM Error Level.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Weitere Informationen zur Problembehandlung bei der Fragmentierung des virtuellen Speichers in Exchange Server 2003 und Exchange 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 325044, „SO WIRD´S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).


Warnungsereignis für niedrigen virtuellen Speicher wurde außer Kraft gesetzt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Schwellenwert für die Protokollierung eines Ereignisses, das sich auf die Fragmentierung des virtuellen Speichers bezieht, manuell außer Kraft gesetzt wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\VM Warning Level

Wenn Exchange Server Analyzer erkennt, dass der Registrierungswert VM Warning Level vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In 32-Bit-Systemen von Microsoft Windows® gibt es zwei Arten von Arbeitsspeicher: den physikalischen Arbeitsspeicher (den tatsächlich im System installierten Arbeitsspeicher) und den virtuellen Speicheradressraum (einen virtualisierten 4-Gigabyte-Speicher). Die Gesamtgröße des virtuellen Adressraums bleibt immer gleich, unabhängig von der Größe des im System installierten physischen Arbeitsspeichers: 4 GB. Auch wenn dies nicht für alle 32-Bit-Anwendungen gilt: Bei Exchange Servern entspricht der virtuelle Adressraum dem virtuellem Speicher, die Begriffe sind daher austauschbar.

Zum normalen Betrieb des Exchange-Informationsspeichers gehört das wiederholte Zuweisen, Verwenden und Freigeben von virtuellem Speicher. Häufiges Zuweisen, Verwenden und Freigeben von virtuellem Speicher kann eine Fragmentierung des virtuellen Speichers verursachen. Die Fragmentierung des virtuellen Speichers entspricht der Fragmentierung des Dateisystems, die im Lauf der Zeit auftreten kann. Nach einer gewissen Zeit sind die zugewiesenen Segmente des virtuellen Speichers nicht mehr zusammenhängend, und die Leistung wird beeinträchtigt. Für das Dateisystem können Sie eine Anwendung ausführen, die die Datei defragmentiert. Im Allgemeinen ist dies möglich, während das System online ist und auf das System zugegriffen wird. Bei einer Fragmentierung des virtuellen Speichers gibt es kein Tool zur Defragmentierung. Stattdessen müssen Sie die Microsoft Exchange-Informationsspeicherdienste beenden und neu starten, um das Problem zu beheben, oder das System neu starten.

Wenn ein Exchange Server-Computer über weniger als 32 MB zusammenhängenden freien virtuellen Adressraum verfügt, wird in der Standardeinstellung im Anwendungsereignisprotokoll die folgende Warnung protokolliert:

Quelle: | MSExchangeIS
Kategorie: | Leistung
ID: | 9582
Typ: | Warnung
Beschreibung: | Der für die Ausführung des Exchange-Servers erforderliche virtuelle Speicher ist so fragmentiert, dass die Leistung beeinträchtigt werden kann. Es wird dringend empfohlen, alle Exchange-Dienste neu zu starten, um dieses Problem zu beheben.

Der Registrierungswert VM Warning Level stellt eine Konfigurationsmöglichkeit dar, mit der Administratoren die Standardwarnung der 32-MB-Ebene außer Kraft setzen und einen alternativen Wert einrichten können.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Löschen Sie im rechten Bereich den Wert VM Warning Level.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Weitere Informationen zur Problembehandlung bei der Fragmentierung des virtuellen Speichers in Exchange Server 2003 und Exchange 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 325044, „SO WIRD´S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).


„Mailbox Cache Age Limit" wurde festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-15

Microsoft® Exchange Server Analyzer überprüft die Registrierung des Exchange Server-Computers, um festzustellen, ob der Registrierungseintrag Mailbox Cache Age Limit vorhanden ist. Dieser Registrierungswert befindet sich unter:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Wenn Exchange Server Analyzer feststellt, dass der Registrierungswert Mailbox Cache Age Limit vorhanden und mit einem Wert größer als oder gleich 1 konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Exchange Server lässt das Festlegen von Größenbeschränkungen (Quoten) für Postfächer zu. Quoteneinstellungen werden im Active Directory®-Verzeichnisdienst gespeichert, und Exchange Server liest regelmäßig die Informationen in Active Directory, um festzustellen, ob diese Beschränkungen geändert wurden. In der Standardeinstellungen werden von Exchange Server diese Informationen für einen Zeitraum von zwei Stunden (120 Minuten) im Cache gespeichert. Nach Ablauf dieses Zeitraums werden die Informationen in Active Directory erneut gelesen.

Mithilfe des in Minuten dargestellten Registrierungswerts Mailbox Cache Age Limit wird der Standardzeitraum überschrieben. Er ist insbesondere dann nützlich, wenn ein Benutzer nicht auf sein Postfach zugreifen kann, weil das Postfachlimit erreicht wurde. Wenn das Cache-Standardzeitlimit wirksam ist, ist es dem Benutzer für bis zu zwei Stunden nicht möglich, auf sein Postfach zuzugreifen. Der empfohlene Wert beträgt 20 Minuten. Setzen Sie diesen Wert nicht zu niedrig, da dies zu Leistungsproblemen führen kann.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. Suchen Sie im rechten Bereich den Wert Mailbox Cache Age Limit, und löschen Sie ihn.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Dienst Microsoft Exchange-Informationsspeicher neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Registrierungswert Mailbox Cache Age Limit finden Sie im Knowledge Base-Artikel 327378 „XADM: Exchange 2000 and Exchange Server 2003 Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time; Fix Requires Exchange 2000 SP3" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378).


„Mailbox Cache Idle Limit" wurde festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob der Wert Mailbox Cache Idle Limit vorhanden ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Wenn Exchange Server Analyzer erkennt, dass der Registrierungszweig Mailbox Cache Idle Limit vorhanden ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Exchange Server lässt das Festlegen von Größenbeschränkungen (Quoten) für Postfächer zu. Quoteneinstellungen werden im Active Directory®-Verzeichnisdienst gespeichert, und Exchange Server liest regelmäßig die Informationen in Active Directory, um festzustellen, ob diese Beschränkungen geändert wurden. Exchange Server speichert diese Informationen für einen bestimmten Zeitraum; nach Ablauf dieses Zeitraums werden die Informationen in Active Directory erneut gelesen.

Die Einstellungen von Mailbox Cache Age Limit und Mailbox Cache Idle Limit legen fest, wie lange ein Eintrag im Mailboxcache gespeichert wird. Befindet sich ein Element länger als die im Wert Mailbox Cache Age Limit festgelegte Dauer (in Sekunden) im Cache, wird es entfernt. Außerdem werden Elemente entfernt, die über die im Wert Mailbox Cache Idle Limit hinausgehende Dauer nicht verwendet werden. Die Standardwerte für diese Einstellungen sind 7.200 Sekunden (120 Minuten) für die Einstellung Mailbox Cache Age Limit und 900 Sekunden (15 Minuten) für die Einstellung Mailbox Cache Idle Limit. Der Wert der Einstellung Mailbox Cache Idle Limit darf nicht höher sein als der Wert der Einstellung Mailbox Cache Age Limit.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem.

  3. Suchen Sie im rechten Bereich den Wert Mailbox Cache Idle Limit, und löschen Sie ihn.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Registrierungswert Mailbox Cache Age Limit finden Sie im Knowledge Base-Artikel 327378, „XADM: Exchange 2000 Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time; Fix Requires Exchange 2000 SP3" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378).


„Mailbox Cache Size" wurde festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft ® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob Mailbox Cache Size vorhanden ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Wenn Exchange Server Analyzer erkennt, dass der Registrierungseintrag Mailbox Cache Size vorhanden ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert für „Mailbox Cache Size" legt die Größe des Postfachcache fest. Der Standardwert ist 256 MB. Exchange Server lässt das Festlegen von Größenbeschränkungen (Quoten) für Postfächer zu. Quoteneinstellungen werden im Active Directory®-Verzeichnisdienst gespeichert, und Exchange Server liest regelmäßig die Informationen in Active Directory, um festzustellen, ob diese Beschränkungen geändert wurden. In der Standardeinstellungen werden von Exchange Server diese Informationen für einen Zeitraum von zwei Stunden (7.200 Sekunden) im Cache gespeichert. Nach Ablauf dieses Zeitraums werden die Informationen in Active Directory erneut gelesen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Suchen Sie im rechten Bereich den Wert für „Mailbox Cache Size", und löschen Sie ihn.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://support.microsoft.com/?scid=kb%3Bde%3B256986&x=2&y=12, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Registrierungswert Mailbox Cache Age Limit finden Sie im Knowledge Base-Artikel 327378, „XADM: Exchange 2000 Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time; Fix Requires Exchange 2000 SP3" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378).


Größe des Postfachspeichers ist auf null festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Einstellung des Wertes Mailbox Cache Size zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Wenn Exchange Server Analyzer als Registrierungswert für Mailbox Cache Size 0 ermittelt, wird ein Fehler angezeigt.

Exchange Server lässt das Festlegen von Größenbeschränkungen (Quoten) für Postfächer zu. Quoteneinstellungen werden im Active Directory®-Verzeichnisdienst gespeichert, und Exchange Server liest regelmäßig die Informationen in Active Directory, um festzustellen, ob diese Beschränkungen geändert wurden. Der Wert für Mailbox Cache Size legt die Größe dieses Postfachcaches fest. Der Standardwert ist 256 MB. Wenn 0 festgelegt wurde, ist der Postfachcache ausgeschaltet. Es wird nicht empfohlen, für diesen Wert 0 festzulegen, da die DSAccess-Komponente (Directory Service Access, Verzeichnisdienstzugriff) in diesem Fall mehr Active Directory-Suchvorgänge durchführt. Zudem können bei einem festgelegten Wert von 0 Probleme mit dem Exchange-Speicher und beim Verschieben von Postfächern auftreten.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diesen Fehler

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Suchen Sie im rechten Bereich den Wert für Mailbox Cache Size, und löschen Sie ihn.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Registrierungswert Mailbox Cache Age Limit finden Sie im Knowledge Base-Artikel 327378, „XADM: Exchange 2000 Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time; Fix Requires Exchange 2000 SP3" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378).


Der Postfachspeicher wird durch eine Richtlinie gesteuert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2006-06-06

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs msExchPolicyList für jedes Postfachspeicherobjekt zu ermitteln. Das Attribut msExchPolicyList bestimmt, ob eine Exchange Server-Postfachrichtlinie erstellt und einem Postfachspeicher zugewiesen wurde. Wenn Exchange Server Analyzer feststellt, dass das Attribut msExchPolicyList festgelegt wurde, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Wenn Postfachspeicher erstellt werden, ist ihnen in der Standardeinstellung keine Postfachrichtlinie zugewiesen. Meistens erstellen Administratoren jedoch Postfachrichtlinien und weisen diese mehreren Postfachspeichern zu. Diese Richtlinien wenden administrative Einstellungen an, z. B. Speicherbegrenzungen, Indexaktualisierungen, Wartungsintervalle, Zuordnungen zu öffentlichen Speichern und Offlineadresslisten. Wenn eine Postfachrichtlinie erstellt und einem Postfachspeicher zugewiesen wurde, zeigt Microsoft Exchange Server Analyzer eine Meldung an, dass der Postfachspeicher derzeit von einer Postfachrichtlinie gesteuert wird. Es sind keine zusätzlichen Aktionen erforderlich.

So entfernen Sie eine Postfachrichtlinie aus einem Postfachspeicher

  1. Öffnen Sie den Exchange-System-Manager, und erweitern Sie in der Konsolenstruktur Administrative Gruppen.

  2. Erweitern Sie Erste Administratorgruppe, und wählen Sie dann Systemrichtlinien aus.

  3. Klicken Sie im Ergebnisbereich mit der rechten Maustaste auf Postfachspeicher, und wählen Sie Aus Richtlinie entfernen aus.

  4. Klicken Sie im Exchange-System-Manager-Fenster auf Ja, um das Entfernen des Postfachspeichers zu bestätigen.
Hinweis:
Wenn der Knoten Systemrichtlinien im Exchange-System-Manager in der Konsolenstruktur nicht sichtbar ist, konfigurieren Sie den Exchange-System-Manager für das Anzeigen der administrativen Gruppen.

Weitere Informationen zu Postfachspeicherrichtlinien finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 822938, „How To: Use System Policies to Configure Mailbox Storage Limits in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=822938.

  • 256141, "Erstellen von Systemrichtlinien in Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256141).

Weitere Informationen zu Exchange Server-Datenbankdateien finden Sie in den folgenden Themen zu Exchange Server 2003:

  • „Verwalten von Postfachspeichern und Informationsspeichern für Öffentliche Ordner" im Exchange Server 2003-Administratorhandbuch (http://www.microsoft.com/germany/technet/datenbank/articles/600271.mspx).

  • „Informationen zum Exchange-Informationsspeicher" im Handbuch Arbeiten mit dem Exchange Server 2003-Informationsspeicher (http://www.microsoft.com/downloads/details.aspx?displaylang=de).


Datenbankdatei für Postfachspeicher ist auf Netzlaufwerk gespeichert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs msExchEDBFile für jedes Postfachspeicherobjekt zu ermitteln. Diese Attribut gibt die Position der von diesem Postfachspeicher verwendeten Datenbankdateien an.

Exchange Server Analyzer sendet außerdem eine Abfrage an Active Directory, um die Anzahl der im Attribut homeMDBBL enthaltenen Werte jedes Postfachspeichers auf diesem Server zu bestimmen. Der Zählwert dieses Attributs stellt die Zahl der Postfächer in dem Postfachspeicher dar. Anschließend errechnet Exchange Server Analyzer die Gesamtzahl aller vom Server verwalteten Postfächer.

Stellt Exchange Server Analyzer dabei fest, dass das Attribut msExchEDBFile auf einem Exchange-Server mit mehr als 50 Postfächern mit \\ beginnt, wird ein Fehler angezeigt.

Dieser Fehler zeigt an, dass die Datenbankdateien für einen Postfachspeicher auf dem Netzlaufwerk gespeichert werden. Wenn das Attribut msExchEDBFile mit \\ beginnt, bedeutet dies, dass der Protokolldateipfad ein UNC-Pfad (Universal Naming Convention) ist. Diese Vorgehensweise wird jedoch nicht empfohlen, da sie zu Unterbrechungen der Netzwerkverbindung und damit zu Datenbankfehlern, dem Verlust von Daten oder der Beschädigung von Datenbanken führen kann. Es wird daher empfohlen, dieses Problem so schnell wie möglich zu beheben.

So verschieben Sie die Datenbankdateien auf ein neues Laufwerk

  1. Erweitern Sie im Exchange-System-Manager das Exchange Server-Objekt, auf dem sich der Informationsspeicher befindet. Erweitern Sie dann den entsprechenden Speichergruppencontainer, klicken Sie mit der rechten Maustaste auf das Postfachspeicherobjekt, das Sie verschieben möchten, und klicken Sie dann auf Eigenschaften.

  2. Geben Sie im Dialogfeld Properties auf der Registerkarte Datenbank den neuen Speicherort der Dateien an.

Weitere Informationen zu Exchange Server-Datenbankdateien finden Sie unter den folgenden Themen:

  • „Verwalten von Postfachspeichern und Informationsspeichern für Öffentliche Ordner" im Exchange Server 2003-Administratorhandbuch (http://www.microsoft.com/germany/technet/datenbank/articles/600271.mspx).

  • „Informationen zum Exchange-Informationsspeicher" im Handbuch Arbeiten mit dem Exchange Server 2003-Informationsspeicher (http://www.microsoft.com/downloads/details.aspx?displaylang=de).

Weitere Informationen zum Verwenden von Exchange Server mit Netzlaufwerken finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 328879, „Using Exchange Server with Storage Attached Network and network-attached storage devices" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328879)

  • 839687, „Microsoft support policy on the use of network-attached storage devices with Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839687)

  • 317173, „Exchange Server and network-attached storage" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317173)

  • 317172, „Exchange Server 5.5 and network-attached storage" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317172)


Der Wert für die maximal zulässige Größe der Datenbank des Postfachspeichers wurde festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Registrierungswert Database Size Limit in Gb vorhanden und für Postfachspeicher-Datenbanken konfiguriert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

Wenn Exchange Server Analyzer feststellt, dass der Wert Database Size Limit in Gb vorhanden und konfiguriert ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Beim Anwenden von Exchange Server 2003 Service Pack 2 (SP2) auf Exchange Server 2003 Standard Edition wird die hartcodierte, durch Lizenzierung festgelegte Datenbankgrößenbeschränkung von 16 GB auf 75 GB erhöht. Sie können zum Schutz der Datenbank eine Größenbeschränkung angeben, um eine unerwünschte Zunahme der Datenbankgröße zu verhindern. Der Standardwert für die Größenbeschränkung in SP2 beträgt 18 GB. Dieser Wert kann überschrieben werden, indem der Registrierungswert Database Size Limit in Gb erstellt wird.

Die in Exchange Server 2007 Standard Edition dauerhaft festgelegte Beschränkung der Größe der Lizenzierungsdatenbank von 50 GB kann über die Erstellung des Registrierungswerts Database Size Limit in Gb erhöht werden.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Löschen Sie den Wert Database Size Limit in Gb.

  4. Schließen Sie den Registrierungs-Editor.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zu SP2 für Exchange Server 2003 finden Sie auf der Website zu Exchange Server 2003 Service Pack 2 unter http://go.microsoft.com/fwlink/?LinkId=52073.


Der Postfachspeicher verfügt nicht über einen zugeordneten Standardinformationsspeicher für Öffentliche Ordner
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob das Attribut msExchPrivateMDB über einen Standardspeicher für Öffentliche Ordner verfügt, der dem Postfachspeicher zugeordnet ist.

Das Attribut msExchPrivateMDB ist die Konfiguration für eine private Datenbank für ein Postfachspeicherobjekt. In der Standardeinstellung ist das Attribut msExchHomePublicMDB einem Postfachspeicher zugeordnet. Das Attribut msExchPrivateMDB ist die Öffentliche Stammnachrichtendatenbank (MDB - Message Database).

Wenn Exchange Server Analyzer feststellt, dass das Attribut msExchHomePublicMDB gelöscht wurde oder nicht ordnungsgemäß konfiguriert ist, wird ein Fehler angezeigt.

Jeder Postfachspeicher muss einem Standardspeicher für Öffentliche Ordner zugeordnet sein (entweder auf dem lokalen Server oder auf einem anderen Server). Für jeden postfachaktivierten Benutzer, der von einem Postfachspeicher unterstützt wird, ist der zugeordnete Öffentliche Order-Speicher der Öffentliche Stammordner-Speicher. Verwenden Sie möglichst den Standardspeicher für Öffentliche Ordner auf demselben Server, auf dem sich der Postfachspeicher befindet.

Hinweis:
Wenn Sie den Standardspeicher für Öffentliche Ordner und den Postfachspeicher auf demselben Server verwenden, können Sie möglicherweise die Leistung verbessern, wenn Benutzer auf Öffentliche Ordner zugreifen, und den Fehlerbehebungsvorgang bei Fehlern in Öffentlichen Ordnern vereinfachen.
So weisen Sie einem Postfachspeicher einen Standardspeicher für Öffentliche Ordner zu

  1. Klicken Sie im Exchange-System-Manager mit der rechten Maustaste auf die Speichergruppe, in der sich der Postfachspeicher befindet.

  2. Klicken Sie mit der rechten Maustaste auf den Postfachspeicher, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie im Standardspeicher für Öffentliche Ordner auf der Registerkarte Allgemein auf Durchsuchen, und wählen Sie den Informationsspeicher für Öffentliche Ordner aus, den Sie diesem Postfachspeicher zuweisen möchten.

    Hinweis:
    Wenn Sie einen neuen Postfachspeicher erstellen, wählt Exchange Server automatisch den Standardspeicher für Öffentliche Ordner aus, der der Öffentlichen Ordner-Struktur zugeordnet ist, sowie das Offlineadressbuch, das Benutzer für die Offlineverwendung downloaden.

Weitere Informationen zur Verwaltung von Postfachspeichern und Informationsspeichern für Öffentliche Ordner finden Sie im Exchange Server 2003-Administratorhandbuch (http://www.microsoft.com/germany/technet/datenbank/articles/600271.mspx).


Postfachspeicher überschreitet 12 GB
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2006-02-28

Microsoft® Exchange Server Analyzer fragt die Microsoft Windows®-Verwaltungsinstrumentationsklasse (Windows® Management Instrumentation, WMI) CIM_DataFile ab, um den Wert des Schlüssels FileSize für jede Datenbank- (EDB-Datei) und Streamingdatei (STM-Datei) des Exchange-Postfachspeichers zu bestimmen. Microsoft Exchange Server Analyzer liest auch den folgenden Registrierungszweig, um die installierte Version von Exchange Server zu bestimmen:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<Exchange Product GUID>

Wenn Microsoft Exchange Server Analyzer feststellt, dass eine Datenbankdatei und eine Streamingdatei des Postfachspeichers gemeinsam die Größe von 12 GB auf einem Computer überschreiten, auf dem Microsoft Exchange Server 2003 Standard Edition oder Microsoft Exchange 2000 Server Standard Edition ausgeführt wird, wird eine Warnung angezeigt.

Exchange-Informationsspeicher-Datenbanken in Exchange Server 2003 Standard Edition und Exchange 2000 Server Standard Edition dürfen nicht größer als 16 GB sein. Nach Erreichen dieses Grenzwerts wird kein Postfachspeicher mehr bereitgestellt, und der Zugriff auf Exchange wird verweigert. Exchange-Informationsspeicher-Datenbanken in Exchange Server 2003 Enterprise Edition und Exchange 2000 Server Enterprise Edition sind nicht auf 16 GB beschränkt. Sie sind nur durch die verfügbare Hardware auf eine theoretische Größe von 16 Terabyte beschränkt.

So beheben Sie diese Warnung

  1. Ziehen Sie in Betracht, einige Postfächer aus dem großen Postfachspeicher in einen neuen Postfachspeicher auf diesem oder einem anderen Exchange Server-Computer zu verschieben.

  2. Wenn Sie gerade Postfächer von diesem Informationsspeicher in einen anderen Speicher verschoben haben oder Postfächer aus diesem Postfachspeicher gelöscht haben, führt eine Offlinedefragmentierung möglicherweise zu einer Verringerung der Dateigröße.

  3. Sie können für Postfächer und Nachrichten Größenbegrenzungen festlegen, um ein unbegrenztes Anwachsen des Postfachspeichers zu verhindern.
Hinweis:
Mit der Version von Exchange Server 2003 Service Pack 2 (SP2) wurde für Exchange Server 2003 Standard Edition die hartcodierte, durch Lizenzierung festgelegte Datenbankgrößenbeschränkung von 16 GB auf 75 GB erhöht. Der Administrator kann zum Schutz der Datenbank eine Größenbeschränkung festlegen (um eine unerwünschte Zunahme der Datenbankgröße zu verhindern). Der Standardwert in SP2 für Standard Edition ist 18 GB. Der Standardwert 18 GB kann durch Bearbeiten des Registrierungsschlüssels Database Size Limit in Gb überschrieben werden.
Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So konfigurieren Sie die Datenbankgrößenbeschränkung für eine Datenbank unter Exchange Server 2003 SP2

  1. Starten Sie auf dem Computer, auf dem Exchange Server ausgeführt wird, die Datei Regedit.exe.

  2. Öffnen Sie den folgenden Registrierungsschlüssel: HKLM\System\CurrentControlSet\Services\MSExchangeIS\Servername\GUID des privaten Postfachspeichers

  3. Klicken Sie mit der rechten Maustaste auf GUID des privaten Postfachspeichers, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  4. Geben Sie für den neuen Wertnamen Database Size Limit in Gb ein.

  5. Doppelklicken Sie auf Database Size Limit in Gb. Geben Sie unter Wert einen entsprechenden Wert für die maximale Datenbankgröße in GB ein. Geben Sie für Exchange Server 2003 Standard Edition einen Dezimalwert zwischen 1 und 75 ein (der Standardwert beträgt 18 GB). Geben Sie für Exchange Server 2003 Enterprise Edition einen Dezimalwert zwischen 1 und 8000 ein (der Standardwert beträgt 8000 GB). Klicken Sie auf OK.

  6. Klicken Sie mit der rechten Maustaste auf GUID des privaten Postfachspeichers, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  7. Geben Sie für den neuen WertnamenDatabase Size Buffer in Percentage ein.

  8. Doppelklicken Sie auf Database Size Buffer in Percentage. Geben Sie unter Wert einen Dezimalwert zwischen 1 und 100 ein. Mit diesem Wert geben Sie an, ab welchem Zeitpunkt Ereignisse protokolliert werden sollen, um Sie zu warnen, dass der Wert für die maximale Größe der Datenbank bald erreicht wird. Beim Standardwert 10 werden Warnereignisse protokolliert, sobald nur noch 10 % der Kapazität verfügbar sind, bevor die maximale Größe für die Datenbank erreicht wird. Klicken Sie auf OK.

  9. Klicken Sie mit der rechten Maustaste auf GUID des privaten Postfachspeichers, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  10. Geben Sie für den neuen Namen Database Size Check Start Time in Hours From Midnight ein.

  11. Doppelklicken Sie auf Database Size Check Start Time in Hours From Midnight. Geben Sie unter Wert einen Wert zwischen 0 und 23 ein, um anzugeben, wann die Datenbankgröße von Exchange überprüft werden soll. Beim Standardwert 5 wird die Datenbankgröße 5 Stunden nach 0:00 Uhr (5:00 Uhr) von Exchange Server überprüft. Klicken Sie auf OK.

  12. Schließen Sie den Registrierungs-Editor.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zu STM- und EDB-Dateien finden Sie im Microsoft Knowledge Base-Artikel 232323, „Native Content Storage in Microsoft Exchange" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323.

Weitere Informationen zum Verschieben von Postfächern in Exchange Server 2003 finden Sie im Knowledge Base-Artikel 821829, „Moving Mailboxes in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829.

Weitere Informationen zum Verschieben von Postfächern in Exchange 2000 Server finden Sie im Knowledge Base-Artikel 328810, „Moving mailboxes between servers" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810.

Weitere Informationen zum Durchführen von Offlinedefragmentierungen von ExchangeServer-Datenbanken finden Sie im Knowledge Base-Artikel 328804, „So defragmentieren Sie Exchange-Datenbanken" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804.

Weitere Informationen zum Festlegen von Größenbegrenzungen für Nachrichten finden Sie im Knowledge Base-Artikel 322679, „How to set size limits for messages in Exchange Server" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679.

Informationen zum Erreichen der maximalen Datenbankgröße in Exchange Server 2003 Standard Edition oder Microsoft Exchange 2000 Server Standard Edition finden Sie im Knowledge Base-Artikel 828070, „Exchange Server-Postfachspeicher wird nicht bereitgestellt, wenn die Postfachspeicher-Datenbank das 16-GB-Limit erreicht" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070.

Weitere Informationen zu SP2 für Exchange Server 2003 finden Sie auf der Website zu Exchange Server 2003 Service Pack 2 unter http://go.microsoft.com/fwlink/?LinkId=52073.


Postfachspeicher überschreitet 15 GB
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2006-02-28

Microsoft® Exchange Server Analyzer fragt die Microsoft Windows®-Verwaltungsinstrumentationsklasse (Windows® Management Instrumentation, WMI) CIM_DataFile ab, um den Wert des Schlüssels FileSize für jede Datenbank- (EDB-Datei) und Streamingdatei (STM-Datei) des Exchange-Postfachspeichers zu bestimmen. Microsoft Exchange Server Analyzer liest auch den folgenden Registrierungszweig, um die installierte Version von Exchange Server zu bestimmen:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<GUID des Exchange-Produkts>

Wenn Exchange Server Analyzer feststellt, dass eine Datenbankdatei und eine Streamingdatei des Postfachspeichers gemeinsam die Größe von 15 GB auf einem Computer überschreiten, auf dem Microsoft Exchange Server 2003 Standard Edition oder Microsoft Exchange 2000 Server Standard Edition ausgeführt wird, wird ein Fehler angezeigt.

Exchange-Informationsspeicher-Datenbanken in Exchange Server 2003 Standard Edition und Exchange 2000 Server Standard Edition dürfen nicht größer als 16 GB sein. Nach Erreichen dieses Grenzwerts wird kein Postfachspeicher mehr bereitgestellt, und der Zugriff auf Exchange wird verweigert. Exchange-Informationsspeicher-Datenbanken in Exchange Server 2003 Enterprise Edition und Exchange 2000 Server Enterprise Edition sind nicht auf 16 GB beschränkt. Sie sind nur durch die verfügbare Hardware auf eine theoretische Größe von 16 Terabyte beschränkt.

So beheben Sie diesen Fehler

  1. Ziehen Sie in Betracht, einige Postfächer aus dem großen Postfachspeicher in einen neuen Postfachspeicher auf diesem oder einem anderen Exchange Server-Computer zu verschieben.

  2. Wenn Sie gerade Postfächer von diesem Informationsspeicher in einen anderen Speicher verschoben haben oder Postfächer aus diesem Postfachspeicher gelöscht haben, führt eine Offlinedefragmentierung möglicherweise zu einer Verringerung der Dateigröße.

  3. Sie können für Postfächer und Nachrichten Größenbegrenzungen festlegen, um ein unbegrenztes Anwachsen des Postfachspeichers zu verhindern.
Hinweis:
Mit der Version von Exchange Server 2003 Service Pack 2 (SP2) wurde für Exchange Server 2003 Standard Edition die hartcodierte, durch Lizenzierung festgelegte Datenbankgrößenbeschränkung von 16 GB auf 75 GB erhöht. Der Administrator kann zum Schutz der Datenbank eine Größenbeschränkung festlegen (um eine unerwünschte Zunahme der Datenbankgröße zu verhindern). Der Standardwert in SP2 für Standard Edition beträgt 18 GB. Der Standardwert 18 GB kann durch Bearbeiten des Registrierungsschlüssels Database Size Limit in GB überschrieben werden.
Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So konfigurieren Sie die Datenbankgrößenbeschränkung für eine Datenbank unter Exchange Server 2003 SP2

  1. Starten Sie auf dem Computer, auf dem Exchange Server ausgeführt wird, die Datei Regedit.exe.

  2. Öffnen Sie den folgenden Registrierungsschlüssel: HKLM\System\CurrentControlSet\Services\MSExchangeIS\Servername\GUID des privaten Postfachspeichers

  3. Klicken Sie mit der rechten Maustaste auf GUID des privaten Postfachspeichers, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  4. Geben Sie für den neuen Wertnamen Database Size Limit in Gb ein.

  5. Doppelklicken Sie auf Database Size Limit in Gb. Geben Sie unter Wert einen entsprechenden Wert für die maximale Datenbankgröße in GB ein. Geben Sie für Exchange Server 2003 Standard Edition einen Dezimalwert zwischen 1 und 75 ein (der Standardwert beträgt 18 GB). Geben Sie für Exchange Server 2003 Enterprise Edition einen Dezimalwert zwischen 1 und 8000 ein (der Standardwert beträgt 8000 GB). Klicken Sie auf OK.

  6. Klicken Sie mit der rechten Maustaste auf GUID des privaten Postfachspeichers, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  7. Geben Sie für den neuen WertnamenDatabase Size Buffer in Percentage ein.

  8. Doppelklicken Sie auf Database Size Buffer in Percentage. Geben Sie unter Wert einen Dezimalwert zwischen 1 und 100 ein. Mit diesem Wert geben Sie an, ab welchem Zeitpunkt Ereignisse protokolliert werden sollen, um Sie zu warnen, dass der Wert für die maximale Größe der Datenbank bald erreicht wird. Beim Standardwert 10 werden Warnereignisse protokolliert, sobald nur noch 10 % der Kapazität verfügbar sind, bevor die maximale Größe für die Datenbank erreicht wird. Klicken Sie auf OK.

  9. Klicken Sie mit der rechten Maustaste auf GUID des privaten Postfachspeichers, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  10. Geben Sie für den neuen Namen Database Size Check Start Time in Hours From Midnight ein.

  11. Doppelklicken Sie auf Database Size Check Start Time in Hours From Midnight. Geben Sie unter Wert einen Wert zwischen 0 und 23 ein, um anzugeben, wann die Datenbankgröße von Exchange überprüft werden soll. Beim Standardwert 5 wird die Datenbankgröße 5 Stunden nach 0:00 Uhr (5:00 Uhr) von Exchange Server überprüft. Klicken Sie auf OK.

  12. Schließen Sie den Registrierungs-Editor.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zu STM- und EDB-Dateien finden Sie im Microsoft Knowledge Base-Artikel 232323, „Native Content Storage in Microsoft Exchange" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323.

Weitere Informationen zum Verschieben von Postfächern in Exchange Server 2003 finden Sie im Knowledge Base-Artikel 821829, „Moving Mailboxes in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829.

Weitere Informationen zum Verschieben von Postfächern in Exchange 2000 Server finden Sie im Knowledge Base-Artikel 328810, „Moving mailboxes between servers" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810.

Weitere Informationen zum Durchführen von Offlinedefragmentierungen von Exchange Server-Datenbanken finden Sie im Knowledge Base-Artikel 328804, „So defragmentieren Sie Exchange-Datenbanken", unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804.

Weitere Informationen zum Festlegen von Größenbegrenzungen für Nachrichten finden Sie im Knowledge Base-Artikel 322679, „How to set size limits for messages in Exchange Server" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679.

Informationen zum Erreichen der maximalen Datenbankgröße in Exchange Server 2003 Standard Edition und Exchange 2000 Server Standard Edition finden Sie im Knowledge Base-Artikel 828070, „Exchange Server-Postfachspeicher wird nicht bereitgestellt, wenn die Postfachspeicher-Datenbank das 16-GB-Limit erreicht" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070.

Weitere Informationen zu SP2 für Exchange Server 2003 finden Sie auf der Website zu Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52073).


Für den Postfachspeicher wurde mehr als 8 Tage lang keine vollständige Sicherung durchgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer fragt jeden Postfachspeicher ab, um das Datum und die Uhrzeit der letzten vollständigen Sicherung zu ermitteln. Microsoft Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um die Anzahl der Benutzer mit Postfächern in den einzelnen Postfachspeichern zu ermitteln. Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen erfüllt sind:

  • Die Anzahl der Tage seit der letzten vollständigen Sicherung des Postfachspeichers ist größer als acht.

  • Im Postfachspeicher sind mehr als zehn Postfächer vorhanden.

Der Postfachspeicher ist eine Datenbank zum Speichern von Postfächern in Microsoft Exchange Server 2003 und Exchange Server 2007. Ein Postfachspeicher besteht aus einer EDB-Datei (Rich-Text) und einer STM-Datei (Streaming Native Internet Content) mit Internetinhalten. Die zwei Dateien, die EDB-Datei und die STM-Datei, stellen die zwei Hälften einer einzigen Datenbank und keine separaten Datenbanken dar.

Die Daten des Postfachspeichers und des Informationsspeichers für Öffentliche Ordner in Ihren Exchange Server-Datenbanken und Transaktionsprotokolldateien sind die Daten, deren Sicherung in Ihrer Exchange Server-Organisation am wichtigsten sind. Sie können die Sicherung einer Exchange Server-Datenbank zum Wiederherstellen eines beschädigten Postfachspeichers auf einem funktionstüchtigen Server verwenden, der Exchange Server ausführt. Außerdem können Sie Sicherungen von Exchange Server-Datenbanken zum Wiederherstellen Ihrer Exchange Server-Datenbanken auf einem anderen Server verwenden.

Als optimale Methode sollten Sie täglich eine vollständige Sicherung Ihrer Datenbankdateien und Transaktionsprotokolle durchführen. Nach dem Abschluss einer vollständigen Sicherung einer Speichergruppe werden die übermittelten Transaktionsprotokolldateien in den Exchange Server-Datenbanken vom Server gelöscht. Durch eine vollständige Sicherung wird im Fall einer Wiederherstellung ein Geschwindigkeitsvorteil erreicht, da Sie zum Wiederherstellen sämtlicher Daten nur ein Band benötigen.

Hinweis:
Die optimale Methode besteht darin, die Transaktionsprotokolldateien auf einem speziell dafür vorgesehenen Datenträger separat von den Datenbankdateien aufzubewahren. Diese Vorgehensweise stellt Fehlertoleranz im Falle von Beschädigungen des Datenbankdatenträgers sicher und verbessert sogar in manchen Fällen die Leistung der Datenbank.
Wichtig:
Wenn Sie versuchen, Dateien oder Ordner zu sichern oder wiederherzustellen, müssen Sie über die erforderlichen Berechtigungen für das Benutzerkonto verfügen, an dem Sie angemeldet sind. Zum Erstellen von Exchange Server-Sicherungen müssen Sie über Bedienerberechtigungen zum Sichern auf Domänenebene verfügen. Zum Erstellen von Sicherungen unter Microsoft Windows Server 2003 müssen Sie mindestens über lokale Bedienerberechtigungen zum Sichern verfügen.

Die Sicherungsstrategie, die Sie für Ihre Exchange Server-Daten auswählen, hängt von der Größe der Speicher, der Geschwindigkeit der Sicherungssoftware und -hardware, der Hardwarekapazität und den zeitlichen Anforderungen ab.

Weitere Informationen zu Sicherungsstrategien und Wiederherstellungsoperationen finden Sie unter:

  • Exchange Server 2003-Handbuch zur Wiederherstellung nach Datenverlust (http://go.microsoft.com/fwlink/?LinkId=47570).

  • Database Backup and Restore (http://go.microsoft.com/fwlink/?LinkId=80766).


Für den Postfachspeicher wurde mehr als 60 Tage lang keine vollständige Sicherung durchgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer fragt jeden Postfachspeicher ab, um das Datum und die Uhrzeit der letzten vollständigen Sicherung zu ermitteln. Microsoft Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um die Anzahl der Benutzer mit Postfächern in den einzelnen Postfachspeichern zu ermitteln. Exchange Server Analyzer zeigt einen Fehler an, wenn beide der folgenden Bedingungen erfüllt sind:

  • Die Anzahl der Tage seit der letzten vollständigen Sicherung des Postfachspeichers beträgt mehr als 60 Tage.

  • Im Postfachspeicher sind mehr als 10 Postfächer vorhanden.

Der Postfachspeicher ist eine Datenbank zum Speichern von Postfächern in Microsoft Exchange Server 2003 und Microsoft Exchange Server 2007. Ein Postfachspeicher besteht aus einer EDB-Datei (Rich-Text) und einer STM-Datei (Streaming Native Internet Content) mit Internetinhalten. Die zwei Dateien, die EDB-Datei und die STM-Datei, stellen die zwei Hälften einer einzigen Datenbank und keine separaten Datenbanken dar.

Die Daten des Postfachspeichers und des Informationsspeichers für Öffentliche Ordner in Ihren Exchange Server-Datenbanken und Transaktionsprotokolldateien sind die Daten, deren Sicherung in Ihrer Exchange Server-Organisation am wichtigsten ist. Sie können die Sicherung einer Exchange Server-Datenbank zum Wiederherstellen eines beschädigten Postfachspeichers auf einem funktionstüchtigen Server verwenden, der Exchange Server ausführt. Außerdem können Sie mithilfe der Sicherungen von Exchange Server-Datenbanken Ihre Exchange Server-Datenbanken auf einem anderen Server wiederherstellen.

Es wird empfohlen, täglich eine vollständige Sicherung Ihrer Datenbankdateien und Transaktionsprotokolle durchzuführen. Nach dem Durchführen einer vollständigen Sicherung einer Speichergruppe werden die übermittelten Transaktionsprotokolldateien in den Exchange Server-Datenbanken vom Server gelöscht. Durch eine vollständige Sicherung wird im Fall einer Wiederherstellung ein Geschwindigkeitsvorteil erreicht, da Sie zum Wiederherstellen sämtlicher Daten nur ein Band benötigen.

Hinweis:
Die optimale Methode besteht darin, die Transaktionsprotokolldateien auf einem speziell dafür vorgesehenen Datenträger separat von den Datenbankdateien aufzubewahren. Diese Vorgehensweise stellt Fehlertoleranz im Falle von Beschädigungen des Datenbankdatenträgers sicher und verbessert sogar in manchen Fällen die Leistung der Datenbank.
Wichtig:
Wenn Sie versuchen, Dateien oder Ordner zu sichern oder wiederherzustellen, müssen Sie über die erforderlichen Berechtigungen für das Benutzerkonto verfügen, an dem Sie angemeldet sind. Zum Erstellen von Exchange Server-Sicherungen müssen Sie über Bedienerberechtigungen zum Sichern auf Domänenebene verfügen. Zum Erstellen von Sicherungen unter Microsoft Windows Server™ 2003 müssen Sie mindestens über lokale Bedienerberechtigungen für Sicherungen verfügen.

Die Sicherungsstrategie, die Sie für Ihre Exchange Server-Daten auswählen, hängt von der Größe der Speicher, der Geschwindigkeit der Sicherungssoftware und -hardware, der Hardwarekapazität und den zeitlichen Anforderungen ab.

Weitere Informationen zu Sicherungsstrategien und Wiederherstellungsoperationen finden Sie unter:

  • Exchange Server 2003-Handbuch zur Wiederherstellung nach Datenverlust (http://go.microsoft.com/fwlink/?LinkId=47570).

  • Database Backup and Restore (http://go.microsoft.com/fwlink/?LinkID=80766).


Die Onlinewartungszeitpläne zur Postfachspeicherung überschneiden sich.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob alle Postfachspeicher in der Speichergruppe denselben Wartungszeitplan haben. Wenn der Speichergruppencontainer (Klasse msExchStorageGroup) über zwei oder mehr Postfachspeicher-Objekte verfügt (Klasse msExchPrivMDB), überprüft Exchange Server Analyzer das Attribut activationSchedule für jedes Postfachspeicherobjekt. Wenn Microsoft Exchange Server Analyzer feststellt, dass diese Werte (gespeichert als Oktettzeichenfolgen) für alle Postfachspeicher identisch sind oder dass sie sich überschneiden, wird eine Warnung angezeigt.

In der Standardeinstellung werden die Postfachspeicher-Wartungsvorgänge nachts von 01:00 bis 05:00 Uhr ausgeführt. Aufgrund der für die Wartungsvorgänge erforderlichen Serverressourcen wird es empfohlen, die Wartungszeitpläne zu ändern, sodass die Zeitpläne der Postfachspeicher sich um mindestens 15 Minuten unterscheiden.

So vermeiden Sie diese Warnung in Exchange 2000 Server und Exchange Server 2003

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Server, und erweitern Sie dann den Server, mit dem gearbeitet werden soll.

  3. Erweitern Sie die Speichergruppe, mit der Sie arbeiten möchten.

  4. Klicken Sie mit der rechten Maustaste auf den Speicher, mit dem Sie arbeiten möchten, und klicken Sie dann auf Eigenschaften.

  5. Klicken Sie auf der Registerkarte Datenbank auf Wartungsintervall, und klicken Sie auf ein neues Intervall. Sie können auch auf Anpassen klicken, um einen benutzerdefinierten Zeitplan zu erstellen.

So vermeiden Sie diese Warnung in Exchange Server 2007

  1. Öffnen Sie die Exchange-Verwaltungskonsole.

  2. Erweitern Sie Serverkonfiguration und dann den Server, mit dem Sie arbeiten möchten.

  3. Erweitern Sie die Speichergruppe, mit der Sie arbeiten möchten.

  4. Klicken Sie mit der rechten Maustaste auf den Informationsspeicher, mit dem Sie arbeiten möchten, und klicken Sie dann auf Eigenschaften.

  5. Klicken Sie auf der Registerkarte Allgemein auf die Dropdownliste Wartungsintervall, und wählen Sie ein neues Intervall aus. Sie können auch auf Anpassen klicken, um einen benutzerdefinierten Zeitplan zu erstellen.

Weitere Informationen zur Exchange Server 2003-Speicherwartung finden Sie im Exchange Server 2003-Administratorhandbuch unter „Konfigurieren der Wartungs- und Sicherungsoptionen für Informationsspeicher" (http://go.microsoft.com/fwlink/?LinkId=47617).


Die Grenzwerte für das Nichtzulassen von Sendevorgängen und Empfangsvorgängen für den Postfachspeicher sind zu ähnlich.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um die für ein Postfach festgelegte Größenbegrenzung zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass der Unterschied zwischen den Postfachbegrenzungen Prohibit send und Prohibit send and receive weniger als 20 Prozent beträgt, zeigt Microsoft Exchange Server Analyzer eine Meldung mit der optimalen Methode zur Konfiguration an.

Die optimale Methode besteht darin, die Begrenzungen für Prohibit send und Prohibit send and receive mit mindestens 20 Prozent Unterschied festzulegen. Wenn der Unterschied zwischen den Begrenzungen weniger als 20 Prozent beträgt, hat der Benutzer des Postfachs möglicherweise nicht ausreichend Zeit, das Postfach zu leeren, bevor Nachrichten vom Postfach abgelehnt werden. Wenn Benutzer beispielsweise keine Nachrichten mehr senden dürfen, sobald ihr Postfach 100 MB erreicht, sollte die Begrenzung Prohibit send and receive mindestens 120 MB betragen.

Hinweis:
Außerdem ist es wichtig, für die Postfächer ein Warnungslimit festzulegen. Wenn für das Postfach das Warnungslimit erreicht wird, wird eine E-Mail-Nachricht an den Benutzer gesendet, in der er darauf hingewiesen wird, dass die in der Begrenzung Prohibit send für das Postfach definierte Begrenzung fast erreicht ist.

Um dieses Problem zu beheben, sollten Sie den Unterschied zwischen den Postfachbegrenzungen Prohibit send und Prohibit send and receive auf mehr als 20 Prozent erhöhen.

So legen Sie Grenzwerte für Postfächer fest

  1. Öffnen Sie den Exchange-System-Manager.

  2. Suchen Sie den Postfachspeicher, der in der Nachricht von Microsoft Exchange Server Analyzer angegeben ist.

  3. Klicken Sie mit der rechten Maustaste auf Postfachspeichername, und wählen Sie Eigenschaften aus.

  4. Wählen Sie die Registerkarte Grenzwerte aus.

  5. Ändern Sie eine oder beide der Begrenzungen Senden verbieten ab (KB) und Senden und Empfangen verbieten ab (KB).

  6. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.
So legen Sie in Exchange Server 2007 mithilfe der Exchange-Verwaltungskonsole Postfachbegrenzungen fest

  1. Öffnen Sie die Exchange-Verwaltungskonsole.

  2. Suchen Sie den Postfachspeicher, der in Exchange Server Analyzer zu diesem Problem angegeben ist.

  3. Klicken Sie mit der rechten Maustaste auf Postfachspeichername, und wählen Sie Eigenschaften aus.

  4. Wählen Sie die Registerkarte Grenzwerte aus.

  5. Ändern Sie die Grenzwerte Warnmeldung senden ab (KB), Senden verbieten ab (KB) und Senden/Empfangen verbieten ab (KB).

  6. Klicken Sie auf Übernehmen und dann auf OK.
So legen Sie in Exchange Server 2007 mithilfe der Exchange-Verwaltungsshell Postfachbegrenzungen fest

  1. Das folgende Beispiel zeigt, wie die Postfachgröße festgelegt wird, ab der eine Warnmeldung an den Benutzer gesendet wird. Dieses Attribut gilt für alle Postfächer in dieser Postfachdatenbank, für die kein eigenes Attribut zur Überschreitungswarnung festgelegt ist. Sie müssen entweder eine ganze Zahl oder "Unbegrenzt" angeben. Der Standardwert ist 1,9 GB.
Code kopieren
Set-MailboxDatabase "Mailbox Database Name" -IssueWarningQuota 1991680
  1. Das folgende Beispiel zeigt, wie die Größe des Postfachs festgelegt wird, ab der Benutzer, die Postfächern in dieser Postfachdatenbank zugeordnet sind, keine Nachrichten mehr senden können. Dieses Attribut gilt für alle Postfächer in dieser Postfachdatenbank, für die keine eigenen Attribute für das Kontingent für "Senden verbieten" festgelegt sind. Der Grenzwert muss entweder als ganze Zahl oder "Unbegrenzt" festgelegt werden.

Code kopieren
Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendQuota 2097152
  1. Das folgende Beispiel zeigt, wie die Größe des Postfachs angegeben wird, ab der der diesem Postfach zugeordnete Benutzer keine Nachrichten mehr senden oder empfangen kann. Dieses Attribut gilt für alle Postfächer in dieser Postfachdatenbank, für die keine eigenen Attribute für das Kontingent für "Empfangen verbieten" festgelegt sind. Sie müssen entweder eine ganze Zahl oder "Unbegrenzt" angeben.

Code kopieren
Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendReceiveQuota 2411520

Weitere Informationen zur Verwaltung von Exchange-Postfächern finden Sie unter Working with Exchange Server 2003 Stores (http://go.microsoft.com/fwlink/?LinkId=47595).

Weitere Informationen zum Verwalten von Exchange-Postfachbegrenzungen in Exchange Server 2007 finden Sie unter "How to Configure Database Limits and Properties" (http://go.microsoft.com/fwlink/?LinkID=80746).


Der Postfachspeicher wird beim Start nicht bereitgestellt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer sendet eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert des Attributs msExchEDBOffline für alle Objekte mit der Klasse msExchPrivateMDB zu bestimmen. Objekte mit dieser Klasse sind Postfachspeicher.

Der Wert True für das Attribut msExchEDBOffline zeigt an, dass der Postfachspeicher beim Start von Microsoft Exchange-Informationsspeicherdienst nicht automatisch bereitgestellt wird. Der Wert False zeigt an, dass der Postfachspeicher beim Start bereitgestellt wird. Stellt Exchange Server Analyzer fest, dass der Wert für dieses Attribut True ist, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass das Kontrollkästchen Diesen Informationsspeicher beim Start nicht bereitstellen aktiviert ist. Dieses Kontrollkästchen befindet sich im Dialogfeld Eigenschaften des Postfachspeichers auf der Registerkarte Datenbank. Wenn das Kontrollkästchen aktiviert ist, wird der Postfachspeicher beim Start von Microsoft Exchange-Informationsspeicherdienst nicht automatisch bereitgestellt. Wenn Microsoft Exchange-Informationsspeicherdienst das nächste Mal gestartet wird, z. B. nachdem der Server erneut gestartet wurde, wird ein Postfachspeicher, für den dieses Attribut auf True festgelegt ist, nicht bereitgestellt. Es wird empfohlen, Postfachspeicher automatisch bereitzustellen, wenn der Microsoft Exchange-Informationsspeicherdienst gestartet wird.

So vermeiden Sie diese Warnung in Exchange 2000 Server und Exchange Server 2003

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Server. Erweitern Sie dann den Server mit dem Postfachspeicher, den Sie ändern möchten.

  3. Erweitern Sie die Speichergruppe, die den Postfachspeicher enthält, den Sie ändern möchten.

  4. Klicken Sie mit der rechten Maustaste auf den Postfachspeicher, und klicken Sie dann auf Eigenschaften.

  5. Deaktivieren Sie auf der Registerkarte Datenbank das Kontrollkästchen Diesen Informationsspeicher beim Start nicht bereitstellen.

  6. Klicken Sie zum Speichern der Einstellung auf OK.

  7. Schließen Sie den Exchange-System-Manager.

So vermeiden Sie diese Warnung in Exchange Server 2007

  1. Öffnen Sie die Exchange-Verwaltungskonsole.

  2. Erweitern Sie Serverkonfiguration und dann den Server, mit dem Sie arbeiten möchten.

  3. Erweitern Sie die Speichergruppe, mit der Sie arbeiten möchten.

  4. Klicken Sie mit der rechten Maustaste auf die Datenbank, mit der Sie arbeiten möchten, und klicken Sie dann auf Eigenschaften.

  5. Deaktivieren Sie auf der Registerkarte Allgemein das Kontrollkästchen Diese Datenbank beim Start nicht bereitstellen.

  6. Klicken Sie zum Speichern der Einstellung auf OK.

  7. Schließen Sie die Exchange-Verwaltungskonsole.

Weitere Informationen zu dieser Option finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 314218, „HOW TO: Turn Off or Turn On Automatic Mounting of Data Stores at Startup in Exchange 2000 Server" (http://support.microsoft.com/kb/314218/en-us)

  • 285169, „XADM: Information Stores Do Not Mount After You Use the "/disasterrecovery" Switch" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285169)


Der Parameter „Max FXGetBuffer Users" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft ® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob der Registrierungsschlüssel Max FXGetBuffer Users erstellt wurde:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Wenn Exchange Server Analyzer erkennt, dass der Registrierungsschlüssel Max FXGetBuffer Users unter ParametersSystem erstellt wurde, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Mithilfe des Registrierungsschlüssels Max FXGetBuffer Users können Sie die Anzahl der Microsoft Office Outlook® 2003-Clients bestimmen, die gleichzeitig eine Synchronisierung mit einem Exchange Server 2003-Server ausführen. Sie können den Wert des Registrierungsschlüssels Max FXGetBuffer Users festlegen, um den Grenzwert für von Outlook-Clients hergestellte gleichzeitige RPC-Verbindungen (Remoteprozeduraufruf) zu überschreiben. Diese Verbindungen werden manchmal als ropFXSrcGetBuffers bezeichnet. Der Standardwert des Registrierungsschlüssels Max FXGetBuffer Users wird berechnet, indem Sie die Anzahl der Prozessoren auf dem Server mit 2 multiplizieren und anschließend 3 addieren. Beispielsweise beträgt der Standardwert für einen Exchange Server 2003-Server mit zwei Prozessoren 7 ([2*2] + 3=7).

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Löschen Sie den Wert Max FXGetBuffer Users.

  4. Schließen Sie den Registrierungs-Editor.

Der Microsoft Exchange-Informationsspeicherdienst erkennt innerhalb weniger Minuten die Änderungen. Sie müssen den Computer nicht neu starten.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Festlegen von Registrierungsschlüsseln zum Steuern der Anzahl der Outlook-Clients, die eine Synchronisierung mit Exchange Server 2003 ausführen können, finden Sie im Knowledge Base-Artikel 818484, „Registry Values and Counters That You Can Use to Configure and Monitor Outlook Client Synchronization" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484.


Maximale Anlagenanzahl je Nachrichtenübertragung wurde geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob die in der Standardeinstellung vorgegebene maximale Anlagenanzahl pro Nachrichtenübermittlung geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtAttachment

Wenn Exchange Server Analyzer feststellt, dass der Registrierungswert objtAttachment vorhanden ist und mit einem Wert konfiguriert wurde, der von dem in der folgenden Tabelle abweicht, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Eintrag | Exchange Server 2003 RTM - Standardwert | Exchange Server 2003 SP1 und höher - Standardwert | Exchange Server 2007 - Standardwert
objtAttachment | 100 | 500 | 500

Wenn der Registrierungswert objtAttachment manuell hinzugefügt und konfiguriert wird, bestimmt er die maximale Anlagenanzahl je Nachrichtenübermittlung pro MAPI-Client. Wenn ein MAPI-Client versucht, eine Nachricht mit mehr als der zulässigen Anzahl von Anlagen zu senden, wird im Anwendungsereignisprotokoll auf dem Computer mit Exchange Server, der das Postfach des Clients enthält, das folgende Ereignis protokolliert:

Ereignistyp: | Fehler
Ereignis-ID: | 9646
Ereignisquelle: | MSExchangeIS
Ereigniskategorie: | Allgemein
Beschreibung: | Beenden der Mapi-Sitzung „/o=OrganizationName/ou=AdministrativeGroupName/cn=Recipients/cn=UserName" wegen Überschreitung der Maximalanzahl von xxx Objekten des Typs „objtAttachment"

Der Registrierungswert objtAttachment stellt eine Konfigurierungsmöglichkeit dar, die dem Administrator größere Steuerungsmöglichkeiten über die von MAPI-Clients verwendeten Exchange Server-Ressourcen bietet.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. Löschen Sie den Registrierungswert objtAttachment.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Wenn Sie den Registrierungswert objtAttachment weiterhin verwenden möchten, anstatt ihn zu löschen, behalten Sie den bisherigen Wert bei, oder passen Sie ihn nach Bedarf an.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986.

Weitere Informationen finden Sie im Knowledge Base-Artikel 830829, „Your Exchange Server 2003 computer may stop responding after a MAPI client opens more than the default value of certain server objects" unter (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829).


Maximale Anzahl zwischengespeicherter Ansichten wurde geändert
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob die maximale Anzahl zwischengespeicherter Ansichten pro Datenbank geändert wurde. Wenn Exchange Server Analyzer feststellt, dass der Standardwert 11 für das Attribut msExchMaxCachedViews geändert wurde, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht. Die konfigurierte Anzahl der zwischengespeicherten Ansichten pro Datenbank ist in der Ausgabe von Microsoft Exchange Server Analyzer enthalten. Eine optimale Methode besteht darin, fünf bis 20 zwischengespeicherte Ansichten zuzulassen.

msExchMaxCachedViews ist ein Attribut der Objektklasse msExchangePrivateMDB. Daher verfügt jedes Postfach-Datenbankspeicherobjekt in Active Directory über einen Attributwert msExchMaxCachedViews. Der Attributwert msExchMaxCachedViews gibt die maximale Anzahl der Ansichten an, die für einen bestimmten Ordner in einem Postfach zwischengespeichert werden. In diesem Kontext verweist „Ansicht" auf die Ordner, die angezeigt werden, wenn ein Benutzer auf ein Microsoft Office Outlook® 2003-Postfach eines anderen Benutzers zugreift. Wenn Benutzer mit anderen Benutzern gemeinsam auf einen Outlook-Ordner zugreifen, generiert Exchange Server eine Ansicht, in der private Elemente ausgeblendet werden.

Wenn ein Outlook-Benutzer zum ersten Mal den Kalender, den Kontaktordner oder andere Daten eines anderen Benutzers anzeigt, kann es bei der Anzeige zu Verzögerungen kommen. Nach der erstmaligen Anzeige kann bei nachfolgenden Versuchen die Anzeige schneller erfolgen. Nach einer gewissen Zeit wird die Anzeige jedoch wieder verzögert, wenn der Benutzer versucht, erneut auf den Ordner zuzugreifen. Die Verzögerung macht sich am stärksten bemerkbar, wenn der Ordner sehr viele Elemente enthält. Das ist der Fall, wenn im Ordner über 5000 Elemente enthalten sind.

Bei der Generierung einer Ansicht auf einen Ordner werden Suchordner im Exchange-Speicher für jeden einzelnen Benutzer erstellt, der auf den Outlook-Ordner zugreift. Wenn ein Suchordner erstellt wird, wird er für spätere Verwendungen zwischengespeichert. Bevor Exchange Server einen neuen Suchordner erstellt, wird ermittelt, ob der Suchordner nicht bereits vorhanden ist. Wenn der Suchordner vorhanden ist, wird der zwischengespeicherte Suchordner verwendet, um die nachfolgende Anzeige zu beschleunigen.

Das Attribut msExchMaxCachedViews definiert, wie viele Suchordner in einem bestimmten Ordner zwischengespeichert werden. Das Attribut msExchMaxCachedViews kann z. B. definieren, wie viele Suchordner im Kalenderordner zwischengespeichert werden.

Wenn viele Benutzer die Outlook-Ordner gemeinsam verwenden, müssen Sie entscheiden, wie die Serverressourcen und akzeptable Client-Leistungswerte aufeinander abgestimmt werden sollen. Wenn ein Suchordner zwischengespeichert wird, wird ein Suchordner aktualisiert, sobald die Daten im Suchordner geändert werden. Bei solchen Aktualisierungen werden Prozessor- und Datenträgerressourcen verwendet. Wenn mehrere Zwischenspeicherungen des Suchordners verwaltet werden, wird die Prozessorleistung und die Datenträgerleistung weiter beeinträchtigt.

Wenn Exchange Server erstmals einen Suchordner erstellt, muss der Benutzer beim Erstellen des Suchordners möglicherweise mit Wartezeiten rechnen.

Angenommen, ein Exchange-Server ist mit 11 Suchordnern konfiguriert. Elf ist die Standardanzahl für Suchordner. Benutzer A verwendet den Kalenderordner mit 15 anderen Benutzern gemeinsam. Benutzer B greift auf den Ordner zu und muss warten, bis sein Suchordner erstellt ist. Nach der Erstellung des Suchordners für Benutzer B ist der Zugriff auf den Kalenderordner von Benutzer A schnell. Angenommen, Benutzer B greift am gleichen Tag nicht mehr auf den Ordner zu. In der Zwischenzeit, wenn 11 andere Benutzer auf den Ordner zugreifen, werden für sie eindeutige Suchordner erstellt. Da nur 11 Suchordner zwischengespeichert werden, muss Benutzer B, wenn er das nächste Mal auf den Kalender von Benutzer A zugreift, während der Erstellung eines neuen Suchordners für ihn erneut warten.

Als optimale Methode empfiehlt es sich, die maximale Anzahl der Suchordnerzwischenspeicherungen auf höchstens 20 zu begrenzen. Beim Überschreiten dieses Wertes, insbesondere bei Ordnern mit mehr als 5000 Elementen, kann es zur Überlastung des Servers kommen, weil der Server versucht, die zwischengespeicherten Ordner zu verwalten.

Eine weitere optimale Methode besteht darin, mindestens fünf Zwischenspeicherungen zuzulassen. Wenn Benutzer die Outlook-Ordner mit mehreren Benutzern gemeinsam verwenden, wirkt sich das Zwischenspeichern von nur vier Suchordnern negativ auf die Client-Erfahrungen aus und bewirkt, dass der Server mehr Ressourcen verwendet, um häufiger erneut zwischenzuspeichern.

Das Attribut msExchMaxCachedViews kann auch für Datenbanken mit Öffentlichen Ordnern festgelegt werden. Suchordner werden auch für Öffentliche Ordner erstellt. In der Standardeinstellung sind Öffentliche Ordner freigegebene Ressourcen, auf die viele Benutzer zugreifen können. Wenn Öffentliche Ordner viel Post empfangen, sollten Sie die Suchordner minimieren, weil Exchange Server beim Aktualisieren der Suchordner möglicherweise viel Prozessor- und Datenträgerleistung verbraucht. Weiterhin ist es nicht als optimale Methode anzusehen, die Client-Erfahrungen zu optimieren, indem viele Suchordnerzwischenspeicherungen bereitgestellt werden, wenn viele unterschiedliche Benutzer auf einen öffentlichen Ordner zugreifen. Diese Zwischenspeicherungen werden vermutlich verworfen, wenn für neue Benutzer neue Suchordner erstellt werden.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So ändern Sie das Attribut msExchMaxCachedViews

  1. Starten Sie das ADSI-Bearbeitungs-Snap-In in den Supporttools von Microsoft Windows® 2000 oder Windows Server 2003.

  2. Erweitern Sie die folgenden Knoten:

    • Container Konfiguration

    • Konfiguration

    • Dienste

    • Microsoft Exchange

    • Organisationsname

    • Administrative Gruppen

    • Name der administrativen Gruppe

    • Server

    • Informationsspeicher

    • Name der Speichergruppe

  3. Klicken Sie mit der rechten Maustaste im Bereich Details auf Datenbankname, und wählen Sie anschließend Eigenschaften aus.

  4. Doppelklicken Sie im Feld Attribute auf msExchMaxCachedViews.

  5. Geben Sie im Dialogfeld Ganzzahlattribut-Editor im Feld Wert eine ganze Zahl zwischen 5 und 20 ein, und klicken Sie dann auf OK.

  6. Klicken Sie auf Übernehmen, und schließen Sie dann die ADSI-Bearbeitung.

  7. Warten Sie mindestens 15 Minuten, bis die Replikation abgeschlossen ist, und starten Sie dann den Microsoft Exchange-Informationsspeicherdienst auf dem Exchange-Server neu, auf dem die Änderung erfolgt ist.


Der Maximalwert für zwischengespeicherte Ansichten ist zu hoch festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob die maximale Anzahl zwischengespeicherter Ansichten pro Datenbank geändert wurde. Wenn Exchange Server Analyzer feststellt, dass das Attribut msExchMaxCachedViews auf einen größeren Wert als 20 festgelegt wurde, wird eine Warnung angezeigt. Die konfigurierte Anzahl der zwischengespeicherten Ansichten pro Datenbank ist in der Ausgabe von Microsoft Exchange Server Analyzer enthalten. Eine optimale Methode besteht darin, fünf bis 20 zwischengespeicherte Ansichten zuzulassen.

msExchMaxCachedViews ist ein Attribut der Objektklasse msExchangePrivateMDB. Daher verfügt jedes Postfach-Datenbankspeicherobjekt in Active Directory über einen Attributwert msExchMaxCachedViews. Der Attributwert msExchMaxCachedViews gibt die maximale Anzahl der Ansichten an, die für einen bestimmten Ordner in einem Postfach zwischengespeichert werden. In diesem Kontext verweist „Ansicht" auf die Ordner, die angezeigt werden, wenn ein Benutzer auf ein Microsoft Office Outlook® 2003-Postfach eines anderen Benutzers zugreift. Wenn Benutzer mit anderen Benutzern gemeinsam auf einen Outlook-Ordner zugreifen, generiert Exchange Server eine Ansicht, in der private Elemente ausgeblendet werden.

Wenn ein Outlook-Benutzer zum ersten Mal den Kalender, den Kontaktordner oder andere Daten eines anderen Benutzers anzeigt, kann es bei der Anzeige zu Verzögerungen kommen. Nach der erstmaligen Anzeige kann bei nachfolgenden Versuchen die Anzeige schneller erfolgen. Nach einer gewissen Zeit wird die Anzeige jedoch wieder verzögert, wenn der Benutzer versucht, erneut auf den Ordner zuzugreifen. Die Verzögerung macht sich am stärksten bemerkbar, wenn der Ordner sehr viele Elemente enthält. Das ist der Fall, wenn im Ordner über 5000 Elemente enthalten sind.

Bei der Anwendung einer Ansicht auf einen Ordner werden Suchordner im Exchange-Speicher für jeden einzelnen Benutzer erstellt, der auf den Outlook-Ordner zugreift. Wenn ein Suchordner erstellt wird, wird er für spätere Verwendungen zwischengespeichert. Bevor Exchange Server einen neuen Suchordner erstellt, wird ermittelt, ob der Suchordner nicht bereits vorhanden ist. Wenn der Suchordner vorhanden ist, wird der zwischengespeicherte Suchordner verwendet, um die nachfolgende Anzeige zu beschleunigen.

Das Attribut msExchMaxCachedViews definiert, wie viele Suchordner in einem bestimmten Ordner zwischengespeichert werden. Das Attribut msExchMaxCachedViews kann z. B. definieren, wie viele Suchordner im Kalenderordner zwischengespeichert werden.

Wenn viele Benutzer die Outlook-Ordner gemeinsam verwenden, müssen Sie entscheiden, wie die Serverressourcen und akzeptable Client-Leistungswerte aufeinander abgestimmt werden sollen. Wenn ein Suchordner zwischengespeichert wird, wird ein Suchordner aktualisiert, sobald die Daten im Suchordner geändert werden. Bei solchen Aktualisierungen werden Prozessor- und Datenträgerressourcen verwendet. Wenn mehrere Zwischenspeicherungen des Suchordners verwaltet werden, wird die Prozessorleistung und die Datenträgerleistung weiter beeinträchtigt.

Wenn Exchange Server erstmals einen Suchordner erstellt, muss der Benutzer beim Erstellen des Suchordners möglicherweise mit Wartezeiten rechnen.

Angenommen, ein Exchange-Server ist mit 11 Suchordnern konfiguriert. Elf ist die Standardanzahl für Suchordner. Benutzer A verwendet den Kalenderordner mit 15 anderen Benutzern gemeinsam. Benutzer B greift auf den Ordner zu und muss warten, bis sein Suchordner erstellt ist. Nach der Erstellung des Suchordners für Benutzer B ist der Zugriff auf den Kalenderordner von Benutzer A schnell. Angenommen, Benutzer B greift am gleichen Tag nicht mehr auf den Ordner zu. In der Zwischenzeit, wenn 11 andere Benutzer auf den Ordner zugreifen, werden für sie eindeutige Suchordner erstellt. Da nur 11 Suchordner zwischengespeichert werden, muss Benutzer B, wenn er das nächste Mal auf den Kalender von Benutzer A zugreift, während der Erstellung eines neuen Suchordners für ihn erneut warten.

Als optimale Methode empfiehlt es sich, die maximale Anzahl der Suchordnerzwischenspeicherungen auf höchstens 20 zu begrenzen. Beim Überschreiten dieses Wertes, insbesondere bei Ordnern mit mehr als 5000 Elementen, kann es zur Überlastung des Servers kommen, weil der Server versucht, die zwischengespeicherten Ordner zu verwalten.

Eine weitere optimale Methode besteht darin, mindestens fünf Zwischenspeicherungen zuzulassen. Wenn Benutzer die Outlook-Ordner mit mehreren Benutzern gemeinsam verwenden, wirkt sich das Zwischenspeichern von nur vier Suchordnern negativ auf die Client-Erfahrungen aus und bewirkt, dass der Server mehr Ressourcen verwendet, um häufiger erneut zwischenzuspeichern.

Das Attribut msExchMaxCachedViews kann auch für Datenbanken mit Öffentlichen Ordnern festgelegt werden. Suchordner werden auch für Öffentliche Ordner erstellt. In der Standardeinstellung sind Öffentliche Ordner freigegebene Ressourcen, auf die viele Benutzer zugreifen können. Wenn Öffentliche Ordner viel Post empfangen, sollten Sie die Suchordner minimieren, weil Exchange Server beim Aktualisieren der Suchordner möglicherweise viel Prozessor- und Datenträgerleistung verbraucht. Weiterhin ist es nicht als optimale Methode anzusehen, die Client-Erfahrungen zu optimieren, indem viele Suchordnerzwischenspeicherungen bereitgestellt werden, wenn viele unterschiedliche Benutzer auf einen öffentlichen Ordner zugreifen. Diese Zwischenspeicherungen werden vermutlich verworfen, wenn für neue Benutzer neue Suchordner erstellt werden.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So ändern Sie das Attribut msExchMaxCachedViews

  1. Starten Sie das ADSI-Bearbeitungs-Snap-In in den Supporttools von Microsoft Windows® 2000 oder Windows Server 2003.

  2. Erweitern Sie die folgenden Knoten:

    • Container Konfiguration

    • Konfiguration

    • Dienste

    • Microsoft Exchange

    • Organisationsname

    • Administrative Gruppen

    • Name der administrativen Gruppe

    • Server

    • InformationStore

    • Name der Speichergruppe

  3. Klicken Sie mit der rechten Maustaste im Bereich Details auf Datenbankname, und wählen Sie anschließend Eigenschaften aus.

  4. Doppelklicken Sie im Feld Attribute auf msExchMaxCachedViews.

  5. Geben Sie im Dialogfeld Ganzzahlattribut-Editor im Feld Wert eine ganze Zahl zwischen 5 und 20 ein, und klicken Sie dann auf OK.

  6. Klicken Sie auf Übernehmen, und schließen Sie dann die ADSI-Bearbeitung.

  7. Warten Sie mindestens 15 Minuten, bis die Replikation abgeschlossen ist, und starten Sie dann den Microsoft Exchange-Informationsspeicherdienst auf dem Exchange-Server neu, auf dem die Änderung erfolgt ist.


Der Maximalwert für zwischengespeicherte Ansichten ist zu niedrig festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob die maximale Anzahl zwischengespeicherter Ansichten pro Datenbank geändert wurde. Wenn Exchange Server Analyzer feststellt, dass das Attribut msExchMaxCachedViews auf einen kleineren Wert als 5 festgelegt wurde, zeigt Microsoft Exchange Server Analyzer eine Warnung an. Die von Ihnen konfigurierte Anzahl der zwischengespeicherten Ansichten pro Datenbank ist in der Ausgabe von Microsoft Exchange Server Analyzer enthalten. Eine optimale Methode besteht darin, fünf bis 20 zwischengespeicherte Ansichten zuzulassen.

msExchMaxCachedViews ist ein Attribut der Objektklasse msExchangePrivateMDB. Daher verfügt jedes Postfach-Datenbankspeicherobjekt in Active Directory über einen Attributwert msExchMaxCachedViews. Der Attributwert msExchMaxCachedViews gibt die maximale Anzahl der Ansichten an, die für einen bestimmten Ordner in einem Postfach zwischengespeichert werden.

In diesem Kontext verweist „Ansicht" auf die Ordner, die angezeigt werden, wenn ein Benutzer auf ein Microsoft Office Outlook® 2003-Postfach eines anderen Benutzers zugreift. Wenn Benutzer mit anderen Benutzern gemeinsam auf einen Outlook-Ordner zugreifen, generiert Exchange Server eine Ansicht, in der private Elemente ausgeblendet werden.

Wenn ein Outlook-Benutzer zum ersten Mal den Kalender, den Kontaktordner oder andere Daten eines anderen Benutzers anzeigt, kann es bei der Anzeige zu Verzögerungen kommen. Nach der erstmaligen Anzeige kann bei nachfolgenden Versuchen die Anzeige schneller erfolgen. Nach einer gewissen Zeit wird die Anzeige jedoch wieder verzögert, wenn der Benutzer versucht, erneut auf den Ordner zuzugreifen. Die Verzögerung macht sich am stärksten bemerkbar, wenn der Ordner sehr viele Elemente enthält. Das ist der Fall, wenn im Ordner über 5000 Elemente enthalten sind.

Bei der Anwendung einer Ansicht auf einen Ordner werden Suchordner im Exchange-Speicher für jeden einzelnen Benutzer erstellt, der auf den Outlook-Ordner zugreift. Wenn ein Suchordner erstellt wird, wird er für spätere Verwendungen zwischengespeichert. Bevor Exchange Server einen neuen Suchordner erstellt, wird ermittelt, ob der Suchordner nicht bereits vorhanden ist. Wenn der Suchordner vorhanden ist, wird der zwischengespeicherte Suchordner verwendet, um die nachfolgende Anzeige zu beschleunigen.

Das Attribut msExchMaxCachedViews definiert, wie viele Suchordner in einem bestimmten Ordner zwischengespeichert werden. Das Attribut msExchMaxCachedViews kann z. B. definieren, wie viele Suchordner im Kalenderordner zwischengespeichert werden.

Wenn viele Benutzer die Outlook-Ordner gemeinsam verwenden, müssen Sie entscheiden, wie die Serverressourcen und akzeptable Client-Leistungswerte aufeinander abgestimmt werden sollen. Wenn ein Suchordner zwischengespeichert wird, wird ein Suchordner aktualisiert, sobald die Daten im Suchordner geändert werden. Bei solchen Aktualisierungen werden Prozessor- und Datenträgerressourcen verwendet. Wenn mehrere Zwischenspeicherungen des Suchordners verwaltet werden, wird die Prozessorleistung und die Datenträgerleistung weiter beeinträchtigt.

Wenn Exchange Server erstmals einen Suchordner erstellt, muss der Benutzer beim Erstellen des Suchordners möglicherweise mit Wartezeiten rechnen.

Angenommen, ein Exchange-Server ist mit 11 Suchordnern konfiguriert. Elf ist die Standardanzahl für Suchordner. Benutzer A verwendet den Kalenderordner mit 15 anderen Benutzern gemeinsam. Benutzer B greift auf den Ordner zu und muss warten, bis sein Suchordner erstellt ist. Nach der Erstellung des Suchordners für Benutzer B ist der Zugriff auf den Kalenderordner von Benutzer A schnell. Angenommen, Benutzer B greift am gleichen Tag nicht mehr auf den Ordner zu. In der Zwischenzeit, wenn 11 andere Benutzer auf den Ordner zugreifen, werden für sie eindeutige Suchordner erstellt. Da nur 11 Suchordner zwischengespeichert werden, muss Benutzer B, wenn er das nächste Mal auf den Kalender von Benutzer A zugreift, während der Erstellung eines neuen Suchordners für ihn erneut warten.

Als optimale Methode empfiehlt es sich, die maximale Anzahl der Suchordnerzwischenspeicherungen auf höchstens 20 zu begrenzen. Beim Überschreiten dieses Wertes, insbesondere bei Ordnern mit mehr als 5000 Elementen, kann es zur Überlastung des Servers kommen, weil der Server versucht, die zwischengespeicherten Ordner zu verwalten.

Eine weitere optimale Methode besteht darin, mindestens fünf Zwischenspeicherungen zuzulassen. Wenn Benutzer die Outlook-Ordner mit mehreren Benutzern gemeinsam verwenden, wirkt sich das Zwischenspeichern von nur vier Suchordnern negativ auf die Client-Erfahrungen aus und bewirkt, dass der Server mehr Ressourcen verwendet, um häufiger erneut zwischenzuspeichern.

Das Attribut msExchMaxCachedViews kann auch für Datenbanken mit Öffentlichen Ordnern festgelegt werden. Suchordner werden auch für Öffentliche Ordner erstellt. In der Standardeinstellung sind Öffentliche Ordner freigegebene Ressourcen, auf die viele Benutzer zugreifen können. Wenn Öffentliche Ordner viel Post empfangen, sollten Sie die Suchordner minimieren, weil Exchange Server beim Aktualisieren der Suchordner möglicherweise viel Prozessor- und Datenträgerleistung verbraucht. Weiterhin ist es nicht als optimale Methode anzusehen, die Client-Erfahrungen zu optimieren, indem viele Suchordnerzwischenspeicherungen bereitgestellt werden, wenn viele unterschiedliche Benutzer auf einen öffentlichen Ordner zugreifen. Diese Zwischenspeicherungen werden vermutlich verworfen, wenn für neue Benutzer neue Suchordner erstellt werden.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So ändern Sie das Attribut msExchMaxCachedViews

  1. Starten Sie das ADSI-Bearbeitungs-Snap-In in den Supporttools von Microsoft Windows® 2000 oder Windows Server 2003.

  2. Erweitern Sie die folgenden Knoten:

    • Container Konfiguration

    • Konfiguration

    • Dienste

    • Microsoft Exchange

    • Organisationsname

    • Administrative Gruppen

    • Name der administrativen Gruppe

    • Server

    • InformationStore

    • Name der Speichergruppe

  3. Klicken Sie mit der rechten Maustaste im Bereich Details auf Datenbankname, und wählen Sie anschließend Eigenschaften aus.

  4. Doppelklicken Sie im Feld Attribute auf msExchMaxCachedViews.

  5. Geben Sie im Dialogfeld Ganzzahlattribut-Editor im Feld Wert eine ganze Zahl zwischen 5 und 20 ein, und klicken Sie dann auf OK.

  6. Klicken Sie auf Übernehmen, und schließen Sie dann die ADSI-Bearbeitung.

  7. Warten Sie mindestens 15 Minuten auf die Replikation, und starten Sie dann erneut den Microsoft Exchange-Informationsspeicherdienst auf dem Exchange-Server, auf dem die Änderung erfolgt ist.


Maximaler ESE-Cache wurde manuell geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2006-02-21

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchESEParamCacheSizeMax fu¨r alle Postfachspeicherobjekte zu bestimmen. Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs msExchESEParamCacheSizeMax fu¨r einen beliebigen Postfachspeicher gro¨ßer als 0 und niedriger als 219727 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Bei Exchange 2000 Server wird ein Großteil des von STORE.EXE verwendeten virtuellen Speichers dem ESE-Puffer zugewiesen. Exchange 2000 Server verwendet fu¨r diesen Puffer den hartcodierten Standardwert 858 MB. Bei Exchange Server 2003 richtet sich die ESE-Pufferzuweisung nach dem Vorhandensein des Schalters /3GB in der Datei Boot.ini. Wenn der Schalter /3GB vorhanden ist, wird der ESE-Puffer auf 896 MB festgelegt. Andernfalls wird der ESE-Puffer auf 576 MB festgelegt. Obwohl eine automatische Feinabstimmung in jedem Fall nu¨tzlich ist, mo¨chten Sie jedoch den automatisch festgelegten Wert u. U. u¨berschreiben und einen fu¨r Ihre Umgebung besser geeigneten Wert manuell festlegen. Sie ko¨nnen diesen Wert zwar auf ein beliebiges Vielfaches von 8192 festlegen, es wird jedoch empfohlen, nur Werte aus der folgenden Tabelle zu verwenden.

Empfohlener Wert | Zugewiesener Speicher | Kommentare
147456 | 576 MB | Dies ist der empfohlene Mindestwert. Legen Sie den Wert nicht darunter fest. Dieser Wert eignet sich fu¨r Server mit eingeschra¨nktem virtuellen Speicher und fu¨r Exchange Server 2003-Computer, die unter Microsoft Windows® 2000 Server ausgefu¨hrt werden, das den Schalter /3GB nicht unterstu¨tzt. Dies ist auch der Standardwert fu¨r Systeme, die den Schalter /3GB nicht verwenden.
196608 | 768 MB | Dieser Wert wird fu¨r Server mit großem Bedarf an virtuellem Speicherplatz empfohlen, die ha¨ufig das Ereignis 9582 protokollieren.
219726 | 858 MB | Dies ist der Standardwert fu¨r Exchange 2000 Server. Dieser Wert ist daru¨ber hinaus auch gut fu¨r Systeme geeignet, die Sie im laufenden Betrieb aktualisieren und die ebenfalls u¨ber einen großen Bedarf an virtuellem Speicherplatz verfu¨gen.
229376 | 896 MB | Dies ist der Standardwert fu¨r Exchange Server 2003. Dieser Wert ist daru¨ber hinaus auch gut fu¨r neue Systeme geeignet, sofern das Ereignisprotokoll der Anwendung keine anderen Vorgaben macht, z. B. bei vorhandenen Ereignissen vom Typ 9582.
311296 | 1,2 GB | Dies ist der ho¨chste Wert, der festgelegt werden kann. Dieser Wert wird nur fu¨r Systeme mit mindestens 2 GB physischem Speicher empfohlen.

Vor dem Neukonfigurieren dieses Werts empfiehlt es sich, den vom Prozess STORE.EXE beno¨tigten virtuellen Speicherplatz zu u¨berwachen. U¨berwachen Sie hierzu unter Windows das Leistungsobjekt Process. Bei Systemen mit dem Schalter /3GB sollte der Leistungsindikator Virtual Bytes fu¨r die Instanz STORE.EXE des Objekts Process unter 2,8 GB liegen. Bei Systemen ohne den Schalter /3GB wird ein Wert unter 1,8 GB empfohlen. Wenn die Werte u¨ber diesen Betra¨gen liegen, muss mo¨glicherweise der Wert fu¨r msExchESEParamCacheSizeMax verringert werden. Wenn die Werte darunter liegen, muss mo¨glicherweise der Wert fu¨r msExchESEParamCacheSizeMax erho¨ht werden.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgema¨ß a¨ndern, ko¨nnen schwerwiegende Probleme verursacht werden. Diese Probleme erfordern mo¨glicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie a¨ndern Active Directory-Objektattribute auf eigenes Risiko.

So nehmen Sie die Feinabstimmung fu¨r das Attribut „msExchESEParamCacheSizeMax" vor

  1. O¨ffnen Sie einen Active Directory-Editor, z. B. die ADSI-Bearbeitung.

  2. Doppelklicken Sie auf den Container Konfiguration.

  3. Erweitern Sie CN=Services.

  4. Erweitern Sie CN=Microsoft Exchange.

  5. Erweitern Sie CN=<Name der Exchange-Organisation>.

  6. Erweitern Sie CN=Administrative Groups.

  7. Erweitern Sie CN=<Name der administrativen Gruppe>.

  8. Erweitern Sie CN=Servers.

  9. Erweitern Sie CN=<Name des Exchange-Servers>.

  10. Klicken Sie mit der rechten Maustaste auf CN=InformationStore, und klicken Sie dann auf Eigenschaften.

  11. Fu¨hren Sie im Feld Attribute einen Bildlauf zu msExchESEParamCacheSizeMax aus, und doppelklicken Sie darauf.

  12. Geben Sie im Feld Wert den gewu¨nschten Wert ein. Bestimmen Sie anhand der Tabelle in diesem Artikel den optimalen Wert fu¨r das von Ihnen verwendete System. Beachten Sie, dass es sich bei diesem Wert um ein Vielfaches von 8192 handeln muss.

  13. Klicken Sie auf OK, und klicken Sie anschließend erneut auf OK.

  14. Schließen Sie den Active Directory-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die A¨nderung wirksam wird.

Weitere Informationen zum Optimieren der Speichernutzung finden Sie im Microsoft Knowledge Base-Artikel 815372 „Optimieren der Speichernutzung in Exchange Server 2003" (http://support.microsoft.com/?kbid=815372).

Weitere Informationen zum Attribut msExchESEParamCacheSizeMax finden Sie im Microsoft Knowledge Base-Artikel 266768 „XSTR: How to modify the Store Database maximum cache size" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768.


Der maximale ESE-Cache ist zu hoch festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2006-02-21

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchESEParamCacheSizeMax fu¨r alle Postfachspeicherobjekte zu bestimmen. Exchange Server Analyzer fragt auch die Microsoft Windows®-Verwaltungsinstrumentationsklasse (Windows® Management Instrumentation, WMI) Win32_PerfRawData_MSExchangeIS_MSExchangeIS ab, um den Wert fu¨r den Schlu¨ssel VMLargestBlockSize zu bestimmen. Der Schlu¨ssel VMLargestBlockSize gibt die Gro¨ße (in Byte) des gro¨ßten verfu¨gbaren Blocks des virtuellen Speichers an.

Exchange Server Analyzer fragt außerdem Active Directory ab, um die Anzahl der Eintra¨ge zu ermitteln, die im Attribut homeMDBBL der einzelnen Postfachspeicher aufgelistet sind. Der Za¨hlwert dieses Attributs stellt die Zahl der Postfa¨cher im Postfachspeicher dar.

Wenn Exchange Server Analyzer feststellt, dass der Wert msExchESEParamCacheSizeMax auf einem Exchange Server-Computer mit mehr als 20 Postfa¨chern gro¨ßer als 219726 ist und der Wert fu¨r VMLargestBlockSize gro¨ßer als 50000000 und kleiner als 150000000 ist, wird ein Fehler angezeigt. Dieser Fehler weist darauf hin, dass das Attribut msExchESEParamCacheSizeMax auf diesem Exchange Server-Computer zu hoch festgelegt ist.

Bei Exchange 2000 Server wird ein Großteil des von STORE.EXE verwendeten virtuellen Speichers dem ESE-Puffer zugewiesen. Exchange 2000 Server verwendet fu¨r diesen Puffer den hartcodierten Standardwert 858 Megabyte (MB). Bei Exchange Server 2003 richtet sich die ESE-Pufferzuweisung nach dem Vorhandensein des Schalters /3GB in der Datei Boot.ini. Wenn der Schalter /3GB vorhanden ist, wird der ESE-Puffer auf 896 MB festgelegt. Andernfalls wird der ESE-Puffer auf 576 MB festgelegt. Obwohl eine automatische Feinabstimmung in normalerweise nu¨tzlich ist, mo¨chten Sie jedoch den automatisch festgelegten Wert u. U. u¨berschreiben und einen fu¨r Ihre Umgebung besser geeigneten Wert manuell festlegen. Sie ko¨nnen diesen Wert zwar auf ein beliebiges Vielfaches von 8192 festlegen, es wird jedoch empfohlen, nur Werte aus der folgenden Tabelle zu verwenden.

Empfohlener Wert | Zugewiesener Speicher | Kommentare
147456 | 576 MB | Dies ist der empfohlene Mindestwert. Legen Sie den Wert nicht darunter fest. Dieser Wert eignet sich fu¨r Server mit eingeschra¨nktem virtuellen Speicher und fu¨r Exchange Server 2003-Computer, die unter Microsoft Windows 2000 Server ausgefu¨hrt werden, das den Schalter /3GB nicht unterstu¨tzt. Dies ist auch der Standardwert fu¨r Systeme, die den Schalter /3GB nicht verwenden.
196608 | 768 MB | Dieser Wert wird fu¨r Server mit großem Bedarf an virtuellem Speicherplatz empfohlen, die ha¨ufig das Ereignis 9582 protokollieren.
219726 | 858 MB | Dies ist der Standardwert fu¨r Exchange 2000 Server. Dieser Wert ist daru¨ber hinaus auch gut fu¨r Systeme geeignet, die Sie im laufenden Betrieb aktualisieren und die ebenfalls u¨ber einen großen Bedarf an virtuellem Speicherplatz verfu¨gen.
229376 | 896 MB | Dies ist der Standardwert fu¨r Exchange Server 2003. Dieser Wert ist daru¨ber hinaus auch gut fu¨r neue Systeme geeignet, sofern das Ereignisprotokoll der Anwendung keine anderen Vorgaben macht, z. B. bei vorhandenen Ereignissen vom Typ 9582.
311296 | 1,2 GB | Dies ist der ho¨chste Wert, der festgelegt werden kann. Dieser Wert wird nur fu¨r Systeme mit mindestens 2 GB physischem Speicher empfohlen.

Vor dem Neukonfigurieren dieses Werts empfiehlt es sich, den vom Prozess STORE.EXE beno¨tigten virtuellen Speicherplatz zu u¨berwachen. U¨berwachen Sie hierzu unter Windows das Leistungsobjekt Process. Bei Systemen mit dem Schalter /3GB sollte der Leistungsindikator Virtual Bytes fu¨r die Instanz STORE.EXE des Objekts Process unter 2,8 GB liegen. Bei Systemen ohne den Schalter /3GB wird ein Wert unter 1,8 GB empfohlen. Wenn die Werte u¨ber diesen Betra¨gen liegen, muss mo¨glicherweise der Wert fu¨r msExchESEParamCacheSizeMax verringert werden. Wenn die Werte darunter liegen, muss mo¨glicherweise der Wert fu¨r msExchESEParamCacheSizeMax erho¨ht werden.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgema¨ß a¨ndern, ko¨nnen schwerwiegende Probleme verursacht werden. Diese Probleme erfordern mo¨glicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie a¨ndern Active Directory-Objektattribute auf eigenes Risiko.

So nehmen Sie die Feinabstimmung fu¨r das Attribut „msExchESEParamCacheSizeMax" vor

  1. O¨ffnen Sie einen Active Directory-Editor, z. B. die ADSI-Bearbeitung.

  2. Doppelklicken Sie auf den Container Konfiguration.

  3. Erweitern Sie CN=Services.

  4. Erweitern Sie CN=Microsoft Exchange.

  5. Erweitern Sie CN=<Name der Exchange-Organisation>.

  6. Erweitern Sie CN=Administrative Groups.

  7. Erweitern Sie CN=<Name der administrativen Gruppe>.

  8. Erweitern Sie CN=Servers.

  9. Erweitern Sie CN=<Name des Exchange-Servers>.

  10. Klicken Sie mit der rechten Maustaste auf CN=InformationStore, und klicken Sie dann auf Eigenschaften.

  11. Fu¨hren Sie im Feld Attribute einen Bildlauf zu msExchESEParamCacheSizeMax aus, und doppelklicken Sie darauf.

  12. Geben Sie im Feld Wert den gewu¨nschten Wert ein. Bestimmen Sie anhand der Tabelle den optimalen Wert fu¨r das von Ihnen verwendete System. Beachten Sie, dass es sich bei diesem Wert um ein Vielfaches von 8192 handeln muss.

  13. Klicken Sie auf OK, und klicken Sie anschließend erneut auf OK.

  14. Schließen Sie den Active Directory-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die A¨nderung wirksam wird.

Weitere Informationen zum Optimieren der Speichernutzung finden Sie im Microsoft Knowledge Base-Artikel 815372 „Optimieren der Speichernutzung in Exchange Server 2003" unter http://support.microsoft.com/?kbid=815372.

Weitere Informationen zum Attribut msExchESEParamCacheSizeMax finden Sie im Microsoft Knowledge Base-Artikel 266768 „XSTR: How to modify the Store Database maximum cache size" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768.


Die maximale Größe des ESE-Cache wurde erhöht.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2006-02-21

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchESEParamCacheSizeMax fu¨r alle Postfachspeicherobjekte zu bestimmen.

Exchange Server Analyzer fragt auch die Microsoft Windows®-Verwaltungsinstrumentationsklasse (Windows® Management Instrumentation, WMI) Win32_PerfRawData_MSExchangeIS_MSExchangeIS ab, um den Wert fu¨r den Schlu¨ssel VMLargestBlockSize zu bestimmen. Der Schlu¨ssel VMLargestBlockSize gibt die Gro¨ße (in Byte) des gro¨ßten verfu¨gbaren Blocks des virtuellen Speichers an.

Exchange Server Analyzer fragt außerdem Active Directory ab, um die Anzahl der Eintra¨ge zu ermitteln, die im Attribut homeMDBBL der einzelnen Postfachspeicher aufgelistet sind. Der Za¨hlwert dieses Attributs stellt die Zahl der Postfa¨cher im Postfachspeicher dar.

Wenn Exchange Server Analyzer feststellt, dass der Wert msExchESEParamCacheSizeMax gro¨ßer als 219726 ist und sich der Wert fu¨r VMLargestBlockSize auf einem Exchange Server-Computer mit mehr als 20 Postfa¨chern nicht innerhalb der folgenden Werte befindet, wird eine Warnung angezeigt:

  • Gro¨ßer als 50000000 und kleiner als 150000000

  • Gro¨ßer als 0 und kleiner als 50000001

Durch diese Warnung wird angezeigt, dass das Attribut msExchESEParamCacheSizeMax auf diesem Exchange Server-Computer erho¨ht wurde. Dies kann dazu fu¨hren, dass der vorhandene virtuelle Speicher nicht ausreicht.

Bei Exchange 2000 Server wird ein Großteil des von STORE.EXE verwendeten virtuellen Speichers dem ESE-Puffer zugewiesen. Exchange 2000 Server verwendet fu¨r diesen Puffer den hartcodierten Standardwert 858 Megabyte (MB). Bei Exchange Server 2003 richtet sich die ESE-Pufferzuweisung nach dem Vorhandensein des Schalters /3GB in der Datei Boot.ini. Wenn der Schalter /3GB vorhanden ist, wird der ESE-Puffer auf 896 MB festgelegt. Andernfalls wird der ESE-Puffer auf 576 MB festgelegt. Obwohl eine automatische Feinabstimmung in jedem Fall nu¨tzlich ist, mo¨chten Sie jedoch den automatisch festgelegten Wert u. U. u¨berschreiben und einen fu¨r Ihre Umgebung besser geeigneten Wert manuell festlegen. Sie ko¨nnen diesen Wert zwar auf ein beliebiges Vielfaches von 8192 festlegen, es wird jedoch empfohlen, nur Werte aus der folgenden Tabelle zu verwenden:

Empfohlener Wert | Zugewiesener Speicher | Kommentare
147456 | 576 MB | Dies ist der empfohlene Mindestwert. Legen Sie den Wert nicht darunter fest. Dieser Wert eignet sich fu¨r Server mit eingeschra¨nktem virtuellen Speicher und fu¨r Exchange Server 2003-Computer, die unter Microsoft Windows 2000 Server ausgefu¨hrt werden, das den Schalter /3GB nicht unterstu¨tzt. Dies ist auch der Standardwert fu¨r Systeme, die den Schalter /3GB nicht verwenden.
196608 | 768 MB | Dieser Wert wird fu¨r Server mit großem Bedarf an virtuellem Speicherplatz empfohlen, die ha¨ufig das Ereignis 9582 protokollieren.
219726 | 858 MB | Dies ist der Standardwert fu¨r Exchange 2000 Server. Dieser Wert eignet sich daru¨ber hinaus auch hervorragend fu¨r Systeme, die Sie im laufenden Betrieb aktualisieren und die ebenfalls u¨ber einen großen Bedarf an virtuellem Speicherplatz verfu¨gen.
229376 | 896 MB | Dies ist der Standardwert fu¨r Exchange Server 2003. Dieser Wert eignet sich daru¨ber hinaus auch hervorragend fu¨r neue Systeme, sofern das Ereignisprotokoll der Anwendung keine anderen Vorgaben macht, z. B. bei vorhandenen Ereignissen vom Typ 9582.
311296 | 1,2 GB | Dies ist der ho¨chste Wert, der festgelegt werden kann. Dieser Wert wird nur fu¨r Systeme mit mindestens 2 GB physischem Speicher empfohlen.

Vor dem Neukonfigurieren dieses Werts empfiehlt es sich, den vom Prozess STORE.EXE beno¨tigten virtuellen Speicherplatz zu u¨berwachen. U¨berwachen Sie hierzu unter Windows das Leistungsobjekt Process. Bei Systemen mit dem Schalter /3GB sollte der Leistungsindikator Virtual Bytes fu¨r die Instanz STORE.EXE des Objekts Process unter 2,8 GB liegen. Bei Systemen ohne den Schalter /3GB wird ein Wert unter 1,8 GB empfohlen. Wenn die Werte u¨ber diesen Betra¨gen liegen, muss mo¨glicherweise der Wert fu¨r msExchESEParamCacheSizeMax verringert werden. Wenn die Werte darunter liegen, muss mo¨glicherweise der Wert fu¨r msExchESEParamCacheSizeMax erho¨ht werden.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgema¨ß a¨ndern, ko¨nnen schwerwiegende Probleme verursacht werden. Diese Probleme erfordern mo¨glicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie a¨ndern Active Directory-Objektattribute auf eigenes Risiko.

So nehmen Sie die Feinabstimmung fu¨r das Attribut „msExchESEParamCacheSizeMax" vor

  1. O¨ffnen Sie einen Active Directory-Editor, z. B. die ADSI-Bearbeitung.

  2. Doppelklicken Sie auf den Container Konfiguration.

  3. Erweitern Sie CN=Services.

  4. Erweitern Sie CN=Microsoft Exchange.

  5. Erweitern Sie CN=<Name der Exchange-Organisation>.

  6. Erweitern Sie CN=Administrative Groups.

  7. Erweitern Sie CN=<Name der administrativen Gruppe>.

  8. Erweitern Sie CN=Servers.

  9. Erweitern Sie CN=<Name des Exchange-Servers>.

  10. Klicken Sie mit der rechten Maustaste auf CN=InformationStore, und klicken Sie dann auf Eigenschaften.

  11. Fu¨hren Sie im Feld Attribute einen Bildlauf zu msExchESEParamCacheSizeMax aus, und doppelklicken Sie darauf.

  12. Geben Sie im Feld Wert den gewu¨nschten Wert ein. Bestimmen Sie anhand der Tabelle in diesem Artikel den optimalen Wert fu¨r das von Ihnen verwendete System. Beachten Sie, dass es sich bei diesem Wert um ein Vielfaches von 8192 handeln muss.

  13. Klicken Sie auf OK, und klicken Sie anschließend erneut auf OK.

  14. Schließen Sie den Active Directory-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die A¨nderung wirksam wird.

Weitere Informationen zum Optimieren der Speichernutzung finden Sie im Microsoft Knowledge Base-Artikel 815372 „Optimieren der Speichernutzung in Exchange Server 2003" unter http://support.microsoft.com/?kbid=815372.

Weitere Informationen zum Attribut msExchESEParamCacheSizeMax finden Sie im Microsoft Knowledge Base-Artikel 266768 „XSTR: How to modify the Store Database maximum cache size" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768.


MaxOpenMessagesPerLogon wurde festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-05-14

Microsoft Exchange Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Registrierungswert MaxOpenMessagesPerLogon vorhanden und konfiguriert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Wenn Exchange Analyzer erkennt, dass der Registrierungswert MaxOpenMessagesPerLogon vorhanden und mit einem Wert größer "0" konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Jedes Mal, wenn ein MAPI-Client oder eine MAPI-Anwendung eine Nachricht auf einem Exchange Server-Computer öffnet, beansprucht dies eine geringe Menge physischen Arbeitsspeichers im Microsoft Exchange-Informationsspeicherdienst (store.exe). Wird die Nachricht von Microsoft Office Outlook 2003- oder Outlook 2007-Clients geschlossen, wird der Arbeitsspeicher wieder freigegeben. Um zu verhindern, dass ein oder mehrere MAPI-Clients den Exchange-Speicher permanent Arbeitsspeicher zuweisen, wurde in Exchange 2000 Server Service Pack 1 (SP1) eine neue Konfigurationsoption eingeführt, mit der der Administrator die Anzahl der Nachrichten begrenzen kann, die jede MAPI-Clientanmeldesitzung öffnet. Die Einrichtung eines derartigen Limits kann in Ihrer Umgebung zweckdienlich sein, wenn bestimmte Clientanwendungen unbeabsichtigt viele Nachrichten öffnen und damit die Gesamtleistung des Servers beeinträchtigen.

Diese Konfigurationsoption wird mit dem Registrierungswert MaxOpenMessagesPerLogon auf dem Exchange Server-Computer implementiert. Es wird empfohlen, dieses Limit nicht auf einen Wert über 1000 festzulegen. Bei einem Wert von 1000 kann jeder Client ungefähr 4 bis 6 Megabyte (MB) Arbeitsspeicher verwenden. In einigen Umgebungen ist der kleinere Wert 500 besser geeignet.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So konfigurieren Sie eine maximale Anzahl gleichzeitig geöffneter Nachrichten

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Öffnen:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Klicken Sie mit der rechten Maustaste auf ParametersSystem, wählen Sie Neu | DWORD-Wert, und geben Sie dem neuen Wert den Namen MaxOpenMessagesPerLogon.

  4. Im rechten Bereich klicken Sie doppelt auf den Wert MaxOpenMessagesPerLogon, und geben Sie die maximale Anzahl der gleichzeitig geöffneten Nachrichten in Dezimalzahlen ein.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Registrierungswert MaxOpenMessagesPerLogon finden Sie im Microsoft Knowledge Base-Artikel 289109 "XADM: Begrenzen der Anzahl von Nachrichten, die für einzelne MAPI-Anmeldungen geöffnet werden" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=289109).


Die maximale Anzahl der Datenbanken pro Speichergruppe wurde manuell geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchMaxStoresPerGroup für jede Speichergruppe zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs msExchMaxStoresPerGroup für eine beliebige Speichergruppe nicht gleich 5 ist, wird ein Fehler angezeigt.

Dieser Wert gilt für alle Speichergruppen auf dem Server. Dieser spezielle Fehler tritt auf, wenn der Standardwert 5 des Attributs geändert wurde. Dies ist der einzige Wert, der für das Attribut unterstützt wird. Er darf daher unter keinen Umständen geändert werden. Exchange Server funktioniert nicht einwandfrei, wenn dieser Wert erhöht wird.

Sie müssen den Wert mit einem Tool wie Active Directory Service Interfaces (ADSI) Edit-Snap-In, LDP (ldp.exe) oder einem beliebigen anderen Client für LDAP (Lightweight Directory Access Protocol), Version 3, korrigieren.

Achtung:
Wenn Sie die ADSI-Bearbeitung, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So beheben Sie diesen Fehler

  1. Starten Sie die ADSI-Bearbeitung.

  2. Doppelklicken Sie auf den Container Configuration, erweitern Sie CN=Services, erweitern Sie CN=Microsoft Exchange, und erweitern Sie dann CN=<ExchangeOrganizationName>.

  3. Erweitern Sie CN=Administrative Groups, erweitern Sie CN=<AdministrativeGroupName>, und erweitern Sie dann CN=Servers.

  4. Erweitern Sie CN=<Servername>, klicken Sie mit der rechten Maustaste auf CN=Informationsspeicher, und klicken Sie anschließend auf Eigenschaften.

  5. Im Attribute Editor klicken Sie auf das Attribut msExchMaxStoresPerGroup und anschließend auf Bearbeiten.

  6. Im Feld zum Bearbeiten von Attributen stellen Sie den Wert auf 5 ein.

  7. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.

  8. Schließen Sie die ADSI-Bearbeitung, und starten Sie den Dienst Microsoft Exchange-Informationsspeicher neu, damit die Änderung wirksam wird.

Weitere Informationen zum Verwenden des LDP-Tools finden Sie im Microsoft Knowledge Base-Artikel 260745 „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Weitere Informationen zur maximal zulässigen Anzahl von Speichergruppen finden Sie im Knowledge Base-Artikel 251123 „XADM: Maximum Number of Storage Groups in Exchange 2000 for Database Capacity Planning" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=251123).

Weitere Informationen zur Verwendung der ADSI-Bearbeitung finden Sie im Abschnitt „Adsiedit.msc: ADSI Bearbeitung" in der Hilfe zu Windows Server.


Die maximale Anzahl der Speichergruppen wurde manuell geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer sendet eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert des Attributs msExchMaxStorageGroups für jeden InformationStore-Container zu ermitteln. Wenn Exchange Server Analyzer ermittelt, dass der Wert für ein msExchMaxStorageGroups-Attribut nicht gleich 4 ist, wird ein Fehler angezeigt.

Der einzige Wert, der für das Attribut msExchMaxStorageGroups unterstützt wird, ist 4, und dieser Wert darf unter keinen Umständen geändert werden. Exchange funktioniert nicht einwandfrei, wenn dieser Wert geändert wird.

Sie müssen den Wert mit einem Active Directory-Editor wie dem ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), dem LDP-Tool (ldp.exe) oder einem beliebigen anderen Client für LDAP (Lightweight Directory Access Protocol), Version 3, korrigieren.

Achtung:
Wenn Sie die ADSI-Bearbeitung, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So berichtigen Sie diesen Fehler

  1. Suchen Sie das InformationStore-Objekt für diesen Server in Active Directory mit der ADSI-Bearbeitung oder einem vergleichbaren Tool.

    Das Attribut msExchMaxStorageGroups befindet sich unter:

    CN=Configuration,DC=Domain,CN=com, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=AdminGroupName, CN=Servers, CN=ServerName, CN=InformationStore

  2. Ändern Sie das Attribut msExchMaxStorageGroups, indem Sie 4 als neuen Wert eingeben.

  3. Schließen Sie den Active Directory-Editor, und starten Sie dann den Exchange Server-Computer neu, damit die Änderung wirksam wird.

Weitere Informationen zum Verwenden des LDP-Tools finden Sie im Microsoft Knowledge Base-Artikel 260745 „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).


Die je Anmeldung maximal mögliche Anzahl geöffneter Ordnerobjekte wurde geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer liest die folgenden Registrierungseinträge, um zu ermitteln, ob die standardmäßig vorgegebene Anzahl von Ordnern, die pro MAPI-Sitzung maximal geöffnet werden kann, geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtFolder

Wenn Microsoft Exchange Server Analyzer Tool erkennt, dass der Wert für objtFolder vorhanden und ungleich 500 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Wenn der Registrierungswert objtFolder manuell hinzugefügt und konfiguriert wurde, bestimmt er die maximale Anzahl von Ordnern, die pro MAPI-Client geöffnet werden kann. Standardmäßig begrenzen Exchange Server 2003 und Exchange Server 2007 die Anzahl geöffneter Ordner auf 500. Wenn ein MAPI-Client versucht, mehr als 500 Ordner zu öffnen, wird im Ereignisprotokoll Anwendung auf dem Computer mit Exchange Server, der das Postfach des Clients enthält, das folgende Ereignis protokolliert:

Ereignistyp: | Fehler
Ereignis-ID: | 9646
Ereignisquelle: | MSExchangeIS
Ereigniskategorie: | Allgemein
Beschreibung: | Beenden der Mapi-Sitzung „/o=OrganizationName/ou=AdministrativeGroupName/cn=Recipients/cn=UserName" wegen Überschreitung der Maximalzahl von 500 Objekten des Typs „objtFolder"

Der Registrierungswert objtFolder stellt eine Konfigurierungsmöglichkeit dar, die dem Administrator größere Steuerungsmöglichkeiten über die von MAPI-Clients verwendeten Exchange Server-Ressourcen bietet.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. Löschen Sie den Registrierungswert objtFolder.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

  5. Wenn Sie den Registrierungswert objtFolder weiterhin verwenden möchten, anstatt ihn zu löschen, behalten Sie seinen bisherigen Wert bei oder passen Sie diesen nach Bedarf an.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986.

Weitere Informationen finden Sie im Knowledge Base-Artikel 830829, „Your Exchange Server 2003 computer may stop responding after a MAPI client opens more than the default value of certain server objects" unter (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829).


Die je Anmeldung maximal mögliche Anzahl geöffneter Ordneransichten wurde geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer liest die folgenden Registrierungseinträge, um zu ermitteln, ob die Standardanzahl von Ordnern, die pro MAPI-Sitzung maximal geöffnet werden können, geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtFolderView

Wenn Exchange Server Analyzer erkennt, dass der Registrierungswert objtFolder vorhanden und mit einem anderen Wert als 500 konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Wenn der Registrierungswert objtFolderView manuell hinzugefügt und konfiguriert wurde, bestimmt er die maximale Anzahl von Ordneransichten, die pro MAPI-Client geöffnet werden können. In der Standardeinstellung begrenzen Exchange Server 2003 und Exchange Server 2007 die Anzahl geöffneter Ordneransichten auf 500. Wenn ein MAPI-Client versucht, mehr als 500 Ordneransichten zu öffnen, wird im Anwendungsereignisprotokoll auf dem Computer mit Exchange Server, der das Postfach des Clients enthält, das folgende Ereignis protokolliert:

Ereignistyp: Fehler

Ereignisquelle: MSExchangeIS

Ereigniskategorie: Allgemein

Beschreibung: Mapi-Sitzung „/o= OrganisationsName /ou= AdministrativerGruppenName /cn=Recipients/cn= Benutzername " wird geschlossen, da sie den Höchstwert von 500 Objekten des Typs objtFolderView überschreitet.

Der Registrierungswert objtFolderView stellt eine Konfigurierungsmöglichkeit dar, die dem Administrator größere Steuerungsmöglichkeiten über die von MAPI-Clients verwendeten Exchange Server-Ressourcen bietet.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. Löschen Sie den Registrierungswert objtFolderView.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

  5. Wenn Sie den Registrierungswert objtFolderView verwenden möchten, anstatt ihn zu löschen, behalten Sie seinen bisherigen Wert bei, oder passen Sie ihn an.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986.

Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 830829, „Ihr Exchange Server 2003-Computer reagiert nicht mehr, nachdem ein MAPI-Client eine größere Anzahl als den Standardwert bestimmter Serverobjekte geöffnet hat" unter (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829).


Die je Anmeldung maximal mögliche Anzahl geöffneter Nachrichtenobjekte wurde geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob die standardmäßig vorgegebene Anzahl von Nachrichten, die pro MAPI-Sitzung maximal geöffnet werden kann, geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtMessage

Wenn MicrosoftMicrosoft Exchange Server Analyzer feststellt, dass der Registrierungswert objtMessage vorhanden ist und mit einem Wert ungleich 250 konfiguriert wurde, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Wenn der Registrierungswert objtMessage manuell hinzugefügt und konfiguriert wurde, bestimmt er die maximale Anzahl offener Nachrichten pro MAPI-Client. In der Standardeinstellung begrenzen Exchange Server 2003 und Exchange Server 2007 die Anzahl geöffneter Nachrichten auf 250. Wenn ein MAPI-Client versucht, mehr als 250 Nachrichten zu öffnen, wird im Anwendungsereignisprotokoll auf dem Computer mit Exchange Server, der das Postfach des Clients enthält, das folgende Ereignis protokolliert:

Ereignistyp: Fehler

Ereignis-ID: 9646

Ereignisquelle: MSExchangeIS

Ereigniskategorie: Allgemein

Beschreibung: Beenden der Mapi-Sitzung „/o= OrganisationsName /ou= AdministrativerGruppenName /cn=Recipients/cn= Benutzername " wegen Überschreitung der Maximalanzahl von 250 Objekten vom Typ "objtMessage".

Der Registrierungswert objtMessage stellt eine Konfigurierungsmöglichkeit dar, die dem Administrator größere Steuerungsmöglichkeiten über die von MAPI-Clients verwendeten Exchange Server-Ressourcen bietet.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. Löschen Sie den Registrierungswert objtMessage.

  4. Schließen Sie den Registrierungseditor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

  5. Wenn Sie den Registrierungswert objtMessage verwenden möchten, anstatt ihn zu löschen, behalten Sie seinen bisherigen Wert bei, oder passen Sie ihn an.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986.

Weitere Informationen finden Sie im Knowledge Base-Artikel 830829, „Your Exchange Server 2003 computer may stop responding after a MAPI client opens more than the default value of certain server objects" unter (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829).


Die maximale Abfragehäufigkeit weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungswert, um zu bestimmen, ob der Wert des Abfrageintervalls für Microsoft Office Outlook® 2003- und Outlook 2007-Clients, die mithilfe von RPC über HTTP auf Exchange Server 2003 Exchange Server 2007 zugreifen, auf einen nicht dem Standard entsprechenden Wert geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Maximum Polling Frequency

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel Maximum Polling Frequency vorhanden und mit einem Wert konfiguriert ist, der größer ist als 0, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Bei der ersten Verbindung zu einem Exchange-Server registriert sich Outlook für die Benachrichtigung beim Eingang neuer Nachrichten. Wenn das Postfach eines Outlook-Benutzers eine neue Nachricht empfängt, sendet Exchange über UDP (User Datagram Protocol) eine Benachrichtigung an Outlook. Wenn Outlook diese Benachrichtigung empfängt, wird die Nachricht des Exchange-Servers abgerufen und im entsprechenden Ordner angezeigt. Wenn Outlook beim Eingang neuer Nachrichten keine Benachrichtigung empfängt, wird die Abfrage an den Exchange-Server wieder eingerichtet. Outlook initiiert die Abfrage, die Abfragehäufigkeit wird jedoch vom Exchange-Server vorgegeben.

In der Standardeinstellung sendet Outlook 2003 alle 60 Sekunden eine Abfrage. Sie können die Häufigkeit ändern, indem Sie dem Exchange-Server, der das Postfach des Benutzers enthält, den Registrierungseintrag Maximum Polling Frequency hinzufügen. Der Eingabewert stellt die minimale Anzahl von Millisekunden zwischen Abfrageintervallen dar. Wenn Maximum Polling Frequency nicht vorhanden ist, wird ein Standardwert von 60 Sekunden verwendet (60.000 Millisekunden). Dieser Standardwert bedeutet nicht, dass alle 60 Sekunden eine Abfrage durchgeführt wird. Vielmehr bedeutet dies, dass die Abfrage zu einem Zeitpunkt zwischen dem Abfragehäufigkeitsintervall und der doppelten Zeit dieses Intervalls durchgeführt wird. Angenommen, Maximum Polling Frequency ist auf 90 Sekunden festgelegt. In diesem Beispiel wird die Abfrage zwischen 90 und 180 Sekunden nach der letzten Abfrage durchgeführt.

Der Standardwert sollte nicht auf unter 60 Sekunden festgelegt werden, da die Leistung von Exchange, Outlook und des Netzwerks dadurch beeinträchtigt werden könnte. Sie müssen diesen Wert möglicherweise nicht anpassen, weil viele Benutzeraktionen als Teil der internen Operationen eine Überprüfung auf neue Nachrichten durchführen. Wenn z. B. ein Benutzer von einem zu einem anderen Ordner wechselt oder eine Nachricht öffnet, werden neue Elemente auf dem Server angezeigt. Wenn Outlook notwendige RPC-Anforderungen an Exchange sendet, um die Benutzeraktion umzusetzen, wird das Flag der neuen Nachricht überprüft. Die Benachrichtigung über den Empfang einer neuen Nachricht wird ggf. zusammen mit der RPC-Antwort an Outlook gesendet.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Löschen Sie den Registrierungswert Maximum Polling Frequency.

  4. Starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zu RPC über HTTP finden Sie im Handbuch Exchange Server 2003 RPC over HTTP Deployment Scenarios unter http://go.microsoft.com/fwlink/?LinkId=47577.


Minimaler ESE-Cache wurde manuell geändert
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2006-01-16

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs msExchESEParamCacheSizeMin für alle Postfachspeicherobjekte zu bestimmen. Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs msExchESEParamCacheSizeMin für einen beliebigen Postfachspeicher größer als 0 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Beim Speichern von Daten auf einem Datenträger verwendet der Microsoft Exchange-Informationsspeicherdienst den ESE-Cache (Extensible Storage Engine) als Puffer. Die maximale Größe des Caches von Exchange 2000 Server beträgt 858 MB. Exchange Server 2003 stellt auf der Grundlage des auf dem Server installierten physischen Arbeitsspeichers (RAM) den Standardwert der Eigenschaft msExchESEParamCacheSizeMin dynamisch fest.

Die maximale Cachegröße eines Exchange Server 2003-Computers, auf dem der Schalter /3 GB in der Datei boot.ini festgelegt wurde, beträgt 896 MB. Wurde der Schalter /3 GB hingegen nicht festgelegt, beträgt die maximale Cachegröße 576 MB.

Verwenden Sie folgende Daten, um den Wert der Eigenschaft msExchESEParamCacheSizeMin wieder auf den Standardwert zurückzusetzen:

  • Wenn Exchange Server 2003 unter Microsoft Windows Server™ 2003 ausgeführt wird und wenn auf dem Server 2 GB Arbeitsspeicher oder mehr installiert sind, beträgt der Wert von msExchESEParamCacheSizeMin 131072 (512 MB).

  • Wenn Exchange Server 2003 unter Windows Server 2003 ausgeführt wird, und wenn auf dem Server mindestens 768 MB, maximal jedoch weniger als 2 GB Arbeitsspeicher installiert sind, ist der Wert von msExchESEParamCacheSizeMin gleich RAM/4*(4*1024).

  • Wenn Exchange Server 2003 unter Windows Server 2003 ausgeführt wird und auf dem Server weniger als 768 MB Arbeitsspeicher installiert sind, ist der Wert von msExchESEParamCacheSizeMin gleich RAM/8*(4*1024).

Beispiel:

  • Für Windows Server 2003 mit 512 MB Arbeitsspeicher beträgt der Standardwert für msExchESEParamCacheSizeMin 16384 (4 KB Seiten).

  • Für Windows Server 2003 mit 1 GB Arbeitsspeicher beträgt der Standardwert für msExchESEParamCacheSizeMin 65536 (4 KB Seiten).

  • Für Windows Server 2003 mit 4 GB Arbeitsspeicher beträgt der Standardwert für msExchESEParamCacheSizeMin 131072 (4 KB Seiten).

  • Für Exchange Server 2003 unter Microsoft Windows® 2000 Server ist für msExchESEParamCacheSizeMin kein Standardwert festgelegt.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Windows Server 2003, Exchange Server 2003 oder beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Active Directory-Editor, z. B. die ADSI-Bearbeitung.

  2. Doppelklicken Sie auf den Container Konfiguration.

  3. Erweitern Sie CN=Services.

  4. Erweitern Sie CN=Microsoft Exchange.

  5. Erweitern Sie CN=<Name der Exchange-Organisation>.

  6. Erweitern Sie CN=Administrative Groups.

  7. Erweitern Sie CN=<Name der administrativen Gruppe>.

  8. Erweitern Sie CN=Servers.

  9. Erweitern Sie CN=<Name des Exchange-Servers>.

  10. Klicken Sie mit der rechten Maustaste auf CN=InformationStore, und klicken Sie dann auf Eigenschaften.

  11. Führen Sie im Feld Attribute einen Bildlauf zu msExchESEParamCacheSizeMin aus, und doppelklicken Sie darauf.

  12. Geben Sie im Feld Wert den gewünschten Wert ein. Sie können den Standardwert verwenden und ihn je nach Bedarf anpassen. Beachten Sie, dass es sich bei diesem Wert um ein Vielfaches von 32 MB handeln muss.

  13. Klicken Sie auf OK, und klicken Sie anschließend erneut auf OK.

  14. Schließen Sie den Active Directory-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Weitere Informationen zum Optimieren des Attributs msExchESEParamCacheSizeMin finden Sie im Microsoft Knowledge Base-Artikel 822894 „Jet Database Does Not Work Correctly During a Backup or During a Content Indexing Operation" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822894).


Die Anzahl der Threads für den Speichervorgang ist hoch.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Process ab, um den Wert für den Schlüssel ThreadCount für den Exchange-Informationsspeichervorgang zu ermitteln. Dieser Wert steht für die Anzahl aktiver Speicherungs-Threads auf dem Server. Bei mehr als 400 aktiven Speicherungs-Threads wird eine Warnmeldung angezeigt.

Dieses Problem wird sehr häufig durch inkompatible Antivirussoftware verursacht, die auf demselben Computer ausgeführt wird.

So beheben Sie diese Warnmeldung

  1. Wenden Sie sich an den Hersteller, um sicherzustellen, dass Sie aktuelle und mit Exchange kompatible Antivirussoftware ausführen.

  2. Aktualisieren Sie die Antivirussoftware.

Weitere Informationen zu Antivirussoftware und Exchange Server 2003 finden Sie im Microsoft Knowledge Base-Artikel 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://support.microsoft.com/kb/823166/de&kbid=823166).


Der Registrierungsparameter „OAB Bandwidth Threshold (KBps)" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungsschlüssel, um festzustellen, ob der Registrierungsschlüssel OAB Bandwidth Threshold (KBps) erstellt wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Wenn Exchange Server Analyzer erkennt, dass der Registrierungsschlüssel OAB Bandwidth Threshold (KBps) unter ParametersSystem erstellt wurde, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In Microsoft Exchange Server 2003 Service Pack 1 (SP1) kann der Administrator den Registrierungsschlüssel OAB Bandwidth Threshold (KBps) festlegen und konfigurieren, um die Standardfunktionen zu überschreiben und die Bandbreite für vollständige Downloads eines Offlineadressbuchs von einem bestimmten Öffentlichen Informationsspeicher zu beschränken.

In der Standardeinstellung werden die einzelnen Clientanforderungen für vollständige Downloads eines Offlineadressbuchs sofort beantwortet. Darüber hinaus ist in Öffentlichen Informationsspeichern die Anzahl der gleichzeitigen vollständigen Downloads von Offlineadressbüchern nicht beschränkt. Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich. Sie können allerdings den Registrierungsschlüssel OAB Bandwidth Threshold (KBps) löschen, wenn Sie die Standardkonfiguration wiederherstellen möchten.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Löschen Sie den Wert OAB Bandwidth Threshold (KBps).

  4. Schließen Sie den Registrierungs-Editor.

Der Microsoft Exchange-Informationsspeicherdienst erkennt innerhalb weniger Minuten die Änderungen. Sie müssen den Computer nicht neu starten.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Drosseln der belegten Bandbreite beim Download von Offlineadressbüchern finden Sie im Knowledge Base-Artikel 867623, „Throttling full offline Address Book downloads to limit the effect on a LAN in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=867623).


Offlineadressbuch ist keinem bestimmten Postfachspeicher zugeordnet
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob das Attribut msExchUseOAB in der Klasse msExchPrivateMDB so konfiguriert wurde, dass ein bestimmtes Offlineadressbuch für einen bestimmten Postfachspeicher in einer Datenbank verwendet werden soll. Mit der Klasse msExchPrivateMDB wird die Konfiguration für eine private Datenbank festgelegt. Mit dem Attribut msExchUseOAB wird ein bestimmtes Offlineadressbuch für die Verwendung durch einen bestimmten Postfachspeicher festgelegt. Wenn Microsoft Exchange Server Analyzer feststellt, dass das Offlineadressbuch für den Postfachspeicher in der Datenbank fehlt, zeigt Microsoft Exchange Server Analyzer eine Fehlermeldung an.

Ab Exchange 2000 Server wird allen Benutzern, die in einem Informationsspeicher enthalten sind, eine Offlineadressliste zugeordnet. Es ist nicht möglich, eine Offlineadressliste automatisch einem bestimmten Postfachspeicher zuzuordnen oder die globalen Offlineadresslisteneinstellungen für den Informationsspeicher oder die Speichergruppe außer Kraft zu setzen.

Wenn Sie einem bestimmten Postfachspeicher eine Offlineadressliste zuordnen möchten, müssen Sie zunächst eine Offlineadressliste erstellen, die eine gefilterte Kopie der globalen Adressliste enthält. Danach ordnen Sie die Offlineadressliste einem bestimmten Postfach zu, indem Sie das Attribut msExchUseOAB mithilfe des ADSI-Bearbeitungs-Snap-Ins (ADSI - Active Directory Service Interfaces) oder eines anderen LDAP-Clients (LDAP - Lightweight Directory Access Protocol), Version 3, auf den vollständigen DN (Distinguished Name) der Offlineadressliste festlegen.

Achtung:
Wenn Sie die ADSI-Bearbeitung, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, von Exchange Server 2003 bzw. Exchange Server 2007 oder beider Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

Ausführliche Anweisungen zum Zuordnen eines Offlineadressbuchs zu einem bestimmten Postfach finden Sie im Microsoft Knowledge Base-Artikel 275203 „Offline Address Book Cannot Be Associated with a Particular Mailbox" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=275203).

Weitere Informationen zu Offlineadressbüchern finden Sie unter Offline Address Book Best Practices Guide (http://go.microsoft.com/fwlink/?LinkId=47583).


OLD-Beendigungszeit für einen Informationsspeicher für Öffentliche Ordner weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die Startverzögerung für die Onlinedefragmentierung von seinem Standardwert in einen anderen Wert geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\OLD Completion Time

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel OLD Completion Time vorhanden ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht. Der Schlüssel OLD Completion Time gibt die Zeitspanne für die Onlinedefragmentierung in Sekunden an, nachdem das Fenster zur Informationsspeicherverwaltung geschlossen wurde. Der Standardwert beträgt 1 Stunde (3600 Sekunden).

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. Löschen Sie den Schlüssel OLD Completion Time.

  4. Schließen Sie den Registrierungseditor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Minimale OLD-Laufzeit für einen Informationsspeicher für Öffentliche Ordner weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob die minimale Laufzeit für die Onlinedefragmentierung von ihrem Standardwert in einen anderen Wert geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\OLD Minimum RunTime

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel OLD Minimum RunTime vorhanden ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht. Der Schlüssel OLD Minimum RunTime gibt in Sekunden an, wie lange die Onlinedefragmentierung mindestens ausgeführt wird.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. Löschen Sie den Schlüssel OLD Minimum RunTime.

  4. Schließen Sie den Registrierungseditor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Onlinedefragmentierung wurde deaktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchESEParamEnableOnlineDefrag jeder Speichergruppe zu ermitteln. Der Wert True gibt an, dass die Online-Datenbankwartung gemäß dem konfigurierten Zeitplan stattfindet. Der Wert False gibt an, dass die Online-Wartung nicht stattfindet. Wenn Microsoft Exchange Server Analyzer Tool feststellt, dass der Wert für das Attribut msExchESEParamEnableOnlineDefrag auf False festgelegt ist, wird ein Fehler angezeigt.

Die Online-Wartung der Datenbank in Exchange Server, einschließlich der Defragmentierung, ist von großer Bedeutung. Während dieses Intervalls werden Aufgaben wie Dumpster-Bereinigung (Löschen von Nachrichten, die das Datum für die Objektwiederherstellung überschritten haben), Bereinigung Öffentlicher Ordner (Nachrichten in Öffentlichen Ordnern gelten als abgelaufen, wenn sie ein bestimmtes Datum überschritten haben), Bereinigung gelöschter Postfächer und Onlinedefragmentierung (Ermitteln und Entfernen von nicht mehr verwendeten Datenbankobjekten, wodurch zusätzlicher Speicherplatz für Datenbanken verfügbar wird) ausgeführt. Durch diese Prozesse wird ein optimaler Betrieb und eine stabile Leistung des Exchange Server-Computers sichergestellt. Die Online-Datenbankwartung sollte nicht auf Nie ausführen eingestellt werden, da sonst die Leistung im Laufe der Zeit abfällt.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, von Exchange Server 2003 bzw. Exchange Server 2007 oder beider Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So beheben Sie diesen Fehler

  1. Klicken Sie auf Start, Ausführen, geben Sie MMC ein, und klicken Sie auf OK.

  2. In der Microsoft Management Console (MMC) klicken Sie auf Datei und anschließend auf Snap-In hinzufügen/entfernen.

  3. In der Liste Verfügbare eigenständige Snap-Ins wählen Sie ADSI Edit, klicken auf Hinzufügenund anschließend auf Schließen. Klicken Sie im Feld Snap-In hinzufügen/entfernen auf OK.

  4. Klicken Sie mit der rechten Maustaste auf ADSI Edit, und klicken Sie anschließend auf Verbinden mit. Im Listendialogfeld zum Auswählen eines bekannten Namenskontexts wählen Sie Konfiguration, und klicken Sie anschließend auf OK.

  5. Erweitern Sie den Container „Konfiguration" und anschließend CN=Konfiguration, CN=Dienste, CN=Microsoft Exchange, CN=<Name der Organisation>, CN=Administrative Gruppen, CN=<Name der administrativen Gruppe>, CN=Server, CN=<Servername>, CN=Informationsspeicher.

  6. Klicken Sie mit der rechten Maustaste auf CN=<Name der Speichergruppe>, und klicken Sie dann auf Eigenschaften.

  7. Im Eigenschaften-Dialogfeld der Speichergruppe wählen Sie msExchESEParamEnableOnlineDefrag in der Liste der Attribute, klicken auf Bearbeiten, und ändern Sie den Wert auf True.

  8. Schließen Sie ADSI Edit, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Weitere Informationen zur Onlinewartung von Datenbanken finden Sie in den folgenden Exchange-Ressourcen:

  • Microsoft Knowledge Base-Artikel 314214, "How to set maintenance intervals in data stores in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314214).

  • Exchange Server 2007 Insider-Artikel "Exchange Store Maintenance" (http://go.microsoft.com/fwlink/?LinkId=80787).


„Preferred Backfill Source" ist aktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest die folgenden Registrierungseinträge, um zu ermitteln, ob der Wert für den Schlüssel Preferred Backfill Source vom Standardwert abweicht:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des Öffentlichen Informationsspeichers>\Preferred Backfill Source

In der Standardeinstellung ist Preferred Backfill Source nicht vorhanden. Wenn Exchange Server Analyzer erkennt, dass Preferred Backfill Source vorhanden ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Ein Abgleich findet statt, wenn ein Öffentlicher Ordner ermittelt, dass er nicht alle Aktualisierungen für einen replizierten Ordner (oder für die Hierarchie) erhalten hat und die fehlenden Aktualisierungen von einem anderen Speicher abrufen muss.

Um den Abgleichvorgang zu rationalisieren, speichert Exchange Server Informationen über fehlende Aktualisierungen im Abgleich-Array.

Im Abgleich-Array werden diese Informationen für eine bestimmte Zeitspanne (genannt Abgleich-Zeitlimit) gespeichert. Wenn die fehlenden Aktualisierungen während dieser Zeitspanne in aufeinander folgenden Replikationsnachrichten eintreffen, werden sie aus dem Abgleich-Array entfernt. In der Tabelle werden die Standardwerte für das Abgleich-Zeitlimit aufgelistet, die davon abhängen, wo die fehlenden Aktualisierungen vorhanden sind und ob sie bereits vorher angefordert wurden.

Anforderungstyp | Inhalt ist in einem Speicher am lokalen Standort vorhanden | Inhalt ist in einem Speicher an einem Remotestandort vorhanden
Anfangsabgleich | 6 Stunden | 12 Stunden
Erster erneuter Abgleich | 12 Stunden | 24 Stunden
Weitere erneute Abgleiche | 24 Stunden | 48 Stunden

Wenn das Abgleich-Zeitlimit abläuft und die Aktualisierungen immer noch fehlen, erstellt Exchange Server 2003 eine oder mehrere Abgleichsanforderungen und bestimmt, welche Server als Abgleichsquellen verwendet werden.

Um einen (oder mehrere) Server als Abgleichquelle auszuwählen, erstellt Exchange Server 2003 zunächst eine Liste aller Server, die über Replikate des Ordners verfügen, und sortiert dann die Liste anhand der folgenden Reihenfolge von Kriterien:

  • Sortieren anhand des Serverstatus. Inaktive oder nicht verfügbare Server werden an das Ende der Liste gestellt.

  • Sortieren anhand bevorzugter Abgleichserver (falls vorhanden). Diese Funktion ist nur in Versionen ab Exchange Server 2003 verfügbar. Exchange Server 2003 überprüft das Informationsspeicherobjekt für Öffentliche Ordner im Active Directory®-Verzeichnisdienst auf einen bevorzugten Abgleichserver. Diese Einstellung wird selten verwendet. Unter den meisten Bedingungen wird der Abgleichvorgang am effektivsten durchgeführt, wenn Exchange Server 2003 automatisch einen Abgleichserver auswählt. Die meisten Bereitstellungen von Exchange Server 2003 benötigen keinen bevorzugten Abgleichserver. Wenn Ihre Bereitstellung dies erfordert, können Sie über den technischen Support von Microsoft ein Skript beziehen, das einen bevorzugten Abgleichserver festlegt.

  • Sortieren anhand von Transportkosten (niedrig nach hoch). Server am gleichen Standort bekommen Priorität über Server an Remotestandorten. Die Transportkosten eines Servers werden vom Exchange Server 2003-Routingmodul berechnet und normalerweise dazu verwendet, die effizienteste Art zum Übermitteln einer Nachricht zu berechnen. Beachten Sie, dass in Exchange-Versionen vor Exchange Server 2003 die Transportkosten geringere Priorität haben und erst nach der Exchange-Version und der Anzahl verfügbarer Änderungen berücksichtigt werden.

  • Sortieren anhand der Exchange-Version (neu nach alt).

  • Sortieren anhand der Anzahl notwendiger Änderungen, die auf dem Server verfügbar sind (hoch nach niedrig). Server ohne die fehlenden Änderungen werden aus der Liste entfernt.

Wenn ein Server nicht über alle erforderlichen Änderungen verfügt, wählt Exchange Server 2003 den nächsten Server in der sortierten Liste aus, und sendet auch an diesen Server eine Abgleichanfrage. Dieser Vorgang wird so lange wiederholt, bis alle Änderungen angefordert wurden. Diese Funktion ist nur in Exchange Server 2003 oder höher verfügbar. Wenn nicht alle fehlenden Aktualisierungen für einen bestimmten Ordner gleichzeitig auf einem Server vorhanden sind, senden Versionen von Exchange Abgleichanfragen zu einem Zeitpunkt nur an einen Server. Nach jeder Anfrage warten früherere Versionen von Exchange auf den Ablauf des Wiederholungszeitlimits (zwischen 24 und 48 Stunden), bevor sie die nächste Anfrage senden.

Wenn der ausgewählte Server nicht auf die Abgleichsanfrage antwortet, kennzeichnet der Speicher diesen Server als inaktiv und wiederholt den Auswählvorgang. Als inaktiv gekennzeichnete Server fallen an das Ende der Liste zurück.

In den meisten Fällen wird die Topologie effizient ausgeführt, wenn Exchange Server den Abgleichserver automatisch auswählen kann. Zur Fehlerbehebung kann der technische Support von Microsoft unter Umständen empfehlen, die Preferred Backfill Source einzustellen. Diese Einstellung sollten Sie jedoch nur vornehmen, um ein spezifisches Problem zu lösen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So setzen Sie den Registrierungsschlüssel Preferred Backfill Source zurück

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des Öffentlichen Informationsspeichers>

  3. Prüfen oder bearbeiten Sie die Werte für Preferred Backfill Source.

    Der Wert für diesen Registrierungseintrag wird in Kilobyte (KB) angegeben. Um wieder den Standardwert zu verwenden, müssen Sie den Schlüssel Preferred Backfill Source löschen und den Dienst Microsoft Exchange-Informationsspeicher neu starten.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Replikation von Öffentlichen Ordnern finden Sie in Working with the Exchange Server 2003 Store unter „Controlling Exchange Server 2003 Public Folder Replication" (http://go.microsoft.com/fwlink/?LinkId=47595).


Bevorzugte Abgleichquelle für Öffentliche Ordner ist aktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob Exchange mit einer bevorzugten Abgleichquelle für die Öffentliche Ordnerhierarchie konfiguriert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des Öffentlichen Informationsspeichers>\Preferred Backfill Source

Wenn Exchange Server Analyzer erkennt, dass der Registrierungseintrag Preferred Backfill Source vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Exchange Server 2003 führt ein neues Attribut für den Active Directory®-Verzeichnisdienst mit dem Namen msexchPreferredBackfillSource ein. Mit diesem Attribut kann angegeben werden, welcher Exchange-Server Abgleichanfragenachrichten erhalten soll.

Wenn ein Öffentlicher Ordner Inhalt replizieren muss, sendet er eine Abgleichanfrage an die Exchange-Organisation. Der erste reagierende Server mit Öffentlichen Ordnern wird verwendet, um die Daten abzugleichen. Diese Logik setzt voraus, dass der erste reagierende Server mit Öffentlichen Ordnern am nächsten liegt, dies ist jedoch nicht immer der Fall. In Exchange Server 2003 wurde eine Konfigurationsmöglichkeit eingeführt, mit der Administratoren einen bevorzugten Server zum Abgleichen angeben können.

Sie können in Exchange Server 2003 einen bevorzugten Server für den Abgleich von Hierarchien und Inhalten Öffentlicher Ordner festlegen. Verwenden Sie dazu entweder ein Active Directory-Attribut oder den Registrierungseintrag Preferred Backfill Source auf dem Server mit Öffentlichen Ordnern. Der Active Directory-Parameter wird zuerst überprüft. Wenn er nicht vorhanden ist, wird der Registrierungsparameter überprüft. Wenn dieser ebenfalls nicht vorhanden ist, wird der Standardalgorithmus für den Abgleich Öffentlicher Ordner verwendet.

Legen Sie den Distinguished Name (DN) des erforderlichen Abgleichspeichers für Öffentliche Ordner im Attribut msExchPreferredBackfillSource der Speicherobjekte für Öffentliche Ordner fest, um das Active Directory-Attribut zu verwenden.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

Wenn Sie das Attribut msExchPreferredBackfillSource in Active Directory bearbeiten möchten, müssen Sie einen Active Directory-Editor verwenden, z. B die ADSI-Bearbeitung (Active Directory Service Interfaces) oder das LDP-Tool (Ldp.exe).

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In, das LDP-Tool oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So geben Sie eine bevorzugte Abgleichquelle für Öffentliche Ordner in der Registrierung an

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des öffentlichen Informationsspeichers>

  3. Überprüfen und ändern Sie bei Bedarf den Wert für Preferred Backfill Source. Der einzugebende Wert ist der Distinguished Name (DN) des Exchange-Informationsspeichers für Öffentliche Ordner, der Ihre bevorzugte Quelle darstellt.

  4. Wenn eine Änderung vorgenommen wurde, heben Sie die Bereitstellung des Informationsspeichers für Öffentliche Ordner auf und stellen ihn dann erneut bereit, damit die Änderung wirksam wird.

So geben Sie eine bevorzugte Abgleichquelle für Öffentliche Ordner in Active Directory an

  1. Ändern Sie im Informationsspeicher für Öffentliche Ordner den Wert des betroffenen Objekts msExchPreferredBackfillSource, um auf die gewünschte Abgleichquelle zu verweisen. Das Attribut msExchPreferredBackfillSource befindet sich unter: CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=AdministrativeGroupName, CN=Servers, CN=ServerName, CN=InformationStore, CN=StorageGroupName, CN=Public Folder Store

  2. Der einzugebende Wert ist der Distinguished Name (DN) des Exchange-Informationsspeichers für Öffentliche Ordner, der Ihre bevorzugte Quelle darstellt.

  3. Wenn eine Änderung vorgenommen wurde, heben Sie die Bereitstellung des Informationsspeichers für Öffentliche Ordner auf und stellen ihn dann erneut bereit, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Ändern von Active Directory mit dem LDP-Tool finden Sie im Knowledge Base-Artikel 260745, „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260745).


Bereitstellen von zusätzlichen Speicherplatz
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2006-09-06

Microsoft® Exchange Server Analyzer hat festgestellt, dass der Speicherplatz auf den Datenträgern des Computers, auf dem Exchange Server ausgeführt wird, unterhalb der zulässigen Grenzen liegt. Exchange Server Analyzer misst den verfügbaren Plattenspeicherplatz, um sicherzustellen, dass die Speichergröße im akzeptablen Bereich liegt. Wenn das Tool feststellt, dass auf dem Datenträger zu wenig Speicher vorhanden ist, wird eine Fehlermeldung angezeigt. Es wird empfohlen, dass sich auf allen Datenträgern auf Computern, die Exchange Server ausführen, Postfächer befinden, die ständig mindestens 10 % der Speicherkapazität frei halten.

Exchange Server Analyzer testet die folgenden Laufwerke:

  • Datenbanklaufwerk

  • Temp-Laufwerk

  • MailRoot-Laufwerk

  • STM-Laufwerk

  • Systemlaufwerk

  • Protokolllaufwerk

    Hinweis:
    Die Statustabelle macht es erforderlich, die Größe des Protokolllaufwerks zu erhöhen und die Protokolle zu archivieren.
  • Auslagerungslaufwerk

So beheben Sie diesen Fehler

  1. Löschen Sie unnötige Dateien vom Datenträger, um Speicherplatz auf dem Datenträger freizugeben.

  2. Wenn der Datenträger, auf dem weniger als 10 % freier Speicherplatz verfügbar ist, Daten enthält, die sicher auf einen anderen Datenträger verschoben werden können (beispielsweise Postfächer oder die Microsoft Windows®-Auslagerungsdatei), führen Sie die zum Verschieben der Daten notwendigen Schritte aus.

  3. Fügen Sie auf dem Computer, der Exchange Server ausführt, Plattenspeicherkapazität hinzu.

  4. Reduzieren Sie die Größe der Postfächer oder verschieben Sie Benutzer zu einem anderen Server.

Weitere Informationen

  • Weitere Informationen zum Verschieben von Postfächern in Exchange Server 2003 finden Sie im Microsoft-Knowledge Base-Artikel 821829, "Postfächer in Exchange Server 2003 verschieben" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829.

  • Weitere Informationen zum Verschieben von Postfächern in Exchange 2000 Server und Exchange Server 5.5 finden Sie im Microsoft-Knowledge Base-Artikel 328810 „Moving mailboxes between servers" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810.

  • Weitere Informationen zum Festlegen von Postfachbegrenzungen mit Systemrichtlinien unter Exchange Server 2003 finden Sie im Microsoft Knowledge Base-Artikel 822938 „HOW TO: Use System Policies to Configure Mailbox Storage Limits in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=822938.

  • Weitere Informationen zum Festlegen von Postfachbegrenzungen mit Systemrichtlinien unter Exchange 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 319130 „HOW TO: Use System Policies to Configure Mailbox Storage Limits in Exchange Server 2000" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=822938.

  • Weitere Informationen zur Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange finden Sie unter Behandeln von Leistungsproblemen bei Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen zu den bewährten Methoden für das Entwerfen von Speicherarchitekturen finden Sie unter Bewährte Methoden für mehrere Architekturen (http://go.microsoft.com/fwlink/?LinkId=72988).

  • Weitere Informationen zu Datenträgerbemessung, -wartezeiten und -E/A-Raten finden Sie unter Berechnung der Anforderungen an die Datenträger-E/A (http://go.microsoft.com/fwlink/?linkid=69747).


Datenbankdatei des Informationsspeichers für Öffentliche Ordner wird auf Netzlaufwerk gespeichert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs msExchEDBFile für jeden Informationsspeicher für Öffentliche Ordner zu bestimmen. Dieses Attribut gibt die Position der von diesem Informationsspeicher für Öffentliche Ordner verwendeten Datenbankdateien an.

Exchange Server Analyzer sendet außerdem eine Abfrage an Active Directory, um die Anzahl der im Attribut homeMDBBL enthaltenen Werte jedes Postfachspeichers auf diesem Server zu bestimmen. Der Zählwert dieses Attributs stellt die Zahl der Postfächer im Postfachspeicher dar. Anschließend errechnet Exchange Server Analyzer die Gesamtzahl aller vom Server verwalteten Postfächer.

Wenn Exchange Server Analyzer dabei feststellt, dass das Attribut msExchEDBFile auf einem Exchange-Server mit mehr als 50 Postfächern mit \\ beginnt, wird ein Fehler angezeigt.

Dieser Fehler zeigt an, dass die Datenbankdateien für einen Informationsspeicher für Öffentliche Ordner auf dem Netzlaufwerk gespeichert werden. Wenn das Attribut msExchEDBFile mit \\ beginnt, bedeutet dies, dass der Protokolldateipfad ein UNC-Pfad (Universal Naming Convention) ist. Diese Vorgehensweise wird jedoch nicht empfohlen, da sie zu Unterbrechungen der Netzwerkverbindung und damit zu Datenbankfehlern, dem Verlust von Daten oder der Beschädigung von Datenbanken führen könnte. Es wird daher empfohlen, dieses Problem so schnell wie möglich zu beheben.

So verschieben Sie die Datenbankdateien auf ein neues Laufwerk

  1. Erweitern Sie im Exchange-System-Manager das Exchange Server-Objekt, auf dem sich der Informationsspeicher befindet. Erweitern Sie dann den entsprechenden Speichergruppencontainer, klicken Sie mit der rechten Maustaste auf das Informationsspeicherobjekt, das Sie verschieben möchten, und klicken Sie dann auf Eigenschaften.

  2. Geben Sie im Dialogfeld Eigenschaften auf der Registerkarte Datenbank den neuen Speicherort der Dateien an.

Weitere Informationen zu Exchange Server-Datenbankdateien finden Sie unter den folgenden Themen:

  • „Verwalten von Postfachspeichern und Informationsspeichern für Öffentliche Ordner" im Exchange Server 2003-Administratorhandbuch (http://www.microsoft.com/germany/technet/datenbank/articles/600271.mspx).

  • „Informationen zum Exchange-Informationsspeicher" im Handbuch Arbeiten mit dem Exchange Server 2003-Informationsspeicher (http://www.microsoft.com/downloads/details.aspx?displaylang=de).

Weitere Informationen zum Verwenden von Exchange Server mit Netzlaufwerken finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 328879, „Using Exchange Server with Storage Attached Network and network-attached storage devices" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328879)

  • 839687, „Microsoft support policy on the use of network-attached storage devices with Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839687)

  • 317173, „Exchange Server and network-attached storage" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317173)

  • 317172, „Exchange Server 5.5 and network-attached storage" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317172)


Der Wert für die maximal zulässige Größe der Datenbank des Informationsspeichers für Öffentliche Ordner wurde festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob der Registrierungswert Database Size Limit in Gb vorhanden und für den Informationsspeicher für Öffentliche Ordner konfiguriert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Server_Name>\Public-<MailboxStoreGUID>

Wenn Exchange Server Analyzer feststellt, dass der Wert Database Size Limit in Gb vorhanden und konfiguriert ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Beim Anwenden von Exchange Server 2003 Service Pack 2 (SP2) auf Exchange Server 2003 Standard Edition wird die hartcodierte, durch Lizenzierung festgelegte Datenbankgrößenbeschränkung von 16 GB auf 75 GB erhöht. Sie können zum Schutz der Datenbank eine Größenbeschränkung angeben, um eine unerwünschte Zunahme der Datenbankgröße zu verhindern. Der Standardwert für die Größenbeschränkung in SP2 beträgt 18 GB. Dieser Wert kann überschrieben werden, indem der Registrierungswert Database Size Limit in Gb erstellt wird.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<MailboxStoreGUID>

  3. Löschen Sie den Wert Database Size Limit in Gb.

  4. Schließen Sie den Registrierungs-Editor.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zu SP2 für Exchange Server 2003 finden Sie auf der Website zu Exchange Server 2003 Service Pack 2 unter http://go.microsoft.com/fwlink/?LinkId=52073.


Für den Informationsspeicher für Öffentliche Ordner wurde mehr als 8 Tage lang keine vollständige Sicherung durchgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer fragt den Informationsspeicher für Öffentliche Ordner ab, um das Datum und die Uhrzeit der letzten Sicherung zu ermitteln. Wenn Exchange Server Analyzer erkennt, dass die Anzahl von Tagen, die seit der letzen vollständigen Sicherung eines Informationsspeichers für Öffentliche Ordner vergangen ist, größer als 8 ist, wird eine Warnmeldung angezeigt.

Der Informationsspeicher für Öffentliche Ordner enthält Informationen, die einer bestimmten Öffentlichen Ordnerstruktur zugeordnet sind, z. B. die Art der Struktur und die darin enthaltenen Ordner. Außerdem enthält er Inhalt von Öffentlichen Ordnern. Ein Informationsspeicher für Öffentliche Ordner besteht aus einer EDB-Datei (Rich-Text) und einer STM-Datei (Streaming Native Internet Content) mit Internetinhalten.

Die Daten des Postfachspeichers und des Informationsspeichers für Öffentliche Ordner in Ihren Exchange Server-Datenbanken und Transaktionsprotokolldateien sind die Daten, deren Sicherung in Ihrer Exchange Server-Organisation am wichtigsten ist. Mithilfe einer Sicherung einer Exchange Server-Datenbank können Sie einen beschädigten Informationsspeicher für Öffentliche Ordner auf einem funktionstüchtigen Server unter Exchange Server wiederherstellen. Außerdem können Sie mithilfe der Sicherungen von Exchange Server-Datenbanken Ihre Exchange Server-Datenbanken auf einem anderen Server wiederherstellen.

Es wird empfohlen, täglich eine vollständige Sicherung Ihrer Datenbankdateien und Transaktionsprotokolle durchzuführen. Nach dem Durchführen einer vollständigen Sicherung einer Speichergruppe werden die übermittelten Transaktionsprotokolldateien in den Exchange Server-Datenbanken vom Server gelöscht. Durch eine vollständige Sicherung wird im Fall einer Wiederherstellung ein Geschwindigkeitsvorteil erreicht, da Sie zum Wiederherstellen sämtlicher Daten nur ein Band benötigen.

Hinweis:
Die optimale Methode besteht darin, die Transaktionsprotokolldateien auf einem besonderen Datenträger separat von den Datenbankdateien aufzubewahren. Diese Vorgehensweise stellt Fehlertoleranz im Falle von Beschädigungen des Datenbankdatenträgers sicher und verbessert sogar in manchen Fällen die Leistung der Datenbank.
Wichtig:
Wenn Sie versuchen, Dateien oder Ordner zu sichern oder wiederherzustellen, müssen Sie über die erforderlichen Berechtigungen für das Benutzerkonto verfügen, an dem Sie angemeldet sind. Zum Erstellen von Exchange Server-Sicherungen müssen Sie über Bedienerberechtigungen zum Sichern auf Domänenebene verfügen. Zum Erstellen von Sicherungen unter Microsoft Windows Server™ 2003 müssen Sie mindestens über lokale Bedienerberechtigungen für Sicherungen verfügen.

Die Sicherungsstrategie, die Sie für Ihre Exchange Server-Daten auswählen, hängt von der Größe der Speicher, der Geschwindigkeit der Sicherungssoftware und -hardware, der Hardwarekapazität und den zeitlichen Anforderungen ab.

Weitere Informationen zu Sicherungsstrategien und Wiederherstellungsoperationen finden Sie unter:

  • Exchange Server 2003-Handbuch zur Wiederherstellung nach Datenverlust (http://go.microsoft.com/fwlink/?linkid=47570).

  • Database Backup and Restore (http://go.microsoft.com/fwlink/?LinkID=80766).


Für den Informationsspeicher für Öffentliche Ordner wurde mehr als 60 Tage lang keine vollständige Sicherung durchgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer fragt den Informationsspeicher für Öffentliche Ordner ab, um das Datum und die Uhrzeit der letzten Sicherung zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass die Anzahl von Tagen, die seit der letzen vollständigen Sicherung eines Informationsspeichers für Öffentliche Ordner vergangen ist, größer als 60 ist, zeigt Exchange Server Analyzer einen Fehler an.

Der Informationsspeicher für Öffentliche Ordner enthält Informationen, die einer bestimmten Öffentlichen Ordner-Struktur zugeordnet sind, z. B. die Art der Struktur und die Ordner, die die Struktur enthält. Der Informationsspeicher für Öffentliche Ordner enthält auch den Inhalt der Öffentlichen Ordner. Ein Informationsspeicher für Öffentliche Ordner besteht aus einer Rich-Text-.edb-Datei und einer einheitlichen Streaming-.stm-Datei mit Internetinhalten.

Die Daten des Postfachspeichers und des Informationsspeichers für Öffentliche Ordner in Ihren Exchange Server-Datenbanken und Transaktionsprotokolldateien sind die Daten, deren Sicherung in Ihrer Exchange Server-Organisation am wichtigsten sind. Sie können eine Sicherung einer Exchange Server-Datenbank zum Wiederherstellen eines beschädigten Informationsspeichers für Öffentliche Ordner auf einem funktionstüchtigen Server unter Exchange Server verwenden. Außerdem können Sie Sicherungen von Exchange Server-Datenbanken zum Wiederherstellen Ihrer Exchange Server-Datenbanken auf einem anderen Server verwenden.

Als optimale Methode sollten Sie täglich eine vollständige Sicherung Ihrer Datenbankdateien und Transaktionsprotokolle durchführen. Nach dem Durchführen einer vollständigen Sicherung einer Speichergruppe werden die übermittelten Transaktionsprotokolldateien in den Exchange Server-Datenbanken vom Server gelöscht. Durch eine vollständige Sicherung wird im Fall einer Wiederherstellung ein Geschwindigkeitsvorteil erreicht, da Sie zum Wiederherstellen sämtlicher Daten nur ein Band benötigen.

Hinweis:
Die optimale Methode besteht darin, die Transaktionsprotokolldateien auf einem besonderen Datenträger separat von den Datenbankdateien aufzuheben. Durch diese optimale Methode wird nicht nur die Leistung der Datenbank verbessert, sondern außerdem im Fall der Zerstörung des Datenbankdatenträgers Fehlertoleranz gewährleistet.
Wichtig:
Wenn Sie versuchen, Dateien oder Ordner zu sichern oder wiederherzustellen, müssen Sie über die erforderlichen Berechtigungen für das Benutzerkonto verfügen, an dem Sie angemeldet sind. Zum Erstellen von Exchange Server-Sicherungen müssen Sie über Bedienerberechtigungen zum Sichern auf Domänenebene verfügen. Zum Erstellen von Sicherungen unter Microsoft Windows Server™ 2003 müssen Sie mindestens über lokale Bedienerberechtigungen für Sicherungen verfügen.

Die Sicherungsstrategie, die Sie für Ihre Exchange Server-Daten auswählen, hängt von der Größe der Speicher, der Geschwindigkeit der Sicherungssoftware und -hardware, der Hardwarekapazität und den zeitlichen Anforderungen ab.

Weitere Informationen zu Sicherungsstrategien und Wiederherstellungsoperationen finden Sie unter:

  • Exchange Server 2003-Handbuch zur Wiederherstellung nach Datenverlust (http://go.microsoft.com/fwlink/?linkid=47570).

  • Database Backup and Restore (http://go.microsoft.com/fwlink/?LinkId=80766).


Die Größe des Informationsspeichers für Öffentliche Ordner überschreitet 12 GB
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) CIM_DataFile ab, um den Wert des Schlüssels FileSize für jede Datenbankdatei (EDB-Datei) und Streamingdatei (STM-Datei) des Exchange-Informationsspeichers für Öffentliche Ordner zu bestimmen. Microsoft Exchange Server Analyzer liest auch den folgenden Registrierungszweig, um die installierte Version von Exchange Server zu bestimmen:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<GUID des Exchange-Produkts>

Wenn Microsoft Exchange Server Analyzer feststellt, dass eine Datenbankdatei und eine Streamingdatei des Informationsspeichers für Öffentliche Ordner gemeinsam die Größe von 12 GB auf einem Computer überschreiten, auf dem Microsoft Exchange Server 2003 Standard Edition oder Microsoft Exchange 2000 Server Standard Edition ausgeführt wird, wird eine Warnung angezeigt.

Exchange-Informationsspeicher-Datenbanken in Exchange Server 2003 Standard Edition und Exchange 2000 Server Standard Edition dürfen nicht größer als 16 GB sein. Nach Erreichen dieser Grenze wird kein Postfachspeicher mehr bereitgestellt, und der Zugriff auf Exchange wird verweigert. Exchange-Informationsspeicher-Datenbanken in Exchange Server 2003 Enterprise Edition und Exchange 2000 Server Enterprise Edition sind nicht auf 16 GB beschränkt. Sie sind nur durch die verfügbare Hardware auf eine theoretische Größe von 16 Terabyte beschränkt.

So beheben Sie diese Warnung

  1. Berücksichtigen Sie die Ablaufrichtlinien für Einstellungen in Öffentlichen Ordnern, um Nachrichten zu löschen, die ein bestimmtes Alter überschreiten.

  2. Legen Sie Speicherbegrenzungen für Informationsspeicher für Öffentliche Ordner und einzelne Öffentliche Ordner fest, um ein unbegrenztes Wachstum des Informationsspeichers für Öffentliche Ordner zu verhindern.

  3. Wenn Sie kürzlich Massennachrichten gelöscht oder Replikate für Öffentliche Ordner aus dem Informationsspeicher für Öffentliche Ordner entfernt haben, können Dateien mithilfe einer Offlinedefragmentierung möglicherweise verkleinert werden.
Hinweis:
Mit der Version von Exchange Server 2003 Service Pack 2 (SP2) wurde für Exchange Server 2003 Standard Edition die hartcodierte, durch Lizenzierung festgelegte Datenbankgrößenbeschränkung von 16 GB auf 75 GB erhöht. Der Administrator kann zum Schutz der Datenbank eine Größenbeschränkung festlegen (um eine unerwünschte Zunahme der Datenbankgröße zu verhindern). Der Standardwert in SP2 für Standard Edition ist 18 GB. Der Standardwert 18 GB kann durch Bearbeiten des Registrierungsschlüssels Database Size Limit in Gb überschrieben werden.
Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So konfigurieren Sie die Datenbankgrößenbeschränkung für eine Datenbank unter Exchange Server 2003 SP2

  1. Starten Sie auf dem Computer, auf dem Exchange Server ausgeführt wird, die Datei Regedit.exe.

  2. Öffnen Sie den folgenden Registrierungsschlüssel: HKLM\System\CurrentControlSet\Services\MSExchangeIS\Servername\GUID des Öffentlichen Informationsspeichers

  3. Klicken Sie mit der rechten Maustaste auf GUID des Öffentlichen Informationsspeichers, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  4. Geben Sie für den neuen Wertnamen Database Size Limit in Gb ein.

  5. Doppelklicken Sie auf Database Size Limit in Gb. Geben Sie unter Wert einen entsprechenden Wert für die maximale Datenbankgröße in GB ein. Geben Sie für Exchange Server 2003 Standard Edition einen Wert zwischen 1 und 75 ein (der Standardwert beträgt 18 GB). Geben Sie für Exchange Server 2003 Enterprise Edition einen Wert zwischen 1 und 8000 ein (der Standardwert beträgt 8000 GB). Klicken Sie auf OK.

  6. Klicken Sie mit der rechten Maustaste auf GUID des Öffentlichen Informationsspeichers, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  7. Geben Sie für den neuen WertnamenDatabase Size Buffer in Percentage ein.

  8. Doppelklicken Sie auf Database Size Buffer in Percentage. Geben Sie unter Wert einen Wert zwischen 1 und 100 ein. Mit diesem Wert geben Sie an, ab welchem Zeitpunkt Ereignisse protokolliert werden sollen, um Sie zu warnen, dass der Wert für die maximale Größe der Datenbank bald erreicht wird. Beim Standardwert 10 werden Warnereignisse protokolliert, sobald nur noch 10 % der Kapazität verfügbar sind, bevor die maximale Größe für die Datenbank erreicht wird. Klicken Sie auf OK.

  9. Klicken Sie mit der rechten Maustaste auf GUID des Öffentlichen Informationsspeichers, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  10. Geben Sie für den neuen Namen Database Size Check Start Time in Hours From Midnight ein.

  11. Doppelklicken Sie auf Database Size Check Start Time in Hours From Midnight. Geben Sie unter Wert einen Wert zwischen 0 und 23 ein, um anzugeben, wann die Datenbankgröße von Exchange überprüft werden soll. Beim Standardwert 5 wird die Datenbankgröße 5 Stunden nach 0:00 Uhr (5:00 Uhr) von Exchange Server überprüft. Klicken Sie auf OK.

  12. Schließen Sie den Registrierungs-Editor.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zu STM- und EDB-Dateien finden Sie im Microsoft Knowledge Base-Artikel 232323, „Native Content Storage in Microsoft Exchange" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323.

Weitere Informationen zum Verschieben von Postfächern in Exchange Server 2003 finden Sie im Knowledge Base-Artikel 821829, „Moving Mailboxes in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829.

Weitere Informationen zum Verschieben von Postfächern in Exchange 2000 Server finden Sie im Knowledge Base-Artikel 328810, „Moving mailboxes between servers" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810.

Weitere Informationen zum Durchführen von Offlinedefragmentierungen von Exchange Server-Datenbanken finden Sie im Knowledge Base-Artikel 328804, „So defragmentieren Sie Exchange-Datenbanken", unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804.

Weitere Informationen zum Festlegen der Speicherbegrenzungen in öffentlichen Ordnern finden Sie im Knowledge Base-Artikel 823144, „HOW TO: Configure Storage Limits on Public Folders in Exchange 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=823144.

Informationen zum Erreichen der maximalen Datenbankgröße in Exchange Server 2003 Standard Edition und Exchange 2000 Server Standard Edition finden Sie im Microsoft Knowledge Base-Artikel 828070, „Exchange Server-Postfachspeicher wird nicht bereitgestellt, wenn die Postfachspeicher-Datenbank das 16-GB-Limit erreicht" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070).

Weitere Informationen zu SP2 für Exchange Server 2003 finden Sie auf der Website zu Exchange Server 2003 Service Pack 2 unter http://go.microsoft.com/fwlink/?LinkId=52073.


Die Größe des Informationsspeichers für Öffentliche Ordner überschreitet 15 GB
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_DataFile ab, um den Wert des Schlüssels FileSize für jede Datenbankdatei (EDB-Datei) und Streamingdatei (STM-Datei) des Exchange-Informationsspeichers für Öffentliche Ordner zu bestimmen. Microsoft Exchange Server Analyzer liest auch den folgenden Registrierungszweig, um die installierte Version von Exchange Server zu bestimmen:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<GUID des Exchange-Produkts>

Wenn Microsoft Exchange Server Analyzer feststellt, dass eine Datenbankdatei und eine Streamingdatei des Informationsspeichers für Öffentliche Ordner gemeinsam die Größe von 15 GB auf einem Computer überschreiten, auf dem Microsoft Exchange Server 2003 Standard Edition oder Exchange 2000 Server Standard Edition ausgeführt wird, wird ein Fehler angezeigt.

Exchange-Informationsspeicher-Datenbanken in Exchange Server 2003 Standard Edition und Exchange 2000 Server Standard Edition dürfen nicht größer als 16 GB sein. Nach Erreichen dieser Grenze wird kein Postfachspeicher mehr bereitgestellt, und der Zugriff auf Exchange wird verweigert. Exchange-Informationsspeicher-Datenbanken in Exchange Server 2003 Enterprise Edition und Exchange 2000 Server Enterprise Edition sind nicht auf 16 GB beschränkt. Sie sind nur durch die verfügbare Hardware auf eine theoretische Größe von 16 Terabyte beschränkt.

So beheben Sie diesen Fehler

  1. Berücksichtigen Sie die Ablaufrichtlinien für Einstellungen in Öffentlichen Ordnern, um Nachrichten zu löschen, die ein bestimmtes Alter überschreiten.

  2. Legen Sie Speicherbegrenzungen für Informationsspeicher für Öffentliche Ordner und einzelne Öffentliche Ordner fest, um ein unbegrenztes Wachstum des Informationsspeichers für Öffentliche Ordner zu verhindern.

  3. Wenn Sie kürzlich Massennachrichten gelöscht oder Replikate für Öffentliche Ordner aus dem Informationsspeicher für Öffentliche Ordner entfernt haben, können Dateien mithilfe einer Offlinedefragmentierung möglicherweise verkleinert werden.
Hinweis:
Mit der Version von Exchange Server 2003 Service Pack 2 (SP2) für Exchange Server 2003 Standard Edition wurde die hartcodierte, durch Lizenzierung festgelegte Datenbankgrößenbeschränkung von 16 GB auf 75 GB erhöht. Der Administrator kann zum Schutz der Datenbank eine Größenbeschränkung festlegen (um eine unerwünschte Zunahme der Datenbankgröße zu verhindern). Der Standardwert in SP2 für Standard Edition ist 18 GB. Der Standardwert 18 GB kann durch Bearbeiten des Registrierungsschlüssels Database Size Limit in Gb überschrieben werden.
Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So konfigurieren Sie die Datenbankgrößenbeschränkung für eine Datenbank unter Exchange Server 2003 SP2

  1. Starten Sie auf dem Computer, auf dem Exchange Server ausgeführt wird, die Datei Regedit.exe.

  2. Öffnen Sie den folgenden Registrierungsschlüssel: HKLM\System\CurrentControlSet\Services\MSExchangeIS\Servername\GUID des Öffentlichen Informationsspeichers

  3. Klicken Sie mit der rechten Maustaste auf GUID des Öffentlichen Informationsspeichers, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  4. Geben Sie für den neuen Wertnamen Database Size Limit in Gb ein.

  5. Doppelklicken Sie auf Database Size Limit in Gb. Geben Sie unter Wert einen entsprechenden Wert für die maximale Datenbankgröße in GB ein. Geben Sie für Exchange Server 2003 Standard Edition einen Wert zwischen 1 und 75 ein (der Standardwert beträgt 18 GB). Geben Sie für Exchange Server 2003 Enterprise Edition einen Wert zwischen 1 und 8000 ein (der Standardwert beträgt 8000 GB). Klicken Sie auf OK.

  6. Klicken Sie mit der rechten Maustaste auf GUID des Öffentlichen Informationsspeichers, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  7. Geben Sie für den neuen WertnamenDatabase Size Buffer in Percentage ein.

  8. Doppelklicken Sie auf Database Size Buffer in Percentage. Geben Sie unter Wert einen Wert zwischen 1 und 100 ein. Mit diesem Wert geben Sie an, ab welchem Zeitpunkt Ereignisse protokolliert werden sollen, um Sie zu warnen, dass der Wert für die maximale Größe der Datenbank bald erreicht wird. Beim Standardwert 10 werden Warnereignisse protokolliert, sobald nur noch 10 % der Kapazität verfügbar sind, bevor die maximale Größe für die Datenbank erreicht wird. Klicken Sie auf OK.

  9. Klicken Sie mit der rechten Maustaste auf GUID des Öffentlichen Informationsspeichers, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  10. Geben Sie für den neuen Namen Database Size Check Start Time in Hours From Midnight ein.

  11. Doppelklicken Sie auf Database Size Check Start Time in Hours From Midnight. Geben Sie unter Wert einen Wert zwischen 0 und 23 ein, um anzugeben, wann die Datenbankgröße von Exchange überprüft werden soll. Beim Standardwert 5 wird die Datenbankgröße 5 Stunden nach 0:00 Uhr (5:00 Uhr) von Exchange Server überprüft. Klicken Sie auf OK.

  12. Schließen Sie den Registrierungs-Editor.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zu STM- und EDB-Dateien finden Sie im Microsoft Knowledge Base-Artikel 232323, „Native Content Storage in Microsoft Exchange" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323.

Weitere Informationen zum Verschieben von Postfächern in Exchange Server 2003 finden Sie im Knowledge Base-Artikel 821829, „Moving Mailboxes in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829.

Weitere Informationen zum Verschieben von Postfächern in Exchange 2000 Server finden Sie im Knowledge Base-Artikel 328810, „Moving mailboxes between servers" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810.

Weitere Informationen zum Durchführen von Offlinedefragmentierungen von Exchange Server-Datenbanken finden Sie im Knowledge Base-Artikel 328804, „So defragmentieren Sie Exchange-Datenbanken", unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804.

Weitere Informationen zum Festlegen der Speicherbegrenzungen in öffentlichen Ordnern finden Sie im Knowledge Base-Artikel 823144, „HOW TO: Configure Storage Limits on Public Folders in Exchange 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=823144.

Informationen zum Erreichen der maximalen Datenbankgröße in Exchange Server 2003 Standard Edition und Exchange 2000 Server Standard Edition finden Sie im Knowledge Base-Artikel 828070, „Exchange Server-Postfachspeicher wird nicht bereitgestellt, wenn die Postfachspeicher-Datenbank das 16-GB-Limit erreicht" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070.

Weitere Informationen zu SP2 für Exchange Server 2003 finden Sie auf der Website zu Exchange Server 2003 Service Pack 2 unter http://go.microsoft.com/fwlink/?LinkId=52073.


Der Informationsspeicher für Öffentliche Ordner besitzt keine E-Mail-Adresse
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2006-03-28

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den für das Attribut mail konfigurierten Wert für jeden Informationsspeicher für Öffentliche Ordner zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass das Attribut mail für keinen Informationsspeicher für Öffentliche Ordner konfiguriert ist, wird ein Fehler angezeigt.

Wenn ein Informationsspeicher für Öffentliche Ordner nicht mit einer SMTP-Adresse (Simple Mail Transfer Protocol) konfiguriert ist, funktioniert die Hierarchiereplikation für Öffentliche Ordner für den Informationsspeicher nicht ordnungsgemäß.

Aus technischer Sicht handelt es sich bei einem Informationsspeicher für Öffentliche Ordner um einen besonderen Typ von Exchange-Postfach. Wie für alle postfachaktivierten Objekte müssen für einen Informationsspeicher für Öffentliche Ordner zum Senden und Empfangen von Mail die folgenden Attribute korrekt konfiguriert sein:

  • legacyExchangeDN: Dies ist der Distinguished Name für das Objekt im Exchange-Format.

  • proxyAddresses: Dieses Attribut enthält alle E-Mail-Adressen, die für das Senden von Mail an diesen Empfänger verwendet werden können.

  • textEncodedORAddress: Dieses Attribut enthält die primäre X.400-Adresse.

  • Mail: Dieses Attribut enthält die primäre SMTP-Adresse des Objekts ohne Adressenpräfix.

  • mailNickname: Dieses Attribut wird zum Erstellen des URL für den Zugriff auf das Postfach verwendet.

  • displayName: Dieses Attribut enthält den Anzeigenamen des Objekts, wie er in der globalen Adressliste und allen anderen Adresslisten auftritt, in denen das Objekt Mitglied ist.

Wenn das Attribut mail für einen Informationsspeicher für Öffentliche Ordner nicht festgelegt ist, bedeutet dies häufig, dass der Empfängeraktualisierungsdienst nicht konfiguriert ist bzw. nicht ordnungsgemäß funktioniert. Es gibt zwei Typen von Empfängeraktualisierungsdiensten. Der eine Dienst ist zuständig für die Verarbeitung von Exchange-Systemobjekten im Konfigurationscontainer (der Enterprise-Empfängeraktualisierungsdienst), und der andere für die Verarbeitung der Empfänger in jeder Domäne (ein Domänen-Empfängeraktualisierungsdienst).

In der Active Directory-Gesamtstruktur gibt es nur einen Enterprise-Empfängeraktualisierungsdienst, da nur ein Konfigurationscontainer vorhanden ist. Dieser Empfängeraktualisierungsdienst konfiguriert u. a. das Attribut mail für den Informationsspeicher für Öffentliche Ordner. Wenn dieser Empfängeraktualisierungsdienst deaktiviert oder falsch konfiguriert ist, oder wenn beim Empfängeraktualisierungsdienst ein Problem auftritt, sind möglicherweise die Attribute falsch konfiguriert, und die Replikation Öffentlicher Ordner funktioniert nicht ordnungsgemäß. Sie sollten dieses Problem beheben, indem Sie die Konfiguration des Enterprise-Empfängeraktualisierungsdienstes überprüfen.

So beheben Sie diesen Fehler

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie den Eintrag Empfänger, und wählen Sie dann den Knoten Empfängeraktualisierungsdienste aus.

  3. Klicken Sie im rechten Bereich mit der rechten Maustaste auf den Empfängeraktualisierungsdienst, in dessen Name (Enterprise-Konfiguration) vorkommt, und klicken Sie auf Eigenschaften.

  4. Vergewissern Sie sich, dass im Feld Domäne der korrekte Domänenname aufgeführt ist.

  5. Vergewissern Sie sich, dass die in den Feldern Exchange-Server und Windows-Domänencontroller aufgeführten Computer normal funktionieren und im Netzwerk verfügbar sind. Wenn diese Systeme nicht aktiv oder nicht verfügbar sind oder nicht die für die Durchführung der Aufgaben eines Empfängeraktualisierungsdienstes erforderlichen Systeme sind, können Sie mit der Schaltfläche Durchsuchen des Feldes einen anderen Computer angeben.

  6. Vergewissern Sie sich, dass das Aktualisierungsintervall auf Immer ausführen festgelegt ist.

  7. Klicken Sie auf OK, um die Änderungen zu speichern.

  8. Klicken Sie im rechten Bereich mit der rechten Maustaste auf den Empfängeraktualisierungsdienst, in dessen Name (Enterprise-Konfiguration) vorkommt, und wählen Sie Neu erstellen aus. Die folgende Meldung wird angezeigt:

    „Durch diesen Vorgang werden die Mitgliedschaften der Adressliste und die Einstellungen der Empfängerrichtlinien aller Empfänger in contoso.com im nächsten festgelegten Aktualisierungsintervall neu berechnet. Je nach Anzahl der Empfänger in der Domäne kann dies einige Stunden dauern. Möchten Sie fortfahren?"

  9. Klicken Sie auf Ja, um den Empfängeraktualisierungsdienst neu zu erstellen.

  10. Beginnen Sie nach 15 Minuten, den Fortschritt des Empfängeraktualisierungsdienstes zu überwachen. Folgen Sie dazu den Verfahren, die im Microsoft Knowledge Base-Artikel 246127 beschrieben sind („XADM: How to Check the Progress of the Recipient Update Service" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127).

Weitere Informationen zum Empfängeraktualisierungsdienst finden Sie in den folgenden Knowledge Base-Artikeln:

  • 296479, „XADM: Requirements for Disabling the Recipient Update Service" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=296479)

  • 328738, „XADM: How the Recipient Update Service Applies Recipient Policies" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253770, „XADM: Tasks Performed by the Recipient Update Service" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 288807, „Troubleshooting the Recipient Update Service" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=288807)

  • 319065, „HOW TO: Work with the Exchange Recipient Update Service" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319065).


Informationsspeicher für Öffentliche Ordner wird beim Start nicht bereitgestellt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer sendet eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert des Attributs msExchEDBOffline für alle Objekte mit der Klasse msExchPublicMDB zu bestimmen. Bei Objekten mit dieser Klasse handelt es sich um Informationsspeicher für Öffentliche Ordner.

Der Wert True für das msExchEDBOffline-Attribut gibt an, dass der Informationsspeicher für Öffentliche Ordner beim Start des Microsoft Exchange-Informationsspeicherdiensts nicht automatisch bereitgestellt wird. Der Wert False gibt an, dass der Informationsspeicher für Öffentliche Ordner beim Start bereitgestellt wird. Wenn Exchange Server Analyzer feststellt, dass der Wert für dieses Attribut auf True festgelegt ist, wird eine Warnung angezeigt.

Diese Warnung gibt an, dass das Kontrollkästchen Diesen Informationsspeicher beim Start nicht bereitstellen aktiviert ist. Dieses Kontrollkästchen befindet sich im Dialogfeld Eigenschaften des Informationsspeicher für Öffentliche Ordner auf der Registerkarte Datenbank. Wenn das Kontrollkästchen aktiviert ist, wird der Informationsspeicher für Öffentliche Ordner beim Start des Microsoft Exchange-Informationsspeicherdiensts nicht automatisch bereitgestellt. Beim nächsten Start des Microsoft Exchange-Informationsspeicherdiensts, z. B. nach einem Neustart des Servers, wird ein Postfachspeicher, für den dieses Attribut auf True festgelegt ist, nicht bereitgestellt. Es wird empfohlen, dass Informationsspeicher für Öffentliche Ordner automatisch bereitgestellt werden, wenn der Microsoft Exchange-Informationsspeicherdienst gestartet wird.

So vermeiden Sie diese Warnung in Exchange 2000 Server und Exchange Server 2003

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Server, und erweitern Sie dann den Server mit dem Informationsspeicher für Öffentliche Ordner, den Sie ändern möchten.

  3. Erweitern Sie die Speichergruppe, die den Informationsspeicher für Öffentliche Ordner enthält, den Sie ändern möchten.

  4. Klicken Sie mit der rechten Maustaste auf den Informationsspeicher für Öffentliche Ordner, und klicken Sie dann auf Eigenschaften.

  5. Deaktivieren Sie auf der Registerkarte Datenbank das Kontrollkästchen Diesen Informationsspeicher beim Start nicht bereitstellen.

  6. Klicken Sie zum Speichern der Einstellung auf OK.

  7. Schließen Sie den Exchange-System-Manager.

So vermeiden Sie diese Warnung in Exchange Server 2007

  1. Öffnen Sie die Exchange-Verwaltungskonsole.

  2. Erweitern Sie Serverkonfiguration und dann den Server, mit dem Sie arbeiten möchten.

  3. Erweitern Sie die Speichergruppe, mit der Sie arbeiten möchten.

  4. Klicken Sie mit der rechten Maustaste auf die Öffentliche Ordner-Datenbank, mit der Sie arbeiten möchten, und klicken Sie dann auf Eigenschaften.

  5. Deaktivieren Sie auf der Registerkarte Allgemein das Kontrollkästchen Diese Datenbank beim Start nicht bereitstellen.

  6. Klicken Sie zum Speichern der Einstellung auf OK.

  7. Schließen Sie die Exchange-Verwaltungskonsole.

Weitere Informationen zu dieser Option finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 314218, „HOW TO: Turn Off or Turn On Automatic Mounting of Data Stores at Startup in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314218)

  • 285169, „XADM: Information Stores Do Not Mount After You Use the "/disasterrecovery" Switch" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285169)


Datenbankzuordnung für Öffentliche Ordner-Struktur
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchOwningPFTreeBL für jede Objektklasse msExchPFTree zu ermitteln. Im Attribut msExchOwningPFTreeBL wird eine Liste von Distinguished Names für Informationsspeicher für Öffentliche Ordner gespeichert, die ein Replikat der Öffentlichen Ordner-Struktur enthalten. Wenn Exchange Server Analyzer feststellt, dass das Attribut msExchOwningPFTreeBL für ein Objekt im Informationsspeicher für Öffentliche Ordner leer ist, wird eine Warnung angezeigt. Diese Warnung zeigt an, dass die Öffentliche Ordner-Struktur keinem Informationsspeicher für Öffentliche Ordner gehört.

Jede Öffentliche Ordner-Struktur (auch als „Öffentliche Ordner-Hierarchie" bezeichnet) hat eine Verknüpfung zurück zu einem Informationsspeicher für Öffentliche Ordner. Sie müssen zuerst die Struktur und danach den Informationsspeicher erstellen. Wenn die Struktur noch nicht mit einer Datenbank verknüpft wurde, wird diese Warnung angezeigt. Jede Öffentliche Ordner-Struktur kann nur über einen Informationsspeicher auf einem bestimmten Server verfügen. Eine Struktur kann über mehrere Informationsspeicher verfügen, wenn sich die einzelnen Informationsspeicher auf separaten Servern befinden. Mit einer derartigen Konfiguration repliziert Exchange die Informationen zwischen den Informationsspeichern, um die Hierarchie konsistent zu halten.

Wenn Microsoft Office Outlook® Web Access-Clients versuchen, eine Verbindung mit einem Öffentlichen Ordner innerhalb der Struktur herzustellen, der keinen zugehörigen Informationsspeicher für Öffentliche Ordner hat, tritt der Fehler Dienst ist nicht verfügbar (HTTP 503) auf.

Sie können diese Warnmeldung durch eine der folgenden Vorgehensweisen beheben:

  • Verknüpfen Sie die Öffentliche Ordner-Struktur mit einer Öffentlichen Ordner-Datenbank. Um die Öffentliche Ordner-Struktur mit einer Öffentlichen Ordner-Datenbank zu verknüpfen, müssen Sie zuerst eine neue Öffentliche Ordner-Datenbank erstellen, danach die Öffentliche Ordner-Struktur suchen und beide verknüpfen.

  • Löschen Sie die Öffentliche Ordner-Struktur. Wenn die Öffentliche Ordner-Struktur noch nicht mit einer Öffentlichen Ordner-Datenbank verknüpft wurde, gehen keine Benutzerdaten verloren, wenn Sie die Struktur löschen.

So verknüpfen Sie die Öffentliche Ordner-Struktur mit einer Öffentlichen Ordner-Datenbank.

  1. Erweitern Sie im Exchange-System-Manager den Server, den Sie zu einem Informationsspeicher für Öffentliche Ordner hinzufügen möchten.

  2. Klicken Sie mit der rechten Maustaste auf eine bestimmte Speichergruppe, zeigen Sie auf Neu, und klicken Sie dann auf Öffentlicher Informationsspeicher.

  3. Geben Sie bei Name einen Namen für die neue Datenbank ein.

  4. Um eine Öffentliche Ordner-Struktur mit der Datenbank zu verknüpfen, klicken Sie auf Durchsuchen, und wählen Sie dann die Öffentliche Ordner-Struktur aus, die in der Warnung von Exchange Server Analyzer angezeigt wird.

  5. Um Ihre Einstellungen zu speichern, klicken Sie auf OK.

  6. Um den neuen Informationsspeicher bereitzustellen, klicken Sie auf Ja.

So löschen Sie die Öffentliche Ordner-Struktur

  1. Erweitern Sie im Exchange-System-Manager den Knoten Ordner für den Ordner, in dem sich die Öffentliche Ordner-Struktur befindet.

  2. Klicken Sie mit der rechten Maustaste auf die Öffentliche Ordner-Struktur, die Sie löschen möchten, klicken Sie auf Löschen, und klicken Sie danach auf Ja.

Weitere Informationen zur Verwaltung von Öffentlichen Ordnern finden Sie im Abschnitt „Verwalten von Postfachspeichern und Informationsspeichern für Öffentliche Ordner" im Exchange Server 2003-Administratorhandbuch unter http://go.microsoft.com/fwlink/?linkid=47617.

Weitere Informationen finden Sie in der Onlinehilfe zu Exchange Server 2003 Service Pack 1 (SP1) unterhttp://go.microsoft.com/fwlink/?LinkId=29847.


Speichergruppe für die Wiederherstellung aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer sendet eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert des Attributs msExchESEParamBaseName für alle Objekte mit der Klasse msExchStorageGroup zu bestimmen. Bei Objekten mit dieser Klasse handelt es sich um Speichergruppenobjekte. Der Wert R00 für das Attribut msExchESEParamBaseName zeigt an, dass es sich bei dem Speichergruppenobjekt um eine Speichergruppe für die Wiederherstellung handelt. Stellt Exchange Server Analyzer fest, dass der Wert für dieses Attribut R00 ist, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass eine Speichergruppe für die Wiederherstellung vorhanden ist. Es wird empfohlen, eine Speichergruppe für die Wiederherstellung nach dem Wiederherstellungsvorgang zu löschen. Wenn Sie Speichergruppen für die Wiederherstellung nicht löschen, können Administratoren, die mit diesen Gruppen nicht vertraut sind, beim zukünftigen Durchführen einer Standardwiederherstellung verwirrt werden.

So vermeiden Sie diese Warnung in Exchange 2000 Server und Exchange Server 2003

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Server, und erweitern Sie dann den Server, der die zu löschende Speichergruppe für die Wiederherstellung enthält.

  3. Klicken Sie mit der rechten Maustaste auf die Speichergruppe für die Wiederherstellung, und klicken Sie dann auf Löschen.

  4. Schließen Sie den Exchange-System-Manager.

So vermeiden Sie diese Warnung in Exchange Server 2007

  1. Befolgen Sie die Anweisungen in der Exchange Server 2007-Hauptdokumentation unter "Entfernen einer Speichergruppe für die Wiederherstellung" (http://www.microsoft.com/technet/prodtechnol/exchange/E2k7/DE/Help/ExchHelp/f3f4c21f-1d5c-4c66-8721-548032abd87e.mspx?mfr=true).

Weitere Informationen zu Speichergruppen für die Wiederherstellung und Exchange Server 2003finden Sie unter Using Exchange Server 2003 Recovery Storage Groups (http://go.microsoft.com/fwlink/?LinkId=23233) und im Microsoft Knowledge Base-Artikel 824126, "Verwenden von Speichergruppen für die Wiederherstellung in Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=824126).

Weitere Informationen zu Speichergruppen für die Wiederherstellung und Exchange Server 2007 finden Sie unter "Grundlagen von Speichergruppen für die Wiederherstellung" (http://www.microsoft.com/technet/prodtechnol/exchange/E2k7/DE/Help/ExchHelp/a65ef04e-a0db-47a5-8d88-41a532d69872.mspx?mfr=true).


Die Funktionen der Speichergruppe für die Wiederherstellung wurden deaktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob das Attribut msExchMaxRestoreStorageGroups geändert wurde. Wenn Exchange Server Analyzer feststellt, dass das Attribut msExchMaxRestoreStorageGroups auf 0 festgelegt wurde, wird von Exchange Server Analyzer ein Fehler angezeigt.

Bei dem Attribut msExchMaxRestoreStorageGroups handelt es sich um ein binäres Attribut des Informationsspeicherobjekts für die einzelnen Exchange-Computer. Wenn das Attribut msExchMaxRestoreStorageGroups auf 0 festgelegt ist, können die Wiederherstellungsspeichergruppen für den jeweiligen Exchange-Computer nicht erstellt werden.

Dieser Fehler kann eintreten, wenn Sie direkt eine Aktualisierung von Exchange 2000 Server SP3 auf Exchange Server 2003 SP1 in einem Windows-Cluster vorgenommen haben, wobei der virtuelle Exchange-Server nicht mit Exchange Server 2003 aktualisiert wurde. Beachten Sie, dass möglicherweise durch diese direkte Aktualisierung zuweilen auch Fehler bei Outlook® Mobile Access bewirkt werden können.

Sie müssen den Fehler bei der Wiederherstellung der Speichergruppe korrigieren, indem Sie das AttributmsExchMaxRestoreStorageGroups auf 1 für das Informationsspeicherobjekt eines jeden Exchange-Computers festlegen. Die betroffenen Informationsspeicherobjekte werden in der Ausgabe von Microsoft Exchange Server Analyzer angezeigt. Wenn Sie bei Problemen mit Outlook Mobile Access Hilfe benötigen, wenden Sie sich an den technischen Support von Microsoft.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, von Exchange Server 2003 bzw. Exchange Server 2007 oder beider Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So korrigieren Sie den beim Wiederherstellen einer Speichergruppe auftretenden Fehler

  1. Starten Sie die ADSI-Bearbeitung.

  2. Doppelklicken Sie auf den Container Konfiguration, erweitern Sie CN=Services, erweitern Sie CN=Microsoft Exchange, und erweitern Sie dann CN=<Name der Exchange-Organisation>.

  3. Erweitern Sie CN=Administrative Groups, erweitern Sie CN=<AdministrativeGroupName>, und erweitern Sie dann CN=Servers.

  4. Klicken Sie mit der rechten Maustaste im Detailbereich auf CN=InformationStore, und klicken Sie dann auf Eigenschaften.

  5. Im Attribut-Editor klicken Sie auf das Attribut msExchMaxRestoreStorageGroups und anschließend auf Bearbeiten.

  6. Geben Sie im Feld zum Bearbeiten von Attributen den Wert 1 ein.

  7. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.

  8. Schließen Sie die ADSI-Bearbeitung. Starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Weitere Informationen zur Verwendung des LDP-Tools finden Sie im Knowledge Base-Artikel 260745, „XADM: Using the LDP Utility to Modify Active Directory Object Attributes" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Weitere Informationen zu Exchange-Speichergruppen für die Wiederherstellung finden Sie in den folgenden Exchange-Ressourcen:

  • Using Exchange Server 2003 Recovery Storage Groups (http://go.microsoft.com/fwlink/?LinkId=47589).

  • Grundlagen von Speichergruppen für die Wiederherstellung (http://www.microsoft.com/technet/prodtechnol/exchange/E2k7/DE/Help/ExchHelp/a65ef04e-a0db-47a5-8d88-41a532d69872.mspx?mfr=true


Verfallsereignisse (Replikation) für Server mit Öffentlichen Ordnern entspricht nicht dem Standard
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2006-05-25

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungswert, um zu bestimmen, ob das Intervall, in dem der Exchange-Informationsspeicher Elemente entfernt, die die Aufbewahrungsdauer überschritten haben, geändert wurde und nicht mehr dem Standard entspricht:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<GUID des Öffentlichen Ordners>\Replication Expiry

Wenn Exchange Server Analyzer erkennt, dass der Registrierungswert Replication Expiry vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Als Nachrichtenablauf wird der Prozess des Ablaufs von Nachrichten in Öffentlichen Ordnern bezeichnet, die einen bestimmten zeitlichen Wert überschritten haben. Das Standardintervall für den Nachrichtenablauf beträgt 24 Stunden.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess der Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>

  3. Löschen Sie den Registrierungswert Replication Expiry.

  4. Starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zur Replikation Öffentlicher Ordner finden Sie unter Arbeiten mit Exchange Server 2003-Informationsspeichern (http://go.microsoft.com/fwlink/?LinkId=47595) und im Knowledge Base-Artikel 273479 mit einer Beschreibung der Verweisfunktion für Öffentliche Ordner in Exchange 2000 Server und Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=273479).


„Replication Folder Conflict Age Limit" für einen Informationsspeicher für Öffentliche Ordner weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungswert, um zu bestimmen, ob der Alterungswert für Ordnerkonflikte gegenüber der Standardeinstellung geändert wurde:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>\Replication Folder Conflict Age Limit

Wenn Exchange Server Analyzer erkennt, dass der Registrierungswert Replication Folder Conflict Age Limit vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Wenn dieselbe Nachricht in einem Öffentlichen Ordner von zwei Benutzern bearbeitet und geändert wurde, befinden sich die sich ergebenden gespeicherten Nachrichten der Definition nach im Konflikt. Diese Situation kann eintreten, wenn in einem Ordner gleichzeitig Speicherungen erfolgen oder wenn die Nachricht auf zwei Servern bearbeitet wird, die Replikate des Ordners enthalten. Wenn von den Eigentümern des Öffentlichen Ordners innerhalb des durch den Konfliktalterungsgrenzwert festgelegten Zeitraums keine Aktion ausgeführt wird, wird der Konflikt nach Verstreichen des Alterungsgrenzwerts durch den Informationsspeicher für Öffentliche Ordner aufgelöst. Der Registrierungswert Replication Folder Conflict Age Limit steuert diesen Alterungsgrenzwert. Sein Wert gibt die Anzahl von Tagen an, die im Konflikt befindliche Elemente fortbestehen dürfen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>

  3. Löschen Sie den Registrierungswert Replication Folder Conflict Age Limit.

  4. Starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Information zur Replikation von Öffentlichen Ordnern finden Sie im Knowledge Base-Artikel 273479, „Understanding Public Folder Replication and Referrals" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=273479).


Der Wert für „Replication Folder Count Limit" wurde geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob der Wert für den Schlüssel Replication Folder Count Limit vom Standardwert abweicht:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des Öffentlichen Informationsspeichers>\Replication Folder Count Limit

Wenn Exchange Server Analyzer feststellt, dass Replication Folder Count Limit vorhanden ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In der Standardeinstellung ist Replication Folder Count Limit nicht vorhanden. Der Wert für Replication Folder Count Limit stellt die maximale Anzahl der Ordner dar, die in einer Hierarchiereplikationsnachricht enthalten sein können (Hierarchiereplikationsnachrichten werden zum Replizieren der hierarchischen Struktur der Öffentlichen Ordner und der Eigenschaften der Öffentlichen Ordner verwendet). Der Wert muss zwischen 1 und 1000 liegen. Der Standardwert ist 20. Dieser Registrierungsschlüssel ist unter Exchange Server 2003 und höher nicht gültig. Er wird nur in früheren Versionen von Exchange Server verwendet.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So setzen Sie den Registrierungsschlüssel „Replication Folder Count Limit" zurück

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des Öffentlichen Informationsspeichers>

  3. Überprüfen bzw. bearbeiten Sie den Wert für Replication Folder Count Limit.

    Der Wert für diesen Registrierungseintrag wird in Kilobyte (KB) angegeben. Um den Standardwert wiederherzustellen, sollten Sie Replication Folder Count Limit löschen und den Microsoft Exchange-Informationsspeicherdienst neu starten.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Replikation von Öffentlichen Ordnern finden Sie in Working with the Exchange Server 2003 Store unter „Controlling Exchange Server 2003 Public Folder Replication" (http://go.microsoft.com/fwlink/?LinkId=47595).


RMQ-Zeitüberschreitungswert für die Replikationsordnerstruktur wurde geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Schlüssel Replication Folder Tree RMQ Timeout (RMQ-Zeitüberschreitungswert für die Replikationsordnerstruktur) vom Standardwert abweicht:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des Öffentlichen Informationsspeichers>\Replication Folder Tree RMQ Timeout

Wenn Exchange Server Analyzer erkennt, dass Replication Folder Tree RMQ Timeout vorhanden ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In der Standardeinstellung ist Replication Folder Tree RMQ Timeout nicht vorhanden. Exchange verwendet Hierarchienachrichten, um die Hierarchie der Öffentlichen Ordnerstruktur und die Eigenschaften der Öffentlichen Ordner zu replizieren. Erhält ein Öffentlicher Ordnerspeicher replizierte Änderungen, lädt er die Änderungen im Speicher (Replikationsnachrichten-Warteschlangen), um sie zu bearbeiten. DerRMQ-Zeitüberschreitungswert für die Replikationsordnerstruktur stellt die maximale Zeitlänge dar, die replizierte Hierarchieänderungen im Speicher verweilen. Der Wert, in Sekunden, muss zwischen 3600 (eine Stunde) und 2592000 (30 Tage) liegen, der Standardwert beträgt 604800 (7 Tage). Erfolgreich bearbeitete Änderungen werden unverzüglich aus dem Speicher gelöscht, andererseits werden die Änderungen im Speicher solange aufgehoben, bis sie verarbeitet oder gelöscht werden können.

Dies ist beispielsweise dann der Fall, wenn eine Änderung für einen Ordner und eine andere Änderung für einen Unterordner des Ordners repliziert wird. Je nach Typologie und der verstrichenen Zeit zwischen den Änderungen können die Änderungen in irgendeiner Reihenfolge im Öffentlichen Zielordnerspeicher ankommen. Wenn die Unterordneränderung zuerst ankommt, jedoch nicht korrekt bearbeitet werden kann, bis die übergeordnete Ordneränderung angewendet wurde, wird die Unterordneränderung so lange im Öffentlichen Ordnerspeicher gespeichert, bis die übergeordnete Ordneränderung ankommt und bearbeitet wird. Wenn das Timeout endet, bevor die Änderung des übergeordneten Ordners bearbeitet wurde, wird die Änderung des Unterordners aus dem Speicher gelöscht. Nach dem Verarbeiten der Änderung des übergeordneten Ordners kann der Informationsspeicher für Öffentliche Ordner möglicherweise eine andere Kopie der Änderung des Unterordners erhalten, die dann erfolgreich verarbeitet werden kann. Wenn der Speicher keine andere Kopie der Änderung des Unterordners erhält, wird bei der Statusüberprüfung des Informationsspeichers für Öffentliche Ordner gegenüber anderen Informationsspeichern für Öffentliche Ordner in der Topologie festgestellt, dass in der Kopie der Öffentlichen Ordnerstruktur die Änderung des Unterordners nicht berücksichtigt wurde. Der Speicher startet einen Abgleichvorgang.

In der Regel ist es nicht empfehlenswert, Replication Folder Tree RMQ Timeout (den RMQ-Zeitüberschreitungswert für die Replikationsordnerstruktur) von seinem Standardwert zu ändern. Wenn der Wert geändert wurde, kann er möglicherweise während eines schweren Replikationsverkehrs zeitweise erhöht sein (beispielsweise nach dem Hinzufügen eines neuen Öffentlichen Speicherordners).

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den RMQ-Zeitüberschreitungs-Registrierungsschlüssel für die Replikationsordnerstruktur fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des Öffentlichen Informationsspeichers>

  3. Überprüfen bzw. bearbeiten Sie den Wert für Replication Folder Tree RMQ Timeout.

    Der Wert für diesen Registrierungseintrag wird in Sekunden angegeben. Um den Standardwert wiederherzustellen, sollten Sie Replication Folder Tree RMQ Timeout löschen und den Microsoft Exchange-Informationsspeicherdienst neu starten.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Replikation von Öffentlichen Ordnern finden Sie in Working with the Exchange Server 2003 Store unter „Controlling Exchange Server 2003 Public Folder Replication" (http://go.microsoft.com/fwlink/?LinkId=47595).


„Replication Folder Tombstone Age Limit" für einen Informationsspeicher für Öffentliche Ordner weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob das Intervall zum Entfernen veralteter Elemente in Öffentlichen Ordnern vom Standardwert abweicht:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder Store GUID>\Replication Folder Tombstone Age Limit

Wenn Exchange Server Analyzer erkennt, dass Replication Folder Tombstone Age Limit in der Registrierung vorhanden ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Informationen zur Ordneralterung werden bei der Replikation Öffentlicher Ordner verwendet. Alterungsinformationen werden benötigt, um das ungehinderte Anwachsen von Listen veralteter Ordner zu verhindern. Der Standardwert von 180 Tagen kann mit dem Registrierungswert Replication Folder Tombstone Age Limit überschrieben werden.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder Store GUID>

  3. Löschen Sie den Registrierungswert Replication Folder Tombstone Age Limit.

  4. Starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Registrierungswert Replication Folder Tombstone Age Limit finden Sie im Knowledge Base-Artikel 159196 „XADM: Vom IS-Wartungsplan gesteuerte Aufgaben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159196).


Der Wert „Replication Long Backfill Request Delay" wurde geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob der Schlüssel Replication Long Backfill Request Delay vom Standardwert abweicht:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des Öffentlichen Informationsspeichers>\Replication Long Backfill Request Delay

Wenn Exchange Server Analyzer feststellt, dass Replication Long Backfill Request Delay vorhanden ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In der Standardeinstellung ist Replication Long Backfill Request Delay nicht vorhanden. Abgleichen findet statt, wenn ein Öffentlicher Ordner ermittelt, dass er nicht alle Aktualisierungen für einen replizierten Ordner (oder für die Hierarchie) erhalten hat und die fehlenden Aktualisierungen von einem anderen Speicher abrufen muss.

Um den Abgleichvorgang zu rationalisieren, speichert Exchange Server Informationen über fehlende Aktualisierungen im Abgleich-Array. Im Abgleich-Array werden diese Informationen für eine bestimmte Zeitspanne (genannt Abgleich-Zeitlimit) gespeichert. Wenn die fehlenden Aktualisierungen während dieser Zeitspanne in aufeinander folgenden Replikationsnachrichten eintreffen, werden sie aus dem Abgleich-Array entfernt. In der untenstehenden Tabelle werden die Standardwerte für das Abgleich-Zeitlimit aufgelistet, die davon abhängen, wo die fehlenden Aktualisierungen vorhanden sind und ob sie bereits vorher angefordert wurden.

Anforderungstyp | Inhalt ist in einem Speicher am lokalen Standort vorhanden | Inhalt ist in einem Speicher an einem Remotestandort vorhanden
Anfangsabgleich | 6 Stunden | 12 Stunden
Erster erneuter Abgleich | 12 Stunden | 24 Stunden
Weitere erneute Abgleiche | 24 Stunden | 48 Stunden

Wenn das Abgleich-Zeitlimit abläuft und die Aktualisierungen immer noch fehlen, erstellt Exchange Server 2003 eine oder mehrere Abgleichsanforderungen und bestimmt, welche Server als Abgleichsquellen verwendet werden.

Um einen (oder mehrere) Server als Abgleichquelle auszuwählen, erstellt Exchange Server 2003 zunächst eine Liste aller Server, die über Replikate des Ordners verfügen, und sortiert dann die Liste anhand der folgenden Reihenfolge von Kriterien:

  • Sortieren anhand des Serverstatus Servers, die inaktiv oder nicht verfügbar sind, werden an das Ende der Liste verschoben.

  • Sortieren anhand bevorzugter Abgleichserver falls solche vorhanden sind. Diese Funktion ist nur in Exchange Server 2003 oder höher verfügbar. Exchange Server 2003 überprüft das Informationsspeicherobjekt für Öffentliche Ordner im Active Directory®-Verzeichnisdienst auf einen bevorzugten Abgleichserver. Diese Einstellung wird selten verwendet. Unter den meisten Bedingungen wird der Abgleichvorgang am effektivsten durchgeführt, wenn Exchange Server 2003 automatisch einen Abgleichserver auswählt. Die meisten Bereitstellungen von Exchange Server 2003 benötigen keinen bevorzugten Abgleichserver. Wenn Ihre Bereitstellung dies erfordert, können Sie über den technischen Support von Microsoft ein Skript beziehen, das einen bevorzugten Abgleichserver festlegt.

  • Sortieren anhand von Transportkosten (niedrig nach hoch) Server am gleichen Standort bekommen Priorität über Server an Remotestandorten. Die Transportkosten eines Servers werden vom Exchange Server 2003-Routingmodul berechnet und normalerweise dazu verwendet, die effizienteste Art zum Übermitteln einer Nachricht zu berechnen. Beachten Sie, dass in Exchange-Versionen vor Exchange Server 2003 die Transportkosten geringere Priorität haben und erst nach der Exchange-Version und der Anzahl verfügbarer Änderungen berücksichtigt werden.

  • Sortieren anhand der Exchange-Version (neu nach alt)

  • Sortieren anhand der Anzahl notwendiger Änderungen, die auf dem Server verfügbar sind (hoch nach niedrig) Server, die über keine der fehlenden Änderungen verfügen, werden aus der Liste entfernt.

Wenn ein Server nicht über alle erforderlichen Änderungen verfügt, wählt Exchange Server 2003 den nächsten Server in der sortierten Liste aus, und sendet auch an diesen Server eine Abgleichanfrage. Dieser Vorgang wird so lange wiederholt, bis alle Änderungen angefordert wurden. Diese Funktion ist nur in Exchange Server 2003 oder höher verfügbar. Wenn nicht alle fehlenden Aktualisierungen für einen bestimmten Ordner gleichzeitig auf einem Server vorhanden sind, senden frühere Versionen von Exchange Abgleichanfragen an jeweils nur einen Server. Nach jeder Anfrage warten früherere Versionen von Exchange auf den Ablauf des Wiederholungszeitlimits (zwischen 24 und 48 Stunden), bevor sie die nächste Anfrage senden.

Wenn der ausgewählte Server nicht auf die Abgleichsanfrage antwortet, kennzeichnet der Speicher diesen Server als inaktiv und wiederholt den Auswählvorgang. Als inaktiv gekennzeichnete Server fallen an das Ende der Liste zurück.

Der Wert Replication Long Backfill Request Delay stellt den Wert für den Zeitraum der Verzögerung durch einen Informationsspeicher für Öffentliche Ordner dar, bevor dieser versucht, eine Abgleichsanfrage für Daten zu senden, die nicht am selben Exchange-Standort verfügbar sind. Der Wert (in Sekunden) muss zwischen 900 und 2592000 Sekunden (30 Tage) liegen, der Standardwert beträgt 43200 Sekunden (12 Stunden).

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So setzen Sie den Registrierungsschlüssel „Replication Long Backfill Request Delay" zurück:

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des Öffentlichen Informationsspeichers>

  3. Überprüfen bzw. bearbeiten Sie den Wert für Replication Long Backfill Request Delay.

    Der Wert für diesen Registrierungseintrag wird in Sekunden angegeben. Um den Standardwert wiederherzustellen, müssen Sie Replication Long Backfill Request Delay löschen und den Microsoft Exchange-Informationsspeicherdienst neu starten.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Replikation von Öffentlichen Ordnern finden Sie in Working with the Exchange Server 2003 Store unter „Controlling Exchange Server 2003 Public Folder Replication" (http://go.microsoft.com/fwlink/?LinkId=47595).


Der Wert für „Replication Long Backfill Request Timeout" wurde geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob der Schlüssel Replication Long Backfill Request Timeout vom Standardwert abweicht:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des Öffentlichen Informationsspeichers>\Replication Long Backfill Request Timeout

Wenn Exchange Server Analyzer erkennt, dass Replication Long Backfill Request Timeout vorhanden ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In der Standardeinstellung ist Replication Long Backfill Request Timeout nicht vorhanden. Abgleichen findet statt, wenn ein Öffentlicher Ordner-Speicher ermittelt, dass er nicht alle Aktualisierungen für einen replizierten Ordner (oder für die Hierarchie) erhalten hat und die fehlenden Aktualisierungen von einem anderen Speicher abrufen muss.

Um den Abgleichvorgang zu rationalisieren, speichert Exchange Server Informationen über fehlende Aktualisierungen im Abgleich-Array. Im Abgleich-Array werden diese Informationen für eine bestimmte Zeitspanne (genannt Abgleich-Zeitlimit) gespeichert. Wenn die fehlenden Aktualisierungen während dieser Zeitspanne in aufeinander folgenden Replikationsnachrichten eintreffen, werden sie aus dem Abgleich-Array entfernt. In der untenstehenden Tabelle werden die Standardwerte für den Abgleich-Timeout aufgelistet, die davon abhängen, wo die fehlenden Aktualisierungen vorhanden sind und ob sie bereits vorher angefordert wurden.

Anforderungstyp | Inhalt ist in einem Speicher am lokalen Standort vorhanden | Inhalt ist in einem Speicher an einem Remotestandort vorhanden
Anfangsabgleich | 6 Stunden | 12 Stunden
Erster erneuter Abgleich | 12 Stunden | 24 Stunden
Weitere erneute Abgleichungen | 24 Stunden | 48 Stunden

Wenn der Abgleich-Timeout abläuft und die Aktualisierungen immer noch fehlen, erstellt Exchange Server 2003 eine oder mehrere Abgleichsanforderungen und bestimmt, welche Server als Abgleichsquellen verwendet werden.

Um einen (oder mehrere) Server als Abgleichquelle auszuwählen, erstellt Exchange Server 2003 zunächst eine Liste aller Server, die über Replikate des Ordners verfügen, und sortiert dann die Liste anhand der folgenden Reihenfolge von Kriterien:

  • Sortieren anhand des Serverstatus Servers, die inaktiv oder nicht verfügbar sind, werden an das Ende der Liste verschoben.

  • Sortieren anhand bevorzugter Abgleichserver falls solche vorhanden sind. Diese Funktion ist nur in Exchange Server 2003 oder höher verfügbar. Exchange Server 2003 überprüft das Informationsspeicherobjekt für Öffentliche Ordner im Active Directory®-Verzeichnisdienst auf einen bevorzugten Abgleichserver. Diese Einstellung wird selten verwendet. Unter den meisten Bedingungen wird der Abgleichvorgang am effektivsten durchgeführt, wenn Exchange Server 2003 automatisch einen Abgleichserver auswählt. Die meisten Bereitstellungen von Exchange Server 2003 benötigen keinen bevorzugten Abgleichserver. Wenn Ihre Bereitstellung dies erfordert, können Sie über den technischen Support von Microsoft ein Skript beziehen, das einen bevorzugten Abgleichserver festlegt.

  • Sortieren anhand von Transportkosten (niedrig nach hoch) Server am gleichen Standort bekommen Priorität über Server an Remotestandorten. Die Transportkosten eines Servers werden vom Exchange Server 2003-Routingmodul berechnet und normalerweise dazu verwendet, die effizienteste Art zum Übermitteln einer Nachricht zu berechnen. Beachten Sie, dass in Exchange-Versionen vor Exchange Server 2003 die Transportkosten geringere Priorität haben und erst nach der Exchange-Version und der Anzahl verfügbarer Änderungen berücksichtigt werden.

  • Sortieren anhand der Exchange-Version (neu nach alt)

  • Sortieren anhand der Anzahl notwendiger Änderungen, die auf dem Server verfügbar sind (hoch nach niedrig) Server, die über keine der fehlenden Änderungen verfügen, werden aus der Liste entfernt.

Wenn ein Server nicht über alle erforderlichen Änderungen verfügt, wählt Exchange Server 2003 den nächsten Server in der sortierten Liste aus und sendet auch an diesen Server eine Abgleichanfrage. Dieser Vorgang wird so lange wiederholt, bis alle Änderungen angefordert wurden. Diese Funktion ist nur in Exchange Server 2003 oder höher verfügbar. Wenn nicht alle fehlenden Aktualisierungen für einen bestimmten Ordner gleichzeitig auf einem Server vorhanden sind, senden frühere Versionen von Exchange Abgleichanfragen an jeweils nur einen Server. Nach jeder Anfrage warten früherere Versionen von Exchange auf den Ablauf des Wiederholungszeitlimits (zwischen 24 und 48 Stunden), bevor sie die nächste Anfrage senden.

Wenn der ausgewählte Server nicht auf die Abgleichsanfrage antwortet, kennzeichnet der Speicher diesen Server als inaktiv und wiederholt den Auswahlvorgang. Als inaktiv gekennzeichnete Server fallen an das Ende der Liste zurück.

Der Wert Replication Long Backfill Request Timeout stellt den Wert für den Timeout dar, der für einen Informationsspeicher für Öffentliche Ordner gilt, wenn dieser versucht, eine Abgleichsanfrage für nicht am selben Exchange-Standort verfügbare Daten zu senden. Der Wert (in Sekunden) muss zwischen 900 und 2592000 Sekunden (30 Tage) liegen, der Standardwert beträgt 86400 Sekunden (24 Stunden).

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den Registrierungsschlüssel „Replication Long Backfill Request Timeout" zurück

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des Öffentlichen Informationsspeichers>

  3. Überprüfen bzw. bearbeiten Sie den Wert für Replication Long Backfill Request Timeout.

    Der Wert für diesen Registrierungseintrag wird in Sekunden angegeben. Um den Standardwert wiederherzustellen, müssen Sie Replication Long Backfill Request Timeout löschen und den Microsoft Exchange-Informationsspeicherdienst neu starten.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Replikation von Öffentlichen Ordnern finden Sie in Working with the Exchange Server 2003 Store unter „Controlling Exchange Server 2003 Public Folder Replication" (http://go.microsoft.com/fwlink/?LinkId=47595).


Der Wert für „Replication Long Backfill Request Timeout Retry " wurde geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob der Schlüssel Replication Long Backfill Request Timeout Retry vom Standardwert abweicht:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des Öffentlichen Informationsspeichers>\Replication Long Backfill Request Timeout Retry

Wenn Exchange Server Analyzer erkennt, dass Replication Long Backfill Request Timeout Retry vorhanden ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Standardmäßig ist Replication Long Backfill Request Timeout Retry nicht vorhanden. Abgleichen findet statt, wenn ein Öffentlicher Ordner ermittelt, dass er nicht alle Aktualisierungen für einen replizierten Ordner (oder für die Hierarchie) erhalten hat und die fehlenden Aktualisierungen von einem anderen Speicher abrufen muss.

Um den Abgleichvorgang zu rationalisieren, speichert Exchange Server Informationen über fehlende Aktualisierungen im Abgleich-Array. Im Abgleich-Array werden diese Informationen für eine bestimmte Zeitspanne (genannt Abgleich-Zeitlimit) gespeichert. Wenn die fehlenden Aktualisierungen während dieser Zeitspanne in aufeinander folgenden Replikationsnachrichten eintreffen, werden sie aus dem Abgleich-Array entfernt. In der Tabelle werden die Standardwerte für das Abgleich-Zeitlimit aufgelistet, die davon abhängen, wo die fehlenden Aktualisierungen vorhanden sind und ob sie bereits vorher angefordert wurden.

Anforderungstyp | Inhalt ist in einem Speicher am lokalen Standort vorhanden | Inhalt ist in einem Speicher an einem Remotestandort vorhanden
Anfangsabgleich | 6 Stunden | 12 Stunden
Erster erneuter Abgleich | 12 Stunden | 24 Stunden
Weitere erneute Abgleiche | 24 Stunden | 48 Stunden

Wenn das Abgleich-Zeitlimit abläuft und die Aktualisierungen immer noch fehlen, erstellt Exchange Server 2003 eine oder mehrere Abgleichsanforderungen und bestimmt, welche Server als Abgleichsquellen verwendet werden.

Um einen (oder mehrere) Server als Abgleichquelle auszuwählen, erstellt Exchange Server 2003 zunächst eine Liste aller Server, die über Replikate des Ordners verfügen, und sortiert dann die Liste anhand der folgenden Reihenfolge von Kriterien:

  • Sortieren anhand des Serverstatus Servers, die inaktiv oder nicht verfügbar sind, werden an das Ende der Liste verschoben.

  • Sortieren anhand bevorzugter Abgleichserver falls solche vorhanden sind. Diese Funktion ist nur in Exchange Server 2003 oder höher verfügbar. Exchange Server 2003 überprüft das Informationsspeicherobjekt für Öffentliche Ordner im Active Directory®-Verzeichnisdienst auf einen bevorzugten Abgleichserver. Diese Einstellung wird selten verwendet. Unter den meisten Bedingungen wird der Abgleichvorgang am effektivsten durchgeführt, wenn Exchange Server 2003 automatisch einen Abgleichserver auswählt. Die meisten Bereitstellungen von Exchange Server 2003 benötigen keinen bevorzugten Abgleichserver. Wenn Ihre Bereitstellung dies erfordert, können Sie über den technischen Support von Microsoft ein Skript beziehen, das einen bevorzugten Abgleichserver festlegt.

  • Sortieren anhand von Transportkosten (niedrig nach hoch) Server am gleichen Standort bekommen Priorität über Server an Remotestandorten. Die Transportkosten eines Servers werden vom Exchange Server 2003-Routingmodul berechnet und normalerweise dazu verwendet, die effizienteste Art zum Übermitteln einer Nachricht zu berechnen. Beachten Sie, dass in Exchange-Versionen vor Exchange Server 2003 die Transportkosten geringere Priorität haben und erst nach der Exchange-Version und der Anzahl verfügbarer Änderungen berücksichtigt werden.

  • Sortieren anhand der Exchange-Version (neu nach alt)

  • Sortieren anhand der Anzahl notwendiger Änderungen, die auf dem Server verfügbar sind (hoch nach niedrig) Server, die über keine der fehlenden Änderungen verfügen, werden aus der Liste entfernt.

Wenn ein Server nicht über alle erforderlichen Änderungen verfügt, wählt Exchange Server 2003 den nächsten Server in der sortierten Liste aus, und sendet auch an diesen Server eine Abgleichanfrage. Dieser Vorgang wird so lange wiederholt, bis alle Änderungen angefordert wurden. Diese Funktion ist nur in Exchange Server 2003 oder höher verfügbar. Wenn nicht alle fehlenden Aktualisierungen für einen bestimmten Ordner gleichzeitig auf einem Server vorhanden sind, senden frühere Versionen von Exchange Abgleichanfragen an jeweils nur einen Server. Nach jeder Anfrage warten früherere Versionen von Exchange auf den Ablauf des Wiederholungszeitlimits (zwischen 24 und 48 Stunden), bevor sie die nächste Anfrage senden.

Wenn der ausgewählte Server nicht auf die Abgleichsanfrage antwortet, kennzeichnet der Speicher diesen Server als inaktiv und wiederholt den Auswählvorgang. Als inaktiv gekennzeichnete Server fallen an das Ende der Liste zurück.

Der Wert Replication Long Backfill Request Timeout Retry stellt den Zeitlimitwert dar, den der Informationsspeicher für Öffentliche Ordner verwendet, wenn er eine Abgleichsanfrage für Daten sendet, die nicht auf demselben Exchange-Standort verfügbar sind, und wenn diese Anfrage den erneuten Versuch einer vorherigen Abgleichsanfrage darstellt. Der Wert (in Sekunden) muss zwischen 900 und 2592000 Sekunden (30 Tage) liegen, der Standardwert beträgt 172800 Sekunden (48 Stunden).

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So setzen Sie den Registrierungsschlüssel „Replication Long Backfill Request Timeout Retry" zurück

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des Öffentlichen Informationsspeichers>

  3. Überprüfen bzw. bearbeiten Sie den Wert für Replication Long Backfill Request Timeout Retry.

    Der Wert für diesen Registrierungseintrag wird in Sekunden angegeben. Um den Standardwert zurückzugeben, sollten Sie Replication Long Backfill Request Timeout Retry löschen und den Microsoft Exchange-Informationsspeicherdienst neu starten.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://support.microsoft.com/?scid=kb%3Bde%3B256986&x=2&y=12, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Replikation von Öffentlichen Ordnern finden Sie in Working with the Exchange Server 2003 Store unter „Controlling Exchange Server 2003 Public Folder Replication" (http://go.microsoft.com/fwlink/?LinkId=47595).


Replikationsnachrichten wurden beim Start auf „Enabled" festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob Exchange zum Generieren von Statusanforderungsnachrichten für die Öffentliche Ordnerhierarchie konfiguriert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des Öffentlichen Informationsspeichers>\Enable Replication Messages At Startup

Wenn Exchange Server Analyzer erkennt, dass der Registrierungseintrag Enable Replication Messages At Startup vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In Exchange Server 5.5 sendet jeder Computer mit einem Informationsspeicher für Öffentliche Ordner nachts eine Statusanforderungsnachricht, um den Status der Öffentlichen Ordnerhierarchie zu ermitteln. In Exchange 2000 Server und Exchange Server 2003 wird dies nicht ausgeführt. In Exchange 2000 Server und Exchange Server 2003 wird die Statusanforderungsnachricht während der gesamten Lebensdauer des Informationsspeichers für Öffentliche Ordner nur einmal gesendet, nämlich beim Erstellen des Speichers.

Dennoch muss unter bestimmten Umständen eine Statusanforderungsnachricht generiert werden. Wenn beispielsweise die Öffentliche Ordnerhierarchie auf dem Exchange 2000 Server- oder Exchange Server 2003-Computer nicht repliziert wird oder die Öffentliche Ordnerhierarchie sehr langsam repliziert wird, kann die Generierung einer Statusanforderungsnachricht die Fortsetzung der Öffentlichen Ordnerhierarchie ermöglichen. Probleme mit der Replikation Öffentlicher Ordnerhierarchien können dann auftreten, wenn die ursprüngliche Statusanforderungsnachricht, die beim Erstellen des Informationsspeichers für Öffentliche Ordner gesendet wurde, gelöscht und nie bestätigt wurde oder wenn die Nachricht an einen Server mit einer unvollständigen Hierarchie gesendet wurde.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So zeigen Sie den Registrierungswert „Aging Keep Time" an und ändern diesen

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des öffentlichen Informationsspeichers>

  3. Prüfen oder ändern Sie bei Bedarf den Wert von Enable Replication Messages At Startup. Dieser Wert für REG_DWORD muss auf 1 festgelgt sein, um wirksam zu werden. Wenn Sie den Wert auf 0 (Standardeinstellung) festlegen, wird beim Starten des Informationsspeichers für Öffentliche Ordner keine Statusanforderungsnachricht gesendet.

  4. Wenn eine Änderung vorgenommen wurde, schließen Sie den Registrierungs-Editor, heben Sie die Bereitstellung des Informationsspeichers für Öffentliche Ordner zunächst auf, und stellen Sie ihn dann erneut bereit, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zu Nachrichten über den Replikationsstatus der Öffentlichen Ordner und zum Registrierungswert Enable Replication Messages At Startup finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 321082, „XADM: How to Send Replication Status Request Messages in Exchange 2000 Server" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=321082.

  • 842273 „How to troubleshoot public folder replication problems in Exchange 2000 Server and in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=842273).


Der Wert „Replication Short Backfill Request Delay" wurde geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob der Schlüssel Replication Short Backfill Request Delay so geändert wurde, dass er vom Standardwert abweicht:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des Öffentlichen Informationsspeichers>\Replication Short Backfill Request Delay

Wenn Exchange Server Analyzer feststellt, dass Replication Short Backfill Request Timeout vorhanden ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In der Standardeinstellung ist Replication Short Backfill Request Delay nicht vorhanden. Ein Abgleich findet statt, wenn ein Öffentlicher Ordner ermittelt, dass er nicht alle Aktualisierungen für einen replizierten Ordner (oder für die Hierarchie) erhalten hat und die fehlenden Aktualisierungen von einem anderen Speicher abrufen muss.

Um den Abgleichvorgang zu rationalisieren, speichert Exchange Server Informationen über fehlende Aktualisierungen im Abgleich-Array. Im Abgleich-Array werden diese Informationen für eine bestimmte Zeitspanne (genannt Abgleich-Zeitlimit) gespeichert. Wenn die fehlenden Aktualisierungen während dieser Zeitspanne in aufeinander folgenden Replikationsnachrichten eintreffen, werden sie aus dem Abgleich-Array entfernt. In der Tabelle werden die Standardwerte für das Abgleich-Zeitlimit aufgelistet, die davon abhängen, wo die fehlenden Aktualisierungen vorhanden sind und ob sie bereits vorher angefordert wurden.

Anforderungstyp | Inhalt ist in einem Speicher am lokalen Standort vorhanden | Inhalt ist in einem Speicher an einem Remotestandort vorhanden
Anfangsabgleich | 6 Stunden | 12 Stunden
Erster erneuter Abgleich | 12 Stunden | 24 Stunden
Weitere erneute Abgleiche | 24 Stunden | 48 Stunden

Wenn das Abgleich-Zeitlimit abläuft und die Aktualisierungen immer noch fehlen, erstellt Exchange Server 2003 eine oder mehrere Abgleichsanforderungen und bestimmt, welche Server als Abgleichsquellen verwendet werden.

Um einen (oder mehrere) Server als Abgleichquelle auszuwählen, erstellt Exchange Server 2003 zunächst eine Liste aller Server, die über Replikate des Ordners verfügen, und sortiert dann die Liste anhand der folgenden Reihenfolge von Kriterien:

  • Sortieren anhand des Serverstatus Servers, die inaktiv oder nicht verfügbar sind, werden an das Ende der Liste verschoben.

  • Sortieren anhand bevorzugter Abgleichserver falls solche vorhanden sind. Diese Funktion ist nur in Versionen ab Exchange Server 2003 verfügbar. Exchange Server 2003 überprüft das Informationsspeicherobjekt für Öffentliche Ordner im Active Directory®-Verzeichnisdienst auf einen bevorzugten Abgleichserver. Diese Einstellung wird selten verwendet. Unter den meisten Bedingungen wird der Abgleichvorgang am effektivsten durchgeführt, wenn Exchange Server 2003 automatisch einen Abgleichserver auswählt. Die meisten Bereitstellungen von Exchange Server 2003 benötigen keinen bevorzugten Abgleichserver. Wenn Ihre Bereitstellung dies erfordert, können Sie über den technischen Support von Microsoft ein Skript beziehen, das einen bevorzugten Abgleichserver festlegt.

  • Sortieren anhand von Transportkosten (niedrig nach hoch) Server am gleichen Standort bekommen Priorität über Server an Remotestandorten. Die Transportkosten eines Servers werden vom Exchange Server 2003-Routingmodul berechnet und normalerweise dazu verwendet, die effizienteste Art zum Übermitteln einer Nachricht zu berechnen. Beachten Sie, dass in Exchange-Versionen vor Exchange Server 2003 die Transportkosten geringere Priorität haben und erst nach der Exchange-Version und der Anzahl verfügbarer Änderungen berücksichtigt werden.

  • Sortieren anhand der Exchange-Version (neu nach alt)

  • Sortieren anhand der Anzahl notwendiger Änderungen, die auf dem Server verfügbar sind (hoch nach niedrig) Server, die über keine der fehlenden Änderungen verfügen, werden aus der Liste entfernt.

Wenn ein Server nicht über alle erforderlichen Änderungen verfügt, wählt Exchange Server 2003 den nächsten Server in der sortierten Liste aus, und sendet auch an diesen Server eine Abgleichanfrage. Dieser Vorgang wird so lange wiederholt, bis alle Änderungen angefordert wurden. Diese Funktion ist nur in Exchange Server 2003 oder höher verfügbar. Wenn nicht alle fehlenden Aktualisierungen für einen bestimmten Ordner gleichzeitig auf einem Server vorhanden sind, senden frühere Versionen von Exchange Abgleichanfragen an jeweils nur einen Server. Nach jeder Anfrage warten früherere Versionen von Exchange auf den Ablauf des Wiederholungszeitlimits (zwischen 24 und 48 Stunden), bevor sie die nächste Anfrage senden.

Wenn der ausgewählte Server nicht auf die Abgleichsanfrage antwortet, kennzeichnet der Speicher diesen Server als inaktiv und wiederholt den Auswählvorgang. Als inaktiv gekennzeichnete Server fallen an das Ende der Liste zurück.

Der Wert Replication Short Backfill Request Delay stellt den Wert für den Zeitraum der Verzögerung durch einen Informationsspeicher für Öffentliche Ordner dar, bevor dieser versucht, eine Abgleichsanfrage für Daten zu senden, die am selben Exchange-Standort verfügbar sind. Der Wert (in Sekunden) muss zwischen 900 und 2592000 Sekunden (30 Tage) liegen, der Standardwert beträgt 21600 Sekunden (6 Stunden).

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den Registrierungsschlüssel „Replication Short Backfill Request Delay" zurück

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des Öffentlichen Informationsspeichers>

  3. Überprüfen bzw. bearbeiten Sie den Wert für Replication Short Backfill Request Delay.

    Der Wert für diesen Registrierungseintrag wird in Sekunden angegeben. Um den Standardwert wiederherzustellen, müssen Sie Replication Short Backfill Request Delay löschen und den Microsoft Exchange-Informationsspeicherdienst neu starten.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Replikation von Öffentlichen Ordnern finden Sie in Working with the Exchange Server 2003 Store unter „Controlling Exchange Server 2003 Public Folder Replication" (http://go.microsoft.com/fwlink/?LinkId=47595).


Der Wert für „Replication Short Backfill Request Timeout" wurde geändert
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob der Schlüssel Replication Short Backfill Request Timeout vom Standardwert abweicht:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des Öffentlichen Informationsspeichers>\Replication Short Backfill Request Timeout

Wenn Exchange Server Analyzer erkennt, dass Replication Short Backfill Request Timeout vorhanden ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Standardmäßig ist Replication Short Backfill Request Timeout nicht vorhanden. Abgleichen findet statt, wenn ein Öffentlicher Ordner ermittelt, dass er nicht alle Aktualisierungen für einen replizierten Ordner (oder für die Hierarchie) erhalten hat und die fehlenden Aktualisierungen von einem anderen Speicher abrufen muss.

Um den Abgleichvorgang zu rationalisieren, speichert Exchange Server Informationen über fehlende Aktualisierungen im Abgleich-Array. Im Abgleich-Array werden diese Informationen für eine bestimmte Zeitspanne (genannt Abgleich-Zeitlimit) gespeichert. Wenn die fehlenden Aktualisierungen während dieser Zeitspanne in aufeinander folgenden Replikationsnachrichten eintreffen, werden sie aus dem Abgleich-Array entfernt. In der untenstehenden Tabelle werden die Standardwerte für das Abgleich-Zeitlimit aufgelistet, die davon abhängen, wo die fehlenden Aktualisierungen vorhanden sind und ob sie bereits vorher angefordert wurden.

Anforderungstyp | Inhalt ist in einem Speicher am lokalen Standort vorhanden | Inhalt ist in einem Speicher an einem Remotestandort vorhanden
Anfangsabgleich | 6 Stunden | 12 Stunden
Erster erneuter Abgleich | 12 Stunden | 24 Stunden
Weitere erneute Abgleiche | 24 Stunden | 48 Stunden

Wenn das Abgleich-Zeitlimit abläuft und die Aktualisierungen immer noch fehlen, erstellt Exchange Server 2003 eine oder mehrere Abgleichsanforderungen und bestimmt, welche Server als Abgleichsquellen verwendet werden.

Um einen (oder mehrere) Server als Abgleichquelle auszuwählen, erstellt Exchange Server 2003 zunächst eine Liste aller Server, die über Replikate des Ordners verfügen, und sortiert dann die Liste anhand der folgenden Reihenfolge von Kriterien:

  • Sortieren anhand des Serverstatus Servers, die inaktiv oder nicht verfügbar sind, werden an das Ende der Liste verschoben.

  • Sortieren anhand bevorzugter Abgleichserver falls solche vorhanden sind. Diese Funktion ist nur in Exchange Server 2003 oder höher verfügbar. Exchange Server 2003 überprüft das Informationsspeicherobjekt für Öffentliche Ordner im Active Directory®-Verzeichnisdienst auf einen bevorzugten Abgleichserver. Diese Einstellung wird selten verwendet. Unter den meisten Bedingungen wird der Abgleichvorgang am effektivsten durchgeführt, wenn Exchange Server 2003 automatisch einen Abgleichserver auswählt. Die meisten Bereitstellungen von Exchange Server 2003 benötigen keinen bevorzugten Abgleichserver. Wenn Ihre Bereitstellung dies erfordert, können Sie über den technischen Support von Microsoft ein Skript beziehen, das einen bevorzugten Abgleichserver festlegt.

  • Sortieren anhand von Transportkosten (niedrig nach hoch) Server am gleichen Standort bekommen Priorität über Server an Remotestandorten. Die Transportkosten eines Servers werden vom Exchange Server 2003-Routingmodul berechnet und normalerweise dazu verwendet, die effizienteste Art zum Übermitteln einer Nachricht zu berechnen. Beachten Sie, dass in Exchange-Versionen vor Exchange Server 2003 die Transportkosten geringere Priorität haben und erst nach der Exchange-Version und der Anzahl verfügbarer Änderungen berücksichtigt werden.

  • Sortieren anhand der Exchange-Version (neu nach alt)

  • Sortieren anhand der Anzahl notwendiger Änderungen, die auf dem Server verfügbar sind (hoch nach niedrig) Server, die über keine der fehlenden Änderungen verfügen, werden aus der Liste entfernt.

Wenn ein Server nicht über alle erforderlichen Änderungen verfügt, wählt Exchange Server 2003 den nächsten Server in der sortierten Liste aus, und sendet auch an diesen Server eine Abgleichanfrage. Dieser Vorgang wird so lange wiederholt, bis alle Änderungen angefordert wurden. Diese Funktion ist nur in Exchange Server 2003 oder höher verfügbar. Wenn nicht alle fehlenden Aktualisierungen für einen bestimmten Ordner gleichzeitig auf einem Server vorhanden sind, senden frühere Versionen von Exchange Abgleichanfragen an jeweils nur einen Server. Nach jeder Anfrage warten früherere Versionen von Exchange auf den Ablauf des Wiederholungszeitlimits (zwischen 24 und 48 Stunden), bevor sie die nächste Anfrage senden.

Wenn der ausgewählte Server nicht auf die Abgleichsanfrage antwortet, kennzeichnet der Speicher diesen Server als inaktiv und wiederholt den Auswählvorgang. Als inaktiv gekennzeichnete Server fallen an das Ende der Liste zurück.

Der Wert Replication Short Backfill Request Timeout stellt den Wert für das Zeitlimit dar, das ein Informationsspeicher für Öffentliche Ordner verwendet, wenn er versucht, eine Abgleichsanfrage für am selben Exchange-Standort verfügbare Daten zu senden. Der Wert (in Sekunden) muss zwischen 900 und 2592000 Sekunden (30 Tage) liegen, der Standardwert beträgt 43200 Sekunden (12 Stunden).

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den Registrierungsschlüssel „Replication Short Backfill Request Timeout" zurück

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des Öffentlichen Informationsspeichers>

  3. Überprüfen bzw. bearbeiten Sie den Wert für Replication Short Backfill Request Timeout.

    Der Wert für diesen Registrierungseintrag wird in Sekunden angegeben. Um den Standardwert wiederherzustellen, müssen Sie Replication Short Backfill Request Timeout löschen und den Microsoft Exchange-Informationsspeicherdienst neu starten.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Replikation von Öffentlichen Ordnern finden Sie in Working with the Exchange Server 2003 Store unter „Controlling Exchange Server 2003 Public Folder Replication" (http://go.microsoft.com/fwlink/?LinkId=47595).


Der Wert für „Replication Short Backfill Request Timeout Retry" wurde geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob der Schlüssel Replication Short Backfill Request Timeout Retry vom Standardwert abweicht:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Servername>\Public-<GUID des Öffentlichen Informationsspeichers>\Replication Short Backfill Request Timeout Retry

Wenn Exchange Server Analyzer erkennt, dass Replication Short Backfill Request Timeout Retry vorhanden ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In der Standardeinstellung ist Replication Short Backfill Request Timeout Retry nicht vorhanden. Abgleichen findet statt, wenn ein Öffentlicher Ordner ermittelt, dass er nicht alle Aktualisierungen für einen replizierten Ordner (oder für die Hierarchie) erhalten hat und die fehlenden Aktualisierungen von einem anderen Speicher abrufen muss.

Um den Abgleichvorgang zu rationalisieren, speichert Exchange Server Informationen über fehlende Aktualisierungen im Abgleich-Array. Im Abgleich-Array werden diese Informationen für eine bestimmte Zeitspanne (genannt Abgleich-Zeitlimit) gespeichert. Wenn die fehlenden Aktualisierungen während dieser Zeitspanne in aufeinander folgenden Replikationsnachrichten eintreffen, werden sie aus dem Abgleich-Array entfernt. In der untenstehenden Tabelle werden die Standardwerte für das Abgleich-Zeitlimit aufgelistet, die davon abhängen, wo die fehlenden Aktualisierungen vorhanden sind und ob sie bereits vorher angefordert wurden.

Anforderungstyp | Inhalt ist in einem Speicher am lokalen Standort vorhanden | Inhalt ist in einem Speicher an einem Remotestandort vorhanden
Anfangsabgleich | 6 Stunden | 12 Stunden
Erster erneuter Abgleich | 12 Stunden | 24 Stunden
Weitere erneute Abgleiche | 24 Stunden | 48 Stunden

Wenn das Abgleich-Zeitlimit abläuft und die Aktualisierungen immer noch fehlen, erstellt Exchange Server 2003 eine oder mehrere Abgleichsanforderungen und bestimmt, welche Server als Abgleichsquellen verwendet werden.

Um einen (oder mehrere) Server als Abgleichquelle auszuwählen, erstellt Exchange Server 2003 zunächst eine Liste aller Server, die über Replikate des Ordners verfügen, und sortiert dann die Liste anhand der folgenden Reihenfolge von Kriterien:

  • Sortieren anhand des Serverstatus Servers, die inaktiv oder nicht verfügbar sind, werden an das Ende der Liste verschoben.

  • Sortieren anhand bevorzugter Abgleichserver falls solche vorhanden sind. Diese Funktion ist nur in Exchange Server 2003 oder höher verfügbar. Exchange Server 2003 überprüft das Informationsspeicherobjekt für Öffentliche Ordner im Active Directory®-Verzeichnisdienst auf einen bevorzugten Abgleichserver. Diese Einstellung wird selten verwendet. Unter den meisten Bedingungen wird der Abgleichvorgang am effektivsten durchgeführt, wenn Exchange Server 2003 automatisch einen Abgleichserver auswählt. Die meisten Bereitstellungen von Exchange Server 2003 benötigen keinen bevorzugten Abgleichserver. Wenn Ihre Bereitstellung dies erfordert, können Sie über den technischen Support von Microsoft ein Skript beziehen, das einen bevorzugten Abgleichserver festlegt.

  • Sortieren anhand von Transportkosten (niedrig nach hoch) Server am gleichen Standort bekommen Priorität über Server an Remotestandorten. Die Transportkosten eines Servers werden vom Exchange Server 2003-Routingmodul berechnet und normalerweise dazu verwendet, die effizienteste Art zum Übermitteln einer Nachricht zu berechnen. Beachten Sie, dass in Exchange-Versionen vor Exchange Server 2003 die Transportkosten geringere Priorität haben und erst nach der Exchange-Version und der Anzahl verfügbarer Änderungen berücksichtigt werden.

  • Sortieren anhand der Exchange-Version (neu nach alt)

  • Sortieren anhand der Anzahl notwendiger Änderungen, die auf dem Server verfügbar sind (hoch nach niedrig) Server, die über keine der fehlenden Änderungen verfügen, werden aus der Liste entfernt.

Wenn ein Server nicht über alle erforderlichen Änderungen verfügt, wählt Exchange Server 2003 den nächsten Server in der sortierten Liste aus, und sendet auch an diesen Server eine Abgleichanfrage. Dieser Vorgang wird so lange wiederholt, bis alle Änderungen angefordert wurden. Diese Funktion ist nur in Exchange Server 2003 oder höher verfügbar. Wenn nicht alle fehlenden Aktualisierungen für einen bestimmten Ordner gleichzeitig auf einem Server vorhanden sind, senden frühere Versionen von Exchange Abgleichanfragen an jeweils nur einen Server. Nach jeder Anfrage warten früherere Versionen von Exchange auf den Ablauf des Wiederholungszeitlimits (zwischen 24 und 48 Stunden), bevor sie die nächste Anfrage senden.

Wenn der ausgewählte Server nicht auf die Abgleichsanfrage antwortet, kennzeichnet der Speicher diesen Server als inaktiv und wiederholt den Auswählvorgang. Als inaktiv gekennzeichnete Server fallen an das Ende der Liste zurück.

Der Wert Replication Short Backfill Request Timeout Retry stellt den Zeitlimitwert dar, den der Informationsspeicher für Öffentliche Ordner verwendet, wenn er eine Abgleichsanfrage für Daten sendet, die auf demselben Exchange-Standort verfügbar sind, und wenn diese Anfrage den erneuten Versuch einer vorherigen Abgleichsanfrage darstellt. Der Wert (in Sekunden) muss zwischen 900 und 2592000 Sekunden (30 Tage) liegen, der Standardwert beträgt 86400 Sekunden (24 Stunden).

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie den Registrierungsschlüssel Replication Short Backfill Request Timeout Retry zurück

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\\<Servername>\Public-<GUID des Öffentlichen Informationsspeichers>

  3. Überprüfen bzw. bearbeiten Sie den Wert für Replication Short Backfill Request Timeout Retry.

    Der Wert für diesen Registrierungseintrag wird in Sekunden angegeben. Um den Standardwert zurückzugeben, sollten Sie Replication Short Backfill Request Timeout Retry löschen und den Microsoft Exchange-Informationsspeicherdienst neu starten.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zur Replikation von Öffentlichen Ordnern finden Sie in Working with the Exchange Server 2003 Store unter „Controlling Exchange Server 2003 Public Folder Replication" (http://go.microsoft.com/fwlink/?LinkId=47595).


Größe für Reserve-Inkrement festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-30

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob ein Wert für Reserve Increment KB festgelegt wurde: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber aller Verzeichnisobjekte mit der Objektklasse msExchExchangeServer zu ermitteln. Wenn der Zeichenfolgenwert Version 5.5 einschließt, wird auf dem Computer Microsoft Exchange Server 5.5 ausgeführt. Wenn der Zeichenfolgenwert Version 6.0 einschließt, wird auf dem Computer Microsoft Exchange 2000 Server ausgeführt. Wenn der Wert die Zeichenfolge "Version 6.5" enthält, wird auf dem Computer Microsoft Exchange Server 2003 ausgeführt. Wenn der Wert die Zeichenfolge "Version 8.0" enthält, wird auf dem Computer Exchange Server 2007 ausgeführt.

Wenn Exchange Server Analyzer feststellt, dass der Registrierungswert Reserve Increment KB auf einem Computer vorhanden ist, der Exchange Server 2003 ausführt, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Registrierungswert Reserve Increment KB setzt den einheitlichen Speicherheap-Wert in Microsoft Windows® außer Kraft. Der interne, prozessumfassende Heap-Manager von Windows verwaltet die Speichervorgänge für alle Prozesse. Wenn ein Prozess instanziiert wird, wird jedes Mal ein Standard-Heap (als "Prozess-Heap" bezeichnet) für diesen Prozess erstellt. Programme oder Module, die in den Prozess geladen werden, können bei Bedarf ebenfalls zusätzliche Heaps erstellen. Der Microsoft Exchange-Informationsspeicherdienst (Store.exe) ist ein Beispiel für einen Prozess, der bei Bedarf zusätzliche Heaps erstellt. In der Standardeinstellung legt Store.exe den anfänglichen Arbeitsspeicher, der für Heap-Speicher reserviert ist, auf 20 Prozent des physischen Arbeitsspeichers fest. Der Wert Reserve Increment KB ändert die Anfangsspeicherreservierung für den Heap in 10 Prozent des physischen Arbeitsspeichers.

Die Verwendung des Registrierungswertes Reserve Increment KB ist nur in Einzelfällen hilfreich. Dieser Wert sollte außerdem nur auf Anraten eines Produktsupportspezialisten des technischen Supports (PSS) von Microsoft festgelegt werden. Eine falsche Einstellung oder Verwendung dieses Werts kann zu verringerter Leistung führen und die Fragmentierung des virtuellen Speichers beschleunigen. Wenn dieser Wert ohne entsprechenden Hinweis von des technischen Supports (PSS) von Microsoft festgelegt wurde, sollten Sie erwägen, ihn über das folgende Verfahren zu entfernen.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Löschen Sie im rechten Bereich den Wert Reserve Increment KB.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Weitere Informationen zum Optimieren von Exchange Server 2003 finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 325044, „SO WIRD´S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044

  • 815372, „Optimieren der Speichernutzung in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372


RPC-Buffer Packing ist deaktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob RPC-Buffer Packing (Remote Procedure Call) deaktiviert wurde:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc Packing Enabled

Wenn Exchange Server Analyzer feststellt, dass der Datenwert für den Registrierungsschlüssel Rpc Packing Enabled auf 0 festgelegt wurde, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht. Der Registrierungsschlüssel Rpc Packing Enabled ist deaktiviert, wenn sein Datenwert auf 0 festgelegt ist.

Der Datenwert für den Registrierungsschlüssel Rpc Packing Enabled ist einer von drei Registrierungseinträgen, den Administratoren hinzufügen können, um die RPC-Komprimierung zwischen Microsoft Office Outlook® 2003 und Exchange Server 2003 zu konfigurieren.

Outlook 2003 kann einen Datenpuffer mit einer Größe von 96 KB anfordern. Nachdem jedoch Exchange Server 2003 die Daten komprimiert hat, ist der Datenpuffer möglicherweise erheblich kleiner als von Outlook 2003 angefordert.

Exchange Server 2003 unterstützt Buffer Packing, um unterschiedliche Komprimierungsraten zu unterstützen und um Puffer aus Effizienzgründen gefüllt zu halten.

Wenn der Registrierungsschlüssel Rpc Packing Enabled aktiviert ist, fügt Exchange Server 2003 dem Puffer weiterhin komprimierte Daten hinzu, bis der Puffer gefüllt ist. Bei jeder Datenanforderung kann Outlook 2003 aus den folgenden Gründen erheblich mehr Daten downloaden als die früheren Versionen von Outlook:

  • Outlook 2003 fordert größere Puffer an.

  • Exchange Server 2003 unterstützt Buffer Packing.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich. Sie können allerdings den Registrierungsschlüssel Rpc Packing Enabled löschen, wenn Sie die Standardkonfiguration wiederherstellen möchten. Sie können auch den Datenwert des Registrierungsschlüssels Rpc Packing Enabled auf 1 festlegen, um RPC-Buffer Packing zu aktivieren.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

    • Zum Löschen des Eintrags löschen Sie den Wert Rpc Packing Enabled.

    • Um den Eintrag beizubehalten und RPC-Buffer Packing zu aktivieren, doppelklicken Sie auf Rpc Packing Enabled, legen Sie den Wert auf 1 fest, und klicken Sie dann auf OK.

  3. Schließen Sie den Registrierungs-Editor.

Der Microsoft Exchange-Informationsspeicherdienst erkennt innerhalb weniger Minuten die Änderungen. Sie müssen den Computer nicht neu starten.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Festlegen von Registrierungsschlüsseln zum Konfigurieren der RPC-Komprimierung zwischen Outlook-Clients und ExchangeServer 2003 finden Sie im Knowledge Base-Artikel 825371 „Modify Remote Procedure Call Compression in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371.


Die Minimale Größe der RPC-Komprimierung weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die minimale Paketgröße für die RPC-Komprimierung (Remote Procedure Call -Remoteprozeduraufruf) zu ermitteln:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc Compression Minimum Size

Wenn Exchange Server Analyzer feststellt, dass der Wert für Rpc Compression Minimum Size größer als 0 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In der Standardeinstellung werden alle RPC-Daten, die zwischen Microsoft Office Outlook® 2003 oder Outlook 2007 und Exchange Server 2003 oder Exchange Server 2007 übertragen werden, unabhängig von ihrer Größe komprimiert. In einigen Szenarios möchten Sie die RPC-Komprimierung möglicherweise steuern. Wenn Sie z. B. Verbindungsprobleme beheben möchten und die über das Netzwerk gesendeten Pakete anzeigen, kann die RPC-Komprimierung die Analyse erschweren, da Sie nur die komprimierten Daten in der Ablaufverfolgung sehen.

Zum Konfigurieren der RPC-Komprimierungseinstellungen können Sie drei Registrierungsschlüsselwerte in den Systemeinstellungen hinzufügen:

  • Rpc Compression Minimum Size

  • Rpc Compression Enabled

  • Rpc Packing Enabled

Der Registrierungswert Rpc Compression Minimum Size gibt die Mindestanzahl von Bytes an, die in dem RPC-Paket enthalten sein mussten, bevor die Komprimierung aktiviert wurde. Wenn der Schlüssel nicht vorhanden ist, wird der Standardwert von 1.024 Bytes verwendet.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Löschen Sie den Schlüssel Rpc Compression Minimum Size. Wenn die Schlüssel Rpc Compression Enabled und Rpc Packing Enabled vorhanden sind, löschen Sie auch diese.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den Exchange-Server neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Steuern der RPC-Komprimierung finden Sie im Knowledge Base-Artikel 825371, „Modify Remote Procedure Call Compression in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371.


Der Parameter „RpcEtwTracing" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungsschlüssel, um seinen Wert zu bestimmen:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\RpcEtwTracing

Wenn Exchange Server Analyzer erkennt, dass der Wert des Registrierungsschlüssels RpcEtwTracing gleich 1 ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert des Registrierungsschlüssels RpcEtwTracing wird nur zum Beheben von Netzwerkproblemen zwischen Microsoft Office Outlook® 2003 und Exchange Server verwendet. Es wird empfohlen, dass Sie den Registrierungsschlüssel RpcEtwTracing deaktivieren, wenn Sie derzeit kein Problem behandeln.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich. Sie können allerdings den Registrierungsschlüssel RpcEtwTracing löschen, wenn Sie die Standardkonfiguration wiederherstellen möchten.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Löschen Sie den Registrierungswert RpcEtwTracing.

  4. Schließen Sie den Registrierungs-Editor.

Der Microsoft Exchange-Informationsspeicherdienst erkennt innerhalb weniger Minuten die Änderungen. Sie müssen den Computer nicht neu starten.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Für den Server sind weniger als vier Speichergruppen und mehr als vier Postfachspeicher definiert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um die Anzahl von StorageGroup-Objekten und MailboxGroup-Objekten auf dem Server zu bestimmen, auf dem Exchange Server 2003 ausgeführt wird. Wenn Exchange Server Analyzer feststellt, dass die Gesamtzahl von StorageGroup-Objekten kleiner als vier und die Gesamtzahl von MailboxStore-Objekten größer als vier ist, wird ein Fehler angezeigt.

Wenn Sie Exchange Server 2003 Standard Edition verwenden, kann jeder Exchange Server-Computer eine Speichergruppe aufweisen, die einen Postfachspeicher und einen Öffentlichen Ordnerspeicher unterstützt. Wenn Sie Exchange Server 2003 Enterprise Edition verwenden, kann jeder Server bis zu vier Speichergruppen aufweisen, die jeweils bis zu fünf Datenbanken unterstützen (Postfachspeicher oder Öffentliche Ordnerspeicher).

Die empfohlene Vorgehensweise zum Konfigurieren von Speichergruppen für Computer, auf denen Exchange Server 2003 Enterprise Edition ausgeführt wird, besteht im Hinzufügen einer zusätzlichen Speichergruppe für jede neue Datenbank, bis die maximale Anzahl von Speichergruppen erstellt wurde. Die Last der Postfächer in der Exchange Server-Speichertopologie kann auf so viele Speichergruppen wie möglich aufgeteilt werden. Eine solche Topologie hat die folgenden Vorteile:

  • Die Zuverlässigkeit der Speichertopologie wird erhöht.

  • Die Wiederherstellbarkeit der Speichertopologie wird erhöht.

  • Eine bessere Laufwerk-E/A-Verwaltung ist möglich.

Wenn auf einem Server, auf dem Exchange Server 2003 Enterprise Edition ausgeführt wird, weniger als vier Speichergruppen und mehr als vier Postfachspeicher vorhanden sind, führen Sie die folgenden Schritte aus, um die Postfächer auf so viele Speichergruppen wie möglich zu verteilen.

So beheben Sie diesen Fehler

  1. Wählen Sie im Exchange-System-Manager den Server aus, der diesen Fehler gemeldet hat. Notieren Sie die Anzahl der Speichergruppen und Postfachspeicher, die sich auf diesem Server befinden. Notieren Sie die Speichergruppen, die mehrere Postfachspeicher enthalten.

  2. Erstellen Sie zusätzliche Speichergruppen, bis auf dem Computer, auf dem Exchange Server 2003 Enterprise Edition ausgeführt wird, vier Speichergruppen vorhanden sind. Informationen zum Erstellen von neuen Speichergruppen finden Sie unter „Hinzufügen einer Speichergruppe" im Technischen Referenzhandbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).

  3. Erstellen Sie in allen neu erstellten Speichergruppen einen neuen Postfachspeicher. Informationen zum Erstellen von neuen Postfachspeichern finden Sie unter „Hinzufügen eines Postfachspeichers" im Technischen Referenzhandbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).

  4. Verschieben Sie Postfächer aus einem der Postfachspeicher in der Speichergruppe, die mehrere Postfachspeicher enthält, in den Postfachspeicher in einer neu erstellten Speichergruppe. Verschieben Sie Postfächer mithilfe des Assistenten zum Verschieben von Postfächern. Weitere Informationen zum Verwenden des Assistenten zum Verschieben von Postfächern finden Sie in „Verwenden des Assistenten für Exchange-Aufgaben zum Verschieben des Postfachs" im Kapitel „Migration von Exchange Server 5.5" im Bereitstellungshandbuch für Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=77b6d819-c7b3-42d1-8fbb-fe6339ffa1ed&DisplayLang=de).

Weitere Informationen zum Konfigurieren von Speichergruppen in Exchange Server 2003 finden Sie im Microsoft Knowledge Base-Artikel 890699 „How to configure storage groups in Exchange Server 2003" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=890699.

Informationen zum Konfigurieren von Speichergruppen finden Sie im Abschnitt zur Speichergruppenkonfiguration in „Planen einer zuverlässigen Back-End-Speicherlösung" unter Exchange Server 2003-Handbuch für hohe Verfügbarkeit (http://go.microsoft.com/fwlink/?LinkId=47571).

Allgemeine Empfehlungen zum Maximieren der Verfügbarkeit, Fehlertoleranz und Leistung finden Sie unter Optimieren von Speichersystemen für Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=c6084d20-9730-4ffc-805d-b957327604c6&DisplayLang=de).


Signaturdiskrepanz zwischen Datenbank und Streamingdatei
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer hat festgestellt, dass es eine Signaturdiskrepanz zwischen Ihrer Exchange-Datenbankdatei (EDB) und ihrer zugehörigen Exchange-Streamingdatenbankdatei (STM) gibt.

Jede Datenbank in Exchange 2000 Server und Exchange Server 2003 besteht aus zwei Dateien: MAPI-Datenbankdatei (EDB) und Streamingdatenbankdatei (STM). Verbundene Paare dieser Dateien tragen die gleiche Datenbanksignatur. Wenn die Datenbanksignatur nicht übereinstimmt, sind die Dateien nicht verbunden.

Sie sollten die EDB- und STM-Dateien so behandeln, als ob sie eine einzige Datei wären. Sie werden immer zusammen verschoben oder kopiert.

So beheben Sie diesen Fehler

  • Untersuchen Sie den Verlauf der Datenbankdateien. Es ist wahrscheinlich, dass Dateien manuell kopiert, verschoben oder gelöscht wurden. Sie müssen dieses Problem beheben, ehe die Datenbank wiederhergestellt werden kann.

  • Wenn Sie die zusammengehörigen EDB- und STM-Dateien nicht finden können, können Sie Eseutil.exe verwenden, um nur die EDB-Datei zu reparieren und Eseutil mit dem Schalter /createstm, um die STM-Datei zu verwerfen. Diese Methode führt zum Verlust sämtlicher Informationen in der Streamingdatenbank.

    Hinweis:
    Wenn alle Datenbankbenutzer sich über einen MAPI-Client wie Microsoft Office Outlook® mit der Datenbank verbinden, wird in der Stramingdatenbank nur sehr wenig Information gespeichert. Wenn Benutzer sich über POP3-, IMAP- oder Outlook Web Access-Clients mit der Datenbank verbinden, enthält die Streamingdatenbank den Inhalt aller oder einiger Benutzerpostfächer.

Weitere Informationen zum Reparieren einer Exchange-Datenbank finden Sie im Microsoft Knowledge Base-Artikel 812357 „How to maintain your Exchange database after you repair by using the Eseutil /p tool in Exchange Server 5.5, in Exchange 2000 Server, and in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679).


Die SMTP-Adresse ist in der Standardempfängerrichtlinie nicht definiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2006-12-03

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob die SMTP-Adresse im Attribut gatewayProxy der Standardempfängerrichtlinie der Exchange Server-Organisation angegeben wurde. Wenn Exchange Server Analyzer feststellt, dass im Attribut gatewayProxy keine SMTP-Adresse enthalten ist, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Bei diesem Fehler handelt es sich um einen schwerwiegenden Fehler. Die SMTP-Adresse (z. B. SMTP:@contoso.com) muss dem Attribut gatewayProxy der Standardempfängerrichtlinie in der Exchange Server-Organisation hinzugefügt werden. Die Standardempfängerrichtlinie muss eine SMTP-Adresse enthalten. Wenn die Standardempfängerrichtlinie keine SMTP-Adresse enthält, kann der Microsoft Exchange-Informationsspeicherdienst nach dem Neustart nicht initialisiert werden. Dieser Fehler betrifft alle Exchange-Server in der Exchange Server-Organisation, d. h. beim nächsten Start des Microsoft Exchange-Informationsspeicherdiensts kann dieser nicht initialisiert werden.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, von Exchange Server 2003 bzw. Exchange Server 2007 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So fügen Sie dem Attribut „gatewayProxy" der Standardempfängerrichtlinie die SMTP-Adresse hinzu

  1. Starten Sie das ADSI-Bearbeitungs-Snap-In in den Supporttools von Microsoft Windows® 2000 oder Windows Server 2003.

  2. Erweitern Sie die folgenden Knoten:

    • Container Konfiguration

    • Konfiguration

    • Dienste

    • Microsoft Exchange

    • Organisationsname

    • Empfängerrichtlinien

  3. Klicken Sie mit der rechten Maustaste im Detailbereich auf CN=Default Policy, und wählen Sie anschließend Eigenschaften aus.

  4. Doppelklicken Sie im Feld Attribute auf gatewayProxy.

  5. Geben Sie im Dialogfeld zum Bearbeiten mehrwertiger Zeichenfolgen im Feld für den hinzuzufügenden Wert die Zeichenfolge SMTP:@Domänenname.com ein, und klicken Sie dann auf Hinzufügen.

    Hinweis:
    Achten Sie bei der Eingabe auf die richtige Syntax. Dem Domänennamen der Exchange Server-Organisation muss SMTP:@ vorangestellt werden. In der Zeichenfolge sind keine Leerzeichen zulässig.

  6. Klicken Sie auf OK, klicken Sie anschließend auf Übernehmen, und schließen Sie dann die ADSI-Bearbeitung.

  7. Warten Sie mindestens 15 Minuten, bis die Replikation abgeschlossen ist.


Speicher-RPC-Prorate-Registrierungsparameter sind nicht auf ihre richtigen Werte festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest drei Registrierungsschlüssel, um zu bestimmen, ob deren Standardwerte geändert wurden. Alle drei Schlüssel sind DWORD-Werte, die sich unter folgenden Pfaden befinden:

HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Image File Execution Options\STORE.EXE\RpcThreadPoolThrottle

Die Schlüssel weisen die folgenden Namen und Standardwerte auf:

DWORD-Wert Standarddezimalwert
  • ProrateStart
  • 40
  • ProrateMax
  • 10,000
  • ProrateFactor
  • 100

Wenn Exchange Server Analyzer feststellt, dass einer der obigen Standardwerte geändert wurde, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardwerte wieder her

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\Software\Microsoft\WindowsNT\CurrentVersion\Image File Execution Options\STORE.EXE\RpcThreadPoolThrottle

  3. Doppelklicken Sie im rechten Bereich auf den Eintrag, dessen Wert geändert wurde, und legen Sie diesen auf seinen Standardwert fest.

  4. Wiederholen Sie Schritt 3, wenn mehrere Werte geändert wurden.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zu Threads für den Speichervorgang finden Sie im Knowledge Base-Artikel 267255, „Store.exe Threads Use Up Available Memory" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=267255).


Das Arbeitsverzeichnis des Speichers fehlt oder ist falsch
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-30

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um das Arbeitsverzeichnis für den Microsoft Exchange-Informationsspeicherdienst zu überprüfen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Working Directory

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen vorliegen:

  • Das als Arbeitsverzeichnis angegebene Verzeichnis ist nicht vorhanden.

  • Sie führen Exchange 2000 Server, Exchange Server 2003 oder Exchange Server 2007 aus.

Exchange Server verwendet das Arbeitsverzeichnis als temporären Speicher. Exchange Server verwendet das Arbeitsverzeichnis z. B. während der Nachrichtenkonvertierung. Exchange Server verwendet das Arbeitsverzeichnis außerdem zum Speichern einer temporären Datenbank während der Defragmentierung. Wenn das Arbeitsverzeichnis nicht richtig angegeben ist, können folgende Probleme auftreten:

  • Möglicherweise sammeln sich Nachrichten mit Anlagen in der lokalen SMTP-Übermittlungswarteschlage an.

  • Unter Umständen werden Nachrichten ohne Anlagen empfangen.

  • Möglicherweise werden Nachrichten nicht erfolgreich übermittelt.

In der Standardeinstellung legen Exchange 2000 Server und Exchange Server 2003 das Verzeichnis mdbdata als Arbeitsverzeichnis fest, das sich unterhalb des Verzeichnisses befindet, in dem Exchange Server installiert ist. Wenn Sie z. B. Exchange Server im Verzeichnis C:\Programme\Exchsrvr installieren, legt Exchange Server C:\Programme\Exchsrvr\mdbdata als Arbeitsverzeichnis fest.

In der Standardeinstellung legt Exchange Server 2007 das Postfach-Datenbankverzeichnis als Arbeitsverzeichnis fest, das sich unterhalb des Verzeichnisses befindet, in dem Exchange Server installiert ist. Wenn Sie z. B. Exchange Server im Verzeichnis C:\Programme\Exchange Server installieren, legt Exchange Server 2007 C:\Programme\Exchange Server\Mailbox\MDBTemp als Arbeitsverzeichnis fest.

Geben Sie zum Beheben dieser Warnmeldung als Arbeitsverzeichnis ein Verzeichnis an, das sich auf dem Exchange-Server befindet.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So geben Sie das Arbeitsverzeichnis mithilfe von „regedit" an

  1. Starten Sie den Registrierungs-Editor (regedit).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Aktualisieren Sie den Registrierungswert Working Directory auf das richtige Arbeitsverzeichnis für den Microsoft Exchange-Informationsspeicherdienst, z. B. C:\Programme\Exchsrvr\mdbdata.

    Hinweis:
    Für diese Änderung muss der Microsoft Exchange-Informationsspeicherdienst nicht neu gestartet werden.

  4. Schließen Sie den Registrierungs-Editor.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Registrierungswert Working Directory finden Sie im Knowledge Base-Artikel 298415, „Messages that have attachments are not delivered as expected, and Event ID 12003 and 327 messages are logged in Exchange 2000 Server and in Exchange Server 2003" (http://go.microsoft.com/fwlink/?Linkid=3052&kbid=298415).


Einstellung zur Unterdrückung von Abwesenheitsnachrichten für Verteilerlisten wurde festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-02-27

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob Abwesenheitsnachrichten für Verteilerlisten unterdrückt werden:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\SuppressOOFsToDistributionLists

Wenn Exchange Server Analyzer feststellt, dass der Wert für SuppressOOFsToDistributionLists mehr als 0 beträgt, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Wenn eine Nachricht an ein Postfach gesendet wird, für das der Abwesenheits-Assistent aktiviert ist, erhält der Absender eine Nachricht ohne Adresse im Feld An oder dem Feld Cc. Diese Nachricht enthält jedoch eine Verteilerliste im Feld Bcc, eine Abwesenheitsnachricht wird an die Adressen der Verteilerliste im Feld Bcc gesendet.

Wenn eine Nachricht an einen Empfänger gesendet wird, der nur im Feld Bcc genannt wird, jedoch nicht in einer Verteilerliste, und dieser Empfänger den Abwesenheits-Assistenten aktiviert hat, sendet der Postfachspeicher des Empfängers selbst dann eine Abwesenheitsnachricht, wenn der Registrierungswert SuppressOOFsToDistributionLists festgelegt ist. Diese Einschränkung gilt nur dann, wenn der Empfänger im Feld Bcc adressiert wurde und die Felder An und Cc leer sind. Wenn in den Feldern An und Cc mindestens ein Benutzer enthalten ist, unterdrückt der Registrierungsparameter auf dem Computer mit Exchange Server die Erstellung einer Abwesenheitsnachricht an den bzw. die im Feld Bcc aufgelisteten Empfänger.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So ändern Sie das Erstellungsverhalten von Abwesenheitsnachrichten

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Klicken Sie mit der rechten Maustaste auf ParametersSystem, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.

  4. Benennen Sie den neuen Wert SuppressOOFsToDistributionLists.

  5. Klicken Sie mit der rechten Maustaste auf SuppressOOFsToDistributionLists, und klicken Sie dann auf Ändern.

  6. Geben Sie im Feld Wert den Wert 1 ein, und klicken Sie dann auf OK.

  7. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Registrierungswert SuppressOOFsToDistributionLists finden Sie im Microsoft Knowledge Base-Artikel 825370, „Out-of-Office Messages Are Sent to Distribution Lists That Are in the BCC Field" (http://go.microsoft.com/fwlink/?lin k id=3052 & kbid=825370).


Der Schwellenwert, der steuert, wie oft eine beschädigte Nachricht den Speicher passieren darf, wurde geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-08

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um den Wert für PoisonThreshold zu bestimmen:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <GUID des privaten Informationsspeichers>

Wenn Exchange Server Analyzer feststellt, dass der Wert für PoisonThreshold nicht dem Wert 2 entspricht, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In Versionen von Exchange Server höher als Exchange Server 2003 Service Pack 1 wurde ein neues Verhalten implementiert, mit dessen Hilfe verhindert werden kann, dass beschädigte oder ungültige Nachrichten zum unerwarteten Beenden des Microsoft Exchange-Informationsspeicherdiensts führen oder dessen erfolgreichen Start verhindern.

In Exchange Server 2003 Service Pack 1 oder höher werden Nachrichten nachverfolgt, die ein unerwartetes Beenden des Microsoft Exchange-Informationsspeicherdiensts während der Konvertierung vom MAPI-Format zum MIME-Format verursachen. Der Nachrichten-ID der beschädigten Nachricht wird beim Auftreten des Absturzes in der Registrierung gespeichert. Wenn eine beschädigte Nachricht dreimal zum unerwarteten Beenden des Informationsspeichers führt, wird mithilfe dieser Informationen beim vierten Neustart des Microsoft Exchange-Informationsspeicherdiensts eine erneute Verarbeitung der Nachricht verhindert.

Wird der Microsoft Exchange-Informationsspeicherdienst aufgrund einer beschädigten Nachricht unerwartet beendet, wird der Registrierungswert PoisonIDs am folgendenden Speicherort erstellt:

HKLM\System\CurrentControlSet\Services\MSExchangeIS \<ExchangeServerName> \Private- <GUID des privaten Informationsspeichers>

Darüber hinaus kann ein Administrator den Registrierungseintrag PoisonThreshold erstellen. Der Schlüssel PoisonThreshold steuert die maximale Häufigkeit, die eine Nachricht durch den Exchange-Informationsspeicherdienst transportiert werden kann, bevor sie zum Registrierungsschlüssel PoisonIDs hinzugefügt wird. In der Standardeinstellung ist der Schwellenwert2. Um das Verhalten auszulösen, muss die Schwelle überschritten werden. Daher kann der Microsoft Exchange-Informationsspeicherdienst aufgrund einer beschädigten Datei 3 Mal beendet werden, bevor die Nachricht blockiert wird. Wenn eine Nachricht beispielsweise Ursache von 3 Abstürzen ist, wird sie blockiert, weil drei den Schwellenwert von 2 überschreitet.

Wenn ein beschädigtes Meldungsereignis in die Registrierung geschrieben wird, werden im Anwendungsereignisprotokoll Fehlerereignismeldungen (Ereignis-IDs 9680 und 9681) angezeigt. Nach dem erfolgreichen Starten des Microsoft Exchange-Informationsspeicherdiensts blockiert Exchange anschließend die Nachricht und versucht, einen Unzustellbarkeitsbericht dafür zu senden. In einigen Fällen ist Exchange möglicherweise nicht in der Lage, einen Unzustellbarkeitsbericht zu senden. In solchen Fällen verbleibt die blockierte Nachricht in der Warteschlange, bis sie abläuft. Der Registrierungsschlüssel PoisonIDs kann bis zu zehn Nachrichten-ID-Werte berücksichtigen. Wird die Grenze von zehn überschritten, wird ein neues beschädigtes Nachrichtenereignis hinzugefügt. Das beschädigte Nachrichtenereignis mit dem ältesten Absturzdatum wird entfernt.

Hinweis:
Die Schritte zum Beheben einzelner beschädigter Nachrichten liegen außerhalb des Bereichs von Exchange Server Analyzer. In einigen Fällen kann der technische Support von Microsoft möglicherweise dabei helfen, einzelne beschädigte Nachrichten zu beheben. Wenn Sie aufgrund beschädigter Nachrichten Probleme beim Herunterfahren von Exchange Server 2003 oder höher feststellen, kann es hilfreich sein, die automatische Fehlerberichterstattung auf dem Computer mit Exchange Server zu aktivieren. Fehlerberichtdaten werden zum Finden und Beheben von Problemen in der von Ihnen verwendeten Software verwendet. Weitere Informationen zum Aktivieren der Exchange-Fehlerberichterstattung finden Sie unter Exchange-Fehlerberichterstattung ist deaktiviert.

Es wird empfohlen, den Wert für PoisonThreshold wieder auf den Standardwert 2 festzulegen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diesen Fehler

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Name des Exchange-Servers>\Private-<GUID des privaten Informationsspeichers>

  3. Doppelklicken Sie im rechten Bereich auf PoisonThreshold.

  4. Geben Sie im Feld Wert den Wert 2 (als Dezimalzahl) ein, und klicken Sie auf OK.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Für den Speichervorgang wurde eine Ablaufverfolgung aktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer überprüft die Registrierung, um festzustellen, ob der Registrierungseintrag Enable Tracing und der Registrierungswert Trace User LegacyDN gemeinsam vorhanden sind. Diese beiden Registrierungswerte befinden sich unter dem folgenden Registrierungsschlüssel:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

Wenn Microsoft Exchange Server Analyzer feststellt, dass beide Registrierungseinträge vorhanden und konfiguriert sind, wird eine Warnung ausgegeben.

Der DWORD-Registrierungswert Enable Tracing ermöglicht die Ablaufverfolgung für den Microsoft Exchange-Informationsspeicherdienst. Die Ablaufverfolgung wird bei der Behebung von Startproblemen des Exchange-Speichers ausgeführt. Dies kann die Leistung erheblich beinträchtigen. Verwenden sie daher diese Registrierungseinstellung nur dann, wenn Sie ein Problem beheben möchten. Die Ablaufverfolgung kann für bestimmte Benutzer (gefilterte Ablaufverfolgung) aktiviert werden, indem der Zeichenfolgen-Registrierungswert Trace User LegacyDN hinzugefügt wird. Wenn der Wert Trace User LegacyDN nicht vorhanden ist, ist die Ablaufverfolgung für alle Benutzer aktiviert. Wenn der Wert Trace User LegacyDN vorhanden ist, ist die Ablaufverfolgung für die unter dem Schlüssel aufgeführten speziellen Benutzer aktiv.

Wenn auf dem Exchange Server-Computer keine Problembehandlung ausgeführt wird, dürfen diese Registrierungswerte nicht vorhanden sein.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Löschen Sie die Registrierungswerte Enable Tracing und Trace User LegacyDN.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den Computer neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen über die Ablaufverfolgung für einzelne Benutzer auf einem Exchange-Server finden Sie im Knowledge Base-Artikel „Per-User Tracing Feature Added to Exchange 2000 Server Service Pack 2 (SP2)" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296624).


Im Microsoft Exchange-Informationsspeicherdienst wurde für alle Benutzer Ablaufverfolgung aktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2007-01-17

Microsoft® Exchange Server Analyzer liest die Registrierung, um zu bestimmen, ob der Eintrag Enable Tracing unter dem folgenden Pfad verfügbar ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

Wenn Exchange Server Analyzer feststellt, dass der Registrierungswert Enable Tracing vorhanden und konfiguriert ist, wird eine Warnung ausgegeben.

Der DWORD-Registrierungswert Enable Tracing ermöglicht die Ablaufverfolgung für den Microsoft Exchange-Informationsspeicherdienst. Die Ablaufverfolgung wird bei Startproblemen des Speichers ausgeführt. Dies kann die Leistung erheblich beinträchtigen. Wenn keine Problembehandlung erforderlich ist, sollte diese Registrierungseinstellung nicht verwendet werden. Die Ablaufverfolgung kann für bestimmte Benutzer aktiviert werden, indem der Zeichenfolgen-Registrierungswert Trace User LegacyDN hinzugefügt wird. Wenn dieser Wert nicht vorhanden ist, bedeutet dies, dass die Ablaufverfolgung für alle Benutzer aktiviert ist.

Wenn auf dem Exchange Server-Computer keine Problembehandlung ausgeführt wird, darf dieser Wert nicht vorhanden sein.

Hinweis:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Löschen Sie den Registrierungswert Enable Tracing.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Weitere Informationen über die Ablaufverfolgung für einzelne Benutzer auf einem Exchange-Server finden Sie im Knowledge Base-Artikel „Per-User Tracing Feature Added to Exchange 2000 Server Service Pack 2 (SP2)" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296624).


Es sind nicht mehr genügend Dateinamen für Transaktionsprotokolle vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Best Practices Analyzer überprüft den Zustand der Transaktionsprotokolldateien für jede Speichergruppe durch Überprüfen der Protokolldateien auf dem Serverlaufwerk. Zum Ermitteln des Speicherorts der Protokolldateien fragt Exchange Server Best Practices Analyzer den Active Directory®-Verzeichnisdienst ab. Für jedes Speichergruppenobjekt (Klasse msExchStorageGroup) wird der Dateipfad zu den Protokolldateien im Attribut msExchESEParamLogFilePath gespeichert.

Die Transaktionsprotokolldateinamen beinhalten sequenzielle Hexadezimalzahlen, die die Sequenz der Protokolldateien erkennen. Beispielsweise wird die erste Protokolldatei für die Erste Speichergruppe in der Standardeinstellung E0000001.log genannt, die zweite E0000002.log usw. Die Sequenz kann fortgeführt werden bis E00FFFFF.log. Exchange kann bis zu 1.030.000 eindeutige Protokolldateien erstellen. Wenn Exchange jedoch das Ende der Sequenz erreicht, können die Speicher in den betroffenen Speichergruppen nicht mehr bereitgestellt werden, falls deren Bereitstellung aufgehoben wird, sobald der Grenzwert erreicht wird. Wenn die Bereitstellung aufrechterhalten wird, kann der Speicher die Bereitstellungen der Datenbanken nicht aufheben, selbst wenn keine Jet-Operationen erfolgen können. In der Regel kann Exchange mehrere Jahre ausgeführt werden, bis der Grenzwert erreicht wird.

Diese Meldung wird als Warnung angezeigt, wenn der angegebene Server über 950.000 Transaktionsprotokolldateien verwendet hat.

Diese Meldung wird als Fehler angezeigt, wenn der angegebene Server über 1.020.000 Transaktionsprotokolldateien verwendet hat.

Um das ordnungsgemäße Aufheben der Bereitstellung von Datenbanken bei Erreichen dieses Grenzwerts zu ermöglichen, wurde in ExchangeServer 2003 Service Pack 1 ein Hotfix eingefügt. Für Exchange 2000 Server ist ein Hotfix in Post-Service Pack 3 verfügbar, wie im Microsoft Knowledge Base-Artikel 830408 beschrieben: „Exchange database stores remain mounted although all transaction logs that are available to a storage group have been used" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830408).

Wenn Exchange noch nicht die Grenze von 1.030.000 Transaktionsprotokollen erreicht hat, führen Sie eine vollständige Onlinesicherung des Servers baldmöglichst aus. Weitere Informationen zum Ausführen einer vollständigen Onlinesicherung der Exchange-Speicher finden Sie im Exchange Server 2003-Handbuch zur Wiederherstellung nach Datenverlust (http://www.microsoft.com/germany/technet/datenbank/articles/600405.mspx).

Wenn Exchange diesen Grenzwert erreicht hat, müssen Sie alle vorhandenen Transaktionsprotokolle an einen anderen Speicherort verschieben. Nachdem die Protokolle verschoben wurden, wird eine neue Sequenz von Protokolldateien generiert, die mit 0x00001 beginnt. Um zu gewährleisten, dass der Exchange-Speicher die Bereitstellung der Datenbanken ordnungsgemäß aufhebt, müssen Sie den entsprechenden Hotfix für Ihre Exchange-Version anwenden.

Hinweis:
Bevor Sie die Transaktionsprotokolle verschieben, vergewissern Sie sich, dass alle Datenbanken in der Speichergruppe den Status Clean Shutdown aufweisen.
Wichtig:
Nachdem Sie die unten angegebene Prozedur ausgeführt haben, werden alle vorherigen Sicherungen ungültig gemacht. Das bedeutet nicht, dass die Sicherungen nicht wiederhergestellt werden können. Für die Sicherungen kann jedoch kein Rollforward mit zusätzlichen Transaktionsprotokollen ausgeführt werden. Nachdem Sie die Transaktionsprotokolle entfernt haben, ist das Wiederherstellen einer vorherigen Sicherung nur für die Daten möglich, die vor dem Generieren des neuen Protokolls erstellt wurden.

So beheben Sie dieses Problem

  1. Installieren Sie Service Pack 1 für Exchange Server 2003, verfügbar auf der Website für Exchange Server-Downloads unter http://go.microsoft.com/fwlink/?LinkId=29090.

    - oder -

    Im Falle von Exchange 2000 Server rufen Sie den im Microsoft Knowledge Base-Artikel 830408 „Exchange database stores remain mounted although all transaction logs that are available to a storage group have been used" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830408) angegebenen Hotfix ab und installieren ihn.

  2. Heben Sie die Bereitstellung aller Datenbanken in der Speichergruppe auf, für die keine Transaktionsprotokolldateien mehr vorhanden sind. Führen Sie hierzu die folgenden Schritte aus:

    1. Öffnen Sie den Exchange-System-Manager.

    2. Erweitern Sie Administrative Gruppen, erweitern Sie <Name der administrativen Gruppe>, erweitern Sie Server, erweitern Sie <Servername>, und erweitern Sie dann <Speichergruppenname>.

    3. Klicken Sie mit der rechten Maustaste auf den ersten Speicher in dieser Speichergruppe, und klicken Sie dann auf Bereitstellung des Informationsspeichers aufheben. Wiederholen Sie diesen Schritt für jeden Speicher in dieser Speichergruppe.

  3. Stellen Sie sicher, dass sich alle Datenbanken in der Speichergruppe im Status Clean Shutdown befinden. Führen Sie hierzu die folgenden Schritte aus:

    1. Klicken Sie im Exchange-System-Manager mit der rechten Maustaste auf den ersten Speicher in der Speichergruppe, für die keine Transaktionsprotokolldateien mehr verfügbar sind, und klicken Sie auf Eigenschaften.

    2. Klicken Sie auf die Registerkarte Datenbank, und notieren Sie sich die Pfade und die Namen der Datenbankdateien im Feld Exchange-Datenbank und im Feld Exchange-Streamingdatenbank. Jede Exchange-Datenbank besteht aus einem Dateipaar aus einer EDB-Datei und einer STM-Datei. Wiederholen Sie diesen Schritt für jeden Speicher in der Speichergruppe.

    3. Ändern Sie in der Eingabeaufforderung das Verzeichnis in den Exchange Server-Binärordner. Ändern Sie beispielsweise das Verzeichnis in C:\Programme\Exchsrvr\bin.

    4. Geben Sie Eseutil /mh Name der Datenbankdatei ein, und drücken Sie dann die EINGABETASTE. Wiederholen Sie diesen Schritt für jede Datenbank in der Speichergruppe. Durch diesen Befehl wird der Datenbankdateiheader angezeigt. Der Header enthält eine der beiden folgenden Zeilen: Status: Clean Shutdown oder Status: Dirty Shutdown.

  4. Wenn der Header die Zeile Status: Dirty Shutdown enthält, müssen Sie die Datenbank manuell wiederherstellen, bevor Sie die Protokolldateien entfernen. Führen Sie hierzu die folgenden Schritte aus:

    1. Klicken Sie im Exchange-System-Manager mit der rechten Maustaste auf die Speichergruppe, für die keine Transaktionsprotokolldateien mehr verfügbar sind, und klicken Sie auf Eigenschaften.

    2. Klicken Sie auf die Registerkarte Allgemein, und notieren Sie sich die Pfade der Transaktionsprotokolle im Feld Pfad des Transaktionsprotokolls.

    3. Notieren Sie sich den Pfad der Prüfpunktdatei im Feld Systempfad.

    4. Ändern Sie in der Eingabeaufforderung das Verzeichnis in den Exchange Server-Binärordner.

    5. Geben Sie den folgenden Befehl ein, und drücken Sie die EINGABETASTE: Eseutil /r 3-stelliger Basisname der Protokolldatei /lDirectory:\Pfad der Protokolldatei /sDirectory:\Pfad der Prüfpunktdatei.

      Hinweis:
      Geben Sie keine Leerstelle zwischen dem Optionsschalter und den Verzeichnispfaden ein. Bei einem Tippfehler in den Pfaden, die im Befehl aufgelistet sind, schlägt die Wiederherstellung möglicherweise fehl. Um dies zu vermeiden, kopieren Sie die Prüfpunktdatei in den Transaktionsprotokolldateiordner. Führen Sie in einer Eingabeaufforderung, die in der Standardeinstellung das Protokolldateiverzeichnis aufweist, den Befehl Eseutil /r 3-stelliger Basisname der Protokolldatei aus. Da der Schalter /l und der Schalter /s in der Standardeinstellung das aktuelle Verzeichnis aufweisen, müssen Sie die Pfade der Protokolldateien oder der Prüfpunktdateien nicht bereitstellen.
    6. Überprüfen Sie nach Abschluss der Wiederherstellung, dass sich jetzt alle Datenbankdateien im Status Clean Shutdown befinden, bevor Sie die Transaktionsprotokolldateien und die Prüfpunktdateien verschieben. Wenn Sie Protokolldateien verschieben, wenn sich die Datenbank im Status Dirty Shutdown befindet, können Sie anschließend keinen Neustart der Datenbank ausführen. Wenn Sie nicht alle Datenbanken im Status Clean Shutdown wiederherstellen können, wenden Sie sich an den Technischen Support von Microsoft, um weitere Informationen zu erhalten.

  5. Klicken Sie im Exchange-System-Manager mit der rechten Maustaste auf die Speichergruppe, für die keine Transaktionsprotokolldateien mehr verfügbar sind, und klicken Sie auf Eigenschaften.

  6. Klicken Sie auf die Registerkarte Allgemein, und notieren Sie sich die Pfade der Transaktionsprotokolle im Feld Pfad des Transaktionsprotokolls.

  7. Notieren Sie sich den Pfad der Prüfpunktdatei im Feld Systempfad.

  8. Verschieben Sie die Transaktionsprotokolldateien und die Prüfpunktdateien an eine andere Position. Die Protokolldateien weisen die Dateinamenerweiterung LOG auf, und die Prüfpunktdateien weisen die Dateinamenerweiterung CHK auf.

  9. Klicken Sie im Exchange-System-Manager mit der rechten Maustaste auf den ersten aufgehobenen Speicher in der Speichergruppe, und klicken Sie auf Informationsspeicher bereitstellen.

  10. Wiederholen Sie diesen Schritt für jeden Speicher in der Speichergruppe. Die Sequenz der Protokolldatei ist jetzt auf die Speichergruppe festgelegt.

  11. Führen Sie eine vollständige Sicherung aller Datenbanken der Speichergruppe durch.

Weitere Informationen zu den Service Packs für Exchange Server finden Sie auf der Exchange Server-Website (http://go.microsoft.com/fwlink/?LinkId=21573).


Die max. Blockgröße des VM ist niedrig.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_PerfRawData_MSExchangeIS_MSExchangeIS ab, um den Wert für den Schlüssel VMLargestBlockSize zu ermitteln. Der Schlüssel VMLargestBlockSize gibt die Größe (in Byte) des größten verfügbaren Blocks des virtuellen Speichers an.

Um die Anzahl der Einträge zu ermitteln, die im Attribut homeMDBBL jedes Postfachspeichers aufgelistet sind, fragt Exchange Server Analyzer außerdem den Active Directory®-Verzeichnisdienst ab. Der Zählwert dieses Attributs stellt die Zahl der Postfächer im Postfachspeicher dar.

Wenn Exchange Server Analyzer feststellt, dass der Wert für VMLargestBlockSize auf einem Exchange Server-Computer mit mehr als 20 Postfächern mehr als 50000000 und weniger als 150000000 beträgt, wird eine Warnmeldung angezeigt.

Exchange-Server verwenden den virtuellen Speicher u. a., um Meldungen zu speichern, wenn diese zwischen MIME- und MAPI-Formaten konvertiert werden, sowie als Puffer bei der Übermittlung von Meldungen aus dem Transaktionsprotokoll und bei der Übermittlung an den Speicher. Häufig sind große zusammenhängende Abschnitte von virtuellem Speicher erforderlich, um diese Vorgänge schnell und effizient abzuschließen. Wenn diese Warnung angezeigt wird, ist der virtuelle Speicher des Exchange-Computers auf einen zusammenhängendem Abschnitt von weniger als 150 MB geschrumpft. Dies wird als Fragmentierung von virtuellem Speicher bezeichnet.

Falls der virtuelle Speicher zu stark reduziert wird, finden Sie möglicherweise im Ereignisprotokoll Fehlermeldungen (Ereignis-ID 9582) vor, die sich auf den virtuellen Speicher beziehen. Falls der virtuelle Speicher ausreichend niedrig ist, finden Sie Ereignis-ID 12800 im Ereignisprotokoll. Das bedeutet, dass keine Nachrichten übermittelt werden, da nicht genügend Arbeitsspeicher vorhanden ist, um Nachrichten zu verarbeiten.

Folgen Sie diesen Empfehlungen in der angegebenen Reihenfolge, um diese Warnung zu vermeiden.

Suchen Sie nach dem Fehler „Maximale ESE-Cache-Größe wurde heraufgestuft" in der Ausgabe von Exchange Server Analyzer.

Wenn der Fehler Maximale ESE-Cache-Größe wurde heraufgestuft auf demselben Exchange-Computer zurückgegeben wird, auf dem diese Fragmentierungswarnung für virtuellen Speicher zurückgegeben worden ist, folgen Sie den Empfehlungen im Artikel Der maximale ESE-Cache ist zu hoch festgelegt..

Die Kombination dieser beiden Meldungen weist vermutlich darauf hin, dass die Fragmentierungsprobleme des virtuellen Speichers eine Folge des manuellen Heraufstufens des ESE-Caches ist.

Neustarten des Exchange-Informationsspeicherdiensts

In der Beschreibung dieser Fehlermeldung wird von Exchange Server Analyzer die Anzahl von Tagen angegeben, die der Microsoft Exchange-Informationsspeicherdienst ausgeführt wurde. Sie starten den Dienst neu, wenn die angegebene Zahl an Tagen den Wert 30 überschreitet.

So starten Sie den Microsoft Exchange-Informationsspeicherdienst neu

  1. Öffnen Sie das MMC-Snap-In Dienste.

  2. Klicken Sie mit der rechten Maustaste auf den Dienst Microsoft Exchange-Informationsspeicher, und klicken Sie dann auf Neu starten.

Auswerten der Nachrichtengrößenbeschränkung

Wenn viele Benutzer umfangreiche Nachrichten (über 30 MB) senden, wird der virtuelle Speicher schneller fragmentiert, als wenn viele Benutzer weniger umfangreiche Nachrichten senden. Wie bereits erwähnt, wird der virtuelle Speicher als Puffer verwendet, wenn Daten aus Protokolldateien verschoben und an den Speicher übermittelt werden. Große, zusammenhängende Abschnitte an virtuellem Speicher werden schnell verbraucht, wenn es sich bei den verschobenen Daten häufig um umfangreiche Daten handelt.

Ziehen Sie die Einrichtung von freigegebenen Verzeichnissen auf Dateiservern in Erwägung, auf denen Benutzer umfangreiche Daten bereitstellen können, wenn umfangreiche Daten regelmäßig intern per E-Mail versandt werden.

Es wird empfohlen, den Grenzwert für die maximale Nachrichtengröße auf höchstens 30 MB festzulegen. Wenn Sie jedoch einen höheren Grenzwert für die Nachrichtengröße der innerhalb Ihrer Exchange-Organisation gesendeten Nachrichten mit großen Anlagen benötigen, möchten Sie u. U. den maximalen Grenzwert für die Größe ausgehender Nachrichten über 30 MB hinaus erhöhen. Neben der Fragmentierung des virtuellen Speichers kann die Erhöhung des Grenzwerts für die Nachrichtengröße über 30 MB hinaus dazu führen, dass Ihr System anfälliger für böswillige Angriffe wird. Es wird daher nicht empfohlen, einen höheren Grenzwert als 30 MB für die Nachrichtengröße zuzulassen.

So legen Sie Grenzwerte für die Nachrichtengröße fest

  1. Erweitern Sie im Exchange-System-Manager Globale Einstellungen, klicken Sie mit der rechten Maustaste auf Nachrichtenübermittlung, und klicken Sie dann auf Eigenschaften.

  2. Wählen Sie im Dialogfeld Eigenschaften von Nachrichtenübermittlung auf der Registerkarte Standardwerte die Option Senden des Grenzwerts für Nachrichtengröße aus, und geben Sie den gewünschten Grenzwert ein.

Überprüfen der Aktualität der Antivirus-Software

Zuweilen verursacht veraltete Antivirus-Software, die im Exchange Virus Scanning API (VSAPI)-Modus ausgeführt wird, eine Fragmentierung des virtuellen Speichers. Wenden Sie sich an Ihren Hersteller von Antivirus-Software, wenn Sie Antivirus-Software im VSAPI-Modus ausführen, und vergewissern Sie sich, dass Sie die neueste Version der Software und der Treiber verwenden.

Verschieben von Postfächern auf einen anderen Exchange Server

Wenn Sie alle diese Maßnahmen durchgeführt haben und von Exchange Server Analyzer immer noch diese Warnung angezeigt wird, müssen Sie die Postfächer vom betroffenen Server verschieben, um die Serverbelastung zu verringern. Auf diesem Server befinden sich zu viele Postfächer.

So verschieben Sie Postfächer auf Exchange 2000 Server und Exchange Server 2003

  1. Wählen Sie in Active Directory-Benutzer und -Computer den oder die Benutzer, deren Postfächer Sie verschieben möchten.

  2. Klicken Sie mit der rechten Maustaste auf die Benutzerliste, die Sie im vorherigen Schritt ausgewählt haben, und klicken Sie dann auf Exchange-Aufgaben.

  3. Klicken Sie im Assistent für Exchange-Aufgaben auf der Seite Verfügbare Aufgaben auf Postfach verschieben und dann aufWeiter.

  4. Lesen Sie die verbleibenden Schritte im Assistenten sorgfältig, und folgen Sie den Anweisungen.

So verschieben Sie Postfächer auf Exchange Server 2003

  1. Erweitern Sie im Exchange-System-Manager den Eintrag Server, erweitern Sie den Server, von dem Sie Postfächer verschieben möchten, erweitern Sie die Speichergruppe, von der Sie Postfächer verschieben möchten, erweitern Sie den Postfachspeicher mit den zu verschiebenden Postfächern, und klicken Sie dann auf Postfächer.

  2. Klicken Sie im Detailbereich mit der rechten Maustaste auf den oder die Benutzer, dessen bzw. deren Postfächer Sie verschieben möchten, und klicken Sie dann auf Exchange-Aufgaben.

  3. Klicken Sie im Assistent für Exchange-Aufgaben auf der Seite Verfügbare Aufgaben auf Postfach verschieben und dann aufWeiter.

  4. Lesen Sie die verbleibenden Schritte im Assistenten sorgfältig, und folgen Sie den Anweisungen.

Weitere Informationen zum Beheben von Fragmentierungsproblemen des virtuellen Speichers finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 325044, „SO WIRD'S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044

  • 838233, "Your computer may slow or stop responding and repeatedly log event IDs 9582 and 1160 in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=838233)

Weitere Informationen zum Festlegen der Grenzwerte für die Nachrichtengröße finden Sie im Microsoft Knowledge Base-Artikel 322679: „Set Size Limits for Messages" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)

Weitere Informationen zum Verschieben von Postfächern finden Sie in den folgenden Artikeln der Knowledge Base:

  • 328810, „Moving mailboxes between servers" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328810).

  • 821829, „Moving Mailboxes in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821829).


Die maximale VM-Blockgröße erreicht eine kritische Grenze.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_PerfRawData_MSExchangeIS_MSExchangeIS ab, um den Wert für den Schlüssel VMLargestBlockSize zu ermitteln. Der Schlüssel VMLargestBlockSize gibt die Größe (in Byte) des größten verfügbaren Blocks des virtuellen Speichers an.

Um die Anzahl der Einträge zu ermitteln, die im Attribut homeMDBBL jedes Postfachspeichers aufgelistet sind, fragt Exchange Server Analyzer auch den Active Directory®-Verzeichnisdienst ab. Der Zählwert dieses Attributs stellt die Zahl der Postfächer im Postfachspeicher dar.

Wenn Exchange Server Analyzer feststellt, dass der Wert für VMLargestBlockSize auf einem Exchange Server-Computer mit mehr als 20 Postfächern größer als 0 und kleiner als 50000001 ist, wird ein Fehler angezeigt.

Exchange-Server verwenden den virtuellen Speicher u. a., um Meldungen zu speichern, wenn diese zwischen MIME- und MAPI-Formaten konvertiert werden, sowie als Puffer bei der Übermittlung von Meldungen aus dem Transaktionsprotokoll und bei der Übermittlung an den Speicher. Häufig sind große zusammenhängende Abschnitte von virtuellem Speicher erforderlich, um diese Vorgänge schnell und effizient abzuschließen. Wenn dieser Fehler angezeigt wird, ist der virtuelle Speicher des Exchange-Computers auf einen zusammenhängenden Abschnitt von weniger als 50 MB geschrumpft. Dies wird als Fragmentierung von virtuellem Speicher bezeichnet. Wenn ein Exchange-Postfachserver mit weniger als 50 MB zusammenhängendem virtuellem Speicher ausgeführt wird, ist dies ein schwerwiegender Fehler.

Falls der virtuelle Speicher zu stark reduziert wird, finden Sie im Ereignisprotokoll (Ereignis-ID 9582) möglicherweise Fehlermeldungen vor, die sich auf den virtuellen Speicher beziehen. Falls der virtuelle Speicher zu gering ist, finden Sie Ereignis-ID 12800 im Ereignisprotokoll. Das bedeutet, dass keine Nachrichten übermittelt werden, da nicht genügend Arbeitsspeicher vorhanden ist, um Nachrichten zu verarbeiten.

Um diesen Fehler zu beheben, befolgen Sie die nachstehenden Empfehlungen in der angegebenen Reihenfolge.

Suchen Sie nach dem Fehler „Maximale ESE-Cache-Größe wurde heraufgestuft" in der Ausgabe von Exchange Server Analyzer.

Wenn der Fehler Maximale ESE-Cache-Größe wurde heraufgestuft auf demselben Exchange-Computer zurückgegeben wird, auf dem diese Fragmentierungswarnung für virtuellen Speicher zurückgegeben worden ist, folgen Sie den Empfehlungen im Artikel Der maximale ESE-Cache ist zu hoch festgelegt..

Die Kombination dieser beiden Warnmeldungen weist vermutlich darauf hin, dass die Fragmentierungsprobleme des virtuellen Speichers eine Folge des manuellen Heraufstufens des ESE-Caches ist.

Neustarten des Exchange-Informationsspeicherdiensts

In der Beschreibung dieser Warnmeldung wird von Exchange Server Analyzer die Anzahl von Tagen angegeben, die der Microsoft Exchange-Informationsspeicherdienst ausgeführt wurde. Starten Sie den Dienst neu, wenn die angegebene Zahl an Tagen den Wert 30 überschreitet.

So starten Sie den Exchange-Informationsspeicher neu

  1. Öffnen Sie das MMC-Snap-In Dienste.

  2. Klicken Sie mit der rechten Maustaste auf den Dienst Microsoft Exchange-Informationsspeicher, und klicken Sie dann auf Neu starten.

Auswerten der Nachrichtengrößenbeschränkung

Wenn viele Benutzer umfangreiche Nachrichten (über 30 MB) senden, wird der virtuelle Speicher u. U. schneller fragmentiert, als wenn viele Benutzer weniger umfangreiche Nachrichten senden. Wie zuvor erwähnt, wird der virtuelle Speicher als Puffer verwendet, wenn Daten aus Protokolldateien verschoben und an den Speicher übermittelt werden. Große, zusammenhängende Abschnitte an virtuellem Speicher werden schnell verbraucht, wenn es sich bei den verschobenen Daten häufig um umfangreiche Daten handelt.

Ziehen Sie die Einrichtung von freigegebenen Verzeichnissen auf Dateiservern in Erwägung, auf denen Benutzer umfangreiche Daten bereitstellen können, wenn umfangreiche Daten regelmäßig intern per E-Mail versandt werden.

Es wird empfohlen, den Grenzwert für die maximale Nachrichtengröße auf höchstens 30 MB festzulegen. Wenn Sie jedoch einen höheren Grenzwert für die Nachrichtengröße der innerhalb Ihrer Exchange-Organisation gesendeten Nachrichten mit großen Anlagen benötigen, möchten Sie u. U. den maximalen Grenzwert für die Größe ausgehender Nachrichten über 30 MB hinaus erhöhen. Neben der Fragmentierung des virtuellen Speichers kann die Erhöhung des Grenzwerts für die Nachrichtengröße über 30 MB hinaus dazu führen, dass Ihr System anfälliger für böswillige Angriffe wird. Es wird daher nicht empfohlen, einen höheren Grenzwert als 30 MB für die Nachrichtengröße zuzulassen.

So legen Sie Grenzwerte für die Nachrichtengröße fest

  1. Erweitern Sie im Exchange-System-Manager Globale Einstellungen, klicken Sie mit der rechten Maustaste auf Nachrichtenübermittlung, und dann auf Eigenschaften.

  2. Wählen Sie im Dialogfeld Eigenschaften von Nachrichtenübermittlung auf der Registerkarte Standardwerte die Option Senden des Grenzwerts für Nachrichtengröße aus, und geben Sie den gewünschten Grenzwert ein.

Überprüfen der Aktualität der Antivirus-Software

Zuweilen verursacht veraltete Antivirus-Software, die im Exchange Virus Scanning API (VSAPI)-Modus ausgeführt wird, eine Fragmentierung des virtuellen Speichers. Wenden Sie sich an Ihren Hersteller von Antivirus-Software, wenn Sie Antivirus-Software im VSAPI-Modus ausführen, und vergewissern Sie sich, dass Sie die neueste Version der Software und der Treiber verwenden.

Verschieben von Postfächern auf einen anderen Exchange Server

Wenn Sie alle o. g. Prozeduren durchgeführt haben und Exchange Server Analyzer diesen Fehler oder die Warnmeldung noch immer anzeigt (d. h., es sind weniger als 150 MB zusammenhängender virtueller Speicher verblieben), müssen Sie Postfächer vom betroffenen Server verschieben, um die Serverbelastung zu verringern. Auf diesem Server befinden sich zu viele Postfächer.

So verschieben Sie Postfächer auf Exchange 2000 Server und Exchange Server 2003

  1. Wählen Sie in Active Directory-Benutzer und -Computer den oder die Benutzer, deren Postfächer Sie verschieben möchten.

  2. Klicken Sie mit der rechten Maustaste auf die Benutzerliste, die Sie im vorherigen Schritt ausgewählt haben, und klicken Sie dann auf Exchange-Aufgaben.

  3. Klicken Sie im Assistent für Exchange-Aufgaben auf der Seite Verfügbare Aufgaben auf Postfach verschieben und dann aufWeiter.

  4. Lesen Sie die verbleibenden Schritte im Assistenten sorgfältig, und folgen Sie den Anweisungen.

So verschieben Sie Postfächer auf Exchange Server 2003

  1. Erweitern Sie im Exchange-System-Manager den Eintrag Server, erweitern Sie den Server, von dem Sie Postfächer verschieben möchten, erweitern Sie die Speichergruppe, von der Sie Postfächer verschieben möchten, erweitern Sie den Postfachspeicher mit den zu verschiebenden Postfächern, und klicken Sie dann auf Postfächer.

  2. Klicken Sie im Detailbereich mit der rechten Maustaste auf den oder die Benutzer, dessen bzw. deren Postfächer Sie verschieben möchten, und klicken Sie dann auf Exchange-Aufgaben.

  3. Klicken Sie im Assistent für Exchange-Aufgaben auf der Seite Verfügbare Aufgaben auf Postfach verschieben und dann aufWeiter.

  4. Lesen Sie die verbleibenden Schritte im Assistenten sorgfältig, und folgen Sie den Anweisungen.

Weitere Informationen zum Beheben von Fragmentierungsproblemen des virtuellen Speichers finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 325044, „SO WIRD'S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044

  • 838233, „Your computer may slow or stop responding and repeatedly log event IDs 9582 and 1160 in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=838233)

Weitere Informationen zum Festlegen der Grenzwerte für die Nachrichtengröße finden Sie im Microsoft Knowledge Base-Artikel 322679 „Set Size Limits for Messages" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679)

Weitere Informationen zum Verschieben von Postfächern finden Sie in den folgenden Artikeln der Knowledge Base:

  • 328810 „Moving mailboxes between servers" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810).

  • 821829 „Moving Mailboxes in Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).


VirtualReserveSize is non-default
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungswert, um zu bestimmen, ob die anfängliche Arbeitsspeicherreservierung für die ExIPC-Komponente (Exchange Interprocess Communication -prozessübergreifende Exchange-Kommunikation) vom Standardwert abweicht:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIPC\Parameters\VirtualReserveSize

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel VirtualReserveSize vorhanden und mit einem Wert konfiguriert ist, der größer ist als 0, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

ExIPC ist eine Warteschlangenkomponente, mit der Inetinfo.exe (Internetinformationsdienste - Internet Information Services) und Store.exe (Microsoft Exchange-Informationsspeicherdienst - Microsoft Exchange Information Store Service) Daten schnell verschieben können. Im Allgemeinen ist die anfängliche Standard-Arbeitsspeicherreservierung für ExIPC ausreichend. In der Standardeinstellung ist der Schlüssel VirtualReserveSize nicht vorhanden. Er sollte nur auf Anraten der Microsoft Consulting Services oder des technischen Supports von Microsoft hinzugefügt und konfiguriert werden.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\EXIPC\Parameters

  3. Löschen Sie den Schlüssel VirtualReserveSize.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst und den IIS-Verwaltungsdienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zu ExIPC finden Sie in den folgenden Knowledge Base-Artikeln:

  • 821879, „Definitions of key transport components in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821879)

  • 260995, „XCON: Definitions of Key Transport Components in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260995)


Ereignisintervall für virtuellen Speicher wurde außer Kraft gesetzt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Schwellenwert für die Protokollierung eines Ereignisses, das sich auf die Fragmentierung des virtuellen Speichers bezieht, manuell außer Kraft gesetzt wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ VM Info Update Interval

Wenn Microsoft Exchange Server Analyzer ermittelt, dass der Registrierungswert VM Info Update Interval vorhanden, jedoch ungleich 3600 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In 32-Bit-Systemen von Microsoft Windows® gibt es zwei Arten von Arbeitsspeicher: den physischen Arbeitsspeicher (den tatsächlich im System installierten Arbeitsspeicher) und den virtuellen Speicheradressraum (einen virtualisierten 4 GB-Speicher). Die Gesamtgröße des virtuellen Adressraums bleibt immer gleich, unabhängig von der Größe des im System installierten physischen Arbeitsspeichers: 4 GB. Auch wenn dies nicht für alle 32-Bit-Anwendungen gilt: Bei Exchange Servern entspricht der virtuelle Adressraum dem virtuellem Speicher, die Begriffe sind daher austauschbar.

Zum normalen Betrieb des Microsoft Exchange-Informationsspeicherdienstes gehört das wiederholte Zuweisen, Verwenden und Freigeben von virtuellem Speicher. Häufiges Zuweisen, Verwenden und Freigeben von virtuellem Speicher kann eine Fragmentierung des virtuellen Speichers verursachen. Die Fragmentierung des virtuellen Speichers entspricht der Fragmentierung des Dateisystems, die im Lauf der Zeit auftreten kann. Nach einer gewissen Zeit sind die zugewiesenen Segmente des virtuellen Speichers nicht mehr zusammenhängend, und die Leistung wird beeinträchtigt. Beim Dateisystem können Sie eine Anwendung ausführen, die eine Defragmentierung des Dateisystems durchführt. In den meisten Fällen kann dies erfolgen, während auf das System zugegriffen wird und es online ist. Bei einer Fragmentierung des virtuellen Speichers gibt es kein Tool zur Defragmentierung. Stattdessen müssen Sie den Microsoft Exchange-Informationsspeicherdienst beenden und neu starten, um das Problem zu beheben.

In der Standardeinstellung überprüft der Microsoft Exchange-Informationsspeicherdienst einmal pro Stunde (z. B. alle 3.600 Sekunden), ob freier virtueller Speicher vorhanden ist. Der Registrierungswert VM Info Update Interval stellt eine Konfigurationsmöglichkeit dar, durch die der Administrator das Standardintervall von 3.600 Sekunden überschreiben kann. Wenn Sie den Standardwert überschreiben, wird empfohlen, keinen Wert von weniger als 5 Minuten (300 Sekunden) festzulegen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Löschen Sie im rechten Bereich den Wert für VM Info Update Interval.

  4. Schließen Sie den Registrierungs-Editor, und starten Sie den Microsoft Exchange-Informationsspeicherdienst neu, damit die Änderung wirksam wird.

Weitere Informationen zur Problembehandlung bei der Fragmentierung des virtuellen Speichers in Exchange Server 2003 und Exchange 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 325044, „SO WIRD´S GEMACHT: Problembehandlung bei Fragmentierung des virtuellen Speichers in Exchange 2003 und Exchange 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).


Write-Back-Cache nicht aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Speicher >

Letztes Änderungsdatum des Themas: 2006-08-18

Microsoft® Exchange Server Analyzer hat erkannt, dass auf Ihrem Datenträger-Arraycontroller der Write-Back-Cache für die Laufwerke mit den Transaktionsprotokollen nicht ordnungsgemäß festgelegt ist.

Es wird empfohlen, den Write-Back-Cache Ihres Arraycontrollers für alle Laufwerke mit Transaktionsprotokollen zu 100 % zu aktivieren. Transaktionsprotokolle werden selten gelesen. Je höher die Schreibgeschwindigkeit, die dem Transaktionsprotokolllaufwerk zur Verfügung steht, desto besser ist die Leistung eines Servers mit Exchange Server.

So vermeiden Sie diese Warnung

  • Aktivieren Sie den Write-Back Cache.

Weitere Informationen zum Konfigurieren der Festplatten eines Computers mit Exchange Server finden Sie im Microsoft Knowledge Base-Artikel 188589, "Exchange DB and caching hard disks and controllers" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=188589).


Software von Drittanbietern
Microsoft Exchange Server Analyzer-Tools - Artikel >

Letztes Änderungsdatum des Themas: 2005-11-18

Die Artikel in diesem Abschnitt enthalten Details darüber, welche Daten Microsoft® Exchange Server Analyzer in Bezug auf Software von Drittanbietern auswertet. Darüber hinaus werden in diesen Artikeln Aktionen beschrieben, mit denen Sie von Microsoft Exchange Server Analyzer gefundene Fehler, Warnungen und vom Standard abweichende Konfigurationen beheben können, die im Zusammenhang mit Software von Drittanbietern auftreten.


Es wurden keine Ausschlüsse von Anti-Virus-Ordnern konfiguriert
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob Symantec AntiVirus Corporate Edition (Symantec AV) unter Exchange Server installiert und RealTime Protection (RTP) aktiviert ist:

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Storages\Filesystem\RealTimeScan

Wenn Exchange Server Analyzer feststellt, dass der Registrierungswert HaveExceptionDirs auf 0 festgelegt ist, wird von Exchange Server Analyzer ein Fehler angezeigt. Der Registrierungswert 0 für HaveExceptionDirs gibt an, dass Ordnerausschlüsse deaktiviert sind.

Durch das Ausschließen von Ordnern wird verhindert, dass bestimmte Ordner in die Echtzeit-Antivirusüberprüfung einbezogen werden. Wenn unter Exchange Server keine Ordnerausschlüsse aktiviert sind, können die folgenden Probleme auftreten:

  • Symantec AV RTP liefert möglicherweise falsche Berichte über den Virusbefall bestimmter sauberer Dateien, auf die bei normalen Programmaktivitäten zugegriffen wird.

  • Symantec AV RTP gibt u. U. fälschlicherweise Berichte über infizierte Dateien in Software zurück, deren Ausführung in der Exchange Server-Umgebung von der Sicherheitsrichtlinie Ihres Unternehmens bereits zugelassen wurde.

  • Symantec AV RTP überprüft möglicherweise die Verzeichnisstruktur von Exchange Server. Dies kann u. U. zu falschen Meldungen über Virusbefall, unerwartetem Verhalten auf dem Exchange-Server oder zu Beschädigungen der Exchange Server-Datenbanken führen.

Wichtig:
Virusüberprüfungssoftware auf Dateiebene darf nicht für Exchange Server-Datenbanken, Protokolle, temporäre Dateien, IIS-Systemdateien (IIS - Internet Information Services) oder das IFS-Laufwerk (Installable File System - installierbares Dateisystem; Laufwerk M) ausgeführt werden. Konfigurieren Sie die Antivirussoftware so, dass die Ordner, die diese Dateien enthalten, von der Antivirusüberprüfung ausgeschlossen werden.

Antivirussoftware auf Dateiebene kann für das Betriebssystem des Exchange Server-Computers und für Exchange Server-Programmdateien (Ordner Exchsrvr\Bin) ausgeführt werden. Führen Sie Antivirussoftware auf Dateiebene jedoch nicht für die folgenden Dateien und Ordner aus:

  • Exchange Server-Datenbanken (MDB- und STM-Dateien) und Transaktionsprotokolldateien (LOG-Dateien) (Standardspeicherort: \Exchsrvr\MDBData)

  • Exchange Server-Dateien (MTA-Dateien; Standardspeicherort: \Exchsrvr\MDBData)

  • Protokolldateien für die Exchange Server-Nachrichtenverfolgung (Standardspeicherort: \Exchsrvr\Server_Name.log)

  • Ordner auf dem virtuellen Server (Standardspeicherort: \Exchsrvr\Mailroot)

  • SRS-Dateien (Site Replication Service - Standortreplikationsdienst; Standardspeicherort: \Exchsrvr\Srsdata)

  • IIS-Systemdateien (Internet Information Service - Internetinformationsdienste; Standardspeicherort: \%SystemRoot%\System32\Inetsrv)

  • Internet Mail Connector-Dateien (Standardspeicherort: \Exchsrvr\IMCData)

  • Der Arbeitsordner, in dem temporäre Streaming-Dateien gespeichert werden, die zur Nachrichtenkonvertierung verwendet werden. In der Standardeinstellung befindet sich dieser Arbeitsordner unter \Exchsrvr\MDBData.

  • Ein temporärer Ordner, der zusammen mit Offlinewartungstools (z. B. Eseutil.exe) verwendet wird. In der Standardeinstellung ist dieser Ordner der Speicherort, von dem die EXE-Dateien ausgeführt werden. Sie können den Speicherort jedoch beim Ausführen des Dienstprogramms konfigurieren.

Antivirusüberprüfungen auf Dateiebene können für die folgenden Ordner ausgeführt werden:

  • Exchsrvr\Address

  • Exchsrvr\Bin

  • Exchsrvr\Exchweb

  • Exchsrvr\Res

  • Exchsrvr\Schema

Detaillierte Informationen zum Konfigurieren von Ausschlüssen für die Virusüberprüfung mit RealTime in Symantec AntiVirus Corporate Edition finden Sie auf der Website von Symantec (http://www.symantec.com/).

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.

Weitere Informationen zum Schutz von Exchange Server-Umgebungen vor durch E-Mail-Nachrichten übertragenen Viren und Würmern finden Sie unter „Behindern und Blockieren von E-Mail-Viren in einer Exchange 2003-Umgebung" (http://www.microsoft.com/downloads/details.aspx?FamilyID=fb3f649a-2b0a-443d-92a5-8f8cf4bf9fdb&DisplayLang=de).

Weitere Informationen zum Verwenden von Antivirussoftware mit Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 328841, „Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841).

  • 823166, „Überblick über ExchangeServer 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie auf der Exchange Partners: Antivirus-Website (http://go.microsoft.com/fwlink/?LinkId=16226).


Replikationsnachrichten für Öffentliche Ordner werden von Antigen untersucht
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2006-03-13

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob auf jedem Exchange-Server ein Informationsspeicher für Öffentliche Ordner vorhanden ist. Wenn Exchange Server Analyzer feststellt, dass das Objekt InformationStore die Objektklasse msExchPublicMDB hat, befindet sich ein Informationsspeicher für Öffentliche Ordner auf dem Server.

Microsoft® Exchange Server Analyzer fragt außerdem die Microsoft Windows®-Verwaltungsinstrumentationsklasse (Windows® Management Instrumentation, WMI) CIM_Datafile ab, um den Wert des Schlüssels Version für die Datei ANTIGENVSAPI.DLL zu ermitteln. Ein Wert des Schlüssels Version von 1517 oder höher für ANTIGENVSAPI.DLL zeigt an, dass Sybari Antigen für Microsoft Exchange Version 8.0 SR3 oder höher auf dem Computer mit Exchange Server installiert ist.

Schließlich fragt Exchange Server Analyzer folgende Registrierungsteilstruktur ab, um festzustellen, ob der Schlüssel DoNotScanIPMReplicationMessages vorhanden ist und keinen Wert hat, der größer als 0 ist:

HKEY_LOCAL_MACHINE\Software\Sybari Software\Antigen for Exchange\DoNotScanIPMReplicationMessages

Der Wert des Schlüssels DoNotScanIPMReplicationMessages legt fest, ob die Replikationsnachrichten für Öffentliche Ordner von Exchange Server von dem installierten Sybari Antigen untersucht und möglicherweise entfernt werden. Jeder Wert des Schlüssels DoNotScanIPMReplicationMessages unter 1 bedeutet, dass die winmail.dat-Dateien von Antigen auf Viren untersucht werden. Exchange Server verwendet die Winmail.dat-Dateien zu mehreren Zwecken, einschließlich dem Erleichtern der Replikation Öffentlicher Ordner zwischen Servern. Wenn eine dieser Winmail.dat-Dateien von Antigen geändert wird, schlägt der Replikationsprozess für Öffentliche Ordner fehl.

Wenn Exchange Server Analyzer feststellt, dass die folgenden Bedingungen erfüllt sind, wird ein Fehler angezeigt:

  • Auf dem Computer mit Exchange Server befindet sich mindestens ein Informationsspeicher für Öffentliche Ordner.

  • Auf dem Server ist Sybari Antigen Build 1517 oder höher installiert.

  • Der Schlüssel DoNotScanIPMReplicationMessages ist nicht vorhanden, oder wenn er vorhanden ist, hat er einen Wert, der kleiner oder gleich 0 ist.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So berichtigen Sie diesen Fehler

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\Software\Sybari Software\Antigen for Exchange

  3. Wenn der Unterschlüssel DoNotScanIPMReplicationMessages im rechten Bereich bereits vorhanden ist, doppelklicken Sie darauf und legen den Wert auf 1 fest.

  4. Wenn der Unterschlüssel DoNotScanIPMReplicationMessages noch nicht vorhanden ist, klicken Sie mit der rechten Maustaste in den rechten Bereich, um ihn als neuen DWORD-Wert zu erstellen.

  5. Konfigurieren Sie den Wert DoNotScanIPMReplicationMessages, und legen Sie ihn auf 1 fest.

    Hinweis:
    Wenn ein Virus durch die Replikation Öffentlicher Ordner repliziert wird, wird dieser von Antigen immer noch im Echtzeit-Scanauftrag entdeckt, auch wenn dieser neue Registrierungsschlüssel aktiviert wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Weitere Informationen zum Verwenden von Antivirussoftware mit Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 328841, „XADM: Exchange und Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841).

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • 306105, „XGEN: Microsofts Position zu Antivirenlösungen für Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105).

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).


CA eTrust: EML/LOG/EDB/STM/DAT-Dateien befinden sich nicht in der Echtzeitausschlussliste für Dateien
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest die folgenden Registrierungseinträge, um eine Liste der Dateierweiterungen zu erhalten, die von der Echtzeit-Antivirus-Prüfung auf Dateiebene in eTrust Antivirus von Computer Associates ausgeschlossen sind:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeExtList

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeExtList

Wenn Exchange Server Analyzer feststellt, dass der Wert für szExcludeExtList nicht die Dateierweiterungen enthält, die dem Dateityp der Exchange-Daten (EML, LOG, EDB, STM oder DAT) entsprechen, wird eine Warnung angezeigt.

eTrust Antivirus ist ein Antivirusprogramm, das Überprüfungen auf der Dateiebene ausführt. Um die auf Ihrem Exchange Server-Computer installierte Version von eTrust Antivirus zu bestimmen, gehen Sie folgendermaßen vor:

  1. Navigieren Sie zu Start | Programme | eTrust Antivirus, und klicken Sie dann auf eTrust Antivirus, um die Anwendung zu starten.

  2. Klicken Sie im Anwendungsmenü von eTrust Antivirus auf Hilfe und anschließend auf Info zu eTrust Antivirus.

  3. Prüfen Sie das Feld Produktversion, um die Version von eTrust Antivirus zu bestimmen.

Die folgenden Probleme können auftreten, wenn Sie Antivirusprogramme auf Dateiebene auf einem Exchange Server-Computer verwenden:

  • Antivirusprüfprogramme auf Dateiebene prüfen eine Datei bei Verwendung oder in festgelegten Intervallen. Sie können u. U. eine Exchange-Protokoll- oder Datenbankdatei sperren oder isolieren, während Exchange versucht, die Datei zu verwenden. Dies kann einen schwerwiegenden Fehler in Exchange Server verursachen und zu Datenbankfehlern führen.

  • Weitere Probleme können beim Prüfen des Laufwerks auftreten, das durch das IFS (Installable File System, normalerweise Laufwerk M) mit Virenprüfsoftware auf Dateiebene dargestellt wird.

Ungeachtet des verwendeten Antivirenprogramms auf der Dateiebene sollten Sie immer die folgenden Dateien und Ordner von der Virusprüfung auf Dateiebene ausschließen:

  • EML-, EDB-, STM-, LOG-, DAT- und CHK-Dateien.

  • Das durch IFS dargestellte Exchange Server-Laufwerk. In der Standardeinstellung ist dies Laufwerk M.

  • Exchange-Datenbanken und -Protokolldateien. In der Standardeinstellung befinden sich diese im Ordner Exchsrvr\Mdbdata.

  • Exchange MTA-Dateien im Ordner Exchsrvr\Mtadata.

  • Weitere Protokolldateien wie z. B. die Datei Exchsrvr\server_name.log.

  • Der Ordner Exchsrvr\Mailroot des virtuellen Servers.

  • Der Arbeitsordner, in dem temporäre Streaming-Dateien gespeichert werden, die zur Nachrichtenkonvertierung verwendet werden. Als Standard befindet sich dieser Ordner unter \Exchsrvr\MDBData. Sie können aber den Speicherort konfigurieren.

  • Der temporäre Ordner, der mit Offlinewartungstools wie z. B. Eseutil.exe verwendet wird. In der Standardeinstellung ist dieser Ordner der Speicherort, aus dem die EXE-Datei ausgeführt wird. Sie können den Speicherort jedoch beim Ausführen des Tools konfigurieren.

  • Standortreplikationsdienst-Dateien (SRS-Dateien) im Ordner Exchsrvr\Srsdata.

  • Microsoft-Internetinformationsdienste-(IIS)-Systemdateien im Ordner %SystemRoot%\System32\Inetsrv.

  • IIS-Arbeitsdateien im Ordner %SystemRoot%\IIS für temporär komprimierte Dateien.

So beheben Sie diese Warnmeldung

  1. Schließen Sie mithilfe der eTrust Antivirus-Benutzerschnittstelle die o. a. Ordner und Dateien von der Antivirusprüfung auf Dateiebene aus.

  2. Besuchen Sie die Website von CA eTrust Antivirus (http://www3.ca.com/Solutions/Product.asp?ID=156), um aktuelle Informationen zum Verwenden von eTrust Antivirus auf einem Exchange Server-Computer zu erhalten.

    Hinweis:
    Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.

Weitere Informationen zum Verwenden von Antivirus-Software mit Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 328841, „XADM: Exchange und Antivirus-Software" (http://support.microsoft.com/kb/328841/de)

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://support.microsoft.com/kb/823166/de)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105).

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://support.microsoft.com/default.aspx?scid=kb;de-de;Q245822)

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie bei den Exchange-Partnern: Antivirus-Website (http://go.microsoft.com/fwlink/?LinkId=16226).

Weitere Informationen zu Problemen, die beim Prüfen des IFS-Laufwerks auftreten können, finden Sie in den folgenden Artikeln der Knowledge Base:

  • 298924, „XADM: Durch eine Sicherung bzw. Überprüfung des Laufwerks "M" von Exchange 2000 verursachte Probleme" unter http://support.microsoft.com/kb/298924/de.

  • 300608, „XADM: C1041737 Err Msg Displayed When You Mount Databases" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608).

  • 299046, „XADM: Kalenderelemente verschwinden aus Benutzerordnern" (http://support.microsoft.com/kb/299046/DE/)


CA eTrust: Exchange-Datenlaufwerk wurde nicht aus der manuellen Auftragsprüfung ausgeschlossen
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest die folgenden Registrierungseinträge, um eine Liste der Verzeichnisse abzurufen, die von der manuellen Antivirusprüfung auf Dateiebene in eTrust Antivirus von Computer Associates ausgeschlossen sind:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7,0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

Exchange Server Analyzer liest auch den Wert für das Attribut MsExchESEParamSystemPath im Active Directory®-Verzeichnisdienst. Hierbei handelt es sich um ein Speichergruppenattribut, das dem Speicherort der Exchange-Systemdatendateien entspricht.

Wenn Exchange Server Analyzer feststellt, dass der Wert für szExcludeDirs nicht den Pfad enthält, der dem Speicherort der Exchange-Systemdatendateien entspricht, wird eine Warnung angezeigt.

eTrust Antivirus ist ein Antivirusprogramm, das Überprüfungen auf der Dateiebene ausführt. So bestimmen Sie die auf dem Exchange Server-Computer installierte Version von eTrust Antivirus:

  1. Navigieren Sie zu Start | Programme | eTrust Antivirus, und klicken Sie dann auf eTrust Antivirus, um die Anwendung zu starten.

  2. Klicken Sie im Anwendungsmenü von eTrust Antivirus auf Hilfe und anschließend auf Info zu eTrust Antivirus.

  3. Prüfen Sie das Feld Produktversion, um die Version von eTrust Antivirus zu bestimmen.

Wenn Sie Antivirus-Programme auf Dateiebene auf einem Exchange Server-Computer verwenden, können die folgenden Probleme auftreten:

  • Antivirusprüfprogramme auf Dateiebene prüfen eine Datei bei Verwendung oder in festgelegten Intervallen. Sie können u. U. eine Exchange-Protokoll- oder Datenbankdatei sperren oder isolieren, während Exchange versucht, die Datei zu verwenden. Dies kann einen schwerwiegenden Fehler in Exchange Server verursachen und zu Datenbankfehlern führen.

  • Weitere Probleme können auftreten, wenn das durch das IFS (Installable File System, i. d. R. Laufwerk M) dargestellte Laufwerk mit Virenprüfsoftware auf Dateiebene überprüft wird.

Ungachtet des verwendeten Antivirenprogramm auf der Dateiebene sollten Sie immer die folgenden Dateien und Ordner von der Virusprüfung auf Dateiebene ausschließen:

  • EML-, EDB-, STM-, LOG-, DAT- und CHK-Dateien.

  • Das durch IFS dargestellte Exchange Server-Laufwerk. In der Standardeinstellung ist dies Laufwerk M.

  • Exchange-Datenbanken und -Protokolldateien. In der Standardeinstellung befinden sich diese im Ordner Exchsrvr\Mdbdata.

  • Exchange MTA-Dateien im Ordner Exchsrvr\Mtadata.

  • Weitere Protokolldateien, z. B. die Datei Exchsrvr\server_name.log.

  • Der Ordner Exchsrvr\Mailroot des virtuellen Servers.

  • Der Arbeitsordner, in dem temporäre Streaming-Dateien gespeichert werden, die zur Nachrichtenkonvertierung verwendet werden. In der Standardeinstellung befindet sich dieser Ordner unter \Exchsrvr\MDBData. Sie können den Speicherort jedoch auch konfigurieren.

  • Der temporäre Ordner, der mit Offlinewartungstools, z. B Eseutil.exe verwendet wird. In der Standardeinstellung ist dieser Ordner der Speicherort, aus dem die EXE-Datei ausgeführt wird. Sie können den Speicherort jedoch beim Ausführen des Tools konfigurieren.

  • Standortreplikationsdienstdateien (SRS-Dateien) im Ordner Exchsrvr\Srsdata.

  • Microsoft-Internetinformationsdienste-(IIS)-Systemdateien im Ordner %SystemRoot%\System32\Inetsrv.

  • IIS-Arbeitsdateien im Ordner %SystemRoot%\IIS für temporär komprimierte Dateien.

So beheben Sie dieses Problem

  1. Schließen Sie mithilfe der eTrust Antivirus-Benutzerschnittstelle die oben aufgeführten Ordner und Dateien von der Virenprüfung auf Dateiebene aus.

  2. Besuchen Sie die Website von CA eTrust Antivirus (http://www3.ca.com/Solutions/Product.asp?ID=156), um aktuelle Informationen zum Verwenden von eTrust Antivirus auf einem Exchange Server-Computer zu erhalten.

    Hinweis:
    Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.

Weitere Informationen zum Verwenden von Antivirus-Software mit Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 328841, „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie bei den Exchange-Partnern: Antivirus-Website (http://go.microsoft.com/fwlink/?LinkId=16226).

Weitere Informationen zu Problemen, die beim Prüfen des IFS-Laufwerks auftreten können, finden Sie in den folgenden Artikeln der Knowledge Base:

  • 298924, „XADM: Durch eine Sicherung bzw. Überprüfung des Laufwerks „M" von Exchange 2000 verursachte Probleme" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, „XADM: C1041737 Err Msg Displayed When You Mount Databases" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608).

  • 299046, „XADM: Kalenderelemente verschwinden aus Benutzerordnern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: Exchange-Datenlaufwerk wurde von der Echtzeitprüfung nicht ausgeschlossen.
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest die folgenden Registrierungseinträge, um eine Liste der Verzeichnisse abzurufen, die von der Echtzeit-Antivirenprüfung auf Dateiebene in eTrust Antivirus von Computer Associates ausgeschlossen sind:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7,0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

Exchange Server Analyzer fragt darüber hinaus den Active Directory®-Verzeichnisdienst ab, um den Wert für das Attribut MsExchESEParamSystemPath für die einzelnen Speichergruppen zu bestimmen. Dieses Attribut stellt den Pfad der Exchange-Datendateien dar.

Wenn Exchange Server Analyzer feststellt, dass der Wert für szExcludeDirs nicht den Pfad enthält, der dem Speicherort der Exchange-Systemdatendateien entspricht, wird eine Warnung angezeigt.

eTrust Antivirus ist ein Antivirusprogramm, das Überprüfungen auf Dateiebene ausführt. So bestimmen Sie die auf dem Exchange Server-Computer installierte Version von eTrust Antivirus:

  1. Navigieren Sie zu Start | Programme | eTrust Antivirus, und klicken Sie dann auf eTrust Antivirus, um die Anwendung zu starten.

  2. Klicken Sie im Anwendungsmenü von eTrust Antivirus auf Hilfe und anschließend auf Info zu eTrust Antivirus.

  3. Prüfen Sie das Feld Produktversion, um die Version von eTrust Antivirus zu bestimmen.

Die folgenden Probleme können auftreten, wenn Sie Antivirusprogramme auf Dateiebene auf einem Exchange Server-Computer verwenden:

  • Antivirusprüfprogramme auf Dateiebene prüfen eine Datei bei deren Verwendung oder in festgelegten Intervallen. Sie können u. U. eine Exchange-Protokoll- oder Datenbankdatei sperren oder isolieren, während Exchange versucht, die Datei zu verwenden. Dies kann einen schwerwiegenden Fehler in Exchange Server verursachen und zu Datenbankfehlern führen.

  • Weitere Probleme können beim Prüfen des Laufwerks auftreten, das durch das IFS (Installable File System, normalerweise Laufwerk M) mit Virenprüfsoftware auf Dateiebene dargestellt wird.

Ungeachtet des verwendeten Antivirusprogramms auf der Dateiebene sollten Sie immer die folgenden Dateien und Ordner von der Virenprüfung auf Dateiebene ausschließen:

  • EML-, EDB-, STM-, LOG-, DAT- und CHK-Dateien.

  • Das durch IFS dargestellte Exchange Server-Laufwerk. In der Standardeinstellung ist dies Laufwerk M.

  • Exchange-Datenbanken und -protokolldateien. In der Standardeinstellung befinden sich diese im Ordner Exchsrvr\Mdbdata.

  • Exchange MTA-Dateien im Ordner Exchsrvr\Mtadata.

  • Weitere Protokolldateien wie z. B. die Datei Exchsrvr\server_name.log.

  • Der Ordner Exchsrvr\Mailroot des virtuellen Servers.

  • Der Arbeitsordner, in dem temporäre Streaming-Dateien gespeichert werden, die zur Nachrichtenkonvertierung verwendet werden. Als Standard befindet sich dieser Ordner unter \Exchsrvr\MDBData. Sie können aber den Speicherort konfigurieren.

  • Der temporäre Ordner, der mit Offlinewartungstools wie z. B. Eseutil.exe verwendet wird. In der Standardeinstellung ist dieser Ordner der Speicherort, aus dem die EXE-Datei ausgeführt wird. Sie können den Speicherort jedoch beim Ausführen des Tools konfigurieren.

  • Standortreplikationsdienst (SRS)-Dateien im Ordner Exchsrvr\Srsdata.

  • Microsoft-Internetinformationsdienste-(IIS)-Systemdateien im Ordner %SystemRoot%\System32\Inetsrv.

  • IIS-Arbeitsdateien im Ordner %SystemRoot%\IIS für temporär komprimierte Dateien.

So beheben Sie diese Warnmeldung

  1. Schließen Sie mithilfe der eTrust Antivirus-Benutzerschnittstelle die o. a. Ordner und Dateien von der Antivirusprüfung auf Dateiebene aus.

  2. Besuchen Sie die Website von CA eTrust Antivirus (http://www3.ca.com/Solutions/Product.asp?ID=156), um aktuelle Informationen zum Verwenden von eTrust Antivirus auf einem Exchange Server-Computer zu erhalten.

    Hinweis:
    Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.

Weitere Informationen zum Verwenden von Antivirussoftware mit Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 328841, „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie auf der Exchange Partners: Antivirus-Website (http://go.microsoft.com/fwlink/?LinkId=16226).

Weitere Informationen zu Problemen, die beim Prüfen des IFS-Laufwerks auftreten können, finden Sie in den folgenden Artikeln der Knowledge Base:

  • 298924, „XADM: Durch eine Sicherung bzw. Überprüfung des Laufwerks „M" von Exchange 2000 verursachte Probleme" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, „XADM:C1041737 Err Msg Displayed When You Mount Databases" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, „XADM: Kalenderelemente verschwinden aus Benutzerordnern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: Exchange-IFS-Pfad wurde nicht aus der manuellen Auftragsprüfung ausgeschlossen
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest die folgenden Registrierungseinträge, um eine Liste der Verzeichnisse abzurufen, die von der manuellen Antivirusprüfung auf Dateiebene in eTrust Antivirus von Computer Associates ausgeschlossen sind:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

Exchange Server Analyzer liest zudem den folgenden Registrierungseintrag, um den Laufwerksbuchstaben abzurufen, der das IFS-Laufwerk (Installable File System) von Exchange darstellt:

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

Unter Exchange 2000 Server ist der Standardlaufwerksbuchstabe M. Das IFS-Laufwerk ist in Exchange Server 2003 in der Standardeinstellung deaktiviert.

Wenn Exchange Server Analyzer feststellt, dass der Wert für szExcludeDirs nicht den Pfad enthält, der dem IFS-Laufwerk entspricht, wird eine Warnung angezeigt.

eTrust Antivirus ist ein Antivirenprogramm, das Überprüfungen auf der Dateiebene ausführt. Um die auf Ihrem Exchange Server-Computer installierte Version von eTrust Antivirus zu bestimmen, gehen Sie folgendermaßen vor:

  1. Navigieren Sie zu Start | Programme | eTrust Antivirus, und klicken Sie dann auf eTrust Antivirus, um die Anwendung zu starten.

  2. Klicken Sie im Anwendungsmenü von eTrust Antivirus auf Hilfe und anschließend auf Info zu eTrust Antivirus.

  3. Prüfen Sie das Feld Produktversion, um die Version von eTrust Antivirus zu bestimmen.

Die folgenden Probleme können auftreten, wenn Sie Antivirusprogramme auf Dateiebene auf einem Exchange Server-Computer verwenden:

  • Antivirusprüfprogramme auf Dateiebene prüfen eine Datei bei Verwendung oder in festgelegten Intervallen. Sie können u. U. eine Exchange-Protokoll- oder Datenbankdatei sperren oder isolieren, während Exchange versucht, die Datei zu verwenden. Dies kann einen schwerwiegenden Fehler in Exchange Server verursachen und zu Datenbankfehlern führen.

  • Weitere Probleme können beim Prüfen des Laufwerks auftreten, das durch das IFS (Installable File System, normalerweise Laufwerk M) mit Virenprüfsoftware auf Dateiebene dargestellt wird.

Ungachtet des verwendeten Antivirusprogramm auf der Dateiebene sollten Sie immer die folgenden Dateien und Ordner von der Virenprüfung auf Dateiebene ausschließen:

  • EML-, EDB-, STM-, LOG-, DAT- und CHK-Dateien.

  • Das durch IFS dargestellte Exchange Server-Laufwerk. In der Standardeinstellung ist dies Laufwerk M.

  • Exchange-Datenbanken und -protokolldateien. In der Standardeinstellung befinden sich diese im Ordner Exchsrvr\Mdbdata.

  • Exchange MTA-Dateien im Ordner Exchsrvr\Mtadata.

  • Weitere Protokolldateien wie z. B. die Datei Exchsrvr\server_name.log.

  • Der Ordner Exchsrvr\Mailroot des virtuellen Servers.

  • Der Arbeitsordner, in dem temporäre Streaming-Dateien gespeichert werden, die zur Nachrichtenkonvertierung verwendet werden. Als Standard befindet sich dieser Ordner unter \Exchsrvr\MDBData. Sie können aber den Speicherort konfigurieren.

  • Der temporäre Ordner, der mit Offlinewartungstools wie z. B. Eseutil.exe verwendet wird. In der Standardeinstellung ist dieser Ordner der Speicherort, aus dem die EXE-Datei ausgeführt wird. Sie können den Speicherort jedoch beim Ausführen des Tools konfigurieren.

  • Standortreplikationsdienst (SRS)-Dateien im Ordner Exchsrvr\Srsdata.

  • Microsoft-Internetinformationsdienste-(IIS)-Systemdateien im Ordner %SystemRoot%\System32\Inetsrv.

  • IIS-Arbeitsdateien im Ordner %SystemRoot%\IIS für temporär komprimierte Dateien.

So beheben Sie diese Warnmeldung

  1. Schließen Sie mithilfe der eTrust Antivirus-Benutzerschnittstelle die o. a. Ordner und Dateien von der Antivirusprüfung auf Dateiebene aus.

  2. Besuchen Sie die Website von Computer Associates eTrust Antivirus (http://www3.ca.com/Solutions/Product.asp?ID=156), um aktuelle Informationen zum Verwenden von eTrust Antivirus auf einem Exchange Server-Computer zu erhalten.

    Hinweis:
    Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.

Weitere Informationen zum Verwenden von Antivirus-Software mit Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 328841, „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie bei den Exchange-Partnern: Antivirus-Website (http://go.microsoft.com/fwlink/?LinkId=16226).

Weitere Informationen zu Problemen, die beim Prüfen des IFS-Laufwerks auftreten können, finden Sie in den folgenden Artikeln der Knowledge Base:

  • 298924, „XADM: Durch eine Sicherung bzw. Überprüfung des Laufwerks „M" von Exchange 2000 verursachte Probleme" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, „XADM: C1041737 Err Msg Displayed When You Mount Databases" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608).

  • 299046, „XADM: Kalenderelemente verschwinden aus Benutzerordnern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: Exchange-IFS-Pfad wurde nicht von der Echtzeitprüfung ausgeschlossen
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest die folgenden Registrierungseinträge, um eine Liste der Verzeichnisse abzurufen, die von der Echtzeit-Antivirusprüfung auf Dateiebene in eTrust Antivirus von Computer Associates ausgeschlossen sind:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

Exchange Server Analyzer liest zudem den folgenden Registrierungseintrag, um den Laufwerksbuchstaben abzurufen, der das IFS-Laufwerk (Installable File System) von Exchange darstellt:

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

Unter Exchange 2000 Server ist der Standardlaufwerksbuchstabe M. In der Standardeinstellung ist das IFS-Laufwerk in Exchange Server 2003 deaktiviert.

Wenn Exchange Server Analyzer feststellt, dass der Wert für szExcludeDirs nicht den Pfad enthält, der dem IFS-Laufwerk entspricht, wird eine Warnung angezeigt.

eTrust Antivirus ist ein Antivirusprogramm, das Überprüfungen auf der Dateiebene ausführt. Um die auf Ihrem Exchange Server-Computer installierte Version von eTrust Antivirus zu bestimmen, gehen Sie folgendermaßen vor:

  1. Navigieren Sie zu Start | Programme | eTrust Antivirus, und klicken Sie dann auf eTrust Antivirus, um die Anwendung zu starten.

  2. Klicken Sie im Anwendungsmenü von eTrust Antivirus auf Hilfe und anschließend auf Info zu eTrust Antivirus.

  3. Prüfen Sie das Feld Produktversion, um die Version von eTrust Antivirus zu bestimmen.

Die folgenden Probleme können auftreten, wenn Sie Antivirusprogramme auf Dateiebene auf einem Exchange Server-Computer verwenden:

  • Antivirusprüfprogramme auf Dateiebene prüfen eine Datei bei Verwendung oder in festgelegten Intervallen. Sie können u. U. eine Exchange-Protokoll- oder Datenbankdatei sperren oder isolieren, während Exchange versucht, die Datei zu verwenden. Dies kann einen schwerwiegenden Fehler in Exchange Server verursachen und zu Datenbankfehlern führen.

  • Weitere Probleme können auftreten, wenn Sie mit Antivirussoftware auf Dateiebene das Laufwerk prüfen, das durch das IFS (typischerweise Laufwerk M) dargestellt wird.

Ungeachtet des verwendeten Antivirenprogramms auf der Dateiebene sollten Sie immer die folgenden Dateien und Ordner von der Virusprüfung auf Dateiebene ausschließen:

  • EML-, EDB-, STM-, LOG-, DAT- und CHK-Dateien.

  • Das durch IFS dargestellte Exchange Server-Laufwerk. In der Standardeinstellung ist dies Laufwerk M.

  • Exchange-Datenbanken und -Protokolldateien. In der Standardeinstellung befinden sich diese im Ordner Exchsrvr\Mdbdata.

  • Exchange MTA-Dateien im Ordner Exchsrvr\Mtadata.

  • Weitere Protokolldateien wie z. B. die Datei Exchsrvr\server_name.log.

  • Der Ordner Exchsrvr\Mailroot des virtuellen Servers.

  • Der Arbeitsordner, in dem temporäre Streaming-Dateien gespeichert werden, die zur Nachrichtenkonvertierung verwendet werden. Als Standard befindet sich dieser Ordner unter \Exchsrvr\MDBData. Sie können aber den Speicherort konfigurieren.

  • Der temporäre Ordner, der mit Offlinewartungstools wie z. B. Eseutil.exe verwendet wird. In der Standardeinstellung ist dieser Ordner der Speicherort, aus dem die EXE-Datei ausgeführt wird. Sie können den Speicherort jedoch beim Ausführen des Tools konfigurieren.

  • Standortreplikationsdienst-Dateien (SRS-Dateien) im Ordner Exchsrvr\Srsdata.

  • Microsoft-Internetinformationsdienste-(IIS)-Systemdateien im Ordner %SystemRoot%\System32\Inetsrv.

  • IIS-Arbeitsdateien im Ordner %SystemRoot%\IIS für temporär komprimierte Dateien.

So beheben Sie diese Warnmeldung

  1. Schließen Sie mithilfe der eTrust Antivirus-Benutzerschnittstelle die o. a. Ordner und Dateien von der Antivirusprüfung auf Dateiebene aus.

  2. Besuchen Sie die Website von CA eTrust Antivirus (http://www3.ca.com/Solutions/Product.asp?ID=156), um aktuelle Informationen zum Verwenden von eTrust Antivirus auf einem Exchange Server-Computer zu erhalten.

    Hinweis:
    Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.

Weitere Informationen zum Verwenden von Antivirus-Software mit Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 328841, „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie bei den Exchange-Partnern: Antivirus-Website (http://go.microsoft.com/fwlink/?LinkId=16226).

Weitere Informationen zu Problemen, die beim Prüfen des IFS-Laufwerks auftreten können, finden Sie in den folgenden Artikeln der Knowledge Base:

  • 298924, „XADM: Durch eine Sicherung bzw. Überprüfung des Laufwerks „M" von Exchange 2000 verursachte Probleme" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, „XADM: C1041737 Err Msg Displayed When You Mount Databases" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608).

  • 299046, „XADM: Kalenderelemente verschwinden aus Benutzerordnern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: Die Echtzeitprüfung ist so festgelegt, dass alle Dateien unabhängig von ihrer Erweiterung geprüft werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2006-04-21

Microsoft® Exchange Server Analyzer liest die folgenden Registrierungseinträge, um eine Liste der Dateinamenerweiterungen zu erhalten, die von der Echtzeit-Antivirus-Prüfung auf Dateiebene in eTrust Antivirus von Computer Associates ausgeschlossen sind:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\dwFileFilterType

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\dwFileFilterType

Wenn Exchange Server Analyzer feststellt, dass der Wert für dwFileFilterType für die Überprüfung sämtlicher Dateien unabhängig von der Dateinamenerweiterung konfiguriert ist, wird ein Fehler angezeigt.

eTrust Antivirus ist ein Antivirusprogramm, das Überprüfungen auf Dateiebene ausführt. Um die auf dem Exchange Server-Computer installierte Version von eTrust Antivirus zu bestimmen, gehen Sie folgendermaßen vor:

  1. Navigieren Sie zu Start | Programme | eTrust Antivirus, und klicken Sie dann auf eTrust Antivirus, um die Anwendung zu starten.

  2. Klicken Sie im Anwendungsmenü von eTrust Antivirus auf Hilfe und anschließend auf Info zu eTrust Antivirus.

  3. Überprüfen Sie das Feld Produktversion, um die Version von eTrust Antivirus zu bestimmen.

Die folgenden Probleme können u. U. auftreten, wenn Sie Antivirusprogramme auf Dateiebene auf einem Exchange Server-Computer verwenden:

  • Antivirusprüfprogramme auf Dateiebene prüfen eine Datei bei Verwendung oder in festgelegten Intervallen. Sie können u. U. eine Exchange-Protokoll- oder Datenbankdatei sperren oder isolieren, während Exchange versucht, die Datei zu verwenden. Dies kann einen schwerwiegenden Fehler in Exchange Server verursachen und zu Datenbankfehlern führen.

  • Weitere Probleme können auftreten, wenn das durch das IFS (Installable File System, i. d. R. Laufwerk M) dargestellte Laufwerk mit Virenprüfsoftware auf Dateiebene überprüft wird.

Ungeachtet des verwendeten Antivirusprogramms auf Dateiebene sollten Sie immer die folgenden Dateien und Ordner von der Virusprüfung auf Dateiebene ausschließen:

  • EML-, EDB-, STM-, LOG-, DAT- und CHK-Dateien.

  • Das durch IFS dargestellte Exchange Server-Laufwerk. In der Standardeinstellung ist dies Laufwerk M.

  • Exchange-Datenbanken und -Protokolldateien. In der Standardeinstellung befinden sich diese im Ordner Exchsrvr\Mdbdata.

  • Exchange MTA-Dateien im Ordner Exchsrvr\Mtadata.

  • Weitere Protokolldateien wie z. B. die Datei Exchsrvr\server_name.log.

  • Der Ordner Exchsrvr\Mailroot des virtuellen Servers.

  • Der Arbeitsordner, in dem temporäre Streaming-Dateien gespeichert werden, die zur Nachrichtenkonvertierung verwendet werden. Als Standard befindet sich dieser Ordner unter \Exchsrvr\MDBData. Sie können aber den Speicherort konfigurieren.

  • Der temporäre Ordner, der von Offlinewartungstools, z. B. Eseutil.exe, verwendet wird. In der Standardeinstellung ist dieser Ordner der Speicherort, von dem aus die EXE-Datei ausgeführt wird. Sie können den Speicherort jedoch beim Ausführen des Tools konfigurieren.

  • Standortreplikationsdienst-Dateien (SRS-Dateien) im Ordner Exchsrvr\Srsdata.

  • Microsoft-Internetinformationsdienste-(IIS)-Systemdateien im Ordner %SystemRoot%\System32\Inetsrv.

  • IIS-Arbeitsdateien im Ordner %SystemRoot%\IIS für temporär komprimierte Dateien.

So beheben Sie diese Warnmeldung

  1. Schließen Sie mithilfe der eTrust Antivirus-Benutzerschnittstelle die aufgeführten Ordner und Dateien von der Antivirusprüfung auf Dateiebene aus.

  2. Besuchen Sie die Website von CA eTrust Antivirus (http://www3.ca.com/Solutions/Product.asp?ID=156), um aktuelle Informationen zum Verwenden von eTrust Antivirus auf einem Computer mit Exchange Server zu erhalten.

    Hinweis:
    Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.

Weitere Informationen zum Verwenden von Antivirus-Software mit Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 328841, „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie auf der Exchange Partners: Antivirus-Website (http://go.microsoft.com/fwlink/?LinkId=16226).

Weitere Informationen zu Problemen, die beim Prüfen des IFS-Laufwerks auftreten können, finden Sie in den folgenden Artikeln der Knowledge Base:

  • 298924, „XADM: Durch eine Sicherung bzw. Überprüfung des Laufwerks „M" von Exchange 2000 verursachte Probleme" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, „XADM:C1041737 Err Msg Displayed When You Mount Databases" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046, „XADM: Kalenderelemente verschwinden aus Benutzerordnern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: Das Laufwerk mit der Speichergruppe wurde nicht aus der manuellen Auftragsprüfung ausgeschlossen
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest die folgenden Registrierungseinträge, um eine Liste der Verzeichnisse abzurufen, die von der manuellen Antivirusprüfung auf Dateiebene in eTrust Antivirus von Computer Associates ausgeschlossen sind:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

Exchange Server Analyzer liest auch den Wert für das Attribut MsExchESEParamSystemPath im Active Directory®-Verzeichnisdienst. Hierbei handelt es sich um ein Speichergruppenattribut, das dem Speicherort für die Exchange-Systemprotokolldatei entspricht.

Wenn Exchange Server Analyzer feststellt, dass der Wert für szExcludeDirs nicht den Pfad enthält, der dem Speicherort der Exchange-Systemprotokolldatei entspricht, wird eine Warnung angezeigt.

eTrust Antivirus ist ein Antivirusprogramm, das Überprüfungen auf der Dateiebene ausführt. Um die auf Ihrem Exchange Server-Computer installierte Version von eTrust Antivirus zu bestimmen, gehen Sie folgendermaßen vor:

  1. Navigieren Sie zu Start | Programme | eTrust Antivirus, und klicken Sie dann auf eTrust Antivirus, um die Anwendung zu starten.

  2. Klicken Sie im Anwendungsmenü von eTrust Antivirus auf Hilfe und anschließend auf Info zu eTrust Antivirus.

  3. Überprüfen Sie das Feld Produktversion, um die Version von eTrust Antivirus zu bestimmen.

Wenn Sie Antivirus-Programme auf Dateiebene auf einem Exchange Server-Computer verwenden, können die folgenden Probleme auftreten:

  • Antivirusprüfprogramme auf Dateiebene prüfen eine Datei bei Verwendung oder in festgelegten Intervallen. Sie können u. U. eine Exchange-Protokoll- oder Datenbankdatei sperren oder isolieren, während Exchange versucht, die Datei zu verwenden. Dies kann einen schwerwiegenden Fehler in Exchange Server verursachen und zu Datenbankfehlern führen.

  • Weitere Probleme können auftreten, wenn das durch das IFS (Installable File System, i. d. R. Laufwerk M) dargestellte Laufwerk mit Virenprüfsoftware auf Dateiebene überprüft wird.

Ungeachtet des verwendeten Antivirusprogramms auf Dateiebene sollten Sie immer die folgenden Dateien und Ordner von der Virusprüfung auf Dateiebene ausschließen:

  • EML-, EDB-, STM-, LOG-, DAT- und CHK-Dateien.

  • Das durch IFS dargestellte Exchange Server-Laufwerk. In der Standardeinstellung ist dies Laufwerk M.

  • Exchange-Datenbanken und -Protokolldateien. In der Standardeinstellung befinden sich diese im Ordner Exchsrvr\Mdbdata.

  • Exchange MTA-Dateien im Ordner Exchsrvr\Mtadata.

  • Weitere Protokolldateien, z. B. die Datei Exchsrvr\server_name.log.

  • Der Ordner Exchsrvr\Mailroot des virtuellen Servers.

  • Der Arbeitsordner, in dem temporäre Streaming-Dateien gespeichert werden, die zur Nachrichtenkonvertierung verwendet werden. In der Standardeinstellung befindet sich dieser Ordner unter \Exchsrvr\MDBData. Sie können den Speicherort jedoch auch konfigurieren.

  • Der temporäre Ordner, der von Offlinewartungstools, z. B. Eseutil.exe, verwendet wird. In der Standardeinstellung ist dieser Ordner der Speicherort, von dem aus die EXE-Datei ausgeführt wird. Sie können den Speicherort jedoch beim Ausführen des Tools konfigurieren.

  • Standortreplikationsdienstdateien (SRS-Dateien) im Ordner Exchsrvr\Srsdata.

  • Microsoft-Internetinformationsdienste-(IIS)-Systemdateien im Ordner %SystemRoot%\System32\Inetsrv.

  • IIS-Arbeitsdateien im Ordner %SystemRoot%\IIS für temporär komprimierte Dateien.

So beheben Sie dieses Problem

  1. Schließen Sie mithilfe der eTrust Antivirus-Benutzerschnittstelle die oben aufgeführten Ordner und Dateien von der Virenprüfung auf Dateiebene aus.

  2. Besuchen Sie die Website von Computer Associates eTrust Antivirus (http://www3.ca.com/Solutions/Product.asp?ID=156), um aktuelle Informationen zum Verwenden von eTrust Antivirus auf einem Exchange Server-Computer zu erhalten.

    Hinweis:
    Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.

Weitere Informationen zum Verwenden von Antivirus-Software mit Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 328841, „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

  • Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie auf der Exchange Partners: Antivirus-Website (http://go.microsoft.com/fwlink/?LinkId=16226).

Weitere Informationen zu Problemen, die beim Prüfen des IFS-Laufwerks auftreten können, finden Sie in den folgenden Artikeln der Knowledge Base:

  • 298924, „XADM: Durch eine Sicherung bzw. Überprüfung des Laufwerks „M" von Exchange 2000 verursachte Probleme" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, „XADM: C1041737 Err Msg Displayed When You Mount Databases" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608).

  • 299046, „XADM: Kalenderelemente verschwinden aus Benutzerordnern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust: Speichergruppenlaufwerk wurde nicht von der Echtzeitprüfung ausgeschlossen
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest die folgenden Registrierungseinträge, um eine Liste der Verzeichnisse abzurufen, die von der Echtzeit-Antivirenprüfung auf Dateiebene in eTrust Antivirus von Computer Associates ausgeschlossen sind:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

Exchange Server Analyzer fragt auch den Wert für das Attribut MsExchESEParamSystemPath im Active Directory®-Verzeichnisdienst ab. Hierbei handelt es sich um ein Speichergruppenattribut, das dem Speicherort der Exchange-Systemdatendateien entspricht.

Wenn Exchange Server Analyzer feststellt, dass der Wert für szExcludeDirs nicht den Pfad enthält, der dem Speicherort der Exchange-Systemdatendateien entspricht, wird eine Warnung angezeigt.

eTrust Antivirus ist ein Antivirusprogramm, das Überprüfungen auf der Dateiebene ausführt. Gehen Sie folgendermaßen vor, um die auf dem Exchange Server-Computer installierte Version von eTrust Antivirus zu bestimmen:

  1. Navigieren Sie zu Start | Programme | eTrust Antivirus, und klicken Sie dann auf eTrust Antivirus, um die Anwendung zu starten.

  2. Klicken Sie im Anwendungsmenü von eTrust Antivirus auf Hilfe und anschließend auf Info zu eTrust Antivirus.

  3. Prüfen Sie das Feld Produktversion, um die Version von eTrust Antivirus zu bestimmen.

Wenn Sie Antivirusprogramme auf Dateiebene auf einem Exchange Server-Computer verwenden, können die folgenden Probleme auftreten:

  • Antivirusprüfprogramme auf Dateiebene prüfen eine Datei bei Verwendung oder in festgelegten Intervallen. Sie können u. U. eine Exchange-Protokoll- oder Datenbankdatei sperren oder isolieren, während Exchange versucht, die Datei zu verwenden. Dies kann einen schwerwiegenden Fehler in Exchange Server verursachen und zu Datenbankfehlern führen.

  • Weitere Probleme können beim Prüfen des Laufwerks auftreten, das durch das IFS (Installable File System, normalerweise Laufwerk M) mit Virenprüfsoftware auf Dateiebene dargestellt wird.

Ungeachtet des verwendeten Antivirenprogramms auf der Dateiebene sollten Sie immer die folgenden Dateien und Ordner von der Virusprüfung auf Dateiebene ausschließen:

  • EML-, EDB-, STM-, LOG-, DAT- und CHK-Dateien.

  • Das durch IFS dargestellte Exchange Server-Laufwerk. In der Standardeinstellung ist dies Laufwerk M.

  • Exchange-Datenbanken und -Protokolldateien. In der Standardeinstellung befinden sich diese im Ordner Exchsrvr\Mdbdata.

  • Exchange MTA-Dateien im Ordner Exchsrvr\Mtadata.

  • Weitere Protokolldateien, z. B. die Datei Exchsrvr\server_name.log.

  • Der Ordner Exchsrvr\Mailroot des virtuellen Servers.

  • Der Arbeitsordner, in dem temporäre Streamingdateien gespeichert werden, die zur Nachrichtenkonvertierung verwendet werden. In der Standardeinstellung befindet sich dieser Ordner unter \Exchsrvr\MDBData. Sie können den Speicherort jedoch auch konfigurieren.

  • Der temporäre Ordner, der von Offlinewartungstools, z. B. Eseutil.exe, verwendet wird. In der Standardeinstellung ist dieser Ordner der Speicherort, von dem aus die EXE-Datei ausgeführt wird. Sie können den Speicherort jedoch beim Ausführen des Tools konfigurieren.

  • Standortreplikationsdienst-Dateien (SRS-Dateien) im Ordner Exchsrvr\Srsdata.

  • Microsoft-Internetinformationsdienste-(IIS)-Systemdateien im Ordner %SystemRoot%\System32\Inetsrv.

  • IIS-Arbeitsdateien im Ordner %SystemRoot%\IIS für temporär komprimierte Dateien.

So beheben Sie diese Warnmeldung

  1. Schließen Sie mithilfe der eTrust Antivirus-Benutzerschnittstelle die o. a. Ordner und Dateien von der Antivirusprüfung auf Dateiebene aus.

  2. Besuchen Sie die Website von CA eTrust Antivirus (http://www3.ca.com/Solutions/Product.asp?ID=156), um aktuelle Informationen zum Verwenden von eTrust Antivirus auf einem Exchange Server-Computer zu erhalten.

    Hinweis:
    Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.

Weitere Informationen zum Verwenden von Antivirus-Software mit Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 328841, „XADM: Exchange und Antivirus-Software" (http://support.microsoft.com/kb/328841/DE/)

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" unter http://support.microsoft.com/kb/823166/de&kbid=823166.

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://support.microsoft.com/default.aspx?scid=kb;de-de;Q245822)

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie bei den Exchange-Partnern: Antivirus-Website (http://go.microsoft.com/fwlink/?LinkId=16226).

Weitere Informationen zu Problemen, die beim Prüfen des IFS-Laufwerks auftreten können, finden Sie in den folgenden Artikeln der Knowledge Base:

  • 298924, „XADM: Durch eine Sicherung bzw. Überprüfung des Laufwerks "M" von Exchange 2000 verursachte Probleme" unter http://support.microsoft.com/kb/298924/de.

  • 300608, „XADM: C1041737 Err Msg Displayed When You Mount Databases" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608).

  • 299046, „XADM: Kalenderelemente verschwinden aus Benutzerordnern" (http://support.microsoft.com/kb/299046/DE/)


CA eTrust: Exchange-Vorgang wurde nicht von der Echtzeitprüfung ausgeschlossen
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest die folgenden Registrierungseinträge, um eine Liste der Prozesse abzurufen, die von der Echtzeit-Antivirusprüfung auf Dateiebene in eTrust Antivirus von Computer Associates ausgeschlossen sind:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\RealTime\szExcludeProcessNames

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeProcessNames

Wenn Exchange Server Analyzer feststellt, dass der Wert für szExcludeProcessNames nicht STORE.EXE, EMSMTA.EXE und MAD.EXE enthält, wird eine Warnung angezeigt.

Es wird empfohlen, dass Sie den Microsoft Exchange-Informationsspeicherprozess (Store.exe), den Exchange MTA-Prozess (Emsmta.exe) oder den Systemaufsichtsprozess (Mad.exe) nicht mit einem Antivirenprüfprogramm auf Dateiebene überprüfen, solange diese Vorgänge ausgeführt werden.

eTrust Antivirus ist ein Antivirusprogramm, das Überprüfungen auf Dateiebene ausführt. Um die auf dem Exchange Server-Computer installierte Version von eTrust Antivirus zu bestimmen, gehen Sie folgendermaßen vor:

  1. Navigieren Sie zu Start | Programme | eTrust Antivirus, und klicken Sie dann auf eTrust Antivirus, um die Anwendung zu starten.

  2. Klicken Sie im Anwendungsmenü von eTrust Antivirus auf Hilfe und anschließend auf Info zu eTrust Antivirus.

  3. Überprüfen Sie das Feld Produktversion, um die Version von eTrust Antivirus zu bestimmen.

Wenn Sie Antivirusprogramme auf Dateiebene auf einem Exchange Server-Computer verwenden, können die folgenden Probleme auftreten:

  • Antivirusprüfprogramme auf Dateiebene prüfen eine Datei bei Verwendung oder in festgelegten Intervallen. Sie können u. U. eine Exchange-Protokoll- oder Datenbankdatei sperren oder isolieren, während Exchange versucht, die Datei zu verwenden. Dies kann einen schwerwiegenden Fehler in Exchange Server verursachen und zu Datenbankfehlern führen.

  • Weitere Probleme können auftreten, wenn Sie mit Antivirussoftware auf Dateiebene das Laufwerk prüfen, das durch das IFS (typischerweise Laufwerk M) dargestellt wird.

Ungeachtet des verwendeten Antivirusprogramms auf Dateiebene sollten Sie immer die folgenden Dateien und Ordner von der Virusprüfung auf Dateiebene ausschließen:

  • EML-, EDB-, STM-, LOG-, DAT- und CHK-Dateien.

  • Das durch IFS dargestellte Exchange Server-Laufwerk. In der Standardeinstellung ist dies Laufwerk M.

  • Exchange-Datenbanken und -Protokolldateien. In der Standardeinstellung befinden sich diese im Ordner Exchsrvr\Mdbdata.

  • Exchange MTA-Dateien im Ordner Exchsrvr\Mtadata.

  • Weitere Protokolldateien wie z. B. die Datei Exchsrvr\server_name.log.

  • Der Ordner Exchsrvr\Mailroot des virtuellen Servers.

  • Der Arbeitsordner, in dem temporäre Streaming-Dateien gespeichert werden, die zur Nachrichtenkonvertierung verwendet werden. Als Standard befindet sich dieser Ordner unter \Exchsrvr\MDBData. Sie können aber den Speicherort konfigurieren.

  • Der temporäre Ordner, der von Offlinewartungstools, z. B. Eseutil.exe, verwendet wird. In der Standardeinstellung ist dieser Ordner der Speicherort, von dem aus die EXE-Datei ausgeführt wird. Sie können den Speicherort jedoch beim Ausführen des Tools konfigurieren.

  • Standortreplikationsdienst-(SRS)-Dateien im Ordner Exchsrvr\Srsdata.

  • Microsoft-Internetinformationsdienste-(IIS)-Systemdateien im Ordner %SystemRoot%\System32\Inetsrv.

  • IIS-Arbeitsdateien im Ordner %SystemRoot%\IIS für temporär komprimierte Dateien.

So beheben Sie diese Warnmeldung

  1. Schließen Sie mithilfe der eTrust Antivirus-Benutzerschnittstelle die o. a. Ordner und Dateien von der Antivirusprüfung auf Dateiebene aus.

  2. Besuchen Sie die Website von Computer Associates eTrust Antivirus (http://www3.ca.com/Solutions/Product.asp?ID=156), um aktuelle Informationen zum Verwenden von eTrust Antivirus auf einem Exchange Server-Computer zu erhalten.

    Hinweis:
    Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.

Weitere Informationen zum Verwenden von Antivirus-Software mit Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 328841, „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie auf der Exchange Partners: Antivirus-Website (http://go.microsoft.com/fwlink/?LinkId=16226).

Weitere Informationen zu Problemen, die beim Prüfen des IFS-Laufwerks auftreten können, finden Sie in den folgenden Artikeln der Knowledge Base:

  • 298924, „XADM: Durch eine Sicherung bzw. Überprüfung des Laufwerks „M" von Exchange 2000 verursachte Probleme" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608, „XADM: C1041737 Err Msg Displayed When You Mount Databases" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608).

  • 299046, „XADM: Kalenderelemente verschwinden aus Benutzerordnern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


Aktualisierung für Client Service Messaging Security for SMB v2.0 verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2006-02-13

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag:

HKEY_LOCAL_MACHINE\SOFTWARE\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Ein Versionswert von 6.2100 zeigt an, dass Trend Micro ScanMail Client Service Messaging Security for SMB v2.0 installiert ist.

Microsoft® Exchange Server Analyzer fragt außerdem die Microsoft Windows®-Verwaltungsinstrumentationsklasse (Windows Management Instrumentation, WMI) CIM_Datafile ab, um die installierte Version von Client Service Messaging Security for SMB Version 2.0 zu ermitteln. Wenn die Hauptbuildnummer niedriger als 1145 ist, zeigt Exchange Server Analyzer eine Warnung an.

Diese Warnung zeigt an, dass Client Server Messaging Security for SMB v2.0 auf dem Exchange-Server installiert ist und dass eine empfohlene Softwareaktualisierung verfügbar ist. Die empfohlene Aktualisierung ist Client Server Messaging Security for SMB v2.0 Patch 2 for Messaging Component. Es wird dringend empfohlen, diese Aktualisierung vorzunehmen. Sie erhöht die Gesamtleistung und Zuverlässigkeit des Servers.

So beheben Sie diese Warnung

  1. Besuchen Sie den Bereich Client Server Messaging Security for SMB im Trend Micro Update Center (http://www.trendmicro.com/download/product.asp?productid=39).

  2. Laden Sie Patch 2 herunter, und installieren Sie ihn.
Hinweis:
Die Informationen zur Website des Drittanbieters in diesem Thema werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.

Weitere Informationen zu anderen Produktaktualisierungen von Trend Micro finden Sie auf der Trend Micro Update Center-Website (http://www.trendmicro.com/download/).

Weitere Informationen zum Verwenden von Antivirussoftware mit Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 328841, „Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841).

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsofts Standpunkt zu Antiviruslösungen für Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105).

  • 245822, „Empfehlungen fu¨r die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Eine Liste mit Antivirussoftware von Drittanbietern, die fu¨r Exchange Server verfu¨gbar ist, finden Sie bei Exchange Server Partners: Antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Empfohlene Vorgehensweise: Installieren von HP Command View EVAPerf.
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-12-09

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_SCSIController ab, um den aktuellen Wert des Schlüssels Name zu bestimmen. Wenn der Wert des Schlüssels Name gleich Compaq HSV110CCL ist, gibt dies an, dass mindestens ein Datenträgervolume auf dem Server von einem HP EVA SAN (Storage Area Network) bereitgestellt wird.

Exchange Server Analyzer fragt außerdem die WMI-Klasse Win32_Service ab, um den Wert des Schlüssels Started für den Dienst HP StorageWorks Command View EVAPerf (EVSPDCS) zu bestimmen. Der Wert False gibt an, dass der Dienst nicht ausgeführt wird. Der Wert True gibt an, dass der Dienst ausgeführt wird.

Microsoft Exchange Server Analyzer zeigt eine Empfehlung mit der optimalen Methode an, wenn die folgenden Bedingungen erfüllt sind:

  • Mindestens ein Datenträgervolume auf dem Server wird von einem HP EVA SAN bereitgestellt.

  • Der Dienst HP StorageWorks Command View EVAPerf (EVSPDCS) ist nicht vorhanden bzw. wird nicht ausgeführt.

HP stellt eine kostenlose Softwareverwaltungsanwendung bereit, die zusätzliche Leistungsindikatoren für HP StorageWorks SANs bereitstellt. Administratoren können mit dieser Softwareverwaltungsanwendung die Leistung einzelner Controller und physischer Datenträger im SAN überwachen.

So führen Sie die empfohlene optimale Methode aus

  1. Um die Anwendung HP Command View EVAPerf zu downloaden, gehen Sie auf die Website HP StorageWorks Command View EVAPerf Software (http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?pnameOID=471498&locale=en_US&taskId=135&prodSeriesId=471497&prodTypeId=12169&swEnvOID=1005http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?pnameOID=471498&locale=en_US&taskId=135&prodSeriesId=471497&prodTypeId=12169&swEnvOID=1005).

    Hinweis:
    Die Informationen zur Website des Drittanbieters werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.

  2. Führen Sie nach dem Download die sich selbst entpackende ausführbare Datei aus, und folgen Sie den Anweisungen zum Installieren der Anwendung.


EMC PowerPath Service wurde unterbrochen.
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Service ab, um den Wert für den Schlüssel Started für den Dienst EMC PowerPath Service zu bestimmen. Der Wert True gibt an, dass der Dienst EMC PowerPath Service ausgeführt wird, und der Wert False gibt an, dass der Dienst EMC PowerPath Service nicht ausgeführt wird. Wenn Exchange Server Analyzer feststellt, dass für den Schlüssel Started der Wert False festgelegt ist, wird eine Warnung angezeigt.

Bei EMC PowerPath handelt es sich um eine MPIO-Software (Multipath I/O). Die Multipath-Funktion bietet Hochverfügbarkeit beim Datenzugriff. Ein Host kann auf ein externes Speichergerät über bis zu 32 Pfade zugreifen, wodurch Failover und Lastenausgleich ermöglicht werden. Multipath ist keine Funktion des Betriebssystems, sondern wird über das MPIO Driver Development Kit (DDK) bereitgestellt, das es Anbietern von Speicherlösungen ermöglicht, vollständig kompatible Multipath-Lösungen zu entwickeln.

Wenn MPIO-Software ausgeführt wird, erkennt Microsoft Windows® nur ein einziges Laufwerk, während die MPIO-Software die Verbindungen zu den verschiedenen Speichergeräten verwaltet. Wenn die MPIO-Software beendet wird, erkennt Windows alle verbundenen Speicherlaufwerke als unabhängige Laufwerke. Dies kann zu Speicherfehlern und Fehlfunktionen führen.

So starten Sie den Dienst „EMC PowerPath Service"

  1. Öffnen Sie das MMC-Snap-In Dienste.

  2. Klicken Sie mit der rechten Maustaste auf den Dienst EMC PowerPath Service, und klicken Sie dann auf Eigenschaften.

  3. Vergewissern Sie sich, dass auf der Eigenschaftenseite von EMC PowerPath Service auf der Registerkarte Allgemein für Starttyp die Option Automatisch festgelegt ist. Wenn das nicht zutrifft, klicken Sie auf Übernehmen und dann auf OK.

  4. Klicken Sie mit der rechten Maustaste auf den Dienst EMC PowerPath Service, und klicken Sie dann auf Starten.

  5. Schließen Sie das Snap-In Dienste.

Allgemeine Informationen zum Bereitstellen verschiedener Speichertechnologien unter Windows finden Sie in „Planning to Use Windows Storage Features with SANs" unter http://go.microsoft.com/fwlink/?LinkId=33626.


EMC PowerPath Version Mismatch Between Cluster Nodes
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2007-07-25

Das Tool Microsoft Exchange Analyzer liest den folgenden Registrierungseintrag, um die Version von EMC PowerPath zu bestimmen, die auf den einzelnen Knoten im Cluster installiert ist:

HKEY_LOCAL_MACHINE\SOFTWARE\EMC\PowerPath\Version

Wenn Exchange Analyzer auf dem zweiten oder folgenden Knoten im Exchange-Cluster einen Wert für Version ermittelt, der sich vom Wert für Version auf dem ersten Knoten im Exchange-Cluster unterscheidet, wird ein Fehler angezeigt.

Dieser Fehler zeigt an, dass die Knoten in diesem Exchange-Cluster nicht die gleiche Version des EMC PowerPath-Treibers ausführen. Als bewährte Methode wird empfohlen, dass alle Knoten in einem Exchange-Cluster die gleiche Version des EMC PowerPath-Treibers ausführen.

Bei EMC PowerPath handelt es sich um eine MPIO-Software (Multipath I/O). Die Multipath-Funktion bietet Hochverfügbarkeit beim Datenzugriff. Ein Host kann auf ein externes Speichergerät über bis zu 32 Pfade zugreifen, wodurch Failover und Lastenausgleich ermöglicht werden. Multipath ist keine Funktion des Betriebssystems, sondern wird über das MPIO Driver Development Kit (DDK) bereitgestellt, das es Anbietern von Speicherlösungen ermöglicht, vollständig kompatible Multipath-Lösungen zu entwickeln.

Wenn MPIO-Software ausgeführt wird, erkennt Microsoft Windows nur ein einziges Laufwerk, während die MPIO-Software die Verbindungen zu den verschiedenen Speichergeräten verwaltet. Wenn auf verschiedenen Knoten des Clusters unterschiedliche Versionen des MPIO-Treibers ausgeführt werden, können Clusterfailoverprobleme auftreten.

Zum Beheben dieses Problems müssen Sie alle Knoten auf die gleiche Version des EMC PowerPath-Treibers aktualisieren.

Weitere Informationen

Weitere Informationen zum Bereitstellen verschiedener Speichertechnologien unter Windows finden Sie in "Planning to Use Windows Storage Features with SANs" unter http://go.microsoft.com/fwlink/?LinkId=33626.


Der FC-Porttreiber von Emulex wurde seit mehr als zwei Jahren nicht aktualisiert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2006-04-19

Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_SCSIController ab, um zu ermitteln, ob für den Schlüssel DriverName ein Wert festgelegt wurde. Microsoft Exchange Server Analyzer ermittelt, ob die folgenden Bedingungen gegeben sind:

  • Der Emulex FC Port-Treiber ist auf dem Exchange-Server installiert.

  • Die aktuelle Version des Emulex FC Port-Treibers ist auf dem Exchange-Server installiert.

  • Der Emulex FC Port-Treiber wurde in den vergangenen zwei Jahren aktualisiert.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel DriverName seit mehr als zwei Jahren nicht aktualisiert wurde, zeigt Exchange Server Analyzer eine Warnung an.

Der Emulex FC Port-Treiber stellt entweder ausschließlich SCSI-Funktionen oder gleichzeitig SCSI- und IP-Funktionen in einem einzelnen HBA (Host Bus Adapter) oder mehreren HBAs bereit. Der FC Port-Treiber unterstützt FC-AL-Topologien (Fibre Channel Arbitrated Loop), Point-to-Point-Topologien und Fabric-Topologien. Der FC Port-Treiber wurde für spezielle Anwendungen entworfen, für die hostbasierte LUN-Zuordnungen (Logical Unit Number) oder dauerhafte Bindungen erforderlich sind.

Informationen zum Aktualisieren des Emulex FC Port-Treibers finden Sie unter Downloads and Manuals for Windows (http://www.emulex.com/ts/docfc/winframe.htm). Informationen zu speziellen OEM-Treibern finden Sie auf der Website für Emulex-Software und -Dokumentation (http://www.emulex.com/ts/index.html).

Hinweis:
Die Informationen zur Website des Drittanbieters in diesem Thema werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.


Der SCSIport Miniport-Treiber von Emulex wurde seit mehr als zwei Jahren nicht aktualisiert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2006-06-14

Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation, Windows®-Verwaltungsinstrumentation) Win32_SCSIController ab, um zu ermitteln, ob für den Schlüssel DriverName ein Wert festgelegt wurde. Microsoft Exchange Server Analyzer ermittelt, ob die folgenden Bedingungen gegeben sind:

  • Der SCSIport Miniport-Treiber von Emulex ist auf dem Exchange-Server installiert.

  • Die aktuelle Version des SCSIport Miniport-Treiber von Emulex ist auf dem Exchange-Server installiert.

  • Der SCSIport Miniport-Treiber von Emulex wurde in den vergangenen zwei Jahren aktualisiert.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel DriverName seit mehr als zwei Jahren nicht aktualisiert wurde, zeigt Exchange Server Analyzer eine Warnung an.

Der SCSIport Miniport-Treiber unterstützt SCSI-Funktionen über FC-AL-Topologien (Fibre Channel Arbitrated Loop), Point-To-Point-Topologien und Fabric-Topologien.

Informationen zum Aktualisieren des SCSIport Miniport-Treibers von Emulex finden Sie unter "Downloads and Manuals for Windows" (http://www.emulex.com/ts/docfc/winframe.htm). Informationen zu besonderen OEM-Treibern finden Sie unter "OEM Software and Documentation" (http://www.emulex.com/ts/index.html).

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.


Der Storport Miniport-Treiber von Emulex wurde seit mehr als zwei Jahren nicht aktualisiert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2006-06-14

Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_SCSIController ab, um zu ermitteln, ob für den Schlüssel DriverName ein Wert festgelegt wurde. Microsoft Exchange Server Analyzer ermittelt, ob die folgenden Bedingungen gegeben sind:

  • Der Storport Miniport-Treiber von Emulex ist auf dem Exchange-Server installiert.

  • Die aktuelle Version des Storport Miniport-Treibers von Emulex ist auf dem Exchange-Server installiert.

  • Der Storport Miniport-Treiber von Emulex wurde in den vergangenen zwei Jahren aktualisiert.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel DriverName seit mehr als zwei Jahren nicht aktualisiert wurde, zeigt Exchange Server Analyzer eine Warnung an.

Der Storport Miniport-Treiber von Emulex optimiert die Leistung und Verwaltung von SANs (Storage Area Networks) und hardwarebasierten Datenträgerarrays. Der Storport Miniport-Treiber von Emulex unterstützt FC-AL-Topologien (Fibre Channel Arbitrated Loop), Point-To-Point-Topologien und Fabric-Topologien.

Informationen zur Aktualisierung des Storport Miniport-Treibers von Emulex finden Sie unter Downloads and Manuals for Windows (http://www.emulex.com/ts/docfc/winframe.htm). Informationen zu besonderen OEM-Treibern finden Sie unter "OEM Software and Documentation" (http://www.emulex.com/ts/index.html).

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.


Hohe CPU-Auslastung durch einen Vorgang außerhalb von Exchange
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

  • Microsoft® Exchange Server Analyzer hat festgestellt, dass ein Prozess außerhalb von Exchange Server die CPU derzeit zu mehr als 20 Prozent auslastet. Wenn ein Vorgang, der nichts mit Exchange-Server zu tun hat, mehr als 20 % der verfügbaren Prozessorleistung verbraucht, wird ein Fehler angezeigt.

  • Es wird empfohlen, dass die Server, auf denen Exchange Server ausgeführt wird, möglichst für Exchange Server dediziert sind und dass möglichst wenige Anwendungen oder Dienste außerhalb von Exchange ausgeführt werden.

So beheben Sie diesen Fehler

  • Wenn ein anderer Prozess den größten Teil der Prozessorauslastung verursacht, führen Sie eine der folgenden Optionen aus:

    • Deaktivieren Sie den Prozess und kontrollieren Sie, ob das Problem beseitigt ist.

    • Verschieben Sie diesen Prozess möglichenfalls auf einen anderen Server.

    • Stellen Sie sicher, dass der Prozess ordnungsgemäß konfiguriert ist, und achten Sie auf Updates von Microsoft und dem Prozessanbieter, die sich mit diesem Problem befassen.

    • Deinstallieren Sie den Prozess, wenn Sie ihn nicht benötigen.

  • Wenn der Prozess nicht verschoben oder behoben werden kann, sollte der Server neu skaliert werden, um für Prozesse, die nicht mit Exchange Server zu tun haben, zusätzliche Kapazität bereitzustellen. Sie sollten im Zuge dieser neuskalierung möglicherweise Benutzer auf einen anderen Exchange-Server verlegen.


HP/Compaq Secure Path Service wird beendet.
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_Service ab, um zu ermitteln, ob der Dienst HP/Compaq Secure Path ausgeführt wird. Wenn Exchange Server Analyzer feststellt, dass der Dienst HP/Compaq Secure Path nicht ausgeführt wird, wird eine Warnung angezeigt.

Bei dem Dienst HP/Compaq Secure Path handelt es sich um Multipath I/O-Software (MPIO). Die Multipath-Funktion bietet Hochverfügbarkeit beim Datenzugriff. Ein Host kann auf ein externes Speichergerät über bis zu 32 Pfade zugreifen, wodurch Failover und Lastenausgleich ermöglicht werden. Multipath ist keine Funktion des Betriebssystems, sondern wird über das MPIO Driver Development Kit (DDK) bereitgestellt, das es Anbietern von Speicherlösungen ermöglicht, vollständig kompatible Multipath-Lösungen zu entwickeln.

Wenn MPIO-Software ausgeführt wird, erkennt das Windows-Betriebssystem nur ein einziges Laufwerk, während die MPIO-Software die Verbindungen zu den verschiedenen Speichergeräten verwaltet. Wenn die MPIO-Software beendet wird, erkennt Windows alle verbundenen Speicherlaufwerke als unabhängige Laufwerke. Dies kann zu Speicherfehlern und Fehlfunktionen führen.

So beheben Sie dieses Problem

  1. Öffnen Sie das MMC-Snap-In Dienste.

  2. Klicken Sie mit der rechten Maustaste auf den Dienst HP/Compaq Secure Path, und klicken Sie dann auf Eigenschaften.

  3. Vergewissern Sie sich, dass auf der Eigenschaftenseite von HP/Compaq Secure Path auf der Registerkarte Allgemein für Starttyp die Option Automatisch festgelegt ist. Wenn das nicht zutrifft, klicken Sie auf Übernehmen und dann auf OK.

  4. Klicken Sie mit der rechten Maustaste auf den Dienst HP/Compaq Secure Path, und klicken Sie dann auf Starten.

  5. Schließen Sie das Snap-In Dienste.

Allgemeine Informationen zum Bereitstellen verschiedener Speichertechnologien unter Windows finden Sie in „Planning to Use Windows Storage Features with SANs" unter http://go.microsoft.com/fwlink/?LinkId=33626.


Einfluss der Software von Drittanbietern
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer hat festgestellt, dass Sie auf Ihrem Exchange-Server Software vn Drittanbietern ausführen. Diese Drittanbietersoftware kann die Ursache für das Leistungsproblem Ihres Servers sein. Von Drittanbietern stammt unter anderem die folgende Software:

  • Antivirusprodukte auf Dateiebene

  • Exchange-Antivirussoftware für E-Mail-Nachrichten

  • Anti-Spam-Produkte

  • Faxserversoftware

  • Connector für fremde Mail oder Zusammenarbeit

  • File and Print Services

  • Connectors für mobile Geräte

So beheben Sie diesen Fehler

  • Wenn Sie vermuten, dass die Software eines Drittanbieters die Leistung von Exchange Server vermindert, deinstallieren oder deaktivieren Sie die Software des Drittanbieters, und messen Sie die Leistung von Exchange-Server.

  • Wenn Sie feststellen, dass die Software eines Drittanbieters einen Leistungsabfall bewirkt und die Software des Drittanbieters jedoch für die Serverfunktionen wichtig ist, sollten Sie in Erwägung ziehen, einen anderen Server zu reservieren, um die Belastung auf zwei Server zu verteilen.

Weitere Informationen

  • Weitere Informationen zur Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=de).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=de).


Aktualisierung der „INO_FLPY.SYS"-Version verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile ab, um die Version des Treibers für den Antivirusfilter Ino_flpy.sys von Computer Associates zu bestimmen.

Exchange Server Analyzer fragt die WMI-Klasse CIM_Datafile ab, um den Wert des Schlüssels Version für Ino_flpy.sys zu bestimmen. Anhand der Buildnummer von Version kann bestimmt werden, ob eine Softwareaktualisierung erforderlich ist. Wenn der Wert des Schlüssels Version angibt, dass die Buildnummer für die Datei Ino_flpy.sys kleiner als 5.00.6100.109 ist, wird eine Warnung angezeigt.

Eine kleinere Versionsnummer als 5.00.6100.109 gibt an, dass nicht die aktuelle Version der Datei Ino_flpy.sys auf dem Exchange Server-Computer installiert ist und dass eine aktuellere Version des Filtertreibers installiert werden muss. Eine Aktualisierung der Antiviren-Software für die Datei Ino_flpy.sys finden Sie auf der Computer Associates-Website. Es wird dringend empfohlen, dieses Softwareupdate zu installieren. Es erhöht die Gesamtleistung und Zuverlässigkeit des Exchange Server-Computers.

Wenn die Antiviren-Programme Inoculan Computer Associates eTrust Antivirus Version 6.x oder 7.x und InoculateIT Version 6.x auf einem Exchange 2000 Server- oder Exchange Server 2003-Computer installiert sind, kopiert das Setup-Programm die Dateien Ino_flpy.sys und Ino_fltr.sys mit den Filtertreibern in den Ordner %systemroot%\system32\drivers. Die Antiviren-Treiberdateien sind Treiber für den Windows NT®-Kernelmodus, mit denen die erforderlichen Antivirendienste gestartet werden. Ältere Versionen der Filtertreiber können unerwartete Ergebnisse auf den Exchange Server-Computern bewirken.

So beheben Sie diese Warnung

  1. Die aktuellen Updates der Antivirensoftware für die Datei ino_flpy.sys finden Sie auf der Computer Associates-Website unter http://supportconnectw.ca.com/premium/antivirus/downloads/nt/4.5/ildrvupdate.asp.

  2. Downloaden Sie die entsprechende aktualisierte Version von eTrust oder InoculateIT.

  3. Führen Sie eine vollständige Sicherung des Exchange Server-Computers aus, einschließlich einer Sicherung der Datei Ino_flpy.sys.

  4. Installieren Sie das aktuellste Update von eTrust oder InoculateIT.
Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Websites nicht aufrufen.

Weitere Informationen zum Verwenden von Antivirussoftware mit Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 240309, „How to Fully Disable Antivirus Software from Filtering Files" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240309)

  • 328841, „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, „Überblick über ExchangeServer 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Eine Liste mit Antivirensoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie bei den Exchange-Partnern: Antivirus-Website (http://go.microsoft.com/fwlink/?LinkId=16226).


Aktualisierung der „INO_FLPY.SYS"-Version verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) CIM_Datafile ab, um die Version des Treibers des Antivirusfilters no_fltr.sys von Computer Associates zu bestimmen.

Exchange Server Analyzer fragt die WMI-Klasse CIM_Datafile ab, um den Wert des Schlüssels Version für Ino_fltr.sys zu bestimmen. Anhand der Buildnummer von Version kann bestimmt werden, ob eine Softwareaktualisierung erforderlich ist. Wenn der Wert des Schlüssels Version angibt, dass die Buildnummer für die Datei Ino_fltr.sys kleiner als 5.00.6100.142 ist, wird eine Warnung angezeigt.

Eine kleinere Versionsnummer als 5.00.6100.142 gibt an, dass nicht die aktuellste Version der Datei Ino_fltr.sys auf dem Exchange Server-Computer installiert ist und dass eine aktuellere Version des Filtertreibers installiert werden muss. Eine Aktualisierung der Antivirussoftware für die Datei Ino_fltr.sys finden Sie auf der Website von Computer Associates. Es wird dringend empfohlen, dieses Softwareupdate zu installieren. Es erhöht die Gesamtleistung und Zuverlässigkeit des Exchange Server-Computers.

Wenn die Antiviren-Programme Inoculan Computer Associates eTrust Antivirus Version 6.x oder 7.x und InoculateIT Version 6.x auf einem Exchange 2000 Server- oder Exchange Server 2003-Computer installiert sind, kopiert das Setup-Programm die Dateien Ino_flpy.sys und Ino_fltr.sys mit den Filtertreibern in den Ordner %systemroot%\system32\drivers. Die Antivirentreiber-Filterdateien sind Treiber für den Windows NT®-Kernelmodus, mit denen die erforderlichen Antivirendienste gestartet werden. Ältere Versionen der Filtertreiber können unerwartete Ergebnisse auf den Exchange Server-Computern bewirken.

So beheben Sie diese Warnung

  1. Um die neuesten Antivirussoftware-Aktualisierungen für die Datei Ino_fltr.sys abzurufen, besuchen Sie die Website von Computer Associates: (http://supportconnectw.ca.com/premium/antivirus/downloads/nt/4.5/ildrvupdate.asp).

  2. Downloaden Sie die entsprechende aktualisierte Version von eTrust oder InoculateIT.

  3. Führen Sie eine vollständige Sicherung des Exchange Server-Computers aus, einschließlich einer Sicherung der Datei Ino_fltr.sys.

  4. Installieren Sie das aktuellste Update von eTrust oder InoculateIT.
Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Websites nicht aufrufen.

Weitere Informationen zum Verwenden von Antivirussoftware mit Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 240309, „How to Fully Disable Antivirus Software from Filtering Files" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240309)

  • 328841, „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie auf der Exchange Server Partners: Antivirus-Website (http://go.microsoft.com/fwlink/?LinkId=16226).


McAfee GroupShield 5,2 für Microsoft Exchange Update für Exchange ist verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2006-04-19

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungswert, um zu bestimmen, ob eine VSAPI-Bibliothek (Virus Scanning Application Programming Interface) im Microsoft Exchange-Informationsspeicherdienst registriert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Wenn McAfee GroupShield 5.2 fu¨r Microsoft Exchange unter Exchange 2000 Server oder Exchange Server 2003 installiert ist, lautet der Wert des Registrierungseintrags der Bibliothek GSEVS2.DLL. Diese Bibliotheksdatei fu¨hrt mehrere VSAPI-bezogene Funktionen in GroupShield 5.2 fu¨r Microsoft Exchange aus.

Exchange Server Analyzer fragt außerdem die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile ab, um den Wert des Schlu¨ssels Version fu¨r GSEVS2.DLL zu bestimmen. Wenn der Wert fu¨r den Schlu¨ssel Version angibt, dass die Build-Nummer fu¨r diese Datei kleiner als 682 ist, wird eine Warnung angezeigt.

Wenn die Versionsnummer fu¨r GSEVS2.DLL kleiner als 682 ist, stellt dies einen Hinweis darauf dar, dass die neueste Version von GroupShield 5.2 fu¨r Microsoft Exchange nicht installiert ist. Auf der Website von McAfee ist aktualisierte Software fu¨r GroupShield 5.2 fu¨r Microsoft Exchange erha¨ltlich. Es wird dringend empfohlen, diese Aktualisierung anzuwenden. Sie erho¨ht die Gesamtleistung und Zuverla¨ssigkeit. Außerdem wird durch eine Aktualisierung auf GroupShield fu¨r Microsoft Exchange 5.2.682 die Verwendung der aktuellsten Versionen von wichtigen DLLs sichergestellt. Durch die Verwendung der aktuellsten Version von gsevs2.dll wird die Leistung und die Zuverla¨ssigkeit von Exchange Server-Messagingbereitstellungen deutlich verbessert.

So beheben Sie diese Warnung

  1. Ermitteln Sie auf der Seite Guided Knowledge Search auf der Website von McAfee (http://knowledgemap.nai.com/) die aktuellste Version von GroupShield 5.2 fu¨r Microsoft Exchange Server. Ermitteln Sie die aktuellste Version anhand der folgenden oder anderer McAfee Solutions KnowledgeBase-Artikel auf der oben angegebenen Website:

    • Solution ID KB40567, „Getting the latest version of GroupShield and/or SpamKiller"

    • Solution ID KB nai18117, „Product Version Information for GroupShield for Exchange 2000"

  2. Besuchen Sie die McAfee-Website (https://secure.nai.com/us/forms/downloads/upgrades/login.asp).

  3. Downloaden Sie die neueste Aktualisierung Ihrer Version von GroupShield 5.2 fu¨r Microsoft Exchange Server.

  4. Nehmen Sie eine vollsta¨ndige Sicherung des Exchange Server-Computers vor.

  5. Installieren Sie die neueste Aktualisierung fu¨r GroupShield 5.2 fu¨r Microsoft Exchange Server.
Hinweis:
Die Informationen zur Website des Drittanbieters in diesem Thema werden bereitgestellt, um Ihnen das Auffinden der beno¨tigten technischen Informationen zu ermo¨glichen. Die URLs ko¨nnen jederzeit ohne vorherige Anku¨ndigung gea¨ndert werden.

Weitere Informationen zum Verwenden von Antivirussoftware mit Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 328841, „Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841).

  • 823166, „U¨berblick u¨ber Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen fu¨r die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Eine Liste mit Antivirussoftware von Drittanbietern, die fu¨r Exchange Server verfu¨gbar ist, finden Sie auf der Exchange Server Partners: Antivirus-Website (http://go.microsoft.com/fwlink/?LinkId=16226).


McAfee GroupShield 6,0 für Microsoft Exchange Update für Exchange ist verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungswert, um zu bestimmen, ob eine VSAPI-Bibliothek (Virus Scanning Application Programming Interface) im Microsoft Exchange-Informationsspeicherdienst registriert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Wenn McAfee GroupShield 6,0 für Microsoft Exchange unter Exchange 2000 Server oder Exchange Server 2003 installiert ist, lautet der Wert des Registrierungseintrags der Bibliothek VSAPISCANSOURCE.DLL. Diese Bibliotheksdatei führt mehrere VSAPI-bezogene Funktionen in GroupShield 6,0 für Microsoft Exchange aus.

Exchange Server Analyzer fragt außerdem die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile ab, um den Wert des Schlüssels Version für VSAPISCANSOURCE.DLL zu bestimmen. Wenn der Wert für den Schlüssel Version angibt, dass die Build-Nummer für diese Datei kleiner als 6.0.1148.0 ist, wird eine Warnung angezeigt.

Ist die Versionsnummer für VSAPISCANSOURCE.DLL kleiner als 6.0.1148.0, ist dies ein Hinweis darauf, dass die neueste Version von GroupShield 6.0 für Microsoft Exchange nicht installiert ist. Auf der Website von McAfee ist aktualisierte Software für GroupShield 6,0 für Microsoft Exchange erhältlich. Es wird dringend empfohlen, diese Aktualisierung anzuwenden. Sie erhöht die Gesamtleistung und Zuverlässigkeit.

So beheben Sie diese Warnung

  1. Ermitteln Sie auf der Seite Guided Knowledge Search auf der Website von McAfee (http://knowledgemap.nai.com/) die aktuellste Version von GroupShield 6.0 für Microsoft Exchange Server. Ermitteln Sie die aktuellste Version anhand der folgenden oder anderer McAfee Solutions-Artikel auf der oben angegebenen Website:

    • Solution ID KB nai18117, „Product Version Information for GroupShield for Exchange 2000"

    • Solution ID KB37636, „Version numbers for McAfee GroupShield 6.x for Microsoft Exchange"

    • Solution ID KB40567, „Getting the latest version of GroupShield and/or SpamKiller"

  2. Besuchen Sie die Seite für Produkt-Downloads auf der McAfee-Website (https://secure.nai.com/us/forms/downloads/upgrades/login.asp).

  3. Downloaden Sie die neueste Aktualisierung Ihrer Version von GroupShield 6.0 für Microsoft Exchange.

  4. Nehmen Sie eine vollständige Sicherung des Exchange Server-Computers vor.

  5. Installieren Sie das aktuelle Update für GroupShield 6.0 für Microsoft Exchange.
Hinweis:
Die Informationen zur Website des Drittanbieters in diesem Thema werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.

Weitere Informationen zum Verwenden von Antivirussoftware mit Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 328841, „Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841).

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie auf der Exchange Server Partners: Antivirus-Website (http://go.microsoft.com/fwlink/?LinkId=16226).


Auf diesem Exchange-Server wurde McAfee GroupShield installiert, der Dienst wurde jedoch angehalten.
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Service ab, um zu bestimmen, ob McAfee GroupShield für Microsoft Exchange installiert ist und ob der Dienst McAfee GroupShield auf dem Exchange-Computer ausgeführt wird.

Exchange Server Analyzer fragt die WMI-Klasse Win32_Service auch ab, um zu ermitteln, ob der für den Schlüssel Started im Microsoft Exchange-Informationsspeicherdienst festgelegte Wert auf True oder False festgelegt ist.

Der Wert False gibt an, dass der Informationsspeicherdienst auf diesem Exchange Server-Computer nicht ausgeführt wird. Der Wert True gibt an, dass der Microsoft-Informationsspeicherdienst ausgeführt wird.

Wenn Exchange Server Analyzer feststellt, dass der Microsoft Exchange-Informationsspeicherdienst ausgeführt wird und dass McAfee GroupShield installiert ist, aber der Dienst McAfee GroupShield nicht ausgeführt wird, wird eine Warnung angezeigt.

McAfee GroupShield bietet Virenschutz für Exchange. Im Folgenden werden einige Gründe, die zum Beenden des McAfee GroupShield-Dienstes geführt haben können, mit den dazugehörigen Lösungen aufgelistet.

  • Bei der Software, die Sie auf dem Exchange Server ausführen, handelt es sich möglicherweise um eine Evaluierungsversion (oder Testversion), die inzwischen abgelaufen ist. In diesem Fall müssen Sie möglicherweise McAfee GroupShield neu installieren. Sie müssen aber zumindest die Software aktivieren, um mit ihr weiter arbeiten zu können.

  • Der Dienst McAfee GroupShield wurde möglicherweise versehentlich von einem Administrator beendet. Überprüfen Sie, ob der Dienst so eingerichtet ist, dass er automatisch gestartet wird, und starten Sie dann den Dienst.

  • Der Dienst wurde möglicherweise durch einen bösartigen Wurm, einen Virus oder ein anderes Programm angehalten. Überprüfen Sie, ob der Dienst so festgelegt ist, dass er automatisch startet, und starten Sie dann den Dienst. Wenn der Dienst weiterhin unerwartet und ohne relevante Fehlerereignisse anhält, prüfen Sie, ob der Computer mit einem bösartigen Wurm infiziert ist, und entfernen Sie gegebenenfalls den Wurm.

Von Microsoft wird im Allgemeinen empfohlen, Antivirus-Software bereitzustellen, die für Messaging-Systeme am SMTP-Gateway (Simple Mail Transfer Protocol) oder auf Exchange-Servern entwickelt wurde, auf denen sich Postfächer befinden. Den höchsten Schutz erhalten Sie, wenn Sie eine Antivirussoftware am Gateway, das die eingehenden MIME-Nachrichten überprüft, und ein Prüfprogramm auf dem Exchange-Server mit VSAPI 2.5 ausführen.

So starten Sie den McAfee GroupShield-Dienst

  1. Öffnen Sie das MMC-Snap-In Dienste.

  2. Klicken Sie mit der rechten Maustaste auf den Dienst McAfee GroupShield, und klicken Sie dann auf Eigenschaften.

  3. Vergewissern Sie sich, dass auf der Eigenschaftenseite für McAfee GroupShield auf der Registerkarte Allgemein die Option Starttyp auf Automatisch festgelegt ist. Wenn dies nicht zutrifft, klicken Sie auf Übernehmen und dann auf OK.

  4. Klicken Sie mit der rechten Maustaste auf den Dienst McAfee GroupShield, und klicken Sie dann auf Start.

  5. Schließen Sie das Snap-In Dienste.

Zusätzlich sollten Sie eine Client-Antivirussoftware auf dem Desktop des Benutzers ausführen. Wenn Sie die für Sofortnachrichtensysteme entwickelte Antivirussoftware (d. h. Software, die MIME analysieren und überprüfen kann) am Gateway oder auf dem Exchange-Server ausführen, reicht es aus, auf dem Desktop ein Virenprüfprogramm auf Dateiebene auszuführen.

  • Weitere Informationen zu den verschiedenen mit Microsoft Exchange Server 2003 üblicherweise verwendeten Virenprüfprogrammen finden Sie im Microsoft Knowledge Base-Artikel 823166 „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

  • Weitere Informationen zu den verschiedenen mit Microsoft Exchange 2000 Server üblicherweise verwendeten Virenprüfprogrammen finden Sie im Knowledge Base-Artikel 328841 „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

  • Weitere Informationen zum Schutz von Exchange-Umgebungen vor durch E-Mails übertragenen Viren und Würmern finden Sie im White Paper von Microsoft „Behindern und Blockieren von E-Mail-Viren in einer Exchange 2003-Umgebung" auf der Seite http://go.microsoft.com/fwlink/?LinkId=30732).


Messageware Plus Pack ist installiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob das Messageware Plus Pack auf einem der Exchange Server ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\Messageware Incorporated\Core Services\PlusPack\Load

Wenn Exchange Server Analyzer ermittelt, dass der Datenwert für Load gleich 1 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich.

Messageware Plus Pack ist ein Add-In zu Microsoft Office Outlook® Web Access für Exchange Server 2003, hergestellt von Messageware Incorporated. Messageware Plus Pack erweitert und optimiert Outlook Web Access sowohl für die Benutzer von Outlook Web Access Basic als auch für die Benutzer von Outlook Web Access Premium.

Weitere Informationen zum Messageware Plus Pack finden Sie auf der Website „Messageware OWA Suite" unter http://www.messageware.com.

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.


Microsoft Antigen-Datenausführungsverhinderung - Kompatibilität
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2007-02-19

Microsoft Exchange Analyzer fragt die Microsoft WMI-Klasse (Windows Management Instrumentation) Win32_Service ab, um den Wert des Schlüssels Started für den Microsoft Antigen-Dienst zu bestimmen. Der Wert False gibt an, dass der Dienst nicht ausgeführt wird. Der Wert True gibt an, dass der Dienst ausgeführt wird.

Der Exchange Analyzer liest außerdem den folgenden Registrierungseintrag, um zu bestimmen, ob das Kaspersky-Scanmodul für Microsoft Antigen auf dem Exchange Server installiert ist. Dieser Registrierungseintrag liegt nur dann vor, wenn das Kaspersky-Scanmodul auf dem Exchange Server installiert ist.

HKEY_LOCAL_MACHINE\Software\Sybari Software\Antigen for Exchange\Scan Engines\Kaspersky

Wird Exchange Server unter Microsoft Windows Server 2003 Service Pack 1 (SP1) oder höher ausgeführt, fragt Exchange Analyzer schließlich die WMI-Klasse Win32_ComputerSystem ab, um zu bestimmen, ob der Wert für den Schlüssel SystemStartupOptions die Zeichenfolge '/NOEXECUTE=OPTOUT' oder '/NOEXECUTE=ALWAYSON' enthält. Dies zeigt an, dass die Datenausführungsverhinderung auf dem Server aktiviert ist. Bei der Datenausführungsverhinderung handelt es sich um eine Reihe von Hardware- und Softwaretechnologien, die mittels zusätzlicher Prüfungen des Arbeitsspeichers die Ausführung von bösartigem Code auf einem System verhindern.

Wenn Exchange Analyzer ermittelt, dass die folgenden Bedingungen erfüllt sind, zeigt das Tool eine Warnung an:

  • Der Microsoft Antigen-Dienst ist auf dem Server aktiviert.

  • Das Kaspersky-Scanmodul für Antigen ist installiert.

  • Auf dem Exchange-Server wird Microsoft Windows Server 2003 Service Pack 1 (SP1) oder höher ausgeführt.

  • Die Datenausführungsverhinderung ist auf dem Server aktiviert.

Diese Warnung weist darauf hin, dass die aktuelle Serverkonfiguration zu Leistungsproblemen bei Nachrichtenübermittlung und Virenprüfung führen kann.

Zum Beheben dieser Warnung befolgen Sie die in Microsoft Knowledge Base-Artikel 905952, "Nachrichtenübermittlung erfolgt bei Verwendung von Antigen langsamer und der Antigen-Client reagiert eventuell nicht mehr" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905952) enthaltenen Anweisungen, um die Datenausführungsverhinderung selektiv für einzelne Programme zu deaktivieren.

Weitere Informationen

Weitere Informationen zur Datenausführungsverhinderung finden Sie in Microsoft Knowledge Base-Artikel 875352 "Detaillierte Beschreibung der Funktion Datenausführungsverhinderung in Windows XP Service Pack 2, Windows XP Tablet PC Edition 2005 und Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=875352).


Die NSI-Software Double-Take ist installiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Windows Management Instrumentation) Win32_Service ab, um den Wert des Schlüssels Started für den Double-Take-Dienst zu bestimmen. Der Wert True gibt an, dass der Double-Take-Dienst auf diesem Exchange-Server ausgeführt wird. Wenn der Double-Take-Dienst auf einem Exchange-Server erkennt wird, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Microsoft Exchange Server Analyzer meldet diese nicht der Standardkonfiguration entsprechende Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich.

Double-Take von NSI Software, Inc., kopiert von Benutzern ausgewählte Dateien oder ganze Datenträger von mindestens einem Quellserver über Standardnetzwerkverbindungen auf mindestens einen Zielserver. Mithilfe dieser Kopien können Unternehmen nach einem Datenverlust oder Systemausfall mit oder ohne Eingriff der Benutzer schnell den Betrieb wieder aufnehmen.

Weitere Informationen zu Double-Take finden Sie auf der Website „Double-Take" unter http://www.nsisoftware.com/pro/doubletake.

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.

Double-Take ist eine Software zum Replizieren von Daten. Detaillierte Informationen zur Datenreplikation bei vielen Standorten für Exchange 2000 Server und Exchange Server 2003 finden Sie im Microsoft Knowledge Base-Artikel 895847, „Multi-site data replication support for Exchange 2003 and Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895847).


Ein nicht zu Exchange gehörender Prozess belegt mehr als 20 % der CPU-Zeit
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2006-02-13

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem %Processor Time (_Total)-Leistungsindikator des Processor-Leistungsobjekts.

Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Ein Prozessorengpass liegt vor.

  • Einer oder mehrere Prozesse, die nicht zu Exchange gehören, belegen mehr als 20 % der gesamten Server-CPU-Durchschnittszeit.

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Ein Prozessorengpass liegt vor.

  • Einer oder mehrere Prozesse, die nicht zu Exchange gehören, belegen mehr als 10 % der gesamten Server-CPU-Durchschnittszeit.

Der Leistungsindikator % Processor Time (_Total) unter dem Leistungsobjekt Process stellt Informationen zur Gesamtauslastung des Prozessors bereit. Die durchschnittliche CPU-Auslastung sollte immer unter 80 Prozent liegen. Höhere Durchschnittswerte deuten auf einen Prozessorengpass hin. Häufige Spitzen in der Prozessorzeit, die 90 Prozent übersteigen, sind ebenfalls ein Hinweis auf einen Prozessorengpass.

Beheben von Prozessorengpässen

Es gibt viele Möglichkeiten, um Prozessorengpässe auf Ihrem Exchange-Server zu beheben.

  • Überprüfen Sie zunächst die Anwendungen oder Aufgaben, die Serverlast verursachen. Ermitteln Sie, ob die Anwendung die tatsächlich verwendete Prozessorzeit wirklich benötigt, oder ob es möglicherweise ein Problem mit dem Prozess gibt.

  • Wenn eine nicht zu Exchange gehörende Anwendung für den Server nicht wichtig ist, führen Sie diese Anwendung auf einem anderen Server aus. Ist dies möglich, verschieben Sie ebenfalls Serverfunktionen auf andere Computer. Wenn beispielsweise der Inetinfo-Prozess einen großen Teil der CPU-Auslastung beansprucht, sollten Sie Front-End-Server hinzufügen, damit diese die Aufgaben der Protokollarbeit übernehmen, die von Inetinfo ausgeführt wird. Sie können auch den Zugriff auf Öffentliche Ordner auf einen dedizierten Server für Öffentliche Ordner umlenken. Schließlich können Sie bei einem Server, der viele Erweiterungen von Verteilerlisten vornimmt, die CPU-Auslastung verringern, indem Sie das Erweitern von Verteilerlisten auf einen speziell für die Erweiterung von Verteilerlisten vorgesehenen Server verschieben.

  • Ist dies möglich, fügen Sie dem Server zusätzliche oder schnellere Prozessoren hinzu. Aktivieren Sie außerdem Hyper-Threading, wenn dies von den Prozessoren unterstützt wird. Sie aktivieren Hyper-Threading, indem Sie das System-BIOS entsprechend konfigurieren. Weitere Informationen finden Sie in der Hilfedokumentation des Computerherstellers.

  • Wenn sich die Prozessorleistung nicht steigern lässt, müssen Sie die Last auf den Prozessoren reduzieren. Um die Gesamtauswirkung auf den Server zu verringern, muss sichergestellt werden, dass E/A-intensive Aufgaben sowie CPU-intensive oder besonders speicherintensive Aufgaben außerhalb der normalen Betriebszeiten verarbeitet werden.

  • Stellen Sie sicher, dass prozessorintensive Aufgaben wie Sicherungs- und Wartungsaufgaben außerhalb der Spitzenlastzeiten ausgeführt werden. Sorgen Sie außerdem dafür, dass diese Aufgaben in einer phasenweisen Abfolge (Staging) ausgeführt werden. Unter dem Staging (Phasenplanung) einer Aufgabe ist zu verstehen, dass für jede Aufgabe unterschiedliche Start- und vorzugsweise auch Endzeiten definiert werden. Durch Staging der Wartung und Sicherung von Datenbanken oder Speichergruppen werden die Auswirkungen dieser ressourcenintensiven Aufgaben verringert.

Weitere Informationen

  • Weitere Informationen über Prozessorengpässe finden Sie unter Prozessorengpass.

  • Weitere Informationen zur Leistung von Exchange Server finden Sie im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange Server finden Sie im Handbuch Troubleshooting Microsoft Exchange Server 2003 Performance (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Weitere Informationen zum Verschieben von Benutzerpostfächern zur Verringerung der Serverlast finden Sie unter Verschieben von Benutzerpostfächern auf einen anderen Server.


Ein nicht zu Exchange gehörender Prozess belegt mehr als 50 % der CPU-Zeit
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2006-02-13

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst für deren Analyse Daten aus dem %Processor Time (_Total)-Leistungsindikator des Processor-Leistungsobjekts.

Dieser Leistungsindikator % Processor Time (_Total) unter dem Leistungsobjekt Process stellt Informationen zur Gesamtauslastung des Prozessors bereit. Die durchschnittliche CPU-Auslastung sollte immer unter 80 Prozent liegen. Höhere Durchschnittswerte deuten auf einen Prozessorengpass hin. Häufige Spitzen in der Prozessorzeit, die 90 Prozent übersteigen, sind ebenfalls ein Hinweis auf einen Prozessorengpass.

Wenn Exchange Server Analyzer feststellt, dass ein nicht zu Exchange gehörender Prozess mehr als 50 % der gesamten Server-CPU-Durchschnittszeit belegt, wird, auch wenn dabei kein tatsächlicher Prozessorengpass erkannt wird, eine Warnung angezeigt.

Beheben von potenziellen Prozessorengpässen

Es gibt viele Möglichkeiten, um potenzielle Prozessorengpässe auf Ihrem Exchange-Server zu beheben.

  • Überprüfen Sie zunächst die Anwendungen oder Aufgaben, die Serverlast verursachen. Ermitteln Sie, ob die Anwendung die tatsächlich verwendete Prozessorzeit wirklich benötigt, oder ob es möglicherweise ein Problem mit dem Prozess gibt.

  • Wenn eine nicht zu Exchange gehörende Anwendung für den Server nicht wichtig ist, führen Sie diese Anwendung auf einem anderen Server aus. Ist dies möglich, verschieben Sie ebenfalls Serverfunktionen auf andere Computer. Wenn beispielsweise der Inetinfo-Prozess einen großen Teil der CPU-Auslastung beansprucht, sollten Sie Front-End-Server hinzufügen, damit diese die Aufgaben der Protokollarbeit übernehmen, die von Inetinfo ausgeführt wird. Sie können auch den Zugriff auf Öffentliche Ordner auf einen dedizierten Server für Öffentliche Ordner umlenken. Schließlich können Sie bei einem Server, der viele Erweiterungen von Verteilerlisten vornimmt, die CPU-Auslastung verringern, indem Sie das Erweitern von Verteilerlisten auf einen speziell für die Erweiterung von Verteilerlisten vorgesehenen Server verschieben.

  • Ist dies möglich, fügen Sie dem Server zusätzliche oder schnellere Prozessoren hinzu. Aktivieren Sie außerdem Hyper-Threading, wenn dies von den Prozessoren unterstützt wird. Sie aktivieren Hyper-Threading, indem Sie das System-BIOS entsprechend konfigurieren. Weitere Informationen finden Sie in der Hilfedokumentation des Computerherstellers.

  • Wenn sich die Prozessorleistung nicht steigern lässt, müssen Sie die Last auf den Prozessoren reduzieren. Um die Gesamtauswirkung auf den Server zu verringern, muss sichergestellt werden, dass E/A-intensive Aufgaben sowie CPU-intensive oder besonders speicherintensive Aufgaben außerhalb der normalen Betriebszeiten verarbeitet werden.

  • Stellen Sie sicher, dass prozessorintensive Aufgaben wie Sicherungs- und Wartungsaufgaben außerhalb der Spitzenlastzeiten ausgeführt werden. Sorgen Sie außerdem dafür, dass diese Aufgaben in einer phasenweisen Abfolge (Staging) ausgeführt werden. Unter dem Staging (Phasenplanung) einer Aufgabe ist zu verstehen, dass für jede Aufgabe unterschiedliche Start- und vorzugsweise auch Endzeiten definiert werden. Durch Staging der Wartung und Sicherung von Datenbanken oder Speichergruppen werden die Auswirkungen dieser ressourcenintensiven Aufgaben verringert.

Weitere Informationen

  • Weitere Informationen über Prozessorengpässe finden Sie unter Prozessorengpass.

  • Weitere Informationen zur Leistung von Exchange Server finden Sie im Handbuch Performance and Scalability Guide for Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange Server finden Sie im Handbuch Troubleshooting Microsoft Exchange Server Performance (http://go.microsoft.com/fwlink/?LinkId=47588).


Eine veraltete Version von HP/Compaq Secure Path ist installiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-12-13

Microsoft® Exchange Server Best Practices Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Service ab, um die Software-Version der HP/Compaq Secure Path-Software zu ermitteln, die auf dem Exchange-Server installiert ist. Wenn die Secure Path-Version nicht 3.7.2.540 ist, wird eine Warnung angezeigt.

Um dieser Warnung vorzubeugen, aktualisieren Sie die Secure Path-Software. Setzen Sie sich dazu mit Ihrem HP/Compaq-Händler in Verbindung.

Weitere Informationen zu HP/Compaq Secure Path-Softwareaktualisierungen finden Sie auf der HP-Website „HP StorageWorks Secure Path" unter http://h18006.www1.hp.com/products/sanworks/softwaredrivers/securepath/index.html.

Hinweis:
Die Informationen zur Website des Drittanbieters in diesem Thema werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.


Anschluss 25 ist gesperrt
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2006-10-06

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungswert, um zu ermitteln, ob McAfee VirusScan für Microsoft Exchange auf dem Exchange-Server installiert ist:

HKEY_LOCAL_MACHINE\Software\Network Associates\TVD\VirusScan Enterprise\CurrentVersion

Microsoft Exchange Server Analyzer fragt auch den folgenden Registrierungszweig ab, um zu ermitteln, wie die Sperrung von Anschlüssen in McAfee VirusScan konfiguriert ist:

HKLM\Software\Network Associates\TVD\Shared Components\On Access Scanner\BehaviourBlocking

Anhand der Schlüssel in diesem Zweig wird festgelegt, welche Vorgänge und Anschlüsse über die Funktion „Beim Zugriff" von McAfee VirusScan blockiert oder zugelassen bzw. freigegeben werden.

Exchange Server Analyzer fragt außerdem die Win32_Service Microsoft Windows®-Verwaltungsinstrumentationsklasse (Windows® Management Instrumentation, WMI) nach dem Wert des Schlüssels Started für den McAfee VirusScan-Dienst ab, um zu ermitteln, ob er auf dem Exchange-Server ausgeführt wird.

Der Wert False zeigt an, dass der McAfee VirusScan-Dienst auf diesem Exchange-Server nicht ausgeführt wird. Der Wert True gibt an, dass der McAfee VirusScan-Dienst ausgeführt wird.

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • McAfee VirusScan ist installiert und wird auf dem Exchange-Server ausgeführt.

  • Die Blockierregel „Versenden von Massen-E-Mails durch einen Wurm verhindern" ist für Anschluss 25 aktiviert.

  • Der Exchange-SMTP-Dienst (Simple Mail Transfer Protocol) ist nicht von der Blockierregel ausgenommen.

Diese Warnung weist darauf hin, dass durch die Konfiguration der Anwendung McAfee VirusScan möglicherweise auch erwünschte Exchange Server-Kommunikation über Anschluss 25 blockiert wird. Es können Probleme bei der Nachrichtenübermittlung auftreten.

So beheben Sie dieses Problem

  • Deaktivieren Sie die Blockierregel „Versenden von Massen-E-Mails durch einen Wurm verhindern".

  • Fügen Sie den Exchange Server SMTP-Dienst zur Ausschlussliste für die Blockierregel „Versenden von Massen-E-Mails durch einen Wurm verhindern" hinzu.

Weitere Informationen

  • Weitere Informationen zur Konfiguration von McAfee VirusScan für Microsoft Exchange finden Sie auf dem McAfee-Serviceportal (http://knowledge.mcafee.com/).

    Hinweis:
    Die Informationen zur Website des Drittanbieters werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.
  • Weitere Informationen zu den verschiedenen mit Microsoft Exchange Server 2003 üblicherweise verwendeten Virenprüfprogrammen finden Sie im Microsoft Knowledge Base-Artikel 823166 „Überblick über Exchange Server 2003 und Antivirussoftware" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

  • Weitere Informationen zu den verschiedenen in Microsoft Exchange 2000 Server üblicherweise verwendeten Virenprüfprogrammen finden Sie im Knowledge Base-Artikel 328841, „XADM: Exchange und Antivirussoftware" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

  • Weitere Informationen zum Schutz von Exchange-Umgebungen vor durch E-Mails übertragenen Viren und Würmern finden Sie im Whitepaper von Microsoft „Behindern und Blockieren von durch E-Mails übertragenen Viren in einer Exchange-Umgebung" (http://go.microsoft.com/fwlink/?LinkId=30732).


Red Earth Software Policy Patrol for Exchange Server Needs Update
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2007-07-24

Das Tool Microsoft Exchange Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob einer der folgenden beiden Unterschlüssel vorhanden ist:

HKEY_LOCAL_MACHINE\Software\Red Earth Software\Policy Patrol\3.0

HKEY_LOCAL_MACHINE\Software\Wow6432Node\Red Earth Software\Policy Patrol\3.0

Das Vorhandensein eines dieser Zweige zeigt an, dass Policy Patrol, Version 3.0, für Exchange Server von Red Earth Software auf dem lokalen Computer installiert ist.

Wenn Exchange Analyzer ermittelt, dass Policy Patrol, Version 3, für Exchange Server auf dem lokalen Computer installiert ist, zeigt Exchange Analyzer eine Warnung an.

Diese Warnung weist darauf hin, dass eine empfohlene Aktualisierung von Policy Patrol für Exchange Server verfügbar ist.

So beheben Sie diese Warnung

  1. Besuchen Sie die Downloadwebsite von Red Earth Software Policy Patrol für Exchange Server unter der Adresse http://www.policypatrol.com/download.htm

  2. Laden Sie alle erforderlichen oder empfohlenen Aktualisierungen von Policy Patrol für Exchange Server herunter, und installieren Sie diese.
Hinweis:
Die Informationen zur Website des Drittanbieters werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.


ScanMail für Microsoft Exchange und CA eTrust werden gleichzeitig ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die installierte Version von Trend Micro ScanMail für Microsoft Exchange zu bestimmen, die auf dem Exchange-Server installiert ist:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Wenn die Wertdaten für den Versionswert mit 7 beginnen, wird angezeigt, dass die Version ScanMail für Microsoft Exchange vorliegt: 7 ist installiert.

Exchange Server Analyzer liest außerdem den folgenden Registrierungseintrag, um zu bestimmen, ob auf dem Exchange-Server auch eTrust von Computer Associates installiert ist:

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\

Wenn der Registrierungswert CurrentVersion vorhanden ist, gibt er an, dass eTrust Antivirus, Version 7 von Computer Associates auf dem Exchange-Server installiert ist.

Schließlich fragt Exchange Server Analyzer außerdem die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_Service ab, um den Wert des Schlüssels Started für den InoRT-Dienst zu bestimmen, der in eTrust Antivirus auch als eTrust Antivirus Echtzeit-Antivirenserver bezeichnet wird.

Microsoft Exchange Server Analyzer zeigt eine Meldung mit der optimalen Methode an, wenn die folgenden Bedingungen erfüllt sind:

  • Sowohl ScanMail für Microsoft Exchange als auch eTrust Antivirus sind auf dem Exchange-Server installiert.

  • Der eTrust Antivirus Realtime Server-Dienst wurde gestartet.

Trend Micro empfiehlt, dass dateisystembasierte Antivirussoftware, wie eTrust Antivirus, die Ordner von ScanMail für Microsoft Exchange nicht untersucht. ScanMail für Microsoft Exchange verwendet temporäre Ordner in seinem Pfad für die eigenen Suchaktivitäten. Wenn ein Antivirenprüfprogramm auf Dateisystemebene diese temporären Ordner überprüft, könnte diese Überprüfung Auswirkungen auf den normalen Betrieb von ScanMail für Microsoft Exchange haben.

Es empfiehlt sich, ScanMail für Microsoft Exchange-Ordner von der Echtzeitüberprüfung durch dateisystembasierte Antivirussoftware, wie eTrust Antivirus von Computer Associates, auszuschließen. Weitere Informationen zur Verwendung von ScanMail für Microsoft Exchange auf einem Computer, auf dem eine Antivirussoftware auf Dateisystemebene installiert ist, finden Sie in dem Trend Micro-Knowledge Base-Artikel, „###Installing another antivirus application with ScanMail for Exchange also installed on the same server" (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=8540).

Hinweis:
Die Informationen zur Website des Drittanbieters werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.


Archivverzeichnis von ScanMail für Microsoft Exchange enthält zu viele Dateien
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob Version 7.0 von Trend Micro ScanMail für Microsoft Exchange installiert ist:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer ermittelt dann die Anzahl der Dateien, die sich in dem von ScanMail für Microsoft Exchange verwendeten Archivverzeichnis befinden. In der Standardeinstellung lautet der Pfad des Archivverzeichnisses folgendermaßen.

C:\Program Files\Trend Micro\Smex\Storage\Archive

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Version 7.0 von ScanMail für Microsoft Exchange ist installiert.

  • Mehr als 1.000 Dateien befinden sich im Archivverzeichnis, das ScanMail für Microsoft Exchange verwendet.

Diese Warnung weist darauf hin, dass sich viele Dateien im Archivverzeichnis befinden, das ScanMail für Microsoft Exchange verwendet. Trend Micro empfiehlt, dass Sie den von ScanMail für Microsoft Exchange verwendeten Archivordner regelmäßig kontrollieren und bereinigen.


Sicherungsverzeichnis von ScanMail für Microsoft Exchange enthält zu viele Dateien
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob Version 7.0 von Trend Micro ScanMail für Microsoft Exchange installiert ist:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer ermittelt dann die Anzahl der Dateien, die sich in dem von ScanMail für Microsoft Exchange verwendeten Sicherungsverzeichnis befinden. In der Standardeinstellung lautet der Pfad des Sicherungsverzeichnisses folgendermaßen.

C:\Program Files\Trend Micro\Smex\Storage\Backup

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Version 7.0 von ScanMail für Microsoft Exchange ist installiert.

  • Mehr als 1.000 Dateien befinden sich im Sicherungsverzeichnis, das ScanMail für Microsoft Exchange verwendet.

Diese Warnung weist darauf hin, dass sich viele Dateien im Sicherungsverzeichnis befinden, das ScanMail für Microsoft Exchange verwendet. Trend Micro empfiehlt, dass Sie den von ScanMail für Microsoft Exchange verwendeten Sicherungsordner regelmäßig kontrollieren und bereinigen.


ScanMail für Microsoft Exchange-Backupausschluss
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Dateien und Ordner zu ermitteln, die von Aktualisierungen mit Windows® Backup ausgenommen wurden:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

Exchange Server Analyzer sucht insbesondere nach einer Zeichenfolgenwert, der SMEX\DATA enthält.

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel FilesNotToBackup einen Wert mit der Zeichenfolge SMEX\DATA enthält, zeigt ExchangeServer Analyzer eine Warnung an.

Wenn Sie Windows Backup nicht verwenden, können Sie diese Warnung ignorieren. Wenn Sie Windows Backup verwenden, wird empfohlen, dass Sie den Ausschluss für das Verzeichnis SMEX\DATA entfernen. Trend Micro empfiehlt, dass Benutzer in diesem Ordner alle Dateien mit der Dateinamenserweiterung MDB sichern. Die Sicherungsdateien können in dem Fall verwendet werden, dass die Produktionsdatenbankdateien (MDB) im Ordner SMEX\DATA beschädigt oder gelöscht werden.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So beheben Sie diese Warnung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

  3. Wählen Sie im linken Fenster FilesNotToBackup.

  4. Klicken Sie mit der rechten Maustaste auf den Wert mit der Zeichenfolge SMEX\DATA, und wählen Sie Löschen aus.

  5. Schließen Sie den Registrierungs-Editor.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Debugmodus von ScanMail für Microsoft Exchange ist aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob für Trend Micro ScanMail für Microsoft Exchange der Debugmodus aktiviert ist:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\DebugModule

Wenn die Wertdaten für DebugModule eine oder mehrere der nachfolgenden Zeichenfolgen enthalten, wird vom Exchange Server Analyzer eine Warnung angezeigt:

  • HOST:1

  • CONFIG:1

  • MASTER:1

  • WATCHER:1

  • STORE:1

  • INETINFO:1

  • TCHER:1

  • MON:1

  • MONITOR:1

Diese Warnung zeigt an, dass gerade für eines oder mehrere Module von ScanMail für Microsoft Exchange der Debugmodus aktiviert ist. Trend Micro empfiehlt, den Debugmodus nur dann zu aktivieren, wenn dies zum Beispiel für die Fehlerbehebung nötig ist. Trend Micro empfiehlt das der Debugmodus ansonsten für Standardoperationen deaktiviert bleibt.

So beheben Sie diese Warnung

  1. Lesen Sie den Artikel der Knowledge Base von Trend Micro: „Enabling the ScanMail for Exchange (SMEX) 7.0 debugging through the Registry Editor" (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=25532).

  2. Deaktivieren Sie das Debuggen für alle Module, und folgen Sie dabei den Anweisungen im Trend Micro-Knowledge Base-Artikel.
Hinweis:
Die Informationen zur Website des Drittanbieters werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.


Quarantäneverzeichnis von ScanMail für Microsoft Exchange enthält zu viele Dateien
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob Version 7.0 von Trend Micro ScanMail für Microsoft Exchange installiert ist:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer ermittelt dann die Anzahl der Dateien, die sich in dem von ScanMail für Microsoft Exchange verwendeten Quarantäneverzeichnis befinden. In der Standardeinstellung lautet der Pfad des Quarantäneverzeichnisses folgendermaßen.

C:\Program Files\Trend Micro\Smex\Storage\Quarantine

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Version 7.0 von ScanMail für Microsoft Exchange ist installiert.

  • Mehr als 1.000 Dateien befinden sich im Quarantäneverzeichnis, das ScanMail für Microsoft Exchange verwendet.

Diese Warnung weist darauf hin, dass sich viele Dateien im Quarantäneverzeichnis befinden, das ScanMail für Microsoft Exchange verwendet. Trend Micro empfiehlt, dass Sie den von ScanMail für Microsoft Exchange verwendeten Quarantänesordner regelmäßig kontrollieren und bereinigen.


SharedResPool-Verzeichnis von ScanMail für Microsoft Exchange im Standardpfad
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2007-06-05

Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die installierte Version von Trend Micro ScanMail für Microsoft Exchange zu bestimmen:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer liest auch den folgenden Registrierungseintrag, um den Speicherort des SharedResPool-Ordners zu ermitteln:

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\SharedResPool

Schließlich liest Exchange Server Analyzer den folgenden Registrierungseintrag, um den Speicherort der Installation von ScanMail für Microsoft Exchange zu bestimmen:

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\HomeDir

Microsoft Exchange Server Analyzer zeigt eine Meldung mit der optimalen Methode an, wenn die folgenden Bedingungen erfüllt sind:

  • ScanMail für Microsoft Exchange Version: 7 ist installiert.

  • Der SharedResPool-Ordner befindet sich im Pfad des ScanMail-Stammverzeichnisses.

Es ist eine optimale Methode, das Verzeichnis SharedResPool auf ein Laufwerk zu verlagern, das schneller als das von ScanMail für Microsoft Exchange verwendete Stammverzeichnis ist. Trend Micro empfiehlt, dass Kunden, die bessere Leistung wünschen, den Ordner „SharedResPool" auf ein schnelleres Laufwerk verschieben. Das SharedResPool-Verzeichnis enthält Speicherabbildungsdateien für die Ressourcen, die von den Prozessen innerhalb von ScanMail für Microsoft Exchange Version: 7.0. Gemeinsam genutzt werden. Sie dürfen den Inhalt dieses Verzeichnisses nicht löschen.

Weitere Informationen zum SharedResPool-Ordner finden Sie in „What are the ScanMail for Exchange (SMEX) 7.0 SharedResPool and Engine directories?" (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=26898).

Weitere Informationen zum Verschieben des Ordners SharedResPool finden Sie unter "Verschieben des SMEX 7.0-Verzeichnisses (ScanMail for Exchange) SharedResPool an einen anderen Speicherort" (http://esupport.trendmicro.com/support/viewxml.do?ContentID=EN-127549&id=EN-127549).

Hinweis:
Die Informationen zur Website des Drittanbieters werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.


SMTP-Scan von ScanMail für Microsoft Exchange für den Postfachserver aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft® Exchange Server Analyzer liest die folgende Eigenschaft in der Microsoft Internet Information Services-Metabasis (IIS), um zu ermitteln, ob die aktuellen Konfigurationseinstellungen für Trend Micro ScanMail für Microsoft Exchange richtig sind:

LM/SmtpSvc/%SMTPINSTANCE%/EventManager/EventTypes/{76719654-05A6-11d2-9dfd-00C04FA322BA}/Bindings/{6BA0CE4C-AC34-411E-B58A-EB715D04019D}/Enabled

Auch sendet Exchange Server Analyzer eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert für das Attribut serverRole des Exchange-Server-Objekts zu ermitteln. Der Wert 1 für das Attribut for the serverRole gibt an, dass der Exchange Server nicht als Front-End-Server konfiguriert wurde. Der Wert 0 zeigt an, dass es sich der Exchange Server nicht als Front-End-Server konfiguriert wurde.

Exchange Server Analyzer fragt außerdem die WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_OperatingSystem ab, um den Wert des Schlüssels OSProductSuite für den Exchange-Server zu bestimmen. Diese Abfrage wird durchgeführt, um die jeweilige Version des Windows-Betriebssystems zu bestimmen, das auf dem Exchange Server ausgeführt wird.

Exchange Server Analyzer liest außerdem den folgenden Registrierungseintrag, um die Version von ScanMail für Exchange, die auf dem Exchange-Server ausgeführt wird:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Wenn die Wertdaten für Version mit 7 beginnen, wird angezeigt, dass die Version ScanMail für Microsoft Exchange vorliegt: 7 ist installiert.

Schließlich fragt Exchange Server Analyzer Active Directory ab, um die Anzahl von Objekten mit einem konfigurierten homeMDBBL-Attribut zu bestimmen. Objekte, bei denen das Attribut homeMDBBL konfiguriert ist, sind postfachaktiviert. Deshalb entspricht die Anzahl der Objekte mit konfiguriertem homeMDBBL der Anzahl der vorhandenen Postfächer.

Microsoft Exchange Server Analyzer zeigt eine Meldung mit der optimalen Methode an, wenn die folgenden Bedingungen erfüllt sind:

  • ScanMail für Microsoft Exchange Version: 7 ist installiert.

  • ScanMail für Microsoft Exchange ist so konfiguriert, dass SMTP-Suche auf einem Exchange-Server durchgeführt wird, der nicht als ein Frontend-Server konfiguriert ist.

  • Der Exchange-Server enthält mehr als 20 Postfächer.

  • Der Server wird nicht unter Microsoft Windows Small Business Server 2003 oder Microsoft Windows Small Business Server 2000 ausgeführt.

Trend Micro empfiehlt, dass Benutzer von ScanMail für Microsoft Exchange Version: 7 +++Deaktivieren Sie SMTP-Scan. SMTP-Scan verwendet die ScanMail-Verwaltungskonsole auf Postfachservern, wenn separate dedizierte Gateway- oder Bridgeheadserver vorhanden sind. Um eine bestmögliche Leistung und Sicherheit zu gewährleisten, empfiehlt Trend Micro, die SMTP-Prüfung statt auf den Postfachservern auf Gateway-Bridgehead-Servern zu aktivieren.


TEMP-Verzeichnis von ScanMail für Microsoft Exchange enthält viele Dateien
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob Version 7.0 von Trend Micro ScanMail für Microsoft Exchange installiert ist:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer ermittelt dann die Anzahl der Dateien, die sich in dem von ScanMail für Microsoft Exchange verwendeten TEMP-Verzeichnis befinden. Standardmäßig lautet der Pfad des von ScanMail für Microsoft Exchange verwendeten TEMP-Verzeichnisses folgendermaßen.

C:\Program Files\Trend Micro\Smex\Temp

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Version 7.0 von ScanMail für Microsoft Exchange ist installiert.

  • Mehr als 100 Dateien befinden sich im TEMP-Verzeichnis, das ScanMail für Microsoft Exchange verwendet.

Diese Warnung weist darauf hin, dass sich viele Dateien im TEMP-Verzeichnis befinden, das ScanMail für Microsoft Exchange verwendet. Bei den Dateien in diesem Ordner handelt es sich um temporäre Dateien, die ScanMail für Microsoft Exchange verwendet. ScanMail für Microsoft Exchange soll diese Dateien automatisch löschen.

Wenn es viele Dateien mit einem Datum vor dem aktuellen Tagesdatum gibt, empfiehlt Trend Micro, diese alten Dateien zu löschen.


TEMP-Verzeichnis von ScanMail für Microsoft Exchange enthält zu viele Dateien
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob Version 7.0 von Trend Micro ScanMail für Microsoft Exchange installiert ist:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Wenn ScanMail für Microsoft Exchange, Version 7, installiert ist, liest Exchange Server Analyzer den folgenden Registrierungseintrag, um den Speicherort des von ScanMail für Microsoft Exchange verwendeten TEMP-Verzeichnisses zu bestimmen:

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\TempFolderPath

Exchange Server Analyzer ermittelt dann die Anzahl der Dateien, die sich in dem von ScanMail für Microsoft Exchange verwendeten TEMP-Verzeichnis befinden.

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Version 7.0 von ScanMail für Microsoft Exchange ist installiert.

  • Mehr als 100 Dateien befinden sich im TEMP-Verzeichnis, das ScanMail für Microsoft Exchange verwendet.

Diese Warnung weist darauf hin, dass sich viele Dateien im TEMP-Verzeichnis befinden, das ScanMail für Microsoft Exchange verwendet. Bei den Dateien in diesem Ordner handelt es sich um temporäre Dateien, die ScanMail für Microsoft Exchange verwendet. ScanMail für Microsoft Exchange soll diese Dateien automatisch löschen.

Wenn es viele Dateien mit einem Datum vor dem aktuellen Tagesdatum gibt, empfiehlt Trend Micro, diese alten Dateien zu löschen.


Pfad des temporären Ordners in ScanMail für Microsoft Exchange geändert
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob Version 7.0 von Trend Micro ScanMail für Microsoft Exchange installiert ist:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer liest den folgenden Registrierungseintrag, um den Speicherort des temporären Ordners zu ermitteln, der von ScanMail für Microsoft Exchange verwendet wird:

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\TempFolderPath

Wenn der Wert TempFolderPath in der Registrierung vorhanden und konfiguriert ist, zeigt er an, dass der von ScanMail für Microsoft Exchange verwendete Ordner von seinem Standardspeicherort verschoben wurde.

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) CIM_Datafile ab, um den Wert des Schlüssels Version für AdapterSMTP.dll abzufragen. Dieses Modul wird zusammen mit ScanMail für Microsoft Exchange von Trend Micro geliefert. Ein Wert des Schlüssels Version für AdapterSMTP.dll von weniger 7.0.1366 bedeutet, dass eine aktualisierte Version von ScanMail für Microsoft Exchange benötigt wird.

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • ScanMail für Microsoft Exchange Version: 7 ist installiert.

  • Der von ScanMail für Microsoft Exchange verwendete temporäre Ordner ist von seinem ursprünglichen Speicherort verschoben worden.

  • Die Datei adapterSMTP.dll liegt in der Version 7.0.1366 oder früher vor.

In den neusten Versionen von ScanMail für Microsoft Exchange hat Trend Micro die Möglichkeit zum Ändern des Speicherortes für den temporären Ordner eingeführt. Diese Funktion kann nur in Builds ab 7.0.1366 verwendet werden. Diese Warnung zeigt an, dass der temporäre Ordner verschoben worden ist, dass aber diese Verschiebung nicht ausgeführt wird, weil dieser Server einen älteren Build von ScanMail für Microsoft Exchange ausführt, der das Verschieben des temporären Ordners nicht unterstützt.

So beheben Sie dieses Problem

  1. Besuchen Sie die Trend Micro-Website (http://www.trendmicro.com/download/).

  2. Downloaden und installieren Sie alle erforderlichen oder empfohlenen Updates für ScanMail für Microsoft Exchange.
Hinweis:
Die Informationen zur Website des Drittanbieters werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.


Pfadoptimierung für temporäre Ordner in ScanMail für Microsoft Exchange
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob Version 7.0 von Trend Micro ScanMail für Microsoft Exchange installiert ist:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer liest den folgenden Registrierungseintrag, um den Speicherort des temporären Ordners zu ermitteln, der von ScanMail für Microsoft Exchange verwendet wird:

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\TempFolderPath

Wenn der Wert TempFolderPath in der Registrierung vorhanden und konfiguriert ist, zeigt er an, dass der von ScanMail für Microsoft Exchange verwendete Ordner von seinem Standardspeicherort verschoben wurde.

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) CIM_Datafile ab, um den Wert des Schlüssels Version für AdapterSMTP.dll abzufragen. Dieses Modul wird zusammen mit ScanMail für Microsoft Exchange von Trend Micro geliefert.

Microsoft Exchange Server Analyzer zeigt eine Meldung mit der optimalen Methode an, wenn die folgenden Bedingungen erfüllt sind:

  • ScanMail für Microsoft Exchange Version: 7 ist installiert.

  • Der von ScanMail für Microsoft Exchange verwendete temporäre Ordner bleibt an seinem ursprünglichen Standardspeicherort.

  • Die vorliegende Version von AdapterSMTP.dll unterstützt die Umleitung des von ScanMail für Microsoft Exchange verwendeten temporären Ordners.

In den neusten Versionen von ScanMail für Microsoft Exchange hat Trend Micro die Möglichkeit zum Ändern des Speicherortes für den temporären Ordner eingeführt. Diese Funktion kann nur in Builds ab 7.0.1366 verwendet werden. Wenn Sie einen Build von ScanMail für Microsoft Exchange verwenden, der älter als Version 7.0.1366 ist, empfiehlt Trend Micro den temporären Ordner auf ein schnelleres Laufwerk zu verschieben.

So ändern Sie den Speicherort des temporären Ordners

  1. Lesen Sie den Artikel der Knowledge Base von Trend Micro „Can users change the location of the ScanMail for Exchange (SMEX) 7.0 temporary folder?" (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=26343).

  2. Gehen Sie vor, wie in diesem Artikel beschrieben, um den Ordner für temporäre Dateien auf ein schnelleres Laufwerk zu verschieben.
Hinweis:
Die Informationen zur Website des Drittanbieters werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.


Update für ScanMail für Microsoft Exchange verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-12-15

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) CIM_Datafile ab, um den Wert des Schlüssels Version für AdapterSMTP.dll abzufragen. Dieses Modul wird zusammen mit ScanMail für Microsoft Exchange von Trend Micro geliefert.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Registrierungsschlüssels Version kleiner als 7.0.1366 ist, zeigt ExchangeServer Analyzer eine Warnung an.

Diese Warnung zeigt an, dass ScanMail für Microsoft Exchange Version 7 auf dem Exchange-Server installiert ist und dass eine empfohlene Software-Aktualisierung verfügbar ist. Es wird dringend empfohlen, diese Aktualisierung anzuwenden. Sie erhöht die Gesamtleistung und Zuverlässigkeit des Servers.

So beheben Sie diese Warnung

  1. Besuchen Sie die Trend Micro-Website (http://www.trendmicro.com/download/).

  2. Downloaden und installieren Sie alle erforderlichen oder empfohlenen Updates für ScanMail für Microsoft Exchange.
Hinweis:
Die Informationen zur Website des Drittanbieters werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.


Die SMTP-Transport-Antivirenprüfung ist nicht aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) Win32_Service ab, um zu ermitteln, ob im SMSMSE-Dienst (Symantec Mail Security für Microsoft Exchange) für den Schlüssel Started ein Wert festgelegt wurde. Mit der Klasse Win32_Service wird angegeben, ob SMSMSE auf dem Exchange Server 2003-Computer installiert ist. Der Wert True gibt an, dass der SMSMSE-Dienst ausgeführt wird. Der Wert False gibt an, dass der SMSMSE-Dienst nicht ausgeführt wird. Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen vorliegen:

  • SMSMSE ist auf dem Exchange Server 2003-Computer installiert.

  • Die SMTP-Transport-Antivirusüberprüfung ist nicht aktiviert.

In Exchange Server 2003 verwendet das erweiterte Warteschlangenmodul die Exchange Transport AntiVirus-API als eine von sechs Transport-Ereignissenken zum Senden von Nachrichten an ihr entsprechendes Ziel. Die Exchange Transport AntiVirus-API-Ereignissenke ist in OnSubmit.dll implementiert. Sie ermöglicht Drittanbietern (z. B. Symantec) die Implementierung von Antivirusüberprüfungslösungen, bei denen jede Nachricht auf bösartige Anhänge und Datenstrukturen überprüft wird, bevor die Nachricht ihr Ziel erreicht. Dieses Ereignis wird für das Ereignis OnSubmission registriert.

In der Standardeinstellung ist die Transport-Antivirusüberprüfung nicht aktiviert, weil Nachrichten dadurch zweimal überprüft werden: zuerst auf SMTP-Ebene und danach im Exchange-Speicher. Wenn Sie jedoch für die Verbindung der Exchange-Organisation mit dem Internet Front-End-Server verwenden, können Sie auf diesen Servern die Transport-Antivirusüberprüfung aktivieren.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So aktivieren Sie die Transport-Antivirusüberprüfung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\TransportAVAPI.

  3. Erstellen Sie einen neuen Wert DWORD, und verwenden Sie den Wertnamen Enabled. Ordnen Sie dem Wertnamen Enabled den Datenwert 1 zu.

  4. Schließen Sie den Registrierungs-Editor.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Hinweis:
Die Virenprüffunktion auf Transportebene steht nur bei Exchange-Antivirusüberprüfungen zur Verfügung, die auf VSAPI 2.5 (Virus Scanning Application Programming Interface) basieren.

Weitere Informationen zur SMTP-Transportarchitektur finden Sie unter Exchange Server 2003 Technical Reference Guide (http://go.microsoft.com/fwlink/?LinkId=47891).

Weitere Informationen zum Verwenden von Antivirussoftware mit Exchange Server finden Sie in den folgenden Artikeln der Knowledge Base:

  • 328841, „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841).

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105).

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie auf der Exchange Partners: Antivirus-Website (http://go.microsoft.com/fwlink/?LinkId=16226).

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.


Aktualisierung für Simpler-Webb Exchange Resource Manager ist verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2006-04-14

Microsoft® Exchange Server Analyzer fragt die Microsoft Windows®-Verwaltungsinstrumentationsklasse (Windows® Management Instrumentation, WMI) CIM_Datafile ab um den Wert des Schlüssels Version für die Datei ERME2KAsyncSink.dll zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass der Versionswert für ERME2KAsyncSink.dll kleiner als 1015 ist, wird eine Warnung angezeigt.

Die Datei ERME2KAsyncSink.dll stellt eine binäre Kerndatei für Simpler-Webb Exchange Resource Manager (ERM) dar. Wenn der Wert für die Version von ERME2KAsyncSink.dll kleiner als 1015 ist, wird angezeigt, dass ERM 1.2 oder früher auf dem Server installiert ist. Es gibt ein bekanntes Problem mit ERM, Version 1.2, das dazu führen kann, dass die lokale Übermittlungswarteschlange in Exchange die Übermittlung von Nachrichten beendet, da Exchange OLE DB auf einen Rückruf von der ERM-Ereignissenke wartet. Microsoft Exchange OLEDB wartet darauf, dass die Ereignissenke ERME2KAsyncSink.dll von dem OnSyncSave-Aufruf zurückkehrt, während das Herunterfahren des Exchange-Informationsspeichers in Bearbeitung ist.

Durch einen Fehler beim Zurückkehren aus diesem Aufruf kann der Exchange-Informationsspeicher eventuell nicht vollständig heruntergefahren werden. In ERM Version 1.35 ist dieses Problem behoben.

So beheben Sie diese Warnmeldung

  1. Verwenden Sie Software, um ERM Version 1.2 manuell zu entfernen.

  2. Installieren Sie ERM Version 1.35. Diese Version ist auf der Website von Simpler-Webb verfügbar (http://www.swinc.com/products/ERM/upgrade/).

    Hinweis:
    Die Informationen zur Website des Drittanbieters in diesem Thema werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.


Sybari Antigen 7,5 für Microsoft Exchange Update für Exchange verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungswert, um zu bestimmen, ob eine VSAPI-Bibliothek (Virus Scanning Application Programming Interface) im Microsoft Exchange-Informationsspeicherdienst registriert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Antigen 7,5 für Microsoft Exchange ist ein Produkt von Sybari. Wenn Antigen 7.5 für Microsoft Exchange unter Exchange 2000 Server oder Exchange Server 2003 installiert wird, lautet der Wert des Registrierungseintrags der Bibliothek ANTIGENVSAPI.DLL. Diese Bibliotheksdatei führt mehrere VSAPI-bezogene Funktionen in Antigen 7.5 für Microsoft Exchange aus.

Exchange Server Analyzer fragt außerdem die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) CIM_Datafile ab, um den Wert des Schlüssels Version für ANTIGENVSAPI.DLL zu bestimmen. Wenn der Wert für den Schlüssel Version angibt, dass die Build-Nummer für diese Datei kleiner als 1316 ist, wird eine Warnung angezeigt.

Ist die Versionsnummer für ANTIGENVSAPI.DLL kleiner als 1316, ist dies ein Hinweis darauf, dass die neueste Version von Antigen 7.5 für Microsoft Exchange nicht installiert ist. Auf der Website von Sybari ist aktualisierte Software für Antigen 7.5 für Microsoft Exchange erhältlich. Es wird dringend empfohlen, diese Aktualisierung anzuwenden. Sie erhöht die Gesamtleistung und Zuverlässigkeit.

So beheben Sie diese Warnung

  1. Besuchen Sie die Website von Sybari: „Licensed Download Center" (http://www.sybari.com/portal/alias__Rainbow/lang__en-US/tabID__3359/DesktopDefault.aspx).

    Hinweis:
    Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführte Website nicht aufrufen.

  2. Downloaden Sie die neueste Aktualisierung Ihrer Version von Antigen 7.5 für Microsoft Exchange.

  3. Nehmen Sie eine vollständige Sicherung des Exchange Server-Computers vor.

  4. Installieren Sie die neueste Aktualisierung für Antigen 7.5 für Microsoft Exchange.

Weitere Informationen zum Verwenden von Antivirussoftware mit Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 328841, „Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841).

  • 823166, „Überblick über ExchangeServer 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie auf der Exchange Server Partners: Antivirus-Website (http://go.microsoft.com/fwlink/?linkid=16226).


Sybari Antigen 8,0 für Microsoft Exchange Update für Exchange verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2006-01-09

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungswert, um zu bestimmen, ob eine VSAPI-Bibliothek (Virus Scanning Application Programming Interface) im Microsoft Exchange-Informationsspeicherdienst registriert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Antigen 8.0 fu¨r Microsoft Exchange ist ein Produkt von Sybari. Wenn Antigen 8.0 fu¨r Microsoft Exchange unter Exchange 2000 Server oder Exchange Server 2003 installiert wird, lautet der Wert des Registrierungseintrags der Bibliothek ANTIGENVSAPIEx.DLL. Diese Bibliotheksdatei fu¨hrt mehrere VSAPI-bezogene Funktionen in Antigen 8.0 fu¨r Microsoft Exchange aus.

Exchange Server Analyzer fragt außerdem die Microsoft Windows®-Verwaltungsinstrumentationsklasse (Windows® Management Instrumentation, WMI) CIM_Datafile ab, um den Wert des Schlu¨ssels Version fu¨r ANTIGENVSAPI.DLL zu bestimmen. Wenn der Wert fu¨r den Schlu¨ssel Version angibt, dass die Buildnummer fu¨r diese Datei kleiner als 1517 ist, wird eine Warnung angezeigt.

Ist die Versionsnummer fu¨r ANTIGENVSAPI.DLL kleiner als 1517, ist dies ein Hinweis darauf, dass die neueste Version von Antigen 8.0 fu¨r Microsoft Exchange nicht installiert ist. Auf der Website von Sybari ist aktualisierte Software fu¨r Antigen 8.0 fu¨r Microsoft Exchange erha¨ltlich. Es wird dringend empfohlen, diese Aktualisierung anzuwenden. Sie erho¨ht die Gesamtleistung und Zuverla¨ssigkeit.

So beheben Sie diese Warnmeldung

  1. Besuchen Sie die Website von Sybari: „Licensed Download Center" (http://www.sybari.com/portal/alias__Rainbow/lang__en-US/tabID__3359/DesktopDefault.aspx).

    Hinweis:
    Webadressen ko¨nnen sich a¨ndern. Mo¨glicherweise ko¨nnen Sie deshalb die hier aufgefu¨hrte Website nicht aufrufen.

  2. Downloaden Sie die neueste Aktualisierung Ihrer Version von Antigen 8.0 fu¨r Microsoft Exchange.

  3. Nehmen Sie eine vollsta¨ndige Sicherung des Exchange Server-Computers vor.

  4. Installieren Sie die neueste Aktualisierung fu¨r Antigen 8.0 fu¨r Microsoft Exchange.

Weitere Informationen zum Verwenden von Antivirussoftware mit Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 328841, „Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841).

  • 823166, „U¨berblick u¨ber Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen fu¨r die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Eine Liste mit Antivirussoftware von Drittanbietern, die fu¨r Exchange Server verfu¨gbar ist, finden Sie bei den Exchange Server-Partnern: Website von Antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Auf diesem Exchange-Server ist Sybari Antigen installiert, der AntigenStore-Dienst wird jedoch nicht ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Service ab, um zu ermitteln, ob Sybari Antigen installiert ist und der Dienst AntigenStore auf dem Exchange Server-Computer ausgeführt wird.

Exchange Server Analyzer fragt die WMI-Klasse Win32_Service auch ab, um zu ermitteln, ob der für den Schlüssel Started im Microsoft Exchange-Informationsspeicherdienst festgelegte Wert auf True oder False festgelegt ist.

Der Wert False gibt an, dass der Microsoft Exchange-Informationsspeicherdienst auf diesem Exchange Server-Computer nicht ausgeführt wird. Der Wert True gibt an, dass der Microsoft-Informationsspeicherdienst ausgeführt wird.

Wenn Exchange Server Analyzer feststellt, dass der Microsoft Exchange-Informationsspeicherdienst ausgeführt wird und Sybari Antigen installiert ist, der Dienst AntigenStore jedoch nicht gestartet wurde, wird eine Warnung angezeigt.

Sybari Antigen bietet Virenschutz für Exchange Server. Hier werden einige der Gründe, die zum Abbruch des Sybari-Diensts AntigenStore geführt haben können, mit den zugehörigen Lösungen aufgelistet.

  • Bei der Software, die Sie auf dem Exchange Server ausführen, handelt es sich möglicherweise um eine Evaluierungsversion (oder Testversion), die inzwischen abgelaufen ist. In diesem Fall muss Sybari Antigen möglicherweise neu installiert werden. Sie müssen aber zumindest die Software aktivieren, um mit ihr weiter arbeiten zu können.

  • Der Sybari Antigen-Dienst wurde möglicherweise versehentlich von einem Administrator angehalten. Überprüfen Sie, ob der Dienst so eingerichtet ist, dass er automatisch gestartet wird, und starten Sie dann den Dienst.

  • Der Dienst wurde möglicherweise durch einen bösartigen Wurm, einen Virus oder ein anderes Programm angehalten. Überprüfen Sie, ob der Dienst so festgelegt ist, dass er automatisch startet, und starten Sie dann den Dienst. Wenn der Dienst weiterhin unerwartet und ohne relevante Fehlerereignisse anhält, prüfen Sie, ob der Computer mit einem bösartigen Wurm infiziert ist, und desinfizieren Sie gegebenenfalls das System.

Es wird im Allgemeinen empfohlen, Antivirussoftware bereitzustellen, die für Sofortnachrichtensysteme auf dem SMTP-Gateway (Simple Mail Transfer Protocol) oder auf Exchange-Servern entwickelt wurde, auf denen sich Postfächer befinden. Den höchsten Schutz erhalten Sie, wenn Sie eine Antivirussoftware am Gateway ausführen, das die eingehenden MIME-Nachrichten überprüft, und mit einem Prüfprogramm auf dem Exchange-Server mit VSAPI 2.5. Zusätzlich sollten Sie eine Client-Antivirussoftware auf dem Desktop des Benutzers ausführen. Wenn Sie die für Sofortnachrichtensysteme entwickelte Antivirussoftware (d. h. Software, die MIME analysieren und überprüfen kann) am Gateway oder auf dem Exchange-Server ausführen, reicht es aus, auf dem Desktop ein Virenprüfprogramm auf Dateiebene auszuführen.

So starten Sie den Dienst „AntigenStore"

  1. Öffnen Sie das Dienste-MMC-Snap-In.

  2. Klicken Sie mit der rechten Maustaste auf den Dienst AntigenStore, und klicken Sie dann auf Eigenschaften.

  3. Vergewissern Sie sich, dass auf der Eigenschaftenseite AntigenStore auf der Registerkarte Allgemein die Option Starttyp auf Automatisch festgelegt ist. Legen Sie andernfalls die Option auf Automatisch fest, klicken Sie auf Übernehmen und dann auf OK.

  4. Klicken Sie mit der rechten Maustaste auf den Dienst AntigenStore, und klicken Sie dann auf Start.

  5. Schließen Sie das Dienste-Snap-In.

Informationen zum Schutz von Exchange-Umgebungen vor durch E-Mail-Nachrichten übertragenen Viren und Würmern finden Sie unter „Behindern und Blockieren von E-Mail-Viren in einer Exchange 2003-Umgebung" (http://go.microsoft.com/fwlink/?LinkId=47587).

Weitere Informationen zum Verwenden von Antivirussoftware mit Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 328841, „XADM: Exchange und Antivirus-Software" (http://support.microsoft.com/?scid=kb%3Bde%3B328841&x=8&y=10).

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://support.microsoft.com/kb/823166/de).

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105).

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://support.microsoft.com/kb/245822/de).

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie auf der Website Exchange Server-Partners: Antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Auf diesem Exchange-Server wurde Sybari Antigen installiert, der Dienst wurde jedoch angehalten.
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Windows® Management Instrumentation) Win32_Service ab, um zu ermitteln, ob Sybari Antigen installiert ist und der Dienst AntigenService auf dem Exchange Server-Computer ausgeführt wird.

Exchange Server Analyzer fragt die WMI-Klasse Win32_Service auch ab, um zu ermitteln, ob der für den Schlüssel Started im Microsoft Exchange-Informationsspeicherdienst festgelegte Wert auf True oder False festgelegt ist.

Der Wert False gibt an, dass der Microsoft Exchange-Informationsspeicherdienst auf diesem Exchange Server-Computer nicht ausgeführt wird. Der Wert True gibt an, dass der Microsoft-Informationsspeicherdienst ausgeführt wird.

Wenn Exchange Server Analyzer feststellt, dass der Microsoft Exchange-Informationsspeicherdienst ausgeführt wird und Sybari Antigen installiert ist, der Dienst AntigenService jedoch nicht gestartet wurde, wird eine Warnung angezeigt.

Sybari Antigen bietet Virenschutz für Exchange Server. Im Folgenden werden einige Ursachen für das Anhalten des Sybari Antigen-Dienstes mit zugehörigen Lösungsmöglichkeiten aufgeführt:

  • Bei der auf dem Exchange-Server ausgeführten Software handelt es sich möglicherweise um eine Evaluierungsversion (oder Testversion), die inzwischen abgelaufen ist. In diesem Fall muss Sybari Antigen möglicherweise neu installiert werden. Die Software muss jedoch mindestens aktiviert werden, um mit ihr weiter arbeiten zu können.

  • Der Sybari Antigen-Dienst wurde möglicherweise versehentlich von einem Administrator angehalten. Überprüfen Sie, ob der Dienst so eingerichtet ist, dass er automatisch gestartet wird, und starten Sie dann den Dienst.

  • Der Dienst wurde möglicherweise durch einen bösartigen Wurm, ein Virus oder ein anderes Programm angehalten. Überprüfen Sie, ob der Dienst so festgelegt ist, dass er automatisch startet, und starten Sie dann den Dienst. Wenn der Dienst weiterhin unerwartet und ohne relevante Fehlerereignisse anhält, prüfen Sie, ob der Computer mit einem bösartigen Wurm infiziert ist, und desinfizieren Sie gegebenenfalls das System.

Es wird im Allgemeinen empfohlen, Antivirus-Software bereitzustellen, die für Messaging-Systeme am SMTP-Gateway (Simple Mail Transfer Protocol) oder auf Exchange-Servern entwickelt wurde, auf denen sich Postfächer befinden. Den größtmöglichen Schutz erhalten Sie, wenn Sie eine Antivirus-Software an einem Gateway ausführen, das die eingehenden MIME-Nachrichten überprüft, und wenn Sie ein Prüfprogramm auf dem Exchange-Server ausführen, der VSAPI 2.5 verwendet. Darüber hinaus empfiehlt es sich, Antivirus-Software auf den Client-Computern auszuführen. Wenn Sie die für Messaging-Systeme entwickelte Antivirus-Software (d.h. Software, die MIME analysieren und überprüfen kann) am Gateway oder auf dem Exchange-Server ausführen, reicht es aus, auf dem Desktop ein Virenprüfprogramm auf Dateiebene auszuführen.

So starten Sie den Dienst AntigenService

  1. Öffnen Sie das MMC-Snap-In Dienste.

  2. Klicken Sie mit der rechten Maustaste auf den Dienst AntigenService, und klicken Sie dann auf Eigenschaften.

  3. Vergewissern Sie sich, dass auf der Eigenschaftenseite AntigenService auf der Registerkarte Allgemein die Option Starttyp auf Automatisch festgelegt ist. Wenn dies nicht der Fall ist, legen Sie die Option auf Automatisch fest, klicken Sie auf Übernehmen und dann auf OK.

  4. Klicken Sie mit der rechten Maustaste auf den Dienst AntigenService, und klicken Sie dann auf Start.

  5. Schließen Sie das Snap-In Dienste.
  • Weitere Informationen zum Schutz von Exchange-Umgebungen vor durch E-Mails übertragenen Viren und Würmern finden Sie unter „Behindern und Blockieren von E-Mail-Viren in einer Exchange 2003-Umgebung" (http://go.microsoft.com/fwlink/?LinkId=47587).

Weitere Informationen zum Verwenden von Antivirus-Software mit Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 328841, „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie auf der Website Exchange Server-Partners: Antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Die Symantec Antivirus-Definitionen wurden seit mehr als 30 Tagen nicht aktualisiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die folgenden Bedingungen erfüllt werden:

  • Symantec Antivirus ist auf dem Server installiert.

  • Die folgenden Antivirus-Definitionsdateien sind aktualisiert:

    HKEY_LOCAL_MACHINE\Software\Symantec\SharedDefs\MicroDefs

Wenn Exchange Server Analyzer feststellt, dass der Datenwert für den Registrierungsschlüssel BinHubStamp seit mehr als 30 Tagen nicht aktualisiert wurde, zeigt Microsoft Exchange Server Analyzer eine Warnung an.

Symantec Antivirus für Microsoft Exchange Server stellt Virenschutz für Exchange Server bereit. Es wird empfohlen, die neuste Symantec Antivirus-Definition gleich nach der Veröffentlichung zu downloaden. Stellen Sie sicher, dass Sie die Aktualisierung der Antivirus-Definition auf den folgenden Ebenen der Organisation bereitstellen:

  • Nachrichten-Gatewayserver

  • Exchange-Server

  • Client-Workstations

Downloaden Sie die neuesten Virusdefinitionen von der Symantec Antivirus-Website, der Homepage von Symantec unter http://www.symantec.com.

Weitere Informationen zum Schutz von Exchange-Umgebungen vor durch E-Mails übertragenen Viren und Würmern finden Sie unter „Behindern und Blockieren von E-Mail-Viren in einer Exchange 2003-Umgebung" (http://go.microsoft.com/fwlink/?LinkId=47587).

Weitere Informationen zum Verwenden von Antivirussoftware mit Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 328841, „Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841).

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie auf der Website Exchange Server-Partners: Antivirus (http://go.microsoft.com/fwlink/?linkid=16226).

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.


Auf diesem Exchange-Server wurde „Symantec Antivirus" installiert, der Dienst wurde jedoch angehalten
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_Service ab, um zu ermitteln, ob für den Schlüssel Started ein Wert festgelegt wurde. Die Klasse Win32_Service ermittelt, ob Symantec Antivirus für Exchange Server installiert ist. Der Wert True für den Schlüssel Started gibt an, dass der Symantec Antivirus-Dienst auf diesem Exchange Server-Computer ausgeführt wird. Der Wert False für den Schlüssel Started gibt an, dass der Symantec Antivirus-Dienst auf diesem Exchange Server-Computer nicht ausgeführt wird.

Wenn Exchange Server Analyzer feststellt, dass Symantec Antivirus auf diesem Exchange Server-Computer installiert ist, der Symantec Antivirus-Dienst jedoch nicht gestartet wurde, zeigt Exchange Server Analyzer eine Warnung an.

Symantec Antivirus bietet Virenschutz für Exchange Server. Im Folgenden werden einige Gründe, die zum Abbruch des Symantec Antivirus-Dienstes geführt haben können, sowie mögliche Lösungen aufgeführt.

  • Bei der Software, die auf dem Exchange Server ausgeführt wird, handelt es sich möglicherweise um eine abgelaufene Evaluierungs- oder Testversion. In diesem Fall müssen Sie möglicherweise Symantec Antivirus neu installieren. Sie müssen aber zumindest die Software aktivieren, um mit ihr weiter arbeiten zu können.

  • Der Symantec Antivirus-Dienst wurde möglicherweise versehentlich von einem Administrator angehalten. Überprüfen Sie, ob der Dienst so eingerichtet ist, dass er automatisch gestartet wird, und starten Sie dann den Dienst.

  • Der Dienst wurde möglicherweise durch einen bösartigen Wurm, einen Virus oder ein anderes Programm angehalten. Überprüfen Sie, ob der Dienst so festgelegt ist, dass er automatisch startet, und starten Sie dann den Dienst. Wenn der Dienst weiterhin unerwartet und ohne relevante Fehlerereignisse anhält, prüfen Sie, ob der Computer mit einem bösartigen Wurm infiziert ist, und entfernen Sie gegebenenfalls den Wurm.

Es wird empfohlen, Antivirussoftware bereitzustellen, die für Messagingsysteme auf dem SMTP-Gateway (Simple Mail Transfer Protocol) oder auf Exchange-Servern entwickelt wurde, auf denen Postfächer gehostet werden. Den höchsten Schutz erhalten Sie, wenn Sie eine Antivirussoftware am Gateway, das die eingehenden MIME-Nachrichten überprüft, und ein Prüfprogramm auf dem Exchange-Server mit VSAPI 2.5 ausführen.

So starten Sie den Symantec Antivirus-Dienst

  1. Öffnen Sie das MMC-Snap-In Dienste.

  2. Klicken Sie mit der rechten Maustaste auf den Dienst Symantec Antivirus, und klicken Sie dann auf Eigenschaften.

  3. Vergewissern Sie sich, dass auf der Eigenschaftenseite von Symantec Antivirus auf der Registerkarte Allgemein für Starttyp die Option Automatisch festgelegt ist. Wenn dies nicht zutrifft, klicken Sie auf Übernehmen und dann auf OK.

  4. Klicken Sie mit der rechten Maustaste auf den Dienst Symantec Antivirus, und klicken Sie dann auf Starten.

  5. Schließen Sie das Snap-In Dienste.

Zusätzlich sollten Sie eine Client-Antivirussoftware auf dem Desktop des Benutzers ausführen. Virenprüfsoftware auf Dateiebene auf dem Desktop stellt ausreichenden Schutz bereit, wenn eine der folgenden Bedingung zutrifft:

  • Sie führen eine für Messaging-Systeme entwickelte Antivirussoftware aus, die MIME auf dem Gateway analysieren und überprüfen kann.

  • Sie führen eine für Messaging-Systeme entwickelte Antivirussoftware aus, die MIME auf dem Exchange-Server analysieren und überprüfen kann.

Weitere Informationen zu den verschiedenen mit Microsoft Exchange Server 2003 üblicherweise verwendeten Virenprüfprogrammen finden Sie im Microsoft Knowledge Base-Artikel 823166 „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Weitere Informationen zu den verschiedenen in Microsoft Exchange 2000 Server üblicherweise verwendeten Virenprüfprogrammen finden Sie im Knowledge Base-Artikel 328841, „XADM: Exchange und Antivirus-Software" unter http://support.microsoft.com/?scid=kb%3Bde%3B328841&x=13&y=12.

Informationen zum Schutz von Exchange Server-Umgebungen vor durch E-Mails übertragenen Viren und Würmern finden Sie unter „Behindern und Blockieren von E-Mail-Viren in einer Exchange 2003-Umgebung" (http://go.microsoft.com/fwlink/?LinkId=47587).


Symantec Mail Security für Virenprüfungs-Konfigurationswarnungen in Exchange.
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_Service ab, um zu bestimmen, ob der Wert für den Schlüssel Started für den Dienst SMSMSE (Symantec Mail Security für Microsoft Exchange) festgelegt ist.

Der Wert True zeigt an, dass Symantec Mail Security für Microsoft Exchange Server auf diesem Exchange Server-Computer installiert ist und dass der Dienst SMSMSE ausgeführt wird. Der Wert False gibt an, dass der Dienst SMSMSE nicht ausgeführt wird.

Exchange Server Analyzer fragt die WMI-Klasse Win32_Service auch ab, um zu ermitteln, ob der für den Schlüssel Started im Microsoft Exchange-Informationsspeicherdienst festgelegte Wert auf True oder False festgelegt ist.

Der Wert False gibt an, dass der Microsoft Exchange-Informationsspeicherdienst auf diesem Exchange Server-Computer nicht ausgeführt wird. Der Wert True gibt an, dass der Microsoft-Informationsspeicherdienst ausgeführt wird.

Wenn Exchange Server Analyzer feststellt, dass der Microsoft Exchange-Informationsspeicherdienst ausgeführt wird und dass Symantec Mail Security für Microsoft Exchange installiert ist, aber der Dienst SMSMSE nicht ausgeführt wird, wird eine Warnung angezeigt.

Durch E-Mail-Nachrichten übermittelte Viren stellen eine wesentliche Bedrohung für Ihre Umgebung dar. E-Mail-Viren greifen u. U. die Computersysteme selbst oder die E-Mail-Umgebung an, indem sie das System mit Nachrichten überlasten. Daher müssen Sie einen ausreichenden Schutz gegen Viren in Ihrer Umgebung gewährleisten. Sie sollten einen Virenschutz an der Firewall, am bzw. außerhalb des SMTP-Gateways, auf jedem Exchange-Server und auf jedem Client gewährleisten.

So beheben Sie diese Warnmeldung

  1. Starten Sie das Windows Snap-In Dienste auf dem Exchange Server-Computer.

  2. Führen Sie im rechten Bereich einen Bildlauf bis zum Dienst Symantec Mail Security für Microsoft Exchange durch, und doppelklicken Sie darauf.

  3. Vergewissern Sie sich, dass der Wert im Dropdownfeld Starttyp auf Automatisch festgelegt ist.

  4. Klicken Sie auf Start, um den Dienst Symantec Mail Security für Microsoft Exchange zu starten.

  5. Klicken Sie auf OK, um die Änderungen zu speichern. Schließen Sie das Dialogfeld Eigenschaften, und verlassen Sie dann das Snap-In.

Informationen zum Schutz von Exchange-Umgebungen vor durch E-Mail-Nachrichten übertragenen Viren und Würmern finden Sie unter „Behindern und Blockieren von E-Mail-Viren in einer Exchange 2003-Umgebung" (http://go.microsoft.com/fwlink/?LinkId=47587).

Weitere Informationen zum Verwenden von Antivirus-Software mit Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 328841, „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie auf der Website Exchange Server-Partners: Antivirus-Website (http://go.microsoft.com/fwlink/?linkid=16226).


Aktualisierung für Symantec Mail Security für Microsoft Exchange 4.5 verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2006-02-14

Microsoft® Exchange Server Analyzer fragt die Microsoft Windows®-Verwaltungsinstrumentationsklasse (Windows® Management Instrumentation, WMI) CIM_Datafile ab, um den Wert des Schlüssels Version für Savfmsevsapi.dll zu ermitteln. Wenn der Wert für den Schlüssel Version angibt, dass die Buildnummer für diese Datei kleiner als 4.5 ist, wird eine Warnung angezeigt.

Eine Versionsnummer von 4.5 für Savfmsevsapi.dll zeigt an, dass nicht die aktuellste Version von Symantec Mail Security for Microsoft Exchange 4.6x ausgeführt wird. Auf der Symantec-Website steht eine Softwareaktualisierung für Symantec Mail Security for Microsoft Exchange 4.6x zur Verfügung. Es wird dringend empfohlen, auf die Version 4.63 oder höhere Versionen zu aktualisieren, da sich die Gesamtleistung und -zuverlässigkeit dadurch verbessern können.

Im Folgenden werden bekannte Probleme aufgeführt, die beim Ausführen der Version 4.5 von Savfmsevsapi.dll auftreten können.

  • Bei Mailflowprozessen von Exchange Server kann es während ganz normaler Vorgänge zu einem Abfall in der Leistung kommen.

  • SMTP-Warteschlangen wie die Verzeichnissuche-Warteschlange und die Warteschlange für die lokale Übermittlung werden gesichert.

  • Der Microsoft Exchange-Informationsspeicherdienst kann nicht beendet werden.

  • Microsoft Outlook®-Clients können keine Verbindung mit dem Exchange-Server herstellen.

  • Von Outlook-Clients gesendete Nachrichten benötigen wesentlich mehr Zeit, als gewöhnlich zum Übermitteln einer Nachricht an den Exchange-Server notwendig ist. Outlook-Clients reagieren möglicherweise für einen Zeitraum von 30 Sekunden nicht mehr.

So beheben Sie dieses Problem

  1. Besuchen Sie auf der Symantec-Website die Seite „Enterprise Support" (http://www.symantec.com/techsupp/enterprise/).

  2. Aktualisieren Sie auf Version 4.63 oder eine höhere Version.
Hinweis:
Die Informationen zur Website des Drittanbieters in diesem Thema werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.

Weitere Informationen zum Verwenden von Antivirussoftware mit Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 328841, „Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841).

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsofts Standpunkt zu Antiviruslösungen für Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105).

  • 245822, „Empfehlungen fu¨r die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Eine Liste mit Antivirussoftware von Drittanbietern, die fu¨r Exchange Server verfu¨gbar ist, finden Sie bei Exchange Server Partners: Antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Trend Micro ScanMail für Microsoft Exchange-Aktualisierung verfügbar.
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2006-01-09

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungswert, um zu ermitteln, ob eine VSAPI-Bibliotheksdatei (Virus Scanning Application Programming Interface) im Microsoft Exchange-Informationsspeicher registriert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Wenn ScanMail fu¨r Microsoft Exchange (ein Produkt von Trend Micro) unter Exchange 2000 Server oder Exchange Server 2003 installiert ist, lautet der Wert des Registrierungseintrags der Bibliothek SMXS3DLL.DLL. Diese Bibliotheksdatei fu¨hrt mehrere VSAPI-bezogene Funktionen in ScanMail fu¨r Microsoft Exchange aus.

Exchange Server Analyzer fragt außerdem die Microsoft Windows®-Verwaltungsinstrumentationsklasse (Windows® Management Instrumentation, WMI) CIM_Datafile ab, um den Wert des Schlu¨ssels Version fu¨r SMXS3DLL.DLL zu ermitteln. Wenn der Wert fu¨r den Schlu¨ssel Version angibt, dass die Buildnummer fu¨r diese Datei kleiner als 1174 ist, wird eine Warnung angezeigt.

Ist die Versionsnummer fu¨r SMXS3DLL.DLL kleiner als 1174, ist dies ein Hinweis darauf, dass die neueste Version von ScanMail fu¨r Microsoft Exchange nicht installiert ist. Auf der Website von Trend Micro ist aktualisierte Software fu¨r Scan Mail fu¨r Microsoft Exchange erha¨ltlich. Es wird dringend empfohlen, diese Aktualisierung anzuwenden. Sie erho¨ht die Gesamtleistung und Zuverla¨ssigkeit.

So beheben Sie diese Warnmeldung

  1. Besuchen Sie die Trend Micro-Website „Update Center, ScanMail for Microsoft Exchange" unter http://www.trendmicro.com/download/product.asp?productid=8.

  2. Downloaden Sie die neueste Aktualisierung Ihrer Version von ScanMail fu¨r Microsoft Exchange.

  3. Nehmen Sie eine vollsta¨ndige Sicherung des Exchange Server-Computers vor.

  4. Installieren Sie die neueste Aktualisierung fu¨r ScanMail fu¨r Microsoft Exchange.

Weitere Informationen zum Verwenden von Antivirus-Software mit Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 328841, „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, „U¨berblick u¨ber Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen fu¨r die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Eine Liste mit Antivirussoftware von Drittanbietern, die fu¨r Exchange Server verfu¨gbar ist, finden Sie auf der Exchange Server Partners: Antivirus-Website (http://go.microsoft.com/fwlink/?linkid=16226).


Trend Micro ServerProtect für Microsoft Windows wird beendet.
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Microsoft Windows Management Instrumentation) Win32_Service ab, um den Wert des Schlüssels Started für den SpntSvc-Dienst zu bestimmen. Der SpntSvc-Dienst wird von ServerProtect für Microsoft Windows installiert, einem Produkt von Trend Micro. Der Wert True für den Schlüssel Started gibt an, dass der Dienst ausführt wird, und der Wert False gibt an, dass der Dienst nicht ausgeführt wird. Wenn Exchange Server Analyzer feststellt, dass der Dienst SpntSvc nicht gestartet wurde, wird eine Warnung angezeigt.

ServerProtect für Microsoft Windows bietet dateisystembasierte Antivirusprüfungen für Server, einschließlich der Erkennung und Entfernung von Viren in Echtzeit.

So starten Sie den Dienst SpntSvc

  1. Öffnen Sie das MMC-Snap-In Dienste.

  2. Klicken Sie mit der rechten Maustaste auf den Dienst ServerProtect Server, und klicken Sie dann auf Eigenschaften.

  3. Vergewissern Sie sich auf der Registerkarte General der Eigenschaftenseite von ServerProtect Server, dass Start-up type auf Automatic festgelegt ist. Wenn dies nicht der Fall ist, legen Sie die Option auf Automatic fest, klicken Sie auf Apply und dann auf OK.

  4. Klicken Sie mit der rechten Maustaste auf ServerProtect Server, und klicken Sie dann auf Starten.

  5. Schließen Sie das Snap-In Dienste.

Weitere Informationen zum Verwenden von Antivirus-Software mit Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 328841, „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie auf der Website Exchange Server-Partners: Website von Antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Trend ScanMail-Konfiguration: Leistung kann möglicherweise gesteigert werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2006-09-05

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um den Wert für TempFileThreshold zu bestimmen:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

Der Registrierungswert TempFileThreshold kann auf die Überprüfung des Nachrichtentexts und der Anlagen angewendet werden. Wenn die Größe des Nachrichtentexts oder der Anlage größer als der im Schlüssel TempFileThreshold angegebene Wert ist, wird die temporäre Datei auf der Festplatte erstellt. Andernfalls wird sie im Speicher erstellt. Der Standardwert für TempFileThreshold beträgt 3.072 KB (3 MB).

Exchange Server Analyzer fragt außerdem die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_ComputerSystem ab, um den festgelegten Wert für den Schlüssel TotalPhysicalMemory zu bestimmen. Dieser Wert stellt die Größe des auf dem Computer installierten Arbeitsspeichers (RAM) dar.

Microsoft® Exchange Server Analyzer fragt auch den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs delivContLength für die allgemeinen Einstellungen zu bestimmen. Dieser ist unter dem folgenden Pfad gespeichert:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN= OrganisationsName , CN=Global Settings, CN=Message Delivery

Dieses Attribut stellt die maximale Größe eingehender SMTP-Nachrichten dar.

Wenn Exchange Server Analyzer feststellt, dass der Wert von TempFileThreshold weniger als 70 % der maximalen Größe der eingehenden Nachrichten auf einem Exchange Server-Computer mit mindestens 1 GB RAM beträgt, wird eine Warnung angezeigt.

Diese Warnung gibt an, dass der Registrierungswert TempFileThreshold möglicherweise nicht für Ihre Umgebung optimiert ist. Dieser Wert sollte zumindest gleich dem Grenzwert der Anlagengröße sein, den Sie auf Ihren Exchange-Servern festgelegt haben.

Hinweis:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema "Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\Software\TrendMicro\ScanMail für Exchange\RealTimeScan\ScanOption

  3. Doppelklicken Sie im rechten Bereich auf TempFileThreshold.

  4. Geben Sie einen Wert in KB ein, der der durchschnittlichen Nachrichtengröße in Ihrer Organisation entspricht. Wenn z. B. die durchschnittliche Nachrichtengröße 10 MB beträgt, geben Sie "10240" ein.
Hinweis:
Wird dieser Wert erhöht, ist ggf. zusätzlicher Systemspeicher erforderlich. Wenn beispielsweise der Wert ScanningThreads auf 8 und der Wert TempFileThreshold auf 10240 gesetzt wird, werden für die Virensuche mindestens 80 MB Speicher benötigt (ScanningThreads * TempFileThreshold).
  1. Schließen Sie den Registrierungs-Editor, und starten Sie die Dienste ScanMail_RealTimeScan und Microsoft Exchange-Informationsspeicher neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, "Beschreibung der Microsoft Windows-Registrierung" (http://support.microsoft.com/kb/256986/DE/).


Trend ScanMail-Konfiguration: Der Registrierungswert „QuerySender" ist aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2006-04-20

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_Service ab, um den Wert des Schlüssels Started für Trend Micro ScanMail für den Microsoft Exchange-Dienst ScanMail_Action zu bestimmen. Der Wert True gibt an, dass der Dienst ScanMail_Action ausgeführt wird, und der Wert False gibt an, dass er nicht ausgeführt wird.

Microsoft Exchange Server Analyzer liest auch den folgenden Registrierungseintrag, um zu bestimmen, ob ScanMail für Microsoft Exchange für die Suche mit Platzhaltern im Active Directory®-Verzeichnisdienst konfiguriert ist:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\QuerySender

Der Wert 0 für den Registrierungseintrag QuerySender gibt an, dass die Platzhaltersuche deaktiviert ist. Der Wert 1 für den Eintrag QuerySender gibt an, dass die Platzhaltersuche aktiviert ist.

Exchange Server Analyzer fragt außerdem Active Directory ab, um die Anzahl der Einträge zu ermitteln, die im Attribut homeMDBBL der einzelnen Postfachspeicher aufgelistet sind. Der Zählwert dieses Attributs stellt die Zahl der Postfächer im Postfachspeicher dar.

Wenn Exchange Server Analyzer feststellt, dass der Dienst ScanMail_Action ausgeführt wird, dass der Computer mit Exchange Server mehr als 100 Postfächer enthält und dass der Registrierungseintrag QuerySender nicht auf 0 festgelegt ist, wird eine Warnung angezeigt.

Trend Micro ScanMail für Microsoft Exchange stellt Virenschutz für Exchange Server bereit. Wenn ScanMail für Exchange eine an eine Verteilerliste gesendete Nachricht scannt, wird in der Standardeinstellung der globale Active Directory-Katalog für alle Nachrichtenempfänger abgefragt. Wenn sich in der Verteilerliste eine große Anzahl von Empfängern befindet, kann durch dieses Verhalten die Leistung beeinträchtigt werden. Außerdem nehmen die folgenden Leistungsindikatoren hohe Werte an, wenn die Empfehlungen in diesem Artikel nicht implementiert werden:

  • Warteschlangenlänge für das Scannen von MSExchangeIS/Virus

  • Anforderungen von MSExchangeIS/RPC

  • Durchschnittliche Wartezeit für MSExchangeIS/RPC

Das Festlegen des Werts von QuerySender auf 0 verhindert, dass ScanMail für Microsoft Exchange beim Scannen von an Verteilerlisten gesendeten Nachrichten den globalen Katalog für alle Empfänger abfragt.

So beheben Sie diese Warnmeldung

  1. Wenden Sie sich für Informationen zur Verwendung des Registrierungswerts QuerySender an Trend Micro unter http://www.trendmicro.com/en/about/overview.htm.

  2. Weitere Informationen zum Registrierungswert QuerySender finden Sie in Trend Micro Solution ID 120393 (http://esupport.trendmicro.com/support/viewxml.do?ContentID=en-120393).

    Hinweis:
    Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.

Informationen zum Schutz von Exchange-Umgebungen vor durch E-Mails übertragenen Viren und Würmern finden Sie unter „Behindern und Blockieren von E-Mail-Viren in einer Exchange 2003-Umgebung" (http://go.microsoft.com/fwlink/?LinkId=47587).

Weitere Informationen zum Verwenden von Antivirus-Software mit Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 328841, „XADM: Exchange und Antivirus-Software" (http://support.microsoft.com/kb/328841/de)

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://support.microsoft.com/kb/823166/de)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105).

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://support.microsoft.com/default.aspx?scid=kb;de-de;Q245822)

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie auf der Website Exchange Server-Partners: Antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Konfiguration von Trend ScanMail: Der ScanMail_Monitor-Dienst ist nicht vom Clusterdienst abhängig
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2006-02-13

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag für jeden Server, der als Clusterknoten fungiert:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Ein Versionswert von 6.2.000 zeigt an, dass Version 6.2 von ScanMail for Microsoft Exchange installiert ist.

Exchange Server Analyzer fragt außerdem die Microsoft Windows®-Verwaltungsinstrumentationsklasse (Windows® Management Instrumentation, WMI) Win32_Service ab, um den Wert des Schlu¨ssels Started für ClusSvc, den Clusterdienst, zu ermitteln. Der Wert True gibt an, dass der Clusterdienst ausgeführt wird, und der Wert False gibt an, dass er nicht ausgeführt wird.

Exchange Server Analyzer liest außerdem den folgenden Registrierungseintrag für jeden Server, der als Clusterknoten fungiert:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ScanMail_Monitor

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel ScanMail_Monitor nicht den mehrwertigen Registrierungseintrag DependOnService mit einem Wert von ClusSvc enthält, besteht keine Abhängigkeit des ScanMail_Monitor-Diensts vom Clusterdienst.

Exchange Server Analyzer zeigt eine Warnmeldung an, wenn die folgenden Bedingungen zutreffen:

  • Der Server führt die Version TrendMicro ScanMail for Microsoft Exchange 6.2 aus.

  • Der Server führt den Clusterdienst (ClusSvc) aus.

  • Der ScanMail_Monitor-Dienst ist nicht für eine Abhängigkeit vom Clusterdienst konfiguriert.

Nach der Installation eines Builds von ScanMail for Microsoft Exchange 6.2 müssen Sie den ScanMail_Monitor-Dienst so konfigurieren, dass er vom Clusterdienst abhängig ist. Wenn Sie diese Abhängigkeit nicht konfigurieren, wird der Clusterdienst bei jedem Neustart des Knotens nicht mehr antworten.

So beheben Sie diese Warnung

  1. Informationen hierzu finden Sie unter „The Microsoft Exchange Cluster Service unexpectedly stops after applying ScanMail for Exchange (SMEX) 6.2 Patch 1 [Solution ID: 121441]" auf der Trend Micro-Website (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionId=21441&id=21441).

    Hinweis:
    Zwar bezieht sich der Artikel mit der Solution ID 121441 spezifisch auf die Notwendigkeit, diese Abhängigkeit nach der Installation von Patch 1 konfigurieren zu müssen, doch trifft dieser Artikel auf alle Server zu, auf denen ein beliebiger Build von ScanMail for Microsoft Exchange 6.2 ausgeführt wird.

  2. Fügen Sie der Registrierung den mehrteiligen Zeichenfolgenwert DependOnService hinzu, wie es in dem Artikel der Solution ID 121441 im Abschnitt „Solutions" angegeben ist.
Hinweis:
Die Informationen zur Website des Drittanbieters in diesem Thema werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.

Weitere Informationen zu anderen Produktaktualisierungen von Trend Micro finden Sie auf der Trend Micro Update Center-Website (http://www.trendmicro.com/download/).

Weitere Informationen zum Verwenden von Antivirussoftware mit Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 328841, „Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841).

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsofts Standpunkt zu Antiviruslösungen für Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105).

  • 245822, „Empfehlungen fu¨r die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Eine Liste mit Antivirussoftware von Drittanbietern, die fu¨r Exchange Server verfu¨gbar ist, finden Sie bei Exchange Server Partners: Antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Trend ScanMail-Konfiguration: Registrierungswert „SkipWildcardSearchInGC" ist auf 0 festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Service ab, um den Wert des Schlüssels Started für Trend Micro ScanMail für den Microsoft Exchange-Dienst ScanMail_Action zu bestimmen. Der Wert True gibt an, dass der Dienst ScanMail_Action ausgeführt wird, und der Wert False gibt an, dass er nicht ausgeführt wird.

Microsoft Exchange Server Analyzer liest auch den folgenden Registrierungseintrag, um zu bestimmen, ob ScanMail für Microsoft Exchange für die Suche mit Platzhaltern im Active Directory®-Verzeichnisdienst konfiguriert ist:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\SkipWildcardSearchInGC

Der Wert 1 für den Registrierungseintrag SkipWildcardSearchInGC gibt an, dass die Platzhaltersuche deaktiviert ist. Der Wert 0 für den Eintrag SkipWildcardSearchInGC gibt an, dass die Platzhaltersuche aktiviert ist.

Außerdem fragt Exchange Server Analyzer Active Directory ab, um die Anzahl der Einträge zu ermitteln, die im Attribut homeMDBBL der einzelnen Postfachspeicher aufgelistet sind. Der Zählwert dieses Attributs stellt die Zahl der Postfächer im Postfachspeicher dar.

Wenn Exchange Server Analyzer feststellt, dass der Dienst ScanMail_Action ausgeführt wird, der Exchange-Server mehr als 100 Postfächer enthält und der Registrierungseintrag SkipWildcardSearchInGC auf 0 festgelegt ist, wird eine Warnung angezeigt.

Trend Micro ScanMail für Microsoft Exchange stellt Virenschutz für Exchange Server bereit. Durch das Festlegen des Werts von SkipWildcardSearchInGC auf 1 wird verhindert, dass ScanMail für Microsoft Exchange einen Namen mit einem Platzhalter (*) darin auflöst. Abfragen von Namen mit einem Platzhalter darin können die Leistung des Exchange Server-Computers wesentlich verringern, weil ScanMail für Exchange das gesamte Verzeichnis durchsucht. Außerdem nehmen die folgenden Leistungsindikatoren hohe Werte an, wenn die Empfehlungen in diesem Artikel nicht implementiert werden:

  • Warteschlangenlänge für das Scannen von MSExchangeIS/Virus

  • Anforderungen von MSExchangeIS/RPC

  • Durchschnittliche Wartezeit für MSExchangeIS/RPC

So beheben Sie diese Warnmeldung

  1. Wenden Sie sich unter http://www.trendmicro.com/en/about/overview.htm an Trend Micro, um Informationen zur Verwendung des Registrierungswerts SkipWildcardSearchInGC zu erhalten.

  2. Weitere Informationen zum Registrierungswert SkipWildcardSearchInGC finden Sie in Trend Micro Solution ID 20393 (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=20393).

    Hinweis:
    Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.

Weitere Informationen zum Schutz von Exchange-Umgebungen vor durch E-Mails übertragenen Viren und Würmern finden Sie unter „Behindern und Blockieren von E-Mail-Viren in einer Exchange 2003-Umgebung" (http://go.microsoft.com/fwlink/?LinkId=47587).

Weitere Informationen zum Verwenden von Antivirus-Software mit Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 328841, „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie auf der Website Exchange Server-Partners: Antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Trend ScanMail-Konfiguration: Wert für den Registrierungseintrag „MaxMessageCount" ist kleiner als 500
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um den Wert für MaxMessageCount zu bestimmen:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion

Um die Anzahl der Einträge zu ermitteln, die im Attribut homeMDBBL jedes Postfachspeichers aufgelistet sind, fragt Exchange Server Analyzer auch den Active Directory®-Verzeichnisdienst ab. Der Zählwert dieses Attributs stellt die Zahl der Postfächer im Postfachspeicher dar.

Wenn Exchange Server Analyzer feststellt, dass der Exchange Server mehr als 100 Postfächer enthält und der Wert für MaxMessageCount weniger als 500 beträgt, wird eine Warnung angezeigt.

Trend Micro ScanMail für Microsoft Exchange stellt Virenschutz für Exchange Server bereit. Nachdem der Scanthread von ScanMail für Exchange eine Aufgabe beendet hat, schreibt er die Überprüfungsergebnisse in eine Warteschlange. Wenn es in der Warteschlange zu viele Elemente gibt, muss der Scanthread warten, bevor er in die Warteschlange schreiben und den Thread freigeben kann. Der Schwellenwert für die Größe der Überprüfungsergebnis-Warteschlage wird von MaxMessageCount gesteuert. Durch das Festlegen des Werts von MaxMessageCount auf 500 wird die Leistung von ScanMail für Exchange optimiert.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\Software\TrendMicro\ScanMail für Exchange\CurrentVersion

  3. Doppelklicken Sie im rechten Teilfenster auf MaxMessageCount.

  4. Geben Sie den Wert 500 (Dezimalwert) ein.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie die Dienste ScanMail_RealTimeScan und Microsoft Exchange-Informationsspeicher neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Weitere Informationen zur Verwendung des Registrierungswerts MaxMessageCount finden Sie auf der Website von Trend Micro unter http://www.trendmicro.com/en/about/overview.htm ein.

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.

Weitere Informationen zum Schutz von Exchange-Umgebungen vor durch E-Mails übertragenen Viren und Würmern finden Sie unter „Behindern und Blockieren von E-Mail-Viren in einer Exchange 2003-Umgebung" (http://go.microsoft.com/fwlink/?LinkId=47587).

Weitere Informationen zum Verwenden von Antivirus-Software mit Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 328841, „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie auf der Website Exchange Server-Partners: Antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Trend ScanMail ist so konfiguriert, dass alle Dateianlagen gelöscht werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest eine Reihe von Registrierungseinträgen, um zu bestimmen, ob ScanMail für Microsoft Exchange so konfiguriert ist, dass Anlagen gelöscht werden. Die gelesenen Werte befinden sich in der Registrierung an folgender Position:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption\Advance

Wert | Beschreibung
ActionType | Gibt an, welche Anlagen gesperrt werden sollen, wenn das Sperren von Anlagen aktiviert ist. Ein Wert 0 gibt an, dass alle Anlagen gesperrt werden. Der Wert 3 gibt an, dass der Administrator eine Liste von Dateinamenerweiterungen, Dateinamen oder True-File-Typen festgelegt hat. Diese Einstellung kann konfiguriert werden, indem in der ScanMail-Verwaltungskonsole im Dialogfeld Attachment Blocking Settings die entsprechende Option ausgewählt wird.
EnableAlert | Gibt an, ob das Sperren von Anlagen aktiviert ist. Ein Wert 1 gibt an, dass das Sperren von Anlagen aktiviert ist. Ein Wert 0 gibt an, dass die Funktion deaktiviert ist. Diese Einstellung kann konfiguriert werden, indem in der ScanMail-Verwaltungskonsole auf der Seite Virus Scan | Options das Kontrollkästchen Enable attachment blocking aktiviert bzw. deaktiviert wird.

HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

Wert | Beschreibung
EnableEManager | Gibt an, ob ScanMail eManager aktiviert ist. Ein Wert von 1 gibt an, dass eManager aktiviert ist. Ein Wert von 0 gibt an, dass die Funktion deaktiviert ist. Diese Einstellung kann konfiguriert werden, indem in der ScanMail-Verwaltungskonsole das Kontrollkästchen Enable eManager aktiviert bzw. deaktiviert wird. Diese Einstellung ist nur dann verfügbar, wenn ScanMail eManager installiert ist, eine separates Begleitprodukt.
EnableWebStoreDelMail | Gibt an, ob der ScanMail Active Message Filter für eingehende Nachrichten aktiviert ist. Ein Wert 1 gibt an, dass Active Message Filter für eingehende Nachrichten aktiviert ist. Ein Wert 0 gibt an, dass die Funktion für eingehende Nachrichten nicht aktiviert ist. Diese Einstellung kann konfiguriert werden, indem in der ScanMail-Verwaltungskonsole im Dialogfeld Active Message Filter das Kontrollkästchen Inbound Messages aktiviert bzw. deaktiviert wird.

Microsoft Exchange Server Analyzer liest außerdem den folgenden Registrierungseintrag, um zu bestimmen, ob das VSAPI-Nachrichtenscanning (Virus Scanning API) aktiviert ist:

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Ein Wert 1 für Enabled gibt an, dass das VSAPI-Scanning aktiviert ist. Ein Wert 0 gibt an, dass das VSAPI-Scanning nicht aktiviert ist. Diese Einstellung kann konfiguriert werden, indem in der ScanMail-Verwaltungskonsole auf der Seite Virus Scan | Options das Kontrollkästchen Enable VS API virus scanning aktiviert bzw. deaktiviert wird.

Wenn Exchange Server Analyzer feststellt, dass alle folgenden Kriterien erfüllt sind, wird eine Warnung angezeigt:

  • VSAPI-Scanning ist in ScanMail für Exchange aktiviert

  • EnableAlert hat einen Wert von 1

  • ActionType hat einen Wert von 0

  • EnableEManager hat einen Wert von 1

  • EnableWebStoreDelMail hat einen Wert von 1

Diese Warnung weist darauf hin, dass ScanMail so konfiguriert ist, dass alle Anlagen während des nächsten geplanten bzw. manuellen Scans gelöscht werden.

So beheben Sie diese Warnmeldung

  1. Überlegen Sie, ob die Anlagen tatsächlich gelöscht werden sollen.

  2. Wenn dies der Fall ist, deaktivieren Sie das Sperren von Anlagen oder ändern Sie die Aktion von Delete in Quarantine. Dadurch können Administratoren die isolierten Dateien auf Anlagen überprüfen, die möglicherweise erhalten bleiben sollen.

Weitere Informationen zu ScanMail für Microsoft Exchange und ScanMail eManager erhalten Sie auf der Trend Micro-Website unter http://www.trend.com/.

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.


Trend ScanMail ist zum Löschen von Anlagen mit bestimmten Dateinamen konfiguriert
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest eine Reihe von Registrierungseinträgen, um zu bestimmen, ob ScanMail für Microsoft Exchange so konfiguriert ist, dass Anlagen gelöscht werden. Die gelesenen Werte befinden sich in der Registrierung an folgender Position:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption\Advance

Wert | Beschreibung
ActionType | Gibt an, welche Anlagen gesperrt werden sollen, wenn das Sperren von Anlagen aktiviert ist. Ein Wert 0 gibt an, dass alle Anlagen gesperrt werden. Der Wert 3 gibt an, dass der Administrator eine Liste von Dateinamenerweiterungen, Dateinamen oder True-File-Typen festgelegt hat. Diese Einstellung kann konfiguriert werden, indem in der ScanMail-Verwaltungskonsole im Dialogfeld Attachment Blocking Settings die gewünschte Option ausgewählt wird.
EnableAlert | Gibt an, ob das Sperren von Anlagen aktiviert ist. Ein Wert 1 gibt an, dass das Sperren von Anlagen aktiviert ist. Ein Wert 0 gibt an, dass die Funktion deaktiviert ist. Diese Einstellung kann konfiguriert werden, indem in der ScanMail-Verwaltungskonsole auf der Seite Virus Scan | Options das Kontrollkästchen Enable attachment blocking aktiviert bzw. deaktiviert wird.
FileName | Ein durch Semikolons getrennter Zeichenfolgenwert mit einer Liste der zu löschenden Dateien. Wenn angegebene Dateien blockiert werden, kann diese Einstellung konfiguriert werden, indem in der ScanMail-Verwaltungskonsole im Dialogfeld Attachment Blocking Settings die gewünschten Dateinamen eingegeben werden.

HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

Wert | Beschreibung
EnableEManager | Gibt an, ob ScanMail eManager aktiviert ist. Ein Wert von 1 gibt an, dass eManager aktiviert ist. Ein Wert von 0 gibt an, dass die Funktion deaktiviert ist. Diese Einstellung kann konfiguriert werden, indem in der ScanMail-Verwaltungskonsole das Kontrollkästchen Enable eManager aktiviert bzw. deaktiviert wird. Diese Einstellung ist nur dann verfügbar, wenn ScanMail eManager installiert ist, eine separates Begleitprodukt.
EnableWebStoreDelMail | Gibt an, ob der ScanMail Active Message Filter für eingehende Nachrichten aktiviert ist. Ein Wert 1 gibt an, dass Active Message Filter für eingehende Nachrichten aktiviert ist. Ein Wert 0 gibt an, dass die Funktion für eingehende Nachrichten nicht aktiviert ist. Diese Einstellung kann konfiguriert werden, indem in der ScanMail-Verwaltungskonsole im Dialogfeld Active Message Filter das Kontrollkästchen Inbound Messages aktiviert bzw. deaktiviert wird.

Microsoft Exchange Server Analyzer liest außerdem den folgenden Registrierungseintrag, um zu bestimmen, ob das VSAPI-Nachrichtenscanning (Virus Scanning API) aktiviert ist:

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Ein Wert 1 für Enabled gibt an, dass das VSAPI-Scanning aktiviert ist. Ein Wert 0 gibt an, dass das VSAPI-Scanning nicht aktiviert ist. Diese Einstellung kann konfiguriert werden, indem in der ScanMail-Verwaltungskonsole auf der Seite Virus Scan | Options das Kontrollkästchen Enable VS API virus scanning aktiviert bzw. deaktiviert wird.

Wenn Exchange Server Analyzer feststellt, dass alle folgenden Kriterien erfüllt sind, wird eine Warnung angezeigt:

  • VSAPI-Scanning ist in in ScanMail für Exchange aktiviert

  • EnableAlert hat einen Wert von 1

  • ActionType hat einen Wert von 3

  • EnableEManager hat einen Wert von 1

  • EnableWebStoreDelMail hat einen Wert von 1

  • FileName ist ungleich null oder leer

Diese Warnung zeigt an, dass ScanMail so konfiguriert ist, dass alle Anlagen mit den im Schlüssel FileName aufgeführten Namen während des nächsten geplanten bzw. manuellen Scans gelöscht werden.

So beheben Sie diese Warnmeldung

  1. Stellen Sie sicher, dass alle Anlagen mit den im Schlüssel FileName aufgeführten Namen gelöscht werden sollen.

  2. Bei Bedarf deaktivieren Sie das Sperren von Anlagen, oder ändern Sie die Aktion von Delete in Quarantine. Dadurch können Administratoren die isolierten Dateien auf Anlagen überprüfen, die möglicherweise erhalten bleiben sollen.

Weitere Informationen zu ScanMail für Microsoft Exchange und ScanMail eManager erhalten Sie auf der Trend Micro-Website unter http://www.trend.com/.

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.


Trend ScanMail ist zum Löschen von Anlagen mit bestimmten Dateierweiterungen konfiguriert
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest eine Reihe von Registrierungseinträgen, um zu bestimmen, ob ScanMail für Microsoft Exchange Server so konfiguriert ist, dass Anlagen gelöscht werden. Die gelesenen Werte befinden sich in der Registrierung an folgender Position:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption\Advance

Wert | Beschreibung
ActionType | Gibt an, welche Anlagen gesperrt werden sollen, wenn das Sperren von Anlagen aktiviert ist. Der Wert 0 gibt an, dass alle Anlagen gesperrt werden. Der Wert 3 gibt an, dass der Administrator eine Liste von Dateinamenerweiterungen, Dateinamen oder True-File-Typen festgelegt hat. Diese Einstellung kann konfiguriert werden, indem in der ScanMail-Verwaltungskonsole im Dialogfeld Attachment Blocking Settings die gewünschte Option ausgewählt wird.
EnableAlert | Gibt an, ob das Sperren von Anlagen aktiviert ist. Ein Wert 1 gibt an, dass das Sperren von Anlagen aktiviert ist. Ein Wert von 0 gibt an, dass die Funktion deaktiviert ist. Diese Einstellung kann konfiguriert werden, indem in der ScanMail-Verwaltungskonsole auf der Seite Virus Scan | Options das Kontrollkästchen Enable attachment blocking aktiviert bzw. deaktiviert wird.
Erweiterung | Ein durch Semikolons getrennter Zeichenfolgenwert mit einer Liste der Dateierweiterungen für zu löschende Anlagen Wenn die angegebenen Anlagen gesperrt werden sollen, kann diese Einstellung konfiguriert werden, indem in der ScanMail-Verwaltungskonsole im Dialogfeld Attachment Blocking Settings die gewünschten Erweiterungen eingegeben werden.

HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

Wert | Beschreibung
EnableEManager | Gibt an, ob ScanMail eManager aktiviert ist. Ein Wert von 1 gibt an, dass eManager aktiviert ist. Ein Wert von 0 gibt an, dass die Funktion deaktiviert ist. Diese Einstellung kann konfiguriert werden, indem in der ScanMail-Verwaltungskonsole das Kontrollkästchen Enable eManager aktiviert bzw. deaktiviert wird. Diese Einstellung ist nur dann verfügbar, wenn ScanMail eManager installiert ist, eine separates Begleitprodukt.
EnableWebStoreDelMail | Gibt an, ob der ScanMail Active Message Filter für eingehende Nachrichten aktiviert ist. Ein Wert 1 gibt an, dass Active Message Filter für eingehende Nachrichten aktiviert ist. Ein Wert 0 gibt an, dass die Funktion für eingehende Nachrichten nicht aktiviert ist. Diese Einstellung kann konfiguriert werden, indem in der ScanMail-Verwaltungskonsole im Dialogfeld Active Message Filter das Kontrollkästchen Inbound Messages aktiviert bzw. deaktiviert wird.

Microsoft Exchange Server Analyzer liest außerdem den folgenden Registrierungseintrag, um zu bestimmen, ob das VSAPI-Nachrichtenscanning (Virus Scanning API) aktiviert ist:

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Ein Wert 1 für Enabled gibt an, dass das VSAPI-Scanning aktiviert ist. Ein Wert 0 gibt an, dass das VSAPI-Scanning nicht aktiviert ist. Diese Einstellung kann konfiguriert werden, indem in der ScanMail-Verwaltungskonsole auf der Seite Virus Scan | Options das Kontrollkästchen Enable VS API virus scanning aktiviert bzw. deaktiviert wird.

Wenn Exchange Server Analyzer feststellt, dass alle folgenden Kriterien erfüllt sind, wird eine Warnung angezeigt:

  • VSAPI-Scanning ist in ScanMail für Exchange aktiviert

  • EnableAlert hat einen Wert von 1

  • ActionType hat einen Wert von 3

  • EnableEManager hat einen Wert von 1

  • EnableWebStoreDelMail hat einen Wert von 1

  • Extension ist ungleich null oder leer

Diese Warnung zeigt an, dass ScanMail so konfiguriert ist, dass alle Anlagen mit den im Schlüssel Extension aufgeführten Erweiterungen während der nächsten geplanten bzw. manuellen Überprüfung gelöscht werden.

So beheben Sie dieses Problem

  1. Vergewissern Sie sich, dass alle Anlagen mit den im Schlüssel Extension aufgeführten Erweiterungen gelöscht werden sollen.

  2. Wenn dies der Fall ist, deaktivieren Sie das Sperren von Anlagen oder ändern Sie die Aktion von Delete in Quarantine. Dadurch können Administratoren die isolierten Dateien auf Anlagen überprüfen, die möglicherweise erhalten bleiben sollen.

Weitere Informationen zu ScanMail für Microsoft Exchange Server und ScanMail eManager erhalten Sie auf der Trend Micro-Website (http://www.trend.com/).

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.


Trend ScanMail ist für die doppelte Nachrichtenverarbeitung konfiguriert
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_Service ab, um den Wert für den Schlüssel Started für den Dienst ScanMail_RealTimeScan zu ermitteln. Der Wert True gibt an, dass der Dienst ScanMail_RealTimeScan gestartet ist; der Wert False gibt an, dass der Dienst ScanMail_RealTimeScan nicht gestartet ist. Der Dienst ScanMail_RealTimeScan ist eine Komponente der Anwendung Trend Micro ScanMail für Microsoft Exchange. Trend Micro ScanMail für Microsoft Exchange stellt Virenschutz für Exchange bereit.

Zusätzlich liest Exchange Server Analyzer den folgenden Registrierungseintrag, um die Einstellung des Wertes Enabled zu bestimmen:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\TransportAVAPI

Der Wert 1 für Enabled gibt an, dass die Virenprüfung auf Transportebene (auch als „SMTP-Scan" bezeichnet (Simple Mail Transfer Protocol)) aktiviert ist. Der Wert 0 zeigt an, dass der SMTP-Scan nicht aktiviert ist.

Wenn Exchange Server Analyzer ermittelt, dass Enabled auf 1 und der Wert des Schlüssels Started für den Dienst ScanMail_RealTimeScan auf True eingestellt ist, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass Nachrichten, die über diesen Exchange-Server laufen, zwei Mal geprüft werden, von der Anwendung selbst und dem Virenscanmodul. Diese doppelte Prüfung derselben Nachricht beim Durchlauf durch die Übertragungs- und Speicherungskomponenten von Exchange Server stellt eine unnötige Beanspruchung der Ressourcen dar und erbringt keinen zusätzlichen Schutz oder andere Vorteile. Es wird empfohlen, dass die VSAPI-Virenprüfung (Virus Scanning API) aktiviert bleibt und Sie den SMTP-Mailscan über die ScanMail-Verwaltungskonsole deaktivieren.

Es wird im Allgemeinen empfohlen, Antivirussoftware bereitzustellen, die für Messagingsysteme auf dem SMTP-Gateway (Simple Mail Transfer Protocol) oder auf Exchange-Servern entwickelt wurde, auf denen sich Postfächer befinden. Den höchsten Schutz erhalten Sie, wenn Sie eine Antivirussoftware am Gateway ausführen, das die eingehenden MIME-Nachrichten überprüft, und mit einem Prüfprogramm auf dem Exchange-Server mit VSAPI 2.5. Zusätzlich sollten Sie eine Client-Antivirussoftware auf dem Desktop des Benutzers ausführen. Wenn Sie die für Messagingsysteme entwickelte Antivirussoftware (d. h. Software, die MIME analysieren und überprüfen kann) am Gateway oder auf dem Exchange-Server ausführen, reicht es aus, auf dem Desktop ein Virenprüfprogramm auf Dateiebene auszuführen.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie die ScanMail Management Console, und geben Sie die Anmeldeinformationen ein.

  2. Stellen Sie sicher, dass auf der Seite Virus Scan | Options das Kontrollkästchen Enable VS API virus scanning aktiviert ist.

  3. Auf der gleichen Seite deaktivieren Sie das Kontrollkästchen Enable SMTP mail scanning.

  4. Klicken Sie auf Übernehmen, um die Änderungen zu speichern.

  5. Schließen Sie die ScanMail Management Console.

Weitere Informationen zu Trend Micro ScanMail für Microsoft Exchange finden Sie auf der Trend-Website unter http://de.trendmicro-europe.com/index.php.

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.

Weitere Informationen zum Verwenden von Antivirus-Software mit Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 328841, „XADM: Exchange und Antivirus-Software" unter http://support.microsoft.com/kb/328841/DE/.

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" unter http://support.microsoft.com/kb/823166/de&kbid=823166.

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, „Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" unter http://support.microsoft.com/default.aspx?scid=kb;de-de;Q245822.


Niedrige Thread-Anzahl für Trend ScanMail
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um den Wert für MaxScanningThreadCount zu bestimmen:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

Der Registrierungswert MaxScanningThreadCount stellt die maximale Anzahl von Threads dar, die von ScanMail für Exchange zum Scannen erstellt werden können. Der Standardwert ist 12.

Microsoft Exchange Server Analyzer liest außerdem den folgenden Registrierungseintrag, um zu bestimmen, ob das VSAPI-Nachrichtenscanning (Virus Scanning API) aktiviert ist:

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Der Wert 1 für Enabled gibt an, dass VSAPI-Scanning aktiviert ist. Der Wert 0 gibt an, dass das VSAPI-Scanning nicht aktiviert ist.

Exchange Server Analyzer fragt außerdem die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_ComputerSystem ab, um den festgelegten Wert für den Schlüssel NumberOfProcessors zu bestimmen. Dieser Wert stellt die Anzahl der auf dem Computer installierten Prozessoren dar und enthält sowohl die physikalischen als auch die logischen Prozessoren. Mithilfe der Hyper-Threading-Technologie von Intel kann ein physikalischer Prozessor in zwei logische Prozessoren aufgeteilt werden.

Exchange Server Analyzer fragt darüber hinaus den Active Directory®-Verzeichnisdienst ab, um die Anzahl der Objekte mit der Objektklasse msExchPrivateMDB zu bestimmen. Der Zähler dieser Objekte stellt die Anzahl der Postfachspeicher auf diesem Exchange Server-Computer dar.

Wenn Exchange Server Analyzer feststellt, dass der Wert für MaxScanningThreadCount auf einem ExchangeServer-Computer mit installiertem VSAPI-Scanning kleiner als (2 x NumberOfProcessors + 1) + 3 + Anzahl der Postfachspeicher) ist, wird eine Warnung angezeigt.

Hinweis:
Bei aktiviertem Hyper-Threading beträgt der Wert für NumberOfProcessors das Zweifache der Anzahl der physikalischen Prozessoren. Es wird empfohlen, die oben angegebene Formel für Systeme, die nur über physikalische Prozessoren verfügen, und für Systeme, die sowohl über physikalische als auch logische Prozessoren verfügen, zu verwenden.

Diese Warnung gibt an, dass der Registrierungswert MaxScanningThreadCount für Ihre Umgebung möglicherweise nicht optimiert ist. Dieser Wert sollte zumindest gleich dem Grenzwert der Anlagengröße sein, den Sie auf Ihren Exchange-Servern festgelegt haben. Informationen über einen verwandten Registrierungswert finden Sie unter Niedrige Thread-Pool-Anzahl für Trend ScanMail:

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\Software\TrendMicro\ScanMail für Exchange\RealTimeScan\ScanOption

  3. Doppelklicken Sie im rechten Bereich auf MaxScanningThreadCount.

  4. Geben Sie einen Wert ein, der von Exchange Server Analyzer empfohlen wird.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie den Dienst ScanMail_RealTimeScan und den Dienst Microsoft Exchange-Informationsspeicher neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://support.microsoft.com/kb/256986/DE/).

Weitere Informationen zum Registrierungswert MaxScanningThreadCount finden Sie in Trend Micro Solution ID 13176 unter http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=13176.

Weitere Informationen zur Hyper-Threading-Technologie finden Sie auf der Intel-Webseite (http://www.intel.com/technology/hyperthread).

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.


Niedrige Thread-Pool-Anzahl für Trend ScanMail
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2006-04-21

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um den Wert für ScanningThreadPoolCount zu bestimmen:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

Der Registrierungswert ScanningThreadPoolCount stellt die Anzahl der Scanthreads dar, die initialisiert und für die Verwendung vorbereitet werden, wenn ScanMail für Exchange gestartet wird. Der Standardwert ist 12. Wenn alle beim Start erstellten Threads verbraucht wurden, erstellt ScanMail für Exchange zusätzliche zu verwendende Threads, bis die Anzahl der Threads erreicht wird, die durch den Registrierungswert MaxScanningThreadCount festgelegt wird. Dieser Wert wird unter Niedrige Thread-Anzahl für Trend ScanMail beschrieben.

Microsoft Exchange Server Analyzer liest außerdem den folgenden Registrierungseintrag, um zu bestimmen, ob das VSAPI-Nachrichtenscanning (Virus Scanning API) aktiviert ist:

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Der Wert 1 für Enabled gibt an, dass VSAPI-Scanning aktiviert ist. Der Wert 0 gibt an, dass das VSAPI-Scanning nicht aktiviert ist.

Exchange Server Analyzer fragt außerdem die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_ComputerSystem ab, um den festgelegten Wert für den Schlüssel NumberOfProcessors zu bestimmen. Dieser Wert stellt die Anzahl der auf dem Computer installierten Prozessoren dar und enthält sowohl die physikalischen als auch die logischen Prozessoren. Mithilfe der Hyper-Threading-Technologie von Intel kann ein physikalischer Prozessor in zwei logische Prozessoren aufgeteilt werden.

Exchange Server Analyzer fragt darüber hinaus den Active Directory®-Verzeichnisdienst ab, um die Anzahl der Objekte mit der Objektklasse msExchPrivateMDB zu bestimmen. Der Zähler dieser Objekte stellt die Anzahl der Postfachspeicher auf diesem Exchange Server-Computer dar.

Wenn Exchange Server Analyzer feststellt, dass der Wert für ScanningThreadPoolCount auf einem ExchangeServer-Computer mit installiertem VSAPI-Scanning kleiner als (2 x NumberOfProcessors + 1) + 3 + Anzahl der Postfachspeicher) ist, wird eine Warnung angezeigt.

Hinweis:
Bei aktiviertem Hyper-Threading beträgt der Wert für NumberOfProcessors das Zweifache der Anzahl der physikalischen Prozessoren. Es wird empfohlen, die oben angegebene Formel für Systeme, die nur über physikalische Prozessoren verfügen, und für Systeme, die sowohl über physikalische als auch logische Prozessoren verfügen, zu verwenden.

Diese Warnung gibt an, dass der Registrierungswert ScanningThreadPoolCount möglicherweise nicht für Ihre Umgebung optimiert ist. Dieser Wert sollte zumindest gleich dem Grenzwert der Anlagengröße sein, den Sie auf Ihren Exchange-Servern festgelegt haben.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\Software\TrendMicro\ScanMail für Exchange\RealTimeScan\ScanOption.

  3. Doppelklicken Sie im rechten Bereich auf ScanningThreadPoolCount.

  4. Geben Sie einen Wert ein, der von Exchange Server Analyzer empfohlen wird.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie den Dienst ScanMail_RealTimeScan sowie den Dienst Microsoft Exchange-Informationsspeicher neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://support.microsoft.com/kb/256986/DE/).

Weitere Informationen zur Hyper-Threading-Technologie finden Sie auf der Intel-Webseite (http://www.intel.com/technology/hyperthread).

Hinweis:
Webadressen können sich ändern. Möglicherweise können Sie deshalb die hier aufgeführten Webseiten oder Websites nicht aufrufen.


Trend ScanMail befindet sich im Debugmodus
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2006-06-22

Microsoft ® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um den Wert für ModuleName zu bestimmen:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\Tools\Debug

Der Registrierungswert ModuleName gibt den Namen der verwendeten Debugmoduldatei an.

Microsoft Exchange Server Analyzer liest außerdem den folgenden Registrierungseintrag, um zu bestimmen, ob das VSAPI-Nachrichtenscanning (Virus Scanning API) aktiviert ist:

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Ein Wert 1 für Enabled gibt an, dass das VSAPI-Scanning aktiviert ist. Ein Wert 0 gibt an, dass das VSAPI-Scanning nicht aktiviert ist.

Wenn Exchange Server Analyzer ermittelt, dass VSAPI-Scanning aktiviert und der Registrierungswert ModuleName nicht leer oder null ist, wird eine Warnung angezeigt.

Das Ausführen des Debugmodus führt durch die Diagnoseablaufverfolgung im Hintergrund zu einem deutlichen Leistungsabfall. Vorausgesetzt, Sie sind nicht gerade aktiv mit einer Problembehandlung beschäftigt, für die Sie ScanMail für Exchange im Debugmodus ausführen müssen, empfiehlt es sich, den Debugmodus zu deaktivieren.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie dieses Problem

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\Software\TrendMicro\ScanMail for Exchange\Tools\Debug.

  3. Doppelklicken Sie im rechten Bereich auf ModuleName.

  4. Löschen Sie den Wert für diesen Eintrag, indem Sie keine Zeichenfolge angeben. Der Schlüssel ModuleName darf nicht gelöscht werden.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie den Dienst ScanMail_RealTimeScan und den Dienst Microsoft Exchange-Informationsspeicher neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, "Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052).

Weitere Informationen zum Überprüfen, ob der Debugmodus deaktiviert ist, finden Sie unter Trend Micro Solution ID 19149 (http://esupport.trendmicro.com/support/viewxml.do?ContentID=en-119149).

Hinweis:
Die Informationen zur Website des Drittanbieters in diesem Thema werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.


Der Dienst „Trend ScanMail Mail Action" ist auf diesem Exchange-Server installiert, wurde aber angehalten
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer sendet eine Abfrage an die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Service, um zu ermitteln, ob Trend Micro ScanMail für Exchange installiert ist und ob der Dienst ScanMail_MailAction auf dem Exchange-Computer ausgeführt wird.

Exchange Server Analyzer fragt die WMI-Klasse Win32_Service auch ab, um zu ermitteln, ob der für den Schlüssel Started im Microsoft Exchange-Informationsspeicherdienst festgelegte Wert auf True oder False festgelegt ist.

Der Wert False gibt an, dass der Microsoft Exchange-Informationsspeicherdienst auf diesem Exchange Server-Computer nicht ausgeführt wird. Der Wert True gibt an, dass der Microsoft-Informationsspeicherdienst ausgeführt wird.

Wenn Exchange Server Analyzer feststellt, dass der Microsoft Exchange-Informationsspeicherdienst ausgeführt wird und dass Trend Micro ScanMail für Exchange installiert ist, aber der Dienst ScanMail_MailAction nicht gestartet wird, wird eine Warnung angezeigt.

Trend Micro ScanMail für Exchange bietet Virenschutz für Exchange Server. Hier werden einige Gründe aufgelistet, die zum Abbruch des Trend ScanMail-Dienstes geführt haben können, und wie diese Probleme gelöst werden können.

  • Bei der Software, die Sie auf dem Exchange-Server ausführen, handelt es sich möglicherweise um eine Evaluierungsversion (oder Testversion), die inzwischen abgelaufen ist. In diesem Fall müssen Sie möglicherweise Trend ScanMail neu installieren. Sie müssen aber zumindest die Software aktivieren, um mit ihr weiter arbeiten zu können.

  • Ein Administrator hat möglicherweise den Dienst ScanMail_MailAction versehentlich angehalten. Prüfen Sie, ob der Dienst so eingerichtet ist, dass er automatisch startet, und starten Sie dann den Dienst.

  • Der Dienst wurde möglicherweise durch einen bösartigen Wurm, einen Virus oder ein anderes Programm angehalten. Überprüfen Sie, ob der Dienst so festgelegt ist, dass er automatisch startet, und starten Sie dann den Dienst. Wenn der Dienst weiterhin unerwartet und ohne relevante Fehlerereignisse anhält, prüfen Sie, ob Ihr Computer nicht mit einem bösartigen Wurm infiziert ist, und bereinigen Sie gegebenenfalls das System.

Es wird im Allgemeinen empfohlen, Antivirussoftware bereitzustellen, die für Messagingsysteme auf dem SMTP-Gateway (Simple Mail Transfer Protocol) oder auf Exchange-Servern entwickelt wurde, auf denen sich Postfächer befinden. Den höchsten Schutz erhalten Sie, wenn Sie eine Antivirussoftware am Gateway, das die eingehenden MIME-Nachrichten überprüft, und ein Prüfprogramm auf dem Exchange-Server mit VSAPI 2.5 ausführen. Zusätzlich sollten Sie eine Client-Antivirussoftware auf dem Desktop des Benutzers ausführen. Wenn Sie die für Messagingsysteme entwickelte Antivirussoftware (d. h. Software, die MIME analysieren und überprüfen kann) am Gateway oder auf dem Exchange-Server ausführen, reicht es aus, auf dem Desktop ein Virenprüfprogramm auf Dateiebene auszuführen.

So starten Sie den Dienst ScanMail_MailAction

  1. Öffnen Sie das MMC-Snap-In Dienste.

  2. Klicken Sie mit der rechten Maustaste auf den Dienst ScanMail_MailAction, und klicken Sie dann auf Eigenschaften.

  3. Vergewissern Sie sich, dass auf der Eigenschaftenseite von ScanMail_MailAction auf der Registerkarte Allgemein für Starttyp die Option Automatisch festgelegt ist. Ist dies nicht der Fall, legen Sie Automatisch fest, klicken Sie auf Übernehmen und dann auf OK.

  4. Klicken Sie mit der rechten Maustaste auf den Dienst ScanMail_MailAction, und klicken Sie dann auf Starten.

  5. Schließen Sie das Snap-In Dienste.
  • Informationen zum Schutz von Exchange-Umgebungen vor durch E-Mail-Nachrichten übertragenen Viren und Würmern finden Sie unter „Behindern und Blockieren von E-Mail-Viren in einer Exchange 2003-Umgebung" (http://go.microsoft.com/fwlink/?LinkId=47587).

Weitere Informationen zum Verwenden von Antivirussoftware mit Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 328841, „XADM: Exchange und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie auf der Website Exchange Server-Partners: Antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Trend ScanMail-Echtzeitdienst ist auf diesem Exchange-Server installiert, der Dienst wurde jedoch angehalten
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_Service ab, um zu ermitteln, ob Trend Micro ScanMail für Microsoft Exchange installiert ist und ob der Dienst ScanMail_RealTimeScan auf dem Exchange Server-Computer ausgeführt wird. Wenn Exchange Server Analyzer feststellt, dass Trend Micro ScanMail für Microsoft Exchange installiert ist, aber der Dienst ScanMail_RealTimeScan nicht gestartet wurde, wird eine Warnung angezeigt.

Trend Micro ScanMail für Microsoft Exchange stellt Virenschutz für Exchange bereit. Hier werden einige Gründe aufgelistet, warum der Dienst ScanMail_RealTimeScan angehalten worden sein könnte und wie dieses Problem gelöst werden kann:

  • Bei der auf dem Exchange-Server ausgeführten Software handelt es sich möglicherweise um eine Evaluierungsversion (oder Testversion), die inzwischen abgelaufen ist. In diesem Fall müssen Sie unter Umständen Trend Micro ScanMail für Microsoft Exchange neu installieren. Sie müssen aber zumindest die Software aktivieren, um mit ihr weiter arbeiten zu können.

  • Ein Administrator hat möglicherweise den Dienst ScanMail_RealTimeScan versehentlich angehalten. Prüfen Sie, ob der Dienst so eingerichtet ist, dass er automatisch startet, und starten Sie dann den Dienst.

  • Der Dienst wurde möglicherweise durch einen bösartigen Wurm, einen Virus oder ein anderes Programm angehalten. Prüfen Sie, ob der Dienst so eingerichtet ist, dass er automatisch startet, und starten Sie den Dienst. Wenn der Dienst weiterhin unerwartet und ohne relevante Fehlerereignisse anhält, prüfen Sie, ob Ihr Computer nicht mit einem bösartigen Wurm infiziert ist, und bereinigen Sie gegebenenfalls das System.

Es wird im Allgemeinen empfohlen, Antivirussoftware bereitzustellen, die für Messagingsysteme auf dem SMTP-Gateway (Simple Mail Transfer Protocol) oder auf Exchange-Servern entwickelt wurde, auf denen sich Postfächer befinden. Den höchsten Schutz erhalten Sie, wenn Sie eine Antivirussoftware am Gateway ausführen, das die eingehenden MIME-Nachrichten überprüft, und mit einem Prüfprogramm auf dem Exchange-Server mit VSAPI (Virus Scanning API), Version 2.5. Zusätzlich sollten Sie eine Client-Antivirussoftware auf dem Desktop des Benutzers ausführen. Wenn Sie die für Messagingsysteme entwickelte Antivirussoftware (d. h. Software, die MIME analysieren und überprüfen kann) am Gateway oder auf dem Exchange-Server ausführen, reicht es aus, auf dem Desktop ein Virenprüfprogramm auf Dateiebene auszuführen.

So starten Sie den Dienst ScanMail_RealTimeScan

  1. Öffnen Sie das MMC-Snap-In Dienste.

  2. Klicken Sie mit der rechten Maustaste auf den Dienst ScanMail_RealTimeScan, und klicken Sie dann auf Eigenschaften.

  3. Vergewissern Sie sich, dass auf der Eigenschaftenseite von ScanMail_RealTimeScan auf der Registerkarte Allgemein für Starttyp die Option Automatisch festgelegt ist. Ist dies nicht der Fall, legen Sie Automatisch fest, klicken Sie auf Übernehmen und dann auf OK.

  4. Klicken Sie mit der rechten Maustaste auf den Dienst ScanMail_RealTimeScan, und klicken Sie dann auf Start.

  5. Schließen Sie das Snap-In Dienste.
  • Informationen zum Schutz von Exchange-Umgebungen vor durch E-Mails übertragenen Viren und Würmern finden Sie unter „Behindern und Blockieren von E-Mail-Viren in einer Exchange 2003-Umgebung" (http://go.microsoft.com/fwlink/?LinkId=47587).

Weitere Informationen zum Verwenden von Antivirussoftware mit Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 328841, „XADM: Exchange und Antivirus-Software" (http://support.microsoft.com/kb/328841/de)

  • 823166, „Überblick über Exchange Server 2003 und Antivirus-Software" (http://support.microsoft.com/kb/823166/de)

  • 306105, „XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105).

  • 245822, „XGEN: Empfehlungen für die Problembehandlung bei einem Exchange-Computer mit installierter Antivirensoftware" (http://support.microsoft.com/default.aspx?scid=kb;de-de;Q245822)

Eine Liste mit Antivirussoftware von Drittanbietern, die für Exchange Server verfügbar ist, finden Sie auf der Website Exchange Server-Partners: Antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Deaktivieren Sie Add-Ins von Drittanbietern auf dem Client
Microsoft Exchange Server Analyzer-Tools - Artikel > Software von Drittanbietern >

Letztes Änderungsdatum des Themas: 2006-04-21

Microsoft® Exchange Server Analyzer hat festgestellt, dass Sie Drittanbieter-Software der folgenden Arten einsetzen:

  • Ein Add-In für Microsoft Office Outlook® von einem Drittanbieter wie Antivirussoftware oder Faxsoftware

  • Eine Anwendung von Drittanbietern, die auf Ihren Exchange-Server zugreift

  • Synchronisierungssoftware von Drittanbietern für Mobilgeräte

Wir emfehlen eine Untersuchung, welche Arten von Drittanbieteranwendungen Ihre Benutzer einsetzen. Entscheiden Sie dann, ob Sie diese Anwendungen beschränken oder die Anwendungen ganz entfernen möchten. Beachten Sie das das Ausführen von Drittanbietersoftware häufig überhöhte Lasten auf Ihren Servern verursachen kann.

So deaktivieren Sie Add-Ins von Drittanbietern in Outlook

  1. Klicken Sie in Outlook im Menü Extras auf Optionen.

  2. Klicken Sie in Optionen auf die Registerkarte Erweitert, und klicken Sie dann auf Erweiterte Optionen.

  3. Unter Erweiterte Optionen klicken Sie auf Add-In-Manager.

  4. Deaktivieren Sie alle Kontrollkästchen, die Add-Ins von Drittanbietern betreffen.

  5. Klicken Sie auf OK.

  6. Starten Sie Outlook erneut.

Weitere Informationen

  • Weitere Informationen zur Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Weitere Informationen zur Behandlung von Problemen mit der Leistung von Exchange finden Sie im Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Transport
Microsoft Exchange Server Analyzer-Tools - Artikel >

Letztes Änderungsdatum des Themas: 2005-11-18

Die Artikel in diesem Abschnitt enthalten Details zur Auswertung, die Microsoft® Exchange Server Analyzer in Bezug auf Exchange-Transportkomponenten vornimmt. Darüber hinaus beschreiben diese Artikel Aktionen, die Sie durchführen können, um Fehler, Warnungen und vom Standard abweichende Konfigurationen im Zusammenhang mit dem Transport beheben zu können, die von Exchange Server Analyzer gefunden wurden.


8BITMIME ist nicht registriert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-18

Microsoft® Exchange Server Analyzer übermittelt das ESMTP-Befehlsverb (Extended Simple Mail Transfer Protocol) EHLO an Port 25 eines Remoteservers und analysiert die Antwort, um zu ermitteln, ob der Remoteserver das ESMTP-Verb 8BITMIME unterstützt.

Wenn die vom Remotserver erhaltene Antwort nicht die Zeichenfolge '250-8BITMIME' enthält, zeigt Exchange Server Analyzer eine Warnung an.

Exchange Server 2003 verwendet Exchange-spezifische erweiterte SMTP-Verben, um mit anderen Servern in der Organisation zu kommunizieren, auf denen Exchange Server ausgeführt wird. Exchange-spezifische erweiterte SMTP-Verben ermöglichen eine effektivere Kommunikation als Standard-SMTP-Verben. Wenn die Unterstützung des ESMTP-Befehlssatzes deaktiviert ist, kann die Leistung von Exchange Server unter Umständen herabgesetzt werden.

Dieser Fehler gibt an, dass der Remoteserver das ESMTP-Befehlsverb 8BITMIME nicht unterstützt. Der Fehler zeigt nicht an, ob es sich bei dem Remoteserver um einen Exchange-Server handelt. Nachrichten, die die 8BITMIME-Erweiterung benötigen, werden nicht weitergeleitet.

Um dieses Problem zu beheben, überprüfen Sie den Inhalt der SMTP-Warteschlangen auf Nachrichten, die die 8BITMIME-Erweiterung benötigen.

Weitere Informationen zum Entfernen oder Wiederherstellen der standardmäßigen Unterstützung dieser Verben finden Sie im Microsoft Knowledge Base-Artikel 257569 "Informationen zum Deaktivieren von Verben in Exchange 2000 Server und Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569).

Weitere Informationen dazu, wie Exchange Server die ESMTP-Befehlsverben verwendet, finden Sie im Abschnitt zum ordnungsgemäßen Laden von Exchange SMTP im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=71800)


ADAM LDAP Port Identified
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-07-23

Das Tool Microsoft Exchange Analyzer liest die folgenden Registrierungseinträge, um die Ports zu ermitteln, die vom ADAM- Verzeichnisdienst (Active Directory Application Mode) auf dem Edge-Transport-Server verwendet werden:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\EdgeTransportRole\AdamSettings\MsExchangeAdam\LdapPort

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\EdgeTransportRole\AdamSettings\MsExchangeAdam\SslPort

ADAM ist ein LDAP-Verzeichnisdienst (Lightweight Directory Access Protocol), der speziell für die Verwendung mit verzeichnisaktivierten Anwendungen entwickelt wurde. ADAM speichert und repliziert nur anwendungsspezifische Informationen. Der Dienst muss nicht auf einem Domänencontroller bereitgestellt werden und ist nicht vom Active Directory-Verzeichnisdienst abhängig. ADAM bietet keine Authentifizierung oder Autorisierung für das Netzwerkbetriebssystem.

In Microsoft Exchange Server 2007 verwendet die Serverfunktion Edge-Transport ADAM zum Speichern von Konfigurationsinformationen und Empfängerdaten für die Inhaltsfilterung. Wenn ADAM mit Active Directory synchronisiert wird, kann der Dienst auch für die Nachrichtensicherheit zum Durchführen von Empfängersuchen verwendet werden.

Wenn aus Active Directory Daten an ADAM gesendet werden, geschieht dies mithilfe einer LDAP-Verbindung über die folgenden nicht standardmäßigen Ports:

  • LDAP: Port 50389/TCP

  • Sicheres LDAP: Port 50636/UDP

Wenn Exchange Analyzer die von ADAM verwendeten Ports erkennt, zeigt Exchange Analyzer eine Meldung zur bewährten Methode an.

Als bewährte Methode wird empfohlen, alle nicht wesentlichen Ports für den externen Zugriff zu blockieren.

Um dieses Problem zu beheben, stellen Sie sicher, dass die von Exchange Analyzer als für ADAM verwendet erkannten Ports nicht für den externen Zugriff geöffnet sind.

Achtung:
Port 50636/UDP wird für den Exchange EdgeSync-Dienst verwendet und sollte geöffnet bleiben, wenn EdgeSync-Funktionen gewünscht werden.
So blockieren Sie mithilfe von Windows Firewall die erkannten ADAM-Ports für den externen Zugriff

  1. Klicken Sie auf Start und auf Ausführen, geben Sie firewall.cpl ein, und klicken Sie dann auf OK.

  2. Klicken Sie auf die Registerkarte Ausnahmen.

  3. Wählen Sie alle Programme oder Dienste aus, die im Feld Name aufgeführt werden, und klicken Sie dann auf Bearbeiten, um die geöffneten Ports zu überprüfen.

  4. Vergewissern Sie sich, dass die von Exchange Analyzer als für ADAM verwendet gemeldeten Ports nicht aufgelistet werden.

  5. Wenn die erkannten Ports aufgelistet werden, vergewissern Sie sich, dass sie nicht für andere erforderliche Kommunikation verwendet werden, und schließen Sie sie dann, indem Sie sie im Fenster Dienst bearbeiten deaktivieren.

  6. Klicken Sie zweimal auf OK, um die Konfiguration von Windows Firewall zu beenden.

Weitere Informationen

Weitere Informationen zu den Ports, der Authentifizierung und der Verschlüsselung für alle von Exchange 2007 verwendeten Datenpfade finden Sie unter "Data Path Security Reference" (http://go.microsoft.com/fwlink/?LinkId=95630).


Antivirus-Plug-In ist installiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-18

Microsoft® Exchange Server Analyzer sucht nach dem folgenden Registrierungseintrag, um zu ermitteln, ob das Plug-In Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect installiert ist:

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail

Wenn dieser Registrierungseintrag vorhanden ist, ist das Plug-In Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect auf dem Server installiert, auf dem Exchange Server ausgeführt wird.

Darüber hinaus liest Exchange Server Analyzer den folgenden Registrierungseintrag, um zu ermitteln, ob das Plug-In Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect aktiviert ist:

HKLM\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail\RealTimeScan\OnOff

Der Wert 1 für OnOff gibt an, dass das Auto Protect-Plug-In aktiviert ist. Der Wert 0 gibt an, dass das Auto Protect-Plug-In nicht aktiviert ist.

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Das Plug-In Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect ist installiert.

  • Das Plug-In Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect ist nicht aktiviert.

Diese Warnung weist darauf hin, dass die Installation und Konfiguration des Plug-In hinsichtlich der vom Hersteller empfohlenen bewährten Methoden überprüft werden sollte.

Weitere Informationen zu den vom Hersteller empfohlenen bewährten Methoden für dieses Plug-In finden Sie unter "Bewährte Methoden für Symantec AntiVirus Corporate Edition 9.x Auto-Protect auf einem Microsoft Exchange-Server" (http://service1.symantec.com/SUPPORT/ent-security.nsf/c9b1ac1936fbf63488256e77006521df/3d1bcbc855fce10288256e9e007e01f0?OpenDocument&src=bar_sch_nam).

Hinweis:
Die Informationen der Website des Drittanbieters werden zur Verfügung gestellt, um Sie beim Auffinden der benötigten technischen Informationen zu unterstützen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.


Antivirus-Plug-In ist installiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-18

Microsoft® Exchange Server Analyzer sucht nach dem folgenden Registrierungseintrag, um zu ermitteln, ob das Plug-In Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect installiert ist.

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail

Wenn dieser Registrierungseintrag vorhanden ist, ist das Plug-In Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect auf dem Server installiert, auf dem Exchange Server ausgeführt wird.

Darüber hinaus liest Exchange Server Analyzer den folgenden Registrierungseintrag, um zu ermitteln, ob das Plug-In Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect aktiviert ist.

HKLM\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail\RealTimeScan\OnOff

Der Wert 1 für OnOff gibt an, dass das Auto Protect-Plug-In aktiviert ist. Der Wert 0 gibt an, dass das Auto Protect-Plug-In nicht aktiviert ist.

Exchange Server Analyzer zeigt einen Fehler an, wenn folgende Bedingungen zutreffen:

  • Das Plug-In Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect ist installiert.

  • Das Plug-In Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect ist aktiviert.

Dieser Fehler weist darauf hin, dass die Installation und Konfiguration des Plug-In hinsichtlich der vom Hersteller empfohlenen bewährten Methoden überprüft werden sollte.

Weitere Informationen zu den vom Hersteller empfohlenen bewährten Methoden für dieses Plug-In finden Sie unter "Bewährte Methoden für Symantec AntiVirus Corporate Edition 9.x Auto-Protect auf einem Microsoft Exchange-Server" (http://service1.symantec.com/SUPPORT/ent-security.nsf/c9b1ac1936fbf63488256e77006521df/3d1bcbc855fce10288256e9e007e01f0?OpenDocument&src=bar_sch_nam).

Hinweis:
Die Informationen der Website des Drittanbieters werden zur Verfügung gestellt, um Sie beim Auffinden der benötigten technischen Informationen zu unterstützen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.


Die Bcc-Aufzeichnung ist aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungswert, um zu bestimmen, ob das Bcc-Journal (BCC - Blind Carbon Copy) aktiviert ist:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\JournalBCC

Wenn Exchange Server Analyzer feststellt, dass der Wert für JournalBCC auf 1 festgelegt ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Beim Bcc-Journal handelt es sich um eine auf Nachrichten beschränkte Aufzeichnung, bei der zusätzlich Bcc-Empfänger aufgezeichnet werden können. Wenn das Bcc-Journal aktiviert ist, zeichnet Exchange Server alle Empfänger (einschließlich Bcc-Empfängern) auf, die dem sendenden Server bekannt sind. Wenn diese Empfängerliste ausgeblendete Verteilerlisten, abfragebasierte Verteilerlisten oder Verteilerlisten einschließt, die auf einem anderen Server erweitert werden, werden die Empfänger für diese Listen nicht in Aufzeichnungsnachrichten eingeschlossen.

Das Bcc-Journal wird durch Festlegen eines Registrierungsschlüssels aktiviert. Weitere Informationen zum Festlegen dieses Registrierungsschlüssels finden Sie im Microsoft Knowledge Base-Artikel 810999 „XADM: Bcc Information Is Lost for Journaled Messages in Exchange 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810999).

Wenn Sie das Bcc-Journal auf einem bestimmten Server aktivieren möchten, müssen Sie zuerst die auf Nachrichten beschränkte Aufzeichnung konfigurieren. Die Einstellung JournalBCC ist nicht aktiviert, wenn die folgenden Bedingungen erfüllt sind:

  • Der Registrierungswert JournalBCC ist auf 1 festgelegt.

  • Die auf Nachrichten beschränkte Aufzeichnung ist für keine Datenbank auf dem entsprechenden Server aktiviert.

Aufzeichnungsnachrichten können umfangreiche Datenträger-, Netzwerk- und CPU-Ressourcen beanspruchen. Aufzeichnungen erfordern daher eine sorgfältige Bereitstellungsplanung. Aufzeichnungen sollten ausschließlich im Rahmen einer Gesamtlösung für Aufzeichnungen aktiviert werden.

Wenn die folgenden Bedingungen zutreffen, können Sie die Meldung über die von der Standardkonfiguration abweichende Konfiguration ignorieren:

  • Ihr Unternehmen macht Aufzeichnungen erforderlich.

  • Sie haben eine Gesamtlösung für Aufzeichnungen bereitgestellt.

Wenn dies nicht der Fall ist, sollten Sie die Aufzeichnungsfunktion deaktivieren. Durch Deaktivieren der Aufzeichnungsfunktion in der Datenbank wird die Aufzeichnung deaktiviert.

So deaktivieren Sie die auf Nachrichten beschränkte Aufzeichnung für eine Datenbank

  1. Erweitern Sie im Exchange-System-Manager die Option Server, und erweitern Sie <Ihren Exchange-Server>. Erweitern Sie die <Speichergruppe>, und klicken Sie mit der rechten Maustaste auf den Postfachspeicher.

  2. Deaktivieren Sie auf der Registerkarte Allgemein das Kontrollkästchen Alle von Postfächern in diesem Informationsspeicher gesendeten oder empfangenen Nachrichten archivieren.

  3. Warten Sie 15 Minuten, bis die Änderungen vom Exchange-Informationsspeicher vorgenommen wurden. Sie müssen den Microsoft Exchange-Informationsspeicherdienst nicht neu starten.

Wenn Exchange Server Analyzer die Nachricht nicht erneut anzeigen soll, müssen Sie den Registrierungsschlüssel JournalBCC löschen. Es ist nicht erforderlich, den Registrierungsschlüssel JournalBCC zu löschen, um die Journalfunktion zu deaktivieren.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So löschen Sie den Registrierungsschlüssel „JournalBCC"

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\

  3. Suchen Sie im rechten Bereich den Wert JournalBCC, und löschen Sie ihn.

  4. Schließen Sie den Registrierungs-Editor.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Bereitstellen einer Aufzeichnungslösung finden Sie unter Journaling with Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).


BDAT ist nicht registriert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-18

Microsoft® Exchange Server Analyzer übermittelt das ESMTP-Befehlsverb (Extended Simple Mail Transfer Protocol) EHLO an Port 25 eines Remoteservers und analysiert die Antwort, um zu ermitteln, ob der Remoteserver das ESMTP-Verb BDAT unterstützt.

Wenn Exchange Server Analyzer eine Antwort mit einer Zeichenfolge erhält, die angibt, das auf dem Remoteserver ein nicht abrufbarer Fehler aufgetreten ist, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Exchange Server 2003 verwendet Exchange-spezifische erweiterte SMTP-Verben, um mit anderen Servern in der Organisation zu kommunizieren, auf denen Exchange Server ausgeführt wird. Exchange-spezifische erweiterte SMTP-Verben ermöglichen eine effektivere Kommunikation als Standard-SMTP-Verben. Wenn die Unterstützung des ESMTP-Befehlssatzes deaktiviert ist, kann die Leistung von Exchange Server unter Umständen herabgesetzt werden.

Dieser Fehler gibt an, dass der Remoteserver das ESMTP-Befehlsverb BDAT nicht unterstützt. Der Fehler zeigt nicht an, ob es sich bei dem Remoteserver um einen Exchange-Server handelt. Nachrichten, die die BDAT-Erweiterung benötigen, werden nicht geroutet.

Um dieses Problem zu beheben, überprüfen Sie den Inhalt der SMTP-Warteschlangen auf Nachrichten, die die BDAT-Erweiterung benötigen.

Weitere Informationen zum Entfernen oder Wiederherstellen der standardmäßigen Unterstützung dieser Verben finden Sie im Microsoft Knowledge Base-Artikel 257569 "Informationen zum Deaktivieren von Verben in Exchange 2000 Server und Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569).

Weitere Informationen dazu, wie Exchange Server die ESMTP-Befehlsverben verwendet, finden Sie im Abschnitt zum ordnungsgemäßen Laden von Exchange SMTP im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkID=71800).


Bridgehead-Server zum Überprüfen von Übermittlungseinschränkungen für Verteilergruppen für RGC
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-09-18

Microsoft® Exchange Server Analyzer fragt die folgenden Attribute für jedes im Active Directory®-Verzeichnisdienst erkannte Routinggruppenconnector-Objekt (msExchRoutingGroupConnector) ab, um festzustellen, ob Übermittlungseinschränkungen basierend auf der Mitgliedschaft in Verteilergruppen festgelegt sind.

dLMemRejectPerms | Enthält die Domänennamen (DNs) einer Verteilerliste (Distribution List, DL), deren Mitglieder keine Nachrichten über diesen Routinggruppenconnector senden dürfen.
dLMemSubmitPerms | Enthält die DNs einer Verteilerliste, deren Mitglieder Nachrichten über diesen Routinggruppenconnector senden dürfen.

Wenn Exchange Server Analyzer Routinggruppenconnectors findet, für die Übermittlungseinschränkungen basierend auf der Mitgliedschaft in Verteilergruppen gelten, fragt Exchange Server Analyzer das Attribut msExchSourceBridgeheadServersDN der erkannten Routinggruppenconnectors ab, um zu ermitteln, ob der Server, der zurzeit einer Analyse unterzogen wird, als Bridgehead-Server für einen oder mehrere dieser Connectors eingerichtet ist.

Abschließend liest Exchange Server Analyzer den folgenden Registrierungsschlüssel, um zu ermitteln, ob der Registrierungswert CheckConnectorRestrictions vorhanden und konfiguriert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Ein Routinggruppenconnector dient zur Einschränkung der Übermittlung basierend auf der Mitgliedschaft in Verteilergruppen.

  • Der zurzeit der Analyse unterzogene Exchange-Server ist für den betreffenden Routinggruppenconnector als Bridgehead-Server eingerichtet und hat die Aufgabe, die Verteilergruppe zu erweitern.

  • Der Schlüssel CheckConnectorRestrictions ist vorhanden, auf 1 gesetzt und daher aktiviert.

Das Standardverhalten des Kategorisierungsmoduls besteht darin, Verteilergruppen rekursiv zu erweitern und die Einschränkungen für jede Nachricht zu überprüfen, die das System durchläuft.

Beim Erstellen einer Routinggruppe legen Sie eine Gruppe von Servern fest, die direkt miteinander kommunizieren können. Damit Server in verschiedenen Routinggruppen miteinander kommunizieren können, müssen Sie die Routinggruppen miteinander verbinden.

Ein Routinggruppenconnector stellt die bevorzugte Verbindungsmethode dar, da ein solcher Connector speziell für das Verbinden von Routinggruppen entwickelt wurde.

Server, die E-Mails über einen Routinggruppenconnector senden können, werden als Bridgehead-Server bezeichnet. Bei einem Bridgehead-Server handelt es sich um eine Kombination aus einem virtuellen SMTP-Server (Simple Mail Transfer Protocol) und einem Exchange-Server, der für die Übermittlung sämtlicher Nachrichten über einen Connector verantwortlich ist.

Wenn Sie einen Routinggruppenconnector erstellt, können Sie wählen, ob alle Server für diesen Connector als Bridgehead-Server vorgesehen werden sollen oder ob nur eine ausgewählte Gruppe von Servern als Bridgehead-Server für den betreffenden Connector fungieren sollen. Bei den festgelegten Bridgeheads handelt es sich um diejenigen Server, deren Aufgabe die Erweiterung der Verteilergruppenmitgliedschaft ist.

Wenn Sie E-Mails über Routinggruppenconnectors senden, für die Übermittlungseinschränkungen basierend auf der Mitgliedschaft in Verteilergruppen festgelegt wurden, muss das Nachrichtenkategorisierungsmodul die Mitgliedschaft der Verteilergruppe erweitern, die vollständige Liste der DNs der Mitglieder anfordern und anschließend die Liste der DNs mit den DNs der Absender vergleichen. Eine Zugriffsoperation oder eine Verweigerungsoperation erfolgt, wenn in beiden Listen eine Übereinstimmung bei einem DN gefunden wird. Wenn eine Verteilergruppe in eine andere Verteilergruppe geschachtelt ist, wird die geschachtelte Verteilergruppe ebenfalls erweitert.

Diese Warnung gibt an, dass an den Bridgehead gesendete Nachrichten aufgrund der Übermittlungseinschränkungen, die auf der Mitgliedschaft in Verteilergruppen basieren, möglicherweise in eine Warteschlange übernommen werden, während das Kategoriesierungsmodul die Einschränkungen überprüft.

So beheben Sie diese Warnung

  • Konfigurieren Sie den Routinggruppenconnector für eine lokale Routinggruppe gemäß den Erläuterungen im Microsoft Knowledge Base-Artikel 329171, "XADM: Übermittlung von E-Mails ist langsam, wenn Empfänger mit Übermittlungseinschränkungen basierend auf der Gruppenmitgliedschaft konfiguriert sind" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • Verwenden Sie einen dedizierten und robusteren globalen Katalogserver als für den Connector vorgesehenen Bridgehead-Server.

  • Konfigurieren Sie einzelne Postfächer und keine Verteilergruppen für Übermittlungseinschränkungen gemäß den Erläuterungen im Microsoft Knowledge Base-Artikel 812298, "Übermittlung von E-Mails ist langsam, nachdem Sie Übermittlungseinschränkungen konfiguriert haben, die auf einer Verteilerliste basieren" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Ziehen Sie das Implementieren der SMTP-Absenderfilterung in Betracht.

  • Erwägen Sie für Server, auf denen Microsoft Exchange Server 2003 Service Pack 2 (SP2) oder höher ausgeführt wird, die nicht hierarchische Einschränkungsüberprüfung zu implementieren. Bei Servern, auf denen Versionen von Exchange vor Exchange 2003 SP2 ausgeführt werden, sollten Sie die Aktualisierung auf Exchange 2003 SP2 in Betracht ziehen.

Weitere Informationen

Weitere Informationen zu der nicht hierarchischen Einschränkungsüberprüfung finden Sie unter Empfohlene Vorgehensweise: Nicht hierarchische Einschränkungsüberprüfung..

Weitere Informationen zu der SMTP-Absenderfilterung finden Sie unter "Aktivieren der Absenderfilterung" im Exchange Server 2003-Administratorhandbuch (http://go.microsoft.com/fwlink/?LinkId=71832).

Weitere Informationen zu der Auswirkung der Verteilergruppeneinschränkung auf den E-Mail-Verkehr in Exchange finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 329171 "XADM: Übermittlung von E-Mails ist langsam, wenn Empfänger mit Übermittlungseinschränkungen basierend auf der Gruppenmitgliedschaft konfiguriert sind" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • 895407, "Die Nachrichtenübermittlung zu lokalen und externen Postfächern ist in Exchange Server 2003 langsamer als erwartet, nachdem Sie die Übermittlungseinschränkungen basierend auf Verteilergruppen konfiguriert haben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 839949 "Problembehandlung bei E-Mail-Transport und Verteilergruppen in Exchange 2000 Server und in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).


Bridgehead-Server zum Überprüfen von Übermittlungseinschränkungen für Verteilergruppen für SMTP-Connector
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-21

Microsoft® Exchange Server Analyzer fragt die folgenden Attribute für jedes im Active Directory®-Verzeichnisdienst erkannte SMTP-Connectorobjekt (Simple Mail Transfer Protocol) (msExchRoutingSMTPConnector) ab, um zu ermitteln, ob Übermittlungseinschränkungen basierend auf der Mitgliedschaft in Verteilergruppen festgelegt sind.

dLMemRejectPerms | Enthält die Domänennamen (DNs) einer Verteilerliste (Distribution List, DL), deren Mitglieder keine Nachrichten über diesen SMTP-Connector senden dürfen.
dLMemSubmitPerms | Enthält die DNs einer Verteilerliste, deren Mitglieder Nachrichten über diesen SMTP-Connector senden dürfen.

Wenn Exchange Server Analyzer SMTP-Connectors findet, für die Übermittlungseinschränkungen basierend auf der Mitgliedschaft in Verteilergruppen gelten, fragt Exchange Server Analyzer das Attribut msExchSourceBridgeheadServersDN der erkannten SMTP-Connectors ab, um zu ermitteln, ob der Server, der zurzeit einer Analyse unterzogen wird, als Bridgehead-Server für einen oder mehrere dieser Connectors eingerichtet ist.

Abschließend liest Exchange Server Analyzer den folgenden Registrierungsschlüssel, um zu ermitteln, ob der Registrierungswert CheckConnectorRestrictions vorhanden und konfiguriert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Ein SMTP-Connector dient zur Einschränkung der Übermittlung basierend auf der Mitgliedschaft in Verteilergruppen.

  • Der zurzeit der Analyse unterzogene Exchange-Server ist für den betreffenden SMTP-Connector als Bridgehead-Server eingerichtet und hat die Aufgabe, die Verteilergruppe zu erweitern.

  • Der Schlüssel CheckConnectorRestrictions ist vorhanden, auf 1 gesetzt und daher aktiviert.

Das Standardverhalten des Kategorisierungsmoduls besteht darin, Verteilergruppen rekursiv zu erweitern und die Einschränkungen für jede Nachricht zu überprüfen, die das System durchläuft.

Wenn Sie E-Mails über einen Connector senden, der Nachrichten von einer Verteilergruppe akzeptiert oder verweigert, muss das Nachrichtenkategorisierungsmodul die Mitgliedschaft der Verteilergruppe erweitern, die vollständige Liste der DNs der Mitglieder anfordern und anschließend die Liste der DNs mit den DNs der Absender vergleichen. Eine Zugriffsoperation oder eine Verweigerungsoperation erfolgt, wenn in beiden Listen eine Übereinstimmung bei einem DN gefunden wird. Wenn eine Verteilergruppe in eine andere Verteilergruppe geschachtelt ist, wird die geschachtelte Verteilergruppe ebenfalls erweitert.

Bei dem festgelegten Bridgehead handelt es sich um denjenigen Server, dessen Aufgabe die Erweiterung der Verteilergruppenmitgliedschaft ist.

Die Einschränkungsprüfung wird über den Registrierungswert CheckConnectorRestrictions gesteuert, der auf dem Exchange-Bridgehead-Server festgelegt wird. Dieser Server ist die Quelle für den zu prüfenden Connector. Wenn Sie eine Einschränkung festlegen, jedoch keinen Registrierungswert für CheckConnectorRestrictions angeben, erfolgt keine Einschränkungsprüfung.

Die Einschränkungsprüfung für den Connector ist standardmäßig deaktiviert. Wenn Verteilergruppen erweitert werden und jede Nachricht, die das System durchläuft, auf Einschränkungen überprüft wird, hat dies eine erhebliche Beeinträchtigung der Systemleistung zur Folge.

Diese Warnung gibt an, dass an den Bridgehead gesendete Nachrichten aufgrund der Übermittlungseinschränkungen, die auf der Mitgliedschaft in Verteilergruppen basieren, möglicherweise in eine Warteschlange übernommen werden, während das Kategorisierungsmodul die Einschränkungen überprüft.

So beheben Sie diese Warnung

  • Erstellen Sie eine dedizierte Routinggruppe für Connectoreinschränkungen, und konfigurieren Sie sie als lokale Routinggruppe gemäß den Erläuterungen im Microsoft Knowledge Base-Artikel 329171, "XADM: Übermittlung von E-Mails ist langsam, wenn Empfänger mit Übermittlungseinschränkungen basierend auf der Gruppenmitgliedschaft konfiguriert sind" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)

  • Verwenden Sie einen dedizierten und robusteren globalen Katalogserver als für den Connector vorgesehenen Bridgehead-Server.

  • Konfigurieren Sie einzelne Postfächer und keine Verteilergruppen für Übermittlungseinschränkungen gemäß den Erläuterungen im Microsoft Knowledge Base-Artikel 812298, "Übermittlung von E-Mails ist langsam, nachdem Sie Übermittlungseinschränkungen konfiguriert haben, die auf einer Verteilerliste basieren" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Ziehen Sie das Implementieren der SMTP-Absenderfilterung in Betracht.

  • Erwägen Sie für Server, auf denen Microsoft Exchange Server 2003 Service Pack 2 (SP2) oder höher ausgeführt wird, die nicht hierarchische Einschränkungsüberprüfung zu implementieren. Bei Servern, auf denen Versionen von Exchange vor Exchange 2003 SP2 ausgeführt werden, sollten Sie die Aktualisierung auf Exchange 2003 SP2 in Betracht ziehen.

Weitere Informationen

Weitere Informationen zu der nicht hierarchischen Einschränkungsüberprüfung finden Sie unter Empfohlene Vorgehensweise: Nicht hierarchische Einschränkungsüberprüfung..

Weitere Informationen zu der SMTP-Absenderfilterung finden Sie unter "Aktivieren der Absenderfilterung" im Exchange Server 2003-Administratorhandbuch (http://go.microsoft.com/fwlink/?LinkId=71832).

Weitere Informationen zu der Auswirkung der Verteilergruppeneinschränkung auf den E-Mail-Verkehr in Exchange finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 329171 "XADM: Übermittlung von E-Mails ist langsam, wenn Empfänger mit Übermittlungseinschränkungen basierend auf der Gruppenmitgliedschaft konfiguriert sind" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • 895407, "Die Nachrichtenübermittlung zu lokalen und externen Postfächern ist in Exchange Server 2003 langsamer als erwartet, nachdem Sie die Übermittlungseinschränkungen basierend auf Verteilergruppen konfiguriert haben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 839949 "Problembehandlung bei E-Mail-Transport und Verteilergruppen in Exchange 2000 Server und in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).


Mit dem Routingmaster an Anschluss 25 kann keine Verbindung hergestellt werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-24

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchRoutingMasterDN für jede Routinggruppe in der aktuellen administrativen Gruppe zu ermitteln. Exchange Server Analyzer versucht anschließend, eine Socketverbindung mit dem Routingmaster an TCP-Anschluss 25 zu öffnen. Wenn Microsoft Exchange Server Analyzer nicht die erwartete benutzerdefinierte Antwort 25 Available erhält, wird ein Fehler angezeigt.

Dieser Fehler gibt an, dass der Routingmaster an TCP-Anschluss 25 nicht verfügbar ist und daher möglicherweise Routingfehler auftreten können. Um diesen Fehler zu korrigieren, können Sie das Verbindungsproblem mit dem Routingmaster beheben oder einen neuen Routingmaster zuweisen.

So behandeln Sie das Verbindungsproblem mit dem Routingmaster

  1. Können Sie vom Routingmaster aus eine Telnet-Verbindung mit dem Anschluss 25 herstellen? Wenn nicht, wird das Problem nicht vom Netzwerk verursacht.

  2. Sind alle Stecker angeschlossen? Funktioniert die gesamte Hardware fehlerfrei?

  3. Ist der DNS aktiv und richtig konfiguriert?

  4. Funktioniert der Router fehlerfrei?

  5. Sind Firewalls oder Anwendungen vorhanden, die das Herstellen einer Verbindung verhindern können?
So weisen Sie einen neuen Routingmaster zu

  1. Öffnen Sie den Exchange-System-Manager.

  2. Klicken Sie mit der rechten Maustaste auf das Symbol für den Organisationsnamen (Exchange) oben in der Struktur im linken Bereich (wobei der Organisationsname der für die Exchange 2000-Organisation festgelegte Name ist), und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf Administrative Gruppen anzeigen, auf Routinggruppen anzeigen und dann auf OK.

  4. Erweitern Sie Administrative Gruppen und <Administrative Gruppe>, und erweitern Sie dann Routinggruppen.

  5. Erweitern Sie die Routinggruppe, und klicken Sie anschließend auf Mitglieder.

  6. Klicken Sie im rechten Bereich mit der rechten Maustaste auf den Exchange-Computer, den Sie als Routinggruppenmaster konfigurieren möchten, und klicken Sie dann auf Als Master festlegen.

Weitere Informationen zur Fehlerbehebung beim Routing, zum Konfigurieren von Routingtopologien und zu erweiterten Routingkonzepten finden Sie im Exchange Server 2003 Transport and Routing Guide unter „Troubleshooting Routing" (http://go.microsoft.com/fwlink/?LinkId=47579).


Mit dem Routingmaster an Anschluss 691 kann keine Verbindung hergestellt werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-24

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchRoutingMasterDN für jede Routinggruppe in der aktuellen administrativen Gruppe zu ermitteln. Exchange Server Analyzer versucht anschließend, eine Socketverbindung mit dem Routingmaster an TCP-Anschluss 691 zu öffnen. Wenn Microsoft Exchange Server Analyzer nicht die erwartete benutzerdefinierte Antwort 691 Available erhält, wird ein Fehler angezeigt.

Dieser Fehler gibt an, dass der Routingmaster an TCP-Anschluss 691 nicht verfügbar ist und daher möglicherweise Routingfehler auftreten können. Um diesen Fehler zu korrigieren, können Sie das Verbindungsproblem mit dem Routingmaster beheben oder einen neuen Routingmaster zuweisen.

So behandeln Sie das Verbindungsproblem mit dem Routingmaster

  1. Können Sie vom Routingmaster aus eine Telnet-Verbindung mit dem Anschluss 691 herstellen? Andernfalls wird das Problem nicht vom Netzwerk verursacht.

  2. Sind alle Stecker angeschlossen? Funktioniert die gesamte Hardware fehlerfrei?

  3. Ist DNS aktiv und richtig konfiguriert?

  4. Funktioniert der Router fehlerfrei?

  5. Sind Firewalls vorhanden, die das Herstellen einer Verbindung verhindern können?
So weisen Sie einen neuen Routingmaster zu

  1. Öffnen Sie den Exchange-System-Manager.

  2. Klicken Sie mit der rechten Maustaste auf das Symbol für den Organisationsnamen (Exchange) oben in der Struktur im linken Bereich (wobei der Organisationsname der für die Exchange 2000-Organisation festgelegte Name ist), und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf Administrative Gruppen anzeigen, auf Routinggruppen anzeigen und dann auf OK.

  4. Erweitern Sie Administrative Gruppen und <Administrative Gruppe>, und erweitern Sie dann Routinggruppen.

  5. Erweitern Sie die Routinggruppe, und klicken Sie anschließend auf Mitglieder.

  6. Klicken Sie im rechten Bereich mit der rechten Maustaste auf den Exchange-Computer, den Sie als Routinggruppenmaster konfigurieren möchten, und klicken Sie dann auf Als Master festlegen.

Weitere Informationen zur Fehlerbehebung beim Routing, zum Konfigurieren von Routingtopologien und zu erweiterten Routingkonzepten finden Sie im Exchange Server 2003 Transport and Routing Guide unter „Troubleshooting Routing" (http://go.microsoft.com/fwlink/?LinkId=47579).


"Host"- oder "MX"-Einträge nicht gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-05-10

Microsoft Exchange Analyzer führt eine DNS-Suche (Domain Name System) aus, um MX-Einträge (Mail Exchanger) für eine Domäne abzurufen. Wenn Exchange Analyzer keine MX-Einträge für eine Domäne vom DNS-Server abrufen kann, führt es eine DNS-Suche aus, um "Host (A)"-Einträge der Domänen abzurufen, an die der Server mit Exchange versucht, Nachrichten zu senden.

Exchange Analyzer zeigt einen Fehler an, wenn folgende Bedingungen zutreffen:

  • Exchange Analyzer kann keine MX-Einträge für eine Domäne abrufen.

  • Die DNS-Suche gibt keine IP-Adresse für einen beliebigen der "Host (A)"-Einträge zurück.

Dieser Fehler bedeutet, dass die DNS-Einträge "MX" (Mail Exchanger) und "Host (A)" für die Domäne und Server zu fehlen scheinen. Dieser Fehler kann verursachen, dass Nachrichten an Remotedomänen in den Warteschlangen vom Typ Remoteübermittlung auf dem Server mit Exchange zurückbehalten werden. Ferner kommt es ggf. zu anderen Routing- oder Dienstverzögerungen.

Um Mailhosts zu bestimmen, sucht der sendende Server mit Exchange nach einem MX-Eintrag. Als Nächstes löst der sendende Server den MX-Eintrag in eine IP-Adresse auf, indem nach einem Adresseintrag vom Typ "(A)" gesucht wird.

Die DNS-Suche der Einträge "MX" (Mail Exchanger ) und "Host (A)" kann aus folgenden Gründen fehlschlagen:

  • Der DNS-Server ist wegen eines Netzwerkfehlers oder aus anderen Gründen nicht verfügbar oder antwortet nicht.

  • Der Eintrag "Host (A)" für den Remoteserver fehlt auf dem DNS-Server, da der Eintrag nicht verfügbar oder falsch ist.

  • Der DNS-Server ist nicht für die dynamische Aktualisierung von Hosteinträgen konfiguriert.

  • Das System versucht, Unzustellbarkeitsberichte als Antwort auf Spamnachrichten zu senden, die ihre Ursprungsdomänen tarnen. Ist dies der Fall, sollten Sie die Nachrichten löschen. Weitere Informationen finden Sie unter dem Link für das Exchange Server-Tool Badmail löschen und archivieren im Abschnitt Weitere Informationen weiter unten.

So stellen Sie sicher, dass der DNS-Server online ist und die Einträge "MX" und "Host" vorhanden sind

  1. Überprüfen Sie, ob der DNS-Server ausgeführt wird, indem Sie die folgenden Schritte ausführen:

    • Untersuchen Sie den Status des DNS-Servers mithilfe des DNS-Administrationsprogramms auf dem DNS-Server.

    • Starten Sie den DNS-Server neu. Weitere Informationen finden Sie unter "Start, stop, pause, or restart a DNS server" (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Untersuchen Sie die Reaktionsbereitschaft des DNS-Servers mithilfe des Befehls nslookup. Weitere Informationen finden Sie unter "Verify DNS server responsiveness using the nslookup command" (http://go.microsoft.com/fwlink/?LinkId=63000).

  2. Überprüfen Sie mit nslookup, ob die MX-Einträge (Mail Exchanger) ordnungsgemäß konfiguriert sind. Weitere Informationen finden Sie unter "Überprüfen der Konfiguration von MX-Einträgen mithilfe von Nslookup " im Abschnitt "Überprüfen des DNS-Designs und der Konfiguration" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  3. Verwenden Sie nslookup, um zu überprüfen, ob der Eintrag "Host (A)" auf dem DNS-Server vorhanden ist. Weitere Informationen finden Sie unter "To verify A resource records exist in DNS" (http://go.microsoft.com/fwlink/?LinkId=63001).

  4. Wenn der Eintrag "Host (A)" nicht vorhanden ist, fügen Sie den "A"-Ressourceneintrag manuell hinzu oder ändern ihn bzw. konfigurieren den DNS-Server so, dass dynamische Eintragsaktualisierungen zulässig sind.

    • Fügen Sie manuell einen "A"-Ressourceneintrag hinzu. Weitere Informationen finden Sie unter „Add a resource record to a DNS zone" (http://go.microsoft.com/fwlink/?LinkId=63002).

    • Ändern Sie einen "A"-Ressourceneintrag manuell. Anweisungen finden Sie unter "Modify an existing resource record" (http://go.microsoft.com/fwlink/?LinkId=63014).

    • Konfigurieren Sie auf dem DNS-Server die dynamische Aktualisierung von Hosteinträgen. Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 816592, "Konfigurieren der dynamischen DNS-Updates in Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592).

Weitere Informationen

  • Weitere Informationen zur Verwendung von DNS durch Exchange Server 2003 zum Auflösen externer IP-Adressen finden Sie unter "Transportabhängigkeiten in Exchange Server 2003" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Informationen zur DNS-Namensauflösung finden Sie im Microsoft Knowledge Base-Artikel 322856, "Konfigurieren von DNS für eine Verwendung mit Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • Informationen zur Behandlung von DNS-Problemen finden Sie unter "Troubleshooting DNS" (http://go.microsoft.com/fwlink/?LinkId=63003).

  • Informationen zur Exchange Server 2003-Systemüberwachung finden Sie unter "System Monitoring with Exchange Management Pack" im Handbuch Exchange Server 2003 Management Pack für MOM 2005 (http://go.microsoft.com/fwlink/?LinkId=47573).

  • Informationen zu "Host (A)"-Ressourceneinträgen finden Sie unter "Managing resource records" (http://go.microsoft.com/fwlink/?LinkId=63004).

  • Weitere Informationen zum Exchange Server-Tool Badmail löschen und archivieren finden Sie in "Exchange Server Badmail Deletion and Archiving" (http://go.microsoft.com/fwlink/?LinkId=84239).


Der Absender kann nicht identifiziert werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-08

Microsoft® Exchange Server Analyzer fragt im Active Directory®-Verzeichnisdienst den Wert des Attributs proxyAddress für alle Benutzerobjekte ab, um zu ermitteln, ob eine Übereinstimmung mit der vom Benutzer angegebenen SMTP-Adresse (Simple Mail Transfer Protocol) des lokalen Absenders vorhanden ist.

Wenn Exchange Server Analyzer für die vom Benutzer angegebene SMTP-Adresse des lokalen Absenders keine Übereinstimmung mit dem Attribut proxyAddress findet, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Dieser Fehler weist darauf hin, dass eine der folgenden Bedingungen vorliegt:

  • Der lokale Absender ist in der lokalen Exchange Server-Organisation nicht vorhanden.

  • Die vom Benutzer angegebene SMTP-Adresse des lokalen Absenders wurde nicht korrekt eingegeben.

Um diesen Fehler zu beheben, überprüfen Sie die angegebene SMTP-Adresse des lokalen Absenders, und versuchen Sie es dann erneut.

So überprüfen Sie die Adresse des lokalen Absenders

  1. Starten Sie den Exchange-System-Manager.

  2. Erweitern Sie Empfänger, und anschließend Alle Globalen Adresslisten.

  3. Klicken Sie mit der rechten Maustaste auf Globale Standardadressliste, und wählen Sie anschließend Eigenschaften aus.

  4. Klicken Sie auf Vorschau, um die SMTP-Adressen der in der globalen Standardadressliste enthaltenen Empfänger anzuzeigen.

  5. Überprüfen Sie, ob der angegebene lokale Absender angezeigt wird, und notieren Sie die SMTP-Adresse.


Die Ereignissenke „CatDbgSink" wurde installiert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest die Daten der LM/SmtpSvc/%SMTPINSTANCE%/EventManager/EventTypes-Eigenschaft in der IIS-Metabase (Internet Information Services), um zu bestimmen, ob das Diagnoseprotokoll des Nachrichtenflusses von CatDbgSink auf einem Computer installiert ist, auf dem Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird.

Die Anwendung CatDbgSink ist eine Ereignissenke, mit der Probleme beim Nachrichtenfluss auf Exchange 2000 Server- bzw. Exchange Server 2003-Computern behoben werden können. Wenn die Anwendung CatDbgSink auf dem Exchange-Server installiert ist, zeigt Exchange Server Analyzer eine Warnung an, dass die Anwendung CatDbgSink installiert ist und nur bei der Behandlung von Problemen beim Nachrichtenfluss verwendet werden sollte.

Die Anwendung CatDbgSink wird normalerweise an Kunden gesendet, um Probleme beim Nachrichtenfluss sowohl auf Exchange 2000 Server- als auch auf Exchange Server 2003-Computern zu behandeln. Die Anwendung CatDbgSink wird normalerweise unter der Anweisung des technischen Supports von Microsoft installiert. Nachdem die Anwendung CatDbgSink installiert und erfolgreich registriert wurde, können Kunden mit der Anwendung CatDbgSink Protokolldateien erstellen, um Informationen zur Behandlung von Problemen beim Nachrichtenfluss auf einem Exchange-Server zu sammeln.

In einigen Fällen kann die Anwendung CatDbgSink nicht vom Exchange-Server für die Produktion entfernt werden, nachdem Sie ein oder mehrere Probleme isoliert und behoben haben. Wenn die Anwendung CatDbgSink nicht vom Exchange-Computer entfernt wird, verursacht CatDbgSink eine deutliche Belastung, die einen unerwünschten Leistungsabfall auf dem Exchange-Server bewirkt. Nachdem Sie Probleme beim Nachrichtenfluss auf einem Exchange-Server für die Produktion diagnostiziert haben, müssen Sie die Anwendung CatDbgSink entfernen.

So beheben Sie diese Warnung

  1. Finden Sie den lokalen Installationsordner von CatDbgSink. Dieser Ordner enthält die folgenden Setup-Dateien: Setup.vbs, CatDbgSink.dll, CatDbgSink.pdb und MustReadMe.txt.

  2. Ändern Sie von einem Eingabeaufforderungsfenster aus das Verzeichnis zu den Setup-Dateien auf dem lokalen Laufwerk, z. B.: C:\CatDbgSink.

  3. Geben Sie an der Eingabeaufforderung den Befehl cscript setup.vbs uninstall 1 ein.
Hinweis:
Die Zahl 1 in der Befehlszeile legt die Instanz des virtuellen SMTP-Servers beginnend bei 1 fest.

Wenn Sie weitere Informationen zur Anwendung CatDbgSink benötigen, wenden Sie sich an den technischen Support von Microsoft (http://support.microsoft.com/default.aspx?pr=cntactms).


Das Katgorisierungsmodul wurde für die SMTP-Instanz deaktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest die Daten der Eigenschaft LM/SmtpSvc/%SMTPInstance%/RoutingSources in der IIS-Metabase (Internet Information Services), um den Zustand des Nachrichtenkategorisierungsmoduls für jede virtuelle SMTP-Serverinstanz auf Computern zu ermitteln, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird.

Exchange Server Analyzer ermittelt, ob der Schlüssel SMTPDSUseCat in der IIS-Metabase vorhanden ist, und meldet anschließend die Ergebnisse. Wenn Exchange Server Analyzer feststellt, dass SMTPDSUseCat vorhanden und deaktiviert ist (festgelegt auf 0X000000), wird von Exchange Server Analyzer ein Fehler angezeigt. Wenn das Nachrichtenkategorisierungsmodul deaktiviert ist, treten beim Exchange-Server schwerwiegende Probleme beim Nachrichtenfluss auf.

In der Standardeinstellung wird der Schlüssel SMTPDSUseCat in der IIS-Metabase erstellt, wenn der SMTP-Dienst auf einem Computer installiert ist, auf dem Microsoft Windows®°2000 Server oder Microsoft Windows Server™ 2003 ausgeführt wird. In der Standardeinstellung ist der Schlüssel SMTPDSUseCat deaktiviert (0). Beim Installieren von Exchange Server wird der IIS-Metabase-Schlüssel SMTPDSUseCat entfernt. Dadurch wird das Nachrichtenkategorisierungsmodul aktiviert. Wenn der SMTP-Dienst oder Exchange Server auf einem Computer installiert ist, auf dem Windows 2000 Server oder Windows Server 2003 ausgeführt wird, wird eine virtuelle SMTP-Server-Standardinstanz (1) erstellt. Das Nachrichtenkategorisierungsmodul kann in Situationen deaktiviert werden, in denen Exchange Server installiert und der SMTP-Dienst deinstalliert ist und dann wieder auf dem Computer installiert wird. Das Nachrichtenkategorisierungsmodul kann auch deaktiviert werden, wenn Software von Drittanbietern installiert wird oder ein administrativer Konfigurationsfehler auftritt.

Hinweis:
Jede virtuelle SMTP-Serverinstanz auf dem Exchange-Server kann den Status des Nachrichtenkategorisierungsmoduls unabhängig steuern.

Das Nachrichtenkategorisierungsmodul überprüft alle Nachrichten, die von den verschiedenen virtuellen SMTP-Serverinstanzen empfangen werden, und ermittelt die Optionen. Die Nachrichten werden möglicherweise an den lokalen Speicher oder mithilfe des MTA (Message Transfer Agent) oder mithilfe von SMTP an einen Remotehost übermittelt. Das Nachrichtenkategorisierungsmodul bearbeitet auch die Aufgliederung der Verteilerliste (Distribution List, DL). Das Nachrichtenkategorisierungsmodul überprüft Meldungen auf SMTP-Servern und bestimmt, wie sie behandelt werden sollen. Das Nachrichtenkategorisierungsmodul ist ein Plug-In für das erweiterte Warteschlangenmodul, das LDAP-Abfragen (Lightweight Directory Access Protocol) im globalen Katalogserver an TCP-Anschluss 3268 durchführt. Das Nachrichtenkategorisierungsmodul stellt eine Sammlung von Ereignissenken dar, die eine erweiterte Adressauflösung für jede Nachricht vornehmen, die vom erweiterten Warteschlangenmodul bearbeitet wird.

Hinweis:
Das Tool für die Neuinstallation von SMTP Smtpreinstall.exe befindet sich auf der Exchange 2000 Server SP2-CD-ROM im Ordner \SUPPORT\UTILS\I386.
So aktivieren Sie das Nachrichtenkategorisierungsmodul mithilfe des Tools für die Neuinstallation von SMTP

  1. Kopieren Sie Smtpreinstall.exe in den Ordner \Exchsrvr\Bin.

  2. Doppelklicken Sie im Ordner \Exchsrvr\Bin auf Smtpreinstall.exe.

  3. Klicken Sie im Microsoft Exchange-Dialogfeld für die Neuinstallation von SMTP auf OK, um den Exchange-Server neu zu starten.

Wenn Sie die Eigenschaften in der IIS-Metabase anzeigen möchten, können Sie dazu das Dienstprogramm Metaedit 2.2 für IIS 4.0/5.0 oder das Dienstprogramm IIS Metabase Explorer für IIS 6.0 installieren.

Achtung:
Es wird nicht empfohlen, die Metabase direkt zu bearbeiten.

Weitere Informationen zum Nachrichtenkategorisierungsmodul oder zu verfügbaren IIS-Metabase-Dienstprogrammen finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 290290, "XIMS: Cannot Send Mail After Re-Installing the IIS SMTP Service" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=290290)

  • 319885, „XCON: Messages Sent in the Exchange 2000 Server Organization Are Not Delivered" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319885)

  • 231729, „XCON: DSUseCat Key and the Message Categorizer" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231729)

  • 232068, „How To: Herunterladen, Installieren und Entfernen des IIS-Programms MetaEdit 2.2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232068)

Informationen zum Downloaden von Tools des IIS 6.0 Resource Kits finden Sie unter „Internet Information Services (IIS) 6.0 Resource Kit Tools" (http://go.microsoft.com/fwlink/?LinkId=33134)


In den letzten 24 Stunden wurde ein Warnungsereignis (ID: 6004) des Kategorisierungsmoduls protokolliert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-10-05

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) Win32_NTLogEvent ab, um zu ermitteln, ob in den letzten 24 Stunden für MSExchangeTransport ein Warnereignis 6004 aufgetreten ist.

Wenn Exchange Server Analyzer feststellt, dass für MSExchangeTransport in den letzten 24 Stunden eine Warnung für ein Ereignis 6004 protokolliert wurde, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass im Kategorisierungsmodul beim Versuch, eine Nachricht zu verarbeiten, ein Fehler aufgetreten ist.

Das Nachrichtenkategorisierungsmodul überprüft Meldungen auf SMTP-Servern (Simple Mail Transfer Protocol) und bestimmt, was mit ihnen passieren soll. Die Nachrichten werden möglicherweise an den lokalen Informationsspeicher oder mithilfe des Message Transfer Agent (MTA) oder mithilfe von SMTP an einen Remotehost übermittelt. Das Kategorisierungsmodul behandelt auch die Aufgliederung der Verteilerliste. Das Kategorisierungsmodul ist ein Plug-In für das Warteschlangenmodul, das LDAP-Abfragen (Lightweight Directory Access Protocol) gegen globale Katalogserver am TCP-Anschluss 3268 durchführt. Das Kategorisierungsmodul stellt eine Sammlung von Ereignissenken dar, die eine erweiterte Adressauflösung an jeder Nachricht vornehmen, die vom erweiterten Warteschlangenmodul bearbeitet wird. Das Kategorisierungsmodul löst Adressen auf, leitet E-Mail-Nachrichten weiter, legt Inhaltskonvertierungsflags fest, erweitert Verteilerlisten, erzwingt globale Einstellungen, generiert Benachrichtigungen über den Übermittlungsstatus und führt alternative Empfängerroutenermittlung, Verzweigung, Aufzeichnung und viele andere Funktionen durch.

Wird eine Nachricht in das Nachrichtenkategorisierungsmodul eingegeben, löst das Kategorisierungsmodul den Umschlagabsender auf, indem es die Proxyadressenattribute im Active Directory®-Verzeichnisdienst sucht. Das Kategorisierungsmodul löst auch den Umschlagempfänger auf, indem es jedes Proxyadressenattribut in Active Directory sucht. Wenn die Liste beispielsweise eine Verteilerliste einschließt und das Erweitern von Verteilerlisten auf dem Server zugelassen ist, wird die Liste erweitert, um diese Mitglieder einzuschließen.

Possible causes of MSExchangeTransport-Warnung 6004 können sein:

  • Probleme bezüglich des Verzeichnisdienstzugriffs (DSAccess)

  • Verzeichnisreplikations-Latenzzeit oder -Fehler

  • Überlastete globale Katalogserver

  • Probleme mit DNS

So beheben Sie diese Warnung

  • Vergewissern Sie sich, dass Exchange Server eine Verbindung zu mindestens einem globalen Katalogserver hat. Dafür ist das Netzwerkmonitor-Tool in Windows sehr gut geeignet.

  • Überprüfen Sie alle erstellten Benachrichtigungen über den Übermittlungsstatus. Benachrichtigungen über den Übermittlungsstatus können Unzustellbarkeitsberichte enthalten. Benachrichtigungen über den Übermittlungsstatus beschreiben dauerhafte Fehlermeldungen und vorübergehende Fehlermeldungen, die häufig als dauerhafte Übermittlungsfehler enden.

  • Mit der Nachrichtenverfolgung können Sie Meldungen beheben, die im Kategorisierungsmodul festsitzen.

  • Mit dem Tool „Archive Sink" können Sie Nachrichten archivieren und analysieren, die bei Exchange Server ein- oder ausgehen.

  • Überwachen Sie mithilfe des Systemmonitors die Leistungsindikatoren des Kategorisierungsmoduls.

Weitere Informationen zu Exchange Server 2003-Ereignissen und -Fehlern finden Sie im "Events and Errors Message Center" (http://go.microsoft.com/fwlink/?LinkId=34258).

Eine Auflistung der von Exchange Server und Microsoft Windows Small Business Server generierten Benachrichtigungen über den Übermittlungsstatus und zu Unzustellbarkeitsberichten finden Sie im Microsoft Knowledge Base-Artikel 284204, „Benachrichtigungen über den Übermittlungsstatus in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Weitere Informationen zur Verwendung des Nachrichtenstatus in Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 262162, "XADM: Verwenden des Nachrichtenstatus, um eine Nachricht zu verfolgen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162).

  • 246856, "XADM: Aktivieren des Nachrichtenstatus in Exchange 2000 Server und Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856).

  • 821905, "Nachrichtenstatusereignis-IDs in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905).

  • 823864, "Verbesserte Nachrichtenstatusfunktionen in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864).

Weitere Informationen zum Behandeln von Problemen im Zusammenhang mit Nachrichtenkategorisierungsmodulen finden Sie im Microsoft Support Webcast, „Exchange 2000 Server: Das Nachrichtenkategorisierungsmodul und NDR-Problembehandlung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Weitere Informationen zum Tool Archive Sink finden Sie im Microsoft Knowledge Base-Artikel 307798, „Archive Sink ist in Service Pack 2 verfügbar" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Allgemeine Informationen zum Behandeln von transportbezogenen Problemen finden Sie in den folgenden Microsoft Knowledge Base-Artikeln und -Ressourcen:

  • 821910, "Beheben von Transportproblemen mit Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910).

  • 257265, "Allgemeine Behandlung von Transportproblemen in Exchange 2000 Server und in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265).

  • 895853, "Behandlung von Problemen mit der E-Mail-Weiterleitung in Exchange Server 2003 und Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853).

  • "Problembehandlung bei der Nachrichtenübermittlung und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875).

Die Leistungsindikatoren für das Nachrichtenkategorisierungsmodul werden für jede Instanz des virtuellen SMTP-Servers einzeln veröffentlicht. Eine Liste der verfügbaren Leistungsindikatoren im Zusammenhang mit dem Nachrichtenkategorisierungsmodul finden Sie im Microsoft Knowledge Base-Artikel 231734, „XCON: Leistungsindikatoren für das Nachrichtenkategorisierungsmodul" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).


In den letzten 24 Stunden wurde ein Warnungsereignis (ID: 6006) des Kategorisierungsmoduls protokolliert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-10-06

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) Win32_NTLogEvent ab, um zu ermitteln, ob in den letzten 24 Stunden für MSExchangeTransport ein Warnereignis 6006 aufgetreten ist.

Wenn Exchange Server Analyzer feststellt, dass für MSExchangeTransport in den letzten 24 Stunden eine Warnung für ein Ereignis 6006 protokolliert wurde, wird eine Warnung angezeigt.

Diese Warnung bedeutet, dass sich Nachrichten im Nachrichtenkategorisierungsmodul angehäuft haben.

Das Nachrichtenkategorisierungsmodul überprüft Meldungen auf SMTP-Servern (Simple Mail Transfer Protocol) und bestimmt, was mit ihnen passieren soll. Die Nachrichten werden möglicherweise an den lokalen Informationsspeicher oder mithilfe des Message Transfer Agent (MTA) oder mithilfe von SMTP an einen Remotehost übermittelt. Das Kategorisierungsmodul behandelt auch die Aufgliederung der Verteilerliste. Das Kategorisierungsmodul ist ein Plug-In für das Warteschlangenmodul, das LDAP-Abfragen (Lightweight Directory Access Protocol) gegen globale Katalogserver am TCP-Anschluss 3268 durchführt. Das Kategorisierungsmodul stellt eine Sammlung von Ereignissenken dar, die eine erweiterte Adressauflösung an jeder Nachricht vornehmen, die vom erweiterten Warteschlangenmodul bearbeitet wird. Das Kategorisierungsmodul löst Adressen auf, leitet E-Mail-Nachrichten weiter, legt Inhaltskonvertierungsflags fest, erweitert Verteilerlisten, erzwingt globale Einstellungen, generiert Benachrichtigungen über den Übermittlungsstatus und führt alternative Empfängerroutenermittlung, Verzweigung, Aufzeichnung und viele andere Funktionen durch.

Wird eine Nachricht in das Nachrichtenkategorisierungsmodul eingegeben, löst das Kategorisierungsmodul den Umschlagabsender auf, indem es die Proxyadressenattribute im Active Directory®-Verzeichnisdienst sucht. Das Kategorisierungsmodul löst auch den Umschlagempfänger auf, indem es jedes Proxyadressenattribut in Active Directory sucht. Wenn die Liste beispielsweise eine Verteilerliste einschließt und das Erweitern von Verteilerlisten auf dem Server zugelassen ist, wird die Liste erweitert, um diese Mitglieder einzuschließen.

Possible causes of MSExchangeTransport-Warnung 6006 können sein:

  • Veraltete oder fehlerhaft konfigurierte Antivirussoftware.

  • Übermäßige Verteilerlistenaufgliederung

  • Fehlerhaft konfigurierte Journalempfänger.

  • Fehlerhaft konfigurierte Berechtigungen für Exchange-Objekte in Active Directory.

So beheben Sie diese Warnung

  • Stellen Sie sicher, dass die Antivirusanwendung auf Dateiebene richtig konfiguriert ist und bestimmte Exchange Server-Verzeichnisse ausschließt. Welche Ordner beim Scannen von Servern, auf denen Microsoft Exchange Server ausgeführt wird, ausgespart werden sollten, erfahren Sie in Microsoft Knowledge Base-Artikel 823166, "Überblick über Exchange Server 2003 und Antivirussoftware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Stellen Sie sicher, dass Sie die aktuellste Version der Antivirusanwendung einsetzen.

  • Überprüfen Sie die Einstellungen der Übermittlungseinschränkungen für die Verteilergruppe, und entfernen Sie nicht erforderliche Einschränkungen.

  • Überprüfen Sie die Journaleinstellungen auf eine mögliche falsche Konfiguration.

  • Überprüfen Sie die Exchange-Objekte in Active Directory auf fehlerhaft konfigurierte Berechtigungen.

Weitere Informationen

Weitere Informationen zu der nicht hierarchischen Einschränkungsüberprüfung finden Sie unter Empfohlene Vorgehensweise: Nicht hierarchische Einschränkungsüberprüfung..

Weitere Informationen zu der Auswirkung der Verteilergruppeneinschränkung auf die Nachrichtenübermittlung in Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 895407, "Die Nachrichtenübermittlung zu lokalen und externen Postfächern ist in Exchange Server 2003 langsamer als erwartet, nachdem Sie die Übermittlungseinschränkungen basierend auf Verteilergruppen konfiguriert haben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 839949, "Problembehandlung bei E-Mail-Transport und Verteilergruppen in Exchange 2000 Server und in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • 812298, "Übermittlung von E-Mails ist langsam, nachdem Sie Übermittlungseinschränkungen konfiguriert haben, die auf einer Verteilerliste basieren" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

Weitere Informationen zum Bereitstellen einer Journallösung finden Sie unter "Journalfunktionen in Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47581).

Weitere Informationen zu den möglichen Ursachen für das Warnungsereignis ID 6006 des Kategorisierungsmoduls finden Sie in Microsoft Knowledge Base-Artikel 922256, "E-Mail-Nachrichten sitzen in der Warteschlange für Nachrichten, die auf die Verzeichnissuche warten, in einer Exchange Server 2003-Organisation fest" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=922256).

Weitere Informationen zu Exchange Server 2003-Ereignissen und -Fehlern finden Sie im "Events and Errors Message Center" (http://go.microsoft.com/fwlink/?LinkId=34258).

Eine Auflistung der von Exchange Server und Microsoft Windows Small Business Server generierten Benachrichtigungen über den Übermittlungsstatus und zu Unzustellbarkeitsberichten finden Sie im Microsoft Knowledge Base-Artikel 284204, „Benachrichtigungen über den Übermittlungsstatus in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Weitere Informationen zum Behandeln von Problemen im Zusammenhang mit Nachrichtenkategorisierungsmodulen finden Sie im Microsoft Support Webcast, „Exchange 2000 Server: Das Nachrichtenkategorisierungsmodul und NDR-Problembehandlung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Allgemeine Informationen zum Behandeln von transportbezogenen Problemen finden Sie in den folgenden Microsoft Knowledge Base-Artikeln und -Ressourcen:

  • 821910, "Beheben von Transportproblemen mit Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910).

  • 257265, "Allgemeine Behandlung von Transportproblemen in Exchange 2000 Server und in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265).

  • 895853, "Behandlung von Problemen mit der E-Mail-Weiterleitung in Exchange Server 2003 und Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853).

  • "Problembehandlung bei der Nachrichtenübermittlung und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875).

Die Leistungsindikatoren für das Nachrichtenkategorisierungsmodul werden für jede Instanz des virtuellen SMTP-Servers einzeln veröffentlicht. Eine Liste der verfügbaren Leistungsindikatoren im Zusammenhang mit dem Nachrichtenkategorisierungsmodul finden Sie im Microsoft Knowledge Base-Artikel 231734, „XCON: Leistungsindikatoren für das Nachrichtenkategorisierungsmodul" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).


In den letzten 24 Stunden wurde ein Warnungsereignis (ID: 6008) des Kategorisierungsmoduls protokolliert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-10-06

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) Win32_NTLogEvent ab, um zu ermitteln, ob in den letzten 24 Stunden für MSExchangeTransport ein Warnereignis 6008 aufgetreten ist.

Wenn Exchange Server Analyzer feststellt, dass für MSExchangeTransport in den letzten 24 Stunden eine Warnung für ein Ereignis 6008 protokolliert wurde, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass im Kategorisierungsmodul beim Versuch, eine Nachricht zu verarbeiten, ein Fehler aufgetreten ist.

Das Nachrichtenkategorisierungsmodul überprüft Meldungen auf SMTP-Servern (Simple Mail Transfer Protocol) und bestimmt, was mit ihnen passieren soll. Die Nachrichten werden möglicherweise an den lokalen Informationsspeicher oder mithilfe des Message Transfer Agent (MTA) oder mithilfe von SMTP an einen Remotehost übermittelt. Das Kategorisierungsmodul behandelt auch die Aufgliederung der Verteilerliste. Das Kategorisierungsmodul ist ein Plug-In für das Warteschlangenmodul, das LDAP-Abfragen (Lightweight Directory Access Protocol) gegen globale Katalogserver am TCP-Anschluss 3268 durchführt. Das Kategorisierungsmodul stellt eine Sammlung von Ereignissenken dar, die eine erweiterte Adressauflösung an jeder Nachricht vornehmen, die vom erweiterten Warteschlangenmodul bearbeitet wird. Das Kategorisierungsmodul löst Adressen auf, leitet E-Mail-Nachrichten weiter, legt Inhaltskonvertierungsflags fest, erweitert Verteilerlisten, erzwingt globale Einstellungen, generiert Benachrichtigungen über den Übermittlungsstatus und führt alternative Empfängerroutenermittlung, Verzweigung, Aufzeichnung und viele andere Funktionen durch.

Wird eine Nachricht in das Nachrichtenkategorisierungsmodul eingegeben, löst das Kategorisierungsmodul den Umschlagabsender auf, indem es die Proxyadressenattribute im Active Directory®-Verzeichnisdienst sucht. Das Kategorisierungsmodul löst auch den Umschlagempfänger auf, indem es jedes Proxyadressenattribut in Active Directory sucht. Wenn die Liste beispielsweise eine Verteilerliste einschließt und das Erweitern von Verteilerlisten auf dem Server zugelassen ist, wird die Liste erweitert, um diese Mitglieder einzuschließen.

Possible causes of MSExchangeTransport-Warnung 6008 können sein:

  • Probleme bezüglich des Verzeichnisdienstzugriffs (DSAccess)

  • Verzeichnisreplikations-Latenzzeit oder -Fehler

  • Überlastete globale Katalogserver

  • Probleme mit DNS

  • Übermäßige Verteilerlistenaufgliederung

So beheben Sie diese Warnung

  • Vergewissern Sie sich, dass Exchange Server eine Verbindung zu mindestens einem globalen Katalogserver hat. Dafür ist das Netzwerkmonitor-Tool in Windows sehr gut geeignet.

  • Überprüfen Sie alle erstellten Benachrichtigungen über den Übermittlungsstatus. Benachrichtigungen über den Übermittlungsstatus können Unzustellbarkeitsberichte enthalten. Benachrichtigungen über den Übermittlungsstatus beschreiben dauerhafte Fehlermeldungen und vorübergehende Fehlermeldungen, die häufig als dauerhafte Übermittlungsfehler enden.

  • Mit der Nachrichtenverfolgung können Sie Meldungen beheben, die im Kategorisierungsmodul festsitzen.

  • Mit dem Tool „Archive Sink" können Sie Nachrichten archivieren und analysieren, die bei Exchange Server ein- oder ausgehen.

  • Überwachen Sie mithilfe des Systemmonitors die Leistungsindikatoren des Kategorisierungsmoduls.

  • Überprüfen Sie die Einstellungen der Übermittlungseinschränkungen für die Verteilergruppe, und entfernen Sie nicht erforderliche Einschränkungen.

Weitere Informationen zu Exchange Server 2003-Ereignissen und -Fehlern finden Sie im "Events and Errors Message Center" (http://go.microsoft.com/fwlink/?LinkId=34258).

Eine Auflistung der von Exchange Server und Microsoft Windows Small Business Server generierten Benachrichtigungen über den Übermittlungsstatus und zu Unzustellbarkeitsberichten finden Sie im Microsoft Knowledge Base-Artikel 284204, „Benachrichtigungen über den Übermittlungsstatus in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Weitere Informationen zur Verwendung des Nachrichtenstatus in Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 262162, "XADM: Verwenden des Nachrichtenstatus, um eine Nachricht zu verfolgen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162).

  • 246856, "XADM: Aktivieren des Nachrichtenstatus in Exchange 2000 Server und Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856).

  • 821905, "Nachrichtenstatusereignis-IDs in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905).

  • 823864, "Verbesserte Nachrichtenstatusfunktionen in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864).

Weitere Informationen zum Behandeln von Problemen im Zusammenhang mit Nachrichtenkategorisierungsmodulen finden Sie im Microsoft Support Webcast, „Exchange 2000 Server: Das Nachrichtenkategorisierungsmodul und NDR-Problembehandlung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Weitere Informationen zum Tool Archive Sink finden Sie im Microsoft Knowledge Base-Artikel 307798, „Archive Sink ist in Service Pack 2 verfügbar" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Weitere Informationen zu der nicht hierarchischen Einschränkungsüberprüfung finden Sie unter Empfohlene Vorgehensweise: Nicht hierarchische Einschränkungsüberprüfung..

Weitere Informationen zu der Auswirkung der Verteilergruppeneinschränkung auf die Nachrichtenübermittlung in Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 895407, "Die Nachrichtenübermittlung zu lokalen und externen Postfächern ist in Exchange Server 2003 langsamer als erwartet, nachdem Sie die Übermittlungseinschränkungen basierend auf Verteilergruppen konfiguriert haben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 839949, "Problembehandlung bei E-Mail-Transport und Verteilergruppen in Exchange 2000 Server und in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • 812298, "Übermittlung von E-Mails ist langsam, nachdem Sie Übermittlungseinschränkungen konfiguriert haben, die auf einer Verteilerliste basieren" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

Allgemeine Informationen zum Behandeln von transportbezogenen Problemen finden Sie in den folgenden Microsoft Knowledge Base-Artikeln und -Ressourcen:

  • 821910, "Beheben von Transportproblemen mit Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910).

  • 257265, "Allgemeine Behandlung von Transportproblemen in Exchange 2000 Server und in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265).

  • 895853, "Behandlung von Problemen mit der E-Mail-Weiterleitung in Exchange Server 2003 und Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853).

  • "Problembehandlung bei der Nachrichtenübermittlung und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875).

Die Leistungsindikatoren für das Nachrichtenkategorisierungsmodul werden für jede Instanz des virtuellen SMTP-Servers einzeln veröffentlicht. Eine Liste der verfügbaren Leistungsindikatoren im Zusammenhang mit dem Nachrichtenkategorisierungsmodul finden Sie im Microsoft Knowledge Base-Artikel 231734, „XCON: Leistungsindikatoren für das Nachrichtenkategorisierungsmodul" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).


Verbindungsfilterung ist aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob die Eigenschaft msExchServerBindingsFiltering eines virtuellen SMTP-Serverobjekts (Simple Mail Transfer Protocol) angibt, dass die Verbindungsfilterung für eine virtuelle SMTP-Serverinstanz aktiviert ist.

Exchange Server Analyzer fragt Active Directory auch ab, um zu ermitteln, ob die Eigenschaften msExchSmtpConnectionRulesPriority, msExchSMTPGlobalIPAcceptList oder msExchSMTPGlobalIPDenyList angeben, dass die Verbindungsfilterung ebenfalls auf der Ebene der globalen Einstellungen aktiviert ist.

Exchange Server Analyzer zeigt eine Warnmeldung an, wenn die folgenden Bedingungen vorliegen:

  • Die Verbindungsfilterung ist für eine virtuelle SMTP-Serverinstanz aktiviert.

  • Die Verbindungsfilterung ist auf der Ebene der globalen Einstellungen aktiviert.

Diese Warnung bedeutet, dass die Verbindungsfilterung wirksam aktiviert ist. Die Verbindungsfilterung stellt in der Regel kein Problem dar. Beim Behandeln von Problemen mit dem Nachrichtenfluss eines bestimmten Servers müssen Sie jedoch ggf. die Filterkonfiguration überprüfen oder die Verbindungsfilterung vorübergehend deaktivieren, um zu ermitteln, ob diese fälschlicherweise erwünschte E-Mail blockiert.

So deaktivieren Sie einen Verbindungsfilter auf einem virtuellen SMTP-Server

  1. Starten Sie den Exchange-System-Manager: Klicken Sie auf Start, zeigen Sie auf Alle Programme, zeigen Sie auf Microsoft Exchange, und klicken Sie dann auf System-Manager.

  2. Erweitern Sie in der Konsolenstruktur Server, dann den gewünschten Server, danach Protokolle und anschließend SMTP.

  3. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server, auf dem Sie den Filter deaktivieren möchten, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie im Dialogfeld <Eigenschaften des virtuellen-SMTP-Servers> auf der Registerkarte Allgemein auf Erweitert.

  5. Wählen Sie in Erweitert die IP-Adresse aus, für die Sie den Filter deaktivieren möchten, und klicken Sie auf Bearbeiten.

  6. Deaktivieren Sie in Identifikation die Option Verbindungsfilter anwenden, um den Filter zu deaktivieren.

  7. Sind mehrere virtuelle Server vorhanden, wiederholen Sie die Schritte 3 bis 6 für jeden virtuellen Server, auf dem Sie den Filter deaktivieren möchten.

Weitere Informationen zum Konfigurieren von Verbindungsfiltern finden Sie im Microsoft Knowledge Base-Artikel 823866, "Konfigurieren der Verbindungsfilterung für die Verwendung von Realtime Block Lists (RBLs) und Konfigurieren von Empfängerfilterung in Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823866).

Weitere Informationen zur intelligenten Nachrichtenfilterung finden Sie auf der Website "Exchange Intelligent Message Filter" (http://go.microsoft.com/fwlink/?LinkId=21607).


Für den Connector sind Annahmeeinschränkungen festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs dLMemDefault für jeden SMTP-Connector in der Routinggruppe zu bestimmen. Exchange Server Analyzer fragt auch Active Directory ab, um für jeden Connector den Wert der Attribute authOrig und unauthOrig zu ermitteln. Die Attribute unauthOrig und authOrig enthalten Listen von DNs (Distinguished Names) von Konten.

In der Standardeinstellung lassen alle SMTP-Connectors zu, dass Benutzer Nachrichten über den Connector senden. Wenn dLMemDefault auf die Standardeinstellung 1 festgelegt ist, werden Nachrichten von allen Absendern akzeptiert, mit Ausnahme der Nachrichten von den Konten, die im Attribut unauthOrig aufgelistet sind. Wenn dLMemDefault auf 0 (null) festgelegt ist, werden Nachrichten von allen Absendern abgelehnt, mit Ausnahme der Nachrichten von den Konten, die im Attribut authOrig aufgelistet sind.

Microsoft Exchange Server Analyzer zeigt eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht, wenn die folgenden Bedingungen erfüllt sind:

  • Der Wert für das Attribut dLMemDefault ist auf 0 (null) festgelegt.

  • Das Attribut authOrig enthält Werte.

Der von Exchange Server Analyzer angegebene Connector ist so konfiguriert, dass er nur ausgewählte Nachrichten akzeptiert. Nur die Konten, denen auf der Registerkarte Empfangseinschränkungen des Connectors explizite Berechtigungen zugewiesen wurden, dürfen Nachrichten über den Connector senden.

Die Meldung, dass die Konfiguration nicht dem Standard entspricht, wird von Microsoft Exchange Server Analyzer nur zu Informationszwecken angezeigt.

Weitere Informationen zu Connectors finden Sie im Transport- und Routing-Handbuch für Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?displaylang=de&FamilyID=c092b7a7-9034-4401-949c-b29d47131622).


Für den Connector sind Ablehnungseinschränkungen festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs dLMemDefault für jeden SMTP-Connector in der Routinggruppe zu bestimmen. Exchange Server Analyzer fragt auch Active Directory ab, um für jeden Connector den Wert der Attribute authOrig und unauthOrig zu ermitteln. Die Attribute unauthOrig und authOrig enthalten Listen von DNs (Distinguished Names) von Konten.

In der Standardeinstellung lassen alle SMTP-Connectors zu, dass Benutzer Nachrichten über den Connector senden. Wenn dLMemDefault auf die Standardeinstellung 1 festgelegt ist, werden Nachrichten von allen Absendern akzeptiert, mit Ausnahme der Nachrichten von den Konten, die im Attribut unauthOrig aufgelistet sind. Wenn dLMemDefault auf 0 festgelegt ist, werden Nachrichten von allen Absendern abgelehnt, mit Ausnahme der Nachrichten von den Konten, die im Attribut authOrig aufgelistet sind.

Microsoft Exchange Server Analyzer zeigt eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht, wenn die folgenden Bedingungen erfüllt sind:

  • Der Wert für das Attribut dLMemDefault ist auf 1 festgelegt.

  • Das Attribut unauthOrig enthält Werte.

Der von Microsoft Exchange Server Analyzer angegebene Connector ist so konfiguriert, dass er einige Nachrichten ablehnt. Die Konten, für die auf der Registerkarte Empfangseinschränkungen des Connectors explizite Berechtigungen verweigert wurden, dürfen keine Nachrichten über den Connector senden.

Die Meldung, dass die Konfiguration nicht dem Standard entspricht, wird von Microsoft Exchange Server Analyzer nur zu Informationszwecken angezeigt.

Weitere Informationen zu Connectors finden Sie im Transport- und Routing-Handbuch für Exchange Server 2003 unter http://www.microsoft.com/germany/technet/datenbank/articles/600421.mspx.


Connector lehnt in der Standardeinstellung alle Nachrichten ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs dLMemDefault für die einzelnen Connectors zu ermitteln. Mit dem Attribut dLMemDefault wird gesteuert, ob Nachrichten in der Standardeinstellung angenommen oder abgelehnt werden.

Mit dem Wert 0 für das Attribut dLMemDefault wird angegeben, dass Nachrichten in der Standardeinstellung abgelehnt werden. Mit dem Wert 1 für das Attribut dLMemDefault wird angegeben, dass Nachrichten in der Standardeinstellung angenommen werden. Wenn Exchange Server Analyzer erkennt, dass der Wert des Attributs dLMemDefault gleich 0 ist, zeigt Microsoft Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der von Exchange Server Analyzer angegebene Connector ist so konfiguriert, dass in der Standardeinstellung alle Nachrichten abgelehnt werden. Nur die Konten, denen auf der Registerkarte Empfangseinschränkungen des Connectors explizite Berechtigungen zugewiesen wurden, dürfen Nachrichten über den Connector senden.

Die Meldung, dass die Konfiguration nicht dem Standard entspricht, wird von Microsoft Exchange Server Analyzer nur zu Informationszwecken angezeigt.

Weitere Informationen zu Connectors finden Sie im Transport- und Routing-Handbuch für Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=c092b7a7-9034-4401-949c-b29d47131622&DisplayLang=de).


Connector-Einschränkungsprüfung ist aktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungszweig, um zu bestimmen, ob der Registrierungswert CheckConnectorRestrictions vorhanden und konfiguriert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

Wenn Exchange Server Analyzer feststellt, dass der Wert CheckConnectorRestrictions auf 1 festgelegt wurde, wird eine Warnung angezeigt.

Falls Sie eine auf der Verteilerliste basierende Einschränkung für einen Connector anwenden möchten, müssen Sie den Prüfprozess für diese Einschränkungen manuell aktivieren. Die Einschränkungsprüfung wird über den Registrierungswert CheckConnectorRestrictions gesteuert, der auf dem Exchange-Bridgeheadserver festgelegt wird. Dieser Server ist die Quelle für den zu prüfenden Connector. Wenn Sie eine Einschränkung festlegen, jedoch keinen Registrierungswert für CheckConnectorRestrictions angeben, erfolgt keine Einschränkungsprüfung.

Die Einschränkungsprüfung für den Connector ist im Standardmodus deaktiviert, da eine Erweiterung der Verteilergruppen und eine Einschränkungsprüfung für jede Nachricht, die durch das System transportiert wird, eine deutliche Beeinträchtigung der Leistung zur Folge hat. Aktivieren Sie diese Einstellung nur bei Bedarf (z. B. auf dem Bridgeheadserver für den eingeschränkten Connector).

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So deaktivieren Sie die Einschränkungsprüfung für den Connector

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\Resvc\Parameters

  3. Suchen Sie im rechten Bereich den Wert CheckConnectorRestrictions, und löschen Sie ihn.

  4. Schließen Sie den Registrierungseditor, und starten Sie dann die Dienste Microsoft Exchange Routing Engine und Simple Mail Transfer Protocol (SMTP), damit die Änderung übernommen wird.

Weitere Informationen zum Bearbeiten der Registrierung finden Sie im Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Weitere Informationen zur Einschränkungsüberprüfung für den Registrierungswert des Connectors finden Sie in Artikel 277872 der Microsoft Knowledge Base „XCON: Connector Delivery Restrictions May Not Work Correctly" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872.


Connector besitzt einen Bereich für die lokale Weiterleitung
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-04-21

Microsoft®Microsoft Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchRoutingSMTPConnector für die einzelnen SMTP-Connectors zu ermitteln. Wenn Exchange Server Analyzer erkennt, dass der Wert des Attributs msExchRoutingSMTPConnector die Zeichenfolge „Local:" enthält, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht. Das Vorhandensein der Zeichenfolge „Local:" gibt an, dass der SMTP-Connector einen Bereich für die lokale Weiterleitung besitzt.

Ein SMTP-Connector legt für E-Mails eine gesonderte Route fest. Sie können mit dem SMTP-Connector einen Gateway für Intermails einrichten oder eine Verbindung zu einer bestimmten Domäne oder einem bestimmten Mailsystem herstellen. Mit Connectors können Sie bestimmte Optionen für die angegebene Mailroute festlegen.

Obwohl Sie über einen virtuellen SMTP-Server auch Internetmails senden und empfangen können, konfigurieren viele Organisationen zum Weiterleiten von Internetmails einen speziellen Connector. Es wird empfohlen, einen SMTP-Connector zu verwenden, da dieser eine gesonderte Route für Internetmails bereitstellt. Außerdem ist auf einem SMTP-Connector eine größere Anzahl an Optionen als auf dem virtuellen SMTP-Server verfügbar.

Die Meldung, dass die Konfiguration nicht dem Standard entspricht, wird von Microsoft Exchange Server Analyzer nur zu Informationszwecken angezeigt.

Weitere Informationen zu SMTP-Connectors finden Sie im Transport- und Routing-Handbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


Empfohlene Vorgehensweise: Nicht hierarchische Einschränkungsüberprüfung.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für jedes ExchangeServer-Objekt im Verzeichnis zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs serialNumber für ein ExchangeServer 2003-Serverobjekt in seinem Zeichenfolgenwert Service Pack 2 enthält, liest Exchange Server Analyzer danach den folgenden Registrierungsschlüssel, um zu ermitteln, ob der Registrierungswert CheckConnectorRestrictions vorhanden und konfiguriert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

Diese Bedingung zeigt an, dass vom Server vor der Verarbeitung einer Nachricht Sende- und Empfangseinschränkungen überprüft werden.

Wenn Exchange Server Analyzer feststellt, dass der Wert für CheckConnectorRestrictions vorhanden ist, auf 1, festgelegt und somit aktiviert ist, liest Exchange Server Analyzer auch den Registrierungsschlüssel HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod , um zu ermitteln, ob der Registrierungswert RestrictionMethod vorhanden ist und wie er konfiguriert ist.

Wenn Exchange Server Analyzer erkennt, dass der Registrierungswert RestrictionMethod fehlt oder auf einen anderen Wert als 2 festgelegt ist, zeigt Exchange Server Analyzer eine Meldung mit der optimalen Methode an.

Zusammenfassend gesagt, zeigt Exchange Server Analyzer eine Meldung mit der optimalen Methode an, wenn die folgenden Bedingungen erfüllt sind:

  • Auf dem Exchange Server 2003-Server ist SP 2 installiert.

  • Der Registrierungswert CheckConnectorRestrictions von HKLM\System\CurrentControlSet\Services\Resvc\Parameters ist so konfiguriert, dass eine auf einer Verteilerliste basierende Einschränkung für einen Connector auf dem lokalen Computer verwendet werden kann.

  • Der Registrierungswert RestrictionMethod von HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod fehlt oder ist auf einen anderen Wert als 2 festgelegt.

Der Wert von RestrictionMethod bestimmt, wie das Kategorisierungsmodul Einschränkungen verarbeitet. Das Standardverhalten des Kategorisierungsmoduls besteht darin, Verteilergruppen rekursiv zu erweitern und die Einschränkungen für jede Nachricht zu überprüfen, die das System durchläuft. Dieses Verhalten des Kategorisierungsmoduls kann die Leistung erheblich beeinträchtigen und stellt keine optimale Methode dar.

Wenn der Wert von RestrictionMethod auf 2 festgelegt wird, erweitern die Transportkomponenten für diesen Exchange-Server die Mitgliedschaft der Verteilergruppen nicht, während der Server die Einschränkungen überprüft. Diese Konfiguration stellt die beste Leistung für Einschränkungsüberprüfungen bereit. Darüber hinaus müssen alle Verteilergruppen mit Benutzern, für die Übermittlungseinschränkungen gelten, flach sein, damit der Registrierungseintrag RestrictionMethod wirksam wird. Das heißt, dass die eingeschränkten Verteilergruppen keine geschachtelten Verteilergruppen aufweisen dürfen. Die Erweiterungslogik funktioniert nicht, wenn die eingeschränkten Verteilergruppen geschachtelt sind.

Für Verteilergruppen, die in Connectoreinschränkungen verwendet werden, wird empfohlen, den Wert des RestrictionMethod-Registrierungseintrags für einen Connector-Bridgeheadserver festzulegen, der keine Postfächer aufweist. Wenn die eingeschränkten Verteilergruppen über Server für die Aufgliederung der Verteilerlisten verfügen, wird bei Benutzereinschränkungen für Active Directory empfohlen, dass Sie den Registrierungseintrag RestrictionMethod für die Server für die Aufgliederung der Verteilerlisten erstellen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So erstellen Sie den Registrierungseintrag „RestrictionMethod" und legen dessen Wert auf 2 fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

  3. Klicken Sie im linken Bereich auf Parameter.

  4. Zeigen Sie im Menü Bearbeiten auf Neu, und klicken Sie dann auf DWORD-Wert.

  5. Geben Sie RestrictionMethod ein, und drücken Sie danach EINGABETASTE, um den neuen Registrierungseintrag zu benennen.

  6. Klicken Sie mit der rechten Maustaste auf RestrictionMethod, und klicken Sie dann auf Ändern.

  7. Geben Sie 2 ein, und drücken Sie dann die EINGABETASTE.

  8. Beenden Sie den Registrierungs-Editor.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zum Registrierungswert RestrictionMethod finden Sie im Microsoft Knowledge Base-Artikel 895407, „In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

Weitere Informationen zum Registrierungswert finden Sie im Knowledge Base-Artikel 277872 „XCON: Connector Delivery Restrictions May Not Work Correctly" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872.


Der Registrierungsschlüssel „ConvertDSNInternetContent" wurde zum Ausführen der Inhaltskonvertierung für alle Nachrichten konfiguriert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Registrierungswert ConvertDSNInternetContent so konfiguriert wurde, dass eine Inhaltskonvertierung für alle Nachrichten ausgeführt wird, die vom Exchange-Informationsspeicher auf dem Exchange Server 2003-Computer empfangen werden:

HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Der Registrierungswert ConvertDSNInternetContent wurde manuell erstellt.

  • Der Registrierungswert ConvertDSNInternetContent ist auf 1 festgelegt.

Der Datenwert 0 oder kein Wert für den Registrierungswert ConvertDSNInternetContent deaktiviert die Inhaltskonvertierung von SMTP-Nachrichten durch den Exchange-Informationsspeicher. Der Datenwert 1 aktiviert die Inhaltskonvertierung aller Nachrichten, einschließlich SMTP-Nachrichten, für alle virtuellen SMTP-Serverinstanzen (VSI - Virtual Server Instance) oder für einzelne virtuelle Serverinstanzen.

In der Standardeinstellung wird der Registrierungswert ConvertDSNInternetContent während einer Exchange Server-Installation nicht erstellt. Der Registrierungswert ConvertDSNInternetContent kann nach der Serverinstallation von Exchange Server manuell erstellt werden, um das Verhalten der Inhaltskonvertierung auf dem Exchange Server 2003-Computer zu ändern. Im Allgemeinen darf bei übermittelten SMTP-Nachrichten keine Inhaltskonvertierung ausgeführt werden. Wenn Sie die Inhaltskonvertierung für alle Nachrichten aktivieren, einschließlich SMTP-Nachrichten, entsteht auf dem Exchange-Server Verarbeitungsmehraufwand. Dieser zusätzliche Verarbeitungsmehraufwand kann zu Problemen bei der Leistungs- und Protokolldateispeicherung führen.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Sie müssen die Registrierung bearbeiten, um das Inhaltskonvertierungsverhalten des Exchange Server 2003-Computers wieder auf die effizienteste Methode der Inhaltskonvertierung zurückzusetzen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So beheben Sie diese Warnung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zum folgenden Registrierungsschlüssel: HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

  3. Klicken Sie im Detailbereich mit der rechten Maustaste auf den Registrierungswert ConvertDSNInternetContent, klicken Sie auf Ändern, und ändern Sie dann den Wert in 80. Klicken Sie auf OK.

    Hinweis:
    Um den Registrierungswert ConvertDSNInternetContent zu löschen, klicken Sie im Detailbereich mit der rechten Maustaste auf den Registrierungswert ConvertDSNInternetContent und klicken Sie dann auf Löschen. Bestätigen Sie das Löschen des Registrierungswerts, indem Sie im Dialogfeld auf Ja klicken.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den Exchange-Server neu.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zum Bearbeiten der Microsoft Windows-Registrierung finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 322755, „SO WIRD'S GEMACHT: Unter Windows 2000 eine Sicherungskopie der Registrierung erstellen und die Registrierung bearbeiten und wiederherstellen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, „Unter Windows XP und Windows Server 2003 eine Sicherungskopie der Registrierung erstellen und die Registrierung bearbeiten und wiederherstellen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Verteilergruppe wurde als gemeinsames Ziel identifiziert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-10-04

Microsoft® Exchange Server Analyzer fragt die Exchange_Queue WMI-Klasse (Windows® Management Instrumentation) ab, um die Werte der folgenden Attribute für SMTP-Warteschlangen (Simple Mail Transfer Protocol) auf dem virtuellen SMTP-Server zu bestimmen.

LinkId | Gibt den Bezeichner für den Link an, der die Warteschlange enthält.
QueueId | Gibt den Bezeichner der Warteschlange an.
QueueName | Gibt den Namen der Warteschlange an.
VirtualMachine | Gibt den Namen des virtuellen Computers an, der die Warteschlange enthält.
VirtualServerName | Gibt den Namen des virtuellen Servers an, auf dem sich die Warteschlange befindet.
MessageCount | Gibt die Anzahl der Nachrichten in der Warteschlange an.

Exchange Server Analyzer fragt anhand der hier angegebenen Informationen die WMI-Klasse Exchange_QueuedSMTPMessage nach den Werten der folgenden Attribute für Nachrichten in der Warteschlange ab:

Recipients | Gibt die Empfänger der Nachricht an.
Received | Gibt den Zeitstempel des Empfangs der Nachricht an.
MessageId | Gibt den Bezeichner der in der Warteschlange befindlichen Nachricht an.
StateRetry | Gibt an, dass eine Nachricht, die nicht erfolgreich zugestellt werden konnte, erneut übermittelt wird.

Schließlich verwendet Exchange Server Analyzer die hier erhaltenen Daten dazu, um den Active Directory®-Verzeichnisdienst nach dem distinguishedName-Wert für jedes Recipient-Objekt abzufragen. Exchange Server Analyzer ermittelt daraufhin, ob es sich bei dem Empfänger um einen Benutzer, eine Verteilergruppe, einen Öffentlicher Ordner oder einen Informationsspeicher für Öffentliche Ordner handelt.

Wenn Exchange Server Analyzer ermittelt, dass 25 Prozent oder mehr der in der Warteschlange festsitzenden Nachrichten entweder im Feld To: oder im Feld Cc: an eine bestimmte Verteilergruppe adressiert sind, wird eine Warnung angezeigt.

Wenn Exchange Server Analyzer ermittelt, dass 50 Prozent oder mehr der in der Warteschlange festsitzenden Nachrichten entweder im Feld To: oder im Feld Cc: an eine bestimmte Verteilergruppe adressiert sind, wird ein Fehler angezeigt.

Diese Warnung bzw. dieser Fehler bedeutet, dass die identifizierte Verteilergruppe ein gemeinsames Ziel für Nachrichten ist, die in einer SMTP-Warteschlange festsitzen.

Um dieses Problem zu beheben, sollten Sie überprüfen, ob Konfigurationsprobleme oder andere Anomalien für diese Verteilergruppe vorliegen, die dazu führen, dass die an diese Verteilergruppe gerichteten Nachrichten in die Warteschlange gesetzt werden.

  • Stellen Sie sicher, dass die Attribute des Verteilergruppenobjekts ordnungsgemäß eingerichtet wurden und in Active Directory die richtigen Werte enthalten.

  • Überprüfen Sie, ob die Active Directory-Berechtigungen des Verteilergruppenobjekts richtig eingestellt sind.

  • Wenn die Verteilergruppe ein spezielles Benutzerobjekt enthält, d. h. einen vorgesehenen Journalempfänger, überprüfen Sie, ob der Dienst und die Komponenten, mit denen das Benutzerobjekt verknüpft ist, ordnungsgemäß konfiguriert sind.

  • Suchen Sie nach möglichen unerwünschten kommerziellen E-Mails (UCE oder SPAM) oder Virusangriffen auf die Verteilergruppe.

  • Überprüfen Sie, ob die Übermittlungseinschränkungen für die Verteilergruppe richtig eingestellt sind.

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei der Nachrichtenübermittlung und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

Weitere Informationen zu der Auswirkung der Verteilergruppeneinschränkung auf die Nachrichtenübermittlung in Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 895407, "Die Nachrichtenübermittlung zu lokalen und externen Postfächern ist in Exchange Server 2003 langsamer als erwartet, nachdem Sie die Übermittlungseinschränkungen basierend auf Verteilergruppen konfiguriert haben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407)

  • 329171 "XADM: Übermittlung von E-Mails ist langsam, wenn Empfänger mit Übermittlungseinschränkungen basierend auf der Gruppenmitgliedschaft konfiguriert sind" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • 839949, "Problembehandlung bei E-Mail-Transport und Verteilergruppen in Exchange 2000 Server und in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • 812298, "Übermittlung von E-Mails ist langsam, nachdem Sie Übermittlungseinschränkungen konfiguriert haben, die auf einer Verteilerliste basieren" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).


Frühere Kategorisierungsvorgänge wiesen behebbare Fehler auf
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-09-06

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst Daten der Leistungsindikatoren Kat: Ausgeführte Kategorisierungen und Kat: Länge der Warteschlange des Kategorisierungsmoduls des Leistungsobjekts SMTP Server, um Leistungsdaten zu analysieren.

Der Leistungsindikator Kat: Ausgeführte Kategorisierungen zeigt die Anzahl der zurzeit ausgeführten Kategorisierungen an, während der Leistungsindikator Kat: Länge der Warteschlange des Kategorisierungsmoduls die Anzahl der Nachrichten angibt, die in der Warteschlange des Kategorisierungsmoduls enthalten sind.

Bei dieser Abfrage ruft Microsoft Exchange Server Analyzer zwei Minuten lang alle 6 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den Durchschnittswert des Leistungsindikators innerhalb des Erfassungszeitraums.

Exchange Server Analyzer untersucht die durchschnittliche Anzahl der ausgeführten Kategorisierungen und diese Zahl mit der Anzahl der Kategorisierungen, die sich noch in der Warteschlangen befinden.

Exchange Server Analyzer zeigt einen Fehler an, wenn in dem Erfassungszeitraum folgende Bedingungen zutreffen:

  • Die durchschnittliche Anzahl der ausgeführten Kategorisierungen ist Null.

  • Die durchschnittliche Länge der Warteschlange des Kategorisierungsmoduls ist größer als Null.

Das Kategorisierungsmodul führt die folgenden Kernoperationen aus:

  • Auflösen und Validieren aller Empfänger.

  • Ermitteln von Grenzwerten und Einschränkungen für alle Empfänger.

  • Erweitern von Verteilerlisten, falls erforderlich.

  • Ermitteln, ob eine Nachricht für die lokale oder Remoteübermittlung bestimmt ist.

Dieser Fehler weist darauf hin, dass Nachrichten in der Warteschlange des Kategorisierungsmoduls festsitzen, für die der Kategorisierungsvorgang mit einem behebbaren Fehler fehlgeschlagen ist.

Nachrichten häufen sich im Allgemeinen dann in Warteschlangen an, wenn das erweiterte Warteschlangenmodul eine Nachricht nicht kategorisieren kann. Das erweiterte Warteschlangenmodul kann möglicherweise nicht auf die globalen Katalogserver und auf Empfängerinformationen zugreifen. Unter Umständen sind auch die globalen Katalogserver nicht erreichbar oder überlastet. Darüber hinaus können sich Nachrichten aus den folgenden Gründen anhäufen:

  • Der Active Directory®-Verzeichnisdienst ist nicht erreichbar.

    Hinweis:
    Das Kategorisierungsmodul verwendet Active Directory zum Kategorisieren von Nachrichten.
  • Active Directory ist ggf. überlastet, wenn viele Nachrichten in der Warteschlange für die Vorkategorisierung abgelegt wurden.

  • Ein Konvertierungsfehler liegt vor. Das Kategorisierungsmodul ist auch für die Inhaltskonvertierung zuständig.

  • Das Nachrichtenkategorisierungsmodul kann die Postfachspeicher nicht finden.

  • Wenn SMTP (Simple Mail Transfer Protocol) neu installiert oder entfernt wurde, können die folgenden Metabasisschlüssel der Internetinformationsdienste (IIS) ggf. ungültig geworden sein: /smtpsvc/DsUseCat und /smtpsvc/vsi#/DsUseCat.

    Hinweis:
    Ermitteln Sie, ob SMTP neu installiert oder entfernt wurde.

Sie können die Eigenschaften der Warteschlange untersuchen, um die Ursache für den Fehler zu finden. Wenn in den Warteschlangeneigenschaften eine Nachricht vom Typ "Ein SMTP-Fehler ist aufgetreten" angezeigt wird, müssen Sie die Ereignisprotokolle des Servers auf SMTP-Fehler überprüfen. Enthalten die Protokolle keine Ereignisse, müssen Sie die Protokolliergrad für SMTP erhöhen.

Weitere Informationen zum Behandeln von Problemen mit Exchange und SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft Knowledge Base-Artikel 821877, "Beschreibung der Felder auf den Registerkarten mit den Eigenschaften für SMTP- und X.400-Warteschlangen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)

  • "Behandeln von Leistungsproblemen bei Microsoft Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47588).

  • "Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47576).

Die Leistungsindikatoren für das Nachrichtenkategorisierungsmodul werden für jede Instanz des virtuellen SMTP-Servers einzeln veröffentlicht. Eine Liste der verfügbaren Leistungsindikatoren im Zusammenhang mit dem Nachrichtenkategorisierungsmodul finden Sie im Microsoft Knowledge Base-Artikel 231734, "XCON: Performance Monitor Counters for Message Categorizer" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).


Automatische Aktualisierung für intelligenten Nachrichtenfilter aktivieren
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-02-13

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert für das Attribut serialNumber für sämtliche Exchange Server-Objekte im Verzeichnis zu ermitteln. Das Attribut serialNumber ist ein Zeichenfolgenwert, der die Version von Exchange Server und ggf. die Version des Service Packs enthält. Ein Wert des Attributs serialNumber von Version 6.5 (Build 7638: Service Pack 2) gibt an, dass auf dem Server Exchange Server 2003 Service Pack 2 ausgeführt wird.

Exchange Server Analyzer fragt außerdem die Microsoft Windows®-Verwaltungsinstrumentationsklasse (Windows® Management Instrumentation, WMI) Win32_Service ab, um den Wert des Schlu¨ssels Started für ClusSvc, den Clusterdienst, zu ermitteln. Der Wert True gibt an, dass der Clusterdienst ausgeführt wird, und der Wert False gibt an, dass er nicht ausgeführt wird.

Exchange Server Analyzer liest ebenfalls den folgenden Registrierungseintrag, um zu ermitteln, ob der intelligente Nachrichtenfilter von Microsoft Exchange auf dem Server installiert und aktiviert ist:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

Wenn Exchange Server Analyzer feststellt, dass im Registrierungsschlüssel ContentFilter der Eintrag ContentFilterBindings vorhanden ist, der Wert ContentFilterBindings aber nicht konfiguriert ist, zeigt dies an, dass der intelligente Nachrichtenfilter auf dem Server nicht aktiviert ist.

Schließlich fragt Exchange Server Analyzer folgenden Registrierungseintrag ab, um zu ermitteln, ob der Unterschlüssel ContentFilterState vorhanden ist und ob die automatische Aktualisierung für den intelligenten Nachrichtenfilter auf dem Server aktiviert ist.

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\

Jeder andere Wert als 1 für den Unterschlüssel ContentFilterState zeigt an, dass die automatische Aktualisierung für den intelligenten Nachrichtenfilter nicht aktiviert ist.

Exchange Server Analyzer zeigt eine Best Practices-Meldung an, wenn folgende Bedingungen erfüllt sind:

  • Auf dem Server wird Exchange Server 2003 Service Pack 2 ausgeführt.

  • Der Exchange-Server befindet sich nicht in einem Cluster.

  • Der intelligente Nachrichtenfilter ist aktiviert.

  • Die automatische Aktualisierung für den intelligenten Nachrichtenfilter ist nicht aktiviert.

Der intelligente Nachrichtenfilter wird standardmäßig mit Exchange Server 2003 SP2 installiert. Der intelligente Nachrichtenfilter muss allerdings manuell aktiviert werden, um die Vorteile dieser neuen Nachrichtenfiltertechnologie ausschöpfen zu können. Nach der Aktivierung des intelligenten Nachrichtenfilters müssen die .dat- und .dll-Dateien regelmäßig aktualisiert werden, um den Filter aktuell und wirksam zu halten. In dem im folgenden Abschnitt angesprochenen Artikel wird der Aktualisierungsprozess beschrieben, mit dem der intelligente Nachrichtenfilter aktuell gehalten wird.

Informationen zum Aktivieren der automatischen Aktualisierung für den intelligenten Nachrichtenfilter finden Sie im Microsoft Knowledge Base-Artikel 907747, „Aktualisieren des intelligenten Nachrichtenfilters, Version 2, in Exchange Server 2003 SP2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=907747).


Die Umschlagaufzeichnung ist aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-03-30

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob das Attribut heuristics für die Aktivierung der Umschlagaufzeichnung konfiguriert wurde. In der Standardeinstellung ist das Attribut heuristics nicht konfiguriert. Wenn Exchange Server Analyzer erkennt, dass das Attribut heuristics auf 512 festgelegt ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Die Umschlagaufzeichnung lässt das Archivieren von P1-Nachrichtenkopfzeilen zu. P1-Nachrichtenkopfzeilen enthalten die Adressinformationen, die von MTAs (Message Transfer Agents zum Routen von Nachrichten verwendet werden. Diese Adressinformationen schließen Informationen über Empfänger ein, die die Nachricht tatsächlich empfangen haben, einschließlich Bcc-Empfänger und Empfänger aus Verteilergruppen. Die Umschlagaufzeichnung übermittelt Nachrichten, die mithilfe einer Umschlagnachricht, die einen Aufzeichnungsbericht und die ursprüngliche Nachricht enthält, für die Archivierung gekennzeichnet sind. Die ursprüngliche Nachricht wird als Anhang übermittelt. Der Text des Aufzeichnungsberichts enthält die Transportumschlagsdaten der archivierten Nachricht.

Zum Aktivieren der Bcc-Aufzeichnung für einen bestimmten Server müssen Sie zuerst auf Datenbankebene die auf Nachrichten beschränkte Aufzeichnung konfigurieren. Das Attribut heuristics ist nicht aktiviert, wenn die folgenden Bedingungen erfüllt sind:

  • Das Attribut heuristics ist auf 512 festgelegt.

  • Die auf Nachrichten beschränkte Aufzeichnung ist für keinen Datenbankspeicher aktiviert.

Aufzeichnungsnachrichten können umfangreiche Datenträger-, Netzwerk- und CPU-Ressourcen beanspruchen. Aufzeichnungen erfordern daher eine sorgfältige Bereitstellungsplanung. Aufzeichnungen sollten ausschließlich im Rahmen einer Gesamtlösung für Aufzeichnungen aktiviert werden.

Wenn die folgenden Bedingungen zutreffen, können Sie die Meldung über die von der Standardkonfiguration abweichende Konfiguration ignorieren:

  • Ihr Unternehmen macht Aufzeichnungen erforderlich.

  • Sie haben eine Gesamtlösung für Aufzeichnungen bereitgestellt.

Wenn dies nicht der Fall ist, sollten Sie die Aufzeichnungsfunktion deaktivieren.

So deaktivieren Sie die auf Nachrichten beschränkte Aufzeichnung für eine Datenbank

  1. Erweitern Sie im Exchange-System-Manager die Option Server, und erweitern Sie <Ihren Exchange-Server>. Erweitern Sie die <Speichergruppe>, und klicken Sie mit der rechten Maustaste auf den Postfachspeicher.

  2. Deaktivieren Sie auf der Registerkarte Allgemein das Kontrollkästchen Alle von Postfächern in diesem Informationsspeicher gesendeten oder empfangenen Nachrichten archivieren.

  3. Warten Sie 15 Minuten, bis die Änderungen vom Exchange-Informationsspeicher vorgenommen wurden. Sie müssen den Microsoft Exchange-Informationsspeicherdienst nicht neu starten.

Wenn Exchange Server Analyzer diese Nachricht nicht mehr anzeigen soll, müssen Sie das Attribut heuristics deaktivieren. Um die Aufzeichnungsfunktion zu deaktivieren, ist es nicht erforderlich, das Attribut heuristics zu deaktivieren.

Sie können die Umschlagaufzeichnung mit dem Tool E-Mail Journaling Advanced Configuration (Exejcfg.exe) deaktivieren. Das Tool kann von jedem Server mit Zugriff auf Active Directory aus ausgeführt werden. Es wird jedoch empfohlen, das Tool von einem Domänencontroller aus auszuführen.

Das Tool E-Mail Journaling Advanced Configuration und die Dokumentation sind im Toolspaket enthalten, das Sie unter http://go.microsoft.com/fwlink/?LinkId=33122 herunterladen können. Das Tool E-Mail Journaling Advanced Configuration kann in Exchange 2000 Server-Umgebungen und Exchange Server 2003-Umgebungen verwendet werden.

So deaktivieren Sie das Attribut „heuristics"

  1. Downloaden Sie das Tool E-Mail Journaling Advanced Configuration und entzippen Sie es in ein Verzeichnis Ihrer Wahl.

  2. Öffnen Sie eine Eingabeaufforderung.

  3. Gehen Sie zu dem Verzeichnis, in dem Sie das Tool E-Mail Journaling Advanced Configuration installiert haben.

  4. Geben Sie zum Deaktivieren der Umschlagaufzeichnung den folgenden Befehl ein:

    Code kopieren
    exejcfg -d

Weitere Informationen zum Bereitstellen einer Aufzeichnungslösung finden Sie unter Journaling with Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).


ESMTP-Verb nicht unterstützt
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob der Wert des Attributs msExchSmtpInboundCommandSupportOptions für jede Instanz eines virtuellen SMTP-Servers (Simple Mail Transfer Protocol) so konfiguriert ist, dass die standardmäßigen erweiterten SMTP-Verben für eingehende Verbindungen unterstützt werden.

Diese erweiterten SMTP-Verben sind in der nachfolgenden Tabelle enthalten. Wenn Exchange Server Analyzer feststellt, dass ein beliebiges der angegebenen erweiterten SMTP-Standardverben für eingehende Verbindungen nicht unterstützt wird, zeigt das Tool eine Warnung an.

Exchange Server 2003 verwendet diese Exchange-spezifischen erweiterten SMTP-Verben, um mit anderen Servern mit Exchange in der Organisation effizienter als über Standard-SMTP zu kommunizieren. Diese Verben werden von der Metabasis und in Exchange Server-Ereignissenken gesteuert. In Exchange Server 2003 ist der DS2MB-Prozess zuständig für das Aktualisieren der Werte in der Metabasis, indem die Werte aus Active Directory kopiert werden. Wenn Sie Ereignissenken deaktivieren, beeinträchtigen Sie ggf. die Leistung von Exchange Server.

Erweitertes SMTP-Verb Kommentare

8BITMIME

Gibt an, dass der virtuelle lokale SMTP-Server 8-Bit-MIME-Nachrichten unterstützt.

BDAT, CHUNKING

Eine Alternative zum Befehl DATA. Dieser Befehl verarbeitet zwei Argumente. Wenn ein virtueller SMTP-Server auf das Schlüsselwort EHLO mit CHUNKING antwortet, gibt der SMTP-Server an, dass der Befehl BDAT unterstützt wird und Nachrichten in Abschnitten angenommen werden.

  • Das erste Argument gibt die Länge des binären Datenpakets an. Deshalb muss der SMTP-Host nicht fortlaufend nach dem Ende der Daten suchen. Der empfangende Server zählt die Bytes in der Nachricht. Wenn die Nachrichtgröße dem vom Befehl BDAT gesendeten Wert entspricht, geht der Server davon aus, dass er alle Nachrichtendaten empfangen hat.

  • Das zweite Argument gibt an, ob das Datenpaket das letzte Paket in der aktuellen Übertragung ist. Das zweite Argument ist optional.

BINARYMIME

Gibt an, dass der virtuelle SMTP-Server Nachrichten, die binäre Informationen enthalten, ohne Transportcodierung annimmt, indem der Parameter BODY mit dem Wert BINARYMIME mit dem Befehl MAIL verwendet wird. Wenn der SMTP-Server einen Befehl MAIL akzeptiert, dessen Parameter BODY auf BINARYMIME festgelegt ist, behält der Server alle Bits in allen Oktetts bei, die mit dem Befehl BDAT übergeben werden. Die SMTP-Erweiterung BINARYMIME kann nur mit CHUNKING verwendet werden.

DSN

Ein ESMTP-Befehl, der Benachrichtigungen zum Übermittlungsstatus gemäß RFC 1891 (Request for Comments) aktiviert.

ENHANCEDSTATUSCODES

Gibt an, dass der SMTP-Server erweiterte Fehlerstatuscodes bereitstellt. Der Textteil aller SMTP-Statusantworten mit Ausnahme der anfänglichen Begrüßung und beliebiger Antworten auf HELO oder EHLO erhält gemäß RFC 1893 einen Statuscode als Präfix.

ETRN

Wird von einem SMTP-Server gesendet, um anzufordern, dass der lokale virtuelle Server beliebige E-Mail-Nachrichten sendet, die sich in der Warteschlange für die Domänen befinden, die vom Befehl ETRN angegeben sind.

TURN

Ermöglicht einem Remotehost und einem lokalen Host das Tauschen ihrer Rollen und das Senden von E-Mail in umgekehrter Richtung, ohne eine neue Verbindung einzurichten.

Weitere Informationen zum Wiederherstellen der standardmäßigen Unterstützung dieser Verben finden Sie im Microsoft Knowledge Base-Artikel 257569 mit Informationen zum Deaktivieren von Verben in Exchange 2000 Server und Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569).


Erweiterte Verben werden vom Exchange-Server nicht angekündigt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest die Eigenschaft SmtpInboundCommandSupportOptions in der IIS-Metabasis (Internet Information Services), um zu ermitteln, ob Exchange Server so konfiguriert wurde, dass die erweiterten Verben unterstützt werden. Wenn Exchange Server Analyzer feststellt, dass die Einstellung SmtpInboundCommandSupportOptions nicht auf 7697601 festgelegt wurde, wird eine Warnung angezeigt.

Erweiterte SMTP-Verben sind sowohl unter Exchange 2000 Server als auch unter Exchange Server 2003 erforderlich. Der Wert in der IIS-Metabasis muss mit dem Wert übereinstimmen, der im Active Directory®-Verzeichnisdienst festgelegt wurde. Wenn Sie Exchange Server in einer Umgebung mit gemischtem Modus ausführen, muss dieser Wert auf 7697601 festgelegt sein.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So stellen Sie den Standardwert von SmtpInboundCommandSupportOptions wieder her

  1. Öffnen Sie die ADSI-Bearbeitung, und stellen Sie eine Verbindung mit einem Domänencontroller her.

  2. Öffnen Sie den Container Konfiguration.

  3. Navigieren Sie zum folgenden Verzeichnis:

    Configuration/Services/Microsoft Exchange/<Ihre Organisation>/Administrative Groups/<Ihre administrative Gruppe>/Servers/<Ihr Exchange-Server>/Protocols/SMTP/<Ihr virtueller Server>.

  4. Klicken Sie mit der rechten Maustaste auf den virtuellen Server, und klicken Sie dann auf Eigenschaften.

  5. Wählen Sie im Feld zum Auswählen einer anzuzeigenden Eigenschaft msExchSmtpInboundCommandsSupportOptions aus.

  6. Geben Sie im Feld zum Bearbeiten von Attributen den Wert 7697601 ein.

  7. Klicken Sie auf Festlegen und auf Übernehmen, und klicken Sie dann auf OK.

  8. Schließen Sie die ADSI-Bearbeitung.


Warteschlangen mit dem Status "Fixiert" erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-03

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Microsoft Windows® Management Instrumentation - Microsoft Windows®-Verwaltungsinstrumentation) ExchangeLink ab, um den Wert des Schlüssels StateFrozen von SMTP-Warteschlangen (Simple Mail Transfer Protocol) auf einem Server zu bestimmen.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Schlüssels StateFrozen für eine der SMTP-Warteschlangen auf einem Server mit Exchange auf True festgelegt ist, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Eine fixierte Warteschlange bedeutet, dass die Transportsitzungen für diese Warteschlange beendet wurden. Eine fixierte Warteschlange verhindert ausgehende Nachrichten, obgleich neue Nachrichten hinzugefügt werden können. Sie können den Status einer Verbindung über das Kontextmenü für jede Verbindungswarteschlange manuell ändern. Wenn Sie mit dem Befehl Verbindung erzwingen einen Warteschlangenstatus in Aktiv ändern, aktivieren Sie sofort eine Verbindung, über welche die Nachrichten in dieser Warteschlange gesendet werden.

Informationen zu den bestimmten betroffenen SMTP-Warteschlangen und möglichen Ursachen finden Sie in den folgenden Exchange Server Analyzer-Artikeln:

  • Warteschlange "Nachrichten warten auf Verzeichnissuche" hat den Status "Fixiert"

  • Warteschlange "Nachrichten warten auf Routing" hat den Status "Fixiert"

  • Warteschlange "Nachrichten mit ausstehender Übertragung" hat den Status "Fixiert"

  • Warteschlange "Lokale Übermittlung" hat den Status "Fixiert"

  • Warteschlange "Remoteübermittlung" hat den Status "Fixiert"

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Microsoft Knowledge Base-Artikel 821877 mit einer Beschreibung der Felder auf den Eigenschaftsregisterkarten für die SMTP- und X.400-Warteschlange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Filterupdate für Intelligent Message Filter ist verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer sendet eine Abfrage an die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile, um zu bestimmen, ob die Datei MSExchange.UceContentFilter.dll über den folgenden Pfad auf dem Exchange-Server vorhanden ist:

<Pfad zu den Binärdateien auf dem Exchange-Server>\MSCFv2\MSExchange.UceContentFilter.dll

Hinweis:
In diesem Pfad bezieht sich <Pfad zu den Binärdateien auf dem Exchange-Server> auf den Speicherort des Binärordners.

Wenn die Datei MSExchange.UceContentFilter.dll an diesem Speicherort nicht vorhanden ist, zeigt Exchange Server Analyzer eine empfohlene optimale Methode an.

Es wird empfohlen, das Filterupdate für Microsoft Exchange Intelligent Message Filter auf allen Exchange-Servern zu installieren, auf denen Intelligent Message Filter installiert ist. Das Filterupdate für Intelligent Message Filter stellt das aktuellste Intelligent Message Filter SmartScreen™-Filterupdate für Intelligent Message Filter dar. Das Filterupdate für den SmartScreen-Filter enthält aktualisierte Charakteristika unerwünschter Internetwerbung, mit denen die Fähigkeit von Intelligent Message Filter verbessert wird, unerwünschte kommerzielle E-Mail-Nachrichten (UCE) zu blockieren, die häufig auch als „Spam" bezeichnet werden.

Hinweis:
Vor den Installieren des Updates muss Intelligent Message Filter installiert werden. Verwenden Sie zum Installieren von Intelligent Message Filter ein Konto mit den Rechten eines lokalen Administrators, das Mitglied einer Gruppe ist, der die Funktion als Exchange-Administrator zugewiesen wurde.

Nachdem Sie Intelligent Message Filter installiert haben, führen Sie zum Installieren der Updates das folgende Verfahren aus.

So erhalten und installieren Sie das Intelligent Message Filter-Update

  1. Rufen Sie das aktuellste Update für Exchange Intelligent Message Filter unter folgender Adresse ab: http://go.microsoft.com/fwlink/?LinkId=41026.

  2. Lesen Sie die Anmerkungen zu dieser Version des Intelligent Message Filter-Updates unter folgender Adresse: http://go.microsoft.com/fwlink/?LinkId=41027.

  3. Führen Sie das Updatepaket aus, und befolgen Sie die Anweisungen des Setup-Assistenten.

Weitere Informationen finden Sie auf der Website zu Exchange Intelligent Message Filter unter (http://go.microsoft.com/fwlink/?LinkId=21607).


Die flache Einschränkungsüberprüfung ist aktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für jedes ExchangeServer-Objekt im Verzeichnis zu ermitteln. Wenn der Zeichenfolgenwert für das Attribut serialNumber eines Exchange Server 2003-Serverobjekts Service Pack 2 enthält, ist dies ein Hinweis darauf, dass auf dem Exchange-Server eine Vorabversion von Exchange Server 2003 Service Pack 2 ausgeführt wird.

Exchange Server Analyzer liest auch den folgenden Registrierungseintrag, um festzustellen, ob der Registrierungswert RestrictionMethod vorhanden ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

Microsoft Exchange Server Analyzer zeigt eine Meldung an, dass die Konfiguration nicht dem Standard entspricht, wenn die folgenden Bedingungen erfüllt sind:

  • Exchange Server 2003 Service Pack 2 ist installiert.

  • Der Registrierungswert RestrictionMethod ist vorhanden und auf den Wert 2 konfiguriert.

Diese Konfiguration weist darauf hin, dass die Transportkomponenten für diesen Exchange-Server nicht die Mitgliedschaft von Verteilergruppen erweitern, wenn der Server die Einschränkungen überprüft. Diese Konfiguration stellt die beste Leistung für Einschränkungsüberprüfungen bereit.

Wenn Sie der Ansicht sind, dass es sich bei dem Vorhandensein und der Einstellung des Registrierungswerts RestrictionMethod um einen Fehler handelt, können Sie mit dem folgenden Verfahren die Standardkonfiguration wiederherstellen. Da das Vorhandensein dieses Schlüssels in Verbindung mit Exchange Server 2003 Service Pack 2 die beste Leistung beim Überprüfen der Einschränkungen bereitstellt, wird jedoch empfohlen, dass Sie die derzeitige Einstellung für den Registrierungswert RestrictionMethod beibehalten.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\

  3. Klicken Sie im rechten Bereich auf auf RestrictionMethod, und wählen Sie Löschen aus.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie dann den IIS-Administratordienst und die Microsoft Exchange Routing Engine-Dienste neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zum Registrierungswert RestrictionMethod finden Sie im Microsoft Knowledge Base-Artikel 895407, „In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).


DNS-Einträge vom Typ "Host" gefunden, vom Typ "MX" dagegen nicht
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer fragt die verwendeten DNS-Server (Domain Name System) auf die MX-Einträge (Mail Exchanger) von Remotedomänen ab, an die Exchange Nachrichten sendet. Exchange Server Analyzer führt anschließend eine DNS-Suche aus, um "Host (A)"-Einträge von Remotedomänen abzurufen.

Wenn die DNS-Suche von Exchange Server Analyzer keine MX-Einträge für die Remotedomänen zurückgibt, jedoch anschließend "Host (A)"-Einträge für dieselben Remotedomänen abrufen kann, zeigt Exchange Server Analyzer eine Warnung an.

Nach dem Fehlschlagen des Abrufs der MX-Einträge kann der Server mit Exchange versuchen, E-Mail an die Server zu senden, auf welche die "Host (A)"-Einträge zeigen. Es ist sehr wichtig, dass diese "Host (A)"-Einträge auf die ordnungsgemäßen Mailserver zeigen.

In einigen Domänen sind die "Host (A)"-Einträge ggf. so konfiguriert, dass auf einen Internetdienstanbieter verwiesen wird, der, wenngleich über gültige Mailserver verfügend, ggf. nicht den autorisierenden Mailserver für den vorgesehenen Empfänger aufweist. In diesem Fall wird die E-Mail zurückgewiesen.

Die DNS-Suche nach den MX-Einträgen kann fehlschlagen, wenn der DNS-Server wegen eines Netzwerkfehlers oder aus anderen Gründen nicht verfügbar ist oder nicht antwortet.

So stellen Sie sicher, dass der DNS-Server online ist und die MX-Einträge vorhanden sind

  1. Überprüfen Sie, ob der DNS-Server ausgeführt wird, indem Sie die folgenden Schritte ausführen:

    • Untersuchen Sie den Status des DNS-Servers mithilfe des DNS-Administrationsprogramms auf dem DNS-Server.

    • Starten Sie den DNS-Server neu. Weitere Informationen finden Sie unter "Start, stop, pause, or restart a DNS server" (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Untersuchen Sie die Reaktionsbereitschaft des DNS-Servers mithilfe des Befehls nslookup. Weitere Informationen finden Sie in den Anweisungen unter "Verify DNS server responsiveness using the nslookup command" (http://go.microsoft.com/fwlink/?LinkId=63000).

  2. Überprüfen Sie mit nslookup, ob die MX-Einträge ordnungsgemäß konfiguriert sind. Weitere Informationen finden Sie unter "Überprüfen der Konfiguration von MX-Einträgen mithilfe von Nslookup " im Abschnitt "Überprüfen des DNS-Designs und der Konfiguration" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Weitere Informationen

  • Weitere Informationen zur Verwendung von DNS durch Exchange Server 2003 zum Auflösen externer IP-Adressen finden Sie unter "Transportabhängigkeiten in Exchange Server 2003" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Informationen zur DNS-Namensauflösung finden Sie im Microsoft Knowledge Base-Artikel 322856, "Konfigurieren von DNS für eine Verwendung mit Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • Informationen zur Behandlung von DNS-Problemen finden Sie unter "Troubleshooting DNS" (http://go.microsoft.com/fwlink/?LinkId=63003).


Der Registrierungswert „IIS PoolThreadLimit" wurde manuell hinzugefügt und konfiguriert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseinträge, um zu bestimmen, ob die maximale Anzahl der Pool-Threads für Internet Information Services (IIS) vom Standardwert abweicht:

HKEY_LOCAL_MACHINE\ System\CurrentControlSet\Services\Inetinfo\Parameters\PoolThreadLimit

Wenn Exchange Server Analyzer feststellt, dass der Wert PoolThreadLimit vorhanden und mit einem anderen Wert konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Registrierungswert PoolThreadLimit gibt die maximale Anzahl der E/A-Arbeiterthreads an, die im Prozess Inetinfo.exe erstellt werden können, der im Gegenzug die maximale Anzahl gleichzeitiger Verbindungen steuert, die für IIS hergestellt werden können. Jeder Pool-Thread sucht nach einer Netzwerkanforderung und verarbeitet diese durch entweder Zurücksenden einer statischen Datei oder durch Weiterleiten der Anforderung an eine ISAPI-Erweiterungs-DDL (z. B. ASP.DLL) oder an eine CGI-Anwendung (Common Gateway Interface). Wenn die ISAPI-Erweiterung eine Anforderung synchron verarbeitet (die Verarbeitung von Anforderungen nimmt viel Zeit in Anspruch), bindet es den Arbeiterthread. Damit stehen IIS weniger Arbeiterthreads zum Verarbeiten anderer Anforderungen zur Verfügung. Aus diesem Grund implementieren gut geschriebene ISAPI-Erweiterungen ihre eigenen Thread-Pools, legen Anforderungen in einer Warteschlange ab und verarbeiten sie asynchron mit eigenen Threads, sodass keine IIS-Arbeiterthreads gebunden werden.

In der Standardeinstellung wird PoolThreadLimit von IIS festgelegt auf:

2 * Anzahl der Megabyte des Arbeitsspeichers (RAM) im Gerät

Wenn dieser Wert höher als 256 ist, wird er auf 256 heruntergesetzt. In der Standardeinstellung existiert dieser Registrierungswert nicht. Wenn dieser Wert in der Registrierung vorhanden ist, setzt er die Standardberechnung von IIS außer Kraft.

Wenn Sie das Standardlimit von 256 Threads unangemessen finden, ist die ISAPI-Erweiterung möglicherweise schlecht geschrieben und bindet IIS-Arbeiterthreads. 256 gleichzeitig aktive Threads sind eine Menge und verursachen erheblichen Overhead bei der Synchronisierung und beim Kontextwechsel.

Der Registrierungswert PoolThreadLimit ist ein streng gesetztes Limit, das alle IIS-Arbeiterthreads berücksichtigt, einschließlich der HTTP-, FTP-, NNTP und SMTP-Dienste.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

  3. Überprüfen, löschen oder ändern Sie den Wert PoolThreadLimit.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den IIS-Administratordienst neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://support.microsoft.com/kb/256986/DE/).


Beschränkung der Größe für eingehende und ausgehende Nachrichten
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-12-01

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob sich das Attribut für den Höchstwert ausgehender Nachrichten (submissionContLength) vom Attribut für den Höchstwert eingehender Nachrichten (delivContLength) unterscheidet. Wenn Microsoft Exchange Server Analyzer ermittelt, dass sich die Höchstwerte für ein- und ausgehende Nachrichten unterscheiden, zeigt das Tool eine Meldung mit empfohlenen optimalen Methoden an.

Es wird empfohlen, die Höchstwerte für ein- und ausgehende Nachrichten auf denselben Wert festzulegen, um Konsistenz für die Nachrichteneinschränkungen zu gewährleisten.

So ändern Sie den Höchstwert für ausgehende Nachrichten für Exchange 2000 Server und Exchange Server 2003

  1. Starten Sie den Exchange-System-Manager.

  2. Erweitern Sie im linken Bereich Globale Einstellungen.

  3. Klicken Sie mit der rechten Maustaste auf Nachrichtenübermittlung, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf der Registerkarte Standardeinstellungen unter Größe für gesendete Nachrichten auf Maximum (KB), und geben Sie dann eine Zahl ein.
So legen die Höchstwerte für ausgehende Nachrichten für Exchange Server 2007 fest

  1. Führen Sie in der Exchange-Verwaltungsshell den folgenden Befehl aus, wobei für <Größe> der Standardwert "Unbegrenzt" bzw. die Größe in Bytes, KB oder MB (Wertebereich zwischen 0 und 2147483647 Bytes) angegeben wird:
Code kopieren
Set-TransportConfig -MaxSendSize <size>

Wenn Sie die Größe der ausgehenden Nachrichten für Benutzer in der Exchange-Organisation auf 10 MB beschränken möchten, geben Sie folgendes ein:

Code kopieren
Set-TransportConfig -MaxSendSize 10MB

Wenn Sie die Größe der ausgehenden Nachrichten für Benutzer in der Exchange-Organisation nicht beschränken möchten (Standardwert), geben Sie folgendes ein:

Code kopieren
Set-TransportConfig -MaxSendSize unlimited
 So ändern Sie den Höchstwert für eingehende Nachrichten

  1. Starten Sie den Exchange-System-Manager.

  2. Erweitern Sie im linken Bereich Globale Einstellungen.

  3. Klicken Sie mit der rechten Maustaste auf Nachrichtenübermittlung, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf der Registerkarte Standardeinstellungen unter Größe für empfangene Nachrichten auf Maximum (KB), und geben Sie dann eine Zahl ein.
So legen die Höchstwerte für eingehende Nachrichten für Exchange Server 2007 fest

  1. Führen Sie in der Exchange-Verwaltungsshell den folgenden Befehl aus, wobei für <Größe> der Standardwert "Unbegrenzt" bzw. die Größe in Bytes, KB oder MB (Wertebereich zwischen 0 und 2147483647 Bytes) angegeben wird:
Code kopieren
Set-TransportConfig -MaxReceiveSize <size>

Wenn Sie die Größe der eingehenden Nachrichten für Empfänger in der Exchange-Organisation auf 10 MB beschränken möchten, geben Sie folgendes ein:

Code kopieren
Set-TransportConfig -MaxReceiveSize 10MB

Wenn Sie die Größe der eingehenden Nachrichten für Empfänger in der Exchange-Organisation nicht beschränken möchten (Standardwert), geben Sie folgendes ein:

Code kopieren
Set-TransportConfig -MaxReceiveSize unlimited

Weitere Informationen zum Festlegen von Größenbegrenzungen für Nachrichten in Exchange 2000Server und in Exchange Server 2003 finden Sie im Microsoft Knowledge Base-Artikel 322679, „How to set size limits for messages in Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679).

Weitere Informationen zum Cmdlet TransportConfig für Exchange Server 2007 finden Sie unter "Set-TransportConfig" in der technischen Referenz zu Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkId=79237).


Benutzerdefinierte Intelligent Message Filter-Antwort ist vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungsschlüssel, um zu bestimmen, ob der Registrierungswert CustomRejectResponse vorhanden ist:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

Microsoft Exchange Server Analyzer zeigt eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht, wenn die folgenden Bedingungen erfüllt sind:

  • Der Registrierungseintrag CustomRejectResponse ist vorhanden.

  • Dieser Wert ist eine gültige Zeichenfolge.

    Hinweis:
    Der Zeichenfolgenwert der Antwort muss mit 550 5.7.1 beginnen, um als gültiger Wert erkannt zu werden.

Es ist keine Aktion erforderlich.

Unter Exchange Server 2003 Service Pack 2 (SP2) ist die intelligente Nachrichtenfilterung installiert und betriebsbereit, sobald Sie SP2 installiert haben. Unter Exchange Server 2003 SP2 kann die vom Server generierte und an den Unzustellbarkeitsbericht für den Absender angefügte Antwortzeichenfolge angepasst werden. Die Standardantwort 550 5.7.1 Requested action not taken: message refused kann geändert werden, sodass berechtigte, blockierte Benutzer eine aussagekräftige Erklärung erhalten, warum ihre Nachricht blockiert wurde. Diese Erklärung kann dazu beitragen, Überprüfungen von fälschlich blockierten Nachrichten zu reduzieren und die mit der Antispamverarbeitung verbundenen Supportkosten zu verringern.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So ändern Sie die benutzerdefinierte Antwortzeichenfolge

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\Software\Microsoft\Exchange\ContentFilter

  3. Klicken Sie im rechten Aufgabenbereich mit der rechten Maustaste auf den Wert CustomRejectResponse, und wählen Sie Ändern aus.

  4. Geben Sie den Zeichenfolgenwert ein, der als benutzerdefinierte Antwort verwendet werden soll. Die Zeichenfolge muss mit 550 5.7.1 beginnen. Sie können z. B. 550 5.7.1 Domäne ist kein zulässiger Absender eingeben, um die Zeichenfolge als gültige Zeichenfolge festzulegen, die an den Unzustellbarkeitsbericht angefügt werden kann.

  5. Speichern Sie die Änderungen, beenden Sie den Registrierungs-Editor, und starten Sie den SMPT-Dienst neu, damit die Änderungen wirksam werden.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zur intelligenten Nachrichtenfilterung finden Sie auf der Website „Exchange Intelligent Message Filter" (http://go.microsoft.com/fwlink/?LinkId=21607).

Ausführliche Informationen zum Durchführen von Aufgaben mit der intelligenten Nachrichtenfilterung finden Sie in der Onlinehilfe zu Exchange Server 2003 SP2 unter „Configure Intelligent Message Filtering".

Weitere Informationen zu SP2 für Exchange Server 2003 finden Sie auf der Website zu Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52073).


Benutzerdefinierte Intelligent Message Filter-Wortliste ist vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) CIM_Datafile ab, um zu ermitteln, ob die Datei MSExchange.UCEContentFilter.xml auf dem Exchange-Server vorhanden ist. Wenn Exchange Server Analyzer feststellt, dass die Datei MSExchange.UCEContentFilter.xml auf dem Exchange-Server vorhanden ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht. Es ist keine Aktion erforderlich.

Bei der Datei MSExchange.UCEContentFilter.xml handelt es sich um eine Komponente des benutzerdefinierten Einstufungsfeatures in Intelligent Message Filter für Exchange Server 2003 Service Pack 2 (SP2).

Mithilfe des benutzerdefinierten Einstufungsfeatures in Intelligent Message Filter für SP2 können Administratoren das Verhalten von Intelligent Message Filter auf Grundlage von Ausdrücken im Text einer E-Mail-Nachricht, der Betreffzeile oder beidem anpassen. Für das benutzerdefinierte Einstufungsfeature wird keine Benutzeroberfläche bereitgestellt. Die Funktion für die benutzerdefinierte Einstufung wird in Form einer XML-Konfigurationsdatei (MSExchange.UCEContentFilter.xml) verfügbar gemacht, die von Intelligent Message Filter bei der Initialisierung gelesen und danach jedes Mal bei Änderungen an der Datei geladen wird. Wenn die Datei MSExchange.UCEContentFilter.xml beim Starten von Intelligent Message Filter nicht vorhanden ist, muss der SMTP-Dienst neu gestartet werden. Die Datei MSExchange.UCEContentFilter.xml für die benutzerdefinierte Einstufung muss sich in dem gleichen Verzeichnis befinden wie die Datei MSExchange.UceContentFilter.dll und die DAT-Dateien.

Weitere Informationen zur Datei für die benutzerdefinierte Einstufung finden Sie in den Versionsanmerkungen zu Exchange Server 2003 Service Pack 2. Die Versionsanmerkungen zu Exchange Server 2003 Service Pack 2 sind sowohl auf der CD für SP2 als auch auf der Website mit den Versionsanmerkungen zu Exchange Server 2003 Service Pack 2 unter http://go.microsoft.com/fwlink/?LinkId=52072 verfügbar.

Weitere Informationen zu SP2 für Exchange Server 2003 finden Sie auf der Website zu Exchange Server 2003 Service Pack 2 unter http://go.microsoft.com/fwlink/?LinkId=52073.


Ungültige benutzerdefinierte Intelligent Message Filter-Antwort
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungsschlüssel, um zu bestimmen, ob der Registrierungswert CustomRejectResponse vorhanden ist:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen vorliegen:

  • Der Registrierungseintrag CustomRejectResponse ist vorhanden.

  • Der Zeichenfolgenwert beginnt nicht mit 550 5.7.1.

    Hinweis:
    Der Zeichenfolgenwert der Antwort muss mit 550 5.7.1 beginnen, um als gültiger Wert erkannt zu werden.

Unter Exchange Server 2003 SP2 kann die vom Server generierte und an den Unzustellbarkeitsbericht für den Absender angefügte Antwortzeichenfolge angepasst werden. Die Standardantwort ###550 5.7.1 Requested action not taken: message refused kann geändert werden, sodass berechtigte, blockierte Benutzer eine aussagekräftige Erklärung erhalten, warum ihre Nachricht blockiert wurde. Diese Erklärung kann dazu beitragen, Überprüfungen von fälschlich blockierten Nachrichten zu reduzieren und die mit der Antispamverarbeitung verbundenen Supportkosten zu verringern.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So beheben Sie diese Warnung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\Software\Microsoft\Exchange\ContentFilter

  3. Klicken Sie im rechten Aufgabenbereich mit der rechten Maustaste auf den Wert CustomRejectResponse, und wählen Sie Ändern aus.

  4. Geben Sie den Zeichenfolgenwert ein, der als benutzerdefinierte Antwort verwendet werden soll. Die Zeichenfolge muss mit 550 5.7.1 beginnen. Sie können z. B. 550 5.7.1 Domäne ist kein zulässiger Absender eingeben, um die Zeichenfolge als gültige Zeichenfolge festzulegen, die an den Unzustellbarkeitsbericht angefügt werden kann.

  5. Speichern Sie die Änderungen, beenden Sie den Registrierungs-Editor, und starten Sie den SMPT-Dienst neu, damit die Änderungen wirksam werden.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zur intelligenten Nachrichtenfilterung finden Sie auf der Website „Exchange Intelligent Message Filter" (http://go.microsoft.com/fwlink/?LinkId=21607).

Ausführliche Informationen zum Durchführen von Aufgaben mit der intelligenten Nachrichtenfilterung finden Sie in der Onlinehilfe zu Exchange Server 2003 SP2 unter „Configure Intelligent Message Filtering".


Intelligent Message Filter ist auf dem Postfachserver aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der intelligente Nachrichtenfilter von Microsoft® Exchange auf dem Server installiert und aktiviert ist:

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

Exchange Server Analyzer liest den Wert ContentFilterBindings im Registrierungsschlüssel ContentFilter, um zu bestimmen, ob der intelligente Nachrichtenfilter auf dem Server installiert und aktiviert ist.

Anschließend sendet Exchange Server Analyzer eine Abfrage an den Active Directory®-Verzeichnisdienst, um den Wert des Attributs msExchAuthenticationFlags für das ExchangeServer-Objekt zu ermitteln. Das Attribut msExchAuthenticationFlags stellt die auf dem Server zugelassene Art der Authentifizierung dar. Exchange Server Analyzer zeigt eine Warnmeldung an, wenn die folgenden Bedingungen vorliegen:

  • Die Authentifizierung des Attributs msExchAuthenticationFlags wurde für den anonymen Zugriff auf den Server konfiguriert.

  • Auf dem Server werden auch Postfächer gehostet.

Der intelligente Nachrichtenfilter identifiziert Meldungen, bei denen es sich wahrscheinlich um unerwünschte kommerzielle E-Mail-Nachrichten (UCE) handelt. Sie können UCEs effektiv filtern, indem Sie den intelligenten Nachrichtenfilter auf den Exchange-Gatewayservern oder auf den Exchange-Bridgeheadservern bereitstellen, wenn Sie auf dem Gateway keine Microsoft E-Mail-Server einsetzen. Diese Gatewayserver akzeptieren eingehende E-Mail-Nachrichten aus dem Internet und leiten diese an den entsprechenden Postfachserver weiter. Auf Gatewayservern werden im Allgemeinen keine Postfächer gehostet.

Darüber hinaus müssen Sie den intelligente Nachrichtenfilter auf jedem virtuellen SMTP-Server aktivieren, der eingehende E-Mail-Nachrichten aus dem Internet auf den Exchange-Gatewayservern zulässt.

Wichtig:
Deaktivieren Sie nicht den anonymen Zugriff auf die virtuellen SMTP-Server des Internetgateways. Diese virtuellen SMTP-Server, die E-Mails aus dem Internet zulassen, müssen für den anonymen Zugriff konfiguriert sein.

Sie können UCEs filtern, indem Sie den intelligenten Nachrichtenfilter durch das Festlegen von Schwellenwerten für die SCL-Bewertung (Spam Confidence Level) konfigurieren, die eingehenden Nachrichten sowohl auf dem Gateway als auch in den Exchange-Postfächern zugewiesen sind. Der intelligente Nachrichtenfilter wertet jede eingehende Nachricht aus und weist ihr eine SCL-Bewertung zu, die den Grad der Wahrscheinlichkeit angibt, mit der es sich bei der Nachricht um eine UCE handelt. Exchange-Postfachserver verwenden den SCL-Schwellenwert sowie die für das Postfach angegebenen Einstellungen, um zu bestimmen, ob eine Nachricht im Posteingang des Benutzers oder im Junk-E-Mail-Ordner abgelegt wird.

Wichtig:
Der intelligente Nachrichtenfilter muss nicht auf den Exchange-Postfachservern installiert sein. Wenn der intelligente Nachrichtenfilter auf den virtuellen SMTP-Gatewayservern installiert und aktiviert ist, empfangen Exchange-Postfachserver die SCL-Bewertung mit jeder eingehenden Nachricht und gehen dementsprechend vor.

Weitere Informationen finden Sie auf der Website für den intelligenten Nachrichtenfilter von Exchange unter http://go.microsoft.com/fwlink/?LinkId=21607. Weitere Informationen zum Konfigurieren Ihrer Microsoft Exchange Server 2003-Organisation für das Senden und Empfangen von E-Mails über das Internet finden Sie im Transport- und Routing-Handbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


Intelligent Message Filter ist auf dem Server nicht aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der intelligente Nachrichtenfilter von Microsoft® Exchange auf dem Server installiert und aktiviert ist:

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

Wenn Exchange Server Analyzer feststellt, dass der Wert ContentFilterBindings im Registrierungsschlüssel ContentFilter vorhanden ist, der Wert ContentFilterBindings jedoch nicht konfiguriert ist, zeigt Exchange Server Analyzer eine Warnmeldung an.

Hinweis:
Wenn der Wert ContentFilterBindings im Registrierungsschlüssel ContentFilter vorhanden und der Wert ContentFilterBindings nicht konfiguriert ist, ist der intelligente Nachrichtenfilter auf dem Server nicht aktiviert.
Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

Der intelligente Nachrichtenfilter identifiziert Meldungen, bei denen es sich wahrscheinlich um unerwünschte kommerzielle E-Mail-Nachrichten (UCE) handelt. Nachdem Sie den intelligenten Nachrichtenfilter auf dem die eingehenden E-Mails annehmenden Exchange-Gatewayserver oder Exchange-Bridgeheadserver bereitgestellt haben, müssen Sie den intelligenten Nachrichtenfilter auf jedem virtuellen SMTP-Server aktivieren, der eingehende Internet-E-Mail-Nachrichten annimmt.

So wird der Registrierungsschlüssel „ContentFilter" angezeigt

  1. Klicken Sie im Registrierungs-Editor (regedit) im Detailbereich mit der rechten Maustaste auf ContentFilter, um die Einstellung für ContentFilterBindings anzuzeigen.

    Hinweis:
    Wenn Exchange Intelligent Message Filter auf dem virtuellen SMTP-Server nicht konfiguriert ist, ist der Wert für ContentFilterBindings auf 0 festgelegt.

    Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://support.microsoft.com/kb/256986/de).

Es wird empfohlen, den intelligenten Nachrichtenfilter auf allen Exchange-Servern zu aktivieren, auf denen der intelligente Nachrichtenfilter installiert ist. Führen Sie die folgenden Schritte aus, um den intelligenten Nachrichtenfilter auf dem virtuellen SMTP-Server zu aktivieren. Nachdem Sie Intelligent Message Filter aktiviert haben, können Sie den Wert des Registrierungsschlüssels ContentFilter in der Registrierung überprüfen.

So aktivieren Sie den intelligenten Nachrichtenfilter

  1. Klicken Sie auf Start, zeigen Sie auf Alle Programme, zeigen Sie auf Microsoft Exchange, und klicken Sie dann auf System-Manager.

  2. Im Exchange-System-Manager, erweitern Sie Server, erweitern Sie Servername, erweitern Sie Protokolle, erweitern Sie SMTP, klicken Sie mit der rechten Maustaste auf Intelligente Nachrichtenfilterung, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Allgemein unter Intelligenten Nachrichtenfilter auf die IP-Adressen der folgenden virtuellen Server anwenden auf das Kontrollkästchen neben jedem virtuellen SMTP-Server, auf dem Sie den intelligenten Nachrichtenfilter aktivieren möchten.

    Das Dialogfeld „Eigenschaften" des intelligenten Nachrichtenfilters

Weitere Informationen finden Sie auf der Website für den intelligenten Nachrichtenfilter von Exchange unter http://go.microsoft.com/fwlink/?LinkId=21607.


Ungültiger Server für den Empfängeraktualisierungsdienst reserviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-07-30

Das Tool Microsoft Exchange Analyzer fragt den Active Directory-Verzeichnisdienst ab, um den Wert des Attributs msExchAddressListServiceLink für jedes Objekt Empfängeraktualisierungsdienst im Verzeichnis zu ermitteln. Das Attribut msExchAddressListServiceLink stellt eine Verknüpfung zwischen dem Adresslistendienst und einem Servercomputer mit Exchange dar, auf dem der Empfängeraktualisierungsdienst (Recipient Update Service - RUS) ausgeführt wird.

Exchange Analyzer fragt dann die WMI-Klasse (Microsoft Windows® Management Instrumentation) CIM_Datafile ab, um den Wert des Schlüssels Version für die Adressbuchansicht und den dynamischer Gruppendienst (abv_dg.dll) auf den erkannten Computern mit Exchange Server zu ermitteln. Der WMI-Schlüssel Version gibt die Buildnummer für diese Datei an.

Wenn Exchange Analyzer erkennt, dass die Buildnummer für die Datei abv_dg.dll auf einem der identifizierten Computer mit 08 beginnt, wird ein Fehler angezeigt.

Dieser Fehler zeigt an, dass der als RUS-Server reservierte Computer Microsoft Exchange Server 2007 ausführt.

Der Empfängeraktualisierungsdienst ist eine Komponente des Exchange-Systemaufsichtsdiensts, die in Exchange 2000 Server und Exchange Server 2003 vorhanden ist. Der Empfängeraktualisierungsdienst für Exchange 2000 und Exchange 2003 erstellt und verwaltet Exchange-spezifische Attributwerte in Active Directory. Diese Funktion wird vom Empfängererstellungsprozess in Exchange 2007 verwaltet, und der Legacy-Empfängeraktualisierungsdienst verarbeitet keine Aktualisierungen, wenn er auf einem Servercomputer mit Exchange 2007 ausgeführt wird.

Um diesen Fehler zu beheben, reservieren Sie einen Computer mit Exchange 2000 Server oder Exchange Server 2003 als Host für den Empfängeraktualisierungsdienst.

So beheben Sie diesen Fehler

  1. Öffnen Sie den Exchange-System-Manager.

  2. Klicken Sie unter Empfänger auf Empfängeraktualisierungsdienste. Klicken Sie im rechten Navigationsbereich mit der rechten Maustaste auf die entsprechende Instanz des Empfängeraktualisierungsdiensts, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Allgemein unter Exchange-Server auf Durchsuchen, und geben Sie dann einen neuen Servercomputer mit Exchange 2000 Server oder Exchange Server 2003 an, auf dem die RUS-Instanz ausgeführt werden soll.

  4. Klicken Sie auf OK. Klicken Sie anschließend erneut auf OK, damit die Änderung wirksam wird.


Aktuell wird eine große Anzahl von Kategorisierungsvorgängen ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-21

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst Daten des Leistungsindikators Kat: Ausgeführte Kategorisierungen des Leistungsobjekts SMTP Server, um Leistungsdaten zu analysieren.

Der Leistungsindikator Kat: Ausgeführte Kategorisierungen zeigt die Anzahl der zurzeit ausgeführten Kategorisierungen an.

Bei dieser Abfrage ruft Microsoft Exchange Server Analyzer zwei Minuten lang alle 6 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den Durchschnittswert des Leistungsindikators innerhalb des Erfassungszeitraums.

Wenn Exchange Server Analyzer feststellt, dass die durchschnittliche Anzahl der ausgeführten Kategorisierungen im Erfassungszeitraum 800 übersteigt, zeigt Exchange Server Analyzer einen Fehler an.

Das Kategorisierungsmodul führt die folgenden Kernoperationen aus:

  • Auflösen und Validieren aller Empfänger.

  • Ermitteln von Grenzwerten und Einschränkungen für alle Empfänger.

  • Erweitern von Verteilerlisten, falls erforderlich.

  • Ermitteln, ob eine Nachricht für die lokale oder Remoteübermittlung bestimmt ist.

Dieser Fehler weist möglicherweise darauf hin, dass der Server außergewöhnlichen Belastungen ausgesetzt ist oder ein Problem hinsichtlich der Serverleistung vorliegt.

So beheben Sie diesen Fehler

  • Ermitteln Sie, ob die übermäßige Beanspruchung des Kategorisierungsmoduls erwartet wurde oder ihre Ursache in einer typischen Belastung liegt. Lesen Sie in diesem Fall in den folgenden Microsoft TechNet-Artikeln die Anleitungen im Hinblick auf die Leistung von Exchange.

    • "Behandeln von Leistungsproblemen bei Microsoft Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47588).

    • "Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Wurde die übermäßige Beanspruchung des Kategorisierungsmoduls nicht durch eine erwartete Belastung verursacht, prüfen Sie ob Virusbefall oder Spam dafür verantwortlich ist.

Die Leistungsindikatoren für das Nachrichtenkategorisierungsmodul werden für jede Instanz des virtuellen SMTP-Servers (Simple Mail Transfer Protoco) einzeln veröffentlicht. Eine Liste der verfügbaren Leistungsindikatoren im Zusammenhang mit dem Nachrichtenkategorisierungsmodul finden Sie im Microsoft Knowledge Base-Artikel 231734, "XCON: Performance Monitor Counters for Message Categorizer" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).


Große Anzahl von Postfächern mit festgelegten Übermittlungseinschränkungen für Verteilergruppen
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-21

Microsoft® Exchange Server Analyzer Tool fragt die folgenden Attribute für jedes Benutzerobjekt in allen in dem Active Directory®-Verzeichnisdienst gefundenen Domänen ab, um zu ermitteln, ob für Postfächer in den Domänen auf der Mitgliedschaft in Verteilergruppen basierende Übermittlungseinschränkungen festgelegt wurden:

dLMemDefault | Steuert, ob Nachrichten standardmäßig akzeptiert oder abgelehnt werden. Mit der Standardeinstellung 1 werden Nachrichten von allen Absendern akzeptiert.
dLMemRejectPerms | Enthält die DNs der Verteilerlisten, deren Mitglieder keine Nachrichten an diesen Empfänger senden dürfen.
dLMemSubmitPerms | Enthält die DNs der Verteilerlisten, deren Mitglieder Nachrichten an diesen Empfänger senden dürfen.

Wenn Exchange Server Analyzer feststellt, dass für mehr als 500 Postfächer in der Domäne Übermittlungseinschränkungen basierend auf der Mitgliedschaft in Verteilergruppen festgelegt sind, zeigt Exchange Server Analyzer einen Fehler an.

Dieser Fehler weist darauf hin, dass sich auf der Mitgliedschaft in Verteilergruppen basierende Übermittlungseinschränkungen für viele Postfächer möglicherweise negativ auf die Leistung der Exchange-Nachrichtenübermittlung auswirken.

Standardmäßig führt das Kategorisierungsmodul eine rekursive Erweiterung von Verteilergruppen durch und überprüft jede Nachricht, die das System durchläuft, auf Einschränkungen.

Wenn das Nachrichtenkategorisierungsmodul E-Mails an einen Benutzer sendet, der Nachrichten von einer Verteilergruppe akzeptiert oder verweigert, muss das Nachrichtenkategorisierungsmodul die Mitgliedschaft der Verteilergruppe erweitern, die vollständige Liste der DNs der Mitglieder anfordern und anschließend die Liste der DNs mit den DNs der Absender vergleichen. Eine Zugriffsoperation oder eine Verweigerungsoperation erfolgt, wenn ein DN in beiden Listen enthalten ist. Wenn eine Verteilergruppe in eine andere Verteilergruppe geschachtelt ist, wird die geschachtelte Verteilergruppe ebenfalls erweitert.

So beheben Sie diesen Fehler

  • Überprüfen Sie diejenigen Benutzer, deren Übermittlungseinschränkungen für Verteilergruppen festgelegt sind, und entfernen Sie nicht benötigte Einschränkungen.

  • Konfigurieren Sie einzelne Postfächer und keine Verteilergruppen für Übermittlungseinschränkungen gemäß den Erläuterungen im Microsoft Knowledge Base-Artikel 812298, "Übermittlung von E-Mails ist langsam, nachdem Sie Übermittlungseinschränkungen konfiguriert haben, die auf einer Verteilerliste basieren" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Erwägen Sie für Server, auf denen Microsoft Exchange Server 2003 Service Pack 2 (SP2) oder höher ausgeführt wird, die nicht hierarchische Einschränkungsüberprüfung zu implementieren. Bei Servern, auf denen Versionen von Exchange vor Exchange Sever 2003 SP2 ausgeführt werden, sollten Sie die Aktualisierung auf Exchange Server 2003 SP2 in Betracht ziehen.

Weitere Informationen

Weitere Informationen zu der nicht hierarchischen Einschränkungsüberprüfung finden Sie unter Empfohlene Vorgehensweise: Nicht hierarchische Einschränkungsüberprüfung..

Weitere Informationen zu der Auswirkung der Verteilergruppeneinschränkung auf die Nachrichtenübermittlung in Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 895407, "Die Nachrichtenübermittlung zu lokalen und externen Postfächern ist in Exchange Server 2003 langsamer als erwartet, nachdem Sie die Übermittlungseinschränkungen basierend auf Verteilergruppen konfiguriert haben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 839949, "Problembehandlung bei E-Mail-Transport und Verteilergruppen in Exchange 2000 Server und in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • 812298, "Übermittlung von E-Mails ist langsam, nachdem Sie Übermittlungseinschränkungen konfiguriert haben, die auf einer Verteilerliste basieren" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).


„Least Cost Routing" ist in einer Organisation im gemischten Modus aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Microsoft Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob auf dem Server, auf dem Exchange Server Version 5.5 in einer Umgebung im gemischten Modus ausgeführt wird, „Least Cost Routing" aktiviert ist. Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen vorliegen:

  • „Least Cost Routing" ist aktiviert.

  • In Ihrer Organisation wird Exchange Server 2003 in einer Umgebung im gemischten Modus mit Exchange Server 5.5 ausgeführt.

Wenn „Least Cost Routing" in einer Umgebung im gemischten Modus aktiviert ist, werden möglicherweise Nachrichtenschleifen erstellt. Exchange Server 2003 verwendet Statusinformationen zur Routingverbindung. Wenn Exchange Server 2003 feststellt, dass eine Verknüpfung inaktiv ist, werden Nachrichten an einen anderen Server weitergeleitet. Wenn ein Exchange Server 5.5-Server die Option Only use least cost routes in der Eigenschaftenseite des Message Transfer Agent ausführt, wird regelmäßig die optimale Route zu dem Exchange Server 2003 Server zurückverfolgt, der die Nachricht soeben gesendet hat. Beim Zurücksenden der Nachricht an den Exchange Server 2003 entsteht eine Nachrichtenschleife.

In einer Organisation im gemischtem Modus, in der Exchange Server 5.5 und Exchange 2000 Server ausgeführt werden, empfiehlt es sich, die Option Least Cost Routing auf allen Servern zu deaktivieren, auf denen Exchange Server 5.5 ausgeführt wird.

So deaktivieren Sie die Option „Least Cost Routing" für Exchange Server 5.5

  1. Erweitern Sie im Programm Microsoft Exchange Server-Administrator den Container Organisation, erweitern Sie den Container Standort, den Container Konfiguration und den Container Server. Klicken Sie anschließend auf Ihr Serverobjekt.

  2. Klicken Sie im rechten Bereich auf das Objekt Message Transfer Agent.

  3. Klicken Sie auf das Menü Datei, und klicken Sie anschließend auf Eigenschaften.

  4. Deaktivieren Sie im Dialogfeld mit den Eigenschaften von Message Transfer Agent auf der Registerkarte Allgemein die Option Nur günstigste Routen verwenden.

  5. Klicken Sie auf OK.


Der Wert für den empfangenden Anschluss für SMTP wurde anscheinend von seinem Standardwert 25 in einen anderen Wert geändert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob der konfigurierte Wert für das Attribut msExchServerBindings (Standardwert 25) geändert wurde. In der Standardeinstellung ist das Attribut msExchServerBindings für den TCP-Anschluss 25 konfiguriert. Wenn Microsoft Exchange Server Analyzer feststellt, dass dieses Attribut nicht den Wert 25 aufweist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Das Attribut msExchServerBindings stellt den TCP-Anschluss dar, der vom SMTP-Server (Simple Mail Transfer Protocol) auf eingehende Verbindungen überwacht wird. Virtuelle SMTP-Server können so konfiguriert werden, dass sie einen oder mehrere TCP-Ports abhören. In der Standardeinstellung sind alle virtuellen SMTP-Server so konfiguriert, dass sie den Standard-TCP-Port 25 abhören. Wenn der SMTP-Abhörport abweichend von der Standardeinstellung geändert wurde und der TCP-Port 25 nicht mehr in der Liste der Abhörports enthalten ist, kann es zur Störung des Nachrichtenflusses kommen.

Das Ändern des SMTP-Abhörports ist nur dann ohne Probleme möglich, wenn auch der Rest Ihrer internen Messaging-Infrastruktur entsprechend geändert wird. Im Allgemeinen können jedoch andere Ports für virtuelle SMTP-Server, die Nachrichten direkt aus dem Internet annehmen, nicht verwendet werden, da SMTP-Server im Internet Nachrichten über Port 25 senden.

Beachten Sie, dass Exchange Server Analyzer den Wert für den virtuellen Exchange-SMTP-Protokollserver untersucht. Bei diesem virtuellen SMTP-Protokollserver kann es sich um den SMTP-Server handeln, der Nachrichten direkt aus dem Internet empfängt, dies muss aber nicht der Fall sein. Manche Antivirus- und Anti-Spam-Produkte sind dafür entwickelt, SMTP-Nachrichten aus dem Internet über Port 25 zu empfangen und sie an einen virtuellen Exchange-SMTP-Server oder einen anderen Port weiterzuleiten. In diesem Szenario ist die Konfiguration mit einem virtuellen Exchange-SMTP-Server, der einen anderen Port als 25 überprüft, zulässig.

So zeigen Sie den Abhörport des virtuellen SMTP-Servers an oder ändern ihn

  1. Erweitern Sie im Exchange-System-Manager die Option Server, erweitern Sie einen Exchange-Server, erweitern Sie dann Protokolle, und erweitern Sie anschließend SMTP.

  2. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise Virtueller Standardserver für SMTP), und klicken Sie dann auf Eigenschaften.

  3. Wählen Sie die Registerkarte Allgemein aus, und klicken Sie dann auf Erweitert.

  4. Eine Liste mit IP-Adressen und Ports wird angezeigt.

    • Um den vorhandenen Port zu ändern, wählen Sie die IP-Adresse aus, und klicken Sie auf Bearbeiten. Ändern Sie den Wert im Feld für den TCP-Port auf 25.

    • Um Port 25 als zusätzlichen Abhörport hinzuzufügen, klicken Sie auf Hinzufügen, und geben Sie die neue Kombination aus IP-Adresse und Port ein. Wenn Sie eine Verbindungs-, Sender- oder Empfängerfilterung verwenden, stellen Sie sicher, dass die entsprechenden Kontrollkästchen aktiviert sind.

  5. Klicken Sie auf OK, um die Änderungen zu speichern. Klicken Sie dann auf OK, um das Dialogfeld Erweitert zu schließen. Klicken Sie auf OK, um das Dialogfeld Eigenschaften des virtuellen SMTP-Servers zu schließen.

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 266686, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://support.microsoft.com/?kbid=266686)

  • 268163, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://support.microsoft.com/?kbid=268163)


Warteschlange "Lokale Übermittlung" hat den Status "Fixiert"
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-03

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) ExchangeLink ab, um den Wert des Schlüssels StateFrozen für die SMTP-Warteschlange (Simple Mail Transfer Protocol) Lokale Übermittlung zu bestimmen.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Schlüssels StateFrozen für die Warteschlange Lokale Übermittlung auf einem Server mit Exchange auf True festgelegt ist, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Eine fixierte Warteschlange bedeutet, dass die Transportsitzungen für diese Warteschlange beendet wurden. Eine fixierte Warteschlange verhindert ausgehende Nachrichten, obgleich neue Nachrichten hinzugefügt werden können. Sie können den Status einer Verbindung über das Kontextmenü für jede Verbindungswarteschlange manuell ändern. Wenn Sie mit dem Befehl Verbindung erzwingen einen Warteschlangenstatus in Aktiv ändern, aktivieren Sie sofort eine Verbindung, über welche die Nachrichten in dieser Warteschlange gesendet werden.

Die Warteschlange Lokale Übermittlung enthält Nachrichten, die auf dem Server mit Exchange zur lokalen Übermittlung an ein Exchange Server-Postfach oder einen Informationsspeicher für Öffentliche Ordner abgelegt werden.

Nachrichten können sich in dieser Warteschlange ansammeln, wenn der Server mit Exchange keine Nachrichten für die lokale Übermittlung annimmt. Eine langsame oder nur zeitweise Nachrichtenübermittlung kann ein Hinweis auf eine Nachricht in einer Schleife oder ein Leistungsproblem sein.

Erhöhen Sie zum Beheben dieses Fehlers den Protokolliergrad für die Diagnose des Diensts MSExchangeTransport, um Informationen zu Komponenten des Kategorisierungsmoduls zu erfassen.

Weitere Informationen zum Ändern von Protokolleinstellungen finden Sie unter "Ändern von Protokollierungseinstellungen für MSExchangeTransport" im Kapitel "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft Knowledge Base-Artikel 821877 mit einer Beschreibung der Felder auf den Eigenschaftsregisterkarten für die SMTP- und X.400-Warteschlange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Warteschlange "Lokale Übermittlung" hat den Status "Wiederholen"
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-03

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) ExchangeLink ab, um den Wert des Schlüssels StateRetry für die SMTP-Warteschlange (Simple Mail Transfer Protocol) Lokale Übermittlung zu bestimmen.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Schlüssels StateRetry für die Warteschlange Lokale Übermittlung auf einem Server mit Exchange auf True festgelegt ist, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Wenn eine Warteschlange den Status Wiederholen hat, bedeutet dies, dass mindestens ein Fehler bei den vorherigen Versuchen der Verarbeitung der Nachrichten in der Warteschlange aufgetreten ist. Mit dem Befehl Verbindung erzwingen kann der Status von Warteschlangen von Wiederholen und Geplant in Aktiv geändert werden. Dadurch funktioniert die Warteschlange so, als ob das Wiederholungsintervall abgelaufen oder der geplante Zeitpunkt erreicht sei. Diese Methode funktioniert jedoch nicht immer. Die Eigenschaften einer Warteschlange können einen bestimmten Grund angeben, warum eine Warteschlange den Status Wiederholen hat.

Die Warteschlange Lokale Übermittlung enthält Nachrichten, die auf dem Server mit Exchange zur lokalen Übermittlung an ein Exchange Server-Postfach oder einen Informationsspeicher für Öffentliche Ordner abgelegt werden.

Nachrichten können sich in dieser Warteschlange ansammeln, wenn der Server mit Exchange keine Nachrichten für die lokale Übermittlung annimmt. Eine langsame oder nur zeitweise Nachrichtenübermittlung kann ein Hinweis auf eine Nachricht in einer Schleife oder ein Leistungsproblem sein.

Erhöhen Sie zum Beheben dieses Fehlers den Protokolliergrad für die Diagnose des Diensts MSExchangeTransport, um Informationen zu Komponenten des Kategorisierungsmoduls zu erfassen.

Weitere Informationen zum Ändern von Protokolleinstellungen finden Sie unter "Ändern von Protokollierungseinstellungen für MSExchangeTransport" im Kapitel "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Microsoft Knowledge Base-Artikel 821877 mit einer Beschreibung der Felder auf den Eigenschaftsregisterkarten für die SMTP- und X.400-Warteschlange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Fehler bei der E-Mail-Annahme
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer versucht, eine Nachricht an das Postmasterkonto oder ein benutzerdefiniertes Konto für die SMTP-Domäne (Simple Mail Transfer Protocol) zu senden, indem folgende Aufgaben ausgeführt werden:

  • Exchange Server Analyzer öffnet eine Socket-Verbindung mit dem SMTP-Server. Wenn Exchange Server Analyzer den Antwortcode 220 empfängt, wurde dieser Schritt erfolgreich ausgeführt.

  • Exchange Server Analyzer übermittelt das SMTP-Befehlsverb EHLO. Wenn die folgenden Bedingungen zutreffen, wurde dieser Schritt erfolgreich abgeschlossen:

    • Exchange Server Analyzer empfängt eine Folge von Antwortcodes vom Typ 250.

    • Eine dieser Antworten enthält 250-X-LINK2STATE und 250-XEXCH50.

  • Exchange Server Analyzer übermittelt das SMTP-Befehlsverb MAIL FROM: ExMFA-MailAcceptTest@Fabrikam.com. Wenn Exchange Server Analyzer den Antwortcode 250 empfängt, wurde dieser Schritt erfolgreich ausgeführt.

  • Exchange Server Analyzer übermittelt das SMTP-Befehlsverb RCPT TO: Postmaster (oder benutzerdefiniertes Konto)@<Domänenname>.com. Wenn Exchange Server Analyzer den Antwortcode 250 empfängt, wurde dieser Schritt erfolgreich ausgeführt.

  • Exchange Server Analyzer übermittelt das SMTP-Befehlsverb DATA mit einem Beispielnachrichtentext, der mit einem Punkt endet. Wenn Exchange Server Analyzer den Antwortcode 250 empfängt, wurde dieser Schritt erfolgreich ausgeführt.

Wenn Exchange Server Analyzer nicht alle Schritte abschließen kann, wird ein Fehler angezeigt. Der Fehler weist darauf hin, dass u. U. ein allgemeines Problem beim Nachrichtenfluss besteht. Die folgenden Verknüpfungen sind in der Reihenfolge angegeben, in der Sie bei der Problembehebung vorgehen sollen, beginnend auf der Serverebene bis hin zur Netzwerkebene.

So beheben Sie diesen Fehler

  1. Siehe "Problembehandlung beim Routing" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?linkid=47579).
  2. Microsoft Knowledge Base-Artikel 324867, "Support WebCast:

    Siehe Microsoft Knowledge Base-Artikel 324867, "Support WebCast: Microsoft Exchange 2000 Server: Troubleshooting Mail Flow Problems (Revisited)" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324867).

  3. Siehe Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" ((http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489).

  4. Siehe Microsoft Knowledge Base-Artikel 324759, "Support WebCast: Microsoft Exchange 2000 Server: DNS Troubleshooting in Transports" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324759).

Weitere Informationen zum Postmasterkonto in Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 223860, "XCON: SMTP-Postmaster-Postfach muss manuell festgelegt werden" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=223860).

  • 313832, "SMTP-Postmaster-Konto in Exchange 2000 Server einrichten" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313832).


E-Mail-Akzeptanzfehler, BDAT-Befehl
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-21

Microsoft® Exchange Server Analyzer übermittelt das ESMTP-Befehlsverb (Extended Simple Mail Transfer Protocol) EHLO an Port 25 eines Remoteservers und analysiert die Antwort, um zu ermitteln, ob der Remoteserver das ESMTP-Verb BDAT unterstützt.

Wenn die auf das BDAT-Befehlsverb vom Remoteserver erhaltene Antwort keinen nicht abrufbaren Fehler angibt, übermittelt Exchange Server Analyzer eine Testnachricht an den Remoteserver und analysiert die Antwort, um zu ermitteln, ob die Nachrichtenübertragung erfolgreich war.

Falls Exchange Server Analyzer die erwartete Antwortzeichenfolge '250' nicht erhält, zeigt Exchange Server Analyzer einen Fehler an.

Exchange Server 2003 verwendet Exchange-spezifische erweiterte SMTP-Verben, um mit anderen Servern in der Organisation zu kommunizieren, auf denen Exchange Server ausgeführt wird. Exchange-spezifische erweiterte SMTP-Verben ermöglichen eine effektivere Kommunikation als Standard-SMTP-Verben. Wenn die Unterstützung des ESMTP-Befehlssatzes deaktiviert ist, kann die Leistung von Exchange Server unter Umständen herabgesetzt werden.

Das ESMTP-Befehlsverb BDAT stellt eine Alternative zu dem DATA-Befehl dar. Wenn ein virtueller SMTP-Server auf das Schlüsselwort EHLO mit CHUNKING antwortet, gibt der SMTP-Server an, dass der Befehl BDAT unterstützt wird und Nachrichten in Abschnitten angenommen werden. Dieser Befehl verarbeitet zwei Argumente.

  • Das erste Argument gibt die Länge des binären Datenpakets an. Deshalb muss der SMTP-Host nicht fortlaufend nach dem Ende der Daten suchen. Der empfangende Server zählt die Bytes in der Nachricht. Wenn die Nachrichtengröße dem vom Befehl BDAT gesendeten Wert entspricht, geht der Server davon aus, dass er alle Nachrichtendaten empfangen hat.

  • Das zweite Argument gibt an, ob das Datenpaket das letzte Paket in der aktuellen Übertragung ist. Das zweite Argument ist optional.

Dieser Fehler gibt an, dass die anschließende BDAT-E-Mail-Akzeptanzprüfung fehlschlägt, obwohl das ESMTP-Befehlsverb durch den Remoteserver unterstützt wird.

Um diesen Fehler zu beheben, überprüfen Sie die Messagingumgebung auf Probleme oder Konfigurationen, die das BDAT-Befehlsverb unter Umständen blockieren. Hierzu zählen:

  • Vorübergehende Netzwerkausfälle

  • SMTP-Proxies

  • Firewalls

  • Anwendungen

Weitere Informationen zum Entfernen oder Wiederherstellen der standardmäßigen Unterstützung dieser Verben finden Sie im Microsoft Knowledge Base-Artikel 257569 "Kann ESMTP-Verben in Exchange 2000 Server und Exchange Server 2003 wie deaktivieren" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569).

Weitere Informationen dazu, wie Exchange Server die ESMTP-Befehlsverben verwendet, finden Sie im Abschnitt zum ordnungsgemäßen Laden von Exchange SMTP im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkID=71800).


Postfachspeicher wurde als gemeinsames Ziel identifiziert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-10-04

Microsoft® Exchange Server Analyzer fragt die Exchange_Queue WMI-Klasse (Windows® Management Instrumentation) ab, um die Werte der folgenden Attribute für SMTP-Warteschlangen (Simple Mail Transfer Protocol) auf dem virtuellen SMTP-Server zu bestimmen.

LinkId | Gibt den Bezeichner für den Link an, der die Warteschlange enthält.
QueueId | Gibt den Bezeichner der Warteschlange an.
QueueName | Gibt den Namen der Warteschlange an.
VirtualMachine | Gibt den Namen des virtuellen Computers an, der die Warteschlange enthält.
VirtualServerName | Gibt den Namen des virtuellen Servers an, auf dem sich die Warteschlange befindet.
MessageCount | Gibt die Anzahl der Nachrichten in der Warteschlange an.

Exchange Server Analyzer fragt anhand der hier angegebenen Informationen die WMI-Klasse Exchange_QueuedSMTPMessage nach den Werten der folgenden Attribute für Nachrichten in der Warteschlange ab:

Recipients | Gibt die Empfänger der Nachricht an.
Received | Gibt den Zeitstempel des Empfangs der Nachricht an.
MessageId | Gibt den Bezeichner der in der Warteschlange befindlichen Nachricht an.
StateRetry | Gibt an, dass eine Nachricht, die nicht erfolgreich zugestellt werden konnte, erneut übermittelt wird.

Schließlich verwendet Exchange Server Analyzer die hier erhaltenen Daten dazu, um den Active Directory®-Verzeichnisdienst nach den folgenden werten für jedes Recipient-Objekt abzufragen. Exchange Server Analyzer ermittelt daraufhin, ob es sich bei dem Empfänger um einen Benutzer, eine Verteilergruppe, einen Öffentlicher Ordner oder einen Informationsspeicher für Öffentliche Ordner handelt:

distinguishedName | Gibt den DN (Distinguished Name) des Objekts an.
msExchHomeServerName | Gibt den Server an, auf dem sich der Empfänger befindet.
homeMDB | Gibt den Postfachspeicher des Empfängers an.

Wenn Exchange Server Analyzer ermittelt, dass 25 Prozent oder mehr der in der Warteschlange festsitzenden Nachrichten entweder im Feld To: oder im Feld Cc: an Empfänger mit Postfächern im selben Postfachspeicher adressiert sind, wird eine Warnung angezeigt.

Wenn Exchange Server Analyzer ermittelt, dass 50 Prozent oder mehr der in der Warteschlange festsitzenden Nachrichten entweder im Feld To: oder im Feld Cc: an Empfänger mit Postfächern im selben Postfachspeicher adressiert sind, wird ein Fehler angezeigt.

Diese Warnung bzw. dieser Fehler bedeutet, dass der identifizierte Postfachspeicher ein gemeinsames Ziel für Nachrichten ist, die in einer SMTP-Warteschlange festsitzen.

Um dieses Problem zu beheben, sollten Sie überprüfen, ob Konfigurationsprobleme oder andere Anomalien für diesen Postfachspeicher vorliegen, die dazu führen, dass die an diese Verteilergruppe gerichteten Nachrichten in die Warteschlange gesetzt werden.

  • Stellen Sie sicher, dass die Attribute des Speicherobjekts ordnungsgemäß eingerichtet wurden und in Active Directory die richtigen Werte enthalten.

  • Überprüfen Sie, ob die Active Directory-Berechtigungen des Speicherobjekts richtig eingestellt sind.

  • Wenn der Postfachspeicher der Speicher für ein spezielles Benutzerobjekt ist, d. h. einen vorgesehenen Journalempfänger, überprüfen Sie, ob der Dienst und die Komponenten, mit denen das Benutzerobjekt verknüpft ist, ordnungsgemäß konfiguriert sind.

  • Suchen Sie nach möglichen unerwünschten kommerziellen E-Mails (UCE oder SPAM) oder Virusangriffen auf die Speicherempfänger.

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei der Nachrichtenübermittlung und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).


Warteschlange 'Nachrichten mit nicht erreichbarem Ziel' enthält Nachrichten
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-10-04

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Microsoft Windows® Management Instrumentation - Microsoft Windows®-Verwaltungsinstrumentation) ExchangeLink ab, um den Wert der Eigenschaften TypeCurrentlyUnreachable, LinkName und NumberofMessages von SMTP-Warteschlangen (Simple Mail Transfer Protocol) auf einem Server zu bestimmen.

Enthält die Eigenschaft TypeCurrentlyUnreachable den Wert True, bedeutet dies, dass die Verbindung (die Exchange-Warteschlange) Nachrichten für Ziele enthält, die gegenwärtig nicht erreichbar sind.

Die Eigenschaft LinkName gibt den Namen der Verbindung an.

Die Eigenschaft NumberOfMessages gibt die Anzahl der Nachrichten an, die auf die Übertragung über die Verbindung warten.

Wenn Exchange Server Analyzer feststellt, dass SMTP-Warteschlange Nachrichten mit nicht erreichbarem Ziel Nachrichten enthält, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Dieser Fehler weist darauf hin, dass sich in der Warteschlange Nachrichten befinden, die den gewünschten Zielserver nicht erreichen können. Es kann z. B. sein, dass Exchange eine Route oder einen Connector zum Endziel nicht ermitteln kann oder alle verfügbaren Routen bzw. Connectors als "nicht verfügbar" gekennzeichnet sind.

Um diesen Fehler zu beheben, führen Sie folgende Schritte aus:

  • Überprüfen Sie, ob es sich bei den Nachrichten in der Warteschlange Nachrichten mit nicht erreichbarem Ziel um legitime Nachrichten handelt.

  • Überprüfen Sie die von Exchange Server Analyzer bereitgestellten Anweisungen und Links zu dem Fehler.

  • Beachten Sie die Anweisungen unter "Weitere Informationen" weiter unten in diesem Thema.

Weitere Informationen

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei der Nachrichtenübermittlung und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579)

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).


Warteschlange 'Nachrichten mit nicht erreichbarem Ziel' hat den Status 'Fixiert'
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-10-06

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) ExchangeLink ab, um den Wert des Schlüssels StateFrozen für die SMTP-Warteschlange (Simple Mail Transfer Protocol) Nachrichten mit nicht erreichbarem Ziel zu bestimmen.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Schlüssels StateFrozen für die Warteschlange Nachrichten mit nicht erreichbarem Ziel auf einem Server mit Exchange auf True festgelegt ist, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Eine fixierte Warteschlange bedeutet, dass die Transportsitzungen für diese Warteschlange beendet wurden. Eine fixierte Warteschlange verhindert ausgehende Nachrichten, obgleich neue Nachrichten hinzugefügt werden können.

Die Warteschlange Nachrichten mit nicht erreichbarem Ziel enthält Nachrichten, die den gewünschten Zielserver nicht erreichen. Es kann z. B. sein, dass Exchange eine Route oder einen Connector zum Endziel nicht ermitteln kann oder alle verfügbaren Routen bzw. Connectors als "nicht verfügbar" gekennzeichnet sind. Es können sich Nachrichten in dieser Warteschlange ansammeln, wenn eine der folgenden Bedingungen vorliegt:

  • Es existiert keine Route für die Nachrichtenübermittlung.

  • Ein Exchange-Connector oder eine Remotezustellungswarteschlange ist nicht verfügbar.

  • Neue Nachrichten werden in diese Warteschlange verschoben, wenn ein Exchange-Connector oder eine Remotezustellungswarteschlange den Status Wiederholen hat und es keine alternative Route zum Connector oder zum Remoteziel gibt.

Zum Beheben dieses Fehlers können Sie den Status der Verbindung über das Kontextmenü für jede Verbindungswarteschlange manuell ändern. Wenn Sie mit dem Befehl Verbindung erzwingen einen Warteschlangenstatus in Aktiv ändern, aktivieren Sie sofort eine Verbindung, über welche die Nachrichten in dieser Warteschlange gesendet werden. Wenn der Fehler weiterhin auftritt, erhöhen Sie den Diagnoseprotokolliergrade des Warteschlangenmoduls, wie weiter unten in diesem Thema unter "Weitere Informationen" beschrieben.

Weitere Informationen

Weitere Informationen zum Ändern von Protokollierungseinstellungen finden Sie unter "Ändern von Protokollierungseinstellungen für MSExchangeTransport" im Kapitel "Problembehandlung bei der Nachrichtenübermittlung und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei der Nachrichtenübermittlung und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579)

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Microsoft Knowledge Base-Artikel 821877, "Beschreibung der Felder auf den Registerkarten mit den Eigenschaften für SMTP- und X.400-Warteschlangen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Warteschlange 'Nachrichten mit nicht erreichbarem Ziel' hat den Status 'Wiederholen'
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-10-06

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) ExchangeLink ab, um den Wert des Schlüssels StateRetry für die SMTP-Warteschlange (Simple Mail Transfer Protocol) Nachrichten mit nicht erreichbarem Ziel zu bestimmen.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Schlüssels StateRetry für die Warteschlange Nachrichten mit nicht erreichbarem Ziel auf einem Server mit Exchange auf True festgelegt ist, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Wenn eine Warteschlange den Status Wiederholen hat, bedeutet dies, dass mindestens ein Fehler bei den vorherigen Versuchen der Verarbeitung der Nachrichten in der Warteschlange aufgetreten ist.

Hinweis:
Die Eigenschaften einer Warteschlange können einen bestimmten Grund angeben, warum eine Warteschlange den Status Wiederholen hat.

Die Warteschlange Nachrichten mit nicht erreichbarem Ziel enthält Nachrichten, die den gewünschten Zielserver nicht erreichen. Es kann z. B. sein, dass Exchange eine Route oder einen Connector zum Endziel nicht ermitteln kann oder alle verfügbaren Routen bzw. Connectors als "nicht verfügbar" gekennzeichnet sind. Es können sich Nachrichten in dieser Warteschlange ansammeln, wenn eine der folgenden Bedingungen vorliegt:

  • Es existiert keine Route für die Nachrichtenübermittlung.

  • Ein Exchange-Connector oder eine Remotezustellungswarteschlange ist nicht verfügbar.

  • Neue Nachrichten werden in diese Warteschlange verschoben, wenn ein Exchange-Connector oder eine Remotezustellungswarteschlange den Status Wiederholen hat und es keine alternative Route zum Connector oder zum Remoteziel gibt.

Um diesen Fehler zu beheben, ändern Sie mit dem Befehl Verbindung erzwingen den Status von Wiederholen in Aktiv. Dadurch funktioniert die Warteschlange so, als ob das Wiederholungsintervall abgelaufen sei. Diese Methode funktioniert jedoch nicht immer. Wenn der Fehler weiterhin auftritt, erhöhen Sie den Diagnoseprotokolliergrade des Warteschlangenmoduls, wie weiter unten in diesem Thema unter "Weitere Informationen" beschrieben.

Weitere Informationen

Weitere Informationen zum Ändern von Protokollierungseinstellungen finden Sie unter "Ändern von Protokollierungseinstellungen für MSExchangeTransport" im Kapitel "Problembehandlung bei der Nachrichtenübermittlung und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei der Nachrichtenübermittlung und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579)

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Microsoft Knowledge Base-Artikel 821877, "Beschreibung der Felder auf den Registerkarten mit den Eigenschaften für SMTP- und X.400-Warteschlangen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Postfächer mit festgelegten Übermittlungseinschränkungen für Verteilergruppen
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-21

Microsoft® Exchange Server Analyzer Tool fragt die folgenden Attribute für jedes Benutzerobjekt in allen in dem Active Directory®-Verzeichnisdienst gefundenen Domänen ab, um zu ermitteln, ob für Postfächer in den Domänen auf der Mitgliedschaft in Verteilergruppen basierende Übermittlungseinschränkungen festgelegt wurden:

dLMemDefault | Steuert, ob Nachrichten standardmäßig akzeptiert oder abgelehnt werden. Mit der Standardeinstellung 1 werden Nachrichten von allen Absendern akzeptiert.
dLMemRejectPerms | Enthält die DNs der Verteilerlisten, deren Mitglieder keine Nachrichten an diesen Empfänger senden dürfen.
dLMemSubmitPerms | Enthält die DNs der Verteilerlisten, deren Mitglieder Nachrichten an diesen Empfänger senden dürfen.

Wenn Exchange Server Analyzer feststellt, dass für Postfächer in der Domäne Übermittlungseinschränkungen basierend auf der Mitgliedschaft in Verteilergruppen festgelegt sind, zeigt Exchange Server Analyzer eine Warnung an.

Diese Warnung gibt an, dass sich Übermittlungseinschränkungen, die auf der Mitgliedschaft in Verteilergruppen basieren, möglicherweise negativ auf die Leistung der Exchange Server-Nachrichtenübermittlung auswirken.

Standardmäßig führt das Kategorisierungsmodul eine rekursive Erweiterung von Verteilergruppen durch und überprüft jede Nachricht, die das System durchläuft, auf Einschränkungen.

Wenn das Nachrichtenkategorisierungsmodul E-Mails an einen Benutzer sendet, der Nachrichten von einer Verteilergruppe akzeptiert oder verweigert, muss das Nachrichtenkategorisierungsmodul die Mitgliedschaft der Verteilergruppe erweitern, die vollständige Liste der DNs der Mitglieder anfordern und anschließend die Liste der DNs mit den DNs der Absender vergleichen. Eine Zugriffsoperation oder eine Verweigerungsoperation erfolgt, wenn ein DN in beiden Listen enthalten ist. Wenn eine Verteilergruppe in eine andere Verteilergruppe geschachtelt ist, wird die geschachtelte Verteilergruppe ebenfalls erweitert.

So beheben Sie diese Warnung

  • Überprüfen Sie diejenigen Benutzer, deren Übermittlungseinschränkungen für Verteilergruppen festgelegt sind, und entfernen Sie nicht benötigte Einschränkungen.

  • Konfigurieren Sie einzelne Postfächer und keine Verteilergruppen für Übermittlungseinschränkungen gemäß den Erläuterungen im Microsoft Knowledge Base-Artikel 812298, "Übermittlung von E-Mails ist langsam, nachdem Sie Übermittlungseinschränkungen konfiguriert haben, die auf einer Verteilerliste basieren" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Erwägen Sie für Server, auf denen Microsoft Exchange Server 2003 Service Pack 2 (SP2) oder höher ausgeführt wird, die nicht hierarchische Einschränkungsüberprüfung zu implementieren. Bei Servern, auf denen Versionen von Exchange vor Exchange Sever 2003 SP2 ausgeführt werden, sollten Sie die Aktualisierung auf Exchange Server 2003 SP2 in Betracht ziehen.

Weitere Informationen

Weitere Informationen zu der nicht hierarchischen Einschränkungsüberprüfung finden Sie unter Empfohlene Vorgehensweise: Nicht hierarchische Einschränkungsüberprüfung..

Weitere Informationen zu der Auswirkung der Verteilergruppeneinschränkung auf die Nachrichtenübermittlung in Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 895407, "Die Nachrichtenübermittlung zu lokalen und externen Postfächern ist in Exchange Server 2003 langsamer als erwartet, nachdem Sie die Übermittlungseinschränkungen basierend auf Verteilergruppen konfiguriert haben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 839949, "Problembehandlung bei E-Mail-Transport und Verteilergruppen in Exchange 2000 Server und in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • 812298, "Übermittlung von E-Mails ist langsam, nachdem Sie Übermittlungseinschränkungen konfiguriert haben, die auf einer Verteilerliste basieren" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).


Maximale Größe für eingehende Nachrichten wurde nicht festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-01-05

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs delivContLength für die globalen Einstellungen zu bestimmen, das sich befindet unter:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs delivContLength kleiner ist als 1, wird ein Fehler angezeigt.

Dieser Fehler weist darauf hin, dass der Höchstwert für die Größe eingehender Nachrichten nicht festgelegt wurde. Je nach Netzwerkbandbreite und Benutzeranforderungen in der Organisation kann die Nachrichtengröße begrenzt werden. In Exchange 2000 Server und Exchange Server 2007 gibt es keine Standardgrenzwerte für die Nachrichtengröße. In Exchange Server 2003 beträgt der Standardgrenzwert für das Senden und Empfangen von Nachrichten 10.240 KB. Dieser Standardgrenzwert für Exchange Server 2003 gilt für Neuinstallationen und für Aktualisierungen von Exchange 2000 Server, für die kein Grenzwert hinsichtlich der Nachrichtengröße festgelegt worden war.

Sie können die Systemressourcen schonen, indem Sie Grenzwerte für die Nachrichtengröße festlegen, die die Benutzer daran hindern, umfangreiche E-Mail-Nachrichten zu senden und zu empfangen. Das trägt dazu bei, den Netzwerkverkehr einzuschränken, Speicherplatz auf Datenträgern zu sparen und die Gesamtleistung des Netzwerks zu verbessern. Sie können für Exchange 2000 Server und Exchange Server 2003 unter Globale Einstellungen in Eigenschaften für Nachrichtenübermittlung auf der Registerkarte Standardeinstellungen Einschränkungen für die Übermittlung eingehender und ausgehender Nachrichten angeben. Um die maximale Größe einer Einzelnachricht festzulegen, wählen Sie Maximum (KB) aus, und geben Sie dann im Textfeld die maximale Größe in Kilobyte (KB) an. Wenn Sie die Nachrichtengröße nicht beschränken möchten, wählen Sie Unbegrenzt aus. Sender in der Organisation erhalten einen Unzustellbarkeitsbericht, wenn sie eine Nachricht zu versenden versuchen, die die angegebene Größenbeschränkung überschreitet. Ob externe Absender einen Unzustellbarkeitsbericht erhalten, ist von den Einstellungen für Unzustellbarkeitsberichte abhängig, die Sie unter Internet-Nachrichtenformate konfigurieren.

In Exchange Server 2007 können Sie die Exchange-Verwaltungsshell zum Festlegen des TransportConfig-Parameters MaxReceiveSize für die Exchange-Organisation verwenden.

Es wird empfohlen, den Grenzwert für die maximale Nachrichtengröße auf höchstens 10 MB festzulegen. Wenn Sie jedoch einen höheren Grenzwert für die Nachrichtengröße der innerhalb Ihrer Exchange-Organisation gesendeten Nachrichten mit großen Anlagen benötigen, können Sie den maximalen Grenzwert für die Größe eingehender Nachrichten auf 30 MB erhöhen. Eine Erhöhung der Grenze für die Nachrichtengröße auf über 30 MB kann zu einer Minderung der Netzwerkleistung sowie zu einer höheren Anfälligkeit Ihres Systems für Angriffe auf die Sicherheit führen.

So legen Sie die Grenzwerte für die Nachrichtengröße für Exchange 2000 Server und Exchange Server 2003 fest

  1. Erweitern Sie im Exchange-System-Manager Globale Einstellungen, klicken Sie mit der rechten Maustaste auf Nachrichtenübermittlung, und klicken Sie dann auf Eigenschaften.

  2. Wählen Sie im Dialogfeld Eigenschaften von Nachrichtenübermittlung auf der Registerkarte Defaults die Option Receiving message size limit aus, und geben Sie den gewünschten Grenzwert ein.

So legen die Höchstwerte für Nachrichten für Exchange Server 2007 fest

  1. Führen Sie in der Exchange-Verwaltungsshell den folgenden Befehl aus, wobei für <Größe> der Standardwert "Unbegrenzt" bzw. die Größe in Bytes, KB oder MB (Wertebereich zwischen 0 und 2147483647 Bytes) angegeben wird:
Code kopieren
Set-TransportConfig -MaxReceiveSize <size>

Wenn Sie die Größe der eingehenden Nachrichten für Empfänger in der Exchange-Organisation auf 10 MB beschränken möchten, geben Sie folgendes ein:

Code kopieren
Set-TransportConfig -MaxReceiveSize 10MB

Wenn Sie die Größe der eingehenden Nachrichten für Empfänger in der Exchange-Organisation nicht beschränken möchten (Standardwert), geben Sie folgendes ein:

Code kopieren
Set-TransportConfig -MaxReceiveSize unlimited
  • Weitere Informationen zum Festlegen der Grenzwerte für die Nachrichtengröße für Exchange 2000 Server und Exchange Server 2003 finden Sie im Artikel 322679 der Microsoft Knowledge Base: "Festlegen von Größenbegrenzungen für Nachrichten" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

  • Weitere Informationen zum Cmdlet TransportConfig für Exchange Server 2007 finden Sie unter "Set-TransportConfig" in der technischen Referenz zu Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkID=79237).

  • Weitere Informationen zu Internet-Nachrichtenformaten finden Sie unter „Verwenden von SMTP-Richtlinien zur Formatierung ausgehender Nachrichten und automatischer Antworten" im Exchange Server 2003-Administratorhandbuch (http://www.microsoft.com/germany/technet/datenbank/articles/600271.mspx).


Maximale Größe für eingehende Nachrichten ist zu hoch festgelegt (>30 MB).
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-02-27

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs delivContLength für die globalen Einstellungen zu bestimmen, das sich befindet unter:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs delivContLength größer als 30720 ist, wird ein Fehler angezeigt.

Dieser Fehler zeigt an, dass der Grenzwert für die maximal eingehenden Nachrichten auf einen Wert größer als 30 MB festgelegt wurde. In Exchange 2000 Server und Exchange Server 2007 gibt es keine Standardgrenzwerte für die Nachrichtengröße. In Exchange Server 2003 beträgt der Standardgrenzwert für das Senden und Empfangen von Nachrichten 10.240 KB. Dieser Standardgrenzwert wird auf neue Installationen und auf Upgrades von Exchange 2000 Server angewendet, für die kein Grenzwert für die Nachrichtengröße festgelegt wurde.

Sie können die Systemressourcen schonen, indem Sie Grenzwerte für die Nachrichtengröße festlegen, die die Benutzer daran hindern, umfangreiche E-Mail-Nachrichten zu senden und zu empfangen. Das trägt dazu bei, den Netzwerkverkehr zu begrenzen, Speicherplatz auf Datenträgern zu sparen und die Gesamtleistung des Netzwerks zu verbessern. Sie können für Exchange 2000 Server und Exchange Server 2003 unter Globale Einstellungen in Eigenschaften für Nachrichtenübermittlung auf der Registerkarte Standardeinstellungen Einschränkungen für die Übermittlung eingehender und ausgehender Nachrichten angeben. Um eine maximale Größe für einzelne Nachrichten festzulegen, wählen Sie Maximum (KB) aus, und geben Sie im Textfeld die maximale Größe in Kilobyte (KB) an. Wenn Sie die Nachrichtengröße nicht beschränken möchten, wählen Sie Unbegrenzt aus. Sender in Ihrer Organisation erhalten einen Unzustellbarkeitsbericht (NDR), wenn sie versuchen, eine Nachricht zu versenden, die die angegebene Größenbeschränkung überschreitet. Ob externe Absender einen Unzustellbarkeitsbericht erhalten, ist von den Einstellungen für Unzustellbarkeitsberichte abhängig, die Sie unter Internet-Nachrichtenformate konfigurieren.

Für Exchange Server 2007 können Sie die Exchange-Verwaltungsshell zum Festlegen des TransportConfig-Parameters MaxSendSize für die Exchange-Organisation verwenden.

Es wird empfohlen, den Grenzwert für die maximale Nachrichtengröße auf höchstens 30 MB festzulegen. Wenn Sie jedoch einen höheren Grenzwert für die Nachrichtengröße der innerhalb Ihrer Exchange-Organisation gesendeten Nachrichten mit großen Anlagen benötigen, können Sie den maximalen Grenzwert für die Größe eingehender Nachrichten auf mehr als 30 MB erhöhen. Eine Erhöhung des Grenzwerts für die Nachrichtengröße auf über 30 MB kann zu einer Minderung der Netzwerkleistung sowie zu einer höheren Anfälligkeit Ihres Systems für Angriffe auf die Sicherheit führen.

Wichtig:
Die Ergebnisse der folgenden Einstellungen unterscheiden sich für reine Exchange 2000 Server-/Exchange Server 2003-Umgebungen und Exchange Server 2007-Umgebungen ganz wesentlich, auch wenn sie möglicherweise ähnlich zu sein scheinen.

Wird die Größenbeschränkung für gesendete und empfangene Nachrichten unter Globale Einstellungen für einen postfachaktivierten Benutzer in einer reinen Exchange 2000 Server-/Exchange Server 2003-Umgebung auf den Wert 0 festgelegt, bewirkt dies, dass die Größenbeschränkung für Nachrichten komplett entfernt wird.

Werden die Parameter TransportConfig -MaxSendSize und TransportConfig -MaxReceiveSize in einer reinen Exchange 2007-Umgebung auf den Wert 0 festgelegt, führt dies dazu, dass der Versand von Nachrichten jeder Größe verhindert wird.

So legen Sie die Grenzwerte für die Nachrichtengröße für Exchange 2000 Server und Exchange Server 2003 fest

  1. Erweitern Sie im Exchange-System-Manager Globale Einstellungen, klicken Sie mit der rechten Maustaste auf Nachrichtenübermittlung, und klicken Sie dann auf Eigenschaften.

  2. Wählen Sie im Dialogfeld Eigenschaften von Nachrichtenübermittlung auf der Registerkarte Defaults die Option Receiving message size limit aus, und geben Sie den gewünschten Grenzwert ein.

So legen die Höchstwerte für Nachrichten für Exchange Server 2007 fest

  1. Führen Sie in der Exchange-Verwaltungsshell den folgenden Befehl aus, wobei für <Größe> der Standardwert "Unbegrenzt" bzw. die Größe in Bytes, KB oder MB (Wertebereich zwischen 0 und 2147483647 Bytes) angegeben wird:
Code kopieren
Set-TransportConfig -MaxReceiveSize <size>

Wenn Sie die Größe der eingehenden Nachrichten für Empfänger in der Exchange-Organisation auf 10 MB beschränken möchten, geben Sie folgendes ein:

Code kopieren
Set-TransportConfig -MaxReceiveSize 10MB

Wenn Sie die Größe der eingehenden Nachrichten für Empfänger in der Exchange-Organisation nicht beschränken möchten (Standardwert), geben Sie folgendes ein:

Code kopieren
Set-TransportConfig -MaxReceiveSize unlimited
  • Weitere Informationen zum Festlegen der Grenzwerte für die Nachrichtengröße für Exchange 2000 Server und Exchange Server 2003 finden Sie im Artikel 322679 der Microsoft Knowledge Base: "Festlegen von Größenbegrenzungen für Nachrichten" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

Weitere Informationen zum Cmdlet TransportConfig für Exchange Server 2007 finden Sie unter "Set-TransportConfig" in der technischen Referenz zu Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkID=79237).

  • Weitere Informationen zu Internet-Nachrichtenformaten finden Sie unter „Verwenden von SMTP-Richtlinien zur Formatierung ausgehender Nachrichten und automatischer Antworten" im Exchange Server 2003-Administratorhandbuch (http://www.microsoft.com/germany/technet/datenbank/articles/600271.mspx).


Maximale Größe für eingehende Nachrichten wurde möglicherweise zu klein festgelegt (<1 MB).
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-01-05

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs delivContLength für die globalen Einstellungen zu bestimmen, das sich befindet unter:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs delivContLength kleiner als 1024, jedoch größer als 0 ist, wird ein Fehler angezeigt.

Dieser Fehler gibt an, dass der Höchstwert für eingehende Nachrichten auf einen Wert von weniger als 1 MB festgelegt ist. Bei einem so niedrigen Wert kann Exchange Server möglicherweise einen Teil der an Ihre Organisation gesendeten Nachrichten nicht empfangen. In Exchange 2000 Server und Exchange Server 2007 gibt es keine Standardgrenzwerte für die Nachrichtengröße. In Exchange Server 2003 beträgt der Standardgrenzwert für das Senden und Empfangen von Nachrichten 10.240 KB. Dieser Standardgrenzwert gilt für Neuinstallationen und für Aktualisierungen von Exchange 2000 Server, für den kein Grenzwert hinsichtlich der Nachrichtengröße festgelegt worden war.

Sie können die Systemressourcen schonen, indem Sie Grenzwerte für die Nachrichtengröße festlegen, die die Benutzer daran hindern, umfangreiche E-Mail-Nachrichten zu senden und zu empfangen. Das trägt dazu bei, den Netzwerkverkehr einzuschränken, Speicherplatz auf Datenträgern zu sparen und die Gesamtleistung des Netzwerks zu verbessern. Sie können für Exchange 2000 Server und Exchange Server 2003 unter Globale Einstellungen in Eigenschaften für Nachrichtenübermittlung auf der Registerkarte Standardeinstellungen Einschränkungen für die Übermittlung eingehender und ausgehender Nachrichten angeben. Um die maximale Größe einer Einzelnachricht festzulegen, wählen Sie Maximum (KB) aus, und geben Sie dann im Textfeld die maximale Größe in Kilobyte (KB) an. Wenn Sie die Nachrichtengröße nicht beschränken möchten, wählen Sie Unbegrenzt aus. Sender in der Organisation erhalten einen Unzustellbarkeitsbericht, wenn sie eine Nachricht zu versenden versuchen, die die angegebene Größenbeschränkung überschreitet. Ob externe Absender einen Unzustellbarkeitsbericht erhalten, ist von den Einstellungen für Unzustellbarkeitsberichte abhängig, die Sie unter Internet-Nachrichtenformate konfigurieren.

In Exchange Server 2007 können Sie die Exchange-Verwaltungsshell zum Festlegen des TransportConfig-Parameters MaxSendSize für die Exchange-Organisation verwenden.

Es wird empfohlen, den Grenzwert für die maximale Nachrichtengröße auf höchstens 10 MB festzulegen. Wenn Sie jedoch einen höheren Grenzwert für die Nachrichtengröße der innerhalb Ihrer Exchange-Organisation gesendeten Nachrichten mit großen Anlagen benötigen, können Sie den maximalen Grenzwert für die Größe eingehender Nachrichten auf 30 MB erhöhen. Eine Erhöhung des Grenzwerts für die Nachrichtengröße auf über 30 MB kann zu einer Minderung der Netzwerkleistung sowie zu einer höheren Anfälligkeit Ihres Systems für Angriffe auf die Sicherheit führen.

So legen Sie die Grenzwerte für die Nachrichtengröße für Exchange 2000 Server und Exchange Server 2003 fest

  1. Erweitern Sie im Exchange-System-Manager Globale Einstellungen, klicken Sie mit der rechten Maustaste auf Nachrichtenübermittlung, und dann auf Eigenschaften.

  2. Wählen Sie im Dialogfeld Eigenschaften von Nachrichtenübermittlung auf der Registerkarte Defaults die Option Receiving message size limit aus, und geben Sie den gewünschten Grenzwert ein.

So legen die Höchstwerte für Nachrichten für Exchange Server 2007 fest

  1. Führen Sie in der Exchange-Verwaltungsshell den folgenden Befehl aus, wobei für <Größe> der Standardwert "Unbegrenzt" bzw. die Größe in Bytes, KB oder MB (Wertebereich zwischen 0 und 2147483647 Bytes) angegeben wird:
Code kopieren
Set-TransportConfig -MaxReceiveSize <size>

Wenn Sie die Größe der eingehenden Nachrichten für Empfänger in der Exchange-Organisation auf 10 MB beschränken möchten, geben Sie folgendes ein:

Code kopieren
Set-TransportConfig -MaxReceiveSize 10MB

Wenn Sie die Größe der eingehenden Nachrichten für Empfänger in der Exchange-Organisation nicht beschränken möchten (Standardwert), geben Sie folgendes ein:

Code kopieren
Set-TransportConfig -MaxReceiveSize unlimited
  • Weitere Informationen zum Festlegen der Grenzwerte für die Nachrichtengröße für Exchange 2000 Server und Exchange Server 2003 finden Sie im Artikel 322679 der Microsoft Knowledge Base: "Festlegen von Größenbegrenzungen für Nachrichten" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

Weitere Informationen zum Cmdlet TransportConfig für Exchange Server 2007 finden Sie unter "Set-TransportConfig" in der technischen Referenz zu Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkID=79237).

  • Weitere Informationen zu Internet-Nachrichtenformaten finden Sie unter „Verwenden von SMTP-Richtlinien zur Formatierung ausgehender Nachrichten und automatischer Antworten" im Exchange Server 2003-Administratorhandbuch (http://www.microsoft.com/germany/technet/datenbank/articles/600271.mspx).


„MaxDSNSize" wurde nicht festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die maximale Größe für DSN-Nachrichten (Delivery Status Notification, Benachrichtigungen zum Übermittlungsstatus) festgelegt ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MaxDSNSize

Exchange Server Analyzer fragt auch den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs serialNumber aller Verzeichnisobjekte mit der Objektkategorie msExchExchangeServer zu ermitteln. Wenn der Zeichenfolgenwert „Version 5.5" enthält, wird auf dem Computer Microsoft Exchange Server 5.5 ausgeführt. Wenn der Zeichenfolgenwert „Version 6.0" enthält, wird auf dem Computer Microsoft Exchange 2000 Server ausgeführt. Wenn der Zeichenfolgenwert Version 6.5 einschließt, führt der Computer Microsoft Exchange Server 2003 aus.

Wenn Exchange Server Analyzer feststellt, dass der Registrierungswert MaxDSNSize auf einem Exchange 2000 Server- bzw. Exchange Server 2003-Computer nicht vorhanden ist, wird eine Warnung angezeigt.

Der Registrierungswert MaxDSNSize ist ein optionaler Wert in Exchange Server, mit dem die Größe von DSN-Nachrichten begrenzt wird. Durch diese Option wird Exchange so konfiguriert, dass Anlagen entfernt werden, wenn eine Nachricht nicht übermittelt werden kann. Wenn dieser Registrierungswert hinzugefügt wird, empfiehlt es sich, einen Wert von 10240000 Bytes (10 MB) zu verwenden.

Hinweis:
Der Registrierungswert MaxDSNSize wurde in Service Pack 2 (SP2) für Exchange 2000 Server eingeführt. Damit er verwendet werden kann, ist daher Exchange 2000 Server SP2 oder eine höhere Version erforderlich. Wenn der Registrierungswert MaxDSNSize nicht vorhanden ist, wird in Service Pack 1 für Exchange Server 2003 und höheren Versionen ein Wert von 10 MB verwendet. Sie können den Registrierungswert MaxDSNSize hinzufügen, um dieses Standardverhalten außer Kraft setzen.

Durch das Aktivieren dieser Option können Sie Server- und Netzwerkressourcen sparen. Diese Implementierung des Entfernens von SMTP-Anlagen (Simple Mail Transfer Protocol) hat jedoch auch Nachteile. Wenn Sie diese Option zum Entfernen der Anlagen vom NDR (Non-Delivery Report, Unzustellbarkeitsbericht) aktivieren, werden auch die Details entfernt, die zum Anzeigen der Nachricht im Vorschaufenster erforderlich sind, und der Verfasser der Nachricht kann die Option zum erneuten Senden nicht verwenden. Wenn der Verfasser der Nachricht versucht, die Option zum erneuten Senden vom NDR zu verwenden, erhält er die folgende Fehlermeldung: Diese Nachricht kann nicht gesendet werden. Der Unzustellbarkeitsbericht enthält nicht genug Information über die ursprüngliche Nachricht. Um die Nachricht erneut zu senden, öffnen Sie diese im Ordner "Gesendete Objekte" und klicken Sie im Menü Aktionen auf Diese Nachricht erneut senden."

Allerdings kann der Verfasser der Nachricht auch dann nicht senden, wenn er die in der Fehlermeldung angegebene Methode anwendet.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\SMTPSvc

  3. Klicken Sie mit der rechten Maustaste auf SMTPSvc, und wählen Sie Neu | Schlüssel aus. Benennen Sie den neuen Schlüssel Queuing, und geben Sie keine Klasse an.

  4. Klicken Sie mit der rechten Maustaste auf Queuing, und wählen Sie Neu | DWORD-Wert aus. Benennen Sie den neuen Wert MaxDSNSize.

  5. Doppelklicken Sie im rechten Bereich auf den Registrierungswert MaxDSNSize, und geben Sie die Größenbeschränkung (in Byte) ein, die für das Datenfeld Wert gelten soll. Für Nachrichten, von denen ein Unzustellbarkeitsbericht erzeugt wird und deren Größe diesen Wert überschreitet, werden nicht die Anlagen und die vollständigen Nachrichteneigenschaften zurückgegeben.

  6. Schließen Sie den Registrierungs-Editor, und starten Sie den SMTP-Dienst (Simple Mail Transfer Protocol) neu, damit die Änderung wirksam wird.

Weitere Informationen zum Registrierungswert MaxDSNSize finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 308303, „XCON: Option to Strip Attachments for Messages That Generate an NDR" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308303).

  • 323484, „XCON: Description of the Multipart/Report Internet Message Format in Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=323484).


Maximale Größe für ausgehende Nachrichten wurde nicht festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-12-04

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs submissionContLength für die allgemeinen Einstellungen zu bestimmen. Der Speicherort dieses Attributs lautet wie folgt:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs submissionContLength kleiner ist als 1, wird ein Fehler angezeigt.

Dieser Fehler weist darauf hin, dass der Höchstwert für die Größe ausgehender Nachrichten nicht festgelegt wurde. Je nach Netzwerkbandbreite und Benutzeranforderungen in der Organisation kann die Nachrichtengröße begrenzt werden. In Exchange 2000 Server und Exchange Server 2007 gibt es keine Standardgrenzwerte für die Nachrichtengröße. In Exchange Server 2003 beträgt der Standardgrenzwert für das Senden und Empfangen von Nachrichten 10.240 KB. Dieser Standardgrenzwert gilt für Neuinstallationen und für Aktualisierungen von Exchange 2000 Server, für den kein Grenzwert hinsichtlich der Nachrichtengröße festgelegt worden war.

Sie können die Systemressourcen schonen, indem Sie Grenzwerte für die Nachrichtengröße festlegen, die die Benutzer daran hindern, umfangreiche E-Mail-Nachrichten zu senden und zu empfangen. Das trägt dazu bei, den Netzwerkverkehr einzuschränken, Speicherplatz auf Datenträgern zu sparen und die Gesamtleistung des Netzwerks zu verbessern. Sie können für Exchange 2000 Server und Exchange Server 2003 unter Globale Einstellungen in Eigenschaften für Nachrichtenübermittlung auf der Registerkarte Standardeinstellungen Einschränkungen für die Übermittlung eingehender und ausgehender Nachrichten angeben. Um die maximale Größe einer Einzelnachricht festzulegen, wählen Sie Maximum (KB) aus, und geben Sie dann im Textfeld die maximale Größe in Kilobyte (KB) an. Wenn Sie die Nachrichtengröße nicht beschränken möchten, wählen Sie Unbegrenzt aus. Sender in der Organisation erhalten einen Unzustellbarkeitsbericht, wenn sie eine Nachricht zu versenden versuchen, die die angegebene Größenbeschränkung überschreitet. Ob externe Sender einen Unzustellbarkeitsbericht erhalten können, hängt von den Einstellungen für Unzustellbarkeitsberichte ab, die Sie unter Internet-Nachrichtenformate konfigurieren.

Für Exchange Server 2007 verwenden Sie die Exchange-Verwaltungsshell zum Festlegen des TransportConfig-Parameters MaxSendSize für die Exchange-Organisation.

Es wird empfohlen, den Grenzwert für die maximale Nachrichtengröße auf höchstens 10 MB festzulegen. Wenn Sie jedoch einen höheren Grenzwert für die Nachrichtengröße der innerhalb Ihrer Exchange-Organisation gesendeten Nachrichten mit großen Anlagen benötigen, können Sie den maximalen Grenzwert für die Größe ausgehender Nachrichten auf 30 MB erhöhen. Eine Erhöhung der Grenze für die Nachrichtengröße auf über 30 MB kann zu einer Herabsetzung der Netzwerkleistung sowie zu einer höheren Anfälligkeit Ihres Systems für Sicherheitsattacken führen.

So legen Sie die Grenzwerte für die Nachrichtengröße für Exchange 2000 Server und Exchange Server 2003 fest

  1. Erweitern Sie im Exchange-System-Manager Globale Einstellungen, klicken Sie mit der rechten Maustaste auf Nachrichtenübermittlung, und klicken Sie dann auf Eigenschaften.

  2. Wählen Sie im Eigenschaftendialogfeld für die Nachrichtenübermittlung auf der Registerkarte Standardeinstellungen die Option für die maximale Größe für gesendete Nachrichten aus, und geben Sie den gewünschten Grenzwert ein.

So legen die Höchstwerte für Nachrichten für Exchange Server 2007 fest

  1. Führen Sie in der Exchange-Verwaltungsshell den folgenden Befehl aus, wobei für <Größe> der Standardwert "Unbegrenzt" bzw. die Größe in Bytes, KB oder MB (Wertebereich zwischen 0 und 2147483647 Bytes) angegeben wird:
Code kopieren
Set-TransportConfig -MaxSendSize <size>

Wenn Sie die Größe der ausgehenden Nachrichten für Benutzer in der Exchange-Organisation auf 10 MB beschränken möchten, geben Sie folgendes ein:

Code kopieren
Set-TransportConfig -MaxSendSize 10MB

Wenn Sie die Größe der ausgehenden Nachrichten für Benutzer in der Exchange-Organisation nicht beschränken möchten (Standardwert), geben Sie folgendes ein:

Code kopieren
Set-TransportConfig -MaxSendSize unlimited
  • Weitere Informationen zum Festlegen der Grenzwerte für die Nachrichtengröße für Exchange 2000 Server und Exchange Server 2003 finden Sie im Artikel 322679 der Microsoft Knowledge Base: "Festlegen von Größenbegrenzungen für Nachrichten" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

  • Weitere Informationen zum Cmdlet TransportConfig für Exchange Server 2007 finden Sie unter "Set-TransportConfig" in der technischen Referenz zu Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkID=79237).

  • Weitere Informationen zu Internet-Nachrichtenformaten finden Sie unter „Verwenden von SMTP-Richtlinien zur Formatierung ausgehender Nachrichten und automatischer Antworten" im Exchange Server 2003-Administratorhandbuch (http://www.microsoft.com/germany/technet/datenbank/articles/600271.mspx).


Maximale Größe für ausgehende Nachrichten ist zu hoch festgelegt (>30 MB).
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-12-04

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs submissionContLength für die allgemeinen Einstellungen zu bestimmen. Der Speicherort dieses Attributs lautet wie folgt:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs submissionContLength größer als 30720 ist , wird ein Fehler angezeigt.

Dieser Fehler gibt an, dass der Grenzwert für die maximale Größe von ausgehenden Nachrichten auf einen Wert größer als 30 MB festgelegt ist. Je nach Netzwerkbandbreite und Benutzeranforderungen in der Organisation kann die Nachrichtengröße auch auf einen geringeren Wert festgelegt werden. In Exchange 2000 Server und Exchange Server 2007 gibt es keine Standardgrenzwerte für die Nachrichtengröße. In Exchange Server 2003 beträgt der Standardgrenzwert für das Senden und Empfangen von Nachrichten 10.240 KB. Dieser Standardgrenzwert gilt für Neuinstallationen und für Aktualisierungen von Exchange 2000 Server, für die kein Grenzwert hinsichtlich der Nachrichtengröße festgelegt worden war.

Sie können die Systemressourcen schonen, indem Sie Grenzwerte für die Nachrichtengröße festlegen, die die Benutzer daran hindern, umfangreiche E-Mail-Nachrichten zu senden und zu empfangen. Das trägt dazu bei, den Netzwerkverkehr einzuschränken, Speicherplatz auf Datenträgern zu sparen und die Gesamtleistung des Netzwerks zu verbessern. Sie können für Exchange 2000 Server und Exchange Server 2003 unter Globale Einstellungen in Eigenschaften für Nachrichtenübermittlung auf der Registerkarte Standardeinstellungen Einschränkungen für die Übermittlung eingehender und ausgehender Nachrichten angeben. Um die maximale Größe einer Einzelnachricht festzulegen, wählen Sie Maximum (KB) aus, und geben Sie dann im Textfeld die maximale Größe in Kilobyte (KB) an. Wenn Sie die Nachrichtengröße nicht beschränken möchten, wählen Sie Unbegrenzt aus. Sender in der Organisation erhalten einen Unzustellbarkeitsbericht, wenn sie eine Nachricht zu versenden versuchen, die die angegebene Größenbeschränkung überschreitet. Ob externe Sender einen Unzustellbarkeitsbericht erhalten können, hängt von den Einstellungen für Unzustellbarkeitsberichte ab, die Sie unter Internet-Nachrichtenformate konfigurieren.

Für Exchange Server 2007 verwenden Sie die Exchange-Verwaltungsshell zum Festlegen des TransportConfig-Parameters MaxSendSize für die Exchange-Organisation.

Es wird empfohlen, den Grenzwert für die maximale Nachrichtengröße auf höchstens 10 MB festzulegen. Wenn Sie jedoch einen höheren Grenzwert für die Nachrichtengröße der innerhalb Ihrer Exchange-Organisation gesendeten Nachrichten mit großen Anlagen benötigen, können Sie den maximalen Grenzwert für die Größe ausgehender Nachrichten auf 30 MB erhöhen. Eine Erhöhung der Grenze für die Nachrichtengröße auf über 30 MB kann zu einer Herabsetzung der Netzwerkleistung sowie zu einer höheren Anfälligkeit Ihres Systems für Sicherheitsattacken führen.

So legen Sie die Grenzwerte für die Nachrichtengröße für Exchange 2000 Server und Exchange Server 2003 fest

  1. Erweitern Sie im Exchange-System-Manager Globale Einstellungen, klicken Sie mit der rechten Maustaste auf Nachrichtenübermittlung, und klicken Sie dann auf Eigenschaften.

  2. Wählen Sie im Eigenschaftendialogfeld für die Nachrichtenübermittlung auf der Registerkarte Standardeinstellungen die Option für die maximale Größe für gesendete Nachrichten aus, und geben Sie den gewünschten Grenzwert ein.

So legen die Höchstwerte für Nachrichten für Exchange Server 2007 fest

  1. Führen Sie in der Exchange-Verwaltungsshell den folgenden Befehl aus, wobei für <Größe> der Standardwert "Unbegrenzt" bzw. die Größe in Bytes, KB oder MB (Wertebereich zwischen 0 und 2147483647 Bytes) angegeben wird:
Code kopieren
Set-TransportConfig -MaxSendSize <size>

Wenn Sie die Größe der ausgehenden Nachrichten für Benutzer in der Exchange-Organisation auf 10 MB beschränken möchten, geben Sie folgendes ein:

Code kopieren
Set-TransportConfig -MaxSendSize 10MB

Wenn Sie die Größe der ausgehenden Nachrichten für Benutzer in der Exchange-Organisation nicht beschränken möchten (Standardwert), geben Sie folgendes ein:

Code kopieren
Set-TransportConfig -MaxSendSize unlimited
  • Weitere Informationen zum Festlegen der Grenzwerte für die Nachrichtengröße für Exchange 2000 Server und Exchange Server 2003 finden Sie im Artikel 322679 der Microsoft Knowledge Base: "Festlegen von Größenbegrenzungen für Nachrichten" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

Weitere Informationen zum Cmdlet TransportConfig für Exchange Server 2007 finden Sie unter "Set-TransportConfig" in der technischen Referenz zu Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkID=79237).

  • Weitere Informationen zu Internet-Nachrichtenformaten finden Sie unter „Verwenden von SMTP-Richtlinien zur Formatierung ausgehender Nachrichten und automatischer Antworten" im Exchange Server 2003-Administratorhandbuch (http://go.microsoft.com/fwlink/?LinkId=21769).


Die maximale Größe ausgehender Nachrichten ist möglicherweise zu niedrig festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-12-04

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs submissionContLength für die allgemeinen Einstellungen zu bestimmen. Der Speicherort dieses Attributs lautet wie folgt:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN= OrganisationsName , CN=Global Settings, CN=Message Delivery

Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs submissionContLength kleiner ist als 1024, jedoch größer als 0, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass der Grenzwert für die maximal mögliche Größe ausgehender Nachrichten auf einen Wert kleiner als 1 Megabyte (MB) festgelegt ist. Je nach Netzwerkbandbreite und Benutzeranforderungen in der Organisation kann die Nachrichtengröße auch auf einen höheren Wert festgelegt werden. In Exchange 2000 Server und Exchange Server 2007 gibt es keine Standardgrenzwerte für die Nachrichtengröße. In Exchange Server 2003 beträgt der Standardgrenzwert für das Senden und Empfangen von Nachrichten 10.240 KB. Dieser Standardgrenzwert gilt für Neuinstallationen und für Aktualisierungen von Exchange 2000 Server, für den kein Grenzwert hinsichtlich der Nachrichtengröße festgelegt worden war.

Sie können die Systemressourcen schonen, indem Sie Grenzwerte für die Nachrichtengröße festlegen, die die Benutzer daran hindern, umfangreiche E-Mail-Nachrichten zu senden und zu empfangen. Das trägt dazu bei, den Netzwerkverkehr einzuschränken, Speicherplatz auf Datenträgern zu sparen und die Gesamtleistung des Netzwerks zu verbessern. Sie können für Exchange 2000 Server und Exchange Server 2003 unter Globale Einstellungen in Eigenschaften für Nachrichtenübermittlung auf der Registerkarte Standardeinstellungen Einschränkungen für die Übermittlung eingehender und ausgehender Nachrichten angeben. Um die maximale Größe einer Einzelnachricht festzulegen, wählen Sie Maximum (KB) aus, und geben Sie dann im Textfeld die maximale Größe in Kilobyte (KB) an. Wenn Sie die Nachrichtengröße nicht beschränken möchten, wählen Sie Unbegrenzt aus. Sender in Ihrer Organisation erhalten einen Unzustellbarkeitsbericht (NDR), wenn sie versuchen, eine Nachricht zu versenden, die die angegebene Größenbeschränkung überschreitet. In Abhängigkeit von den Einstellungen für Nichtzustellbarkeitsberichte, die Sie in Internet-Nachrichtenformate konfigurieren, können externe Sender einen Nichtzustellbarkeitsbericht erhalten oder nicht.

Für Exchange Server 2007 verwenden Sie die Exchange-Verwaltungsshell zum Festlegen des TransportConfig-Parameters MaxSendSize für die Exchange-Organisation.

Es wird empfohlen, den Grenzwert für die maximale Nachrichtengröße auf höchstens 30 MB festzulegen. Wenn Sie jedoch einen höheren Grenzwert für die Nachrichtengröße der innerhalb der Exchange-Organisation gesendeten Nachrichten mit großen Anlagen benötigen, können Sie die maximal mögliche Größe ausgehender Nachrichten auf einen Wert größer als 30 MB erhöhen. Eine Erhöhung der Grenze für die Nachrichtengröße auf über 30 MB kann zu einer Herabsetzung der Netzwerkleistung sowie zu einer höheren Anfälligkeit Ihres Systems für Sicherheitsattacken führen.

So legen Sie die Grenzwerte für die Nachrichtengröße für Exchange 2000 Server und Exchange Server 2003 fest

  1. Erweitern Sie im Exchange-System-Manager Globale Einstellungen, klicken Sie mit der rechten Maustaste auf Nachrichtenübermittlung, und dann auf Eigenschaften.

  2. In the Message Delivery Properties dialog box, on the Defaults tab, select the Sending message size limit option and type the size limit you want.

So legen die Höchstwerte für Nachrichten für Exchange Server 2007 fest

  1. Führen Sie in der Exchange-Verwaltungsshell den folgenden Befehl aus, wobei für <Größe> der Standardwert "Unbegrenzt" bzw. die Größe in Bytes, KB oder MB (Wertebereich zwischen 0 und 2147483647 Bytes) angegeben wird:
Code kopieren
Set-TransportConfig -MaxSendSize <size>

Wenn Sie die Größe der ausgehenden Nachrichten für Benutzer in der Exchange-Organisation auf 10 MB beschränken möchten, geben Sie folgendes ein:

Code kopieren
Set-TransportConfig -MaxSendSize 10MB

Wenn Sie die Größe der ausgehenden Nachrichten für Benutzer in der Exchange-Organisation nicht beschränken möchten (Standardwert), geben Sie folgendes ein:

Code kopieren
Set-TransportConfig -MaxSendSize unlimited
  • Weitere Informationen zum Festlegen der Grenzwerte für die Nachrichtengröße für Exchange 2000 Server und Exchange Server 2003 finden Sie im Artikel 322679 der Microsoft Knowledge Base: "Festlegen von Größenbegrenzungen für Nachrichten" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

Weitere Informationen zum Cmdlet TransportConfig für Exchange Server 2007 finden Sie unter "Set-TransportConfig" in der technischen Referenz zu Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkID=79237).

  • Weitere Informationen zu Internet-Nachrichtenformaten finden Sie unter „Verwenden von SMTP-Richtlinien zur Formatierung ausgehender Nachrichten und automatischer Antworten" im Exchange Server 2003-Administratorhandbuch (http://www.microsoft.com/germany/technet/datenbank/articles/600271.mspx).


Die auf Nachrichten beschränkte Aufzeichnung ist aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-01-10

Microsoft® Exchange Server Analyzer sendet eine Abfrage an den Active Directory®-Verzeichnisdienst, um zu ermitteln, ob das Attribut msExchMessageJournalRecipient für das Kopieren von E-Mails in ein Empfängerpostfach konfiguriert wurde. Das Attribut msExchMessageJournalRecipient ist ein Attribut von Postfachspeicher-Objekten in Active Directory. In der Standardeinstellung ist das Attribut msExchMessageJournalRecipient nicht konfiguriert. Wenn Exchange Server Analyzer erkennt, dass das Attribut msExchMessageJournalRecipient konfiguriert ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht. Exchange Server Analyzer zeigt außerdem den Datenbanknamen und den Servernamen an, auf dem die auf Nachrichten beschränkte Aufzeichnung aktiviert ist.

Durch die auf Nachrichten beschränkte Journalerstellung von Exchange Server 2003 oder die Standardjournalerstellung von Exchange Server 2007 wird eine Kopie aller Nachrichten sowie der entsprechenden Daten der P2-Nachrichtenkopfzeilen für und von Postfachdatenbankbenutzern erstellt und eine Kopie der Nachricht an das angegebene Postfach gesendet. Der P2-Nachrichtenkopf enthält nur die Nachrichtenempfängerdaten, die der Sender für die Empfänger angegeben hat. Wenn eine externe Nachricht aus dem Internet empfangen wird, zeichnet Exchange Server die P1-Nachrichtenkopfzeilen auf. P1-Nachrichtenkopfzeilen enthalten die Adressinformationen, die von MTAs (Message Transfer Agents) zum Routen von Nachrichten verwendet werden. Wenn die auf Nachrichten beschränkte Aufzeichnung aktiviert ist, berücksichtigt Exchange Server in der Standardeinstellung weder Bcc-Empfänger noch Empfänger aus Weiterleitungsregeln oder Empfänger aus Verteilergruppenerweiterungen. Exchange Server archiviert außerdem keine MAPI-Berichtnachrichen wie Lesebestätigungen und Abwesenheitsnachrichten.

Aufzeichnungsnachrichten können umfangreiche Datenträger-, Netzwerk- und CPU-Ressourcen beanspruchen. Aufzeichnungen erfordern daher eine sorgfältige Bereitstellungsplanung. Aufzeichnungen sollten ausschließlich im Rahmen einer Gesamtlösung für Aufzeichnungen aktiviert werden.

Wenn die folgenden Bedingungen zutreffen, können Sie die Meldung über die von der Standardkonfiguration abweichende Konfiguration ignorieren:

  • Ihr Unternehmen macht Aufzeichnungen erforderlich.

  • Sie haben eine Gesamtlösung für Aufzeichnungen bereitgestellt.

Wenn dies nicht der Fall ist, sollten Sie die Aufzeichnungsfunktion deaktivieren.

So deaktivieren Sie die auf Nachrichten beschränkte Journalerstellung in Exchange 2000 Server und Exchange Server 2003

  1. Erweitern Sie im Exchange-System-Manager die Option Server, und erweitern Sie <Ihren Exchange-Server>. Erweitern Sie die <Speichergruppe>, und klicken Sie mit der rechten Maustaste auf den Postfachspeicher.

  2. Deaktivieren Sie auf der Registerkarte Allgemein das Kontrollkästchen Alle von Postfächern in diesem Informationsspeicher gesendeten oder empfangenen Nachrichten archivieren.

  3. Warten Sie 15 Minuten, bis die Änderungen vom Exchange-Informationsspeicher vorgenommen wurden. Sie müssen den Microsoft Exchange-Informationsspeicherdienst nicht neu starten.
So deaktivieren Sie die Standardjournalerstellung für eine Datenbank in Exchange Server 2007

  1. Befolgen Sie die Anweisungen in der Exchange Server 2007-Dokumentation unter "Deaktivieren der postfachweisen Erfassung von Datenbankjournalen" (http://go.microsoft.com/fwlink/?LinkId=80889).

Weitere Informationen zum Bereitstellen einer Journallösung für Exchange Server 2003 finden Sie unter Journaling with Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).

Weitere Informationen zum Bereitstellen einer Journallösung für Exchange Server 2007 finden Sie unter Übersicht über Journale (http://go.microsoft.com/fwlink/?LinkId=80820).


Möglicherweise ist eine Nachrichtenweiterleitungsschleife vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchAlternateServer für die einzelnen virtuellen SMTP-Server zu ermitteln. Exchange Server Best Practices Analyzer stellt außerdem fest, ob das Attribut msExchNonAuthoritativeDomains für einzelne Empfängerrichtlinien in der Organisation konfiguriert wurde. Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen vorliegen:

  • Eine Instanz des Attributs msExchAlternateServer wurde festgelegt.

  • Das Attribut msExchNonAuthoritativeDomains wurde für eine beliebige Empfängerrichtlinie festgelegt.

Exchange Server Analyzer zeigt eine Warnung an, da die zuvor angeführten Konfigurationen zu Nachrichtenschleifen führen können. Nachrichtenschleifen treten auf, wenn unterschiedliche Nachrichtensysteme in einer einzelnen Organisation für den gemeinsamen Betrieb konfiguriert sind. In diesem Szenario werden Exchange Server-Empfängerrichtlinien und SMTP-Konfigurationen dazu verwendet, Nachrichten für Benutzergruppen in heterogenen Messagingsystemen weiterzuleiten und zuzustellen.

Das Attribut msExchAlternateServer wird festgelegt, wenn Sie im Feld Alle E-Mails mit nicht ausgewerteten Empfängern weiterleiten an Host der Eigenschaftenseite für einen virtuellen SMTP-Server eine Adresse angeben.

Das Attribut msExchNonAuthoritativeDomains wird festgelegt, wenn Sie das Kontrollkästchen Diese Exchange-Organisation ist für die gesamte E-Mail-Übermittlung an diese Adresse verantwortlich auf der Eigenschaftenseite für die SMTP-Adresse für eine bestimmte Empfängerrichtlinie deaktivieren.

Therefore, if you specify an SMTP domain as non-authoritative by clearing the This Exchange Organization is responsible for all mail delivery to this address check box, and you have specified an address for unresolved recipients on any SMTP virtual server, the Exchange Server Analyzer displays a warning. Sie müssen jedoch beachten, dass ein Anzeigen dieser Warnung nicht notwendigerweise ein Hinweis darauf ist, dass in Ihrer Organisation eine Nachrichtenschleife vorhanden ist.

Wenn eine Domäne ohne Autorisierung vorhanden ist und für mindestens einen Server in der Organisation msExchAlternateServer festgelegt ist, ist möglicherweise eine Nachrichtenschleife vorhanden. Sie sollten sicherstellen, dass folgende Bedingungen erfüllt sind:

  • Für alle Domänen in der Organisation sind autorisierte Domänen vorhanden.

  • Die virtuellen SMTP-Server sind so konfiguriert, dass alle nicht ausgewerteten Nachrichten von autorisierten Domänen behandelt werden.

Insbesondere wenn Sie einen Domänennamen gemeinsam mit einer anderen Organisation nutzen, empfiehlt es sich, dass nur ein eingehender Pfad zu diesem Domänennamespace vorhanden ist. Für die Domäne sollte ein Mailserver oder ein Mailsystem autorisiert sein, sodass keine Schleifenbildung erfolgt. Der autorisierte Server sollte das letzte System im eingehenden Pfad sein.

Es ist unwichtig, welches System den ersten Empfänger bildet. Es ist unwichtig, ob mehr als zwei dieser Empfänger vorhanden sind. Es ist jedoch wichtig, dass nur ein System das endgültige Ziel darstellt.

So ändern Sie das Attribut „msExchAlternateServer"

  1. Erweitern Sie im Exchange-System-Manager die Option Server, erweitern Sie <Servername>, erweitern Sie dann Protokolle, und erweitern Sie anschließend SMTP.

  2. Klicken Sie mit der rechten Maustaste auf den virtuellen SMTP-Server, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie im Eigenschaftenfenster des virtuellen SMTP-Servers auf die Registerkarte Nachrichten.

  4. Geben Sie im Feld Alle E-Mails mit nicht ausgewerteten Empfängern weiterleiten an Host den FQDN (vollqualifizierten Distinguished Name) des Servers an, der die nicht ausgewerteten Nachrichten empfängt. Sie können auch die IP-Adresse des Servers in eckigen Klammern ([ ]) eingeben.

  5. Klicken Sie auf OK.
So ändern Sie das Attribut „msExchNonAuthoritativeDomains"

  1. Erweitern Sie im Exchange-System-Manager Empfänger, und doppelklicken Sie auf <Name der Empfängerrichtlinie>.

  2. Doppelklicken Sie auf der Registerkarte E-Mail-Adressen (Richtlinie) auf eine SMTP-Adresse.

  3. Wenn Sie auf der Eigenschaftenseite für die SMTP-Adresse das Kontrollkästchen Diese Exchange-Organisation ist für die gesamte E-Mail-Übermittlung an diese Adresse verantwortlich aktivieren, wird das Attribut msExchNonAuthoritativeDomains gelöscht. Wenn Sie das Kontrollkästchen deaktivieren, wird das Attribut msExchNonAuthoritativeDomains mit der SMTP-Adresse festgelegt, die im Feld Adresse angegeben ist.

Weitere Informationen zum gemeinsamen Nutzen von SMTP-Adressräumen finden Sie im Microsoft Knowledge Base-Artikel 321721, „XCON: Gemeinsame Nutzung von SMTP-Adressräumen in Exchange 2000" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321721.

Weitere Informationen zu Bereitstellungsszenarios für Internetverbindungen finden Sie im entsprechenden Kapitel im Transport- und Routing-Handbuch für Exchange Server 2003 unter http://www.microsoft.com/germany/technet/datenbank/articles/600421.mspx.


Warteschlange "Nachrichten warten auf Verzeichnissuche" hat den Status "Fixiert"
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) ExchangeLink ab, um den Wert des Schlüssels StateFrozen für die SMTP-Warteschlange (Simple Mail Transfer Protocol) Nachrichten warten auf Verzeichnissuche zu bestimmen.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Schlüssels StateFrozen für die Warteschlange Nachrichten warten auf Verzeichnissuche auf einem Server mit Exchange auf True festgelegt ist, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Eine fixierte Warteschlange bedeutet, dass die Transportsitzungen für diese Warteschlange beendet wurden. Eine fixierte Warteschlange verhindert ausgehende Nachrichten, obgleich neue Nachrichten hinzugefügt werden können. Sie können den Status einer Verbindung über das Kontextmenü für jede Verbindungswarteschlange manuell ändern. Wenn Sie mit dem Befehl Verbindung erzwingen einen Warteschlangenstatus in Aktiv ändern, aktivieren Sie sofort eine Verbindung, über welche die Nachrichten in dieser Warteschlange gesendet werden.

Die Warteschlange Nachrichten warten auf Verzeichnissuche enthält Nachrichten an Empfänger, die noch nicht im Abgleich mit dem Verzeichnisdienst Active Directory® aufgelöst werden konnten. Nachrichten werden auch während der Aufgliederung von Verteilerlisten in der Warteschlange abgelegt.

Nachrichten häufen sich im Allgemeinen in dieser Warteschlange an, wenn das erweiterte Warteschlangenmodul eine Nachricht nicht kategorisieren kann. Das erweiterte Warteschlangenmodul kann ggf. nicht auf die globalen Katalogserver und Empfängerinformationen zugreifen, oder die globalen Katalogserver sind nicht erreichbar oder überlastet. Darüber hinaus können sich Nachrichten aus den folgenden Gründen anhäufen:

  • Active Directory ist nicht verfügbar.

    Hinweis:
    Das Kategorisierungsmodul verwendet Active Directory zum Kategorisieren von Nachrichten.
  • Active Directory ist ggf. überlastet, wenn viele Nachrichten in der Warteschlange für die Vorkategorisierung abgelegt wurden.

  • Ein Konvertierungsfehler liegt vor. Das Kategorisierungsmodul ist auch für die Inhaltskonvertierung zuständig.

  • Das Nachrichtenkategorisierungsmodul kann die Postfachspeicher nicht finden.

  • Wenn SMTP neu installiert oder entfernt wurde, können die folgenden Metabasisschlüssel von Internetinformationsdienste (IIS) ggf. ungültig geworden sein: "/smtpsvc/DsUseCat" und "/smtpsvc/vsi#/DsUseCat"

    Hinweis:
    Ermitteln Sie, ob SMTP neu installiert oder entfernt wurde.

Erhöhen Sie zum Beheben dieses Fehlers den Protokolliergrad für die Diagnose der Dienste MSExchangeDSAccess und MSExchangeTransport, um Informationen zu Komponenten des Kategorisierungsmoduls zu erfassen.

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Microsoft Knowledge Base-Artikel 821877 mit einer Beschreibung der Felder auf den Eigenschaftsregisterkarten für die SMTP- und X.400-Warteschlange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Warteschlange "Nachrichten warten auf Verzeichnissuche" hat den Status "Wiederholen"
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) ExchangeLink ab, um den Wert des Schlüssels StateRetry für die SMTP-Warteschlange (Simple Mail Transfer Protocol) Nachrichten warten auf Verzeichnissuche zu bestimmen.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Schlüssels StateRetry für die Warteschlange Nachrichten warten auf Verzeichnissuche auf einem Server mit Exchange auf True festgelegt ist, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Wenn eine Warteschlange den Status Wiederholen hat, bedeutet dies, dass mindestens ein Fehler bei den vorherigen Versuchen der Verarbeitung der Nachrichten in der Warteschlange aufgetreten ist. Mit dem Befehl Verbindung erzwingen kann der Status von Warteschlangen von Wiederholen und Geplant in Aktiv geändert werden. Dadurch funktioniert die Warteschlange so, als ob das Wiederholungsintervall abgelaufen oder der geplante Zeitpunkt erreicht sei. Diese Methode funktioniert jedoch nicht immer.

Hinweis:
Die Eigenschaften einer Warteschlange können einen bestimmten Grund angeben, warum eine Warteschlange den Status Wiederholen hat.

Die Warteschlange Nachrichten warten auf Verzeichnissuche enthält Nachrichten an Empfänger, die noch nicht im Abgleich mit dem Verzeichnisdienst Active Directory® aufgelöst werden konnten. Nachrichten werden auch während der Aufgliederung von Verteilerlisten in der Warteschlange abgelegt.

Nachrichten häufen sich im Allgemeinen in dieser Warteschlange an, wenn das erweiterte Warteschlangenmodul eine Nachricht nicht kategorisieren kann. Das erweiterte Warteschlangenmodul kann ggf. nicht auf die globalen Katalogserver und Empfängerinformationen zugreifen, oder die globalen Katalogserver sind nicht erreichbar oder überlastet. Darüber hinaus können sich Nachrichten aus den folgenden Gründen anhäufen:

  • Active Directory ist nicht verfügbar.

    Hinweis:
    Das Kategorisierungsmodul verwendet Active Directory zum Kategorisieren von Nachrichten.
  • Active Directory ist ggf. überlastet, wenn viele Nachrichten in der Warteschlange für die Vorkategorisierung abgelegt wurden.

  • Ein Konvertierungsfehler liegt vor. Das Kategorisierungsmodul ist auch für die Inhaltskonvertierung zuständig.

  • Das Nachrichtenkategorisierungsmodul kann die Postfachspeicher nicht finden.

  • Wenn SMTP neu installiert oder entfernt wurde, können die folgenden Metabasisschlüssel von Internetinformationsdienste (IIS) ggf. ungültig geworden sein: "/smtpsvc/DsUseCat" und "/smtpsvc/vsi#/DsUseCat"

    Hinweis:
    Ermitteln Sie, ob SMTP neu installiert oder entfernt wurde.

Um diesen Fehler zu beheben, untersuchen Sie die Eigenschaften der Warteschlange, um zu ermitteln, warum die Warteschlange den Status Wiederholen hat. Wenn in den Warteschlangeneigenschaften eine Nachricht vom Typ "Ein SMTP-Fehler ist aufgetreten" angezeigt wird, müssen Sie die Ereignisprotokolle des Servers auf SMTP-Fehler überprüfen. Enthalten die Protokolle keine Ereignisse, müssen Sie die Protokolliergrad für SMTP erhöhen.

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Microsoft Knowledge Base-Artikel 821877 mit einer Beschreibung der Felder auf den Eigenschaftsregisterkarten für die SMTP- und X.400-Warteschlange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Warteschlange "Nachrichten mit ausstehender Übertragung" hat den Status "Fixiert"
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-16

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) ExchangeLink ab, um den Wert des Schlüssels StateFrozen für die SMTP-Warteschlange (Simple Mail Transfer Protocol) Nachrichten mit ausstehender Übertragung zu bestimmen.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Schlüssels StateFrozen für die Warteschlange Nachrichten mit ausstehender Übertragung auf einem Server mit Exchange auf True festgelegt ist, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Eine fixierte Warteschlange bedeutet, dass die Transportsitzungen für diese Warteschlange beendet wurden. Eine fixierte Warteschlange verhindert ausgehende Nachrichten, obgleich neue Nachrichten hinzugefügt werden können. Sie können den Status einer Verbindung über das Kontextmenü für jede Verbindungswarteschlange manuell ändern. Wenn Sie mit dem Befehl Verbindung erzwingen einen Warteschlangenstatus in Aktiv ändern, aktivieren Sie sofort eine Verbindung, über welche die Nachrichten in dieser Warteschlange gesendet werden.

Die Warteschlange Nachrichten mit ausstehender Übertragung enthält Nachrichten, die vom SMTP-Dienst bestätigt und angenommen wurden.

Nachrichten in dieser Warteschlange wurden noch nicht verarbeitet. Wenn sich Nachrichten ständig anhäufen, liegt ggf. ein Leistungsproblem vor. Gelegentliche Spitzen bei der CPU-Leistung können dafür sorgen, dass Nachrichten zeitweise in dieser Warteschlange vorhanden sind. Regelmäßig bewirken Probleme wie Ereignissenken, z. b. benutzerdefinierter SMTP-Verarbeitungscode für Virenscans und Haftungsausschlüsse, dass sich Nachrichten in dieser Warteschlange ansammeln.

Weitere Informationen zum Ändern von Protokolleinstellungen finden Sie unter "Ändern von Protokollierungseinstellungen für MSExchangeTransport" im Kapitel "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Microsoft Knowledge Base-Artikel 821877 mit einer Beschreibung der Felder auf den Eigenschaftsregisterkarten für die SMTP- und X.400-Warteschlange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Warteschlange "Nachrichten mit ausstehender Übertragung" hat den Status "Wiederholen"
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) ExchangeLink ab, um den Wert des Schlüssels StateRetry für die SMTP-Warteschlange (Simple Mail Transfer Protocol) Nachrichten mit ausstehender Übertragung zu bestimmen.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Schlüssels StateRetry für die Warteschlange Nachrichten mit ausstehender Übertragung auf einem Server mit Exchange auf True festgelegt ist, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Wenn eine Warteschlange den Status Wiederholen hat, bedeutet dies, dass mindestens ein Fehler bei den vorherigen Versuchen der Verarbeitung der Nachrichten in der Warteschlange aufgetreten ist. Mit dem Befehl Verbindung erzwingen kann der Status von Warteschlangen von Wiederholen und Geplant in Aktiv geändert werden. Dadurch funktioniert die Warteschlange so, als ob das Wiederholungsintervall abgelaufen oder der geplante Zeitpunkt erreicht sei. Diese Methode funktioniert jedoch nicht immer.

Hinweis:
Die Eigenschaften einer Warteschlange können einen bestimmten Grund angeben, warum eine Warteschlange den Status Wiederholen hat.

Die Warteschlange Nachrichten mit ausstehender Übertragung enthält Nachrichten, die vom SMTP-Dienst bestätigt und angenommen wurden.

Nachrichten in dieser Warteschlange wurden noch nicht verarbeitet. Wenn sich Nachrichten ständig anhäufen, liegt ggf. ein Leistungsproblem vor. Gelegentliche Spitzen bei der CPU-Leistung können dafür sorgen, dass Nachrichten zeitweise in dieser Warteschlange vorhanden sind. Regelmäßig bewirken Probleme wie Ereignissenken, z. b. benutzerdefinierter SMTP-Verarbeitungscode für Virenscans und Haftungsausschlüsse, dass sich Nachrichten in dieser Warteschlange ansammeln.

Weitere Informationen zum Ändern von Protokolleinstellungen finden Sie unter "Ändern von Protokollierungseinstellungen für MSExchangeTransport" im Kapitel "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Microsoft Knowledge Base-Artikel 821877 mit einer Beschreibung der Felder auf den Eigenschaftsregisterkarten für die SMTP- und X.400-Warteschlange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Warteschlange "Nachrichten warten auf Routing" hat den Status "Fixiert"
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) ExchangeLink ab, um den Wert des Schlüssels StateFrozen für die SMTP-Warteschlange (Simple Mail Transfer Protocol) Nachrichten warten auf Routing zu bestimmen.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Schlüssels StateFrozen für die Warteschlange Nachrichten warten auf Verzeichnissuche auf einem Server mit Exchange auf True festgelegt ist, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Eine fixierte Warteschlange bedeutet, dass die Transportsitzungen für diese Warteschlange beendet wurden. Eine fixierte Warteschlange verhindert ausgehende Nachrichten, obgleich neue Nachrichten hinzugefügt werden können. Sie können den Status einer Verbindung über das Kontextmenü für jede Verbindungswarteschlange manuell ändern. Wenn Sie mit dem Befehl Verbindung erzwingen einen Warteschlangenstatus in Aktiv ändern, aktivieren Sie sofort eine Verbindung, über welche die Nachrichten in dieser Warteschlange gesendet werden.

Die Warteschlange Nachrichten warten auf Routing speichert Nachrichten, bis deren nächster Zielserver bestimmt wurde, und verschiebt diese anschließend in die entsprechenden Verbindungswarteschlangen.

Nachrichten sammeln sich bei Exchange Server-Routingproblemen in dieser Warteschlange an. Beim Nachrichtenrouting ist es ggf. zu einem Stau gekommen.

Erhöhen Sie zum Beheben dieses Fehlers den Protokolliergrad für die Diagnose der Dienste MSExchangeDSAccess und MSExchangeTransport, um Informationen zu Komponenten des Kategorisierungsmoduls zu erfassen.

Weitere Informationen zum Ändern von Protokolleinstellungen finden Sie unter "Ändern von Protokollierungseinstellungen für MSExchangeTransport" im Kapitel "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Microsoft Knowledge Base-Artikel 821877 mit einer Beschreibung der Felder auf den Eigenschaftsregisterkarten für die SMTP- und X.400-Warteschlange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Warteschlange "Nachrichten warten auf Routing" hat den Status "Wiederholen"
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) ExchangeLink ab, um den Wert des Schlüssels StateRetry für die SMTP-Warteschlange (Simple Mail Transfer Protocol) Nachrichten warten auf Routing zu bestimmen.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Schlüssels StateRetry für die Warteschlange Nachrichten warten auf Verzeichnissuche auf einem Server mit Exchange auf True festgelegt ist, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Wenn eine Warteschlange den Status Wiederholen hat, bedeutet dies, dass mindestens ein Fehler bei den vorherigen Versuchen der Verarbeitung der Nachrichten in der Warteschlange aufgetreten ist. Mit dem Befehl Verbindung erzwingen kann der Status von Warteschlangen von Wiederholen und Geplant in Aktiv geändert werden. Dadurch funktioniert die Warteschlange so, als ob das Wiederholungsintervall abgelaufen oder der geplante Zeitpunkt erreicht sei. Diese Methode funktioniert jedoch nicht immer.

Hinweis:
Die Eigenschaften einer Warteschlange können einen bestimmten Grund angeben, warum eine Warteschlange den Status Wiederholen hat.

Die Warteschlange Nachrichten warten auf Routing speichert Nachrichten, bis deren nächster Zielserver bestimmt wurde, und verschiebt diese anschließend in die entsprechenden Verbindungswarteschlangen.

Nachrichten sammeln sich bei Exchange Server-Routingproblemen in dieser Warteschlange an. Beim Nachrichtenrouting ist es ggf. zu einem Stau gekommen.

Erhöhen Sie zum Beheben dieses Fehlers den Protokolliergrad für die Diagnose des Diensts MSExchangeTransport, um Informationen zu Komponenten des Kategorisierungsmoduls zu erfassen. Deaktivieren Sie unnötige Connectoreinschränkungen, da diese eine wesentliche Verschlechterung der Serverleistung verursachen können. Aufgrund bestimmter Vorgaben muss der Registrierungsschlüssel CheckConnectorRestrictions ggf. aktiviert sein.

Weitere Informationen zum Ändern von Protokolleinstellungen finden Sie unter "Ändern von Protokollierungseinstellungen für MSExchangeTransport" im Kapitel "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Microsoft Knowledge Base-Artikel 821877 mit einer Beschreibung der Felder auf den Eigenschaftsregisterkarten für die SMTP- und X.400-Warteschlange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Fehlende Transportereignissenken-Bindung
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-01-11

Microsoft® Exchange Server Analyzer sendet eine Abfrage an die Microsoft Internet Information Server-Metabase (IIS), um die Liste der SMTP-Transportereignissenken-Bindungen (Simple Mail Transport Protocol) aufzulisten. Exchange Server Analyzer versucht, auf Grundlage der folgenden in Exchange Server Analyzer vorausgefu¨llten Liste mehrere Standardereignisbindungen aufzufinden:

  • Benutzerdefinierte Exchange-DSN-Senke

  • X-LSA-Senke des Handlers für eingehende EHLO-Befehle

  • X-SLA-Senke des Handlers für EHLO-Antworten

  • Senke des Handlers für eingehende EDO-Befehle

  • Exchange-Kategorisierungsmodul

  • Exchange LoadBalancer

  • Exchange-NTFS-Informationsspeichertreiber

  • Exchange-Router

  • Senke für die Exchange-SMTP-Protokollierung

  • Senke für Exchange-SMTP-Protokollsicherheit-EHLO

  • Senke für Exchange-SMTP-Protokollsicherheit-EXPS

  • Aux-Senke für Exchange-SMTP-Protokollsicherheit-EXPS

  • Senke für Exchange-SMTP-Protokollsicherheit-EXPS-EOD

  • Senke für Exchange-SMTP-Protokollsicherheitsmail

  • Senke für Exchange-SMTP-XEXCH50-Before-Data

  • Senke für Exchange-SMTP-XEXCH50-EHLO-Antworten

  • Senke für Exchange-SMTP-XEXCH50-EOD

  • Senke für eingehendes Exchange-SMTP-XEXCH50-EHLO

  • Senke für eingehendes Exchange-SMTP-XEXCH50-MAIL

  • Senke für eingehendes Exchange-SMTP-XEXCH50-RCPT

  • XEXCH50-Senke für eingehendes Exchange-SMTP-XEXCH50

  • Pro-Empfänger-Ereignissenke für Exchange-SMTP-XEXCH50

  • Senke für Exchange-SMTP-XEXCH50-RCPT-Antworten

  • Senke für Exchange-SMTP-XEXCH50-Antworten

  • Exchange-Informationsspeichertreiber

  • Exchange Transport AntiVirus-API

  • Senke für Exchange Transport-XEXCH50-Übermittlung

  • TURF-Senke des Handlers für eingehende MAIL-Befehle

  • Mobiles Kategorisierungsmodul

  • Senke für MSExchange-Inhaltsfilter-EOD

  • MsgTrackLog-Senke

  • Senke des Handlers für eingehende RCPT-Befehle

  • SMTP Eventlog-Senke

  • UmConvSink

  • Senke des Handlers für eingehende X-LSA-Befehle

  • Senke des Handlers für X-LSA-Antworten

  • X-LSA-Senke

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere Standardereignisbindungen fehlen, generiert Exchange Server Analyzer eine Warnung.

Ein SMTP-Transportereignis tritt ein, wenn Nachrichtendaten an den SMTP-Dienst bzw. von diesem übertragen werden. Alle Nachrichten durchlaufen Ereignisse. Hierzu gehören ein- und ausgehende X.400- und RPC-Nachrichten. Ein gängiges Beispiel für ein eingehendes Transportereignis ist der Eingang einer Nachricht beim SMTP-Dienst über das Netzwerk oder in das SMTP-Pickup-Verzeichnis. Sobald dieses Ereignis eintritt, benachrichtigt eine Quelle dieses Ereignisses die Transportereignissenken, von denen jede in Abhängigkeit vom Dateninhalt der Nachricht auf eine bestimmte Art reagieren kann. Das System führt nach der Übergabe der Nachrichtendaten an die Senke mit diesen Daten erst weitere Aktionen aus, nachdem die Senke die Verarbeitung abgeschlossen und die Nachricht zurückgegeben hat. Die Senke verfügt bei der Ausführung der Aktion über die alleinige Kontrolle über die Nachrichtendaten und deren Zustand.

Fehlende Transportereignissenken-Bindungen ko¨nnen zu Problemen bei der Mailu¨bermittlung fu¨hren. Wenn Exchange Server Anzeichen von Problemen bei der Mailu¨bermittlung zeigt, wie zum Beispiel das Einstellen von Nachrichten in Warteschlangen, registrieren Sie die Transportereignissenken erneut.

So registrieren Sie die Transportereignissenken erneut

  1. Öffnen Sie in Microsoft Exchange Server ein Eingabeaufforderungsfenster, und wechseln Sie in den Ordner \Programme\Exchsrvr\Bin.

  2. Geben Sie folgende Befehle ein, um die Transportereignissenken erneut zu registrieren:

    regsvr32 /i exps.dll

    regsvr32 /i miscat.dll

    regsvr32 /i onsubmit.dll

    regsvr32 /i peexch50.dll

    regsvr32 /i phatcat.dll

    regsvr32 /i protolog.dll

    regsvr32 /i reapi.dll

    regsvr32 /i regsinks.dll

    regsvr32 /i tranmsg.dll

    regsvr32 /i turflist.dll

    regsvr32 /i xlsasink.dll

    regsvr32 /i msgfilter.dll

  3. Fu¨hren Sie Exchange Server Analyzer erneut aus, um zu u¨berpru¨fen, dass die Warnungen nicht mehr angezeigt werden. Wenn weiterhin Ereignissenkenwarnungen angezeigt werden und Probleme bei der Mailu¨bermittlung auftreten, wenden Sie sich an den Microsoft-Produktsupport (PSS).

Weitere Informationen u¨ber Transportereignissenken-Bindungen finden Sie in den folgenden Ressourcen zu Exchange Server:

  • Microsoft Knowledge Base-Artikel 258224, „XCON: senkt das Aufza¨hlen des registrierten Transportereignisses" (http://go.microsoft.com/fwlink/?linkID=3052&kbid=258224)

  • „SMTP Service Design" in Technisches Referenzhandbuch fu¨r Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=58876)


Das Attribut „msExchAlternateServer" wurde festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert des Attributs msExchAlternateServer für die einzelnen virtuellen SMTP-Server zu ermitteln. In der Standardeinstellung ist der Wert des Attributs msExchAlternateServer nicht festgelegt. Wenn Exchange Server Analyzer feststellt, dass das Attribut msExchAlternateServer festgelegt wurde, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Im folgenden Beispiel-Szenario sollten Sie das Attribut msExchAlternateServer festlegen. Der SMTP-Adressraum, z. B. eine SMTP-Domäne, wird von Exchange Server 2003 und einem anderen E-Mail-System gemeinsam verwendet. In diesem Szenario akzeptiert Exchange Server 2003 über das Internet eingehende Nachrichten. Exchange Server 2003 sucht nach einem entsprechenden Empfänger in der Exchange Server-Organisation. Wenn kein entsprechender Empfänger gefunden wurde, leitet Exchange Server die Nachricht zu einem fremden Mailsystem weiter. Das empfangende System sucht möglicherweise auch nach einer Übereinstimmung. Wenn keine Übereinstimmung gefunden wird, wird die Nachricht möglicherweise an ein drittes E-Mail-System weitergeleitet. Das letzte System in der Kette muss über eine Autorisierung für die Domäne verfügen. Das letzte empfangende System muss nach einem entsprechenden Empfänger suchen. Wenn kein entsprechender Empfänger gefunden wurde, muss für die Nachricht ein Unzustellbarkeitsbericht generiert werden. Wenn ein empfangendes System nach einer Übereinstimmung sucht und dann die Nachricht zum ursprünglichen System zurückleitet, weil keine Übereinstimmung gefunden wurde, wird die Nachricht in eine Schleife weitergeleitet.

So ändern Sie das Attribut „msExchAlternateServer"

  1. Erweitern Sie im Exchange-System-Manager die Option Server, und erweitern Sie nacheinander <Servername>, Protokolle und SMTP.

  2. Klicken Sie mit der rechten Maustaste auf den virtuellen SMTP-Server, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie unter Eigenschaften des virtuellen SMTP-Servers auf die Registerkarte Nachrichten.

  4. Geben Sie im Feld Alle E-Mails mit nicht ausgewerteten Empfängern weiterleiten an Host den vollqualifizierten Domänennamen des Servers an, der die nicht ausgewerteten Nachrichten empfängt. Sie können auch die IP-Adresse des Servers in eckigen Klammern ([ ]) eingeben.

  5. Klicken Sie auf OK.

Weitere Informationen zum gemeinsamen Nutzen von SMTP-Adressräumen finden Sie im Microsoft Knowledge Base-Artikel 321721, „XCON: Gemeinsame Nutzung von SMTP-Adressräumen in Exchange 2000" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321721.

Weitere Informationen zu Bereitstellungsszenarios für Internetverbindungen finden Sie im entsprechenden Kapitel im Transport- und Routing-Handbuch für Exchange Server 2003 unter http://www.microsoft.com/germany/technet/datenbank/articles/600421.mspx.


Der Wert „msExchMaxIncomingConnections" wurde von seinem Standardwert in einen anderen Wert geändert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den konfigurierten Wert des Attributs msExchSmtpMaxIncomingConnections für die jeweiligen virtuellen SMTP-Server zu ermitteln.

Auf einem Exchange Server-Computer, der nicht Teil einer Installation von Microsoft® Windows® Small Business Server 2003 ist, ist das Attribut msExchSmtpMaxIncomingConnections in der Standardeinstellung für eine unbegrenzte Anzahl von Verbindungen mit dem Standardwert 2000000000 konfiguriert. Auf einem Exchange Server-Computer, der Teil einer Installation von Windows Small Business Server 2003 ist, beträgt der Standardwert für die maximale Anzahl eingehender Verbindungen 500.

Microsoft Exchange Server Analyzer fragt außerdem die WMI-Klasse (Windows Management Instrumentation) Win32_OperatingSystem ab, um den Wert für den Schlüssel OSProductSuite zu bestimmen. Der Wert dieses Schlüssels entspricht einer bestimmten Version eines Windows Server-Betriebssystems.

Wenn Exchange Server Analyzer feststellt, dass das Attribut msExchSmtpMaxIncomingConnections auf einem Exchange Server-Computer, der nicht Teil einer Installation von Windows Small Business Server 2003 ist, nicht den Wert 2000000000 aufweist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht. Der für dieses Attribut verwendete Wert von 2000000000 ist sowohl eine theoretische Grenze als auch die auf die Elemente der Benutzeroberfläche auferlegte Grenze, mit denen Sie diesen Wert konfigurieren können.

Wenn Exchange Server Analyzer feststellt, dass das Attribut msExchSmtpMaxIncomingConnections auf einem Exchange Server-Computer, der Teil einer Installation von Windows Small Business Server 2003 ist, nicht den Wert 500 aufweist, wird ebenfalls eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Im Hinblick auf die Sicherheit kann das Begrenzen der Anzahl eingehender Verbindungen sinnvoll sein. Die Möglichkeit, eine im Prinzip unbegrenzte Anzahl eingehender SMTP-Verbindungen zu akzeptieren, kann selbst eine Denial-of-Service-Situation herbeiführen. Zu viele gleichzeitige Verbindungen zum virtuellen Server können zur Überlastung des Netzwerks und zu Leistungsverlust führen. Für jede Organisation muss gesondert entschieden werden, welcher Wert für dieses Attribut angemessen ist.

So wird die maximale Anzahl eingehender Nachrichten angezeigt und konfiguriert

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Server, erweitern Sie einen Exchange-Server, erweitern Sie Protokolle, und erweitern Sie dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise Virtueller Standardserver für SMTP), und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf Allgemein:

    • Um die Anzahl der eingehenden Verbindungen zu beschränken, aktivieren Sie das Kontrollkästchen Zahl der Verbindungen beschränken auf, und geben Sie den gewünschten Wert ein.

    • Um die Standardeinstellung einer unbegrenzten Anzahl eingehender Verbindungen wiederherzustellen, müssen Sie das Kontrollkästchen Zahl der Verbindungen beschränken auf deaktivieren.

  5. Klicken Sie auf OK, um die Änderungen zu speichern.

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 266686, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://support.microsoft.com/?kbid=266686)

  • 268163, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" unter http://support.microsoft.com/kb/268163/DE/.


Der Wert für „msExchSmtpMaxHopCount" weicht vom Standardwert ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob der konfigurierte Wert für das Attribut msExchSmtpMaxHopCount vom Standardwert abweicht.

In Exchange 2000 Server ist das Attribut msExchSmtpMaxHopCount mit einem Standardwert von 15 konfiguriert. In Exchange Server 2003 hat dieses Attribut einen Standardwert von 30. Wenn Exchange Server Analyzer feststellt, dass dieses Attribut nicht länger auf den Standardwert festgelegt ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Eine Nachricht kann über viele verschiedene SMTP-Server geroutet werden (jeweils als Hop bezeichnet), bevor die Nachricht ihr endgültiges Ziel erreicht. Um zu verhindern, dass eine Nachricht wiederholt fehlerhaft geroutet wird (diese Bedingung ist auch als Nachrichtenschleife bekannt), kann ein Administrator die Maximalanzahl erlaubter Hops steuern. Das Attribut mxExchSmtpMaxHopCount gibt die Anzahl der SMTP-Server an, die eine Nachricht passieren kann, bevor sie an den Absender als nicht zustellbar zurückgesendet wird.

Sowohl für Exchange 2000 Server als auch für Exchange Server 2003 wird eine Anzahl von 30 virtuellen SMTP-Servern empfohlen.

So berichtigen Sie diesen Fehler

  1. Erweitern Sie im Exchange-System-Manager die Option Server, erweitern Sie einen Exchange-Server, erweitern Sie dann Protokolle, und erweitern Sie anschließend SMTP.

  2. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise Virtueller Standardserver für SMTP), und wählen Sie dann Eigenschaften aus.

  3. Wählen Sie die Registerkarte Übermittlung aus, und klicken Sie auf Erweitert.

  4. Geben Sie im Feld Maximale Anzahl der Hops den gewünschten Wert ein, und klicken Sie auf OK, um die Änderung zu speichern.

  5. Klicken Sie auf OK, um das Dialogfeld Eigenschaften des virtuellen SMTP-Servers zu schließen.

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 266686, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


Der Wert „msExchSmtpMaxMessageSize" weicht von seinem Standardwert 0 ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob der Wert für das Attribut msExchSmtpMaxMessageSize vom Standardwert 0 abweicht. In der Standardeinstellung ist das Attribut msExchSmtpMaxMessageSize für eine unbeschränkte Nachrichtengröße konfiguriert. Wenn Exchange Server Analyzer feststellt, dass dieses Attribut nicht auf den Wert 0 festgelegt ist und Exchange nicht unter Microsoft Windows® Small Business Server 2003 ausgeführt wird, wird eine Warnung angezeigt.

Das Attribut msExchSmtpMaxMessageSize stellt die maximale Größe einzelner SMTP-Nachrichten dar, die gesendet oder empfangen werden können. In Bezug auf die Sicherheit stellt das Beschränken der maximalen Größe der über das Internet gesendeten und empfangenen SMTP-Nachrichten eine optimale Methode dar. Für interne SMTP-Nachrichten (z. B. für zwischen Exchange-Servern innerhalb derselben Organisation übertragene SMTP-Nachrichten) empfiehlt es sich jedoch, den Wert 0 für das Attribut msExchSmtpMaxMessageSize beizubehalten.

Intern verwendet Exchange SMTP-Nachrichten zum Verarbeiten von Aufgaben, z. B. die Replikation Öffentlicher Ordner. Wenn das Attribut msExchSmtpMaxMessageSize mit einer zu niedrigen Grenze konfiguriert ist, können Probleme bei der Replikation Öffentlicher Ordner und andere Fehler beim Übermitteln von Nachrichten innerhalb derselben Organisation auftreten.

Handelt es sich bei dem Exchange-Server um einen Bridgeheadserver, der SMTP-Nachrichten ins und aus dem Internet überträgt, kann diese Warnung ignoriert werden. Wenn der Exchange-Server interne SMTP-Nachrichten bearbeitet, muss der Wert für das Attribut msExchSmtpMaxMessageSize auf die Standardeinstellung 0 zurückgesetzt werden.

Hinweis:
Wenn die Beschränkung für die Nachrichtengröße zu niedrig festgelegt wird, kann die Replikation von Offlineadressbüchern zwischen Exchange Server-Computern verhindert werden. Weitere Informationen zu diesem Problem finden Sie im Microsoft Knowledge Base-Artikel 326154 „XADM: The OAB Does Not Replicate If You Set a Message Size Restriction at the Transport Level„ (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154).

So zeigen Sie die maximale SMTP-Nachrichtengröße an und konfigurieren diese

  1. Erweitern Sie im Exchange-System-Manager die Option Server, erweitern Sie einen Exchange-Server, erweitern Sie dann Protokolle, und erweitern Sie anschließend SMTP.

  2. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise Virtueller Standardserver für SMTP), und wählen Sie dann Eigenschaften aus.

  3. Wählen Sie die Registerkarte Nachrichten aus.

  4. Um den Standardwert 0 wiederherzustellen, deaktivieren Sie das Kontrollkästchen Nachrichtengröße beschränken auf (KB). Sie können das Kontrollkästchen auch aktiviert lassen und einen gewünschten Wert festlegen.

  5. Klicken Sie auf OK, um die Änderungen zu speichern und das Dialogfeld Eigenschaften des virtuellen SMTP-Servers zu schließen.

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 266686, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://support.microsoft.com/?kbid=266686)

  • 268163, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


Der Wert „MsExchSmtpMaxOutboundMsgPerDomain" weicht von seinem Standardwert 20 ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-07-07

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob der konfigurierte Wert des Attributs msExchSmtpMaxOutboundMsgPerDomain vom Standardwert 20 in einen anderen Wert geändert wurde. Das Attribut msExchSmtpMaxOutboundMsgPerDomain ist in der Standardeinstellung für ein Maximum von 20 ausgehenden SMTP-Nachrichten (Simple Mail Transfer Protocol) pro Verbindung konfiguriert. Stellt Exchange Server Analyzer fest, dass dieses Attribut nicht den Wert 20 aufweist, wird eine Meldung angezeigt, dass diese Konfiguration nicht der Standardkonfiguration entspricht.

Das Attribut msExchSmtpMaxOutboundMsgPerDomain stellt die maximale Anzahl der Nachrichten pro Verbindung dar, die von einem virtuellen SMTP-Server auf dem Exchange-Server gesendet werden können. Wenn beispielsweise ein SMTP-Server 35 Nachrichten an microsoft.com senden muss, und das Attribut msExchSmtpMaxOutboundMsgPerDomain auf 20 gesetzt wurde, werden zwei Verbindungen zu den Mailservern hergestellt, die für die Nachrichten an microsoft.com verantwortlich sind. Die erste Verbindung wird mit dem Maximum von 20 Nachrichten bestückt, und eine zweite Verbindung wird hergestellt, die die verbleibenden 15 Nachrichten sendet.

Im Allgemeinen gibt es keine Empfehlung für die beste Vorgehensweise zum Bestimmen des richtigen Werts für dieses Attribut. Jede Organisation muss für sich selbst den entsprechenden festzulegenden Wert ermitteln.

So legen Sie die Maximalanzahl von Nachrichten pro Verbindung.

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Server, erweitern Sie einen Exchange-Server, erweitern Sie Protokolle, und erweitern Sie dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise Virtueller Standardserver für SMTP), und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf Nachrichten.

  5. Im Feld Anzahl der Verbindungen beschränken auf ist der aktuelle Wert für das Attribut msExchSmtpMaxOutboundMsgPerDomain aufgeführt. Ändern Sie dieses Feld nach Bedarf, und klicken Sie dann auf OK, um die Änderungen zu speichern. Akzeptierte Werte für dieses Feld sind alle ganzen Zahlen zwischen 1 und 1999999999.

  6. Klicken Sie auf OK, um das Dialogfeld Eigenschaften des virtuellen SMTP-Servers zu schließen.

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 266686, "XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163, "XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


Der Wert „MsExchSmtpMaxOutgoingConnections" weicht von seinem Standardwert 1000 ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um festzustellen, ob der konfigurierte Wert für das Attribut msExchSmtpMaxOutgoingConnections geändert wurde und vom Standardwert 1000 abweicht. Als Standard ist das Attribut MsExchSmtpMaxOutgoingConnections für ein Maximum von 1000 ausgehenden SMTP-(Simple Mail Transfer Protocol)-Verbindungen konfiguriert. Stellt Exchange Server Analyzer fest, dass dieses Attribut nicht den Wert 1000 aufweist, wird eine Meldung angezeigt, dass diese Konfiguration nicht der Standardkonfiguration entspricht.

Das Attribut msExchSmtpMaxOutgoingConnections stellt die maximale Anzahl der ausgehenden Verbindungen dar, die von einem virtuellen SMTP-Server auf dem Exchange-Server hergestellt werden können.

Im Allgemeinen gibt es keine Empfehlung für die beste Vorgehensweise zum Bestimmen des richtigen Werts für dieses Attribut. Jede Organisation muss für sich selbst den entsprechenden festzulegenden Wert ermitteln. Das bedeutet, dass der Standardwert für einige Organisationen zu hoch sein kann. Sie können die tatsächliche Anzahl der ausgehenden SMTP-Verbindungen überwachen und bestimmen, die von einem virtuellen Exchange-SMTP-Server hergestellt werden, indem auf dem Exchange-Server die folgenden Leistungsindikatoren gesammelt werden:

Objekt | Leistungsindikator | Erklärung
SMTP-Server | Ausgehende Verbindungen Aktuell | Die Anzahl aktuell bestehender ausgehender Verbindungen.
SMTP-Server | Ausgehende Verbindungen Gesamt | Die Gesamtzahl der Versuche, ausgehende Verbindungen herzustellen.

Ziehen Sie in Erwägung, den Wert für dieses Attribut zu reduzieren, falls Ihre Organisation keinen starken Gebrauch von ausgehendem SMTP auf diesem Exchange-Server macht. Durch die Reduzierung der Gesamtzahl gleichzeitig ausgehender SMTP-Verbindungen, die jederzeit vorgenommen werden kann, können potentiell jegliche Spitzen der SMTP-Server-Aktivität reduziert werden, die durch eine falsche Konfiguration, einen unbeabsichtigten Fehler, einen unberechtigten Zugriff, eine Meldungsschleife oder anderen Fehler, einen Virusbefall oder eine Sicherheitsverletzung verursacht werden können.

So lässt sich die ausgehende Verbindungsbeschränkung anzeigen und konfigurieren

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie nacheinander Server, einen Exchange-Server, Protokolle und dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise Virtueller Standardserver für SMTP), und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf Übermittlung, und klicken Sie dann auf Ausgehende Verbindungen.

  5. Im Feld Anzahl der Verbindungen beschränken auf ist der aktuelle Wert für das Attribut msExchSmtpMaxOutgoingConnections aufgeführt. Ändern Sie dieses Feld nach Bedarf, und klicken Sie dann auf OK, um die Änderungen zu speichern. Akzeptierte Werte für dieses Feld sind alle ganzen Zahlen zwischen 1 und 1999999999.

  6. Klicken Sie auf OK, um das Dialogfeld Eigenschaften des virtuellen SMTP-Servers zu schließen.

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 266686, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


Der Wert „msExchSmtpMaxOutgoingConnectionsPerDomain" wurde vom Standardwert 100 in einen anderen Wert geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob der eingestellte Wert für das Attribut msExchSmtpMaxOutgoingConnectionsPerDomain vom Standardwert abweicht. Das Attribut msExchSmtpMaxOutgoingConnectionsPerDomain stellt die maximale Anzahl der ausgehenden Verbindungen pro Domäne dar, die von einem virtuellen SMTP-Server auf dem Microsoft Exchange-Server hergestellt werden können. In der Standardeinstellung eines Exchange Server-Computers, der nicht Teil einer Installation von Microsoft Windows® Small Business Server 2003 ist, ist der Wert des Attributs msExchSmtpMaxOutgoingConnectionsPerDomain mit dem Standardwert 100 konfiguriert. Der Standardwert für die maximale Anzahl der ausgehenden Verbindungen pro Domäne auf einem Exchange Server-Computer, der Teil einer Installation von Windows Small Business Server 2003 ist, beträgt 10.

Exchange Server Analyzer fragt außerdem die WMI-Klasse (Windows Management Instrumentation) Win32_OperatingSystem ab, um den Wert für den Schlüssel OSProductSuite zu bestimmen. Der Wert dieses Schlüssels entspricht einer bestimmten Version eines Windows Server-Betriebssystems.

Wenn Exchange Server Analyzer feststellt, dass das Attribut msExchSmtpMaxOutgoingConnectionsPerDomain auf einem Exchange Server-Computer, der nicht Teil einer Installation von Windows Small Business Server 2003 ist, nicht den Wert 500 aufweist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Wenn Exchange Server Analyzer feststellt, dass das Attribut msExchSmtpMaxOutgoingConnectionsPerDomain auf einem Exchange Server-Computer, der Teil einer Installation von Windows Small Business Server 2003 ist, nicht den Wert 10 aufweist, wird ebenfalls eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Im Allgemeinen gibt es keine Empfehlung für die beste Vorgehensweise zum Bestimmen des richtigen Werts für dieses Attribut. Jede Organisation muss für sich selbst den entsprechenden festzulegenden Wert ermitteln. Das bedeutet, dass der Standardwert für einige Organisationen zu hoch sein kann. Sie können die tatsächliche Anzahl der ausgehenden SMTP-Verbindungen überwachen und bestimmen, die von einem virtuellen Exchange-SMTP-Server hergestellt werden, indem auf dem Exchange-Server die folgenden Leistungsindikatoren gesammelt werden:

Objekt | Leistungsindikator | Erklärung
SMTP-Server | Ausgehende Verbindungen Aktuell | Die Anzahl aktuell bestehender ausgehender Verbindungen.
SMTP-Server | Ausgehende Verbindungen Gesamt | Die Gesamtzahl der Versuche, ausgehende Verbindungen herzustellen.

Ziehen Sie in Erwägung, den Wert für dieses Attribut zu reduzieren, falls Ihre Organisation keinen starken Gebrauch von ausgehenden SMTP auf diesem Exchange-Server macht. Durch die Reduzierung der Gesamtzahl gleichzeitig ausgehender SMTP-Verbindungen, die jederzeit vorgenommen werden kann, können potentiell jegliche Spitzen der SMTP-Server-Aktivität reduziert werden, die durch eine falsche Konfiguration, einen unbeabsichtigten Fehler, einen unberechtigten Zugriff, eine Meldungsschleife oder anderen Fehler, einen Virusbefall oder eine Sicherheitsverletzung verursacht werden kann.

So können Sie die Höchstzahl ausgehender Verbindungen pro Domäne anzeigen lassen und konfigurieren

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Server, erweitern Sie einen Exchange-Server, erweitern Sie Protokolle, und erweitern Sie dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise Virtueller Standardserver für SMTP), und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf Übermittlung, und klicken Sie dann auf Ausgehende Verbindungen.

  5. Der aktuelle Wert für das Attribut MsExchSmtpMaxOutgoingConnections ist im Feld Verbindungsanzahl pro Domäne beschränken auf aufgeführt. Ändern Sie den Wert im Feld nach Bedarf, und klicken Sie dann auf OK, um die Änderungen zu speichern. Akzeptierte Werte für dieses Feld sind alle ganzen Zahlen zwischen 1 und 1999999999.

  6. Klicken Sie auf OK, um das Dialogfeld Eigenschaften des virtuellen SMTP-Servers zu schließen.

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 266686, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


Der Wert „msExchSmtpMaxRecipients" wurde von seinem Standardwert „64000" in einen anderen Wert geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob der konfigurierte Wert für das Attribut msExchSmtpMaxRecipients vom Standardwert 64000 abweicht. In der Standardeinstellung ist das Attribut msExchSmtpMaxRecipients für 64000 Empfänger konfiguriert. Wenn Microsoft Exchange Server Analyzer feststellt, dass dieses Attribut nicht den Wert 64000 aufweist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Aus Gründen der Sicherheit hat es sich bewährt, die maximale Anzahl der Empfänger für jede Nachricht zu beschränken. Jede Organisation sollte für sich einen geeigneten Wert festlegen. Wenn kein Grund vorliegt, diesen Wert anders zu konfigurieren, wird empfohlen, die Festlegung des Attributs msExchSmtpMaxRecipients auf den Standardwert 64000 beizubehalten.

So wird die maximale Anzahl der Empfänger angezeigt und konfiguriert

  1. Erweitern Sie im Exchange-System-Manager die Option Server, erweitern Sie einen Exchange-Server, erweitern Sie dann Protokolle, und erweitern Sie anschließend SMTP.

  2. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise den virtuellen Standardserver für SMTP), und klicken Sie dann auf Eigenschaften .

  3. Wählen Sie die Registerkarte Nachrichten aus.

  4. Um die Standardeinstellung 64000 wiederherzustellen, muss das Kontrollkästchen Zahl d. Nachrichten pro Empfänger beschränken auf: aktiviert sein. Geben Sie den Wert 64000 ein. Alternativ können Sie dieses Feld mit einem beliebigen Wert konfigurieren oder das Kontrollkästchen deaktivieren, um eine unbegrenzte Anzahl von Empfängern zuzulassen.

  5. Klicken Sie auf OK, um die Änderungen zu speichern und das Dialogfeld Eigenschaften des virtuellen SMTP-Servers zu schließen.

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 266686, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://support.microsoft.com/?kbid=266686)

  • 268163, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


Der Wert „msExchSmtpMaxSessionSize" wurde von seinem Standardwert 0 in einen anderen Wert geändert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um festzustellen, ob der konfigurierte Wert für das Attribut msExchSmtpMaxSessionSize geändert wurde und vom Standardwert 0 abweicht. In der Standardeinstellung ist das Attribut msExchSmtpMaxSessionSize für eine unbegrenzte Nachrichtengröße konfiguriert. Wenn Exchange Server Analyzer feststellt, dass das Attribut nicht den Wert 0 aufweist, wird eine Warnmeldung angezeigt.

Das Attribut msExchSmtpMaxSessionSize gibt die maximale Datenmenge in Kilobyte (KB) an, die in einer SMTP-Sitzung angenommen wird. In Bezug auf die Sicherheit stellt das Beschränken der Größe von SMTP-Sitzungen für über das Internet gesendete und empfangene Nachrichten eine optimale Methode dar. Für interne SMTP-Sitzungen (z. B. zwischen Exchange-Servern in derselben Organisation) empfiehlt es sich jedoch, den Wert 0 für das Attribut msExchSmtpMaxSessionSize beizubehalten.

Intern verwendet Exchange SMTP-Nachrichten zum Verarbeiten von Aufgaben, z. B. die Replikation Öffentlicher Ordner. Wenn das Attribut msExchSmtpMaxSessionSize mit einer zu niedrigen Grenze konfiguriert ist, können Probleme bei der Replikation Öffentlicher Ordner und andere Fehler beim Übermitteln von Nachrichten innerhalb derselben Organisation auftreten.

Handelt es sich bei dem Exchange-Server um einen Bridgeheadserver, der SMTP-Nachrichten in und aus dem Internet überträgt, kann diese Warnung ignoriert werden. Wenn der Exchange-Server interne SMTP-Nachrichten bearbeitet, muss der Wert für das Attribut msExchSmtpMaxSessionSize auf die Standardeinstellung 0 zurückgesetzt werden.

So zeigen Sie die maximale SMTP-Sitzungsgröße an und konfigurieren diese

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Server, erweitern Sie einen Exchange-Server, erweitern Sie Protokolle, und erweitern Sie dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise Virtueller Standardserver für SMTP), und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf Nachrichten.

  5. Um den Standardwert auf 0 zurückzusetzen, deaktivieren Sie das Kontrollkästchen Sitzungsgröße beschränken auf (KB). Sie können das Kontrollkästchen auch aktiviert lassen und einen gewünschten Wert festlegen.

  6. Klicken Sie auf OK, um die Änderungen zu speichern und das Dialogfeld Eigenschaften des virtuellen SMTP-Servers zu schließen.

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 266686, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" ( http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686 ).

  • 268163, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


Der Wert „msExchSmtpOutgoingPort" weicht vom Standardwert 25 ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um festzustellen, ob der konfigurierte Wert für das Attribut msExchSmtpOutgoingPort geändert wurde und vom Standardwert 25 abweicht. In der Standardeinstellung ist das Attribut msExchSmtpOutgoingPort für TCP-Port 25 konfiguriert. Stellt Exchange Server Analyzer fest, dass das Attribut für einen abweichenden Port konfiguriert wurde, wird eine Warnung angezeigt.

SMTP-Server sind in der Standardeinstellung so konfiguriert, dass sie über TCP-Port 25 eingehende Verbindungen akzeptieren. Der Parameter msExchSmtpOutgoingPort stellt den TCP-Port dar, über den dieser Exchange Server auf allen SMTP-Remoteservern versucht, eine Verbindung herzustellen. Eine Verbindung kann nur dann hergestellt werden, wenn die Remote-SMTP-Server für die Überwachung dieses Port konfiguriert wurden.

Verwenden Sie TCP-Port 25 nur dann nicht für die SMTP-Kommunikation, wenn Sie Ihre interne Messagingstruktur bereits vollständig auf die Verwendung von nicht standardisierten Ports umgestellt haben.

So zeigen Sie den SMTP-Standardport für ausgehende Nachrichten an oder ändern ihn

  1. Erweitern Sie im Exchange-System-Manager die Option Server, erweitern Sie einen Exchange-Server, erweitern Sie dann Protokolle, und erweitern Sie anschließend SMTP.

  2. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise Virtueller Standardserver für SMTP), und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf Übermittlung, und klicken Sie dann auf Ausgehende Verbindungen.

  4. Geben Sie im Feld für den TCP-Port den Port ein, den Sie für ausgehende Verbindungen verwenden möchten. Jeder SMTP-Remoteserver, mit dem Sie kommunizieren möchten, muss so konfiguriert sein, dass der Verbindungsaufbau über den angegebenen Port zugelassen wird. In den meisten Fällen ist das Ändern dieses Werts nicht erforderlich.

  5. Ändern Sie dieses Feld nach Bedarf, und klicken Sie dann auf OK, um die Änderungen zu speichern.

  6. Klicken Sie auf OK, um das Dialogfeld Eigenschaften des virtuellen SMTP-Servers zu schließen.

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 266686, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


Der Wert „msExchSmtpRelayForAuth" weicht von seinem Standardwert „True" ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob der festgelegte Wert für das Attribut msExchSmtpRelayForAuth vom Standardwert abweicht. Als Standardwert ist das Attribut msExchSmtpRelayForAuth mit dem Wert True konfiguriert. Wenn Exchange Server Analyzer feststellt, dass das Attribut msExchSmtpRelayForAuth nicht den Wert True aufweist, wird eine Meldung wegen einer nicht dem Standard entsprechenden Konfiguration angezeigt.

Wenn dieser Wert auf True festgelegt ist, könnnen nur authentifizierte SMTP-Verbindungen ein Relay für SMTP-Nachrichten über diesen virtuellen SMTP-Server durchführen. Wenn diese Einstellung auf False geändert wurde, weist dies darauf hin, dass auf dem virtuellen SMTP-Server in den Relay-Einstellungen im Dialogfeld Eigenschaften das Kontrollkästchen Jedem Computer, der erfolgreich authentifiziert ist, unabhängig von der Liste oben das Relay erlauben nicht markiert ist.

Relay ist die Aktion einer eingehenden Verbindung zum SMTP-Server, mit dessen Hilfe E-Mail-Nachrichten an externe Domänen gesendet werden. Das geschieht bei Junk-E-Mail-Nachrichten (Unsolicited Commercial E-Mail (UCE), unerwünschte kommerzielle E-Mail-Nachrichten), wenn eine einzelne E-Mail-Nachricht an den SMTP-Server mit mehreren Empfängern in Domänen außerhalb Ihres Unternehmens gesendet wird. Da die Standardeinstellung für SMTP-Server auf anonyme Authentifizierung festgelegt ist, akeptiert das System, das an das Verbreiten von UCEs gewöhnt ist, die eingehenden Nachrichten als typisch.

Nachdem die Nachricht akzeptiert ist, erkennt der SMTP-Server, dass die Nachrichtenempfänger zu externen Domänen gehören, und dann übermittelt der SMTP-Server die Nachrichten. Nichtautorisierte Benutzer, die UCEs senden, können eine eingehende Nachricht an den SMTP-Server senden und diese wird dann an Tausende Empfänger weiter übermittelt. Dadurch verlangsamt sich die Reaktionszeit des Exchange Server-Computers, es entstehen Warteschlangen, und die Empfänger reagieren verärgert, wenn sie die Nachrichten in ihrem Posteingang vorfinden.

Die optimale Methode zur Steuerung des Relays besteht darin, anderen Hosts die Berechtigungen zum Relay zu verweigern. Das Relay ist jedoch u. U. erforderlich, z. B. bei POP3-Clients (Post Office Protocol) und IMAP4-Clients (Internet Message Access Protocol), die für die Nachrichtenübermittlung SMTP verwenden und berechtigte Gründe für das Senden von E-Mail-Nachrichten an externe Domänen besitzen. Sie können dieses Problem umgehen, indem Sie einen zweiten virtuellen SMTP-Server erstellen, der zum Empfangen von E-Mail-Nachrichten von POP3- und IMAP4-Clients dient. Virtuelle SMTP-Server können die Authentifizierung in Kombination mit der SSL-Verschlüsselung (Secure Sockets Layer) verwenden und können so konfiguriert werden, dass sie das Relay für authentifizierte Clients aktivieren. Weitere Informationen zum Implementieren dieser Konfiguration finden Sie im Microsoft Knowledge Base-Artikel 319267 „HOW TO: Secure Simple Message Transfer Protocol Client Message Delivery in Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319267).

So können Sie den Wert von msExchSmtpRelayForAuth im System-Manager anzeigen oder ändern

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Server, erweitern Sie einen Exchange-Server, erweitern Sie Protokolle, und erweitern Sie dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise Virtueller Standardserver für SMTP), und klicken Sie dann auf Eigenschaften.

  4. Wählen Sie die Registerkarte Zugriff aus, und klicken Sie dann auf Relay.

  5. Aktivieren Sie das Kontrollkästchen Jedem Computer, der erfolgreich authentifiziert ist, unabhängig von der Liste oben das Relay erlauben, oder deaktivieren Sie es.

  6. Klicken Sie auf OK, um die Änderungen zu speichern.

Wenn das Kontrollkästchen aktiviert ist, muss das Attribut msExchSmtpRelayForAuth auf True festgelegt werden. Wenn das Kontrollkästchen nicht aktiviert ist, muss das Attribut msExchSmtpRelayForAuth auf False festgelegt werden.

Weitere Informationen dazu, welche Konten ein Relay von Nachrichten durchführen können und zur Steuerung dieser Konten, finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 818778, „Users Without Permissions to Relay Messages Can Still Send Messages Through the SMTP Virtual Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818778)

  • 310380, „SO WIRD'S GEMACHT: Verhindern der Weiterleitung von E-Mail-Nachrichten mit Exchange 2000 in Windows 2000" (http://support.microsoft.com/default.aspx?scid=kb;de;310380)


Der Wert „msExchSmtpSmartHostType" weicht von seinem Standardwert „0" ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob der konfigurierte Wert für das Attribut msExchSmtpSmartHostType von seinem Standardwert 0 geändert wurde. Als Standard ist das Attribut msExchSmtpSmartHostType auf 0 festgelegt. Wenn Exchange Server Analyzer feststellt, dass dieses Attribut nicht den Wert 0 aufweist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Das Attribut msExchSmtpSmartHostType zeigt an, ob ein virtueller SMTP-Server dafür konfiguriert ist, einen Smarthost zum Übermitteln von Nachrichten zu verwenden. Anstatt diese Nachrichten direkt an die Empfängerdomänen zu senden, können Sie alle ausgehenden Nachrichten für Remote-Domänen über einen Smarthost weiterleiten. Wenn Exchange für die Verwendung eines Smarthost konfiguriert ist, wird der Wert für das Attribut msExchSmtpSmartHostType wie in der folgenden Tabelle angegeben geändert.

Einstellung des Smarthosts | Attributwert msExchSmtpSmartHostType
Kein Smarthost | 0
Smarthost | 2
Smarthost mit zuerst versuchter direkter Übermittlung | 1

Auf Exchange Server 2003-Computern ist dieser Wert entweder 0 oder 2. Auf Exchange 2000 Server-Computern kann der Wert 0, 1 oder 2 betragen. Der Wert 1 wird festgelegt, wenn das Kontrollkästchen Direkte Übermittlung versuchen, bevor zum Smarthost gesendet wird aktiviert ist. Dieses Kontrollkästchen ist nur auf Exchange 2000 Server-Computern vorhanden. Auf Exchange Server 2003 ist dieses Kontrollkästchen nicht vorhanden.

Wenn keine besonderen Gründe dagegen sprechen, wird empfohlen, dass Sie für das Attribut msExchSmtpSmartHostType die Standardeinstellung 0 beibehalten.

Wenn Ihre Umgebung einen Smarthost erfordert oder dort mehr als ein Exchange Server-Computer vorhanden (oder geplant) ist, wird empfohlen, dass Sie für Smarthost-Einträge einen SMTP-Connector verwenden. Auf diese Weise werden alle Ihre internen Nachrichten von Exchange Server weitergeleitet, und nur Ihre externen Nachrichten werden über den Smarthost weitergeleitet.

So zeigen Sie Smarthost-Einstellungen an und konfigurieren diese

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Server, erweitern Sie einen Exchange-Server, erweitern Sie Protokolle, und erweitern Sie dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise Virtueller Standardserver für SMTP), und wählen Sie dann Eigenschaften aus.

  4. Wählen Sie die Registerkarte Übermittlung aus, und klicken Sie auf Erweitert.

  5. Geben Sie den Smarthost ein, den Sie verwenden möchten. Sie können den Smarthost anhand des vollständig qualifizierten Domänenamens oder einer IP-Adresse identifizieren. Wenn Sie eine IP-Adresse verwenden, müssen Sie diese in eckige Klammern ([ ]) setzen. Exchange sucht zunächst nach einem Servernamen und dann nach einer IP-Adresse. Die Klammern identifizieren den Wert als IP-Adresse; deshalb wird die DNS-Suche umgangen.

  6. Auf einem Exchange 2000 Server-Computer können Sie optional das Kontrollkästchen Direkte Übermittlung versuchen, bevor zum Smarthost gesendet wird aktivieren.

  7. Klicken Sie auf OK, um die Änderungen zu speichern, und klicken Sie dann auf OK, um das Dialogfeld Eigenschaften des virtuellen SMTP-Servers zu schließen.

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 266686, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=266686)

  • 268163, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=268163)


Dienst „MTA Stacks" wurde für die Zusammenarbeit mit dem Desktop konfiguriert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_Service ab, um den Wert der Eigenschaft DesktopInteract für den Microsoft Exchange MTA Stacks-Dienst (MSExchangeMTA) zu bestimmen. Wenn Microsoft Exchange Server Analyzer feststellt, dass der MTA-Dienst für die Zusammenarbeit mit dem Desktop konfiguriert ist, wird von dem Tool ein Fehler ausgegeben.

Diese Konfiguration sollte nur unter Anleitung des Technischen Supports von Microsoft (PSS) verwendet werden. Wenn Sie vom PSS nicht angewiesen wurden, den MTA-Dienst unter dieser Konfiguration auszuführen, wird empfohlen, die Eigenschaften des Diensts MTA-Stacks neu zu konfigurieren, sodass keine Zusammenarbeit mit dem Desktop möglich ist.

So konfigurieren Sie das Konto für den Dienst „Exchange MTA-Stacks"

  1. Öffnen Sie das MMC-Snap-In Dienste.

  2. Suchen Sie den Dienst Microsoft Exchange MTA-Stacks, und beenden Sie ihn.

  3. Doppelklicken Sie auf den Dienst Microsoft Exchange MTA-Stacks.

  4. Wählen Sie auf der Seite Eigenschaften von Microsoft Exchange MTA-Stacks auf der Registerkarte Anmelden unter Anmelden als das lokale Systemkonto aus.

  5. Deaktivieren Sie das Kontrollkästchen Datenaustausch zwischen Dienst und Desktop zulassen, und klicken Sie dann auf Übernehmen.

  6. Klicken Sie unter Dienststatus auf Start, und klicken Sie dann auf OK.

  7. Schließen Sie das Snap-In Dienste.

Weitere Informationen zur richtigen Konfiguration von Exchange-Diensten finden Sie im Microsoft Knowledge Base-Artikel 239762, „Exchange Services Run Under LocalSystem" unter http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762.


Keine DNS-Einträge vom Typ "Host" gefunden für "MX"-Einträge gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-03

Microsoft® Exchange Server Analyzer führt eine DNS-Suche (Domain Name System) aus, um MX-Einträge (Mail Exchanger) für eine Domäne abzurufen. Wenn die MX-Einträge erfolgreich abgerufen werden, führt Exchange Server Analyzer anschließend eine DNS-Suche zum Abrufen der Einträge vom Typ "Host (A)" der Server ab, auf welche die MX-Einträge zeigen. Wenn die DNS-Suche keine IP-Adresse für einen beliebigen dieser "Host (A)"-Einträge zurückgibt, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Dieser Fehler bedeutet, dass der DNS-Eintrag "Host (A)" für den Server zu fehlen scheint. Dieser Fehler kann verursachen, dass Nachrichten an Remotedomänen in den Warteschlangen vom Typ Remoteübermittlung auf dem Server mit Exchange zurückbehalten werden. Dieser Fehler kann auch andere Routing- oder Dienstverzögerungen verursachen.

Die DNS-Suche des Eintrags "Host (A)" für einen MX-Eintrag kann aus folgenden Gründen fehlschlagen:

  • Der DNS-Server ist wegen eines Netzwerkfehlers oder aus anderen Gründen nicht verfügbar oder antwortet nicht.

  • Der "Host (A)"-Eintrag für den Remoteserver fehlt auf dem DNS-Server, da der Eintrag nicht verfügbar oder falsch ist.

  • Der DNS-Server ist nicht für die dynamische Aktualisierung von Hosteinträgen konfiguriert.

So stellen Sie sicher, dass der DNS-Server online und der Hosteintrag vorhanden ist

  1. Überprüfen Sie, ob der DNS-Server ausgeführt wird, indem Sie die folgenden Schritte ausführen:

    • Untersuchen Sie den Status des DNS-Servers mithilfe des DNS-Administrationsprogramms auf dem DNS-Server.

    • Starten Sie den DNS-Server neu. Weitere Informationen finden Sie unter "Start, stop, pause, or restart a DNS server" (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Untersuchen Sie die Reaktionsbereitschaft des DNS-Servers mithilfe des Befehls nslookup. Weitere Informationen finden Sie unter "Verify DNS server responsiveness using the nslookup command" (http://go.microsoft.com/fwlink/?LinkId=63000).

  2. Verwenden Sie nslookup, um zu überprüfen, ob der Eintrag "Host (A)" auf dem DNS-Server vorhanden ist. Weitere Informationen finden Sie unter "To verify A resource records exist in DNS" (http://go.microsoft.com/fwlink/?LinkId=63001).

  3. Wenn der Eintrag "Host (A)" nicht vorhanden ist, fügen Sie den A-Ressourceneintrag manuell hinzu oder ändern ihn bzw. konfigurieren den DNS-Server so, dass dynamische Eintragsaktualisierungen zulässig sind.

    • Fügen Sie manuell einen "A"-Ressourceneintrag hinzu. Weitere Informationen finden Sie unter „Add a resource record to a DNS zone" (http://go.microsoft.com/fwlink/?LinkId=63002).

    • Ändern Sie einen "A"-Ressourceneintrag manuell. Weitere Informationen finden Sie unter „Modify an existing resource record" (http://go.microsoft.com/fwlink/?LinkId=63014).

    • Konfigurieren Sie auf dem DNS-Server die dynamische Aktualisierung von Hosteinträgen. Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 816592, "Konfigurieren der dynamischen DNS-Updates in Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592).

Weitere Informationen

  • Weitere Informationen zur Verwendung von DNS durch Exchange Server 2003 zum Auflösen externer IP-Adressen finden Sie unter "Transportabhängigkeiten in Exchange Server 2003" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Informationen zur DNS-Namensauflösung finden Sie im Microsoft Knowledge Base-Artikel 322856, "Konfigurieren von DNS für eine Verwendung mit Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • Informationen zur Behandlung von DNS-Problemen finden Sie unter "Troubleshooting DNS" (http://go.microsoft.com/fwlink/?LinkId=63003).

  • Informationen zur Exchange Server 2003-Systemüberwachung finden Sie in "Kapitel 3: System Monitoring with Exchange Server 2003 Management Pack" im Exchange Server 2003 Management Pack Guide for MOM 2000 SP1 (http://go.microsoft.com/fwlink/?LinkId=47573).

  • Informationen zu "Host (A)"-Ressourceneinträgen finden Sie unter "Managing resource records" (http://go.microsoft.com/fwlink/?LinkId=63004).


Keine DNS-Einträge vom Typ "Host" gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-04

Microsoft® Exchange Server Analyzer führt eine DNS-Suche (Domain Name System) aus, um den "Host (A)"-Eintrag von Remoteservern abzurufen, an die der Server mit Exchange versucht, Nachrichten zu senden. Wenn die DNS-Suche keine IP-Adresse zurückgibt, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Dieser Fehler bedeutet, dass der DNS-Eintrag "Host (A)" für den Remoteserver zu fehlen scheint. Dieser Fehler kann verursachen, dass Nachrichten in den Warteschlangen vom Typ Remoteübermittlung auf dem Server mit Exchange zurückbehalten werden.

Die DNS-Suche des Eintrags "Host (A)" auf dem Remoteserver kann aus folgenden Gründen fehlschlagen:

  • Der DNS-Server ist wegen eines Netzwerkfehlers oder aus anderen Gründen nicht verfügbar oder antwortet nicht.

  • Der "Host (A)"-Eintrag für den Remoteserver fehlt auf dem DNS-Server, da der Eintrag nicht verfügbar oder falsch ist.

  • Der DNS-Server ist nicht für die dynamische Aktualisierung von Hosteinträgen konfiguriert.

So stellen Sie sicher, dass der DNS-Server online und der Hosteintrag vorhanden ist

  1. Überprüfen Sie, ob der DNS-Server ausgeführt wird, indem Sie die folgenden Schritte ausführen:

    • Untersuchen Sie den Status des DNS-Servers mithilfe des DNS-Administrationsprogramms auf dem DNS-Server.

    • Starten Sie den DNS-Server neu. Weitere Informationen finden Sie unter "Start, stop, pause, or restart a DNS server" (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Untersuchen Sie die Reaktionsbereitschaft des DNS-Servers mithilfe des Befehls nslookup. Weitere Informationen finden Sie unter "Verify DNS server responsiveness using the nslookup command" (http://go.microsoft.com/fwlink/?LinkId=63000).

  2. Verwenden Sie nslookup, um zu überprüfen, ob der Eintrag "Host (A)" auf dem DNS-Server vorhanden ist. Weitere Informationen finden Sie unter "To verify A resource records exist in DNS" (http://go.microsoft.com/fwlink/?LinkId=63001).

  3. Wenn der Eintrag "Host (A)" nicht vorhanden ist, fügen Sie den "A"-Ressourceneintrag manuell hinzu oder ändern ihn bzw. konfigurieren den DNS-Server so, dass dynamische Eintragsaktualisierungen zulässig sind.

    • Fügen Sie manuell einen "A"-Ressourceneintrag hinzu. Weitere Informationen finden Sie unter „Add a resource record to a DNS zone" (http://go.microsoft.com/fwlink/?LinkId=63002).

    • Ändern Sie einen "A"-Ressourceneintrag manuell. Weitere Informationen finden Sie unter "Modify an existing resource record" (http://go.microsoft.com/fwlink/?LinkId=63014).

    • Konfigurieren Sie auf dem DNS-Server die dynamische Aktualisierung von Hosteinträgen. Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 816592, "Konfigurieren der dynamischen DNS-Updates in Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592).
  • Weitere Informationen zur Verwendung von DNS durch Exchange Server 2003 zum Auflösen externer IP-Adressen finden Sie unter "Transportabhängigkeiten in Exchange Server 2003" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Informationen zur DNS-Namensauflösung finden Sie im Microsoft Knowledge Base-Artikel 322856, "Konfigurieren von DNS für eine Verwendung mit Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • Informationen zur Behandlung von DNS-Problemen finden Sie unter "Troubleshooting DNS" (http://go.microsoft.com/fwlink/?LinkId=63003).

  • Informationen zur Exchange Server 2003-Systemüberwachung finden Sie in "Kapitel 3: System Monitoring with Exchange Server 2003 Management Pack" im Exchange Server 2003 Management Pack Guide for MOM 2000 SP1 (http://go.microsoft.com/fwlink/?LinkId=47573).

  • Informationen zu "Host (A)"-Ressourceneinträgen finden Sie unter "Managing resource records" (http://go.microsoft.com/fwlink/?LinkId=63004).


Keine "MX"-Einträge gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer fragt die verwendeten DNS-Server (Domain Name System) auf die MX-Einträge (Mail Exchanger) von Remotedomänen ab, an die Exchange Nachrichten sendet.

Wenn Exchange Server Analyzer keine MX-Einträge für eine Remotedomäne von den verwendeten DNS-Server abrufen kann, zeigt Exchange Server Analyzer eine Warnung an.

Diese Warnung besagt, dass die DNS-Einträge vom Typ "MX" für die Remotedomäne zu fehlen scheinen.

Um Mailhosts zu bestimmen, sucht der sendende Server mit Exchange nach einem MX-Eintrag. Als Nächstes löst der sendende Server den MX-Eintrag in eine IP-Adresse auf, indem nach einem Adresseintrag vom Typ "(A)" gesucht wird.

Wenn MX-Einträge für Remotedomänen fehlen, häufen sich ggf. an die Remotedomänen gerichtete Nachrichten in den Warteschlangen vom Typ Remoteübermittlung des Servers mit Exchange an. Ferner kommt es ggf. zu anderen Routing- oder Dienstverzögerungen.

Die DNS-Suche nach den MX-Einträgen kann fehlschlagen, wenn der DNS-Server wegen eines Netzwerkfehlers oder aus anderen Gründen nicht verfügbar ist oder nicht antwortet.

So stellen Sie sicher, dass der DNS-Server online ist und die MX-Einträge vorhanden sind

  1. Überprüfen Sie, ob der DNS-Server ausgeführt wird, indem Sie die folgenden Schritte ausführen:

    • Untersuchen Sie den Status des DNS-Servers mithilfe des DNS-Administrationsprogramms auf dem DNS-Server.

    • Starten Sie den DNS-Server neu. Weitere Informationen finden Sie unter "Start, stop, pause, or restart a DNS server" (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Untersuchen Sie die Reaktionsbereitschaft des DNS-Servers mithilfe des Befehls nslookup. Weitere Informationen finden Sie in den Anweisungen unter "Verify DNS server responsiveness using the nslookup command" (http://go.microsoft.com/fwlink/?LinkId=63000).

  2. Überprüfen Sie mit nslookup, ob die MX-Einträge ordnungsgemäß konfiguriert sind. Weitere Informationen finden Sie unter "Überprüfen der Konfiguration von MX-Einträgen mithilfe von Nslookup " im Abschnitt "Überprüfen des DNS-Designs und der Konfiguration" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Weitere Informationen

  • Weitere Informationen zur Verwendung von DNS durch Exchange Server 2003 zum Auflösen externer IP-Adressen finden Sie unter "Transportabhängigkeiten in Exchange Server 2003" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Informationen zur DNS-Namensauflösung finden Sie im Microsoft Knowledge Base-Artikel 322856, "Konfigurieren von DNS für eine Verwendung mit Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • Informationen zur Behandlung von DNS-Problemen finden Sie unter "Troubleshooting DNS" (http://go.microsoft.com/fwlink/?LinkId=63003).

  • Informationen zur Exchange Server 2003-Systemüberwachung finden Sie in "Kapitel 3: System Monitoring with Exchange Server 2003 Management Pack" im Exchange Server 2003 Management Pack Guide for MOM 2000 SP1 (http://go.microsoft.com/fwlink/?LinkId=47573).


Geschachtelte Verteilergruppe in Übermittlungseinschränkungen
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-21

Microsoft® Exchange Server Analyzer fragt die folgenden Attribute für jedes Verteilergruppenobjekt in allen in dem Active Directory®-Verzeichnisdienst gefundenen Domänen ab, um zu ermitteln, ob eine oder mehrere dieser Gruppen zum Festlegen von Übermittlungseinschränkungen basierend auf der Mitgliedschaft in einer der Gruppen verwendet werden:

dLMemRejectPermsBL | Enthält die DNs der Empfänger oder Connectors, die keine Nachrichten von dieser Gruppe akzeptieren.
dLMemSubmitPermsBL | Enthält die DNs der Empfänger oder Connectors, die Nachrichten von dieser Gruppe akzeptieren.

Wenn Exchange Server Analyzer zum Festlegen von Übermittlungseinschränkungen verwendete Gruppenobjekte findet, überprüft Exchange Server Analyzer diese Gruppen auf enthaltene geschachtelte Gruppen.

Microsoft Exchange Server Analyzer liest auch den folgenden Registrierungsschlüssel, um festzustellen, ob der Registrierungswert RestrictionMethod vorhanden ist, und wie er konfiguriert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Die Mitgliedschaft in Verteilergruppen dient zum Festlegen von Übermittlungseinschränkungen.

  • Es sind geschachtelte Verteilergruppen in den Verteilergruppen vorhanden, für die Übermittlungseinschränkungen festgelegt sind.

  • Der Registrierungswert RestrictionMethod ist vorhanden und nicht so festgelegt, dass die flache Einschränkungsüberprüfung erzwungen wird.

Dieser Fehler gibt an, dass Übermittlungseinschränkungen, die auf der Mitgliedschaft in Verteilergruppen basieren, Leistung der Exchange-Nachrichtenübermittlung unter Umständen erheblich beeinträchtigen.

Das Standardverhalten des Kategorisierungsmoduls besteht darin, Verteilergruppen rekursiv zu erweitern und die Einschränkungen für jede Nachricht zu überprüfen, die das System durchläuft.

Wenn Sie E-Mails an einen Benutzer senden, der Nachrichten von einer Verteilergruppe akzeptiert oder ablehnt, oder wenn Sie E-Mails senden, die einen Connector durchlaufen, der Nachrichten von einer Verteilergruppe akzeptiert oder ablehnt, muss das Nachrichtenkategorisierungsmodul die Mitgliedschaft der Verteilergruppe erweitern, die vollständige Liste der DNs der Mitglieder anfordern und anschließend die Liste der DNs mit den DNs der Absender vergleichen. Eine Zugriffsoperation oder eine Verweigerungsoperation erfolgt, wenn in beiden Listen eine Übereinstimmung bei einem DN gefunden wird. Wenn eine Verteilergruppe in eine andere Verteilergruppe geschachtelt ist, wird die geschachtelte Verteilergruppe ebenfalls erweitert.

Der Wert RestrictionMethod bestimmt, wie das Kategorisierungsmodul Einschränkungen verarbeitet. Wenn Sie den Wert von RestrictionMethod auf 2 festlegen, erweitern die Transportkomponenten für diesen Server mit Exchange Server die Mitgliedschaft der Verteilergruppen nicht, während der Server die Einschränkungen überprüft. Diese Konfiguration stellt die beste Leistung für Einschränkungsüberprüfungen bereit. Darüber hinaus müssen alle Verteilergruppen mit Benutzern, für die Übermittlungseinschränkungen gelten, flach sein, damit der Registrierungseintrag RestrictionMethod wirksam wird. Das heißt, dass die eingeschränkten Verteilergruppen keine geschachtelten Verteilergruppen aufweisen dürfen. Die Aufgliederungslogik funktioniert nicht, wenn die eingeschränkten Verteilergruppen geschachtelt sind.

Für Verteilergruppen, die in Connectoreinschränkungen verwendet werden, wird empfohlen, den Wert des Registrierungseintrags RestrictionMethod für einen Connector-Bridgeheadserver festzulegen, der keine Postfächer aufweist. Wenn die eingeschränkten Verteilergruppen über Server für die Aufgliederung der Verteilerlisten verfügen, wird bei Benutzereinschränkungen für Active Directory empfohlen, dass Sie den Registrierungseintrag RestrictionMethod für die Server für die Aufgliederung der Verteilerlisten erstellen.

So beheben Sie diesen Fehler

  • Überprüfen Sie diejenigen Benutzer, deren Übermittlungseinschränkungen für Verteilergruppen festgelegt sind, und entfernen Sie nicht benötigte Einschränkungen.

  • Konfigurieren Sie einzelne Postfächer und keine Verteilergruppen für Übermittlungseinschränkungen gemäß den Erläuterungen im Microsoft Knowledge Base-Artikel 812298, "Übermittlung von E-Mails ist langsam, nachdem Sie Übermittlungseinschränkungen konfiguriert haben, die auf einer Verteilerliste basieren" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Erwägen Sie für Server, auf denen Microsoft Exchange Server 2003 Service Pack 2 (SP2) oder höher ausgeführt wird, die nicht hierarchische Einschränkungsüberprüfung zu implementieren. Bei Servern, auf denen Versionen von Exchange vor Exchange 2003 SP2 ausgeführt werden, sollten Sie die Aktualisierung auf Exchange 2003 SP2 in Betracht ziehen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema "Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So erstellen Sie den Registrierungseintrag RestrictionMethod und legen dessen Wert auf 2 fest

  1. Öffnen Sie einen Registrierungs-Editor wie zum Beispiel Regedit.exe oder Regedt32.exe.

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

  3. Klicken Sie im linken Bereich auf Parameter.

  4. Zeigen Sie im Menü Bearbeiten auf Neu, und klicken Sie dann auf DWORD-Wert.

  5. Geben Sie RestrictionMethod ein, und drücken Sie danach EINGABETASTE, um den neuen Registrierungseintrag zu benennen.

  6. Klicken Sie mit der rechten Maustaste auf RestrictionMethod, und klicken Sie dann auf Ändern.

  7. Geben Sie 2 ein, und drücken Sie dann die EINGABETASTE.

  8. Schließen Sie den Registrierungs-Editor.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, "Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen

Weitere Informationen zu der nicht hierarchischen Einschränkungsüberprüfung finden Sie unter Empfohlene Vorgehensweise: Nicht hierarchische Einschränkungsüberprüfung..

Weitere Informationen zu der Auswirkung der Verteilergruppeneinschränkung auf den E-Mail-Verkehr in Exchange finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 895407, "Die Nachrichtenübermittlung zu lokalen und externen Postfächern ist in Exchange Server 2003 langsamer als erwartet, nachdem Sie die Übermittlungseinschränkungen basierend auf Verteilergruppen konfiguriert haben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 839949 "Problembehandlung bei E-Mail-Transport und Verteilergruppen in Exchange 2000 Server und in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • 812298 "Übermittlung von E-Mails ist langsam, nachdem Sie Übermittlungseinschränkungen konfiguriert haben, die auf einer Verteilerliste basieren" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

Weitere Informationen zum Registrierungswert RestrictionMethod finden Sie im Microsoft Knowledge Base-Artikel 895407, "Die Nachrichtenübermittlung zu lokalen und externen Postfächern ist in Exchange Server 2003 langsamer als erwartet, nachdem Sie die Übermittlungseinschränkungen basierend auf Verteilergruppen konfiguriert haben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

Weitere Informationen zum Registrierungswert finden Sie im Knowledge Base-Artikel 277872 "XCON: Connector-Empfangseinschränkung funktioniert möglicherweise nicht richtig" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872)


Es wurde eine geschachtelte Verteilergruppe gefunden, die flache Einschränkungsprüfung ist jedoch aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-21

Microsoft® Exchange Server Analyzer fragt die folgenden Attribute für jedes Verteilergruppenobjekt in allen in dem Active Directory®-Verzeichnisdienst gefundenen Domänen ab, um zu ermitteln, ob eine oder mehrere dieser Gruppen zum Festlegen von Übermittlungseinschränkungen basierend auf der Mitgliedschaft in einer der Gruppen verwendet werden:

dLMemRejectPermsBL | Enthält die DNs der Empfänger oder Connectors, die keine Nachrichten von dieser Gruppe akzeptieren.
dLMemSubmitPermsBL | Enthält die DNs der Empfänger oder Connectors, die Nachrichten von dieser Gruppe akzeptieren.

Wenn Exchange Server Analyzer zum Festlegen von Übermittlungseinschränkungen verwendete Gruppenobjekte findet, überprüft Exchange Server Analyzer anschließend diese Gruppen auf enthaltene geschachtelte Gruppen.

Microsoft Exchange Server Analyzer liest auch den folgenden Registrierungsschlüssel, um festzustellen, ob der Registrierungswert RestrictionMethod vorhanden ist, und wie er konfiguriert ist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Die Mitgliedschaft in Verteilergruppen dient zum Festlegen von Übermittlungseinschränkungen.

  • Es sind geschachtelte Verteilergruppen in den Verteilergruppen vorhanden, für die Übermittlungseinschränkungen festgelegt sind.

  • Der Registrierungswert RestrictionMethod ist vorhanden und so festgelegt, dass die flache Einschränkungsüberprüfung erzwungen wird.

Diese Warnung gibt an, das in die Verteilergruppen, für die Übermittlungseinstellungen festgelegt sind, andere Verteilergruppen eingebettet (geschachtelt) sind, obwohl der Registrierungswert RestrictionMethod so festgelegt ist, dass die flache (nicht hierarchische) Einschränkungsüberprüfung erzwungen wird. Die flache Einschränkungsüberprüfung kann die zugelassenen oder verweigerten Absender nicht korrekt ermitteln, wenn die Verteilergruppen geschachtelte Verteilergruppen enthalten. Bei Verwendung der flachen Einschränkungsüberprüfung werden geschachtelte Verteilergruppen nicht erweitert.

Das Standardverhalten des Kategorisierungsmoduls besteht darin, Verteilergruppen rekursiv aufzugliedern und die Einschränkungen für jede Nachricht zu überprüfen, die das System durchläuft.

Wenn Sie E-Mails an einen Benutzer senden, der Nachrichten von einer Verteilergruppe akzeptiert oder ablehnt, oder wenn Sie E-Mails senden, die einen Connector durchlaufen, der Nachrichten von einer Verteilergruppe akzeptiert oder ablehnt, muss das Nachrichtenkategorisierungsmodul die Mitgliedschaft der Verteilergruppe erweitern, die vollständige Liste der DNs der Mitglieder anfordern und anschließend die Liste der DNs mit den DNs der Absender vergleichen. Eine Zugriffsoperation oder eine Verweigerungsoperation erfolgt, wenn in beiden Listen eine Übereinstimmung bei einem DN gefunden wird. Wenn eine Verteilergruppe in eine andere Verteilergruppe geschachtelt ist, wird die geschachtelte Verteilergruppe ebenfalls erweitert.

Der Wert RestrictionMethod bestimmt, wie das Kategorisierungsmodul Einschränkungen verarbeitet. Wenn Sie den Wert von RestrictionMethod auf 2 festlegen, erweitern die Transportkomponenten für diesen Server mit Exchange Server die Mitgliedschaft der Verteilergruppen nicht, während der Server die Einschränkungen überprüft. Diese Konfiguration stellt die beste Leistung für Einschränkungsüberprüfungen bereit. Darüber hinaus müssen alle Verteilergruppen mit Benutzern, für die Übermittlungseinschränkungen gelten, flach sein, damit der Registrierungseintrag RestrictionMethod wirksam wird. Das heißt, dass die eingeschränkten Verteilergruppen keine geschachtelten Verteilergruppen aufweisen dürfen.

Um diese Warnung zu beheben, schachteln Sie keine Verteilergruppen innerhalb anderer Verteilergruppen, die für Übermittlungseinschränkungen verwendet werden, wenn die flache Einschränkungsüberprüfung aktiviert ist.

Weitere Informationen

Weitere Informationen zu der nicht hierarchischen Einschränkungsüberprüfung finden Sie unter Empfohlene Vorgehensweise: Nicht hierarchische Einschränkungsüberprüfung..

Weitere Informationen zu der Auswirkung der Verteilergruppeneinschränkung auf den E-Mail-Verkehr in Exchange finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 895407, "Die Nachrichtenübermittlung zu lokalen und externen Postfächern ist in Exchange Server 2003 langsamer als erwartet, nachdem Sie die Übermittlungseinschränkungen basierend auf Verteilergruppen konfiguriert haben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 839949 "Problembehandlung bei E-Mail-Transport und Verteilergruppen in Exchange 2000 Server und in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • 812298 "Übermittlung von E-Mails ist langsam, nachdem Sie Übermittlungseinschränkungen konfiguriert haben, die auf einer Verteilerliste basieren" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

Weitere Informationen zum Registrierungswert RestrictionMethod finden Sie im Microsoft Knowledge Base-Artikel 895407, "Die Nachrichtenübermittlung zu lokalen und externen Postfächern ist in Exchange Server 2003 langsamer als erwartet, nachdem Sie die Übermittlungseinschränkungen basierend auf Verteilergruppen konfiguriert haben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

Weitere Informationen zum Registrierungswert finden Sie im Knowledge Base-Artikel 277872 "XCON: Connector-Empfangseinschränkung funktioniert möglicherweise nicht richtig" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872)


Keine Nachricht vom angegebenen Absender
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-03-07

Das Tool Microsoft Exchange Server Analyzer fragt im Active Directory-Verzeichnisdienst den Wert des Attributs proxyAddress für alle Benutzerobjekte ab, um zu ermitteln, ob eine Übereinstimmung mit der vom Benutzer angegebenen SMTP-Adresse (Simple Mail Transfer Protocol) des lokalen Absenders vorhanden ist.

Wenn für das Benutzerobjekt proxyAddress eine Übereinstimmung gefunden wurde, fragt Exchange Server Analyzer danach in Active Directory des Wert des Attributs msExchHomeServerName des Benutzerobjekts ab, um zu ermitteln, ob dieser Wert mit dem vom Benutzer angegebenen Exchange Server-Namen übereinstimmt.

Abschließend fragt Exchange Server Analyzer die Eigenschaft SenderAddress für die Microsoft WMI-Klasse (Microsoft Windows Management Instrumentation) Exchange_MessageTrackingEntry unter dem Namespace root\MicrosoftExchangeV2 ab, um alle in den Nachrichtenverfolgungsprotokollen erfassten Nachrichten des vom Benutzer angegebenen Absenders zu ermitteln.

Wenn Exchange Server Analyzer im Nachrichtenverfolgungsprotokoll keinen Eintrag mit dem Eigenschaftenwert senderAddress findet, der der legacyDN oder der SMTP-Adresse des vom Benutzer angegebenen Absenders entspricht, zeigt Exchange Server Analyzer einen Fehler an.

  • Dieser Fehler weist darauf hin, dass eine oder mehrere der folgenden Bedingungen zutreffen:

  • Der vom Benutzer angegebene Absender hat keine Nachrichten gesendet.

  • Die Aufbewahrungszeit für das Nachrichtenverfolgungsprotokoll ist abgelaufen, und die relevanten Protokolleinträge wurden bereits gelöscht.

  • Die Nachrichtenprotokollierung ist für den Server nicht aktiviert.

So beheben Sie dieses Problem

  • Sorgen Sie dafür, dass der angegebene Absender eine weitere Nachricht an den angegebenen Empfänger übermittelt.

  • Aktivieren Sie den Nachrichtenstatus.

  • Verlängern Sie den Aufbewahrungszeitraum für das Nachrichtenverfolgungsprotokoll , oder verfolgen Sie eine aktuellere Nachricht.

Weitere Informationen zum Aktivieren des Nachrichtenstatus finden Sie unter "Aktivieren des Nachrichtenstatus auf einem Server" (http://go.microsoft.com/fwlink/?LinkId=71257) unter "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875).

Weitere Informationen zur Verwendung der Nachrichtenverfolgung finden Sie im Microsoft Knowledge Base-Artikel 262162, "XADM: Verwenden des Nachrichtenstatus, um eine Nachricht zu verfolgen" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162)


Keine Nachricht an den angegebenen Empfänger
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-12-07

Microsoft® Exchange Server Analyzer fragt im Active Directory®-Verzeichnisdienst den Wert des Attributs proxyAddress für alle Benutzerobjekte ab, um zu ermitteln, ob eine Übereinstimmung mit der vom Benutzer angegebenen SMTP-Adresse (Simple Mail Transfer Protocol) des lokalen Absenders vorhanden ist.

Wenn für das Benutzerobjekt proxyAddress eine Übereinstimmung gefunden wurde, fragt Exchange Server Analyzer danach in Active Directory des Wert des Attributs msExchHomeServerName des Benutzerobjekts ab, um zu ermitteln, ob dieser Wert mit dem vom Benutzer angegebenen Exchange Server-Namen übereinstimmt.

Anschließend fragt Exchange Server Analyzer die Eigenschaft SenderAddress für die Microsoft WMI-Klasse (Microsoft Windows® Management Instrumentation) Exchange_MessageTrackingEntry unter dem Namespace root\MicrosoftExchangeV2 ab, um alle in den Nachrichtenverfolgungsprotokollen erfassten Nachrichten des vom Benutzer angegebenen Absenders zu ermitteln.

Abschließend fragt Exchange Server Analyzer die Eigenschaft RecipientAddress der WMI-Klasse Exchange_MessageTrackingEntry ab, um zu ermitteln, ob in den Nachrichtenverfolgungsprotokollen Nachrichten für den vom Benutzer angegebenen Empfänger erfasst wurden.

Wenn Exchange Server Analyzer im Nachrichtenverfolgungsprotokoll keinen Eintrag mit dem Eigenschaftenwert RecipientAddress findet, der der SMTP-Adresse des vom Benutzer angegebenen Absenders entspricht, zeigt Exchange Server Analyzer einen Fehler an.

Dieser Fehler weist darauf hin, dass eine oder mehrere der folgenden Bedingungen zutreffen:

  • Der vom Benutzer angegebene Absender hat keine Nachrichten an den vom Benutzer angegebenen Empfänger gesendet.

  • Die Aufbewahrungszeit für das Nachrichtenverfolgungsprotokoll ist abgelaufen, und die relevanten Protokolleinträge wurden bereits gelöscht.

So beheben Sie dieses Problem

  • Überprüfen Sie, ob die angegebene Empfängeradresse korrekt ist.

  • Sorgen Sie dafür, dass der angegebene Absender eine weitere Nachricht an den angegebenen Empfänger übermittelt.

  • Verlängern Sie den Aufbewahrungszeitraum für das Nachrichtenverfolgungsprotokoll , oder verfolgen Sie eine aktuellere Nachricht.

Weitere Informationen zum Verlängern der Aufbewahrungszeit im Nachrichtenverfolgungsprotokoll finden Sie unter "Aktivieren des Nachrichtenstatus auf einem Server" (http://go.microsoft.com/fwlink/?LinkID=71257).

Weitere Informationen zur Verwendung der Nachrichtenverfolgung finden Sie im Microsoft Knowledge Base-Artikel 262162, "XADM: Verwenden des Nachrichtenstatus, um eine Nachricht zu verfolgen" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162)


Kein Warteschlangenstatus verfügbar. Die SMTP-Warteschlangenanalyse wurde abgebrochen.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-03-15

Das Tool Microsoft Exchange Analyzer fragt die Microsoft WMI-Klasse (Microsoft Windows Management Instrumentation) ExchangeLink ab, um den Status der SMTP-Warteschlangen (Simple Mail Transfer Protocol) für einen Servercomputer mit Exchange zu überprüfen.

SMTP ist das systemeigene E-Mail-Protokoll von Exchange Server für die Übertragung und den Transport von E-Mail. Dies bedeutet, dass Clients SMTP zum Senden von Nachrichten und Server mit Exchange SMTP für die Zustellung von Nachrichten und Nachrichtendaten verwenden.

Die Eigenschaften der WMI-Klasse ExchangeLink geben Informationen zu Nachrichtenverarbeitungslinks (Warteschlangen) zwischen Mailservern zurück. Ein Link kann Null oder mehr ExchangeQueue-Objekte enthalten. Diese Anzahl richtet sich nach dem aktuellen Nachrichtenverkehr entlang des Links.

SMTP verwendet die SMTP-Warteschlangen für die interne und externe Zustellung von E-Mail. Während der Nachrichtenkategorisierung und -zustellung sendet das erweiterte Warteschlangenmodul sämtliche Nachrichten über die SMTP-Warteschlangen eines virtuellen SMTP-Servers. Wenn an einem beliebigen Punkt in diesem Vorgang ein Problem mit der Zustellung der Nachricht auftritt, verbleibt die Nachricht in der Warteschlange, in der das Problem aufgetreten ist.

Beschreibungen der SMTP-Warteschlangen

SMTP-Warteschlange Beschreibung

[Name der lokalen Domäne] (Lokale Zustellung)

Enthält Nachrichten, die auf dem Server mit Exchange zur lokalen Zustellung an ein Exchange-Postfach oder einen Informationsspeicher für Öffentliche Ordner in einer Warteschlange gespeichert werden.

Nachrichten, mit ausstehender Verzeichnissuche

Enthält Nachrichten an Empfänger, die noch nicht im Abgleich mit dem Active Directory-Verzeichnisdienst aufgelöst werden konnten. Nachrichten werden auch während der Aufgliederung von Verteilerlisten in dieser Warteschlange gespeichert.

Nachrichten mit ausstehender Weiterleitung

Speichert Nachrichten, bis deren nächster Zielserver bestimmt wurde, und verschiebt diese anschließend in die entsprechenden Verbindungswarteschlangen.

Remoteübermittlung

[Connectorname|

Servername| Remotedomäne]

Enthält Nachrichten mit Remoteübermittlungszielen. Der Name der Warteschlange entspricht dem Remoteübermittlungsziel. Dieses Ziel kann ein Connector, ein Server oder eine Domäne sein.

Endziel zurzeit nicht erreichbar

Der Endzielserver für diese Nachrichten kann nicht erreicht werden. Exchange kann z. B. keinen Netzwerkpfad zum Endziel bestimmen.

Vor Übermittlung

Enthält Nachrichten, die vom SMTP-Dienst bestätigt und angenommen wurden. Die Verarbeitung dieser Nachrichten hat noch nicht begonnen.

DSN-Nachrichten mit ausstehender Übertragung

Enthält Benachrichtigungen zum Übermittlungsstatus, die auch als Unzustellbarkeitsberichte bezeichnet werden, die für die Zustellung durch Exchange bereit sind.

Hinweis Die folgenden Vorgänge stehen für diese Warteschlange nicht zur Verfügung:

  • Löschen aller Nachrichten (kein Unzustellbarkeitsbericht)

  • Löschen aller Nachrichten (Unzustellbarkeitsbericht)

Wiederholungsversuchwarteschlange für Fehlernachrichten

Enthält Nachrichten, bei denen ein Fehler bei der Wartschlangenübermittlung aufgetreten ist. Dies betrifft häufig Nachrichten, für die noch keine weitere Verarbeitung stattgefunden hat. Standardmäßig werden Nachrichten in dieser Warteschlange in 60 Minuten verarbeitet.

Für verzögerte Zustellung in Warteschlangen gespeicherte Nachrichten

Enthält Nachrichten, die für die Zustellung zu einem späteren Zeitpunkt in Warteschlangen gespeichert wurde, z. B. auch Nachrichten, die von älteren Versionen von Outlook gesendet wurden. (Sie können diese Option auf Outlook-Clientcomputern festlegen).

Frühere Versionen von Outlook verwenden den MTA (Message Transfer Agent) für die Nachrichtenzustellung. Die Nachrichtenzustellung wird jetzt durch SMTP und nicht mehr durch den MTA vorgenommen. Aus diesem Grund wird für von älteren Versionen von Outlook gesendete Nachrichten die verzögerte Zustellung anders behandelt.

Diese Nachrichten verbleiben bis zu ihrer geplante Zustellungszeit in dieser Warteschlange.

Wenn Exchange Analyzer die Abfrage der WMI-Klasse ExchangeLink für einen Server nicht erfolgreich abschließen kann, zeigt Exchange Analyzer einen Fehler an.

Dieser Fehler weist darauf hin, dass die angeforderten Daten von der WMI-Abfrage nicht abgerufen werden konnten.

Wahrscheinliche Ursachen für diesen Fehler:

  • Das Konto, unter dem Microsoft Exchange Analyzer ausgeführt wird, verfügt nicht über die nötigen Berechtigungen, um WMI-Klassen abzufragen.

  • Wegen eines Netzwerkproblems kann Exchange Analyzer keine Verbindung mit dem Computer herstellen.

  • Ein vorübergehender Zustand unbekannten Ursprungs hat zu einem Timeout für die Abfrage geführt.

Um diesen Fehler zu beheben, führen Sie die folgenden Schritte aus:

  1. Stellen Sie sicher, dass der Computer mit Exchange Server gestartet wurde und mit dem Netzwerk verbunden ist.

  2. Verwenden Sie den Befehl PING, um festzustellen, ob eine Verbindung mit dem Computer mit Exchange Server hergestellt werden kann.

  3. Wenn ein Firewall vorhanden ist, überprüfen Sie, ob die RPC-Anschlüsse (Remote Procedure Call) blockiert sind.

  4. Überprüfen Sie die Berechtigungen für das Konto, unter dem Microsoft Exchange Analyzer ausgeführt wird. Das Konto, unter dem Microsoft Exchange Analyzer ausgeführt wird, muss über lokale Administratorberechtigungen für jeden durchsuchten Servercomputer mit Exchange verfügen.

    Alternativ können Sie dem Konto, unter dem Microsoft Exchange Analyzer ausgeführt wird, bestimmte WMI-Berechtigungen erteilen:

    1. Öffnen Sie auf dem Exchange-Computer die MMC-Struktur (Microsoft Management Console) Computerverwaltung.

    2. Klicken Sie mit der rechten Maustaste unter Dienste und Anwendungen auf WMI-Steuerung, und klicken Sie dann auf Eigenschaften.

    3. Klicken Sie auf der Seite Eigenschaften von WMI-Steuerung auf die Registerkarte Sicherheit, und erweitern Sie dann Stamm.

    4. Wählen Sie den Ordner CIMV2 aus, und klicken Sie auf Sicherheit.

    5. Fügen Sie auf der Seite Sicherheit für ROOT\CIMV2 das Konto hinzu, unter dem Exchange Analyzer ausgeführt wird.

  5. Wählen Sie das Konto aus, dass Sie oben in Schritt 5 hinzugefügt haben. Aktivieren Sie unter Berechtigungen für Ausgewähltes_Konto in der Spalte Zulassen die Kontrollkästchen Remote aktivieren und Sicherheit lesen, und klicken Sie dann auf OK.

Weitere Informationen zum Behandeln von Problemen mit Netzwerkverbindungen finden Sie im Microsoft Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Weitere Informationen zur Problembehandlung des Tools Exchange Server Best Practices Analyzer finden Sie unter "Problembehandlung bei Verbindungsproblemen mit Microsoft Exchange Server Best Practices Analyzer" (http://go.microsoft.com/fwlink/?LinkId=56285).

Weitere Informationen zu den Anforderungen hinsichtlich der Anschlüsse finden Sie im Microsoft Knowledge Base-Artikel 832017, "Dienste und Port-Anforderungen für das Microsoft Windows-Serversystem" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Keine Remoteserver oder -domänen für DNS-Eintragstests verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-07-06

Microsoft® Exchange Server Analyzer versucht, die vollqualifizierten Domänennamen (Fully Qualified Domain Name, FQDN), IP-Adressen und Domänennamen von Remoteservern, für die Nachrichten in einer Remoteübermittlungswarteschlange bestimmt sind, zu ermitteln und eine entsprechende Liste zu erstellen.

Die Liste der FQDNs, IP-Adressen und Domänennamen von Remoteservern wird folgendermaßen erstellt:

  • Die msExchSmtpFullyQualifiedDomainName-Eigenschaft des Active Directory®-Verzeichnisdienstobjekts für den virtuellen SMTP-Server (Simple Mail Transfer Protocol) wird angefragt.

    Hinweis:
    Die msExchSmtpFullyQualifiedDomainName-Eigenschaft wiederum wird aus der msExchTargetBridgeheadServersDN-Eigenschaft eines Verzeichnisobjekts für Routinggruppenconnectors gelesen, wenn das Objekt nach den angegebenen Bridgeheadzielservern abgefragt wird.
  • Die msExchSmtpSmartHost-Eigenschaft des Active Directory-Objekts für SMTP-Connectors wird nach dem angegebenen Smarthost für einen SMTP-Connector abgefragt.

  • Die LinkName-Eigenschaft der Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation, Windows® Management Instrumentation) ExchangeLink nach direkten Verbindungen zu Remoteservern ab.

Wenn Exchange Server Analyzer beim Erstellen der Liste keine Einträge findet, wird ein Fehler angezeigt.

Diese Fehler weist auf folgende Probleme hin:

  • Es gibt vorübergehende Netzwerk- oder Active Directory-Verbindungsprobleme, die Nachrichtenflussprobleme verursachen.

  • Das Konto, unter dem Exchange Server Analyzer ausgeführt wird, verfügt u. U. nicht über die erforderlichen Berechtigungen, um die Informationen abzufragen.

So beheben Sie diesen Fehler

  1. Stellen Sie sicher, dass der Exchange Server-Computer gestartet wurde und mit dem Netzwerk verbunden ist.

  2. Stellen Sie sicher, dass Sie über das Netzwerk mit einem Active Directory-Domänencontroller verbunden sind.

  3. Bestimmen Sie in Exchange Server Analyzer einen Active Directory-Domänencontroller.

  4. Verwenden Sie den Befehl PING, um festzustellen, ob eine Verbindung mit dem Exchange Server-Computer hergestellt werden kann.

  5. Wenn ein Firewall vorhanden ist, überprüfen Sie, ob die RPC-Anschlüsse blockiert sind.

  6. Überprüfen Sie die Berechtigungen für das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird. Das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird, muss über lokale Administratorberechtigungen für jeden durchsuchten Exchange-Server-Computer verfügen.

Weitere Informationen zu Problemen mit Netzwerkverbindungen finden Sie im Microsoft Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Weitere Informationen zu Verbindungsproblemen bei Exchange Server Analyzer finden Sie unter "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" (http://go.microsoft.com/fwlink/?LinkId=56285).

Weitere Informationen zu den Anforderungen hinsichtlich der Anschlüsse finden Sie im Knowledge Base-Artikel 832017, "Dienste und Netzwerk-Port-Anforderungen für das Microsoft Windows-Serversystem" (http://support.microsoft.com/?kbid=832017).


Keine Server verfügbar für SMTP-Befehlstests
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-10-16

Microsoft® Exchange Server Analyzer versucht, die vollqualifizierten Domänennamen (Fully Qualified Domain Name, FQDN), IP-Adressen und Domänennamen von Remoteservern, für die Nachrichten in einer Remoteübermittlungswarteschlange bestimmt sind, zu ermitteln und eine entsprechende Liste zu erstellen.

Die Liste der FQDNs, IP-Adressen und Domänennamen von Remoteservern wird folgendermaßen erstellt:

  • Die msExchSmtpFullyQualifiedDomainName-Eigenschaft des Active Directory®-Verzeichnisdienstobjekts für den virtuellen SMTP-Server (Simple Mail Transfer Protocol) wird angefragt.

    Hinweis:
    Die msExchSmtpFullyQualifiedDomainName-Eigenschaft wiederum wird aus der msExchTargetBridgeheadServersDN-Eigenschaft eines Verzeichnisobjekts für Routinggruppenconnectors gelesen, wenn das Objekt nach den angegebenen Bridgeheadzielservern abgefragt wird.
  • Die msExchSmtpSmartHost-Eigenschaft des Active Directory-Objekts für SMTP-Connectors wird nach dem angegebenen Smarthost für einen SMTP-Connector abgefragt.

  • Die LinkName-Eigenschaft der Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation, Windows® Management Instrumentation) ExchangeLink nach direkten Verbindungen zu Remoteservern ab.

Wenn Exchange Server Analyzer beim Erstellen der Liste keine Einträge findet, wird ein Fehler angezeigt.

Diese Fehler weist auf folgende Probleme hin:

  • Vorübergehende Netzwerk- oder Active Directory-Verbindungsprobleme verursachen möglicherweise Nachrichtenübermittlungsprobleme.

  • Das Konto, unter dem Exchange Server Analyzer ausgeführt wird, verfügt u. U. nicht über die erforderlichen Berechtigungen, um die Informationen abzufragen.

So beheben Sie diesen Fehler

  1. Stellen Sie sicher, dass der Server, auf dem Exchange Server ausgeführt wird, gestartet wurde und mit dem Netzwerk verbunden ist.

  2. Stellen Sie sicher, dass Sie über das Netzwerk mit einem Active Directory-Domänencontroller verbunden sind.

  3. Bestimmen Sie in Exchange Server Analyzer einen Active Directory-Domänencontroller.

  4. Verwenden Sie den Befehl PING, um festzustellen, ob eine Verbindung mit dem Exchange-Server hergestellt werden kann.

  5. Wenn eine Firewall vorhanden ist, überprüfen Sie, ob die RPC-Anschlüsse (Remote Procedure Call) blockiert sind.

  6. Überprüfen Sie die Berechtigungen für das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird. Das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird, muss über lokale Administratorberechtigungen für jeden durchsuchten Exchange-Server-Computer verfügen.

Weitere Informationen zu Problemen mit Netzwerkverbindungen finden Sie im Microsoft Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Weitere Informationen zu Verbindungsproblemen bei Exchange Server Analyzer finden Sie unter "Problembehandlung bei Verbindungsproblemen mit Microsoft Exchange Server Best Practices Analyzer" (http://go.microsoft.com/fwlink/?LinkId=56285).

Weitere Informationen zu den Anforderungen hinsichtlich der Anschlüsse finden Sie im Knowledge Base-Artikel 832017, "Dienste und Netzwerk-Port-Anforderungen für das Microsoft Windows-Serversystem" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Keine Server verfügbar für Verbindungstests
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-07-07

Microsoft® Exchange Server Analyzer versucht, die vollqualifizierten Domänennamen (Fully Qualified Domain Name, FQDN), IP-Adressen und Domänennamen von Remoteservern, für die Nachrichten in einer Remoteübermittlungswarteschlange bestimmt sind, zu ermitteln und eine entsprechende Liste zu erstellen.

  • Die Liste der FQDNs, IP-Adressen und Domänennamen von Remoteservern wird folgendermaßen erstellt:

  • Die msExchSmtpFullyQualifiedDomainName-Eigenschaft des Active Directory®-Verzeichnisdienstobjekts für den virtuellen SMTP-Server (Simple Mail Transfer Protocol) wird angefragt.

    Hinweis:
    Die msExchSmtpFullyQualifiedDomainName-Eigenschaft wiederum wird aus der msExchTargetBridgeheadServersDN-Eigenschaft eines Verzeichnisobjekts für Routinggruppenconnectors gelesen, wenn das Objekt nach den angegebenen Bridgeheadzielservern abgefragt wird.
  • Die msExchSmtpSmartHost-Eigenschaft des Active Directory-Objekts für SMTP-Connectors wird nach dem angegebenen Smarthost für einen SMTP-Connector abgefragt.

  • Die LinkName-Eigenschaft der Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation, Windows® Management Instrumentation) ExchangeLink nach direkten Verbindungen zu Remoteservern ab.

Wenn Exchange Server Analyzer beim Erstellen der Liste keine Einträge findet, wird ein Fehler angezeigt.

Diese Fehler weist auf folgende Probleme hin:

  • Es gibt vorübergehende Netzwerk- oder Active Directory-Verbindungsprobleme, die Nachrichtenflussprobleme verursachen.

  • Das Konto, unter dem Exchange Server Analyzer ausgeführt wird, verfügt u. U. nicht über die erforderlichen Berechtigungen, um die Informationen abzufragen.

So beheben Sie diesen Fehler

  1. Stellen Sie sicher, dass der Exchange Server-Computer gestartet wurde und mit dem Netzwerk verbunden ist.

  2. Stellen Sie sicher, dass Sie über das Netzwerk mit einem Active Directory-Domänencontroller verbunden sind.

  3. Bestimmen Sie in Exchange Server Analyzer einen Active Directory-Domänencontroller.

  4. Verwenden Sie den Befehl PING, um festzustellen, ob eine Verbindung mit dem Exchange Server-Computer hergestellt werden kann.

  5. Wenn ein Firewall vorhanden ist, überprüfen Sie, ob die RPC-Anschlüsse blockiert sind.

  6. Überprüfen Sie die Berechtigungen für das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird. Das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird, muss über lokale Administratorberechtigungen für jeden durchsuchten Exchange-Server-Computer verfügen.

Weitere Informationen zu Problemen mit Netzwerkverbindungen finden Sie im Microsoft Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Weitere Informationen zu Verbindungsproblemen bei Exchange Server Analyzer finden Sie unter "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" (http://go.microsoft.com/fwlink/?LinkId=56285).

Weitere Informationen zu den Anforderungen hinsichtlich der Anschlüsse finden Sie im Knowledge Base-Artikel 832017, "Dienste und Netzwerk-Port-Anforderungen für das Microsoft Windows-Serversystem" (http://support.microsoft.com/?kbid=832017).


Keine Server für Überprüfungen von SMTP-Instanznamen verfügbar
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-07-07

Microsoft® Exchange Server Analyzer versucht, die vollqualifizierten Domänennamen (Fully Qualified Domain Name, FQDN), IP-Adressen und Domänennamen von Remoteservern, für die Nachrichten in einer Remoteübermittlungswarteschlange bestimmt sind, zu ermitteln und eine entsprechende Liste zu erstellen.

Die Liste der FQDNs, IP-Adressen und Domänennamen von Remoteservern wird folgendermaßen erstellt:

  • Die msExchSmtpFullyQualifiedDomainName-Eigenschaft des Active Directory®-Verzeichnisdienstobjekts für den virtuellen SMTP-Server (Simple Mail Transfer Protocol) wird angefragt.

    Hinweis:
    Die msExchSmtpFullyQualifiedDomainName-Eigenschaft wiederum wird aus der msExchTargetBridgeheadServersDN-Eigenschaft eines Verzeichnisobjekts für Routinggruppenconnectors gelesen, wenn das Objekt nach den angegebenen Bridgeheadzielservern abgefragt wird.
  • Die msExchSmtpSmartHost-Eigenschaft des Active Directory-Objekts für SMTP-Connectors wird nach dem angegebenen Smarthost für einen SMTP-Connector abgefragt.

  • Die LinkName-Eigenschaft der Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation, Windows® Management Instrumentation) ExchangeLink nach direkten Verbindungen zu Remoteservern ab.

Wenn Exchange Server Analyzer beim Erstellen der Liste keine Einträge findet, wird ein Fehler angezeigt.

Diese Fehler weist auf folgende Probleme hin:

  • Es gibt vorübergehende Netzwerk- oder Active Directory-Verbindungsprobleme, die Nachrichtenflussprobleme verursachen.

  • Das Konto, unter dem Exchange Server Analyzer ausgeführt wird, verfügt u. U. nicht über die erforderlichen Berechtigungen, um die Informationen abzufragen.

So beheben Sie diesen Fehler

  1. Stellen Sie sicher, dass der Exchange Server-Computer gestartet wurde und mit dem Netzwerk verbunden ist.

  2. Stellen Sie sicher, dass Sie über das Netzwerk mit einem Active Directory-Domänencontroller verbunden sind.

  3. Bestimmen Sie in Exchange Server Analyzer einen Active Directory-Domänencontroller.

  4. Verwenden Sie den Befehl PING, um festzustellen, ob eine Verbindung mit dem Exchange Server-Computer hergestellt werden kann.

  5. Wenn ein Firewall vorhanden ist, überprüfen Sie, ob die RPC-Anschlüsse blockiert sind.

  6. Überprüfen Sie die Berechtigungen für das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird. Das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird, muss über lokale Administratorberechtigungen für jeden durchsuchten Exchange-Server-Computer verfügen.

Weitere Informationen zu Problemen mit Netzwerkverbindungen finden Sie im Microsoft Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Weitere Informationen zu Verbindungsproblemen bei Exchange Server Analyzer finden Sie unter "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" (http://go.microsoft.com/fwlink/?LinkId=56285).

Weitere Informationen zu den Anforderungen hinsichtlich der Anschlüsse finden Sie im Knowledge Base-Artikel 832017, "Dienste und Netzwerk-Port-Anforderungen für das Microsoft Windows-Serversystem" (http://support.microsoft.com/?kbid=832017).


Die Zwischenspeichereinstellung für den Routingdienst weicht von der Standardeinstellung ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die Standardeinstellung für den Zwischenspeicher des Routingdiensts geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\

Wenn Exchange Server Analyzer feststellt, dass der Registrierungswert ServerCacheRefreshInterval manuell erstellt wurde, wobei die binäre Standardeinstellung des Exchange-Servers von 900 geändert wurde, zeigt Exchange Server Analyzer eine Warnmeldung an. In der Standardeinstellung wird der Registrierungswert ServerCacheRefreshInterval von einer Exchange Server-Installation nicht erstellt. Der Registrierungswert ServerCacheRefreshInterval kann jedoch nach der Installation von Exchange Server manuell erstellt werden, um die Standardeinstellung für den Zwischenspeicher des Routingdiensts zu ändern. Wenn der Registrierungswert manuell erstellt wird und die Einstellung für den Registrierungswert falsch konfiguriert ist, können für den Exchange-Server Probleme bei der Mailübermittlung auftreten.

Es wird empfohlen, den Registrierungswert ServerCacheRefreshInterval nur nach gründlicher Überlegung zu erstellen oder zu ändern. Die Standardwerte in den Binärdateien für Exchange Server wurden sorgfältig ausgewählt, um eine optimale Leistung bei Verwendung in den meisten Exchange Server-Umgebungen zu gewährleisten. Im Allgemeinen hat es sich bewährt, die Ursache des Problems zu beheben, anstatt das Standardverhalten von Exchange Server durch manuelle Konfiguration der Registrierung zu ändern. Um dieser Empfehlung zu folgen, können Sie ggf. den Registrierungswert ServerCacheRefreshInterval löschen, um den Exchange-Server wieder in der binären Standardeinstellung für den Routingdienstzwischenspeicher zu konfigurieren. Dies hängt jedoch von den benutzerdefinierten Konfigurationseinstellungen für Exchange Server oder der Exchange-Umgebung ab.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Sie können jedoch den Registrierungswert auch durch Bearbeiten der Registrierung wieder auf die Standardeinstellung festlegen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess vertraut sind. Informationen hierzu finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedit32.exe.
So beheben Sie diese Warnung

  1. Klicken Sie auf Start, klicken Sie auf Ausführen, und geben Sie Regedit ein. Klicken Sie anschließend auf OK.

  2. Suchen Sie in der Konsolenstruktur den folgenden Registrierungsschlüssel, und klicken Sie darauf: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\RESvc\Parameters\

  3. Klicken Sie im Detailbereich mit der rechten Maustaste auf den Registrierungswert ServerCacheRefreshInterval. Ändern Sie den Datenwert in 900.

  4. Sie können auch im Detailbereich mit der rechten Maustaste auf den Registrierungswert ServerCacheRefreshInterval klicken und dann auf Löschen klicken. Bestätigen Sie das Löschen des Registrierungswerts, indem Sie im Dialogfeld auf Ja klicken.

  5. Starten Sie den Exchange-Server neu.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zum Bearbeiten der Microsoft Windows-Registrierung finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 322755, „SO WIRD'S GEMACHT: Unter Windows 2000 eine Sicherungskopie der Registrierung erstellen und die Registrierung bearbeiten und wiederherstellen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, "How to back up, edit, and restore the registry in Windows XP and Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756).


Vom Standard abweichender SMTP-Registrierungswert „LdapRequestTimeLimit"
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Standardwert für LdapRequestTimeLimit geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Wenn Exchange Server Best Practices Analyzer feststellt, dass der Registrierungswert LdapRequestTimeLimit manuell erstellt wurde, um die binäre Standardeinstellung des Exchange-Servers von 600 Sekunden zu ändern, zeigt Microsoft Exchange Server Analyzer eine Warnmeldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht. In der Standardeinstellung wird der Registrierungswert LdapRequestTimeLimit von einer Exchange Server-Installation nicht erstellt. Der Registrierungswert LdapRequestTimeLimit kann jedoch nach der Installation des Exchange Servers manuell erstellt werden, um für eine LDAP-Anforderung die maximale Wartezeit in Sekunden in der Warteschlange zu ändern. Wenn der Registrierungswert manuell erstellt wird und die Einstellung für den Registrierungswert falsch konfiguriert ist, können für den Exchange-Server Probleme beim Nachrichtentransport auftreten.

Es wird empfohlen, den Registrierungswert LdapRequestTimeLimit nur nach gründlicher Überlegung zu erstellen oder zu ändern. Die Standardwerte in den Binärdateien für Exchange-Server wurden sorgfältig ausgewählt, um eine optimale Leistung bei Verwendung in den meisten Exchange-Serverumgebungen zu gewährleisten. Im Allgemeinen hat es sich bewährt, die Ursache des Problems zu beheben, anstatt das Standardverhalten von Exchange Server durch manuelle Konfiguration der Registrierung zu ändern. Um dieser Empfehlung zu folgen, können Sie ggf. den Registrierungswert LdapRequestTimeLimit löschen, um den Exchange-Server wieder in der binären Standardeinstellung zu konfigurieren.

Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Möglicherweise möchten Sie jedoch den Registrierungswert durch Bearbeiten der Registrierung wieder auf die Standardeinstellung festlegen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess vertraut sind. Informationen hierzu finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedit32.exe.
So beheben Sie diese Warnung

  1. Klicken Sie auf Start, klicken Sie auf Ausführen, und geben Sie Regedit ein. Klicken Sie anschließend auf OK.

  2. Suchen Sie in der Konsolenstruktur den folgenden Registrierungsschlüssel, und klicken Sie darauf: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Klicken Sie im Detailbereich mit der rechten Maustaste auf den Registrierungswert LdapRequestTimeLimit. Ändern Sie den Datenwert in 600.

  4. Sie können auch im Detailbereich mit der rechten Maustaste auf den Registrierungswert LdapRequestTimeLimit klicken und dann auf Löschen klicken. Bestätigen Sie das Löschen des Registrierungswerts, indem Sie im Dialogfeld auf Ja klicken.

  5. Starten Sie den Exchange-Server neu.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zum Bearbeiten der Microsoft Windows-Registrierung finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 322755, „SO WIRD'S GEMACHT: Unter Windows 2000 eine Sicherungskopie der Registrierung erstellen und die Registrierung bearbeiten und wiederherstellen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, „Unter Windows XP und Windows Server 2003 eine Sicherungskopie der Registrierung erstellen und die Registrierung bearbeiten und wiederherstellen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Vom Standard abweichender SMTP-Registrierungswert „LdapResultTimeout"
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Standardwert für LdapResultTimeout geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Wenn Exchange Server Analyzer feststellt, dass der Registrierungsschlüssel LdapResultTimeout manuell erstellt wurde, wobei die binäre Standardeinstellung des Exchange-Servers von 121 Sekunden geändert wurde, zeigt Microsoft Exchange Server Analyzer eine Warnmeldung an, die angibt, dass die Konfiguration nicht der Standardkonfiguration entspricht. Standardmäßig wird der Registrierungsschlüssel LdapResultTimeout von einer Exchange Server-Installation nicht erstellt. Der Registrierungsschlüssel LdapResultTimeout kann jedoch nach der Installation von Exchange Server manuell erstellt werden, um den Wert für das Zeitlimit zu ändern. LdapResultTimeout entspricht der maximalen Zeit in Sekunden, die der LDAP-Abschluss-Thread für LDAP-Verbindungen des Kategorisierungsmoduls bis zur Verarbeitung wartet. Wenn das Zeitlimit überschritten wird und von einem globalen Katalogserver keine neuen Ergebnisse empfangen wurden, schlagen die anstehenden Suchvorgänge für die Verbindung mit LDAP_SERVER_DOWN fehl. Dieser Prozess ermöglicht dann, dass diese anstehenden Suchvorgänge für neue Verbindungen erneut gesendet werden. Wenn der Registrierungswert manuell erstellt wird und die Einstellung für den Registrierungswert falsch konfiguriert ist, können für den Exchange-Server Probleme beim Nachrichtentransport auftreten.

Es wird empfohlen, den Registrierungswert LdapResultTimeout nur nach gründlicher Überlegung zu erstellen oder zu ändern. Die Standardwerte in den Binärdateien für Exchange Server wurden sorgfältig ausgewählt, um eine optimale Leistung bei Verwendung in den meisten Exchange Server-Umgebungen zu gewährleisten. Allgemein hat es sich bewährt, die Ursache des Problems zu beheben, anstatt das Standardverhalten von Exchange durch manuelle Konfiguration der Registrierung zu ändern. Um dieser Empfehlung zu folgen, können Sie ggf. den Registrierungswert LdapResultTimeout löschen, um den Exchange-Server wieder in der binären Standardeinstellung zu konfigurieren.

Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Möglicherweise möchten Sie jedoch den Registrierungswert durch Bearbeiten der Registrierung wieder auf die Standardeinstellung festlegen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess vertraut sind. Informationen hierzu finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedit32.exe.
So beheben Sie diese Warnmeldung

  1. Klicken Sie auf Start, klicken Sie auf Ausführen, und geben Sie Regedit ein. Klicken Sie anschließend auf OK.

  2. Suchen Sie in der Konsolenstruktur den folgenden Registrierungsschlüssel, und klicken Sie darauf: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Klicken Sie im Detailbereich mit der rechten Maustaste auf den Registrierungswert LdapResultTimeout. Ändern Sie den Datenwert in 121.

  4. Sie können auch im Detailbereich mit der rechten Maustaste auf den Registrierungswert LdapResultTimeout klicken und dann auf Löschen klicken. Bestätigen Sie das Löschen des Registrierungswerts, indem Sie im Dialogfeld auf Ja klicken.

  5. Starten Sie den Exchange-Server neu.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zum Bearbeiten der Microsoft Windows-Registrierung finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 322755, „SO WIRD'S GEMACHT: Unter Windows 2000 eine Sicherungskopie der Registrierung erstellen und die Registrierung bearbeiten und wiederherstellen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, „Unter Windows XP und Windows Server 2003 eine Sicherungskopie der Registrierung erstellen und die Registrierung bearbeiten und wiederherstellen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Vom Standard abweichender SMTP-Registrierungswert „MaxConnectionRetries"
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Standardwert für MaxConnectionRetries geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Wenn Exchange Server Analyzer feststellt, dass der Registrierungswert MaxConnectionRetries manuell erstellt wurde, wobei die binäre Standardeinstellung des Exchange-Servers von 20 geändert wurde, zeigt Exchange Server Analyzer eine Warnmeldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht. In der Standardeinstellung wird der Registrierungswert MaxConnectionRetries von einer Exchange Server-Installation nicht erstellt. Der Registrierungswert MaxConnectionRetries kann jedoch nach der Installation von Exchange Server manuell erstellt werden, um den Wert zu ändern. Der Wert MaxConnectionRetries legt fest, wie oft bei einer einzelnen Kategorisierung der Aufbau einer LDAP-Verbindung maximal fehlschlagen und diese Kategorisierung in einer neuen Verbindung erneut ausgegeben werden kann. Nach dem Fehlschlagen der Verbindungskategorisierung von MaxConnectionRetries wird diese in der Warteschlange der Verbindungswiederholungen platziert. Wenn der Registrierungswert manuell erstellt wird und die Einstellung für den Registrierungswert falsch konfiguriert ist, können für den Exchange-Server Probleme beim Nachrichtentransport auftreten.

Es wird empfohlen, den Registrierungswert MaxConnectionRetries nur nach gründlicher Überlegung zu erstellen oder zu ändern. Die Standardwerte in den Binärdateien für Exchange Server wurden sorgfältig ausgewählt, um eine optimale Leistung bei Verwendung in den meisten Exchange Server-Umgebungen zu gewährleisten. Im Allgemeinen hat es sich bewährt, die Ursache des Problems zu beheben, anstatt das Standardverhalten von Exchange Server durch manuelle Konfiguration der Registrierung zu ändern. Um dieser Empfehlung zu folgen, können Sie den Registrierungswert MaxConnectionRetries löschen, falls er vorhanden ist, um den Exchange-Server wieder in der binären Standardeinstellung zu konfigurieren.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Möglicherweise möchten Sie jedoch den Registrierungswert durch Bearbeiten der Registrierung wieder auf die Standardeinstellung festlegen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess vertraut sind. Informationen hierzu finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedit32.exe.
So beheben Sie diese Warnung

  1. Klicken Sie auf Start, klicken Sie auf Ausführen, und geben Sie Regedit ein. Klicken Sie anschließend auf OK.

  2. Suchen Sie in der Konsolenstruktur den folgenden Registrierungsschlüssel, und klicken Sie darauf: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Klicken Sie im Detailbereich mit der rechten Maustaste auf den Registrierungswert MaxConnectionRetries. Ändern Sie den Wert in 20.

  4. Sie können auch im Detailbereich mit der rechten Maustaste auf den Registrierungswert MaxConnectionRetries klicken und dann auf Löschen klicken. Bestätigen Sie das Löschen des Registrierungswerts, indem Sie im Dialogfeld auf Ja klicken.

  5. Starten Sie den Exchange-Server erneut.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://support.microsoft.com/kb/256986/de).

Weitere Informationen zum Bearbeiten der Microsoft Windows-Registrierung finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 322755, „SO WIRD'S GEMACHT: Unter Windows 2000 eine Sicherungskopie der Registrierung erstellen und die Registrierung bearbeiten und wiederherstellen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, „Unter Windows XP und Windows Server 2003 eine Sicherungskopie der Registrierung erstellen und die Registrierung bearbeiten und wiederherstellen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Vom Standard abweichender SMTP-Registrierungswert „MaxLdapConnections"
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Standardwert für MaxLdapConnections geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Wenn Exchange Server Analyzer feststellt, dass der Registrierungswert MaxLdapConnections manuell erstellt wurde, wobei die binäre Standardeinstellung des Exchange-Servers von 8 geändert wurde, zeigt Exchange Server Analyzer eine Warnmeldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht. In der Standardeinstellung wird der Registrierungswert MaxLdapConnections von einer Exchange-Installation nicht erstellt. Der Registrierungswert MaxLdapConnections kann jedoch nach der Installation von Exchange manuell erstellt werden, um den Wert zu ändern. Der Wert MaxLdapConnections legt die maximale Anzahl von LDAP-Verbindungen fest, die das Kategorisierungsmodul für einen einzelnen globalen Katalogserver öffnet. Wenn der Registrierungswert manuell erstellt wird und die Einstellung für den Registrierungswert falsch konfiguriert ist, können für den Exchange-Server Probleme beim Nachrichtentransport auftreten.

Achtung:
Der Registrierungswert MaxLdapConnections muss zu jedem Zeitpunkt mit der Einstellung des Registrierungswerts HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters\MaxPoolThreads übereinstimmen.

Es wird empfohlen, den Registrierungswert MaxLdapConnections nur nach gründlicher Überlegung zu erstellen oder zu ändern. Die Standardwerte in den Binärdateien für Exchange-Server wurden sorgfältig ausgewählt, um eine optimale Leistung bei Verwendung in den meisten Exchange-Serverumgebungen zu gewährleisten. Im Allgemeinen hat es sich bewährt, die Ursache des Problems zu beheben, anstatt das Standardverhalten von Exchange Server durch manuelle Konfiguration der Registrierung zu ändern. Um dieser Empfehlung zu folgen, können Sie ggf. den Registrierungswert MaxLdapConnections löschen, um den Exchange-Server wieder in der binären Standardeinstellung zu konfigurieren.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Möglicherweise möchten Sie jedoch den Registrierungswert durch Bearbeiten der Registrierung wieder auf die Standardeinstellung festlegen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess vertraut sind. Informationen hierzu finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedit32.exe.
So beheben Sie diese Warnung

  1. Klicken Sie auf Start, klicken Sie auf Ausführen, und geben Sie Regedit ein. Klicken Sie anschließend auf OK.

  2. Suchen Sie in der Konsolenstruktur den folgenden Registrierungsschlüssel, und klicken Sie darauf: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Klicken Sie im Detailbereich mit der rechten Maustaste auf den Registrierungswert MaxLdapConnections. Ändern Sie den Datenwert in 8.

  4. Sie können auch im Detailbereich mit der rechten Maustaste auf den Registrierungswert MaxLdapConnections klicken und dann auf Löschen klicken. Bestätigen Sie das Löschen des Registrierungswerts, indem Sie im Dialogfeld auf Ja klicken.

  5. Starten Sie den Exchange-Server neu.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://support.microsoft.com/kb/256986/de).

Weitere Informationen zum Bearbeiten der Microsoft Windows-Registrierung finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 322755, „SO WIRD'S GEMACHT: Unter Windows 2000 eine Sicherungskopie der Registrierung erstellen und die Registrierung bearbeiten und wiederherstellen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, „Unter Windows XP und Windows Server 2003 eine Sicherungskopie der Registrierung erstellen und die Registrierung bearbeiten und wiederherstellen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Vom Standard abweichender SMTP-Registrierungswert „MaxPendingSearches"
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Standardwert für MaxPendingSearches geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Wenn Exchange Server Analyzer feststellt, dass der Registrierungswert MaxPendingSearches manuell erstellt wurde, wobei die binäre Standardeinstellung des Exchange-Servers von 60 geändert wurde, zeigt Exchange Server Analyzer eine Warnmeldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht. In der Standardeinstellung wird der Registrierungswert MaxPendingSearches von einer Exchange Server-Installation nicht erstellt. Der Registrierungswert MaxPendingSearches kann jedoch nach der Installation von Exchange Server manuell erstellt werden, um den Wert zu ändern. Der Wert MaxPendingSearches legt die Anzahl der ausstehenden LDAP-Suchvorgänge fest, die im Kategorisierungsmodul zu einem bestimmten Zeitpunkt für einen bestimmten globalen Katalogserver vorhanden sind. Die maximale Anzahl der anstehenden Suchvorgänge pro Verbindung betrug in Exchange 2000 Server vor SP3 1024. Der Standardwert ist in Exchange 2000 Server SP3 und Exchange Server 2003 auf 60 festgelegt. Eine Änderung dieses Werts vom Standardwert 60 auf 30 reduziert beispielsweise die Gesamtanzahl der LDAP-Suchvorgänge, die im Kategorisierungsmodul für den globalen Katalogserver anstehen.

Wenn der Registrierungswert manuell erstellt wird und die Einstellung für den Registrierungswert falsch konfiguriert ist, können für den Exchange-Server Probleme beim Nachrichtentransport auftreten.

Es wird empfohlen, den Registrierungswert MaxPendingSearches nur nach gründlicher Überlegung zu erstellen oder zu ändern. Die Standardwerte in den Binärdateien für Exchange-Server wurden sorgfältig ausgewählt, um eine optimale Leistung bei Verwendung in den meisten Exchange-Serverumgebungen zu gewährleisten. Allgemein hat es sich bewährt, die Ursache des Problems zu beheben, anstatt das Standardverhalten von Exchange durch manuelle Konfiguration der Registrierung zu ändern. Um dieser Empfehlung zu folgen, können Sie ggf. den Registrierungswert MaxPendingSearches löschen, um den Exchange-Server wieder in der binären Standardeinstellung zu konfigurieren.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Möglicherweise möchten Sie jedoch den Registrierungswert durch Bearbeiten der Registrierung wieder auf die Standardeinstellung festlegen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess vertraut sind. Informationen hierzu finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedit32.exe.
So beheben Sie diese Warnung

  1. Klicken Sie auf Start, klicken Sie auf Ausführen, und geben Sie Regedit ein. Klicken Sie anschließend auf OK.

  2. Suchen Sie in der Konsolenstruktur den folgenden Registrierungsschlüssel, und klicken Sie darauf: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Klicken Sie im Detailbereich mit der rechten Maustaste auf den Registrierungswert MaxPendingSearches. Ändern Sie den Datenwert in 60.

  4. Sie können auch im Detailbereich mit der rechten Maustaste auf den Registrierungswert MaxPendingSearches klicken und dann auf Löschen klicken. Bestätigen Sie das Löschen des Registrierungswerts, indem Sie im Dialogfeld auf Ja klicken.

  5. Starten Sie den Exchange-Server neu.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zum Bearbeiten der Microsoft Windows-Registrierung finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

•322755, „SO WIRD'S GEMACHT: Unter Windows 2000 eine Sicherungskopie der Registrierung erstellen und die Registrierung bearbeiten und wiederherstellen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

•322756, „Unter Windows XP und Windows Server 2003 eine Sicherungskopie der Registrierung erstellen und die Registrierung bearbeiten und wiederherstellen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Vom Standard abweichender SMTP-Registrierungswert „MaxSearchBlockSize".
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Standardwert für MaxSearchBlockSize geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Wenn Exchange Server Best Practices Analyzer feststellt, dass der Registrierungswert MaxSearchBlockSize manuell erstellt wurde, wobei die binäre Standardeinstellung des Exchange-Servers von 20 geändert wurde, zeigt Exchange Server Best Practices Analyzer eine Warnmeldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht. In der Standardeinstellung wird der Registrierungswert MaxSearchBlockSize von einer Exchange Server-Installation nicht erstellt. Der Registrierungswert MaxSearchBlockSize kann jedoch nach der Installation von Exchange Server manuell erstellt werden, um den Wert zu ändern. Mit dem Wert MhelpsBlockSize wird die maximale Anzahl an Suchvorgängen des Kategorisierungsmoduls festgelegt, die zusammen als einzelne LDAP-Suche übergeben werden können. Durch Festlegen der maximalen Anzahl an Suchvorgängen des Kategorisierungsmoduls können Sie die Suchfilter für das Kategorisierungsmodul vereinfachen.

Mithilfe dieses Prozesses können die anstehenden Suchvorgänge für neue Verbindungen erneut gesendet werden. Wenn der Registrierungswert manuell erstellt wird und die Einstellung für den Registrierungswert falsch konfiguriert ist, können für den Exchange-Server Probleme beim Nachrichtentransport auftreten.

Es wird empfohlen, den Registrierungswert MaxSearchBlockSize nur nach gründlicher Überlegung zu erstellen oder zu ändern. Die Standardwerte in den Binärdateien für Exchange Server wurden sorgfältig ausgewählt, um eine optimale Leistung bei Verwendung in den meisten Exchange Server-Umgebungen zu gewährleisten. Allgemein hat es sich bewährt, die Ursache des Problems zu beheben, anstatt das Standardverhalten von Exchange Server durch manuelle Konfiguration der Registrierung zu ändern. Um dieser Empfehlung zu folgen, können Sie ggf. den Registrierungswert MaxSearchBlockSize löschen, um den Exchange-Server wieder in der binären Standardeinstellung zu konfigurieren.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Möglicherweise möchten Sie jedoch den Registrierungswert durch Bearbeiten der Registrierung wieder auf die Standardeinstellung festlegen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess vertraut sind. Informationen hierzu finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedit32.exe.
So beheben Sie diese Warnmeldung

  1. Klicken Sie auf Start, klicken Sie auf Ausführen, und geben Sie Regedit ein. Klicken Sie anschließend auf OK.

  2. Suchen Sie in der Konsolenstruktur den folgenden Registrierungsschlüssel, und klicken Sie darauf: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Klicken Sie im Detailbereich mit der rechten Maustaste auf den Registrierungswert MaxSearchBlockSize. Ändern Sie den Datenwert in 20.

  4. Sie können auch im Detailbereich mit der rechten Maustaste auf den Registrierungswert MaxSearchBlockSize klicken und dann auf Löschen klicken. Bestätigen Sie das Löschen des Registrierungswerts, indem Sie im Dialogfeld auf Ja klicken.

  5. Starten Sie den Exchange-Server neu.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zum Bearbeiten der Microsoft Windows-Registrierung finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 322755, „SO WIRD'S GEMACHT: Unter Windows 2000 eine Sicherungskopie der Registrierung erstellen und die Registrierung bearbeiten und wiederherstellen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, „Unter Windows XP und Windows Server 2003 eine Sicherungskopie der Registrierung erstellen und die Registrierung bearbeiten und wiederherstellen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Vom Standard abweichender SMTP-Registrierungswert „TopoRecheckSecs"
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Standardwert für diesen geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\TopoRecheckSecs.

Wenn Exchange Server Analyzer erkennt, dass der Wert von TopoRecheckSecs nicht dem Standardwert von 900 Sekunden entspricht, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht. Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich, da DSAccess den Wert des Registrierungswerts TopoRecheckSecs verwendet, um das Intervall festzulegen, nach dem die globale Katalogliste neu erstellt wird. Wenn die Einstellung nicht ordnungsgemäß festgelegt wurde, kann die Leistung beeinträchtigt werden. Die empfohlene Vorgehensweise besteht in der Verwendung der Standardkonfigurationseinstellungen für Exchange Server (sofern möglich). Wenn dieser Registrierungswert jedoch vorhanden ist, wurde dieser möglicherweise auf Empfehlung des technischen Supports von Microsoft zum Beheben eines zuvor aufgetretenen Problems hinzugefügt und konfiguriert. Wenn dieser Registrierungswert nicht auf Anraten des technischen Supports von Microsoft oder eines anderen Experten hinzugefügt und konfiguriert wurde, sollten Sie diesen Registrierungswert möglicherweise entfernen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So löschen Sie den Registrierungsschlüssel „TopoRecheckSecs"

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess

  3. Suchen Sie im rechten Bereich den Wert TopoRecheckSecs, und löschen Sie ihn.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie die Systemaufsicht erneut, damit diese Änderung dauerhaft wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Optimieren der Platzierung des globalen Katalogs für Exchange Server finden Sie unter Understanding and Troubleshooting Directory Access (http://go.microsoft.com/fwlink/?LinkId=39012).


Ein nicht auf Exchange basierender Gatewayserver ist nicht als SmartHost festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-09

Microsoft® Exchange Server Analyzer fragt im Active Directory®-Verzeichnisdienst den Wert des Attributs distingushedName der Objektklasse protocolCfgSMTPServer ab, um alle Instanzen eines virtuellen SMTP-Servers (Simple Mail Transfer Protocol) auf dem vom Benutzer angegebenen Gateway aufzulisten.

Anschließend fragt Exchange Server Analyzer in Active Directory den Wert der Attribute msExchSourceBridgeheadServersDN und routingList für jedes gefundene msExchRoutingSMTPConnector-Objekt ab, um festzustellen, ob für einen SMTP-Connector eine der erkannten Instanzen des virtuellen SMTP-Servers als lokaler Bridgehead zu einem externen SMTP-Adressraum korrekt festgelegt ist.

Schließlich fragt Exchange Server Analyzer in Active Directory den Wert des Attributs msExchSmtpSmartHost auf allen erkannten SMTP-Connectors (msExchRoutingSMTPConnector-Objekt) ab, um zu ermitteln, ob einer der Server als Smarthost für den vom Benutzer angegebenen nicht auf Exchange basierenden Gatewayserver festgelegt ist.

Wenn Exchange Server Analyzer feststellt, dass der vom Benutzer angegebene nicht auf Exchange basierende Gatewayserver nicht als Smarthost für einen der SMTP-Connectors eingerichtet ist, zeigt Exchange Server Analyzer eine Warnung an.

Diese Warnung gibt an, dass von dem vom Benutzer angegebenen Exchange-Gatewayserver zu dem vom Benutzer angegebenen nicht auf Exchange basierenden Gatewayserver keine explizite Route eingerichtet wurde und dass andere Server als der nicht auf Exchange basierende Gatewayserver möglicherweise unbeabsichtigterweise Nachrichten nach außerhalb der Organisation routen.

Um dieses Problem zu beheben, legen Sie den nicht auf Exchange basierenden Gatewayserver als Smarthost für einen SMTP-Connector fest.

So zeigen Sie Smarthosteinstellungen an und konfigurieren diese

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Server, erweitern Sie einen Exchange-Server, erweitern Sie Protokolle, und erweitern Sie dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise Virtuelle Standardserver für SMTP), und wählen Sie dann Eigenschaften aus.

  4. Wählen Sie die Registerkarte Übermittlung aus, und klicken Sie auf Erweitert.

  5. Geben Sie den Smarthost ein, den Sie verwenden möchten. Sie können den Smarthost anhand des vollständig qualifizierten Domänenamens oder einer IP-Adresse identifizieren. Wenn Sie eine IP-Adresse verwenden, müssen Sie diese in eckige Klammern ([ ]) setzen. Exchange sucht zunächst nach einem Servernamen und dann nach einer IP-Adresse. Durch die Klammern wird der Wert als IP-Adresse gekennzeichnet. Auf diese Weise werden DNS-Lookups umgangen.

  6. Auf einem Server unter Exchange 2000 Server können Sie optional das Kontrollkästchen Direkte Übermittlung versuchen, bevor zum Smarthost gesendet wird aktivieren.

  7. Klicken Sie auf OK, um die Änderungen zu speichern, und klicken Sie dann auf OK, um das Dialogfeld Eigenschaften des virtuellen SMTP-Servers zu schließen.

Weitere Informationen zum Konfigurieren eines Smarthostconnectors finden Sie im Microsoft Knowledge Base-Artikel 821911, "So konfigurieren Sie Exchange Server 2003 für die Verwendung einer Smarthost-IP-Adresse" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821911).

Weitere Informationen zur Verwendung von SMTP-Connectors finden Sie im Microsoft Knowledge Base-Artikel 294736, "Gründe für das Erstellen von SMTP-Connectors in Exchange 2000 und höher" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=294736).

Weitere Informationen zu SMTP-Connectors finden Sie im Transport- und Routing-Handbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


Mögliche Überlastung des Kategorisierungsmoduls
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-09-06

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst Daten des Leistungsindikators Kat: Übergebene Nachrichten/Sek. und des Leistungsindikators Kat: Abgeschlossene Kategorisierungen/s des Leistungsobjekts SMTP Server, um Leistungsdaten zu analysieren.

Der Leistungsindikator Kat: Übergebene Nachrichten/Sek. zeigt die Anzahl der Nachrichten an, die pro Sekunde an das Kategorisierungsmodul übergeben wurden, wohingegen der Leistungsindikator Kat: Abgeschlossene Kategorisierungen/s die Rate der pro Sekunde abgeschlossenen Kategorisierungen anzeigt.

Exchange Server Analyzer vergleicht die durchschnittliche Gesamtzahl der beiden Leistungsindikatoren, um zu ermitteln, ob ständig mehr Nachrichten übergeben als verarbeitet werden.

Wenn Exchange Server Analyzer feststellt, dass die durchschnittliche Gesamtanzahl der pro Sekunde an das Kategorisierungsmodul übergebenen Nachrichten ständig um zwei Nachrichten größer ist als die durchschnittliche Gesamtanzahl der pro Sekunde abgeschlossenen Nachrichten, zeigt Exchange Server Analyzer eine Warnung an.

Das Kategorisierungsmodul führt die folgenden Kernoperationen aus:

  • Auflösen und Validieren aller Empfänger.

  • Ermitteln von Grenzwerten und Einschränkungen für alle Empfänger.

  • Erweitern von Verteilerlisten, falls erforderlich.

  • Ermitteln, ob eine Nachricht für die lokale oder Remoteübermittlung bestimmt ist.

Diese Warnung zeigt an, dass das Kategorisierungsmodul möglicherweise überbeansprucht ist. Sie sollten die möglichen Ursachen untersuchen und gegebenenfalls entsprechende Maßnahmen ergreifen.

Ursache für eine Überbeanspruchung des Kategorisierungsmoduls kann die Anforderung der Verarbeitung sehr vieler Nachrichten sein. Mögliche Gründe hierfür:

  • Unerwünschte kommerzielle E-Mails oder Spam.

  • Ausbreitung von Viren.

  • Probleme mit der Serverleistung.

So beheben Sie diese Warnung

  • Ermitteln Sie, ob die übermäßige Beanspruchung des Kategorisierungsmoduls erwartet wurde oder ihre Ursache in einer typischen Belastung liegt. Lesen Sie in diesem Fall in den folgenden Microsoft TechNet-Artikeln die Anleitungen im Hinblick auf die Leistung von Exchange.

    • "Behandeln von Leistungsproblemen bei Microsoft Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47588).

    • "Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Wurde die übermäßige Beanspruchung des Kategorisierungsmoduls nicht durch eine erwartete Belastung verursacht, prüfen Sie ob Virusbefall oder Spam dafür verantwortlich ist.


Mögliches Gatewayproblem
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-09

Microsoft® Exchange Server Analyzer sendet von dem Server aus, auf dem Exchange Server ausgeführt wird, eine Testnachricht an ein benutzerdefiniertes externes Konto. Exchange Server Analyzer überprüft anschließend die Nachrichtenverfolgungsprotokolle des Servers, um zu ermitteln, ob bei der Übermittlung der Testnachricht Probleme aufgetreten sind.

Im Rahmen dieser Untersuchung fragt Exchange Server Analyzer die Eigenschaft EntryType der Microsoft WMI-Klasse (Windows® Management Instrumentation, Windows®-Verwaltungsinstrumentation) Exchange_MessageTrackingEntry unter dem Namespace root\MicrosoftExchangeV2 ab, um den Grund für die Erstellung der Einträge in den Nachrichtenverfolgungsprotokollen zu ermitteln.

Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Das Nachrichtenverfolgungsprotokoll kann erfolgreich durchsucht werden.

  • Die Testnachricht wurde nicht erfolgreich aus der Warteschlange übertragen.

  • Es wurde kein Unzustellbarkeitsbericht generiert.

  • Die Eigenschaft EntryType weist den Wert 1034 auf.

  • Die Nachricht hat den angegebenen lokalen ausgehenden Exchange-Gatewayserver erreicht.

Dieser Fehler kann auf ein Verbindungsproblem zwischen dem vom Benutzer angegebenen lokalen ausgehenden Exchange-Gatewayserver und dem Remoteserver hindeuten.

Verwenden Sie zum Beheben dieses Fehlers das Dienstprogramm NSlookup, um mögliche Probleme bei der DNS-Auflösung (Domain Name System) zu überprüfen. Verwenden Sie bei Verbindungs- und Protokollfehlern, z. B. vom Typ "Host nicht erreichbar" Telnet.exe, um eine Verbindung mit dem Zielcomputer herzustellen. Zur Behebung von Protokollproblemen erhöhen Sie den Protokolliergrad für die Diagnose des MSExchangeTransport-Diensts für die SMTP-Komponente (Simple Mail Transfer Protocol), und überprüfen Sie die Protokolle auf Fehler. Alternativ können Sie mit dem Tool Netzwerkmonitor (Netmon.exe) Informationen zu Netzwerkverbindungsfehlern abrufen.

Weitere Informationen zum Ändern von Protokolleinstellungen finden Sie unter "Ändern von Protokollierungseinstellungen für MSExchangeTransport" im Kapitel "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579)

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft Knowledge Base-Artikel 821877, "Beschreibung der Felder auf den Registerkarten mit den Eigenschaften für SMTP- und X.400-Warteschlangen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


Mögliches Problem bei Inetinfo
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-09-06

Microsoft® Exchange Server Analyzer enthält ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird. Das Erfassungsmodul für Leistungsdaten erfasst Daten des Leistungsindikators Kat: Ausgeführte Kategorisierungen des Leistungsobjekts SMTP Server, um Leistungsdaten zu analysieren.

Der Leistungsindikator Kat: Ausgeführte Kategorisierungen zeigt die Anzahl der zurzeit ausgeführten Kategorisierungen an.

Bei dieser Abfrage ruft Microsoft Exchange Server Analyzer zwei Minuten lang alle 6 Sekunden einen Wert ab. Microsoft Exchange Server Analyzer meldet den Durchschnittswert des Leistungsindikators innerhalb des Erfassungszeitraums.

Wenn Exchange Server Analyzer feststellt, dass die Mindestanzahl der im Erfassungszeitraum ausgeführten Kategorisierungen nie Null ist, zeigt Exchange Server Analyzer eine Warnung an.

Das Kategorisierungsmodul führt die folgenden Kernoperationen aus:

  • Auflösen und Validieren aller Empfänger.

  • Ermitteln von Grenzwerten und Einschränkungen für alle Empfänger.

  • Erweitern von Verteilerlisten, falls erforderlich.

  • Ermitteln, ob eine Nachricht für die lokale oder Remoteübermittlung bestimmt ist.

Wenn die Serverauslastung nicht besonders hoch ist, kann diese Warnung bedeuten, dass der Prozess Inetinfo.exe oder die Ressourcen, von denen der Prozess Inetinfo.exe abhängig ist, gesperrt sind (Deadlock).

Der SMTP-Dienst (Simple Mail Transfer Protocol) wird in dem Prozess Inetinfo.exe ausgeführt, Wenn Nachrichten das Transportsubsystem durchlaufen, verwendet SMTP in großem Maße IIS-Ressourcen (Internet Information Services).

Ein Deadlock tritt auf, wenn mindestens zwei Prozesse (oder Threads) darauf warten, dass der jeweils andere Prozess beendet wird, bevor sie fortgesetzt werden können. Als Ergebnis reagieren alle Prozesse (oder Threads) nicht mehr. Bei einem Deadlock wird die Ausführung von Prozessen nie beendet, und die Systemressourcen sind belegt. Hierdurch wird verhindert, dass andere Aufträge gestartet werden können.

So beheben Sie diese Warnung

  • Ermitteln Sie, ob die übermäßige Beanspruchung des Kategorisierungsmoduls erwartet wurde oder ihre Ursache in einer typischen Belastung liegt. Wenn das Kategorisierungsmodul nicht stark ausgelastet ist, verwenden Sie die Ressourcen aus dem Abschnitt "Weitere Informationen", um mithilfe des Prozesses Inetinfo.exe oder zugehörigen Ressourcen mögliche Leistungsprobleme zu identifizieren.

  • Überprüfen Sie, ob der Prozess Inetinfo.exe ausgeführt wird.

  • Prüfen Sie, ob eine durch Inetinfo.exe verursachte Deadlock-Situation vorliegt. Nutzen Sie hierfür die Anleitungen zum Debuggen im Microsoft Knowledgebase-Artikel 919791 "Verwenden des Diagnosetools für das Debuggen zum Beheben von Problemen bei hoher CPU-Auslastung durch einen Prozess in IIS" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=919791).

Weitere Informationen

Weitere Informationen zu Inetinfo.exe finden Sie unter "Internetinformationsdienste" im Technischen Referenhandbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=72966).

Weitere Informationen zum Beheben eines durch einen Prozess verursachten Deadlocks finden Sie im Microsoft Knowledgebase-Artikel 919791 "Verwenden des Diagnosetools für das Debuggen zum Beheben von Problemen bei hoher CPU-Auslastung durch einen Prozess in IIS" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=919791).

Weitere Informationen zur Leistung von Exchange Server finden Sie im "Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47576).

Weitere Informationen zur Behebung von Leistungsproblemen bei Exchange Server finden Sie unter "Behebung von Leistungsproblemen bei Microsoft Exchange Server" (http://go.microsoft.com/fwlink/?LinkId=47588).


Mögliches nicht gatewaybezogenes Problem
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-09

Microsoft® Exchange Server Analyzer sendet von dem Server aus, auf dem Exchange Server ausgeführt wird, eine Testnachricht an eine benutzerdefinierte SMTP-Adresse eines externen Empfängers. Exchange Server Analyzer überprüft anschließend die Nachrichtenverfolgungsprotokolle des Servers, um zu ermitteln, ob bei der Übermittlung der Testnachricht Probleme aufgetreten sind.

Im Rahmen dieser Untersuchung fragt Exchange Server Analyzer die Eigenschaft EntryType der Microsoft WMI-Klasse (Windows® Management Instrumentation, Windows®-Verwaltungsinstrumentation) Exchange_MessageTrackingEntry unter dem Namespace root\MicrosoftExchangeV2 ab, um den Grund für die Erstellung der Einträge in den Nachrichtenverfolgungsprotokollen zu ermitteln.

Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Das Nachrichtenverfolgungsprotokoll kann erfolgreich durchsucht werden.

  • Die Testnachricht wurde nicht erfolgreich aus der Warteschlange übertragen.

  • Es wurde kein Unzustellbarkeitsbericht generiert.

  • Die Eigenschaft EntryType weist den Wert 1034 auf.

  • Die Nachricht hat den angegebenen lokalen ausgehenden Exchange-Gatewayserver nicht erreicht.

Dieser Fehler kann darauf hindeuten, dass die Testnachricht noch immer in einer der SMTP-Warteschlangen (Simple Mail Transfer Protocol) für die Remoteübermittlung des absendenden Servers enthalten ist und ein Problem mit der Warteschlange vorliegt.

Eine Remoteübermittlungswarteschlange enthält Nachrichten mit Remoteübermittlungszielen. Der Name der Warteschlange entspricht dem Remoteübermittlungsziel. Dieses Ziel kann ein Connector, ein Server oder eine Domäne sein.

Um Protokollprobleme zu behandeln, erhöhen Sie den Protokolliergrad für die Diagnose des MSExchangeTransport-Diensts für die SMTP-Komponente, und überprüfen Sie die Protokolle auf Fehler. Alternativ können Sie mit dem Tool Netzwerkmonitor (Netmon.exe) Informationen zu Netzwerkverbindungsfehlern abrufen. Um das Problem zu reproduzieren, müssen Sie ggf. für die Warteschlange den Status Wiederholen erzwingen. Untersuchen Sie das Ereignisprotokoll auf mögliche Fehler im Zusammenhang mit dem Microsoft Exchange-Informationsspeicherdienst.

Weitere Informationen zum Ändern von Protokolleinstellungen finden Sie unter "Ändern von Protokollierungseinstellungen für MSExchangeTransport" im Kapitel "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579)

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft Knowledge Base-Artikel 821877, "Beschreibung der Felder auf den Registerkarten mit den Eigenschaften für SMTP- und X.400-Warteschlangen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


Es wurde ein möglicher SMTP-Proxy erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-12-06

Microsoft® Exchange Server Analyzer versucht, eine Nachricht an das Postmasterkonto oder ein benutzerdefiniertes Konto für die SMTP-Domäne zu senden.

Die folgende Standardantwort wird erwartet, wenn Exchange Server Analyzer eine Socketverbindung zu dem SMTP-Server öffnet:

"220 Computername. Domänenname.com Microsoft ESMTP MAIL Service, Version: Versionsnummer ready at Datum Uhrzeit +0000"

Wenn Exchange Server Analyzer eine nicht standardmäßige Antwort erhält, die eine Zeichenfolge eines Drittanbieters enthält, zeigt Exchange Server Analyzer einen Fehler an.

Dieser Fehler weist darauf hin, dass möglicherweise hinter dem Remoteserver ein SMTP-Proxyserver eines Drittanbieters ausgeführt wird.

Wenn das standardmäßige SMTP-Banner nicht absichtlich vom Exchange Server-Administrator geändert wurde, kann diese Warnung bedeuten, dass sich der Server mit Exchange hinter einem SMTP-Proxy befindet, die/der die ESMTP-Befehle (Exchange Server Extended Simple Mail Transfer Protocol filtert.

Wenn die Exchange Server-ESMTP-Befehle gefiltert werden, kann sich dies wesentlich auf die Exchange-Leistung auswirken und zu einem Verhalten führen, das im Microsoft Knowledge Base-Artikel 320027, "E-Mail-Nachrichten können hinter Cisco PIX-Firewall nicht gesendet oder empfangen werden" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027) beschrieben wird.

Weitere Informationen zu angepassten SMTP-Banners finden Sie im folgenden Microsoft Knowledge Base-Artikel:

  • 281224: "XCON: Ändern des SMTP-Banners" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281224)


Mögliches Problem mit der Leistung des Kategorisierungsmoduls
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-09-06

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Microsoft Windows® Management Instrumentation) ExchangeLink im Hinblick auf den Wert des Attributs TypePendingCategorization der SMTP-Instanz (Simple Mail Transfer Protocol) ProtocolName ab, um die Anzahl der Nachrichten in der SMTP-Warteschlange für "Nachrichten mit ausstehender Verzeichnissuche" (Messages Awaiting Directory Lookup, MADL) zu ermitteln.

Die Eigenschaften der WMI-Klasse ExchangeLink geben Informationen zu Nachrichtenverarbeitungslinks (Warteschlangen) zwischen Mailservern zurück. Ein Link kann Null oder mehr ExchangeQueue-Objekte enthalten. Diese Anzahl richtet sich nach dem aktuellen Nachrichtenverkehr entlang des Links.

Exchange Server Analyzer enthält auch ein Erfassungsmodul für Leistungsdaten, mit dem Leistungsindikatorobjekte auf Computern abgefragt werden, auf denen Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird.

Wenn Exchange Server Analyzer feststellt, dass die MADL-Warteschlange zurzeit mehr als 50 Nachrichten enthält, sammelt das Erfassungsmodul für Leistungsdaten von Exchange Server Analyzer Daten der Leistungsindikatoren Kat: Kategorisierte Nachrichten und Kat: Abgeschlossene Kategorisierungen des SMTP Server-Leistungsobjekts, um die Leistungsdaten zu analysieren.

Der Leistungsindikator Kat: Kategorisierte Nachrichten zeigt die Anzahl der Nachrichten an, die das Kategorisierungsmodul an Warteschlangen übergeben hat, während der Leistungsindikator Kat: Abgeschlossene Kategorisierungen die Gesamtzahl der abgeschlossenen Nachrichten anzeigt, die an das Kategorisierungsmodul übermittelt wurden.

Das Kategorisierungsmodul führt die folgenden Kernoperationen aus:

  • Auflösen und Validieren aller Empfänger.

  • Ermitteln von Grenzwerten und Einschränkungen für alle Empfänger.

  • Erweitern von Verteilerlisten, falls erforderlich.

  • Ermitteln, ob eine Nachricht für die lokale oder Remoteübermittlung bestimmt ist.

Exchange Server Analyzer untersucht die durchschnittliche Gesamtzahl der beiden Leistungsindikatoren, um zu ermitteln, ob die Zahlen im Erfassungszeitraum anwachsen.

Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Die MADL-Warteschlange enthält mindesten 50 Nachrichten.

  • Der Leistungsindikator Kat: Kategorisierte Nachrichten zeigt im Verlauf des Erfassungszeitraums ein Anwachsen der Nachrichtenanzahl, das auf einen Fortschritt bei der Übergabe übermittelter Nachrichten an den nächsten Prozess hinweist.

  • Der Leistungsindikator Kat: Abgeschlossene Kategorisierungen zeigt im Verlauf des Erfassungszeitraums ein Anwachsen der Nachrichtenanzahl, was auf einen Fortschritt bei der erfolgreich abgeschlossenen Kategorisierung übermittelter Nachrichten hinweist.

Dieser Fehler gibt an, dass die Warteschlange umfangreich bleibt und die Leistung möglicherweise stark beeinträchtigt wird, obwohl das Kategorisierungsmodul erfolgreich Nachrichten verarbeitet.

Ursache für eine Beeinträchtigung der Leistung des Kategorisierungsmoduls kann die Anforderung der Verarbeitung sehr vieler Nachrichten sein. Mögliche Gründe hierfür:

  • Unerwünschte kommerzielle E-Mails oder Spam.

  • Ausbreitung von Viren.

  • Probleme mit der Serverleistung.

So beheben Sie diese Warnung

  • Ermitteln Sie, ob die übermäßige Beanspruchung des Kategorisierungsmoduls erwartet wurde oder ihre Ursache in einer typischen Belastung liegt. Lesen Sie in diesem Fall in den folgenden Exchange-Ressourcen die Anleitungen im Hinblick auf die Leistung von Exchange.

    • "Behandeln von Leistungsproblemen bei Microsoft Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47588)

    • "Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Wurde die übermäßige Beanspruchung des Kategorisierungsmoduls nicht durch eine erwartete Belastung verursacht, prüfen Sie ob Virusbefall oder Spam dafür verantwortlich ist.


Mögliche Probleme bei der Aufgliederung von Verteilergruppen erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob Exchange Server 2003 Service Pack 2 (SP2) auf dem Server mit Exchange ausgeführt wird und ob dieser für die Aufgliederung von Verteilergruppen konfiguriert ist, wenn nach Übermittlungseinschränkungen gesucht wird:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

  • Der Wert 1 dieses Eintrags bedeutet, dass der Server für die Aufgliederung von Verteilergruppen konfiguriert ist, wenn nach Übermittlungseinschränkungen gesucht wird.

  • Der Wert 2 dieses Eintrags bedeutet, dass der Server nicht für die Aufgliederung von Verteilergruppen konfiguriert ist, wenn nach Übermittlungseinschränkungen gesucht wird.

Wenn Exchange Server Analyzer beim Suchen nach Übermittlungseinschränkungen feststellt, dass der Server für die Aufgliederung von Verteilergruppen eingerichtet ist, liest das Tool die Serverereignisprotokolle, um festzustellen, ob die Fehlerereignisse 6004, 6006 und 6008 alle in den letzten 24 Stunden aufgetreten sind.

Diese Fehlerereignisse bedeuten, dass sich Nachrichten im Nachrichtenkategorisierungsmodul angehäuft haben. Das Nachrichtenkategorisierungsmodul ist eine Komponente des erweiterten Warteschlangenmoduls, das LDAP-Abfragen (Lightweight Directory Access Protocol) an den globalen Katalogserver zum Durchführen von Verzeichnissuchen sendet.

Schließlich fragt Exchange Server Analyzer Active® Directory ab, um Folgendes zu ermitteln:

  • Ob mehr als 500 Postfächer in der Gesamtstruktur vorhanden sind, deren Übermittlungseinschränkungen so festgelegt sind, dass mindestens eine Verteilergruppe verwendet wird, um Absender zuzulassen bzw. nicht zuzulassen.

  • Ob ein Routinggruppenconnector Übermittlungseinschränkungen basierend auf der Mitgliedschaft in Verteilergruppen aufweist und auf dem Bridgeheadserver die Einschränkungsprüfung für den Connector aktiviert ist.

  • Ob ein SMTP-Connector Übermittlungseinschränkungen basierend auf der Mitgliedschaft in Verteilergruppen aufweist und auf dem Bridgeheadserver die Einschränkungsprüfung für den Connector aktiviert ist.

Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Der Server mit Exchange Server 2003 SP2 ist für die Aufgliederung von Verteilergruppen konfiguriert, wenn Übermittlungseinschränkungen überprüft werden.

  • Der Server mit Exchange hat die Ereignisse 6004, 6006 und 6008 in den letzten 24 Stunden protokolliert.

  • Es sind mehr als 500 Postfächer in der Gesamtstruktur vorhanden, deren Übermittlungseinschränkungen so festgelegt sind, dass mindestens eine Verteilergruppe verwendet wird, um Absender zuzulassen bzw. nicht zuzulassen, oder es ist ein Routinggruppenconnector mit Übermittlungseinschränkungen basierend auf der Mitgliedschaft in Verteilergruppen vorhanden, und auf dem Bridgeheadserver ist die Einschränkungsprüfung für den Connector aktiviert, oder ein SMTP-Connector weist Übermittlungseinschränkungen basierend auf der Mitgliedschaft in Verteilergruppen auf, und auf dem Bridgeheadserver ist die Einschränkungsprüfung für den Connector aktiviert.

Der Wert von RestrictionMethod bestimmt, wie das Kategorisierungsmodul Einschränkungen verarbeitet. Das Standardverhalten des Kategorisierungsmoduls besteht darin, Verteilergruppen rekursiv zu erweitern und die Einschränkungen für jede Nachricht zu überprüfen, die das System durchläuft. Wenn eine E-Mail-Nachricht an einen Empfänger gesendet wird, der mit einer Einschränkung konfiguriert ist, die Nachrichten von Mitgliedern einer bestimmten Verteiler- oder Sicherheitsgruppe zurückweist, muss Exchange Server diese Gruppe aufgliedern, um sicherzustellen, dass der Absender nicht einer eingeschränkten Gruppe angehört. Die Ergebnisse dieser Gruppenaufgliederung werden nicht in Exchange Server zwischengespeichert, weshalb die Aufgliederung jedes Mal erfolgen muss. Dies bewirkt, dass die Nachrichten in den Warteschlangen des Kategorisierungsmoduls abgelegt werden, wodurch die Nachrichtenverarbeitung verzögert wird.

Wenn der Wert von RestrictionMethod auf 2 festgelegt wird, gliedern die Transportkomponenten für diesen Server mit Exchange die Mitgliedschaft der Verteilergruppen nicht auf, während der Server die Einschränkungen überprüft. Diese Konfiguration stellt die beste Leistung für Einschränkungsüberprüfungen bereit. Darüber hinaus müssen alle Verteilergruppen mit Benutzern, für die Übermittlungseinschränkungen gelten, flach sein, damit der Registrierungseintrag RestrictionMethod wirksam wird. Das heißt, dass die eingeschränkten Verteilergruppen keine geschachtelten Verteilergruppen aufweisen dürfen. Die Aufgliederungslogik funktioniert nicht, wenn die eingeschränkten Verteilergruppen geschachtelt sind.

Für Verteilergruppen, die in Connectoreinschränkungen verwendet werden, wird empfohlen, den Wert des Registrierungseintrags RestrictionMethod für einen Connector-Bridgeheadserver festzulegen, der keine Postfächer aufweist. Wenn die eingeschränkten Verteilergruppen über Server für die Aufgliederung der Verteilerlisten verfügen, wird bei Benutzereinschränkungen für Active Directory empfohlen, dass Sie den Registrierungseintrag RestrictionMethod für die Server für die Aufgliederung der Verteilerlisten erstellen.

Weitere Informationen dazu, was passiert, wenn Übermittlungseinschränkungen konfiguriert sind, finden Sie im Microsoft KnowledgeBase-Artikel 812298, "Übermittlung von E-Mails ist langsam, nachdem Sie Übermittlungseinschränkungen konfiguriert haben, die auf einer Verteilerliste basieren" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

Weitere Informationen zum Registrierungswert RestrictionMethod finden Sie im Microsoft Knowledge Base-Artikel 895407, "In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

Weitere Informationen zu Exchange Server 2003-Ereignissen und -Fehlern finden Sie im "Events and Errors Message Center" (http://go.microsoft.com/fwlink/?LinkId=34258).

Weitere Informationen zu Connectoreinschränkungen finden Sie im Knowledge Base-Artikel 277872, "XCON: Connector Delivery Restrictions May Not Work Correctly" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872)

Weitere Informationen zu SMTP-Warteschlangen finden Sie im Microsoft Knowledge Base-Artikel 884996 mit Informationen zur SMTP-Warteschlange "Nachrichten warten auf Verzeichnissuche" in Exchange Server 2003 oder Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=884996).


Mögliche Probleme mit dem Nachrichtenjournalempfänger erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) Win32_NTLogEvent ab, um zu ermitteln, ob die folgenden Kombinationen von Warnungs-/Fehlerereignissen des Kategorisierungsmoduls in den letzten 24 Stunden aufgetreten sind:

  • Ereignis 9004 und Ereignis 9003

  • Ereignis 9035 und Ereignis 6004

Diese Fehlerereignisse bedeuten, dass sich Nachrichten im Nachrichtenkategorisierungsmodul angehäuft haben. Das Nachrichtenkategorisierungsmodul ist eine Komponente des erweiterten Warteschlangenmoduls, das LDAP-Abfragen (Lightweight Directory Access Protocol) an den globalen Katalogserver zum Durchführen von Verzeichnissuchen sendet.

  • Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob auch beliebige der folgenden Bedingungen erfüllt sind:

  • Der vorgesehene Journalempfänger eines Informationsspeichers zeigt auf ein gelöschtes Objekt.

  • Der vorgesehene Journalempfänger eines Informationsspeichers zeigt auf ein Objekt ohne gültigen mailNickname.

  • Der vorgesehene Journalempfänger eines Informationsspeichers zeigt auf ein deaktiviertes Konto.

Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Eine der zuvor genannten Kombinationen von Warnungs-/Fehlerereignissen ist eingetreten.

  • Eine beliebige der genannten Bedingungen für den vorgesehenen Journalempfänger ist ebenfalls eingetreten.

Dieser Fehler bedeutet, dass es in der Exchange-Umgebung möglicherweise ein Problem mit der Journalerstellung gibt, das eine Anhäufung von Nachrichten in Warteschlangen verursacht.

Informationen zum Beheben dieses Problem finden Sie im entsprechenden Exchange Server Analyzer-Artikel zu Ihrem Problem:

  • Aufzeichnungsempfänger verweist auf ein gelöschtes Objekt

  • Journalempfänger ist ungültig

  • Aufzeichnungsempfänger verweist auf ein deaktiviertes Konto

  • Informationen zu Exchange Server 2003-Ereignissen und -Fehlern finden Sie im "Events and Errors Message Center" (http://go.microsoft.com/fwlink/?LinkId=34258).


Mögliche Probleme bei der Nachrichtenjournalerstellung und beim Informationsspeicherdienst erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) Win32_NTLogEvent ab, um zu ermitteln, ob das Warnungsereignis 9004 des Kategorisierungsmoduls in den letzten 24 Stunden aufgetreten ist.

Exchange Server Analyzer fragt auch die WMI-Klasse Win32_Service ab, um zu bestimmen, ob der Microsoft Exchange-Informationsspeicherdienst (MSExchangeIS) gestartet oder beendet wurde. Ein anderer Wert als Started für die MSExchangeIS-Instanz bedeutet, dass der MSExchangeIS-Dienst beendet wurde.

Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Der Server hat das Warnungsereignis 9003 des Kategorisierungsmoduls in den letzten 24 Stunden protokolliert.

  • Der MSExchangeIS-Dienst wurde beendet.

Dieser Fehler bedeutet, dass es möglicherweise ein Problem mit der Nachrichtenjournalerstellung oder dem Microsoft Exchange-Informationsspeicherdienst (Store.exe) gibt, das eine Anhäufung von Nachrichten in Warteschlangen verursacht.

Dieses Problem kann auftreten, wenn eine der folgenden Bedingungen vorliegt:

  • Das Journalempfangsobjekt wurde aus dem Verzeichnisdienst Active Directory® gelöscht.

  • Der Informationsspeicherdienst wird nicht ausgeführt oder wurde auf dem Computer mit Exchange Server deaktiviert, der als SMTP-Bridgeheadserver fungiert.

  • Die Bereitstellung eines oder mehrerer Postfachspeicher auf dem SMTP-Bridgeheadserver wurde aufgehoben.

So beheben Sie dieses Problem:

  • Stellen Sie sicher, dass der Informationsspeicherdienst auf dem SMTP-Bridgeheadserver aktiviert ist und ausgeführt wird. Vergewissern Sie sich, dass die Postfachspeicher auf dem SMTP-Bridgeheadserver bereitgestellt sind.

  • Stellen Sie sicher, dass das Journalempfangsobjekt für Postfachspeicher nicht aus Active Directory gelöscht wurde.

So bestimmen Sie den Journalempfänger für einen Postfachspeicher

  1. Starten Sie Exchange-System-Manager.

  2. Erweitern Sie Server und anschließen <Ihren Server mit Exchange>. Erweitern Sie die <Speichergruppe>, klicken Sie dann mit der rechten Maustaste auf den Postfachspeicher und wählen Sie Eigenschaften aus.

  3. Betrachten Sie auf der Registerkarte Allgemein das Konto unmittelbar unter dem Kontrollkästchen Alle von Postfächern in diesem Informationsspeicher gesendeten oder empfangenen Nachrichten archivieren. Dieses Konto wird als Journalempfänger verwendet.

    Hinweis:
    Überprüfen Sie den Journalempfänger für jedes Postfachspeicherobjekt.
So bestimmen Sie ein neues Benutzerpostfach als Journalempfänger

  1. Starten Sie Exchange-System-Manager.

  2. Erweitern Sie Server und anschließen <Ihren Server mit Exchange>. Erweitern Sie die <Speichergruppe>, klicken Sie dann mit der rechten Maustaste auf den Postfachspeicher und wählen Sie Eigenschaften aus.

  3. Klicken Sie auf der Registerkarte Allgemein rechts neben dem Text Alle von Postfächern in diesem Informationsspeicher gesendeten oder empfangenen Nachrichten archivieren auf Durchsuchen, um ein Postfach als Journalempfangspostfach zu bestimmen.

    Hinweis:
    Alle im Journal erfassten Nachrichten für Absender in diesem Postfachspeicher werden an das von Ihnen angegebene Postfach gesendet.

Informationen zu diesem Problem finden Sie unter Aufzeichnungsempfänger verweist auf ein gelöschtes Objekt.

Weitere Informationen zu Exchange Server 2003-Ereignissen und -Fehlern finden Sie im "Events and Errors Message Center" (http://go.microsoft.com/fwlink/?LinkId=34258).

Weitere Informationen zum Bereitstellen einer Journallösung finden Sie unter "Journaling with Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=47581).


Mögliche Berechtigungsprobleme erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) Win32_NTLogEvent ab, um zu ermitteln, ob die folgenden Exchange Server-Fehlerereignisse in den letzten 24 Stunden aufgetreten sind:

  • Ereignis 929.

  • Ereignis 9035.

  • Eine Kombination der Ereignisse 9003, 9004 und 6004.

Das Exchange Server-Fehlerereignis 929 kann aufgrund falscher Zugriffsberechtigungen für die Exchange Server-Objekte im Verzeichnisdienst Active Directory® auftreten.

Die Exchange Server-Fehlerereignisse 9003, 9004 und 6004 bedeuten, dass sich Nachrichten im Nachrichtenkategorisierungsmodul angehäuft haben. Das Nachrichtenkategorisierungsmodul ist eine Komponente des erweiterten Warteschlangenmoduls, das LDAP-Abfragen (Lightweight Directory Access Protocol) an den globalen Katalogserver zum Durchführen von Verzeichnissuchen sendet.

Exchange Server Analyzer fragt Active Directory auch ab, um zu bestimmen, ob die Attribute der Objekte im Zusammenhang mit Exchange einen Hinweis liefern, dass für diese Objekte Probleme bei der Berechtigungsvererbung vorliegen.

Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Eines der folgenden Ereignisse bzw. eine Kombination von Ereignissen wurde in den letzten 24 Stunden auf einem Server protokolliert, auf dem Nachrichten in dessen Warteschlange Nachrichten warten auf Verzeichnissuche abgelegt wurden:

    • Ereignis 929.

    • Ereignis 9035.

    • Die Kombination der Ereignisse 9003, 9004 und 6004.

  • Objekte im Zusammenhang mit Exchange weisen fehlende oder falsche Zugriffsberechtigungen auf.

Dieser Fehler bedeutet, dass es in der Exchange-Umgebung Probleme mit der Berechtigungsvererbung gibt, die eine Anhäufung von Nachrichten in Warteschlangen verursachen.

Um dieses Problem zu lösen, befolgen Sie die Anweisungen im Microsoft Knowledge Base-Artikel 907969, "Ereignis-ID 929 wird protokolliert und Nachricht wird nicht auf einem anderen Mail-Server in einer Exchange 2000 Server-Organisation von einem Mail-Server übermittelt" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=907969).

Weitere Informationen zu Exchange Server 2003-Ereignissen und -Fehlern finden Sie im "Events and Errors Message Center" (http://go.microsoft.com/fwlink/?LinkId=34258).


Öffentlicher Ordner wurde als gemeinsames Ziel identifiziert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-10-04

Microsoft® Exchange Server Analyzer fragt die Exchange_Queue WMI-Klasse (Windows® Management Instrumentation) ab, um die Werte der folgenden Attribute für SMTP-Warteschlangen (Simple Mail Transfer Protocol) auf dem virtuellen SMTP-Server zu bestimmen.

LinkId | Gibt den Bezeichner für den Link an, der die Warteschlange enthält.
QueueId | Gibt den Bezeichner der Warteschlange an.
QueueName | Gibt den Namen der Warteschlange an.
VirtualMachine | Gibt den Namen des virtuellen Computers an, der die Warteschlange enthält.
VirtualServerName | Gibt den Namen des virtuellen Servers an, auf dem sich die Warteschlange befindet.
MessageCount | Gibt die Anzahl der Nachrichten in der Warteschlange an.

Exchange Server Analyzer fragt anhand der hier angegebenen Informationen die WMI-Klasse Exchange_QueuedSMTPMessage nach den Werten der folgenden Attribute für Nachrichten in der Warteschlange ab:

Recipients | Gibt die Empfänger der Nachricht an.
Received | Gibt den Zeitstempel des Empfangs der Nachricht an.
MessageId | Gibt den Bezeichner der in der Warteschlange befindlichen Nachricht an.
StateRetry | Gibt an, dass eine Nachricht, die nicht erfolgreich zugestellt werden konnte, erneut übermittelt wird.

Schließlich verwendet Exchange Server Analyzer die hier erhaltenen Daten dazu, um den Active Directory®-Verzeichnisdienst nach dem distinguishedName-Wert für jedes Recipient-Objekt abzufragen. Exchange Server Analyzer ermittelt daraufhin, ob es sich bei dem Empfänger um einen Benutzer, eine Verteilergruppe, einen Öffentlicher Ordner oder einen Informationsspeicher für Öffentliche Ordner handelt.

Wenn Exchange Server Analyzer ermittelt, dass 25 Prozent oder mehr der in der Warteschlange festsitzenden Nachrichten entweder im Feld To: oder im Feld Cc: an einen bestimmten Öffentlichen Ordner adressiert sind, wird eine Warnung angezeigt.

Wenn Exchange Server Analyzer ermittelt, dass 50 Prozent oder mehr der in der Warteschlange festsitzenden Nachrichten entweder im Feld To: oder im Feld Cc: an einen bestimmten Öffentlichen Ordner adressiert sind, wird ein Fehler angezeigt.

Diese Warnung bzw. dieser Fehler bedeutet, dass der identifizierte Öffentliche Ordner ein gemeinsames Ziel für Nachrichten ist, die in einer SMTP-Warteschlange festsitzen.

Um dieses Problem zu beheben, sollten Sie überprüfen, ob Konfigurationsprobleme oder andere Anomalien für diesen Öffentlichen Ordner vorliegen, die dazu führen, dass die an diese Verteilergruppe gerichteten Nachrichten in die Warteschlange gesetzt werden.

  • Stellen Sie sicher, dass die Attribute des Öffentlichen Ordner-Objekts ordnungsgemäß eingerichtet wurden und in Active Directory die richtigen Werte enthalten.

  • Überprüfen Sie, ob die Active Directory-Berechtigungen des Öffentlichen Ordner-Objekts richtig eingestellt sind.

  • Suchen Sie nach möglichen unerwünschten kommerziellen E-Mails (UCE oder SPAM) oder Virusangriffen auf den Öffentlichen Ordner.

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei der Nachrichtenübermittlung und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).


Informationsspeicher für Öffentliche Ordner wurde als gemeinsames Ziel identifiziert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-10-04

Microsoft® Exchange Server Analyzer fragt die Exchange_Queue WMI-Klasse (Windows® Management Instrumentation) ab, um die Werte der folgenden Attribute für SMTP-Warteschlangen (Simple Mail Transfer Protocol) auf dem virtuellen SMTP-Server zu bestimmen.

LinkId | Gibt den Bezeichner für den Link an, der die Warteschlange enthält.
QueueId | Gibt den Bezeichner der Warteschlange an.
QueueName | Gibt den Namen der Warteschlange an.
VirtualMachine | Gibt den Namen des virtuellen Computers an, der die Warteschlange enthält.
VirtualServerName | Gibt den Namen des virtuellen Servers an, auf dem sich die Warteschlange befindet.
MessageCount | Gibt die Anzahl der Nachrichten in der Warteschlange an.

Exchange Server Analyzer fragt anhand der hier angegebenen Informationen die WMI-Klasse Exchange_QueuedSMTPMessage nach den Werten der folgenden Attribute für Nachrichten in der Warteschlange ab:

Recipients | Gibt die Empfänger der Nachricht an.
Received | Gibt den Zeitstempel des Empfangs der Nachricht an.
MessageId | Gibt den Bezeichner der in der Warteschlange befindlichen Nachricht an.
StateRetry | Gibt an, dass eine Nachricht, die nicht erfolgreich zugestellt werden konnte, erneut übermittelt wird.

Schließlich verwendet Exchange Server Analyzer die hier erhaltenen Daten dazu, um den Active Directory®-Verzeichnisdienst nach dem distinguishedName-Wert für jedes Recipient-Objekt abzufragen. Exchange Server Analyzer ermittelt daraufhin, ob es sich bei dem Empfänger um einen Benutzer, eine Verteilergruppe, einen Öffentlicher Ordner oder einen Informationsspeicher für Öffentliche Ordner handelt.

Wenn Exchange Server Analyzer ermittelt, dass 25 Prozent oder mehr der in der Warteschlange festsitzenden Nachrichten entweder im Feld To: oder im Feld Cc: an Empfänger adressiert sind, deren Postfächer sich im selben Informationsspeicher für Öffentliche Ordner befinden, wird eine Warnung angezeigt.

Wenn Exchange Server Analyzer ermittelt, dass 50 Prozent oder mehr der in der Warteschlange festsitzenden Nachrichten entweder im Feld To: oder im Feld Cc: an Empfänger adressiert sind, deren Postfächer sich im selben Informationsspeicher für Öffentliche Ordner befinden, wird ein Fehler angezeigt.

Diese Warnung bzw. dieser Fehler bedeutet, dass der identifizierte Informationsspeicher für Öffentliche Ordner ein gemeinsames Ziel für Nachrichten ist, die in einer SMTP-Warteschlange festsitzen.

Um dieses Problem zu beheben, sollten Sie überprüfen, ob Konfigurationsprobleme, Replikationsanstürme oder andere Anomalien für diesen Informationsspeicher für Öffentliche Ordner vorliegen, die dazu führen, dass die an diese Verteilergruppe gerichteten Nachrichten in die Warteschlange gesetzt werden.

  • Stellen Sie sicher, dass die Attribute des Speicherobjekts ordnungsgemäß eingerichtet wurden und in Active Directory die richtigen Werte enthalten.

  • Überprüfen Sie, ob die Active Directory-Berechtigungen des Speicherobjekts richtig eingestellt sind.

  • Suchen Sie nach möglichen unerwünschten kommerziellen E-Mails (UCE oder SPAM) oder Virusangriffen auf den Öffentlichen Ordner.

  • Überprüfen Sie, ob Änderungen an der Öffentlichen Ordnerhierarchie oder Inhalte vorliegen, die zu einer großen Menge von Replikationen zwischen Informationsspeichern für Öffentliche Ordner führen.

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei der Nachrichtenübermittlung und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Microsoft Knowledge Base-Artikel 842273 „Beheben von Problemen mit der Replikation Öffentlicher Ordner in Exchange 2000 Server und Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=842273).


Empfängerfilterung ist aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob die Eigenschaft msExchServerBindingsFiltering eines virtuellen SMTP-Serverobjekts (Simple Mail Transfer Protocol) angibt, dass die Empfängerfilterung für eine virtuelle SMTP-Serverinstanz aktiviert ist.

Exchange Server Analyzer fragt Active Directory auch ab, um zu ermitteln, ob die Eigenschaft msExchRecipTurfListNames oder msExchRecipTurfListOptions angibt, dass die Empfängerfilterung auch auf der Ebene der globalen Einstellungen aktiviert ist.

Wenn das Tool Exchange Server Analyzer feststellt, dass die Verbindungsfilterung sowohl für die virtuelle SMTP-Serverinstanz als auch auf der Ebene der globalen Einstellungen aktiviert ist, wird eine Warnung angezeigt.

Diese Warnung bedeutet, dass die Empfängerfilterung wirksam aktiviert ist. Die Empfängerfilterung stellt in der Regel kein Problem dar. Beim Behandeln von Problemen mit dem Nachrichtenfluss eines bestimmten Servers müssen Sie jedoch ggf. die Filterkonfiguration überprüfen oder die Empfängerfilterung vorübergehend deaktivieren, um zu ermitteln, ob diese fälschlicherweise erwünschte E-Mail blockiert.

So deaktivieren Sie einen Empfängerfilter auf einem virtuellen SMTP-Server

  1. Starten Sie den Exchange-System-Manager: Klicken Sie auf Start, zeigen Sie auf Alle Programme, zeigen Sie auf Microsoft Exchange, und klicken Sie dann auf System-Manager.

  2. Erweitern Sie in der Konsolenstruktur Server, dann den gewünschten Server, danach Protokolle und anschließend SMTP.

  3. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server, auf dem Sie den Filter deaktivieren möchten, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie im Dialogfeld < Eigenschaften von SMTP Virtual Server> auf der Registerkarte Allgemein auf Erweitert.

  5. Wählen Sie in Erweitert die IP-Adresse aus, für die Sie den Filter deaktivieren möchten, und klicken Sie auf Bearbeiten.

Deaktivieren Sie in Identifikation die Option Empfängerfilter anwenden, um den Filter zu deaktivieren.

  1. Sind mehrere virtuelle Server vorhanden, wiederholen Sie die Schritte 3 bis 6 für jeden virtuellen Server, auf dem Sie den Filter deaktivieren möchten.

Weitere Informationen zum Konfigurieren von Empfängerfiltern finden Sie im Microsoft Knowledge Base-Artikel 823866, "Konfigurieren der Verbindungsfilterung für die Verwendung von Realtime Block Lists (RBLs) und Konfigurieren von Empfängerfilterung in Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823866).

Weitere Informationen zur intelligenten Nachrichtenfilterung finden Sie auf der Website "Exchange Intelligent Message Filter" (http://go.microsoft.com/fwlink/?LinkId=21607).


Warteschlange "Remoteübermittlung" hat den Status "Fixiert"
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) ExchangeLink ab, um den Wert des Schlüssels StateFrozen für die SMTP-Warteschlange (Simple Mail Transfer Protocol) Remoteübermittlung zu bestimmen.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Schlüssels StateFrozen für die Warteschlange Remoteübermittlung auf einem Server mit Exchange auf True festgelegt ist, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Eine fixierte Warteschlange bedeutet, dass die Transportsitzungen für diese Warteschlange beendet wurden. Eine fixierte Warteschlange verhindert ausgehende Nachrichten, obgleich neue Nachrichten hinzugefügt werden können. Sie können den Status einer Verbindung über das Kontextmenü für jede Verbindungswarteschlange manuell ändern. Wenn Sie mit dem Befehl Verbindung erzwingen einen Warteschlangenstatus in Aktiv ändern, aktivieren Sie sofort eine Verbindung, über welche die Nachrichten in dieser Warteschlange gesendet werden.

Die Warteschlange Remoteübermittlung enthält Nachrichten mit Remoteübermittlungszielen. Der Name der Warteschlange entspricht dem Remoteübermittlungsziel. Dieses Ziel kann ein Connector, ein Server oder eine Domäne sein.

Verwenden Sie zum Beheben dieses Fehlers das Dienstprogramm NSlookup, um mögliche Probleme bei der DNS-Auflösung (Domain Name System) zu überprüfen. Verwenden Sie bei Verbindungs- und Protokollfehlern, z. B. vom Typ "Host nicht erreichbar", Telnet.exe, um eine Verbindung mit dem Zielcomputer herzustellen. Um Protokollprobleme zu behandeln, erhöhen Sie den Protokolliergrad für die Diagnose des Diensts MSExchangeTransport für die Komponente SMTP-Protokoll, und überprüfen Sie die Protokolle auf Fehler. Alternativ können Sie mit dem Tool Netzwerkmonitor (Netmon.exe) Informationen zu Netzwerkverbindungsfehlern abrufen. Um das Problem zu reproduzieren, müssen Sie ggf. für die Warteschlange den Status Wiederholen erzwingen. Untersuchen Sie das Ereignisprotokoll auf mögliche Fehler im Zusammenhang mit dem Microsoft Exchange-Informationsspeicherdienst.

Weitere Informationen zum Ändern von Protokolleinstellungen finden Sie unter "Ändern von Protokollierungseinstellungen für MSExchangeTransport" im Kapitel "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Microsoft Knowledge Base-Artikel 821877 mit einer Beschreibung der Felder auf den Eigenschaftsregisterkarten für die SMTP- und X.400-Warteschlange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Warteschlange "Remoteübermittlung" hat den Status "Wiederholen"
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) ExchangeLink ab, um den Wert des Schlüssels StateRetry für die SMTP-Warteschlange (Simple Mail Transfer Protocol) Remoteübermittlung zu bestimmen.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Schlüssels StateRetry für die Warteschlange Remoteübermittlung auf einem Server mit Exchange auf True festgelegt ist, zeigt Exchange Server Analyzer eine Fehlermeldung an.

Wenn eine Warteschlange den Status Wiederholen hat, bedeutet dies, dass mindestens ein Fehler bei den vorherigen Versuchen der Verarbeitung der Nachrichten in der Warteschlange aufgetreten ist. Mit dem Befehl Verbindung erzwingen kann der Status von Warteschlangen von Wiederholen und Geplant in Aktiv geändert werden. Dadurch funktioniert die Warteschlange so, als ob das Wiederholungsintervall abgelaufen oder der geplante Zeitpunkt erreicht sei. Diese Methode funktioniert jedoch nicht immer.

Hinweis:
Die Eigenschaften einer Warteschlange können einen bestimmten Grund angeben, warum eine Warteschlange den Status Wiederholen hat.

Die Warteschlange Remoteübermittlung enthält Nachrichten mit Remoteübermittlungszielen. Der Name der Warteschlange entspricht dem Remoteübermittlungsziel. Dieses Ziel kann ein Connector, ein Server oder eine Domäne sein.

Verwenden Sie zum Beheben dieses Fehlers das Dienstprogramm NSlookup, um mögliche Probleme bei der DNS-Auflösung (Domain Name System) zu überprüfen. Verwenden Sie bei Verbindungs- und Protokollfehlern, z. B. vom Typ "Host nicht erreichbar", Telnet.exe, um eine Verbindung mit dem Zielcomputer herzustellen. Um Protokollprobleme zu behandeln, erhöhen Sie den Protokolliergrad für die Diagnose des Diensts MSExchangeTransport für die Komponente SMTP-Protokoll, und überprüfen Sie die Protokolle auf Fehler. Alternativ können Sie mit dem Tool Netzwerkmonitor (Netmon.exe) Informationen zu Netzwerkverbindungsfehlern abrufen. Um das Problem zu reproduzieren, müssen Sie ggf. für die Warteschlange den Status Wiederholen erzwingen. Untersuchen Sie das Ereignisprotokoll auf mögliche Fehler im Zusammenhang mit dem Microsoft Exchange-Informationsspeicherdienst.

Weitere Informationen zum Ändern von Protokolleinstellungen finden Sie unter "Ändern von Protokollierungseinstellungen für MSExchangeTransport" im Kapitel "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Microsoft Knowledge Base-Artikel 821877 mit einer Beschreibung der Felder auf den Eigenschaftsregisterkarten für die SMTP- und X.400-Warteschlange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Problem bei der Warteschlange vom Typ "Remoteübermittlung"
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Das Tool Microsoft® Exchange Server Analyzer sendet eine Testnachricht vom Server mit Exchange an das Postmasterkonto oder ein benutzerdefiniertes Konto für die SMTP-Domäne (Simple Mail Transfer Protocol) und untersucht anschließend die Nachrichtenverfolgungsprotokolle des Servers, um zu bestimmen, ob bei der Übermittlung der Testnachricht Probleme aufgetreten sind.

Im Rahmen dieser Untersuchung fragt Exchange Server Analyzer die Eigenschaft EntryType der Microsoft WMI-Klasse (Windows® Management Instrumentation, Windows®-Verwaltungsinstrumentation) Exchange_MessageTrackingEntry unter dem Namespace root\MicrosoftExchangeV2 ab, um den Grund für den Eintrag in die Nachrichtenverfolgungsprotokolle zu ermitteln.

Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Das Nachrichtenverfolgungsprotokoll kann erfolgreich durchsucht werden.

  • Die Testnachricht wurde nicht erfolgreich aus der Warteschlange übertragen.

  • Es wurde kein Unzustellbarkeitsbereich generiert.

  • Die Eigenschaft EntryType weist den Wert 1034 auf.

Dieser Fehler bedeutet, dass die Testnachricht noch immer in einer der SMTP-Warteschlangen (Simple Mail Transfer Protocol) vom Typ Remoteübermittlung des absendenden Servers enthalten ist und ein Problem mit der Warteschlange vorliegt.

Die Warteschlange Remoteübermittlung enthält Nachrichten mit Remoteübermittlungszielen. Der Name der Warteschlange entspricht dem Remoteübermittlungsziel. Dieses Ziel kann ein Connector, ein Server oder eine Domäne sein.

Verwenden Sie zum Beheben dieses Fehlers das Dienstprogramm NSlookup, um mögliche Probleme bei der DNS-Auflösung (Domain Name System) zu überprüfen. Verwenden Sie bei Verbindungs- und Protokollfehlern, z. B. vom Typ "Host nicht erreichbar", Telnet.exe, um eine Verbindung mit dem Zielcomputer herzustellen. Um Protokollprobleme zu behandeln, erhöhen Sie den Protokolliergrad für die Diagnose des Diensts MSExchangeTransport für die Komponente SMTP-Protokoll, und überprüfen Sie die Protokolle auf Fehler. Alternativ können Sie mit dem Tool Netzwerkmonitor (Netmon.exe) Informationen zu Netzwerkverbindungsfehlern abrufen. Um das Problem zu reproduzieren, müssen Sie ggf. für die Warteschlange den Status Wiederholen erzwingen. Untersuchen Sie das Ereignisprotokoll auf mögliche Fehler im Zusammenhang mit dem Microsoft Exchange-Informationsspeicherdienst.

Weitere Informationen zum Ändern von Protokolleinstellungen finden Sie unter "Ändern von Protokollierungseinstellungen für MSExchangeTransport" im Kapitel "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Microsoft Knowledge Base-Artikel 821877 mit einer Beschreibung der Felder auf den Eigenschaftsregisterkarten für die SMTP- und X.400-Warteschlange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Wiederholen der Kategorisierung
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Das Tool Microsoft® Exchange Server Analyzer sendet eine Testnachricht vom Server mit Exchange an das Postmasterkonto oder ein benutzerdefiniertes Konto für die SMTP-Domäne (Simple Mail Transfer Protocol) und untersucht anschließend die Nachrichtenverfolgungsprotokolle des Servers, um zu bestimmen, ob bei der Übermittlung der Testnachricht Probleme aufgetreten sind.

Im Rahmen dieser Untersuchung fragt Exchange Server Analyzer die Eigenschaft EntryType der Microsoft WMI-Klasse (Windows® Management Instrumentation, Windows®-Verwaltungsinstrumentation) Exchange_MessageTrackingEntry unter dem Namespace root\MicrosoftExchangeV2 ab, um den Grund für den Eintrag in die Nachrichtenverfolgungsprotokolle zu ermitteln.

Wenn Exchange Server Analyzer feststellt, dass die Eigenschaft EntryType den Wert 1032 hat, zeigt Exchange Server Analyzer eine Warnung an.

Diese Warnung bedeutet, dass sich die Testnachricht in einer Warteschlange befindet, die für eine Wiederholung der Kategorisierung eingeplant ist. Wenn eine Warteschlange den Status Wiederholen hat, bedeutet dies, dass mindestens ein Fehler bei den vorherigen Versuchen der Verarbeitung der Nachrichten in der Warteschlange aufgetreten ist. Mit dem Befehl Verbindung erzwingen kann der Status von Warteschlangen von Wiederholen und Geplant in Aktiv geändert werden. Dadurch funktioniert die Warteschlange so, als ob das Wiederholungsintervall abgelaufen oder der geplante Zeitpunkt erreicht sei. Diese Methode funktioniert jedoch nicht immer.

Hinweis:
Die Eigenschaften einer Warteschlange können einen bestimmten Grund angeben, warum eine Warteschlange den Status Wiederholen hat.

Nachrichten häufen sich im Allgemeinen in Warteschlangen, die auf eine Wiederholung warten, an, wenn das erweiterte Warteschlangenmodul eine Nachricht nicht kategorisieren kann. Das erweiterte Warteschlangenmodul kann ggf. nicht auf die globalen Katalogserver und Empfängerinformationen zugreifen, oder die globalen Katalogserver sind nicht erreichbar oder überlastet. Darüber hinaus können sich Nachrichten aus den folgenden Gründen anhäufen:

  • Active Directory ist nicht verfügbar.

    Hinweis:
    Das Kategorisierungsmodul verwendet Active Directory zum Kategorisieren von Nachrichten.
  • Active Directory ist ggf. überlastet, wenn viele Nachrichten in der Warteschlange für die Vorkategorisierung abgelegt wurden.

  • Ein Konvertierungsfehler liegt vor. Das Kategorisierungsmodul ist auch für die Inhaltskonvertierung zuständig.

  • Das Nachrichtenkategorisierungsmodul kann die Postfachspeicher nicht finden.

  • Wenn SMTP neu installiert oder entfernt wurde, können die folgenden Metabasisschlüssel von Internetinformationsdienste (IIS) ggf. ungültig geworden sein: "/smtpsvc/DsUseCat" und "/smtpsvc/vsi#/DsUseCat"

    Hinweis:
    Ermitteln Sie, ob SMTP neu installiert oder entfernt wurde.

Um diesen Fehler zu beheben, untersuchen Sie die Eigenschaften der Warteschlange, um zu ermitteln, warum die Warteschlange den Status Wiederholen hat. Wenn in den Warteschlangeneigenschaften eine Nachricht vom Typ "Ein SMTP-Fehler ist aufgetreten" angezeigt wird, müssen Sie die Ereignisprotokolle des Servers auf SMTP-Fehler überprüfen. Enthalten die Protokolle keine Ereignisse, müssen Sie die Protokolliergrad für SMTP erhöhen.

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Microsoft Knowledge Base-Artikel 821877 mit einer Beschreibung der Felder auf den Eigenschaftsregisterkarten für die SMTP- und X.400-Warteschlange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Neuversuchen der lokalen Übermittlung
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-04

Das Tool Microsoft® Exchange Server Analyzer sendet eine Testnachricht vom Server mit Exchange an das Postmasterkonto oder ein benutzerdefiniertes Konto für die SMTP-Domäne (Simple Mail Transfer Protocol) und untersucht anschließend die Nachrichtenverfolgungsprotokolle des Servers, um zu bestimmen, ob bei der Übermittlung der Testnachricht Probleme aufgetreten sind.

Im Rahmen dieser Untersuchung fragt Exchange Server Analyzer die Eigenschaft EntryType der Microsoft WMI-Klasse (Windows® Management Instrumentation, Windows®-Verwaltungsinstrumentation) Exchange_MessageTrackingEntry unter dem Namespace root\MicrosoftExchangeV2 ab, um den Grund für den Eintrag in die Nachrichtenverfolgungsprotokolle zu ermitteln.

Wenn Exchange Server Analyzer feststellt, dass die Eigenschaft EntryType den Wert 1037 hat, wird eine Warnung angezeigt.

Diese Warnung bedeutet, dass mindestens ein Fehler bei den vorherigen Versuchen der Verarbeitung der Nachricht in der Warteschlange Lokale Übermittlung aufgetreten ist.

Die Warteschlange Lokale Übermittlung enthält Nachrichten, die auf dem Server mit Exchange zur lokalen Übermittlung an ein Exchange Server-Postfach oder einen Informationsspeicher für Öffentliche Ordner abgelegt werden.

Nachrichten können sich in dieser Warteschlange ansammeln, wenn der Server mit Exchange keine Nachrichten für die lokale Übermittlung annimmt. Eine langsame oder nur zeitweise Nachrichtenübermittlung kann ein Hinweis auf eine Nachricht in einer Schleife oder ein Leistungsproblem sein.

Mit dem Befehl Verbindung erzwingen kann der Status von Warteschlangen von Wiederholen und Geplant in Aktiv geändert werden. Dadurch funktioniert die Warteschlange so, als ob das Wiederholungsintervall abgelaufen oder der geplante Zeitpunkt erreicht sei. Diese Methode funktioniert jedoch nicht immer.

Hinweis:
Die Eigenschaften einer Warteschlange können einen bestimmten Grund angeben, warum eine Warteschlange den Status Wiederholen hat.

Erhöhen Sie zum Beheben dieses Fehlers den Protokolliergrad für die Diagnose der SMTP-Speichertreiberkomponenten der Dienste MSExchangeIS und MSExchangeTransport.

Weitere Informationen zum Ändern von Protokolleinstellungen finden Sie unter "Ändern von Protokollierungseinstellungen für MSExchangeTransport" im Kapitel "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Microsoft Knowledge Base-Artikel 821877 mit einer Beschreibung der Felder auf den Eigenschaftsregisterkarten für die SMTP- und X.400-Warteschlange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Wiederholen des Routings
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Das Tool Microsoft® Exchange Server Analyzer sendet eine Testnachricht vom Server mit Exchange an das Postmasterkonto oder ein benutzerdefiniertes Konto für die SMTP-Domäne (Simple Mail Transfer Protocol) und untersucht anschließend die Nachrichtenverfolgungsprotokolle des Servers, um zu bestimmen, ob bei der Übermittlung der Testnachricht Probleme aufgetreten sind.

Im Rahmen dieser Untersuchung fragt Exchange Server Analyzer die Eigenschaft EntryType der Microsoft WMI-Klasse (Windows® Management Instrumentation, Windows®-Verwaltungsinstrumentation) Exchange_MessageTrackingEntry unter dem Namespace root\MicrosoftExchangeV2 ab, um den Grund für den Eintrag in die Nachrichtenverfolgungsprotokolle zu ermitteln.

Wenn Exchange Server Analyzer feststellt, dass die Eigenschaft EntryType den Wert 1035 hat, zeigt Exchange Server Analyzer eine Warnung an.

Diese Warnung bedeutet, dass sich die Testnachricht in einer Warteschlange befindet, die für eine Wiederholung des Routings eingeplant ist. Wenn eine Warteschlange den Status Wiederholen hat, bedeutet dies, dass mindestens ein Fehler bei den vorherigen Versuchen der Verarbeitung der Nachrichten in der Warteschlange aufgetreten ist. Mit dem Befehl Verbindung erzwingen kann der Status von Warteschlangen von Wiederholen und Geplant in Aktiv geändert werden. Dadurch funktioniert die Warteschlange so, als ob das Wiederholungsintervall abgelaufen oder der geplante Zeitpunkt erreicht sei. Diese Methode funktioniert jedoch nicht immer.

Hinweis:
Die Eigenschaften einer Warteschlange können einen bestimmten Grund angeben, warum eine Warteschlange den Status Wiederholen hat.

Nachrichten sammeln sich bei Exchange Server-Routingproblemen in dieser Warteschlange an. Die Nachrichten wurden aufgrund eines vorübergehenden Fehlers nicht geroutet, weil das Routingmodul nicht erfolgreich initialisiert wurde. Die Nachrichten befinden sich in dieser Warteschlange und warten auf einen Wiederholungs- oder erneuten Routingvorgang.

Erhöhen Sie zum Beheben dieses Fehlers den Protokolliergrad für die Diagnose des Diensts MSExchangeTransport, um Informationen zu Komponenten des Routingmoduls zu erfassen. Deaktivieren Sie unnötige Connectoreinschränkungen, da diese eine wesentliche Verschlechterung der Serverleistung verursachen können. Aufgrund bestimmter Vorgaben muss der Registrierungsschlüssel CheckConnectorRestrictions ggf. aktiviert sein.

Weitere Informationen zum Ändern von Protokolleinstellungen finden Sie unter "Ändern von Protokollierungseinstellungen für MSExchangeTransport" im Kapitel "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Microsoft Knowledge Base-Artikel 821877 mit einer Beschreibung der Felder auf den Eigenschaftsregisterkarten für die SMTP- und X.400-Warteschlange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Die umgekehrte DNS-Suche wurde in der Metabase aktiviert, nicht aber auf dem zugeordneten SMTP-Server in Active Directory
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-01-17

Microsoft® Exchange Server Analyzer liest die folgende Eigenschaft in der IIS-Metabase (Internet Information Services), um zu ermitteln, ob der zugehörige Wert mit dem konfigurierten Wert des Attributs msExchSmtpPerformReverseDnsLookup im Active Directory®-Verzeichnisdienst übereinstimmt:

/LM/SmtpSvc/<SMTP virtual server instance>/EnableReverseDnsLookup

Wenn Microsoft Exchange Server Analyzer feststellt, dass die Werte nicht übereinstimmen, wird eine Warnmeldung angezeigt.

Wenn der Wert in der IIS-Metabase nicht mit dem Wert in Active Directory übereinstimmt, kann dies auf ein Problem mit der Active Directory-Replikation oder Verzeichnisdienst-Nach-Metabase-Replikationskomponente (DS2MB) in Exchange hinweisen.

Die Funktion des DS2MB-Vorgangs besteht darin, die Konfigurationsinformationen von Active Directory in die lokale Metabase zu übertragen. Anstatt in der Registrierung ist diese Konfiguration aus Leistungs- und Skalierbarkeitsgründen in der lokalen Metabase gespeichert. In Exchange 2000 Server und Exchange Server 2003 werden alle Internet-Protokolle (SMTP, NNTP, POP3, IMAP4 und HTTP) als Komponenten von IIS ausgeführt.

Alle 15 Minuten kopiert der DS2MB-Vorgang die gesamten Unterstrukturen von Active Directory, ohne die Form der Unterstruktur zu ändern. Dieser Schreibvorgang erfolgt einseitig von Active Directory zur Metabase; die Metabase schreibt niemals ins Active Directory.

Die Eigenschaft EnableReverseDnsLookup und das Attribut msExchSmtpPerformReverseDnsLookup können beide den Wert TRUE oder FALSE aufweisen. Der Wert TRUE bedeutet, dass der virtuelle SMTP-Server umgekehrte DNS-Suchen für alle eingehenden Nachrichten durchführt. Der Wert FALSE bedeutet, dass keine umgekehrten DNS-Suchen durchgeführt werden. Aufgrund möglicher Leistungseinschränkungen infolge falsch konfigurierter DNS-Einträge oder von Unterbrechungen von Internetverbindungen sind die Eigenschaft EnableReverseDnsLookup und das Attribut msExchSmtpPerformReverseDnsLookup in der Standardeinstellung auf FALSE festgelegt.

Wenn die Eigenschaft EnableReverseDnsLookup auf TRUE (aktiviert) und das Attribut msExchSmtpPerformReverseDnsLookup auf FALSE (deaktiviert) festgelegt sind, bedeutet dies, dass Active Directory und die IIS-Metabase nicht synchronisiert sind. Wenn dieses Problem durch einen Fehler beim DS2MB-Vorgang verursacht wurde, können Sie es mithilfe des folgenden Verfahrens für die bei Ihnen ausgeführte Version von Exchange Server beheben. Wenn dieses Problem auftritt, weil die Active Directory-Replikation teilweise oder vollständig fehlgeschlagen ist, können Sie mithilfe des Replikationsmonitor-Dienstprogramms für Active Directory (ReplMon.exe) den Zustand und Status der Active Directory-Replikation überprüfen. ReplMon.exe finden Sie auf der Windows Server-CD-ROM bei den Windows®-Supporttools.

So beheben Sie den Fehler unter Exchange Server 2003

  1. Überprüfen Sie das Vorhandensein von Anwendungsereignisprotokolleinträgen mit der Quelle MSExchangeMU. Bei einem Fehler von DS2MB wird ein Ereignis unter Exchange Server 2003 protokolliert.

  2. Wenn Sie keine DS2MB-Fehler entdecken, überprüfen Sie mithilfe von ReplMon die Active Directory-Replikation. Achten Sie insbesondere auf die globalen Katalogserver, die vom virtuellen SMTP-Server verwendet werden.

  3. Wenn Sie DS2MB-Fehler entdecken oder Probleme mit der Active Directory-Replikation beseitigt oder gelöst haben, starten Sie den Exchange-Systemaufsichtsdienst neu.

So beheben Sie diesen Fehler unter Exchange 2000 Server

  1. Überprüfen Sie mithilfe von ReplMon die Active Directory-Replikation. Achten Sie insbesondere auf die globalen Katalogserver, die vom virtuellen SMTP-Server verwendet werden.

  2. Nachdem Sie Probleme mit der Active Directory-Replikation beseitigt oder gelöst haben, starten Sie die Exchange-Systemaufsicht neu.

Weitere Informationen zur Funktion für die umgekehrte DNS-Suche in Exchange finden Sie im Microsoft Knowledge Base-Artikel 297412 „The 'Perform Reverse DNS Lookup for Incoming Messages' Option Is for Host Name Resolution" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den Microsoft Knowledge Base-Artikeln 266686, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) und 268163, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

Weitere Informationen zur Active Directory-Replikation finden Sie im Microsoft Knowledge Base-Artikel 232072, „Einleiten der Replikation zwischen direkten Replikationspartnern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Weitere Informationen zum DS2MB-Vorgang finden Sie im Microsoft Knowledge Base-Artikel 240105, „XGEN: General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105).


Routingmodul: Der Parameter „AttachedTimeout" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob die Routinglogik des SMTP-Connectors (Simple Mail Transfer Protocol) von der Standardeinstellung in einen anderen Wert geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\AttachedTimeout

Wenn Exchange Server Analyzer feststellt, dass der Registrierungsschlüssel AttachedTimeout vorhanden und mit einem Wert konfiguriert ist, der größer ist als 300, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Bei dem Registrierungseintrag AttachedTimeout handelt es sich um eine benutzerdefinierte Konfigurationseinstellung für Exchange Server mit der bestimmt wird, wie häufig das Paket ORG_INFO gesendet wird. Jedes Mal, wenn der Routingclient keine Verbindung zu einem Routingserver herstellen kann, wird die Benutzerversion der Topologie erhöht, und das Paket ORG_INFO wird an die gesamte Organisation weitergeleitet.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Löschen Sie den Registrierungsschlüssel AttachedTimeout.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den IIS-Verwaltungsdienst erneut, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Registrierungswert AttachedTimeout finden Sie im Knowledge Base-Artikel 832281 „Link state issues and routing issues in Exchange 2000 Server and in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832281).


Routingmodul: Der Parameter „BestAddressMatchOnly" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob die Routinglogik des SMTP-Connectors (Simple Mail Transfer Protocol) von der Standardeinstellung in einen anderen Wert geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\BestAddressMatchOnly

Wenn Exchange Server Analyzer feststellt, dass der Registrierungsschlüssel BestAddressMatchOnly vorhanden und mit einem Wert konfiguriert ist, der größer ist als 0, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Registrierungseintrag BestAddressMatchOnly ist eine benutzerdefinierte Konfigurationseinstellung für Exchange Server, die dazu führt, dass an eine bestimmte Domäne gesendete E-Mail-Nachrichten über einen bestimmten Connector ungeachtet aller vorhandenen Einschränkungen geroutet werden.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Löschen Sie den Registrierungsschlüssel BestAddressMatchOnly.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den IIS-Verwaltungsdienst erneut, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung enthält.


Routingmodul: Der Parameter „CheckConnectorRestrictions" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob die Routinglogik des SMTP-Connectors (Simple Mail Transfer Protocol) von der Standardeinstellung in einen anderen Wert geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\CheckConnectorRestrictions

Wenn Exchange Server Analyzer feststellt, dass der Registrierungsschlüssel CheckConnectorRestrictions vorhanden und mit einem Wert konfiguriert ist, der größer ist als 0, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Registrierungsschlüssel CheckConnectorRestrictions ist eine benutzerdefinierte Konfigurationseinstellung für Exchange Server, mit der die Einschränkungsprüfung auf dem Exchange-Bridgeheadserver aktiviert wird, der die Quelle des überprüften Connectors darstellt. In der Standardeinstellung ist die Einschränkungsprüfung für den Connector ausgeschaltet, da diese erhebliche Auswirkungen auf die Leistung haben kann, besonders in Konfigurationen mit vielen Verteilergruppen. Die Einschränkungen werden für jede durch das System transportierte Nachricht an jedes Mitglied der einzelnen Verteilergruppen überprüft. Wenn Einschränkungen angegeben, dieser Registrierungseintrag jedoch nicht vorhanden ist, wird die Einschränkungsprüfung nicht ausgeführt.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Löschen Sie den Registrierungsschlüssel CheckConnectorRestrictions.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den IIS-Verwaltungsdienst neu.

  6. Aktivieren Sie auf der Registerkarte Empfangseinschränkungen des Connectors die Einschränkungsoption erneut.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Registrierungswert CheckConnectorRestrictions finden Sie im Knowledge Base-Artikel 277872 „XCON: Connector Delivery Restrictions May Not Work Correctly" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872.


Routingmodul: Der Parameter „Configuration" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob das Leseintervall des Active Directory®-Verzeichnisdiensts für die Einstellung des Exchange-Routingmoduls von der Standardeinstellung abweicht:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RESvc\Parameters\ReloadOsInterval

Wenn Exchange Server Analyzer ermittelt, dass der Datenwert für ReloadOsInterval auf einen anderen Wert als 3600 festgelegt ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Mit dem Wert ReloadOsInterval wird das Intervall angegeben, in dem Statusinformationen zur Routingverbindung zwischen zwei Exchange-Servern aktualisiert werden. Exchange verwendet Statusinformationen zur Routingverbindung, sodass für alle Server sowohl die günstigste Route zum Übermitteln einer Nachricht als auch die Funktionsfähigkeit der Connectors dieser Route bestimmt werden kann. In der Standardeinstellung lesen Exchange-Server die Verbindungsstatusinformationen alle 3.600 Sekunden (1 Stunde) aus Active Directory.

Unter bestimmten Umständen werden die Routingstatusinformationen nicht ordnungsgemäß dynamisch zwischen den Servern einer Exchange-Organisation weitergegeben. Einige Server in der Organisation arbeiten weiterhin mit alten und möglicherweise falschen Routingstatusinformationen. Diese Situation kann auch dazu führen, dass neue Connectors beim Anzeigen einer Remoteroutinggruppe mit dem WinRoute-Tool (Winroute.exe) nicht angezeigt werden. Mit dem WinRoute-Tool können Sie überprüfen, ob die Verbindungsstatusinformationen weitergegeben werden. Um zu überprüfen, ob die Informationen weitergegeben werden, zeigen Sie mit dem WinRoute-Tool die Verbindungsstatusinformationen verschiedener Stellen in der Exchange-Organisation an, und vergleichen Sie dann die Versionsnummern für alle Routinggruppen. Das WinRoute-Tool stellt eine Verbindung mit dem Verbindungsstatusanschluss auf einem Exchange Server-Computer her und extrahiert die Verbindungsstatusinformationen für die Exchange-Organisation. Auch wenn es sich bei den Verbindungsstatusinformationen um eine Reihe von global eindeutigen Bezeichnern (GUIDs - Globally Unique Identifiers) handelt, gleicht WinRoute die GUIDs von Connectors und Bridgeheadservern mit Objekten in Active Directory ab und stellt die Informationen in einem lesbaren Format dar.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SYSTEM\CurrentControlSet\Services\RESvc\Parameters

  3. Doppelklicken Sie im rechten Bereich auf ReloadOsInterval.

  4. Geben Sie im Datenfeld Wert den Wert 3600 ein, und klicken Sie dann auf OK.

  5. Schließen Sie den Registrierungs-Editor.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://support.microsoft.com/kb/256986/de).

Weitere Informationen zu Routing- und Verbindungsstatusinformationen finden Sie in den folgenden Knowledge Base-Artikeln:

  • 842026, „Routing status information is not propagated correctly to all servers in Exchange 2000 Server or in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=842026)

  • 285130, „XCON: Link State Information" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285130)

Informationen zum Downloaden von WinRoute, einem Tool zum Bestimmen der dem Routingmaster bekannten Verbindungsstatusinformationen finden Sie unter „Exchange Server WinRoute" (http://go.microsoft.com/fwlink/?LinkId=25049).


Routingmodul: Der Parameter „ClientMonitoringReportLevel" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob die Routinglogik des SMTP-Connectors (Simple Mail Transfer Protocol) von der Standardeinstellung in einen anderen Wert geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\PollingInterval

Wenn Exchange Server Analyzer feststellt, dass der Registrierungsschlüssel PollingInterval vorhanden und mit einem Wert konfiguriert ist, der größer ist als 300, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Bei dem Registrierungseintrag PollingInterval handelt es sich um eine benutzerdefinierte Konfigurationseinstellung für Exchange Server, mit der die Häufigkeit des Verbindungsstatus-Datenverkehrs zwischen Routinggruppen und insbesondere zum und vom Routinggruppenmaster innerhalb einer Routinggruppe gesteuert wird. Durch das Erhöhen dieser Einstellung können Fehler in Verbindungen vermieden werden, aber es kann verhindert werden, dass eine größere Menge langsamer Verbindungen zwischen Membern einer Routinggruppe gesendet wird.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Löschen Sie den Registrierungsschlüssel PollingInterval.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den IIS-Verwaltungsdienst erneut, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung enthält.


Routingmodul: Der Parameter „StateChangeDelay" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob die Routinglogik des SMTP-Connectors (Simple Mail Transfer Protocol) von der Standardeinstellung in einen anderen Wert geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\StateChangeDelay

Wenn Exchange Server Analyzer feststellt, dass der Registrierungsschlüssel StateChangeDelay vorhanden und mit einem Wert konfiguriert ist, der größer ist als 0, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Registrierungseintrag StateChangeDelay ist eine benutzerdefinierte Konfigurationseinstellung für Exchange Server, mit deren Benachrichtigungen aufgrund von Änderungen im Status von Connector und Server sowie das Intervall gesteuert werden, in dem Connectors als nicht verfügbar markiert werden. Wenn StateChangeDelay auf einen Wert größer als 0 festgelegt ist, kann ein Server nur einmal in der von diesem Wert festgelegten Zeitspanne als verfügbar oder nicht verfügbar markiert werden.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Löschen Sie den Registrierungsschlüssel StateChangeDelay.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den IIS-Verwaltungsdienst erneut, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung enthält.


Routingmodul: Der Parameter „SuppressStateChanges" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob die Routinglogik des SMTP-Connectors (Simple Mail Transfer Protocol) von der Standardeinstellung in einen anderen Wert geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\SuppressStateChanges

Wenn Exchange Server Analyzer feststellt, dass der Registrierungsschlüssel SuppressStateChanges vorhanden und mit einem Wert konfiguriert ist, der größer ist als 0, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Exchange Server 2003 enthält Funktionen für die automatische Erkennung von Änderungen des Status einer Verbindung. Mit diesen Daten können andere Server, die Exchange Server 2003 ausführen, darüber informiert werden, dass eine alternative Route anstelle der primären Route mit den geringsten Kosten verwendet werden soll. Die Verbindungsstatusinformationen werden in wesentliche und unwesentliche Änderungen unterteilt. Ein wesentliche Änderung tritt auf, wenn der Administrator die Routingtopologie ändert, z. B durch Hinzufügen eines neuen Connectors oder durch Kostenänderung. Unwesentliche Änderungen treten auf, wenn das System automatisch den Fehler oder die Wiederherstellung einer Verbindung erkennt.

Dieses Feature ist gut für kleine bis mittelgroße Organisationen geeignet. In großen Umgebungen mit vielen Standorten kann jedoch eine hohe Netzwerkfluktuation zu einer Flut von Verbindungsaktualisierungen der unwesentlichen Art führen. Um wirklich effektiv zu sein, müssen die Verbindungsstatusinformationen an alle Server in der Organisation weitergeleitet werden. Darüber hinaus wird bei Statusänderungen erneut die vollständige Verbindungsstatustabelle übertragen. Dies kann zu erheblichen Datenmengen führen, die über das Netzwerk übermittelt werden müssen. In diesen Szenarien kann es nützlich sein, die unwesentlichen Verbindungsstatusänderungen zu unterdrücken. Der Registrierungseintrag SuppressStateChanges ist eine benutzerdefinierte Konfigurationseinstellung zum Unterdrücken der unwesentlichen Verbindungsstatusänderungen. Wenn SuppressStateChanges auf einen Wert festgelegt ist, der größer als 0 ist, werden alle Verbindungsstatusänderungen auf diesem Exchange Server-Computer unterdrückt.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Löschen Sie den Registrierungsschlüssel SuppressStateChanges.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie die Dienste SMTP (Simple Mail Transfer Protocol), Microsoft Exchange Routing Engine und Microsoft Exchange MTA-Stacks neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Registrierungsschlüssel SuppressStateChanges finden Sie in den folgenden Microsoft-Handbüchern:

  • Transport- und Routing-Handbuch für Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=c092b7a7-9034-4401-949c-b29d47131622&DisplayLang=de)

  • Handbuch zur Leistung und Skalierbarkeit von Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=62fb1297-4c6b-4d84-84cc-060989f2f305&DisplayLang=de)


Routinggruppenconnector mit festgelegten Übermittlungseinschränkungen für Verteilergruppen
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-09-06

Microsoft® Exchange Server Analyzer fragt die folgenden Attribute für jedes im Active Directory®-Verzeichnisdienst erkannte Routinggruppenconnectorobjekt (msExchRoutingGroupConnector) ab, zu ermitteln, ob für diese Objekte Übermittlungseinschränkungen basierend auf der Mitgliedschaft in Verteilergruppen festgelegt sind.

dLMemRejectPerms | Enthält die Domänennamen (DNs) der Verteilerlisten (Distribution List, DL), deren Mitglieder keine Nachrichten über diesen Routinggruppenconnector senden dürfen.
dLMemSubmitPerms | Enthält die Domänennamen (DNs) der Verteilerlisten (Distribution List, DL), deren Mitglieder Nachrichten über diesen Routinggruppenconnector senden dürfen.

Wenn Exchange Server Analyzer feststellt, dass Routinggruppenconnectors vorhanden sind, für die Übermittlungseinschränkungen basierend auf der Mitgliedschaft in Verteilergruppen festgelegt sind, zeigt Exchange Server Analyzer eine Warnung an.

Diese Warnung gibt an, dass sich Übermittlungseinschränkungen, die auf der Mitgliedschaft in Verteilergruppen basieren, möglicherweise negativ auf die Leistung der Exchange-Nachrichtenübermittlung auswirken.

Wenn Sie E-Mails über Routinggruppenconnectors senden, für die Übermittlungseinschränkungen basierend auf der Mitgliedschaft in Verteilergruppen festgelegt wurden, muss das Nachrichtenkategorisierungsmodul die Mitgliedschaft der Verteilergruppe erweitern, die vollständige Liste der DNs der Mitglieder anfordern und anschließend die Liste der DNs mit den DNs der Absender vergleichen. Eine Zugriffsoperation oder eine Verweigerungsoperation erfolgt, wenn in beiden Listen eine Übereinstimmung bei einem DN gefunden wird. Wenn eine Verteilergruppe in eine andere Verteilergruppe geschachtelt ist, wird die geschachtelte Verteilergruppe ebenfalls erweitert.

So beheben Sie diese Warnung

  • Erstellen Sie eine dedizierte Routinggruppe für Connectoreinschränkungen, und konfigurieren Sie sie als lokale Routinggruppe gemäß den Erläuterungen im Microsoft Knowledge Base-Artikel 329171, "XADM: Übermittlung von E-Mails ist langsam, wenn Empfänger mit Übermittlungseinschränkungen basierend auf der Gruppenmitgliedschaft konfiguriert sind" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • Verwenden Sie einen dedizierten und robusteren globalen Katalogserver als für den Connector vorgesehenen Bridgehead-Server.

  • Konfigurieren Sie einzelne Postfächer und keine Verteilergruppen für Übermittlungseinschränkungen gemäß den Erläuterungen im Microsoft Knowledge Base-Artikel 812298, "Übermittlung von E-Mails ist langsam, nachdem Sie Übermittlungseinschränkungen konfiguriert haben, die auf einer Verteilerliste basieren" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Ziehen Sie das Implementieren der SMTP-Absenderfilterung (Simple Mail Transfer Protocol) in Betracht.

  • Erwägen Sie für Server, auf denen Microsoft Exchange Server 2003 Service Pack 2 (SP2) oder höher ausgeführt wird, die nicht hierarchische Einschränkungsüberprüfung zu implementieren. Bei Servern, auf denen Versionen von Exchange vor Exchange 2003 SP2 ausgeführt werden, sollten Sie die Aktualisierung auf Exchange 2003 SP2 in Betracht ziehen.

Weitere Informationen

Weitere Informationen zu der nicht hierarchischen Einschränkungsüberprüfung finden Sie unter Empfohlene Vorgehensweise: Nicht hierarchische Einschränkungsüberprüfung..

Weitere Informationen zu der SMTP-Absenderfilterung finden Sie unter "Aktivieren der Absenderfilterung" im Exchange Server 2003-Administratorhandbuch (http://go.microsoft.com/fwlink/?LinkId=72967).

Weitere Informationen zu der Auswirkung der Verteilergruppeneinschränkung auf den E-Mail-Verkehr in Exchange finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 329171 "XADM: Übermittlung von E-Mails ist langsam, wenn Empfänger mit Übermittlungseinschränkungen basierend auf der Gruppenmitgliedschaft konfiguriert sind" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • 895407, "Die Nachrichtenübermittlung zu lokalen und externen Postfächern ist in Exchange Server 2003 langsamer als erwartet, nachdem Sie die Übermittlungseinschränkungen basierend auf Verteilergruppen konfiguriert haben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 839949 "Problembehandlung bei E-Mail-Transport und Verteilergruppen in Exchange 2000 Server und in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).


Routinggruppenmaster wurde gelöscht.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory ®-Verzeichnisdienst ab, um den Wert des Attributs msExchRoutingMasterDN für jeden Routinggruppencontainer zu bestimmen. Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert für das Attribut msExchRoutingMasterDN die Zeichenfolge „DEL:" enthält, wird ein Fehler angezeigt.

Bei msExchRoutingMasterDN handelt es sich um ein Attribut, das nur einen Wert haben darf. Es speichert den Distinguished Name des Exchange Server-Computers, der als Routinggruppenmaster für die jeweilige Routinggruppe dient. Das Vorhandensein der Zeichenfolge „DEL:" kann darauf hinweisen, dass der vorherige Routinggruppenmaster über das Tool Active Directory-Benutzer und -Computer gelöscht wurde. Exchange benötigt einen Routinggruppenmaster, um die Routingtopologie ordnungsgemäß aktualisieren und verwalten zu können.

Beim Erstellen einer Routinggruppe wird dem ersten Server in dieser Routinggruppe die Rolle des Routinggruppenmasters zugewiesen. Der Routinggruppenmaster verwaltet die aktuellen Verbindungsstatusinformationen seiner Routinggruppe und gibt diese an die anderen Server in der Routinggruppe weiter. Der Routinggruppenmaster überwacht nur die in Active Directory eingetragene Routingkonfiguration seiner Routinggruppe. Mitgliedsserver können alle Connectorzustands- und Serververfügbarkeitsinformationen an den Routinggruppenmaster übertragen. Wenn beispielsweise ein Mitgliedsserver versucht, eine Verbindung zu einem anderen Server in einer anderen Routinggruppe über einen Connector herzustellen, diese Verbindung aber nicht verfügbar ist, benachrichtigt der Mitgliedsserver sofort den Routinggruppenmaster. Entsprechend überträgt ein Server, der nicht als Routinggruppenmaster fungiert, Connectorzustandsinformationen an den Routinggruppenmaster, wenn er neue Verbindungszustandsinformationen erhält, damit die anderen Server diese Routingänderungsinformationen erhalten.

So berichtigen Sie diesen Fehler

  1. Erweitern Sie im Exchange-System-Manager unter Administrative Gruppen den Eintrag Administrative_Group und dann Routinggruppen.

  2. Erweitern Sie die Routinggruppe, und klicken Sie anschließend auf Mitglieder.

  3. Klicken Sie im rechten Bereich mit der rechten Maustaste auf den Exchange-Computer, den Sie als Routinggruppenmaster konfigurieren möchten, und klicken Sie dann auf Als Master festlegen.

Weitere Informationen zu Routinggruppenmastern finden Sie im Transport- und Routing-Handbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47579) unter „Konfigurieren der Routingtopologie".


Fehler bei der Routinggruppenmitgliedschaft
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-21

Microsoft® Exchange Server Analyzer fragt jeden Wert des Attributs msExchRoutingGroupMembersBL in den Routing Group-Objekten im Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob der Backlink-Server zu der dedizierten administrativen Gruppe von Microsoft Exchange Server 2007 Exchange - Administrative Gruppe (FYDIBOHF23SPDLT) gehört.

Darüber hinaus fragt Exchange Server Analyzer den Wert des Attributs CN für das Objekt Routing Group ab, um zu ermitteln, ob der Wert dem Standardwert der Exchange 2007-Routinggruppe Exchange-Routinggruppe (DWBGZMFD01QNBJR) entspricht.

Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Der Backlink-Server gehört zu der dedizierten administrativen Gruppe von Exchange 2007: Exchange - Administrative Gruppe (YDIBOHF23SPDLT).

  • Bei der Routinggruppe handelt es sich nicht um die Standardroutinggruppe von Exchange 2007: Exchange-Routinggruppe (DWBGZMFD01QNBJR).

Dieser Fehler weist darauf hin, dass der Server unter Umständen manuell aus der Standardroutinggruppe von Exchange 2007 verschoben wurde. Dies kann zu Routingproblemen führen.

Microsoft Exchange Server 2003 und Microsoft Exchange 2000 Server verwenden Routinggruppen zum Definieren einer Exchange-spezifischen Routingtopologie. Exchange 2007 verwendet zum Definieren der Routingtopologie Active Directory-Standorte. Exchange 2003 und Exchange 2000 bedienen sich einer Routingtopologie, die auf Routinggruppen und Connectors basiert. Eine Exchange-spezifische Routingkonfiguration ist in einer reinen Exchange 2007-Organisation nicht mehr erforderlich. In einer reinen Exchange 2007-Organisation wird die Active Directory-Standorttopologie zur Ermittlung der Routingtopologie eingesetzt.

Um Unterstützung für die Koexistenz zwischen den beiden Routingtopologien zu bieten, werden beim Installieren von Exchange 2007 alle Exchange 2007-Server automatisch einer einzigen Routinggruppe hinzugefügt. Die Exchange 2007-Routinggruppe wird im Exchange-System-Manager von Exchange 2003 oder Exchange 2000 als Exchange-Routinggruppe (DWBGZMFD01QNBJR) innerhalb von Exchange - Administrative Gruppe (FYDIBOHF23SPDLT) erkannt.

Um dieses Problem zu beheben, müssen Sie die Exchange 2007-Server in die dedizierte Exchange 2007-Routinggruppe verschieben oder den Server entfernen und neu installieren.


Sendeconnector deaktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-07-30

Das Tool Microsoft Exchange Analyzer Tool verwendet das folgende Cmdlet der Exchange-Verwaltungsshell, um alle Sendeconnectors in der Exchange-Umgebung abzufragen, deren Wert für das Attribut Enabled auf False festgelegt ist. Der Wert False für das Attribut Enabled des Sendeconnectors gibt an, dass der Sendeconnector deaktiviert ist.

Get-SendConnector | where { $_.Enabled -eq $False}

Exchange Server Analyzer fragt dann den Active Directory-Verzeichnisdienst ab, um den Wert des Attributs serialNumber für alle Objekte der Objektklasse msExchExchangeServer zu ermitteln.

Wenn der Zeichenfolgenwert Version 5.5 enthält, wird auf dem Computer Microsoft Exchange Server 5.5 ausgeführt. Wenn der Zeichenfolgenwert Version 6.0 enthält, wird auf dem Computer Microsoft Exchange 2000 Server ausgeführt. Wenn der Zeichenfolgenwert Version 6.5 enthält, wird auf dem Computer Exchange Server 2003 ausgeführt. Wenn der Zeichenfolgenwert Version 8 enthält, wird auf dem Computer Exchange Server 2007 ausgeführt.

Wenn Exchange Analyzer feststellt, dass ein Sendeconnector in einer Exchange-Umgebung deaktiviert ist, die auch Servercomputer mit Exchange 2000 oder Exchange 2003 enthält, wird ein Fehler angezeigt.

Dieser Fehler zeigt an, dass das Exchange 2007-Routing zwar deaktivierte Sendeconnectors ignoriert, Exchange 2000 und Exchange 2003 jedoch das deaktivierte Flag für den Connector nicht erkennen und weiterhin versuchen, Nachrichten durch den Connector weiterzuleiten. Dieses Verhalten führt zu Routingschleifen.

Um diesen Fehler zu beheben, löschen Sie alle deaktivierten Sendeconnectors in Exchange-Umgebungen, in denen Exchange 2000 oder Exchange 2003 ausgeführt wird.

Um einen deaktivierten Sendeconnector zu löschen, befolgen Sie die Anweisungen für die Verwendung des Cmdlets Remove-SendConnector der Exchange-Verwaltungsshell im Thema "Remove-SendConnector" (http://go.microsoft.com/fwlink/?LinkId=96007) in der Exchange Server 2007-Produktdokumentation.


Absenderfilterung aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob die Eigenschaft msExchServerBindingsTurflist eines virtuellen SMTP-Serverobjekts (Simple Mail Transfer Protocol) angibt, dass die Absenderfilterung für eine virtuelle SMTP-Serverinstanz aktiviert ist.

Exchange Server Analyzer fragt Active Directory auch ab, um zu ermitteln, ob die Eigenschaft msExchTurfListNames oder msExchTurfListOptions angibt, dass die Absenderfilterung auf der Ebene der globalen Einstellungen aktiviert ist.

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Die Absenderfilterung ist für eine virtuelle SMTP-Serverinstanz aktiviert.

  • Die Absenderfilterung ist auf der Ebene der globalen Einstellungen aktiviert.

Diese Warnung bedeutet, dass die Absenderfilterung wirksam aktiviert ist. Dass die Absenderfilterung aktiviert ist, stellt im Allgemeinen kein Problem dar, es sei denn, Sie beheben Nachrichtenflussprobleme eines bestimmten Servers. Ist dies der Fall, müssen Sie ggf. die Filterkonfiguration überprüfen oder die Absenderfilterung vorübergehend deaktivieren, um zu ermitteln, ob diese fälschlicherweise erwünschte E-Mail von zulässigen Absendern blockt.

So deaktivieren Sie einen Absenderfilter auf einem virtuellen SMTP-Server

  1. Starten Sie den Exchange-System-Manager: Klicken Sie auf Start, zeigen Sie auf Alle Programme, zeigen Sie auf Microsoft Exchange, und klicken Sie dann auf System-Manager.

  2. Erweitern Sie in der Konsolenstruktur Server, dann den gewünschten Server, danach Protokolle und anschließend SMTP.

  3. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server, auf dem Sie den Filter deaktivieren möchten, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie im Dialogfeld Eigenschaften des <virtuellen SMTP-Servers> auf der Registerkarte Allgemein auf Erweitert.

  5. Wählen Sie in Erweitert die IP-Adresse aus, für die Sie den Filter deaktivieren möchten, und klicken Sie auf Bearbeiten.

  6. Deaktivieren Sie in Identifikation die Option Absenderfilter anwenden, um den Filter zu deaktivieren.

  7. Sind mehrere virtuelle Server vorhanden, wiederholen Sie die Schritte 3 bis 6 für jeden virtuellen Server, auf dem Sie den Filter deaktivieren möchten.

Weitere Informationen zur intelligenten Nachrichtenfilterung finden Sie auf der Website "Exchange Intelligent Message Filter" (http://go.microsoft.com/fwlink/?LinkId=21607).

Weitere Informationen zum Konfigurieren der Filterung zur Abwehr von Spam finden Sie unter "Konfigurieren der Spamsteuerung und -filterung" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).


Absenderfilterung aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob die Eigenschaft msExchServerBindingsFiltering eines virtuellen SMTP-Serverobjekts (Simple Mail Transfer Protocol) angibt, dass die Absenderfilterung für eine virtuelle SMTP-Serverinstanz aktiviert ist.

Exchange Server Analyzer fragt Active Directory auch ab, um zu ermitteln, ob das Attribut wWWHomePage des Objekts Inhaltsfilter für Junk-E-Mail Einträge für die Absender- und Verbindungsfilterung enthält.

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Die Absenderfilterung ist für eine virtuelle SMTP-Serverinstanz aktiviert.

  • Die Absenderfilterung ist auf der Ebene des Objekts Inhaltsfilter für Junk-E-Mail aktiviert.

Diese Warnung bedeutet, dass die Absenderfilterung wirksam aktiviert ist. Dass die Absenderfilterung aktiviert ist, stellt im Allgemeinen kein Problem dar, es sei denn, Sie beheben Nachrichtenflussprobleme eines bestimmten Servers. Ist dies der Fall, müssen Sie ggf. die Filterkonfiguration überprüfen oder die Absenderfilterung vorübergehend deaktivieren, um zu ermitteln, ob diese fälschlicherweise E-Mail von zulässigen Absendern blockt.

So deaktivieren Sie einen Absenderfilter auf einem virtuellen SMTP-Server

  1. Starten Sie den Exchange-System-Manager: Klicken Sie auf Start, zeigen Sie auf Alle Programme, dann auf Microsoft Exchange, und klicken Sie dann auf System-Manager.

  2. Erweitern Sie in der Konsolenstruktur Server, dann den gewünschten Server, danach Protokolle und anschließend SMTP.

  3. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server, auf dem Sie den Filter deaktivieren möchten, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie im Dialogfeld Eigenschaften des <virtuellen SMTP-Servers> auf der Registerkarte Allgemein auf Erweitert.

  5. Wählen Sie in Erweitert die IP-Adresse aus, für die Sie den Filter deaktivieren möchten, und klicken Sie auf Bearbeiten.

  6. Deaktivieren Sie in Identifikation die Option Absenderfilter anwenden, um den Filter zu deaktivieren.

  7. Sind mehrere virtuelle Server vorhanden, wiederholen Sie die Schritte 3 bis 6 für jeden virtuellen Server, auf dem Sie den Filter deaktivieren möchten.

Weitere Informationen zur intelligenten Nachrichtenfilterung finden Sie auf der Website "Exchange Intelligent Message Filter" (http://go.microsoft.com/fwlink/?LinkId=21607).


Server wurde als gemeinsames Ziel identifiziert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-10-04

Microsoft® Exchange Server Analyzer fragt die Exchange_Queue WMI-Klasse (Windows® Management Instrumentation) ab, um die Werte der folgenden Attribute für SMTP-Warteschlangen (Simple Mail Transfer Protocol) auf dem virtuellen SMTP-Server zu bestimmen.

LinkId | Gibt den Bezeichner für den Link an, der die Warteschlange enthält.
QueueId | Gibt den Bezeichner der Warteschlange an.
QueueName | Gibt den Namen der Warteschlange an.
VirtualMachine | Gibt den Namen des virtuellen Computers an, der die Warteschlange enthält.
VirtualServerName | Gibt den Namen des virtuellen Servers an, auf dem sich die Warteschlange befindet.
MessageCount | Gibt die Anzahl der Nachrichten in der Warteschlange an.

Exchange Server Analyzer fragt anhand der hier angegebenen Informationen die WMI-Klasse Exchange_QueuedSMTPMessage nach den Werten der folgenden Attribute für Nachrichten in der Warteschlange ab:

Recipients | Gibt die Empfänger der Nachricht an.
Received | Gibt den Zeitstempel des Empfangs der Nachricht an.
MessageId | Gibt den Bezeichner der in der Warteschlange befindlichen Nachricht an.
StateRetry | Gibt an, dass eine Nachricht, die nicht erfolgreich zugestellt werden konnte, erneut übermittelt wird.

Schließlich verwendet Exchange Server Analyzer die hier erhaltenen Daten dazu, um den Active Directory®-Verzeichnisdienst nach den folgenden werten für jedes Empfänger-Objekt abzufragen. Exchange Server Analyzer ermittelt daraufhin, ob es sich bei dem Empfänger um einen Benutzer, eine Verteilergruppe, einen Öffentlicher Ordner oder einen Informationsspeicher für Öffentliche Ordner handelt:

distinguishedName | Gibt den DN (Distinguished Name) des Objekts an.
msExchHomeServerName | Gibt den Server an, auf dem sich der Empfänger befindet.
homeMDB | Gibt den Postfachspeicher des Empfängers an.

Wenn Exchange Server Analyzer ermittelt, dass 25 Prozent oder mehr der in der Warteschlange festsitzenden Nachrichten entweder im Feld To: oder im Feld Cc: an Empfänger auf einem bestimmten Server adressiert sind, wird eine Warnung angezeigt.

Wenn Exchange Server Analyzer ermittelt, dass 50 Prozent oder mehr der in der Warteschlange festsitzenden Nachrichten entweder im Feld To: oder im Feld Cc: an Empfänger auf einem bestimmten Server adressiert sind, wird ein Fehler angezeigt.

Diese Warnung bzw. dieser Fehler bedeutet, dass der identifizierte Server ein gemeinsames Ziel für Nachrichten ist, die in einer SMTP-Warteschlange festsitzen.

Um dieses Problem zu beheben, sollten Sie überprüfen, ob Konfigurationsprobleme oder andere Anomalien für diesen Server vorliegen, die dazu führen, dass die an diese Verteilergruppe gerichteten Nachrichten in die Warteschlange gesetzt werden.

  • Stellen Sie sicher, dass die Attribute des Serverobjekts ordnungsgemäß eingerichtet wurden und in Active Directory die richtigen Werte enthalten.

  • Überprüfen Sie, ob die Active Directory-Berechtigungen des Serverobjekts richtig eingestellt sind.

  • Wenn der Server der Stammserver für ein spezielles Benutzerobjekt ist, d. h. einen vorgesehenen Journalempfänger, überprüfen Sie, ob der Dienst und die Komponenten, mit denen das Benutzerobjekt verknüpft ist, ordnungsgemäß konfiguriert sind.

  • Suchen Sie nach möglichen unerwünschten kommerziellen E-Mails (UCE oder SPAM) oder Virusangriffen auf den Öffentlichen Ordner.

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei der Nachrichtenübermittlung und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

Weitere Informationen zu der Auswirkung der Verteilergruppeneinschränkung auf die Nachrichtenübermittlung in Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 895407, "Die Nachrichtenübermittlung zu lokalen und externen Postfächern ist in Exchange Server 2003 langsamer als erwartet, nachdem Sie die Übermittlungseinschränkungen basierend auf Verteilergruppen konfiguriert haben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 329171 "XADM: Übermittlung von E-Mails ist langsam, wenn Empfänger mit Übermittlungseinschränkungen basierend auf der Gruppenmitgliedschaft konfiguriert sind" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • 839949, "Problembehandlung bei E-Mail-Transport und Verteilergruppen in Exchange 2000 Server und in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • 812298, "Übermittlung von E-Mails ist langsam, nachdem Sie Übermittlungseinschränkungen konfiguriert haben, die auf einer Verteilerliste basieren" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).


Registrierung der Ereignissenke nicht gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-01-11

Microsoft® Exchange Server Analyzer sendet eine Abfrage an die Microsoft Internet Information Server-Metabase (IIS), um die Liste der SMTP-Transportereignissenken-Bindungen (Simple Mail Transport Protocol) aufzulisten. Exchange Server Analyzer versucht, auf Grundlage einer in Exchange Server Analyzer vorausgefu¨llten Liste eine Reihe von Standardereignisbindungen aufzufinden. Fu¨r jede Bindung u¨berpru¨ft Exchange Server Analyzer die in der Registrierung unter folgender Teilstruktur enthaltenen COM-Registrierungsdetails (Component Object Model):

HKEY_CLASSES_ROOT\CLSID\

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Es wird eine Transportereignissenken-Bindung in der Metabase gefunden.

  • Die entsprechende COM-Registrierung fehlt in der Registrierung.

Ein SMTP-Transportereignis tritt ein, wenn Nachrichtendaten an den SMTP-Dienst bzw. von diesem u¨bertragen werden. Alle Nachrichten durchlaufen Ereignisse. Hierzu geho¨ren ein- und ausgehende X.400- und RPC-Nachrichten. Ein ga¨ngiges Beispiel fu¨r ein eingehendes Transportereignis ist der Eingang einer Nachricht beim SMTP-Dienst u¨ber das Netzwerk oder in das SMTP-Pickup-Verzeichnis. Sobald dieses Ereignis eintritt, benachrichtigt eine Quelle dieses Ereignisses die Transportereignissenken, von denen jede in Abha¨ngigkeit vom Dateninhalt der Nachricht auf eine bestimmte Art reagieren kann. Das System fu¨hrt nach der U¨bergabe der Nachrichtendaten an die Senke mit diesen Daten erst weitere Aktionen aus, nachdem die Senke die Verarbeitung abgeschlossen und die Nachricht zuru¨ckgegeben hat. Die Senke verfu¨gt bei der Ausfu¨hrung der Aktion u¨ber die alleinige Kontrolle u¨ber die Nachrichtendaten und deren Zustand.

Fehlende COM-Registrierungen fu¨r Transportereignissenken-Bindungen ko¨nnen zu Problemen bei der Mailu¨bermittlung fu¨hren. Wenn Exchange Server Anzeichen von Problemen bei der Mailu¨bermittlung zeigt, wie zum Beispiel das Einstellen von Nachrichten in Warteschlangen, registrieren Sie die Transportereignissenken erneut.

So registrieren Sie die Transportereignissenken erneut

  1. O¨ffnen Sie in Microsoft Exchange Server ein Eingabeaufforderungsfenster, und wechseln Sie in den Ordner \Programme\Exchsrvr\Bin.

  2. Geben Sie folgende Befehle ein, um die Transportereignissenken erneut zu registrieren:

    regsvr32 /i exps.dll

    regsvr32 /i miscat.dll

    regsvr32 /i onsubmit.dll

    regsvr32 /i peexch50.dll

    regsvr32 /i phatcat.dll

    regsvr32 /i protolog.dll

    regsvr32 /i reapi.dll

    regsvr32 /i regsinks.dll

    regsvr32 /i tranmsg.dll

    regsvr32 /i turflist.dll

    regsvr32 /i xlsasink.dll

    regsvr32 /i msgfilter.dll

  3. Fu¨hren Sie Exchange Server Analyzer erneut aus, um zu u¨berpru¨fen, dass die Warnungen nicht mehr angezeigt werden. Wenn weiterhin Ereignissenkenregistrierungs-Warnungen angezeigt werden und Probleme bei der Mailu¨bermittlung auftreten, wenden Sie sich an den Microsoft-Produktsupport (PSS).

Weitere Informationen u¨ber Transportereignissenken-Bindungen finden Sie in den folgenden Ressourcen zu Exchange Server:

  • Microsoft Knowledge Base-Artikel 258224, „XCON: Auflisten der registrierten Transportereignissenken" (http://go.microsoft.com/fwlink/?linkID=3052&kbid=258224)

  • „SMTP Service Design" in Technisches Referenzhandbuch fu¨r Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=58876)


Der Smarthost wurde auf dem virtuellen SMTP-Server festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob das Attribut msExchSmtpSmartHost auf einem bestimmten virtuellen SMTP-Server konfiguriert wurde. Wenn Exchange Server Analyzer feststellt, dass das Attribut msExchSmtpSmartHost konfiguriert wurde, wird eine Warnmeldung angezeigt.

Das Konfigurieren eines Smarthosts auf einem virtuellen SMTP-Server ist keine optimale Methode. Stattdessen sollte ein SMTP-Connector erstellt und dort die Einstellung des Smarthosts konfiguriert werden.

Konfigurieren Sie in Exchange Server 2003 mithilfe des Internet Mail-Assistenten die E-Mail-Übermittlung. Weitere Informationen finden Sie im Exchange Server 2003 Transport and Routing Guide (http://go.microsoft.com/fwlink/?LinkId=50099) unter „How to Use Internet Mail Wizard".

Weitere Informationen zum Erstellen von SMTP-Connectoren finden Sie im Exchange Server 2003 Transport and Routing Guide (http://go.microsoft.com/fwlink/?LinkId=50100) unter „How to Create an SMTP Connector".


Der SMTP-Registrierungswert „AdditionalPoolThreadsPerProc" wurde manuell festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-01-17

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob zusätzliche Pool-Threads manuell konfiguriert wurden:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\AdditionalPoolThreadsPerProc

Wenn Exchange Server Analyzer feststellt, dass der Wert AdditionalPoolThreadsPerProc vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In SMTP gibt es fünf Arbeits-Warteschlangen, die einen Pool von Threads verwenden, die als ATQ-Threads bezeichnet werden. Dabei können in der Standardeinstellung zwei dieser Warteschlangen bis zu 90 Prozent der verfügbaren Threads verwenden. Dieser Thread-Pool ist freigegeben für das Annehmen von POP- und IMAP-Anforderungen. Daher kann in einem Szenario mit mittlerer bis hoher Last eine Situation auftreten, in der SMTP Ressourcen von POP- und IMAP-Diensten beibehalten kann.

Sie können entsprechende Threads für POP und IMAP reservieren, indem Sie den Prozentsatz an Threads, die SMTP verwenden kann, begrenzen. Um diese Änderung vorzunehmen, müssen Sie die Gesamtanzahl der für IIS verfügbaren Threads erhöhen. Der einzige Nachteil hierbei besteht in der erhöhten Speicherverwendung für die zusätzlichen Threads.

Es gibt zwei Registrierungswerte, mit denen Sie den SMTP-Prozentsatz an Threads und weiteren Threads pro Prozessor steuern können:

Speicherort: HKLM\System\CurrentControlSet\Services\SMTPSVC\Parameters

Wert: AdditionalPoolThreadsPerProc

Typ: REG_DWORD

Speicherort: HKLM\System\CurrentControlSet\Services\SMTPSVC\Parameters

Wert: MaxPercentPoolThreads

Typ: REG_DWORD

Beide Registrierungswerte sollten auf Exchange Server-Computern, die Teil eines Clusters sind, angepasst werden, wenn durch hohe SMTP-Aktivität POP3-Ressourcen, IMAP4-Ressourcen bzw. beide fehlschlagen. Mit den folgenden Formeln können Sie den optimalen Wert für Ihren Cluster berechnen:

Registrierungswert | Formel
AdditionalPoolThreadsPerProc | ((9 / (MaxPercentPoolThreads/100)) - 4) / 2
MaxPercentPoolThreads | 90 / (2 * Anzahl an virtuellen Protokollservern)

In einem Exchange Server-Cluster mit zwei virtuellen Protokollservern lautet die Formel für MaxPercentPoolThreads beispielsweise: 90 / (2*2) = 22. Beim Berechnen des Wertes für MaxPercentPoolThreads sollten Sie das Ergebnis zur nächsten ganzen Zahl abrunden, wenn die Berechnung zu einem Wert mit Dezimalkomma führt. Wenn die Berechnung des Wertes AdditionalPoolThreadsPerProc einen Wert von mehr als 200 ergibt, müssen Sie den berechneten Wert einem weiteren Registrierungswert zuordnen:

Speicherort: HKLM\System\CurrentControlSet\Services\InetInfo\Parameters\

Wert: PoolThreadLimit

Typ: REG_DWORD

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So konfigurieren Sie die optimale Einstellung des Exchange-Clusters:

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Erstellen Sie einen DWORD-Registrierungswert mit der Bezeichnung AdditionalPoolThreadsPerProc, und legen Sie dessen Datenwert auf die den obigen Formeln entsprechende Zahl fest.

  4. Erstellen Sie einen DWORD-Registrierungswert mit der Bezeichnung MaxPercentPoolThreads, und legen Sie dessen Datenwert auf die den obigen Formeln entsprechende Zahl fest.

  5. Beenden Sie den Registrierungs-Editor, und starten Sie den IIS-Administratordienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://support.microsoft.com/?kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zu dem in diesem Artikel beschriebenen speziellen Clusterressourcenproblem finden Sie im Microsoft Knowledge Base-Artikel 281868, „XADM: Virtuelle POP/IMAP4-Server brechen bei hoher Belastung wiederholt zusammen" (http://support.microsoft.com/kb/281868/de).


SMTP Archive Sink: Archivieren von P1-Kopfzeilen ist festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob SMTP Archive Sink installiert und aktiviert wurde:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Dump P1

Wenn Exchange Server Analyzer feststellt, dass der Wert für Dump P1 größer als 0 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Ein Wert von 0 gibt an, dass die P1-Kopfzeilenarchivierung deaktiviert ist. Ein Wert von 1 gibt an, dass die P1-Kopfzeilenarchivierung aktiviert ist. Andere Werte als 0 und 1 werden nicht unterstützt.

Bei dem Tool SMTP Archive Sink handelt es sich um ein benutzerdefiniertes Skript, das die Archivierung aller Nachrichten aktiviert, die für einen bestimmten Ordner auf einem Exchange-Server eingehen bzw. gesendet werden. Wenn SMTP Archive Sink aktiviert ist, werden in der Standardeinstellung alle Nachrichten und ihre Empfänger in einer EML-Datei archiviert, mit Ausnahme von Bcc-Empfängern.

P1-Kopfzeilen werden auch als „Umschlagdaten" bezeichnet. Bei Umschlagdaten handelt es sich um die tatsächliche Empfängerliste, die Exchange beim Übertragen einer Nachricht generiert und durch die ermöglicht wird, dass eine Nachricht alle Empfänger erreicht. Im Gegensatz zu P2-Kopfzeilen, bei denen es sich um die Empfänger handelt, wie sie vom Absender in einem bestimmten Teil der empfangenen Nachricht deklariert wurden, ändern sich die Umschlagdaten beim Weiterleiten an die verschiedenen Ziele. Diese Änderungen treten aufgrund der Erweiterung der Verteilerlisten und des Verhaltens ausgeblendeter Verteilerlisten auf.

In der Standardeinstellung werden P1-Kopfzeilen nicht archiviert, wenn Sie SMTP Archive Sink installieren und aktivieren. Üblicherweise wird die P1-Kopfzeilenarchivierung nur zur Fehlerbehebung aktiviert.

Wenn Sie auf dem Computer keine P1-Kopfzeilen archivieren möchten, können Sie den Registrierungsschlüssel Dump P1 auf 0 festlegen oder SMTP Archive Sink deinstallieren. Wenn Sie SMTP Archive Sink deinstallieren, werden alle von SMTP Archive Sink verwendeten Registrierungsschlüssel gelöscht.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So deaktivieren Sie die P1-Kopfzeilenarchivierung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Doppelklicken Sie auf den Registrierungsschlüssel Dump P1, geben Sie im Feld Datenwerte den Wert 0 ein, und klicken Sie dann auf OK.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den IIS-Verwaltungsdienst neu, damit die Änderungen wirksam werden.

So deinstallieren Sie SMTP Archive Sink

  1. Klicken Sie auf Start, klicken Sie auf Ausführen, und geben Sie cmd ein. Klicken Sie anschließend auf OK.

  2. Geben Sie im Ordner C:\Program Files\Exchsrvr\bin die Zeichenfolge cscript archivesink_setup.vbs ein, und drücken Sie dann die EINGABETASTE.

  3. Geben Sie cscript archivesink_setup.vbs uninstall Virtual Server ID ein, wobei Virtual Server ID für die Nummer des virtuellen Servers steht, auf dem SMTP Archive Sink installiert ist.

  4. Schließen Sie das Eingabeaufforderungsfenster, und starten Sie den IIS-Verwaltungsdienst neu, damit die Änderungen wirksam werden.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Einrichten und Konfigurieren von SMTP Archive Sink in Exchange Server 2003 finden Sie im Knowledge Base-Artikel 871110 „How to install and use the Archive Sink utility in Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110).

Weitere Informationen zum Einrichten und Konfigurieren von SMTP Archive Sink in Exchange 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 307798 „The Archive Sink utility is available in Service Pack 2" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798).

Weitere Informationen zum Bereitstellen einer umfassenden Aufzeichnungslösung für eine regelnde Kompatibilität finden Sie unter Journaling with Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).


SMTP Archive Sink aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob SMTP Archive Sink installiert und aktiviert wurde:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable Smtp Messages

Wenn Exchange Server Analyzer feststellt, dass der Wert für Enable Smtp Messages größer als 0 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert 0 gibt an, dass SMTP Archive Sink deaktiviert ist. Der Wert 1 gibt an, dass SMTP Archive Sink aktiviert ist. Andere Werte als 0 und 1 werden nicht unterstützt.

Bei dem Tool SMTP Archive Sink handelt es sich um ein benutzerdefiniertes Skript, das die Archivierung aller Nachrichten aktiviert, die für einen bestimmten Ordner auf einem Exchange-Server eingehen bzw. gesendet werden. Wenn SMTP Archive Sink aktiviert ist, werden in der Standardeinstellung alle Nachrichten und ihre Empfänger in einer EML-Datei archiviert, mit Ausnahme von Bcc-Empfängern.

Wenn in der Standardeinstellung die SMPT-Archivierung mit SMTP Archive Sink aktiviert wird, lösen alle von SMTP (Simple Mail Transfer Protocol), vom Exchange-Speicher oder von anderen Senken übertragenen Nachrichten dieses Ereignis aus. Dieses Ereignis kann theoretisch einmal pro Nachricht ausgelöst werden, und dieses Ereignis kann nur einmal archiviert werden. Das Ereignis OnMessageSubmission wird vor den Routing- oder Kategorisierungsereignissen ausgelöst. Daher werden diese Nachrichten als PreCat-Nachrichten bezeichnet. In der Standardeinstellung werden Nachrichten für dieses Ereignis archiviert, wenn das Tool SMTP Active Sink installiert ist. Für dieses Ereignis archivierte Nachrichten enthalten den folgenden Präfix-Dateinamen. ARCH_Zufallszahl.xml.

Wenn Sie auf dem Exchange-Computer keine Nachrichten archivieren möchten, können Sie den Registrierungsschlüssel Enable Smtp Messages auf 0 festlegen oder SMTP Archive Sink deinstallieren. Wenn Sie SMTP Archive Sink deinstallieren, werden alle von SMTP Archive Sink verwendeten Registrierungsschlüssel gelöscht.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So deaktivieren Sie SMTP Archive Sink

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Doppelklicken Sie auf den Registrierungsschlüssel Enable Smtp Messages, geben Sie im Feld Wert den Wert 0 ein, und klicken Sie dann auf OK.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den IIS-Verwaltungsdienst neu, damit die Änderungen wirksam werden.

So deinstallieren Sie SMTP Archive Sink

  1. Klicken Sie auf Start, klicken Sie auf Ausführen, und geben Sie cmd ein. Klicken Sie anschließend auf OK.

  2. Geben Sie im Ordner C:\Program Files\Exchsrvr\bin die Zeichenfolge cscript archivesink_setup.vbs ein, und drücken Sie dann die EINGABETASTE.

  3. Geben Sie cscript archivesink_setup.vbs uninstall Virtual Server ID ein, wobei Virtual Server ID für die Nummer des virtuellen Servers steht, auf dem SMTP Archive Sink installiert ist.

  4. Schließen Sie das Eingabeaufforderungsfenster, und starten Sie den IIS-Verwaltungsdienst neu, damit die Änderungen wirksam werden.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Einrichten und Konfigurieren von SMTP Archive Sink in Exchange Server 2003 finden Sie im Knowledge Base-Artikel 871110 „How to install and use the Archive Sink utility in Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110).

Weitere Informationen zum Einrichten und Konfigurieren von SMTP Archive Sink in Exchange 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 307798 „The Archive Sink utility is available in Service Pack 2" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798).

Weitere Informationen zum Bereitstellen einer umfassenden Aufzeichnungslösung für eine regelnde Kompatibilität finden Sie unter Journaling with Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).


SMTP Archive Sink: Nach-Kategorisierungssatz
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob SMTP Archive Sink installiert und aktiviert wurde:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable PostCat

Wenn Exchange Server Analyzer feststellt, dass der Wert für Enable PostCat größer als 0 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert 0 gibt an, dass die Archivierung von Nachrichten nach der Kategorisierung deaktiviert ist. Der Wert 1 gibt an, dass die Archivierung von Nachrichten nach der Kategorisierung aktiviert ist. Andere Werte als 0 und 1 werden nicht unterstützt.

Bei dem Tool SMTP Archive Sink handelt es sich um ein benutzerdefiniertes Skript, das die Archivierung aller Nachrichten aktiviert, die für einen bestimmten Ordner auf einem Exchange-Server eingehen bzw. gesendet werden. Wenn SMTP Archive Sink aktiviert ist, werden in der Standardeinstellung alle Nachrichten und ihre Empfänger in einer EML-Datei archiviert, mit Ausnahme von Bcc-Empfängern.

Wenn Enable PostCat auf 1 festgelegt ist, werden die Nachrichten nach der Kategorisierung einer Nachricht archiviert. Dieses Ereignis kann von Nachrichten mehrmals ausgelöst werden, aber es tritt nur ein, wenn eine Nachricht kategorisiert, in die Warteschlange gestellt und anschließend erneut aufgelistet wurde. Für dieses Ereignis archivierte Nachrichten enthalten den Präfix-Dateinamen ARCH_POSTCAT_Zufallszahl.xml.

Wenn auf diesem Exchange-Computer keine Nachrichten nach der Kategorisierung archiviert werden sollen, können Sie den Registrierungsschlüssel Enable PostCat auf 0 festlegen. Wenn auf diesem Computer keine Archivierung vorgenommen werden soll, können Sie SMTP Archive Sink deinstallieren. Wenn Sie SMTP Archive Sink deinstallieren, werden alle von SMTP Archive Sink verwendeten Registrierungsschlüssel gelöscht.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So deaktivieren Sie die Archivierung von Nachrichten nach der Kategorisierung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Doppelklicken Sie auf den Registrierungsschlüssel Enable PostCat, geben Sie im Feld Datenwerte den Wert 0 ein, und klicken Sie dann auf OK.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den IIS-Verwaltungsdienst neu, damit die Änderungen wirksam werden.

So deinstallieren Sie SMTP Archive Sink

  1. Klicken Sie auf Start, klicken Sie auf Ausführen, und geben Sie cmd ein. Klicken Sie anschließend auf OK.

  2. Geben Sie im Ordner C:\Program Files\Exchsrvr\bin die Zeichenfolge cscript archivesink_setup.vbs ein, und drücken Sie dann die EINGABETASTE.

  3. Geben Sie cscript archivesink_setup.vbs uninstall Virtual Server ID ein, wobei Virtual Server ID für die Nummer des virtuellen Servers steht, auf dem SMTP Archive Sink installiert ist.

  4. Schließen Sie das Eingabeaufforderungsfenster, und starten Sie den IIS-Verwaltungsdienst neu, damit die Änderungen wirksam werden.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Einrichten und Konfigurieren von SMTP Archive Sink in Exchange Server 2003 finden Sie im Knowledge Base-Artikel 871110 „How to install and use the Archive Sink utility in Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110).

Weitere Informationen zum Einrichten und Konfigurieren von SMTP Archive Sink in Exchange 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 307798 „The Archive Sink utility is available in Service Pack 2" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798).

Weitere Informationen zum Bereitstellen einer umfassenden Aufzeichnungslösung für eine regelnde Kompatibilität finden Sie unter Journaling with Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).


SMTP Archive Sink: Vor-Kategorisierungssatz
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob SMTP Archive Sink installiert und aktiviert wurde:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable PreCat

Wenn Exchange Server Analyzer feststellt, dass der Wert für Enable PreCat größer als 0 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert 0 gibt an, dass die Archivierung von Nachrichten vor der Kategorisierung deaktiviert ist. Der Wert 1 gibt an, dass die Archivierung von Nachrichten vor der Kategorisierung aktiviert ist. Andere Werte als 0 und 1 werden nicht unterstützt.

Bei dem Tool SMTP Archive Sink handelt es sich um ein benutzerdefiniertes Skript, das die Archivierung aller Nachrichten aktiviert, die für einen bestimmten Ordner auf einem Exchange-Server eingehen bzw. gesendet werden. Wenn SMTP Archive Sink aktiviert ist, werden in der Standardeinstellung alle Nachrichten und ihre Empfänger in einer EML-Datei archiviert, mit Ausnahme von Bcc-Empfängern.

Alle Nachrichten, die über SMTP (Simple Mail Transfer Protocol), vom Exchange-Informationsspeicher oder von einer beliebigen anderen Senke übermittelt werden, lösen dieses Ereignis aus. Dieses Ereignis kann theoretisch einmal pro Nachricht ausgelöst werden, und dieses Ereignis kann nur einmal archiviert werden. Das Ereignis OnMessageSubmission wird vor den Routing- oder Kategorisierungsereignissen ausgelöst. Daher werden diese Nachrichten als PreCat-Nachrichten bezeichnet. In der Standardeinstellung werden Nachrichten für dieses Ereignis archiviert, wenn das Dienstprogramm SMTP Active Sink installiert ist. Für dieses Ereignis archivierte Nachrichten enthalten den Präfix-Dateinamen ARCH_random number.xml.

Wenn auf diesem Exchange-Computer keine Nachrichten vor der Kategorisierung archiviert werden sollen, können Sie den Registrierungsschlüssel Enable PreCat auf 0 festlegen. Wenn auf diesem Computer keine Archivierung vorgenommen werden soll, können Sie SMTP Archive Sink deinstallieren. Wenn Sie SMTP Archive Sink deinstallieren, werden alle von SMTP Archive Sink verwendeten Registrierungsschlüssel gelöscht.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So deaktivieren Sie die Archivierung von Nachrichten vor der Kategorisierung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Doppelklicken Sie auf den Registrierungsschlüssel Enable PreCat, geben Sie im Feld Datenwerte den Wert 0 ein, und klicken Sie dann auf OK.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den IIS-Verwaltungsdienst neu, damit die Änderungen wirksam werden.

So deinstallieren Sie SMTP Archive Sink

  1. Klicken Sie auf Start, klicken Sie auf Ausführen, und geben Sie cmd ein. Klicken Sie anschließend auf OK.

  2. Geben Sie im Ordner C:\Program Files\Exchsrvr\bin die Zeichenfolge cscript archivesink_setup.vbs ein, und drücken Sie dann die EINGABETASTE.

  3. Geben Sie cscript archivesink_setup.vbs uninstall Virtual Server ID ein, wobei Virtual Server ID für die Nummer des virtuellen Servers steht, auf dem SMTP Archive Sink installiert ist.

  4. Schließen Sie das Eingabeaufforderungsfenster, und starten Sie den IIS-Verwaltungsdienst neu, damit die Änderungen wirksam werden.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Einrichten und Konfigurieren von SMTP-Archive Sink in Exchange Server 2003 finden Sie im Knowledge Base-Artikel 871110, „How to install and use the Archive Sink utility in Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110).

Weitere Informationen zum Einrichten und Konfigurieren von SMTP-Archive Sink in Exchange 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 307798, „The Archive Sink utility is available in Service Pack 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Weitere Informationen zum Bereitstellen einer umfassenden Aufzeichnungslösung für eine regelnde Kompatibilität finden Sie unter Journaling with Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).


SMTP Archive Sink: Systemmeldungen werden archiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob SMTP Archive Sink installiert und aktiviert wurde:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Archive System Messages

Wenn Exchange Server Analyzer feststellt, dass der Wert für Archive System Messages größer als 0 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert 0 gibt an, dass Systemmeldungen nicht archiviert werden. Der Wert 1 gibt an, dass Systemmeldungen archiviert werden. Andere Werte als 0 und 1 werden nicht unterstützt.

Bei dem Tool SMTP Archive Sink handelt es sich um ein benutzerdefiniertes Skript, das die Archivierung aller Nachrichten aktiviert, die für einen bestimmten Ordner auf einem Exchange-Server eingehen bzw. gesendet werden. Wenn SMTP Archive Sink aktiviert ist, werden in der Standardeinstellung alle Nachrichten und ihre Empfänger in einer EML-Datei archiviert, mit Ausnahme von Bcc-Empfängern.

Wenn auf diesem Exchange-Computer keine Systemmeldungen archiviert werden sollen, können Sie den Registrierungsschlüssel Archive System Messages auf 0 festlegen. Wenn auf diesem Computer keine Archivierung vorgenommen werden soll, können Sie SMTP Archive Sink deinstallieren. Wenn Sie SMTP Archive Sink deinstallieren, werden alle von SMTP Archive Sink verwendeten Registrierungsschlüssel gelöscht.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So deaktivieren Sie das Archivieren von Systemmeldungen

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Doppelklicken Sie auf den Registrierungsschlüssel Archive System Messages, geben Sie im Feld Datenwerte den Wert 0 ein, und klicken Sie dann auf OK.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den IIS-Verwaltungsdienst neu, damit die Änderungen wirksam werden.

So deinstallieren Sie SMTP Archive Sink

  1. Klicken Sie auf Start, klicken Sie auf Ausführen, und geben Sie cmd ein. Klicken Sie anschließend auf OK.

  2. Geben Sie im Ordner C:\Program Files\Exchsrvr\bin die Zeichenfolge cscript archivesink_setup.vbs ein, und drücken Sie dann die EINGABETASTE.

  3. Geben Sie cscript archivesink_setup.vbs uninstall Virtual Server ID ein, wobei Virtual Server ID für die Nummer des virtuellen Servers steht, auf dem SMTP Archive Sink installiert ist.

  4. Schließen Sie das Eingabeaufforderungsfenster, und starten Sie den IIS-Verwaltungsdienst neu, damit die Änderungen wirksam werden.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986), der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Einrichten und Konfigurieren von SMTP Archive Sink in Exchange Server 2003 finden Sie im Knowledge Base-Artikel 871110 „How to install and use the Archive Sink utility in Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110).

Weitere Informationen zum Einrichten und Konfigurieren von SMTP Archive Sink in Exchange 2000 Server finden Sie im Microsoft Knowledge Base-Artikel 307798 „The Archive Sink utility is available in Service Pack 2" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798).

Weitere Informationen zum Bereitstellen einer umfassenden Aufzeichnungslösung für eine regelnde Kompatibilität finden Sie unter Journaling with Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).


SMTP-BadMail-Daten werden in einen komprimierten Ordner geschrieben.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_Directory ab, um den Wert des Schlüssels Compressed für den SMTP-Ordner (Simple Mail Transfer Protocol) BadMail zu bestimmen. Stellt Exchange Server Analyzer fest, dass der Wert Compressed auf True festgelegt ist, wird eine Warnung angezeigt.

Wenn Nachrichten mithilfe des SMTP-Dienstes auf dem Exchange-Computer ankommen, werden die Daten als EML-Datei auf die Festplatte geschrieben. In der Standardeinstellung werden diese Dateien im Ordner <Laufwerk>:\Programme\Exchsrvr\Mailroot auf derselben Partition gespeichert, auf der Exchange installiert ist. Wenn für den Ordner, in dem SMTP-BadMail-Daten gespeichert sind, die Dateikomprimierung aktiviert ist, kann die Leistung von Exchange stark beeinträchtigt werden. Aus diesem Grund wird die Komprimierung in dem Ordner, in dem SMTP-BadMail-Daten gespeichert werden, nicht unterstützt.

Wenn Sie diese Warnung erhalten, müssen Sie die Komprimerung für den Ordner deaktivieren, in dem die SMPT-BadMail-Daten gespeichert werden, oder Sie müssen die SMPT-BadMail-Daten in einen nicht komprimierten Ordner verschieben.

Das Speichern von Exchange-Datendateien auf einem komprimierten Datenträger wird von Microsoft nicht unterstützt. Wenn Sie Ihre Exchange-Datendateien auf einem komprimierten Datenträger speichern, beeinträchtigt der zusätzliche Aufwand die Leistung von Exchange erheblich. Zu den Exchange-Datendateien gehören folgende Dateien:

  • EDB-Dateien

  • STM-Dateien

  • LOG-Dateien

  • DAT-Dateien

  • EML-Dateien

  • CHK-Dateien

So deaktivieren Sie die Dateikomprimierung für einen angegebenen Ordner:

  1. Klicken Sie mit der rechten Maustaste auf den Ordner, für den die Dateikomprimierung deaktiviert werden soll, und klicken Sie dann auf Eigenschaften.

  2. Klicken Sie auf der Registerkarte Allgemein auf Erweitert.

  3. Deaktivieren Sie im Dialogfeld Erweiterte Attribute das Kontrollkästchen Inhalt komprimieren, um Speicherplatz zu sparen, und klicken Sie dann auf OK.

So verschieben Sie den BadMail-Ordner auf Exchange 2000 Server oder Exchange Server 2003

  1. Öffnen Sie den Exchange-System-Manager.

  2. Klicken Sie auf Administrative Gruppen, erweitern Sie Ihre administrative Gruppe, erweitern Sie Server und Ihren Server, erweitern Sie Protokolle und dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf Ihren virtuellen SMTP-Server, und klicken Sie dann auf Beenden.

  4. Klicken Sie mit der rechten Maustaste auf Ihren virtuellen SMTP-Server, und klicken Sie dann auf Eigenschaften.

  5. Klicken Sie auf der Registerkarte Nachrichten neben dem Feld BadMail-Verzeichnis auf Durchsuchen, und geben Sie dann den Pfad für den neuen Speicherort des Warteschlangenordners ein.

  6. Klicken Sie auf OK.

  7. Klicken Sie mit der rechten Maustaste auf Ihren virtuellen SMTP-Server, und klicken Sie dann auf Starten.

Weitere Informationen über das Verschieben des Ordners Mailroot finden Sie im Microsoft Knowledge Base-Artikel 822933 „How to change the Exchange 2003 SMTP Mailroot folder location" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).


SMTP-BadMail-Daten werden in eine Nicht-NTFS-Partition geschrieben
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) Win32_Directory ab, um den Wert des Schlüssels FSName für das SMTP-BadMail-Verzeichnis vonExchange zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel FSName nicht NTFS ist, wird eine Warnung angezeigt.

Das Speichern von Exchange-Datendateien auf einem Nicht-NTFS-Datenträger wird von Microsoft nicht unterstützt. Exchange-Datendateien umfassen folgende Dateien:

  • EDB-Dateien

  • STM-Dateien

  • LOG-Dateien

  • DAT-Dateien

  • EML-Dateien

Wenn diese Warnung angezeigt wird, müssen Sie das SMTP-BadMail-Verzeichnis in einen Ordner auf einem NTFS-Dateisystemlaufwerk verschieben. Wenn das Laufwerk, auf dem das BadMail-Verzeichnis gespeichert ist, als FAT-Laufwerk formatiert ist, können Sie zum Konvertieren des Laufwerks in NTFS auch das Befehlszeilentool convert.exe verwenden.

So verschieben Sie das SMTP-BadMail-Verzeichnis in einen anderen Ordner

  1. Starten Sie den Exchange-System-Manager.

  2. Klicken Sie auf Administrative Gruppen, erweitern Sie Ihre administrative Gruppe, erweitern Sie Server und Ihren Server, erweitern Sie Protokolle und dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf Ihren virtuellen SMTP-Server, und klicken Sie dann auf Beenden.

  4. Klicken Sie mit der rechten Maustaste auf den virtuellen SMTP-Server, und klicken Sie dann auf Eigenschaften.

  5. Klicken Sie auf der Registerkarte Nachrichten neben dem Feld BADMAIL-Verzeichnis auf Durchsuchen, und geben Sie dann den Pfad für den neuen Speicherort des BadMail-Ordners ein.

  6. Klicken Sie auf OK.

  7. Klicken Sie mit der rechten Maustaste auf Ihren virtuellen SMTP-Server, und klicken Sie dann auf Starten.

Weitere Informationen über das Verschieben des Ordners Mailroot finden Sie im Microsoft Knowledge Base-Artikel 822933 „How to change the Exchange 2003 SMTP Mailroot folder location" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Wenn das Laufwerk, auf dem die Dateien gespeichert sind, als FAT-Laufwerk formatiert ist, können Sie alternativ zur obigen Vorgehensweise zum Konvertieren des Laufwerks in NTFS auch das Befehlszeilentool convert.exe verwenden. Weitere Informationen zum Konvertieren einer FAT-Partition in eine NTFS-Partition mit dem Befehlszeilentool convert.exe finden Sie im Microsoft Knowledge Base-Artikel 214579 „Konvertieren einer Partition in NTFS mit "Convert.exe"" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579).


SMTP-BadMail-Daten werden in einen verschlüsselten Ordner geschrieben.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer sendet eine Abfrage an die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_Directory, um den Wert des Schlüssels Encrypted für den SMTP-BadMail-Ordner zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass der Wert Verschlüsselt auf True festgelegt ist, wird eine Warnung angezeigt.

Wenn Nachrichten mithilfe des SMTP-Dienstes auf dem Exchange-Computer ankommen, werden die Daten als EML-Datei auf die Festplatte geschrieben. In der Standardeinstellung werden diese Dateien im Ordner <Laufwerk>:\Programme\Exchsrvr\Mailroot auf derselben Partition gespeichert, auf der Exchange installiert ist. Wenn für den Ordner, in dem SMTP-BadMail-Daten gespeichert sind, die Dateiverschlüsselung aktiviert ist, kann die Leistung von Exchange stark beeinträchtigt werden. Aus diesem Grund wird die Verschlüsselung des Ordners mit den gespeicherten SMTP-BadMail-Daten nicht unterstützt.

Wenn Sie diese Warnung erhalten, müssen Sie die Verschlüsselung für den Ordner deaktivieren, in dem die SMPT-BadMail-Daten gespeichert werden, oder Sie müssen die SMPT-BadMail-Daten in einen nicht verschlüsselten Ordner verschieben.

Microsoft unterstützt nicht das Speichern von Exchange-Datendateien auf verschlüsselten Datenträgern in verschlüsselnden Dateisystemen (Encrypting File Systems, EFS). Wenn Sie Exchange-Datendateien auf einem verschlüsselten Datenträger speichern, wirkt sich der zusätzliche Overhead entscheidend auf die Exchange-Leistung aus. Exchange-Datendateien umfassen folgende Dateien:

  • EDB-Dateien

  • STM-Dateien

  • LOG-Dateien

  • DAT-Dateien

  • EML-Dateien

  • CHK-Dateien

Um die Sicherheit der Exchange-Datendateien zu gewährleisten, empfiehlt es sich, den unbefugten Zugriff auf den Exchange-Computer zu verhindern und Nachrichtendaten mithilfe des S/MIME-Nachrichtenformats zu verschlüsseln.

Um diese Fehler zu beheben, müssen Sie entweder die Dateiverschlüsselung für den BadMail-Ordner deaktivieren, oder Sie müssen den BadMail-Ordner an einen Speicherort verschieben, an dem keine Verschlüsselung aktiviert ist.

So deaktivieren Sie die Dateiverschlüsselung für den angegebenen Ordner:

  1. Klicken Sie mit der rechten Maustaste auf den Ordner, für den die Verschlüsselung deaktiviert werden soll, und klicken Sie dann auf Eigenschaften.

  2. Klicken Sie auf der Registerkarte Allgemein auf Erweitert.

  3. Deaktivieren Sie im Dialogfeld Erweiterte Attribute das Kontrollkästchen Inhalt verschlüsseln, um Daten zu schützen, und klicken Sie dann auf OK.

So verschieben Sie den BadMail-Ordner auf Exchange 2000 Server oder Exchange Server 2003

  1. Öffnen Sie den Exchange-System-Manager.

  2. Klicken Sie auf Administrative Gruppen, erweitern Sie Ihre administrative Gruppe, erweitern Sie Server und Ihren Server, erweitern Sie Protokolle und dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf Ihren virtuellen SMTP-Server, und klicken Sie dann auf Beenden.

  4. Klicken Sie mit der rechten Maustaste auf Ihren virtuellen SMTP-Server, und klicken Sie dann auf Eigenschaften.

  5. Klicken Sie auf der Registerkarte Nachrichten neben dem Feld BADMAIL-Verzeichnis auf Durchsuchen, und geben Sie dann den Pfad für den neuen Speicherort des Warteschlangenordners ein.

  6. Klicken Sie auf OK.

  7. Klicken Sie mit der rechten Maustaste auf Ihren virtuellen SMTP-Server, und klicken Sie dann auf Starten.

Weitere Informationen über das Verschieben des Ordners Mailroot finden Sie im Microsoft Knowledge Base-Artikel 822933 „How to change the Exchange 2003 SMTP Mailroot folder location" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Weitere Informationen über Exchange Server-Datendateien und EFS finden Sie im Microsoft Knowledge Base-Artikel 834638, „Information about the storage of data files on an encrypted volume in Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638).

Informationen zum Sichern von Nachrichten in Microsoft Exchange Server 2003 finden Sie im Handbuch zur Nachrichtensicherheit in Exchange Server 2003 unter http://go.microsoft.com/fwlink/?linkid=47574.


Der SMTP-Registrierungswert „CatRetryMinutes" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die Standardkonfigurationen für Warteschlangen in SMTP geändert wurden:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel CatRetryMinutes festgelegt ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Es wird empfohlen, die Standardwerte für Warteschlangen nur nach gründlicher Überlegung zu ändern. Die Standardwerte wurden mit Bedacht ausgewählt, um eine optimale Leistung in den meisten Umgebungen zu gewährleisten. Im Allgemeinen hat es sich bewährt, die Ursache des Problems zu beheben, anstatt das Warteschlangenverhalten in Exchange Server zu ändern.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu Exchange-SMTP-Warteschlangen finden Sie im Microsoft Exchange Team-Blogeintrag „Explaining the Mysterious SMTP Advanced Queuing Engine" unter http://go.microsoft.com/fwlink/?LinkId=48585.


SMTP-Konfigurationswarnung
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-03

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob der Wert für das Attribut msExchSmtpMaxMessageSize vom Standardwert 0 abweicht. In der Standardeinstellung ist das Attribut msExchSmtpMaxMessageSize für eine unbeschränkte Nachrichtengröße konfiguriert.

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen vorliegen:

  • Das Attribut msExchSmtpMaxMessageSize ist mit dem Wert 0 konfiguriert.

  • Exchange wird nicht auf dem Computer mit Microsoft Windows® Small Business Server 2003 ausgeführt.

Das Attribut msExchSmtpMaxMessageSize stellt die maximale Größe einzelner SMTP-Nachrichten dar, die gesendet oder empfangen werden können. In Bezug auf die Sicherheit stellt das Beschränken der maximalen Größe der über das Internet gesendeten und empfangenen SMTP-Nachrichten eine bewährte Methode dar. Für interne SMTP-Nachrichten (z. B. für zwischen Servern mit Exchange innerhalb derselben Organisation übertragene SMTP-Nachrichten) empfiehlt es sich jedoch, den Wert 0 für das Attribut msExchSmtpMaxMessageSize beizubehalten.

Intern verwendet Exchange SMTP-Nachrichten zum Verarbeiten von Aufgaben, z. B. für die Replikation Öffentlicher Ordner. Wenn das Attribut msExchSmtpMaxMessageSize mit einem zu niedrigen Grenzwert konfiguriert ist, können Probleme bei der Replikation Öffentlicher Ordner und andere Fehler beim Übermitteln von Nachrichten innerhalb derselben Organisation auftreten.

Handelt es sich bei dem Server mit Exchange um einen Bridgeheadserver, der SMTP-Nachrichten in das und aus dem Internet überträgt, kann diese Warnung ignoriert werden. Wenn der Server mit Exchange interne SMTP-Nachrichten bearbeitet, muss der Wert für das Attribut msExchSmtpMaxMessageSize auf die Standardeinstellung 0 zurückgesetzt werden.

Hinweis:
Wenn die Beschränkung für die Nachrichtengröße zu niedrig festgelegt wird, kann die Replikation von Offlineadressbüchern zwischen Computern mit Exchange Server verhindert werden. Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 326154, "Sie können das Offline-Adressbuch in Microsoft Outlook in Exchange 2000 Server nicht downloaden" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154).
So zeigen Sie die maximale SMTP-Nachrichtengröße an und konfigurieren diese

  1. Erweitern Sie im Exchange-System-Manager Server, einen Server mit Exchange, dann Protokolle und anschließend SMTP.

  2. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise den virtuellen Standardserver für SMTP), und klicken Sie dann auf Eigenschaften.

  3. Wählen Sie die Registerkarte Nachrichten aus.

  4. Um den Standardwert auf 0 zurückzusetzen, deaktivieren Sie das Kontrollkästchen Nachrichtengröße beschränken auf (KB). Sie können das Kontrollkästchen auch aktiviert lassen und den gewünschten Wert festlegen.

  5. Klicken Sie auf OK, um die Änderungen zu speichern und das Dialogfeld Eigenschaften des virtuellen SMTP-Servers zu schließen.

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 266686, "XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163, "XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


SMTP-Connector mit festgelegten Übermittlungseinschränkungen für Verteilergruppen
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-09-06

Microsoft® Exchange Server Analyzer fragt die folgenden Attribute für jedes im Active Directory®-Verzeichnisobjekt erkannte SMTP-Connectorobjekt (Simple Mail Transfer Protocol) (msExchRoutingSMTPConnector) ab, um zu ermitteln, ob für diese Objekte Übermittlungseinschränkungen basierend auf der Mitgliedschaft in Verteilergruppen festgelegt sind.

dLMemRejectPerms | Enthält die Domänennamen (DNs) der Verteilerlisten (Distribution List, DL), deren Mitglieder keine Nachrichten über diesen SMTP-Connector senden dürfen.
dLMemSubmitPerms | Enthält die Domänennamen (DNs) der Verteilerlisten (Distribution List, DL), deren Mitglieder Nachrichten über diesen SMTP-Connector senden dürfen.

Wenn Exchange Server Analyzer feststellt, dass SMTP-Connectors vorhanden sind, für die Übermittlungseinschränkungen basierend auf der Mitgliedschaft in Verteilergruppen festgelegt sind, zeigt Exchange Server Analyzer eine Warnung an.

Diese Warnung gibt an, dass sich Übermittlungseinschränkungen, die auf der Mitgliedschaft in Verteilergruppen basieren, möglicherweise negativ auf die Leistung der Exchange-Nachrichtenübermittlung auswirken.

Wenn Sie E-Mails über SMTP-Connectors senden, für die Übermittlungseinschränkungen basierend auf der Mitgliedschaft in Verteilergruppen festgelegt wurden, muss das Nachrichtenkategorisierungsmodul die Mitgliedschaft der Verteilergruppe erweitern, die vollständige Liste der DNs der Mitglieder anfordern und anschließend die Liste der DNs mit den DNs der Absender vergleichen. Eine Zugriffsoperation oder eine Verweigerungsoperation erfolgt, wenn in beiden Listen eine Übereinstimmung bei einem DN gefunden wird. Wenn eine Verteilergruppe in eine andere Verteilergruppe geschachtelt ist, wird die geschachtelte Verteilergruppe ebenfalls erweitert.

So beheben Sie diese Warnung

  • Erstellen Sie eine dedizierte Routinggruppe für Connectoreinschränkungen, und konfigurieren Sie sie als lokale Routinggruppe gemäß den Erläuterungen im Microsoft Knowledge Base-Artikel 329171, "XADM: Übermittlung von E-Mails ist langsam, wenn Empfänger mit Übermittlungseinschränkungen basierend auf der Gruppenmitgliedschaft konfiguriert sind" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • Verwenden Sie einen dedizierten und robusteren globalen Katalogserver als für den Connector vorgesehenen Bridgehead-Server.

  • Konfigurieren Sie einzelne Postfächer und keine Verteilergruppen für Übermittlungseinschränkungen gemäß den Erläuterungen im Microsoft Knowledge Base-Artikel 812298, "Übermittlung von E-Mails ist langsam, nachdem Sie Übermittlungseinschränkungen konfiguriert haben, die auf einer Verteilerliste basieren" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Ziehen Sie das Implementieren der SMTP-Absenderfilterung in Betracht.

  • Erwägen Sie für Server, auf denen Microsoft Exchange Server 2003 Service Pack 2 (SP2) oder höher ausgeführt wird, die nicht hierarchische Einschränkungsüberprüfung zu implementieren. Bei Servern, auf denen Versionen von Exchange vor Exchange 2003 SP2 ausgeführt werden, sollten Sie die Aktualisierung auf Exchange 2003 SP2 in Betracht ziehen.

Weitere Informationen

Weitere Informationen zu der nicht hierarchischen Einschränkungsüberprüfung finden Sie unter Empfohlene Vorgehensweise: Nicht hierarchische Einschränkungsüberprüfung..

Weitere Informationen zu der SMTP-Absenderfilterung finden Sie unter "Aktivieren der Absenderfilterung" im Exchange Server 2003-Administratorhandbuch (http://go.microsoft.com/fwlink/?LinkId=72967).

Weitere Informationen zu der Auswirkung der Verteilergruppeneinschränkung auf den E-Mail-Verkehr in Exchange finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 329171 "XADM: Übermittlung von E-Mails ist langsam, wenn Empfänger mit Übermittlungseinschränkungen basierend auf der Gruppenmitgliedschaft konfiguriert sind" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171)

  • 895407, "Die Nachrichtenübermittlung zu lokalen und externen Postfächern ist in Exchange Server 2003 langsamer als erwartet, nachdem Sie die Übermittlungseinschränkungen basierend auf Verteilergruppen konfiguriert haben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 839949 "Problembehandlung bei E-Mail-Transport und Verteilergruppen in Exchange 2000 Server und in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).


Die Funktion für das erneute Schreiben der SMTP-Domäne ist aktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Wert für das Attribut heuristics für das SMTP Virtual Server-Objekt für diesen Exchange-Server zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs heuristics nicht dem Standardwert 131072 entspricht, wird ein Fehler angezeigt.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zum Tool für das erneute Schreiben von Adressen von Exchange Server finden Sie unter „Exchange Server Address Rewrite" (http://go.microsoft.com/fwlink/?LinkId=25932).


Der SMTP-Registrierungswert „FailedMsgQRetryMinutes" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die Standardkonfigurationen für Warteschlangen in SMTP geändert wurden:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel FailedMsgQRetryMinutes festgelegt ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Es wird empfohlen, die Standardwerte für Warteschlangen nur nach gründlicher Überlegung zu ändern. Die Standardwerte wurden mit Bedacht ausgewählt, um eine optimale Leistung in den meisten Umgebungen zu gewährleisten. Im Allgemeinen hat es sich bewährt, die Ursache des Problems zu beheben, anstatt das Warteschlangenverhalten in Exchange Server zu ändern.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu Exchange-SMTP-Warteschlangen finden Sie im Microsoft Exchange Team-Blogeintrag „Explaining the Mysterious SMTP Advanced Queuing Engine" unter http://go.microsoft.com/fwlink/?LinkId=48585.


Der SMTP-Registrierungswert „LocalDeliveryMaxBatch" weicht vom Standardwert ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die Standardeinstellung des Registrierungswerts LocalDeliveryMaxBatch geändert wurde:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\StoreDriver\Exchange\%SMTPVirtualServerInstance%.

Wenn Exchange Server Analyzer feststellt, dass der Registrierungswert LocalDeliveryMaxBatch manuell erstellt wurde, wobei die binäre Standardeinstellung des Exchange-Servers von 80 geändert wurde, zeigt Exchange Server Analyzer eine Warnmeldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In der Standardeinstellung wird der Registrierungswert LocalDeliveryMaxBatch während einer Exchange Server-Installation nicht erstellt. Der Registrierungswert LocalDeliveryMaxBatch kann nach der Exchange Server-Installation manuell erstellt werden, um das Vorgehen des Exchange-Informationsspeichers beim internen Verarbeiten und Übermitteln von Nachrichten zu ändern. Möglicherweise entstehen Probleme bei der Nachrichtenübermittlung und der Speicherleistung des Exchange-Servers, wenn die folgenden Bedingungen zutreffen:

  • Der Registrierungswert LocalDeliveryMaxBatch wurde manuell erstellt.

  • Die Einstellung des Registrierungswerts LocalDeliveryMaxBatch wurde falsch konfiguriert.

Es wird empfohlen, den Registrierungswert LocalDeliveryMaxBatch nur nach gründlicher Überlegung zu erstellen oder zu ändern. Die Standardwerte in den Binärdateien für Exchange-Server wurden sorgfältig ausgewählt, um eine optimale Leistung bei Verwendung in den meisten Exchange-Serverumgebungen zu gewährleisten. Im Allgemeinen hat es sich bewährt, die Ursache des Problems zu beheben, anstatt das Standardverhalten von Exchange Server durch manuelle Konfiguration der Registrierung zu ändern. Um dieser Empfehlung zu folgen, können Sie ggf. den Registrierungswert LocalDeliveryMaxBatch löschen, um den Exchange-Server wieder in der binären Standardeinstellung zu konfigurieren.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Sie können jedoch den Registrierungswert auch durch Bearbeiten der Registrierung wieder auf die Standardeinstellung festlegen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So beheben Sie diese Warnung

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zum folgenden Registrierungsschlüssel: HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\StoreDriver\Exchange\%SMTPVirtualServerInstance%

  3. Klicken Sie im Detailbereich mit der rechten Maustaste auf den Registrierungswert LocalDeliveryMaxBatch, klicken Sie auf Ändern, und ändern Sie dann den Wert in 80. Klicken Sie auf OK.

    Hinweis:
    Um den Registrierungswert LocalDeliveryMaxBatch zu löschen, klicken Sie im Detailbereich mit der rechten Maustaste auf den Registrierungswert LocalDeliveryMaxBatch und klicken Sie dann auf Löschen. Bestätigen Sie das Löschen des Registrierungswerts, indem Sie im Dialogfeld auf Ja klicken.

  4. Schließen Sie den Registrierungs-Editor.

  5. Starten Sie den Exchange-Server neu.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zum Bearbeiten der Microsoft Windows-Registrierung finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 322755, „SO WIRD'S GEMACHT: Unter Windows 2000 eine Sicherungskopie der Registrierung erstellen und die Registrierung bearbeiten und wiederherstellen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756, „Unter Windows XP und Windows Server 2003 eine Sicherungskopie der Registrierung erstellen und die Registrierung bearbeiten und wiederherstellen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Der vollqualifizierte Domänenname (FQDN) de SMTP-Instanz stimmt nicht mit dem aufgelösten DNS-Servernamen überein
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-10-04

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst nach dem Wert des Attributs msExchSmtpFullyQualifiedDomainName für das virtuelle SMTP-Standardserverobjekt ab.

Exchange Server Analyzer versucht auf den konfigurierten DNS-Servern eine DNS-Abfrage (Domain Name System) für den vollqualifizierten Domänennamen (FQDN) des Servers durchzuführen, auf dem Exchange Server ausgeführt wird. Diese Verbindung wird mithilfe eines benutzerdefinierten Objektprozessors hergestellt, der eine Namensauflösung anfordert und die Ergebnisse analysiert.

Exchange Server Analyzer vergleicht die Ergebnisse der beiden Abfragen. Wenn der Wert des Attributs msExchSmtpFullyQualifiedDomainName des virtuellen SMTP-Standardserverobjekts nicht mit dem vollqualifizierten DNS-Domänennamen des Exchange-Servers übereinstimmt, zeigt Exchange Server Analyzer eine Warnung an.

Diese Warnung weist darauf hin, dass die Werte dieser Attribute möglicherweise manuell geändert wurden. Die geänderten Werte können daher Nachrichtenübermittlungsprobleme auf diesem Server verursachen.

Der Wert des msExchSmtpFullyQualifiedDomainName-Attributs gibt den FQDN des virtuellen SMTP-Servers an und muss vom DNS-Netzwerkprotokoll (Domain Name System) aufgelöst werden können.

Für den Wert dieses Attributs muss ein gültiger HOST (A)-Eintrag in DNS vorhanden sein, damit Messagingserver, die den FQDN des virtuellen SMTP-Servers auflösen müssen, die richtige IP-Adresse abrufen und die Nachrichten entsprechend weiterleiten können.

Um diese Warnung zu beheben, überprüfen Sie, ob die Werte absichtlich geändert wurden und gültig sind. Wenn die Werte zu einem gültigen Zweck geändert wurden, führen Sie einen der folgenden Schritte aus:

  • Ändern Sie den Wert des Attributs msExchSmtpFullyQualifiedDomainName so, dass er mit dem vollqualifizierten DNS-Domänennamen übereinstimmt.

  • Konfigurieren Sie den vollqualifizierten DNS-Domänennamen des Exchange-Servers so, dass er mit dem Wert des Attributs msExchSmtpFullyQualifiedDomainName übereinstimmt.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In (Active Directory Service Interfaces), das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client (Lightweight Directory Access Protocol), Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme können eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder beiden Anwendungen erforderlich machen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So aktualisieren Sie den Wert des Attributs "msExchSMTPFullyQualifiedDomainName"

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie nacheinander Administrative Gruppen, Server, den Exchange-Server, Protokolle und SMTP.

  3. Klicken Sie mit der rechten Maustaste auf den virtuellen SMTP-Standardserver, und wählen Sie dann Eigenschaften aus.

  4. Wählen Sie die Registerkarte Übermittlung aus, und klicken Sie dann auf Erweitert.

  5. Geben Sie unter Vollqualifizierter Domänenname den Wert für das Attribut msExchSmtpFullyQualifiedDomainName ein.

  6. Klicken Sie auf OK, um die Änderungen zu speichern, und klicken Sie dann auf OK, um das Dialogfeld Eigenschaften des virtuellen SMTP-Servers zu schließen.
So konfigurieren Sie den vollqualifizierten DNS-Domänennamen des Exchange-Servers

  1. Befolgen Sie die Anweisungen unter Konfigurieren der Einstellungen auf dem DNS-Server.

Weitere Informationen zum DNS-Reverse-Lookup-Feature in Exchange finden Sie unter "Hinzufügen eines Ressourceneintrags zu einer DNS-Zone" (http://go.microsoft.com/fwlink/?LinkId=63002).

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Knowledge Base-Artikeln:

  • 266686, "XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163, "XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

Weitere Informationen zum Aufbau des SMTP-Diensts finden Sie unter "Entwurf des SMTP-Diensts" im Technischen Referenzhandbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=58876).


SMTP-Instanz ohne festgelegten ausgehenden SMTP-Connector
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-22

Microsoft® Exchange Server Analyzer fragt im Active Directory®-Verzeichnisdienst den Wert des Attributs distingushedName der Objektklasse protocolCfgSMTPServer ab, um alle Instanzen eines virtuellen SMTP-Servers (Simple Mail Transfer Protocol) auf dem vom Benutzer angegebenen Gateway aufzulisten.

Anschließend fragt Exchange Server Analyzer in Active Directory den Wert der Attribute msExchSourceBridgeheadServersDN und routingList für jedes gefundene msExchRoutingSMTPConnector-Objekt ab, um festzustellen, ob für einen SMTP-Connector eine der erkannten Instanzen des virtuellen SMTP-Servers als lokaler Bridgehead zu einem externen SMTP-Adressraum festgelegt ist.

Ein SMTP-Connector legt für E-Mails eine gesonderte Route fest. Sie können mit dem SMTP-Connector einen Gateway für Intermails einrichten oder eine Verbindung zu einer bestimmten Domäne oder einem bestimmten Mailsystem herstellen. Mit Connectors können Sie bestimmte Optionen für die angegebene Mailroute festlegen.

Wenn Exchange Server Analyzer feststellt, dass keine SMTP-Connectors vorhanden sind, für die eine Instanz eines virtuellen SMTP-Server auf dem angegebenen Exchange-Gatewayserver als dessen lokaler Bridgeheadserver festgelegt ist, zeigt Exchange Server Analyzer eine Warnung an.

Diese Warnung weist darauf hin, dass möglicherweise andere Server als der vom Benutzer angegebenen Exchange-Gatewayserver unbeabsichtigterweise Nachrichten nach außerhalb der Organisation routen.

Sie sollten einen SMTP-Connector erstellen, der eine Instanz eines virtuellen SMTP-Servers auf dem angegebenen Exchange-Gatewayserver als dessen Bridgehead bestimmt, um eine Situation zu verhindern, in der andere Server als der von Benutzer angegebene Gatewayserer unbeabsichtigterweise Nachrichten nach außerhalb der Organisation routen können.

Obwohl Sie über einen virtuellen SMTP-Server auch Internet-E-Mails senden können, empfiehlt es sich, einen dedizierten SMTP-Connector für die Weiterleitung von Internet-E-Mails zu konfigurieren. Es wird empfohlen, einen SMTP-Connector zu verwenden, da dieser eine gesonderte Route für Internetmails bereitstellt. Außerdem ist auf einem SMTP-Connector eine größere Anzahl an Optionen als auf dem virtuellen SMTP-Server verfügbar.

Weitere Informationen zur Verwendung von SMTP-Connectors finden Sie im Microsoft Knowledge Base-Artikel 294736, "Gründe für das Erstellen von SMTP-Connectors in Exchange 2000 und höher" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=294736).

Weitere Informationen zu SMTP-Connectors finden Sie im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).


Der SMTP-Registrierungswert „LocalRetryMinutes" weicht vom Standard ab.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die Standardkonfigurationen für Warteschlangen in SMTP geändert wurden:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel LocalRetryMinutes festgelegt ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Es wird empfohlen, die Standardwerte für Warteschlangen nur nach gründlicher Überlegung zu ändern. Die Standardwerte wurden mit Bedacht ausgewählt, um eine optimale Leistung in den meisten Umgebungen zu gewährleisten. Im Allgemeinen hat es sich bewährt, die Ursache des Problems zu beheben, anstatt das Warteschlangenverhalten in Exchange zu ändern.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu Exchange-SMTP-Warteschlangen finden Sie im Microsoft Exchange Team-Blogeintrag „Explaining the Mysterious SMTP Advanced Queuing Engine" unter http://go.microsoft.com/fwlink/?LinkId=48585.


Der SMTP-Registrierungswert „FileCacheLifeTimeSeconds" wurde manuell hinzugefügt, ist jedoch möglicherweise nicht mehr erforderlich.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob die Standardlebensdauer der zwischengespeicherten IIS-Dateizugriffsnummer (Internet Information Services) vom Standardwert 1880 Sekunden (30 Minuten) abweichend festgelegt wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Inetinfo\Parameters\FileCacheLifeTimeSeconds

Wenn Exchange Server Analyzer feststellt, dass der Wert FileCacheLifeTimeSeconds vorhanden und mit einem anderen Wert konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert FileCacheLifeTimeSeconds gibt die Lebensdauer für zwischengespeicherte IIS-Dateizugriffsnummern an. Dateizugriffsnummern werden zwischengespeichert, um die Leistung zu verbessern, da zwischengespeicherte Dateizugriffsnummern den Server davon abhalten, redundante Eingabe-/Ausgabe- (E/A) und CPU-Zyklen durchzuführen. Sobald der SMTP-Transportstack auf einem Exchange Server-Computer eine Nachricht empfängt, wird diese an das Dateisystem übertragen und von dort zu ihrem Ziel umgeleitet. Um in das Dateisystem zu schreiben, erhält der SMTP-Transportstack eine Dateizugriffsnummer und leitet die Nachricht weiter an diese Zugriffsnummer. Jede Dateizugriffsnummer beansprucht ungefähr 2 KB ausgelagerten Poolspeicher. Die Standardanzahl von Dateizugriffsnummern für den IIS-Cache beträgt 800 je 32 MB.

Der Registrierungswert ist in der Standardeinstellung nicht vorhanden, da Exchange 2000 Server Service Pack 2 (SP2) und höher sowie Exchange Server 2003 so konfiguriert sind, dass sie eine optimale Anzahl von Dateizugriffsnummern zwischenspeichern. Exchange Server 2003 berechnet die angemessenen Einstellungen für SMTP-Dateizugriffsnummern dynamisch, sodass die Einstellungen nicht mehr benötigt werden. Daher müssen Sie die Einträge aus der Registrierung löschen, bevor Sie Exchange 2000 Server-Computer mit diesen Einstellungen auf Exchange Server 2003 aktualisieren.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

  3. Löschen Sie im rechten Bereich den Wert FileCacheLifeTimeSeconds.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den IIS-Administratordienst neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Der SMTP-Registrierungswert „FileCacheMaxHandles" wurde manuell hinzugefügt, ist jedoch möglicherweise nicht mehr erforderlich.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob die maximale Anzahl der IIS-Cachedateizugriffsnummern (Internet Information Services) vom Standardwert 800 in einen anderen Wert geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Inetinfo\Parameters\FileCacheMaxHandles

Wenn Microsoft Exchange Server Analyzer feststellt, dass FileCacheMaxHandles vorhanden und mit einem Wert größer als 800 konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert FileCacheMaxHandles gibt die maximale Anzahl der IIS-Dateizugriffsnummern an, die Exchange für jeweils 32 MB physischen Speicher verwendet. Dateizugriffsnummern werden zwischengespeichert, um die Leistung zu verbessern, da zwischengespeicherte Dateizugriffsnummern den Server davon abhalten, redundante Eingabe-/Ausgabe- (E/A) und CPU-Zyklen durchzuführen. Sobald der SMTP-Transportstack auf einem Exchange Server-Computer eine Nachricht empfängt, wird diese an das Dateisystem übertragen und von dort zu ihrem Ziel weitergeleitet. Um in das Dateisystem zu schreiben, erhält der SMPT-Transportstack eine Dateizugriffsnummer und leitet die Nachricht weiter zu dieser Zugriffsnummer. Jede Dateizugriffsnummer beansprucht ungefähr 2 KB ausgelagerten Poolspeicher. Die Standardanzahl von Dateizugriffsnummern für den IIS-Cache beträgt 800 je 32 MB.

Vor Service Pack 2 (SP2) für Exchange 2000 Server traten bei Exchange-Servern mit langen SMTP-Nachrichtenwarteschlangen (z. B durchschnittlich 1.000 oder mehr Nachrichten) Leistungseinschränkungen auf, da in der Standardeinstellung im SMTP-Dienst maximal 1.000 Dateizugriffsnummern möglich waren. Da in der Standardeinstellung für Exchange 200 Server maximal 1.000 Dateizugriffsnummern zulässig waren, konnte der SMTP-Dienst nur 1.000 Nachrichten gleichzeitig in das Dateisystem schreiben.

Um die Leistung dieser großen Systeme zu verbessern, wurden oft drei Registrierungseinträge gleichzeitig angepasst, um die maximale Anzahl der Dateizugriffsnummern, die vom SMTP-Dienst geöffnet werden konnten, zu erhöhen (sodass mehr Nachrichten verarbeitet werden konnten) und die Anzahl der offenen Dateizugriffsnummern für das installierbare Dateisystem, eine andere Exchange-Komponente, zu verringern. (So wird vermieden, dass bei einer langen Warteschlange nicht ausreichend Arbeitsspeicher zur Verfügung steht). Die Registrierungswerte, die nicht in der Standardeinstellung vorhanden waren und daher manuell hinzugefügt werden mussten, sind unten aufgeführt:

Speicherort: HKLM\System\CurrentControlSet\Services\SMTPSVC\Queuing

Wert: MsgHandleThreshold

Typ: REG_DWORD

Speicherort: HKLM\System\CurrentControlSet\Services\SMTPSVC\Queuing

Wert: MsgHandleAsyncThreshold

Typ: REG_DWORD

Speicherort: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

Wert: FileCacheMaxHandles

Typ: REG_DWORD

Die Werte für die Einträge MsgHandleThreshold und MsgHandleAsyncThreshold stimmen normalerweise überein (üblicherweise ein Wert größer als 1.000), und der Wert für FileCacheMaxHandles wird üblicherweise von 800 auf 600 verringert.

Dieser Registrierungswert ist in der Standardeinstellung nicht vorhanden, da Exchange 2000 Server Service Pack 2 (SP2) und neuere Versionen die optimalen zu verwendenden Werte dynamisch bestimmen. Wenn auf dem Exchange-Server Exchange 2000 Server mit Service Pack 1 oder eine frühere Version ausgeführt wird, wird als optimale Vorgehensweise empfohlen, auf das aktuelle Service Pack oder Rollup-Paket zu aktualisieren. Sobald Sie auf den neuesten Code aktualisiert haben, können Sie die Registrierungseinträge löschen.

Exchange Server 2003 berechnet die entsprechenden Einstellungen für SMTP-Dateizugriffsnummern dynamisch, sodass die Einstellungen nicht mehr benötigt werden. Daher müssen Sie die Einträge aus der Registrierung löschen, bevor Sie Exchange 2000 Server-Computer mit diesen Einstellungen auf Exchange Server 2003 aktualisieren.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diesen Fehler

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

  3. Löschen Sie den Wert FileCacheMaxHandles.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den IIS-Administratordienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Der SMTP-Registrierungswert „GlitchRetrySeconds" wurde manuell festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-01-17

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die vorgegebene Wiederholungszeit bei Störungen manuell außer Kraft gesetzt wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\GlitchRetrySeconds

Wenn Exchange Server Analyzer erkennt, dass der Wert GlitchRetrySeconds vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Wenn Exchange 2000 Server oder Exchange Server 2003 versucht, eine Meldung zu einem stark überlasteten externen SMTP-System zu routen, wird unter Umständen eine Fehlermeldung empfangen, dass der Server ausgelastet ist. Geschieht dies, ändert Exchange seinen Status auf „glitch retry" (Wiederholung bei Störung). In diesem Status wartet Exchange 60 Sekunden, bevor es versucht, die Meldung erneut zu senden, und es wiederholt diesen Vorgang dreimal, bevor es auf andere Aktionen zurückgreift. Wenn externe SMTP-Server dauerhaft ausgelastet sind, sollten Sie die Wiederholungszeit bei Störung reduzieren, um zu verhindern, dass in der Warteschlange Meldungen massiv auflaufen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. Löschen Sie im rechten Bereich den Wert GlitchRetrySeconds. Alternativ können Sie den Wert für GlitchRetrySeconds reduzieren, wenn es zu einem massenhaften Auflauf von Meldungen kommt.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den SMTP-Dienst (Simple Mail Transfer Protocol) neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Der SMTP-Registrierungswert „IgnorePFTimeLimit" wurde manuell festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-01-17

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die Anzahl der Tage, die das Routingmodul des SMTP-Dienstes den neuen Informationsspeicher für Öffentliche Ordner umgeht, manuell festgelegt wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\IgnorePFTimeLimit

Wenn Microsoft Exchange Server Analyzer feststellt, dass der Wert IgnorePFTimeLimit vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Wenn der neue Informationsspeicher für Öffentliche Ordner online geschaltet wird, erkennen Sie möglicherweise in der Warteschlangenanzeige, dass die lokale Übermittlungswarteschlange wächst. Wenn die Öffentliche Ordner-Hierarchie groß ist, wachsen die Nachrichten in der lokalen Übermittlungswarteschlange weiter an, und die Übermittlung nimmt unter Umständen zusätzliche Zeit in Anspruch. In Einzelfällen können die Nachrichten möglicherweise nicht übermittelt werden.

Beim Integrieren des neuen Servers wird sein Distinguished Name dem Attribut msExchOwningPFTreeBL des Öffentlichen Ordner-Objekts in der Ordnerhierarchie der administrativen Gruppe im Active Directory®-Verzeichnisdienst hinzugefügt. Wenn das Kategorisierungsmodul für den Server, der für Öffentliche Ordner bestimmte Nachrichten empfängt, das Attribut msExchOwningPFTreeBL liest, sollte es, falls vorhanden, zunächst den lokalen Informationsspeicher für Öffentliche Ordner auswählen. Zum Lastenausgleich wählt es danach die Informationsspeicher für Öffentliche Ordner in der Reihenfolge aus, in der sie aufgelistet sind. Da der neue Server in der Liste ganz oben steht, werden die Nachrichten zu diesem Server geroutet. Dort werden sie der lokalen Übermittlungswarteschlange des neuen Server hinzugefügt. Wenn ein Informationsspeicher für Öffentliche Ordner keine Kopie der Hierarchie erhalten hat, kann der Server die Nachricht nicht zu einem Informationsspeicher routen, dem eine Kopie des Zielordners gehört.

Sie können dies verhindern, indem Sie zur Registrierung des neuen Öffentliche Ordner-Servers den Wert IgnorePFTimeLimit hinzufügen. Dabei wird die Anzahl der Tage angegeben, die das Routingmodul den neuen Informationsspeicher für Öffentliche Ordner umgeht.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Löschen Sie im rechten Bereich den Wert IgnorePFTimeLimit.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie dann den IIS-Administratordienst neu, damit die Änderung wirksam wird.

Weitere Informationen zu dem Thema und dem in diesem Artikel beschriebenen Registrierungswert IgnorePFTimeLimit finden Sie im Microsoft Knowledge Base-Artikel 328870, „XADM: Public Folder Routing is Enabled Before the Hierarchy is Replicated" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328870).

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Für die SMTP-Instanz sind mehrere Anschlussbindungen konfiguriert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob der Wert des Attributs msExchServerBindings auf einen Wert festgelegt wurde, der vom Standardwert 25 abweicht bzw. ob mehrere Werte festgelegt wurden. In der Standardeinstellung ist das Attribut msExchServerBindings für TCP-Anschluss 25 konfiguriert. Wenn Microsoft Exchange Server Analyzer feststellt, dass für dieses Attribut mehrere Werte festgelegt sind, wird zusammen mit dem Namen des virtuellen SMTP-Servers (Simple Mail Transfer Protocol), für den mehrere Werte festgelegt sind, eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Das Attribut msExchServerBindings stellt den TCP-Anschluss dar, der von diesem SMTP-Server auf eingehende Verbindungen überwacht wird. Virtuelle SMTP-Server können so konfiguriert werden, dass sie einen oder mehrere TCP-Anschlüsse abhören. In der Standardeinstellung sind alle virtuellen SMTP-Server so konfiguriert, dass sie den Standard-TCP-Anschluss 25 abhören. Wenn die Standardeinstellung für den überwachten SMTP-Anschluss geändert wurde und mehrere Anschlussbindungen umfasst, kann der Nachrichtenfluss gestört werden.

Das Ändern des überwachten SMTP-Anschlusses ist nur dann ohne Probleme möglich, wenn auch der Rest der internen Sofortnachrichteninfrastruktur entsprechend geändert wird. Im Allgemeinen können jedoch andere Anschlüsse für virtuelle SMTP-Server, die Nachrichten direkt aus dem Internet annehmen, nicht verwendet werden, da SMTP-Server im Internet Nachrichten über Anschluss 25 senden.

Microsoft Exchange Server Analyzer untersucht den Wert für den virtuellen Exchange-SMTP-Protokollserver. Bei diesem virtuellen SMTP-Protokollserver kann es sich um den SMTP-Server handeln, der Nachrichten direkt aus dem Internet empfängt. Manche Antivirus- und Anti-Spam-Produkte wurden dafür entwickelt, SMTP-Nachrichten aus dem Internet über Anschluss 25 zu empfangen und sie an einen virtuellen Exchange-SMTP-Server oder einen anderen Anschluss weiterzuleiten. In diesem Szenario ist die Konfiguration mit einem virtuellen Exchange-SMTP-Server zulässig, der mehrere Anschlüsse überprüft.

So können Sie den Abhöranschluss des virtuellen SMTP-Servers anzeigen oder ändern

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie nacheinander Server, einen Exchange-Server, Protokolle und dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise den virtuellen Standardserver für SMTP), und klicken Sie dann auf Eigenschaften.

  4. Wählen Sie die Registerkarte Allgemein aus, und klicken Sie dann auf Erweitert.

  5. Eine Liste mit IP-Adressen und Anschlüssen wird angezeigt.

    • Sie können den vorhandenen Anschluss ändern, indem Sie die IP-Adresse auswählen und auf Bearbeiten klicken. Ändern Sie den Wert im Feld TCP-Anschluss in 25.

    • Um Anschluss 25 als zusätzlichen Abhöranschluss hinzuzufügen, klicken Sie auf Hinzufügen, und geben Sie die neue Kombination aus IP-Adresse und Anschluss ein. Wenn Sie eine Verbindungs-, Sender- oder Empfängerfilterung verwenden, stellen Sie sicher, dass die entsprechenden Kontrollkästchen aktiviert sind.

  6. Klicken Sie auf OK, um die Änderungen zu speichern. Klicken Sie dann auf OK, um das Dialogfeld Erweitert zu schließen.

  7. Klicken Sie auf OK, um das Dialogfeld Eigenschaften des virtuellen SMTP-Servers zu schließen.

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 266686, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


Warnung zu SMTP-Nachrichtenfehler - Allgemeiner BADMAIL-Nachrichtenfehler
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_SMTPSVC_SMTPServer ab, um den Wert für den Schlüssel BadmailedMessagesGeneralFailure zu ermitteln. Der Wert dieses Schlüssels gibt die Anzahl der Nachrichten an, die nicht aufgrund eines spezifischen Leistungsindikators an das BadMail-Verzeichnis gesendet wurden. Das BadMail-Verzeichnis wird verwendet, um unzustellbare Nachrichten zu speichern. Informationen zu einigen anderen BadMail-WMI-Leistungsindikatoren finden Sie in den folgenden Artikeln zu Exchange Server Analyzer:

  • SMTP-Nachrichtenfehlerwarnung - BadMail-Nachrichten-Schwellenwert für Anzahl der Hops

  • Warnung zu SMTP-Nachrichtenfehler - BadMail-Nachrichten: Unzustellbarkeitsbericht von DSN

Es gibt Indikatoren, die erhöht werden, wenn eine Nachricht aus anderen Gründen an das BadMail-Verzeichnis gesendet wird, unter anderem durch beschädigte Pickup-Dateien, fehlende Empfänger, oder wenn dies durch ein Ereignis ausgelöst wurde.

Exchange Server Analyzer fragt außerdem den WMI-Schlüssel Win32_PerfRawData_PerfOS_System ab, um den Wert für SystemUpTime zu ermitteln.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel SystemUpTime größer als 0 und das Ergebnis des Wertes für BadmailedMessagesHopCountExceeded geteilt durch den Wert für SystemUpTime größer als 1000 ist, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass täglich durchschnittlich über 1.000 Nachrichten als nicht zustellbar gekennzeichnet und im BadMail-Verzeichnis gespeichert werden. Nachrichten im BadMail-Verzeichnis müssen manuell gelöscht werden. Es wird empfohlen, dass die Prüfung und Löschung von Nachrichten im BadMail-Verzeichnis in die regelmäßige Exchange Server-Wartung einbezogen wird. Wenn zugelassen wird, dass das BadMail-Verzeichnis ohne Beschränkungen anwächst, könnte der gesamte verfügbare Speicherplatz verbraucht werden und dadurch die Aufhebung der Bereitstellung des Informationsspeichers für die Exchange-Datenbanken verursacht werden.

So beheben Sie diese Warnmeldung

  1. Überprüfen Sie die Nachrichten im BadMail-Verzeichnis, um zu ermitteln, ob die Nachricht aus einer internen oder externen Quelle stammt. Nachrichten im BadMail-Verzeichnis werden im ASCII-Format gespeichert und können in Editor oder einem anderen Texteditor geöffnet und angezeigt werden.

    • Wenn die Nachrichten intern erstellt wurden, können Sie die Nachrichten-Header überprüfen, um den Ursprung der Nachricht zu ermitteln.

    • Wenn die Nachrichten extern erstellt wurden, ist dies möglicherweise ein Hinweis darauf, dass der Exchange Server als Mail-Relay verwendet wird.

Weitere Informationen über die Steuerung und Konfiguration von Relayoptionen finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 310380, „SO WIRDS GEMACHT: Verhindern der Weiterleitung von E-Mail-Nachrichten mit Exchange 2000 in Windows 2000" (http://support.microsoft.com/default.aspx?scid=kb;de;310380)

  • 313395, „SO WIRDS GEMACHT: Überprüfen von Relayeinschränkungen für anonyme SMTP-Verbindungen und Filtern nicht angeforderter E-Mail-Nachrichten in Exchange 2000 Server" (http://support.microsoft.com/default.aspx?scid=kb;de;313395)

Weitere Informationen zum Aufheben der Bereitstellung von Datenbanken aufgrund von nicht ausreichendem freien Speicherplatz finden Sie im Microsoft Knowledge Base-Artikel 321825, „Databases Become Dismounted Because of Lack of Disk Space" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=321825).


SMTP-Nachrichtenfehlerwarnung - BadMail-Nachrichten-Schwellenwert für Anzahl der Hops
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_PerfRawData_SMTPSVC_SMTPServer ab, um den Wert für den Schlüssel BadmailedMessagesHopCountExceeded zu ermitteln. Der Wert dieses Schlüssels stellt die Anzahl der Nachrichten dar, die an das BadMail-Verzeichnis gesendet wurden, weil sie die maximale Anzahl der Hops überschritten haben. Das BadMail-Verzeichnis wird verwendet, um unzustellbare Nachrichten zu speichern. Informationen zu einigen anderen WMI-BadMail-Indikatoren finden Sie in den Exchange Server Analyzer-Artikeln Warnung zu SMTP-Nachrichtenfehler - Allgemeiner BADMAIL-Nachrichtenfehler und Warnung zu SMTP-Nachrichtenfehler - BadMail-Nachrichten: Unzustellbarkeitsbericht von DSN.

Es gibt Indikatoren, die erhöht werden, wenn eine Nachricht aus anderen Gründen an das BadMail-Verzeichnis gesendet wird, unter anderem durch beschädigte Pickup-Dateien, fehlende Empfänger, oder wenn dies durch ein Ereignis ausgelöst wurde.

Exchange Server Analyzer fragt außerdem den WMI-Schlüssel Win32_PerfRawData_PerfOS_System ab, um den Wert für SystemUpTime zu ermitteln.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel SystemUpTime größer als 0 und das Ergebnis des Wertes für BadmailedMessagesHopCountExceeded geteilt durch den Wert für SystemUpTime größer als 100 ist, wird eine Warnung angezeigt.

Diese Warnung gibt an, dass täglich durchschnittlich 100 oder mehr Nachrichten als unzustellbar markiert und im BadMail-Verzeichnis gespeichert werden, weil sie die maximale Anzahl der Hops überschritten haben. Die maximale Anzahl der Hops stellt die maximale Anzahl der SMTP-Server dar, über die eine Nachricht vom Sender an den Empfänger weitergeleitet werden kann. Bei jeder Weiterleitung einer Nachricht über einen SMTP-Server wird dem Nachrichtenkopf eine Textzeile hinzugefügt, die den Hop darstellt.

Die optimale Anzahl der Nachrichtenhops richtet sich nach der Topologie des Netzwerks und den Messagingbedürfnissen. Um zu verhindern, dass eine Nachricht wiederholt fehlerhaft geroutet wird (diese Bedingung ist auch als Nachrichtenschleife bekannt), kann ein Administrator die Maximalanzahl erlaubter Hops steuern. Dies erfolgt durch das Festlegen einer maximalen Anzahl der Hops für den virtuellen SMTP-Server. Für Exchange 2000 Server liegt der Standardwert für die Anzahl der Hops bei 15. Für Exchange Server 2003 lautet der Standardwert 30. Sowohl für virtuelle SMTP-Server in Exchange 2000 Server als auch in Exchange Server 2003 wird der Wert 30 empfohlen.

Nachrichten im BadMail-Verzeichnis müssen manuell gelöscht werden. Es wird empfohlen, dass die Prüfung und Löschung von Nachrichten im BadMail-Verzeichnis in die regelmäßige Exchange Server-Wartung einbezogen wird. Wenn zugelassen wird, dass das BadMail-Verzeichnis ohne Beschränkungen anwächst, könnte der gesamte verfügbare Speicherplatz verbraucht werden und dadurch die Aufhebung der Bereitstellung des Informationsspeichers für die Exchange-Datenbanken verursacht werden.

So beheben Sie diese Warnmeldung

  1. Überprüfen Sie die Nachrichten im BadMail-Verzeichnis, um zu bestimmen, ob die Nachricht eine interne oder externe Quelle besitzt. Nachrichten im BadMail-Verzeichnis werden im ASCII-Format gespeichert und können in Notepad oder einem anderen Texteditor geöffnet und angezeigt werden.

    • Wenn die Nachrichten intern erstellt wurden, können Sie die Nachrichten-Header überprüfen, um den Ursprung der Nachricht zu ermitteln.

    • Wenn die Nachrichten extern erstellt wurden, ist dies möglicherweise ein Hinweis darauf, dass der Exchange Server als Mail-Relay verwendet wird.

  2. Legen Sie die Maximale Anzahl der Hops auf 30 fest.

    1. Öffnen Sie den Exchange-System-Manager.

    2. Erweitern Sie Server, erweitern Sie einen Exchange-Server, erweitern Sie Protokolle, und erweitern Sie dann SMTP.

    3. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise Virtueller Standardserver für SMTP), und wählen Sie dann Eigenschaften aus.

    4. Wählen Sie die Registerkarte Übermittlung aus, und klicken Sie auf Erweitert.

    5. Geben Sie im Feld Maximale Anzahl der Hops den gewünschten Wert ein, und klicken Sie auf OK, um die Änderung zu speichern.

    6. Klicken Sie auf OK, um das Dialogfeld Eigenschaften des virtuellen SMTP-Servers zu schließen.

Weitere Informationen über die Steuerung und Konfiguration von Relayoptionen finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 310380, „SO WIRDS GEMACHT: Verhindern der Weiterleitung von E-Mail-Nachrichten mit Exchange 2000 in Windows 2000" (http://support.microsoft.com/default.aspx?scid=kb;de;310380)

  • 313395, „SO WIRDS GEMACHT: Überprüfen von Relayeinschränkungen für anonyme SMTP-Verbindungen und Filtern nicht angeforderter E-Mail-Nachrichten in Exchange 2000 Server" (http://support.microsoft.com/default.aspx?scid=kb;de;313395)

Weitere Informationen zum Aufheben der Bereitstellung von Datenbanken aufgrund von nicht ausreichendem freien Speicherplatz finden Sie im Microsoft Knowledge Base-Artikel 321825, „Databases Become Dismounted Because of Lack of Disk Space" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=321825).


Warnung zu SMTP-Nachrichtenfehler - BadMail-Nachrichten: Unzustellbarkeitsbericht von DSN
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-23

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_SMTPSVC_SMTPServer ab, um den Wert für den Schlüssel BadmailedMessagesNDRofDSN zu ermitteln. Der Wert dieses Schlüssels stellt die Anzahl der DNS-Nachrichten (Delivery Status Notifications, Benachrichtigungen zum Übermittlungsstatus) dar, die an das BadMail-Verzeichnis gesendet wurden, da sie nicht zugestellt werden konnten. Das BadMail-Verzeichnis wird verwendet, um unzustellbare Nachrichten zu speichern. Informationen zu einigen anderen WMI-BadMail-Indikatoren finden Sie in den Exchange Server Analyzer-Artikeln Warnung zu SMTP-Nachrichtenfehler - Allgemeiner BADMAIL-Nachrichtenfehler und SMTP-Nachrichtenfehlerwarnung - BadMail-Nachrichten-Schwellenwert für Anzahl der Hops.

Es gibt Indikatoren, die erhöht werden, wenn eine Nachricht aus anderen Gründen an das BadMail-Verzeichnis gesendet wird, unter anderem durch beschädigte Pickup-Dateien, fehlende Empfänger, oder wenn dies durch ein Ereignis ausgelöst wurde.

Exchange Server Analyzer fragt außerdem den WMI-Schlüssel Win32_PerfRawData_PerfOS_System ab, um den Wert für SystemUpTime zu ermitteln.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel SystemUpTime größer ist als 0 und das Ergebnis des Werts für BadmailedMessagesNDRofDSN geteilt durch den Wert für SystemUpTime größer als 1000 ist, wird eine Warnung angezeigt.

Diese Warnung zeigt an, dass im Durchschnitt 1.000 oder mehr Benachrichtigungen zum Übermittlungsstatus täglich im BadMail-Verzeichnis gespeichert werden, da sie nicht zugestellt werden konnten. Nachrichten im BadMail-Verzeichnis müssen manuell gelöscht werden. Es wird empfohlen, dass die Prüfung und Löschung von Nachrichten im BadMail-Verzeichnis in die regelmäßige Exchange Server-Wartung einbezogen wird. Wenn zugelassen wird, dass das BadMail-Verzeichnis ohne Beschränkungen anwächst, könnte der gesamte verfügbare Speicherplatz verbraucht werden und dadurch die Aufhebung der Bereitstellung des Informationsspeichers für die Exchange-Datenbanken verursacht werden.

So beheben Sie diese Warnmeldung

  • Prüfen Sie die Nachrichten im BadMail-Verzeichnis, um zu bestimmen, ob die Benachrichtigungen zum Übermittlungsstatus für interne oder für externe Empfänger bestimmt sind. Nachrichten im BadMail-Verzeichnis werden im ASCII-Format gespeichert und können in Editor oder einem anderen Texteditor geöffnet und angezeigt werden.

    • Falls die Benachrichtigungen für interne Empfänger bestimmt sind, wird ein Problem beim Nachrichtenfluss angezeigt. Die Fehlerbehebung für dieses Problem ist abhängig vom spezifischen numerischen Code, der von der Benachrichtigung zum Übermittlungsstatus zurückgegeben wird.

    • Wenn die Benachrichtigungen zum Übermittlungsstatus für externe Empfänger bestimmt sind, ist dies möglicherweise ein Hinweis darauf, dass der Exchange Server als Mail-Relay verwendet wird. Auch in diesem Fall ist die Fehlerbehebung für dieses Problem abhängig vom zurückgegebenen numerischen Code.

Weitere Informationen zur Übermittlung von numerischen DSN-Rückgabecodes finden Sie im Microsoft Knowledge Base-Artikel 284204, „Benachrichtigungen zum Übermittlungsstatus in Exchange 2000 Server".

Informationen zum Steuern und Konfigurieren von Relayoptionen finden Sie im Microsoft Knowledge Base-Artikel 313395, „Überprüfen von Relayeinschränkungen für anonyme SMTP-Verbindungen und Filtern nicht angeforderter E-Mail-Nachrichten in Exchange 2000 Server".

Weitere Informationen zum Aufheben der Bereitstellung von Datenbanken aufgrund von nicht ausreichendem freien Speicherplatz finden Sie im Microsoft Knowledge Base-Artikel 321825 mit Informationen zu Datenbanken, deren Bereitstellung aufgrund fehlenden Festplattenspeichers aufgehoben wurde.


SMTP-Nachrichtenfehlerwarnung - Adressensuche für Kategorisierungsmodul nicht gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-03-20

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) Win32_PerfRawData_SMTPSVC_SMTPServer ab, um den Wert für den Schlüssel CatAddresslookupsnotfound zu ermitteln. Der Wert dieses Schlüssels steht für die Anzahl der von Nachrichtenkategorisierungsmodulen ausgeführten Adressensuchen, bei denen kein Verzeichnisdienstobjekt ermittelt wurde. Exchange Server Analyzer fragt außerdem den WMI-Schlüssel Win32_PerfRawData_PerfOS_System ab, um den Wert für SystemUpTime zu ermitteln.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel SystemUpTime größer als 0 und das Ergebnis des Werts für CatAddresslookupsnotfound geteilt durch den Wert für SystemUpTime größer als 5000 ist, wird eine Warnung angezeigt.

Das Nachrichtenkategorisierungsmodul überprüft Meldungen auf SMTP-Servern und bestimmt, was mit ihnen passieren soll. Die Nachrichten werden möglicherweise mithilfe des Message Transfer Agent (MTA) an den lokalen Informationsspeicher (einen Remotehost) übermittelt, oder die Nachrichten werden mithilfe von SMTP an einen Remotehost übermittelt. Das Katgorisierungsmodul behandelt auch die Aufgliederung der Verteilerliste. Das Kategorisierungsmodul ist ein Plug-In für das Warteschlangenmodul, das LDAP-Abfragen (Lightweight Directory Access Protocol) gegen globale Katalogserver am TCP-Anschluss 3268 durchführt. Das Kategorisierungsmodul stellt eine Sammlung von Ereignissenken dar, die eine erweiterte Adressauflösung an jeder Nachricht vornehmen, die vom erweiterten Warteschlangenmodul berabeitet wird. Es löst Adressen auf, leitet E-Mail-Nachrichten weiter, legt Inhaltskonvertierungsflags fest, erweitert Verteilerlisten, erzwingt globale Einstellungen, generiert Benachrichtigungen zum Übermittlungsstatus und führt alternative Empfängerroutenermittlung, Verzweigung, Aufzeichnung und viele andere Funktionen durch.

Wenn eine Nachricht in das Nachrichtenkategorisierungsmodul eingeht, löst das Kategorisierungsmodul den Umschlagabsender auf, indem es in den Proxyadressenattributen im Active Directory®-Verzeichnisdienst nach der Adresse sucht. Das Kategorisierungsmodul löst auch den Umschlagempfänger auf, indem es jedes Proxyadressenattribut in Active Directory sucht. Wenn die Liste beispielsweise eine Verteilerliste einschließt und das Erweitern von Verteilerlisten auf dem Server zugelassen ist, wird die Liste erweitert, um diese Mitglieder einzuschließen.

Die Warnung zeigt an, dass täglich durchschnittlich 5.000 oder mehr Adressensuchen durch Kategorisierungsmodule fehlschlagen. Es gibt einige Gründe dafür, unter anderem auch Probleme bezüglich des Verzeichnisdienstzugriffs (DSAccess), der Verzeichnisreplikationslatenzzeit oder -fehler, Verzeichnisangriffe, Probleme mit DNS oder die Verwendung fehlerhafter Adressen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie dieses Problem

  1. Überprüfen Sie die Ereignisprotokolle auf dem Exchange Server-Computer auf Fehler.

  2. Wenn Sie keine Ereignisse finden, die das Lösen des Problems ermöglichen, setzen Sie das Diagnoseprotokoll im MSExchangeTransport Categorizer auf den Maximalwert. Wenn das Diagnoseprotokoll aktiviert ist, überprüfen Sie das Protokoll erneut auf Fehler. Wenn das Konfigurieren des Diagnoseprotokolls zu keinen Ereignisprotokolleinträgen führt, konfigurieren Sie das Diagnoseprotokoll auf Ebene 7, indem Sie die Registrierung verwenden. Wenn Ebene 7 festgelegt ist, wird die vom Nachrichtenkategorisierungsmodul generierte Ereignis-ID 9000 protokolliert. Diese gibt die Einzelheiten zu Funktion, Fehlerursache, Name des fehlgeschlagenen Empfängers und Empfängertyp an. So legen Sie das Diagnoseprotokoll auf Ebene 7 fest:

    1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

    2. Navigieren Sie zu:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. Doppelklicken Sie im rechten Bereich auf 2 Categorizer, legen Sie den Datenwert auf 7 fest, und klicken Sie dann auf OK.

    4. Schließen Sie den Registrierungs-Editor.

      Hinweis:
      Wenn Sie die Fehlerbehandlung abgeschlossen haben, setzen Sie den Datenwert für 2 Categorizer zurück auf 0.

  3. Vergewissern Sie sich, dass Exchange Server eine Verbindung zu mindestens einem globalen Katalogserver hat. Dafür ist das Netzwerkmonitor-Tool in Windows sehr gut geeignet.

  4. Überprüfen Sie alle erstellten Benachrichtigungen zum Übermittlungsstatus. Benachrichtigungen zum Übermittlungsstatus, die Unzustellbarkeitsberichte enthalten können, beschreiben dauerhafte Fehlermeldungen und vorübergehende Fehlermeldungen, die häufig als dauerhafte Übermittlungsfehler enden.

  5. Mit der Nachrichtenverfolgung können Sie Meldungen beheben, die im Kategorisierungsmodul festsitzen.

  6. Mit dem Tool „Archive Sink" können Sie Nachrichten archivieren und analysieren, die bei Exchange Server ein- oder ausgehen.

  7. Überwachen Sie mithilfe des Systemmonitors die Leistungsindikatoren des Kategorisierungsmoduls.

Eine Auflistung der von Exchange Server und Microsoft Windows Small Business Server generierten Benachrichtigungen zum Übermittlungsstatus und zu Unzustellbarkeitsberichten finden Sie im Microsoft Knowledge Base-Artikel 284204, „Benachrichtigungen zum Übermittlungsstatus in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Weitere Informationen zur Verwendung des Nachrichtenstatus in Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 262162, „XADM: Using the Message Tracking Center to Track a Message" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162).

  • 246856, „XADM: How to Enable Message Tracking in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856).

  • 821905, „Message Tracking Event IDs in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905).

  • 823864, „Improved Message Tracking Features in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864).

Weitere Informationen zum Behandeln von Problemen im Zusammenhang mit Nachrichtenkategorisierungsmodulen finden Sie im Microsoft Support WebCast, „Exchange 2000 Server: Message Categorizer and NDR Troubleshooting" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137.

Weitere Informationen zum Tool Archive Sink finden Sie im Microsoft Knowledge Base-Artikel 307798, „The Archive Sink utility is available in Service Pack 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Allgemeine Informationen zum Behandeln von transportbezogenen Problemen finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 821910, „How To Troubleshoot for Exchange Server 2003 Transport Issues" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, „XCON: General Troubleshooting for Exchange 2000 Transport Issues" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

Die Leistungsindikatoren für das Nachrichtenkategorisierungsmodul werden für jede Instanz des virtuellen SMTP-Servers einzeln veröffentlicht. Eine Liste der verfügbaren Leistungsindikatoren im Zusammenhang mit dem Nachrichtenkategorisierungsmodul finden Sie im Microsoft Knowledge Base-Artikel 231734, „XCON: Performance Monitor Counters for Message Categorizer" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

Informationen zu einigen anderen WMI-Indikatoren für das Kategorisierungsmodul finden Sie in den folgenden Exchange Server Analyzer-Artikeln:

  • SMTP-Nachrichtenfehlerwarnung - Fehler beim Verzeichnisdienst des Kategorisierungsmoduls

  • SMTP-Nachrichtenfehlerwarnung - Fehler beim Anmelden am Kategorisierungsmodulverzeichnis

  • SMTP-Nachrichtenfehlerwarnung - Nicht-wiederholbarer Fehler des Kategorisierungsmoduls

  • SMTP-Nachrichtenfehlerwarnung - Speicher des Kategorisierungsmoduls voll

  • Warnung zu SMTP-Nachrichtenfehler - Behebbarer Fehler des Kategorisierungsmoduls


SMTP-Nachrichtenfehlerwarnung - Fehler beim Anmelden am Kategorisierungsmodulverzeichnis
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_PerfRawData_SMTPSVC_SMTPServer ab, um den Wert für den Schlüssel CatCategorizationsfailedDSlogonfailure zu ermitteln. Der Wert des Schlüssels stellt die Anzahl von Kategorisierungen dar, die aufgrund eines Fehlers beim Anmelden am Verzeichnisdienst fehlgeschlagen sind. Exchange Server Analyzer fragt außerdem den WMI-Schlüssel Win32_PerfRawData_PerfOS_System ab, um den Wert für SystemUpTime zu ermitteln.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel SystemUpTime größer als 0 ist und dass das Ergebnis des Werts für CatCategorizationsfailedDSlogonfailure geteilt durch den Wert für SystemUpTime größer als 50 ist, wird eine Warnung angezeigt.

Das Nachrichtenkategorisierungsmodul überprüft Meldungen auf SMTP-Servern und bestimmt, was mit ihnen passieren soll. Die Nachrichten werden möglicherweise mithilfe des Message Transfer Agent (MTA) an den lokalen Informationsspeicher (einen Remotehost) übermittelt, oder die Nachrichten werden mithilfe von SMTP an einen Remotehost übermittelt. Das Katgorisierungsmodul behandelt auch die Aufgliederung der Verteilerliste. Das Kategorisierungsmodul ist ein Plug-In für das Warteschlangenmodul, das LDAP-Abfragen (Lightweight Directory Access Protocol) gegen globale Katalogserver am TCP-Anschluss 3268 durchführt. Das Kategorisierungsmodul stellt eine Sammlung von Ereignissenken dar, die eine erweiterte Adressauflösung an jeder Nachricht vornehmen, die vom erweiterten Warteschlangenmodul berabeitet wird. Es löst Adressen auf, leitet E-Mail-Nachrichten weiter, legt Inhaltskonvertierungsflags fest, erweitert Verteilerlisten, erzwingt globale Einstellungen, generiert Benachrichtigungen zum Übermittlungsstatus und führt alternative Empfängerroutenermittlung, Verzweigung, Aufzeichnung und viele andere Funktionen durch.

Wird eine Nachricht in das Nachrichtenkategorisierungsmodell eingegeben, löst das Kategorisierungsmodul den Umschlagabsender auf, indem es die Proxyadressenattribute im Active Directory®-Verzeichnisdienst sucht. Das Kategorisierungsmodul löst auch den Umschlagempfänger auf, indem es jedes Proxyadressenattribut in Active Directory sucht. Wenn die Liste beispielsweise eine Verteilerliste einschließt und das Erweitern von Verteilerlisten auf dem Server zugelassen ist, wird die Liste erweitert, um diese Mitglieder einzuschließen.

Diese Warnung zeigt an, dass täglich durchschnittlich 50 oder mehr vom Nachrichtenkategorisierungsmodul durchgeführte Verzeichnisdienst-Verbindungsversuche wegen Anmeldefehlern fehlschlagen. Dafür gibt es mehrere Gründe, unter anderem Probleme beim Zugriff auf den Verzeichnisdienst (DSAccess), der Wartezeit oder Fehlern bei der Verzeichnisreplikation, überlastete globale Katalogserver oder Probleme mit DNS.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie dieses Problem

  1. Überprüfen Sie die Ereignisprotokolle auf dem Exchange Server-Computer auf Fehler.

  2. Wenn Sie keine Ereignisse finden, die das Lösen des Problems ermöglichen, setzen Sie das Diagnoseprotokoll im MSExchangeTransport-Kategorisierungsmodul auf Maximum. Überprüfen Sie nach dem Aktivieren des Diagnoseprotokolls das Ereignisprotokoll erneut auf Fehler. Wenn nach dem Konfigurieren des Diagnoseprotokolls keine Ereignisprotokolleinträge angezeigt werden, konfigurieren Sie das Diagnoseprotokoll mithilfe der Registrierung auf Ebene 7. Wenn Ebene 7 festgelegt ist, wird die vom Nachrichtenkategorisierungsmodul generierte Ereignis-ID 9000 protokolliert. Diese gibt die Einzelheiten zu Funktion, Fehlerursache, Name des fehlgeschlagenen Empfängers und Empfängertyp an. So legen Sie das Diagnoseprotokoll auf Ebene 7 fest:

    1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

    2. Navigieren Sie zu:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. Doppelklicken Sie im rechten Bereich auf 2 Categorizer, legen Sie den Datenwert auf 7 fest, und klicken Sie dann auf OK.

    4. Schließen Sie den Registrierungs-Editor.

      Hinweis:
      Wenn Sie die Fehlerbehandlung abgeschlossen haben, setzen Sie den Datenwert für 2 Categorizer zurück auf 0.

  3. Vergewissern Sie sich, dass Exchange Server eine Verbindung zu mindestens einem globalen Katalogserver hat. Dafür ist das Netzwerkmonitor-Tool in Windows sehr gut geeignet.

  4. Überprüfen Sie alle erstellten Benachrichtigungen zum Übermittlungsstatus. Benachrichtigungen zum Übermittlungsstatus, die Unzustellbarkeitsberichte enthalten können, beschreiben dauerhafte Fehlermeldungen und vorübergehende Fehlermeldungen, die häufig als dauerhafte Übermittlungsfehler enden.

  5. Mit der Nachrichtenverfolgung können Sie Meldungen beheben, die im Kategorisierungsmodul festsitzen.

  6. Mit dem Tool Archive Sink können Sie Nachrichten archivieren und analysieren, die bei Exchange Server ein- oder ausgehen.

  7. Überwachen Sie mithilfe des Systemmonitors die Leistungsindikatoren des Kategorisierungsmoduls.

Eine Auflistung der von Exchange Server und Microsoft Windows Small Business Server generierten Benachrichtigungen zum Übermittlungsstatus und zu Unzustellbarkeitsberichten finden Sie im Microsoft Knowledge Base-Artikel 284204, „Benachrichtigungen zum Übermittlungsstatus in Exchange 2000 Server" (http://support.microsoft.com/default.aspx?scid=kb;de;284204).

Weitere Informationen zum Verwenden des Nachrichtenstatus in Exchange Server finden Sie in den folgenden Knowledge Base-Artikeln:

  • 262162, „XADM: Using the Message Tracking Center to Track a Message" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162).

  • 246856, „XADM: How to Enable Message Tracking in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856).

  • 821905, „Message Tracking Event IDs in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905).

  • 823864, „Improved Message Tracking Features in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864).

Weitere Informationen zum Behandeln von Problemen im Zusammenhang mit Nachrichtenkategorisierungsmodulen finden Sie im Microsoft Support Webcast, „Exchange 2000 Server: Message Categorizer and NDR Troubleshooting" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137.

Weitere Informationen zum Tool Archive Sink finden Sie im Microsoft Knowledge Base-Artikel 307798, „The Archive Sink utility is available in Service Pack 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Allgemeine Informationen zum Behandeln von transportbezogenen Problemen finden Sie in den folgenden Knowledge Base-Artikeln:

  • 821910, „How To Troubleshoot for Exchange Server 2003 Transport Issues" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, „XCON: General Troubleshooting for Exchange 2000 Transport Issues" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

Die Leistungsindikatoren für das Nachrichtenkategorisierungsmodul werden für jede Instanz des virtuellen SMTP-Servers einzeln veröffentlicht. Eine Liste der verfügbaren Leistungsindikatoren im Zusammenhang mit dem Nachrichtenkategorisierungsmodul finden Sie im Microsoft Knowledge Base-Artikel 231734, „XCON: Performance Monitor Counters for Message Categorizer" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

Informationen zu einigen anderen WMI-Indikatoren für das Kategorisierungsmodul finden Sie in den folgenden Exchange Server Analyzer-Artikeln:

  • SMTP-Nachrichtenfehlerwarnung - Fehler beim Verzeichnisdienst des Kategorisierungsmoduls

  • SMTP-Nachrichtenfehlerwarnung - Adressensuche für Kategorisierungsmodul nicht gefunden

  • SMTP-Nachrichtenfehlerwarnung - Nicht-wiederholbarer Fehler des Kategorisierungsmoduls

  • SMTP-Nachrichtenfehlerwarnung - Speicher des Kategorisierungsmoduls voll

  • Warnung zu SMTP-Nachrichtenfehler - Behebbarer Fehler des Kategorisierungsmoduls


SMTP-Nachrichtenfehlerwarnung - Fehler beim Verzeichnisdienst des Kategorisierungsmoduls
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-03-20

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_PerfRawData_SMTPSVC_SMTPServer ab, um den aktuellen Wert des Schlüssels CatCategorizationsfailedDSconnectionfailure zu bestimmen. Der Wert des Schlüssels stellt die Anzahl von Kategorisierungen dar, die aufgrund eines Fehlers bei der Verbindung mit dem Verzeichnisdienst fehlgeschlagen sind. Exchange Server Analyzer fragt außerdem den WMI-Schlüssel Win32_PerfRawData_PerfOS_System ab, um den Wert für SystemUpTime zu ermitteln.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel SystemUpTime größer als 0 ist und dass das Ergebnis des Werts für CatCategorizationsfailedDSconnectionfailure geteilt durch den Wert für SystemUpTime größer als 50 ist, wird eine Warnung angezeigt.

Das Nachrichtenkategorisierungsmodul überprüft Meldungen auf SMTP-Servern und bestimmt, was mit ihnen passieren soll. Die Nachrichten werden möglicherweise mithilfe des Message Transfer Agent (MTA) an den lokalen Informationsspeicher (einen Remotehost) übermittelt, oder die Nachrichten werden mithilfe von SMTP an einen Remotehost übermittelt. Das Katgorisierungsmodul behandelt auch die Aufgliederung der Verteilerliste. Das Kategorisierungsmodul ist ein Plug-In für das Warteschlangenmodul, das LDAP-Abfragen (Lightweight Directory Access Protocol) gegen globale Katalogserver am TCP-Anschluss 3268 durchführt. Das Kategorisierungsmodul stellt eine Sammlung von Ereignissenken dar, die eine erweiterte Adressauflösung an jeder Nachricht vornehmen, die vom erweiterten Warteschlangenmodul berabeitet wird. Es löst Adressen auf, leitet E-Mail-Nachrichten weiter, legt Inhaltskonvertierungsflags fest, erweitert Verteilerlisten, erzwingt globale Einstellungen, generiert Benachrichtigungen zum Übermittlungsstatus und führt alternative Empfängerroutenermittlung, Verzweigung, Aufzeichnung und viele andere Funktionen durch.

Wenn eine Nachricht in das Nachrichtenkategorisierungsmodul eingeht, löst das Kategorisierungsmodul den Umschlagabsender auf, indem es in den Proxyadressenattributen im Active Directory®-Verzeichnisdienst nach der Adresse sucht. Das Kategorisierungsmodul löst auch den Umschlagempfänger auf, indem es jedes Proxyadressenattribut in Active Directory sucht. Wenn die Liste beispielsweise eine Verteilerliste einschließt und das Erweitern von Verteilerlisten auf dem Server zugelassen ist, wird die Liste erweitert, um diese Mitglieder einzuschließen.

Diese Warnung zeigt an, dass täglich durchschnittlich 50 oder mehr vom Nachrichtenkategorisierungsmodul durchgeführte Verbindungsversuche des Verzeichnisdiensts fehlschlagen. Dafür gibt es mehrere Gründe, unter anderem Probleme beim Zugriff auf den Verzeichnisdienst (DSAccess), der Wartezeit oder Fehlern bei der Verzeichnisreplikation, überlastete globale Katalogserver oder Probleme mit DNS.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie dieses Problem

  1. Überprüfen Sie die Ereignisprotokolle auf dem Exchange Server-Computer auf Fehler.

  2. Wenn Sie keine Ereignisse finden, die das Lösen des Problems ermöglichen, setzen Sie das Diagnoseprotokoll im MSExchangeTransport Categorizer auf den Maximalwert. Überprüfen Sie nach dem Aktivieren des Diagnoseprotokolls das Ereignisprotokoll erneut auf Fehler. Wenn das Konfigurieren des Diagnoseprotokolls zu keinen Ereignisprotokolleinträgen führt, konfigurieren Sie das Diagnoseprotokoll auf Ebene 7, indem Sie die Registrierung verwenden. Wenn Ebene 7 festgelegt ist, wird die vom Nachrichtenkategorisierungsmodul generierte Ereignis-ID 9000 protokolliert. Diese gibt die Einzelheiten zu Funktion, Fehlerursache, Name des fehlgeschlagenen Empfängers und Empfängertyp an. So legen Sie das Diagnoseprotokoll auf Ebene 7 fest:

    1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

    2. Navigieren Sie zu:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. Doppelklicken Sie im rechten Bereich auf 2 Categorizer, legen Sie den Datenwert auf 7 fest, und klicken Sie dann auf OK.

    4. Schließen Sie den Registrierungs-Editor.

      Hinweis:
      Wenn Sie die Fehlerbehandlung abgeschlossen haben, setzen Sie den Datenwert für 2 Categorizer zurück auf 0.

  3. Vergewissern Sie sich, dass Exchange Server eine Verbindung zu mindestens einem globalen Katalogserver hat. Dafür ist das Netzwerkmonitor-Tool in Windows sehr gut geeignet.

  4. Überprüfen Sie alle erstellten Benachrichtigungen zum Übermittlungsstatus. Benachrichtigungen zum Übermittlungsstatus, die Unzustellbarkeitsberichte enthalten können, beschreiben dauerhafte Fehlermeldungen und vorübergehende Fehlermeldungen, die häufig als dauerhafte Übermittlungsfehler enden.

  5. Mit der Nachrichtenverfolgung können Sie Meldungen beheben, die im Kategorisierungsmodul festsitzen.

  6. Mit dem Tool „Archive Sink" können Sie Nachrichten archivieren und analysieren, die bei Exchange Server ein- oder ausgehen.

  7. Überwachen Sie mithilfe des Systemmonitors die Leistungsindikatoren des Kategorisierungsmoduls.

Eine Auflistung der von Exchange Server und Microsoft Windows Small Business Server generierten Benachrichtigungen zum Übermittlungsstatus und zu Unzustellbarkeitsberichten finden Sie im Microsoft Knowledge Base-Artikel 284204, „Benachrichtigungen zum Übermittlungsstatus in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Weitere Informationen zur Verwendung des Nachrichtenstatus in Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 262162, „XADM: Using the Message Tracking Center to Track a Message" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162).

  • 246856, „XADM: How to Enable Message Tracking in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856).

  • 821905, „Message Tracking Event IDs in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905).

  • 823864, „Improved Message Tracking Features in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864).

Weitere Informationen zum Behandeln von Problemen im Zusammenhang mit Nachrichtenkategorisierungsmodulen finden Sie im Microsoft Support Webcast, „Exchange 2000 Server: Message Categorizer and NDR Troubleshooting" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137.

Weitere Informationen zum Tool Archive Sink finden Sie im Microsoft Knowledge Base-Artikel 307798, „The Archive Sink utility is available in Service Pack 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Allgemeine Informationen zum Behandeln von transportbezogenen Problemen finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 821910, „How To Troubleshoot for Exchange Server 2003 Transport Issues" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, „XCON: General Troubleshooting for Exchange 2000 Transport Issues" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

Die Leistungsindikatoren für das Nachrichtenkategorisierungsmodul werden für jede Instanz des virtuellen SMTP-Servers einzeln veröffentlicht. Eine Liste der verfügbaren Leistungsindikatoren im Zusammenhang mit dem Nachrichtenkategorisierungsmodul finden Sie im Microsoft Knowledge Base-Artikel 231734, „XCON: Performance Monitor Counters for Message Categorizer" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

Informationen zu einigen anderen WMI-Indikatoren für das Kategorisierungsmodul finden Sie in den folgenden Exchange Server Analyzer-Artikeln:

  • SMTP-Nachrichtenfehlerwarnung - Adressensuche für Kategorisierungsmodul nicht gefunden

  • SMTP-Nachrichtenfehlerwarnung - Fehler beim Anmelden am Kategorisierungsmodulverzeichnis

  • SMTP-Nachrichtenfehlerwarnung - Nicht-wiederholbarer Fehler des Kategorisierungsmoduls

  • SMTP-Nachrichtenfehlerwarnung - Speicher des Kategorisierungsmoduls voll

  • Warnung zu SMTP-Nachrichtenfehler - Behebbarer Fehler des Kategorisierungsmoduls


SMTP-Nachrichtenfehlerwarnung - Nicht-wiederholbarer Fehler des Kategorisierungsmoduls
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) Win32_PerfRawData_SMTPSVC_SMTPServer ab, um den Wert für den Schlüssel CatCategorizationsfailednonretryableerror zu ermitteln. Der Wert des Schlüssels stellt die Anzahl von Kategorisierungen dar, die aufgrund eines schwerwiegenden Fehlers (nicht-wiederholbar) fehlgeschlagen sind. Exchange Server Analyzer fragt außerdem den WMI-Schlüssel Win32_PerfRawData_PerfOS_System ab, um den Wert für SystemUpTime zu ermitteln.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel SystemUpTime größer als 0 und das Ergebnis des Werts für CatCategorizationsfailednonretryableerror geteilt durch den Wert für SystemUpTime größer als 50 ist, wird eine Warnung angezeigt.

Das Nachrichtenkategorisierungsmodul überprüft Meldungen auf SMTP-Servern und bestimmt, was mit ihnen passieren soll. Die Nachrichten werden möglicherweise mithilfe des Message Transfer Agent (MTA) an den lokalen Informationsspeicher (einen Remotehost) übermittelt, oder die Nachrichten werden mithilfe von SMTP an einen Remotehost übermittelt. Das Katgorisierungsmodul behandelt auch die Aufgliederung der Verteilerliste. Das Kategorisierungsmodul ist ein Plug-In für das Warteschlangenmodul, das LDAP-Abfragen (Lightweight Directory Access Protocol) gegen globale Katalogserver am TCP-Anschluss 3268 durchführt. Das Kategorisierungsmodul stellt eine Sammlung von Ereignissenken dar, die eine erweiterte Adressauflösung an jeder Nachricht vornehmen, die vom erweiterten Warteschlangenmodul berabeitet wird. Es löst Adressen auf, leitet E-Mail-Nachrichten weiter, legt Inhaltskonvertierungsflags fest, erweitert Verteilerlisten, erzwingt globale Einstellungen, generiert Benachrichtigungen zum Übermittlungsstatus und führt alternative Empfängerroutenermittlung, Verzweigung, Aufzeichnung und viele andere Funktionen durch.

Wird eine Nachricht in das Nachrichtenkategorisierungsmodell eingegeben, löst das Kategorisierungsmodul den Umschlagabsender auf, indem es die Proxyadressenattribute im Active Directory®-Verzeichnisdienst sucht. Das Kategorisierungsmodul löst auch den Umschlagempfänger auf, indem es jedes Proxyadressenattribut in Active Directory sucht. Wenn die Liste beispielsweise eine Verteilerliste einschließt und das Erweitern von Verteilerlisten auf dem Server zugelassen ist, wird die Liste erweitert, um diese Mitglieder einzuschließen.

Die Warnung zeigt an, dass täglich durchschnittlich 50 oder mehr schwerwiegende Fehler auftreten. Dafür gibt es mehrere Gründe, unter anderem Probleme beim Zugriff auf den Verzeichnisdienst (DSAccess), der Wartezeit oder Fehlern bei der Verzeichnisreplikation, überlastete globale Katalogserver oder Probleme mit DNS.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie dieses Problem

  1. Überprüfen Sie die Ereignisprotokolle auf dem Exchange Server-Computer auf Fehler.

  2. Wenn Sie keine Ereignisse finden, die das Lösen des Problems ermöglichen, setzen Sie das Diagnoseprotokoll im MSExchangeTransport-Kategorisierungsmodul auf Maximum. Nach dem Aktivieren des Diagnoseprotokolls, überprüfen Sie das Ereignisprotokoll erneut auf Fehler. Wenn nach dem Konfigurieren des Diagnoseprotokolls keine Ereignisprotokolleinträge angezeigt werden, konfigurieren Sie das Diagnoseprotokoll mithilfe der Registrierung auf Ebene 7. Wenn Ebene 7 festgelegt ist, wird die vom Nachrichtenkategorisierungsmodul generierte Ereignis-ID 9000 protokolliert. Diese gibt die Einzelheiten zu Funktion, Fehlerursache, Name des fehlgeschlagenen Empfängers und Empfängertyp an. So legen Sie das Diagnoseprotokoll auf Ebene 7 fest:

    1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

    2. Navigieren Sie zu:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. Doppelklicken Sie im rechten Bereich auf 2 Categorizer, legen Sie den Datenwert auf 7 fest, und klicken Sie dann auf OK.

    4. Schließen Sie den Registrierungs-Editor.

      Hinweis:
      Wenn Sie die Fehlerbehandlung abgeschlossen haben, setzen Sie den Datenwert für 2 Categorizer zurück auf 0.

  3. Vergewissern Sie sich, dass Exchange Server eine Verbindung zu mindestens einem globalen Katalogserver hat. Dafür ist das Netzwerkmonitor-Tool in Windows sehr gut geeignet.

  4. Überprüfen Sie alle erstellten Benachrichtigungen zum Übermittlungsstatus. Benachrichtigungen zum Übermittlungsstatus, die Unzustellbarkeitsberichte enthalten können, beschreiben dauerhafte Fehlermeldungen und vorübergehende Fehlermeldungen, die häufig als dauerhafte Übermittlungsfehler enden.

  5. Mit der Nachrichtenverfolgung können Sie Meldungen beheben, die im Kategorisierungsmodul festsitzen.

  6. Mit dem Tool „Archive Sink" können Sie Nachrichten archivieren und analysieren, die bei Exchange Server ein- oder ausgehen.

  7. Überwachen Sie mithilfe des Systemmonitors die Leistungsindikatoren des Kategorisierungsmoduls.

Eine Auflistung der von Exchange Server und Microsoft Windows Small Business Server generierten Benachrichtigungen zum Übermittlungsstatus und zu Unzustellbarkeitsberichten finden Sie im Microsoft Knowledge Base-Artikel 284204, „Benachrichtigungen zum Übermittlungsstatus in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Weitere Informationen zur Verwendung des Nachrichtenstatus in Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 262162, „XADM: Using the Message Tracking Center to Track a Message" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162).

  • 246856, „XADM: How to Enable Message Tracking in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856).

  • 821905, „Message Tracking Event IDs in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905).

  • 823864, „Improved Message Tracking Features in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864).

Weitere Informationen zum Behandeln von Problemen im Zusammenhang mit Nachrichtenkategorisierungsmodulen finden Sie im Microsoft Support Webcast, „Exchange 2000 Server: Message Categorizer and NDR Troubleshooting" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137.

Weitere Informationen zum Tool Archive Sink finden Sie im Microsoft Knowledge Base-Artikel 307798, „The Archive Sink utility is available in Service Pack 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Allgemeine Informationen zum Behandeln von transportbezogenen Problemen finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 821910, „How To Troubleshoot for Exchange Server 2003 Transport Issues" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, „XCON: General Troubleshooting for Exchange 2000 Transport Issues" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

Die Leistungsindikatoren für das Nachrichtenkategorisierungsmodul werden für jede Instanz des virtuellen SMTP-Servers einzeln veröffentlicht. Eine Liste der verfügbaren Leistungsindikatoren im Zusammenhang mit dem Nachrichtenkategorisierungsmodul finden Sie im Microsoft Knowledge Base-Artikel 231734, „XCON: Performance Monitor Counters for Message Categorizer" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

Informationen zu einigen anderen WMI-Indikatoren für das Kategorisierungsmodul finden Sie in den folgenden Exchange Server Analyzer-Artikeln:

  • SMTP-Nachrichtenfehlerwarnung - Adressensuche für Kategorisierungsmodul nicht gefunden

  • SMTP-Nachrichtenfehlerwarnung - Fehler beim Anmelden am Kategorisierungsmodulverzeichnis

  • SMTP-Nachrichtenfehlerwarnung - Fehler beim Verzeichnisdienst des Kategorisierungsmoduls

  • SMTP-Nachrichtenfehlerwarnung - Speicher des Kategorisierungsmoduls voll

  • Warnung zu SMTP-Nachrichtenfehler - Behebbarer Fehler des Kategorisierungsmoduls


SMTP-Nachrichtenfehlerwarnung - Speicher des Kategorisierungsmoduls voll
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-03-28

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_SMTPSVC_SMTPServer ab, um den Wert für den Schlüssel CatCategorizationsfailedretryableerror zu ermitteln. Der Wert des Schlüssels stellt die Anzahl von Kategorisierungen dar, die aufgrund eines Mangels an verfügbarem Speicherplatz fehlgeschlagen sind. Exchange Server Analyzer fragt außerdem den WMI-Schlüssel Win32_PerfRawData_PerfOS_System ab, um den Wert für SystemUpTime zu ermitteln.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel SystemUpTime größer als 0 ist, und dass das Ergebnis des Werts für CatCategorizationsfailedOutOfMemory geteilt durch den Wert für SystemUpTime größer als 50 ist, wird eine Warnung angezeigt.

Das Nachrichtenkategorisierungsmodul überprüft Meldungen auf SMTP-Servern und bestimmt, was mit ihnen passieren soll. Die Nachrichten werden möglicherweise mithilfe des Message Transfer Agent (MTA) an den lokalen Informationsspeicher (einen Remotehost) übermittelt, oder die Nachrichten werden mithilfe von SMTP an einen Remotehost übermittelt. Das Katgorisierungsmodul behandelt auch die Aufgliederung der Verteilerliste. Das Kategorisierungsmodul ist ein Plug-In für das Warteschlangenmodul, das LDAP-Abfragen (Lightweight Directory Access Protocol) gegen globale Katalogserver am TCP-Anschluss 3268 durchführt. Das Kategorisierungsmodul stellt eine Sammlung von Ereignissenken dar, die eine erweiterte Adressauflösung an jeder Nachricht vornehmen, die vom erweiterten Warteschlangenmodul berabeitet wird. Es löst Adressen auf, leitet E-Mail-Nachrichten weiter, legt Inhaltskonvertierungsflags fest, erweitert Verteilerlisten, erzwingt globale Einstellungen, generiert Benachrichtigungen zum Übermittlungsstatus und führt alternative Empfängerroutenermittlung, Verzweigung, Aufzeichnung und viele andere Funktionen durch.

Wird eine Nachricht in das Nachrichtenkategorisierungsmodell eingegeben, löst das Kategorisierungsmodul den Umschlagabsender auf, indem es die Proxyadressenattribute im Active Directory®-Verzeichnisdienst sucht. Das Kategorisierungsmodul löst auch den Umschlagempfänger auf, indem es jedes Proxyadressenattribut in Active Directory sucht. Wenn die Liste beispielsweise eine Verteilerliste einschließt und das Erweitern von Verteilerlisten auf dem Server zugelassen ist, wird die Liste erweitert, um diese Mitglieder einzuschließen.

Diese Warnung zeigt an, dass täglich durchschnittlich 50 oder mehr Kategorisierungsmodule aufgrund mangelnden Arbeitspeichers fehlschlagen. Dafür gibt es mehrere Gründe, unter anderem Probleme beim Zugriff auf den Verzeichnisdienst (DSAccess), der Wartezeit oder Fehlern bei der Verzeichnisreplikation, überlastete globale Katalogserver oder Probleme mit DNS.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diese Warnmeldung

  1. Überprüfen Sie die Ereignisprotokolle auf dem Exchange Server-Computer auf Fehler.

  2. Wenn Sie keine Ereignisse finden, die das Lösen des Problems ermöglichen, setzen Sie das Diagnoseprotokoll im MSExchangeTransport-Kategorisierungsmodul auf Maximum. Nach dem Aktivieren des Diagnoseprotokolls, überprüfen Sie das Ereignisprotokoll erneut auf Fehler. Wenn nach dem Konfigurieren des Diagnoseprotokolls keine Ereignisprotokolleinträge angezeigt werden, konfigurieren Sie das Diagnoseprotokoll mithilfe der Registrierung auf Ebene 7. Wenn Ebene 7 festgelegt ist, wird die vom Nachrichtenkategorisierungsmodul generierte Ereignis-ID 9000 protokolliert. Diese gibt die Einzelheiten zu Funktion, Fehlerursache, Name des fehlgeschlagenen Empfängers und Empfängertyp an. So legen Sie das Diagnoseprotokoll auf Ebene 7 fest:

    1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

    2. Navigieren Sie zu:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. Doppelklicken Sie im rechten Bereich auf 2 Categorizer, legen Sie den Datenwert auf 7 fest, und klicken Sie dann auf OK.

    4. Schließen Sie den Registrierungs-Editor.

      Hinweis:
      Wenn Sie die Fehlerbehandlung abgeschlossen haben, setzen Sie den Datenwert für 2 Categorizer zurück auf 0.

  3. Vergewissern Sie sich, dass Exchange Server eine Verbindung zu mindestens einem globalen Katalogserver hat. Dafür ist das Netzwerkmonitor-Tool in Windows sehr gut geeignet.

  4. Überprüfen Sie alle erstellten Benachrichtigungen zum Übermittlungsstatus. Benachrichtigungen zum Übermittlungsstatus, die Unzustellbarkeitsberichte enthalten können, beschreiben dauerhafte Fehlermeldungen und vorübergehende Fehlermeldungen, die häufig als dauerhafte Übermittlungsfehler enden.

  5. Mit der Nachrichtenverfolgung können Sie Meldungen beheben, die im Kategorisierungsmodul festsitzen.

  6. Mit dem Tool Archive Sink können Sie Nachrichten archivieren und analysieren, die bei Exchange Server ein- oder ausgehen.

  7. Überwachen Sie mithilfe des Systemmonitors die Leistungsindikatoren des Kategorisierungsmoduls.

Eine Auflistung der von Exchange Server und Microsoft Windows Small Business Server generierten Benachrichtigungen zum Übermittlungsstatus und zu Unzustellbarkeitsberichten finden Sie im Microsoft Knowledge Base-Artikel 284204, „Benachrichtigungen zum Übermittlungsstatus in Exchange 2000 Server" (http://support.microsoft.com/default.aspx?scid=kb;de;284204).

Weitere Informationen zur Verwendung des Nachrichtenstatus in Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 262162, „XADM: Using the Message Tracking Center to Track a Message" (http://support.microsoft.com/kb/262162/en-us).

  • 246856, „XADM: Aktivieren des Nachrichtenstatus in Exchange 2000 Server und Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856).

  • 821905, „Message Tracking Event IDs in Exchange Server 2003" (http://support.microsoft.com/kb/821905/en-us).

  • 823864, „Improved Message Tracking Features in Exchange Server 2003" (http://support.microsoft.com/kb/823864/en-us).

Weitere Informationen zum Behandeln von Problemen im Zusammenhang mit Nachrichtenkategorisierungsmodulen finden Sie im Microsoft Support Webcast, „Exchange 2000 Server: Message Categorizer and NDR Troubleshooting" unter http://support.microsoft.com/kb/329137/en-us.

Weitere Informationen zum Tool Archive Sink finden Sie im Microsoft Knowledge Base-Artikel 307798, „The Archive Sink utility is available in Service Pack 2" (http://support.microsoft.com/kb/307798/en-us).

Allgemeine Informationen zum Behandeln von transportbezogenen Problemen finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 821910, „How To Troubleshoot for Exchange Server 2003 Transport Issues" (http://support.microsoft.com/kb/821910/en-us).

  • 257265, "Allgemeine Behandlung von Transportproblemen in Exchange 2000 Server und in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=305 2 &kbid=257265).

Die Leistungsindikatoren für das Nachrichtenkategorisierungsmodul werden für jede Instanz des virtuellen SMTP-Servers einzeln veröffentlicht. Eine Liste der verfügbaren Leistungsindikatoren im Zusammenhang mit dem Nachrichtenkategorisierungsmodul finden Sie im Microsoft Knowledge Base-Artikel 231734, „XCON: Performance Monitor Counters for Message Categorizer" (http://support.microsoft.com/kb/231734/en-us).

Informationen zu einigen anderen WMI-Indikatoren für das Kategorisierungsmodul finden Sie in den folgenden Exchange Server Analyzer-Artikeln:

  • SMTP-Nachrichtenfehlerwarnung - Adressensuche für Kategorisierungsmodul nicht gefunden

  • SMTP-Nachrichtenfehlerwarnung - Fehler beim Anmelden am Kategorisierungsmodulverzeichnis

  • SMTP-Nachrichtenfehlerwarnung - Fehler beim Verzeichnisdienst des Kategorisierungsmoduls

  • SMTP-Nachrichtenfehlerwarnung - Nicht-wiederholbarer Fehler des Kategorisierungsmoduls

  • Warnung zu SMTP-Nachrichtenfehler - Behebbarer Fehler des Kategorisierungsmoduls


Warnung zu SMTP-Nachrichtenfehler - Behebbarer Fehler des Kategorisierungsmoduls
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-03-20

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_PerfRawData_SMTPSVC_SMTPServer ab, um den Wert für den Schlüssel CatCategorizationsfailedretryableerror zu ermitteln. Der Wert dieses Schlüssels legt die Anzahl der Kategorisierungen fest, die mit einem wiederholbaren Fehler fehlschlagen dürfen. Exchange Server Analyzer fragt außerdem den WMI-Schlüssel Win32_PerfRawData_PerfOS_System ab, um den Wert für SystemUpTime zu ermitteln.

Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel SystemUpTime größer als 0 und das Ergebnis des Werts für CatCategorizationsfailedretryableerror geteilt durch den Wert für SystemUpTime größer als 500 ist, wird eine Warnung angezeigt.

Das Nachrichtenkategorisierungsmodul überprüft Meldungen auf SMTP-Servern und bestimmt, was mit ihnen passieren soll. Die Nachrichten werden möglicherweise mithilfe des Message Transfer Agent (MTA) an den lokalen Informationsspeicher (einen Remotehost) übermittelt, oder die Nachrichten werden mithilfe von SMTP an einen Remotehost übermittelt. Das Katgorisierungsmodul behandelt auch die Aufgliederung der Verteilerliste. Das Kategorisierungsmodul ist ein Plug-In für das Warteschlangenmodul, das LDAP-Abfragen (Lightweight Directory Access Protocol) gegen globale Katalogserver am TCP-Anschluss 3268 durchführt. Das Kategorisierungsmodul stellt eine Sammlung von Ereignissenken dar, die eine erweiterte Adressauflösung an jeder Nachricht vornehmen, die vom erweiterten Warteschlangenmodul berabeitet wird. Es löst Adressen auf, leitet E-Mail-Nachrichten weiter, legt Inhaltskonvertierungsflags fest, erweitert Verteilerlisten, erzwingt globale Einstellungen, generiert Benachrichtigungen zum Übermittlungsstatus und führt alternative Empfängerroutenermittlung, Verzweigung, Aufzeichnung und viele andere Funktionen durch.

Wenn eine Nachricht in das Nachrichtenkategorisierungsmodell eingegeben wird, löst das Kategorisierungsmodul den Umschlagabsender auf, indem es die Proxyadressenattribute im Active Directory®-Verzeichnisdienst sucht. Das Kategorisierungsmodul löst auch den Umschlagempfänger auf, indem es jedes Proxyadressenattribut in Active Directory sucht. Wenn die Liste beispielsweise eine Verteilerliste einschließt und das Erweitern von Verteilerlisten auf dem Server zugelassen ist, wird die Liste erweitert, um diese Mitglieder einzuschließen.

Diese Warnung zeigt an, dass täglich durchschnittlich 500 oder mehr Kategorisierungen mit einem wiederholbaren Fehler fehlschlagen. Dafür gibt es mehrere Gründe, unter anderem Probleme bezüglich des Verzeichnisdienstzugriffs (DSAccess), der Verzeichnisreplikations-Latenzzeit oder -Fehler, überlastete globale Katalogserver oder Probleme mit DNS.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diese Warnmeldung

  1. Überprüfen Sie die Ereignisprotokolle auf dem Exchange Server-Computer auf Fehler.

  2. Wenn Sie keine Ereignisse finden, die das Lösen des Problems ermöglichen, setzen Sie das Diagnoseprotokoll im MSExchangeTransport-Kategorisierungsmodul auf Maximum. Überprüfen Sie nach dem Aktivieren des Diagnoseprotokolls das Ereignisprotokoll erneut auf Fehler. Wenn nach dem Konfigurieren des Diagnoseprotokolls keine Ereignisprotokolleinträge angezeigt werden, konfigurieren Sie das Diagnoseprotokoll mithilfe der Registrierung auf Ebene 7. Wenn Ebene 7 festgelegt ist, wird die vom Nachrichtenkategorisierungsmodul generierte Ereignis-ID 9000 protokolliert. Diese gibt die Einzelheiten zu Funktion, Fehlerursache, Name des fehlgeschlagenen Empfängers und Empfängertyp an. So legen Sie das Diagnoseprotokoll auf Ebene 7 fest:

    1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

    2. Navigieren Sie zu:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. Doppelklicken Sie im rechten Bereich auf 2 Categorizer, legen Sie den Datenwert auf 7 fest, und klicken Sie dann auf OK.

    4. Schließen Sie den Registrierungs-Editor.

      Hinweis:
      Wenn Sie die Fehlerbehandlung abgeschlossen haben, setzen Sie den Datenwert für 2 Categorizer zurück auf 0.

  3. Vergewissern Sie sich, dass Exchange Server eine Verbindung zu mindestens einem globalen Katalogserver hat. Dafür ist das Netzwerkmonitor-Tool in Windows sehr gut geeignet.

  4. Überprüfen Sie alle erstellten Benachrichtigungen zum Übermittlungsstatus. Benachrichtigungen zum Übermittlungsstatus, die Unzustellbarkeitsberichte enthalten können, beschreiben dauerhafte Fehlermeldungen und vorübergehende Fehlermeldungen, die häufig als dauerhafte Übermittlungsfehler enden.

  5. Mit der Nachrichtenverfolgung können Sie Meldungen beheben, die im Kategorisierungsmodul festsitzen.

  6. Mit dem Tool Archive Sink können Sie Nachrichten archivieren und analysieren, die bei Exchange Server ein- oder ausgehen.

  7. Überwachen Sie mithilfe des Systemmonitors die Leistungsindikatoren des Kategorisierungsmoduls.

Eine Auflistung der von Exchange Server und Microsoft Windows Small Business Server generierten Benachrichtigungen zum Übermittlungsstatus und zu Unzustellbarkeitsberichten finden Sie im Microsoft Knowledge Base-Artikel 284204, „Benachrichtigungen zum Übermittlungsstatus in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Weitere Informationen zur Verwendung des Nachrichtenstatus in Exchange Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 262162, „XADM: Using the Message Tracking Center to Track a Message" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162).

  • 246856, „XADM: How to Enable Message Tracking in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856).

  • 821905, „Message Tracking Event IDs in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905).

  • 823864, „Improved Message Tracking Features in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864).

Weitere Informationen zum Behandeln von Problemen im Zusammenhang mit Nachrichtenkategorisierungsmodulen finden Sie im Microsoft Support Webcast, „Exchange 2000 Server: Message Categorizer and NDR Troubleshooting" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137.

Weitere Informationen zum Tool Archive Sink finden Sie im Microsoft Knowledge Base-Artikel 307798, „The Archive Sink utility is available in Service Pack 2" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Allgemeine Informationen zum Behandeln von transportbezogenen Problemen finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 821910, „How To Troubleshoot for Exchange Server 2003 Transport Issues" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910)

  • 257265, „XCON: General Troubleshooting for Exchange 2000 Transport Issues" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265)

Die Leistungsindikatoren für das Nachrichtenkategorisierungsmodul werden für jede Instanz des virtuellen SMTP-Servers einzeln veröffentlicht. Eine Liste der verfügbaren Leistungsindikatoren im Zusammenhang mit dem Nachrichtenkategorisierungsmodul finden Sie im Microsoft Knowledge Base-Artikel 231734, „XCON: Performance Monitor Counters for Message Categorizer" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

Informationen zu einigen anderen WMI-Indikatoren für das Kategorisierungsmodul finden Sie in den folgenden Exchange Server Analyzer-Artikeln:

  • SMTP-Nachrichtenfehlerwarnung - Adressensuche für Kategorisierungsmodul nicht gefunden

  • SMTP-Nachrichtenfehlerwarnung - Fehler beim Anmelden am Kategorisierungsmodulverzeichnis

  • SMTP-Nachrichtenfehlerwarnung - Fehler beim Verzeichnisdienst des Kategorisierungsmoduls

  • SMTP-Nachrichtenfehlerwarnung - Nicht-wiederholbarer Fehler des Kategorisierungsmoduls

  • SMTP-Nachrichtenfehlerwarnung - Speicher des Kategorisierungsmoduls voll


Daten aus der SMTP-Mail-Warteschlange werden in einen komprimierten Ordner geschrieben.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer sendet eine Abfrage an die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) Win32_Directory, um den Wert des Schlüssels Compressed für den SMTP-Mail-Warteschlangenordner zu ermitteln. Stellt Exchange Server Analyzer fest, dass der Wert Compressed auf True festgelegt ist, wird eine Warnung angezeigt.

Wenn Nachrichten über den SMTP-Dienst auf dem Exchange-Computer eingehen, werden die Daten als EML-Datei auf die Festplatte geschrieben. In der Standardeinstellung werden diese Dateien im Ordner <Laufwerk>:\Programme\Exchsrvr\Mailroot auf der Partition gespeichert, auf der auch Exchange installiert ist. Wenn im Ordner mit der SMTP-Warteschlange die Dateikomprimierung aktiviert ist, kann die Exchange-Leistung stark beeinträchtigt werden. Aus diesem Grund wird die Komprimierung für den Ordner mit der SMTP-Mail-Warteschlange nicht unterstützt.

Das Speichern von Exchange-Datendateien auf einem komprimierten Datenträger wird von Microsoft nicht unterstützt. Wenn Sie Ihre Exchange-Datendateien auf einem komprimierten Datenträger speichern, beeinträchtigt der zusätzliche Aufwand die Leistung von Exchange erheblich. Zu den Exchange-Datendateien gehören folgende Dateien:

  • EDB-Dateien

  • STM-Dateien

  • LOG-Dateien

  • DAT-Dateien

  • EML-Dateien

  • CHK-Dateien

So deaktivieren Sie die Dateikomprimierung für einen angegebenen Ordner:

  1. Klicken Sie mit der rechten Maustaste auf den Ordner, für den Dateikomprimierung deaktiviert werden soll, und klicken Sie dann auf Eigenschaften.

  2. Klicken Sie auf der Registerkarte Allgemein auf Erweitert.

  3. Deaktivieren Sie im Dialogfeld Erweiterte Attribute das Kontrollkästchen Inhalt komprimieren, um Speicherplatz zu sparen, und klicken Sie dann auf OK.

So verschieben Sie den Mailroot-Ordner auf Exchange 2000 Server oder Exchange Server 2003

  1. Öffnen Sie den Exchange-System-Manager.

  2. Klicken Sie auf Administrative Gruppen, erweitern Sie Ihre administrative Gruppe, erweitern Sie Server und Ihren Server, erweitern Sie Protokolle und dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf Ihren virtuellen SMTP-Server, und klicken Sie dann auf Beenden.

  4. Klicken Sie mit der rechten Maustaste auf Ihren virtuellen SMTP-Server, und klicken Sie dann auf Eigenschaften.

  5. Klicken Sie auf der Registerkarte Nachrichten neben dem Feld Warteschlangenverzeichnis auf Durchsuchen, und geben Sie dann den Pfad für den neuen Speicherort des Warteschlangenordners ein.

  6. Klicken Sie auf OK.

  7. Klicken Sie mit der rechten Maustaste auf Ihren virtuellen SMTP-Server, und klicken Sie dann auf Starten.

Weitere Informationen über das Verschieben des Ordners Mailroot finden Sie im Microsoft Knowledge Base-Artikel 822933 „How to change the Exchange 2003 SMTP Mailroot folder location" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).


SMTP-Mail-Warteschlangendaten werden in einen verschlüsselten Ordner geschrieben
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_Directory ab, um den Wert des Schlüssels Encrypted für den SMTP-Mail-Warteschlangenordner (Simple Mail Transfer Protocol) zu bestimmen. Wenn Exchange Server Analyzer feststellt, dass der Wert Verschlüsselt auf True festgelegt ist, wird eine Warnung angezeigt.

Wenn Nachrichten über den SMTP-Dienst auf dem Exchange-Computer eingehen, werden die Daten als EML-Datei auf die Festplatte geschrieben. In der Standardeinstellung werden diese Dateien im Ordner <Laufwerk>:\Programme\Exchsrvr\Mailroot auf der Partition gespeichert, auf der auch Exchange installiert ist. Wenn im Ordner mit der SMTP-Warteschlange die Dateiverschlüsselung aktiviert ist, kann die Exchange-Leistung stark beeinträchtigt werden. Aus diesem Grunde wird die Verschlüsselung des Ordners mit der SMTP-Mail-Warteschlange nicht unterstützt.

Microsoft unterstützt nicht das Speichern von Exchange-Datendateien auf verschlüsselten Datenträgern in verschlüsselnden Dateisystemen (Encrypting File Systems, EFS). Wenn Exchange-Datendateien auf einem verschlüsselten Datenträger gespeichert werden, beeinträchtigt der zusätzliche Aufwand die Leistung von Exchange erheblich. Zu den Exchange-Datendateien gehören folgende Dateien:

  • EDB-Dateien

  • STM-Dateien

  • LOG-Dateien

  • DAT-Dateien

  • EML-Dateien

  • CHK-Dateien

Um die Sicherheit der Exchange-Datendateien zu gewährleisten, empfiehlt es sich, den unbefugten Zugriff auf den Exchange-Computer zu verhindern und Nachrichtendaten mithilfe des S/MIME-Nachrichtenformats zu verschlüsseln.

Um diesen Fehler zu beheben, müssen Sie entweder die Dateiverschlüsselung für den SMTP-Mail-Warteschlangenordner deaktivieren, oder Sie müssen ihn an einen Speicherort verschieben, an dem keine Verschlüsselung aktiviert ist.

So deaktivieren Sie die Dateiverschlüsselung für den angegebenen Ordner:

  1. Klicken Sie mit der rechten Maustaste auf den Ordner, für den die Verschlüsselung deaktiviert werden soll, und klicken Sie dann auf Eigenschaften.

  2. Klicken Sie auf der Registerkarte Allgemein auf Erweitert.

  3. Deaktivieren Sie im Dialogfeld Erweiterte Attribute das Kontrollkästchen Inhalt verschlüsseln, um Daten zu schützen, und klicken Sie dann auf OK.

So verschieben Sie den SMTP-Mail-Warteschlangenordner unter Exchange 2000 Server oder Exchange Server 2003

  1. Öffnen Sie den Exchange-System-Manager.

  2. Klicken Sie auf Administrative Gruppen, erweitern Sie Ihre administrative Gruppe, erweitern Sie Server und Ihren Server, erweitern Sie Protokolle und dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf Ihren virtuellen SMTP-Server, und klicken Sie dann auf Beenden.

  4. Klicken Sie mit der rechten Maustaste auf Ihren virtuellen SMTP-Server, und klicken Sie dann auf Eigenschaften.

  5. Klicken Sie auf der Registerkarte Nachrichten neben dem Feld BADMAIL-Verzeichnis auf Durchsuchen, und geben Sie dann den Pfad für den neuen Speicherort des Warteschlangenordners ein.

  6. Klicken Sie auf OK.

  7. Klicken Sie mit der rechten Maustaste auf Ihren virtuellen SMTP-Server, und klicken Sie dann auf Starten.

Weitere Informationen über das Verschieben des Ordners Mailroot finden Sie im Microsoft Knowledge Base-Artikel 822933 „How to change the Exchange 2003 SMTP Mailroot folder location" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Weitere Informationen über Exchange Server-Datendateien und EFS finden Sie im Microsoft Knowledge Base-Artikel „Information about the storage of data files on an encrypted volume in Exchange Server" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638.

Informationen zum Sichern von Nachrichten in Microsoft Exchange Server 2003 finden Sie im „Handbuch zur Nachrichtensicherheit in Exchange Server 2003" (http://www.microsoft.com/downloads/details.aspx?FamilyID=2305405C-FAF1-488A-A856-AD467BB59B26&DisplayLang=de).


Die Daten aus der SMTP-Mail-Warteschlange werden auf eine Nicht-NTFS-Partition geschrieben.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_Directory ab, um den Wert des Schlüssels FSName für das Exchange SMTP-Warteschlangenverzeichnis zu ermitteln. Wenn Exchange Server Analyzer ermittelt, dass der Wert für den Schlüssel FSName nicht NTFS File System ist, wird ein Fehler angezeigt.

Das Speichern von Exchange-Datendateien auf einem Nicht-NTFS-Datenträger wird von Microsoft nicht unterstützt. Zu den Exchange-Datendateien gehören folgende Dateien:

  • EDB-Dateien

  • STM-Dateien

  • LOG-Dateien

  • DAT-Dateien

  • EML-Dateien

Wenn dieser Fehler auftritt, müssen Sie das SMTP-Warteschlangenverzeichnis in einen Ordner auf einem NTFS-Laufwerk verschieben. Wenn das Laufwerk, auf dem das Warteschlangenverzeichnis gespeichert ist, als FAT-Laufwerk formatiert ist, können Sie zum Konvertieren des Laufwerks in NTFS auch das Befehlszeilentool convert.exe verwenden.

So verschieben Sie die SMTP-Warteschlange in einen anderen Ordner

  1. Öffnen Sie den Exchange-System-Manager.

  2. Klicken Sie auf Administrative Gruppen, erweitern Sie Ihre administrative Gruppe, erweitern Sie Server und Ihren Server, erweitern Sie Protokolle und dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf Ihren virtuellen SMTP-Server, und klicken Sie dann auf Beenden.

  4. Klicken Sie mit der rechten Maustaste auf den virtuellen SMTP-Server, und klicken Sie dann auf Eigenschaften.

  5. Klicken Sie auf der Registerkarte Nachrichten neben dem Feld BADMAIL-Verzeichnis auf Durchsuchen, und geben Sie dann den Pfad für den neuen Speicherort des Warteschlangenordners ein.

  6. Klicken Sie auf OK.

  7. Klicken Sie mit der rechten Maustaste auf Ihren virtuellen SMTP-Server, und klicken Sie dann auf Starten.

Weitere Informationen über das Verschieben des Ordners Mailroot finden Sie im Microsoft Knowledge Base-Artikel 822933 „How to change the Exchange 2003 SMTP Mailroot folder location" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Wenn das Laufwerk, auf dem die Dateien gespeichert sind, als FAT-Laufwerk formatiert ist, können Sie alternativ zu der in diesem Artikel beschriebenen Vorgehensweise auch das Befehlszeilentool convert.exe verwenden, um das Laufwerk in NFTS zu konvertieren. Weitere Informationen zum Konvertieren einer FAT-Partition in eine NTFS-Partition mit dem Befehlszeilentool convert.exe finden Sie im Microsoft Knowledge Base-Artikel 214579 „Konvertieren einer Partition in NTFS mit "Convert.exe"" unter (http://go.microsoft.com/fwlink/?linkid=3052&kbid=214579).


Der SMTP-Wert „MaxDSNSize" wurde manuell festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-01-17

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungsunterschlüssel, um zu ermitteln, ob die maximale Größe von DSN-Nachrichten (Delivery Status Notification - Benachrichtigungen zum Übermittlungsstatus) manuell überschrieben wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MaxDSNSize

Wenn Exchange Server Analyzer erkennt, dass der Wert MaxDSNSize vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Mit dem Registrierungswert MaxDSNSize kann ein Computer unter Exchange 2000 Server Service Pack 2 (SP2) oder höher Anlagen entfernen, wenn eine Nachricht nicht übermittelt werden kann. Durch das Aktivieren dieser Option können Sie Server- und Netzwerkressourcen sparen. Diese Implementierung des Entfernens von SMTP-Anlagen hat allerdings auch Nachteile.

Wenn Sie diese Option zum Entfernen der Anlagen vom NDR (non-delivery report, Unzustellbarkeitsbericht) aktivieren, werden auch die Details entfernt, die zum Anzeigen der Nachricht im Vorschaufenster erforderlich sind, und der Verfasser der Nachricht kann die Option zum erneuten Senden nicht verwenden. Wenn der Verfasser der Nachricht versucht, die Option zum erneuten Senden vom NDR zu verwenden, erhält er die folgende Fehlermeldung:

„Diese Nachricht kann nicht gesendet werden. Der Unzustellbarkeitsbericht enthält nicht genug Information über die ursprüngliche Nachricht. Um die Nachricht erneut zu senden, öffnen Sie diese im Ordner Gesendete Objekte und klicken Sie im Menü Aktionen auf Diese Nachricht erneut senden."

Allerdings kann der Verfasser der Nachricht auch dann nicht senden, wenn er die in der Fehlermeldung angegebene Methode anwendet. Deshalb sollten Sie diese Methode mit Vorsicht verwenden.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So ändern Sie den Registrierungswert „MaxDSNSize"

  1. Öffnen Sie einen Registrierungseditor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. Erstellen Sie einen DWORD-Registrierungswert mit dem Namen MaxDSNSize, und legen Sie seine Wertdaten (in Byte) auf den gewünschten Betrag fest.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie den SMPT-Dienst neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://support.microsoft.com/kb/256986/de).

Weitere Informationen zum Registrierungswert MaxDSNSize finden Sie in den folgenden Knowledge Base-Artikeln:

  • 308303, „XCON: Option to Strip Attachments for Messages That Generate an NDR" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308303).

  • 323484, „XCON: Description of the Multipart/Report Internet Message Format in Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=323484).


Der SMTP-Registrierungswert „MaxPendingCat" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die Standardkonfigurationen für Warteschlangen in SMTP geändert wurden:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel MaxPendingCat festgelegt ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Es wird empfohlen, die Standardwerte für Warteschlangen nur nach gründlicher Überlegung zu ändern. Die Standardwerte wurden mit Bedacht ausgewählt, um eine optimale Leistung in den meisten Umgebungen zu gewährleisten. Im Allgemeinen hat es sich bewährt, die Ursache des Problems zu beheben, anstatt das Warteschlangenverhalten in Exchange zu ändern.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu Exchange-SMTP-Warteschlangen finden Sie im Microsoft Exchange Team-Blogeintrag „Explaining the Mysterious SMTP Advanced Queuing Engine" unter http://go.microsoft.com/fwlink/?LinkId=48585.


SMTP MaxMessageObjects ist zu niedrig festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die maximale Anzahl der Mail-Nachrichten zu ermitteln, die das System zuweisen kann:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\MailMsg\MaxMessageObjects

Wenn Exchange Server Analyzer feststellt, dass der Wert von MaxMessageObjects auf weniger als 30001 festgelegt ist, wird eine Warnung angezeigt.

Wenn die Warteschlange die maximale Anzahl der Nachrichten enthält, akzeptiert SMTP (Simple Mail Transfer Protocol) keine weiteren eingehenden Nachrichten. Jede E-Mail-Nachricht beansprucht in der SMTP-Warteschlange mindestens 4 Kilobyte (KB) Arbeitsspeicher. Daher bei einer sehr großen Warteschlange der Arbeitsspeicher erschöpft werden.

In der Standardeinstellung ist der Wert für MaxMessageObjects nicht vorhanden, und die maximale Anzahl von Nachrichten ist auf 100.000 festgelegt. Wenn MaxMessageObjects auf einen niedrigeren Wert festgelegt wird, sinkt die maximale Anzahl von Nachrichten, die sich in der Warteschlange befinden kann. Damit nimmt der maximale Speicherbedarf für SMTP ab. Nach Erreichen dieses Grenzwertes wird jede mit dem Server hergestellte SMTP-Verbindung wegen unzureichenden Arbeitsspeichers abgelehnt.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie einen Grenzwert für die Anzahl der SMTP-Nachrichten in der Warteschlange fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\Software\Microsoft\Exchange

  3. Klicken Sie mit der rechten Maustaste auf den Schlüssel Exchange. Anschließend klicken Sie auf Neuer Schlüssel. Nennen Sie den neuen Schlüssel MailMsg.

  4. Klicken Sie mit der rechten Maustaste auf den Schlüssel MailMsg. Anschließend klicken Sie auf Neuer DWORD-Wert.

  5. Klicken Sie mit der rechten Maustaste auf den neuen Wert, klicken Sie auf Umbenennen, und geben Sie MaxMessageObjects ein.

  6. Doppelklicken Sie auf den Wert MaxMessageObjects, und legen Sie ihn auf die maximale Anzahl der Nachrichten fest, die sich zur gleichen Zeit in der Warteschlange befinden sollen. Wenn Sie nicht mehr Nachrichten verarbeiten müssen, ist ein Höchstwert von 100.000 empfehlenswert.

  7. Beenden Sie den Registrierungs-Editor, und starten Sie den SMPT-Dienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zum Festlegen von Begrenzungen für Nachrichten in Warteschlangen finden Sie im Microsoft Knowledge Base-Artikel 258748, „How to set a limit on the number of SMTP messages in queues" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=258748.


Der SMTP-Registrierungsparameter „MaxMessageObjects" wurde vom Standardwert in einen anderen Wert geändert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die maximale Anzahl der Mail-Nachrichten zu ermitteln, die das System zuweisen kann:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\MailMsg\MaxMessageObjects

Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs MaxMessageObjects größer als 0 ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Wenn die Warteschlange die maximale Anzahl der Nachrichten enthält, akzeptiert SMTP keine weiteren eingehenden Nachrichten. Jede E-Mail-Nachricht beansprucht in der SMTP-Warteschlange mindestens 4 Kilobyte (KB) Arbeitsspeicher. Daher kann bei einer sehr großen Warteschlange der Arbeitsspeicher erschöpft werden.

In der Standardeinstellung ist der Wert für MaxMessageObjects nicht vorhanden, und die maximale Anzahl von Nachrichten ist auf 100.000 festgelegt. Wenn MaxMessageObjects auf einen niedrigeren Wert festgelegt wird, sinkt die maximale Anzahl von Nachrichten, die sich in der Warteschlange befinden können. Damit nimmt der maximale Speicherbedarf für SMTP ab. Nach Erreichen dieses Grenzwertes wird jede mit dem Server hergestellte SMTP-Verbindung wegen unzureichenden Arbeitsspeichers abgelehnt.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So legen Sie einen Grenzwert für die Anzahl der SMTP-Nachrichten in der Warteschlange fest

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\Software\Microsoft\Exchange

  3. Klicken Sie mit der rechten Maustaste auf den Schlüssel Exchange. Anschließend klicken Sie auf Neuer Schlüssel. Nennen Sie den neuen Schlüssel MailMsg.

  4. Klicken Sie mit der rechten Maustaste auf den Schlüssel MailMsg. Anschließend klicken Sie auf Neuer DWORD-Wert.

  5. Klicken Sie mit der rechten Maustaste auf den neuen Wert, klicken Sie auf Umbenennen, und geben Sie MaxMessageObjects ein.

  6. Doppelklicken Sie auf den Wert MaxMessageObjects, und legen Sie ihn auf die maximale Anzahl der Nachrichten fest, die sich zur gleichen Zeit in der Warteschlange befinden sollen. Wenn Sie nicht mehr Nachrichten verarbeiten müssen, sollten Sie einen Höchstwert von 100000 verwenden.

  7. Schließen Sie den Registrierungs-Editor, und starten Sie den SMTP-Dienst (Simple Mail Transfer Protocol) neu, damit die Änderung wirksam wird.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" (http://support.microsoft.com/kb/256986/de).

Weitere Informationen zum Festlegen von Begrenzungen für Nachrichten in Warteschlangen finden Sie im Microsoft Knowledge Base-Artikel 258748, „How to set a limit on the number of SMTP messages in queues" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=258748.


Der SMTP-Registrierungswert „MaxPercentPoolThreads" wurde manuell festgelegt.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-01-17

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um festzustellen, ob zusätzliche Pool-Threads manuell konfiguriert wurden:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\MaxPercentPoolThreads

Wenn Exchange Server Analyzer feststellt, dass der Wert MaxPercentPoolThreads vorhanden und konfiguriert ist, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

In SMTP gibt es fünf Arbeits-Warteschlangen, die einen Pool von Threads verwenden, die als ATQ-Threads bezeichnet werden. Dabei können in der Standardeinstellung zwei dieser Warteschlangen bis zu 90 Prozent der verfügbaren Threads verwenden. Dieser Thread-Pool ist freigegeben für das Annehmen von POP- und IMAP-Anforderungen. Daher kann in einem Szenario mit mittlerer bis hoher Last eine Situation auftreten, in der SMTP Ressourcen von POP- und IMAP-Diensten beibehalten kann.

Sie können entsprechende Threads für POP und IMAP reservieren, indem Sie den Prozentsatz an Threads, die SMTP verwenden kann, begrenzen. Um diese Änderung vorzunehmen, müssen Sie die Gesamtzahl der für IIS verfügbaren Threads erhöhen. Der einzige Nachteil hierbei besteht in der erhöhten Speicherverwendung für die zusätzlichen Threads.

Es gibt zwei Registrierungswerte, mit denen Sie den SMTP-Prozentsatz an Threads und weiteren Threads pro Prozessor steuern können:

Speicherort: HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

Wert: AdditionalPoolThreadsPerProc

Typ: REG_DWORD

Speicherort: HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

Wert: MaxPercentPoolThreads

Typ: REG_DWORD

Beide Registrierungswerte sollten auf Exchange Server-Computern, die Teil eines Clusters sind, angepasst werden, wenn durch hohe SMTP-Aktivität POP3-Ressourcen, IMAP4-Ressourcen bzw. beide fehlschlagen. Mit den folgenden Formeln können Sie den optimalen Wert für Ihren Cluster berechnen:

Registrierungswert | Formel
AdditionalPoolThreadsPerProc | ((9 / (MaxPercentPoolThreads/100)) - 4) / 2
MaxPercentPoolThreads | 90 / (2 * Anzahl an virtuellen Protokollservern)

In einem Exchange Server-Cluster mit zwei virtuellen Protokollservern lautet die Formel für MaxPercentPoolThreads beispielsweise: 90 / (2*2) = 22. Beim Berechnen des Wertes für MaxPercentPoolThreads sollten Sie das Ergebnis zur nächsten ganzen Zahl abrunden, wenn die Berechnung zu einem Wert mit Dezimalkomma führt. Wenn die Berechnung des Wertes AdditionalPoolThreadsPerProc einen Wert von mehr als 200 ergibt, müssen Sie den berechneten Wert einem weiteren Registrierungswert zuordnen:

Speicherort: HKLM\System\CurrentControlSet\Services\InetInfo\Parameters\

Wert: PoolThreadLimit

Typ: REG_DWORD

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So konfigurieren Sie die optimale Einstellung des Exchange-Clusters

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Erstellen Sie einen DWORD-Registrierungswert mit der Bezeichnung AdditionalPoolThreadsPerProc, und legen Sie dessen Datenwert auf die den obigen Formeln entsprechende Zahl fest.

  4. Erstellen Sie einen DWORD-Registrierungswert mit der Bezeichnung MaxPercentPoolThreads, und legen Sie dessen Datenwert auf die den obigen Formeln entsprechende Zahl fest.

  5. Schließen Sie den Registrierungs-Editor, und starten Sie den IIS-Administratordienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.

Weitere Informationen zu dem in diesem Artikel beschriebenen speziellen Clusterressourcenproblem finden Sie im Knowledge Base-Artikel 281868, „XADM: Virtuelle POP\IMAP4-Server brechen bei hoher Belastung wiederholt zusammen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281868).


Der SMTP-Registrierungswert „MsgHandleAsyncThreshold" wurde manuell hinzugefügt, ist jedoch möglicherweise nicht mehr erforderlich
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-01-17

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob die maximale Anzahl der asynchronen IIS-Dateizugriffsnummern (Internet Information Services) vom Standardwert 1000 in einen anderen Wert geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MsgHandleAsyncThreshold

Wenn Exchange Server Analyzer feststellt, dass der Wert MsgHandleAsyncThreshold vorhanden ist und mit einem anderen Wert konfiguriert wurde, wird eine Warnung angezeigt.

Der Wert MsgHandleAsyncThreshold gibt die maximale Anzahl von Dateizugriffsnummern an, die von IIS verwendet werden können. Dateizugriffsnummern werden zwischengespeichert, um die Leistung zu verbessern, da zwischengespeicherte Dateizugriffsnummern den Server davon abhalten, redundante Eingabe-/Ausgabe- (E/A) und CPU-Zyklen durchzuführen. Sobald der SMTP-Transportstack auf einem Exchange Server-Computer eine Nachricht empfängt, wird diese an das Dateisystem übertragen und von dort zu ihrem Ziel umgeleitet. Um in das Dateisystem zu schreiben, erhält der SMPT-Transportstack eine Dateizugriffsnummer und leitet die Nachricht weiter zu dieser Zugriffsnummer. Jede Dateizugriffsnummer beansprucht ungefähr 2 KB ausgelagerten Poolspeicher. Die Standardanzahl von Dateizugriffsnummern für den IIS-Cache beträgt 800 je 32 MB.

Vor Exchange 2000 Server mit Service Pack 2 (SP2) kam es bei Exchange-Servern, die umfangreiche SMTP-Nachrichtenwarteschlangen (z. B im Durchschnitt 1000 oder mehr Nachrichten) unterstützten, zu Leistungseinschränkungen, da in der Standardeinstellung im SMTP-Dienst maximal 1000 Dateizugriffsnummern möglich waren. Da in der Standardeinstellung für Exchange 200 Server maximal 1000 Dateizugriffsnummern zulässig waren, konnte der SMTP-Dienst nur 1000 Nachrichten gleichzeitig in das Dateisystem schreiben.

Um die Leistung dieser großen Systeme zu verbessern, wurden oft drei Registrierungseinträge gleichzeitig angepasst, um die maximale Anzahl der Dateizugriffsnummern, die vom SMTP-Dienst geöffnet werden konnten, zu erhöhen (sodass mehr Nachrichten verarbeitet werden konnten) und die Anzahl der offenen Dateizugriffsnummern für das installierbare Dateisystem, eine andere Exchange-Komponente, zu verringern. (So wird vermieden, dass nicht ausreichend Arbeitsspeicher zur Verfügung steht, wenn die Warteschlange lang ist). Die Registrierungswerte, die nicht in der Standardeinstellung vorhanden waren und daher manuell hinzugefügt werden mussten, sind unten aufgeführt:

Speicherort: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

Wert: MsgHandleThreshold

Typ: REG_DWORD

Speicherort: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

Wert: MsgHandleAsyncThreshold

Typ: REG_DWORD

Speicherort: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

Wert: FileCacheMaxHandles

Typ: REG_DWORD

Die Einträge MsgHandleThreshold andMsgHandleAsyncThreshold sind normalerweise auf denselben Wert abgestimmt (üblicherweise einen Wert größer als 1000), und der Wert für FileCacheMaxHandles wird üblicherweise von 800 auf 600 verringert.

Dieser Registrierungswert ist in der Standardeinstellung nicht vorhanden, da bei Exchange 2000 Server mit SP2 und höher die zu verwendenden optimalen Werte dynamisch bestimmt werden. Wenn der Exchange-Server Exchange 2000 Server mit Service Pack 1 (SP1) oder früher ausführt, wird als optimale Vorgehensweise empfohlen, auf das aktuelle Service Pack und Rollup-Paket zu aktualisieren. Sobald Sie auf den neuesten Code aktualisiert haben, können Sie die Registrierungseinträge löschen.

Exchange Server 2003 berechnet die entsprechenden Einstellungen für SMTP-Dateizugriffsnummern dynamisch, sodass die Einstellungen nicht mehr benötigt werden. Wenn Sie vom technischen Support von Microsoft keine anderen Anweisungen erhalten haben, müssen Sie deshalb die Einträge aus der Registrierung löschen, bevor Sie Exchange 2000 Server-Computer mit diesen Einstellungen auf Exchange Server 2003 aktualisieren.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. Löschen Sie im rechten Bereich den Wert MsgHandleAsyncThreshold.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie dann den IIS-Administratordienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


Der SMTP-Registrierungswert „MsgHandleThreshold" wurde manuell hinzugefügt, ist jedoch möglicherweise nicht mehr erforderlich
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-09-06

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu ermitteln, ob die maximale Anzahl der IIS-Dateizugriffsnummern (Internet Information Services) vom Standardwert 1000 in einen anderen Wert geändert wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MsgHandleThreshold

Wenn Exchange Server Analyzer feststellt, dass der Wert MsgHandleThreshold vorhanden ist und mit einem anderen Wert konfiguriert wurde, wird eine Meldung angezeigt, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Der Wert MsgHandleThreshold gibt die maximale Anzahl von Dateizugriffsnummern an, die von IIS verwendet werden können. Dateizugriffsnummern werden zwischengespeichert, um die Leistung zu verbessern, da zwischengespeicherte Dateizugiffsnummern den Server davon abhalten, redundante Eingabe-/Ausgabe- (E/A) und CPU-Zyklen durchzuführen. Sobald der SMTP-Transportstack auf einem Exchange Server-Computer eine Nachricht empfängt, wird diese an das Dateisystem übertragen und von dort zu ihrem Ziel weitergeleitet. Um in das Dateisystem zu schreiben, erhält der SMPT-Transportstack eine Dateizugriffsnummer und leitet die Nachricht weiter zu dieser Zugriffsnummer. Jede Zugriffsnummer beansprucht ungefähr 2 KB ausgelagerten Poolspeicher. Die Standardanzahl an IIS-Cachedateizugriffsnummern beträgt 800 je 32 MB.

Vor Exchange 2000 Server mit Service Pack 2 (SP2) kam es bei Exchange-Servern, die umfangreiche SMTP-Nachrichtenwarteschlangen (z. B im Durchschnitt 1000 oder mehr Nachrichten) unterstützten, zu Leistungseinschränkungen, da in der Standardeinstellung im SMTP-Dienst maximal 1000 Dateizugriffsnummern möglich waren. Da in der Standardeinstellung für Exchange 200 Server maximal 1000 Dateizugriffsnummern zulässig waren, konnte der SMTP-Dienst nur 1000 Nachrichten gleichzeitig in das Dateisystem schreiben.

Um die Leistung dieser großen Systeme zu verbessern, wurden oft drei Registrierungseinträge gleichzeitig angepasst, um die maximale Anzahl der Dateihandles, die vom SMTP-Dienst geöffnet werden konnten, zu erhöhen (sodass mehr Nachrichten verarbeitet werden konnten) und die Anzahl der offenen Dateihandles für das installierbare Dateisystem, eine andere Exchange-Komponente, zu verringern (um zu vermeiden, dass nicht ausreichend Arbeitsspeicher zur Verfügung steht, wenn die Warteschlange lang ist). Die Registrierungswerte, die nicht in der Standardeinstellung vorhanden waren und daher manuell hinzugefügt werden mussten, sind unten aufgeführt:

Speicherort: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

Wert: MsgHandleThreshold

Typ: REG_DWORD

Speicherort: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

Wert: MsgHandleAsyncThreshold

Typ: REG_DWORD

Speicherort: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

Wert: FileCacheMaxHandles

Typ: REG_DWORD

Die Einträge MsgHandleThreshold und MsgHandleAsyncThreshold haben normalerweise denselben Wert (üblicherweise einen Wert größer als 1000), und der Wert für FileCacheMaxHandles wird üblicherweise von 800 auf 600 verringert.

Wenn auf dem Server mit Exchange Exchange 2000 Server ausgeführt wird, wird als optimale Vorgehensweise empfohlen, auf das aktuelle Service Pack oder Rollup-Paket zu aktualisieren. Nachdem Sie eine Aktualisierung auf den neuesten Code durchgeführt haben, empfiehlt es sich, den Wert MsgHandleThreshold auf den Standardwert 1000 zu setzen.

Die Standardeinstellung des Werts MsgHandleThreshold für Exchange Server 2003 ist 1000. Diese Einstellungen zum Überschreiben der Registrierung werden daher nicht mehr benötigt. Wenn Sie vom technischen Support von Microsoft keine anderen Anweisungen erhalten haben, müssen Sie deshalb die Einträge aus der Registrierung löschen, bevor Sie Exchange 2000 Server-Computer mit diesen Einstellungen auf Exchange Server 2003 aktualisieren.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.

So beheben Sie diesen Fehler

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. Löschen Sie den Registrierungswert MsgHandleThreshold.

  4. Beenden Sie den Registrierungs-Editor, und starten Sie dann den IIS-Administratordienst neu, damit die Änderung wirksam wird.

Lesen Sie vor dem Bearbeiten der Registrierung den Microsoft Knowledge Base-Artikel 256986 „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986, der weitere Informationen zum Bearbeiten der Registrierung enthält.


SMTP-Pickup-Dateien werden in einen komprimierten Ordner geschrieben.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_Directory ab, um den Wert des Schlüssels Compressed für den SMTP-Ordner (Simple Mail Transfer Protocol) PickUp zu bestimmen. Stellt Exchange Server Analyzer fest, dass der Wert Compressed auf True festgelegt ist, wird eine Warnung angezeigt.

Wenn Nachrichten über den SMTP-Dienst auf dem Exchange-Computer eingehen, werden die Daten als EML-Datei auf die Festplatte geschrieben. In der Standardeinstellung werden diese Dateien im Ordner <Laufwerk>:\Programme\Exchsrvr\Mailroot auf der Partition gespeichert, auf der auch Exchange installiert ist. Wenn für den Ordner, in dem SMTP-PickUp-Daten gespeichert sind, die Dateikomprimierung aktiviert ist, kann die Leistung von Exchange stark beeinträchtigt werden. Aus diesem Grund wird die Komprimierung von Ordnern, in denen SMTP-Pickup-Daten gespeichert werden, nicht unterstützt.

Wenn Sie diese Warnung erhalten, müssen Sie die Komprimerung für den Ordner deaktivieren, in dem die SMPT-Pickup-Daten gespeichert werden, oder Sie müssen die SMPT-Pickup-Daten in einen nicht komprimierten Ordner verschieben.

Das Speichern von Exchange-Datendateien auf einem komprimierten Datenträger wird von Microsoft nicht unterstützt. Wenn Sie Exchange-Datendateien auf einem komprimierten Datenträger speichern, wirkt sich der zusätzliche Overhead entscheidend auf die Leistung von Exchange aus. Zu den Exchange-Datendateien gehören folgende Dateien:

  • EDB-Dateien

  • STM-Dateien

  • LOG-Dateien

  • DAT-Dateien

  • EML-Dateien

  • CHK-Dateien

So deaktivieren Sie die Dateikomprimierung für einen angegebenen Ordner:

  1. Klicken Sie mit der rechten Maustaste auf den Ordner, für den die Dateikomprimierung deaktiviert werden soll, und klicken Sie dann auf Eigenschaften.

  2. Klicken Sie auf der Registerkarte Allgemein auf Erweitert.

  3. Deaktivieren Sie im Dialogfeld Erweiterte Attribute das Kontrollkästchen Inhalt komprimieren, um Speicherplatz zu sparen, und klicken Sie dann auf OK.

Weitere Informationen über das Verschieben des Ordners PickUp finden Sie im Microsoft Knowledge Base-Artikel 822933 „How to change the Exchange 2003 SMTP Mailroot folder location" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).


SMTP-Pickup-Dateien werden in einen verschlüsselten Ordner geschrieben.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die WMI-Klasse (Microsoft Windows® Management Instrumentation) Win32_Directory ab, um den Wert des Schlüssels Encrypted für den SMTP-Ordner (Simple Mail Transfer Protocol) PickUp zu bestimmen. Wenn Exchange Server Analyzer feststellt, dass der Wert Verschlüsselt auf True festgelegt ist, wird eine Warnung angezeigt.

Wenn Nachrichten über den SMTP-Dienst auf dem Exchange-Computer eingehen, werden die Daten als EML-Datei auf die Festplatte geschrieben. In der Standardeinstellung werden diese Dateien im Ordner <drive>:\Program Files\Exchsrvr\Mailroot auf derselben Partition gespeichert, auf der Exchange installiert ist. Wenn auf dem Ordner, auf dem SMTP-PickUp-Daten geschrieben sind, die Dateiverschlüsselung aktiv ist, kann die Exchange-Leistung beträchtlich vermindert werden. Aus diesem Grund wird die Verschlüsselung des Ordners dort nicht unterstützt, wo SMTP-PickUP-Daten gespeichert werden.

Wenn Sie diese Warnung erhalten, müssen Sie die Verschlüsselung in dem Ordner deaktivieren, in dem die SMPT-Daten gespeichert werden, oder Sie müssen die SMPT-Pick-Up-Daten in einen nicht-verschlüsselten Ordner verschieben.

Microsoft unterstützt nicht das Speichern von Exchange-Datendateien auf verschlüsselten Datenträgern in einem Encrypting File Systems (EFS - verschlüsseltes Dateisystem). Wenn Sie Exchange-Datendateien auf einem verschlüsselten Datenträger speichern, wirkt sich der zusätzliche Overhead entscheidend auf die Exchange-Leistung aus. Exchange-Datendateien umfassen folgende Dateien:

  • EDB-Dateien

  • STM-Dateien

  • LOG-Dateien

  • DAT-Dateien

  • EML-Dateien

  • CHK-Dateien

Um die Sicherheit der Exchange-Datendateien zu gewährleisten, empfiehlt es sich, den unbefugten Zugriff auf den Exchange-Computer zu verhindern und Nachrichtendaten mithilfe des S/MIME-Nachrichtenformats zu verschlüsseln.

Um den Fehler zu beheben, muss entweder die Dateiverschlüsselung des PickUP-Ordners deaktiviert werden oder der PickUp-Ordner an einen Ort verschoben werden, an dem die Verschlüsselung nicht deaktiviert ist.

So deaktivieren Sie die Dateiverschlüsselung für den angegebenen Ordner:

  1. Klicken Sie mit der rechten Maustaste auf den Ordner, für den die Verschlüsselung deaktiviert werden soll, und klicken Sie dann auf Eigenschaften.

  2. Klicken Sie auf der Registerkarte Allgemein auf Erweitert.

  3. Deaktivieren Sie im Dialogfeld Erweiterte Attribute das Kontrollkästchen Inhalt verschlüsseln, um Daten zu schützen, und klicken Sie dann auf OK.

Weitere Informationen über das Verschieben des Ordners PickUp finden Sie im Microsoft Knowledge Base-Artikel 822933 „How to change the Exchange 2003 SMTP Mailroot folder location" (http://support.microsoft.com/kb/822933/en-us).

Weitere Informationen über Exchange Server-Datendateien und EFS finden Sie im Knowledge Base-Artikel 834638, „Information about the storage of data files on an encrypted volume in Exchange Server" (http://support.microsoft.com/kb/834638/en-us).

Informationen zum Sichern von Nachrichten in Microsoft Exchange Server 2003 finden Sie im Handbuch zur Nachrichtensicherheit in Exchange Server 2003 unter http://www.microsoft.com/downloads/details.aspx?FamilyID=2305405C-FAF1-488A-A856-AD467BB59B26&DisplayLang=de.


SMTP-Pickup-Dateien werden in eine Nicht-NTFS-Partition geschrieben
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_Directory ab, um den Wert des Schlüssels FSName für das Exchange SMTP-PickUp-Verzeichnis zu ermitteln. Wenn Exchange Server Analyzer feststellt, dass der Wert für den Schlüssel FSName nicht NTFS ist, wird eine Warnung angezeigt.

Das Speichern von Exchange-Datendateien auf einem Nicht-NTFS-Datenträger wird von Microsoft nicht unterstützt. Exchange-Datendateien umfassen folgende Dateien:

  • EDB-Dateien

  • STM-Dateien

  • LOG-Dateien

  • DAT-Dateien

  • EML-Dateien

Wenn diese Warnung angezeigt wird, müssen Sie das SMTP-PickUp-Verzeichnis in einen Ordner auf einem NTFS-Dateisystemlaufwerk verschieben. Wenn das Laufwerk, auf dem das PickUp-Verzeichnis gespeichert ist, als FAT-Laufwerk formatiert ist, können Sie zum Konvertieren des Laufwerks in NTFS auch das Befehlszeilentool convert.exe verwenden.

Weitere Informationen über das Verschieben des Ordners PickUp finden Sie im Microsoft Knowledge Base-Artikel 822933 „How to change the Exchange 2003 SMTP Mailroot folder location" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Wenn das Laufwerk, auf dem die Dateien gespeichert sind, als FAT-Laufwerk formatiert ist, können Sie zum Konvertieren des Laufwerks in NTFS auch das Befehlszeilentool convert.exe verwenden. Weitere Informationen zum Konvertieren einer FAT-Partition in eine NTFS-Partition mit dem Befehlszeilentool convert.exe finden Sie im Microsoft Knowledge Base-Artikel 214579 „Konvertieren einer Partition in NTFS mit "Convert.exe"" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579).


SMTP-Portänderung
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-11

Microsoft® Exchange Server Analyzer liest die folgende Eigenschaft in der IIS-Metabasis (Internetinformationsdienste, IIS), um zu ermitteln, ob deren Wert dem Standardwert 25 entspricht:

LM/SmtpSvc/<virtuelle SMTP-Serverinstanz>/SMTPPORT

Wenn Exchange Server Analyzer feststellt, dass der Wert der Eigenschaft SMTPPORT niedriger als 25 ist, wird eine Warnung ausgegeben.

Die Eigenschaft SMTPPORT stellt den TCP-Port dar, der vom SMTP-Server (Simple Mail Transfer Protocol) auf eingehende Verbindungen überwacht wird. Virtuelle SMTP-Server können so konfiguriert werden, dass sie einen oder mehrere TCP-Ports überwachen. In der Standardeinstellung sind alle virtuellen SMTP-Server so konfiguriert, dass sie den Standard-TCP-Port 25 überwachen. Wenn der SMTP-Überwachungsport abweichend von der Standardeinstellung geändert wurde und der TCP-Port 25 nicht mehr in der Liste der Überwachungsport enthalten ist, kann es zur Störung des Nachrichtenflusses kommen.

Das Ändern des SMTP-Überwachungsports ist nur dann ohne Probleme möglich, wenn auch der Rest Ihrer internen Messaginginfrastruktur entsprechend geändert wird. Im Allgemeinen können jedoch andere Ports für virtuelle SMTP-Server, die Nachrichten direkt aus dem Internet annehmen, nicht verwendet werden, da SMTP-Server im Internet Nachrichten über Port 25 senden.

Hinweis:
Microsoft Exchange Server Analyzer untersucht den Wert für den virtuellen Exchange-SMTP-Protokollserver. Bei diesem virtuellen SMTP-Protokollserver muss es sich nicht unbedingt um den SMTP-Server handeln, der Nachrichten direkt aus dem Internet empfängt. Manche Antivirus- und Anti-Spam-Produkte sind so entwickelt, SMTP-Nachrichten aus dem Internet über Port 25 zu empfangen und sie an einen virtuellen Exchange-SMTP-Server oder einen anderen Port weiterzuleiten. In diesem Szenario ist die Konfiguration mit einem virtuellen Exchange-SMTP-Server, der einen anderen Port als 25 überprüft, zulässig.
So können Sie den Überwachungsport des virtuellen SMTP-Servers anzeigen oder ändern

  1. Erweitern Sie im Exchange-System-Manager die Option Server, dann einen Server mit Exchange, danach Protokolle und anschließend SMTP.

  2. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise Virtueller Standardserver für SMTP), und klicken Sie dann auf Eigenschaften.

  3. Wählen Sie die Registerkarte Allgemein aus, und klicken Sie dann auf Erweitert.

  4. Eine Liste mit IP-Adressen und Ports wird angezeigt.

    • Sie können den vorhandenen Port ändern, indem Sie die IP-Adresse auswählen und auf Bearbeiten klicken. Ändern Sie den Wert im Feld TCP-Anschluss in 25.

    • Um Port 25 als zusätzlichen Überwachungsport hinzuzufügen, klicken Sie auf Hinzufügen, und geben Sie die neue Kombination aus IP-Adresse und Port ein. Wenn Sie eine Verbindungs-, Absender- oder Empfängerfilterung verwenden, stellen Sie sicher, dass die entsprechenden Kontrollkästchen aktiviert sind.

  5. Klicken Sie auf OK, um die Änderungen zu speichern. Klicken Sie dann auf OK, um das Dialogfeld Erweitert zu schließen. Klicken Sie auf OK, um das Dialogfeld Eigenschaften des virtuellen SMTP-Servers zu schließen.

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 266686, "XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163, "XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


Der SMTP-Warteschlangenordner enthält eine Große Zahl von Dateien
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-10-06

Microsoft® Exchange Server Analyzer fragt die IIS-Metabasis (Internet Information Services) ab, um den Wert des Attributs QueueDirectory der einzelnen virtuellen SMTP-Server zu ermitteln.

Exchange Server Analyzer ermittelt dann die Anzahl der Dateien, die sich im Warteschlangenordner für die einzelnen virtuellen SMTP-Server befinden.

Wenn Exchange Server Analyzer feststellt, dass der Warteschlangenordner eines virtuellen SMTP-Servers 50.000 oder mehr Dateien enthält, zeigt Exchange Server Analyzer eine Warnung an.

Wenn Exchange Server Analyzer feststellt, dass der Warteschlangenordner eines virtuellen SMTP-Servers 90.000 oder mehr Dateien enthält, zeigt Exchange Server Analyzer einen Fehler an.

Diese Warnung bzw. dieser Fehler zeigt an, dass eine Anhäufung von Nachrichten vorliegt, die die virtuelle SMTP-Serverinstanz verarbeiten muss. Die Warnung bzw. der Fehler deutet auf ein Leistungsproblem oder auf einen Ausfall auf dem Server hin, weil der Server die eingehenden E-Mail-Nachrichten nicht mehr zeitgerecht übermitteln kann. Durch die folgenden Bedingungen kann diese Verzögerung verursacht werden:

  • Der Active Directory®-Verzeichnisdienst wird nicht schnell abgefragt.

  • Nachrichten werden nicht schnell zur lokalen Übermittlung oder an SMTP übergeben.

So beheben Sie dieses Problem

  • Überprüfen Sie die Nachrichten in der Warteschlange auf ihre Legitimation, um sicherzustellen, dass keine unnormale Belastung des Servers aufgrund von unerwünschten kommerziellen E-Mail-Nachrichten (Unsolicited Commercial E-Mail, UCE), Spam oder Virusangriffen vorliegt.

  • Vergewissern Sie sich, dass der SMTP-Dienst aktiviert ist und ausgeführt wird.

So stellen Sie sicher, dass der SMTP-Dienst gestartet wird

  1. Öffnen Sie das MMC-Snap-In (Microsoft Management Console) Dienste.

  2. Führen Sie im rechten Bereich einen Bildlauf zum Dienst Simple Mail Transfer Protocol (SMTP) aus, und doppelklicken Sie darauf. Das Dialogfeld Eigenschaften von Simple Mail Transfer Protocol (SMTP) wird angezeigt.

  3. Vergewissern Sie sich, dass der Wert im Dropdownmenü Starttyp auf Automatisch festgelegt ist.

  4. Klicken Sie auf Starten, um den Systemaufsichtsdienst zu starten.

  5. Klicken Sie auf OK, um die Änderungen zu speichern und das Dialogfeld Eigenschaften von Simple Mail Transfer Protocol (SMTP) zu schließen.

  6. Schließen Sie das Snap-In Dienste.

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei der Nachrichtenübermittlung und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579)

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Microsoft Knowledge Base-Artikel 821877, "Beschreibung der Felder auf den Registerkarten mit den Eigenschaften für SMTP- und X.400-Warteschlangen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877).

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054).


Der SMTP-Warteschlangenordner und der Abholordner sind identisch
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um sicherzustellen, dass das Verzeichnis, aus dem Nachrichten abgeholt werden, nicht das gleiche Verzeichnis ist, in dem Nachrichten in die Warteschlange für einen bestimmten virtuellen SMTP-Server eingereiht werden. Wenn Exchange Server Analyzer feststellt, dass das Attribut für das Warteschlangenverzeichnis msExchSmtpQueueDirectory und das Attribut für das Abholverzeichnis msExchSmtpPickupDirectory übereinstimmen, zeigt Exchange Server Analyzer einen Fehler an.

Bei diesem Fehler handelt es sich um einen schwerwiegenden Fehler. Wenn das Attribut msExchSmtpQueueDirectory und das Attribut msExchSmtpPickupDirectory auf dasselbe Verzeichnis festgelegt wurden, werden Nachrichten doppelt übermittelt. Sie können diese Attribute mithilfe des ADSI-Bearbeitungs-Snap-Ins (ADSI, Active Directory Service Interfaces) aktualisieren.

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.
So aktualisieren Sie das Attribut für „msExchSmtpPickupDirectory" oder „msExchSmtpQueueDirectory" mithilfe des ADSI-Bearbeitungs-Snap-Ins

  1. Starten Sie das ADSI-Bearbeitungs-Snap-In in den Supporttools von Windows® 2000 oder Windows Server 2003.

  2. Erweitern Sie die folgenden Knoten:

    • Container Konfiguration

    • Konfiguration

    • Dienste

    • Microsoft Exchange

    • Organisationsname

    • Empfängerrichtlinien

    • Name der administrativen Gruppe

    • Server

    • Servername

    • Protokolle

    • SMTP

  3. Klicken Sie mit der rechten Maustaste im Detailbereich auf CN=1 (wobei 1 für den virtuellen Standard-SMTP-Server steht), und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie in der Liste ###Auswählen der anzuzeigenden Eigenschaften auf Beides.

  5. Aktualisieren Sie das Attribut für msExchSmtpPickupDirectory, um den Konflikt mit msExchSmtpQueueDirectory aufzuheben, und klicken Sie anschließend auf Festlegen.

  6. Klicken Sie auf OK, anschließend auf Übernehmen, und schließen Sie dann das ADSI-Bearbeitungs-Snap-In.

  7. Warten Sie mindestens 15 Minuten, bis die Replikation abgeschlossen ist.


SMTP-Warteschlange befindet sich auf dem gleichen Laufwerk wie die Systempartition
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den konfigurierten Wert des Attributs msExchSmtpQueueDirectory zu bestimmen.

Exchange Server Analyzer fragt außerdem die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation -Windows® Management Instrumentation) Win32_Service ab, um den Wert des Schlüssels Started für den SMPT-Dienst (Simple Message Transfer Protocol) zu ermitteln. Der Wert False gibt an, dass der Dienst nicht ausgeführt wird. Der Wert True gibt an, dass der Dienst ausgeführt wird. Darüber hinaus fragt Exchange Server Analyzer die WMI-Klasse Win32_OperatingSystem ab, um den Wert des Schlüssels WindowsDirectory zu ermitteln. Der Wert dieses Schlüssels gibt den Speicherort des Windows-Systemlaufwerks an.

Wenn Exchange Server Analyzer feststellt, dass das Attribut msExchSmtpQueueDirectory mit dem gleichen Pfad wie für das Systemlaufwerk konfiguriert ist, dass der SMTP-Dienst ausgeführt wird und dass Exchange nicht auf Microsoft Windows Small Business Server ausgeführt wird, wird eine Warnung angezeigt.

Das Attribut msExchSmtpQueueDirectory stellt den Pfad für den SMTP-Warteschlangenordner dar, der auch als Mailroot-Ordner bezeichnet wird. Wenn Nachrichten über den SMTP-Dienst auf dem Exchange-Server eingehen, werden die Daten als EML-Datei auf die Festplatte geschrieben. In der Standardeinstellung werden diese Dateien im Ordner <Laufwerk>:\Programme\Exchsrvr\Mailroot auf der Partition gespeichert, auf der auch Exchange installiert ist.

In manchen Szenarios, wenn z. B. ein Bridgeheadserver konfiguriert wird, können Sie die Leistung des Exchange-Servers steigern, wenn Sie das SMTP-Verzeichnis Mailroot direkt auf eine andere Festplatte oder Partition verschieben. Als optimale Vorgehensweise sollte sich der SMTP-Ordner Mailroot nicht auf dem gleichen Laufwerk wie das Windows®-Systemlaufwerk befinden. Stattdessen sollte es sich zum Erreichen optimaler Leistung auf einer schnellen Festplatte oder einem schnellen Festplattenteilsystem befinden.

Der Ordner Mailroot kann im Exchange-System-Manager zwar auf einen virtuellen SMTP-Server unter Exchange Server 2003 verschoben werden, zum Verschieben auf einen virtuellen SMTP-Server unter Exchange Server 2000 ist allerdings ein allgemeiner Active Directory-Editor erforderlich, z. B. die ADSI-Bearbeitung (Active Directory Service Interfaces).

Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

So beheben Sie den Fehler auf Exchange Server 2003

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie nacheinander Server, einen Exchange-Server, Protokolle und dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise den virtuellen Standardserver für SMTP), und klicken Sie dann auf Beenden.

  4. Klicken Sie mit der rechten Maustaste erneut auf den virtuellen SMTP-Server, und klicken Sie dann auf Eigenschaften.

  5. Klicken Sie auf die Registerkarte Nachrichten.

  6. Geben Sie im Feld Warteschlangenverzeichnis den vollständigen Pfad des entsprechenden Ordners Mailroot an. Sie können auf Durchsuchen klicken, um den Pfad auf dem lokalen Computer zu suchen.

  7. Klicken Sie auf OK, um die Änderungen zu speichern.

  8. Klicken Sie mit der rechten Maustaste auf Ihren virtuellen SMTP-Server, und klicken Sie dann auf Starten. Der neue Speicherort wird sofort verwendet.

So beheben Sie diesen Fehler unter Exchange 2000 Server

  1. Beenden Sie auf dem Exchange 2000 Server-Computer, dessen Ordner Mailroot des virtuellen SMTP-Servers Sie ändern möchten, alle Exchange Server- und IIS-Dienste.

  2. Ändern Sie den Wert für msExchSmtpQueueDirectory des betroffenen virtuellen SMTP-Servers so, dass er mit dem entsprechenden Pfad konfiguriert ist.

  3. Warten Sie darauf, dass Active Directory diese Änderung auf die globalen Katalogserver repliziert, die von diesem Exchange-Server verwendet werden.

  4. Starten Sie den Dienst Microsoft Exchange-Systemaufsicht.

  5. Überprüfen Sie den Exchange Server-Computer darauf, ob im Ereignisprotokoll der Anwendung drei Instanzen der Ereignis-ID 1005 vorhanden sind, die über eine Ereignisquelle von MSExchangeMU und eine Kategorie von General verfügen.

  6. Starten Sie den Exchange Server-Computer neu, damit die Änderungen wirksam werden.

Weitere Informationen zu beiden beschriebenen Vorgängen finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 822933, „How to change the Exchange 2003 SMTP Mailroot folder location" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=822933.

  • 318230, „XCON: How to Change the Exchange 2000 SMTP Mailroot Directory Location" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=318230.

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Knowledge Base-Artikeln:

  • 266686, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" ( http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686 ).

  • 268163, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


Der SMTP-Registrierungswert „ResetMessageStatus" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die Standardkonfigurationen für Warteschlangen in SMTP geändert wurden:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing

Microsoft Exchange Server Analyzer zeigt einen Fehler an, wenn die folgenden Bedingungen erfüllt sind:

  • Der ResetMessageStatus Schlüssel ist nicht auf 0 (null) festgelegt.

  • Der Clusterdienst wird nicht vom Exchange Server ausgeführt.

Wenn der ResetMessageStatus Registrierungsschlüssel auf 1 festgelegt ist, werden alle aktuellen Nachrichten, die derzeit in der Warteschlange gespeichert sind, nochmals durch die interne Verarbeitungsschlangen gesendet, sobald der Exchange Server neu gestartet wird. Alle Nachrichten, die derzeit in der Warteschlange sind, werden beispielsweise erneut durch das Kategorisierungsmodul gesendet, sobald der Exchange Server neu gestartet wird. Daher sollte der Registrierungsschlüssel ResetMessageStatus nur auf 1 festgelegt werden, um SMTP-Installationsprobleme zu bearbeiten, wie dokumentiert im Microsoft Knowledge Base Artikel 279616, „XCON: Adding a Registry Key to Re-Categorize Messages" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=279616). Wenn Sie keine SMTP-Installationsprobleme bearbeiten, sollten SIe diesen Registrierungsschlüssel löschen.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So löschen Sie den Registrierungsschlüssel „ResetMessageStatus"

  1. Öffnen Sie einen Registrierungs-Editor (z. B. Regedit.exe oder Regedt32.exe).

  2. Navigieren Sie zu: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. Suchen Sie im rechten Bereich den Wert ResetMessageStatus, und löschen Sie ihn.

  4. Schließen Sie den Registrierungs-Editor.

Machen Sie sich vor dem Bearbeiten der Registrierung mit den entsprechenden Vorgängen vertraut. Lesen Sie dazu den Microsoft Knowledge Base-Artikel 256986, „Beschreibung der Microsoft Windows-Registrierung" unter http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Weitere Informationen zu Exchange-SMTP-Warteschlangen finden Sie im Microsoft Exchange Team-Blogeintrag „Explaining the Mysterious SMTP Advanced Queuing Engine" unter http://go.microsoft.com/fwlink/?LinkId=48585.


The SMTP ResetRoutesRetryMinutes registry value is non-default
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die Standardkonfigurationen für Warteschlangen in SMTP geändert wurden:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel ResetRoutesRetryMinutes festgelegt ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Es wird empfohlen, die Standardwerte für Warteschlangen nur nach gründlicher Überlegung zu ändern. Die Standardwerte wurden mit Bedacht ausgewählt, um eine optimale Leistung in den meisten Umgebungen zu gewährleisten. Im Allgemeinen hat es sich bewährt, die Ursache des Problems zu beheben, anstatt das Warteschlangenverhalten in Exchange Server zu ändern.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu Exchange-SMTP-Warteschlangen finden Sie im Microsoft Exchange Team-Blogeintrag „Explaining the Mysterious SMTP Advanced Queuing Engine" unter http://go.microsoft.com/fwlink/?LinkId=48585.


Der SMTP-Registrierungswert „RoutingRetryMinutes" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die Standardkonfigurationen für Warteschlangen in SMTP geändert wurden:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel RoutingRetryMinutes festgelegt ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Es wird empfohlen, die Standardwerte für Warteschlangen nur nach gründlicher Überlegung zu ändern. Die Standardwerte wurden mit Bedacht ausgewählt, um eine optimale Leistung in den meisten Umgebungen zu gewährleisten. Im Allgemeinen hat es sich bewährt, die Ursache des Problems zu beheben, anstatt das Warteschlangenverhalten in Exchange Server zu ändern.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu Exchange-SMTP-Warteschlangen finden Sie im Microsoft Exchange Team-Blogeintrag „Explaining the Mysterious SMTP Advanced Queuing Engine" unter http://go.microsoft.com/fwlink/?LinkId=48585.


Der SMTP-Registrierungswert „LocalDeliveryMaxBatch" weicht vom Standardwert ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um die Einstellung für den Registrierungswert SecondsPerDSNPass zu ermitteln:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel SecondsPerDSNPass vorhanden und auf 10 festgelegt ist, zeigt Microsoft Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Anhand dieser Einstellung werden die Benachrichtigungen zum Übermittlungsstatus (DSN - Delivery Status Notifications) optimiert. Zudem wird die Anzahl von Sekunden angegeben, die zur Übermittlung der DSN-Verarbeitung benötigt wurden. Sobald dieser Schwellenwert überschritten ist, wird die DSN-Generierung angehalten und später erneut gestartet. Es wird empfohlen, die Standardwerte erst nach gründlicher Überlegung zu ändern. Diese spezifische Einstellung sollte nur nach Rücksprache mit dem technischen Kundendienst von Microsoft geändert werden. Die Standardwerte wurden mit Bedacht ausgewählt, um eine optimale Leistung in den meisten Umgebungen zu gewährleisten. Im Allgemeinen hat es sich bewährt, die Ursache des Problems zu beheben, anstatt das Warteschlangenverhalten in Exchange Server zu ändern.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich.


NTLM-Authentifizierung für SMTP-Server ist deaktiviert.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-11-10

Microsoft® Exchange Server Analyzer Tool fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob das Bit für das NTLM-Authentifizierungsprotokoll (ebenfalls bekannt als Integrierte Windows-Authentifizierung) im Attribut msExchAuthenticationFlags festgelegt ist. Wenn Microsoft Exchange Server Analyzer feststellt, dass das Bit nicht festgelegt ist und dass Exchange nicht auf dem Microsoft Windows® Small Business Server ausgeführt wird, wird eine Warnung angezeigt.

Das Attribut msExchAuthenticationFlags gibt an, welcher Typ von Authentifizierungsprotokoll von einem virtuellen Server akzeptiert wird. Dieses Attribut verwendet eine Drei-Bit-Maske.

Bit | Authentifizierungsmethode
0 | Anonym
1 | Standard
2 | NTLM (Integrierte Windows-Authentifizierung)

Wenn das Bit, das die NTLM-Authentifizierung steuert, nicht festgelegt ist, lässt der virtuelle SMTP-Server die NTLM-Authentifizierung nicht zu. Dies kann zu Authentifizierungsproblemen zwischen Exchange Server-Computern führen.

So beheben Sie diese Warnmeldung

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Server, erweitern Sie den Servernamen, erweitern Sie Protokolle, und erweitern Sie dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf den virtuellen Exchange-SMTP-Server, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf die Registerkarte Zugriff, klicken Sie auf Authentifizierung, und wählen Sie dann das Kontrollkästchen Integrierte Windows-Authentifizierung durch Mausklick aus.

  5. Klicken Sie auf OK, und klicken Sie anschließend erneut auf OK.

  6. Schließen Sie den Exchange-System-Manager.

Weitere Informationen über Authentifizierungsmethoden für SMTP finden Sie im Transport- und Routing-Handbuch für Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579) sowie im Microsoft Knowledge Base-Artikel 319267, „GEWUSST WIE: Sichern der Client-Nachrichtenübertragung über SMTP in Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319267).


Der SMTP-Registrierungswert „SubmissionRetryMinutes" weicht vom Standard ab
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Microsoft Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob die Standardkonfigurationen für Warteschlangen in SMTP geändert wurden:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Wenn Exchange Server Analyzer feststellt, dass der Schlüssel SubmissionRetryMinutes festgelegt ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Es wird empfohlen, die Standardwerte für Warteschlangen nur nach gründlicher Überlegung zu ändern. Die Standardwerte wurden mit Bedacht ausgewählt, um eine optimale Leistung in den meisten Umgebungen zu gewährleisten. Im Allgemeinen hat es sich bewährt, die Ursache des Problems zu beheben, anstatt das Warteschlangenverhalten in Exchange zu ändern.

Microsoft Exchange Server Analyzer meldet diese Konfiguration nur zu Informationszwecken. Es ist keine Aktion erforderlich.

Weitere Informationen zu Exchange-SMTP-Warteschlangen finden Sie im Microsoft Exchange Team-Blogeintrag „Explaining the Mysterious SMTP Advanced Queuing Engine" unter http://go.microsoft.com/fwlink/?LinkId=48585.


Die maximale Nachrichtengröße des virtuellen SMTP-Servers ist höher als der globale Grenzwert für die Nachrichtengröße.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um den Höchstwert für die Größe eingehender Nachrichten des virtuellen SMTP-Servers mit dem globalen Höchstwert für die Größe eingehender Nachrichten zu vergleichen.

Das Active Directory-Attribut, das den Höchstwert für die Größe eingehender oder ausgehender Nachrichten des virtuellen SMTP-Servers darstellt, ist msExchSmtpMaxMessageSize. Dieser Wert ist ein Attribut des virtuellen SMTP-Serverobjekts in Active Directory und befindet sich unter:

CN=<Nummer des virtuellen Servers>, CN=SMTP, CN=Protocols, CN=<Servername>, CN=Servers, CN=<Name der administrativen Gruppe>, CN=Administrative Groups, CN=<Name der Organisation>, CN=Microsoft Exchange, CN=Services, CN=Configuration, DC=<Domänenname>, DC=com

Das Active Directory-Attribut, das den globalen Höchstwert für eingehende Nachrichten darstellt ist delivContLength. Dieser Wert ist ein Attribut des Nachrichtenübermittlungsobjekts der globalen Einstellungen der Organisation in Active Directory und befindet sich unter:

CN=Message Delivery, CN=Global Settings, CN=<Name der Organisation>, CN=Microsoft Exchange, CN=Services, CN=Configuration, DC=<Domänenname>, DC=com

Wenn Exchange Server Analyzer feststellt, dass der Wert für msExchSmtpMaxMessageSize größer ist als der Wert für delivContLength, wird eine Warnung angezeigt.

Wenn ein beliebiger virtueller SMTP-Server über einen höheren Höchstwert für die Nachrichtengröße als den globalen Höchstwert für die Nachrichtengröße verfügt, könnte es passieren, dass übergroße Nachrichten angenommen, aber dann nicht weitergeleitet werden.. Konfigurieren Sie zum Lösen dieses Problems den virtuellen Server mit einem Höchstwert für die Nachrichtengröße, der kleiner oder gleich dem globalen Höchstwert für die Größe eingehender Nachrichten ist.

Hinweis:
Wenn die Beschränkung für die Nachrichtengröße zu niedrig festgelegt wird, kann die Replikation von Offlineadressbüchern zwischen Exchange Server-Computern verhindert werden. Weitere Informationen zu diesem Problem finden Sie im Microsoft Knowledge Base-Artikel 326154 „XADM: The OAB Does Not Replicate If You Set a Message Size Restriction at the Transport Level" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154).

So beheben Sie dieses Problem

  1. Erweitern Sie im Exchange-System-Manager die Option Server, erweitern Sie einen Exchange-Server, erweitern Sie dann Protokolle, und erweitern Sie anschließend SMTP.

  2. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise Virtueller Standardserver für SMTP), und wählen Sie dann Eigenschaften aus.

  3. Wählen Sie die Registerkarte Nachrichten.

  4. Bearbeiten Sie den Wert für das Feld Nachrichtengröße beschränken auf (KB): so, dass dieser kleiner oder gleich dem globalen Höchstwert für die Nachrichtengröße ist.

  5. Klicken Sie auf OK, um die Änderungen zu speichern und das Dialogfeld Eigenschaften des virtuellen SMTP-Servers zu schließen.

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Knowledge Base-Artikeln:

  • 266686, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://support.microsoft.com/?kbid=266686)

  • 268163, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://support.microsoft.com/?kbid=268163)

Weitere Informationen zum Anzeigen und Bearbeiten organisationsweiter Einstellungen finden Sie im Knowledge Base-Artikel 821881, „How to Modify Global Settings in Exchange System Manager" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821881).

Weitere Informationen zu globalen Höchstwerten für die Nachrichtengröße finden Sie in den folgenden Knowledge Base-Artikeln:

  • 298572, „An E-Mail Message That Is Larger Than the Sending Message Size Limit or the Receiving Message Size Limit Is Not Delivered" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298572).

  • 322679, „Set Size Limits for Messages" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679).

  • 824111, „Änderungen der Sicherheitseinstellungen und Aktualisierungen in Exchange Server 2003" (http://support.microsoft.com/?kbid=824111).


Dieser virtuelle SMTP-Server ist so konfiguriert, dass er die umgekehrte DNS-Suche für eingehende Nachrichten durchführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-24

Microsoft® Exchange Server Analyzer stellt eine Abfrage an den Active Directory®-Verzeichnisdienst, um zu ermitteln, ob der Wert des Attributs msExchSmtpPerformReverseDnsLookup auf einen Wert festgelegt wurde, der vom Standardwert False abweicht. In der Standardeinstellung ist das Attribut msExchSmtpPerformReverseDnsLookup so konfiguriert, dass die umgekehrte DNS-Suche für eingehende Nachrichten nicht ausgeführt wird. Wenn Exchange Server Analyzer feststellt, dass dieses Attribut auf True festgelegt ist, wird eine Warnung angezeigt.

Die Option Umgekehrte DNS-Suche für eingehende Nachrichten ausführen kann den Erhalt von Spam-E-Mails nicht verhindern. Wenn diese vorhergehende Option verwendet wird, führt Exchange Server eine DNS-Abfrage durch, um die Absender-IP-Adresse der eingehenden Nachrichten in einen Hostnamen aufzulösen. Der Hostname wird dann den Headern der E-Mail-Nachrichten hinzugefügt.

Wenn dieses Feature aktiviert ist, macht sich u. U. ein Leistungsabfall wegen falsch konfigurierter DNS-Einträge oder wegen intermittierender Verbindungen zum Internet bemerkbar. Daher sollten Sie diese Option ggf. deaktivieren, wenn die E-Mail-Übermittlung über das Internet langsamer als erwartet erfolgt.

So aktivieren oder deaktivieren Sie die umgekehrte DNS-Suche für eingehende SMTP-Nachrichten

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Server, erweitern Sie einen Exchange-Server, erweitern Sie Protokolle, und erweitern Sie dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise Virtueller Standardserver für SMTP), und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie auf der Registerkarte Übermittlung auf Erweitert.

    • Um die umgekehrte DNS-Suche zu aktivieren, aktivieren Sie das Kontrollkästchen Reverse-DNS-Lookup an eingehenden Nachrichten durchführen.

    • Um die umgekehrte DNS-Suche zu deaktivieren, müssen Sie das Kontrollkästchen Reverse-DNS-Lookup an eingehenden Nachrichten durchführen deaktivieren.

  5. Klicken Sie auf OK, um die Änderungen zu speichern. Klicken Sie dann auf OK, um das Dialogfeld SMTP virtual server Properties zu schließen.

Weitere Informationen zur umgekehrten DNS-Suche in Exchange finden Sie im Microsoft Knowledge Base-Artikel 297412, „The 'Perform Reverse DNS Lookup for Incoming Messages' Option Is for Host Name Resolution" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Knowledge Base-Artikeln:

  • 266686, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


Service Pack 1-Version des Intelligenten Nachrichtenfilters aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob der Intelligente Nachrichtenfilter von Microsoft® Exchange auf dem Server installiert und aktiviert ist:

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

Exchange Server Analyzer liest den Wert ContentFilterBindings im Registrierungsschlüssel ContentFilter, um zu bestimmen, ob der Intelligente Nachrichtenfilter auf dem Server installiert und aktiviert ist.

Microsoft® Exchange Server Analyzer fragt anschließend die Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation - Windows® Management Instrumentation) CIM_Datafile ab, um zu bestimmen, ob die Exchange Server 2003 Service Pack 1 (SP1)-Version des Intelligenten Nachrichtenfilters MSExchange.UceContentFilter.dll im folgenden Pfad auf dem Server mit Exchange vorhanden ist:

<Pfad zu den Binärdateien auf dem Server mit Exchange>\MSCFv1\MSExchange.UceContentFilter.dll

Hinweis:
In diesem Pfad bezieht sich <Pfad zu den Binärdateien auf dem Server mit Exchange> auf den Speicherort des Ordners Bin.

Wenn die Exchange Server 2003 SP1-Version des Intelligenten Nachrichtenfilters auf dem Server installiert und aktiviert ist, zeigt Exchange Server Analyzer eine Warnung an.

Diese Warnung bedeutet, dass eine aktuellere Version des Intelligenten Nachrichtenfilters verfügbar ist. Es wird empfohlen, die neueste Version des Intelligenten Nachrichtenfilters zu installieren. Beim Behandeln von Problemen mit dem Nachrichtenfluss eines bestimmten Servers müssen Sie ggf. den Intelligenten Nachrichtenfilter vorübergehend deaktivieren, um zu ermitteln, ob dieser fälschlicherweise erwünschte E-Mail blockiert.

So deaktivieren Sie den Intelligenten Nachrichtenfilter

  1. Klicken Sie auf Start, zeigen Sie auf Alle Programme, zeigen Sie auf Microsoft Exchange, und klicken Sie dann auf System-Manager.

  2. Im Exchange-System-Manager, erweitern Sie Server, erweitern Sie Servername, erweitern Sie Protokolle, erweitern Sie SMTP, klicken Sie mit der rechten Maustaste auf Intelligente Nachrichtenfilterung, und klicken Sie dann auf Eigenschaften.

  3. Deaktivieren Sie auf der Registerkarte Allgemein unter Intelligenten Nachrichtenfilter auf die IP-Adressen der folgenden virtuellen Server anwenden das Kontrollkästchen neben jedem virtuellen SMTP-Server, auf dem Sie den Intelligenten Nachrichtenfilter deaktivieren möchten.

    Das Dialogfeld „Eigenschaften" des Intelligenten Nachrichtenfilters

Weitere Informationen finden Sie auf der Website zum Intelligenten Nachrichtenfilter von Exchange (http://go.microsoft.com/fwlink/?LinkId=21607).


Service Pack 2-Version des Intelligenten Nachrichtenfilters aktiviert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-04

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu bestimmen, ob die Eigenschaft msExchServerBindingsFiltering eines virtuellen SMTP-Serverobjekts (Simple Mail Transfer Protocol) angibt, dass der Intelligente Nachrichtenfilter für eine virtuelle SMTP-Serverinstanz aktiviert ist.

Exchange Server Analyzer fragt Active Directory auch ab, um zu ermitteln, ob msExchUceEnabled auf der Ebene der globalen Einstellungen aktiviert ist.

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Der Intelligente Nachrichtenfilter ist für eine virtuelle SMTP-Serverinstanz aktiviert.

  • Der Intelligente Nachrichtenfilter ist auf der Ebene der globalen Einstellungen aktiviert.

Diese Warnung bedeutet, dass die Version des Intelligenten Nachrichtenfilters in Exchange Server 2003 Service Pack 2 (SP2) aktiviert ist. Dass die SP2-Version des Intelligenten Nachrichtenfilters aktiviert ist, stellt im Allgemeinen kein Problem dar, es sei denn, Sie beheben Nachrichtenflussprobleme eines bestimmten Servers. Ist dies der Fall, müssen Sie ggf. die Filterkonfiguration überprüfen oder den Intelligenten Nachrichtenfilter vorübergehend deaktivieren, um zu ermitteln, ob dieser fälschlicherweise erwünschte E-Mail blockiert.

So deaktivieren Sie den Intelligenten Nachrichtenfilter

  1. Klicken Sie auf Start, zeigen Sie auf Alle Programme, zeigen Sie auf Microsoft Exchange, und klicken Sie dann auf System-Manager.

  2. Erweitern Sie im Exchange-System-Manager Server, dann Servername, anschließend Protokolle und schließlich SMTP.

  3. Klicken Sie im Dialogfeld Eigenschaften des virtuellen SMTP-Servers auf der Registerkarte Allgemein auf Erweitert.

  4. Wählen Sie die IP-Adresse aus, für die Sie den Intelligenten Nachrichtenfilter deaktivieren möchten, und klicken Sie auf Bearbeiten.

  5. Deaktivieren Sie in Identifikation die Option Intelligenten Nachrichtenfilter auf die IP-Adressen der folgenden virtuellen Server anwenden.

  6. Sind mehrere virtuelle Server vorhanden, wiederholen Sie die Schritte 3 bis 6 für jeden virtuellen Server, auf dem Sie den Intelligenten Nachrichtenfilter deaktivieren möchten.

Weitere Informationen finden Sie auf der Website zum Intelligenten Nachrichtenfilter von Exchange (http://go.microsoft.com/fwlink/?LinkId=21607).


Der angegebene Gatewayserver wurde nicht verwendet
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-09

Microsoft® Exchange Server Analyzer sendet eine Testnachricht von dem Server mit Exchange an ein benutzerdefiniertes externes Konto und durchsucht anschließend die Nachrichtenverfolgungsprotokolle des Servers, um zu ermitteln, ob bei der Übermittlung der Testnachricht Probleme aufgetreten sind.

Im Rahmen dieser Untersuchung prüft Exchange Server Analyzer, ob es sich bei dem Exchange-Gatewayserver, über den die Nachricht an den externen Empfänger weitergeleitet wird, um denselben Server handelt, der in dem Schritt, in dem der Servername und die Anmeldeinformationen eingerichtet wurden, auf der Seite Server- und Benutzerinformationen eingeben angegeben wurde.

Wenn Exchange Server Analyzer feststellt, dass die Nachricht erfolgreich nach außerhalb der Exchange-Organisation geroutet wurde, wobei der angegebene Gatewayserver jedoch nicht verwendet wurde, zeigt Exchange Server Analyzer eine Warnung an.

Diese Warnung gibt an, dass möglicherweise ein Problem mit der Exchange-Routingtopologie vorliegt und dass unbekannte ausgehende Gatewayserver vorhanden sind.

Routingprobleme können dann auftreten, wenn Smarthosteinträge auf der Ebene des virtuellen Servers statt auf der Connectorebene festgelegt wurden. Bewährt hat sich die Festlegung von Smarthosteinträgen auf dem SMTP-Connector und nicht auf dem virtuellen SMTP-Server.

Um diese Warnung zu beheben, führen Sie die folgenden Schritte aus:

  • Überprüfen Sie die Konfiguration des virtuellen SMTP-Servers (Simple Mail Transfer Protocol). um sicherzustellen, dass keine Smarthosteinträge festgelegt sind.

  • Überprüfen Sie die Konfiguration der lokalen Bridgeheadserver auf korrekte Adressräume und Kosten der Connectors.

So zeigen Sie Smarthosteinstellungen an und konfigurieren diese

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Server, erweitern Sie einen Exchange-Server, erweitern Sie Protokolle, und erweitern Sie dann SMTP.

  3. Klicken Sie mit der rechten Maustaste auf einen virtuellen SMTP-Server (beispielsweise Virtueller Standardserver für SMTP), und wählen Sie dann Eigenschaften aus.

  4. Wählen Sie die Registerkarte Übermittlung aus, und klicken Sie auf Erweitert.

  5. Löschen Sie alle Einträge unter Smarthost.

  6. Klicken Sie auf OK, um die Änderungen zu speichern, und klicken Sie dann auf OK, um das Dialogfeld Eigenschaften des virtuellen SMTP-Servers zu schließen.

Weitere Informationen zum Konfigurieren der SMTP-Connectors finden Sie im Microsoft Knowledge Base-Artikel 822941, "Verwenden von SMTP-Connectors zum Verbinden von Routinggruppen in Exchange 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822941).

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)


Der angegebene Absender befindet sich auf einem anderen Server
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-08-10

Microsoft® Exchange Server Analyzer fragt im Active Directory®-Verzeichnisdienst den Wert des Attributs proxyAddress für alle Benutzerobjekte ab, um zu ermitteln, ob eine Übereinstimmung mit der vom Benutzer angegebenen SMTP-Adresse (Simple Mail Transfer Protocol) des lokalen Absenders vorhanden ist.

Wenn für das Benutzerobjekt proxyAddress eine Übereinstimmung gefunden wurde, fragt Exchange Server Analyzer danach in Active Directory den Wert des Attributs msExchHomeServerName des Benutzerobjekts ab, um zu ermitteln, ob dieser Wert mit dem vom Benutzer angegebenen Exchange Server-Namen übereinstimmt.

Wenn Exchange Server Analyzer feststellt, dass der Wert des Attributs msExchHomeServerName für den vom Benutzer angegebenen Absender keine Übereinstimmung mit dem vom Benutzer angegebenen Exchange Server-Namen aufweist, zeigt Exchange Server Analyzer eine Warnung an.

Diese Warnung weist darauf in, dass entweder ein falscher Exchange Server-Name angegebene wurde oder dass das Problem mit der Nachrichtenübermittlung einen anderen Server betrifft, als den vom Benutzer angegebenen.

Um dieses Problem zu beheben, müssen Sie prüfen, ob der korrekte Exchange Server-Name eingegeben wurde.

So zeigen Sie die Benutzerpostfächer auf dem angegebenen Server an

  1. Starten Sie den Exchange-System-Manager:

    Klicken Sie auf Start, zeigen Sie auf Programme, zeigen Sie auf Microsoft Exchange, und klicken Sie dann auf System-Manager.

  2. Navigieren Sie im Exchange-System-Manager zu folgendem Container, und klicken Sie dann darauf:

    \Administrative Groups\ GroupName \Servers\ ServerName \ StorageGroupName \Mailbox Store\Mailboxes

  3. Überprüfen Sie, ob das angegebene Postfach auf dem angegebenen Exchange-Server angezeigt wird.


Zielserver konnten nicht identifiziert werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-07-06

Microsoft® Exchange Server Analyzer versucht, die vollqualifizierten Domänennamen (Fully Qualified Domain Name, FQDN), IP-Adressen und Domänennamen von Remoteservern, für die Nachrichten in einer Remoteübermittlungswarteschlange bestimmt sind, zu ermitteln und eine entsprechende Liste zu erstellen.

Die Liste der FQDNs, IP-Adressen und Domänennamen von Remoteservern wird folgendermaßen erstellt:

  • Die msExchSmtpFullyQualifiedDomainName-Eigenschaft des Active Directory®-Verzeichnisdienstobjekts für den virtuellen SMTP-Server (Simple Mail Transfer Protocol) wird angefragt.

    Hinweis:
    Die msExchSmtpFullyQualifiedDomainName-Eigenschaft wiederum wird aus der msExchTargetBridgeheadServersDN-Eigenschaft eines Verzeichnisobjekts für Routinggruppenconnectors gelesen, wenn das Objekt nach den angegebenen Bridgeheadzielservern abgefragt wird.
  • Die msExchSmtpSmartHost-Eigenschaft des Active Directory-Objekts für SMTP-Connectors wird nach dem angegebenen Smarthost für einen SMTP-Connector abgefragt.

  • Die LinkName-Eigenschaft der Microsoft WMI-Klasse (Windows®-Verwaltungsinstrumentation, Windows® Management Instrumentation) ExchangeLink nach direkten Verbindungen zu Remoteservern ab.

Wenn Exchange Server Analyzer beim Erstellen der Liste keine Einträge findet, wird ein Fehler angezeigt.

Diese Fehler weist auf folgende Probleme hin:

  • Es gibt vorübergehende Netzwerk- oder Active Directory-Verbindungsprobleme, die Nachrichtenflussprobleme verursachen.

  • Das Konto, unter dem Exchange Server Analyzer ausgeführt wird, verfügt u. U. nicht über die erforderlichen Berechtigungen, um die Informationen abzufragen.

So beheben Sie diesen Fehler

  1. Stellen Sie sicher, dass der Exchange Server-Computer gestartet wurde und mit dem Netzwerk verbunden ist.

  2. Stellen Sie sicher, dass Sie über das Netzwerk mit einem Active Directory-Domänencontroller verbunden sind.

  3. Bestimmen Sie in Exchange Server Analyzer einen Active Directory-Domänencontroller.

  4. Verwenden Sie den Befehl PING, um festzustellen, ob eine Verbindung mit dem Exchange Server-Computer hergestellt werden kann.

  5. Wenn ein Firewall vorhanden ist, überprüfen Sie, ob die RPC-Anschlüsse blockiert sind.

  6. Überprüfen Sie die Berechtigungen für das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird. Das Konto, unter dem Microsoft Exchange Server Analyzer ausgeführt wird, muss über lokale Administratorberechtigungen für jeden durchsuchten Exchange-Server-Computer verfügen.

Weitere Informationen zu Problemen mit Netzwerkverbindungen finden Sie im Microsoft Knowledge Base-Artikel 325487, "Behandlung von Problemen mit der Netzwerkverbindung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Weitere Informationen zu Verbindungsproblemen bei Exchange Server Analyzer finden Sie unter "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" (http://go.microsoft.com/fwlink/?LinkId=56285).

Weitere Informationen zu den Anforderungen hinsichtlich der Anschlüsse finden Sie im Knowledge Base-Artikel 832017, "Dienste und Netzwerk-Port-Anforderungen für das Microsoft Windows-Serversystem" (http://support.microsoft.com/?kbid=832017).


„TarpitTime" wurde implementiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-02-21

Microsoft® Exchange Server Analyzer liest den folgenden Registrierungseintrag, um zu bestimmen, ob das Tar Pit-Feature für die Empfängerfilterung festgelegt wurde:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\TarpitTime

Wenn Exchange Server Analyzer feststellt, dass der Wert von TarpitTime größer als 0 (null) ist, zeigt Exchange Server Analyzer eine Meldung an, dass der Wert nicht dem Standard entspricht.

Tar Pitting ist ein technisches Verfahren zum absichtlichen Verlangsamen oder Verzögern von nicht erlaubten Verbindungen, um die Rate zu verringern, mit der automatisch Spam gesendet werden kann bzw. mit der ein Wörterbuchangriff zur Gewinnung von E-Mail-Adressen verübt werden kann.

Das in Microsoft Windows Server™ 2003 Service Pack 1 (SP1) verfügbare Tarpit-Feature kann zusammen mit der Empfängerfilterung verwendet werden, wie im Microsoft Knowledge Base-Artikel 842851 beschrieben: „SMTP-Tar Pit-Feature für Microsoft Windows Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=842851). Insbesondere verstärkt das Tar Pit-Feature den Nutzen der Empfängerfilterung, wenn in Globale Einstellungen auf der Registerkarte Empfängerfilterung das Kontrollkästchen Empfänger filtern, die nicht im Verzeichnis vorhanden sind aktiviert ist.

Das Tar Pit-Feature wird implementiert, indem der Registrierungsunterschlüssel TarpitTime festgelegt wird. Für den Registrierungsunterschlüssel TarpitTime ist ein Dezimalwert erforderlich. Der Dezimalwert wird als die Anzahl von Sekunden interpretiert, die während einer SMTP-Sitzung gewartet wird, um einem Sender zu antworten, wenn ein Empfänger in der Exchange Server-Zielorganisation nicht vorhanden ist.

Die Tar Pit-Funktion erschwert es den Versendern von Spam, unerwünschte E-Mail-Nachrichten zu senden, um einen Wörterbuchangriff zu automatisieren. Bei einem Wörterbuchangriff (Directory Harvest Attack - DHA) handelt es sich um den Versuch, eine Liste von bekannten gültigen E-Mail-Adressen von einer bestimmten Organisation abzurufen.

Das SMTP-Protokoll bestätigt gültige Empfänger während einer SMTP-Sitzung durch Rückgabe von 2.1.5 Recipient OK. Wenn eine E-Mail-Nachricht an einen unbekannten Empfänger gesendet wird, gibt das SMTP-Protokoll einen 5.x.x-Fehler zurück. Daher kann eine Person (Spammer), die Spam versendet, ein automatisiertes Programm schreiben, in dem übliche Namen oder Wörterbucheinträge verwendet werden, um E-Mail-Adressen für eine bestimmte Domäne zu erstellen. Das Programm kann dann alle E-Mail-Adressen sammeln, die 2.1.5 Recipient OK zurückgegeben haben, und alle E-Mail-Adressen verwerfen, die einen 5.x.x-Fehler ausgelöst haben. Der Spammer kann dann die gültigen E-Mail-Adressen verkaufen oder sie als Empfänger für unverlangte E-Mails verwenden.

Wenn das Kontrollkästchen Empfänger filtern, die nicht im Verzeichnis vorhanden sind aktiviert ist, der Registrierungsunterschlüssel TarpitTime jedoch nicht festgelegt ist, gibt Exchange Server während der SMTP-Sitzung sofoft den einen 5.x.x-Fehler an den Absender zurück, wenn ein Empfänger nicht im Active Directory®-Zielverzeichnisdienst vorhanden ist.

Wenn jedoch der Registrierungsunterschlüssel TarpitTime festgelegt und das Kontrollkästchen Empfänger filtern, die nicht im Verzeichnis vorhanden sind aktiviert ist, wartet SMTP vor dem Zurückgeben eines 5.x.x-Fehlers. Der Dezimalwert, der für den Registrierungsunterschlüssel TarpitTime eingegeben wurde, gibt die Anzahl der Sekunden an, die SMTP bis zur Rückgabe des Fehlers wartet. Durch diese Pause in der SMTP-Sitzung wird das Automatisieren eines Wörterbuchangriffs sehr erschwert.

Wie eingangs erwähnt, zeigt Exchange Server Analyzer eine Meldung an, dass ein vom Standardwert abweichender Wert konfiguriert wurde, wenn der Registrierungsunterschlüssel TarpitTime festgelegt wurde. Diese Meldung dient ausschließlich Informationszwecken.

Wichtig:
Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Stellen Sie vor dem Bearbeiten der Registrierung sicher, dass Sie für den Fall eines Problems mit dem Wiederherstellungsprozess für die Registrierung vertraut sind. Weitere Informationen zum Wiederherstellen der Registrierung finden Sie im Hilfethema „Wiederherstellen der Registrierung" in Regedit.exe oder Regedt32.exe.
So zeigen Sie den Registrierungsunterschlüssel „TarpitTime" an oder ändern ihn

  1. Klicken Sie auf Start, klicken Sie auf Ausführen, und geben im Feld Öffnen die Zeichenfolge regedit ein. Klicken Sie anschließend auf OK.

  2. Suchen Sie den folgenden Registrierungsunterschlüssel, und klicken Sie dann darauf:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SMTPSVC\Parameters\TarpitTime

  3. Das Feld Datenwerte enthält eine Dezimalzahl. Dieser Zahl gibt die Anzahl der Sekunden an, um die die Antworten für die SMTP-Adressüberprüfung für jede Adresse, die nicht in Active Directory vorhanden ist, verzögert werden soll.

  4. Wenn Sie den Wert ändern oder den Registrierungsunterschlüssel TarpitTime löschen, müssen Sie den SMTP-Dienst (Simple Mail Transport Protocol) neu starten.

Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 842851, „SMTP-Tar Pit-Feature für Microsoft Windows Server 2003" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=842851).


Testnachricht hat Unzustellbarkeitsbericht generiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Das Tool Microsoft® Exchange Server Analyzer sendet eine Testnachricht vom Server mit Exchange an das Postmasterkonto oder ein benutzerdefiniertes Konto für die SMTP-Domäne (Simple Mail Transfer Protocol) und untersucht anschließend die Nachrichtenverfolgungsprotokolle des Servers, um zu bestimmen, ob bei der Übermittlung der Testnachricht Probleme aufgetreten sind.

Im Rahmen dieser Untersuchung fragt Exchange Server Analyzer die Eigenschaft EntryType der Microsoft WMI-Klasse (Windows® Management Instrumentation, Windows®-Verwaltungsinstrumentation) Exchange_MessageTrackingEntry unter dem Namespace root\MicrosoftExchangeV2 ab, um den Grund für den Eintrag in die Nachrichtenverfolgungsprotokolle zu ermitteln.

Wenn Exchange Server Analyzer feststellt, dass die Eigenschaft EntryType den Wert 1030 hat, zeigt Exchange Server Analyzer eine Warnung an.

Diese Warnung bedeutet, dass die Testnachricht einen Unzustellbarkeitsbericht generiert hat und ein Problem mit der SMTP-Konfiguration (Simple Mail Transfer Protocol) auf diesem Server vorlag. Ein Unzustellbarkeitsbericht ist zu erwarten, wenn der Zielempfänger nicht vorhanden ist, stellt aber ein Problem dar, wenn die Testnachricht an einen rechtmäßigen Empfänger gesendet wurde.

Als Problembehandlungsschritt können Sie weitere Testnachrichten an denselben Empfänger senden und die Unzustellbarkeitsberichte zur Ermittlung der Ursache überprüfen.

Weitere Informationen zur Behandlung von Unzustellbarkeitsberichten finden Sie unter "Problembehandlung bei Unzustellbarkeitsberichten" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579.


Test-E-Mail an das Badmail-Verzeichnis gesendet
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-05-17

Das Tool Microsoft® Exchange Server Analyzer sendet eine Testnachricht vom Server mit Exchange an das Postmasterkonto oder ein benutzerdefiniertes Konto für die SMTP-Domäne (Simple Mail Transfer Protocol) und untersucht anschließend die Nachrichtenverfolgungsprotokolle des Servers, um zu bestimmen, ob bei der Übermittlung der Testnachricht Probleme aufgetreten sind.

Im Rahmen dieser Untersuchung fragt Exchange Server Analyzer die Eigenschaft EntryType der Microsoft WMI-Klasse (Windows® Management Instrumentation, Windows®-Verwaltungsinstrumentation) Exchange_MessageTrackingEntry unter dem Namespace root\MicrosoftExchangeV2 ab, um den Grund für den Eintrag in die Nachrichtenverfolgungsprotokolle zu ermitteln.

Wenn Exchange Server Analyzer feststellt, dass die Eigenschaft EntryType den Wert 1021 hat, zeigt Exchange Server Analyzer eine Warnung an.

Diese Warnung bedeutet, dass die Testnachricht an das Verzeichnis Badmail des Servers mit Exchange gesendet wurde und ein Problem mit der SMTP-Konfiguration (Simple Mail Transfer Protocol) auf diesem Server vorlag.

Eine Nachricht wird aus folgenden Gründen in das Verzeichnis Badmail eingegeben:

  • Die Nachricht kann nicht übermittelt werden.

  • Die maximale Anzahl der Wiederholungen wurde überschritten.

  • Die Nachricht kann nicht als unzustellbar an den Absender zurückgesendet werden.

Weitere Informationen zum Testen des ausgehenden Nachrichtenflusses finden Sie im Microsoft Knowledge Base-Artikel 297700, "Testen von ausgehendem Nachrichtenfluss mit einer Datei in dem Ordner Pickup" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297700).

Weitere Informationen zur Behandlung von Nachrichtenfluss- und SMTP-Problemen finden Sie unter "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).


Festsitzende Testnachricht in SMTP-Warteschlange
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-07-06

Das Tool Microsoft® Exchange Server Analyzer sendet eine Testnachricht vom Server mit Exchange an das Postmasterkonto oder ein benutzerdefiniertes Konto für die SMTP-Domäne (Simple Mail Transfer Protocol) und untersucht anschließend die Nachrichtenverfolgungsprotokolle des Servers, um zu bestimmen, ob bei der Übermittlung der Testnachricht Probleme aufgetreten sind.

Im Rahmen dieser Untersuchung fragt Exchange Server Analyzer die Eigenschaft EntryType der Microsoft WMI-Klasse (Windows® Management Instrumentation, Windows®-Verwaltungsinstrumentation) Exchange_MessageTrackingEntry unter dem Namespace root\MicrosoftExchangeV2 ab, um den Grund für die Erstellung der Einträge in den Nachrichtenverfolgungsprotokollen zu ermitteln.

In der folgenden Tabelle sind die möglichen EntryType-Werte aufgeführt, die zurückgegeben werden können.

Bezeichnung des Werts | Wert
Nachricht über X.400 empfangen | 0
Bericht empfangen | 2
Nachricht zum Senden übergeben | 4
Nachricht ausgehend übertragen | 7
Bericht ausgehend übertragen | 8
Nachricht übermittelt | 9
Bericht übermittelt | 10
Verteilerliste erweitert | 26
Nachricht umgeleitet | 28
Nachricht erneut umgeleitet | 29
Server von MTA zurückgestuft | 31
Bericht aufgenommen | 33
Bericht erstellt | 34
Nicht-routingfähiger Bericht gelöscht | 43
Nachricht gelöscht von Administrator | 50
Überprüfung gelöscht von Administrator | 51
Bericht gelöscht von Administrator | 52
Nachricht lokal übermittelt | 1000
Nachricht eingehend (Backbone) übertragen | 1001
Nachricht ausgehend (Backbone) übertragen | 1002
Nachricht ausgehend (Gateway) übertragen | 1003
Nachricht eingehend (Gateway) übertragen | 1004
Bericht eingehend (Gateway) übertragen | 1005
Bericht ausgehend (Gateway) übertragen | 1006
Bericht erstellt | 1007
SMTP: Nachricht für ausgehende Übermittlung in die Warteschlange gestellt | 1010
SMTP: Nachricht ausgehend übertragen | 1011
SMTP: Eingehende Nachricht empfangen | 1012
SMTP: Eingehende Nachricht übertragen | 1013
SMTP: Nachricht erneut umgeleitet | 1014
SMTP: Bericht eingehend übertragen | 1015
SMTP: Bericht ausgehend übertragen | 1016
SMTP: Bericht erstellt | 1017
SMTP: Bericht aufgenommen | 1018
SMTP: Nachricht an erweiterten Warteschlangenmechanismus übermittelt | 1019
SMTP: Beginn der ausgehenden Übermittlung | 1020
SMTP: Nachricht an Verzeichnis für beschädigte E-Mail gesendet | 1021
SMTP: Fehler im erweiterten Warteschlangenmechanismus | 1022
SMTP: Nachricht lokal übermittelt | 1023
SMTP: Nachricht an Kategorisierungsmodul übermittelt | 1024
SMTP: Nachrichtenübermittlung an erweiterten Warteschlangenmechanismus begonnen | 1025
SMTP: Erweiterter Warteschlangenmechanismus konnte Nachricht nicht übermitteln | 1026
SMTP-Speichertreiber: Nachricht von Informationsspeicher übermittelt | 1027
SMTP-Speichertreiber: Nachricht lokal an Informationsspeicher übermittelt | 1028
SMTP-Speichertreiber: Nachricht an MTA übermittelt | 1029
SMTP: Unzustellbarkeitsbereich generiert | 1030
SMTP: Nachricht ausgehend übertragen | 1031

Exchange Server Analyzer zeigt einen Fehler an, wenn die zurückgegebenen EntryType-Werte die folgenden Bedingungen erfüllen:

  • Das Testnachrichtenverfolgungsprotokoll kann erfolgreich durchsucht werden.

  • Die Testnachricht wurde nicht erfolgreich aus der Warteschlange übertragen.

  • Für die Testnachricht wurde kein Unzustellbarkeitsbereich generiert.

  • Die Testnachricht wurde nicht an das Verzeichnis für beschädigte E-Mail gesendet.

  • Die Testnachricht wurde nicht in die Warteschlange für Remoteübermittlung gestellt.

  • Die Testnachricht wurde nicht erfolgreich in den lokalen Informationsspeicher übermittelt.

  • Die Testnachricht wurde nicht zur Wiederholung der Kategorisierung geplant.

  • Die Testnachricht wurde nicht zur Wiederholung des Routing geplant.

  • Die Testnachricht wurde nicht zur Wiederholung der lokalen Übermittlung geplant.

Dieser Fehler bedeutet, dass die Testnachricht in einer SMTP-Warteschlange festsitzt und eine weitere Analyse erforderlich ist, um den Grund dafür zu ermitteln.

Verwenden Sie zum Beheben dieses Fehlers das Dienstprogramm NSlookup, um mögliche Probleme bei der DNS-Auflösung (Domain Name System) zu überprüfen. Verwenden Sie bei Verbindungs- und Protokollfehlern, z. B. vom Typ "Host nicht erreichbar", Telnet.exe, um eine Verbindung mit dem Zielcomputer herzustellen. Um Protokollprobleme zu behandeln, erhöhen Sie den Protokolliergrad für die Diagnose des MSExchangeTransport-Diensts für die SMTP-Komponente, und überprüfen Sie die Protokolle auf Fehler. Alternativ können Sie mit dem Tool Netzwerkmonitor (Netmon.exe) Informationen zu Netzwerkverbindungsfehlern abrufen. Um das Problem zu reproduzieren, müssen Sie ggf. für die Warteschlange den Status Wiederholen erzwingen. Untersuchen Sie das Ereignisprotokoll auf mögliche Fehler im Zusammenhang mit dem Microsoft Exchange-Informationsspeicherdienst.

Weitere Informationen zum Ändern von Protokolleinstellungen finden Sie unter "Ändern von Protokollierungseinstellungen für MSExchangeTransport" im Kapitel "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579)

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Microsoft Knowledge Base-Artikel 821877, "Beschreibung der Felder auf den Registerkarten mit den Eigenschaften für SMTP- und X.400-Warteschlangen" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Microsoft Knowledge Base-Artikel 264054, "XCON: Grundlegendes zu Warteschlangenzuständen in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


Es sind mehr als 900 Connectors in einer Routinggruppe vorhanden.
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-01-17

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um die Anzahl der Connectors zu bestimmen, die in einer bestimmten Routinggruppe enthalten sind, einschließlich SMTP-Connectors, Routinggruppenconnectors, X.400-Connectors und EDK-Connectors. Wenn der Exchange Server Analyzer eine Gesamtzahl von mehr als 900 Connectors in einer einzigen Routinggruppe ermittelt, wird eine Warnung angezeigt.

Es empfiehlt sich, für einen einzigen Exchange-Objekttyp maximal 900 Instanzen zu verwenden. Dies ist darauf zurückzuführen, dass die maximal zurückgegebene Seitengröße pro Anforderung in Active Directory in der Standardeinstellung 1.000 beträgt. Das heißt, dass bei einer gesendeten LDAP-Anforderung (Lightweight Directory Access Protocol) für ein Objekt und mehr als 1.000 vorhandenen Instanzen des betreffenden Objekts in Active Directory keine Ergebnisse zurückgegeben werden, da die maximale Seitengröße überschritten wurde.

Für Exchange Server erfordern eine Reihe von Prozessen das Erstellen von Instanzen für bestimmte Objekttypen. Exchange-System-Manager sendet beispielsweise eine LDAP-Anforderung an Active Directory, um eine Listenansicht aller Connectors in einer Routinggruppe zu erstellen. Wenn in einer einzigen Routinggruppe mehr als 1.000 Connectors vorhanden sind, werden von Active Directory keine Abfrageergebnisse zurückgegeben. Wenn dies eintritt, wird in Exchange-System-Manager ein Fehler angezeigt.

Die maximale Seitengröße für Active Directory kann zwar vergrößert werden, dies wird jedoch für Exchange Server nicht empfohlen und nicht unterstützt. In Exchange-Umgebungen, in denen der Wert für die maximale Seitengröße heraufgesetzt wurde, waren ein ungewöhnliches Verhalten und Fehler zu beobachten.

Zwar wird empfohlen, für einen einzigen Objekttyp in Exchange Server einen Höchstwert von 900 einzuhalten, es werden jedoch bis zu 1.000 Objekttypen unterstützt.

So beheben Sie diese Warnmeldung

  1. Konsolidieren Sie die Connectors, oder erstellen Sie weitere Routinggruppen, und verteilen Sie die Belastung der vorhandenen Connectors auf diese Routinggruppen.

  2. Durchsuchen Sie Active Directory nach verwaisten Connectors, und entfernen Sie diese aus Active Directory.

  3. Sie können die Exchange-Server in Ihrer Organisation konsolidieren.

Weitere Informationen über das Routinggruppendesign und Connectors finden Sie im Exchange Server 2003 Transport and Routing Guide (http://go.microsoft.com/fwlink/?LinkId=47579).

Weitere Informationen über das Konsolidieren von Exchange-Servern finden Sie unter Server Consolidation Using Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47586).


Zwischen Active Directory und Metabase besteht eine Diskrepanz bei der Einstellung für den vollständig qualifizierten Domänenamen
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2007-01-17

Microsoft® Exchange Server Analyzer liest die folgende Eigenschaft in der IIS-Metabase (Internet Information Services), um zu ermitteln, ob der zugehörige Wert mit dem konfigurierten Wert des Attributs msExchSmtpFullyQualifiedDomainName im Active Directory®-Verzeichnisdienst übereinstimmt:

/LM/SmtpSvc/<SMTP virtual server instance>/FullyQualifiedDomainName

Wenn Exchange Server Analyzer feststellt, dass die Werte der beiden Attribute nicht übereinstimmen, wird eine Warnung angezeigt:

Wenn der Wert in der IIS-Metabase nicht mit dem Wert in Active Directory übereinstimmt, könnte dies auf ein Problem bei der Active Directory-Replikation oder auf ein Problem bei der Verzeichnisdienst-Nach-Metabase (DS2MB)-Replikationskomponente in Exchange hinweisen.

Die Funktion des DS2MB-Vorgangs besteht darin, die Konfigurationsinformationen von Active Directory zur lokalen Metabase zu übertragen. Anstatt in der Registrierung ist diese Konfiguration aus Leistungs- und Skalierbarkeitsgründen in der lokalen Metabase gespeichert. In Exchange 2000 Server und Exchange Server 2003 werden alle Internet-Protokolle (SMTP, NNTP, POP3, IMAP4 und HTTP) als Komponenten von IIS ausgeführt.

Alle 15 Minuten kopiert der DS2MB-Vorgang die gesamten Teilstrukturen von Active Directory, ohne die Form der Teilstruktur zu ändern. Dieser Schreibvorgang erfolgt einseitig von Active Directory zur Metabase; umgekehrt schreibt die Metabase niemals ins Active Directory.

Die Eigenschaft FullyQualifiedDomainName und das Attribut msExchSmtpFullyQualifiedDomainName verwenden einen Standardservernamen, der dem vollständig qualifizierten Domänennamen des Exchange-Servers entspricht (z. B. server.domain.com). Wenn die Eigenschaft FullyQualifiedDomainName und das Attribut msExchSmtpFullyQualifiedDomainName nicht denselben Wert für den vollständig qualifizierten Domänennamen aufweisen, bedeutet dies, dass Active Directory und die IIS-Metabase nicht miteinander synchronisiert sind. Wenn dieses Problem durch einen Fehler beim DS2MB-Vorgang verursacht ist, können Sie es mit nachstehendem Verfahren für die bei Ihnen ausgeführte Version von Exchange Server beheben. Wenn dieses Problem auftritt, weil die Replikation des Active Directory teilweise oder vollständig fehlgeschlagen ist, können Sie mithilfe des Active Directory-Replikationsmonitor-Dienstprogramms (ReplMon.exe) den Zustand und Status der Active Directory-Replikation überprüfen. ReplMon.exe finden Sie auf der CD-ROM mit Windows Server™ 2003 bei den Microsoft Windows®-Supporttools.

So vermeiden Sie diese Warnung unter Exchange Server 2003

  1. Überprüfen Sie das Vorhandensein der Anwendungsereignisprotokolleinträge mit der Quelle MSExchangeMU. Bei einem Fehler von DS2MB wird ein Ereignis unter Exchange Server 2003 protokolliert.

  2. Wenn keine DS2MB-Fehler zu finden sind, prüfen Sie mithilfe von ReplMon die Active Directory-Replikation. Achten Sie insbesondere auf die globalen Katalogserver, die von Ihrem virtuellen SMTP-Server verwendet werden.

  3. Wenn Sie DS2MB-Fehler entdecken oder nachdem Sie Probleme mit der Active Directory-Replikation beseitigt oder gelöst haben, starten Sie die Exchange-Systemaufsicht neu.

So vermeiden Sie diese Warnung unter Exchange 2000 Server

  1. Überprüfen Sie mithilfe von ReplMon die Active Directory-Replikation. Achten Sie insbesondere auf die globalen Katalogserver, die von Ihrem virtuellen SMTP-Server verwendet werden.

  2. Nachdem Sie Probleme mit der Active Directory-Replikation beseitigt oder gelöst haben, starten Sie die Exchange-Systemaufsicht neu.

Weitere Informationen zur Funktion für die umgekehrte DNS-Suche in Exchange finden Sie im Microsoft Knowledge Base-Artikel 297412 „The 'Perform Reverse DNS Lookup for Incoming Messages' Option Is for Host Name Resolution" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den Knowledge Base-Artikeln 266686, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) und 268163, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

Weitere Informationen zur Active Directory-Replikation finden Sie im Knowledge Base-Artikel 232072, „Einleiten der Replikation zwischen direkten Replikationspartnern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Weitere Informationen zum DS2MB-Prozess finden Sie im Knowledge Base-Artikel 240105, „XGEN: General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105).


Zwischen Active Directory und Metabase besteht eine Diskrepanz bei der Einstellung für die maximale Anzahl der Hops
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest die folgende Eigenschaft in der IIS-Metabase (Internet Information Services), um zu ermitteln, ob der zugehörige Wert mit dem konfigurierten Wert des Attributs msExchSmtpMaxHopCount im Active Directory®-Verzeichnisdienst übereinstimmt:

/LM/SmtpSvc/<SMTP virtual server instance>/HopCount

Wenn Microsoft Exchange Server Analyzer feststellt, dass die Werte nicht übereinstimmen, wird eine Warnung angezeigt:

Wenn der Wert in der IIS-Metabase nicht mit dem Wert in Active Directory übereinstimmt, könnte dies auf ein Problem bei der Active Directory-Replikation oder auf ein Problem bei der Verzeichnisdienst-Nach-Metabase (DS2MB)-Replikationskomponente in Exchange hinweisen.

Die Funktion des DS2MB-Vorgangs besteht darin, die Konfigurationsinformationen von Active Directory zur lokalen Metabase zu übertragen. Anstatt in der Registrierung ist diese Konfiguration aus Leistungs- und Skalierbarkeitsgründen in der lokalen Metabase gespeichert. In Exchange 2000 Server und Exchange Server 2003 werden alle Internet-Protokolle (SMTP, NNTP, POP3, IMAP4 und HTTP) als Komponenten von IIS ausgeführt.

Alle 15 Minuten kopiert der DS2MB-Vorgang die gesamten Teilstrukturen von Active Directory, ohne die Form der Teilstruktur zu ändern. Dieser Schreibvorgang erfolgt einseitig von Active Directory zur Metabase; umgekehrt schreibt die Metabase niemals in Active Directory.

Auf einem virtuellen SMTP-Server für Exchange 2000 Server beträgt die Anzahl der Hops in der Standardeinstellung 15. Auf einem virtuellen SMTP-Server für Exchange 2003 Server beträgt die Anzahl der Hops in der Standardeinstellung 30. Wenn die Eigenschaft HopCount und das Attribut msExchSmtpMaxHopCount nicht übereinstimmen, sind Active Directory und die IIS-Metabase unabhängig vom konfigurierten Wert nicht synchronisiert. Wenn dieses Problem durch einen Fehler beim DS2MB-Vorgang verursacht ist, können Sie es mit nachstehendem Verfahren für die bei Ihnen ausgeführte Version von Exchange Server beheben. Wenn dieses Problem auftritt, weil die Replikation des Active Directory teilweise oder vollständig fehlgeschlagen ist, können Sie mithilfe des Active Directory-Replikationsmonitor-Dienstprogramms (ReplMon.exe) den Zustand und Status der Active Directory-Replikation überprüfen. ReplMon.exe finden Sie auf der CD-ROM mit Windows Server™ 2003 bei den Microsoft Windows®-Supporttools.

So beheben Sie den Fehler unter Exchange Server 2003

  1. Überprüfen Sie das Vorhandensein der Anwendungsereignisprotokolleinträge mit der Quelle MSExchangeMU. Bei einem Fehler von DS2MB wird ein Ereignis unter Exchange Server 2003 protokolliert.

  2. Wenn keine DS2MB-Fehler zu finden sind, prüfen Sie mithilfe von ReplMon die Active Directory-Replikation. Achten Sie insbesondere auf die globalen Katalogserver, die von Ihrem virtuellen SMTP-Server verwendet werden.

  3. Wenn Sie DS2MB-Fehler entdecken oder nachdem Sie Probleme mit der Active Directory-Replikation beseitigt oder gelöst haben, starten Sie die Exchange-Systemaufsicht neu.

So beheben Sie diesen Fehler unter Exchange 2000 Server

  1. Überprüfen Sie mithilfe von ReplMon die Active Directory-Replikation. Achten Sie insbesondere auf die globalen Katalogserver, die von Ihrem virtuellen SMTP-Server verwendet werden.

  2. Nachdem Sie Probleme mit der Active Directory-Replikation beseitigt oder gelöst haben, starten Sie die Exchange-Systemaufsicht neu.

Weitere Informationen zur Funktion für die umgekehrte DNS-Suche in Exchange finden Sie im Microsoft Knowledge Base-Artikel 297412 „The 'Perform Reverse DNS Lookup for Incoming Messages' Option Is for Host Name Resolution" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Knowledge Base-Artikeln:

  • 266686, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

Weitere Informationen zur Active Directory-Replikation finden Sie im Knowledge Base-Artikel 232072, „Einleiten der Replikation zwischen direkten Replikationspartnern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Weitere Informationen zum DS2MB-Prozess finden Sie im Knowledge Base-Artikel 240105, „XGEN: General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105).


Bei der Einstellung für die maximale Nachrichtengröße ist eine Diskrepanz zwischen Active Directory und der Metabase aufgetreten
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest die folgende Eigenschaft in der IIS-Metabase (Internet Information Services), um zu ermitteln, ob der zugehörige Wert mit dem konfigurierten Wert des Attributs msExchSmtpMaxMessageSize im Active Directory®-Verzeichnisdienst übereinstimmt:

/LM/SmtpSvc/<Instanz des virtuellen SMTP-Servers>/MaxMessageSize

Wenn Microsoft Exchange Server Analyzer feststellt, dass die Werte nicht übereinstimmen, wird eine Warnung angezeigt:

Wenn der Wert in der IIS-Metabase nicht mit dem Wert in Active Directory übereinstimmt, könnte dies auf ein Problem bei der Active Directory-Replikation oder auf ein Problem bei der Verzeichnisdienst-Nach-Metabase (DS2MB)-Replikationskomponente in Exchange hinweisen.

Die Funktion des DS2MB-Vorgangs besteht darin, die Konfigurationsinformationen von Active Directory zur lokalen Metabase zu übertragen. Anstatt in der Registrierung ist diese Konfiguration aus Leistungs- und Skalierbarkeitsgründen in der lokalen Metabase gespeichert. In Exchange 2000 Server und Exchange Server 2003 werden alle Internet-Protokolle (SMTP, NNTP, POP3, IMAP4 und HTTP) als Komponenten von IIS ausgeführt.

Alle 15 Minuten kopiert der DS2MB-Vorgang die gesamten Teilstrukturen von Active Directory, ohne die Form der Teilstruktur zu ändern. Dieser Schreibvorgang erfolgt einseitig von Active Directory zur Metabase; umgekehrt schreibt die Metabase niemals in Active Directory.

Sowohl die Eigenschaft MaxMessageSize als auch das Attribut msExchSmtpMaxMessageSize verwenden die Standardeinstellung 0. Dies bedeutet, dass es keine Beschränkungen für die Nachrichtengröße gibt. Wenn die Eigenschaft MaxMessageSize und das Attribut msExchSmtpMaxMessageSize nicht denselben Wert aufweisen, bedeutet dies, dass Active Directory und die IIS-Metabase nicht miteinander synchronisiert sind. Wenn dieses Problem durch einen Fehler beim DS2MB-Vorgang verursacht ist, können Sie es mit nachstehendem Verfahren für die bei Ihnen ausgeführte Version von Exchange Server beheben. Wenn dieses Problem auftritt, weil die Replikation des Active Directory teilweise oder vollständig fehlgeschlagen ist, können Sie mithilfe des Active Directory-Replikationsmonitor-Dienstprogramms (ReplMon.exe) den Zustand und Status der Active Directory-Replikation überprüfen. ReplMon.exe finden Sie auf der CD-ROM mit Windows Server™ 2003 bei den Microsoft Windows®-Supporttools.

So beheben Sie den Fehler unter Exchange Server 2003

  1. Überprüfen Sie das Vorhandensein der Anwendungsereignisprotokolleinträge mit der Quelle MSExchangeMU. Bei einem Fehler von DS2MB wird ein Ereignis unter Exchange Server 2003 protokolliert.

  2. Wenn keine DS2MB-Fehler zu finden sind, prüfen Sie mithilfe von ReplMon die Active Directory-Replikation. Achten Sie insbesondere auf die globalen Katalogserver, die von Ihrem virtuellen SMTP-Server verwendet werden.

  3. Wenn Sie DS2MB-Fehler entdecken oder nachdem Sie Probleme mit der Active Directory-Replikation beseitigt oder gelöst haben, starten Sie den Dienst Exchange-Systemaufsicht neu.

So beheben Sie diesen Fehler unter Exchange 2000 Server

  1. Überprüfen Sie mithilfe von ReplMon die Active Directory-Replikation. Achten Sie insbesondere auf die globalen Katalogserver, die von Ihrem virtuellen SMTP-Server verwendet werden.

  2. Nachdem Sie Probleme mit der Active Directory-Replikation beseitigt oder gelöst haben, starten Sie den Dienst Exchange-Systemaufsicht neu.

Weitere Informationen zur umgekehrten DNS-Suche in Exchange finden Sie im Microsoft Knowledge Base-Artikel 297412, „The 'Perform Reverse DNS Lookup for Incoming Messages' Option Is for Host Name Resolution" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Knowledge Base-Artikeln:

  • 266686, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

Weitere Informationen zur Active Directory-Replikation finden Sie im Microsoft Knowledge Base-Artikel 232072, „Einleiten der Replikation zwischen direkten Replikationspartnern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Weitere Informationen zum DS2MB-Vorgang finden Sie im Microsoft Knowledge Base-Artikel 240105, „XGEN: General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105).


Bei der Einstellung für die maximale Sitzungsgröße ist eine Diskrepanz zwischen Active Directory und der Metabase aufgetreten
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer liest die /LM/SmtpSvc/<SMTP virtual server instance>/MaxSessionSize-Eigenschaft in der IIS-Metabase (Internet Information Services), um zu ermitteln, ob der zugehörige Wert mit dem konfigurierten Wert des Attributs msExchSmtpMaxSessionSize im Active Directory®-Verzeichnisdienst übereinstimmt:

Wenn Microsoft Exchange Server Analyzer feststellt, dass die Werte nicht übereinstimmen, wird eine Warnmeldung angezeigt.

Wenn der Wert in der IIS-Metabase nicht mit dem Wert in Active Directory übereinstimmt, könnte dies auf ein Problem bei der Active Directory-Replikation oder auf ein Problem bei der Verzeichnisdienst-Nach-Metabase (DS2MB)-Replikationskomponente in Exchange hinweisen.

Die Funktion des DS2MB-Vorgangs besteht darin, die Konfigurationsinformationen von Active Directory zur lokalen Metabase zu übertragen. Anstatt in der Registrierung ist diese Konfiguration aus Leistungs- und Skalierbarkeitsgründen in der lokalen Metabase gespeichert. In Exchange 2000 Server und Exchange Server 2003 werden alle Internet-Protokolle (SMTP, NNTP, POP3, IMAP4 und HTTP) als Komponenten von IIS ausgeführt.

Alle 15 Minuten kopiert der DS2MB-Vorgang die gesamten Teilstrukturen von Active Directory, ohne die Form der Teilstruktur zu ändern. Dieser Schreibvorgang erfolgt einseitig von Active Directory zur Metabase; umgekehrt schreibt die Metabase niemals in Active Directory.

Sowohl die Eigenschaft MaxSessionSize als auch das Attribut msExchSmtpMaxSessionSize verwenden die Standardeinstellung 0. Dies bedeutet, dass es keine Beschränkungen für die Sitzungsgröße gibt. Wenn die Eigenschaft MaxSessionSize und das Attribut msExchSmtpMaxSessionSize nicht denselben Wert aufweisen, bedeutet dies, dass Active Directory und die IIS-Metabase nicht miteinander synchronisiert sind. Wenn dieses Problem durch einen Fehler beim DS2MB-Vorgang verursacht ist, können Sie es mit nachstehendem Verfahren für die bei Ihnen ausgeführte Version von Exchange Server beheben. Wenn dieses Problem auftritt, weil die Replikation des Active Directory teilweise oder vollständig fehlgeschlagen ist, können Sie mithilfe des Active Directory-Replikationsmonitor-Dienstprogramms (ReplMon.exe) den Zustand und Status der Active Directory-Replikation überprüfen. ReplMon finden Sie auf der Windows Server™ 2003-CD-ROM unter den Microsoft Windows® Support Tools.

So beheben Sie den Fehler unter Exchange Server 2003

  1. Überprüfen Sie das Vorhandensein der Anwendungsereignisprotokolleinträge mit der Quelle MSExchangeMU. Bei einem Fehler von DS2MB wird ein Ereignis unter Exchange Server 2003 protokolliert.

  2. Wenn keine DS2MB-Fehler zu finden sind, prüfen Sie mithilfe von ReplMon die Active Directory-Replikation. Achten Sie insbesondere auf die globalen Katalogserver, die von Ihrem virtuellen SMTP-Server verwendet werden.

  3. Wenn Sie DS2MB-Fehler entdecken oder nachdem Sie Probleme mit der Active Directory-Replikation beseitigt oder gelöst haben, starten Sie die Exchange-Systemaufsicht neu.

So beheben Sie diesen Fehler unter Exchange 2000 Server

  1. Überprüfen Sie mithilfe von ReplMon die Active Directory-Replikation. Achten Sie insbesondere auf die globalen Katalogserver, die von Ihrem virtuellen SMTP-Server verwendet werden.

  2. Nachdem Sie Probleme mit der Active Directory-Replikation beseitigt oder gelöst haben, starten Sie die Exchange-Systemaufsicht neu.

Weitere Informationen zur umgekehrten DNS-Suche in Exchange finden Sie im Microsoft Knowledge Base-Artikel 297412, „The 'Perform Reverse DNS Lookup for Incoming Messages' Option Is for Host Name Resolution" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Weitere Informationen zu Einstellungen für virtuelle SMTP-Server finden Sie in den folgenden Knowledge Base-Artikeln:

  • 266686, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 1)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163, „XCON: Konfiguration eines virtuellen SMTP-Servers (Teil 2)" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

Weitere Informationen zur Active Directory-Replikation finden Sie im Microsoft Knowledge Base-Artikel 232072, „Einleiten der Replikation zwischen direkten Replikationspartnern" (http://support.microsoft.com/kb/232072/de&kbid=232072).

Weitere Informationen zum DS2MB-Vorgang finden Sie im Microsoft Knowledge Base-Artikel 240105, „XGEN: General Information on Directory Service/Metabase Synchronization in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105).


In den letzten 24 Stunden wurde ein Transportwarnereignis des Verbindungs-Managers protokolliert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-07-07

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) Win32_NTLogEvent ab, um zu ermitteln, ob in den letzten 24 Stunden für MSExchangeTransport ein Warnereignis 4006 aufgetreten ist.

Wenn Exchange Server Analyzer feststellt, dass für MSExchangeTransport in den letzten 24 Stunden eine Warnung für ein Ereignis 4006 protokolliert wurde, wird eine Warnung angezeigt.

Diese Warnung weist normalerweise darauf hin, dass der Versuch fehlgeschlagen ist, Nachrichten an einen Remoteserver zu senden.

Eine MSExchangeTransport Ereignis 4006-Warnung kann folgende Ursachen haben:

  • Die Verbindung wurde vom Remotehost getrennt.

  • Vom Remote-SMTP-Dienst (Simple Mail Transfer Protocol) wurde die AUTH-Aushandlung abgelehnt.

  • Der Server, der versucht, die Nachricht zu übermitteln, kann nicht auf die Nachrichtenübermittlungsinformationen in der Nachricht zugreifen.

  • Es ist ein SMTP-Fehler aufgetreten.

  • Der Server, der versucht, die Nachricht zu übermitteln, kann keine Verbindung zum Remoteserver herstellen.

  • Ein Smarthost, der in den Eigenschaften des virtuellen SMTP-Servers angegeben wurde, ist aus irgendwelchen Gründen nicht erreichbar.

Weitere Informationen zu MSExchangeTransport Ereignis 4006-Warnungen und deren Ereignisdetails finden Sie im "Events and Errors Message Center" (http://go.microsoft.com/fwlink/?LinkId=34258).

Weitere Informationen zu von Problemen bei der E-Mail-Weiterleitung in Exchange Server finden Sie im Microsoft Knowledge Base-Artikel 895853, "Behandlung von Problemen mit der E-Mail-Weiterleitung in Exchange Server 2003 und Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=895853).

Weitere Informationen zu Nachrichtenfluss- und SMTP-Problemen finden Sie unter "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=67875).


In den letzten 24 Stunden wurde ein Transportwarnereignis des Verbindungs-Managers protokolliert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-07-07

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Windows® Management Instrumentation - Windows®-Verwaltungsinstrumentation) Win32_NTLogEvent ab, um zu ermitteln, ob in den letzten 24 Stunden für MSExchangeTransport ein Warnereignis 4001 aufgetreten ist.

Wenn Exchange Server Analyzer feststellt, dass für MSExchangeTransport in den letzten 24 Stunden eine Warnung für ein Ereignis 4001 protokolliert wurde, wird eine Warnung angezeigt.

Diese Warnung weist normalerweise darauf hin, dass der Versuch fehlgeschlagen ist, Nachrichten an einen Remoteserver zu senden.

Eine MSExchangeTransport Ereignis 4001-Warnung kann auftreten, wenn der SMTP-Dienst (Simple Mail Transfer Protocol) von Exchange 2000 Server oder Exchange Server 2003 Nachrichtenübermittlungsprobleme aufweist. Mögliche Ursachen für Nachrichtenübermittlungsprobleme sind DNS-Probleme (Domain Name System), IP-Konfigurationsprobleme oder die Installation falscher DLL-Dateien.

Weitere Informationen zu Ereignis 4001-Warnungen und deren Ereignisdetails finden Sie im "Events and Errors Message Center" (http://go.microsoft.com/fwlink/?LinkId=34258).

Weitere Informationen zu von Problemen bei der E-Mail-Weiterleitung in Exchange Server finden Sie im Microsoft Knowledge Base-Artikel 895853, "Behandlung von Problemen mit der E-Mail-Weiterleitung in Exchange Server 2003 und Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=895853).

Weitere Informationen zu Nachrichtenfluss- und SMTP-Problemen finden Sie unter "Problembehandlung bei Nachrichtenfluss und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkId=67875).


Transportereignissenken-Datei nicht gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-01-10

Microsoft® Exchange Server Analyzer sendet eine Abfrage an die Microsoft Internet Information Server-Metabase (IIS), um die Liste der SMTP-Transportereignissenken-Bindungen (Simple Mail Transport Protocol) aufzulisten. Exchange Server Analyzer versucht, auf Grundlage einer in Exchange Server Analyzer vorausgefüllten Liste mehrere Standardereignisbindungen aufzufinden. Für jede Bindung überprüft Exchange Server Analyzer die in der Registrierung unter folgender Teilstruktur enthaltenen COM-Registrierungsdetails (Component Object Model):

HKEY_CLASSES_ROOT\CLSID\

Die COM-Registrierungsdetails enthalten den vollständigen Pfad der zugeordneten DLL-Datei. Exchange Server Analyzer verwendet die Microsoft Windows®-Verwaltungsinstrumentation (Windows® Management Instrumentation, WMI), um die DLL-Datei aufzufinden und ihre Versionsnummer anzuzeigen. Wenn Exchange Server Analyzer die DLL-Datei nicht finden kann, zeigt er eine Warnung an, in der der Dateiname und der Pfad der fehlenden DLL-Datei angegeben werden.

Wenn Exchange Server Analyzer feststellt, dass eine oder mehrere Standardereignisbindungen fehlen, generiert Exchange Server Analyzer eine Warnung.

Ein SMTP-Transportereignis tritt ein, wenn Nachrichtendaten an den SMTP-Dienst bzw. von diesem übertragen werden. Alle Nachrichten durchlaufen Ereignisse. Hierzu gehören ein- und ausgehende X.400- und RPC-Nachrichten. Ein gängiges Beispiel für ein eingehendes Transportereignis ist der Eingang einer Nachricht beim SMTP-Dienst über das Netzwerk oder in das SMTP-Pickup-Verzeichnis. Sobald dieses Ereignis eintritt, benachrichtigt eine Quelle dieses Ereignisses die Transportereignissenken, von denen jede in Abhängigkeit vom Dateninhalt der Nachricht auf eine bestimmte Art reagieren kann. Das System führt nach der Übergabe der Nachrichtendaten an die Senke mit diesen Daten erst weitere Aktionen aus, nachdem die Senke die Verarbeitung abgeschlossen und die Nachricht zurückgegeben hat. Die Senke verfügt bei der Ausführung der Aktion über die alleinige Kontrolle über die Nachrichtendaten und deren Zustand.

Fehlende DLL-Dateien für COM-Registrierungen von Transportereignissenken können zu Problemen bei der Mailübermittlung führen. Wenn Exchange Server Anzeichen von Problemen bei der Mailübermittlung zeigt, wie zum Beispiel das Einstellen von Nachrichten in Warteschlangen, überprüfen Sie, ob die angegebenen DLL-Dateien vorhanden sind und installieren diese gegebenenfalls erneut.

So beheben Sie dieses Problem

  1. Verwenden Sie den Explorer, um die angegebene DLL-Datei manuell aufzufinden. Normalerweise befindet sich diese Datei im Ordner \Programme\Exchsrvr\Bin.

  2. Wenn folgende Bedingungen erfüllt (wahr) sind, kann die von Exchange Server Analyzer generierte Warnung ohne Sicherheitseinschränkungen ignoriert werden:

    • Die DLL-Datei ist im aufgeführten Ordner vorhanden.

    • Der Server zeigt keine Anzeichen von Problemen bei der Mailübermittlung.

  3. Wenn folgende Bedingungen erfüllt (wahr) sind, kopieren Sie die fehlende DLL-Datei von den ursprünglichen Exchange Server-Installationsmedien:

    • Die DLL-Datei ist nicht im von Exchange Server Analyzer aufgeführten Ordner vorhanden.

    • Der Server zeigt Anzeichen von Problemen bei der Mailübermittlung.

    Wenden Sie alternativ das neueste Exchange Service Pack erneut an.

  4. Führen Sie Exchange Server Analyzer erneut aus, um zu überprüfen, dass die Warnung nicht mehr angezeigt wird.


Änderungen der Benutzerversion der Informationen zum Verbindungsstatus werden unterdrückt
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2005-11-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um zu ermitteln, ob das Attribut heuristics so konfiguriert wurde, dass Änderungen der Benutzerversion der Informationen über den Verbindungsstatus unterdrückt werden. In der Standardeinstellung ist das Attribut heuristics nicht konfiguriert. Wenn Exchange Server Analyzer erkennt, dass das Attribut heuristics auf 2048 festgelegt ist, zeigt Exchange Server Analyzer eine Meldung an, dass die Konfiguration nicht der Standardkonfiguration entspricht.

Mithilfe von Verbindungsstatustabellen wird effizientes und verlässliches Nachrichtenrouting sichergestellt. Die Verbindungsstatustabelle enthält Versionsinformationen für jede Routinggruppe in Form von Hauptversions-, Nebenversions- und Benutzerversionsnummern. Änderungen der Hauptversion haben die höchste Priorität, gefolgt von Änderungen der Nebenversion und schließlich Änderungen der Benutzerversionsnummern.

Änderungen der Benutzerversion treten bei einer Aktualisierung des Verzeichnisdiensts auf der Grundebene ein. Diese minimalen Änderungen umfassen Änderungen des Routinegruppen-Masters, wenn auf einem Exchange-Server Dienste gestartet oder beendet werden, wenn der Routinggruppe ein weiterer Server hinzugefügt wird oder wenn ein Mitgliedsserver die Verbindung zum Routinggruppen-Master verliert.

Eine Aktualisierung des Verzeichnisdiensts auf der Grundebene tritt u. U. ein, wenn ein Exchange Server-Administrator Änderungen auf der Routinggruppen-Ebene vornimmt. Eine Änderung der Benutzerversion tritt beispielsweise ein, wenn ein Administrator den Namen einer Routinggruppe ändert, einen Server hinzufügt oder einen Server entfernt. Die primäre Ursache von Änderungen der Benutzerversion sind jedoch die WMI-Daten (Microsoft Windows® Management Instrumentation), die sich auf jedem Server befinden. Diese Daten geben an, welche Dienste ausgeführt werden. Wenn ein Dienst gestartet oder beendet wird, werden Benutzerversionsänderungen in der Verbindungsstatustabelle auf allen Exchange Server-Computern in der Organisation repliziert.

Häufige Aktualisierungen der Benutzerversion können den Netzwerkverkehr auf unerwünschte Weise erhöhen. Dies kann durch die Verwendung eines Hotfixes vom technischen Support von Microsoft und das Festlegen des Attributs heuristics auf den Wert 2048 (bzw. 0x800 als Hexadezimalwert) unterdrückt werden.

Wenn Aktualisierungen der Benutzerversion keinen übermäßigen Netzwerkverkehr erzeugen, wird empfohlen, diese nicht zu unterdrücken.

So stellen Sie die Standardkonfiguration wieder her

  1. Öffnen Sie die ADSI-Bearbeitung (ADSI, Active Directory Service Interfaces).

  2. Erweitern Sie in der ADSI-Bearbeitung den Container Konfiguration, erweitern Sie CN=Configuration, DC=DomainName, DC=com, CN=Services und anschließend CN=Microsoft Exchange.

  3. Klicken Sie mit der rechten Maustaste auf CN=OrganizationName, und klicken Sie dann auf Eigenschaften.

  4. Klicken Sie im Feld zum Auswählen einer anzuzeigenden Eigenschaft auf Heuristics.

  5. Löschen Sie im Feld zum Bearbeiten von Attributen den Wert 0x800.

  6. Klicken Sie auf Festlegen, und klicken Sie dann auf OK.

  7. Schließen Sie die ADSI-Bearbeitung.
Achtung:
Wenn Sie das ADSI-Bearbeitungs-Snap-In, das LDP-Tool (ldp.exe) oder einen anderen LDAP-Client, Version 3, verwenden und die Attribute der Active Directory-Objekte nicht ordnungsgemäß ändern, können schwerwiegende Probleme verursacht werden. Diese Probleme erfordern möglicherweise eine Neuinstallation von Microsoft Windows Server™ 2003, Exchange Server 2003 oder von beiden Anwendungen. Sie ändern Active Directory-Objektattribute auf eigenes Risiko.

Weitere Informationen zu Verbindungsstatus und Benutzerversionsnummern finden Sie unter „Architektur des Exchange-System-Managers" im Technischen Referenzhandbuch für Exchange Server 2003 (http://www.microsoft.com/downloads/details.aspx?FamilyID=3768246d-c9ed-45d8-bece-a666143cba4e&DisplayLang=de).


Benutzer wurde als gemeinsames Ziel identifiziert
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-09-06

Microsoft® Exchange Server Analyzer fragt die Exchange_Queue WMI-Klasse (Windows® Management Instrumentation) ab, um die Werte der folgenden Attribute für SMTP-Warteschlangen (Simple Mail Transfer Protocol) auf dem virtuellen SMTP-Server zu bestimmen.

LinkId | Gibt den Bezeichner für den Link an, der die Warteschlange enthält.
QueueId | Gibt den Bezeichner der Warteschlange an.
QueueName | Gibt den Namen der Warteschlange an.
VirtualMachine | Gibt den Namen des virtuellen Computers an, der die Warteschlange enthält.
VirtualServerName | Gibt den Namen des virtuellen Servers an, auf dem sich die Warteschlange befindet.
MessageCount | Gibt die Anzahl der Nachrichten in der Warteschlange an.

Exchange Server Analyzer fragt anhand der oben angegebenen Informationen die WMI-Klasse Exchange_QueuedSMTPMessage nach den Werten der folgenden Attribute für Nachrichten in der Warteschlange ab:

Recipients | Gibt die Empfänger der Nachricht an.
Received | Gibt den Zeitstempel des Empfangs der Nachricht an.
MessageId | Gibt den Bezeichner der in der Warteschlange befindlichen Nachricht an.
StateRetry | Gibt an, dass eine Nachricht, die nicht erfolgreich zugestellt werden konnte, erneut übermittelt wird.

Mit den über die voranstehenden Abfrage ermittelten Daten fragt Exchange Server Analyzer den Active Directory®-Verzeichnisdienst nach den folgenden Werten für jedes Recipient-Objekt ab, um zu ermitteln, ob der Empfänger ein Benutzer, eine Verteilergruppe, ein öffentlicher Ordner oder ein Informationsspeicher für Öffentliche Ordner ist:

distinguishedName | Gibt den DN (Distinguished Name) des Objekts an.
msExchHomeServerName | Gibt den Server an, auf dem sich der Empfänger befindet.
homeMDB | Gibt den Postfachspeicher des Empfängers an.

Wenn Exchange Server Analyzer ermittelt, dass 25 Prozent oder mehr der in der Warteschlange festsitzenden Nachrichten entweder im Feld An: oder im Feld CC: an einen bestimmten Benutzer adressiert sind, wird eine Warnung angezeigt.

Wenn Exchange Server Analyzer ermittelt, dass 50 Prozent oder mehr der in der Warteschlange festsitzenden Nachrichten entweder im Feld An: oder im Feld CC: an einen bestimmten Benutzer adressiert sind, wird ein Fehler angezeigt.

Diese Warnung bzw. dieser Fehler bedeutet, dass der identifizierte Benutzer ein gemeinsames Ziel für Nachrichten ist, die in einer SMTP-Warteschlange festsitzen.

Um dieses Problem zu beheben, sollten Sie überprüfen, ob Konfigurationsprobleme oder andere Anomalien für diesen Benutzer vorliegen, die dazu führen, dass die an ihn gerichteten Nachrichten in die Warteschlange gesetzt werden.

Zu überprüfende Bereiche:

  • Stellen Sie sicher, dass die Attribute des Benutzerobjekts ordnungsgemäß eingerichtet wurden und in Active Directory die richtigen Werte enthalten.

  • Überprüfen Sie, ob die Active Directory-Berechtigungen des Benutzerobjekts richtig eingestellt sind.

  • Suchen Sie nach möglichen unerwünschten kommerziellen E-Mails (UCE oder SPAM) oder Virusangriffen auf den Benutzer.

  • Überprüfen Sie, ob der Benutzer zu einer Verteilergruppe gehört, deren Übermittlungseinschränkungen fehlerhaft eingestellt sind.

  • Wenn es sich um ein spezielles Benutzerobjekt handelt, d. h. einen vorgesehenen Journalempfänger, überprüfen Sie, ob der Dienst und die Komponenten, mit denen das Benutzerobjekt verknüpft ist, ordnungsgemäß konfiguriert sind.

Weitere Informationen zum Behandeln von Problemen mit SMTP-Warteschlangen finden Sie in den folgenden Exchange-Ressourcen:

  • "Problembehandlung bei der Nachrichtenübermittlung und SMTP" im Transport- und Routing-Handbuch für Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875).

  • Microsoft Knowledge Base-Artikel 823489, "So verwenden Sie die Warteschlangenanzeige, um Probleme mit dem E-Mail-Verkehr in Exchange Server 2003 zu beheben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

Weitere Informationen zu der Auswirkung der Verteilergruppeneinschränkung auf die Nachrichtenübermittlung in Exchange Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

  • 895407, "Die Nachrichtenübermittlung zu lokalen und externen Postfächern ist in Exchange Server 2003 langsamer als erwartet, nachdem Sie die Übermittlungseinschränkungen basierend auf Verteilergruppen konfiguriert haben" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 329171 "XADM: Übermittlung von E-Mails ist langsam, wenn Empfänger mit Übermittlungseinschränkungen basierend auf der Gruppenmitgliedschaft konfiguriert sind" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • 839949, "Problembehandlung bei E-Mail-Transport und Verteilergruppen in Exchange 2000 Server und in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • 812298, "Übermittlung von E-Mails ist langsam, nachdem Sie Übermittlungseinschränkungen konfiguriert haben, die auf einer Verteilerliste basieren" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).


Unbekanntes SMTP-Problem
Microsoft Exchange Server Analyzer-Tools - Artikel > Transport >

Letztes Änderungsdatum des Themas: 2006-10-06

Microsoft® Exchange Server Analyzer fragt die Microsoft WMI-Klasse (Microsoft Windows® Management Instrumentation - Microsoft Windows®-Verwaltungsinstrumentation) Win32_Service ab, um den Wert des Schlüssels Started des SMTP-Diensts (Simple Mail Transfer Protocol) zu bestimmen. Der Wert False gibt an, dass der SMTP-Dienst nicht ausgeführt wird. Der Wert True gibt an, dass der SMTP-Dienst ausgeführt wird.

Exchange Server Analyzer erfordert außerdem, dass die IIS-Metabasis (Internet Information Services) den Wert für die Eigenschaft ServerState für die virtuelle SMTP-Serverinstanz ermittelt.

Die Eigenschaft ServerState zeigt den aktuellen Zustand der Serverinstanz. Die Zustandscodes und die entsprechenden Zustände lauten wie folgt:

Zustandscode | Zustand
1 | Starten
2 | Gestartet
3 | Beenden
4 | Beendet
5 | Anhalten
6 | Angehalten
7 | Fortsetzen

Microsoft Exchange Server Analyzer zeigt eine Warnung an, wenn die folgenden Bedingungen zutreffen:

  • Der SMTP-Dienst wird ausgeführt.

  • Alle virtuellen SMTP-Serverinstanzen auf dem Server wurden gestartet.

Diese Warnung weist darauf hin, dass der SMTP-Dienst und die virtuellen SMTP-Serverinstanzen zwar betriebsbereit zu sein scheinen, dass jedoch ein Problem, das weitere Untersuchungen erfordert, eine ordnungsgemäße Antwort der SMTP-Anschlüsse verhindert.

Mögliche Ursachen für dieses Problem:

  • Der SMTP-Dienst hat sich aufgehängt.

  • Eine Firewall oder Antivirenanwendung blockiert die Kommunikation mit den SMTP-Anschlüssen.

So beheben Sie dieses Problem

  • Starten Sie den SMTP-Dienst neu.

  • Überprüfen Sie die Konfiguration aller Firewalls oder Antivirenanwendungen im Hinblick auf die SMTP-Anschlüsse.

  • Überprüfen Sie die von Exchange Server Analyzer bereitgestellten Anweisungen und Links zu dem spezifischen Fehler.

So können Sie den SMTP-Dienst starten, anhalten oder beenden

  1. Klicken Sie auf das Menü Start, zeigen Sie auf Verwaltung, und klicken Sie dann auf Komponentendienste.

  2. Klicken Sie in der Konsolenstruktur auf Dienste (Lokal).

  3. Klicken Sie im Ergebnisbereich mit der rechten Maustaste auf Simple Mail Transfer Protocol (SMTP), und klicken Sie dann auf Starten, Beenden oder Anhalten.


Exchange Server 2007-Bereitschaft
Microsoft Exchange Server Analyzer-Tools - Artikel >

Letztes Änderungsdatum des Themas: 2006-07-18

Die Artikel in diesem Abschnitt enthalten Details über die Auswertungen von Microsoft® Exchange Server Analyzer in Bezug auf die Exchange Server 2007-Bereitschaft. Darüber hinaus werden in diesen Artikeln Aktionen beschrieben, die Sie durchführen können, um Fehler, Warnungen und vom Standard abweichende Konfigurationen im Zusammenhang mit Voraussetzungen beheben zu können, die von Microsoft Exchange Server Analyzer gefunden wurden.


Die Vererbung von Zugriffssteuerungslisten (Access Control List, ACL) ist blockiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-06-19

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil die erforderlichen Berechtigungen nicht propagiert werden konnten.

Das Setup von Exchange erfordert, dass die Vererbung von Berechtigungen für die Objekte der Öffentlichen Ordner-Struktur aktiviert ist.

Um dieses Problem zu beheben, vergewissern Sie sich, dass die Einstellung für die Propagierung von Berechtigungen an dieses Objekt und untergeordnete Objekte aktiviert ist, und führen Sie das Exchange Server 2007-Setup dann erneut aus.

So aktivieren Sie die Vererbung für die Öffentliche Ordner-Struktur erneut

  1. Öffnen Sie den Exchange Server 2003-System-Manager.

  2. Klicken Sie mit der rechten Maustaste auf den Informationsspeicher für Öffentliche Ordner, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf die Registerkarte Sicherheit, und aktivieren Sie dann das Kontrollkästchen Vererbbare Berechtigungen zulassen.


Die Active Directory-Schemaerweiterung erfordert, dass "Ldifde.exe" installiert ist
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-06-19

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, da der lokale Computer das Active Directory-Schema nicht aktualisieren kann.

Das Microsoft Exchange-Setup erfordert, dass Ldifde.exe auf dem lokalen Computer installiert ist, damit die erforderlichen Erweiterungen des Active Directory-Schemas vorgenommen werden können.

Um dieses Problem zu beheben, installieren Sie Ldifde.exe auf dem lokalen Computer, und führen Sie das Exchange Server 2007-Setup erneut aus, oder starten Sie das Exchange Server 2007-Setup von einem Domänencontroller aus.

Hinweis:
Nachdem das Active Directory-Schema erweitert wurde, können Exchange 2007-Serverfunktionen auf dem lokalen Computer installiert werden, ohne dass ldifde.exe installiert ist.
So installieren Sie "Ldifde.exe" auf dem lokalen Computer

  1. Klicken Sie auf Start und dann auf Ausführen, und führen Sie im Feld Öffnen den Befehl ServerManagerCmd -i RSAT-ADDS aus.


Der ADAM-Installationspfad ist vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-26

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil beim Versuch, ADAM (Active Directory Application Mode) zu installieren, ein Fehler aufgetreten ist.

Eine ältere Installation von ADAM ist am Standardspeicherort vorhanden. Das Exchange-Setup kann keine neue ADAM-Installation in einer vorhandenen ADAM-Verzeichnisstruktur vornehmen.

Um dieses Problem zu beheben, entfernen Sie den vorhandenen ADAM-Order und führen das Exchange-Setup erneut aus.


ADAM ist nicht auf dem lokalen Computer installiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-22

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil ADAM (Active Directory Application Mode) nicht auf diesem Computer installiert ist.

ADAM ist ein LDAP-Verzeichnisdienst (Lightweight Directory Access Protocol), der speziell für die Verwendung mit verzeichnisaktivierten Anwendungen entwickelt wurde. ADAM speichert und repliziert nur anwendungsspezifische Informationen. Der Dienst muss nicht auf einem Domänencontroller bereitgestellt werden und ist nicht vom Active Directory-Verzeichnisdienst abhängig. ADAM bietet keine Authentifizierung oder Autorisierung für das Netzwerkbetriebssystem.

In Exchange 2007 verwendet die Transport-Serverfunktion von Exchange ADAM zum Speichern von Konfigurationsinformationen. Wenn ADAM mit Active Directory synchronisiert wird, kann der Dienst auch für die Nachrichtensicherheit zum Durchführen von Empfängersuchen verwendet werden.

Das Setup von Microsoft Exchange erfordert, dass der ADAM-Dienst auf dem lokalen Computer installiert wird, bevor die Installation fortgesetzt werden kann.

Um dieses Problem zu beheben, installieren Sie ADAM Service Pack 1 (SP1) aus "Active Directory Application Mode (ADAM)" (http://go.microsoft.com/fwlink/?linkid=71063). Führen Sie Setup dann erneut aus.


ADAM ist nicht auf dem lokalen Computer (Longhorn) installiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-08-13

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil ADAM (Active Directory Application Mode) nicht auf diesem auf Windows Server 2008 basierenden Computer installiert ist.

ADAM ist ein LDAP-Verzeichnisdienst (Lightweight Directory Access Protocol), der speziell für die Verwendung mit verzeichnisaktivierten Anwendungen entwickelt wurde. ADAM speichert und repliziert nur anwendungsspezifische Informationen. Der Dienst muss nicht auf einem Domänencontroller bereitgestellt werden und ist nicht vom Active Directory-Verzeichnisdienst abhängig. ADAM bietet keine Authentifizierung oder Autorisierung für das Netzwerkbetriebssystem.

In Exchange 2007 verwendet die Transport-Serverfunktion von Exchange ADAM zum Speichern von Konfigurationsinformationen. Wenn ADAM mit Active Directory synchronisiert wird, kann der Dienst auch für die Nachrichtensicherheit zum Durchführen von Empfängersuchen verwendet werden.

Das Setup von Microsoft Exchange erfordert, dass der ADAM-Dienst auf dem lokalen Computer installiert wird, bevor die Installation fortgesetzt werden kann.

Um dieses Problem zu beheben, installieren Sie ADAM auf dem lokalen Computer, der das Betriebssystem Windows Server 2008 ausführt, und führen das Setup dann erneut aus.

So installieren Sie ADAM im Betriebssystem Windows Server 2008

  1. Klicken Sie auf Ausführen, und geben Sie dann den folgenden Befehl ein:

  2. cmd.exe /c start /w pkgmgr.exe /iu:"DirectoryServices-ADAM"

  3. Führen Sie das Exchange 2007-Setup erneut aus.


Warnung der Analyzer-Suchfunktion
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-08-09

Dieses Thema beschäftigt sich mit einem besonderen Problem, das vom Tool Exchange Server Analyzer angezeigt wird. Die Problembehandlung sollte nur auf Systeme angewendet werden, auf denen das Tool Exchange Server Analyzer ausgeführt wird und dieses spezielle Problem auftritt.

Das Tool Exchange Server Analyzer, das als kostenloser Download verfügbar ist, trägt remote Konfigurationsdaten von allen Servern in der Topologie zusammen und analysiert diese Daten automatisch. Der sich ergebende Bericht enthält ausführliche Informationen zu wichtigen Konfigurationskonflikten, möglichen Problemen und Produkteinstellungen, die nicht den Standardeinstellungen entsprechen. Indem Sie diese Empfehlungen beachten, können Sie bessere Leistung, Skalierbarkeit, Zuverlässigkeit und Betriebszeit erzielen.

Weitere Informationen zum Tool sowie zum Download der aktuellsten Version finden Sie unter "Microsoft Exchange Analyzers" unter der Adresse http://go.microsoft.com/fwlink/?linkid=34707.


Warnung zur 32-Bit-Kompatibilität
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-08-13

Das Setup von Microsoft Exchange Server 2007 zeigt diese Warnung an, weil Sie die 32-Bit-Version von Microsoft Exchange installieren.

Exchange 2007 steht in zwei Plattformversionen zur Verfügung: eine Plattformversion (die 64-Bit-Version) ist für Liveproduktionsumgebungen konzipiert, die andere Plattformversion (die 32-Bit-Version) für Umgebungen, die keine Produktionsumgebungen sind (z. B. Labore, Schulungseinrichtungen, Demo- und Auswertungsumgebungen). Nur die 64-Bit-Version kann käuflich erworben werden, weil 32-Bit-Servercomputer mit Exchange 2007 nicht in Produktionsumgebungen ausgeführt werden können.

Hinsichtlich der Verwendung der 32-Bit-Plattform in Produktions- und anderen Umgebungen gelten zwei Ausnahmen, weil Microsoft die minimal unterstützte Verwendung der 32-Bit-Version in Produktionsumgebungen erlaubt. Daher gilt Folgendes:

  • Sie können die 32-Bit-Version der Exchange-Verwaltungstools in Produktionsumgebungen zum Verwalten von Servercomputern mit Exchange 2007 über Windows Server 2003 oder Windows XP verwenden. Zum jetzigen Zeitpunkt können Sie weder die 32-Bit-Version noch die 64-Bit-Version unter Windows Vista oder unter Windows Server 2008 verwenden. Unterstützung für Windows Vista und Windows Server 2008 wird wahrscheinlich in Service Pack 1 für Exchange 2007 bereitgestellt.

  • Sie können die 32-Bit-Version von Setup in Produktionsumgebungen verwenden, um das Active Directory-Verzeichnisdienstschema zu erweitern. Ausführliche Anleitungen zum Vorbereiten von Active Directory für Exchange 2007, finden Sie unter "Vorbereiten von Active Directory und Domänen".

Alle anderen Verwendungen der 32-Bit-Version von Exchange 2007 in Produktionsumgebungen werden nicht unterstützt.

Wenn Sie die 32-Bit-Version der Exchange-Verwaltungstools herunterladen möchten, finden Sie diese unter "Microsoft Exchange Server 2007 Management Tools (32-Bit)" (http://go.microsoft.com/fwlink/?LinkId=82335). Weitere Informationen zu den Exchange 2007-Plattformversionen finden Sie unter "Exchange Server 2007: Plattformen, Editionen und Versionen" (http://go.microsoft.com/fwlink/?LinkId=88051) in der Exchange 2007-Produktdokumentation.


2007 Zeitzonenupdate für Microsoft Windows-Betriebssysteme muss installiert werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-02-20

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, da ein Update erforderlich ist, um die Einstellungen der Zeitzoneninformationen für diesen Computer zu korrigieren.

Das Exchange 2007-Setup setzt voraus, dass das im Microsoft Knowledge Base-Artikel 931836 erläuterte Zeitzonenupdate für Windows-Betriebssysteme installiert wird.

Um dieses Problem zu beheben, installieren Sie das im Microsoft Knowledge Base-Artikel 931836 "Kumulatives Zeitzonenupdate für Microsoft Windows-Betriebssysteme vom Februar 2007" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=931836) genannte Update, und führen Sie anschließend das Exchange 2007-Setup erneut aus.


Active Directory ist nicht vorhanden oder kann nicht kontaktiert werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-04-18

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, da keine Verbindung mit einem gültigen Standort des Active Directory-Verzeichnisdiensts hergestellt werden kann.

Für das Microsoft Exchange-Setup ist erforderlich, dass der Server, auf dem Microsoft Exchange installiert werden soll, den Konfigurationsnamenskontext in Active Directory finden kann.

Überprüfen Sie zum Beheben dieses Problems ob das Benutzerkonto, mit dem das Microsoft Exchange-Setup ausgeführt wird, an Active Directory angemeldet ist, und führen Sie das Setup von Microsoft Exchange erneut aus. Wenn das Problem hierdurch nicht behoben wird, befolgen Sie die Anweisungen für die Verwendung der Supporttools NETDIAG.Exe und DCDIAG.Exe in den Themen weiter unten, um eine weitergehende Diagnose des Problems zu erstellen.

Weitere Informationen zum Behandeln von Problemen und zur Konfiguration von Active Directory für Microsoft Exchange finden Sie in den folgenden Quellen:

  • "Troubleshooting Active Directory Operations" in Windows Server 2003: Operations (http://go.microsoft.com/fwlink/?LinkId=68099).

  • "Tools for Troubleshooting Active Directory" im Active Directory Operations Guide (http://go.microsoft.com/fwlink/?LinkId=68100).

  • "Konfigurationsnamenskontext" in "Arbeiten mit Active Directory-Berechtigungen in Exchange Server" (http://go.microsoft.com/fwlink/?LinkId=47592).

  • "Arbeiten mit Active Directory-Berechtigungen in Exchange Server" (http://go.microsoft.com/fwlink/?LinkId=47592).

  • "Überblick über Netdiag" (http://go.microsoft.com/fwlink/?LinkID=69481).

  • "Überblick über Dcdiag" (http://go.microsoft.com/fwlink/?LinkID=68936).


Active Directory-Domäne im gemischten Modus
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-08-10

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da sich eine vorhandene Active Directory-Domäne nicht im einheitlichen Modus Microsoft Windows®°2000 Server-Modus oder höher befindet.

Beim Setup von Exchange 2007 werden universelle Sicherheitsgruppen erstellt, die nur in Domänen vorhanden sein können, die sich nur im einheitlichen Windows 2000 Server-Modus oder höher befinden.

Verfahren Sie wie folgt, um dieses Problem zu beheben, indem Sie die Funktionsebene der Domäne mindestens auf die einheitliche Windows 2000 Server-Ebene heraufstufen und anschließend das Setup von Exchange 2007 erneut ausführen.

So stufen Sie die Funktionsebene der Domäne herauf

  1. Öffnen Sie Active Directory-Domänen und -Vertrauensstellungen.

  2. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf die Domäne, deren Funktion Sie heraufstufen möchten, und klicken Sie dann auf Domänenfunktionsebene heraufstufen.

  3. Verwenden Sie unter Wählen Sie eine verfügbare Domänenfunktionsebene eines der folgenden Verfahren:

    • Um die Domänenfunktionsebene auf Windows 2000 Server im einheitlichen Modus heraufzustufen, klicken Sie auf Windows 2000 pur und anschließend auf Heraufstufen.

    • Um die Domänenfunktionsebene auf Windows Server® 2003 heraufzustufen, klicken Sie auf Windows Server 2003 und anschließend auf Heraufstufen.
Achtung:

Wenn Domänencontroller vorhanden oder geplant sind, auf denen NT® 4.0 oder früher ausgeführt wird, sollten Sie die Domänenfunktionsebene nicht auf den einheitlichen Windows 2000 Server-Modus heraufstufen. Nachdem die Domänenfunktionsebene auf Windows 2000 Server im einheitlichen Modus heraufgestuft wurde, kann sie nicht in den gemischten Modus von Windows 2000 Server zurückgeändert werden.

Wenn Domänencontroller vorhanden oder geplant sind, auf denen Windows NT 4.0 oder früher oder Windows 2000 Server ausgeführt wird, sollten Sie die Domänenfunktionsebene nicht auf Windows Server 2003 heraufstufen. Nachdem die Domänenfunktionsebene auf Windows Server 2003 festgelegt wurde, kann sie nicht zum einheitlichen Modus oder gemischten Modus von Windows 2000 Server zurückgeändert werden.


Active Directory-Vorbereitung erforderlich
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-26

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil beim Versuch, die Domäne vorzubereiten, ein Fehler aufgetreten ist.

Das Setup von Exchange erfordert, dass der Active Directory-Verzeichnisdienst für Exchange Server 2007 geändert werden muss, bevor Domänen in Active Directory vorbereitet werden können.

Um dieses Problem zu beheben, bereiten Sie Active Directory mit dem Befehl Setup /PrepareAD vor und bereiten dann die Domänen vor.

Weitere Informationen zum Durchführen des PrepareAD-Vorgangs finden Sie unter "Vorbereiten von Active Directory und Domänen" (http://go.microsoft.com/fwlink/?LinkId=78453).


ADAM-Port wird bereits verwendet
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-06

Das Setupprogramm von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da beim Versuch, die Funktion Gatewayserver zu installieren, erkannt wurde, dass die der Active Directory®-Application Mode-Synchronisierung (ADAM) zugewiesenen Ports bereits verwendet werden.

ADAM ist ein LDAP-Verzeichnisdienst (Lightweight Directory Access Protocol), der speziell für die Verwendung mit verzeichnisaktivierten Anwendungen entwickelt wurde. ADAM speichert und repliziert nur anwendungsspezifische Informationen. Der Dienst muss nicht auf einem Domänencontroller bereitgestellt werden und ist nicht vom Active Directory-Verzeichnisdienst abhängig. ADAM bietet keine Authentifizierung oder Autorisierung für das Netzwerkbetriebssystem.

In Exchange 2007 verwendet der Gatewayserver ADAM zum Speichern von Konfigurationsinformationen. Wenn ADAM mit dem Active Directory-Verzeichnisdienst synchronisiert wird, kann der Dienst auch für die Nachrichtensicherheit zum Durchführen von Empfängersuchen verwendet werden.

Für das Setupprogramm von Microsoft Exchange ist erforderlich, dass bestimmte Ports verfügbar (nicht belegt sind), damit diese dem ADAM-Synchronisierungsprozess zugewiesen werden können, wenn die Funktion Gatewayserver installiert wird.

Zum Beheben dieses Problems müssen Sie den Prozess bestimmen und beenden, der die von ADAM benötigten Ports belegt, oder das Exchange 2007-Setup mit Befehlszeilenparametern ausführen, welche die standardmäßigen ADAM-Portzuweisungen außer Kraft setzen.

So führen Sie das Setup zur Außerkraftsetzung der standardmäßigen ADAM-Portzuweisungen aus

  1. Geben Sie an der Eingabeaufforderung den folgenden Befehl ein:

    Setup.exe /adamport:xxxx /adamsslport:yyyy

    • /adamport:<Die ADAM zuzuweisende Portnummer>

    • /adamsslport:<Die ADAM zuzuweisende Portnummer>


Öffentliche Ordner-Hierarchie für Anwendungen vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-05

Microsoft® Exchange Server Analyzer sucht in der Domäne des Active Directory®-Verzeichnisdienstes Öffentliche Ordner-Hierarchien für Anwendungen. Wenn Exchange Server Analyzer feststellt, dass andere Strukturen für Öffentliche Ordner als MAPI-Strukturen vorhanden sind, zeigt Exchange Server Analyzer eine Warnung an, die darauf hinweist, dass in der Exchange-Organisation Hierarchien für Öffentliche Ordner vorhanden sind, die keine MAPI-Strukturen sind. Diese benutzerdefinierten Anwendungsstrukturen werden in Exchange Server 2007 nicht unterstützt.

Strukturen für Öffentliche Ordner, die keine MAPI-Strukturen sind, werden für die Entwicklung benutzerdefinierter Anwendungen verwendet. Diese Strukturen kommen in Microsoft Exchange 2000 Server und Microsoft Exchange Server 2003 vor, werden aber in Exchange 2007 nicht unterstützt. Es wird empfohlen, dass Sie vor der Bereitstellung von Exchange 2007 eine der folgenden Maßnahmen durchführen:

  • Verschieben der Strukturen für Öffentliche Ordner, die keine MAPI-Strukturen sind, auf einen SharePoint Portal-Server

  • Belassen der Daten auf dem Exchange 2003-Server

Weitere Informationen zu den verschiedenen Hierarchien für Öffentliche Ordner finden Sie unter "Selecting the Appropriate Client for Exchange Public Folder Access" ( ).


Der Name des Active Directory-Standorts kann nicht bestimmt werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-06

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da dieser Server anscheinend nicht zu einem gültigen Standort des Verzeichnisdiensts Active Directory® gehört.

Für das Microsoft Exchange-Setup ist erforderlich, dass der Server, auf dem Exchange 2007 installiert werden soll, zu einem gültigen Active Directory-Standort gehört.

Überprüfen Sie zum Beheben dieses Problems, ob der lokale Server zu einem Active Directory-Standort gehört, und führen Sie das Setup von Exchange 2007 erneut aus.

Mithilfe des Parameters /DsGetSite des Befehlszeilenprogramms Nltest.exe können Sie die Standortzugehörigkeit anzeigen und überprüfen. Weitere Informationen finden Sie unter "Nltest.exe: NLTest Overview" im Abschnitt "Tools and Settings Collection" von Windows Server 2003 Technical Reference (http://go.microsoft.com/fwlink/?LinkId=27734).

Weitere Informationen zur Behandlung von Active Directory-Problemen finden Sie unter "Troubleshooting Active Directory Operations" in Windows Server 2003: Operations (http://go.microsoft.com/fwlink/?linkid=68099).


Empfängeraktualisierungsdienst nicht gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-05-16

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da der für eine Domäne zuständige Empfängeraktualisierungsdienst in der vorhandenen Exchange-Organisation nicht gefunden werden kann.

Das Microsoft Exchange-Setup fordert an, dass jede Domäne in der vorhandenen Exchange-Organisation eine Instanz des Empfängeraktualisierungsdiensts aufweist.

Wenn eine Instanz des Empfängeraktualisierungsdiensts für eine Domäne fehlt, erhalten neue in der Domäne erstellte Benutzerobjekte die für sie ausgestellten E-Mail-Nachrichten nicht.

Um dieses Problem zu beheben, stellen Sie sicher, dass eine Instanz des Empfängeraktualisierungsdiensts für jede Domäne vorhanden ist. Erstellen Sie eine Instanz des Empfängeraktualisierungsdiensts für die Domänen, die über keine verfügen, und führen Sie das Microsoft Exchange-Setup erneut aus.

So erstellen Sie eine Instanz des Empfängeraktualisierungsdiensts für eine Domäne

  1. Öffnen Sie den Exchange-System-Manager.

  2. Erweitern Sie Empfänger.

  3. Klicken Sie mit der rechten Maustaste auf den Knoten Empfängeraktualisierungsdienste, klicken Sie auf Neu und dann auf Empfängeraktualisierungsdienst.

  4. Klicken Sie im Fenster Neues Objekt auf Durchsuchen, um zum Namen der Domäne zu wechseln.

  5. Wählen Sie den Namen der Domäne aus, und klicken Sie dann auf OK.

  6. Klicken Sie im Fenster Neues Objekt auf Weiter und anschließend auf Fertig stellen.

Weitere Informationen zum Empfängeraktualisierungsdienst finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • Informationen dazu, wie der Empfängeraktualisierungsdienst Empfängerrichtlinien anwendet (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • Informationen, wie der Empfängeraktualisierungsdienst Adresslisten auffüllt (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828).

  • "Überprüfen des Fortschritts des Empfängeraktualisierungsdiensts von Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127).

  • "Aufgaben, die von dem Empfängeraktualisierungsdienst von Exchange ausgeführt werden" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770).


Postfachdatenbank kann nicht entfernt werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-06-20

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, da der Vorgang zum Deinstallieren der Serverfunktion Mailbox eine Benutzerpostfach-Datenbank (d. h. einen Informationsspeicher) nicht ohne potenziellen Datenverlust vom lokalen Server entfernen kann.

Das Exchange 2007-Setup prüft, ob alle Postfachspeicher vom Server entfernt wurden, bevor die Serverfunktion Mailbox entfernt wird. Benutzerpostfächer sind jedoch ggf. weiterhin auf dem Server vorhanden.

Um dieses Problem zu beheben, verschieben oder deaktivieren Sie alle Benutzerpostfächer auf dem Server und führen das Exchange 2007-Setup erneut aus.

Weitere Informationen zum Identifizieren von Postfächern in der Datenbank finden Sie in der Exchange Server 2007-Produktdokumentation unter "Get-Mailbox" (http://go.microsoft.com/fwlink/?LinkId=93470).

Weitere Informationen zum Deaktivieren eines Postfachs finden Sie unter "Deaktivieren eines Postfachs" (http://go.microsoft.com/fwlink/?LinkId=93471) in der Exchange Server 2007-Produktdokumentation.

Weitere Informationen zum Entfernen von Postfachdatenbanken in Exchange Server 2007 finden Sie unter "Entfernen einer Postfachdatenbank" (http://go.microsoft.com/fwlink/?LinkId=93473) in der Exchange Server 2007-Produktdokumentation.

Weitere Informationen zur Verwaltung von Datenbankinformationsspeichern für Benutzerpostfächer und Replikaten finden Sie im Abschnitt "Verwalten von Postfachspeichern und Informationsspeichern für Öffentliche Ordner" im Exchange Server 2003-Administratorhandbuch (http://go.microsoft.com/fwlink/?LinkId=47617).


Öffentliche Ordner-Datenbank kann nicht entfernt werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-01-23

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da der Vorgang zum Deinstallieren der Serverfunktion Mailbox eine Öffentliche Ordner-Datenbank Datenverlust ohne potenziellen nicht entfernen kann.

Für das Setup von Exchange 2007 ist erforderlich, dass die Öffentliche Ordner-Datenbank vom Server entfernt wird, bevor die Serverfunktion Mailbox entfernt wird.

Replikate von Öffentlichen Ordnern dürfen auf dem Server verbleiben, oder die Öffentliche Ordner-Datenbank kann ggf. die letzte in der Exchange-Organisation sein.

Um dieses Problem zu beheben, verschieben oder löschen Sie die Öffentliche Ordner-Datenbank auf dem Server und führen das Exchange Server 2007-Setup erneut aus.

Weitere Informationen zum Entfernen von Öffentlichen Ordner-Datenbanken in Exchange Server 2007 finden Sie unter "Entfernen einer Datenbank für Öffentliche Ordner" (https://www.microsoft.com/technet/prodtechnol/exchange/E2k7/DE/Help/ExchHelp/5e1e9fbc-53d5-44e3-9b47-6873be84e6ee.mspx?mfr=true).

Weitere Informationen zur Verwaltung von Öffentlichen Ordner-Datenbank und Replikaten finden Sie im Abschnitt "Verwalten von Postfachspeichern und Informationsspeichern für Öffentliche Ordner" im Exchange Server 2003-Administratorhandbuch (http://go.microsoft.com/fwlink/?LinkId=47617).


Die Serverfunktion "UnifiedMessaging" kann nicht entfernt werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-26

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil beim Versuch, die Serverfunktion UnifiedMessaging zu deinstallieren, ein Fehler aufgetreten ist.

Das Exchange 2007-Setup überprüft, ob die zu deinstallierende Serverfunktion UnifiedMessaging als Host für die Dateifreigabe für Telefonansagen für einen Wählplan fungiert und ob dieser Wählplan mit anderen Servern verbunden ist.

Wenn die Serverfunktion UnifiedMessaging als Host für die Dateifreigabe für Telefonansagen für einen Wählplan fungiert, tritt bei der Deinstallation ein Fehler auf.

Um dieses Problem zu beheben, verschieben Sie die Dateifreigabe für Telefonansagen auf einen anderen Server, und führen Sie das Exchange 2007-Setup dann erneut aus.

Weitere Informationen zum Verschieben der Dateifreigabe für Telefonansagen für einen Wählplan finden Sie unter "Ändern der Dateifreigabe für Telefonansagen" (http://go.microsoft.com/fwlink/?LinkId=82356).


In den CMS-Datenpfad kann nicht geschrieben werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-26

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, da beim Versuch der Installation der Clusterserverfunktion Mailbox auf einem freigegebenen Clusterlaufwerk ein Fehler aufgetreten ist.

Das Exchange-Setup konnte nicht in den für den Parameter /CMSDataPath angegebenen Zielinstallationspfad schreiben. Das Setup von Exchange erfordert, dass sich der Zielpfad für die Daten des Postfachclusterservers auf einem beschreibbaren Volume befindet.

Um dieses Problem zu beheben, geben Sie einen Zielpfad für /CMSDataPath an, der sich auf einem beschreibbaren Speichermedium befindet.

Weitere Informationen zum Installieren des Postfachclusterservers finden Sie in der Exchange Server 2007-Produktdokumentation unter "Installieren der Serverfunktion "Mailbox" auf dem aktiven Knoten" (http://go.microsoft.com/fwlink/?LinkId=86624).


In den Exchange-Organisationscontainer kann nicht geschrieben werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-05-04

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil der angemeldete Benutzer nicht über die Kontoberechtigungen verfügt, die zum Schreiben in den Organisationscontainer im Active Directory-Verzeichnisdienst benötigt werden.

Für das Microsoft Exchange-Setup ist erforderlich, dass der bei der Installation von Exchange 2007 angemeldete Benutzer über die Berechtigung Exchange-Administrator oder Exchange-Organisationsadaministrator verfügt.

Während des Installationsvorgangs muss das Exchange 2007-Setup ggf. Objekte im Microsoft Exchange-Organisationscontainer erstellen.

Zum Beheben dieses Problems gewähren Sie dem angemeldeten Benutzer die oben genannten Berechtigungen, oder melden Sie sich mit einem Konto an, das über diese Berechtigungen verfügt, und führen Sie das Setup von Exchange 2007 erneut aus.

Wichtig:
Die gesamtstrukturübergreifende Installation von Exchange 2007 wird nicht unterstützt. Verwenden Sie ein Konto, das Mitglied der Active Directory-Gesamtstruktur ist, in der Sie Exchange 2007 installieren.

Weitere Informationen zu den in Microsoft Exchange benötigten Active Directory-Berechtigungen finden Sie in "Arbeiten mit Active Directory-Berechtigungen in Exchange Server" unter http://go.microsoft.com/fwlink/?LinkId=47592.


Serverfunktion "ClientAccess" nicht am lokalen Standort gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-06

Das Setup von Microsoft® Exchange Server 2007 zeigt diese Warnung an, da eine vorhandene ClientAccess-Serverfunktion nicht am lokalen Standort des Verzeichnisdiensts Active Directory® gefunden wurde.

Sie haben ausgewählt, die Serverfunktion Mailbox zu installieren, bevor eine Instanz der Serverfunktion ClientAccess am Active Directory-Standort installiert wurde.

Die Serverfunktion ClientAccess akzeptiert Verbindungen mit Ihrem Server mit Exchange 2007 von einer Vielzahl unterschiedlicher Clients aus. Softwareclients wie Microsoft Outlook Express und Eudora kommunizieren über POP3- oder IMAP4-Verbindungen mit dem Server mit Exchange. Hardwareclients wie mobile Geräte kommunizieren über ActiveSync, POP3 oder IMAP4 mit dem Server mit Exchange.

Wenn Benutzer auf ihren Posteingang mittels eines anderen Clients als Microsoft Office Outlook® zugreifen, müssen Sie die Serverfunktion ClientAccess in Ihrer Exchange-Organisation installieren.

Benutzer können sich über Outlook an ihren Postfächern anmelden, jedoch nicht Outlook Web Access oder mobile Geräte für dasselbe Postfach verwenden, solange die Serverfunktion ClientAccess nicht am lokalen Active Directory-Standort vorhanden ist.


Verwaltete Clusterressourcen müssen verschoben oder offline geschaltet werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-04-09

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil beim Versuch, die Serverfunktion Mailbox für einen neuen aktiven Cluster zu installieren, ein Fehler aufgetreten ist.

Exchange Server 2007 erfordert, dass clusterverwaltete Ressourcen inaktiv auf dem Clusterknoten sein müssen, für den die Installation ausgeführt wird.

Um dieses Problem zu beheben, verschieben Sie alle clusterverwalteten Ressourcen, die sich im Besitz dieses Knotens befinden (einschließlich der Nicht-Exchange Server-Clusterressourcen), auf einen anderen Knoten im Cluster. Alternativ können Sie sie auch offline schalten und Setup dann erneut ausführen.

Weitere Informationen zum Verschieben von mit Exchange in Beziehung stehenden verwalteten Clusterdiensten finden Sie in der Exchange Server 2007-Produktdokumentation unter dem Thema zum Cmdlet "Move-ClusteredMailboxServer" (http://go.microsoft.com/fwlink/?LinkId=86627).

Weitere Informationen zum Offlineschalten von mit Exchange in Beziehung stehenden verwalteten Clusterdiensten finden Sie in der Exchange Server 2007-Produktdokumentation unter dem Thema zum Cmdlet "Stop-ClusteredMailboxServer" (http://go.microsoft.com/fwlink/?LinkId=86635).

Weitere Informationen zum Verwalten von Nicht-Exchange-Clusterressourcen finden Sie unter "Verwalten von Ressourcen" (http://go.microsoft.com/fwlink/?LinkId=86637) in der Windows Server 2003-Produkthilfe.


Der Clusterdienst ist nicht gestartet
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-26

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil der Microsoft Windows Server-Clusterdienst nicht gestartet wurde.

Für das Setup von Exchange 2007 ist erforderlich, dass der Clusterdienst gestartet wird, wenn der Clusterdienst auf dem lokalen Computer installiert ist.

Um dieses Problem zu beheben, starten Sie den Clusterdienst auf dem lokalen Computer und führen das Exchange-Setup dann erneut aus.

Weitere Informationen zum Starten des Clusterdiensts finden Sie unter "Starten des Clusterdiensts" (http://go.microsoft.com/fwlink/?LinkId=86638) in der technischen Bibliothek für Windows Server 2003.


Clusterupdate erforderlich (KB921181)
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-08-11

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da ein Update für den Clusterknoten erforderlich ist.

Für das Exchange 2007-Setup ist erforderlich, dass das im Microsoft Knowledge Base-Artikel 921181 erläuterte Clustenknotenupdate installiert wird.

Um dieses Problem zu beheben, installieren Sie das im Microsoft Knowledge Base-Artikel 921181, "Ein verfügbares Update fügt Windows Server 2003 Service Pack 1-basierten Serverclustern ein Dateifreigabezeugen-Feature und ein Feature zum Konfigurieren von Clustertakten hinzu" (http://go.microsoft.com/fwlink/?LinkId=69785) erläuterte Update, und führen Sie das Setup von Exchange 2007 anschließend erneut aus.


Der CMS-Datenpfad muss sich auf einem NTFS-Volume befinden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-26

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, da beim Versuch der Installation der Clusterserverfunktion Mailbox auf einem freigegebenen Clusterlaufwerk ein Fehler aufgetreten ist.

Der für den Parameter /CMSDataPath übermittelte Zielinstallationspfad befindet sich nicht auf einem NTFS-Volume. Das Setup von Exchange erfordert, dass sich der Zielpfad für die Daten des Postfachclusterservers auf einem NTFS-Volume befindet.

Um dieses Problem zu beheben, wählen Sie einen anderen Zielpfad für /CMSDataPath aus, oder konvertieren Sie das Zielvolume in NTFS, und führen Sie dann das Exchange 2007-Setup erneut aus.

Weitere Informationen zum Konvertieren eines Volumes in NTFS finden Sie im Thema "Konvertieren" (http://go.microsoft.com/fwlink/?LinkId=86642) in der Windows XP Professional-Produktdokumentation.


Der aktuelle Clusterknoten ist im Besitz der Dienste zur Clusterverwaltung
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-04-09

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil beim Versuch, den passiven Knoten des Clusters zu deinstallieren, ein Fehler aufgetreten ist.

Die Exchange-Dienste zur Clusterverwaltung befinden sich im Besitz dieses Clusterknotens. Das Setup von Exchange 2007 erfordert, dass die Exchange-Dienste zur Clusterverwaltung verschoben werden, bevor die Exchange-Dateien entfernt werden können.

Um dieses Problem zu beheben, verschieben Sie alle clusterverwalteten Ressourcen, die sich im Besitz dieses Knotens befinden (einschließlich der Nicht-Exchange Server-Clusterressourcen), auf einen anderen Knoten im Cluster, oder schalten Sie sie offline. Führen Sie das Setup dann erneut aus.

Weitere Informationen zum Verschieben von mit Exchange in Beziehung stehenden verwalteten Clusterdiensten finden Sie in der Exchange Server 2007-Produktdokumentation unter dem Thema zum Cmdlet "Move-ClusteredMailboxServer" (http://go.microsoft.com/fwlink/?LinkId=86627).

Weitere Informationen zum Offlineschalten von mit Exchange in Beziehung stehenden verwalteten Clusterdiensten finden Sie in der Exchange Server 2007-Produktdokumentation unter dem Thema zum Cmdlet "Stop-ClusteredMailboxServer" (http://go.microsoft.com/fwlink/?LinkId=86635).

Weitere Informationen zum Verwalten von Nicht-Exchange-Clusterressourcen finden Sie unter "Verwalten von Ressourcen" (http://go.microsoft.com/fwlink/?LinkId=86637) in der Windows Server 2003-Produkthilfe.


Der COM+-Ereignissystemdienst muss gestartet werden, bevor Setup fortgesetzt werden kann
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-16

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, da beim Versuch der Installation der Serverfunktion ClientAccess bzw. Edge-Transport ein Fehler aufgetreten ist, weil der COM+-Ereignissystemdienst auf dem Zielcomputer nicht gestartet wurde.

Das Setup von Exchange 2007 erfordert, dass auf dem Computer, auf dem Sie Microsoft Exchange installieren, der Status des COM+-Ereignissystemdiensts auf Gestartet festgelegt ist.

Der COM+-Ereignissystemdienst unterstützt die Systemereignisbenachrichtigung für COM+-Komponenten, die die automatische Verteilung von Ereignissen an abonnierende COM-Komponenten bereitstellen.

Die Serverfunktionen ClientAccess und Edge-Transport hängen von COM+-Komponenten ab, die den COM+-Ereignissystemdienst abonnieren.

Um dieses Problem zu beheben, vergewissern Sie sich, dass der Status des COM+-Ereignissystemdiensts auf dem lokalen Computer auf Gestartet festgelegt ist, und führen anschließend das Microsoft Exchange-Setup erneut aus.

So legen Sie den Status des COM+-Ereignissystemdiensts auf "Gestartet" fest

  1. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und klicken Sie dann auf Verwalten.

  2. Erweitern Sie den Knoten Dienste und Anwendungen, und klicken Sie dann auf den Knoten Dienste.

  3. Suchen Sie im rechten Bereich das Com+-Ereignissystem.

  4. Klicken Sie mit der rechten Maustaste auf Com+-Ereignissystem, und klicken Sie dann auf Eigenschaften.

  5. Legen Sie den Starttyp auf Automatisch und Dienststatus auf Gestartet fest.

  6. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.


Es wurde ein komplexes Exchange-Organisationsmodell erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-08-10

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um die Anzahl der Routinggruppen in der Exchange Server-Organisation zu ermitteln. Außerdem fragt Exchange Server Analyzer Active Directory ab, um die Anzahl der Active Directory-Standortes zu ermitteln, an denen Exchange-Server mit Microsoft Exchange 2000 Server oder Microsoft Exchange Server 2003 vorhanden sind.

Exchange Server Analyzer kategorisiert die Exchange-Organisation als komplexe Exchange-Organisation, wenn die folgenden Bedingungen erfüllt sind:

  • Es ist mehr als eine Active Directory-Gesamtstruktur vorhanden.

  • Microsoft Identity Integration Server (MIIS) ist in einer oder mehreren Gesamtstrukturen installiert.

Von den vier definierten Organisationsmodellen für Microsoft Exchange Server 2007 stellt die komplexe Exchange-Organisation das einzige Modell dar, das mehrere Active Directory-Gesamtstrukturen beinhaltet oder in dem die Synchronisierungstechnologie eingesetzt wird.

So führen Sie den Übergang einer komplexen Exchange-Organisation zu Exchange 2007 durch

  1. Rufen Sie die Onlinedokumentation zu Exchange 2007 auf (http://go.microsoft.com/fwlink/?LinkId=69434).

  2. Lesen Sie das Thema "Planung für eine komplexe Exchange-Organisation" (http://go.microsoft.com/fwlink/?LinkId=70505).


Standardwebsite nicht auf dem lokalen Computer gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-06

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da kein Zugriff auf die Standardwebsite auf diesem Server möglich ist.

Für das Microsoft Exchange-Setup ist erforderlich, dass bei der Installation der Serverfunktion ClientAccess auf die von Microsoft Internetinformationsdienste (IIS) erstellte Standardwebsite zugegriffen wird.

Die Serverfunktion ClientAccess bietet Funktionalität für den Clientzugriff, z. B. für Microsoft Office Outlook® (bei Verbindungen über HTTP), Outlook Web Access, Exchange ActiveSync® und Clients, welche die Protokolle POP3 und IMAP4 verwenden.

IIS fungiert als Protokollmodul für die Protokolle HTTP, POP3, IMAP4, SMTP (Simple Mail Transfer Protocol) und NNTP (Network News Transfer Protocol).

Es kann vorkommen, dass die IIS-Standardwebsite nicht mehr vorhanden ist, da sie ggf. gelöscht oder in einen anderen Namen als "Standardwebsite" umbenannt wurde.

Um dieses Problem zu beheben, müssen Sie IIS auf diesem Server zuerst de- und anschließend neu installieren. Führen Sie anschließend das Exchange 2007-Setup erneut aus.

Wichtig:
IIS muss zum Beheben dieses Problems zuerst de- und anschließend neu installiert werden. Es reicht nicht aus, das Verzeichnis neu zu erstellen oder umzubenennen.
So deinstallieren Sie IIS über die Option "Software" in der Systemsteuerung

  1. Klicken Sie im Menü Start auf Systemsteuerung.

  2. Doppelklicken Sie auf Software.

  3. Klicken Sie auf Windows-Komponenten hinzufügen/entfernen.

  4. Aktivieren Sie in der Liste Komponenten das Kontrollkästchen Anwendungsserver.

  5. Klicken Sie auf Details.

  6. Deaktivieren Sie Internetinformationsdienste-Manager.

  7. Klicken Sie auf Weiter.

  8. Klicken Sie auf Fertig stellen, wenn IIS deinstalliert ist.
So installieren Sie IIS über die Systemsteuerung

  1. Klicken Sie im Menü Start auf Systemsteuerung.

  2. Doppelklicken Sie auf Software.

  3. Klicken Sie auf Windows-Komponenten hinzufügen/entfernen.

  4. Aktivieren Sie in der Liste Komponenten das Kontrollkästchen Anwendungsserver.

  5. Klicken Sie auf Details.

  6. Aktivieren Sie das Kontrollkästchen Internetinformationsdienste-Manager.

  7. Klicken Sie OK, bis Sie zum Assistenten für Windows-Komponenten zurückkehren.

  8. Klicken Sie auf Weiter, und schließen Sie den Assistenten für Windows-Komponenten ab.


Der DTC-Dienst (Distributed Transaction Coordinator) muss gestartet werden, bevor Setup fortgesetzt werden kann
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-16

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, da beim Versuch der Installation der Serverfunktion ClientAccess bzw. UnifiedMessaging ein Fehler aufgetreten ist, weil der DTC-Dienst (Distributed Transaction Coordinator) auf dem Zielcomputer nicht gestartet wurde.

Das Setup von Exchange 2007 erfordert, dass auf dem Computer, auf dem Sie Microsoft Exchange installieren, der Status des DTC-Diensts (Distributed Transaction Coordinator) auf Gestartet festgelegt ist.

Der DTC-Dienst stellt Dienste zur Verfügung, die erfolgreiche und vollständige Transaktionen selbst bei Systemfehlern, Prozessfehlern und Kommunikationsfehlern sicherstellen.

Jeder Computer, der an einer verteilten Transaktion teilnimmt, verwaltet seine eigenen Ressourcen und Daten und agiert außerdem im Zusammenspiel mit anderen Computern in der Transaktion. Das wichtigste bei einer verteilten Transaktion ist, dass diese vollständig auf allen teilnehmenden Computern übergeben oder abgebrochen werden muss. DTC (Distributed Transaction Coordinator) führt die Transaktionskoordinationsfunktion für die beteiligten Komponenten aus und fungiert als Transaktions-Manager für jeden Computer, der Transaktionen verwaltet.

Die Serverfunktionen ClientAccess und UnifiedMessaging sind vom DTC-Dienst abhängig.

Um dieses Problem zu beheben, vergewissern Sie sich, dass der Status des DTC-Diensts auf dem lokalen Computer auf Gestartet festgelegt ist, und führen anschließend das Microsoft Exchange-Setup erneut aus.

So legen Sie den Status des DTC-Diensts auf "Gestartet" fest

  1. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und klicken Sie dann auf Verwalten.

  2. Erweitern Sie den Knoten Dienste und Anwendungen, und klicken Sie dann auf den Knoten Dienste.

  3. Suchen Sie im rechten Bereich nach Distributed Transaction Coordinator.

  4. Klicken Sie mit der rechten Maustaste auf Distributed Transaction Coordinator, und klicken Sie dann auf Eigenschaften.

  5. Legen Sie den Starttyp auf Automatisch und Dienststatus auf Gestartet fest.

  6. Klicken Sie auf Übernehmen, und klicken Sie dann auf OK.


Das DNS-Suffix ist auf dem lokalen Computer nicht festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-05

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da der vollqualifizierte Domänenname des lokalen Computers nicht festgelegt ist.

Das Exchange 2007-Setup fordert an, dass der lokale Computer über ein gültiges festgelegtes DNS-Suffix (Domain Name System) verfügt

Um dieses Problem zu beheben, legen Sie das DNS-Suffix für den lokalen Computer fest und führen das Exchange 2007-Setup erneut aus.

So legen Sie das primäre DNS-Suffix auf dem lokalen Computer fest

  1. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und klicken Sie dann auf Eigenschaften. Das Dialogfeld Systemeigenschaften wird angezeigt.

  2. Klicken Sie auf die Registerkarte Computername.

  3. Klicken Sie auf Ändern. Das Dialogfeld Computernamen ändern wird angezeigt.

  4. Klicken Sie auf Weiter. Das Dialogfeld DNS-Suffix und NetBIOS-Computername wird angezeigt.

  5. Geben Sie das entsprechende DNS-Suffix für die Domäne ein.

  6. Aktivieren Sie das Kontrollkästchen Primäres DNS-Suffix bei Domänenmitgliedschaftsänderung ändern.

  7. Klicken Sie auf OK, um die Änderungen zu speichern und dann nochmals auf OK, um das Dialogfeld Computernamen ändern zu schließen.

  8. Klicken Sie auf OK, um das Dialogfeld Systemeigenschaften zu schließen, und starten Sie den Computer anschließend neu, damit die Änderung wirksam wird.

Weitere Informationen zu DNS-Namen finden Sie im Microsoft Knowledge Base-Artikel 909264 mit Informationen zu Benennungskonventionen in Active Directory für Computer, Domänen, Standorte und Organisationseinheiten (http://go.microsoft.com/fwlink/?linkid=3052&kbid=909264).


In der Registrierung ist das Außerkraftsetzen des Domänencontrollers festgelegt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-27

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil beim Versuch, den angegebenen Domänencontroller zu verwenden, ein Fehler aufgetreten ist. In der Registrierung wurde ein Domänencontroller statisch zugewiesen.

Das Setup von Exchange 2007 erfordert, dass der im Setup-Befehl angegebene Domänencontroller dem Domänencontroller entspricht, der mithilfe einer Außerkraftsetzung in der Registrierung statisch zugewiesen wurde.

Um dieses Problem zu beheben, führen Sie Setup erneut aus und geben dabei den statisch zugewiesenen Domänencontroller für den Parameter /DomainController: <FQDN des statisch zugewiesenen Domänencontrollers> an.

Weitere Informationen über DSAccess und die Erkennung von Verzeichnisdiensten finden Sie im Microsoft Knowledge Base-Artikel 250570, "Verzeichnisdienst-Servererkennung und DSAccess-Verwendung" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


Domänenvorbereitung erforderlich
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-27

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil beim Versuch, die Serverfunktion zu installieren, ein Fehler aufgetreten ist.

Das Setup von Microsoft Exchange erfordert, dass die lokale Domäne für Exchange Server 2007 vorbereitet wird, bevor bestimmte Serverfunktionen installiert werden können.

Die Vorbereitung der Domäne für Exchange Server 2007 besteht aus den folgenden Aufgaben:

  • Festlegen der Berechtigungen für den Domänencontainer für die Servercomputer mit Exchange Server, die Exchange-Organisationsadministratoren, die authentifizierten Benutzer und die Exchange-Postfachadministratoren.

  • Erstellen des Microsoft Exchange-Systemobjektecontainers (wenn dieser nicht bereits vorhanden ist) und Festlegen der Berechtigungen für diesen Container für die Servercomputer mit Exchange Server, die Exchange-Organisationsadministratoren und die authentifizierten Benutzer.

  • Erstellen einer neuen globalen Domänengruppe namens Exchange Install Domain Servers in der aktuellen Domäne.

  • Hinzufügen der Gruppe Exchange Install Domain Servers zur universellen Sicherheitsgruppe Exchange-Server in der Stammdomäne.

Um dieses Problem zu beheben, führen Sie setup /PrepareDomain aus, um die Domäne vorzubereiten und dann einen erneuten Installationsversuch der Serverfunktion durchzuführen.

Weitere Informationen zum Durchführen des PrepareDomain-Vorgangs finden Sie unter "Vorbereiten von Active Directory und Domänen" (http://go.microsoft.com/fwlink/?LinkId=78453).


Die Serverfunktion "Edge-Transport" kann nicht auf dem lokalen Computer installiert werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-01-03

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da beim Versuch der Installation der Funktion Edge-Server festgestellt wurde, dass andere Microsoft Exchange-Serverfunktionen bereits auf diesem Server installiert sind.

Exchange 2007 kann die Funktion Edge-Server nicht auf einem Server installieren, auf dem andere Microsoft Exchange-Serverfunktionen installiert sind.

Die Microsoft Exchange-Funktion Edge-Server wird im Umkreisnetzwerk der Organisation bereitgestellt und verarbeitet die Nachrichtenübermittlung in das und aus dem Internet. Sie ver- und entschlüsselt Nachrichten, die zwischen vertrauenswürdigen Microsoft Exchange-Organisationen gesendet werden, und bietet einen Schutz gegen Spam.

Um dieses Problem zu beheben, installieren Sie die Funktion Edge-Server auf einem Computer, auf dem keine anderen Microsoft Exchange 2007-Funktionen installiert sind.


EDK-Connector in Topologie gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-04

Microsoft® Exchange Server Analyzer sucht im Active Directory®-Verzeichnisdienst nach EDK-Connectors (Exchange Development Kit) in der Exchange-Organisation. Wenn in Active Directory EDK-Connectors gefunden werden, zeigt Exchange Server Analyzer eine Warnung an, die darauf hinweist, dass EDK-Connectors in Microsoft Exchange Server 2007 nicht unterstützt werden.

Sie sollten sich in diesem Fall beim Hersteller nach einem Ersatzconnectorprodukt für Exchange 2007 erkundigen. Alternativ können Sie einen Exchange 2003- oder Microsoft Exchange 2000-Server behalten, damit der EDK-Connector unterstützt wird.

Hinweis:
Bei EDK-Connectors handelt es sich um Anwendungen von Drittanbietern, um Verbindungen zu Kommunikationssystemen wie Faxgeräten, SMS (Short Message Service) und Telex oder zu anderen Messagingsystemen wie Lotus Notes herzustellen, die einen Gatewayconnector verwenden. EDK (Exchange Development Kit) wird von anderen Herstellern als Microsoft für die Entwicklung von proprietären Connectors verwendet.


"Esm.dll" ist durch mindestens einen Prozess in Gebrauch
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-28

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil beim Versuch, den Server zu aktualisieren, ein Problem beim Modulzugriff aufgetreten ist.

Das Setup von Exchange 2007 erfordert, dass bestimmte Module nicht ausgeführt werden, damit die Aktualisierung die Binärdateien ändern kann. Die Datei "Esm.dll" gehört zu diesen Modulen.

Um dieses Problem zu beheben, entfernen Sie die Prozesse, die Esm.dll geöffnet haben, und führen Sie dann das Exchange 2007-Setup erneut aus.

So beenden Sie den Prozess, der "Esm.dll" geöffnet hat

  1. Starten Sie die Exchange-Verwaltungsshell.

  2. Verwenden Sie das Cmdlet Get-Process, um die Prozess-ID für die Prozesse zu ermitteln, die Exchange Analyzer identifiziert hat.

  3. Get-Process < Prozessname >

  4. Verwenden Sie das Cmdlet Stop-Process, um den Prozess zu beenden.

  5. Stop-Process < Prozess-ID >

  6. Dabei ist <process ID> der Prozess-ID-Wert, der vom Cmdlet Get-Process hier in Schritt 2 zurückgegeben wird.

Weitere Informationen zum Cmdlet Get-Process finden Sie unter Verwenden des Cmdlets "Get-Process" im Thema zu den Verwendungsbereichen der Windows PowerShell.


"ExchHelp.chm" ist geöffnet
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-16

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil beim Versuch, den Server zu aktualisieren, ein Problem beim Dateizugriff aufgetreten ist.

Das Setup von Exchange 2007 erfordert, dass bestimmte Dateien geschlossen sind, damit der Aktualisierungsvorgang die Dateien oder die Prozesse, die auf diese zugreifen, ändern kann. Die lokale Exchange-Hilfedatei (ExchHelp.chm) gehört zu diesen Dateien.

Um dieses Problem zu beheben, schließen Sie die Datei ExchHelp.chm und führen das Exchange 2007-Setup erneut aus.


Computer mit Exchange 2000 Server erfordern eine Aktualisierung auf SP3
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-27

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil mindestens ein Server in der vorhandenen Organisation Exchange 2000 Server ohne Service Pack 3 oder eine höhere Version ausführt.

Das Setup von Exchange 2007 erfordert, dass alle vorhandenen Computer mit Exchange 2000 Server in der Organisation Exchange 2000 Server Service Pack 3 (SP3) ausführen.

Um dieses Problem zu beheben, aktualisieren Sie alle vorhandenen Computer mit Exchange 2000 Server in der Organisation auf Exchange 2000 Server SP3 oder eine höhere Version, und führen Sie das Exchange 2007-Setup dann erneut aus.

Weitere Informationen zum Aktualisieren von Computern mit Exchange 2000 Server auf Exchange 2000 Server SP3 oder eine höhere Version finden Sie unter "Downloads für Exchange 2000 Server" (http://go.microsoft.com/fwlink/?LinkId=86647).


Exchange-Organisation ist im gemischten Modus
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-05

Microsoft® Exchange Server Analyzer fragt den Exchange-Organisationscontainer ab, um den Modus der Exchange-Organisation zu ermitteln. Exchange Server Analyzer überprüft dazu den Wert des msExchangeMixedMode-Attributs. Wenn der Wert des msExchangeMixedMode-Attributs True lautet, zeigt Exchange Server Analyzer einen Fehler an. Die Fehlermeldung weist darauf hin, dass sich die Exchange-Organisation im gemischten Modus befindet. Microsoft Exchange Server 2007 kann nur in einer Organisation installiert werden, die sich im einheitlichen Modus befindet. Sie müssen daher eine Organisation, die sich im gemischten Modus befindet, in den einheitlichen Modus versetzen, um eine Exchange 2007-Bereitstellung vorzubereiten.

Hinweis:
Eine Organisation im einheitlichen Modus kann nur Server mit Exchange 2000 oder höher enthalten.

Zur Vorbereitung einer Exchange 2007-Bereitstellung müssen Sie die Exchange-Organisation in den einheitlichen Modus konvertieren, indem Sie die folgenden Schritte ausführen:

  1. Entfernen oder Außerbetriebsetzen aller restlichen Exchange 5.5-Server

  2. Öffnen der Eigenschaften des Exchange-Organisationsobjekts in Exchange-System-Manager und Wechseln in den einheitlichen Modus

Weitere Informationen zum Konvertieren einer Exchange-Organisation in den einheitlichen Modus finden Sie unter "How to Convert from Mixed Mode to Native Mode in Exchange" unter http://go.microsoft.com/fwlink/?LinkId=56642 im Exchange Server Deployment Guide.

Weitere Informationen zum gemischten Modus und einheitlichen Modus für Microsoft Exchange finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 270143, "Unterschiede zwischen gemischtem Modus und einheitlichem Modus in Exchange 2000 Server und Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270143)

  • 327779, "Konvertierung vom gemischten Modus in den einheitlichen Modus in Exchange" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779)

  • 272314, "XADM: Vorbereiten einer Organisation im gemischten Modus für die Konvertierung in den einheitlichen Modus" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=272314)


Computer mit Exchange 2000 Server erfordern eine Aktualisierung auf SP2
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-27

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil mindestens ein Server in der vorhandenen Organisation Exchange Server 2003 ohne Service Pack 2 (oder eine höhere Version) ausführt.

Das Setup von Exchange 2007 erfordert, dass alle vorhandenen Computer mit Exchange Server 2003 in der Organisation Exchange Server 2003 Service Pack 2 (SP2) oder eine höhere Version ausführen.

Um dieses Problem zu beheben, aktualisieren Sie alle vorhandenen Computer mit Exchange Server 2003 in der Organisation auf Exchange Server 2003 SP2 oder eine höhere Version, und führen Sie das Exchange 2007-Setup dann erneut aus.

Weitere Informationen zum Aktualisieren von Computern mit Exchange Server 2003 auf Exchange Server 2003 SP2 oder eine höhere Version finden Sie unter "Downloads für Exchange Server 2003" (http://go.microsoft.com/fwlink/?LinkId=21030).


Exchange Server 2007 kann mit dieser Version von Windows nicht verwendet werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-27

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, da auf dem lokalen Computer keine Version des Betriebssystems Microsoft Windows Server ausgeführt wird, die mit Exchange Server 2007 unterstützt wird.

Das Setup von Exchange 2007-Setup erfordert, dass die Version von Windows Server auf dem lokalen Computer wie in den Exchange Server 2007-Systemanforderungen angegeben unterstützt werden muss, damit Exchange Server 2007 ausgeführt werden kann.

Um dieses Problem zu beheben, installieren Sie eine von Exchange Server 2007 unterstützte Version des Betriebssystems Windows Server auf dem lokalen Computer, oder installieren Sie Exchange Server 2007 auf einem Computer, der eine unterstützte Version von Windows Server ausführt.

Weitere Informationen zu den Systemanforderungen von Exchange Server 2007 finden Sie unter "Exchange Server 2007 System Requirements" (http://go.microsoft.com/fwlink/?LinkId=86651).


Dateifreigabezeuge nicht konfiguriert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-23

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil kein Dateifreigabezeuge für den Cluster für die fortlaufende Clusterreplikation (Cluster Continuous Replication, CCR) konfiguriert wurde.

Um den Ausfall eines beliebigen Knotens in einem MNS-Quorumcluster (Majority Node Set) ausgleichen zu können, müssen mindestens drei Geräte vorhanden sein, die als verfügbar betrachtet werden können. Die Dateifreigabezeuge-Funktion ermöglicht die Verwendung einer externen Dateifreigabe als Zeuge. Dieser Zeuge fungiert als drittes verfügbares Gerät in einem MNS-Quorumcluster mit zwei Knoten.

Das Setup von Exchange 2007 erfordert, dass die Dateifreigabezeuge-Funktion für die Installation der Clusterserverfunktion Mailbox in einer CCR-Umgebung konfiguriert wird.

Um dieses Problem zu beheben, befolgen Sie das Verfahren zum Erstellen und Sichern der Dateifreigabe für den Dateifreigabezeugen unter "Konfigurieren des Dateifreigabezeugen" (http://go.microsoft.com/fwlink/?LinkId=78278). Legen Sie dann den Wert MNSFileShare fest, verschieben Sie die Clustergruppe zweimal, und führen Sie anschließend das Microsoft Exchange-Setup erneut aus.


Die Installation der ersten Serverfunktion kann nicht delegiert werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-06

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, weil der angemeldete Benutzer nicht über die Kontoberechtigungen verfügt, die zum Installieren der ersten Serverfunktion in der Topologie erforderlich sind.

Wenngleich das Microsoft Exchange-Setup die Delegierung der Installation nachfolgender Serverfunktionen zulässt, erfordert das Setup, dass der angemeldete Benutzer über die Berechtigungen der Rolle Exchange-Organisationsadministrator verfügt, wenn die erste der Exchange 2007-Serverfunktionen in der Topologie installiert wird.

Während des Installationsvorgangs der ersten Serverfunktion muss das Exchange 2007-Setup ggf. Objekte im Microsoft Exchange-Organisationscontainer erstellen.

Zum Beheben dieses Problems gewähren Sie dem angemeldeten Benutzer die Berechtigung Exchange-Organisationsadministrator, oder melden Sie sich mit einem Konto an, das über diese Berechtigung verfügt, und führen Sie das Setup von Exchange 2007 erneut aus.


Forefront Security für die Exchange-Serverdienste muss deaktiviert sein
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-06-20

Das Setup von Microsoft Exchange Server 2007 kann die Exchange Server 2007-Aktualisierung nicht fortsetzen, weil die Microsoft Forefront Security für Exchange Server-Dienste auf dem lokalen Computer ausgeführt werden.

Das Exchange-Setup erfordert, dass die Microsoft Forefront Security für Exchange Server-Dienste deaktiviert werden, bevor die Exchange Server 2007-Aktualisierung fortgesetzt werden kann.

Um dieses Problem zu beheben, deaktivieren Sie die Forefront Security für Exchange Server-Dienste und führen dann Exchange Server-Aktualisierung erneut aus.

Weitere Informationen zum Installieren eines Service Packs oder einer Softwareaktualisierung für einen Servercomputer, der Forefront Security ausführt, finden Sie im Microsoft Knowledge Base-Artikel 929080 "Installieren eines Service Packs oder einer Softwareaktualisierung auf einem Computer mit Exchange Server, der Forefront Security ausführt".


Forefront Security für Exchange Server-Aktualisierung erforderlich
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Gilt für: Exchange Server 2007, Exchange Server 2007 SP1
Letztes Änderungsdatum des Themas: 2007-08-08

Das Setup von Microsoft Exchange Server 2007 kann die Exchange 2007-Aktualisierung nicht fortsetzen, da auf dem lokalen Computer eine Version von Microsoft Forefront Security für Exchange Server ausgeführt wird, die mit Exchange Server 2007 Service Pack 1 (SP1) nicht unterstützt wird.

Das Exchange-Setup erfordert, dass die Version von Microsoft Forefront Security für Exchange Server aktualisiert und dessen Dienste deaktiviert werden, bevor die Exchange Server 2007-Aktualisierung fortgesetzt werden kann.

Um dieses Problem zu beheben, aktualisieren Sie Microsoft Forefront Security Version 10.0 für Exchange Server auf Microsoft Forefront Security für Exchange Server SP1 und deaktivieren dann die Microsoft Forefront Security für Exchange Server-Dienste, bevor Sie die Exchange Server-Aktualisierung fortsetzen.

Weitere Informationen

Weitere Informationen zum Installieren eines Service Packs oder einer Softwareaktualisierung für einen Servercomputer, der Forefront Security ausführt, finden Sie im Microsoft Knowledge Base-Artikel 929080 "Installieren eines Service Packs oder einer Softwareaktualisierung auf einem Computer mit Exchange Server, der Forefront Security ausführt" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=929080).


Der vollqualifizierte Domänenname des Computers entspricht einer Empfängerrichtlinie
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-05-16

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da der vollqualifizierte Domänenname des lokalen Computers der SMTP-Adresse (Simple Mail Transfer Protocol) einer Empfängerrichtlinie entspricht.

Für das Microsoft Exchange-Setup ist erforderlich, dass der vollqualifizierte Domänenname der Server in einer Exchange-Organisation keinen SMTP-Adressen von Empfängerrichtlinien in derselben Exchange-Organisation entspricht.

Wenn der vollqualifizierte Domänenname eines Computers der SMTP-Adresse einer Empfängerrichtlinie entspricht, kann diese Übereinstimmung dazu führen, dass der Mailtransport über SMTP fehlschlägt und Verzögerungen in den MTA-Warteschlangen auftreten.

Um dieses Problem zu beheben, können Sie den lokalen Computer umbenennen bzw. die Empfängerrichtlinie entfernen oder umbenennen. Führen Sie anschließend das Microsoft Exchange-Setup erneut aus.

So benennen Sie den lokalen Computer um

  1. Wählen Sie in Systemsteuerung die Option System aus.

  2. Klicken Sie auf der Registerkarte Computername auf Ändern.

  3. Geben Sie unter Computername einen neuen Namen für den Computer ein, und klicken Sie anschließend auf OK. Sie werden aufgefordert, einen Benutzernamen und ein Kennwort anzugeben, um den Computer in der Domäne umzubenennen.

  4. Klicken Sie auf OK, um das Dialogfeld Systemeigenschaften zu schließen. Sie werden aufgefordert, den Computer neu zu starten, damit die Änderungen wirksam werden.
Wichtig:
Wenn der umzubenennende Computer ein Domänencontroller ist, lesen Sie "Rename a domain controller" (http://go.microsoft.com/fwlink/?LinkId=66828).
So ändern Sie die SMTP-Adresse der Empfängerrichtlinie

  1. Starten Sie den Exchange-System-Manager.

  2. Klicken Sie auf Organisation, klicken Sie anschließend auf Empfänger und dann auf Empfängerrichtlinien.

  3. Doppelklicken Sie auf die zu ändernde Richtlinie.

  4. Klicken Sie auf die Registerkarte E-Mail-Adressen, und ändern Sie die entsprechende SMTP-Adresse.

Weitere Informationen zu Umbenennungsproblemen bei Empfängerrichtlinien finden Sie im Microsoft Knowledge Base-Artikel 288175 „XCON: Recipient Policy Cannot Match the FQDN of Any Server in the Organization, 5.4.8 NDRs" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=288175).


Am lokalen Standort ist kein globaler Katalogserver vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-06

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da am Standort, an dem Sie versuchen, Microsoft Exchange zu installieren, kein globaler Katalogserver vorhanden ist.

Für das Microsoft Exchange-Setup ist erforderlich, dass der Active Directory®-Standort des Computers, auf dem das Setup ausgeführt wird, einen Server enthält, der als globaler Katalog fungiert.

Um dieses Problem zu beheben, führen Sie einen der folgenden Schritte aus:

  • Ändern Sie einen am Standort vorhandenen Domänencontroller in einen globalen Katalogserver.

  • Installieren Sie einen neuen Server als globalen Katalogserver.

So ändern Sie einen vorhandenen Domänencontroller in einen globalen Katalogserver

  1. Öffnen Sie Active Directory-Standorte und -Dienste.

  2. Erweitern Sie Standorte, dann den Standort und schließlich Server.

  3. Wählen Sie den Domänencontroller aus, den Sie als globalen Katalogserver angeben möchten.

  4. Klicken Sie im rechten Bereich auf NTDS-Einstellungen, und wählen Sie Eigenschaften aus.

  5. Aktivieren Sie auf der Registerkarte Allgemein das Kontrollkästchen Globaler Katalogserver. Die Änderung erfolgt dynamisch ohne Neustart des Servers.
  • Weitere Informationen zum Erstellen globaler Katalogserver finden Sie im Microsoft Knowledge Base-Artikel 313994 mit Informationen zum Erstellen oder Verschieben eines globalen Katalogs unter Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313994).

  • Weitere Informationen zur Platzierung und Verfügbarkeit globaler Katalogserver in Bezug auf Exchange Server finden Sie im Microsoft Knowledge Base-Artikel 875427 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=875427).


Globale Updates erforderlich
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-09-19

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, weil der angemeldete Benutzer nicht über die Kontoberechtigungen verfügt, die für globale Aktualisierungen des Active Directory®-Verzeichnisdienstes benötigt werden.

Für das Microsoft Exchange-Setup ist erforderlich, dass der bei der Installation von Exchange 2007 angemeldete Benutzer über die Berechtigung Organisationsadministrator verfügt.

Während des Installationsvorgangs muss das Setup von Exchange 2007 ggf. die folgenden Aktionen ausführen:

  • Erstellen oder Ändern von Exchange-Organisationsobjekten im Active Directory-Verzeichnisdienst

  • Vorbereiten aller Domänen in der Active Directory-Gesamtstruktur für Exchange 2007

  • Vorbereiten der vorhandenen Exchange 2000 Server- und Exchange Server 2003-Domänen für Exchange 2007

Zum Beheben dieses Problems gewähren Sie dem angemeldeten Benutzer die Berechtigung Organisations-Admin, oder melden Sie sich mit einem Konto an, das über diese Berechtigungen verfügt, und führen Sie das Setup von Exchange 2007 erneut aus.

Weitere Informationen zu den in Exchange benötigten Active Directory-Berechtigungen finden Sie in "Arbeiten mit Active Directory-Berechtigungen in Exchange Server" unter http://go.microsoft.com/fwlink/?LinkId=47592.


"Host"-Eintrag für den lokalen Computer nicht in der DNS-Datenbank gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-05

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da der "Host (A)"-Eintrag für diesen Computer nicht in der DNS-Datenbank (Domain Name System) gefunden wurde.

Für das Microsoft Exchange-Setup ist erforderlich, dass der lokale Computer über einen gültigen "Host (A)"-Eintrag verfügt, der bei der autorisierenden DNS-Datenbank der Domäne registriert ist.

Microsoft Exchange benötigt DNS-Einträge vom Typ "Host (A)" zum Auflösen der IP-Adresse des nächsten internen oder externen Zielservers.

So beheben Sie dieses Problem:

  • Vergewissern Sie sich, dass die lokale TCP/IP-Konfiguration auf den ordnungsgemäßen DNS-Server zeigt.

    So überprüfen Sie die lokale TCP/IP-Konfiguration

    1. Überprüfen Sie die lokale TCP/IP-Konfiguration. Weitere Informationen finden Sie unter "Configure TCP/IP to use DNS" (http://go.microsoft.com/fwlink/?LinkId=68094).
  • Verwenden Sie nslookup, um zu überprüfen, ob der Eintrag "Host (A)" auf dem DNS-Server vorhanden ist. Weitere Informationen finden Sie unter "To verify A resource records exist in DNS" (http://go.microsoft.com/fwlink/?LinkId=63001).

Weitere Informationen zu DNS-Namensauflösung, -Problembehandlung und -"Host (A)"-Einträgen finden Sie in den folgenden Quellen:

  • Microsoft Knowledge Base-Artikel 322856, "How to configure DNS for use with Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • "Troubleshooting DNS" (http://go.microsoft.com/fwlink/?LinkId=63003).

  • "Managing resource records" (http://go.microsoft.com/fwlink/?LinkId=63004).


Serverfunktion "Hub-Transport" nicht am lokalen Standort gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-06

Das Setup von Microsoft® Exchange Server 2007 zeigt diese Warnung an, da eine vorhandene Hub-Transport-Serverfunktion nicht am lokalen Standort des Verzeichnisdiensts Active Directory® gefunden wurde.

Sie haben versucht, die Serverfunktion Mailbox zu installieren, bevor eine Instanz der Serverfunktion Hub-Transport am Active Directory-Standort installiert wurde.

Die Exchange 2007-Hub-Transport-Dienste werden im Active Directory-Verzeichnis Ihrer Organisation bereitgestellt. Hub-Transport-Dienste verarbeiten den gesamten Nachrichtenfluss innerhalb der Organisation, wenden die Routingregeln auf den Nachrichtenfluss der Organisation an und sind zuständig für die Übermittlung von Nachrichten an das Postfach eines Empfängers.

Benutzer können sich an ihren Postfächern anmelden, jedoch erst dann über diesen Postfachserver E-Mail senden und empfangen, nachdem die Serverfunktion Hub-Transport installiert wurde.


Hub Transport Server Not Present in Active Directory Site
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-07-25

Microsoft Exchange Analyzer fragt den Active Directory-Verzeichnisdienst nach den Werten aller Objekte der Klasse msExchAdminGroupContainer in der Exchange-Organisation ab, die den Exchange Server 2007-spezifischen Bezeichner der administrativen Gruppe, FYDIBOHF23SPDLT, enthalten.

Findet Exchange Analyzer in der Exchange-Organisation eine administrative Gruppe von Exchange Server 2007, werden alle Active Directory-Standorte in der Organisation nach dem Wert des Attributs msExchCurrentServerRoles für jedes msExchExchangeServer-Objekt abgefragt, um zu bestimmen, ob die Serverfunktion Mailbox an einem der gefundenen Standorte installiert ist.

Stellt Exchange Analyzer fest, dass die Serverfunktion Mailbox an einem Standort installiert ist, wird das Attribut msExchCurrentServerRoles jedes msExchExchangeServer-Objekts an diesem Standort abgefragt, um zu bestimmen, ob auch die Serverfunktion Hub-Transport an demselben Standort installiert ist.

Stellt Exchange Analyzer fest, dass an einem Active Directory-Standort die Serverfunktion Mailbox, nicht jedoch die Serverfunktion Hub-Transport installiert ist, wird ein Fehler angezeigt.

Dieser Fehler weist darauf hin, dass die Serverfunktion Mailbox zwar am Active Directory-Standort installiert ist, Nachrichten jedoch selbst dann nicht zwischen Postfächern übermittelt werden, wenn sich die Postfächer auf dem gleichen Server befinden, bevor nicht mindestens eine Serverfunktion Hub-Transport an diesem Standort installiert ist.

Die Serverfunktion Hub-Transport wird im Active Directory-Verzeichnisdienst Ihrer Organisation bereitgestellt. Sie verarbeitet den gesamten Nachrichtenfluss innerhalb der Organisation, wendet die Nachrichtenrichtlinien der Organisation an und ist für die Zustellung von Nachrichten an das Postfach eines Empfängers zuständig. Hub-Transport-Server stellen die folgenden Funktionen zur Verfügung:

Nachrichtenübermittlung Die Serverfunktion Hub-Transport verarbeitet alle Nachrichten, die innerhalb der Exchange 2007-Organisation gesendet werden, bevor sie dem Posteingang eines Empfängers innerhalb der Organisation zugestellt oder an Benutzer außerhalb der Organisation weitergeleitet werden. Be diesem Verhalten gibt es keine Ausnahmen.

Kategorisierung Das Kategorisierungsmodul führt die Empfängerauflösung, Routingauflösung und Inhaltskonvertierung für alle Nachrichten durch, die die Exchange 2007-Transportpipeline durchlaufen.

Routing Die Serverfunktion Hub-Transport bestimmt den Routingpfad für alle Nachrichten, die in der Organisation gesendet und empfangen werden.

Zustellung Nachrichten werden dem Postfach eines Empfängers durch den Speichertreiber zugestellt. Nachrichten, die von Benutzern in Ihrer Organisation gesendet werden, werden durch den Speichertreiber dem Postausgang des Absenders entnommen und in der Übermittlungswarteschlange auf einem Hub-Transport-Server gespeichert.

Um diesen Fehler zu beheben, installieren Sie die Serverfunktion Hub-Transport an den Standorten, an denen eine Serverfunktion Mailbox installiert ist.

Weitere Informationen

Weitere Informationen zum Bereitstellen der Serverfunktion Hub-Transport an einem Standort finden Sie unter "Bereitstellen von Serverfunktionen" (http://go.microsoft.com/fwlink/?LinkId=83282) in der Exchange Server 2007-Produktdokumentation.


IIS 6-Kompatibilitätskomponenten nicht installiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-08-13

Das Setup von Microsoft Exchange Server 2007 kann den Installationsversuch der Serverfunktion ClientAccess oder Mailbox bzw. der Exchange 2007-Verwaltungstools auf dem auf Windows Server 2008 basierenden Zielcomputer nicht fortsetzen, weil die Komponenten IIS 6-Metabase-Kompatibilität (Internet Information Server) und IIS 6-Verwaltungskonsole nicht installiert sind.

Das Setup von Exchange 2007 erfordert, dass auf dem auf Windows Server 2008 basierenden Computer, auf dem Sie die Exchange 2007-Serverfunktion ClientAccess bzw. Mailbox oder die Exchange 2007-Verwaltungstools installieren, die Komponenten IIS 6-Metabase-Kompatibilität und IIS 6-Verwaltungskonsole installiert sind.

Um dieses Problem zu beheben, installieren Sie die Komponente IIS 6-Metabase-Kompatibilität auf dem Zielserver, und führen Sie das Exchange-Setup anschließend erneut aus.

So installieren Sie die Komponente IIS 6.0-Metabase-Kompatibilität mithilfe des Server-Managers von Windows Server 2008

  1. Klicken Sie auf Start, klicken Sie auf Verwaltung und dann auf Server-Manager.

  2. Erweitern Sie im linken Navigationsbereich die Option Funktionen, und klicken Sie dann mit der rechten Maustaste auf Webserver (IIS). Wählen Sie dann Funktionsdienste hinzufügen aus.

  3. Führen Sie im Bereich Funktionsdienste auswählen einen Bildlauf bis zum Eintrag Kompatibilität mit der IIS 6-Verwaltung durch.

  4. Aktivieren Sie die Kontrollkästchen für IIS 6-Metabase-Kompatibilität und IIS 6-Verwaltungskonsole.

  5. Klicken Sie im Bereich Funktionsdienste auswählen auf Weiter, und klicken Sie dann im Bereich Installationsauswahl bestätigen auf Installieren.

  6. Klicken Sie auf Schließen, um den Assistenten für das Hinzufügen von Funktionsdiensten zu schließen.


IIS 7-Komponente nicht installiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-08-09

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, um die Serverfunktion ClientAccess auf dem auf Microsoft Windows Server 2008 basierenden System zu installieren, weil die erforderlichen IIS 7-Komponenten (Internet Information Server) nicht installiert sind.

Das Exchange 2007-Setup erfordert, dass auf dem auf Windows Server 2008 basierenden Computer, auf dem Sie die Serverfunktion ClientAccess installieren, die folgenden IIS 7-Komponenten installiert wurden, bevor die Serverfunktion ClientAccess installiert wird.

Erforderliche IIS 7-Komponenten

Komprimierung dynamischer Inhalte

Komprimierung statischer Inhalte

Standardauthentifizierung

Windows-Authentifizierung

Um dieses Problem zu beheben, installieren Sie die erforderliche(n) IIS 7-Komponente(n) auf dem Zielcomputer, und führen Sie das Microsoft Exchange-Setup anschließend erneut aus.

So installieren Sie die IIS 7-Komponenten mithilfe des Server-Managers von Windows Server 2008

  1. Klicken Sie auf Start, klicken Sie auf Verwaltung und dann auf Server-Manager.

  2. Erweitern Sie im linken Navigationsbereich die Option Funktionen, und klicken Sie dann mit der rechten Maustaste auf Webserver (IIS). Wählen Sie dann Funktionsdienste hinzufügen aus.

  3. Führen Sie im Bereich Funktionsdienste auswählen einen Bildlauf bis zum Eintrag IIS durch.

  4. Aktivieren Sie die Kontrollkästchen unter Sicherheit für Standardauthentifizierung und Windows-Authentifizierung.

  5. Aktivieren Sie die Kontrollkästchen unter Leistung für Statische Komprimierung und Dynamische Komprimierung.

  6. Klicken Sie im Bereich Funktionsdienste auswählen auf Weiter, und klicken Sie dann im Bereich Installationsauswahl bestätigen auf Installieren.

  7. Klicken Sie auf Schließen, um den Assistenten für das Hinzufügen von Funktionsdiensten zu schließen.


Die gemeinsamen IIS-Dateien sind erforderlich
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-08-14

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da die gemeinsamen Dateien der Microsoft-Internetinformationsdienste (IIS) auf diesem Server nicht installiert sind.

Möglicherweise benötigt die Microsoft Exchange-Verwaltungsshell Remotezugriff auf die IIS-Metabase. Bei der Metabase handelt es sich um ein Repository für die meisten IIS-Konfigurationswerte. Für den Remotezugriff auf die Metabase ist es erforderlich, dass die entsprechenden DLLs für COM+ auf dem lokalen Computer installiert sind.

Um dieses Problem zu beheben, installieren Sie die gemeinsamen IIS-Dateien auf dem Server, und führen Sie das Exchange 2007-Setup anschließend erneut aus.

So installieren Sie die gemeinsamen Dateien für IIS mithilfe der Systemsteuerung unter Windows Server™ 2003

  1. Klicken Sie im Menü Start auf Systemsteuerung.

  2. Doppelklicken Sie auf Software.

  3. Klicken Sie auf Windows-Komponenten hinzufügen/entfernen.

  4. Aktivieren Sie in der Liste Komponenten das Kontrollkästchen Anwendungsserver.

  5. Klicken Sie auf Details.

  6. Aktivieren Sie in der Liste Unterkomponenten von Anwendungsserver das Kontrollkästchen Internetinformationsdienste (IIS).

  7. Klicken Sie auf Details.

  8. Aktivieren Sie das Kontrollkästchen Gemeinsame Dateien.

  9. Klicken Sie mehrfach auf OK, bis der Assistent für Windows-Komponenten wieder angezeigt wird.

  10. Klicken Sie auf Weiter, und schließen Sie den Assistenten für Windows-Komponenten ab.
So installieren Sie die gemeinsamen Dateien für IIS mithilfe der Systemsteuerung unter Windows® XP

  1. Klicken Sie im Menü Start auf Systemsteuerung.

  2. Doppelklicken Sie auf Software.

  3. Klicken Sie auf Windows-Komponenten hinzufügen/entfernen.

  4. Aktivieren Sie in der Liste Komponenten das Kontrollkästchen Internetinformationsdienste (IIS).

  5. Klicken Sie auf Details.

  6. Aktivieren Sie das Kontrollkästchen Gemeinsame Dateien.

  7. Klicken Sie mehrfach auf OK, bis der Assistent für Windows-Komponenten wieder angezeigt wird.

  8. Klicken Sie auf Weiter, und schließen Sie den Assistenten für Windows-Komponenten ab.


IIS befindet sich im 32-Bit-Kompatibilitätsmodus
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-08-11

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da Microsoft Internet Information Service (IIS) auf dem 64-Bit-Computer im 32-Bit-Modus ausgeführt wird.

Exchange 2007 erfordert, dass IIS bei Ausführung auf einem 64-Bit-Computer im vollständigen 64-Bit-Modus betrieben wird.

Um dieses Problem zu beheben, schalten Sie IIS in den 64-Bit-Modus um, und führen Sie das Microsoft Exchange-Setup anschließend erneut aus.

So schalten Sie IIS in den 64-Bit-Modus um

  1. Öffnen Sie eine Eingabeaufforderung.

  2. Geben Sie Folgendes ein:

    cscript c:\inetpub\adminscripts\adsutil.vbs SET /w3svc/AppPools/Enable32BitAppOnWin64 False

  3. Drücken Sie die EINGABETASTE.


Nicht ausreichende Berechtigungen zum Vorbereiten von Active Directory
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-21

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil beim Versuch, die Domäne vorzubereiten, ein Fehler aufgetreten ist.

Das Setup von Exchange erfordert, dass der Active Directory-Verzeichnisdienst für Exchange Server 2007 geändert werden muss, bevor Domänen in Active Directory vorbereitet werden können.

Das Konto, das zum Ausführen des Befehls setup /PrepareAD verwendet wird, verfügt nicht über ausreichende Berechtigungen zum Ausführen dieses Befehls, obwohl es der Gruppe Organisationsadministratoren anzugehören scheint. Möglicherweise ist das Konto abgelaufen.

Um dieses Problem zu beheben, stellen Sie sicher, dass das angemeldete Benutzerkonto gültig ist und zur Gruppe Organisationsadministratoren gehört, oder melden Sie sich mit einem Konto an, das über diese Berechtigungen verfügt, und führen Sie setup /PrepareAD dann erneut aus.

Weitere Informationen zum Durchführen des PrepareAD-Vorgangs finden Sie unter "Vorbereiten von Active Directory und Domänen" (http://go.microsoft.com/fwlink/?LinkId=78453).

Weitere Informationen zu den in Microsoft Exchange benötigten Active Directory-Berechtigungen finden Sie in "Arbeiten mit Active Directory-Berechtigungen in Exchange Server" unter http://go.microsoft.com/fwlink/?LinkId=47592.


Unzureichende Berechtigungen zum Entfernen aller Serverfunktionen
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-27

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil beim Versuch, alle Serverfunktionen zu deinstallieren, ein Fehler aufgetreten ist.

Das Setup von Exchange 2007 erfordert, dass der Benutzer, der beim Deinstallieren aller Serverfunktionen angemeldet ist, ein Mitglied der Gruppe Exchange-Organisationsadministratoren oder der Gruppe Organisationsadministratoren ist.

Um dieses Problem zu beheben, gewähren Sie dem angemeldeten Benutzer Exchange-Organisationsadministrator-Berechtigungen bzw. fügen ihn der Gruppe Organisationsadministratoren hinzu, oder melden Sie sich mit einem Konto an, das über diese Berechtigungen verfügt, und führen Sie das Exchange 2007-Setup dann erneut aus.

Weitere Informationen zu den in Microsoft Exchange benötigten Active Directory-Berechtigungen finden Sie unter "Arbeiten mit Active Directory-Berechtigungen in Exchange Server" (http://go.microsoft.com/fwlink/?LinkId=47592).


Nicht ausreichende Berechtigungen zum Ausführen von "/PrepareDomain"
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-27

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil beim Versuch, den Prozess /PrepareDomain auszuführen, ein Fehler aufgetreten ist. Der angemeldete Benutzer verfügt nicht über ausreichende Berechtigungen zum Ausführen des Prozesses /PrepareDomain.

Das Setup von Exchange 2007 erfordert, dass der Benutzer, der beim Ausführen von /PrepareDomain angemeldet ist, ein Mitglied der Gruppe Domänenadministratoren für die vorzubereitende Domäne und der Gruppe Exchange-Organisationsadministratoren oder der Gruppe Organisationsadministratoren ist.

Um dieses Problem zu beheben, gewähren Sie dem angemeldeten Benutzer Domänenadministrator-Berechtigungen für die vorzubereitende Domäne und fügen ihn der Gruppe Exchange-Organisationsadministratoren oder Organisationsadministratoren hinzu, oder melden Sie sich mit einem Konto an, das über diese Berechtigungen verfügt, und führen Sie das Exchange 2007-Setup dann erneut aus.

Weitere Informationen zu den in Microsoft Exchange benötigten Active Directory-Berechtigungen finden Sie in "Arbeiten mit Active Directory-Berechtigungen in Exchange Server" unter http://go.microsoft.com/fwlink/?LinkId=47592.


Ungültiger DNS-Domänenname (Domain Name System)
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-04-13

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, da der auf dem lokalen Computer festgelegte DNS-Domänenname (Domain Name System) ungültig ist.

Das Setup von Exchange 2007 erfordert, dass der DNS-Domänenname keine anderen Zeichen als 'A-Z', 'a-z','0-9', '.' und '-' enthält.

Um dieses Problem zu beheben, ermitteln Sie, ob sich die ungültigen Zeichen im Computernamen des lokalen Computers oder im tatsächlichen DNS-Domänennamen befinden.

  • Wenn die ungültigen Zeichen im Computernamen für den lokalen Computer enthalten sind, setzen Sie den DNS-Domänennamen für den lokalen Computer zurück, indem Sie nur gültige Zeichen im Bereich von 'A-Z', 'a-z','0-9', '.' und '-' verwenden. Starten Sie dann den Computer neu, und führen Sie das Exchange 2007-Setup erneut aus.

  • Wenn sich die ungültigen Zeichen im DNS- Domänennamen der Organisation befinden, sollten Sie abwägen, ob es möglich ist, die DNS-Domäne umzubenennen oder Exchange 2007 in einer neuen Domänenstruktur zu installieren.

Achtung:
Das Ändern des DNS-Domänennamens kann sich erheblich auf das gesamte Netzwerk auswirken. Bevor Sie Änderungen am DNS-Domänennamen vornehmen, sprechen Sie dies mit dem Netzwerkadministrator ab.
So überprüfen Sie den DNS-Namen des lokalen Computers

  1. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und klicken Sie dann auf Eigenschaften. Das Dialogfeld Systemeigenschaften wird angezeigt.

  2. Klicken Sie auf die Registerkarte Computername.

  3. Klicken Sie auf Ändern. Das Dialogfeld Computernamen ändern wird angezeigt.

  4. Klicken Sie auf Weiter. Das Dialogfeld DNS-Suffix und NetBIOS-Computername wird angezeigt.

  5. Vergewissern Sie sich, dass nur Zeichen im Bereich 'A-Z', 'a-z','0-9', '.' und '-' verwendet werden.

  6. Aktivieren Sie das Kontrollkästchen Primäres DNS-Suffix bei Domänenmitgliedschaftsänderung ändern.

  7. Klicken Sie auf OK, um die Änderungen zu speichern und dann nochmals auf OK, um das Dialogfeld Computernamen ändern zu schließen.

  8. Klicken Sie auf OK, um das Dialogfeld Systemeigenschaften zu schließen, und starten Sie den Computer anschließend neu, damit die Änderungen wirksam werden.

Weitere Informationen zu DNS-Namen finden Sie im Microsoft Knowledge Base-Artikel 909264 mit Informationen zu Benennungskonventionen in Active Directory für Computer, Domänen, Standorte und Organisationseinheiten (http://go.microsoft.com/fwlink/?linkid=3052&kbid=909264).


Ungültiger Installationspfad
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-27

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, da beim Versuch der Installation der Server- bzw. Clusterserverfunktion Mailbox auf einem freigegebenen Clusterlaufwerk ein Fehler aufgetreten ist.

Das Exchange-Setup erfordert, dass Exchange-Serverfunktionen auf einem Laufwerk installiert werden, das keine freigegebene Clusterressource ist.

Um dieses Problem zu beheben, installieren Sie die Serverfunktion Mailbox bzw. den Postfachclusterserver in einem Pfad, der nicht als freigegebenes Clusterlaufwerk reserviert ist.

Weitere Informationen zu Clusterkonfigurationen finden Sie unter "Hochverfügbarkeit" (http://go.microsoft.com/fwlink/?linkid=68190) in der Exchange Server 2007-Produktdokumentation.


Ungültiges CMS-Zielpfadformat
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-27

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, da beim Versuch der Installation der Clusterserverfunktion Mailbox auf einem freigegebenen Clusterlaufwerk ein Fehler aufgetreten ist.

Der übermittelte Parameter /CMSDataPath: <Pfad_zur_Datenbank> lag in einem ungültigen UNC-Format (Universal Naming Convention) vor. Das Exchange-Setup erfordert, dass der angegebene Parameter /CMSDataPath: <Pfad_zur_Datenbank> eine gültige Laufwerkbuchstabenzuordnung wie etwa /CMSDataPath: s:\<Pfad_zur_Datenbank> und nicht das UNC-Format verwendet.

Um dieses Problem zu beheben, verwenden Sie eine gültige Laufwerkbuchstabenzuordnung für den Parameter /CMSDataPath: <Pfad_zur_Datenbank>.

Weitere Informationen zum Installieren des Postfachclusterservers finden Sie in der Exchange Server 2007-Produktdokumentation unter "Installieren der Serverfunktion "Mailbox" auf dem aktiven Knoten" (http://go.microsoft.com/fwlink/?LinkId=86624).


Die installierte Version von MOUNTMGR.SYS ist nicht mit Exchange Server kompatibel
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-06

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da die installierte Version von MOUNTMGR.SYS nicht mit Exchange Server kompatibel ist.

Das Exchange 2007-Setup fordert an, dass auf dem Clusterknoten das im Microsoft Knowledge Base-Artikel 898790 genannte Update installiert ist.

Die gegenwärtig auf dem Clusterknoten installierte Version von Mountmgr.sys verursacht ggf. Fehler bei Volumebereitstellungspunkten. Dieses Problem tritt wegen eines Problems im Treiber Mountmgr.sys auf. Es handelt sich hierbei um ein zeitweises Koordinationsproblem, das auftreten kann, wenn ein Datenträger in einem Bereitstellungspunkt bereitgestellt werden soll.

Um dieses Problem zu beheben, installieren Sie das im Microsoft Knowledge Base-Artikel 898790 genannte Update (http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790) und führen anschließend das Exchange 2007-Setup erneut aus.

Weitere Informationen zu diesem Problem finden Sie im Microsoft Knowledge Base-Artikel 898790, "Nachdem Sie Windows Server 2003 Service Pack 1 installieren, können Datenträgerbereitstellungspunkte auf Datenträgern in einem Servercluster zeitweise nicht mehr verfügbar sein" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790).


Die installierte Version von TCPIP.SYS ist nicht mit Exchange Server kompatibel
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-06

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da die installierte Version von TCPIP.SYS nicht mit Exchange Server kompatibel ist.

Das Exchange 2007-Setup fordert an, dass auf dem lokalen Computer das im Microsoft Knowledge Base-Artikel 898060 genannte Update installiert ist.

Auf diesem Computer wird gegenwärtig der Treiber TCPIP.SYS in Windows Server™ 2003 Service Pack 1 ausgeführt. Dieser Treiber kann in WANs Verbindungsprobleme verursachen.

Installieren Sie zum Beheben dieses Problems das im Microsoft Knowledge Base-Artikel 898060 "Update for Windows Server x64 Edition (KB898060)" (http://go.microsoft.com/fwlink/?linkid=59272) genannte Update, und führen Sie anschließend das Exchange 2007-Setup erneut aus.

Weitere Informationen zu dieser Warnung erhalten Sie im Microsoft Knowledge Base-Artikel 898060, "Die Installation des Sicherheitsupdates MS05-019 oder von Windows Server 2003 Service Pack 1 kann dazu führen, dass die Netzwerkverbindungen zwischen Clients und Servern fehlschlagen" (http://support.microsoft.com/kb/898060/de).


Es wurde ein großes Exchange-Organisationsmodell erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-08-10

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um die Anzahl der Routinggruppen in der Exchange Server-Organisation zu ermitteln. Außerdem fragt Exchange Server Analyzer Active Directory ab, um die Anzahl der Active Directory-Standortes zu ermitteln, an denen Exchange-Server mit Microsoft Exchange 2000 Server oder Microsoft Exchange Server 2003 vorhanden sind.

Exchange Server Analyzer kategorisiert die Exchange-Organisation als große Exchange-Organisation, wenn die folgenden Bedingungen erfüllt sind:

  • In der Exchange-Organisation befinden sich mehr als 5 Routinggruppen.

  • An mehr als 5 Active Directory-Standorten sind Server mit Echange 2000 oder Exchange 2003 installiert.

So führen Sie den Übergang einer großen Exchange-Organisation zu Exchange 2007 durch

  1. Rufen Sie die Onlinedokumentation zu Microsoft Exchange Server 2007 auf (http://go.microsoft.com/fwlink/?LinkId=69434).

  2. Lesen Sie das Thema "Planung für eine große Exchange-Organisation" (http://go.microsoft.com/fwlink/?LinkId=70504).


Der lokale Computer ist ein Domänencontroller einer untergeordneten Domäne
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-12-29

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da der lokale Computer ein Domänencontroller einer untergeordneten Domäne ist.

Das Exchange 2007-Setup kann nicht auf einem Domänencontroller einer untergeordneten Domäne ausgeführt werden, es sei denn, der Domänencontroller in ein globaler Katalogserver.

Um dieses Problem zu beheben, stufen Sie den Domänencontroller zu einem globalen Katalogserver herauf oder installieren Exchange 2007 auf einem Nicht-Domänencontroller, d. h. einem Mitgliedsserver, in der untergeordneten Domäne, und führen anschließend das Microsoft Exchange-Setup erneut aus.

So vermeiden Sie diese Warnung, indem Sie den Exchange-Server in einem globalen Katalogserver ändern

  1. Klicken Sie dem Domänencontroller auf Start, zeigen Sie auf Programme, klicken Sie auf Verwaltung, und klicken Sie dann auf Active Directory-Standorte und -Dienste.

  2. Doppelklicken Sie in der Konsolenstruktur auf Standorte, dann auf den Namen des Standorts und schließlich auf Server.

  3. Doppelklicken Sie auf den Zieldomänencontroller.

  4. Klicken Sie im Ergebnisbereich auf NTDS-Einstellungen, und wählen Sie Eigenschaften aus.

  5. Aktivieren Sie auf der Registerkarte Allgemein das Kontrollkästchen Globaler Katalogserver.

  6. Starten Sie den Domänencontroller neu.


Auf dem lokalen Computer wird Exchange Server bereits ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-01-15

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da auf dem lokalen Computer vorherige Microsoft Exchange-Komponenten installiert sind.

Für das Setup von Microsoft® Exchange Server 2007 ist erforderlich, dass auf dem lokalen Computer keine vorherigen Microsoft Exchange-Komponenten installiert sind.

Um dieses Problem zu beheben, entfernen Sie Microsoft Exchange 2000 Server- oder Microsoft Exchange Server 2003-Komponenten und führen anschließend das Microsoft Exchange-Setup erneut aus.

So entfernen Sie Microsoft Exchange-Komponenten

  1. Klicken Sie auf Start, zeigen Sie auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Doppelklicken Sie auf Software.

  3. Klicken Sie in der Liste Zurzeit installierte Programme auf Microsoft Exchange, und klicken Sie dann auf Ändern/Entfernen.

  4. Klicken Sie im Microsoft Exchange-Installations-Assistenten auf Weiter.

  5. Klicken Sie in der Liste Aktion auf der Seite Auswahl der Komponenten auf den Nach-Unten-Pfeil neben jeder installierten Komponente, und klicken Sie dann auf Entfernen.

    Hinweis:
    Bei installierten Komponenten wird in der Liste Aktion ein Häkchen angezeigt. Wenn Sie auf Entfernen klicken, wird das Häkchen durch das Wort Entfernen ersetzt.

  6. Klicken Sie zweimal auf Weiter.

  7. Klicken Sie auf Fertig stellen.


Auf dem lokalen Computer wird nicht Windows Server 2003 Service Pack 1 oder höher ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-05

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da auf dem lokalen Computer nicht Microsoft Windows Server™ 2003 Service Pack 1 (SP1) oder höher ausgeführt wird.

Für das Microsoft Exchange-Setup ist erforderlich, dass auf dem Computer, auf dem Exchange installiert werden soll, Windows Server 2003 SP1 oder höher ausgeführt wird.

So beheben Sie dieses Problem:

  • Führen Sie das Exchange 2007-Setup auf einem Computer aus, auf dem Windows Server 2003 SP1 oder höher ausgeführt wird.

  • Aktualisieren Sie den Computer, auf dem das Exchange 2007-Setup ausgeführt werden soll, auf Windows Server 2003 SP1 oder höher.

Weitere Informationen zum Aktualisieren auf Windows Server 2003 finden Sie im Microsoft Knowledge Base-Artikel 810613, "Möglichkeiten der Aktualisierung auf Windows Server 2003 oder Windows Small Business Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810613).

Das neueste Service Pack für Windows Server 2003 Server finden Sie im Windows Server TechCenter (http://go.microsoft.com/fwlink/?LinkId=45315).


Der lokale Computer ist für die Aufgliederung der Gruppenmitgliedschaft zuständig
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-06

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da der Versuch der Deinstallation einer Hub-Transport-Serverfunktion fehlgeschlagen ist, die für die Aufgliederung der Gruppenmitgliedschaft zuständig ist.

Für das Setup von Exchange 2007 ist erforderlich, dass die Verteilerlistenaufgliederung vom aktuellen Bridgeheadserver entfernt wird, bevor die Serverfunktion Hub-Transport deinstalliert werden kann.

Die Aufgliederung von Verteilerlisten ermöglicht die Identifikation einzelner Empfänger, die zu der zu identifizierenden Verteilerliste gehören, bzw. die Identifikation weiterer aufzugliedernder Verteilerlisten. Eine aufgegliederte Verteilerliste kann den Pfad beliebiger erforderlicher Benachrichtigungen über den Übermittlungsstatus zurückgeben. Benachrichtigungen über den Übermittlungsstatus informieren den Microsoft Exchange-Administrator oder E-Mail-Absender über den Status einer bestimmten E-Mail-Nachricht. Darüber hinaus bestimmt die Aufgliederung von Verteilerlisten, ob Abwesenheitsnachrichten oder automatisch generierte Antworten an den Absender der ursprünglichen Nachricht gesendet werden sollen.

Um dieses Problem zu beheben, verschieben Sie die Verteilerlistenaufgliederung auf einen anderen Server und führen das Microsoft Exchange-Setup erneut aus.

So ändern Sie den Server für die Aufgliederung einer Verteilergruppe bzw. dynamischen Verteilergruppe

  1. Öffnen Sie die Exchange-Verwaltungskonsole.

  2. Erweitern Sie in der Konsolenstruktur Empfängerkonfiguration.

  3. Klicken Sie in der Konsolenstruktur auf Verteilergruppe.

  4. Erstellen Sie einen Filter zum Anzeigen aller Verteilergruppen und dynamischen Verteilergruppen, die den aktuellen Bridgeheadserver gegenwärtig als Server für die Aufgliederung der Verteilerlisten verwenden.

    1. Klicken Sie im Aktionsbereich auf Filter erstellen.

    2. Klicken Sie in der Dropdownliste Eigenschaft auf Server für die Aufgliederung der Verteilerlisten.

    3. Klicken Sie in der Dropdownliste Operator auf Gleich.

    4. Klicken Sie im Feld Wert auf Durchsuchen, um den Bridgeheadserver auszuwählen, der gegenwärtig als Server für die Aufgliederung der Verteilerlisten fungiert.
Hinweis:
Der folgende Schritt ist optional.
  1. Klicken Sie auf Ausdruck hinzufügen, um zusätzliche Filterkriterien anzugeben. Nur Nachrichten, die alle Filterkriterien erfüllen, werden angezeigt.

  2. Klicken Sie auf Filter anwenden. Die Ergebnisse, welche die Filterkriterien erfüllen, werden angezeigt.

  1. Klicken Sie im Ergebnisbereich auf die Verteilergruppe, deren Server für die Aufgliederung der Verteilerlisten Sie ändern möchten, und anschließend im Aktionsbereich auf Eigenschaften.

  2. Klicken Sie im Dialogfeld Eigenschaften auf die Registerkarte Erweitert.

  3. Wählen Sie in der Dropdownliste Server für die Aufgliederung der Verteilerlisten einen bestimmten Server in der Liste oder Alle Server in der Organisation aus.

  4. Wiederholen Sie die Schritte 5 bis 7 für alle Verteilergruppen und dynamischen Verteilergruppen, die den aktuellen Bridgeheadserver gegenwärtig als Server für die Aufgliederung der Verteilerlisten verwenden.


Der lokale Computer ist für die Generierung des Offlineadressbuchs zuständig
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-06

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da der Versuch der Deinstallation einer Mailbox-Serverfunktion fehlgeschlagen ist, die für die Generierung des Offlineadressbuchs zuständig ist.

Für das Microsoft Exchange-Setup ist erforderlich, es sei denn, die Serverfunktion Mailbox ist die letzte in der Exchange-Organisation, dass die Generierung des Offlineadressbuchs vom aktuellen Postfachserver entfernt wird, bevor die Serverfunktion Mailbox deinstalliert werden kann.

Um dieses Problem zu beheben, verschieben Sie die Generierung des Offlineadressbuchs auf einen anderen Server und führen das Microsoft Exchange-Setup erneut aus.

So verschieben Sie die Generierung des Offlineadressbuchs mit dem Exchange-System-Manager

  1. Öffnen Sie den Exchange-System-Manager.

  2. Klicken Sie unter Empfänger auf Offlineadresslisten.

  3. Klicken Sie im rechten Bereich mit der rechten Maustaste auf Standard-Offlineadressliste, und klicken Sie dann auf Eigenschaften.

    Hinweis:
    Gehen Sie für alle anderen Offlineadresslisten, bei denen diese Meldung angezeigt wird, in gleicher Weise vor.

  4. Klicken Sie auf der Registerkarte Allgemein unter Server für Offlineadresslisten auf Durchsuchen, und klicken Sie dann auf den Server mit Exchange, der verwendet werden soll.
So verschieben Sie die Generierung des Offlineadressbuchs mithilfe der Exchange-Verwaltungskonsole

  1. Öffnen Sie die Exchange-Verwaltungskonsole.

  2. Erweitern Sie Microsoft Exchange, dann Organisationskonfiguration, und wählen Sie Postfach aus.

  3. Klicken Sie im Ergebnisbereich auf die Registerkarte Offlineadressbuch.

  4. Wählen Sie auf der Registerkarte Offlineadressbuch die zu entfernenden Offlineadressbücher aus. Klicken Sie im Aktionsbereich auf Verschieben.

  5. Wählen Sie im eingeblendeten Assistenten zum Verschieben von Offlineadressbüchern über die Schaltfläche Durchsuchen den neuen Server aus, auf dem das Offlineadressbuch generiert werden soll, und klicken Sie anschließend auf Verschieben.

  6. Um den Assistenten zu schließen, klicken Sie auf Fertig stellen.
So verschieben Sie die Generierung des Offlineadressbuchs über die Exchange-Verwaltungsshell

  • Führen Sie den folgenden Befehl aus:

    Code kopieren
    Move-OfflineAddressBook -Identity <OfflineAddressBookIdParameter> -Server <ServerIdParameter> [-DomainController <String>]


Auf dem lokalen Computer wird die Serverfunktion "Gatewayserver" ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-06

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da beim Versuch der Installation einer Exchange 2007-Serverfunktion festgestellt wurde, dass die Funktion Gatewayserver bereits auf diesem Server installiert ist.

Exchange 2007 kann keine anderen Serverfunktionen auf einem Server installieren, auf dem die Microsoft Exchange-Funktion Gatewayserver installiert ist.

Die Microsoft Exchange-Funktion Gatewayserver wird im Umkreisnetzwerk Ihrer Organisation bereitgestellt. Sie verarbeitet den Nachrichtenfluss in das und aus dem Internet, ver- und entschlüsselt Nachrichten, die zwischen vertrauenswürdigen Microsoft Exchange-Organisationen gesendet werden, und bietet einen Schutz gegen Spam.

Um dieses Problem zu beheben, installieren Sie die anderen Microsoft Exchange 2007-Funktionen auf einem Computer, auf dem die Funktion Gatewayserver nicht installiert ist.


Auf dem lokalen Computer wird Windows Server 2003 Web Edition ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-06

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da auf dem lokalen Computer Windows Server™ 2003 Web Edition ausgeführt wird.

Für das Exchange 2007Setup ist erforderlich, dass Sie Microsoft Exchange auf einem Computer mit einem unterstützten Betriebssystem ausführen.

Installieren Sie zum Beheben dieses Problems Microsoft Exchange auf einem Computer mit Windows Server 2003 Service Pack 1 (SP1) oder höher (nicht Web Edition).


Die lokale Domäne muss aktualisiert werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-27

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, weil der angemeldete Benutzer nicht über die Kontoberechtigungen verfügt, die für die Domänenvorbereitung erforderlich sind.

Das Setup von Exchange 2007 erfordert, dass der Benutzer, der beim Ausführen von Setup /PrepareDomain angemeldet ist, ein Mitglied der Gruppe Domänenadministratoren und Exchange-Organisationsadministratoren oder der Gruppe Organisationsadministratoren ist.

Um dieses Problem zu beheben, gewähren Sie dem angemeldeten Benutzer Domänenadministrator- und Exchange-Organisationsadministrator-Berechtigungen bzw. fügen ihn der Gruppe Organisationsadministratoren hinzu, oder melden Sie sich mit einem Konto an, das über diese Berechtigungen verfügt, und führen Sie das Exchange 2007-Setup dann erneut aus.

Weitere Informationen zu den in Microsoft Exchange benötigten Active Directory-Berechtigungen finden Sie in "Arbeiten mit Active Directory-Berechtigungen in Exchange Server" unter http://go.microsoft.com/fwlink/?LinkId=47592.


Kein Zugriff auf die lokale Metabasis möglich
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-06

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da Daten in der lokalen Metabasis nicht gelesen werden konnten.

Für das Microsoft Exchange-Setup ist erforderlich, dass bei der Installation der Serverfunktionen Mailbox und ClientAccess Daten in der Metabasis von Microsoft Internetinformationsdienste (IIS) gelesen werden können.

Die IIS-Metabasis enthält Informationen, die Microsoft Exchange betreffen, z. B. Protokolleinstellungen für HTTP, virtuelle Verzeichnisse für den Zugriff auf Postfächer und mobile Geräte sowie HTTP-Sicherheitseinstellungen.

Um dieses Problem zu beheben, stellen Sie sicher, dass IIS ordnungsgemäß installiert ist, und führen das Microsoft Exchange-Setup erneut aus.

Um zu prüfen, ob IIS ordnungsgemäß installiert ist, lesen Sie die folgenden Quellen:

  • Microsoft Knowledge Base-Artikel 843093 mit Informationen zur Problembehandlung bei einer fehlerhaften IIS-Metabasis auf einem Server mit Windows 2000 Server, auf dem Exchange 2000 Server oder Exchange Server 2003 ausgeführt wird (http://go.microsoft.com/fwlink/?linkid=3052&kbid=843093).

  • Microsoft Knowledge Base-Artikel 240225, "Beschreibung von Adsutil und MetaEdit-Dienstprogrammen, die verwandt werden, um die Metabasis zu ändern" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240225).

  • Microsoft Knowledge Base-Artikel 317678 mit Informationen zum Neustarten von Internetinformationsdienste (IIS) in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317678).

Wenn anhand der Anleitungen in diesen Quellen das Problem nicht behoben werden kann, müssen Sie Internetinformationsdienste (IIS) de- und anschließend neu installieren.

So deinstallieren Sie IIS über die Option "Software" in der Systemsteuerung

  1. Klicken Sie im Menü Start auf Systemsteuerung.

  2. Doppelklicken Sie auf Software.

  3. Klicken Sie auf Windows-Komponenten hinzufügen/entfernen.

  4. Aktivieren Sie in der Liste Komponenten das Kontrollkästchen Anwendungsserver.

  5. Klicken Sie auf Details.

  6. Klicken Sie auf Internetinformationsdienste-Manager.

  7. Klicken Sie auf Weiter.

  8. Klicken Sie auf Fertig stellen, wenn IIS installiert ist.
So installieren Sie IIS über die Systemsteuerung

  1. Klicken Sie im Menü Start auf Systemsteuerung.

  2. Doppelklicken Sie auf Software.

  3. Klicken Sie auf Windows-Komponenten hinzufügen/entfernen.

  4. Aktivieren Sie in der Liste Komponenten das Kontrollkästchen Anwendungsserver.

  5. Klicken Sie auf Details.

  6. Aktivieren Sie das Kontrollkästchen Internetinformationsdienste-Manager.

  7. Klicken Sie OK, bis Sie zum Assistenten für Windows-Komponenten zurückkehren.

  8. Klicken Sie auf Weiter, und schließen Sie den Assistenten für Windows-Komponenten ab.


Der angemeldete Benutzer ist kein Mitglied der lokalen Gruppe "Administratoren"
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-06

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da der angemeldete Benutzer kein Mitglied der Gruppe "Administratoren" auf dem lokalen Computer ist.

Für das Exchange 2007-Setup ist erforderlich, dass der angemeldete Benutzer, der Microsoft Exchange installiert, Vollzugriff auf den lokalen Computer hat.

Melden Sie sich zum Beheben dieses Problems am Computer mit einem Konto an, das Zugriffsberechtigungen des lokalen Administrators hat, und führen Sie das Setup von Microsoft Exchange erneut aus.


Der angemeldete Benutzer ist kein Mitglied der Gruppe "Schema-Admins"
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-09-06

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da der Schemaaktualisierungsprozess im Verzeichnisdienst Active Directory® nicht über die Anmeldeinformationen der Gruppen Schema-Admins oder Organisations-Admins verfügt.

Für das Exchange 2007-Setup ist erforderlich, dass der angemeldete Benutzer, der Microsoft Exchange installiert, über die Berechtigung der Gruppen Schema-Admins und Organisations-Admins für die Active Directory-Gesamtstruktur verfügt.

Während des Installationsvorgangs erweitert das Microsoft Exchange-Setup das Active Directory-Schema, um Exchange 2007-spezifische Klassen und Attribute hinzuzufügen.

Wenn der angemeldete Benutzer nicht die Berechtigungen der Gruppen Schema-Admins oder Organisations-Admins hat, schlägt der Schemaaktualisierungsprozess fehl.

Um dieses Problem zu heben, fügen Sie den angemeldeten Benutzer in den Gruppen Schema-Admins und Organisations-Admins hinzu, melden Sie sich ab und anschließend wieder an, oder melden Sie sich ab und melden Sie sich dann mit einem Konto wieder an, dass bereits über die Anmeldeinformationen der Gruppen Schema-Admins und Organisations-Adminsfür die Active Directory-Gesamtstruktur verfügt.


Zu viele aktive Knoten
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-23

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil beim Versuch, die Serverfunktion Mailbox für einen neuen aktiven Cluster zu erstellen, ein Fehler aufgetreten ist.

Exchange Server 2007 erfordert, dass mindestens ein Knoten des Clusters passiv ist, um die Widerherstellung nach einem Fehler zu unterstützen.

Um dieses Problem zu beheben, installieren Sie zuerst eine andere Serverfunktion Mailbox für den passiven Cluster in der Umgebung, und führen Sie dann das Setup erneut aus.

Weitere Informationen zum Installieren aktiver und passiver Knoten finden Sie unter "Hochverfügbarkeit" (http://go.microsoft.com/fwlink/?linkid=68190) in der Exchange Server 2007-Produktdokumentation.


Laufwerksangabe für Postfachdatenbank fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-05-15

Das Setup zur Wiederherstellung nach Datenverlust von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da dieses Setup nicht auf die Laufwerksangabe der Postfachdatenbank zugreifen kann, die bei der vorherigen Installation dieses Serverprogramms verwendet wurde.

Das Setup zur Wiederherstellung nach Datenverlust von Microsoft Exchange erfordert, dass die zuvor für diesen Server verwendeten Laufwerksangaben für die Postfachdatenbank während der Wiederherstellung verfügbar sind.

Konfigurieren Sie zum Beheben dieses Problems die Laufwerke so, dass diese der ursprünglichen logischen Laufwerkskonfiguration entsprechen, und führen Sie das Microsoft Exchange-Setup zur Wiederherstellung nach Datenverlust erneut aus.

Zuweisen oder Ändern eines Laufwerksbuchstaben

  1. Öffnen Sie Computerverwaltung (Lokal).

  2. Klicken Sie in der Konsolenstruktur auf Computerverwaltung (Lokal), dann auf Datenspeicher und anschließend auf Datenträgerverwaltung.

  3. Klicken Sie mit der rechten Maustaste auf eine Partition, ein logisches Laufwerk oder ein Volume, und klicken Sie dann auf Laufwerkbuchstaben und -pfade ändern.

  4. Führen Sie eines der folgenden Verfahren aus:

    • Um einen Laufwerksbuchstaben zuzuweisen, klicken Sie auf Hinzufügen, dann auf den gewünschten Laufwerksbuchstaben und schließlich auf OK.

    • Um einen Laufwerksbuchstaben zu ändern, klicken Sie auf Ändern, dann auf den gewünschten Laufwerksbuchstaben und schließlich auf OK.

Weitere Informationen zum Zuweisen von Laufwerksbuchstaben finden Sie in "Assign, change, or remove a drive letter" (http://go.microsoft.com/fwlink/?LinkId=66764).


Nachrichten in einer oder mehreren Warteschlangen vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-05

Das Setup von Microsoft® Exchange Server 2007 zeigt diese Warnung an, da der Versuch der Deinstallation einer Transportfunktion zum Verlust von Daten in einer Transportwarteschlange führen kann.

Das Setup von Exchange 2007 prüft, ob die Transportwarteschlangen leer sind, bevor versucht wird, die mit der Verwaltung dieser Warteschlangen verknüpften Serverfunktionen zu entfernen.

Wenn Sie die Transportfunktionen vor der Übermittlung der noch in den Transportwarteschlangen enthaltenen Nachrichten entfernen, werden die Nachricht ggf. unbegrenzt lange aufbewahrt.

Untersuchen Sie zum Beheben dieses Problems die betreffenden Warteschlangen, um sicherzustellen, dass sie keine Nachrichten enthalten, bevor Sie das Setup fortsetzen.

So zeigen Sie den Inhalt einer Warteschlange an

  1. Öffnen Sie die Exchange-Verwaltungskonsole.

  2. Klicken Sie in der Konsolenstruktur auf Toolbox.

  3. Klicken Sie im linken Bereich auf Microsoft Exchange-Warteschlangenanzeige.

  4. Klicken Sie im Aktionsbereich auf Tool öffnen.

  5. Klicken Sie in der Warteschlangenanzeige auf die Registerkarte Warteschlangen. Eine Liste aller Warteschlangen auf dem Server, mit dem Sie verbunden sind, wird angezeigt.

  6. Klicken Sie mit der rechten Maustaste auf die gewünschte Warteschlange, und wählen Sie Eigenschaften aus, um deren Eigenschaften anzuzeigen.
So zeigen Sie die Nachrichten in einer Warteschlange an

  1. Befolgen Sie die Schritte 1 bis 4.

  2. Klicken Sie in der Warteschlangenanzeige auf die Registerkarte Nachrichten. Eine Liste aller Nachrichten auf dem Server, mit dem Sie verbunden sind, wird angezeigt. Um die Ansicht einer einzelnen Warteschlange anzupassen, klicken Sie auf die Registerkarte Warteschlangen. Doppelklicken Sie auf den Warteschlangennamen, und klicken Sie dann auf die eingeblendete Registerkarte Server\Warteschlange.

  3. Um detaillierte Informationen zu einer Nachricht anzuzeigen, wählen Sie eine Nachricht aus und klicken im Aktionsbereich auf Eigenschaften.


Update von Microsoft .NET Framework erforderlich
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-02-26

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, da auf dem lokalen Computer die Aktualisierung von Software erforderlich ist.

Das Setup von Exchange 2007 setzt voraus, dass das entsprechende, hier angegebene Microsoft .NET Framework-Update auf dem lokalen Computer installiert ist.

Um dieses Problem zu beheben, müssen Sie das Setup von Exchange 2007 beenden, das Update (32-Bit oder 64-Bit) über die folgenden URLs herunterladen und installieren und anschließend das Setup von Exchange 2007 erneut ausführen.

Hinweis:
Wenn Sie auf diese Links klicken, werden Sie aufgefordert, die Dateien sofort herunterzuladen.
  • 64-Bit-Download, http://go.microsoft.com/fwlink/?linkid=74465

  • 32-Bit-Download, http://go.microsoft.com/fwlink/?linkid=74469


Die Microsoft XML-Kerndienste (MSXML) 6.0 sind erforderlich
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-08-21

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da die Microsoft XML-Kerndienste (MSXML) 6.0 nicht auf diesem Server installiert sind.

Beim Setup von Exchange 2007 ist für alle Installationen der Unified Messaging-Serverrolle erforderlich, dass MSXML 6.0 zur Unterstützung der Microsoft-Sprachdienste auf dem Computer installiert wird.

Um dieses Problem zu beheben, installieren Sie MSXML 6.0 von http://go.microsoft.com/fwlink/?LinkId=70796. Führen Sie anschließend das Setup von Exchange 2007 erneut aus.


Der MNSFileShare-Pfad ist ungültig
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-27

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil der MNSFileShare-Pfad ungültig ist.

Der Wert für MNSFileShare muss auf einen Zeichenfolgenwert festgelegt werden, der den UNC-Pfad (Universal Naming Convention) einer Dateifreigabe enthält, die für den Cluster extern ist, z. B. \\Server\Freigabename.

Um dieses Problem zu beheben, stellen Sie einen Wert für die Eigenschaft MNSFileShare zur Verfügung, der einen gültigen UNC-Pfad darstellt.

Weitere Informationen zum Konfigurieren der Eigenschaft MNSFileShare finden Sie unter "Konfigurieren des Dateifreigabezeugen" (http://go.microsoft.com/fwlink/?LinkId=78278).


MSDAPS.DLL-Update erforderlich
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-12-05

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da auf dem lokalen Computer die Aktualisierung von Software erforderlich ist.

Das Setup von Exchange 2007 setzt voraus, dass das unten angegebene MSDAPS.DLL-Update auf dem lokalen Computer installiert ist.

Um dieses Problem zu beheben, müssen Sie das unten angegebene Update herunterladen und installieren, und anschließend das Setup von Exchange 2007 erneut ausführen.

  • http://go.microsoft.com/fwlink/?linkid=74467


Der NNTP-Dienst (Network News Transport Protocol) ist gegenwärtig installiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-01-22

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da der NNTP-Dienst (Network News Transport Protocol) von Microsoft Windows Server™ 2003 auf diesem Computer installiert ist.

Für das Microsoft Exchange-Setup ist erforderlich, dass der NNTP-Dienst nicht auf Servern installiert wird, die für Exchange 2007 verwendet werden.

Um dieses Problem zu beheben, deinstallieren Sie den NNTP-Dienst und führen das Microsoft Exchange-Setup erneut aus.

So deinstallieren Sie den NNTP-Dienst über die Option "Software" in der Systemsteuerung

  1. Klicken Sie im Menü aufStart auf Systemsteuerung.

  2. Doppelklicken Sie auf Software.

  3. Klicken Sie auf Windows-Komponenten hinzufügen/entfernen.

  4. Aktivieren Sie in der Liste Komponenten das Kontrollkästchen Anwendungsserver, und klicken Sie dann auf Details.

  5. Wählen Sie Internetinformationsdienste-Manager aus, und klicken Sie dann auf Details.

  6. Wählen Sie NNTP-Dienst aus, und deaktivieren Sie das Kontrollkästchen.

  7. Klicken Sie zum zweimal auf OK, um zur Liste Komponenten zurückzukehren, und klicken Sie dann auf Weiter.

  8. Klicken Sie auf Fertig stellen, wenn der NNTP-Dienst deinstalliert ist.


Es wurde keine Serverfunktion "ClientAccess" gefunden.
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-02-16

Microsoft Exchange Analyzer fragt den Active Directory-Verzeichnisdienst nach den Werten aller Objekte der Klasse msExchAdminGroupContainer in der Exchange-Organisation ab, die den Exchange Server 2007-spezifischen Bezeichner der administrativen Gruppe, FYDIBOHF23SPDLT, enthalten.

Findet Exchange Analyzer in der Exchange-Organisation eine administrative Gruppe von Exchange Server 2007, werden alle Active Directory-Standorte in der Organisation nach dem Wert des Attributs msExchCurrentServerRoles für jedes msExchExchangeServer-Objekt abgefragt, um zu bestimmen, ob die Serverfunktion Mailbox auf einem der gefundenen Standorte installiert ist.

Stellt Exchange Analyzer fest, dass die Serverfunktion Mailbox auf einem Standort installiert ist, wird das Attribut msExchCurrentServerRoles jedes msExchExchangeServer-Objekts auf diesem Standort abgefragt, um zu bestimmen, ob auch die Serverfunktion ClientAccess auf demselben Standort installiert ist.

Stellt Exchange Analyzer fest, dass auf einem Active Directory-Standort die Serverfunktion Mailbox aber nicht die Serverfunktion ClientAccess installiert ist, wird eine Warnung angezeigt.

Diese Warnung weist darauf hin, dass die Serverfunktion Mailbox zwar auf dem Active Directory-Standort installiert ist, Microsoft Office Outlook Web Access- und Exchange ActiveSync-Zugriffsclients für mobile Geräte aber nicht auf ihre Nachrichten auf dem Postfachserver zugreifen können, bevor nicht mindestens eine ClientAccess-Serverfunktion auf diesem Standort installiert ist.

Die Serverfunktion ClientAccess akzeptiert Verbindungen mit dem Exchange 2007-Server von einer Vielzahl unterschiedlicher Clients aus. Softwareclients wie Microsoft Outlook Express und Eudora kommunizieren über POP3- oder IMAP4-Verbindungen mit dem Exchange-Server. Hardwareclients wie mobile Geräte kommunizieren über ActiveSync, POP3 oder IMAP4 mit dem Exchange-Server.

Wenn Benutzer auf ihren Posteingang mit einem anderen Client als Microsoft Outlook zugreifen, müssen Sie die Serverfunktion ClientAccess in der Exchange-Organisation installieren.

So beheben Sie diese Warnung: Wenn mit anderen Clients als Microsoft Outlook auf die Postfächer zugegriffen wird, installieren Sie die Serverfunktion ClientAccess auf dem Standort, auf dem die Serverfunktion Mailbox installiert ist.

Weitere Informationen

Weitere Informationen zum Installieren der Serverfunktion ClientAccess finden Sie unter "Bereitstellen von Serverfunktionen" (http://go.microsoft.com/fwlink/?LinkId=83282) in der Exchange Server 2007-Produktdokumentation.


Ein nicht standardmäßiger Adressraum wurde gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-08-21

Microsoft® Exchange Server Analyzer zeigt diese Warnmeldung an, wenn festgestellt wird, dass in einer oder mehreren Empfängerrichtlinien ein nicht standardmäßiger Adressraum vorhanden ist.

Bei einem nicht standardmäßigen Adressraum (oder Proxyadressraum) handelt es sich um die Adresse, anhand derer ein Exchange Server-Empfängerobjekt in einem fremden Messagingsystem erkannt wird.

In früheren Versionen von Exchange Server war der Empfängeraktualisierungsdienst für die Unterstützung von nicht standardmäßigen Adressräumen verantwortlich.

In Microsoft Exchange Server 2007 ist der Empfängeraktualisierungsdienst nicht implementiert. Die Exchange 2007-Verwaltungskonsole ist für die Generierung von Proxyadressen verantwortlich.

In den Verwaltungskonsolen muss für jeden erkannten nicht standardmäßigen Adressraum eine Proxy-Generator-DLL geladen sein.

Wichtig:
Wenn die Verwaltungskonsole auf einem 64-Bit-Computer ausgeführt wird, ist eine 64-Bit-Version der Proxy-Generator-DLL erforderlich.

Um diese Warnung zu beheben, fordern Sie bei dem Hersteller, der den fremden Adressraum unterstützt, eine Exchange 2007-kompatible Proxy-Generator-DLL an.


Nicht in Schemamasterstandort/-domäne
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-08-10

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da sich der Computer, auf dem das Setup ausgeführt wird, nicht am selben Standort oder in der selben Domäne des Active Directory®-Verzeichnisdienstes befindet, wie der Server, der die Funktion des Domänenschemamasters innehat (auch Flexible Single Master Operations/FSMO genannt).

Für das Setup von Exchange 2007 ist erforderlich, dass sich der Domänencontroller, der als Domänenschemamaster fungiert, am selben Standort und in derselben Domäne befindet, wie der Computer, auf dem das Exchange-Setup ausgeführt wird.

Der Domänenschemamaster steuert alle Updates und Änderungen am Active Directory-Schema.

Um dieses Problem zu beheben, führen Sie das Exchange Server 2007-Setup am selben Standort und in derselben Domäne aus, an dem bzw. in der sich auch der Domänenschemamaster befindet.

Die Funktion kann mit dem Schemamastertool angegeben werden. Damit das Schematool als MMC-Snap-In verfügbar ist muss jedoch die DLL Schmmgmt.dll registriert werden.

So zeigen Sie den aktuellen Schemamaster an

  1. Geben Sie an der Eingabeaufforderung regsvr32 schmmgmt.dll ein.

    Hinweis:
    RegSvr32 wurde erfolgreich registriert, wenn das folgende Dialogfeld angezeigt wird:

    DllRegisterServer in schmmgmt.dll erfolgreich.

  2. Klicken Sie zum Öffnen einer Verwaltungskonsole auf Start und dann auf Ausführen, und geben Sie anschließend mmc ein.

  3. Klicken Sie im Konsolenmenü auf Snap-In hinzufügen/entfernen.

  4. Klicken Sie auf Hinzufügen, um das Dialogfeld Eigenständiges Snap-In hinzufügen zu öffnen.

  5. Wählen Sie Active Directory-Schema aus, und klicken Sie dann auf Hinzufügen.

  6. Active Directory Schema wird unter Snap-In hinzufügen/entfernen angezeigt. Klicken Sie auf Schließen und anschließend auf OK, um zu der Konsole zurückzukehren.

  7. Wählen Sie Active Directory-Schema aus. Die Abschnitte Klassen und Attribute werden daraufhin auf der rechten Seite angezeigt.

  8. Klicken Sie mit der rechten Maustaste auf Active Directory-Schema, und klicken Sie dann auf Betriebsmaster.

  9. Der aktuelle Schemamaster wird angezeigt.


In der Domäne befindet sich kein Windows Server 2003 SP1-Domänencontroller
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-27

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, weil der Prozess setup /PrepareLegacyExchangePermissions in der Domäne, die vorbereitet wird, keinen Domänencontroller ermitteln konnte, der Microsoft Windows Server 2003 Service Pack 1 (SP1) oder eine höhere Version ausführt.

In jeder Domäne, in der setup /PrepareLegacyExchangePermissions ausgeführt werden soll, muss Setup die Verbindung mit einem Windows Server 2003 SP1-Domänencontroller herstellen. Setup /PrepareLegacyExchangePermissions wird nicht erfolgreich abgeschlossen, wenn nicht mindestens ein Windows Server 2003 SP1-Domänencontroller ermittelt werden kann.

Durch das Ausführen des Befehls setup /PrepareLegacyExchangePermissions kann der Legacy-Empfängeraktualisierungsdienst ordnungsgemäß funktionieren. Bevor das neue Exchange 2007-Schema importiert werden kann, muss Exchange 2007 in jeder Domäne neue Berechtigungen gewähren, in der Sie DomainPrep von Exchange Server 2003- oder Exchange 2000 Server ausgeführt haben. Der Befehl setup /PrepareLegacyExchangePermissions gewährt diese neuen Berechtigungen.

Um dieses Problem zu beheben, aktualisieren Sie mindestens einen Domänencontroller in jeder Domäne, in der setup /PrepareLegacyExchangePermissions ausgeführt werden soll, auf Windows Server 2003 SP1 oder eine höhere Version, und führen Sie dann Setup erneut aus.

Weitere Informationen zum Vorbereiten von Exchange-Legacyberechtigungen finden Sie unter "Vorbereiten von Exchange-Legacyberechtigungen" (http://go.microsoft.com/fwlink/?linkid=81776) in der Exchange Server 2007-Produktdokumentation.


Der OAB-Server wurde gelöscht
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-21

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil beim Versuch, die Serverfunktion ClientAccess zu installieren, ein Fehler aufgetreten ist. Der Exchange-Postfachserver, der für die Speicherung des Offlineadressbuchs (OAB) reserviert war, wurde gelöscht.

Für das Setup von Exchange 2007 ist ein gültiger Exchange-Postfachserver erforderlich, der als Host für die OAB-Generierung fungiert, damit die Installation der Serverfunktion ClientAccess fortgesetzt werden kann.

Um dieses Problem zu beheben, legen Sie einen gültigen Exchange-Postfachserver als OAB-Generierungshost fest, und führen Sie anschließend das Exchange 2007-Setup erneut aus.

Weitere Informationen zum Reservieren eines Servercomputers mit Exchange als Host für die Generierung des Offlineadressbuchs finden Sie unter "Erstellen eines Offlineadressbuchs" (http://go.microsoft.com/fwlink/?LinkId=86314) in der Exchange Server 2007-Produktdokumentation.


Ältere Datenbankdateien vorhanden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-06

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da im Zielinstallationspfad vorhandene Microsoft Exchange-Datenbankdateien erkannt wurden.

Für das Microsoft Exchange-Setup ist erforderlich, dass im Zielinstallationspfad keine Microsoft Exchange-Datenbankdateien vorhanden sind.

Entfernen Sie zum Beheben dieses Problems alle vorhandenen Dateien aus Zielinstallationspfaden, und führen Sie das Setup erneut aus.

So löschen Sie vorhandene Microsoft Exchange-Datenbankdateien aus dem Zielinstallationspfad

  1. Suchen Sie in Arbeitsplatz oder Windows Explorer den Zielinstallationspfad.

    Hinweis:
    Der Standardspeicherort der Datenbankdateien ist:

    <systemDrive>:\Programme\Microsoft\Exchange Server\Mailbox\First Storage Group

  2. Klicken Sie mit der rechten Maustaste die zu entfernenden Dateien, und klicken Sie dann auf Löschen.

  3. Klicken Sie im Dialogfeld Löschen von Dateien bestätigen auf Ja.

  4. Wiederholen Sie die Schritte 2 und 3 für alle Dateien in den Zielinstallationspfaden.


Ältere Version von ADAM entdeckt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-06

Das Setup von Microsoft® Exchange Server 2007 zeigt diese Warnung an, da beim Versuch, die Funktion Gatewayserver zu installieren, erkannt wurde, dass eine ältere Version von Active Directory®-Application Mode (ADAM) auf dem aktuellen Server vorhanden ist.

ADAM ist ein LDAP-Verzeichnisdienst (Lightweight Directory Access Protocol), der speziell für die Verwendung mit verzeichnisaktivierten Anwendungen entwickelt wurde. ADAM speichert und repliziert nur anwendungsspezifische Informationen. Der Dienst muss nicht auf einem Domänencontroller bereitgestellt werden und ist nicht vom Active Directory-Verzeichnisdienst abhängig. ADAM bietet keine Authentifizierung oder Autorisierung für das Netzwerkbetriebssystem.

In Exchange 2007 verwendet der Gatewayserver ADAM zum Speichern von Konfigurationsinformationen. Wenn ADAM mit Active Directory synchronisiert wird, kann der Dienst auch für die Nachrichtensicherheit zum Durchführen von Empfängersuchen verwendet werden.

Das Exchange 2007-Setup aktualisiert die ADAM-Installation automatisch auf die Service Pack 1 (SP1)-Version.

Es ist keine Aktion erforderlich, es sei denn, Sie möchten ADAM nicht aktualisieren. In diesem Fall sollten Sie die Funktion Gatewayserver nicht auf dem lokalen Computer installieren.


Einen oder mehrere ADC-Server (Active Directory Connector) gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-06

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da ein oder mehrere Active Directory Connectors (ADC) in der aktuellen Microsoft Exchange-Umgebung gefunden wurden.

Ein ADC repliziert Objekte aus Exchange Server, Version 5.5, in den Verzeichnisdienst Active Directory® in einer Microsoft Exchange-Umgebung im gemischten Modus und wird von Exchange 2007 nicht unterstützt.

Für das Microsoft Exchange-Setup ist erforderlich, dass sämtliche ADC-Komponenten entfernt werden.

Um dieses Problem zu beheben, entfernen Sie alle ADC-Komponenten und führen das Microsoft Exchange-Setup erneut aus.

So entfernen Sie Active Directory Connector-Komponenten

  1. Um den ADC-Dienst auf dem Server zu deaktivieren, auf dem er ausgeführt wird, klicken Sie mit der rechten Maustaste auf dem Desktop auf Arbeitsplatz, und klicken Sie dann auf Verwalten.

  2. Erweitern Sie den Knoten Dienste und Anwendungen, und klicken Sie dann auf den Knoten Dienste.

  3. Klicken Sie mit der rechten Maustaste im rechten Bereich auf Microsoft Active Directory Connector, und klicken Sie dann auf Eigenschaften.

  4. Ändern Sie Starttyp in Deaktiviert. Beim nächsten Start des Computers wird der ADC-Dienst nicht gestartet.

  5. Klicken Sie auf Übernehmen und dann auf OK.

  6. Um den ADC-Dienst zu deinstallieren, verwenden Sie den Assistenten für die Installation von Active Directory auf der Microsoft Exchange 2000- oder Microsoft Exchange Server 2003-CD. Öffnen Sie den Ordner \ADC\I386, und doppelklicken Sie auf das Programm Setup.exe. Folgen Sie den Eingabeaufforderungen, um alle ADC-Dienstkomponenten zu entfernen.

    Wichtig:
    Sie müssen Schritt 6 abschließen und alle ADC-Komponenten über Alle entfernen entfernen, um dieses Problem zu beheben. Es reicht nicht aus, den ADC-Dienst zu deaktivieren.

Weitere Informationen zum ADC finden Sie in den folgenden Microsoft Knowledge Base-Artikeln:

  • 325300, "Support WebCast: Introduction to the Active Directory Connector" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325300).

  • 325221, "Support WebCast: Microsoft erweiterte Active Directory Connector" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325221).

  • 312632, "SO WIRD'S GEMACHT: Installation und Konfiguration des Active Directory Connectors in Exchange 2000 Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=312632).


Es ist nur ein CCR-Server zulässig
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-27

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil beim Versuch, einen neuen Postfachclusterserver zu erstellen, ein Fehler aufgetreten ist.

Exchange Server 2007 erfordert, dass nur ein Postfachclusterserver für die fortlaufende Clusterreplikation im CCR-Cluster (Cluster Continuous Replication, fortlaufende Clusterreplikation) vorhanden ist. In diesem CCR-Cluster ist bereits ein Postfachclusterserver vorhanden.

Um dieses Problem zu beheben, versuchen Sie nicht, einen weiteren Postfachclusterserver für die fortlaufende Clusterreplikation in diesem Cluster zu erstellen.

Weitere Informationen zum Installieren des Postfachclusterservers in einer CCR-Umgebung finden Sie in der Exchange Server 2007-Produktdokumentation unter "Installieren der Serverfunktion "Mailbox" auf dem aktiven Knoten" (http://go.microsoft.com/fwlink/?LinkId=86624).


Nur die Serverfunktion "Mailbox" kann auf einem Clusterserver installiert werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-07

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da der Versuch der Installation einer anderen Serverfunktion als Mailbox auf diesem Clusterserver fehlgeschlagen ist.

Microsoft Exchange 2007 unterstützt auf Servern, auf denen der Clusterdienst installiert ist, nur die Serverfunktion Mailbox.

Informationen zur Problembehandlung finden Sie unter "High Availability for Exchange 2007" im Exchange Server 2007 Operations Guide (http://go.microsoft.com/fwlink/?LinkId=68190).


Organisation im gemischten Modus
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-05-15

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da die vorhandene Microsoft Exchange-Organisation nicht im einheitlichen Modus ist.

Für das Microsoft Exchange-Setup ist erforderlich, dass die vorhandene Microsoft Exchange-Organisation im einheitlichen Modus ist.

Um dieses Problem zu beheben, befolgen Sie diese Anweisungen, nachdem der letzte Server mit Exchange Server, Version 5.5, in der vorhandenen Organisation aktualisiert wurde oder bevor der letzte Server mit Exchange Server, Version 5.5, außer Funktion gesetzt wird. Führen Sie anschließend das Exchange 2007-Setup erneut aus.

Hinweis:
Nach einem Wechsel in den einheitlichen Modus kann kein Wechsel zurück in den gemischten Modus erfolgen.
So wechseln Sie in den einheitlichen Modus

  1. Starten Sie Exchange-System-Manager: Klicken Sie auf Start, zeigen Sie auf Alle Programme, zeigen Sie auf Microsoft Exchange, und klicken Sie dann auf System-Manager.

  2. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf die Organisation, die in den einheitlichen Modus wechseln soll, und klicken Sie anschließend auf Eigenschaften.

  3. Klicken Sie im Fenster Eigenschaften für <Organisationsname> unter Betriebsmodus ändern auf Modus ändern.

  4. Klicken Sie im Dialogfeld mit der Warnmeldung auf Ja, wenn Sie dauerhaft in den einheitlichen Modus wechseln möchten. Klicken Sie auf Übernehmen, um den neuen Exchange-Modus zu übernehmen.

Um den einheitlichen Exchange-Modus vollständig nutzen zu können, müssen Sie den Microsoft Exchange-Informationsspeicherdienst auf allen Servern mit Exchange in der Organisation neu starten. Es ist nicht erforderlich, alle Instanzen des Microsoft Exchange-Informationsspeicherdienstes gleichzeitig neu zu starten. Sie müssen den Dienst jedoch auf jedem Server neu starten, damit die Server die Vorteile des einheitlichen Exchange-Modus nutzen können. Starten Sie den Dienst auf den Servern erneut, nachdem der Wechsel in den einheitlichen Modus auf den lokalen Microsoft Windows®-Domänencontroller repliziert wurde.

So starten Sie den Microsoft Exchange-Informationsspeicherdienst neu

  1. Klicken Sie auf Start, dann auf Ausführen, und geben Sie services.msc ein. Klicken Sie anschließend auf OK.

  2. Suchen Sie im Bereich Dienste (Lokal) die Option Microsoft Exchange-Informationsspeicherdienst.

  3. Klicken Sie mit der rechten Maustaste auf den Dienst, und klicken Sie dann auf Neu starten.

Weitere Informationen zum Konvertieren vom gemischten Modus in den einheitlichen Modus finden Sie im Microsoft Knowledge Base-Artikel 32779 zum Konvertieren vom gemischten Modus in den einheitlichen Modus in Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779).


Der primäre DNS-Server kann nicht kontaktiert werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-05

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, weil keine Verbindung mit dem primären DNS-Server (Domain Name System) hergestellt werden kann.

Das Exchange 2007-Setup fordert an, dass der lokale Computer mit der autorisierenden DNS-Datenbank der Domäne kommuniziert.

Microsoft Exchange benötigt DNS zum Auflösen der IP-Adresse des nächsten internen oder externen Zielservers.

Die Kommunikation mit dem primären DNS-Server kann aus folgenden Gründen fehlschlagen:

  • Die lokale TCP/IP-Konfiguration zeigt nicht auf den ordnungsgemäßen DNS-Server.

  • Der DNS-Server ist wegen eines Netzwerkfehlers oder aus anderen Gründen nicht verfügbar oder antwortet nicht.

So beheben Sie dieses Problem:

  • Vergewissern Sie sich, dass die lokale TCP/IP-Konfiguration auf den ordnungsgemäßen DNS-Server zeigt.

So überprüfen Sie die lokale TCP/IP-Konfiguration

  1. Überprüfen Sie die lokale TCP/IP-Konfiguration:

    Weitere Informationen finden Sie unter "Configure TCP/IP to use DNS" (http://go.microsoft.com/fwlink/?LinkId=68094).
  • Überprüfen Sie, ob der DNS-Server ausgeführt wird und kontaktiert werden kann.

So überprüfen Sie, ob der DNS-Server ausgeführt wird und kontaktiert werden kann

  1. Überprüfen Sie, ob der DNS-Server ausgeführt wird, indem Sie die folgenden Schritte ausführen:

    • Untersuchen Sie den Status des DNS-Servers mithilfe des DNS-Administrationsprogramms auf dem DNS-Server.

    • Starten Sie den DNS-Server neu.

      Weitere Informationen finden Sie unter "Start, stop, pause, or restart a DNS server" (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Untersuchen Sie die Reaktionsbereitschaft des DNS-Servers mithilfe des Befehls nslookup.

      Weitere Informationen finden Sie in den Anweisungen unter "Verify DNS server responsiveness using the nslookup command" (http://go.microsoft.com/fwlink/?LinkId=63000).


Laufwerksangabe für Öffentliche Ordner-Datenbank fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-05-15

Das Setup zur Wiederherstellung nach Datenverlust von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da dieses Setup nicht auf die Laufwerksangabe der Öffentlichen Ordner-Datenbank zugreifen kann, die bei der vorherigen Installation dieses Serverprogramms verwendet wurde.

Das Setup zur Wiederherstellung nach Datenverlust von Microsoft Exchange erfordert, dass die zuvor für diesen Server verwendeten Laufwerksangaben für die Öffentliche Ordner-Datenbank während der Wiederherstellung verfügbar sind.

Konfigurieren Sie zum Beheben dieses Problems die Laufwerke so, dass diese der ursprünglichen logischen Laufwerkskonfiguration entsprechen, und führen Sie das Microsoft Exchange-Setup zur Wiederherstellung nach Datenverlust erneut aus.

Zuweisen oder Ändern eines Laufwerksbuchstaben

  1. Öffnen Sie Computerverwaltung (Lokal).

  2. Klicken Sie in der Konsolenstruktur auf Computerverwaltung (Lokal), dann auf Datenspeicher und anschließend auf Datenträgerverwaltung.

  3. Klicken Sie mit der rechten Maustaste auf eine Partition, ein logisches Laufwerk oder ein Volume, und klicken Sie dann auf Laufwerkbuchstaben und -pfade ändern.

  4. Führen Sie eines der folgenden Verfahren aus:

    • Um einen Laufwerksbuchstaben zuzuweisen, klicken Sie auf Hinzufügen, dann auf den gewünschten Laufwerksbuchstaben und schließlich auf OK.

    • Um einen Laufwerksbuchstaben zu ändern, klicken Sie auf Ändern, dann auf den gewünschten Laufwerksbuchstaben und schließlich auf OK.

Weitere Informationen zum Zuweisen von Laufwerksbuchstaben finden Sie in "Assign, change, or remove a drive letter" (http://go.microsoft.com/fwlink/?LinkId=66764).


Auf die Registrierung auf einem Clusterknoten konnte remote nicht zugegriffen werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-04-13

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil auf die Registrierung auf einem Clusterknoten nicht remote zugegriffen werden konnte.

Für das Setup von Exchange 2007 ist ein Zugriff auf die Registrierung aller Knoten im Cluster erforderlich, um verschiedene Einstellungen abzurufen.

Um dieses Problem zu beheben, führen Sie folgende Schritte aus:

  • Vergewissern Sie sich, dass der Remoteregistrierungsdienst auf allen Knoten im Cluster ausgeführt wird.

  • Stellen Sie sicher, dass Datei- und Druckerfreigabe für Microsoft-Netzwerke für den Netzwerkadapter aktiviert ist, der in der Bindungsreihenfolge an erster Stelle aufgeführt wird.

  • Vergewissern Sie sich, dass die Werte für die folgenden Registrierungsschlüssel auf jedem Knoten im Cluster gleich und für die relevante Grupperichtlinie gültig sind:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Lanmanworkstation\parameters\RequireSecuritySignature

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Rdr\Parameters\EnableSecuritySignature

Weitere Informationen zur Problembehandlung der Registrierungsverbindung finden Sie im Abschnitt zur Problembehandlung der Registrierungsverbindung unter "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" (http://go.microsoft.com/fwlink/?linkid=56285).


Entfernen des Edge-Abonnements vor der Deinstallation der Serverfunktion
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-21

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, da ein Fehler beim Deinstallieren der Serverfunktion Edge-Transport oder Hub-Transport aufgetreten ist, weil die Serverfunktion ein Edge-Abonnement besitzt.

Sie abonnieren einen Active Directory-Standort für den Edge-Transport-Server, um den Edge-Transport-Server einer Exchange-Organisation zuzuordnen. Ein abonnierter Edge-Transport-Server wird mit einem Active Directory-Standortattribut gestempelt. Durch diese Zuordnung können Sie z. B. das Edge-Abonnement als einen Quellserver für Sendeconnectors konfigurieren, die in der Exchange-Organisation erstellt werden. Die Hub-Transport-Server in der Exchange-Organisation verwenden einen impliziten, organisationsinternen Sendeconnector, um E-Mail-Nachrichten über den abonnierten Edge-Transport-Server in das Internet weiterzuleiten. Die Active Directory-Standortzuordnung ermöglicht den Hub-Transport-Servern, den Edge-Transport-Server für Routingzwecke zu ermitteln.

Das Setup von Exchange 2007 erfordert, dass alle Edge-Abonnements für die Zielserverfunktion Edge-Transport oder die letzte Serverfunktion Hub-Transport an einem Standort entfernt werden, bevor die Deinstallation der Serverfunktion Edge-Transport oder Hub-Transport durchgeführt werden kann.

Um diesen Fehler zu beheben, verwenden Sie das Cmdlet Get-EdgeSubscription, um Informationen zu den Edge-Abonnements abzurufen, sowie das Cmdlet Remove-EdgeSubscription, um das Edge-Abonnement vom Zielserver zu entfernen. Führen Sie anschließend das Exchange 2007-Setup erneut aus.

So identifizieren und entfernen Sie das Edge-Abonnement

  1. Befolgen Sie die Anweisungen im Thema zum Cmdlet Get-EdgeSubscription (http://go.microsoft.com/fwlink/?LinkId=86320), um Edge-Abonnements für den Zielserver zu identifizieren.

  2. Befolgen Sie die Anweisungen im Thema zum Cmdlet Remove-EdgeSubscription (http://go.microsoft.com/fwlink/?LinkId=86321), um das Edge-Abonnement vom Zielserver zu entfernen.


Schema-FSMO ist nicht Windows Server 2003 Service Pack (SP1) oder höher
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-05

Microsoft® Exchange Server Analyzer Tool ermittelt in der Gesamtstruktur des Active Directory®-Verzeichnisdienstes die Version des Serverbetriebssystems, das auf dem Active Directory-Domänencontroller mit dem Schemamaster ausgeführt wird. Wenn Exchange Server Analyzer feststellt, dass auf dem Domänencontroller mit dem Active Directory-Schemamaster (auch Flexible Single Master Operations/FSMO genannt), nicht Microsoft Windows Server™ 2003 Service Pack 1 (SP1) oder höher ausgeführt wird, wird ein Fehler angezeigt.

Der Fehler weist darauf hin, dass für die Installation von Microsoft Exchange Server 2007 Windows Server 2003 SP1 oder höher erforderlich ist. Windows Server 2003 SP1 oder höher ist erforderlich, damit die neuen Berechtigungsstrukturen von Exchange 2007 unterstützt werden.

Wenn auf dem Domänencontroller mit dem Active Directory-Schemamaster nicht Windows Server 2003 SP1 oder höher ausgeführt wird, schlägt das Setup von Exchange 2007 fehl.

Bei dieser Nachricht handelt es sich um eine Prüfung der Voraussetzungen vor der Bereitstellung von Exchange 2007. Es wird empfohlen, dass Windows Server 2003 SP1 oder höher auf dem gesamtstrukturweiten Active Directory-Domänencontroller mit dem Schemamaster ausgeführt wird, wenn Exchange 2007 installiert werden soll.


Der Schemamaster wird unter Windows 2000 Server ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-01-08

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da auf dem Domänencontroller, welcher der Schemamasterrolle (auch Flexible Single Master Operations/FSMO genannt) des Verzeichnisdiensts Active Directory® zugewiesen ist, Microsoft Windows 2000 Server ausgeführt wird.

Für das Exchange 2007-Setup ist erforderlich, dass auf dem Domänencontroller, der als Schemamaster-Domänencontroller dient, Windows Server™ 2003 Service Pack 1 (SP1) oder höher ausgeführt wird.

Der Schemamaster-Domänencontroller steuert alle Aktualisierungen und Änderungen des Active Directory-Schemas.

Um dieses Problem zu beheben, aktualisieren oder überführen Sie den Schemamaster-Domänencontroller auf Windows Server 2003 SP1 oder höher und führen das Microsoft Exchange-Setup erneut aus.

Weitere Informationen finden Sie im Microsoft Knowledge Base-Artikel 325379, "Aktualisieren von Windows 2000-Domänencontrollern auf Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325379).

Weitere Informationen zur Übertragung der Infrastrukturmasterrolle von einem Domänencontroller auf einen anderen Domänencontroller finden Sie in den Microsoft Knowledge Base-Artikeln:

  • Weitere Informationen zu Microsoft Windows Server™ 2003 finden Sie unter „Anzeigen und Übertragen von FSMO-Funktionen in Windows Server 2003" http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801).

  • Für Microsoft Windows 2000 Server: 255690 „SO WIRD'S GEMACHT: Einsehen und Übertragen von FSMO-Funktionen in der GUI" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Auf dem Schemamaster wird nicht Windows Server 2003 Service Pack 1 oder höher ausgeführt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-27

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil auf dem Domänencontroller, dem die Schemamasterrolle (auch Flexible Single Master Operations/FSMO genannt) des Active Directory-Verzeichnisdiensts zugewiesen ist, nicht Microsoft Windows Server 2003 Service Pack 1 (SP1) oder höher ausgeführt wird.

Für das Exchange 2007-Setup ist erforderlich, dass auf dem Domänencontroller, der als Schemamaster-Domänencontroller dient, Windows Server 2003 SP1 oder höher ausgeführt wird.

Der Schemamaster-Domänencontroller steuert alle Aktualisierungen und Änderungen des Active Directory-Schemas.

Um dieses Problem zu beheben, führen Sie einen oder mehrere der folgenden Schritte aus:

  • Aktualisieren Sie den Schemamaster-Domänencontroller auf Windows Server 2003 SP1 oder höher und führen das Microsoft Exchange-Setup dann erneut aus.

  • Wenn ein Schemamaster-Domänencontroller vorhanden ist, der Microsoft Windows Server 2003 Service Pack 1 (SP1) oder eine höhere Version in der Exchange-Organisation ausführt, führen Sie das Exchange 2007-Setup so aus, dass der Parameter /domaincontroller auf diesen Schemamaster-Domänencontroller verweist:

    [/DomainController oder /dc <FQDN_des_Domänencontrollers>]

    Verwenden Sie den Parameter /DomainController, um den Domänencontroller anzugeben, der für das Lesen aus und Schreiben in Active Directory während der Installation verwendet werden soll. Sie können das NetBIOS-Format oder den vollqualifizierten Domänennamen verwenden.

Das neueste Service Pack für Windows Server 2003 Server finden Sie im Windows Server TechCenter (http://go.microsoft.com/fwlink/?LinkId=45315).

Weitere Informationen zu den Installationsparametern von Exchange Server 2007 finden Sie unter "Installieren von Exchange 2007 im unbeaufsichtigten Modus" (http://go.microsoft.com/fwlink/?LinkId=86476) in der Exchange Server 2007-Produktdokumentation.


Setup Cannot Install Exchange to a Read-Only Domain Controller
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-07-23

Das Setup von Microsoft Exchange Server 2007 kann die Installation nicht fortsetzen, weil der Zielcomputer ein schreibgeschützter Domänencontroller (Read-Only Domain Controller, RODC) ist.

Schreibgeschützte Domänencontroller sind ein Feature von Windows Server 2008 Active Directory. Der RODC ist eine der Domänencontroller-Installationsoptionen, die an Remotestandorten installiert werden kann, deren physikalische Sicherheit ggf. geringer ist.

Das Exchange-Setup erfordert Schreibzugriff auf dem Zielinstallationscomputer.

Um dieses Problem zu beheben, wählen Sie einen Zielinstallationscomputer aus, der nicht als RODC reserviert ist, und führen Sie Setup dann erneut aus.


Installationsfehler bei der Installation einer Serverfunktion
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-04-12

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil zuvor ein Installationsfehler beim Installieren einer Serverfunktion aufgetreten ist.

Das Setup von Exchange 2007 erfordert, dass nach einem Installationsfehler einer Serverfunktion diese erfolgreich erneut installiert oder aus dem Installationsvorgang entfernt wird, bevor andere Setuptasks fortgesetzt werden können.

Um dieses Problem zu beheben, installieren Sie die fehlerhaften Serverfunktionen neu, oder entfernen Sie die betreffenden Serverfunktionen.

So installieren Sie die fehlerhafte Serverfunktion über die Befehlszeile neu

  1. Öffnen Sie ein Eingabeaufforderungsfenster, und navigieren Sie dann zu den Installationsdateien.

  2. Führen Sie den folgenden Befehl aus:

    Code kopieren
    Setup /roles:<Failed Server Role>

    Wählen Sie mindestens eine der folgenden Funktionen in einer durch Kommas getrennten Liste aus:

    ClientAccess (oder CA oder C)

    EdgeTransport (oder ET oder E)

    Hinweis:
    Die Serverfunktion Edge-Transport darf nicht zusammen mit einer der anderen Serverfunktionen auf dem gleichen Computer vorhanden sein.
    Hinweis:
    Sie müssen die Serverfunktion Edge-Transport im Umkreisnetzwerk und außerhalb der Active Directory-Gesamtstruktur bereitstellen.

    HubTransport (oder HT oder H)

    Mailbox (oder MB oder M)

    UnifiedMessaging (oder UM oder U)

    ManagementTools (oder MT oder T)

    Hinweis:
    Wenn Sie ManagementTools angeben, installieren Sie die Exchange-Verwaltungskonsole, die Exchange-Cmdlets für die Exchange-Verwaltungsshell, die Exchange-Hilfedatei, das Tool Exchange Best Practices Analyzer und den Exchange-Problembehandlungs-Assistenten. Wenn Sie eine andere Serverfunktion installieren, werden die Verwaltungstools automatisch installiert.

    Um beispielsweise die Serverfunktion Hub-Transport einem vorhandenen Postfachserver hinzuzufügen, geben Sie Folgendes ein: %LocalExchangeInstallationDir%\bin\Setup.com /role:HubTransport /Mode:Install

Hinweis:
Wenn eine der Exchange Server 2007-Serverfunktionen zuvor erfolgreich installiert wurde, wird der Setup-Assistent im Wartungsmodus ausgeführt. Wenn keine der Exchange Server 2007-Serverfunktionen zuvor erfolgreich installiert wurde, fährt der Setup-Assistent dort fort, wo er beendet wurde.
So verwenden Sie den Setup-Assistenten für Exchange Server 2007 im Wartungsmodus, um die fehlerhafte Serverfunktion erneut zu installieren

  1. Melden Sie sich an dem Server an, auf dem eine Serverfunktion erneut installiert werden soll.

  2. Öffnen Sie die Systemsteuerung, und doppelklicken Sie dann auf Software.

  3. Wählen Sie auf der Seite Software die Option Microsoft Exchange Server aus, und klicken Sie dann auf Ändern.

  4. Klicken Sie im Setup-Assistenten für Exchange Server 2007 auf der Seite Exchange-Wartungsmodus auf Weiter.

  5. Aktivieren Sie auf der Seite Auswahl von Serverfunktionen die Kontrollkästchen für die Serverfunktionen, die installiert werden sollen, und klicken Sie dann auf Weiter.

    Hinweis:
    Die Serverfunktion Edge-Transport darf nicht zusammen mit einer der anderen Serverfunktionen auf dem gleichen Computer vorhanden sein.
    Hinweis:
    Sie müssen die Serverfunktion Edge-Transport im Umkreisnetzwerk und außerhalb der Active Directory-Gesamtstruktur bereitstellen.
    Hinweis:
    Wenn Sie ManagementTools auswählen, installieren Sie die Exchange-Verwaltungskonsole, die Exchange-Cmdlets für die Exchange-Verwaltungsshell und die Exchange-Hilfedatei. Die Verwaltungstools werden automatisch installiert, wenn Sie eine andere Serverfunktion installieren.

  6. Wenn Sie die Serverfunktion Hub-Transport ausgewählt haben und Exchange 2007 in einer Gesamtstruktur installieren, die eine vorhandene Exchange Server 2003- oder Exchange 2000 Server-Organisation aufweist, wählen Sie auf der Seite Nachrichtenübermittlungseinstellungen einen Bridgeheadserver in der vorhandenen Organisation aus, der Mitglied der Exchange 2003- oder Exchange 2000-Routinggruppe ist, für die Sie einen Routinggruppenconnector erstellen möchten.

  7. Zeigen Sie auf der Seite Abschließende Überprüfung den Status an, um zu ermitteln, ob die Voraussetzungsüberprüfungen für die Organisation und die Serverfunktion erfolgreich abgeschlossen wurden. Ist dies der Fall, klicken Sie auf Installieren, um Exchange 2007 zu installieren.

  8. Klicken Sie auf der Seite Fertigstellung auf Fertig stellen.
So verwenden Sie den Setup-Assistenten für Exchange Server 2007 zum erneuten Installieren der fehlerhaften Serverfunktion, wenn zuvor keine andere Serverfunktion erfolgreich installiert wurde

  1. Befolgen Sie die Anweisungen unter "Ausführen einer benutzerdefinierten Installation mithilfe des Exchange Server 2007-Setups" (http://go.microsoft.com/fwlink/?LinkId=86648) in der Exchange Server 2007-Produktdokumentation.
So entfernen Sie eine fehlerhafte Serverfunktion

  1. Befolgen Sie die Anweisungen unter "Entfernen von Exchange 2007-Serverfunktionen" (http://go.microsoft.com/fwlink/?LinkId=86649) in der Exchange Server 2007-Produktdokumentation.

Weitere Informationen

Weitere Informationen zum Installieren von Exchange 2007 im unbeaufsichtigten Modus finden Sie unter "Installieren von Exchange 2007 im unbeaufsichtigten Modus" (http://go.microsoft.com/fwlink/?LinkId=86476).


Dieser Server ist die Quelle für einen Routinggruppenconnector
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-27

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil beim Versuch, die Serverfunktion Hub-Transport zu entfernen, ein Fehler aufgetreten ist. Der lokale Computer ist die Quelle für mindestens einen Routinggruppenconnector in der Exchange-Organisation.

Ein Routinggruppenconnector wird zum Senden und Empfangen von Nachrichten zwischen Hub-Transport-Servern von Exchange 2007 und Bridgeheadservern mit Exchange Server 2003 oder Exchange 2000 Server verwendet. Wenn Exchange Server 2007 in einer vorhandenen Exchange Server 2003- und Exchange 2000 Server-Organisation installiert wird, wird der erforderliche Routinggruppenconnector während der Installation erstellt.

Das Setup von Exchange 2007 erfordert, dass alle Routinggruppenconnectors für eine Exchange-Organisation vom Hub-Transport-Servercomputer verschoben oder entfernt wurden, bevor die Serverfunktion gelöscht werden kann.

Um dieses Problem zu beheben, verschieben oder löschen Sie alle Routinggruppenconnectors vom lokalen Computer und führen das Setup erneut aus.

So verschieben Sie den Routinggruppenconnector mithilfe der Exchange-Verwaltungsshell

  1. Verwenden Sie das Cmdlet Set-RoutingGroupConnector, um die Eigenschaften eines vorhandenen Routinggruppenconnectors zwischen einer Microsoft Exchange Server 2007-Routinggruppe und einer Exchange Server 2003- oder Exchange 2000 Server-Routinggruppe zu ändern.

  2. In diesem Beispiel wird das Cmdlet Set-RoutingGroupConnector zum Ändern der Quelle eines Routinggruppenconnectors verwendet.
Code kopieren
Set-RoutingGroupConnector -Identity "[[Administrative Group Name\]Routing Group Name]\Routing Group Connector Name" -SourceTransportServers [FQDN of desired Hub Transport Server]
 So entfernen Sie den Routinggruppenconnector mithilfe der Exchange-Verwaltungsshell

  1. Verwenden Sie das Cmdlet Remove-RoutingGroupConnector, um einen Routinggruppenconnector zwischen einer Microsoft Exchange Server 2007-Routinggruppe und einer Exchange Server 2003- oder Exchange 2000 Server-Routinggruppe zu entfernen.

  2. Das folgende Beispiel zeigt, wie das Cmdlet Remove-RoutingGroupConnector zum Entfernen des angegebenen Routinggruppenconnectors verwendet wird.
Code kopieren
Remove-RoutingGroupConnector -Identity"[[Administrative Group Name\]Routing Group Name]\Routing Group Connector Name"

Weitere Informationen zum Ändern oder Entfernen von Routinggruppenconnectors finden Sie unter den folgenden Themen in der Exchange Server 2007-Produktdokumentation:

  • Set-RoutingGroupConnector (http://go.microsoft.com/fwlink/?LinkId=86659).

  • Remove-RoutingGroupConnector (http://go.microsoft.com/fwlink/?LinkId=86660).


Dieser Server ist die Quelle für einen Sendeconnector
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-27

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil beim Versuch, die Serverfunktion Hub-Transport zu entfernen, ein Fehler aufgetreten ist. Der lokale Computer ist die Quelle für mindestens einen Sendeconnector in der Exchange-Organisation.

Ein Sendeconnector stellt einen logischen Gateway dar, durch den ausgehende Nachrichten gesendet werden.

Das Setup von Exchange 2007 erfordert, dass alle Sendeconnectors für eine Exchange-Organisation vom Hub-Transport-Servercomputer verschoben oder entfernt wurden, bevor die Serverfunktion gelöscht werden kann.

Um dieses Problem zu beheben, verschieben oder löschen Sie alle Sendeconnectors vom lokalen Computer und führen das Setup erneut aus.

Weitere Informationen zum Ändern oder Entfernen von Sendeconnectors finden Sie unter den folgenden Themen in der Exchange Server 2007-Produktdokumentation:

  • "Entfernen eines Sendeconnectors" (http://go.microsoft.com/fwlink/?LinkId=86655).

  • "Ändern der Konfiguration eines Sendeconnectors" (http://go.microsoft.com/fwlink/?LinkId=86656).


Es wurde ein einfaches Exchange-Organisationsmodell erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-08-18

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um die Anzahl der Postfächer auf dem Server zu ermitteln. Jedes Postfachspeicherobjekt (Klasse msExchPrivateMDB) besitzt ein mehrwertiges Attribut homeMDBBL, das alle Postfächer im Speicher auflistet. Exchange Server Analyzer zählt diese Werte und erhält so die Gesamtzahl der Postfächer auf dem Server.

Außerdem fragt Exchange Server Analyzer Active Directory ab, um die Anzahl der Active Directory-Standorte zu ermitteln, die Computer mit Exchange Server enthalten. Darüber hinaus fragt Exchange Server Analyzer Active Directory ab, um die Anzahl der Server zu ermitteln, auf denen entweder Microsoft Exchange 2000 Server oder Microsoft Exchange Server 2003 ausgeführt wird. Schließlich fragt Exchange Server Analyzer das Microsoft WMI-Objekt (Windows® Management Instrumentation) Win32_Service ab, um zu ermitteln, ob der Windows-Clusterdienst vorhanden ist und ausgeführt wird.

Exchange Server Analyzer kategorisiert die Exchange-Organisation als einfache Exchange-Organisation, wenn die folgenden Bedingungen erfüllt sind:

  • Die Gesamtzahl der Postfächer in der Organisation beträgt weniger als 1.000.

  • Exchange-Server sind nur an einem einzigen Active Directory-Standort installiert.

  • Exchange 2000 oder Exchange 2003 wird auf weniger als 3 Computern ausgeführt.

  • Es wurden keine Exchange-Clusterserver bereitgestellt.

Von den vier definierten Organisationsmodellen für Microsoft Exchange Server 2007 stellt die einfache Exchange-Organisation die Basistopologie dar, in der Exchange 2007 bereitgestellt werden kann. Die einfache Exchange-Organisation weist eine der beiden folgenden Konfigurationen auf:

  • Ein einzelner Exchange-Server, der sämtliche Exchange-Dienste zur Verfügung stellt und alle Exchange-Daten für die gesamte Organisation speichert.

  • Mehrere Exchange-Server in einer Topologie, die redundante Verzeichnisserver und einen Edge-Transport-Server in einem Umkreisnetzwerk beinhaltet.

So führen Sie den Übergang einer einfachen Exchange-Organisation zu Exchange 2007 durch

  1. Rufen Sie die Onlinedokumentation zu Exchange 2007 auf (http://go.microsoft.com/fwlink/?LinkId=69434).

  2. Erweitern Sie zunächst "Planung und Architektur" und dann "Planen der Bereitstellung", und klicken Sie dann auf "Planen für eine einfache Exchange-Organisation".


SMTP (Simple Mail Transport Protocol) ist gegenwärtig installiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-01-22

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da der SMTP-Dienst (Simple Mail Transfer Protocol) von Microsoft Windows Server™ 2003 auf diesem Computer installiert ist.

Für das Microsoft Exchange-Setup ist erforderlich, dass der SMTP-Dienst nicht auf Servern installiert wird, die für Exchange 2007 verwendet werden.

Um dieses Problem zu beheben, deinstallieren Sie den SMTP-Dienst und führen das Microsoft Exchange-Setup erneut aus.

So deinstallieren Sie den SMTP-Dienst über die Option "Software" in der Systemsteuerung

  1. Klicken Sie im Menü Start auf Systemsteuerung.

  2. Doppelklicken Sie auf Software.

  3. Klicken Sie auf Windows-Komponenten hinzufügen/entfernen.

  4. Aktivieren Sie in der Liste Komponenten das Kontrollkästchen Anwendungsserver, und klicken Sie dann auf Details.

  5. Wählen Sie Internetinformationsdienste-Manager aus, und klicken Sie dann auf Details.

  6. Wählen Sie SMTP-Dienst aus, und deaktivieren Sie das Kontrollkästchen.

  7. Klicken Sie zum zweimal auf OK, um zur Liste Komponenten zurückzukehren, und klicken Sie dann auf Weiter.

  8. Klicken Sie auf Fertig stellen, wenn der SMTP-Dienst deinstalliert ist.


Der Standort kann keine Server mit Exchange 2007 unterstützen
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-08-11

Microsoft® Exchange Server Analyzer zeigt diese Warnmeldung an, da die Gesamtstruktur des Active Directory-Verzeichnisdienstes Standorte enthält, in denen nicht mindestens ein globaler Katalogserver enthalten ist, auf dem Microsoft Windows Server™ 2003 Service Pack 1 (SP1) oder höher ausgeführt wird.

Für das Microsoft Exchange Server 2007-Setup ist erforderlich, dass jeder Active Directory-Standort, der einen Server enthält, auf dem Exchange 2007 ausführt wird, mindestens einen globalen Katalogserver enthalten muss, auf dem Windows Server 2003 SP1 oder eine höhere Version ausgeführt wird.

Um dieses Problem zu beheben, aktualisieren Sie mindestens einen globalen Katalogserver an jedem Active Directory-Standort auf Windows Server 2003 SP1 oder höher.

Weitere Informationen zum Aktualisieren auf Windows Server 2003 finden Sie im Microsoft Knowledge Base-Artikel 810613, "Möglichkeiten der Aktualisierung auf Windows Server 2003 oder Windows Small Business Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810613).

Das neueste Service Pack für Windows Server 2003 finden Sie im Windows Server TechCenter (http://go.microsoft.com/fwlink/?LinkId=45315).


Es wurde ein standardmäßiges Exchange-Organisationsmodell erkannt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-08-10

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst ab, um Folgendes zu ermitteln:

  • Die Anzahl der Postfächer in der Organisation.

  • Die Anzahl der Routinggruppen in der Organisation.

  • Die Anzahl der Active Directory-Standorte in der Organisation.

  • Die Anzahl der Active Directory-Gesamtstrukturen in der Organisation.

  • Ob Microsoft Identity Integration Server (MIIS) installiert ist.

Die Anzahl der jeweiligen Elemente bestimmt, ob es sich bei dem Exchange-Organisationsmodell um ein einfaches, großes, komplexes oder ein Standardmodell handelt. Eine Organisation, die nicht als einfach, groß oder komplex klassifiziert ist, wird automatisch als Exchange-Standardorganisation klassifiziert.

Von den vier definierten Organisationsmodellen für Microsoft Exchange Server 2007 stellt die Exchange-Standardorganisation die gängigste Topologie dar, in der Exchange 2007 bereitgestellt wird. Wenn der Messagingdienst über die Ressourcengrenzen eines einzelnen Computers hinauswachsen muss, führt die Aufteilung der Exchange 2007-Dienste auf mehrere Computer zum nächsten Topologiebereich, der Exchange-Standardorganisation. Die Exchange-Standardorganisation baut auf der einfachen Exchange-Organisation auf, indem mehrere Computer mit Exchange bereitgestellt werden.

So führen Sie den Übergang einer Exchange-Standardorganisation zu Exchange 2007 durch

  1. Rufen Sie die Onlinedokumentation zu Exchange 2007 auf (http://go.microsoft.com/fwlink/?LinkId=69434).

  2. Erweitern Sie zunächst "Planung und Architektur" und dann "Planen der Bereitstellung", und klicken Sie dann auf "Planen einer Exchange-Standardorganisation".


Für ein Cluster werden statische IP-Adressen empfohlen
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-05

Das Setup von Microsoft® Exchange Server 2007 zeigt diese Warnung an, da eine oder mehrere Netzwerkschnittstellen für die Verwendung von DHCP (Dynamic Host Configuration Protocol) konfiguriert sind.

Es hat sich bewährt, eine statische IP-Adresse für Netzwerkschnittstellen zu verwenden, die Clientverbindungen und Heartbeat-Links in einem Microsoft Windows-Servercluster verwalten. Der Einsatz einer dynamischen Konfiguration über DHCP wird nicht empfohlen, da der Clusterbetrieb gestört werden kann, wenn die Erneuerung des DHCP-Lease fehlschlägt.

Um dieses Problem zu beheben, müssen Sie die Netzwerkschnittstellen für die Verwaltung von Clientverbindungen oder Heartbeat-Links für die Verwendung einer statischen IP-Adresse konfiguriert werden.

So konfigurieren Sie eine statische IP-Adresse für eine Netzwerkverbindung

  1. Klicken Sie im Menü Start auf Einstellungen und dann auf Netzwerkeinstellungen.

  2. Klicken Sie mit der rechten Maustaste auf die zu konfigurierende Verbindung, und klicken Sie dann auf Eigenschaften.

  3. Klicken Sie auf der Registerkarte Allgemein unter Diese Verbindung verwendet folgende Elemente auf Internetprotokoll (TCP/IP) und dann auf Eigenschaften.

  4. Klicken Sie auf Folgende IP-Adresse verwenden, und geben Sie in IP-Adresse die IP-Adresse ein.

  5. Klicken Sie zum Fertigstellen zweimal auf OK.

Weitere Informationen zur optimalen Netzwerkkonfiguration für Windows-Servercluster finden Sie in "Server Clusters: Network Configuration Best Practices for Windows 2000 and Windows Server 2003" (http://go.microsoft.com/fwlink/?linkid=34304).

Weitere Informationen zur richtigen Cluster-Heartbeat-Konfiguration finden Sie im Microsoft Knowledge Base-Artikel 258750, "Empfehlungen für die private Heartbeat-Konfiguration auf einem Clusterserver" unterhttp://support.microsoft.com/kb/258750/de.


Der Speicherpfad für einen Einzelkopiecluster muss ein gruppierter Datenträger sein
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-27

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil der Speicherpfad für einen Einzelkopiecluster ein gruppierter Datenträger sein muss.

In Exchange Server 2007 ist der Einzelkopiecluster (Single Copy Cluster, SCC) eine Clusterlösung, die eine einzelne Kopie einer Speichergruppe für die freigegebene Speicherung zwischen den Knoten im Cluster verwendet.

Um dieses Problem zu beheben, geben Sie ein gruppiertes Laufwerk für den Datenpfad an, und führen Sie anschließend Exchange 2007-Setup erneut aus.

Weitere Informationen zu Einzelkopieclustern finden Sie unter "Installieren eines Einzelkopieclusters" (http://go.microsoft.com/fwlink/?LinkId=76162) in der Exchange Server 2007-Produktdokumentation.


Das SMTP-Addressierungsformat wird nicht unterstützt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-27

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, weil die angegebene Empfängerrichtlinie ein nicht unterstütztes SMTP-Adressformat (Simple Mail Transfer Protocol) verwendet.

Das Setup von Exchange 2007 erfordert, dass alle SMTP-Adressen, die für E-Mail-Adressenrichtlinien verwendet werden, keine IP-Adressliterale enthalten. Beispiel: Benutzer@[10.10.1.1].

Um dieses Problem zu beheben, ändern Sie den Wert der SMTP-Adresse in der Empfängerrichtlinie so, dass sie keine IP-Adressliterale enthält. Ersetzen Sie eckige Klammern ([]) und Ziffern (10.10.1.1) der IP-Adressliterale durch Angaben im DNS-Namensformat (Domain Name System). Beispiel: Benutzer@contoso.com. Führen Sie anschließend das Exchange 2007-Setup erneut aus.

Weitere Informationen zum Verwalten von Empfängerrichtlinien in Exchange Server 2007 finden Sie unter "Verwalten von E-Mail-Adressenrichtlinien" (http://go.microsoft.com/fwlink/?LinkId=86653).


Es wurde eine SMTP-Standortverknüpfung gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-12-07

Microsoft® Exchange Server Analyzer zeigt diese Warnmeldung an, wenn im Active Directory®-Verzeichnisdienst SMTP-basierte (Simple Mail Transfer Protocol) Standortverknüpfungen gefunden werden.

In Microsoft Exchange Server 2007 werden beim Routing durch SMTP-Standortverknüpfungen verbundene Active Directory-Standorte ignoriert. Wenn Exchange 2007 an Standorten installiert ist, die nur durch eine SMTP-Standortverknüpfung verbunden sind, treten Routingfehler auf.

Um dieses Problem zu beheben, ersetzen Sie die SMTP-Standortverknüpfungen durch IP-basierte Standortverknüpfungen.

Weitere Informationen zu Active Directory-IP-Standortlinks finden Sie unter "Planen der Verwendung von Active Directory-Standorten für das E-Mail-Routing" (http://go.microsoft.com/fwlink/?LinkId=71803).


Laufwerksangabe für Speichergruppe fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-05-15

Das Setup zur Wiederherstellung nach Datenverlust von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da dieses Setup nicht auf die Laufwerksangabe der Speichergruppe zugreifen kann, die bei der vorherigen Installation dieses Serverprogramms verwendet wurde.

Das Setup zur Wiederherstellung nach Datenverlust von Microsoft Exchange erfordert, dass die zuvor für diesen Server verwendeten Laufwerksangaben für die Speichergruppe während der Wiederherstellung verfügbar sind.

Konfigurieren Sie zum Beheben dieses Problems die Laufwerke so, dass diese der ursprünglichen logischen Laufwerkskonfiguration entsprechen, und führen Sie das Microsoft Exchange-Setup zur Wiederherstellung nach Datenverlust erneut aus.

Zuweisen oder Ändern eines Laufwerksbuchstaben

  1. Öffnen Sie Computerverwaltung (Lokal).

  2. Klicken Sie in der Konsolenstruktur auf Computerverwaltung (Lokal), dann auf Datenspeicher und anschließend auf Datenträgerverwaltung.

  3. Klicken Sie mit der rechten Maustaste auf eine Partition, ein logisches Laufwerk oder ein Volume, und klicken Sie dann auf Laufwerkbuchstaben und -pfade ändern.

  4. Führen Sie eines der folgenden Verfahren aus:

    • Um einen Laufwerksbuchstaben zuzuweisen, klicken Sie auf Hinzufügen, dann auf den gewünschten Laufwerksbuchstaben und schließlich auf OK.

    • Um einen Laufwerksbuchstaben zu ändern, klicken Sie auf Ändern, dann auf den gewünschten Laufwerksbuchstaben und schließlich auf OK.

Weitere Informationen zum Zuweisen von Laufwerksbuchstaben finden Sie in "Assign, change, or remove a drive letter" (http://go.microsoft.com/fwlink/?LinkId=66764).


Zielinstallationspfad-Konflikt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-27

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil der Zielpfad für die Exchange-Binärdateien nicht dem vorhandenen Exchange-Installationspfad auf anderen Clusterknoten übereinstimmt.

Exchange Server 2007 erfordert, dass Knoten des gleichen Clusters konsistente Zielinstallationspfade für die Exchange-Binärdateien aufweisen.

Um dieses Problem zu beheben, verwenden Sie einen Zielinstallationspfad für die Exchange-Binärdateien, der für alle Knoten des Clusters konsistent ist.

Weitere Informationen zu hochverfügbaren Exchange Server 2007-Installationen finden Sie in der Exchange Server 2007-Produktdokumentation unter "Hochverfügbarkeit" (http://go.microsoft.com/fwlink/?linkid=68190).


Zielpfad ist komprimiert
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-06

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da der Zielpfad für die Microsoft Exchange-Installation komprimiert ist.

Für das Microsoft Exchange-Setup ist erforderlich, dass der erste Ordner im Zielpfad der Installation nicht komprimiert ist. Der erste Ordner im Zielpfad der Installation ist standardmäßig C:\Programme.

Um dieses Problem zu beheben, deaktivieren Sie die Komprimierung des ersten Ordners und führen das Exchange 2007-Setup erneut aus.

So deaktivieren Sie die Komprimierung des Zielpfads

  1. Klicken Sie in Arbeitsplatz oder Windows Explorer mit der rechten Maustaste auf den zu dekomprimierenden Ordner.

  2. Klicken Sie auf Eigenschaften, um das Dialogfeld Eigenschaften anzuzeigen.

  3. Klicken Sie auf der Registerkarte Allgemein auf Erweitert.

  4. Deaktivieren Sie im Dialogfeld Erweiterte Attribute das Kontrollkästchen Inhalt komprimieren, um Speicherplatz zu sparen, und klicken Sie dann auf OK.

  5. Klicken Sie im Dialogfeld Eigenschaften auf OK.

  6. Wählen Sie nach Änderung des Komprimierungsstatus des Ordners im Dialogfeld Änderungen der Attribute bestätigen die Option Änderungen für diesen Ordner, Unterordner und Dateien übernehmen .

  7. Klicken Sie auf OK, wenn Sie fertig sind.


Für ein Cluster werden zwei oder mehr Netzwerkschnittstellen empfohlen
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-05

Das Setup von Microsoft® Exchange Server 2007 zeigt diese Warnung an, da die aktuelle Microsoft Windows-Clusterumgebung nur eine definierte Netzwerkschnittstelle aufweist.

Bewährt hat sich die Implementierung mindestens einer Netzwerkschnittstelle für das öffentliche Netzwerk (Clientverbindung) und einer Netzwerkschnittstelle für das private Netzwerk (Verwaltung/Heartbeat), um eine einzelne Fehlerstelle zu vermeiden.

Implementieren Sie zur Vermeidung dieser Warnung mindestens eine zusätzliche Netzwerkschnittstelle für das Microsoft Windows-Cluster.

Weitere Informationen zur optimalen Netzwerkkonfiguration für Windows-Servercluster finden Sie in "Server Clusters: Network Configuration Best Practices for Windows 2000 and Windows Server 2003" unter http://go.microsoft.com/fwlink/?linkid=34304.


Mit dem Remoteregistrierungsdienst kann keine Verbindung hergestellt werden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-01-23

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da auf dem lokalen Computer nicht auf die Registrierung zugegriffen werden kann.

Für das Setup von Exchange 2007 ist ein Zugriff auf die lokale Registrierung erforderlich, um verschiedene Einstellungen abrufen zu können.

Das Setup von Exchange versucht, DNS (Domain Name System) zum Abrufen des vollständig qualifizierten Domänennamens des lokalen Computers zu verwenden, um auf die Registrierung zuzugreifen.

Das Setup konnte entweder den vollständig qualifizierten Domänennamen aufgrund eines Netzwerkfehlers nicht aus DNS abrufen, oder es konnte nicht auf die Registrierung zugreifen.

Um dieses Problem zu beheben, überprüfen Sie, ob der Remoteregistrierungsdienst auf dem lokalen Computer ausgeführt wird und ob Datei- und Druckerfreigabe für die erste Netzwerkkarte in der Bindungsreihenfolge aktiviert ist. Führen Sie dann das Exchange-Setup erneut aus.

So überprüfen Sie, ob der Remoteregistrierungsdienst ausgeführt wird

  1. Klicken Sie auf Start, zeigen Sie auf Einstellungen, dann auf Systemsteuerung und auf Verwaltung, und doppelklicken Sie auf Dienste.

  2. Prüfen Sie, ob Remoteregistrierungsdienst den Status Gestartet hat.
So aktivieren Sie die Datei- und Druckerfreigabe für die erste Netzwerkkarte

  1. Klicken Sie auf Start, zeigen Sie auf Einstellungen, dann auf Systemsteuerung, doppelklicken Sie auf Netzwerkverbindungen und danach auf LAN-Verbindung.

  2. Prüfen Sie, ob das Kontrollkästchen Datei- und Druckerfreigabe für Microsoft-Netzwerke aktiviert ist.
Hinweis:
Wenn es sich um einen Clusterserver handelt, müssen Sie prüfen, ob der Remoteregistrierungsdienst auf allen Knoten des Clusters ausgeführt wird und Datei- und Druckerfreigabe für Microsoft-Netzwerke für die Netzwerkkarte aktiviert ist, die in der Bindungsreihenfolge zuerst angegeben ist.


Windows Media Audio Voice Codec-Update erforderlich
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-07-13

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, weil Microsoft Windows Media Audio Voice Codec nicht installiert ist oder eine aktuellere Version von Windows Media Audio Voice Codec zur Verfügung steht.

Um Exchange 2007 installieren zu können, muss die aktuellste Version von Windows Media Audio Voice Codec auf dem Server installiert sein. Windows Media Audio Voice Codec ist zur Unterstützung der Unified Messaging-Serverrolle von Exchange Server 2007 erforderlich.

Um dieses Problem zu beheben, installieren Sie die aktuelle Version von Windows Media Audio Voice Codec von http://go.microsoft.com/fwlink/?LinkId=67407. Führen Sie anschließend die Installation von Exchange 2007 erneut aus.


Windows Media Encoder-Update erforderlich
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-07-13

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, weil Microsoft Windows Media Encoder nicht installiert ist oder eine aktuellere Version von Windows Media Encoder zur Verfügung steht.

Um Exchange 2007 installieren zu können, muss die aktuellste Version von Windows Media Encoder auf dem Server installiert sein. Windows Media Encoder ist zur Unterstützung der Unified Messaging-Serverrolle von Exchange Server 2007 erforderlich.

Um dieses Problem zu beheben, installieren Sie die aktuelle Version von Windows Media Encoder von http://go.microsoft.com/fwlink/?LinkId=67406. Führen Sie anschließend die Installation von Exchange 2007 erneut aus.


Der WWW-Veröffentlichungsdienst ist deaktiviert oder fehlt
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-02-14

Das Setup von Microsoft® Exchange Server 2007 kann nicht fortgesetzt werden, da beim Versuch der Installation der Serverfunktion Mailbox bzw. ClientAccess festgestellt wurde, dass der WWW-Veröffentlichungsdienst entweder deaktiviert oder nicht auf diesem Server installiert ist.

Für das Setup von Exchange 2007 ist erforderlich, dass auf dem Computer, auf dem Sie Exchange installieren, der WWW-Veröffentlichungsdienst installiert ist und keinen deaktivierten Status hat.

Um dieses Problem zu beheben, vergewissern Sie sich, dass der WWW-Veröffentlichungsdienst auf dem lokalen Computer installiert und nicht deaktiviert ist, und führen anschließend das Microsoft Exchange-Setup erneut aus.

So überprüfen Sie, ob der WWW-Veröffentlichungsdienst installiert und nicht deaktiviert ist.

  1. Klicken Sie auf dem Desktop mit der rechten Maustaste auf Arbeitsplatz, und klicken Sie dann auf Verwalten.

  2. Erweitern Sie den Knoten Dienste und Anwendungen, und klicken Sie dann auf den Knoten Dienste.

  3. Suchen Sie im rechten Bereich WWW-Veröffentlichungsdienst.

    Wenn WWW-Veröffentlichungsdienst in der Liste der installierten Dienste nicht angezeigt wird, befolgen Sie die nachfolgenden Anweisungen, um den Dienst zu installieren.

  4. Wird WWW-Veröffentlichungsdienst angezeigt, verfügt aber über einen anderen Status als Gestartet, fahren Sie mit den nachfolgenden Schritten fort, um den Dienst zu starten.

  5. Klicken Sie mit der rechten Maustaste auf WWW-Veröffentlichungsdienst, und klicken Sie dann auf Eigenschaften.

  6. Stellen Sie sicher, dass Starttyp auf Automatisch und Dienststatus auf Gestartet festgelegt ist.

  7. Klicken Sie auf Übernehmen und dann auf OK.
So installieren Sie den WWW-Veröffentlichungsdienst

  1. Klicken Sie im Menü Start auf Einstellungen, Systemsteuerung, und klicken Sie dann auf Software.

  2. Klicken Sie auf Windows-Komponenten hinzufügen/entfernen.

  3. Aktivieren Sie in der Liste Komponenten das Kontrollkästchen Anwendungsserver, und klicken Sie dann auf Details.

  4. Wählen Sie Internetinformationsdienste-Manager aus, und klicken Sie dann auf Details.

  5. Wählen Sie WWW-Veröffentlichungsdienst aus, und aktivieren Sie das Kontrollkästchen.

  6. Klicken Sie zum zweimal auf OK, um zur Liste Komponenten zurückzukehren, und klicken Sie dann auf Weiter.

  7. Klicken Sie auf Fertig stellen, wenn der IIS-Dienst installiert ist.


Deinstallieren der Unified Messaging-Sprachpakete
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-16

Das Setup von Microsoft Exchange Server 2007 kann nicht fortgesetzt werden, weil bei der Aktualisierung der Serverfunktion UnifiedMessaging ein Fehler aufgetreten ist.

Das Setup von Exchange erfordert, dass alle Sprachpakete für die Serverfunktion UnifiedMessaging mit Ausnahme des US-Englischen Sprachpakets deinstalliert werden, bevor die Aktualisierung der Serverfunktion UnifiedMessaging fortgesetzt werden kann.

In Exchange 2007 enthaltene UM-Sprachpakete (Unified Messaging) enthalten voraufgezeichnete Ansagen und TTS-Konvertierungsunterstützung (Text-to-Speech) für die jeweilige Sprache.

Die Sprachpakete von Exchange 2007 ermöglichen Anrufern und Benutzern von Outlook Voice Access die Interaktion mit dem Unified Messaging-System in mehreren Sprachen.

Die vorhandenen Nicht-US-Englischen Sprachpakete müssen deinstalliert werden, damit neue Sprachpakete installiert werden können.

Um dieses Problem zu beheben, deinstallieren Sie alle Sprachpakete für die Serverfunktion UnifiedMessaging mit Ausnahme des US-Englischen Sprachpakets, und führen Sie das Exchange 2007-Setup anschließend erneut aus.

Weitere Informationen zum Deinstallieren der Sprachpakete für die Serverfunktion UnifiedMessaging finden Sie unter Entfernen eines Unified Messaging-Sprachpakets von einem Unified Messaging-Server in der Exchange 2007-Produktdokumentation.


Update erforderlich für Wiederherstellung nach Datenverlust
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2007-03-27

Die Wiederherstellung nach Datenverlust von Microsoft Exchange Server 2007 kann nicht fortfahren, weil eine höhere Version von Exchange Server 2007 ursprünglich zum Installieren von Exchange Server auf diesem Computer verwendet wurde.

Die Wiederherstellung nach Datenverlust von Microsoft Exchange erfordert, dass die Version von Exchange Server 2007, die zum Durchführen einer Wiederherstellung des Servercomputers mit Exchange Server verwendet wird, gleich der oder höher als die Version ist, die ursprünglich zum Installieren des Servercomputers mit Exchange Server verwendet wurde.

Um dieses Problem zu beheben, starten Sie die Wiederherstellung nach Datenverlust von Microsoft Exchange aus einer Version von Exchange Server 2007, die gleich der oder höher als die Version ist, die ursprünglich zum Installieren des Servercomputers mit Exchange Server verwendet wurde.


X400-Connector in Topologie gefunden
Microsoft Exchange Server Analyzer-Tools - Artikel > Exchange Server 2007-Bereitschaft >

Letztes Änderungsdatum des Themas: 2006-06-05

Microsoft® Exchange Server Analyzer fragt den Active Directory®-Verzeichnisdienst nach X.400-Connectors ab. Wenn Exchange Server Analyzer feststellt, dass X.400-Connectors in der Microsoft Exchange-Organisation vorhanden ist, wird eine Warnung angezeigt, die darauf hinweist, dass der X.400-Connector (ein Protokoll für die Übertragung von Nachrichten zwischen früheren Messagingssystemen), in Microsoft Exchange Server 2007 nicht unterstützt wird.

In Microsoft Exchange 2000 Server und Microsoft Exchange Server 2003 wurde SMTP (Simple Mail Transfer Protocol) als Standardtransportprotokoll verwendet. Obwohl X.400-Connectors in Exchange 2000 und Exchange 2003 unterstützt werden, werden sie in Exchange 2007 nicht unterstützt, da die Nutzung von X.400-Connectors im Laufe der Jahre zurückgegangen ist. Wenn weiterhin eine X.400-Unterstützung erforderlich ist, wird empfohlen, einen Exchange 2000- oder Exchange 2003-Server zu behalten. Ansonsten kann der X.400-Connector durch SMTP ersetzt werden.

Weitere Informationen zur X.400-Transportarchitektur in Exchange 2003 finden Sie unter "Exchange Server 2003 Message Routing" (http://go.microsoft.com/fwlink/?LinkId=65578).

Weitere Informationen zum Implementieren des X.400-Connectors in Exchange 2003 finden Sie unter "Implementing the X.400 Connector - Is It Worth Using with Exchange Server 2003?" (http://www.msexchange.org/tutorials/X400-Connector-Exchange-Server-2003.html).

Hinweis:
Die Informationen zur Website des Drittanbieters in diesem Thema werden bereitgestellt, um Ihnen das Auffinden der benötigten technischen Informationen zu ermöglichen. Die URLs können jederzeit ohne vorherige Ankündigung geändert werden.


Rechtliche Informationen

Letztes Änderungsdatum des Themas: 2007-04-06

Die in diesem Dokument enthaltenen Informationen, einschließlich URL und andere Verweise auf Internetwebseiten, können jederzeit ohne vorherige Ankündigung geändert werden. Soweit nichts anderes angegeben, sind die in den Beispielen verwendeten Firmen, Organisationen, Produkte, Domänennamen, E-Mail-Adressen, Logos, Personen, Orte und Ereignisse frei erfunden. Jede Ähnlichkeit mit bestehenden Firmen, Organisationen, Produkten, Domänennamen, E-Mail-Adressen, Logos, Personen, Orten oder Ereignissen ist rein zufällig. Die Benutzer/innen sind verpflichtet, sich an alle anwendbaren Urheberrechtsgesetze zu halten. Unabhängig von der Anwendbarkeit der entsprechenden Urheberrechtsgesetze darf ohne ausdrückliche schriftliche Erlaubnis der Microsoft Corporation kein Teil dieses Dokuments für irgendwelche Zwecke vervielfältigt oder in einem Datenempfangssystem gespeichert oder darin eingelesen werden, unabhängig davon, auf welche Art und Weise oder mit welchen Mitteln (elektronisch, mechanisch, durch Fotokopieren, Aufzeichnen, usw.) dies geschieht.

Es ist möglich, dass Microsoft Rechte an Patenten bzw. angemeldeten Patenten, an Marken, Urheberrechten oder sonstigem geistigen Eigentum besitzt, die sich auf den fachlichen Inhalt dieses Dokuments beziehen. Das Bereitstellen dieses Dokuments gibt Ihnen jedoch keinen Anspruch auf diese Patente, Marken, Urheberrechte oder auf sonstiges geistiges Eigentum, es sei denn, dies wird ausdrücklich in den schriftlichen Lizenzverträgen von Microsoft eingeräumt.

© 2004-2006 Microsoft Corporation. Alle Rechte vorbehalten.

Microsoft, Active Directory, ActiveSync, ActiveX, MSDN, Outlook, SharePoint, Visual C++, Win32, Windows, Windows NT, Windows Server und Windows Server System sind entweder eingetragene Marken oder Marken der Microsoft Corporation in den USA und/oder anderen Ländern.

In diesem Dokument genannte Produkt- und Firmennamen sind möglicherweise die Marken ihrer jeweiligen Eigentümer.